Titel

CX1000: Embedded-PC-System

First Steps to CX-Systems

version: 1.1
date: 2006-07-31


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger |
 | This symbol is intended to highlight risks for the life or health of personnel.

Warning |
 | This symbol is intended to highlight risks for equipment, materials or the environment.

Note |
 | This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Version | Changes
1.1 | pictures installation position updated
1.0 | revised version
0.2 | preliminarily version


Mechanical Assembly

Embedded PC: Fitting and wiring

Mechanical Assembly of the base module

The installation of the modules takes place in three steps:

1. The Sequence of the Modules

The CPU basic module with system interfaces, which are factory-installed on the left side, is extended with the power supply unit on the right and with the fieldbus connection (master or slave) left side if available. The mounting of an filedbus module is described on the next page.

2. Assembly with Other Modules

The attachment of the individual modules is done by simple plugging them together (FIG. 1). Care must be taken that the plug of the PC104 interface is not damaged.
When correctly assembled, no significant gap can be seen between the attached housings.

FIG. 1: Engaging of the Modules

3. Engaging on the top-hat rail

On the bottom of the modules, there is a white tension strap, which is connected with a latching mechanism. These tension straps must be pulled down before attaching to the mounting rail. This can be done with a slotted screwdriver and a small rotation. (FIG. 4). After engaging the module on the top-hat rail successfully (FIG. 5), the tension straps must be shifted into the starting position again (FIG. 6).

FIG. 4: Tension straps down FIG. 5: Engaging on the top-hat rail

FIG. 6: Tension straps back in starting position FIG.7: Tension straps not engaged / engaged

Note:

A locking mechanism prevents the individual housings from being pulled off again. More detailed information about disassembling the CX configuration from the top-hat rail can be found on the page decommissioning.

By lowering the front surfaces, which contain the interfaces, installation can easily be done in a standard terminal box of 120 mm height.

Installation position for CX1000:

Warning
The CPU module installed on a top-hat rail may be operated only in case of ambient temperatures up to 55°C. The orientation in which the device is fitted must be selected in such a way that cooling air can flow vertically through the ventilation holes. The images show the permitted (FIG. 8 and FIG.9) as well as a forbidden installation positions (FIG. 10).

Observe minimum clearance!

Mounting must provide a clearance of 30 mm both above and below a CX1000 device combination to ensure adequate ventilation of the CPU base module and the power supply unit.

FIG. 8: Allowable installation position

FIG. 9: Allowable installation position

FIG. 10: Unallowable installation position

Installation position for CX1020:

Warning
The CPU module installed on a top-hat rail may be operated only in case of ambient temperatures up to 55°C. The orientation in which the device is fitted must be selected in such a way that cooling air can flow vertically through the ventilation holes. The images show the permitted (FIG. 11) as well as two forbidden installation positions (FIG. 12)

Observe minimum clearance!

Mounting must provide a clearance of 30 mm both above and below a CX1020 device combination to ensure adequate ventilation of the CPU base module and the power supply unit.

FIG. 11: Allowable installation position

FIG. 12: Unallowable installation positions


Mechanical Assembly of the Fieldbus modules

Embedded PC: Fitting and wiring

Mechanical mounting of the Fieldbus modules

The mounting of the Fieldbus modules takes place in several steps:

1. Remove cover at CX1000/CX1020 basic module

In order to be able to fasten the connection of the fieldbus connection to the CPU basic module, the cover must first be removed (FIG 1, 2). This can be achieved by a small pressure against the cover.

FIG.1+2: Remove Cover

2. Assembly with CX1000/CX1020 configuration

Because the CX1000 configuration is already on the top-hat rail, the fieldbus module first has to be pressed on the top-hat rail. For that purpose the locking of the latching mechanism with the white tension straps (pull down) is required.

The attachment of the individual modules is done by simple plugging them together (FIG. 3). Care must be taken that the plug of the PC104 interface is not damaged.
When correctly assembled, no significant gap can be seen between the attached housings. At the end the white tension strips must be shifted into the starting position again in order that the latching mechanism locks.

FIG. 3: Stick modules together FIG. 4: Tension straps back in starting position

3. Attach Cover

If the connection area does not have a closing cover on the left-hand side, the cover that was previously removed should be pressed over the connections until it audibly engages.

Note:

If the CX1000/CX1020 configuration is not positioned on the top-hat rail it is possible to join the connection first with the CX1000/CX1020 configuration, as shown in FIG. 3, and then to clip the entire module onto the top-hat rail.

Note:

A locking mechanism prevents the individual housings from being pulled off again.


Connecting devices

Also read the section Safety instructions regarding this subject.

Warning |
 | The power supply cable of the external power supply unit must be disconnected! Please read the documentation for the external devices prior to connecting them. During thunderstorms, plug connector must neither be inserted nor removed.

Check voltage rating and connect.

1. Check that the external power supply is providing the correct voltage.
2. Plug the power supply cable into the open pluggable connector or the cage clamp of the power supply unit (depending on the version) and connect it to your external 24 V power supply.

If the green power LED of the power supply unit and the CPU basic module lights up, the power supply is connected correctly.


CX1100-0001 Connections

This power supply unit does not have an I/O interface. The power supply is therefore connected through the 5-pin open pluggable connector. The power supply unit supplies all further system components with a voltage of 24 V DC (-15 %/+20%) via the PC104 bus. The dielectric strength of the power supply unit is 500 Vrms.
The integrated NOVRAM permits storage of process data that is safe against power failure.

Pin Allocation Open Style Connector:

Pin | Assignment
1 | +24 V DC
2 | 0 V DC
3 | GROUND
4 | +UPS (+ 24 V DC)
5 | -UPS (0 V DC)

LED:

With proper connection of the power supply unit and with power supply turned on, the power LED (PWR) lights up green. In the case of a short-circuit, it lights up red.


CX1100-0002 Connections

This power supply unit is equipped with an I/O interface, which permits connection of the Beckhoff Bus Terminals. The power is supplied via the upper spring-loaded terminals labelled “24V” and “0V”.
The supply voltage feeds the CX system and supplies a voltage of 24 V DC (-15 %/+20%) to the Bus Terminals via the K-Bus. The dielectric strength of the power supply unit is 500 Vrms. Since the K-Bus does no more than pass data on, a further power supply is necessary for the Bus Terminals. This is provided by means of the power contacts, which are not connected to the power supply.
The integrated NOVRAM permits storage of process data that is safe against power failure.

LED:

With proper connection of the power supply unit and with power supply turned on, the power LED (PWR) lights up green. In the case of a short-circuit, it lights up red.

The I/O LEDs display the operation status of the Bus Terminals. Error-free start-up of the configuration is signalled by the red "I/O ERR" LED being extinguished. If the ”I/O ERR" LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks.

PE power contacts

The ”PE" power contact must not be used for other potentials.


CX1100-0003 Connections

This power supply unit permits not only the connection of the Beckhoff Bus Terminals, but also the serial connection of the Beckhoff fieldbus box modules of the type extension box IExxxx. The power is supplied via the upper spring-loaded terminals labelled “24V” and “0V”.
The supply voltage feeds the CX system and, over the K-Bus, the Bus Terminals. Since the K-Bus does no more than pass data on, a further power supply is necessary for the Bus Terminals. This is provided by means of the power contacts, which are not connected to the power supply.

Fieldbus connection:

Plug the IP link connector into the respective connections, i.e. one fibre-optic cable each into IN (x03) and OUT (x04). You then connect the other end with the corresponding IP link interface of the extension box. The connection must be made so that the output of the fieldbus connection is connected to the input of the extension box and vice versa.

LED:

With proper connection of the power supply unit and with power supply turned on, the power LED (PWR) lights up green. In the case of a short-circuit, it lights up red. The I/O LEDs display the operation status of the Bus Terminals. Error-free start-up of the configuration is signalled by the red "I/O ERR" LED being extinguished. If the ”I/O ERR" LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks.

PE power contacts

The ”PE" power contact must not be used for other potentials.


Removal and disposal

A CX1000 hardware configuration is dismantled in 2 stages:

1. Removing from the top-hat rail:

The white straps on the underneath of all the modules must be pulled downwards (FIG 1). This can be done using an ordinary screwdriver and a slight turn. The latching mechanism that provides fixing to the top-hat rail opens up (this procedure is not visible).

If the configuration has a power supply unit with an I/O interfaces, it is first necessary to release the first terminal from the top-hat rail (FIG 2) so that the CX1000 configuration can be separated from the I/O hardware, allowing the module to be removed from the top-hat rail (FIG 3).

FIG 1: Straps down FIG. 2: Releasing the I/O terminal from the top-hat rail

FIG. 3: Separating the module from the top-hat rail

2. Separating the individual modules:

Before separating the individual modules from one another, the entire CX1000 hardware block must first be removed from the top-hat rail, as described in Step 1. The individual modules can then be separated from one another by means of the separation mechanism mounted on the rear, as shown in Fig 4. This is done by inserting a flat screwdriver with dimensions 1.0 x 5.5 x 150 mm into the locking mechanism, and then operating the slider by turning it about 90 degrees. The rear-mounted locking mechanism creates a separation of approx. 2-3 mm in the mechanical engagement of the modules, pushing them apart, so that the PC 104 interface connectors can then carefully be pulled apart (FIG 5). Modules that cannot be separated from one another do not have a slider slot, but merely a marking point (which may or may not be sealed with red lacquer). Applying force to these elements will destroy them.

FIG. 4: Undoing the latching mechanism FIG 5: Separating the modules

The CPU can be separated from the power supply unit and the fieldbus connections in this way.

Note:

If the configuration has a power supply unit with an I/O interface, it is first necessary to release one terminal from the top-hat rail so that the configuration can be separated from the I/O hardware.

Note:

The embedded PC must be shut down and the power supply disconnected before dismantling!

Warning |
 | Forcibly opening the module housing (e.g. removing the cover) will destroy the housing.

Disposal

The device must be fully dismantled in order to dispose of it.

Battery-recycling:

This unit contains an accumulator. This must must be disposed of in accordance with national electronics scrap regulations.

Used batteries / accumulators may contain harmful substances or heavy metal that can harm the environment and health. Batteries will be recycled. They contain important commodities as iron, zinc, nickel or manganese.

The environment and Beckhoff thank for your understanding.

Electronic parts must be disposed of in accordance with national electronics scrap regulations.


Display settings

The CX1000 supports the display resolutions 640 x 480 dpi (VGA), 800 x 600 dpi (SVGA) and 1024 x 768 dpi (XGA).

A TFT display with DVI interface can be connected directly to the DVI-I port of the CX1000. Additionally, the connection of a standard CRT monitor is possible with a via DVI to VGA adaptor (part number: CX1900-0101).

The display settings for resolution and refresh rate have to take place inside the CX1000 Registry.

1. Go to Start | Run...

2. Type "regedit' at the appearing 'Open' dialog

3. Navigate to HKEY_LOCAL_MACHINE -> SOFTWARE -> GEODE and double-click on the value name 'Resolution' which is listed on the dialog on the right.

Different resolutions correlate with their applicable refresh rates. The 'Resolution' string value has to contain the refresh rate value.

E.g. for a resolution of

640 x 480 (VGA) [default], please enter the following value: 640 480 60

800 x 600 (SVGA), please enter the following: 800 600 60

1024 x 768 (XGA), please enter the following: 1024 768 50

If you have a Windows CE based CX and the wrong resolution is currently configured, you can change the settings from a host system by using the CERHOST utility like done for the sample picture shown below.

Exit the Registry Editor afterwards and execute Start | Suspend for activation of the changed settings.


Accessories

Compact flash cards

order number | Description
CX1900-0023 | 1 GByte compact flash card type I
CX1900-0025 | 2 GByte compact flash card type I
CX1900-0027 | 4 GByte compact flash card type I

Connectors and Adaptors

order number | Description
CX1900-0101 | DVI-to-VGA passive Adaptor for connecting a standard desktop VGA monitor to the CX1000 system – singles out the VGA signals of the DVI-I interface of the CX1000-N001 module – 29-pin male DVI-A connector (bottom) to 15-pin female connector (top) – weight approx. 40 g – dimensions (W x H x D) 40 x 42 x 15 mm

Labelling Tags

order number | Description
CX1900-0200 | Universal plastic labels for the CX1000 system (package contains 1000 labels) – snaps into the premoulded spots on the CX1000 components – labelling can be done with a X-Y plotter – dimension of the single label 15 x 5 mm – material: white coloured plastic – Murrplastik type KMR 5/15, order number 86401014


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


Certifications

All products of the Embedded PC family are CE, UL and GOST-R certified. Since the product family is continuously developed further, we are unable to provide a full listing here. The current list of certified products can be found on the Embedded PC certificates web page or at www.beckhoff.com under Embedded PC.


Systemboot

Embedded-PC: Boot

System boot

under preparation