CU2508 - Real-time Ethernet port multiplier
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version | Comment
2.6 | - Chapter „Firmware Update“ updated - Update revision status - Update structure
2.5 | - Chapter „Technical data“ updated - Chapter „Technology“ updated - Update revision status - Update structure
2.4 | - Chapter „Technology“ updated - Update revision status - Update structure
2.3 | - Chapter „Technology“ updated - Update revision status - Update structure
2.2 | - Chapter „Firmware Update“ updated - Update revision status - Update structure
2.1 | - Chapter „Portdefinition TwinCAT 2.11“ updated - Chapter „Technical data“ updated - Update structure
2.0 | - Migration
1.8 | - Update chapter "LEDs and connection" - Update structure
1.7 | - Addenda chapter "Setting up under TwinCAT 2.11"
1.6 | - Addenda chapter "Setting up: PROFINET Controller/Device"
1.5 | - Addenda chapter "Technology"
1.4 | - Addenda note chapter Ethernet/IP slave
1.3 | - Addenda RT Ethernet
1.2 | - Addenda current firmware status
1.1 | - Addenda Ethernet/IP slave
1.0 | - Corrections, 1st public issue
0.1 | - Preliminary documentation for CU2508


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Technology
•
Start


Introduction

Product overview [image] Introduction
Introduction
CU2508
Real-time Ethernet port multiplier
The real-time Ethernet port multiplier allows the connection of eight independent FastEthernet networks (100 Mbit/s). The CU2508 is connected to the PC via a gigabit uplink.
The PC offers high-performance data transfer to the multiplier, which allocates the data to the relevant 100BASE-TX port based on an analysis of a frame prefix and sends them time-controlled with µs precision. Received frames are also allocated a prefix including a time stamp and sent to the PC.
With the aid of a driver, users have eight independent ports with full real-time characteristics available. The CU2508 is used in applications in which several Ethernet ports are required that need to be realized externally to the PC.
TwinCAT 2.11 supports the CU2508 and avoids the need for further network ports at the PC. For extremely high demands, an EtherCAT installation can, for example, be distributed or expanded to up to eight strands in order to multiply the performance. The distributed clocks of the EtherCAT strands are synchronized. An EtherCAT cable redundancy in conjunction with distributed clocks can also be realized with two ports of the CU2508.
Quick links


Technical data

Product overview [image] Technical data
Technical data
Technical data | CU2508
Operating voltage | 24 (18...30) VDC, 250 mA, 3-pin connector (+, -, PE)
Number of Ethernet ports | 8 x 100 Mbit/s (100BASE-TX) and 1 x 1 Gbit/s (1000BASE-T, Uplink)
Ethernet interface | RJ 45
Cable length | up to 100 m, min. CAT5 twisted-pair, shielded
Diagnosis | via LED, software
Protocols | depends on used CU2508 driver TwinCAT: Ethernet TCP/IP; real-time protocols: EtherCAT, PROFINET, RT Ethernet etc.
TwinCAT support | TwinCAT from version 2.11R2 (build 2028) Operating systems XP/7/WES and CE/WEC
Electrical isolation | 1,500 V
Weight | approx. 500 g
permissible ambient temperature range during operation | 0°C ... + 55°C
permissible ambient temperature range during storage | -25°C ... + 85°C
permissible relative humidity | 95 %, no condensation
Dimensions (W x H x D) | approx. 146 mm x 100 mm x 30 mm
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE cULus


Technology

Product overview [image] Technology
Technology
Introduction
As a port multiplier that is as transparent as possible, the CU2508 extends one Gbit Ethernet port on the controller to 8 FastEthernet ports in the field. It transports IEEE802.3 conformant Ethernet frames with arbitrary contents.
Each port of the CU2508 sends and receives FastEthernet frames (100 Mbit, 100BASE-TX) over up to 100 m of copper cable/RJ45. The CU2508 does not generate or process the contents of any frames itself; instead, it exclusively forwards frames sent to it by a special software driver to the field selectively via its 8 ports or forwards frames received from the field to the driver. The highly precise time information regarding when the frames are sent or received is thereby optional.
To this end, the CU2508 has at its disposal
▪
the Uplink Gbit Master Port (X9) to the driver in the controller, which needs a Gbit connection at the opposite end
▪
8 equivalent 10/100 Mbit downlink ports (X1-X8) for the real-time traffic to the connected field devices
A CU2508 system thus consists of the CU2508 device and the CU2508 driver, e.g. integrated in TwinCAT 2.11R2 or TwinCAT 3.
The CU2508 system does not replace master implementations of Ethernet based field buses; instead, it tunnels specified data telegrams via the Gbit connection and then sends the frames at the specified time. It behaves transparently for the protocols fed across it, with exception of the EtherCAT protocol – in this case a CU2508 device is visible as the first slave in the configuration. Each materially existent I/O system on the field side must therefore match a logical master component in the controller.
Several CU2508s can be used in each TwinCAT system.
Principle CU2508 topology
Downlink Port characteristics
The default setting of the CU2508 is optimized for use with EtherCAT downlinks, especially for EtherCAT IO redundancy operation. Therefore the 8 downlinks up to and including FW11 in the factory setting had the function to mirror incoming 100 Mbit frames back to the transmitter if the 1 GBit uplink is missing, called "Auto Link Close".
Display "Auto Link Close"
In non-EtherCAT operation this feature can be a problem and might disrupt the underlying network. Therefore it is deactivated globally for all downlink ports starting from FW12, so that in case of an uplink loss no return of incoming 100 Mbit frames takes place but the frames in the CU2508 "percolate". The electrical link is not changed.
ESL protocol
The software driver in the controller/control device/IPC forms the counterpart to the CU2508. It works on a Gbit port in the controller and "packs" the user data into the EtherCAT Switch Link Protocol (ESL) or unpacks the ESL protocol from the CU2508 and forwards the user data to the application. Therefore, no extra telegram containing control data is sent to/from the CU2508 for the handling of the user data; instead, the user data generated by user programs are supplemented by several bytes of control and information data for the connection between controller and CU2508.
The CU2508 driver is integrated in TwinCAT from version 2.11R2 onwards; pay attention to the specifications in the Technical data. The ESL protocol is disclosed, see the Description page. In addition, it has been included in the Wireshark-Installation since version 1.4.2.
EtherCAT systems and CU2508
The CU2508 can be used to operate several FastEthernet EtherCAT systems on one port of the IPC, i.e. quasi as port-multiplier. Hence the term "port multiplier”.
When operating several EtherCAT systems on the ports of a CU2508, temporal effects may occur that may be relevant for the application. Some explanations are provided below.
The CU2508 essentially supports the following three operation modes. To understand this, basic knowledge of the EtherCAT operation modes and synchronization methods is helpful.
1.
Standard mode: no frame influence, no DistributedClocks
–
The CU2508 forwards incoming frames via Gbit-ESL to the desired FastEthernet port, also in the opposite direction. There is no time control for the Ethernet frames.
–
The EtherCAT slaves of the lower-level systems therefore operate on a frame-triggered basis (also referred to as FreeRun mode), and the output times are essentially dependent on frame delays/jitter, for example.
2.
Time-controlled sending/time-stamped receiving: with frame influence, no DistributedClocks
–
The CU2508 forwards incoming frames via Gbit-ESL to the desired FastEthernet port at the requested time. Time stamping takes place in the opposite direction. In other words, the Ethernet frames are time-controlled.
–
Frame-triggered EtherCAT slaves thus operate with "low jitter", and "synchronized" between the EtherCAT systems.
–
In order for the frames to be forwarded on a time-controlled basis, buffering in the CU2508 is required, which may cause considerable delays. For short cycle times the feasibility should be verified!
–
This operation mode is not yet supported (as of 2019)
3.
DistributedClocks mode, no frame influence
–
The forwarded EtherCAT frames are subject to temporal influence by the transmitting IPC, the CU2508 and the EtherCAT slaves.
–
The ports X1..8 are parameterized as DistributedClocks - ReferenceClocks
–
Thus, the EtherCAT slaves of the lower-level systems that support DistributedClocks also operate DC-synchronously. This means that the input/output operations in these slaves can be synchronized, even at the "same" time between the EtherCAT systems on ports X1..8.
In this case the overall system is essentially independent of frame delays/jitter, as long as these are not significant enough to impair the DistributedClocks control.
–
With regard to EtherCAT operation, this method is essentially the most sensible, because
• it offers the best temporal definition for the input/output operations of the EtherCAT devices
• no time buffers are necessary in the CU2508
The following aspects must be taken into account in order to be able to estimate temporal effects in operation modes 1 and 3:
▪
Depending on the data content, Ethernet frames have a time length of
–
X1..8 FastEthernet: 7..128µs, InterFrameGap (IFG) 9.6 µs
–
X9 Gbit: 0.7..12 µs, IFG 0.96 µs
▪
The CU2508 has an internal delaying data buffer for each port, due to the different transport speed
▪
TwinCAT sends the Gbit frames for X9 serially (one after another) via the GBIT/ESL connection. The GBit frame lengths can be of a magnitude that is significant in the context of short TwinCAT cycle times!
▪
If several tasks are to be processed in TwinCAT, by default TwinCAT processes them serially (one after the other). As a result, the ESL frames are sent with a corresponding delay.
The "isolated core" setting in the RealTime tasks provides a remedy so that the tasks can be processed in parallel.
▪
The EtherCAT frame length must also be taken into account.
Example: An EtherCAT system is installed at ports X1 and X2, each with an EL2202 as output terminal. The edges are to be measured with an oscilloscope for demonstration purposes. In system X1 the bit of the respective output terminal used is in a short 7 µs frame, whereas in system X2 it is in a long 128 µs frame. This alone causes the signal to be output 121 µs later in system X2.
A remedy is provided by DistributedClocks, see above.
(The position of the output data in the EtherCAT frame is usually irrelevant since output data is only output after the checksum procedure, once the frame has fully passed the output device.)
▪
Typical delays caused by the management of the CU2508 are as follows
–
In the downlink
Gbit X9 to FastEthernet X1..4: tFE = 1 µs
Gbit X9 to FastEthernet X5..8: tFE = 1.6 µs

CU2508 Downlink Delay
–
In the uplink
FastEthernet X1..X4 to Gbit X9: tGE = 0.7 µs
FastEthernet X5..X8 to Gbit X9: tGE = 1.1 µs
CU2508 Uplink Delay
–
These delays are therefore relatively insignificant compared to the other factors mentioned above. What immediately catches the eye, however, is the importance of the frame length and the required buffering in the uplink.
CU2508 als EtherCAT slave
Each downlink port of the CU2508 can be configured as a separate "EtherCAT device", see chapter EtherCAT device setup. In this case the CU2508 port represents the first EtherCAT device in the system. It is capable of Distributed Clocks and can therefore operate as a reference clock in the strand.
The combination of EtherCAT cable redundancy and Distributed Clock function is possible by combining two such EtherCAT ports using the "TwinCAT cable redundancy" supplement (subject to charge).
Time-controlled send/receive (in preparation)
The frame forwarding in the CU2508 can be subjected to precise time control by the local clock:
▪
the driver or the user application specifies the downlink port via which the frame is to be sent by the CU2508 and when.
These data are added by the driver to each frame as additional information.
▪
each frame received by the CU2508 at a Downlink port is supplemented by receipt information (receiving port, time) and forwarded to the controller via the uplink.
The local hardware-based clock in the CU2508 then controls the sending of the frames with a high temporal quality. In this way, the CU2508 permits the construction of a real-time Ethernet network (TwinCAT Publisher/Subscriber, Ethernet/IP, Profinet etc.), even if the control device cannot guarantee hard real-time when sending the protocol data. However, the control device must be able to deliver or accept the data with sufficient speed.
The time controller uses the 64-bit time format familiar from the EtherCAT Distributed Clocks system: resolution 1 ns, starting from 1.1.2000 00:00 and thus adequate for ~584 years
The time stamp information (sending and receiving) is for the time being only evaluated by the CU2508 driver and is not available to the user application.
As the start of an Ethernet frame, the SFD (Start of Frame Delimiter) is evaluated according to the IEEE802.3 standard.
EoE and TCP/IP
The CU2508 is connected to the IPC via the Gbit interface. This Ethernet interface appears in the operating system/Windows of the IPC with its properties (IP address, IP mask etc.). From the point of view of the operating system, therefore, there is “only” this network connection via which telegrams can be sent or received. The CU2508 driver can now either convey data traffic from the operating system level to a dedicated CU2508 port or feed it into the virtual EtherCAT EoE “switch”. Also compare the documentation for the EL6601/EL6614 here. The selection is made in the settings in the System Manager. Either the specific CU2508 port or generally EoE can be selected via "TCP/IP Port".
Refer in particular to the TCP/IP notes here.
Different IP data traffic depending on the setting
Applications
The above-described functions permit the use of the CU2508 for the following applications, among others:
▪
Multi EtherCAT adapter
Up to 8 independent EtherCAT systems can be created.
▪
Synchronized EtherCAT systems
If the CU2508 is selected as the ReferenceClock, the EtherCAT systems connected to the CU2508 are operated with the same synchronized time base.
▪
EtherCAT cable redundancy
2 downlink ports of each CU2508 can be combined into a cable-redundant EtherCAT system. Hence, fewer Ethernet ports are occupied on the controller; only one Gbit Ethernet port is required for the uplink. Up to 4 cable-redundant EtherCAT systems are possible. The CU2508 is placed next to the controller in the control cabinet; I/O cable connections that are in danger of being disconnected are then fed redundantly out of the control cabinet in the ring closure.
Use of the CU2508 as an EtherCAT cable redundancy star point
▪
EtherCAT cable redundancy with Distributed Clocks
The common time base of the CU2508 ensures that EtherCAT slaves that require Distributed Clocks are still subject to synchronization in the case of redundancy.
▪
Use of TCP/IP without real-time
A downlink port on the CU2508 can be configured as a non-real-time Ethernet port, or the CU2508 works in the Ethernet over EtherCAT (EoE) network and forwards TCP/IP frames from the connected EtherCAT systems.
Use of the CU2508 as an Ethernet multi-protocol handler with EtherCAT and TCP/IP
▪
Real time fieldbus on non-real-time controller
If an Ethernet-based fieldbus requires a reliable constancy with respect to the sending of communication telegrams, low jitter is demanded in the cyclic operations of the controller. If a high-performance controller is able to process the cyclic operations with sufficient frequency (= demanded short cycle time), but the jitter, i.e. the regular interval between the cycles is inadmissibly high, then the CU2508 system, as a real-time frame handler, can provide the constant interval in frame sending, provided the new data are available early enough in the CU2508.
Use of the CU2508 as an EtherCAT real-time environment
There are currently still restrictions (TwinCAT 2.11/3.1, FW10) with regard to
▪
external synchronization of the CU2508
The influence on the internal CU2508 clock is still in preparation.
▪
Profinet
▪
BACNet
▪
time stamp-controlled sending/receiving of frames
The implementation of these and further protocols is in preparation.
Data traffic in the lower-level EtherCAT segments
From FW07 and ESI revision -0018, Ports 1 and 5 have a larger data buffer of 16 kbyte (instead of 8 kbyte) for EtherCAT segments with particularly high data transfer rates.
"High data traffic" is generated by IO systems with many cyclical data, e.g. when many subscribers (over 100) and/or subscribers with large data requirements (e.g. analog oversampling terminals) are used.
If a "large" IO system is operated in EtherCAT redundancy mode, it is advisable to use ports 1 and 5.
The memory situation found is occasionally reported by TwinCAT with "Cu2508 fifo sizes...":
Message relating to CU2508 fifo sizes


Start

Product overview [image] Start
Start
For commissioning
▪
install the CU2508 as described in the Mounting and wiring chapter
▪
configure the CU2508 in TwinCAT as described in the Commissioning chapter
Furthermore, the field devices typical for the application are required on the downlink ports.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Dimensions
•
Mounting and demounting
•
Cabling
•
LEDs and connection
•
UL notice


Dimensions

Mounting and wiring [image] Dimensions
Dimensions
Dimensions without plugs (W x H x D)
▪
CU2508: approx. 146.5 mm x 100 mm x 38 m
Space requirement in the control cabinet
•
The RJ45 connector increase the depth depending on their design and the Ethernet cable used.
•
Above the mounting rail an additional height of approx. 10 mm is required to enable latching of the switch onto the rail.
CU2508 dimensions


Mounting and demounting

Mounting and wiring [image] Mounting and demounting
Mounting and demounting
The CU2xx switches are mounted on the mounting surface with the aid of a 35 mm DIN rail (mounting rail according to EN 60715).
Mounting
▪
Fit the mounting rail to the planned assembly location.
▪
Suspend the switch on the mounting rail with the spring on the lower side of its latching flange.
▪
Press the switch upwards (1).
▪
Press the upper side of the switch (2) against the assembly surface until it latches in the mounting rail.
▪
Attach the cable.
Mounting
Removal
▪
Remove all the cables.
▪
Press the switch upwards (3).
▪
Pull the other side of the switch (4) away from the assembly surface.
Removal
Additional information
•
Diagnostic LEDs


Diagnostic LEDs

Mounting and wiring [image] Mounting and demounting [image] Diagnostic LEDs
Diagnostic LEDs
The CU2508 has 4 diagnosis LEDs.
CU2508 front view
The CU2508 currently has no further diagnostic features.


Cabling

Mounting and wiring [image] Cabling
Cabling
Power supply
Pin configuration of the spring loaded terminal
CU20xx_PowerClamp
culus-logo
UL requirements
•
from an isolated source protected by a fuse of max. 4A (according to UL248) or
•
from a voltage supply complying with NEC class 2.
•
An NEC class 2 voltage source must not be connected in series or parallel with another NEC class 2 voltage source! These requirements apply to the supply of all Bus Couplers, power supply terminals, Bus Terminals and their power contacts.
culus-logo
UL requirements
In order to comply with UL requirements, the EtherCAT components must not be connected to unlimited voltage sources!
Ethernet
Pin configuration of the RJ45 sockets
Pin configuration of the RJ45 sockets


LEDs and connection

Mounting and wiring [image] LEDs and connection
LEDs and connection
The CU2508 has 4 diagnosis LEDs.
CU2508 front view
LEDs
LED | Color | Meaning
RUN | green | This LED indicates the operating state of the CU2508 running as an EtherCAT device
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal or BOOTSTRAP
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | single flash | State of the EtherCAT State Machine: SAFEOP = verification of the sync manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
Int Act | green | flashes when data traffic occurs
Power | green | on, when the device is powered correctly
Error | yellow | an error has occurred (see chapter "Error handling and diagnosis")
X1 - X8 | green | Link/Activity
 | yellow | internal buffer overflow, alignment error detected
Pin assignment
Terminal point | Comment
X0 | 24 VDC power supply: +, GND and shield connection (functional earth)
X1..X8 | DownLink Port FastEthernet 10/100 Mbit
X9 | UpLink Port Gbit Ethernet
Shielding concept
The PE/shield connection is connected to the metal housing. It should be used as functional earth to protect from interference.
CU2508 shield concept


UL notice

Mounting and wiring [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:


Commissioning

Commissioning
Commissioning
Additional information
•
Setting up under TwinCAT 2.11
•
Port definition TwinCAT 2.11
•
Beckhoff EAP network variables


Setting up under TwinCAT 2.11

Commissioning [image] Setting up under TwinCAT 2.11
Setting up under TwinCAT 2.11
The CU2508 must be created as a MultipleProtocolHandler in the configuration before functions can be assigned to its downlink ports.
Online scanning of the CU2508 is for the time being only possible with EtherCAT systems connected to the downlink ports. The notes in the EtherCAT port definition regarding the ESI XML files must then be observed.
Setting up
Append a new device in the TwinCAT System Manager with a right click.
Appending a new device
Select the "Real-Time Ethernet Adapter (Multiple Protocol Handler)".
Selection of the MultiplerProtocolHandler
Now select the Gbit uplink port used for the CU2508. You can only select ports on which the Beckhoff real-time driver is installed/activated. <none> can also be selected if the port is to be selected later.
Selection of the Gbit Ethernet port used on the controller
If the real-time driver is not yet installed, it has to be installed first, e.g. via the System Manager options.
Installation of the Beckhoff real-time driver
Characteristics that are important for the further operation, e.g. the MAC and the IP addresses of the Gbit network port are now listed in the adapter characteristics of the MultipleProtocolHandler.
Adapter data for the Gbit Ethernet port used
Name | Explanation
Description | Name of the adapter in the operating system (the same on several identical PC systems)
Device Name | Unique adapter name (different on several identical PC systems)
MAC Address | MAC address of the hardware adapter; not changeable
IP Address | IP address of the hardware adapter; changeable via the Windows operating system "Network Connection" settings
Freerun Cycle | The adapter is now operated in ConfigMode with this cycle time, i.e. usually 250 cycles/sec.
Promiscuous Mode | If activated, the Ethernet Frames are copied from the real-time context into the Windows NDIS layer and can thus be read by Netmon/Wireshark
Virtual Device Names | deactivated: "Device Name" is used by TwinCAT for the identification of the network adapter. Thus a TwinCAT configuration is not transferable to another PC system without being changed. activated: "Description" is used by TwinCAT for the identification of the network adapter. Thus a TwinCAT configuration is transferable to another PC system without being changed if an adapter with this name is present there.
The number of necessary ports must be set in the port mask (A). The TCP/IP mode of operation is also to be set (B); "via EoE" must be set for pure EtherCAT operation. Refer here to the Notes on TCP/IP settings. In each case the ESL protocol must be activated for the CU2508 on this Gbit port (C).
Number of adapters
The CU2508 has no separate diagnostic variables, since it is designed to be as transparent an infrastructure device as possible.
In the following
▪
individual downlink ports can now be assigned to protocols
▪
the TCP/IP behavior of the CU2508 can be set
Diagnosis
The TwinCAT System Manager provide several information about the online operation.
Statistics
Name | Explanation
Send Utilization (%) | Utilization of the Gbit ESL transmission in transmit direction R: real-time data, N: non-real-time data
Recv Utilization (%) | Utilization of the Gbit ESL transmission in receive direction R: real-time data, N: non-real-time data


Port definition TwinCAT 2.11

Commissioning [image] Port definition TwinCAT 2.11
Port definition TwinCAT 2.11
Additional information
•
Setup: Device EtherCAT
•
Setting up: Device EtherCAT with cable redundancy
•
Setting up: Device Ethernet and TCP/IP notes
•
Setting up: Real-time Ethernet (Publisher/Subscriber, EAP push)
•
Setting up: Real-time Ethernet (BK90xx, ADS/RAW, EAP polling)
•
Setting up: PROFINET Controller/Device
•
Configuration: Ethernet/IP


Setup: Device EtherCAT

Commissioning [image] Port definition TwinCAT 2.11 [image] Setup: Device EtherCAT
Setup: Device EtherCAT
Table of contents
• Notes on the EtherCAT device
• Setting up an EtherCAT device
• Configuration settings under TwinCAT 2.11R2
• Distributed Clocks behavior
• EoE settings
A downlink port of the CU2508 is set up as an EtherCAT device. The correct setup of the CU2508 device is assumed.
Notes on the EtherCAT device
▪
The CU2508 downlink port appears as the first regular EtherCAT slave. It can optionally represent the Distributed Clocks reference clock in this EtherCAT system. The port has no controllable I/O.
▪
All CU2508 downlink ports are synchronized with each other.
▪
A second CU2508 port can be used as a ring closure for EtherCAT cable redundancy. The primary EtherCAT connection must then be connected to an odd CU2508 port (X1, X3 etc.) and the secondary redundancy adapter to the following even CU2508 port (refer to the corresponding chapter Device EtherCAT with cable redundancy).
▪
The CU2508 sends EtherCAT frames in pass-through mode without time stamps.
Setting up an EtherCAT device
In EtherCAT operation the CU2508 downlink port used is not transparent, but appears as a Distributed Clocks-capable EtherCAT slave in the configuration. As a result it can appear as a reference clock. However, the EtherCAT slave is otherwise not parameterizable or addressable.
As applies to every EtherCAT device, the current ESI xml files should be present in the TwinCAT system for the CU2508 also. This applies both to the offline creation of the configuration and to scanning in online operation. The files (in particular “Beckhoff CUxxxx.xml”) can be procured from the download area on the Beckhoff web page. They are to be saved under "… \ TwinCAT\Io\EtherCAT\".
Updating the ESI XML files
If the following information window should appear in online mode when scanning the devices on the CU2508: (see Fig. Information window "Online description") then an update for above mentioned file is necessary:
Click on "No", close the System Manager window, install the current ESI xml files and create the configuration in a newly opened System Manager window.
Information window "Online description"
Creation of the configuration
The simple option to create the configuration by scanning the real hardware is only possible if an EtherCAT device is manually connected to a CU2508 port in the configuration.
Configuration settings under TwinCAT 2.11R2
Creating an EtherCAT device
An EtherCAT device can be added by right-clicking on I/O Device - > Append Device.
Creating an EtherCAT device
Selection of the "EtherCAT" device
The desired downlink port of the CU2508 can now be selected.
Selection of the CU2508 port
The device "Device 2 (EtherCAT)" is now connected, according to the adapter reference, not to a physical Ethernet port of the controller, but to a logical adapter reference of the CU2508. This assignment can also be changed later. The freerun cycle time in the TwinCAT ConfigMode is shown here for the adapter.
Adapter setting for the EtherCAT device
Creation of the configuration
Scanning of the EtherCAT configuration is also possible from this state onwards.
Creating a CU2508 box
The CU2508 downlink port appears as an EtherCAT slave and can be scanned or created manually.
Appending a CU2508 EtherCAT slave
If creating manually, the “CU2508 Ethernet port” CU2508-0000 must be selected. The check box "ExtendedInformation" displays the revision numbers, in this case -0000 (fig. Selection of “CU2508 Ethernet Port”).
If "CU2508" is entered in the Search mask, the overview is reduces to the sought device.
Fig. 7: Selection of “CU2508 Ethernet Port”
Further EtherCAT slaves can now be appended to the CU2508 Box.
Appending further EtherCAT slaves
Distributed Clocks settings
All CU2508 downlink ports are synchronized with each other and can appear as ReferenceClock in the respective EtherCAT strand. In the default setting, however, the CU2508 port is not marked as Distributed-Clocks-capable, hence under TwinCAT the next subsequent Distributed-Clocks-capable slave is selected as the ReferenceClock. In each case the CU2508 port is the 1st slave in the respective strand.
EtherCAT Distributed Clocks reference
If the CU2508 port is to be used as the ReferenceClock in a system, the setting "Use as potential ReferenceClock" must be changed; see fig. CU2508 slave - Distributed Clocks setting.
CU2508 slave - Distributed Clocks setting
Synchronized EtherCAT systems
If several EtherCAT systems are to be operated on CU2508 ports synchronized with the same time base, the flag "Use as potential Reference Clock" must be set in the appropriate "CU2508 box".
External synchronization to another time base is then not possible.
The internal clock in the CU2508 works independently and is only managed by the CU2508 driver.
EoE settings (Ethernet over EtherCAT)
If devices with EoE support are used in a lower-level EtherCAT system, this affects the settings of the EoE switch in the CU2508 if this is configured for EoE transport. Refer to the Notes pages on TCP/IP traffic.
If such devices are present in the EtherCAT system,
▪
the Virtual Ethernet Switch must be enabled (“Enable”)
▪
“Connect to TCP/IP Stack” can be activated
▪
the numbers "Max Frames" and "Max MAC IDs" can be increased if throughput problems are determined
EtherCat device EoE settings
If several EtherCAT system EoE devices are used, this increases the settings of the CU2508 EoE switch.
CU2508 EoE settings


Setting up: Device EtherCAT with cable redundancy

Commissioning [image] Port definition TwinCAT 2.11 [image] Setting up: Device EtherCAT with cable redundancy
Setting up: Device EtherCAT with cable redundancy
If a downlink port of the CU2508 has been set up as an EtherCAT device, a further port can be used as a 2nd EtherCAT port for the purpose of cable redundancy.
The "TwinCAT cable redundancy" supplement serves to keep the EtherCAT system in operation in the case of an unforeseen interruption in communication due to cable breakage. The system is single-error tolerant. This achieved by the ring closure of the EtherCAT system to the controller. If more than 1 error occurs, slaves drop out of the communication. They are only readmitted after all connections have been restored.
TwinCAT EtherCAT cable redundancy
Regarding this, refer to the principle explanations in the EtherCAT system documentation.
The combination of the EtherCAT cable redundancy and Distributed Clocks technologies is possible using the CU2508.
Notes on EtherCAT cable redundancy
▪
Only the downlink port combinations X1/2, X3/4, X5/6 and X7/8 are permissible for EtherCAT cable redundancy. In addition, the port combination X1/5 is recommended for an EtherCAT strand with extensive process data, since an increased memory of 16kByte is available from FW07/Rev0018.
▪
If EtherCAT cable redundancy is activated, the CU2508 ports used is automatically set as the Distributed Clock ReferenceClock. The synchronization of the devices can thus be maintained even in the case of media interruption.
▪
During EtherCAT startup with Distributed Clock devices, the cable-redundant ring must be closed, and continuous communication must be possible, otherwise no synchronization is possible.
▪
An external Distributed Clocks synchronization of such an EtherCAT system is not possible for the time being.
▪
The supplementary license "EtherCAT cable redundancy" is chargeable and is available for Windows XP (NT, 7, WES) and CE (WEC).
It can be downloaded from the download area on the Beckhoff web page.
Setting up EtherCAT cable redundancy
The EtherCAT configuration must be created on a CU2508 downlink port as described in the chapter "Setup: Device EtherCAT". The resulting topology can be displayed in the Device EtherCAT using the Topology button; see fig. Display of a simple EtherCAT topology.
Display of a simple EtherCAT topology
The items below are to be specified in the following steps
▪
the control-side redundancy adapter, in this case on the CU2508
▪
the field-side redundancy adapter on the last EtherCAT slave
The EtherCAT redundancy port is specified in Device -> EtherCAT -> Advanced Settings.
Specification of the redundancy port
Specification | Meaning
Off | no EtherCAT cable redundancy
Second Adapter | physical adapter/Ethernet port of the controller
Adapter Reference | logical adapter such as in the CU2508
Number of ports
A corresponding number of ports must be set to available in the settings for the CU2508 adapter.
After specifying the redundancy adapter, it must be checked whether the System Manager has selected the correct EtherCAT slave port as the field-side connection point, see fig. Specification of the field-side redundancy port.
Specification of the field-side redundancy port
The correct selection can be checked in the Topology window.
Checking topology with EtherCAT cable redundancy


Setting up: Device Ethernet and TCP/IP notes

Commissioning [image] Port definition TwinCAT 2.11 [image] Setting up: Device Ethernet and TCP/IP notes
Setting up: Device Ethernet and TCP/IP notes
Table of contents
• Explanation of TCP/IP v4
• Application CU2508
• Settings for the dedicated TCP/IP port
• EoE settings
Explanation TCP/IP v4
TransmissionControlProtocol/InternetProtocol (TCP/IP) is the name given to a bundle of procedures from the 1970s, which defines a packet-mediated forwarding of data. This mediation procedure is used in contemporary everyday communication, in particular on the Ethernet physics (e.g. Fast Ethernet, Gbit) and the hardware-orientated MAC addressing normally used there. The basic principles of this set are
▪
packets of user data of 64 to 1486 bytes (special forms are not uncommon) are sent from a transmitter to one (unicast) or more (multicast, broadcast) receivers.
▪
In IPv4 the source and destination addresses each consist of 4 bytes separated by a point, e.g. "192.168.1.1" or "123.001.002.001".
Note: IPv6 extends the address space by a further 2 bytes and will replace IPv4 in the mid-term.
▪
There does not have to be a direct physical connection (cable) between transmitter and receiver; instead, intelligent packet mediators analyze the source and destination addresses and forward the packets (key words: routing and switching). This results in delays and possible loss of data.
▪
The IP is a bi-directional reconfirmed communication, because the receiver acknowledges the receipt of data to the transmitter. This causes a further communication load and increased transport time. Lost data can thus be repeated automatically.
▪
UDP (User Datagram Protocol) can also be used instead of IP. It works without reconfirmation, lost data must then be requested again at a higher communication level. In return, less time is required for data communication.
The Windows operating system manages TCP/IP communication with its Ethernet adapters in the so-called NDIS network mediation layer. The adapter settings can be accessed via the Windows Control Panel->Network Settings or the Windows CE CXconfig tool from Beckhoff.
These circumstances make TCP/IP-supported communication unsuitable for an application with higher real-time requirements, but very suitable for flexible (variable) connections via many hubs (intermediate stations) with an arbitrarily high data traffic.
Application CU2508
Two methods are available if TCP/IP frames are to be transmitted via the CU2508 (with no real-time requirement):
▪
one port of the CU2508 is defined as a dedicated TCP/IP port.
Hence, it works for the operating system as an "extension" of the port to which the CU2508 is connected, with the MAC and IP data of the Gbit port used according to the operating system data.
Under TwinCAT with its integrated CU2508 driver, this port is then connected to the Windows NDIS mediation layer in the Windows operating system. Real-time traffic is then no longer possible via this port; the CU2508 works as a transparent frame transporter.
▪
the CU2508 is generally set to EoE operation (Ethernet over EtherCAT), “via EoE”.
Then the integrated virtual EoE switch is activated in the CU2508 system and the connection is established to the EtherCAT systems connected to the CU2508. In the case of EoE, Ethernet frames are transported within acyclic EtherCAT telegrams by mailbox procedures, fragmented if necessary in the case of overlength. The EL6601 or EL6614 can be used as an EtherCAT/Ethernet interface.
The MAC and IP data of the Gbit port used according to operating system data are used for addressing.
This procedure is usable only for connected EtherCAT circuits.
The setting is made in the Ports tab for the CU2508 and does not change the mode of operation of the CU2508, but only the handling of TCP/IP Frames in the CU2508 driver.
Setting the TCP/IP operating mode
It is not possible to operate the CU2508 as an independent switch with forwarding rules according to MAC rules (switch) or IP rules (router).
Settings for the dedicated TCP/IP port
The specified CU2508 port (100Mbit/FastEthernet) is then connected directly to the Windows network mediation layer; real-time operation of this port is no longer possible. Free TCP/IP network traffic is then no longer possible on the other CU2508 ports.
Notes
▪
The IP and MAC address of the used Gbit port are used for TCP/IP communication. Address area/subnet mask must therefore correspond to the addressed devices.
In the example in fig. Declaration of a CU2508 downlink port as a TCP/IP port, the address area is under the IP mask 255.255.0.0; therefore, all devices must have an IP address from the area 192.168.x.x.
▪
These settings are changed via the Windows Control Panel -> Network Settings for the adapter. The CXconfig tool must be used under Windows CE.
▪
The CU2508 works transparently; all procedures for the address assignment (DHCP, BootP,…) can be used.
▪
The throughput depends on the extent of utilization of the downlink port and the Windows network mediation layer.
Declaration of a CU2508 downlink port as a TCP/IP port
EoE settings
The virtual EoE switch of the CU2508 driver is tied into the CU2508 Ethernet adapter and accessible in the Switch tab of the RT Ethernet adapter. The VirtualEthernetSwitch is activated automatically if devices that use Ethernet-over-EtherCAT are used in the lower-level EtherCAT systems - the numbers of max. frames and ports are adapted accordingly.
Notes
▪
The IP address of the used Gbit adapter and the subnet mask is used for communication. The EoE devices (printer, scanner, remote PC etc.) must therefore have their address within this area.
▪
The throughput depends among other things on the EtherCAT cycle time, the number EoE devices and the extent of utilization of the individual connections. Attention must be paid to the notes regarding this in the documentation for the EoE devices.
▪
The EoE system can be connected to the NDIS layer via the switch "Connect to TCP/IP Stack" (fig. Flow of data when using the CU2508 as an EoE switch, A).
▪
IP routing is a function inherent to the operating system for the mediation of IP telegrams even between networks that do not lie in the same subnet. Thus, for example, between the devices 192.168.1.1 and 172.168.1.1, which each lie in the mask 255.255.0.0.
This function is activated with "IP Enable Router" (fig. Flow of data when using the CU2508 as an EoE switch, B). It is also available under Windows CE (CXconfig tools).
Flow of data when using the CU2508 as an EoE switch
The switch settings for the EoE mediation are accessible in the System Manager, see fig. EoE switch settings. The limit values are adapted automatically to the types and numbers of the devices during the creation of the configuration.
EoE switch settings
Name | Explanation
Max. Ports | Number of ports of the virtual switch. Each EoE device (e.g. EL6601, AX5000) in the lower-level EtherCAT systems occupies one port.
Max Frames | Max. number of temporarily stored Ethernet frames. Can be increased if there are noticeable throughput bottlenecks.
Max MAC Ids | MAC addresses of the connected devices stored in the internal Switch-Look-Up table. Must be larger than the maximum number of Ethernet devices ever connected to all systems.
Connect to TCP/IP Stack | Connects the EoE switch to the internal Windows NDIS network layer IP range must thereby correspond
IP Enable Router | This function is provided by the Windows operating system and is accessible via the registry or, in the case of embedded CX systems under Windows CE/WEC, via the CX-config tool. If activated, the NDIS network layer also mediates IP packets whose IP addresses do not correspond to the subnet mask .


Setting up: Real-time Ethernet (Publisher/Subscriber, EAP push)

Commissioning [image] Port definition TwinCAT 2.11 [image] Setting up: Real-time Ethernet (Publisher/Subscriber, EAP push)
Setting up: Real-time Ethernet (Publisher/Subscriber, EAP push)
Table of contents
• Notes on the device
• Setting up the device
Notes on the device
▪
An EAP adapter must be created in the configuration in order to operate a CU2508 downlink port as a publisher/subscriber device of EAP real-time Ethernet telegrams ("network variables").
▪
Attention is to be paid to the general notes on the EAP/Publisher/Subscriber procedure.
▪
The EAP (EtherCAT Automation Protocol) is operated here in the so-called push mode as opposed to the so-called polling mode for flexible data transfer.
▪
At least TwinCAT 2.11R3 is required for operation on the master side.
Setting up the real-time Ethernet device
For the setup a real-time Ethernet adapter is to be created as usual.
Creating a new device
Selection of the adapter for EAP
If not all devices are offered, the target platform can be selected via TargetType.
Not an actual port of the PC, but rather a virtual adapter of the CU2508 is then merely selected as the Ethernet adapter for the CU2508.
Selection of the Ethernet adapter
The number of available ports (in this case 4) depends on the settings of the CU2508 device (see there).
Adding the Ethernet devices
Subsequently the required Ethernet couplers/boxes/drives can be manually added or scanned. Before a scan TwinCAT should be restarted once in the Config/FreeRun mode.


Setting up: Real-time Ethernet (BK90xx, ADS/RAW, EAP polling)

Commissioning [image] Port definition TwinCAT 2.11 [image] Setting up: Real-time Ethernet (BK90xx, ADS/RAW, EAP polling)
Setting up: Real-time Ethernet (BK90xx, ADS/RAW, EAP polling)
Table of contents
• Notes on the device
• Setting up the device
Notes on the device
▪
An EAP (poll) adapter must be created in the configuration in order to operate a CU2508 downlink port as an EAP real-time Ethernet interface for IO devices (BK90xx, EK90x).
▪
The EAP (EtherCAT Automation Protocol) is operated here in the so-called polling mode
▪
At least TwinCAT 2.11R3 is required for operation on the master side.
Setting up the real-time Ethernet device
For the setup a real-time Ethernet adapter is to be created as usual.
Creating a new device
Selection of the device for BK90xx and others
Not an actual port of the PC, but rather a virtual adapter of the CU2508 is then merely selected as the Ethernet adapter for the CU2508.
Selection of the CU2508 port to be used
The number of available ports (in this case 7) depends on the settings of the CU2508 device (see there).
Adding the Ethernet devices
Subsequently the required Ethernet couplers/boxes/drives can be manually added or scanned. Before a scan TwinCAT should be restarted once in the Config/FreeRun mode.


Setting up: PROFINET Controller/Device

Commissioning [image] Port definition TwinCAT 2.11 [image] Setting up: PROFINET Controller/Device
Setting up: PROFINET Controller/Device
The usage of the PROFINET real-time protocol is possible for the device (slave) or controller (master) supplement with the CU2508. However, you can use only one controller or device, if they are in a unique network. If the networks a physically separated, it is possible to use more than one controller or device supplement with one CU2508. This is due to the fact, that the CU2508 uses only one MAC address. The function of several PROFINET segments can only be secured, if the MAC address in a network segment is unique and there is no connection to other networks.
Availability
This function can be used from TwinCAT 2.11R3 build 2234.
RT Ethernet adapter settings
Enable the lower setting under the Ports tab (radio button "EtherCAT Switch Link Protocol"); all other settings should be left at default.
Selection of the "Virtual Port" setting
Setting of the PROFINET Device or Controller adapter
Once the CU2508 has been activated as Multiple Protocol Handler in the system and the relevant ports have been enabled, you can select an "Adapter Referent" under the "Adapter" tab for the Controller or the Device. Enter the port through which you want to operate PROFINET.
Selecting the "Adapter Referent"
No other special considerations are required for the CU2508; you can proceed as usual.


Configuration: Ethernet/IP

Commissioning [image] Port definition TwinCAT 2.11 [image] Configuration: Ethernet/IP
Configuration: Ethernet/IP
Ethernet/IP is currently (2020) not supported.


Beckhoff EAP network variables

Commissioning [image] Beckhoff EAP network variables
Beckhoff EAP network variables
Additional information
•
Introduction
•
Configuration of the Publisher
•
Configuration of the Subscriber
•
Beckhoff network variables - Settings


Introduction

Commissioning [image] Beckhoff EAP network variables [image] Introduction
Introduction
Network variables are any variables that are cyclically exchanged between PC/CX1000 via TwinCAT. Variables with any data types, including complex types, can be exchanged. The Publisher/Subscriber model is used. For highly deterministic communication, the real-time Ethernet driver for TwinCAT must be installed.
Publisher/Subscriber model
In the Publisher/Subscriber model, the Publisher makes variables available. Subscribers can subscribe to a variable. The Publisher can make the variable available to a Subscriber, several Subscribers or all Subscribers. In Broadcast mode the variable is made available to all PCs, in Multicast mode to selected PCs and in Unicast mode only to one selected PC. A Subscriber can also be Publisher at the same time. In this way, a bidirectional data link can be provided.
Publisher/Subscriber model
Unicast
The Publisher makes the network variable available to a single selected PC.
Multicast
The Publisher makes the network variable available to selected PCs.
Broadcast
The Publisher makes the network variable available to all PCs.


Configuration of the Publisher

Commissioning [image] Beckhoff EAP network variables [image] Configuration of the Publisher
Configuration of the Publisher
In the TwinCAT System Manager, a new box is added for the Publisher under the RT Ethernet device.
Insert a Publisher Box
A Publisher box must be added under the RT Ethernet device.
Insert a Publisher Box
Insert a Network Variable
Network variables can then be added under the box. Enter a name (nCounterPub in the example) and a data type (UINT32 in the example, corresponding to UDINT).
Insert a Network Variable
Inputs and outputs were created under the added variable.
Displaying the inputs and outputs of the added Publisher box
The FrameState input under the box indicates the current status of the sent Ethernet frames.
The following values are possible for the FrameState:
Short description | Value | Description
Not sent (frame skipped) | 0x0001 |
Error (frame oversized) | 0x0001 | The maximum size of an Ethernet frames was exceeded. The linked variable should be smaller.
A Control Word can be written in the FrameCtrl output under the box.
The following values are possible for FrameCtrl:
Short description | Value | Description
Disable sending | 0x0001 | Sending of a frame is interrupted. Sending of the frame does not restart until the value is 0 again.
The VarState input under the network variable indicates the current status of the network variable.
The following values are possible for VarState:
Short description | Value | Description
Not sent (variable skipped) | 0x0001 |
A Control Word can be written in the VarCtrl output under the network variable.
The following values are possible for FrameCtrl:
Short description | Value | Description
Disable publishing | 0x0001 | Sending of the network variable is interrupted. Sending of the network variable does not restart until the value is 0 again.
Mappings
The network variable of the Publisher can be mapped to any output variable with a suitable data type. In the example, the network variable is linked to the output variable of a PLC.
Mapping of the network variable with an output variable of the PLC


Configuration of the Subscriber

Commissioning [image] Beckhoff EAP network variables [image] Configuration of the Subscriber
Configuration of the Subscriber
In the TwinCAT System Manager, a new box is added for the Subscriber under the RT Ethernet device.
Adding a Subscriber box and linking the network variables
A Subscriber box must be added under the RT Ethernet device.
Insert a Subscriber box under the RT Ethernet device
"Insert Box" dialog - selecting and naming the Subscriber box (Box1)
A network variable is then created under the Subscriber box.
Creating the network variable under the Subscriber box
Adding a network variable
The link to a Publisher variable can be created automatically. First, you need to find the Publisher computer. All variables of this Publisher are then shown in a list.
"Import Network Variable" dialog - display of Publisher variables
Inputs and outputs were created under the added variable.
Display of created inputs and outputs
The FrameState input and the FrameCtrl output under the box indicate the current status (or control) of the received Ethernet frames. FrameState and FrameCtrl are reserved and are currently not supported.
The VarState input and the VarCtrl output under the network variable indicate the current status (or control) of the received network variable. VarState and VarCtrl are reserved and are currently not supported.
Quality of the network variables
The quality of a network variable is assessed on the Subscriber side. Two input variables are available for this purpose under the network variable. The Quality variable provides a counter with a resolution of 100 µs. The counter value indicates the variable delay. The example below shows the online value of Quality when the network connector is unplugged (counter increases) and reconnected (counter value 0).
Online value of Quality after unplugging and reconnecting of the network connector.
In addition to the Quality variables, the CycleIndex variable is incremented in each Publisher cycle.
Incrementing of the CycleIndex variables


Beckhoff network variables - Settings

Commissioning [image] Beckhoff EAP network variables [image] Beckhoff network variables - Settings
Beckhoff network variables - Settings
Beckhoff network variables (NWV) can be used for cyclic or acyclic sending of data between Windows-based PCs. In a device declared as a publisher (sender), such a network variable is received on the other side by a subscriber declared as the same type. As the name suggests, this data traffic is network-based, and the configuration is directly based on the protocols used.
A choice of two protocols is available:
▪
MAC: An ISO Layer 2 frame is sent with a sender and receiver MAC address, Ethertype 0x0806. An IP part with the destination IP address (e.g. 192.168.0.1) is not included. The telegram can therefore be further processed via a switch, but usually not via a router.
MAC stands for media access control and in this case refers to the (unique) hardware address assigned to each Ethernet device during production. For example, the Ethernet port of a Beckhoff PC might have the MAC ID 00:01:05:34:05.84, with "00:01:05" representing the Beckhoff ID and the rest assigned during production. The route of each Ethernet telegram between two Ethernet cable ends is determined by the source MAC and the destination MAC.
The Ethernet telegram is identified as Beckhoff real-time Ethernet by the Ethertype 0x88A4. As a real-time Ethernet telegram (RT Ethernet) it bypasses the regular Windows TCP stack and is sent with higher priority, i.e. "immediately", via the specified Ethernet port of the PC.
An option is available for configuring whether the sent telegram is received by all (broadcast), many (multicast) or a single subscriber (unicast).
▪
UDP/IP: The recipient is identified via an additional IP header in the Ethernet telegram. The UDP Ethernet frame can thus be further processed via a router.
Once again, broadcast, multicast and unicast are available as options. The Ethernet telegram is identified as Beckhoff real-time Ethernet through the Ethertype 0x88A4 and treated as an RT protocol in the TwinCAT PC.
In contrast to TCP, as a connection-less protocol UDP requires no acknowledgement of receipt for the message, i.e. the publisher does not know whether the subscriber has received the message. The ARP protocol is therefore used for remote terminal monitoring in TwinCAT.
The telegram with the process data arrives at the recipient device (network port) via these addressing modes. In the Ethernet device/TwinCAT several transported process data are allocated via a variable ID
All network variables must be declared in the System Manager before they can be used.
The following intervention options are then available during operation:
▪
Sending of a configured network variable can be blocked dynamically
▪
The destination IP or destination MAC can be changed dynamically
▪
The variable ID "variable ID" can be changed dynamically
▪
The NWV content can be changed, but not the size (bit size)
Diagnostic variables on the publisher and subscriber side provide information about the connection quality.
If network variables are used, the temporal boundary conditions for the network topology used must be taken into account: In switched mode (MAC addressing) communication cycles of approx. 10 ms and below can be achieved, in routed mode (IP addressing) a few 100 ms may be achievable in some cases.
Diagnostic variable "quality"
If the processing tasks operate with different cycle times or the user changes the DataExchangeDivider, this must be taken into account in the analysis of the diagnostic variables. In conjunction with a fast Subscriber (e.g. 10 ms), a slow Publisher (e.g. 100 ms) leads to poor connection quality (as reported by the diagnostic variable "Quality").
Dynamic temporary blocking of sending a Publisher must also be taken into account. In this case the Subscriber registers poor quality.
Diagnostic variable "CycleIndex"
Please note the following information in order to decide whether you have to serve the variable CycleIndex.
Basic principles of Beckhoff network variables
▪
Quality:
Time in [100 µs] by which arrival of the NWV at the Publisher was delayed.
Relative arrival location:
Input process image of the TwinCAT system
Relative arrival time:
Time at which the next cycle is loaded into the input image

Note:
The reason for determining the delay so precisely is that the NWVs are managed directly by the IO driver, independent of the cycle. Nevertheless, the data of an NWV that is delayed by a few percent of the cycle time will not be taken into account until the input process image is read during the next task cycle.

Note regarding EL6601/EL6614:
Even with the EL66xx the NWV arrival time is defined as the time when the data are available in the input process image of the RT device, not the time of arrival at the EL66xx or in the input image of the EtherCAT device.
Interrelationship between quality and delayed network variable
▪
Variable ID
The variable ID (16 bit) is used for global identification of the individual process data. Therefore, an ID in the Publisher or Subscriber group may only be used once within a TwinCAT device, see Fig. Example for communication via network variables: Publishers 1 and 2 on PC1 must have different IDs (10 and 8), although the same ID (8) may be used in Publisher 2 and Subscriber 1.
Selecting the variable ID
In order to achieve unambiguous allocation we recommend using different IDs for each data communication between connected PCs.
Reason: In Fig. Example for communication via network variables, PC2/subscriber2 not only receives the designed ID=8-variable from PC1/Publisher2, but, since it is sent as a broadcast (!), it also receives the NWV from PC3/Publisher1. Differentiation is then no longer possible in PC2.
▪
Cycle Index
The 16-bit cycle index is a counter sent by the Publisher together with the data. It is generally incremented with each transmission and can therefore be used as an indicator for flawless transfer. It can be read on the subscriber side as CycleIndex. Its appearance depends on the Publisher platform:
–
Publisher on a PC: The variable CycleIndex is not visible and is automatically and cyclically incremented by the System Manager
–
Publisher on an EL66xx: The variable CycleIndex is visible and must be incremented/served by the user such that it is not equal 0 on the subscriber side.
Example for communication via network variables
Data representation on different platforms
Please note that simple and complex data (WORD, ARRAYs, REAL, STRING, user-defined structures) are represented internally in a different manner on different platforms! x86 platforms use byte-alignment, others (ARM) 2-byte or 4-byte alignment.
This means that if a complex structure is created in an x86/PC PLC project and an ARM PLC project, they can each have a different effective size and a different internal structure.
In Fig. Example for different size and structure in PC and CX, the structure in the CX (and hence the network variable to be created there) is larger than in the PC; also the word and real variables do not match each other because a variable can begin at any byte position in the PC, but only at every even-numbered one in the CX.
Recommendation for structures that are identical on both end devices
- firstly, all 4-byte variables (must lie at an address that is divisible by 4)
- then all 2-byte variables (must lie at an address that is divisible by 2)
- then all 1-byte variables
Further recommendations
- if STRING(x) is used, the "EndOfString" zero is also interpreted as a character, otherwise x+1 must be divisible by 4
- the above rules also apply to sub-structures.
Please refer to the notes in the Structure section of the Infosys.
Use of Bus Terminal Controllers (BCxxxx, BXxxxx)
Since the representation of floating point numbers (REAL) on Bus Terminal Controllers (BCxxxx, BXxxxx) differs from that in the x86, these cannot be transmitted. "SINT", for example, can be used for signed values.
Example for different size and structure in PC and CX
Settings in the System Manager
Appearance of the variables
Depending on the platform used (PC or EL66xx), the publisher/subscriber will appear differently. A Publisher/Subscriber can be created.
•
On a PC network interface, see Fig. Publisher settings - RT Ethernet
•
on an EL66xx, see Beckhoff network variables - Settings
The following settings options are available in the Beckhoff System Manager TwinCAT 2.10 build 1328:
Publisher, Box
Publisher RT Ethernet settings
RT Ethernet settings:
▪
MAC-Broadcast: Sent to all network devices, destination MAC FF:FF:FF:FF:FF:FF.
▪
Multicast: A destination MAC address becomes a multicast address if the first bit in the first byte of the MAC (the so-called group bit) is set. With the Beckhoff ID "00 01 05" the default target address "01 01 05 04 00 00" is formed, as shown in Fig. Publisher RT Ethernet settings.
The MAC range 01:00:5E:00:00:00 to 01:00:5E:FF:FF:FF is intended for general multicast application, with the first 3 bytes specified by the IEEE and the last 3 bytes derived from the lower part of the IP address of the destination PC. The resulting destination MAC therefore never physically exists in the network. Instead, the destination network card detects Ethernet frames formed in this way as multicast frames sent to it, although the Ethernet port itself can have another, unique MAC address. Please refer to the relevant literature for further rules relating to the formation of multicast MAC/IP addresses.
▪
Unicast: Either direct entry of the destination MAC or via the AMS Net ID of the destination device, e.g. 123.456.123.456.1.1, in which case this route must be entered in the local AMS router (right-click on the TwinCAT icon in the taskbar --> Properties --> AMS router)
Use of broadcast and multicast
Network variables sent as broadcast or multicast at MAC or IP level can generate high network load (depending on the cycle time), since they are multiplied into the whole connected network. This may cause simple network devices such as printers to crash. With short cycle times all network traffic may become blocked.
We strongly recommend using unicast addressing, taking into account variable identification, as described above.
Advanced Settings:
▪
Data exchange: The task cycle time * divider is the rhythm at which this network variable is sent. (not for EL66xx)
▪
VLAN support: In conjunction with manageable switches the Ethernet frame parameterized here can be assigned a fixed route via VLAN tagging (Virtual Local Area Network).
Publisher settings - UDP/IP
UDP/IP settings - the addressing technique of the IP network layer with IP addresses is used. UDP is a connection-less protocol without feedback.
▪
Broadcast: Sent to all device with destination IP (v4) 255.255.255.255
▪
Multicast: The destination IP must be specified, see notes on MAC multicast
▪
Unicast: Specify the target device (e.g.: 192.168.0.1), making sure that it can be reached through the subnet mask
Use of broadcast and multicast
Network variables sent as broadcast or multicast at MAC or IP level can generate high network load (depending on the cycle time), since they are multiplied into the whole connected network. This may cause simple network devices such as printers to crash. With short cycle times all network traffic may become blocked.
We strongly recommend using unicast addressing, taking into account variable identification, as described above.
Advanced Settings:
▪
"ARP Retry Interval": In order to ascertain the presence of the recipient, the publisher sends an ARP request to the target device at these intervals. If the network administration of the recipient is operational, it sends an ARP reply. This is only meaningful with unicast.
In the event of an error bit 3 is set (0x0004) in the diagnostic FrameState variable.
Note: ARP handling (ARP = Address Resolution Protocol: allocation of hardware/MAC addresses to network addresses [IP]) is managed by the operating system (Windows).
▪
"Disable Subscriber Monitoring": Deactivates the procedure described above
▪
"Target Address changeable": In this case the destination IP can be changed dynamically
Publisher, Variable
Publisher variable settings
Settings:
▪
"Variable ID": Identification number with which the variable is sent. Can be changed online via PLC where appropriate
▪
"Data exchange": see above (not for EL66xx)
▪
"On change only": NWV is only sent if the value changes (not for EL66xx)
Subscriber, Box
Subscriber settings
Settings:
▪
"Receiving Options": Only permits NWVs from a certain publisher for this subscriber
▪
"Multicast Configuration": ditto
Process data:
▪
"VarId": If activated, the variable ID can be modified online
Subscriber, variable
Subscriber variable settings
Settings:
▪
"Variable ID": Only permits NWVs with a certain ID for this subscriber. Can be changed dynamically via PLC where appropriate
▪
"Ignore Data Type Hash": Hash calculation is currently not supported
Process data:
▪
"Quality": See explanatory notes above
▪
"CycleIndex": This index is incremented with each successful transfer, IF this is done by the opposite side, i.e. the publisher. If the publisher is an EL66x, the user must increment CycleIdx there.
▪
"VarData": Transferred data


Appendix

Appendix
Appendix
Additional information
•
ESL Protocol
•
Firmware Update
•
Firmware compatibility
•
Support and Service


ESL Protocol

Appendix [image] ESL Protocol
ESL Protocol
The EtherCAT Switch Link protocol (ESL) from Beckhoff is a simple extension for the control of EtherCAT infrastructure components. It is currently used (as of 2010) for the operation of the ET2000 Industrial Ethernet Multichannel Probe and the CU2508.
The ESL data consist of 16 bytes of control data and information, which are added as a prefix (in front) or as a postfix (to the end) of an existing Ethernet data frame. The check sum (CRC) is adapted accordingly.
CU2508 ESL prefix
The ESL data are structured as follows:
ESL structure
Ethernet network monitors
The freely available network monitor Wireshark has contained an interpreter for the ESL protocol since the version 1.4.2.


Firmware Update

Appendix [image] Firmware Update
Firmware Update
The CU2508 has 2 different firmware versions, one for the FPGA and one for the controller.
The CU2508 must be operated in a special configuration for the determination of the current firmware version and for updating. It must therefore be removed from the application and is to be operated as an individual EtherCAT device on a TwinCAT system.
The following steps must be carried out in order to update:
1. TwinCAT
On the PC system used for programming, TwinCAT must have at least version 2.11R2 build 2021 or TwinCAT 3.1.
TwinCAT Version
2. ESI/XML description
The current CU2508 ESI/XML data must be present on the system; they can be downloaded from the download area on the Beckhoff web page and are to be saved under …"\ TwinCAT\Io\EtherCAT\".
3. Installation of the CU2508
Connect the CU2508 with its uplink to an Ethernet port on the master PC and connect the power supply. The port must be set up as a real-time port with the Beckhoff TwinCAT driver. The downports X1..8 must not be connected.
CU2508 structure
4. Creating the TwinCAT configuration
The CU2508 must now be added manually as an EtherCAT device. To do this, set up an EtherCAT device and specify the adapter to be used.
Instruction TwinCAT 2:
Open a new System Manager window. This causes the ESI data updated above to be read in again.
Right mouse click, Append device
Selection of the device "EtherCAT"
Selection of the Ethernet adapter
If the adapter you want is not visible, then the Beckhoff real-time driver is not yet installed on this adapter.
Now append the CU2508.
Right mouse click, Append device
If the device name is entered in the search mask (A) the overview is reduced in size. Activate the check boxes "ExtendedInformation" and "ShowHiddenDevices". As a result of this, a previously hidden element, the CU2508 configuration port, becomes visible (in this case: CU2508-0000-0016).
Selection of the CU2508-0000 configuration port
Select this device. The configuration now consists of the “EtherCAT Device” and the single slave CU2508.
Now ensure that the function is correct by restarting TwinCAT (B) in ConfigMode and carrying out ReloadIoDevices (press key F4). If the EtherCAT device is selected (A), the current State OP (D) and Traffic utilization (E) are displayed in the Online tab (C). Approx. 250 CyclicFrames per second are usual in the ConfigMode with a 4 ms cycle time; no lost frames or TXRXErrors may occur.
Online configuration
Instruction TwinCAT 3:
The procedure is the same as for TwinCAT 2: add the "CU2508 Configuration Port" to the selected EtherCAT adapter.
Append Configuration Port
Then check that it is operating correctly:
▪
No Lost frames
▪
State:OP
Check for lost frames and State: OP
5. Reading out the current ESI/FW version
On the basis of fig. Online configuration, EtherCAT ESI revision, controller and FPGA-FW can now be checked.
ESI Revision
When the system is running in ConfigMode, the revision found can be displayed by scan:
Display revision after scan
If the connected CU2508 carries a different revision, the following is displayed:
Display different revision
Controller firmware (*.efw)
Select device CU2508 (A); the online CoE directory of the device is displayed in the CoE-Online tab (B); the firmware version (in this case 01) is displayed in the index 0x100A (D). Note that in (C) “OnlineData” (green) is displayed.
Reading out the controller firmware version
FPGA firmware (*.rbf)
Select device CU2508 (A); press Advanced Settings ... (C) in the EtherCAT tab (B). There, select Memory (D) and read out the data starting from StartOffset 0E00 (E).
If the function is correct, the firmware version (here: 12) can be read at position x0E00 (F) and 2508dec at position x0E06.
Reading FPGA firmware
6. Firmware and ESI Update
On the basis of fig. Online configuration, if communication is working perfectly, an update of ESI, controller and FPGA firmware can be performed by right-clicking on the CU2508 device.
Update by right-clicking
ESI/XML- update
The ESI *.xml can also be overwritten by "EEPROM Update". Then select and program the corresponding XML revision of the "CU2508 Configuration Port".
Select XML revision
Display of the revision CU2508 slaves
Only the ConfigurationPort of the CU2508 is described with an updated ESI, if necessary. This is used to set some of the CU2508's properties. The CU2508 slaves running in regular EtherCAT operation always report with revision 0000 and cannot be programmed separately.
Display of the revision -0000
FW Update
The firmware is ideally downloaded to the CU2508 in bootstrap mode.
Update in Bootstrap Mode
FPGA update
The FPGA firmware is loaded by right clicking, this can take a few seconds.
Update FPGA firmware
A TwinCAT3 message window then appears:
Message window FPGA Update
The CU2508 must then be briefly switched to the de-energized state.


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
Beckhoff EtherCAT devices are delivered with the latest available firmware version. Compatibility of firmware and hardware is mandatory; not every combination ensures compatibility. The overview below shows the hardware versions on which a firmware can be operated.
Note
▪
It is recommended to use the newest possible firmware for the respective hardware
▪
Beckhoff is not under any obligation to provide customers with free firmware updates for delivered products.
Note
Risk of damage to the device!
Pay attention to the instructions for firmware updates on the separate page.
If a device is placed in BOOTSTRAP mode for a firmware update, it does not check when downloading whether the new firmware is suitable.
This can result in damage to the device!
Therefore, always make sure that the firmware is suitable for the hardware version!
CU2508
Hardware (HW) | Firmware (FW) | Revision no. | Date
00 - 07* | 01 | CU2508-0000-0016 | 2011/01
 | 02 | CU2508-0000-0017 | 2011/03
 | 03 |  | 2012/05
 | 04 |  | 2013/01
 | 05 |  | 2013/01
 | 06 |  | 2014/10
 | 07 | CU2508-0000-0018 | 2015/08
 | 08 |  | 2016/02
 | 09 |  | 2016/06
 | 10 |  | 2017/05
 | 11 |  | 2019/08
 | 12* | CU2508-0000-0019 | 2019/10
*) This is the current compatible hardware version at the time of the preparing this documentation. Check on the Beckhoff web page whether more up-to-date documentation is available.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com