EK15xx - EtherCAT media converter

BECKHOFF Fieldbus components

Documentation for

CU1521 - EtherCAT media converter multimode fiber optic

CU1521-0010 - EtherCAT singlemode fiber optic

CU1561 - EtherCAT media converter fiber optic (POF)

Version 1.1
Date 2013-02-22

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to environment and devices
If you do not adhere the notice adjoining this symbol, there is obvious hazard to environment and devices.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.
UL Pointer
This symbol indicates important information about the UL-compliant.


CU15x1 - Documention issue status

BECKHOFF CU15x1: Foreword

Documention issue status

Version | Comment
1.0 | - Update chapter "Application notes"
1.0 | - minor corrections, 1st public issue
0.3 | - addenda
0.2 | - addenda
0.1 | - preliminary version


Version identification

BECKHOFF: Foreword

Version identification of EtherCAT devices

Designation

A Beckhoff EtherCAT device has a 14-digit designation, made up of

  • family key
  • type
  • version
  • revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017

Notes

  • The order identifier is made up of
    - family key
    - type
    - version
  • The revision indicates the technical progress and is managed by Beckhoff.
    In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise.
    Each revision usually has an associated XML description (ESI, EtherCAT Slave information), which is available for download from the Beckhoff webpage.
  • Type, version and revision are read as decimal numbers.

Serial number

Beckhoff EtherCAT devices usually have an 8-digit serial number, which is printed on the device or attached to it on a sticker. This serial number indicates the construction condition on delivery.

Syntax of the serial number

Structure of the serial number: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 06 3A 02:

12 - week of production 12
06 - year of production 2006
3A - firmware version 3A
02 - hardware version 02

Examples of serial number data

Fig. 1: EL6688 EL Terminal

Fig. 2: CU2016 Switch

Fig. 3: EK1100 EtherCAT coupler


CU15x1 - Product overview

BECKHOFF CU15x1: Product overview

Introduction

The EtherCAT-capable CU1521, CU1521-0010 and CU1561 devices should be used as media converter for industrial fast Ethernet/100 Mbaud from optical fiber to copper and vice versa.

From the physical layer perspective the CU1521 is suitable for multimode, while the CU1521-0010 is suitable for single mode optical fiber and therefore for significantly longer transmission links up to 20 km.
The CU1561 is used for interfacing with POF (plastic optical fiber), which are suitable for small-scale machine installation thanks to relatively inexpensive cable material and field-configurability.

The media converter operates bidirectionally and collision-free. The CU15x1 devices are therefore also suitable as media converters for any Ethernet traffic. They support “Link Loss Forwarding”, which means that, if the link fails at the outgoing strand, for example due to a broken wire, the link is also withdrawn from the incoming line, so that the sending device is notified of the link loss.

The CU15x1 devices are characterized by the fact that they support the requirements of an EtherCAT network for a converter particularly well. This includes fast link control (establishment and disconnection), diagnosis of communication errors, constant frame deceleration and readable identity (no transparent operation). If the CU15x1 is set to EtherCAT mode with the rotary switch, it can be diagnosed as a separate EtherCAT device. Hence, as opposed to standard media converters, he also ensures fast link control and thus the secure termination of an EtherCAT strand even in the event of a disruption. Since the transfer direction (copper Þ optical fiber or optical fibers Þ copper) is relevant for the EtherCAT bus, the operating direction can be configured via the rotary switch.

The CU15x1 are useful in applications where EtherCAT transfers over large distances are required or where higher EMC loads on the bus line are to be expected.

Quick links

• EtherCAT function principles
• Application notes
• Diagnostic LEDs


CU15xx - Technical data

BECKHOFF CU15x1: Product overview

Technical data

Technical data | CU1521 | CU1521-0010 | CU1561
Function Ethernet "IP" | Media converter Fast Ethernet/100Mbaud (all IEEE 802.3-based protocols) IEEE 802.3u auto negotiation, half or full duplex, automatic settings Link Loss-Forwarding (notification direction configurable) Store and Forward Mode (FIFO) unmanaged
Function EtherCAT "EC" | Media converter Fast Ethernet/100Mbaud Cut-through mode Port handling/link control
Number of Ethernet ports | 2
Ethernet interface X1 | 100BASE-FX multimode glass fiber 50/125 µm (MM) typically 1300 nm 2 x SC Duplex | 100BASE-FX single mode glass fiber 9/125 µm (SM) typically 1300 nm 2 x SC Duplex | 100BASE-FX-POF glass fibre 980/1000 µm (POF); typically 650 nm 2 x versatile link for POF duplex connector (connector set ZS1090-0008) Laser class 1, see note
Ethernet interface X2 | 10BASE-T/100BASE-TX Ethernet/EtherCAT cable (min. CAT 5), screened RJ45
Cable length X1 max. | max. 2 km (100BASE-FX) | max. 20 km (100BASE-FX) | max. 50 m (100BASE-FX-POF)
Cable length X2 max. | up to 100 m twisted pair CAT5 (e)
Diagnostics | LED: Supply voltage, link/activity X1/X2 EtherCAT: CRC
Power supply | via three-pole spring loaded terminal (+, -, PE)
Supply voltage | 24 VDC (18 VDC to 30 VDC), reverse polarity protected.
Current consumption | typ. 95 mA | typ. 80 mA | typ. 60 mA
Weight | approx. 105 g
Dimensions without connector (W x H x D) | approx. 34 x 98 x 77 mm
Mounting | on 35 mm DIN rail (mounting rail according to EN 50022)
Permissible ambient temperature range during operation | 0°C... + 55°C
Permissible ambient temperature range during storage | -25°C... +85°C
Permissible relative humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP 20
Installation position | variable
Approval | CE


EtherCAT - EtherCAT basics

BECKHOFF EtherCAT: Basics communication

EtherCAT basics

Please refer to the chapter EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabeling

BECKHOFF EtherCAT: Basics communication

EtherCAT cabling – wire-bound

The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.

Cables and connectors

For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.

EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).

Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -

Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

Note 		Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!

E-Bus supply

A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9400) must be inserted at appropriate places in the terminal strand.

The pre-calculated theoretical maximum E-bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.

Fig. 1: System manager current calculation

Attention 		Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EtherCAT State Machine

The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.

A distinction is made between the following states:

  • Init
  • Pre-Operational
  • Safe-Operational and
  • Operational
  • Boot

The regular state of each EtherCAT slave after bootup is the OP state.

Init

After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.

Pre-Operational (Pre-Op)

During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.

In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.

Safe-Operational (Safe-Op)

During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).

In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.

Operational (Op)

Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.

In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.

Boot

In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.

In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


EtherCAT - CoE Interface

BECKHOFF EtherCAT: Basics communication

CoE-Interface

This device has no CoE.

Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Dimensions

Note 		Space requirement in the control cabinet
  • The RJ45 connector increase the depth depending on their design and the Ethernet cable used.
  • Above the mounting rail an additional height of approx. 10 mm is required to enable latching of the switch onto the rail.

CU1521-00x0

CU1561


CU15xx - Mounting and demounting

BECKHOFF CU15xx: Mounting and commissioning

Assembly and Removal

The CU15xx converters are mounted on the mounting surface with the aid of a 35 mm DIN rail (according to EN 50022).

Mounting
  • Fit the mounting rail to the planned assembly location.
  • Position the converter in the mounting rail with the spring at the top of its latching flange (1)
  • Push the lower side of the converter (2) against the mounting surface until it latches on the mounting rail.
  • Attach the cable.

Removal
  • Remove all the cables.
  • Pull the strap on the underside of the converter (1) downwards with a screwdriver
  • Pull the converter upwards away from the mounting surface (2)


Terminal Modules - Recommended mounting rails

BECKHOFF Terminal Modules: Mounting and wiring

Recommended mounting rails

Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series can be snapped onto the following recommended mounting rails:

  • DIN Rail TH 35-7.5 with 1 mm material thickness (according to EN 60715)
  • DIN Rail TH 35-15 with 1,5 mm material thickness

Note 		Pay attention to the material thickness of the DIN Rail
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series does not fit to the DIN Rail TH 35-15 with 2,2 to 2,5 mm material thickness (according to EN 60715)!


CU15x1 - Application notes

BECKHOFF CU15xx: Commission/Application notes

Application notes

Table of contents
• Standard Ethernet
• EtherCAT
• Earthing/Shielding
• Firmware update
• General notes

The media converters CU1521, CU1521-0010, CU1561 (referred to as CU15x1 below) physically convert 10/100 Mbit Ethernet telegrams (FastEthernet) from copper physics (RJ45 connector) to optical fiber (SC connector or versatile link) and back.
Special behavior is expected from the converter, depending on whether EtherCAT or standard Ethernet telegrams are to be transferred.

Used for: Standard Ethernet 10/100MBit

An Ethernet connection is a managed point-to-point connection between two intelligent end devices.

Fig. 1: Point-to-point connection between two Ethernet devices

Both devices send a so-called idle sample to their Ethernet connection. The link has been established if a corresponding sample is received. Both devices then know that they can use this connection. If the connection is interrupted, the link is lost and both devices are notified.

Fig. 2: Interrupted point-to-point connection

If a media converter is placed between the two stations, it too becomes an intelligent transmitter/receiver. If connection C is interrupted, device A would not necessarily be informed and would continue to send data to the converter via the existing link B, and the data would "trickle away". The CU15x1 therefore supports Link Loss Forwarding (LLF) in a selected direction. The notification is indicated by a label on the CU15x1. If the converter detects an interruption of connection C in switch setting 1 in Fig. 3, it also interrupts link B.

Fig. 3: Interposed media converter in the Ethernet connection

In both IP settings the CU15x1 operates as a store and forward network device with checksum function. Frames that are faulty (CRC error), too short (< 64 bytes) or too long (> 1536 bytes) are not passed on.

Used for: EtherCAT 100MBit

Other characteristics are required if it is used as a media converter in an EtherCAT network:

  • Consistently low delay in the frame transit, irrespective of frame length
  • Fast link detection when the connection is established and interrupted
  • Identification as separate EtherCAT device with diagnostic function

EtherCAT slaves process the EtherCAT telegrams in forward direction from the perspective of the master. Accordingly, in the CU15x1 the forward direction may be X1 --> X2 or X2 --> X1, depending on the application. It has to be set at the rotary switch prior to commissioning. The direction of the arrow of S1 indicates the set forward direction.

Fig. 4: Setting the forward direction at the media converter

Make sure the rotary switch is set to the right position, so that the CU15x1 operates in forward direction. For example, in Fig. 5 the CU15x1 on the left operates as a copper --> optical fiber converter (rotary switch position 5), the CU15x1 on the right operates as an optical fiber --> copper converter (rotary switch position 0).

Fig. 5: Copper -> optical fiber-> copper operation of two media converters

If the opposite direction of rotation is set, the subsequent behavior depends on the EtherCAT master. The scanned CU15x1 may be inserted at a different position in the topology, or an INIT_VPRS error message of the EtherCAT master may occur.

Earthing/Shielding

The FE contact of the supply connector is directly connected with the mounting rail contact. During assembly, always take care of a conductive connection to the mounting rail.

Fig. 6: internal shielding concept

Firmware update

A firmware update via EtherCAT is not possible for devices of the CU15x1 series

General notes

The CU15x1 deals with setting the rotary switch when the supply voltage is applied, unless the rotary switch is in an invalid position. In this case the CU15x1 deals with the setting when the rotary switch reaches a valid position for the first time.

If the rotary switch is moved during valid operation, the CU15x1 does not alter its function but indicates this state through its LED, see Diagnostics. The switch setting must be rectified before the voltage is re-applied!

Fig. 7: Rotary switch

Slanting installation of the optical fiber socket in the CU15x1 reduces the bending radius of the optical fiber cable during connection in the control cabinet (fig. 7).

Fig. 8: Slanting installation of the optical fiber socket


CU1521, CU1521-0010 - Application notes

BECKHOFF CU1521, CU1521-0010: Application notes

Application notes

Contents
• Mounting rail installation
• Notes on suitable optical fiber cables

• Connecting and disconnecting the fiber cable

Mounting rail installation

Note 		Mounting
Please ensure that the CU15x1 engages properly on the DIN rail.

See Mounting rail installation or Recommended mounting rails

Notes on suitable optical fiber cables

General information on optical fiber types

Optical fiber are available as multimode and single mode types with different step and graded indices.

Step and graded index

Optical fiber cables consist of 2 concentric materials, the core and cladding, plus a protective (colored) jacket. The core and the cladding have a different index of refraction, causing the light waves (modes; a mode is a natural wave in the optical fiber) to be reflected back into the core at the boundary. Due to the step change in the index of refraction this type of fiber is referred to as step index. A gradual/parabolic transition between the index of refraction in the core and the coating (referred to as graded index) can be achieved by mixing the materials. In a graded index fiber the modes are gradually diffracted back to the core, leading to propagation-time compensation and significantly higher quality of the light pulse at the outlet compared with a multimode step index fiber, where the different light modes have different signal run times (mode dispersion) with associated front distortion.

Singlemode

Single mode fiber cables have a very thin core (9 µm) and therefore only conduct a single light mode with high signal quality and almost without mode dispersion. They are only available as step index fibers. Due to the high signal quality they are suitable for large transmission bandwidths > 10 GHz*km and distances > 50 km. The refractive index profile of single-mode fibers is dimensioned such that the multipath propagation (intermodal dispersion), which is a problem with multi-mode fibers, is omitted – the signal light propagates in a single-mode fiber only in a single guided fiber mode, hence the designation ‘single-mode’. This makes considerably larger transmission distances and/or bandwidths possible, and the limiting effect that arises next is the colour distortion of the transmitted mode.

Multimode

Multimode optical fiber cables are produced as step index or graded index cables. Step index multimode fiber cables are suitable for transmission bandwidths up to 100 MHz*km and distances up to 1 km. Graded index multimode fiber cables with core diameters between 50 and 62.5 µm reach transmission bandwidths > 1 GHz*km and ranges > 10 km. Multimode means that the core of the optical fiber cable is thick enough to enable several light modes to propagate reflectively in the cable.

Application with CU1521, CU1521-0010

The CU1521, CU1521-0010 are intended for application with optical fiber cables with the following characteristics:

  • SC duplex connector
  • CU1521: Duplex multimode 50/125 µm or 62.5/125 µm (inner/outer core diameter). The use of both diameters is possible. However, the use of 50/125 µm is recommended due to the lower attenuation.
    Multimode means that the core of the optical fiber cable is thick enough to enable several light modes to propagate reflectively in the cable.
  • CU1521-0010: Duplex singlemode 9/125 µm (inner/outer core diameter). A typically usable cable can be manufactured according to the specification ITU-T G.652.D (0.4dBm/km at 1300nm).

Note 		Recommended connectors
The use of SC/PC connectors is recommended for connecting to the CU1521, CU1521-0010. The advantage of the "PC" (physical contact) version of this connector is the crowned end face, which allows the region of the fiber core that is relevant to transmission to be optimally joined when the connector is pushed together. Other versions include, for instance, the SC/UPC (ultra-polish PC), SC/HRL (high return loss) and the SC/APC plug (angled physical contact).
An additional feature of these connectors is that light that is reflected by the connector's end face, which is at an angle of about 8° to the fiber axis, is refracted from the core by the cladding glass into the air. This avoids interference with the data transmission, optimizing the core size of the back-scatter.

In the glass fiber wavelengths of 850 and 1300 nm are usually used for data communication. Commercially available optical fiber cables are usually optimized for application in one of these ranges, since signal attenuation is frequency-dependent (like in copper cable), so that large ranges of several km can be achieved for the respective wavelength. Optical fiber cables in the 1300 nm window generally have lower attenuation than cables in the 850 nm window.

In the CU1521, CU1521-0010 a transceiver with the wavelength of 1300 nm is used.

Note 		Range and bandwidth product
Optical fiber cables are available in different qualities from well-known manufacturers. One of the relevant parameters for the user is the frequency-dependent bandwidth product of a cable, specified in [MHz*km]. The greater the bandwidth product, the lower the attenuation, and therefore the range increase with this cable (see ITU-T G-651).

To maximize the range with the CU1521, CU1521-0010 optical fiber cables with a maximum high bandwidth product at 1300 nm should therefore be used. We recommend optical fiber cables from the OM2 class (EN50173:2002).

Standard optical fiber cables have a minimum bandwidth product of 500 MHz*km at 1300 nm, higher-quality cables are suitable for distances > 500 m over > 1000 MHz*km.

For maximum distances the remote counterpart of the CU1521, CU1521-0010 should also support such ranges.

Note 		Installation notes
The following parameters must be taken into account in the installation of optical fiber cables
  • permitted bending radius
  • permitted tensile strength
  • sensitivity of the exposed contact ends

Further information can be found in the following documents:

  • ITU Recommendation ITU-T G.651 - G.655
  • EN 50173:2002
  • EN 60793-2

Connecting and disconnecting the fiber cable

Attention 		Mechanical damage to optical fiber cable possible!
To disconnect the optical fiber cable always pull the connector to release the locking mechanism - never pull the optical fiber cable itself.

Note 		Crossed cables
Please note that under certain circumstances it is essential to use crossed fiber cables to establish a connection between the CU1521, CU1521-0010.

Practical notice:

It is possible to visualize the emitting infrared light from the coupler or junction e.g. with a digital-/mobile phone camera (see fig. 1).
Please ensure that the light emitting SC plugs are connected to the non light emitting sc plugs (Tx -> Rx). Otherwise, no connection can be established. In this case, you have to cross the cables.

Fig. 1: Visualization of infrared light at the SC duplex plug

Note 		Usage of blind plugs
To protect the transceiver against environmental influences, you should closed unused SC connectors with the provided blind plugs!

Fig. 2: Closing unused SC connectors with blind plugs


CU1561 - Application notes

BECKHOFF CU1561: Application notes

Application notes

Contents
• Mounting rail installation
• Notes on suitable POF cables
- General information on POF cable
- Application with CU1561

• Connecting and disconnecting the POF cable

Mounting rail installation

Note 		Mounting
Please ensure that the CU 15x1 engages properly on the DIN rail.

See Mounting rail installation or Recommended mounting rails

Notes on suitable POF cables

General information on POF cables

The standard polymer fiber is 1 mm thick and consists of a 0.98 mm thick core made of polymethyl methacrylate (PMMA) as well as a thin sheath. In order to enable the guidance of light using the effect of total reflection in the core, the usually very thin sheath consists of fluorinated PMMA, which has a low refractive index. The core diameters lie between 0.06 and 1 mm, as a result of which simple plug connections are easy to implement. Furthermore, the splicing process often used for the connection of glass fibres and the unnecessarily high expenditure associated with it can usually be dispensed with. The maximum operating temperature of standard POF is approximately 60 °C and has a refraction profile with step index (SI-POF). The refractive index of the core material is around 1.49 and that of the sheath around 1.41. The difference determines the numerical aperture (NA) and thus the maximum propagation angle. With a difference of 5% this angle is about 20 degrees in relation to the fibre axis, which leads to a reduction in the bandwidth.

Due to the simple and almost universally applicable connection techniques compared to glass fibers, POFs are used in particular for short transmission distances, such as inside rooms, technical equipment, mechanical systems or cars.

POFs have an attenuation of about 140 dB/km at a wavelength of 650 Nm, so that a maximum data transmission distance of 50 m can be achieved when used with the CU1561.

If additional plug connections are necessary in the transmission line, the signal attenuation increases. The maximum permitted transmission line length decreases by typ. 6.5 m per additional connector.

Application with CU1561

Note 		Recommended plug connectors and POF cables
For the connection of the CU1561 it is recommended to use the connector set ZS1090-0008 (Versatile Link Duplex plugs) in conjunction with a duplex polymer fiber with an outside diameter of 2 x 2.2 mm (Z1190), which are available from Beckhoff.

Note 		Installation notes
Among other things, the following items should be observed when laying POF cables:
  • permissible bending radius (in general r ≥ 25 mm, refer to the manufacturer’s data!)
  • permitted tensile strength
  • sensitivity of the exposed contact ends

Connecting and disconnecting the POF cable

To connect the cable, insert the plug (available as an accessory in the connector set ZS1090-0008) into the connection opening until it audibly latches.
The latching lug with the release catch is thereby located on the right-hand side of the plug (see fig. 1)

Fig. 1: Latching lug with release catch on the POF duplex plug

Attention 		Risk of damage to the cable!
To release the cable, press the release catch on the plug and pull the plug at the same time – never pull by the POF cable alone!

Attention 		Tx / Rx channel assignment
During the POF cable harnessing, take care about the assignment of the optical channels of the POF socket.
The light emitting transmitter channel (Tx) of the CU1561 is the top outlet of the POF socket (fig. 2).

Fig. 2: Transmitter channel of the CU1561

Please pay attention to the Safety Instructions concerning the Class1 Laser!

Attention 		Use of blanking plugs
In order to avoid accidents due to glare (Class 1 laser, please observe the safety instructions) and to protect the transceiver against environmental influences, unused sockets should be sealed using the blanking plugs provided (fig. 3)!

Fig. 3: Blanking plugs in unused sockets


Fiber optic application notes

BECKHOFF EK15xx: Commisssioning

Termination guide for ZS1090-0008 (Duplex connector set for POF)

Contents
• Step-by-Step Polymeric Cable Connectoring Instructions
1. Stripping the fiber
2. Putting on the connector
3. Trimming and polishing
4. Finishing

Fig. 1: Duplex connector set ZS1090-0008

The Duplex Connector Set ZS1090-0008 consist of 10 Duplex Versatile Link Connectors and a couple of 600 grit abrasive paper and 3 µm pink lapping film.

Step-by-Step Polymeric Cable Connectoring Instructions

The following step-by-step guide describes how to terminate polymeric fiber optic cable. Connectors can be easily installed on cable ends with standard tools such as wire strippers and cutters. Finishing the cable is accomplished with a Polishing Kit (included with the Duplex connector set ZS1090-0008), consisting of a three hole polishing fixture, 600 grit abrasive paper and 3 µm pink lapping film. The connector can be used immediately after polishing. The following materials are needed for polymeric fiber termination:

1. Polymeric optical fiber cable (Example: Z1190 from Beckhoff)
2. Wire cutters or scissors
3. Wire stripper
4. Polishing Kit (included with Duplex Connector Set ZS1090-0008)
5. Versatile Duplex Connectors (included with Duplex Connector Set ZS1090-0008)

1. Stripping the fiber

The cable should be separated a minimum of 100 mm (4 in) to a maximum of 150 mm (6 in) back from the ends to permit connectoring, polishing and cable end flexibility.

After cutting the cable to the desired length, strip off approximately 7 mm (0.3 in) of the outer jacket of the single core with the wire stripper.

The separated duplex cable should be stripped to roughly equal lengths on each cable end (fig. 2).

Fig. 2: Stripped POF cable

2. Putting on the connector

Place the connector on each end of the fiber, and slide the connector down until the fiber jacket stops it. The fiber should protrude no less than 1.5 mm (0.06 in) from the end of the connector (fig. 3).

Manually press connectors together. The connectors are secured when top halves latch into the ferrule halves (fig. 4).

Fig. 3: Inserted cable in connector

Fig. 4: Secured connector

During insertion of the fiber into the connector, make sure that the orientation of the connector is correct (fig. 5). So you make sure that the optical channels are connected correctly (Tx1 --> Rx2; Tx2 --> Rx1).

Fig. 5: Correctly connected optical channels

3. Trimming and polishing

Any fiber in excess of 1.5 mm (0.06 in) protruding from the connector end should be cut off with wire cutters or scissors.

Insert the connector fully into the polishing fixture with the trimmed fiber protruding from the bottom of the fixture (fig. 6). This plastic polishing fixture can be used to polish one or two simplex connectors or one duplex connector.

Fig. 6: Polishing fixture with the trimmed fiber

Note 		Wear indicators
The four dots on the bottom of the polishing fixture are wear indicators. Replace the polishing fixture when any dot is no longer visible.

Now press the polishing tool down on the 600 grit abrasive paper. Polish the fiber using a figure eight pattern until the connector is flush with the bottom of the polishing fixture (fig. 7). Wipe the connector and fixture with a clean cloth or tissue.

Fig. 7: Polishing the fiber using a figure eight pattern

4. Finishing

Place the flush connector and polishing fixture on the dull side of the 3 μm pink lapping film and continue to polish the fiber in the same figure eight pattern for approximately 25 strokes. The fiber end should be flat, smooth and clean.

Note 		Improvement of coupling performance
Use of the pink lapping film fine polishing step results in up to 0,5 dB improvement in coupling performance of either a transmitter-receiver link or a bulkhead/splice over a 600 grit polish alone. The fine polishing step may be omitted for short link lengths.

Fig. 8: Full finished fiber in connector


CU15x1- Diagnosis LEDs

BECKHOFF CU15x1: Error handling and diagnosis

Diagnosis LEDs

Pin assignment CU1521, CU1521-0010, CU1561

LEDs for fieldbus diagnostics/power supply

LED | Color | Display | State | Description
L/A (X1) green (x2) | green | off | - | no connection on the EtherCAT strand
 |  | on | linked | EtherCAT device connected
 |  | flashing | active | Communication with EtherCAT device
Power | green | off |  | No supply voltage
 |  | on |  | 24 V supply voltage present

LED diagnostics EtherCAT state machine

LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT state machine: INIT = terminal initialization
 |  | Single flash | State of the EtherCAT state machine: PREOP = function for mailbox communication and different standard-settings set
 |  | flashing | State of the EtherCAT state machine: SAFEOP = verification of the sync manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | State of the EtherCAT state machine: OP = normal operating state; mailbox-and process data communication is possible
 |  | flickering | State of the EtherCAT state machine: BOOTSTRAP = function for terminal firmware updates
 | orange | on | CU15x1 is in EtherCAT mode, rotary switch was moved during operation Remedy: Resetting or voltage reset
 | red | on | CU15x1 is in Ethernet mode, rotary switch was moved during operation Remedy: Resetting or voltage reset
 | red/green | flashing | Invalid rotary switch position after power-on Remedy: Move rotary switch to valid position


Safety instructions and behavioural rules for Class 1 laser

CAUTION 		Class 1 laser product – danger of accident due to glare!

The following laser-specific behavioural rules are to be followed for the Class 1 laser products described in this document:

  • The laser beam may not be directed toward persons, since accidents may be caused by glare.
  • Do not look into the direct or reflected beam.
  • If laser radiation meets the eye, the eyes must be consciously closed and the head turned away from the beam immediately.
  • When using the laser, no optical instruments may be used to view the radiation source, since this can lead to exposure limit values being exceeded.
  • Manipulations (modifications) of the laser device are not permitted.


UL Requirements

BECKHOFF EKxxxx, ELxxxx: Appendix

UL notice

Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
For devices with Ethernet connectors
Not for connection to telecommunication circuits.

Basic principles

Two UL certificates are met in the Beckhoff EtherCAT product range, depending upon the components:

  • UL certification according to UL508
    Devices with this kind of certification are marked by this sign:

  • UL certification according to UL508 with limited power consumption
    The current consumed by the device is limited to a max. possible current consumption of 4 A. Devices with this kind of certification are marked by this sign:

Almost all current EtherCAT products (as at 2010/05) are UL certified without restrictions.

Application

If terminals certified with restrictions are used, then the current consumption at 24 V DC must be limited accordingly by means of supply

  • from an isolated source protected by a fuse of max. 4A (according to UL248) or
  • from a voltage supply complying with NEC class 2.
    A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2 compliant voltage supply!

These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.


EK1122, EK15xx - Firmware Kompatibilität

BECKHOFF CU15xx: Appendix

Firmware compatibility

The media converters CU15x1 have no firmware.


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.

Table of contents
• Storage locations
• Device description ESI file/XML
• Frimware version definition
• Updating Controller firmware *.efw
• FPGA firmware update *.rbf
• Multiple update

Storage locations

An EtherCAT slave stores operating data in up to 3 locations:

  • Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
  • In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
  • In addition each EtherCAT slave has a memory chip for storing its own device description, a so-called EEPROM. On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at http://www.beckhoff.com . All ESI files (EtherCAT Slave Information) are available in ZIP format.

Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.

The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.

Attention 		Risk of damage to the device!
Note the following when downloading new device files
  • Firmware downloads to an EtherCAT device must not be interrupted
  • Flawless EtherCAT communication must be ensured. CRC errors or Lost Frames must be avoided.
  • The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.

Device description ESI file/XML

Attention 		Notice regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.

The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:

Fig. 1: Device identifier consisting of name EL3204-0000 and revision -0016

The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Generally the configured revision must be equal or lower than the version used in the terminal network.

For further information please refer to the EtherCAT System Documentation.

Note 		Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device.
Corresponding updates should only be carried out in consultation with Beckhoff support.

Display of ESI slave identifier

The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/Freerun:

Fig. 2: Scan the subordinate field by right-clicking on the EtherCAT device in Config/FreeRun mode

If the found field matches the configured field, the display shows

Fig. 3: Configuration is identical

otherwise a change dialog for entering the actual data in the configuration.

Fig. 4: Change dialog

In the example shown in Fig. 4. an EL3201-0000-0017 was found, while an EL3201-0000-0016 had been configured. In this case it makes sense to adapt the configuration with the Copy Before button. The Extended Information checkbox must be set in order to have the revision displayed.

Changing the ESI slave identifier

The ESI/EEPROM identifier can be updated as follows under TwinCAT:

  • The EtherCAT communication with the slave must be flawless.
  • The state of the slave is irrelevant.
  • Right-click on the slave in the online display to bring up the EEPROM Update dialog, Fig. 5

Fig. 5: EEPROM Update

Select the new ESI description in the following dialog, see Fig. 6. The ShowHiddenDevices checkbox also shows older, usually hidden slave versions.

Fig. 6: Selecting the new ESI

A progress bar in the System Manager shows the progress. Data are first written, then verified.

Note 		The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on.
The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.

Determining the firmware version

Determining the version on laser inscription

Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 10 03 02:

12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02

Determining the version via the System Manager

The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).

Note 		CoE Online and Offline CoE
Two CoE directories are available:
  • online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave does supported it.
    This CoE directory can only be displayed if a slave is connected and operational.
  • offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE.
    This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").

The Advanced button must be used for switching between the two views.

In Fig. 7 the firmware version of the selected EL3204 is shown as 03 in CoE entry x100A.

Fig. 7: Display of EL3204 firmware version

In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.

Updating controller firmware *.efw

Note 		CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.

To update the controller firmware of a slave switch to tab Online, see Fig. 8.

Fig. 8: Firmware Update

Proceed as follows, unless instructed otherwise by Beckhoff support.

  • Switch slave to INIT (A)
  • Switch slave to BOOTSTRAP
  • Check the current status (B, C)
  • Download the new *efw file
  • After the download switch to INIT, then OP
  • Switch off the slave briefly

FPGA firmware *.rbf

If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.

  • Controller firmware for processing I/O signals
  • FPGA firmware for EtherCAT communication (only for terminals with FPGA)

The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.

Determining the version via the System Manager

The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.

The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.

Fig. 9: FPGA firmware version definition

If the column Reg:0002 is not displayed, right-click the table header and select Properties... in the context menu.

Fig. 10: Context menu Properties

The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.

Fig. 11: Dialog Advanced Settings

Update

For updating the FPGA firmware

  • of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
  • of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.

Older firmware versions can only be updated by the manufacturer!

Updating an EtherCAT device

In the TwinCAT System Manager select the terminal whose FPGA firmware you want to update (in this example terminal 5: EL5001) and
click on Advanced Settings in the EtherCAT tab.

Fig. 12: Select dialog Advanced Settings

The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button,

Fig. 13: Select dialog Write FPGA

select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device.

Attention 		Risk of damage to the device!
A firmware download to an EtherCAT device must never be interrupted!

If this process is cancelled, the supply voltage switched off or the Ethernet connection interrupted, the EtherCAT device can only be recommissioned by the manufacturer!

In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.

Simultaneous updating of several EtherCAT devices

The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.

Fig. 14: Multiple selection and firmware update

Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


EtherCAT - General notes for setting the watchdog

BECKHOFF EtherCAT: Basics communication

General notes for setting the watchdog

ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.

The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:

  • SM watchdog (default: 100 ms)
  • PDI watchdog (default: 100 ms)

SM watchdog (SyncManager Watchdog)

The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.

The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.

PDI watchdog (Process Data Watchdog)

If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.

The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.

The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.

Fig. 1 EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog

Notes:

  • the multiplier is valid for both watchdogs.
  • each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
  • Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
    If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.

Multiplier

Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:

1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)

The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.

The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.

Example "Set SM watchdog"

This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0..65535. Together with a multiplier with a range of 1..65535 this covers a watchdog period between 0..~170 seconds.

Calculation

Multiplier = 2498 → watchdog base time = 1 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time

CAUTION 		CAUTION! Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016.
In previous versions this operating mode should not be used.

CAUTION 		CAUTION! Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog!
Set outputs are NOT set in a safe state, if the communication is interrupted.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.