CU112x - EtherCAT-Abzweig und EtherCAT Sternverteiler
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Produktübersicht EtherCAT-Abzweige
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Produktübersicht EtherCAT-Abzweige

Vorwort [image] Produktübersicht EtherCAT-Abzweige
Produktübersicht EtherCAT-Abzweige
CU1123 | EtherCAT-Abzweig 3-fach, RJ45
CU1124 | EtherCAT-Abzweig 4-fach, RJ45
CU1128 | EtherCAT-Sternverteiler


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.1
▪
Neue Titelseite
▪
CU1123 und CU1124 hinzugefügt
▪
Struktur-Update
2.0
▪
Migration
1.0
▪
Ergänzungen
▪
1. Veröffentlichung
0.1
▪
Vorabversion


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät hat eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
CU2016 Switch mit Seriennummer/ Chargennummer
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
CU1123, CU1124 - Einführung
•
CU1123, CU1124 - Technische Daten
•
CU1128 - Einführung
•
CU1128 - Technische Daten


CU1123, CU1124 - Einführung

Produktübersicht [image] CU1123, CU1124 - Einführung
CU1123, CU1124 - Einführung
CU1123, CU1124
EtherCAT Abzweig, 3-fach / 4-fach, RJ45
Linie, Baum oder Stern: EtherCAT unterstützt nahezu beliebige Topologien. Mit dem 3-fach EtherCAT-Abzweig CU1123 und dem 4-fach-EtherCAT-Abzweig CU1124 stehen kompakte Lösungen zur Kaskadierung eines EtherCAT-Netzwerks zur Verfügung. Wenn außerhalb des EtherCAT-Klemmensystems ein Mehrfach-Abzweig benötigt wird, können die, auf der Hutschiene montierbaren, EtherCAT-Abzweige statt des EtherCAT-Kopplers EK1122 und des 8-fach-EtherCAT-Sternverteilers CU1128 genutzt werden.
Port 1 ist der Eingangs-Port für das Netzwerk.
Weitere EK1100-Koppler oder EtherCAT-Box-Module können angeschlossen werden an den Ports
▪
2 und 3 des EtherCAT-Abzweigs CU1123,
▪
2, 3 und 4 des EtherCAT-Abzweigs CU1124.
Der Anschluss erfolgt über RJ45-Buchsen, an denen Link- und Activity-Status direkt angezeigt werden.
In Verbindung mit TwinCAT oder anderen geeigneten EtherCAT-Mastern unterstützen die EtherCAT-Abzweige CU1123 und CU1124 auch das An- und Abkoppeln von EtherCAT-Strängen im laufenden Betrieb (Hot-Connect). Die Geräte sind nicht als Standard-Ethernet-Switch verwendbar.


CU1123, CU1124 - Technische Daten

Produktübersicht [image] CU1123, CU1124 - Technische Daten
CU1123, CU1124 - Technische Daten
Technische Daten | CU1123 | CU1124
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Abzweigen
Übertragungsmedium | Ethernet/EtherCAT-Kabel (min. CAT 5), geschirmt
Businterface | 3 x RJ45 | 4 x RJ45
Länge zwischen Stationen | max. 100 m (100BASE-TX)
Protokoll | EtherCAT
Distributed Clocks | ja
Durchlaufverzögerung | ca. 1 µs pro Port
Übertragungsraten | 100 Mbit/s
Versorgung | über dreipolige Anschlussklemme (+, -, PE)
Versorgungsspannung | 24 VDC (-15 % / 20 %)
Stromaufnahme | typ. 185 mA
Gewicht | ca. 220 g | ca. 240 g
Abmessungen ohne Stecker (B x H x T) | ca. 35 mm x 98 mm x 77,5 mm
Montage | auf 35 mm Tragschiene (EN 60715)
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95 %, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


CU1128 - Einführung

Produktübersicht [image] CU1128 - Einführung
CU1128 - Einführung
CU1128
EtherCAT Sternverteiler
Linie, Baum oder Stern: EtherCAT unterstützt nahezu beliebige Topologien. Wenn bei der Sterntopologie mehrere Abzweige an einer Stelle erforderlich sind, kann statt mehrerer EK1122 der 8-fach-EtherCAT-Sternverteiler CU1128 als Mehrfach-Abzweig eingesetzt werden.
Port 1 ist der Eingangs-Port für das Netzwerk.
An den Ports 2..8 können weitere EK1100 oder EtherCAT-Box-Module angeschlossen werden. Der Anschluss der EtherCAT-Abzweige erfolgt über RJ-45-Buchsen, an denen Link- und Activity-Status direkt angezeigt werden.
In Verbindung mit TwinCAT oder anderen geeigneten EtherCAT-Mastern unterstützt der CU1128 auch das An- und Abkoppeln von EtherCAT-Strängen im laufenden Betrieb (Hot-Connect). Das Gerät ist nicht als Standard-Ethernet-Switch verwendbar.


CU1128 - Technische Daten

Produktübersicht [image] CU1128 - Technische Daten
CU1128 - Technische Daten
Technische Daten | CU1128
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Abzweigen
Übertragungsmedium | Ethernet/EtherCAT-Kabel (min. CAT 5), geschirmt
Businterface | 8 x RJ45
Länge zwischen Stationen | max. 100 m (100BASE-TX)
Protokoll | EtherCAT
Distributed Clocks | Ja
Durchlaufverzögerung | ca. 1 µs pro Port
Übertragungsraten | 100 MBaud
Versorgung | über dreipolige Federzugklemme (+, -, PE)
Versorgungsspannung | 24 VDC (18 VDC bis 30 VDC)
Stromaufnahme | typ. 185 mA
Gewicht | ca. 430 g
Abmessungen ohne Stecker (B x H x T) | ca. 122 mm x 100 mm x 38 mm
Montage | auf 35 mm Tragschiene (EN 60715)
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95 %, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE UL


Grundlagen

Grundlagen
Grundlagen
Weiterführende Informationen
•
Grundlagen zur Funktion
•
Funktionsgrundlagen EtherCAT-Abzweige


Grundlagen zur Funktion

Grundlagen [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die CU112x sind Infrastrukturgeräte ohne ansteuerbare Ein-/Ausgangsdaten (I/O). Sie sind einsetzbar
▪
als Abzweigstelle für leitungsgeführtes FastEthernet, um EtherCAT-Klemmenstationen, Antriebe oder beliebige andere EtherCAT Slaves an Stichleitungen anzuschließen.
▪
als DistributedClock Referenz-Uhr (siehe Hinweise).
Sie haben kein I/O und kein CoE-Verzeichnis und sind nicht parametrierbar. Die Kernfunktionen der Linkkontrolle und DistributedClocks-Synchronisierung werden von den ESC abgebildet.
CU1123, CU1124 - Struktur
Die EtherCAT-Abzweige CU1123 und CU1124 stellen drei bzw. vier RJ45-Ports zur Verfügung. Dafür wird intern ein Kommunikations-IC (ESC) verwendet. Die Struktur zu den internen ESC-Ports (A, B, C, D) und den Bezeichnungen der Anschlussbuchsen (CU1123: X1 ... X3, CU1124:.X1 … X4) ist in folgender Abbildung dargestellt.
CU1123, CU1124 - Schema
Dabei ist zu beachten:
▪
der Port X1 ist immer der Eingang für den EtherCAT-Verkehr in die EtherCAT-Abzweige CU1123 und CU1124 zu verwenden.
▪
die anderen Ports X2..X3 (CU1123), X2…X4 (CU1124) sind als Abgänge zu verwenden.
CU1128 - Struktur
Um acht EtherCAT-Anschlüsse bereitzustellen, verfügt der CU1128 intern über drei Kommunikations-IC (ESC), die geräteintern in Reihe geschaltet sind. Deshalb tritt der CU1128 im EtherCAT-Konfigurator wie drei einzelne Slaves auf, die zusammen in einem Gehäuse verbaut sind. Der Zusammenhang zwischen den internen ESC-Ports (A, B, C, D) und den Bezeichnungen der Anschlussbuchsen (1..8) wird in folgender Abb. dargestellt.
CU1128 - Schema
Im TwinCAT System Manager werden demzufolge auch drei Geräte angezeigt:
Three Slaves im TwinCAT System Manager
Dabei ist zu beachten:
▪
der Port 1 ist immer der Eingang für den EtherCAT-Verkehr in den CU1128.
▪
die anderen Ports 2..7 sind als Abgänge zu verwenden.
▪
es ist nicht zulässig nach Anlegen des CU1128 Teilgeräte zu löschen.
Zur Unterscheidung siehe auch EEPROM-Update.
CU1128 - Topologische Anordnung
Beim CU1128 ist besondere Aufmerksamkeit auf die strukturelle Anordnung der EtherCAT-Slaves in Bezug auf die Reihenfolge zu richten. Da der CU1128 über sieben Abzweig-Ports verfügt, muss und kann klar zugeordnet werden, an welchem Port eine Stichleitung in der Realität angeschlossen ist. Werden hier in der Konfiguration (TwinCAT System Manager Datei *.tsm) falsche Angaben gemacht, kann das System nicht starten.
Der System Manager teilt für jedes EtherCAT-Gerät mit, an welchem Vorgänger-Port PreviousPort es angeschlossen ist, d. h. wie der verbundene Port (B..D) des Vorgänger-Slave heißt. Dies gilt auch für die internen Verbindungen zwischen den ESC im CU1128:
Vorgänger-Port des 2. ESC im CU1128
In Abb. Vorgänger-Port des 2. ESC im CU1128 ist beispielsweise angegeben, dass der 2. ESC im CU1128 „Box 1“, genannt „Term 2“, mit dem ESC 1 Port C verbunden ist, vergleiche auch Abb. CU1128 - Schema. Diese Einstellung ist nicht veränderbar, da sie durch das Gerät CU1128 fest vorgegeben ist.
Im Allgemeinen ist sie allerdings veränderbar, wenn ein steckbarer Koppler, EtherCAT-Box o. ä. in der Konfiguration vorhanden ist, s. Abb. Einstellung des Previous Port für einen EK1100. Dann kann
▪
durch Drag & Drop im System Manager mit der Maus die generelle Position im I/O-System eingerichtet werden.
▪
anschließend kann in der „Feineinstellung“ der Vorgänger-Port ausgewählt werden, falls mehrere Optionen zur Verfügung stehen.
Einstellung des „Previous Port“ für einen EK1100
In Abb. Einstellung des Previous Port für einen EK1100 ist der Koppler „Term 4“ als Nachfolger des ESC2 „Term 2“ eingerichtet, in der Previous Port-Auswahl des EK1100 stehen somit beide freien Ports des ESC2 (B und D, siehe Abb. CU1128 - Schema) zur Auswahl, B ist hier gewählt.
Ob Ports technisch und real miteinander verbunden werden können, erkennt der System Manager an der Port-Eigenschaft Ethernet oder E-Bus laut ESI/XML-Gerätebeschreibung. Die internen Verbindungen im CU1128 sind E-Bus-Verbindungen, die acht Ports dagegen Ethernet, siehe Abb. CU1128 - Schema.
Siehe auch die Hinweise bei der Konfigurationserstellung.


Funktionsgrundlagen EtherCAT-Abzweige

Grundlagen [image] Funktionsgrundlagen EtherCAT-Abzweige
Funktionsgrundlagen EtherCAT-Abzweige
Es sind einige Beckhoff EtherCAT-Geräte verfügbar, die für Abzweige im EtherCAT-Strang verwendet werden können. Dazu gehören EK1122, EK1521, EP1122 oder auch CU112x. Aufgrund der gleichen Systematik und ähnlichen technischen Eigenschaften dieser Geräte wird in den folgenden Beispielen nur der EK1122 verwendet.
EtherCAT-Handling in den Slaves
Beim Einsatz von EtherCAT als Feldbusprotokoll sind viele verschiedene Bustopologien anwendbar: Linie-, Stern-, Baumtopologie und mit Redundanz-Unterstützung sogar Ringtopologie. Die einfachste Topologie ist die Linientopologie, bei der jeder EtherCAT-Slave die Daten an den einzigen nächsten weiterreicht, siehe folgende Abbildung EtherCAT Linientopologie.
EtherCAT Linientopologie
Beim Einsatz von z. B. EtherCAT-Kopplern EK1100 ist auch ein Abzweig und damit eine Art Baumtopologie möglich, siehe folgende Abbildung Linientopologie mit Erweiterungen.
Linientopologie mit Erweiterungen
Grundlegend dabei ist, dass intern der oder die Ethernet-Frame(s) mit den EtherCAT-Protokolldaten weiterhin in einem logischen Ring befördert werden:
▪
der EtherCAT-Master sendet den Frame auf den beiden Hin-Leitungen des Ethernet-Kabels aus
▪
dieser Frame durchläuft einmalig jeden Slave
▪
wird vom logisch letzten Slave dann gewendet
▪
und auf den beiden Rück-Leitungen des Ethernet-Kabels dann ohne weiteres Processing wieder durch jeden EtherCAT-Slave zum Master zurückbefördert
Bei kurzen Zykluszeiten von z. B. 50 µs sind dabei mindestens 20.000 Ethernet Frames je Sekunde im dem EtherCAT-System unterwegs, zuzüglich azyklischer Organisationsframes. Der Master wartet dabei auf die Rückkehr der ausgesandten Frames, die z. B. die Eingangsdaten der Teilnehmer zum Master zurücktransportieren. Die Weiterleitung der Telegramme von einem Slave zum nächsten ist dabei link-basiert: nur wenn ein „Link“-Signal zum nächsten Teilnehmer besteht, sendet ein EtherCAT-Slave einen Frame weiter. Im Normalfall ist davon auszugehen, dass der nachfolgende Teilnehmer jedes EtherCAT-Telegramm korrekt weiterbearbeitet und am Schluss ggf. zurücksendet bzw. weiterleitet.
Entscheidend bei der Weiterleitung von EtherCAT-Telegrammen ist also, dass ein Link-Signal erst dann von einem Slave zum anderen gemeldet wird, wenn beide wirklich bereit sind in Echtzeit an der Datenverarbeitung teilzunehmen. Konkret darf ein EtherCAT-Slave also erst dann den jeweiligen Ethernet-Port öffnen, wenn er umgehend einen Ethernet-Frame annehmen und weiterleiten kann.
Um üblichen Ethernet-Verkehr weiterzuleiten wird in der Regel ein Switch oder Router eingesetzt. Treten dort Kollisionen oder Frame-Verluste auf, wird dies von übergeordneten Protokollschichten (z. B. TCP) durch Frame-Wiederholung ausgeglichen. Diese Betriebsart ist bei EtherCAT aufgrund der kurzen Zykluszeiten und des Echtzeit-Anspruchs standardmäßig nicht im Einsatz. Einige Ethernet-Geräte wie z. B. spezielle Switche melden bereits einen Link zur Gegenstelle, obwohl sie erst in einigen Millisekunden zur Datenverarbeitung bereit sind. Besonders auffällig wird dieses Verhalten bei Medienkonvertern von 100Base-TX (Kupfer) nach 100Base-Fx (Lichtwellenleiter), die je nach Einstellung auf der Kupferseite zum vorhergehenden EtherCAT-Slave einen Link melden, obwohl die LWL-Verbindung unterbrochen ist.
Deshalb ist die schnelle Link-Detektion ein zentraler Bestandteil eines jeden ESC (EtherCAT Slave Controller, Hardwareverarbeitungseinheit des EtherCAT-Protokolls). Laut EtherCAT-Spezifikation kann ein ESC über ein bis vier Ports verfügen, die er von sich aus kontrolliert. Öffnet er einen Port, ist dort abgehender und ankommender Ethernet-Verkehr möglich. Die Datenflussrichtung in einem vollausgebauten ESC ist in Abb. Datenflussrichtung im ESC gezeigt - dabei werden die Daten in den EtherCAT-Datagrammen nur zwischen Port 0 (A) und 3 (D) in der EtherCAT-Processing-Unit verarbeitet.
Datenflussrichtung im ESC
Idealerweise findet die Link-Erkennung und damit das Port-Handling im ESC so schnell statt, dass selbst bei 100 µs Zykluszeit kein Lost-Frame-Ereignis auftritt. Dennoch ist zumindest ein verlorener Frame nie auszuschließen, falls nämlich eine Verbindung getrennt wird, während ein Ethernet-Frame gerade genau auf diesem Kabel bzw. in dem Bussegment hinter der Trennstelle unterwegs ist.
Umsetzung: EL-Klemme
Ein üblicher EtherCAT-Slave wie z. B. Beckhoff EL-Klemmen verfügt über zwei Ports:
▪
einen für ankommende Frames (Port 0 [A])
▪
und einen für abgehende Frames (z. B. Port [D]).
Die anderen beiden Ports sind intern im ESC geschlossen. Ein EtherCAT-Telegramm gelangt über Port 0 (A)/oben zur Processing-Unit und wird dann über Port 3 (D)/links zum nächsten Slave weitergereicht, falls ein Link zu diesem besteht - s. grüne Pfeile. Das ist dann der Fall, wenn rechts eine weitere EL-Klemme gesteckt ist.
Besteht kein Link, wird der Frame über den violetten Weg zum Port 1(B) weitergereicht. Dieser und auch Port 2 (C) haben keinen Link und reichen den Frame damit zum Port 0 (A) zurück, wo der Frame über den gleichen Ethernet-Port über den er am Slave ankam, diesen wieder verlässt. Das ist der Fall, wenn die betrachtete Klemme als Endklemme fungiert.
Ein EtherCAT-Teilnehmer mit nur einem Port ist somit nur begrenzt einsetzbar, da er nur als End-Teilnehmer eingesetzt werden kann.
Umsetzung: EK1100 EtherCAT Koppler
Im EtherCAT-Koppler EK1100 werden drei von den vier verfügbaren Ports genutzt und damit ein Anschluss nach rechts zu Klemmen und über eine RJ45-Buchse zu weiteren Kopplern ermöglicht, vgl. Abb. „Linientopologie mit Erweiterungen“. Die Processing-Unit wird im EK1100 nicht zum Prozessdatenaustausch genutzt.
Umsetzung: EK1122 EtherCAT Abzweig
Im EK1122 können alle vier Ports des ESC verbunden werden. Zwei über den klemmeninternen E-Bus und zwei über die RJ45-Buchsen mit Ethernet-Physik. Im TwinCAT System Manager werden die Link-Status der Ports 0, 1, 2 und 3 über die Online-Anzeige mitgeteilt - dort werden sie mit Port A, B, C und D bezeichnet, s. Abb. „Topologie Anzeige bei unterbrochener Leitung“.
Umsetzung: EK1521/EK1521-0010/EK1561 EtherCAT Abzweig
In o. g. Abzweigen können wie im EK1100 drei Ports des ESC verbunden werden. Zwei über den klemmeninternen E-Bus und einer über die SC-Buchse/Versatile Link per LWL-Leitung/POF-Leitung.
Umsetzung: CU1123 EtherCAT Abzweig
Im CU1123 können drei der vier verfügbaren Ports des ESC über RJ45-Buchsen verbunden werden.
Umsetzung: CU1124 EtherCAT Abzweig
Im CU1124 können alle vier verfügbaren Ports des ESC über RJ45-Buchsen verbunden werden.
Umsetzung: CU1128 EtherCAT Abzweig
Im CU1128 sind drei ESC integriert, es können somit insgesamt acht Ports durch Anwender belegt werden. Die drei ESC sind untereinander über E-Bus verbunden.
Beispielkonfiguration mit EK1122
Im Folgenden wird beispielhaft das Linkverhalten unter TwinCAT und seine Darstellung im System Manager erläutert.
Beispielkonfiguration
In der TwinCAT Online-Topologie ist der Verdrahtungsplan ersichtlich, s. Abb. Online Topologie. Markiert ist darin der EK1122, so dass weitere Informationen dargestellt werden. Die grünen Balken über den Slaves zeigen den ordnungsgemäßen RUN-State in allen Slaves an.
Online Topologie
Nun soll ein Fehler erzeugt werden: die Verbindung der oberen RJ45-Buchse (X1) zur EL3102 wird getrennt. Innerhalb weniger µs erkennt die ESC in der EK1122 den verlorenen Link und schließt den betroffenen Port selbsttätig. Damit wird das nächste ankommende EtherCAT-Telegramm sofort zum Port D (Port 3) und der EL4732 weitergereicht. Damit fehlt hier der Link und der System Manager kennzeichnet dies in der Online-Anzeige, siehe folgende Abbildung Beispielkonfiguration mit unterbrochener Leitung.
Beispielkonfiguration mit unterbrochener Leitung
Die Meldungen des System Manager sind wie folgt zu deuten:
▪
Adresse 1002 - EK1122: „OP LNK:MIS D“ - Slave ist weiterhin im OP-State, vermisst aber einen laut Konfiguration vorhandenen Link an Port D (3)
▪
Adresse 1003 - EK1100: „INIT NO_COMM“ - da keine Kommunikation mehr zu diesem Slave besteht, wird er als im INIT-State befindlich geführt
▪
Adresse 1004 - EL3104: dto.
Logger-Ausgabe
Im unteren Teil des System Managers kann die Logger-Ausgabe eingeblendet werden (Anzeige → Zeige Logger Ausgabe). Dort werden nicht nur bei Linkunterbrechungen hilfreiche Meldungen zur weiteren Interpretation ausgegeben.
In der Topologie-Ansicht zeigt sich diese Unterbrechung durch eine rote Umrandung der betroffenen Slaves, siehe folgende Abbildung Topologie Anzeige bei unterbrochener Leitung.
Topologie Anzeige bei unterbrochener Leitung
Man beachte in Abb. „Beispielkonfiguration“ und Abb. „Beispielkonfiguration mit unterbrochener Leitung“ die Anzeige der azyklischen Frames, siehe folgende Abbildung Gegenüberstellung der Frame-Anzeigen im System Manager.
Gegenüberstellung der Frame-Anzeigen im System Manager
Im linken Bildauszug sind nur sehr wenige (2) azyklische Frames in der betreffenden Sekunde vom Master ausgesendet worden - alle Slaves sind ordnungsgemäß in Betrieb. Im rechten Bildauszug ist dagegen mit aktuell 77 azyklischen Frames/sec ein deutlicher Anstieg zu verzeichnen: der EtherCAT Master hat schnell erkannt, dass nicht alle Slaves störungsfrei am Datenaustausch teilnehmen. Nachdem er die Störung lokalisiert hat, versucht er nun fortlaufend die Verbindung wiederherzustellen.
Verbindungswiederherstellung
Wird nun in diesem Beispiel die Verbindung wiederhergestellt, meldet der EK1122 an den Master, dass am Port D (3) wieder ein Link anliegt. Der EtherCAT Master wird dann seine Prozessdaten für diesen Abschnitt wieder entsprechend bereitstellen. Wenn die Vorbereitungen abgeschlossen sind, wird er den EK1122 anweisen, den Port D (3) für den regulären Datenaustausch wieder zu öffnen. Der zyklische und azyklische Datenverkehr mit den anderen EtherCAT Slaves läuft dabei selbstverständlich weiter.
Externer Zugriff auf die EtherCAT-Diagnose
Es bestehen umfangreiche Möglichkeiten, aus der PLC heraus auf Zustände, Diagnoseinformationen und Funktionen des EtherCAT-Masters zuzugreifen. Auch über ADS sind fast alle Informationen, die der System Manager online darstellt (s. Abbildungen auf dieser Seite) abrufbar. Ebenso können Aktionen des System Managers über PLC oder ADS ausgelöst werden. Beachten Sie dazu entsprechende Informationen im Beckhoff Information System und Erläuterungen zur EtherCAT Diagnose.


Montage

Montage
Montage
Weiterführende Informationen
•
CU1123, CU1124 - Montage und Demontage
•
CU1128 - Montage und Demontage
•
Verkabelung der Spannungsversorgung
•
Abmessungen
•
LED-Anzeigen
•
UL-Hinweise


CU1123, CU1124 - Montage und Demontage

Montage [image] CU1123, CU1124 - Montage und Demontage
CU1123, CU1124 - Montage und Demontage
Die EtherCAT-Abzweige CU1123 und CU1124 werden mit Hilfe einer 35 mm Tragschiene (nach EN 60715) auf der Montagefläche befestigt.
Tragschienenmontage
Beachten Sie, dass der CU1123 und CU1124 bis zum Kontakt mit der Tragschiene aufgeschoben wird und hörbar auf der Tragschiene einrastet. Siehe Kapitel Empfohlene Tragschienen.
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle.
▪
Hängen Sie das Gerät mit der Feder an der Oberseite seines Rastflansches in die Tragschiene ein (1).
▪
Drücken Sie die Unterseite des Gerätes (2) gegen die Montagefläche bis es auf der Tragschiene einrastet.
▪
Schließen Sie die Kabel an.
Montage
Demontage
▪
Entfernen Sie alle Kabel.
▪
Ziehen Sie die Lasche auf der Unterseite des Gerätes (1) mit einem Schraubendreher nach unten.
▪
Ziehen Sie das Gerät nach oben von der Montagefläche weg (2).
Demontage
Weiterführende Informationen
•
Empfohlene Tragschienen


Empfohlene Tragschienen

Montage [image] CU1123, CU1124 - Montage und Demontage [image] Empfohlene Tragschienen
Empfohlene Tragschienen
Die EtherCAT-Abzweige CU1123 und CU1124, können Sie auf folgende Tragschienen aufrasten:
▪
Tragschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
▪
Tragschiene TH 35-15 mit 1,5 mm Materialstärke
▪
Tragschiene TH 35-15 mit 2,2 mm bis 2,5 mm Materialstärke


CU1128 - Montage und Demontage

Montage [image] CU1128 - Montage und Demontage
CU1128 - Montage und Demontage
Der EtherCAT Sternverteiler CU1128 wird mit Hilfe einer 35 mm Tragschiene (nach EN 60715) auf der Montagefläche befestigt.
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle.
▪
Hängen Sie das Gerät mit der Feder an der unterseite seines Rastflansches in die Tragschiene ein.
▪
Drücken Sie das Gerät nach oben (1).
▪
Drücken Sie die Oberseite des Gerätes (2) gegen die Montagefläche bis es auf der Tragschiene einrastet.
▪
Schließen Sie die Kabel an.
Montage
Demontage
▪
Entfernen Sie alle Kabel.
▪
Drücken Sie das Gerät nach oben (3).
▪
Ziehen Sie die obere Seite des Gerätes (4) von der Montagefläche weg.
Demontage


Verkabelung der Spannungsversorgung

Montage [image] Verkabelung der Spannungsversorgung
Verkabelung der Spannungsversorgung
Pin-Belegung der Anschlussklemmen
Pin-Belegung der Anschlussklemmen


Abmessungen

Montage [image] Abmessungen
Abmessungen
Platzbedarf im Schaltschrank
•
Die RJ45-Stecker erhöhen die Tiefe in Abhängigkeit ihrer Bauform und des verwendeten Ethernet-Kabels.
•
Berücksichtigen Sie oberhalb der Tragschiene zusätzlich ca. 10 mm Höhe um das Gerät auf die Schiene aufrasten zu können.
CU1123, CU1124
Abmessungen CU1123, CU1224
CU1128
Abmessungen CU1128


LED-Anzeigen

Montage [image] LED-Anzeigen
LED-Anzeigen
CU1123, CU1124 - LEDs
CU1123, CU1124 - LEDs
▪
Die grüne RUN-LED zeigt den Zustand der EtherCAT State Machine an. Sie befindet sich jeweils oben am ersten RJ45-Port (X1).
▪
Die grünen LNK/ACT-LEDs zeigen für jeden Kanal den aktuellen Status an. Sie befinden sich jeweils unten an den RJ45-Ports.
LED |  | Anzeige
RUN | grün | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flackernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Es wird eine Firmware geladen
LNK/ ACT | grün | aus | Keine Verbindung
 |  | an | Verbindung vorhanden (Link)
 |  | blinkt | Datenübertragung (Act)
CU1128 - LEDs
CU1128 - Power-LED, Link/Act-LED
▪
Die grüne Power-LED zeigt beim EtherCAT-Sternverteiler CU1128 das Anliegen der Versorgungsspannung (24 VDC) an.
▪
Die grünen LNK/ACT-LEDs zeigen für jeden Kanal den aktuellen Status an. Sie befinden sich unten an den RJ45-Ports X1 … X4 und oben an den RJ45-Ports X5 … X8.
LED |  | Anzeige
LNK/ ACT | grün | aus | Keine Verbindung
 |  | an | Verbindung vorhanden (Link)
 |  | blinkt | Datenübertragung (Act)


UL-Hinweise

Montage [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
Quick Start
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Distributed Clocks Referenzuhr
•
Konfiguration der CU1128 im TwinCAT System Manager


Quick Start

Inbetriebnahme [image] Quick Start
Quick Start
Zur Erstinbetriebnahme der EtherCAT-Komponenten CU112x sind keine besonderen Maßnahmen erforderlich.
Montieren Sie die Komponenten CU112x wie im Kapitel Montage und Verdrahtung beschrieben.
Hinweise zur Konfigurationserstellung finden Sie im Kapitel Konfiguration im TwinCAT System Manager


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im System Manager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im System Manager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter „Kompatible Geräte“ aufgeführt sind, über den „Install“ Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung „Internet Protocol TCP/IP“ eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z. B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → „Update EtherCAT Device Descriptions“
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verfügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung „EL2521-0025-1018“ zusammen aus:
▪
Familienschlüssel „EL“
▪
Name „2521“
▪
Typ „0025“
▪
und Revision „1018“
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z. B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der „üblichen“ Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z. B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u. U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei „OnlineDescription0000...xml“ an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom System Manager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung Kennzeichnung einer online erfassten ESI am Beispiel EL2521).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
„OnlineDescription0000...xml“ löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei „OnlineDescription0000...xml“ legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z. B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der „EtherCAT“ Typ auszuwählen. „EtherCAT Automation Protocol via EL6601“ ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z. B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
„Ethernet“: Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
„E-Bus“: LVDS „Klemmenbus“,„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als „Extended Information“ eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox „Show Hidden Devices“ zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d. h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt „I/O Devices“ zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als „RT-Ethernet“ Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als „EtherCAT Device“ angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung „OK“ im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Default-Zustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d. h. aus der PLC „B.pro“ oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von „B.tsm“ oder gar „B.pro“ ist somit nicht nötig. Die Serienmaschinen können weiterhin mit „B.tsm“ und „B.pro“ gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration „B.tsm“ sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht „B.tsm“ verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration „B2.tsm“ ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. Beispielhafte Online-Anzeige befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im „Actual State“ OP sein
▪
„Frames/sec“ soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig „LostFrames“- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d. h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel „Hinweise zu ESI/XML“.
▪
Teilnehmer werden nicht richtig erkannt
Ursachen können sein
–
fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
–
Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z. Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder „Copy“ sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s. o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der „Extended Information“ wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtigung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button „Ignore“)
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtigung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d. h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch „OK“ in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog „Change to Compatible Type…“ (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z. B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z. B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z. B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im System Manager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten „intelligenten“ EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird davon abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist laut Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. Konfigurieren der Prozessdaten.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: Wählen Sie im Reiter „Process Data“ den Input- oder Output-Syncmanager (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im System Manager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv.
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes („Predefined PDO-settings“) verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann laut ESI-Beschreibung ein PDO als „fixed“ mit dem Flag „F“ gekennzeichnet sein (Abb. Konfigurieren der Prozessdaten, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet („Edit“). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration „G“ unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen „invalid SM cfg“ wird im System Manager ausgegeben: Diese Fehlermeldung „invalid SM IN cfg“ oder „invalid SM OUT cfg“ bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in „<>“ eingeschlossen ist (z. B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE - Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE - Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slaves an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. Auswahl an Diagnoseinformationen eines EtherCAT Slave entspricht auch den Variablenfarben im System Manager, siehe Abb. Grundlegende EtherCAT Slave Diagnose in der PLC.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d. h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. Grundlegende EtherCAT Slave Diagnose in der PLC ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. EL3102, CoE-Verzeichnis:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter „Process Data“, „DC“, „Startup“ und „CoE-Online“ werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahme-Tool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog „Erweiterte Einstellung“ beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z. B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z. B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechenden Positionen im Klemmenstrang Einspeiseklemmen (z. B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung „E-Bus Power of Terminal...“ im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Distributed Clocks Referenzuhr

Inbetriebnahme [image] Distributed Clocks Referenzuhr
Distributed Clocks Referenzuhr
Die Distributed Clock Einheit ist in den EtherCAT-Komponenten CU112x standardmäßig aktiviert. Deshalb kann der CU1128 als Distributed Clocks (DC) „Reference Clock“ verwendet werden. Die Verwendung als Referenzuhr wird im Folgenden am Beispiel der CU1128 erklärt.
Da die EtherCAT „Reference Clock“ möglichst weit vorne und insbesondere vor flexiblen Komponenten (HotConnect) im System angeordnet sein soll, ist es empfehlenswert Koppler oder Abzweigkomponenten wie den CU1128 als DC „Reference Clock“ zu verwenden.
Ohne weitere Einstellungen verwendet der TwinCAT System Manager die erste DC-fähige Klemme/Koppler als „Reference Clock“, siehe Abb. Beispieltopologie mit EL7201 als ReferenceClock.
Beispieltopologie mit EL7201 als „Reference Clock“
Würde nun der Abzweig mit der EL7201 z. B. wegen einer Änderung der Topologie zur Maschinenlaufzeit oder durch eine Störung abgekoppelt, verlöre das EtherCAT-System seine Referenz-Uhr. Deshalb sollten zentrale Komponenten diese Funktion übernehmen.
In den erweiterten Einstellungen des ersten CU1128 (ESC1) ist dazu die Checkbox Use as potential Reference Clock zu setzen.
Aktivierung der CU1128-DC-Funktion
Nach der Aktivierung wählt TwinCAT nun den CU1128 als „Reference Clock“.
CU1128 als „Reference Clock“
Auch in Komponenten kann diese Funktion aktiviert werden, siehe dazu die Hinweise in der Dokumentation EK1100.


Konfiguration der CU1128 im TwinCAT System Manager

Inbetriebnahme [image] Konfiguration der CU1128 im TwinCAT System Manager
Konfiguration der CU1128 im TwinCAT System Manager
Der CU1128 kann wie jeder EtherCAT Slave auf zweierlei Wegen im TwinCAT System Manager angelegt werden:
▪
wenn real online vorhanden und am Konfigurations-PC angeschlossen: durch Scannen
▪
wenn nicht vorliegend: durch manuelle Konfigurationserstellung
Siehe dazu das Kapitel Konfiguration.
Da sich der CU1128 durch seine drei integrierten Slaves etwas von anderen Slaves unterscheidet, werden hier dazu noch einige Hinweise gegeben.
Konfigurationserstellung durch OnlineScan
Ab TwinCAT 2.10 b1340 (und damit auch TwinCAT 2.11 und folgende) wird der CU1128 beim Scan erkannt und das Hauptgerät wie auch die beiden Nebengeräte (CU1128-0001 und CU1128-0002) angelegt.
Scannen der EtherCAT-Geräte im Config-Mode
Zur Kontrolle ist im Topology-View (siehe Abb. Topologie-Darstellung CU1128 im System Manager) darauf zu achten, dass der CU1128 als drei Abzweige in einer Ebene dargestellt wird.
Topologie-Darstellung CU1128 im System Manager
Zum Vergleich hier noch eine inkorrekte Darstellung, die z. B. durch unzulässiges Verschieben der Nebengeräte in der Konfiguration erzeugt werden kann.
Topologie-Darstellung CU1128
Konfigurationserstellung manuell
Zur manuellen Konfigurationserstellung des CU1128 und anhängende Geräte muss die korrekte ESI/XML-Datei vorliegen, siehe hier.
Der Ablauf im Einzelnen:
Rechtsklick mit der Maus, Box anfügen
Auf Ethernet-Ebene wird zuerst ein neues Gerät angefügt. Im Folgenden spielt eine wesentliche Rolle die Port-Angabe im Auswahldialog, siehe Abb. Auswahl des Hauptgerätes CU1128-0000 rechte Seite: hier wird ausgewählt, an welchem abgehenden Port des selektierten Gerätes das neue Gerät angeschlossen werden soll. Je nach verfügbarer Physik (Ethernet oder E-Bus) an Port A, B, C, D steht entsprechendes zur Auswahl. Am EtherCAT-Master ist in diesem Beispiel nur Ethernet, Port B möglich.
Auswahl des Hauptgerätes CU1128-0000
Durch Extended Information kann die Revision im Auswahldialog eingeblendet werden.
Einfügen CU1128
Soll ein CU1128 in eine Konfiguration eingefügt werden, ist er immer über DeviceEtherCAT -> AppendBox einzufügen und im zweiten Schritt per Drag and Drop an die vorgesehene Stelle in der Konfiguration zu schieben.
Eingefügter CU1128 mit Nebengeräten Dev A und Dev B
Schon hier ist in den Nebengeräten die Angabe PreviousPort zu finden, über welche die Nebengeräte anzeigen, dass sie jeweils am Port C des Vorgängers fest verbunden sind.
Previous-Port-Angabe des CU1128, ESC2
Im Topology-View sind die drei Geräte als eine Kette zu erkennen:
CU1128 Ansicht im Topology-View
Weitere CU1128 anfügen
Üblicherweise sind nun weitere Geräte an die abgehenden Ports des CU1128 anzuschließen. Am Beispiel eines weiteren CU1128 wird dies hier erläutert. Dabei ist jeweils der richtige Anschluss-Port auszuwählen.
Anfügen weiterer CU1128
Der CU1128-0000 ist über DeviceEtherCAT einzufügen.
Auswahl CU1128-0000
Der neue Term4 wird hinter dem vorhandenen CU1128 angefügt.
Eingefügter CU1128
Dann ist er per Drag and Drop auf die vorgesehene Position zu schieben. In diesem Beispiel soll er am Port 4 des CU1128, also an Port D von ESC2 = Term2 angeschlossen werden. Dies kann über den PreviousPort vorgegeben werden.
Auswahl PreviousPort nach Verschieben des CU1128
Zur Kontrolle kann die Topologie-Ansicht betrachtet werden.
Topologie-Anzeige 2x CU1128
Weitere EtherCAT-Teilnehmer
Auch andere EtherCAT-Teilnehmer mit Ethernet-Physik können über AppendBox an beliebigen Ports angeschlossen werden.
Hinzufügen weitere Geräte
An den CU1128 sind immer nur Ethernet-Geräte anschließbar, deshalb ist darauf zu achten, dass in der Portauswahl (s. Abb. Hinzufügen Gerät rechts) Ethernet ausgewählt ist.
Hinzufügen Gerät
Die Reihenfolge:
▪
A: nachdem der CU1128 ausgewählt ist
▪
B: und einer der Ethernet-Ports ausgewählt wurde,
▪
C: kann das anzuhängende Gerät gewählt werden.
Der E-Bus-Port (s. Abb. Port-Auswahl CU1128) kann nicht gewählt werden, denn daran hängt das nächste CU1128-Nebengerät.
Port-Auswahl CU1128


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EEPROM Update
•
Support und Service


EEPROM Update

Anhang [image] EEPROM Update
EEPROM Update
Der CU1128 verfügt intern über drei EtherCAT Slave Controller (ESC). Somit sind auch drei EEPROMs vorhanden die beschrieben werden können. Im CU1128 sind diese unterschiedlich, da alle drei ESC über differierende Port-Technologie (Ethernet oder E-Bus) verfügen, siehe Abb. Die drei internen ESC-Namen des CU1128.
Die drei internen ESC-Namen des CU1128
Der Haupt-Slave ist der CU1128-0000, hier in der Revision -0000. Die beiden nachfolgenden internen Slaves sind der CU1128-0001 und CU1128-0002.
Über den Dialog „EEPROM Update“ im System Manager kann das EEPROM aktualisiert werden - dies ist nur in Sonderfällen nötig und sollte nur auf Veranlassung des Beckhoff Support/Service durchgeführt werden.
EEPROM Update TwinCAT
Es können alle drei internen ESC nacheinander beschrieben werden, dann ist ein Strom-Neustart (An/Aus) durchzuführen, damit das EEPROM geladen wird. Zur Zuordnung im TwinCAT Auswahldialog siehe Abb. Derzeit verfügbare EEPROM-Beschreibung des CU1128 und Zuordnung.
Derzeit verfügbare EEPROM-Beschreibungen des CU1128 und Zuordnung
Dev A ist dabei für den ESC2 CU1128-0001 bestimmt, Dev B für den ESC3 CU1128-0002.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.