BX3100 - Bus Terminal Controller for PROFIBUS DP
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
2.3.0
▪
Update Technical data - BX
2.2.0
▪
Download links updated
▪
Design of safety instructions adapted to IEC 82079-1.
2.1.0
Profibus Connection corrected
2.0.0
Migration
1.2.0
Update to firmware version 1.20
1.1.7
Update to firmware version 1.17
1.1.6
Update to firmware version 1.16
1.1.4
Update to firmware version 1.14
1.1.2
Update to firmware version 1.12
1.1.0
Notes regarding compliance with UL requirements added.
1.0.9
Update to firmware version 1.09
1.0.8
Update to firmware version 1.08
1.0.7
Update to firmware version 1.07
1.0.6
Update to firmware version 1.06
1.0.5
Update to firmware version 1.05
1.0.4
Update to firmware version 1.04
1.0.1
Update to firmware version 1.01
1.0.0
Update to firmware version 1.00
BX3100 firmware versions
The BX controller displays its firmware version for about three seconds when it is switched on.
For updating your firmware you need a serial cable, the KS2000 configuration software, or the firmware update program.
Firmware
Description
1.27
▪
BX without K-bus: if no K-bus was created in the System Manager, no error is generated (only possible for TC Config)
1.25
▪
SSB reset problem in the event of short-circuited CAN line resolved
1.24
▪
SSB fix if the CAN is not connected when the BX starts up
1.22
▪
Large model implemented
1.20
▪
Firmware for BX controllers from hardware version 3.5
▪
Switching of the COM 2 interface between RS232 and RS485 modified
▪
New: Support for TwinSAFE Bus Terminals: A maximum of one logic terminal at the K-bus with a maximum of 7 connections permitted (further information)
Attention
Firmware version 1.20 does not run on older hardware versions (lower than 3.5). The hardware version of your BX controller can be found on its sticker.
1.17
▪
New: Support of persistent data
▪
Forcing and reading of the TwinCAT configuration corrected
▪
CFC tool is supported as in firmware 1.14 and lower
1.16
▪
Online change problem rectified for large projects
▪
New: Lighting display can be switched off
▪
New: Boot project CRC display can be enabled during booting
▪
REAL_TO_STRING: Real variables, e.g. 9.0, are now output as string in this form, i.e. '9.0' (previously '9.')
▪
TC-Config: 4-way and 8-way analog terminals fixed
1.14
▪
K-bus updated
▪
SSB reset of the SSB implemented
▪
Generic function implemented
▪
Non-implemented features are disabled with the System Manager, build 1303.
▪
Writing of outputs is possible with TwinCAT build 1302
▪
Optimization of the terminal verification in a TwinCAT configuration
1.12
▪
The TC-Config supports KL1212
▪
The TC-Config supports KM modules
1.09 / 0.99i*
▪
Code optimization, resulting in a performance enhancement of around 30%
▪
Optimization of TcComPortBX.lbx - Fb_BX_BK8x00_slave improved diagnostics
▪
NEW: CFC client support implemented (Controller Flash Copy client)
▪
NEW: PROFIBUS DP diagnostics data, sending from the PLC
1.08 / 0.99h*
▪
SSB optimization
1.07 / 0.99g*
▪
Serial ADS optimization
▪
Online change optimization
1.06 / 0.99f*
▪
COM 1 serial ADS optimization
1.05 / 0.99e*
▪
If a PLC reset is triggered too soon after an online change, an error message is issued saying that the service is not yet ready.
▪
SSB optimization
▪
NEW: Disabling of the red PLC cycle monitoring LED
1.04 / 0.99d*
▪
NEW: Loading and storing of recipes, new function in TcSystemBX fb_ReadWriteFile
▪
Optimization: TcComPortBX, FB_BX_COM_64ex
1.01 / 0.99a*
▪
If the boot project is created too quickly after an online change, a service not ready error message is issued.
1.00 / 0.99*
▪
NEW: ADS function blocks implemented
▪
NEW: SSB: SDO communication from the PLC
▪
BugFix: Mapping problems for digital signals in the TwinCAT-Config rectified
▪
NEW: Serial ADS implemented
▪
Task time precision improved (0.95)
*) The 1.xx versions only support new (blue) displays! The 0.99x versions only support old (green) displays!


Product overview

Product overview
Product overview
Additional information
•
Bus Terminal Controllers of the BX series
•
BX3100 - Introduction
•
Technical data
•
The principle of the Bus Terminal
•
The Beckhoff Bus Terminal system


Bus Terminal Controllers of the BX series

Product overview [image] Bus Terminal Controllers of the BX series
Bus Terminal Controllers of the BX series
Busklemmen-Controller der BX-Serie (BX-Controller_570x259.jpg)
Bus Terminal Controllers of the BX series
The Bus Terminal Controllers of the BX series (BX controllers) offer a high degree of flexibility. In terms of the equipment and performance range, the BX series is positioned between the BC series Bus Terminal controller and the CX1000 Embedded PC. The concept of a stand-alone controller in combination with a link to a higher-level fieldbus system is based on the BC series. The housing design originates from the CX1000. The main features distinguishing the BC and BX series are the larger memory and the expanded interfaces of the BX series.
The BX controllers consist of a programmable IEC 61131-3 controller, a connection to the higher-level fieldbus system and the K-bus interface for connecting the Beckhoff Bus Terminals. In addition, the BX controllers have two serial interfaces: one for programming, the other for free utilization. The device itself includes an illuminated LC display (2 rows with 16 characters each) with joystick switch and a real-time clock. Further peripheral devices, e.g. displays, can be connected via the integrated Beckhoff Smart System Bus (SSB).
The Bus Terminals are connected on the right side of the BX controller, as usual. The comprehensive range of different I/Os enables any input signal to be read and any output signal that may be required to be generated. The BX controllers can be used for a wide range of automation tasks, from garage door control to autonomous temperature control at injection molding machines. The BX controllers are also eminently suitable for a modular machine concept. Within a network, the BX controllers can exchange data with other machine components via the fieldbus interfaces. The real-time clock also enables decentralized applications, for which the day of the week or the time play an important role.
The areas of application of this series are similar to that of the BC series, but due to the larger memory the BX can execute significantly more complex and larger programs and can manage more data locally (e.g. history and trend data recording), which are then successively fetched over the fieldbus.
Bus Terminal and end terminal required
To operate a BX controller, at least one Bus Terminal with process image and the end terminal must be connected to its K-bus.
Fieldbus interface
The variants of the BX series Bus Terminal Controllers differ in terms of their fieldbus interfaces. Additionally, two serial interfaces are integrated for programming and for the connection of further serial devices. Five different versions cover the main fieldbus systems:
▪
BX3100: PROFIBUS DP
▪
BX5100: CANopen
▪
BX5200: DeviceNet
▪
BX8000: RS232 or RS485 (without fieldbus interface)
▪
BX9000: Ethernet ModbusTCP/ADS-TCP/UDP
Programming
The BX controllers are programmed based on the effective IEC 61131-3 standard. As with all other Beckhoff controllers, the TwinCAT automation software is the basis for parameterization and programming. Users therefore have the familiar TwinCAT tools available, e.g. PLC programming interface, System Manager and TwinCAT Scope. Data is exchanged optionally via the serial port (COM1) or via the fieldbus through Beckhoff PC FCxxxx fieldbus cards.
Configuration
The configuration is also carried out using TwinCAT. The fieldbus interface, the SSB bus and the real-time clock can be configured and parameterized via the System Manager. The System Manager can read all connected devices and Bus Terminals. After the parameterization, the configuration is saved on the BX via the serial interface. The configuration thus created can be accessed again later.


BX3100 - Introduction

Product overview [image] BX3100 - Introduction
BX3100 - Introduction
BX3100
The BX3100 Bus Terminal Controller has a PROFIBUS slave interface with automatic baud rate detection up to 12 Mbaud and an address selection switch for address assignment. Inputs and outputs up to 244 bytes can be exchanged with the controller.


Technical data

Product overview [image] Technical data
Technical data
Additional information
•
Technical data - BX
•
Technical data - PROFIBUS DP
•
Technical Data - PLC


Technical data - BX

Product overview [image] Technical data [image] Technical data - BX
Technical data - BX
Technical data | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Processor | 16 bit micro-controller
Diagnostic LEDs | 2 x power supply, 2 x K-Bus
Display | FSTN 2 x 16 lines display for diagnosis or own texts, illuminated
Switch | Joystick switch for parameterization and diagnosis
Clock | battery-powered internal clock for time and date
Configuration and programming software | TwinCAT PLC
Fieldbus interface | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Fieldbus | PROFIBUS DP | CANopen | DeviceNet | - | Ethernet
Interfaces | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Serial interface | COM1 (RS232 for configuration and programming, automatic baud rate detection 9600/19200/38400/57600 baud) COM2 (RS232 or RS485) for connecting serial devices
SSB | CANopen-based sub-bus interface
Terminal Bus (K-Bus) | 64 (255 with K-bus extension)
Technical data | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Digital peripheral signals | 2040 inputs/outputs
Analog peripheral signals | 1024 inputs/outputs
Configuration possibility | via TwinCAT or the controller
max. number of bytes, fieldbus | depending on fieldbus
max. number of bytes, PLC | 2048 bytes of input data, 2048 bytes of output data
Fieldbus connection | D-sub, 9-pin | Open Style Connector, 5 pin |  | - | RJ45
Power supply (Us) | 24 VDC (-15% /+20%) Use a 4 A fuse or an NEC Class 2 power supply to meet the UL requirements!
Input current (Us) | 180 mA + (total K-bus current)/4
Starting current (Us) | approx. 2.5 x continuous current
K-bus current (5 V) | maximum 1450 mA
Power contact voltage (Up) | 24 VDC max. Use a 4 A fuse or an NEC Class 2-compliant power supply to meet the UL requirements.
Power contact current load (Up) | maximum 10 A
Dielectric strength | 500 V (power contact/supply voltage/Ethernet/fieldbus)
Permissible ambient temperature range during operation | -25°C ... +60 °C extended temperature range from hardware 4.4 | -25°C ... +60 °C extended temperature range from hardware 4.4 | -25°C ... +60 °C extended temperature range from hardware 4.4 | -25°C ... +60 °C extended temperature range from hardware 4.4 | 0°C ... +55 °C
Permissible ambient temperature range during storage | -40°C ... +85 °C extended temperature range from hardware 4.4 | -40°C ... +85 °C extended temperature range from hardware 4.4 | -40°C ... +85 °C extended temperature range from hardware 4.4 | -40°C ... +85 °C extended temperature range from hardware 4.4 | -20°C ... +85 °C
Relative humidity | 95 % no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Approvals | CE, cULus
Mechanical data | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Weight | approx. 170 g
Dimensions (W x H x D) | approx. 83 mm x 100 mm x 90 mm (BX8000: approx. 65 mm x 100 mm x 90 mm)
Mounting | with latch, on mounting rail (35 mm DIN rail)
Installation position | Any
Connection cross-section | 0.08 mm² .. 2.5 mm² AWG 28-14 8-9 mm strip length


Technical data - PROFIBUS DP

Product overview [image] Technical data [image] Technical data - PROFIBUS DP
Technical data - PROFIBUS DP
System data | PROFIBUS (BX3100)
Number of I/O modules | 126 (BX3100 max. 99 devices)
Number of I/O points | depending on controller
Transmission medium | shielded copper cable 2 x 0.25 mm², cable type A according to EN 50 170
Segment length | up to 1200 m
Number of segments | 3
Data transfer rate | up to 12 MBaud
Topology | RS485 line, optical fiber ring
Transmission time | approx. 0.5 ms with 10 stations for 32 bits input/output at 12 MBaud


Technical Data - PLC

Product overview [image] Technical data [image] Technical Data - PLC
Technical Data - PLC
PLC data | BXxxxx
Programmability | via programming interface (COM1 or COM2) or via fieldbus
Program memory | 256 kbyte
Source code memory | 256 kbyte
Data memory | 256 kbyte
Remanent flags | 2 kbyte
PLC cycle time | Approx. 0.85 ms for 1000 IL commands (without I/O cycle)
Programming languages | IEC 6-3 (IL, LD, FBD, ST, SFC)
Propagation delay | 1 PLC task (second task in preparation)
Online change | Yes
Up/Down Load Code | Yes/Yes


The principle of the Bus Terminal

Product overview [image] The principle of the Bus Terminal
The principle of the Bus Terminal
The principle of the Bus Terminal


The Beckhoff Bus Terminal system

Product overview [image] The Beckhoff Bus Terminal system
The Beckhoff Bus Terminal system
Up to 256 Bus Terminals, with 1 to 16 I/O channels per signal form
The Bus Terminal system is the universal interface between a fieldbus system and the sensor / actuator level. A unit consists of a Bus Coupler as the head station, and up to 64 electronic series terminals, the last one being an end terminal. Up to 255 Bus Terminals can be connected via the K-bus extension. For each technical signal form, terminals are available with one, two, four or eight I/O channels, which can be mixed as required. All the terminal types have the same mechanical construction, so that difficulties of planning and design are minimized. The height and depth match the dimensions of compact terminal boxes.
Decentralised wiring of each I/O level
Fieldbus technology allows more compact forms of controller to be used. The I/O level does not have to be brought to the controller. The sensors and actuators can be wired decentrally, using minimum cable lengths. The controller can be installed at any location within the plant.
Industrial PCs as controllers
The use of an Industrial PC as the controller means that the operating and observing element can be implemented in the controller's hardware. The controller can therefore be located at an operating panel, in a control room, or at some similar place. The Bus Terminals form the decentralised input/output level of the controller in the control cabinet and the subsidiary terminal boxes. The power sector of the plant is also controlled over the bus system in addition to the sensor/actuator level. The Bus Terminal replaces the conventional series terminal as the wiring level in the control cabinet. The control cabinet can have smaller dimensions.
Bus Couplers for all usual bus systems
The Beckhoff Bus Terminal system unites the advantages of a bus system with the possibilities of the compact series terminal. Bus Terminals can be driven within all the usual bus systems, thus reducing the controller parts count. The Bus Terminals then behave like conventional connections for that bus system. All the performance features of the particular bus system are supported.
Mounting on standardized mounting rails
The installation is standardized thanks to the simple and space-saving mounting on a standardized mounting rail (EN 60715, 35 mm) and the direct wiring of actuators and sensors, without cross connections between the terminals. The consistent labelling scheme also contributes.
The small physical size and the great flexibility of the Bus Terminal system allow it to be used wherever a series terminal is also used. Every type of connection, such as analog, digital, serial or the direct connection of sensors can be implemented.
Modularity
The modular assembly of the terminal strip with Bus Terminals of various functions limits the number of unused channels to a maximum of one per function. The presence of two channels in one terminal is the optimum compromise of unused channels and the cost of each channel. The possibility of electrical isolation through potential feed terminals also helps to keep the number of unused channels low.
Display of the channel state
The integrated LEDs show the state of the channel at a location close to the sensors and actuators.
K-bus
The K-bus is the data path within a terminal strip. The K-bus is led through from the Bus Coupler through all the terminals via six contacts on the terminals' side walls. The end terminal terminates the K-bus. The user does not have to learn anything about the function of the K-bus or about the internal workings of the terminals and the Bus Coupler. Many software tools that can be supplied make project planning, configuration and operation easy.
Potential feed terminals for isolated groups
The operating voltage is passed on to following terminals via three power contacts. You can divide the terminal strip into arbitrary isolated groups by means of potential feed terminals. The potential feed terminals play no part in the control of the terminals, and can be inserted at any locations within the terminal strip.
Up to 64 Bus Terminals can be used in a terminal block, with optional K-bus extension for up to 256 Bus Terminals. This count does include potential feed terminals, but not the end terminal.
Bus Couplers for various fieldbus systems
Various Bus Couplers can be used to couple the electronic terminal strip quickly and easily to different fieldbus systems. It is also possible to convert to another fieldbus system at a later time. The Bus Coupler performs all the monitoring and control tasks that are necessary for operation of the connected Bus Terminals. The operation and configuration of the Bus Terminals is carried out exclusively by the Bus Coupler. Nevertheless, the parameters that have been set are stored in each Bus Terminal, and are retained in the event of voltage drop-out. Fieldbus, K-bus and I/O level are electrically isolated.
If the exchange of data over the fieldbus is prone to errors or fails for a period of time, register contents (such as counter states) are retained, digital outputs are cleared, and analog outputs take a value that can be configured for each output when commissioning. The default setting for analog outputs is 0 V or 0 mA. Digital outputs return in the inactive state. The timeout periods for the Bus Couplers correspond to the usual settings for the fieldbus system. When converting to a different bus system it is necessary to bear in mind the need to change the timeout periods if the bus cycle time is longer.
The interfaces
A Bus Coupler has six different methods of connection. These interfaces are designed as plug connectors and as spring-loaded terminals.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Mounting
•
Wiring


Mounting

Mounting and wiring [image] Mounting
Mounting
Additional information
•
Dimensions
•
Installation on mounting rails


Dimensions

Mounting and wiring [image] Mounting [image] Dimensions
Dimensions
The Beckhoff Bus Terminal system is characterized by low physical volume and high modularity. When planning a project it must be assumed that at least one Bus Coupler and a number of Bus Terminals will be used. The dimensions of the Bus Terminal Controllers are independent of the fieldbus system.
BX3100, BX5100, BX5200, BX9000
BX8000
The overall width of the fieldbus station is the width of the Bus Terminal Controller plus the widths of the individual Bus Terminals (including the KL9010 bus end terminal). Depending on design, the Bus Terminals are 12 mm or 24 mm wide. The height is 100 mm.
The BX series Bus Terminal Controllers are up to 83 mm wide and 91 mm deep.
Pay attention to the total depth
Note that a Bus Terminal Controller with DIN rail and connected plug connectors is usually higher than the specified value of 91 mm. Example:
BX3100 + ZB3100 + DIN rail = 105 mm


Installation on mounting rails

Mounting and wiring [image] Mounting [image] Installation on mounting rails
Installation on mounting rails
Mounting
1.
The white pull-tabs on the underside of the BX controller are connected to a latching mechanism.
Pull the tabs downwards before pushing the BX controller onto the mounting rail.
Released BX controller
Note
Avoid damaging the display during the installation!
Avoid pressing on the display when you push the BX controller onto the mounting rail, in order to avoid damaging the display.
2.
Now press the BX controller onto the mounting rail.
3.
Once it has snapped onto the mounting rail, push the tabs back into their initial position.
Latched BX controller
Disassembly
1.
First release all pull tabs on the underside of the BX controller.
2.
Then pull the orange tab next to the power supply for the power contacts.
Disassembly


Wiring

Mounting and wiring [image] Wiring
Wiring
Additional information
•
Potential groups, insulation testing and PE
•
Power supply
•
Programming cable for COM1
•
SSB and COM interface
•
PROFIBUS Connection
•
PROFIBUS cabling


Potential groups, insulation testing and PE

Mounting and wiring [image] Wiring [image] Potential groups, insulation testing and PE
Potential groups, insulation testing and PE
Potential groups
A Beckhoff Bus Terminal block usually has three different potential groups:
▪
The fieldbus interface is electrically isolated (except for individual Low Cost couplers) and forms the first potential group.
▪
Bus Coupler / Bus Terminal Controller logic, K-bus and terminal logic form a second electrically isolated potential group.
▪
The inputs and outputs are supplied via the power contacts and form further potential groups.
Groups of I/O terminals can be consolidated to further potential groups via potential supply terminals or separation terminals.
Potential groups of a Bus Terminal block
Insulation testing
The connection between Bus Coupler / Bus Terminal Controller and Bus Terminals is realized automatically by latching the components. The transfer of the data and the supply voltage for the intelligent electronics in the Bus Terminals is performed by the K-bus. The supply of the field electronics is performed through the power contacts. Plugging together the power contacts creates a supply rail. Since some Bus Terminals (e.g. analog Bus Terminals or 4-channel digital Bus Terminals) are not looped through these power contacts or not completely the Bus Terminal contact assignments must be considered.
The potential feed terminals interrupt the power contacts, and represent the start of a new supply rail. The Bus Coupler / Bus Terminal Controller can also be used for supplying the power contacts.
PE power contacts
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on the left
It should be noted that, for reasons of electromagnetic compatibility, the PE contacts are capacitively coupled to the mounting rail. This can both lead to misleading results and to damaging the terminal during insulation testing (e.g. breakdown of the insulation from a 230 V power consuming device to the PE conductor). The PE supply line at the Bus Coupler / Bus Terminal Controller must be disconnected for an insulation test. In order to uncouple further feed locations for the purposes of testing, the feed terminals can be pulled at least 10 mm out from the connected group of other terminals. In that case, the PE conductors do not have to be disconnected.
The power contact with the label PE must not be used for other potentials.


Power supply

Mounting and wiring [image] Wiring [image] Power supply
Power supply
SmallWarningYellow DANGER
Risk of injury through electric shock and damage to the device!
De-energize the Bus Terminal I/O system
before you start installation, disassembly or wiring of the components!
SmallWarningYellow DANGER
Note the UL requirements for the power supply.
These UL requirements apply to all supply voltages of the BX controller (Us and Up)!
To comply with UL requirements, the BX controllers may only be connected to supply voltages (24 VDC) that originate
•
from an isolated source protected by a fuse of max. 4A (according to UL248) or
•
from a voltage supply complying with NEC class 2.
An NEC class 2 voltage source must not be connected in series or parallel with another NEC class 2 voltage source!
SmallWarningYellow DANGER
No unlimited voltage sources!
In order to comply with UL requirements, the BX controllers must not be connected to unlimited voltage sources!
Supply of Bus Terminal Controller and Bus Terminals (Us)
The Bus Terminal Controller requires a supply voltage of 24 VDC.
The BX controller is connected via the upper terminal points labelled 24 V and 0 V. This voltage supplies the Bus Terminal Controller electronics, and the Bus Terminal electronics via the K-bus. It is galvanically separated from the field level voltage.
Terminal points for the Bus Terminal Controller supply
UL identification
Power contacts supply (Up)
The bottom six connections with spring-loaded terminals can be used to feed the supply for the peripherals. The spring-loaded terminals are joined in pairs to a power contact. The feed for the power contacts has no connection to the voltage supply for the BX electronics. The design of the feed permits voltages of up to 24 V.
The spring-loaded terminals are designed for wires with cross-sections from 0.08 mm2 to 2.5 mm2.
The assignment in pairs and the electrical connection between feed terminal contacts allows the connection wires to be looped through to various terminal points. The current load from the power contact must not exceed 10 A for long periods. The current carrying capacity between two spring-loaded terminals is identical to that of the connecting wires.
Power contacts
On the right hand face of the Bus Terminal Controller there are three spring contacts for the power contact connections. The spring contacts are hidden in slots so that they cannot be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue and groove guides on the top and bottom of the Bus Terminal Controllers and of the Bus Terminals guarantees that the power contacts mate securely.


Programming cable for COM1

Mounting and wiring [image] Wiring [image] Programming cable for COM1
Programming cable for COM1
You can use a 1:1 cable for programming the BX Controllers (socket/plug, and only connect the pins listed below). On the BX side you need a nine-pin connector, and on the PC side usually a nine-pin socket. The wiring is 1:1, and the necessary pins can be found in the table below. The length of the cable should not exceed 5 meters!
Description | BX COM Port 1 | PC COM port RS 232 serial interface
Cable | Plug connector, pin | Socket, pin
RS 232 RxD/TxD | 2 | 2
RS 232 RxD/TxD | 3 | 3
GND | 5 | 5
Note
All pins that are not listed in the table are reserved
Please note that pins that are not listed are not freely available at this COM port, but are reserved for other signals.
ZK1000-0030
The programming cable can be used to program the BX controller via the COM 1 interface and connect another serial device at the COM 2 interface. Once installed, make sure the maximum overall height of the plug connector is not exceeded.
Programming cable ZK1000-0030 - COM 1 and COM 2
Programming cable ZK1000-0030 - plug connector dimensions
Programming cable ZK1000-0030 - Pinning


SSB and COM interface

Mounting and wiring [image] Wiring [image] SSB and COM interface
SSB and COM interface
The basic BX controller module the COM1, COM2 and SSB (Smart System Bus) interfaces. A D-sub socket is used for COM1 and COM2. A special programming cable (ZK1000-0030) for connecting the two interfaces is available from Beckhoff. The COM2 interface is intended for the connection of serial devices. For the COM2 interface, you can choose between RS232 or RS485.
Libraries are available for the serial COM2 interface.
SSB interface
SSB interface
SSB interface assignment (plug connector X00)
PIN | Signal
1 | reserved
2 | CAN low
3 | GND
4 | reserved
5 | Shield
6 | GND
7 | CAN high
8 | reserved
9 | reserved
COM1 (RS 232) and COM2 (RS 232/485) interface
COM1 (RS 232) and COM2 (RS 232/485) interface
COM interface assignment (socket X01)
PIN | Interface | Signal
1 | COM2 | RS485 D+
2 | COM1 | RS232 TxD
3 | COM1 | RS232 RxD
4 | VCC +5 V | VCC
5 | GND | GND
6 | COM2 | RS485 D-
7 | COM2 | RS232 RxD
8 | COM2 | RS232 TxD
9 | GND | GND


PROFIBUS Connection

Mounting and wiring [image] Wiring [image] PROFIBUS Connection
PROFIBUS Connection
M12 round connector
The M12 socket is inverse-coded and has five pins. Pin 1 transfers 5 VDC, pin 3 transfers GND for the active termination resistor. These must never be misused for other functions, as this can lead to destruction of the device.
Pins 2 and 4 transfer the PROFIBUS signals. These must never be swapped over, as this will prevent communication. Pin 5 transfers the shield, which is capacitively connected to the base of the Fieldbus Box.
Pin assignment M12 socket (-B310)
Pin assignment M12 socket (-B310)
Pin assignment M12 socket/plug connector (-B318)
Pin assignment M12 socket/plug connector (-B318)
Nine-pin D-Sub
Pin 6 transfers 5 VDC, pin 5 transfers GND for the active termination resistor. These must never be misused for other functions, as this can lead to destruction of the device.
Pins 3 and 8 transfer the PROFIBUS signals. These must never be swapped over, as this will prevent communication.
Pin assignment of the PROFIBUS D-sub socket
Pin assignment of the PROFIBUS D-sub socket
PROFIBUS wire colors
PROFIBUS line | M12 | D-Sub
B red | Pin 4 | Pin 3
A green | Pin 2 | Pin 8
Connection of the Fieldbus Box modules
The Fieldbus Box modules are connected either directly or via a T-piece (or Y-piece).
The B318 series features a socket and a plug connector, i.e. this is where the PROFIBUS is routed in the module. The supply voltage (+5 VDC) for the termination resistor is only present at the socket. The termination resistor ZS1000-1610 is only available as a plug connector.
The incoming PROFIBUS line should always end with a socket.
Pin assignment socket/plug connector Fieldbus Box modules
Two T-pieces are available:
▪
ZS1031-2600 with +5 VDC transfer for supplying the termination resistor
▪
ZS1031-2610 without +5 VDC transfer


PROFIBUS cabling

Mounting and wiring [image] Wiring [image] PROFIBUS cabling
PROFIBUS cabling
Physical aspects of the data transmission are defined in the PROFIBUS standard (see PROFIBUS layer 1: Physical Layer).
The types of area where a fieldbus system can be used is largely determined by the choice of the transmission medium and the physical bus interface. In addition to the requirements for transmission security, the expense and work involved in acquiring and installing the bus cable is of crucial significance. The PROFIBUS standard therefore allows for a variety of implementations of the transmission technology while retaining a uniform bus protocol.
Cable-based transmission
This version, which accords with the American EIA RS-485 standard, was specified as a basic version for applications in production engineering, building management and drive technology. A twisted copper cable with one pair of conductors is used. Depending on the intended application area (EMC aspects should be considered) the screening may be omitted.
Two types of conductor are available, with differing maximum conductor lengths (see the RS-485 table).
RS485 - Fundamental properties
RS-485 transmission according to the PROFIBUS standard
Network topology | Linear bus, active bus terminator at both ends, stubs are possible.
Medium | Screened twisted cable, screening may be omitted, depending upon the environmental conditions (EMC).
Number of stations | 32 stations in each segment with no repeater. Can be extended to 127 stations with repeater
Max. bus length without repeater | 100 m at 12 Mbit/s 200 m at 1500 Kbit/s, up to 1.2 km at 93.75 kbit/s
Max. bus length with repeater | Line amplifiers, or repeaters, can increase the bus length up to 10 km. The number of repeaters possible is at least 3, and, depending on the manufacturer, may be up to 10.
Transmission speed (adjustable in steps) | 9.6 kbit/s; 19.2 kbit/s; 93.75 kbit/s; 187.5 kbit/s; 500 kbit/s; 1500 kbit/s; 12 Mbit/s
Connector | 9-pin D-Sub connector for IP20 M12 round connector for IP65/67
Cabling for PROFIBUS DP and PROFIBUS FMS
Note the special requirements on the data cable for baud rates greater than 1.5 Mbaud. The correct cable is a basic requirement for correct operation of the bus system. If a simple 1.5 Mbaud cable is used, reflections and excessive attenuation can lead to some surprising phenomena. It is possible, for instance, for a connected PROFIBUS station not to achieve a connection, but for it to be included again when the neighboring station is disconnected. Or there may be transmission errors when a specific bit pattern is transmitted. The result of this can be that when the equipment is not operating, PROFIBUS works without faults, but that there are apparently random bus errors after start-up. Reducing the baud rate (< 93.75 kbaud) corrects this faulty behavior.
If reducing the baud rate does not correct the error, then in many cases this can indicate a wiring fault. The two data lines may be crossed over at one or more connectors, or the termination resistors may not be active, or they may be active at the wrong locations.
Recommended cables
Installation is made a great deal more straightforward if preassembled cables from Beckhoff are used! Wiring errors are avoided, and commissioning is more rapidly completed. The Beckhoff range includes fieldbus cables, power supply cables, sensor cables and accessories such as termination resistors and T-pieces. Connectors and cables for field assembly are nevertheless also available.
PROFIBUS cable assignment
Termination resistors
In systems with more than two stations all devices are wired in parallel. The PROFIBUS cable must be terminated with resistances at both ends, in order to avoid reflections and associated transfer problems.
Distances
The bus cable is specified in EN 50170. This yields the following lengths for a bus segment.
Baud rate in kbits/sec | 9,6 | 19,2 | 93,75 | 187,5 | 500 | 1500 | 12000
Cable length in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100
Stubs up to 1500 kbaud <6.6 m; at 12 Mbaud stub segments should not be used.
Bus segments
A bus segment consists of at most 32 devices. 126 devices are permitted in a PROFIBUS network. Repeaters are required to refresh the signal in order to achieve this number. Each repeater is counted as one device.
IP-Link is the subsidiary bus system for Fieldbus Boxes, whose topology is a ring structure. There is an IP master in the coupler modules (IP230x-Bxxx or IP230x-Cxxx) to which up to 120 extension modules (IExxxx) may be connected. The distance between two modules may not exceed 5 m. When planning and installing the modules, remember that because of the ring structure the IP-Link master must be connected again to the last module.
Installation guidelines
When assembling the modules and laying the cables, observe the technical guidelines provided by the PROFIBUS User Organization (PROFIBUS Nutzerorganisation e.V.) for PROFIBUS DP/FMS (see www.profibus.de).
Checking the PROFIBUS wiring
A PROFIBUS cable (or a cable segment when using repeaters) can be checked with a few simple resistance measurements. The cable should meanwhile be removed from all stations:
1.
Resistance between A and B at the start of the lead: approx. 110 Ohm
2.
Resistance between A and B at the end of the lead: approx. 110 Ohm
3.
Resistance between A at the start and A at the end of the lead: approx. 0 Ohm
4.
Resistance between B at the start and B at the end of the lead: approx. 0 Ohm
5.
Resistance between screen at the start and screen at the end of the lead: approx. 0 Ohm
If these measurements are successful, the cable is okay. If, in spite of this, bus malfunctions still occur, this is usually a result of EMC interference. Observe the installation notes from the PROFIBUS User Organization (www.profibus.com).


Parameterization and commissioning

Parameterization and commissioning
Parameterization and commissioning
Additional information
•
Start-up behavior of the Bus Terminal Controller
•
PROFIBUS address
•
Configuration
•
Menu
•
Configuration software KS2000


Start-up behavior of the Bus Terminal Controller

Parameterization and commissioning [image] Start-up behavior of the Bus Terminal Controller
Start-up behavior of the Bus Terminal Controller
When the Bus Terminal Controller is switched on it checks its state, configures the K-bus, creates a configuration list based on the connected Bus Terminals and starts its local PLC.
The I/O LEDs flash when the Bus Terminal Controller starts up. If the system is in an error-free state, the I/O LEDs should stop flashing after approx. 2-3 seconds. In the event of a fault the error type determines which LED flashes (see chapter Diagnostic LEDs).
Start-up behavior of the Bus Terminal Controller


PROFIBUS address

Parameterization and commissioning [image] PROFIBUS address
PROFIBUS address
The PROFIBUS address for the BX3100 can be set via two rotary selection switches. The default setting is 11. All addresses are permitted, although each address may only occur once within the network. For changing an address the Bus Coupler must be switched off. The switches can be set to the required position using a screwdriver. Ensure that the switches engage correctly. The lower switch is the 10-multiplier, the upper switch is the 1-multiplier. The address change becomes active when the BX3100 is switched on.
Sample
You want to set address 34.
▪
Lower rotary selection switch S311: 3
▪
Upper rotary selection switch S310: 4
Rotary selection switch for the PROFIBUS address


Configuration

Parameterization and commissioning [image] Configuration
Configuration
Additional information
•
Overview
•
Creating a TwinCAT configuration
•
Downloading a TwinCAT configuration
•
Uploading a TwinCAT configuration
•
Resources in the Bus Terminal Controller
•
ADS connection via serial interface
•
PROFIBUS
•
K-bus
•
PLC
•
SSB
•
Real-Time Clock (RTC)
•
COM port


Overview

Parameterization and commissioning [image] Configuration [image] Overview
Overview
Configuration types
The Bus Terminal controllers of the BCxx50, BCxx20 and BXxx00 series can be configured in two different ways: DEFAULT CONFIG or TwinCAT CONFIG.
DEFAULT-CONFIG
Bus Terminals are mapped in the order they are inserted, i.e. first the complex Bus Terminals followed by the digital Bus Terminals.
The complex Bus Terminals are mapped as follows:
▪
Word Alignment
▪
complex representation
SmallWarningYellow CAUTION
The process image depends on the connected terminals!
The process image changes when a terminal is added or removed!
The data of the fieldbus slaves interface are referred to as PLC variables. The PLC variables have addresses from %QB1000 and %IB1000
The DEFAULT CONFIG (without PLC program) can also be used for writing and testing of the Connected Bus Terminals. To this end, the Bus Terminal Controller must be scanned in the System Manager, and FreeRun mode must be enabled (to use this function, no PLC program may be active on the Bus Terminal Controller).
TWINCAT-CONFIG
In the TwinCAT CONFIG the Bus Terminals and PLC variables can be freely linked as required (TwinCAT System Manager file required). The configuration is transferred to the coupler via the System Manager and ADS.
The following is required for the TwinCAT configuration (TC file):
▪
Via the fieldbus (PROFIBUS, CANopen, Ethernet)
PROFIBUS: (BC3150, BX3100)
–
PC with FC310x from version 2.0 and TwinCAT 2.9 build 1000
–
BX3100 with CIF60 or CP5412
–
TwinCAT 2.9 build 946
(NOTE: with PROFIBUS cards from Hilscher only one ADS communication is permitted, i.e. either System Manager or PLC Control)
CANopen: (BC5150, BX5100)
–
PC with FC510x from version 1.76 TwinCAT build 1030
DeviceNet: (BC5250, BX5200)
–
on request
Ethernet: (BC9050, BC9020, BC9120, BX9000)
–
PC with TwinCAT 2.10 build 1322
▪
Via the serial ADS TwinCAT 2.9 build 1010
–
BX3100 version 1.00
–
BX5100 version 1.00
–
BX5200 version 1.10
–
BX8000 version 1.00
–
BC3150, BC5150, BC5250, BC9050, BC9020, BC9120 from firmware B0
–
For BC8150 from TwinCAT 2.10 build 1243
BCxx50 and BXxx00 can be parameterized via the System Manager of the TwinCAT program.
▪
Variable I/O mapping
▪
Type-specific PROFIBUS data (BC3150 and BX3100 only)
▪
RTC (real-time clock) (BX series only)
▪
SSB (Smart System Bus) (BX series only)
▪
PLC settings
▪
K-Bus settings
The configuration can be transferred to the BCxx50 or BXxx00 via fieldbus ADS protocol or serial ADS protocol.
The TwinCAT configuration can be used to link variables, I/Os and data. The following is possible:
▪
PLC - K-BUS
▪
PLC fieldbus (e.g. PROFIBUS slave interface to PLC)
▪
K-bus fieldbus (only for BX controllers)
▪
Support for TwinSAFE terminals (only BX controllers from firmware 1.17)
In addition, the TwinCAT configuration can be used to parameterize special behavior, for example whether data are preserved or set to "0" in the event of a fieldbus error.
The real-time clock can be set via a tab in the system manager.
Work steps
1.
Setting the fieldbus address
2.
Open the System Manager and create a TC file
3.
Configure fieldbus data in the TC file
4.
Save the TC file
5.
Opening a new system manager, creating a PC file and reading in saved TX file
6.
Creating a link to a PLC task
7.
Saving the configuration
8.
Starting the TwinCAT system
9.
Open the TC file in the System Manager, complete the configuration and transfer it to the BCxx50, BCxx20 or BXxx00
10.
Transfer the program to BCxx50, BCxx20 or BXxx00
11.
Creating a boot project


Creating a TwinCAT configuration

Parameterization and commissioning [image] Configuration [image] Creating a TwinCAT configuration
Creating a TwinCAT configuration
In order to configure a Bus Terminal Controller of the BCxx50, BCxx20 or BXxx00 series, create a BX file in the System Manager. To simplify matters, files for the basic units have already been prepared. Open the corresponding Bus Terminal Controller with New from Template.
systemm new from template.gif
Creating a TwinCAT configuration
Select the corresponding Bus Terminal Controller.
systemm new from template 2.png
Selecting the Bus Terminal Controller
All Bus Terminal Controller components are now available:
▪
Fieldbus interface
▪
K-bus interface
▪
PLC Program
▪
SSB (only Bus Terminal Controllers of the BX series)
Please refer to the relevant chapter for device configuration.


Downloading a TwinCAT configuration

Parameterization and commissioning [image] Configuration [image] Downloading a TwinCAT configuration
Downloading a TwinCAT configuration
The TwinCAT configuration is loaded into the Bus Terminal Controller via ADS protocol.
Serial ADS protocol
(all Bus Terminal Controllers of the BXxx00 and BCxx50 series)
Enter the serial ADS connection, as described in the chapter Serial ADS .
ADS protocol via the fieldbus
(BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000 only)
A prerequisite is that TwinCAT operates as master and is engaged in data exchange, i.e. the physical and fieldbus configuration must be complete, and data exchange must take place between the master (e.g. fieldbus master card) and the Bus Terminal Controller.
Choose Target System
Select the Bus Terminal Controller onto which the configuration is to be loaded. Use the function key F8 to open the dialog for downloading your file to the corresponding device.
Downloading a TwinCAT configuration
Select the corresponding Bus Terminal Controller.
Selecting the Bus Terminal Controller
The state of the Bus Terminal Controller is shown at the bottom right of the System Manager.
State of the Bus Terminal Controller
In Config mode / FreeRun the configuration can now be downloaded to Bus Terminal Controller. If the Bus Terminal Controller is in Stop mode, ADS communication is not yet activated. In this case, it is not possible to download the configuration.
To activate the TwinCAT configuration select Ctrl+Shift+F4 or Activate Configuration.
Activating the TwinCAT configuration
The current configuration is loaded onto the Bus Terminal Controller. The display will show Store Config, and the BUS and I/O LED will flash. Once the configuration is successfully loaded onto Bus Terminal Controller, TwinCAT Config should appear in the display of a BXxx00. The corresponding program can now be transferred to the Bus Terminal Controller (program-download via the fieldbus).


Uploading a TwinCAT configuration

Parameterization and commissioning [image] Configuration [image] Uploading a TwinCAT configuration
Uploading a TwinCAT configuration
The TwinCAT configuration is loaded into the Bus Terminal Controller via ADS protocol.
Serial ADS protocol
(all Bus Terminal Controllers of the BCxx50, BCxx20 and BXxx00 series)
Enter the serial ADS connection, as described in the chapter Serial ADS .
ADS protocol via the fieldbus
(BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000 only)
A prerequisite is that TwinCAT operates as master and is engaged in data exchange, i.e. the physical and fieldbus configuration must be complete, and data exchange must take place between the master (e.g. fieldbus card) and the Bus Terminal Controller.
Choose Target System
Select the Bus Terminal Controller onto which the configuration is to be loaded. Use the function key [F8] to open the dialog for downloading your file to the corresponding device.
Choose Target System
Select the corresponding Bus Terminal Controller.
Selecting the Bus Terminal Controller
The state of the Bus Terminal Controller is shown at the bottom right of the System Manager.
State of the Bus Terminal Controller
Click on the red folder. The TwinCAT configuration will now be uploaded.
Uploading the TwinCAT configuration


Resources in the Bus Terminal Controller

Parameterization and commissioning [image] Configuration [image] Resources in the Bus Terminal Controller
Resources in the Bus Terminal Controller
The memory resources assigned in the Bus Terminal Controller are shown in the System Manager in the Resources tab of the Bus Terminal Controller.
Mapping code
The mapping code is required for calculating the TwinCAT configuration (see Figure Memory for the code mapping). The percentages are added here. In the example from Fig. Memory for code mapping, 8% of the memory is allocated to the mapping calculation.
Memory for code mapping
Data memory mapping
Data memory for mapping. The values are to be considered individually, i.e. each value can be up to 100%.
Data memory mapping
Used code and data memory
Fig. Code and data memory (1) "Used PLC code" in %.
Fig. Code and data memory (2) "Used PLC data" in %.
Fig. Code and data memory (3) "Used PLC source" in %.
Code and data memory
Other memory
Fig. Other Memory (1) "Used Near Heap" is required for the COM interface and SSB. % values.
Fig. Other Memory (2) "Used Huge Heap" is required for the ADS communication. % values. This value should be less than 30 %.
Fig. Other Memory (3) "Used File Area" is required for the TwinCAT configuration, the TSM file and the 16 kbyte flash access. % values.
Other memory


ADS connection via serial interface

Parameterization and commissioning [image] Configuration [image] ADS connection via serial interface
ADS connection via serial interface
(from firmware version 1.xx or 0.99x, Bus Terminal Controllers of the BX series and for all BCxx50)
From TwinCAT 2.9 build 1020 (TwnCAT level PLC, NC or NCI)
Use only a serial connection
To ensure trouble-free operation of the ADS link via the serial interface, only a serial connection to the BX controller is allowed.
After successful configuration via the System Manager, close the System Manager before starting programming.
AMS Net ID in delivery state (default)
For BX9000
The default AMS Net ID is 172.16.21.20.1.1. If the IP address of the BX9000 is changed, the AMS Net ID of the BX9000 also changes. There is a menu option for displaying the current AMS Net ID.
Example: If you change the IP address to 10.2.3.7, the AMS Net ID changes to 10.2.3.7.1.1.
For BC9050, BC9020, BC9120
The default AMS Net ID is 172.16.xxx.[DIP switch].1.1. If the IP address of the BX9xxx is changed, the AMS Net ID of the BX9xxx also changes.
Example: If you change the IP address to 10.2.3.7, the AMS Net ID changes to 10.2.3.7.1.1.
BC9050: DEFAULT 172.16.21.[DIP-Switch].1.1
BC9020: DEFAULT 172.16.22.[DIP-Switch].1.1
BC9120: DEFAULT 172.16.23.[DIP-Switch].1.1
Initializing the ADS connection
Enter the Bus Terminal Controller in the remote connection under TwinCAT. Click on the TwinCAT icon and open the features menu. The following settings can be made under the >AMS Remote< tab.
Properties of the remote connection
Remote Name: Any
AMS-Net-ID: 1.1.1.1.1.1 (Default)
Address: COM Port: Baud rate, parity, data bits, stop bits
Transport: Select "COM port"
When the Bus Terminal Controller is switched on, the default AMS Net ID is always "1.1.1.1.1.1" (except all Ethernet Controllers).
The AMS Net ID can be changed as required. Please note that the new AMS Net ID cannot be changed again in this way.
If you need to change the new AMS Net ID again, you have to restart the Bus Terminal Controller, so that the AMS Net ID is reset to the default AMS Net ID, "1.1.1.1.1.1".
You can now change the AMS Net ID again.
Strings can only be entered at the second call
No strings can be entered under address when the dialog is first called (see above). Enter the name, AMS Net ID and transport type and close the dialog. With the second call you can enter your COM port.
The communication starts when TwinCAT is in Config mode (TwinCAT icon is blue) or RUN mode (TwinCAT icon is green). The COM interface remains open until a TwinCAT stop occurs (TwinCAT icon is red). It is then available again for other programs. No error message is issued if the COM interface is used by another program during a TwinCAT restart (e.g. by the KS2000 configuration software).
AMS Net ID after ADS connection via the fieldbus
If you have addressed the Bus Terminal Controller with an ADS connection via the fieldbus before the serial ADS was used, the AMS Net ID was automatically changed by the System Manager. In this case a new serial ADS connection is only possible, if the AMS Net ID is adjusted.
BX series: reading the AMS Net ID
The current AMS Net ID can be read from the menu via the display of BX series Bus Terminal Controller.
AMS
1.1.1.1.1.1
AMS Net ID


PROFIBUS

Parameterization and commissioning [image] Configuration [image] PROFIBUS
PROFIBUS
Additional information
•
PROFIBUS settings
•
Master configuration


PROFIBUS settings

Parameterization and commissioning [image] Configuration [image] PROFIBUS [image] PROFIBUS settings
PROFIBUS settings
The PROFIBUS-relevant settings are made in the DP slaves tab.
DP slaves tab
Reaction to PROFIBUS Error
In the event of a PROFIBUS error (e.g. PROFIBUS cable is pulled), the output data of the PROFIBUS master are retained unchanged or set to 0 (depending on the parameterization). From the perspective of the Bus Terminal controller, these are input data which the PROFIBUS master transfers to the Bus Terminal Controller.
DP data format
The PROFIBUS data can be transferred in Intel or Motorola format.
Checking the DP configuration data
The configuration data can
▪
not be checked at all;
▪
checked for correct length; or
▪
checked for length and content


Master configuration

Parameterization and commissioning [image] Configuration [image] PROFIBUS [image] Master configuration
Master configuration
Additional information
•
Basic Device File (GSD)
•
Creating a TwinCAT PC file
•
Variable mapping - PROFIBUS DP
•
BX3100 at Siemens S7 controllers


Basic Device File (GSD)

Parameterization and commissioning [image] Configuration [image] PROFIBUS [image] Master configuration [image] Basic Device File (GSD)
Basic Device File (GSD)
All field devices with PROFIBUS slave interface are described via the GSD file. The BX3100 is a PROFIBUS DP slave. For data exchange, the GSD file has to be inserted in the master configuration tool. The maximum length of input and output data 244 bytes in each direction.
Download GSD file (German) ( )
Download GSD file (English) ( )
These files are also available from the Beckhoff website: http://www.beckhoff.de/german/download/bkconfg.htm
The GSD file can describe the following data types:
Variable | Length
Integer 8 | 1 bytes
UnInteger 8 | 1 bytes
Integer 16 | 2 bytes
UnInteger 16 | 2 bytes
Integer 32 | 4 bytes
UnInteger 32 | 4 bytes
Float 32 | 4 bytes
Data types that are not listed, e.g. BOOL variables, can be described via the length. For this purpose, the GSD file includes configuration data starting with a byte and ending with 64 words.


Creating a TwinCAT PC file

Parameterization and commissioning [image] Configuration [image] PROFIBUS [image] Master configuration [image] Creating a TwinCAT PC file
Creating a TwinCAT PC file
DEFAULT CONFIG
DEFAULT-CONFIG contains the PROFIBUS data from the address %IB1000 input and %QB1000. The data length depends on the number of configured PROFIBUS data. A maximum of 244 bytes of input data and 244 bytes of output data can be parameterized. No further settings are required for this configuration type.
Inserting BX3100
Inserting the BX3100 in a PROFIBUS master via the System Manager
Select your PROFIBUS master PC card in the System Manager and right-click on your PROFIBUS master card. The PROFIBUS devices will then be offered for selection, among them a BX3100. Select this and confirm with OK.
Opening an existing BX file
If you wish to work with the DEFAULT-CONFIG, interrupt the process at this point (see Creating PROFIBUS data in DEFAULT-CONFIG). Otherwise select your configured BX file. If no such file exists, you have to create one (Creating a BX file). Once you have selected your BX file, all required PROFIBUS data are copied automatically into your project from this file. You now have to create a link to your task and set the PROFIBUS address. The configuration can then be saved and the TwinCAT system started.
Creating PROFIBUS data in DEFAULT-CONFIG
▪
The PROFIBUS data can now be created. Various variables are available:
–
Integer 8 bit
–
Integer 16 bit
–
Integer 32 bit
–
Unsigned 8 bit
–
Unsigned 16 bit
–
Unsigned 32 bit
–
FLOAT 32 bit
They have to match the variable types currently projected in the BX.
Data sizes from 1 byte to 64 words are available.
systemm insert modul pb.gif
Creating PROFIBUS data
ADS Communication has to be selected for preparing the configuration. If the configuration data are to be transferred via the fieldbus, data communication has to be active, i.e. the BX must be in active data exchange with the higher-level controller.
system manager bx pb ads.gif
ADS Interface


Variable mapping - PROFIBUS DP

Parameterization and commissioning [image] Configuration [image] PROFIBUS [image] Master configuration [image] Variable mapping - PROFIBUS DP
Variable mapping - PROFIBUS DP
Creating the PROFIBUS data.
systemm insert modul pb.gif
Creating PROFIBUS data
For linking with the PLC project, the PLC program must be read in. Add your PLC program under PLC Configuration. The PLC variables can now be linked with the fieldbus variables.
Permitted number of PROFIBUS data
Ensure that the maximum number of PROFIBUS data is not exceeded.
BX3100: max. 244 byte inputs and 244 byte outputs
BC3150: max. 128 byte inputs and 128 byte outputs


BX3100 at Siemens S7 controllers

Parameterization and commissioning [image] Configuration [image] PROFIBUS [image] Master configuration [image] BX3100 at Siemens S7 controllers
BX3100 at Siemens S7 controllers
Additional information
•
Configuration: Siemens S7 Controller
•
Configuration: Siemens S7 controller with BX3100


Configuration: Siemens S7 Controller

Parameterization and commissioning [image] Configuration [image] PROFIBUS [image] Master configuration [image] BX3100 at Siemens S7 controllers [image] Configuration: Siemens S7 Controller
Configuration: Siemens S7 Controller
Inserting the images
In order to assign an image to the devices in the Siemens software, the following graphics must be copied into the Step7\S7Data\ncbmp directory.
Inserting the GSD files
▪
Go to Extras\Install new GSD in the hardware catalog for your Step7.
▪
Select the directory in which the BECKHOFF GSD is located, and import the files.
▪
You will then find them in the hardware catalog under Profibus DP\Other field devices\I/O.


Configuration: Siemens S7 controller with BX3100

Parameterization and commissioning [image] Configuration [image] PROFIBUS [image] Master configuration [image] BX3100 at Siemens S7 controllers [image] Configuration: Siemens S7 controller with BX3100
Configuration: Siemens S7 controller with BX3100
BX3100 parameter data
step7 bx userprm data.png
Settings
BX3100 module configuration
Sample 1
1 x BX3100
step7 bx config.png
Sample for entering individual bytes.
byte for byte
Each individual byte requires one byte of ConfigData.
step7 bx config data.gif
Sample for entering associated bytes.


K-bus

Parameterization and commissioning [image] Configuration [image] K-bus
K-bus
Bus Terminal and end terminal required
To operate a Bus Terminal Controller of the BC or BX series, at least one Bus Terminal with process image and the end terminal must be connected to the K-bus.
BX Settings tab
BX Settings tab
Check Terminals during Start-up
When a boot project is created, the current Bus Terminal configuration is stored. The connected Bus Terminals are checked when the Bus Terminal Controller restarts. If this option is selected, the Bus Terminal Controller does not enter into data exchange. The PLC project will not be started.
Auto K-Bus Reset
Once a K-bus error has been rectified, the Bus Terminal Controller automatically resumes the data exchange.
SmallWarningYellow CAUTION
Once a K-Bus error has been rectified, the outputs become active again immediately!
Ensure that the outputs are reactivated immediately and that analog outputs retain their programmed value, if this is not dealt with in your PLC project.
Clear Outputs on Breakpoint
If breakpoints are set in PLC Control, the K-Bus is no longer processed, i.e. the outputs are set to a safe state (zero).
K-Bus Sync Mode
Writing and reading of the Bus Terminals can take place synchronously with task 1 or the fieldbus.
K-Bus Re-Trigger
If the processor is busy dealing with the PLC project or the SSB, the K-Bus cannot be processed for a certain amount of time. This leads to triggering of the Bus Terminal watchdog and dropping of the outputs. The Bus Terminal Controller is set such that the K-bus watchdog is re-triggered 3 times after 85 ms. The K-Bus watchdog would then be activated.
K-Bus Re-Trigger 0: 100 ms
K-Bus Re-Trigger 1: 2 x 85 ms = 170 ms
K-Bus Re-Trigger 2: 3 x 85 ms = 255 ms
K-Bus Re-Trigger 3: 4 x 85 ms = 340 ms
Reaction on K-Bus Error
In the event of a K-Bus error, the K-Bus inputs are set to "0" or retain their last state.
Response on PLC-Stop
The user can set the behavior of the fieldbus output data in the event of the PLC project being stopped. The master will use these data as input data. In the event of a PLC stop, the data can be set to "0" or remain unchanged.
BX Diag tab
Display of the cycle time for task 1, K-bus, fieldbus processing and the SSB load.
BX Diag tab
Factory Settings: the Bus Terminal Controller is set to its delivery. These settings are reactivated via Restart System or by switching the system off and on again (display shows DEFAULT-CONFIG).
Reset Maximum Values: resets the maximum values
K-Bus variables
PLC interface: Not supported (only included for moving CX or BX projects)
K-bus state: see Diagnostics


PLC

Parameterization and commissioning [image] Configuration [image] PLC
PLC
Additional information
•
Inserting a PLC project
•
Measuring the PLC cycle time


Inserting a PLC project

Parameterization and commissioning [image] Configuration [image] PLC [image] Inserting a PLC project
Inserting a PLC project
For variable mapping, configuration has to be specified in the system manager. This is where the link between PLC and hardware is specified. The variables can process and link bit, byte, word or data structures. Automatic addressing via the System Manager is possible, but should be checked for offset.
Word alignment, byte orientation
With data structures, ensure that the Bus Terminal Controller saves the data in word alignment and the System Manager operates byte-oriented (see Data structures)
A valid project has to be compiled and saved in PLC Control. These data are saved as a *.tpy file. For inserting a PLC project, right-click on PLC - Configuration. Select your current PLC project.
systemmanager plc 1.gif
Selecting the PLC project
Link the PLC variable with the hardware (e.g. digital Bus Terminal).
systemmanager plc 2.gif
Connecting PLC variable and hardware
Once all links have been created, activate the configuration Actions/Activate Configuration (Ctrl+Shift+F4) and start TwinCAT Set/Reset TwinCAT to Run Mode. Ensure that you have selected the correct target system (bottom right in the System Manager window).
Target system display


Measuring the PLC cycle time

Parameterization and commissioning [image] Configuration [image] PLC [image] Measuring the PLC cycle time
Measuring the PLC cycle time
The task time is set in PLC Control. The default setting is 20 ms.
Setting the task time
In the default setting, the PLC program is called every 20 ms, as long as the general cycle time is less than 20 ms. To determine the load of your system, the PLC cycle time can be measured in the System Manager. In order to ensure trouble-free operation, the set task time should be 20-30 % higher than the measured total cycle time. A precise cycle time breakdown can be found under K-Bus tab description. The total cycle time is displayed with the TcBase library (see TcBase.lbx or TcBaseBCxx50.lbx).
Displaying the PLC cycle time


SSB

Parameterization and commissioning [image] Configuration [image] SSB
SSB
Additional information
•
SSB overview
•
CANopen cabling
•
SSB configuration
•
SSB - SDO communication
•
SDO communication from the PLC
•
Emergency telegrams and diagnostics
•
CANopen Trouble Shooting
•
Examples


SSB overview

Parameterization and commissioning [image] Configuration [image] SSB [image] SSB overview
SSB overview
The SSB (Smart System Bus) is a sub-bus system based on CANopen. It is a CANopen master with limited functionality. CANopen slaves may be connected to this interface for reading or writing distributed I/Os. Parameterization SDOs (service data objects) can be sent to the slave via a start-up window.
Configuration
The SSB is configured via the TwinCAT System Manager (see TwinCAT config). The configuration is then loaded onto the BX controller via ADS.
Technical data
SSB | Data
Max. number of slaves | 8
Max. number of PDOs | 32 RxPODs / 32 TxPDOs
Baud rate | 10 kbaud to 1 Mbaud
Permitted slave addresses | 1 to 64
Sync telegram
The sync telegram is transferred depending on the PLC task time. If a task time of 20 ms is set, the sync telegram is also sent every 20 ms (asynchronous with the PLC run time). The sync telegram is only generated when a device requires it and is configured accordingly.
Sync telegrams are supported from firmware 1.12.
Guarding
Guarding is supported and is sent after a configurable interval.


CANopen cabling

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling
CANopen cabling
Notes related to checking the CAN wiring can be found in the Trouble Shooting section.
Additional information
•
CAN topology
•
Bus length
•
Drop lines
•
Star Hub (Multiport Tap)
•
CAN cable
•
Shielding
•
Cable colors
•
BK5151, FC51xx, CX with CAN interface and EL6751: D-sub, 9 pin
•
BK51x0/BX5100: 5-pin open style connector
•
LC5100: Bus connection via spring-loaded terminals
•
Fieldbus Box: M12 CAN socket


CAN topology

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] CAN topology
CAN topology
CAN is a 2-wire bus system, to which all participating devices are connected in parallel (i.e. using short drop lines). The bus must be terminated at each end with a 120 (or 121) Ohm terminating resistor to prevent reflections. This is also necessary even if the cable lengths are very short!
Termination of the bus with a 120 Ohm termination resistor
Since the CAN signals are represented on the bus as the difference between the two levels, the CAN leads are not very sensitive to incoming interference (EMI): Both leads are affected, so the interference has very little effect on the difference.
Insensitivity to incoming interference


Bus length

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] Bus length
Bus length
The maximum length of a CAN bus is primarily limited by the signal propagation delay. The multi-master bus access procedure (arbitration) requires signals to reach all the nodes at effectively the same time (before the sampling within a bit period). Since the signal propagation delays in the CAN connecting equipment (transceivers, opto-couplers, CAN controllers) are almost constant, the line length must be chosen in accordance with the baud rate:
Baud rate | Bus length
1 Mbit/s | < 20 m*
500 kbit/s | < 100 m
250 kbit/s | < 250 m
125 kbit/s | < 500 m
50 kbit/s | < 1000 m
20 kbit/s | < 2500 m
10 kbit/s | < 5000 m
*) A figure of 40 m at 1 Mbit/s is often found in the CAN literature. This does not, however, apply to networks with optically isolated CAN controllers. The worst case calculation for opto-couplers yields a figure 5 m at 1 Mbit/s - in practice, however, 20 m can be reached without difficulty.
It may be necessary to use repeaters for bus lengths greater than 1000 m.


Drop lines

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] Drop lines
Drop lines
Drop lines must always be avoided as far as possible, since they inevitably cause reflections. The reflections caused by drop lines are not however usually critical, provided they have decayed fully before the sampling time. In the case of the bit timing settings selected in the Bus Couplers it can be assumed that this is the case, provided the following drop line lengths are not exceeded:
Baud rate | Drop line length | Total length of all drop lines
1 Mbit/s | < 1 m | < 5 m
500 kbit/s | < 5 m | < 25 m
250 kbit/s | < 10 m | < 50 m
125 kbit/s | < 20 m | < 100 m
50 kbit/s | < 50 m | < 250 m
Drop lines must not have terminating resistors.
Sample topology of drop lines


Star Hub (Multiport Tap)

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] Star Hub (Multiport Tap)
Star Hub (Multiport Tap)
Shorter drop line lengths must be maintained when passive distributors ("multiport taps"), such as the Beckhoff ZS5052-4500 Distributor Box. The following table indicates the maximum drop line lengths and the maximum length of the trunk line (without the drop lines):
Baud rate | Drop line length with multiport topology | Trunk line length (without drop lines)
1 Mbit/s | < 0,3 m | < 25 m
500 kbit/s | < 1,2 m | < 66 m
250 kbit/s | < 2,4 m | < 120 m
125 kbit/s | < 4,8 m | < 310 m


CAN cable

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] CAN cable
CAN cable
Screened twisted-pair cables (2x2) with a characteristic impedance of between 108 and 132 Ohm is recommended for the CAN wiring. If the CAN transceiver’s reference potential (CAN ground) is not to be connected, the second pair of conductors can be omitted. (This is only recommended for networks of small physical size with a common power supply for all the participating devices).
ZB5100 CAN Cable
A high quality CAN cable with the following properties is included in Beckhoff's range:
▪
2 x 2 x 0.25 mm² (AWG 24) twisted pairs, cable colors: red/black + white/black
▪
double screened
▪
braided screen with filler strand (can be attached directly to pin 3 of the 5-pin connection terminal)
▪
flexible (minimum bending radius 35 mm when bent once, 70 mm for repeated bending)
▪
characteristic impedance (60 kHz): 120 ohm
▪
conductor resistance < 80 Ohm/km
▪
sheath: grey PVC, outside diameter 7.3 +/- 0.4 mm
▪
Weight: 64 kg/km.
▪
printed with "Beckhoff ZB5100 CAN-BUS 2x2x0.25" and meter marking (length data every 20cm)
Structure of CAN cable ZB5100
ZB5200 CAN/DeviceNet Cable
The ZB5200 cable material corresponds to the DeviceNet specification, and is also suitable for CANopen systems. The ready-made ZK1052-xxxx-xxxx bus cables for the Fieldbus Box modules are made from this cable material. It has the following specification:
▪
2 x 2 x 0.34 mm² (AWG 22) twisted pairs
▪
double screened, braided screen with filler strand
▪
characteristic impedance (1 MHz): 126 ohm
▪
Conductor resistance 54 Ohm/km
▪
sheath: grey PVC, outside diameter 7.3 mm
▪
printed with "InterlinkBT DeviceNet Type 572" as well as UL and CSA ratings
▪
stranded wire colors correspond to the DeviceNet specification
▪
UL recognized AWM Type 2476 rating
▪
CSA AWM I/II A/B 80°C 300V FT1
▪
corresponds to the DeviceNet "Thin Cable" specification
Structure of CAN/DeviceNet cable ZB5200


Shielding

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] Shielding
Shielding
The screen is to be connected over the entire length of the bus cable, and only galvanically grounded at one point, in order to avoid ground loops.
The design of the screening, in which HF interference is diverted through R/C elements to the mounting rail assumes that the rail is appropriately earthed and free from interference. If this is not the case, it is possible that HF interference will be transmitted from the mounting rail to the screen of the bus cable. In that case the screen should not be attached to the couplers - it should nevertheless still be fully connected through.
Notes related to checking the CAN wiring can be found in the Trouble Shooting section.


Cable colors

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] Cable colors
Cable colors
Suggested method of using the Beckhoff CAN cable on Bus Terminal and Fieldbus Box:
BK51x0 pin PIN BX5100 (X510) | Pin BK5151 CX8050, CX8051, CXxxxx-B510/M510 | Fieldbus Box pin | Pin FC51xx | Function | ZB5100 cable color | ZB5200 cable color
1 | 3 | 3 | 3 | CAN Ground | black/ (red) | black
2 | 2 | 5 | 2 | CAN Low | black | blue
3 | 5 | 1 | 5 | Shield | Filler strand | Filler strand
4 | 7 | 4 | 7 | CAN high | white | white
5 | 9 | 2 | 9 | not used | (red) | (red)


BK5151, FC51xx, CX with CAN interface and EL6751: D-sub, 9 pin

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] BK5151, FC51xx, CX with CAN interface and EL6751: D-sub, 9 pin
BK5151, FC51xx, CX with CAN interface and EL6751: D-sub, 9 pin
The CANbus cable is connected to the FC51x1, FC51x2 CANopen cards and in the case of the EL6751 CANopen master/slave terminal via 9-pin Sub-D sockets with the following pin assignment.
Pin | Assignment
2 | CAN low (CAN-)
3 | CAN ground (internally connected to pin 6)
6 | CAN ground (internally connected to pin 3)
7 | CAN high (CAN+)
The unlisted pins are not connected.
The mounting rail contact spring and the plug shield are connected together.
Note: an auxiliary voltage of up to 30 VDC may be connected to pin 9. Some CAN devices use this to supply the transceiver.
BK5151, EL6751 pin assignment
FC51x2:
FC51x2


BK51x0/BX5100: 5-pin open style connector

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] BK51x0/BX5100: 5-pin open style connector
BK51x0/BX5100: 5-pin open style connector
The BK51x0/BX5100 (X510) Bus Couplers have a recessed front surface on the left hand side with a five pin connector.
The supplied CANopen socket can be inserted here.
BK51x0/BX5100 socket assignment
The left figure shows the socket in the BK51x0/BX5100 Bus Coupler. Pin 5 is the connection strip's top most pin. Pin 5 is not used. Pin 4 is the CAN high connection, pin 2 is the CAN low connection, and the screen is connected to pin 3 (which is connected to the mounting rail via an R/C network). CAN-GND can optionally be connected to pin 1. If all the CAN ground pins are connected, this provides a common reference potential for the CAN transceivers in the network. It is recommended that the CAN GND be connected to earth at one location, so that the common CAN reference potential is close to the supply potential. Since the CANopen BK51X0/BX5100 Bus Couplers provide full electrical isolation of the bus connection, it may in appropriate cases be possible to omit wiring up the CAN ground.
ZS1052-3000 Bus Interface Connector
The ZS1052-3000 CAN Interface Connector can be used as an alternative to the supplied connector. This makes the wiring significantly easier. There are separate terminals for incoming and outgoing leads and a large area of the screen is connected via the strain relief. The integrated terminating resistor can be switched externally. When it is switched on, the outgoing bus lead is electrically isolated - this allows rapid wiring fault location and guarantees that no more than two resistors are active in the network.


LC5100: Bus connection via spring-loaded terminals

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] LC5100: Bus connection via spring-loaded terminals
LC5100: Bus connection via spring-loaded terminals
In the low cost LC5100 Coupler, the CAN wires are connected directly to the contact points 1 (CAN-H, marked with C+) and 5 (CAN-L, marked with C-). The screen can optionally be connected to contact points 4 or 8, which are connected to the mounting rail via an R/C network.
LC5100
Note
Risk of device damage!
On account of the lack of electrical isolation, the CAN driver can be destroyed or damaged due to incorrect cabling. Always carry out the cabling in the switched-off condition.
First connect the power supply and then the CAN. Check the cabling and only then switch on the voltage.


Fieldbus Box: M12 CAN socket

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen cabling [image] Fieldbus Box: M12 CAN socket
Fieldbus Box: M12 CAN socket
The IPxxxx-B510, IL230x-B510 and IL230x-C510 Fieldbus Boxes are connected to the bus using 5-pin M12 plug-in connectors.
Pin assignment: M12 plug, fieldbus box
Beckhoff offer plugs for field assembly, passive distributor's, terminating resistors and a wide range of pre-assembled cables for the Fieldbus Box system. Details be found in the catalogue, or under www.beckhoff.de.


SSB configuration

Parameterization and commissioning [image] Configuration [image] SSB [image] SSB configuration
SSB configuration
The SSB is configured in the system manager. Open your existing configuration, in which you have already configured the PLC project, the K-bus and the higher-level fieldbus, or open a new configuration.
Under I/O devices (left mouse button) a further device can now be appended.
Adding a further device
Select the CANopen Master SSB and confirm with OK.
Selecting the CANopen master SSB
With the left mouse button, a CANopen node can now be selected on the SSB device.
Adding a CANopen device
All Beckhoff CAN nodes are available, as well as a general CANopen node for CANopen devices from other manufacturers.
Selecting a CANopen node
Now link the PLC variables with your CAN node. Once the configuration is complete, load it into the BX.


SSB - SDO communication

Parameterization and commissioning [image] Configuration [image] SSB [image] SSB - SDO communication
SSB - SDO communication
CANopen SDO communication (Service Data Object) is used to read or write any parameters in the CANopen bus node's object directory. The SSB uses the SDO communication for configuring the communication parameters during start-up.
Downloading Application-Specific Parameters when Starting Up
The appropriate parameters are to be entered here in the System Manager for the corresponding node in tab "SDO". The objects that result from the configuration under CAN node appear in square brackets. Any desired number of object directory entries can then be inserted.
Adding/editing object directory entries
The SSB expects a positive acknowledgement of the parameter download from the respective bus device. If it was not possible to write a parameter (the bus device has aborted the SDO) the card then attempts to read the corresponding value back and to compare it with the value that was to be written. This is because it could, for instance, be a read-only value, and therefore already correctly configured within the bus device. If they agree with one another, the card moves onto the next parameter entry.


SDO communication from the PLC

Parameterization and commissioning [image] Configuration [image] SSB [image] SDO communication from the PLC
SDO communication from the PLC
ADS blocks are used for SDO communication from the PLC. These blocks can be used for sending SDO telegrams and receiving the response of the slave (ADSWRITE/ADSREAD).
Input parameters | Description
NETID | Local NetId of the BX or leave empty, e.g. with ''
Port number | 0x1000hex + NodeId (slave number)
IDXGRP | SDO Index
IDXOFFS | SDO Subindex
LEN | Length of SDO data (1...4)
Download BX ( )
Setting individual or all nodes to pre-operational or operational state
The ADSWRTCTL function block can be used for setting individual CANopen nodes or all slaves to pre-operational or operational state.
Input parameters | Description
NETID | Local NetId of the BX or leave empty, e.g. with ''
Port number | 0x1000hex + NodeId (slave number) / 153dec (all nodes)
ADSSTATE | ADSSTATE_RUN
DEVSTATE | 1 - Pre / 0 - Operational
LEN | 0
SRCADDR | 0
Download BX ( )
Restarting the SSB interface
The ADSWRTCTL function block can be used to stop and restart the SSB. It should be stopped first before restarting it.
Input parameters | Description
NETID | Local NetId of the BX or leave empty, e.g. with ''
Port number | 153dec
ADSSTATE | ADSSTATE_STOP, ADSSTATE_RUN
DEVSTATE | 0
LEN | 0
SRCADDR | 0
or
Input parameters | Description (from software version 1.16 for all BX controllers)
NETID | Local NetId of the BX or leave empty, e.g. with ''
Port number | 300dec
ADSSTATE | ADSSTATE_RESET
DEVSTATE | 0
LEN | 4
SRCADDR | ADR on a DWORD variable with the ID of the SSB device (the ID can be obtained from the System Manager file and is typically a value between 1 and 3).


Emergency telegrams and diagnostics

Parameterization and commissioning [image] Configuration [image] SSB [image] Emergency telegrams and diagnostics
Emergency telegrams and diagnostics
The status of the CAN slave is indicated by NodeState. The DiagFlag is set if an emergency telegram was received. The EmergencyCounter is incremented with each emergency telegram.
NodeState, DiagFlag and EmergencyCounter
NodeState value | Description
0 | No error
1 | Node deactivated
2 | Node not found
4 | SDO syntax error at Start Up
5 | SDO data mismatch at Start Up
8 | Node start up in progress
11 | SSB Bus off
12 | Pre-Operational
13 | Severe bus fault
14 | Guarding: toggle error
20 | TxPDO too short
22 | Expected TxPDO is missing
23 | Node is Operational but not all TxPDOs were received
ADS Port 153
Reading of emergency telegrams with AdsRead
Input parameters | Description
NETID | local NetId of BX
Port number | 153
IDXGRP | 16#xxxxF180 (xxxx) NodeId, the Diag flag is only reset when at least 106 bytes are read 16#xxxxF181 (xxxx) NodeId, the Diag flag is reset immediately
IDXOFFS | Byte Offset
Description of the array
Offset | Bit | Value / description
0 - 1 | Bit 0 | reserved
 | Bit 1 | Boot up message not received or incorrect
 | Bit 2 | Emergency-Overflow
 | Bit 3 - 15 | reserved
2 - 3 | Bit 0 - 14 | TX-PDO (i+1) received
 | Bit 15 | All TX PDOs 16-n received
4 - 5 | Bit 0 - 4 | 1: Incorrect TX PDO length
 |  | 2: Synchronous TX PDO absent
 |  | 3: Node signaling PRE-OPERATIONAL
 |  | 4: Event timer timed out for TX PDO
 |  | 5: No response and guarding is activated
 |  | 6: Toggling missed several times and guarding activated
 | Bit 5 - 15 | Associated COB ID
6 | Bit 0 - 7 | 1: Incorrect value during SDO upload
 |  | 2: Incorrect length during SDO upload
 |  | 3: Abort during SDO up/download
 |  | 4: Incorrect date during a boot-up message
 |  | 5: Timeout while waiting for a boot-up message
7 | Bit 0 - 7 | 2: Incorrect SDO command specifier
 |  | 3: SDO toggle bit has not changed
 |  | 4: SDO length too great
 |  | 5: SDO-Abort
 |  | 6: SDO-Timeout
8 - 9 | Bit 0 - 7 | SDO up/download index
10 | Bit 0 - 7 | SDO up/download subindex
11 | Bit 0 - 7 | reserved
12 | Bit 0 - 7 | errorClass des Aborts
13 | Bit 0 - 7 | errorCode des Aborts
14 - 15 | Bit 0 - 15 | Abort additionalCode
16 - 19 |  | Read value (if offset 6 = 1)
20 - 23 |  | Expected value (if offset 6 = 1)
24 - 25 |  | Number of consecutive emergencies
26 - n |  | Emergencies (8 bytes each)
Download BX ( )
Download sample System Manager file BX ( )
Reading the number of PDO telegrams with AdsRead
Input parameters | Description
NETID | local NetId of BX
Port number | 153
IDXGRP | 16#xxxxF930 (xxxx) NodeId
IDXOFFS | 0
Download BX ( )
Configuration of the node ID required
The node ID must be configured before the ADS function blocks is called in the TwinCAT configuration.
Sending a CAN message
This ADSWRITE command enables any CAN message to be sent.
Input parameters | Description
NETID | local NetId of BX
Port Nummer | 153
IDXGRP | 16#0000F921
IDXOFFS | 0
LEN | 11 bytes
SRCADDR | Pointer to an 11 byte ARRAY
Structure of the 11 byte CAN data
Byte | Description | Example Node 7 SDO 0x607 Len 8 Download Request 0x2100 (Index) Sub Index 1 - Value "1"
1 | COB-ID LowByte | 0x06 (SDO Low Byte)
2 | COB-ID HighByte | 0x07 (SDO High Byte)
3 | LEN (length) | 0x08 (LEN, may be 5 in this case)
4 | Data[1] | 0x22 (Download Request)
5 | Data[2] | 0x00 (Index Low Byte)
6 | Data[3] | 0x21 (Index High Byte)
7 | Data[4] | 0x01 (Sub Index)
8 | Data[5] | 0x01 (Value "1")
9 | Data[6] | 0x00
10 | Data[7] | 0x00
11 | Data[8] | 0x00


CANopen Trouble Shooting

Parameterization and commissioning [image] Configuration [image] SSB [image] CANopen Trouble Shooting
CANopen Trouble Shooting
Error Frames
One sign of errors in the CAN wiring, the address assignment or the setting of the baud rate is an increased number of error frames: the diagnostic LEDs then show Warning Limit exceeded or Bus-off state entered.
Error Frames
Warning limit exceeded, passive error or bus-off state are indicated first of all at those nodes that have detected the most errors. These nodes are not necessarily the cause for the occurrence of error frames!
If, for instance, one node contributes unusually heavily to the bus traffic (e.g. because it is the only one with analog inputs, the data for which triggers event-driven PDOs at a high rate), then the probability of its telegrams being damaged increases. Its error counter will, correspondingly, be the first to reach a critical level.
Node ID / Setting the Baud Rate
Care must be taken to ensure that node addresses are not assigned twice: there may only be one sender for each CAN data telegram.
Test 1
Check node addresses. If the CAN communication functions at least some of the time, and if all the devices support the boot up message, then the address assignment can also be examined by recording the boot up messages after the devices are switched on. This will not, however, recognize node addresses that have been swapped.
Test 2
Check that the same baud rate has been set everywhere. For special devices, if the bit timing parameters are accessible, do they agree with the CANopen definitions (sampling time, SJW, oscillator).
Testing the CAN wiring
These tests should not be carried out if the network is active: No communication should take place during the tests. The following tests should be carried out in the stated sequence, because some of the tests assume that the previous test was successful. Not all the tests are generally necessary.
Network terminator and signal leads
The nodes should be switched off or the CAN cable unplugged for this test, because the results of the measurements can otherwise be distorted by the active CAN transceiver.
Wiring diagram for test setup
Test 3
Determine the resistance between CAN high and CAN low - at each device, if necessary.
If the measured value is greater than 65 Ohms, it indicates the absence of a terminating resistor or a break in a signal lead. If the measured value is less than 50 Ohms, look for a short circuit between the CAN lines, more than the correct number of terminating resistors, or faulty transceivers.
Test 4
Check for a short circuit between the CAN ground and the signal leads, or between the screen and signal leads.
Test 5
Remove the earth connection from the CAN ground and screen. Check for a short circuit between the CAN ground and screen.
Topology
The possible cable length in CAN networks depends heavily on the selected baud rate. CAN will tolerate short drop lines - although this again depends on the baud rate. The maximum permitted drop line length should not be exceeded. The length of cable that has been installed is often underestimated - estimates can even be a factor of 10 less than the actual length. The following test is therefore recommended:
Test 6
Measure the lengths of the drop lines and the total bus lengths (do not just make rough estimates!) and compare them with the topology rules for the relevant baud rate.
Screening and earthing
The power supply and the screen should be carefully earthed at the power supply unit, once only and with low resistance. At all connecting points, branches and so forth the screen of the CAN cable (and possibly the CAN GND) must also be connected, as well as the signal leads. In the Beckhoff IP20 Bus Couplers, the screen is grounded for high frequencies via an R/C element.
Test 7
Use a DC ammeter (16 amp max.) to measure the current between the power supply ground and the shield at the end of the network most remote from the power supply unit. An equalization current should be present. If there is no current, then either the screen is not connected all the way through, or the power supply unit is not properly earthed. If the power supply unit is somewhere in the middle of the network, the measurement should be performed at both ends. When appropriate, this test can also be carried out at the ends of the drop line.
Test 8
Interrupt the screen at a number of locations and measure the connection current. If current is flowing, the screen is earthed at more than one place, creating a ground loop.
Potential differences
The screen must be connected all the way through for this test, and must not be carrying any current - this has previously been tested.
Test 9
Measure and record the voltage between the screen and the power supply ground at each node. The maximum potential difference between any two devices should be less than 5 volts.
Detect and localize faults
The "low-tech approach" usually works best: disconnect parts of the network, and observe when the fault disappears.
However, this does not work well for problems such as excessive potential differences, ground loops, EMC or signal distortion, since the reduction in the size of the network often solves the problem without the "missing" piece being the cause. The bus load also changes as the network is reduced in size, which can mean that external interference "hits" CAN telegrams less often.
Diagnosis with an oscilloscope is not usually successful: even when they are in good condition, CAN signals can look really chaotic. It may be possible to trigger on error frames using a storage oscilloscope - this type of diagnosis, however, is only possible for expert technicians.
Protocol problems
In rare cases, protocol problems (e.g. faulty or incomplete CANopen implementation, unfavorable timing at boot up, etc.) can be the cause of faults. In this case it is necessary to trace the bus traffic for evaluation by a CANopen experts - the Beckhoff support team can help here.
A free channel on a Beckhoff FC5102 CANopen PCI card is appropriate for such a trace - Beckhoff make the necessary trace software available on the internet. Alternatively, it is of course possible to use a normal commercial CAN analysis tool.
Protocol problems can be avoided if devices that have not been conformance tested are not used. The official CANopen Conformance Test (and the appropriate certificate) can be obtained from the CAN in Automation Association (http://www.can-cia.de).


Examples

Parameterization and commissioning [image] Configuration [image] SSB [image] Examples
Examples
Additional information
•
BK5120 at SSB
•
Communication between BX controllers (via SSB)
•
AX2000 at SSB
•
Cimrex panel at the SSB of the BX controller
•
IclA drive at SSB
•
Lenze frequency converter at SSB


BK5120 at SSB

Parameterization and commissioning [image] Configuration [image] SSB [image] Examples [image] BK5120 at SSB
BK5120 at SSB
Required material:
▪
TwinCAT 2.9 build 953 or higher
▪
BX3100 version 0.80 or higher, BX5100 version 0.13, BX8000 version 0.04
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
1 x BK5120
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
Cabling material and power supply
▪
TwinCAT System Manager file ( )
(The system manager file has to be transferred to the BX controller via ADS).
▪
BX program file ( )
For the configuration download via ADS, either a BECKHOFF fieldbus master or a free serial port is required.


Communication between BX controllers (via SSB)

Parameterization and commissioning [image] Configuration [image] SSB [image] Examples [image] Communication between BX controllers (via SSB)
Communication between BX controllers (via SSB)
2 or more BX controllers can exchange data via the SSB. Use 2 telegrams for configuring this data exchange in the System Manager (CAN layer).
CAN telegram communication is specified via the COB ID. The BX type is irrelevant, since the SSB is present on each BX controller, and the behavior and configuration is identical.
Communication between BX controllers (via SSB)
Example configuration
BX_ONE:
Node Id 2
CAN_Out AT %QB100: ARRAY[0..7] OF BYTE
COD Id 514 0x202
CAN_In AT %IB100: ARRAY[0..7] OF BYTE
COD Id 386 0x182
BX_TWO:
Node Id 2
CAN_Out AT %QB100: ARRAY[0..7] OF BYTE
COD Id 386 0x182
CAN_In AT %IB100: ARRAY[0..7] OF BYTE
COD Id 514 0x202
Configuration and program example:
Required material
▪
TwinCAT 2.9 build 959 or higher
▪
2 x BXxx00
▪
Cabling material and power supply
▪
TwinCAT System Manager file BX_ONE ( )
▪
Program file BX_ONE ( )
▪
TwinCAT System Manager file BX_TWO ( )
▪
Program file BX_ONE ( )
For the configuration download via ADS, either a BECKHOFF master (FC310x, FC510x, FC520x) or a free serial port is required.


AX2000 at SSB

Parameterization and commissioning [image] Configuration [image] SSB [image] Examples [image] AX2000 at SSB
AX2000 at SSB
AX2000
Required material:
▪
TwinCAT 2.9 build 953 or higher
▪
BX3100 version 0.80 or higher
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
1 x AX2000 with the following settings: Slave address 4, baud rate 500 kbyte
▪
Cabling material and power supply
▪
Example program and configuration on the BX Controller
–
TwinCAT System Manager file ( )

(The System Manager file has to be transferred to the BX Controller via ADS).
–
BX program file ( )
For the configuration download via ADS, either a BECKHOFF fieldbus master or a free serial port is required.
AX2000 description
The following sections are extracts from the AX2000 drive manual. Further information can be found on the internet at http://www.beckhoff.de.
Hardware and interfaces
Setting the Station Address
The station address (device address at the CAN bus) of the servo drive can be set in three
ways:
▪
Via the front panel keyboard (see AX2000 installation guide)
▪
Via the "Basic settings" screen of the DRIVE.EXE commissioning software
▪
Via the serial interface with the following ASCII command sequence:
ADDR nn > SAVE > COLDSTART (with nn = address)
The address range can be extended from 1..63 to 1..127 with the ASCII object
MDRV.
Setting the baud rate
The CAN transfer speed (baud rate) can be set in three ways:
▪
Via the front panel keyboard (see AX2000 installation guide)
▪
Via the "Basic settings" screen of the DRIVE.EXE commissioning software
▪
Via the serial interface with the following ASCII command sequence:
CBAUD bb > SAVE > COLDSTART (with bb = baud rate in kB)
Possible baud rates are 10, 20, 50, 100, 125, 250, 333, 500 (default), 666, 800 or 1000 kBaud.
CANopen Interface (X6)
Interface for connection to the CAN bus (default 500 kBaud). The integrated profile is based on the DS301 CANopen communication profile and on the DSP402 drive profile. The following functions are available in combination with the position controller:
jogging with variable speed, reference motion, start travel command, start direct travel command, digital set value specification, data transfer functions and many others.
Detailed information can be found in the CANopen manual. The interface is electrically isolated via an optocoupler and has the same potential as the RS232 interface. The analog set value inputs can still be used. The two interfaces (RS232 and CAN) occupying the same connector (X6) can be split to two connectors via the optional 2 CAN extension card.
CANopen Interface (X6)


Cimrex panel at the SSB of the BX controller

Parameterization and commissioning [image] Configuration [image] SSB [image] Examples [image] Cimrex panel at the SSB of the BX controller
Cimrex panel at the SSB of the BX controller
The CAN interface of the BX controller can also be used for connecting an operating panel. In this example, a panel from the company Beijers is connected. Further information on the panel can be found under http://www.beijerelectronics.de.
Cimrex panel at the SSB of the BX controller
Necessary components
▪
1 x BX3100
▪
Some Bus Terminals for the K-bus (here 3 x KL2114, can be adjusted in the System Manager file)
▪
1 x Cimrex 41
▪
1 x CAB 15 CAN adapter
▪
BX sample program in ST: ( )
▪
BX example configuration: ( )
▪
Example for Cimrex 41: ( )
–
Baud rate 500 kbaud
–
CAN slave address 10


IclA drive at SSB

Parameterization and commissioning [image] Configuration [image] SSB [image] Examples [image] IclA drive at SSB
IclA drive at SSB
IclA drive at SSB
Required material:
▪
TwinCAT 2.9 build 953 or higher
▪
BX3100 version 0.80 or higher
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
1 x IclA D065 with the following settings: slave address 10, baud rate 500 kbyte (Please note: These are not the default parameters of the drive)
▪
Cabling material and power supply
For the configuration download via ADS, either a BECKHOFF fieldbus master or a free serial port is required.
Reconfiguration example for TwinCAT with FC510x CANopen master card
An example for converting a drive is listed below.
▪
TwinCAT System Manager file ( )
▪
TwinCAT PLC file ( )
Example program and configuration on the BX Controller
▪
TwinCAT System Manager file ( )
(The System Manager file has to be transferred to the BX Controller via ADS).
▪
BX program file ( )
IclA D065 description
The following sections are extracts from the IclA drive manual. They were provided by the company SIG Positec Automation GmbH for the purpose of describing the basic parameters. Further information can be found on the internet at http://www.sig-positec.de.
Hardware and interfaces
IclA drive connections
▪
Signal interface for
–
Supply voltage
–
Control signals for manual mode
–
Connection for emergency stop signal
▪
Protective conductor connection for earthing via PE bus bar
▪
Fieldbus connection for connecting the fieldbus cable.
Signal interface
If the emergency stop function is not required, connect pin 2 with pin 8 or 9 (24 VDC).
Fieldbus connection
Control word 0x6040
The object represents the control word for the device. The control word is used for several control tasks:
▪
Changeover between different operating states. The possible states and transitions can be found under the index keyword "machine state". Bits 0 to 3 and bit 7 are relevant for a change of state.
▪
Starting and stopping mode-specific functions, e.g. starting a travel command via bit 4. Bits 4 to 6 are used for mode-specific settings. Further details can be found under the keywords "Operating mode, starting", "Operating mode, monitoring" and in the description of the respective operating modes in sections "Manual mode" and "Positioning mode".
▪
Stopping of the positioning drive from an active travel operation. Bit 8 "Stop" is used for stopping. Further details can be found under the keywords "Operating mode, starting" and "Operating mode, monitoring".
Object description | Value description
Index | 6040h
Object name | Control word
Data type | Integned16
Subindex | 00h, control word
Access | read-write
PDO-Mapping | R_PDO
Bit | Name | Meaning
11..15 | Manufacturer specific | not used
9, 10 | - | reserved
8 | Stop | Stop motor
7 | Reset fault | Reset fault
4..6 | - | Operating mode dependent,
3 | Enable operation | Execute operating mode
2 | Quick stop (low active) | Breaking with quick stop ramp
1 | Disable voltage (low active) | Switch off voltage
0 | Switch on | Switch into ready-to-run state
Status word 0x6041
The object describes the current operating state of the device. The status word can be used for the following monitoring functions:
▪
Checking the operating state of the positioning controller. Bits 0 to 3, 5 and 6 are relevant.
▪
Bit 4 indicates whether the output stage is ready for processing a transport instruction.
▪
Bits 7 to 15 are used for monitoring the travel operation and for status monitoring of device-specific states.
Further details for monitoring travel operation can be found under the keywords "Operating mode, starting", "Operating mode, monitoring" and in the description of the respective operating modes in sections "Manual mode" and "Positioning mode". The bits for device status monitoring are described in section "Diagnostics and trouble shooting".
The control word is represented in the first two bytes of the R_PDOs.
Object description | Value description
Index | 6041h
Object name | Status word
Data type | Unsigned16
Subindex | 00h, status word
Access | read-only
PDO Mapping | T_PDO
Bit
Name
Meaning
15
Out of security area
Out of security area
0->1: Limit switch position S0 or S1 exceeded
14
Out of drive area
Out of drive area
0->1: Limit switch position D0 or D1 exceeded
12..13
-
Operating mode-dependent meaning
11
Internal limit active
Out of working area
10
Target reached
Target reached
1->0: New target position transferred
0->1: Requested target position reached or motor standstill after stop request
9
Remote
0: manual mode
1: no manual mode
8
Right out of drive area
Only valid if bit 11 = 1
- 0: Limit switch position W1 exceeded
- 1: Limit switch position W0 exceeded
7
Warning
Warning
6
Switch on disabled
not ready for operation
5
Quick Stop
Quick stop active
4
Voltage disabled
Voltage off
3
Fault
Fault occurred
2
Operation enabled
Operating mode enabled
1
Switched on
Ready for operation
0
Ready to switch on
Ready to switch on
Reference ranges
A valid referencing is defined via three limit switch zones, which have to be within the possible traversing range of the drive. The limit switches protect the drive and the system from damage.
Reference ranges
▪
Working area W0 - W1 for positioning mode.
▪
Drive area D0 - D1. From ranges D0 - W0 and D1 - W1, the drive can
▪
only be moved backwards towards the operating range.
▪
Security area S0 - S1. From areas S0 - D0 and S1 - D1, the drive can only be moved backwards manually.
▪
CANopen objects - three CANopen objects are used for setting up the limit switches. They contain the position values for the upper and lower range limits.
▪
Working area limits in software position limit (607Dhex)
▪
Drive area limits in software position drive limit (2009hex)
▪
Security area limits in software position safety limit (2008hex)
Referencing example
The following listing demonstrates the input of the referencing values. The node address of the positioning drive is set to 01hex.
Listing of the referencing values


Lenze frequency converter at SSB

Parameterization and commissioning [image] Configuration [image] SSB [image] Examples [image] Lenze frequency converter at SSB
Lenze frequency converter at SSB
Frequency converter from Lenze
Required material
▪
TwinCAT 2.9 build 953 or higher
▪
BXxx00
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
1 x Lenze 8200 vector + motor
▪
1 x Lenze CANopen Interface 2175
▪
Cabling material and power supply
For the configuration download via ADS you need a BECKHOFF fieldbus master card or a free serial port.
Lenze description
The following sections are extracts from the Lenze 2175 manual. They were provided by the company Lenze Drive Systems GmbH for the purpose of describing the basic parameters. Further information can be found on the internet at http://www.Lenze.com.
Initial commissioning
Set the power supply for the bus module to internal power supply.
External power supply - internal power supply
(State at Delivery)
For CANopen communication set DIP switch 10 to "ON".
DIP switch
Baud rate DIP switches 7-9
Transfer rate [kbps] | S7 | S8 | S9
10 | ON | ON | OFF
20 | ON | OFF | ON
50 | OFF | ON | ON
125 | OFF | ON | OFF
250 | OFF | OFF | ON
500 (default) | OFF | OFF | OFF
1000 | ON | OFF | OFF
Priority of the DIP switches
DIP switch 6 has the smallest weighting.
Example: Address 3 switches 5 and 6 "ON".
Enabling the communication module
Switch to operating mode 3 for enabling the communication module. This can be achieved via the SSB using the following entry:
Enabling the communication module
Sync telegram
In the default setting, the Lenze drive will send its output PDOs only once it has received a sync telegram from the CAN master. If you set the trans. type to 2, for example, the Lenze drive will send an output PDO after every second sync telegram it receives.
Sample project
▪
TwinCAT-System-Manager-File: ( )
▪
TwinCAT-PLC-File: ( )


Real-Time Clock (RTC)

Parameterization and commissioning [image] Configuration [image] Real-Time Clock (RTC)
Real-Time Clock (RTC)
A real-time-clock (RTC) with backup battery is implemented on the BX controller. The clock has a battery.
Setting the real-time clock
The simplest way of setting the clock is via the System Manager. When the ADS communication is operating normally, the current time is displayed on the BX controller. To adjust the time, simply edit the time, and adjust the day, month and year with the drop down key. For setting the year, click on the year display and specify the required year. Repeat the procedure for the month. Once all parameters have been set, click on Update RTC on BX.
systemmanager rtc 1.gif
Setting the real-time clock (RTC)
Service life of the battery
The service life of the battery may vary depending on utilization.
Reading the RTC on the BX controller (see example Programming\Library)
The RTC can be read via a function block. Required libraries:
▪
TcSystemBX.lbx
▪
TCBaseBX.lbx
Writing the RTC to the BX controller
The RTC can be set via a function block. Required libraries:
▪
TcSystemBX.lbx
▪
TCBaseBX.lbx
Reading the RTC via ADS
Description | Meaning | Value
NETID | Target device | see System Manager "ADS"
Port | ADS port number | 150dec
IDXGRP | IDX group | 0x0000_F100hex
IDXOFFS | IDX Offset | 0x0000_0000hex
Length | Length of the data | 16 byte
Variable type | Type of variable | TIMESTRUCT
Writing of the RTC via ADS
Description | Meaning | Value
NETID | Target device | see System Manager "ADS"
Port | ADS port number | 150dec
IDXGRP | IDX group | 0x0000_F100hex
IDXOFFS | IDX Offset | 0x0000_0000hex
Length | Length of the data | 16 byte
Variable type | Type of variable | TIMESTRUCT
Setting via the navigation switch
See menu.
Technical data for RTC
Accuracy: approx. 1 second/day
Duration for which the time is stored: approx. 3 months with fully charged battery
Service life of the battery: approx. 10 years for 10 cycles per day (1000 cycles for complete charge/discharge cycles)


COM port

Parameterization and commissioning [image] Configuration [image] COM port
COM port
The BX Controller has two serial interfaces. For PIN assignment please refer to Hardware description.
Setting options:
Description | Selection
Baud rate | 9600 baud 19200 baud 38400 baud (starting with auto baud rate detection) 57600 baud 115200 baud (COM 2 only)
Data bits | 7 8 (Default)
Parity | NONE ODD EVEN (Default)
Stop bits | 1 (default) 2
COM 1
The COM 1 interface is used for communication with the KS2000 software or with TwinCAT PLC Control (login via serial interface).
COM 2
The COM 2 interface (with RS 232 or RS 485) is used for the application of user protocols or protocol libraries (such as ModbusRTU, RK512, etc.) for the connection of other serial devices.
Library
Function blocks are available for communication with the serial interface.
▪
Documentation
▪
Example
▪
Library


Menu

Parameterization and commissioning [image] Menu
Menu
Additional information
•
BX menu settings
•
Creating own menus


BX menu settings

Parameterization and commissioning [image] Menu [image] BX menu settings
BX menu settings
To change into the menu, press the navigation switch for three seconds. The Menu directory appears first.
▪
You can change between the menu settings with the RIGHT/LEFT keys (the menu shown in row 1 is the active menu).
▪
Press the DOWN key for changing into a submenu.
▪
Press the UP key to return to the main menu.
Row 1 of the submenu shows the menu item, row 2 the current setting of this menu item.
Some settings cannot be changed (read only). These items are only intended to provide checks and to give the user information. To close the menu it is necessary to be in the main menu and then to hold the navigation switch down for three seconds.
Before settings can be changed, a password has to be set. The password remains stored even during a firmware update and through a reset to the factory settings. If you forget the password, the BX controller will have to be sent in.
Navigation switches of the BX controller
Switch assignment
Switch assignment
Main menu | Submenu 1st row | Submenu 2st row | Read/Write
MENU | Password | **** not set ???? set | See below
 | Factory settings | Activate? | Pressing the key causes the factory setting to be reset and the controller to be rebooted automatically
 | Reboot | Activate? | Pressing the key causes the controller to be rebooted
AMS | AMS | >AMS Net-ID< | read only
PLC | NAME | >current NAME< | read only
 | Curr. Exex. Time | >current value< | [ms]
 | Task time | >current value< | The cycle time can be set if the key is pressed
 | Status | >Boot-Prj< >PLC Status< | Boot project exists PLC status
Config | NAME | >current NAME< | read only
 | Delete config | Activate? | Pressing the right key causes the current configuration to be deleted
Real Time Clock | Date and Time | >current time< | read only
 | Year | Setting | 2003-2xxx
 | Month | Setting | 1-12
 | Day | Setting | 1-31
 | Day of week | Setting | Mon, ... Fri
 | Hour | Setting | 0-23
 | Minute | Setting | 0-59
 | Second | Setting | 0-59
COM 1 read only | Baud rate | >current value< | 9600/19200/38400/56800
COM 2 read only | Baud rate | >current value< | 9600/19200/38400/56800/115k
SSB read only | Baud rate | >current value< | 1MBaud, 500k, 250k, 125k, 100k, 50k
 | Cycle Time | >current value< [in µs] | read only
 | Utilization | >current value< [in %] | read only
K-bus read only | Diagnosis | >current diagnosis< | read only
 | Number of Bus Terminals | >current value< | read only
Bus-specific menu items
BX3100
F-bus PROFIBUS read only | Address* | >current value< | 1-126
 | Baud rate* | >current value< | read only
 | Status | >current value< | read only
 | Diagnostic* | >current value< | read only
BX5100
F-bus CANopen read only | Address* | >current value< | 1-126
 | Baud rate* | >current value< | read only
 | Status | >current value< | read only
 | Diagnostic* | >current value< | read only
*) in preparation
BX9000
Ethernet | MAC ID | >current value< | 000105-xx-xx-xx, read only
 | ADDR.STATE | >current value< | read only
 | ADDRESSING MODE | FIXED IP (default) DHCP BOOTP BOOTP & SAVE | read / write
 | NAME | >current value< | BX_xxxxxx (xxxxxxx last 3 Bytes from the MAC ID) read / write
 | DEFAULT GATEWAY | 0.0.0.0 | read / write
 | IP MASK | 255.255.0.0 | read / write
 | IP ADDRESS | 172.16.21.20 | read / write
Code
The default setting is "****", i.e. no password is active. A password is required for setting parameters.
Menu navigation
Press the navigation switch for three seconds to switch to the Directory menu. Some of the menu items are described below.


Creating own menus

Parameterization and commissioning [image] Menu [image] Creating own menus
Creating own menus
The display and the navigation switch can also be used for user-specific purposes, for example displaying diagnostic information or changing parameters. A simple example is provided that can be used and adapted to get you started.
Download ( ):


Configuration software KS2000

Parameterization and commissioning [image] Configuration software KS2000
Configuration software KS2000
Bus Terminal controllers of the BCxx50, BXxx20 and BXxx00 series cannot be parameterized and configured with the KS2000 configuration software. These devices must be configured with the TwinCAT System Manager.
The KS2000 configuration software offers configuration and diagnostic support for the Bus Terminals attached to the Bus Terminal Controller.
It is advisable to set the baud rate in the KS2000 configuration software and the BCxx50 BCxx20 and BXxx00 to 38400 baud (8 data bits, even, 1 stop bit).
COM1 - automatic baud rate detection
The COM 1 interface of the BXxx00 features automatic baud rate detection between 9.6 kbaud and 56.4 kbaud.
Required KS2000 version
Configuration or diagnostics of Bus Terminals at BXxx00 is supported from KS2000 version 4.3.14.
In some Bus Terminals (e.g. KL25xx, KL6811, KL6201, KL6401) the following parameters must be set in order to be able to use the configuration dialogs:
▪
A PLC project or boot project must be deactivated.
▪
The BX controller must be in its default configuration. Set the manufacturer’s setting or switch to Config Mode in the TwinCAT System Manager (blue TwinCAT icon).
▪
The BX controller must be in FreeRun mode. Activate it with the TwinCAT System Manager.
You can now log in with the KS2000 configuration software via ADS (port 100) or the serial cable and use the KS2000 dialogs in the Bus Terminals.


Programming

Programming
Programming
Additional information
•
PLC features of the BX controllers
•
TwinCAT PLC
•
TwinCAT PLC - Error codes
•
Allocated flags
•
Mapping the Bus Terminals
•
Local process image in delivery state (default config)
•
Persistent data
•
Remanent data
•
Local process image in the TwinCAT configuration
•
Creating a boot project
•
Communication between TwinCAT and BX/BCxx50
•
Up- and downloading of programs
•
Libraries
•
Program transfer
•
Process image


PLC features of the BX controllers

Programming [image] PLC features of the BX controllers
PLC features of the BX controllers
Description | Value
Data memory | 256 kbyte
Program memory | 256 kbyte minus task-configuration minus POUs during online change
Source code memory | 256 kbyte
RETAIN | 2 kbyte
INPUT | 2 kbyte
OUTPUT | 2 kbyte
FLAG | 4 kbyte
Max. variable size | 16 kbyte
Max. POUs | Limited by memory


TwinCAT PLC

Programming [image] TwinCAT PLC
TwinCAT PLC
The Beckhoff TwinCAT Software System turns any compatible PC into a real-time controller with a multi-PLC system, NC axis control, programming environment and operating station. The TwinCAT programming environment is also used for programming the BC/BX. If you have TwinCAT PLC (Windows NT4/2000/XP) installed, you can use the fieldbus connection or the serial port for downloading and debugging software.
TwinCAT I/O or TwinCAT PLC can also be used as the Ethernet Master (host), in order to exchange process data with the Bus Terminal Controller. TwinCAT provides you with the System Manager as a configuration tool, as well as the drivers and the ADS protocol.
Bus Terminal Controllers of the BCxx50, BCxx20 and BXxx00 series
These 2nd-generation Bus Terminal Controllers are configured with the TwinCAT System Manager and programmed with TwinCAT PLC Control. TwinCAT PLC must be installed for these couplers (Windows NT4, Windows 2000, Windows XP).
Programming and program transfer
▪
via the serial interface
▪
via the fieldbus interface (only for Bus Terminal controllers for PROFIBUS, CANopen and Ethernet)
Online change
The Bus Terminal Controllers of the BX series and the BCxx50 support online change. This means that the PLC program is replaced with a new program without interrupting the program. The switch-over to the new program occurs after the task is completed. This means that two versions of the PLC program have to be stored. 512 kbyte are available, which therefore have to be divided by two, leaving 256 kbyte for the actual PLC program. In addition, several kbyte are required for task configuration etc. During an online change, dynamic data are stored in memory. Should a program approach the memory limit (program size greater than 240 kbyte), the online change may no longer work, even though the program may still be written to the BX after "Rebuild all".
When is online change not available?
Online change is not available under certain conditions,.
▪
Inserting of a new library
▪
Changing the task setting
▪
"Rebuild all"
▪
Controller memory limit is almost reached (PLC program greater than 90%)


TwinCAT PLC - Error codes

Programming [image] TwinCAT PLC - Error codes
TwinCAT PLC - Error codes
Error type | Description
PLC compiler error | Maximum number of POUs (...) exceeded
PLC compiler error | Out of global data memory ...
Error POUs
For each function block one POU (process object unit) is created. 256 function blocks are available by default.
Maximum number of POUs exceeded
If libraries are integrated this value may be insufficient. In this case, the number of POUs should be increased.
To this end, open in PLC Control under Projects/Options...
Menu path Projects / Options / Controller Settings
...the controller settings.
Controller settings
Changing these settings will deactivate online changes.
Global memory error
Global memory insufficient
2 x 16 kbyte of data are available by default. If large data quantities are to be used, this range should be increased. A maximum of 14 data segments are possible for the BX.
Menu path Projects / Options / Build
Build


Allocated flags

Programming [image] Allocated flags
Allocated flags
4 kbyte of allocated flags are available. They can be used to assign different variable types to the same address, e.g. for converting strings to bytes. Data can also be placed here that can be read or written via ADS by the controller.
Allocated variables are not remanent data
For the Bus Terminal Controllers of the BX series and the BCxx50 the allocated variables are not saved as remanent data.
Reading/writing of allocated flags via ADS
The flags may also be read via the controller and ADS. In PROFIBUS, the DPV-1 services are used for this purpose, in CANopen SDO communication is used.
The AmsNetID can be obtained from the System Manager, or it can be displayed via the Bus Terminal Controller menu.
The PLC port number is 800.
Index group | Meaning | Index offset (value range)
0x4020 | Flag (only BXxxx0) | 0..4096
Example
BX program
VAR
Flag_01 AT %MB0: WORD;
END_VAR
TwinCAT PC/CX master program
VAR
fbADRSREAD: ADSREAD;
Flag_M: WORD;
END_VAR
fbADRSREAD(
NETID:='172.16.3.0.2.3' , (* AMSNetId BX *)
PORT:=800 , (* 800 - PLC *)
IDXGRP:=16#4020 , (* 0x4020hex falgs *)
IDXOFFS:=0 , (* byte offset *)
LEN:=2 , (* Lenght byte *)
DESTADDR:=ADR(Merker) ,
READ:=TRUE ,
TMOUT:=t#1s );
IF NOT fbADRSREAD.BUSY THEN
fbADRSREAD(READ:=FALSE);
END_IF


Mapping the Bus Terminals

Programming [image] Mapping the Bus Terminals
Mapping the Bus Terminals
The precise assignment of the byte-oriented Bus Terminals may be found in the configuration guide for the particular bus terminal. This documentation is available on the Beckhoff Products & Solutions CD or on the Internet under http://www.beckhoff.de.
Byte oriented Bus Terminals | Bit oriented Bus Terminals
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Local process image in delivery state (default config)

Programming [image] Local process image in delivery state (default config)
Local process image in delivery state (default config)
The process image of the Bus Terminal Controller consists of input, output and flag area. In addition, there are unallocated data without fixed address. They are created without specifying an address. For these variable types the memory allocation is as follows:
▪
BCxx50 48 kbyte,
▪
BC9x20 128 kbyte,
▪
BXxx00 256 kbyte.
The maximum size of a variable or structure (array) is 16 kbyte. For the allocated data 2048 bytes of input data and 2048 bytes of output data are available. The Bus Terminal Controller has 4 kbyte of memory allocated for the flag area.
In the delivery state (default configuration) of the BX/BCxx50, fixed addresses are allocated for all connected Bus Terminals. The data for Ethernet communication start from address offset 1000dec. The length of the Ethernet data depends on how much data has been configured; on the BX9000 it has a maximum length of 1000 bytes.
Inputs | Outputs
Bus Terminal %IB0 ... | Bus Terminal %QB0 ...
Ethernet DATA (PLC variables) %IB1000 ...(Modbus TCP/ADS-TCP/ADS-UDP) | Ethernet DATA (PLC variables) %QB1000 ...(Modbus TCP/ADS-TCP/ADS-UDP)
... %IB2047 maximum | ... %QB2047 maximum
Addressing of the connected Bus Terminals
The default setting is for all the connected Bus Terminals to be assigned to the local process image. Mapping within the Bus Terminal Controller is carried out according to the following rule:
First all the complex Bus Terminals, in the sequence they are physically inserted, followed by the digital Bus Terminals which are filled to a byte. The default mapping of the complex Bus Terminals is:
▪
complete evaluation
▪
Intel format
▪
Word alignment
Example structure
Bus Terminal Controller: 1 x BCxx50, BCxx20 or BXxx00
Position 1: 1 x KL1012
Position 2: 1 x KL1104
Position 3: 1 x KL2012
Position 4: 1 x KL2034
Position 5: 1 x KL1501
Position 6: 1 x KL3002
Position 7: 1 x KL4002
Position 8: 1 x KL6001
Position 9: 1 x KL9010
Process image
Bus Terminal | Position | Input image | Output image | Size
KL1501 | 5 | %IB0...%IB5 | %QB0...%QB5 | 6 bytes
KL3002 | 6 | %IB6...%IB13 | %QB6...%QB13 | 8 bytes
KL4002 | 7 | %IB14...%IB21 | %QB14...%QB21 | 8 bytes
KL6001 | 8 | %IB22...%IB29 | %QB22...%QB29 | 6 bytes
KL1012 | 1 | %IX30.0...%IX30.1 | - | Bit 2
KL1104 | 2 | %IX30.1...%IX30.5 | - | Bit 4
KL2012 | 3 | - | %QX30.0...%IX30.1 | Bit 2
KL2034 | 4 | - | %QX30.2...%IX30.5 | Bit 4
KL9010 | 9 | - | - | -


Persistent data

Programming [image] Persistent data
Persistent data
The Bus Terminal Controller has 1000 bytes of persistent data available.
In contrast to the retain data, these are not deleted, even with a new project, a PLC reset or a new download.
In order to use the persistent data, these must first be activated once with a function block from the PLC.
Secondly, the variables should reside in the allocated flag area. Here you can choose where the persistent data reside.
4 kbytes of allocated flags are available, of which 1000 bytes can be declared as persistent data.
Example
VAR
Test AT %MX1000 :BOOL;
Count AT %MB1002 :INT;
END_VAR
The Persistent_Data function block can be used to specify the start address and the length (in bytes) from which the data are to be persistent.
The input variable WriteOffset is used to specify the byte offset of the flag area, WriteSize is used for the length in bytes.
The function block can be found in the TcSystemBX.lbx library. Should this not be available, it can be downloaded from this documentation (see Libraries).
Example values
WriteOffset 1000
WriteSize 10
All data in the range %MB1000 - %MB1009 are then persistent. The variable type is irrelevant.
Like the retain data, the data are copied to the NOVRAM and are therefore writeable in each cycle.
Persistent data from firmware 1.17
Persistent data is supported for all BX controllers from firmware 1.17 or higher.
Parameters are valid immediately
The parameters only have to be written once, after which they are valid immediately. These data are stored permanently.
Activation of the factory setting deletes everything, including the persistent data.
Sample Program
Click on the link [image] ( ) to download a sample program from this documentation.


Remanent data

Programming [image] Remanent data
Remanent data
2000 kbyte of remanent data are available for the BX controller. These data are declared as VAR RETAIN in PLC Control:
Example
VAR RETAIN
Test :BOOL;
Count :INT;
END_VAR
Retain data are located between VAR RETAIN and END_VAR. These data are stored in a NOVRAM and are consistent across the whole 2 kbyte range. The RETAIN data are stored in the NOVRAM after each cycle. For 2 kbyte approx. 2 ms are required (for 1 kbyte approx. 1 ms). The variables can be configured locally or globally. Allocated variables (%MB, %QB, %IB) cannot be used as remanent data.
Do not use VAR_RETAIN in function blocks
VAR_RETAIN should not be used in function blocks. All FB data are copied into the retain memory. This leads to an unnecessary increase in cycle time, and the retain memory is filled with unnecessary data.
Do not use variables with address as remanent data
Variables that have been assigned an address (%MB, %QB, %IB) must not be used as remanent data.
Example for remanent data in the function block
This should be avoided, if possible, since all the data of a function block, in which even just a single remanent bit is found, are stored by default. A program sample can be found below.
Function block test (no program code required - in ST semicolon is sufficient)
FUNCTION_BLOCK Test
VAR_INPUT
END_VAR
VAR_OUTPUT
END_VAR
VAR
END_VAR
VAR_IN_OUT
Counter :INT;
END_VAR
MAIN program
PROGRAM MAIN
VAR
fb_Test:Test;
END_VAR
VAR RETAIN
iCounter1:INT;
END_VAR
fb_Test(Counter:=iCounter1);


Local process image in the TwinCAT configuration

Programming [image] Local process image in the TwinCAT configuration
Local process image in the TwinCAT configuration
The TwinCAT configuration (TwinCAT CONFIG) enables free mapping between fieldbus, K-bus and PLC variables. Variables can be linked independent of their address via the System Manager.
Changing variable links
Linking a variable with an input
In the default configuration all Bus Terminals are assigned fixed addresses. If a Bus Terminal is inserted, the whole address range may be shifted. The TwinCAT configuration enables allocated variables to be linked to a Bus Terminal, as required. This is parameterized in the System Manager, and the configuration is then downloaded to the Bus Terminal Controller (see TwinCAT configuration). It is also possible to upload an existing TwinCAT configuration.


Creating a boot project

Programming [image] Creating a boot project
Creating a boot project
The following memory resources are available for generating the boot project
▪
approx. 250 kbyte flash on the Bus Terminal controllers of the BX series;
▪
approx. 48 kbyte flash on the Bus Terminal controllers of the BCxx50 series.
PLC Control
After logging into TwinCAT PLC Control, a boot project can be created.
▪
Opening a PLC project
▪
Selecting the target system (or selection the serial interface)
▪
Logging into the BX/BCxx50
▪
Creating a boot project (Online\Create boot project)
The PLC LED lights up green once a valid boot project is available on the BX/BCxx50.
In the Bus Terminal controllers of the BX series, the PLC LED flashes orange while boot project is created. The PLC LED lights up orange if no boot project is available on the BX.
Deleting a boot project
The boot project can be deleted from the Bus Terminal Controller. The following steps must be followed:
▪
Opening the project
▪
Logging into the Bus Terminal Controller
▪
Deleting the boot project (Online\Delete boot project)
The PLC LED lights up orange when the boot project is deleted.
Using the current project as boot project
After an online change the old project is still shown as boot project. To use the current project (after the online change) as the boot project, the boot project has to be recreated.
Bypassing the start of the boot project*
With the Bus Terminal controllers of the BX series, starting of the boot project during booting can be prevented by pressing the Navi button. This does not delete the boot project. The project is reloaded when the Bus Terminal Controller is rebooted.
* from version 0.85


Communication between TwinCAT and BX/BCxx50

Programming [image] Communication between TwinCAT and BX/BCxx50
Communication between TwinCAT and BX/BCxx50
For transferring data from TwinCAT to the Bus Terminal Controller, it makes sense to organize the data in a structure. Please note the following to account for the differences in data management on the two systems.
▪
If two different data types are sent in sequence (e.g. byte and INT), the following variable is set to the next even address offset
▪
Boolean variables should never be allocated individually within a structure, since they would invariably occupy 1 byte. Boolean expressions should always be masked in a byte or word.
Example 1: A structure on the BX/BCxx50 and on the PC
Variable | BX/BCxx50 memory | PC memory (TwinCAT)
Byte | %..B0 | %..B0
INT (1) | %..B2 | %..B1
INT (2) | %..B4 | %..B3
Due to the fact that another variable type (INT) follows the first byte, in the BX/BCxx50 it was assigned the next free even address. In order to achieve the same data structure on both systems, a dummy byte has to be inserted in the PC project (see example 2).
Example 2: A structure on the BX/BCxx50 and on the PC with the same memory allocation
Variable | BX/BCxx50 memory | PC memory (TwinCAT)
Byte | %..B0 | %..B0
Byte (dummy) | %..B1 (not necessarily required, since the system deals with this itself if the variable does not exist) | %..B1
INT (1) | %..B2 | %..B2
INT (2) | %..B4 | %..B4
Data structure
Type PB_Data
STRUCT
wVar_1:WORD;
iValue_1:INT;
iValue_2:INT;
iValue_3:INT;
END_STRUCT
END_TYPE
Creating a variable structure
VAR_Global
strData_Out AT %QB1000:PB_Data; (*PLC Variables *)
bInput_01 AT %IX0.0:BOOL; (* Input from a terminal *)
END_VAR
Small programming example
strData_Out.wVar_1.0:=bInput_01;
Do not use real values in a mixed data structure
A mixed data structure should not contain real values. If this is nevertheless the case, the high and low words must be swapped in the BX/BCxx50 or in the TwinCAT master project. It is better to use an array of Real values or to transfer the Real values individually.
Larger fieldbus data blocks
You can transfer larger fieldbus data blocks, in order to have a reserve for your structure. Disadvantage: These reserves are then transferred with each fieldbus telegram, resulting in overload of the fieldbus communication.


Up- and downloading of programs

Programming [image] Up- and downloading of programs
Up- and downloading of programs
The Bus Terminal Controller has a memory for the source code. It can be used for storing the program, the task configuration, and the libraries. Should the memory be insufficient, the source code may be stored without task configuration and libraries. This takes up significant less memory space!
General settings
The timing of the source code download to the target system can be specified via Edit/Options. Open the options menu.
Opening the options menu
Select Source Download.
Selecting Source Download
Here you can set which parts of the source code are to be downloaded to the Bus Terminal Controller, and when.
Source code only: the prx file with information on the online change is transferred. Login via online change is possible (the PLC does not stop).
All files: as Source code only, plus all required libraries.
Source code only (compile info excluded): only the prx file is transferred. Login is only possible when the PLC stops.
Which option you can use depends on the size of your projects.
Downloading a program
The source code can be transferred to the target system on request. This requires the user to be logged in with his program. Under Online/Source code download the program code can now be transferred to the Bus Terminal Controller.
Downloading the program code
After a short delay, a window will open that indicates the download progress.
Download progress
Uploading a program
For uploading the program code again, open a new file in PLC Control. Then click on the PLC button.
Uploading a program
Select the data transfer route:
▪
BCxx50 or BX via AMS, if you are connected to the Bus Terminal Controller via the fieldbus, or
▪
BCxx50 or BX via serial, if you are connected to the Bus Terminal Controller via the serial interface.
plc choose target bx ads.gif
Selecting the data transfer route
Then select the device and confirm with OK.
Selecting the device
The source code will now be uploaded.
Password
You can protect your project with a password (in PLC Control Project/Options/Passwords).


Libraries

Programming [image] Libraries
Libraries
Additional information
•
Libraries overview
•
TcBaseBX
•
TcSystemBX
•
TcComPortBX
•
TcTwinSAFE


Libraries overview

Programming [image] Libraries [image] Libraries overview
Libraries overview
Various libraries are available for the Bus Terminal Controllers (Bus Coupler with PLC functionality: BXxxxx) (see Beckhoff Information System).
Download
To download the libraries click on the link. Please copy the libraries to directory TwinCAT\PLC\LIB.
▪
Standard ( )
▪
TcSystemBX ( )
(the TcSystemBX requires the TcBaseBX library)
▪
TcBaseBX (Download)
(TcDisplayBX, TcNaciSwitchBX and TcDebugBX are now included here)
▪
TcComPortBX ( )
▪
ChrAscBX.lbx ( )
Use the library that matches the firmware
The latest firmware requires the latest library. If you update your BX Controller, please also change the libraries.
Copy these libraries to the LIB directory, remove these libraries from your project and add them again.
TcSystemBX
ADS | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
ADSREAD | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSWRITE | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSRDWRT | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSWRTCTL | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSRDSTATE | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSRDDEVINFO | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
Bit Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
CLEARBIT32 | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
CSETBIT32 | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
GETBIT32 | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
SETBIT32 | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
Display Function | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
FB_DispWrite | 31.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
Diagnosis | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
BX_Security | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
DeviceTyp | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
FirmwareVersion | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
FirmwareVersionString | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
DeviceTyp | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
Read_Diagnose | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
CRCBootproject | 15.08.06 | 1.14 | 1.14 | - | 1.14 | 1.14
Read Address | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
ReadSlaveAddress | 15.08.06 | 1.12 | 1.12 | 1.10 | 1.12 | -
Controller | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
FB_BasicPID | 04.03.04 | 0.64 | 0.01 | 1.00 | 0.01 | 1.00
Event Logger Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
- | - | - | - | - | - | -
File Access | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
FB_ReadFromFile | 03.08.04 | 1.04 | 1.04 | 1.00 | 1.04 | 1.00
FB_WriteToFile | 03.08.04 | 1.04 | 1.04 | 1.00 | 1.04 | 1.00
FB_ReadWriteFile | 03.08.04 | 1.04 | 1.04 | 1.00 | 1.04 | 1.00
Memory Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
MEMCMP | 07.03.03 | 0.41 | 0.01 | 1.00 | 0.01 | 1.00
MEMCYP | 07.03.03 | 0.41 | 0.01 | 1.00 | 0.01 | 1.00
MEMMOVE | 07.03.03 | 0.41 | 0.01 | 1.00 | 0.01 | 1.00
MEMSET | 07.03.03 | 0.41 | 0.01 | 1.00 | 0.01 | 1.00
NOVRAM Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
- | - | - | - | - | - | -
Serial Communication Interface | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
FB_COMPortClose | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
FB_COMPortOpen | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
F_COMPortRead | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
F_COMPortWrite | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
SFC | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
AnalyzeExpression | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
AppendErrorString | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
SFCActionControl | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
System / Time / TBus | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
DRAND | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
RTC | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
SYSTEMTIME_TO_DT | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
DT_TO_SYSTEMTIME | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
GetSysTick | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
PresetSysTick | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
Reboot | 21.07.03 | 0.59 | 0.14 | 1.00 | 0.02 | 1.00
Persistent_Data | 21.08.07 | 1.17 | 1.17 | - | 1.17 | 1.17
Debug | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
F_ReadDebugTimer | 08.08.03 | 0.59 | 0.14 | 1.00 | 0.02 | 1.00
F_StartDebugTimer | 08.08.03 | 0.59 | 0.14 | 1.00 | 0.02 | 1.00
NaviSwitch | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
All function blocks | 10.10.03 | 0.64 | 0.14 | 1.00 | 0.02 | 1.00
TcComPortBX
Com FBs | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
All function blocks | 20.08.03 | 0.60 | 0.02 | 1.00 | 0.01 | 1.00


TcBaseBX

Programming [image] Libraries [image] TcBaseBX
TcBaseBX
Additional information
•
System task information
•
System task information type
•
System info
•
System information type
•
ADS
•
COM Port
•
BX debugging function
•
Navigation switch
•
Display


System task information

Programming [image] Libraries [image] TcBaseBX [image] System task information
System task information
VAR_GLOBAL
SystemTaskInfoArr : ARRAY[1..2] OF SYSTEMTASKINFOTYPE;
END_VAR
System flags are implicitly declared variables. Using the Input Assistant, a variable SystemTaskInfoArr can be found under system variables. This variable is a field with four structures of type SYTEMTASKINFOTYPE. The structure definition can be found in the system library. The index in this field is the task ID.
Development environment | Target platform | PLC libraries to be linked
TwinCAT v2.9.0 | BX Controller | TcBaseBX.lbx


System task information type

Programming [image] Libraries [image] TcBaseBX [image] System task information type
System task information type
TYPE SYSTEMTASKINFOTYPE
STRUCT
active : BOOL;
taskName : STRING(16);
firstCycle : BOOL;
cycleTimeExceeded : BOOL;
cycleTime : UDINT;
lastExecTime : UDINT;
priority : BYTE;
cycleCount : UDINT;
END_STRUCT
END_TYPE
Legend
active: This variable indicates whether the task is active.
taskName: the task name.
firstCycle: During the first PLC task cycle, this variable has the value: TRUE.
cycleTimeExceeded: this variable indicates whether the set task cycle time was exceeded.
cycleTime: set task cycle time in multiples of 100 ns.
lastExecTime: cycle time required for the last cycle in multiples of 100 ns.
priority: set task priority.
cycleCount: cycle counter.
Development environment | Target platform | PLC libraries to be linked
TwinCAT v2.9.0 | BX Controller | TcBaseBX.lbx


System info

Programming [image] Libraries [image] TcBaseBX [image] System info
System info
VAR_GLOBAL
SystemInfo : SYSTEMINFOTYPE;
END_VAR
System flags are implicitly declared variables. Using the Input Assistant, a variable Systeminfo can be found under system variables. The type SYSTEMINFOTYPE is declared in the system library. For accessing the variable, the system library has to be integrated in the project.
Development environment | Target platform | PLC libraries to be linked
TwinCAT v2.9.0 | BX Controller | TcBaseBX.lbx


System information type

Programming [image] Libraries [image] TcBaseBX [image] System information type
System information type
TYPE SYSTEMINFOTYPE
STRUCT
runTimeNo : BYTE;
projectName : STRING(32);
numberOfTasks : BYTE;
onlineChangeCount : UINT;
bootDataFlags : BYTE;
systemStateFlags : WORD;
END_STRUCT
END_TYPE
Legend
runTimeNo: specifies the number of the runtime system (1).
projectName: project name as STRING.
numberOfTasks: number of tasks contained in the runtime system (max. 2).
onlineChangeCount: number of online changes since the last complete download.
bootDataFlags: Reserved
systemStateFlags: Reserved.
Development environment | Target platform | PLC libraries to be linked
TwinCAT v2.9.0 | BX Controller | TcBaseBX.lbx


ADS

Programming [image] Libraries [image] TcBaseBX [image] ADS
ADS
Additional information
•
Local ADS Port Numbers - Overview
•
ADS services
•
Deactivating the LED for cycle time exceeding


Local ADS Port Numbers - Overview

Programming [image] Libraries [image] TcBaseBX [image] ADS [image] Local ADS Port Numbers - Overview
Local ADS Port Numbers - Overview
Port number | Description
100dec | Reading and writing of registers and tables from the coupler and the complex Bus Terminals
150dec | Reading and writing of RTC (real-time clock)
153dec | SSB - reading of the emergency message
800dec | Local process image of the PLC, see also port 801
801dec | Local process image of the PLC, see also port 800
0x1000 + node ID | SSB - SDO communication with CANopen node (slave number)


ADS services

Programming [image] Libraries [image] TcBaseBX [image] ADS [image] ADS services
ADS services
Local Process Image PLC Task 1 Port 800/801
Data can be read from and written to the local process image. If it is necessary for outputs to be written, it is important to ensure that they are not used by the local PLC, because the local controller will overwrite these values. The data are not associated with a watchdog, and therefore must not be used for outputs that would have to be switched off in the event of a fault.
Index group | Meaning | Index offset (value range)
0xF020 | Inputs | 0...2047
0xF021 | Bit inputs | 0...16376
0xF030 | Outputs | 0...2047
0xF031 | Bit outputs | 0...16376
0x4020 | Flags | 0...4095
0x4021 | Flag bit | 0...32760
ADS services
AdsServerAdsState
Data type (read only) | Meaning
String | Start - the local PLC is running Start - the local PLC is stopped
AdsServerDeviceState
Data type (read only) | Meaning
INT | 0 - Start - the local PLC is running 1 - Stop - the local PLC is stopped
AdsServerType
Data type (read only) | Meaning
String | BX PLC Server
ADSWriteControl
Data type (write only) | Meaning
NetID | Net ID of the Ethernet Controller*
Port | 800
ADSSTATE | 5 - RUN / 6 - STOP
DEVSTATE | 0
LEN | 0
SRCADDR | 0
WRITE | rising edge starts the function block
TMOUT | example: T#1000 ms
* BC9050, BC9020, BC9120, BX9000
Register access port 100
On the Bus Terminal Controllers of the BX series, and on the BCxx50/xx20, the ADS port number for register communication is fixed at 100.
Index group | Index offset (value range) |  | Meaning
 | Hi-Word | Low Word
0 [READ ONLY] | 0...127 | 0...255 | Registers in the Bus Coupler Hi-Word, table number of the Bus Coupler Lo-Word, register number of the table
1...255 | 0...3 | 1...255 | Register of the Bus Terminals Hi-Word, channel number Lo-Word, register number of the Bus Terminal
Minimum timeout
For reading the registers, ensure that the timeout for the ADS function block is set to more than one second.
Setting the password
When writing to the registers, the password has to be set (see the documentation for the particular Bus Terminal).


Deactivating the LED for cycle time exceeding

Programming [image] Libraries [image] TcBaseBX [image] ADS [image] Deactivating the LED for cycle time exceeding
Deactivating the LED for cycle time exceeding
The BX controller monitors the set task cycle time. If it is exceeded, the cycleTimeExceeded bit and the red PLC LED are set. In some applications the value may be exceeded for short periods, which is tolerable. This may be the case when many data are received in serial communication, for example. In order to avoid flickering of the red PLC LED, it can be switched off via ADSWRITE.
Structure of the ADSWRITE command
This ADSWRITE command enables the red PLC LED of the BX controller to be deactivated.
Input parameters | Description
NETID | local NetId of BX
Port number | 800
IDXGRP | 16#0000_4080
IDXOFFS | 0
LEN | 1 bytes
SRCADDR | Pointer on 1 bytes 0: red LED ON 1: red LED OFF


COM Port

Programming [image] Libraries [image] TcBaseBX [image] COM Port
COM Port
Additional information
•
COM port - overview
•
COM port functions
•
COM port function block
•
ComConfig data structure
•
Example


COM port - overview

Programming [image] Libraries [image] TcBaseBX [image] COM Port [image] COM port - overview
COM port - overview
The library includes function blocks that enable data exchange between the BXxxxx Bus Controller and a remote partner. The maximum COM buffer is 512 bytes for both directions.
Function blocks
Name | Description
FB_ComPortOpen | Opens a serial connection to a partner.
FB_ComPortClose | Closes a serial connection to a partner.
Functions
Name | Description
F_ComPortRead | Reading data from the COM buffer
F_ComPortWrite | Writing data into the COM buffer
Supported baud rates
Baud rate [baud] | COM 1 | COM 2
300 | NO | YES
600 | NO | YES
1200 | NO | YES
2400 | NO | YES
4800 | NO | YES
9600 | YES | YES
19200 | YES | YES
38400 | YES | YES
57600 | YES | YES
115200 | NO | YES
Further helpful function blocks can be found in TcComPortBX.lbx.
▪
Function block for using ComLib, ModbusRTU etc. for the BX COM ports
▪
Function block for communication with the BK8x00 Bus Couplers
▪
Function block for emulation of a BK8x00 slave


COM port functions

Programming [image] Libraries [image] TcBaseBX [image] COM Port [image] COM port functions
COM port functions
COM Port Read
Function block F_COMPORTREAD
FUNCTION F_COMPORTREAD
VAR_INPUT
hCom :INT;
cbRxBuffer :UINT;
pRxBuffer :UDINT;
Legend
hCom: is connected with the iHandle of FB_COMPORTOPEN
cbRxBuffer: maximum length of data that can be read.
pRxBuffer: pointer to data to be written with the COM buffer content
Return value | Meaning
> 0 | Number of bytes that is to be copied from the COM buffer into the PLC.
0x8000 | Memory overflow
COM Port Write
Function block F_COMPORTWRITE
FUNCTION F_COMPORTWRITE
VAR_INPUT
hCom :INT;
cbTxBuffer :UINT;
pTxBuffer :UDINT;
Legend
hCom: is connected with the iHandle of FB_COMPORTOPEN
cbTxBuffer: Number of data bytes that were copied into the COM buffer.
pTxBuffer: Pointer to the data from which the COM buffer is to be filled.
Return value | Meaning
> 0 | Number of bytes that is to be copied into the COM buffer from the PLC
0x8000 | Memory overflow


COM port function block

Programming [image] Libraries [image] TcBaseBX [image] COM Port [image] COM port function block
COM port function block
COM Port Open
Function block FB_COMPORTOPEN
FUNCTION_BLOCK FB_COMPORTOPEN
VAR_INPUT
bOpen :BOOL;
stComConfig :ST_COMCONFIG;
Legend
bOpen: rising edge starts the function block
stComConfig: COM interface data structure
VAR_OUTPUT
bBusy :BOOL;
bErr :BOOL;
iErrId :WORD;
iHandle :WORD;
Legend
bBusy: The function block is active as long it is TRUE.
bErr: Error bit.
iErrId: Error number.
iHandle: pointer transfer.
Return parameter iErrId | Meaning
0 | No error
-1, 0xFFFF | Incorrect COM port
-2, 0xFFFE | Incorrect or unsupported baud rate. Check the parameter stComConfig.BaudRate.
-3, 0xFFFD | Incorrect data format. Check the parameter stComConfig.
-4, 0xFFFC | Incorrect initialization of the COM interface
-5, 0xFFFB | Unsupported instance
-6, 0xFFFA | Incorrect size of the RX buffer
-7, 0xFFF9 | Incorrect size of the TX buffer
-8, 0xFFF8 | COM port is blocked
COM Port Close
Function block FB_COMPORTCLOSE
FUNCTION_BLOCK FB_COMPORTCLOSE
VAR_INPUT
bOpen :BOOL;
iHandle :WORD;
Legend
bClose: rising edge starts the function block
iHandle: pointer transfer of FB_COMPORTOPEN.
VAR_OUTPUT
bBusy :BOOL;
bErr :BOOL;
iErrId :WORD;
Legend
bBusy: The function block is active as long it is TRUE.
bErr: Error bit.
iErrId: Error number.
Return parameter iErrId | Meaning
0 | No error
> 0 | error number (#not documented#)


ComConfig data structure

Programming [image] Libraries [image] TcBaseBX [image] COM Port [image] ComConfig data structure
ComConfig data structure
The settings for the serial interfaces of the BX are transferred with the following data structure.
TYPE ST_COMConfig:
STRUCT
cbRxBufferLen :WORD;
cbTxBufferLen :WORD;
dwMode :DWORD;
BaudRate :DWORD;
eCommPort :E_CommPort;
eDataBits :E_DataBits;
eParity :E_Parity;
eStoppBits :E_StoppBits;
END_STRUCT
END_TYPE
Legend
cbRxBufferLen: Has no purpose (was retained for compatibility reasons)
cbTxBufferLen: Has no purpose (was retained for compatibility reasons)
dwMode: data mode COM 1 only "0" - COM 2 RS232 "0" and RS485 "1"
BaudRate: Baud rate
eCommPort: Com Port COM1/COM2
eDataBits: number of data bits SEVEN_DATABITS/EIGHT_DATABITS
eParity: EVEN/ODD/NONE
eStoppBits: Number of stop bits ONE_STOPPBIT/TWO_STOPPBITS


Example

Programming [image] Libraries [image] TcBaseBX [image] COM Port [image] Example
Example
ST sample program
Download ( )
PROGRAM MAIN
VAR
(* EXAMPLE - BRIDGE between PIN 7 and 8 from X01 COM 2 Port*)
fb_COMPortOpen_1 : FB_COMPortOpen;
stCOMConfig_1 : ST_COMConfig;
hCOM : WORD;
Result_R : INT;
Result_W : INT;
Var_M : ARRAY[0..9] OF BYTE:=11,22,0,33,0(6);
Var_R : ARRAY[0..9] OF BYTE;
Value : INT;
Counter_V : BYTE; (* It is all OK, this value counts up *)
i : INT;
i_k : INT;
fbTimer : TON;
END_VAR
stCOMConfig_1.cbRxBufferLen :=300;
stCOMConfig_1.cbTxBufferLen :=300;
stCOMConfig_1.dwMode :=0;
stCOMConfig_1.BaudRate :=19200;
stCOMConfig_1.eCommPort :=COM2;
stCOMConfig_1.eDataBits:=EIGHT_DATABITS;
stCOMConfig_1.eParity:=EVEN;
stCOMConfig_1.eStoppBits:=ONE_STOPPBIT;

CASE i OF
(* Open Port *)
0: fb_COMPortOpen_1(bOpen:=TRUE , stCOMConfig:=stCOMConfig_1);
IF NOT fb_COMPortOpen_1.bBusy THEN
IF NOTfb_COMPortOpen_1.bError THEN
hCOM:=fb_COMPortOpen_1.iHandle ;
i:=i+1;
ELSE

i:=100;
END_IF
END_IF
(* Write data*)
1: fbTimer(IN:=FALSE);
Result_W:=F_COMPortWrite(hCom, 4,ADR(Var_M[0]));
IF Result_W>0 THEN
i:=i+1;
Var_M[2]:=Var_M[2]+1;
ELSE
i:=101;
END_IF
(*Receive data*)
2: Result_R:=F_COMPortRead(hCom, 100,ADR(Var_R[Value]));
IF Result_R<>0 THEN
Value:=Result_R+Value;
END_IF
IF Value>=4 THEN
FOR i_k:=0 TO Value DO(*Check protocol*)
IF Var_R[i_k-4]=11 AND Var_R[i_k-3]=22 AND Var_R[i_k-1]=33 THEN
Counter_V:=Var_R[i_k-2];
i:=1;
Value:=0;
END_IF
END_FOR
END_IF
fbTimer(IN:=TRUE,PT:=t#1s); (*Watchdog receive*)
IF fbTimer.Q THEN
fbTimer(IN:=FALSE);
i:=102;
END_IF
100: ; (*ERROR open port*)
101: ; (*ERROR send data*)
102: i:=1; (*WD ERROR no data receive*)
END_CASE


BX debugging function

Programming [image] Libraries [image] TcBaseBX [image] BX debugging function
BX debugging function
These functions can be used for measuring command execution times in a PLC project. The unit is a tick. One tick corresponds to 5.12 µs.
Start Debug Timer function
Function block F_STARTDEBUGTIMER
Calling this function starts the timer. The return value is "0".
Read Debug Timer function
Function block F_READDEBUGTIMER
This function reads the timer value. The return value has to be multiplied with 5.12 µs.
Example
VAR
Timer_BX :WORD;
i :INT;
END_VAR
Program
F_STARTDEBUGTIMER();
For i:=0 to 1000 do
;
END_FOR
Timer_BX:=F_READDEBUGTIMER();


Navigation switch

Programming [image] Libraries [image] TcBaseBX [image] Navigation switch
Navigation switch
Additional information
•
FUN GetNavSwitch


FUN GetNavSwitch

Programming [image] Libraries [image] TcBaseBX [image] Navigation switch [image] FUN GetNavSwitch
FUN GetNavSwitch
This function block enables reading of the navigation switch.
Function block F_GETNAVSWITCH
VAR_Output
F_GETNAVSWITCH :WORD;
Legend
F_GETNAVSWITCH: Switch data
WORD description
Bit | 15 | 14 | ... | 5 | 4 | 3 | 2 | 1 | 0
Name | LOCKED | - | ... | - | PRESS | RIGHT | LEFT | DOWN | UP
If bit 15 is set, you are in the BX controller menu. This bit is set for as long as the user remains in the BX3100 menu. On exit of the menu, the navigation switch is immediately released for the PLC, i.e. pressing of the Press button is still visible in the program. Please take account of this in your application. For example, the switch should only be evaluated after a short delay by starting a timer with falling edge from bit 15.
Download sample ST program


Display

Programming [image] Libraries [image] TcBaseBX [image] Display
Display
Additional information
•
FB DISPWRITE


FB DISPWRITE

Programming [image] Libraries [image] TcBaseBX [image] Display [image] FB DISPWRITE
FB DISPWRITE
Function block FB_DISPWRITE
VAR_INPUT
bWrite :BOOL;
bBlanking :BOOL;
nRow :UINT;
sData :STRING(16)
Legend
bWrite: rising edge starts the function block
bBlanking: FALSE backlight on, TRUE backlight off, default is on (supported in all BX controllers from FW 1.15).
nRow: row in display 1 or 2.
sData: displayed character string
VAR_OUTPUT
bBusy :BOOL;
bErr :BOOL;
iErrId :WORD;
Legend
bBusy: The function block is active as long it is TRUE.
bErr: Error bit.
iErrId: Error number.
Return parameter | Meaning
0 | No error
> 0 | Error number
ST sample program
Download
PROGRAM MAIN
VAR
fb_DispWrite1: FB_DispWrite;

i: INT;
udiCounter: UDINT;
strCounter: STRING;
strLine: STRING;
k: INT;
END_VAR
CASE i OF
0: strCounter:=CONCAT('Counter :',UDINT_TO_STRING(udiCounter));
fb_DispWrite1(bWrite:=TRUE , nRow:=1 ,sData:=strCounter );
IF NOT fb_DispWrite1.bBusy THEN
IF NOTfb_DispWrite1.bErr THEN
fb_DispWrite1(bWrite:=FALSE);
udiCounter:=udiCounter+1;
i:=1;
END_IF
END_IF
1: fb_DispWrite1(bWrite:=TRUE , nRow:=2 , sData:=strLine);
IF NOT fb_DispWrite1.bBusy THEN
IF NOTfb_DispWrite1.bErr THEN
fb_DispWrite1(bWrite:=FALSE);
k:=k+1;
strLine:=REPLACE(' ','#',1,k);
IF k=16 THEN
k:=0;
END_IF
i:=0;
END_IF
END_IF
END_CASE
Display of ASCII table
Example for the "&" sign (see row 1 column 7): 00100110bin = 38dec = 26hex. In the PLC values this corresponds to '$26' (string.)


TcSystemBX

Programming [image] Libraries [image] TcSystemBX
TcSystemBX
Additional information
•
Real-time clock - example
•
Loading and storing of recipes


Real-time clock - example

Programming [image] Libraries [image] TcSystemBX [image] Real-time clock - example
Real-time clock - example
The BX Controller features a real-time clock. The current time can be read via a function block. The following example will illustrate this.
Function block RTC
FUNCTION_BLOCK RTC
VAR_INPUT
EN :BOOL;
PDT :DT;
Legend
EN: Rising edge sets the time to the value available at the PDT input.
PDT: Date and time to be set.
VAR_OUTPUT
Q :BOOL;
CDT :BOOL;
Legend
CDT: Current time.
Required libraries:
▪
TcSystemBX.lb6
▪
TcBaseBX.lb6
Download sample ST program ( )
PROGRAM MAIN
VAR
fbTimer: TON;
fbRTC: RTC;
END_VAR
fbTimer(PT:=t#60s,IN:=NOT fbTimer.Q);

IF fbTimer.Q THEN
fbRTC;
END_IF
Do not call the RTC function block in every PLC cycle
Calling the RTC block increases the cycle time by approx. 5 ms, due to the data conversion into a TIME AND DATE variable. The function block should therefore not be called during each PLC cycle.
Alternatively, you can read the time via an . The ADS function block returns the date and the time as WORD variables.
Example 19:30 hrs - hour: 19 / minute: 30


Loading and storing of recipes

Programming [image] Libraries [image] TcSystemBX [image] Loading and storing of recipes
Loading and storing of recipes
The function block fb_ReadWriteFile enables data (up to 16,000 bytes) to be stored permanently in the flash memory of the BX controller. A new program or a project reset does not affect the content of this memory. This function block is not suitable for sustained and continuous use. A maximum of 10000 write cycles are permitted. There is no limit on read operations.
Application: Saving of recipes or settings that only change rarely or not at all, for example controller parameters.
Note the following during writing of data
•
The voltage must not be interrupted during writing. It is therefore advisable to initiate writing via an operating panel or the navigation keys or simply via a digital input, in order to ensure that the BX Controller is not switched off during writing. Automatic writing is not recommended, since uninterrupted voltage supply during writing cannot be guaranteed.
•
Writing of data takes approx. two seconds, irrespective of the number of data that are written.
•
The data are lost if the BX controller is switched off during the write operation.
•
Only one instance of this function block is permitted.
Function block fb_ReadWriteFile
Function block for reading and writing of recipes
Function block fb_ReadWriteFile
VAR_INPUT
bRead :BOOL;
bWrite :BOOL;
OffsetRead :WORD;
DataReadSize :WORD;
DataRead :Pointer to Byte;
OffsetWrite :WORD;
DataWriteSize :WORD;
DataWrite :Pointer to Byte;
Legend
bRead: A rising edge triggers reading of the function block (bWrite must be FALSE)
bWrite: A rising edge triggers writing of the function block (bRead must be FALSE)
OffsetRead: Offset in the memory 16,000 bytes max.
DataReadSize: Size of data to be read in bytes (16,000 bytes max.)
DataRead: The pointer should be pointed to the data via ADR
OffsetWrite: Offset in the memory 16,000 bytes max.
DataWriteSize: Size of data to be written in bytes (16,000 bytes max.)
DataWrite: The pointer should be pointed to the data via ADR
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
bErrorId :UDINT
Legend
bBusy: Indicates that the function block is still active
bError: Function block error
bErrorId: Error number
Return parameter iErrorId | Meaning
0 | No error
1dec | READ: Data offset and data length more than 16,000 bytes
2dec | WRITE: Data offset and data length more than 16,000 bytes
0x31440708 | CRC error in the data memory
0x31470708 | Writing of data is not yet complete
Required libraries:
▪
TcSystemBX.lb6
▪
TcBaseBX.lb6
Download sample ST program ( )


TcComPortBX

Programming [image] Libraries [image] TcComPortBX
TcComPortBX
Additional information
•
TcComPortBX overview
•
BK8x00 - FB COM-Port
•
BK8x00 - FB Slave COM-Port
•
FB_BX_COM_5
•
FB_BX_COM_64
•
FB_BX_COM_64ex
•
Further samples


TcComPortBX overview

Programming [image] Libraries [image] TcComPortBX [image] TcComPortBX overview
TcComPortBX overview
Required libraries:
▪
TcBaseBX
▪
TcSystemBX
Overview
Name | Description
fb_BX_BK8x00 Master | BK8x00 COM port function block, communication with Bus Coupler BK8x00 or BC8x00
fb_BX_BK8x00 Slave | BK8x00 COM port function block, communication with PC. A BK8x00 is simulated.
Name | Description
FB_BX_COM_5 | Function block for emulating a KL60x1(if COMlib.lb6 or ModbusRTU.lb6 is used).
FB_BX_COM_64 | Function block for emulating a PC interface (if COMlib.lib or ModbusRTU.lib is used).
FB_BX_COM_64ex | Function block for emulating a PC interface (if COMlib.lib or ModbusRTU.lib is used). Here the COM interface can be closed during operation.


BK8x00 - FB COM-Port

Programming [image] Libraries [image] TcComPortBX [image] BK8x00 - FB COM-Port
BK8x00 - FB COM-Port
This function block can be used to connect (via the serial interface of the BXxxxx) the BK8000 serial Bus Coupler with RS485 and BK8100 with RS232 connection. The maximum baud rate is 38400 baud.
Function block FB_BX_BK8X00_master
VAR_INPUT
stCOMConfig :ST_COMConfig;
byAddress :BYTE;
byLen :BYTE;
byMaxInputLen :BYTE;
ptDataOut :POINTER TO BYTE;
ptDataIN :POINTER TO BYTE;
bStart :BOOL;
TmOut :TIME;
Legend
stComConfig: Structure for selecting the COM parameters
byAddress: BX8x00 address 1-98 (0 and 99 are reserved)
byLen: data length in [BYTES] (only even numbers are permitted, i.e. 0, 2, 4, ...)
byMaxInputLen: is connected with SIZEOF and the variable that is linked with ptDataIN
ptDataOut: is connected with ADR and data out
ptDataIn: is connected with ADR and data in
bStart: rising edge starts the function block
TMOut: delay until process is aborted
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
iErrorId :WORD;
Input_len :WORD;
Legend
bBusy: The function block is active as long it is TRUE.
bError: error bit
iErrorID: Error number
Input_Len: number of data that were received
Return parameter iErrorId | Meaning
0 | No error
100dec | Error during opening of the COM port
101dec | Error during sending of data
102dec | Watchdog error, no response from the slave within the WD time
105dec | The input buffer is too small
200dec | CRC error
0x80xxhex | Bus Coupler error xx status byte of the Bus Coupler (see BX8x00 documentation)
Hardware
RS 232 communication PIN assignment
BX COM1 RS232 | BX COM2 RS232 | BK8100
2 | 8 | 2
3 | 7 | 3
5 | 5 | 5
RS485 communication PIN assignment
FB settings: When using the RS485 connection it is important that the stCOMConfig variable is set to 1 and that the COM2 interface is selected.
BX COM2 RS485 | BK8000
1 | 3
6 | 8
ST example program
Download ( )
Required material:
▪
BX3100 + Bus Terminal
▪
BK8100, KL1xx8, KL2xx8, KL9010
▪
Serial cable, PIN assignment: see sample program


BK8x00 - FB Slave COM-Port

Programming [image] Libraries [image] TcComPortBX [image] BK8x00 - FB Slave COM-Port
BK8x00 - FB Slave COM-Port
With this function block, the PC (TwinCAT or KS8000) can be connected with the BXxxxx via the serial interface. The PC acts as the serial master, and the BXxxxx emulates a BK8x00 with the aid of the function block.
Function block FB_BX_BK8X00_SLAVE
VAR_INPUT
stCOMConfig :ST_COMConfig;
byAddress :BYTE;
byLenDataOut :BYTE;
byLenDataIN :BYTE;
ptDataOut :POINTER TO BYTE;
ptDataIN :POINTER TO BYTE;
WDTime :TIME;
Legend
stComConfig: Structure for selecting the COM parameters
byAddress: BX8x00 address 1-98 (0 and 99 are reserved)
byLenDataOut: data length in [BYTES] (only even numbers are permitted, i.e. 0, 2, 4, ...)
byLenDataIn: data length in [BYTES] (only even numbers are permitted, i.e. 0, 2, 4, ...)
ptDataOut: is connected with ADR and data out
ptDataIn: is connected with ADR and data in
WDTime: error message if no new data are received within the watchdog time (0 ms disable WD)
VAR_OUTPUT
bError :BOOL;
iErrorId :WORD;
Input_Len :BYTE;
Legend
bError: error bit
iErrorId: Error number
Input_Len: number of data that were received
Return parameter iErrorId | Meaning
0 | No error
1 | Watchdog error, if greater than 0 ms (WD disable if 0 ms)
100dec | Error during opening of the COM port
101dec | Error during sending of data
103dec | Internal receive buffer overflow
104dec | Data exceed the PLC buffer capacity (more than 500 bytes)
105dec | Data cannot be copied into the PLC buffer
200dec | CRC error
Hardware
RS232 communication PIN assignment
BX COM 1 RS232 | BX COM 2 RS232 | PC COM interface
2 | 8 | 2
3 | 7 | 3
5 | 5 | 5
RS485 communication PIN assignment
FB settings: When using the RS485 connection it is important that the stCOMConfig variable is set to 1 and that the COM2 interface is selected.
BX COM 2 RS485 | PC COM port (e.g. RS485 card W&T #13601, 2-wire, without echo, automatic)
1 | 1 - 2 bridges
6 | 6 - 7 bridges
ST sample program for BXxxx
Download ( )
System Manager file for TwinCAT as master. As shown in the figure, a Bus Coupler with Bus Terminals is configured. In this case, the type and number of Bus Terminals determines the data length. In principle, the type of Bus Terminal is irrelevant. Sample:
▪
2 x KL3002 results in 4 words of input
▪
2 x KL4002 results in 4 words of output
Communication features
Required material:
▪
BX3100 + Bus Terminal
▪
PC with RS232 interface and TwinCAT from version 2.9, serial cable, PIN assignment: see above


FB_BX_COM_5

Programming [image] Libraries [image] TcComPortBX [image] FB_BX_COM_5
FB_BX_COM_5
This function block connects ModbusRTU.lb6, ModbusRTU.lib or ComLib.lb6 with the serial interface of the BX Controller. It emulates a KL60x1 - data output is not via a Bus Terminal, but via one of the two serial interfaces of the BX.
Function block FB_BX_COM_5
VAR_INPUT
pstrEmo_IN :POINTER TO BYTE;
pstrEmo_OUT :POINTER TO BYTE;
ComConfig :ST_COMConfig;
Legend
pstrEmo_IN: Pointer to KL6inData5B
pstrEmo_OUT: Pointer to KL6outData5B
ComConfig: Parameterization of the COM interface
Download sample program in ST for linking COMLib and BX: ( )


FB_BX_COM_64

Programming [image] Libraries [image] TcComPortBX [image] FB_BX_COM_64
FB_BX_COM_64
This function block connects ModbusRTU.lib or ComLib.lib with the serial interface of the BX Controller. It emulates a PC interface. Data output is not via a PC interface, but via one of the two serial interfaces of the BX (COM1 or COM2).
Function block FB_BX_COM_64
VAR_INPUT
pstrEmo_IN :POINTER TO BYTE;
pstrEmo_OUT :POINTER TO BYTE;
ComConfig :ST_COMConfig;
Legend
pstrEmo_IN: Pointer to ModbusPCComInData
pstrEmo_OUT: Pointer to ModbusPCComInData
ComConfig: Parameterization of the COM interface
Download sample program in ST for linking ModbusRTU and BX: ( )
Download sample program in ST for linking ModbusRTU version 2 and BX: ( )
The sample requires the ModbusRTU library!


FB_BX_COM_64ex

Programming [image] Libraries [image] TcComPortBX [image] FB_BX_COM_64ex
FB_BX_COM_64ex
This function block connects ModbusRTU.lib or ComLib.lib with the serial interface of the BX Controller. A PC interface with 64 byte of user data is emulated. Data output is not via a PC interface, but via one of the two serial interfaces of the BX (COM1 or COM2).
Function block FB_BX_COM_64EX
VAR_INPUT
pstrEmo_IN :POINTER TO BYTE;
pstrEmo_OUT :POINTER TO BYTE;
ComConfig :ST_COMConfig;
VAR_OUTPUT
ComPortIsClose :BOOL;
bError :BOOL;
iErrorId :INT;
Legend
pstrEmo_IN:
Pointer to ModbusPCComInData
pstrEmo_OUT:
Pointer to ModbusPCComOutData
ComConfig:
Parameterization of the COM interface
COM_Port_Open:
If this bit is set, the interface is opened. If this bit is reset, the interface is closed.
ComPortIsClose:
If the interface is closed, this bit is set.
bError:
There is an error.
iErrorId:
Error code (see FB_COMPortOpen)
Download sample program in ST for linking ModbusRTU and BX: ( )
The sample requires the ModbusRTU library!


Further samples

Programming [image] Libraries [image] TcComPortBX [image] Further samples
Further samples
Additional information
•
BX COM port as ModbusRTU master
•
BX COM port - ComLibV2
•
BX COM port - Cimrex panel
•
BX COM port - RK512 protocol
•
BX COM port - text message via mobile phone


BX COM port as ModbusRTU master

Programming [image] Libraries [image] TcComPortBX [image] Further samples [image] BX COM port as ModbusRTU master
BX COM port as ModbusRTU master
The serial interface of the BX can also be used as Modbus master.
Necessary components
1 x BX3100
Bus Terminals for the K-Bus (any, since they are not used for the example)
1 x BK7300
2 x KL2xx4
2 x KL1xx4
1 x KL9010
RS 485 cable*
BX3100 COM 2 / RS 485 | BK7300 / RS 485
1 | 3
6 | 8
*) active termination resistor required for short cable lengths (< 5 m) and low baud rates (<19200 baud)
Download ST sample program for linking the ModbusRTU master and BX: ( )
Download ST sample program for linking the ModbusRTU master version 2 and BX: ( )
The example requires the ModbusRTU, TcComPortBC, TcBaseBX libraries.
Baud rate 9600, n, 8.1 default BK7300,
BK7300 address 11
Reaction times
The reaction times depend on the set task time, the number of slaves, the length of the Modbus telegrams and the response time of the slaves.
Beckhoff BK7300 Modbus slaves were used for determining the following table. Since this is not transferable to all slaves, the table should only be used for guidance.
Baud rate 38400 baud (one read reg. and one write reg. telegram per slave)
Number of slaves | Task time on the BX | Time for one cycle
1 | 5 | 100 ms* / 125 ms**
2 | 5 | 200 ms / 225 ms
1 | 10 | 180 ms / 220 ms
2 | 10 | 350 ms / 390 ms
1 | 20 | 350 ms / 350 ms
2 | 20 | 700 ms / 700 ms
*) 2 words inputs and 2 words outputs
*) 20 words inputs and 20 words outputs


BX COM port - ComLibV2

Programming [image] Libraries [image] TcComPortBX [image] Further samples [image] BX COM port - ComLibV2
BX COM port - ComLibV2
Examples for ComLibV2 sending of strings via the internal COM interface of the BX controller. For receiving a bridge can be established from PIN 7 and 8 to X01 (COM2).
Required material
Hardware:
▪
BX Controller
Software:
▪
TwinCAT from 2.10
▪
COMlibV2.lib
▪
TcComPortBX.lbx
▪
Standard.lbx
▪
TcBase.lbx
▪
TcSystemBX.lbx
Download BX sample program: ( )


BX COM port - Cimrex panel

Programming [image] Libraries [image] TcComPortBX [image] Further samples [image] BX COM port - Cimrex panel
BX COM port - Cimrex panel
The serial interface of the BX controller can also be used as Modbus slave. In this example, a panel from the company Beijers is connected. Further information on the panel can be found under http://www.beijerelectronics.de.
Cimrex panel at the COM port of the BX controller
Necessary components
▪
1 x BX3100
▪
1 x Cimrex 12
▪
any Bus Terminals (any, since no Bus Terminals are used in the example)
RS232 cable
BX3100 COM 2 / RS485 | Cimrex 12 RS232
7 | 2
8 | 3
9 | 5
RS485* cable
BX3100 COM 2 / RS 485 | Cimrex 12 RS485
1 | 2 -3
6 | 15 -16
*) active termination resistor is not required for short cable lengths (≤ 5 m) and low baud rates (≤19200 baud)
Download sample program in ST for the BX: ( )
Download sample with Cimrex panel: ( )
The example requires the ModbusRTU, TcComPortBC and TcBaseBX libraries.
- Baud rate 9600,n,8,1 D
- Cimrex 12


BX COM port - RK512 protocol

Programming [image] Libraries [image] TcComPortBX [image] Further samples [image] BX COM port - RK512 protocol
BX COM port - RK512 protocol
The RK512 protocol can exchange data with a distant station via the COM1 or COM2 interface of the BX controller. Documentation for the RK512 function block can be found in the Beckhoff Information System.
The serial PC interface is simulated via the 64 byte emulation of the BX controller.
Required material
Hardware:
▪
PC with RS232 interface and TwinCAT PLC from 2.9
▪
BX Controller
▪
Serial cable for the BX - PC connection
Software:
▪
TwinCAT from 2.9
▪
COMlib.lib
▪
COMlib3964R.lib
▪
COMlibRK512.lib
▪
TcComPortBX.lbx
▪
Standard.lbx
▪
TcBase.lbx
▪
TcSystemBX.lbx
▪
ChrAscBx.lbx
Download sample program BX3100: ( )
Download PC sample program: ( )
Download sample System Manager file PC: ( )


BX COM port - text message via mobile phone

Programming [image] Libraries [image] TcComPortBX [image] Further samples [image] BX COM port - text message via mobile phone
BX COM port - text message via mobile phone
The serial interface can also be used for sending a text message from the BX controller. The following example uses the SMS library with a Siemens S35 mobile phone.
Mobile phone at the COM port of the BX controller
Download: ( )
Pin assignment (Siemens cable S30880-S4501 A801-2)
S35 | COM 1 | COM 2
2 | 3 | 7
3 | 2 | 8
5 | 5 | 9


TcTwinSAFE

Programming [image] Libraries [image] TcTwinSAFE
TcTwinSAFE
Additional information
•
Overview
•
FUNCTION F_GetVersionTcTwinSAFE
•
FUNCTION_BLOCK FB_TwinSAFE_KLx904_input
•
FUNCTION_BLOCK FB_TwinSAFE_KLx904_output


Overview

Programming [image] Libraries [image] TcTwinSAFE [image] Overview
Overview
The Bus Terminal Controllers of the BX series support the TwinSAFE Bus Terminals when the following conditions are met:
▪
At the Bus Terminal Controller only one logic terminal is permitted. It must be connected to the K-bus interface, not the SSB.
▪
At this logic terminal a maximum of seven connections are permitted.
▪
TwinSAFE-input and output terminals can be connected to the K-bus or the SSB, for example via BK5120 or BK515x.
▪
If the online change feature is to be used, the connection timeout must be set to 500 ms or greater.
▪
An ADS connection must exist for downloading the TwinSAFE projects. The connection can be serial or via the fieldbus.
▪
The firmware version of the Bus Terminal Controller must be 1.17 or higher.
TwinSAFE library
The TwinSAFE library includes function blocks for executing services/functions in connection with the TwinSAFE terminals KL1904, KL2904 and KL6904.
Name | Description
F_GetVersionTcTwinSAFE | Library version number
FB_TwinSAFE_KLx904_input | Evaluation of TwinSAFE data sent from a KL1904 or KL2904 to a KL6904
FB_TwinSAFE_KLx904_output | Evaluation of TwinSAFE data sent from a KL6904 to a KL1904 or KL2904
Download of the TwinSAFE library: ( )


FUNCTION F_GetVersionTcTwinSAFE

Programming [image] Libraries [image] TcTwinSAFE [image] FUNCTION F_GetVersionTcTwinSAFE
FUNCTION F_GetVersionTcTwinSAFE
Function block F_GETVERSIONTCTWINSAFE
This function can be used to read PLC library version information.
FUNCTION F_GetVersionTcTwinSAFE : UINT
VAR_INPUT
nVersionElement : INT;
END_VAR
nVersionElement: Version element to be read. Possible parameters:
▪
1 : major number;
▪
2 : minor number;
▪
3 : revision number;
Development environment | Target platform | IO Hardware | PLC libraries to include
TwinCAT v2.10.0 Build > 914 | PC (i386) | - | TcTwinSAFE.Lib (Standard.lib, TcBase.Lib and TcSystem.Lib are integrated automatically)
TwinCAT v2.10.0 | BX series | - | TcTwinSAFE.LBX (Standard.LBX; TcBaseBX.LBX; TcSystemBX.LBX are integrated automatically)


FUNCTION_BLOCK FB_TwinSAFE_KLx904_input

Programming [image] Libraries [image] TcTwinSAFE [image] FUNCTION_BLOCK FB_TwinSAFE_KLx904_input
FUNCTION_BLOCK FB_TwinSAFE_KLx904_input
Function block FB_TWINSAFE_KLX904_INPUT
The function block FB_TwinSAFE_KLx904_input can be used for evaluation of TwinSAFE data sent from a KL1904 or KL2904 to a KL6904. The input parameter is doubly linked to the SafetyIn data of a KL1904 or KL2904 in the System Manager.
VAR_INPUT
VAR_INPUT
KLx904_SafetyIn AT%I* : TwinSAFE_Data; (* Additional link to "SafetyIn" *)
END_VAR
KLx904_SafetyIn: TwinSAFE telegram sent from a KL1904 or KL2904 to a KL6904. This parameter is doubly linked to SafetyIn in the System Manager (input data of the KLx904).
VAR_OUTPUT
VAR_OUTPUT
bInput1 : BOOL;
bInput2 : BOOL;
bInput3 : BOOL;
bInput4 : BOOL;
tCycleTime : TIME;
bConnectionInRun : BOOL;
END_VAR
bInput1: Returns input 1 of a KL1904. If this function block is used for connection to a KL2904, the value is always 0.
bInput2: Returns input 2 of a KL1904. If this function block is used for connection to a KL2904, the value is always 0.
bInput3: Returns input 3 of a KL1904. If this function block is used for connection to a KL2904, the value is always 0.
bInput4: Returns input 4 of a KL1904. If this function block is used for connection to a KL2904, the value is always 0.
tCycleTime: Returns the cycle time in ms for exchanging the TwinSAFE telegram between the devices.
bConnectionInRun: Returns TRUE if there is no error in the connection between the KLx904 and the KL6904.
Example of a call in the FBD:
PROGRAM MAIN
VAR
fbTwinSAFE_KLx904_input : FB_TwinSAFE_KLx904_input;
bInput1_KL1904_S_Address_113 : BOOL;
bInput2_KL1904_S_Address_113 : BOOL;
bInput3_KL1904_S_Address_113 : BOOL;
bInput4_KL1904_S_Address_113 : BOOL;
tCycleTime_KL1904_KL6904 : TIME;
bConnection3_In_Run : BOOL;
END_VAR
Function block FB_TWINSAFE_KLX904_input
In the example the values of the KL1904 input data are written to the connected variables. If the output bConnectionInRun is FALSE, all outputs are set to FALSE.
To link the input data, select the parameter KLx904_SafetyIn and select "Modify link..." from the context menu.
Linking the input data
and select the corresponding SafetyIn variable in the dialog that follows.
Selecting the SafetyIn variable
Development environment | Target platform | IO Hardware | PLC libraries to include
TwinCAT v2.10.0 Build > 914 | PC (i386) | KLx904 | TcTwinSAFE.Lib (Standard.lib, TcBase.Lib and TcSystem.Lib are integrated automatically)
TwinCAT v2.10.0 Build > 914 | BX series | KLx904 | TcTwinSAFE.LBX (Standard.LBX, TcBaseBX.LBX and TcSystemBX.LBX are integrated automatically)


FUNCTION_BLOCK FB_TwinSAFE_KLx904_output

Programming [image] Libraries [image] TcTwinSAFE [image] FUNCTION_BLOCK FB_TwinSAFE_KLx904_output
FUNCTION_BLOCK FB_TwinSAFE_KLx904_output
Function block FB_TWINSAFE_KLX904_output
The function block FB_TwinSAFE_KLx904_output can be used for evaluation of TwinSAFE data sent from a KL6904 to a KL1904 or KL2904. The input parameter is doubly linked to the SafetyQBx data of a KL6904 in the System Manager.
VAR_INPUT
VAR_INPUT
KL6904_SafetyQBx AT%I* : TwinSAFE_Data; (* Additional link to "SafetyQBx" *)
END_VAR
KL6904_SafetyQBx: TwinSAFE telegram sent from a KL6904 to a KL1904 or KL2904. This parameter is doubly linked to SafetyQBx in the System Manager (input data of the KL6904); x represents for numerals between 1 and 15, according to the TwinSAFE connection used.
VAR_OUTPUT
VAR_OUTPUT
bOutput1 : BOOL;
bOutput2 : BOOL;
bOutput3 : BOOL;
bOutput4 : BOOL;
tCycleTime : TIME;
bConnectionInRun : BOOL;
END_VAR
bOutput1: Returns output 1 of a KL2904. If the function block is used for a connection to the KL1904, this value is always 0.
bOutput2: Returns output 2 of a KL2904. If the function block is used for a connection to the KL1904, this value is always 0.
bOutput3: Returns output 3 of a KL2904. If the function block is used for a connection to the KL1904, this value is always 0.
bOutput4: Returns output 4 of a KL2904. If the function block is used for a connection to the KL1904, this value is always 0.
tCycleTime: Returns the cycle time in ms for exchanging the TwinSAFE telegram between the devices.
bConnectionInRun: Returns TRUE if there is no error in the connection between the KL6904 and the KLx904.
Example of a call in the FBD
PROGRAM MAIN
VAR
fbTwinSAFE_KLx904_output : FB_TwinSAFE_KLx904_output;
bOutput1_KL6904_Connection_to_113 : BOOL;
bOutput2_KL6904_Connection_to_113 : BOOL;
bOutput3_KL6904_Connection_to_113 : BOOL;
bOutput4_KL6904_Connection_to_113 : BOOL;
tCycleTime_KL6904_KL1904 : TIME;
bConnection3_In_Run_2 : BOOL;
END_VAR
Call of function block FB_TWINSAFE_KLX904_OUTPUT
In the example the values of TwinSAFE terminals KL6904 and KL1904 are evaluated. Since no output signals are used in this connection, the outputs are always FALSE. Only tCycleTime and bConnectionInRun can be evaluated.
Call of function block FB_TWINSAFE_KLX904_OUTPUT
In the example the values of TwinSAFE terminals KL6904 and KL1904 are evaluated. In this connection the output signals are written to the KL2904 and copied from the function block to the connected variables. If the output bConnectionInRun is FALSE, all outputs are set to FALSE.
To link the input data, select the parameter KL6904_SafetyQBx and select "Modify link..." from the context menu.
Linking the input data
and select the corresponding SafetyQBx variable in the dialog that follows.
Selecting the corresponding SafetyQBx variable
Development environment | Target platform | IO Hardware | PLC libraries to include
TwinCAT v2.10.0 Build > 914 | PC (i386) | KLx904 | TcTwinSAFE.Lib (Standard.lib, TcBase.Lib and TcSystem.Lib are integrated automatically)
TwinCAT v2.10.0 Build > 914 | BX series | KLx904 | TcTwinSAFE.LBX (Standard.LBX, TcBaseBX.LBX and TcSystemBX.LBX are integrated automatically)


Program transfer

Programming [image] Program transfer
Program transfer
Additional information
•
Program transfer via the serial interface
•
Program transfer via PROFIBUS


Program transfer via the serial interface

Programming [image] Program transfer [image] Program transfer via the serial interface
Program transfer via the serial interface
Every Bus Terminal Controller can be programmed via the PC's RS232 interface.
Select the serial interface in TwinCAT PLC Control.
Selecting the data transfer route - serial interface
The settings for the serial interface, port number, baud rate etc. are found under Online/Communication parameters in PLC Control.
The Bus Terminal Controller requires the following setting:
▪
Baud Rate: 9600/19200/38400/57600 baud (automatic baud rate detection)
▪
Stop bits: 1
▪
Parity: Straight line
plc seriell com port.gif
Parameterization of the serial interface
Program transfer via the serial interface and ADS
The Bus Terminal Controller can be programmed via the PC's RS232 interface. Before you can work with the Bus Terminal Controller, TwinCAT must be notified of it (see serial ADS).
Select the ADS connection in TwinCAT PLC Control.
plc choose target bx ads.gif
Selecting the data transfer route - AMS
PLC Control can be accessed via Online/Communication Parameters....
Selecting the device


Program transfer via PROFIBUS

Programming [image] Program transfer [image] Program transfer via PROFIBUS
Program transfer via PROFIBUS
TwinCAT offers a facility for transferring the user program to the Bus Terminal Controller over the fieldbus. The BC/BX can be selected as the target system in PLC Control, after saving in the registry and restarting the TwinCAT system. The TwinCAT-level TwinCAT PLC is necessary.
Minimum requirements:
▪
FC310x with firmware from 2.55
▪
TwinCAT 2.9 Build 1025
Initializing the Bus Terminal Controller
The coupler must first be made known to the system before it can be selected in PLC Control.
Enter the Bus Terminal Controller in the System Manager, specify type, quantity and size of the fieldbus variables and link them with a task. For the subsequent program download via the PROFIBUS, the ADS interface must be enabled for the Bus Terminal Controller in the ADS tab. Save your settings and activate the configuration. Then start the TwinCAT system and the cyclic task.
TwinCAT System Manager
system manager bx pb ads.gif
ADS Interface
PLC Control
When TwinCAT PLC Control is restarted, TwinCAT asks for the target platform, i.e. the device on which the user program is later to run. TwinCAT offers two target platforms as controller, the PC or the Bus Terminal Controller.
Two options are available to you for transmission to the Bus Terminal Controller:
▪
AMS for BCxx00 (Bus Terminal Controller without online change, one task)
▪
AMS for BCxx50 and BX (Bus Terminal Controller with online change, two tasks)
▪
BC serial – the serial cable for communication via the RS232 interface of the PC and the programming interface of the Bus Terminal Controller
plc choose target bx ads.gif
Selection of the target platform
After your program has been created, select the target system under the Online toolbar. TwinCAT must be running to do this. In the sample, this is the Ethernet card with Box 1 and the Run-Time 1 of the Bus Terminal Controller.
plc choose target bx ads 2.gif
selection of the target system


Process image

Programming [image] Process image
Process image
Additional information
•
PROFIBUS process image


PROFIBUS process image

Programming [image] Process image [image] PROFIBUS process image
PROFIBUS process image
The BX3100 is a PROFIBUS slave device. A basic device file (GSD) is available for the configuration on the master side, which has to be implemented in the respective master configuration software. On the slave side, i.e. in the BX3100, the user can specify which and how many data are to be transferred to the PROFIBUS master The BX3100 can process up to 244 bytes of input data and up to 244 bytes of output data. Two configuration types are available.
No special configuration is required for the DEFAULT CONFIG. The PROFIBUS data start at a certain address offset. The type and quantity of data is configured in the master.
The TwinCAT System Manager is required for the TwinCAT CONFIG. It can be used for byte-wise linking of PROFIBUS data with PLC data, or for linking data from the K-Bus to the PROFIBUS directly.
The input data of the BX3100 are output data of the master, and output data of the BX3100 are input data of the slave.
DEFAULT CONFIG
In DEFAULT CONFIG, all allocated variables with address 1000 or greater are transferred to the master. The type and number of variables is configured on the master side.
Sample
Var_1 AT %IB1000 :INT; a 2-byte output variable has to be configured on the master side.
Var_2 AT %IB1002 :DINT; a 4-byte output variable has to be configured on the master side.
The order of the variables on the master side must be adhered to. Address gaps are only permitted if they are configured on the master side. Otherwise, addressing must be continuous from address 1000.
TWINCAT CONFIG
For the TwinCAT CONFIG, a configuration must be created via the System Manager. The System Manager is used for specifying the type and number of variables and for linking the variables. The PROFIBUS data may therefore be located anywhere in the permissible allocated process image.
Permissible process image:
INPUT %IB0 - %IB2047
OUTPUT %QB0 - %QB2047


PROFIBUS

PROFIBUS
PROFIBUS
Additional information
•
Introduction to the system


Introduction to the system

PROFIBUS [image] Introduction to the system
Introduction to the system
Additional information
•
Fieldbus Overview
•
PROFIBUS DP
•
PROFIBUS DPV1
•
Plug connectors, cables and switches
•
Topology


Fieldbus Overview

PROFIBUS [image] Introduction to the system [image] Fieldbus Overview
Fieldbus Overview
PROFIBUS is a manufacturer - independent, open fieldbus standard with a wide range of applications in manufacturing and process automation. Manufacturer-independence and openness are guaranteed by the International standards EN 50170 and EN 50254. PROFIBUS allows devices from different manufacturers to communicate without the need for specially adapted interfaces. PROFIBUS is suitable both for fast, time-critical applications and for complex communication tasks.
PROFIBUS offers communication protocols of different functional levels: DP and FMS. According to the application, RS-485, IEC 1158-2 or optical fiber are available as transmission techniques.
PROFIBUS specifies the technical features of a serial fieldbus system with which distributed digital automation devices can be networked together, from the field level up to the cell level. PROFIBUS is a multi-master system, and therefore permits common operation of a number of automation, engineering or visualization systems with their decentralized peripheral devices on one bus.
PROFIBUS device types
PROFIBUS distinguishes the following device types:
Master devices determine the data traffic on the bus. A master may transmit messages without having received an external request when it is in possession of the bus access authorization (token). Masters are also referred to as active devices.
Slave devices are peripheral devices such as input/output devices, valves, drives, measuring transducers and the Beckhoff PROFIBUS slaves from the BK3xx0, BC3xx0, IPxxxx-B310, IL230x-B310 and IL230x-C310 series. They do not receive any bus access authorization, so that they are only allowed to acknowledge messages that have been received, or to send messages in response to a request from master. Slaves are referred to as passive devices. They only require a small proportion of the bus protocol, which means that they can be implemented with little effort.
PROFIBUS DP
PROFIBUS DP is designed for efficient data exchange at the field level. The central automation devices, e.g. PLC/PC or process control systems, communicate with decentralized field devices such as I/O, drives, valves etc. via a fast serial link. The data exchange with the decentralized devices is predominantly cyclic. The communication functions required for this are specified by the basic DP functions conforms to EN 50170.
In addition to these basic functions, PROFIBUS DP also offers extended acyclic communication services for such purposes as parameterization and other operations. These are also supported by the Beckhoff PROFIBUS slaves of the IPxxxx-B310, IL230x-B310 and IL230x-C310 series. A central controller (master) cyclically reads the input information from the slaves, and writes the output information cyclically to the slaves. The bus cycle time here should be shorter than the central automation system's program cycle time, which lies around 10 ms in many applications.
A high data throughput is not in itself sufficient for successful use of a bus system. Ease of handling, good diagnostic facilities and secure transmission technology are also of the utmost importance if the user's demands are to be satisfied. These properties are ideally combined in PROFIBUS DP.
System configuration and device types
PROFIBUS DP allows single master or multi-master systems to be implemented. This permits a high level of flexibility in system configuration. A maximum of 126 devices (master or slaves) can be connected to one bus. A station address between 0 and 99 can be chosen for the Beckhoff PROFIBUS slaves from the IPxxxx-B310, IL230x- B310 and IL230x-C310 series. The specifications for the system configuration contain the number of stations, the assignment of the station addresses to the I/O addresses, data consistency of the I/O data and the format of the diagnostic messages and the bus parameters being used. Every PROFIBUS DP system consists of different device types. Three types of device are distinguished:
Class | Description
DP master class 1 (DPM1) e.g. Beckhoff FC310x: PROFIBUS master card for PCs | This involves a central controller that exchanges information cyclically with the decentralized stations (slaves) in a specified message cycle. Typical devices include, for instance, programmable logic controllers (PLCs) or PCs.
DP master class 2 (DPM2) | Devices of this type are engineering, project design or operating devices. They are used for commissioning, for servicing and diagnosis in order to configure the connected devices, to evaluate measured values and parameters and to interrogate the status of devices.
DP slave e.g. Beckhoff IPxxxx-B310: Fieldbus Box for PROFIBUS | A PROFIBUS DP slave is a peripheral device (I/O, drive, measuring transducer, etc.) that reads input information and passes output information on to the peripherals. It is also possible to have devices that only handle either input or output information. The quantity of input and output information is device-dependent, and may not exceed 246 bytes of input data and 246 bytes of output data.
Mono master systems
In single master systems only one master is active on the bus in the operating phase of the bus system. The PLC controller is the central control component. The decentralized slaves are coupled to the PLC controller via the transmission medium. The shortest bus cycle time is achieved with this system configuration.
Multi-Master Operation
In a multi-master mode there is more than one master on the bus. They either form subsystems that are independent of one another, each consisting of one DPM1 and the associated slaves, or additional project design and diagnostic devices. All the DP masters can read the input and output images of the slaves. Writing the outputs is only possible for one DP master (the one assigned as DPM1 during the project planning). Multi-master systems achieve a medium bus cycle time. In time-critical applications, the increase in bus cycle time should be observed by adding a diagnostic tool.
Basic device files (GSD)
In PROFIBUS DP, the performance characteristics of the devices are documented by the manufacturers and made available to users in the form of a device data sheet and of a basic device file. The structure, content and coding of these basic device files (GSD) is standardized. They make it easy to plan a project with any PROFIBUS DP slaves using project planning devices from various manufacturers. The PROFIBUS User Organization (Profibus Nutzer Organisation - PNO) archives this information for all manufacturers, and will provide information about the GSD from any manufacturer on request. The GSD files are read by a PROFIBUS master configuration software, and appropriate adjustments are transferred to the PROFIBUS master. Please see the appropriate software manual from the master manufacturer for a description.
The Beckhoff GSD files may be obtained from the internet under http://www.beckhoff.de.
Diagnostic functions
The extensive diagnostic functions of PROFIBUS DP allow rapid fault localization. Diagnosis of the Beckhoff Bus Coupler is not switched on in the default setting of the type file or the GSD file. The diagnostic messages are transmitted over the bus and collated by the master.
They are divided into three levels:
Diagnosis type | Description
Station-related | Messages relating to the general operational readiness of a device such as overtemperature or undervoltage
Module-related | These messages indicate that diagnostic signals are pending within a specific I/O sub range of the device (e.g. an 8 bit output module)
Channel-related | Here the cause of an error is related to a single input/output bit (channel), such as a short circuit on output 2
The Beckhoff PROFIBUS slaves from the IPxxxx-B310, IL230x-B310 and IL230x-C310 series support the PROFIBUS DP diagnostic functions. Assessment of the diagnostic data by means of the controller depends on the support for the PROFIBUS master. Please refer to the device manuals for the master interfaces for details of how to handle the diagnosis.
Sync and Freeze Mode
In addition to the user data traffic related to the device, which is automatically dealt with by DPM1, a DP master has the option of sending control commands to one DP slave, to a group of them or to all of them at the same time. These control commands are transmitted as Multicasts. These control commands can be used to specify the sync and freeze operating modes, in order to synchronize the DP slave. They permit event-controlled synchronization of the DP slaves.
The DP slaves start Sync mode when they receive a sync control command from the assigned DP master. In this operating state, the outputs of all the addressed DP slaves are frozen at their current values. In the following user data transmissions, the DP slaves store the output data, but the output states themselves nevertheless remain unchanged. Only when the next sync control command is received from the master the stored output data is switched through to the outputs. Sync operation is ended with an Unsync control command.
A freeze control command similarly causes the addressed DP slaves to enter Freeze mode. In this operation mode the states of the inputs are frozen at their current value. The input data is only updated again when the DP master has sent the next freeze control command to the devices concerned. Freeze operation is ended with an unfreeze command.
System behavior
The system behavior is also standardized in PROFIBUS DP, so that devices can to a large extent be interchanged. It is largely determined by the operating state of the DPM1. This can either be controlled locally, or over the bus by the project design device.
The following three major states are distinguished:
Operation mode | Description
Stop | There is no data traffic between the DPM1 and the DP slaves. The Bus Coupler only addresses the Bus Terminals once after the power has been switched on (none of the I/O LEDs are lit).
Clear | The DPM1 reads the input information from the DP slaves, and maintains the outputs of the DP slaves in a safe state (depending on the reaction to fieldbus errors, the green I/O LED is lit and the outputs are set).
Operate | The DPM1 is in a data transfer phase. In the course of cyclic data traffic the inputs of the DP slaves are read and the output information is transmitted to the DP slaves (the green I/O LED is lit).
The DPM1 sends its local status at a configurable time interval using a multicast command cyclically to all the DP slaves that have been assigned to it. The reaction that the system has to the occurrence of an error during the DPM1's data transfer phase, such as the failure of a DP slave, is specified in the Auto-Clear operating parameter. If this parameter is set to True, then the DPM1 switches the outputs of all the associated DP slaves into a safe state as soon as one DP slave is no longer ready for the transfer of user data. The DPM1 then switches into the Clear state. If the parameter is False then the DPM1 remains in the operating state even after a fault, and the user can himself specify the system's reaction.
Data traffic between the DPM1 and the DP slaves
The data traffic between the DPM1 and the DP slaves that have been assigned to it is automatically executed by the DPM1 in a specified, continuously repeated sequence. The user specifies the assignment of a DP slave to the DPM1 when the bus system's project is being planned. Those DP slaves that are included in or excluded from the cyclic user data traffic are also defined.
The data traffic between the DPM1 and the DP slaves is divided into the parameterization, configuration and data transfer phases.
Before a DP slave is included in the data transfer phase, the DPM1 checks, in the parameterization and configuration phase, whether the theoretical configuration that has been planned agrees with the actual configuration of devices. The check requires the device type, the format and length information, as well as the number of inputs and outputs, to be in agreement. The user is thus provided with reliable protection against errors in parameterization. In addition to the transfer of user data, which is automatically carried out by the DPM1, it is possible to send new parameterization data to the DP slaves at the user's request.
Protection mechanisms
In the context of decentralized peripherals it is necessary, for reasons of safety and reliability, for the system to be given extremely effective functions to protect against incorrect parameterization or the failure of the transmission mechanisms. PROFIBUS DP uses monitoring mechanisms in the DP Master and in the DP Slaves. They are implemented in the form of time monitors. The monitoring interval is specified in when the DP system project is planned.
Protection mechanisms | Description
At the DP Master | The DPM1 monitors the slave's transfer of user data with the Data_Control_Timer. An individual monitoring timer is used for each assigned slave. The time monitor triggers if a proper transfer of user data does not take place within the monitoring interval. In this case the user is informed. If automatic error reaction is enabled (Auto_Clear = True) then the DPM1 leaves the Operate state, switches the outputs of the assigned slaves into a safe state, and then goes into the Clear operating state.
At the DP Slave | The slave uses communication monitoring in order to detect errors of the master or in the transmission link. If data is not transferred with the assigned master within the communication monitoring interval the slave switches the outputs into the safe state itself. The slave inputs and outputs further require access protection in multi-master systems, to ensure that direct access is only made from the authorized master. The slaves will make an image of the inputs and outputs available to other masters, and this can be read by any other master even if it does not have access authorization.
Ident number
Every DP slave and every DPM1 must have an individual identification number. This is required so that a DP master can identify the types of the connected devices without any significant protocol overhead. The master compares the identification numbers of the connected DP devices with the identification numbers in the project planning data specified by DPM2. The transfer of user data only starts if the correct device types are connected to the bus at the correct station addresses. This provides protection from project planning errors. Manufacturer-specific identification numbers are issued by the PROFIBUS User Organization (PNO). The PNO administers the identification numbers along with the basic device data (GSD).


PROFIBUS DP

PROFIBUS [image] Introduction to the system [image] PROFIBUS DP
PROFIBUS DP
In PROFIBUS DP systems a master (PLC, PC, etc.) usually communicates with many slaves (I/Os, drives, etc.); only the master actively accesses the bus (by sending unsolicited telegrams), while a DP slave only sends telegrams when requested by the master.
DP StartUp
Before the master and slave can cyclically exchange data, the parameter and configuration data is transmitted from the master to the slaves during the DP StartUp phase. After the parameter and configuration data has been sent, the master interrogates the slave's diagnostic data until the slave indicates that it is ready for data exchange. Depending on the extent of the calculations that the slave must carry out after receiving the parameter and configuration data, it can take up to a few seconds before it is ready for data exchange. For this reason the slave possesses the following states:
Parameter data
The parameter data is sent from the master to the slave in the SetPrmLock request telegram. The SetPrmLock response telegram does not contain any data, and therefore consists of a single byte, the short acknowledgement. The parameter data consists of DP parameters (e.g. the setting of the DP watchdog or checking the IdentNumber (unique to each DP device)), of DPV1-/DPV2 parameters and of application-specific parameters that only have to be transmitted once during the StartUp. If an error is found in the parameter data, this is indicated in the diagnostic data, and the slave either remains in or enters the WAIT-PRM state.
Configuration data
The configuration data is sent from the master to the slave in the ChkCfg request telegram. The ChkCfg response telegram does not contain any data, and therefore consists of a single byte, the short acknowledgement. The configuration data describes the assignment of the DP modules to the cyclic I/O data that is to be exchanged between the master and slave via the Data_Exchange telegram in the cyclic data exchange phase. The sequence of the DP modules added to a slave in the DP configuration tool determines the sequence of the associated I/O data in the Data_Exchange telegram.
Diagnostic data
The diagnostic data is requested by the master using a SlaveDiag request telegram without any data. The slave replies with the diagnostic data in a SlaveDiag response telegram. The diagnostic data consists of the standard DP diagnostics (e.g. the state of the slave, the IdentNumber) and of application-specific diagnostic data.
Cyclic data exchange
At the core of the PROFIBUS DP protocol is the cyclic data exchange, during which the master exchanges I/O data with each slave within a PROFIBUS DP cycle. This involves the master sending the outputs to each slave with a DataExchange request telegram, while the slave replies with the inputs in a DataExchange response telegram. This means that all the output and/or input data is transmitted in one telegram, in which the DP configuration (the sequence of DP modules) specifies the assignment of the output and/or input data to the slave's actual process data.
Diagnosis during cyclic data exchange
A slave can send a diagnostics signal to the master during cyclic data exchange. In this case, the slave sets a flag in the DataExchange response telegram, whereby the master recognizes that there is new diagnostic data in the slave. It then fetches that data in the SlaveDiag telegram. The diagnostic data is therefore not available in real-time as the cyclic I/O data in the controller, but always delayed by at least one DP cycle.
Synchronization with Sync and Freeze
The Sync and Freeze commands in the GlobalControl request telegram (broadcast telegram) allow the master to synchronize the activation of the outputs (Sync) or the reading of the inputs (Freeze) in a number of slaves. When the Sync command is used, the slaves are first switched into Sync mode (a process that is acknowledged in the diagnostic data). The I/O data is then exchanged sequentially with the slaves in the DataExchange telegram. Transmitting the Sync command in the GlobalControl telegram then has the effect of causing the slaves to generate the most recently received outputs. In Freeze operation a Freeze command is first sent in the GlobalControl telegram, in response to which all the slaves latch their inputs. These are then fetched sequentially by the master in the DataExchange telegram.
States in the master
The master distinguishes between the CLEAR state (all outputs are set to the Fail_Safe value) and the OPERATE state (all outputs have the process value). The Master is usually switched into the CLEAR mode when, for instance, the PLC enters STOP.
Class 1 and Class 2 DP Masters
The Class 1 master refers to the controller that carries out cyclic I/O data exchange with the slaves, while a Class 2 master is a B&B device that generally only has read access to the slaves' I/O data.


PROFIBUS DPV1

PROFIBUS [image] Introduction to the system [image] PROFIBUS DPV1
PROFIBUS DPV1
PROFIBUS DPV1 refers primarily to the acyclic read and write telegrams, with which data sets in the slave are acyclically accessed. A distinction between a Class 1 and a Class 2 master is also made for DPV1. The difference between acyclic Class 1 (C1) and Class 2 (C2) connections is that the acyclic C1 connection is established during the DP StartUp phase of cyclic DP operation. Once the slave has reached the WAIT-CFG state it is possible for acyclic DPV1-C1 read and write telegrams to be sent from the master to the slave, whereas the C2 connection is established separately, independently of the cyclic DP connection. This is usually carried out by a second (C2) master so that, for instance, a manufacturer-specific project configuration and diagnostic tool can access the slave's data.
When two masters are used, however, is must always be borne in mind that these share bus access (a token is exchanged), so that time relationships are less favorable than in the case of a single master system.


Plug connectors, cables and switches

PROFIBUS [image] Introduction to the system [image] Plug connectors, cables and switches
Plug connectors, cables and switches
The physics of the transmission
Physical aspects of the data transmission are defined in the PROFIBUS standard. See PROFIBUS layer 1 (physical layer).
The types of area where a fieldbus system can be used is largely determined by the choice of the transmission medium and the physical bus interface. In addition to the requirements for transmission security, the expense and work involved in acquiring and installing the bus cable is of crucial significance. The PROFIBUS standard therefore allows for a variety of implementations of the transmission technology while retaining a uniform bus protocol.
Cable-based transmission: This version, which accords with the American EIA RS-485 standard, was specified as a basic version for applications in production engineering, building management and drive technology. A twisted copper cable with one pair of conductors is used. Depending on the intended application area (EMC aspects should be considered) the shielding may be omitted.
Cable-related faults
Two types of conductor are available, with differing maximum conductor lengths; see the "RS485" table. The plug connector assignment and the wiring are shown in the diagram below. Note the special requirements on the data cable for baud rates greater than 1.5 Mbaud. The correct cable is a basic requirement for correct operation of the bus system. If a "simple" 1.5 Mbaud cable is used, reflections and excessive attenuation can lead to some surprising phenomena. This could, for example be that some station is not connected, but when the neighboring station is unplugged the connection appears again. Or there may be transmission errors when a specific bit pattern is transmitted. The result of this can be that when the equipment is not operating, PROFIBUS works without faults, but that there are apparently random bus errors after start-up. Reducing the baud rate (< 93.75 kbaud) corrects this faulty behavior.
If reducing the baud rate does not correct the error, then in many cases this can indicate a wiring fault. The two data lines maybe crossed over at one or more connectors, the termination resistors may not be switched on, or they may be active at the wrong locations.
Preassembled cable from Beckhoff
Installation is made a great deal more straightforward if preassembled cables from Beckhoff are used. Wiring errors are avoided, and commissioning is more rapidly completed. The range includes fieldbus cables, power supply cables, sensor cables and accessories such as termination resistors and T-pieces. Connectors and cables for field assembly are nevertheless also available.
PROFIBUS connection of the Fieldbus Box modules
The M12 socket is inverse-coded and has 5 contact pins. Pin 1 transfers 5 VDC, pin 3 transfers GND for the active termination resistor. These must never be misused for other functions, as this can lead to destruction of the device. Pins 2 and 4 transfer the PROFIBUS signals. These must never be swapped over, as this will prevent communication. Pin 5 transfers the shield, which is capacitively connected to the base of the Fieldbus Box.
PROFIBUS socket pin assignment
Pin assignment M12 socket
PROFIBUS wire colors
PROFIBUS line | M12 | D sub
B red | Pin 4 | Pin 3
A green | Pin 2 | Pin 8
RS485 - Fundamental properties
RS-485 transmission according to the PROFIBUS standard
Network topology | Linear bus, active bus terminator at both ends, stubs are possible.
Medium | Screened twisted cable, shielding may be omitted, depending upon the environmental conditions (EMC).
Number of stations | 32 stations in each segment with no repeater. Can be extended to 127 stations with repeater
Max. bus length without repeater | 100 m at 12 Mbit/s 200 m at 1500 kbit/s, up to 1.2 km at 93.75 kbit/s
Max. bus length with repeater | Line amplifiers (repeaters) can increase the bus length to the order of 10 km. The number of repeaters possible is at least 3, and, depending on the manufacturer, may be up to 10
Data transfer rate | 9.6, 19.2, 93.75, 187.5, 500, 1500 kbit/s, up to 12 Mbit/s, infinitely variable
Connector | 9-pin D sub connector for IP20 M12 round connector for IP65/67
Cabling for PROFIBUS-DP and PROFIBUS_FMS
PROFIBUS cable assignment
Termination resistors
In systems with more than two stations all devices are wired in parallel. The PROFIBUS cable must be terminated with resistances at both ends, in order to avoid reflections and associated transfer problems.
Addressing
Setting of station addresses
The PROFIBUS address must be set using the two rotary selection switches behind the transparent cover. The default setting is 11. Any address is permitted, but each address may only be used once within the network. The address can be modified when the Fieldbus Box (Bus Coupler) is switched off. Release the cover (Fieldbus Box only) and set the switches to the required position using a screwdriver. Make sure that the switches engage properly. The change in address is active as soon as the device is switched on.
Fieldbus Box address
The switch on the left represents the tens, while that on the right represents the units.
Address selection switch
Bus Coupler address
The lower switch S311 represents the tens, while the upper switch S310 represents the unit.
Address selection switch


Topology

PROFIBUS [image] Introduction to the system [image] Topology
Topology
▪
A bus segment may consist of a maximum of 32 devices (including the repeaters).
▪
The maximum cable length of a segment depends on the data transfer rate in use and on the quality of the bus cables being used.
▪
No more than 9 repeaters may be installed between two devices.
▪
Stubs are to be avoided, and are not permitted above 1.5 Mbaud.
▪
The maximum number of devices is 127
▪
Interrupting the supply voltages from cable ends by switching off the repeater/slave, or by pulling out the plug, is not permitted.
RS485 topology with 3 segments and 2 repeaters


Error handling and diagnosis

Error handling and diagnosis
Error handling and diagnosis
Additional information
•
Diagnosis
•
Diagnostic LEDs
•
Diagnostics display
•
PROFIBUS diagnostic data


Diagnosis

Error handling and diagnosis [image] Diagnosis
Diagnosis
PROFIBUS state
In many cases it is important to know whether the communication with the higher-level master is still OK. To this end, link the "DpState" variable with your PLC program.
PROFIBUS diagnostic byte in the System Manager
Error number | Description | Remedy
0 | No error | -
129 | Waiting for configuration data | Start PROFIBUS
130 | Waiting for parameter data | Start PROFIBUS
131 | No master available | Check PROFIBUS cables and connectors
Sample
If the PROFIBUS is interrupted, e.g. if the cable is pulled or the PLC is switched, the Bus Terminal Controller indicates this by reporting 130 in DP state. That is, the Bus Terminal Controller is waiting for parameter data from the master.
Slave boot sequence after a timeout or starting of the master:
parameter data - configuration data - data exchange
Reading fieldbus state by ADS
In default or TwinCAT configuration the fieldbus state can be read via ADSREAD.
Parameter ADSREAD function block | Description
NetID | local – empty string
Port | 1
IndexGroup | 16#0006
IndexOffset | BX3100: 16#000C_A0F4 BC3150: 16#000C_A080
LEN | 1
State of the K-Bus
An internal bus or Bus Terminal error is indicated in the K-Bus state. A more precise fault description can be obtained via a function block (in preparation). To this end, link the "K-Bus state" variable with your PLC program.
K-bus status
Error bit | Description | Error type
0 | No error | No ERROR.
Bit 0 | K-Bus error | ERROR
Bit 2 | K-Bus is re-triggered | NOTICE
Reading K-Bus state by ADS
In default or TwinCAT configuration the fieldbus state can be read via ADSREAD.
Parameter ADSREAD function block | Description
NetID | local – empty string
Port | 1
IndexGroup | 16#0006
IndexOffset | 16#000C_9000
LEN | 1


Diagnostic LEDs

Error handling and diagnosis [image] Diagnostic LEDs
Diagnostic LEDs
The Bus Coupler has two groups of LEDs for the display of status. The "DIAG LEDs" on the left indicate the fieldbus, PLC and K-Bus state. Two green LEDs (Power LEDs) are located in the top right corner of the Bus Coupler. They are used for displaying the supply voltage of the BX Controller and the 24 VDC supply of the power contacts.
LEDs for power supply diagnostics
LED (Power LEDs) | Meaning
Left LED off | Bus Coupler has no voltage 24 VDC
Right LED off | No power supply 24 VDC connected at the power contacts
Diagnostic LEDs for the fieldbus, the PLC, the K-bus and the power supply units
The DIAG LEDs are sub-divided as follows:
▪
Bus: Fieldbus diagnosis
▪
PLC: PLC diagnosis
▪
I/O: K-bus diagnosis
The LEDs can be off, green, orange or red.
Diagnostic LEDs for the fieldbus, the PLC and the K-bus
After switching on, the Bus Coupler immediately checks the connected configuration. The I/O LED goes out if the start-up was successful. A red I/O LED indicates a Bus Terminal error. The error type is shown in the display. This permits rapid rectification of the error.
LED bus - fieldbus diagnosis
LED | Meaning
LED off | no fieldbus connected, Bus Coupler searches for baud rate
LED red | error flashing - error type - display
LED orange | Bus Coupler has found baud rate, waiting for config and parameter data
LED green | Bus communication OK, BX Controller is exchanging data
LED PLC - PLC diagnosis
LED | Meaning
LED off | PLC stop or no program available
LED red | Flashing - the set task time is exceeded from time to time On - the set task time is always exceeded Disable the red LED
LED orange | PLC running without boot project (only during the on cycle), LED flashes orange during creating of the boot project
LED green | Boot project - PLC running (only during the on cycle)
LED I/O - K-Bus diagnosis
LED | Meaning
LED off | No data are exchanged via the K-Bus
LED red | error flashing - error type - display
LED orange | Register or KS2000 online access
LED green | K-Bus OK and running
Error codes for K-Bus diagnosis
Error
code
Error
argument
Description
Remedy
0
-
EMC problems
▪
Check power supply for undervoltage or overvoltage peaks
▪
Implement EMC measures
▪
If a K-Bus error is present, it can be located by a restart (switching the BX controller off and on again)
1
0
EEPROM checksum error
Enter factory settings with the KS2000 configuration software
1
Code buffer overflow
Insert fewer Bus Terminals. Too many entries in the table for the programmed configuration
2
Unknown data type
Software update required for the BX Controller
2
-
Reserve
-
3
0
K-bus command error
▪
No Bus Terminal inserted
▪
One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4
0
K-Bus data error, break behind the BX Controller
Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
n
Break behind Bus Terminal n
Check whether the Bus End Terminal KL9010 is connected.
5
n
K-bus error in register communication with Bus Terminal n
Exchange the nth bus terminal
6
0
Error at initialization
Replace the BX controller
1
Internal data error
Hardware reset of the BX controller (switching off and on again)
2
DIP switch changed after a software reset
Hardware reset of the BX controller (switching off and on again)
3
IP address collision
Check whether the IP address already exists in the network.
7
0
Note: cycle time was exceeded
Warning: the set cycle time was exceeded. This indication (flashing LEDs) can only be cleared by booting the BX Controller again.
Remedy: increase the cycle time
9
0
Checksum error in Flash program
Transfer the program to the BX controller again
1
Incorrect or faulty library implemented
Remove the faulty library
10
n
Bus Terminal n is not consistent with the configuration that existed when the boot project was created
Check the nth Bus Terminal. The boot project must be deleted if the insertion of an nth Bus Terminal is intentional
14
n
nth Bus Terminal has the wrong format
Start the BX Controller again, and if the error occurs again then exchange the Bus Terminal.
15
n
Number of Bus Terminals is no longer correct
Restart the BX controller. If the error occurs again, reset the BX controller to the delivery state with the configuration software.
16
n
Length of the K-bus data is no longer correct


Diagnostics display

Error handling and diagnosis [image] Diagnostics display
Diagnostics display
During start-up, the display shows the current firmware version for approx. three seconds.
If an error occurs during start-up, this will be indicated via a flash sequence of the associated LED.
Configuration errors are shown in the display via TC-Config and an error number. In this case, please use the System Manager to check your hardware configuration or contact support.
Display | Meaning
TC-Config 0xE02E | A complex Bus Terminal is assigned a bit address. Check the TwinCAT configuration.
TC-Config 0xF0nn | Bus Terminal no. nn does not correspond to the configuration. Compare the bus structure of Bus Terminal no. nn with the configuration.
TC-Config 0xC0nn | Bus Terminal no. nn does not correspond to the configuration. Compare the bus structure of Bus Terminal no. nn with the configuration.
Firmware errors are shown in the display via FW-Error and an error number. Please contact support.
Display | Meaning
FW-Error 0xnnnn | Please contact support


PROFIBUS diagnostic data

Error handling and diagnosis [image] PROFIBUS diagnostic data
PROFIBUS diagnostic data
The BX controller enables sending of diagnostic data from the PLC. You can write your own diagnostic message for the master and fill it individually with data (see Device-specific diagnostic data).
DP Diagnostic Data (DiagData)
The DP diagnostic data consists of 6 bytes of DP standard diagnosis, along with up to 238 bytes of device-specific diagnostic data.
When the DP diagnostic data changes, the slave reports this fact to the master, and the master will automatically fetch the changed diagnostic data. The DP diagnostic data are not available in real-time with the DP process data, but reach the controller a few cycles later.
In TwinCAT the DP diagnostic data is read from the DP Master interface (FC310x, CX1500-M310) using ADS (see the section describing Slave Diagnosis in the FC310x documentation).
DP standard diagnostic data
Offset | Meaning
0x00.0 | StationNonExistent: slave did not reply to the last telegram
0x00.1 | StationNotReady: slave still processing the Set_Prm / Chk_Cfg telegram
0x00.2 | CfgFault: slave signaling a configuration error
0x00.3 | ExtDiag: extended DiagData available and valid
0x00.4 | NotSupported: slave does not support a feature requested via Set_Prm or Global_Control
0x00.5 | InvalidSlaveResponse: slave response not DP-compatible
0x00.6 | PrmFault: slave reports a parameterization error
0x00.7 | MasterLock: slave currently exchanging data with another master
0x01.0 | PrmReq: Slave must be parameterized and configured again
0x01.1 | StatDiag: slave signaling static diagnosis / DPV1 slave application not yet ready for data exchange
0x01.2 | PROFIBUS DP slave
0x01.3 | WdOn: DP watchdog switched on
0x01.4 | FreezeMode: DP slave in freeze mode
0x01.5 | SyncMode: DP slave in sync mode
0x01.6 | reserved
0x01.7 | Deactivated: DP slave has been deactivated
0x02.0 | reserved
0x02.1 | reserved
0x02.2 | reserved
0x02.3 | reserved
0x02.4 | reserved
0x02.5 | reserved
0x02.6 | reserved
0x02.7 | ExtDiagOverflow: too much extended data present
0x03 | MasterAdd: station address of master with which slave is exchanging data
0x04,0x05 | IdentNumber
from 0x06 | Device-specific diagnostic data (extended DiagData)
Device-specific diagnostic data
The function block ADSWRITE is used for sending the diagnostic data. The current DP diagnosis sent to the bus can be read via ADSREAD. Please note that an additional 6 bytes (PROFIBUS standard DP diagnosis) are required for reading, i.e. the number of bytes that are read exceeds the number of bytes that were written by 6. The ADS parameters for the read process are identical.
Input parameters | Description
NETID | local NetId of BX
PORT number | 100
IDXGRP | 16#0003_0000
IDXOFFS | 0
LEN | 1-238 bytes (writing), 7-244 (reading)
SRCADDR | Pointer to diagnostic data
Diagnostic telegram is event-driven
A diagnostic telegram is only sent to the controller if the diagnostic data have changed.


Appendix

Appendix
Appendix
Additional information
•
First steps with the BX3100
•
Switching between controllers
•
Firmware Update
•
CFC-Client*
•
Sample programs - overview
•
General operating conditions
•
Test standards for device testing
•
Bibliography
•
List of Abbreviations
•
Support and Service


First steps with the BX3100

Appendix [image] First steps with the BX3100
First steps with the BX3100
For the following sample, the following hardware and software components are required:
Hardware
▪
FC310x from firmware 2.0
▪
BX3100
▪
KL10x4
▪
KL20x4
▪
KL9010
▪
PROFIBUS cable + cabling material (such as 24 VDC power supply unit etc.)
Software
▪
TwinCAT 2.9 build 947 (minimum TwinCAT PLC level)
Sample 1: Default Configuration
a.) Open the file [image] ( ). This file contains the System Manager file for the master configuration with the FC310x card and the BX3100 slave. Select the correct PCI address for the FC3101.
Select the PCI address for the FC3101
and set PROFIBUS address 2 on the BX3100.
Setting the PROFIBUS address
Activate the configuration and start the system. The TwinCAT icon (bottom right on the desktop) should be green. The bus LED on the BX3100 should also be green. Should this not be the case, check the BX3100 address and the physical connection with the PROFIBUS master (terminating resistors etc.).
b.) Open the file [image] (File). This file is the PLC project for the BX3100. Select the BX3100 under >Online\Selecting the target system<.
plc choose target bx ads 2.gif
selection of the target system
Load the project into the controller (>Online\Login<) and Start the program (>Online\Start<). The PLC LED on the BX3100 should now be orange.
Program description
The program increments a value >Profibus_Out_1< as long as the variable Profibus_Input_1 contains the value = 0. At the same time, the first digital output cycles with approx. 2 Hz. In the System Manager, the variable >Var 36< can be forced to a value unequal zero. This stops the counter, and the first digital output is set to a fixed value of "one".


Switching between controllers

Appendix [image] Switching between controllers
Switching between controllers
Switching from BCxx00 to BCxx50/BCxx20
File names
In the Bus Terminal controllers of the BCxx50 and BCxx20 series, libraries have the extension *.lbx, programs have the extension *.prx.
Flag variables
The allocated flag variables
▪
of the BCxx00 are assigned %MB0...%MB511 (except BC9000/BC9100: %MB0...%B4095).
▪
of the BCxx20 are assigned %MB0...%MB4095
▪
of the BCxx50 are assigned %MB0...%MB4095
Status information such as K-bus/fieldbus status and cycle tick is not copied to the BCxx50/BCxx20. This information is available in TcSystemBCxx50.lbx as a function for the BCxx50/BCxx20.
The allocated flags do not act as retain variables.
Retain data
The retain data have to be declared as VAR_RETAIN. Up to 2 kbyte are available.
PLC Variables
In the Default-Config the PLC variables start from %IB1000 and %QB1000.
Large model
Not applicable for BCxx50 and BCxx20.
Max. memory:
▪
BCxx50: 48 kbyte
▪
BCxx20: 128 kbyte
Task time
The task time is specified in the PLC Control. It should be set to a realistic value (measuring of PLC cycle time and K-Bus). The background time is not used.
Task configuration
A maximum of one task is available. This task must be configured.
PLC and fieldbus terminals
For the standard Bus Terminal Controllers (BCxx00) it was possible to select whether a Bus Terminal is assigned to the fieldbus or the local PLC.
In the default configuration of the BCxx50/BCxx20 all Bus Terminals are assigned to the local PLC. An assignment to the fieldbus is not possible in this case.
Switching from BCxx00 to BXxx00
File names
In the Bus Terminal controllers of the BCxx00, libraries have the extension *.lbx, programs have the extension *.prx.
Flag variables
The allocated flag variables
▪
of the BCxx00 are assigned %MB0...%MB511 (except BC9000/BC9100: %MB0...%B4095).
▪
of the BXxx00 are assigned %MB0...%MB4095
Status information such as K-bus/fieldbus status and cycle tick is not copied to the BXxx20. This information is available in TcSystemBCxx00.lbx as a function for the BXxx50.
The allocated flags do not act as retain variables.
Retain data
The retain data have to be declared as VAR_RETAIN. Up to 2 kbyte are available.
PLC Variables
In the Default-Config the PLC variables start from %IB1000 and %QB1000.
Large model
Not applicable for BXxx00. Max. memory: 256 kbyte.
Task time
The task time is specified in the PLC Control. It should be set to a realistic value (measuring of PLC cycle time and K-Bus). The background time is not used.
Task configuration
A maximum of one task is available. This task must be configured.
PLC and fieldbus terminals
For the standard Bus Terminal Controllers (BCxx00) it was possible to select whether a Bus Terminal is assigned to the fieldbus or the local PLC.
In the default configuration of the BXxx00 all Bus Terminals are assigned to the local PLC. An assignment to the fieldbus is not possible in this case.
Switching from PC to BCxx50/BCxx20/BXxx00
File names
In the Bus Terminal controllers of the BCxx50/BCxx20 and BXxx00 series, libraries have the extension *.lbx, programs have the extension *.prx.
Allocated variables
For the Bus Terminal controllers of the BCxx50/BCxx20 and BXxx00 series, a limited number of allocated data are available:
▪
inputs 2 kbyte, %IB0…2048
▪
outputs 2 kbyte, %QB0…2048
▪
flags 4 kbyte, %MB0…4095
Task configuration
A maximum of one task is available. A sensible task time should be selected. Adjust the task time to your application by measuring the required system time (PLC + K-Bus + fieldbus + other).
Retain data
For the Bus Terminal controllers of the BCxx50, BCxx20 and BXxx00 series, up to 2 kbyte of retain data are available. Ensure that no (or only very few) retain data are used in function blocks (see RETAIN data).


Firmware Update

Appendix [image] Firmware Update
Firmware Update
Firmware update program
The firmware update program is required for loading a new firmware to the Bus Coupler. The program is transferred via the serial interface.
Note for BX3100:
Updates are not available with BX3100 firmware 0.64 (or lower). If these devices need updating, send the BX3100 to the manufacturer with a corresponding note.
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstr. 31
33415 Verl, Germany
Firmware update program 241 ( ) 71 kbytes (for Windows NT4.0 SP6, 2000, XP).
The program FirmwareUpdate.exe and the file TcRouterHelper.dll have to be in the same directory. Open the program by double-clicking on FirmwareUpdate.exe.
Update for Bus Terminal Controllers
BX series
Select the appropriate device of - in this example "Serial interface (BX)".
fw update 1.gif
Selecting a BX series Bus Terminal Controller
BCxx50 series
Select the corresponding device, in this case "Serial Interface".
fw update 5.gif
Selecting a BC series Bus Terminal Controller
BX and BCxx50 series
Then select the COM port.
fw update 2.gif
Select the COM port
Open the file you wish to download.
fw update 3.gif
Open the firmware file
Start the download via the green 'traffic light'. The download begins after about a minute, and is then also shown on the BX's display. After successful download (approx. 2 to 3 minutes) the Bus Terminal Controller reboots automatically.
fw update 4.gif
Status messages relating to the firmware update


CFC-Client*

Appendix [image] CFC-Client*
CFC-Client*
With the CFC client, the BX device offers the option of copying the complete memory content of a BX Controller. The data from the memory are saved in a BIN file and can be loaded into an identical controller.
The CFC client runs on Windows 9x, NT, 2000 and XP and is completely independent of TwinCAT.
CFC client ( ) (Note: The DLLs have to be registered manually via regsvr32)
When the CFC client is started, the COM parameters have to be set first.
CFC client
Port/Port Setup...
Call the port setup
Select the required setting.
Set the COM parameters
Before opening the COM port, a physical connection to the BX Controller has to be established. Then open the COM port.
Open the COM port
Use upload to create a copy of the BX memory and save it as a BIN file.
Upload the BX memory content to a BIN file
Use download to load the BIN file onto the BX controller. The controller starts automatically after a successful download.
Downloading a BIN file to the BX controller
* The CFC server is available on the BX Controller range from firmware version 1.09.


Sample programs - overview

Appendix [image] Sample programs - overview
Sample programs - overview
Denomination | Description
Display | Example for controlling the display
Navigation switch | Reading of the navigation switch from the PLC
Menu | Example for own menu with navigation switch and display
RTC | Example for reading the real-time clock (RTC) via function blocks
COM port - BK/BC8x00 master interface | COM1 or COM2 interface as master with the BK8x00 protocol
COM port - BK8x00 slave interface | COM1 or COM2 interface as slave with the BK8x00 protocol
COM port - Cimrex 12 | Example for controlling a Cimrex 12 display via ModbusRTU
COM port - ModbusRTU slave | Link of ModbusRTU Lib with the COM 1 or COM 2 interface of the BX
COM port - ModbusRTU master | Link of ModbusRTU Lib with the COM 1 or COM 2 interface of the BX
COM port - RK512 protocol | RK512 protocol via COM 1 or COM 2
COM port - text message via COM port | Connecting a Siemens S35 mobile phone to the COM interface for sending text messages
COM port - COMlibV2 | Sending and receiving strings with COMlibV2
SSB - Display | Cimrex panel at SSB
SSB - AX2000 | AX2000 at SSB
SSB - BK51x0 | BK5120 at SSB
SSB - BX / BX communication | Communication between BXs (via SSB)
SSB - IclA Drive | IclA drive at SSB
SSB - Lenze Drive | Lenze frequency converter at SSB


General operating conditions

Appendix [image] General operating conditions
General operating conditions
The following conditions must be met in order to ensure flawless operation of the fieldbus components.
Environmental conditions
Operation
The components may not be used without additional protection in the following locations:
▪
in difficult environments, such as where there are corrosive vapors or gases, or high dust levels
▪
in the presence of high levels of ionizing radiation
Condition | Permissible range
Permissible ambient temperature during operation | see technical data
Installation position | variable
Vibration resistance | conforms to EN 60068-2-6
Shock resistance | conforms to EN 60068-2-27
EMC immunity | conforms to EN 61000-6-2
Emission | conforms to EN 61000-6-4
Transport and storage
Condition | Permissible range
Permissible ambient temperature during storage | -25°C... +85°C
Relative humidity | 95 %, no condensation
Free fall | up to 1 m in the original packaging
Protection classes and types
Condition | Permissible range
Protection class in accordance with IEC 536 (VDE 0106, Part 1) | A protective conductor connection to the profile rail is necessary!
Protection class conforms to IEC 529 | IP20 (protection against contact with a standard test finger)
Protection against foreign objects | Less than 12 mm in diameter
Protection against water | no protection
Component identification
Every supplied component includes an adhesive label providing information about the product's approvals. For sample, on the BK2000 Bus Coupler:
The following information is printed on the label:
Printed item | Meaning for this label
Precise product identification | Lightbus Coupler BK2000
Supply voltage Us | 24 VDC (Use a 4 A fuse or a Class 2 power supply to meet UL requirements)
Data transfer rate | 2.5 Mbaud
Manufacturer | Beckhoff Automation GmbH & Co. KG
CE mark | Conformity mark
UL mark | Mark for UL approval. UL stands for the Underwriters Laboratories Inc., the leading certification organization for North America, based in the USA. C = Canada, US = USA, UL file number: E172151
Production identification | From left to right, this sequence of characters indicates the week of production (2 characters), the year of production (2 characters), the software version (2 characters) and hardware version (2 characters), along with any special indications (4 characters). In this case the device is a BK2000 - produced in calendar week 9 - of 2001 - with firmware version BF - in hardware version 6 - without special designation


Test standards for device testing

Appendix [image] Test standards for device testing
Test standards for device testing
EMC
EMC immunity
EN 61000-6-2
Electromagnetic emission
EN 61000-6-4
Vibration / shock resistance
Vibration resistance
EN 60068-2-6
Shock resistance
EN 60068-2-27


Bibliography

Appendix [image] Bibliography
Bibliography
German books
PROFIBUS
▪
PROFIBUS DP/DPV1
Basic principles, tips and tricks for users
by Manfred Popp
ISBN: 3778527819
General fieldbus technology
▪
Gerhard Gruhler (Pub.): Fieldbuses and device communication systems
Practical knowledge with comparison options
Franzis Verlag 2001
244 pages
ISBN
English books
(in preparation)
PROFIBUS-DP standards
▪
IEC 61158 and IEC 61784
▪
DIN 19245, Part 3
▪
Euronorm EN 50 170
Web sites
▪
http://www.profibus.de


List of Abbreviations

Appendix [image] List of Abbreviations
List of Abbreviations
DP
Decentralized periphery. PROFIBUS protocol for fast cyclic data exchange
FMS
PROFIBUS transfer protocol (Fieldbus Message Specification).
Freeze mode
This command makes the slave freeze its inputs
GSD file
German device master file
GSE file
English device master file
IP20, IP65, IP66, IP67
Protection class (contact, water, dust)
K-bus
Terminal Bus: Internal bus for communication between Bus Coupler and Bus Terminals
PNO
PROFIBUS User Organization (see www.profibus.de)
Repeater
Provides signal conditioning, connecting individual bus segments
PLC
Programmable logic controller
Sync mode
This command makes the slave hold its outputs unchanged until it receives the Sync telegram.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com