BK9500 - Bus Coupler for USB
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
20
▪
Migration
1.0
▪
First version
1.1
▪
Notes for troubleshooting adapted to TwinCAT version 2.8 (build 747) and version 2.9 (build 947).
▪
Chapter Mounting and wiring updated


Product overview

Product overview
Product overview
Additional information
•
Technical data
•
The Beckhoff Bus Terminal system
•
The principle of the Bus Terminal
•
Fieldbus Overview
•
Windows support for USB


Technical data

Product overview [image] Technical data
Technical data
BK9500
Technical data | BK9500
Number of Bus Terminals | 64
Digital peripheral signals | 256 inputs/outputs
Analog peripheral signals | 128 inputs/outputs
Configuration possibility | via the KS2000 configuration software or the controller (TwinCAT)
Maximum number of bytes | 512 bytes I and 512 bytes O
Bus connection | 1 x B type (upstream), 3 x A type (downstream)
Power supply | 24 VDC (-15%/+20%)
Input current | 70 mA + (total K-Bus current)/4, 500 mA max.
Starting current | approx. 2.5 x continuous current
Rec. Back-up fuse | ≤ 10 A
K-bus power supply up to | 1750 mA
Power contact voltage | max. 24 VDC
Power contact current load | max. 10 A
Dielectric strength | 500 V (power contact/supply voltage/fieldbus)
Weight | app. 170 g
Permissible ambient temperature during operation | 0 °C ... +55 °C
Permissible ambient temperature during storage | -25 °C ... +85 °C
Permissible relative humidity | 95 % no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Installation position | variable
Protection class | IP20
Approvals | CE, cULus, ATEX
System data | USB Universal Serial Bus (BK9500)
Number of I/O modules | max. 127
Number of I/O points | depending on controller
Data transfer medium | 1 x 2 twisted-pair (28 AWG) copper cable, 1 x 2 power supply
Maximum cable length | 5 m from BK9500 to BK9500, 30 m between PC and last BK9500
Data transfer rate | 12 Mbaud
Topology | Tree structure, maximum depth 5


The Beckhoff Bus Terminal system

Product overview [image] The Beckhoff Bus Terminal system
The Beckhoff Bus Terminal system
Up to 256 Bus Terminals, with 1 to 16 I/O channels per signal form
The Bus Terminal system is the universal interface between a fieldbus system and the sensor / actuator level. A unit consists of a Bus Coupler as the head station, and up to 64 electronic series terminals, the last one being an end terminal. Up to 255 Bus Terminals can be connected via the K-bus extension. For each technical signal form, terminals are available with one, two, four or eight I/O channels, which can be mixed as required. All the terminal types have the same mechanical construction, so that difficulties of planning and design are minimized. The height and depth match the dimensions of compact terminal boxes.
Decentralised wiring of each I/O level
Fieldbus technology allows more compact forms of controller to be used. The I/O level does not have to be brought to the controller. The sensors and actuators can be wired decentrally, using minimum cable lengths. The controller can be installed at any location within the plant.
Industrial PCs as controllers
The use of an Industrial PC as the controller means that the operating and observing element can be implemented in the controller's hardware. The controller can therefore be located at an operating panel, in a control room, or at some similar place. The Bus Terminals form the decentralised input/output level of the controller in the control cabinet and the subsidiary terminal boxes. The power sector of the plant is also controlled over the bus system in addition to the sensor/actuator level. The Bus Terminal replaces the conventional series terminal as the wiring level in the control cabinet. The control cabinet can have smaller dimensions.
Bus Couplers for all usual bus systems
The Beckhoff Bus Terminal system unites the advantages of a bus system with the possibilities of the compact series terminal. Bus Terminals can be driven within all the usual bus systems, thus reducing the controller parts count. The Bus Terminals then behave like conventional connections for that bus system. All the performance features of the particular bus system are supported.
Mounting on standardized mounting rails
The installation is standardized thanks to the simple and space-saving mounting on a standardized mounting rail (EN 60715, 35 mm) and the direct wiring of actuators and sensors, without cross connections between the terminals. The consistent labelling scheme also contributes.
The small physical size and the great flexibility of the Bus Terminal system allow it to be used wherever a series terminal is also used. Every type of connection, such as analog, digital, serial or the direct connection of sensors can be implemented.
Modularity
The modular assembly of the terminal strip with Bus Terminals of various functions limits the number of unused channels to a maximum of one per function. The presence of two channels in one terminal is the optimum compromise of unused channels and the cost of each channel. The possibility of electrical isolation through potential feed terminals also helps to keep the number of unused channels low.
Display of the channel state
The integrated LEDs show the state of the channel at a location close to the sensors and actuators.
K-bus
The K-bus is the data path within a terminal strip. The K-bus is led through from the Bus Coupler through all the terminals via six contacts on the terminals' side walls. The end terminal terminates the K-bus. The user does not have to learn anything about the function of the K-bus or about the internal workings of the terminals and the Bus Coupler. Many software tools that can be supplied make project planning, configuration and operation easy.
Potential feed terminals for isolated groups
The operating voltage is passed on to following terminals via three power contacts. You can divide the terminal strip into arbitrary isolated groups by means of potential feed terminals. The potential feed terminals play no part in the control of the terminals, and can be inserted at any locations within the terminal strip.
Up to 64 Bus Terminals can be used in a terminal block, with optional K-bus extension for up to 256 Bus Terminals. This count does include potential feed terminals, but not the end terminal.
Bus Couplers for various fieldbus systems
Various Bus Couplers can be used to couple the electronic terminal strip quickly and easily to different fieldbus systems. It is also possible to convert to another fieldbus system at a later time. The Bus Coupler performs all the monitoring and control tasks that are necessary for operation of the connected Bus Terminals. The operation and configuration of the Bus Terminals is carried out exclusively by the Bus Coupler. Nevertheless, the parameters that have been set are stored in each Bus Terminal, and are retained in the event of voltage drop-out. Fieldbus, K-bus and I/O level are electrically isolated.
If the exchange of data over the fieldbus is prone to errors or fails for a period of time, register contents (such as counter states) are retained, digital outputs are cleared, and analog outputs take a value that can be configured for each output when commissioning. The default setting for analog outputs is 0 V or 0 mA. Digital outputs return in the inactive state. The timeout periods for the Bus Couplers correspond to the usual settings for the fieldbus system. When converting to a different bus system it is necessary to bear in mind the need to change the timeout periods if the bus cycle time is longer.
The interfaces
A Bus Coupler has six different methods of connection. These interfaces are designed as plug connectors and as spring-loaded terminals.


The principle of the Bus Terminal

Product overview [image] The principle of the Bus Terminal
The principle of the Bus Terminal
Principle of the Bus Terminal


Fieldbus Overview

Product overview [image] Fieldbus Overview
Fieldbus Overview
The USB was developed in response to the need for an economical, modern solution for connecting peripheral components to a PC.
The most important features of the concept were:
▪
cost reduction
▪
connection and configuration were to be as easy as possible (plug-and-play)
▪
addition and removal of devices while the PC is running (hot plugging)
▪
many of the technical disadvantages of existing solutions such as RS232 were to be overcome
▪
connection without opening the PC
The USB is a polled bus, which means that all actions are initiated by the host, which is, in most cases, a PC.
usb typ application.gif
USB topology
Basic principles
Velocity/speed
Version 1.1 of the USB supports two speeds:
▪
1.5 Mbit/s (Low-Speed)
▪
12 Mbit/s (Full-Speed)
The BK9500 supports 12 Mbit/s.
Architecture
The cable length from one USB device to another may not be greater than 5 meters. A maximum of 127 devices may be inserted in a tree structure. Branching is implemented through hubs. The maximum nesting depth for cascading hubs is 5. This means that the maximum distance of the last device from the host cannot be greater than 25 meters!
Some additional function is often integrated into a hub. A keyboard (KBD), for example, receives data from the PC (host) and passes it on to other connected peripheral devices such as a mouse, printer and so forth.
USB architecture
Transfer types
Four types of transfer are distinguished:
Control-Transfer
Special inquiries known as requests are sent to the USB device, typically during the configuration phase.
Interrupt-Transfer
This is the transfer method for devices in the PC environment, such as the keyboard, that classically are driven by means of interrupts. No interrupt is, however, actually used.
Bulk-Transfer
Typical examples of this include printers, where large quantities of data must be transmitted without particular real-time requirements.
Isochronous-Transfer
This transfer types is used for data with special requirements on latency time. This mode functions synchronously and with high continuity.
Note
Further Information
More detailed information on USB can be obtained from the USB organization under http://www.usb.org.


Windows support for USB

Product overview [image] Windows support for USB
Windows support for USB
The Universal Serial Bus (USB) is not supported by all versions of Windows.
Proceed as follows to find out which Windows version you are using:
1.
Click on Settings/Control Panel on the start menu
2.
Double-click on the System symbol
3.
Click on the General tabbed page
4.
You will find the general name of the operating system and the version number under System.
Operating system | Version | Version number | USB support
Windows 95 | Full version | 4.00.950 | no*
 | Full version SP1 | 4.00.950A | no*
 | OEM Service Release 1 | 4.00.950A | no*
 | OEM Service Release 2 | 4.00.1111 (4.00.950B) | no*
 | OEM Service Release 2.1 | 4.03.1212-1214 (4.00.950B) | yes
 | OEM Service Release 2.5 | 4.03.1214 (4.00.950C) | yes
Windows 98 | Retail | 4.10.1998 | yes
 | OEM | 4.10.1998 | yes
 | Second Edition (SE) | 4.10.2222A | yes
Windows ME | all | e.g. 4.90.3000 | yes
Windows NT 40 | all | e.g. 4.00.1381 | no**
Windows 2000 | all | e.g. 5.00.2195 | yes
Windows XP | all | 2002 | yes
Windows Vista | all | e.g. 6.0 | yes
Windows 7 | all | e.g. 6.1 | yes
Windows 8 | all | e.g. 6.2 | yes
Windows 8.1 | all | e.g. 6.3 | yes
Windows 10 | all | e.g. 10 | yes
*) In case you have a Windows 95 version without support for USB, however you want USB support, Microsoft recommends, that you update to Windows 98 Second Edition.
**) Windows NT 40 does not support USB. According to Microsoft, no Service Pack to provide USB support under Windows NT 40 is planned.
Note
Further information on USB support
You will find detailed information on USB support in relation to your Windows version at Microsoft. You will also find updates to improve the USB support under a variety of Windows versions there.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Mechanical installation
•
Wiring and cabling


Mechanical installation

Mounting and wiring [image] Mechanical installation
Mechanical installation
Additional information
•
Dimensions
•
Mounting
•
Installation on mounting rails
•
ATEX - Special conditions (standard temperature range)


Dimensions

Mounting and wiring [image] Mechanical installation [image] Dimensions
Dimensions
The system of the Beckhoff Bus Terminals is characterized by low physical volume and high modularity. When planning a project it must be assumed that at least one Bus Coupler and a number of Bus Terminals will be used. The mechanical dimensions of the Bus Couplers are independent of the fieldbus system.
Dimensions
The total width in practical cases is composed of the width of the Bus Coupler, the KL9010 Bus End Terminal and the width of the bus terminals in use. Depending on function, the Bus Terminals are 12 mm or 24 mm wide. The front wiring increases the total height of 68 mm by about 5 mm to 10 mm, depending on the wire thickness.


Mounting

Mounting and wiring [image] Mechanical installation [image] Mounting
Mounting
The Bus Coupler and all the Bus Terminals can be clipped, with a light press, onto a 35 mm mounting rail. A locking mechanism prevents the individual housings from being pulled off again. For removal from the mounting rail the orange colored tension strap releases the latching mechanism, allowing the housing to be pulled off the rail without any force.
Release the locking mechanism by pulling the orange tab
Up to 64 Bus Terminals can be attached to the Bus Coupler on the right hand side. When plugging the components together, be sure to assemble the housings with groove and tongue against each other. A properly working connection cannot be made by pushing the housings together on the mounting rail. When correctly assembled, no significant gap can be seen between the attached housings.
Groove and tongue of the housings
Attention
Bus Terminals should only be pulled or plugged in switched-off state.
Insertion and removal of Bus Terminals is only permitted when switched off. The electronics in the Bus Terminals and in the Bus Coupler are protected to a large measure against damage, but incorrect function and damage cannot be ruled out if they are plugged in under power.


Installation on mounting rails

Mounting and wiring [image] Mechanical installation [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
Mounting
The Bus Couplers and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rail according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the fieldbus Coupler. Join the components with slot and key and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without slot and key, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
During the installation of the Bus Terminals, the locking mechanism of the terminals must not come into conflict with the fixing bolts of the mounting rail.
Removal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Carefully pull the orange-colored lug approximately 1 cm out of the terminal to be disassembled, until it protrudes loosely. The lock with the mounting rail is now released for this terminal, and the terminal can be pulled from the mounting rail without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal away from the mounting rail.
Connections within a Bus Terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the Bus Terminal block. The power contacts are supplied via terminals on the Bus Coupler.
Note
Power contacts
During the design of a Bus Terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx and EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Attention
Risk of damage to the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a rated voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
The PE power contact must not be used for other potentials!
Wiring
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire safely and permanently.
Note
Shielding
Analog sensors and actuators should always be connected with shielded, pair-wise twisted cables.


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] Mechanical installation [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


Wiring and cabling

Mounting and wiring [image] Wiring and cabling
Wiring and cabling
Additional information
•
Power supply
•
Potential groups, insulation testing and PE
•
USB connection


Power supply

Mounting and wiring [image] Wiring and cabling [image] Power supply
Power supply
Supply of Bus Coupler / Bus Terminal Controller and Bus Terminals (Us)
Additional information
•
BKxx00, BKxx10, BKxx20 and LCxxxx
•
BKxx50 and BKxx51
•
Configuration and Programming Interface
•
Electrical isolation
•
Power contacts


BKxx00, BKxx10, BKxx20 and LCxxxx

Mounting and wiring [image] Wiring and cabling [image] Power supply [image] BKxx00, BKxx10, BKxx20 and LCxxxx
BKxx00, BKxx10, BKxx20 and LCxxxx
The Bus Couplers / Bus Terminal Controllers require an operating voltage of 24 VDC.
The connection is made by means of the upper spring-loaded terminals labelled 24 V and 0 V. This supply voltage is used for the electronic components of the Bus Coupler and Bus Terminal Controllers and (via the K-bus) the electronic components of the Bus Terminals. It is galvanically separated from the field level voltage.
Power supply connections for BKxx00, BKxx10, BKxx20 and LCxxxx


BKxx50 and BKxx51

Mounting and wiring [image] Wiring and cabling [image] Power supply [image] BKxx50 and BKxx51
BKxx50 and BKxx51
The Bus Couplers / Bus Terminal Controllers require an operating voltage of 24 VDC. Use a 4 A fuse or a Class 2 power supply to comply with the UL requirements.
The connection is made by means of the upper spring-loaded terminals labelled Us and GNDs. This supply voltage is used for the electronic components of the Bus Coupler and Bus Terminal Controllers and (via the K-bus) the electronic components of the Bus Terminals. It is galvanically separated from the field level voltage.
Power supply connections for BKxx50 and BKxx51
UL identification
DANGER
Note the UL requirements for the power supply.
To comply with the UL requirements, the 24 VDC supply voltage for Us must originate
•
from an isolated source protected by a fuse of max. 4A (according to UL248) or
•
from a voltage supply complying with NEC class 2.
An NEC class 2 voltage source must not be connected in series or parallel with another NEC class 2 voltage source!
DANGER
No unlimited voltage sources!
To comply with the UL requirements, Us must not be connected with unlimited voltage sources.


Configuration and Programming Interface

Mounting and wiring [image] Wiring and cabling [image] Power supply [image] Configuration and Programming Interface
Configuration and Programming Interface
The standard Bus Couplers have an RS232 interface at the bottom of the front face. The miniature plug connector can be connected to a PC using a connecting cable and the KS2000 configuration software. The interface permits the Bus Terminals to be configured, for example adjusting the amplification factors of the analog channels. The interface can also be used to change the assignments of the bus terminal data to the process image in the Bus Coupler. The functionality of the configuration interface can also be reached via the fieldbus using string communication facility.


Electrical isolation

Mounting and wiring [image] Wiring and cabling [image] Power supply [image] Electrical isolation
Electrical isolation
The Bus Couplers / Bus Terminal Controllers operate with three independent potential groups. The supply voltage feeds the K-bus electronics and the K-bus itself. The supply voltage is also used to generate the operating voltage for the fieldbus interface.
Note: All the Bus Terminals are electrically isolated from the K-bus. The K-bus is thus electrically isolated from everything else.
Potential connection diagram of an EKxxxx


Power contacts

Mounting and wiring [image] Wiring and cabling [image] Power supply [image] Power contacts
Power contacts
Power contacts supply (Up)
The bottom six connections with spring-loaded terminals can be used to feed the supply for the peripherals. The spring-loaded terminals are joined in pairs to a power contact. The power supply for the power contacts has no connection to the power supply for the Bus Couplers / Bus Terminal Controllers.
The spring-loaded terminals are designed for wires with cross-sections between 0.08 mm² and 2.5 mm².
The assignment in pairs and the electrical connection between feed terminal contacts allows the connection wires to be looped through to various terminal points. The current load from the power contact must not exceed 10 A for long periods. The current carrying capacity between two spring-loaded terminals is identical to that of the connecting wires.
Power contacts
Three spring contacts of the power contact connections can be found on the right of the Bus Coupler / Bus Terminal Controller. The spring contacts are hidden in slots so that they cannot be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue & groove design of the top and bottom of the Bus Coupler / Bus Terminal Controller and Bus Terminals enables secure fitting of the power contacts.


Potential groups, insulation testing and PE

Mounting and wiring [image] Wiring and cabling [image] Potential groups, insulation testing and PE
Potential groups, insulation testing and PE
Potential groups
A Beckhoff Bus Terminal block usually has three different potential groups:
▪
The fieldbus interface is electrically isolated (except for individual Low Cost couplers) and forms the first potential group.
▪
Bus Coupler / Bus Terminal Controller logic, K-bus and terminal logic form a second electrically isolated potential group.
▪
The inputs and outputs are supplied via the power contacts and form further potential groups.
Groups of I/O terminals can be consolidated to further potential groups via potential supply terminals or separation terminals.
Potential groups of a Bus Terminal block
Insulation testing
The connection between Bus Coupler / Bus Terminal Controller and Bus Terminals is realized automatically by latching the components. The transfer of the data and the supply voltage for the intelligent electronics in the Bus Terminals is performed by the K-bus. The supply of the field electronics is performed through the power contacts. Plugging together the power contacts creates a supply rail. Since some Bus Terminals (e.g. analog Bus Terminals or 4-channel digital Bus Terminals) are not looped through these power contacts or not completely the Bus Terminal contact assignments must be considered.
The potential feed terminals interrupt the power contacts, and represent the start of a new supply rail. The Bus Coupler / Bus Terminal Controller can also be used for supplying the power contacts.
PE power contacts
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on the left
It should be noted that, for reasons of electromagnetic compatibility, the PE contacts are capacitively coupled to the mounting rail. This can both lead to misleading results and to damaging the terminal during insulation testing (e.g. breakdown of the insulation from a 230 V power consuming device to the PE conductor). The PE supply line at the Bus Coupler / Bus Terminal Controller must be disconnected for an insulation test. In order to uncouple further feed locations for the purposes of testing, the feed terminals can be pulled at least 10 mm out from the connected group of other terminals. In that case, the PE conductors do not have to be disconnected.
The power contact with the label PE must not be used for other potentials.


USB connection

Mounting and wiring [image] Wiring and cabling [image] USB connection
USB connection
The connection is made via a commercially available USB cable. Extensions are not permitted.
bk9500 typical molded cable
USB cables
Cabling
BK9500 USB ports
The BK9500 has one upstream port (type B) for connecting to the PC and three downstream ports (type A) for other USB devices.
bk9500 connector typ b.jpg
Upstream Port (type B)
bk9500 connector typ a.jpg
Downstream Port (type A)
Assignment of the USB ports
PIN | Signal | Description
1 | VBUS | Red
2 | D - | White
3 | D + | Green
4 | GND | Black
Housing | Shield | Shield


Parameterization and Commissioning

Parameterization and Commissioning
Parameterization and Commissioning
Additional information
•
Start-up behaviour of the Bus Coupler
•
Process data and the process image
•
Local process image
•
Address selection
•
Configuration by means of the TwinCAT System Manager
•
Configuration with KS2000


Start-up behaviour of the Bus Coupler

Parameterization and Commissioning [image] Start-up behaviour of the Bus Coupler
Start-up behaviour of the Bus Coupler
Immediately after being switched on, the Bus Coupler checks, in the course of a self-test, all the functions of its components and the communication on the K-bus/E-bus. The red I/O LED blinks while this is happening. After completion of the self-test, the Bus Coupler starts to test the attached Bus Terminals (the "Bus Terminal Test"), and reads in the configuration. The Bus Terminal configuration is used to generate an internal structure list, which is not accessible from outside. In case of an error, the Bus Coupler enters the Stop state. Once the start-up has completed without error, the Bus Coupler enters the fieldbus start state.
Start-up behaviour of the Bus Coupler
The Bus Coupler can be made to enter the normal operating state by switching it on again once the fault has been rectified.


Process data and the process image

Parameterization and Commissioning [image] Process data and the process image
Process data and the process image
After being switched on, the Bus Coupler determines automatically the configuration of the inserted input/output terminals. The assignment of the physical slots for the input/output channels and the addresses in the process image is carried out automatically by the Bus Coupler.
The Bus Coupler creates an internal assignment list, in which the input/output channels have a specific position in the process image of the Bus Coupler. A distinction is made here according to inputs and outputs, and according to bit-oriented (digital) and byte-oriented (analog or complex) signal processing.
Two groups are created, one for inputs and the other for outputs. Each group has the byte-oriented channels in ascending sequence, starting from the lowest address, and these are followed by the bit-oriented channels.
Digital signals (bit-oriented)
The (binary) digital signals are bit-oriented. This means that one bit in the process image is assigned to each channel. The Bus Coupler creates a memory area containing the current input bits, and ensures that the bits in a second (output) memory area dedicated to the output channels are written out immediately, following the update command. The details of the assignment of the input and output channels to the controller's process image is explained fully with the aid of an example in the appendix.
Analog signals (byte-oriented)
The processing of analog signals is always byte-oriented. Analog input and output values are represented in memory by two bytes each. Values are represented in SIGNED INTEGER format. The number 0 stands for the input/output value 0 V, 0 mA or 4 mA. The maximum value of an output or input value is represented, according to the standard settings, by 0x7FFF. The intermediate values are correspondingly proportional. A range with a resolution of 15 bits is not achieved for all inputs and outputs. If the actual resolution is 12 bits, the last three bits have no effect in outputs, while as inputs they are read as 0. Each channel also has a control and status byte. The control and status byte is the most significant byte in the most significant word. An analog channel is represented by 4 bytes in the process image, of which 3 bytes are used. In the BK3000 and BK4000 only 2 bytes are occupied in the process image of the corresponding bus system for each analog channel. The Bus Terminal's control and status bytes can also be included through appropriate configuration of the Bus Coupler and Bus Terminals.
Special signals and interfaces
The Bus Coupler supports Bus Terminals with other interfaces such as RS232, RS485, incremental encoder and others. These signals can be considered similarly to the analog signals named above. For some special signals the bit width of 16 is not sufficient. The Bus Coupler can support any byte width. It is necessary to consider how data consistency is ensured when accessing these values. This means that update commands must not be issued nor must the Bus Coupler be placed into the free running mode between the accesses.
Default assignment of inputs/outputs to the process image
Once it has been switched on, the Bus Coupler finds out how many Bus Terminals are inserted, and creates an assignment list. The analog and digital channels, divided into inputs and outputs, are assembled into separate parts of this list. The assignment starts on the left next to the Bus Coupler. The software in the Bus Coupler collects consecutively the individual entries for each of the channels in order to create the assignment list counting from left to right. Four groups are distinguished in the assignment:
Group | Functional type of the channel | Assignment
1 | Analog outputs | byte-wise
2 | Digital outputs | bit-wise
3 | Analog inputs | byte-wise
4 | Digital inputs | bit-wise
All complex Bus Terminals are represented by analog inputs or outputs.
Overview of the distribution of the process image within the Bus Coupler
Output data in the Bus Coupler
Output data in the Bus Coupler
Input data in the Bus Coupler
Input data in the Bus Coupler
Data consistency
Items of data are said to be consistent if their content all belongs together, and if they are transmitted as a single block. Examples of data items that belong together are:
▪
the high and low bytes of an analog value (word consistency)
▪
a control/status byte and the associated parameter word for access to the registers
Data consistency in the interaction of peripheral devices and their controllers is, in a basic sense, only assured for a single byte. In other words, the bits of a byte are written or read together. Byte consistency is sufficient for the transmission of digital (binary) signals.
When transmitting process data with a length greater than 8 bits (e.g. analog values) the consistency must be appropriately extended, bearing in mind any properties relating to data consistency specific to the fieldbus. The TwinCAT driver for process data transmission over the USB always exchanges in the entire BK9500 process image, so that the BK9500 can ensure data consistency when the K-Bus cycles are not free running.


Local process image

Parameterization and Commissioning [image] Local process image
Local process image
The default setting is for all the connected Bus Terminals to be assigned to the local process image. Mapping within the Bus Terminal coupler is carried out according to the following rule:
First all the byte-oriented (analog) Bus Terminals, in the sequence in which they are inserted, followed by the bit-oriented (digital) Bus Terminals, rounded up to a whole byte.
Sample
The BK9500 is connected to a PC over the USB. The address of the coupler is set to 1. The following terminals are attached to the coupler (the number of the bits that are mapped is given in brackets):
Location | Terminal on the rail
POS00 | BK9500
POS01 | KL1002 (2 input bits)
POS02 | KL1002 (2 input bits)
POS03 | KL1002 (2 input bits)
POS04 | KL1114 (4 input bits)
POS05 | KL1114 (4 input bits)
POS06 | KL3002 (2 x 16 input bits)
POS07 | KL9200 (-)
POS08 | KL2012 (2 output bits)
POS09 | KL2012 (2 output bits)
POS10 | KL2012 (2 output bits)
POS11 | KL2012 (2 output bits)
POS12 | KL4002 (2 x 16 output bits)
POS13 | KL9010 (-)
It follows that the Bus Coupler's process image appears as indicated below:
Process image for the inputs
Relative byte address of the coupler/inputs | Bit position | Position in the station | Bus Terminal
0, 1 | - | POS06 | KL3002, channel 1
2, 3 | - | POS06 | KL3002, channel 2
4 | 0 | POS01 | KL1002, channel 1
4 | 1 | POS01 | KL1002, channel 2
4 | 2 | POS02 | KL1002, channel 1
4 | 3 | POS02 | KL1002, channel 2
4 | 4 | POS03 | KL1002, channel 1
4 | 5 | POS03 | KL1002, channel 2
4 | 6 | POS04 | KL1114, channel 1
4 | 7 | POS04 | KL1114, channel 2
5 | 0 | POS04 | KL1114, channel 3
5 | 1 | POS04 | KL1114, channel 4
5 | 2 | POS05 | KL1114, channel 1
5 | 3 | POS05 | KL1114, channel 2
5 | 4 | POS05 | KL1114, channel 3
5 | 5 | POS05 | KL1114, channel 4
Process image of the outputs
Relative byte address of the coupler/outputs | Bit position | Position in the station | Bus Terminal
0, 1 | - | POS12 | KL4002, channel 1
2, 3 | - | POS12 | KL4002, channel 2
4 | 0 | POS08 | KL2012, channel 1
4 | 1 | POS08 | KL2012, channel 2
4 | 2 | POS09 | KL2012, channel 1
4 | 3 | POS09 | KL2012, channel 2
4 | 4 | POS10 | KL2012, channel 1
4 | 5 | POS10 | KL2012, channel 2
4 | 6 | POS11 | KL2012, channel 1
4 | 7 | POS11 | KL2012, channel 2


Address selection

Parameterization and Commissioning [image] Address selection
Address selection
Although it is the nature of the USB not to require address setting in the conventional sense, an address switch has nevertheless been integrated. This makes it possible to distinguish multiple Bus Couplers in one USB network.
The address is set by means of the DIP switch. Addresses from 0 to 127 are permitted.
DIP switch
Priority of the address - example
DIP switch
Switch no. | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |
Valence | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 |
Decimal | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128 |
In this example | ON | ON | OFF | OFF | OFF | ON | OFF | OFF |
Example value | 1 | 2 | 0 | 0 | 0 | 32 | 0 | 0 | Total=35
Address in the TwinCAT System Manager
Address in the TwinCAT System Manager
Enter the address that has been set using the DIP switch for each USB coupler into the TwinCAT System Manager. In an automatic device search, the TwinCAT System Manager will automatically determine the addresses that have been set for all the connected USB couplers.


Configuration by means of the TwinCAT System Manager

Parameterization and Commissioning [image] Configuration by means of the TwinCAT System Manager
Configuration by means of the TwinCAT System Manager
Insert a virtual USB interface under I/O devices in the TwinCAT System Manager. If Bus Couplers are already connected to the USB network, the system manager can automatically read these too. In this way the configuration of all the connected Bus Couplers and Bus Terminals is loaded. It is then possible to adapt this configuration to your particular needs in the System Manager.
bk9500 twincat configuration
Adding a virtual USB interface
Stop the TwinCAT system
Note
Older TwinCAT versions
For older TwinCAT versions (see chapter Troubleshooting), the TwinCAT system must be stopped for automatic reading of the connected USB couplers!
Stopping the TwinCAT system
Note
Display of control and status bytes of the connected terminals
For terminals,
•
which otherwise can optionally be operated with compact or complete process image, the BK9500 USB coupler only supports the compact process image. That means that the BK9500 does not display the control and status bytes of these terminals in the process image.
•
For terminals, which require the complete process image for operation, the BK9500 USB coupler naturally supports this. That means that the BK9500 displays the control and status bytes of these terminals in the process image.


Configuration with KS2000

Parameterization and Commissioning [image] Configuration with KS2000
Configuration with KS2000
The Bus Coupler parameters can also be set via the KS2000 configuration software.
Note
No simultaneous access to the USB coupler
You cannot simultaneously access the USB coupler via USB and the serial configuration interface. Terminate the cyclic data transfer on the USB before accessing the Bus Coupler via the serial interface using the KS2000 configuration software.
Representation of the BK9500 in KS2000
Configuration of the BK9500 in KS2000
Auto-configuration
When starting, the USB coupler assigns an address in its input and output process image to the attached terminals.
Evaluating complex terminals
The Beckhoff Bus Terminal system makes a large number of different Bus Terminals available for the operation of sensors and actuators.
In general, a distinction is made between digital and complex Bus Terminals. Complex terminals include all terminals that exchange byte information with the Bus Coupler (e.g. analog terminals, communication terminals or terminals for incremental encoders).
If the Evaluation of complex terminals option is selected the Bus Terminals for this station are fully evaluated, which means that all the data related to the connected terminals is transferred in the USB coupler's process image. In the case of analog terminals (such as the KL3002) this means that control and status bytes are included in the transmission, and that the terminal exchanges both input and output data with the Bus Coupler.
The technical documentation for the relevant Bus Terminals provides information relating to the data representation of the individual channels.
TwinCAT 2.8 only supports compact mapping for the USB coupler!
Motorola format (complex terminals)
This option sets the representation format for the complex terminals. You can choose between Motorola format (active) and Intel format (inactive). Using the Motorola format indicates that the more significant data byte of data word is located at the lower address offset of the memory location. The arrangement is precisely the opposite under the Intel format.
Format | Address-Offset | High byte | Low byte
Motorola | $0 | D0 | D1
Intel | $0 | D1 | D0
Motorola format (digital terminals)
If you select the Motorola format for digital terminals, the high and low bytes of a word containing digital input data (i.e. from a total of 16 sequential digital channels) are swapped.
WORD Alignment
You must select the Word Alignment option if you wish to place a data word against a word boundary within the process image memory area (i.e. on an even byte address).
Free running input image
The coupler autonomously fetches the process input image from the input terminals. Updating the process image runs freely (asynchronously) with respect to the fieldbus. Data consistency is not ensured for all types of terminal!
Free running output image
The coupler autonomously (asynchronously) sends the process output image to the output terminals. There is no synchronization with the fieldbus cycles. Data consistency is not ensured for all types of terminal!


Error handling and diagnosis

Error handling and diagnosis
Error handling and diagnosis
Additional information
•
Diagnostic LEDs
•
Trouble Shooting


Diagnostic LEDs

Error handling and diagnosis [image] Diagnostic LEDs
Diagnostic LEDs
After switching on, the Bus Coupler immediately checks the connected configuration. Error-free start-up is indicated when the red I/O ERR LED goes out. If the I/O ERR LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.
The Bus Coupler has two groups of LEDs for the display of status. The upper group with four LEDs indicates the status of the respective fieldbus. The significance of the fieldbus status LEDs is explained in the appropriate sections of this manual. It corresponds to the usual fieldbus display.
On the upper right hand side of the Bus Couplers are two more green LEDs that indicate the supply voltage. The left hand LED indicates the presence of the 24 V supply for the Bus Coupler. The right hand LED indicates the presence of the supply to the power contacts.
BK9500 - LEDs
LEDs for power supply diagnostics
LED | Meaning
Left LED off | Bus Coupler has no power
Right LED off | No power supply 24 VDC connected at the power contacts
LEDs for fieldbus diagnostics
LED | On | Off
CYCLE | Cyclic data exchange (isochronous pipes) | No connection present
DIA 0 | Bulk or control data exchange | No bus traffic present
DIA 1 | The USB device is being addressed by the host. | No error
ERROR | Error |
LEDs for K-Bus diagnosis of I/O ERR
Error code | Error code argument | Description | Remedy
Persistent, continuous flashing |  | EMC problems | Check power supply for undervoltage or overvoltage peaks Implement EMC measures If a K-Bus error is present, it can be localized by a restart of the coupler (by switching it off and then on again)
1 pulse | 0 | EEPROM checksum error | Set manufacturer's setting with the KS2000
 | 1 | Inline code buffer overflow | Connect fewer terminals; too many entries in the table for the programmed configuration
 | 2 | Unknown data type | Firmware update necessary for the fieldbus coupler
2 pulses | 0 | Programmed configuration incorrect table entry / Bus Coupler | Check programmed configuration for correctness
 | (n>0) | Incorrect table comparison (terminal n) | Incorrect table entry / Bus Coupler
3 pulses | 0 | Terminal bus command error | No terminal connected; attach terminals. One of the terminals is defective; halve the number of terminals attached and check whether the error is still present with the remaining terminals. Repeat until the defective terminal is located.
4 pulses | n | Terminal bus data error, break behind terminal n | Check whether the n+1 terminal is correctly connected; replace if necessary. Check whether the End Terminal 9010 is connected.
5 pulses | n | Terminal bus error in register communication with terminal n | Replace terminal n.
Error location
The number of pulses indicates the position of the last Bus Terminal before the fault. Passive Bus Terminals, such as a power feed terminal, are not included in the count.
When the error is rectified, the Bus Coupler does not stop flashing. Operating state of the Bus Coupler: Stop. The Bus Coupler can only be re-started by switching off the supply voltage.


Trouble Shooting

Error handling and diagnosis [image] Trouble Shooting
Trouble Shooting
If the BK9500 USB coupler is used with older TwinCAT versions, the following behavior occurs.
Error
Cause
Remedy
The TwinCAT System Manager does not recognize the connected USB coupler.
The higher level TwinCAT system must be stopped while the connection between the USB interface of your PC and the USB coupler is established! The TwinCAT System Manager cannot reliably recognize USB couplers that are switched on or that are connected to their USB network while the TwinCAT system is running.
▪
Stop the TwinCAT system
▪
Switch all the USB couplers off, or disconnect their USB connections to your PC
▪
Switch all the USB couplers on again, or connect them once more to your PC's USB interface
▪
Allow the TwinCAT System Manager to search for the USB couplers
▪
Start the TwinCAT system again
Although the TwinCAT System Manager does detect the connected USB coupler, the terminals that are connected to it are not seen
Terminals that are added while the TwinCAT system is running cannot be reliably detected by the TwinCAT System Manager.
Note
Update your TwinCAT version
These errors are fixed from the following TwinCAT versions. When using the BK9500 USB coupler, Beckhoff therefore recommends updating to this TwinCAT version or a later version!
•
TwinCAT version 2.8 (build 747) and
•
TwinCAT Version 2.9 (Build 947)
Access from the PC to the BK9500 USB coupler is always via the Beckhoff PC TwinCAT control software. Other drivers are not supported!


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
The following conditions must be met in order to ensure flawless operation of the fieldbus components.
Environmental conditions
Operation
The components may not be used without additional protection in the following locations:
▪
in difficult environments, such as where there are corrosive vapors or gases, or high dust levels
▪
in the presence of high levels of ionizing radiation
Condition | Permissible range
Permissible ambient temperature during operation | see technical data
Installation position | variable
Vibration resistance | According to EN 60068-2-6
Shock resistance | According to EN 60068-2-27
EMC resistance | According to EN 61000-6-2
Emission | According to EN 61000-6-4
Transport and storage
Condition | Permissible range
Permissible ambient temperature during storage | -25 °C... +85 °C
Relative humidity | 95 %, no condensation
Free fall | up to 1 m in the original packaging
Protection classes and types
Condition | Permissible range
Protection class in accordance with IEC 536 (VDE 0106, Part 1) | A protective conductor connection to the mounting rail is necessary!
Protection class conforms to IEC 529 | IP20 (protection against contact with a standard test finger)
Protection against foreign objects | Less than 12 mm in diameter
Protection against water | no protection
Component identification
Every supplied component includes an adhesive label providing information about the product's approvals. For example, on the BK2000:
Sticker with information about the BK2000 Bus Coupler certification
The following information is printed on the label:
Printed item | Meaning for this label
Precise product identification | Lightbus Coupler BK2000
Supply voltage | 24 VDC
Data transfer rate | 2.5 Mbit/s
Manufacturer | Beckhoff Automation GmbH
CE mark | Conformity mark
UL mark | Mark for UL approval. UL stands for the Underwriters Laboratories Inc., the leading certification Organisation for North America, based in the USA. C = Canada, US = USA, LISTED 22ZA (the test results can be inspected under this entry)
Production identification | From left to right, this sequence of characters indicates the week of production (2 characters), the year of production (2 characters), the software version (2 characters) and hardware version (2 characters), along with any special indications (4 characters). This case therefore is a BK2000 - produced in the 9th calendar week - in the year 2001 - containing the BF firmware version - and using the 6th hardware version - with no special indications


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com