BK9053_BK9103 - Bus Coupler for PROFINET
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
2.3.0
▪
Update chapter Foreword
2.2.0
▪
Update chapter IP address
▪
Update Technical data
▪
ATEX - Special conditions (extended temperature range) added
2.1.0
▪
Update Technical data
▪
Update structure
2.0.0
▪
Migration
▪
Update structure
1.3.1
▪
Firmware update
1.3.0
▪
Description of diagnostic D-words added
▪
ATEX notes added
1.2.0
▪
BK9053 added
1.1.0
▪
Firmware B2 update
1.0.0
▪
First version
Firmware and hardware versions
Documentation Version | BK9053 |  | BK9103
 | Firmware | Hardware* | Firmware | Hardware*
2.2.0 | B9 | 06 | C1 | 11
2.1.0 | B9 | 06 | C1 | 11
2.0.0 | B8 | 04 | C0 | 11
1.3.1 | B5 | 00 | BD | 06
1.3.0 | B2 | 00 | BA | 06
1.2.0 | B1 | 00 | B7 | 06
1.1.0 | - | - | B2 | 00
1.0.0 | - | - | B0 | 00
Minimum hardware* required for update.
You can determine which firmware was fitted when the Bus Coupler left the factory from the adhesive label underneath (see the fifth and sixth figures of the production number).
Sample:
3200B2020000
The firmware in the example is B2.
The KS2000 configuration software and the corresponding serial cable included with, is required for updating your firmware.
New firmware versions can be found at http://www.beckhoff.de.
Notes on the firmware versions
BK9103
Firmware
Description
C0
▪
Supported terminals - KL6781, KL8519, KL8524, KL8528 and KL8548
BF
▪
The record index 0x1010 can be used to deselect a parametrization (= write) of the K-bus -> e.g. for the IO-Link terminal
BE
▪
Internal buffer for frames increased
BD
▪
Support compact mapping for KL6051
▪
After a K-bus reset via KS2000 or DAP Ctrl the AR is always disassembled
▪
Only one LLDP is accepted; the REMMIB is not deleted and a new neighbor is not accepted until the TTL has elapsed
BC
▪
Reading of the RemPort MIB rectified (via SNMP)
BB
▪
GSDML for Schema V2.3
▪
MRP client is now supported
▪
Multiple write is supported
BA
▪
In the event of a pull/plug alarm only the states of the affected modules are set to BAD/GOOD
B9
▪
Support of KL6224 (IO-Link master)
B8
▪
I&M2 and I&M3 supported
B7
▪
HD terminals included
B6
▪
KL2791, KL1212, KL2641 implemented
▪
Step 7 online view supported
B5
▪
Alias name revised
B4
▪
LLDP, SNMP implemented
▪
I&M0, I&M1, I&M4 supported
B3
▪
Support for all KL terminals
B2
▪
Support for new Bus Terminals implemented.
▪
KL3xxx and KL4xxx can now also be entered in compact form.
B0
▪
First published
BK9053
Firmware
Description
▪
Supported terminals - KL6781, KL8519, KL8524, KL8528 and KL8548
B7
▪
The record index 0x1010 can be used to deselect a parametrization (= write) of the K-bus -> e.g. for the IO-Link terminal
B6
▪
Internal buffer for frames increased
B5
▪
Support compact mapping for KL6051
▪
After a K-bus reset via KS2000 or DAP Ctrl the AR is always disassembled
▪
Only one LLDP is accepted; the REMMIB is not deleted and a new neighbor is not accepted until the TTL has elapsed
B4
▪
Reading of the RemPort MIB rectified (via SNMP)
B3
▪
Support of KL6224 (IO-Link master)
▪
GSDML for Schema V2.3
B2
▪
Firmware released
B0
▪
First publication (preliminary)


Product overview

Product overview
Product overview
Additional information
•
BK9053 - introduction
•
BK9103 - introduction
•
Technical data
•
The Beckhoff Bus Terminal system
•
The principle of the Bus Terminal


BK9053 - introduction

Product overview [image] BK9053 - introduction
BK9053 - introduction
BK9053
PROFINET is the open Industrial Ethernet-standard of the PNO (PROFIBUS User Organisation). Internationally established IT standards are used for communication.
PROFINET IO describes data exchange between controllers and field devices. It can be used in standard Ethernet networks and networked via commercially available switches. Linking to any PROFINET controller takes place via the GSDML basic device file.
The BK9053 Bus Coupler connects PROFINET with the modular, extendable electronic terminal blocks. A unit consists of a Bus Coupler, any number (between 1 and 64) of terminals (255 with K-bus extension) and one end terminal.
The Bus Couplers recognize the terminals to which they are connected, and perform the assignment of the inputs and outputs to the words of the process image automatically.


BK9103 - introduction

Product overview [image] BK9103 - introduction
BK9103 - introduction
BK9103
The BK9103 Bus Coupler connects PROFINET with the modular, extendable electronic terminal blocks. A unit consists of a Bus Coupler, any number (between 1 and 64) of terminals, and a bus end terminal (255 Bus Terminals with Terminal Bus extension).
The Bus Couplers recognize the terminals to which they are connected, and perform the assignment of the inputs and outputs to the words of the process image automatically.
The BK9103 Bus Coupler supports 10 Mbit/s and 100 Mbit/s Ethernet. Connection is through normal RJ 45 connectors. The IP address is set on a DIP switch (the offset from a freely selectable start address). In networks with DHCP (a service for the allocation of the logical IP address to the physical node address (MAC-ID)) the Bus Coupler obtains its IP address from the DHCP server.
The BK9103 has an additional RJ-45 port. Both Ethernet ports operate as 2-channel switches. The I/O stations can thus be configured with a line topology, instead of the classic star topology. In many applications; this significantly reduces the wiring effort and the cabling costs. The maximum distance between two couplers is 100 m. Up to 20 BK9103 Bus Couplers are cascadable, so that a maximum line length of 2 km can be achieved.
Complex signal processing for analog I/Os, displacement measurement, etc.
The BK9000 Bus Coupler supports operation of all K-Bus Terminals. As far as the user is concerned, the inputs and outputs are not handled any differently from the way they are by other coupler series. The information is made available for use as a byte array in the process image of the automation device.
The KS2000 configuration software allows the analog and multifunctional Bus Terminals to be adapted to the specific application. Depending on the particular type, the registers in the analog Bus Terminals contain temperature ranges, amplification factors and linearization curves. The KS2000 software can be used to set the desired paramétrisation via the PC. The Bus Terminal stores the setting permanently, even if the voltage supply fails. Having the controller (PLC, IPC) carry out the configuration of the Bus Terminals is a further option. The PLC or IPC uses function blocks (FB) to take care of the configuration of all the peripherals during the start-up phase. The controller can, if required, upload the non-centrally generated configuration data in order to manage and store them centrally. This means that it is not necessary to carry out the setting procedure again if a Bus Terminal is exchanged. The controller carries out the desired setting automatically after switching on.


Technical data

Product overview [image] Technical data
Technical data
System
System data | BK9053 | BK9103
Number of I/O modules | only limited by the IP address space
Number of I/O points | depending on controller
Transmission medium | Twisted pair copper cable, 4 x 2, shielded; category 5 (100 Mbaud)
Distance between modules | 100 m (between switch and Bus Coupler)
Data transfer rate | 10/100 Mbaud
Topology | line or star wiring
Cascading | up to 20 Bus Couplers (max. line length 2 km)
Bus Coupler
Technical data | BK9053 | BK9103
Number of Bus Terminals | 64 (255 with K-bus extension)
Digital peripheral signals | 512 inputs/outputs | 512 inputs/outputs
Analog peripheral signals | 256 inputs/outputs | 256 inputs/outputs
Protocols | PROFINET RT (class B) TCP-ADS for access via Ethernet with KS2000 configuration software
Configuration possibility | Via the KS2000 configuration software or the controller
Maximum number of bytes | 512 bytes of input data and 512 bytes of output data
Bus connection | 1 x RJ45 | 2 x RJ45
Power supply | 24 VDC (-15%/+20%)
Current consumption | 70 mA + (total K bus current)/4, max. 500 mA
Starting current | approx. 2.5 x continuous current
K-Bus power supply up to | 1750 mA
Power contact voltage | maximal 24 VDC
Power contact current load | maximal 10 A
Dielectric strength | 500 V (power contact/supply voltage/Ethernet/fieldbus)
Recommended fuse | ≤ 10 A
Weight | approx. 100 g | approx. 170 g
Mounting | on 35 mm mounting rail conforms to EN 60715
Permissible ambient temperature range during operation | 0 °C ... +55 °C | -25 °C ... +60 °C
Permissible ambient temperature range during storage | -25 °C ... +85 °C | -40 °C ... +85 °C
Permissible relative humidity | 95 %, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Installation position | variable
Protection class | IP20
Approvals | CE, UL, ATEX | CE, UL, ATEX, GL


The Beckhoff Bus Terminal system

Product overview [image] The Beckhoff Bus Terminal system
The Beckhoff Bus Terminal system
Up to 256 Bus Terminals, with 1 to 16 I/O channels per signal form
The Bus Terminal system is the universal interface between a fieldbus system and the sensor / actuator level. A unit consists of a Bus Coupler as the head station, and up to 64 electronic series terminals, the last one being an end terminal. Up to 255 Bus Terminals can be connected via the K-bus extension. For each technical signal form, terminals are available with one, two, four or eight I/O channels, which can be mixed as required. All the terminal types have the same mechanical construction, so that difficulties of planning and design are minimized. The height and depth match the dimensions of compact terminal boxes.
Decentralised wiring of each I/O level
Fieldbus technology allows more compact forms of controller to be used. The I/O level does not have to be brought to the controller. The sensors and actuators can be wired decentrally, using minimum cable lengths. The controller can be installed at any location within the plant.
Industrial PCs as controllers
The use of an Industrial PC as the controller means that the operating and observing element can be implemented in the controller's hardware. The controller can therefore be located at an operating panel, in a control room, or at some similar place. The Bus Terminals form the decentralised input/output level of the controller in the control cabinet and the subsidiary terminal boxes. The power sector of the plant is also controlled over the bus system in addition to the sensor/actuator level. The Bus Terminal replaces the conventional series terminal as the wiring level in the control cabinet. The control cabinet can have smaller dimensions.
Bus Couplers for all usual bus systems
The Beckhoff Bus Terminal system unites the advantages of a bus system with the possibilities of the compact series terminal. Bus Terminals can be driven within all the usual bus systems, thus reducing the controller parts count. The Bus Terminals then behave like conventional connections for that bus system. All the performance features of the particular bus system are supported.
Mounting on standardized mounting rails
The installation is standardized thanks to the simple and space-saving mounting on a standardized mounting rail (EN 60715, 35 mm) and the direct wiring of actuators and sensors, without cross connections between the terminals. The consistent labelling scheme also contributes.
The small physical size and the great flexibility of the Bus Terminal system allow it to be used wherever a series terminal is also used. Every type of connection, such as analog, digital, serial or the direct connection of sensors can be implemented.
Modularity
The modular assembly of the terminal strip with Bus Terminals of various functions limits the number of unused channels to a maximum of one per function. The presence of two channels in one terminal is the optimum compromise of unused channels and the cost of each channel. The possibility of electrical isolation through potential feed terminals also helps to keep the number of unused channels low.
Display of the channel state
The integrated LEDs show the state of the channel at a location close to the sensors and actuators.
K-bus
The K-bus is the data path within a terminal strip. The K-bus is led through from the Bus Coupler through all the terminals via six contacts on the terminals' side walls. The end terminal terminates the K-bus. The user does not have to learn anything about the function of the K-bus or about the internal workings of the terminals and the Bus Coupler. Many software tools that can be supplied make project planning, configuration and operation easy.
Potential feed terminals for isolated groups
The operating voltage is passed on to following terminals via three power contacts. You can divide the terminal strip into arbitrary isolated groups by means of potential feed terminals. The potential feed terminals play no part in the control of the terminals, and can be inserted at any locations within the terminal strip.
Up to 64 Bus Terminals can be used in a terminal block, with optional K-bus extension for up to 256 Bus Terminals. This count does include potential feed terminals, but not the end terminal.
Bus Couplers for various fieldbus systems
Various Bus Couplers can be used to couple the electronic terminal strip quickly and easily to different fieldbus systems. It is also possible to convert to another fieldbus system at a later time. The Bus Coupler performs all the monitoring and control tasks that are necessary for operation of the connected Bus Terminals. The operation and configuration of the Bus Terminals is carried out exclusively by the Bus Coupler. Nevertheless, the parameters that have been set are stored in each Bus Terminal, and are retained in the event of voltage drop-out. Fieldbus, K-bus and I/O level are electrically isolated.
If the exchange of data over the fieldbus is prone to errors or fails for a period of time, register contents (such as counter states) are retained, digital outputs are cleared, and analog outputs take a value that can be configured for each output when commissioning. The default setting for analog outputs is 0 V or 0 mA. Digital outputs return in the inactive state. The timeout periods for the Bus Couplers correspond to the usual settings for the fieldbus system. When converting to a different bus system it is necessary to bear in mind the need to change the timeout periods if the bus cycle time is longer.
The interfaces
A Bus Coupler has six different methods of connection. These interfaces are designed as plug connectors and as spring-loaded terminals.


The principle of the Bus Terminal

Product overview [image] The principle of the Bus Terminal
The principle of the Bus Terminal
The principle of the Bus Terminal


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Dimensions
•
Installation on mounting rails
•
Power supply, potential groups
•
Ethernet connection
•
Ethernet topologies
•
Ethernet cable
•
ATEX - Special conditions (standard temperature range)
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation


Dimensions

Mounting and wiring [image] Dimensions
Dimensions
The system of the Beckhoff Bus Terminals is characterized by low physical volume and high modularity. When planning a project it must be assumed that at least one Bus Coupler and a number of Bus Terminals will be used. The mechanical dimensions of the Bus Couplers are independent of the fieldbus system.
Dimensions
The total width in practical cases is composed of the width of the Bus Coupler, the KL9010 Bus End Terminal and the width of the bus terminals in use. Depending on function, the Bus Terminals are 12 or 24 mm wide. The front wiring increases the total height of 68 mm by about 5 to 10 mm, depending on the wire thickness.
Mechanical data | BKxxxx BCxxxx | BKxx50 BCxx50 | BXxxxx | LCxxxx
Design form | compact terminal housing with signal LED
Material | Polyamide (PA 6.6) | Polyamide (PA 6.6) | Polycarbonate | Polyamide (PA 6.6)
Dimensions (W x H x D) | 49 x 100 x 68 mm | 44 x 100 x 68 mm | 81 (BX8000 61) x 100 x 89 mm | 21 x 100 x 68 mm
Mounting | on 35 mm C-rail in accordance with EN 60715 with latching
Stackable by | Double groove-tongue connection
Labelling | Standard terminal block labelling
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Connection technology | BKxxxx BCxxxx | BKxx50 BCxx50 | BXxxxx | LCxxxx
Wiring | Cage Clamp® spring-loaded system
Connection cross-section | 0.08 mm² ... 2.5 mm², stranded, solid wire, 28-14 AWG
Fieldbus connection | depending on fieldbus |  |  | spring-loaded terminals
Power contacts | 3 spring contacts
Current loading IMAXX | 10 A (125 A short circuit)
Rated voltage | 24 VDC


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
Mounting
The Bus Couplers and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rail according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the fieldbus Coupler. Join the components with slot and key and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Carefully pull the orange-colored lug approximately 1 cm out of the terminal to be disassembled, until it protrudes loosely. The lock with the mounting rail is now released for this terminal, and the terminal can be pulled from the mounting rail without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal away from the mounting rail.
Connections within a Bus Terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the Bus Terminal block. The power contacts are supplied via terminals on the Bus Coupler.
Power contacts
During the design of a Bus Terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx and EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Note
Risk of damage to the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!
Wiring
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire safely and permanently.
Shielding
Analog sensors and actuators should always be connected with shielded, pair-wise twisted cables.


Power supply, potential groups

Mounting and wiring [image] Power supply, potential groups
Power supply, potential groups
Power supply for the Bus Coupler
The Bus Couplers require a 24 VDC supply for their operation. The connection is made by means of the upper spring-loaded terminals labelled 24 V and 0 V. The supply voltage feeds the Bus Coupler electronics and, over the K-Bus/E-Bus, the Bus Terminals. The power supply for the Bus Coupler electronics and that of the K-Bus/E-Bus are electrically separated from the potential of the field level.
Power supply for the power contacts
The bottom six connections with spring-loaded terminals can be used to feed the supply for the peripherals. The spring-loaded terminals are joined in pairs to a power contact. The feed for the power contacts has no connection to the voltage supply for the Bus Coupler. The design of the feed permits voltages of up to 24 V. The assignment in pairs and the electrical connection between feed terminal contacts allows the connection wires to be looped through to various terminal points. The current drawn from the power contacts must not exceed 10 A for long periods. The current carrying capacity between two spring-loaded terminals is identical to that of the connecting wires.
Power contacts
On the right hand face of the Bus Coupler there are three spring contacts for the power contact connections. The spring contacts are hidden in slots so that they cannot be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue and groove guides on the top and bottom of the Bus Coupler and of the Bus Terminals guarantees that the power contacts mate securely.
Configuration interface (not for BK1250, EK1x00)
The standard Bus Couplers have an RS232 interface at the bottom of the front face. The miniature connector can be joined to a PC with the aid of a connecting cable and the KS2000 configuration software. The interface permits the Bus Terminals to be configured, for example adjusting the amplification factors of the analog channels. The interface can also be used to change the assignments of the bus terminal data to the process image in the Bus Coupler. The functionality of the configuration interface can also be reached via the fieldbus using string communication facility.
Electrical isolation
The bus couplers operate by means of three independent potential groups. The supply voltage feeds the K-Bus/E-Bus electronics in the Bus Coupler and the K-Bus/E-Bus itself in an electrically isolated manner. The supply voltage is also used to generate the operating voltage for the fieldbus.
Note: All Bus Terminals are electrically isolated from the K-Bus/E-bus. The K-Bus/E-bus is therefore completely electrically isolated.
Electrical isolation


Ethernet connection

Mounting and wiring [image] Ethernet connection
Ethernet connection
The connection to the Ethernet bus is made via an RJ45 connector (a Western plug).
RJ45 connector
Cabling
Ethernet connection from PC to BK910x via a switch
Ethernet connection from PC to BK910x via a switch
Connect the PC's network card to the hub using a standard Ethernet cable, and connect the hub, again using a standard Ethernet cable, to the Bus Terminal controller. Connection via a switch is done in the same way.
Direct Ethernet connection from PC to BK910x
Direct Ethernet connection from PC to BK910x
A standard Ethernet cable must be used for connecting the PC directly with the Bus Terminal Controller.
Pin assignment of the RJ45 plug
PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | - | reserved
5 | - | reserved
6 | RD - | Receive -
7 | - | reserved
8 | - | reserved


Ethernet topologies

Mounting and wiring [image] Ethernet topologies
Ethernet topologies
BK9053
Since the BK9053 has only one port, a conventional star topology must be used.
BK9103
The BK9103 features an internal triple switch with two external ports and one internal port. The internal switch facilitates creation of a line topology. A maximum of 20 BK9103s can be connected in series in a physical line. The maximum distance between two BK9103s is 100 m. The maximum overall line length is therefore 2 km. No further switch may be included in this line.
Ethernet topology with several BK9103 in two lines
The BK9103 also enables a classic star topology to be set up. In this case the second port is not used. Both port interfaces are equivalent.


Ethernet cable

Mounting and wiring [image] Ethernet cable
Ethernet cable
Transmission standards
10Base5
The transmission medium for 10Base5 consists of a thick coaxial cable ("yellow cable") with a max. transmission speed of 10 Mbaud arranged in a line topology with branches (drops) each of which is connected to one network device. Because all the devices are in this case connected to a common transmission medium, it is inevitable that collisions occur often in 10Base5.
10Base2
10Base2 (Cheaper net) is a further development of 10Base5, and has the advantage that the coaxial cable is cheaper and, being more flexible, is easier to lay. It is possible for several devices to be connected to one 10Base2 cable. It is frequent for branches from a 10Base5 backbone to be implemented in 10Base2.
10BaseT
Describes a twisted pair cable for 10 Mbaud. The network here is constructed as a star. It is no longer the case that every device is attached to the same medium. This means that a broken cable no longer results in failure of the entire network. The use of switches as star couplers enables collisions to be reduced. Using full-duplex connections they can even be entirely avoided.
100BaseT
Twisted pair cable for 100 Mbaud. It is necessary to use a higher cable quality and to employ appropriate hubs or switches in order to achieve the higher data rate.
10BaseF
The 10BaseF standard describes several optical fiber versions.
Short description of the 10BaseT and 100BaseT cable types
Twisted-pair copper cable for star topologies, where the distance between two devices may not exceed 100 meters.
UTP
Unshielded twisted pair
This type of cable belongs to category 3, and is not recommended for use in an industrial environment.
S/UTP
Screened/unshielded twisted pair (screened with copper braid)
Has an overall shield of copper braid to reduce influence of external interference. This cable is recommended for use with Bus Couplers.
FTP
Foiled shielded twisted pair (screened with aluminium foil)
This cable has an outer screen of laminated aluminium and plastic foil.
S/FTP
Screened/foiled-shielded twisted pair (screened with copper braid and aluminium foil)
Has a laminated aluminium screen with a copper braid on top. Such cables can provide up to 70 dB reduction in interference power.
STP
Shielded twisted pair
Describes a cable with an outer screen, without defining the nature of the screen any more closely.
S/STP
Screened/shielded twisted pair (wires are individually screened)
This identification refers to a cable with a screen for each of the two wires as well as an outer shield.
ITP
Industrial Twisted-Pair
The structure is similar to that of S/STP, but, in contrast to S/STP, it has only one pair of conductors.


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Parameterization and commissioning

Parameterization and commissioning
Parameterization and commissioning
Additional information
•
Start-up behaviour of the Bus Coupler
•
DIP switch settings
•
Network classes
•
IP address


Start-up behaviour of the Bus Coupler

Parameterization and commissioning [image] Start-up behaviour of the Bus Coupler
Start-up behaviour of the Bus Coupler
Immediately after being switched on, the Bus Coupler checks, in the course of a self-test, all the functions of its components and the communication on the K-bus/E-bus. The red I/O LED blinks while this is happening. After completion of the self-test, the Bus Coupler starts to test the attached Bus Terminals (the "Bus Terminal Test"), and reads in the configuration. The Bus Terminal configuration is used to generate an internal structure list, which is not accessible from outside. In case of an error, the Bus Coupler enters the Stop state. Once the start-up has completed without error, the Bus Coupler enters the fieldbus start state.
Start-up behaviour of the Bus Coupler
The Bus Coupler can be made to enter the normal operating state by switching it on again once the fault has been rectified.


DIP switch settings

Parameterization and commissioning [image] DIP switch settings
DIP switch settings
DIP switches can be used to select different addressing options and assign the PROFINET name.
BK9103
▪
Right switch position: OFF
▪
Left switch position: ON
DIP switches of the BK9103
The device is PROFINET-compliant if DIP switches 18 are OFF and DIP switches 9 and 10 are ON. All other modes are available as options.
BK9053
▪
Right switch position: ON
▪
Left switch position: OFF
DIP switches of the BK9053
The device is PROFINET-compliant if DIP switches 18 are OFF and DIP switches 1 and 2 are ON. All other modes are available as options.
PROFINET name via DIP switch
The name is formed from bk9103-xxx + DIP switch. xxx corresponds to DIP switch 1-8. Bk must be lower case!
BK9103,
DIP9
BK9103,
DIP10
Description
Restart behaviour
Behaviour with factory settings
BK9053
DIP1 blue
BK9053
DIP2 blue
0
0
Last byte of the IP address via DIP switches 1 to 8
▪
PN name from memory
▪
IP address via DIP switch 1 to 8
▪
PN name becomes empty string
▪
IP address via DIP switches
172.16.17.xxx (xxx DIP-switch)
SNM 255.255.0.0
0
1
DHCP
DIP switch 1 to 8 set to OFF
▪
PN name from memory
▪
IP address and SNM via DHCP
▪
PN name becomes empty string
▪
IP address and SNM via DHCP
▪
DNS name "bk9103-xxyyzz"
xxyyzz last 3 bytes of MAC ID
DHCP
DIP switch 1 to 8 set to ON
▪
PN name via DIP switch 1 to 8*
▪
IP address and SNM via DHCP
▪
PN name via DIP switch 1 to 8
▪
IP address and SNM via DHCP
▪
DNS name "bk9103-xxyyzz"
xxyyzz last 3 bytes of MAC ID
1
0
BootP
▪
PN name from memory
▪
IP address and SNM via BootP
▪
PN name becomes empty string
▪
IP address via BootP
1
1
PROFINET-compliant
DIP switch 1 to 8 set to OFF
▪
PN name from memory
▪
IP address from memory
▪
PN name becomes empty string
▪
IP address 0.0.0.0
PROFINET with fixed name
DIP switch 1 to 8 set to ON
▪
PN name via DIP switch 1 to 8*
▪
IP address from memory
▪
PN name via DIP switch 1 to 8
▪
IP address 0.0.0.0
*) PROFINET name (PN name) cannot be overwritten by the controller.
Legend
PN - Profinet
SNM - SubNetMask
DHCP - Dynamic Host Configuration Protocol
DNS - Domain Name Server


Network classes

Parameterization and commissioning [image] Network classes
Network classes
Three different network classes are distinguished. They determine how many address bits are reserved for the network ID and how many for the node number (e.g. for PCs or Bus Couplers). The difference is located in the first three bits of the IP address.
Network class | Number of bits for the network ID | Enables no. of networks | No. of bits for the node address | Enables no. of nodes per network
A | 7 | 126 | 24 | 16 777 214
B | 14 | 16 382 | 16 | 65 536
C | 21 | 2 097 150 | 8 | 254
Unique IP address
An IP address must be unique within the entire connected network!
Network classes
Identical network class
In a communication with another Ethernet devices, the IP address set must have the same network class. Sample: Your PC has the address 172.16.17.55, which means the coupler must have the address 172.16.xxx.xxx (xxx stands for a number between 0 and 255. 0 is usually used by the router/switch and should therefore remain reserved).
In order to see the PC's own address, the command ipconfig can be entered into a DOS window under Windows NT/2000/XP.


IP address

Parameterization and commissioning [image] IP address
IP address
Usually the IP address is specified by the PROFINET controller and therefore does not need to be set in the bus coupler. The bus couplers are addressed via the PROFINET-Name which can be set using various procedures (see DIP switch settings).
In exceptional cases it makes sense to give the bus coupler an IP address in advance (without connecting PROFINET), e.g. to access the couplers via KS2000 Software and Ethernet.
Additional information
•
IP address and PROFINET name
•
Configuration with KS2000
•
Setting the IP Address Using the Beckhoff BootP Server
•
Setting the address using a DHCP server
•
Subnet mask
•
Testing the IP address


IP address and PROFINET name

Parameterization and commissioning [image] IP address [image] IP address and PROFINET name
IP address and PROFINET name
The IP address can be set using three different procedures, and these will be described in more detail below.
Procedure | Explanation | Necessary components
KS2000 | Addressing using the KS2000 configuration software and DIP switches | KS2000 configuration software and KS2000 cable
BootP | Addressing via BootP server | BootP-Server
DHCP | Addressing via DHCP server | DHCP-Server


Configuration with KS2000

Parameterization and commissioning [image] IP address [image] Configuration with KS2000
Configuration with KS2000
The KS2000 configuration software (from version 3.2.8) can be used to set the TCP/IP address in a dialog box, or it can be written directly into the registers. DIP switches 9 and 10 (for BK9050 DIP switches 1 and 2 in blue) should both be OFF (0) before switching on.
Table 100
Register | High-Byte | Low-Byte
0 | IP-Byte 2 | IP-Byte 1
1 | Not used | IP-Byte 3
Default
Byte | Default value (hex) | Default value (dec)
1 | 0xAC | 172dec
2 | 0x10 | 16dec
3 | 0x11 | 17dec
4 | (DIP switch) | (0 to 255dec)
Sample
DIP switch
Switch no. | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 |
Valence | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128 | - | - |
In this example | ON | OFF | OFF | ON | OFF | OFF | ON | ON | OFF | OFF |
Value | 1 | 0 | 0 | 8 | 0 | 0 | 64 | 128 | - | - | Total=201
Software reset
A software reset is required to save changes in the Bus Coupler tables. A hardware reset (power on/off) is not sufficient!


Setting the IP Address Using the Beckhoff BootP Server

Parameterization and commissioning [image] IP address [image] Setting the IP Address Using the Beckhoff BootP Server
Setting the IP Address Using the Beckhoff BootP Server
If the address is to be set by the Beckhoff BootP server, then set DIP switch 9 to ON (1) and DIP switch 10 to OFF (0). DIP switches 1-8 then no longer have any address function. If this is not the case, the Bus Coupler reports LED error code 6-4 (see diagnostics LEDs). The TCP/IP ERROR LED flashes while the address is being allocated.
IP address save modes
DIP switches 1-8 in the ON position
The address assigned by the BootP server is stored, and the BootP service will not be restarted after the next cold start.
The address can be cleared again by reactivating the manufacturers' settings (using the KS2000 software or by DIP switch and end terminal).
DIP switches 1-8 in the OFF position
The IP address assigned by the BootP server is only valid until the Bus Coupler is switched off. The BootP server must assign a new IP address to the Bus Coupler at the next cold start.
The address is, however, retained through a software reset of the Bus Coupler.
Beckhoff BootP server
Beckhoff supply a BootP server for Windows 98, ME, NT4.0, NT2000 and XP. The installation version of the Beckhoff TwinCAT CD can be found under the folder >Unsupported Utilities< or under http://download.beckhoff.com/.
Configuration of the Beckhoff BootP server
As soon as the BootP server has started, the New MAC Address window shows all the Beckhoff nodes that are working in BootP mode and still have not received an IP address. The assignment of the MAC-ID to IP address is made with the "<<" button. Successful assignment is displayed in the log window.
To start the BootP server automatically when your PC boots, it is only necessary to provide a shortcut in the Windows autostart folder. Include the /Start parameter in the shortcut (.../TcBootPDlg.exe/start).


Setting the address using a DHCP server

Parameterization and commissioning [image] IP address [image] Setting the address using a DHCP server
Setting the address using a DHCP server
To set the address by means of a DHCP server, set DIP switch 9 to OFF (0) and DIP switch 10 to ON (1).
In this state the DHCP service is switched on, and the Bus Coupler is assigned an IP address by the DHCP server.
The DHCP server must know the MAC ID of the Bus Coupler and should assign the same IP address to this MAC ID on each startup.
The TCP/IP error LED flashes while the address is being allocated.


Subnet mask

Parameterization and commissioning [image] IP address [image] Subnet mask
Subnet mask
The subnet mask is subject to the control of the network administrator, and specifies the structure of the subnet.
Small networks without a router do not require a subnet mask. The same is true if you do not use registered IP numbers. A subnet mask can be used to subdivide the network with the aid of the mask instead of using a large number of network numbers.
The subnet mask is a 32-bit number:
▪
Ones in the mask indicate the subnet part of an address space.
▪
Zeros indicate that part of the address space which is available for the host IDs.
Description | Binary representation | Decimal representation
IP address | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnet mask | 11111111.11111111.00010100.00000000 | 255.255.20.0
Network ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host ID | 00000000.00000000.00000001.11001000 | 0.0.1.200
Standard subnet mask
Address class | Standard subnet mask (decimal) | Standard subnet mask (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00
Subnets and host number
Neither subnet 0 nor the subnet consisting only of ones may be used. Neither host number 0 nor the host number consisting only of ones may be used!
If the IP address is set using the KS2000 configuration software, it is necessary for the subnet mask also to be changed with the KS2000 configuration software.
If ARP addressing is used, the associated standard subnet mask, based on the IP address, is entered.
Under BootP or DHCP the subnet mask is transmitted also by the server.


Testing the IP address

Parameterization and commissioning [image] IP address [image] Testing the IP address
Testing the IP address
To test the IP address you can use the Ping command in a Windows prompt.
Testing the IP address using the Ping command


Configuration

Configuration
Configuration
Additional information
•
GSDML configuration files
•
Mapping the Bus Terminals
•
Configuration example with Step 7


GSDML configuration files

Configuration [image] GSDML configuration files
GSDML configuration files
The latest PROFINET master configuration file for the Bus Couplers BK9053 and BK9103 can be found on the Beckhoff website under Downloads:
http://www.beckhoff.de/german/download/bkconfg.htm


Mapping the Bus Terminals

Configuration [image] Mapping the Bus Terminals
Mapping the Bus Terminals
The KLxxxx or KSxxxx Bus Terminals are mapped to the Bus Coupler in the order in which the hardware is connected. No distinction is made between KLxxxx and KSxxxx Bus Terminals. Bus Terminals without process image cannot be configured (e.g. KL9100, KL9020, KL9050, KL9010).
For digital Bus Terminals at least one byte is reserved in all cases.
Example: KL1xx2 2 digital inputs, 8 bit, with the first two bits 0-1 reserved for the terminal. Bits 2-7 are not used.
Complex Bus Terminals are represented with an input and output process image.
Sample: KL3001 1 analog input 1 Byte Control or Status Information, one empty byte, 2 Byte Data.


Configuration example with Step 7

Configuration [image] Configuration example with Step 7
Configuration example with Step 7
Install the GSDML file (Step 7 from version 5.4 + SP1)
To this end open the hardware manager. Install the GSDML file.
Step 7 - installing the GSDML file
Add a BK9103 as a node in your Manager, then add the terminals according to your configuration.
Step 7 - adding the BK9103 Bus Coupler and the Bus Terminals according to the configuration
Enter the name of the PN device, e.g. bk9103-1 (bk must be lower case).
Set DIP switches 1, 9 and 10 of the BK9103 to ON and all others to OFF, then switch on the Coupler).
Step 7 - enter the name for the PROFINET device
The configuration will now look as follows, for example. Load the configuration into your control system.
Step 7 - display of the configuration in the controller


Fieldbus system

Fieldbus system
Fieldbus system
Additional information
•
Fieldbus Overview
•
Ethernet
•
Topology


Fieldbus Overview

Fieldbus system [image] Fieldbus Overview
Fieldbus Overview
Ethernet was originally developed by DEC, Intel and XEROX (as the "DIX" standard) for passing data between office devices. The term nowadays generally refers to the IEEE 802.3 CSMA/CD specification, published in 1985. Because of the high acceptance around the world this technology is available everywhere and is very economical. This means that it is easy to make connections to existing networks.
There are now a number of quite different transmission media: coaxial cable (10Base5), optical fiber (10BaseF) or twisted pairs (10BaseT) with screen (STP) or without screen (UTP). A variety of topologies such as ring, line or star can be constructed with Ethernet.
Ethernet transmits Ethernet packets from a sender to one or more receivers. This transmission takes place without acknowledgement, and without the repetition of lost packets. To achieve reliable data communication, there are protocols, such as TCP/IP, that can run on top of Ethernet.
Basic principles
The Internet Protocol (IP)
The internet protocol (IP) forms the basis of this data communication. IP transports data packets from one device to another; the devices can be in the same network, or in different networks. IP here looks after the address management (finding and assigning MAC-IDs), segmentation and routing. Like the Ethernet protocol, IP does not guarantee that the data is transported - data packets can be lost, or their sequence can be changed.
TCP/IP was developed to provide standardized, reliable data exchange between any numbers of different networks. TCP/IP is thus substantially independent of the hardware or software being used. Although the term is often used as if it were a single concept, a number of protocols are layered together: e.g. IP, TCP, UDP, ARP and ICMP.
Transmission Control Protocol (TCP)
The Transmission Control Protocol (TCP) which runs on top of IP is a connection-oriented transport protocol. It includes error detection and error handling mechanisms. Lost telegrams are repeated.
User Datagram Protocol (UDP)
UDP is connectionless transport protocol. It provides no control mechanism when exchanging data between sender and receiver. This results in a higher processing speed than, for example, TCP. Checking whether or not the telegram has arrived must be carried out by the higher-level protocol.
Internet Control Message Protocol (ICMP)
It is used by end devices, to exchange information about the current status of the internet protocol.
Address Resolution Protocol (ARP)
Performs conversion between the IP addresses and MAC addresses.
BootP
The BootP protocol allows the TCP/IP address to be set or altered, by addressing the network device with its MAC-ID.


Ethernet

Fieldbus system [image] Ethernet
Ethernet
Ethernet was originally developed by DEC, Intel and XEROX (as the "DIX" standard) for passing data between office devices. The term nowadays generally refers to the IEEE 802.3 CSMA/CD specification, published in 1985. Because of the high acceptance around the world this technology is available everywhere and is very economical. This means that it is easy to make connections to existing networks.
There are now a number of quite different transmission media: coaxial cable (10Base5), optical fiber (10BaseF) or twisted pairs (10BaseT) with screen (STP) or without screen (UTP). Coaxial cable (10Base5), optical fiber (10BaseF) or twisted pairs (10BaseT) with screen (STP) or without screen (UTP).
Ethernet transmits Ethernet packets from a sender to one or more receivers. This transmission takes place without acknowledgement, and without the repetition of lost packets. To achieve reliable data communication, there are protocols, such as TCP/IP, that can run on top of Ethernet.
MAC-ID
The sender and receiver of Ethernet packets are addressed by means of the MAC-ID. The MAC-ID is a 6 byte identification code unique to every Ethernet device in the world. The MAC-ID consists of two parts. The first part (i.e. the first 3 bytes) is a manufacturer identifier. The identifier for Beckhoff is 00 01 05. The next 3 bytes are assigned by the manufacturer and implement a unique serial number. The MAC-ID can, for example, be used for the BootP protocol in order to set the TCP/IP number. This involves sending a telegram containing the information such as the name or the TCP/IP number to the corresponding node. You can read the MAC-ID with the KS2000 configuration software.
The Internet Protocol (IP)
The internet protocol (IP) forms the basis of this data communication. IP transports data packets from one device to another; the devices can be in the same network, or in different networks. IP here looks after the address management (finding and assigning MAC-IDs), segmentation and routing. Like the Ethernet protocol, IP does not guarantee that the data is transported - data packets can be lost, or their sequence can be changed.
TCP/IP was developed to provide standardized, reliable data exchange between any numbers of different networks. TCP/IP was developed to provide standardized, reliable data exchange between any numbers of different networks. Although the term is often used as if it were a single concept, a number of protocols are layered together: z. B. IP, TCP, UDP, ARP and ICMP.
Transmission Control Protocol (TCP)
The Transmission Control Protocol (TCP) which runs on top of IP is a connection-oriented transport protocol. It includes error detection and handling mechanisms. Lost telegrams are repeated.
User Datagram Protocol (UDP)
UDP is connectionless transport protocol. It provides no control mechanism when exchanging data between sender and receiver. This results in a higher processing speed than, for example, TCP. Checking whether or not the telegram has arrived must be carried out by the higher-level protocol.
User Datagram Protocol (UDP)
Protocols running on top of TCP/IP and UDP/IP
The following protocols can run on top of TCP/IP or UDP:
▪
ADS
▪
ModbusTCP
Both of these protocols are implemented in parallel on the Bus Coupler, so that no configuration is needed to activate the protocols.
Protocols running on top of TCP/IP and UDP/IP
ADS can be used on top of either TCP or UDP, but ModbusTCP is always based on TCP/IP.


Topology

Fieldbus system [image] Topology
Topology
In 10BaseT and 100BaseT a number of stations are star connected according to the Ethernet standard.
Star topology
The simplest form of a star LAN consists of a single point-to-point connection. All messages pass via a central node (the hub or switch), which then passes the information to the desired device according to the destination address.
Tree topology
A tree topology consists of a number of connected star networks. As soon as the network contains a number of hubs or switches, the topology is classified as a tree. Ideally the connections between the star couplers have a particularly wide bandwidth, since these transport the most traffic. When constructing tree topologies, the repeater rule must be observed. This is also known as the 5-4-3 repeater rule. There must be no more than two pairs of repeaters (or of hubs) in the transmission path between any two stations, unless they are separated by bridges, switches or routers. A transmission path may consist of at most five segments and four repeater sets (two repeater pairs). Up to three of these segments may be coaxial segments to which the stations are connected. The remaining segments must consist of point-to-point connections; these are also known as IRL (inter repeater link) connections.
Cabling guidelines
Structured cabling provides general guidelines for constructing the cabling for a LAN. It specifies maximum permitted cable lengths for the wiring within the grounds, building or floor. Standardized in EN 50173, ISO 11801 and TIA 568-A, structured cabling provides the basis for an advanced, application-independent and economical network infrastructure. The wiring standards are applicable to a range defined as having a geographical extent of up to 3 km and an office area of up to one million sq meters, with between 50 and 50,000 end devices. Recommendations for the structure of a cabling system are also given. The figures can vary, depending on the topology selected, the transmission media and coupling modules used under industrial conditions, and on the use of components from various manufacturers in one network. The given figures should therefore only be considered as recommendations.


Error handling and diagnosis

Error handling and diagnosis
Error handling and diagnosis
Additional information
•
Diagnostic LEDs
•
Diagnostic word


Diagnostic LEDs

Error handling and diagnosis [image] Diagnostic LEDs
Diagnostic LEDs
After switching on, the Bus Coupler immediately checks the connected configuration. Error-free start-up is indicated when the red I/O ERR LED goes out. If the I/O ERR LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.
The Bus Coupler has two groups of LEDs for the display of status. The upper group with four LEDs indicates the status of the respective fieldbus. The significance of the fieldbus status LEDs is explained in the appropriate sections of this manual. It corresponds to the usual fieldbus display.
On the upper right hand side of the Bus Couplers are two more green LEDs that indicate the supply voltage. The left hand LED indicates the presence of the 24 V supply for the Bus Coupler. The right hand LED indicates the presence of the supply to the power contacts.
LEDs of Bus Couplers BK9053 and BK9103
LEDs for power supply diagnostics
LED | Meaning
LED Us | off | the power supply voltage, Us, is not present
 | on | the power supply voltage, Us, is present
LED Up | off | Supply voltage Up (for power contacts) not available
 | on | Supply voltage Up (for power contacts) available
LEDs at RJ45
LED | Meaning
LED Link/Act | off | No physical connection present
 | on | Physical connection present
 | flashing | Communication available
LED 10/100 Mbaud (only BK9103) | off | 10 Mbaud (if LED Link/Act is lit or flashes)
 | on | 100 Mbaud
LEDs for PROFINET diagnostics
PROFINET diagnosis | PN Err (red) | PN Run (green) | DIAG E (red) | DIAG R (green)
IP Address OK | off | 0,5 s | x | x
No IP valid Address (Dip Switch 9,10 -> on) | 0,1 sec | off | x | x
Online | off | on | x | x
Offline PLC Stop | off | 0,1 s | x | x
TimeOut | 0,5 s | off | x | x
IP address configuration fault | on | off | x | x
Alternate flashing (triggered by a Profinet tool) | 0.5 sec | 0.5 sec | x | x
Configuration Diagnose | PN Err (red) | PN Run (green) | DIAG E (red) | DIAG R (green)
OK | x | x | off | on
Wrong module | x | x | Slot number | 1
Missing module (physical) | x | x | Slot number | 2
Missing module (in the configuration) | x | x | Slot number | 3
No PROFINET name assigned | x | x | 0 | 4
Substitute | x | x | Slot number | 5
x: The status of the LED is not relevant for this diagnosis.
Note:
▪
In the event of several errors the last faulty module is displayed.
▪
Substitute is set for incorrectly configured modules that are nevertheless executable (example: KL2xx2 was configured but KL2xx4 was inserted in the slot)
Sample
You have configured a KL2xx4 for the fifth slot, but in fact only four modules are inserted.
▪
Start Error Code: Red DIAG E LED flickers rapidly, green DIAG R LED is off
▪
Red DIAG E LED is on, green LED shows the error code and flashes twice (0.5 sec)
▪
Red and green LED off
▪
Red DIAG E LED shows the error argument and flashes 5 times (0.5 sec, in this case the slot number), green LED is off
Example for Error Code and Error Argument
LEDs for K-bus diagnostics
Error code
Error code argument
Description
Remedy
Persistent, continuous flashing
EMC problems
▪
Check power supply for undervoltage or overvoltage peaks
▪
Implement EMC measures
▪
If a K-bus error is present, it can be localized by a restart of the coupler (by switching it off and then on again)
1 pulse
0
EEPROM checksum error
Set manufacturer's settings with the KS2000 configuration software
1
Code buffer overflow
Insert fewer Bus Terminals. Too many entries in the table for the programmed configuration
2
Unknown data type
Software update required for the Bus Coupler
2 pulses
0
Programmed configuration has an incorrect table entry
Check programmed configuration for correctness
n (n > 0)
Table comparison (Bus Terminal n)
Incorrect table entry
3 pulses
0
K-bus command error
▪
No Bus Terminal inserted
▪
One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses
0
K-bus data error, break behind the Bus Coupler
Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
n
Break behind Bus Terminal n
Check whether the bus end terminal 9010 is connected.
5 pulses
n
K-bus error in register communication with Bus Terminal n
Exchange the nth bus terminal
6 pulses
0
Error at initialization
Exchange Bus Coupler
1
Internal data error
Perform a hardware reset on the Bus Coupler (switch off and on again)
4
DIP switch incorrect for BootP
Set 1-8 to on or off, see BootP
8
Internal data error
Perform a hardware reset on the Bus Coupler (switch off and on again)
16
Error in IP socket
Perform a hardware reset on the Bus Coupler (switch off and on again)
14 pulses
n
nth Bus Terminal has the wrong format
Start the Bus Coupler again, and if the error occurs again then exchange the Bus Terminal
15 pulses
n
Number of Bus Terminals is no longer correct
Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software
16 pulses
n
Length of the K-bus data is no longer correct
Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software


Diagnostic word

Error handling and diagnosis [image] Diagnostic word
Diagnostic word
If GSDML version 2.1 or higher is integrated in the configurator, a status and control DWord (double word) is integrated in the DAP. Additional functions can be used here:
▪
Measurement of the K-bus cycle time
▪
K-bus cycle counter (is incremented after each K-bus cycle)
▪
K-bus error, error code and error argument (see K-bus diagnostic LEDs)
▪
K-Bus reset
▪
Bus Coupler reset
Status DWord (input word of the PLC)
The status DWord shows diagnostic information.
Bit | 31-24 | 23-16 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | K-bus error argument | K-bus error code | K-bus counter or K-bus cycle time |  |  |  |  |  |  |  | - | S | - | - | L2 | - | R1 | K1
Legend
K1: 0 -> 1 rising flag K-bus reset
R1: 1 ->0 falling flag reboot Bus Coupler
L2: "1" K-bus stop on PROFINET error or PLC stop
S: "0" K-bus counter
"1" K-bus cycle time in 0.1 ms
Control DWord (output word of the PLC)
The respective functions can be enabled in the control DWord.
Bit | 31-24 | 23-16 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | - | - | - |  |  |  |  |  |  |  | - | S | - | - | L2 | - | R1 | K1
Control DWord (output word of the PLC)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Bibliography
•
List of Abbreviations
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
The following conditions must be met in order to ensure flawless operation of the fieldbus components.
Environmental conditions
Operation
The components may not be used without additional protection in the following locations:
▪
in difficult environments, such as where there are corrosive vapors or gases, or high dust levels
▪
in the presence of high levels of ionizing radiation
Condition | Permissible range
Permissible ambient temperature during operation | see technical data
Installation position | variable
Vibration resistance | According to EN 60068-2-6
Shock resistance | According to EN 60068-2-27
EMC resistance | According to EN 61000-6-2
Emission | According to EN 61000-6-4
Transport and storage
Condition | Permissible range
Permissible ambient temperature during storage | -25 °C... +85 °C
Relative humidity | 95 %, no condensation
Free fall | up to 1 m in the original packaging
Protection classes and types
Condition | Permissible range
Protection class in accordance with IEC 536 (VDE 0106, Part 1) | A protective conductor connection to the mounting rail is necessary!
Protection class conforms to IEC 529 | IP20 (protection against contact with a standard test finger)
Protection against foreign objects | Less than 12 mm in diameter
Protection against water | no protection
Component identification
Every supplied component includes an adhesive label providing information about the product's approvals. For example, on the BK2000:
Sticker with information about the BK2000 Bus Coupler certification
The following information is printed on the label:
Printed item | Meaning for this label
Precise product identification | Lightbus Coupler BK2000
Supply voltage | 24 VDC
Data transfer rate | 2.5 Mbit/s
Manufacturer | Beckhoff Automation GmbH
CE mark | Conformity mark
UL mark | Mark for UL approval. UL stands for the Underwriters Laboratories Inc., the leading certification Organisation for North America, based in the USA. C = Canada, US = USA, LISTED 22ZA (the test results can be inspected under this entry)
Production identification | From left to right, this sequence of characters indicates the week of production (2 characters), the year of production (2 characters), the software version (2 characters) and hardware version (2 characters), along with any special indications (4 characters). This case therefore is a BK2000 - produced in the 9th calendar week - in the year 2001 - containing the BF firmware version - and using the 6th hardware version - with no special indications


Bibliography

Appendix [image] Bibliography
Bibliography
TCP/IP
TCP/IP (German)
Aufbau und Betrieb eines TCP/IP Netzes (Structure and Operation of a TCP/IP Network)
by Kevin Washburn and Jim Evans
Publisher: ADDISON-WESLEY Longmann Verlag
TCP/IP (English)
Illustrated, Volume1 The Protocols
by W. Richard Stevens
Publisher: ADDISON-WESLEY Longmann Verlag
Modbus/TCP
http://www.modicon.com/
http://www.modbus.org
TwinCAT
BECKHOFF Information System
http://infosys.beckhoff.com


List of Abbreviations

Appendix [image] List of Abbreviations
List of Abbreviations
ADS
Automation Device Specification
IP (20)
Bus Terminal protection class
IPC
Industrial PC
I/O
Inputs and outputs
K-bus
Terminal bus
KS2000
Configuration software for Bus Terminals, Bus Couplers, Bus Terminal Controllers, fieldbus box modules, etc.
PE
The PE power contact can be used as a protective earth.
TwinCAT
The Windows Control and Automation Technology


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com