BK9000, BK9050, BK9100 - Bus Coupler for Ethernet
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Beckhoff Identification Code (BIC)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
4.4.0
▪
Update Technical data
4.3.0
▪
Update Technical data
▪
Chapter “Beckhoff Identification Code (BIC)” added
4.2.0
▪
update technical data
▪
Design of the safety instructions adapted to IEC 82079-1
▪
Update chapter Installation on mounting rails
▪
ATEX notes added
▪
Corrections
4.1.0
▪
extended temperature range for BK9000 and BK9100
4.0.0
▪
Migration
▪
Update structure
3.9.0
▪
Description of the BK9050 added
3.8.2
▪
Description of the BK9100 added
▪
Description of the Modbus-TCP function corrected
3.8.1
▪
Description of the RT-Ethernet added
Firmware and hardware versions
Documentation Version | BK9000 |  | BK9100 |  | BK9050
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
4.2.0 | BD | 18 | B6 | 10 | B3 | 06
4.0.0 | BD | 18 | B6 | 10 | B3 | 04
3.9.0 | BC | 12 | B1 | 03 | B0 | 00
3.8.2 | BA | 11 | B1 | 00 | - | -
3.8.1 | B8 | 10 | - | - | - | -
3.8 | B8 | 10 | - | - | - | -
You can determine which firmware was fitted when the Bus Coupler left the factory from the adhesive label underneath (see the fifth and sixth figures of the production number).
Sample:
3200B2020000
The firmware in the example is B2.
The KS2000 configuration software and the corresponding serial cable included with, is required for updating your firmware. You can also update your coupler using the System Manager from TwinCAT version 2.8 (in the case of the BK9000 only from firmware version B6). You will find the firmware under www.beckhoff.de.
Notes on the firmware versions
BK9000
Firmware
Description
BD
▪
Modbus/TCP: protocol extended
BC
▪
Start-up improved
BB
▪
Link detection changed
BA
▪
Supports TwinSAFE terminals (KL1904, KL2904 and KL6904)
B8
▪
In the event of watchdog errors the analog outputs are now set to zero
▪
RT-Ethernet implemented
B7
▪
Error in the B6 version related to mapping the KL60xx Bus Terminals corrected
B6
▪
Internal software reset modified (this does not have any effects that concern the user)
B5
▪
Fast ModbusTCP implemented
B4
▪
Settings such as the IP address are retained during a firmware update
B3
▪
Firmware update over Ethernet possible
▪
Reading out the configuration with the System Manager (as from TwinCAT 2.8) possible
▪
ADS access control through table 2 implemented
B2
▪
Addressing via ARP, DHCP and BootP possible
▪
Access to process inputs with FC3 ModbusTCP implemented
B1
▪
Watchdog LED triggered under ModbusTCP
B0
▪
First released version
BK9050
Firmware
Description
B3
▪
Modbus/TCP: protocol extended
B2
▪
K-bus reset via ADS implemented (ADS control)
B1
▪
IP address was not secured after addressing via "ARP"
B0
▪
First released version
BK9100
Firmware
Description
B6
▪
Modbus watchdog can be written again (error in FW B5)
B2-B5
▪
Internet changes
B1
▪
Supports TwinSAFE terminals (KL1904, KL2904 and KL6904)
B0
▪
First released version


Beckhoff Identification Code (BIC)

Foreword [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
BK9000, BK9050 – Introduction
•
BK9100 - introduction
•
Technical data
•
The Beckhoff Bus Terminal system
•
The principle of the Bus Terminal
•
Ethernet


BK9000, BK9050 – Introduction

Product overview [image] BK9000, BK9050 – Introduction
BK9000, BK9050 – Introduction
BK9000, BK9050
The BK9000 and BK9050 Bus Couplers connect Ethernet with the modular, extendable electronic terminal blocks. One unit consists of one Bus Coupler, any number from 1 to 64 terminals and one end terminal. The "Compact" BK9050 Bus Coupler is a cost-optimized version with compact housing. With the K-bus extension, up to 255 Bus Terminals can be connected.
The Bus Couplers recognize the terminals to which they are connected, and perform the assignment of the inputs and outputs to the words of the process image automatically. The BK9000 and BK9050 Bus Couplers support 10 Mbit/s and 100 Mbit/s Ethernet. Connection is through normal RJ 45 connectors. The IP address is set on the DIP switch (offset to a freely selectable start address). In networks with DHCP (a service for the allocation of the logical IP address to the physical node address (MAC-ID)) the Bus Coupler obtains its IP address from the DHCP server.
The BK9000 and BK9050 Bus Couplers support ADS TwinCAT system communication. TwinCAT I/O makes available configuration tools and Windows-NT//2000/XP drivers for programs in any desired high-level language (DLLs) and for Visual Basic applications (ActiveX). Applications with OPC interfaces can access ADS (and therefore the BK9000 or BK9050) via an OPC server. In addition to ADS the Bus Coupler supports Open Modbus (Modbus TCP), a simple master/slave protocol based on TCP/IP in wide application.
Complex signal processing for analog I/Os, displacement measurement, etc.
The BK9000 and BK9050 Bus Couplers support the operation of all Bus Terminal types. As far as the user is concerned, the inputs and outputs are not handled any differently from the way they are with other coupler series. The information is made available for use as a byte array in the process image of the automation device.
The KS2000 configuration software allows the analog and multifunctional Bus Terminals to be adapted to the specific application. Depending on the type, the registers of the analog Bus Terminals contain temperature ranges, gain factors and linearization characteristic curves, which are parameterized via the PC using the KS2000. The Bus Terminal stores the setting permanently, even if the voltage supply fails.
Having the controller (PLC, IPC) carry out the configuration of the Bus Terminals is a further option. The PLC or IPC uses function blocks (FB) to take care of the configuration of all the peripherals during the start-up phase. The controller can, if required, upload the non-centrally generated configuration data in order to manage and store them centrally. The replacement of a Bus Terminal does not necessitate new settings. The controller carries out the desired setting automatically after switching on.


BK9100 - introduction

Product overview [image] BK9100 - introduction
BK9100 - introduction
BK9100
The BK9100 Bus Coupler connects Ethernet with the modular, extendable electronic terminal blocks. One unit consists of one Bus Coupler, any number from 1 to 64 terminals and one end terminal. The connected terminals are recognized by the Bus Coupler and the assignment of the inputs/outputs to the words in the process image is created automatically. The BK9100 Bus Coupler supports 10 Mbit/s and 100 Mbit/s Ethernet. Connection is through normal RJ 45 connectors. The IP address is set on the DIP switch (offset to a freely selectable start address). In networks with DHCP (a service for the allocation of the logical IP address to the physical node address (MAC-ID)) the Bus Coupler obtains its IP address from the DHCP server.
Unlike the BK9000, the BK9100 has an additional RJ 45 port. Both Ethernet ports operate as 2-channel switches. The I/O stations can thus be configured with a line topology, instead of the classic star topology. In many applications; this significantly reduces the wiring effort and the cabling costs. The maximum distance between two couplers is 100 m. Up to 20 BK9100 Bus Couplers are cascadable, so that a maximum line length of 2 km can be achieved.
The BK9100 support ADS TwinCAT system communication. TwinCAT I/O makes available configuration tools and Windows/2000/XP drivers for programs in any desired high-level language (DLLs) and for Visual Basic applications (ActiveX). Applications with OPC interfaces can access ADS (and therefore the BK9100 or BK9050) via an OPC server. In addition to ADS the Bus Coupler supports Open Modbus (Modbus TCP), a simple master/slave protocol based on TCP/IP in wide application.
Complex signal processing for analog I/Os, displacement measurement, etc.
The BK9100 Bus Coupler supports the operation of all Bus Terminal types. As far as the user is concerned, the inputs and outputs are not handled any differently from the way they are with other coupler series. The information is made available for use as a byte array in the process image of the automation device.
The KS2000 configuration software allows the analog and multifunctional Bus Terminals to be adapted to the specific application. Depending on the type, the registers of the analog Bus Terminals contain temperature ranges, gain factors and linearization characteristic curves, which are parameterized via the PC using the KS2000. The Bus Terminal stores the setting permanently, even if the voltage supply fails.
Having the controller (PLC, IPC) carry out the configuration of the Bus Terminals is a further option. The PLC or IPC uses function blocks (FB) to take care of the configuration of all the peripherals during the start-up phase. The controller can, if required, upload the non-centrally generated configuration data in order to manage and store them centrally. The replacement of a Bus Terminal does not necessitate new settings. The controller carries out the desired setting automatically after switching on.


Technical data

Product overview [image] Technical data
Technical data
Technical data | BK9000 | BK9050 | BK9100
Number of Bus Terminals | 64 | 64 (255 with K-bus extension) | 64
Digital peripheral signals | 512 inputs/outputs | 1020 inputs/outputs | 512 inputs/outputs
Analog peripheral signals | 128 inputs/outputs
Protocols | UDP- ADS, TCP-ADS, RT-Ethernet, ModbusTCP/Fast ModbusTCP
Configuration possibility | Via the KS2000 configuration software or the controller (TwinCAT)
Maximum number of bytes | 512 bytes of input data and 512 bytes of output data
Bus connection | 1 x RJ 45 | 1 x RJ 45 | 2 x RJ 45
Power supply | 24 VDC (-15%/+20%)
Input current | 70 mA + (total K-bus current)/4, 4.500 mA max.
Starting current | approx. 2.5 x continuous current
K-bus power supply up to | 1750 mA
Power contact voltage | maximum 24 VDC
Power contact current load | maximum 10 A
Dielectric strength | 500 V (power contact/supply voltage/Ethernet/fieldbus)
Recommended fuse | ≤ 10 A
Weight | ca. 170 g | ca. 100 g | ca. 170 g
Permissible ambient temperature range during operation | -25°C ... +60°C | 0°C ... +55°C | -25°C ... +60°C
Permissible ambient temperature range during storage | -40°C ... +85°C | -25°C ... +85°C | -40°C ... +85°C
Permissible relative humidity | 95%, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Installation position | variable
Protection class | IP20
Approvals | CE, cULus, ATEX, GL
System data | BK9000 | BK9050 | BK9100
Number of I/O modules | only limited by the IP address space
Number of I/O points | depending on controller
Transmission medium | 4 x 2 twisted pair copper cable; category 3 (10 Mbaud), category 5 (100 Mbaud)
Distance between modules | 100 m
Data transfer rate | 10/100 Mbaud
Topology | star wiring | star wiring | line or star wiring
Cascading | - | - | up to 20 BK9100 or max. line length 2 km


The Beckhoff Bus Terminal system

Product overview [image] The Beckhoff Bus Terminal system
The Beckhoff Bus Terminal system
Up to 256 Bus Terminals, with 1 to 16 I/O channels per signal form
The Bus Terminal system is the universal interface between a fieldbus system and the sensor / actuator level. A unit consists of a Bus Coupler as the head station, and up to 64 electronic series terminals, the last one being an end terminal. Up to 255 Bus Terminals can be connected via the K-bus extension. For each technical signal form, terminals are available with one, two, four or eight I/O channels, which can be mixed as required. All the terminal types have the same mechanical construction, so that difficulties of planning and design are minimized. The height and depth match the dimensions of compact terminal boxes.
Decentralised wiring of each I/O level
Fieldbus technology allows more compact forms of controller to be used. The I/O level does not have to be brought to the controller. The sensors and actuators can be wired decentrally, using minimum cable lengths. The controller can be installed at any location within the plant.
Industrial PCs as controllers
The use of an Industrial PC as the controller means that the operating and observing element can be implemented in the controller's hardware. The controller can therefore be located at an operating panel, in a control room, or at some similar place. The Bus Terminals form the decentralised input/output level of the controller in the control cabinet and the subsidiary terminal boxes. The power sector of the plant is also controlled over the bus system in addition to the sensor/actuator level. The Bus Terminal replaces the conventional series terminal as the wiring level in the control cabinet. The control cabinet can have smaller dimensions.
Bus Couplers for all usual bus systems
The Beckhoff Bus Terminal system unites the advantages of a bus system with the possibilities of the compact series terminal. Bus Terminals can be driven within all the usual bus systems, thus reducing the controller parts count. The Bus Terminals then behave like conventional connections for that bus system. All the performance features of the particular bus system are supported.
Mounting on standardized mounting rails
The installation is standardized thanks to the simple and space-saving mounting on a standardized mounting rail (EN 60715, 35 mm) and the direct wiring of actuators and sensors, without cross connections between the terminals. The consistent labelling scheme also contributes.
The small physical size and the great flexibility of the Bus Terminal system allow it to be used wherever a series terminal is also used. Every type of connection, such as analog, digital, serial or the direct connection of sensors can be implemented.
Modularity
The modular assembly of the terminal strip with Bus Terminals of various functions limits the number of unused channels to a maximum of one per function. The presence of two channels in one terminal is the optimum compromise of unused channels and the cost of each channel. The possibility of electrical isolation through potential feed terminals also helps to keep the number of unused channels low.
Display of the channel state
The integrated LEDs show the state of the channel at a location close to the sensors and actuators.
K-bus
The K-bus is the data path within a terminal strip. The K-bus is led through from the Bus Coupler through all the terminals via six contacts on the terminals' side walls. The end terminal terminates the K-bus. The user does not have to learn anything about the function of the K-bus or about the internal workings of the terminals and the Bus Coupler. Many software tools that can be supplied make project planning, configuration and operation easy.
Potential feed terminals for isolated groups
The operating voltage is passed on to following terminals via three power contacts. You can divide the terminal strip into arbitrary isolated groups by means of potential feed terminals. The potential feed terminals play no part in the control of the terminals, and can be inserted at any locations within the terminal strip.
Up to 64 Bus Terminals can be used in a terminal block, with optional K-bus extension for up to 256 Bus Terminals. This count does include potential feed terminals, but not the end terminal.
Bus Couplers for various fieldbus systems
Various Bus Couplers can be used to couple the electronic terminal strip quickly and easily to different fieldbus systems. It is also possible to convert to another fieldbus system at a later time. The Bus Coupler performs all the monitoring and control tasks that are necessary for operation of the connected Bus Terminals. The operation and configuration of the Bus Terminals is carried out exclusively by the Bus Coupler. Nevertheless, the parameters that have been set are stored in each Bus Terminal, and are retained in the event of voltage drop-out. Fieldbus, K-bus and I/O level are electrically isolated.
If the exchange of data over the fieldbus is prone to errors or fails for a period of time, register contents (such as counter states) are retained, digital outputs are cleared, and analog outputs take a value that can be configured for each output when commissioning. The default setting for analog outputs is 0 V or 0 mA. Digital outputs return in the inactive state. The timeout periods for the Bus Couplers correspond to the usual settings for the fieldbus system. When converting to a different bus system it is necessary to bear in mind the need to change the timeout periods if the bus cycle time is longer.
The interfaces
A Bus Coupler has six different methods of connection. These interfaces are designed as plug connectors and as spring-loaded terminals.


The principle of the Bus Terminal

Product overview [image] The principle of the Bus Terminal
The principle of the Bus Terminal
The principle of the Bus Terminal


Ethernet

Product overview [image] Ethernet
Ethernet
Ethernet was originally developed by DEC, Intel and XEROX (as the "DIX" standard) for passing data between office devices. The term nowadays generally refers to the IEEE 802.3 CSMA/CD specification, published in 1985. Because of the high acceptance around the world this technology is available everywhere and is very economical. This means that it is easy to make connections to existing networks.
There are now a number of quite different transmission media: coaxial cable (10Base5), optical fiber (10BaseF) or twisted pairs (10BaseT) with screen (STP) or without screen (UTP). Using Ethernet, different topologies can be built such as ring, line or star.
Ethernet transmits Ethernet packets from a sender to one or more receivers. This transmission takes place without acknowledgement, and without the repetition of lost packets. To achieve reliable data communication, there are protocols, such as TCP/IP, that can run on top of Ethernet.
Basic principles
The Internet Protocol (IP)
The internet protocol (IP) forms the basis of this data communication. IP transports data packets from one device to another; the devices can be in the same network, or in different networks. IP here looks after the address management (finding and assigning MAC-IDs), segmentation and routing. Like the Ethernet protocol, IP does not guarantee that the data is transported - data packets can be lost, or their sequence can be changed.
TCP/IP was developed to provide standardised, reliable data exchange between any numbers of different networks. TCP/IP was developed to provide standardised, reliable data exchange between any numbers of different networks. Although the term is often used as if it were a single concept, a number of protocols are layered together: e.g. IP, TCP, UDP, ARP and ICMP.
Transmission Control Protocol (TCP)
The Transmission Control Protocol (TCP) which runs on top of IP is a connection-oriented transport protocol. It includes error detection and handling mechanisms. Lost telegrams are repeated.
User Datagram Protocol (UDP)
UDP is connectionless transport protocol. It provides no control mechanism when exchanging data between sender and receiver. This results in a higher processing speed than, for example, TCP. Checking whether or not the telegram has arrived must be carried out by the higher-level protocol.
Internet Control Message Protocol (ICMP)
It is used by end devices, to exchange information about the current status of the internet protocol.
Address Resolution Protocol (ARP)
Performs conversion between the IP addresses and MAC addresses.
BootP
The BootP protocol allows the TCP/IP address to be set or altered, by addressing the network device with its MAC-ID.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Mechanical installation
•
Wiring
•
ATEX


Mechanical installation

Mounting and wiring [image] Mechanical installation
Mechanical installation
Additional information
•
Dimensions
•
Installation on mounting rails


Dimensions

Mounting and wiring [image] Mechanical installation [image] Dimensions
Dimensions
The system of the Beckhoff Bus Terminals is characterized by low physical volume and high modularity. When planning a project it must be assumed that at least one Bus Coupler and a number of Bus Terminals will be used. The dimensions of the Bus Couplers are independent of the fieldbus system.
BK9000, BK9100, BC9000, BC9020, BC9100, BC9120 - dimensions
BK9050, BC9050 - dimensions
The total width in practical cases is composed of the width of the Bus Coupler, the width of the bus terminals in use and the KL9010 Bus End Terminal. Depending on function, the Bus Terminals are 12 or 24 mm wide. The front wiring increases the total height of 68 mm by about 5 to 10 mm, depending on the wire thickness.


Installation on mounting rails

Mounting and wiring [image] Mechanical installation [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
Mounting
The Bus Couplers and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rail according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the fieldbus Coupler. Join the components with slot and key and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Carefully pull the orange-colored lug approximately 1 cm out of the terminal to be disassembled, until it protrudes loosely. The lock with the mounting rail is now released for this terminal, and the terminal can be pulled from the mounting rail without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal away from the mounting rail.
Connections within a Bus Terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the Bus Terminal block. The power contacts are supplied via terminals on the Bus Coupler.
Power contacts
During the design of a Bus Terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx and EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Note
Risk of damage to the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!
Wiring
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire safely and permanently.
Shielding
Analog sensors and actuators should always be connected with shielded, pair-wise twisted cables.


Wiring

Mounting and wiring [image] Wiring
Wiring
Additional information
•
Power supply, potential groups
•
Ethernet connection
•
Ethernet topologies
•
Ethernet cable


Power supply, potential groups

Mounting and wiring [image] Wiring [image] Power supply, potential groups
Power supply, potential groups
Power supply for the Bus Coupler
The Bus Couplers require a 24 VDC supply for their operation. The connection is made by means of the upper spring-loaded terminals labelled 24 V and 0 V. The supply voltage feeds the Bus Coupler electronics and, over the K-Bus/E-Bus, the Bus Terminals. The power supply for the Bus Coupler electronics and that of the K-Bus/E-Bus are electrically separated from the potential of the field level.
Power supply for the power contacts
The bottom six connections with spring-loaded terminals can be used to feed the supply for the peripherals. The spring-loaded terminals are joined in pairs to a power contact. The feed for the power contacts has no connection to the voltage supply for the Bus Coupler. The design of the feed permits voltages of up to 24 V. The assignment in pairs and the electrical connection between feed terminal contacts allows the connection wires to be looped through to various terminal points. The current drawn from the power contacts must not exceed 10 A for long periods. The current carrying capacity between two spring-loaded terminals is identical to that of the connecting wires.
Power contacts
On the right hand face of the Bus Coupler there are three spring contacts for the power contact connections. The spring contacts are hidden in slots so that they cannot be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue and groove guides on the top and bottom of the Bus Coupler and of the Bus Terminals guarantees that the power contacts mate securely.
Configuration interface (not for BK1250, EK1x00)
The standard Bus Couplers have an RS232 interface at the bottom of the front face. The miniature connector can be joined to a PC with the aid of a connecting cable and the KS2000 configuration software. The interface permits the Bus Terminals to be configured, for example adjusting the amplification factors of the analog channels. The interface can also be used to change the assignments of the bus terminal data to the process image in the Bus Coupler. The functionality of the configuration interface can also be reached via the fieldbus using string communication facility.
Electrical isolation
The bus couplers operate by means of three independent potential groups. The supply voltage feeds the K-Bus/E-Bus electronics in the Bus Coupler and the K-Bus/E-Bus itself in an electrically isolated manner. The supply voltage is also used to generate the operating voltage for the fieldbus.
Note: All Bus Terminals are electrically isolated from the K-Bus/E-bus. The K-Bus/E-bus is therefore completely electrically isolated.
Electrical isolation


Ethernet connection

Mounting and wiring [image] Wiring [image] Ethernet connection
Ethernet connection
The connection to Ethernet is made via an RJ45 connector (a Western plug).
RJ45 connector (Western plug)
Cabling
Connection via hub or switch
Ethernet connection via hub or switch
Connect the PC's network card to the hub/switch using a standard Ethernet cable, and connect the hub, again using a standard Ethernet cable, to the Bus Terminal controller. Connection via a switch is done in the same way.
Direct connection between PC with Ethernet card and BC9000
Direct Ethernet connection (crossover cable)
Use a crossover Ethernet cable to connect the PC directly with the Bus Terminal Controller.
Pin assignment of the RJ45 plug
PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | - | reserved
5 | - | reserved
6 | RD - | Receive -
7 | - | reserved
8 | - | reserved


Ethernet topologies

Mounting and wiring [image] Wiring [image] Ethernet topologies
Ethernet topologies
BK9000, BK9050, BC9000, BC9020, BC9050
These Bus Couplers and Bus Terminal controllers have a single Ethernet connection. This can be connected directly to an external switch. This makes it possible to construct the typical Ethernet star topology.
Ethernet layout in star topology
BK9100, BC9100, BC9120, BC9191
These Bus Couplers and Bus Terminal controllers have an internal triple switch with one internal and two external ports. The internal switch enables the simple construction of a linear topology. A maximum of 20 BK9100/BC91x0/BC9191 can be connected in series in a physical line. However the distance between two Ethernet devices may not exceed 100 m. The maximum overall line length is therefore 2 km. No further switches may be included in this line.
Ethernet layout in linear topology
Of course, the construction of a classic star topology is also possible with these Bus Couplers and Bus Terminal controllers.


Ethernet cable

Mounting and wiring [image] Wiring [image] Ethernet cable
Ethernet cable
Transmission standards
10Base5
The transmission medium for 10Base5 consists of a thick coaxial cable ("yellow cable") with a max. transmission speed of 10 Mbaud arranged in a line topology with branches (drops) each of which is connected to one network device. Because all the devices are in this case connected to a common transmission medium, it is inevitable that collisions occur often in 10Base5.
10Base2
10Base2 (Cheaper net) is a further development of 10Base5, and has the advantage that the coaxial cable is cheaper and, being more flexible, is easier to lay. It is possible for several devices to be connected to one 10Base2 cable. It is frequent for branches from a 10Base5 backbone to be implemented in 10Base2.
10BaseT
Describes a twisted pair cable for 10 Mbaud. The network here is constructed as a star. It is no longer the case that every device is attached to the same medium. This means that a broken cable no longer results in failure of the entire network. The use of switches as star couplers enables collisions to be reduced. Using full-duplex connections they can even be entirely avoided.
100BaseT
Twisted pair cable for 100 Mbaud. It is necessary to use a higher cable quality and to employ appropriate hubs or switches in order to achieve the higher data rate.
10BaseF
The 10BaseF standard describes several optical fiber versions.
Short description of the 10BaseT and 100BaseT cable types
Twisted-pair copper cable for star topologies, where the distance between two devices may not exceed 100 meters.
UTP
Unshielded twisted pair
This type of cable belongs to category 3, and is not recommended for use in an industrial environment.
S/UTP
Screened/unshielded twisted pair (screened with copper braid)
Has an overall shield of copper braid to reduce influence of external interference. This cable is recommended for use with Bus Couplers.
FTP
Foiled shielded twisted pair (screened with aluminium foil)
This cable has an outer screen of laminated aluminium and plastic foil.
S/FTP
Screened/foiled-shielded twisted pair (screened with copper braid and aluminium foil)
Has a laminated aluminium screen with a copper braid on top. Such cables can provide up to 70 dB reduction in interference power.
STP
Shielded twisted pair
Describes a cable with an outer screen, without defining the nature of the screen any more closely.
S/STP
Screened/shielded twisted pair (wires are individually screened)
This identification refers to a cable with a screen for each of the two wires as well as an outer shield.
ITP
Industrial Twisted-Pair
The structure is similar to that of S/STP, but, in contrast to S/STP, it has only one pair of conductors.


ATEX

Mounting and wiring [image] ATEX
ATEX
Additional information
•
ATEX - Special conditions (standard temperature range)
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified according to the ATEX directive for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX Documentation

Mounting and wiring [image] ATEX [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Parameterization and commissioning

Parameterization and commissioning
Parameterization and commissioning
Additional information
•
Start-up behaviour of the Bus Coupler
•
Parameterization of the Bus Coupler using DIP switches
•
Network classes
•
IP address


Start-up behaviour of the Bus Coupler

Parameterization and commissioning [image] Start-up behaviour of the Bus Coupler
Start-up behaviour of the Bus Coupler
Immediately after being switched on, the Bus Coupler checks, in the course of a self-test, all the functions of its components and the communication on the K-bus/E-bus. The red I/O LED blinks while this is happening. After completion of the self-test, the Bus Coupler starts to test the attached Bus Terminals (the "Bus Terminal Test"), and reads in the configuration. The Bus Terminal configuration is used to generate an internal structure list, which is not accessible from outside. In case of an error, the Bus Coupler enters the Stop state. Once the start-up has completed without error, the Bus Coupler enters the fieldbus start state.
Start-up behaviour of the Bus Coupler
The Bus Coupler can be made to enter the normal operating state by switching it on again once the fault has been rectified.


Parameterization of the Bus Coupler using DIP switches

Parameterization and commissioning [image] Parameterization of the Bus Coupler using DIP switches
Parameterization of the Bus Coupler using DIP switches
The following parameterizations can be carried out without using configuration software, with the aid of the DIP switches and the end terminal (KL9010).
This paramétrisation mode is only active if only one end terminal (KL9010) is inserted. Otherwise, the normal settings apply.
Restoring the manufacturer's settings
▪
Switch the Bus Coupler off and then append the end terminal (KL9010).
▪
Set all the DIP switches to ON, and switch the Bus Coupler on again.
▪
Once the default parameters have successfully been set, the Error LED lights, and the I/O RUN and I/O ERR LEDs flash alternately.
▪
You can then switch the Bus Coupler off, connect the Bus Terminals, and continue as usual.
Deleting the boot project (BC9000 only)
▪
Switch the Bus Coupler off and then append the end terminal (KL9010).
▪
Set DIP switches 1 to 9 to ON, DIP switch 10 to OFF, and switch the Bus Coupler on again.
▪
Once the boot project has been successfully deleted, the I/O RUN and I/O ERR LEDs flash alternately.
▪
You can then switch the Bus Coupler off, connect the Bus Terminals, and continue as usual.
Setting the Ethernet parameters
▪
Switch the Bus Coupler off and then append the end terminal (KL9010).
▪
Set all the DIP switches to OFF, and switch the Bus Coupler on again.
▪
The I/O RUN and I/O ERR LEDs light steadily.
▪
Make the desired setting in accordance with the following table.
DIP switch | Parameter | Selection | Setting | Comment
1 | Baud rate | 10 MBaud | OFF (0) |
 |  | 100 MBaud | ON (1) | Default
2 | Auto-Baud-Rate | Disable | OFF (0) |
 |  | Enable | ON (1) | Default
3 | Transmission type | Half duplex | OFF (0) |
 |  | Full duplex | ON (1) | Default
▪
To accept the values, set DIP switch 10 to ON.
By flashing the I/O RUN and I/O ERR LEDs the Bus Coupler indicates that it has accepted the parameters.
▪
You can then switch the Bus Coupler off, connect the Bus Terminals, and continue as usual.


Network classes

Parameterization and commissioning [image] Network classes
Network classes
Three different network classes are distinguished. They determine how many address bits are reserved for the network ID and how many for the node number (e.g. for PCs or Bus Couplers). The difference is located in the first three bits of the IP address.
Network class | Number of bits for the network ID | Enables no. of networks | No. of bits for the node address | Enables no. of nodes per network
A | 7 | 126 | 24 | 16 777 214
B | 14 | 16 382 | 16 | 65 536
C | 21 | 2 097 150 | 8 | 254
Unique IP address
An IP address must be unique within the entire connected network!
Network classes
Identical network class
In a communication with another Ethernet devices, the IP address set must have the same network class. Sample: Your PC has the address 172.16.17.55, which means the coupler must have the address 172.16.xxx.xxx (xxx stands for a number between 0 and 255. 0 is usually used by the router/switch and should therefore remain reserved).
In order to see the PC's own address, the command ipconfig can be entered into a DOS window under Windows NT/2000/XP.


IP address

Parameterization and commissioning [image] IP address
IP address
Additional information
•
IP address
•
Configuration with KS2000
•
Setting the IP address using the ARP table
•
Setting the IP Address Using the Beckhoff BootP Server
•
Setting the address using a DHCP server
•
Subnet mask
•
Testing the IP address
•
Reading the MAC-ID


IP address

Parameterization and commissioning [image] IP address [image] IP address
IP address
The IP address can be set using four different procedures, and these will be described in more detail below.
Procedure | Explanation | Necessary components
KS2000 | Addressing using the KS2000 configuration software and DIP switches | KS2000 configuration software and KS2000 cable
ARP | Addressing via the ARP table | PC with network
BootP | Addressing via BootP server | BootP server
DHCP | Addressing via DHCP server | DHCP server


Configuration with KS2000

Parameterization and commissioning [image] IP address [image] Configuration with KS2000
Configuration with KS2000
The KS2000 configuration software (from version 3.2.8) can be used to set the TCP/IP address in a dialog box, or it can be written directly into the registers. DIP switches 9 and 10 (for BK9050 DIP switches 1 and 2 in blue) should both be OFF (0) before switching on.
Table 100
Register | High byte | Low byte
0 | IP-Byte 2 | IP-Byte 1
1 | Not used | IP-Byte 3
Default
Byte | Default value (hex) | Default value (dec)
1 | 0xAC | 172dec
2 | 0x10 | 16dec
3 | 0x11 | 17dez
4 | (DIP switch) | (0 to 255dec)
Sample
BK9000, BK9100, BC9000, BC9100
BK9050
Switch no. | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 (1) | 10 (2) |
Valence | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128 | - | - |
In this example | ON | OFF | OFF | ON | OFF | OFF | ON | ON | OFF | OFF |
Value | 1 | 0 | 0 | 8 | 0 | 0 | 64 | 128 | - | - | Total=201
Software reset
A software reset of the BK9500 is required in order to save changes in the tables of a BK9000. A hardware reset (power on/off) is not sufficient!


Setting the IP address using the ARP table

Parameterization and commissioning [image] IP address [image] Setting the IP address using the ARP table
Setting the IP address using the ARP table
An easy method of modifying the IP address is to set the address using the DOS window. It is, however, only possible to alter addresses within the same network class. The new IP address that has been set remains stored even after the Bus Coupler has been switched off.
Procedure
▪
Set DIP switches 9 and 10 to OFF. DIP switches 1-8 then no longer have any address function.
▪
Open a DOS box on your PC.
▪
Enter the command "ping <OLD IP address>" to create an entry in the ARP table.
▪
Read the table with the command "ARP -a".
▪
Enter "ARP -d <OLD IP address>" to remove the Bus Coupler from the table.
▪
Use "ARP -s <NEW IP address> <MAC-ID>" to make an entry manually.
▪
With "ping -l 123 <NEW IP address>" the new IP address becomes valid.
A short flash from the ERROR LED at the moment of switching on indicates that the Bus Coupler is being addressed by ARP, and that DIP switches 1-8 give no indication of the address that is set.
Changing the IP address
If the IP address is changed, all dynamic ARP entries must be deleted. Only one ping with a length of 123 bytes is permitted for the reconfiguration of the IP address (>ping -l "IP-Address<).
Sample
1.
C:>ping 172.16.17.255
2.
C:>ARP -a
172.16.17.255 00-01-05-00-11-22
3.
C:>arp -d 172.16.17.255
4.
C:>arp -s 172.16.44.44 00-01-05-00-11-22
5.
C:>ping -l 123 172.16.44.44


Setting the IP Address Using the Beckhoff BootP Server

Parameterization and commissioning [image] IP address [image] Setting the IP Address Using the Beckhoff BootP Server
Setting the IP Address Using the Beckhoff BootP Server
If the address is to be set by the Beckhoff BootP server, then set DIP switch 9 to ON (1) and DIP switch 10 to OFF (0). DIP switches 1-8 then no longer have any address function. If this is not the case, the Bus Coupler reports LED error code 6-4 (see diagnostics LEDs). The TCP/IP ERROR LED flashes while the address is being allocated.
IP address save modes
DIP switches 1-8 in the ON position
The address assigned by the BootP server is stored, and the BootP service will not be restarted after the next cold start.
The address can be cleared again by reactivating the manufacturers' settings (using the KS2000 software or by DIP switch and end terminal).
DIP switches 1-8 in the OFF position
The IP address assigned by the BootP server is only valid until the Bus Coupler is switched off. The BootP server must assign a new IP address to the Bus Coupler at the next cold start.
The address is, however, retained through a software reset of the Bus Coupler.
Beckhoff BootP server
Beckhoff supply a BootP server for Windows 98, ME, NT4.0, NT2000 and XP. The installation version of the Beckhoff TwinCAT CD can be found under the folder >Unsupported Utilities< or under https://download.beckhoff.com/download/software/TwinCAT/TwinCAT2/Unsupported_Utilities/TcBootP_Server/
Configuration of the Beckhoff BootP server
As soon as the BootP server has started, the New MAC Address window shows all the Beckhoff nodes that are working in BootP mode and still have not received an IP address. The assignment of the MAC-ID to IP address is made with the "<<" button. Successful assignment is displayed in the log window.
To start the BootP server automatically when your PC boots, it is only necessary to provide a shortcut in the Windows autostart folder. Include the /Start parameter in the shortcut (.../TcBootPDlg.exe/start).


Setting the address using a DHCP server

Parameterization and commissioning [image] IP address [image] Setting the address using a DHCP server
Setting the address using a DHCP server
To set the address by means of a DHCP server, set DIP switch 9 to OFF (0) and DIP switch 10 to ON (1).
In this state the DHCP service is switched on, and the Bus Coupler is assigned an IP address by the DHCP server.
The DHCP server must know the MAC ID of the Bus Coupler and should assign the same IP address to this MAC ID on each startup.
The TCP/IP error LED flashes while the address is being allocated.


Subnet mask

Parameterization and commissioning [image] IP address [image] Subnet mask
Subnet mask
The subnet mask is subject to the control of the network administrator, and specifies the structure of the subnet.
Small networks without a router do not require a subnet mask. The same is true if you do not use registered IP numbers. A subnet mask can be used to subdivide the network with the aid of the mask instead of using a large number of network numbers.
The subnet mask is a 32-bit number:
▪
Ones in the mask indicate the subnet part of an address space.
▪
Zeros indicate that part of the address space which is available for the host IDs.
Description | Binary representation | Decimal representation
IP address | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnet mask | 11111111.11111111.00010100.00000000 | 255.255.20.0
Network ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host ID | 00000000.00000000.00000001.11001000 | 0.0.1.200
Standard subnet mask
Address class | Standard subnet mask (decimal) | Standard subnet mask (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00
Subnets and host number
Neither subnet 0 nor the subnet consisting only of ones may be used. Neither host number 0 nor the host number consisting only of ones may be used!
If the IP address is set using the KS2000 configuration software, it is necessary for the subnet mask also to be changed with the KS2000 configuration software.
If ARP addressing is used, the associated standard subnet mask, based on the IP address, is entered.
Under BootP or DHCP the subnet mask is transmitted also by the server.


Testing the IP address

Parameterization and commissioning [image] IP address [image] Testing the IP address
Testing the IP address
To test the IP address you can use the Ping command in a Windows prompt.
Testing the IP address using the Ping command


Reading the MAC-ID

Parameterization and commissioning [image] IP address [image] Reading the MAC-ID
Reading the MAC-ID
Proceed as follows to read the MAC-ID.
▪
Change the IP address of your PC to 172.16.x.x. and the subnet mask to 255.255.0.0
In the delivery condition of the BC9000 or BK9000, the IP address is 172.16.17.255 (DIP switches 1 to 8 set to ON).
▪
Start the DOS window
▪
Send a ping >ip-address< to the IP address 172.16.17.255
▪
Read the MAC-ID with arp -a.


Configuration

Configuration
Configuration
Additional information
•
ModbusTCP
•
Mapping the Bus Terminals
•
TwinCAT System Manager


ModbusTCP

Configuration [image] ModbusTCP
ModbusTCP
Additional information
•
ModbusTCP Process Image


ModbusTCP Process Image

Configuration [image] ModbusTCP [image] ModbusTCP Process Image
ModbusTCP Process Image
The ModbusTCP process image makes a fundamental distinction between digital and byte-oriented and word-oriented signals (Bus Terminals). Additionally, a distinction is made between inputs and outputs. The mapping table shows which Bus Terminals belong to which mapping.
Digital inputs | Digital outputs
Offset 0 ... 4095 Modbus function Reading 2 Writing: - | Offset 0 ... 4095 Modbus function Reading 1 Writing 5, 15
Analog/digital inputs | Analog/digital outputs
Offset 0x000 ... 0x0FF Modbus function Reading 3, 23 Writing: - | Offset 0x800 ... 0x8FF Modbus function Reading 3, 4, 23 Reading 3, 4, 23
This will be clarified by examples.
Sample 1
1 x BK9000
4 x KL1xx4
2 x KL2xx2
1 x KL9010
Inputs |  |  | Outputs
Modbus function | Modbus address/offset | Bus Terminal | Modbus function | Modbus address/offset | Bus Terminal
3 read | 0x0000 | 4 x KL1xx4 | 3 read | 0x0800 | 2 x KL2xx2
4 read | 0x0000 |  | 1 read | 0x0000
2 read | 0x0000 - 0x000F |  | 5 write | 0x0000-0x0003
 |  |  | 15 write | 0x0000-0x0003
 |  |  | 6 write | 0x800
 |  |  | 16 write | 0x800
 |  |  | 23 write | 0x800
Sample 2
1 x BK9000
4 x KL1xx4
2 x KL2xx2
1 x KL1501
1 x KL3xx2
1 x KL4xx2
1 x KL9010
Inputs |  |  | Outputs
Modbus function | Modbus address/offset | Bus Terminal | Modbus function | Modbus address/offset | Bus Terminal
3, 4 read | 0x0000..0002 | KL1501 | 3 read | 0x0800..0802 | KL1501
 |  |  | 6, 16 write | 0x0800..0802
3, 4 read | 0x0003..0x0006 | KL3xx2 | 3 read | 0x0803..0x0806 | KL3xx2
 |  |  | 6, 16 write | 0x0803..0x0806
3, 4 read | 0x0007..0x000A | KL4xx2 | 3 read | 0x0807..0x080A | KL4xx2
 |  |  | 6, 16 write | 0x0807..0x080A
3 read | 0x000B | 4 x KL1xx4 | 3 read | 0x080B | 2 x KL2xx2
 |  |  | 4 read | 0x080B
4 read | 0x000B |  | 1 read | 0x0000-0x0003
2 read | 0x0000 - 0x000F |  | 5 write | 0x0000-0x0003
 |  |  | 15 write | 0x0000-0x0003
 |  |  | 6 write | 0x80B
 |  |  | 16 write | 0x80B
 |  |  | 23 write | 0x80B


Mapping the Bus Terminals

Configuration [image] Mapping the Bus Terminals
Mapping the Bus Terminals
The precise assignment of the byte-oriented Bus Terminals may be found in the configuration guide for the particular bus terminal. This documentation is available on the Beckhoff Products & Solutions CD or on the Internet under http://www.beckhoff.de.
Byte oriented Bus Terminals | Bit oriented Bus Terminals
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


TwinCAT System Manager

Configuration [image] TwinCAT System Manager
TwinCAT System Manager
Additional information
•
Configuration using the System Manager
•
ADS Process Image
•
The IP Address tab


Configuration using the System Manager

Configuration [image] TwinCAT System Manager [image] Configuration using the System Manager
Configuration using the System Manager
Enter a general Ethernet card in the TwinCAT System Manager under devices. If the Bus Couplers are already connected to the network and have IP addresses, you can also read these. This will cause all the Bus Couplers with Bus Terminals and their configurations to be loaded. You can then adapt these to meet your requirements.
Reading the connected Bus Couplers and Bus Terminals
Commissioning with 6 or more Ethernet nodes
If you enter more than five nodes in the System Manager, you will have to increase the router memory. You will find this setting in the System Manager under Real Time Settings. Enter 350 kB there for each Bus Coupler. This will give, for instance, 3.5 MB (10 x 350 kB) for 10 Bus Couplers.
Setting the router memory
Note: The router memory depends on your PC's main memory, and there is a limit to how high it can be set.
Calculation of the maximum possible router memory:
max. router memory [MB] = (1 MB +((RAM [MB] - 4 MB ) x 0.4)
Sample
Suppose your PC has 128 MB of RAM:
1 MB +(128 MB - 4 MB) x 0.4 = 50.6 MB
So the maximum size of the router memory must not exceed 50.6 MB if there is 128 MB of RAM.


ADS Process Image

Configuration [image] TwinCAT System Manager [image] ADS Process Image
ADS Process Image
The process image of the Bus Terminals is sub-divided into input image and output image. The Bus Coupler first maps all complex (byte-oriented) Bus Terminals into the process image in the order in which they are inserted, and only at the end attaches the digital Bus Terminals to the process image.
The complex (byte-oriented) Bus Terminals are mapped as follows:
▪
Complete evaluation
▪
Word alignment
▪
Intel format
Sample 1
BK9000
4 x KL1xx4
2 x KL2xx2
1 x KL9010
Pos. | Bus Terminal | Input %I.. | Output %Q..
1 | KL1xx4 | 0.0 ... 0.3 | -
2 | KL1xx4 | 0.4 ... 0.7 | -
3 | KL1xx4 | 1.0 ... 1.3 | -
4 | KL1xx4 | 1.4 ... 1.7 | -
5 | KL2xx2 | - | 0.0 ... 0.1
6 | KL2xx2 | - | 0.2 ... 0.3
9 | KL6010 | - | -
Sample 2
BK9000
4 x KL1xx4
2 x KL2xx2
1 x KL1501
1 x KL3xx2
1 x KL4xx2
1 x KL9010
Pos. | Bus Terminal | Input %I.. | Output %Q..
1 | KL1501 | 0..5 | 0..5
2 | KL3xx2 | 6..13 | 6..13
3 | KL4xx2 | 14..21 | 14..21
4 | KL1xx4 | 22.0..22.3 | -
5 | KL1xx4 | 22.4..22.7 | -
6 | KL1xx4 | 23.0..23.3 | -
7 | KL1xx4 | 23.4..23.7 | -
8 | KL2xx2 | - | 22.0...22.1
9 | KL2xx2 | - | 22.2...22.3
10 | KL6010 | - | -


The IP Address tab

Configuration [image] TwinCAT System Manager [image] The IP Address tab
The IP Address tab
Ethernet components require an unambiguous IP address in the network. The setting dialog necessary for configuration of the fieldbus nodes in the TwinCAT system is described below. The tab illustrated appears after you have selected a BK9000, BC9000 or other Ethernet fieldbus device with the right mouse button (Add box) under your Ethernet cards in the System Manager.
The IP Address tab
Host name
The name of the Bus Coupler station can be edited here.
IP address
Enter the IP address of the Bus Coupler here.
GetHostByName
By clicking this button you can (as from BK9000 firmware version B2) obtain an IP address from a Windows 2000 DHCP (Dynamic Host Configuration Protocol) server.
AMS Address
Reports the Bus Coupler's AMS Net ID. It is automatically generated from the IP address by adding two additional bytes (e.g. ".1.1").
BootP
This checkbox can be activated if the Beckhoff BootP server has been installed and started (as from TwinCAT Version 2.8).
New MAC Addresses
If the Beckhoff BootP server has been started, the MAC addresses (Media Access Controller) of Ethernet fieldbus devices that have newly been connected can be displayed by clicking this button. If only one new Ethernet fieldbus device has been connected, then only one new MAC address will accordingly be displayed. You can then assign it to the desired IP address in the IP address field described above. Each time another Ethernet fieldbus component is added you can repeat this process on the tab described here for the new device.
Communication Settings
Settings for IP (Internet Protocol) communication.
TCP
If this option is active (which is the default) the communication is handled by TCP (Transmission Control Protocol). This means that telegram packets to and from Bus Couplers are exchanged using a reliable (acknowledged) mechanism.
UDP
If this option is selected, communication is handled by UDP (User Datagram Protocol). In contrast to TCP, the individual telegram packets are not exchanged using a reliable mechanism. They are, in other words, not individually acknowledged by the receiver after they have arrived. Telegram packets that are damaged or whose sequence has become disturbed are neither re-sent nor sorted. The advantage of UDP is that the telegram transfer times can be calculated, because it is not necessary to wait for an answer from the receiver. It is therefore possible to talk of UDP in terms of a limited real-time capability.
Max. Warning Level
This setting option is only active with UDP. The maximum value of the error counter can be entered here. Waiting for response telegrams from the fieldbus node stops when the set maximum value has been reached. Instead, read telegrams only, based on a higher cycle time, are sent to the fieldbus nodes.
No Auto Retries
This checkbox also can only be selected when the UDP option is active. If this checkbox is active, then when the level set under Max. Warning Level has been reached it will be necessary to execute the IO/Reset function. No outputs will be output as long as no reset has been triggered.


Fieldbus system

Fieldbus system
Fieldbus system
Additional information
•
Ethernet
•
Topology
•
Reaction times
•
Real-time Ethernet
•
ADS-Communication
•
ModbusTCP
•
Description of parameters


Ethernet

Fieldbus system [image] Ethernet
Ethernet
Ethernet was originally developed by DEC, Intel and XEROX (as the "DIX" standard) for passing data between office devices. The term nowadays generally refers to the IEEE 802.3 CSMA/CD specification, published in 1985. Because of the high acceptance around the world this technology is available everywhere and is very economical. This means that it is easy to make connections to existing networks.
There are now a number of quite different transmission media: coaxial cable (10Base5), optical fiber (10BaseF) or twisted pairs (10BaseT) with screen (STP) or without screen (UTP). Coaxial cable (10Base5), optical fiber (10BaseF) or twisted pairs (10BaseT) with screen (STP) or without screen (UTP).
Ethernet transmits Ethernet packets from a sender to one or more receivers. This transmission takes place without acknowledgement, and without the repetition of lost packets. To achieve reliable data communication, there are protocols, such as TCP/IP, that can run on top of Ethernet.
MAC-ID
The sender and receiver of Ethernet packets are addressed by means of the MAC-ID. The MAC-ID is a 6 byte identification code unique to every Ethernet device in the world. The MAC-ID consists of two parts. The first part (i.e. the first 3 bytes) is a manufacturer identifier. The identifier for Beckhoff is 00 01 05. The next 3 bytes are assigned by the manufacturer and implement a unique serial number. The MAC-ID can, for example, be used for the BootP protocol in order to set the TCP/IP number. This involves sending a telegram containing the information such as the name or the TCP/IP number to the corresponding node. You can read the MAC-ID with the KS2000 configuration software.
The Internet Protocol (IP)
The internet protocol (IP) forms the basis of this data communication. IP transports data packets from one device to another; the devices can be in the same network, or in different networks. IP here looks after the address management (finding and assigning MAC-IDs), segmentation and routing. Like the Ethernet protocol, IP does not guarantee that the data is transported - data packets can be lost, or their sequence can be changed.
TCP/IP was developed to provide standardized, reliable data exchange between any numbers of different networks. TCP/IP was developed to provide standardized, reliable data exchange between any numbers of different networks. Although the term is often used as if it were a single concept, a number of protocols are layered together: z. B. IP, TCP, UDP, ARP and ICMP.
Transmission Control Protocol (TCP)
The Transmission Control Protocol (TCP) which runs on top of IP is a connection-oriented transport protocol. It includes error detection and handling mechanisms. Lost telegrams are repeated.
User Datagram Protocol (UDP)
UDP is connectionless transport protocol. It provides no control mechanism when exchanging data between sender and receiver. This results in a higher processing speed than, for example, TCP. Checking whether or not the telegram has arrived must be carried out by the higher-level protocol.
User Datagram Protocol (UDP)
Protocols running on top of TCP/IP and UDP/IP
The following protocols can run on top of TCP/IP or UDP:
▪
ADS
▪
ModbusTCP
Both of these protocols are implemented in parallel on the Bus Coupler, so that no configuration is needed to activate the protocols.
Protocols running on top of TCP/IP and UDP/IP
ADS can be used on top of either TCP or UDP, but ModbusTCP is always based on TCP/IP.


Topology

Fieldbus system [image] Topology
Topology
In 10BaseT and 100BaseT a number of stations are star connected according to the Ethernet standard.
Star topology
The simplest form of a star LAN consists of a single point-to-point connection. All messages pass via a central node (the hub or switch), which then passes the information to the desired device according to the destination address.
Tree topology
A tree topology consists of a number of connected star networks. As soon as the network contains a number of hubs or switches, the topology is classified as a tree. Ideally the connections between the star couplers have a particularly wide bandwidth, since these transport the most traffic. When constructing tree topologies, the repeater rule must be observed. This is also known as the 5-4-3 repeater rule. There must be no more than two pairs of repeaters (or of hubs) in the transmission path between any two stations, unless they are separated by bridges, switches or routers. A transmission path may consist of at most five segments and four repeater sets (two repeater pairs). Up to three of these segments may be coaxial segments to which the stations are connected. The remaining segments must consist of point-to-point connections; these are also known as IRL (inter repeater link) connections.
Cabling guidelines
Structured cabling provides general guidelines for constructing the cabling for a LAN. It specifies maximum permitted cable lengths for the wiring within the grounds, building or floor. Standardized in EN 50173, ISO 11801 and TIA 568-A, structured cabling provides the basis for an advanced, application-independent and economical network infrastructure. The wiring standards are applicable to a range defined as having a geographical extent of up to 3 km and an office area of up to one million sq meters, with between 50 and 50,000 end devices. Recommendations for the structure of a cabling system are also given. The figures can vary, depending on the topology selected, the transmission media and coupling modules used under industrial conditions, and on the use of components from various manufacturers in one network. The given figures should therefore only be considered as recommendations.


Reaction times

Fieldbus system [image] Reaction times
Reaction times
BC9000 reaction time
ADS | Time [ms]
TCP | 23 to 50 ms + task time on the BC9000 (jitter)
UDP | 2 to 3 ms + task time on the BC9000 (jitter)
Modbus | Time [ms]
TCP | 12 to 15 ms + task time on the BC9000 (jitter) (default)
Fast TCP* | 1 to 3 ms + task time on the BC9000 (jitter)
* as from firmware B7, Table 100, Register 29 - "1" Fast TCP / "0" TCP (see Modbus Interface)
BK9000 reaction time
ADS | Time [ms]
TCP | 23 to 50 ms
UDP | 2 to 3 ms
RT-Ethernet** | Time [ms]
RAW | < 1 ms + K-bus (depending on the K-bus propagation delay)
Modbus | Time [ms]
TCP | 12 to 15 ms (default)
Fast TCP* | 1 to 3 ms
* as from firmware B5, Table 100 Register 29 - "1" Fast TCP / "0" TCP (see Modbus interface)** from firmware B8


Real-time Ethernet

Fieldbus system [image] Real-time Ethernet
Real-time Ethernet
Additional information
•
Real-time Ethernet with Fast-ADS


Real-time Ethernet with Fast-ADS

Fieldbus system [image] Real-time Ethernet [image] Real-time Ethernet with Fast-ADS
Real-time Ethernet with Fast-ADS
The Fast ADS protocol is based on Ethernet. In combination with TwinCAT, this bus system has real-time capability and reaches cycle times of < 1 ms. The real-time Ethernet driver was developed for Windows 2000, Windows XP and Intel Ethernet chips.
Further information can be found at http://www.pc-control.net/pdf/022002/pcc_ethernet_d.pdf.
BK9000
The Fast-ADS protocol is implemented in addition to the already existing protocols on the BK9000 from firmware version B8. Simultaneous utilization is only possible, if the function ADS was selected in the System Manager (IP address tab). If the NoRealTimeFlag function is not selected, communication can only take place via Fast-ADS.
With Fast-ADS the watchdog is set to 100 ms. If it is triggered (e.g. when TwinCAT stops), all other Ethernet services are usable again. The K-bus works synchronous with the Fast ADS.
B900
RT-Ethernet or Fast-ADS is implemented on all B900 modules. The cycle time of the TwinCAT task must be shorter than 10 ms. Otherwise the process image and thus the outputs of the module and the connected extensions will be reset after 10 ms.
Settings in the System Manager
BK9000 tab
BK9000 tab
No Real Time Flag
TCP/IP or UDP telegrams can also be received if the checkbox is activated. However, the jitter of the real-time telegrams increases!
K-bus reset
A reset is triggered on the K-bus.
Data Exchange
The number of task cycles after which a telegram should be sent to the fieldbus station (Bus Coupler / Fieldbus Box) is determined here.
Modulo specifies the task in which the telegram should be dispatched. This enables the system performance to be optimized.
Sample: Divider 5 and Modulo 3 – a telegram is sent after every 5th task (the third to be specific).
VLAN
Switches that support VLAN (virtual LANs) can prioritize the incoming telegrams with this.
IP address tab
IP address tab
Host Name
The name of the fieldbus station (Bus Coupler / Fieldbus Box) can be edited here.
IP Address
The IP address of the fieldbus station (Bus Coupler / Fieldbus Box) must be entered here.
GetHostByName
Using this button an IP address can be obtained from a DHCP server (Dynamic Host Configuration Protocol Server) (BK9000: from firmware version B2).
Set IP Address
Using this button the IP address is set via ARP.
AMS address
Specifies the AMS-Net ID of the fieldbus station (Bus Coupler / Fieldbus Box). It is generated automatically by appending two additional byte values (".1.1") to the IP address.
BootP
This checkbox can be activated if the Beckhoff BootP server has been installed and started (as from TwinCAT Version 2.8).
New MAC Addresses
If the Beckhoff BootP server has started, the new MAC addresses (Media Access Controller addresses) can be displayed by pressing this button.
The new addresses are displayed in the field under the button.
If only one fieldbus station has been connected, then accordingly only one new MAC address will be displayed.
A desired IP address can then be assigned to this MAC address in the IP Address field described above.
If further fieldbus stations are then connected, you can repeat this procedure on the IP Address tabs for these stations.
Communication Settings
Settings for communication via ADS or RAW.


ADS-Communication

Fieldbus system [image] ADS-Communication
ADS-Communication
Additional information
•
ADS-Communication
•
ADS protocol
•
ADS services
•
AMS routing table


ADS-Communication

Fieldbus system [image] ADS-Communication [image] ADS-Communication
ADS-Communication
The ADS protocol (ADS: Automation Device Specification) is a transport layer within the TwinCAT system. It was developed for data exchange between the different software modules, for instance the communication between the NC and the PLC. This protocol enables communication with other tools from any point within the TwinCAT. If communication with other PCs or devices is required, the ADS protocol can use TCP/IP as a basis. Within a networked system it is thus possible to reach all data from any point.
The ADS protocol as a transport layer within the TwinCAT system
The ADS protocol runs on top of the TCP/IP or UDP/IP protocols. It allows the user within the Beckhoff system to use almost any connecting route to communicate with all the connected devices and to parameterize them. Outside the Beckhoff system a variety of methods are available to exchange data with other software tools.
Software interfaces
ADS-OCX
The ADS-OCX is an Active-X component. It offers a standard interface to, for instance, Visual Basic, Delphi, etc.
ADS-DLL
You can link the ADS-DLL (DLL: Dynamic Link Library) into your C program.
OPC
The OPC interface is a standardised interface for communication used in automation engineering. Beckhoff offer an OPC server for this purpose.


ADS protocol

Fieldbus system [image] ADS-Communication [image] ADS protocol
ADS protocol
The ADS functions provide a method for accessing the Bus Coupler information directly from the PC. ADS function blocks can be used in TwinCAT PLC Control for this. The function blocks are contained in the TcSystem.lib library. It is also equally possible to call the ADS functions from AdsOCX, ADSDLL or OPC. It is possible to access all the data through ADS port number 300, and to access the registers of the Bus Coupler and Bus Terminals through ADS port number 100.
Structure of the ADS protocol
AMSNetID
The AMSNetID provides a reference to the device that is to be addressed. This is created from the set TCP/IP address and an additional 2 bytes. These additional 2 bytes consist of "1.1", and cannot be altered.
Sample:
IP address 172.16.17.128
AMSNetID 172.16.17.128.1.1
Port number
The port number distinguishes sub-elements in the connected device.
Port 100: register access
Port 300: fieldbus process data
Port 800: local process data (BC90x0, C900 only)
Index group
The index group distinguishes different data within a port.
Index offset
Indicates the offset, from which reading or writing the byte is to start.
Len
Gives the length of the data, in bytes, that is to be read or written.
TCP port number
The TCP port number for the ADS protocol is 48898 or 0xBF02.


ADS services

Fieldbus system [image] ADS-Communication [image] ADS services
ADS services
User data of an ADS telegram
The maximum size of the user data in an ADS telegram is 1900 bytes.
Process data port 300
The fieldbus data is accessed via ADS port number 300. The data is monitored by a watchdog. If no further telegram arrives within 1000 ms the outputs will be switched to the safe state.
Index group | Meaning | Index offset (value range)
0xF020 | Inputs | 0...511
0xF030 | Outputs | 0...511
Local process image port 800 (BC9000, C900 only)
Data can be read from and written to the local process image. If it is necessary for outputs to be written, it is important to ensure that they are not used by the local PLC, because the local controller will overwrite these values. The data are not associated with a watchdog, and therefore must not be used for outputs that would have to be switched off in the event of a fault.
Index group | Meaning | Index offset (value range)
0xF020 | Inputs | 0...511
0xF030 | Outputs | 0...511
0x4020 | Flags (BC 9000, C900 only) | 0...4096
ADS services
AdsServerAdsStateB7
Data type (read only) | Meaning
String | Start - the local PLC is running Start - the local PLC is stopped
AdsServerDeviceStateB7
Data type (read only) | Meaning
INT | 0 - Start - the local PLC is running 1 - Stop - the local PLC is stopped
AdsServerTypeB7
Data type (read only) | Meaning
String | Coupler_PLC
ADSWriteControlBA
Data type (write only) | Meaning
NetID | Net ID of the BC9000,C900
Port | 800
ADSSTATE | 5 - RUN / 6 - STOP
DEVSTATE | 0
LEN | 0
SRCADDR | 0
WRITE | rising edge starts the block
TMOUT | example: t#1000 ms
Acyclic data communication
With acyclic data communication it is important to note that about 20 to 30 ms are required in order to establish a TCP/IP connection. Following the successful establishment of a connection the ADS data are sent or read. An ADS read of 1000 bytes takes about 50 ms. If no data are transmitted for 10 seconds, the TCP/IP connection is disconnected from the BC/BK9000, B/C900.
Register port 100
The ADS port number in the BK/BC9000, B/C900 for register communication is fixed, being set at 100.
Index group | Index offset (value range) |  | Meaning
 | Hi-Word | Lo-Word
0 | 0...127 | 0...255 | Registers in the Bus Coupler Hi-Word, table number of the Bus Coupler Lo-Word, register number of the table
1...64 | 0...3 | 1...64 | Register of the Bus Terminals Hi-Word, channel number Lo-Word, register number of the Bus Terminal
Timeout of the ADS function block
When reading the register, the time out of the ADS block has to be set to a time longer than 1 second.
Setting the password
When writing to the registers, the password has to be set (see the documentation for the particular Bus Terminal).
Access control and IP - AMS-Net ID assignmentB6
The AMS Net-Id table permits access control to the BC 9000, C900 via AMS. As soon as this table has entries, only those AMS devices that have been entered will be able to access the BC 9000.
Furthermore, an assignment of the AMS-Net ID to the IP address of the node is explicitly done here.
The AMS Net-Id table can be filled with ADS write commands:
a maximum of 10 entries is possible.
The structure
AMS Net ID | Size
AMS Net ID | 6 byte
IP address | 4 byte
Reserve | 2 byte
Reserve | 4 byte
Reserve | 4 byte
Access takes place via port number: 10,000
Index group: 700
Index Offset (Write) | Comment | Data
0 | Add an entry | Data structure, 20 bytes
1 | Delete an entry | -
2 | Delete all entries | -
10 | Save the table in Flash memory | -
Index Offset (Read) | Comment | Data
0 | Number of entries | 2 byte
1..10 | Entry n (1...10) | Data structure, 20 bytes
First entry
The first entry must be the device that his writing into the table, because the settings have immediate effect. Make sure that all the settings are correct. The table can also be deleted if the end terminal only is inserted, and the DIP switches 1 to 7 are set to ON.
* as from firmware B6
** as from firmware B7
)² as from firmware BA
See the example.


AMS routing table

Fieldbus system [image] ADS-Communication [image] AMS routing table
AMS routing table
The AMS routing table can be used for two functions:
1.
If the AMS Net ID does not match the TCP/IP address, the link between the two non-matching numbers can be entered here.
The AMS Net ID matches the TCP/IP address if the first 4 bytes are identical and the AMS Net ID ends with ".1.1".
2.
Only AMS Net IDs stored in the table can access the BC9000 via ADS.
Please ensure that all ADS devices with which communication is required are entered in the table. If the table is empty (default), all ADS devices can access the BC9000.
Processing the AMS routing table using the KS2000 configuration software
From KS2000 version 4.3.0.39 entries in the AMS routing table can be made via dialog.
Displaying the AMS routing table using the KS2000 configuration software
Entering values in the routing table via ADS
The AMS routing table can be loaded into the BC9000 via ADS. Ensure that the first entry is that of the sender, since this setting becomes effective immediately and may otherwise prevent further entries in the AMS routing table.
Download ( )


ModbusTCP

Fieldbus system [image] ModbusTCP
ModbusTCP
Additional information
•
Examples for ModbusTCP
•
ModbusTCP Protocol
•
Modbus TCP interface
•
ModbusTCP slave error answer (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
•
ModbusTCP functions


Examples for ModbusTCP

Fieldbus system [image] ModbusTCP [image] Examples for ModbusTCP
Examples for ModbusTCP
Examples for Modbus TCP are contained in this help text.
Simple example: Modbus TCP via VB6.0
Download
Sample: ModbusTCP via VB6.0, set and reset of the watchdog:
Download


ModbusTCP Protocol

Fieldbus system [image] ModbusTCP [image] ModbusTCP Protocol
ModbusTCP Protocol
The Ethernet protocol is addressed by means of the MAC-ID. The user does not normally need to be concerned about this address. The IP number has a length of 4 bytes, and must be parameterized by the user on the Bus Coupler and in the application. In ModbusTCP, the TCP port is set to 502. The UNIT can be freely selected under ModbusTCP, and does not have to be configured by the user.
ModbusTCP Protocol
TCP port number
The TCP port number for ModbusTCP has been standardised to 502.
Modbus-Unit
The unit is returned by the slave.
ModbusTCP Protocol
Byte | Name | Description
0 | Transaction identifier | is returned by the slave
1 | Transaction identifier | is returned by the slave
2 | Protocol identifier | always 0
3 | Protocol identifier | always 0
4 | Length field | 0 (if the message is less than 256 bytes in length)
5 | Length field | Number of following bytes
6 | UNIT identifier | returned by the slave
7 | Modbus | Modbus protocol beginning with the function follows


Modbus TCP interface

Fieldbus system [image] ModbusTCP [image] Modbus TCP interface
Modbus TCP interface
Address |  | Description
0x0000 0x00FF |  | Process data interface Inputs
0x0800 0x08FF |  | Process data interface Outputs
0x1000 0x1006 | Read only | Bus Coupler identification
0x100A |  | 2 byte PLC interface
0x100B |  | Bus terminal diagnosis
0x100C |  | Bus Coupler status
0x1010 |  | Process image length in bits, analog outputs (without PLC variables)
0x1011 |  | Process image length in bits, analog inputs (without PLC variables)
0x1012 |  | Process image length in bits, digital outputs
0x1013 |  | Process image length in bits, digital inputs
0x1020 |  | Watchdog, current time in [ms]
0x110A | Read / Write | 2 byte PLC interface
0x110B |  | Bus terminal diagnosis
0x1120 |  | Watchdog, pre-defined time in [ms] (Default value: 1000)
0x1121 |  | Watchdog reset register
0x1122 |  | Type of watchdog | 1 | Telegram watchdog (default)
 |  |  | 0 | Write telegram watchdog
0x1123** |  | ModbusTCP mode** | 1 | Fast Modbus
 |  |  | 0 | Normal Modbus (default)
0x4000* 0x47FF |  | Flags area (%MB..)*
* all Bus Terminal controllers BC9xx0 and BX9000
** for BC9x00 from firmware B7 and BK9000 from firmware B5 and all unlisted BK9xxx and BC/BX9xxx
Watchdog
The watchdog is active under the factory settings. After the first write telegram the watchdog timer is initiated, and is triggered each time a telegram is received from this device. Other devices have no effect on the watchdog. A second approach, which represents a more sensitive condition for the watchdog, is for the watchdog only to be re-triggered after each write telegram. To do this, write a zero into register 0x1122 (default value "1").
The watchdog can be deactivated by writing a zero to offset 0x1120. The watchdog register can only be written if the watchdog is not active. The data in this register is retained.
Watchdog register
If the watchdog timer on your slave has elapsed it can be reset by writing twice to register 0x1121. The following must be written to the register: 0xBECF 0xAFFE. This can be done either with function 6 or with function 16.
The Bus Coupler's status register
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | FB | - | - | - | - | - | - | - | - | - | - | - | - | - | CNF | KB
Legend
Bit | Name | Value | Description
15 | FB | 1bin | Fieldbus error, watchdog time elapsed
14...2 | - | - | reserved
1 | CNF | 1bin | Bus Coupler configuration error
0 | KB | 1bin | Bus Terminal error
ModbusTCP mode
The fast Modbus mode should only be used in small local networks. The fast ModbusTCP is not active under the default settings. If problems are found to occur with this type of communication, the Bus Coupler should be switched to "normal" ModbusTCP communication. The mode is set in the Modbus interface, offset 0x1123. It is necessary to reset the coupler (e.g. using ModbusTCP function 8) after the change. It is not permitted to send more than one Modbus service within one Ethernet frame in fast Modbus mode.
2 byte PLC interface
Registers in the complex terminals and Bus Terminal Controller registers can be both read and written using the 2 byte PLC interface. The complex terminal registers are described in the associated terminal documentation. The Bus Coupler registers can be used, for example, to read terminal bus diagnostics data, the terminal composition or the cycle times, and the programmed configuration can be written. It is also possible for a manual K-bus reset to be carried out. The 2-byte PLC interface requires two bytes each of input and output data. They are handled using a special protocol. A description of the 2 byte PLC interface, the registers available in the Bus Couplers and of function blocks for various PLC systems that support the 2 byte PLC interface can be supplied on request.
2 byte diagnostic interface
The terminals' error messages can be sent over the 2-byte diagnostic interface. K-bus diagnostics must however be activated for this purpose. The 2-byte diagnostic interface occupies two bytes each of input and output data. A special protocol is processed via these two bytes. A description of the 2 byte-diagnostic interface can be supplied on request.


ModbusTCP slave error answer (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)

Fieldbus system [image] ModbusTCP [image] ModbusTCP slave error answer (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
ModbusTCP slave error answer (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
When the user sends the slave either a request or information that the coupler does not understand, the slave responds with an error report. This answer contains the function and the error code. 0x80 is added to the value returned by the function.
Code | Name | Meaning
1 | ILLEGAL FUNCTION | Modbus function not implemented
2 | ILLEGAL DATA ADDRESS | Invalid address or length
3 | ILLEGAL DATA VALUE | Invalid parameter - Diagnostic functions - Incorrect register
4 | SLAVE DEVICE ERROR | Watchdog or K-bus error EK9000: E-bus error
6 | SLAVE DEVICE BUSY | Output data is already been received from another IP device


ModbusTCP functions

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions
ModbusTCP functions
Additional information
•
ModbusTCP functions
•
Read coil status (Function 1)
•
Read input status (Function 2)
•
Read holding register (Function 3)
•
Read input register (Function 4)
•
Force single coil (Function 5)
•
Preset single register (Function 6)
•
Diagnosis (Function 8)
•
Force multiple coils (Function 15)
•
Preset single register (Function 16)
•
Read / write registers (Function 23)


ModbusTCP functions

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] ModbusTCP functions
ModbusTCP functions
In the Modbus protocol, the functions determine whether data is to be read or written, and what kind of data is involved.
Function | Code | Description
Read coil status | 1 | Read digital outputs
Read input status | 2 | Read digital inputs
Read holding register | 3 | Read analog outputs and inputs / GPR
Read input register | 4 | Reading the inputs / GPR
Force single coil | 5 | Writing a digital output
Preset single register | 6 | Writing an output / GPR
Diagnostics | 8 | Diagnostics
Force multiple coils | 15 | Write a number of digital outputs
Preset multiple register | 16 | Writing several outputs / GPRs
Read / write registers | 23 | Write and read a number of process data outputs / GPRs
GPR (General Preset Register) - register structure of the Modbus interface (see appendix)


Read coil status (Function 1)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Read coil status (Function 1)
Read coil status (Function 1)
The Read coil status function can be used to read the digital outputs that have been set.
The first 10 digital outputs are read in this example. The start address is zero. An offset can be entered in the Start address field
Query
Byte name | Sample
Function code | 1
Start address high | 0
Start address low | 0
Count high | 0
Count low | 10
The fieldbus coupler answers with byte count 2, i.e. 2 bytes of data are returned. The query was for 10 bits, and these are now distributed over 2 bytes. The third bit is set in the output process image, and the fieldbus coupler shows the value 4 in the first data byte.
Response
Byte name | Sample
Function code | 1
Byte count | 2
Data bits 0...7 | 4
Data bits 8...18 | 0


Read input status (Function 2)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Read input status (Function 2)
Read input status (Function 2)
The Read input status function can be used to read the digital input data. The first 10 digital inputs are read in this example. The start address is zero. An offset can be entered in the Start address field
Query
Byte name | Sample
Function code | 2
Start address high | 0
Start address low | 0
Count high | 0
Count low | 10
The fieldbus coupler answers with byte count 2, i.e. two bytes of data are returned. The query was for 10 bits, and these are now distributed over 2 bytes. The third bit is set in the output process image, and the fieldbus coupler shows the value 4 in the first data byte.
Response
Byte name | Sample
Function code | 2
Byte count | 2
Data bits 0..7 | 1
Data bits 8..18 | 0


Read holding register (Function 3)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Read holding register (Function 3)
Read holding register (Function 3)
The Read holding register function can be used to read the input and output words and the registers. Inputs from offset 0 - 0xFF and outputs from offset 0x800 - 0x8FF, and for controllers (BC, BX) the flag area from offset 0x4000.
In this example the first two analog outputs (or two output words) are read. The analog outputs (or output words) start at offset 0x800. The length indicates the number of channels (or words) to be read.
Query
Byte name | Sample
Function code | 3
Start address high | 8
Start address low | 0
Count high | 0
Count low | 2
The fieldbus coupler answers with byte count 4, i.e. 4 bytes of data are returned. The query was for two analog channels, and these are distributed over two words. In the analog output process image, the first channel has the value 0x3FFF, while the second channel has the value 0x0.
Response
Byte name | Sample
Function code | 3
Byte count | 4
Data 1 high byte | 63
Data 1 low byte | 255
Data 2 high byte | 0
Data 2 low byte | 0


Read input register (Function 4)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Read input register (Function 4)
Read input register (Function 4)
The function Read input register reads the inputs on a word basis.
In this example the first two analog inputs (or the first two input words) are read. The analog inputs (or input words) start at an offset of 0x0000. The length indicates the number of words to be read. A KL3002, for example, has two words of input data. Therefore, the length to be entered at Number low is two.
Query
Byte name | Sample
Function code | 4
Start address high | 0
Start address low | 0
Count high | 0
Count low | 2
The fieldbus coupler answers with byte count 4, i.e. four bytes of data are returned. The query was for two analog channels, and these are now distributed over 2 words. In the analog input process image, the first channel has the value 0x0038, while the second channel has the value 0x3F1B.
Response
Byte name | Sample
Function code | 4
Byte count | 4
Data 1 high byte | 0
Data 1 low byte | 56
Data 2 high byte | 63
Data 2 low byte | 11


Force single coil (Function 5)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Force single coil (Function 5)
Force single coil (Function 5)
The Force single coil function can be used to write a digital output. The third digital output is written in this example. The digital outputs start at address 0x0000. The digital value is located in Data high. To switch the output on, Data high must contain the value 0xFF, while 0x00 is used to switch the output off again. Data low must contain the value 0x00.
Query
Byte name | Sample
Function code | 5
Start address high | 0
Start address low | 2
Data high | 255
Data low | 0
The coupler answers with the same telegram.
Response
Byte name | Sample
Function code | 5
Start address high | 0
Start address low | 2
Data high | 255
Data low | 0


Preset single register (Function 6)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Preset single register (Function 6)
Preset single register (Function 6)
The function Preset singles register can be used to access the output or flag process image (only for controllers) and the Modbus TCP interface.
Function 6 writes the first output word. The outputs start at an offset of 0x0800. Here again the offset always describes a word. This means offset 0x0803 refers to the fourth word in the output process image.
Query
Byte name | Sample
Function code | 6
Start address high | 8
Start address low | 0
Data high | 63
Data low | 255
The Fieldbus Coupler replies with the same telegram and confirmation of the received value.
Response
Byte name | Sample
Function code | 6
Start address high | 8
Start address low | 0
Data high | 63
Data low | 255


Diagnosis (Function 8)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Diagnosis (Function 8)
Diagnosis (Function 8)
The diagnosis function provides a series of tests for checking the communication system between the master and the slave and for examining a variety of internal error states within the slave. A broadcast telegram is not supported.
The function uses two bytes in the query to specify a sub-function code defining the test that is to be carried out. The slave returns the function code and the sub-function code in the response.
The diagnostic queries use a two-byte data field to send diagnostics data or control information to the slave.
Query
Byte name | Sample
Function code | 8
Sub-function high | 0
Sub-function low | 0
Data high | 2
Data low | 3
Response
Byte name | Sample
Function code | 8
Sub-function high | 0
Sub-function low | 0
Data high | 2
Data low | 3
Echo a request (Subfunction 0)
Subfunction 0 causes the data that is sent to the slave by the master to be returned.
Coupler reset (Subfunction 1)
The coupler is reset with sub-function 1, error counters are reset and the controller performs a self-test. No telegrams are either received or sent while the controller is being reset. The IP socket is closed.
Last reply with the sub-function 1
Before the Controller restarts it sends a reply with sub-function 1, after which the IP socket is closed.
Sub-function | Data field (query) | Data field (response)
0x0001 | 0x0000 | 0x0000
Delete all counter contents (sub-function 10)
When this sub-function is called the controller clears all error counters.
Sub-function | Data field (query) | Data field (response)
0x000A | 0x0000 | Echo query data
Bus Communication Answer Counter (Subfunction 11)
Returns the number of communication answers.
Sub-function | Data field (query) | Data field (response)
0x000B | 0x0000 | Counter value
Error Answer Counter (Subfunction 13)
This counter contains the number of error answer telegrams that the coupler has sent.
Sub-function | Data field (query) | Data field (response)
0x000D | 0x0000 | Counter value
The following functions contain the counter states for various units. This means that the Modbus telegrams can be distinguished through their units, if, for example, a coupler is accessed by different masters.
Slave Answers (Subfunction 14)
Contains the number of answers that the slave has sent.
Sub-function | Data field (query) | Data field (response)
0x000E | 0x0000 | Counter value
Number of unanswered telegrams (Subfunction 15)
Contains the number of answers that the slave has not sent.
Sub-function | Data field (query) | Data field (response)
0x000F | 0x0000 | Counter value
Number of Error Answers (Subfunction 16)
Contains the number of error answers that the slave has sent.
Sub-function | Data field (query) | Data field (response)
0x0010 | 0x0000 | Counter value


Force multiple coils (Function 15)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Force multiple coils (Function 15)
Force multiple coils (Function 15)
The Force multiple coils function can be used to set or reset a number of digital outputs at the same time.
The first 20 digital outputs are written in this example. The digital outputs start at an offset of 0x0000. Here the offset always describes a bit. Offset 0x0003 writes to the fourth bit in the output process image. The length indicates the number of bits, and the Byte count is composed from the combination all the bytes that are to be written.
Sample: 20 bits count is 3 bytes (round up to the nearest byte)
The data bytes contain the values for the individual bits. In this example, the bits 0 to 15 are set to TRUE, while bits 17 to 20 are set to FALSE.
Query
Byte name | Sample
Function code | 15
Start address high | 0
Start address low | 0
Length high | 0
Length low | 20
Byte count | 3
Data 1 bit 0..7 | 255
Data 2 bit 8..15 | 255
Data 3 bit 16..23 | 0
Response
The Bus Coupler answers with the same telegram.
Byte name | Sample
Function code | 15
Start address high | 0
Start address low | 0
Length high | 0
Length low | 20


Preset single register (Function 16)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Preset single register (Function 16)
Preset single register (Function 16)
The Preset multiple register function can be used to write a number of outputs. The first two analog output words are written in this example. The outputs start at an offset of 0x0800. Here the offset always describes a word. Offset 0x0003 writes to the fourth word in the output process image. The length indicates the number of words, and the Byte count is formed from the combination of all the bytes that are to be written.
Sample: 4 words - correspond to a byte count of 8
The data bytes contain the values for the analog outputs. In this example, two words are to be written. The first word is to receive the value 0x7FFF, and the second word is to receive the value 0x3FFF.
Query
Byte name | Sample
Function code | 16
Start address high | 8
Start address low | 0
Length high | 0
Length low | 2
Byte count | 4
Data 1 byte 1 | 127
Date 1 byte 2 | 255
Date 2 byte 1 | 63
Data 2 byte 2 | 255
Response
The coupler replies with the start address and the length of the transmitted words.
Byte name | Sample
Function code | 16
Start address high | 8
Start address low | 0
Length high | 0
Length low | 2


Read / write registers (Function 23)

Fieldbus system [image] ModbusTCP [image] ModbusTCP functions [image] Read / write registers (Function 23)
Read / write registers (Function 23)
A number of analog outputs can be written and a number of analog inputs read with one telegram using the Read / write registers function. In this example the first two analog output words are written, and the first two analog inputs are read. The analog outputs start at offset 0x0800, while the inputs start at offset 0x0000. Here the offset always describes a word. Offset 0x0003 writes to the fourth word in the output process image. The length indicates the number of words, and the Byte count is formed from the combination of all the bytes that are to be written. Sample: 4 words - correspond to a byte count of 8
The data bytes contain the values for the analog outputs. In this example, two words are to be written. The first word is to receive the value 0x3FFF, and the second word is to receive the value 0x7FFF.
Query
Byte name | Sample
Function code | 23
Read start address high | 0
Read start address low | 0
Read length high | 0
Read length low | 2
Write start address high | 8
Write start address low | 0
Write length high | 0
Write length low | 2
Byte count | 4
Data 1 high | 63
Data 1 low | 255
Data 2 high | 127
Data 2 low | 255
Response
The coupler replies with the start address and the length of the bytes to be transferred in Byte count. The data information follows. In this example the first word contains 0x0038 while the second word contains 0x3F0B.
Byte name | Sample
Function code | 23
Byte count | 4
Data 1 high | 0
Data 1 low | 56
Data 2 high | 63
Data 2 low | 11


Description of parameters

Fieldbus system [image] Description of parameters
Description of parameters
Additional information
•
Register settings, Table 100


Register settings, Table 100

Fieldbus system [image] Description of parameters [image] Register settings, Table 100
Register settings, Table 100
The registers can be set through a dialog using the KS2000 configuration software, or it is possible to write into the registers directly.
Register | Description |  | Default | Bus Terminal Controller
0-1 | IP address |  | 0xAC, 0x10, 0x11, 0x00 | BC9000, BC9100, BK9000, BK9050, BK9100
2-3 | IP mask |  | 0xFF, 0xFF, 0x00, 0x00 | BC9000, BC9100, BK9000, BK9050, BK9100
4-13 | Device Name |  | BC9000 | BC9000, BC9100, BK9000, BK9050, BK9100
14 | Watchdog AMS/ADS |  | 1000 ms | BC9000, BC9100, BK9000, BK9050, BK9100
15.0 | 0bin | enable ModbusTCP | 0bin | BC9000, BC9100, BK9000, BK9050, BK9100
 | 1bin | disable ModbusTCP
15.1 | 0bin | enable AMS/ADS | 0bin
 | 1bin | disable AMS/ADS
16.8 | 0bin | Ethernet mode half duplex | 1bin | BC9000, BC9100, BK9000, BK9050, BK9100
 | 1bin | Ethernet mode full duplex
16.12 | 0bin | Autobaud off | 1bin
 | 1bin | Autobaud on
16.13 | 0bin | 10 Mbaud | 1bin
 | 1bin | 100 Mbaud
17-18 | Default Gateway |  | 0x00, 0x00, 0x00, 0x00 | BC9000, BC9100, BK9000, BK9050, BK9100
24 | Watchdog ModbusTCP |  | 1000 ms | BC9000, BC9100, BK9000, BK9050, BK9100
25.0 | Entry of a fieldbus error (connection to switch interrupted) in the flags area diagnosis |  | 0bin | BC9000, BC9100
 | 0 | Error was not entered
 | 1 | Error was entered
26 | ModbusTCP port no. |  | 502 | BC9000, BC9100, BK9000, BK9050, BK9100
27 | ADS connection service life |  | 10 s | BC9000, BC9100, BK9000, BK9050, BK9100
28 | Modbus connection service life |  | 10 s | BC9000, BC9100, BK9000, BK9050, BK9100
29.0 | ModbusTCP mode |  | 0bin | BC9000, BC9100, BK9000, BK9050, BK9100
 | 1bin | Fast ModbusTCP


Error handling and diagnosis

Error handling and diagnosis
Error handling and diagnosis
Additional information
•
Diagnostic LEDs
•
Diagnostic LEDs
•
General errors
•
ADS diagnostics
•
ModbusTCP diagnostic


Diagnostic LEDs

Error handling and diagnosis [image] Diagnostic LEDs
Diagnostic LEDs
BK9000, BK9100, BC9000, BC9100
After switching on, the Bus Coupler immediately checks the connected configuration. Error-free start-up is indicated when the red I/O ERR LED goes out. If the I/O ERR LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.
The Bus Coupler has two groups of LEDs for the display of status. The upper group with four LEDs indicates the status of the respective fieldbus. The significance of the fieldbus status LEDs is explained in the appropriate sections of this manual. It corresponds to the usual fieldbus display.
On the upper right hand side of the Bus Couplers are two more green LEDs that indicate the supply voltage. The left hand LED indicates the presence of the 24 V supply for the Bus Coupler. The right hand LED indicates the presence of the supply to the power contacts.
BC9000 LEDs
BC9100 LEDs
LEDs for power supply diagnostics
LED | Meaning
Left LED off | Bus Coupler has no power
Right LED off | No 24 VDC power supply connected to the power contacts
LEDs for fieldbus diagnostics
LED
On
Off
LINK (BK9000/BC9000 only)
Physical connection present
No physical connection present
ACT (BK9000/BC9000 only)
Flashing: Bus traffic present
No bus traffic (bus idle)
COM (BK9100/BC9100 only)
Flashing: data received at the controller
no data are received
ERROR
The LED flashes slowly if DHCP or BootP is active but the Bus Coupler has not yet received an IP address
The LED flashes rapidly (5 times, only when switching on); the Bus Coupler is addressed with ARP. The settings on the DIP SWITCH are not valid.
LED permanently on (in RT-Ethernet mode only)
Note: task time set too fast
No error
PLC (BC9000/BC9100 only)
PLC program is in RUN mode
The LED flashes while the boot project is being saved.
PLC program is in stop mode
WDG (BK9000 only)
Watchdog is triggered
▪
No error
Watchdog expired or not triggered
▪
Start communication
▪
Reset watchdog error
LEDs for K-bus diagnostics
Error code
Error code argument
Description
Remedy
Persistent, continuous flashing
EMC problems
▪
Check power supply for undervoltage or overvoltage peaks
▪
Implement EMC measures
▪
If a K-bus error is present, it can be localized by a restart of the coupler (by switching it off and then on again)
1 pulse
0
EEPROM checksum error
Set manufacturer's setting with the KS2000 configuration software
1
Code buffer overflow
Insert fewer Bus Terminals. Too many entries in the table for the programmed configuration
2
Unknown data type
Software update required for the Bus Coupler
2 pulses
0
Programmed configuration has an incorrect table entry
Check programmed configuration for correctness
n (n > 0)
Table comparison (Bus Terminal n)
Incorrect table entry
3 pulses
0
K-bus command error
- No Bus Terminal inserted
- One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses
0
K-bus data error, break behind the Bus Coupler
Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
n
Break behind Bus Terminal n
Check whether the bus end terminal 9010 is connected.
5 pulses
n
K-bus error in register communication with Bus Terminal n
Exchange the nth bus terminal
6 pulses
0
Error at initialization
Exchange Bus Coupler
1
Internal data error
Perform a hardware reset on the Bus Coupler (switch off and on again)
2
DIP switch changed after a software reset
from firmware BC9000 BB and BC9100 B0:
from firmware BK9000 BA and BK9100 B0:
IP address already exists in the network
Perform a hardware reset on the Bus Coupler (switch off and on again)

Assign a different IP address
4
DIP switch incorrect for BootP
Set 1-8 to on or off, see BootP
8
Internal data error
Perform a hardware reset on the Bus Coupler (switch off and on again)
16
Error in IP socket
Perform a hardware reset on the Bus Coupler (switch off and on again)
7 pulses (BC9000/BC9100 only)
0
Note: cycle time was exceeded
(see Table 1, Register 17)
Warning: the set cycle time was exceeded. This note (flashing of the LED) can only be reset by rebooting the BC.
Remedy: increase the cycle time
9 pulses (BC9000/BC9100 only)
0
Checksum error in Flash program
Transmit program to the BC again
1
Incorrect or faulty library implemented
Remove the faulty library
10 pulses (BC9000/BC9100 only)
n
Bus Terminal n is not consistent with the configuration that existed when the boot project was created
Check the nth Bus Terminal. The boot project must be deleted if the insertion of an nth Bus Terminal is intentional
14 pulses
n
nth Bus Terminal has the wrong format
Start the Bus Coupler again, and if the error occurs again then exchange the Bus Terminal
15 pulses
n
Number of Bus Terminals is no longer correct
Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software
16 pulses
n
Length of the K-bus data is no longer correct
Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software
LEDs for switch diagnosis (BK9100/BC9100 only)
LED | On | Flashes | Off
LINK/ACT | Physical connection present | Communication available | No physical connection present
10/100 Mbaud | 100 Mbaud | - | 10 Mbaud


Diagnostic LEDs

Error handling and diagnosis [image] Diagnostic LEDs
Diagnostic LEDs
BK9050
BK9050 LEDs
LEDs for power supply diagnostics
LED (Power LEDs) | Meaning
Us | off: Bus Coupler has no voltage 24 VDC
Up | off: No 24 VDC power supply connected to the power contacts
LEDs for K-bus diagnostics
LED (K-bus) | Meaning
K-bus RUN | on or flashing: K-bus running
K-bus ERR | flashing: (see error code)
LEDs for Ethernet diagnosis
LED (Ethernet) | Meaning
WD ERR | on: Watchdog error
COM | on or flashing: communication with controller
ERROR | flashing: DHCP or BootP active. Waiting for an IP address
RTE | on: hard real-time with TC is switched on. No ADS communication is possible at the same time. All TCP, UPD and ICMP telegrams (e.g. ping) remain unanswered.
LINK/ACT | on: LINK present flashing: LINK present and communication active
Error code for K-bus diagnosis
Error
code
Error
argument
Description
Remedy
-
flashing continuously
EMC problems
▪
Check power supply for undervoltage or overvoltage peaks
▪
Implement EMC measures
▪
If a K-bus error is present, it can be localized by a restart of the coupler (by switching it off and then on again)
1
0
EEPROM checksum error
Enter factory settings with the KS2000 configuration software
1
Code buffer overflow
Insert fewer Bus Terminals. Too many entries in the table for the programmed configuration
2
Unknown data type
Software update required for the Bus Coupler
2
-
Reserve
-
3
0
K-bus command error
▪
No Bus Terminal inserted
▪
One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4
0
K-bus data error, break behind the Bus Coupler
Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
n
Break behind Bus Terminal n
Check whether the Bus End Terminal KL9010 is connected.
5
n
K-bus error in register communication with Bus Terminal n
Exchange the nth bus terminal
6
0
Error at initialization
Exchange Bus Coupler
1
Internal data error
Perform a hardware reset on the Bus Coupler (switch off and on again)
2
IP address already exists
Check the IP address; the coupler has already found its set IP address in the network
4
BootP invalid DIP switch setting
With BootP the DIP switches 1-8 must be all On or all Off
7
0
Note: cycle time was exceeded
Warning: the set cycle time was exceeded. This indication (flashing LEDs) can only be cleared by booting the Bus Coupler again.
Remedy: increase the cycle time
9
0
Checksum error in Flash program
Transmit program to the BC again
1
Incorrect or faulty library implemented
Remove the faulty library
10
n
Bus Terminal n is not consistent with the configuration that existed when the boot project was created
Check the nth Bus Terminal. The boot project must be deleted if the insertion of an nth Bus Terminal is intentional
14
n
nth Bus Terminal has the wrong format
Start the Bus Coupler again, and if the error occurs again then exchange the Bus Terminal
15
n
Number of Bus Terminals is no longer correct
Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software
16
n
Length of the K-bus data is no longer correct
Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software


General errors

Error handling and diagnosis [image] General errors
General errors
No data exchange after replacing a bus coupler
You have exchanged the Ethernet Bus Coupler and set the same TCP/IP number, but data is not exchanged.
Every Ethernet device has its own, unique MAC-ID. This number is saved when connecting to an Ethernet node, and stored in a table. This table contains the correspondences between the MAC-ID and the TCP/IP number. You must delete this table. Do this in a DOS window, by entering the command "arp -d" and the TCP/IP number of the Bus Coupler.
Sample: >arp -d 172.16.17.203<
If the DHCP protocol or the BootP protocol is active it is necessary to set the MAC-ID of the new coupler in the DHCP server or BootP server after changing the Bus Coupler.
Communication errors when online *
After a period in the online state (logged in via Ethernet/AMS) the message Communication error - logging out always occurs.
The data traffic through the Ethernet interface is jamming.
Remedy:
▪
reduce the level of data communication.
▪
Stop the cyclical data traffic, or lengthen the task time.
▪
Reduce the number of windows open in the online display.
▪
Log in via the serial interface.
* BC9000, IL230x-C900 only


ADS diagnostics

Error handling and diagnosis [image] ADS diagnostics
ADS diagnostics
Status inputs
It is possible to monitor the BK/BC9000, B/C900 Bus Coupler's communication in the system manager. Each Bus Coupler has status inputs that can be found in the hardware tree.
Status inputs of the BC9000
Coupler state
Value | Meaning
0x0000 | No error
0x0001 | Bus Terminal error; there is a K-bus error
0x0002 | Configuration error; the parameterized configuration does not match the actual configuration
MissedCnt
Ideal configuration:
The task time is always longer than the Ethernet transmission time. An Ethernet telegram is transmitted at the beginning of the task, and it returns it to the PC again after a period of time, tEth. If the time tEth is always smaller than the task time that has been set, the value in the MissedCnt counter remains constant.
Task time longer than Ethernet propagation delay
If, after the task time has elapsed, an Ethernet telegram has still not arrived at the PC, only reaching it after the next task has started, then TwinCAT will continue to work with the old input data. In addition, the MissedCnt counter is incremented.
Task time shorter than Ethernet propagation delay
This can have the following causes:
▪
The chosen task time is too short. Set
–
100 ms or more for TCP.
–
20 ms or more for UDP.
▪
Too many collisions in the network: use switches instead of hubs!
▪
The bus loading is too high: change to 100 MBaud!
▪
You are logged in to the BC9000, C900: this consumes additional processing capacity in the Controller, which lengthens the response time.
The two following diagnostic inputs have different meanings, depending on the transmission type.
TCP/IP diagnosis
BoxState
Value | Meaning
0x0000 | No error
0x0001 | No current inputs
MissedCnt
Value | Meaning
0xyyyy | Number of telegrams that have not returned in time for the start of the task. This value should remain almost constant. If the value keeps rising, the task time should be lengthened.
UDP/IP diagnosis
BoxState
Value | Meaning
0x0000 | No error
0x0001 | No current inputs
0x0002 | Outputs are written as zero
0xxxzz | xx - warning level. The value here is incremented by one each time the data is not received in time. When data is exchanged correctly, the value is decremented by one. When the maximum warning level (default value 100) is reached, zero is written to the output data, and it is only enabled again for the normal process image when the warning level has reached zero.
MissedCnt
Value | Meaning
0xyyyy | Number of telegrams that have not returned in time for the start of the task. This value should remain almost constant. If the value keeps rising, the task time should be lengthened.


ModbusTCP diagnostic

Error handling and diagnosis [image] ModbusTCP diagnostic
ModbusTCP diagnostic
▪
See Modbus diagnostic function
▪
See ModbusTCP error answers


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Approvals
•
Test standards for device testing
•
Bibliography
•
List of Abbreviations
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
The following conditions must be met in order to ensure flawless operation of the fieldbus components.
Environmental conditions
Operation
The components may not be used without additional protection in the following locations:
▪
in difficult environments, such as where there are corrosive vapors or gases, or high dust levels
▪
in the presence of high levels of ionizing radiation
Condition | Permissible range
Permissible ambient temperature during operation | see technical data
Installation position | variable
Vibration resistance | According to EN 60068-2-6
Shock resistance | According to EN 60068-2-27
EMC resistance | According to EN 61000-6-2
Emission | According to EN 61000-6-4
Transport and storage
Condition | Permissible range
Permissible ambient temperature during storage | -25 °C... +85 °C
Relative humidity | 95 %, no condensation
Free fall | up to 1 m in the original packaging
Protection classes and types
Condition | Permissible range
Protection class in accordance with IEC 536 (VDE 0106, Part 1) | A protective conductor connection to the mounting rail is necessary!
Protection class conforms to IEC 529 | IP20 (protection against contact with a standard test finger)
Protection against foreign objects | Less than 12 mm in diameter
Protection against water | no protection
Component identification
Every supplied component includes an adhesive label providing information about the product's approvals. For example, on the BK2000:
Sticker with information about the BK2000 Bus Coupler certification
The following information is printed on the label:
Printed item | Meaning for this label
Precise product identification | Lightbus Coupler BK2000
Supply voltage | 24 VDC
Data transfer rate | 2.5 Mbit/s
Manufacturer | Beckhoff Automation GmbH
CE mark | Conformity mark
UL mark | Mark for UL approval. UL stands for the Underwriters Laboratories Inc., the leading certification Organisation for North America, based in the USA. C = Canada, US = USA, LISTED 22ZA (the test results can be inspected under this entry)
Production identification | From left to right, this sequence of characters indicates the week of production (2 characters), the year of production (2 characters), the software version (2 characters) and hardware version (2 characters), along with any special indications (4 characters). This case therefore is a BK2000 - produced in the 9th calendar week - in the year 2001 - containing the BF firmware version - and using the 6th hardware version - with no special indications


Approvals

Appendix [image] Approvals
Approvals
Underwriter laboratories
UL E172151
Conformity mark
CE
Protection class
IP20 conforms to EN60529


Test standards for device testing

Appendix [image] Test standards for device testing
Test standards for device testing
EMC
EN 61000-6-2
EN 61000-6-4
Vibration resistance
EN 60068-2-6 vibration test
EN 60068-2-27/29 shock test


Bibliography

Appendix [image] Bibliography
Bibliography
TCP/IP
TCP/IP (German)
Aufbau und Betrieb eines TCP/IP Netzes (Structure and Operation of a TCP/IP Network)
by Kevin Washburn and Jim Evans
Publisher: ADDISON-WESLEY Longmann Verlag
TCP/IP (English)
Illustrated, Volume1 The Protocols
by W. Richard Stevens
Publisher: ADDISON-WESLEY Longmann Verlag
Modbus/TCP
http://www.modicon.com/
http://www.modbus.org
TwinCAT
BECKHOFF Information System
http://infosys.beckhoff.com


List of Abbreviations

Appendix [image] List of Abbreviations
List of Abbreviations
ADS
Automation Device Specification
IP (20)
Bus Terminal protection class
IPC
Industrial PC
I/O
Inputs and outputs
K-bus
Terminal bus
KS2000
Configuration software for Bus Terminals, Bus Couplers, Bus Terminal Controllers, fieldbus box modules, etc.
PE
The PE power contact can be used as a protective earth.
TwinCAT
The Windows Control and Automation Technology


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com