BK3xx0 - Bus Couplers for PROFIBUS DP
Home


Foreword

Foreword
Foreword
Additional information
•
Product overview Bus Couplers for PROFIBUS DP
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Product overview Bus Couplers for PROFIBUS DP

Foreword [image] Product overview Bus Couplers for PROFIBUS DP
Product overview Bus Couplers for PROFIBUS DP
BK3010, BK3110, BK3120, BK3150, BK3500, BK3520 and LC3100


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Stand
4.3.0
▪
Design of the safety instructions adapted to IEC 82079-1
▪
Technical data updated
▪
Chapter Instructions for ESD protection added
▪
ATEX added
▪
Update structure
4.2.0
▪
Mounting and wiring updated
4.1.0
▪
PROFIBUS-Connection corrected
4.0.0
▪
Migration
3.5.1
▪
Notes regarding compliance with UL requirements added.
3.5
▪
BK3150 with firmware version B0 added
3.03
▪
Corrections in English translation
3.02
▪
GSD files updated for BK3110, BK3120, BK3520
3.01
▪
Configuration examples for operation under Siemens S7 expanded.
3.0
▪
For BK3010 with firmware version B9
▪
For BK3110 with firmware version B9
▪
For BK3120 with firmware version B9
▪
For BK3500 with firmware version B9
▪
For BK3520 with firmware version B9
▪
For LC3100 with firmware version B9


Product overview

Product overview
Product overview
Additional information
•
BK30x0, BK3100, BK3110, BK3120, LC3100 - Technical data
•
BK3150 - Technical data
•
BK35x0 - Technical data (optical fibers)
•
The Beckhoff Bus Terminal system
•
PROFIBUS introduction


BK30x0, BK3100, BK3110, BK3120, LC3100 - Technical data

Product overview [image] BK30x0, BK3100, BK3110, BK3120, LC3100 - Technical data
BK30x0, BK3100, BK3110, BK3120, LC3100 - Technical data
BK3120 and LC3100 - Bus Couplers for PROFIBUS DP
Technical data
Type | BK3000, BK3010 | BK3100, BK3110 | BK3120 | LC3100
Number of Bus Terminals | 64 |  | 64 (255 with K-bus extension) | 64
Digital peripheral signals | 512 inputs/outputs (BK3x00) 256 inputs/outputs (BK3x10) |  | max. 1020 inputs/outputs | 256 inputs/outputs
Analog peripheral signals | 128 inputs/outputs (BK3x00) |  | max. 64 inputs/outputs | -
Configuration possibility | Via the KS2000 configuration software or the controller
Max. number of bytes (inputs and outputs) | BK3000: 244 bytes | BK3100: 64 bytes (DP and FMS operation) 128 bytes (DP operation only) | 128 bytes | 32 bytes
 | BK3010: 32 bytes | BK3110: 32 bytes
Baud rate (automatic detection) | up to max. 1.5 Mbaud | up to max. 12 Mbaud
Bus connection | 1 x D-sub plug, 9-pin with shielding |  |  | spring-loaded terminals
Power supply | 24 VDC (-15 % /+20 %)
Input current | 70 mA + (total K-bus current)/4, 500 mA max. (BK3x00) 70 mA + (total K-bus current)/4, 200 mA max. (BK3x10) |  | 70 mA + (total K bus current)/4, max. 500 mA | 70 mA + (total K bus current)/4, max. 200 mA
Starting current | 2.5 x continuous current
Recommended fuse | maximum 10 A
K-bus current up to | 1750 mA (BK3x00) 500 mA (BK3x10) |  | 1750 mA | 500 mA
Power contact voltage | maximum 24 VDC
Power contact current load | maximum 10 A
Electrical isolation | Power contact / supply / fieldbus |  |  | Power supply / fieldbus
Dielectric strength | 500 V (power contact / supply / fieldbus) |  |  | 500 V (supply / fieldbus)
Weight | approx. 170 g | approx. 150 g | approx. 170 g | approx. 100 g
Permissible ambient temperature (operation) | 0°C … +55°C |  | -25°C … +60°C | 0°C … +55°C
Permissible ambient temperature (storage) | -25°C … +85°C
Permissible relative humidity | 95% (no condensation)
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approvals | CE, ATEX, cULus, GL |  | CE, ATEX, cULus, GL, IECEx | CE, ATEX, cULus


BK3150 - Technical data

Product overview [image] BK3150 - Technical data
BK3150 - Technical data
BK3150 - Bus Coupler for PROFIBUS DP
Technical data BK3150
Type | BK3150
Number of Bus Terminals | 64 (255 with K-bus extension)
Digital peripheral signals | 256 inputs/outputs (BK3x10)
Analog peripheral signals | 128 inputs/outputs (BK3x00)
Configuration possibility | Via the KS2000 configuration software or the controller
Max. number of bytes (inputs and outputs) | 128 bytes (DP operation only)
Baud rate (automatic detection) | up to max. 12 Mbaud
Bus connection | 1 x D-sub plug, 9-pin with shielding
Power supply (Us) | 24 VDC (-15% /+20%) Use a 4 A fuse or an NEC Class 2 power supply to meet the UL requirements!
Input current (Us) | 70 mA + (total K bus current)/4, max. 320 mA
Starting current (Us) | 2.5 x continuous current
K-bus current (5 V) | up to hardware version 04: 1000 mA from hardware version 05: 1750 mA
Power contact voltage (Up) | maximum 24 VDC
Power contacts current load (Up) | maximum 10 A
Recommended backup fuse (Up) | maximum 10 A
Electrical isolation | Power contact / supply / fieldbus
Dielectric strength | 500 V (power contact / supply / fieldbus)
Weight | approx. 100 g
Permissible ambient temperature (operation) | -25°C … +60°C
Permissible ambient temperature (storage) | -25°C … +85°C
Permissible relative humidity | 95% (no condensation)
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approvals | CE, ATEX, cULus


BK35x0 - Technical data (optical fibers)

Product overview [image] BK35x0 - Technical data (optical fibers)
BK35x0 - Technical data (optical fibers)
BK3500 and BK3520 - Bus Couplers with optical fiber connection for PROFIBUS DP
Technical data
Type | BK3500 | BK3520
Number of Bus Terminals | 64 | 64 (255 with K-bus extension)
Digital peripheral signals | max. 512 inputs/outputs | max. 1020 inputs/outputs
Analog peripheral signals | max. 64 inputs/outputs | max. 64 inputs/outputs
Configuration possibility | Via the KS2000 configuration software or the controller
Max. number of bytes (inputs and outputs) | 128 bytes | 128 bytes
Baud rates | up to max. 1.5 Mbaud (manual setting) | up to max. 12 Mbaud (automatic detection)
Bus connection | 1 x optical fiber with 2 HP Simplex connectors | 2 x optical fibers with 2 HP Simplex connectors each
Power supply | 24 VDC (-15% /+20%)
Input current | 70 mA + (total K-bus current)/4, 500 mA, 500 mA max.
Starting current | 2.5 x continuous current
Recommended fuse | maximum 10 A
K-bus power supply up to | 1750 mA
Power contact voltage | maximum 24 VDC
Power contact current load | maximum 10 A
Electrical isolation | Power contact / supply / fieldbus
Dielectric strength | 500 V (power contact / supply / fieldbus)
Weight | approx. 170 g | approx. 170 g
Permissible ambient temperature (operation) | 0°C … +55°C
Permissible ambient temperature (storage) | -25°C … +85°C
Permissible relative humidity | 95% (no condensation)
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approvals | CE, ATEX, cULus


The Beckhoff Bus Terminal system

Product overview [image] The Beckhoff Bus Terminal system
The Beckhoff Bus Terminal system
Up to 256 Bus Terminals, with 1 to 16 I/O channels per signal form
The Bus Terminal system is the universal interface between a fieldbus system and the sensor / actuator level. A unit consists of a Bus Coupler as the head station, and up to 64 electronic series terminals, the last one being an end terminal. Up to 255 Bus Terminals can be connected via the K-bus extension. For each technical signal form, terminals are available with one, two, four or eight I/O channels, which can be mixed as required. All the terminal types have the same mechanical construction, so that difficulties of planning and design are minimized. The height and depth match the dimensions of compact terminal boxes.
Decentralised wiring of each I/O level
Fieldbus technology allows more compact forms of controller to be used. The I/O level does not have to be brought to the controller. The sensors and actuators can be wired decentrally, using minimum cable lengths. The controller can be installed at any location within the plant.
Industrial PCs as controllers
The use of an Industrial PC as the controller means that the operating and observing element can be implemented in the controller's hardware. The controller can therefore be located at an operating panel, in a control room, or at some similar place. The Bus Terminals form the decentralised input/output level of the controller in the control cabinet and the subsidiary terminal boxes. The power sector of the plant is also controlled over the bus system in addition to the sensor/actuator level. The Bus Terminal replaces the conventional series terminal as the wiring level in the control cabinet. The control cabinet can have smaller dimensions.
Bus Couplers for all usual bus systems
The Beckhoff Bus Terminal system unites the advantages of a bus system with the possibilities of the compact series terminal. Bus Terminals can be driven within all the usual bus systems, thus reducing the controller parts count. The Bus Terminals then behave like conventional connections for that bus system. All the performance features of the particular bus system are supported.
Mounting on standardized mounting rails
The installation is standardized thanks to the simple and space-saving mounting on a standardized mounting rail (EN 60715, 35 mm) and the direct wiring of actuators and sensors, without cross connections between the terminals. The consistent labelling scheme also contributes.
The small physical size and the great flexibility of the Bus Terminal system allow it to be used wherever a series terminal is also used. Every type of connection, such as analog, digital, serial or the direct connection of sensors can be implemented.
Modularity
The modular assembly of the terminal strip with Bus Terminals of various functions limits the number of unused channels to a maximum of one per function. The presence of two channels in one terminal is the optimum compromise of unused channels and the cost of each channel. The possibility of electrical isolation through potential feed terminals also helps to keep the number of unused channels low.
Display of the channel state
The integrated LEDs show the state of the channel at a location close to the sensors and actuators.
K-bus
The K-bus is the data path within a terminal strip. The K-bus is led through from the Bus Coupler through all the terminals via six contacts on the terminals' side walls. The end terminal terminates the K-bus. The user does not have to learn anything about the function of the K-bus or about the internal workings of the terminals and the Bus Coupler. Many software tools that can be supplied make project planning, configuration and operation easy.
Potential feed terminals for isolated groups
The operating voltage is passed on to following terminals via three power contacts. You can divide the terminal strip into arbitrary isolated groups by means of potential feed terminals. The potential feed terminals play no part in the control of the terminals, and can be inserted at any locations within the terminal strip.
Up to 64 Bus Terminals can be used in a terminal block, with optional K-bus extension for up to 256 Bus Terminals. This count does include potential feed terminals, but not the end terminal.
Bus Couplers for various fieldbus systems
Various Bus Couplers can be used to couple the electronic terminal strip quickly and easily to different fieldbus systems. It is also possible to convert to another fieldbus system at a later time. The Bus Coupler performs all the monitoring and control tasks that are necessary for operation of the connected Bus Terminals. The operation and configuration of the Bus Terminals is carried out exclusively by the Bus Coupler. Nevertheless, the parameters that have been set are stored in each Bus Terminal, and are retained in the event of voltage drop-out. Fieldbus, K-bus and I/O level are electrically isolated.
If the exchange of data over the fieldbus is prone to errors or fails for a period of time, register contents (such as counter states) are retained, digital outputs are cleared, and analog outputs take a value that can be configured for each output when commissioning. The default setting for analog outputs is 0 V or 0 mA. Digital outputs return in the inactive state. The timeout periods for the Bus Couplers correspond to the usual settings for the fieldbus system. When converting to a different bus system it is necessary to bear in mind the need to change the timeout periods if the bus cycle time is longer.
The interfaces
A Bus Coupler has six different methods of connection. These interfaces are designed as plug connectors and as spring-loaded terminals.


PROFIBUS introduction

Product overview [image] PROFIBUS introduction
PROFIBUS introduction
Additional information
•
PROFIBUS DP
•
PROFIBUS DPV1


PROFIBUS DP

Product overview [image] PROFIBUS introduction [image] PROFIBUS DP
PROFIBUS DP
In PROFIBUS DP systems a master (PLC, PC, etc.) usually communicates with many slaves (I/Os, drives, etc.); only the master actively accesses the bus (by sending unsolicited telegrams), while a DP slave only sends telegrams when requested by the master.
DP StartUp
Before the master and slave can cyclically exchange data, the parameter and configuration data is transmitted from the master to the slaves during the DP StartUp phase. After the parameter and configuration data has been sent, the master interrogates the slave's diagnostic data until the slave indicates that it is ready for data exchange. Depending on the scope of the calculations the slave has to carry out as a result of receiving parameter and configuration data, it may take several seconds before it is ready for data exchange. For this reason the slave possesses the following states.
Parameter data
The parameter data is sent from the master to the slave in the SetPrmLock request telegram. The SetPrmLock response telegram does not contain any data, and therefore consists of a single byte, the short acknowledgement. The parameter data consists of DP parameters (e.g. the setting of the DP watchdog or checking the IdentNumber (unique to each DP device)), of DPV1-/DPV2 parameters and of application-specific parameters that only have to be transmitted once during the StartUp. If an error is found in the parameter data, this is indicated in the diagnostic data, and the slave either remains in or enters the WAIT-PRM state.
Configuration data
The configuration data is sent from the master to the slave in the ChkCfg request telegram. The ChkCfg response telegram does not contain any data, and therefore consists of a single byte, the short acknowledgement. The configuration data describes the assignment of the DP modules to the cyclic I/O data that is to be exchanged between the master and slave via the Data_Exchange telegram in the cyclic data exchange phase. The sequence of the DP modules added to a slave in the DP configuration tool determines the sequence of the associated I/O data in the Data_Exchange telegram.
Diagnostic data
The diagnostic data is requested by the master using a SlaveDiag request telegram without any data. The slave replies with the diagnostic data in a SlaveDiag response telegram. The diagnostic data consists of the standard DP diagnostics (e.g. the state of the slave, the IdentNumber) and of application-specific diagnostic data.
Cyclic data exchange
At the core of the PROFIBUS DP protocol is the cyclic data exchange, during which the master exchanges I/O data with each slave within a PROFIBUS DP cycle. This involves the master sending the outputs to each slave with a DataExchange request telegram, while the slave replies with the inputs in a DataExchange response telegram. This means that all the output and/or input data is transmitted in one telegram, in which the DP configuration (the sequence of DP modules) specifies the assignment of the output and/or input data to the slave's actual process data.
Diagnosis during cyclic data exchange
A slave can send a diagnostics signal to the master during cyclic data exchange. In this case, the slave sets a flag in the DataExchange response telegram, whereby the master recognizes that there is new diagnostic data in the slave. It then fetches that data in the SlaveDiag telegram. The diagnostic data is therefore not available at the same time as the cyclic I/O data, but always delayed by at least one DP cycle.
Synchronisation with Sync and Freeze
The Sync and Freeze commands in the GlobalControl request telegram (broadcast telegram) allow the master to synchronise the activation of the outputs (Sync) or the reading of the inputs (Freeze) in a number of slaves. When the Sync command is used, the slaves are first switched into Sync mode (a process that is acknowledged in the diagnostic data). The I/O data is then exchanged sequentially with the slaves in the DataExchange telegram. Transmitting the Sync command in the GlobalControl telegram then has the effect of causing the slaves to generate the most recently received outputs. In Freeze operation a Freeze command is first sent in the GlobalControl telegram, in response to which all the slaves latch their inputs. These are then fetched sequentially by the master in the DataExchange telegram.
States in the master
The master distinguishes between the CLEAR state (all outputs are set to the Fail_Safe value) and the OPERATE state (all outputs have the process value). The Master is usually switched into the CLEAR mode when, for instance, the PLC enters STOP.
Class 1 and Class 2 DP Masters
The Class 1 master refers to the controller that carries out cyclic I/O data exchange with the slaves, while a Class 2 master is a B&B device that generally only has read access to the slaves' I/O data.


PROFIBUS DPV1

Product overview [image] PROFIBUS introduction [image] PROFIBUS DPV1
PROFIBUS DPV1
PROFIBUS DPV1 refers primarily to the read and write telegrams, with which data sets in the slave are acyclically accessed. A distinction between a Class 1 (C1) and a Class 2 (C2) master is also made for DPV1. The acyclic Class 1 or Class 2 connections differ in that the acyclic C1 connection is established with the DP startup of the cyclic DP mode. Acyclic DPV1 C1 read and write telegrams can be sent from the master to the slave from the state WAIT-CFG of the slave. In contrast, the C2 connection is established separately, usually by a second C2 master. For example, a manufacturer-specific project configuration and diagnostics tool can access the slave data independent of the cyclic DP connection.
When two masters are used, however, is must always be borne in mind that these share bus access (a token is exchanged), so that time relationships are less favorable than in the case of a single master system.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Dimensions
•
Mounting
•
Connection
•
ATEX


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Dimensions

Mounting and wiring [image] Dimensions
Dimensions
The Beckhoff Bus Terminal system is characterized by low physical volume and high modularity. When planning a project it must be assumed that at least one Bus Coupler and a number of Bus Terminals will be used. The dimensions of the Bus Couplers are independent of the fieldbus system.
Dimensions, using BK3120 and LC3100 as examples
The total width in practical cases is composed of the width of the Bus Coupler with the KL9010 Bus End Terminal and the width of the Bus Terminals in use. Depending on function, the Bus Terminals are 12 mm or 24 mm wide. The front wiring increases the total height of 68 mm by about 5 mm to 10 mm, depending on the wire thickness.
Mechanical data | BK30x0, BK35x0, KL3110, BK3120 | BK3150 | LC3100
Material | polycarbonate, polyamide (PA 6.6)
Dimensions (W x H x D) | 50 mm x 100 mm x 68 mm | 44 mm x 100 mm x 68 mm | 21 mm x 100 mm x 68 mm
Mounting | on 35 mm mounting rail according to EN60715 with locking mechanism
Stackable by | double groove-tongue connection
Labelling | Standard terminal block labelling and text slide (8 mm x 47 mm, not BK3150)


Mounting

Mounting and wiring [image] Mounting
Mounting
The Bus Coupler and all the Bus Terminals can be clipped, with a light press, onto a 35 mm mounting rail. A locking mechanism prevents the individual housings from being pulled off again. For removal from the mounting rail the orange colored tension strap releases the latching mechanism, allowing the housing to be pulled off the rail without any force.
Release the locking mechanism by pulling the orange tab
Up to 64 Bus Terminals can be attached to the Bus Coupler on the right hand side. When plugging the components together, be sure to assemble the housings with groove and tongue against each other. A properly working connection cannot be made by pushing the housings together on the mounting rail. When correctly assembled, no significant gap can be seen between the attached housings.
Groove and tongue of the housings
Note
Bus Terminals should only be pulled or plugged in switched-off state.
Insertion and removal of Bus Terminals is only permitted when switched off. The electronics in the Bus Terminals and in the Bus Coupler are protected to a large measure against damage, but incorrect function and damage cannot be ruled out if they are plugged in under power.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Potential groups, insulation testing and PE
•
Power supply
•
PROFIBUS cabling


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Potential groups, insulation testing and PE

Mounting and wiring [image] Connection [image] Potential groups, insulation testing and PE
Potential groups, insulation testing and PE
Potential groups
A Beckhoff Bus Terminal block usually has three different potential groups:
▪
The fieldbus interface is electrically isolated (except for individual Low Cost couplers) and forms the first potential group.
▪
Bus Coupler / Bus Terminal Controller logic, K-bus and terminal logic form a second electrically isolated potential group.
▪
The inputs and outputs are supplied via the power contacts and form further potential groups.
Groups of I/O terminals can be consolidated to further potential groups via potential supply terminals or separation terminals.
Potential groups of a Bus Terminal block
Insulation testing
The connection between Bus Coupler / Bus Terminal Controller and Bus Terminals is realized automatically by latching the components. The transfer of the data and the supply voltage for the intelligent electronics in the Bus Terminals is performed by the K-bus. The supply of the field electronics is performed through the power contacts. Plugging together the power contacts creates a supply rail. Since some Bus Terminals (e.g. analog Bus Terminals or 4-channel digital Bus Terminals) are not looped through these power contacts or not completely the Bus Terminal contact assignments must be considered.
The potential feed terminals interrupt the power contacts, and represent the start of a new supply rail. The Bus Coupler / Bus Terminal Controller can also be used for supplying the power contacts.
PE power contacts
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on the left
It should be noted that, for reasons of electromagnetic compatibility, the PE contacts are capacitively coupled to the mounting rail. This can both lead to misleading results and to damaging the terminal during insulation testing (e.g. breakdown of the insulation from a 230 V power consuming device to the PE conductor). The PE supply line at the Bus Coupler / Bus Terminal Controller must be disconnected for an insulation test. In order to uncouple further feed locations for the purposes of testing, the feed terminals can be pulled at least 10 mm out from the connected group of other terminals. In that case, the PE conductors do not have to be disconnected.
The power contact with the label PE must not be used for other potentials.


Power supply

Mounting and wiring [image] Connection [image] Power supply
Power supply
Supply of Bus Coupler / Bus Terminal Controller and Bus Terminals (Us)
Additional information
•
BKxx00, BKxx10, BKxx20 and LCxxxx
•
BKxx50 and BKxx51
•
Configuration and Programming Interface
•
Electrical isolation
•
Power contacts


BKxx00, BKxx10, BKxx20 and LCxxxx

Mounting and wiring [image] Connection [image] Power supply [image] BKxx00, BKxx10, BKxx20 and LCxxxx
BKxx00, BKxx10, BKxx20 and LCxxxx
The Bus Couplers / Bus Terminal Controllers require an operating voltage of 24 VDC.
The connection is made by means of the upper spring-loaded terminals labelled 24 V and 0 V. This supply voltage is used for the electronic components of the Bus Coupler and Bus Terminal Controllers and (via the K-bus) the electronic components of the Bus Terminals. It is galvanically separated from the field level voltage.
Power supply connections for BKxx00, BKxx10, BKxx20 and LCxxxx


BKxx50 and BKxx51

Mounting and wiring [image] Connection [image] Power supply [image] BKxx50 and BKxx51
BKxx50 and BKxx51
The Bus Couplers / Bus Terminal Controllers require an operating voltage of 24 VDC. Use a 4 A fuse or a Class 2 power supply to comply with the UL requirements.
The connection is made by means of the upper spring-loaded terminals labelled Us and GNDs. This supply voltage is used for the electronic components of the Bus Coupler and Bus Terminal Controllers and (via the K-bus) the electronic components of the Bus Terminals. It is galvanically separated from the field level voltage.
Power supply connections for BKxx50 and BKxx51
UL identification
SmallWarningYellow DANGER
Note the UL requirements for the power supply.
To comply with the UL requirements, the 24 VDC supply voltage for Us must originate
•
from an isolated source protected by a fuse of max. 4A (according to UL248) or
•
from a voltage supply complying with NEC class 2.
An NEC class 2 voltage source must not be connected in series or parallel with another NEC class 2 voltage source!
SmallWarningYellow DANGER
No unlimited voltage sources!
To comply with the UL requirements, Us must not be connected with unlimited voltage sources.


Configuration and Programming Interface

Mounting and wiring [image] Connection [image] Power supply [image] Configuration and Programming Interface
Configuration and Programming Interface
The standard Bus Couplers have an RS232 interface at the bottom of the front face. The miniature plug connector can be connected to a PC using a connecting cable and the KS2000 configuration software. The interface permits the Bus Terminals to be configured, for example adjusting the amplification factors of the analog channels. The interface can also be used to change the assignments of the bus terminal data to the process image in the Bus Coupler. The functionality of the configuration interface can also be reached via the fieldbus using string communication facility.


Electrical isolation

Mounting and wiring [image] Connection [image] Power supply [image] Electrical isolation
Electrical isolation
The Bus Couplers / Bus Terminal Controllers operate with three independent potential groups. The supply voltage feeds the K-bus electronics and the K-bus itself. The supply voltage is also used to generate the operating voltage for the fieldbus interface.
Note: All the Bus Terminals are electrically isolated from the K-bus. The K-bus is thus electrically isolated from everything else.
Potential connection diagram of an EKxxxx


Power contacts

Mounting and wiring [image] Connection [image] Power supply [image] Power contacts
Power contacts
Power contacts supply (Up)
The bottom six connections with spring-loaded terminals can be used to feed the supply for the peripherals. The spring-loaded terminals are joined in pairs to a power contact. The power supply for the power contacts has no connection to the power supply for the Bus Couplers / Bus Terminal Controllers.
The spring-loaded terminals are designed for wires with cross-sections between 0.08 mm² and 2.5 mm².
The assignment in pairs and the electrical connection between feed terminal contacts allows the connection wires to be looped through to various terminal points. The current load from the power contact must not exceed 10 A for long periods. The current carrying capacity between two spring-loaded terminals is identical to that of the connecting wires.
Power contacts
Three spring contacts of the power contact connections can be found on the right of the Bus Coupler / Bus Terminal Controller. The spring contacts are hidden in slots so that they cannot be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue & groove design of the top and bottom of the Bus Coupler / Bus Terminal Controller and Bus Terminals enables secure fitting of the power contacts.


PROFIBUS cabling

Mounting and wiring [image] Connection [image] PROFIBUS cabling
PROFIBUS cabling
Additional information
•
PROFIBUS Connection
•
PROFIBUS cabling


PROFIBUS Connection

Mounting and wiring [image] Connection [image] PROFIBUS cabling [image] PROFIBUS Connection
PROFIBUS Connection
M12 round connector
The M12 socket is inverse-coded and has five pins. Pin 1 transfers 5 VDC, pin 3 transfers GND for the active termination resistor. These must never be misused for other functions, as this can lead to destruction of the device.
Pins 2 and 4 transfer the PROFIBUS signals. These must never be swapped over, as this will prevent communication. Pin 5 transfers the shield, which is capacitively connected to the base of the Fieldbus Box.
Pin assignment M12 socket (-B310)
Pin assignment M12 socket (-B310)
Pin assignment M12 socket/plug connector (-B318)
Pin assignment M12 socket/plug connector (-B318)
Nine-pin D-Sub
Pin 6 transfers 5 VDC, pin 5 transfers GND for the active termination resistor. These must never be misused for other functions, as this can lead to destruction of the device.
Pins 3 and 8 transfer the PROFIBUS signals. These must never be swapped over, as this will prevent communication.
Pin assignment of the PROFIBUS D-sub socket
Pin assignment of the PROFIBUS D-sub socket
PROFIBUS wire colors
PROFIBUS line | M12 | D-Sub
B red | Pin 4 | Pin 3
A green | Pin 2 | Pin 8
Connection of the Fieldbus Box modules
The Fieldbus Box modules are connected either directly or via a T-piece (or Y-piece).
The B318 series features a socket and a plug connector, i.e. this is where the PROFIBUS is routed in the module. The supply voltage (+5 VDC) for the termination resistor is only present at the socket. The termination resistor ZS1000-1610 is only available as a plug connector.
The incoming PROFIBUS line should always end with a socket.
Pin assignment socket/plug connector Fieldbus Box modules
Two T-pieces are available:
▪
ZS1031-2600 with +5 VDC transfer for supplying the termination resistor
▪
ZS1031-2610 without +5 VDC transfer


PROFIBUS cabling

Mounting and wiring [image] Connection [image] PROFIBUS cabling [image] PROFIBUS cabling
PROFIBUS cabling
Physical aspects of the data transmission are defined in the PROFIBUS standard (see PROFIBUS layer 1: Physical Layer).
The types of area where a fieldbus system can be used is largely determined by the choice of the transmission medium and the physical bus interface. In addition to the requirements for transmission security, the expense and work involved in acquiring and installing the bus cable is of crucial significance. The PROFIBUS standard therefore allows for a variety of implementations of the transmission technology while retaining a uniform bus protocol.
Cable-based transmission
This version, which accords with the American EIA RS-485 standard, was specified as a basic version for applications in production engineering, building management and drive technology. A twisted copper cable with one pair of conductors is used. Depending on the intended application area (EMC aspects should be considered) the screening may be omitted.
Two types of conductor are available, with differing maximum conductor lengths (see the RS-485 table).
RS485 - Fundamental properties
RS-485 transmission according to the PROFIBUS standard
Network topology | Linear bus, active bus terminator at both ends, stubs are possible.
Medium | Screened twisted cable, screening may be omitted, depending upon the environmental conditions (EMC).
Number of stations | 32 stations in each segment with no repeater. Can be extended to 127 stations with repeater
Max. bus length without repeater | 100 m at 12 Mbit/s 200 m at 1500 Kbit/s, up to 1.2 km at 93.75 kbit/s
Max. bus length with repeater | Line amplifiers, or repeaters, can increase the bus length up to 10 km. The number of repeaters possible is at least 3, and, depending on the manufacturer, may be up to 10.
Transmission speed (adjustable in steps) | 9.6 kbit/s; 19.2 kbit/s; 93.75 kbit/s; 187.5 kbit/s; 500 kbit/s; 1500 kbit/s; 12 Mbit/s
Connector | 9-pin D-Sub connector for IP20 M12 round connector for IP65/67
Cabling for PROFIBUS DP and PROFIBUS FMS
Note the special requirements on the data cable for baud rates greater than 1.5 Mbaud. The correct cable is a basic requirement for correct operation of the bus system. If a simple 1.5 Mbaud cable is used, reflections and excessive attenuation can lead to some surprising phenomena. It is possible, for instance, for a connected PROFIBUS station not to achieve a connection, but for it to be included again when the neighboring station is disconnected. Or there may be transmission errors when a specific bit pattern is transmitted. The result of this can be that when the equipment is not operating, PROFIBUS works without faults, but that there are apparently random bus errors after start-up. Reducing the baud rate (< 93.75 kbaud) corrects this faulty behavior.
If reducing the baud rate does not correct the error, then in many cases this can indicate a wiring fault. The two data lines may be crossed over at one or more connectors, or the termination resistors may not be active, or they may be active at the wrong locations.
Recommended cables
Installation is made a great deal more straightforward if preassembled cables from Beckhoff are used! Wiring errors are avoided, and commissioning is more rapidly completed. The Beckhoff range includes fieldbus cables, power supply cables, sensor cables and accessories such as termination resistors and T-pieces. Connectors and cables for field assembly are nevertheless also available.
PROFIBUS cable assignment
Termination resistors
In systems with more than two stations all devices are wired in parallel. The PROFIBUS cable must be terminated with resistances at both ends, in order to avoid reflections and associated transfer problems.
Distances
The bus cable is specified in EN 50170. This yields the following lengths for a bus segment.
Baud rate in kbits/sec | 9,6 | 19,2 | 93,75 | 187,5 | 500 | 1500 | 12000
Cable length in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100
Stubs up to 1500 kbaud <6.6 m; at 12 Mbaud stub segments should not be used.
Bus segments
A bus segment consists of at most 32 devices. 126 devices are permitted in a PROFIBUS network. Repeaters are required to refresh the signal in order to achieve this number. Each repeater is counted as one device.
IP-Link is the subsidiary bus system for Fieldbus Boxes, whose topology is a ring structure. There is an IP master in the coupler modules (IP230x-Bxxx or IP230x-Cxxx) to which up to 120 extension modules (IExxxx) may be connected. The distance between two modules may not exceed 5 m. When planning and installing the modules, remember that because of the ring structure the IP-Link master must be connected again to the last module.
Installation guidelines
When assembling the modules and laying the cables, observe the technical guidelines provided by the PROFIBUS User Organization (PROFIBUS Nutzerorganisation e.V.) for PROFIBUS DP/FMS (see www.profibus.de).
Checking the PROFIBUS wiring
A PROFIBUS cable (or a cable segment when using repeaters) can be checked with a few simple resistance measurements. The cable should meanwhile be removed from all stations:
1.
Resistance between A and B at the start of the lead: approx. 110 Ohm
2.
Resistance between A and B at the end of the lead: approx. 110 Ohm
3.
Resistance between A at the start and A at the end of the lead: approx. 0 Ohm
4.
Resistance between B at the start and B at the end of the lead: approx. 0 Ohm
5.
Resistance between screen at the start and screen at the end of the lead: approx. 0 Ohm
If these measurements are successful, the cable is okay. If, in spite of this, bus malfunctions still occur, this is usually a result of EMC interference. Observe the installation notes from the PROFIBUS User Organization (www.profibus.com).


ATEX

Mounting and wiring [image] ATEX
ATEX
Additional information
•
ATEX - Special conditions (standard temperature range)
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX Documentation

Mounting and wiring [image] ATEX [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Parameterization and commissioning

Parameterization and commissioning
Parameterization and commissioning
Additional information
•
Start-up behaviour of the Bus Coupler
•
The Bus Coupler's UserPrmData
•
Technical data - overview
•
Configuration


Start-up behaviour of the Bus Coupler

Parameterization and commissioning [image] Start-up behaviour of the Bus Coupler
Start-up behaviour of the Bus Coupler
Immediately after being switched on, the Bus Coupler checks, in the course of a self-test, all the functions of its components and the communication on the K-bus/E-bus. The red I/O LED blinks while this is happening. After completion of the self-test, the Bus Coupler starts to test the attached Bus Terminals (the "Bus Terminal Test"), and reads in the configuration. The Bus Terminal configuration is used to generate an internal structure list, which is not accessible from outside. In case of an error, the Bus Coupler enters the Stop state. Once the start-up has completed without error, the Bus Coupler enters the fieldbus start state.
Start-up behaviour of the Bus Coupler
The Bus Coupler can be made to enter the normal operating state by switching it on again once the fault has been rectified.


The Bus Coupler's UserPrmData

Parameterization and commissioning [image] The Bus Coupler's UserPrmData
The Bus Coupler's UserPrmData
The following settings can be made in the Bus Coupler's UserPrmData. So that a more easily understood GSD file is obtained in 90% of applications, some of the settings are only contained in text form in the Extended GSD file, and these are indicated in the last column by Extended. The standard settings are contained both in the standard and the extended GSD file.
Byte | Bit | Value | Description | GSD file
0 | 7 | 0bin | MSAC_C1 connection is not active (default) | Standard
 |  | 1bin | MSAC_C1 connection is active (see DPV1)
1 | 0 | 0bin | CfgData checking is active (default) | Extended
 |  | 1bin | CfgData checking deactivated (see Deactivating the CfgData checking)
2 | 3 | 0bin | Diagnostic data is transferred in a form compatible with the BK3100 | Extended
 |  | 1bin | Diagnostic data is transferred in a form compatible with DPV1 (default)
3 | 3 | 0bin | K-bus cycle counter is not active (default) | Extended
 |  | 1bin | K-bus cycle counter is active (see K-bus cycle)
3 | 4 | 0bin | Multi-configuration mode is not active (default) | Extended
 |  | 1bin | Multi-configuration mode is active (see Multi-configuration mode)
3 | 5 | 0bin | Dummy output byte not active (default) | Extended
 |  | 1bin | Dummy output byte is active (see K-bus cycle)
3 | 6 | 0bin | MCM startup "Static diagnostics" In multi-configuration mode, the coupler sets the Stat_Diag bit in the diagnostic data if the configuration is not consistent, and does not yet enter data exchange (default). | Extended
 |  | 1bin | MCM startup "Data exchange without K-bus" In multi-configuration mode the coupler also enters data exchange even when the configuration is not consistent, although K-bus cycles are not yet executed (see Multi-configuration mode)
5 | 0 | 0bin | 2-byte PLC interface not activated (default) | Extended
 |  | 1bin | 2-byte PLC interface is active (see 2-byte PLC interface)
7 | 0 | 0bin | Response to K-bus error: Manual K-bus reset (default) (see K-bus interruption) | Standard
 |  | 1bin | Response to K-bus error: automatic K-bus reset
7 | 1 | 0bin | Terminal diagnosis is not active (default) (see Terminal diagnosis) | Standard
 |  | 1bin | Terminal diagnosis is active
7 | 4 | 0bin | Diagnostic data for digital terminals included in process image (default) (see Terminal diagnosis) | Standard
 |  | 1bin | Diagnostic data of digital terminals not in the process image (default)
9 | 2 | 0bin | Analog modules are mapped in compact form (only showing the input and/or output user data) (this is the default, only relevant when CfgData checking has been deactivated, otherwise the terminals are set by means of the CfgData) (see Deactivation of CfgData checking) | Extended
 |  | 1bin | Analog modules are mapped in complex form (with control/status for register access and with the same data length in inputs and outputs) (only relevant when CfgData checking has been deactivated, otherwise the terminals are set by means of the CfgData)
9 | 3 | 0bin | Representation in INTEL format | Standard
 |  | 1bin | Representation in Motorola format (default)
9 | 4 | 0bin | K-bus mode slow FreeRun (default) (see K-bus cycle) | Standard
 |  | 1bin | K-bus mode fast FreeRun
9 | 5 | 0bin | WORD alignment inactive (default) | Extended
 |  | 1bin | WORD alignment active (see WORD alignment)
9 | 6 | 0bin | K-bus mode is synchronous (see K-bus cycle) | Standard
 |  | 1bin | K-bus mode FreeRun (default)
Byte | Bit | Value | Description | GSD file
10 | 0-1 | 00bin | Reaction to PROFIBUS error: K-bus cycle is abandoned (default, digital outputs become 0, complex outputs are set to a configured substitute value) (see Reaction to PROFIBUS errors) | Standard
 |  | 01bin | Reaction to PROFIBUS error: K-bus outputs become 0
 |  | 10bin | Reaction to PROFIBUS error: K-bus outputs remain unchanged
10 | 2-3 | 00bin | Reaction to K-bus error: DP data exchange is abandoned (default) (see K-bus interruption) | Standard
 |  | 01bin | Reaction to K-bus error: DP inputs set to 0
 |  | 10bin | Reaction to K-bus error: DP inputs remain unchanged
11 | 3-6 | X | Maximum length of the diagnostic data. Allowed values: 16, 24, 32, 40, 48, 56, 64 (see Terminal diagnosis) | Extended
12 | 0-1 | 0bin | If K-bus mode is synchronous: Standard synchronous mode (default) (see K-bus cycle) | Extended
 |  | 01bin | If K-bus mode is synchronous: synchronous mode with optimized input update (one cycle)
 |  | 10bin | If K-bus mode is synchronous: synchronous mode with optimized input update (two cycles)
12 | 4-7 | 0bin | Maximum DP buffer lengths not changed | Extended
12 | 4-7 | 15 | The maximum DP buffer lengths are changed using the values from UserPrmData 37-40 (see Multi-configuration mode) | Extended
13 | 0-7 | X | Delay time (in µs) high byte (see K-bus cycle) | Extended
14 | 0-7 | X | Delay time (in µs) low byte (see K-bus cycle) | Extended
15-30 | 0-7 | X | Assignment of Bus Terminals 1 to 64 (see Multi-configuration mode) | Extended
31-36 | 0-7 | - | Reserved | Extended
37 | 0-7 | X | Maximum length of the input data (see Multi-configuration mode) | Extended
38 | 0-7 | X | Maximum length of the output data (see Multi-configuration mode) | Extended
39 | 0-7 | X | Maximum length of the diagnostic data (see Multi-configuration mode) | Extended
40 | 0-7 | X | Maximum length of the configuration data (see Multi-configuration mode) | Extended
41-56 | 0-7 | X | Assignment of terminals 65 to 128 (see Multi-configuration mode) | Extended


Technical data - overview

Parameterization and commissioning [image] Technical data - overview
Technical data - overview
Description | BK3010 | BK3110 | BK3120 | BK3150 | BK3500 | BK3520 | LC3100 | BC3100
Number of Bus Terminals | 64 | 64 | 255 | 255 | 64 | 255 | 64 | 64
Baud rate [Mbaud] | 1,5 | 12 | 12 | 12 | 1,5 | 12 | 12 | 12
Physical basis | RS 485 | RS 485 | RS 485 | RS 485 | Optical fibers | Optical fibers | RS 485 | RS 485
UserPrm Data
DPV1 Services | x | x | x | x | x | x | x | x
Multi-configuration mode | x | x | x | x | x | x | x |
Word Align |  |  | x | x | x | x |  |
Byte oriented Bus Terminals |  |  | x | x | x | x |  | x
Distributed control
PLC IEC 6 1131-3 |  |  |  |  |  |  |  | x


Configuration

Parameterization and commissioning [image] Configuration
Configuration
Additional information
•
Configuration - CfgData
•
Configuration of the Coupler Modules
•
Configuration of Complex Modules
•
Configuration of Digital Modules
•
GSD Files
•
KS2000 - Introduction
•
Configuration via TwinCAT
•
Configuration with Siemens S7 controller


Configuration - CfgData

Parameterization and commissioning [image] Configuration [image] Configuration - CfgData
Configuration - CfgData
The CfgData is generated from the modules inserted in the DP configuration tool. When modules are added, the following rules are to be observed:
Sequence of DP modules to be added in the DP configuration tool
Modules for the coupler's functions
Complex function modules
Digital function modules
For TwinCAT applications, these rules are followed by the TwinCAT system manager. It adds the terminals or IE modules in the sequence in which they are plugged in, and the modules for functions are added automatically if the corresponding function is activated in the UserPrmData.


Configuration of the Coupler Modules

Parameterization and commissioning [image] Configuration [image] Configuration of the Coupler Modules
Configuration of the Coupler Modules
The DP modules for the following Bus Coupler functions are to be added first in the DP configuration tool if the associated function is activated (if the function is not activated, the corresponding DP module is not to be added):
Function module | Activation of the function
2-byte PLC Interface | The 2-byte PLC interface is activated via the UserPrmData (byte 5, bit 0). By default it is not active.
K-bus cycle counter | The K-bus cycle counter is activated via the UserPrmData (byte 3, bit 3). By default it is not active.
Dummy output byte | The dummy output byte is activated via the UserPrmData (byte 3, bit 5). By default it is not active.


Configuration of Complex Modules

Parameterization and commissioning [image] Configuration [image] Configuration of Complex Modules
Configuration of Complex Modules
After the DP modules for the activated functions of the Bus Coupler have been added to the Bus Coupler in the DP configuration tool, the next step is for the complex terminals (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) to be added in the sequence in which they are plugged in, regardless of whether digital terminals are plugged in between the complex terminals, or of how many there may be:
Complex function module | Description | Associated CfgData (as hex code)
KL1501 | KL1501 | 0xB4 (in GSD file)
 |  | 0xB5 (alternatively)
 |  | 0xF2 (alternatively)
KL2502 | KL2502 | 0xB5 (in GSD file)
 |  | 0xB2, 0xB2 (alternatively)
 |  | 0xF2 (alternatively)
KL2521 | KL2521 | 0xB2 (in GSD file)
 |  | 0xF1 (alternatively)
KL3351 compact | KL3351 - only the 16 bit input value is transmitted | 0x51 (in GSD file)
 |  | 0x50, 0x50 (alternatively)
KL3351 complex | KL3351 - 24 bits of input/output are transmitted, so that access can be had to the terminal's registers in addition to transmission of the 16 bit input value | 0xB5 (in GSD file)
 |  | 0xB2, 0xB2 (alternatively)
 |  | 0xF2 (alternatively)
KL3361 | KL3361 | 0xFB (in GSD file)
KL3xx2 compact | All KL3xx2 - only the 16 bit input value of each channel is transmitted | 0x51 (in GSD file)
 |  | 0x50, 0x50 (alternatively)
KL3xx2 complex | Old KL3xx2 - 24 bits of input/output are transmitted for each channel, so that access can be had to the terminal's registers in addition to transmission of the 16 bit input value | 0xB5 (in GSD file)
 |  | 0xB2, 0xB2 (alternatively)
 |  | 0xF2 (alternatively)
KL3xx4 compact | All KL3xx4 - only the 16 bit input value of each channel is transmitted | 0x53 (in GSD file)
 |  | 0x51, 0x51(alternatively)
 |  | 0x50, 0x50, 0x50, 0x50 (alternatively)
KL3xx4 complex | Old KL3xx4 - 24 bits of input/output are transmitted for each channel, so that access can be had to the terminal's registers in addition to transmission of the 16 bit input value | 0xBB (in GSD file)
 |  | 0xB5, 0xB5 (alternatively)
 |  | 0xB2, 0xB2, 0xB2, 0xB2 (alternatively)
 |  | 0xF5 (alternatively)
KL4xx2 compact | All KL4xx2 - only the 16 bit output value of each channel is transmitted | 0x61 (in GSD file)
 |  | 0x60, 0x60 (alternatively)
KL4xx2 complex | Old KL4xx2 - 24 bits of input/output are transmitted for each channel, so that access can be had to the terminal's registers in addition to transmission of the 16 bit input value | 0xB5 (in GSD file)
 |  | 0xB2, 0xB2 (alternatively)
 |  | 0xF2 (alternatively)
KL4xx4 compact | All KL4xx4 - only the 16 bit output value of each channel is transmitted | 0x63 (in GSD file)
 |  | 0x61, 0x61 (alternatively)
 |  | 0x60, 0x60, 0x60, 0x60 (alternatively)
KL4xx4 complex | Old KL4xx4 - 24 bits of input/output are transmitted for each channel, so that access can be had to the terminal's registers in addition to transmission of the 16 bit input value | 0xBB (in GSD file)
 |  | 0xB5, 0xB5 (alternatively)
 |  | 0xB2, 0xB2, 0xB2, 0xB2 (alternatively)
 |  | 0xF5 (alternatively)
Complex function module | Description | Associated CfgData (as hex code)
KL5001 compact | KL5001 - only the 32 bit input value is transmitted | 0x93 (in GSD file)
 |  | 0xD1 (alternatively)
KL5001 complex | KL5001 - 40 bits of input/output are transmitted, so that access can be had to the terminal's registers in addition to transmission of the 40 bit input value | 0xB4 (in GSD file)
 |  | 0xB5 (alternatively)
 |  | 0xF2 (alternatively)
KL5051 | KL5051 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5101 | KL5101 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5111 | KL5111 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5121 | KL5121 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5151 | KL5151 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5302 | KL5302 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6001 | KL6001 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6011 | KL6011 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6021 | KL6021 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6051 compact | KL6051 - only the 32 input bits and 32 output bits are transmitted | 0xB3 (in GSD file)
 |  | 0xF1 (alternatively)
KL6051 complex | KL6051 - 48 input bits and 48 output bits are transmitted, so that in addition to the 40 input bits and the 40 output bits, access can also be had to the terminal's registers | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6061 | KL6061 | 0xBA (in GSD file)
 |  | 0xF5 (alternatively)
KL6201 (PAB 6) | KL6201 - 6 bytes input and output process data is transferred (ASI slaves 1-11) | 0x35 (in GSD file)
KL6201 (PRM PAB 6) | KL6201 - 6 bytes parameter interface and 6 bytes input and output process data is transferred (ASI slaves 1-11) | 0xF2,0x35 (in GSD file)
KL6201 (PAB 16) | KL6201 - 16 bytes input and output process data is transferred (ASI slaves 1-31) | 0x3F (in GSD file)
KL6201 (PRM PAB 16) | KL6201 - 6 bytes parameter interface and 16 bytes input and output process data is transferred (ASI slaves 1-31) | 0xF2,0x3F (in GSD file)
KL6801 | KL6801 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL8001 | KL8001 | 0xBB (in GSD file)
 |  | 0xF5 (alternatively)


Configuration of Digital Modules

Parameterization and commissioning [image] Configuration [image] Configuration of Digital Modules
Configuration of Digital Modules
After the DP modules for the activated functions of the Bus Coupler and the complex terminals (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) have been added to the Bus Coupler in the DP configuration tool in the sequence in which they are plugged in, the digital terminals follow. In the case of digital terminals, it is only necessary for the total of the digital inputs and outputs of the modules that have been added to agree with the number of digital inputs and outputs that are plugged in:
Sample
4 x KL1408 = 32 digital input bits
2 x KL2408 = 16 digital output bits
3 x KL1114 = 12 digital input bits
2 x KL2114 = 8 digital output bits
4 x KL1012 = 8 digital input bits
1 x KL2012 = 2 digital output bits
=> 52 digital input bits and 26 digital output bits
The following combinations of DP modules could, for instance, now be added in the DP configuration tool to the Bus Coupler:
Alternative 1
8 digital input bits
8 digital input bits
8 digital input bits
8 digital input bits
8 digital input bits
8 digital input bits
8 digital input bits
8 digital output bits
8 digital output bits
8 digital output bits
8 digital output bits
Alternative 2
56 digital input bits
32 digital output bits
Other alternatives are possible, provided the total of digital inputs is 56 bits (the next number larger than 52 divisible by 8) and that the sum of the digital inputs is 32 bits (the next number larger than 26 divisible by 8).


GSD Files

Parameterization and commissioning [image] Configuration [image] GSD Files
GSD Files
GSD files are required for integrating the PROFIBUS couplers in DP configuration tools.
GSD files can be found online at http://www.beckhoff.com/english/download/bkconfg.htm
Note regarding GSD file
The GSD file contains a maximum of 244 bytes of input, output and configuration data. These are the maximum values. Below are the default of values and the setting options.
DP buffer | Default | Maximum size
Inputs | 128 | 244
Outputs | 128 | 244
Diagnostic Data | 64 | 64
Configuration data | 64 | 244
The sizes can be adjusted through the PrmData. The length is changed in 8-byte steps.
Sample
If it is desired to increase the size of the input data, other sizes must be reduced to compensate.
If we have 20 x 4 channel KL3314 thermocouples, then in compact mapping we find 20 Bus Terminals * 4 channels * 2 bytes per channel = 20 * 4 * 2 = 160 bytes
160 bytes is larger than the 128 byte default figure - settings must therefore be modified.
Set PrmData byte 12 bits 4-7 to 15dec or 0xFhex, set byte for 37 to 160 (input data) and byte 38 to 96 (output data).


KS2000 - Introduction

Parameterization and commissioning [image] Configuration [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Configuration via TwinCAT

Parameterization and commissioning [image] Configuration [image] Configuration via TwinCAT
Configuration via TwinCAT
The TwinCAT automation software is a complete automation solution for PC-compatible computers. TwinCAT turns any compatible PC into a real-time controller, an IEC 61131-3 Multi-PLC, NC positioning system, the corresponding programming environment and user interface. TwinCAT supports several different PROFIBUS DP PC cards. Beckhoff recommends the PROFIBUS DP PCI master card FC3101, which can also be obtained as a two-channel version (FC3102).
TwinCAT*System-Manager
The TwinCAT System Manager Tool is used to configure the FC310x PROFIBUS DP PCI card. The System Manager provides a representation of the number of programs of the TwinCat PLC systems, the configuration of the axis control and of the connected I/O channels as a structure, and organizes the mapping of the data traffic.
TwinCAT System Manager
For applications without TwinCAT PLC or NC, the TwinCAT System Manager configures the programming interfaces for a wide range of application programs:
▪
ActiveX control (ADS-OCX) for e.g. Visual Basic, Visual C++, Delphi, etc.
▪
DLL interface (ADS-DLL) for e.g. Visual C++ projects
▪
Script interface (ADS script DLL) for e.g. VBScript, JScript, etc.
The TwinCAT System Manager has the following properties:
▪
Bit-wise connection between server process images and I/O channels
▪
Standard data formats such as arrays and structures
▪
User defined data formats
▪
Continuous variable linking
▪
Drag and Drop
▪
Import and export at all levels
Procedure when configuring the PROFIBUS DP input/output modules
1.
The corresponding PROFIBUS DP master PC card is selected first, and inserted into the I/O configuration.
Configuration of the PROFIBUS DP I/O modules - selection of the PROFIBUS DP master PC card
2.
Following the master card, the bus nodes are then inserted:
Configuration of the PROFIBUS DP I/O modules - inserting the bus nodes
3.
The appropriate Bus Terminals are now inserted at the PROFIBUS DP Bus Coupler.
Configuration of the PROFIBUS DP I/O modules - appending the Bus Terminals


Configuration with Siemens S7 controller

Parameterization and commissioning [image] Configuration [image] Configuration with Siemens S7 controller
Configuration with Siemens S7 controller
Additional information
•
Configuration: Siemens S7 Controller
•
Configuration: Siemens S7 Controller BK3120


Configuration: Siemens S7 Controller

Parameterization and commissioning [image] Configuration [image] Configuration with Siemens S7 controller [image] Configuration: Siemens S7 Controller
Configuration: Siemens S7 Controller
Inserting the images
In order to assign an image to the devices in the Siemens software, they must be copied into the Step7 \ S7Data \ NcBmp directory.
Busklemn.bmp
Busklems.bmp
Inserting the GSD files
▪
Go to Extras \ Install new GSD in the hardware catalog for your Step7.
▪
Select the directory in which the Beckhoff GSD is located, and import the files.
▪
It can then be found in the hardware catalogue under PROFIBUS DP \ Further field devices \ I/O.


Configuration: Siemens S7 Controller BK3120

Parameterization and commissioning [image] Configuration [image] Configuration with Siemens S7 controller [image] Configuration: Siemens S7 Controller BK3120
Configuration: Siemens S7 Controller BK3120
Parameter data for the BK3120
Settings
Parameter data for the BK3120
Parameter data | Name
DPV1 service (class 1) | DPV1 Services
Reaction to Bus Terminal error | Reaction to Bus Terminal error
Terminal bus diagnostics | PROFIBUS diagnosis
Digital terminal diagnostic data | Digital Bus Terminal diagnostics
Data format | Data format
K-Bus mode | K-bus update
Fast FreeRun mode | Fast FreeRun mode
Reaction to DP errors | Reaction to fieldbus error
Reaction to K-bus errors | Reaction to K-bus errors
Configuration of the BK3120 module with digital inputs/outputs only
Sample 1:
1 x BK3120
10 x KL1xx4
1 x KL9100 (is not entered, as this Bus Terminal is entirely passive)
11 x KL2xx4
1 x KL9010 (is not entered, as this Bus Terminal is entirely passive)
The sum total of digital bytes must be added together and entered.
Digital inputs
10 x KL1xx4, i.e. 10 x 4 bits = 40 bits
40 bit / 8 = 5 bytes, i.e. enter 5 x 8 bit or 1 x 40 bit or 1 x 8 bit + 1 x 32 bit, etc. (see Fig. Example for entering individual bytes and Fig. Example for entering contiguous bytes)
Digital outputs
11 x KL2xx4, i.e. 10 x 4 bit = 44 bit
44 bit / 8 = 5.5 bytes, rounded up to 6 bytes, i.e. enter 6 x 8 bit or 1 x 48 bit or 1 x 8 bit + 1 x 40 bit etc. (see Fig. Example for entering individual bytes and Fig. Example for entering contiguous bytes)
Example for entering individual bytes.
Maximum config data
Each individual byte requires one byte of ConfigData. In the BK3120 a maximum of 64 bytes of configuration data is available.
Example for entering associated bytes.
Configuration of the BK3120 module with complex and digital input/outputs
Byte-oriented modules are the first to be mapped into the process image, and for this reason all the complex modules must first be entered in the sequence in which they are plugged into the Bus Coupler. For some byte-oriented Bus Terminals, it is possible to distinguish between compact and complex mapping.
Compact - only user data
Complex - user data plus status (for extended diagnosis) and control (for register communication)
Finally the digital signals are entered and rounded up to a whole byte.
Example 2.a:
1 x BK3120
2 x KL1012
1 x KL2022
1 x KL3312 compact mapping
1 x KL9010
Example for compact representation of the Bus Terminal KL3312
Example 2.b:
1 x BK3120
2 x KL1012
1 x KL2022
1 x KL3312 complex mapping
1 x KL9010
Example for compact representation of the Bus Terminal KL3312


PROFIBUS DP communication

PROFIBUS DP communication
PROFIBUS DP communication
Additional information
•
DataExchange - cyclic data exchange
•
DPV1 - acyclic data transfer


DataExchange - cyclic data exchange

PROFIBUS DP communication [image] DataExchange - cyclic data exchange
DataExchange - cyclic data exchange
Additional information
•
Process data, process image
•
K-bus Cycle


Process data, process image

PROFIBUS DP communication [image] DataExchange - cyclic data exchange [image] Process data, process image
Process data, process image
The Bus Coupler includes different memory areas, each having a capacity of 256 words. Telegrams passing over the Lightbus can specifically access any desired memory cell. The control and status bytes in the Lightbus telegrams can be used to distinguish between two relevant regions of the memory and to address them separately. In order to initiate a Bus Coupler update, the value in the control and status bytes must be 0x10, while the data byte must contain the constant 80hex. It is possible to access the Bus Coupler data after this. For this purpose the control and status byte contains the value 0x30. Two bytes can be written and two bytes can be read simultaneously with one access. The process is described in detail in the following sections.
After being switched on, the Bus Coupler determines the configuration of the inserted input/output terminals. The assignment of the physical slots for the input/output channels and the addresses in the process image is carried out automatically by the Bus Coupler.
The Bus Coupler creates an internal assignment list, in which the input/output channels have a specific position in the process image of the Bus Coupler. A distinction is made here according to inputs and outputs, and according to bit-oriented (digital) and byte-oriented (analog or complex) signal processing.
Two groups are created, one for inputs and the other for outputs. Each group has the byte-oriented channels in ascending sequence, starting from the lowest address, and these are followed by the bit-oriented channels.
Digital signals (bit-oriented)
The digital signals are bit-oriented. This means that one bit in the process image is assigned to each channel. The Bus Coupler creates a memory area containing the current input bits, and ensures that the bits in a second (output) memory area dedicated to the output channels are written out immediately, following the update command.
The details of the assignment of the input and output channels to the controller's process image is explained fully with the aid of an example in the appendix.
Analog signals (byte-oriented)
The processing of analog signals is always byte-oriented. Analog input and output values are represented in memory by two bytes each. Values are represented in SIGNED INTEGER format. The number 0 stands for the input/output value 0 V, 0 mA or 4 mA. The maximum value of an output or input value is represented, according to the standard settings, by 0x7FFF. The intermediate values are correspondingly proportional. A range with a resolution of 15 bits is not achieved for all inputs and outputs. If the actual resolution is 12 bits, the last three bits have no effect in outputs, while as inputs they are read as 0. Each channel also has a control and status byte. The control and status byte is the most significant byte in the most significant word. An analog channel is represented by 4 bytes in the process image, of which 3 bytes are used. In the BK3000 and BK4000 only 2 bytes are occupied in the process image of the corresponding bus system for each analog channel. The Bus Terminal's control and status bytes can also be included through appropriate configuration of the Bus Coupler and Bus Terminals.
Special signals and interfaces
The Bus Coupler supports Bus Terminals with other interfaces such as RS232, RS485, incremental encoder and others. These signals can be considered similarly to the analog signals named above. For some special signals the bit width of 16 is not sufficient. The Bus Coupler can support any byte width. It is necessary to consider how data consistency is ensured when accessing these values. This means that update commands must not be issued nor must the Bus Coupler be placed into the free running mode between the accesses.
Default assignment of the inputs and outputs to the process image
Once it has been switched on, the Bus Coupler finds out how many Bus Terminals are inserted, and creates an assignment list. The analog and digital channels, divided into inputs and outputs, are assembled into separate parts of this list. The assignment starts on the left next to the Bus Coupler. The software in the Bus Coupler collects consecutively the individual entries for each of the channels in order to create the assignment list counting from left to right. Four groups are distinguished in the assignment:
Group | Functional type of the channel | Assignment
1 | analog outputs | byte-wise
2 | digital outputs | bit-wise
3 | analog inputs | byte-wise
4 | digital inputs | bit-wise
All complex Bus Terminals are represented by analog inputs or outputs.
Overview of the distribution of the process image within the Bus Coupler
Output data in the Bus Coupler
Output data in the Bus Coupler
Input data in the Bus Coupler
Input data in the Bus Coupler


K-bus Cycle

PROFIBUS DP communication [image] DataExchange - cyclic data exchange [image] K-bus Cycle
K-bus Cycle
The K-bus cycle can be set to run freely (FreeRun mode) or synchronously (synchronous mode) with respect to the DP cycle. The K-bus cycle for the DP coupler consists of the following parts:
Configuration of the K-bus cycle for the DP couplers
The K-bus cycle time can be calculated with a precision of around 10 % using the following formula (4-channel terminals or terminals with more than 6 bytes data (exception: ASI terminal KL6201: more than 12 bytes of data) require two or more K-bus cycles).
Tcyc (in µs) = number of K-Bus cycles x (600 + number of digital channels x 2.5 + number of analog input channels x 32 + number of analog output channels x 42)
The K-bus cycle time can be read via DPV1. If TwinCAT is used, this is possible on the "Beckhoff" tab of the DP coupler in the System Manager.
K-bus modes
The K-bus mode (the type of synchronisation between the K-bus cycles and the DP cycle) is set via the UserPrmData:
Byte 9, bit 4 | Byte 9, bit 6 | Byte 12, bit 0 | Byte 12, bit 1 | K-bus mode
0bin | 1bin | 0bin | 0bin | Slow FreeRun
1bin | 1bin | 0bin | 0bin | Fast FreeRun
0bin | 0bin | 0bin | 0bin | Synchronous
0bin | 0bin | 1bin | 0bin | Synchronous with optimized input update, one cycle
0bin | 0bin | 0bin | 1bin | Synchronous with optimized input update, two cycles
FreeRun mode
Slow FreeRun (default setting)
In the FreeRun mode there is no synchronisation between the K-bus cycle and the DP cycle. It is a characteristic feature of the Slow FreeRun mode that the K-bus cycle is called from the main task. Acyclic communication or events result in heavy jitter in the K-bus cycle (KS2000, DPV1, terminal diagnosis, etc.), because all of these functions are also called from the main task.
K-bus - Slow FreeRun mode (default setting)
Fast FreeRun
To avoid the jitter resulting from acyclic communication or events and to achieve fast K-bus update times, the Fast FreeRun mode can be activated. The K-bus cycle is called by a higher priority task, controlled by a timer. At the end of the K-bus cycle the low-priority tasks (DPV1, KS2000 interface, etc.) are assigned computing time corresponding to 12.5 % of the preceding K-bus cycle duration, before the next K-bus cycle is started. In fast FreeRun mode therefore the inputs and outputs are up-to-date, but are not synchronized to the DP cycle:
K-bus mode fast FreeRun
Synchronous mode
As explained in the table above, there are three different synchronous modes.
Standard synchronous mode
In standard synchronous mode the K-bus cycle is always started immediately following reception of the Data_Exchange telegram from the DP master. The outputs are therefore generated as quickly as possible, while the input cycles are always one DP cycle old.
K-bus - standard synchronous mode
It is important here to ensure that the duration of the K-bus cycle plus approx. 20 % (to allow for the lower priority processes on the coupler) is shorter than the DP cycle time (which, under TwinCAT, means the cycle time of the associated task).
Synchronous mode with optimized input update (one cycle)
In optimized input update, the start of the K-bus cycle can be delayed following reception of the Data_Exchange telegram, so that the inputs are more up-to-date than they are in standard synchronous mode, whereas generation of the outputs is more severely delayed. It is important here to ensure that the duration of the K-bus cycle, plus the delay time, plus approx. 20 % (to allow for the lower priority processes on the coupler) is shorter than the DP cycle time (which, under TwinCAT, means the cycle time of the associated task).
K-bus - synchronous mode with optimized input update (one cycle)
The delay time is set by means of the UserPrmData (in µs, in Motorola format). The extended GSD file of the Bus Coupler is, however, necessary for this:
Byte | Value: Description
13 | Delay time (in µs) high byte
14 | Delay time (in µs) low byte
Synchronous mode with optimized input update (two cycles)
In the third mode of synchronous operation, the advantages of the other two operating modes are combined. Two K-bus cycles are carried out within one DP cycle. The first cycle begins immediately after reception of the Data_Exchange telegram from the master, which means that the outputs are generated as quickly as possible. The second cycle is started after a delay time that begins after completion of the first cycle has elapsed, so that the inputs are as recent as possible. It is important here to ensure that two times the duration of the K-bus cycle, plus the delay time, plus approx. 20 % (to allow for the lower priority processes on the coupler) is shorter than the DP cycle time (which, under TwinCAT, means the cycle time of the associated task).
K-bus - synchronous mode with optimized input update (two cycles)
The delay time is set by means of the UserPrmData (in µs, in Motorola format). The extended GSD file of the Bus Coupler is, however, necessary for this:
Byte | Description
13 | Delay time (in µs) high byte
14 | Delay time (in µs) low byte
Dummy output byte
The Bus Coupler's PROFIBUS DP ASIC can only generate an interrupt after reception of a Data_Exchange telegram if output data has been received. This means that at least one output byte must be transferred via DP in synchronous mode. If only input terminals are plugged in, and no output data is therefore present, a dummy output byte can be configured. It is activated in the UserPrmData, and must be entered as the module in the CfgData. The extended GSD file for the Bus Coupler is, however, necessary for this:
Byte | Bit | Value | Description
3 | 5 | 1bin | Dummy output byte activated
It is also necessary for the dummy output byte to be configured in the CfgData before the complex terminals:
CfgData | DP modules
0x20 | Dummy output byte
K-bus cycle counter
In order for the master to be able to check reliably whether precisely one (or two) K-bus cycles are always being carried out during one DP cycle, a K-bus cycle counter can be transferred in the input data from the Bus Coupler to the master. This is incremented after each K-bus cycle (0 is omitted, so that 1 follows after 255). The K-bus cycle counter must be activated in the UserPrmData and entered as a module in the CfgData. The extended GSD file for the Bus Coupler is, however, necessary for this:
Byte | Bit | Value | Description
3 | 3 | 1bin | K-bus cycle counter activated
It is also necessary for the K-bus cycle counter byte to be configured in the CfgData before the complex terminals:
CfgData | DP modules
0x10 | K-bus cycle counter


DPV1 - acyclic data transfer

PROFIBUS DP communication [image] DPV1 - acyclic data transfer
DPV1 - acyclic data transfer
Additional information
•
DPV1 Interface
•
Assignment of the DPV1 slot number
•
DPV1 at the coupler


DPV1 Interface

PROFIBUS DP communication [image] DPV1 - acyclic data transfer [image] DPV1 Interface
DPV1 Interface
By default, one MSAC_C1 connection and one MSAC_C2 connection with 52 bytes of data (4 bytes DPV1 header plus 48 bytes of user data) are supported. The MSAC_C1 connection is established along with cyclic connection, and can be activated via the UserPrmData:
Byte | Bit | Value: Description
0 | 7 | 1: MSAC_C1 connection is activated
The MSAC_C2 connection can be used either by the C1 master (which communicates with the slave cyclically) or by a C2 master (which then only communicates with the slave acyclically), and has its own establishment of connection. The parameters at the establishment of the MSAC_C2 connection (Feature_Supported, Profile_Feature_Supported, Profile_Ident_Number, etc.) are not examined, and the parameters of the request are mirrored in the response.
Slot_Number = 0 addresses PROFIBUS coupler data, Slot_Number > 0 addresses the data of the function module(s).
PROFIBUS coupler data (Slot_Number = 0)
The data associated with the PROFIBUS coupler is addressed via an index:
Index | Access | Description
1-2 | R/W | Module assignment in multi-configuration mode
5 | R | Firmware information
9-19 | R/W | Device configuration (Table 9)
90 | R | K-bus status (Table 90)
98 | R/W | Internal cycle time
99 | W | Commands: local bus reset, starting or stopping the internal cycle time measurement
Function module data (Slot_Number > 0)
Depending on the type of function module, access is made either to the registers (max. 4 channels, each with 64 registers) or to the parameters (only supported by a few function modules, where the quantity of data is insufficient for the register model)
Accessing registers
Index | Access | Length | Description
0-63 | R(/W) | 2 | Registers 0-63 of the channel 1 in the function module
64-127 | R(/W) | 2 | Registers 0-63 of the channel 2 in the function module
128-191 | R(/W) | 2 | Registers 0-63 of the channel 3 in the function module
192-254 | R(/W) | 2 | Registers 0-63 of the channel 4 in the function module
Accessing parameters
Index | Access | Length | Description
0 | R(/W) | 4-32 (must be divisible by 4) | Parameters 0x0000-0x0007 of the function module
1 | R(/W) | 4-32 (must be divisible by 4) | Parameters 0x0008-0x000F of the function module
... | ... | ... |
127 | R(/W) | 4-32 (must be divisible by 4) | Parameters 0x03F8-0x03FF of the function module


Assignment of the DPV1 slot number

PROFIBUS DP communication [image] DPV1 - acyclic data transfer [image] Assignment of the DPV1 slot number
Assignment of the DPV1 slot number
The Slot_Number = 0 addresses the data of the Bus Coupler, while Slot_Number > 0 addresses the data (registers or parameters (KL6201)) of the complex terminals:
Device | Slot number = 0 | Slot number > 0
BK3120, BK3150, BK3500, BK3520 | Data in Bus Coupler | Slot_Number = 1: first complex terminal plugged into the Bus Coupler (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) Slot_Number = 2: second complex terminal plugged into the Bus Coupler (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) etc.
BK3x10/LC3100 | Data in Bus Coupler | Not present, because neither the BK3x10 nor the LC3100 support complex terminals.


DPV1 at the coupler

PROFIBUS DP communication [image] DPV1 - acyclic data transfer [image] DPV1 at the coupler
DPV1 at the coupler
Additional information
•
Module Assignment
•
Firmware Information
•
Terminal Composition
•
K-bus status
•
Cycle Time Measuring


Module Assignment

PROFIBUS DP communication [image] DPV1 - acyclic data transfer [image] DPV1 at the coupler [image] Module Assignment
Module Assignment
The multi-configuration mode is possible with a maximum of 128 modules (terminals, IE modules, etc.). The specification of which of the modules configured in the CfgData are indeed inserted can be written with DPV1 Write and read with DPV1 Read.
Slot number | Index | Length | Data | Description
0 | 1 | 1-15 | Byte 0 (bit 0,1) | Assignment of module 1 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | Byte 0 (bit 2,3) | Assignment of module 2 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | Byte 0 (bit 4,5) | Assignment of module 3 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | Byte 0 (bit 6,7) | Assignment of module 4 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | Byte 1 (bit 0,1) | Assignment of module 5 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | ... |
 |  |  | Byte 15 (bit 6,7) | Assignment of module 64 0: DP DataExchange (default) 2: disabled (configured module missing)
 | 2 | 1-15 | Byte 0 (bit 0,1) | Assignment of module 65 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | Byte 0 (bit 2,3) | Assignment of module 66 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | Byte 0 (bit 4,5) | Assignment of module 67 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | Byte 0 (bit 6,7) | Assignment of module 68 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | Byte 1 (bit 0,1) | Assignment of module 69 0: DP DataExchange (default) 2: disabled (configured module missing)
 |  |  | ... |
 |  |  | Byte 15 (bit 6.7) | Assignment of module 128 0: DP DataExchange (default) 2: disabled (configured module missing)


Firmware Information

PROFIBUS DP communication [image] DPV1 - acyclic data transfer [image] DPV1 at the coupler [image] Firmware Information
Firmware Information
The following firmware information can be read through DPV1. The data is transferred in Intel format (low byte first):
Slot number | Index | Byte | Description
0 | 5 | 0-1 | Bus Coupler number
 |  | 2-3 | Software version
 |  | 4-5 | Manufacturer type (table 0, register 245)
 |  | 6-7 | Coupler type (table 0, register 246)
 |  | 8-9 | Bus Coupler type (table 0, register 247)
 |  | 10-11 | reserved


Terminal Composition

PROFIBUS DP communication [image] DPV1 - acyclic data transfer [image] DPV1 at the coupler [image] Terminal Composition
Terminal Composition
The terminal composition can be read by DPV1. A word is transmitted for each terminal containing the terminal number for complex terminals (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx), and the length and type information for digital terminals:
Bit | Value | Description
0 | 1bin | Digital terminal has inputs
1 | 1bin | Digital terminal has outputs
2-7 | - | reserved
8-14 | X | Length in bits
15 | 1bin | Always 1bin (indicates that the terminal is digital)
Reading the terminal composition
The terminal composition is represented in the DPV1 addressing as follows:
Slot number | Index | Byte | Description
0 | 9 | 0-1 | Number of the Bus Coupler
 |  | 2-3 | Value for terminal 1
 |  | ... | ...
 |  | 46-47 | Value for terminal 23
 | 10 | 0-1 | Value for terminal 24
 |  | ... | ...
 |  | 46-47 | Value for terminal 47
 | 11 | 0-1 | Value for terminal 48
 | ... | ... | ...
 | 18 | 46-47 | Value for terminal 239
 | 19 | 0-1 | Value for terminal 240
 |  | ... | ...
 |  | 30-31 | Value for terminal 255
Checking the terminal composition
The same data can also be accessed by a DPV1 Write. In this case the Bus Coupler compares the value that has been written with the true value, returning a negative DPV1 Write response if the data does not agree. This permits more precise checking of the terminal configuration than is possible by checking the CfgData. The length must match the actual length of table 9. The calculation should include two bytes for each terminal with process data. The Bus Coupler ID in register 0 of table 9 is not taken into account.
Error codes in the write response
Error_Code_1 | Error_Code_2
0xBE | Number of terminals
0xBF | First faulty byte in the written data


K-bus status

PROFIBUS DP communication [image] DPV1 - acyclic data transfer [image] DPV1 at the coupler [image] K-bus status
K-bus status
The K-bus status can be read through DPV1. The data is transferred in Intel format (low byte first):
Slot number | Index | Byte | Description
0 | 90 | 0-1 | Bit 0: Fieldbus errors
 |  |  | Bit 1: K-bus error
 |  |  | Bit 2: Error on the Bus Terminal
 |  |  | Bit 3: Coupler error
 |  | 2-3 | In the presence of a coupler error: Error code
 |  | 4-5 | K-bus error = 0: Bit length of the K-bus
 |  |  | K-bus error = 1: K-bus error code (-> Diagnostic data)
 |  | 6-7 | K-bus error = 0: Number of terminals
 |  |  | K-bus error = 1: Bus Terminal number following which the K-bus error is detected (-> Diagnostic data)


Cycle Time Measuring

PROFIBUS DP communication [image] DPV1 - acyclic data transfer [image] DPV1 at the coupler [image] Cycle Time Measuring
Cycle Time Measuring
The duration of the process data cycle can be measured with DPV1.
The cycle time measurement is started or stopped using DPV1 Write:
Slot number | Index | Length | Data | Description
0 | 99 | 4 | Byte 0: 0x04 | Start the cycle time measurement
 |  |  | Byte 1: 0x01
 |  |  | Byte 2: 0x01
 |  |  | Byte 3: 0x00
0 | 99 | 4 | Byte 0: 0x04 | Stop the cycle time measurement
 |  |  | Byte 1: 0x01
 |  |  | Byte 2: 0x00
 |  |  | Byte 3: 0x00
The minimum, maximum, mean (of the last 200 cycles) and current cycle time can be read with DPV1 Read and reset with DPV1 Write:
Slot number | Index | Length | Data | Description
0 | 98 | 8 | Byte 0, 1 | Minimum cycle time in µs (INTEL format, low byte first)
 |  |  | Byte 2, 3 | Maximum cycle time in µs (INTEL format, low byte first)
 |  |  | Byte 4, 5 | Mean cycle time in µs (INTEL format, low byte first)
 |  |  | Byte 6, 7 | Current cycle time in µs (INTEL format, low byte first)


Diagnostics and error handling

Diagnostics and error handling
Diagnostics and error handling
Additional information
•
LEDs
•
DP diagnostics
•
K-bus diagnosis


LEDs

Diagnostics and error handling [image] LEDs
LEDs
The Bus Coupler has two groups of LEDs for the display of status. The upper group (BK3xx0) or left hand group (LC3100) indicates the state of the fieldbus.
On the upper right hand side of the BK3xx0 Bus Coupler are two more green LEDs that indicate the supply voltage. The left hand LED indicates the presence of the 24 V supply for the Bus Coupler. The right hand LED indicates the presence of the supply to the power contacts. The two K-Bus LEDs (I/O RUN, I/O ERR) are located under the fieldbus LEDs. These indicate the operational state of the Bus Terminals and the connection to these Bus Terminals.
Fieldbus LEDs
The upper three LEDs (or the two LEDs on the left) indicate the operating state of the PROFIBUS communication:
LEDs BK3120 and BK3150
BK3xx0
I/O RUN | BF | DIA | Meaning | Remedy
on | off | off | Operating state: RUN, inputs are read and outputs are set | Everything is operating correctly
on | on | off, blinking | 1. Bus activity, but slave is already parameterized | Start master
 |  |  | 2. Bus error with reaction to PROFIBUS error: a.) K-bus outputs become 0 or b.) K-bus outputs are retained | Check parameters, configuration (possible error in DP start-up)
off | off | off | Data exchange with the master is not started | PLC start
off | on | on | No bus activity | Start the master, check the bus cable
off | on | off, blinking | Bus error with reaction to PROFIBUS error: K-bus cycle is stopped | Start master, check parameters, configuration (possible error in DP start-up)
DIA-LED blink codes
If an error occurs in the paramétrisation or configuration during DP start-up, this is indicated both through the fieldbus LEDs and in the diagnostic data.
Flashing Code
fast blinking | Start of the error code
First slow sequence | Error code
Second slow sequence | Error argument (error location)
LEDs LC3100
LC3100
I/O RUN | BF | RUN | Meaning | Remedy
on | off | on | Operating state: RUN, inputs are read and outputs are set | Everything is operating correctly
on | on, blinking | on | 1. Bus activity, but slave is already parameterized | Start master
 |  |  | 2. Bus error with reaction to PROFIBUS error: a.) K-bus outputs become 0 or b.) K-bus outputs are retained | Check parameters, configuration (possible error in DP start-up)
off | off | on | Data exchange with the master is not started | PLC start
off | on | off | No bus activity | Start the master, check the bus cable
off | on, blinking | on | Bus error with reaction to PROFIBUS error: K-bus cycle is stopped | Start master, check parameters, configuration (possible error in DP start-up)
K-bus LEDs (local errors)
Two LEDs, the K-bus LEDs, indicate the operational state of the Bus Terminals and the connection to these Bus Terminals. The green LED (I/O RUN) lights up in order to indicate fault-free operation. The red LED (I/O ERR) flashes with two different frequencies in order to indicate an error. The errors are displayed in the blink code in the following way:
Error type
Error code | Error code argument | Description | Remedy
Persistent, continuous flashing | - | general K-bus error | Check the Bus Terminal strip
1 pulse | 0 | EEPROM checksum error | Set manufacturer’s setting with the KS2000 software
 | 1 | Inline code buffer overflow | Connect fewer Bus Terminals; too many entries in the table for the programmed configuration
 | 2 | Unknown data type | Software update required for the coupler
2 pulses | 0 | Programmed configuration incorrect | Check programmed configuration for correctness
 | n>0 | Incorrect table entry Bus Coupler / incorrect table comparison (Bus Terminal n) | Correct table entry / Bus Coupler
3 pulses | 0 | K-bus command error | No Bus Terminal connected; attach Bus Terminals
 |  |  | One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses | 0 n | K-bus data error, break behind Bus Coupler n | Check whether the n+1 Bus Terminal is correctly connected; replace if necessary. Check whether the End Terminal 9010 is connected.
5 pulses | n | K-bus error in register communication with Bus Terminal n | Replace Bus Terminal n
7 pulses | n | BK3x10 or LC3100: unsupported Bus Terminal detected at location n | Only use digital (bit oriented) Bus Terminals, or use a BK3120 Bus Coupler
Error code | Error code argument | Description | Remedy
9 pulses | 0 | Checksum error in program flash memory | Set manufacturer's setting with the KS2000
13 pulses | 0 | Runtime K-bus command error | One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
14 pulses | n | Bus Terminal n has the wrong format | Start the coupler again, and if the error occurs again then exchange the Bus Terminal
15 pulses | n | Number of Bus Terminals is no longer correct | Start the coupler again, and if the error occurs again after this, use the KS2000 software to set manufacturer’s settings
16 pulses | n | Length of the K-bus data (bit length) is no longer correct. n = bit length after booting
17 pulses | n | Number of Bus Terminals is no longer correct. n = number of Bus Terminals after booting
18 pulses | n | Bus Terminal identifier no longer correct after reset (n = Bus Terminal number).
Error location
The number of pulses indicates the position of the last Bus Terminal before the fault. Passive Bus Terminals, such as a power feed terminal, are not included in the count.


DP diagnostics

Diagnostics and error handling [image] DP diagnostics
DP diagnostics
Additional information
•
DP Diagnostic Data (DiagData)
•
Errors during DP Start-up
•
Reaction to PROFIBUS Error


DP Diagnostic Data (DiagData)

Diagnostics and error handling [image] DP diagnostics [image] DP Diagnostic Data (DiagData)
DP Diagnostic Data (DiagData)
The DP diagnostic data consists of six bytes of DP standard diagnosis, along with up to 238 bytes of device-specific diagnostic data. The device-specific diagnostic data for Beckhoff slaves is represented in the DPV1 status message.
When the DP diagnostic data changes, the slave reports this fact to the master, and the master will automatically fetch the changed diagnostic data. This means that DP diagnostic data is not included in the DP process data in real-time, but is always sent to the controller a few cycles later.
In TwinCAT the DP diagnostic data is read from the DP Master interface (FC310x, CX1500-M310) using ADS (see the section describing Slave Diagnosis in the FC310x documentation).
DP standard diagnostic data
Offset | Meaning
0x00.0 | StationNonExistent: slave did not reply to the last telegram
0x00.1 | StationNotReady: slave still processing the Set_Prm / Chk_Cfg telegram
0x00.2 | CfgFault: slave signaling a configuration error
0x00.3 | ExtDiag: extended DiagData available and valid
0x00.4 | NotSupported: slave does not support a feature requested via Set_Prm or Global_Control
0x00.5 | InvalidSlaveResponse: slave response not DP-compatible
0x00.6 | PrmFault: slave reports a paramétrisation error
0x00.7 | MasterLock: slave currently exchanging data with another master
0x01.0 | PrmReq: re-parameterize and reconfigure slave
0x01.1 | StatDiag: slave signaling static diagnosis / DPV1 slave application not yet ready for data exchange
0x01.2 | PROFIBUS DP slave
0x01.3 | WdOn: DP watchdog on
0x01.4 | FreezeMode: DP slave in freeze mode
0x01.5 | SyncMode: DP slave in sync mode
0x01.6 | reserved
0x01.7 | Deactivated: DP slave has been deactivated
0x02.0 | reserved
0x02.1 | reserved
0x02.2 | reserved
0x02.3 | reserved
0x02.4 | reserved
0x02.5 | reserved
0x02.6 | reserved
0x02.7 | ExtDiagOverflow: too much extended data present
0x03 | MasterAdd: station address of master with which slave is exchanging data
0x04,0x05 | IdentNumber
from 0x06 | Device-specific diagnostic data (extended DiagData)
Device-specific diagnostic data (DPV1 status message)
The meaning of the first 4 bytes of the DPV1 status message is specified by the DPV1 standard, while the bytes that follow are manufacturer-specific.
Byte | Bit | Description
6 | 0-7 | The length of the DPV1 status message (including this byte)
7 | 0-7 | StatusType: the StatusType identifies the format of the diagnostic data starting at byte 16 (0x81: max. 64 modules, 0xA1: more than 64 modules)
8 | 0-7 | SlotNumber: always 0
9 | 0-7 | Specifier: always 0
10 | 0 | EEPROM checksum error (can be cleared by setting the manufacturers setting through KS2000 or DPV1, followed by a power off/power on cycle)
10 | 4 | Unknown module type
10 | 5 | The length of the CfgData is too great (too many modules are inserted)
10 | 6 | The length of the DP input data is too great (too many modules are inserted)
10 | 7 | The length of the DP output data is too great (too many modules are inserted)
11 | 0-7 | Error on an internal bus (K-bus, IP-Link, etc.)
12 | 0-7 | Error code on an internal bus (K-bus, IP-Link, etc.)
13 | 0-7 | Error argument on an internal bus (K-bus, IP-Link, etc.)
14 | 0-7 | DP start-up error code
15 | 0-7 | DP start-up error argument
Errors in the modules (terminals, IP modules, IE module, etc.)
Diagnosis of the modules must be activated through the UserPrmData.
Couplers with a maximum of 64 possible modules
Byte | Bit | Description
16 | 0-5 | Module number (0-63) with an error (bit 6 of the status bytes is set, except for the serial interface modules (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022), where bit 3 of the status byte is set)
16 | 6-7 | Associated channel number (0-3)
17 | 0-7 | Status byte of the faulty channel (bits 0-7)
18 | 0-5 | Module number (0-63) with an error (bit 6 of the status bytes is set, except for the serial interface modules (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022), where bit 3 of the status byte is set)
18 | 6-7 | Associated channel number (0-3)
19 | 0-7 | Status byte of the faulty channel (bits 0-7)
... | ... | ...
60 | 0-5 | Module number (0-63) with an error (bit 6 of the status bytes is set, except for the serial interface modules (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022), where bit 3 of the status byte is set)
60 | 6-7 | Associated channel number (0-3)
61 | 0-7 | Status byte of the faulty channel (bits 0-7)
Couplers with a maximum of more than 64 possible modules
Byte | Bit | Description
16 | 0-7 | Module number (1-255) with an error (bit 6 of the status bytes is set, except for the serial interface modules (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022), where bit 3 of the status byte is set)
17 | 6-7 | Associated channel number (0-3)
17 | 0-5 | Status byte of the faulty channel (bits 0-5)
18 | 0-7 | Module number (1-255) with an error (bit 6 of the status bytes is set, except for the serial interface modules (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022), where bit 3 of the status byte is set)
19 | 6-7 | Associated channel number (0-3)
19 | 0-5 | Status byte of the faulty channel (bits 0-5)
... | ... | ...
60 | 0-7 | Module number (1-255) with an error (bit 6 of the status bytes is set, except for the serial interface modules (KL6001, KL6011, KL6021, IP6002, IP6012, IP6022, IE6002, IE6012, IE6022), where bit 3 of the status byte is set)
61 | 6-7 | Associated channel number (0-3)
61 | 0-5 | Status byte of the faulty channel (bits 0-5)


Errors during DP Start-up

Diagnostics and error handling [image] DP diagnostics [image] Errors during DP Start-up
Errors during DP Start-up
If an error occurs in the paramétrisation (UserPrmData) or configuration (CfgData) during DP start-up, this is indicated both through the fieldbus LEDs and in the diagnostic data (DiagData).
Possible DP start-up errors are identified by an error code and an error argument.
Errors when checking the UserPrmData
Error code 1
Error code 1 indicates that a reserved bit in the UserPrmData has been set to an incorrect value, or that the function corresponding to the bit in the UserPrmData is not supported. The error argument describes which UserPrmData byte has been detected as containing an error (the offset of the faulty byte + 1).
Error code 3
Error code 3 indicates that a combination of functions selected in the UserPrmData is not allowed. The error argument describes the impermissible combination.
Error code argument | Description
1 | The Reaction to DP error cannot be set to "Outputs unchanged" in synchronous mode
2 | The DPV1-MSAC_C1 connection has been activated by the master, but no DPV1-MSAC_C1 connection is defined
6 | The Multi-configuration mode is not allowed if Checking the CfgData is switched off
8 | Synchronous mode may only be activated when at least one DP output byte is configured
10 | The optimized input cycle is only possible in synchronous mode
11 | The length of the DP buffer exceeds the size of the DP RAM in the PROFIBUS ASIC
12 | Fast-FreeRun mode may not be activated together with synchronous mode
Errors when checking the CfgData
Error code 2
Error code 2 indicates that a byte in the CfgData is not correct. The error argument describes which CfgData byte has been detected as containing an error (the offset of the faulty byte + 1).
Error code 5
Error code 5 indicates that the length of the digital outputs (in bytes) calculated from the CfgData is not correct. The error argument contains the expected byte length.
Error code 6
Error code 6 indicates that the length of the digital inputs (in bytes) calculated from the CfgData is not correct. The error argument contains the expected byte length.
Error code 7
Error code 7 indicates a variety of errors when checking the CfgData. The error argument describes the error.
Error argument | Description
1 | The length of the CfgData received is not correct
2 | The syntax of the CfgData received is not correct
3 | The length of the DP input data that has been calculated from the CfgData is too large
4 | The length of the DP output data that has been calculated from the CfgData is too large
5..12 | Reserve
13 | Maximum input length exceeded
14 | Maximum output length exceeded
15 | Maximum diagnostic data length exceeded (64 bytes) or value below minimum diagnostic data length (16 bytes)
16 | Maximum config data length exceeded (240 bytes) or value below minimum config data length (1 byte)
17 | Maximum parameter data length exceeded (224 bytes) or value below minimum parameter data length (64 bytes)
Errors during slave start-up
Error code 8
Error code 8 indicates that the length of the DP buffer is greater than the size of the DP RAM in the PROFIBUS ASIC. The error argument contains the difference (divided by 8). DP communication is deactivated.
Error code 9
Error code 9 indicates a variety of errors that may be detected as the device boots. The error argument describes the error.
Error argument | Description
1 | The length of the DP input data is too great (too many modules are inserted)
2 | The length of the DP output data is too great (too many modules are inserted)
3 | The length of the CfgData is too great (too many modules are inserted)
Error code 10*
Error during the register communication. The settings to be written via the UserPrm data were executed incorrectly.
Error argument | Description
x | Problems with terminal x
Error code 11*
Error during the register communication. The settings to be written via the UserPrm data were aborted with a timeout.
Error argument | Description
x | Problems with terminal x
* Only for BK3120 or BK3150 with the GSD file and slot-oriented mapping (E312BECE.GS? or E315BECE.GS?)


Reaction to PROFIBUS Error

Diagnostics and error handling [image] DP diagnostics [image] Reaction to PROFIBUS Error
Reaction to PROFIBUS Error
A PROFIBUS error (failure of the master, withdrawal of the PROFIBUS plug etc.) is detected after the DP watchdog has elapsed (usually in the region of 100 ms, unless this has been deactivated in the master) or by bus timeout (the baud rate supervision time is set to 10 s).
The reaction at the output data of the coupler can be set in the UserPrmData:
Byte | Bit | Value | Description
10 | 0-1 | 00bin | Reaction to PROFIBUS error: K-bus cycle is abandoned (default, digital outputs become 0, complex outputs are set to a planned substitute value)
 |  | 01bin | Reaction to PROFIBUS error: K-bus outputs become 0
 |  | 10bin | Reaction to PROFIBUS error: K-bus outputs remain unchanged


K-bus diagnosis

Diagnostics and error handling [image] K-bus diagnosis
K-bus diagnosis
Additional information
•
K-bus interruption
•
Terminal Diagnostics


K-bus interruption

Diagnostics and error handling [image] K-bus diagnosis [image] K-bus interruption
K-bus interruption
If the K-bus is interrupted, or suffers from a relatively long malfunction, the coupler enters the K-bus error state. Depending on the setting made for Reaction to K-Bus error in the UserPrmData, the coupler abandons DP data exchange and sets the Stat_Diag bit in the diagnostic data at the next DP start-up (with the consequence that DP data exchange is not carried out), sets the DP inputs to 0, or leaves the DP inputs unchanged.
Byte | Bit | Value | Description
10 | 2-3 | 00bin | Reaction to K-bus error: DP data exchange is abandoned (default)
 |  | 01bin | Reaction to K-bus error: DP inputs set to 0
 |  | 10bin | Reaction to K-bus error: DP inputs remain unchanged
When the interruption or malfunction on the K-bus has been rectified, the setting of Response to K-bus error in the UserPrmData determines whether the K-bus error state is left manually (by means of a K-bus reset), or automatically:
Byte | Bit | Value | Description
7 | 0 | 0bin | Response to K-bus error: manual K-bus reset (default)
 |  | 1bin | Response to K-bus error: automatic K-bus reset
Signaling the K-bus error
A K-bus error is indicated both on the I/O-ERR LED and in the DPV1 status message in the DP diagnostic data (bytes 11-13).
Byte | Bit | Description
11 | 0 | too many K-bus command errors
11 | 1 | too many K-bus timeouts
11 | 2 | too many K-bus receive errors
11 | 3 | too many K-bus transmit errors
11 | 4 | K-bus reset error
11 | 5 | general K-bus error
12 | 0-7 | K-bus error code
13 | 0-7 | K-bus error argument
K-bus reset
A K-bus reset can be carried out manually by means of a DPV1 Write:
Slot number | Index | Byte | Value
0 | 99 | 0 | 2
 |  | 1 | 1
 |  | 2 | 0
 |  | 3 | 0


Terminal Diagnostics

Diagnostics and error handling [image] K-bus diagnosis [image] Terminal Diagnostics
Terminal Diagnostics
If terminal diagnosis has been activated, then each channel of a complex terminals is examined to see whether bit 6 in the status has changed (exceptions are the KL6001, KL6011 and KL6021, where the relevant bit is bit 3), and whether the diagnostic bit of each channel of a digital terminal with diagnostics (KL12x2 or KL22x2) has changed. If that is the case, the existence of new diagnostic data is reported to the master, and two bytes of diagnostic information starting at byte 16 of each channel for which a diagnosis is pending are inserted (see Diagnostic data).
Terminal diagnosis can be activated in the UserPrmData:
Byte | Bit | Value | Description
7 | 1 | 1bin | Terminal diagnosis is active
Digital terminal diagnosis
By default, the diagnostic bits for the digital terminals that have diagnosis (KL12x2 and KL22x2) are transmitted cyclically in the process image. These terminals occupy 4 bits each in both the input and output data. If terminal diagnosis is active, then UserPrmData can be used to specify that only the I/O data for the digital terminals with diagnosis (KL12x2: 2 bit inputs, KL22x2: 4 bit outputs) is to be included in the cyclic process image transfer:
Byte | Bit | Value | Description
7 | 4 | 1bin | Diagnostic data of digital terminals not in the cyclic process image
Real-time capacity of the diagnostic data
When making use of terminal diagnosis, it should always be borne in mind that the diagnostic data always reaches the controller at least one cycle later, and that as a rule access also takes place through different mechanisms from those used for cyclic process data. This means that process data can already be faulty, but the controller program is only informed of this in the following cycle or the one after that. If the diagnostic bits of digital terminals with diagnostics or the status of complex terminals are mapped to the process image, the control program always has a consistent state between process and diagnostic data. The appropriate setting therefore depends on the way that the diagnosis is to be used. If it is only intended for diagnostic display, transmission within the cyclic process data is unnecessary, but if on the other hand consistency between the process data and the diagnostic data is desired, then the diagnostic data should be transmitted along with the cyclic process data.
Maximum diagnosis data length
If more diagnostic terminal data are active than specified in the maximum diagnostic data length, the ExtDiagOverflow bit of the standard diagnostic data is set. Since older controllers have trouble handling the maximum diagnostic data length of 64 bytes (default setting), the maximum diagnostic data length can be limited in UserPrmData:
Byte | Bit | Description
11 | 3-6 | Maximum length of the diagnostic data. Allowed values: 16, 24, 32, 40, 48, 56, 64
It is only possible to set the maximum diagnostic data length in text form in the extended GSD file.


Extended functions

Extended functions
Extended functions
Additional information
•
2-byte PLC Interface
•
Word Alignment
•
Deactivating the CfgData Check
•
Multi-Configuration Mode
•
Changing the Size of the Process Data
•
Bus Coupler versions in multi-configuration mode


2-byte PLC Interface

Extended functions [image] 2-byte PLC Interface
2-byte PLC Interface
Checking the CfgData can be deactivated if a DP master is not capable of operating with the modules listed in the GSD file. In that case the master can send any CfgData, and as many inputs and outputs are transferred as are described by the CfgData.
Deactivation of the CfgData checking can also be useful if a specific address range is to be reserved in the PLC for future extensions. In that case, more input and output data is to be transferred than is in fact necessary.
Deactivation of the CfgData check can be set in the UserPrmData:
Byte | Bit | Value | Description
1 | 0 | 1bin | CfgData checking is deactivated
In general, the I/O data from the modules (terminals or IE modules) is written by the coupler in the standard sequence (first the complex, then the digital modules), as is also the case for other fieldbus couplers; this has already been described in connection with the structure of the process image in the coupler. The decision on a module-to-module basis as to whether the module is mapped in compact or complex form, which would otherwise be possible under DP, is omitted when CfgData checking is deactivated. In that case, the setting made in the UserPrmData applies to all modules:
The compact or complex mapping can be set in the UserPrmData:
Byte | Bit | Value | Description
9 | 2 | 0bin | Analog modules are mapped in compact form (only with the input or output user data)
 |  | 1bin | Analog modules are mapped in complex form (including control/status for register access and the same data length in the inputs and outputs)
The extended GSD file must be used to deactivate CfgData checking and to specify compact/complex mapping textually in the master's configuration tool.


Word Alignment

Extended functions [image] Word Alignment
Word Alignment
In order to obtain the I/O data in the controller's process image in a clear form in controllers with word-oriented process images, it is possible to specify that word alignment is used when the coupler generates its process image. This involves a dummy byte being inserted for every variable that is larger than one byte and which would start on an uneven address.
Word alignment can be set in the UserPrmData:
Byte | Bit | Value | Description
9 | 5 | 1bin | Word alignment is active
When using the DP modules it is necessary to ensure that only those complex modules that are identified with word alignment are used.
The extended GSD file must be used in order to set word alignment in text form in the master's configuration tool and to be able to select the word alignment module.


Deactivating the CfgData Check

Extended functions [image] Deactivating the CfgData Check
Deactivating the CfgData Check
Checking the CfgData can be deactivated if a DP master is not capable of operating with the modules listed in the GSD file. In that case the master can send any CfgData, and as many inputs and outputs are transferred as are described by the CfgData.
Deactivation of the CfgData checking can also be useful if a specific address range is to be reserved in the PLC for future extensions. In that case, more input and output data is to be transferred than is in fact necessary.
Deactivation of the CfgData check can be set in the UserPrmData:
Byte | Bit | Value | Description
1 | 0 | 1bin | CfgData checking is deactivated
In general, the I/O data from the modules (terminals or IE modules) is written by the coupler in the standard sequence (first the complex, then the digital modules), as is also the case for other fieldbus couplers; this has already been described in connection with the structure of the process image in the coupler. The decision on a module-to-module basis as to whether the module is mapped in compact or complex form, which would otherwise be possible under DP, is omitted when CfgData checking is deactivated. In that case, the setting made in the UserPrmData applies to all modules:
The compact or complex mapping can be set in the UserPrmData:
Byte | Bit | Value | Description
9 | 2 | 0bin | Analog modules are mapped in compact form (only with the input or output user data)
 |  | 1bin | Analog modules are mapped in complex form (including control/status for register access and the same data length in the inputs and outputs)
The extended GSD file must be used to deactivate CfgData checking and to specify compact/complex mapping textually in the master's configuration tool.


Multi-Configuration Mode

Extended functions [image] Multi-Configuration Mode
Multi-Configuration Mode
Applications of the multi-configuration mode
Multi-configuration mode can be used for the following types of application. A more extensive consideration, considering, in particular, the various implementation levels of the Bus Coupler, is given in the Requirements of a production machine.
Creating a DP configuration for various implementation levels of the Bus Coupler
If a PLC program is to be used for controlling different configurations of a process, it may make sense to use the same DP configuration even if the terminal configuration is different. In this case the address offsets in the process image do not change, and the DP configuration of the PROFIBUS DP master does not have to be re-saved for each version. With the multi-configuration mode it is now possible to define a maximum configuration for the Bus Coupler, and in this case it will only be necessary to disable those terminals that are not present in accordance with the current implementation level.
Reserved Bus Terminals
Because all the analog terminals are configured first in the DP configuration, before the digital terminals, the consequence of inserting analog terminals at a later stage is that the address offsets of the digital terminals are shifted. The insertion of a digital terminal within the existing terminal structure (which can, for instance, be useful if digital terminals with different input voltages are used) also has the consequence that the offsets of the digital terminals that follow it are shifted. If a digital terminal is inserted before the end terminal however, the offset of the existing terminals are not shifted. With multi-configuration mode it is now possible to configure additional terminals as reserves at any location within the terminal structure.
Assigning the Bus Terminals to freely chosen process image addresses
Because digital terminals are always grouped into bytes, which therefore means that the smallest DP configuration module is an 8-bit module, a difficulty arises when the associated terminals are to be distributed over a number of bytes in the PLC process image. This is because in the PLC it is usually only possible to assign addresses for each DP configuration module. With multi-configuration mode it is now possible to configure additional digital terminals as "dummy" terminals at any desired locations, enabling the address offsets of the other terminals to be shifted in the PLC process image.
Setting the multi-configuration mode
Multi-configuration mode is activated via the UserPrmData:
Byte | Bit | Description
3 | 4 | 1: Multi-configuration mode is active
Rules for multi-configuration mode
Multi-configuration mode requires a few additional rules to be observed, in addition to those for standard configuration:
▪
Only one DP module may be configured for each analog terminal
▪
The digital terminals are to be declared as KLxxxx Multi-Cfg mode modules at their true position
▪
The digital terminals are to be declared after the analog modules moreover as input/output sum modules, corresponding to their bit width, as is also the case for standard configuration in the process image.
▪
All modules for the maximum configuration, including the reserve modules, are to be declared
▪
Modules that are not inserted must be disabled
Enabling/disabling Bus Terminals
Those Bus Terminals that are present in the DP configuration, but that are not in fact plugged in, must be disabled. This can be done in the UserPrmData, via DPV1, KS2000 or through the 2-byte PLC interface.
Making the setting through DPV1 or through the 2-byte PLC interface has the advantage that the terminal assignment for the multi-configuration mode can usually be made directly from the PLC program, without having to change the DP configuration of the master.
As long as the inserted Bus Terminals do not agree with the non-disabled Bus Terminals to be expected from the DP configuration, the Bus Terminal will normally set the Stat_Diag bit in the diagnostic data, with the consequence that it is not yet ready for cyclic data exchange.
If, however, the enabling and disabling is to be carried out via the 2-byte PLC interface, it is a precondition for function of the 2-byte PLC interface that the coupler is in cyclic data exchange mode. For that reason it is also possible to deactivate remaining in the Stat_Diag state:
Byte | Bit | Description
3 | 6 | 1: In multi-configuration mode the coupler also enters the data exchange even when the configuration is not consistent, although K-bus cycles are not yet executed
Enabling/disabling via UserPrmData
The assignment of the terminals (a maximum of 128 terminals is possible) is entered from byte 15 to byte 30 and from byte 41 to byte 56 of the UserPrmData. Two bits are reserved here for each terminal, indicating whether the relevant terminal is enabled (value 0) or disabled (value 2). If the UserPrmData is to be displayed as text in the DP configuration tool, then the parameters Assignment of module x are to be set to DP DataExchange (enabled) or Multi-Config. mode (disabled).
Byte | Bit | Description
15 | 0,1 | Assignment for terminal 1 0: DP DataExchange (default) 2: disabled (Multi-Config mode)
 | 2,3 | Assignment for terminal 2 0: DP DataExchange (default) 2: disabled (Multi-Config mode)
 | 4,5 | Assignment for terminal 3 0: DP DataExchange (default) 2: disabled (Multi-Config mode)
 | 6,7 | Assignment for terminal 4 0: DP DataExchange (default) 2: disabled (Multi-Config mode)
... | ... | ...
30 | 6,7 | Assignment for terminal 64 0: DP DataExchange (default) 2: disabled (Multi-Config mode)
41 | 0,1 | Assignment for terminal 65 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
... | ... | ...
56 | 6,7 | Assignment for terminal 128 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
Enabling/disabling via DPV1 Write
The terminals are enabled/disabled through Slot_Number 0 and Index 1 or 2:
Index | Byte | Bit | Description
1 | 0 | 0,1 | Assignment for terminal 1 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 |  | 2,3 | Assignment for terminal 2 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 |  | 4,5 | Assignment for terminal 3 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 |  | 6,7 | Assignment for terminal 4 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | ... | ... | ...
 | 15 | 6,7 | Assignment for terminal 64 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
2 | 0 | 0,1 | Assignment for terminal 65 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | ... | ... | ...
 | 15 | 6,7 | Assignment for terminal 128 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
Enabling/disabling via the 2-byte PLC interface or through KS2000
The terminals are enabled or disabled through table 1, registers 0-31:
Register | Bit | Description
0 | 0,1 | Assignment for terminal 1 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 2,3 | Assignment for terminal 2 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 4,5 | Assignment for terminal 3 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 6,7 | Assignment for terminal 4 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 8,9 | Assignment for terminal 5 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 10,11 | Assignment for terminal 6 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 12,13 | Assignment for terminal 7 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
 | 14,15 | Assignment for terminal 8 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
... | ... | ...
31 | 14,15 | Assignment for terminal 128 0: DP-DataExchange (Default) 2: disabled (Multi-Config-Mode)
Note the size of the Cfg data
It can happen under multi-configuration mode that the CfgData exceeds 64 bytes.
In such a case, the CfgData must be enlarged.


Changing the Size of the Process Data

Extended functions [image] Changing the Size of the Process Data
Changing the Size of the Process Data
Exceeding the input data length (InputData)
By default, a maximum of 128 bytes of input data is set on the Bus Coupler.
The maximum lengths of the DP buffers can be changed, although the amount by which a length is increased has to be subtracted from another, and the sizes must only be modified in 8-byte steps:
Exceeding the output data length (OutputData)
By default, a maximum of 128 bytes of output data is set on the Bus Coupler.
The maximum length of the DP buffer can be changed. The amount, however, by which one length is increased must be taken away from another, and it must be noted that the sizes can only be changed in 8-byte steps:
Exceeding the configuration data length (CfgData)
By default, a maximum of 64 bytes of configuration data is set on the Bus Coupler. Normally, this is only a problem in very rare cases. In multi-configuration mode, however, this limit is reached with no more than a 30 digital terminals, because each KLxxxx MultiCfgMode module occupies two bytes in the configuration data, on top of which there is at least one sum byte for digital inputs or for digital outputs.
The maximum lengths of the DP buffers can be changed, although the amount by which a length is increased has to be subtracted from another, and the sizes must only be modified in 8-byte steps:
Maximum DP buffer sizes
DP buffer | Maximum sizes under default settings
Inputs | 128 bytes
Outputs | 128 bytes
Diagnostic data | 64 bytes
Configuration data | 64 bytes
Setting via the 2-BYTE PLC interface or KS2000
The maximum DP buffer sizes can be modified in Table 100, although it is necessary for the Bus Coupler to be reset (power off/power on, or a software reset) before the new value is adopted:
Register | Description
2 | maximum length of input data
3 | maximum length of output data
4 | maximum length of diagnosis data
5 | maximum length of configuration data
Setting via UserPrmData
The Bus Coupler's reset is carried out automatically if the DP buffers are set using UserPrmData:
Byte | Bit | Description
12 | 4-7 | 15 dec or 0xF hex: the maximum DP buffer lengths are changed using the values from UserPrmData 37-40
37 | 0-7 | maximum length of input data
38 | 0-7 | maximum length of output data
39 | 0-7 | maximum length of diagnosis data
40 | 0-7 | maximum length of configuration data
Example 1: Not enough configuration data
128 bytes input
128 bytes output
80 bytes CfgData
48 bytes diagnosis data
Example 2: Not enough input data
160 bytes input
96 bytes output
64 bytes CfgData
64 bytes diagnosis data


Bus Coupler versions in multi-configuration mode

Extended functions [image] Bus Coupler versions in multi-configuration mode
Bus Coupler versions in multi-configuration mode
Structure of a production machine
Production machines often consist of a machine part that is always present in the machine and of machine extensions that may be added as options. This division also usually applies as well both to the software (the control program) and to the hardware (the necessary process signals via Beckhoff Bus Terminals) associated with the machine. A machine, with machine extensions A, B and C, whose process signals are to be read or output over the PROFIBUS DP through Beckhoff Bus Couplers BK3110, BK3120 or BK3520, could be structured as follows.
Representation of a production machine
The machine illustrated consists of a controller (e.g. TwinCAT, S7-400, etc.), a PROFIBUS DP master interface (e.g. FC3101, CP???, etc.) that sends or receives the process signals over the PROFIBUS DP, and of Bus Couplers with Bus Terminals that form the interface to the machine process. The areas shown in grey relate to machine parts that are always present. The machine extensions A, B and C are shown in red, green and blue. It can be seen that each machine extension is associated both with software modules within the control program and process signals that are connected to the controller via Bus Terminals.
Because the machine builder will not want to maintain eight different control programs for all possible combinations of the machine extensions, it is helpful if the control program is designed in such a way that the necessary software modules are activated according to whichever machine extensions are in fact being used. In order to create a control program suited to all implementation levels of the machine it is however necessary for the same process signals always to appear at the same addresses in the controller's process image, independently of which process signals are in fact present in the relevant implementation level. For conventional DP slaves, a different configuration of the PROFIBUS DP master interface is necessary in such cases. The following sections explain how this problem can be solved with Beckhoff Bus Couplers, using a single configuration of the PROFIBUS DP master interface.
The advantage of this solution is that two machine configurations only differ in terms of the hardware used (machine components and Bus Terminals), but not in terms of the software. If the machine is upgraded, it is only necessary for the additional Bus Terminals to be inserted and wired-up, and for the relevant extension to be activated (e.g. via the man-machine interface to the machine). Software changes are no longer required.
Process image interfaces
The interfaces between controller, PROFIBUS DP master interface, Bus Coupler and Bus Terminals form process images, in which the process signals are stored according to certain algorithms.
Process image of the production machine
The process signals of a DP slave (Bus Coupler BK3110, BK3120 or BK3520) are always transferred in a Data_Exchange telegram, in which the outputs are sent by the DP master and the inputs are received in the associated telegram response. In the PROFIBUS DP master interface, the process images exchanged with the Bus Couplers are mapped to the process images of the control according to a mapping rule.
Process images of the machine configurations
As shown in the two examples in the figure below, the mapping rule in the PROFIBUS DP master interface changes, depending on which machine extensions are used (there are two examples here).
Process images of the two different machine configurations
In order to solve the problem of the changed mapping rule, a facility is provided in the BK3110, BK3120 and BK3520 Bus Couplers through which the mapping can be carried out in the Bus Coupler (multi-configuration mode), so that they always exchange the same process image with the PROFIBUS DP master, independently of the Bus Terminals present:
Setting the Bus Terminal extension in the Bus Coupler
So that the same process image can always be transferred between the PROFIBUS DP master and the Bus Coupler, independently of the implementation level of the machine or of the Bus Terminals, the maximum Bus Terminal implementation for the Bus Coupler is always configured in the PROFIBUS DP master under multi-configuration mode. This PROFIBUS DP configuration is sent from the PROFIBUS DP master to the Bus Coupler when the PROFIBUS DP bus is starting up. This then compares the received PROFIBUS DP configuration with the bus terminals that are actually present.
If the Bus Coupler is not already being operated with the maximum Bus Terminal implementation level, the PROFIBUS DP configuration will not agree with the Bus Terminal structure that it finds. So that the Bus Coupler can nevertheless represent the process signals from the connected Bus Terminals in the process image that is to be exchanged with the PROFIBUS DP master, the mapping rule is now required.
Because the Bus Coupler maps the process signals from the Bus Terminals into the DP process image according to a fixed algorithm (first complex, then digital terminals, each in the sequence in which they are plugged in), the only information that is missing is that of which of the Bus Terminals that are included in the PROFIBUS DP configuration are indeed truly present. This information can be transmitted via the acyclic DPV1 Write, or through the 2-byte PLC interface for those PROFIBUS DP master interfaces that do not support PROFIBUS DPV1. The acyclic DPV1 Write is usually available through function blocks (TwinCAT: ADS-Write, S7 400: SFB 52 (read) and SFB53 (write)) from the controller program. The 2-byte PLC interface of the Bus Coupler is mapped directly into the controller's process image. As soon as a machine extension is activated or deactivated, the controller program can therefore activate or deactivate the associated Bus Terminals.
Example as above, where deactivated terminals are marked in yellow:
Process images of the two different machine configurations with deactivated terminals
State transitions in the Bus Coupler
If the PROFIBUS DP configuration received does match the Bus Terminal configuration in multi-configuration mode, the Bus Coupler sets the "static diagnostics" bit in the PROFIBUS DP diagnostic data and delays the execution of a terminal bus cycle (I/O RUN LED remains off). As soon as the terminal assignment (activated/not activated) has been written by the PROFIBUS DP master, the Bus Coupler again carries out an examination of the PROFIBUS DP configuration, and automatically enters cyclic data exchange (the "static diagnosis" bit in PROFIBUS DP diagnostic data is cleared, and the terminal bus cycle is executed cyclically (the I/O-RUN LED goes on during the terminal cycle)). Furthermore, the terminal assignment is stored in the non-volatile memory of the Bus Coupler, so that during a restart of the PROFIBUS DP, the PROFIBUS DP master does not have to write the terminal configuration again.
State transitions in the Bus Coupler


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Approvals
•
Bibliography
•
List of Abbreviations
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
The following conditions must be met in order to ensure flawless operation of the fieldbus components.
Environmental conditions
Operation
The components may not be used without additional protection in the following locations:
▪
in difficult environments, such as where there are corrosive vapors or gases, or high dust levels
▪
in the presence of high levels of ionizing radiation
Condition | Permissible range
Permissible ambient temperature during operation | see technical data
Installation position | variable
Vibration resistance | According to EN 60068-2-6
Shock resistance | According to EN 60068-2-27
EMC resistance | According to EN 61000-6-2
Emission | According to EN 61000-6-4
Transport and storage
Condition | Permissible range
Permissible ambient temperature during storage | -25 °C... +85 °C
Relative humidity | 95 %, no condensation
Free fall | up to 1 m in the original packaging
Protection classes and types
Condition | Permissible range
Protection class in accordance with IEC 536 (VDE 0106, Part 1) | A protective conductor connection to the mounting rail is necessary!
Protection class conforms to IEC 529 | IP20 (protection against contact with a standard test finger)
Protection against foreign objects | Less than 12 mm in diameter
Protection against water | no protection
Component identification
Every supplied component includes an adhesive label providing information about the product's approvals. For example, on the BK2000:
Sticker with information about the BK2000 Bus Coupler certification
The following information is printed on the label:
Printed item | Meaning for this label
Precise product identification | Lightbus Coupler BK2000
Supply voltage | 24 VDC
Data transfer rate | 2.5 Mbit/s
Manufacturer | Beckhoff Automation GmbH
CE mark | Conformity mark
UL mark | Mark for UL approval. UL stands for the Underwriters Laboratories Inc., the leading certification Organisation for North America, based in the USA. C = Canada, US = USA, LISTED 22ZA (the test results can be inspected under this entry)
Production identification | From left to right, this sequence of characters indicates the week of production (2 characters), the year of production (2 characters), the software version (2 characters) and hardware version (2 characters), along with any special indications (4 characters). This case therefore is a BK2000 - produced in the 9th calendar week - in the year 2001 - containing the BF firmware version - and using the 6th hardware version - with no special indications


Approvals

Appendix [image] Approvals
Approvals
Underwriter laboratories
UL E172151
Conformity mark
CE
Protection class
IP20 conforms to EN60529


Bibliography

Appendix [image] Bibliography
Bibliography
German books
PROFIBUS
▪
PROFIBUS-DP/DPV1
Basic principles, tips and tricks for users
by Manfred Popp
ISBN: 3778527819
General fieldbus technology
▪
Gerhard Gruhler (Pub.): Fieldbuses and device communication systems
Practical knowledge with comparison options
Franzis Verlag 2001
244 pages
ISBN 3-7723-5745-8
English books
(in preparation)
Standards PROFIBUS-DP
▪
IEC 61158 and IEC 61784
▪
DIN 19245, Part 3
▪
Euronorm EN 50170
Web sites
▪
http://www.profibus.de


List of Abbreviations

Appendix [image] List of Abbreviations
List of Abbreviations
DP
Decentralised periphery. PROFIBUS protocol for fast cyclic data exchange
FMS
PROFIBUS transfer protocol (Fieldbus Message Specification).
Freeze mode
This command makes the slave freeze its inputs
GSD file
German device master file
GSE file
English device master file
IP20, IP65, IP66, IP67
Protection class (contact, water, dust)
K-bus
Terminal Bus: Internal bus for communication between Bus Coupler and Bus Terminals
PNO
PROFIBUS User Organisation (seewww.profibus.de)
Repeater
Provides signal conditioning, connecting individual bus segments
PLC
Programmable logic controller
Sync mode
This command makes the slave hold its outputs unchanged until it receives the Sync telegram.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com