BK11x0, BK1250 – EtherCAT Bus Coupler
Home


Foreword

Foreword
Foreword
Additional information
•
Product overview - EtherCAT Bus Coupler
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Product overview - EtherCAT Bus Coupler

Foreword [image] Product overview - EtherCAT Bus Coupler
Product overview - EtherCAT Bus Coupler
BK1120, BK1150 - EtherCAT Bus Coupler for standard Bus Terminals
BK1250 - "Compact" coupler between E-bus and K-bus terminals


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
4.4
▪
Update chapter “Firmware compatibility”
▪
Update structure
4.3
▪
Update chapter “Technical data”
▪
Update chapter “Instructions for ESD protection”
▪
Example program added to chapter “Parameterization and commissioning”, section “KS2000 Configuration software“
4.2
▪
Correction Diagnostic LEDs
▪
Update structure
4.1
▪
Update chapter "Notes on the documentation"
▪
Update chapter "Technical data"
▪
Addenda chapter "Instructions for ESD protection"
▪
Chapter "ATEX - Special conditions" replaced with chapter "ATEX - Special conditions (extended temperature range)"
▪
Update chapter "General operating conditions"
▪
Update revision status
4.0
▪
Migration
▪
Update structure
▪
Update revision status
3.0
▪
Update structure
▪
Notes regarding ET
2.9
▪
Note re status bits amended
2.8
▪
Update Technical data
2.7
▪
Addenda technical notes
2.6
▪
Update Technical data
2.5
▪
BK1150 added
2.4
▪
Extension of terminal diagnostics
2.3
▪
Correction Diagnostic LEDs
2.2
▪
CoE access, AoE
2.1
▪
Object descriptions amended
2.0
▪
BK1250 added; object descriptions and technical data amended
1.0
▪
Object descriptions amended
0.2
▪
Technical data added
0.1
▪
First preliminary version


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data


Introduction

Product overview [image] Introduction
Introduction
EtherCAT coupler for K-bus Terminals
BK1120, BK1150
Bus Couplers BK1120 and BK1150
The Bus Couplers BK1120 and BK1150 connect EtherCAT with the tried and tested Beckhoff K-bus terminals (KLxxx). A station consists of a BK1120 / BK1150 Bus Coupler, any number of K-bus terminals (up to 64, or up to 255 with K-bus extension) and a bus end terminal. The Bus Coupler recognizes the connected terminals and automatically allocates them into the EtherCAT process image. The Bus Coupler is connected to the network via the upper Ethernet interface. The lower RJ45 socket may be used to connect further EtherCAT devices in the same segment. In the EtherCAT network, the BK1120 / BK1150 Bus Coupler can be installed anywhere in the Ethernet signal transfer section (100BASE-TX) – except directly at the switch. The Bus Couplers BK9000 (for K-bus terminals) and EK1000 (for E-bus terminals) are suitable for application at the switch.
BK1250
BK1250
K-bus_E-bus
The BK1250 is a "Bus Coupler in the terminal housing" for mixed application of EtherCAT terminals (ELxxxx) and standard Bus Terminals (KLxxxx) in a bus station. It allows implementation of compact and cost-effective control solutions. The wide range of more than 300 available Bus Terminals (incl. special terminals) can thus be optimally combined with the communication speed and large bandwidth of EtherCAT terminals. Up to 64 Bus Terminals (with K-bus extension up to 255) can be connected to a BK1250. The Bus Coupler recognizes the connected Bus Terminals and automatically allocates them into the EtherCAT process image.


Technical data

Product overview [image] Technical data
Technical data
Technical data | BK1120 | BK1150 | BK1250
Task in the EtherCAT system | Coupling of standard Bus Terminals (KLxxxx) to 100BASE-TX EtherCAT networks
Number of K-bus terminals | 64 (255 with K-bus extension interface KL9020 and KL9050)
Max. number of bytes, fieldbus | 1024 bytes input and 1024 bytes output
Digital peripheral signals | 8192 inputs/outputs
Analog peripheral signals | 256 inputs/outputs
Protocols | EtherCAT
Baud rate | 100 Mbaud
Configuration | KS2000 configuration software, TwinCAT System Manager or via EtherCAT (ADS)
Bus connection | 2 x RJ45 |  | via E-bus contacts
Power supply | 24 VDC (-15%/+20%)
Current consumption | 70 mA + (K-bus current)/4, max. 500 mA |  | 70 mA + (K-bus current)/4, max. 200 mA
K-bus power supply (5 V) | max. 1750 mA | max. 1750 mA | max. 500 mA
Power contacts | max. 24 VDC, max. 10 A
Electrical isolation | 500 V (power contact/supply voltage/Ethernet)
Weight | approx. 170 g |  | approx. 55 g
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Dimensions (W x H x D) | approx. 49 mm x 100 mm x 70 mm |  | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also installation instructions for enhanced mechanical load capacity
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE ATEX cULus


Basic principles

Basic principles
Basic principles
Additional information
•
System properties
•
The Beckhoff Bus Terminal system
•
CoE Interface
•
EtherCAT State Machine
•
LEDs and connection


System properties

Basic principles [image] System properties
System properties
Protocol
The EtherCAT protocol is optimized for process data and is transported directly within the Ethernet frame thanks to a special Ether-type. It may consist of several sub-telegrams, each serving a particular memory area of the logical process images that can be up to 4 gigabytes in size. The data sequence is independent of the physical order of the Ethernet terminals in the network; addressing can be in any order. Broadcast, Multicast and communication between slaves are possible. Transfer directly in the Ethernet frame is used in cases where EtherCAT components are operated in the same subnet as the control computer.
However, EtherCAT applications are not limited to a subnet: EtherCAT UDP packs the EtherCAT protocol into UDP/IP datagrams. This enables any control with Ethernet protocol stack to address EtherCAT systems. Even communication across routers into other subnets is possible. In this variant, system performance obviously depends on the real-time characteristics of the control and its Ethernet protocol implementation. The response times of the EtherCAT network itself are hardly restricted at all: the UDP datagram only has to be unpacked in the first station.
EtherCAT Telegram Structure
Protocol structure: The process image allocation is freely configurable. Data are copied directly in the I/O terminal to the desired location within the process image: no additional mapping is required. The available logical address space is with very large (4 GB).
Topology
Line, tree or star: EtherCAT supports almost any topology. The bus or line structure known from the fieldbuses thus also becomes available for Ethernet. Particularly useful for system wiring is the combination of line and junctions or stubs. The required interfaces exist on the couplers; no additional switches are required. Naturally, the classic switch-based Ethernet star topology can also be used.
EtherCAT Topology
Maximum wiring flexibility:
with or without switch, line or tree topologies, can be freely selected and combined.
Wiring flexibility is further maximized through the choice of different cables. Flexible and cost-effective standard Ethernet patch cables transfer the signals in Ethernet mode (100Base-TX). The complete bandwidth of the Ethernet network - such as different optical fibers and copper cables - can be used in combination with switches or media converters.
Distributed Clocks
Accurate synchronization is particularly important in cases where spatially distributed processes require simultaneous actions. This may be the case, for example, in applications where several servo axes carry out coordinated movements simultaneously.
The most powerful approach for synchronization is the accurate alignment of distributed clocks, as described in the new IEEE 1588 standard. In contrast to fully synchronous communication, where synchronization quality suffers immediately in the event of a communication fault, distributed aligned clocks have a high degree of tolerance vis-à-vis possible fault-related delays within the communication system.
With EtherCAT, the data exchange is fully based on a pure hardware machine. Since the communication utilizes a logical (and thanks to full-duplex Fast Ethernet also physical) ring structure, the mother clock can determine the run-time offset to the individual daughter clocks simply and accurately - and vice versa. The distributed clocks are adjusted based on this value, which means that a very precise network-wide timebase with a jitter of significantly less than 1 microsecond is available.
However, high-resolution distributed clocks are not only used for synchronization, but can also provide accurate information about the local timing of the data acquisition. For example, controls frequently calculate velocities from sequentially measured positions. Particularly with very short sampling times, even a small temporal jitter in the displacement measurement leads to large step changes in velocity. With EtherCAT new, extended data types are introduced as a logical extension (time stamp and oversampling data type). The local time is linked to the measured value with a resolution of up to 10 ns, which is made possible by the large bandwidth offered by Ethernet. The accuracy of a velocity calculation then no longer depends on the jitter of the communication system. It is orders of magnitude better than that of measuring techniques based on jitter-free communication.
Performance
EtherCAT reaches new dimensions in network performance. Protocol processing is purely hardware-based through an FMMU chip in the terminal and DMA access to the network card of the master. It is thus independent of protocol stack run-times, CPU performance and software implementation. The update time for 1000 I/Os is only 30 µs - including terminal cycle time. Up to 1486 bytes of process data can be exchanged with a single Ethernet frame - this is equivalent to almost 12000 digital inputs and outputs. The transfer of this data quantity only takes 300 µs.
The communication with 100 servo axes only takes 100 µs. During this time, all axes are provided with set values and control data and report their actual position and status. Distributed clocks enable the axes to be synchronized with a deviation of significantly less than 1 microsecond.
The extremely high performance of the EtherCAT technology enables control concepts that could not be realized with classic fieldbus systems. For example, the Ethernet system can now not only deal with velocity control, but also with the current control of distributed drives. The tremendous bandwidth enables status information to be transferred with each data item. With EtherCAT, a communication technology is available that matches the superior computing power of modern Industrial PCs. The bus system is no longer the bottleneck of the control concept. Distributed I/Os are recorded faster than is possible with most local I/O interfaces. The EtherCAT technology principle is scalable and not bound to the baud rate of 100 Mbaud – extension to Gbit Ethernet is possible.
Diagnostics
Experience with fieldbus systems shows that availability and commissioning times crucially depend on the diagnostic capability. Only faults that are detected quickly and accurately and which can be precisely located can be corrected quickly. Therefore, special attention was paid to exemplary diagnostic features during the development of EtherCAT.
During commissioning, the actual configuration of the I/O terminals should be checked for consistency with the specified configuration. The topology should also match the saved configuration. Due to the built-in topology recognition down to the individual terminals, this verification can not only take place during system start-up, automatic reading in of the network is also possible (configuration upload).
Bit faults during the transfer are reliably detected through evaluation of the CRC checksum: The 32 bit CRC polynomial has a minimum hamming distance of 4. Apart from breaking point detection and localization, the protocol, physical transfer behavior and topology of the EtherCAT system enable individual quality monitoring of each individual transmission segment. The automatic evaluation of the associated error counters enables precise localization of critical network sections. Gradual or changing sources of error such as EMC influences, defective push-in connectors or cable damage are detected and located, even if they do not yet overstrain the self-healing capacity of the network.
Integration of standard Bus Terminals from Beckhoff
In addition to the new Bus Terminals with E-Bus connection (ELxxxx), all Bus Terminals from the familiar standard range with K-bus connection (KLxxxx) can be connected via the BK1120 or BK1250 Bus Coupler. This ensures compatibility and continuity with the existing Beckhoff Bus Terminal systems. Existing investments are protected.


The Beckhoff Bus Terminal system

Basic principles [image] The Beckhoff Bus Terminal system
The Beckhoff Bus Terminal system
Up to 256 Bus Terminals, with 1 to 16 I/O channels per signal form
The Bus Terminal system is the universal interface between a fieldbus system and the sensor / actuator level. A unit consists of a Bus Coupler as the head station, and up to 64 electronic series terminals, the last one being an end terminal. Up to 255 Bus Terminals can be connected via the K-bus extension. For each technical signal form, terminals are available with one, two, four or eight I/O channels, which can be mixed as required. All the terminal types have the same mechanical construction, so that difficulties of planning and design are minimized. The height and depth match the dimensions of compact terminal boxes.
Decentralized wiring of each I/O level
Fieldbus technology allows more compact forms of controller to be used. The I/O level does not have to be brought to the controller. The sensors and actuators can be wired decentrally, using minimum cable lengths. The controller can be installed at any location within the plant.
Industrial PCs as controllers
The use of an Industrial PC as the controller means that the operating and observing element can be implemented in the controller's hardware. The controller can therefore be located at an operating panel, in a control room, or at some similar place. The Bus Terminals form the decentralized input/output level of the controller in the control cabinet and the subsidiary terminal boxes. The power sector of the plant is also controlled over the bus system in addition to the sensor/actuator level. The Bus Terminal replaces the conventional series terminal as the wiring level in the control cabinet. The control cabinet can have smaller dimensions.
Bus Couplers for all usual bus systems
The Beckhoff Bus Terminal system unites the advantages of a bus system with the possibilities of the compact series terminal. Bus Terminals can be driven within all the usual bus systems, thus reducing the controller parts count. The Bus Terminals then behave like conventional connections for that bus system. All the performance features of the particular bus system are supported.
Mounting on standardized mounting rails
The installation is standardized thanks to the simple and space-saving mounting on a standardized mounting rail (EN 50022, 35 mm) and the direct wiring of actuators and sensors, without cross connections between the terminals. The consistent labelling scheme also contributes.
The small physical size and the great flexibility of the Bus Terminal system allows it to be used wherever a series terminal is also used. Every type of connection, such as analog, digital, serial or the direct connection of sensors can be implemented.
Modularity
The modular assembly of the terminal strip with Bus Terminals of various functions limits the number of unused channels to a maximum of one per function. The presence of two channels in one terminal is the optimum compromise of unused channels and the cost of each channel. The possibility of electrical isolation through potential feed terminals also helps to keep the number of unused channels low.
Display of the channel state
The integrated LEDs show the state of the channel at a location close to the sensors and actuators.
K-bus
The K-bus is the data path within a terminal strip. The K-bus is led through from the Bus Coupler through all the terminals via six contacts on the terminals' side walls. The end terminal terminates the K-bus. The user does not have to learn anything about the function of the K-bus or about the internal workings of the terminals and the Bus Coupler. Many software tools that can be supplied make project planning, configuration and operation easy.
Potential feed terminals for isolated groups
The operating voltage is passed on to following terminals via three power contacts. You can divide the terminal strip into arbitrary isolated groups by means of potential feed terminals. The potential feed terminals play no part in the control of the terminals, and can be inserted at any locations within the terminal strip.
Up to 64 Bus Terminals can be used in a terminal block, with optional K-bus extension for up to 256 Bus Terminals. This count does include potential feed terminals, but not the end terminal.
Bus Couplers for various fieldbus systems
Various Bus Couplers can be used to couple the electronic terminal strip quickly and easily to different fieldbus systems. It is also possible to convert to another fieldbus system at a later time. The Bus Coupler performs all the monitoring and control tasks that are necessary for operation of the connected Bus Terminals. The operation and configuration of the Bus Terminals is carried out exclusively by the Bus Coupler. Nevertheless, the parameters that have been set are stored in each Bus Terminal, and are retained in the event of voltage drop-out. Fieldbus, K-bus and I/O level are electrically isolated.
If the exchange of data over the fieldbus is prone to errors or fails for a period of time, register contents (such as counter states) are retained, digital outputs are cleared, and analog outputs take a value that can be configured for each output when commissioning. The default setting for analog outputs is 0 V or 0 mA. Digital outputs return in the inactive state. The timeout periods for the Bus Couplers correspond to the usual settings for the fieldbus system. When converting to a different bus system it is necessary to bear in mind the need to change the timeout periods if the bus cycle time is longer.
The interfaces
A Bus Coupler has six different methods of connection. These interfaces are designed as plug connectors and as spring-loaded terminals.


CoE Interface

Basic principles [image] CoE Interface
CoE Interface
General description
The CoE interface (CAN application protocol over EtherCAT)) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
The order is specified in two levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are
▪
Index: 0x0000 …0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255dez)
A parameter localized in this way is normally written as 0x8010:07, with preceding “0x” to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: here are the channel parameters for some EtherCAT devices. Historically, this was the first parameter area before the 0x8000 area was introduced. EtherCAT devices that were previously equipped with parameters in 0x4000 and changed to 0x8000 support both ranges for compatibility reasons and mirror internally.
▪
0x6000: Input PDOs (“input” from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs (“output” from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
“CoE Online” tab
The figure above shows the CoE objects available in device “EL2502”, ranging from 0x1000 to 0x1600. The subindices for 0x1018 are expanded.
Data management and function “NoCoeStorage”
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (Fig. “CoE Online” tab) by clicking
This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterized and enter a value in the “SetValue” dialog.
▪
from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.
The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
Please refer to the technical data in this documentation as to whether this applies to the respective device.
•
If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
•
Function is not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager
The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list.
The order of the Startup entries is usually irrelevant.
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline list
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is “available”, i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE list as shown in Fig. “CoE online tab” is displayed. The connectivity is shown as offline/online.
▪
If the slave is offline
–
The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
The configured status is shown under Identity.
–
No firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red.
Offline list
▪
If the slave is online
–
The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
–
The actual identity is displayed
–
The firmware and hardware version of the equipment according to the electronic information is displayed
–
Online is shown in green.
Online list
Channel-based order
The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0...10 V input terminal also has four logical channels and therefore four identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder “n” tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
...
This is generally written as 0x80n0.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


EtherCAT State Machine

Basic principles [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


LEDs and connection

Basic principles [image] LEDs and connection
LEDs and connection
Additional information
•
LEDs
•
Connection BK1120 and BK1150
•
Connection BK1250


LEDs

Basic principles [image] LEDs and connection [image] LEDs
LEDs
After switching on, the Bus Coupler immediately checks the connected configuration. Error-free start-up is signaled by the red LED I/O ERR being extinguished. If the I/O ERR LED blinks, an error in the area of the terminals is indicated. The frequency and number of flashes indicate the error code (see below).
The BK1120 / BK1150 Bus Coupler has a green LED Link/Act In / Link/Act Out at the RJ45 sockets, which indicates the fieldbus status.
The RUN and ERROR LEDs (for BK1120: center top, for BK1150: left row of the LED prism) indicate the state of the EtherCAT state machine.
On the upper right hand side of the BK1120 are two more green LEDs that indicate the supply voltage. The left hand LED indicates the presence of the 24 V supply for the Bus Coupler. The right hand LED indicates the presence of the supply to the power contacts. At the BK1150, the diagnostic LEDs are on the right side of the LED prism, as shown in Fig. Diagnostic LEDs at Bus Coupler BK1120, BK1150.
Diagnostic LEDs at Bus Coupler BK1120, BK1150
The diagnostic LEDs for the BK1250 are arranged as shown in Fig. Diagnostic LEDs at Bus Coupler BK1250.
Diagnostic LEDs at Bus Coupler BK1250
LEDs for power supply diagnostics
LED |  | Display | State | Description
Us (POWER SUPPLY) | green | off | - | No operating voltage present at the Bus Coupler
 |  | on | - | 24 VDC operating voltage present at the Bus Coupler
Up (POWER CONTACTS) | green | off | - | No power supply present at the power contacts
 |  | on | - | 24 VDC power supply present at the power contacts
Diagnostic LEDs for the EtherCAT State Machine/PLC
LED |  | Display | State | Description
RUN | green | off | Init | The Bus Coupler is in initialization state
 |  | flashing | Pre-Operational | The Bus Coupler is in pre-operational state
 |  | single flash | Safe-Operational | The Bus Coupler is in safe-operational state
 |  | on | Operational | The Bus Coupler is in operational state
 |  | flickers | Bootstrap | Firmware is being loaded.
ERROR | red | off | - | No error
 |  | flashing | Err-Operational No Communication | PLC error / lost frames
LEDs for fieldbus diagnostics
BK1120, BK1150
LED |  | Display | State | Description
LINK / ACT (X1 IN) | green | off | - | No connection on the incoming EtherCAT segment
 |  | on | linked | Preceding EtherCAT device connected
 |  | flashing | active | Communication with preceding EtherCAT device
LINK / ACT (X2 OUT) | green | off | - | No connection on the outgoing EtherCAT segment
 |  | on | linked | Following EtherCAT device connected
 |  | flashing | active | Communication with downstream EtherCAT device
BK1250
LED |  | Display | State | Description
LINK/ACT | green | off | - | No connection/communication with the E-bus
 |  | flashing | linked | Connection/communication with the E-bus established
LEDs for K-bus diagnostics
LED |  | Display | State | Description
I/O-RUN | green | off | - | K-bus inactive
 |  | on | - | K-bus active
LED red; I/O-Error
Error code argument
Description
Remedy
Persistent, continuous flashing
EMC problems
▪
Check power supply for undervoltage or overvoltage peaks
▪
Implement EMC measures
▪
If a K-bus error is present, it can be localized by a restart of the coupler (by switching it off and then on again)
1 pulse
0
EEPROM checksum error
▪
Enter factory settings with the KS2000 configuration software
(Menu "Online -> Coupler -> Services -> Factory Setting")
1
Code buffer overflow
▪
Insert fewer Bus Terminals. Too many entries in the table for the programmed configuration
2
Unknown data type
▪
Software update required for the Bus Coupler
2 pulses
0
Programmed configuration has an incorrect table entry
▪
Check programmed configuration for correctness
n (n > 0)
Table comparison (Bus Terminal n)
▪
Incorrect table entry
3 pulses
0
K-bus command error
▪
No Bus Terminal inserted
▪
One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses
0
K-bus data error, break behind the Bus Coupler
▪
Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
n
Break behind Bus Terminal n
▪
Check whether the bus end terminal 9010 is connected.
5 pulses
n
K-bus error in register communication with Bus Terminal n
▪
Exchange the nth bus terminal
14 pulses
n
nth Bus Terminal has the wrong format
▪
Start the Bus Coupler again, and if the error occurs again then exchange the Bus Terminal
15 pulses
n
Number of Bus Terminals is no longer correct
▪
Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software
16 pulses
n
Length of the K-bus data is no longer correct
▪
Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software


Connection BK1120 and BK1150

Basic principles [image] LEDs and connection [image] Connection BK1120 and BK1150
Connection BK1120 and BK1150
BK1120, BK1150 Connection
Terminal point |  | Description
Name | No.
+24 V Us | 1 | Power supply for Bus Coupler and E-bus electronics
+24 V Up | 2 | Power supply for power contacts (internally connected to terminal point 6)
0 V Up | 3 | Power supply for power contacts (internally connected to terminal point 7)
PE | 4 | PE connection (internally connected to terminal point 8)
0 V Us | 5 | Power supply for Bus Coupler and E-bus electronics
+24 V Up | 6 | Power supply for power contacts (internally connected to terminal point 2)
0 V Up | 7 | Power supply for power contacts (internally connected to terminal point 3)
PE | 8 | PE connection (internally connected to terminal point 4)


Connection BK1250

Basic principles [image] LEDs and connection [image] Connection BK1250
Connection BK1250
BK1250 Connection
Connection
Terminal point |  | Description
Name | No.
+24 V Us | 1 | Power supply for Bus Coupler and E-bus electronics
+24 V Up | 2 | Power supply for power contacts (internally connected to terminal point 6)
0 V Up | 3 | Power supply for power contacts (internally connected to terminal point 7)
PE | 4 | PE connection (internally connected to terminal point 8)
0 V Us | 5 | Power supply for Bus Coupler and E-bus electronics
+24 V Up | 6 | Power supply for power contacts (internally connected to terminal point 2)
0 V Up | 7 | Power supply for power contacts (internally connected to terminal point 3)
PE | 8 | PE connection (internally connected to terminal point 4)


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Installation positions
•
Power supply, potential groups
•
Ethernet cable
•
EtherCAT wiring
•
ATEX - Special conditions (extended temperature range)
•
Continuative documentation about explosion protection
•
UL notice


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with a KL9010 bus end terminal, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. Recommended distances for standard installation position). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. “From below” is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. Recommended distances for standard installation position is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Power supply, potential groups

Mounting and wiring [image] Power supply, potential groups
Power supply, potential groups
Bus Coupler power supply
The Bus Couplers require a 24 VDC supply for their operation. The connection is made by means of the upper spring-loaded terminals labelled 24 V and 0 V. The supply voltage is used by the Bus Coupler electronics and for direct voltage generation for the E-bus. The voltage generation for the E-bus takes place in a DC/DC converter without electrical isolation.
The EK1xxx units supply the E-bus with max. 2,000 mA E-bus current. Power feed terminals are to be inserted if the added terminals require more current.
Input for power contacts
The bottom six connections with spring-loaded terminals can be used to feed the supply for the peripherals. The spring-loaded terminals are joined in pairs to a power contact. The feed for the power contacts has no connection to the voltage supply for the Bus Coupler. The design of the feed permits voltages of up to 24 V. The assignment in pairs and the electrical connection between feed terminal contacts allows the connection wires to be looped through to various terminal points. The current load via the power contacts may not permanently exceed 10 A; the supply line must therefore be protected by a 10 A fuse (slow-blow).
Power contacts
On the right hand face of the Bus Coupler there are three spring contacts for the power contact connections. The spring contacts are hidden in slots so that they can not be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue and groove guides on the top and bottom of the Bus Coupler and of the Bus Terminals guarantees that the power contacts mate securely.
The current load of the power contacts may not permanently exceed 10 A.
Electrical isolation
The bus couplers operate by means of three independent potential groups. The supply voltage feeds the E-bus electronics in the bus coupler and the E-bus itself, which are electrically isolated. The supply voltage is also used to generate the operating voltage for the fieldbus.
Note: All the Bus Terminals are electrically isolated from the E-bus. The E-bus is thus electrically isolated from everything else.
Potential diagram EKxxxx


Ethernet cable

Mounting and wiring [image] Ethernet cable
Ethernet cable
Transmission standards
10Base5
The transmission medium for 10Base5 consists of a thick coaxial cable ("yellow cable") with a max. transmission speed of 10 Mbaud arranged in a line topology with branches (drops) each of which is connected to one network device. Because all the devices are in this case connected to a common transmission medium, it is inevitable that collisions occur often in 10Base5.
10Base2
10Base2 (Cheaper net) is a further development of 10Base5, and has the advantage that the coaxial cable is cheaper and, being more flexible, is easier to lay. It is possible for several devices to be connected to one 10Base2 cable. It is frequent for branches from a 10Base5 backbone to be implemented in 10Base2.
10BaseT
Describes a twisted pair cable for 10 Mbaud. The network here is constructed as a star. It is no longer the case that every device is attached to the same medium. This means that a broken cable no longer results in failure of the entire network. The use of switches as star couplers enables collisions to be reduced. Using full-duplex connections they can even be entirely avoided.
100BaseT
Twisted pair cable for 100 MBaud. It is necessary to use a higher cable quality and to employ appropriate hubs or switches in order to achieve the higher data rate.
10BaseF
The 10BaseF standard describes several optical fiber versions.
Short description of the 10BaseT and 100BaseT cable types
Twisted-pair copper cable for star topologies, where the distance between two devices may not exceed 100 meters.
UTP
Unshielded twisted-pair
This type of cable belongs to category 3, and is not recommended for use in an industrial environment.
S/UTP
Screened/unshielded twisted-pair (shielded with copper braid)
Has an overall shield of copper braid to reduce influence of external interference. This cable is recommended for use with Bus Couplers.
FTP
Foiled shielded twisted-pair (shielded with aluminium foil)
This cable has an outer screen of laminated aluminium and plastic foil.
S/FTP
Screened/foiled-shielded twisted-pair (shielded with copper braid and aluminium foil)
Has a laminated aluminium screen with a copper braid on top. Such cables can provide up to 70 dB reduction in interference power.
STP
Shielded twisted-pair
Describes a cable with an outer screen, without defining the nature of the screen any more closely.
S/STP
Screened/shielded twisted pair (wires are individually shielded)
This identification refers to a cable with a shield for each of the two wires as well as an overall shield.
ITP
Industrial Twisted-Pair.
The structure is similar to that of S/STP, but, in contrast to S/STP, it has only one pair of conductors.


EtherCAT wiring

Mounting and wiring [image] EtherCAT wiring
EtherCAT wiring
The cable length between two EtherCAT devices must not exceed 100 m.
Cables and connectors
For connecting EtherCAT devices only Ethernet cables that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 connectors. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
The following Beckhoff cables and connectors are suitable for application in EtherCAT systems:
▪
ZB9010 (Industrial Ethernet/EtherCAT cable, fixed installation, CAT 5e, 4-core)
▪
ZB9020 (Industrial Ethernet/EtherCAT cable, suitable for drag chain applications CAT 5e, 4-core)
▪
ZS1090-0003 (RJ45 connector, 4-pin, IP 20, field-configurable)
▪
ZS1090-0005 (RJ45 connector, 8-pin (suitable for GigaBit), IP20, field-configurable)
▪
ZK1090-9191-0001 (0.17 m EtherCAT patch cable)
▪
ZK1090-9191-0005 (0.5m EtherCAT patch cable)
▪
ZK1090-9191-0010 (1.0m EtherCAT patch cable)
▪
ZK1090-9191-0020 (2.0m EtherCAT patch cable)
▪
ZK1090-9191-0030 (3.0m EtherCAT patch cable)
▪
ZK1090-9191-0050 (5.0m EtherCAT patch cable)
E-bus supply
Note
Attention! Malfunction possible!
The same ground potential must be used for the E-bus supply of all EtherCAT terminals in a terminal block!


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
For dust (only the fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9): The equipment shall be installed in a suitable enclosure providing a degree of protection of IP54 according to EN 60079-0 for group IIIA or IIIB and IP6X for group IIIC, taking into account the environmental conditions under which the equipment is used.
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
▪
EN 60079-31:2013 (only for certificate no. KEMA 10ATEX0075 X Issue 9)
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified according to the ATEX directive for potentially explosive areas bear the following marking:

II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
II 3D KEMA 10ATEX0075 X Ex tc IIC T135°C Dc Ta: -25 ... +60°C
(only for fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9)
or

II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C
II 3D KEMA 10ATEX0075 X Ex tc IIC T135°C Dc Ta: -25 ... +60°C
(only for fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9)


Continuative documentation about explosion protection

Mounting and wiring [image] Continuative documentation about explosion protection
Continuative documentation about explosion protection
Explosion protection for terminal systems
Pay also attention to the continuative documentation

Notes on the use of the Beckhoff terminal systems in hazardous areas according to ATEX and IECEx

that is available for download on the Beckhoff homepage https:\\www.beckhoff.com!


UL notice

Mounting and wiring [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:


Parameterization and commissioning

Parameterization and commissioning
Parameterization and commissioning
Additional information
•
Start-up behavior of the Bus Coupler
•
EKxxxx - Optional Distributed Clocks support
•
KL register communication
•
TwinCAT System Manager
•
KS2000 configuration software


Start-up behavior of the Bus Coupler

Parameterization and commissioning [image] Start-up behavior of the Bus Coupler
Start-up behavior of the Bus Coupler
Immediately after being switched on, the Bus Coupler checks, in the course of a self test, all the functions of its components and the communication on the K-bus/E-bus. The red I/O LED blinks while this is happening After completion of the self-test, the Bus Coupler starts to test the attached Bus Terminals (the "Bus Terminal Test"), and reads in the configuration. The Bus Terminal configuration is used to generate an internal structure list, which is not accessible from outside. In case of an error, the Bus Coupler enters the Stop state. Once the start-up has completed without error, the Bus Coupler enters the fieldbus start state.
Flow chart showing start-up behavior of the Bus Coupler
The Bus Coupler can be made to enter the normal operating state by switching it on again once the fault has been rectified.


EKxxxx - Optional Distributed Clocks support

Parameterization and commissioning [image] EKxxxx - Optional Distributed Clocks support
EKxxxx - Optional Distributed Clocks support
Basic principles Distributed Clocks (DC)
The EtherCAT Distributed Clocks system comprises local clocks that are integrated in the EtherCAT slaves and are synchronized by the EtherCAT master via special datagrams. Not all EtherCAT slaves support the Distributed Clocks procedure. It is only supported by slaves whose function requires it. In the TwinCAT System Manager a slave indicates its DC capability by showing “DC” in the settings dialog.
DC tab for indicating the Distributed Clocks function
Once of these local clocks is the reference clock, based on which all other clocks are synchronized. See also explanatory notes in the Basic EtherCAT documentation. The reference clock must be the first DC-capable EtherCAT slave. By default TwinCAT therefore selects the first DC-capable device as reference clock. This is shown (and can be modified by the user) under advanced properties of the EtherCAT master. The standard setting should not be changed, except in cases where external synchronization is recommended in the relevant documentation, for example.
Advanced Distributed Clocks settings in the EtherCAT master
The figure shows how TwinCAT selects the EL1252 as reference clock by default, since the preceding components do not support DC.
Settings EtherCAT device
System and infrastructure devices such as EK1100 or EK1122 couplers and junction etc. do not require Distributed Clocks to function properly. Nevertheless, it may be topologically expedient to designate the first coupler in an EtherCAT system as reference clock, for example. For this reason, from a certain level the infrastructure components are able to operate as reference clocks, based on special configuration settings.
According to the following table (DC support from rev/firmware version), the components support activation of distributed clocks:
Device | XML revision in the configuration | Serial number of the component
BK1150 | from BK1150-0000-0016 | from firmware 01: xxxx01yy
CU1128 | from CU1128-0000-0000 | from firmware 00: xxxx00yy
EK1100 | from EK1100-0000-0017 | from firmware 06: xxxx06yy
EK1101 | from EK1101-0000-0017 | from firmware 01: xxxx01yy
EK1501 | from EK1501-0000-0017 | from firmware 01: xxxx01yy
EK1501-0010 | from EK1501-0010-0017 | from firmware 02: xxxx02yy
EK1122 | from EK1122-0000-0017 | from firmware 01: xxxx02yy
EK1521 | from EK1521-0000-0018 | from firmware 03: xxxx03yy
EK1541 | from EK1541-0000-0016 | from firmware 01: xxxx01yy
EK1561 | from EK1561-0000-0016 | from firmware 01: xxxx01yy
EK1521-0010 | from EK1521-0010-0018 | from firmware 03: xxxx03yy
EK1814 | from EK1814-0000-0016 | from firmware 00: xxxx00yy
To ensure that TwinCAT uses such a component as DC reference clock, a manual intervention during the configuration setup is required, as shown here using the EK1100 as an example.
The checkboxes “Cyclic Mode Enable” and “Use as potential Reference Clock” must be set.
TwinCAT setting for using this component as reference clock
Activation of Distributed Clocks support
The (synchronization) procedure described here is only successful for the components described above. The checkboxes can be set for other components, too, although the hardware does not support this function, unless specified in the respective documentation. In particularly, please note that after commissioning the component may not be replaced with a previous version without DC support.


KL register communication

Parameterization and commissioning [image] KL register communication
KL register communication
Additional information
•
Parameterization of KL terminals
•
Configuration of KL terminals via EtherCAT
•
Online parameterization of KL terminals via CoE
•
Online parameterization of KL terminals via AoE
•
Beckhoff coupler tables


Parameterization of KL terminals

Parameterization and commissioning [image] KL register communication [image] Parameterization of KL terminals
Parameterization of KL terminals
If a KL terminal supports this kind of parameterization, the parameters can be changed via the KL register communication. The parameters are managed in so-called registers in the terminal.
They can be changed during the startup phase or online during operation.
The available parameters/registers are described in the corresponding terminal documentation. In these chapters, only the route to the registers via EtherCAT is described.
The following 3 routes are available; all require the coupler as a gateway:
▪
Change during the EtherCAT startup phase via the coupler’s CoE startup list
This ensures that the terminal is parameterized correctly and immediately, even after the terminal is exchanged.
▪
Change during operation
–
via EtherCAT CoE access to the coupler
–
via AoE access (ADS over EtherCAT) from a TwinCAT system by means of ADS commands on the KL terminal
As a rule, it is not necessary to reboot the KL terminal after a parameter change; see terminal documentation.
▪
KS2000 configuration software
The KS2000 software for parameterizing KL terminals runs on Windows IPCs and can communicate with the terminals and the upstream coupler via two communication channels:
–
Internal ADS.
–
External via a serial RS232 COM cable or a USB cable. Both are available from Beckhoff. A KS2000 interface at the coupler (e.g. BK1120) is a prerequisite for external access.
Register access on KL terminals
ADS access
In contrast to COM access via a cable, ADS access is not limited to the local IPC platform. The routing capabilities of each TwinCAT IPC enable the KL registers to be accessed from other TwinCAT stations.


Configuration of KL terminals via EtherCAT

Parameterization and commissioning [image] KL register communication [image] Configuration of KL terminals via EtherCAT
Configuration of KL terminals via EtherCAT
The following is an explanation of how register communication with the KL terminals is parameterized during the EtherCAT start-up.
This ensures that the KL terminal used always contains the desired register set, even if the terminal (hardware) is exchanged, because the register data is written to the KL terminal again at the next start-up of the system or EtherCAT.
The principle:
▪
a set of calls is stored in the CoE startup list of the BK11x0/BK1250 for each terminal to be parameterized.
▪
the entering and cancelling of the code word must thereby be included if required.
▪
the startup entries are processed in succession by the TwinCAT EtherCAT master during the start-up.
▪
in doing so, confirmed mailbox communication takes place, so that the next entry will be initiated only when the previous one has been successfully completed.
▪
no check is made of whether certain values already exist in the KL terminal; the defined startup entries will be written to the terminal position in all cases.
▪
the startup entries are to be sent in the PREOP -> SAFEOP transition.
This is the process to be adhered to for each terminal:
▪
entry of the terminal number to CoE 0x427F: 00 as a 2-byte value
the first KL terminal after the BK11x0/BK1250 also has the number 1; accordingly consecutive.
▪
if necessary: set the code word in register 31
0x4280:20 = 0x1235.
▪
List the register values sequentially; subindexhex = register number + 1
e.g. 0x4280: 21 = 0x0800
See table, among others, for the required CoE index.
▪
if the code word was needed: delete the code word in order to accept data
0x4280:20 = 0.
▪
deselect terminal selection by CoE 0x427F: 00 = 0
Information for the register values
▪
a KL terminal can have a maximum of 4 parameterisable channels/register pages; see the corresponding terminal documentation.
▪
each channel/register page has n registers, 0 – 63 is usual.
▪
each register is accessible via the CoE sub-index: Subindexhex = Register number + 1.
▪
the following assignments apply to the channels/register pages:
Channel | Register | CoE Index
Channel /Register page 0 | Register 0 - 63 | 0x4280
 | Register > 63 (if available) | 0x4281
Channel /Register page 1 | Register 0 - 63 | 0x4282
 | Register > 63 (if available) | 0x4283
Channel /Register page 2 | Register 0 - 63 | 0x4284
 | Register > 63 (if available) | 0x4285
Channel /Register page 3 | Register 0 - 63 | 0x4286
 | Register > 63 (if available) | 0x4287
Code word
The user parameters in registers 32 - 47 can only be changed if the code word 0x1235 is written in register 31. Register 31 must be set back to 0 for non-volatile storage of the modified user parameters in the terminal.
Please refer to the corresponding terminal documentation for access to the register.
Example
TwinCAT 2:11 b1539 and a BK1120 with firmware B8 were used in the following example.
In an existing configuration (scanned or manually created), the user scaling (offset) of the KL3314 is to be changed in the startup list of the BK1120 coupler in order to ensure that the desired scaling is also saved in the terminal in the event of the terminal being exchanged.
2 entries have already been created: selection of terminal 3 and setting of the code word.
Now the user scaling (offset) will be set in register 33 (see terminal documentation). A right click opens the "Insert" dialog.
Insert dialog
The following is to be entered in the dialogue
▪
The state transition P -> S
▪
the sub-index as register number + 1
in this case: Register 33dec = Subindex 22hex
▪
the hexadecimal register value as a byte pair, the high-order byte first
in this case: Set value 1234dec = 04D2hex
Data entry
The complete entry is shown in Fig. Entry.
Entry
Since the code word was used, it must also be reset in order to complete the terminal access.
Complete terminal access
More extensive register access is possible, if required, see Fig. Access to two KL terminals. In this case, two KL2541s with the numbers 3 and 4 will be parameterized in the startup phase.
Access to two KL terminals


Online parameterization of KL terminals via CoE

Parameterization and commissioning [image] KL register communication [image] Online parameterization of KL terminals via CoE
Online parameterization of KL terminals via CoE
In the same way as with the CoE startup entry (CANopen over EtherCAT), online access to a KL terminal is also possible via the CoE directory of the BK11x0/BK1250 EtherCAT coupler used. Using this route, access to the coupler-internal tables or to the registers in the terminals is possible.
The coupler-internal tables are displayed in the CoE directory; the terminal registers can be dynamically displayed and edited via the 0x4280ff indices.
Online CoE directory of the BK11x0
The CoE directory (B) of the BK11x0 (A) includes the coupler tables (C) and the terminal-specific registers (D).
Coupler tables
▪
from CoE 0x4000
Terminal register
▪
Set terminal number CoE 0x427F: 0 as a 2-byte value
▪
Address register in CoE 0x4280 - 0x4287
–
a KL terminal has a maximum of 4 channels [0 - 3], which have n registers
the registers 0 - 63 are each in channel n (LO)
the registers > 63 (if available) are each in channel n (HI)
–
the sub-index corresponds to the register number: Subindexhex = Register number + 1
–
specify values /data as a 2-byte value
Online display based on Fig. Online CoE directory of the BK11x0
The online display of register values, as shown in Fig. 1 in the CoE directory from CoE objects 0x4280ff, only works for KL terminals with register communication. If a terminal number is specified in CoE object 0x427F:
- which does not exist
- whose terminals do not feature register communication
the System Manager logger window shows "SDO Abort".
Example
Download ( )
In this example program (TwinCAT 2.11, BK1120 with firmware 08), AoE and CoE register communication with a KL3314 (thermocouple terminal) is executed in the PLC. Here, register R34 (user scaling, offset) in Channel 1 is repeatedly incremented - success can be verified with the KS2000 software or via the visualization page; to do this, connect a type K thermocouple to channel 1.
Note: In the startup list of the BK1120, entries are available that set the user offset to a start value at each switch-on or INIT-OP transition.


Online parameterization of KL terminals via AoE

Parameterization and commissioning [image] KL register communication [image] Online parameterization of KL terminals via AoE
Online parameterization of KL terminals via AoE
Access via AoE (ADS over EtherCAT) is useful from TwinCAT 2:11. An additional AoE NetId is required for the coupler used, so that the TwinCAT-internal ADS router can access it. It is useful to link this AoE NetId with the PLC program.
The same procedure is described here to access the KL terminals with the KS2000 software via ADS.
Activation of the AoE NetID
The AoE NetId can be generated in the advanced settings of the BK11x0/BK1250. Optionally, it can be initialized with a pre-specified (unique!) start value.
After a TwinCAT restart it is available in the ADS router and can be used, for example, from the PLC.
The following applies to ADS accesses:
▪
AmsNetId: AoE NetID
▪
Port: 100
▪
IdxGrp: 0= coupler, 1.. = terminal number
▪
IdxOffset:
Channel | IdxGrp = 0, coupler | IdxGrp> 0, terminal number
High Word | Coupler table, e.g. 99 | Terminal channel [0 - 3] for the channels 1 - 4
Low Word | Register | Register
A possible call would be:
▪
AmsNetId: 172.16.8.29.3.10
▪
Port: 100
▪
IdxGrp: 3 (3rd terminal after the coupler)
▪
IdxOffset: 0x0001001F (channel 2 of the terminal and register 31 [code word])
Example
Download ( )
In this example program (TwinCAT 2.11, BK1120 with firmware 08), AoE and CoE register communication with a KL3314 (thermocouple terminal) is executed in the PLC. Here, register R34 (user scaling, offset) in Channel 1 is repeatedly incremented - success can be verified with the KS2000 software or via the visualization page; to do this, connect a type K thermocouple to channel 1.
Note: In the startup list of the BK1120, entries are available that set the user offset to a start value at each switch-on or INIT-OP transition.


Beckhoff coupler tables

Parameterization and commissioning [image] KL register communication [image] Beckhoff coupler tables
Beckhoff coupler tables
The Beckhoff BK/BCxxxx Fieldbus Couplers feature internal information lists referred to as tables that are identified by unique numbers. The BK11x0/BK1250 maps these tables in its CoE directory, see Object overview.
Tables 0, 9, 90, 98, 99, 100 and 127 are available.
Table 9
Table 9, which maps the scanned state of the added terminals after the coupler is switched on, i.e. the status with which the terminals have identified themselves at the coupler, is helpful for terminal bus analysis. The first 63 K-bus devices are listed in CoE index 0x4012 and/or its subindices, the remaining devices in CoE index 0x4013 , see Fig. Table 9 with terminal type.
Table 9 with terminal type
SubIndex 1 is the "name" of the coupler itself, the terminals follow from subindex 2. Subindex 0 contains the number of terminals that were found. Since the subindex 1 contains the coupler name itself, the value in subindex 0 corresponds to the number of terminals, including the KL9010.
For each KL/KM terminal the type is specified as a 16-bit value based on the following key (see index 0x4012)
Terminal type | High byte |  |  |  |  |  |  |  | Low byte
 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
complex terminal (e.g. analog terminals) | 0 | terminal type (decimal) from terminal reg. 8
simple digital input/output terminals | 1 | process data configuration [bit] |  |  |  |  |  |  | shift register Extension |  |  |  |  | 1: KL1212 | 1: output terminal | 1: input terminal


TwinCAT System Manager

Parameterization and commissioning [image] TwinCAT System Manager
TwinCAT System Manager
Additional information
•
BK1120, BK1150 - configuration overview
•
BK1250 - configuration overview
•
Inputs - configuration overview
•
Outputs - configuration overview
•
Status of the working counter (Wc state) - - configuration overview
•
Online status (info data) - configuration overview
•
ADS address (ADSAddr) - configuration overview
•
EtherCAT cycle time - configuration overview
•
Object description
•
Mapping the Bus Terminals
•
Process image example


BK1120, BK1150 - configuration overview

Parameterization and commissioning [image] TwinCAT System Manager [image] BK1120, BK1150 - configuration overview
BK1120, BK1150 - configuration overview
In the TwinCAT System Manager, in Config mode under Devices enter the BK1120 / BK1150 as EtherCAT device (Fig. TwinCAT tree showing BK1120 as example). Any Bus Couplers already connected to the network can also be read. This will cause all the Bus Couplers with Bus Terminals and their configurations to be loaded. You can then adapt these to meet your requirements.
TwinCAT tree showing BK1120 as example


BK1250 - configuration overview

Parameterization and commissioning [image] TwinCAT System Manager [image] BK1250 - configuration overview
BK1250 - configuration overview
The BK1250 can be added in the TwinCAT System Manager (Config mode) as a further box under a corresponding coupler (e.g. EK1100) by right-clicking in the terminal network (Fig. TwinCAT tree BK1250). If the Bus Coupler is already integrated in the network, it is automatically added as a box during scanning. Subsidiary Bus Terminals and their configuration are also uploaded.
TwinCAT tree BK1250


Inputs - configuration overview

Parameterization and commissioning [image] TwinCAT System Manager [image] Inputs - configuration overview
Inputs - configuration overview
CouplerState, "Online" tab
Display of general coupler errors.
CouplerState, "Online" tab


Outputs - configuration overview

Parameterization and commissioning [image] TwinCAT System Manager [image] Outputs - configuration overview
Outputs - configuration overview
CouplerCtrl, "Online" tab
Display of K-bus errors or deactivation of outputs.
CouplerCrtl, "Online" tab


Status of the working counter (Wc state) - - configuration overview

Parameterization and commissioning [image] TwinCAT System Manager [image] Status of the working counter (Wc state) - - configuration overview
Status of the working counter (Wc state) - - configuration overview
WCstate, "Online" tab
Boolean variable indicating the working counter status of coupler. An invalid working counter (value: 1) is displayed if invalid data were transferred by the EtherCAT slave controller.
WCstate, "Online" tab


Online status (info data) - configuration overview

Parameterization and commissioning [image] TwinCAT System Manager [image] Online status (info data) - configuration overview
Online status (info data) - configuration overview
State, "Online" tab
Indicates the online status of the coupler.
State, "Online" tab
Value | Description
0x___1 | Slave in 'INIT' state
0x___2 | Slave in 'PREOP' state
0x___3 | Slave in 'BOOT' state
0x___4 | Slave in 'SAFEOP' state
0x___8 | Slave in 'OP' state
0x001_ | Slave signals error
0x002_ | Invalid vendorId, productCode... read
0x004_ | Initialization error occurred
0x010_ | Slave not present
0x020_ | Slave signals link error
0x040_ | Slave signals missing link
0x080_ | Slave signals unexpected link
0x100_ | Communication port A
0x200_ | Communication port B
0x400_ | Communication port C
0x800_ | Communication port D


ADS address (ADSAddr) - configuration overview

Parameterization and commissioning [image] TwinCAT System Manager [image] ADS address (ADSAddr) - configuration overview
ADS address (ADSAddr) - configuration overview
ADSAddr, Online tab
Single line indicating the AMS NetID and the AMS port of the coupler using the hexadecimal system. This information is required for mailbox communication via ADS.
Sample:
AC 10 06 31 02 01 (AMS netID) = 172.16.06.49.2.1
03 E9 (port) = 1001dec
ADSAddr, "Online" tab


EtherCAT cycle time - configuration overview

Parameterization and commissioning [image] TwinCAT System Manager [image] EtherCAT cycle time - configuration overview
EtherCAT cycle time - configuration overview
The EtherCAT cycle time with which the couplers can be operated should be considered in conjunction with the achieved K-bus cycle time. The cycle time achieved with the K-bus terminals is shown in the BK1250 tab (or BK1120 / BK1150).
BK1250, "BK1250" tab
If the EtherCAT cycle time exceeds the K-bus cycle time both systems operate in synchronous mode. The K-bus is started after an EtherCAT telegram and copies its inputs into the memory. They are retrieved with the next EtherCAT telegram, i.e. the inputs are always one cycle old.
If the EtherCAT cycle is shorter than the K-bus cycle, the K-bus operates asynchronous relative to EtherCAT. Faster polling than "Estimated Cycle (offline)" is therefore possible but may lead to outdated input data or outputs not being set in time via the K-bus.
The EtherCAT cycle applied to the BK1120 / BK1150 (BK1250) should therefore be significantly greater than the "Estimated Cycle (offline)" (min. 250 µs, depending on the Bus Terminal configuration). Online control in the system through "Max. Cycle (online)" or "CouplerState" is recommended.


Object description

Parameterization and commissioning [image] TwinCAT System Manager [image] Object description
Object description
Additional information
•
Standard objects
•
Device-specific objects


Standard objects

Parameterization and commissioning [image] TwinCAT System Manager [image] Object description [image] Standard objects
Standard objects
Index 1000: Device type
Device type (read only) of the EtherCAT slave.
Index 1008 Device name
Device name (read only, value: e.g. BK1120-0000-0000) of the EtherCAT slave.
Index 1009 Hardware version
Hardware version (read only) of the EtherCAT slave.
Index 100A Software version
Version (read only, value: e.g. 07 (B7)) of the firmware (chip for processing the I/O signals) of the EtherCAT slave.
Index 1018 Identity object
Index (hex) | Name | Meaning | Flags | Default
1018:0 | Identity object | Length of this object | RO | -
1018:01 | Vendor id | Vendor ID of the EtherCAT slave | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | RO | 0x04602C22 (73411618dec)
1018:03 | Revision number | Revision number of the EtherCAT slave | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave | RO | 0x00000000 (0dec)
Index 16kk RxPDO Mapping Terminal
Value ranges:
(kk = 00..FE)hex ,
[(hh = 01..FF)hex ,(ddd = 001..255)]dec
Index (hex) | Name | Meaning | Flags | Default
16kk:0 | RxPDO Mapping Terminal | Length of this object | RW | -
16kk:01 | Output Mapping Area 001 | First output variable of this terminal (subindex 001) | RW | e.g. 0x7kk0:01, 1
16kk:hh | Output Mapping Area ddd | Last output variable (subindex ddd) | RW | e. g. 0x7kk0:hh, 1
Index 16FF Control PDO
Index (hex) | Name | Meaning | Flags | Default
16FF:0 | Control PDO | Length of this object | RW | -
16FF:01 | Output Mapping Area | Control word | RW | 0xF200:01, 16
Index 1701 RxPDO Digital Align
Index (hex) | Name | Meaning | Flags | Default
1701:0 | RxPDO Digital Align | Length of this object | RW | -
1701:01 | PDO Align | Word Alignment Dummy for Digital RxPDOs | RW | 0x0000:00, 00
Index 1Akk TxPDO Mapping Terminal
Value ranges:
(kk = 00..FE)hex ,
[(hh = 01..FF)hex, (ddd = 001..255)dec]
Index (hex) | Name | Meaning | Flags | Default
1Akk:0 | TxPDO Mapping Terminal | Length of this object | RW | -
1Akk:01 | Input Mapping Area 001 | First input variable of this terminal (subindex 001) | RW | e.g. 0x6kk0:01, 1
1Akk:hh | Input Mapping Area ddd | Last input variable for this terminal (subindex ddd) | RW | e.g. 0x6kk0:hh, 1
Index 1AFF Status PDO
Index (hex) | Name | Meaning | Flags | Default
16FF:0 | Status PDO | Length of this object | RW | -
16FF:01 | Input Mapping Area | Status word | RW | 0xF100:01, 16
Index 1B01 TxPDO Digital Align
Index (hex) | Name | Meaning | Flags | Default
1B01:0 | TxPDO Digital Align | Length of this object | RW | -
1B01:01 | PDO Align | Word Alignment Dummy for Digital TxPDOs | RW | 0x0000:00, 00
Index 1C00 SM type
Index (hex) | Name | Meaning | Flags | Default
1C00:0 | Sync Manager Type | Length of this object | RO | 4
1C00:01 | Subindex 001 | Sync manager, parameter 1 | RO | 0x01 (1dec)
1C00:02 | Subindex 002 | Sync manager, parameter 2 | RO | 0x02 (2dec)
1C00:03 | Subindex 003 | Sync manager, parameter 3 | RO | 0x03 (3dec)
1C00:04 | Subindex 004 | Sync manager, parameter 4 | RO | 0x04 (4dec)
Index 1C12 RxPDO Assign
Value ranges:
[(hh = 01..FF)hex, (ddd = 001..255)dec]
Index (hex) | Name | Meaning | Flags | Default
1C12:0 | RxPDO Assign | Length of this object | RW | -
1C32:01 | Subindex 001 | Assignment of the control PDO | RW | 0x16FF(5887dec)
1C12:02 | Subindex 002 | Assignment of first RxPDO analog terminals | RW | e.g. 0x1603 (5635dec)
1C12:nn | Subindex nnn | Assignment of nth RxPDO analog terminals | RW | e.g. 0x1605 (5637dec)
1C12:(nn+1) | Subindex (nnn+1) | Assignment of (n+1)th RxPDO digital terminals | RW | e.g. 0x1600 (5632dec)
1C12:hh | Subindex ddd | Assignment Word Alignment Dummy for Digital RxPDOs | RW | 0x1701(5889dec)
Index 1C13 TxPDO Assign
Value ranges:
[(hh = 01..FF)hex, (ddd = 001..255)dec]
Index (hex) | Name | Meaning | Flags | Default
1C13:0 | TxPDO Assign | Length of this object | RW | -
1C13:01 | Subindex 001 | Assignment of the control PDO | RW | 0x1AFF(6911dec)
1C13:02 | Subindex 002 | Assignment of first TxPDO analog terminals | RW | e.g. 0x1A03 (6659dec)
1C13:nn | Subindex nnn | Assignment of nth TxPDO analog terminals | RW | e.g. 0x1A05 (6661dec)
1C13:(nn+1) | Subindex (nnn+1) | Assignment of (n+1)th TxPDO digital terminals | RW | e.g. 0x1A01 (6657dec)
1C13:hh | Subindex ddd | Assignment Word Alignment Dummy for Digital TxPDOs | RW | 0x1B01(6913dec)


Device-specific objects

Parameterization and commissioning [image] TwinCAT System Manager [image] Object description [image] Device-specific objects
Device-specific objects
Index 4000 Coupler Table 0 [LO]: general configuration of the Bus Coupler
Index (hex) | Name | Meaning | Flags | Default
4000:0 | Coupler Table 0 [LO] | Length of this object | RW | 128
4000:01 | Subindex 001 | Register 0 | RW |
4000:02 | Subindex 002 | Register 1 | RW |
4000:80 | Subindex 128 | Register 127 | RW |
Index 4001 Coupler Table 0 [HI]: general configuration of the Bus Coupler (cont.)
Index (hex) | Name | Meaning | Flags | Default
4001:0 | Coupler Table 0 [HI] | Length of this object | RW | 128
4001:01 | Subindex 001 | Register 128 | RW |
4001:02 | Subindex 002 | Register 129 | RW |
4001:80 | Subindex 128 | Register 255 | RW |
Index 4012 Coupler Table 9 [LO]: Configuration of the Bus Terminal block
Index (hex) | Name | Meaning | Flags | Default
4012:0 | Coupler Table 9 [LO] | Length of this object | RO | max. 128
4012:01 | Subindex 001 | Register 0: Name of the Bus Coupler | RO | 0x0460 (1120dec1)
4012:02 | Subindex 002 | Register 1: Name of the first terminal | RO | e.g.: 0x8201 (33281dec2)
4012:03 | Subindex 003 | Register 2: Name of the 2nd terminal | RO | e.g.: 0x0BBA (3002dec1)
4012:04 | Subindex 004 | Register 3: Name of the 3rd terminal | RO | e.g.: 0x0C84 (3204dec1)
4012:80 | Subindex 128 | Register 127: Name of the 127th terminal | RO |
1) For Bus Coupler and intelligent (e.g. analog) terminals, the terminal designation is
specified decimally in plain text; e.g. 0x0C84 (3204dec) means KL3204.
2) For simple (digital) terminals, the following coding applies:
Bit | Value | Meaning
15 | 0bin | intelligent (e.g. analog) terminal
 | 1bin | simple (digital) terminal
14...8 | xxxxxxbin | terminal size in bit (range of values: 0 to 63 bit)
7 | 1bin | Shift register extension for Control Panels
6...3 | 0bin | reserved
2 | 1bin | KL1212
1 | 1bin | Output terminal | Special case: 00bin means KL1202 or KL2212 (digital terminals with input and output data)
0 | 1bin | Input terminal
Index 4013 Coupler Table 9 [HI]: Configuration of the Bus Terminal block (continuation if more than 127 terminals)
Index (hex) | Name | Meaning | Flags | Default
4013:0 | Coupler Table 9 [HI] | Length of this object | RO | max. 128dec
4013:01 | Subindex 001 | Register 128: Name of the 128th terminal | RO |
4013:02 | Subindex 002 | Register 129: Name of the 129th terminal | RO |
4013:04 | Subindex 128 | Register 255: Name of the 255th terminal | RO |
Index 40B4 Coupler Table 90 [LO]: Internal diagnostic information for the Bus Coupler
Index (hex) | Name | Meaning | Flags | Default
40B4:0 | Coupler Table 90 [LO] | Length of this object | RO | 128dec
40B4:01 | Subindex 001 | Register 0: reserved | RO |
40B4:02 | Subindex 002 | Register 1: reserved | RO |
40B4:04 | Subindex 128 | Register 127: reserved | RO |
Index 40B5 Coupler Table 90 [HI]: Internal diagnostic information for the Bus Coupler (cont.)
Index (hex) | Name | Meaning | Flags | Default
40B5:0 | Coupler Table 90 [HI] | Length of this object | RO | 128dec
40B5:01 | Subindex 001 | Register 128: reserved | RO |
40B5:02 | Subindex 002 | Register 129: reserved | RO |
40B5:04 | Subindex 128 | Register 255: reserved | RO |
Index 40C4 Coupler Table 98 [LO]: Pd Update time (µs)
Index (hex) | Name | Meaning | Flags | Default
40C4:0 | Coupler Table 98 Pd Update time (µs) | Length of this object | RW | 5
40C4:01 | Min time | minimum update time on the K-bus | RW | 0x0355 (853dec)
40C4:02 | Max time | maximum update time on the K-bus | RW | 0x059A (1434dec)
40C4:03 | Curr time | current update time on the K-bus | RW | 0x036A (874dec)
40C4:04 | - | reserved | RW | 0x0000 (0dec)
40C4:50 | - | reserved | RW | 0x09F8 (2552dec)
Index 40C5 Coupler Table 98 [HI]: Pd update time (µs) (cont.)
Index (hex) | Name | Meaning | Flags | Default
40C5:0 | Coupler Table 98 Pd Update time (µs) | Length of this object | RW | 0
Index 40C8 Coupler Table 100 [LO]: Reserved for internal fieldbus-specific settings
Index (hex) | Name | Meaning | Flags | Default
40C8:0 | Coupler Table 100 [LO] | Length of this object | RO | 128dec
40C8:01 | Subindex 001 | Register 0: reserved | RO |
40C8:02 | Subindex 002 | Register 1: reserved | RO |
40C8:04 | Subindex 128 | Register 127: reserved | RO |
Index 40C9 Coupler Table 100 [HI]: Reserved for internal fieldbus-specific settings (cont.)
Index (hex) | Name | Meaning | Flags | Default
40C9:0 | Coupler Table 100 [HI] | Length of this object | RO | 128dec
40C9:01 | Subindex 001 | Register 128: reserved | RO |
40C9:02 | Subindex 002 | Register 129: reserved | RO |
40C9:04 | Subindex 128 | Register 255: reserved | RO |
Index 40FE Coupler Table 127 [LO]: Reserved for internal settings
Index (hex) | Name | Meaning | Flags | Default
40FE:0 | Coupler Table 100 [LO] | Length of this object | RO | 128dec
40FE:01 | Subindex 001 | Register 0: reserved | RO |
40FE:02 | Subindex 002 | Register 1: reserved | RO |
40FE:04 | Subindex 128 | Register 127: reserved | RO |
Index 40FF Coupler Table 127 [HI]: Reserved for internal settings (cont.)
Index (hex) | Name | Meaning | Flags | Default
40FF:0 | Coupler Table 100 [HI] | Length of this object | RO | 128dec
40FF:01 | Subindex 001 | Register 128: reserved | RO |
40FF:02 | Subindex 002 | Register 129: reserved | RO |
40FF:04 | Subindex 128 | Register 255: reserved | RO |
Index 427F Terminal No
Index (hex) | Name | Meaning | Flags | Default
427F:0 | Terminal No | Number of the terminal in the Bus Terminal block, which can be parameterized with the following four tables (object 4280 - 4287). Counting method: the Bus Coupler is no. 0 in the Bus Terminal block. The first terminal connected to the Bus Coupler is no. 1 etc. Only intelligent terminals (with register set) can be parameterized! | RO | 3
Index 4280 Terminal Table 0 [LO]: for parameterization of the terminal specified with object 427F
Index (hex) | Name | Meaning | Flags | Default
4280:0 | Terminal Table 0 | Length of this object | RW | 64
4280:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dec)
4280:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dec)
4280:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dec)
Index 4281 Terminal Table 0 [HI]: for parameterization of the terminal specified with object 427F (cont.)
Index (hex) | Name | Meaning | Flags | Default
4081:0 | Terminal Table 0 | Length of this object | RW | 0
Index 4282 Terminal Table 1 [LO]: for parameterization of the terminal specified with object 427F
Index (hex) | Name | Meaning | Flags | Default
4282:0 | Terminal Table 1 | Length of this object | RW | 64
4282:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dec)
4282:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dec)
4282:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dec)
Index 4283 Terminal Table 1 [HI]: for parameterization of the terminal specified with object 427F (cont.)
Index (hex) | Name | Meaning | Flags | Default
4083:0 | Terminal Table 1 | Length of this object | RW | 0
Index 4284 Terminal Table 2 [LO]: for parameterization of the terminal specified with object 427F
Index (hex) | Name | Meaning | Flags | Default
4284:0 | Terminal Table 2 | Length of this object | RW | 64
4284:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dec)
4284:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dec)
4284:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dec)
Index 4285 Terminal Table 2 [HI]: for parameterization of the terminal specified with object 427F (cont.)
Index (hex) | Name | Meaning | Flags | Default
4085:0 | Terminal Table 2 | Length of this object | RW | 0
Index 4286 Terminal Table 3 [LO]: for parameterization of the terminal specified with object 427F
Index (hex) | Name | Meaning | Flags | Default
4286:0 | Terminal Table 3 | Length of this object | RW | 64
4286:01 | Subindex 001 | Register 0 | RW | 0x0000 (0dec)
4286:02 | Subindex 002 | Register 1 | RW | 0x0000 (0dec)
4286:40 | Subindex 064 | Register 63 | RW | 0x0000 (0dec)
Index 4287 Terminal Table 3 [HI]: for parameterization of the terminal specified with object 427F (cont.)
Index (hex) | Name | Meaning | Flags | Default
4087:0 | Terminal Table 3 | Length of this object | RW | 0
Index 6kk0 Terminal Input Data
Mapping
The value ranges of the "kk", "hh", and "ddd" variables of the input and output indices are shown below. The dynamic generation of the input and output objects depends on the order of the terminals in the Bus Terminal block.
Example configuration of the Bus Terminal block
BK1120 - KL1408 - KL2032 - K3403 - KL4032
Mapping of the assigned PDOs (from index 0x6000)
Index (hex) | Name | Meaning
6000:0 | KL1408 | KL1408, max. Subindex (8) | Position 1 after the coupler: KL1408 | Input data
6000:01 | Channel 1 | Channel 1, KL1408
6000:02 | Channel 2 | Channel 2, KL1408
6000:03 | Channel 3 | Channel 3, KL1408
6000:04 | Channel 4 | Channel 4, KL1408
6000:05 | Channel 5 | Channel 5, KL1408
6000:06 | Channel 6 | Channel 6, KL1408
6000:07 | Channel 7 | Channel 7, KL1408
6000:08 | Channel 8 | Channel 8, KL1408
6010:0 |  | not mapped, since no inputs available | Position 2 after the coupler: KL2032
6020:0 | KL3403 | KL3403, max. Subindex (9) | Position 3 after the coupler: KL3403
6020:01 | Channel 1 Status | Channel 1, status, KL3403
6020:02 | Channel 1 Word Aligment | Channel 1, word alignment KL3403
6020:03 | Channel 1 Data | Channel 1, data KL3403
6020:04 | Channel 2 Status | Channel 2, status, KL3403
6020:05 | Channel 2 Word Aligment | Channel 2, word alignment, KL3403
6020:06 | Channel 2 Data | Channel 2, data, KL3403
6020:07 | Channel 3 Status | Channel 3, status, KL3403
6020:08 | Channel 3 Word Aligment | Channel 3, word alignment, KL3403
6020:09 | Channel 3 Data | Channel 3, data, KL3403
6030:0 | KL4032 | KL4032, max. Subindex (6) | Position 4 after the coupler: KL4032
6030:01 | Channel 1 Status | Channel 1, status, KL4032
6030:02 | Channel 1 Word Aligment | Channel 1, word alignment KL4032
6030:03 | Channel 1 Data | Channel 1, data KL4032
6030:04 | Channel 2 Status | Channel 2, status, KL4032
6030:05 | Channel 2 Word Aligment | Channel 2, word alignment KL4032
6030:06 | Channel 2 Data | Channel 2, data, KL4032
Index (hex) | Name | Meaning
7000:0 |  | not mapped, since no outputs available | Position 1 after the coupler: KL1408 | Output data
7010:0 | KL2032 | KL2032, max. Subindex (2) | Position 2 after the coupler: KL2032
7010:01 | Channel 1 | Channel 1, KL2032
7010:02 | Channel 2 | Channel 2, KL2032
7020:0 | KL3403 | KL3403, max. Subindex (9) | Position 3 after the coupler: KL3403
7020:01 | Channel 1 Status | Channel 1, status, KL3403
7020:02 | Channel 1 Word Aligment | Channel 1, word alignment KL3403
7020:03 | Channel 1 Data | Channel 1, data KL3403
7020:04 | Channel 2 Status | Channel 2, status, KL3403
7020:05 | Channel 2 Word Aligment | Channel 2, word alignment, KL3403
7020:06 | Channel 2 Data | Channel 2, data, KL3403
7020:07 | Channel 3 Status | Channel 3, status, KL3403
7020:08 | Channel 3 Word Aligment | Channel 3, word alignment, KL3403
7020:09 | Channel 3 Data | Channel 3, data, KL3403
7030:0 | KL4032 | KL4032, max. Subindex (6) | Position 4 after the coupler: KL4032
7030:01 | Channel 1 Status | Channel 1, status, KL4032
7030:02 | Channel 1 Word Aligment | Channel 1, word alignment KL4032
7030:03 | Channel 1 Data | Channel 1, data KL4032
7030:04 | Channel 2 Status | Channel 2, status, KL4032
7030:05 | Channel 2 Word Aligment | Channel 2, word alignment KL4032
7030:06 | Channel 2 Data | Channel 2, data, KL4032
Value ranges:
(kk = 00..FF)hex, [(hh = 01..FF)hex, (ddd = 001..255)dec]
Index (hex) | Name | Meaning | Flags | Default
6kk0:0 | Terminal Input Data | [Terminal designation] | RO P | -
6kk0:01 | Channel 001 | Channel 001 | RO P | -
6kk0:hh | Channel ddd | Channel ddd | RO P | -
Non-digital terminals (for hh ≥ 03; ddd ≥ 003):
Value ranges:
(kk = 00..FF)hex, dec. increment (hex)
[(hh = 03..FF)hex, (ddd = 003..255)dec] for integer values that are divisible by 3 hh or ddd
Index (hex) | Name | Meaning | Flags | Default
6kk0:0 | Terminal Input Data | [Terminal designation] | RO P | -
6kk0:01 | Channel 001 Status | Channel 001: Status | RO P | -
6kk0:02 | Channel 001 Word-Alignment | Channel 001: Word Alignment | RO P | -
6kk0:03 | Channel 001 Data | Channel 001: Data | RO P | -
6kk0:hh-2 | Channel ddd/3 | Channel ddd/3: Status | RO P | -
6kk0:hh-1 | Channel ddd/3 | Channel ddd/3: Word Alignment | RO P | -
6kk0:hh | Channel ddd/3 | Channel ddd/3: Data | RO P | -
Index 7kk0 Terminal Output Data
Digital terminals:
Value ranges:
(kk = 00..FF)hex, [(hh = 01..FF)hex, (ddd = 001..255)dec]
Index (hex) | Name | Meaning | Flags | Default
7kk0:0 | Terminal Output Data | [Terminal designation] | RO P | -
7kk0:01 | Channel 001 | Channel 001 | RO P | -
7kk0:hh | Channel ddd | Channel ddd | RO P | -
Non-digital terminals (for hh ≥ 03; ddd ≥ 003):
Value ranges: (kk = 00..FF)hex,
[(hh = 03..FF)hex, (ddd = 003..255)dec] for integer values that are divisible by 3 hh or ddd
Index (hex) | Name | Meaning | Flags | Default
7kk0:0 | Terminal Input Data | [Terminal designation] | RO P | -
7kk0:01 | Channel 001 Ctrl | Channel 001: Control | RO P | -
7kk0:02 | Channel 001 Word-Alignment | Channel 001: Word Alignment | RO P | -
7kk0:03 | Channel 001 Data | Channel 001: Data | RO P | -
7kk0:hh-2 | Channel ddd/3 Ctrl | Channel ddd/3: Control | RO P | -
7kk0:hh-1 | Channel ddd/3 Word Alignment | Channel ddd/3: Word Alignment | RO P | -
7kk0:hh | Channel ddd/3 Data | Channel ddd/3: Data | RO P | -
Index 9kk0 Slave Info Data
Value ranges:
(kk = 00..FF)hex
Index (hex) | Name | Meaning | Flags | Default
9kk0:0 | Slave Info Data | [Terminal designation] | RO | -
9kk0:01 | Position | Module position in the terminal network | RO | -
9kk0:09 | Module PDO Group | Module PDO Group • Non-digital terminals: Group 1 • Digital terminals: Group 2 | RO | -
9kk0:0A | Module Ident | Module name (terminal designation) | RO | -
Index F000 Modular Device Profile
Index (hex) | Name | Meaning | Flags | Default
F000:0 | Modular Device Profile | Length of this object | RO | 5
F000:01 | Module Index Distance | Module Index Distance | RO | 0x0010 (16dec)
F000:02 | Maximum Number of Modules | Max. number of K-bus modules | RO | 0x00FF (255dec)
F000:03 | Standard Entries in Object 0x8yy0 | Possible entries in object 0x8kk0 | RO | 0x0000000 (0dec)
F000:04 | Standard Entries in Object 0x9yy0 | Possible entries in object 0x9kk0 | RO | 0x0000300 (0dec)
F000:04 | Module PDO Group | Module PDO group of device = 0, (control and status word data are assigned before all terminals in the process data) | RO | 0x00 (0dec)
Index F00E Group Alignment PDO
Index (hex) | Name | Meaning | Flags | Default
F00E:0 | Group Alignment PDO | Length of this object (3 PDO terminal groups) | RO | 3
F00E:01 | Subindex 001 | Group 0: no alignment required | RO | 0x0000 (0dec)
F00E:02 | Subindex 002 | Group 1: PDO alignment (PDO 257) for PDO group 1 (non-digital terminals) | RO | 0x0100 (256dec)
F00E:03 | Subindex 003 | Group 2: PDO alignment (PDO 258) for PDO group 2 (digital terminals) | RO | 0x0101 (257dec)
Index F00F Module Group Mapping Alignment
Index (hex) | Name | Meaning | Flags | Default
F00F:0 | Module Group Mapping Alignment | Length of this object (3 PDO terminal groups) | RO | 3
F00F:01 | Subindex 001 | Group 0: no alignment for PDO group 0 required, control and status word data are fixed | RO | 0x0000 (0dec)
F00F:02 | Subindex 002 | Group 1: word alignment for PDO group 1 (non-digital terminals). In this way, the following process data for the digital terminals are always assigned to an even byte address | RO | 0x0002 (2dec)
F00F:03 | Subindex 003 | Group 2: word alignment for PDO group 2 (digital terminals). The process data size of the digital terminals is always even-numbered. | RO | 0x0002 (2dec)
Index F010 Module List
Value ranges:
(hh = 01..FF)hex, (ddd = 001..255)dec
Index (hex) | Name | Meaning | Flags | Default
F010:0 | Module list | Length of this object | RO | -
F010:01 | Subindex 001 | Terminal designation module 001 | RO | -
F010:hh | Subindex ddd | Terminal designation module ddd | RO | -
Index F030 Configured Module List
Value ranges:
(hh = 01..FF)hex, (ddd = 001..255)dec
Index (hex) | Name | Meaning | Flags | Default
F030:0 | Module list | Length of this object | RW | -
F030:01 | Subindex 001 | Terminal designation of the configured terminal at position 1 (value as 0x8kk0:0A) | RW | -
F030:hh | Subindex ddd | Terminal designation of the configured terminal at the last position (value as 0x8kk0:0A) | RW | -
Index F040 Detected Address List
Value ranges:
(hh = 01..FF)hex, (ddd = 001..255)dec
Index (hex) | Name | Meaning | Flags | Default
F040:0 | Module list | Length of this object | RO | -
F040:01 | Subindex 001 | Position of the first terminal (value as 0x9kk0:01) | RO | 0x0001 (1dec)
F040:hh | Subindex ddd | Position of the last terminal (value as 0x9kk0:01) | RO | 0x00hh (ddddec)
Index F050 Detected Module List
Value ranges:
(hh = 01..FF)hex, (ddd = 001..255)dec
Index (hex) | Name | Meaning | Flags | Default
F050:0 | Module list | Length of this object | RO | -
F050:01 | Subindex 001 | Terminal designation of the terminal at position 1 (value as 0x9kk0:0A) | RO | -
F050:hh | Subindex ddd | Terminal designation of the terminal at last position (value as 0x9kk0:0A) | RO | -
Index F100 Status PDO
Index (hex) | Name | Meaning | Flags | Default
F100:0 | Status PDO | Length of this object | RO | 1
F100:01 | CouplerState | Coupler status word | RO P | 0x0000 (0dec)
Index F200 Control PDO
Index (hex) | Name | Meaning | Flags | Default
F100:0 | ControlPDO | Length of this object | RO | 1
F100:01 | CouplerCtrl | Coupler control word | RO P | 0x0000 (0dec)


Mapping the Bus Terminals

Parameterization and commissioning [image] TwinCAT System Manager [image] Mapping the Bus Terminals
Mapping the Bus Terminals
The precise assignment of the byte-oriented Bus Terminals may be found in the configuration guide for the particular bus terminal. This documentation is available on the Beckhoff Products & Solutions CD or on the Internet under http://www.beckhoff.de.
Byte oriented Bus Terminals | Bit oriented Bus Terminals
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Process image example

Parameterization and commissioning [image] TwinCAT System Manager [image] Process image example
Process image example
The following examples with the BK1120 illustrates the process image of a Bus Terminal block.
Configuration example for explaining the process image
The Bus Terminal block shown in the example consists of a Bus Coupler with attached KL2012, KL1408, KL3062, KL1104, KL1408 and KL9010 (see image). For complex mapping with Word alignment (factory settings) all non-digital terminals are shown in the process input and output image. Please refer to the relevant terminal documentation regarding the mapping details. The non-digital terminals are mapped first, followed by the digital terminals. The first 16 bits of the process image are reserved for the status word (process input image) and the control word (process output image).
Process input image
The status word (SW) is located in the output process image, and is transmitted from terminal to the controller.
Word-Offset |  | High byte |  |  |  |  |  |  |  | Low byte
 |  | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
0 | Status |  |  |  |  |  |  | K-bus overr. | Outputs disabled | no valid output data | no valid input data |  |  |  |  | Config. Error | K-bus Error
1 | KL3062 (non-digital) | Dummy for Word alignment |  |  |  |  |  |  |  | Status byte channel 1
2 |  | Process data channel 1
3 |  | Dummy for Word alignment |  |  |  |  |  |  |  | Status byte channel 2
4 |  | Process data channel 2
5 | Digital terminals | KL1408 (2) |  |  |  | KL1104 |  |  |  | KL1408 (1)
6 |  |  |  |  |  |  |  |  |  |  |  |  |  | KL1408 (2)
Process output image
The control word (CW) is located in the output process image, and is transmitted from the controller to the terminal.
Word-Offset |  | High byte |  |  |  |  |  |  |  | Low byte
 |  | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
0 | Control |  |  |  |  |  |  | Show K-bus overrun | Disable Outputs |
1 | KL3062 (non-digital) | Dummy for Word alignment |  |  |  |  |  |  |  | Control byte channel 1
2 |  | Register communication data channel 1
3 |  | Dummy for Word alignment |  |  |  |  |  |  |  | Control byte channel 2
4 |  | Register communication data channel 2
5 | Digital terminals
 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  | KL2012


KS2000 configuration software

Parameterization and commissioning [image] KS2000 configuration software
KS2000 configuration software
Additional information
•
Example: parameterization with the KS2000 configuration software
•
Sample program for KL register communication via EtherCAT on KL3314 exemplary


Example: parameterization with the KS2000 configuration software

Parameterization and commissioning [image] KS2000 configuration software [image] Example: parameterization with the KS2000 configuration software
Example: parameterization with the KS2000 configuration software
The KS2000 software tool is used for planning, parameterization, and commissioning Bus Couplers and Bus Terminals. It can be downloaded from the Beckhoff website under KS2000 Update.
Help for installation and operation is available under KS2000 Documentation in the download area.
Configuration software KS2000
Support for KS2000
Access via ADS is supported for the KS2000 software from the following firmware versions:
•
BK1120: from FW08
•
BK1150: from FW01
•
BK1250: from FW01
The following example describes how to set up communication via ADS with a BK11x0/BK1250. The AmsServerNetId of the target system is required for this purpose.
Step 1: In the TwinCAT System Manager select the corresponding coupler BK11x0/BK1250, navigate to the "EtherCAT" tab and click on "Advanced Settings" (Fig. TwinCAT System Manager: EtherCAT tab for box BK11x0/BK1250).
TwinCAT System Manager: EtherCAT tab for Box BK11x0/BK1250
Step 2: Under "Mailbox", "AoE" (ADS over EtherCAT) select "Generate NetID" and "Initialize NetID". Confirm with OK.
Dialog "EtherCAT", "Advanced Settings", "AoE"
Step 3: After the KS2000 software has been started and the ADS communication channel has been activated ("Options", "Communication channel", "ADS"), enter the AmsServerNetId specified in the TwinCAT System Manager under "Mailbox", "ADS Info" (Fig. TwinCAT System Manager: dialog "Mailbox", transferring the AmsServerNetID) in the pull-down menu of the "ADS" tab (Fig.4):
▪
Existing device: If you select an existing device under Name (1), the AmsServerNetId (2) is entered automatically. The AdsPort setting ("100") (3) should not be changed. Click on Test(4) to check the connection settings.
▪
User Defined: For User Defined the AmsServerNetId has to be entered manually (2). Click on Test(4) to check the connection settings.
TwinCAT System Manager: "Mailbox" dialog, transfer of AmsServerNetID
KS2000: "ADS" tab, enter the AmsServerNetID
Step 4: The test was successful, if the following dialog box appears (Fig. KS2000: Confirmation of successful communication test). Click OK to close the dialog box.
Confirmation of successful communication test
Step 5: Click OK to accept the set value (Fig. KS2000: "ADS" tab, entering the AmsServerNetID).
Step 6: Log into the KS2000 system (see also KS2000 Documentation). Parameterization can now be carried out according to the Bus Terminal configuration. Further information can be found in the associated terminal documentation.


Sample program for KL register communication via EtherCAT on KL3314 exemplary

Parameterization and commissioning [image] KS2000 configuration software [image] Sample program for KL register communication via EtherCAT on KL3314 exemplary
Sample program for KL register communication via EtherCAT on KL3314 exemplary
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Program description / function
This example program (TwinCAT 3) provides change of single register values of the KL3314 as selection of the element type, characteristical settings of the feature register R32 and user scaling offset and gain (R33/ R34) similar as per KS2000.
Settings of KL3314 via visualisation of TwinCAT 3
At least following configuration setup shall be present:
[coupler (e.g. BK1120) or embedded PC] + KL3314 + KL9010.
Download:
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the “EtherCAT” tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on “EtherCAT device” within the solution explorer a context menu opens where “Change NetId...” have to be selected. The first four numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1


Error handling and diagnosis

Error handling and diagnosis
Error handling and diagnosis
Additional information
•
Error messages to the EtherCAT master


Error messages to the EtherCAT master

Error handling and diagnosis [image] Error messages to the EtherCAT master
Error messages to the EtherCAT master
The Beckhoff TwinCAT EtherCAT master issues the slave error message after the ETG specification in plain text in the logger window.
Switching the logger window on/off
Error message
Display of the error message AL Status Code '0x0003' in the logger window
Error code
AL Status Code '0x0003'
Explanation
The error message is displayed in the logger window, if a K-bus error is present and the coupler should enter the status SAFEOP. Rectify the K-bus error.
Error Message:
Display of the error message AL Status Code '0x001e - invalid SM IN cfg' in the logger window
Error code
AL Status Code '0x001e - Invalid SM IN cfg'
Explanation:
The process data scope is incorrect. The BK11x0/BK1250 is set by the EtherCAT master based on the EtherCAT extent of process data according to the configured KL terminals. Before that the coupler scans its KL terminals and establishes its internal process data image based on their message. If the two process data do not match, the system reports a SyncManager error.
Use the KS2000 software or correct CoE startup entries to ensure that a KL terminal does not report with an alternative process data format that may differ from the TwinCAT configuration, for example.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Test standards for device testing
•
Firmware compatibility
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
The following conditions must be met in order to ensure flawless operation of the fieldbus components. Also note the details in chapter "Technical data".
Environmental conditions
Operation
The components may not be used without additional protection in the following locations:
▪
in difficult environments, such as where there are corrosive vapours or gases, or high dust levels
▪
in the presence of high levels of ionizing radiation
Condition | Permissible range
Permissible ambient temperature during operation | -25°C ...+60°C
Relative humidity during operation | 95 %, no condensation
Installation position | variable
Vibration resistance | conforms to EN 60068-2-6
Shock resistance | conforms to EN 60068-2-27, EN 60068-2-29, see also installation instructions for enhanced mechanical load capacity
EMC resistance | conforms to EN 61000-6-2
Emission | conforms to EN 61000-6-4
Transport and storage
Condition | Permissible range
Permissible ambient temperature during storage | -40°C... +85°C
Relative humidity | 95 %, no condensation
Free fall | up to 1 m in the original packaging
Protection classes and types
Condition | Permissible range
Protection class in accordance with IEC 536 (VDE 0106, Part 1) | A protective conductor connection to the mounting rail is necessary!
Protection class conforms to IEC 529 | IP20 (protection against contact with a standard test finger)
Protection against foreign objects | Less than 12 mm in diameter
Protection against water | no protection


Test standards for device testing

Appendix [image] Test standards for device testing
Test standards for device testing
EMC
EN 61000-6-2
EN 61000-6-4
Vibration resistance
EN 60068-2-6 vibration test
EN 60068-2-27/29 shock test


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
Firmware and hardware versions
Documentation Version | BK1120 |  | BK1150
 | Firmware | Hardware | Firmware | Hardware
4.2 | 19 | 20 | 06 | 06
4.1 | 18 | 19 | 05 | 05
3.0 | 18 | 19 | 04 | 05
3.0 | 17 | 17 | 03 | 05
2.9 | 15 | 15 | 01 | 04
2.8 | 15 | 15 | 01 | 04
2.7 | 13 (C2) | 12 | 01 | 00
2.6 | 13 (C2) | 12 | 00 | 00
2.5 | 12 (C1) | 12 | 00 | 00
2.4 | 12 (C1) | 11 | - | -
2.3 | 11 (C0) | 11 | - | -
2.2 | 09 (B9) | 09 | - | -
2.1 | 08 (B8) | 05 | - | -
2.0 | 08 (B8) | 03 | - | -
1.0 | 06 | 02 | - | -
0.2 | 06 | 02 | - | -
0.1 | 06 | 02 | - | -
Documentation Version | BK1250
 | Firmware | Hardware
4.2 | 12 | 13
4.1 | 12 | 13
3.0 | 11 | 13
2.9 | 05 | 10
2.8 | 05 | 09
2.7 | 04 | 05
2.6 | 04 | 05
2.5 | 04 | 05
2.4 | 04 | 05
2.3 | 04 | 05
2.2 | 03 | 03
2.1 | 02 | 01
2.0 | 01 | 01
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 34 06 08 02:
34 - week of production 34
06 - year of production 2006
08 - firmware version 08
02 - Hardware-Stand 02


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com