BC9000 - Busklemmen Controller für Ethernet
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
4.1
▪
Download Links aktualisiert
4.0
▪
Migration
3.12
▪
HTML-Dokumentation; gültig ab Firmware BB (BC9000) und B1 (BC9100)
3.11
▪
HTML-Dokumentation; gültig ab Firmware BB (BC9000) und B1 (BC9100)
3.10
▪
HTML-Dokumentation; gültig ab Firmware BA
3.9
▪
HTML-Dokumentation; gültig ab Firmware B9
3.8
▪
HTML-Dokumentation; gültig ab Firmware B8
Firmware BC9000/BC9100
Welche Firmware im Auslieferungszustand auf dem Buskoppler ist, erkennen Sie an dem Aufkleber unter dem Koppler (siehe fünfte und sechste Stelle der Produktionsnummer).
Beispiel:
3200B2020000
Die Firmware im Beispiel ist B2.
Zum Update Ihrer Firmware benötigen Sie die Konfigurationssoftware KS2000 und das zu deren Lieferumfang gehörende serielle Kabel oder Sie können ab Software Version B6 Ihren Koppler mit dem TwinCAT 2.8 System Manager updaten. Die Firmware finden Sie unter www.beckhoff.de.
Firmware
Beschreibung
BB (BC9000)
B1 (BC9100)
▪
Umstrukturierung der Internen Ethernet Kommunikation
▪
Anpassung des ZyklusTick Counters auf 1 ms pro Tick
BA
▪
Variablen Größe von 6 kByte auf 16 kByte erhöht
▪
Speicher von Daten im Flash
▪
SNTP/Time Protokoll implementiert
▪
Zugriff über Namensauflösung
▪
Optimierung: Durch Code Optimierung 25 % Performance Steigerung
B9
Fehler der B8 Version behoben, betreffend mapping der KL60xx Busklemmen
B8
Interner Software Reset geändert (dies hat keine Auswirkung für den Benutzer)
B7
▪
Beim Firmware Update bleiben die Einstellungen, wie IP-Adresse, erhalten
▪
ADS Indication Bausteine Implementiert
▪
ADS "State" werden unterstützt
▪
DHCP für "Nortel Switch" geändert
▪
Zykluszeit Überwachung
▪
Fast ModbusTCP implementiert
B6
▪
Implementierung der Funktionsbausteine ModbusTCP, ADS, SMTP, IP-Config
▪
Firmware Update über Ethernet möglich
▪
Auslesen der Konfiguration mit System-Manager (ab TwinCAT 2.8) möglich
▪
Zugriffskontrolle ADS über Tabelle 2 implementiert
B5
▪
Adressierung über ARP und BootP möglich
▪
Zugriff auf den Merkerbereich über ModbusTCP
B3
Implementierung von ModbusTCP
B2
▪
Probleme mit den ASC/CHR-Funktionen behoben
▪
Fehler, das nach einem Neustart von TwinCAT der Fehler-Code 1 erzeugt wird, wurde behoben
▪
Implementierung der PLCSystemBC.lb6
B1
Freigegebene Version
B0
Vorab-Version


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Prinzip der Busklemme
•
Das Beckhoff Busklemmensystem
•
Technische Daten
•
Technische Daten der SPS
•
Ethernet


Prinzip der Busklemme

Produktübersicht [image] Prinzip der Busklemme
Prinzip der Busklemme
Prinzip der Busklemme


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
BC9000 und BC9100
Systemdaten | Ethernet (BC9000) | Ethernet (BC9100)
Anzahl der E/A-Module | nur durch IP-Adressraum begrenzt
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | 4 x 2 Twisted-Pair Kupferkabel; Kategorie 3 (10 Mbit/s), Kategorie 5 (100 Mbit/s)
Länge zwischen Modulen | 100 m (Verteiler Hub bis BC9000) | Linie: max. 100 m zwischen 2 BC9100
Übertragungsrate | 10/100 Mbit/s
Topologie | sternförmige Verkabelung | sternförmige Verkabelung, Linie maximal 20 x BC9100 in einer Linie)
Technische Daten | BC9000 | BC9100
Anzahl der Busklemmen | 64
Digitale Peripheriesignale | 256 Ein-/Ausgänge
Analoge Peripheriesignale | 128 Ein-/Ausgänge
Protokolle | Beckhoff ADS, ModbusTCP
Konfigurationsmöglichkeit | über die Konfigurationssoftware KS2000 oder die Steuerung (TwinCAT)
maximale Byteanzahl | 512 Byte E und 512 Byte A
Busanschluss | 1 x RJ 45 | 2 x RJ45
Interner Switch | - | 3 Port Switch (2 Externe Anschlüsse)
Spannungsversorgung | 24 VDC (-15 %/+20 %)
Eingangsstrom | 70 mA + (ges. K-Bus Strom)/4
Einschaltstrom | ca. 2,5 x Dauerstrom
Empf. Vorsicherung | ≤10 A
K-Bus-Stromversorgung | bis 1750 mA
Spannung Powerkontakt | 24 VDC max.
Stromlast Powerkontakt | 10 A max.
Spannungsfestigkeit | 500 V (Powerkontakt/Versorgungsspannung/Feldbus)
Gewicht ca. | 170 g
Betriebstemperatur | -25°C ... +60°C
Lagertemperatur | -40°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß IEC 68-2-6 / IEC 68-2-27
EMV-Festigkeit/Aussendung | gemäß EN 50082 (ESD, Burst) / EN 50081
Einbaulage | beliebig
Schutzart | IP20


Technische Daten der SPS

Produktübersicht [image] Technische Daten der SPS
Technische Daten der SPS
PLC-Daten | BC9000 | BC9100
Programmiermöglichkeit | über Programmierschnittstelle (TwinCAT) oder über Ethernet (TwinCAT)
Programmspeicher | 64/96 kByte
Datenspeicher | 64/128 kByte
Remanente Merker | 4 kByte
SPS-Zykluszeit | ca. 1,5 ms für 1000 AWL Befehle (ohne E/A-Zyklus) | ca. 1,2 ms für 1000 AWL Befehle (ohne E/A-Zyklus)
Programmiersprachen | IEC 6-1131-3 (AWL, KOP, FUP, ST, AS)


Ethernet

Produktübersicht [image] Ethernet
Ethernet
Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert.. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.
Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.
Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.
Grundlagen
Internet-Protokoll (IP)
Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.
Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z.B. IP, TCP, UDP, ARP und ICMP.
Transmission Control Protocol (TCP)
Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.
User Datagram Protocol (UDP)
UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.
Internet Control Message Protocol (ICMP)
Dient dem Informationsaustausch der Endgeräte über den aktuellen Status des Internet-Protokolls.
Address Resolution Protocol (ARP)
Dient der Umwandlung zwischen IP-Adressen und MAC-Adressen.
BootP
Das BootP-Protokoll ermöglicht das Einstellen und Ändern der TCP/IP-Adresse indem der Netzwerk-Teilnehmer mit der MAC-ID angesprochen wird.


Einbau und Verdrahtung

Einbau und Verdrahtung
Einbau und Verdrahtung
Weiterführende Informationen
•
Mechanischer Einbau
•
Verdrahtung


Mechanischer Einbau

Einbau und Verdrahtung [image] Mechanischer Einbau
Mechanischer Einbau
Weiterführende Informationen
•
Abmessungen
•
Tragschienenmontage


Abmessungen

Einbau und Verdrahtung [image] Mechanischer Einbau [image] Abmessungen
Abmessungen
Das System der Beckhoff-Busklemmen zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Baumaße der Buskoppler sind unabhängig vom Feldbus-System.
Abmessungen
Die Gesamtbreite der Anwendung setzt sich aus der Breite des Buskopplers, der Busendklemme KL9010 und der Breite der verwendeten Busklemmen zusammen. Die Busklemmen sind je nach Funktion 12 mm oder 24 mm breit. Die lichte Höhe von 68 mm wird durch die Frontverdrahtung in Abhängigkeit von der Drahtstärke um ca. 5 mm bis 10 mm überbaut.


Tragschienenmontage

Einbau und Verdrahtung [image] Mechanischer Einbau [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Art und Quelle der Gefahr
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie vorsichtig die orangefarbige Lasche ca. 1 cm aus der zu demontierenden Klemme heraus, bis die Lasche locker hervorsteht. Jetzt ist für diese Klemme die Verriegelung mit der Tragschiene gelöst und die Klemme kann ohne großen Kraftaufwand von der Tragschiene gezogen werden.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen Sie die Klemme von der Tragschiene weg.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z. B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!
Verdrahtung
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Verdrahtung

Einbau und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Spannungsversorgung, Potenzialgruppen
•
Ethernet-Topologien
•
Ethernet-Anschluss
•
Ethernet-Kabel


Spannungsversorgung, Potenzialgruppen

Einbau und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung, Potenzialgruppen
Spannungsversorgung, Potenzialgruppen
Spannungsversorgung des Buskopplers
Die Buskoppler benötigen zum Betrieb eine 24 V Gleichspannung. Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Die Versorgungsspannung versorgt die Buskopplerelektronik und über den K-Bus/E-Bus die Busklemmen. Die Spannungsversorgung der Buskopplerelektronik und die des K-Bus/E-Bus sind galvanisch von der Spannung der Feldebene getrennt.
Einspeisung für die Powerkontakte
Die unteren sechs Anschlüsse mit Federkraftklemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der Buskoppler. Die Auslegung der Einspeisung lässt Spannungen bis zu 24 V zu. Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschleifen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakten darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Buskopplers befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um den Berührungsschutz sicherzustellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut/Federführung an der Ober- und Unterseite der Buskoppler und Busklemmen garantiert sichere Führung der Powerkontakte.
Konfigurations-Schnittstelle (nicht für BK1250, EK1x00)
Auf der unteren Seite der Frontfläche sind die Standardbuskoppler mit einer RS232-Schnittstelle ausgerüstet. Der Miniaturstecker kann mit einem Verbindungskabel und der Konfigurations-Software KS2000 mit einem PC verbunden werden. Die Schnittstelle erlaubt das Konfigurieren der Busklemmen, wie zum Beispiel das Einstellen des Verstärkungsfaktors der analogen Kanäle. Über die Schnittstelle kann auch die Zuordnungen der Busklemmen- Daten zum Prozessabbild im Buskoppler verändert werden. Die Funktionalität der Konfigurationsschnittstelle ist auch über den Feldbus mit der String-Kommunikation zu erreichen.
Potenzialtrennung
Die Buskoppler arbeiten mit drei unabhängigen Potenzialgruppen. Die Versorgungsspannung speist galvanisch getrennt die K-Bus/E-Bus-Elektronik im Buskoppler und den K-Bus/E-Bus selbst. Aus der Versorgungsspannung wird weiter die Betriebsspannung für den Betrieb des Feldbusses erzeugt.
Anmerkung: Alle Busklemmen haben eine galvanische Trennung zum K-Bus/E-Bus. Der K-Bus/E-Bus ist dadurch vollständig galvanisch gekapselt.
Potenzialtrennung


Ethernet-Topologien

Einbau und Verdrahtung [image] Verdrahtung [image] Ethernet-Topologien
Ethernet-Topologien
BK9000, BK9050, BC9000, BC9020, BC9050
Diese Buskoppler und Busklemmen-Controller besitzen einen einfachen Ethernet-Anschluss. Dieser kann direkt an einen externen Switch angeschlossen werden. Somit ist er Aufbau der für Ethernet typischen Sterntopologie möglich.
Ethernet-Aufbau in Sterntopologie
BK9100, BC9100, BC9120, BC9191
Diese Buskoppler und Busklemmen-Controller besitzen einen internen Dreifach-Switch mit zwei externen und einem intern Port. Der interne Switch ermöglicht den einfachen Aufbau einer Linien-Topologie. Sie könne maximal 20 BK9100/BC91x0/BC9191 zu einer physikalischen Linie hintereinander schalten. Dabei darf die Distanz zwischen zwei Ethernet-Geräten maximal 100 m betragen. Die gesamte Länge der so aufgebauten Linie darf also 2 km betragen. In diese Linie dürfen keine weiteren Switche eingebaut werden.
Ethernet-Aufbau in Linien-Topologie
Natürlich ist auch mit diesen Buskopplern und Busklemmen-Controllern der Aufbau einer klassischen Sterntopologie möglich.


Ethernet-Anschluss

Einbau und Verdrahtung [image] Verdrahtung [image] Ethernet-Anschluss
Ethernet-Anschluss
Der Ethernet-Anschluss erfolgt über einen RJ45-Stecker (Westernstecker).
RJ45-Stecker (Westernstecker)
Verkabelung
Verbindung über Hub oder Switch
Ethernet-Verbindung über Hub oder Switch
Verbinden Sie die Netzwerkkarte des PCs über ein Standard-Ethernet-Kabel mit dem Hub und das Hub ebenfalls über ein Standard-Ethernet-Kabel mit dem Busklemmen Controller. Die Verbindung über einen Switch erfolgt auf die gleiche Weise.
Direkte Verbindung zwischen PC mit Ethernet-Karte und BC9000
Direkte Ethernet-Verbindung (Cross-Over-Kabel)
Um den PC direkt mit dem Busklemmen Controller zu verbinden, müssen Sie ein Ethernet-Kabel mit gekreuzten Aderpaaren (Cross-Over-Kabel) verwenden.
Belegung des RJ45-Steckers
PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | - | reserviert
5 | - | reserviert
6 | RD - | Receive -
7 | - | reserviert
8 | - | reserviert


Ethernet-Kabel

Einbau und Verdrahtung [image] Verdrahtung [image] Ethernet-Kabel
Ethernet-Kabel
Übertragungsstandards
10Base5
Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.
10Base2
10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.
10BaseT
Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.
100BaseT
Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.
10BaseF
Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.
Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT
Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.
UTP
Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung)
Dieser Kabeltyp gehört zur Kategorie 3 und sind für industrielle Umgebungen nicht empfehlenswert.
S/UTP
Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung)
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.
FTP
Foilesshielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung)
Dieses Kabel hat eine alukaschierten Kunststoff-Folie-Gesamtschirm.
S/FTP
Screened/Foilesshielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung)
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70 dB erreichen.
STP
Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung)
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.
S/STP
Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung)
Ein solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.
ITP
Industrial Twisted-Pair
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Busklemmen-Controllers
•
Parametrierung des Buskopplers über DIP-Schalter
•
Netzwerkklassen
•
IP-Adresse


Anlaufverhalten des Busklemmen-Controllers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Busklemmen-Controllers
Anlaufverhalten des Busklemmen-Controllers
Nach dem Einschalten prüft der Busklemmen-Controller seinen Zustand, konfiguriert den K-Bus, erstellt anhand der gesteckten Busklemmen eine Aufbauliste und startet seine lokale SPS.
Beim Hochlaufen des Busklemmen-Controllers leuchten und blinken die I/O-LEDs. Im fehlerfreien Zustand sollte nach ca. 2 bis 3 Sekunden keine I/O-LED mehr Blinken. Im Fehlerfall hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose-LEDs).
Anlaufverhalten des Busklemmen-Controllers


Parametrierung des Buskopplers über DIP-Schalter

Parametrierung und Inbetriebnahme [image] Parametrierung des Buskopplers über DIP-Schalter
Parametrierung des Buskopplers über DIP-Schalter
Die folgende Parametrierungen können Sie ohne Konfigurationssoftware mit Hilfe des DIP-Schalters und der Endklemme (KL9010) vornehmen.
Dieser Parametrierungsmode ist nur dann aktiv, wenn am Buskoppler nur eine Endklemme (KL9010) gesteckt ist. Sonst gelten die normalen Einstellungen.
Wiederherstellen der Hersteller-Einstellungen
▪
Schalten Sie den Buskoppler aus und fügen Sie nur die Endklemme (KL9010) an.
▪
Stellen Sie alle DIP-Schalter auf ON und schalten Sie den Buskoppler wieder ein.
▪
Nach erfolgreichem Einstellen der Default-Parameter leuchtet die LED Error und die LEDs I/O RUN und I/O ERR blinken abwechselnd.
▪
Danach können Sie den Buskoppler ausschalten, die Busklemmen anschließen und wie gewohnt fortfahren.
Löschen des Bootprojektes (nur BC9000)
▪
Schalten Sie den Buskoppler aus und fügen Sie nur die Endklemme (KL9010) an.
▪
Stellen Sie die DIP-Schalter 1 bis 9 auf ON und den DIP-Schalter 10 auf OFF und schalten Sie den Buskoppler wieder ein.
▪
Nach erfolgreichem Löschen des Bootprojektes blinken die LEDs I/O RUN und I/O ERR abwechselnd.
▪
Danach können Sie den Buskoppler ausschalten, die Busklemmen anschließen und wie gewohnt fortfahren.
Einstellung der Ethernet-Parameter
▪
Schalten Sie den Buskoppler aus und fügen Sie nur die Endklemme (KL9010) an.
▪
Stellen Sie alle DIP-Schalter auf OFF und schalten Sie den Buskoppler wieder ein.
▪
Die LEDs I/O RUN und I/O ERR leuchten konstant.
▪
Nehmen Sie nun anhand der folgenden Tabelle die gewünschte Einstellung vor.
DIP-Schalter | Parameter | Auswahl | Einstellung | Kommentar
1 | Baud-Rate | 10 MBaud | OFF (0) |
 |  | 100 MBaud | ON (1) | Default
2 | Auto-Baud-Rate | Disable | OFF (0) |
 |  | Enable | ON (1) | Default
3 | Übertragungsart | Halbduplex | OFF (0) |
 |  | Vollduplex | ON (1) | Default
▪
Schalten Sie zur um Übernahme der Werte den DIP-Schalter 10 auf ON.
Der Buskoppler zeigt nun durch blinken der LEDs I/O RUN und I/O ERR, das er die Parameter übernommen hat.
▪
Danach können Sie den Buskoppler ausschalten, die Busklemmen anschließen und wie gewohnt fortfahren.


Netzwerkklassen

Parametrierung und Inbetriebnahme [image] Netzwerkklassen
Netzwerkklassen
Man unterscheidet drei verschiedene Netzwerkklassen. Diese legen fest, wie viele Adress-Bits für die Netzwerk-ID und wie viele für die Knotennummer (z. B. für PCs oder Buskoppler) reserviert werden. Die Unterscheidung findet in den ersten drei Bits der IP-Adresse statt.
Netzwerk- klasse | Anzahl Bits für die Netzwerk-ID | Ermöglicht Anzahl Netzwerke | Anzahl Bits für die Knotenadresse | Ermöglicht Anzahl Knoten pro Netzwerk
A | 7 | 126 | 24 | 16 777 214
B | 14 | 16 382 | 16 | 65 536
C | 21 | 2 097 150 | 8 | 254
Einmalige IP-Adresse
Eine IP-Adresse muss im gesamten verbundenen Netzwerk einmalig sein!
Netzwerkklassen
Gleiche Netzwerkklasse
Die eingestellte IP-Adresse muss bei einer Kommunikation mit einem anderen Ethernet-Teilnehmer die gleiche Netzwerkklasse besitzen. Beispiel: Ihr PC hat die Adresse 172.16.17.55, damit muss der Koppler die Adresse 172.16.xxx.xxx haben (die xxx stehen für eine Zahl von 0...255. Die 0 wird üblicherweise vom Router/Switch benutzt sollte dafür reserviert bleiben).
Um sich die Adresse des eigenen PCs anzusehen, kann man bei Windows NT/2000/XP im DOS-Fenster den Befehl ipconfig eingeben.


IP-Adresse

Parametrierung und Inbetriebnahme [image] IP-Adresse
IP-Adresse
In der Regel wird die IP Adresse bei PROFINET über die Steuerung (PROFINET Controller) vorgegeben und braucht daher nicht im Buskoppler eingestellt zu werden. Die Adressierung der Buskoppler erfolgt über den PROFINET-Namen, welcher mit unterschiedlichen Verfahren eingestellt werden kann (s. DIP-Schalter-Einstellungen).
In Ausnahmefällen macht es Sinn dem Koppler eine IP Adresse vorab zu geben (ohne PROFINET angeschlossen zu haben), zum Beispiel damit man über die KS2000 Software und Ethernet auf die Koppler zugreifen kann.
Weiterführende Informationen
•
IP-Adresse
•
Adresseinstellung mit KS2000
•
Einstellung der IP-Adresse über die ARP-Tabelle
•
Einstellung der IP-Adresse über den Beckhoff BootP-Server
•
Adresseinstellung über einen DHCP-Server
•
Adressierung per Name
•
Subnetz-Maske
•
Test der IP-Adresse
•
Auslesen der MAC-ID
•
Security-Einstellungen


IP-Adresse

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] IP-Adresse
IP-Adresse
Die Einstellung der IP-Adresse kann mit vier unterschiedlichen Verfahren durchgeführt werden, die im Folgenden genauer beschrieben werden.
Verfahren | Erläuterung | Benötigte Komponenten
KS2000 | Adressierung über die Konfigurationssoftware KS2000 und DIP-Schalter | Konfigurationssoftware KS2000 und KS2000-Kabel
ARP | Adressierung über die ARP-Tabelle | PC mit Netzwerk
BootP | Adressierung über BootP-Server | BootP-Server
DHCP | Adressierung über DHCP-Server | DHCP-Server


Adresseinstellung mit KS2000

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Adresseinstellung mit KS2000
Adresseinstellung mit KS2000
Mit der der Konfigurationssoftware KS2000 (ab Version 3.2.8) können Sie die TCP/IP-Adresse per Dialogfenster einstellen oder direkt in die Register schreiben. Die DIP-Schalter 9 und 10 (beim BK9050 DIP-Schalter 1 und 2 in blau) müssen beide vor dem Einschalten auf OFF (0) stehen.
Tabelle 100
Register | High-Byte | Low-Byte
0 | IP-Byte 2 | IP-Byte 1
1 | Nicht benutzt | IP-Byte 3
Default
Byte | Default-Wert (hex) | Default-Wert (dez)
1 | 0xAC | 172dez
2 | 0x10 | 16dez
3 | 0x11 | 17dez
4 | (DIP-Schalter) | (0 bis 255dez)
Beispiel
BK9000, BK9100, BC9000, BC9100
BK9050
Schalter-Nr. | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 (1) | 10 (2) |
Wertigkeit | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128 | - | - |
Im Beispiel | ON | OFF | OFF | ON | OFF | OFF | ON | ON | OFF | OFF |
Wert | 1 | 0 | 0 | 8 | 0 | 0 | 64 | 128 | - | - | Summe=201
Software-Reset
Um Änderungen in den Tabellen eines BK9000 zu speichern ist ein Software-Reset des BK9500 erforderlich. Ein Hardware-Reset (Power on/off) reicht nicht aus!


Einstellung der IP-Adresse über die ARP-Tabelle

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Einstellung der IP-Adresse über die ARP-Tabelle
Einstellung der IP-Adresse über die ARP-Tabelle
Eine einfache Methode die IP-Adresse zu ändern ist die Adresseinstellung über das DOS-Fenster. Sie können so allerdings nur Adressen innerhalb der selben Netzwerkklasse ändern. Die neu eingestellte IP-Adresse bleibt auch beim Ausschalten des Buskopplers gespeichert.
Vorgehensweise
▪
Stellen Sie die DIP-Schalter 9 und 10 auf OFF. Die DIP-Schalter 1-8 haben dann keine Adress-Funktion mehr.
▪
Öffnen Sie auf Ihrem PC eine DOS-Eingabeaufforderung (DOS-Box).
▪
Erzeugen Sie mit "ping >IP-Adresse ALT<" einen Eintrag in die ARP-Tabelle.
▪
Lesen Sie mit "ARP-a" die Tabelle aus.
▪
Löschen Sie mit "ARP-d >IP-Adresse ALT< den Buskoppler aus der Tabelle.
▪
Nehmen Sie mit "ARP -s >IP Adresse NEU< >MAC-ID<" einen manuellen Eintrag vor.
▪
Mit "ping -l 123 >IP-Adresse NEU<" ist die neue IP-Adresse gültig
Kurzzeitiges blinken der ERROR LED im Einschaltaugenblick signalisiert, dass der Buskoppler über ARP adressiert wurde und die DIP-Schalter 1-8 keine Aussage über die eingestellte Adresse geben.
Änderung der IP-Adresse
Bei Änderung der IP-Adresse müssen alle dynamischen ARP-Einträge gelöscht werden. Es wird nur ein ping mit der Länge 123 Byte zur Umkonfiguration der IP-Adresse zugelassen (>ping -l "IP-Adresse<).
Beispiel
1.
C:>ping 172.16.17.255
2.
C:>ARP -a
172.16.17.255 00-01-05-00-11-22
3.
C:>arp -d 172.16.17.255
4.
C:>arp -s 172.16.44.44 00-01-05-00-11-22
5.
C:>ping -l 123 172.16.44.44


Einstellung der IP-Adresse über den Beckhoff BootP-Server

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Einstellung der IP-Adresse über den Beckhoff BootP-Server
Einstellung der IP-Adresse über den Beckhoff BootP-Server
Stellen Sie für die Adresseinstellung mit dem Beckhoff BootP-Server den DIP-Schalter 9 auf ON (1) und den DIP-Schalter 10 auf OFF (0). Die DIP-Schalter 1-8 haben dann keine Adress-Funktion mehr. Ist dies nicht der Fall so meldet der Buskoppler LED-Fehler-Code 6-4 (siehe Diagnose LEDs). Während der Adressvergabe blinkt die LED TCP/IP ERROR.
Speicherverhalten der IP-Adresse
DIP-Schalter 1-8 in Stellung ON
Die vom BootP-Server vergebene IP-Adresse wird gespeichert und der BootP-Service wird beim nächsten Kaltstart nicht gestartet.
Die Adresse kann durch Reaktivierung der Herstellereinstellungen (mittels Konfigurationssoftware KS2000 oder DIP-Schalter und Endklemme) wieder gelöscht werden.
DIP-Schalter 1-8 in Stellung OFF
Die vom BootP-Server vergebene IP-Adresse ist nur bis zum Ausschalten des Buskopplers gültig. Beim nächsten Kaltstart muss der BootP-Server dem Buskoppler eine neue IP-Adresse vergeben.
Bei einem Software-Reset des Buskopplers bleibt die Adresse allerdings erhalten.
Beckhoff BootP-Server
Beckhoff bietet einen BootP-Server für Windows 98, ME, NT4.0, NT2000 und XP an. Sie finden die Installationsversion auf der Beckhoff TwinCAT CD unter dem Folder >Unsupported Utilities< oder unter https://download.beckhoff.com/download/software/TwinCAT/TwinCAT2/Unsupported_Utilities/TcBootP_Server/
Konfiguration des Beckhoff BootP-Servers
Sobald der BootP-Server gestartet wird zeigt das Fenster New MAC Address alle Beckhoff-Knoten an, die im BootP-Betrieb arbeiten und noch keine IP-Adresse bekommen haben. Die Zuweisung MAC-ID zu IP-Adresse erfolgt mit dem Button "<<". Eine erfolgreiche Zuweisung wird im Log-Fenster angezeigt.
Um den BootP-Server beim Booten Ihres PCs automatisch zu starten reicht eine Verknüpfung im Autostart von Windows. Fügen Sie hierzu im Verknüpfungspfad den Parameter /Start an (.../TcBootPDlg.exe/start).


Adresseinstellung über einen DHCP-Server

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Adresseinstellung über einen DHCP-Server
Adresseinstellung über einen DHCP-Server
Stellen Sie für die Adresseinstellung über einen DHCP-Server den DIP-Schalter 9 auf OFF (0) und den DIP-Schalter 10 auf ON (1).
In diesem Zustand ist der DHCP-Dienst eingeschaltet und der Buskoppler bekommt eine IP-Adresse vom DHCP-Server zugewiesen.
Der DHCP-Server muss hierfür die MAC-ID des Buskopplers kennen und sollte dieser MAC-ID bei jedem Hochlauf dieselbe IP-Adresse zuweisen!
Während der Adressvergabe blinkt die LED TCP/IP Error.


Adressierung per Name

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Adressierung per Name
Adressierung per Name
Anforderungen an eine Namensauflösung:
▪
DHCP aktivieren: DIP Schalter 10 auf ON (DHCP und DNS Server vorhanden)
▪
Namenseinstellung per KS2000 auf den BC/BK9000
Die Default-Einstellung für den Namen ist bei einem BC9000 zum Beispiel BC9000-4. Die 4 ergibt sich aus den Adresswählschaltern 1 bis 8 des BC9000. Der Name kann auch mit der Konfigurationssoftware KS2000 eingestellt werden und darf maximal 18 Zeichen lang sein.
Adressierung per Name
Nach dem die IP-Adresse vom DHCP-Server vergeben wurde, kann der Buskoppler per Name angesprochen werden.
C:>ping BC9000-4
Adressierung im System Manager
Im System Manager kann ein Ethernet Koppler über GetHostByName gesucht werden. Als erstes wird der DNS-Server angefragt. Ist dieser nicht vorhanden oder kennt der DNS-Server den Buskoppler nicht, wird per NetBIOs der Koppler angefragt. Entspricht der Name des Kopplers nicht mehr dem Default-Namen, antwortet der Koppler und gibt seine IP-Adresse bekannt*.
Zur Namens-Vergabe über NetBIOs können Sie den Koppler mit der Konfigurationssoftware KS2000 adressieren und einen Namen vergeben (siehe Tabelle 100).
*) Beim BK9000 ab Firmware-Version B8, beim BC9000 ab Firmware-Version BA.


Subnetz-Maske

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Subnetz-Maske
Subnetz-Maske
Die Subnetz-Maske unterliegt der Kontrolle des Netzwerkverwalters und legt die Struktur der Subnetze fest.
Kleine Netze ohne Router benötigen keine Subnetz-Maske. Das gleiche gilt, wenn Sie keine registrierten IP-Nummern verwenden. Sie können die Subnetz-Maske dazu verwenden, anstelle des Gebrauchs vieler Netznummern das Netz mit dieser Maske zu unterteilen.
Die Subnetz-Maske ist eine 32-Bit Ziffer:
▪
Einsen in der Maske kennzeichnen den Subnetz-Nummernteil eines Adressraums.
▪
Nullen kennzeichnen den Teil des Adressraums, der für die Host-IDs zur Verfügung steht.
Beschreibung | Binäre Darstellung | Dezimale Darstellung
IP-Adresse | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnetz-Maske | 11111111.11111111.00010100.00000000 | 255.255.20.0
Netz-ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host-ID | 00000000.00000000.00000001.11001000 | 0.0.1.200
Standard Subnetz-Maske
Adressklasse | Standard Subnetz-Maske (dezimal) | Standard Subnetz-Maske (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00
Subnetze und Host-Nummer
Die Subnetze 0 und das nur aus nur Einsen bestehende Subnetz dürfen nicht verwendet werden! Die Host-Nummer 0 und die aus nur Einsen bestehende Host-Nummer dürfen nicht verwendet werden!
Wenn die IP-Adresse über die Konfigurations-Software KS2000 eingestellt wurde, muss auch die Subnetz-Maske mit der Konfigurations-Software KS2000 geändert werden.
Bei ARP-Adressierung wird anhand der IP-Adresse die dazugehörige Standard Subnetz-Maske eingetragen.
Bei BootP und DHCP wird die Subnetz-Maske mit vom Server übertragen.


Test der IP-Adresse

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Test der IP-Adresse
Test der IP-Adresse
Zum Testen der IP-Adresse können Sie in einer Windows-Eingabeaufforderung das Kommando Ping benutzen.
Test der IP-Adresse über das Kommando Ping


Auslesen der MAC-ID

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Auslesen der MAC-ID
Auslesen der MAC-ID
Gehen Sie folgendermaßen vor, um die MAC-ID auszulesen:
▪
Ändern Sie die IP-Adresse Ihres PCs auf 172.16.x.x. und SubNetMask auf 255.255.0.0
Die IP-Adresse ist im Auslieferungszustand des BC9000 oder BK9000 172.16.17.255 (DIP-Schalter 1 bis 8 auf ON).
▪
Starten Sie das DOS-Fenster
▪
Schicken Sie ein Ping >ip-address< auf die IP-Adresse 172.16.17.255
▪
Lesen Sie die MAC-ID mit arp -a aus.


Security-Einstellungen

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Security-Einstellungen
Security-Einstellungen
Die Security-Einstellung bewirkt das der Busklemmen-Controller nur von bestimmten TCP/IP-Teilnehmern TCP/IP- bzw. UPD/IP-Telegramme annimmt und verarbeitet. Ist ein TCP/IP-Teilnehmer nicht in der Tabelle enthalten, so lehnt der Busklemmen-Controller einen Verbindungsaufbau zu diesem Teilnehmer ab. UDP-Telegramme von nicht eingetragenen Teilnehmern werden verworfen. Die Tabelle ist im Auslieferungszustand leer, d.h. das alle Teilnehmer Zugriff auf den Buskoppler haben.
KS2000 Dialog
Ab KS2000-Version 4.3.0.39 können Sie den Eintrag in die Security-Tabelle per Dialog vornehmen.
Security-Einstellungen


Konfiguration

Konfiguration
Konfiguration
Weiterführende Informationen
•
Konfiguration mit dem System Manager
•
Karteireiter IP Address
•
Karteireiter PLC
•
Konfiguration für ModbusTCP


Konfiguration mit dem System Manager

Konfiguration [image] Konfiguration mit dem System Manager
Konfiguration mit dem System Manager
Tragen Sie im TwinCAT System Manager unter Geräte eine allgemeine Ethernet-Karte ein. Sollten die Buskoppler schon am Netzwerk angeschlossen sein und eine IP-Adresse besitzen, können Sie diese auch einlesen. Dabei werden automatisch alle Buskoppler mit Busklemmen und Konfiguration hochgeladen. Diese können Sie dann nach Ihren Bedürfnissen anpassen.
Einlesen der angeschlossenen Buskoppler und Busklemmen
Inbetriebnahme bei 6 oder mehr Ethernet-Knoten
Wenn Sie im System Manager mehr als 5 Knoten eintragen, müssen Sie den Router-Speicher erhöhen. Diese Einstellung finden Sie im System Manager unter Real Time Settings. Tragen Sie dort für jeden Buskoppler 350 kByte ein. Dies ergibt z. B. für 10 Buskoppler 3,5 MB (10 x 350 kByte).
Einstellung des Router-Speichers
Hinweis: Der Router-Speicher ist vom Arbeitsspeicher ihres PCs abhängig und darf nicht beliebig hoch gesetzt werden.
Berechnung des maximal zulässigen Router-Speichers:
Max Router-Speicher [MB] = (1 MB + ((Arbeitsspeicher [MB] - 4 MB ) x 0,4)
Beispiel
Ihr PC hat 128 MB Arbeitsspeicher:
1 MB +(128 MB - 4 MB) x 0,4 = 50,6 MB
Die maximale Größe des Router-Speichers darf bei 128 MB Arbeitsspeicher 50,6 MB nicht überschreiten.


Karteireiter IP Address

Konfiguration [image] Karteireiter IP Address
Karteireiter IP Address
Ethernet-Komponenten benötigen im Netzwerk eine eindeutige IP-Adresse. Nachfolgend ist der, für die Konfiguration des Feldbusknoten im TwinCAT-System notwendige, Einstelldialog beschrieben. Der gezeigte Karteireiter erscheint nachdem Sie im System Manager unter Ihrer Ethernetkarte mit der rechten Maustaste (Box Anfügen) einen BK9000, BC9000 oder eines anderen Ethernet-Feldbusgerätes ausgewählt haben.
Karteireiter IP Address
Hostname
Hier kann der Name der Buskopplerstation editiert werden.
IP-Address
Tragen Sie hier die IP-Adresse des Buskopplers ein.
GetHostByName
Durch Betätigung dieser Schaltfläche kann (ab BK9000 Firmware-Version B2) eine IP-Adresse von einem Windows 2000 DHCP (Dynamic Host Configuration Protocol) Server bezogen werden.
AMS Address
Gibt die AMS-Net ID des Buskopplers an. Sie wird automatisch durch Hinzufügen von zwei zusätzlichen Bytes (z. B.: ".1.1") aus der IP-Adresse generiert.
BootP
Diese Checkbox ist aktivierbar, falls der Beckhoff BootP-Server installiert und gestartet ist (ab TwinCAT Version 2.8)
New MAC Addresses
Bei gestartetem Beckhoff BootP-Server können durch Betätigung dieser Schaltfläche die MAC-Adressen (Media Access Controller) neu angeschalteter Ethernet-Feldbusgeräte angezeigt werden. Falls nur ein neues Ethernet-Feldbusgerät angeschlossen ist, wird dementsprechend auch nur eine neue MAC-Adresse angezeigt, der Sie dann im oben beschriebenem Feld IP Address die gewünschte IP-Adresse zuweisen können. Bei Anschluss jeder weiteren Ethernet-Feldbuskomponenten, können Sie diesen Vorgang auf dem hier beschriebenen Karteireiter des neuen Geräts wiederholen.
Communication Settings
Einstellungen zur Kommunikation über IP (Internet Protocol).
TCP
Wenn diese Option aktiv ist (default), wird die Kommunikation über TCP (Transmission Control Protocol) abgewickelt. Dies bedeutet, dass die Telegrammpakete vom und zum Buskoppler über einen gesicherten (bestätigten) Mechanismus ausgetauscht werden.
UDP
Wenn diese Option ausgewählt wurde, wird die Kommunikation über UDP (User Datagram Protocol) abgewickelt. Im Gegensatz zum TCP sind hierbei die einzelnen Telegrammpakete nicht gesichert, d.h., sie werden nicht jeweils nach Erhalt vom Empfänger bestätigt. Zerstörte oder in der Reihenfolge vertauschte Telegrammpakete werden nicht erneut gesendet oder sortiert. Der Vorteil des UDP besteht aus kalkulierbaren Telegrammlaufzeiten, da nicht erst auf eine Antwort vom Empfänger gewartet werden muss. Man kann daher bei UDP von einer bedingten Echtzeitfähigkeit reden.
Max. Warning Level
Diese Einstelloption ist nur bei UDP aktiv. Hier kann der maximale Wert des Fehlerzählers eingetragen werden. Bei Erreichen des eingestellten Maximalwertes wird nicht mehr auf ein Antworttelegramm des Feldbusknotens gewartet. Stattdessen werden nur noch Lesetelegramme, basierend auf einer höheren Zykluszeit, zum Feldbusknoten geschickt.
No Auto Retries
Diese Checkbox ist auch nur bei aktivierter Option UDP anwählbar. Bei Erreichen des eingestellten Wertes unter Max. Warning Level, ist bei aktivierter Checkbox ein Ausführen der Funktion IO/Reset notwendig. Solange kein Reset ausgelöst wurde, werden keine Ausgänge ausgegeben.


Karteireiter PLC

Konfiguration [image] Karteireiter PLC
Karteireiter PLC
Karteireiter PLC
Bei Busklemmen-Controllern (BC) können unterhalb von SPS-Variablen spezielle Datenaustausch-Variablen für die feldbusbasierende Kommunikation zwischen PC und BC definiert werden (siehe Beispielkonfiguration eines Busklemmen-Controllers).
Bei Anwahl eines BCs in der Baumansicht des TwinCAT System Managers, erscheint auf der rechten Seite u.a. der folgende Karteireiter:
Karteireiter PLC
PLC Cycle Time
Die reservierte Zykluszeit der Kleinsteuerung. In dieser Zeitspanne werden vom BC keine Daten an den Feldbus übergeben.
Background Time
Zeit für die Bearbeitung der Kommunikation über den Feldbus (u.a. auch Programm-Download, Debugging usw.).
PLC Var. Offs IN
Start-Offset der Datenaustauschvariablen im Eingangsbereich des BC-Prozessabbilds
PLC Var. Offs OUT
Start-Offset der Datenaustauschvariablen im Ausgangsbereich des BC-Prozessabbilds
AMS Response during download
Kann aus Kompatibilitätsgründen bei älteren Busklemmen-Controllern (z.B. BC2000 und BC3100) deaktiviert werden. Neuere Bus Controller Firmware-Stände quittieren den Erhalt einzelner Download-Sequenzen. Daher muss hier die Checkbox aktiviert sein (beim BC9000 in jedem Fall).
Start with Configuration Error
Auch wenn der konfigurierte BC9000 nicht am Netzwerk angeschlossen ist, lässt sich, sofern diese Checkbox aktiviert ist, das TwinCAT-System starten.
Retain Data
Store Retain Data: Aktiviert den Support remanenter Daten im Busklemmen-Controller.
Size: Größe des remanenten Merkerbereichs innerhalb des Busklemmen-Controllers (%Mx0 ... %Mxyy).
K-Bus Update
Double Cycle: Aktiviert die Ausführung von E/A-Zyklen (K-Bus Update) innerhalb der BC-Station vor und nach jedem SPS-Zyklus.
Before PLC: Vor Ausführung des SPS-Zyklus wird ein K-Bus Update ausgeführt.
After PLC: Nach Ausführung des SPS-Zyklus wird ein K-Bus Update ausgeführt.
Firmware Update (via COMx)
Über diese Funktion kann das Update der BC-Firmware ausgeführt werden.
Karteireiter Variable
Nach Anfügen von Variablen unterhalb des Baumeintrags SPS-Variablen, erscheint auf der rechten Seite der zur Variablen gehörende Dialog, wie in der Rubrik Variablen Informationen beschrieben.
Wählen Sie sinnvolle Namen für die Datenaustauschvariablen, da diese bei Export von Variablen-Informationen als Variablen-Namen im lokalen BC-Prozessabbild verwendet werden. Anschließend können Sie, die Datenaustauschvariablen mit vorhandenen Tasks verknüpfen.
Beispielkonfiguration eines Busklemmen-Controllers
Im folgenden Bild sind sowohl Datenaustauschvariablen, wie auch die Feldbus-Variablen dargestellt. Der Busklemmen-Controller verwaltete die Klemmen 4 bis 9 lokal.
Beispielkonfiguration eines Busklemmen-Controllers


Konfiguration für ModbusTCP

Konfiguration [image] Konfiguration für ModbusTCP
Konfiguration für ModbusTCP
Für die Kommunikation über ModbusTCP ist keine besondere Konfiguration notwendig. Die Default-Einstellung beträgt 16 Byte Ein- und Ausgänge (SPS-Variablen). Diese sind über die Modbus-Funktionen erreichbar.


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
TwinCAT PLC
•
PLC Cycle Time
•
SPS-Variablen
•
Mapping der Busklemmen
•
Lokales Prozessabbild
•
Lokierter Merkerbereich %MB..
•
Feldbus Prozessabbild
•
Programmübertragung
•
Bibliotheken


TwinCAT PLC

Programmierung [image] TwinCAT PLC
TwinCAT PLC
Das Beckhoff TwinCAT Software-System verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. Die Programmierumgebung von TwinCAT wird auch für die Programmierung des BC9000 genutzt. Wenn Sie TwinCAT PLC (WinNT4, Win2000, XP) installiert haben, so können Sie die Ethernet-Verbindung oder die serielle Schnittstelle für Software-Download und Debugging verwenden.
TwinCAT E/A oder TwinCAT PLC können auch als Ethernet-Master (Host) genutzt werden, um Prozessdaten mit dem Busklemmen-Controller auszutauschen. TwinCAT stellt ihnen hierzu den System-Manager als Konfigurationstool sowie die Treiber und das ADS-Protokoll zu Verfügung.


PLC Cycle Time

Programmierung [image] PLC Cycle Time
PLC Cycle Time
Die PLC Cycle Time bestimmt die Wiederholungssequenz des Programms. Diese Zeit ist nicht deterministisch. Das bedeutet, dass die PLC Cycle Time sich je nach Programm vergrößern und über die eingestellte Cycle Time hinweg ansteigen kann. Benötigt das Programm weniger Zeit als eingestellt, wird es mit der eingestellten Cycle Time wiederholt und der Rest der übrigen Zeit mit Background Time ausgefüllt.
In der Background-Zeit läuft die Bearbeitung des Ethernets und der seriellen Schnittstelle. Diese sollte auf ca. 20 bis 50 % der PLC Cycle Time eingestellt sein.
Um das System zu optimieren misst man die Mittlere Zykluszeit. Dies finden Sie im PLC Control unter dem Menüpunkt Online/Koppler. Der dort ermittelt Zeit gibt man einen Aufschlag von 50 % und trägt die Zeit als PLC Cycle Time ein. Stellen Sie die Background Time auf 20 bis 50 % der PLC Cycle Time ein.
task time 1.png
Programmlaufzeit
Die Programmlaufzeit besteht aus der Programmbearbeitung und der K-Bus-Zeit. Bevor das Programm aufgerufen wird, fährt der Busklemmen Controller ein K-Bus-Update und liest die aktuellen Eingänge ein. Nach der Programmbearbeitung erfolgt ein zweites K-Bus-Update um die Ausgänge zu schreiben. Die K-Bus-Zeit ist abhängig von Anzahl und Art der gesteckten Busklemmen.
Man kann die Programmlaufzeit verkürzen in dem man nur einen K-Bus-Zyklus fährt und zwar entweder vor oder nach der Programmbearbeitung. Dann werden in einem K-Bus-Zyklus Eingänge gelesen und Ausgänge geschrieben. Sie können diese Einstellungen über die Konfigurationssoftware KS2000 oder per ADS vornehmen.
Taskzeit


SPS-Variablen

Programmierung [image] SPS-Variablen
SPS-Variablen
Die SPS-Variablen dienen als Schnittstelle zwischen dem lokalen Prozessabbild des Bus Controllers und dem Feldbusprozessabbild für eine übergeordnete Steuerung. Als erstes soll dies anhand der Default-Einstellung erläutert werden.
Busklemmen im lokalen Prozessabbild des BCs
Alle angeschlossenen Busklemmen sind dem lokalen Prozessabbild zugewiesen. Die SPS-Variablen befinden sich ab der Adresse 128. Sie können diese Anfangsadresse sowie die Länge dieser Daten (Default 16 Byte) verändern.
Daten, die von einer überlagerten Steuerung gelesen werden sollen, schreibt man in das Ausgangsprozessabbild. Diese Daten sind für die überlagerte Steuerung Eingangsdaten. Daten, die von der überlagerten Steuerung zum BC übertragen werden, sind für diese Steuerung Ausgangsdaten und für den BC Eingangsdaten. Dies soll die folgende Grafik verdeutlichen.
Busklemmen im lokalen Prozessabbild des BCs
Busklemmen der übergeordneten Steuerung zuweisen
Sie können die Busklemmen auch direkt der überlagerten Steuerung zuweisen. Im Feldbus Prozessabbild sieht das Ganze dann so aus, dass sich erst die analogen Busklemmen in dieses Prozessabbild mappen. Als nächstes folgen die digitalen Busklemmen und als letztes dann die SPS-Variablen.
Busklemmen der übergeordneten Steuerung zuweisen
Achten Sie darauf, dass alle benutzten Prozessabbilder nicht größer als 512 Byte sein dürfen.


Mapping der Busklemmen

Programmierung [image] Mapping der Busklemmen
Mapping der Busklemmen
Die genaue Belegung der byteorientierten Busklemmen entnehmen Sie bitte der Konfigurations-Anleitung zur jeweiligen Busklemme. Diese Dokumentation finden Sie auf der Beckhoff CD Products & Solutions oder im Internet unter http://www.beckhoff.de.
byteorientierte Busklemmen | bitorientierte Busklemmen
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Lokales Prozessabbild

Programmierung [image] Lokales Prozessabbild
Lokales Prozessabbild
Alle angeschlossenen Busklemmen werden in der Default-Einstellung dem lokalen Prozessabbild des BC/BX zugewiesen.
Das Mapping im Busklemmen Controller erfolgt nach folgender Gesetzmäßigkeit:
Erst alle komplexen Busklemmen, in der Reihenfolge wie diese gesteckt sind, und dann die digitalen Busklemmen, die zu einem Byte aufgefüllt werden.
Das Default-Mapping der komplexen Busklemmen ist:
▪
komplette Auswertung
▪
Intel-Format
▪
Word-Alignment
Beispiel
1 x BCxxxx oder BXxxxx
1 1 x KL1012
2 1 x KL1104
3 1 x KL2012
4 1 x KL2034
5 1 x KL1502
6 1 x KL3002
7 1 x KL4002
8 1 x KL6001
9 1 x KL9010
Busklemme | Position | Eingangsabbild | Ausgangsabbild
KL1502 | 5 | %IB0...%IB5 | %QB0...%QB5
KL3002 | 6 | %IB6...%IB13 | %QB6...%QB13
KL4002 | 7 | %IB14...%IB21 | %QB14...%QB21
KL6001 | 8 | %IB22...%IB29 | %QB22...%QB29
KL1012 | 1 | %IX30.0...%IX30.1 | -
KL1104 | 2 | %IX30.1...%IX30.5 | -
KL2012 | 3 | - | %QX30.0...%QX30.1
KL2034 | 4 | - | %QX30.2...%QX30.5
KL9010 | 9 | - | -
Adresse der Busklemmen, die Sie lokalen SPS (BCxx00) zugewiesen wurden
Falls Sie nicht wissen, auf welchen Adressen sich die Busklemmen befinden, die Sie der lokalen SPS Ihres BC/BX zugewiesen haben:
Konfigurieren Sie im System Manager Ihre Hardware-Konfiguration.
Nachdem Sie alle Busklemmen und SPS-Variablen eingetragen haben, klicken Sie im Hardware-Baum des System Managers mit der rechten Maustaste auf den BC/BX und wählen Sie den Menü Punkt Export Variablen Info...
Es wird eine Datei gespeichert, die Sie im PLC-Control unter Projekt Importieren einfügen können.
Nun haben Sie unter den globalen Variablen den Eintrag TwinCAT Import, in dem Sie alle Variablen finden, die Sie der lokalen SPS ihres BC/BX zugeordnet haben.


Lokierter Merkerbereich %MB..

Programmierung [image] Lokierter Merkerbereich %MB..
Lokierter Merkerbereich %MB..
Weiterführende Informationen
•
Remanente und persistente Daten
•
Diagnose
•
Zykluszeitmessung


Remanente und persistente Daten

Programmierung [image] Lokierter Merkerbereich %MB.. Remanente und persistente Daten
Remanente und persistente Daten
Im höheren Speicherbereich gibt es spezielle Merker für remanente und persistente Daten.
Remanente Daten
Die remanenten Daten befinden sich im lokierten Merkerbereich. In der Default-Einstellung sind 64 Byte remanent, d.h. von %MB0 bis %MB63. Dieser Bereich lässt sich maximal bis auf 4 kByte vergrößern. Dabei ist darauf zu achten, das sich die Task-Zeit mit der Menge der remanenten Daten erhöht (512 Byte ca. 0,5 ms). Die Einstellungen für die remanenten Daten können Sie über den System Manager (TwinCAT) oder mit der Konfigurationssoftware KS2000 vornehmen (Tabelle 1 Register 15 Default 64 max. 4 kByte).
Persistente Daten
Die persistenten Daten sind noch eine Stufe stabiler, d.h. diese Daten bleiben sogar bei einem Programmdownload erhalten. Die Anzahl der persistenten Daten muss kleiner oder gleich der Anzahl der remanenten Daten sein! Die persistenten Daten liegen wie die remanenten Daten im lokierten Merkerbereich (%MBxx). Die Einstellungen für die persistenten Daten können Sie mit der Konfigurationssoftware KS2000 vornehmen (Tabelle 1 Register 18 Default 0 max. 4 kByte).
Beispiel
400 Byte remanente Daten, davon sollen 200 Byte persistent sein
Register 15 400 (%MB200 … %MB399)
Register 18 200 (%MB0 … %MB199)


Diagnose

Programmierung [image] Lokierter Merkerbereich %MB.. Diagnose
Diagnose
Es gibt die Möglichkeit, die Diagnosedaten im Busklemmen-Controller zu lesen. Diese Informationen liegen im lokierten Merkerbereich.
Merker-Byte | Bedeutung
%MB4092-4093 | Bit 0 | Watchdog ADS Kommunikation
 | Bit 1 | Watchdog ModbusTCP Kommunikation
 | Bit 1 … 14 | reserviert
 | Bit 15 | Keine Verbindung zum Switch: die LED Link leuchtet nicht (Im Auslieferungszustand ist die Übertragung dieser Fehlerinformation deaktiviert. Setzen Sie zum Aktivieren in Tabelle 100, Register 25 auf 1bin).
%MB4094-4095 | Bit 0 | K-Bus-Fehler
 | Bit 1 | Konfigurationsfehler
 | Bit 2 | K-Bus-Zykluszeit überschritten (siehe Tabelle 1, Register 17)
 | Bit 3 … 15 | reserviert


Zykluszeitmessung

Programmierung [image] Lokierter Merkerbereich %MB.. Zykluszeitmessung
Zykluszeitmessung
In dem Merkerbereich befindet sich eine Zeitmessung mit einer Auflösung von einer Millisekunde pro Digit. Der Datentyp ist UDINT (unsigned double integer). Dieser Wert kann vom Programm überschrieben werden, um einen Abgleich zu einer Steuerung zu übernehmen. Der Überlauf geschieht nach ca. 48 Tagen.
Merker-Byte | Bedeutung
%MB4088-4091 | 4 Byte
 | Datentyp | UDINT
 |  | 0...4,22 Mrd ms / 0... ca. 48 Tage
 | Auflösung | 1 ms / Digit


Feldbus Prozessabbild

Programmierung [image] Feldbus Prozessabbild
Feldbus Prozessabbild
Weiterführende Informationen
•
Feldbus-Prozessabbild
•
ModbusTCP-Prozessabbild
•
ADS-Prozessabbild


Feldbus-Prozessabbild

Programmierung [image] Feldbus Prozessabbild [image] Feldbus-Prozessabbild
Feldbus-Prozessabbild
Bei allen BCxxxx sind in der Default-Einstellung 16 Byte Ein- und Ausgänge dem Feldbus zugewiesen. Diese Variablen heißen SPS-Variablen. Sie liegen im BCxxxx Prozessabbild in der Default-Einstellung ab Adresse 128. Diese Adresse kann verschoben werden. Die Einstellung kann mit der Konfigurationssoftware KS2000 oder bei einigen BCs per Start-Up-Parameter geändert werden.


ModbusTCP-Prozessabbild

Programmierung [image] Feldbus Prozessabbild [image] ModbusTCP-Prozessabbild
ModbusTCP-Prozessabbild
Das Prozessabbild des ModbusTCP unterscheidet grundsätzlich digitale und byteorientierte (wortorientierte) Signale. Anhand von Beispielen soll dies verdeutlicht werden.
Beispiel 1 (Default-Einstellung)
Alle angeschlossenen Busklemmen sind der lokalen PLC zugeordnet. Für die Kommunikation mit dem ModbusTCP-Master stehen die 16 Byte SPS-Variablen zur Verfügung. SPS-Variablen zählen zu den byteorientierten Datenpaketen und können deshalb auch nicht mit den digitalen Modbus-Funktionen erfasst werden, auch wenn diese Variablen im BCxxxx digital gemappt sind. Probleme bereitet meist die Sichtweise der Ein - oder Ausgänge. Was für den BCxxxx bei den SPS-Variablen Ausgänge sind, sind für den Modbus-Master Eingänge und umgekehrt. Eine Änderung der Default-Einstellung kann mit der Konfigurations-Software KS2000 geändert werden (Registerbeschreibung Tabelle1).
Eingänge lokale SPS |  |  | Ausgänge lokale SPS
Modbus- Funktion | Modbus- Adresse/Offset | Lokale Variable | Modbus- Funktion | Modbus- Adresse/Offset | Lokale Variable
3 lesen | 0x800…807 | %IB128...%IB143 | 3 lesen | 0x000...007 | %QB128...%QB143
 |  |  | 4 lesen | 0x000...007 | %QB128...%QB143
6 schreiben | 0x800...807 | %IB128...%IB143 |  |  |
16 schreiben | 0x800...807 | %IB128...%IB143 |  |  |
23 lesen/schreiben | 0x800...807 | %IB128...%IB143 | 23 lesen/schreiben | 0x000..007 | %QB128...%QB143
Beispiel 2
Zusätzlich können die Busklemmen einmal dem BC zugewiesen werden oder der lokalen SPS. Das verkompliziert das Prozessabbild zusätzlich. Die Regel, wie sich das Prozessabbild zusammenstellt, ist allerdings einfach.
▪
Eintrag aller byte-orientierten Busklemmen (zum Beispiel die analoge Busklemmen)
▪
Eintrag aller digitalen Busklemmen (auf 16 Bit wird aufgerundet)
▪
Eintrag der SPS-Variablen


ADS-Prozessabbild

Programmierung [image] Feldbus Prozessabbild [image] ADS-Prozessabbild
ADS-Prozessabbild
Bei allen BCxxxx sind in der Default-Einstellung 16 Byte Ein- und Ausgänge dem Feldbus zugewiesen. Diese Variablen heißen SPS-Variablen und liegen in der Default-Einstellung des BCxxxx im Prozessabbild ab Adresse 128. Diese Einstellung kann mit der Konfigurationssoftware KS2000 oder, bei BCs die ADS unterstützen, per Start-UP-Parameter geändert werden.


Programmübertragung

Programmierung [image] Programmübertragung
Programmübertragung
Weiterführende Informationen
•
Programmübertragung über die serielle Schnittstelle
•
Programmübertragung über Ethernet


Programmübertragung über die serielle Schnittstelle

Programmierung [image] Programmübertragung [image] Programmübertragung über die serielle Schnittstelle
Programmübertragung über die serielle Schnittstelle
Die Programmierung des Busklemmen-Controllers erfolgt mit TwinCAT.
Der Programm-Download auf den Busklemmen-Controller kann auch über die RS232 Schnittstelle des PCs erfolgen. Verwenden Sie hierzu ein spezielles Kabel, das im Lieferumfang der Konfigurations-Software KS2000 enthalten ist.
Wählen Sie hierzu im TwinCAT PLC-Control die serielle Schnittstelle an.
Auswahl der Zielplattform
Unter Online/Kommunikationsparameter finden Sie im PLC-Control die Einstellungen zur seriellen Schnittstelle, Portnummer, Baud-Rate usw. Der Busklemmen Controller benötigt folgende Einstellung:
▪
Baud-Rate: 19200
▪
Stopp-Bits: 1
▪
Parity: Gerade
Kommunikationsparameter


Programmübertragung über Ethernet

Programmierung [image] Programmübertragung [image] Programmübertragung über Ethernet
Programmübertragung über Ethernet
TwinCAT bietet die Eigenschaft, das Anwenderprogramm über das Ethernet auf den BC9000 zu übertragen. Im PLC Control kann nach dem Sichern in der Registry und einem Restart des TwinCAT-Systems, als Zielsystem der BC9000 angewählt werden. Erforderlich ist der TwinCAT-Level TwinCAT PLC.
Initialisieren des BC9000
Um den Koppler im PLC Control auswählen zu können, muss er dem System erst einmal bekannt gemacht werden. Es gibt zwei Möglichkeiten dies zu tun. Welche Möglichkeit Sie nutzen, hängt von Ihren Erfordernissen ab.
1. Sie nutzten TwinCAT PLC nur zum Programmieren.
Klicken Sie mit der linken Maustaste auf das TwinCAT-Icon rechts unten in der Bildschirmecke.
Das Menü hinter dem TwinCAT-Icon
Wähle Sie den Menüpunkt Eigenschaften aus.
TwinCAT System-Eigenschaften
Tragen Sie den BC9000 unter dem Menüpunkt AMS Router als Remote-Computer ein. Klicken Sie dafür auf Hinzufügen.
Remote-Verbindung hinzufügen
Tragen Sie den Namen ein, dieser kann frei gewählt werden. Die AMS-Net-ID ist die IP-Adresse ergänzt um ".1.1". Diese Adresse ist die eingestellte IP-Adresse des Buskopplers. Bestätigen Sie mit OK. Nach dem Eintrag der gewünschten Buskoppler müssen Sie das TwinCAT-System Starten (das TwinCAT Icon ist grün). Nun ist der Ethernet-Koppler dem System bekannt gemacht worden und kann jetzt im PLC Control ausgewählt werden.
2. Sie nutzten TwinCAT für den zyklischen Datentransport
TwinCAT System Manager
Starten Sie den System Manager und tragen dort Ihre Konfiguration ein. Im Unterschied zur ersten Methode wird beim Start des TwinCAT diese Konfiguration zum Koppler heruntergeschrieben (z.B. Busklemmen Mapping, PLC Zykluszeit, Anzahl der Retain-Daten etc.). Andere Einstellungen, die mit der Konfigurations-Software KS2000 gemacht wurden, werden überschrieben.
PLC Control
Beim Neustart des TwinCAT PLC Control fragt TwinCAT nach der Zielplattform, d.h. auf welchem Gerät später das Anwender-Programm laufen soll. TwinCAT bietet als Steuerung zwei Zielplattformen, den PC oder den Busklemmen-Controller.
Für die Übertragung zum Busklemmen-Controller stehen Ihnen zwei Wege zur Verfügung:
▪
AMS für die Kommunikation über den Feldbus
▪
das serielle Kabel für die Kommunikation über die RS232-Schnittstelle des PCs und die Programmierschnittstelle des Busklemmen-Controllers
Auswahl der Zielplattform
Wählen Sie nach Erstellung Ihres Programms unter der Symbolleiste Online das Zielsystem aus. Hierzu muss TwinCAT gestartet sein. Im Beispiel ist dies die Ethernet-Karte mit der Box 1 und die Run-Time 1 des Busklemmen-Controllers.
Auswahl der Zielsystems


Bibliotheken

Programmierung [image] Bibliotheken
Bibliotheken
Weiterführende Informationen
•
Bibliotheken
•
TcUtilitiesBC9000
•
TcIpUtilitiesBC


Bibliotheken

Programmierung [image] Bibliotheken [image] Bibliotheken
Bibliotheken
Für die Busklemmen Controller (Buskoppler mit SPS-Funktionalität, Bezeichnung BCxxxx) gibt es verschiedene Bibliotheken (siehe TwinCAT InfoSys).
TwinCAT PLC Library: System BC
Die Bibliothek beinhaltet Funktionsbausteine für den Zugriff auf Systemfunktionen der Busklemmen Controller (BCxxxx).
TwinCAT PLC Library: Utilities BC
Die Bibliothek beinhaltet nützliche Funktionsbausteine für die Busklemmen Controller (BCxxxx). Neben den RTC-Bausteinen beinhaltet die Bibliothek einen Funktionsbaustein für die Dekodierung des DCF-77 Zeitsignals und einige Konvertierungsfunktionen. Intern werden die Systemfunktionen der Busklemmen Controller aufgerufen.
TwinCAT PLC Library: Helper BC
Die Bibliothek PlcHelperBC.lb6 beinhaltet einige Funktionen für den direkten Zugriff auf Speicherbereiche des SPS-Laufzeitsystems der Busklemmen Controller (BCxxxx).
TwinCAT PLC Library: ADS BC
Die Bibliothek beinhaltet Funktionsbausteine für eine azyklische Client-Server-Kommunikation zwischen einem Busklemmen Controller BC9xxx und anderen ADS-Geräten im Netzwerk. Die Funktionsweise der Bausteine unterscheidet sich im Wesentlichen nicht von denen für das SPS-Laufzeitsystem auf dem PC.
TwinCAT PLC Library: Ereignisgesteuerte Übertragungsbausteine BC
Die vorliegenden Funktionsbausteine vereinfachen den ereignisgesteuerten Datenaustausch zwischen Busklemmen Controllern und/oder anderen ADS-Geräten (TwinCAT NC, Busklemmen Controller, ...).
Die Funktionsbausteine FB_WriteXXXOnDelta() führen einen Schreibvorgang aus, wenn das Eingangssignal einen bestimmten Grenzwert über-/ bzw. unterschritten hat. Wie oft das Eingangssignal überprüft werden soll, kann eingestellt werden. Durch das ereignisgesteuerte Schreiben der Daten wird die Belastung der Feldbusses minimiert. Tritt bei der Übertragung ein Fehler auf, so wird der Vorgang solange wiederholt, bis die Verbindung wieder vorhanden ist. Als Quell- und Zielvariablen sind alle, in der TwinCAT PLC unterstützten Datentypen zugelassen. Symbolnamen werden ebenfalls unterstützt.
Zur Überwachung einzelner Kommunikationspartner stehen Watchdog-Bausteine zur Verfügung. Der zu überwachende Teilnehmer versendet zyklisch einen inkrementierenden Zähler. Bei dem Empfänger wird überprüft, ob sich der Zählerstand innerhalb einer bestimmten Zeit ändert.
TwinCAT PLC Library: ModbusTCP BC
Die Bibliothek beinhaltet Funktionsbausteine die einen Datenaustausch zwischen dem Busklemmen Controller (BC9xxx) und einem Remote-Partner auf dem MODBUS/TCP-Port ermöglichen.
TwinCAT PLC Library: SMTP BC
Die Bibliothek beinhaltet nützliche Funktionsbausteine für den Busklemmen Controller (BC9xxx) um das SMTP-Protokoll (Simple Mail Transfer Protocol) zu nutzen.


TcUtilitiesBC9000

Programmierung [image] Bibliotheken [image] TcUtilitiesBC9000
TcUtilitiesBC9000
Weiterführende Informationen
•
TcUtilities BC9000


TcUtilities BC9000

Programmierung [image] Bibliotheken [image] TcUtilitiesBC9000 [image] TcUtilities BC9000
TcUtilities BC9000
Download Bibliothek ( )
FUNCTION_BLOCK RW_FieldbusPrmBC9000
Mit diesem Baustein können Feldbusparameterdaten geändert werden. Es ist nur eine Instanz dieses Bausteins erlaubt.
Funktionsbaustein RW_FIELDBUSPRMBC9000
VAR_INPUT
bStart_R :BOOL;
bStart_W :BOOL;
NetID: :STRING;
W_BC9000_PRM :BC9000_Fieldbus;
AutoReboot :BOOL;
bStart_R: liest die Daten und gibt sie in R_BC9000_Prm aus
bStart_W: liest und schreibt die Daten der Datenstruktur W_BC9000Prm
NetID: String - AMSNetId
W_BC9000_Prm: Datenstruktur für die Parameter
AutoReboot: "TRUE" - der Koppler startet und rebootet nach erfolgreichem setzen der Parameter Automatisch neu. Damit sind die geänderten Einstellungen gültig.
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
iErrorId :DWORD;
R_BC9000_Prm :BC9000_Fieldbus;
RebootNecessary :BOOL;
bBusy: So lange der Baustein TRUE ist der Baustein aktiv.
bError: Fehler Bit.
iErrorId: Fehler Nummer.
R_BC9000_Prm: Datenstruktur Feldbusdaten.
RebootNecessary: Die Parameter sind neu, es ist ein restart des BC-Controllers notwendig.
TYPE BC9000_Fieldbus:
STRUCT
Disable_ADS :BOOL;
WD_ADS :WORD;
CloseIP_Port_ADS :WORD;
DisableModbus :BOOL;
WD_Modbus :WORD;
Close_IP_Port_Modbus :WORD;
FastModbus :BOOL;
IP_Port_Number_Modbus :WORD;
END_STRUCT
END_TYPE
Legende
Disable_ADS: Deaktiviert das ADS Protokoll (Tabelle 100 Offset 15.1)
WD_ADS: ADS Watchdog, wird nach dieser Zeit kein Telegramm empfangen werden Ausgänge auf null geschrieben (Tabelle 100 Offset 14)
Close_IP_Port_ADS: Der TCP/IP Dienst wird nach dieser Zeit geschlossen wenn kein Telegramm mehr den Koppler erreicht (Tabelle 100 Offset 27)
Disable_Modbus: Deaktivierung Modbus Protokoll (Tabelle 100 Offset 15.0)
WD_Modbus: ModbusTCP Watchdog, wird nach dieser Zeit kein Telegramm empfangen werden Ausgänge auf null geschrieben (Tabelle 100 Offset 24)
Close_IP_Port_Modbus: Der TCP/IP Dienst wird nach dieser Zeit geschlossen wenn kein Telegramm mehr den Koppler erreicht (Tabelle 100 Offset 28)
FastModbus: Aktiviert das Fast Modbus (Tabelle 100 Offset 29.0)
IP_Port_Number_Modbus: Die TCP Port Nummer (Tabelle 100 Offset 26)
Rückgabeparameter iErrId | Bedeutung
0 | kein Fehler
> 0 | Fehler Nummer (#nicht dokumentiert#)
FUNCTION_BLOCK RW_ParameterBC9000
Mit diesem Baustein können die PLC Parameter geändert werden. Es ist nur eine Instanz dieses Bausteins erlaubt.
Funktionsbaustein RW_PARAMETERBC9000
VAR_INPUT
bStart_R :BOOL;
bStart_W :BOOL;
NetID: :STRING;
W_BC9000_PRM :BC9000_Prm;
AutoReboot :BOOL;
bStart_R: liest die Daten und gibt sie in R_BC9000_Prm aus
bStart_W: liest und schreibt die Daten der Datenstruktur W_BC9000Prm
NetID: String - AMSNetId
W_BC9000_Prm: Datenstruktur für die Parameter
AutoReboot: "TRUE" - der Koppler startet und rebootet nach erfolgreichem setzen der Parameter Automatisch neu. Damit sind die geänderten Einstellungen gültig.
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
iErrorId :DWORD;
R_BC9000_Prm :BC9000_Prm;
RebootNecessary :BOOL;
bBusy: So lange der Baustein TRUE ist der Baustein aktiv.
bError: Fehler Bit.
iErrorId: Fehler Nummer.
R_BC9000_Prm: Datenstruktur Feldbusdaten.
RebootNecessary: Die Parameter sind neu, es ist ein restart des BC-Controllers notwendig.
TYPE BC9000_Fieldbus:
STRUCT
Byte_Offset_Output :WORD;
Byte_Offset_Input :WORD;
PLC_Offset_Input :WORD;
PLC_Len_Input :WORD;
PLC_Offset_Output :WORD;
Task_Time :WORD;
Background_Time :WORD;
RetainData :WORD;
PersistentData :WORD;
Terminal_Refresh :WORD;
Check_Terminals: :BOOL;
END_STRUCT
END_TYPE
Legende
Byte_Offset_Output: Gibt den Offset an, an dem die digitale Ausgangsklemmen anfangen sollen (Tabelle 0 Offset 19)
Byte_Offset_Input: Gibt den Offset an, an dem die digitale Eingangsklemmen anfangen sollen (Tabelle 0 Offset 20)
PLC_Offset_Input: Gibt den Offset an, an dem die Feldbuseingangsdaten (PLC-Variablen) anfangen sollen (Tabelle 1 Offset 0)
PLC_Len_Input: Gibt die Länge der Feldbuseingangsdaten (PLC-Variablen) an (Tabelle 1, Offset 1)
PLC_Offset_Output: Gibt den Offset an, an dem die Feldbusausgangsdaten (PLC-Variablen) anfangen sollen (Tabelle 1 Offset 2)
PLC_Len_Output: Gibt die Länge der Feldbusausgangsdaten (PLC-Variablen) an (Tabelle 1, Offset 3)
Task_Time: Task Zeit (Tabelle 1, Offset 12)
Background_Time: Background Zeit (Tabelle 1, Offset 13)
RetainData: Anzahl der Retain Daten (Tabelle 1, Offset 15)
PersistentData: Anzahl der Persitenten Daten (Tabelle 1, Offset 18)
Terminal_Refresh: K-Bus refresh (Tabelle1, Offset 17)
Check_Terminals: Überprüfung der Busklemme beim Start deaktivieren (Tabelle 1, Offset 14.6)
Rückgabeparameter iErrId | Bedeutung
0 | kein Fehler
> 0 | Fehler Nummer (#nicht dokumentiert#)
Download Beispiel ( )


TcIpUtilitiesBC

Programmierung [image] Bibliotheken [image] TcIpUtilitiesBC
TcIpUtilitiesBC
Weiterführende Informationen
•
Time Protokoll (SNTP)


Time Protokoll (SNTP)

Programmierung [image] Bibliotheken [image] TcIpUtilitiesBC [image] Time Protokoll (SNTP)
Time Protokoll (SNTP)
(Ab Firmware-Version BB)
Das Simple Network Time Protokoll dient zu synchronisieren von Uhren über das Internet. Sie können den BC9000 zu einem Time-Server synchronisieren.
Download Bibliothek ( )
Funktionsbaustein FB_SNTP
FUNCTION_BLOCK FB_SNTP
Ab Firmware-Version BA:
Wenn in der Variable sSntpServer ein Leerstring eingetragen wird, sucht der BC9000 einen Time-Server. Wird keiner gefunden wird abgebrochen. Wenn ein Time-Server gefunden wird, kann man unter der Variable cCurrSntpServer sich die IP-Adresse anzeigen lassen. Eine positive Flanke von bStart aktiviert den Baustein und startet die Anfrage an den Time-Server.
Ab Firmware-Version BB:
Wird eine IP-Adresse eingetragen benutzt der Busklemmen Controller das SNTP-Protokoll. Wird eine Leer String übergeben wird das Time-Protokoll (UDP Port 37) verwendet.
VAR_INPUT
bStart :BOOL;
sSntpServer :STRING(15);
tTimeOut :TIME;
bOpen: Positive Flanke startet den Baustein
sSntpServer: Eintrag des SNTP Servers. Wenn ein Leerstring eingegeben wird, wird das Time-Protokoll verwendet (UDP Port 37)*.
tTimeOut: TMOut nach dem abgebrochen werden soll
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
iErrorId :WORD;
tTime :DT;
cCurrSntpServer :STRING(15);
bBusy: So lange der Baustein TRUE ist der Baustein aktiv.
bError: Fehler Bit.
iErrorId: Fehler Nummer.
tTime: Zeit und Datum.
sCurrSnptServer: IP-Adresse des SNTP-Servers
Rückgabeparameter iErrId | Bedeutung
0 | kein Fehler
> 0 | Fehler Nummer (#nicht dokumentiert#)
Download Beispiel ( )


Feldbussystem

Feldbussystem
Feldbussystem
Weiterführende Informationen
•
Ethernet
•
Topologie
•
Reaktionszeiten
•
ADS-Kommunikation
•
ModbusTCP
•
Beschreibung der Parameter


Ethernet

Feldbussystem [image] Ethernet
Ethernet
Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.
Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.
Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.
MAC-ID
Sender und Empfänger von Ethernet-Paketen werden über die MAC-ID adressiert. Die MAC-ID ist ein 6 Byte großer Identifikations-Code, der eineindeutig, d.h. für jedes Ethernet-Gerät weltweit unterschiedlich ist. Die MAC-ID besteht aus zwei Teilen. Der erste Teil (d.h. die ersten 3 Byte) ist eine Herstellerkennung. Die Firma Beckhoff hat die Kennung 00 01 05. Die nächsten 3 Byte werden durch den Hersteller vergeben und entsprechen einer eindeutigen Seriennummer. Die MAC-ID kann zum Beispiel beim BootP-Protokoll zum Einstellen der TCP/IP-Nummer verwendet werden. Dafür wird ein Telegramm zum entsprechenden Knoten geschickt, das die Informationen wie Name oder TCP/IP-Nummer beinhaltet. Sie können die MAC-ID mit der Konfigurationssoftware KS2000 auslesen.
Internet-Protokoll (IP)
Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.
Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z. B. IP, TCP, UDP, ARP und ICMP.
Transmission Control Protocol (TCP)
Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.
User Datagram Protocol (UDP)
UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.
User Datagram Protocol (UDP)
Auf TCP/IP und UDP/IP aufsetzende Protokolle
Auf TCP/IP bzw. UDP können folgende Protokolle aufsetzen:
▪
ADS
▪
ModbusTCP
Beide Protokolle sind parallel auf dem Buskoppler implementiert, so dass für die Aktivierung der Protokolle keine Konfiguration nötig ist.
Auf TCP/IP und UDP/IP aufsetzende Protokolle
ADS setzt wahlweise auf TCP oder UDP auf, während ModbusTCP stets auf TCP/IP basiert.


Topologie

Feldbussystem [image] Topologie
Topologie
Mit 10BaseT und 100BaseT werden mehrere Stationen im Ethernet-Standard sternförmig verbunden.
Stern-Topologie
Ein Stern-LAN besteht in der einfachsten Netzform aus einzelnen Punkt-zu-Punkt-Verbindungen. Alle Nachrichten laufen über einen zentralen Knoten (Hub oder Switch), der je nach Zieladresse die Informationen an den gewünschten Empfänger weitergibt.
Baum-Topologie
Eine Baum Topologie besteht aus mehreren verbundenen Stern-Topologien. Sobald mehrere Hubs oder Switches im Netz vorhanden sind, ist eine Baumtopologie vorhanden. Ideal ist es, die Verbindungen zwischen den Sternkopplern besonders breitbandig auszuführen, da diese den meisten Datenverkehr transportieren. Beim Aufbau von Baum-Topologien ist die Repeater-Regel zu beachten, die auch als 5-4-3-Repeater-Regel bezeichnet wird. Maximal zwei Repeater-Paare (bzw. Hub-Paare) dürfen im Übertragungsweg zwischen zwei beliebigen Stationen sein, sofern sie nicht durch Bridges, Switches oder Router getrennt sind. Ein Übertragungsweg kann aus maximal fünf Segmenten und vier Repeater-Sets (zwei Repeater-Paaren) bestehen. Dabei können bis zu drei Segmente Koax-Segmente sein, an denen die Stationen angeschlossen sind, die restlichen Segmente müssen Punkt-zu-Punkt-Verbindungen sein, die auch als IRL-Verbindung (Inter Repeater Link) bezeichnet werden.
Verkabelungsrichtlinien
Allgemeine Richtlinien für den Netzwerkaufbau eines LAN gibt die Strukturierte Verkabelung vor. Darin sind maximal zulässige Kabellängen für die Gelände-, Gebäude- und Etagenverkabelung festgelegt. In den Standards EN 50173, ISO 11801 und TIA 568-A normiert, bildet die Strukturierte Verkabelung die Grundlage für eine zukunftsweisende, anwendungsunabhängige und wirtschaftliche Netzwerk-Infrastruktur. Die Verkabelungsstandards definieren einen Geltungsbereich mit einer geographischen Ausdehnung von bis zu 3 km und für eine Bürofläche von bis zu 1 Mio. Quadratmeter mit 50 bis 50.000 Endgeräten. Darüber beschreiben sie Empfehlungen für den Aufbau eines Verkabelungssystems. Abhängig von der gewählten Topologie, den unter Industriebedingungen eingesetzten Übertragungsmedien und Koppelmodulen sowie von dem Einsatz von Komponenten verschiedener Hersteller in einem Netz können sich abweichende Angaben ergeben. Die Angaben verstehen sich hier deshalb lediglich als Empfehlungen.


Reaktionszeiten

Feldbussystem [image] Reaktionszeiten
Reaktionszeiten
Reaktionszeit des BC9000
ADS | Zeit [ms]
TCP | 23 bis 50 ms + Task-Zeit auf dem BC9000 (Jitter)
UDP | 2 bis 3 ms + Task-Zeit auf dem BC9000 (Jitter)
Modbus | Zeit [ms]
TCP | 12 bis 15 ms + Task-Zeit auf dem BC9000 (Jitter) (Default)
Fast TCP* | 1 bis 3 ms + Task-Zeit auf dem BC9000 (Jitter)
* ab Firmware B7, Tabelle 100 Register 29 - "1" Fast TCP / "0" TCP (Siehe Modbus Interface)
Reaktionszeit BK9000
ADS | Zeit [ms]
TCP | 23 bis 50 ms
UDP | 2 bis 3 ms
RT-Ethernet** | Zeit [ms]
RAW | < 1 ms + K-Bus (abhängig von der K-Bus Laufzeit)
Modbus | Zeit [ms]
TCP | 12 bis 15 ms (Default)
Fast TCP* | 1 bis 3 ms
* ab Firmware B5, Tabelle 100 Register 29 - "1" Fast TCP / "0" TCP (Siehe Modbus Interface)** ab Firmware B8


ADS-Kommunikation

Feldbussystem [image] ADS-Kommunikation
ADS-Kommunikation
Weiterführende Informationen
•
ADS-Kommunikation
•
ADS-Protokoll
•
ADS-Dienste


ADS-Kommunikation

Feldbussystem [image] ADS-Kommunikation [image] ADS-Kommunikation
ADS-Kommunikation
Das ADS-Protokoll (ADS: Automation Device Specification) ist eine Transportschicht innerhalb des TwinCAT-Systems. Es ist für den Datenaustausch der verschiedenen Software-Module entwickelt worden, zum Beispiel für die Kommunikation zwischen der NC und der PLC. Mit diesem Protokoll haben Sie die Freiheit von jedem Punkt im TwinCAT mit anderen Tools kommunizieren zu können. Wird die Kommunikation zu anderen PCs oder Geräten benötigt, setzt das ADS-Protokoll auf TCP/IP auf. Somit ist es in einem vernetzten System möglich, alle Daten von einem beliebigen Punkt aus zu erreichen.
Das ADS-Protokoll als Transportschicht innerhalb des TwinCAT-Systems
Das ADS-Protokoll wird auf das TCP/IP- oder UDP/IP-Protokoll aufgesetzt. Es ermöglicht dem Benutzer innerhalb des Beckhoff-Systems über nahezu beliebige Verbindungswege mit allen angeschlossenen Geräten zu kommunizieren und diese zu parametrieren. Außerhalb des Beckhoff-Systems stehen verschiedene Wege offen, um mit anderen Software-Tools Daten auszutauschen.
Software-Schnittstellen
ADS-OCX
Das ADS-OCX ist eine Active-X-Komponente und bietet eine Standardschnittstelle zum Beispiel zu Visual Basic, Delphi, usw.
ADS-DLL
Sie können die ADS-DLL (DLL: Dynamic Link Library) in Ihr C-Programm einbinden.
OPC
Die OPC-Schnittstelle ist eine genormte Standardschnittstelle für die Kommunikation in der Automatisierungstechnik. Beckhoff bietet hierfür einen OPC-Server an.


ADS-Protokoll

Feldbussystem [image] ADS-Kommunikation [image] ADS-Protokoll
ADS-Protokoll
Die ADS-Funktionen bieten die Möglichkeit, direkt vom PC auf Informationen des Buskopplers zuzugreifen. Dafür können ADS-Funktionsbausteine im TwinCAT PLC Control verwendet werden. Die Funktionsbausteine sind in der Bibliothek TcSystem.lib enthalten. Genauso ist es möglich, die ADS-Funktionen von AdsOCX, ADSDLL oder OPC aufzurufen. Über die ADS-Portnummer 300 sind alle Daten und über die ADS-Portnummer 100 Zugriffe auf die Register des Buskopplers und der Klemmen möglich.
Aufbau des ADS-Protokolls
AMSNetID
Die AMSNetID beschreibt das anzusprechende Gerät. Diese wird aus der eingestellten TCP/IP-Adresse und zusätzlichen 2 Byte erstellt. Diese zusätzlichen 2 Byte bestehen aus "1.1" und sind nicht veränderbar.
Beispiel:
IP-Adresse 172.16.17.128
AMSNetID 172.16.17.128.1.1
Port-Nummer
Die Portnummer unterscheidet im angeschlossenen Gerät Unterelemente.
Port 100: Registerzugriff
Port 300: Prozessdaten Feldbus
Port 800: lokale Prozessdaten (nur BC90x0, C900)
Index Group
Die Index Group unterscheidet innerhalb eines Ports verschiedene Daten.
Index Offset
Gibt den Offset an, ab welchem Byte gelesen oder geschrieben werden soll.
Len
Gibt die Länge der Daten in Byte an, die gelesen bzw. geschrieben werden sollen.
TCP-Port-Nummer
Die TCP-Port-Nummer beträgt für das ADS-Protokoll 48898 oder 0xBF02.


ADS-Dienste

Feldbussystem [image] ADS-Kommunikation [image] ADS-Dienste
ADS-Dienste
Weiterführende Informationen
•
ADS-Dienste
•
Weitere ADS-Dienste
•
Beispiele


ADS-Dienste

Feldbussystem [image] ADS-Kommunikation [image] ADS-Dienste [image] ADS-Dienste
ADS-Dienste
Nutzdaten eines ADS-Telegramms
Die Nutzdaten eines ADS-Telegramms betragen maximal 1900 Byte.
Prozessdaten-Port 300
Der Zugriff auf die Feldbusdaten erfolgt über die ADS-Portnummer 300. Diese Daten werden von einem Watchdog überwacht. Sollte innerhalb von 1000 ms kein weiteres Telegramm eintreffen, werden die Ausgänge in den sicheren Zustand geschaltet.
Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...511
0xF030 | Output - Ausgänge | 0...511
Lokales Prozessabbild Port 800 (nur BC9000, C900)
Im lokalen Prozessabbild können Daten gelesen und geschrieben werden. Sollten Ausgänge geschrieben werden, muss darauf geachtet werden, dass diese von der lokalen SPS nicht verwendet werden, da die lokale Steuerung diese Werte überschreibt. Die Daten sind nicht an einen Watchdog gebunden und dürfen daher nicht für Ausgänge verwendet werden, die im Fehlerfall ausgeschaltet werden müssen.
Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...511
0xF030 | Output - Ausgänge | 0...511
0x4020 | Merker (nur BC9000, C900) | 0...4096
Dienste des ADS
AdsServerAdsStateB7
Datentyp (read only) | Bedeutung
String | Start - die lokale PLC läuft Stop - die lokale PLC ist im Stop
AdsServerDeviceStateB7
Datentyp (read only) | Bedeutung
INT | 0 - Start - die lokale PLC läuft 1 - Stop - die lokale PLC ist im Stop
AdsServerTypeB7
Datentyp (read only) | Bedeutung
String | Coupler_PLC
ADSWriteControlBA
Datentyp (write only) | Bedeutung
NetID | Net ID des BC9000, C900
Port | 800
ADSSTATE | 5 - RUN / 6 - STOP
DEVSTATE | 0
LEN | 0
SRCADDR | 0
WRITE | positive Flanke startet den Baustein
TMOUT | zum Beispiel: t#1000 ms
Azyklische Datenkommunikation
Bei der azyklischen Datenkommunikation muss man beachten, dass ein TCP/IP-Verbindungsaufbau ca. 20 bis 30 ms benötigt. Nach erfolgreichem Verbindungsaufbau werden die ADS-Daten gesendet oder gelesen. Ein ADS Read von 1000 Byte dauert ca. 50 ms. Werden 10 sec lang keine Daten übertragen, wird die TCP/IP Verbindung vom BC/BK9000, B/C900 getrennt.
Register Port 100
Die ADS-Portnummer ist beim BK/BC9000, B/C900 für die Register-Kommunikation fest vorgegeben und beträgt 100.
Index Group | Index Offset (Wertebereich) |  | Bedeutung
 | Hi-Word | Lo-Word
0 | 0...127 | 0...255 | Register des Buskopplers Hi-Word Tabellennummer des Buskopplers Lo-Word Registernummer der Tabelle
1...64 | 0...3 | 1...64 | Register der Busklemmen Hi-Word Kanalnummer Lo-Word Registernummer der Busklemme
Time-Out des ADS-Bausteins
Beachten Sie beim Lesen der Register, dass der Time-Out des ADS-Bausteins auf eine Zeit größer 1 Sekunde eingestellt wird.
Passwort setzen
Beachten Sie beim Schreiben auf die Register, dass das Passwort gesetzt wird (siehe Dokumentation zur entsprechenden Busklemme).
Zugriffskontrolle und IP - AMS-Net-ID ZuordnungB6
Die Tabelle AMS Net-Id ermöglicht über AMS eine Zugriffskontrolle auf den BC9000, C900. Sobald Einträge in dieser Tabelle vorhanden sind, können nur noch die eingetragenen AMS-Teilnehmer auf den BC9000 zugreifen.
Des Weiteren wird hier explizit eine Zuordnung der AMS Net ID zur IP-Adresse des Knotens gemacht.
Die Tabelle AMS Net-Id kann mit ADS Write Kommandos gefüllt werden:
Es sind maximal 10 Einträge möglich.
Aufbau der Struktur
AMS Net ID | Größe
AMS Net ID | 6 Byte
IP-Adresse | 4 Byte
Reserve | 2 Byte
Reserve | 4 Byte
Reserve | 4 Byte
Zugriff erfolgt über Portnummer: 10.000
Indexgroup: 700
Index Offset (Write) | Bemerkung | Daten
0 | Hinzufügen eines Eintrags | Datenstruktur 20 Byte
1 | Löschen eines Eintrags | -
2 | Löschen aller Einträge | -
10 | Speichern der Tabelle im Flash | -
Index Offset (Read) | Bemerkung | Daten
0 | Anzahl der Einträge | 2 Byte
1..10 | Eintrag n (1...10) | Datenstruktur 20 Byte
Erster Eintrag
Der erste Eintrag muss der Teilnehmer sein der in die Tabelle schreibt, da diese Einstellungen sofort gültig sind. Achten Sie darauf dass die Einstellungen alle Richtig sind. Die Tabelle kann ebenfalls gelöscht werden, wenn nur die Endklemme gesteckt ist und die DIP-Schalter 1 bis 7 auf ON gesetzt sind.
* ab Firmware B6
** ab Firmware B7
)² ab Firmware BA
Siehe Beispiel.


Weitere ADS-Dienste

Feldbussystem [image] ADS-Kommunikation [image] ADS-Dienste [image] Weitere ADS-Dienste
Weitere ADS-Dienste
Datenspeicher im Flash*
(ab Firmware-Version BA)
Prozessdaten-Port 0x1234
Mit diesem Dienst ist es möglich weitere Daten in einem Flash zu sichern. Es steht dem Anwender ein Bereich von 16.000 Byte zur Verfügung.
Index Group | Bedeutung | Index Offset (Wertebereich)
0x4000_FE00 | Flash Daten Speicher | 0...0x3EFF
Daten lesen und schreiben
•
Für den Aufruf werden zwei IP-Sockets benötigt. Achten Sie darauf dass Sie nicht zu viele IP-Sockets geöffnet sind.
•
Ein Flash kann nicht beliebig oft beschrieben werden! Stellen Sie sicher, dass nur dann Daten in das Flash schreiben, wenn es wirklich notwendig ist. Verwenden andernfalls Sie die remanenten Daten.
•
Es können maximal 1500 Byte gelesen und geschrieben werden. Über den Index-Offset können Sie die Byte-Adresse des Speichers vorgeben.
Das Schreiben der Daten benötigt Zeit:
Im normal Betrieb, zum Beispiel für 200 Byte 120 ms für 600 Byte ca.150 ms.
Für das Lesen werden für 200 Byte ca. 50 ms und bei 600 Byte ca. 60 ms gebraucht.
Beispiel Programm in ST ( )


Beispiele

Feldbussystem [image] ADS-Kommunikation [image] ADS-Dienste [image] Beispiele
Beispiele
Weiterführende Informationen
•
AMS-Routing-Tabelle
•
Beispiel-Kommunikation zwischen BC9000
•
Beispielkommunikation vom BC9000 zu einem TwinCAT PC-System
•
Beispiel: Einstellungen des Ethernet-Kopplers über ADS ändern


AMS-Routing-Tabelle

Feldbussystem [image] ADS-Kommunikation [image] ADS-Dienste [image] Beispiele [image] AMS-Routing-Tabelle
AMS-Routing-Tabelle
Mit der AMS-Routing-Tabelle kann man zwei Funktionen nutzen:
1.
Sollte die AMS Net ID nicht der TCP/IP-Adresse entsprechen, kann man die Verknüpfung zwischen den beiden ungleichen Nummern hier eintragen.
Die AMS Net ID ist gleich der TCP/IP Adresse wenn die ersten 4 Byte gleich sind und die AMS Net ID mit ".1.1" endet.
2.
Nur die AMS Net IDs, die in der Tabelle hinterlegt sind, können per ADS auf den BC9000 zugreifen.
Achten Sie darauf, dass alle ADS-Teilnehmer mit denen Sie kommunizieren wollen auch in der Tabelle eingetragen sind. Ist kein Eintrag in der Tabelle (Default) sind alle ADS Teilnehmer berechtigt auf den BC9000 zuzugreifen.
Bearbeiten der AMS-Routing-Tabelle mit der Konfigurations-Software KS2000
Ab KS2000-Version 4.3.0.39 kann der Eintrag in die AMS-Routing-Tabelle, per Dialog vorgenommen werden.
Darstellung der AMS-Routing-Tabelle in der Konfigurations-Software KS2000
Per ADS die Routing-Tabelle füllen
Die AMS-Routing-Tabelle kann per ADS in den BC9000 geladen werden. Achten Sie hierbei darauf, dass der erste Eintrag der des Senders ist, da diese Einstellung sofort Gültigkeit hat und ein weiteres beschreiben der AMS-Routing-Tabelle sonst nicht mehr möglich wäre.
Download


Beispiel-Kommunikation zwischen BC9000

Feldbussystem [image] ADS-Kommunikation [image] ADS-Dienste [image] Beispiele [image] Beispiel-Kommunikation zwischen BC9000
Beispiel-Kommunikation zwischen BC9000
ADS-Kommunikation
Mit Hilfe der ADS-Bausteine aus der TcADSBC.lb6 können Sie Daten direkt zu einem anderen BC9000 verschicken. Mit ADSREADEX können Sie Daten von einem anderen BC9000 lesen und mit ADSWRITE schreiben. Es sind maximal 3 BC9000 gleichzeitig ansprechbar. Um mit weiteren BC9000 zu kommunizieren muss mit Hilfe des ADSCLOSE die Verbindung zu mindestens einen der bisher verbundenen BC9000 beendet werden. Achten Sie darauf, dass nur maximal 3 (die 4. Verbindung sollten Sie sich für die Programmierung reservieren) Verbindungen zu einem BC9000 bestehen. Diese Verbindungen können auch von einer anderen Gegenstelle Aufgebaut worden sein.
Beispiel für eine funktionierende ADS-Verbindung
ADS-Verbindung
Beispielprogramm für die Verbindung von BC9000 zu BC9000
Beispielprogramm in ST Master ( )
Beispielprogramm in ST Slave ( )
Quer-Kommunikation besser zwischen BCs als zum BK
Beachten Sie, dass ein BK9000 nur von einem Master aus Schreibzugriffe zulässt und der BK9000 regelmäßig im Abstand von einer Sekunde gepollt werden muss. Es empfiehlt sich daher die Quer-Kommunikation nur zwischen BC9000 und BC9000 zu realisieren.
bc9000 to bc9000pic.gif
Busaufbau für Querkommunikation


Beispielkommunikation vom BC9000 zu einem TwinCAT PC-System

Feldbussystem [image] ADS-Kommunikation [image] ADS-Dienste [image] Beispiele [image] Beispielkommunikation vom BC9000 zu einem TwinCAT PC-System
Beispielkommunikation vom BC9000 zu einem TwinCAT PC-System
In einigen Applikationen ist ein pollender Betrieb (Master-Slave Prinzip) nicht gewünscht. Die ADS-Bausteine des BC9000 ermöglichen Ihnen sowohl eine Querkommunikation (von BC9000 zu BC9000) als auch eine Kommunikation zum überlagerten TwinCAT PC-System. Das heißt, dass die BC9000-Applikation entscheiden kann, wann Daten zum überlagerten System geschickt werden. Wenn zum Beispiel eine Fehler-Information vorliegt, wird diese sofort zum TwinCAT PC übertragen.
bc9000 to pc.gif
Querkommunikation von einem PC zu zwei BC9000
Voraussetzung
TwinCAT 2.9 Build 1025
Die IP Adresse entspricht der AMS Net Id plus ".1.1"
Mit dem Befehl >ipconfig< im DOS-Fenster können Sie die IP-Adresse Ihres PCs herausfinden.
Befehl >ipconfig< im DOS-Fenster
Die AMS Net ID bekommen Sie unter den Eigenschaften/AMS Router angezeigt.
Anzeige der AMS Net ID
Sollte die AMS Net ID ungleich der TCP/IP Adresse sein können Sie in der Routing-Tabelle (Tabelle 2) diese Zuordnung eintragen.
Beispiel für AMS Net Id in Ordnung
AMS Net ID: 172.16.100.10.1.1
TC/IP: 172.16.100.10
Benötigte Bibliothek: AdsBC.lb6
Beispielprogramme für die Verbindung von BC9000 zu einem TwinCAT PC
Beispielprogramm in ST Master ( )
Beispielprogramm in ST Slave ( )


Beispiel: Einstellungen des Ethernet-Kopplers über ADS ändern

Feldbussystem [image] ADS-Kommunikation [image] ADS-Dienste [image] Beispiele [image] Beispiel: Einstellungen des Ethernet-Kopplers über ADS ändern
Beispiel: Einstellungen des Ethernet-Kopplers über ADS ändern
Voraussetzung
Für das Beispiel benötigen Sie einen BC9000. Beachten Sie, dass das Lesen oder Schreiben lokal zwei Sockets benötigt!
Benötigte Bibliothek:
AdsBC.lb6
TcPlcUlititiesBC.lb6
PlcSystemBC.lb6
PlcHelperBC.lb6
TcUtilitiesBC9000.lb6
Beschreibung
Der Baustein ermöglicht das Einstellen verschiedener Parameter (siehe Beispiel). Eine genauere Beschreibung des Bausteins finden Sie unter dem Kapitel Bibliothek.
Beispiel:
Download Beispiel Programm in ST ( )


ModbusTCP

Feldbussystem [image] ModbusTCP
ModbusTCP
Weiterführende Informationen
•
ModbusTCP-Protokoll
•
Modbus TCP-Interface
•
Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
•
ModbusTCP-Funktionen
•
Beispiele zu ModbusTCP


ModbusTCP-Protokoll

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Protokoll
ModbusTCP-Protokoll
Das Ethernet-Protokoll wird über die MAC-ID adressiert. Der Anwender braucht sich meist um diese Adresse nicht zu kümmern. Die IP-Nummer ist 4 Byte groß und muss vom Anwender auf dem Buskoppler und in der Anwendung parametriert werden. Der TCP-Port ist bei ModbusTCP auf 502 festgelegt. Die UNIT ist bei ModbusTCP frei wählbar und braucht vom Anwender nicht konfiguriert werden.
ModbusTCP-Protokoll
TCP-Port-Nummer
Die TCP-Port-Nummer von ModbusTCP wurde auf den Wert 502 standardisiert.
Modbus-Unit
Die Unit wird vom Slave zurückgegeben.
ModbusTCP-Protokoll
Byte | Name | Beschreibung
0 | Transaction identifier | wird vom Slave zurückgesendet
1 | Transaction identifier | wird vom Slave zurückgesendet
2 | Protocol identifier | immer 0
3 | Protocol identifier | immer 0
4 | Length field | 0 (wenn die Nachricht kleiner 256 Byte ist)
5 | Length field | Anzahl der folgenden Bytes
6 | UNIT identtifier | wird vom Slave zurückgegeben
7 | Modbus | es folgt das Modbus-Protokoll beginnend mit der Funktion


Modbus TCP-Interface

Feldbussystem [image] ModbusTCP [image] Modbus TCP-Interface
Modbus TCP-Interface
Adresse |  | Beschreibung
0x0000 0x00FF |  | Prozessdaten-Inferface Eingänge
0x0800 0x08FF |  | Prozessdaten-Inferface Ausgänge
0x1000 0x1006 | Read only | Buskopplerkennung
0x100A |  | 2 Byte SPS-Interface
0x100B |  | Busklemmendiagnose
0x100C |  | Buskoppler Status
0x1010 |  | Prozessabbildlänge in Bit, analoge Ausgänge (ohne SPS Variablen)
0x1011 |  | Prozessabbildlänge in Bit, analoge Eingänge (ohne SPS Variablen)
0x1012 |  | Prozessabbildlänge in Bit, digitale Ausgänge
0x1013 |  | Prozessabbildlänge in Bit, digitale Eingänge
0x1020 |  | Watchdog, aktuelle Zeit in [ms]
0x110A | Read/Write | 2 Byte SPS Interface
0x110B |  | Busklemmendiagnose
0x1120 |  | Watchdog vordefinierte Zeit in [ms] (Default: 1000)
0x1121 |  | Watchdog Reset Register
0x1122 |  | Art des Watchdogs | 1 | Telegramm Watchdog (Default)
 |  |  | 0 | Schreibtelegramm Watchdog
0x1123** |  | ModbusTCP Mode** | 1 | Fast Modbus
 |  |  | 0 | Normal Modbus (Default)
0x4000* 0x47FF |  | Merkerbereich (%MB..)*
* alle Busklemmen Controller BC9xx0 und BX9000
** für BC9x00 ab Firmware B7 und BK9000 ab Firmware B5 und alle nicht aufgeführten BK9xxx und BC/BX9xxx
Watchdog
Der Watchdog ist im Auslieferungszustand aktiviert. Nach dem ersten Schreibtelegramm wird der Watchdog scharf geschaltet und bei jedem empfangenden Telegramm dieses Teilnehmers getriggert. Andere Teilnehmer haben auf den Watchdog keinen Einfluss. Eine zweite Möglichkeit, die eine schärfere Bedingung des Watchdogs darstellt, ist, dass der Watchdog nur nach jedem Schreibtelegramm getriggert wird. Dafür Schreiben Sie in das Register 0x1122 eine Null (Default "1").
Der Watchdog kann deaktiviert werden in dem im Offset 0x1120 eine Null geschrieben wird. Das Watchdog Register darf nur dann beschrieben werden, wenn der Watchdog noch nicht aktiv ist. Die Daten in diesem Register bleiben gespeichert.
Watchdog-Register
Sollte der Watchdog auf Ihren Slave abgelaufen sein können sie diesen durch ein zweimaliges beschreiben des Registers 0x1121 zurücksetzen. Dazu muss folgendes in das Register geschrieben werden: 0xBECF 0xAFFE. Dies kann mit der Funktion 6 oder der Funktion 16 geschehen.
Statusregister des Buskopplers
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | FB | - | - | - | - | - | - | - | - | - | - | - | - | - | CNF | KB
Legende
Bit | Name | Wert | Beschreibung
15 | FB | 1bin | Feldbusfehler, Watchdog abgelaufen
14...2 | - | - | reserviert
1 | CNF | 1bin | Buskoppler Konfigurationsfehler
0 | KB | 1bin | Busklemmenfehler
ModbusTCP Mode
Der Fast Modbus Mode sollte nur in kleinen lokalen Netzwerken eingesetzt werden. In der Default Einstellung ist der Fast ModbusTCP nicht aktiviert. Werden Probleme mit dieser Kommunikationsart festgestellt, ist der Buskoppler auf die "normale" ModbusTCP Kommunikation umzustellen. Per Modbus Interface Offset 0x1123 ist dieser Mode einzustellen. Nach der Änderung ist ein Reset (zum Beispiel mit der ModbusTCP Funktion 8) des Buskopplers notwendig. Im Fast Modbus Mode ist es nicht gestattet, mehr als ein Modbus Dienst in einem Ethernet Frame zu versenden.
2 Byte SPS-Interface
Mit dem 2 Byte SPS-Interface können Register der komplexen Klemmen sowie Register des Busklemmen-Controllers gelesen bzw. beschrieben werden. Die Register der komplexen Klemmen sind in der Dokumentation zur jeweiligen Klemme beschreiben. Über die Register des Buskopplers können z. B. K-Busdiagnosedaten, der Klemmenaufbau oder Zykluszeiten gelesen sowie die programmierte Konfiguration beschrieben werden. Weiterhin kann darüber auch ein manueller K-Bus-Reset durchgeführt werden. Das 2 Byte SPS-Interface benötigt je zwei Bytes in den Ein- und Ausgangsdaten, über die ein spezielles Protokoll abgewickelt wird. Eine Beschreibung des 2 Byte SPS-Interface, der verfügbaren Register im Buskopplers sowie Funktionsbausteine für verschiedene SPS-Systeme, die das 2 Byte SPS-Interface unterstützen, kann auf Anfrage geliefert werden.
2 Byte Diagnose-Interface
Die Fehlermeldungen der Klemmen können mit dem 2 Byte Diagnose-Interface gesendet werden. Dazu ist aber die K-Busdiagnose zu aktivieren. Das 2 Byte Diagnose-Interface belegt je zwei Bytes in den Ein- und Ausgangsdaten, über die ein spezielles Protokoll durchgeführt wird. Eine Beschreibung des 2 Byte Diagnose-Interfaces kann auf Anfrage geliefert werden.


Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)

Feldbussystem [image] ModbusTCP [image] Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
Wenn der Anwender dem Slave eine Anforderung oder Mitteilung sendet, die der Koppler nicht versteht, antwortet der Slave mit einer Fehlermitteilung. Diese Antwort enthält die Funktion und den Fehler-Code. Der Funktionsrückgabewert wird mit 0x80 addiert.
Code | Name | Bedeutung
1 | ILLEGAL FUNKTION | Nicht implementierte Modbus-Funktion
2 | ILLEGAL DATA ADDRESS | Ungültige Adresse oder Länge
3 | ILLEGAL DATA VALUE | Ungültige Parameter - Diagnose-Funktionen - falsches Register
4 | SLAVE DEVICE ERROR | Watchdog- oder K-Bus-Fehler EK9000: E-Bus Fehler
6 | SLAVE DEVICE BUSY | Es wird schon von einem anderen IP-Teilnehmer Ausgangs-Daten empfangen


ModbusTCP-Funktionen

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen
ModbusTCP-Funktionen
Weiterführende Informationen
•
ModbusTCP-Funktionen
•
Read coil status (Funktion 1)
•
Read input status (Funktion 2)
•
Read holding register (Funktion 3)
•
Read input register (Funktion 4)
•
Force single coil (Funktion 5)
•
Preset single register (Funktion 6)
•
Diagnose (Funktion 8)
•
Force multiple coils (Funktion 15)
•
Preset multiple register (Funktion 16)
•
Read / write registers (Funktion 23)


ModbusTCP-Funktionen

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] ModbusTCP-Funktionen
ModbusTCP-Funktionen
Die Funktionen entscheiden beim Modbus-Protokoll, ob Daten gelesen oder geschrieben werden und um welche Art von Daten es sich dabei handelt.
Funktion | Code | Beschreibung
Read coil status | 1 | Lesen digitaler Ausgänge
Read input status | 2 | Lesen digitaler Eingänge
Read holding register | 3 | Lesen analoger Aus- und Eingänge / GPR
Read input register | 4 | Lesen der Eingänge / GPR
Force single coil | 5 | Schreiben eines digitalen Ausgangs
Preset single register | 6 | Schreiben eines Ausgangs / GPR
Diagnose | 8 | Diagnose
Force multiple coils | 15 | Schreiben mehrere digitaler Ausgänge
Preset multiple register | 16 | Schreiben mehrerer Ausgänge / GPRs
Read / write registers | 23 | Schreiben und lesen mehrerer Prozessdaten Ausgänge / GPRs
GPR (General Preset Register) - Registerstruktur Modbus Interface (siehe Anhang)


Read coil status (Funktion 1)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Read coil status (Funktion 1)
Read coil status (Funktion 1)
Mit der Funktion Read coil status können die gesetzten, digitalen Ausgänge gelesen werden.
In diesem Beispiel werden die ersten 10 digitalen Ausgänge gelesen. Die Start-Adresse ist Null. Im Feld Start-Adresse können Sie einen Offset eintragen.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 1
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 10
Der Feldbus-Koppler antwortet mit dem Byte Count 2, d.h. 2 Byte Daten kommen zurück. Die Anfrage war 10 Bits, die jetzt auf 2 Byte aufgeteilt werden. Im Ausgangsprozessabbild ist das dritte Bit gesetzt und der Feldbus-Koppler gibt im ersten Datenbyte eine den Wert 4 wieder.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 1
Byte Count | 2
Daten-Bit 0...7 | 4
Daten-Bit 8...18 | 0


Read input status (Funktion 2)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Read input status (Funktion 2)
Read input status (Funktion 2)
Mit der Funktion Read input status können die digitalen Eingangsdaten gelesen werden. In diesem Beispiel werden die ersten 10 digitale Eingänge gelesen. Die Start-Adresse ist Null. Im Feld Start-Adresse können Sie einen Offset eintragen.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 2
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 10
Der Feldbus-Koppler antwortet mit dem Byte Count 2, d.h. es kommen zwei Byte Daten zurück. Die Anfrage war 10 Bits, die jetzt auf zwei Byte aufgeteilt werden. Im Ausgangsprozessabbild ist das dritte Bit gesetzt und der Feldbus-Koppler gibt im ersten Datenbyte eine den Wert 4 wieder.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 2
Byte Count | 2
Daten-Bits 0..7 | 1
Daten-Bits 8..18 | 0


Read holding register (Funktion 3)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Read holding register (Funktion 3)
Read holding register (Funktion 3)
Mit der Funktion Read holding register können die Ein- und Ausgangsworte und die Register gelesen werden. Eingänge ab dem Offset 0 - 0xFF und Ausgänge ab den Offset 0x800 - 0x8FF und bei den Steuerungen (BC, BX) der Merker Bereich ab den Offset 0x4000.
In diesem Beispiel werden die ersten zwei analogen Ausgänge (oder 2 Ausgangsworte) gelesen. Die analogen Ausgänge (oder Ausgangsworte) beginnen beim Offset 0x800. Die Länge bezeichnet die Anzahl, der zu lesenden Kanäle (oder der zu lesenden Worte).
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 3
Start-Adresse high | 8
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 2
Der Feldbus-Koppler antwortet mit dem Byte Count 4, d.h. es kommen 4 Byte Daten zurück. Die Anfrage waren zwei Analogkanäle, die auf zwei Worte aufgeteilt sind. Im analogen Ausgangsprozessabbild hat der erste Kanal einen Wert von 0x3FFF und der zweite Kanal einen Wert von 0x0.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 3
Byte Count | 4
Daten 1 High-Byte | 63
Daten 1 Low-Byte | 255
Daten 2 High-Byte | 0
Daten 2 Low-Byte | 0


Read input register (Funktion 4)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Read input register (Funktion 4)
Read input register (Funktion 4)
Die Funktion Read input register liest wort-orientiert die Eingänge aus.
In diesem Beispiel werden die ersten zwei analogen Eingänge (oder die erste 2 Eingangsworte) gelesen. Die analogen Eingänge (oder Eingangsworte) beginnen bei einem Offset von 0x0000. Die Länge bezeichnet die Anzahl der zu lesenden Worte. Eine KL3002 z. B. hat zwei Worte Eingangsdaten, daher ist die einzugebende Länge bei Anzahl low zwei.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 4
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 2
Der Feldbus-Koppler antwortet mit dem Byte Count 4, d.h. es kommen vier Byte Daten zurück. Die Anfrage waren zwei analog Kanäle, die jetzt auf zwei Worte aufgeteilt werden. Im analogen Eingangsprozessabbild hat der erste Kanal einen Wert von 0x0038 und der zweite Kanal einen Wert von 0x3F1B.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 4
Byte Count | 4
Daten 1 High-Byte | 0
Daten 1 Low-Byte | 56
Daten 2 High-Byte | 63
Daten 2 Low-Byte | 11


Force single coil (Funktion 5)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Force single coil (Funktion 5)
Force single coil (Funktion 5)
Mir der Funktion Force single coil kann ein digitaler Ausgang beschrieben werden. In diesem Beispiel wird der dritte digitale Ausgang beschrieben. Die digitalen Ausgänge beginnen bei Adresse 0x0000. Im Daten high steht der digitale Wert. Um den Ausgang einzuschalten muss im Daten high der Wert 0xFF stehen und um den Ausgang wieder auszuschalten der Wert 0x00. Im Daten low muss der Wert 0x00 stehen.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 5
Start-Adresse high | 0
Start-Adresse low | 2
Daten high | 255
Daten low | 0
Der Koppler antwortet mit dem gleichen Telegramm.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 5
Start-Adresse high | 0
Start-Adresse low | 2
Daten high | 255
Daten low | 0


Preset single register (Funktion 6)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Preset single register (Funktion 6)
Preset single register (Funktion 6)
Mit der Funktion Preset single register kann auf das Ausgangs- oder Merkerprozessabbild (nur bei den Steuerungen) und das Modbus-TCP-Interface zugegriffen werden.
Bei der Funktion 6 wird das erste Ausgangswort beschrieben. Die Ausgänge beginnen bei einem Offset von 0x0800. Auch hier beschreibt der Offset immer ein Wort. Das heißt, dass der Offset 0x0803, das 4. Wort auf dem Ausgangsprozessabbild ist.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 6
Start-Adresse high | 8
Start-Adresse low | 0
Daten high | 63
Daten low | 255
Der Feldbus-Koppler antwortet mit dem gleichen Telegramm und der Bestätigung der empfangenen Werte.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 6
Start-Adresse high | 8
Start-Adresse low | 0
Daten high | 63
Daten low | 255


Diagnose (Funktion 8)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Diagnose (Funktion 8)
Diagnose (Funktion 8)
Die Funktion Diagnose stellt eine Reihe von Tests, für die Überprüfung des Übertragungssystems zwischen dem Master und dem Slave oder für die Überprüfung der verschiedenen internen Fehlerzustände innerhalb des Slaves zur Verfügung. Ein Broadcast-Telegramm wird nicht unterstützt.
Die Funktion benutzt in der Anfrage zwei Byte, um mit einem Unterfunktions-Code die Art des durchzuführenden Tests zu definieren. Der Slave gibt in der Antwort den Funktions-Code und den Unterfunktions-Code zurück.
Die Diagnose-Anfragen benutzen ein Datenfeld von zwei Byte, um Diagnosedaten oder Steuerinformationen zum Slave zu schicken.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 8
Unterfunktion high | 0
Unterfunktion low | 0
Data high | 2
Data low | 3
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 8
Unterfunktion high | 0
Unterfunktion low | 0
Data high | 2
Data low | 3
Spiegeln einer Anforderung (Unterfunktion 0)
Mit der Unterfunktion 0 werden die Daten, die der Master zum Slave schickt, wieder zurückgeschickt.
Koppler Reset (Unterfunktion 1)
Der Koppler wird mit der Unterfunktion 1 neu initialisiert, Fehlerzähler werden zurückgesetzt und der Controller führt einen Selbsttest durch. In der Zeit, in der der Controller zurückgesetzt wird, werden keine Telegramme empfangen oder gesendet. Der IP-Socket wird geschlossen.
Letzte Antwort mit der Unterfunktion 1
Bevor der Controller neu startet schickt er noch eine Antwort mit der Unterfunktion 1 dann wird der IP-Socket geschlossen.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0001 | 0x0000 | 0x0000
Löschen aller Zählerinhalte (Unterfunktion 10)
Beim Aufruf dieser Unterfunktion löscht der Controller alle Fehler Zähler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000A | 0x0000 | Echo Query Daten
Buskommunikation Antwort Zähler (Unterfunktion 11)
Gibt die Anzahl der Kommunikationsantworten an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000B | 0x0000 | Wert des Zählers
Fehlerantwort Zähler (Unterfunktion 13)
Dieser Zähler gibt die Anzahl der Fehlerantworttelegramme, die der Koppler gesendet hat, an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000D | 0x0000 | Wert des Zählers
Die folgenden Funktionen beinhalten die Zählerstände für verschiedene Units. D.h. die Modbus-Telegramme können mit Units unterschieden werden, wenn es sich zum Beispiel um einen Zugriff auf den Koppler von verschiedenen Mastern aus handelt.
Antworten des Slaves (Unterfunktion 14)
Gibt die Anzahl der gesendeten Antworten des Slaves an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000E | 0x0000 | Wert des Zählers
Anzahl der nicht geantworteten Telegramme (Unterfunktion 15)
Gibt die Anzahl der nicht gesendeten Antworten des Slaves an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000F | 0x0000 | Wert des Zählers
Anzahl der Fehlerantworten (Unterfunktion 16)
Gibt die Anzahl der gesendeten Fehlerantworten des Slaves an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0010 | 0x0000 | Wert des Zählers


Force multiple coils (Funktion 15)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Force multiple coils (Funktion 15)
Force multiple coils (Funktion 15)
Bei der Funktion Force multiple coils können gleichzeitig mehrere digitale Ausgänge gesetzt oder zurückgesetzt werden.
In diesem Beispiel werden die ersten 20 digitalen Ausgänge beschrieben. Die digitalen Ausgänge beginnen bei einem Offset von 0x0000. Hier beschreibt der Offset immer ein Bit. Der Offset 0x0003 schreibt ab dem vierten Bit auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Bits an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 20 Bits belegen 3 Byte Count (auf Byte-Grenzen aufrunden).
Die Daten-Bytes enthalten die Werte für die einzelnen Bits. In diesem Beispiel werden die Bit 0 bis 15 auf TRUE gesetzt und Bit 16 bis 23 auf FALSE.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 15
Start-Adresse high | 0
Start-Adresse low | 0
Länge high | 0
Länge low | 20
Byte Count | 3
Daten 1 Bit 0..7 | 255
Daten 2 Bit 8..15 | 255
Daten 3 Bit 16..23 | 0
Antwort (Response)
Der Buskoppler antwortet mit dem gleichen Telegramm.
Byte Name | Beispiel
Funktions-Code | 15
Start-Adresse high | 0
Start-Adresse low | 0
Länge high | 0
Länge low | 20


Preset multiple register (Funktion 16)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Preset multiple register (Funktion 16)
Preset multiple register (Funktion 16)
Mit der Funktion Preset multiple register können mehrere Ausgänge beschrieben werden. In diesem Beispiel werden die ersten zwei analogen Ausgangsworte beschrieben. Die Ausgänge beginnen bei einem Offset von 0x0800. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem vierten Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 4 Worte - entsprechen 8 Byte Count
Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x7FFF und das zweite Wort mit dem Wert 0x3FFF.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 16
Start-Adresse high | 8
Start-Adresse low | 0
Länge high | 0
Länge low | 2
Byte Count | 4
Daten 1 Byte 1 | 127
Daten 1 Byte 2 | 255
Daten 2 Byte 1 | 63
Daten 2 Byte 2 | 255
Antwort (Response)
Der Koppler antwortet mit der Start-Adresse und der Länge der gesendeten Worte.
Byte Name | Beispiel
Funktions-Code | 16
Start-Adresse high | 8
Start-Adresse low | 0
Länge high | 0
Länge low | 2


Read / write registers (Funktion 23)

Feldbussystem [image] ModbusTCP [image] ModbusTCP-Funktionen [image] Read / write registers (Funktion 23)
Read / write registers (Funktion 23)
Mit der Funktion Read / write registers können mehrere analoge Ausgänge beschrieben und in einem Telegramm mehrere analoge Eingänge gelesen werden. In diesem Beispiel werden die ersten zwei analogen Ausgangsworte beschrieben und die ersten zwei analogen Eingänge gelesen. Die analogen Ausgänge beginnen beim Offset 0x0800 und die Eingänge ab dem Offset 0x0000. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem 4. Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen. Beispiel: 4 Worte - entsprechen 8 Byte Count
Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x3FFF und das zweite Wort mit dem Wert 0x7FFF.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 23
Lesen Start-Adresse high | 0
Lesen Start-Adresse low | 0
Lesen Länge high | 0
Lesen Länge low | 2
Schreiben Start-Adresse high | 8
Schreiben Start-Adresse low | 0
Schreiben Länge high | 0
Schreiben Länge low | 2
Byte Count | 4
Daten 1 high | 63
Daten 1 low | 255
Daten 2 high | 127
Daten 2 low | 255
Antwort (Response)
Der Koppler antwortet mit der Start-Adresse und der Länge der übertragenen Bytes im Byte Count. Es folgen die Dateninformationen. In diesem Beispiel steht im ersten Wort eine 0x0038 und im zweiten Wort eine 0x3F0B.
Byte Name | Beispiel
Funktions-Code | 23
Byte Count | 4
Daten 1 high | 0
Daten 1 low | 56
Daten 2 high | 63
Daten 2 low | 11


Beispiele zu ModbusTCP

Feldbussystem [image] ModbusTCP [image] Beispiele zu ModbusTCP
Beispiele zu ModbusTCP
In dieser Hilfe sind Beispiele zu ModbusTCP enthalten.
Einfaches Beispiel: ModbusTCP über VB6.0
Beispiel: ModbusTCP über VB6.0, Set und Reset des Watchdogs:


Beschreibung der Parameter

Feldbussystem [image] Beschreibung der Parameter
Beschreibung der Parameter
Weiterführende Informationen
•
Eigenschaften des Busklemmen-Controllers


Eigenschaften des Busklemmen-Controllers

Feldbussystem [image] Beschreibung der Parameter [image] Eigenschaften des Busklemmen-Controllers
Eigenschaften des Busklemmen-Controllers
Weiterführende Informationen
•
Registereinstellungen Tabelle 0
•
Registereinstellungen Tabelle 1
•
Registereinstellungen Tabelle 100


Registereinstellungen Tabelle 0

Feldbussystem [image] Beschreibung der Parameter [image] Eigenschaften des Busklemmen-Controllers [image] Registereinstellungen Tabelle 0
Registereinstellungen Tabelle 0
Mit der Konfigurationssoftware KS2000 können Sie die Registerwerte per Dialog einstellen oder auch direkt in die Register schreiben.
Register | Beschreibung | Default | Busklemmen Controller
19 | Byte-Offset digitale Ausgänge %Q.. | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
20 | Byte-Offset digitale Eingänge %I.. | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000


Registereinstellungen Tabelle 1

Feldbussystem [image] Beschreibung der Parameter [image] Eigenschaften des Busklemmen-Controllers [image] Registereinstellungen Tabelle 1
Registereinstellungen Tabelle 1
Mit der Konfigurationssoftware KS2000 können Sie die Registerwerte per Dialog einstellen oder auch direkt in die Register schreiben.
Register | Beschreibung |  | Default | Busklemmen Controller
0 | Byte-Offset SPS-Variablen %I... |  | 128 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
1 | Länge der SPS-Variablen %I... |  | 16 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
2 | Byte-Offset SPS-Variablen %Q... |  | 128 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
3 | Länge der SPS-Variablen %Q... |  | 16 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
4…11 | Busklemmen Zuordnung |  |  | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
4.0…4.1 | Zuordnung der 1. Busklemme |  | 11bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
 | 00bin | Feldbus Prozessabbild komplex
 | 10bin | Feldbus Prozessabbild kompakt
 | 11bin | Lokales Prozessabbild
4.2…4.3 | Zuordnung der 2. Busklemme |  | 00bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
m.n…1..m.n | Zuordnung der n. Busklemme |  | 00bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
12 | SPS-Zykluszeit |  | 5 ms (20 ms bei BC9000/BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
13 | Background Time |  | 2 ms (10 ms bei BC9000/BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
14.0 | Remanente Daten aktivieren |  | 1bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
14.2…14.3 | Ausführung des K-Bus-Update |  | 00bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
 | 00bin | vor und nach der SPS
 | 01bin | vor der SPS
 | 10bin | nach der SPS
14.6 | Busklemmen Überprüfung einschalten |  | 1bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
15 | Größe des NOVRAMs (Remanente Daten) |  | 64 [Byte] | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
17.0…17.7 | Klemmenbus-Autorefresh: Zyklus in [ms] |  | 0x0000 Disable (0x005F beim BC9000) (0x035F beim BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
17.8…17.15 | Klemmenbus-Autorefresh: max. Retries
18 | Größe des NOVRAMs Persistente Daten R18<R15 |  | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
27 | Byte-Offset KL6xx1 Busklemmen Emulation %Q... |  | 500 | BC8x00
28 | Byte-Offset KL6xx1 Busklemmen Emulation %I... |  | 500 | BC8x00
32 | Baud-Rate |  | 2 | BC8x00
 | 0 | 38400 Bd
 | 1 | 19200 Bd
 | 2 | 9600 Bd
 | 3 | 57600 Bd
 | 4 | 1200 Bd
 | 5 | 2400 Bd
 | 6 | 4800 Bd
33 | Modus |  | 2 | BC8x00
 | 0 | 7 Daten-Bits Even Parity
 | 1 | 7 Daten-Bits Odd Parity
 | 2 | 8 Daten-Bits No Parity
 | 3 | 8 Daten-Bits Even Parity
 | 4 | 8 Daten-Bits Odd Parity
34 | Anzahl der Stoppbits |  | 0 | BC8x00
 | 0 | ein Stoppbit
 | 1 | zwei Stoppbits


Registereinstellungen Tabelle 100

Feldbussystem [image] Beschreibung der Parameter [image] Eigenschaften des Busklemmen-Controllers [image] Registereinstellungen Tabelle 100
Registereinstellungen Tabelle 100
Die Register können mit der Konfigurations-Software KS2000 per Dialog eingestellt oder direkt in die Register geschrieben werden.
Register | Beschreibung |  | Default | Busklemmen-Controller
0…1 | IP-Adresse |  | 0xAC, 0x10, 0x11, 0x00 | BC9000, BC9100, BK9000, BK9050, BK9100
2…3 | IP-Maske |  | 0xFF, 0xFF, 0x00, 0x00 | BC9000, BC9100, BK9000, BK9050, BK9100
4…13 | Device Name |  | BC9000 | BC9000, BC9100, BK9000, BK9050, BK9100
14 | Watchdog AMS/ADS |  | 1000 ms | BC9000, BC9100, BK9000, BK9050, BK9100
15.0 | 0bin | enable ModbusTCP | 0bin | BC9000, BC9100, BK9000, BK9050, BK9100
 | 1bin | disable ModbusTCP
15.1 | 0bin | enable AMS/ADS | 0bin
 | 1bin | disable AMS/ADS
16.8 | 0bin | Ethernet Modus halbduplex | 1bin | BC9000, BC9100, BK9000, BK9050, BK9100
 | 1bin | Ethernet Modus vollduplex
16.12 | 0bin | Autobaud aus | 1bin
 | 1bin | Autobaud ein
16.13 | 0bin | 10 MBaud | 1bin
 | 1bin | 100 MBaud
17…18 | Default Gateway |  | 0x00, 0x00, 0x00, 0x00 | BC9000, BC9100, BK9000, BK9050, BK9100
24 | Watchdog ModbusTCP |  | 1000 ms | BC9000, BC9100, BK9000, BK9050, BK9100
25.0 | Eintrag eines Feldbusfehler (Verbindung zum Switch unterbrochen) in die Diagnose des Merkerbereichs |  | 0bin | BC9000, BC9100
 | 0 | Fehler wird nicht eingetragen
 | 1 | Fehler wird eingetragen
26 | ModbusTCP Port Nr |  | 502 | BC9000, BC9100, BK9000, BK9050, BK9100
27 | Lebensdauer ADS-Verbindung |  | 10 s | BC9000, BC9100, BK9000, BK9050, BK9100
28 | Lebensdauer Modbus-Verbindung |  | 10 s | BC9000, BC9100, BK9000, BK9050, BK9100
29.0 | ModbusTCP Mode |  | 0bin | BC9000, BC9100, BK9000, BK9050, BK9100
 | 1bin | Fast ModbusTCP


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose-LEDs
•
Allgemeine Fehler
•
ADS-Diagnose
•
ModbusTCP-Diagnose


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
BK9000, BK9100, BC9000, BC9100
Nach dem Einschalten überprüft der Buskoppler sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen roten der LED E/A ERR signalisiert. Das Blinken der LED I/O ERR zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehler-Code ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.
Zur Statusanzeige besitzt der Buskoppler zwei Gruppen von LEDs. Die obere Gruppe mit vier LEDs zeigt den Zustand des jeweiligen Feldbusses an. Die Bedeutung der Feldbusstatus-LEDs wird in den entsprechenden Kapiteln dieses Handbuches erläutert. Sie entspricht den feldbusüblichen Anzeigen.
Auf der rechten oberen Seite des Buskopplers befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 V Versorgung des Buskopplers an. Die rechte LED signalisiert die Versorgung der Powerkontakte.
BC9000 - LEDs
BC9100 - LEDs
LEDs zur Diagnose der Spannungsversorgung
LED | Bedeutung
Linke LED aus | Buskoppler hat keine Spannung
Rechte LED aus | Keine Spannungsversorgung 24 VDC an den Powerkontakten angeschlossen
LEDs zur Feldbus-Diagnose
LED | Ein | Aus
LINK (nur BK9000/BC9000) | Physikalische Verbindung vorhanden | Keine physikalische Verbindung vorhanden
ACT (nur BK9000/BC9000) | Blinkt: Busverkehr vorhanden | kein Busverkehr vorhanden (bus idle)
COM (nur BK9100/BC9100) | Blinkt: Daten an den Controller empfangen | keine Daten werden empfangen
ERROR | LED blinkt langsam, wenn DHCP oder BootP aktiviert und der Buskoppler noch keine IP-Adresse bekommen hat LED blink schnell (5-mal, nur beim Einschalten) Der Buskoppler wurde mit ARP adressiert. Die Einstellungen auf dem DIP-Schalter sind nicht gültig. LED dauerhaft an (nur im RT-Ethernet Modus) Hinweis: Taskzeit zu schnell eingestellt | Kein Fehler
PLC (nur BC9000/BC9100) | PLC Programm ist im RUN-Modus LED blinkt, während das Bootprojekt gespeichert wird. | PLC Programm ist im Stop-Modus
WDG (nur BK9000) | Watchdog wird getriggert: - Kein Fehler | Watchdog abgelaufen oder nicht getriggert: - Kommunikation starten - Watchdog Fehler zurücksetzen
LEDs zur K-Bus-Diagnose
Fehler-Code
Fehlerargument
Beschreibung
Abhilfe
Ständiges, konstantes Blinken
EMV Probleme
▪
Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
▪
EMV-Maßnahmen ergreifen
▪
Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
1 Impuls
0
EEPROM-Prüfsummenfehler
Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
1
Überlauf im Code Buffer
Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
2
Unbekannter Datentyp
Software Update des Buskopplers notwendig
2 Impulse
0
Programmierte Konfiguration, falscher Tabelleneintrag
Programmierte Konfiguration auf Richtigkeit überprüfen
n (n > 0)
Tabellenvergleich (Busklemme n)
Falscher Tabelleneintrag
3 Impulse
0
K-Bus-Kommandofehler
▪
Keine Busklemme gesteckt
▪
Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse
0
K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler
Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n
Bruchstelle hinter Busklemme n
Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse
n
K-Bus-Fehler bei Register-Kommunikation mit Busklemme n
n-te Busklemme tauschen
6 Impulse
0
Fehler bei der Initialisierung
Buskoppler tauschen
1
Interner Datenfehler
Hardware-Reset des Buskopplers (aus - und wieder einschalten)
2
DIP-Schalter nach einem Software-Reset verändert
ab Firmware BC9000 BB und BC9100 B0:
ab Firmware BK9000 BA und BK9100 B0:
IP-Adresse bereits im Netzwerk vorhanden
Hardware-Reset des Buskopplers (aus - und wieder einschalten)

Eine andere IP-Adresse vergeben
4
DIP-Schalter für BootP falsch
1-8 auf on oder off stellen, siehe BootP
8
Interner Datenfehler
Hardware-Reset des Buskopplers (aus- und wieder einschalten)
16
Fehler beim IP-Socket
Hardware-Reset des Buskopplers (aus- und wieder einschalten)
7 Impulse (nur BC9000/BC9100)
0
Hinweis: Zykluszeit wurde überschritten
(siehe Tab. 1 Register 17)
Warning: Die eingestellte Zykluszeit wurde überschritten. Dieser Hinweis (blinken der LEDs) kann nur durch erneutes booten des BC gelöscht werden.
Abhilfe: Zykluszeit erhöhen
9 Impulse (nur BC9000/BC9100)
0
Checksummenfehler im Programm-Flash
Programm erneut zum BC übertragen
1
Falsche oder fehlerhaft Lib implementiert
Entfernen Sie die fehlerhaft Lib
10 Impulse (nur BC9000/BC9100)
n
Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existiert überein
Die n-te Busklemme überprüfen. Sollte eine n-te Busklemme gewollt eingefügt worden sein, muss das Bootprojekt gelöscht werden.
14 Impulse
n
n-te Busklemme hat das falsche Format
Buskoppler erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse
n
Anzahl der Busklemmen stimmt nicht mehr
Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
16 Impulse
n
Länge der K-Bus-Daten stimmt nicht mehr
Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
LEDs zur Swich-Diagnose (nur BK9100/BC9100)
LED | Ein | Blinkt | Aus
LINK/ACT | Physikalische Verbindung vorhanden | Kommunikation vorhanden | Keine physikalische Verbindung vorhanden
10/100Mbit/s | 100 Mbit/s | - | 10 Mbit/s


Allgemeine Fehler

Fehlerbehandlung und Diagose [image] Allgemeine Fehler
Allgemeine Fehler
Kein Datenaustausch nach Tausch eines Buskopplers
Sie haben den Ethernet Buskoppler getauscht und die gleiche TCP/IP-Nummer eingestellt, erhalten danach aber keinen Datenaustausch mehr.
Jedes Ethernet-Gerät hat seine eigene und eindeutige MAC-ID. Diese Nummer wird bei der Verbindung zum Ethernet-Knoten gespeichert und in einer Tabelle hinterlegt. Die Tabelle enthält die Zuordnung zwischen der MAC-ID und der TCP/IP-Nummer. Sie müssen diesen Speicher löschen und das können Sie tun indem Sie im DOS-Fenster den Befehl >arp -d< und die TCP/IP-Nummer des Buskopplers eingeben.
Beispiel: >arp -d 172.16.17.203<
Bei aktiviertem DHCP- oder BootP-Protokoll muss auf dem DHCP- oder BootP-Server nach dem Kopplerwechsel die MAC-ID des neuen Buskopplers eingestellt werden.
Kommunikationsfehler im Online-Zustand *
Im Online-Zustand (eingeloggt über Ethernet/AMS) kommt es nach einiger Zeit immer zu der Meldung Kommunikationsfehler, es wird ausgeloggt.
Der Datenverkehr über die Ethernet Schnittstelle stockt.
Abhilfe:
▪
Verringern Sie die Daten-Kommunikation.
▪
Halten Sie den zyklischen Datenverkehr an, oder vergrößern Sie die Task-Zeit.
▪
Verringern Sie die Anzahl der offenen Fenster in der Online-Darstellung.
▪
Loggen Sie sich über die serielle Schnittstelle ein.
* nur BC9000, IL230x-C900


ADS-Diagnose

Fehlerbehandlung und Diagose [image] ADS-Diagnose
ADS-Diagnose
Statuseingänge
Im System-Manager hat man die Möglichkeit die Kommunikation der Buskoppler BK/BC9000, B/C900 zu kontrollieren. Jeder Buskoppler verfügt über Status-Eingänge, die man im Hardwarebaum findet.
Status-Eingänge des BC9000
Coupler State
Wert | Bedeutung
0x0000 | kein Fehler
0x0001 | Busklemmen-Fehler, es liegt ein K-Bus-Fehler vor
0x0002 | Konfigurationsfehler, die parametrierte Konfiguration passt nicht mit der tatsächlichen Konfiguration überein
MissedCnt
Ideale Konfiguration:
Die Task-Zeit ist immer größer als die Ethernet-Laufzeit. Am Anfang der Task wird ein Ethernet-Telegramm weggeschickt und kommt nach einer Zeit tEth wieder am PC an. Ist die Zeit tEth immer kleiner als die eingestellte Task-Zeit bleibt der Zähler MissedCnt konstant.
Task-Zeit größer als Ethernet-Laufzeit
Sollte ein Ethernet-Telegramm nach Ablauf der Task-Zeit noch nicht wieder beim PC angekommen sein und erst nach dem Start der nächsten Task eintreffen, so arbeitet TwinCAT mit den alten Eingangsdaten weiter. Zusätzlich wird der Zähler MissedCnt um eins erhöht.
Task-Zeit kleiner als Ethernet-Laufzeit
Dies kann folgende Ursache haben:
▪
Task-Zeit zu klein gewählt. Stellen Sie
–
bei TCP 100 ms oder größer ein.
–
bei UDP 20 ms oder größer ein.
▪
Zu viele Kollisionen im Netzwerk: setzen Sie Switches anstelle von Hubs ein!
▪
Die Bus-Auslastung ist zu hoch: wechseln Sie auf 100 MBaud!
▪
Sie Sind beim BC9000, C900 eingeloggt: dieses belegt zusätzliche Prozessorleistung des Controllers, was die eine Antwortzeit verlängert.
Die beiden folgenden Diagnoseeingänge habe je nach Übertagungsart unterschiedliche Bedeutung.
Diagnose TCP/IP
BoxState
Wert | Bedeutung
0x0000 | kein Fehler
0x0001 | keine aktuellen Eingänge
MissedCnt
Wert | Bedeutung
0xyyyy | Anzahl der Telegramme, die nicht rechtzeitig zum Task-Anfang wieder angekommen sind. Dieser Wert sollte nahezu konstant sein. Sollte der Wert ständig hochzählen so ist die Task-Zeit zu erhöhen.
Diagnose UDP/IP
BoxState
Wert | Bedeutung
0x0000 | kein Fehler
0x0001 | keine aktuellen Eingänge
0x0002 | Ausgänge werden zu Null geschrieben
0xxxzz | xx - Warning Level. Hierbei wird bei jedem nicht rechtzeitigem Empfang der Daten der Wert um eins erhöht. Bei einem Fehlerfreien Datenaustausch wird dieser Wert wieder um eins herunter gezählt. Beim Erreichen der max. Warning Level (Default 100) werden die Ausgangsdaten zu Null geschrieben und werden erst wieder für das normale Prozessabbild freigegeben wenn der Warning Level auf Null ist.
MissedCnt
Wert | Bedeutung
0xyyyy | Anzahl der Telegramme, die nicht rechtzeitig zum Task-Anfang wieder angekommen sind. Dieser Wert sollte nahezu konstant sein. Sollte der Wert ständig hochzählen so ist die Task-Zeit zu erhöhen.


ModbusTCP-Diagnose

Fehlerbehandlung und Diagose [image] ModbusTCP-Diagnose
ModbusTCP-Diagnose
▪
siehe Modbus Diagnose-Funktion
▪
siehe Fehlerantworten ModbusTCP


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Zulassungen
•
Prüfnormen für Geräteprüfung
•
Literaturverzeichnis
•
Abkürzungsverzeichnis
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | Siehe Technische Daten
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:
Aufkleber mit Informationen über die Zulassung des Buskopplers BK2000
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung | 24 VDC
Übertragungsrate | 2,5 Mbit/s
Hersteller | Beckhoff Automation GmbH
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, LISTED 22ZA (unter diesem Eintrag sind die Prüfergebnisse einsehbar)
Produktionsbezeichnung | Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern). In diesem Fall handelt es sich also um einen BK2000 - produziert in der 9. Kalenderwoche - des Jahres 2001 - mit der Firmware-Version BF - in der 6. Hardwareversion - ohne Sonderbezeichnung


Zulassungen

Anhang [image] Zulassungen
Zulassungen
Underwriter laboratories
UL E172151
Konformitätskennzeichnung
CE
Schutzart
IP20 gemäß EN60529


Prüfnormen für Geräteprüfung

Anhang [image] Prüfnormen für Geräteprüfung
Prüfnormen für Geräteprüfung
EMV
EN 61000-6-2
EN 61000-6-4
Vibrationsfestigkeit
EN 60068-2-6 Schwingungsprüfung
EN 60068-2-27/29 Schockprüfung


Literaturverzeichnis

Anhang [image] Literaturverzeichnis
Literaturverzeichnis
TCP/IP
TCP/IP (deutsch)
Aufbau und Betrieb eines TCP/IP Netzes
von Kevin Washburn, Jim Evans
Verlag: ADDISON-WESLEY Longmann Verlag
TCP/IP (englisch)
Illustrated, Volume1 The Protocols
von W. Richard Stevens
Verlag: ADDISON-WESLEY Longmann Verlag
Modbus/TCP
http://www.modicon.com/
http://www.modbus.org
TwinCAT
BECKHOFF Information System
http://infosys.beckhoff.com


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
ADS
Automation Device Specification
IP (20)
Schutzart der Busklemmen
IPC
Industrie-PC
E/A
Ein- und Ausgänge
K-Bus
Klemmen-Bus
KS2000
Konfigurationssoftware für Busklemmen, Bus Koppler, Busklemmen Controller, Feldbus Box Module usw.
PE
Der PE-Powerkontakt kann als Schutzerde verwendet werden.
TwinCAT
The Windows Control and Automation Technology


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.