BC4000 – Bus Terminal Controller for Interbus
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Modifications
2.1
▪
Update technical data
2.0
▪
Migration
1.3
▪
HTML documentation; valid as from firmware B3
Firmware BC4000
You can determine which firmware was fitted when the Bus Coupler left the factory from the adhesive label underneath (see the fifth and sixth figures of the production number).
Example:
3200B2020000
The firmware in the example is B2.
In order to update your firmware, you require the KS2000 configuration software and the serial cable included with that software; as from software version B6, you can update your coupler using the TwinCAT 2.8 system manager. You will find the firmware under www.beckhoff.com.
Firmware | Description
B4 | Update of the firmware to new hardware from version 09
B3 | - Persistent data implemented - Cycle time monitoring implemented - Function "Deleting of the boot project" implemented - PLCSystemBC.lb6 integrated
B2 | Released version
B1 | Preliminary version B
B0 | Preliminary version A


Product overview

Product overview
Product overview
Additional information
•
BC4000 - Introduction
•
Technical data
•
Technical Data for the PLC
•
The Beckhoff Bus Terminal system
•
The principle of the Bus Terminal


BC4000 - Introduction

Product overview [image] BC4000 - Introduction
BC4000 - Introduction
BC4000
The Bus Terminal controller are Bus Couplers with integrated PLC functions. The BC4000 Controller has a fieldbus interface for the Interbus system. It can be used as a decentralized intelligence in the Interbus system. The Interbus has a ring structure, and up to 512 stations can be operated in one ring. Data is transferred at 500 kbaud.
The Bus Terminal Controllers are intelligent slaves. One unit consists of a Bus Terminal controller, any number of terminals between 1 and 64, and a bus end terminal. The Bus Terminal Controller is programmed using the TwinCAT PLC Control programming system in accordance with IEC 61131-3. The configuration and programming interface on the BC4000 is used to load the PLC program.
The Bus Terminal controller recognizes the terminals to which it is connected, and performs the assignment of the inputs and outputs to the words of the process image automatically. The first input/output signal will be added to the first bit of a word (LSB), beginning from the left. The Bus Terminal controller adds further signals to the word. A clear separation is maintained between inputs and outputs. If the number of inputs or outputs is greater than 16 bits, the Bus Terminal controller automatically begins a new word.
Since 1987 Interbus has become established as an open fieldbus system. The Interbus has a ring structure, and up to 256 stations can be operated in one ring. Data is transferred at 500 kbaud. The efficient data transfer allows sensor and actuator data to be transmitted quickly over large distances safe from interference.


Technical data

Product overview [image] Technical data
Technical data
System data | Interbus
Number of I/O modules | 256
Number of I/O points | 4096
Data transfer medium | LiYCY 3 x 2 x 0.22 mm²
Distance between modules | 400 m
Data transfer rate | 500 kbaud
Topology | Ring / line
Technical data | BC4000
Number of Bus Terminals | 64
Digital peripheral signals | 256 inputs/outputs
Analog peripheral signals | 128 inputs/outputs
Protocols | Interbus
Configuration possibility | Via the KS2000 configuration software or the controller (TwinCAT)
Maximum fieldbus byte number | 64 bytes I and 64 bytes O
Bus connection | 2 x D-sub plug, 9-pin, plug and socket with screening and vibration lock
Power supply | 24 VDC (-15%/+20%)
Input current | 70 mA + (total K-bus current)/4
Starting current | approx. 2.5 x continuous current
Recommended fuse | ≤ 10 A
K-bus power supply up to | 1750 mA
Power contact voltage | max. 24 VDC
Power contact current load | 10 A max.
Dielectric strength | 500 V (power contact/supply voltage/fieldbus)
Weight approx. | 170 g
Operating temperature | 0°C ... +55°C
Storage temperature | -25°C ... +85°C
Relative humidity | 95 % no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Installation position | variable
Protection class | IP20
Approvals | CE, cULus, ATEX


Technical Data for the PLC

Product overview [image] Technical Data for the PLC
Technical Data for the PLC
PLC data | BC4000
Programmability | via programming interface (TwinCAT)
Program memory | 32/96 kbyte
Data memory | 32/64 kbyte
Remanent flags | 512 byte (default 64 byte)
Max. size of process image | 512 bytes input and 512 bytes output
PLC cycle time | Approx. 3 ms for 1000 IL commands (without I/O cycle)
Programming languages | IEC 6-1131-3 (IL, LD, FBD, ST, SFC)


The Beckhoff Bus Terminal system

Product overview [image] The Beckhoff Bus Terminal system
The Beckhoff Bus Terminal system
Up to 256 Bus Terminals, with 1 to 16 I/O channels per signal form
The Bus Terminal system is the universal interface between a fieldbus system and the sensor / actuator level. A unit consists of a Bus Coupler as the head station, and up to 64 electronic series terminals, the last one being an end terminal. Up to 255 Bus Terminals can be connected via the K-bus extension. For each technical signal form, terminals are available with one, two, four or eight I/O channels, which can be mixed as required. All the terminal types have the same mechanical construction, so that difficulties of planning and design are minimized. The height and depth match the dimensions of compact terminal boxes.
Decentralised wiring of each I/O level
Fieldbus technology allows more compact forms of controller to be used. The I/O level does not have to be brought to the controller. The sensors and actuators can be wired decentrally, using minimum cable lengths. The controller can be installed at any location within the plant.
Industrial PCs as controllers
The use of an Industrial PC as the controller means that the operating and observing element can be implemented in the controller's hardware. The controller can therefore be located at an operating panel, in a control room, or at some similar place. The Bus Terminals form the decentralised input/output level of the controller in the control cabinet and the subsidiary terminal boxes. The power sector of the plant is also controlled over the bus system in addition to the sensor/actuator level. The Bus Terminal replaces the conventional series terminal as the wiring level in the control cabinet. The control cabinet can have smaller dimensions.
Bus Couplers for all usual bus systems
The Beckhoff Bus Terminal system unites the advantages of a bus system with the possibilities of the compact series terminal. Bus Terminals can be driven within all the usual bus systems, thus reducing the controller parts count. The Bus Terminals then behave like conventional connections for that bus system. All the performance features of the particular bus system are supported.
Mounting on standardized mounting rails
The installation is standardized thanks to the simple and space-saving mounting on a standardized mounting rail (EN 60715, 35 mm) and the direct wiring of actuators and sensors, without cross connections between the terminals. The consistent labelling scheme also contributes.
The small physical size and the great flexibility of the Bus Terminal system allow it to be used wherever a series terminal is also used. Every type of connection, such as analog, digital, serial or the direct connection of sensors can be implemented.
Modularity
The modular assembly of the terminal strip with Bus Terminals of various functions limits the number of unused channels to a maximum of one per function. The presence of two channels in one terminal is the optimum compromise of unused channels and the cost of each channel. The possibility of electrical isolation through potential feed terminals also helps to keep the number of unused channels low.
Display of the channel state
The integrated LEDs show the state of the channel at a location close to the sensors and actuators.
K-bus
The K-bus is the data path within a terminal strip. The K-bus is led through from the Bus Coupler through all the terminals via six contacts on the terminals' side walls. The end terminal terminates the K-bus. The user does not have to learn anything about the function of the K-bus or about the internal workings of the terminals and the Bus Coupler. Many software tools that can be supplied make project planning, configuration and operation easy.
Potential feed terminals for isolated groups
The operating voltage is passed on to following terminals via three power contacts. You can divide the terminal strip into arbitrary isolated groups by means of potential feed terminals. The potential feed terminals play no part in the control of the terminals, and can be inserted at any locations within the terminal strip.
Up to 64 Bus Terminals can be used in a terminal block, with optional K-bus extension for up to 256 Bus Terminals. This count does include potential feed terminals, but not the end terminal.
Bus Couplers for various fieldbus systems
Various Bus Couplers can be used to couple the electronic terminal strip quickly and easily to different fieldbus systems. It is also possible to convert to another fieldbus system at a later time. The Bus Coupler performs all the monitoring and control tasks that are necessary for operation of the connected Bus Terminals. The operation and configuration of the Bus Terminals is carried out exclusively by the Bus Coupler. Nevertheless, the parameters that have been set are stored in each Bus Terminal, and are retained in the event of voltage drop-out. Fieldbus, K-bus and I/O level are electrically isolated.
If the exchange of data over the fieldbus is prone to errors or fails for a period of time, register contents (such as counter states) are retained, digital outputs are cleared, and analog outputs take a value that can be configured for each output when commissioning. The default setting for analog outputs is 0 V or 0 mA. Digital outputs return in the inactive state. The timeout periods for the Bus Couplers correspond to the usual settings for the fieldbus system. When converting to a different bus system it is necessary to bear in mind the need to change the timeout periods if the bus cycle time is longer.
The interfaces
A Bus Coupler has six different methods of connection. These interfaces are designed as plug connectors and as spring-loaded terminals.


The principle of the Bus Terminal

Product overview [image] The principle of the Bus Terminal
The principle of the Bus Terminal
The principle of the Bus Terminal


Fitting and wiring

Fitting and wiring
Fitting and wiring
Additional information
•
Mechanical installation
•
Wiring


Mechanical installation

Fitting and wiring [image] Mechanical installation
Mechanical installation
Additional information
•
Dimensions
•
Mounting


Dimensions

Fitting and wiring [image] Mechanical installation [image] Dimensions
Dimensions
The system of the Beckhoff Bus Terminals is characterized by low physical volume and high modularity. When planning a project it must be assumed that at least one Bus Coupler and a number of Bus Terminals will be used. The mechanical dimensions of the Bus Couplers are independent of the fieldbus system.
BC4000 dimensions
The total width in practical cases is composed of the width of the Bus Coupler, the KL9010 Bus End Terminal and the width of the bus terminals in use. Depending on function, the Bus Terminals are 12 mm or 24 mm wide. The front wiring increases the total height of 68 mm by about 5 mm to 10 mm, depending on the wire thickness.


Mounting

Fitting and wiring [image] Mechanical installation [image] Mounting
Mounting
The Bus Coupler and all the Bus Terminals can be clipped, with a light press, onto a 35 mm mounting rail. A locking mechanism prevents the individual housings from being pulled off again. For removal from the mounting rail the orange colored tension strap releases the latching mechanism, allowing the housing to be pulled off the rail without any force.
Release the locking mechanism by pulling the orange tab
Up to 64 Bus Terminals can be attached to the Bus Coupler on the right hand side. When plugging the components together, be sure to assemble the housings with groove and tongue against each other. A properly working connection cannot be made by pushing the housings together on the mounting rail. When correctly assembled, no significant gap can be seen between the attached housings.
Groove and tongue of the housings
Note
Bus Terminals should only be pulled or plugged in switched-off state.
Insertion and removal of Bus Terminals is only permitted when switched off. The electronics in the Bus Terminals and in the Bus Coupler are protected to a large measure against damage, but incorrect function and damage cannot be ruled out if they are plugged in under power.


Wiring

Fitting and wiring [image] Wiring
Wiring
Additional information
•
Potential groups, insulation testing and PE
•
Power supply
•
Wiring the Bus System
•
ATEX - Special conditions (standard temperature range)


Potential groups, insulation testing and PE

Fitting and wiring [image] Wiring [image] Potential groups, insulation testing and PE
Potential groups, insulation testing and PE
Potential groups
A Beckhoff Bus Terminal block usually has three different potential groups:
▪
The fieldbus interface is electrically isolated (except for individual Low Cost couplers) and forms the first potential group.
▪
Bus Coupler / Bus Terminal Controller logic, K-bus and terminal logic form a second electrically isolated potential group.
▪
The inputs and outputs are supplied via the power contacts and form further potential groups.
Groups of I/O terminals can be consolidated to further potential groups via potential supply terminals or separation terminals.
Potential groups of a Bus Terminal block
Insulation testing
The connection between Bus Coupler / Bus Terminal Controller and Bus Terminals is realized automatically by latching the components. The transfer of the data and the supply voltage for the intelligent electronics in the Bus Terminals is performed by the K-bus. The supply of the field electronics is performed through the power contacts. Plugging together the power contacts creates a supply rail. Since some Bus Terminals (e.g. analog Bus Terminals or 4-channel digital Bus Terminals) are not looped through these power contacts or not completely the Bus Terminal contact assignments must be considered.
The potential feed terminals interrupt the power contacts, and represent the start of a new supply rail. The Bus Coupler / Bus Terminal Controller can also be used for supplying the power contacts.
PE power contacts
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on the left
It should be noted that, for reasons of electromagnetic compatibility, the PE contacts are capacitively coupled to the mounting rail. This can both lead to misleading results and to damaging the terminal during insulation testing (e.g. breakdown of the insulation from a 230 V power consuming device to the PE conductor). The PE supply line at the Bus Coupler / Bus Terminal Controller must be disconnected for an insulation test. In order to uncouple further feed locations for the purposes of testing, the feed terminals can be pulled at least 10 mm out from the connected group of other terminals. In that case, the PE conductors do not have to be disconnected.
The power contact with the label PE must not be used for other potentials.


Power supply

Fitting and wiring [image] Wiring [image] Power supply
Power supply
Supply of Bus Coupler / Bus Terminal Controller and Bus Terminals (Us)
Additional information
•
BKxx00, BKxx10, BKxx20 and LCxxxx
•
BKxx50 and BKxx51
•
Configuration and Programming Interface
•
Electrical isolation
•
Power contacts


BKxx00, BKxx10, BKxx20 and LCxxxx

Fitting and wiring [image] Wiring [image] Power supply [image] BKxx00, BKxx10, BKxx20 and LCxxxx
BKxx00, BKxx10, BKxx20 and LCxxxx
The Bus Couplers / Bus Terminal Controllers require an operating voltage of 24 VDC.
The connection is made by means of the upper spring-loaded terminals labelled 24 V and 0 V. This supply voltage is used for the electronic components of the Bus Coupler and Bus Terminal Controllers and (via the K-bus) the electronic components of the Bus Terminals. It is galvanically separated from the field level voltage.
Power supply connections for BKxx00, BKxx10, BKxx20 and LCxxxx


BKxx50 and BKxx51

Fitting and wiring [image] Wiring [image] Power supply [image] BKxx50 and BKxx51
BKxx50 and BKxx51
The Bus Couplers / Bus Terminal Controllers require an operating voltage of 24 VDC. Use a 4 A fuse or a Class 2 power supply to comply with the UL requirements.
The connection is made by means of the upper spring-loaded terminals labelled Us and GNDs. This supply voltage is used for the electronic components of the Bus Coupler and Bus Terminal Controllers and (via the K-bus) the electronic components of the Bus Terminals. It is galvanically separated from the field level voltage.
Power supply connections for BKxx50 and BKxx51
UL identification
SmallWarningYellow DANGER
Note the UL requirements for the power supply.
To comply with the UL requirements, the 24 VDC supply voltage for Us must originate
•
from an isolated source protected by a fuse of max. 4A (according to UL248) or
•
from a voltage supply complying with NEC class 2.
An NEC class 2 voltage source must not be connected in series or parallel with another NEC class 2 voltage source!
SmallWarningYellow DANGER
No unlimited voltage sources!
To comply with the UL requirements, Us must not be connected with unlimited voltage sources.


Configuration and Programming Interface

Fitting and wiring [image] Wiring [image] Power supply [image] Configuration and Programming Interface
Configuration and Programming Interface
The standard Bus Couplers have an RS232 interface at the bottom of the front face. The miniature plug connector can be connected to a PC using a connecting cable and the KS2000 configuration software. The interface permits the Bus Terminals to be configured, for example adjusting the amplification factors of the analog channels. The interface can also be used to change the assignments of the bus terminal data to the process image in the Bus Coupler. The functionality of the configuration interface can also be reached via the fieldbus using string communication facility.


Electrical isolation

Fitting and wiring [image] Wiring [image] Power supply [image] Electrical isolation
Electrical isolation
The Bus Couplers / Bus Terminal Controllers operate with three independent potential groups. The supply voltage feeds the K-bus electronics and the K-bus itself. The supply voltage is also used to generate the operating voltage for the fieldbus interface.
Note: All the Bus Terminals are electrically isolated from the K-bus. The K-bus is thus electrically isolated from everything else.
Potential connection diagram of an EKxxxx


Power contacts

Fitting and wiring [image] Wiring [image] Power supply [image] Power contacts
Power contacts
Power contacts supply (Up)
The bottom six connections with spring-loaded terminals can be used to feed the supply for the peripherals. The spring-loaded terminals are joined in pairs to a power contact. The power supply for the power contacts has no connection to the power supply for the Bus Couplers / Bus Terminal Controllers.
The spring-loaded terminals are designed for wires with cross-sections between 0.08 mm² and 2.5 mm².
The assignment in pairs and the electrical connection between feed terminal contacts allows the connection wires to be looped through to various terminal points. The current load from the power contact must not exceed 10 A for long periods. The current carrying capacity between two spring-loaded terminals is identical to that of the connecting wires.
Power contacts
Three spring contacts of the power contact connections can be found on the right of the Bus Coupler / Bus Terminal Controller. The spring contacts are hidden in slots so that they cannot be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue & groove design of the top and bottom of the Bus Coupler / Bus Terminal Controller and Bus Terminals enables secure fitting of the power contacts.


Wiring the Bus System

Fitting and wiring [image] Wiring [image] Wiring the Bus System
Wiring the Bus System
The INTERBUS differentiates between remote bus, peripheral bus and remote installation bus. The INTERBUS Bus Coupler is equipped with the remote bus interface. The INTERBUS Bus Coupler has an incoming and outgoing interface based on D-SUB plug and coupling.
INTERBUS topology
INTERBUS is a ring bus system. The INTERBUS line includes the return line. The cabling therefore appears to be a single line.
Bus length
Baud rate | Bus length
500 kbit/s | 12.8 km (400 m between 2 stations)
INTERBUS cable
The use of pair-wise twisted, screened cables is recommended for the INTERBUS wiring (3 x twisted pair with screening).
ZB4200 INTERBUS cable
Beckhoff offers an INTERBUS cable with the order number ZB4200.
Cable preparation
Cable colours for using the Beckhoff INTERBUS cable at Bus Terminal and Fieldbus Box:
Pin BK40x0/BC4000 |  | Function | ZB4200 cable color
D sub plug outgoing remote bus | D sub socket incoming remote bus |  |
6 | 6 | /DO | green
1 | 1 | DO | yellow
7 | 7 | /DI | pink
2 | 2 | DI | grey
3 | 3 | COM | brown
5 | - | jumper | -
9 | - | jumper | -
INTERBUS D sub coupling ZB4100 and plug ZB4101
For the connection with the INTERBUS cable and the Bus Coupler, we recommend the use of D sub plug and coupling.
ZB4100 incoming remote bus, coupling
ZB4101 outgoing remote bus, plug


ATEX - Special conditions (standard temperature range)

Fitting and wiring [image] Wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


Parameterization and Commissioning

Parameterization and Commissioning
Parameterization and Commissioning
Additional information
•
Start-up behavior of the Bus Terminal Controller
•
Addressing


Start-up behavior of the Bus Terminal Controller

Parameterization and Commissioning [image] Start-up behavior of the Bus Terminal Controller
Start-up behavior of the Bus Terminal Controller
When the Bus Terminal Controller is switched on it checks its state, configures the K-bus, creates a configuration list based on the connected Bus Terminals and starts its local PLC.
The I/O LEDs flash when the Bus Terminal Controller starts up. If the system is in an error-free state, the I/O LEDs should stop flashing after approx. 2-3 seconds. In the event of a fault the error type determines which LED flashes (see chapter Diagnostic LEDs).
Start-up behavior of the Bus Terminal Controller


Addressing

Parameterization and Commissioning [image] Addressing
Addressing
The master addresses Interbus slave devices independently in the order they are connected to it. The user is usually not made aware of the node addressing.


Configuration

Configuration
Configuration
Additional information
•
Configuration of the Interbus
•
Configuration of the master
•
Configuration via TwinCAT


Configuration of the Interbus

Configuration [image] Configuration of the Interbus
Configuration of the Interbus
The Bus Couplers BK4000, BK4010, BK4020, BK4500 and BC4000 can be operated with generation 3 or 4 Phoenix masters. The baud rate for all Bus Couplers is 500 kBaud.
ID code
Signal type | Signal direction | Hex value
Digital | Outputs | 0x01
Digital | Inputs | 0x02
Digital | Inputs/outputs | 0x03
Byte-oriented | Outputs | 0x31
Byte-oriented | Inputs | 0x32
Byte-oriented | Inputs/outputs | 0x33
ID length
Length of the inserted periphery | Register width in the ID code
1 word | 1 word
2 words | 2 words
3 words | 3 words
4 words | 4 words
5 words | 5 words
6 words | 6 words
7 words | 7 words
8 words | 8 words
9 words | 9 words
10 words | 10 words
11 -12 words | 12 words
13 -14 words | 14 words
15 -16 words | 16 words
17 -24 words | 24 words
25 -32 words | 32 words
Default Setting
In the default setting, the BC4000 has 16 bytes of input data and 16 bytes of output data (PLC variables). This data can be increased or reduced in single-byte steps (see Table 1 Register 1 and 3).
ID code: 0x33 ID length 8 words


Configuration of the master

Configuration [image] Configuration of the master
Configuration of the master
As already explained above, the Interbus coupler creates a data range with input and output bytes. The assignment of channels of the Bus Terminals to the bits and bytes of the process image is done by the Bus Coupler. The Interbus master exchanges a contiguous input and output data block with each Interbus coupler. The assignment of the bytes from this data block to the addresses of the process image is done via data function blocks in the PLC or the configuration software IBS SYS SWT or IBS CMD SWT G3 and G4 from Phoenix Contact. The corresponding manufacturer's tools should be used for other masters.
Software for the master configuration
Master software | Configuration software | Manufacturer
PLC connection –version lower than 4 | IBS SYS SWT IBS CMD SWT G3 | Phoenix Contact
PC connection –version lower than 4 | IBS SYS SWT IBS CMD SWT G3 | Phoenix Contact
PLC connection –version 4 or higher | IBS CMD SWT G4 | Phoenix Contact
PC connection –version 4 or higher | IBS CMD SWT G4 | Phoenix Contact
Ensuring data consistency
The data consistency of the data from a station is secured by the Interbus transmission protocol. The consistency over the entire process image is secured by synchronous sampling. Inconsistencies may result due to the control CPU (usually a PLC) asynchronously accessing the data range of the Interbus master. Access to 16 bit words and partly to 32 bit double words is secured by most Interbus masters. Please refer to the respective manufacturer's manuals for greater clarity regarding the special methods of accessing the master connections. Common PLC connections are the S5 assemblies IBS S5 DCB and IBS S5 DSC as Interbus masters. The masters with the firmware version 4.0 are particularly easy to operate. The CMD configuration software allows the settings to be made under Windows. The byte-wise and bit-wise assignment of the peripheral data in the address range of the controller is possible. The data consistencies are selectable in groups.
Interbus standard-compliant
The BK4xxx/BC40xx devices work with the SUPI 3 (Serial Universal Periphery Interface) protocol chip. The SUPI 3 protocol chip handles the complete Interbus protocol. In comparison with the predecessor version (SUPI 2), the SUPI 3 offers extended diagnostics and error management. Please refer to the manuals for the Interbus masters used regarding the functions of the SUPI 3 chips that are supported.


Configuration via TwinCAT

Configuration [image] Configuration via TwinCAT
Configuration via TwinCAT
In order to integrate the Bus Coupler into the TwinCAT System Manager, an Interbus master card has to be designed first. The BC4000 can then be attached to this card (see Fig. TwinCAT 1).
twincat sysman 1.gif
TwinCAT 1
In the next step, the Bus Terminals are attached to the coupler. 3 different mapping options are available.
▪
Compact fieldbus terminal
In this setting, the Bus Terminal is invisible for the BC4000. The data are mapped directly into the fieldbus process image. Analog Bus Terminals become compact (only user data without control/status are entered). The BC4000 must be notified of this change via KS2000 or via the System Manager.
▪
Complex PLC Bus Terminal (default)
All Bus Terminals are assigned to the local BC4000 process image and are not visible for the Interbus. The analog Bus Terminals map with control/status.
▪
Compact PLC Bus Terminal
All Bus Terminals are assigned to the local BC4000 process image and are not visible for the Interbus. The analog Bus Terminals map compact (only user data without control/status). The BC4000 must be notified of this change via KS2000 or via the System Manager.
twincat sysman 2.gif
TwinCAT 2
In the default setting, the PLC variables have 16 byte inputs and 16 byte outputs. The Bus Terminal controllers must be notified of every change.
twincat sysman 3.gif
TwinCAT 3
Displaying the local BCxxxx variables
If you do not know the address of the Bus Terminals that you have assigned to the local PLC (BCxx00):
Perform your hardware configuration in the System Manager. After you have entered all the Bus Terminals and PLC variables, click with the right mouse button on the BCxx00 in the hardware tree, and select the menu item Export variables information.... A file is saved, and this file can be inserted in the System Manager under Import Project. Now you will have the entry TwinCAT import under the global variables, and you will find here all the variables that you have assigned to the local PLC (BCxx00).
twincat sysman export var info.gif
Export Variables Info
Bus Terminal configuration, changing PLC variables
The change of the default setting (PLC variables, Bus Terminals) can be downloaded to the Bus Coupler with the KS2000 configuration software or in the TwinCAT System Manager. The Bus Terminal configuration/PLC variables, PLC offset can then be transferred to the Bus Terminal controller with the KS2000 cable.
twincat sysman term conf.gif
Terminal Config


Programming

Programming
Programming
Additional information
•
TwinCAT PLC
•
PLC Cycle Time
•
Remanent and persistent data
•
PLC Variables
•
Mapping the Bus Terminals
•
Local process image
•
Interbus process image
•
Programming


TwinCAT PLC

Programming [image] TwinCAT PLC
TwinCAT PLC
The Beckhoff TwinCAT Software System turns any compatible PC into a real-time controller with a multi-PLC system, NC axis control, programming environment and operating station. The TwinCAT programming environment is also used for programming the BCxx00 Bus Terminal Controller. If you have installed TwinCAT PLC you can use the fieldbus connection or the serial interface for program downloading and debugging.
Programming via the fieldbus
The following Bus Terminal controllers enable programming with TwinCAT PLC via the fieldbus interface:
BC2000 Lightbus
BC3100, BC3150 PROFIBUS
BC5150 CANopen
BC5250 Device Net
BC9000 Ethernet
Programming via the serial port
Programming with TwinCAT PLC is possible via the serial interface with the following Bus Terminal Controllers:
BC2000: Lightbus
BC3100, BC3150: PROFIBUS
BC4000: Interbus
BC5150: CANopen
BC5250: DeviceNet
BC7300: Modbus
BC8000: RS 485
BC8100: RS 232
BC9000: Ethernet
Program and data memory
The BCxx00 Bus Terminal Controller has 64 kbyte memory in the delivery state. 2 kbyte are required for internal PLC functions. The slider can be individually adjusted in order to increase the program memory or the data memory share. In the large model, the memory allocation is fixed at 96 kbyte for the code and 62 (128) kbyte (BC9000) for the data memory.
Disadvantages of the large model:
▪
No flow control possible
▪
Significantly slower execution of the program code (BC9000 only)
▪
Execution from the flash (max. 25,000 accesses permitted)
Program and data memory


PLC Cycle Time

Programming [image] PLC Cycle Time
PLC Cycle Time
The PLC cycle time determines the program’s repetition frequency. This time is not deterministic. This means that the PLC cycle time can become longer in some programs, and can exceed the cycle time that has been set. If the program requires less time than has been set, it is repeated within the set cycle time, and the remaining duration is padded with background time.
The processing of the Ethernet and the serial interface runs in the background time. This should be set to somewhere between 20 and 50 % of the PLC cycle time.
The mean cycle time is measured in order to optimize the system. You will find this in PLC Control under the Online/Coupler menu item. About 50 % is added to the time determined there, and the result entered as the PLC cycle time. Set the background time to between 20 and 50 % of the PLC cycle time.
task time 1.png
Program running time
The program running time is composed of the program processing and the K-Bus time. Before the program is called, the Bus Terminal Controller carries out a K-bus update, and reads the current inputs. Following the processing of the program, a second K-bus update takes place in order to write the outputs. The K-Bus time depends on the number and type of Bus Terminals inserted.
The program running time can be shortened by operating only one K-Bus cycle, and this may either be done before or after program processing. In that case, inputs are read and outputs written in a single K-Bus cycle. You can make these settings either with the aid of the KS2000 configuration software, or through ADS.
Task Time


Remanent and persistent data

Programming [image] Remanent and persistent data
Remanent and persistent data
There are special flags for remanent and persistent data in the higher memory region.
Remanent data
The remanent data is located in the flags area. The default setting is for 64 remanent bytes, i.e. from %MB0 to %MB63. This region can be expanded to a maximum size of 512 bytes. It should be borne in mind that the task time increases with the quantity of remanent data (approx. 0.5 ms for 512 bytes). The settings for the remanent data can be made via the (TwinCAT) System Manager, or with the KS2000 configuration software (Table 1, Register 15, default value 64 max. 512 bytes).
Persistent data
Persistent data is even more stable, and is retained even through a program download. The number of persistent data must be greater than or equal to the number of remanent data! Like the remanent data, the persistent data is located in the region allocated for flags (%MBxx). You can make the settings for the persistent data using the KS2000 configuration software (Table 1, Register 18, default value 0, max. 512 bytes).
Example
400 bytes of remanent data, of which 200 bytes are to be persistent
Register 15 400 (%MB200 - %MB399)
Register 18 200 (%MB0 - %MB199)
Cycle Time Measuring
The flags area includes a timing system with a resolution of one millisecond for each digit. The data type is UDINT (unsigned double integer). This value can be overwritten by the program, in order to align with a controller. The timer rolls over in about 48 days.
Flag byte | Meaning
%MB504-507 | 4 byte
 | Type | UDINT
 |  | 0..4.22 billion ms / 0.. about 48 days
 | Resolution | 1 ms / digit
Diagnostics
It is possible to read the diagnostic data in the Bus Terminal controller. This information is located in the flags area.
Flag byte | Meaning
%MB508-509 | Bit 0 | Interbus communication ("1" - no communication)
 | Bit 1-15 | reserved
%MB510-511 | Bit 0 | K-bus error
 | Bit 1 | Configuration error
 | Bit 2-15 | reserved


PLC Variables

Programming [image] PLC Variables
PLC Variables
The PLC variables act as the interface between the local process image of the bus controller and the fieldbus process image for a higher-level controller. This will first be explained on the basis of the default setting.
Bus Terminals in the BC's local process image
All the connected Bus Terminals are assigned to the local process image. The PLC variables are located from address 128 onwards. You can change both this starting address and the length of these data (default 16 bytes).
Data that is to be read by a higher level controller is written into the output process image. This is input data for the higher level controller. Data that is to be transferred from the higher level controller to the BC is output data for the controller and input data for the BC. The following diagram may clarify this.
Bus Terminals in the BC's local process image
Assign bus terminals to the higher level controller
You can also assign the Bus Terminals directly to the higher level controller. The general scheme of the fieldbus process image is such that the analog Bus Terminals are mapped into this process image first. The digital Bus Terminals then follow, while the PLC variables come last.
Assign bus terminals to the higher level controller
Remember that none of the process images in use may be larger than 512 bytes.


Mapping the Bus Terminals

Programming [image] Mapping the Bus Terminals
Mapping the Bus Terminals
The precise assignment of the byte-oriented Bus Terminals may be found in the configuration guide for the particular bus terminal. This documentation is available on the Beckhoff Products & Solutions CD or on the Internet under http://www.beckhoff.de.
Byte oriented Bus Terminals | Bit oriented Bus Terminals
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Local process image

Programming [image] Local process image
Local process image
All connected bus terminals are assigned in the default setting to the local process image of the BC/BX.
Mapping within the Bus Terminal Controller is carried out according to the following rule:
First come all the complex Bus Terminals, in whatever sequence they are physically inserted, followed by the digital Bus Terminals which are padded to a whole byte.
The default mapping of the complex Bus Terminals is:
▪
complete evaluation
▪
Intel format
▪
Word alignment
Example
1 x BCxxxx or BXxxxx
1 1 x KL1012
2 1 x KL1104
3 1 x KL2012
4 1 x KL2034
5 1 x KL1502
6 1 x KL3002
7 1 x KL4002
8 1 x KL6001
9 1 x KL9010
Bus Terminal | Position | Input image | Output image
KL1502 | 5 | %IB0...%IB5 | %QB0...%QB5
KL3002 | 6 | %IB6...%IB13 | %QB6...%QB13
KL4002 | 7 | %IB14...%IB21 | %QB14...%QB21
KL6001 | 8 | %IB22...%IB29 | %QB22...%QB29
KL1012 | 1 | %IX30.0 to %IX30.1 | -
KL1104 | 2 | %IX30.1 to %IX30.5 | -
KL2012 | 3 | - | %QX30.0 to %QX30.1
KL2034 | 4 | - | %QX30.2 to %QX30.5
KL9010 | 9 | - | -
Address of the Bus Terminals, which you have assigned to local PLCs (BCxx00)
If you don't know the address at which the Bus Terminals are located, which you have assigned to the local PLC of your BC/BX:
Perform your hardware configuration in the System Manager.
Once you have entered all Bus Terminals and PLC variables, right-click on the BC/BX in the hardware tree of the System Manager and select the menu item Export Variable Info...
A file is saved that you can insert in the PLC control under Import Project.
Under the global variables you now have the entry TwinCAT Import in which all variables are located that you have assigned to the local PLC of your BC/BX.


Interbus process image

Programming [image] Interbus process image
Interbus process image
Data transferred via the fieldbus are accessible via the PLC variables for the BCxxxx. In the default setting, 16 bytes of output data are transferred to the Bus Terminal controller, and 16 bytes of input data are read. The local PLC, i.e. the BCxxxx, recognizes the master output data as inputs in the memory area %IB128...143 and writes its output data %QB128...143 to input data in the master control. The offset and the length of the PLC variables can be changed in Table 1.


Programming

Programming [image] Programming
Programming
Additional information
•
Transmission via the serial interface
•
Overview


Transmission via the serial interface

Programming [image] Programming [image] Transmission via the serial interface
Transmission via the serial interface
Everything that can be programmed and parameterized with TwinCAT BC can also be handled with TwinCAT. A special feature of TwinCAT BC is that it operates both under Windows 95/98/ME or under NT/2000/XP. Program download via Ethernet, however, is not possible with TwinCAT BC.
Every Bus Terminal Controller can be programmed via the PC's RS232 interface. A special cable to be used for this purpose is supplied along with TwinCAT BC and the KS2000 configuration software.
Select the serial interface in TwinCAT PLC Control.
Selecting the data transfer route - serial interface
The settings for the serial interface, port number, baud rate etc. are found under Online/Communication parameters in PLC Control. The Bus Terminal Controller requires the following setting:
Baud Rate: 19200
Stop bits: 1
Parity: even
Parameterization of the serial interface


Overview

Programming [image] Programming [image] Overview
Overview
Various libraries are available for the Bus Terminal Controllers (Bus Coupler with PLC functionality: BCxxxx) (see Beckhoff Information System).
TwinCAT PLC Library: System BC
The library contains function blocks for access to the Bus Terminal Controller's (BCxxxx) system functions.
TwinCAT PLC Library: Utilities BC
The library contains useful function blocks for the Bus Terminal Controller (BCxxxx). In addition to the RTC blocks, the library contains a function block for decoding the DCF-77 time signal, along with a number of conversion functions. Internally, the Bus Terminal controller's system functions are called.
TwinCAT PLC Library: Helper BC
The PlcHelper.lb6 library contains a number of functions which provide direct access to memory areas in the Bus Terminal Controller's (BCxxxx) PLC runtime system.


Fieldbus system

Fieldbus system
Fieldbus system
Additional information
•
Interbus introduction
•
Description of parameters
•
Topology
•
Propagation delay and reaction time of the Interbus


Interbus introduction

Fieldbus system [image] Interbus introduction
Interbus introduction
Introduction to the system
Interbus data ring
The INTERBUS system is configured as a data ring with a central master/slave access procedure. It has the structure of a spatial distributed shift register. Each device, with its registers of different length, is part of the shift register ring. The master pushes data through the ring serially. The use of the ring structure offers the option of sending and receiving data simultaneously. The two data directions of the ring are located in a single cable. Each INTERBUS system device has an ID register (identification register). This register contains information about the module type, the number of input and output registers, and status and error conditions. The INTERBUS system basically knows two operating modes:
The ID cycle,
which is carried out for the initialization of the INTERBUS system and on demand. In the ID cycle, the coupling module reads the ID registers of all devices attached to the bus system and uses this information to build the process image.
The data cycle;
this is the actual duty cycle dealing with the data transmission. In the data cycle, the input data are transferred from the registers to the coupling module, and the output data from the coupling module the devices.
System configuration and device types
The INTERBUS club has a large number of different ID codes. Apart from 6 ID codes, Phoenix Contact has assigned these ID codes to couplers with digital and analog periphery. The manufacturer can therefore not be identified via the ID code. (Detailed commentary in Chapter "ID code and ID length"). The handling of the BK4xx0/BC4xx0 INTERBUS couplers does not differ from the equipment of other manufacturers.


Description of parameters

Fieldbus system [image] Description of parameters
Description of parameters
Additional information
•
Bus Terminal Controller properties


Bus Terminal Controller properties

Fieldbus system [image] Description of parameters [image] Bus Terminal Controller properties
Bus Terminal Controller properties
Additional information
•
Register settings, Table 0
•
Register settings, Table 1


Register settings, Table 0

Fieldbus system [image] Description of parameters [image] Bus Terminal Controller properties [image] Register settings, Table 0
Register settings, Table 0
Using the KS2000 configuration software you can set the register values via the dialog window or write them directly into the registers.
Register | Description | Default | Bus Terminal Controller
19 | Byte offset digital outputs %Q... | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
20 | Byte offset digital inputs %I... | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000


Register settings, Table 1

Fieldbus system [image] Description of parameters [image] Bus Terminal Controller properties [image] Register settings, Table 1
Register settings, Table 1
Using the KS2000 configuration software you can set the register values via the dialog window or write them directly into the registers.
Register | Description |  |  | Default | Bus Terminal Controller
0 | Byte offset PLC variables %I. |  |  | 128 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
1 | Length of the PLC variables %I... |  |  | 16 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
2 | Byte offset PLC variables %Q... |  |  | 128 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
3 | Length of the PLC variables %Q... |  |  | 16 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
4-11 | Bus Terminal assignment |  |  |  | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
4.0-4.1 | Assignment of the 1st Bus Terminal |  |  | 11bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
 | 0bin | Fieldbus process image complex
 | 10bin | Fieldbus process image compact
 | 11bin | Local process image
4.2-4.3 | Assignment of the 2st Bus Terminal |  |  | 0bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
m.n-1..m.n | Assignment of the nth Bus Terminal |  |  | 0bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
12 | PLC cycle time |  |  | 5 ms (20 ms in the case of BC9000/BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
13 | Background Time |  |  | 2 ms (10 ms in the case of BC9000/BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
14.0 | Activate remanent data |  |  | 1bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
14.2-14.3 | Execution of the K-Bus update |  |  | 0bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
 | 0bin | before and after the PLC
 | 01bin | before the PLC
 | 10bin | after the PLC
14.6 | Switch on Bus Terminal checking |  |  | 1bin | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
15 | Size of the NOVRAM (remanent data) |  |  | 64 [bytes] | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
17.0-17.7 | Terminal bus autorefresh: Cycle in [ms] |  |  | 0x0000 Disable (0x005F in the case of BC9000) (0x035F in the case of BC9100) | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
17.8-17.15 | Terminal bus autorefresh: max. retries
18 | Size of the NOVRAM Persistent data R18<R15 |  |  | 0 | BC2000, BC3100, BC4000, BC7300, BC8x00, BC9000
27 | Byte offset KL6xx1 bus terminal emulation %Q... |  |  | 500 | BC8x00
28 | Byte offset KL6xx1 bus terminal emulation %I... |  |  | 500 | BC8x00
32 | Baud rate |  |  | 2 | BC8x00
 | 0 |  | 38400Bd
 | 1 |  | 19200Bd
 | 2 |  | 9600Bd
 | 3 |  | 57600Bd
 | 4 |  | 1200Bd
 | 5 |  | 2400Bd
 | 6 |  | 4800Bd
33 | Mode |  |  | 2 | BC8x00
 | 0 |  | 7 data bits, even parity
 | 1 |  | 7 data bits, odd parity
 | 2 |  | 8 data bits, no parity
 | 3 |  | 8 data bits, even parity
 | 4 |  | 8 data bits, odd parity
34 | Number of stop bits |  |  | 0 | BC8x00
 | 0 |  | one stop bit
 | 1 |  | two stop bits


Topology

Fieldbus system [image] Topology
Topology
▪
Ring bus system with active coupling
▪
400 m between two fieldbus devices
▪
12.8 km total length
▪
max. number of devices 256
All Beckhoff Bus Couplers BK4xxx and BC4000 are remote bus devices and can only be operated as such on the INTERBUS.
Coupling modules
Examples for INTERBUS master controls:
PC cards:
Hilscher CIF 30-IBM
Hilscher CIF 40-IBM
Hilscher CIF 50-IBM
Hilscher CIF 60-IBM
Hilscher CIF 104-IBM
Phoenix IBS PC ISA SC/I-T
Phoenix IBS PC ISA SC/RI/RT-LK
Phoenix IBS PC PCI SC/I-T
Phoenix IBS PC PCI SC/RI/RT-LK
Modules:
Phoenix IBS S5 DCB/I-T
Phoenix IBS S5 DSC/I-T
Phoenix 100 CB-T


Propagation delay and reaction time of the Interbus

Fieldbus system [image] Propagation delay and reaction time of the Interbus
Propagation delay and reaction time of the Interbus
The transmission of the signals from the input into the controller and from the controller to the outputs is subject to a propagation delay. It is composed of a number of elements: Transmission from the controller into the master; transmission via the Interbus and transmission from the Bus Coupler to the outputs, this applies in the reverse order to the return path. Please refer to the master manufacturer's data for the reaction time from the controller to the master. The newly transmitted data only become valid after the complete transmission of a cycle. The reaction time TIBS on the INTERBUS is composed as follows. The constants SW, M, N and TBIT form the sum for the cycle time in milliseconds. The reaction in the worst case is 2 x cycle time, as the data only become valid after the end of the cycle.
TIBS = ( SW + (13 x ( 6 + N ) + 1.5 x M ) x TBIT ) x 2
SW = 0.2 ms
M = number of Bus Couplers
N = number of the effective byte lengths
TBIT = 0.002 ms
Observe the number of bytes and not the word length when calculating the times.
Delays in the case of transmission errors
Observe special delays in the case of transmission errors. The Interbus requires 5 cycle times before the next valid data can be exchanged.


Error handling and diagnosis

Error handling and diagnosis
Error handling and diagnosis
Additional information
•
Diagnostic LEDs
•
General errors


Diagnostic LEDs

Error handling and diagnosis [image] Diagnostic LEDs
Diagnostic LEDs
After switching on, the Bus Coupler immediately checks the connected configuration. Error-free start-up is indicated when the red I/O ERR LED goes out. If the I/O ERR LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.
The Bus Coupler has two groups of LEDs for the display of status. The upper group with four LEDs indicates the status of the respective fieldbus. The significance of the fieldbus status LEDs is explained in the appropriate sections of this manual. It corresponds to the usual fieldbus display.
On the upper right hand side of the Bus Couplers are two more green LEDs that indicate the supply voltage. The left hand LED indicates the presence of the 24 V supply for the Bus Coupler. The right hand LED indicates the presence of the supply to the power contacts.
BC4000 LEDs
LEDs for power supply diagnostics
LED | Meaning
Left LED off | Bus Coupler has no power
Right LED off | No power supply 24 VDC connected at the power contacts
LEDs for fieldbus diagnosis
The four upper left LEDs indicate the operating status of the INTERBUS communication.
Ready | BA | RC | RD | Meaning | Remedy
on | off | off | off | The Bus Coupler is operational |
on | on | on | off | Remote bus active Data transmission with master running |
on | off | on | off | Incoming remote bus connection is established, no communication |
on | on | off | on | Remote continuation bus is switched off due to cable fault or by the master | Find cable interruption or short circuit, switch over master
off | off | off | off | No function, power failure |
LEDs for K-bus diagnostics
Two LEDs, the "I/O LEDs", in the area below the fieldbus status LEDs referred to above, serve to indicate the operating status of the Bus Terminals and the connections to these terminals. The green LED lights up in order to indicate fault-free operation. "Error-free" means that the communication with the fieldbus system is also running. The red LED blinks with two different frequencies in order to indicate an error. The error is encoded in the blinks as follows:
Flashing Codes
Fast blinking | Start of the error code
First slow sequence | Error code
Second slow sequence | Error code argument
Start of the Error Code Error code Error argument
Error code | Error code argument | Description | Remedy
Persistent, continuous flashing |  | EMC problems | - Check power supply for overvoltage or undervoltage peaks - Implement EMC measures - If a K-Bus error is present, it can be localized by a restart of the coupler (by switching it off and then on again)
1 pulse | 0 | EEPROM checksum error | Enter factory settings with the KS2000 configuration software
 | 1 | Code buffer overflow | Insert fewer Bus Terminals. Too many entries in the table for the programmed configuration
 | 2 | Unknown data type | Software update required for the Bus Coupler
2 pulses | 0 | Programmed configuration has an incorrect table entry | Check programmed configuration for correctness
 | n (n > 0) | Table comparison (Bus Terminal n) | Incorrect table entry
3 pulses | 0 | K-bus command error | - No Bus Terminal inserted - One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses | 0 | K-bus data error, break behind the Bus Coupler | Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
 | n | Break behind Bus Terminal n | Check whether the KL9010 Bus End Terminal is connected
5 pulses | n | K-bus error in register communication with Bus Terminal n | Exchange the nth Bus Terminal
6 pulses | 0 ,n (n>0) | Data width more than 32 words at the Bus Coupler | Reduce the fieldbus data
7 pulses * | 0 | Note: cycle time was exceeded (see Table 1, Register 17) | Warning: the set cycle time was exceeded. This indication (flashing LEDs) can only be cleared by booting the Bus Coupler again. Remedy: increase the cycle time
9 pulses * | 0 | Checksum error in Flash program | Transmit program to the BC again
 | 1 | Incorrect or faulty library implemented | Remove the faulty library
10 pulses * | n | Bus Terminal n is not consistent with the configuration that existed when the boot project was created | Check the nth Bus Terminal. The boot project must be deleted if the insertion of an nth Bus Terminal is intentional.
14 pulses | n | nth Bus Terminal has the wrong format | Start the Bus Coupler again, and if the error occurs again then exchange the Bus Terminal
15 pulses | n | Number of Bus Terminals is no longer correct | Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software
16 pulses | n | Length of the K-bus data is no longer correct | Start the Bus Coupler again. If the error occurs again, restore the manufacturers setting using the KS2000 configuration software
The number of pulses in the fault segment indicates the position of the last Bus Terminal before the fault. Passive Bus Terminals, such as a power feed terminal without diagnostics, are not included in the count. When the error is rectified, the Bus Coupler does not stop flashing. The Bus Coupler stays in the "Stop" state. The Bus Coupler can only be re-started by switching the power supply off and on again. Insertion and removal of Bus Terminals is only permitted when switched off. The electronics in the Bus Terminals and in the Bus Coupler are protected to a large measure against damage, but incorrect function and damage cannot be ruled out if they are plugged in under power.


General errors

Error handling and diagnosis [image] General errors
General errors
Mapping of the digital and the byte-oriented Bus Terminals onto a fixed address
▪
Problem
You want a constant start address for the digital inputs and outputs.
▪
Solution
With the KS2000 software, you can enter an offset start value for the digital inputs and outputs in table 0. The byte-oriented Bus Terminals should not jut into this process image, i.e. no overlap should occur. Table 0: Register 19 Offset for digital outputs, Register 20 Offset for digital inputs: "0" is the default setting (automatic Bus Terminal mapping)
▪
Example
You have a KL3002 and a KL2012. In the default case, the KL3002 maps onto %IB0- %IB7 and %QB0-QB7 in the memory. The digital output terminal would now map to %QX8.0 and %QX8.1. As soon as you now plug another byte-oriented Bus Terminal, the process image of the digital Bus Terminal is moved to a higher memory. You can now pre-empt this by entering 20 in register 19. This means that KL2012 now maps onto %QX20.0 and %QX20.1.
Drop of the digital outputs
▪
Problem
Your digital outputs drop away.
▪
Solution
Your program takes longer than 100 ms. Because the internal K-Bus runs synchronous with your PLC program, it is no longer triggered early enough, and the Bus Terminal watchdog becomes active. This can be rectified by triggering a short refresh of the K-Bus. The setting can be carried out with the KS2000 software. Table 1 Register 17 LowByte cycle time for K-Bus refresh (<= 80 ms) HighByte Retries
▪
Recommendation
Enter 0x0350 in Table 1 Register 17. This means three retries, once every 80 ms. Note that this causes the Bus Terminal watchdog to increase to 240 ms during a fault condition (this is not true in case of a K-Bus error, where the watchdog will remain at 100 ms).


Appendix

Appendix
Appendix
Additional information
•
Bibliography
•
General operating conditions
•
Approvals
•
Test standards for device testing
•
List of Abbreviations
•
Support and Service


Bibliography

Appendix [image] Bibliography
Bibliography
Interbus
www.Interbusclub.com


General operating conditions

Appendix [image] General operating conditions
General operating conditions
The following conditions must be met in order to ensure flawless operation of the fieldbus components.
Environmental conditions
Operation
The components may not be used without additional protection in the following locations:
▪
in difficult environments, such as where there are corrosive vapors or gases, or high dust levels
▪
in the presence of high levels of ionizing radiation
Condition | Permissible range
Permissible ambient temperature during operation | see technical data
Installation position | variable
Vibration resistance | conforms to EN 60068-2-6
Shock resistance | conforms to EN 60068-2-27
EMC immunity | conforms to EN 61000-6-2
Emission | conforms to EN 61000-6-4
Transport and storage
Condition | Permissible range
Permissible ambient temperature during storage | -25°C... +85°C
Relative humidity | 95 %, no condensation
Free fall | up to 1 m in the original packaging
Protection classes and types
Condition | Permissible range
Protection class in accordance with IEC 536 (VDE 0106, Part 1) | A protective conductor connection to the profile rail is necessary!
Protection class conforms to IEC 529 | IP20 (protection against contact with a standard test finger)
Protection against foreign objects | Less than 12 mm in diameter
Protection against water | no protection
Component identification
Every supplied component includes an adhesive label providing information about the product's approvals. For sample, on the BK2000 Bus Coupler:
The following information is printed on the label:
Printed item | Meaning for this label
Precise product identification | Lightbus Coupler BK2000
Supply voltage Us | 24 VDC (Use a 4 A fuse or a Class 2 power supply to meet UL requirements)
Data transfer rate | 2.5 Mbaud
Manufacturer | Beckhoff Automation GmbH & Co. KG
CE mark | Conformity mark
UL mark | Mark for UL approval. UL stands for the Underwriters Laboratories Inc., the leading certification organization for North America, based in the USA. C = Canada, US = USA, UL file number: E172151
Production identification | From left to right, this sequence of characters indicates the week of production (2 characters), the year of production (2 characters), the software version (2 characters) and hardware version (2 characters), along with any special indications (4 characters). In this case the device is a BK2000 - produced in calendar week 9 - of 2001 - with firmware version BF - in hardware version 6 - without special designation


Approvals

Appendix [image] Approvals
Approvals
UL E172151
Conformity mark
CE
Protection class
IP20 conforms to EN60529


Test standards for device testing

Appendix [image] Test standards for device testing
Test standards for device testing
EMC
EMC immunity
EN 61000-6-2
Electromagnetic emission
EN 61000-6-4
Vibration / shock resistance
Vibration resistance
EN 60068-2-6
Shock resistance
EN 60068-2-27


List of Abbreviations

Appendix [image] List of Abbreviations
List of Abbreviations
IP (20)
Bus Terminal protection class
IPC
Industrial PC
I/O
Inputs and outputs
K-bus
Terminal bus
KS2000
Configuration Software
PE
The PE power contact can be used as a protective earth.
TwinCAT
The Windows Control and Automation Technology


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com