AX5000 - Digital servo drives 2. generation

BECKHOFF Drive Technology

Operating instructions

Servo Drives AX5000

(2nd generation: serial number ≥ 100.000)

Version: 1.2

Date: 2015-01-22
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


AX5000 - Table of contents

BECKHOFF Automation: AX5000 - Digital servo drives 2nd generation

Table of contents - AX5000 2nd generation

Chapter
Cover
Table of contents

Foreword
Notes on the documentation
Safety Instructions
Special safety instructions for AX5000
Appropriate use
Guidelines and Standards
Copyright
Documentation issue status
New functions – AX5000 with hardware 2

Product overview
Introduction
General overview
Technical data
Type code and name plate
Equipment
Dimensions

Installation
Transport and storage
Mechanical installation
Mounting
Electrical installation
Overview
Power supply
EtherCAT
Digitale I/Os
I/O plug connector - ZS4500
Feedback
Motor
External brake resistor

Commissioning
Important information for commissioning
Basic Principles
Parameter-Handling
First steps
EtherCAT synchronisation
Operating modes
Drive function
Diagnosis during commissioning
Reference Movement
Probe Unit
Homing
Homing
Special characteristics in hardware end positions
Probe Unit function
Display and navigation rocker
Motor Brake Management
Commutation methods
OCT
General commissioning of a motor with OCT feedback
Diagnosis of the operation of a motor with OCT feedback
Asynchronous motors - Special functions
Maintenance

Extended functions
Modulo
Control quality - internal filters
Parameter set switchover

Shutting down
Shutting down

Integrated safety
Safety-Card AX5801

Accessories
AX-Bridge quick connection system
AX5021 brake module
External Brake Resistor - AX2090-BW5x
Motor choke AX2090-MD50
Mains filter AX2090-NF50
Optional encoder card AX5701 / AX5702
Cables
Order key for motor and feedback cables
Motor cables
Extension for motor cables
Feedback cables for Beckhoff motors
Extension for feedback cables for Beckhoff motors
Special motor connections

Project planning
Project planning – important information

Appendix
Fault management
Firmware Update
The Beckhoff automation system
Overview
EtherCAT-System structure
EtherCAT-System Properties
EtherCAT-Wiring
EtherCAT-State Machine
EtherCAT as drive bus
Support and Service


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to environment and devices
If you do not adhere the notice adjoining this symbol, there is obvious hazard to environment and devices.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.
UL Pointer
This symbol indicates important information about the UL-compliant.


AX5000 - Special safety instructions for AX5000

BECKHOFF Automation: Foreword

Special safety instructions for AX5000

The safety instructions are designed to avert danger and must be followed during installation, commissioning, production, troubleshooting, maintenance and trial or test assemblies.

The servo drives of the AX5000 series are not designed for stand-alone operation and must always be installed in a machine or system. After installation the additional documentation and safety instructions provided by the machine manufacturer must be read and followed.

WARNING 		Serious risk of injury through high electrical voltage!
  • Never open the servo drive when it is live. Wait until the DC link capacitors are discharged. The voltage measured between the DC+ and DC- terminals (X02) must have fallen below 50 V. Opening the device (with the exception of expansion card slots) invalidates all warranty and liability claims against Beckhoff Automation GmbH.
  • Negligent, improper handling of the servo drive and bypassing of the safety devices can lead to personal injury or death through electric shock.
  • Ensure that the protective conductor is connected properly.
  • Disconnect the servo drive from the mains supply and secure it against reconnection before connecting or disconnecting the pluggable terminals.
  • Disconnect the servo drive from the mains supply and secure it against reconnection before working on electrical parts with a voltage > 50 V.
  • The DC link voltage can exceed 890 V. Wait until the DC link capacitors are discharged before touching live terminals. The voltage measured between the DC+ and DC- terminals (X02) must have fallen below 50 V.

WARNING 		Danger of injury due to uncontrolled movements!
Read and take note of chapter 'Important information for commissioning' each time before commissioning the AX5000.

WARNING 		Serious risk of injury through hot surfaces!
  • The surface temperature may exceed 50 °C, resulting in a risk of burns.
  • Avoid touching the case during or shortly after operation.
  • Leave the servo drive to cool down for at least 15 minutes after it is switched off.
  • Use a thermometer to check whether the surface has cooled down sufficiently.

CAUTION 		Hazard to persons!
  • Carefully read this manual before using the servo drive thoroughly, paying particular attention to the safety instructions. In the event of any uncertainties please notify your sales office immediately and refrain from working on the servo drive.
  • Only well trained, qualified electricians with sound knowledge of drive equipment may work on the device.
  • During the electrical installation it is essential to ensure that the correct fuses/protective circuit breakers are used between the mains supply and the servo drive. Further information can be found in the "Electrical installation" section.
  • If a servo drive is installed in a machine it must not be commissioned until proof of compliance of the machine with the latest version of the EC Machinery Directive has been provided. This includes all relevant harmonised standards and regulations required for implementation of this Directive in national legislation.

Attention 		Hazard to equipment and environment!
  • During installation it is essential to ensure that the specified ventilation clearances and climatic conditions are adhered to. Further information can be found in the "Technical data" and "Mechanical installation" sections.
  • If the servo drive is operated in contaminated ambient air, the cooling openings must be checked regularly for blockage. These checks should be carried out several times per day.
  • The servo drives contain components at risk from electrostatic discharge caused by improper handling:
    - Please ensure you are electrostatically discharged before touching the servo drive directly.
    - Avoid contact with highly insulating materials (synthetic fibres, plastic film etc.).
    - Place the servo drive on a conductive surface.
    - Do not touch the motor plug during operation of the AX5000.


AX5000 - Appropriate use

BECKHOFF AX5000: Foreword

Appropriate use

The servo drives of the AX5000 series are exclusively designed for torque, speed and position control of suitable asynchronous and synchronous three-phase current motors. The maximum permissible effective motor voltage must be at least equal the effective mains voltage fed into the servo drive.

The servo drives from the AX5000 series are designed for installation as components in electrical systems or machines and may be operated only as integrated system or machine components.

WARNING 		Caution – Risk of injury!
Electronic equipment is not fail-safe. The machine manufacturer is responsible for ensuring that the connected motors and the machine are brought into a safe state in the event of a fault in the drive system.

The servo drives may only be operated in enclosed control cabinets and in accordance with the conditions described in the "Technical data" section.

Dual Use (EU 1382/2014)

As published on December 30, 2014 by EU Commission Delegated Regulation 1382/2014, standard frequency inverters – and with that also Beckhoff products AX5000 – become newly classified Dual-Use items: the item list Annex I of the Dual-Use Council Regulation 428/2009 has been changed accordingly, Frequency inverters (listed in item position 3A225) with a „ rotation field frequency of 600 Hz or more“ are now export controlled items. As a consequence some modifications have to be noticed.

Firmware versions without extension (Dual Use conform) can be used in consideration of Hardware Versions with following drives only:

  • HW Version 1.0 (AX5xxx-0000-x0xx): Serial Number < 68.000
  • HW Version 2.0 (AX5xxx-0000-x20x): Serial Number < 140.000
  • HW Version 2.0 (AX5xxx-0000-x21x)

This Firmware versions with extension (Dual Use conform) can be used in consideration of Hardware Versions with all drives. These versions support both rotational field frequency bands (<600 Hz, >= 600 Hz) depending on product hardware. For products with option „x21x“, shipment as single part may be subject to export control regulations.


AX5000 - Guidelines and Standards

BECKHOFF AX5000: Foreword

Guidelines and Standards

CE conformity

The servo drives of the AX5000 series comply with the

  • • EC Low-Voltage Directive, 2006/95/EC

Applied harmonised standards:

EN 60204-1

EN 50178

CAUTION 		Hazard to persons!
Servo drives are not covered by the EC Machinery Directive. Operation of the servo drives in machines or systems is only permitted once the machine or system manufacturers has provided evidence of CE conformity of the complete machine or system.

Electromagnetic compatibility

The servo drives of the AX5000 series comply with the

  • 2004/108/EC EMC Directive

Applied harmonised standards:

IEC / EN 61000-4-2

IEC / EN 61000-4-3

IEC / EN 61000-4-4

IEC / EN 61000-4-5

IEC / EN 61000-4-6

IEC / EN 61000-6-1

IEC / EN 61000-6-2

IEC / EN 61000-6-3

IEC / EN 61000-6-4

IEC / EN 61800-3

UL Listing

The following servo drives from the AX5000 series have a UL-Listing and must bear the UL symbol

AX5000 with UL-Listing!
AX5101, AX5103; AX5106, AX5112, AX5201, AX5203 and AX5206

on the name plate. If you wish to operate an AX5000 in an economic area that requires a UL-Listing, please check that there is a UL symbol on the name plate.

Below is a list of the relevant chapters that are amended with respect to the UL-Listing. Furthermore, UL-specific remarks are listed. It is essential to observe these specifications.

UL-specific chapter changes

“Mains supply connection (X01)”

AX5000 shall be connected only to a grounded wye-source where the maximum voltage does not exceed 277 V to ground.

“Connection of several servo drives to form a drive system”

Drive system with UL-Listing!
Please consult our Application Department with respect to the requirements for a drive system with UL-Listing.

UL-specific chapter

“External protection, UL-compliant”

Integral solid state short circuit protection does not provide branch circuit protection. Branch circuit protection must be provided in accordance with the Manufacture Instructions, National Electrical Code and any additional local codes.

Suitable for use on a circuit capable of delivering not more than 18000 rms symmetrical amperes, 480 V maximum, when protected by RK5 class fuses.

Single-phase:

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
AC-supply (max.) *) | 6 A | 12 A | 20 A | 12 A | 20 A | 20 A
24 V-supply (max.) | 3 A
Brake resistor | electronic

*) Mains fuses according to type “RK5” must be used.

Three-phase:

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5201 | AX5203 | AX5206
AC-supply (max.) *) | 6 A | 12 A | 20 A | 20 A | 12 A | 20 A | 20 A
24 V-supply (max.) | 3 A
Brake resistor | electronic

*) Mains fuses according to type “RK5” must be used.

AX5112
When protected by RK5 class fuses: Rated 20 A, min. 480 V

UL-specific notes

Use in a Pollution Degree 2 environment.

Use 75 °C Copper Conductors min..

Control Board rating = 24 V

Drive intended for use over a range of motor sizes. Internal motor overload protection level is adjustable:

The internal motor protection is parameterised via the IDN P-0-0062 “Thermal motor model”, based on the value of the IDN S-0-0111 “Motor continuous stall current”. The IDN P-0-0062 “Time constant” is specified by the motor manufacturer and must be entered here. The IDN P-0-0062 “Warning limit” (Default) is responsible for deciding when a warning is to be generated. The IDN P-0-0062 “Error limit” (Default) is responsible for deciding when the motor is to be switched off. The default values take into account the specific characteristics of the servomotors.

Electrical isolation according to EN 50178 / VDE 0160

The power section (motor connection, DC link connection and mains connection) and the control unit are doubly insulated against each other, so that safe protection against accidental contact is ensured at all terminals of the control unit without additional measures. The air and creepage distances also meet the requirements of the above standard.


AX5000 - Copyright

BECKHOFF AX5000: Foreword

Copyright

© This manual is subject to copyright. Any reproduction or third party use of this publication, whether in whole or in part, without the written permission of Beckhoff Automation GmbH, is forbidden.

  • Windows is a registered trademark of Microsoft Corp.
  • HIPERFACE is a registered trademark of Max Stegmann GmbH
  • EnDat is a registered trademark of Dr. Johannes Heidenhain GmbH
  • SERCOS interface ™ is a registered trademark of SERCOS interface e.V.


AX5000 - Documentation issue status

BECKHOFF AX5000: Foreword

Documentation issue status

This documentation only describes AX5000 hardware version 2

Version | Comment
1.2 | Dual Use notes amended
1.1 | Dual Use notes added
1.0 | First published

Scope of the documentation

The overall documentation package for the AX5000 is comprised of the following manuals:

  • User documentation
  • Description of drive parameters (IDN)
  • Description of diagnostic messages


AX5000 - New functions - hardware 2

BECKHOFF AX5000: Foreword

New functions – AX5000 with hardware 2

AX5000 with hardware version 2

The AX5000s with hardware version 2 are marked with ‘0200’ (1) in the catalogue number. The catalogue number can be found on the name plates.

Overview of functions

The functions for which hardware 2 is exclusively required are listed below.

Function | Available from firmware | Documented
Modulo | 2.03
Yes
Parameter set switchover | 2.03
Yes
Control quality - internal filters: 1st and 2nd order IIR filter – Infinite Impulse Response Filter Notch filter (band-stop filter) 1st order low pass filter 1st order phase correction filter | 2.03
Yes
Display and navigation rocker | 2.03
Yes
Commissioning and diagnosis of a motor with OCT feedback | 2.04
Yes
Fast network switchover | 2.04
No
Lowering of the pulse frequency by 4 KHz | 2.04
No
Modified pulse pattern | 2.04
No
Torque correction | 2.04
No
Display of the speed/torque curve in the TCDriveManager | 2.04
No


AX5000 - Introduction

BECKHOFF AX5000: Product overview

General

Introduction

The AX5000 series is available in single- or multi-channel design and is optimised in terms of function and cost-effectiveness. Integrated control technology supports fast and highly dynamic positioning tasks. EtherCAT as a high-performance system communication enables ideal interfacing with PC-based control technology.

The AX51xx single-channel servo drives are designed for rated motor currents up to 40 A.
The AX52xx two-channel servo drive enables operation of two motors with identical or even with different capacity, up to a total current of 12 A. The multi-axis drives with variable motor output allocation optimise packaging density and the cost per drive channel.

The AX5000 system enables simple and fast connection of several AX5000 devices to form a multi-axis system through the AX-Bridge quick connection system. The pluggable supply and connection module combines power supply, DC link, and control (24 VDC) and braking voltage.

A wide range of motor types can be connected to the AX5000. Motors of different size and type can be connected without additional measures. Examples include synchronous, linear, torque and asynchronous motors. The multi-feedback interface supports all common feedback standards such as BiSS, EnDat, 1 Vss, TTL, resolver.

The AX5000 was developed specifically for the EtherCAT real-time Ethernet system. The outstanding features of EtherCAT are particularly beneficial for drive technology. They include short cycle time, synchronicity and simultaneity. EtherCAT enables very short cycle times, even in networks containing a large number of devices.

Properties

  • high-speed EtherCAT system communication
  • wide voltage range: 1 x 100-10% VAC - 1 x 240+10% VAC … 3 x 100-10%VAC - 3 x 480+10% VAC
  • active DC link and brake energy management (in preparation)
  • multi-feedback interface
  • flexible motor type selection
  • scalable wide range motor current measurement
  • high-speed capture inputs
  • diagnostic and parameter display
  • integrated mains filter
  • optional safety functions: restart lock, intelligent TwinSAFE safety functions (in preparation)
  • compact design for simple control cabinet installation
  • AX-Bridge - the quick connection system for power supply, DC link and control voltage
  • variable cooling concept (in preparation)

The integrated, fast AX5000 control technology with a current control cycle of up to 31.25 µs supports fast and highly dynamic positioning tasks. The drives are designed as single- or two-channel servo drives:

  • AX51xx: single-channel servo drive
    rated motor current: 1 A, 3 A, 6 A, 12 A, 18 A, 25 A, 40 A
  • AX52xx: two-channel servo drive
    rated motor current: 2 x 1 A, 2 x 3 A, 2 x 6 A (with flexible allocation of total device current on both axes)

The two-channel servo drives with variable motor output allocation enable operation of two motors with identical or different capacity with the same servo drive. For example, an asynchronous motor with a rated current of 1 A and a linear motor with a rated current of 9 A can be operated with a servo drive with two 6 A channels. The total current is relevant for the device utilisation.

The AX-Bridge enables convenient and fast connection of several servo drives from the AX5000 range to form a drive system. This pluggable supply and connection module combines power supply, DC link and control (24 VDC) and enables fast installation and commissioning.

The AX5000 offers flexible and universal connection options. It supports

  • almost all feedback systems, including robust resolvers, sine/cosine encoders with EnDat, Hiperface or BiSS, and
  • a wide range of motor types such as asynchronous, synchronous, torque or linear motors.

Wide voltage range

In order to facilitate worldwide application with different voltage systems, the AX5000 features a wide voltage range. Between 1 x 100 VAC and 3 x 480 VAC almost any voltage system can be connected to one and the same device. This reduces stock-keeping and prevents destruction through unsuitable mains voltage. Examples for different mains systems:

  • 1 x 100 VAC, 3 x 200 VAC for Asia
  • 1 x 115 VAC, 3 x 230 VAC, 3 x 480 VAC for North America
  • 1 x 220 VAC, 3 x 380 VAC for China
  • 1 x 230 VAC, 3 x 400 VAC for Europe

Variable motor interface

The AX5000 supports the connection of different motor types, ranging from standard asynchronous motors to ironless linear motors:

Motor type Operating mode and limits
Brushless synchronous motors
  • Servo mode with feedback
Torque motors
  • Multiple servomotors with high torque and relatively low speed
Linear motors (iron core)
  • Servo mode with feedback
Linear motors (ironless)
  • Servo mode with feedback
Asynchronous motor
  • Frequency converter mode without feedback
  • High-frequency spindle up to 60,000 rpm
  • Servo mode with feedback

Multi-feedback interface

AX5000 offers interfaces for all common feedback systems. No additional interface cards are required.
Connection options:

  • One Cable feedback system
  • Sine / cosine 1 Vpp
  • EnDAT, single- and multi-turn
  • Hiperface, single- and multi-turn
  • BiSS, single- and multi-turn
  • Resolver, 2-pole - 8-pole
  • TTL encoder
  • Support for electronic motor name plates


AX5000 - General overview

BECKHOFF AX5000: Product overview

General overview (AX5101 - AX5112 and AX520x)

The servo drive shown below is a two-channel device designed for a maximum current of 12 A. Components that are only available for the second channel are identified in the item description.

Item descriptions:

No. | Designation
1 | X11 - feedback connection, encoder
2 | X12 - feedback connection, resolver
3 | X21 - feedback connection, encoder channel B (only for two-channel unit)
4 | X22 - feedback connection, resolver channel B (only for two-channel unit)
5 | X03 - optional slot for safety card X4x - optional slot for expansion cards
6 | Navigation rocker
7 | Status LED for EtherCAT output
8 | Labeling field
9 | X05 - socket for EtherCAT output
10 | X03 - power supply 24 V DC input
11 | X14 - sensor for motor temperature and brake
12 | X24 - sensor for motor temperature and brake channel B (only for two-channel unit)
13 | X23 - motor connection (U, V, W, PE) channel B (only for two-channel unit)
14 | X13 - motor connection (U, V, W, PE)
15 | X01 - mains supply 100 – 480 V
16 | X02 - DC link output (890 V DC voltage) Connection for the external brake resistor
17 | WARNING | Max. 890 V DC voltage at the DC link terminals (X02). Dangerous voltage may be present for 5 minutes after the device is switched off. The device is safe once the voltage has fallen below 50 V.
18 | X04 - socket for EtherCAT input
19 | Labelling field
20 | Status LED for EtherCAT input
21 | Display
22 | X06 - connection for digital inputs and outputs

General overview (AX5118, AX5125 und AX5140)

The servo drive illustrated below is an AX5140; the devices with 18 A or 25 A are structurally similar apart from pos. 11 "X07" (external brake resistor).

No. | Designation |  | No. | Designation
1 | X11 - feedback connection, encoder |  | 11 | X07 - external brake resistor (only AX5140)
2 | X12 - feedback connection, resolver |  | 12 | X13 - motor connection (U, V, W, PE)
3 | X3x - optional slot for safety card X4x - optional slot for expansion cards |  | 13 | X01 - mains supply 100 – 480 V
4 | Navigation rocker |  | 14 | X02 – X02 - DC link output (Max. 890 V DC voltage) Connection for the external brake resistor (only AX5118 and AX5125)
5 | Status LED for EtherCAT output |  | 15 | X04 - socket for EtherCAT input
6 | Labeling field |  | 16 | Labeling field
7 | X05 - socket for EtherCAT output |  | 17 | Status LED for EtherCAT input
8 | X03 - power supply 24 V DC input |  | 18 | Display
9 | WARNUNG | Max. 890 V DC voltage at the DC link terminals (X02). Dangerous voltage may be present for 5 minutes after the device is switched off. The device is safe once the voltage has fallen below 50 V. | 19 | X06 - connection for digital inputs and outputs
10 | X14 - sensor for motor temperature and brake |  |  |

Tightening torques

Plug | Tightening torque
X01; X02; X03; X13; X23 | 0.5 - 0.6 Nm


AX5000 - Technical data

BECKHOFF AX5000: Product overview

Technical data

UL Listing
It is essential to observe chapter "Product overview-->Guidelines and Standards-->UL-Listing" if you wish to operate an AX5000 in an economic area that requires a UL-Listing.

Permitted environmental conditions and operating conditions

Technical data | AX5000
Ambient temperature during operation | 0 °C to +50 °C
Ambient temperature for transportation / storage | -25 °C to +70 °C
Air humidity | 5 % to 95 %, non-condensing
Contamination level | Contamination level 2 according to EN 60204 / EN 50178
Corrosion protection | Under extreme operating conditions, special measures must be agreed with the manufacturer, and implemented by the user.
Operating altitude | up to 1000 m above sea level
Permissible installation position | vertical
Ventilation | Total rated device current ≤3 A: free convection, Total rated device current >3 A: built-in temperature-controlled fan
Protection class | IP20
Vibration test (EN 60068-2-6) | Frequency range: 10 - 500 Hz Amplitude: 10 - 58 Hz = 0,075mm pk-pk 59 - 500 Hz = 1 g
Shock test (EN 60068-2-27) | Half sine wave Amplitude : 5 g Duration: 30 ms Number of shocks: 3 per axis and direction (total. 18 shocks)
Shock test (EN 60068-2-27) | Half sine wave Amplitude : 5 g Duration: 30ms Number of shocks: 1000 per axis and direction (total. 6000 shocks)
EMC / radio interference* | Category C3: standard Category C1, C2: auxiliary filter required
Approvals | CE
Special operating conditions | The usability of Beckhoff servo drives from the AX5000 type series under harsh operating conditions or other unfavourable conditions must be ascertained individually in consultation between the manufacturer and the user.

Electrical data - Single-channel servo drive (AX5101 - AX5106)

Single-phase connection

Technical data | AX5101 | AX5103 | AX5106
Rated output current | 1.5 A | 3 A | 4,5 A
Minimum rated motor current at full current resolution | 0.35 A | 1 A | 1 A
Peak output current (1) | 4.5 A | 7.5 A | 13 A
Rated supply voltage | 1 x 100-10% - 240+10% VAC
max. DC link voltage | 890 VDC
Rated apparent power (choices) 120 V 230 V | 0.3 kVA 0.6 kVA | 0.6 kVA 1.2 kVA | 1.2 kVA 2.4 kVA
Power loss (2) | 35 W | 50 W | 85 W
Continuous braking power (internal brake resistor) | 50 W | 50 W | 150 W
Max. braking power (internal brake resistor) | 14 kW
Min. brake resistor (external brake resistor) | 47 W
Max. braking power (external brake resistor) | 15 kW

(1) Irms for max. 7 s

(2) S1 mode incl. power supply, without braking chopper

Electrical data - Single-channel servo drive (AX5101 - AX5140)

Three-phase connection

Electrical data | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125 | AX5140
Rated output current | 1,5 A | 3 A | 6 A | 12 A | 18 A | 25 A | 40 A
Minimum rated motor current at full current resolution | 0,35 A | 1 A | 1 A | 6 A | 12 A | 12 A | 18 A
Peak output current (1) | 4,5 A | 7,5 A | 13 A | 26 A | 36 A | 50 A | 80 A (2)
Rated supply voltage | 3 x 100-10% - 480+10% VAC
max. DC link voltage | 890 VDC
Rated apparent power (choices) 120 V 230 V 400 V 480 V | 0,3 kVA 0,6 kVA 1,0 kVA 1,2 kVA | 0,6 kVA 1,2 kVA 2,1 kVA 2,5 kVA | 1,2 kVA 2,4 kVA 4,2 kVA 5,0 kVA | 2,5 kVA 4,8 kVA 8,3 kVA 10 kVA | 3,4 kVA 7,2 kVA 12,5 kVA 15 kVA | 4,8 kVA 10 kVA 17,3 kVA 20,8 kVA | 8,3 kVA 16 kVA 28 kVA 33 kVA
Power loss (3) | 35 W | 50 W | 85 W | 160 W | 255 W | 340 W | 510 W
Continuous braking power (internal brake resistor) | 50 W | 50 W | 150 W | 90 W | 200 W | 200 W | 150 W
Max. braking power (internal brake resistor) | 14 kW |  |  |  | 26 kW | 26 kW | 26 kW
Min. brake resistor (external brake resistor) | 47 W | 47 W | 47 W | 30 W | 22 W | 22 W | 22 W (4)
Max. braking power (external brake resistor) | 15 kW | 15 kW | 15 kW | 23,5 kW | 32 kW | 32 kW | 46 kW

(1) Irms for max. 7 s

(2) Ieff for max. 7 s, if rotating field frequency >3 Hz at max. 40°C
(3) S1 mode incl. power supply, without braking chopper
(4) Brake resistor < 22 W –> Please consult our Application Department

Electrical data - Two-channel servo drive (AX52xx)

Single-phase connection

Electrical data | AX5201 | AX5203 | AX5206
Rated output current / channel | 1.5 A | 3 A | 6 A
Minimum rated channel current at full current resolution | 0.35 A | 1 A | 1 A
Maximum rated channel current at full current resolution | 3 A | 4.5 A | 9 A
Total rated output current at full current resolution | 3 A | 4.5 A | 9 A
Maximum Peak output current (1) / channel | 5 A | 10 A | 13 A
Peak output current (1) total device current | 10 A | 20 A | 26 A
Rated supply voltage | 1 x 100-10% - 240+10% VAC
max. DC link voltage | 890 VDC
Rated apparent power (choices) 120 V 230 V | 0.6 kVA 1.2 kVA | 1.2 kVA 2.4 kVA | 2.5 kVA 4.8 kVA
Power loss (2) | 55 W | 85 W | 160 W
Continuous braking power (internal brake resistor) | 50 W | 150 W | 90 W
Max. braking power (internal brake resistor) | 14 kW
Min. brake resistor (external brake resistor) | 47 W
Max. braking power (external brake resistor) | 15 kW

(1) Irms for max. 7 s

(2) S1 mode incl. power supply, without braking chopper

Electrical data - Two-channel servo drive (AX52xx)

Three-phase connection

Electrical data | AX5201 | AX5203 | AX5206
Rated output current / channel | 1.5 A | 3 A | 6 A
Minimum rated channel current at full current resolution | 0.35 A | 1 A | 1 A
Maximum rated channel current at full current resolution | 3 A | 6 A | 9 A
Total rated output current at full current resolution | 3 A | 6 A | 12 A
Maximum Peak output current (1) / channel | 5 A | 10 A | 13 A
Peak output current (1) total device current | 10 A | 20 A | 26 A
Rated supply voltage | 3 x 100-10% - 480+10% VAC
max. DC link voltage | 890 VDC
Rated apparent power (choices) 120 V 230 V 400 V 480 V | 0,6 kVA 1,2 kVA 2,1 kVA 2,5 kVA | 1,2 kVA 2,4 kVA 4,2 kVA 5,0 kVA | 2,5 kVA 4,8 kVA 8,3 kVA 10,0 kVA
Power loss (2) | 55 W | 85 W | 160 W
Continuous braking power (internal brake resistor) | 50 W | 150 W | 90 W
Max. braking power (internal brake resistor) | 14 kW
Min. brake resistor (external brake resistor) | 47 W
Max. braking power (external brake resistor) | 15 kW

(1) Irms for max. 7 s

(2) S1 mode incl. power supply, without braking chopper

Mechanical data - Single-channel servo drive (AX5101 - AX5140)

Mechanical data | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125 | AX5140
Weight | approx. 4 kg | approx.4 kg | approx.5 kg | approx. 5 kg | approx.11 kg | approx.11 kg | approx.13 kg
Width | 92 mm |  |  |  | 185 mm | 185 mm | 185 mm
Height without plugs | 274 mm
Depth without plugs | 232 mm

Mechanical data - Two-channel servo drive (AX52xx)

Mechanical data | AX5201 | AX5203 | AX5206
Weight | approx. 5 kg | approx. 6 kg | approx. 6 kg
Height without plugs | 274 mm
Width | 92 mm
Depth without plugs | 232 mm


AX5000 - Type code and Name plates

BECKHOFF AX5000: Product overview

Type code and Name plates

Type code

AX5xyz-a b c d - efgh
AX | Beckhoff product line: Servo drive
5 | Type series: 5000
X | No. of channels: 1 = single-channel 2 = two-channel
YZ | Nominal current per channel: Single-channel devices 01, 03, 06, 12, 18, 25, 40, 60, 72, 90 or: 91 = 110 A 92 = 143 A 93 = 170 A Two-channel devices: 01, 03, 06
-a | ---
bc | Hardware features: 00 = Standard 01 = Cold plate design with enclosed housing 02 = Auxiliary fan for devices that are normally supplied without fan (e.g. AX5201)
d | reserved
e | Version: 0 = Standard version 1 = Custom version (see key)
f | Hardware version 0 = 1st generation 2 = 2nd generation
gh | Internal number

Name plates

The servo drive features two name plates.

  • Large name plate:
  • Small name plate:
 The large name plate attached at the side of the servo drive and includes the following information.

The second name plate is attached to the upper mounting flange mounted and is designed to show the main, even if several AX5000 are installed directly side by side. The small name plate contains the following information.

1 | Catalog number | 6 | Output rated voltage | 11 | Customer-specific
2 | Max. ambient temperature | 7 | Output rated current | 12 | wye-source only
3 | Input rated voltage | 8 | Output frequency range | 13 | CE - Conform
4 | Input rated current | 9 | Protection class | 14 | UL - Listed
5 | Input frequency | 10 | Serial number |  |


AX5000 - equipment

BECKHOFF AX5000: Product overview

Equipment

Scope of delivery

The AX5000 is supplied as follows:

  • AX5000 in the performance class according to the order
  • Plug connector
    X01: for mains input
    X02: for DC link (not at AX5140)
    X03: for DC power supply (24 V)
    X06: for digital inputs and outputs
    X07: external brake resistor (only AX5140)
  • Short description (Startup)
  • Documentation on CD-ROM

Note 		Connectors
The D-Sub connectors X11, X12, X21, X22 (for feedback cable and resolver/Hall) and the motor and sensor connectors X13, X14, X23, X24 are not part of the scope of delivery of the servo drive.
However, they are included with pre-assembled motor and feedback cables.

Accessories

Accessories with UL-Listing!
If you wish to operate an AX5000 in an economic area that requires a UL-Listing, please make sure that the accessories also have a UL-Listing.

The following optional accessories are available (see Beckhoff main catalog or www.beckhoff.de):

  • Motor and feedback cable (ready-made )
  • Motor and feedback cable sold by the metre
  • D-Sub connector X11, X12, X21, X22 individual (for feedback cable and resolver/Hall)
  • Motor and sensor connector X13, X14, X23, X24
  • EtherCAT bus cable, ready-made or sold by the metre
  • Synchronous servomotors (linear or rotational)
  • External ballast resistor
  • Expansion cards
  • Additional modules


AX5000 - Dimensions

BECKHOFF AX5000: Product overview

Dimensions

AX5000 as single device

All dimensions in millimeters.


AX5000 - Transport and storage

BECKHOFF AX5000: Installation

Transport and storage

Transport

  • Only by qualified personnel
  • Only in recyclable original manufacturer's packaging
  • Avoid sharp impacts
  • Temperature: -40...+70°C, varying no faster than 20K / hour
  • Air humidity: relative humidity max. 95%, non-condensing
  • The servo drives contain components at risk from electrostatic discharge caused by improper handling.
    - Please ensure you are electrostatically discharged before touching the servo drive directly.
    - Avoid contact with highly insulating materials (synthetic fibres, plastic film etc.).
    - Place the servo drive on a conductive surface.
  • If the packaging is damaged check the AX5000 and any accessories for visible damage. Inform the transport company and, if necessary, the manufacturer.

Packaging

  • Recyclable carton with inserts
  • Dimensions:
    AX5000 (H x W x D) 348 x 324 x 175 mm
    Identification: Device name plate on the outside of the carton

Storage

  • The AX5000 and its accessories must not be stored outdoors. The storage space must be adequately ventilated and dry.
  • The devices must be stored in the recyclable original manufacturer's packaging.
  • The servo drives contain components at risk from electrostatic discharge caused by improper handling.
    - Please ensure you are electrostatically discharged before touching the servo drive directly.
    - Avoid contact with highly insulating materials (synthetic fibres, plastic film etc.).
    - Place the servo drive on a conductive surface.
  • Max. stack height 8 cartons
  • Storage temperature: - 40...+ 55° C, varying no faster than 20 K / hour
  • Atmospheric humidity: relative humidity max. 95%, non-condensing
  • Duration of storage:
    < 5 years: without limitation

    Attention     		Destruction of the devices!
    On no account must the device be connected to 400 V if the DC link capacitors have lost their forming.
    The capacitors must be reformed (see below).
    > 5 years: The dielectric (an oxidation layer with a thickness of approx. 1 µ) in the DC link capacitors degrades over time, and the capacitors lose their forming.
    Prior to commissioning of the servo drive the capacitors must be reformed. Release all electrical connections and feed the servo drive for about 30 minutes with 230 VAC (single-phase) at terminals L1/L2 or L2/L3.


AX5000 - Mechanical installation

BECKHOFF AX5000: Installation

Mechanical installation

WARNING 		Caution – Risk of injury!
  • The servo drives may only be installed by trained, qualified personnel. The qualified personnel must know and comply with the national accident prevention regulations.
  • Safety boots must be worn.

WARNING 		Caution - Risk of injury through electric shock!
De-energise all electrical components (servo drive, control cabinet, etc.) before commencing the installation or deinstallation.

Attention 		Destruction of the servo drive!
  • Always install the servo drive vertically
  • Provide adequate ventilation for the servo drive. The permissible ambient conditions are specified in the "Technical data" section.
  • It is essential to adhere to the required distances (see diagrams below).

Installation examples

WARNING 		Caution - Risk of injury through electric shock!
Take care that the mounting plate is earthed (grounded) properly.

Attention 		Grounding!
If the ground connection of the AX5000 is not done as specified it is possible to get trouble with some EMC issues.


AX5000 - Electrical installation

BECKHOFF AX5000: Installation

Electrical installation

UL Listing
It is essential to observe chapter "Product overview-->Guidelines and Standards-->UL-Listing" if you wish to operate an AX5000 in an economic area that requires a UL-Listing.

WARNING 		Caution – Risk of injury!
  • The servo drives may only be installed by trained, qualified personnel. The qualified personnel must know and comply with the national accident prevention regulations.
  • Safety boots must be worn.

WARNING 		Caution - Risk of injury through electric shock!
De-energise all electrical components (servo drive, control cabinet, etc.) before commencing the installation or deinstallation.

DANGER 		Serious risk of injury through electric shock!
Due to the DC link capacitors dangerous voltage may persist at the DC link contacts "X02" after the servo drive has been disconnected from the mains supply. After disconnecting the servo drive wait 5 minutes and measure the voltage at the DC link contacts DC+ and DC-. The device is safe once the voltage has fallen below 50 V.

WARNING 		Caution - Risk of injury through electric shock!
  • Before installation, wiring and commissioning it is essential to read the section on "Safety".
  • Before installing, uninstalling or connecting the servo drive and the motors please note the following:
    - Remove all relevant mains fuses.
    - Switch off the main system switch and secure it with a lock.
    - Put up a warning sign.
  • The control and power connections for the motors may be live, even if the motor is prevented from rotating by the internal brake.

CAUTION 		Destruction of the AX5000!
  • Check the rated voltage and current of the servo drive and the connected motors.
  • When the AX5000 is disconnected from the mains supply (emergency stop, mains contactor etc.), wait at least 3 minutes before starting again or query the status of the IDN "P-0-0205" (see documentation of the “IDN-Description”).

Connection example

The following diagram shows a typical connection diagram for a two-axis device. Motor 1 features an absolute encoder, motor 2 a resolver:


AX5000 - Electrical installation - Power supply

BECKHOFF AX5000: Installation

Power supply

WARNING 		Risk of injury!
The electrical installation must be carried out by a qualified electrician.

Before installing and commissioning AX5000 servo drives please read the safety notes in the foreword of this documentation.

Attention 		Destruction of the AX5000!
The connection sequence of the devices is not arbitrary. The total rated current of the device must decrease from the power supply. The order "AX5112-AX5106-AX5201-AX5103" is correct the order "AX5201-AX5112-AX5203" is wrong.

CAUTION 		Hazard to persons!
Note the total current of the connected devices.

According to CE the current carrying capacity of power busbars is limited to 85 A.

CAUTION 		Hazard to persons!
Please ensure that the connection line for the AX5901 supply module is adequately dimensioned. The dimensioning depends on the total rated current and must comply with EN 60204-1. The connector plugs are designed for a maximum conductor cross-section of 25 mm2.

A 3-phase connection must be used if the total rated current exceeds 9 A.

CAUTION 		Hazard to persons!
To set up a drive system without AX5901 supply module and AX bridge please note the following:

The connector plugs of the wide voltage input are designed for a maximum current of 41 A and a maximum conductor cross-section of 6 mm2. The cable configuration must comply with the requirements specified in DIN VDE 0298 Part 4 / 2003-08 and EN 60204-1.

Avoid phase reversal between the devices!

X01: Main supply connection

UL Listing
It is essential to observe chapter "Product overview-->Guidelines and Standards-->UL-Listing" if you wish to operate an AX5000 in an economic area that requires a UL-Listing.

Voltage systems ranging from single-phase 100 VAC to three-phase 480 VAC can be connected to the wide voltage input of the AX5000. In single-phase systems the mains phase is connected to terminal point L1 and the neutral conductor to terminal point L3/N.

Terminal point | Connection |  | Tightening torque
 | 3-phase | 1-phase
L1 | Phase L1 | Phase L1 | 0,5 - 0,6 Nm
L2 | Phase L2 | not used
L3/ N | Phase L3 | Neutral conductor
PE | Protective conductor | Protective conductor

Connection to the standard mains supply (TT / TN) with earthed centre

Single phase 100 -10% .- 240 +10% VAC, 50/60 Hz Three phase 100 -10% .- 480 +10% VAC, 50/60 Hz

Connection to a IT-mains supply (100 - 240 V) without isolating transformer

Attention 		EMC Act in europe!
Due to electromagnetic emission, in Europe the AX5000 must be operated in conjunction with an isolating transformer

Connection to other mains types (100 - 240 V) without isolating transformer

Connection to other mains types (100 - 240 V) with isolating transformer

Attention 		Destruction of the AX5000!
For asymmetrically earthed or non-earthed 100...480 V mains an isolating transformer must be used.

100 - 480 V Isolating transformer 240 - 480 V Isolating transformer

Fusing

WARNING 		Fire hazard through cable overload!
  • The following data refer to stand-alone devices. Please note the total current of all connected devices in a multi-axis system.
  • The recommended fuses are designed for line protection. The servo drives feature integrated self-protection.

External protection, CE-compliant

Single-phase:

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
AC supply *) | 10 AT | 10 AT | 16 AT | 10 AT | 16 AT | 20 AT
24 V supply | 3 AT
Brake resistor | electronic

*) Application class "gG" mains fuses according to IEC 60269 or "C" type automatic circuit-breakers must be used.

Three-phase:

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5118 | AX5125 | AX5140 | AX5201 | AX5203 | AX5206
AC supply *) | 6 AT | 6 AT | 10 AT | 20 AT | 35 AT | 35 AT | 50 AT | 10 AT | 10 AT | 20 AT
24 V supply | 3 AT
Brake resistor | electronic

*) Application class "gG / gL" mains fuses according to IEC 60269 or "C" type automatic circuit-breakers must be used.

Internal protection, CE-compliant

Circuit | Fuse
24 V system voltage | 3.4 AF
24 V peripheral voltage | electronic
Brake resistor | electronic

External protection, UL-compliant

Integral solid state short circuit protection does not provide branch circuit protection. Branch circuit protection must be provided in accordance with the Manufacture Instructions, National Electrical Code and any additional local codes.

Suitable for use on a circuit capable of delivering not more than 18000 rms symmetrical amperes, 480 V maximum, when protected by RK5 class fuses.

Single-phase:

 | AX5101 | AX5103 | AX5106 | AX5201 | AX5203 | AX5206
AC-supply (max.) *) | 6 A | 12 A | 20 A | 12 A | 20 A | 20 A
24 V-supply (max.) | 3 A
Brake resistor | electronic

*) Mains fuses according to type “RK5” must be used.

Three-phase:

 | AX5101 | AX5103 | AX5106 | AX5112 | AX5201 | AX5203 | AX5206
AC-supply (max.) *) | 6 A | 12 A | 20 A | 20 A | 12 A | 20 A | 20 A
24 V-supply (max.) | 3 A
Brake resistor | electronic

*) Mains fuses according to type “RK5” must be used.

AX5112
When protected by RK5 class fuses: Rated 20 A, min. 480 V

Internal protection, UL-compliant

Circuit | Fuse
24 V system voltage | 3.4 AF
24 V peripheral voltage | electronic
Brake resistor | electronic

External drive system protection

Rule of thumb:

Example:

Determine the total device rated current, multiply by correction factor and round it up to the next higher standard level.

1 x AX5103 + 2 x AX5201 + 2 x AX5203

3 A + 6 A + 12 A = 21 x 1.1 = 23,1 A --> selected 25 A

Special requirements for a drive system
Please consult our Application Department with respect to the special requirements for a drive system with UL-Listing.

Residual current circuit breaker

Servo drives with built-in mains filters generate a small leakage current (fault current) due to the capacitors in the filter. This fault current is responsible for malfunctions in standard residual current circuit breakers. For this reason so-called AC/DC sensitive residual current circuit breakers must be used, which also take into account DC currents.

X02: DC link

DC link coupling or external brake resistor is possible via terminal X2.

Terminal point | Connection |  | Tightening torque
DC+ | DC link + | external brake resistor | 0,5 - 0,6 Nm
DC- | DC link -

X02: DC link

Via the terminal X2 only a DC link coupling can be configured. Do not connect a brake resistor under any circumstances!

Terminal point | Connection
DC+ | DC link +
DC- | DC link -

WARNING 		Serious risk of injury through high electrical voltage!
890 V DC voltage at the DC link terminals X02. Once the device has been switched off dangerous voltage will still be present for a further 5 minutes. Only remove the connector if you wish to configure a drive system with the AX bridge.

Only remove the white hexagonal plug if the terminal points are to be rewired.

X03: 24 VDC supply

System and peripheral voltage for the servo drive is supplied via connector X3. The supply is based on two channels in order to offer an option to separate between motor stopping brakes and control electronics. Both channels are connected via a bridge as standard.

CAUTION 		Safe operation!
The voltage tolerances must be taken into account when connecting motors with stopping brake.
Terminal point | Connection | current consumption | Tightening torque
Up | 24 VDC ± 10% - Periphery (e.g. separate brake supply) | variable (see X06 and X14, X24) | 0,5 - 0,6 Nm
Us | 24 VDC -15% + 20% - system supply / control voltage | -12 A = 0,4 A - 0,8 A 18 A - 25 A = 1,1 A 40 A = 1,6 A
GND | GND |

Safe system stop in the event of power failure

A power failure can lead to uncontrolled run-out of drive axes, which means that linear axes or lifting axes would hit the limit stop unbraked. The 24 VDC supply of the AX5000 has two channels, so that separate power supplies can be used for the control electronics and the brake control. This enables the supply voltage for the control electronics to be buffered via the UPS of the Industrial PCs until all axes were stopped safely.


AX5000 - Electrical installation - EtherCAT

BECKHOFF AX5000: Installation

EtherCAT

X04, X05: EtherCAT connection

The AX5000 is integrated in EtherCAT via the X04 and X05 RJ45 sockets.

RJ45 | Signal
X04 (IN) | incoming EtherCAT line
X05 (OUT) | outgoing EtherCAT line


AX5000 - Digital I/Os (ZS4500)

BECKHOFF AX5000: Installation

X06: Digital I/Os

CAUTION 		Destruction of the AX5000!

This connector is not designed for external power supply. It is supplied via the 24 V supply (periphery) of connector X03.

Note 		Output current
The specified output currents are maximum values. The actual values depend on your current configuration.
I/O plug connector without LEDs

ZS4500-2006

Terminal point | Signal | output current
24 | Output voltage (Up 24 VDC +) | max. 1 A
0 | Input 0 |
1 | Input 1 |
2 | Input 2 |
3 | Input 3 |
4 | Input 4 |
5 | Input 5 |
6 | Input 6 |
7 | Input 7 or output (configurable) (Up 24 VDC +) | max. 0,5 A
0V | Output voltage GND (-) |
I/O plug connector with LEDs

ZS4500-2007 (optional)

ZS4500-2008 (optional)

Voltage level | State
-3 V ... 5 V | "0" signal voltage
15 V ... 30 V | "1" signal voltage

The signal inputs of the connectors can be assigned the following functions, which are configured through IDNs.

IDN | Name
 | Hardware enable
P-0-0400 | Hardware enable configuration
 | Configuration (BitSize 2, OffSet 0)
 | Input number (BitSize 5, OffSet 3)
 | Position limit switches
P-0-0401 | Position limit switch configuration
 | Positive limit switch (BitSize 16, OffSet 0)
 | Input number (BitSize 8, OffSet 8)
 | Negative limit switch (BitSize 16, OffSet 16)
 | Input number (BitSize 8, OffSet 8)
 | Ready to operate
P-0-0402 | Ready to operate configuration
 | Ready to operate output (BitSize 8, OffSet 0)
 | Output number (BitSize 5, OffSet 3)
 | Ready to operate input (BitSize 8, OffSet 8)
 | Configuration number (BitSize 3, OffSet 0)
 | Input number (BitSize 5, OffSet 3)
 | General I/O
P-0-0800 | Digital output control word
 | reserved (BitSize 7, OffSet 0)
 | Digital I/O (BitSize 7, OffSet 1)
 | reserved (BitSize 8, OffSet 8)
P0-0801 | Digital inputs, state
 | Digital Input 0 (BitSize 1, OffSet 0)
 | Digital Input 1 (BitSize 1, OffSet 1)
 | Digital Input 2 (BitSize 1, OffSet 2)
 | Digital Input 3 (BitSize 1, OffSet 3)
 | Digital Input 4 (BitSize 1, OffSet 4)
 | Digital Input 5 (BitSize 1, OffSet 5)
 | Digital Input 6 (BitSize 1, OffSet 6)
 | Digital Input 7 (BitSize 1, OffSet 7)
 | reserved (BitSize 8, OffSet 8)
P-0-0802 | Digital outputs
 | reserved (BitSize 7, OffSet 0)
 | Digital Output 7 (BitSize 1, OffSet 7)
 | reserved (BitSize 8, OffSet 8)
 | Latch-unit
P-0-0251 | Probe 1 logic configuration
 | Mux 1 (BitSize 16, OffSet 0)
 | Signal selection (BitSize 15, OffSet 0)
 | Output negation (BitSize 1, OffSet 15)
 | Mux 2 (BitSize 16, OffSet 16)
 | Signal selection (BitSize 15, OffSet 0)
 | Output negation (BitSize 1, OffSet 15)
 | Logic (BitSize 16, OffSet 32)
 | Latch ctrl (BitSize 16, OffSet 48)


ZS4500 - I/O plug connector

Technical data

Technical data | ZS4500-2006 | ZS4500-2007 | ZS4500-2008
Number of terminal points | 10 | 10 | 30
Signal LEDs | no | yes | yes
Nominal voltage | 24 VDC | 24 VDC | 24 VDC
Rated current | 2 A
Wire cross section | 0.5 mm2 ... 1.5 mm2
Length of stripped conductor | 10 mm
Dimensions (W x H x D) | approx. 42mm x 10.3mm x 26.9mm | approx. 42mm x 12.7mm x 26.9mm | approx. 42mm x 20.8mm x 26.9mm
Weight | approx. 10 g | approx. 10 g | approx. 20 g
Operating temperature | 0°C... + 55°C
Storage temperature | -25°C... + 85°C
Relative humidity | 95%, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP 20
Installation position | variable
Approval | CE, UL, CSA

Ordering information for I/O plug connectors

Order designation | Signal LEDs | Supports the following connection types
 |  | Single-conductor | Two-conductor | Three-conductor
ZS4500-2006 | no | yes | no | no
ZS4500-2007 | yes | yes | no | no
ZS4500-2008 | yes | yes | yes | yes

Connection of digital sensors/actuators

ZS4500-2006 (standard) and ZS4500-2007 (optional)

The connection type (single-conductor) in the two connectors ZS4500-2006 and ZS4500-2007 is identical. The ZS4500-2007 is additionally equipped with LEDs.The following diagram shows the ZS4500-2006.

A sensor (F) is connected at terminal point "0" via a single-conductor connection. The 24 V supply for the sensor is connected externally. The 24 V supply for the sensor (F) could be taken directly from terminal point "24", although this would preclude further connections since only one 24 V connection can be connected at terminal point "24".

In this case terminal point "7" is configured as an output. The configuration is implemented on the software side. At this point a relay (G) is connected via a single-conductor connection. The 0 V connection is established externally. Terminal point "0V" can only be used once.

Note 		Ground potential
  • If sensor (F) or further initiators are supplied through a separate power supply unit, the ground potential of the separate power supply unit must be connected with the ground potential of terminal point "GND" of connector "X03" (24 V supply).
  • The ground potential (0 V) of the relay (G) must be connected with the ground potential of terminal point "GND" of connector "X03" (24 V supply).

ZS4500-2008 (optional)

A single-, two- or three-conductor connection may be used for this connector. The diagram shows the two- and three-conductor type. The single-conductor type matches the diagram for connector ZS4500-2006.

The terminal points at (B) are internally bridged. The two bridges (A) must be established externally on the connector in order to ensure the required function.

A sensor (C) is connected at terminal point "2" via a two-conductor connection.

A sensor (D) is connected at terminal point "4" via a three-conductor connection.

In this case terminal point "7" is configured as an output. The configuration is implemented on the software side. At this point a relay (E) is connected via a two-conductor connection.


AX5000 - Feedback

BECKHOFF AX5000: Installation

Feedback

Information about commutation you will find in the Chapter "Commissioning-->Commutation methods".

Information on the limit frequencies can be found further below, in the descriptions of the interfaces.

Note 		Absolute encoder
When using an absolute encoder, it must be verified before moving the axis that the feedback system supplies the expected position data at the distinctive positions in the traversing range - ‘START’ and ‘MID’ and ‘END’ – and that these positions are retained after the restart (Bootstrap -> OP) of the AX5000.

Encoder

Tested and released encoder for AX5000

Rotational encoders

Heidenhain:

The Heidenhain company supplies feedback systems with the ‘EnDat 2.2’ interface in 2 versions. One version is without the provision of the analog signal and the other version provides the analog signal ‘1Vss’. To date, Beckhoff supports only EnDat 2.1 with analog signal. Since the EnDat 2.2 interface supports all of the commands of EnDat 2.1, attention only needs to be paid to the provision of the analog signal 1Vss on the Heidenhain feedback systems with EnDat 2.2; i.e. the Heidenhain order designation ‘EnDat02’ must be stated.

Type | System | Lines / sine cosine periods per revolution | Supply voltage | Interface | Scanning
ECI 1118 | Singleturn | 16 | 5 V | EnDat 2.1 | Inductive
ECI 1319 | Singleturn | 32 | 5 V or 7 - 10 V | EnDat 2.1 | Inductive
ECN 413 | Singleturn | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optical
ECN 413 | Singleturn | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optical
ECN 1113 | Singleturn | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optical
ECN 1313 | Singleturn | 2048 | 5 V | EnDat 2.1 + 1 Vpp | Optical
EQI 1130 | Multiturn | 16 | 5 V | EnDat 2.1 | Inductive
EQI 1331 | Multiturn | 32 | 5 V or 7 - 10 V | EnDat 2.1 | Inductive
EQN 425 | Multiturn | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optical
EQN 425 | Multiturn | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optical
EQN 1125 | Multiturn | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optical
EQN 1325 | Multiturn | 512 | 5 V | EnDat 2.1 + 1 Vpp | Optical
EQN 1325 | Multiturn | 2048 | 5 V | EnDat 2.1 + 1 Vpp | Optical
RCN 829 | Singleturn | 32768 | 3,6 V - 5,25 V | EnDat 2.2 + 1 Vpp | Optical
ROQ 425 | Multiturn | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optical
ROQ 425 | Multiturn | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | Optical
ERN 180 | Incremental | 1024 | 5 V | 1 Vpp | Optical
ERN 180 | Incremental | 2048 | 5 V | 1 Vpp | Optical
ERN 180 | Incremental | 5000 | 5 V | 1 Vpp | Optical
ERN 480 | Incremental | 2048 | 5 V | 1 Vpp | Optical
ERM 280 | Incremental | 1200 | 5 V | 1 Vpp | Magnetic

Hengstler:

Type | System | Lines / sine cosine periods per revolution | Supply voltage | Interface | Scanning
AD 34 | Singleturn | 2048 | 5 V | BiSS + 1 Vpp | Optical
AD 36 | Singleturn | 2048 | 5 V | BiSS + 1 Vpp | Optical
AD 36 | Multiturn | 2048 | 5 V | BiSS + 1 Vpp | Optical
AD 58 | Singleturn | 2048 | 5 V | BiSS + 1 Vpp | Optical
AD 58 | Multiturn | 2048 | 5 V | BiSS + 1 Vpp | Optical

Kübler:

Type | System | Lines / sine cosine periods per revolution | Supply voltage | Interface | Scanning
8.5853 | Singleturn | 2048 | 5 V | BiSS + 1 Vpp | Optical

Sick Stegmann:

Type | System | Lines / sine cosine periods per revolution | Supply voltage | Interface | Scanning
SEK 37 | Singleturn | 16 | 7 V - 12 V | HIPERFACE | Capacitive
SEK 52 | Singleturn | 16 | 7 V - 12 V | HIPERFACE | Capacitive
SRS 50 | Singleturn | 512 | 7 V - 12 V | HIPERFACE + 1 Vpp | Optical
SRM 50 | Multiturn | 512 | 7 V - 12 V | HIPERFACE + 1 Vpp | Optical

Universal rotational encoders:

Type | System | Lines / sine cosine periods per revolution | Supply voltage | Interface | Scanning
1 |  | 512 | 5 V | 1 Vpp |

Linear encoders

Heidenhain:

Type | System | Measuring steps | Supply voltage | Interface | Scanning
LS 388C | Incremental | 20 µm | 5 V | 1 Vpp | Optical
LS 486 | Incremental | 20 µm | 5 V | 1 Vpp | Optical
LS 487 | Incremental | 20 µm | 5 V | 1 Vpp | Optical
LC 483 | Incremental | 20 µm | 3,6 V - 5,25 V | Endat 2.1 + 1 Vpp | Optical
LIDA 483 | Incremental | 20 µm | 5 V | 1 Vpp | Optical
LIDA 287 | Incremental | 200 µm | 5 V | 1 Vpp | Optical

HIWIN:

Type | System | Measuring steps | Supply voltage | Interface | Scanning
Magic | Incremental | 1 mm | 5 V | 1 Vpp | Magnetic

lika:

Type | System | Measuring steps | Supply voltage | Interface | Scanning
SMS | Incremental | 1 mm | 5 V | 1 Vpp | Magnetic

Numerik Jena:

Type | System | Measuring steps | Supply voltage | Interface | Scanning
LIA20 | Incremental | 20 µm | 5 V | 1 Vpp | Optical

Siko:

Type | System | Measuring steps | Supply voltage | Interface | Scanning
LE100/1 | Incremental | 1 mm | 5 V | 1 Vpp | Magnetic

Universal linear encoders:

Type | System | Measuring steps | Supply voltage | Interface | Scanning
1 | Incremental | 20 µm | 5 V | 1 Vpp |
2 | Incremental | 1 mm | 5 V | 1 Vpp |
3 | Incremental | 20 µm | 5 V - uncontrolled | 1 Vpp |
4 | Incremental | 1 mm | 5 V - uncontrolled | 1 Vpp |

Note 		Motor feedback database
If your feedback system is not listed here, please follow the link to the Beckhoff download area. By downloading and installing the ‘AX5000 setup’ you will obtain the TwinCAT Drive Manager, the latest firmware and the latest motor feedback database.

X11 and X21: Feedback, high-resolution

The X11 and X21 D-SUB sockets are available for connecting high-resolution feedback systems. In delivery state X11 is assigned to axis 1, X21 to axis 2.

Pin | EnDAT / BiSS | Hiperface | Sine / Cosine 1Vpp | TTL | output current
1 | SIN | SIN | SIN | n.c. | max. 250 mA / chanel
2 | GND_5 V | GND_9 V | GND_5 V | GND_5 V
3 | COS | COS | COS | n.c.
4 | Us_5 V | n.c. | Us_5 V | Us_5 V
5 | DX+ (Data) | DX+ (Data) | n.c. | B+
6 | n.c. | Us_9V | n.c. | n.c.
7 | n.c. | n.c. | REF Z | REF Z
8 | CLK+ (Clock) | n.c. | n.c. | A+
9 | REFSIN | REFSIN | REFSIN | n.c.
10 | GND_Sense | n.c. | GND_Sense | GND_Sense
11 | REFCOS | REFCOS | REFCOS | n.c.
12 | Us_5 V_Sense | n.c. | Us_5 V_Sense | Us_5 V_Sense
13 | DX- (Data) | DX- (Data) | n.c. | B-
14 | n.c. | n.c. | Z | Z
15 | CLK- (Clock) | n.c. | n.c. | A-

Limit frequency:

1Vpp = 270 kHz
TTL = 10 MHz
MES = 500 Hz

Resolver

Universal Resolver:

Typ | Number of poles | Frequency | Speed ratio | Phase difference
1 | 2 | 8 kHz | 0,5 phi | 0 °
2 | 6 | 8 kHz | 0,5 phi | 0 °
3 | 8 | 8 kHz | 0,5 phi | 0 °

X12 and X22: Feedback, Resolver / Hall

The X12 and X22 D-SUB sockets are available for connecting resolvers or Hall sensors for commutation. X12 is assigned to axis 1 in the factory, X22 to axis 2.

Resolver specification:

Pin
 | Resolver | Analog hall sensor
1 | Temperature (only PTC, Klixon or bimetal!) Switchpoint 1300 W ± 3% | n.c.
2 | AGND | n.c.
3 | COS - (S3) | n.c.
4 | SIN - (S4) | n.c.
5 | REF - (R2) | n.c.
6 | n.c. | SIN 1 Vpp
7 | n.c. | -120° or -90° 1 Vpp *
8 | n.c. | Us_9 V (supply)
9 | Temp. _ GND | n.c.
10 | COS + (S1) | n.c.
11 | SIN + (S2) | n.c.
12 | REF + (R1) | n.c.
13 | n.c. | REFSIN 1 Vpp
14 | n.c. | REF -120° or -90° 1 Vpp *
15 | n.c. | GND (supply)

*) The angle must be configured

Limit frequency:

Resolver = 300 Hz


AX5000 - Motors

BECKHOFF AX5000: Installation

Motors

Concept

Both three-phase synchronous motors and three-phase asynchronous motors can be driven with the servo drives from the AX5000 series. Due to this flexibility it is possible to implement inexpensive drive solutions with asynchronous motors in addition to demanding positioning tasks in the shortest possible time. The operation of asynchronous motors with the AX5000 is useful if, in the configuration of the drive system, a channel is still freely available and more asynchronous motors are used that are to be operated with open-loop control. In the case of the use of asynchronous motors intended for closed-loop operation, the AX5000 series is a good alternative regardless of the configuration of the drive system.

Motor data set

A motor data set contains the motor data required by the AX5000 in order to operate the motor. Motor data sets are saved in a so-called motor database. Beckhoff is continually expanding the pool of available motor data sets and makes the latest motor database available automatically when the TwinCAT Drive Manager is updated.
If you create motor data sets yourself, you create a separate structure and remain independent of the motor database. This means that your motor data sets are retained even if the motor database is expanded by Beckhoff.

TwinCAT Drive Manager

The selection of motors or the input of the parameters for new motors takes place via the TwinCAT Drive Manager (TCDM). The screen masks required for the parameterisation will be explained at this point. If you need basic information about the TCDM, please read the complete documentation, which is available on our website for download.

Start the TCDM and click the entry (2) under the relevant channel (1) in the tree; the motor/feedback configuration appears in the TCDM working area. Click on the field (3) in order to open the ‘Motor selection window’. In the ‘Motor selection window’ you can display all of the available motors, or enter your own motors including motor parameters (asynchronous motors only).

Synchronous motors

In the case of synchronous motors, you can only select an existing motor; it is not possible to register your own motors. If your motor is not listed, please contact our support department.

Asynchronous motors

With the AX5000 you have the possibility to implement a good positioning drive with an inexpensive standard motor in combination with a low-cost incremental encoder.

Linear

Linear asynchronous motors are not supported at present.

Rotational

General

In the following diagram you will find various curves related to the speed range of an asynchronous motor driven by a converter.

1. Motor selection

You can either choose an existing motor (1) or generate parameters for a new motor (2). After selection, click ‘OK’ (3) to move to the next menu.

2. Identifying motor data

Identifying motor data are entered or selected in the next menu. Expert mode (9) is not currently supported. Parameters (4) and (5) are preset; you do not need to change them. You can enter a new motor manufacturer or select an existing motor manufacturer in parameter (6). A new group is generated in parameter (7) to suit the motor. If you wish to conform to the structure of the motor database, name the group according to the nominal speed of the motor. Enter the exact type designation of the motor in parameter (8). Check your entries and then click ‘Next’ (10) to move to the next menu.

3. Basic motor data

The basic data are subdivided into three categories: ‘Basic’ (1); ‘Temperature:’ (2) and ‘Brake’ (3).

Basic (1):

a) Type of connection: Star or delta connection. If you wire and operate the motor in a star or delta configuration, please note that the rated motor current changes along with the rated motor voltage and that the AX5000 can supply a maximum rated voltage of 480 V. Please refer to the motor documentation or name plate for the permissible motor voltages and currents for star and delta connection.

b) The derating is dependent upon your application. Derating is the difference between the effective rated channel current and the rated motor current in %. Example: rated motor current = 4 A; effective rated channel current = 3 A -> derating = 25 %.

c) The ratio of Ip to In (overload factor) is set to 1.5 as standard and must be checked against the motor documentation or name plate.

d) The rated current must be adjusted in accordance with the type of connection and checked against the motor documentation or name plate.

e) The maximum motor speed is dependent upon the mechanical properties and the maximum rotary field frequency of the AX5000. Please observe the M / f curve and the field weakening according to the motor documentation.

f) The rated voltage must be adjusted in accordance with the type of connection and checked against the motor documentation or name plate.

g) The nominal speed is dependent upon the number of pole pairs and the nominal frequency and must be checked against the motor documentation or name plate.

h) The nominal frequency is set to 50 Hz as standard and must be checked against the motor documentation or name plate.

i) The power factor (cos y) is set to 0.8 as standard and must be checked against the motor documentation or name plate.

Temperature (2):

k) The type of motor temperature monitoring used and the AX5000 input used must be selected:
0 = switch to X14 or X24
1 = KTY 83-110 to X14 or X24
2 = switch to X12 or X22
3 = KTY84-130 to X14 or X24
If the combination you have used is not included in the list, please contact our support department.

m) The temperature at which a warning is given is set to 80 °C. This parameter is effective only for KTY sensors.

n) The temperature at which the motor is switched off is set to 140 °C and must be checked against the motor documentation or name plate. This parameter is effective only for KTY sensors.

Brake (3)

o) The type of motor brake used must be selected and checked against the motor documentation or name plate.

Double-check all entries and click ‘Next’ (4) to move to the next menu.

4. Summary

The motor data entered and the data calculated from them are displayed in this window. Please check ALL parameters once more for plausibility and click ‘OK’ (5) to move to the next menu.

5a. Default storage folder for self-generated motor data sets

The default storage folder for self-generated motor data sets is called ‘CustomerGenerated’ (1) and the suggested file name (2) corresponds to the type of motor entered above (see 2. ‘Identifying motor data’, above). This storage folder has the advantage that you can find your self-generated motor data sets at a glance; however, they are not included in the above list above under 1. ‘Motor selection’, but are only visible if you click the ‘Load’ button at the bottom right under 1. ‘Motor selection’. The suggested name designates only the XML file of the motor data set. For the purposes of displaying in the lists, the XML file is read and the corresponding identifying motor data (‘Vendor’, ‘Motor group’ and ‘Motor type’) are listed as a selection.
To save your data, click on ‘Save’ (4), which then takes you to the last menu.

If your self-generated motor data sets are to be listed directly in the above list under 1. ‘Motor selection’, click on the symbol (3) to open the 'MotorPool’ folder.

5b. Default storage folder for the motor data sets from the Beckhoff motor database

The default storage folder for the motor data sets provided is called ‘MotorPool’ (4). All motor data sets from the Beckhoff motor database are located here in the form of XML files. We recommend that you assign a unique file name to your self-generated motor data set, so that you can identify it (5):
Customer = name of your company
Mototec = The name (Vendor) assigned by you under 2. ‘Identifying motor data’
3000 = The motor group assigned by you under 2. ‘Identifying motor data’
17K456FGH = The motor type assigned by you under 2. ‘Identifying motor data’

Of course, you can also assign an arbitrary file name. The assigned name designates only the XML file of the motor data set. For the purposes of displaying in the lists, the XML file is read and the corresponding identifying motor data (‘Vendor’, ‘Motor group’ and ‘Motor type’) are listed as a selection.

You create one XML file for each motor data set; the motors from the same motor group of a manufacturer (Vendor) are always summarised in the XML files for Beckhoff motor data sets.

To save your data, click on ‘Save’ (6), which then takes you to the last menu.

6. Mains voltage and further settings

This window also appears when you select an existing motor data set (synchronous motor or asynchronous motor). You can adapt the following entries at any time.

a) You can select one of the pre-defined mains voltage variants or you can specify one of your own.

b) Enter the mains voltage (only possible if no voltage was selected in a)).

c) Enter the upper tolerance of the mains voltage (only possible if no voltage was selected in a)).

d) Enter the lower tolerance of the mains voltage (only possible if no voltage was selected in a)).

e) & f) Phase monitoring is only useful for a 3-phase mains supply. Switch phase monitoring on or off (only possible if no voltage was selected in a)).

g) Use this setting to enable automatic transfer of the resolution of the encoder and the scaling factor from the AX5000 to the NC. (Only required if the motor was integrated via an NC axis).

h) The cycle time of the current controller is 125 μs.

i) Selection of the type of ASM connection. If you have generated the motor data set, you can only select the type of connection entered under 3. ‘Basic motor data –a)’. If Beckhoff has generated the motor data set, you can choose between star connection and delta connection.

k) Selection of the ASM control mode. If you select ‘U/f control’, only open-loop operation of the motor is possible; the AX5000 then acts like a frequency converter. If you select ‘i-control with feedback’, closed-loop operation of the motor is possible, but the motor must be equipped with a feedback system. Click on ‘OK’ (1) to complete the procedure.

Open-loop

If open-loop operation of the motor is desired, you can influence the operating behaviour with the following parameters.

Interdependence between the type of connection of the motor, the speed and the rated output current of the AX5000

Example motor:

Asynchronous motor with rated voltage 230 V and rated current 6 A at 50 Hz for delta connection or rated voltage 400 V, rated current 3.5 A at 50 Hz for star connection

If your application requires speeds above the nominal speed (1), this requirement can be realised without having to use a bigger motor:
The AX5000 can provide 400 V of channel output power and thus operate the asynchronous motor in delta connection at up to 87 Hz (2) without field weakening occurring, i.e. with the nominal torque. You only need to note that a rated current of 6 A is required.

Boost voltage

The operation of an asynchronous motor with a linear U/f characteristic curve (see illustration above) results in a weakening of the torque in the lower speed range due to the dominant resistive component. The standstill torque is zero without a boost voltage. Furthermore, the asynchronous motor requires a certain time after the current is applied in order to build up the magnetic field on the rotor and, hence, to generate the magnetic force or the torque. If your application can not tolerate this delay, there is a possibility to reduce this time delay via the so-called ‘boost voltage’, which ‘premagnetises’ the rotor. With ‘premagnetisation’ a magnetic field is created in the rotor even though the rotor is not moving. Torque is hence immediately available to rotate the rotor shaft if a target speed is specified. The interdependence between the boost voltage, speed and torque is illustrated in the graphic below on the basis of an example motor. The influence of the boost voltage on to the torque is clearly visible at low speeds.

Example motor:
Nominal speed: 1410 rpm
Rated torque: 10.2
Breakdown torque: 28.6
Starting torque: 25.5
Power factor: 0.78
Efficiency: 0.79

The boost voltage is parameterised in the IDN-P-0-0103. Most applications will be covered by the default setting of 10 V.

Attention 		Attention: destruction of the motor
In an asynchronous motor without an external fan, the motor temperature must be monitored in the lower speed range when boost voltage is used. If necessary, you can change the boost voltage online.

Settings for ramping up and down

In the open-loop operation of the asynchronous motor, the values you need to adjust for the ramps depend on the application.
The ramp-up is parameterised in the IDN S-0-0136 and the ramp-down in the IDN S-0-0137.

Closed-loop

If closed-loop operation of the asynchronous motor is desired, you must select the feedback system used in the motor in the TCDM.

Feedback

Start the TCDM and click the entry (2) under the relevant channel (1) in the tree; the motor/feedback configuration appears in the TCDM working area. Click on the ‘Feedback 1’ (3) field to open the ‘Feedback selection window’. You can view all available feedback systems in the ‘Feedback selection window’.

1a. Feedback selection - resolver

You can only select one existing feedback system. Either choose the feedback system of an existing manufacturer or choose a standard feedback system under ‘Unknown’ (1). If your motor is equipped with a resolver, determine the parameters of the resolver and select the appropriate resolver type (2). Typical parameters for the classification of resolvers are the number of poles ‘p’ and the gear ratio ‘n’. Click on ‘OK’ (3) to complete the procedure.

1b. Feedback selection - 1Vpp encoder

You can only select one existing feedback system. Either choose the feedback system of an existing manufacturer or choose a standard feedback system under ‘Unknown’ (1). If your motor is equipped with a 1Vpp encoder, determine the parameters of the feedback system and select the appropriate encoder (2). Typical parameters for the classification of 1Vpp encoders are the number of lines ‘s’ and the supply voltage ‘5 V or 5 V fixed’. The difference between the two voltage variants is the use of a sense line (5 V). Click on ‘OK’ (3) to complete the procedure.

1c. Feedback selection - TTL encoder

You can only select one existing feedback system. Either choose the feedback system of an existing manufacturer or choose a standard feedback system under ‘Unknown’ (1). If your motor is equipped with a TTL encoder, determine the parameters of the feedback system and select the appropriate TTL encoder (2). Typical parameters for the classification of TTL encoders are the number of lines ‘s’ and the supply voltage ‘5 V or 5 V fixed’. The difference between the two voltage variants is the use of a sense line (5 V). Click on ‘OK’ (3) to complete the procedure.

Commutation

In asynchronous motors the rotor magnetic field is generated electrically by means of rotor windings, which are energised by the servo drive. For this reason, neither a part-absolute nor an absolute encoder system is required for commutation; wake+shake also does not need to be used.

X13 (A), X23 (B): Motor connection (AX5101 - AX5125 und AX520x)

Terminal point | Signal
U | Motor connection U
V | Motor connection V
W | Motor connection W
PE | Protective conductor
Shroud | Screen

X13 : Motor connection (AX5140)

Terminal point | Signal
U | Motor connection U
V | Motor connection V
W | Motor connection W
PE | Protective conductor
Shroud | Screen

Attention 		Grounding shield!
The grounding shield of the motor is connected via the shield plate in the motor connector. Please tighten the knurled screws of the motor connector with a screwdriver. It is possible that some feedback problems may caused due to a poor shield connection of the motor.

X14 (A), X24 (B): Motor brake, thermal contact

Terminal point | Signal | output current
T- | Temp. - * |
T+ | Temp. + * |
PE | Protective conductor and signal pair screen |
B- | Brake, GND |
B+ | Brake (Up) + | max. 2.2 A

*) Switch, KTY 83-1xx or KTY 84-1xx

Note 		Output current
The specified output currents are maximum values. The actual values depend on your current configuration.

Attention 		Destruction of the AX5000!
Read the ‘Cables’ chapter carefully and be sure to adhere to the specifications contained in it.

Thermal protection contact for Beckhoff motors

AM2000 with resolver

Via resolver cable.

AM2000 with EnDat

The thermal protection contact is implemented in the encoder cable to the AX5000 and must be bridged to the resolver connection via an adapter / Y cable.

AM2000 with BiSS

Not available.

AM3000 with resolver

Via resolver cable.

AM3000 with EnDat

Via motor cable.

AM3000 with BiSS

Via motor cable.

Linear motors AL2000

The thermal protection contact exits the motor via a separate cable.

  1. If the pre-assembled Beckhoff motor and encoder cable is used, an additional thermal protection contact cable (ZK4540-0020-xxx) is required for connecting the thermal protection contact with the AX5000 resolver interface, where temperature evaluation takes place.
  2. If the AL2250 connector box is used, the thermal protection contact is automatically bridged to the motor cable.

Temperature monitoring and evaluation for motors from other manufacturers

1. Temperature monitoring via PTC, Klixon or bimetal

Evaluation either on the resolver interface (X12 / X22) or the temperature contact (X14 / X24)

2. Analog temperature evaluation (e.g. KTY)

Evaluation only on the temperature contact (X14 / X24)


AX5000 - External brake resistor

BECKHOFF AX5000: Installation

External brake resistor

X02 - AX5101-AX5125 and AX520x

Terminal point | Signal
DC+ | DC link +
DC- | DC link -

X07 - AX5140

Terminal point | Signal
PE | Protective conductor
+RB | External brake resistor +
+RBint | internal brake resistor +
-RB | Brake resistor GND

Note 		Operation of AX5140
Commissioning the AX5140 can only be carried out when the terminal points "RBint" and "+RB" are bypassed (delivery state) or an external brake resistor is connected (terminal points "+RB" and "-RB"). If these measures are not taken then the AX5140 will be stopped with the error message "FD4B – undervoltage"


AX5000 - Important information for commissioning

BECKHOFF AX5000: Commissioning

Important information for commissioning

WARNING 		Caution – Risk of injury!
Electronic equipment is not fail-safe. The machine manufacturer is responsible for ensuring that the connected motors and the machine are brought into a safe state in the event of a fault in the drive system.

Please be aware each time before commissioning the AX5000 that connected motors can make uncontrolled movements, which cannot always be prevented even by the AX5000’s integrated diagnostic system, or may permit uncontrolled movements until the diagnostic system responds. Analyse your system and take suitable precautions to prevent damage being caused by these uncontrolled movements.

Potential causes of uncontrolled movements:

The diagnostic system of the AX5000 is equipped with complex plausibility checks, which constantly monitor installation, operation, parameterisation and operation and, if necessary, interrupt them with a diagnostic message. The points listed below are naturally also monitored as standard, but it is not possible to include all eventualities; therefore, with respect to the following points, you must always consider whether the driven axes can only perform permissible movements.

  • Incorrect commutation results (e.g. during wake & shake), it is essential to observe chapter “Commutation methods-->commutation error “F2A0””
  • Specific caution with motors of third parties: always execute the command „P-0-0166“ without load when changing the motor or feedback or when changing the SysMan-file (.TSM) and evaluate the result. Correct the commutation offset if applicable., as described in chapter “Commutation methods”
  • Input of invalid parameters
  • Measuring transducer and/or signal transducer defective or incorrectly adjusted
  • Cables defective or not adequately screened
  • Incorrectly attached sensors

CAUTION 		Increased attention in the case of vertical axes!
When commissioning vertical axes, the risk consideration described above is to be carried out with particular care. An uncontrolled movement can mean the sudden falling down of a load in this case.


AX5000 - Basic principles

BECKHOFF AX5000: Commissioning

Basic Principles

In general, two TwinCAT software modules are required for controlling the AX5000: TwinCAT NC PTP and TwinCAT PLC.

TwinCAT NC is a closed software module whose features the user can only influence via parameters. The TwinCAT NC parameters can be set in the TwinCAT System Manager.

TwinCAT PLC is an interpreter for a program code which the user creates in the PLC Control development environment.

Structure of TwinCAT NC PTP

TwinCAT NC has 2 tasks:

  • NC task 1 SPP (Set PreParation task)
  • NC task 1 SEC (Set ExeCution task)

The SPP task is responsible for planning the requested traversing task. The SEC task is responsible for maintaining this path.

The traversing task leaves the PLC in the direction of the ADS router with destination NC-Task 1 SVB (NC task 1 SPP). The router relays the telegram to this task.

The NC accepts or rejects the message. The response arrives back at the calling block in the PLC via the same route. Instructions are issued based on blocks contained in TCMC.lib. Once the NC has accepted the instruction, the system tries to calculate a solution taking into account the boundary conditions (max. velocity, acceleration, deceleration, and jerk).

If a solution exists, a table containing the position (s) velocity (v), acceleration/deceleration (a) and jerk (j) for the whole travel time within the sampling time of the SEC task is transferred to the SEC.

If no solution exists, the system deviates downwards based on maximum jerk, maximum acceleration, and maximum velocity (in this order).

Actual and set values shown in the diagram are served by the 1_Enc axis and 1_Drive axis components.

Since the AX5000 is known to the system as a slave, linking can take place automatically if required. In the event of problems the link can be checked by the user.

NC / AX5000 link specification
NC set values | AX5000 set values | NC actual values | AX5000 Actual values
axis n_Drive / outputs/axis n_DriveOut / nOutData1 | MDT n / position set value (option) | axis n_Enc / inputs / axis 1_Enc_In / nInData1 | AT n / actual position value sensor 1
axis n_Drive / outputs/axis n_DriveOut / nOutData2 | MDT n / velocity set value |  |
axis n_Drive / outputs/axis n_DriveOut / nCtrl1 | MDT n / master control word (Hi-byte) | axis n_Drive / inputs/axis n_DriveIn / nStatus1 & nStatus2 | AT n / drive status word
 |  | axis n_Drive / inputs/axis n_DriveIn / nStatus4 | WcState' / WcState

Structure of the AX5000 slave in the TwinCAT System Manager.

The AX5000 parameter management is based on the Sercos profile. The parameter description is based on a standardised structure.

Element 1: IDN (required)

IDN description. Bit 15 distinguishes between standard parameters (S-0-nnnn) and manufacturer-specific parameters (P-0-mmmm).

Bit | Value | Description
15 | 0 | S-0-nnnn (standard parameter)
 | 1 | P-0-mmmm (manufacturer-specific parameter)
12-14 |  | product data (manufacturer-specific)
0-11 | 0...4095 | block number

Element 2: Name (optional)

The name includes a brief description of the parameter in text form.

Byte 1,2 | Byte 3,4 | Byte 5, max. 64
Current length of the name in characters (1 character = 1 byte) | maximum length of the name in characters (1 character = 1 byte) | name (max. 60 characters)

Element 3: Attributes (required)

This double word describes the IDN properties (write protection, data type, decimal places).

Bit | Value | Description
31 | - | Reserved
30 | 1 / 0 | Write protection in Op phase / no write protection in Op phase
29 | 1 / 0 | Write protection in SaveOp phase / no write protection in SaveOp phase
28 | 1 / 0 | Write protection in PreOp phase / no write protection in PreOp phase
24-27 | 0000 - 1111 | Number of decimal places for floating point numbers
23 | - | Reserved
20-22 | Value | Data type | Represented as
 | 000 | Binary | Binary
 | 001 | Unsign Integer | Unsigned decimal
 | 010 | Sign Integer | Sign decimal
 | 011 | Unsign Integer | Hexadecimal
 | 100 | Character string | Text
 | 101 | Unsign Integer | IDN
 | 110 | Floating point number | Sign decimal with exponent
 | 111 | Reserved |
19 | 1 / 0 | Command / Parameter. A command executes an assigned function
16-18 | 000 | Reserved
 | 001 | Length: 2 bytes
 | 010 | Length: 4 bytes
 | 011 | Length: 8 bytes
 | 100 |
 | 101 |
 | 110 |
 | 111 |

Element 4: Units (optional)

Byte 1,2 | Byte 3,4 | Byte 5, max. 16
Current length of the name in characters (1 character = 1 byte) | maximum length of the name in characters (1 character = 1 byte) | Physical units max. 12 characters.

Element 5 & 6: Min. & max. values (optional)

The limits for the associated IDN entries are specified here.

Element 7: Value (required)

Four different memory lengths are used.

  • Fixed length of 2 bytes
  • Fixed length of 4 bytes
  • Fixed length of 8 bytes
  • Variable length of up to 65532 bytes

With this variables IDN structure different data types can be stored, displayed and managed. These parameters specify the controller characteristics:

  • Motor data
  • Feedback data
  • Controller settings
  • Special functions

These data are not stored in the controller but in the TwinCAT configuration. The following diagram illustrates how the data configured in the TcDriveManager are stored.

Once the parameters have been set in the TcDriveManager they can be transferred to the Startup list.
After the data have been transferred to the Startup list, they are downloaded to the controller after configuration has been saved and TwinCAT has been restarted.

Some parameter can simply be transferred temporarily into the controller RAM. These parameters are lost during a restart or a power failure.

Inactive write protection is a prerequisite for a successful download. Write protection is set for some parameters when the EtherCAT slave reaches the SafeOP or OP state.

An attempt to change a read-only parameter results in the following error message.

In this case the only available procedure is as follows:

  1. Parameter transfer to the Startup list
  2. Saving the configuration
  3. Restart TwinCAT


AX5000 - Parameter handling

BECKHOFF AX5000: Commissioning

Parameter handling

The servo drives from the AX5000 series use a new method for managing their configuration parameters (IDNs).

In contrast to conventional servo drives (e.g. AX2000) these parameter are not stored on the AX5000 itself, but in the TwinCAT project for the higher-level control system (NC on the IPC).

The parameter are transferred from the NC to the servo drive during startup of the EtherCAT system. Due to the high data transfer rate offered by EtherCAT this process is very fast, even in larger systems.

Transitions

During startup the EtherCAT system passes through the following states: Init, Pre-Operational, Safe-Operational, and Operational (see section EtherCAT state machine).

The diagram shows the following transitions:

IP: | Transition from Init to Pre-Operational
PS: | Transition from Pre-Operational to Safe-Operational
SO: | Transition from Safe-Operational to Operational
OS: | Transition from Operational to Safe-Operational
SP: | Transition from Safe-Operational to Pre-Operational
PI: | Transition from Pre-Operational to Init

In practice the parameters (IDNs) are transferred from the higher-level control system to the AX5000 during transitions IP, PS and SO.

The TwinCAT System Manager indicates at which transition the individual AX5000 parameters can be transferred.


AX5000 - First steps

BECKHOFF AX5000: Commissioning

First steps

To facilitate commissioning of AX5000 servo drives the commissioning tool is integrated in the TwinCAT System Manager. This means that existing and familiar tools such as the oscilloscope can be used without the need to use a different tool for fine-tuning in TwinCAT after the axes have been optimised. Before the actual commissioning you should first consider the overall configuration of the machine. There are several things to observe, particularly in relation to fault management in the case of the 2-channel AX5000.

Integration of axes

Requirements:

  • Control voltage : 24 VDC
  • EtherCAT connection with master card
  • TwinCAT in Config Mode

First the bus is scanned for connected EtherCAT devices:

Select the EtherCAT interface card

Search for connected devices (Scan for boxes):

Acknowledge the request "Activate Free Run" with NO.

If EtherCAT axes are found the system asks whether the axes should be linked in TwinCAT NC. Confirm with Yes.

All axes that were found appear in the NC configuration. They now have to be configured in turn. Open the "Settings" tab.
AX5000 servo drives are displayed as EtherCAT with communication type SoE (Sercos profile over EtherCAT).

The axis details can be found in the I/O Configuration. Open the required axis. Open the TC Drive Manager via the "Configuration" tab.
The TC Drive Manager includes all required data, parameters and tools for configuring and commissioning a servo axis. The menu tree distinguishes
between equipment data and axis data. For multi-axis devices (e.g. AX5206) the axis data are identified as channel A and channel B.

Description of the menu bar:

Menu item Device Info contains all device-specific data such as capacity, serial number, .....

Menu item Power Management is used to set the mains voltage with country-specific upper and lower tolerance. The internal or external brake resistor can also
be selected and dimensioned in this menu.

Menu item Display is used to specify individual error messages etc.

Menu item Scope .....

Menu item Watch Window .....

In the next step the axis-specific parameters and data are set.
The connected motor is selected from the motor database in the Motor and Feedback section.

In the upper section of the Startup list all parameters / IDNs can be found that are available as default or may already have been modified.
All further parameters that are called up via the TC Drive Manager can be found in the lower section. Add these parameters to the
Startup list with Accept All.

Startup list after all parameters have been entered:

Repeat this procedure is for all other axes.

Now switch to NC configuration:
First the scaling factor has to be calculated. Example: One motor revolution corresponds to 40 mm linear feed. The resolution
of the encoder in TwinCAT is 2^20. The scaling factor is therefore 40 / 2^20 = 0.0000381469 mm/INC. Enter and save
this value.

If the AX5000 is operated via the velocity interface the encoder overflow for modulo mode must be calculated. Click
Calculate and Download.

In the next step the maximum permissible axis velocity is calculated and entered: In our example:
40 mm feed x 3000 rpm / 60 = 2000 mm/s. This value can be stored as reference velocitiy.


AX5000 – EtherCAT synchronisation

BECKHOFF AX5000: Commissioning

EtherCAT synchronisation

So-called EtherCAT telegrams (ECT) are sent by the EtherCAT master to all connected EtherCAT slave controllers (ESC). An ESC is an electronic module that performs continually synchronous sequences of calculations and/or data copying actions, based on the ECT, at a certain time interval (clock). The configuration file of the ESC describes which information from the ECT is processed and how. In drive technology it is extremely important that the synchronicity of the data and the slaves is always ensured due to the very short cycle times. The synchronicity of the slaves is achieved via so-called “Distributed Clocks” and information on this can be read in the EtherCAT documentation. The following description deals exclusively with the synchronisation of the data.

EtherCAT Master

The EtherCAT master reads the AX5000 config. file and writes "DT0 = 250 µs" and "DT1 = NC cycle time" to the corresponding ESC registers once during the system start-up. These values are continuously read by the ESC from the register and serve Sync0 und Sync1. If the contents of this register are lost or if the values are overwritten during operation, this leads to problems with Sync0 and/or Sync1.

EtherCAT slave controller (ESC)

The ESC of the AX5000 regularly sends two signals (Sync0 and Sync1) for synchronisation (DT0 and DT1) to the CPU of the AX5000.

Sync0

The interrupts "i" from "Sync0" are sent as standard every 250 µs. If an interrupt fails to arrive (see F0), the CPU generates the error code F414 and the connected axes are brought to a standstill with the "EStop ramp".

Additional error messages:
The Sync0 cycle time may only be configured with 62.5 µs, 125 µs or 250 µs, otherwise the CPU generates the error code F409.
If the synchronisation "Sync0" is not activated in the ESC, the CPU generates the error code F410.
If the pulse length of the interrupt no longer conforms to the standard, the CPU generates the error code F411.
In the case of each error message the connected axes are brought to a standstill with the "EStop ramp".

Sync1

The interrupts "i" of "Sync1" are sent as standard in accordance with the NC cycle time. This cycle time is always a multiple of Sync0 and is 1 ms as standard. If an interrupt fails to arrive (see F1), the CPU likewise generates the error code F414 and the connected axes are brought to a standstill with the "EStop ramp".

Additional error messages:
The Sync1 cycle time must be a multiple of the Sync0 cycle time and must be identical to the parameters "S-0-0001 and S-0-0002", otherwise the CPU generates the error code F412.
If the synchronisation "Sync1" is not activated in the ESC, the CPU generates the error code F413.
If the pulse length of the interrupt no longer conforms to the standard, the CPU generates the error code F411.
In the case of each error message the connected axes are brought to a standstill with the "EStop ramp".

End of telegram (EOT)

The ESC reads the ECT as soon as it arrives; the correct time is shortly before Sync1. The data intended for the ESC are then read from the ECT and written into the data area of SyncMan2. The EOT thus lags slightly behind the interrupt of Sync1 by the time DT2; the status of SyncMan2 is subsequently set to "SyncMan written". The CPU only copies the data from SyncMan2 into its own memory area if this status is "SyncMan written" at the time of Sync1. The data are not copied if the status is not "SyncMan written" (see F2); if the data cannot be copied twice in succession, the CPU generates the error code F415 and the connected axes are brought to a standstill with the "EStop ramp".

Note 		Jitter!
The tolerance for the presence of the telegram at the correct time, due to "jitter" etc., is ZERO. The EtherCAT master must ensure that the data arrive at the SyncMan2 in time.

.

Special notes concerning the diagnostic message F415 “Distributed Clocks: process data synchronisation”

The real-time behaviour of the machine is continuously monitored during operation. An important component of this monitoring is the synchronisation of all hardware and software components involved in data transfer. The illustrations below represent a simplified example of this data transfer. The focus is on the drive tasks “NC” and “PLC”.

Example 1

  1. The CPU timer sends interrupts on a regular basis (default: base time = 1 ms)
  2. The individual tasks are now processed in accordance with the rules of task management.
  3. Task management:
    Since the task takes up a greater or smaller amount of time due to a higher or lower number of computing processes, the “I/O update” should be parameterised directly after the entry point (a) at the start of the task. This excludes one source of incorrect synchronisation.
    A further source of error is an unfavourable prioritisation of the individual tasks (see below).
  4. Following the “I/O update”, the resulting data are transferred to the TwinCAT-IO system and subsequently dispatched by EtherCAT telegram to the connected devices. The EtherCAT telegram passes through each physically connected device and hands over or picks up only the data for this device.
  5. The order of task calculation depends among other things on the prioritisation of the tasks. If a task has a higher priority, it is also calculated first and can send its data to the TwinCAT-IO system, which then dispatches the telegram. Problems usually occur when individual tasks have different cycle times; see below.

Prioritisation

The following graph describes the effects of prioritisation on the synchronisation of the data.

Assumptions:

Sync1 = 3 ms
NC cycle time = 3 ms
NC priority = 10
PLC cycle time = 2 ms
PLC priority = 5
NC data are to be transmitted cyclically to the drive. Although the PLC requires time to compute, no data are transmitted to the drive.

Due to its higher priority, the PLC task is always calculated before the NC task; these tasks affect each other at the start point time ‘0 ms’ and then repetitively every ‘6 ms’, i.e. 2x Sync1. However, the ESC expects the EtherCAT telegram with the NC data at each Sync1 (3 ms). That is not ensured, however, because the more highly prioritised PLC task is always calculated before the NC task and thus in the case of synchronous mapping the telegram start is delayed. For this reason the NC telegram arrives somewhat later every 6 ms and can thus cause the F415 error in the AX5000.

Example 2

  1. The CPU timer sends interrupts on a regular basis (default: base time = 1 ms)
  2. The individual tasks are now processed in accordance with the rules of task management.
  3. Task management:
    Since the task takes up a greater or smaller amount of time due to a higher or lower number of computing processes, the “I/O update” should be parameterised directly after the entry point (a) at the start of the task. This excludes one source of incorrect synchronisation.
    A further source of error is an unfavourable prioritisation of the individual tasks (see below).
  4. Following the “I/O update”, the resulting data are transferred to the TwinCAT-IO system and subsequently dispatched by EtherCAT telegram to the connected devices. The EtherCAT telegram passes through each physically connected device and hands over or picks up only the data for this device.
  5. The order of task calculation depends among other things on the prioritisation of the tasks. If a task has a higher priority, it is also calculated first and can send its data to the TwinCAT-IO system, which then dispatches the telegram. Problems usually occur when individual tasks have different cycle times; see below.

Prioritisation

The following graph describes the effects of prioritisation on the synchronisation of the data.

Assumptions:

Sync1 = 3 ms
NC cycle time = 2 ms
NC priority = 5
PLC cycle time = 3 ms
PLC priority = 25
NC task serves only devices in SyncUnit 1, synchronous mapping
PLC task serves only devices in SyncUnit 2, synchronous mapping
NC and PLC data are to be transferred cyclically.

Due to its higher priority, the NC task is always calculated before the PLC task and the telegram is accordingly also sent first; these tasks affect each other at the start point time ‘0 ms’ and then repetitively every ‘6 ms’, i.e. 2x Sync1. However, the ESC expects an EtherCAT telegram at each Sync1 (3 ms). This is not a problem in SyncUnit 1, which is served by the NC, since the more highly prioritised NC always sends the telegram in the same time pattern. However, the PLC telegram arrives somewhat later every 6 ms and can thus cause the F415 error in the AX5000 in SyncUnit 2.


AX5000 - Operating modes

BECKHOFF AX5000: Product overview

Operating modes

In drive technology a distinction is made between the following operating modes:

  • Current / torque control
  • Speed control
  • Position control

Electrical drives tend to be speed- or position-controlled. In the SoE standard the individual operating modes are specified via the standard parameter S-0-0032 (main operating mode).

Mode parameterisation according to SoE
S-0-0032 (main operating mode)
Bits 0-8 | Operation mode | Bit 3
0 0000 0000 | no mode selected |
0 0000 0001 | torque control |
0 0000 0010 | Velocity regulation |
0 0000 X011 | Position control with position encoder 1 (motor resolver MG) | 0 with following error / 1 without following error
0 0000 X100 | Position control with position encoder 2 (external encoder EG) | 0 with following error / 1 without following error
0 0000 X101 | Position control with position encoder 1 + 2 | 0 with following error / 1 without following error

The diagram shows a typical control structure with higher-level position controller and subordinate speed and current controller.

Fig. 1: Controller structure

A cascaded controller structure consisting of current, speed and position controllers has proven to be necessary for achieving high dynamics and positioning accuracy. The diagram illustrates the time constants of the individual control loops, rising from inside to outside. Two operating modes are suitable for positioning: velocity set value specification or position set value specification.

Position specification

Fig. 1 also shows the interpolation generator. This can take the form of an external software or hardware solution or an option inherent in the servo drive. For the AX5000 TwinCAT PTP/NCI or TwinCAT CNC is used. This set value generator splits the travel command into small position segments. These segments have a temporal resolution that is set via the interpolation cycle (task time of the SAF task of the NC).

Fig. 2: Position specification

This mode is configured via parameter S-0-0032. The individual modes are shown in Table 1. In addition to the internal position controller velocity pre-control can be activated. If no pre-control is used the set value for the speed controller only consists of the product of the control deviation and the position controller gain.

Fig. 3: Positioning without velocity pre-control

S-0-0032 (main operating mode)
0 0000 0011 | 0x03 | Position control with position encoder 1 (motor resolver MG) / with following error
0 0000 0100 | 0x04 | Position control with position encoder 2 (external sensor EG) / with following error

Pre-control is generally advisable. Depending on the application the weighting of this parameter can be set between 0 and 100%. The following block diagram shows two options. One option is to calculate the pre-control in the drive. Using a simplified technique, the set position at time n Sn is subtracted from the set position from the pre-cycle and divided by the cycle time. Another option is to use the set velocity of the interpolation generator.

Fig. 4: Velocity pre-control

If velocity pre-control is used for positioning, the following error during the whole positioning process is relatively small (see Fig. 5).

Fig. 5: Positioning with velocity pre-control

S-0-0032 (main operating mode)
0 0000 1011 | 0x0B | Position control with position encoder 1 (motor encoder MG) / without following error
0 0000 1100 | 0x0C | Position control with position encoder 2 (external encoder EG) / without following error

Velocity specification

If the servo drive has no position controller or if the set velocity has to be influenced with additional components, the position controller can be moved to the interpolation generator. In this mode is the travel command is not only split into small position segments but also into velocity segments. The set velocity calculated by the interpolator is complemented by the value calculated by the TwinCAT-PTP position controller due to a following error.

Fig. 6: Control structure in velocity specification mode

As for position specification, the interpolation points for the velocity set values have a temporal resolution that is greater than the interpolation cycle (task time of the SAF task of the NC).

Fig. 7: Velocity specification

This mode is configured via parameter S-0-0032.

S-0-0032 (main operating mode)
0 0000 0010 0x02 Velocity regulation

A further mode is torque control. In this mode is the set torque is specified. The actual torque is returned as feedback. Torque control is handled by the drive. If the actual value is based on an external measuring point, regulation (set value generation) should be provided in the control system.

Fig. 8: Torque specification

S-0-0032 (main operating mode)
0 0000 0001 0x01 torque control


AX5000 - Drive functions

BECKHOFF AX5000: Commissioning

Drive functions

CAUTION 		Hazard to individuals and devices!
Please read the following functional descriptions carefully and parameterise the relevant functions.

Stopping the drive

Quick stop (S-0-0372) and emergency stop (S-0-0429)

The two stopping procedures are defined using ramp functions which the AX5000 uses to stop the connected motors. The two ramp functions are parameterised using IDN S-0-372 (quick stop) and IDN S-0-0429 (emergency stop). The braking energy balance for the whole system must be borne in mind when parameterising these IDNs. The max. deceleration is influenced by both mechanical and electrical limit values. The electrical limit results primarily from the available power. When this has reached the maximum, no further braking energy can be supplied and the delay time will take correspondingly longer. A further electrical limit is the absorption of regenerative energy which is produced during braking. This energy is first absorbed by a DC link and, when this is saturated, internal or external brake resistors take over the absorption of braking energy.

It is not necessary to activate these braking functions manually during normal operation as "normal" braking procedures are carried out by the set value generator. It is essential to manually actuate the braking functions during commissioning in order to assess the braking procedures.

Under certain circumstances "Quick stop" can be actuated using the bit "14" (enable drive) of IDN S-0-0134 (Master control word).

The "Emergency stop" is only actuated by a drive error and can be actuated using the parameter P-0-0310 (Error reaction verification) "Force error reaction: Closed loop ramp".

CAUTION 		Danger to persons from unexpected movements.
After parameterising the IDNs "S-0-0372" and "S-0-0429" for stopping the drive, the corresponding ramp function must always be tested manually again. This is necessary to ensure that the mechanical or electrical conditions enable reliable operation.

Limit switch monitoring

A translatory drive motion generally results in a finite travel path. In order to be able to protect the mechanical end positions, limit switches must be installed at a distance s to the end positions. If one of the switches is actuated, then the servo drive stops the axis by means of a stop ramp (S-0-0372 or S-0-429).

Limit switch properties (P-0-0401)
Configuration |  | Reaction | Source
0 | No limit switch (default) |  | digital input 0 ... 7
1 | N/C contact | 0 = Axis generates an error and is stopped by the emergency stop S-0-0429. 1 = Axis generates a warning and is stopped by the emergency stop S-0-0429. 2 = Axis generates a warning and is stopped by the quick stop S-0-0372 (default).
2 | N/O contact

This structure is available twice under IDN P-0-0401, i.e. for the negative and the positive limit switch.

Example

A short example for calculating the distance between the limit switch and the mechanical limit stop is shown below:

Example
Parameter no. | Designation | Value | Unit
S-0-0372 | Emergency ramp | 6283.18 | rad/s2
S-0-0429 | Stop ramp | 6283.18 | rad/s2
S-0-0091 | Maximum speed, bipolar | 6000 | rpm
S-0-0079 | Rotational position resolution | 1048576 | inc/rev
Machine data | Feed | 20 | mm/rev

Distance between mechanical limit stop and switch:

Hardware enable

On the AX5000 a hardware enable can be configured. This function operates in addition to the software enable originating from the controller via the bus system and a logical AND link. The digital input for the servocontroller is activated and allocated via parameter P-0-0400.

This function is not limited to a special input.

Ready to operate

The AX5000 can be integrated in the ready-chain of the machine via the device configuration. This function requires a digital input and a digital output. Activation of this function and allocation to the respective input and output is realised in parameter P-0.04002. Since only digital input no. 8 can optionally be configured as output, only digital output no. 8 is offered as output number.

(Electrical properties in preparation)

Controlling the motor brake

If the motor is equipped with a motor brake, this brake is controlled via the servocontroller. The brake is configured via parameter P-0-0060. This parameter is part of the XML description of the motor. The brake can be locked and unlocked via the TcDriveManager as required.

If the brake has to be controlled from the application, parameter P-0-0096 is available as motor control word and P-0-0097 as motor status word. The following table shows the command sequence for unlocking and locking the brake from the PLC.

Unlock the brake |  | Lock the brake
Control word | Status word | Control word | Status word
 | 0x0000 |  | 0x0000
0x0002 |  | 0x0001 |
 | 0x0002 |  | 0x0001

The brake response times are configured in parameter S-0-0206 for (enable) and parameters S-0-0207 (disable).

Mains voltage monitoring

The servo drive monitors the minimum and maximum values of the connected mains voltage. To this end the value of the connected voltage and the permitted tolerance values are specified. The diagram below shows the TCDriveManager configuration option. The section outlined in red is used for configuring the mains voltage with min./max. values. Mains phase monitoring is activated or deactivated in the section outlined in purple. Phase monitoring is always based on 3-phase mains.

Note 		Phase monitoring
With a single-phase mains supply phase monitoring must be deactivated for the servo drive to work.

The values are limited to 50% in maximum and minimum direction. The relevant parameters are P-0-0201, P-0-0202, P-0-0203, and P-0-0204.

Active DC link integration

(in preparation)

Digital inputs and outputs

All AX5000 devices have 8 digital inputs, irrespective of the type (1- or 2-channel) (inputs 0 to 7). Input no. 7 can be reconfigured as output. The digital I/Os can be allocated to channel A or B.

The status of the digital inputs is represented in parameter P-0-0801. This parameter can be transferred in the cyclical interface, so that the information is available in the PLC and NC.

The decision to use input no. 7 as output can be implemented in two different ways, through allocation to the PLC output (P-0-0800), or through allocation of this bit to a drive function that sets this output as a result. An example for the second option is the ready to operate function of the servocontroller. If the PLC output is used the value is transferred via parameter P-0-0802.

The differentiation between the controller and the PLC as the signal source is specified in parameter P-0-0801.

(Electrical properties in preparation)

Measuring probe functions

The measuring probe function enables the actual controller position to be stored event-dependent. This could also be achieved via the control unit, although with a velocity greater than 0 an error would be introduced that is proportional to the velocity. For this reason this function is allocated to the drive, where the actual position is stored and transferred to the control unit almost without time offset, depending on the digital input or a combination of event signals.


AX5000 - Diagnosis during commissioning

BECKHOFF AX5000: Commissioning

Diagnosis during commissioning

The greatest likelihood of error diagnosis occurs during the commissioning process. Incorrectly assembled cables, missing shield connection, wrongly parameterised motors / feedback systems, mechanical problems and many other issues are detected at this early stage. The machine can often not be started or stops after a short time with a diagnostic message. The most complex solutions for diagnostic messages during commissioning are described in detail below.

Notice 		Documentation for all diagnostic messages
When a diagnostic message appears, first check the information on the diagnostic message in the documentation "AX5000_DiagMessages". You will usually find suggestions for solutions there which can be implemented relatively easily. Only continue with the suggested solutions described here if the suggestions there do not solve the problem.

FA49, Feedback process channel error (1Vss)

When this diagnostic message appears it may indicate an error in the analog signal for the feedback system (1Vss). The AX5000 monitors the output signals from the sin/cos 1Vss feedback system and switches off the drive when the signal lies outside the tolerance range between 0.53 Vss and 1.34 Vss. The feedback systems are specified in such a way that they only supply exact values within the stated tolerance range. Beyond this the values may be usable but are not necessarily so.

Voltage analysis using an external oscilloscope

The values from the feedback system can be determined with the aid of an external oscilloscope (scope). You can connect an external scope between the feedback connector and the AX5000 and determine the sine and cosine voltage.

Voltage analysis using TwinCAT Scope2

If you do not have the option of using an external scope you can utilise the Scope2 integrated in TwinCAT. This requires you to make the following adjustments.

Parameterisation of the IDNs P-0-0150 / P-0-0180

Notice 		Feedback system 1 or 2
The diagnostic message FA49 applies to both feedback systems 1 and 2. You can find out which feedback system is currently affected by pointing the mouse cursor at the diagnostic message in the TCDriveManager. A tool tip will then appear showing the faulty feedback system.

The IDN P-0-0150 described below applies to feedback system 1.
The IDN P-0-0180 applies to feedback system 2 and has the same structure as P-0-0150.

Open the System Manager and select the servo drive (1) which is generating the error. Open the TCDriveManager (2) and select the faulty feedback (4) in the affected channel (3). In the IDN "P-0-0150" (5) under the "Sin / Cos" parameter (6) open the value range (8) under the Parameter "SinCos 1Vss monitoring". Four options appear.

0 = Error monitoring (full error monitoring)
1 = Error monitoring and Sin/Cos logging (full error monitoring and logging of sin/cos values)
2 = Error monitoring (only wire break detection) and Sin/Cos logging (only wire break detection and logging of sin/cos values)
3 = Error monitoring (only wire break detection)

Only options 1 and 2 are useful for working with the scope 2 as these also display the sin/cos signals.
Whether to select option 1 or 2 should generally be decided depending on the application. However, there are two rough indications for making the choice:

If the faulty axis can no longer be used because the error always occurs immediately, then you need to select the "2 = (only wire break detection and logging of sin/cos values)" option so that the error can occur and be logged.

If the faulty axis can be operated because the error only occurs sporadically, then you can select "1 = (full error monitoring and logging of sin/cos values)" or "2 = (only wire break detection and logging of sin/cos values)" so that the error can always be logged.

WARNING 		Warning, risk of injury from uncontrolled movements!
If a faulty axis is used then this axis may make uncontrolled movements. Make sure that no one is in the machine's traversing range.

In many cases the faulty axis can also be moved manually and this option should be used preferentially for safety reasons.

Adding the debug pointer to the Startup list

In order for the sin/cos signals to be logged, the relevant debug pointers must be added to the AX5000 Startup list. Call the Startup list in the TCDriveManager using the button (9) and click on "Add" (10). A window opens with a list of parameters including P-0-1006 to P-0-1010 (11).

The IDNs need to be parameterised before being added to the Startup list. The IDNs P-0-1006 and P-0-1007 denote sine signals, the IDNs P-0-1009 and P-0-1010 cosine signals; the structures are the same for sines and cosines.

For the IDN "P-0-1006" under "Addr" select the address "0xA000 Sin/Cos ChA: Sin (Int16)" (12).

Under "Source" select the faulty feedback system, where "0: Front" refers to the feedback system on the front of the AX5000 and "1: Option" refers to the feedback system on the AX5701 / 02 option card.

For the IDN "P-0-1007" select the option "2: Decimal 16".

You now need to repeat the procedure with the IDNs "P-0-1009" and "P-0-1010". For the IDN "P-0-1009" under "Addr" enter the value "0xA001: Sin/Cos ChA: Cos (Int16)".

Select the four IDNs and press "OK" so that the IDNs are entered in the Startup list.

Activating the configuration

In the TCDriveManager (14), click in the tree on "Process Data/Operation Mode". A new window opens where, under "AT or MDT", you select "AT" (16). Next highlight the two IDNs "P-0-1008" and "P-0-1011" (17) and move them into the "Parameter for Process Data" window by clicking on the ">>" button (18).

Under the relevant EtherCAT Device (19), activate the ADS Server (20). Now check the boxes beside "Enable ADS Server" and "Create symbols" (21). The "Port" (22) is entered automatically.

Start "TwinCAT Scope2" and check whether the amplitude values are permissible. The scaling factor is 1 / 46602.


Reference Movement

The TwinCAT NC can reference the axis at the AX5000 using the probe unit of AX5000.

The probe unit should be configured within the startup list, although configuration is also possible during axis operation (at runtime). In order for the TwinCAT NC to be able to control the probe unit and respond to its status, IDNs S-0-0405 and S-0-0406 have to be mapped into the real-time control and status bit 2. This is achieved through associated entries in IDNs S-0-0303 and S-0-0307.

Configuration of the real-time control and status bits:

The position stored by the drive with the probe unit is held in IDN S-0-0130 (probe value 1 positive edge) or in IDN S-0-0131 (probe value 1 negative edge). One of these two IDNs is cyclically transferred to the NC with the AT telegram according to the configured edge.

Cyclical transfer of IDN S-0-0130 with the AT frame:

The AX5000 probe unit is activated with the "Probing cycle procedure" command (S-0-0170). When this command is activated the probe unit configuration are transferred internally. The configuration data are write-protected while the command is active.

The "Probing cycle procedure commands" can be activated by setting the IDN parameter to 3 (set and enable). The commands can also be started via the startup list in the transition from safe SafeOp to Op.

Configuration of the probe unit see AX5000_ProbeUnit.


AX5000 Probe Unit

BECKHOFF AX5000: Commissioning

Probe Unit

The latch/probe functionality implemented in the AX5000 is compliant with the probe functionality defined in the Sercos specification (v2.4).

IDNs involved

Note 		IDN-description
A detailed description of the individual IDNs can be found the following document: AX5000 - IDN Descriptions.
IDN | Name
S-0-0130 | Probe 1 value positive edge
S-0-0131 | Probe 1 value negative edge
S-0-0169 | Probe control parameter
S-0-0170 | Probing cycle procedure command (pc)
S-0-0179 | Probe status
S-0-0405 | Probe 1 enable
S-0-0409 | Probe 1 positive latched
S-0-0410 | Probe 1 negative latched
P-0-0154 | Feedback 1 reference signal
P-0-0250 | Probe 1 value source
P-0-0251 | Probe 1 logic configuration
P-0-0252 | Probe 1 logic state
P-0-0253 | Probe 1 time positive edge
P-0-0254 | Probe 1 time negative edge
P-0-0255* | Probe 1 time difference: reference switch to index
P-0-0256* | Probe 1 data

*) In preparation.

Functioning

The signal source (reference signal feedback, RSF) is selected with IDN P-0-0251. The reference signal of the encoder system or a simple digital input or a combination of 2 inputs can be selected.

The following signals are available for selection:

Multiplexer 1, see drive parameter description (IDNs)
P-0-0251.Mux1 | Input
0 | DigIn 0
1 | DigIn 1
2 | DigIn 2
3 | DigIn3
4 | DigIn4
5 | DigIn5
6 | DigIn6
7 | DigIn7
Multiplexer 2
P-0-0251.Mux1 | Input
0 | DigIn 0
1 | DigIn 1
2 | DigIn 2
3 | DigIn3
4 | DigIn4
5 | DigIn5
6 | DigIn6
7 | DigIn7
8 | Reference Signal Feedback Front
9 | Reference Signal Feedback Option Card
 | rsvd.
Reference Signal Feedback Front
P-0-0154 | Input
0 | Zero Index
1 | Magnitude of sine signal
2 | Magnitude of cosine signal
3 | rsvd

The parameter P-0-0154.ThresholdVoltage can be used to modify the threshold level (if zero index is selected).

IDN P-0-0154 can only be edited in EtherCAT state PreOperational. In states SafeOperational and Operational this IDN is write-protected.

The selected signals are linked via the following logic:

Logic
P-0-0251.Logic | Logic output
0 | Output Mux 1
1 | Output Mux 2
2 | Ouptut Mux 1 AND Output Mux 2
3 | Output Mux 1 OR Output Mux 2
5 | Output Mux 1 AND rising edge output Mux 2
Probe Value-Source

IDN P-0-0250 is used to select which value (e.g. actual position) is to be stored for the latch event.

P-0-0250 | Source
0 | Position feedback value 1 (S-0-0051)
1 | rsvd

The command S-0-0170 is activated internally in the probe cycle, and the parameters of IDNs P-0-0250 and P-0-0251 are transferred internally. These two IDNs are write-protected as long as this command is active.

IDN P-0-0252 indicates the current sate of the logic upstream of the probe unit.

IDN S-0-0169 is used to activate edges at which a latch event is to be triggered.

The probe unit is activated with IDN S-0-0405. If S-0-0405 is associated with a falling edge the result-registers are reset to 0.

IDN-S.0-0179 (or S-0-0409 and S-0-0410) indicates whether a latch event has occurred.

After a latch event the associated data are entered in IDNs S-0-0130, S-0-0131, P-0-0253, and P-0-0254.

Configuration sequence
  1. Feedback 1 reference signal (P-0-0154) (only possible in EtherCAT state PreOperational)
  2. Probe 1 value source (P-0-0250)
  3. Probe 1 logic configuration (P-0-0251)
  4. Start of "Probing cycle procedure commands" (S-0-0170)
  5. Probe control parameter (S-0-0169)
  6. Probe enable (S-0-0405)


AX5000 - Homing

Beckhoff AX5000: Homing

Homing

Homing refers to an axis initialisation run during which the correct actual position is determined by means of a reference signal. This procedure is referred to as homing, referencing or calibration. A switch that is triggered at a known, unique position along the travel path serves as reference signal. Further signals such as the encoder zero track can be analysed in order to increase the precision.

In general a distinction is made between drive-controlled homing and NC-controlled homing. Drive-controlled homing is carried out automatically by a suitable drive without input from the control system and is not discussed in detail in this documentation. NC-controlled homing is fully controlled by the control system and supports a wide range of drive types. The different NC-controlled homing mechanisms are described below.

Position reference systems and encoder systems

A distinction is made between different position reference systems (measurement systems), depending on which position measuring system is used. An absolute measurement system provides an absolute position (directly after switching on) that is unique over the whole travel path. Such a measurement system is calibrated once and set via a persistently stored position offset. In this case homing is not required even after a system restart. In contrast, relative measurement systems provide a non-unambiguous position value (after switching on) that must be calibrated through homing. Relative measurement systems are subdivided further into purely relative systems (incremental encoders) and part-absolute systems, which only provide a unique position during a motor or encoder revolution.

  • Absolute position - e.g. multi-turn encoder
    • BiSS
    • EnDat
    • Hiperface
    • SSI
  • Part-absolute position - e.g. single-turn encoder
    • BiSS
    • EnDat
    • Hiperface
    • MES (Beckhoff)
    • Resolver
  • Relative position - incremental encoders
    • Sine / cosine (sine 1 Vss)
    • TTL, HTL (rectangle)

General description of a homing procedure

Figure A shows a schematic diagram of a homing procedure with individual velocity profile phases.

  1. When the machine is switched on the axis is in a random position (1).
  2. Homing is initiated, and the axis travels towards the reference cam.
  3. Once the reference cam is detected, the axis stops and reverses.
  4. The axis moves away from the reference cam and detects the falling edge of the reference cam signal.
  5. The axis continues and searches for a sync pulse or another distinctive event, depending on the reference mode setting. This step may be omitted where appropriate.
  6. The occasion is detected and the specified reference position is set.
  7. The axis stops at a certain distance from the reference position, which was set shortly beforehand with maximum precision.

Figures B and C show the position and velocity profile during homing.

Referencing modes

The NC system supports different referencing modes, depending on the encoder system type.

  • Homing based on reference cam (Plc Cam)
    The simplest axis referencing mode uses a reference cam that generates a digital signal at a defined position along the travel path. During homing the NC determines the signal edge and allocates a configurable reference position to this position. Referencing based on a reference cam is always possible, irrespective of the encoder type, and is a prerequisite for other, more precise modes.
  • Software Sync
    Software Sync mode enhances the homing precision by additionally detecting the encoder count overflow after an encoder or motor revolution, after the reference cam signal has been detected. This mode requires a part-absolute encoder (e.g. resolver) with constant overflow interval relative to the reference cam. Overflow detection is parameterised via the Reference Mask parameter (see System Manager section).
  • Hardware Sync
    Some encoder systems provide a sync pulse per revolution (zero track) in addition to the count. The homing precision can be enhanced by selecting this mode, if the encoder evaluation logic is able to pick up the sync pulse. The precision is comparable with Software Sync. Hardware Sync mode may require parameterisation or special wiring of the drive or encoder system.
  • Hardware Latch
    Hardware Latch reference mode (Hardware Latch Pos or Hardware Latch Neg, depending on edge) requires an external digital latch signal for storing the encoder position in the evaluation unit of the encoder system. The encoder system must support such a latch function and may have to be configured first in order to be able to utilise this function.
 | Absolute encoder system | Part-absolute encoder system | Relative encoder system
NC | Referencing not required | Recommended reference mode SoftwareSync (also possible: PlcCam, HardwareSync) | Recommended reference mode HardwareSync (also possible: PlcCam)
Drive | Referencing not required | Drive setting not required | Drive parameterisation required (for Sercos/SoE see Probe Unit)

Parameterisation in the System Manager

Reference system: The encoder parameters reference system determines whether the encoder system used is incremental or absolute. In an absolute encoder system the encoder value is taken from the control system without modification.

Not all NC encoders support this optional parameter, i.e. only those types that offer a choice between absolute and incremental encoder reference system (measurement system) support it (e.g. SERCOS, KL5001, M3000, ProfiDrive, Universal). This choice determines whether the actual encoder position is interpreted and evaluated as an absolute or incremental position, based on an absolute or incremental reference system (measurement system).

In an absolute reference system no further processing takes place with regard to encoder counter value overflow or underflow. It is assumed that the counter value is unique within the axis traversing range and no encoder counter value overflow or underflow occurs. Otherwise there would be a discontinuity in the actual position, resulting in a position following error. Axis referencing via MC_Home is not possible. Instead, the actual position is calibrated once via the Position Bias parameter (zero offset / position offset).

In an incremental reference system axis referencing via MC-Home is generally required. In addition the NC automatically detects and accounts for encoder counter value overflow or underflow events, so that continuous axis operation is possible over many months ("infinite range").

Encoder Mask (maximum value): The encoder mask determines the bit width for the incremental encoder position. The encoder mask is used for detecting and counting in range overflow events.

Scaling Factor: The scaling factor is multiplied with the incremental encoder position (including all overflows) and used as the basis for calculating an absolute axis position with the parameterised physical unit.

Position Bias (zero offset): Position offset; moves the axis coordinate system relative to the encoder coordinate system. This value is mainly used in absolute encoder systems. In relative systems an offset is usually not required, since the system moves to a parameterised reference position after homing.

Invert Encoder Counting Direction: The encoder count direction can be inverted if it does not match the required logical count and travel direction.

Reference Mode: Referencing mode as described above (Plc CAM, Hardware Sync, Hardware Latch Pos, Hardware Latch Neg, Software Sync). The default mode corresponds to Plc CAM mode.

The Reference Mode parameter is used to specify the type of reference event (physical or logical event) for the referencing process. Depending on which referencing mode is parameterised the referencing procedure is either based on the hardware characteristics of the drive/encoder (e.g. hardware latch), or the reference event is only detected within the control system, i.e. without additional hardware reference.

Reference Mask: The reference mask parameterises overflow detection for Software Sync reference mode. It is less or equal the encoder mask and defines an encoder value range, which is part-absolute. Examples include the bit width of a motor revolution or the bit width of a sine period in a sine/cosine encoder. Software Sync therefore always detects the same overflow position in a part-absolute encoder system.

Calibration Value: Reference position to which the axis position is set after homing.

Invert Direction for Calibration Cam Search: The parameter inverts the axis travel direction for searching the referencing cam during homing. The standard direction is negative, i.e. towards the axis coordinate system origin.

Invert Direction for Sync Impulse Search: The parameter inverts the axis travel direction for searching the sync pulse during homing.

Referencing of coupled axes

TwinCAT enables axis coupling during referencing. The coupled axes do not necessarily have to be referenced. Axis coupling enables referencing of gantry axes, for example, provided the system can ensure that the two axes are suitably oriented relative to each another before homing. In this case the procedure is as follows:

  • Ensure that both axes can be moved in coupled mode. (Position comparison is not possible at this stage, because none of the axes is referenced.)
  • Couple axis 2 with axis 1.
  • Start homing for axis 1. Slave axis 2 will travel with axis 1.
  • Decouple the axes after the homing procedure.
  • Couple axis 1 with axis 2.
  • Start homing for axis 2. Slave axis 1 will travel with axis 2.
  • Decouple the axes after the second homing procedure.
  • Move both axes to a set position for alignment. The travel path for both axes should be minimal and may correspond to the mean value from both positions, for example.
  • Couple the axes. The coupled system is now referenced.

Programming a homing procedure in the PLC

MC_Home

The MC_Home function block is used to initiate homing from the PLC. The reference mode and further parameters are configured in the System Manager as described above. Only the reference cam signal (bCalibrationCam) is fed into the block.

Drive types and I/O interface

Homing is largely independent of the drive types used. In some cases the drive has to be parameterised, particularly if a drive latch function is used. The following section describes the AX5000 version.


AX5000 - Special characteristics in hardware end positions

Beckhoff AX5000: Homing

Special characteristics in hardware end positions

If a SERCOS or SoE drive (e.g. AX50xx) is in a hardware end position (positive or negative), the drive blocks further traversing commands in end position direction and beyond the end position (see also bit 3, drive follows command value, in the SERCOS status word), and is therefore no longer operational from a control system perspective. This means that, without special measures, the axis can often no longer be moved from the end position into the valid traversing range via TwinCAT or the control system. This situation is particularly likely to occur with drives in the velocity interface, because in this case the position control leads to frequent changes in direction in the drive velocity output.

In order to rectify this special situation, a control bit in the PlcToNc axis interface (see bit 8 called AcceptBlockedDriveSignal in nDeCtrlDWord) can be used to force TwinCAT to accept the AX50xx axis as operational and therefore enable a move from the end position into the valid traversing range.

In the past, in many cases the only alternative was to mechanically move the axis away from the end position.

NC interface:

PlcToNc axis interface, bit 8 called AcceptBlockedDriveSignal in nDeCtrlDWord

PLC interface:

TcNc-Lib, see PLC function AxisSetAcceptBlockedDriveSignal in the TwinCAT PLC Library: NC

Homing with latch function

During homing a trigger event is expected and a position value is latched, depending on the referencing mode (hardware latch). Parameterisation is required in order to be able to use the drive latch function (see AX5000 Probe Unit).


AX5000 - Probe Unit function

Beckhoff AX5000: Homing

Probe Unit function

A probe unit is a hardware-oriented functional group that can store the current axis position for a parameterisable event. The event may be an edge of a digital input in the drive, for example. The position is stored immediately without significant delay for subsequent evaluation by the control system.

The probe unit of the drive can be used for event-driven position sensing through the application program (MC_TouchProbe), or for registering a reference position during homing (MC_Home) if the NC referencing mode is set to hardware latch.

In any case, the probe unit has to be parameterised before it can be used. The following parameterisation description refers to an AX5000 drive (SoE), although it can also be used more generally for the parameterisation of a SERCOS drive.

Parameter overview

SERCOS parameters

Parameter | Value | EtherCAT transition (startup) | Description
S-0-0303 | 405 | P -> S | Allocation of real-time Control bit 2
S-0-0307 | 409 or 410 | P -> S | Allocation of real-time Status bit 2
S-0-0169 | 1, 2, 3 | P -> S | Probe control parameter
S-0-0170 | 3 | S -> O | Probing cycle procedure command

Process data - cyclic data between drive and NC axis

Parameter | Description
S-0-0130 | Probe value positive edge
S-0-0131 | Probe value negative edge

Probe unit parameterisation

The probe unit is controlled via an AX5000 configuration dialog. In multi-channel devices a probe unit is available for each channel.

In the first step a signal source (Mux1) for triggering the probe unit is selected. Digital drive inputs 0 to 7 are available for selection. To parameterise the probe unit for homing with evaluation of the encoder zero track, select Mux 2, which is the only option offering reference signal feedback.

The trigger signal can be linked with a further signal source (Mux 2). In the simplest case only one signal source is used, and the linkage logic is set accordingly.

A signal parameter determines whether the positive or negative signal edge is evaluated (Pos Edge or Neg Edge). The decision to use a particular signal edge is therefore made during drive parameterisation and cannot be made later in the control program.

The modifications entered during these initial configuration steps can be stored in the startup list for the drive, so that they are transferred to the drive on system startup. In the Startup List dialog save the modified parameters by clicking Accept All and or exit the dialog with OK.

Linking the probe unit with the NC

In a further configuration step the probe unit for the drive is linked with the NC controller. The control system operates the probe unit via the SERCOS real-time bits in the master control word and the drive status word and retrieves the latch position from the drive process data.

Startup list

To configure the real-time bits the drive startup list is extended (New...).

To enable activation of the probe unit set S-0-0303 to 405 (95 01).

The drive response is signalled in a status bit. To this end S-0-0307 is set to 409 (99 01) for a positive signal edge and 410 (9A 01) for a negative signal edge.

Finally the probe unit function must be activated. This can be achieved by setting the command S-0-0170 to 3 during startup. Please note that the drive only accepts this value during the EtherCAT transition S->O.

Process data

In order to enable the control system to evaluate the measured value, the value is included in the process data and linked with the NC axis. On the drive side one measured value is available for the positive signal edge and one for the negative signal edge.

Right-click in the PDO Content list to add a new value. Depending on the configuration the value of S-0-0130 or S-0-0131 is stored in the process data.

The measured value is automatically linked with the NC axis when a link is created between the axis and the drive. If the link was already established before the configuration described here, the link can be cancelled and recreated in order to ensure that the measured value is linked.

Startup parameter overview


AX5000 – display and navigation rocker

BECKHOFF AX5000: Installation

Display and navigation rocker

Navigation rocker

The navigation rocker is used for navigating within the display. It has 5 contact points: “right”, “left”, “top”, “bottom” and “centre”

Display

General

Starting from the standard display, you can access the configuration and command displays by pressing the right side of the navigation rocker [image]. Except with the standard display, if you do not change the display for approx. 25 seconds, the standard display is automatically shown again. The standard display is always shown if the device is working perfectly.

Display Description
The display consists of 2 lines. These two lines display independent, configurable contents.

The contents can be arranged into 4 groups.

Cyclic values (standard display):

The so-called standard display is shown permanently. The values provided can be displayed in the two lines. The two lines are preconfigured in the factory as follows:

Line 1: EtherCAT status
Line 2: DC link voltage

Error messages:

If an error occurs, the diagnostic code (hex) and a short version of the message (2+3) are shown alternately on the display. If the error concerns only channel “A”, then this display is shown only in the upper line; the standard text remains in the lower line. If the error concerns only channel “B”, then this display is shown only in the lower line; the standard text remains in the upper line. In both cases the display additionally flashes (2-5).

If the error has been rectified and acknowledged with the reset command (S-0-0099), the standard display with the cyclic values appears again (see above).

see error messages Warnings:

If a warning occurs, the display behaves in the same way as with an error message.

see error messages Information messages:

If an information message occurs, the display behaves in the same way as with an error message, but does not flash.

Cyclic values

The two lines with the cyclic values, which are shown on the standard display, are freely configurable. You can choose from 51 different cyclic values. The values are saved in IDNs and retrieved from there. The procedure for configuring line 1 and line 2 is identical:

Overview (example)

Changing the display

Starting from the standard display, press the right-hand side of the rocker [image] 1x (for line 1) or 2x (for line 2); the display [image] or [image] appears.

Display | Description
 | 1 = “M” indicates that the “menu mode” is activated. 2 = The “CycValuesLine1” menu is active. This means that the cyclic values are displayed in line 1. 3 = Indicates which cyclic values are currently displayed.

The currently displayed value determines the point of entry into the list of the cyclic values. You can change to the next cyclic value with the bottom [image] or the top [image] side of the rocker, as shown below. If the desired value has been reached, press the centre [image] of the rocker for 3 seconds. The value is adopted and the changed standard display is shown.

Error reset (command S-0-0099)

After rectifying an error, it is necessary to perform an error reset. The associated command is the IDN S-0-0099. This command can also be given directly via the display. As soon as an error occurs the display flashes continuously; the standard display is shown again and the flashing stops only after a successful error reset.

Overview

Executing the command

Press the right side of the rocker [image] 3x until the following display appears:

Display | Description
 | 1 = “M” indicates that the “menu mode” is activated. 2 = The “Reset” menu is active. 3 = Indicates which channel of the AX5000 the reset affects.

There are now 2 possibilities:

Press the centre of the rocker [image] for approx. 3 sec. to execute the reset command for channel “A”

or

Press the top or bottom side of the rocker [image] to switch to channel “B”. Now press the centre of the rocker [image] for approx. 3 sec. to execute the reset command for channel “B”; the following display appears: .

The standard display should appear again after approximately 25 seconds. If the error display is still visible after that, this means that you have not rectified the cause of the error, or that there are further errors.

Device ID

The Device ID is a configurable ID of the AX5000 in the system environment. It is saved in the IDN P-0-0020.

Overview (example)

Entering the Device ID

You can edit the 5-digit Device ID by entering the individual digits. The prerequisite for this is that the “Set Device ID” menu is active. As mentioned above, the display of the AX5000 displays freely configurable cyclic data in the upper and lower lines as standard.

Press the right side of the rocker [image] 4x until the following display appears:

Display | Description
 | 1 = “M” indicates that the “menu mode” is activated. 2 = The “Set Device ID” menu is active. 3 = Indicates which digit “X” of the Device ID is currently editable; in this example it is the last digit, i.e. “nine”. 4 = Device ID

You can now immediately edit the last digit of the Device ID by pressing the top or bottom side of the rocker [image]. The top side [image] increments the number, the bottom side [image] decrements it. After you have set the digit, there are 2 possibilities:

Press the centre of the rocker [image] for approx. 3 sec. and you can then edit the digit to the left of the current digit.

or

Press the right side of the rocker [image]; this takes you to the "Save Device ID" menu.

Notice 		Temporary memory
After you have finished editing, the changed Device ID is located in a temporary memory, which is cleared when the AX5000 is switched off. You must execute the command “Save Device ID”, so that the Device ID is saved permanently in the AX5000.

Saving the Device ID

By means of saving the Device ID, the IDN P-0-0020 is written to the AX5000 and can be used further.

If you have just changed the Device ID, press the right side of the rocker [image] and the following display appears:

If the standard display is visible, press the right side of the rocker [image] 5x until the following display appears:

Display | Description
 | 1 = “M” indicates that the “menu mode” is activated. 2 = The “Save Device ID” menu is active. 3 +4 = Indicates which Device ID will be saved.

Press the centre of the rocker [image] for approx. 3 sec. in order to save the displayed Device ID.

If saving was successful, this display appears: .

The standard display appears again after approximately 25 seconds.


Motor brake management

IDNs involved

IDN | Name
S-0-0206 | Drive on delay time
S-0-0207 | Drive off delay time
P-0-0058 | Motor brake type
P-0-0096 | Motor control word
P-0-0097 | Motor status word

Functioning

IDN S-0-0206 defines the switch-on delay between the motor current feed and releasing of the brake.

IDN-S-0-0207 defines the switch-off delay between activation of the motor brake and deactivation of the current feed.

IDN-P-0-0058 is used to configure the motor brake.

IDN-P-0097 displays the state of the motor brake.

IDN-P-0096 can be used to release the motor brake manually or requesting activation of the brake manually. This bits overwrite the internal brake request. The brake is therefore released or engaged irrespective of the motor current feed and any travel command.

WARNING 		Risk of injury!
Improper operation of IDN P-0-0096 can therefore lead to sagging of a non-energised Z axis or closing of the motor brake at full speed!


AX5000 - Commutation Methods

BECKHOFF AX5000: Commissioning

Commutation methods

The important characteristics of a servomotor, such as its very smooth running, high efficiency and optimum thermal utilization, are strongly influenced by the commutation. Commutation refers to the transfer of current from one winding to the next. The moment at which commutation takes place must be harmonized with the magnetic field of the rotor if the servomotor is to operate most effectively.

Rotary servomotors

Mechanical commutation

These motors, which use brushes, generate the alternating fields necessary for operation of the motor through sliding contacts, whose geometrical arrangement switches the current paths. Brush losses and wear are disadvantages of this simple, mechanical commutation method.

Electronic commutation

These modern motors generate the alternating field needed for operation of the motor by means of an electronic circuit which is not subject to either wear or friction. The type of motor and the encoder system in use determine the commutation method.

Absolute encoder system (motor feedback) within one rotation

Samples of this type of encoder system includes: Resolver, EnDat, BiSS and HIPERFACE

Two different commutation methods are involved here:

Mechanical adjustment of the encoder

The motor's encoder system is mechanically adjusted at the factory (the encoder and rotor are matched to one another), but the rotor position is unknown.
The commutation angle is determined once by the P160 command, using the IDN "P0-0-165_Command mode_Static current vector" and the IDN "P-0-057 "Electrical commutation offset". This means that the corresponding mechanical angle coming from the encoder system is displayed and read out in P-0-0058, and is saved in the IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (motor database). In order for the parameter to be used, the IDN "P-0-0150_Parameter chanel_Commutation mode" (motor database) must be set to 3: "Adjustable offset". The associated value of the IDN "P-0-057 "Electrical commutation offset" is also saved in the motor database.

Electronic adjustment of the encoder system

Note 		Synchronous motors!
Electronic adjustment is only required for synchronous motors. In the case of a synchronous motor, the magnetic field of the rotor is generated electronically, and therefore can be set appropriately for the electromagnetic field of the winding.

Depending on the encoder system there are, again, two different commutation methods:

  1. The encoder is always attached to the rotor by the manufacturer in the same rotary position, but the rotor position is not known.
    The commutation angle is determined once by the P160 command, using the IDN "P0-0-165_Command mode_Static current vector" and the IDN "P-0-057 "Electrical commutation offset". This means that the corresponding mechanical angle coming from the encoder system is displayed and read out in P-0-0058, and is saved in the encoder system's data store (exceptionally) and in the IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (motor database). In order for the parameter to be used, the IDN "P-0-0150_Parameter chanel_Commutation mode" (motor database) must be set to 3: "Adjustable offset". The associated value of the IDN "P-0-057 "Electrical commutation offset" is also saved in the motor database. This method requires a encoder system having a data store and a data line.
  2. The angle between the encoder system and the rotor is determined by the motor manufacturer using a command that is specific to the encoder, and is communicated to the encoder system. The encoder system stores this angle, using it for internal calculation, but the rotor position is unknown.
    The commutation angle is determined once by the P160 command, using the IDN "P0-0-165_Command mode_Static current vector" and the IDN "P-0-057 "Electrical commutation offset". This means that the corresponding mechanical angle coming from the encoder system is displayed and read out in P-0-0058, and is saved in the encoder system's data store (exceptionally) and in the IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (motor database). In order for the parameter to be used, the IDN "P-0-0150_Parameter chanel_Commutation mode" (motor database) must be set to 3: "Adjustable offset". This angle is always included in internal calculation processes. This method requires an intelligent encoder system.

Non-absolute encoder system (feedback) within one rotation

Samples of this type of encoder system includes: SIN / COS 1Vss, TTL

In this case, a special commutation procedure (wake&shake) must be run in order to determine the commutation angle. This angle is stored internally, and is taken into account during operation. If the AX5000 is switched off, or if the "EtherCAT-State machine" is switched into "Pre-op" or a lower state, the commutation angle will be lost because the encoder system is not absolute. "Wake&shake" can only operate without error when the drive system is running steadily; in other words there must not be any vibrations affecting the motor from outside. In addition, a stability investigation using the default values of the "IDN P-0-0165" is necessary the first time the system is operated.

Stability investigation

Note 		Oscillatory system!
It is important for this stability investigation to examine the application in advance and to determine the oscillation that is potentially most problematic. This case can occur under load conditions, or may be found when unloaded.

WARNING 		Warning, risk of injury from uncontrolled movements!
In the method described below, the motor shaft is brought directly to a certain position. Make sure that your application permits this movement, secure the surroundings to prevent unintentional entry, and make sure that nobody is in the hazardous area.

Oscillatory system

It is necessary to analyze the vibration pattern of an oscillating system, and to take appropriate damping measures. Oscillations always have their effect in Phase 2 of "wake&shake"; oscillations are not particularly critical in Phase 1.

Decaying oscillation

The amplitude (k) and the decay time (l) of this kind of oscillation must be found. The parameters IDN-P-0-0165 "Commutation pos control: Kp" can affect both the amplitude (k) and the decay time (l). The parameter IDN-P-0-0165 " Second phase duration" should be greater than the decay time (l).

Constant oscillation

This kind of oscillation is unacceptable, as a stable regulation process is not established. The parameters IDN-P-0-0165 "Commutation pos control: Kp" must be checked, and modified if necessary. If this does not achieve the desired result, you must damp the vibration mechanically.

Rising oscillation

This kind of oscillation is unacceptable, as a stable regulation process is not established. The parameters IDN-P-0-0165 "Commutation pos control: Kp" must be checked, and modified if necessary. If this does not achieve the desired result, you must damp the vibration mechanically.

The motor shaft is brought to freely definable electrical positions by impressing an appropriate current in the course of this investigation. When this injected current is switched off, the motor should remain in the position that it has reached. BECKHOFF recommends positions of 0°, 90°, 180° and 270°. In critical applications, eight positions (0°, 45°, 90°, 135° ...315°) should be selected instead of four. The current injection is parameterized in the IDN P-0-0165 under "Static current vector", while the freely selectable electrical position is set in the IDN P-0-0057. "Wake&shake" should be carried out in each position; stability of the system is only ensured when this has been done successfully.

Wake&shake

Note 		Oscillating system!
A mechanical remedy must be provided if the application oscillates. You can carry out the commutation up to a degree using wake&shake, but should carefully select the parameters for the IDN "P-0-0165" to make the effect of the oscillation as small as possible, since too much post-pulse oscillation will cause a commutation error. This is because the angle measured after completing the command will be entered as the commutation angle.

WARNING 		Warning, risk of injury from uncontrolled movements!
The motor shaft will be moved in steps during the process described below. In Phase 1 the maximum electrical movement is 8 x (the value from "P-0-0-0165_Fist phase position monitoring limit"). In Phase 2 it is 0.5 x (the value from "P-0-0-0165_Fist phase step width"). This formula can only be applied if the previous investigation of stability has been concluded satisfactorily. Make sure that your application permits this movement, secure the surroundings to prevent unintentional entry, and make sure that nobody is in the hazardous area.

The wake&shake commutation function consists of two phases. An approximate determination of the rotor position is carried out in Phase 1, while Phase 2 determines the position more precisely. The aim of the commutation function is to determine the precise position of the rotor with a minimum amount of movement.

Due to the pairs of poles, servomotors exhibit a direct relationship between the electrical and mechanical rotation. One electrical rotation always corresponds to one mechanical rotation divided by the number of pole pairs. A motor with a single pair of poles is illustrated in the following example for the sake of simplifying the calculation.

Parameterization is carried out using the IDN P-0-0165 "Commutation offset calibration parameter". The quoted angles always refer to electrical rotations!

IDN P-0-0165 - Commutation offset calibration parameter

Parameter | Default | Description
Command mode | 0: Static current vector | Selection between two commutation methods
Activation | 0: manual | Selection of when the commutation process is started
Static current vector |  | Commutation methods
Current level | Stationary current in % | Current intensity of the current vector (value = 100% x P0-0093 / P0-0092)
Duration | 3000 ms | Period for which the parameterized current is maintained so that any oscillations that may be present can settle, allowing an optimum commutation angle to be reached
Wake and shake |  | Commutation methods
First phase current vector | Stationary current in % | Current intensity of the current vector (value = 100% x P0-0093 / P0-0092)
First phase ramp up time | 100 ms | Time for the current vector "a" to reach its parameterized magnitude
Second phase current level | Stationary current in % | Current intensity of the current vector (value = 100% x P0-0093 / P0-0092)
Second phase ramp up time | 500 ms | Time for the current vector "g" to reach its parameterized magnitude
Commutation pos control: Kp | 0,04 | Amplification factor. Warning: If "0" then Variant 2 will be carried out in Phase 2
Wake and shake expert |  | Warning: Only experienced users should change the following parameters!
First phase pos monitoring limit | 0.5 degrees | Minimum angle of rotation of the rotor required to detect movement
First phase step width | 22.5 degrees | Current vector offset or segment detection angle
First phase waiting time after step | 150 ms | The time from detection of movement and the next step in Phase 1 or between Phase 1 and Phase 2 (any oscillations in the system have time to settle)
Second phase duration | 3000 ms | Period for which the parameterized current is maintained so that any oscillations that may be present can settle, allowing an optimum commutation angle to be reached
Error monitoring (range of motion) | 90 degrees | The maximum movement of the rotor before it is switched off, since there would otherwise be a risk that the motor would make an uncontrolled movement.

= identifying characters for the description below

Motor with 3 pole pairs | Motor with one pair of poles
Phase 1 - approximate determination of the rotor position (motor shaft)

Step 1

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

Sequence:
A current vector "a" is developed during the time "b". Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "a". The direction of rotation "d" is transmitted to the feedback system and the AX5000, where it is stored.

Step 2

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

Sequence:
A current vector "a" is developed during the time "b". Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "a". The direction of rotation "d" is transmitted to the feedback system and the AX5000, where it is stored and analysed. If the analysis shows that the direction of rotation "d" of the rotor "c" has not changed when compared with that of the previous impressed current, the process continues.

Step 3

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

Sequence:
The current vector "a" is again set to the magnitude "e" in the direction of the rotor "c".
The current vector "a" is now again developed during the time "b". Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "a". The direction of rotation "d" is transmitted to the feedback system and the AX5000, where it is stored and analysed. In this case, the analysis shows that the direction of rotation "d" of the rotor "c" has changed when compared with that of the previous impressed current. As a result, the sector in which the rotor "c" is located has been found, and Phase 1 is therefore completed.

Example of an oscilloscope display of Phase 1
Phase 2 - precise determination of the rotor position (motor shaft)

There are two variants of the precise localization that may be used in Phase 2. In the first variant, the rotor only makes minimal movement, but this does require a very stable system with only a slight tendency to oscillate. In the second variant, the rotor can move by up to a maximum of half the sector [image], but this method is much more tolerant against oscillation.

The value set in the parameter IDN-P-0-0165 "Commutation pos control: Kp" controls which variant is used:
IDN-P-0-0165 "Commutation pos control: Kp" > 0 --> Variant 1
IDN-P-0-0165 "Commutation pos control: Kp" = 0 --> Variant 2

Variant 1 (IDN-P-0-0165 "Commutation pos control: Kp" > 0 )

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

= movement of the rotor

Sequence:
The current vector "g" is developed starting from the final position of the current vector "a" in Phase 1. Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "g". The movement is passed through the feedback system to the AX5000, and supplied to a control loop. This control loop immediately corrects the direction of the current vector. This algorithm is executed until the parameterized current intensity is achieved, and the current vector approximately coincides with the flux vector. The current is now maintained over the period "h" which ensures that optimum commutation takes place. In this control algorithm, the rotor only moves minimally through "i".

Variant 2 (IDN-P-0-0165 "Commutation pos control: Kp" = 0 )

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

= movement of the rotor

Sequence:
After determining the sector "e" in Phase 1, the current vector "g" is placed exactly in the centre of the sector "e", and this current is developed. Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "g" until they coincide. In this static alignment, the rotor cannot move more than half the width of the sector "e".

Using IDN P-0-0165 to affect wake&shake
Parameter | Default | Possible causes that might require a change in the default value
First phase current level | Stationary current in % | Sluggish system, high damping --> increase value Easy-running system, low damping --> reduce value
First phase ramp up time | 100 ms | Sluggish system, high damping --> increase value Easy-running system, low damping --> reduce value
First phase pos monitoring limit | 0.5 degrees | Application only permits very limited uncontrolled changes in the movement --> reduce value The system has a small amount of damping --> reduce value The loading relationships require more overshoot --> increase value
First phase step width | 22.5 degrees |
First phase waiting time after step | 150 ms | Decay behaviour of the system: Long settling time --> increase value Short settling time --> reduce value
Second phase current level | Stationary current in % |
Second phase ramp up time | 500 ms |
Second phase duration | 3000 ms |
Error monitoring (range of motion) | 90 degrees | Application only permits very limited uncontrolled changes in the movement --> reduce value The system has a small amount of damping --> reduce value The loading relationships require more overshoot --> increase value
Commutation pos control: Kp | 0,04 | High load stiffness --> increase value Low load stiffness --> reduce value A special case "0": Variant 2 is carried out in Phase 2

Linear motors

The above description of the commutation process applies equally to rotary motors and to linear motors. Depending on the construction, there are merely some differences of nomenclature (e.g. motor shaft (rotor) @ primary assembly; "degree" @ "mm" (recalculation is needed))

WARNING 		Warning, risk of injury from uncontrolled movements!
The primary assembly is moved in steps during "wake&shake". In Phase 1 the maximum electrical movement is 8 x (the value from "P-0-0-0165_Fist phase position monitoring limit"). In Phase 2 it is 0.5 x (the value from "P-0-0-0165_Fist phase step width"). This formula can only be applied if the previous investigation of stability has been concluded satisfactorily. Make sure that your application permits this movement, secure the surroundings to prevent unintentional entry, and make sure that nobody is in the hazardous area.

Linear motors consist of a secondary assembly, whose position is fixed, onto which permanent magnets are attached with alternating polarity and regular spacing. A primary assembly can undergo translatory movement above this magnetic field. This movement is created by generating an electromagnetic field in the primary assembly. Linear motors always have only one pair of poles, and the distance between the poles therefore corresponds to one electrical rotation.

The "Electronic Commutation" section above can be applied to linear motors.

Commutation error "F2A0"

During operation of the motor the commutation is permanently monitored. The following conditions must apply in order for the AX5000 to detect a commutation error:

  1. The current velocity must be higher than the limit speed set in the IDN "P-0-0069 Commutation monitoring"
  2. The power and acceleration vectors must have different signs.
  3. The current power is greater than 90% of the value in the IDN "P-0-0092 Configured channel peak current".

When these three conditions apply it is very likely that there is a commutation error and that the motor is undergoing uncontrolled acceleration; the AX5000 generates a commutation error and switches the motor torque-free i.e. it stops without control.

WARNING 		Warning, risk of injury from uncontrolled movements!
A certain distance will have been travelled from the point when the error is detected until the motor stops. Make sure that your application permits this movement, secure the surroundings to prevent unintentional entry, and make sure that nobody is in the hazardous area. This applies in particular to vertical axes.

Notice 		Occurrence of commutation error
A commutation error almost always occurs when the axis is commissioned. If this error occurs during regular operation of the axis then special measures need to be adopted. See next chapter.

Commutation error during regular operation (very rare)

Under special operating conditions the regular operation of the axes can fulfil the three conditions cited above and therefore trigger this error message despite correct commutation. A number of examples are given below which, however, occur very seldom:

  1. When the servo drive is operating at the limit (conditions 1 and 3 are met) and external forces cause an opposing torque which then fulfils condition 2, the servo drive generates a commutation error.
  2. The servo drive is operating at the limit (conditions 1 and 3 are met) and an oscillating current is produced due to a rapid change of direction or speed. Condition 2 is then also met and a commutation error arises.

If these examples do not apply to your application, analyse the application and try to find the cause. If you are unable to remedy the cause but still wish to operate the axis, there is only one option for suppressing the commutation error:

Parameterise the value of the IDN P-0-0069 to the permitted maximum speed of the motor so that point 1 of the above-mentioned factors cannot apply and the commutation error will no longer appear.

WARNING 		Warning, risk of injury from uncontrolled movements!
Increasing the value of the IDN "P-0-0069" to the highest speed always means that the commutation monitoring will no longer cause errors, even when other conditions actually call for this. This is particularly critical when the motor is being replaced. If the value of the IDN "P-0-0069" is NOT reset, then uncontrolled movements of the motor may occur.

Beckhoff recommends that you should NOT increase the value of the IDN "P-0-0069".

Notice 		Drive design
As a rule the drive should not be designed at the limit i.e. the current power should reach a max. of 90% of the P-0-0092 "Configured channel peak current" value.


AX5000 - General commissioning of a motor with OCT feedback

BECKHOFF AX5000: Commissioning of a motor with OCT feedback

General commissioning of a motor with OCT feedback

You require only the motor connecting cable ZK4500-8xxx for the operation of these motors. Both the power and the feedback signals are transmitted via this cable. As standard these motors are always equipped with an electronic name plate and the parameters are read automatically in the usual way by scanning the name plate and are then processed further in the servo drive. If the electronic name plate should be unreadable, the parameters can also be read from the motor and feedback database.

Precondition for operation

The preconditions for the operation of the OCT motors are a suitable AX5000 from hardware version 2 and firmware from version 2.04.

You can see from the name plate whether the AX5000 is equipped with hardware version 2. (See ‘Diagnosis of the operation of a motor with OCT feedback’)

The value of ‘Feature flag 0’ is taken from the IDN ‘P-0-0322’ (see ‘Diagnosis of the operation of a motor with OCT feedback’)

The firmware version is taken from the ‘Watch Window’. (See ‘Diagnosis of the operation of a motor with OCT feedback’)

Typical commissioning of motors with valid name plate

In this example the AX5203 is connected to a CX1020 with the ID: ‘CX_0D4152’. An AM8031-0D10 with the OCT feedback system EKS36-0KF0A018A is connected to channel A of the AX5203. Open the TwinCAT System Manager.

Check whether TwinCAT is in ‘Config Mode’ (1). If this is not the case, tap the button (2) to enter Config Mode. Subsequently, tap the ‘Select target system...’ button (3).

The ‘Select target system’ selection window appears.

All EtherCAT devices that you can currently reach are shown here. Select the CX_0D4152 to which the servo drive is connected and confirm with ‘OK’.

After selecting the target system you must select the relevant EtherCAT devices. To do this, mark the ‘I/O devices’ entry (4), then click on the button (5) (Find devices) and confirm the message (6) with ‘OK’.

After the scan the devices found are listed. Select ‘EtherCAT’ and confirm with ‘OK’.

Answer the question ‘Search for new boxes?’ with ‘OK’.

An AX5000 was found and the question asked whether a scan for motors should be performed. Answer the question with ‘Yes’.

Answer the question regarding the ‘NC axes’ with ‘Yes’

Answer the question regarding the 'Free Run' with 'No'.

Click on the AX5000 (7) and start the TCDriveManager (8). Select ‘Channel A’ (9) and click on ‘Motor and Feedback’ (10). A graphic containing the corresponding information about the feedback and motor type (11) now appears on the right-hand side.

Typical commissioning of motors without a valid name plate

The procedure corresponds to that described above; only the final screenshot looks different and additional actions are necessary.

There is no entry next to feedback and motor types (11) because no electronic name plate could be read.

Click on the motor sketch (12); the motor selection menu appears. Select the connected motor in accordance with the motor name plate. To do this, open the menu options (14) - (21) and finally confirm with ‘OK’.

Now you must select the mains voltage and confirm with ‘OK’.

Finally you can also modify the NC configuration.

The feedback system (15) and the feedback connection (16) are also automatically entered by selecting the motor (14).


AX5000 - Diagnosis of the operation of a motor with OCT feedback

BECKHOFF AX5000: Commissioning of a motor with OCT feedback

Diagnosis of the operation of a motor with OCT feedback

The diagnosis of the operation of a motor with OCT feedback is supported by various IDNs and special error messages.

Precondition for operation

The preconditions for the operation of the OCT motors are a suitable AX5000 and firmware from version 2.04.

AX5000 with hardware version 2

The AX5000s with hardware version 2 are marked with ‘0200’ (1) in the catalogue number. The catalogue number can be found on the name plates.

AX5000 with hardware version 2 and set ‘Featureflag 0’

The feature flags (3) are documented in the IDN ‘P-0-0322’ (2). The ‘Feature Flag 0’ must have the value 1

AX5000 with hardware version 2 and firmware version 2.04 or higher.

The current firmware version of the AX5000 is displayed under (4) in the ‘Watch Window’.

New IDNs for the one-cable feedback

P-0-0169, Feedback Status

General

Short description | This IDN serves the diagnosis of the OCT feedback by means of displaying status information
Valid from interface revision | 201

Attributes

Data length: | 992
Format: | udec
Cyclic transmission: | No
Changeable: | No
Decimal point: | 0
Device parameter: | No
Parameter structure:
Name |  | Type | Length in bits | Offset | Features
 | Actual length | unsigned decimal | 16 | 0 |
 | Max length | unsigned decimal | 16 | 16 |
 | Data |  | 960 | 32 |
 | Onboard |  | 480 | 0 |
 | Hiperface DSL |  | 480 | 0 |
 | Delay Register |  | 16 | 0 |
 | Line delay | unsigned decimal | 4 | 0 |
 | RSSI: Received Signal Strength Indication | unsigned decimal | 4 | 4 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Quality Monitor Register |  | 16 | 16 |
 | Quality monitor bits | unsigned decimal | 4 | 0 |
 | rsvd | unsigned decimal | 3 | 4 |
 | Link | unsigned decimal | 1 | 7 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Slave RSSI |  | 16 | 32 |
 | Slave RSSI Value | unsigned decimal | 3 | 0 |
 | rsvd | unsigned decimal | 13 | 3 |
 | Edge Register |  | 16 | 48 |
 | Bit Sampling Pattern | unsigned decimal | 8 | 0 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Summary Register | unsigned decimal | 16 | 64 |
 | Encoder Temperature | signed decimal | 16 | 80 | UnitName: °C
 | LED current | unsigned decimal | 16 | 96 | UnitName: mA
 | Supply Voltage | unsigned decimal | 16 | 112 | UnitName: V
 | EncST01 |  | 16 | 128 |
 | ProtocolResetIndication | unsigned decimal | 1 | 0 |
 | AccelerationOverflow | unsigned decimal | 1 | 1 |
 | TestInProgress | unsigned decimal | 1 | 2 |
 | rsvd | unsigned decimal | 1 | 3 |
 | PosErrorTrackingFilterError | unsigned decimal | 1 | 4 |
 | PosErrorVectorLengthError | unsigned decimal | 1 | 5 |
 | PosErrorCounterError | unsigned decimal | 1 | 6 |
 | PosErrorSyncError | unsigned decimal | 1 | 7 |
 | SingleTurnError | unsigned decimal | 1 | 8 |
 | MultiTurnError1 | unsigned decimal | 1 | 9 |
 | MultiTurnError2 | unsigned decimal | 1 | 10 |
 | MultiTurnError3 | unsigned decimal | 1 | 11 |
 | rsvd | unsigned decimal | 4 | 12 |
 | EncST23 |  | 16 | 144 |
 | PowerOnSelftest | unsigned decimal | 1 | 0 |
 | SafetyParameterWarning | unsigned decimal | 1 | 1 |
 | SafetyParameterError | unsigned decimal | 1 | 2 |
 | StandardParameterError | unsigned decimal | 1 | 3 |
 | InternalCommunicationError1 | unsigned decimal | 1 | 4 |
 | InternalCommunicationError2 | unsigned decimal | 1 | 5 |
 | InternalSystemError | unsigned decimal | 1 | 6 |
 | rsvd | unsigned decimal | 1 | 7 |
 | CriticalTemperature | unsigned decimal | 1 | 8 |
 | CriticalLEDcurrent | unsigned decimal | 1 | 9 |
 | CriticalSupplyVoltage | unsigned decimal | 1 | 10 |
 | CriticalSpeed | unsigned decimal | 1 | 11 |
 | CriticalAcceleration | unsigned decimal | 1 | 12 |
 | CounterOverflow | unsigned decimal | 1 | 13 |
 | InternalMonitoringError | unsigned decimal | 1 | 14 |
 | rsvd | unsigned decimal | 1 | 15 |
 | EncST45 |  | 16 | 160 |
 | InvalidResourceAccessArgument | unsigned decimal | 1 | 0 |
 | ResourceAccessDenied | unsigned decimal | 1 | 1 |
 | InternalResourceAccessError | unsigned decimal | 1 | 2 |
 | FileAccessError | unsigned decimal | 1 | 3 |
 | rsvd | unsigned decimal | 4 | 4 |
 | EncST5 | unsigned decimal | 8 | 8 |
 | EncST67 |  | 16 | 176 |
 | EncST6 | unsigned decimal | 8 | 0 |
 | EncST7 | unsigned decimal | 8 | 8 |
 | Operating time | unsigned decimal | 32 | 192 | UnitName: min
 | Total shaft turns | unsigned decimal | 32 | 224 |
 | Extrap Register | unsigned decimal | 16 | 256 |
 | rsvd | unsigned decimal | 16 | 272 |
 | rsvd | unsigned decimal | 16 | 288 |
 | rsvd | unsigned decimal | 16 | 304 |
 | Total VPOS errors | unsigned decimal | 16 | 320 |
 | Total VEL errors | unsigned decimal | 16 | 336 |
 | Total VRT errors | unsigned decimal | 16 | 352 |
 | Total POS errors | unsigned decimal | 16 | 368 |
 | Total LINK errors | unsigned decimal | 16 | 384 |
 | Total 8b10b errors | unsigned decimal | 16 | 400 |
 | Error limit state |  | 16 | 416 |
 | VPOS Error Limit reached | unsigned decimal | 1 | 0 |
 | VEL Error Limit reached | unsigned decimal | 1 | 1 |
 | VRT Error Limit reached | unsigned decimal | 1 | 2 |
 | POS Error Limit reached | unsigned decimal | 1 | 3 |
 | LINK Error Limit reached | unsigned decimal | 1 | 4 |
 | Extrap Error Limit reached | unsigned decimal | 1 | 5 |
 | rsvd | unsigned decimal | 10 | 6 |
 | rsvd | unsigned decimal | 16 | 432 |
 | Cyclic read counter | unsigned decimal | 16 | 448 |
 | Cyclic read error counter | unsigned decimal | 16 | 464 |
 | AX57xx |  | 480 | 480 |
 | Hiperface DSL |  | 480 | 0 |
 | Delay Register |  | 16 | 0 |
 | Line delay | unsigned decimal | 4 | 0 |
 | RSSI: Received Signal Strength Indication | unsigned decimal | 4 | 4 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Quality Monitor Register |  | 16 | 16 |
 | Quality monitor bits | unsigned decimal | 4 | 0 |
 | rsvd | unsigned decimal | 3 | 4 |
 | Link | unsigned decimal | 1 | 7 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Slave RSSI |  | 16 | 32 |
 | Slave RSSI Value | unsigned decimal | 3 | 0 |
 | rsvd | unsigned decimal | 13 | 3 |
 | Edge Register |  | 16 | 48 |
 | Bit Sampling Pattern | unsigned decimal | 8 | 0 |
 | rsvd | unsigned decimal | 8 | 8 |
 | Summary Register | unsigned decimal | 16 | 64 |
 | Encoder Temperature | signed decimal | 16 | 80 | UnitName: °C
 | LED current | unsigned decimal | 16 | 96 | UnitName: mA
 | Supply Voltage | unsigned decimal | 16 | 112 | UnitName: V
 | EncST01 |  | 16 | 128 |
 | ProtocolResetIndication | unsigned decimal | 1 | 0 |
 | AccelerationOverflow | unsigned decimal | 1 | 1 |
 | TestInProgress | unsigned decimal | 1 | 2 |
 | rsvd | unsigned decimal | 1 | 3 |
 | PosErrorTrackingFilterError | unsigned decimal | 1 | 4 |
 | PosErrorVectorLengthError | unsigned decimal | 1 | 5 |
 | PosErrorCounterError | unsigned decimal | 1 | 6 |
 | PosErrorSyncError | unsigned decimal | 1 | 7 |
 | SingleTurnError | unsigned decimal | 1 | 8 |
 | MultiTurnError1 | unsigned decimal | 1 | 9 |
 | MultiTurnError2 | unsigned decimal | 1 | 10 |
 | MultiTurnError3 | unsigned decimal | 1 | 11 |
 | rsvd | unsigned decimal | 4 | 12 |
 | EncST23 |  | 16 | 144 |
 | PowerOnSelftest | unsigned decimal | 1 | 0 |
 | SafetyParameterWarning | unsigned decimal | 1 | 1 |
 | SafetyParameterError | unsigned decimal | 1 | 2 |
 | StandardParameterError | unsigned decimal | 1 | 3 |
 | InternalCommunicationError1 | unsigned decimal | 1 | 4 |
 | InternalCommunicationError2 | unsigned decimal | 1 | 5 |
 | InternalSystemError | unsigned decimal | 1 | 6 |
 | rsvd | unsigned decimal | 1 | 7 |
 | CriticalTemperature | unsigned decimal | 1 | 8 |
 | CriticalLEDcurrent | unsigned decimal | 1 | 9 |
 | CriticalSupplyVoltage | unsigned decimal | 1 | 10 |
 | CriticalSpeed | unsigned decimal | 1 | 11 |
 | CriticalAcceleration | unsigned decimal | 1 | 12 |
 | CounterOverflow | unsigned decimal | 1 | 13 |
 | InternalMonitoringError | unsigned decimal | 1 | 14 |
 | rsvd | unsigned decimal | 1 | 15 |
 | EncST45 |  | 16 | 160 |
 | InvalidResourceAccessArgument | unsigned decimal | 1 | 0 |
 | ResourceAccessDenied | unsigned decimal | 1 | 1 |
 | InternalResourceAccessError | unsigned decimal | 1 | 2 |
 | FileAccessError | unsigned decimal | 1 | 3 |
 | rsvd | unsigned decimal | 4 | 4 |
 | EncST5 | unsigned decimal | 8 | 8 |
 | EncST67 |  | 16 | 176 |
 | EncST6 | unsigned decimal | 8 | 0 |
 | EncST7 | unsigned decimal | 8 | 8 |
 | Operating time | unsigned decimal | 32 | 192 | UnitName: min
 | Total shaft turns | unsigned decimal | 32 | 224 |
 | ACC error counter | unsigned decimal | 16 | 256 |
 | rsvd | unsigned decimal | 16 | 272 |
 | rsvd | unsigned decimal | 16 | 288 |
 | rsvd | unsigned decimal | 16 | 304 |
 | Total VPOS errors | unsigned decimal | 16 | 320 |
 | Total VEL errors | unsigned decimal | 16 | 336 |
 | Total VRT errors | unsigned decimal | 16 | 352 |
 | Total POS errors | unsigned decimal | 16 | 368 |
 | Total LINK errors | unsigned decimal | 16 | 384 |
 | Total 8b10b errors | unsigned decimal | 16 | 400 |
 | Error limit state |  | 16 | 416 |
 | VPOS Error Limit reached | unsigned decimal | 1 | 0 |
 | VEL Error Limit reached | unsigned decimal | 1 | 1 |
 | VRT Error Limit reached | unsigned decimal | 1 | 2 |
 | POS Error Limit reached | unsigned decimal | 1 | 3 |
 | LINK Error Limit reached | unsigned decimal | 1 | 4 |
 | Extrap Error Limit reached | unsigned decimal | 1 | 5 |
 | rsvd | unsigned decimal | 10 | 6 |
 | rsvd | unsigned decimal | 16 | 432 |
 | Cyclic read counter | unsigned decimal | 16 | 448 |
 | Cyclic read error counter | unsigned decimal | 16 | 464 |

Parameter description
Actual length | see section ‘Introduction to parameter description’
max. length | see section ‘Introduction to parameter description’
Data | see section ‘Introduction to parameter description’
Onboard | The following data are related to the feedback system that is connected to the front card.
Hyperface DSL | The following data are related to the Hyperface DSL feedback system, which is sold under the name OCT.
Delay Register | Delays
Line delay
Default: 1 		Line delays

The line delay time is measured and displayed here when establishing the DSL connection. A new value is only determined following a RESET of the feedback system.

Value | Cable-related delay time [ns] | Approximate cable length of the DSL connection [m]
0 | < 100 | < 10
1 | 100...200 | 10...20
2 | 201...300 | 21...30
3 | 301...400 | 31...40
4 | 401...500 | 41...50
5 | 501...600 | 51...60
6 | 601...700 | 61...70
7 | 701...800 | 71...80
8 | 801...900 | 81...90
9 | 901...1000 | 91...100

Note 		Impermissible line delays
A value higher than ‘9’ indicates an impermissible delay of more than one µs. Check the length and the quality of the connection cable.
RSSI Information about the received strength of the DSL signal (4-bit value)
Value range: 0...12. Higher values mean stronger signals
Quality monitor register | Quality monitoring of the data connection
Quality monitor Range of values 0 ... 15 .
Default: 15 = good connection
Link Connection status of the DSL protocol (1-bit value)
1 = protocol connection has been established between DSL Master and Slave.
0 = no connection exists
Slave-RSSI Information about the received strength of the DSL signal at the Slave
Range of values 0...7. Higher values mean stronger signals
Edge register | Monitoring of the connection quality in the edge register. The data bit sampling times employed are shown here.
Bit sampling pattern Bit sampling pattern (8-bit). The more bits are set, the worse the cable signals become (noise).
The bit sampling pattern does not change any further after the start-up phase. A new value is only determined following a RESET of the feedback system.
Summary register Summarised status information of the DSL Slave
Default: 0x00000
Encoder temperature Current temperature of the encoder (see also P-0-0151)
Permissible value range: -20...125 °C
LED current | Present current consumption of the encoder LED
Supply voltage Present encoder supply voltage
Permissible value range: 7...12 V
EncST01 | Encoder status - diagnostic messages
ProtocolResetIndication | The DSL Master has requested a protocol reset due to a bad connection.
AccelerationOverflow | Permissible encoder acceleration is exceeded.
TestInProgress | Encoder test running - the AX5000 has initiated a test due to a general hardware or mechanical error
PosErrorTrackingFilterError | Position error due to error in the tracking filter – position and speed of the encoder are no longer correct
PosErrorVectorLengthError | Position error due to error in the vector length – a general hardware or mechanical error has occurred
PosErrorCounterError | Position error due to counter error – a general hardware or mechanical error has occurred
PosErrorSyncError | Position error due to erroneous synchronisation – a general hardware or mechanical error has occurred
SingleTurnError | Error in the single turn – position and speed of the encoder are no longer correct
MultiTurnError1 | Error in the multi-turn (gearbox stage 1) – position and speed of the encoder are no longer correct
MultiTurnError2 | Error in the multi-turn (gearbox stage 2) – position and speed of the encoder are no longer correct
MultiTurnError3 | Error in the multi-turn (gearbox stage 3) – position and speed of the encoder are no longer correct
EncSt23 | Encoder status - diagnostic messages
PowerOnSelftest | Switch-on self-test – position and speed of the encoder are no longer correct (DSL safety encoders only)
SafetyParameterWarning | Warning of errors in the safety parameters – errors were found in the safety parameters and repaired
SafetyParameterError | Error in the safety parameters – position and speed of the encoder are no longer correct (DSL safety encoders only)
StandardParameterError | Error in the standard parameters – memory error or general hardware error
InternalCommunicationError1 | Internal communication error – memory error or general hardware error
InternalCommunicationError2 | Internal communication error – memory error or general hardware error
InternalSystemError | Internal system error – memory error or general hardware error
CriticalTemperature | Critical temperature – cool or heat the encoder
CriticalLEDcurrent | Critical LED current – LED of the encoder is defective or fatigued or there is internal mechanical damage
CriticalSupplyVoltage | Critical supply voltage
CriticalSpeed | Critical speed – speed limit was exceeded, check application
CriticalAcceleration | Critical acceleration – acceleration limit was exceeded, check application
CounterOverflow | Counter overflow – reset counter
InternalMonitoringError | Internal monitoring error – memory error or general hardware error
EncST45 | Encoder status - diagnostic messages
InvalidResourceAccessArgument | Invalid argument while accessing a resource – check programming of the application
ResourceAccessDenied | Access to resource denied – check programming of the application
InternalResourceAccessError | Error while accessing internal resources – memory error or general hardware error
FileAccessError | Error while accessing a file – check programming of the application
EncST05 | Free for future use
EncST67 | Free for future use
EncST06 | Free for future use
EncST07 | Free for future use
Operating time | Operating time - the total time of operation of the encoder is saved in non-volatile memory
Total shaft turns | Total number of turns of the encoder shaft – the sum of the turns is saved in non-volatile memory
ACC error counter | Number of position errors that have currently not yet been corrected; an error is tolerated, since in this case the deviation between the transmitted position and the actual position is limited and negligibly small
Total VPOS errors | Number of transmission errors in the absolute position of the feedback system; irrelevant for the operation, serves only the evaluation of the transmission quality
Total VEL errors | Number of transmission errors in the relative position of the feedback system
Total VRT errors | Number of CRC errors in the absolute position; irrelevant for the operation, serves only the evaluation of the transmission quality
Total POS errors | Number of errors in the relative position of the feedback system
Total LINK errors | Number of connection interruptions or other serious errors during transmission
Total 8b10b errors | Number of errors in the coding of the data; serves as an indicator for the quality of the transmission
Error limit state | Status of the max. number of errors
VPOS Error Limit reached | Max. number of errors / time period was reached
VEL Error Limit reached | Max. number of errors / time period was reached
VRT Error Limit reached | Max. number of errors / time period was reached
POS Error Limit reached | Max. number of errors / time period for was reached
LINK Error Limit reached | Max. number of errors / time period was reached
ACC Limit reached | Max. number of errors / time period was reached
Cyclic read counter | Error while reading the parameter channel. Number is incremented by 1 if the DSL Master is reached
Cyclic read error counter | Error while reading the parameter channel. Number is decremented by 1 if the DSL Master is not reached
IDNs involved P-0-0151
Description A detailed diagnosis of the OCT feedback connection is possible with this IDN. The feedback can be connected to the AX5000 both directly and via the AX57xx feedback card. This IDN should always be evaluated first in case of malfunctions of the OCT feedback.
Supplementary functional description AX5000_UserManual-->Electrical Installation-->Feedback-->OCT

P-0-0151, scanned-in Feedback 1

General

Short description | This IDN contains information about the scanned-in Feedback 1 (presently only the OCT feedback (EKS36) is described)
Valid from interface revision | 201

Attributes

Data length: | 2048
Format: | udec
Cyclic transmission: | No
Changeable: | No
Decimal point: | 0
Device parameter: | No
Parameter structure:
Name | Type | Size in bits | Offset | Features
Actual length | unsigned decimal | 16 | 0
Max length | unsigned decimal | 16 | 16
Data | 2016 | 32
Manufacturer settings | Enum | 16 | 0

Value | Text
0 | Unknown manufacturer
1 | Hengstler
2 | Heidenhain
3 | Sick
4 | Siko
5 | Kuebler
6 | Lika
7 | Harowe
8 | LTN
9 | NumerikJena
10 | Hiwin
11 | Tecnotion
12 | Beckhoff
13 | Renishaw
14 | Baumer
15 | HighResolution
16 | AMO
Feedback type | Enum | 16 | 16

Value | Text
0 | Rotational feedback
1 | Linear feedback
Feedback type string | text | 240 | 32
rsvd | Array of UINT | 80 | 272

Size in bit | LBound | Elements
80 | 0 | 5
Process channel | 192 | 352
Process interface | Enum | 16 | 0

Value | Text
0 | No interface
1 | Sin / Cos with 1 V peak to peak
2 | Incremental 5V TTL
3 | Resolver
4 | MES
5 | Digital Interface
6 | Incremental HTL
Connector | Enum | 16 | 16

Value | Text
0 | No connector
1 | X11 or X21 (Front, Encoder)
2 | X12 or X22 (Front, Resolver)
3 | X11 (Front, Encoder, Channel A)
4 | X12 (Front, Resolver, Channel A)
5 | X21 (Front, Encoder, Channel B)
6 | X22 (Front, Resolver, Channel B)
14 | X14 (One cable feedback, Channel A)
24 | X24 (One cable feedback, Channel B)
1424 | X14 or X24 (One cable feedback)
41 | X41 (Option Slot, Encoder, Channel A)
42 | X42 (Option Slot, Encoder, Channel B)
4142 | X41 or X42 (Option Slot, Encoder)
rsvd | Array of UINT | 32 | 32

Size in bit | LBound | Elements
32 | 0 | 2
Data | 128 | 64
Sin / Cos | 128 | 0
Resolution per rotation | unsigned decimal | 32 | 0
Length per signal period | unsigned decimal | 32 | 32
rsvd | Array of UINT | 64 | 64

Size in bit | LBound | Elements
64 | 0 | 4
Resolver | 128 | 0
Number of pole pairs | unsigned decimal | 16 | 0
Exciting frequency | unsigned decimal | 16 | 16
rsvd | Array of UINT | 96 | 32

Size in bit | LBound | Elements
96 | 0 | 6
Parameter channel | 1248 | 544
Parameter interface | Enum | 16 | 0

Value | Text
0 | No commutation interface
1 | BiSS
2 | EnDat 2.1
3 | EnDat 2.2
4 | HIPERFACE
5 | BiSS C-Mode
6 | BiSS C-Mode unidirectinal
7 | HIPERFACE DSL
10 | SSI binär
11 | SSI gray
100 | Electrical analog commutation channel: sin(x) and sin(x-120)
102 | Mechanical analog commutation channel: cos and sin
103 | Electrical analog commutation channel: cos and sin
Connector | Enum | 16 | 16

Value | Text
0 | No connector
1 | X11 or X21 (Front, Encoder)
2 | X12 or X22 (Front, Resolver)
3 | X11 (Front, Encoder, Channel A)
4 | X12 (Front, Resolver, Channel A)
5 | X21 (Front, Encoder, Channel B)
6 | X22 (Front, Resolver, Channel B)
14 | X14 (One cable feedback, Channel A)
24 | X24 (One cable feedback, Channel B)
1424 | X14 or X24 (One cable feedback)
41 | X41 (Option Slot, Encoder, Channel A)
42 | X42 (Option Slot, Encoder, Channel B)
4142 | X41 or X42 (Option Slot, Encoder)
Identifier | unsigned decimal | 32 | 32
Bit resolution single pos | unsigned decimal | 16 | 64
Bit resolution multi pos | unsigned decimal | 16 | 80
Number of clockcycles to get singleturn position | unsigned decimal | 16 | 96
Number of clockcycles to get multiturn position | unsigned decimal | 16 | 112
Digital name plate | Enum | 16 | 128

Value | Text
0 | No digital name plate
1 | Digital name plate: Beckhoff
2 | Electronic data sheet: Beckhoff
256 | Lika SMA1: Only Positionoffset register
257 | Lika SMA1: Only Position register
258 | Lika SMA1: Default register values
Commutation mode | Enum | 4 | 144

Value | Text
0 | No commutation position
1 | Feedback commutation offset
2 | Commutation offset 0 deg
3 | Adjustable offset (P-0-0150)

Adjustable commutation offset unsigned decimal 12 148 UnitName:
deg
Linear resolution about digital interface in nm | unsigned decimal | 32 | 160
Serial number | unsigned decimal | 64 | 192
Data | 992 | 256
BiSS | 208 | 0
BiSS identification | Array of UINT | 64 | 0

Size in bit | LBound | Elements
64 | 0 | 4
Feedback identification | Array of UINT | 144 | 64

Size in bit | LBound | Elements
144 | 0 | 9
EnDat | 992 | 0
Additional Internal Id ASCII | unsigned decimal | 16 | 0
Manufacturer parameter | Array of UINT | 768 | 16

Size in bit | LBound | Elements
768 | 0 | 48
Operation parameter | Array of UINT | 96 | 784

Size in bit | LBound | Elements
96 | 0 | 6
rsvd | Array of UINT | 112 | 880

Size in bit | LBound | Elements
112 | 0 | 7
Hiperface | 656 | 0
Manufacturer parameter | 64 | 0
RS485Settings | unsigned decimal | 16 | 0
EncoderType | unsigned decimal | 16 | 16
Size of E2Prom in [16bytes] | unsigned decimal | 16 | 32
Options | unsigned decimal | 16 | 48
Serial number | Array of UINT | 144 | 64

Size in bit | LBound | Elements
144 | 0 | 9
Firmware version | Array of UINT | 320 | 208

Size in bit | LBound | Elements
320 | 0 | 20
Firmware date | Array of UINT | 128 | 528

Size in bit | LBound | Elements
128 | 0 | 8
Hiperface DSL | 992 | 0

QualityMonitor unsigned decimal 16 0

Delay Register unsigned decimal 16 16
Ip Core Version | 16 | 32
Release No | unsigned decimal | 6 | 0
Encoding | Enum | 2 | 6

Value | Text
1 | DSL Master IP core

rsvd unsigned decimal 8 8
Encoder Id | Array of UINT_hex | 48 | 48

Size in bit | LBound | Elements
48 | 0 | 3

Encoder Type unsigned decimal 16 96

Slave Interface Version unsigned decimal 16 112

Resolution unsigned decimal 32 128

Range unsigned decimal 32 160
Type Code Name | 144 | 192
string | text | 144 | 0
hex | Array of UINT_hex | 144 | 0

Size in bit | LBound | Elements
144 | 0 | 9
Serial No | 80 | 336
string | text | 80 | 0
hex | Array of UINT_hex | 80 | 0

Size in bit | LBound | Elements
80 | 0 | 5
Firmware RevNo | 160 | 416
string | text | 160 | 0
hex | Array of UINT_hex | 160 | 0

Size in bit | LBound | Elements
160 | 0 | 10
Firmware Date | 64 | 576
string | text | 64 | 0
hex | Array of UINT_hex | 64 | 0

Size in bit | LBound | Elements
64 | 0 | 4
Eeprom Size | unsigned decimal | 16 | 640

Minimum encoder temperature signed decimal 16 656 UnitName:
°C

Maximum encoder temperature signed decimal 16 672 UnitName:
°C

Maximum encoder speed unsigned decimal 16 688 UnitName:
rpm

Position offset unsigned decimal 64 704 UnitName:
inc
rsvd | Array of UINT_hex | 112 | 768

Size in bit | LBound | Elements
256 | 0 | 16
Sync Mode | unsigned decimal | 16 | 880
VPOS error limit | unsigned decimal | 16 | 896
VEL error limit | unsigned decimal | 16 | 912
VRT error limit | unsigned decimal | 16 | 928
POS error limit | unsigned decimal | 16 | 944
LINK error limit | unsigned decimal | 16 | 960
Extrap error limit | unsigned decimal | 16 | 976
Manufacturer limits settings | 96 | 1792

Maximum continuous operation speed unsigned decimal 16 0 UnitName:
rps or mm/s

Maximum continuous mechanical speed unsigned decimal 16 16 UnitName:
rps or mm/s

Maximum temperature unsigned decimal 16 32 UnitName:
°C
rsvd | Array of UINT | 48 | 48

Size in bit | LBound | Elements
48 | 0 | 3
rsvd | Array of UINT | 128 | 1888
Size in bit | LBound | Elements
128 | 0 | 8

Parameter description
Actual length | see section ‘Introduction to parameter description’
max. length | see section ‘Introduction to parameter description’
Data | see section ‘Introduction to parameter description’
Manufacturer settings | Manufacturer of the feedback system 3 = Sick
Feedback type | Type of feedback system 0 = rotary feedback
Feedback type string | Name of the feedback e.g.: EKS36-0KF0A018A = OCT Single Turn
Process channel | The following data concern the process data channel of the feedback system
Process interface | Information about the process interface 5 = digital interface
Connector | Connector on the AX5000 14 = X14 (OCT on channel A)
Parameter channel | The following data concern the parameter data channel of the feedback system
Parameter interface | Information about the process interface 7 = HIPERFACE DSL
Connector | Connector on the AX5000 14 = X14 (OCT on channel A)
Bit resolution single pos | Resolution of the single-turn range 18 bit
Digital name plate | Type of the digital name plate 2 = Beckhoff electronic data sheet
Commutation mode | Commutation method 0 = no commutation position
Data | The following data concern the process data channel of the feedback system
Hyperface DSL | Special data from the Hiperface DSL feedback system
QualityMonitor | Quality of the DSL connection (see IDN P-0-0169) Default: 15 = good connection
Delay register | Line delays (see IDN P-0-0169)
Ip Core Version | Information about the IP Core
Release No | Version number of the IP Core
Encoding | Version of the IP core 1 = DSL Master IP core
Encoder Id | Encoder identification (0) = 0x0000 (1) = 0x0000 (2) = 0x00D3
Encoder Type | Encoder type 0x0002
Slave Interface Version | Slave interface version 0x0011
Resolution | Resolution 0x00040000
Range | Range 0x00000001
Type Code Name | Name of the feedback system
string | Name e.g.: EKS36-0KF0A018A
hex | Name in hexadecimal notation
Serial No | Serial number
string | Serial number e.g.: N80402393
hex | Serial number in hexadecimal notation
Firmware RevNo | Firmware version number
string | Version number e.g.: EKX-0_01.04 HW_A
hex | Version number in hexadecimal notation
Firmware Date | Date of the firmware
string | Date
hex | Date in hexadecimal notation
Eeprom Size | Size of the Eeprom
Minimum encoder temperature | Lowest temperature of the encoder -20 °C
Maximum encoder temperature | Highest temperature of the encoder 125 °C
Maximum encoder speed | Highest speed of the encoder 12,000 rpm
Position offset | Service data – position offset The value is set ex works and corresponds to the serial number of the encoder
Sync Mode | Service data – synchronisation mode The data are variable
VPOS error limit | Max. number of errors / time period for ‘safe position invalid’ 50 (default value – do not change)
VEL error limit | Max. number of errors / time period for ‘max. speed exceeded’ 25 (default value – do not change)
VRT error limit | Max. number of errors / time period for ‘absolute position invalid’ 255 (default value – do not change)
POS error limit | Max. number of errors / time period for ‘fast position invalid’ 165 (default value – do not change)
LINK error limit | Max. number of errors / time period for ‘connection error due to a communication error’ 255 (default value – do not change)
ACC error limit | Max. number of errors / time period for ‘fast position’ 1 (default value – do not change)
Manufacturer limits settings | Thresholds
Maximum continuous operation speed | Max. speed of the encoder 200 rps
Maximum continuous mechanical speed | Max. speed of the encoder 200 rps
Maximum temperature | Highest temperature of the encoder 125 °C
IDNs involved P-0-0169
Description This IDN contains information about the scanned-in Feedback 1 (presently only the OCT feedback (EKS36) is described). After the successful scanning of the feedback, the data read from the feedback are saved in this IDN. Only the parameters relevant for the feedback employed are filled with data.
Supplementary functional description AX5000_UserManual-->Electrical Installation-->Feedback-->OCT

New diagnostic messages for the one-cable feedback

F850:

One-cable feedback: connection interrupted
The connection between the feedback system and the AX5000 is interrupted

F851:

One-cable feedback: initialisation failed
The general initialisation of the one-cable feedback failed.

F852:

One-cable feedback: position error, error limit reached
Position error: internal error limits were exceeded

F853:

One-cable feedback: Position error: timeout
Position error: a timeout occurred during the position evaluation.

F854:

One-cable feedback: out of memory
The necessary memory space could not be allocated.

F855:

One-cable feedback: parameterisation error

F856:

One-cable feedback: IP Core configuration failed

F857:

One-cable feedback: reading of the cyclic parameter data failed

F858:

One-cable feedback: internal error

F859:

One-cable feedback: IP Core read/write failed

F85A:

One-cable feedback: access to the encoder parameters failed – timeout

F85B:

One-cable feedback: access to the encoder parameters failed

F85C:

One-cable feedback: internal data communication error

F85D:

One-cable feedback: the encoder firmware is not supported.

F85E:

One-cable feedback: erroneous reply to a long message.

F85F:

One-cable feedback: encoder shutdown failed


AX5000 - Asynchronous motors - Special functions

BECKHOFF AX5000: Commissioning

Asynchronous motors - Special functions

The AX5000 features a wide range of integrated complex functions for operating an asynchronous motor, which in most other frequency converters cannot be implemented due to lower computing performance and lack of sensors. The following functions are provided:

Breakdown protection controller
Acceleration controller

Note 		General information on asynchronous motors
General information on asynchronous motors and their parameterisation can be found in section "Installation-->Electrical Installation-->Motor-->Asynchronous Motor".

Typical torque / speed curve of an asynchronous motor

The following diagram describes the characteristic curve at a rotary field frequency.

Open-loop operation without feedback-system

P / I breakdown protection controller (BPC)

The maximum torque of an asynchronous motor is also the breakdown torque or the pull-out point. If the torque exceeds this value, the motor enters an uncontrolled state in which no effective torque is available at the motor shaft, despite high reactive current input. During operation with a breakdown protection controller the system will always try to avoid the non-permissible range, even if it means a set value specification may not be adhered to. In this case the controller must take appropriate measures for reinstating the permitted operating mode.

Example 1: Optimum configuration of application and motor

A similar curve to the torque / speed curve described above emerges for a rotary field frequency if the current is plotted over the speed. This applies mainly for the linear range between rated current and cut-off current. The range beyond the pull-out current is not relevant, since it is not permitted. The AX5000 takes the values for P-0-0093 (rated current) and P-0-0092 (peak current) from the motor database, with P-0-0092 being calculated from P-0-0093 and the overload factor (for asynchronous motors usually 1.5). The default value for activating the breakdown protection controller is 100% of the peak current. If the application and the motor are configured according to the curve below, the breakdown protection controller is not activated in "normal" operating states. If the application requires more current (torque), e.g. because the milling tool is becoming blunt, the current value moves to the left of the curve. According to the parameterisation of P-0-0115 (current limit value) the breakdown protection controller is activated and prevents the rising current reaching the cut-off current and the controller switching the motor torque-free, so that it does not stop in an uncontrolled manner. In other words, the breakdown protection controller reduces the rotary field frequency and ensures that the current value does not significantly exceed the current limit value assigned in P-0-0115. Depending on the boundary conditions this may lead to controlled shutdown of the application.

Example 2: Operation in the field weakening

During operation of an asynchronous motor the torque curves may differ, depending on the rotary field frequency (f). Until the field weakening is reached the breakdown torques (Mk1 - Mk3) are same. When field weakening sets in the breakdown torques (Mk4 and Mk5) decrease almost linearly. If the field weakening increases further (Mk6 and others) the breakdown torque is very low and almost constant. In the field weakening the “envelope of the breakdown torques” follows the function M=1/n. Hence, it follows that within the almost linear range (Mk4 and Mk5) a slight reduction in the rotary field frequency causes a significant enlargement of the torque.

Example: spindle

The main application areas of spindles are machine tools for turning, milling or grinding. In many cases they are designed as asynchronous motors without gear unit, i.e. as direct drives. Other features of spindles include an integrated tool interface and high speeds (up to 60,000 rpm). The following scope logs describe the most common motor spindle type, the asynchronous motor.

The following diagrams / calculations refer to a milling spindle with the following technical data:

Un | 380 V | Rated voltage
In | 24 A | Rated current
Nn | 11,730 rpm | Rated speed
Nmax | 24,000 rpm | Maximum speed
Ip / In | 1,5 | Overload factor
F | 400 Hz | Input frequency
P | 2 | Number of pole pairs
Cosy | 0,8 | Power factor

Scope log - breakdown protection controller not activated

In region (8) the apparent current exceeds the thermal current limit value, with the result that the AX5000 switches the spindle torque-free with an overcurrent error so that it stops uncontrolled.

Legend:

No. | Description | No. | Description
1 | Enabling the AX5000 (premagnetisation) | 5 | Final speed reached
2 | Start of the acceleration phase | 6 | Constant speed range without load (with friction)
3 | Acceleration current has reached maximum value (The logged limitation only takes place if the acceleration controller is active) | 7 | Sudden load variation
4 | Field weakening entry point | 8 | Thermal current limit value is exceeded

Scope log - breakdown protection controller activated

The points described in the scope above are identical, apart from point (8). Although the thermal current limit value is now reached at point (8), in region (9) the breakdown protection controller prevents that the apparent current exceeds the permitted thermal current limit value, although the actual speed is unable to follow the set speed correctly (region 10). If this results in an invalid operating state, the controller has to take suitable measures reinstating a valid operating state.

Parameterisation of the breakdown protection controller in the TCDriveManager

Note 		Joint operation of the breakdown protection controller and the acceleration controller
To use the breakdown protection controller and the acceleration controller together, the two IDNs P-0-0115 and P-0-0112 should have different values.

Select the required drive (1) and open the TCDriveManager (2). The corresponding parameters for the breakdown protection controller can be found in region (3). The controller structure and the control characteristics match those of a P / I controller. The breakdown protection controller is enabled / disabled by touching field (4)(IDN P-0-0451 bit 6).

In field (7) IDN P-0-0115 enter the current limit value in %, from which the breakdown protection controller should become active. The percentage value refers to the maximum peak current specified in IDN P-0-0092. The default for IDN P-0-0115 is 100%. Should the AX5000 shut down unexpectedly, the first measure would be to reduce this, since in many cases the dynamics of the application has sufficient reserve for reaching the switch-off threshold of 125% anyway.

Field (6) IDN P-0-0117 influences the I component of the breakdown protection controller. Experience shows that may make sense to disable the I component.

Note 		I component of the breakdown protection controller
The I component of the breakdown protection controller can be deactivated by setting the time constant in field (6) to 0.0.

Field (5) IDN P-0-0116 influences the P component of the breakdown protection controller. Start with a small "Kp" and slowly increase the value as required


AX5000 Maintenance

BECKHOFF AX5000: Commissioning

Maintenance

Servicing

  • The devices are maintenance-free
  • Opening the devices invalidates the warranty

Cleaning

  • Soiled housing: Clean with isopropanol or similar
    Do not immerse or spray!
  • Contamination inside the device: Cleaning by the manufacturer
  • Soiled fan guard: Clean with (dry) brush


AX5000 - Modulo

BECKHOFF AX5000: Extended functions

Modulo (rotary)

In a rotary multi-turn-feedback system the axis position may be difficult to determine once the maximum speed has been reached (overflow) and the machine is switched off and restarted. This problem can be avoided via the controller, although the solution is rather complex and requires a UPS that enables important data to be saved after a power failure. The modulo function of the AX5000 replaces complex programming of the controller with a simple parameterisation in the AX5000.

Notice 		Position control reference in the AX5000
Without activation of the modulo function the AX5000 will always output the absolute position of the encoder, including the overflow issue.

When the modulo function is activated the AX5000 always outputs the position of the application, without the overflow issue. This application position is generally output for all position data. The AX5000 expects the set values from the controller also in modulo format.

When the modulo function is active the position offset cannot be activated online.

Notice 		Feedback gear unit
If a feedback gear unit is used, the modulo function will not always provide exact values.

Operation without modulo (application with 1:5 gear unit)

In the example described below a multi-turn absolute value feedback system is used, which after switching off and on, and up to 4096 revolutions, can automatically replicate its position before the switch-off. At 4096 revolutions the counter is reset to zero. In practice this means that up to 4096 revolutions the feedback system will always provide the right application position, but not beyond this number.

The first switch-off point is at 12.5 motor revolutions or 2 application revolutions + 180°. The feedback system will make the correct value available when the system is switched on again. The second switch-off point is at 4103 (4096+7) motor revolutions or 820 application revolutions + 216°. Due to the overflow at 4096 revolutions the feedback system did not take into account the revolution in region (a) and shows 7 motor revolutions, but only 1 application revolution + 144°, i.e. there is one motor revolution or 72° missing. This problems occurs every 4096 motor revolutions and keeps growing by one motor revolution. In the controller suitable measures must be taken for dealing with this problem.

Notice 		Selecting the gear unit!
If a gear unit with the gear ratio of 2X is used, the zero points of the motor revolutions and the overflow of the absolute encoder coincide, and the behaviour described above does not occur.

Operation with modulo

Parameterisation

The modulo function is activated in IDN S-0-0076 - bit 7 "Position data scaling type".

The maximum calculated value for an application period is entered in IDN S-0-0103 "Modulo Value". The unit is "inc" and 220 inc correspond to 1 motor revolution. For the conversion please take into account the gear ratio of any gear unit installed after the motor. Accordingly, the maximum modulo position is S-0-0103 - 1 inc.

In this example once again a multi-turn absolute value feedback system is used, which after switching off and on, and up to 4096 revolutions, can automatically replicate its position before the switch-off. In addition a gear unit with a gear reduction of 1:5 is used, i.e. 5 motor revolutions correspond to 1 application revolution. In this case the maximum modulo position is 5 x 220 - 1 inc.

Calculating the positions:

The modulo position "Pmod" is calculated by offsetting the "Poff" value with the absolute position "Pabs".

Pmod = Pabs - z x Poff

Poff corresponds to the maximum value of Pmod. Within an absolute value period the multiplier "z" is incremented by integer values. During each calculation cycle the system checks whether the offset has to be corrected.

Permanently storage of the positions

In order to be able to calculate the modulo position correctly after initialisation of the encoder system, it is necessary to store pairs of absolute feedback position and modulo position values. The following strategy is used: The absolute traversing range of the encoder system is subdivided into 4 equal sections. A value pair is stored when the current position switches to another section.

Example:

The last dataset was stored during the change from 1 --> 2. The next dataset will be stored during the change from 2 --> 3 or 1 --> 0. The system always keeps two full datasets in memory, in view of the risk that a dataset may not be saved properly in the event of a power failure. This strategy enables that modulo position can be reconstructed reliably after switch-off, even if the axis turns by ¼ of the absolute encoder range. If the axis turns by more than ¼, reliable reconstruction can no longer be guaranteed. An additional dataset is stored during the transition from SafeOp to PreOp.

Influenced IDNs

S-0-0047 "Pos command value"

The controller transfers the set position to the AX5000 as a modulo position, where it is converted to the range 0---232-1 inc. All calculations are now carried out, and another modulo position is output as actual position after a further conversion. All values between the two conversion are not influenced by the modulo.

S-0-0048 "Additive pos command value"

See S-0-0047

S-0-0189 "Following distance"

The position lag is not reduced to the modulo period.

S-0-0554 "Effective pos command value"

The IDN outputs the internally available set position value. No modulo calculation takes place for this parameter. (See also S-0-0047 and S-0-0048)

S-0-0091 "Bipolar velocity limit value"

See below (maximum possible speed)

Maximum possible speed

Activation of the modulo function may result in a relevant reduction of the maximum speed.

Maximum speed:

The above equation results in a limitation of the maximum value of IDN S-0-0091 "Bipolar velocity limit value"

Initialisation sequence


AX5000 - Internal filters

BECKHOFF AX5000: Extended functions

Control quality - internal filters

WARNING 		Warning, risk of injury from uncontrolled movements!
When working with the described filters there is always a danger of the motor performing uncontrolled movements due to impermissible parameterisation. Make sure that your application allows these movements and secure the entire danger zone against inadvertent entry; ensure that no persons are in the danger zone.

The control quality describes the capacity of the drive system to follow the setpoint values highly dynamically, with low losses and fail-safe. The control quality depends on many factors. On the mechanical side these could be soft drive trains with belt drive, or resonance points caused by the natural ageing of components or special features of the mechanical structure. Without the use of filters the only possibility is to reduce the loop gain and to adapt it to the worst condition. However, this adaptation affects the total application and lowers the dynamics of the drive system. The application and the parameterisation of the internal speed and current filters act, for example, specifically on a resonant frequency, hence allowing a high loop gain and thus a highly dynamic drive system. The filters described here serve to eliminate or attenuate unwanted noise or resonant frequencies. The main control loops of a servo drive are the position controller, the velocity controller and the current controller. With the exception of the position controller, software filters can be inserted before the controllers. The characteristic of these special software filters is realised by means of a 1st and 2nd order IIR filter with time-discrete transfer function.

Basic principles

The drive system receives the input parameter "Speed n = 40 rpm" from the PLC. If the drive system is operating under optimum conditions, the motor achieves this speed with very good control quality. The different characteristics of the drive system also cause sources of resonance among other things, which are always disturbing. They often manifest themselves in oscillating shafts or hum frequencies. Overlaid signal oscillations of the encoder systems can similarly create high frequency noise, thus reducing the control quality.

The following test provides information about possibly existing interference frequencies: Drive through the necessary operating speed range and make a scope recording of the actual active current (IDN S-0-0084). On the basis of the curve of the graph you can judge whether or not there are points of interference.

1st and 2nd order IIR filter – Infinite Impulse Response Filter

A general digital filter with time-discrete transfer function has been implemented for the current command value filter

The following filters can be selected in the TCDriveManager:

Notch filter
Phase correction filter 1st order (PD T1 or lead lag)
Low-pass filter 1st order (PT1)
Phase correction filter 2nd order (Bi Quad)
Low-pass filter 2nd order (PT2)

The coefficients b0, b1, b2, and a1, a2 determine the characteristic of all the filters described and can also be directly specified.

Notch filter (band-stop filter)

The notch filter is designed as a narrow-band filter for the attenuation of resonance frequencies. Select a servo drive (1) in the TwinCAT System Manager, start the TCDriveManager (2), click on the respective axis (3) and select the "Current command value filter" (4).

A maximum of four filters are evaluated, which can be parameterised independently of one another. In area (6), activate the filter that you would like to occupy with the notch filter. The cycle time of the velocity controller is indicated in field (7). The "QMath Factor" (8) determines the scaling of the filter input parameter. With the current filter implementation the maximum possible resolution is achieved with the default value "30".

Now select "Notch filter" (5) from the drop-down menu.

Parameterisation of the filter

WARNING 		Warning, risk of injury from uncontrolled movements!
Impermissible attenuation values lead to a strong phase shift, which can result in uncontrolled acceleration of the motor and other instable states.

There are two different methods of parameterising the filter.

"Classic" method

This variant is activated by checking the "Classic" checkbox (9).

The parameters "Depth" (10), "Bandwidth" (11) and "Frequency" (12) must now be determined and entered; see the diagram "Bode Plot" below for this. The parameters entered lead internally to the calculation of the coefficients b0, b1, b2, and a1, a2 (see the above diagram "1st and 2nd order IIR filter" for this).

Click on the "Download" button (13) to conclude the parameterisation. If you are online these parameters are loaded directly into the AX5000 and activated. If you are offline they are only written into the start-up list.

"Classic" method – step by step

Notice 		Expert hint!
The software calculates the coefficients independently using the parameters entered. If you have sufficient experience in control technology you can also determine the coefficients yourself and thus affect the behaviour of the filter.

The "Step by step" extension enables you to calculate and enter the coefficients b0, b1, b2, and a1, a2 yourself (see the above diagram "1st and 2nd order IIR filter"). Among other things you can now compare the values calculated by the software with your own values and see how changing the parameters affects the coefficients.

The "Step by step" extension is activated by checking the "Step by step" checkbox (14). You can now enter the parameters (10) to (12) as described in the previous section, after which you click on the button (15). Subsequently, you can read off the calculated coefficients in area (16). If you wish to accept these coefficients, click on the button (17); they are now entered automatically into area (18).

Alternatively you can also determine the coefficients yourself and enter them in area (18).

If you finally click on the "Download" button (19), the values are always taken from area (18). If you are online these parameters are loaded directly into the AX5000 and activated. If you are offline they are only written into the start-up list. The calculated values from area (16) and the parameters (10) to (12) remain visible for information purposes.

"Low-pass and high-pass filter" method

This variant is activated by unchecking the "Classic" checkbox (22).

You must now determine and enter the parameters "Low pass filter damping" (23), "Low pass filter frequency" (24), "High pass filter damping" (26) and "High pass filter frequency" (27); the "Filter time" (25) is calculated by the software in relation to the "Low pass filter frequency" (24). If you wish to emulate the classic method, you must enter the centre frequency plus half the bandwidth in field (24) and the centre frequency minus half the bandwidth in field (27). The depth (10) is determined with the damping (23) or (26); see the diagram "Bode Plot" below for this. The parameters entered lead internally to the calculation of the coefficients b0, b1, b2, and a1, a2 (see the above diagram "1st and 2nd order IIR filter" for this).

Using the methods described you can also map any unbalances of the notch filter, among other things.

Click on the "Download" button (28) to conclude the parameterisation. If you are online these parameters are loaded directly into the AX5000 and activated. If you are offline they are only written into the start-up list.

"Low-pass and high-pass filter" method – step by step

Notice 		Expert hint!
The software calculates the coefficients independently using the parameters entered. If you have sufficient experience in control technology you can also determine the coefficients yourself and thus affect the behaviour of the filter.

The method is the same as in the "Classic method" – step by step.

Bode Plot

1st order low pass filter

The 1st order low pass filter attenuates all frequencies above the specified limit frequency. Select a servo drive (1) in the TwinCAT System Manager, start the TCDriveManager (2), click on the respective axis (3) and select the "Current command value filter" (4).

A maximum of four filters are evaluated, which can be parameterised independently of one another. In area (6), activate the filter that you would like to occupy with the low pass filter. The cycle time of the velocity controller is indicated in field (7). The "QMath Factor" (8) determines the scaling of the filter input parameter. With the current filter implementation the maximum possible resolution is achieved with the default value "30".

Now select "Low pass filter 1. order" (29) from the drop down menu.

Parameterisation of the filter

WARNING 		Warning, risk of injury from uncontrolled movements!
Impermissible damping values lead to a strong phase shift, which can result in uncontrolled acceleration of the motor and other instable states.

This filter is parameterised with the parameter "Limit frequency" (30). The time constant (31) is calculated from the limit frequency according to the following equation
"Time constant [s] = 1 / (2*Pi*Limit frequency [Hz] )".

Determination of the limit frequency
The following test provides information about possibly existing interference frequencies: Drive through the necessary operating speed range and make a scope recording of the actual active current (IDN S-0-0084). A frequency analysis shows possibly existing resonance points.

Notice 		Phase shift
With this filter you have no influence on the damping and any resulting phase shift. If you are not sure whether a phase shift is permissible, please use the "Phase correction filter 1. order"

Click on the "Download" button (32) to conclude the parameterisation. If you are online these parameters are loaded directly into the AX5000 and activated. If you are offline they are only written into the start-up list.

Example:

With this example the frequency response of the PT1 filters has been illustrated for clarity. The Bode plot (logarithmic frequency curve) shows the amplitude over frequency in the upper area and the associated phase shift over frequency in the lower area. Seen together, it is recognisable that a phase shift results from the damping of the amplitude.

Parameter inputs in the TCDriveManager:

Limit frequency = 6280 Hz
(Time constant = 0.025343)

"1st order low pass filter" – method – "step by step"

Notice 		Expert hint!
The software calculates the coefficients independently using the parameters entered. If you have sufficient experience in control technology you can also determine the coefficients yourself and thus affect the behaviour of the filter.

The method is the same as in the "Notch filter classic method" – "step by step".

1st order phase correction filter

The 1st order phase correction filter attenuates all frequencies above the limit frequency entered. Select a servo drive (1) in the TwinCAT System Manager, start the TCDriveManager (2), click on the respective axis (3) and select the "Current command value filter" (4).

A maximum of four filters are evaluated, which can be parameterised independently of one another. In area (6), activate the filter that you would like to occupy with the phase correction filter. The cycle time of the velocity controller is indicated in field (7). The "QMath Factor" (8) determines the scaling of the filter input parameter. With the current filter implementation the maximum possible resolution is achieved with the default value "30".

Now select "Phase correction filter 1. order" (33) from the drop down menu.

Parameterisation of the filter

WARNING 		Warning, risk of injury from uncontrolled movements!
Impermissible damping values lead to a strong phase shift, which can result in uncontrolled acceleration of the motor and other instable states.

This filter is parameterised with the parameters "Limit frequency" (35) and "Damping" (34). The time constant (36) is calculated from the limit frequency according to the following equation --> "Time constant [s] = 1/ (2*Pi*Limit frequency [Hz])".

Determination of the limit frequency
The following test provides information about possibly existing interference frequencies: Drive through the necessary operating speed range and make a scope recording of the actual active current (IDN S-0-0084). A frequency analysis shows possibly existing resonance points.

Click on the "Download" button (37) to conclude the parameterisation. If you are online these parameters are loaded directly into the AX5000 and activated. If you are offline they are only written into the start-up list.

The limitation of the damping of the amplitude ensures that the phase shift returns to zero. The limited damping is adequate for most drive applications.

Example:

With this example the frequency response of the PT1 filters has been illustrated for clarity. The Bode plot (logarithmic frequency curve) shows the amplitude over frequency in the upper area and the associated phase shift over frequency in the lower area. Seen together, it is recognisable that a phase shift results from the damping of the amplitude.

Parameter inputs in the TCDriveManager:

Time constant = 0.000025 s
(Limit frequency = 6280 Hz)
Damping:
d0 = 0
d1 = 0.05
d3 = 0.15
d4 = 0.35

"Phase correction filter 1. order" – method – "step by step"

Notice 		Expert hint!
The software calculates the coefficients independently using the parameters entered. If you have sufficient experience in control technology you can also determine the coefficients yourself and thus affect the behaviour of the filter.

The method is the same as in the "Notch filter classic method" – "step by step".


AX5000 - parameter set switchover

BECKHOFF AX5000: Extended functions

Parameter set switchover

The parameters (IDNs) of AX5000 may contain values and commands. For the parameters containing the values a distinction is made between status parameters, which are automatically provided by the AX5000, and parameters, which are set by the NC program or similar. The status parameters are not relevant for the parameter set switchover. In an application the parameter set switchover must take place as quickly as possible. The AX5000 internal option was therefore selected, which enables significantly faster switching than the option which realises switching on the EtherCAT master.

Parameter sets

The Sercos specification allows all parameters to exist n times, so that parameter sets can be formed. The AX5000 may contain up to 8 different parameter sets. The parameter sets takes are identified via the IDN keys.

IDN keys

The IDN key indicates that the value at "y" ( 0-7) represents the association of this parameter with a certain parameter set. In the AX5000 the IDNs listed in IDN "S-0-0219" are available 8 times and have their specified standard values at initialisation.

IDNs involved

Parameter | Description
S-0-0216: Switch parameter set (pc) | This command is used to execute the parameter set switchover.
S-0-0217: Parameter set preselection | The parameter number for the switchover is entered in this IDN. If, for example, 2 is entered here and then the command S-0-0216 is executed, the parameter of parameter set S/P-2-xxxx are activated.
S-0-0219: IDN-list of parameter sets | This table contains all IDNs for which parameter sets 0 to 7 are available.
S-0-0254: Actual parameter set | This IDN indicates the currently active parameter set.
P-0-0360: Parameter set prearrangement | This IDN is used to specify how many parameter sets are prepared for switchover in the AX5000. The number of parameter sets is P-0-0360 + 1. If this IDN is parameterised to 3 it is possible to switch between parameter sets 0 to 3.
P-0-0361: Parameter set configuration | This list is intended for the IDNs to be switched, which should also be listed in S-0-0219. The parameters of the IDNs entered here are prepared for parameter set switchover and switched accordingly.

Formation of a parameter set

The generation of a parameter set takes place by means of the entry of the corresponding parameters in the IDN S-0-0219 ‘List of parameter sets’. Only the parameters entered here are available for the parameter set switchover. The other parameter retain the value stored in parameter set "0".

Selecting a parameter set

A parameter set is selected via IDN S-0-217 "Parameter set preselection". Numbers 0-7 are entered in this IDN as required.

Switching to a parameter set

Parameter sets are switched via IDN S-0-0216 "Switch parameter set (pc)". During the switchover the parameter listed in IDN S-0-0219 are switched to the parameter set with the number defined in IDN S-0-0217 (0-7).

Note 		Switchable parameters
An overview of all switchable parameters can be found in IDN "S-0-0219".


AX5000 - Shutting down

BECKHOFF AX5000: Shutting down

Shutting down

DANGER 		Serious risk of injury through electric shock!
Bring the AX5000 into a safe, de-energised state. Due to the DC link capacitors dangerous voltage may persist at the DC link contacts "X02" after the servo drive has been disconnected from the mains supply. After disconnecting the servo drive wait 5 minutes and measure the voltage at the DC link contacts DC+ and DC-. The device is safe once the voltage has fallen below 50 V.

Disposal

  • Screw connections enable the servo drives to be dismantled into main components (aluminium heat sink, steel cases, PCBs)
  • The device should be disposed of by a certified disposal company. You can obtain addresses from us. Housing components (polycarbonate, polyamide (PA6.6)) are suitable for plastic recycling.
  • Metal parts can be sent for metal recycling.
  • Electronic parts such as circuit boards and terminals must be disposed of in accordance with national electronics scrap regulations.


AX5000 - Safety-Card AX5801

BECKHOFF AX5000: Integrated Safety

Safety-Card AX5801

Appropriate use

The AX5801 Safety Card is designed exclusively for installation in the optional safety slot of a servo drive from the AX5000 series. The cards are installed together with the servo drive as components in electrical systems and machinery and may only be used in this way.

Scope of supply

The scope of supply includes the following components:

AX5801 Safety Card, 4-pin connector, 6-pin connector, technical documentation and packaging

If one of the components is damaged please notify the logistics company and Beckhoff Automation GmbH immediately.

Safety rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations and guidelines.

DANGER 		Caution - Danger of death!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for 5 minutes. Wait until the DC link capacitors are discharged before touching live terminals. The voltage measured between the DC+ and DC- terminals (X02) must have fallen below 50 V.

WARNING 		Caution - Risk of injury!
Elektronische Electronic equipment is not fail-safe. The machine manufacturer is responsible for ensuring that the connected motors and the machine are brought into a safe state in the event of a fault in the drive system.

Attention 		Caution - electrostatic charging may lead to destruction of the Safety Card!
The Safety Card is an ESD-sensitive component. Follow the usual ESD safety procedures when handling the card (anti-static wrist straps, earthing of the relevant components, etc.).

Personnel qualification

This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards. Knowledge of machine safety legislation is compulsory.

Product description!

The AX5801 Safety Card from Beckhoff is used to realise the safe stop functions "STO or SS1 according to IEC 61800-5-2". STO stands for SafeTorqueOff, SS1 for SafeStop1.

Through 2-channel monitoring integrated in the AX5000, stop category 0 or 1 according to IEC 60204-1 can be realised with minimum effort and additional TwinSAFE blocks from Beckhoff, resulting in category 4 according to ISO 13849-1:2006.

Two-channel monitoring is achieved through certified relays (Rel1 and Rel2). The relays are equipped with positively driven contacts including feedback contacts (K1 and K2). The feedback contacts are connected in series and potential-free with terminals (5) and (6) of the 6-pin connector.

The two coils (S1 and S2) have to be supplied with 24 V DC via terminals 1 and 2 or 3 and 4 of the 6-pin or 4-pin connector.
Terminals1-1, 2-2, 3-3 and 4-4 of the two connectors are bridged internally.

If a relay releases, the de-energising circuit of the AX5000 servo drive range ensures that the connected motors (both channels) become torque-free.

Technical data

Relay operating voltage (terminal1-4) | 24 VDC -15% +20% | Feedback contacts operating voltage (5-6) | 24 VDC-15% +20% | max. switching current of the feedback contacts (5-6) | 0,35 A
Conductor cross section of terminals 1-6 | 0,2 -1,5 mm2 | Conductor strip length of terminals 1-6 | 10mm | current consumption | 50 mA

We recommend using wire end sleeves!

Installation of the AX5801 Safety-Card

DANGER 		Caution - Acute risk of injury!
Before installing the Safety Card disconnect the servo drive from the mains and system voltage. Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for 5 minutes. Wait until the DC link capacitors are discharged before touching live terminals. The voltage measured between the DC+ and DC- terminals (X02) must have fallen below 50 V.

Mechanical installation

Installation of the two connectors on the AX5801 Safety-Card

- Insert the enclosed 4-pin connector (1) into the socket.

- Tighten the two bolts (2).

- Insert the 6-pin connector (3) into the socket.(4).

- Tighten the two bolts (5).

Installation of the AX5801 Safety-Card

- Fully release the bolt (6).

- Remove the insert (7) in the direction of the arrow (8).

- Carefully insert the Safety Card (9) into the opening in the direction of the arrow (10). The slot has guides for the card on the short sides.
Ensure that the card is inserted into these guides.

- Tighten the bolt (11).

Electrical Installation

Configure the safety operation of servo drive via IDN P-0-2000. During the next system start-up the servo drive automatically detects whether a Safety Card was inserted and whether the IDN P-0-2000 parameterisation is correct. Error message "0xFDD4" indicates incorrect configuration. If the servo drive with the Safety Card does not reach the safe state, error message "0xFDD5" appears on the display of servo drive. In this case please contact Beckhoff.

CAUTION 		Hazard to individuals and devices!
If an error message appears on the display of the AX5000 the servo drive must not be put into service if the servo drive in the system or machine represents a safety-relevant part of the control system.

Application example (emergency stop - stop category 1)

Components involved:

  • Emergency stop device (control switch S1) according to ISO 13850 and control switch S2
  • 1 safety input terminal (KL1904) and 1 input terminal (KL 1404)
  • 1 safety logic terminal (KL6904) with function block "ESTOP"
  • AX5801 Safety Card and servo drive from the AX5000 range
  • Programmable logic controller (PLC) and EtherCAT fieldbus

By activating the emergency stop device (S1) inputs EStopIn1 and EStopIn2 of FB "ESTOP" are switched to state "0", resulting in outputs EStopOut and EStopDelOut of FB "ESTOP" being switched to state "0". As a result, a quick stop command is issued to the PLC and therefore the AX5000 via EtherCAT. The output EStopDelOut of FB "ESTOP" ensures that after a specified delay time the 24 V supply of the AX5801 Safety Card is interrupted. This causes the relays (REL1 and REL2) to release and both channels (motors) to be made torque-free via the internal deactivation procedure of the AX5000.

In the event of a fault the controlled shutdown (quick stop) may fail. The Safety Card becomes active once the delay time has elapsed, and all motors connected to the device run out. The risk analysis for the machine must indicate that this behaviour can be tolerated. An interlock may be required.

The delay time must be set slightly longer than the maximum braking time of the quick stop.

Sticking relay contacts on the Safety Card are detected via input EDM1 of FB "ESTOP", and restarting is prevented.

When the emergency stop device is released again, the control switch (S2) must be operated (first rising then falling edge at the restart input of FB "ESTOP") in order to restart the AX5000.

Application example for a safety circuit with several AX5000


AX5000 - AX-Bridge quick connection system

BECKHOFF AX5000: Accessories

AX-Bridge quick connection system

The AX5000 quick connection system enables simple and fast connection of several AX5000 devices to form a multi-axis system. The pluggable supply and connection module combines power supply, DC link, and control and braking voltage (24 VDC).

Drive system with UL-Listing!
Please consult our Application Department with respect to the requirements for a drive system with UL-Listing.

CAUTION 		Danger for persons and equipment
Note the total rated current of the connected devices. According to CE the current carrying capacity of power busbars of the AX Bridge is limited to 85 A.

CAUTION 		Hazard to the equipment
  • The connection sequence of the devices is not arbitrary. The total rated current of the device must decrease from the power supply.
    AX5112-AX5203-AX5106-AX5201 = OK
    AX5201-AX5112-AX5203 ¹ OK
  • All devices in a drive system are always to be disconnected from and reconnected to the mains supply together (emergency stop, mains contactor etc.).

CAUTION 		Destruction of the external brake resistor!
An external brake resistor may not be connected to the X02 terminal point (DC link) in a drive system. Use an external brake module AX5021 for this.

Note 		Drive system with AX5140!
There is no possibility to connect several AX5140s with the AX bridge; they must be connected with individual cables. Use sufficiently dimensioned cables for this.

Supply module for multi-axis system

If several AX5000 units are to be linked to form a multi-axis system, a supply module for connecting the supply voltage and the control voltage (24 VDC) for the control electronics and the motor brakes is required.

Article no. | Description
AX5901 | Supply module (AX5000 with rated current between 1 A and 25 A)
AX5902 | Supply module (AX5000 with 40A rated current)

To install the supply module connectors X01, X02 and X03 must be removed and replaced with the supply module.

AX-Bridge connection module for multi-axis system

The connection between the two AX amplifiers is established by moving the three busbar sliders of the first connection module of the next drive to the left.

Article no. | Description
AX5911 | Connection module for housing size 1 (AX5000 with rated current between 1 A and 12 A)
AX5912 | Connection module for housing size 2 (AX5000 with rated current between 18 A and 25 A)

Connection

CAUTION 		Risk of injury through electric shock and destruction of the AX5000!
Move all busbar sliders to the left limit stop in order to ensure full current carrying capacity. Then tighten all screws with a torque of 2.2 Nm.

CAUTION 		Fire hazard through cable overload!
Please ensure that the final supply network connection cable is adequately dimensioned. The dimensioning depends on the total rated current and must comply with EN60204-1. A 3-phase connection must be used if the total rated current exceeds 9 A.

The supply connection is established as described in section Power supply.

Information of the terminal points

AX5901 (AX520x und AX5101 - AX5125)

Terminal points | Conductor | max. Conductor cross-section | Brake away torque
L1-L3, PE | single wire | 10 mm2, AWG 7 | 2,2 Nm
 | finely stranded with wire end sleeves | 16 mm2, AWG 5 | 2,2 Nm
 | finely stranded / stranded | 25 mm2, AWG 3 | 2,2 Nm

AX5902 (AX5140)

Terminal points | Conductor | max. Conductor cross-section | Brake away torque
L1-L3, PE | single wire | 16 mm2, AWG 7 | 3,2 ±0,8 Nm
 | finely stranded with wire end sleeves | 16 mm2, AWG 5 | 3,2 ±0,8 Nm
 | finely stranded / stranded | 25 mm2, AWG 3 | 3,2 ±0,8 Nm


AX5000 - Brake modul - AX5021

BECKHOFF AX5000: Accessories

Brake module AX5021

Using a brake module it is possible to take up additional braking power in a drive system, because the connection of an external brake resistor without a brake module in a drive system with devices up to max. 25 A rated current is not permissible. A further advantage is the simple installation and the small space requirement of the brake module. The brake module is equipped with a complete DC link and an internal brake resistor and enables the connection of an external brake resistor with the integrated brake chopper. Several brake modules can be integrated into a drive system.

Note 		Operating conditions
The brake module may only be used together with servo drives of the AX51xx-xxxx-02xx or AX52xx-xxxx-02xx series. These devices have serial numbers above 100.000.

In addition to the AX5021, the drive system must include at least 2 further servo drives from the AX5000 range.

Product description

Electrical data

Internal resistance Continuous braking power Prms [W] | Internal resistance Peak braking power Ppeak [W] | External resistance min. [W] | External resistance Continuous braking power Prms [W] | External resistance Peak braking power Ppeak [W]
150 | 14.000 | 22 | 6.000 | max. 32.000

Mechanical data

The external dimensions of the brake module are identical to the dimensions of the servo drives from the AX5000 series up to 12 A.

Mechanical data | AX5021
Weight | approx. 4 kg
Width | 92 mm
Height without plugs | 274 mm
Depth without connectors / accessories | 232 mm

Allgemeine Übersicht

Nr. | Bezeichnung
1 | Navigation rocker
2 | Labelling field
3 | X05 – socket for EtherCAT output
4 | X03 – power supply 24 V DC input
5 | X52 – connection of the temperature monitor and the fan of the external brake resistor
6 | X51 – connection of the external brake resistor
7 | X01 – mains supply 100 – 480 V
8 | X02 – DC link output (890 V DC voltage)
9 | DANGER | 890 V DC voltage at the DC link terminals. Dangerous voltage may be present for 5 minutes after the device is switched off. The device is safe once the voltage has fallen below 50 V.
10 | X04 – socket for EtherCAT input
11 | Display

Pin strip assignment of X51 and X52

Nr. | Designation
1 | T- = input of the temperature measurement sensor of the external brake resistor
2 | T+ = input of the temperature measurement sensor of the external brake resistor
3 | PE = protective conductor
4 | F- = output to the fan controller of the external brake resistor
5 | F+ = output to the fan controller of the external brake resistor
6 | PE = protective conductor
7 | B- = output to the controller of the external brake resistor
8 | B+ = output to the controller of the external brake resistor

Please refer to the servo drive ‘Startup’ manual for the pin assignments of the remaining inputs and outputs.

Note 		Temperature rise in an external brake resistor
The temperature rise of the external brake resistor should be monitored continuously via temperature contacts (1) and (2).

Electrical connection (example)

DANGER 		Serious risk of injury through electric shock!
Due to the DC link capacitors dangerous voltage may persist at the DC link contacts "X02" after the brake module has been disconnected from the mains supply. After disconnecting the brake module wait 5 minutes and measure the voltage at the DC link contacts DC+ and DC-. The device is safe once the voltage has fallen below 50 V.

The example below describes the brake module and several servo drives, which are linked via AX-Bridge modules to make up a drive system. We recommend that the brake module be placed in the first position with the AX-Bridge power supply module (AX5901) and after that the servo drives with decreasing rated current; we assume here that the most powerful servo drive also releases the greatest brake energy.

Attention 		Hazard to devices
Please analyse your application. The brake module should always be placed directly beside the servo drive that releases the greatest brake energy. This rule should also be applied if several brake modules are used in a drive system.

Pos. | Bezeichnung | Pos. | Bezeichnung
1 | PC with TwinCAT and PLC | 6 | Patch cable
2 | Output terminal | 7 | Control cable from the output terminal
2A | Output ‘8’ of the servo drive digital I/Os | 7A | Control cable from output ‘8’ of the servo drive digital I/Os
3 | Brake module | 8 | Mains fuses
4 | Servo drive (with the greatest brake energy) | 9 | Mains contactor
5 | Servo drive |  |

Due to the characteristic of the brake module, a mains failure is recognised immediately; hence, it is necessary that you monitor the ready status of the brake module and disconnect the entire drive system from the mains if necessary. Cyclically check bit 4 – ‘ext. Umain relay’ – in the ‘power management status word’ (IDN P-0-0205) in the controller. If its value is ‘0’, you must ensure that the mains contactor (9) trips, thus disconnecting the complete drive system from the mains. For this, you can use a separate output terminal (2) or a free output ‘8’ of the digital I/O s (2A) of a servo drive.

CAUTION 		Uncontrolled movements
If the drive system is disconnected from the mains due to a mains failure, all axes of the drive system make uncontrolled movements. Take suitable measures to ensure than no persons are endangered during this time. Vertical axes are particularly dangerous.

Integration into TwinCAT

The brake module can be integrated in the TwinCAT System Manager as a completely normal I/O device (1) and is parameterised (3) with the TCDrive Manager (2).

Configuration in the TCDriveManager

Power Management

Pos. | Bezeichnung | Pos. | Bezeichnung
1 | Power management | 6 | Activation / deactivation of the internal brake resistor
2 | Mains voltage selection | 7 | External brake resistor parameter list
3 Phase monitoring (deactivate for single-phase mains) 8 0 = Deactivation of the external brake resistor (not recommended)
1 = Standard energy management with external brake resistor
2 = Energy management with external brake resistor (standalone)
4 Delay time until the phase monitoring responds (activate if mains is unclean) 9

Enabling / disabling the fan of the external brake resistor and setting the switching thresholds.
Switch on Level: Percentage specification of the rated capacity value of the external brake resistor.

Switch on Level: Percentage specification of the rated capacity value of the external brake resistor.

5 | Internal brake resistor parameter list

Energy management

Intelligent energy management ensures that energy is distributed evenly to the DC links and the internal brake resistors when devices are used commonly in the drive system. This reliably prevents the undesirable permanent load of only one device

DC link

The connected servomotors are supplied with energy from the DC link. It serves as an energy storage and first needs to be charged up after switching the device on, before it can supply the servomotors. The DC link is designed such that it can take up and store a certain degree of surplus energy from the motor (brake energy) and subsequently supply the motor again with this stored energy. If the upper limit of the energy storage is reached, the brake chopper feeds any further brake energy into the internal or external brake resistor, where it is converted into heat; it is then no longer available for the further operation of the motor. The voltage is taken and evaluated as the indicator for the current energy level of the DC link. As soon as the brake resistors have also reached their energy limit, the error ‘FD4C, DC link – overvoltage’ appears and the energy flow to and from the motor is interrupted, i.e. the motor makes uncontrolled movements.

In a drive system, the DC links of the individual devices are connected so that the energy level of all devices is the same, regardless of which motor the brake energy is currently being fed back from. In many cases these feedbacks do not happen at the same time, and without a DC link system, for example, a device would be at the limit and would already have to ‘destroy’ energy in a brake resistor, even though other devices could still store energy in the DC link. The energy could be saved in a DC link system, because the DC links of all connected devices are charged up first, before the energy is converted into heat in the brake resistors.

Operating modes of the AX5021

It can be assumed that a brake module is used only if the brake energy cannot be dissipated despite a DC link system and internal brake resistors. The brake module can be operated in 2 different operating modes, which have a direct influence on the energy management. The operating modes can be selected when using the external brake resistor. The following sketches show the storage capacity of the DC link of the individual devices in relation to the operating modes.

Standard operating mode 1 Ext. brake resistor enabled (system / standard)

In this operating mode the capacity of the DC link of the brake module is reduced by approx. 10%. At 90% DC link load the brake chopper then directs the generated braking energy to the external brake resistor and, when this has reached its capacity limit, into the internal brake resistor. In this case the brake energy is first fed into the brake module, since the brake choppers in the other servo drives are only activated at 100% utilisation of the DC link.

This operating mode is set as the default, because no further configuration of the devices in the DC link system is necessary apart from the basic configuration of the brake module. If the external brake resistor of the brake module is mounted outside the control cabinet, then the thermal load in the control cabinet is also lower.

Operating mode 2 Ext. brake resistor enabled (standalone brake chopper)

In this case the capacity of the DC links is fully utilised.

This operating mode must be selected and, apart from the basic configuration of the brake module, the internal brake resistors of the devices in the DC link system should be deactivated, as otherwise the thermal load in the control cabinet will also increase. In order to reduce the thermal load further, it is a good idea to mount an external brake resistor on the brake module outside the control cabinet.

Braking power diagnosis

The current continuous output of the brake resistor can be read via the IDNs P-0-0209 (int. brake resistor) and P-0-0210 (ext. brake resistor). The unit is watts. Loads above 90% of the continuous output of the brake resistor should be avoided. The IDNs can be read cyclically as process data.

The current impulse energy load of the brake resistor can be read via the IDNs P-0-0218 (int. brake resistor) and P-0-0219 (ext. brake resistor). It is specified in % with one decimal place. Loads above 90% should be avoided. The IDNs can be read cyclically as process data.

The maximum energy values since the last reset are stored in IDNs P-0-0220 (int. brake resistor) and P-0-0221 (ext. brake resistor). The values can be reset by entering zero. Duty cycle corresponds to 100 seconds. The energy values are monitored at the specified intervals (100 ms, 1 s, 10 s, 20 s, 40 s and 100 s). The values for 100 s correspond to the continuous output. The maximum values should be approx. 10% below the resistor limits (P-0-0207 or P-0-0208). If a current energy value exceeds the limit value of a brake resistor, this brake resistor is not enabled. In a drive systems or in a configuration with active internal chopper the other brake resistors have to absorb the energy. If this is not possible the DC link voltage will continue to increase until an overvoltage error occurs, followed by disabling of the axes with "Torque off". It is therefore important to ensure that adequate braking power is available in the systems, in order to avoid uncontrolled movements of the axes. The diagnostics should cover the whole system. If not enough reserve capacity is available, an external brake resistor with a higher output should be selected. If the performance limit is still reached, several AX5021 may be used.

Note 		Energy balance
The energy balance is affected positively whenever an axis requires energy and another axis produces generative energy (braking energy). This rule should be observed in all applications.


AX5000 - AX2090-BW5x-xxxx

BECKHOFF AX5000: Accessories

External Brake Resistor - AX2090-BW5x-xxxx

Appropriate use

The brake resistors from the AX2090-BW5x-xxxx series are exclusively designed for direct application with an AX5000 series servo drive or the AX5021 brake module. They are designed for installation as components in electrical installations and machines together with the servo drive or the brake module, and this is their only purpose.

Scope of supply

The scope of supply includes the following components:

  • Brake resistor from the required performance class
  • Technical documentation
  • Packaging

If one of the components is damaged please notify the logistics company and Beckhoff Automation GmbH immediately.

Safety rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations and guidelines.

DANGER 		Serious risk of injury through electric shock!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for 5 minutes. Wait until the DC link capacitors are discharged before touching live terminals. The voltage measured between the DC+ and DC- terminals (X02) must have fallen below 50 V.

WARNING 		Caution - Risk of injury through hot surfaces!
The temperature of the brake resistor housing surface may reach over 200 °C. Please ensure that the housing has cooled down below 40 °C before touching it.
UL-Listing!
It is essential to observe chapter "Product overview-->Guidelines and Standards-->UL-Listing" if you wish to operate an AX5000 in an economic area that requires a UL-Listing.

Product description

Attention 		Caution - Destruction of the equipment
The brake resistor may only be connected to individual AX5000 devices or AX5021 brake modules. It must never be used in a drive system without the AX5021 brake module, since this may lead to its destruction through overload.

The external brake resistors of the AX2090-BW5x-xxxx series are able to convert the dynamic energy generated during braking of a servomotor into heat. The series covers a wide continuous power and peak power range. The built-in temperature switch enables the system to respond immediately to any overload of the brake resistor through analysis in the AX5000 or the PLC. All brake resistors of the AX2090-BW5x-xxxx series are UL and CSA approved.

Attention 		Caution - Destruction of the brake resistor and consequential damage
The built-in temperature switch must be monitored, so that the machine can be stopped in a controlled manner and switched off in the event of an overloading of the brake resistor.

Type key

Mechanical installation

Dimensions and technical data

Type | Nominal capacity [W] * at 40 °C | Resistance [W] | O [mm] | R [mm] | H [mm] | M [mm] | U [mm] | Weight [kg] | AX5000
AX2090-BW50-0300 | 300 | 47 | 349 | 92 | 120 | 230 | 64 | 2 | AX5x01 - AX5112
AX2090-BW50-0600 | 600 | 47 | 549 | 92 | 120 | 430 | 64 | 3 | AX5x01 - AX5112
AX2090-BW50-1600 | 1600 | 47 | 649 | 185 | 120 | 530 | 150 | 5,8 | AX5x01 - AX5112
AX2090-BW51-1000 | 1000 | 23 | 749 | 92 | 120 | 630 | 64 | 4 | AX5118 - AX5193
AX2090-BW51-3000 | 3000 | 23,4 | 490 | 355 | 255 | 380 | 270 | 8 | AX5118 - AX5193
AX2090-BW51-6000 | 6000 | 23,2 | 490 | 455 | 255 | 380 | 370 | 12 | AX5118 - AX5193

*) 4% output reduction per 10 K temperature difference

Mounting positions and distances

(A) = vertical installation is only permitted according to the diagram (terminal box facing downwards).
(B) = horizontal installation

For all mounting positions the following minimum distances must be adhered to:

200 mm to adjacent components, walls etc. and 300 mm to components, ceilings etc. above. If the device is installed vertically (A), the minimum distance to components, floors etc. below is 200 mm in order to allow unobstructed flow of air to the brake resistor.

Electrical installation

DANGER 		Serious risk of injury through electric shock!
Disconnect the AX5000 from the mains before installing the brake resistor!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for 5 minutes. Wait until the DC link capacitors are discharged before touching live terminals. The voltage measured between the DC+ and DC- terminals (X02) must have fallen below 50 V.

Remove the two screws (1) and remove the cover (2) in direction of the arrow. Connect an adequately dimensioned cable (see section Cables) to the terminals (3) of the resistor and the earthing stud (5) and take it out of the terminal box through the strain-relief assembly (9). Ensure adequate strain relief with the two screws (8). Connect the other side of the cable to the DC link contact connector X2 (10) of the AX5000. The connector is supplied with the AX5000. Connect the earthing cable to the earthing conductor of the control cabinet.

Connect an adequately dimensioned cable to the potential-free N/C contact (4) of the temperature switch and take it out of the terminal box through the strain-relief assembly (7) (see section Temperature switch). Ensure adequate strain relief with the nut (6).

Install the cover (2) in reverse order.

Cables

We recommend Beckhoff motor cables for connecting the brake resistors.

WARNING 		Caution - Fire hazard!
The brake resistors become very hot. Only use cables with adequate heat resistance.

Attention 		EMC-Safety
Use only shielded cables.
Type | Brake resistor |  | Temperature switch
 | [mm2] | [AWG] | [mm2] | [AWG]
AX2090-BW50-0300 | 1,5 | 16 | 0,75 | 18
AX2090-BW50-0600 | 1,5 | 16 | 0,75 | 18
AX2090-BW50-1600 | 1,5 | 16 | 0,75 | 18
AX2090-BW51-1000 | 2,5 | 12 | 0,75 | 18
AX2090-BW51-3000 | 2,5 | 12 | 0,75 | 18
AX2090-BW51-6000 | 2,5 | 12 | 0,75 | 18

We recommend wire end sleeves.

Temperature switch

Attention 		Destruction of the brake resistor
The temperature switch is only used for temperature monitoring. The brake resistor is not switched off.

The temperature switch has a potential-free N/C contact, which enables immediate response to any overload of the brake resistor through analysis in the AX5000 or the PLC. Connect the cable directly to a free input of plug "X06". Then parameterise it such that the AX5000 stops the motor(s) with an emergency ramp or the PLC reads and processes this input.

Type | Switching temperature | Switching current 24 VDC er 230 VAC
 | [°C] | [A]
AX2090-BW50-0300 | 180 | 2
AX2090-BW50-0600 | 180 | 2
AX2090-BW50-1600 | 180 | 2
AX2090-BW51-1000 | 180 | 2
AX2090-BW51-3000 | 85 | 2
AX2090-BW51-6000 | 85 | 2

Short-term capacity

Brake resistors are usually not operated continuously, but only exposed to short-time duty. In the following section the permitted short-term capacity is calculated based on the continuous power, overload factor and duty cycle.

Duty cycle

The duty cycle is a relative value that depends on the switch-on time (ton)and the cycle time. Cycle times up to 120 sec. are used directly in the calculation. Should the cycle time exceed 120 sec., the maximum relevant cycle time of 120 sec. is used in the calculation.

Example 1

ton = 60 s

Cycle time = 280 s

Duty cycle = 50 %

Example 2

ton = 40 s

Cycle time = 180 s

Duty cycle = 40 %

Overload factor

Calculation formula:

Short-term capacity = continuous power x overload factor

Overtemperature and continuous power at 100% duty cycle

If your application requires a higher continuous power than the specified nominal capacity, you can accept this state if a higher brake resistor temperature is permitted. The following diagram shows the overtemperature v. the continuous power.

Normal operating range, max. 130%:
This operating range is recommended for maximum service life and error-free operation.

Permitted operating range, max. 160%:
This operating range is still permitted, although it results in shorter service life with higher failure probability.

Inadmissible operating range, more than 160%:
In this operating range there is a risk of destruction of the brake resistor through overheating. Due to the high temperatures the adjacent components are also at risk.

Attention 		Destruction of the brake resistor and adjacent components
Always ensure adequate ventilation of the brake resistor, since the temperatures of the housing surface may exceed 200 °C.


AX5000 - motor chokes

BECKHOFF AX5000: Accessories

Motor chokes

A motor choke must be installed between the AX5000 and the motor from a certain motor cable length onwards. The motor choke reduces the commutation current flowing via the screen back into the AX5000 to a permissible value and can also provide a solution to EMC problems.

Scope of supply

  • Motor choke
  • Spacer including bolts (only necessary for 2-channel AX5000)
  • Documentation

Technical data

Motor rated current | Motor cable length | Servo drives | Motor choke
max. 400 V | ≥25 m to 100 m | AX5101, AX5103, AX5106, AX5112,A X5201, AX5203, AX5206 | AX2090-MD50-0012
max. 480 V | >20 m up to 100 m
Data | AX2090-MD50-0012
Rated voltage | 480 V AC
Rated frequency | 0- 60 Hz
Test voltage cable/cable for 2 s | 1770 V DC
Test voltage cables/housing for 2 s | 2700 V DC
Rated temperature | 50 °C
Inductance | 0,2 mH
Continuous load operation (S1) | 12 A
Climate category (IEC 60068-1) | 25/100/21
Resistance [type] | 25 mW
Weight | 2.9 kg

Installation of the motor choke AX2090-MD50-0012

WARNING 		Caution - Risk of injury through electric shock!
De-energise all electrical components (servo drive, control cabinet etc.) before commencing the installation or deinstallation of the motor choke.

CAUTION 		Destruction of the motor choke!
  • Always install the motor choke vertically on an earthed metallic mounting plate. If no metallic mounting plate is available, you must earth the motor choke; an earthing bolt is provided on the motor choke for this purpose.
  • Ensure adequate ventilation of the motor choke. The permissible ambient conditions are specified in the “Technical data” section.
  • It is essential to maintain the necessary distances to the AX5000 (see sketches below).

The motor chokes for the AX5000 (a) with a max. rated channel current of 12 A are bolted to the mounting plate (d) below the device.
‘Figure 1’ shows a motor choke (b) for one channel.
In the case of 2-channel devices, the motor chokes are bolted on top of one another; see ‘figures 2 and 3’. The spacer (e) is supplied with the motor choke.

Electrical connection

The motor choke is connected using the ‘plug & play’ method. The two plugs of the existing motor cable are unplugged from the AX5000 and plugged into the sockets on the motor choke. The two plugs of the integrated motor choke cable are then plugged into the socket of the AX5000.

Notice 		Connection cables
Use exclusively Beckhoff motor cables and firmly tighten the connecting plugs.
Max. brake away torque - M4 thread = 1,5 Nm ±0,1
Max. brake away torque - M3 thread (motor plug) = 0,6 Nm ±0,1

Dimensions


AX5000 - Mains filter - AX2090-NF50

BECKHOFF AX5000: Accessories

Mains filter - AX2090-NF50

Scope of supply

  • Mains filter

Technical data

Data | AX2090-NF50-0014 | AX2090-NF50-0032
Rated voltage VR | 520 / 300 V AC | 520 / 300 V AC
Rated frequency | 50 / 60 Hz | 50 / 60 Hz
Rated current IR | 14.6 A | 32.8 A
Test voltage cable/cable for 2 s | 2236 V DC | 2236 V DC
Test voltage cables/housing for 2 s | 2720 V DC | 2720 V DC
Rated temperature | 50 °C | 50 °C
Climate category (IEC 60068-1) | 25/100/21 | 25/100/21
Resistance [type] | 9 mW | 4 mW
Leakage current Ileak | 15 mA | 15 mA
Weight | 0.9 kg | 1.75 kg
Approvals | EN 133200, UL 1283, CSA C22.2 No.8 | EN 133200, UL 1283, CSA C22.2 No.8

Installing the mains filter

WARNING 		Caution - Risk of injury through electric shock!
De-energise all electrical components (servo drive, control cabinet etc.) before commencing the installation or deinstallation of the mains filter.

WARNING 		Caution - Risk of injury through electric shock!
Mains filters contain components that can store electrical charge. Wait 5 minutes after disconnecting the filters and measure the voltage on conductors L1 to L3. The device is safe once the voltage has fallen below 50 V.

CAUTION 		Personal injuries!
When installing the mains filter, the protective earth cables must be connected first as a matter of principle. They must be disconnected last when deinstalling. Depending on the size of the leakage current, the special regulations for the implementation of the protective earth connection must be observed. Minimum requirement for the protective conductor KU-value 1) = 4.5 for leakage currents IL < 10 mA or KU = 6 for IL > 10 mA.

1) The KU-value is a variable for the classification of safety-related types of failure for protection against dangerous shock current and excessive heating. A value of KU = 4.5 in relation to interruption is attained:
− with a permanently attached protective earth connection ≥ 1.5 mm2
− with a protective earth connection ≥ 2.5 mm2 via a plug connector for industrial plants (IEC 60309-2).
KU = 6 in relation to interruption is attained with permanently connected conductors ≥ 10 mm2, wherein the type of connection and routing must comply with the standards applicable to PEN conductors.

Attention 		Destruction of the mains filter
The mains filters must be protected by means of an appropriate overcurrent protection device against the impermissible exceeding of the rated current.

Circuit diagram

Connecting cable

The length of the connecting cable from the mains filter to the AX5000 must not exceed 0.4 m. Use exclusively shielded connecting cables.

Dimensional drawings


AX5000 - AX5701 / AX5702

BECKHOFF AX5000: Accessories

Optional encoder card - AX5701 / AX5702

Appropriate use

The optional encoder cards are exclusively intended for application in the optional rear slot of a servo drive from the AX5000 series. The cards are installed together with the servo drive as components in electrical systems and machinery and may only be used in this way.

Scope of supply

The scope of supply includes the following components:

  • Optional encoder card AX570x
  • Technical documentation
  • Packaging

If one of the components is damaged please notify the logistics company and Beckhoff Automation GmbH immediately.

Safety rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations and guidelines.

DANGER 		Caution – Danger of death!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for 5 minutes. Wait until the DC link capacitors are discharged before touching live terminals. The voltage measured between the DC+ and DC- terminals (X02) must have fallen below 50 V.

WARNING 		Caution – Risk of injury!
Electronic equipment is not fail-safe. The machine manufacturer is responsible for ensuring that the connected motors and the machine are brought into a safe state in the event of a fault in the drive system.

Attention 		Caution – Destruction of the optional encoder card through electrostatic charging!
The optional encoder card is an ESD-sensitive component. Follow the usual ESD safety procedures when handling the card (anti-static wrist straps, earthing of the relevant components, etc.).
UL-Listing!
It is essential to observe chapter "Product overview-->Guidelines and Standards-->UL-Listing" if you wish to operate an AX5000 in an economic area that requires a UL-Listing.

Product description

The optional encoder card enables connection of an additional feedback systems per channel. The system parameters match the standard parameters that are analysed via inputs X11 and X21. Through simple configuration via jumpers up to six further digital inputs (In “A” to In “F”) can be analysed, which are provided through special feedback systems via parameter channels. The X41 and X42 sockets are compatible with the plugs of the X11 and X21 front sockets of the AX5000, which means that the tried and tested cables from the ZK4510 series can be used. To analyse the additional digital inputs you simply have to insert an adapter or establish a suitable wiring. This optional card cannot be used as commutation feedback system (primary).

Firmware-version

Operation of the optional encoder card requires firmware version 2.03 b0009 or higher on the AX5000.

Type key

Note 		Operation of the optional encoder card
The AX5701 can only be used in single-channel servo drives, the AX5702 can only be used in two-channel servo drives.

AX5701 – optional encoder card for single-channel servo drives

AX5702 – optional encoder card for two-channel servo drives

Description of the digital inputs

Note 		Functional reliability
Ensure that the ground potentials of the digital inputs “A” to “D” are connected with the ground potential of the AX5000.

Inputs “A” to “D” are “single-wire” inputs (single-ended). They have a certain potential to ground, which is analysed.
Inputs “E” and “F” are “two-wire inputs” (differential). They require (+) and (-) and analyse the voltage difference between the conductors.

Overview of sockets X41 (channel A) and X42 (channel B)

Pin | EnDAT / BiSS | Hiperface | Sin / Cos 1Vpp | TTL | In "A" | In "B" | In "C" | In "D" | In "E" | In "F"
1 | SIN + | SIN + | SIN + | n.c. | X |  |  |  | X (+) |
2 | GND_5 V | GND_9 V | GND_5 V | GND_5 V |  |  |  |  |  |
3 | COS + | COS + | COS + | n.c. |  |  | X |  |  | X (+)
4 | Us_5 V | n.c. | Us_5 V | Us_5 V |  |  |  |  |  |
5 | DX + (Data) | DX + (Data) | n.c. | B + |  |  | Y |  |  |
6 | n.c. | Us_9 V | n.c. | n.c. |  |  |  |  |  |
7 | n.c. | n.c. | REF Z | REF Z |  |  |  |  |  |
8 | CLK + (Clock) | n.c. | n.c. | A + | Y |  |  |  |  |
9 | REF SIN | REF SIN | REF SIN | n.c. |  | X |  |  | X (-) |
10 | GND_Sense | n.c. | n.c. | GND_Sense |  |  |  |  |  |
11 | REF COS | REF COS | REF COS | n.c. |  |  |  | X |  | X (-)
12 | Us_5 V Sense | n.c. | Us_5 V Sense | Us_5 V Sense |  |  |  |  |  |
13 | DX - (Data) | DX - (Data) | n.c. | n.c. |  |  |  | Y |  |
14 | n.c. | n.c. | Z + | Z + |  |  |  |  |  |
15 | CLK - (Clock) | n.c. | n.c. | n.c. |  | Y |  |  |  |

The digital inputs “A” to “D” can be connected to X or Y.
The digital inputs “E” and “F” must be connected to X (+) and X (-).

Configuration of jumpers J-“A” for channel “A” and J-“B” for channel “B”

Jumpers J-“A” and J-“B” (1) are located at the centre of the printed circuit board near the front panel of the card. For each channel there are 2 row of jumpers, each with 20 pins. The default setting without analysis of the additional inputs is shown in the following figure.

The opposite figure shows the basic jumper configuration, which is the same for channel A and channel B. The pins of input sockets X41 and X42 are wired firmly to the corresponding pins of the jumpers rows. The non-configurable pins are not shown. To use the additional inputs proceed as follows:

  • Reposition the relevant jumpers und set IDN P-0-0180-->Feedback options-->Digital Inputs “Input A” to “Input D” to “used” or set IDN P-0-0180-->Feedback options-->Digital Inputs “Input E” or “Input F” to “used” without repositioning the jumpers.

  • Connect the encoder cable as required for the relevant inputs or use an adapter.

The following table shows a selection of combination options.

Feedback system | Input "A" | Input "B" | Input "C" | Input "D" | Input "E" | Input "F"
EnDat | not available
BiSS | not available
Hiperface | X | X |  |  |  |
Sin / Cos 1 Vpp | X | X | X | X |  |
TTL | X1 | X1 | X2 | X2 | X1 | X2

1) Either inputs “A” and “B” or input “E” can be used
2) Either inputs “C” and “D” or input “F” can be used.

Technical Data

Digital inputs “A” to “D” (single-ended) | Open collector max. 1 mA
Digital inputs “E” to “F” (differential) | 0 - 5 V Inp. resistance: 120 W

Installation of the optional encoder card

DANGER 		Caution – Danger of death!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for 5 minutes. Wait until the DC link capacitors are discharged before touching live terminals. The voltage measured between the DC+ and DC- terminals (X02) must have fallen below 50 V.

Attention 		Caution – Destruction of the optional encoder card through electrostatic charging!
The optional encoder card is an ESD-sensitive component. Follow the usual ESD safety procedures when handling the card (anti-static wrist straps, earthing of the relevant components, etc.).
  1. Fully release the bolt (1).
  2. Remove the panel (2).
  3. Carefully insert the optional card (3) into the opening in the direction of the arrow. The slot has guides for the card on the short sides. Ensure that the card is inserted into these guides.
  4. Tighten the bolt (4).

Example: Renishaw RGH 22Z30D00 (TTL encoder with 2 parameter channels)

Configuration via TCDrivemanager (IDN-P-0-0180)

Encoders and inputs

Scaling

Overview of socket X41 (channel A) and jumper configuration

Socket X41

Jumper configuration

Pin | Renishaw | In "C" | In "E"
1 | Alarm + |  | X +
2 | GND_5 V |  |
3 | Limit switch | X |
4 | Us_5 V |  |
5 | B + |  |
6 | n.c. |  |
7 | REF Z |  |
8 | A + |  |
9 | Alarm - |  | X -
10 | GND_Sense |  |
11 | n.c. |  |
12 | Us_5 V Sense |  |
13 | B - |  |
14 | Z + |  |
15 | A - |  |


AX5000 - Cables

BECKHOFF AX5000: Accessories

Cables

General specification

Beckhoff offers pre-assembled motor and feedback cables for faster and flawless installation. Design, dimensioning and installation have significant influence on the function of a servo system. Beckhoff servo cables have been tested with regard to the material used, screening and connection, in order to guarantee proper function and compliance with statutory requirements such as EMC. The use of other may invalidate the warranty.

Wire cross-section depending on the cable length (according to EN60402)

Minimum wire cross-section depending on cable length and current

Line load for different types of installation:

WARNING 		Fire hazard!
If several servo drives are operated at the same time the resulting total current of the configuration must be taken into account for dimensioning of the cables.
The information provides in this section should be regarded as guidance. It is not intended as a substitute for professional design based on the specific application.
Cable cross-section |  | Three-core non-metallic sheathed cable or conduit | Three-core non-metallic sheathed cable, stacked on wall | Three-core non-metallic sheathed cable, side by side, horizontal
[mm²] | [AWG] | [A] | [A] | [A]
1.5 | 16 | 12.2 | 15.2 | 16.1
2.5 | 12 | 16.5 | 21.0 | 22
4 | 10 | 23 | 28.0 | 30
6 | 10 | 29 | 36.0 | 37
10 | 8 | 40 | 50.0 | 52
16 |  | 53 | 66.0 | 70
25 |  | 67 | 84.0 | 88
35 |  | 83 | 104.0 | 114

Line load according to EN60204-1, Table 5, at an ambient temperature of 40°C

Two cable qualities are offered: Cables for fixed installation (static application), and cables for highly dynamic applications such as drag chains.

Cables for fixed installation

General data | Specification
Min. bending radius | 18 x outside diameter
Max. horizontal velocity | 180 m/min
Max. acceleration | 5 m/s²
Max. no. of cycles | 50,000
Max. tensile load | 20 N/mm²
Operating temperature | -10°C to +80°C

Standards and specifications | Motor cable | Encoder cable
UL AWM-listed | 80°C 1000 V | 80°C 30 V
CSA AWM-listed | 75°C 1000V | 75°C 30 V
VDE (U0 / U) | 0.6 / 1 kV | ---
Flame resistance | DIN EN 50265-2-1
Oil resistance | UL 1581
Silicone-free | yes
CFC-free | yes
Halogen-free | no

Specification | Motor cable 4x1.5 + 2x(2x0.75) mm² | Encoder cable 7x(2x0.14) + 1x(2x0.5) mm²
Sheath | Specification
Material | PVC according to UL AWM & CSA AWM
Screen | tinned copper braid, optical cover ≥ 85 %
Separator | polyester tape
Diameter | 11.3 mm ± 0.4 mm | 7.6 mm ± 0.3 mm
Weight | ____ kg / km | ____ kg / km
Colour | orange RAL 2003 | green RAL 6018
Power | 4x1.5 mm² | 2x0.5 mm²
Conductor material | bare copper Cl. 5 (IEC 60228) | tinned copper 19 x 0.18 mm
Insulation | TEO Flexene ® polymer compound according to UL AWM & CSA AWM | polypropylene, according to UL AWM & CSA AWM
Colour code | black (1 - 3) + green/yellow | see section "Feedback cables"
Signal | 2x(2x0.75) mm² | 7x(2x0.14) mm²
Conductor material | bare copper Cl. 5 (IEC 60228) | tinned copper 7 x 0.16 mm
Insulation | TEO Flexene ® polymer compound according to UL AWM & CSA AWM | polypropylene, according to UL AWM & CSA AWM
Structure | pair-wise twisted
Screen per pair | tinned copper sheath, optical cover ≥ 85 % | ---
Separator | fleece tape | ---
Colour code | pair 1: black (5 - 6) pair 2: black (7 - 8) | see section "Feedback cables"
Electrical specification |
Test conditions | 20°C |
Conductor resistance | IEC 60228 Cl. 5 | 0.5 mm²: ≤ 40 Ω/km 0.14 mm²: ≤ 140 Ω/km
Insulation resistance | ≥ 2500 MΩ x km
Operating voltage | ≤ 1000 V | ≤ 30 V
Test voltage: Power (conductor / conductor / screen) Signal (conductor / conductor / screen) | 4 kV eff., 5 min. 2 kV eff., 1 min. | 1500 VDC
Capacitance Power Signal | max. 150 pF / m max. 100 pF / m | max. 100 pF / m max. 120 pF / m

Cables for flexible installation / highly dynamic operation

General data | Specification
Min. bending radius | 7 x outside diameter
Max. horizontal velocity | 240 m/min
Max. acceleration | 30 m/s²
max. moved horizontal length | 20 m
max. vertical length | 5 m
Max. no. of cycles | 10 million
Max. tensile load | 20 N/mm²
Operating temperature | -10°C to +80°C

Standards and specifications | Motor cable | Encoder cable
UL AWM-listed | 80°C 1000 V | 80°C 30 V
CSA AWM-listed | 75°C 1000V | 75°C 30 V
VDE | 0.6 / 1 kV | ---
Flame resistance | DIN EN 50265-2-1
Oil resistance | UL 1581
Silicone-free | yes
CFC-free | yes
Halogen-free | yes

Specification | Motor cable 4x1.5 + 2x(2x0.75) mm² | Encoder cable 4x(2x0.14) + 1x(2x0.5) mm²
Sheath | Specification
Material | TMPU halogen-free, accordingly UL AWM & CSA AWM
Screen | tinned copper braid, optical cover ≥ 85 %
Separator | polyester tape
Diameter | 12.2 mm ± 0.4 mm | 7.6 mm ± 0.3 mm
Weight | ____ kg / km | ____ kg / km
Colour | orange RAL 2003 | green RAL 6018
Power | 4x1.5 mm² | 2x0.5 mm²
Conductor material | bare copper Cl. 5 (IEC 60228) | tinned copper 19 x 0.18 mm
Insulation | TEO Flexene ® polymer compound according to UL AWM & CSA AWM | polypropylene, according to UL AWM & CSA AWM
Colour code | black (1 - 3) + green/yellow | see section "Feedback cables"
Signal | 2x(2x0.75) mm² | 7x(2x0.14) mm²
Conductor material | bare copper Cl. 5 (IEC 60228) | tinned copper 7 x 0,16 mm
Insulation | TEO Flexene ® polymer compound according to UL AWM & CSA AWM | polypropylene, according to UL AWM & CSA AWM
Structure | pair-wise twisted
Screen per pair | tinned copper sheath, optical cover ≥ 85 % | ---
Separator | fleece tape | ---
Colour code | pair 1: black (5 - 6) pair 2: black (7 - 8) | see section "Feedback cables"
Electrical specification |
Test conditions | 20°C |
Conductor resistance | IEC 60228 Cl. 5 | 0.5 mm²: ≤ 40 Ω/km 0.14 mm²: ≤ 140 Ω/km
Insulation resistance | ≥ 2500 MΩ x km
Operating voltage | ≤ 1000 V | ≤ 30 V
Test voltage: Power (conductor / conductor / screen) Signal (conductor / conductor / screen) | 4 kV eff., 5 min. 2 kV eff., 1 min. | 1500 VDC
Capacitance Power Signal | max. 150 pF / m max. 100 pF / m | max. 100 pF / m max. 120 pF / m


AX5000 - Order key for motor and feedback cables

BECKHOFF AX5000: Accessories

Order key for motor and feedback cables

Z K 4 t u v - w w x y - z z z z
t | Servo drive series |  |  |
 |  | 5 | = | AX5000
u | Function |  |  |
 |  | 0 | = | Motor cable
 |  | 1 | = | Encoder cable EnDat, Hiperface, BiSS
 |  | 2 | = | Encoder cable TTL, Sin/Cos with zero pulse
 |  | 3 | = | Resolver cable
 |  | 4 | = | Temperature cable AL2000
 |  | 5 | = | Hall cable for AL2000
v | Function |  |  |
 |  | 0 | = | Motor - drive
 |  | 1 | = | Extension cable
 |  | 2 | = | Motor - choke
 |  | 4 | = | Motor - other side The free end is fitted with wire end sleeves
 |  | 5 | = | Drive - other side The free end is fitted with wire end sleeves
 |  | 9 | = | Raw material
ww | Motor series |  |  |
 |  | 0 0 | = | AL2000/AM2000/AM3000/AM3500
 |  | 01 to 19 | = | Beckhoff
 |  | 80 to 89 | = | Beckhoff
 |  | 20 to 29 | = | Alpha EnDat / Alpha resolver
 |  | 30 to 39 | = | Lenze
 |  | 40 to 49 | = | SEW
 |  | 50 to 59 | = | Siemens
 |  | 60 to 79 | = | Further
x | Quality | 90 to 99 | = | Further
 |  | 0 | = | fixed installation / no motion
 |  | 1 | = | dynamic / drag chain
 |  | 2 | = | high dynamic / high-speed chain
y | Cross-section [mm²] |  |  |
 |  | 0 | = | Feedback
 |  | 1 to 8 | = | 0.75=1 / 1.0=2 / 1.5=3 / 2.5=4 / 4.0=5 / 6.0=6 / 10=7 / 16=8
 |  | 9 | = | special
 |  | 91 | = | 35
 |  | 92 | = | 50
z z z z | Length in dm |  |  |
applies only if Y ≠ 9 |  | 0001 to 9999 | = | 0.1 to 999.9 m
applies only if Y > 9 |  | _001 to _999 | = | 0.1 to 99.9 m


AX5000 Motor cables

BECKHOFF AX5000: Accessories

Motor cables

Motor cable for AL2000 / AM2000 / AM3000 / AM3500

1.5 mm² and 2,5 mm²

Article number | Number of conductors and wire cross-section | Installation
ZK4500-0003-xxxx | 4x1.5 + 2x(2x0.75) mm² | fixed installation
ZK4500-0004-xxxx | 4x2.5 + 2x(2x0.75) mm² | fixed installation
ZK4500-0023-xxxx | 4x1.5 + 2x(2x0.75) mm² | highly dynamic
ZK4500-0024-xxxx | 4x2.5 + 2x(2x0.75) mm² | highly dynamic
Plug connector | Contact | Function | Core identification | Contact | Plug connector
View X | 1 | U | black with white labelling "1" | U | see "Y"
 | 2 / PE | PE | green/yellow | PE
 | 3 | W | black with white labelling "3" | W
 | 4 | V | black with white labelling "2" | V
 | A | Brake + | 5 | 1
 | B | Brake - | 6 | 2
 |  | Screen | Screen | 3
 | C | Temp. + | 7 | 4
 | D | Temp. - | 8 | 5

4 mm²

Article number | Number of conductors and wire cross-section | Installation
ZK4500-0015-xxxx | 4x2 + 2x1 +2x1,5 mm² | highly dynamic
ZK4502-0015-xxxx | 4x2 + 2x1 +2x1,5 mm² | highly dynamic
Plug connector | Contact | Function | Core identification | Contact | Plug connector
View X | U | U | black with white labelling "1" | U | see "Y"
 | PE | PE | green/yellow | PE
 | W | W | black with white labelling "3" | W
 | V | V | black with white labelling "2" | V
 | + | Brake + | 5 | 1
 | - | Brake - | 6 | 2
 |  | Screen | Screen | 3
 | 1 | Temp. + | 7 | 4
 | 2 | Temp. - | 8 | 5


AX5000 - Extension for motor cables

BECKHOFF AX5000: Accessories

Extension for motor cables

Extension cables enable a fixed connection to be used between the control cabinet and the drag chain and the highly dynamic version for the drag chain. The drag chain is regarded as a wear part, which means the drag chain can be replaced with worn cables as required.

Extension for motor cables AL2000 / AM2000 / AM3000 / AM3500

Article number | Number of conductors and wire cross-section | Installation
ZK4501-0003-xxxx | 4x1.5 + 2x(2x0.75) mm² | fixed installation
ZK4501-0004-xxxx | 4x2.5 + 2x(2x0.75) mm² | fixed installation
ZK4501-0023-xxxx | 4x1.5 + 2x(2x0.75) mm² | highly dynamic
ZK4501-0024-xxxx | 4x2.5 + 2x(2x0.75) mm² | highly dynamic

Plug connector | Contact | Function | Core identification | Contact | Plug connector
View X | 1 | U | black with white labelling | 1 | View Y
 | 2 / PE | PE | green/yellow | 2 / PE
 | 3 | W | black with white labelling | 3
 | 4 | V | black with white labelling | 4
 | A | Brake + |  | A
 | B | Brake - |  | B
 |  | Screen | Screen |
 | C | Temp. + |  | C
 | D | Temp. - |  | D


AX5000 - Feedback cables for Beckhoff motors

BECKHOFF AX5000: Accessories

Feedback cables for Beckhoff motors

Attention 		EMC-Safety!
At all cables, do not connect the wires marked with "n.c.".

Encoder cable for AL2000 / AM3000 / AM3500 with EnDat-, BiSS or Hiperface interface and sine / cosine without zero pulse

Article number | Number of conductors and wire cross-section | Installation
ZK4510-0000-xxxx | 7x(2x0.14) + 2x0.5 mm² | fixed installation
ZK4510-0020-xxxx | 7x(2x0.14) + 2x0.5 mm² | highly dynamic

Circular plug 17-pole to motor | Contact | Function | Core identification |  | Contact | D-sub 15-pole to AX5000
 |  |  |  | Rev. 02 05.06.2008
View X (female) | 1 | REFSIN | white | red / blue | 9 | View Y (male)
 | 2 | GND_5 V / 9 V | red/blue | white 0,5 mm2 | 2
 | 3 | REFCOS | green | green | 11
 | 4 | Us_5 V | grey / pink | brown 0,5 mm2 | 4
 | 5 | DX+ Data | grey | grey | 5
 | 6 | Us_9 V | brown / green | brown / green | 6
 | 7 | n.c. |  |  | n.c.
 | 8 | CLK+ Clock | blue | blue | 8
 | 9 | SIN | brown | grey / pink | 1
 | 10 | GND_Sense | violet | violet | 10
 | 11 | COS | yellow | yellow | 3
 | 12 | Us_5 V_Sense | black | black | 12
 | 13 | DX- Data | pink | pink | 13
 | 14 | n.c. |  |  | n.c.
 | 15 | CLK- Clock | red | red | 15
 | 16 | n.c. |  |  | n.c.
 | 17 | n.c. |  |  | n.c.

Encoder cable for AL2000 with sine / cosine encoder with zero pulse

Article number | Number of conductors and wire cross-section | Installation
ZK4520-0020-xxxx | 7x(2x0.14) + 2x0.5 mm² | highly dynamic

 |  | Function |  |  |  |
Circular plug 17-pole to motor | Contact | SIN / COS | TTL | Core identification | Contact | D-sub 15-pole to AX5000
View X (female) | 1 | REFSIN | --- | red / blue | 9 | View Y (male)
 | 2 | GND_5 V / 9 V | GND_5 V / 9 V | white 0,5 mm2 | 2
 | 3 | REFCOS | --- | green | 11
 | 4 | Us_5 V | Us_5 V | brown 0,5 mm2 | 4
 | 5 | --- | B + | grey | 5
 | 6 | Us_9 V | Us_9 V | brown / green | 6
 | 7 | REF Z | REF Z | white / yellow | 7
 | 8 | --- | A + | blue | 8
 | 9 | SIN + | --- | grey / pink | 1
 | 10 | GND_Sense | GND_Sense | violet | 10
 | 11 | COS + | --- | yellow | 3
 | 12 | Us_5 V_Sense | Us_5 V_Sense | black | 12
 | 13 | --- | B - | pink | 13
 | 14 | Z + | Z + | brown / yellow | 14
 | 15 | --- | A - | red | 15
 | 16 | n.c. | n.c. |  | ---
 | 17 | n.c. | n.c. |  | ---

Resolver cable for AM2000 / AM3000 / AM3500

Article number | Number of conductors and wire cross-section | Installation
ZK4530-0010-xxxx | 4x2x0,25 mm² | dynamic

Circular plug 12-pole to motor | Contact | Function | Core identification | Contact | D-sub 15-pole to AX5000
View X (female) | 1 | n.c. |  | n.c. | View Y (female)
 | 2 | Temerature (only PTC, Klixon or Bimetal!) Switchpoint: 1178 W | blue | 1
 | 3 | COS - (S3) | yellow | 3
 | 4 | SIN - (S4) | brown | 4
 | 5 | REF - (R2) | pink | 5
 | 6 | GND_Temp. | red | 9
 | 7 | COS + (S1) | green | 10
 | 8 | SIN + (S2) | white | 11
 | 9 | REF + (R1) | grey | 12
 | 10 | n.c. |  | n.c.
 | 11 | n.c. |  | n.c.
 | 12 | n.c. |  | n.c.


AX5000 - Extension for feedback cables for Beckhoff motors

BECKHOFF AX5000: Accessories

Extension for feedback cables for Beckhoff motors

Extension cables enable a fixed connection to be used between the control cabinet and the drag chain and the highly dynamic version for the drag chain. The drag chain is regarded as a wear part, which means the drag chain can be replaced with worn cables as required.

Encoder cable extension for AL2000 / AM2000 / AM3000

Article number | Number of conductors and wire cross-section | Installation
ZK4511-0000-xxxx | 7x(2x0.14) + 2x0.5 mm² | fixed installation
ZK4511-0020-xxxx | 7x(2x0.14) + 2x0.5 mm² | highly dynamic

Plug connector | Contact | Function | Core identification | Contact | Plug connector
View X (female) | 1 | 1 : 1 connection as in extended cable |  | 1 | View Y (male)
 | 2 |  |  | 2
 | 3 |  |  | 3
 | 4 |  |  | 4
 | 5 |  |  | 5
 | 6 |  |  | 6
 | 7 |  |  | 7
 | 8 |  |  | 8
 | 9 |  |  | 9
 | 10 |  |  | 10
 | 11 |  |  | 11
 | 12 |  |  | 12
 | 13 |  |  | 13
 | 14 |  |  | 14
 | 15 |  |  | 15
 | 16 |  |  | 16
 | 17 | n.c. |  | 17

Extension for resolver and Hall cables for AL2000 / AM2000 / AM3000

Article number | Number of conductors and wire cross-section | Installation
ZK4531-0000-xxxx |  | fixed installation
ZK4531-0020-xxxx |  | highly dynamic

Connector motor side | Contact | Function | Core identification | Contact | Connector clutch side
View X (female) | 1 | 1 : 1 connection as in extended cable |  | 1 | View Y (male)
 | 2 |  |  | 2
 | 3 |  |  | 3
 | 4 |  |  | 4
 | 5 |  |  | 5
 | 6 |  |  | 6
 | 7 |  |  | 7
 | 8 |  |  | 8
 | 9 |  |  | 9
 | 10 |  |  | 10
 | 11 |  |  | 11
 | 12 |  |  | 12


AX5000 - Special motor connections

BECKHOFF AX5000: Accessories

Special motor connections

Linear motors of the AL2xxx series

Connector box

With the Beckhoff AL2250 connector box you can simply connect the motor, encoder and thermal protection contact cables of the AL2000 linear motor range with the trailing cable motor and encoder cables of the AX5000, AX2500 and AX2000 range of servo drives

Appropriate use

The connector box is just for connection to the motor, encoder and thermal protection contact cables of the AL2000 linear motor range with the trailing cable motor and encoder cables of the AX5000, AX2500 and AX2000 range of servo drives.

Description of connections:
A: | Cable bushing and fuse for the linear motor cable.
B: | Cable bushing and fuse for the linear motor encoder cable.
C: | Cable bushing and fuse for the linear motor thermal protection contact cable.
D: | Connecting socket for the standard feedback cable to the servo drive.
E: | Connecting socket for the standard motor cable to the servo drive.
X1: | Terminal strip for the linear motor connection cable. (The side for connection to “E” is already wired)
X2: | Terminal strip for the encoder and thermal protection contact connection cable. (The side for connection to “D” is already wired)
X3: | Thermal protection contact connection. Contacts “1” and “2” are bridged on the board with contacts “7” and “14” of “X2”. (The connection to “E” is already wired).

Installation

WARNING 		Caution – Risk of injury through electric shock!
Remove the motor and feedback lines from the connector box to the servo drive when you open the connector-box.

Note 		Attaching the connector box!
The linear motor cables are not for trailing cables, hence the connector box has to be fixed on the moving part of the linear motor.

Unscrew the cover and fix the connector box with 2 M4 screws on the carriage of the linear motor.

Motor cable:

Strip the wires of the motor cable and fit wire end sleeves.

Twist the screen of the motor cable and solder on a cable with a minimum diameter of 1.5 mm2. Fit wire end sleeves or a cable lug to the free end. Place the nut of socket “A” over the motor cable and feed the wires through the socket “A” in the box and screw the nut onto socket “A”. Fit the shielded and PE cables with a “PE” connection and the power wires on connection “X1”.

Encoder cable:

Strip the wires of the encoder cable and fit wire end sleeves.

Twist the screen of the encoder cable and solder on a cable with a minimum diameter of 0.75 mm2. Fit wire end sleeves or a cable lug to the free end. Place the nut of socket “B” over the encoder cable and feed the wires through the socket “B” in the box and screw the nut onto socket “B”. Fit a “PE” connection to the shielded cable. Wire the signal wires to the “X2” connection as per the table.

Connection pin | Signal description | MES AL2200 | LIKA SMS-V1 | SIKO LE100 | NJ* LIA 1Vss
X1-PE | PE / GND | shield | shield | shield | wh / gn
X2-1 | COS - | red | orange | green | red
X2-2 | GND | white | black | black | white
X2-3 | SIN - | yellow | blue | orange | yellow
X2-4 | + 5V DC | brown | red | brown | brown
X2-5 | DATA + / Z + | --- | white | blue | grey
X2-6 | n.c. | --- | --- | --- | ---
X2-7 | PTC | --- | --- | --- | ---
X2-8 | Clock+ | --- | --- | --- | ---
X2-9 | COS + | blue | green | yellow | blue
X2-10 | GND sense | grey | --- | --- | ---
X2-11 | SIN + | green | yellow | red | green
X2-12 | + 5V sense | pink | --- | --- | ---
X2-13 | DATA - / Z - | --- | --- | violet | pink
X2-14 | PTC | --- | --- | --- | ---
X2-15 | Clock- | --- | --- | --- | ---

Thermal protection contact cable

Strip both wires of the thermal protection contact cable and fit wire end sleeves.

Twist the screen of the thermal protection contact cable and solder on a cable with a minimum diameter of 0.75 mm2. Fit wire end sleeves or a cable lug to the free end. Place the nut of socket “C” over the thermal protection contact cable and feed the wires through the socket “C” in the box and screw the nut onto socket “C”. Fit a “PE” connection to the shielded cable. Fit both thermal protection contact wires to contacts “7” and “14” of connection “X2”.

Retighten the connector box cover.

SEW motors from the “DFS / CFM” range with stopping brake

The stopping brake of the SEW motors has to be connected via a brake rectifier, to guarantee the “quick activation of the brake”. A 3 wire connection cable is required for this. The following schematic diagram shows the correct connections of the motors to the AX5000.

1 = SEW servo motor of the DFS/ CFM range
2 = Motor brake cable ZK4500-4xxx
3 = SEW- BMV5 brake rectifier
4 = Power supply unit with 5A minimum output current


AX5000 - Project planning – important information

BECKHOFF AX5000: Project planning

Project planning – important information

The more thoroughly a machine or plant project is thought through in advance, the less risk there is of having to carry out expensive modifications during or after commissioning. This applies to both the mechanical and electrical design. This section can only give a rough overview of electrical design. Further information can be found in the publication "Projektierungshilfe" (Project planning aid) under Downloads on our website at www.beckhoff.de

Drive train design

Application, servo drive, motors and gear mechanism must be adapted to each other so that there is an adequate safety margin for all components as a degree of sluggishness appears over time due to high temperatures or wear. Make sure that the components in the working area of the system have adequate reserves so that the working life is not impaired and the necessary control quality can be maintained.

Control quality, mass inertia ratio and load connection

Control quality is dependent on the parameters "mass inertia ratio" and "load connection":

Control quality / Dynamics | Mass inertia ratio
Good | 3:1
Average | 5:1
Bad | 10:1

The "Control quality / dynamics" is primarily affected by the mass moment of inertia: a poor "Control quality / dynamic" due to an unfavourable mass moment of inertia cannot be improved even with a very good load connection. Likewise, however, a good "Control quality / dynamic" due to a favourable mass moment of inertia can be reduced through a poor load connection.

Energy management

If the quality of the mains supply is impaired due to wide fluctuations in voltage, then both the servo drive specification and the speed range of the motor will need to be considered. With a positive tolerance for voltage fluctuation the upper limit value of the wide voltage input of the AX5000 needs to be taken into account. With a negative tolerance of the voltage fluctuation it must be checked whether the decrease in speed caused by the low voltage is permissible. With these motors what is known as field weakening operation (check availability) of the servo drive may provide a solution. If the mains supply does not meet the specifications for operation of the AX5000, then isolating transformers, mains chokes, mains filters or other measures may be required. An energy efficient drive system operates in a drive system with a shared DC link and shared internal and possibly also external brake resistors or brake modules. If you are already using similar drive systems, the AX5000 offers a convenient diagnostic system for determining the load on the brake resistors and for transferring the values. Previous experience with drive systems shows that in such a system much smaller or even no external brake resistors / brake modules need to be used.

EMC, earthing, screen connection and potential

The AX5000 corresponds to EMC category "C3" (industrial sector) in terms of conducted interference emissions. If you wish to use components which comply with a higher category you can limit the AX5000 conducted interference emissions with the aid of additional filters to such a degree that this complies with the EMC category "C2" (residential and industrial environment) or "C1" (residential environments). Ensure that there is adequate earthing (large-area low-impedance connection) of all relevant components (incl. control cabinet). The AX5000 incl. periphery, control cabinet, machine bed and motors must be at the same potential, as the AX5000 control quality will suffer under differing potentials and operational malfunction may result. Using the screen connection for potential equalisation is not permitted. If you are unable to provide a uniform reference potential you need to lay potential equalisation cables of adequate dimensions. Smooth operation is only guaranteed by faultless screen connections of the cables. The screens must be applied generously at both ends and must on no account be disconnected. Use pre-assembled Beckhoff motor and feedback cables as these are optimally adapted to the drive system and reduce interference to a minimum. Ensure that the connectors are properly connected: this applies to the motor connector in particular.

Control cabinet

The dimensions of the control cabinet must be sufficient to accommodate all components with the specified distances. Remember that high temperatures may necessitate forced cooling. Position the control cabinet as close as possible to the machine so that the motor cables can be as short as possible. In addition, the control cabinet should have an earthed metal rear panel to which the AX5000 incl. periphery are attached so that safe earthing can be guaranteed. If you are unable to guarantee these conditions you need to earth the AX5000 and the relevant components using an approved cable of adequate size.

Motors and cables at servo drives up to 25A

Motors with max. 400 V rated voltage:
If the length of the motor cable is ≥ 25 m, then a motor choke is required for each motor.

Motors with max. 480 V rated voltage:
If the length of the motor cable is > 20 m, then a motor choke is required for each motor.

The control cabinet should then have adequate space for motor chokes. In exceptional cases (sensitive sensors etc.) it can be necessary to use a motor choke even for motor cable lengths < 25 / 20 m. Lay the power and signal cables in separate metal cable ducts or, if both types of cable use the same metal cable duct, make sure there is an earthed metal dividing wall between the cables.


AX5000 - Fault management

BECKHOFF AX5000: Appendix

Fault management

Fatal errors

General

Fatal errors are error types requiring reinitialisation of the connected AX5000 feedback systems. For this the communication status of the EtherCAT Slave State Machine must be changed from Operational (Op) to Safe-Operational (Safe-Op), which takes place automatically on the occurrence of a fatal error in the case of standard parameterisation. In such a case the drive is in ErrSafe-Op, since an error is additionally signalled. Since two-channel devices possess only one communication unit and no axis operation is possible in the SafeOp state, both channels are stopped by default. In this particular case, the change from Op to ErrSafe-Op results in the working counter of the SyncUnit becoming invalid, since the AX5000 can no longer supply valid actual values, resulting in all servo drives in this SyncUnit being disabled.

Requirement

The measures described in this section assume the following software versions.

  • TwinCAT v2.10 b1329 or later versions
  • Firmware v1.05 b0009 or later versions

Special features for two-channel devices

A fatal error completely stops a two-channel device by default, i.e. the error-free channel and the associated SyncUnit are also stopped. If such a behaviour is not permitted in the application, the default behaviour can be changed with the following parameterisation of IDN P0-0350.

P-0-0350: Change of communication state in the event of fatal errors

0: Immediate state change (default)

If the servo drive is in “Op” state when the fatal error occurs, it immediately changes from “Op” to “ErrSafe-Op” and sets the error bit in the EtherCAT state.

1: No change in communication state while the other channel is enabled

In the case of an active fatal error, the AX5000 only changes to ‘ErrSafeOp’ if the Reset command is executed in the drive; hence, the change of state can be initiated at the best possible time from the application by means of the Reset command.

PLC

The IDN P-0-0040 is used in order to be able to diagnose in the PLC whether a fatal error situation has occurred that will lead to a change of status when next deactivating a channel or when calling the Reset command. This IDN should be read acyclically in the PLC with block “FB_SoERead”. Cyclic evaluation is not meaningful, since the AX5000 no longer supplies valid inputs in ErrSafe-Op state after a fatal error, and therefore no valid information is transferred cyclically.

Bit 0: this bit indicates whether the other channel has an error that will lead to a change of communication from ‘Op’ to ‘ErrSafe-Op’ on deactivation of this channel.

Bit 1: this bit indicates whether this channel has a fatal error that will lead to a change of communication from ‘Op’ to ‘ErrSafe-Op’ on deactivation of the other channel. An error reset is not possible as long as this bit is set.

Bit 2: this bit indicates whether this channel has a fatal error that will lead to a change of communication from ‘Op’ to ‘ErrSafe-Op’ on executing the Reset command.

SyncUnit diagnostics

The individual servo drives should be consolidated in meaningful groups, depending on the application. Each of these groups is allocated to a SyncUnit. Since each group has its own working counter, the individual groups can continue to operate independently in the event of fatal errors. For particularly critical applications, each AX5000 can be allocated a separate Sync Unit. However, this step should only be implemented in cases where it is actually required, because each further Sync Unit results in additional data traffic on the EtherCAT strand.

Allocation of servo drives to a Sync Unit

Start the TwinCAT System Manager and left-click on the associated EtherCAT strand (1). Select the “EtherCAT” tab (2) and left-click on “Sync Unit Assignment” (3). The “Sync Unit Assignment” submenu appears. Section (4) shows the servo drives and their allocation to the Sync Units. Servo drives AX5203 and AX5118 belong to Sync Unit “Cycle Process”, 5206 belongs to Sync Unit “Transport”.

Reinitialisation, troubleshooting and reset

  1. Analyse and rectify the fatal error.
  2. Carry out an error reset via IDN S-0-0099. To this end the blocks “FB_SoEReset” or “FB_SoEReset_ByDriveRef” are available in the PLC.
  3. Automatic change of communication state from “ErrSafe-Op” to “Op”.
  4. NC axis reset. To this end the block “NC_Reset” is available in the PLC.

Re 3.

In order for the communication state to automatically switch back to “Op”, flag “Wait for WcState is OK” must be activated on the corresponding AX5000. This is automatically the case for new configurations. In existing configurations it may have to be set accordingly.
Start the TwinCAT System Manager and left-click on the associated servo drive (1). Select the “EtherCAT” tab (2) and left-click on “Advanced Settings....” (3). The “Advanced Settings” submenu appears. Select the flag “Wait for WcState is OK” with the left mouse button (4).


AX5000 - Firmware Update

BECKHOFF AX5000: Appendix

Firmware Update

The firmware of the AX5000 is a complex software, which is absolutely necessary for the operation of the servo drive. The servo drives are subject to a constant process of further development and improvement and, hence, the firmware is also under constant development, so that the latest technological innovations can also be used.

Dual Use (EU 1382/2014)

As published on December 30, 2014 by EU Commission Delegated Regulation 1382/2014, standard frequency inverters – and with that also Beckhoff products AX5000 – become newly classified Dual-Use items: the item list Annex I of the Dual-Use Council Regulation 428/2009 has been changed accordingly, Frequency inverters (listed in item position 3A225) with a „ rotation field frequency of 600 Hz or more“ are now export controlled items. As a consequence some modifications have to be noticed.

Firmware versions without extension (Dual Use conform) can be used in consideration of Hardware Versions with following drives only:

  • HW Version 1.0 (AX5xxx-0000-x0xx): Serial Number < 68.000
  • HW Version 2.0 (AX5xxx-0000-x20x): Serial Number < 140.000
  • HW Version 2.0 (AX5xxx-0000-x21x)

This Firmware versions with extension (Dual Use conform) can be used in consideration of Hardware Versions with all drives. These versions support both rotational field frequency bands (<600 Hz, >= 600 Hz) depending on product hardware. For products with option „x21x“, shipment as single part may be subject to export control regulations.

Example Firmware file name

Firmware file name of a HW2-Firmware version, which is "Dual Use conform": AX5yxx_xxxx_0203_v2_06_b0016_dual_use_conform.efw

Firmware file name of a HW2-Firmware version, which is NOT "Dual Use conform": AX5yxx_xxxx_0203_v2_06_b0012.efw

Dependency Motor speed - Rotation field frequency

nmax = f x 60 / pp

nmax = max. Motor speedl
f = Rotation field frequency of the servo drive
pp = Amount of motor pole pairs

For f = 599 Hz the motor speed is:

Amount of poles | Amount of pole pairs (pp) | max. motor speed [min-1] | AM8000
2 | 1 | 35.940 | -
4 | 2 | 17.970 | -
6 | 3 | 11.980 | AM801x, AM811x, AM802x, AM812x
8 | 4 | 8.985 | AM8x3x, AM8x4x, AM8x5x
10 | 5 | 7.188 | AM8x6x, AM807x

Note 		Check your application – Dual Use regulation
Please compare the max. attainable motor speed (rpm) with the required speed (rpm) of your application.

Firmware version on the AX5000

The current firmware version of the AX5000 is located in “IDN S-0-0030 - Manufacturer Version” and can be displayed using the TCDriveManager as follows: In the TwinCAT System Manager, mark the servo drive (1) whose firmware version you would like to know. Open the TCDriveManager (2) and click “Device Info” (3). A window opens and the current firmware version (4) appears in the “IDN S-0-0030”.

Update to a new firmware version

Read please the Release Notes carefully before the update. All important changes and additions to the individual firmware versions for the servo drives are located in the corresponding file in the download area on our homepage.

Note 		Never touch a running system!
This old IT concept applies more than ever today, in these times of the most complex systems with ever decreasing cycle times. Please do not perform firmware updates on a system that is working well without a reason, unless requested to do so by Beckhoff Automation.

Note 		Update only within a version number!
We recommend firmware updates only within the same version number (e.g.: V.1.05 (Build 0003) to V.1.05 (Build 0007). If you want to update from V.1.05 to V.1.06, for example, you would need to make further adjustments in TwinCAT. In accompaniment to that, we do not recommend performing a so-called “downgrade” to a lower version number.

VORSICHT 		Do not work on live equipment!
The 24 V supply (plug “X03”) must be connected to the servo drive in order to be able to perform a firmware update. Make sure that the power supply (plug “X01”) is disconnected from the servo drive, so that uncontrolled movements of the equipment cannot occur.

Update preparation

So that you can perform a firmware update, a connection must be made to the computer with TwinCAT that controls the AX5000. It is quite usual for you not to be in the area where the equipment is operated. That is not also necessary, because there are three different procedures for establishing a connection:

1.) Direct accesses to the control computer

You are in the same place where the equipment is operated and can work directly on the control computer. In this case you can continue immediately with the next chapter “Performing the update”.

2.) Remote access to the control computer

You are in a different place and have no direct access to the control computer. In this case you can also perform a firmware update on the control computer using one of the remote connections (VPN tunnel with remote desktop, VNC etc.) that are usual in the IT world. Please make sure that the firewall is configured accordingly for the remote connection and that you have the necessary rights. After establishing the remote connection you can continue with the next chapter “Performing the update”.

3.) Remote access by ADS

You are in a different place and have no direct access to the control computer, or the control computer is located in a cleanroom or the like. In this case you can also perform a firmware update via remote access by ADS. Please read in the Online Information-System how to implement remote access by ADS. Afterwards you can continue with the chapter “Performing the update”. The Online Information System is multilingual!

Performing the update

Click the button (1) in the TwinCAT System Manager to enter the configuration mode. Confirm the query with OK (2). After that a further window appears which must be confirmed with Yes (Ja) (3). Deactivate the “Free Run” with No (Nein) (4).

The system is now in “Configuration mode”.

In order to perform the firmware update, you must click the “Online” tab (6) in the “EtherCAT Device” (5). If you want to update several devices, you can select the respective servo drives (7) together; in the case of one device, select only the one servo drive. Subsequently, click with the right mouse button inside the selected area and select the command “Firmware Update” (8) in the command overview.

In the place where you have stored the desired firmware version, select the firmware file (9) and click “Open” (10). Confirm the window that then opens with “OK”; the firmware update is then performed. After successful completion you must click OK (11) in the concluding “Function Succeeded” window.

Subsequently, TwinCAT must be brought from configuration mode back into operating mode. To do this, click the button (12) and confirm the query that appears with “OK” (13).

Hinweis 		Update failed!
If the firmware update is aborted with an error message, you should try again. If the abortion occurs several times, please start a further attempt with another copy of the firmware file.


AX5000 - The Beckhoff automation system

BECKHOFF AX5000: System description

The Beckhoff automation system

More and more customers are looking for automation systems from one source in order to

  • have a single contact,
  • simplify the interfaces between the components,
  • ensure fast and trouble-free commissioning, and
  • have access to worldwide service and support from one source.

Beckhoff offers this solution:

- Industrial PC as real-time automation platform
- Real-time software packages
 | TwinCAT NC PTP for point-to-point movements
 | TwinCAT NC I for interpolated movements of up to 3 axes
 | TwinCAT CNC for interpolated movements of up to 32 axes
- High-end servo drive
 | AX2000: single-axis drive, up to 70 A rated current AX2500: multi-axis system, up to 8 axes AX5000: EtherCAT Drive
- Rotational and linear servo motors
 | AM2000: Servomotors AM3000: Servomotors, pole-wound AM3500: Servomotors with high moment of inertia AL2000: Linear motors AL3000: Ironless linear motors

The AX5000 servo drive is a component of the Beckhoff automation system. It is not designed for stand-alone operation. The AX5000 is the first drive developed specifically for EtherCAT. This enables the outstanding features of EtherCAT to be fully utilised:

  • Outstanding performance
  • Low-cost
  • Simple diagnosis
  • Safety over EtherCAT


System structure

In analogy to the Beckhoff Bus Terminals the EtherCAT terminal system is a modular I/O system consisting of electronic terminal blocks. An I/O station consists of an EtherCAT coupler and almost any number of terminals. Since up to 65535 devices can be connected, the size of the network is almost unlimited.

EtherCAT is designed for operation without switch. In this case the EK1100 coupler is used. For applications requiring a switch Beckhoff will shortly provide a solution in the form of the EK1000 that can process the EtherCAT UDP protocol in passing.

The electronic terminal blocks are attached to the EtherCAT coupler. The contacts are made as the terminal clicks into place, without any other manipulation. This means that each electronic terminal block can be individually exchanged. It can be placed on a standard mounting rail.

Suitable EtherCAT terminals are available for common digital and analog signal types encountered in the world of automation. Fieldbus devices, e.g. for PROFIBUS, CANopen or DeviceNet, are integrated via local fieldbus master/slave terminals. Removal of the fieldbus master saves PCI slots in the PC. Any Ethernet devices can be connected decentralised via switch terminals.

The fine granularity of the EtherCAT terminals enables bit-precise composition of the required I/O channels. The digital EtherCAT terminals are designed as 2-, 4-, or 8-channel terminals. The standard analog signals of ± 10 V, 0 ... 10 V, 0 ... 20 mA and 4 ... 20 mA are all available as 1-, 2-, 4-, and 8-channel variants within a standard housing. The EtherCAT Terminal system offers different connection options for optimum adaptation to the respective application. The ELxxxx EtherCAT terminals include electronics and connection level in a single enclosure. The ESxxxx type EtherCAT terminals feature a pluggable connection level. The ES series Bus Terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.

Free choice of topology – maximum wiring flexibility: with or without switch, line or tree topologies, can be freely selected and combined. Address assignment is automatic, no IP address setting is required.


System Properties

Protocol

The EtherCAT protocol is optimized for process data and is transported directly within the Ethernet frame thanks to a special Ether-type. It may consist of several sub-telegrams, each serving a particular memory area of the logical process images that can be up to 4 gigabytes in size. The data sequence is independent of the physical order of the Ethernet terminals in the network; addressing can be in any order. Broadcast, Multicast and communication between slaves are possible. Transfer directly in the Ethernet frame is used in cases where EtherCAT components are operated in the same subnet as the control computer.

However, EtherCAT applications are not limited to a subnet: EtherCAT UDP packs the EtherCAT protocol into UDP/IP datagrams. This enables any control with Ethernet protocol stack to address EtherCAT systems. Even communication across routers into other subnets is possible. In this variant, system performance obviously depends on the real-time characteristics of the control and its Ethernet protocol implementation. The response times of the EtherCAT network itself are hardly restricted at all: the UDP datagram only has to be unpacked in the first station.

Protocol structure: The process image allocation is freely configurable. Data are copied directly in the I/O terminal to the desired location within the process image: no additional mapping is required. The available logical address space is with very large (4 GB).

Topology

Line, tree or star: EtherCAT supports almost any topology. The bus or line structure known from the fieldbusses thus also becomes available for Ethernet. Particularly useful for system wiring is the combination of line and branches or stubs. The required interfaces exist on the couplers; no additional switches are required. Naturally, the classic switch-based Ethernet star topology can also be used.

Maximum wiring flexibility:
with or without switch, line or tree topologies, can be freely selected and combined. The complete bandwidth of the Ethernet network - such as different optical fibers and copper cables - can be used in combination with switches or media converters.

Distributed Clocks

Accurate synchronization is particularly important in cases where spatially distributed processes require simultaneous actions. This may be the case, for example, in applications where several servo axes carry out coordinated movements simultaneously.

The most powerful approach for synchronization is the accurate alignment of distributed clocks, as described in the new IEEE 1588 standard. In contrast to fully synchronous communication, where synchronization quality suffers immediately in the event of a communication fault, distributed aligned clocks have a high degree of tolerance vis-à-vis possible fault-related delays within the communication system.

With EtherCAT, the data exchange is fully based on a pure hardware machine. Since the communication utilizes a logical (and thanks to full-duplex Fast Ethernet also physical) ring structure, the mother clock can determine the run-time offset to the individual daughter clocks simply and accurately - and vice versa. The distributed clocks are adjusted based on this value, which means that a very precise network-wide timebase with a jitter of significantly less then 1 microsecond is available.

However, high-resolution distributed clocks are not only used for synchronization, but can also provide accurate information about the local timing of the data acquisition. For example, controls frequently calculate velocities from sequentially measured positions. Particularly with very short sampling times, even a small temporal jitter in the displacement measurement leads to large step changes in velocity. With EtherCAT new, extended data types are introduced as a logical extension (time stamp and oversampling data type). The local time is linked to the measured value with a resolution of up to 10 ns, which is made possible by the large bandwidth offered by Ethernet. The accuracy of a velocity calculation then no longer depends on the jitter of the communication system. It is orders of magnitude better than that of measuring techniques based on jitter-free communication.

Performance

EtherCAT reaches new dimensions in network performance. Protocol processing is purely hardware-based through an FMMU chip in the terminal and DMA access to the network card of the master. It is thus independent of protocol stack run-times, CPU performance and software implementation. The update time for 1000 I/Os is only 30 µs - including terminal cycle time. Up to 1486 bytes of process data can be exchanged with a single Ethernet frame - this is equivalent to almost 12000 digital inputs and outputs. The transfer of this data quantity only takes 300 µs.

The communication with 100 servo axes only takes 100 µs. During this time, all axes are provided with set values and control data and report their actual position and status. Distributed clocks enable the axes to be synchronised with a deviation of significantly less than 1 microsecond.

The extremely high performance of the EtherCAT technology enables control concepts that could not be realized with classic fieldbus systems. For example, the Ethernet system can now not only deal with velocity control, but also with the current control of distributed drives. The tremendous bandwidth enables status information to be transferred with each data item. With EtherCAT, a communication technology is available that matches the superior computing capacity of modern Industrial PCs. The bus system is no longer the bottleneck of the control concept. Distributed I/Os are recorded faster than is possible with most local I/O interfaces. The EtherCAT technology principle is scalable and not bound to the baud rate of 100 MBaud – extension to GBit Ethernet is possible.

Diagnostics

Experience with fieldbus systems shows that availability and commissioning times crucially depend on the diagnostic capability. Only faults that are detected quickly and accurately and which can be precisely located can be corrected quickly. Therefore, special attention was paid to exemplary diagnostic features during the development of EtherCAT.

During commissioning, the actual configuration of the I/O terminals should be checked for consistency with the specified configuration. The topology should also match the saved configuration. Due to the built-in topology recognition down to the individual terminals, this verification can not only take place during system start-up, automatic reading in of the network is also possible (configuration upload).

Bit faults during the transfer are reliably detected through evaluation of the CRC checksum: The 32 bit CRC polynomial has a minimum hamming distance of 4. Apart from breaking point detection and localization, the protocol, physical transfer behavior and topology of the EtherCAT system enable individual quality monitoring of each individual transmission segment. The automatic evaluation of the associated error counters enables precise localization of critical network sections. Gradual or changing sources of error such as EMC influences, defective push-in connectors or cable damage are detected and located, even if they do not yet overstrain the self-healing capacity of the network.

Integration of standard Bus Terminals from Beckhoff

In addition to the new Bus Terminals with E-Bus connection (ELxxxx), all Bus Terminals from the familiar standard range with K-Bus connection (KLxxxx) can be connected via the BK1120 or BK1250 Bus Coupler. This ensures compatibility and continuity with the existing Beckhoff Bus Terminal systems. Existing investments are protected.


EtherCAT Wiring

The cable length between two EtherCAT devices must not exceed 100 m.

Cables and connectors

For connecting EtherCAT devices only Ethernet cables that meet at least the requirements of category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.

EtherCAT uses RJ45 connectors. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).

Pin | Core coloring | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -

Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

The following Beckhoff cables are suitable for cabling of EtherCAT systems:

  • ZB9010 (industrial Ethernet/EtherCAT cable, fixed installation, CAT5e, 4-wires)
  • ZB9020 (industrial Ethernet/EtherCAT cable, drag chain suitable, CAT5e, 4-wires)
  • ZS1090-0003 (RJ 45 connector, 4-pin, IP 20, for field-assembly)
  • ZS1090-0005 (RJ 45 connector, 8-pin, (GigaBit suitable), IP 20, for field-assembly)
  • ZK1090-9191-0001 (0.17m EtherCAT patch cable)
  • ZK1090-9191-0005 (0.5m EtherCAT patch cable)
  • ZK1090-9191-0010 (1.0m EtherCAT patch cable)
  • ZK1090-9191-0020 (2.0m EtherCAT patch cable)
  • ZK1090-9191-0030 (3.0m EtherCAT patch cable)
  • ZK1090-9191-0050 (5.0m EtherCAT patch cable)

E-Bus supply

Attention 		Attention! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EtherCAT State Machine

The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.

A distinction is made between the following states:

  • Init
  • Pre-Operational
  • Safe-Operational and
  • Operational
  • Boot

The regular state of each EtherCAT slave after bootup is the OP state.

Init

After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.

Pre-Operational (Pre-Op)

During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.

In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.

Safe-Operational (Safe-Op)

During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).

In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.

Operational (Op)

Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.

In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.

Boot

In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.

In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


AX5000 - EtherCAT

BECKHOFF AX5000: EtherCAT

EtherCAT as drive bus

EtherCAT technology overcomes these inherent limitations of other Ethernet solutions: the Ethernet packet is no longer received, then interpreted and copied as process data at every connection. The EtherCAT devices read the data addressed to them while the telegram passes through the device. Similarly, input data are inserted while the telegram passes through. The telegrams are only delayed by a few nanoseconds. Since an Ethernet frame reaches the data of many devices both in send and receive direction, the usable data rate increases to over 90%. The full-duplex features of 100BaseTx are fully utilised, so that effective data rates of > 100 Mbit/s (>90% of 2 x 100 Mbit/s) can be achieved.

The option of being able to use EtherCAT both for drive applications and for fast I/O signals was one of its main development aims right from the start. In existing systems, short cycle times and high synchronicity (as required for control loops that are closed via the bus) could only be realised with special drive buses. The SERCOS profile for servo drives according to IEC61491 was implemented in order to make the drive functionality compatible with existing standards and facilitate commissioning and optimised operation of the AX5000 through the user.

Special drive technology requirements

  • Cycle time

  • Synchronicity

  • Simultaneity

Typical values for the necessary cycle times lie between 1 and 4 milliseconds when position is specified cyclically, with position control in the drive. One microsecond is often quoted as an adequate value for synchronicity in drive technology.

While synchronicity describes the temporal jitter during processing of the functions in the device involved (drives and controllers), simultaneity defines the measure of temporal offset of these functions. Synchronicity is important for the individual devices, so that their own subordinate control loops can synchronise with the cyclic signal with the required precision. Simultaneity moreover enables distributed devices to work on a common task with absolutely identical timebase.

Distributed clocks - EtherCAT slave controller features

EtherCAT uses an approach based on distributed clocks for synchronisation control: All devices have an independent clock as a basis for running local cycles and events. The crucial factor is that all clocks run at the same speed and have the same base time. A special control integrated in the EtherCAT Slave Controller (ESC) ensures that all clocks are guided by a reference clock and are synchronised irrespective of temperature and production tolerances.

Multi-protocol capability

Further important criteria for a fieldbus system that is to support drive technology are the communications protocol and profile used, which are responsible for compatibility and efficient data exchange between the controller and the drive. Instead of re-inventing the wheel, EtherCAT uses proven technology for this purpose.

None of the available protocols on their own support all communication requirements of modern fieldbuses (process data, parameter data, parallel TCP/IP, firmware updates, routing to subordinate bus systems, etc.). EtherCAT therefore introduces multi-protocol capability, consolidating the different protocols in a standardised mailbox. This enables quick and full conversion of existing devices to EtherCAT. The protocols relevant for drive technology are CANopen over EtherCAT (CoE) and Servo Profile over EtherCAT (SoE). They enable the advantages of EtherCAT in terms of transfer characteristics to be combined with proven, profile-specific drive functions. The Ethernet over EtherCAT (EoE) and File Access over EtherCAT (FoE) protocols provide options for integrating a web server in the drive, for example, or for efficiently exchanging firmware or cam plate tables via the bus.

Servo Profile over EtherCAT

The Servo Profile over EtherCAT (SoE) protocol enables the proven SERCOS device profile to be used, which is tailored for demanding drive technology and standardised in IEC 61491. The SERCOS service channel, and therefore access to all parameters and functions residing in the drive, is mapped to the EtherCAT mailbox. Here too, the focus is on compatibility with the existing protocol (access to value, attribute, name, units etc. of the SERCOS identifiers) and expandability with regard to data length limitation. The process data (for SERCOS in the form of AT and MDT data) are transferred via the EtherCAT Slave Controller. The associated mapping is done SERCOS-compliant via the identifiers S- 0-0015, S-0-0016 and S-0-0024. For synchronisation - like for the CoE protocol - the synchronisation features of the EtherCAT Slave Controller are utilised as described above. This also includes - with associated quality improvements - those of standard SERCOS, so that implementation is correspondingly easy. The EtherCAT Slave State Machine explained above can also be mapped easily to the phases of the SERCOS protocol. "Pre-operational" corresponds to SERCOS, phase 2, and enables service channel communication without process data exchange. "Safe operational" is comparable with phase 3. Synchronisation is carried out as required, although for EtherCAT inputs that are already valid have to be transferred. "Operational" exactly corresponds to phase 4 for normal, cyclic data exchange. As the name suggests, the EtherCAT Slave State Machine refers to a slave and - unlike SERCOS - therefore enables individual drives to be parameterised and started up independent of other devices.

Conclusions

While EtherCAT is not a pure drive bus, it meets the associated requirements at least one order of magnitude better than familiar, specialised systems. Drive, I/O and communication buses therefore no longer have to be separated. Even demanding tasks, such as measurement technology applications, can be integrated and enable new functionalities to be utilised with classic control technology. Because proven communication profiles are used, migration of existing devices and applications can easily be accomplished. For drive technology in particular, a small number of profiles have been developed and tried and tested over years. It also means that the complete tool chain and existing experience with the parameterisation of associated drives is maintained.

IDNs used

This is a example for the structure and description of an IDN. A list and description of all relevant IDNs can be found in the separate IDN description (chm).

S-0-0001, Control unit cycle time (TNcyc)

Description:
The control unit cycle time defines the cyclic intervals during which the control unit makes new command values available. The control unit cycle time shall be transferred from the master to the slave during CP2 and becomes active in the slave during CP3. The control unit cycle time should be an integer multiple of the communication cycle time. tNcyc = tScyc * n [n =1,2,3,4...]

Parameter structure:

Attributes:
Unit: | us
Default value: | 500
Min value: | 62
Max value: | 20000
Data length: | 16
Format: | binary
Cyclic transfer: | No
Write protected: | SafeOp, Op
Decimal point: | 0
Device parameter: | Yes


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com