AX2000 - IDN Reference

BECKHOFF Drive Technology

IDN Reference for AX2000

Version: 2.0
Date: 15.10.2007


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


AX2000 IDN Reference - Documentation issue status

BECKHOFF AX2000 IDN Reference: Foreword

Documentation issue status

Version | Comment
2.0 | Support and service added
1.0 | First release


AX2000-B750 Introduction

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

Introduction

The AX2000 drive is available with different Fieldbus interfaces. One of these interfaces is the optional SERCOS interface (order number: AX2000-B750). Inside this reference documentation, the SERCOS IDNs supported by AX2000 are described.

Hint:

Beckhoff provides this preliminary document for informational purposes only. Beckhoff makes no warranties, expressed or implied, in this document.

Index | Remarks
Nomenclature | Abbreviations used inside this documentation
IDN notation format | How to read the IDN descriptions
IDN By Function Overview | IDN's sorted by function (Torque Control, Velocity Control, Homing,...)
IDN By Function Overview II | IDN's for general use, sorted by function (Monitoring & Trouble Shooting, Fault & Safety Detection, Configurable I/O,..)
General Information | Informations on how to configure basic settings like baud rate, address,.. of the AX2000-B750 drive
IDN Set Supported By AX2000-B750 | Listing of all currently supported S- and P - parameters (with specific ADS Index Group information for accessing these IDNs with TwinCAT)


AX2000-B750 Abbreviations

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

Nomenclature

IDN description abbreviations

AqB | Incremental encoder signaling scheme. The A and B signals are in quadrature
AT | Amplifier telegram (telegram from drive)
C1D | Class 1 diagnostic (fault)
C2D | Class 2 diagnostic (warning)
C3D | Class 3 diagnostic (status)
CCT | Communication cycle time (IDN 2)
CCW | Counter clockwise. CW and CCW are viewed from the output end of the motor
CUCT | Control unit cycle time (IDN 1)
CUSB | Control unit synchronization bit (MDT control word bit 10)
CW | Clockwise. CW and CCW are viewed from the output end of the motor
CPx | Communication phase
IC | Continuous current
IDN | Identification number
IP | Peak current
LSB | Least significant bit
MDT | Master data telegram
MSB | Most significant bit
MST | Master synchronization telegram
PFB | Position feedback
ROD | Refer to AqB
RTC | Real time control bit
RTS | Real time status bit
SC | Sercos Service channel
mI | Micro-Interpolator


AX2000-B750 IDN Notation

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN Notation Format

The IDN set supported by AX2000-B750 is listed in numerical order with a short description for each IDN. The descriptions use the following format:

Below you'll find an example of the IDN description structure.

IDN 1 Numeric Cycle Time

The cycle time of the numeric controller (TNcyc). This time corresponds to IDN 2, which specifies the SERCOS cycle time (TScyc).

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 1000 | Run-Up Check: | CP2
Maximum: | 8000 | Cyclic Transfer: |
Default: | 2000 | Serial Equiv: |
Units: | μs | Version: |
IDN Type: | SC | ADS Index Group (hex.): | 0x0001

Note:

Not all IDN descriptions require all of the fields listed above. Only the applicable fields are filled within an IDN description. The field definitions are as follows:

IDN x

The identification number in short-hand notation.

S-x-xxxx / P-x-xxxx

According to IEC 61491 specified notation of a SERCOS identification number.
S-x-xxxx are SERCOS standard-specific identification numbers, versus P-x-xxxx are product-specific ones.

Title

A descriptive title of the IDN (in above case it is: Numeric Cycle Time).

Description

Information of the IDN purpose and relations/dependencies to other IDN's are named here.

Data Length

The length of IDN element 0 resp. 7, in bytes. Possible entries for this field are as follows:

2 bytes - The length of the operating data is 2 bytes.

4 bytes - The length of the operating data is 4 bytes.

1 byte var. - The length of the operating data is variable. The length of one data element is 1 byte.

2 bytes var. - The length of the operating data is variable. The length of one data element is 2 bytes.

4 bytes var. - The length of the operating data is variable. The length of one data element is 4 bytes.

Data Format

The format for interpreting and displaying the operating data. Possible entries for this field are binary, unsigned decimal, signed decimal, hexadecimal, text and IDN.

Minimum / Maximum

The allowed range of IDN element 7 data. IDN element 7 is checked for range compliance in the service channel. In general, if the range is blank in the IDN description, this means that IDN elements 5 and 6 are not supported. The ranges of some IDNs are dependent upon the value of other IDNs, drive parameters or motor parameters.

Default

The default value for IDN element 7 data. An IDN will revert to its default value after a firmware upgrade. The default may be a fixed value, or it may be stored in non-volatile memory. A blank “Default” field indicates that the IDN does not have a default value.

Units

The units of IDN element 7 data and of the minimum, maximum, and default fields. The units of some IDNs are obtained from the operating data of other IDNs. IDNs of data type “binary”, “text”, or “IDN” do not have units and the “Units” field is left blank in the IDN description.

Non-Volatile

Indicates whether the IDN operation data can be saved in non-volatile memory. Possible entries for this field are as follows:

(blank) - The operating data is stored in volatile memory and is lost when logic power is removed.
Yes - The operating data may be stored in non-volatile memory and will be retained after power down.

Write Access

The SERCOS communication phases (CPx) during which an IDN may be written. In general an IDN may be read through the service channel during communication phases CP2 and above. However writing to an IDN may be restricted during some communication phases or while the drive is enabled. An entry of “Read-only” indicates that the IDN cannot be written during any communication phase.

Run-Up Check

The SERCOS communication phases (CPx) during which the validity of the operating data is checked. Possible entries for this field are as follows:

(blank) - The validity of the operating data is not checked.
CP2 - The validity of the operating data will be checked in the procedure “S-0-0127 Communication phase 3 transition check.”
CP3 - The validity of the operating data will be checked in the procedure “S-0-0128 Communication phase 4 transition check.”

Cyclic Transfer

Indicates whether cyclic transfer is possible for IDN element 7. Possible entries for this field are as follows:

(blank) - The operating data is not cyclic.
MDT - The IDN may be transferred within the MDT as cyclic data.
AT - The IDN may be transferred within the AT as cyclic data.

Serial Equivalent

An equation of equivalent protocol commands that may be issued through the RS-232/485 serial port (e.g. through the Microsoft Windows® HyperTerminal program to be started with: Start | Run ... type hypertrm.exe) to obtain the IDN data. The contents of the IDN can be obtained by evaluating the equation. The field is blank in the IDN description, if no equivalent serial commands are available.

Version

The drive Firmware version from which on this IDN is supported.

IDN Type

The

IndexGroup

Names the ADS IndexGroup to use for accessing this IDN via ADS in a hexa-decimal format. The IndexOffset, which is also necessary for the ADS command, specifies the required element from this SERCOS IDN in this context. The IndexOffset (IdxOffs) to use, varies from case to case.

IndexOffset specification:

0 or 7 = value,

1 = Data Status,

2 = Name (read only),

3 = Attribute (refer to SERCOS specification IEC 61491),

4 = Unit,

5 = Minimum,

6 = Maximum

TwinCAT PLC contains a function block library (TcSystem.lib) for the ADSREAD and ADSWRITE access of objects accessible via the ADS protocol.


AX2000-B750 IDN By Function Overview

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN By Function Overview

Sorted overview of ident numbers necessary for dedicated drive control functions as for:

Current / Torque Control, Velocity Control, Position Control, Accel / Decel Control and Homing.

For general communication types see: "IDN By Function Overview II".

Current / Torque Control

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 32 | (S-0-0032) | Primary Operation Mode | 0x0020
IDN 33 | (S-0-0033) | Secondary Operation Mode 1 | 0x0021
IDN 84 | (S-0-0084) | Torque Feedback Value | 0x0054
IDN 86 | (S-0-0086) | Torque/Force Data Scaling Type | 0x0056
IDN 92 | (S-0-0092) | Bipolar Torque Limit | 0x005C
IDN 106 | (S-0-0106) | Current Loop Proportional Gain 1 | 0x006A
IDN 107 | (S-0-0107) | Current Loop Integral Action Time 1 | 0x006B
IDN 110 | (S-0-0110) | Amplifier Peak Current | 0x006E
IDN 112 | (S-0-0112) | Amplifier Rated Current | 0x0070
IDN 114 | (S-0-0114) | System Load Limit | 0x0072
IDN 3020 | (P-0-3020) | System Rated Current | 0xB020

Velocity Control

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 32 | (S-0-0032) | Primary Operation Mode | 0x0020
IDN 33 | (S-0-0033) | Secondary Operation Mode 1 | 0x0021
IDN 36 | (S-0-0036) | Velocity Command Value | 0x0024
IDN 38 | (S-0-0038) | Positive Velocity Limit Value | 0x0026
IDN 39 | (S-0-0039) | Negative Velocity Limit Value | 0x0027
IDN 40 | (S-0-0040) | Velocity Feedback Value | 0x0028
IDN 41 | (S-0-0041) | Homing Velocity | 0x0029
IDN 44 | (S-0-0044) | Velocity Data Scaling Type | 0x002C
IDN 45 | (S-0-0045) | Velocity Data Scaling Factor | 0x002D
IDN 46 | (S-0-0046) | Velocity Data Scaling Exponent | 0x002E
IDN 91 | (S-0-0091) | Bipolar Velocity Limit | 0x005B
IDN 100 | (S-0-0100) | Velocity Loop Proportional Gain | 0x0064
IDN 101 | (S-0-0101) | Velocity Loop Integral Action Time | 0x0065
IDN 296 | (S-0-0296) | Velocity Feed Forward Gain | 0x0128
IDN 392 | (S-0-0392) | Velocity Feedback Filter Time Constant | 0x0188
IDN 3021 | (P-0-3021) | Over Speed | 0x8BCD
IDN 3027 | (P-0-3027) | Manufacturer Homing Modes | 0x8BD3

Position Control

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 32 | (S-0-0032) | Primary Operation Mode | 0x0020
IDN 33 | (S-0-0033) | Secondary Operation Mode 1 | 0x0021
IDN 41 | (S-0-0041) | Homing Velocity | 0x0029
IDN 42 | (S-0-0042) | Homing Acceleration | 0x002A
IDN 47 | (S-0-0047) | Position Command Value | 0x002F
IDN 51 | (S-0-0051) | Position Feedback Value 1 (Motor Feedback) | 0x0033
IDN 52 | (S-0-0052) | Reference Distance 1 | 0x0034
IDN 57 | (S-0-0057) | Position Window | 0x0039
IDN 76 | (S-0-0076) | Position Data Scaling Type | 0x004C
IDN 79 | (S-0-0079) | Rotational Position Resolution | 0x004F
IDN 104 | (S-0-0104) | Position Loop Proportional Gain | 0x0068
IDN 105 | (S-0-0105) | Position Loop Integral Action Time | 0x0069
IDN 130 | (S-0-0130) | Probe 1 Positive Edge Value | 0x0082
IDN 131 | (S-0-0131) | Probe 1 Negative Edge Value | 0x0083
IDN 147 | (S-0-0147) | Homing Parameter | 0x0093
IDN 148 | (S-0-0148) | Procedure: Drive Controlled Homing | 0x0094
IDN 159 | (S-0-0159) | Monitoring Window | 0x009F
IDN 169 | (S-0-0169) | Probe Control Parameter | 0x00A9
IDN 170 | (S-0-0170) | Procedure: Probing | 0x00AA
IDN 179 | (S-0-0179) | Probe Position Latch Status | 0x00B3
IDN 189 | (S-0-0189) | Following Distance | 0x00BD
IDN 298 | (S-0-0298) | Home Switch Distance | 0x012A
IDN 336 | (S-0-0336) | Status “In Position” | 0x0150
IDN 400 | (S-0-0400) | Home Switch Status | 0x0190
IDN 401 | (S-0-0401) | Probe 1 | 0x0191
IDN 402 | (S-0-0402) | Probe 2 | 0x0192
IDN 403 | (S-0-0403) | Position Feedback Status | 0x0193
IDN 405 | (S-0-0405) | Probe 1 Enable | 0x0195
IDN 406 | (S-0-0406) | Probe 2 Enable | 0x0196
IDN 409 | (S-0-0409) | Probe 1 Positive Edge Latched Status | 0x0199
IDN 410 | (S-0-0410) | Probe 1 Negative Edge Latched Status | 0x019A
IDN 411 | (S-0-0411) | Probe 2 Positive Edge Latched Status | 0x019B
IDN 412 | (S-0-0412) | Probe 2 Negative Edge Latched Status | 0x019C
IDN 3011 | (P-0-3011) | Encoder Emulation Mode | 0x8BC3
IDN 3027 | (P-0-3027) | Manufacturer Homing Modes | 0x8BD3

Accel / Decel Control

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 42 | (S-0-0042) | Homing Acceleration | 0x002A
IDN 136 | (S-0-0136) | Positive Acceleration Limit Value | 0x0088
IDN 137 | (S-0-0137) | Negative Acceleration Limit Value | 0x0089
IDN 160 | (S-0-0160) | Acceleration Data Scaling Type | 0x00A0
IDN 3022 | (P-0-3022) | Quick Deceleration Rate | 0x8BCE

Homing

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 41 | (S-0-0041) | Homing Velocity | 0x0029
IDN 42 | (S-0-0042) | Homing Acceleration | 0x002A
IDN 147 | (S-0-0147) | Homing Parameter | 0x0093
IDN 148 | (S-0-0148) | Procedure: Drive Controlled Homing | 0x0094
IDN 170 | (S-0-0170) | Procedure: Probing | 0x0AA
IDN 298 | (S-0-0298) | Home Switch Distance | 0x012A
IDN 400 | (S-0-0400) | Home Switch Status | 0x0190
IDN 403 | (S-0-0403) | Position Feedback Status | 0x0193
IDN 3000 | (P-0-3000) | Configurable I/O: Digital Input 1 Mode | 0x8BB8
IDN 3027 | (P-0-3027) | Manufacturer Homing Modes | 0x8BD3


AX2000-B750 IDN By Function Overview II

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN By Function Overview II

Sorted overview of ident numbers necessary for dedicated drive features as for:

Motor Compatibility, Feedback Devices, Monitoring & Troubleshooting, Fault & Safety Detection, Configurable I/O, General Features and Systems Communication.

Motor Compatibility

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 109 | (S-0-0109) | Motor Peak Current | 0x006D
IDN 111 | (S-0-0111) | Motor Continuous Stall Current | 0x006F
IDN 113 | (S-0-0113) | Maximum Motor Speed | 0x0071

Feedback Devices

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 116 | (S-0-0116) | Resolution of Rotational Feedback 1 (Motor Feedback) | 0x0074
IDN 117 | (S-0-0117) | Resolution of Rotational Feedback 2 (External Feedback) | 0x0075
IDN 3010 | (P-0-3010) | Feedback Type | 0x8BC2

Monitoring & Troubleshooting

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 11 | (S-0-0011) | Class 1 Diagnostic (C1D) | 0x000B
IDN 12 | (S-0-0012) | Class 2 Diagnostic (C2D) | 0x000C
IDN 13 | (S-0-0013) | Class 3 Diagnostic (C3D) | 0x000D
IDN 14 | (S-0-0014) | Interface Status | 0x000E
IDN 95 | (S-0-0095) | Diagnostic Message | 0x005F
IDN 96 | (S-0-0096) | Slave Arrangement | 0x0060
IDN 97 | (S-0-0097) | Class 2 Diagnostic Mask | 0x0061
IDN 98 | (S-0-0098) | Class 3 Diagnostic Mask | 0x0062
IDN 99 | (S-0-0099) | Procedure: Reset Class 1 Diagnostic | 0x0063
IDN 129 | (S-0-0129) | Manufacturer Class 1 Diagnostic (MC1D) | 0x0081
IDN 186 | (S-0-0186) | Maximum Length of MDT Configurable Data | 0x00BA
IDN 271 | (S-0-0271) | Drive ID | 0x010F
IDN 304 | (S-0-0304) | Real-Time Status Bit 1 | 0x0130
IDN 305 | (S-0-0305) | Allocation of Real-time Status Bit 1 | 0x0131
IDN 306 | (S-0-0306) | Real-Time Status Bit 2 | 0x0132
IDN 307 | (S-0-0307) | Allocation of Real-time Status Bit 2 | 0x0133

Fault & Safety Detection

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 91 | (S-0-0091) | Bipolar Velocity Limit | 0x005B
IDN 92 | (S-0-0092) | Bipolar Torque Limit | 0x005C
IDN 95 | (S-0-0095) | Diagnostic Message | 0x005F
IDN 99 | (S-0-0099) | Procedure: Reset Class 1 Diagnostic | 0x0063
IDN 114 | (S-0-0114) | System Load Limit | 0x0072
IDN 129 | (S-0-0129) | Manufacturer Class 1 Diagnostic (MC1D) | 0x0081
IDN 159 | (S-0-0159) | Monitoring Window | 0x009F
IDN 3020 | (P-0-3020) | System Rated Current | 0x8BCC
IDN 3021 | (P-0-3021) | Over Speed | 0x8BCD

Configurable I/O

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 400 | (S-0-0400) | Home Switch Status | 0x0190
IDN 3000 | (P-0-3000) | Configurable I/O: Digital Input 1 Mode | 0x8BB8
IDN 3001 | (P-0-3001) | Configurable I/O: Digital Input 2 Mode | 0x8BB9
IDN 3002 | (P-0-3002) | Configurable I/O: Digital Input 3 Mode | 0x8BBA
IDN 3003 | (P-0-3003) | Configurable I/O: Digital Input 4 Mode | 0x8BB8
IDN 3004 | (P-0-3004) | Position Switch Configuration | 0x8BBC
IDN 3005 | (P-0-3005) | Configurable I/O: Digital Output 1 Mode | 0x8BBD
IDN 3006 | (P-0-3006) | Configurable I/O: Digital Output 2 Mode | 0x8BBE
IDN 3030 | (P-0-3030) | Configurable I/O: Digital Input 1 Status | 0x8BD6
IDN 3031 | (P-0-3031) | Configurable I/O: Digital Input 2 Status | 0x8BD7
IDN 3032 | (P-0-3032) | Configurable I/O: Digital Input 3 Status | 0x8BD8
IDN 3033 | (P-0-3033) | Configurable I/O: Digital Input 4 Status | 0x8BD9
IDN 3034 | (P-0-3034) | Analog Input 1 Value | 0x8BDA
IDN 3035 | (P-0-3035) | Analog Input 2 Value | 0x8BDB
IDN 3036 | (P-0-3036) | Configurable I/O: Digital Output 1 Control/Status | 0x8BDC
IDN 3037 | (P-0-3037) | Configurable I/O: Digital Output 2 Control/Status | 0x8BDD

General Features

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 30 | (S-0-0030) | Manufacturer Version | 0x001E
IDN 142 | (S-0-0142) | Application Type | 0x008E
IDN 192 | (S-0-0192) | IDN List of Back-up Operation Data | 0x00C0
IDN 262 | (S-0-0262) | Procedure: Load Default Values | 0x0106
IDN 264 | (S-0-0264) | Procedure: Back-up Working Memory | 0x0108
IDN 288 | (S-0-0288) | IDN List of Data Programmable in CP2 | 0x0120
IDN 289 | (S-0-0289) | IDN List of Data Programmable in CP3 | 0x0121

Systems Communication

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 2 | (S-0-0002) | Communication Cycle Time | 0x0002
IDN 3 | (S-0-0003) | Shortest AT Transmission Starting Time | 0x0003
IDN 4 | (S-0-0004) | Transmit/Receive Transition Time | 0x0004
IDN 5 | (S-0-0005) | Minimum Feedback Processing Time | 0x0005
IDN 6 | (S-0-0006) | AT Transmission Starting Time (T1) | 0x0006
IDN 7 | (S-0-0007) | Feedback Acquisition Capture Point | 0x0007
IDN 8 | (S-0-0008) | Command Value Valid Time | 0x0008
IDN 9 | (S-0-0009) | Position of Data Record in MDT | 0x0009
IDN 10 | (S-0-0010) | Length of MDT | 0x000A
IDN 15 | (S-0-0015) | Telegram Type Parameter | 0x000F
IDN 16 | (S-0-0016) | Configuration List of AT Cyclic Data | 0x0010
IDN 17 | (S-0-0017) | IDN List of All Operation Data | 0x0011
IDN 18 | (S-0-0018) | IDN List of Operation Data for CP2. | 0x0012
IDN 19 | (S-0-0019) | IDN List of Operation Data for CP3. | 0x0013
IDN 21 | (S-0-0021) | IDN List of Invalid Operation Data for CP2. | 0x0015
IDN 22 | (S-0-0022) | IDN List of Invalid Operation Data for CP3. | 0x0016
IDN 24 | (S-0-0024) | Configuration List of MDT Cyclic Data | 0x0018
IDN 25 | (S-0-0025) | IDN List of All Procedure Commands | 0x0019
IDN 28 | (S-0-0028) | MST Error Counter | 0x001C
IDN 29 | (S-0-0029) | MDT Error Counter | 0x001D
IDN 88 | (S-0-0088) | Receive to Receive Recovery Time | 0x0058
IDN 89 | (S-0-0089) | MDT Transmission Starting Time | 0x0059
IDN 90 | (S-0-0090) | Command Value Processing Time | 0x005A
IDN 96 | (S-0-0096) | Slave Arrangement | 0x0060
IDN 97 | (S-0-0097) | Class 2 Diagnostic Mask | 0x0061
IDN 98 | (S-0-0098) | Class 3 Diagnostic Mask | 0x0062
IDN 127 | (S-0-0127) | Procedure: Communication Phase 3 Transition Check | 0x007F
IDN 128 | (S-0-0128) | Procedure: Communication Phase 4 Transition Check | 0x0080
IDN 134 | (S-0-0134) | Master Control Word | 0x0086
IDN 135 | (S-0-0135) | Drive Status Word | 0x0087
IDN 143 | (S-0-0143) | SYSTEM Interface Version | 0x008F
IDN 185 | (S-0-0185) | Maximum Length of AT Configurable Data | 0x00B9
IDN 186 | (S-0-0186) | Maximum Length of MDT Configurable Data | 0x00BA
IDN 187 | (S-0-0187) | List of AT Configurable Data IDNs | 0x00BB
IDN 188 | (S-0-0188) | List of MDT Configurable Data IDNs | 0x00BC
IDN 304 | (S-0-0304) | Real-Time Status Bit 1 | 0x0130
IDN 305 | (S-0-0305) | Allocation of Real-time Status Bit 1 | 0x0131
IDN 306 | (S-0-0306) | Real-Time Status Bit 2 | 0x0132
IDN 307 | (S-0-0307) | Allocation of Real-time Status Bit 2 | 0x0133
IDN 3026 | (P-0-3026) | Non-Volatile Memory Data Checksum | 0x8BD2


AX2000-B750 General Information

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

General Information

AX2000-B750 Configuration

Configure the address, baud rate and optical power on the drive to operate properly with the SERCOS master. These values can be adjusted through a terminal emulator program such as Microsoft Windows® HyperTerminal (Start | Run ... type hypertrm.exe) by the use of the following commands.

  1. Change the desired parameters by using the commands ADDR, SBAUD and SLEN, as explained below.
  2. Type save to save the new values.
  3. Type coldstart to reset the amplifier.

Changing the Drive Address

In the terminal program, use the command ADDR #, where '#' is the new drive address. The SERCOS address can also be changed via key operation on the front panel of the AX2000-B750. (Please refer to the “Digital Servo Amplifier AX2000” manual, e.g. available from http://www.beckhoff.com/english/download/drives.htm). The drive address can be set between 0 and 63. An address of zero designates the drive as a repeater on the SERCOS ring.

Changing the Baud Rate and Optical Power

In the terminal program, change the SERCOS baud rate by using the command "SBAUD 2" for a baud rate of 2 MBaud or "SBAUD 4" for a baud rate of 4 MBaud. The default is 4 MBaud. Change the optical power by using the command SLEN #, where # is the length of plastic optical cable, in meters, from 1 to 45 meters. The default is 5 meters. This parameter can be used to set the optical range (in meters) for a standardized 1mm² plastic optical fiber cable (e.g. BECKHOFF part number "Z1101") Also new is the command SLEN 0 for very short lengths.

SLEN |
0 | very short connection
1…< 15 | Length of the connection of a 1mm plastic cable (e.g. BECKHOFF Z1101)
15…<30 | "
>= 30 | "

The baud rate and the optical power can also be changed via the so-called Drive software. Please refer to the user’s manual “Inbetriebnahme-Software SR600 für AX2000".
If the optical power is not adjusted properly, there will be errors in the telegram transmission, and the red error LED on the drive will light. In normal communication, the green transmit and receive LEDs will blink rapidly, causing the LEDs to appear faintly lit.

MDT CONTROL BITS 13 - 15

The following table gives a detailed description of the operation of the drive in regard to bits 13, 14 and 15 of the MDT Control Word. Please note that the three bits are ordered in the table according to priority.

Enable Drive | Drive On/Off | Halt/Restart | Description
14 | 15 | 13
0 | x | x | When the “Enable Drive” bit changes from 1 to 0, the power stage is disabled and the motor coasts to a stop.
1 | 0 | x | When the “Drive On/Off” bit changes from 1 to 0, the drive decelerates at the quick deceleration rate (P-0-3022). The power stage is disabled when the internal velocity command is zero and the velocity feedback is below 5 RPM.
1 | 1 | 0 | When the “Enable Drive” bit and the “Drive On/Off” bits are set, the power stage is enabled. When the “Halt/Restart” bit changes from 1 to 0, the drive decelerates at the acceleration limit value defined by S-0-0137 or S-0-0042.
1 | 1 | 1 | When the “Halt/Restart” bit changes from 0 to 1, the drive follows the master’s command values. In velocity mode, accelerations are limited by IDN 136 or IDN 137, and the velocity command is limited by S-0-0038, S-0-0039 or S-0-0091. In position mode, the drive monitors the position command and sets a fault if successive position commands exceed the velocity limit (S-0-0038, S-0-0039 or S-0-0091). In position mode, it is the master’s responsibility to limit successive position commands in order to maintain the desired acceleration and velocity limits.


IDN Set Supported by AX2000-B750

Ident Number | Sercos Parameter | Description | ADS IndexGroup (hex.)
IDN 1 | (S-0-0001) | Control unit Cycle time (t Ncyc) | 0x0001
IDN 2 | (S-0-0002) | Communication Cycle Time | 0x0002
IDN 3 | (S-0-0003) | Shortest AT Transmission Starting Time | 0x0003
IDN 4 | (S-0-0004) | Transmit/Receive Transition Time | 0x0004
IDN 5 | (S-0-0005) | Minimum Feedback Processing Time | 0x0005
IDN 6 | (S-0-0006) | AT Transmission Starting Time (T1) | 0x0006
IDN 7 | (S-0-0007) | Feedback Acquisition Capture Point | 0x0007
IDN 8 | (S-0-0008) | Command Value Valid Time | 0x0008
IDN 9 | (S-0-0009) | Position of Data Record in MDT | 0x0009
IDN 10 | (S-0-0010) | Length of MDT | 0x000A
IDN 11 | (S-0-0011) | Class 1 Diagnostic (C1D) | 0x000B
IDN 12 | (S-0-0012) | Class 2 Diagnostic (C2D) | 0x000C
IDN 13 | (S-0-0013) | Class 3 Diagnostic (C3D) | 0x000D
IDN 14 | (S-0-0014) | Interface Status | 0x000E
IDN 15 | (S-0-0015) | Telegram Type Parameter | 0x000F
IDN 16 | (S-0-0016) | Configuration List of AT Cyclic Data | 0x0010
IDN 17 | (S-0-0017) | IDN List of All Operation Data | 0x0011
IDN 18 | (S-0-0018) | IDN List of Operation Data for CP2. | 0x0012
IDN 19 | (S-0-0019) | IDN List of Operation Data for CP3. | 0x0013
IDN 21 | (S-0-0021) | IDN List of Invalid Operation Data for CP2. | 0x0015
IDN 22 | (S-0-0022) | IDN List of Invalid Operation Data for CP3. | 0x0016
IDN 24 | (S-0-0024) | Configuration List of MDT Cyclic Data | 0x0018
IDN 25 | (S-0-0025) | IDN List of All Procedure Commands | 0x0019
IDN 28 | (S-0-0028) | MST Error Counter | 0x001C
IDN 29 | (S-0-0029) | MDT Error Counter | 0x001D
IDN 30 | (S-0-0030) | Manufacturer Version | 0x001E
IDN 32 | (S-0-0032) | Primary Operation Mode | 0x0020
IDN 33 | (S-0-0033) | Secondary Operation Mode 1 | 0x0021
IDN 36 | (S-0-0036) | Velocity Command Value | 0x0024
IDN 38 | (S-0-0038) | Positive Velocity Limit Value | 0x0026
IDN 39 | (S-0-0039) | Negative Velocity Limit Value | 0x0027
IDN 40 | (S-0-0040) | Velocity Feedback Value | 0x0028
IDN 41 | (S-0-0041) | Homing Velocity | 0x0029
IDN 42 | (S-0-0042) | Homing Acceleration | 0x002A
IDN 43 | (S-0-0043) | Velocity Polarity Parameter | 0x002B
IDN 44 | (S-0-0044) | Velocity Data Scaling Type | 0x002C
IDN 45 | (S-0-0045) | Velocity Data Scaling Factor | 0x002D
IDN 46 | (S-0-0046) | Velocity Data Scaling Exponent | 0x002E
IDN 47 | (S-0-0047) | Position Command Value | 0x002F
IDN 49 | (S-0-0049) | Positive Position Limit Switch | 0x0031
IDN 50 | (S-0-0050) | Negative Position Limit Switch | 0x0032
IDN 51 | (S-0-0051) | Position Feedback Value 1 (Motor Feedback) | 0x0033
IDN 52 | (S-0-0052) | Reference Distance 1 | 0x0034
IDN 53 | (S-0-0053) | Position Feedback Value 2 (External Feedback) | 0x0035
IDN 54 | (S-0-0054) | Reference Distance 2 | 0x0036
IDN 55 | (S-0-0055) | Position Polarity Parameter | 0x0037
IDN 57 | (S-0-0057) | Position Window | 0x0039
IDN 59 | (S-0-0059) | Position Switch Flag Parameter | 0x003B
IDN 60 | (S-0-0060) | Position Switch Point 1 | 0x003C
IDN 61 | (S-0-0061) | Position Switch Point 2 | 0x003D
IDN 62 | (S-0-0062) | Position Switch Point 3 | 0x003E
IDN 63 | (S-0-0063) | Position Switch Point 4 | 0x003F
IDN 64 | (S-0-0064) | Position Switch Point 5 | 0x0040
IDN 65 | (S-0-0065) | Position Switch Point 6 | 0x0041
IDN 66 | (S-0-0066) | Position Switch Point 7 | 0x0042
IDN 67 | (S-0-0067) | Position Switch Point 8 | 0x0043
IDN 76 | (S-0-0076) | Position Data Scaling Type | 0x004C
IDN 77 | (S-0-0077) | Linear Position Data Scaling Factor | 0x004D
IDN 78 | (S-0-0078) | Linear Position Data Scaling Exponent | 0x004E
IDN 79 | (S-0-0079) | Rotational Position Resolution | 0x004F
IDN 80 | (S-0-0080) | Torque Command Value | 0x0050
IDN 84 | (S-0-0084) | Torque Feedback Value | 0x0054
IDN 86 | (S-0-0086) | Torque/Force Data Scaling Type | 0x0056
IDN 88 | (S-0-0088) | Receive to Receive Recovery Time | 0x0058
IDN 89 | (S-0-0089) | MDT Transmission Starting Time | 0x0059
IDN 90 | (S-0-0090) | Command Value Processing Time | 0x005A
IDN 91 | (S-0-0091) | Bipolar Velocity Limit | 0x005B
IDN 92 | (S-0-0092) | Bipolar Torque Limit | 0x005C
IDN 95 | (S-0-0095) | Diagnostic Message | 0x005F
IDN 96 | (S-0-0096) | Slave Arrangement | 0x0060
IDN 97 | (S-0-0097) | Class 2 Diagnostic Mask | 0x0061
IDN 98 | (S-0-0098) | Class 3 Diagnostic Mask | 0x0062
IDN 99 | (S-0-0099) | Procedure: Reset Class 1 Diagnostic | 0x0063
IDN 100 | (S-0-0100) | Velocity Loop Proportional Gain | 0x0064
IDN 101 | (S-0-0101) | Velocity Loop Integral Action Time | 0x0065
IDN 103 | (S-0-0103) | Modulo Value | 0x0067
IDN 104 | (S-0-0104) | Position Loop Proportional Gain | 0x0068
IDN 105 | (S-0-0105) | Position Loop Integral Action Time | 0x0069
IDN 106 | (S-0-0106) | Current Loop Proportional Gain 1 | 0x006A
IDN 107 | (S-0-0107) | Current Loop Integral Action Time 1 | 0x006B
IDN 108 | (S-0-0108) | Feedrate Override | 0x006C
IDN 109 | (S-0-0109) | Motor Peak Current | 0x006D
IDN 110 | (S-0-0110) | Amplifier Peak Current | 0x006E
IDN 111 | (S-0-0111) | Motor Continuous Stall Current | 0x006F
IDN 112 | (S-0-0112) | Amplifier Rated Current | 0x0070
IDN 113 | (S-0-0113) | Maximum Motor Speed | 0x0071
IDN 114 | (S-0-0114) | System Load Limit | 0x0072
IDN 116 | (S-0-0116) | Resolution of Rotational Feedback 1 (Motor Feedback) | 0x0074
IDN 117 | (S-0-0117) | Resolution of Rotational Feedback 2 (External Feedback) | 0x0075
IDN 119 | (S-0-0119) | Current Loop Proportional Gain 2 | 0x0077
IDN 120 | (S-0-0120) | Current Loop Integral Action Time 2 | 0x0078
IDN 121 | (S-0-0121) | Input revolutions of load gear | 0x0079
IDN 122 | (S-0-0122) | Output revolutions of load gear | 0x007A
IDN 123 | (S-0-0123) | Feed Constant | 0x007B
IDN 127 | (S-0-0127) | Procedure: Communication Phase 3 Transition Check | 0x007F
IDN 128 | (S-0-0128) | Procedure: Communication Phase 4 Transition Check | 0x0080
IDN 129 | (S-0-0129) | Manufacturer Class 1 Diagnostic (MC1D) | 0x0081
IDN 130 | (S-0-0130) | Probe 1 Positive Edge Value | 0x0082
IDN 131 | (S-0-0131) | Probe 1 Negative Edge Value | 0x0083
IDN 132 | (S-0-0132) | Probe 2 Positive Edge Value | 0x0084
IDN 133 | (S-0-0133) | Probe 2 Negative Edge Value | 0x0085
IDN 134 | (S-0-0134) | Master Control Word | 0x0086
IDN 135 | (S-0-0135) | Drive Status Word | 0x0087
IDN 136 | (S-0-0136) | Positive Acceleration Limit Value | 0x0088
IDN 137 | (S-0-0137) | Negative Acceleration Limit Value | 0x0089
IDN 140 | (S-0-0140) | (S-0-0140) | 0x008C
IDN 141 | (S-0-0141) | Motor Type | 0x008D
IDN 142 | (S-0-0142) | Application Type | 0x008E
IDN 143 | (S-0-0143) | SYSTEM Interface Version | 0x008F
IDN 147 | (S-0-0147) | Homing Parameter | 0x0093
IDN 148 | (S-0-0148) | Procedure: Drive Controlled Homing | 0x0094
IDN 159 | (S-0-0159) | Monitoring Window | 0x009F
IDN 160 | (S-0-0160) | Acceleration Data Scaling Type | 0x00A0
IDN 161 | (S-0-0161) | Acceleration Data Scaling Factor | 0x00A1
IDN 162 | (S-0-0162) | Acceleration Data Scaling Exponent | 0x00A2
IDN 169 | (S-0-0169) | Probe Control Parameter | 0x00A9
IDN 170 | (S-0-0170) | Procedure: Probing | 0x00AA
IDN 179 | (S-0-0179) | Probe Position Latch Status | 0x00B3
IDN 182 | (S-0-0182) | Manufacturer Class 3 Diagnostic (MC3D) | 0x00B6
IDN 185 | (S-0-0185) | Maximum Length of AT Configurable Data | 0x00B9
IDN 186 | (S-0-0186) | Maximum Length of MDT Configurable Data | 0x00BA
IDN 187 | (S-0-0187) | List of AT Configurable Data IDNs | 0x00BB
IDN 188 | (S-0-0188) | List of MDT Configurable Data IDNs | 0x00BC
IDN 189 | (S-0-0189) | Following Distance | 0x00BD
IDN 192 | (S-0-0192) | IDN List of Back-up Operation Data | 0x00C0
IDN 196 | (S-0-0196) | Motor Rated Current | 0x00C4
IDN 203 | (S-0-0203) | Amplifier Shutdown Temperature | 0x00CB
IDN 205 | (S-0-0205) | Cooling Error Shutdown Temperature | 0x00CD
IDN 208 | (S-0-0208) | Temperature Data Scaling Type | 0x00D0
IDN 257 | (S-0-0257) | Multiplication Factor 2 | 0x0101
IDN 262 | (S-0-0262) | Procedure: Load Default Values | 0x0106
IDN 264 | (S-0-0264) | Procedure: Back-up Working Memory | 0x0108
IDN 271 | (S-0-0271) | Drive ID | 0x010F
IDN 288 | (S-0-0288) | IDN List of Data Programmable in CP2 | 0x0120
IDN 289 | (S-0-0289) | IDN List of Data Programmable in CP3 | 0x0121
IDN 296 | (S-0-0296) | Velocity Feed Forward Gain | 0x0128
IDN 298 | (S-0-0298) | Home Switch Distance | 0x012A
IDN 301 | (S-0-0301) | Allocation of Real-time Control Bit 1 | 0x012D
IDN 303 | (S-0-0303) | Allocation of Real-time Control Bit 2 | 0x012F
IDN 304 | (S-0-0304) | Real-Time Status Bit 1 | 0x0130
IDN 305 | (S-0-0305) | Allocation of Real-time Status Bit 1 | 0x0131
IDN 306 | (S-0-0306) | Real-Time Status Bit 2 | 0x0132
IDN 307 | (S-0-0307) | Allocation of Real-time Status Bit 2 | 0x0133
IDN 323 | (S-0-0323) | Status “Target position outside of travel range” | 0x0143
IDN 336 | (S-0-0336) | Status “In Position” | 0x0150
IDN 380 | (S-0-0380) | DC Bus Voltage | 0x017C
IDN 384 | (S-0-0384) | Amplifier Temperature | 0x0180
IDN 392 | (S-0-0392) | Velocity Feedback Filter Time Constant | 0x0188
IDN 400 | (S-0-0400) | Home Switch Status | 0x0190
IDN 401 | (S-0-0401) | Probe 1 | 0x0191
IDN 402 | (S-0-0402) | Probe 2 | 0x0192
IDN 403 | (S-0-0403) | Position Feedback Status | 0x0193
IDN 405 | (S-0-0405) | Probe 1 Enable | 0x0195
IDN 406 | (S-0-0406) | Probe 2 Enable | 0x0196
IDN 409 | (S-0-0409) | Probe 1 Positive Edge Latched Status | 0x0199
IDN 410 | (S-0-0410) | Probe 1 Negative Edge Latched Status | 0x019A
IDN 411 | (S-0-0411) | Probe 2 Positive Edge Latched Status | 0x019B
IDN 412 | (S-0-0412) | Probe 2 Negative Edge Latched Status | 0x019C
IDN 3000 | (P-0-3000) | Configurable I/O: Digital Input 1 Mode | 0x8BB8
IDN 3001 | (P-0-3001) | Configurable I/O: Digital Input 2 Mode | 0x8BB9
IDN 3002 | (P-0-3002) | Configurable I/O: Digital Input 3 Mode | 0x8BBA
IDN 3003 | (P-0-3003) | Configurable I/O: Digital Input 4 Mode | 0x8BBB
IDN 3004 | (P-0-3004) | Position Switch Configuration | 0x8BBC
IDN 3005 | (P-0-3005) | Configurable I/O: Digital Output 1 Mode | 0x8BBD
IDN 3006 | (P-0-3006) | Configurable I/O: Digital Output 2 Mode | 0x8BBE
IDN 3007 | (P-0-3007) | Configurable I/O: Digital Output 1 Trigger | 0x8BBF
IDN 3008 | (P-0-3008) | Configurable I/O: Digital Output 2 Trigger | 0x8BC0
IDN 3010 | (P-0-3010) | Feedback Type | 0x8BC2
IDN 3011 | (P-0-3011) | Encoder Emulation Mode | 0x8BC3
IDN 3012 | (P-0-3012) | Difference Probe Edge Value 1 | 0x8BC4
IDN 3013 | (P-0-3013) | Difference Probe Edge Value 2 | 0x8BC5
IDN 3014 | (P-0-3014) | Probe Difference Control Parameter | 0x8BC6
IDN 3015 | (P-0-3015) | Hardware Limit Switch Consequence | 0x8BC7
IDN 3016 | (P-0-3016) | Reset Command Consequence | 0x8BC8
IDN 3018 | (P-0-3018) | Configuration of the Positionlatch | 0x8BCA
IDN 3019 | (P-0-3019) | Select of the FPGA Program | 0x8BCB
IDN 3020 | (P-0-3020) | System Rated Current | 0x8BCC
IDN 3021 | (P-0-3021) | Over Speed | 0x8BCD
IDN 3022 | (P-0-3022) | Quick Deceleration Rate | 0x8BCE
IDN 3026 | (P-0-3026) | Non-Volatile Memory Data Checksum | 0x8BD2
IDN 3027 | (P-0-3027) | Manufacturer Homing Modes | 0x8BD3
IDN 3030 | (P-0-3030) | Configurable I/O: Digital Input 1 Status | 0x8BD6
IDN 3031 | (P-0-3031) | Configurable I/O: Digital Input 2 Status | 0x8BD7
IDN 3032 | (P-0-3032) | Configurable I/O: Digital Input 3 Status | 0x8BD8
IDN 3033 | (P-0-3033) | Configurable I/O: Digital Input 4 Status | 0x8BD9
IDN 3034 | (P-0-3034) | Analog Input 1 Value | 0x8BDA
IDN 3035 | (P-0-3035) | Analog Input 2 Value | 0x8BDB
IDN 3036 | (P-0-3036) | Configurable I/O: Digital Output 1 Control/Status | 0x8BDC
IDN 3037 | (P-0-3037) | Configurable I/O: Digital Output 2 Control/Status | 0x8BDD
IDN 3038 | (P-0-3038) | Probe 1 and 2 Enable | 0x8BDE
IDN 3039 | (P-0-3039) | Probe 1 and 2 Control Parameter | 0x8BDF
IDN 3040 | (P-0-3040) | Interpolation Method | 0x8BE0
IDN 3041 | (P-0-3041) | Position Switch On/Off Parameter | 0x8BE1
IDN 3042 | (P-0-3042) | Position Switch Enable/Disable Parameter | 0x8BE2
IDN 3043 | (P-0-3043) | Position Switch Polarity Parameter | 0x8BE3
IDN 3044 | (P-0-3044) | Kind Of Position Switch Parameter | 0x8BE4
IDN 3045 | (P-0- 3045) | (P-0- 3045) | 0x8BE5
IDN 3046 | (P-0- 3046) | Motor Number | 0x8BE6


BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 1 (S-0-0001) Control unit Cycle time (t Ncyc)


IDN 2 (S-0-0002) Communication Cycle Time

The period at which MST, AT, and MDT telegrams are transmitted. The “Communication Cycle Time” (CCT) may be varied from 1 ms to 8 ms, in 1 ms increments. Linear interpolator is applied to the command every 250 (s when the CCT is 1, 2, 3 or 4 ms. For the interpolation method please refer to IDN 3040

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 1000 | Run-Up Check: | CP2
Maximum: | 8000 | Cyclic Transfer: |
Default: | 2000 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0002


IDN 3 (S-0-0003) Shortest AT Transmission Starting Time

The time required by the drive between the end of the MST and the beginning of the drive's AT.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 40 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0003


IDN 4 (S-0-0004) Transmit/Receive Transition Time

The time required by the drive between the end of the AT and the beginning of the next MDT.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 40 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0004


IDN 5 (S-0-0005) Minimum Feedback Processing Time

The time required by the drive for receiving and processing cyclic feedback. This time period is measured from the beginning of the feedback acquisition to the end of the next MST.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 200 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0005


IDN 6 (S-0-0006) AT Transmission Starting Time (T1)

The time at which the drive should transmit its AT during CP3 and CP4, measured from the end of the MST. The “AT Transmission Starting Time” must be downloaded from the master during CP2. IDN 6 is limited by the “Shortest AT Transmission Starting Time” ( IDN 3 ), the “MDT Transmission Starting Time” ( IDN 89 ) and the “Transmit/Receive Transition Time” ( IDN 4 ), according to the following equation:

IDN 3 < IDN 6 < IDN 89 – IDN 4

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | None | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0006


IDN 7 (S-0-0007) Feedback Acquisition Capture Point

The time at which the drive should latch the feedback values after the end of the MST. The “Feedback Acquisition Capture Point” is limited by the CCT ( IDN 2 ) and the “Minimum Feedback Processing Time” ( IDN 5 ) according to the following equation.

IDN 7 ( IDN 2 – IDN 5

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | IDN 2 – IDN 5 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0007


IDN 8 (S-0-0008) Command Value Valid Time

The time at which the drive is allowed to access the new command values after the MST. The “Command Value Valid Time” is limited by the “MDT Transmission Starting Time” ( IDN 89 ), the “Command Value Processing Time” ( IDN 90 ) and the CCT ( IDN 2 ) according to the following equation.

IDN 89 + MDT Transmission Time + IDN 90 < IDN 8 ( IDN 2

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | IDN 2 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0008


IDN 9 (S-0-0009) Position of Data Record in MDT

The offset of the drive's data record within the MDT. The offset is measured in bytes from the MDT's address field. The data record position within the MDT must be downloaded from the master during CP2 and becomes active during CP3. The value must be greater than zero and must be an odd number not exceeding 65531.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | None | Serial Equiv: |
Units: | Bytes | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0009


IDN 10 (S-0-0010) Length of MDT

The length of the MDT's data field, expressed in bytes. This length does not include the MDT delimiters, address field, or cyclic redundancy check (CRC). The MDT length must be downloaded from the master during CP2 and becomes active during CP3. The MDT length must be an even number, and it must be greater than or equal to 4, but not exceeding 65534.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | None | Serial Equiv: |
Units: | Bytes | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x000A


IDN 11 (S-0-0011) Class 1 Diagnostic (C1D)

The current fault status of the drive. When a fault occurs, the drive decelerates to a stop and is disabled. The C1D status bit (AT bit 13) is set, and the corresponding fault bits are set within IDN 11. All faults are latched within IDN 11 and are reset through the “Procedure: Reset Class 1 Diagnostic” ( IDN 99 ). IDN 99 performs a cold start automatically when required. Those faults which require a cold start are noted in the table below. The error messages which appear on the front panel of the drive are also shown below.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ERRCODE
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x000B
Definition:
Bit | Description | Coldstart | LED Error
LSB 0 | Overload fault ( IDN 114 ). | no | F15
1 | Amplifier over temperature fault ( IDN 203 ). | no | F01
2 | Motor over temperature fault. | yes | F06
3 | Cooling system fault ( IDN 205 ). | no | F13
4 | Control voltage fault ((15V). | yes | F07
5 | Feedback loss fault. | yes | F04
6 | Commutation fault. Set to 0. | yes | F25
7 | Over current fault. | yes | F14
8 | Over voltage fault. | no | F02
9 | Under voltage fault. | no | F05
10 | Power supply phase fault. | no | F12, F19
11 | Excessive position deviation ( IDN 159 ). | no | F03
12 | Communication interface fault ( IDN 14 ). | no | F29
13 | Software limit switch fault ( IDN 49 and 50). | no | F24
14 | Reserved. Set to 0. |  |
MSB 15 | Manufacturer defined fault ( IDN 129 ). | IDN 129 |


IDN 12 (S-0-0012) Class 2 Diagnostic (C2D)

Warning flags that may indicate an impending shutdown. When an unmasked warning condition changes state , the corresponding warning bits are changed within IDN 12, and the C2D change bit (AT status word, bit 12) is set. The warning bits within IDN 12 are not latched and will automatically reset when the warning condition is no longer valid. The C2D change bit is reset when IDN 12 is read through the service channel. IDN 97 may be used to mask warnings and their affect on the C2D change bit.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x000C
Definition:
Bit | Description
LSB 0 | Overload warning ( IDN 114 and 310).
1 | Reserved: Amplifier over temperature warning.
2 | Reserved: Motor over temperature warning ( IDN 312 ).
3 | Reserved: Cooling system warning (set to 0).
4 | Reserved.
5 | Reserved: Positioning velocity ( n Limit ( IDN 315 ).
6 | Reserved.
7 | Reserved.
8 | Reserved.
9 | Reserved.
10 | Reserved.
11 | Reserved.
12 | Reserved.
13 | Target position outside of travel range ( IDN 323 ).
14 | Reserved.
MSB 15 | Reserved: Manufacturer defined warning flags ( IDN 181 ).


IDN 13 (S-0-0013) Class 3 Diagnostic (C3D)

Status flags for the drive. When an unmasked status condition changes state, the corresponding status bit changes within IDN 13, and the C3D change bit (AT status word, bit 11) is set. The status bits within IDN 13 are not latched and will automatically reset when the status condition is no longer valid. The C3D change bit is reset when IDN 13 is read through the service channel. IDN 98 may be used to mask particular status conditions and their affect on the C3D change bit.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x000D
Definition:
Bit | Description
LSB 0 | Reserved: Nfdbk = Ncmd ( IDN 330 ).
1 | Reserved: Nfdbk = 0 ( IDN 124 and IDN 331 ).
2 | Reserved: |Nfdbk| < |N threshold| ( IDN 332 ).
3 | Reserved: |Torque| ( |Torque threshold| ( IDN 333 ).
4 | Reserved: |Torque| ( |Torque limit| ( IDN 334 ).
5 | Reserved: |Ncmd| > |N limit| ( IDN 335 ).
6 | In Position ( IDN 57 and IDN 336 ).
7 | Reserved: |Power| ( |Power threshold| ( IDN 337 ).
8 | Reserved.
9 | Reserved: |Nfdbk| ( Min spindle speed ( IDN 339 ).
10 | Reserved: |Nfdbk| ( Max spindle speed ( IDN 340 ).
11 | Reserved: In Coarse Position ( IDN 341 ).
12 | Reserved: Target Position Attained ( IDN 342 )
13 | Reserved: Interpolator Halted ( IDN 343 ).
14 | Reserved.
MSB 15 | Manufacturer defined status flags ( IDN 182 ).


IDN 14 (S-0-0014) Interface Status

The communication phase (CPx) and communication fault flags. In the event of a communication fault the drive decelerates to a stop and is disabled, and the drive's communication phase returns to 0. The communication interface fault summary bit ( IDN 11 , bit 12) is set. The cause of the communication fault is latched within IDN 14 along with the communication phase in which the fault occurred. The master may retrieve this information from the drive by reading IDN 14 before issuing a “Reset Class 1 Diagnostic” procedure ( IDN 99 ).

If both bit 3 and bit 4 (MST and MDT failures) are set, this could indicate a signal loss (e.g. a broken optical fiber cable). In this case, the MST and MDT error counters ( IDN 28 and IDN 29 ) will not be incremented.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x000E
Definition:
Bit | Description
2 – 0 | Communication Phase (CPx).
3 | MST failure.
4 | MDT failure.
5 | Invalid phase (CP > 4)
6 | Error during phase advance.
7 | Error during phase regression.
8 | Reserved: Phase switch without proper acknowledgment.
9 | Switching to an uninitialized operation mode.
10 | Reserved: Duplicate drive addresses.
11 - 15 | Reserved.


IDN 15 (S-0-0015) Telegram Type Parameter

The master uses IDN 15 to select the contents of the AT and MDT cyclic data fields. Selecting a pre-defined or standard telegram type completely defines the contents and order of cyclic data within the AT and MDT. Within IDN 15, the ServoSTAR 600 supports values 1 through 7 (indicated in bold-face type in the table below). Telegram type 7, or the application type telegram, allows the master to define the contents and order of the AT and MDT cyclic data. The IDNs that may be transferred as cyclic data within the AT and MDT are listed in IDN 187 and IDN 188 respectively. The maximum amount of AT and MDT cyclic data that the drive can transfer is specified in IDN 185 and IDN 186 respectively. When the application telegram is selected, the master writes the desired cyclic data IDNs for the AT into IDN 16 and for the MDT into IDN 24 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | 4 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x000F
Definition:
IDN 15 Value | Telegram Type | Telegram Cyclic Data
 |  | MDT (Commands) | AT (Feedback)
0 | Standard telegram 0 | Reserved: None | Reserved: None
1 | Standard telegram 1 | Torque ( IDN 80 ) | None
2 | Standard telegram 2 | Velocity ( IDN 36 ) | Velocity ( IDN 40 )
3 | Standard telegram 3 | Velocity ( IDN 36 ) | Motor Position ( IDN 51 )
 |  |  | External Position ( IDN 53 )
4 | Standard telegram 4 | Position ( IDN 47 ) | Motor Position ( IDN 51 )
 |  |  | External Position ( IDN 53 )
5 | Standard telegram 5 | Pos/Vel ( IDN 47 /36) | Motor Pos/Vel ( IDN 51 /40)
13 |  |  | External Pos/Vel ( IDN 53 /40)
6 | Standard telegram 6 | Velocity ( IDN 36 ) | None
7 | Application telegram | Contents defined in IDN 24 | Contents defined in IDN 16


IDN 16 (S-0-0016) Configuration List of AT Cyclic Data

An IDN list of the AT's cyclic data. The master fills this list with IDNs in CP2 selected from a list of configurable AT data ( IDN 187 ) when an application telegram has been selected through IDN 15 .

Data Length: | 2 byte elements, variable length array | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | Empty list. | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0010


IDN 17 (S-0-0017) IDN List of All Operation Data

An IDN list of all data IDNs that are supported by the drive.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0011


IDN 18 (S-0-0018) IDN List of Operation Data for CP2.

An IDN list of all data that must be written by the master during CP2. The drive's CP2 to CP3 transition procedure ( IDN 127 ) will fail if this data is not supplied by the master. IDN 16 and IDN 24 are not included in this list, but they need to be written by the master in CP2 if the application telegram (type 7) is selected. If IDN 16 and IDN 24 are not written during CP2, then the application telegram will be empty.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0012


IDN 19 (S-0-0019) IDN List of Operation Data for CP3.

An IDN list of all data that must be written by the master during CP3. The drive's CP3 to CP4 transition procedure ( IDN 128 ) will fail if this data is not supplied by the master.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0013


IDN 21 (S-0-0021) IDN List of Invalid Operation Data for CP2.

A list of all IDNs which are considered invalid by the CP2 to CP3 transition procedure ( IDN 127 ).

Data Length: | 2 byte elements, variable length array | Non-Volatile: | No
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | Empty list. | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0015


IDN 22 (S-0-0022) IDN List of Invalid Operation Data for CP3.

A list of all IDNs which are considered invalid by the CP3 to CP4 transition procedure ( IDN 128 ).

Data Length: | 2 byte elements, variable length array | Non-Volatile: | No
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | Empty list. | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0016


IDN 24 (S-0-0024) Configuration List of MDT Cyclic Data

An IDN list of the MDT's cyclic data. The master fills this list with IDNs selected from a list of configurable MDT data ( IDN 188 ) when an application telegram has been selected through IDN 15 .

Data Length: | 2 byte elements, variable length array | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | Empty list. | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0018


IDN 25 (S-0-0025) IDN List of All Procedure Commands

An IDN list of all procedure IDNs that are supported by the drive.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0019


IDN 28 (S-0-0028) MST Error Counter

A count of all invalid MSTs in CP3 and CP4. In the case where more than two consecutive MST’s are invalid, only two are counted, and the drive returns to CP0. The MST error counter counts to a maximum of 65535 and does not roll over to 0. If a value of 65535 is in the counter, there may have been a noisy transmission over a long period of time. The MST error counter is cleared on the transition from CP2 to CP3.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x001C


IDN 29 (S-0-0029) MDT Error Counter

A count of all invalid MDTs in CP4. In the case where more than two consecutive MDTs are invalid, only two are counted, and the drive returns to CP0. The MDT error counter counts to a maximum of 65535 and does not roll over to 0. If a value of 65535 is in the counter, there may have been a noisy transmission over a long period of time. The MDT error counter is cleared on the transition from CP2 to CP3.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x001D


IDN 30 (S-0-0030) Manufacturer Version

A text string of the SERCOS firmware version.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | VER *
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x001E


IDN 32 (S-0-0032) Primary Operation Mode

Defines the drive's operational mode when the AT status word bits 8 and 9 are both 0. The master requests a particular operation mode through the MDT control word (bits 8 and 9). The master can switch between the operation modes defined within this IDN and the mode defined within the secondary operation mode 1 ( IDN 33 ) with this bits in realtime. Switch into position control during fast moving, could result a jerk. The following table may be used to define the primary operation mode. All reserved bits are not supported and must be zero. When the drive powers-up the operational mode is undefined, and the master must define a primary operational mode in CP3. The gain for bit 3 is defined by IDN 296 , Velocity Feed Forward Gain. It is not possible to select position control with motor feedback in IDN 32 and position control using external feedback in IDN 33 , also the reverse setting of this IDNs is not possible and will be checked by the drive (refer to IDN 117 ). For position control with external feedback 2, all position data, e.g. also IDN 51 , are used for the external feedback.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: | CP3
Maximum: |  | Cyclic Transfer: |
Default: | 3 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS:VE:CT | ADS Index Group (hex.): | 0x0020
Definition:
Bit | Value | Description
3 – 0 | 0000 | Reserved: No mode of operation.
 | 0001 | Torque control
 | 0010 | Velocity control
 | x011 | Position control using motor feedback.
 | x100 | Position control using external feedback.
 | x101 | Reserved: Position control using motor and external feedback.
3 | 0 | Position control with following error.
 | 1 | Position control without following error ( IDN 296 ).
4 – 13 | 0 | Reserved.
14 | 0 | Command values are issued as cyclic data.
 | 1 | Reserved: Command values are issued through service channel.
15 | 0 | Bits 0-14 are as defined above.
 | 1 | Reserved: Bits 0-14 are defined by the manufacturer.


IDN 33 (S-0-0033) Secondary Operation Mode 1

Defines the drive's operational mode when the AT status word bit 9 is clear and bit 8 is set. The master requests a particular operation mode through the MDT control word (bits 8 and 9). The master can switch between the operation modes defined within this IDN and the mode defined within the primary operation mode ( IDN 32 ) with this bits in realtime. Switch into position control during fast moving, could result a jerk. The following table may be used to define the secondary operation mode 1. All reserved bits are not supported and must be zero. The gain for bit 3 is defined by IDN 296 , Velocity Feed Forward Gain. It is not possible to select position control with motor feedback in IDN 32 and position control using external feedback in IDN 33, also the reverse setting of this IDNs is not possible and will be checked by the drive (refer to IDN 117 ). For position control with external feedback 2, all position data, e.g. also IDN 51 , are used for the external feedback.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: | CP3
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS:VE:CT | ADS Index Group (hex.): | 0x0021
Definition:
Bit | Value | Description
3 - 0 | 0000 | No mode of operation.
 | 0001 | Torque control
 | 0010 | Velocity control
 | x011 | Position control using motor feedback.
 | x100 | Position control using external feedback.
 | x101 | Reserved: Position control using motor and external feedback.
3 | 0 | Position control with following error.
 | 1 | Position control without following error ( IDN 296 ).
4 - 13 | 0 | Reserved.
14 | 0 | Command values are issued as cyclic data.
 | 1 | Reserved: Command values are issued through service channel.
15 | 0 | Bits 0-14 are as defined above.
 | 1 | Reserved: Bits 0-14 are defined by the manufacturer.


IDN 36 (S-0-0036) Velocity Command Value

The master issues the velocity command to the drive through IDN 36. The velocity scaling type is fixed ( IDN 44 ), and the scaling parameters are adjustable ( IDN 45 and 46).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: |  | Serial Equiv: | J
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0024


IDN 38 (S-0-0038) Positive Velocity Limit Value

Establishes the maximum acceptable velocity command in the positive direction. In velocity mode and during homing, velocity commands that exceed the positive velocity limit are clamped to the positive velocity limit. In position mode, the velocity is monitored, and if the positive velocity exceeds the positive velocity limit, a fault is generated ( IDN 129 , bit 10).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed Decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | IDN 113 | Cyclic Transfer: |
Default: | 3000 RPM | Serial Equiv: |
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0026


IDN 39 (S-0-0039) Negative Velocity Limit Value

Establishes the maximum acceptable velocity command in the negative direction. In velocity mode and during homing, velocity commands that exceed the negative velocity limit are clamped to the negative velocity limit. In position mode, the velocity is monitored, and if the negative velocity exceeds the negative velocity limit, a fault is generated ( IDN 129 , bit 10).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed Decimal | Write Access: | CP2, CP3, CP4
Minimum: | – IDN 113 | Run-Up Check: |
Maximum: | 0 | Cyclic Transfer: |
Default: | – 3000 RPM | Serial Equiv: | VLIMN
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0027


IDN 40 (S-0-0040) Velocity Feedback Value

The master retrieves the velocity feedback from the drive through IDN 40. The velocity scaling type is fixed ( IDN 44 ), and the scaling parameters are adjustable ( IDN 45 and 46).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | V
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0028


IDN 41 (S-0-0041) Homing Velocity

The drive's velocity during the “Drive-Controlled Homing” procedure command ( IDN 148 ). The actual homing velocity may be limited by the Bipolar, Positive, or Negative Velocity Limit Values ( IDN 91 , 38, 39 respectively). The velocity scaling type is fixed ( IDN 44 ), and the scaling parameters are adjustable ( IDN 45 and 46).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 231 – 1 | Cyclic Transfer: |
Default: | 23 RPM | Serial Equiv: | VREF*32 / (140 * IDN 45 * 10 IDN 46 )
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | PS:VE | ADS Index Group (hex.): | 0x0029


IDN 42 (S-0-0042) Homing Acceleration

The drive's maximum acceleration and deceleration during the “Drive Controlled Homing” procedure ( IDN 148 ). The homing acceleration is defined as the number of milliseconds to reach the homing velocity.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 1 | Run-Up Check: |
Maximum: | 32767 | Cyclic Transfer: |
Default: | 10 | Serial Equiv: | ACCR, DECR
Units: | IDN 160 , 161, 162 | Version: | 5.04
IDN Type: | PS:AD | ADS Index Group (hex.): | 0x002A


IDN 43 (S-0-0043) Velocity Polarity Parameter

The velocity polarity parameter is used to switch the polarities of velocity data. Polarities are not switched internally but externally, this means on the in- and output of a closed loop system. The motor shaft turns clockwise when there is a positive velocity command and no inversion.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2
Minimum: | 0 | Run-Up Check: |
Maximum: | 0005H | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SERCSET (bits 12-15)
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x002B
Definition:
Bit |  | Description
0 | Velocity command value | 0 = non-inverted
 |  | 1 = inverted
1 | Reserved: Additive velocity command value | 0 = non-inverted
 |  | 1 = Reserved (inverted)
2 | Velocity feedback value | 0 = non-inverted
 |  | 15-7


IDN 44 (S-0-0044) Velocity Data Scaling Type

Defines the scaling options for all velocity data. The scaling types which are supported are indicated in bold-face type. If preferred rotational scaling is selected, the velocity scaling factor ( IDN 45 ) will set to 1 and the velocity data scaling exponent ( IDN 46 ) will set to –4 (refer to IDN 45 and 46).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: | 0002H | Run-Up Check: |
Maximum: | 000AH | Cyclic Transfer: |
Default: | 000AH | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x002C
Definition:
Bit |  | Description
2 – 0 | Scaling Method | 000 = Reserved: No Scaling
 |  | 001 = Reserved: Linear Scaling
 |  | 010 = Rotational Scaling
3 | Standard Scaling Type | 0 = Preferred Scaling
 |  | 1 = Parameter Scaling
4 | Units for Linear Scaling | 0 = Meters (m)
 |  | 1 = Inches (in)
4 | Units for Rotational Scaling | 0 = Revolutions (R)
 |  | 1 = Reserved
5 | Time Units | 0 = Minutes (min)
 |  | 1 = Reserved: Seconds (s)
6 |  |
15-7 | Reserved. |


IDN 45 (S-0-0045) Velocity Data Scaling Factor

The scaling factor for all velocity data in the drive. The exponent is defined with IDN 46 , so that the LSB weight of all rotational velocity data is derived from the following equation:

The scaling may be defined within the following range: 1x10-5 to 1x100. IDN 45 and IDN 46 must be integers. If preferred rotational scaling is selected in IDN 44 , the velocity scaling factor (IDN 45) and the velocity data scaling exponent ( IDN 46 ) will fixed set to there default values (refer to IDN 44 ). By the velocity scaling it is possible to get a rounding error in the LSBits.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 1 | Run-Up Check: |
Maximum: | 10-( IDN 46 ) | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x002D


IDN 46 (S-0-0046) Velocity Data Scaling Exponent

The scaling exponent for all velocity data in the drive. Refer to IDN 45 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3
Minimum: | – 5 | Run-Up Check: |
Maximum: | – log ( IDN 45 ) | Cyclic Transfer: |
Default: | – 4 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x002E


IDN 47 (S-0-0047) Position Command Value

The master issues position commands to the drive as cyclic data through IDN 47. Position commands written via the service channel do not take affect. The “Position Command Value” has a fixed scaling type ( IDN 76 ) and a fixed resolution ( IDN 79 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: |  | Serial Equiv: |
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x002F


IDN 49 (S-0-0049) Positive Position Limit Switch

This IDN defines the maximum position in positive direction. The positive position limit switch is active, when the limit switch is enabled (Refer to IDN 55 and IDN 3004 ). If linear scaling is selected in IDN 76 , the positive limit switch will be automatically calculated, with the feed constant IDN 123 and enabled with the enable bit in IDN 55 . When the position command value reaches the limit switch, the drive decelerates to a stop and in the LED the error “F24” ant the warning “n07” are flashing and the fault bit 13 in IDN 11 and also the warning bits in IDN 323 and IDN 12 Bit 13 are set. With linear position scaling the maximum value is 1024 feed constant.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | -231+1 | Run-Up Check: |
Maximum: | 231-1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SWE2
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0031


IDN 50 (S-0-0050) Negative Position Limit Switch

This IDN defines the minimum position in negative direction. The positive position limit switch is active, when the limit switch is enabled (Refer to IDN 55 and IDN 3004 ). If linear scaling is selected in IDN 76 , the positive limit switch will be automatically calculated, with the feed constant IDN 123 and enabled with the enable bit in IDN 55 . When the position command value reach the limit switch, the drive decelerate to a stop and in the LED the error “F24” ant the warning “n06” are flashing and the fault bit 13 in IDN 11 and also the warning bits in IDN 323 and IDN 12 Bit 13 are set. With linear position scaling the maximum value is 1024 feed constant.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | -231+1 | Run-Up Check: |
Maximum: | 231-1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SWE1
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0032


IDN 51 (S-0-0051) Position Feedback Value 1 (Motor Feedback)

The master retrieves the motor's position feedback from the drive through IDN 51. The scaling type and the resolution will be defined within IDN 76 , 77, 78 and 79.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | PFB
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0033


IDN 52 (S-0-0052) Reference Distance 1

The distance from the machine zero point to the home position, referenced through the motor feedback.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | – 231 + 1 | Run-Up Check: |
Maximum: | 231 – 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ROFFS
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0034


IDN 53 (S-0-0053) Position Feedback Value 2 (External Feedback)

The external position feedback of the drive from an external rotary encoder, in rotational position resolution within IDN 79 . For linear position scaling this IDN is in counts, not in SERCOS units (refer to IDN 76 and 79).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | PFB0
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0035


IDN 54 (S-0-0054) Reference Distance 2

The distance from the machine zero point to the home position for the secondary feedback. If homing is done the position feedback value 2 ( IDN 53 ) contains the value of this IDN (refer to 148).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | – 231 + 1 | Run-Up Check: |
Maximum: | 231 – 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ROFFS0
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0036


IDN 55 (S-0-0055) Position Polarity Parameter

The position polarity parameter is used to switch the polarities of position data. Polarities are not switched internally but externally, this means on the in- and output of a closed loop system. The motor shaft turns clockwise when there is a positive position command difference and no inversion. Bit 4 disable or enable the SW-Limit switches. If linear scaling of the position data is selected (refer to IDN 76 ), these Bit will automatic set and it is not possible to disable the position limit values (refer to IDN 49 and 50). If the Position limit switches are set, the drive set a software limit switch fault (Bit 13 in IDN 11 ), if the drive reach the not allowed area. A new value in bit 4 will not become active until the parameter is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2
Minimum: | 0 | Run-Up Check: |
Maximum: | 001D H | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SERCSET (Bits 4 - 11)
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0037
Definition:
Bit |  | Description
0 | Position command value | 0 = non-inverted 1 = inverted
1 | Reserved: Additive position command value | 0 = non-inverted 1 = Reserved (inverted)
2 | Position feedback value 1 | 0 = non-inverted 1 = inverted
3 | Position feedback value 2 | 0 = non-inverted 1 = inverted
4 | Position limit values | 0 = disabled 1 = enabled
15-5 | Reserved |


IDN 57 (S-0-0057) Position Window

Defines the maximum absolute distance between the position command value and the position feedback value. When the following error is within the “Position Window,” the drive sets the status flag “In Position” ( IDN 13 , bit 6). This function is only active while the drive is in position control. The “In Position” flag may be selected as a RTS bit through IDN 336 (refer to IDN 159 , 189, 336).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 7FFF FFFF | Serial Equiv: |
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0039


IDN 59 (S-0-0059) Position Switch Flag Parameter

The position switch flag parameter depends on the position feedback value, the settings of the “Position Switch Polarity Parameter” ( IDN 3043 and the “Kind of Position Switch Parameter” ( IDN 3044 . The behavior of the position switch flag bits are described below (please refer also to the IDN 3043 and IDN 3044 ). A digital output may also be configured to duplicate a position switch flag through the “Digital Output 1 Mode” ( IDN 3005 ), the “Digital Output 1 Trigger” ( IDN 3007 ), the “Digital Output 2 Mode” ( IDN 3006 ) and the “Digital Output 2 Trigger” ( IDN 3008 ).

The corresponding bits of IDN 3043 and IDN 3044 are set to “0”, which is the default. Then the associated flag bit is set to “0” if the position feedback value is smaller than the position switching point. The associated flag is set to “1” if the position feedback value is greater than or equal to the position switching point.

The corresponding bits of IDN 3043 is set to “1” and of IDN 3044 is set to “0”. Then the associated flag bit is set to “1” if the position feedback value is smaller than the position switching point. The associated flag is set to “0” if the position feedback value is greater than or equal to the position switching point

If the corresponding bit of IDN 3044 is set to “1”, then the associated flag is checked once according to the polarity setting of IDN 3043 and latched till the associated flag is enabled again.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: | 0000H | Run-Up Check: |
Maximum: | 00FFH | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | M POSRSTAT
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003B
Definition:
Bit | Description
LSB 0 | Position switch point 1 ( IDN 60 )
1 | Position switch point 2 ( IDN 61 )
2 | Position switch point 3 ( IDN 62 )
3 | Position switch point 4 ( IDN 63 )
4 | Position switch point 5 ( IDN 64 )
5 | Position switch point 6 ( IDN 65 )
6 | Position switch point 7 ( IDN 66 )
7 | Position switch point 8 ( IDN 67 )
8 – 15 | Reserved.


IDN 60 (S-0-0060) Position Switch Point 1

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003C


IDN 61 (S-0-0061) Position Switch Point 2

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003D


IDN 62 (S-0-0062) Position Switch Point 3

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003E


IDN 63 (S-0-0063) Position Switch Point 4

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003F


IDN 64 (S-0-0064) Position Switch Point 5

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0040


IDN 65 (S-0-0065) Position Switch Point 6

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0041


IDN 66 (S-0-0066) Position Switch Point 7

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0042


IDN 67 (S-0-0067) Position Switch Point 8

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0043


IDN 76 (S-0-0076) Position Data Scaling Type

Defines the scaling options for all position data. The supported scaling types are indicated in bold-face type. The following scaling types are available : 0001(Hex), 0081(Hex), 0009(Hex), 0089(Hex), 000A(Hex) and 008A(Hex). If linear scaling is selected without modulo format on (bit 7 = 1), the software limit switches are automatic switched on (refer to IDN 49 , 50, 55 and IDN 3004 ). If modulo format is selected, the drive operates without interpolation. If rotational scaling is selected and the rotational position resolution ( IDN 79 ) is different from 1048576 or 65536 the modulo format must switch on, this will check during run up. A change of bit 7 will initiate a warm start procedure (refer to IDN 128 during run up. With set the operation mode within IDN 32 or 33 to position control with external feedback, this IDN will set to 004A(Hex) as a fixed setting. The drive can only operate with a fixed rotational scaling for the position data in this case (refer to IDN 79 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2
Minimum: | 0001H | Run-Up Check: | CP3
Maximum: | 008AH | Cyclic Transfer: |
Default: | 000AH | Serial Equiv: | SERCSET (Bits 24 – 31)
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x004C
Definition:
Bit | Description | Value | Description
2 - 0 | Scaling Method | 000 001 010 | Reserved: No Scaling Linear Scaling Rotational Scaling
3 | Standard Scaling Type | 0 1 | Preferred Scaling Parameter Scaling
4 | Reserved: Units for Linear Scaling | 0 1 | Meters (m) Inches (in)
4 | Units for Rotational Scaling | 0 1 | Degrees Reserved
5 | Reserved |  |
6 | Data Reference | 0 1 | At the Motor Shaft At the Load (Only for rotational scaling)
7 | Processing Format | 0 1 | Absolute Format Modulo Format (See IDN 103 )
15-8 | Reserved |  |


IDN 77 (S-0-0077) Linear Position Data Scaling Factor

This parameter defines the scaling factor for all position data in the drive, when linear scaling in IDN 76 is selected.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x004D


IDN 78 (S-0-0078) Linear Position Data Scaling Exponent

This parameter defines the scaling exponent for all position data in the drive, when linear scaling in IDN 76 is selected. Refer to IDN 77 .

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | -7 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x004E


IDN 79 (S-0-0079) Rotational Position Resolution

The rotational position resolution for all position data in the drive. The LSB weight of rotational position data is determined by the following equation:

If the rotational position resolution is different from 65536 or 1048576, it is necessary that the modulo format is switched on in IDN 76 . Only the values 65536 and 1048576 could save in the non-volatile memory. If position control with external feedback is selected, the drive will calculate the rotational position resolution with the resolution of the rotational feedback 2 ( IDN 117 ). This value for IDN 79 is then write protected and could only read by the master. By using parameter 121 and 122 the minimum changes to min: 100 x ( IDN 122 / IDN 121 )and the maximum to max: 100 000 000 x ( IDN 122 / IDN 121 )

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 100 | Run-Up Check: |
Maximum: | 100 000 000 | Cyclic Transfer: |
Default: | 1048576 | Serial Equiv: | PRBASE
Units: | Counts / Revolution | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x004F


IDN 80 (S-0-0080) Torque Command Value

The master issues torque commands to the drive as cyclic data through IDN 80. Torque commands written via the service channel do not take affect.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: |  | Serial Equiv: | ICMD ( (1000 / MICONT)
Units: | IDN 86 | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0050


IDN 84 (S-0-0084) Torque Feedback Value

The master retrieves the motor's torque feedback from the drive through IDN 84.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | I ( (1000 / MICONT)
Units: | IDN 86 | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0054


IDN 86 (S-0-0086) Torque/Force Data Scaling Type

Defines the scaling options for all torque or force data. The scaling types which are supported are indicated in bold-face type. The weight of the LSB for percentage scaling is defined as 0.1% of the motor’s continuous current ( IDN 111 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0056
Definition:
Bit |  | Description
2 – 0 | Scaling Method | 000=Percentage Scaling 001=Reserved: Linear Scaling 010=Reserved: Rotational Scaling
3 | Reserved: Standard Scaling Type | 0=Preferred Scaling 1=Parameter Scaling
4 | Reserved: Units for Force | 0=Newton (N) 1=Pound Force (lbf)
4 | Reserved: Units for Torque | 0=Newton-Meter (Nm) 1=Inch Pound-Force (in-lbf)
5 | Reserved |
6 | Data Reference | 0=At the Motor Shaft 1=Reserved: At the Load
15-7 | Reserved |


IDN 88 (S-0-0088) Receive to Receive Recovery Time

The time required by the drive between the end of the MDT and the beginning of the MST.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 50 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0058


IDN 89 (S-0-0089) MDT Transmission Starting Time

The time at which the master should transmit the MDT, after the end of the MST, during CP3 and CP4. The MDT Transmission Starting Time must be downloaded from the master during CP2. The “MDT Transmission Starting Time” is limited by the CCT ( IDN 2 ), the “Transmit/Receive Transmission Time” ( IDN 4 ) the “AT Transmission Starting Time” ( IDN 6 ) and the “Receive to Receive Recovery Time” ( IDN 88 ) according to the following restrictions.

IDN 89 ( IDN 6 + AT Transmission Time + AT Jitter + IDN 4 + MDT Jitter

IDN 89 ( IDN 2 – max IDN 88 from all drives – MDT Transmission Time

– MST Transmission Time – MDT Jitter – CCT Jitter

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | None | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0059


IDN 90 (S-0-0090) Command Value Processing Time

The minimum time required by the drive from the end of the MDT to the point at which the received command values may be used by the drive.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 50 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x005A


IDN 91 (S-0-0091) Bipolar Velocity Limit

Establishes the maximum acceptable velocity command in both the clockwise and counter-clockwise directions. In velocity mode and during homing, velocity commands that exceed the bipolar velocity limit are clamped to the bipolar velocity limit. In position mode, the velocity is monitored, and if the velocity exceeds the bipolar velocity limit, a fault is generated ( IDN 129 , bit 10).

The “Bipolar Velocity Limit” (IDN 91) is linked to the “Positive and Negative Velocity Limit Values” ( IDN 38 and IDN 39 ). When a value is written to IDN 91, the same value is also written to IDN 38 and IDN 39 (with the appropriate signs). IDN 38 and IDN 39 must have the same absolute value in order for IDN 91 to be valid. If they do not have the same absolute value when IDN 91 is read, then the drive will return error message 7008, “Invalid Data” for IDN 91.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | IDN 113 | Cyclic Transfer: |
Default: | 3000 RPM | Serial Equiv: | VLIM, VLIMN
Units: | IDN 44 ,45,46 (Default: RPM / 10 000) | Version: | 5.04
IDN Type: | VE:FS | ADS Index Group (hex.): | 0x005B


IDN 92 (S-0-0092) Bipolar Torque Limit

Defines the maximum torque limit in both the clockwise and counter-clockwise directions.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | Minimum of IDN 109 and IDN 110 | Cyclic Transfer: |
Default: | Minimum of IDN 109 and IDN 110 | Serial Equiv: | (IPEAK)
Units: | IDN 86 | Version: | 5.04
IDN Type: | CT:FS | ADS Index Group (hex.): | 0x005C


IDN 95 (S-0-0095) Diagnostic Message

The master may read a text message that describes the status of the drive.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | No
Data Type: | Text | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | SSTAT
Units: |  | Version: | 5.04
IDN Type: | FS:MT | ADS Index Group (hex.): | 0x005F


IDN 96 (S-0-0096) Slave Arrangement

The SERCOS address of the drive is contained in both the upper and lower bytes of this IDN. The drive’s address may range from 0 to 63 and may be selected through the front panel of the drive. A drive with an address of zero is a repeater on the SERCOS ring and does not participate in the communication phase run-up. A new drive has a default address of zero.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Hexadecimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | (ADDR << 8) | ADDR
Units: |  | Version: | 5.04
IDN Type: | SC:MT | ADS Index Group (hex.): | 0x0060


IDN 97 (S-0-0097) Class 2 Diagnostic Mask

A mask for the C2D ( IDN 12 ). When a warning condition within IDN 12 changes state, the C2D change bit (AT status word, bit 12) is set. The warning bits within IDN 12 are not latched (i.e. they will automatically set or reset as warning conditions change). The C2D change bit is reset when IDN 12 is read through the service channel. IDN 97 may be used to mask the effect of a particular warning condition on the C2D change bit: when a masked warning changes state, the C2D change bit will not be set. However, the warning bits in IDN 12 will continue to change state according to the warning conditions. When a bit in IDN 97 is clear, the corresponding bit in IDN 12 is masked.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 1111 1111 1111 1111 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC:MT | ADS Index Group (hex.): | 0x0061


IDN 98 (S-0-0098) Class 3 Diagnostic Mask

A mask for the C3D ( IDN 13 ). When a status condition within IDN 13 changes state, the C3D change bit (AT status word, bit 11) is set. The status bits within IDN 13 are not latched (i.e. they will automatically set or reset as status conditions change). The C3D change bit is reset when IDN 13 is read through the service channel. IDN 98 may be used to mask the effect of a particular status condition on the C3D change bit: when a masked status changes state, the C3D change bit will not be set. However, the status bits in IDN 13 will continue to change state according to the status conditions. When a bit in IDN 98 is clear, the corresponding bit in IDN 13 is masked.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 1111 1111 1111 1111 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC:MT | ADS Index Group (hex.): | 0x0062


IDN 99 (S-0-0099) Procedure: Reset Class 1 Diagnostic

Attempts to clear the latched faults contained in IDN 11 , IDN 14 and IDN 129 . Faults that are still active are not cleared. If all the faults are cleared successfully, the C1D status bit (AT bit 13) is also cleared. The fault reset procedure will fail if faults have been latched and the master has not reset the drive enable control bits (MDT bits 13-15). Some faults specified in IDN 11 and IDN 129 require a cold start, which IDN 99 performs automatically when required. The IDN 99 procedure will not reset faults if MDT bits 14 and 15 are set while CP3 or CP4.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | FS:MT | ADS Index Group (hex.): | 0x0063


IDN 100 (S-0-0100) Velocity Loop Proportional Gain

The proportional gain for the proportional-integral velocity loop controller. Typical gain values are between 10 and 20. If the gain is too low, then the drive may respond slowly or have poor damping. If the value is too high, then the drive may whistle or run roughly.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 200 | Cyclic Transfer: |
Default: | 1 | Serial Equiv: | GV * 100
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0064


IDN 101 (S-0-0101) Velocity Loop Integral Action Time

The integral action time for the proportional-integral velocity loop controller. When IDN 101 is zero, the integrator is switched off. If the value is too low, then the drive may run roughly or may have a large overshoot when coupled to a high-inertia load. If the value is too high, the drive response may be sluggish.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 10 000 | Cyclic Transfer: |
Default: | 100 | Serial Equiv: | GVTN * 10
Units: | 0.1 ms | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0065


IDN 103 (S-0-0103) Modulo Value

If the modulo format is on ( IDN 76 bit 7 = 1), the modulo value determines at which numeric value the position data roll over to 0. The following conditions for the modulo value will check during runup:

If linear scaling and modulo format is selected within IDN 76 and the feed constant IDN 123 is smaller then 2^20, the modulo value must be smaller then 1024 * IDN 123 .

If rotational scaling and modulo format is selected within IDN 76 and rotational position resolution IDN 79 is smaller then 2^20, the modulo value must be smaller then 1024 * IDN 79 .

If rotational scaling and modulo format is selected within IDN 76 and rotational position resolution IDN 79 is greater then 2^20, the modulo value must be smaller then 2^50 / IDN 79 .

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 1 | Run-Up Check: | CP3
Maximum: | 2^31-1 | Cyclic Transfer: |
Default: | 2^31-1 | Serial Equiv: | ERND
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0067


IDN 104 (S-0-0104) Position Loop Proportional Gain

The proportional gain for the proportional-integral position loop controller. If the value is too low, the settling time may be too long, and the drive may be too sluggish. If the value is too high, the drive may be noisy and may oscillate.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 60 | Run-Up Check: |
Maximum: | 60 000 | Cyclic Transfer: |
Default: | 900 | Serial Equiv: | GP * 6000
Units: | 0.01 (m/min)/mm ( 0.01 (in/min)/mil | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0068


IDN 105 (S-0-0105) Position Loop Integral Action Time

The integral time for the proportional-integral position loop controller.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 10 | Run-Up Check: |
Maximum: | 2 000 | Cyclic Transfer: |
Default: | 500 | Serial Equiv: | GPTN * 10
Units: | 0.1 ms | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0069


IDN 106 (S-0-0106) Current Loop Proportional Gain 1

The proportional gain for the torque producing current (D) within the proportional-integral current loop controller.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 1 | Run-Up Check: |
Maximum: | 3 000 | Cyclic Transfer: |
Default: | 100 | Serial Equiv: | MLGQ * 100
Units: |  | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x006A


IDN 107 (S-0-0107) Current Loop Integral Action Time 1

The integral time for the torque producing current within the proportional-integral current loop controller.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 200 | Run-Up Check: |
Maximum: | 10 000 | Cyclic Transfer: |
Default: | 600 | Serial Equiv: | KTN * 1000
Units: | µs | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x006B


IDN 108 (S-0-0108) Feedrate Override

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 108 (S-0-0108) Feed rate Override

The feedrate override is activated only with drive controlled procedure commands. In such a case, the velocity command is calculated by the drive internally. This IDN 108 has multiplying effects on the velocity command value.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 10000 | Cyclic Transfer: |
Default: | 10000 | Serial Equiv: |
Units: | 0.01% | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x006C


IDN 109 (S-0-0109) Motor Peak Current

The motor's peak current. If the motor peak current is less than that of the amplifier, the amplifier is automatically limited to the level of the motor peak current.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0.1 * IDN 110 | Run-Up Check: |
Maximum: | 2 * IDN 110 | Cyclic Transfer: |
Default: | IDN 110 | Serial Equiv: | MIPEAK * 1000
Units: | mA | Version: | 5.04
IDN Type: | MR | ADS Index Group (hex.): | 0x006D


IDN 110 (S-0-0110) Amplifier Peak Current

The amplifier's peak current. This value is defined by the hardware and is set to twice the continuous rated current of the drive.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | Hardware defined | Serial Equiv: | DIPEAK * 1000
Units: | mA | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x006E


IDN 111 (S-0-0111) Motor Continuous Stall Current

The current at which the motor produces the continuous standstill torque, according to the motor specification sheet. This parameter is used as a reference for all torque data and for determining motor-related current values from torque data.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0.1 * IDN 112 | Run-Up Check: |
Maximum: | 2.0 * IDN 112 | Cyclic Transfer: |
Default: | IDN 112 | Serial Equiv: | MICONT * 1000
Units: | mA | Version: | 5.04
IDN Type: | MR | ADS Index Group (hex.): | 0x006F


IDN 112 (S-0-0112) Amplifier Rated Current

The amplifier's continuous current rating. This hardware-defined variable is automatically determined by the drive.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | Hardware defined | Serial Equiv: | DICONT * 1000
Units: | mA | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0070


IDN 113 (S-0-0113) Maximum Motor Speed

The motor's maximum recommended speed, as listed in the motor specification sheet provided by the manufacturer.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 12000 RPM | Cyclic Transfer: |
Default: | 3000 RPM | Serial Equiv: | MSPEED
Units: | IDN 44 ,45,46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | MR | ADS Index Group (hex.): | 0x0071


IDN 114 (S-0-0114) System Load Limit

The system’s continuous load rating. The continuous load rating is defined as a percentage of the system’s continuous current. When the load limit is exceeded, the drive sets the overload warning bit in the C2D ( IDN 12 , bit 0). If the load limit is exceeded by 15%, the drive sets the overload shutdown bit in C1D (bit 0).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 100 | Cyclic Transfer: |
Default: | 80 | Serial Equiv: | I2TLIM
Units: | % of min ( IDN 111 , 112, or P3020) | Version: | 5.04
IDN Type: | CT: FS | ADS Index Group (hex.): | 0x0072


IDN 116 (S-0-0116) Resolution of Rotational Feedback 1 (Motor Feedback)

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 116 (S-0-0116) Resolution of Rotational Feedback 1

(Motor Feedback)

The motor's rotary feedback resolution (refer to IDN 79 ).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: | 65536 | Run-Up Check: |
Maximum: | 1048576 | Cyclic Transfer: |
Default: | 1048576 | Serial Equiv: | 2^PRBASE
Units: | Counts | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x0074


IDN 117 (S-0-0117) Resolution of Rotational Feedback 2 (External Feedback)

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 117 (S-0-0117) Resolution of Rotational Feedback 2

(External Feedback)

The resolution of the rotational feedback 2 contains the cycles per revolution of an rotary encoder as an external feedback ( IDN 53 ). The resolution of the external position feedback depends on this parameter and the multiplication factor 2 ( IDN 257 ). The resolution could be calculated with the following calculation rule: resolution = external feedback (IDN117) x 4 x multiplication factor 2 ( IDN 257 ).The maximum resolution is set within IDN 79 divide by 4, the drive checks during runup, that the setting will not give a bigger value. In this case the drive automatically calculates a new multiplication factor 2 ( IDN 257 ).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 12 | Run-Up Check: |
Maximum: | 262144 (16384) | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | FB2RES
Units: | Lines per revolution | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x0075


IDN 119 (S-0-0119) Current Loop Proportional Gain 2

The proportional gain for the field producing current (D) within the proportional-integral current loop controller. This gain has the same value within the proportional gain 1 in the torque producing loop controller (see also IDN 106 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: | 1 | Run-Up Check: |
Maximum: | 3 000 | Cyclic Transfer: |
Default: | 100 | Serial Equiv: | MLGD * 100
Units: |  | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0077


IDN 120 (S-0-0120) Current Loop Integral Action Time 2

The integral time for the field producing current within the proportional-integral current loop controller. This time has the same value within the integral action time 1 in the torque producing loop controller (see also IDN 107 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: | 200 | Run-Up Check: |
Maximum: | 10 000 | Cyclic Transfer: |
Default: | 600 | Serial Equiv: | KTN * 1000
Units: | µs | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0078


IDN 121 (S-0-0121) Input revolutions of load gear

Input revolution values must be entered as integers.

The relation between IDN 121 and 122 can be between 0.01 and 100.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP 3
Minimum: | IDN 122 /100 | Run-Up Check: |
Maximum: | IDN 122 x 100 | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x0079


IDN 122 (S-0-0122) Output revolutions of load gear

Output revolution values must be entered as integers.

The relation between IDN 121 and 122 can be between 0.01 and 100.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP 3
Minimum: | IDN 121 /100 | Run-Up Check: |
Maximum: | IDN 121 x 100 | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x007A


IDN 123 (S-0-0123) Feed Constant

The feed constant describes the machine element which converts a rotational motion into a linear motion. The feed constant indicates the linear distance during one revolution of the feed spindle. This IDN is only active when linear scaling in IDN 76 is selected. This IDN also describes the feed at linear rotational speed scaling.

The maximum is now 10 000 000.

By using parameter 121 and 122 the minimum changes to min: 100 x ( IDN 122 / IDN 121 )and the maximum to max: 100 000 000 x ( IDN 122 / IDN 121 )

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 100 | Run-Up Check: |
Maximum: | 10 000 000 | Cyclic Transfer: |
Default: | 100 000 | Serial Equiv: |
Units: | IDN 76 , 77, 78 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x007B


IDN 127 (S-0-0127) Procedure: Communication Phase 3 Transition Check

Ensures that the drive is ready to switch from CP2 to CP3. The master must successfully execute this procedure prior to switching from CP2 to CP3. If the procedure fails, IDN 21 will contain a list of IDNs that the drive considers invalid.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x007F


IDN 128 (S-0-0128) Procedure: Communication Phase 4 Transition Check

Ensures that the drive is ready to switch from CP3 to CP4. The master must successfully execute this procedure prior to switching from CP3 to CP4. If the procedure fails, IDN 22 will contain a list of IDNs that the drive considers invalid.

If any of the macros have been changed in CP2 or CP3, the drive will re-compile the macro program and perform a warm start, which may take up to 3 minutes. During the warm start, the LED on the front panel of the drive add with the three dots will flashing. During the warm start IDN 182 Bit 1 is set, it will cleared after the warm start. Alternatively, the serial interface may be used to save all values and reset the drive before the CP4 transition check procedure is executed. (For an explanation of the macros, please consult our applications department.)

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0080


IDN 129 (S-0-0129) Manufacturer Class 1 Diagnostic (MC1D)

Lists the status of the latched manufacturer defined drive faults. When a manufacturer defined fault occurs, the drive decelerates to a stop and disables. The C1D status bit (AT status bit 13) is set, IDN 11 bit 15 is set, and the corresponding manufacturer-defined fault bit is set within IDN 129. All manufacturer defined faults are latched within IDN 129 and are reset through the “Reset Class 1 Diagnostic” procedure ( IDN 99 ). IDN 99 performs a cold start automatically when required. Those faults which require a cold start are noted in the table below. The error messages which appear on the front panel of the drive are also shown below.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ERRCODE
Units: |  | Version: | 5.04
IDN Type: | MT:FS | ADS Index Group (hex.): | 0x0081

Definition:

Bit | Description | Cold start | LED Error
LSB 0 | Reserved |  |
1 | Non-volatile memory check-sum fault | yes | F09, F10
2 | Warning fault (actual warning is mask to a fault) | no | F24
3 | Motor brake fault | yes | F11
4 | Supply voltage not present | no | F16
5 | A/D converter fault | yes | F17
6 | Regeneration fault | yes | F18
7 | System fault | yes | F32
8 | Reserved |  |
9 | Motor over speed fault | no | F08
10 | Excessive position command difference | No | F28
11 | Non-permissible software-enable (no hardware-enable; no SERCOS control) | No | F29
12 – 15 | Reserved |  |


IDN 130 (S-0-0130) Probe 1 Positive Edge Value

The “Probing” procedure ( IDN 170 ) is used to capture the motor position ( IDN 51 ) when a digital input changes. IDN 130 will contain the captured position when the “Probe Control Parameter” ( IDN 169 , bit 0) is configured for probe 1 to capture the position on the rising edge of the digital input.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | LATCH32
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0082


IDN 131 (S-0-0131) Probe 1 Negative Edge Value

The “Probing” procedure ( IDN 170 ) is used to capture the motor position ( IDN 51 ) when a digital input changes. IDN 131 will contains the captured position when the “Probe Control Parameter” ( IDN 169 , bit 1) is configured for probe 1 to capture the position on the falling edge of the digital input.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | LATCH32N
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0083


IDN 132 (S-0-0132) Probe 2 Positive Edge Value

The “Probing” procedure ( IDN 170 ) is used to capture the external position ( IDN 53 ) when a digital input changes. IDN 132 will contains the captured position when the “Probe Control Parameter” ( IDN 169 , bit 2) is configured for probe 2 to capture the position on the rising edge of the digital input.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | LATCHX32
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0084


IDN 133 (S-0-0133) Probe 2 Negative Edge Value

The “Probing” procedure ( IDN 170 ) is used to capture the external position ( IDN 53 ) when a digital input changes. IDN 133 will contains the captured position when the “Probe Control Parameter” ( IDN 169 , bit 3) is configured for probe 2 to capture the position on the falling edge of the digital input.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | LATCHX32N
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0085


IDN 134 (S-0-0134) Master Control Word

The drive’s control word within the MDT is stored within IDN 134 as a diagnostic aid.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0086


IDN 135 (S-0-0135) Drive Status Word

The AT telegram status word is stored within IDN 135 as a diagnostic aid.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0087


IDN 136 (S-0-0136) Positive Acceleration Limit Value

Defines the drive's maximum positive acceleration when the drive is in velocity mode. The positive acceleration limit is defined as the number of milliseconds to reach the maximum velocity limit from standstill ( IDN 38 , 39, 91).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 1 | Run-Up Check: |
Maximum: | 32767 | Cyclic Transfer: |
Default: | 10 | Serial Equiv: | ACC
Units: | IDN 160 , 161, 162 | Version: | 5.04
IDN Type: | AD | ADS Index Group (hex.): | 0x0088


IDN 137 (S-0-0137) Negative Acceleration Limit Value

Defines the drive's maximum deceleration (negative acceleration) when the drive is in velocity mode. The drive alternatively uses the quick deceleration limit ( IDN 3022 under the following conditions: position limits are encountered, a fault has occurred, or the master has requested an active disable (MDT control word, bit 15). The quick deceleration limit ( IDN 3022 is always used by the drive when those conditions occur. The negative acceleration limit is defined as the number of milliseconds to go from the maximum velocity limit to standstill ( IDN 38 , 39, 91).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | -32767 | Run-Up Check: |
Maximum: | -1 | Cyclic Transfer: |
Default: | -10 | Serial Equiv: | DEC
Units: | IDN 160 , 161, 162 | Version: | 5.04
IDN Type: | AD | ADS Index Group (hex.): | 0x0089


IDN 140 (S-0-0140)

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | VER *
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x008C


IDN 141 (S-0-0141) Motor Type

The master may use this IDN to read or write the motor type text describing. The master can select the motor that is used from the motor database of the drive.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | “NN” | Serial Equiv: | MNAME
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x008D


IDN 142 (S-0-0142) Application Type

The master may use this IDN to store text describing the drive’s application.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | “DRIVE0” | Serial Equiv: | ALIAS
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x008E


IDN 143 (S-0-0143) SYSTEM Interface Version

Contains the version number of the SERCOS specification. The drive conforms this version of the specification.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | “V01.02” | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x008F


IDN 147 (S-0-0147) Homing Parameter

The “Drive Controlled Homing” procedure ( IDN 148 ) is configured through IDN 41 , IDN 42 and IDN 147. Only the bits 0, 5 and 6 are supported, if the home switch is evaluated to the drive bit 1 must set to 0 and bit 2 must set 1. All other reserved bits must be set as indicated by the bold type within the following table. To the different homing types refer also to IDN 3027 If the position control is set on the external encoder , bit 3 must be set to 1.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0085H | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0093
Definition:
Bit | Description | Setting
LSB 0 | Homing direction | 0 = CW 1 = CCW
1 | Home switch polarity | 1 = Active on falling edge
2 | Home switch location | 0 = Master
4 | Reserved: Home enable evaluation | Set to 0
6 | Marker pulse evaluation | 1 = Not evaluated
7 | Reserved: Stop condition | 1 = On home position ( IDN 52 , 54)
8 – 15 | Reserved. | Set to 0


IDN 148 (S-0-0148) Procedure: Drive Controlled Homing

The drive automatically enters an internal position mode and homes the drive. Homing is configured through the “Homing Velocity” ( IDN 41 ), “Homing Acceleration” ( IDN 42 ) and the “Homing Parameter” ( IDN 147 ). The homing procedure should fail under the following conditions:

1) The drive is disabled, or the master clears any of the enable bits (MDT bits 13-15) during drive-controlled homing.

2) The “Probing” procedure ( IDN 170 ) is active.

3) The home switch is located on the drive ( IDN 147 , bit 2 is set) and will be evaluated during homing ( IDN 147 , bit 5 is clear) and a configurable input has not been configured as a home switch input.

4) A fault occurs during drive controlled homing.

The home switch is located on the master ( IDN 147 , bit 2 is clear) and will be evaluated during homing ( IDN 147 , bit 5 is clear) and the “Homing Enable” signal ( IDN 407 ) has not been configured as a real time control bit.

The master should not cancel the drive controlled homing procedure until it has aligned its position command with the drive’s present position command. The master may abort drive controlled homing by first stopping the drive through the start/stop bit (MDT control bit 13), aligning its position command with the drive and then canceling the procedure.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0094


IDN 159 (S-0-0159) Monitoring Window

The monitoring window defines the maximum position error. When the absolute distance between the active position command and active position feedback exceeds the monitoring window, an “excessive position deviation” fault is generated ( IDN 11 , bit 11).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 7FFF FFFFH | Cyclic Transfer: |
Default: | 262144 | Serial Equiv: | PEMAX
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS:FS | ADS Index Group (hex.): | 0x009F


IDN 160 (S-0-0160) Acceleration Data Scaling Type

Defines the scaling options for all acceleration data. The scaling types which are supported are indicated in bold face type. The rotational parameter scaling setting (IDN 160 = 000A H), could not save in the EEPROM (refer to IDN 161 , 162). For the no scaling option, all acceleration data are scaled in ms, to reach the bipolar velocity limit. A new value will not become active until the parameter is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 000AH | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ACCUNIT
Units: |  | Version: | 5.04
IDN Type: | AD | ADS Index Group (hex.): | 0x00A0
Definition:
Bit |  | Description
2 - 0 | Scaling Method | 000=No scaling 001=reserved: Linear Scaling 010=Rotational Scaling
3 | Standard Scaling Type | 0=Preferred Scaling 1=Parameter Scaling
4 | Reserved: Units for Linear Scaling | 0=Meters (m) 1=Inches (in)
4 | Units for Rotational Scaling | 0=Radian 1=Reserved
5 | Time Units | 0=Seconds (s) 1=Reserved
6 | Data Reference | 0=At the Motor Shaft 1=Reserved: At the Load
15-7 | Reserved |


IDN 161 (S-0-0161) Acceleration Data Scaling Factor

This parameter defines the scaling factor for all acceleration data in the drive, when rotational parameter scaling in IDN 160 is selected (Refer to IDN 160 , 162).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00A1


IDN 162 (S-0-0162) Acceleration Data Scaling Exponent

This parameter defines the scaling exponent for all acceleration data in the drive, when rotational parameter scaling in IDN 160 is selected (Refer to IDN 160 , 161).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3
Minimum: | -3 | Run-Up Check: |
Maximum: | 0 | Cyclic Transfer: |
Default: | -3 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00A2


IDN 169 (S-0-0169) Probe Control Parameter

The probe control parameter defines the input signal edge that will result in a position capture during the “Probing” procedure ( IDN 170 ). Each probe may be used to capture positions on both probe signal edges, but the probe edges must be separated by at least 2 milliseconds. The table below describe the fixed settings if only the digital input 2 is used for the latched function, for the other settings please refer also to IDN 3018

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 15 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00A9
Definition:
Bit | Description | Setting
LSB 0 | Probe 1 – Capture motor position on positive edge | 0 = Inactive. 1 = Active.
1 | Probe 1 – Capture motor position on negative edge | 0 = Inactive. 1 = Active.
2 | Probe 2 – Capture external position on positive edge | 0 = Inactive. 1 = Active.
3 | Probe 2 – Capture external position on negative edge | 0 = Inactive. 1 = Active.
4 - 15 | Reserved. | Set to 0.


IDN 170 (S-0-0170) Procedure: Probing

Probing is used to capture position data when a digital input changes. Each probe may trigger a position capture using both edges (rising and/or falling) of the digital input signal, as long as the edges are separated by at least 2 milliseconds. The “Probe Control Parameter” ( IDN 169 ) is used to configure the digital input edges that will trigger a position capture. Once the probe procedure is started by the master (set IDN 170 to 3), it will continue indefinitely until either the master cancels the probing procedure or a probing error occurs. The probing procedure will fail under the following conditions:

1) The “Homing” procedure ( IDN 148 ) is active.

2) A digital input has not been configured as a position capture input ( IDN 3001 .

During the probing procedure, the master arms the probe trigger by setting a “Probe Enable” signal ( IDN 405 or IDN 406 ). After the probe trigger has been armed, the next rising and/or falling edge(s) (as specified in IDN 169 ) on the probe inputs ( IDN 401 or IDN 402 ) will latch the motor position and cause the corresponding “Probe Position Latch Status” ( IDN 179 ) bits to set. Any further changes in the probe input are ignored until the master re-arms the probe trigger by clearing and setting the probe enable signal. The master may read captured positions through the “Probe Positive Edge Value” ( IDN 130 and IDN 132 ) and the “Probe Negative Edge Value” ( IDN 131 and IDN 133 ).

The drive supports two physical probe input that must be pre-configured through IDN 3001 and IDN 3000 before starting the probe procedure. It will be select with IDN 3018 Probe 1 with the physical input 2 and Probe 2 with the physical input 1 and all combination for the feedback types for both probes.

Although it is possible to use only one physical probe input (digital input 2) with the two logical probes that are operated independently. Logical probe 1 supports capturing the motor feedback while logical probe 2 supports capturing the external feedback.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00AA


IDN 179 (S-0-0179) Probe Position Latch Status

The probe status parameter indicates whether a position has been captured and latched within one of the “Probe Edge Value” IDNs ( IDN 130 0 through 133). IDN 179 duplicates the information found in IDN 409 9 through 412.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00B3
Definition:
Bit | Description | Setting
LSB 0 | Probe 1 – Position latched on positive edge ( IDN 130 ) | 0 = No. 1 = Latched.
1 | Probe 1 – Position latched on negative edge ( IDN 131 ) | 0 = No. 1 = Latched.
2 | Probe 2 – Position latched on positive edge ( IDN 132 ) | 0 = No. 1 = Latched.
3 | Probe 2 – Position latched on negative edge ( IDN 133 ) | 0 = No. 1 = Latched.
4 - 15 | Reserved. | Set to 0.


IDN 182 (S-0-0182) Manufacturer Class 3 Diagnostic (MC3D)

Lists of the manufacturer defined status flags for the drive. If a status condition is set or reset within IDN182, the manufacturer class 3 diagnostic bit ( IDN 13 bit 15) is set as well. When IDN 182 is read via the service channel, the bit 15 of IDN 13 will reset to 0.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x00B6
Definition:
Bit | Description | Setting
LSB 0 | Hardware enable | 0 = not exist 1 = exist
1 | Warm start ( IDN 128 ) | 0 = not running 1 = still running
2-15 | Reserved |


IDN 185 (S-0-0185) Maximum Length of AT Configurable Data

Defines the maximum length, in bytes, of the AT's cyclic data field. The master may use this IDN to determine how many IDNs may be placed within the application telegram (refer to IDN 15 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 24 | Serial Equiv: |
Units: | Bytes | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x00B9


IDN 186 (S-0-0186) Maximum Length of MDT Configurable Data

Defines the maximum length, in bytes, of the MDT's cyclic data field. The master may use this IDN to determine how many IDNs may be placed within an application telegram (refer to IDN 15 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 12 | Serial Equiv: |
Units: | Bytes | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x00BA


IDN 187 (S-0-0187) List of AT Configurable Data IDNs

Lists all the IDNs that may be transferred as AT cyclic data. The master may use this IDN to determine the IDNs that may be placed within an application telegram (refer to IDN 15 ). The following IDNs may be assigned as AT cyclic data:

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x00BB
Definition:
IDN | Description
40 | Velocity Feedback Value
51 | Position Feedback Value 1 (motor)
53 | Position Feedback Value 2 (external)
59 | Position Switch Flag Parameter
84 | Torque Feedback Value
130 | Probe 1 Positive Edge Value
131 | Probe 1 Negative Edge Value
132 | Probe 2 Positive Edge Value
133 | Probe 2 Negative Edge Value
189 | Following Distance
IDN 3012 | Difference Probe Edge Value 1
IDN 3013 | Difference Probe Edge Value 2
IDN 3030 | Configurable I/O: Digital Input 1 Status
IDN 3031 | Configurable I/O: Digital Input 2 Status
IDN 3032 | Configurable I/O: Digital Input 3 Status
IDN 3033 | Configurable I/O: Digital Input 4 Status
IDN 3034 | Analog Input 1 Value
IDN 3035 | Analog Input 2 Value


IDN 188 (S-0-0188) List of MDT Configurable Data IDNs

Lists all the IDNs that may be transferred as MDT cyclic data. The master may use this IDN to determine the IDNs that may be placed within an application telegram (refer to IDN 15 ). The following IDNs may be assigned as MDT cyclic data:

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x00BC
Definition:
IDN | Description
36 | Velocity Command Value
47 | Position Command Value
60 | Position Switch Point 1
61 | Position Switch Point 2
80 | Torque Command Value
IDN 3036 | Configurable I/O: Digital Output 1 Control/Status
IDN 3037 | Configurable I/O: Digital Output 2 Control/Status


IDN 189 (S-0-0189) Following Distance

The distance between the position command value and the appropriate position feedback value (1 or 2). The drive calculates this value by subtracting the position feedback value (1 or 2) from the position command value.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | PE
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00BD


IDN 192 (S-0-0192) IDN List of Back-up Operation Data

A list of all IDNs which are essential for drive operation. The master may use this list to back-up the drive parameters. If the drive is replaced, the IDNs within this list may be reloaded into the replacement drive using the order defined within IDN 288 and IDN 289 or direct the order of the list within this IDN.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x00C0


IDN 196 (S-0-0196) Motor Rated Current

The motor's rated current. If the motor rated current is less than that of the amplifier, the amplifier is automatically limited to the level of the motor rated current.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0.1 * IDN 112 | Run-Up Check: |
Maximum: | 2 * IDN 112 | Cyclic Transfer: |
Default: | IDN 112 | Serial Equiv: | MICONT * 1000
Units: | MA | Version: | 5.04
IDN Type: | MR | ADS Index Group (hex.): | 0x00C4


IDN 203 (S-0-0203) Amplifier Shutdown Temperature

When the amplifier temperature ( heat sink temperature) exceed the value of the amplifier shutdown temperature, the drive sets the fault bit for amplifier over temperature fault in C1D ( IDN 11 bit 1).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 200 | Run-Up Check: |
Maximum: | 850 | Cyclic Transfer: |
Default: | 800 | Serial Equiv: | MAXTEMPH ( 10
Units: | IDN 208 | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x00CB


IDN 205 (S-0-0205) Cooling Error Shutdown Temperature

When the temperature inside the drive housing exceed the value of the cooling error shutdown temperature, the drive sets the fault bit for cooling system fault in C1D ( IDN 11 bit 3).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 100 | Run-Up Check: |
Maximum: | 800 | Cyclic Transfer: |
Default: | 700 | Serial Equiv: | MAXTEMPE ( 10
Units: | IDN 208 | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x00CD


IDN 208 (S-0-0208) Temperature Data Scaling Type

Defines the scaling options for all temperature data. The scaling types which are supported are indicated in bold-face type.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0000H | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x00D0
Definition:
Bit |  | Description
0 | Scaling Method | 0 = 0,1 °C 1=Reserved: 0,1 F
15-1 | Reserved | 15-1


IDN 257 (S-0-0257) Multiplication Factor 2

The multiplication factor 2 defines the drive internal multiplication of an rotary encoder as an external feedback for the position feedback value 2 ( IDN 53 ). If the resolution of the rotational feedback 2 ( IDN 117 ) is not a result of 2x, the drive may use an additional scaling for IDN 53 . If the master write IDN 117 the drive calculate automatic the “Multiplication factor 2” (IDN 257), for the external feedback, and an additional scaling factor if necessary, to scale the external rotary encoder to the rotational position resolution set within IDN 79 (refer to IDN 53 , 79 and 117). The drive also do the automatic calculation for position control with external feedback.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 256 | Serial Equiv: | EXTMUL
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x0101


IDN 262 (S-0-0262) Procedure: Load Default Values

This procedure loads the manufacturer’s default parameters into volatile memory. The parameters stored in non-volatile memory remain unchanged. The default parameters allow the drive to operate without problems, but the operation is not necessarily optimized.

This procedure will normally modify the macro program, and the drive will re-compile the macro program and perform a warm start in the CP4 transition check, which may take up to 3 minutes. During the warm start, the LED on the front panel of the drive add with the three dots will flashing. During the warmstart IDN 182 Bit 1 is set, it will cleared after the warmstart. Alternatively, the serial interface may be used to save all values and reset the drive before the CP4 transition check procedure is executed. (For an explanation of the macros, please consult our applications department.)

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | RSTVAR
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x0106


IDN 264 (S-0-0264) Procedure: Back-up Working Memory

This command saves all data essential for drive operation from the active memory to the non-volatile memory. IDN 192 defines which data is essential for drive operation. Previously saved data is overwritten.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SAVE
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x0108


IDN 271 (S-0-0271) Drive ID

The master may store a unique drive identification number within this IDN. The identification number is saved to non-volatile memory when the “Back-up Working Memory” procedure ( IDN 264 ) is executed. The identification number is reset to zero when the “Load Default Values” procedure ( IDN 262 ) is executed.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 32 767 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | UID
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x010F


IDN 288 (S-0-0288) IDN List of Data Programmable in CP2

A list of all IDNs that may be written by the master in CP2. The IDNs are listed in the order that the master should write them to avoid data dependency problems. Data dependency problems may arise, for example, when the range of one IDN depends upon an IDN that has not yet been written.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x0120


IDN 289 (S-0-0289) IDN List of Data Programmable in CP3

A list of all IDNs that may be written by the master in CP3. The IDNs are listed in the order that the master should write them to avoid data dependency problems. Data dependency problems may arise, for example, when the range of one IDN depends upon an IDN that has not yet been written.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x0121


IDN 296 (S-0-0296) Velocity Feed Forward Gain

Defines a multiplier for an additive velocity command that is generated from the position profile. Velocity feed forward helps to reduce the velocity dependent following error. Velocity feed forward is added to the velocity command when the active operational mode defined by IDN 32 and/or IDN 33 has bit 3 set and is in position control mode.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 2000 | Cyclic Transfer: |
Default: | 1000 | Serial Equiv: | GPFFV
Units: | 0.1% | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0128


IDN 298 (S-0-0298) Home Switch Distance

The distance the home switch is from the “optimal” location after homing. The “optimal” location is defined as half the distance between successive marker pulses (encoder) or null points (resolvers). The home switch distance may be used to ensure that the home switch is located correctly to avoid inconsistent homing. The home switch distance is not valid until homing has completed successfully ( IDN 403 is set).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x012A


IDN 301 (S-0-0301) Allocation of Real-time Control Bit 1

Assigns a control signal IDN to the real-time control bit 1 (RTC bit 1, MDT control word bit 6). Two RTC bits are defined within the MDT control word (bits 6 and 7) and may be updated every communication cycle by the master. The following rules govern the assignment and use of RTC bit:

Only certain control signal IDNs of type binary may be assigned to the real time control allocation IDNs. The exception is IDN 0 , which indicates that the real time control bit is undefined. The following IDNs may be assigned as RTC signals: IDN 0 , IDN 405 ( IDN 3039 = 0), IDN 406 ( IDN 3039 = 0) and IDN 3038 ( IDN 3039 = 1).

A new RTC bit assignment must be valid within the drive, before the service channel busy bit is being reset. After the service channel busy bit from the drive is reset, the master can operate with the RTC bit 1 in the master control word.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x012D


IDN 303 (S-0-0303) Allocation of Real-time Control Bit 2

Assigns a control signal IDN to the real-time control bit 2 (RTC bit 2, MDT control word bit 7). Two RTC bits are defined within the MDT control word (bits 6 and 7) and may be updated every communication cycle by the master. For further information refer to IDN 301 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x012F


IDN 304 (S-0-0304) Real-Time Status Bit 1

The value of the IDN assigned to RTS bit 1.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x0130


IDN 305 (S-0-0305) Allocation of Real-time Status Bit 1

The IDN of a real-time status signal that appears in real-time status bit 1 (AT status word, bit 6). Two real time status bits are defined within the AT status word (bits 6 and 7) and are continuously updated by the drive during CP4. The following rules govern the assignment and use of a real time status bit (i.e. writing IDN 305 or 307):

Only status signal IDNs of type binary may be assigned to the real time status allocation IDNs. The exception is IDN 0 , which indicates that the real time status bit is undefined. The following IDNs may be assigned as RTS signals: IDN 0 , IDN 336 , IDN 400 , IDN 403 , IDN 409 , IDN 410 , IDN 411 and IDN 412 .

The master should no longer evaluate a previous real time status assignment after transmitting a write request for element 7 of a real time status bit allocation IDN. The previously assigned real time status bit will remain valid until the service channel busy bit is set.

The master should not start evaluating a new real time status bit assignment until the service channel busy bit is reset by the drive.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x0131


IDN 306 (S-0-0306) Real-Time Status Bit 2

The value of the IDN assigned to RTS bit 2.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x0132


IDN 307 (S-0-0307) Allocation of Real-time Status Bit 2

The IDN of a real-time status signal that appears in real-time status bit 2 (AT status word, bit 7). Two real time status bits are defined within the AT status word (bits 6 and 7) and are continuously updated by the drive during CP4. For further information, refer to IDN 305 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x0133


IDN 323 (S-0-0323) Status “Target position outside of travel range”

A warning signal IDN that is set (Bit 0 = 1) when the target position is outside of the travel range. This IDN will set if the HW- or SW-Limit Switch is active. The drive show this with flashing the warning “n10” or “n07” for outside of positive range or “n11” or “n06” outside of negative range. IDN 323 duplicates the C2D “Target position outside of travel range” warning bit ( IDN 12 , bit 13).

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |


IDN 336 (S-0-0336) Status “In Position”

A status signal IDN that is set when the difference between the position command value and the position feedback value falls within the range defined by the “Position Window” ( IDN 57 ). IDN 336 duplicates the C3D “In Position” status bit ( IDN 13 , bit 6) and may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0150


IDN 380 (S-0-0380) DC Bus Voltage

The master retrieves the drive’s DC bus voltage through this IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: | 0 | Run-Up Check: |
Maximum: | 900 | Cyclic Transfer: |
Default: |  | Serial Equiv: | VBUS
Units: | Volt | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x017C


IDN 384 (S-0-0384) Amplifier Temperature

The master retrieves the amplifier temperature (heat sink temperature) from the drive through this IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | TEMPH ( 10
Units: | IDN 208 | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0180


IDN 392 (S-0-0392) Velocity Feedback Filter Time Constant

The velocity feedback is passed through a first order low pass filter before being applied to the velocity loop. The filter is useful for improving the step response and operational smoothness, particularly for very small, highly dynamic motors. If the filter’s time constant is to low, then the motor may run roughly. If the filter’s time constant is to high, then the motor’s response may be soft and unstable. The filter’s time constant may be adjusted in intervals of 100 (s.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 65500 | Cyclic Transfer: |
Default: | 400 | Serial Equiv: | GVFBT
Units: | µs | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0188


IDN 400 (S-0-0400) Home Switch Status

Contains the state of the home switch. The digital input used as home switch input is assigned through the use of digital input mode IDNs ( IDN 3000 IDN 3001 IDN 3002 or IDN 3003 . IDN 400 is useful for assigning the home switch signal to a RTS bit.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | PS:IO | ADS Index Group (hex.): | 0x0190


IDN 401 (S-0-0401) Probe 1

Contains the state of the probe 1 input. The digital input used as a probe is assigned through the use of IDN 3001 The drive updates the probe 1 IDN only when the probing procedure ( IDN 170 ) is active and the probe 1 enable ( IDN 405 ) is set.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | IN2
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0191


IDN 402 (S-0-0402) Probe 2

Contains the state of the probe 2 input. The digital input used as a probe is assigned through the use of IDN 3001 The drive updates the probe 2 IDN only when the probing procedure ( IDN 170 ) is active and the probe 2 enable ( IDN 406 ) is set.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | IN2
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0192


IDN 403 (S-0-0403) Position Feedback Status

The position feedback status flag is set by the drive during homing when the position feedback is referenced to the machine zero point. The status flag is reset after power-up, and when the “Drive Controlled Homing” procedure ( IDN 148 ) is started. IDN 403 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0193


IDN 405 (S-0-0405) Probe 1 Enable

Used to arm the position capture mechanism so that the next valid probing signal edge captures the current position into IDN 130 or 131. IDN 405 may be assigned to a RTC bit (MDT control word bit 6 or 7) through IDN 301 or IDN 303 . This IDN is write-protected while it is assigned to a RTC bit and could only reset to 0 via the SC. Refer to IDN 170 for more information.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0195


IDN 406 (S-0-0406) Probe 2 Enable

Used to arm the position capture mechanism so that the next valid probing signal edge captures the current position into IDN 132 or 133. IDN 406 may be assigned to a RTC bit (MDT control word bit 6 or 7) through IDN 301 or IDN 303 . This IDN is write-protected while it is assigned to a RTC bit and could only reset to 0 via the SC. Refer to IDN 170 for more information.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0196


IDN 409 (S-0-0409) Probe 1 Positive Edge Latched Status

Indicates whether captured position data has been latched within IDN 130 after the rising edge of the probe 1 input signal ( IDN 401 ). Position data can only be latched on the positive edge of probe 1 if the “Probing” procedure ( IDN 170 ) is active and the “Probe Control Parameter” ( IDN 169 ) has been configured to use the positive edge of probe 1. Additionally, probe 1 must be armed by setting the “Probe 1 Enable” ( IDN 405 ). After arming probe 1, the next probe 1 rising edge will capture the current position and the “probe 1 positive edge latched status” will set when the captured data is available in IDN 130 . Once the latched status has been set, no more position captures will occur on the rising edges of the probe 1 input until the master re-arms probe 1 by clearing and setting the probe 1 enable. Clearing the probe 1 enable signal will reset the latch status.

IDN 409 duplicates information found in the probe status ( IDN 179 , bit 0). IDN 409 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0199


IDN 410 (S-0-0410) Probe 1 Negative Edge Latched Status

Indicates whether captured position data has been latched within IDN 131 after the falling edge of the probe 1 input signal ( IDN 401 ). Position data can only be latched on the negative edge of probe 1 if the probing procedure ( IDN 170 ) is active and the “Probe Control Parameter” ( IDN 169 ) has been configured to use the negative edge of probe 1. Additionally, probe 1 must be armed by setting the “Probe 1 Enable” ( IDN 405 ). After arming probe 1, the next probe 1 falling edge will capture the current position and the “probe 1 negative edge latched status” will set when the captured data is available in IDN 131 . Once the latched status has been set, no more position captures will occur on the falling edges of the probe 1 input until the master re-arms probe 1 by clearing and setting the probe 1 enable. Clearing the probe 1 enable signal will reset the latch status.

IDN 410 duplicates information found in the probe status ( IDN 179 , bit 1). IDN 410 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x019A


IDN 411 (S-0-0411) Probe 2 Positive Edge Latched Status

Indicates whether captured position data has been latched within IDN 132 after the rising edge of the probe 2 input signal ( IDN 402 ). Position data can only be latched on the positive edge of probe 2 if the “Probing” procedure ( IDN 170 ) is active and the “Probe Control Parameter” ( IDN 169 ) has been configured to use the positive edge of probe 2. Additionally, probe 2 must be armed by setting the “Probe 2 Enable” ( IDN 406 ). After arming probe 2, the next probe 2 rising edge will capture the current position and the “probe 2 positive edge latched status” will set when the captured data is available in IDN 132 . Once the latched status has been set, no more position captures will occur on the rising edges of the probe 2 input until the master re-arms probe 2 by clearing and setting the probe 2 enable. Clearing the probe 2 enable signal will reset the latch status.

IDN 411 duplicates information found in the probe status ( IDN 179 , bit 2). IDN 411 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x019B


IDN 412 (S-0-0412) Probe 2 Negative Edge Latched Status

Indicates whether captured position data has been latched within IDN 133 after the falling edge of the probe 2 input signal ( IDN 402 ). Position data can only be latched on the negative edge of probe 2 if the probing procedure ( IDN 170 ) is active and the “Probe Control Parameter” ( IDN 169 ) has been configured to use the negative edge of probe 2. Additionally, probe 2 must be armed by setting the “Probe 2 Enable” ( IDN 406 ). After arming probe 2, the next probe 2 falling edge will capture the current position and the “probe 2 negative edge latched status” will set when the captured data is available in IDN 133 . Once the latched status has been set, no more position captures will occur on the falling edges of the probe 2 input until the master re-arms probe 2 by clearing and setting the probe 2 enable. Clearing the probe 2 enable signal will reset the latch status.

IDN 412 duplicates information found in the probe status ( IDN 179 , bit 3). IDN 412 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x019C


IDN 3000 (P-0-3000) Configurable I/O: Digital Input 1 Mode

Determines the functionality of digital inputs 1 through 4. The digital inputs may be read directly through IDN 3030 through IDN 3033 . The following table describes the functions that are available. A new input mode will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | InxMODE (x = 1, 2, 3, or 4).
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BB8
Definition:
INx-Mode | Description | Active Edge | Digital Input
 |  |  | 1 | 2 | 3 | 4
0 | Reserved | – |  |  |  |
1 | Reset |  | x |  |  |
2 | PSTOP | Active low |  |  | x | x
3 | NSTOP | Active low |  |  | x | x
4 | PSTOP+Intg.Off | Active low |  |  | x |
5 | NSTOP+Intg.Off | Active low |  |  |  | x
6 | PSTOP+NSTOP | Active low |  |  | x |
7 | P/NSTOP+Intg.Off | Active low |  |  | x |
8 | SETP.1/SETP.2 |  | x | x | x | x
9 | MT_No_Bit |  | x | x | x | x
10 | Intg.Off | Rising | x | x | x | x
11 | v/Torq.Contr. | Active high | x | x | x | x
12 | Reference | IDN 147 | x | x | x | x
13 | ROD/SSI | Low/High | x | x | x | x
14 | FError_clear |  | x | x | x | x
15 | Start_MT Next |  | x | x | x | x
16 | Start_MT No x |  | x | x | x | x
17 | Start_ MT IO |  | x | x | x | x
18 | Ipeak2x |  | x | x | x | x
19 | Reserved |  |  |  |  |
20 | Start_Jog v=x |  | x | x | x | x
21 | U_Mon.off | High | x | x | x | x
22 | MT Restart |  | x | x | x | x
23 | Start2_MT No x |  | x | x | x | x
24 | Switch over OPMODE |  | x | x | x | x
25 | Zero_latch |  | x | x | x | x
26 | Position Latch | IDN 169 | x | x |  |
27 | Emergency Stop |  | x | x | x | x
28 | Reserved |  |  |  |  |
29 | Reserved |  |  |  |  |
30 | Command Buffer 1 |  | x | x | x | x
31 | Command Buffer 2 |  | x | x | x | x
32 | Brake |  | x | x | x | x
33 | see 30 |  | x | x | x | x
34 | see 31 |  | x | x | x | x
35 | Select Velocity/Current Entry |  | x | x | x | x
36 | Give Offset to Gearing Function |  | x | x | x | x
37 | Change source of actual position at EXTPOS=1 |  | x | x | x | x
38 | Enable signal for following motion task |  | x |  |  |
39 | Constant Speed for defined time |  | x | x | x | x
40 | Additional hardware input (enable) |  | x | x | x | x
41 | Fast emergency stop |  | x | x | x | x


IDN 3001 (P-0-3001) Configurable I/O: Digital Input 2 Mode

Determines the functionality of digital inputs 1 through 4. The digital inputs may be read directly through IDN 3030 through IDN 3033 . The following table describes the functions that are available. A new input mode will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | InxMODE (x = 1, 2, 3, or 4).
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BB9

Definition

INx-Mode | Description | Active Edge | Digital Input
 |  |  | 1 | 2 | 3 | 4
0 | Reserved | – |  |  |  |
1 | Reset |  | x |  |  |
2 | PSTOP | Active low |  |  | x | x
3 | NSTOP | Active low |  |  | x | x
4 | PSTOP+Intg.Off | Active low |  |  | x |
5 | NSTOP+Intg.Off | Active low |  |  |  | x
6 | PSTOP+NSTOP | Active low |  |  | x |
7 | P/NSTOP+Intg.Off | Active low |  |  | x |
8 | SETP.1/SETP.2 |  | x | x | x | x
9 | MT_No_Bit |  | x | x | x | x
10 | Intg.Off | Rising | x | x | x | x
11 | v/Torq.Contr. | Active high | x | x | x | x
12 | Reference | IDN 147 | x | x | x | x
13 | ROD/SSI | Low/High | x | x | x | x
14 | FError_clear |  | x | x | x | x
15 | Start_MT Next |  | x | x | x | x
16 | Start_MT No x |  | x | x | x | x
17 | Start_ MT IO |  | x | x | x | x
18 | Ipeak2x |  | x | x | x | x
19 | Reserved |  |  |  |  |
20 | Start_Jog v=x |  | x | x | x | x
21 | U_Mon.off | High | x | x | x | x
22 | MT Restart |  | x | x | x | x
23 | Start2_MT No x |  | x | x | x | x
24 | Switch over OPMODE |  | x | x | x | x
25 | Zero_latch |  | x | x | x | x
26 | Position Latch | IDN 169 | x | x |  |
27 | Emergency Stop |  | x | x | x | x
28 | Reserved |  |  |  |  |
29 | Reserved |  |  |  |  |
30 | Command Buffer 1 |  | x | x | x | x
31 | Command Buffer 2 |  | x | x | x | x
32 | Brake |  | x | x | x | x
33 | see 30 |  | x | x | x | x
34 | see 31 |  | x | x | x | x
35 | Select Velocity/Current Entry |  | x | x | x | x
36 | Give Offset to Gearing Function |  | x | x | x | x
37 | Change source of actual position at EXTPOS=1 |  | x | x | x | x
38 | Enable signal for following motion task |  | x |  |  |
39 | Constant Speed for defined time |  | x | x | x | x
40 | Additional hardware input (enable) |  | x | x | x | x
41 | Fast emergency stop |  | x | x | x | x


IDN 3002 (P-0-3002) Configurable I/O: Digital Input 3 Mode

Determines the functionality of digital inputs 1 through 4. The digital inputs may be read directly through IDN 3030 through IDN 3033 . The following table describes the functions that are available. A new input mode will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | InxMODE (x = 1, 2, 3, or 4).
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBA
Definition:
INx-Mode | Description | Active Edge | Digital Input
 |  |  | 1 | 2 | 3 | 4
0 | Reserved | – |  |  |  |
1 | Reset |  | x |  |  |
2 | PSTOP | Active low |  |  | x | x
3 | NSTOP | Active low |  |  | x | x
4 | PSTOP+Intg.Off | Active low |  |  | x |
5 | NSTOP+Intg.Off | Active low |  |  |  | x
6 | PSTOP+NSTOP | Active low |  |  | x |
7 | P/NSTOP+Intg.Off | Active low |  |  | x |
8 | SETP.1/SETP.2 |  | x | x | x | x
9 | MT_No_Bit |  | x | x | x | x
10 | Intg.Off | Rising | x | x | x | x
11 | v/Torq.Contr. | Active high | x | x | x | x
12 | Reference | IDN 147 | x | x | x | x
13 | ROD/SSI | Low/High | x | x | x | x
14 | FError_clear |  | x | x | x | x
15 | Start_MT Next |  | x | x | x | x
16 | Start_MT No x |  | x | x | x | x
17 | Start_ MT IO |  | x | x | x | x
18 | Ipeak2x |  | x | x | x | x
19 | Reserved |  |  |  |  |
20 | Start_Jog v=x |  | x | x | x | x
21 | U_Mon.off | High | x | x | x | x
22 | MT Restart |  | x | x | x | x
23 | Start2_MT No x |  | x | x | x | x
24 | Switch over OPMODE |  | x | x | x | x
25 | Zero_latch |  | x | x | x | x
26 | Position Latch | IDN 169 | x | x |  |
27 | Emergency Stop |  | x | x | x | x
28 | Reserved |  |  |  |  |
29 | Reserved |  |  |  |  |
30 | Command Buffer 1 |  | x | x | x | x
31 | Command Buffer 2 |  | x | x | x | x
32 | Brake |  | x | x | x | x
33 | see 30 |  | x | x | x | x
34 | see 31 |  | x | x | x | x
35 | Select Velocity/Current Entry |  | x | x | x | x
36 | Give Offset to Gearing Function |  | x | x | x | x
37 | Change source of actual position at EXTPOS=1 |  | x | x | x | x
38 | Enable signal for following motion task |  | x |  |  |
39 | Constant Speed for defined time |  | x | x | x | x
40 | Additional hardware input (enable) |  | x | x | x | x
41 | Fast emergency stop |  | x | x | x | x


IDN 3003 (P-0-3003) Configurable I/O: Digital Input 4 Mode

Determines the functionality of digital inputs 1 through 4. The digital inputs may be read directly through IDN 3030 through IDN 3033 . The following table describes the functions that are available. A new input mode will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | InxMODE (x = 1, 2, 3, or 4).
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBB

Definition:

INx-Mode | Description | Active Edge | Digital Input
 |  |  | 1 | 2 | 3 | 4
0 | Reserved | – |  |  |  |
1 | Reset |  | x |  |  |
2 | PSTOP | Active low |  |  | x | x
3 | NSTOP | Active low |  |  | x | x
4 | PSTOP+Intg.Off | Active low |  |  | x |
5 | NSTOP+Intg.Off | Active low |  |  |  | x
6 | PSTOP+NSTOP | Active low |  |  | x |
7 | P/NSTOP+Intg.Off | Active low |  |  | x |
8 | SETP.1/SETP.2 |  | x | x | x | x
9 | MT_No_Bit |  | x | x | x | x
10 | Intg.Off | Rising | x | x | x | x
11 | v/Torq.Contr. | Active high | x | x | x | x
12 | Reference | IDN 147 | x | x | x | x
13 | ROD/SSI | Low/High | x | x | x | x
14 | FError_clear |  | x | x | x | x
15 | Start_MT Next |  | x | x | x | x
16 | Start_MT No x |  | x | x | x | x
17 | Start_ MT IO |  | x | x | x | x
18 | Ipeak2x |  | x | x | x | x
19 | Reserved |  |  |  |  |
20 | Start_Jog v=x |  | x | x | x | x
21 | U_Mon.off | High | x | x | x | x
22 | MT Restart |  | x | x | x | x
23 | Start2_MT No x |  | x | x | x | x
24 | Switch over OPMODE |  | x | x | x | x
25 | Zero_latch |  | x | x | x | x
26 | Position Latch | IDN 169 | x | x |  |
27 | Emergency Stop |  | x | x | x | x
28 | Reserved |  |  |  |  |
29 | Reserved |  |  |  |  |
30 | Command Buffer 1 |  | x | x | x | x
31 | Command Buffer 2 |  | x | x | x | x
32 | Brake |  | x | x | x | x
33 | see 30 |  | x | x | x | x
34 | see 31 |  | x | x | x | x
35 | Select Velocity/Current Entry |  | x | x | x | x
36 | Give Offset to Gearing Function |  | x | x | x | x
37 | Change source of actual position at EXTPOS=1 |  | x | x | x | x
38 | Enable signal for following motion task |  | x |  |  |
39 | Constant Speed for defined time |  | x | x | x | x
40 | Additional hardware input (enable) |  | x | x | x | x
41 | Fast emergency stop |  | x | x | x | x


IDN 3004 (P-0-3004) Position Switch Configuration

Extends the functionality of the “Position Switch Points” ( IDN 60 0 through 63). A new position switch configuration will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | SWCNFG
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBC

Definition:

Bit | Description | Setting
LSB 0 | Control of negative SW-Limit switch ( IDN 50 and 55) | 0 = Control switched off 1 = Control active
1 | Reserved. | 0
2 | IDN 50 is working as a SW-Limit switch | 0 = Only report 1 = SW-Limit switched on
3 | Reserved | 0
4 | Control of positive SW-Limit switch ( IDN 49 and 55) | 0 = Control switched off 1 = Control active
5 | Reserved. | 0
6 | IDN 49 is working as a SW-Limit switch | 0 = Only report 1 = SW-Limit switched on
7 | Reserved. | 0
8 | Enable extended function for “Position Switch Point 1” ( IDN 60 ). | 0 = Disabled. 1 = Enabled.
9 | Switch point 1 digital output polarity. Note: A digital output mode ( IDN 3005 or 3006 ) must be set to 14. | 0 = PFB ( IDN 51 ) > IDN 60 1 = PFB ( IDN 51 ) < IDN 60
10 – 11 | Reserved. | 0
12 | Enable extended function for “Position Switch Point 2” ( IDN 61 ). | 0 = Disabled. 1 = Enabled.
13 | Switch point 2 digital output polarity. Note: A digital output mode ( IDN 3005 or 3006 ) must be set to 15. | 0 = PFB ( IDN 51 ) > IDN 61 1 = PFB ( IDN 51 ) < IDN 61
14 – 15 | Reserved. | 0


IDN 3005 (P-0-3005) Configurable I/O: Digital Output 1 Mode

Sets the functionality of the digital outputs. The digital outputs may be read through IDN 3036 and IDN 3037 A new digital output mode will not be active until the parameter set is saved to non-volatile memory and a coldstart or warmstart ( IDN 128 procedure is initiated. The following functions are available:

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | O1MODE, O2MODE
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBD
Definition:
Mode | Description | Logic
0 | Reserved | –
1 | V_act |
2 | V_act>x |
3 | Mains-RTO | High
4 | Regen off | Low
5 | Sw_limit |
6 | Pos.>x |
7 | InPos | High
8 | I_act |
9 | I_act>x |
10 | Ferror |
11 | I2t | High
12 | Posreg.1 |
13 | Posreg.2 |
14 | Posreg.3 | High
15 | Posreg.4 | High
16 | Next-InPos |
17 | Error/Warn |
18 | Error |
19 | DC_Link>x |
20 | DC_Link>x |
21 | ENABLE | High
22 | Zero_pulse | High
23 | Slot-DPR |
24 | Ref_OK | High
25-27 | Reserved |
28 | Posreg.0 |
29 | Posreg.5 |
30 | OR-Operation of all Posreg. |
31-34 | Reserved |
35 | Internal Enable |
36 | Logical OR: DRVSTAT – x |
37 | Logical AND: DRVSTAT – x |
38 | Logical OR: TRJSTAT -x |
39 | Logical AND: TRJSTAT -x |
40 | Logical OR: POSRSTAT -x |
41 | Logical AND: POSRSTAT - x |
42 |  |
43 | The sign of the actual speed |
44 | Velocity In-Position (active high) |
45 | Velocity In-Position (active low) |
46 | Current in Window (low active) |
47 | Current not in Window (low active) |


IDN 3006 (P-0-3006) Configurable I/O: Digital Output 2 Mode

Sets the functionality of the digital outputs. The digital outputs may be read through IDN 3036 and IDN 3037 A new digital output mode will not be active until the parameter set is saved to non-volatile memory and a coldstart or warmstart ( IDN 128 procedure is initiated. The following functions are available:

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | O1MODE, O2MODE
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBE
Definition:
Mode | Description | Logic
0 | Reserved | –
1 | V_act |
2 | V_act>x |
3 | Mains-RTO | High
4 | Regen off | Low
5 | Sw_limit |
6 | Pos.>x |
7 | InPos | High
8 | I_act |
9 | I_act>x |
10 | Ferror |
11 | I2t | High
12 | Posreg.1 |
13 | Posreg.2 |
14 | Posreg.3 | High
15 | Posreg.4 | High
16 | Next-InPos |
17 | Error/Warn |
18 | Error |
19 | DC_Link>x |
20 | DC_Link>x |
21 | ENABLE | High
22 | Zero_pulse | High
23 | Slot-DPR |
24 | Ref_OK | High
25-27 | Reserved |
28 | Posreg.0 |
29 | Posreg.5 |
30 | OR-Operation of all Posreg. |
31-34 | Reserved |
35 | Internal Enable |
36 | Logical OR: DRVSTAT – x |
37 | Logical AND: DRVSTAT – x |
38 | Logical OR: TRJSTAT -x |
39 | Logical AND: TRJSTAT -x |
40 | Logical OR: POSRSTAT -x |
41 | Logical AND: POSRSTAT - x |
42 |  |
43 | The sign of the actual speed |
44 | Velocity In-Position (active high) |
45 | Velocity In-Position (active low) |
46 | Current in Window (low active) |
47 | Current not in Window (low active) |


IDN 3007 (P-0-3007) Configurable I/O: Digital Output 1 Trigger

Sets a help or trigger value to the functionality of the digital outputs (refer to IDN 3005 and P3006).

Sets a help or trigger value to the functionality of the digital outputs (refer to IDN 3005 and IDN 3006 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | OxTRIG
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BBF


IDN 3008 (P-0-3008) Configurable I/O: Digital Output 2 Trigger

Sets a help or trigger value to the functionality of the digital outputs (refer to IDN 3005 and P3006).

Sets a help or trigger value to the functionality of the digital outputs (refer to IDN 3005 and IDN 3006 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | OxTRIG
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BC0


IDN 3010 (P-0-3010) Feedback Type

Sets the motor feedback type. A new feedback type will not be active until the parameter set is saved to non-volatile memory and a coldstart or warmstart ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | FBTYPE
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x8BC2
Definition:
Mode | Function | Comments
0 | Resolver | The 6SM series motors have 2-pole hollow-shaft resolvers. 2, 4 or 6-pole resolvers are supported. Cycle time 62.5 (s.
1 | Reserved |
2 | HIPERFACE( With Zero Pulse | HIPERFACE( compatible feedback interface with a commutation track (e.g. SNS 50 from Stegmann). The rotor position after power-on is transmitted asynchronously as an absolute value to the servo amplifier (error (3(). The axis must be rotated through a full turn in order to evaluate the zero pulse. A reset is not possible during the zeroing movement. The encoder emulation is valid only after the zeroing movement has completed. Cycle time 125 (s.
3 | Resolver, EnDAT oder Hiperface |
4 | EnDat | High-resolution absolute encoder (single or multi-turn) with a EnDat compatible feedback interface (e.g. ECN 1313 or EQN 1325 from Heidenhain). Cycle time 125 (s.
5 | Reserved. |
6 | Sine/Cosine Encoder |
7 | Sine/Cosine Encoder |
8 | RS422 & Wake&Shake |
9 | RS422 Feedback Device; MPHASE is loaded out of the EEPROM |
10 | Without Feedback Device (sensorless) |
11 | Sine encoder feedback with hall’s |
12 | RS422 feedback device with hall’s |
13-15 | Reserved |
16 | Start-up with resolver (commutation), then switch over to Sine/Cosine encoder (FBTYPE=7) |


IDN 3011 (P-0-3011) Encoder Emulation Mode

Sets the signaling format for the encoder emulation on connector X5. A new emulation mode will not become active until the parameter set is saved to non-volatile memory and a coldstart or warmstart ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | ENCMODE
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BC3
Definition:
Mode | Function | Comments
0 | Input | The interface is used as an input.
1 | AqB (ROD) | Incremental encoder emulation. Incremental encoder compatible pulses (max. 250 kHz) are transmitted as two signals (A and B) with a 90( electrical phase difference (quadrature). A zero marker pulse is also transmitted. If an encoder with a commutation track is used, then the output of the zero marker pulse is inhibited until the zero pulse from the encoder has been evaluated.
2 | SSI | Synchronous serial interface (SSI) for absolute encoder emulation. The standard SSI absolute encoder format transmits 24 bits. The upper 12 bits are fixed to zero and the lower 12 bits contain position information. For ‘N’ pole resolver feedback systems, the transmitted position refers to the position within 2/N turns of the motor. If an encoder with a commutation track is used as feedback, then the upper 12 bits are set to 1 (invalid data) until homing is performed.


IDN 3012 (P-0-3012) Difference Probe Edge Value 1

The amount of the difference between two latched values of probe 1 is stored here. Which latched values are used to calculate the edge difference is defined with the IDN 3014 “Probe Difference control parameter”. The value will direct computed when a new value is latched (refer to IDN 3014 .

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: | 0 | Run-Up Check: |
Maximum: | 7FFF FFFFH | Cyclic Transfer: | AT
Default: | 0 | Serial Equiv: |
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BC4


IDN 3013 (P-0-3013) Difference Probe Edge Value 2

The amount of the difference between two latched values of probe 2 is stored here. Which latched values are used to calculate the edge difference is defined with the IDN 3014 “Probe Difference control parameter”. The value will direct computed when a new value is latched (refer to IDN 3014 .

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: | 0 | Run-Up Check: |
Maximum: | 7FFF FFFFH | Cyclic Transfer: | AT
Default: | 0 | Serial Equiv: |
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BC5


IDN 3014 (P-0-3014) Probe Difference Control Parameter

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 6 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x8BC6
Definition:
Value | Description
0 | Difference probe edge function is off
1 | Compute distance between one positive edge and one negative edge
2 | Compute distance between one negative edge and one positive edge
3 | Compute distance between two successive positive edges
4 | Compute distance between two successive negative edges
5 | Compute distance between the first positive and negative edge
6 | Compute distance between the first negative and positive edge


IDN 3015 (P-0-3015) Hardware Limit Switch Consequence

This parameter define the consequence off the Hardware Limit Switch, if the corresponding digital inputs ( IDN 3002 and/or IDN 3003 ) are set to the limit switches. If the hardware limit switch consequence is set to 0, then the Limit switch consequence is a warning. Else if the IDN P3015 is set to 1, then the switch consequence is a fault and the drive ramp down with setting the following fault bits, in IDN 11 bit 15 and in IDN 129 the bit 2. After the reset class 1 diagnostic command ( IDN 99 ) the drive could enable again and move back in the valid range. During the procedure drive controlled homing ( IDN 148 ), the hardware limit switch could use in the normal way (refer to IDN 3027 .

This parameter define the consequence off the Hardware Limit Switch, if the corresponding digital inputs ( IDN 3002 and/or IDN 3003 ) are set to the limit switches. If the hardware limit switch consequence is set to 0, then the Limit switch consequence is a warning. Else if the IDN IDN 3015 is set to 1, then the switch consequence is a fault and the drive ramp down with setting the following fault bits, in IDN 11 bit 15 and in IDN 129 the bit 2. After the reset class 1 diagnostic command ( IDN 99 ) the drive could enable again and move back in the valid range. During the procedure drive controlled homing ( IDN 148 ), the hardware limit switch could use in the normal way (refer to IDN 3027 .

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SERCSET (Bit 0)
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x8BC7


IDN 3016 (P-0-3016) Reset Command Consequence

This parameter define the consequence off the reset class 1 diagnostic command ( IDN 99 ), for faults which require a coldstart. If this IDN is set, faults which require a coldstart will not clear. The reset command will abort with the SC message “Command execution not possible” (refer to IDN 11 , 99 and 129).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SERCSET (Bit 1)
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x8BC8


IDN 3018 (P-0-3018) Configuration of the Positionlatch

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 3018 (P-0-3018) Configuration of the Position latch

This IDN defines, the source of Position information of the latch function, if the digital input 1 and 2 are set for the latch function (IN1MODE = 26 and IN2MODE = 26). If both inputs are select for position latch, with the digital input 2 ( IDN 3031 the Probe 1 function will be support and with the digital input 1 ( IDN 3030 the Probe 1 function will be supported (refer to IDN 169 , 170, 40 and 406). If IN1MODE is different from 26 this IDN IDN 3018 (EXTLATCH) has no function , with an edge at the digital input 2 both (Probe 1 and 2) will be latched.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 2 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | EXTLATCH
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x8BCA
Definition:
IDN 3000 (IN1MODE) NOT_EQUAL 26 IDN P3001 (IN2MODE) = 26 |  | IDN 3000 (IN1MODE) = 26 IDN 3001 (IN2MODE) = 26 |  |
IDN 3031 (IN2) | IDN 3030 (IN1) | IDN 3031 (IN2) | IDN 3030 (IN1) | IDN P3018 (EXTLATCH)
Probe1=Motor Fbk. Probe2=ext. Fbk. | No Latch Function | Probe1 = Motor Fbk. | Probe2=Motor Fbk. | 0
 |  | Probe1 = Motor Fbk. | Probe2=ext. Fbk. (inc. Encoder) | 1
 |  | Probe1=ext. Fbk. (inc. Encoder) | Probe2=ext. Fbk. (inc. Encoder) | 2


IDN 3019 (P-0-3019) Select of the FPGA Program

This IDN select the FPGA program of the drive, which will be download to the FPGA in the initialization.

FPGA = 0: Standard FPGA program

FPGA = 1: Program with Up/Down counter (this allows the usage of a high resolution feedback and Master/ Slave functionality; Program with second counter for latch function on the digital input 1

It exist a third FPGA program, for reading of external SSI encoder as a second encoder. This program is automatically selected if GEARMODE = 7 is selected.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | FPGA
Units: |  | Version: | 5.04
IDN Type: | CT:FS | ADS Index Group (hex.): | 0x8BCB


IDN 3020 (P-0-3020) System Rated Current

Allows setting the rated output current of the drive/motor system.

Data Length: | 4 bytes | Non-Volatile: | yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 10% of IDN 112 . | Run-Up Check: |
Maximum: | Minimum of IDN 111 and IDN 112 . | Cyclic Transfer: |
Default: | 50% of the minimum of IDN 112 . | Serial Equiv: | ICONT
Units: | MA | Version: | 5.04
IDN Type: | CT:FS | ADS Index Group (hex.): | 0x8BCC


IDN 3021 (P-0-3021) Over Speed

The maximum motor speed threshold. If the maximum motor speed is exceeded, then an over speed fault ( IDN 129 , bit 9) occurs.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1.2 * IDN 113 | Cyclic Transfer: |
Default: | 36 000 000 | Serial Equiv: | VOSPD * 10 000
Units: | 0.0 001 RPM | Version: | 5.04
IDN Type: | VE:FS | ADS Index Group (hex.): | 0x8BCD


IDN 3022 (P-0-3022) Quick Deceleration Rate

The drive uses the quick deceleration rate during an active disable (MDT control bit 15, a fault or a limit switch). The quick deceleration limit is defined as the number of milliseconds required to decelerate from the maximum velocity limit ( IDN 38 , 39, 91) to a standstill.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 1 | Run-Up Check: |
Maximum: | 32767 | Cyclic Transfer: |
Default: | 10 | Serial Equiv: | DECSTOP
Units: | IDN 160 , 161, 162 | Version: | 5.04
IDN Type: | AD | ADS Index Group (hex.): | 0x8BCE


IDN 3026 (P-0-3026) Non-Volatile Memory Data Checksum

A checksum of the data stored within non-volatile memory. The checksum is updated after a “Back-up Working Memory” procedure ( IDN 264 ) has been executed successfully.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x8BD2


IDN 3027 (P-0-3027) Manufacturer Homing Modes

Selection of manufacturer defined homing modes. Use IDN 41 , IDN 42 and IDN 147 to set the homing velocity, acceleration and direction. This IDN contains the saved serial command NREF after reset. Write this P IDN or write IDN 147 through the service channel, could change the used homing mode for the drive controlled homing ( IDN 148 ). After or while homing with SERCOS the parameter NREF contains the value of this IDN. A following SAVE command can save this value permanent.

For an explanation of the homing modes 0, 3, 4, 5 and 6 please refer to the Kollmorgen manual “Setup Software SR600.exe for ServoSTAR 600.”

Standard SERCOS homing (mode 1): For an explanation of the standard homing mode, please refer to the IEC 61491 Standard or to the Kollmorgen manual “Setup Software SR600.exe for ServoSTAR 600.” This is the default value also for IDN 147 (refer to IDN 147 ).

Hardware Limit Switch Homing (mode 2): This homing mode uses a hardware limit switch as the home switch. The following diagrams show this homing option, without reference switch, in both the positive and the negative directions of motion with zero mark of the feedback.

Warning: Hardware limit switches must be present and connected. The appropriate limit switch functions must be switched on, i.e. digital input 3 must be PSTOP ( IDN 3002 mode 2) and/or digital input 4 must be NSTOP ( IDN 3003 mode 3).

Mechanical Stop Homing (mode 7): This homing mode uses the mechanical stop instead of a separate homing switch or a hardware limit switch. Set the maximum current (torque) limit through IDN 92 , to limit the torque applied against the mechanical stop. The mechanical stop must be fixed in place and hardware limit switches must be disabled in the direction of the mechanical stop. It is not possible to re-enable or disable hardware limit switches in CP4. When motion toward the stop is no longer possible, the following error increases and triggers a movement back to the first zero mark. The following diagrams show this homing option, in both the positive and the negative directions of motion.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 7 | Cyclic Transfer: |
Default: | 1 | Serial Equiv: | NREF
Units: |  | Version: | 5.04
IDN Type: | PS:VE | ADS Index Group (hex.): | 0x8BD3
Definition:
Mode | Function | IDN 147 (bits 7-0)
0 | Set reference point to the actual position | 1110 0xxx
1 | Traverse to the reference switch with zero-mark recognition | 1000 010x
2 | Move to hardware limit-switch, with zero-mark recognition | 1000 010x
3 | Move to reference switch, without zero-mark recognition | 1100 010x
4 | Move to hardware limit-switch, without zero-mark recognition | 1100 010x
5 | Move to the next zero-mark of the feedback unit | 1010 0xxx
6 | Set reference at actual position, without loosing target position | 1110 0xxx
7 | Move to mechanical stop with zero-mark recognition | 1000 010x
8 | Move to absolute SSI-position |
9 | Move to mechanical stop without zero-mark recognition |


IDN 3030 (P-0-3030) Configurable I/O: Digital Input 1 Status

Reflects the state of a digital input (connector X3 pins 11 - 14) in the least significant bit of the IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BD6


IDN 3031 (P-0-3031) Configurable I/O: Digital Input 2 Status

Reflects the state of a digital input (connector X3 pins 11 - 14) in the least significant bit of the IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BD7


IDN 3032 (P-0-3032) Configurable I/O: Digital Input 3 Status

Reflects the state of a digital input (connector X3 pins 11 - 14) in the least significant bit of the IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BD8


IDN 3033 (P-0-3033) Configurable I/O: Digital Input 4 Status

Reflects the state of a digital input (connector X3 pins 11 - 14) in the least significant bit of the IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BD9


IDN 3034 (P-0-3034) Analog Input 1 Value

Returns the differential voltage at an analog input, which may vary from +10V to -10V. Analog input 1 is located on connector X3 (pins 4 and 5). Analog input 2 is located on connector X3 (pins 6 and 7).

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | ANIN1, ANIN2
Units: | mV | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDA


IDN 3035 (P-0-3035) Analog Input 2 Value

Returns the differential voltage at an analog input, which may vary from +10V to -10V. Analog input 1 is located on connector X3 (pins 4 and 5). Analog input 2 is located on connector X3 (pins 6 and 7).

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | ANIN1, ANIN2
Units: | mV | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDB


IDN 3036 (P-0-3036) Configurable I/O: Digital Output 1 Control/Status

The master may set and read the state of a digital output in the least significant bit of the corresponding digital output control/status IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: | 0 | Serial Equiv: | O1, O2
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDC


IDN 3037 (P-0-3037) Configurable I/O: Digital Output 2 Control/Status

The master may set and read the state of a digital output in the least significant bit of the corresponding digital output control/status IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: | 0 | Serial Equiv: | O1, O2
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDD


IDN 3038 (P-0-3038) Probe 1 and 2 Enable

Used to arm the position capture mechanism for probe 1 and 2 so that the next valid probing signal edge captures the current position into IDN 130 and 132 or 131 and 133. This IDN could only used if the IDN 3039 is set to 1 by the master. IDN IDN 3038 may be assigned to a RTC bit (MDT control word bit 6 or 7) through IDN 301 or IDN 303 . This IDN is write-protected while it is assigned to a RTC bit.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDE


IDN 3039 (P-0-3039) Probe 1 and 2 Control Parameter

The master may use this IDN to configure the probe enable IDNs. If this IDN is set to 0, the master can enable both probes with IDN 405 and 406 and if it is set to 1, the master can enable both probes with IDN 3038 at the same time. The following rules govern the assignment and use of this IDN:

This IDN can not set to 0, if the IDN 3038 is actual assign to a real time control bit through IDN 301 or 303.

This IDN can not set to 0, if the IDN 3038 is actual set to 1.

This IDN can not set to 1, if the IDN 405 or 406 is actual assign to a real time control bit through IDN 301 or 303.

This IDN can not set to 1, if the IDN 405 or 406 is actual set to 1.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDF


IDN 3040 (P-0-3040) Interpolation Method

The master may determine the fine interpolation method within the drive with this IDN. If this IDN is set to 1 the drive work, by a 3 ms and 4 ms cycle time, with a spline interpolation for the command values instead of a liner interpolation.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BE0


IDN 3041 (P-0-3041) Position Switch On/Off Parameter

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | WPOS
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BE1


IDN 3042 (P-0-3042) Position Switch Enable/Disable Parameter

This IDN could use to enable or disable the check of each position switch point for the position switch flag parameter ( IDN 59 ) (refer to IDN 59 , IDN 3041 , 3043 and P3044).

This IDN could use to enable or disable the check of each position switch point for the position switch flag parameter ( IDN 59 ) (refer to IDN 59 , IDN 3041 , 3043 and IDN 3044 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0000H | Run-Up Check: |
Maximum: | 00FFH | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | WPOSE
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BE2
Definition:
Bit | Description | Setting
LSB 0 | Position switch point 1 ( IDN 60 ) | 0 = Disable 1 = Enable Position Switch Flag
1 | Position switch point 2 ( IDN 61 )
2 | Position switch point 3 ( IDN 62 )
3 | Position switch point 4 ( IDN 63 )
4 | Position switch point 5 ( IDN 64 )
5 | Position switch point 6 ( IDN 65 )
6 | Position switch point 7 ( IDN 66 )
7 | Position switch point 8 ( IDN 67 )
8-15 |  | Reserved


IDN 3043 (P-0-3043) Position Switch Polarity Parameter

With this IDN it is possible to select the polarity for each position switch flag to the corresponding flag bit ( IDN 59 ) or the digital output (refer to IDN 59 , IDN 3041 , 3042 and IDN 3044 ).

With this functionality it is possible to implement a cam function with a positive or negative polarity.

Application Example : Positive Cam Function

IDN 60 = 2/8 Revolution IDN 3041 0001Hex IDN 3042 = 0003Hex

IDN 61 = 3/8 Revolution IDN IDN 3043 = 0002Hex IDN 3044 = 0

IDN 3005 = 41 IDN 3007 = 0003Hex

Application Example : Negative Cam Function

IDN 60 = 2/8 Revolution IDN 3041 0001Hex IDN 3042 = 0003Hex

IDN 61 = 3/8 Revolution IDN IDN 3043 = 0001Hex IDN 3044 = 0

IDN 3005 = 40 IDN 3007 = 0003Hex

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0000H | Run-Up Check: |
Maximum: | 00FFH | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | WPOSP
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BE3
Definition
Bit | Description | Setting
LSB 0 | Position switch point 1 ( IDN 60 ) | 0= The flag will set to “1” if the position feedback is greatern than or equal to the position switch point. 1 = The flag will set to “0” if the position feedback value is smaller than the position switching point.
1 | Position switch point 2 ( IDN 61 )
2 | Position switch point 3 ( IDN 62 )
3 | Position switch point 4 ( IDN 63 )
4 | Position switch point 5 ( IDN 64 )
5 | Position switch point 6 ( IDN 65 )
6 | Position switch point 7 ( IDN 66 )
7 | Position switch point 8 ( IDN 67 )
8-15 |  | Reserved


IDN 3044 (P-0-3044) Kind Of Position Switch Parameter

With this IDN it is possible to select the kind of the position check for each position switch flag to the corresponding flag bit ( IDN 59 ) or the digital output (refer to IDN 59 , IDN 3041 , 3042 and P3043).

With this IDN it is possible to select the kind of the position check for each position switch flag to the corresponding flag bit ( IDN 59 ) or the digital output (refer to IDN 59 , IDN 3041 , 3042 and IDN 3043 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0000H | Run-Up Check: |
Maximum: | 00FFH | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | WPOSX
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BE4
Definition:
Bit | Description | Setting
LSB 0 | Position switch point 1 ( IDN 60 ) | 0 = The position check is operating the hole time. 1 = The position flag is check once. The corresponding bit in IDN 59 will set and latched and the corresponding enable bit in IDN 3042 will reset.
1 | Position switch point 2 ( IDN 61 )
2 | Position switch point 3 ( IDN 62 )
3 | Position switch point 4 ( IDN 63 )
4 | Position switch point 5 ( IDN 64 )
5 | Position switch point 6 ( IDN 65 )
6 | Position switch point 7 ( IDN 66 )
7 | Position switch point 8 ( IDN 67 )
8-15 |  | Reserved


IDN 3045 (P-0- 3045)

With this parameter the integral part of the current controller can be loaded. This could be necessary by switching into the operation mode torque control under load, in order to ensure a transition without jerks.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | -1640 | Run-Up Check: |
Maximum: | 1640 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x8BE5


IDN 3046 (P-0- 3046) Motor Number

The command “MNUMBER nr” is used to load a motor data set with the number “nr” from the motor database. If MNUMBER 0 is entered, then no data set will be loaded, but the variable MNUMBER will simply be set to 0. This setting indicates a customer-specific motor data set.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 215 - 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | MNUMBER
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x8BE6


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


AX2000-B750 Overview

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

Overview