AX2000-B110 - EtherCAT interface card for the AX20xx

BECKHOFF Drive Technology

Additional documentation for the AX2000-B110 servo drive

EtherCAT interface for the AX2000

Version: 2.1
Date: 15.10.2007


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger This symbol is intended to highlight risks for the life or health of personnel.

Warning This symbol is intended to highlight risks for equipment, materials or the environment.

Note This symbol indicates information that contributes to better understanding.


AX2000-B110 - Documentation issue status

BECKHOFF AX2000-B110: Foreword

Documentation issue status

Version | Comment
2.1
  • Sequence and parameter are modified in the sub-chapter "Monitoring and operating" of the chapter "TwinCAT"
2.0
  • Firmware and hardware versions added
  • Addition of the sub-chapter “Adaptation of the EtherCAT State Machine” to the chapter “EtherCAT”
  • Addition of the sub-chapter “Monitoring and operation” to the chapter “TwinCAT”
  • Expansion of the PDO mappings
  • Expansion of the actual values by “Actual position value 2”
  • In sub-chapter “Latching”: amendment and expansion of the table “Latch status word” and deletion of the formula to calculate the critical referencing speed
  • Consolidation of the sub-chapters “Commissioning software” and “Default data record” in the chapter “Installation”
  • The sub-chapter “Extended ASCII commands” is deleted from the chapter "EtherCAT functions"
1.1 | First published
1.01 | Preliminary version for internal use

Firmware and hardware versions

Version Documentation | Software version TwinCAT | Firmware version EtherCAT card | Firmware version AX2000
2.1 | 2.10 Build 1313 | SocCOM_T2_PHY_C12_F4_S4_BLD22 | 6.78


AX2000-B110 - Introduction

BECKHOFF AX2000-B110: Product Overview

Introduction

The EtherCAT AX2000-B110 interface card allows servo drives from the AX2000 series to be integrated into an EtherCAT network.


AX2000-B110 - Technical data

BECKHOFF AX2000-B110: Product Overview

Technical data

Technical data | AX2000-B110
Fieldbus | EtherCAT
Transmission rate | 100 Mbaud
Delay | approx. 1 µs
Protocol | EtherCAT
Fieldbus connections | X1 IN: EtherCAT signal input X2 OUT: EtherCAT signal output
Bus connection technology | 2 x RJ45
Data transfer medium | Ethernet CAT-5 cable
Electrical isolation | 500 Vrms (EtherCAT/servo drive)
Distance between 2 modules | max. 100 m (100BASE-TX)
Hardware diagnosis | 4 LEDs: Act In, Act Out, Run, Error
Power supply | From the servo drive
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25°C ... +85°C
Relative humidity | 95% (no condensation)
Dimensions | approx. 140mm x 89mm


AX2000-B110 - Requirements

BECKHOFF AX2000-B110: Installation

Requirements

The following conditions must be satisfied in order to operate a servo drive from the AX2000 series on EtherCAT.

Hardware

Servo drive

Note The AX2090-B110 interface card allows servo drives from the AX2000 series, with serial numbers of 780 266 0000 and above, to be used.
You will find the serial number on the servo drive's type plate.

In addition, a hardware status 29.02 is required as a minimum.
These numbers indicate the production week; the first two numbers are the calendar week, while the last two numbers are the year of production.

The hardware status is printed on the interface board, and can be read through the ventilation slots on the top side of the servo drive.

In this example: 29.02 indicates the 29th calendar week in the year 2002.

The hardware status, firmware version and serial number can also be displayed by the Commissioning software for the AX2000 (Drive.exe, "DriveTool").

Note A firmware version of 6.78 or above must be installed on the servo drive!

EtherCAT AX2090-B110 interface card

The FPGA fitted on the AX2090-B110 interface card must be of Build 22 or higher.
The interface card's FPGA version can be displayed by the TwinCAT System Manager:

TwinCAT

Note You require TwinCAT 2.10 (Build 1313 or above) in order to be able to communicate with the AX2090-B110 interface card.
You will find the current version on our web site at www.beckhoff.de in the area "Download->software->TwinCAT".

Network card

In addition, the TwinCAT EtherCAT driver in your PC requires an Ethernet card with an Intel chipset.


AX2000-B110 - Position of the extension card

BECKHOFF AX2000-B110: Installation

Position of the extension card

EtherCAT AX2090-B110 extension card

The AX2090-B110 extension card is plugged and screwed into the servo drive's extension slot when the AX2000 is shipped.

Position of the plug

The AGND and DGND terminal points on plug X3 must be bridged!

Warning Please note that the plug of the EtherCAT cable from the PC is plugged into socket X1 “IN” and that the signal from socket X2 “OUT” must be fed to socket X1 “IN” on the next AX2000 and so forth up to the last AX2000. If the sockets are mixed up, indefinable states and errors may occur.

Assembly

If the EtherCAT AX2090-B110 interface card has not yet been plugged into your servo drive, install it as follows:

  • Lever out the cover of the option slot using a suitable screwdriver.
    Make sure that no small parts (such as screws) fall down into the open option slot!
  • Push the extension card carefully into the guide rails, making sure that it is not misaligned.
  • Push the extension card firmly down into the slot, until the front cover is level with the fixing plates.
    This ensures that proper contact is made with the connectors.
  • Turn the screws in the front cover to tighten them in the threads of the fixing plates.


AX2000-B110 - Commissioning software

BECKHOFF AX2000-B110: Installation

Commissioning software

The commissioning software for the AX2000 (Drive.exe, "DriveTool ") is described in the Commissioning software documentation for the AX2x00 Servo Drive, which you will find on our website (http://www.beckhoff.de) under Download/Drive Technology.

Default data record

The commissioning software for the AX2000 (Drive.exe, "DriveTool ") does not require any special settings to be made in order to use the EtherCAT AX2090-B110 interface card, provided your AX2000 was supplied with firmware version 6.48 (or higher).

Default data record for older firmware versions

For operation of the AX2090-B110 EtherCAT interface card, if you operate your AX2000 with an older firmware version, you must

  • first update the firmware of the AX2000
  • manually adapt the following parameters of the default data record

The following parameter settings are a basic precondition for proper function of the AX2000 with EtherCAT. You should only deviate from them in exceptional cases.
These parameters should already be loaded if an AX2000 is delivered with firmware version 6.48 or higher; please check for reasons of safety!

Warning If the bus system is converted to EtherCAT or for older devices that are converted to EtherCAT, you must adapt these parameters manually.

Parameters | Default | Description
ANCNFG | -1 | Deactivates analog inputs 1 and 2
ANOUT1 | 0 | Deactivates analog output 1
ANOUT2 | 0 | Deactivates analog output 2
AENA | 0 | Deactivates 'Auto Enable'
WMASK | 8 | Assesses the communication monitoring ("TimeOut") with reference to the error
ACTFAULT | 1 | An emergency halt procedure is initiated in the event of an error
VCOMM | 3600 | Speed threshold for monitoring the commutation error in rpm
BOOT | 0 | Internal controller setting is compiled every time the system boots
UID | 1 | Returns the customer identifier (1: Beckhoff)
DRVCNFG2 | |=6 | Bits 1 and 2 are set as the default data record (=> latch activation by the controller)
EXTWD | 100 | No longer a special Beckhoff parameter, as has been adopted as standard
DRVCNFG | Bit 20 | Only for EtherCAT: bit 20 is set due to CAN compatibility with DS402 V2.0
FPGA | 3 | Only for EtherCAT: EtherCAT/CAN FPGA version
OPMODE | 0 | Digital speed (depending on “operation mode”)
POSCNFG | 0 | Axis type (0 = linear, 1 = rotary, 2 = modular)
PRBASE | 20 | Internal position resolution of the drive (EtherCAT = 20-bit, Lightbus = 16-bit)
SERCSET | 0 | Fieldbus specific settings: 0x00010000 = TRUE - generates an error reset if shifted up from INIT/BOOT 0x00020000 = TRUE - synchronisation error monitoring (F28) is deactivated 0x00080000 = FALSE - generates an error reset via Bit 7 "Fault Reset"

The selection of operating mode (position, speed) is executed automatically by the TwinCAT system manager depending on the choice of process image.


EtherCAT Wiring

The cable length between two EtherCAT devices must not exceed 100 m.

Cables and connectors

For connecting EtherCAT devices only Ethernet cables that meet at least the requirements of category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.

EtherCAT uses RJ45 connectors. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).

Pin | Core coloring | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -

Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

The following Beckhoff cables are suitable for cabling of EtherCAT systems:

  • ZB9010 (industrial Ethernet/EtherCAT cable, fixed installation, CAT5e, 4-wires)
  • ZB9020 (industrial Ethernet/EtherCAT cable, drag chain suitable, CAT5e, 4-wires)
  • ZS1090-0003 (RJ 45 connector, 4-pin, IP 20, for field-assembly)
  • ZS1090-0005 (RJ 45 connector, 8-pin, (GigaBit suitable), IP 20, for field-assembly)
  • ZK1090-9191-0001 (0.17m EtherCAT patch cable)
  • ZK1090-9191-0005 (0.5m EtherCAT patch cable)
  • ZK1090-9191-0010 (1.0m EtherCAT patch cable)
  • ZK1090-9191-0020 (2.0m EtherCAT patch cable)
  • ZK1090-9191-0030 (3.0m EtherCAT patch cable)
  • ZK1090-9191-0050 (5.0m EtherCAT patch cable)

E-Bus supply

Attention 		Attention! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


AX2000-B110 – Diagnostic LEDs

BECKHOFF AX2000-B110: Diagnostics

Diagnostic LEDs

Light-emitting diodes

  • Link / Act IN X1: Indicates activity (Ethernet frame) at the incoming port.
  • Link / Act OUT X2: Indicates activity (Ethernet frame) at the outgoing port.
  • Run: see table
    Run-LED | EtherCAT state
    off | Init
    Flashes at 1 Hz | Pre-Operational
    Flashes at 0.5 Hz | Safe-Operational
    Lit | Operational


AX2000-B110 - Warning messages

BECKHOFF AX2000-B110: Diagnostics

Warning messages

Faults that occur that do not cause the servo drive’s output stage to be switched off (ready for operation contact remains open), are encoded and shown in the form of a warning number on the LED display on the front panel.

Number | Designation | Explanation
n01 | I²t | I²t monitoring threshold exceeded
n02 | Ballast power | Configured ballast power reached
n03* | S_error | Configured following error window exceeded
n04* | Communication monitoring | Communication monitoring (fieldbus) activated
n05 | Mains phase | Mains phase missing
n06* | Sw limit switch 1 | Software limit switch 1 passed
n07* | Sw limit switch 2 | Software limit switch 2 passed
n08 | Travel command error | A faulty travel command has been started
n09 | No reference point | No reference point had been set at the start of the travel command
n10* | PSTOP | PSTOP limit switch triggered
n11* | NSTOP | NSTOP limit switch triggered
n12 | Motor default values loaded | Only ENDAT or HIPERFACE® : Different motor numbers are stored in the encoder and the servo drive; default motor values have been loaded
n13* | Extension card | Extension card is not operating properly
n14 | SinCos feedback | SinCos commutation (wake & shake) not complete; is cleared when the servo drive is enabled and wake & shake is executed
n15 | Table Errors | Fault in the INXMODE 35 speed-current table
n16 | Collective warning | Collective warning for warnings n17..n32
n17 | Synchronisation error | =1: Synchronization is generated when the drive is set for synchronization (SYNCSRC) but has not yet synchronized (e.g. CAN Sync). Obvious reasons for this can, for instance, be that TwinCAT is stopped, or that the drive is only in the “INIT” EtherCAT state. Other, more serious reasons, could be that the real-time jitter in the controller (IPC with TwinCAT) is too large, as a result of which the drive cannot synchronize to the EtherCAT Master (this may be caused by, e.g. an internal graphic card, a USB device, to little main buffer, or interrupt blocking times).
n18 | Multi-turn overflow | An overflow exceeding the maximum number of rotations (+/-2048) has been detected in the multi-turn encoder feedback.
n19-n31 | Reserve |
n32 | Firmware is a beta version | =1: The firmware version has not been released
A | Reset | A reset is being asserted at the DIGITAL INx input

*) These warning messages result in the drive being halted (braking with emergency ramp)


AX2000-B110 - Error messages

BECKHOFF AX2000-B110: Diagnostics

Error Messages

The LED display on the servo drive's front panel displays errors that occur as an error number.
All error messages cause the ready for operation contact to be opened and the servo drive's output stage to be switched off. The motor generates no torque, and the motor's holding brake is applied.

Error number | Designation | Explanation
F01* | Heatsink temperature | Heatsink temperature too high. Limit value set by the manufacturer to 80° C.
F02* | Overvoltage | Overvoltage in DC link. Limit value depends on the mains voltage.
F03* | Following error | Message from position controller
F04 | Feedback | Broken cable, short-circuit, earth short
F05* | Undervoltage | Undervoltage in DC link. Limit value set by the manufacturer to 100V.
F06 | Motor temperature | Temperature sensor faulty or motor temperature too high. Limit value set by the manufacturer to 145°C.
F07 | Auxiliary voltage | Internal auxiliary voltage not correct
F08* | Overspeed | Motor out of control, rotation speed unacceptably high
F09 | EEPROM | The "F09" fault occurs if the checksum for the data and parameters in the EEPROM is not correct (can be caused, for instance, if power is removed from the drive while the parameters are being saved). This error can result either from a faulty EEPROM or from a faulty data checksum. In the second case, the fault can be rectified by saving the data (SAVE) again.
F10 | Flash-EPROM | Checksum error
F11 | Brake | Broken cable, short-circuit, earth short
F12 | Motor phase | A motor phase is missing (broken connection or similar)
F13* | Internal temperature | Internal temperature too high
F14 | Output stage | Fault in the power output stage
F15 | I²t max. | I²t maximum value exceeded
F16* | Mains BTB | Two or three phases are missing from the supply
F17 | A/D converter | Fault in the analog/digital conversion, usually caused by exceptional electromagnetic interference
F18 | Ballast | Ballast circuit faulty, or setting not correct
F19* | Mains phase | Absence of a phase from the supply (can be switched off for operation with two phases)
F20 | Slot error | Slot error
F21 | Handling error | Software error in the extension card
F22 | Earth short | Only for 40/70 amp devices: Earth short
F23 | CAN Bus off | Serious CAN Bus communication error
F24 | Warning | Warning indication is interpreted as an error
F25 | Commutation error | Commutation error
F26 | Limit switch | Reference transit error (hardware limit switch reached)
F27 | AS option | Fault in the operation of the AS option (control of the AS option and the ENABLE signal are present at the same time)
F28 | EtherCAT synchronization error | EtherCAT synchronization error (e.g. jitter, double MDT error)
F29 | EtherCAT configuration error | EtherCAT configuration error (e.g. Sync Manager parameterization)
F30 | Emergency stop timeout | The "F30" error ("Emergency stop timeout") occurs when, in the case of a Stop or of an Emergency stop, the axis cannot physically be brought to a halt within a parameterized time window (default: 5000 ms, see <EMRGTO>) (halt limit <VEL0>: 5 RPM). This error can be triggered if very soft ramps are parameterized in the drive (see <DEC>, <DECSTOP>, <DECDIS>).
F31 | Macro error | Error in the macro programming
F32 | System error | The "F32" error ("System error") indicates an internal error. This error is generated when the servo drive is switched on if it has not been possible to successfully complete the system check during the initialization phase (see the output from the RS232 serial interface for the exact cause of the error). The error can also occur if the servo drive is too heavily loaded when cycle times a very short (see Runtime optimization).

*) These error messages can be cleared with the CLRFAULT ASCII command without carrying out a reset.
If only one of these faults is present, and the Reset button is pressed or the Reset I/O function is used,
then again only the CLRFAULT command will be executed.


AX2000-B110 - EtherCAT operating principle

BECKHOFF AX2000-B110: EtherCAT

EtherCAT operating principle

This supplementary manual describes the extended functional capabilities of the AX2000 with the AX2090-B110 EtherCAT interface. The basic functions, together with general advice on installation and commissioning, are described in the AX2000 manual.

EtherCAT technology overcomes these inherent limitations of other Ethernet solutions: the Ethernet packet is no longer received, then interpreted and copied as process data at every connection. The EtherCAT slave devices read the data addressed to them while the telegram passes through the device. Similarly, input data are inserted while the telegram passes through (see figure). The telegrams are only delayed by a few nanoseconds. Since an Ethernet frame reaches the data of many devices both in send and receive direction, the usable data rate increases to over 90%. The full-duplex features of 100BaseTx are fully utilized, so that effective data rates of > 100 Mbit/s (>90% of 2 x 100 Mbit/s) can be achieved.

Figure: Process data are inserted in telegrams


AX2000-B110 - EtherCAT as a drive bus

BECKHOFF AX2000-B110: EtherCAT

EtherCAT as drive bus

The option of being able to use EtherCAT both for drive applications and for fast I/O signals was one of its main development aims right from the start. In former systems it has only been possible to implement short cycle times offering high synchronicity, as are required for control loops that are closed by the bus, with the aid of special "drive buses" such as CANopen.

Special drive technology requirements

  • Cycle time
  • Synchronicity
  • Simultaneity

Typical values for the necessary cycle times lie between 1 and 4 milliseconds when position is specified cyclically, with position control in the drive. Drive technology frequently specifies a microsecond as an adequate requirement for synchronicity. Whereas the synchronicity specifies the temporal jitter in the processing of functions by the devices involved (drive and controller), simultaneity defines the size of the temporal delay involved with these functions. Synchronicity is important for the individual devices, so that their own subordinate control loops can synchronise with the cyclic signal with the required precision. Simultaneity moreover enables distributed devices to work on a common task with absolutely identical timebase.

Figure 1: Cycle time, synchronicity and simultaneity

Distributed clocks - Properties of the EtherCAT slave controller

In order to control synchronization, EtherCAT takes an approach based on what are known as "distributed clocks": All devices have an independent clock as a basis for running local cycles and events. The crucial factor is that all clocks run at the same speed and have the same base time. A special control integrated in the EtherCAT Slave Controller (ESC) ensures that all clocks are guided by a reference clock and are synchronized irrespective of temperature and production tolerances.

Figure 2: Distributed clocks

Topology

Line, tree or star: EtherCAT supports almost any topology (see figure). The bus or line structure known from the fieldbusses thus also becomes available for Ethernet. Particularly useful for system wiring is the combination of line and branches or stubs: the required interfaces exist on the couplers; no additional switches are required. Naturally, the classic switch-based Ethernet star topology can also be used.
Wiring flexibility is further maximized through the choice of different cables. Flexible and inexpensive standard Ethernet patch cables transfer the signals optionally in Ethernet mode (100Base-TX) or in E-bus signal representation. Plastic optical fibers (POF) complement the system for special applications. The complete bandwidth of the Ethernet network - such as different optical fibers and copper cables - can be used in combination with switches or media converters. The Fast Ethernet physics enables a cable length of 100 m between two devices, the E-bus line is intended for distances of up to 10m. For each cable distance, the signal variant can be selected individually. Since up to 65535 devices can be connected, the size of the network is almost unlimited.

Figure 3: Flexible topology: line, tree or star


AX2000-B110 - Multi-protocol capability

BECKHOFF AX2000-B110: EtherCAT

Multi-protocol capability

Further important criteria for a fieldbus system that is to support drive technology are the communications protocol and profile used, which are responsible for compatibility and efficient data exchange between the controller and the drive. Instead of re-inventing the wheel, EtherCAT uses proven technology for this purpose.

None of the available protocols on their own support all communication requirements of modern fieldbusses (process data, parameter data, parallel TCP/IP, firmware updates, routing to subordinate bus systems, etc.). EtherCAT therefore introduces multi-protocol capability, consolidating the different protocols in a standardized mailbox. This enables quick and full conversion of existing devices to EtherCAT.

The CANopen over EtherCAT (CoE) and Servo Profile over EtherCAT (SoE) protocols are relevant for drive technology; they make it possible to combine the advantageous transmission properties of EtherCAT with proven, profile-specific drive functions.

The Ethernet over EtherCAT (EoE) and File Access over EtherCAT (FoE) protocols provide options for integrating a web server in the drive, for example, or for efficiently exchanging firmware or cam plate tables via the bus.


AX2000-B110 - CANopen over EtherCAT

BECKHOFF AX2000-B110: EtherCAT

CANopen over EtherCAT

The CANopen over EtherCAT (CoE) protocol enables the complete CANopen profile family to be utilized via EtherCAT. The SDO protocol is used directly, so that existing CANopen stacks can be used practically unchanged. Optional extensions are defined that lift the 8-byte limit and enable complete readability of the object list.

The process data are organized in process data objects (PDO), which are transferred using the efficient means of EtherCAT - naturally without 8-byte limit. All CANopen profiles - including the drive profile (DS 402) - are fully usable, and devices based on it can be transferred to EtherCAT very easily.

Apart from a few details, the EtherCAT state machine of the slave corresponds to the CANopen state machine, so that only a limited number of changes are required. In order to enable less ambiguous start-up behavior, a further state called "safe operational" is defined, to which inputs that are already valid are transferred, while the outputs remain in safe state.

The AX2000 contains the CANopen profile, in order to implement the technical drive functions:

  1. There are 8 fixed PDO configurations. No other information can be configured in the cyclic data exchange. The PDO configurations are to be considered as "constant configurations".
  2. If other information is required, this can only be read and written asynchronously via ADS (entirely normal CAN objects). Almost every item of information is available as a CAN object (SDO): see examples in the appendix, e.g. the drive's error codes or warnings etc.).
  3. Resolver: one motor rotation has a fixed 20 bit resolution
    (see ASCII parameter <PRBASE> equal to 20).

State machine

EtherCAT State-machine

Drive State-machine based on CANopen (DS402)

Drive State-machine based on CANopen (DS402)


EtherCAT State Machine

The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.

A distinction is made between the following states:

  • Init
  • Pre-Operational
  • Safe-Operational and
  • Operational
  • Boot

The regular state of each EtherCAT slave after bootup is the OP state.

Init

After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.

Pre-Operational (Pre-Op)

During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.

In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.

Safe-Operational (Safe-Op)

During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).

In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.

Operational (Op)

Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.

In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.

Boot

In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.

In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


AX2000-B110: Adaptation of the EtherCAT State Machine

BECKHOFF AX2000-B110: EtherCAT functions

Adaptation of the EtherCAT State Machine

The adaptation of the states of the EtherCAT Slaves is described in the following section. The general descriptions of the states in the chapter “EtherCAT State Machine” are still valid and have merely been added to.

  • Init
  • Pre-Operational
  • Safe-Operational
  • Operational
  • Boot

Init

No addition.

Pre-Operational (Pre-Op)

A soft reset of non-fatal errors is executed by the drive device.

Safe-Operational (Safe-Op)

Switch-over from Safe-Op to Operational takes place on request; synchronisation takes place beforehand. In the event of a synchronisation error (e.g. double MDT error) operation reverts to Safe-Op.

Operational (Op)

No addition.

Boot

No addition.


AX2000-B110 - Linking into the System Manager

BECKHOFF AX2000-B110: Configuration in TwinCAT

Linking into the System Manager

Because of the automatic mechanisms that are present, it is advisable to begin the configuration by inserting the I/O devices.

Reference to Information System -> System Manager -> Appendix C
If the master has been properly installed, it appears as a usable device.

The configuration that has been created is then switched into config mode, and a scan is made for connected boxes. Those devices that are connected are addressed by the master in accordance with their sequence in the ring. If an axis is detected, the System Manager offers the option of adding an NC axis and creating the corresponding link.

I/O level: Selecting the process image

Setpoint contents (outputs from the point of view of the master) can be selected as follows: AX2000-B110 Process Data tab under Sync Manager Outputs. The selected PDO can be seen in the PDO assignment window. A new selection is not possible until the configuration that had previously been established is deselected. Both inputs and outputs can be selected in the PDO list window. The content of the PDOs is then displayed in the PDO Content window.

In the default state, the PDO assignment is linked to object number 0x1702 (set values) and object number 0x1B03 (actual values).

Interfaces

Position interface

Address | Description
0x1701 | Position setpoint, control word (6 bytes) | DINT 32 bit position (20 bits/rotation)
0x1B01 | Actual position value, status word (6 bytes) | DINT 32 bit position (20 bits/rotation)

Speed Interface (default mapping)

Address | Description
0x1702 | Speed setpoint, control word (6 bytes) | DINT 32 bit speed (rotation/139Inc)
0x1B01 | Actual position value, status word (6 bytes) | DINT 32 bit position (20 bits/rotation)

Torque interface

Address | Description
0x1703 | Torque setpoint, control word (4 bytes) | INT 16 bit torque setpoint (peak current -> 3280 Inc)
0x1B03 | Actual position value, actual torque value, status word (8 bytes) | INT 16 bit torque setpoint (peak current -> 3280 Inc)

Position, speed and torque interface with operating mode changeover

Address | Description
0x1704 | Position setpoint, speed setpoint, torque setpoint, operating mode request, control word (14 bytes) | Operating mode request object 0x6060
0x1B04 | Actual position value, actual torque value, operating mode feedback, status word (10 bytes) | Feedback of the selected operating mode 0x6061

Position and speed Interface with “Torque” extension package

Address | Description
0x1705 | Position setpoint, speed setpoint, additive torque setpoint, torque limit, control word (14 bytes)
0x1B05 | Actual position value, actual torque value, drive following error, status word (12 bytes)

Position and speed Interface with “Latching” extension package

Address | Description
0x1706 | Position setpoint, speed setpoint, control word, latch control word (12 bytes) | The latch control word is described in the Some important objects section
0x1B06 | Actual position value, status word, latch status word, latch position (12 bytes) |

Position, speed and torque interface

with operating mode changeover and with “Latching” extension package (not yet implemented!)
Address | Description
0x1707 | Position setpoint, speed setpoint, torque setpoint, operating mode request, control word, latch control word (16 bytes)
0x1B07 | Actual position value, actual torque value, operating mode feedback, status word, latch status word, latch position (16 bytes)

Position, speed and torque interface

with operating mode changeover and with the “Torque” and “Latching” extension packages
Address | Description
0x1708 | Position setpoint, speed setpoint, torque setpoint, torque limit, operating mode request, control word, latch control word (18 bytes)
0x1B08 | Actual position value, actual torque value, drive following error, operating mode feedback, status word, latch status word, latch position (20 bytes)

Start-up list

The user is able to save slave-related settings in this region of the configuration. This list is loaded into the servo drive every time there is a transition from the PREOP to the SAVEOP state.

These entries are generated by the System Manager. The first 6 entries save the process image in the Sync Manager. The seventh entry specifies the controller’s operating mode:

Operation mode | Digital speed | Torque, digital | Ext. trajectory
Value | 0xFE | 0xFD | 0xFA

The two last entries specify the cycle time. In this case it is 1*10-2 seconds.

NC level

No further settings need to be made after the inputs and outputs have been linked with the Box (AX2000-B110). The typical NC settings for the scaling factor, maximum speed, software limit switches and so forth are to be carried out according to the Information System.


AX2000-B110 - Monitoring and operation

BECKHOFF AX2000-B110: Configuration in TwinCAT

Monitoring and operation

A PLC program must monitor the operating state of the drives and if necessary put them in an error-free state, ready for operation. This state is attained if the following conditions are satisfied:

  • The EtherCAT Master and all participating EtherCAT Slaves must be in the OPERATIONAL (OP) state.
  • The drive devices must not be in an error state, but must be ready for operation.

In order to satisfy the above-mentioned conditions, the PLC program must execute the following steps:

  1. IO (fieldbus):
    Read the I/O device’s hardware address associated with the NC axis.
    - Read the address of the I/O device such as NetId, Port, ChannelNo, etc. by means of FB_GetAxisAmsAddr (TcNc-Lib).
    (The data is required for EtherCAT function block).
  2. IO (fieldbus):
    Check the EtherCAT communication
    - Monitor the EtherCAT Master state by means of FB_EcGetMasterState (TcEtherCAT-Lib).
    - Monitor the EtherCAT Slave state by means of FB_EcGetSlaveState (TcEtherCAT-Lib).
    - Change the EtherCAT Master state by means of FB_EcSetMasterState (TcEtherCAT-Lib).
    - Change the EtherCAT Slave state by means of FB_EcSetSlaveState (TcEtherCAT-Lib).
  3. IO (fieldbus):
    Optional evaluation of the EtherCAT WorkingCounter
    - Evaluation of the EtherCAT WorkingCounter by additional mapping from the I/O device to the PLC (cyclic communication)
  4. Drive:
    Check the drive status with regard to errors, warnings and notices (Drive State Machine)
    - Read the current drive error F01 to F32 (see ASCII command ERRCODE) by means of PDO 0x2070 (SubIndex: 0x16, Data: UINT32)
    - Read the current drive status, e.g. warnings n01 to n32 (see ASCII command STATCODE) by means of PDO 0x385E (SubIndex: 0x1, Data: UINT32)


AX2000-B110 - Latching

BECKHOFF AX2000-B110: EtherCAT functions

Latching

The following steps must be carried out for the "flying measurement" function.

  • Selection of the process image (0x1706 & 0x1B06) under the box (AX2000-B110) process data: The link is modified automatically.
  • The latch function (IN1MODE 26) is activated at digital input 1 by means of the Drive Tool.
  • The MC function block MC_TouchProbe is used in the PLC project (TC_MC.lib)

See the Latching appendix for further explanations.


AX2000-B110 - hardware-oriented referencing

BECKHOFF AX2000-B110: EtherCAT functions

Hardware-oriented referencing

A choice can be made from the following reference modes in the NC when the "CANopen DS402" axis type is selected:

Type | Cam | Zero pulse
Default | Required | No zero pulse. Referencing is carried out at the negative edge of the cam.
PLC CAM | Required | No zero pulse. Referencing is carried out at the negative edge of the cam.
Hardware Sync | Required | In this procedure, the zero pulse of the measuring system is used for latching. The latched value is converted to the position in the NC. This procedure requires process image 0x1706 & 0x1B06. Suitable encoders: SinCos with a physical zero mark.
Hardware Latch Pos | Required | In this procedure, latching is carried out in response to digital input 1 (positive edge) of the controller. The latched value is converted to the position in the NC. This procedure requires process image 0x1706 & 0x1B06. Suitable encoders: Any
Hardware Latch Neg | Required | In this procedure, latching is carried out in response to digital input 1 (negative edge) of the controller. The latched value is converted to the position in the NC. This procedure requires process image 0x1706 & 0x1B06. Suitable encoders: Any
Software Sync | Required | In this procedure, it is assumed that an absolute single-turn measuring system is being used. The zero pulse is generated in the NC when the encoder overruns. Suitable encoders: resolver, single-turn.


AX2000-B110 - Torque limiting

BECKHOFF AX2000-B110: EtherCAT functions

Torque limiting

If the process requires positioning with a reduced torque, the following settings should be made.

  • Selection of the process image (0x1705 & 0x1B05) under the box (AX2000-B110): The link is modified automatically.
  • The parameter DILIM is set to 1 in the drive using the Drive Tool.
  • In the PLC project, the variable MaxTorq from the controller's process image is limited to the maximum current. Scaling of the specification: the controller's peak current corresponds to 3280 increments.


AX2000-B110 - Important objects

BECKHOFF AX2000-B110: EtherCAT functions

Important objects

These can only be read acyclically (SDO)

Address | Description
1C12 (SI: 1) | "Sync Manager 2 PDO Communication Type" (Master Output, ARRAY OF UNSIGNED16)
1C13 (SI: 1) | "Sync Manager 3 PDO Communication Type" (Master Input, ARRAY OF UNSIGNED16)
1002 (SI: 0) | Current drive status ("Manufacturer Status Register", "DRVSTAT", SubIndex: 0h, UINT32) (equivalent to object 352D, SubIndex: 1h, UINT32)
385E (SI: 1) | Current drive warnings (“STATCODE”, SubIndex: 1h, UINT32) (from FW 6.68)
2070 (SI: 11) | Status of digital inputs ("Extended Status for TX-PDO 33", SubIndex: 11h, UINT32) bits 0..3: digital inputs 1..4; bit 4: "Hardware Enable"
2070 (SI: 16) | Current drive error ("ERRCODE", SubIndex: 16h, UINT32) (equivalent to object 385D, SubIndex: 1h, UINT32)
2080 (SI: 1) | Status of the digital outputs ("Input/Output/Latch", SubIndex: 1h, UINT8) bits 0..3: digital inputs 1..4; bits 4..5: digital outputs 1..2, bits 6..7: latch inputs 1..2
35D1 (SI: 1) | Internal position resolution of the Drive (e.g. 20 dec or 16 dec) ("PRBASE", SubIndex: 1h, UINT32)
35AE (SI: 1) | Write the digital output 1 ("O1", SubIndex: 1h, UINT8/UINT32), if "O1MODE" equals zero.
35B1 (SI: 1) | Write the digital output 2 ("O2", SubIndex: 1h, UINT8/UINT32), if "O2MODE" equals zero.
35EB (SI: 1) | "SAVE" saves the parameters in EEPROM (SubIndex: 1h, UINT32, value: 0).
363A (SI: 1) | "BCC" returns the checksum for the parameter region of the EEPROM (SubIndex: 1h, UINT16).
3632 (SI: 1) | "COLDSTART" causes a hardware reset in the drive (SubIndex: 1h, UINT32, value: 0).
36E4 (SI: 1) | Drive configuration for supplementary functions ("DRVCNFG2", SubIndex: 1h, UINT32)
- | "STATCODE" is not available as an SDO!


AX2000-B110 - Priorities for the transfer of setpoint values in the AX2000

BECKHOFF AX2000-B110: EtherCAT functions

Priorities of the set values

 | Description | Data type | PDO | DPR no. | NC assignment / remark
A | Position setpoint | UINT32 | 0x6062 | 1003 | Drv->Out->nOutData1
B | Speed setpoint | INT32 | 0x606B | 1007 | Drv->Out->nOutData2
C | Current setpoint | INT16 | 0x6074 | 1002 | Standardised to 3280 digits from DIPEAK
D | Additive current setpoint | INT16 | 0x60F6[1] | 1036 |
E | Torque limit (2 ms*) | UINT16 | 0x6072 | 1039 |
F | Operating mode request (2 ms*) | UINT16 | 0x6060 | 180 |
G | Control word (2 ms*) | UINT16 | 0x6040 | 1000 | Drv->Out->nCtrl1/nCtrl2
H | Latch control word (2 ms*) | UINT16 | 0x2802 | 1035 | Enc->Out->nCtrl1/nCtrl2 (see below)

* Update times: PDO 1-5 with 2 ms, PDO 6 with 1 ms, PDO 7-8 with 4 ms


AX2000-B110 - Priorities of the actual values

BECKHOFF AX2000-B110: EtherCAT functions

Priorities of the actual values

 | Description | Data type | PDO | DPR no. | NC assignment / remark
A | Actual position value | UINT32 | 0x6064 | 200 | Enc->In->nInData1
B | Actual position value 2 | UINT32 | 0x35C9 | 201 | Enc2->In->nInData1
C | Actual current value | INT16 | 0x6077 | 88 | Standardised to 3280 digits from DIPEAK
D | Drive following error | INT32 | 0x60F4 | 197 | Drv->In->nInData1
E | Operating mode (2 ms*) | UINT16 | 0x6061 | 1038 |
F | Status word (2 ms*) | UINT16 | 0x6041 | 1004 | Drv->In->nStatus1/nStatus2
G | Latch status word (2 ms*) | UINT16 | 0x2901 | 1037 | Enc->In->nStatus1/nStatus2
H | Latch value (2 ms*) | UINT32 | 0x2902 | 1022 | Enc->In->nInData2 (see below)
I | WorkingCounter (WcState) | BOOL |  |  | Drv/Enc->In->nStatus4

(*) Update times: PDO 1-5 with 2 ms, PDO 6 with 1 ms, PDO 7-8 with 4 ms


AX2000-B110 - Recommended cycle times

BECKHOFF AX2000-B110: EtherCAT functions

Recommended cycle times

(Depending on operating mode - runtime optimisation)

The minimum cycle time depends heavily on the drive configuration (second encoder, latching). If at all possible, the following settings should be made in order to reduce the loading on the servo drive:

  • The drive's analog output values should be deactivated wherever possible (ANOUT1=0, ANOUT2=0, ANCNFG=-1).
  • If possible, the following parameters should be set to zero: (IN1MODE to IN4MODE, O1MODE, O2MODE, SWCNFG, POSCNFG, WPOS).
Interface | Recommended cycle time | Minimum cycle time
Position | 2 ms (= 2000 µs) | 1 ms
Speed | 1 ms (= 1000 µs) | 0.5 ms
Torque | 0.5 ms (= 500 µs) | 0.5 ms


AX2000-B110 - Latching

BECKHOFF AX2000-B110: Appendix

Latching

Latch control word (2 bytes)

(Encoder->Outputs->nCtrl1 and Encoder->Outputs->nCtrl2):

Bit | Value (bin) | Value (hex) | Description
0 | 00000000 00000001 | xx01 | Enable external latch 1 (positive rise) through the Touch Probe block
1 | 00000000 00000010 | xx02 | Enable external latch 1 (negative rise) through the Touch Probe block
2 | 00000000 00000100 | xx04 | Enable external latch 2 (positive rise) - NOT IMPLEMENTED
3 | 00000000 00001000 | xx08 | Enable external latch 2 (negative rise) - NOT IMPLEMENTED
4 | 00000000 00010000 | xx10 | Enable internal latch C (positive rise) through the MC_Home block
5-7 | - | - | reserved
8-12 | 00000001 00000000 | 01xx | Read external latch 1 (positive rise) through the Touch Probe block
 | 00000010 00000000 | 02xx | Read external latch 1 (negative rise) through the Touch Probe block
 | 00000011 00000000 | 03xx | Read external latch 2 (positive rise) - NOT IMPLEMENTED
 | 00000100 00000000 | 04xx | Read external latch 2 (negative rise) - NOT IMPLEMENTED
 | 00000101 00000000 | 05xx | Read internal latch C (positive rise) through the MC_Home block
13-15 | - | - | reserved

Latch status word (2 bytes)

Bit | Value (bin) | Value (hex) | Description
0 | 00000000 00000001 | xx01 | External latch 1 valid (positive rise) through the Touch Probe block
1 | 00000000 00000010 | xx02 | External latch 1 valid (negative rise) through the Touch Probe block
2 | 00000000 00000100 | xx04 | External latch 2 valid (positive rise) - NOT IMPLEMENTED
3 | 00000000 00010000 | xx08 | External latch 2 valid (negative rise) - NOT IMPLEMENTED
4 | 00000000 00010000 | xx10 | Internal latch C valid (positive rise) through the MC_Home block
5-7 | - | - | reserved
8-11 | 00000001 00000000 | 01xx | Acknowledge value external latch 1 (positive rise) through the Touch Probe block
 | 00000010 00000000 | 02xx | Acknowledge value external latch 1 (negative rise) through the Touch Probe block
 | 00000011 00000000 | 03xx | Acknowledge value external latch 2 (positive rise) - NOT IMPLEMENTED
 | 00000100 00000000 | 04xx | Acknowledge value external latch 2 (negative rise) - NOT IMPLEMENTED
 | 00000101 00000000 | 05xx | Acknowledge value internal latch C (positive rise) through the MC_Home block
12-15 | 00010000 00000000 | 1xxx | Digital input 4 *
 | 00100001 00000000 | 2xxx | Digital input 3 *
 | 01000001 00000000 | 4xxx | Digital input 2 *
 | 10000001 00000000 | 8xxx | Digital input 1 *

*) from AX2000 FW 6.68 and TwinCAT 2.10 Build 1308

Guide value, if the latch input is used for referencing: 1 % of the motor nominal speed


AX2000-B110 - Firmware update

BECKHOFF AX2000-B110: Appendix

Firmware Update

Warning The supply voltage must not be interrupted during a firmware update!

AX2000 Firmware

The firmware of the AX2000 can be updated with the Drive CAN Download Tool as follows:

AX2090-B110 Interface

For future updates, new firmware can be loaded as follows:


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com