AS10x0 - 2-phase stepper motors

BECKHOFF Drive Technology

Documentation

2-phase stepper motors - AS1010, AS1020, AS1030, AS1050 and AS1060

Version: 2.2
Date: 2010-09-06


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards. It is essential that the following notes and explanations are followed when installing and commissioning these components.

Liability Conditions

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

The documentation has been prepared with care. The products described are, however, constantly under development. For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics. None of the statements of this manual represents a guarantee (Garantie) in the meaning of § 443 BGB of the German Civil Code or a statement about the contractually expected fitness for a particular purpose in the meaning of § 434 par. 1 sentence 1 BGB. In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning. No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Copyright

© This documentation is copyrighted. Any reproduction or third party use of this publication, whether in whole or in part, without the written permission of Beckhoff Automation GmbH, is forbidden.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger This symbol is intended to highlight risks for the life or health of personnel.

Warning This symbol is intended to highlight risks for equipment, materials or the environment.

Note This symbol indicates information that contributes to better understanding.


AS10x0 - Guidelines and Standards

BECKHOFF AS10x0: Foreword

Guidelines and Standards

European Guidelines and Standards

Stepper motors are components intended to be fitted into electrical equipment/machines used in industry. When stepper motors are fitted into machines or equipment, it is forbidden to commence their operation in accordance with their specifications until it has been determined that the machine/equipment accords with the specifications of the EC Machinery Directive (98/37/EC), the EC EMC Directive (89/336/EEC) and the EC Low Voltage Directive 73/23/EEC.

The following standards are to be applied in order to observe the EC Machinery Directive (98/37/EC):

  • EN 60204-1 (Safety of machinery - Electrical equipment of machines)
  • EN 292 (Safety of machinery)
Danger The machine manufacturer must prepare a hazard analysis for the machine, and must take appropriate measures to ensure that unexpected movements can not lead to injury to persons or to material damage.

The manufacturer of the equipment/ machine is responsible for observing the limit values for the equipment/ machine required by the statutes governing EMC. Beckhoff stepper motors are not subject to the EMC Directive, because they are operated with a maximum of 50 VDC.

Danger The manufacturer of the machine/equipment must check whether his machine/equipment is subject to further or other standards or EC directives.

CE conformity

The following European Union standards and regulations must be checked, and applied if necessary, in order to achieve CE conformity:

  • EC Machinery Directive (98/37/EC):
    The standard versions of Beckhoff AS1000 series stepper motors are exclusively intended to be mounted in other machines. It is therefore necessary to check, before operation commences, that the machine into which the stepper motors have been fitted accords with the specifications of the 98/37/EC version of the EC Directive.
  • EMC Emission and Immission:
    It can be assumed that stepper motors, because they are operated with a maximum of 50 VDC at the Beckhoff KL2531/41 stepper motor terminal, neither emit interference nor are affected by incoming interference.
  • Low Voltage Directive 27/23/EEC, 93/68/EEC:
    The Low Voltage Directive is applied when voltages are greater than 50 VAC or 75 VDC. Beckhoff stepper motors are only operated, together with the Beckhoff KL2531 and KL2541 stepper motor terminals, in the range from 24 VDC up to a maximum of 50 VDC, and therefore are not subject to the Low Voltage Directive.


AS10x0 - Documentation Issue Status

BECKHOFF AS10x0: Foreword

Documentation Issue Status

Version Comment
2.2

Update:

  • Product description --> Dimensions
  • Installation and Operation --> Installation
            •
    2.1

    Update:

  • Product description --> Fittings and properties
  • Product description --> Technical data
  • Product description --> Dimensions
  • Product description --> Accessories
  • Installation and Operation --> Installation
            •
    2.0

    Only german language
    1.2
    • Rotation speed-torque curves
    1.1
    • technical data extended
    • technical drawings added
    1.07
    • First releas


AS10x0 - General description

BECKHOFF AS10x0: Product Description

General description

Stepper motors are synchronous motors with a high number of poles, which can therefore be regarded as direct drives. Advantages include high holding torque and very good positioning capability. Intelligent drive of the stator windings, in full stepping or micro-stepping mode, permits either single or partial steps to be made directly, without using a feedback system. This feature distinguishes stepper motors from servo-motors, thus representing a cost-effective alternative approach. It is, nevertheless, possible that if the acceleration is too high, or if the load changes too fast, the stepper motor may fail to follow the rotating field, and therefore "loses steps". The encoder option can improve matters in this situation.

Stepper motor have their maximum torque in the lower speed range, and an overriding holding torque at standstill. In many applications this makes a holding brake unnecessary. A matching current curve can be stored in the Beckhoff stepper motor terminals for every rotary speed or load profile, in order to adjust the thermal stress on the motor to an optimum.

Beckhoff stepper motors are used as actuators or auxiliary axes in machine construction and automation applications. Together with the KL2531 and KL2541 stepper motor terminals and the Beckhoff TwinCAT automation system, it is therefore very easy to incorporate cost-effective axes into the total application.

In order to simplify the electrical connection, the stepper motors are equipped with pre-assembled plug connectors. Planetary gear units, incremental encoders and pre-assembled connection cables are available as accessories.


AS10x0 - Bestimmungsgemäße Verwendung

BECKHOFF AS10x0: Product Description

Appropriate use

The AS1000 stepper motors are fitted into electrical equipment or machines as components, and their operation is only permitted as integrated components of the equipment as a whole.

Danger The machine manufacturer must prepare a hazard analysis for the machine, and must take appropriate measures to ensure that unexpected movements can not lead to injury to persons or to material damage.

The stepper motors may be operated on the following DC voltage supplies:

24 V DC to 50 V DC

Only connect them using copper wires. The cable cross-sections may be found from the EN 60204 standard (or Table 310-16 of the NEC 60°C or 75°C column for AWG cross sections).

We can only guarantee conformity of the stepper motor system with the standards mentioned above if Beckhoff components (stepper motor terminals, stepper motors, cables etc.) are used exclusively.

Permitted environmental conditions, ventilation, mounting positions

Environmental conditions, ventilation, mounting positions
Insulation class | class B (130°C)
Temperature change at rated current | max. 80 K
Insulation resistance | ≥ 100 MΩ
Permissible ambient temperature (operation) | -10°C to +50°C
Permissible ambient temperature (transport/storage) | -25°C to +70°C
Permissible air humidity | 20% to 90%, non-condensing
Permissible degree of contamination | contamination level 2 according to EN60204/ EN50178
Corrosion protection | Under extreme operating conditions, special measures must be agreed with the manufacturer, and implemented by the user.
Permitted operating altitude | up to 1000 m above sea level
Max. cable length between motor and terminal | 10 m
Special operating conditions | The usability of the Beckhoff AS1000 stepper motor under more difficult operating conditions, or when other unfavorable environmental conditions are present, must be established on a case-by-case basis, and agreed between the manufacturer and the user.
Permissible installation position | horizontal or vertical
Ventilation | Free ventilation of the motors must be ensured.
Protection class | AS1010 - AS 1050: IP43 AS1060: IP20
Approvals | CE


AS10x0 - Fittings and properties

BECKHOFF AS10x0: Product Description

Fittings and properties

Type plate

The type plate is attached to the side of the stepper motor, and contains the following information:

Type key

AS10uv-wxyz
uv | Size
w | 0 = smooth shaft, 1 = keyway
x | 0 = 1 shaft, 1 = 2nd shaft end 6 mm
y | 0 = no feedback, 1 = incremental encoder 24 VDC
z | 0 = standard, 1.. special versions

Scope of supply

An AS1000 is supplied with:

  • The AS1000 of whatever power class was ordered
  • Connection cable with 4-pin M12 plug
  • Online documentation at http://www.beckhoff.com
Note The mating M12 connectors are not included!

The following additional accessories can be ordered:

  • Second shaft end for the AS1020, AS1050 and AS1060
  • Encoder with connection cable and 5-pin, screened M12 socket
  • Motor and feedback cable (configured and assembled)
  • Planet gears


AS10x0 - Technical data

BECKHOFF AS10x0: Product Description

Technical data

Technical data | AS1010 | AS1020 | AS1030 | AS1050 | AS1060
Rated supply voltage [VDC] | 24 - 50
Rated current [A / phase] | 1.00 | 1.0 | 1.5 | 5.0 | 5.0
Static torque Mo [Nm] | 0.38 | 0.5 | 0.6 | 1.2 | 5.0
Coil resistance [Ω / phase] | 4.10 | 4.80 | 0.80 | 0.28 | 0.36
Coil inductance [mH/ phase] | 9.50 | 9.50 | 3.80 | 0.86 | 2.80
Rotor moment of inertia [kg cm²] | 0.056 | 0.074 | 0.21 | 0.36 | 3.0
Resolution [° or steps] | 1.8° / 200 full steps
Weight [kg] | 0.31 | 0.39 | 0.68 | 1.00 | 2.85

Mechanical capacity

load | AS1010 | AS1020 | AS1030 | AS1050 | AS1060
Axial load [N] | 10 | 10 | 15 | 15 | 60
Radial load 0 mm from shaft end [N] | 22 | 22 | 52 | 52 | 191
Radial load 5 mm from shaft end [N] | 26 | 26 | 65 | 65 | 234
Radial load 10 mm from shaft end [N] | 33 | 33 | 85 | 85 | 301
Radial load 15 mm from shaft end [N] | 46 | 46 | 123 | 123 | 421
Tolerance at standstill [°] | ±0.09 | ±0.09 | ±0.054 | ±0.054 | ±0.09
Axial tolerance [mm] max. 1 | 0.075
Radial tolerance [mm] max. 2 | 0.025
Life time bearings [h] | 30,000

1 measured at a load of 4.4 N (AS1010/ AS1020) and 9 N at all other

2 measured at a load of 4.4 N

Step mode and maximum speed of rotation

The KL2531/41 stepper motor terminals can output about 125,000 steps per second. Beckhoff stepper motors have a step angle of 1.8°, which is 200 steps/ rotation. The following maximum rotation speeds derive from this.

Step mode | Maximum speed of rotation [/min]
Full step | 37,500 (theoretical)
1/2 | 18,750 (theoretical)
1/4 | 9,375 (theoretical)
1/8 | 4,688 (theoretical)
1/16 | 2,344
1/32 | 1,171
1/64 | 585

In practice, the design and construction of the stepper motor limit the maximum speed of rotation. Normally, stepper motors are in fact only used for applications with rated rotation speeds well below 1000 per minute. You will find the actual rotation speeds in the following speed/torque curves.


AS10x0 - Rotation speed-torque curves

BECKHOFF AS10x0: Product Description

Rotation speed-torque curves

AS10x0-0000

Characteristic curves of the AS1010

Characteristic curves of the AS1020

Characteristic curves of the AS1030

Characteristic curves of the AS1050

Characteristic curves of the AS1060


AS1000 - Dimensions

BECKHOFF AS10x0: Product Description

Dimensions

The following drawings are also available in dxf (2D) or step format (3D) under www.beckhoff.de.


AS10x0 - Accessories

BECKHOFF AS10x0: Product Description

Accessories

Connection cables

Beckhoff offers pre-assembled motor and encoder cables to simplify installation and wiring of the stepper motors. The cables are pre-assembled at the motor end with M12 plugs, while individual cores are available at the terminal end, fitted with wire end sleeves.

Motor cable

Order number: ZK4000-6200-2xxx (xxx is the cable length in dm, e.g. 5 m = 50 dm: -2050).

For the specification see Section Motor cable.

Encoder cable

Order number: ZK4000-5100-2xxx (xxx is the cable length in dm, e.g. 5 m = 50 dm: -2050).

For the specification see Section Encoder cable.

Incremental encoders

The principle of stepper motors makes them suitable for positioning. Beckhoff stepper motors have a step angle of 1.8°, which corresponds to 200 steps per rotation. The stepper motor terminal provides control of each single step, allowing positioning to be carried out without the use of either feedback or encoder. The micro-stepping mode of the stepper motor terminal can be used to improve the physical resolution further. This causes the physical resolution to be multiplied by the micro-step factor. The stepping pattern can be adjusted from full steps, through half steps down to 64 micro-steps.

It is possible that, when overloaded, a stepper motor cannot keep up with the desired number of steps. In these cases it is said that the motor "loses" steps. It is therefore possible, optionally, to add an incremental encoder. In this case, the stepper motor needs a second shaft end.

The KL2541 stepper motor terminal incorporates an integrated encoder interface as standard, making the incremental encoder option available for stepper motors from the AS1050 on.

Encoder specification

Mechanical parameters
Number of pulses | 200 divisions / rotation
Rotation speed | max. 12,000 min-1
Moment of inertia of the rotor | approx. 0.1 x 10-6 kgm2
Starting torque | < 0.001 Nm
Weight | approx. 0.06 kg
Protection class according to EN 60 529 | IP 64 (for housing)
Working temperature range | -20° C ... +85 °C
Operating temperature range | -20° C ... +90 °C
Shaft | stainless steel
Shock resistance | in accordance with DIN-IEC 68-2-27: 1000 m/s2, 6 ms
Resistance to vibration | in accordance with DIN-IEC 68-2-6: 100 m/s2, 55 ... 2000 Hz

Electrical parameters
Output circuit | push-pull
Supply voltage | 8 ... 30 V DC
Current consumption (no load) | max. 50 mA
Permitted load/ channel | max. 50 mA
Pulse frequency | max. 160 kHz
Signal level high | min. UB -3 V
Signal level low | max. 2.5 V
Rise time tr | max. 1 µs
Fall time tf | max. 1 µs
Short-circuit protected outputs | yes
CE conform | conforms to EN 61000-6-1, EN 61000-6-2, EN 61000-6-3 and EN 61000-6-4

Planet gears

Beckhoff offers special planetary gears for stepper motors in order to increase the torque or to improve the inertia ratio. Stepper motors whose flanges have dimensions of 56 mm or above can be fitted with low-play planetary gears. If the planetary gear is ordered along with the stepper motor, the combination of motor and gear is delivered fully assembled.

 | AG1000-+PM052.00x | AG1000-+PM081.00x
Rated torque | 4 Nm | 20 Nm
Accelation torque | 6 Nm | 30 Nm
Gear play | ≤ 0,7 ° | ≤ 0,5 °
max. radia load | 200 N | 400 N
max. axial load | 60 N | 80 N
Stepper motors | AS1030 u. AS1050 | AS1060

x = gear ratio 4 (more precisely 3.7, or 63/17 as a fraction), gear ratio 7 (more precisely 6.75, or 27/4 as a fraction)

  • Crown gear and planet wheels of steel, spur-toothed
  • Lubricated with Klübersynth GE 14-151

For retrofitting see section Assembling the incremental encoder.


AS10x0 - Stepper Motor Terminals

BECKHOFF AS10x0: Product Description

Stepper Motor Terminals

The stepper motors in the AS1000 range are a component of the Beckhoff Drive Technology System. The AS1000 is not designed for independent operation. Stepper motor axes can be assembled together with the KL2531 and KL2541 stepper motor terminals.

You can take detailed information about the stepper motor terminals from the according documentation that may be found on our homepage (http://www.beckhoff.com) under download.

The KL2531 stepper motor terminal

This terminal is designed for connection of the AS1010 to AS1030 stepper motors with a rated current of ≤ 1.5 A.

The KL2541 stepper motor terminal

This terminal is designed for connection of the AS1050 to AS1060 stepper motors with a rated current of ≤ 5 A.


AS10x0 - Transport and Storage

BECKHOFF AS10x0: Installation and Operation

Transport

Transport

  • Only by qualified personnel
  • Avoid sharp impacts
  • Temperature: -25...+70°C, varying no faster than 20 K / hour
  • Air humidity: relative humidity max. 95%, non-condensing
  • If the packaging is damaged, check the stepper motor and any included accessories for visible damage. Inform the transport company and, if necessary, the manufacturer.

Storage

  • Only in the manufacturer's original, recyclable packaging
  • Storage temperature: - 25...+ 55° C, varying no faster than 20 K / hour
  • Atmospheric humidity: relative humidity max. 95%, non-condensing
  • Duration of storage: no limit


AS10x0 - Installation

BECKHOFF AS10x0: Installation and Operation

Installation

Safety instructions

Before installing and commencing operation of the AS1000 servo amplifier, read the safety notes at the beginning of this document.

Danger Put the electrical system into a safe, unpowered state before starting installation, dismantling or wiring the AS1000 stepper motors!

Mechanical installation

Assembly the stepper motor

When assembling, make sure that the fastening of the motor is not mechanically overdetermined. Avoid warping, particularly when assembling the shaft.

Assembling the incremental encoder type 2420

It is only possible to retrofit the Beckhoff Type 2420 incremental encoder if the motor was originally made with a second shaft end having a diameter of 6 mm and a 3 mm hole for the locating pin.

The locating pin provides support for the torque, and must be fastened with industrial adhesive such as Loctite.

Mount encoder with coupling on shaft | Carefully tighten clamping hub

Assembling the planetary gears

The AG1000-+xxxx planetary gears are supplied with a separate adapter shaft having an integrated sun wheel. The adapter shaft is pushed on to the stepper motor's motor shaft until it reaches the stop, and is glued with the aid of industrial assembly adhesive (e.g. Loctite, not included). For this reason a solvent should be used first to degrease the motor shaft.

An additional, securing split-pin (not included) can also be attached through the assembly opening. In this case, however, attention must be paid when drilling of the motor shaft to ensure that no metal chips get inside the motor.

The gear is then pushed onto the adapter shaft, and the gear flange is bolted to the motor flange. The bolts must be evenly tightened, to avoid any warping.

Electrical components

Motor winding

Motor connector

The stepper motors are supplied with a 300 mm connecting cable and a preassembled M12 connecting plug.

Connector, 4-pole, straight, M12

Pin | Core colouring | Signal | Circular connector - 4-pole ( View "x")
1 | red | Phase 1 | male
2 | yellow | Phase 1
3 | orange | Phase 2
4 | blue | Phase 2

Motor cable ZK4000-6200-2xxx (Connection to the stepper motor terminals Kl2531/41 or EL70x1)

Pin | Core colouring | Signal | Circular connector - 4-pole ( View "x")
1 | brown | Phase 1 | female
2 | white | Phase 1
3 | blue | Phase 2
4 | black | Phase 2
Motor cable |
Stranding | 4-leads - 0,5 mm2
Weight | 42 kg / km
min. bending radius | 53,5 (10 x D)
Overall diameter | 5,35 ± 0,15 mm
max. velocity | 3 m/s
max. acceleration | 10 m/s2
Traverse path | <= 10 m
min. no. of cycles | 4 Mio.
Operating temperature (IEC 60664-1) | -15....+80 °C
Halogen free to | DIN VDE 0472 Part 815
Flame resistance | AWM Style 20549; UL 758/1581 FT2
Protection class (IEC 60529) | IP 67 in the bolted condition
Rated voltage (IEC 61076-2-101) | 250 V
Test voltage | ≥ 3000 V
Ampacity (IEC 61076-2-101) | 4 A bei 40 °C
insulation resistance (IEC 60512) | ≥ 100 MW
Conductor resistance | max. 39 W / km (20 °C)
Volume resistivity | ≥ 1016 W x cm (20 °C)

Motor cable ZK4000-6261-2xxx (Connection to the EtherCAT-Box EP7041)

Pin assignment and specification see ZK4000-6200-2xxx

Encoder connector

If the optional encoder is fitted, the encoder has a 300 mm, screened connecting cable and a screened M12 connecting plug.

Connector, 5-pole, straight, M12

Pin | Core colouring | Signal | Circular connector - 5-pole ( View "x")
1 | white | 0 V | Female
2 | brown | +Ub
3 | green | Track A
4 | yellow | Track B
5 | grey | Track 0

Encoder cable ZK4000-5100-2xxx (Connection to the stepper motor terminals Kl2531/41 or EL70x1)

Pin | Core colouring | Signal | Circular connector - 5-pole ( View "x")
1 | brown | 0 V | Male
2 | white | +Ub
3 | blue | Track A
4 | black | Track B
5 | grey | Track 0
Motor cable |
Stranding | 5-adrig - 0,25 mm2
Weight | 45 kg / km
min. bending radius | 56,5 (10 x D)
Overall diameter | 5,65 ± 0,20 mm
max. velocity | 3 m/s
max. acceleration | 10 m/s2
Traverse path | <= 10 m
min. no. of cycles | ≥ 2 Mio.
Operating temperature (IEC 60664-1) | -15....+80 °C
Halogen free to | DIN VDE 0472 Teil 815
Flame resistance | AWM Style 20549; UL 758/1581 FT2
Protection class (IEC 60529) | IP 67 im verschraubten Zustand
Rated voltage (IEC 61076-2-101) | 60 V
Test voltage | ≥ 3000 V
Ampacity (IEC 61076-2-101) | 4 A bei 40 °C
insulation resistance (IEC 60512) | ≥ 1 GW
Conductor resistance | max. 78 W / km (20 °C)
Volume resistivity | ≥ 1016 W x cm (20 °C)

Encoder cable ZK4000-5151-2xxx (Connection to the EtherCAT-Box EP7041)

Pin assignment and specification see ZK4000-5100-2xxx

Electrical connection

KL2531 stepper motor terminal
for AS1010, AS1020 and AS1030 without Incremental-Encoder

KL2541 stepper motor terminal
for AS1020, AS1050 and AS1060 with Incremental-Encoder


AS10x0 - Servicing and Disposal

BECKHOFF AS10x0: Installation and Operation

Servicing and maintenance

  • Stepper motors do not require any servicing
  • Opening the stepper motor voids the guarantee

Cleaning

  • If the housing is dirty, clean it with Isopropanol or a similar agent.
    Do not immerse or spray!

Disposal

  • The device should be disposed of by a certified disposal company. You can obtain addresses from us.
  • Metal parts can be sent for metal recycling.
  • Electronic parts such as the connecting cables and plugs must be disposed of in accordance with national electronics scrap regulations.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com