Notes on the Documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards. It is essential that the following notes and explanations are followed when installing and commissioning these components.

Liability Conditions

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

The documentation has been prepared with care. The products described are, however, constantly under development. For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics. None of the statements of this manual represents a guarantee (Garantie) in the meaning of § 443 BGB of the German Civil Code or a statement about the contractually expected fitness for a particular purpose in the meaning of § 434 par. 1 sentence 1 BGB. In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning. No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

© This documentation is copyrighted. Any reproduction or third party use of this publication, whether in whole or in part, without the written permission of Beckhoff Automation GmbH, is forbidden.


Structure of this manual

Drive Technology: A primer of linear motors

About this manual

This documentation consists of the following titles:

  • A Primer of Linear Motors

  • Designing your Application with AL2000 series Linear Motors

  • Installing AL2000 series Linear Motors

A Primer of Linear Motors

Linear motors (LM) enable linear movements at high speeds with great accuracy. Most linear motors are used in the machine construction industry and for production automation purposes.
In this leaflet the following information can be found:

  • The basic physical principles of linear motors.
  • The 3 phase linear motor considered.
  • A comparison of standard electric (rotary) motors and linear motors.
  • The positioning system
  • A brief description of a linear motor system and some practical considerations.
  • A brief description of series AL2000 linear motor

Designing your Application with AL2000 series Linear Motors

With the series AL2000 Beckhoff Automation introduced a wide, standard range of high quality linear motors. Due to a far-reaching standardization it is possible for designers to select the linear motors themselves. However specialized knowledge is required for making the right design decisions. This knowledge is provided here step by step departing form a practical case.

A linear motor of Beckhoff Automation is not a system in itsself. Usually a linear motor is build within a total machine concept or a working unit. Depending on the application choices have to be made concerning the specifications and the sizing of the motorsystem. To assure a faultless operation all the components of the motorsystem must comply to strict requirements. In this document the relevant choices and requirements are discussed step by step.

Several stages can be distinguished in a motor system analysis and design proces. In this leaflet you will be guided through these stages. First of all some system considerations have to be made. These considerations will provide you with relevant practical information, for instance about the powersupply, heat dissipation, stability, accuracy and braking. As a designer of linear motor systems one should be familiar with some theoretical physical laws and formulas. This information will be provided together with the step by step analysis and design proces. Special attention is given to mechanics.

Installing AL2000 series Linear Motors

Generally a linear motor system is a part of a specific machine. Beckhoff’s linear motors can be combined with numerous application devices. This installation manual is intended for those technicians who construct a machine that includes a linear motor system.

When installing a linear motor system one should be familiar with some important safety remarks. In the first chapter these remarks are made. Please, read them carefully.

Besides mounting the coil unit and the magnetplates, the installation includes the electrical wiring and the connections between the motor, the servo-controller and the linear encoder. Information about connecting an optional water cooling system and coupling two coil units is provided in an additional installation chapter.

Before starting up, some required settings will be discussed. Finally your linear motor can take off for it’s first ride.


Principles of magnetism

Attraction and repulsion:

The operation of a linear motor is based on the principles of magnetism. When two permanent magnets are placed in opposition, they will apply a force to each other. Dependent on the position of the poles, they attract or repel each other. Equal poles are repellent and opposite poles are attracting.

Moving principle:

Suppose we have a movable but irrotatable magnet. The magnet only can be moved in a straight horizontal line. Now this magnet is positioned above two fixed magnets as shown left in the figure. Because of the attracting and repelling forces, it will move towards the magnet with the opposite pole pointing upwards. The movement stops when the magnet is positioned right on top of it. Changing the poles of the upper magnet, would make the magnet move back to the right.

Physical resemblance of permanent magnet and electric coil:

A linear motor is propelled by similar attraction and repulsion forces. The changing the magnetical poles is enabled by using winded cupperwire, i.e. a coil, in stead of a permanent magnet.
It is known that a metal wire, winded around a core and conducting een electric current, acts like a magnet. Among others, the produced magnetic force of an electric coil depends on

1. the amperage of the current,
2. the number of windings, and
3. the kind of core material.

Electromagnetic exiting of a constant and a commutating magnetic field:

Generally iron is used as core material. Because of its very low magnetic resistance it has some very good characteristics for conducting the magnetic field. In fact the iron core can be considered as a magnet. In the case of a direct current the core behaves like a permanent magnet. In addition, reversing the phase of the current makes the magnetic poles switch. So an alternating current excites a commutating magnetic field.

Linear motor, schematic cross section:

In a linear motor several coils are mounted in a slide, or coil unit. The slide is movable over a bottom plate. On the entire distance this plate is covered with permanent magnets. The plate, included with the magnet assembly, is called the magnetplate. The length of the magnetplate determines the reach of the linear motor.

The linear motor type discussed in this leaflet has coils with an iron core (see following figure ). These cores that act like magnets are called ‘the teeth’. The coils are supplied with an electric current

The slide is propelled by changing the current phase of each coil. The speed of change allows control of the velocity of the slide. In addition, the amperage of the current is linked to the moving force. So, in- or decreasing the amperage allows control of the motorforce.

Coil unit with three coils, schematic:


3 Phase Linear Motor AL2000

Different techniques can be applied in order to get an accurate and smooth motion of the slide. The permanent magnets are fixed on the magnetplate. So the phase of the magnetic force of each magnet is invariable. For the coils on the other hand the phase is adjustable. The slide is propagated by commutating the phase of the current. Providing each coil with a suitable phase displacement is one of the appropriate techniques for linear motors. Another point of concern is the position of the coils in respect to the permanent magnets.

Erroneous postioning and phasing

Placing the coils in the same pattern and mutual distance as the magnets, as shown in the figure is problematic. When in addition the coils are provided with equally phased current, the slide won’t move at all. Considerations like these should be faced when designing a linear motor of series AL2000.

Postioning and phasing for a 3 phase linear motor AL2000

The principle of the three phase linear motor AL2000 comes to meet the mentioned problems. In the example here discussed, the coils are equally positioned in the slide with a ratio 3 to 4 compared to the magnets of the magnetplate (see figure ). As a result three different groups of coils can be distinguished. Coil 1 will continuously have a comparable position as coil 4. Coil 2 and 5 are also comparably positioned as well as coil 3 and 6. Smooth and accurate motion is now obtained by providing a three phase rotary current to the coils, one phase to each group. The phase angle depends on the position of the slide. Information about this position is provided by a linear encoder.


Linear and rotary motors compared

A rotary motor opened up and laid out flat

It will be notified that a linear motor is based on the same physical principles as the normal rotary electric motor. In fact a linear motor is a rotary motor opened up and laid out flat (see figure). Hereby the function of the rotor is transformed in the slide function. The torque has become a linear force and so the rotary movement has changed to a flat movement.

Because of its flat topolgy the main advantage of the linear motor is apparent. It generates a direct linear movement. Whereas a rotary motor needs some kind of transmission, the linear motor directly provides it.

The direct drive results in some significant advantages.

  • Accurate position control and response is possible at submicron level.
  • A linear motor provides a smooth and controlled motion. No velocity ripple.
  • In comparison with standard rotary motor systems a high velocity and acceleration performance is obtained. This is due to the high ratio of peak force to motor inertia.
  • Except for the side bearings there is no contacting surface. Friction is negligable, virtually no wear.
  • The only limitation on travel displacements is the length of the magnetplate. In the case of added length there are no speed limitations nor is there a higher inertia or lower dynamic stiffness.


The positioning system

Linear motor applications require a sophisticated position and velocity feedback. A linear encoder and a servocontroller are taken up in the positioning system. The position of the slide is detected by a ruler-probe combination. The linear encoder returns this information to the servocontroller.

To have some impression of the positioning system a superficial comparison could be made with the speed control of an automobile. The information of the traffic sign (1) is detected and interpreted by the driver (2) and translated into an adjustment of the gaspedal (3). This results in an adjustment of the motor force (4) and consequently of the rotation speed of the wheels (5). The actual speed information is returned to the driver by the speedometer (6). As long as the desired speed is not gained this specific loop back situation is maintained.

What a linear motor system concerns the measurement unit could be compared with the driver’s visual system. The measurement probe detects the position and the linear encoder translates it into the right position information. The imput ports of the servo-controller act like the eye-nerves. Here the position information is returned to the drivers brains, the very servo-controller. In the controller this information is processed and translated into an appropriate voltage signal to the linear motor, comparable with the gas pedal movement. Because the linear motor needs a powerful input this signal is provided by an amplifier. A bigger amplifier supplies a larger peak force, just like a more powerful car engine produces more horse powers. Comparable with car dynamics the acceleration of a linear motor depends on the ratio of the amplifier power and the total moving load. It should be notified that the voltage signal to the linear motor is provided in the form of pulses with a fixed switching frequency and a fixed voltage. So the pulse width is the parameter to be regulated.

The position information provided by the probe is incremental. So the linear motor has to do without the absolute position of the slide. Especially when starting a motor operation this could be problematical. Herefore the slide is activated to some minimal testmovement. This ‘magnetic alignment’ supplies the positioning system with the required information.


Overview

A linear motor usually is part of a bigger system. This system enables controlled movement. A complete linear motor system consist at least of the following parts:

  • A mounting frame
  • A magnettrack build up out of at least two magnetplates.
  • A set of linear guides that support the slide and its load.
  • A positioning system consisting of a servo controller, a measurement ruler and probe for position detection and a linear encoder for position feedback to the servo controller.
  • A coil unit, water cooled if needed. This slide carries the functional load.
  • Safety end dampers and switches to stop the movement in case of malfuntions.

In the next paragraph some practical considerations concerning these items will be discussed.


Practical considerations

A PART OF A TOTAL MACHINE CONCEPT

A linear motor of Beckhoff Automation is not a system on itsself. It should be build within a total machine concept or a working unit. Depending on the application a choice has to be made between different systems. Therefore it is important to know the specifications of both the total machine concept and the linear motor types. The machine should meet all the appilcable CE requirements

MOUNTING FRAME: SOLIDITY AND STABILITY

For two main reasons the mounting frame has to meet special requirements. The propelling peak forces of a linear motor are high, so the frame needs sufficient dynamic stiffness. Because of the accuracy the frame should be insensible to shocks and vibrations. Usually the magnetplate is horizontally fixed to the base of a machine or working unit. The slide will bear a functional load, such as a measurement unit or a laser cutter. Because of this load, the cabling and optional cooling lines the ratio of peak force to motor inertia could be influenced a little. It will be obvious that a vertical position of a linear motor system demands special considerations. If desired contact Beckhoff Automation.

RAILS AND BEARINGS

To assure a free movement the slide is provided with bearings that run smoothly on two rails or with air bearings. The rails are mounted aside the magnetplate. In addition this construction ensures the right airgap between the coil unit and the magnet plate. For the sideward positioning of the coil unit to the magnetplates a small tolerance is acceptable.

HEAT DISSIPATION

Especially in the coil unit the heat dissipation can be significant. Heatflow causes temperature differences. In some cases this could be unacceptable for accuracy or other reasons. So, special attention has to be given to the heatflow to the ambient. In some cases (water) cooling is needed.

ACCURACY

The accuracy of the positioningsystem is crucial, since the linear motor is supposed to be controlled at submicron level. For instance the accuracy can be influenced by heat expansion of the coil unit, by vibrations and shocks from the surroundings or by a lack of stiffness of the mounting frame. Generally the main restriction for the accuracy arises from this lack of stability.
Like most mechanical systems a linear motor deals with resistance, elasticity and inertia. Because of the feedback of position and velocity it also deals with measuring accuracy and certain delay times. For instance the controller has to deal with some delay because of processor and update times. Accuracy could also be limited by the fixed pulse frequency of the servo-amplifier.

Of course the linear ruler and the measurement probe should meet the desired accuracy. This requires a sophisticated ruler-probe combination. The probe should be mounted as close as possible to the working point of the complete moving unit (slide + load). The probe sends signals to the linear encoder, whereby the encoder has a resolution time. At last the linear motor itsself is an electromagnetic device. It deals with resistance and selfinductance. This implies that the current in the coils always lags behind the provided voltagesignal. Since the magnetic force is directly linked to the current this means that the motorforce also lags behind.
All these items affect the accuracy of the linear motor, its small signal behaviour.

SERVOCONTROLLER

Linear motors of the AL2000 series could ideally be combined with our 3 Phase servocontrollers of the AX2000 series. The servocontroller AX2000 covers the complete rotary and linear motor range. The prepared motor-, feedback- and thermal-protection cables completes the full linear motor servo system. All default parameters of linear motor-controller combinations are defined and loadable.

BRAKING AND DAMPING

High velocities are gained at short distances. In normal conditions dynamic braking is provided by a reversed electromagnetic force. However, for short runouts braking and damping could be necessary. In certain conditions, for instance a loss of electrical power, this could be critical for safety.

MAGNETIC FLUX AND DISTANCE

Just like a rotary motor a linear motor is propagated by an electromagnetical force. Magnets produce a so called magnetic flux, which can be considered as the density of the magnetic field. This counts for the permanent magnet as well as the electromagnetic coil. The magnetic field is densest in the direct vicinity of the magnetic pole, typically several thousand Gauss. This flux usually diminishes rapidly when measured at some centimeters from the magnet pole. Since the magnetic force depends directly on the magnetic flux, it is important to keep the gap between coil unit and magnetplate small. The gap can vary a little without loosing much performance.

COGGING

The permanent magnets produce an attraction force to all magnetic materials in the vicinty. When the coil unit contains such materials, f.i. the iron core, the motorforce could be influenced. Because of the separate positioning of the magnets on the magnetplate, the magnetic field is not homogenous. So, dependent of the position of the magnets the motorforce will be disturbed. Such position dependent disturbance could make the slide cog. Beckhoff Automation sophisticated design meets with the problems of cogging.

CAREFUL INSTALLATION

Installing a linear motor should be done very cautious. Read the installation manual carefully. Installation only by qualified personal. Special attention should be given to the strong magnetic field in the vicinity of the magnetplates. These plates should be handled with care and with proper tools. Beware of the fact that materials or clothes get jammed between magnetplate and iron objects. For mounting and dismounting purposes magnetic field neutralizing protectionplates are to be used. Carefully follow the installation instructions of the applied servo controller ans linear encoder. Electronic wiring, such as the sensor cable, should be shielded or combined to twisted pairs in order to reduce the influence of EMI.


The series AL2000 linear motor

The motors of the AL2000 series are three phase ironcore linear motors in a very compact design. Coils with iron core are mounted in the slide. The slide moves over the magnetplate. The small gap between the plate and the slide is established by the use of rails and bearings. Because of the small airgap the magnetic resistance between coils and magnets is low. This results in a high magnetic force.

  • Some characteristics of this linear motortype are
    High peak force (up to 2000 N).
  • High continuous force.
  • Relatively small attraction force
  • Low heat dissipation.
  • Controlled low cogging level.
  • Dynamics and accuracy at an intermediate level.
  • Medium speed (up to 6m/s).
  • Moderate price of magnet plate.


Power Supply

The performance of a linear motor is depending on the powersupply. Therefore a linear motor is specified for an appropriate voltage. The motor’s servo-amplifier can be connected to different voltage power supplies: 230 to 480V, one- or three phase. By means of capacitors and a rectifier bridge the power is transformed in a DC voltage link. For high forces and velocities a DC link is required of at least 560 V. For limited forces and velocities a 310 V DC link will do. For more information about the DC voltage link and the powersupply - motorforce relatio, please see the appendix - ’Peak force - velocity diagrams’ and - ’DC Link diagram’


Protective Earth (PE)

To prevent hazardous situations in case of an electrical failure, all metal components must be earthed. The coilunit housing and ironcore are earthened by the PE of the motor’s power cable. The cable shield is connected to the housing but is not appropriate as PE. Earthen the cable shield on the servo-amplifier to prevent EMC problems. Follow instructions of the servo-amplifier.

The magnet plates which are bolted to the frame, have to be electrically connected to the frame through the bolts. The stainless cover of the magnetplate is earthened through the magnetplates. The earthing has to be checked according to demands with respect to electrical machine safety.


Heat dissipation

Heat dissipation is a very important but difficult item. Every linear motor produces heat. The heat will mainly be dissipated in the coil unit. There are two aspects to consider:

1. This heat must flow away to ambient. If possible, the route of the heat conduction should be traced.

2. Heat generation causes temperature differences. That can be unacceptable for accuracy or other reasons. For your system, especially for the coil unit, the allowed temperature increase should be determined.

The coil unit is fitted with a temperature sensor. In some designs the coil unit is not capable enough of transferring the heat to the surrounding air. This counts especially for heavy loaded motors with a high ratio between motorforce and coil unit size. Also when the motor is thermally isolated or when ventilation is prevented by a hood. In these cases active cooling, like water cooling, is needed.

Without cooling an unacceptable heat up of the coil unit could occur. This could result in lower performance, thermic safety stops and even damage to your motor system. Water-cooling of the motor is very effective to reduce the heatflow and to obtain a constant temperature of the body. Water-cooling requires a water conditioning unit containing at least a pump and a cooler. Beware of leaking. The temperature sensor can be used to detect failures of a watercooling system. An additional flow-sensor for controlling the cooling is strictly not necessary, but yields extra safety and system information. If heat up of particular parts of the system is critical, a thermal insulation between the coil unit and the critical parts of the slide can be considered. This can reduce, but not nullify, the temperature rise. Sometimes small heat up also takes place in the magnet plates.


Mounting frame: solidity and stability

The propelling forces of a linear motor are relatively high. Therefore the frame needs sufficient dynamic stiffness. Because of the required accuracy the frame should be insensible to shocks and vibrations.

A linear motor system gaines its accuracy by means of a high bandwidth feedback control loop. In this loop all mechanical parts such as load, frame and mountings are involved as well as the characteristics of the servo-controller and the linear encoder. The loop can be compromised by the characteristics of the construction. A bad construction can even cause total loss of control of the linear motor system.

Attention should be paid to the machine’s natural frequencies. Especially vibrations between 50 - 500 Hz in driving direction can be harmful for accuracy. To meet main problems a rule of thumb is: the motorsystem should be rigidly connected to a massive and rigid body of at least 3 times the mass of the accelerated load.


Positioning

LM applications require a sophisticated position and velocity feedback. A linear encoder and a servocontroller are taken up in the positioning system. The position of the slide is detected by a measurement unit, a ruler-probe combination. The unit’s linear encoder returns the information to the servocontroller. The accuracy of the motor system depends strongly on this positioning system.

Most measurement units return incremental position information. So the linear motor has to do without the absolute position of the slide. Especially when starting a motor operation this could be problematical. Herefore the slide is activated to some minimal testmovement. This ‘magnetic alignment’ supplies the positioning system with the required information.


Measurement unit

The series AL2000 motors use a wireless linear encoder for communication, speed and position control. The performance of the linear motor depends on the characteristics of the applied linear encoder. The use of an encoder system with a wire is not possible due to the bad dynamic characteristics. The unit is to be connected and shielded with care. Any disturbance of the positioning signal could lead to positioning failures and system oscillations.

Several types of measurement units can be applied, such as encoder kits by Heidenhain, Renishaw, Siko and Numerik Jena. Mostly the resolution should lie between 0.1 and 5 µm. The accuracy of the measurement unit must at least be better than the required accuracy of the motor system. Depending on the dynamics of the application it can be a factor 2 to 10.

The position of a moving body is measured with respect to the frame. Depending on its stiffness the frame acts more or less as a reaction force body. In the measurement appearing rotations or vibrations should be disgarded. Therefore the mounting of the measurement unit is critical. The probe should be mounted as close as possible to the mass centre of the complete moving unit (slide + load), whereas the ruler needs to be placed near the centroid of the frame. The presence of rotations or vibrations is surmountable but their measurement and feed back should be avoided.

In exceptional cases stick or slip effects are present. If so the measurement can be placed best between the bodies between that cause these effects.


Servo-controller

The position information as well as the current in the coils is fed back to a servocontroller. Here the information is processed and translated into a proper inputsignal for the linear motor. Because the linear motor needs a powerful input the signal is provided by a servo-amplifier.

The slide’s movement is directed by a three phase voltage pulse to the coil unit. The phase depends on the actual and the desired position of the slide. Hereby the motion’s directing quantity is the pulse width. In fact the servo-amplifier is a pulse width modulation amplifier with a fixed voltage and a fixed switching frequency.

AL2000 linear motors can ideally be combined with our servo-controller series AX2000. With prepared motor-, feedback- and thermal protection cables we offer a complete and flexible linear motor system.


Accuracy

Generally the accuracy of the motor system is influenced by
• the accuracy of the error detection and positioning system,
• the static stiffness of the system,
• the dynamic stiffnes of the system

The main restriction for the accuracy arises from the lack of stability of the mounting frame, as discussed before. Here we discuss the restrictions of the linear motor system.

The linear motor itsself is an electromagnetic device. It deals with resistance and selfinductance. This implies that the current in the coils always lags behind the provided voltage signal. Since the magnetic force is directly linked to the current this means that the motorforce also lags behind.

With a static load (constant velocity) the positioning error will be small. Static disturbance arises from cogging at stand-still or friction. Only a constant force has to be compensated. The system must react with an appropriate contant force to the disturbance. Generally this is done by an integrator action of the position controller. This action takes some settling time. The more accurate the positioning, the higher the settling time. An accurate positioning typically requires a settling time of 5 to 25 ms.

With a dynamic load (accelerating or decelerating) the system shouldn’t just react appropriately but also rapidly. Now the disturbance is dynamic. It arises from cogging during move, acceleration forces, vabrations and contact forces (for instance when milling). Depending on the stiffness of the whole system the accurcy can deteriorate because of this. As a motor system can be considered as a kind of mass-spring system, it is obvious that the accuracy is worsened most by disturbances at the system’s natural frequency.

By the servo controller the returned information of the position, the velocity and the current is processed and translated into an appropriate voltage signal to the linear motor. The controller has to deal with some delay because of processor and update times. For a schematic overview, see the appendix ’Influences on accuracy’.

The voltage signal to the linear motor is provided as pulses with a fixed switching frequency. Here the pulse width is the parameter to be regulated. Accuracy is limited by the fixed pulse frequency and the fixed pulse voltage.

Needless to say that the accuracy of the positioning system also depends on the accuracy of the linear encoder and the thermal stability of the system’s components.


Braking

A controlled stop by the servocontroller is recommended, especially with short runouts. The Servocontroller stops the motor as quick as possible using the maximum force of the motor. This action has to be activated by a signal from the position controlling system. Herefore power up is required. In addition there should be no error status in the servocontroller.

Usually a linear motor’s braking depends on the power supply and position information. Without additive measurements this could result in an uncontrolled rollout to the end of the track in case of power loss or measurement and controlling errors. All active solutions need to be activated by the loss of power or control. This means that a normal, free motion of the slide is only made possible by one or more unlocked or unbolted braking systems. Suitable is the use of relais.

Risky situations by uncontrolled roll out can be prevented in several ways, such as

1. The use of pneumatic rail guide brakes. This establishes a short runout. Some rail guide suppliers offer brakes that are released by air pressure. These can be very useful for vertical applications and for some safety situations.

2. Short-circuiting of the motor coils. This results in a moderate runout. A braking force is generated when the coils are short circuited. There are standard relais for this action. The braking energy is dissipated in the coil unit. Requirements for relay: current similar to Ipeak, contact resistance below 0.5 Ohms, switching time according to application requirements.

3. The use of mechanical end stops. Mechanical end stops check the slide at the end of the track. So there is a maximum run out. Non-flexible end stops are not suitable. Hydraulic or pneumatic dampers absorb the energy of the movement and stop the slide. Springs cause the slide to be returned, but can be combined with damping by short circuiting. Requirements: no damage/danger by uncontrolled movement possible

4. a combination of the mentioned measurements.

Which methods are useful depends on the application. For design, consider at least the following worst case situations:
• Safety violation detected by sensors (linear motor must stop immediatly).
• Programming error, (uncontrolled movement at maximum speed).
• Overtemperature in motor, (linear motor must stop within seconds).
• Fatal error in the Servocontroller (uncontrolled movement).
• Main Power loss (loss of motor control and force).
• DC control Power loss (loss of motor control and force).
• Failure of end of track detector, (hitting end of track).
• Air pressure loss.


Contamination

As a standard Beckhoff Automation offers a stainless steel cover that can be placed over the magnet plates. Objects falling on the cover might get jammed causing damage to the system. Particularly small metal parts such as bolts residing on the cover can be quite harmful.


Cables

Linear motors have moving cables. In case of watercooling the coolant lines move as well. Take care of mechanical support of the cables and lines. Make moving parts replacable.


Bearings

To assure a free movement the slide should be provided with robust bearings that run smoothly on two rails. The rails are mounted aside the magnetplate. This construction ensures the right airgap between the coil unit and the magnet plate. For the sideward positioning of the coil unit to the magnetplates a small tolerance is acceptable.

The coil unit contains iron parts which are strongly attracted by the permanent magnets of the magnet plate whether or not the motor is electrically propelled. This attraction force should continuously be beared by the linear bearings. Therefore it is important to take the attraction force into account when dimensioning the bearings.


Vertical applications

Linear motors in vertical applications often require a counterbalance mechanism to prevent dropping the load in the event of power interuption. The counterbalance neutralizes the gravitational force, making an additional continous force of the linear motor superfluous. The inertia of the motorsystem though could increase. For counterbalance mechanisms can be thought of springs, pneumatic cylinders or counterweights.

When the moving mass is small, especially when the gravitational force is significantly smaller then the continuous attraction force, the application could do without a counterbalance mechanism.


Coupling of Coil Units

A magnettrack can be shared by more than one slide. A servocontroller can be shared as well. The following combinations can be distinguished (see figure).

1. Two (or more) coil units share a magnettrack, each of them directed by it’s own amplifier.
2. Two coil units are coupled (rigidly connected), sharing one amplifier and one magnettrack.
3. Two coil units are coupled, sharing one amplifier. They are running on different parallel tracks.

When two linear motors share one amplifier, they are connected in parallel. For motor sizing objectives the currents of both motors should be added up. It is not possible to mount motors in series. Use one of the temperature sensors. Use the sensor of the coil unit which is expected to have the worst cooling and also to reach the highest temperature.


Introduction

The choice for the right linear motor size depends on the requirements of your positioning application, especially the worst case requirements. These requirements can be modelled and translated in some characteristic parameters, such as time, maximum speed, mass of load, inertia and friction. By means of a kinematic and force analysis these parameters can be linked to typical motor parameters, like peak force and continuous force. On base of the calculated values an appropriate motor size is to be selected. In addition the appropriate servo-amplifier can be chosen.

Below a case is worked out as a kind of finger exercise. Understanding this case requires basic knowledge of some physical laws and principles, especially kinematics and dynamics.


Physical background

Usually a linear motor’s motion can be distinguished in 3 stages:

1. acceleration

2. constant (or maximum) velocity

3. deceleration

Below this is reperesented in a velocity-time diagram.

Velocity-time diagram for a combined or ' long motion'

During ta the accelaration takes place and during tc the velocity is constant at its maximum. The decelaration to stand still takes place in td. The total distance covered by the motion equals the area under the graphical drawing.

During acceleration and decelaration the largest forces are displayed while the movement at constant speed only requires the force needed to overcome friction. A linear motor that is constantly moving to and fro without reaching its maximum velocity is thus loaded upmost. In the diagram below this situation is sketched.

Velocity-time diagram for a combined or ' short motion'


Used symbols

symbol | unit | description
t | s | time
ta, td tad |  | time needed for acceleration, deceleration or both
tc |  | time needed to cover a distance at constant speed
Dt |  | small time difference
T |  | total time
v | m/s | velocity
va |  | velocity after acceleration from stand still
vmax |  | maximum velocity
a | m/s² | acceleration
x | m | distance
xa, xd, xc |  | distance covered by acceleration, deceleration or constant speed
X |  | total distance of a combined movement (ta+ tc+ td)
F | N | force
Fa, Fd, Fad |  | force needed for acceleration and/or deceleration
Fl |  | force applied by the load (like processing contact forces)
Fpeak |  | motor´s peak force
Fcont |  | motor´s continuous force
Ff |  | friction force
Frms |  | mean force over a longer period (root mean square)
M | kg | mass of the load
Q | W | dissipated power
S25 | N²/W | motor constant (slope) at 25°C
STW |  | motor constant at working temperature
K | N/A | motor force constant
Krms |  | mean motor force constant (depending on the current)
I | A | current
Ipeak |  | motor´s peak current
Icont |  | motor´s continuous current
Rth | °C/W | thermal resistance
TW | °C | working temperature


Used formulas

Kinematics

From these formulas two practical estimations can be derived.

1. Estimated time of a ‘short motion’ when vmax is not reached (see ’Velocity-time diagram for a ‘short motion’’):

2. Estimated time of a ‘long motion’ when vmax is reached (see ’Velocity-time diagram for a combined or ‘long motion’’):

Dynamics

3. Once you know the mass of the load and having chosen a linear motor type, an estimation of the acceleration can be made by

Other Formulas

The dissipated power by the linear motor:

The mean motor force constant:

Estimated maximum needed current:


The case

A gripper places components and moves to and fro continuously: X = 0.8 m. The duration of a single movement of 0.8 m can ultimately be 0.4 s. On both sides of the movement 0.5 s is needed for settling and gripper action. Other parameters are:

  • The mass of the load: M = 20 kg.
  • Friction: Ff = 30 N.
  • Slide air cooled, large cooling surface.
  • Accuracy approximately 0.02 mm.
  • Maximum speed: vmax = 3 m/s


Step 1: Worst case cycle

Look for the severest job-cycle your application meets. Worst cases happen generally in two situations. First when the motor produces a high holding force and second where the motor is accelerating and deceleration continuously (short moves) with little standstill time. Now determine the quantities during the severest job-cycle. In the case there is only one job-cycle. First let’s choose the type AL2006 motor.

• Calculate the acceleration of this motor:

Note: The value of Fpeak is can be found on the AL2000 series specification sheet.

• The formula to calculate the required time to cover the distance depends on whether the linear motor reaches its maximum velocity vmax during the movement.
- In the case of a short move (vmax not reached):

- In this case the velocity after ta is:

This calculated velocity va exceeds the maximum velocity required for this application (vmax = 3 m/s). It is obvious that the chosen linear motor reaches the maximum velocity somewhere during the motion. In this case we will have to calculate the required time using the formula for long moves.

Notice that this calculated time exceeds the required travelling time for this application (0,4 s). Therefore a more heavy type motor like the AL2012 needs to be selected.

So let’s choose the type AL2012 and repeat the calculations.

• Acceleration:

• Required time using the formula for short moves (vmax not reached):

• Maximum velocity during acceleration:

Once again this velocity exceeds vmax therefore the actual velocity is to be calculated using the formula for long moves (vmax reached):

This time is in accordance with the requirements. So the AL2012 seems to be the right choice


Step 2: Kinematic analysis

Sketch a velocity-time diagram for the worst case cycle of your application. Mark the acceleration and deceleration time and the maximum speed. Take 20-40ms extra settlingtime when exact positioning is required.

Case kinematic analysis:

Accelaration and deceleration time and distance:

In this case for acceleration and decelaration the same time and distance are needed. The time needed to cover the distance of the constant movement (tc = 0,167 s) follows directly from the total time tacd calculated before.


Step 3: Force analysis

Sketch a motorforce-time diagram. The motorforce depends on:

• Required accelation and deceleration forces.

• Friction forces.

• Processing contact forces (for instance when using bits or cutters).

• For vertical applications: the gravitational forces

The maximum force Fmax is the overall maximum force, driving or braking. The motor’s peak force should meet this. Consider the square time average force Frms. This force should remain below the motor’s continuous force.

Case force analysis: motorforce versus time diagram:

In the case we get the following results.

Parameter | Acceleration phase (ta) | Maximum velocity phase (tc) | Deceleration phase (td) | Settling and gripper action phase
Dt(s) | 0,1 | 0,167 | 0,1 | 0,5
a(m/s²) | 30 | 0 | -30 | 0
Fa,c,d (N) | 600 | 0 | -600 | 0
Ff(N) | 30 | 30 | 30 | 0
Ftot(N) | 630 | 30 | -570 | 0

The mean force during the cycle:


Step 4: Motor sizing

Two main criteria for the motor’s thrust force should be kept in mind:

1. A linear motor’s peak force is depending on the velocity of the coil unit. This can be seen in the linear motor Specification Diagrams.

Peak force versus velocity (velocity and force in the same direction)

As shown in the diagram this effect depends on the power supply. The speed at F=0 is the limit. For more diagrams see the appendix - ’Peak force - velocity diagrams’.

2. Frms must remain below the motor’s specified continous force Fcont. The continuous force is a measure for the thermal load of the linear motor. Amongst others it depends on the cooling conditions. For watercooling, Fcont is specified. Without cooling, Fcont is to be estimated. For more information, see the appendix ’Heat transfer and Temperature’.

Choose a linear motor which meets both criteria.
From the calculated mean force and the specified motorconstant the dissipated power is obtained.

This power equals the heat production in the coil unit. It has to be conducted to ambient.


Step 5: Amplifier sizing

For most servocontrollers the duration of the peakcurrent is limited from 0.25 to several seconds. If the current exceeds the continous current during a period, longer than this specified time, the required continous current must be raised to this higher level. So check whether in long periods the required current is over the continuous current. Choose a servocontroller which can deliver the required Icont and Ipeak.

Here, from the specified Krms and the calculated Frms we obtain

The maximum force during the cycle is 630N, so the servo-amplifier has to generate a maximum current

Since the periods of I>Icont are no longer than 5 seconds the AX2006 is fullfilling the requirements.

For braking heavy loads from high speeds (for example 100 kg at 4 m/s) the motor feeds back the electrical power into the servo-amplifier. Most of it is dissipated in a braking resistor. Of course this resistor should be of sufficient power, especially when such situations occur frequently (for instance in short repeated moves).


Heat transfer and temperature

The dissipated power in the coil unit causes a heatflow to the ambient. The resulting temperature rise of the coils is determined by the thermal resistance of the heat conducting route. The coil unit is fitted with a temperature sensor of the PTC 1kOhm type. This sensor detects overtemperature of the coil unit. The servocontroller should check overtemperature at a level of 1000 Ohms

The water-cooling unit can be connected serial as well as parallel. Parallel connection demands a good flow through the T-connection pieces. The watercooling lines are linked to the coil unit by means of standard M5 connections. Haake or Julabo cooling system are compliant with Beckhoff Automation linear motors. Please contact Beckhoff Automation for more information.

As noticed before the linear motor’s continuous force is a measure for the thermal load. Fcont depends on the motor constant STW and is limited by the allowed working temperature. For watercooling, Fcont is specified. In that case the thermal resistance of both motor and water can be determined. The heat flow results in a limited rise of the temperature. Tcoils can be kept controlled beneath the allowed working temperature.

Heatflow and watercooling

The motor constant depends on the temperature.

This means that the motor’s continuous force decreases at high temperatures. When no water cooling is applied, the heat flow usually results in a significant rise of the temperature. The amount depends on the situation. Sometimes it is not so easy to keep Tcoils controlled beneath the allowed working temperature.

Heatflow, without water cooling

Now the heat conducting route and the thermal resistance are much harder to determine. The continuous force has to be estimated. The lower value is specified in the follwing case:
• A mounting surface about two times the motor dimension.
• Air temperature up to 45°C under a closed hood.
• Stationary or short moves.

The high value can be taken for a large surface (f.i. cooling ribs), forced convection and regulated air temperature below 30°C. For all other situations, estimate a value in between.


Drive Technology: Application with Linear Motors

Influences on accuracy


List of specifications AL series

Drive Technology: Application with Linear Motors

List of specifications AL2000 series

Specifications | Coils/Current | Symbol | Unit | AL2003 | AL2006 | AL2012 | AL2015 | AL2024 | AL2030
Motortype |  |  | 3-phase synchronuos
Peak force 3 minutes 1 | magnet@25°C | Fp | N | 200 | 400 | 800 | 1000 | 1600 | 2000
Peak current |  | Ip | Arms | 5 | 5 | 10 | 10 | 20 | 20
Continuous Force watercooled | @100°C | Fcw | N | 105 | 210 | 420 | 525 | 840 | 1050
Continuous Force aircooled 1 | @100°C | Fca | N | 50... 100 | 100... 200 | 200... 400 | 250... 500 | 400.. 800 | 500.. 1000
Continuous Power loss | all coils | Pc | W | 80 | 155 | 310 | 370 | 620 | 740
Maximum speed 2 |  | Vmax | m/s | 6.0 | 6.0 | 6.0 | 6.0 | 6.0 | 6.0
Motor force constant | < 0.6Ip | K | N/Arms | 46 | 93 | 93 | 112 | 93 | 112
Motor constant | @25°C | S | N²/W | 185 | 370 | 740 | 970 | 1480 | 1940
Magnet Pitch NN |  | τ | mm | 24 | 24 | 24 | 24 | 24 | 24
Resistance per phase | @25°C | Rf | Ω | 3.9 | 7.8 | 3.9 | 4.3 | 1.9 | 2.2
Induction per phase | <0.6Ip | Lf | mH | 30 | 60 | 30 | 35 | 15 | 17.5
Electrical time constant | @25°C | &tau;e | ms | 8 | 8 | 8 | 8 | 8 | 8
Thermal Resistance |  | Rth | °C/W | 0.96 | 0.48 | 0.24 | 0.20 | 0.12 | 0.10
Motor Attraction Force |  | Fa | N | 500 | 900 | 1700 | 2000 | 3400 | 4000
Weight of Coil unit |  | Mc | kg | 0.9 | 1.5 | 2.6 | 3.2 | 5.1 | 6.3
Temperature Sensor | PTC 1 kΩ
Protection class | IP 64

1 Depends on application: cooling surface, air speed and ambient temperature

2 Depends on available voltage and required force


Peak force - velocity diagrams

Velocity diagram AL2003

Velocity diagram AL2006

Velocity diagram AL2012

Velocity diagram AL2015


DC link diagram

P1, P2 and P3: the three phases of the AC power supply.

• D1 ... D6: these diodes are part of the 3 phase diode bridge.

• C: the DC link capacitor.

• Tb: the activating transistor of the braking resistor.

• Rb: the braking resistor.

• T1 ... T6: transistors of the PWM amplifier stage.

• L1, L2 and L3: The coils of the motor.


Technical data of some optical linear rulers

Manufacturer type | Encoder period | Stability | Repaetability | Accuracy | Maximum speed | Interface
Heidenhain LIP481 | 2µm | <2nm | <10nm | ± 0.1, 0.2, 0.5 or 1µm/m | 5m/s |
Heidenhain LIF181 (C) | 4µm | <10nm | <25nm | ± 3 or 5µm/m | 1m/s | 1Vpp
Heidenhain LIDA181 (C) | 40µm | <80nm | <200nm | ± 5µm/m | 8m/s | 1Vpp
Heidenhain LIDA185(C) | 40µm | <80nm | <200nm | ± 3 or 5µm/m | 8m/s | 1Vpp
Heidenhain LS485 | 20µm | <40nm | <100nm | ± 5µm/m | 8 m/s | 1Vpp
Heidenhain LS486(C) | 20µm | <100nm | <500nm | ± 3 or 5µm/m | 1 m/s |
Litton/Zeiss LIE5-1PC-FA | 20µm | <50nm | <100nm | ± 5µm/m | 8m/s |
Renishaw RGH-2XR | 20µm | <50nm | <100nm | ± 3µm/m | 4m/s | 1Vpp TTL


General warnings

Please read the following instructions very carefully. They are important for a safe and warranted installation and operation of the Linear Motor.

  • The AL Series Linear Motor is used as a part of a machine. The user has to take care that the machine build fullfilles all CE requirements.
  • Before installing and using the Linear Motor, read this instruction manual carefully. The manufacturerer declines alI responsibility in case of accident or damage due to negligence or lack of observance of the instructions described in this manual. The manufacturerer also declines alI responsibility in case of accident or damage in conditions that differ from those indicated in the manual; Beckhoff also declines all responsibility for damage caused by improper use of the Linear Motor.
  • Unpack the Linear Motor and check its integrity. If there is any irregularity, contact the dealer or manufacturer, signaling the nature of the defects.

  • The Magnetplates show large attraction forces on alI soft magnetic objects such as iron. These forces cannot be controlled by hand. They may cause serious jamming danger.

  • Do not bring any soft magnetic objects (iron) nearer than 10cm of the magnetic side of the Magnetplates. Be sure that the magnetic plates are fixed into your machine before removing the magnetic field neutralizing protection plates. Put the magnetic field neufralizing protection plates on the magnetic plates again before dismounting them.

  • If at any time and in any situation there is any doubt about the safety of the Linear Motor, do not use it and contact your dealer.
  • The Linear Motor is powered by a servo amplifier. In case of a power disruption or fatal error this may automatically result in a free runout of the Motor. Make mechanical precautions to prevent damage on the Motor or your machine in the case of such an event.

  • Before installing the Motor, make sure that the supply mains are grounded and operate in conformity with the regulations in force.
  • Make sure that there is an effective protective earth. Make sure that there is no voltage at the line wire terminals before connecting.
  • An earth connection does not work on nonconducting mounting surfaces like granite. In these cases the protective earth must be established by an earthing wire
  • Before carrying out checks or doing any maintanance, clear the system by disconnecting the voltage. Be sure that there is no possibility of accidental connections.
  • Be aware of electrical danger when the cooling liquid comes in contact with the supply means.


EC declaration

Beckhoff declares that the AL series linear motors (AL2003, AL2006, AL2012, AL2015, AL2024 and AL2030) are manufactured in accordance with the applicable European directives and in conformity with the following standards:

Standard number | Date of issue | Name of standard
ES 50081-2 | 08-1993 | Emission requirements for products in an industrial environement
ES 50082-2 | 03-1995 | Immunity requirements for products in an industrial environement
ES 60034 | 05-1998 | Rotating electrical machines
ES 60204(-1) | 02-1995 | Safety of machinery


Basic Components

Drive Technology: AL2000 series Linear Motors

Overview

A linear motor of Beckhoff is not a system on itsself. It should be build within a total machine concept or a working unit. The size and the shape of the mounting frame, the design of the slide, the type of rails and bearings or the kind of dampers depend of the required application. Beckhoff provides basic and special components which are suitable for numerous linear motor applications. Whatever the design of the mountingframe and the slide is, these components can easily be applied.


Basic Components

The basic LM components supplied by Beckhoff are

- the coil unit (types: AL2003, AL2006, AL2012, AL2015, AL2024 and AL2030),

- magnetplates (length: 192, 288, 768mm).

Magnetplate 768 mm


Special features

In addition special features are supplied by Beckhoff. These include

  • magnetic field neutralizing protectionplates for mounting and dismounting purposes,

coverplate

  • stainless steel coverplate to avoid contamination,

end frets

  • end frets.

The previous mentioned standard components are delivered by Beckhoff.

Before starting the installation, check the presence of the right number and type of the delivered components. In case of doubt, please contact Beckhoff immediately.


Bolts and dowel pins

Drive Technology: AL2000 series Linear Motors

Additional Features

For a proper installation of your linear motor system you also need

  • fixing components, like bolts and pins.
  • additional devices, like a servocontroller and a linear encoder.
  • optinal devices, like a water cooling unit
  • the right tools

These features are no part of Beckhoff’s standard delivery. If desired Beckhoff can supply all additional components as well as some types of devices.

Bolts and dowel pins

  • Bolts (M5x10, stainless steel, DIN 7984), and
  • dowel pins (5h8x8 M3, stainless steel)

are required for positioning and connecting the coil unit to the slide and the magnetplates to the mounting frame.

Controller and measurement unit

  • An appropriate servocontroller/amplifier
  • A ruler and a linear encoder
  • Power supply, cabling and connectors

In this leaflet installation information is provided concerning some standard devices, the Seidel ServostarTM 600 series controller and the Heidenhain LidaTM 100 series encoder. For more information please refer to the next paragraphs or contact Beckhoff.

Water cooling unit (when used)

Additional attention is paid to the installation of a water cooling unit. For connecting this unit to the coil unit you need at least

  • PVC hoses (ø4 inner)
  • 4 M5 hose connections
  • M5 plastic sealings
  • Loctite sealant 638/648

For more information please refer to the next paragraphs or contact Beckhoff.

Tools

Necessary for the installation are

  • 2,5 mm Allenkey

Occasionally usefull are

  • electric hand drilling machine with metal bore bits
  • a tapping unit
  • a pair of scissors
  • two pair protective gloves


Installation order

The installation order of this instruction manual must be followed. A different order may cause dangerous situations and damage due to uncontrolled magnetic attraction forces.

Before installing the linear motor components, the installation of the mounting frame should be completed. The rails should be properly positioned and mounted on the frame, as well as the ruler. The slide should be provided with bearings, dampers, linear probe and required cabling in such a way that a smooth, save and well positioned transport of the slide over the stroke is established. The operation of bearings and dampers should be tested as well as the guidance of the moving cables.

Now the correct installation order in headlines is:

1. Mount the connections for watercooling on coilunit (when used).

2. Mount coil unit to the slide.

3. Move slide to the end of the stroke. Secure slide against unwanted movements.

4. Mount magnetplates partly. Keep magnetplates at least 5 cm away from coil unit.

5. Move slide above the newly mounted magnetplates. Secure slide against unwanted movements.

6. Mount the remaining magnetplates.

7. Mount the end frets, the earth bolt, the stainless steel cover plate and the earth connection of the plate.

8. Connect wiring and hoses for watercooling to coil unit.

These steps will be discussed in detail in the next paragraphs.

The de-installation order of this instruction must be followed. A different order may cause dangerous situations and damage due to uncontrolled magnetic attracfion forces.

The correct de-installation order is:

1. Disconnect wiring and hoses for watercooling of the coil unit.

2. Move slide to one side. Secure slide against unwanted movements.

3. Dismount the earth connection of the plate, the stainless steel cover plate, the earth bolt and the end frets.

4. Remove one or more magnetplates. Keep magnetplates at least 5 cm away from coil unit.

5. Move slide to other end. Secure slide against unwanted movements.

6. Remove remaining magnetplates.

7. Remove coil unit from the slide.

8. Dismount the connections for watercooling on coilunit (when used).


Drive Technology: AL2000 series Linear Motors

Mounting of the Coil Unit

Mounting instructions

Before mounting, notice the following remarks. The flatness of the mounting surface for the coil unit must be better than 0.1 mm. The coil unit has to be mounted parallel to the magnetplate. The parallellism has to be better than 0.20 mm. For this purpose the side of the coil unit or the round holes in the mounting surface can be used. Dowel pins can be applied for the round holes. Sideward positioning of the coil unit to the magnetplates is not very critical. A tolerance of up to ±0.5 mm is acceptable.

• The coil unit has to be fixed with M5 bolts. Tightning torque: 3.0 - 5.0 Nm. In some cases not all holes have to be used (see the figures in the appendix).

Bolts and dowel pins

TIP:

USE DOWEL PINS WITH M3 INTERNAL THREAD TO FACILITATE DISMANTLEMENT AFTERWARDS.

  • The use of too long bolts for the coil unit may unconspiciously cause damage and dangerous situations. Check boltlength before mounting.

In case of watercooling: be aware that the connections for the watercooling unit can lay up to 1mm above the mounting surface. Create enough space or use an intermediate plate of at least 1mm thickness. Also see - ’Connections for Watercooling ’ and the figure - ’Dimensions of coil unit with watercooling connections’ (appendix).


Warning

The magnetic side of the plates is the structured side. The Magnetplates do show large attractionforces on alI soft magnetic objects such as iron. These forces cannot be controlled by hand. They could cause serious jamming danger.
Therefore

  • Only handle the magnetplates if covered with the magnetic field neutralizing protectionplates

  • Be sure that the magneticplates are fixed into your machine before removing the magnetic field neutralizing protectionplates.
  • Put the magnetic field neutralizing protectionplates on the magneticplates again before dismounting them.
  • Do not bring any soft magnetic objects (iron) nearer than 10cm of the magnetic side of the Magnetplates

Handle the magnetplates with care. Don’t shock them and

  • Do not expose the magnets to tempertures higher then 70' C. The magnets may be demagnitised at higher temperatures.


Mounting the magnetplates

Magnet plate, detail

Mounting frame, detail

1. Move the slide to one end of the stroke. The first magnetplate will be mounted against the other end of the stroke. Secure the slide against unwanted movements. Make sure the mounting surface is free of dust and small particles.

2. Apply dowel pins for the positioning holes in the mounting frame (see - ’Mounting frame, detail’. Choose the holes according to the position of the accurate ø5 positioning holes in the magnetplate (see - ’Magnetplate, detail’)

TIP: USE PINS WITH M3 INTERNAL THREAD TO FACILITATE DISMANTLEMENT AFTERWARDS.

Orientating the magnetplates

3. Take care that magnetplate is well orientated. Finally all magnetplates to be mounted should be orientated in an equal direction. For example, all magnetplates should be placed in such a way that the orientating holes are directed in the right upper corner (see Orientating the magnetplates’ and - ’Mounting surface for magnetplates (example)’ in the appendix)

4. Fix the magnetplate to the mounting frame with M5x10 (lowhead) bolts DIN 7984. Depth of thread at least 6.5 mm. Thightning torque: 3.0 to 5.0 Nm. All holes have to be used!

5. Remove the protectionplate from the mounted magnetplate and move the slide to the other ens of the stroke. Secure the slide against unwanted movements (now this could be done by re-placing a protectionplate. Once again, make sure the mounting surface is free of dust and small particles.

6. Now the rest of the magnetplates can be mounted in a similar way. The right orientation of the plates can also be noticed when another plate is placed. The adjacent plates should attract each other. When they are repelling each other the plates are wrongly orientated.

7. Finally remove all protectionplates and check whether the slide can move freely and smoothly over the magnetplates. When there is a clear force ripple at the edges of the magnetplates, please check the orientation of the plates.


Mounting the Magnetplate Cover

Now the magnetplates are mounted, the finishing touch can be made. This means that the end frets must be placed and that the magnettrack is covered by a stainless steel cover.

The end of the stroke, detail

1. Place the end frets at the edges of the magnettrack. They are kept in position by magnetic forces.

2. The magnetplate cover must be placed according to the steps below.

  • Be carefull! The stainless steel magnetplate cover could have sharp edges. Wear protecting gloves while handling the cover.

  • Because of the high magnetic forces the cover will adhere firmly to the magnetplates. Placing is easily performed by rolling off the flexible cover. Removing is best performed by rolling up.

For the these steps also seethe following figures:
- Move the slide to one end of the stroke to clear the major part of the magnettrack.
- Unroll the cover over the cleared magnettrack.
- Move the slide to the middle of the stroke.
- Now lift up the ends of the cover so that only a small part of the cover (underneath the slide) sticks to the magnetplate. This could best be handled by two persons.
- In this position the cover can be slipped over the magnettrack. Now position the cover so that there is a small overlay at each end of the stroke.
- Cut off the overlay and place the cover accurately. The stainless cover should precisely cover the protective strips and the end frets.

  • Note that the magnets and the end frets are fixed obliquely on the stroke.

Placing the stainless magnetplate cover

3. Finally the earth connection of the stainless steel cover has to be checked in accordance with the machine’s safety standards.

  • Before operation make sure that there is an effective protective earth. Figure 3-9: Placing the stainless magnetplate cover


General Remarks

  • Before starting any activity on the wiring, make sure that the mains are disconnected. Work carefully according the instructions belonging to the applied Servocontroller. Be sure your machine meets the requirements of the EN 60204 standard.

The linear motor’s electrical wiring is externally configured with two one meter cables: a powercable and a PTC-cable. If desired you can shorten these cables and provide them with appropriate connectors. Note that these cables are not meant for use within cable chains. Therefore user defined cables should be used that meet the specifications concerning bending radius, length, replacebility, etcetera. In this case the motor’s standard cables must be connected properly to the user defined cables. Both powercable and PTC cable are shielded with a plaited metal cable sheath for electromagnetic immunity.

Besides this manual follow carefully the installation instructions of your servo amplifier supplier. Make sure that the linear motor system as a whole meets all the applicable electrical directives.


Powerline

Drive Technology: AL2000 series Linear Motors

Powerlines

The three phases of the motor’s powercable has to be connected to the servo amplifier in such a way that the positive three phase direction of the motor conforms the positive direction of the linear encoder. This polarisation has to be tested, it cannot be seen at first sight.

  • Testing the polarisation is very important, because a wrong polarisation will result in an uncontrolled runout of the slide.

The powercable can be confectioned by the user to fit on the servodrive. For moving cables it is advised to make the moving parts replacable. This can be done by making a connection of the coil unit cable to the moving cable on the slide.

Cable connections for power lines to the servocontroller

Power lines | Connection to servocontroller
L1, L2, L3 | 3-phases
Green/Yellow | Protected Earth
Shield | (Protective) Earth


Protective Earth

Be sure that the earthshield of the cable is well connected, also through the connecting devices, to the PE connector or the housing of the amplifier. Most AL linear motors are driven on the principle of pulse width modulation. This involves large electrical impulses and causes a significant risk of electromagnetical interference.

Internally the motor’s PE wire (green-yellow) is galvanic connected to the motor housing. This wire must be connected to the PE connector of the servo amplifier. Provide the motor system with PE lines to the amplifier that are as short as possible.


Temperature Sensor

The coil unit is equipped with a temperature sensor of the PTC-1k-type. The PTC resistor is the motor’s standard device for checking the heat production in the coil unit. The PTC cable consists of four wires. Two of them (white and brown) have a defined function: they provide the connection to the PTC. At room temperature the PTC has an electrical resistance of about 65 Ohms. When the temperature raises to 110°C the resistance will increase rather uniformly to 1000 Ohms. Above this temperature the resistance increases exponentially. Now, 1000 Ohms is the switching resistance. The AX2000 should immediately stop the power supply when this resistance is exceeded. In this way overheating and motor damage can be prevented. It’s obvious that the PTC cable must be connected properly to the AX2000.

The prepared thermal protection cable can be orderd or configured by the user to fit on the AX2000. For moving cables it is advised to make the moving parts replaceble. This can be done by making a connection of the coil unit cable to the moving cable on the slide.

Cable connections for sensor lines to the servocontroller

Sensor lines | Connection to the AX2000
White | Sensor wire 1
Brown | Sensor wire 2
Green | Not Specified
Yellow | Not Specified
Shield | Protected Earth


Polarisation Test

  • Before testing, make sure that the electrical and mechanical protection of the linear motor system is well configured!

There are two different ways of testing the polarisation.

1. The AX2000 can operate in an in moment service mode. By means of regulating a resolver manually, it can be determined whether the motor’s direction of running conforms the resolver’s sense of rotation. If so, the motor is well connected. If not, two phases of the powercable - phase 1 and 3 - must be changed.

2. There is a general procedure to test the polarisation. This test is suitable for all types of contollers that do without the above mentioned resolver. Therefore make sure that the servo amplifier is in a speed control mode and that the maximum speed is limited to a save amount, like 1 cm/s. Now use a manual function (JOG function) to make the motor run slowly. If the actual direction equals the defined direction, the polarisation appears to be right.

Internally all AL2000 series linear motors are equally wired and connected, so one test satisfies to find out the polarisation of a motor ruler combination. If more axes are constructed in a similar way the polarisation will be equal.


Temperature Sensor specification

Type PTC1000

Temperature | Resistance
Up to 25°C below critical temperature | <250 W
Up to 5°C below critical temperature | <550 W
Above critical temperature | >1330 W


Drive Technology: AL2000 series Linear Motors

Overview

  • Beckhoff accepts no responsibility for effects of leakage.

For the dimensions of the coil unit and the position of the standard watercooling connections please refer to the figure - ’Dimensions of coil unit with watercooling connections’ (appendix) .

  • The use of other connnections may cause higher pressure drops than indicated due to smaller throughput.

Fitting Watercooling Connections

If desired M5 connections can be mounted. Take care that the flow diameter is at least ø2.5 mm and hose ø4 mm inside.

1. Degrease connection and thread hole. Let the degreasing agent vaporize completely. 2. Place plastic sealing ring on connection.

3. Put one drop of Loctite 638/648 glue on thread and distribute glue around.

4. Mount connection and turn until the sealing ring is deformed visibly. (This only requires about 0.2 - 0.3 Nm torque. Do not turn too hard!)

5. Remove surplus of glue.

6. Let glue harden for 4 hours before applying loads.

7. Let glue harden for 12 hours before applying pressure.

8. Hoses must fit with the connections chosen.

Beckhoff can deliver watercooling connections which are suitable for hoses ø4 inside, for example Festo PU-4 pneumatic or the very flexible PVC-hose Rauclair E 4x1. Both hoses and connections can take 2 bar of pressure.

Connection of hoses

When fitting hoses, the connections have to be free of greases and oil.

Connections of both cooling channels in series is projected. This can be seen in the figure - ’Dimensions of coil unit with watercooling connections’ (appendix). The minimum flow is 1 l/min, causing a pressure drop below 1 bar.

Both cooling channels can also be used in parallel. This connection reduces the pressure drop, but only if cavitationless ø6mm-ø84mm Y-joints are used.


General

When you are convinced that your application’s linear motor system is assembled in a proper way, both mechanically and electrically, you can do the next step. You can put your motor system into operation.

But before powering the system, please do have a final check

• Does the slide have a free run over the whole magnettrack, without touching small mechanical parts like bolts or contamination?

• Are the mechanical end stops, end switches and the dampers well dimensioned and properly configured?

• Does your system have an emergency stop?

• Is the PTC cable properly connected?

• Does the motor ruler combination have the right polarisation?

Configuring

After the amplifier is powered up some input and output signals need to be examined.

1. Check the end switches by pushing the slide manually to the switch position. Simultanuously check whether the signal is detected by the amplifier.

2. Check the presence of the PTC signal.

The following motor items should be configured by loading motor default parameters to the AX2000. Please check all loaded parameters, following parameters are very important:

3. Maximum continuous current.

4. Maximum peak current.

5. Amount of self induction poles1.

6. Maximum speed (rpm).

7. Presence/absence of an electromechanical motor brake.

8. Magnet interval (North-South distance) and/or polepitch (North-North distance.

9. Switching resistance of PTC.

The following settings for the ruler system should be configured as parameters of the servo amplifier:

10. Type of interface of the ruler system.

11. Resolution or period of the linear encoder. These are the I/O parameters to be configured:

12. Settings of the available digital inputs and outputs. For instance, pay attention to the type of end switches.

13. Settings of the available analog inputs and outputs. Finally the controlling parameters must be configured.

  • For configuring several types of servo amplifiers Beckhoff can offer parameter files. With these files motor specific settings can be configured. Nevertheless, application specific settings should be configured by yourself. Please contact Beckhoff for information.

Also see table 6-1 - ’Parameter list’ and 6-2 - ’Settings Currentloop’. Here an example is shown of the parameters and settings when a AL2000 series linear motor is combined with specific servo controller.

Optimization of control settings

Now the current control is configured, the speed control can be adjusted. Supply the motor with several step signals (for example v=0 ... to ... 1m/s). Depending on the response the amplification factor and the integration time have to be adjusted according to the common rules of standard control technology. After this the position control can be adjusted in a similar way.


Drawings

Mounting dimensions AL- series:

Coil unit AL2003, scheme 4022 368 5018:

Coil unit AL2006, scheme 4022 369 7458

Coil unit AL2012, scheme 4022 369 7459

Coil unit AL2015, scheme

Coil unit AL2024, scheme

Coil unit AL2030, scheme

Mounting surface for magnetpaltes (example)

Dimensions of coil unit with watercooled connections


Introduction

Drive Technology: AL2000 series Linear Motors

Parts list

Basic components- coil units

4022 368 5018 | Coil unit AL2003
4022 369 7458 | Coil unit AL2006
4022 369 7459 | Coil unit AL2012
4022 369 7460 | Coil unit AL2015
4022 368 5014 | Coil unit AL2024
4022 368 5015 | Coil unit AL2030

Basic components- Magnetplates

4022 369 7455 | Magnetplate 192 mm
4022 369 7456 | Magnetplate 288 mm
4022 369 7457 | Magnetplate 768 mm

Special features

4022 368 0943 | Protectionplate 192 mm
4022 368 0944 | Protectionplate 288 mm
4022 368 0945 | Protectionplate 768 mm
4022 363 1501 | End fret
4022 363 6601 | Rubber filling strip
4022 363 6603 | Stainless magnettrack cover (per meter)
4022 363 6002 | Pi 5h6 x 8 M3
2522 007 08001 | Bolt M5 x DIN 7984


Example parameter list

This example concerns the Beckhoff AX2000 series controllers. Please note that it exist default parameter files for AL2000/AX2000 combination.

Parameter list

Parameter | AL2003 | AL2006 | AL2012 | AL2015 | AL2024 | AL2030 | Remarks
MPOLES | 2 | 2 | 2 | 2 | 2 | 2 |
MSPEED | 8000 | 8000 | 8000 | 8000 | 8000 | 8000 | 8000 RPM = 33.2 m/s
MBRAKE | 0 | 0 | 0 | 0 | 0 | 0 |
MICONT | 1 | 1 | 2 | 2 | 4 | 4 | Depends on cooling
MIPEAK | 5 | 5 | 10 | 10 | 20 | 20 |
MNAME | AL2003 | AL2006 | AL2012 | AL2015 | AL2024 | AL2030 |
MTEMPM | 1 | 1 | 1 | 1 | 1 | 1 |
L | 30 | 60 | 30 | 35 | 15 | 17.5 |
FBTYPE | 7 | 7 | 7 | 7 | 7 | 7 | Wake and shake
VLO | 1 | 1 | 1 | 1 | 1 | 1 |
ENCLINES | PP/I | PP/I | PP/I | PP/I | PP/I | PP/I | PP=pole pitch = 24.0 mm, I = period linear encoder1

1The parameter ENCLINES gives the ratio between pole pitch and pulse period of the linear encoder. For instance, when the pulse period is 0,040 mm the input should be ENCLINES 600 [ENTER].

Settings currentloop

Parameter | AL2003 | AL2006 | AL2012 | AL2015 | AL2024 | AL2030 | Remarks
ICONT | 1 | 1 | 2 | 2 | 4 | 4 | Depends on cooling
IPEAK | 5 | 5 | 10 | 10 | 20 | 20 |
MLGQ | 1.3 | 2.7 | 2.7 | 3.2 | 2.3 | 2.6 |
MLGC | 0.8 | 0.8 | 0.8 | 0.8 | 0.8 | 0.8 |
MLGD | 0.8 | 0.8 | 0.8 | 0.8 | 0.8 | 0.8 |
KTN | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 |
GVTN | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 | 0.6 |
REFIP | 2 | 2 | 2 | 2 | 2 | 2 |

The parameters can be inserted to the amplifier by means of a PC software programm, or by loading motor default parameter. When the software connection is established a “-->” symbol is shown by the monitor every time when an [ENTER] is returned. After the insertion is completed the settings are saved in the amplifier memory by a SAVE command. At the command COLDSTART the amplifier is restarted and the new settings are activated.


Electrical connections

Connections between LIE5 encoder and AX2000

Numerik Jena LIE5 | Signal | AX2000 | Signal
RED | U2- | X1:1 | B-
BLUE | U2+ | x1:9 | B+
YELLOW | U1- | X1:3 | A-
GREEN | U1+ | X1:11 | A+
PINK | U0- | X1:5 | DATA
GRAY | U0+ | X1:13 | DATA
 | Sensor 5V | X1:12 | Up (sense)
 | Sensor 0V | X1:10 | 0V (sense)
BROWN | 5V | X1:4 | Up (supply)
WHITE | 0V | X1:2 | 0V (supply)
 |  | X1:14 | PTC
 |  | X1:7 | PTC


Drive Technology: AL2000 series Linear Motors

Connection of hoses


Drive Technology: AL2000 series Linear Motors

Connections for watercooling