Satzvorlauf (C6)

1.1 Satzvorlauf (Typ 1, 3, 4) PAGEREF _Toc304466717 \h2

1.2 Wiederanfahren an die Kontur nach Satzvorlauf 3

1.3 Schnittstelle und Parameter des Satzvorlaufs 3

1.3.1 Allgemeine Parameter 3

1.3.2 Parameter für Typ 1 : Dateioffset und -name, Programmpfadkennung, Durchlaufzähler für Start- und Endposition 3

1.3.3 Parameter für Typ 3 : Satzzähler 3

1.3.4 Parameter für Typ 4 : Satznummer / Durchlaufzähler 3

1.4 Ein / Aus-Handshake mit SPS 3

1.5 Bekannte Einschränkungen 3

1.6 Beispiele 3

1.7 Ausnahmen / Fehler 3

Mehr:

button Satzvorlauf (Typ 1, 3, 4)

button Wiederanfahren an die Kontur nach Satzvorlauf

button Schnittstelle und Parameter des Satzvorlaufs

button Ein / Aus-Handshake mit SPS

button Bekannte Einschränkungen

button Beispiele

button Ausnahmen / Fehler


Satzvorlauf (Typ 1, 3, 4)

Satzvorlauf und
Anwahl der
Fortsetzposition

Im Satzvorlaufmodus hat der Anwender die Möglichkeit, die Bearbeitung an einem beliebigen Punkt zu starten (Fortsetzposition). Dabei ist es notwendig, an diesem vorgegebenen Startpunkt den gesamten Programmkontext (Programmparameter, Achspositionen..) wiederherzustellen.

Die Fortsetzposition ist der Punkt, an dem das NC-Programm zuvor unterbrochen wurde. Z.B. wenn der Anwender nach einer Werkstückvermessung (mit Achsbewegungen) oder einem Werkzeugbruch mit einem neuen Werkzeug mit geänderten Parametern (z.B. Werkzeugradius) die Programmbearbeitung an dem Unterbrechungspunkt fortsetzen möchte. Der Anwender legt dann die Fortsetzposition innerhalb des NC-Programmes fest und startet das NC-Programm im Satzvorlaufmodus.

Die Fortsetzposition kann auch innerhalb eines NC-Satzes liegen. Es kann deshalb bei allen Satzvorlauftypen optional der bereits zurückgelegte Weg im NC-Satz festgelegt werden, ab dem die tatsächliche Bearbeitung fortgesetzt werden soll.

Bis zum Startpunkt erfolgt im Satzvorlaufmodus keine physikalische Achsbewegung (Bei Simulationsbetrieb erfolgt nur eine Decodierung des NC-Programmes).

Nach Erreichen der Fortsetzposition im Satzvorlaufmodus muß sichergestellt sein, dass die Achsen von ihren momentanen Istpositionen auf die wiederhergestellten Sollpositionen des NC-Programms verfahren sind (Wiederanfahren an die Kontur).

Gleichzeitig müssen auch die Spindeln wieder ihre zuletzt beauftragten Drehzahlen erreicht haben

Anschließend wird dann das NC-Programm so fortgesetzt, als wäre es ohne Satzvorlaufmodus gestartet worden.

Damit auch die Maschinenfunktionen korrekt geschaltet werden können, erhält die PLC auch im Satzvorlaufmodus alle Technologiefunktionen wie im Normalbetrieb. Diese Funktionen müssen ebenfalls quittiert werden.

Das Ein- und Ausschalten des Satzvorlaufmodus wird mit der PLC synchronisiert. Damit kann ggf. eine spezifische Behandlung bestimmter Technologiebefehle erfolgen, falls die PLC dies unterstützt (Gruppenbehandlung, Aktivierung bestimmter Funktionen vor Abwahl des Satzvorlaufmodus).

Satzvorlauftyp 1:

Fortsetzposition
und Endposition
über Dateioffset

Bei diesem Satzvorlauftyp kann durch Angabe einer Fortsetz-/Endposition (Start-/Endmarke) über den Dateioffset ein Bereich festgelegt werden, in dem bearbeitet werden soll. An der Fortsetzposition wird die Bearbeitung gestartet und nach erreichen der Endposition wird die Bearbeitung abgebrochen und das NC-Programm sofort beendet. Ist keine Endposition angegeben, so erfolgt die Bearbeitung bis zum NC-Programmende M30.

Der Dateioffset definiert die Fortsetz-/Endposition als Abstand zum Dateianfang des NC-Programms. Die Verwendung des Dateioffsets ist nur sinnvoll, wenn im NC-Programm keine WRK oder andere konturverändernden Funktionen (z.B. Polynome, HSC) aktiv sind. Nur dann beschreibt der Dateioffset die korrekte Fortsetzposition.

Die Ermittlung des Dateioffsets liegt hierbei in der Verantwortung des Anwenders, wobei der Dateioffset jeweils im Bezug auf den NC-Zeilenanfang des jeweiligen NC-Programms (Hauptprogramm, globales Unterprogramm) zu ermitteln ist.

Zur Bestimmung der Fortsetz-/Endposition wird der Dateioffset und weitere Daten bei Anwahl des Satzvorlaufes als Parameter mit übergeben.

Satzvorlauftyp: 1

Fortsetzposition

Parameter: Dateioffset,

Dateiname,

Kennung, ob sich Datei im HP-(0) oder UP-Pfad (1) befindet,

Durchlaufzähler (optional),

Zurückgelegter Weg innerhalb des Satzes (optional)

Endposition (optional)

Parameter: Dateioffset,

Dateiname,

Kennung, ob sich Datei im HP-(0) oder UP-Pfad (1) befindet,

Durchlaufzähler (optional)

Beispiel

Start im Hauptprogramm im 1. Durchlauf bei Dateioffset 100 am Satzanfang, Ende bei Dateioffset 239

Satzvorlauftyp 3: Fortsetzposition über Satzzähler | Der Satzzähler wird nach dem Programmstart für jede decodierte NC-Zeile um eins erhöht. Ebenso wird der Satzzähler bei Kommentarzeilen, Leerzeilen, in Schleifen und während Unterprogrammaufrufen fortlaufend hochgesetzt. Während der normalen Programmausführung wird der Satzzähler der SPS oder dem HMI angezeigt. Zur Bestimmung der Fortsetzposition kann der Satzzähler bei Anwahl des Satzvorlaufes als Parameter mit übergeben werden. Satzvorlauftyp: 3 Parameter: Satzzähler, Zurückgelegter Weg innerhalb des Satzes (optional)
Beispiel mit Satzzähler | Start bei Satzzähler 12

Satzvorlauftyp 4: Fortsetzposition über Satznummer | Die Satznummer ist die Nummer (N-Wort) einer NC-Zeile im NC-Programm. Der Anwender bzw. das System zur Generierung des NC-Programms ist dafür verantwortlich, jede Zeile die später evtl. einmal relevant werden sollte, mit einer eindeutigen Satznummer zu identifizieren. Satzvorlauftyp: 4 Parameter: Satznummer, Zurückgelegter Weg innerhalb des Satzes (optional)
Fortsetzposition über Satznummer und Durchlaufzähler | Da die Satznummer z.B. innerhalb von Schleifen mehrmals durchlaufen wird, ist diese allein nicht immer eindeutig. In diesem Fall kann der Bearbeitungsstart optional durch die zusätzliche Angabe eines Durchlaufzählers ausgelöst werden. Satzvorlauftyp: 4 Parameter: Satznummer, Durchlaufzähler, Zurückgelegter Weg innerhalb des Satzes (optional)

In der Default-Parametereinstellung erfolgt nach Erreichen der Fortsetzposition und Freigabe des weiteren Programmablaufs kein automatisches Wiederanfahren an die Kontur !

Bei aktiven kartesischen oder kinematischen Transformationen sind Offsets in den Maschinenachsen nicht sinnvoll.

Beispiel mit
Satznummer

Start bei Satznummer 60

Beispiel mit
Satznummer und
Durchlaufzähler

Start bei Satznummer 60, im 5. Durchlauf


Wiederanfahren an die Kontur nach Satzvorlauf

Zurückfahren auf
Sollposition

Bevor die normale Bearbeitung fortgesetzt werden kann, müssen die Achsen wieder auf den Sollpositionen des NC-Programms stehen (Wiederanfahren an die Kontur). Diese Anfahrbewegung erfolgt entweder durch ein vom Anwender vorgegebenes NC-Programm oder manuell vor dem Start des Satzvorlaufes oder automatisch in einer Geraden am Ende des Satzvorlaufes.

Abbildung 1-1: Einsatz unterschiedlicher Werkzeugradien

Wie Abbildung 1-1 verdeutlicht, muß der bereits zurückgelegte Weg im aktuellen Satz relativ zur gesamten Satzlänge in Promille angegeben werden, weil z.B. bei Zirkularsätzen mit unterschiedlichen Werkzeugradien nach dem Satzvorlauf die absoluten Satzlängen unterschiedlich sind.

Automatisches
Wiederanfahren an die Kontur

Die automatisch erzeugte Bewegung wird im Eilgang (G00) gefahren.

Beispiel

q Anwender startet normales Programm bei Position 1.

q Programmunterbrechung bei Position 2 in Satz N20.

q Achse wird zu Position 3 gefahren und evtl. wird das Werkzeug gewechselt (WZ-radius kann sich ändern).

q Der Programmkontext wird am Ende des Satzvorlaufes in der Bewegung auf Position 4 wiederhergestellt. Die automatische Wiederanfahrbewegung erfolgt in einer Geraden.

q Das Programm kann mit dem neuen Werkzeugradius im Satz N20 fortgesetzt werden.

Abbildung 1-2: Einsatz des Satzvorlaufs zur Wiederherstellung des Programmkontextes

Anwendereingabe

Folgende Anwendereingabe ist notwendig:

q Fortsetzposition (Satznummer und relative Weg im Satz).

Manuelles
Wiederanfahren an die Kontur

Wird das Anfahren an die Kontur manuell durchgeführt und die Achsen werden nicht exakt an die Kontur zurückpositioniert, so entsteht ein Offset zwischen den Sollpositionen des NC-Programms und den tatsächlichen Istpositionen. Der maximal zulässige 3-dimensionale Offset kann hierbei durch den Anwender vorgegeben werden.

Anwendereingabe

Folgende Anwendereingabe ist notwendig:

q Fortsetzposition (Satznummer und relativer Weg im Satz).

q Maximal zulässiger Offset nach Satzvorlauf zwischen Sollposition und tatsächlicher Istposition.

Bei einem Offset > 0 ist Rückwärtsfahren nicht möglich !

Bei einem aktiven Offset ist in Verbindung mit der Softwareendschalterüberwachung bzw. Kollisionsüberwachung folgendes zu berücksichtigen:

Der Offset zwischen den Sollpositionen und der tatsächlichen Istposition kann zu SWE-Fehlern oder Kollisionsfehlern führen, obwohl sich die Istpositionen noch im gültigen Bereich befinden und keine Kollision aufgetreten ist. Ebenso kann im anderen Fall das Überschreiten der SWE nicht im vorab in der Bahnvorbereitung, sondern erst im Lageregler erkannt werden. Eine Kollision kann dann ebenso nicht in der Bahnvorbereitung erkannt werden.


Schnittstelle und Parameter des Satzvorlaufs

Gültigkeit der
Satzvorlaufparameter

Verfügbarkeit auf
dem HMI

Die Satzvorlaufparameter (Satzvorlauftyp, Angabe der Fortsetzposition) werden vor dem Start des NC-Programms festgelegt. Beim Programmstart werden dann diese aktuellen Daten in die Startparameter übernommen. Jede weitere Änderung der Satzvorlaufparameter nach Programmstart hat keinen Einfluß mehr auf das laufende Programm.

Die einmalige Belegung der Parameter vor Programmstart vermeidet zeitkritische Situationen. Die Parameter sind auf dem HMI verfügbar und der Zugriff erfolgt über die SPS durch ADS-Lese-/Schreibanforderungen.

Mehr:

button Allgemeine Parameter

button Parameter für Typ 1 : Dateioffset und -name, Programmpfadkennung, Durchlaufzähler für Start- und Endposition

button Parameter für Typ 3 : Satzzähler

button Parameter für Typ 4 : Satznummer / Durchlaufzähler


Allgemeine Parameter

Satzvorlauftyp
Beschreibung | Legt den Satzvorlauftyp fest.
Typ | UNS16
Wertebereich | 0  keiner (Default), 1  Dateioffset, 3  Satzzähler, 4  Satznummer
HMI Elemente | mc_cmd_bs_type_r, mc_cmd_bs_type_w
Zugriff | Read, write
IndexOffsetADS | 0x61, 0x49 (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Zurückgelegter Weg
Beschreibung | Legt den bereits zurückgelegten Weg im NC-Satz in Promille fest, ab dem die tatsächliche Bearbeitung fortgesetzt werden soll. Somit wird der erste Teil des Satzes im Satzvorlauf ohne Bewegung ausgeführt und erst der verbleibende Teil wird mit bewegten Achsen gefahren.
Typ | REAL64
Wertebereich | [ 0.0; 1000.0 ], Default 0.0
HMI Elemente | mc_cmd_bs_covered_distance_r, mc_cmd_bs_covered_distance_w
Zugriff | Read, write
IndexOffsetADS | 0x62, 0x4A (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Automatisches Wiederanfahren
Beschreibung | Legt fest, dass das Wiederanfahren an die Kontur automatisch erfolgen soll.
Typ | BOOLEAN
Wertebereich | TRUE, FALSE (Default)
HMI Elemente | mc_cmd_bs_auto_return_r, mc_cmd_bs_auto_return_w
Zugriff | Read, write
IndexOffsetADS | 0x63, 0x4b (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Maximale Bahnabweichung

Beschreibung

Beschreibt die maximale Abweichung der Achsen zwischen Istposition und Fortsetzposition bei Wiederaufnahme der Bearbeitung nach Satzvorlauf.

Im Falle des automatischen Wiederanfahrens an die Kontur wird die maximale Bahnabweichung nicht berücksichtigt, weil das Erreichen der genauen Fortsetzposition sichergestellt ist.

Typ

UNS32

Wertebereich

[ 0; MAX_UNS32 ] in 0.1 µm, Default 0

HMI Elemente

mc_cmd_bs_deviation_max_r,
mc_cmd_bs_deviation_max_w

Zugriff

Read, write

IndexOffsetADS

0x64, 0x4c

(IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Aktuell zurückgelegter Weg (PCS)
Beschreibung | Dient in der PLC zum Lesen des tatsächlich zurückgelegten Weges im aktuellen Bewegungssatz (z.B.nach Feedhold, Nothalt, Programmabbruch ...).
Informationsfluss | NCK → PLC
Einheit | Promille
ST-Pfad | pMC[channel_idx]^.addr^.StateBahn_Data.D_CoveredDistance
Datentyp | DINT
Zugriff | PLC reads
Eigenschaften | Der gelesene Wert kann bei der Beauftragung des Satzvorlaufes zur Definition des zurückgelegten Weges im NC-Satz verwendet werden, ab dem die tatsächliche Bearbeitung fortgesetzt werden soll.


Parameter für Typ 1 : Dateioffset und -name, Programmpfadkennung, Durchlaufzähler für Start- und Endposition

Parameter für die Startposition:

Dateioffset
Beschreibung | Legt den Dateioffset fest, ab dem die Bearbeitung fortgesetzt werden soll.
Typ | SGN32
Wertebereich | [ 0; MAX_SGN32 ]
HMI Elemente | mc_cmd_bs_pos_start_offset_r, mc_cmd_bs_pos_start_offset_w
Zugriff | Read, write
IndexOffsetADS | 0x68, 0x50 (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Dateiname

Beschreibung

Gibt die Datei an, in welcher die über den Dateioffset angegebene Startposition liegt. D.h. an dieser Stelle wird die tatsächliche Bearbeitung dann fortgesetzt.

Typ

STRING

Wertebereich

[ 0; 83]  maximal 84 Zeichen

HMI Elemente

mc_cmd_bs_pos_start_name_r,
mc_cmd_bs_pos_start_name_w

Zugriff

Read, write

IndexOffsetADS

0x67, 0x4f

(IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Der angegebene Satzvorlauf-Dateiname muss identisch mit der im Automatikbetrieb gestarteten Datei sein. Dies umfasst auch einen evtl. zusätzlich angegebenen Pfad.

D.h. wurde beim Programmstart ein expliziter Pfad mitangegeben, so muss dieser Pfad bei der Angabe des Dateinamens im Satzvorlauf ebenso aufgeführt werden.

Programmpfadkennung
Beschreibung | Die Kennung gibt an, ob sich das über den Dateiname definierte NC-Programm im Hauptprogrammpfad (HP) oder Unterprogrammpfad (UP) befindet.
Typ | UNS16
Wertebereich | 0 - HP (Default); 1 - UP
HMI Elemente | mc_cmd_bs_pos_start_type_r, mc_cmd_bs_pos_start_type_w
Zugriff | Read, write
IndexOffsetADS | 0x66, 0x4e (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Durchlaufzähler
Beschreibung | Der Durchlaufzähler bestimmt, wie oft die Startposition z.B. in Schleifen bis zum endgültigen Start durchlaufen werden soll.
Typ | SGN16
Wertebereich | [ 1; MAX_SGN16 ], Default 1
HMI Elemente | mc_cmd_bs_pos_start_count_r mc_cmd_bs_pos_start_count_w
Zugriff | Read, write
IndexOffsetADS | 0x69, 0x51 (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Parameter für die Endposition:

Dateioffset
Beschreibung | Legt den Dateioffset fest, ab dem die Bearbeitung beendet werden soll.
Typ | SGN32
Wertebereich | [ 0; MAX_SGN32 ]
HMI Elemente | mc_cmd_bs_pos_end_offset_r, mc_cmd_bs_pos_end_offset_w
Zugriff | Read, write
IndexOffsetADS | 0x6c, 0x54 (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Dateiname

Beschreibung

Gibt die Datei an, in welcher die über den Dateioffset angegebene Endposition liegt. D.h. an dieser Stelle wird die tatsächliche Bearbeitung dann beendet.

Typ

STRING

Wertebereich

[ 0; 83]  maximal 84 Zeichen

HMI Elemente

mc_cmd_bs_pos_end_name_r,
mc_cmd_bs_pos_end_name_w

Zugriff

Read, write

IndexOffsetADS

0x6b, 0x53

(IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Der angegebene Satzvorlauf-Dateiname muss identisch mit der im Automatikbetrieb gestarteten Datei sein. Dies umfasst auch einen evtl. zusätzlich angegebenen Pfad.

D.h. wurde beim Programmstart ein expliziter Pfad mitangegeben, so muss dieser Pfad bei der Angabe des Dateinamens im Satzvorlauf ebenso aufgeführt werden.

Programmpfadkennung
Beschreibung | Die Kennung gibt an, ob sich das über den Dateiname definierte NC-Programm im Hauptprogrammpfad (HP) oder Unterprogrammpfad (UP) befindet.
Typ | UNS16
Wertebereich | 0 - HP (Default); 1 - UP
HMI Elemente | mc_cmd_bs_pos_end_type_r, mc_cmd_bs_pos_end_type_w
Zugriff | Read, write
IndexOffsetADS | 0x6a, 0x52 (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Durchlaufzähler
Beschreibung | Der Durchlaufzähler bestimmt, wie oft die Endposition z.B. in Schleifen bis zum endgültigen Bearbeitungsende durchlaufen werden soll.
Typ | SGN16
Wertebereich | [ 1; MAX_SGN16 ], Default 1
HMI Elemente | mc_cmd_bs_pos_end_count_r mc_cmd_bs_pos_end_count_w
Zugriff | Read, write
IndexOffsetADS | 0x6d, 0x55 (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)


Parameter für Typ 3 : Satzzähler

Satzzähler
Beschreibung | Legt den Satzzähler fest, bei dem die tatsächliche Bearbeitung fortgesetzt werden soll.
Typ | UNS32
Wertebereich | [ 1; MAX_UNS32 ]
HMI Elemente | mc_cmd_bs_intern_block_count_r, mc_cmd_bs_intern_block_count_w
Zugriff | Read, write
IndexOffsetADS | 0x76, 0x5e (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)


Parameter für Typ 4 : Satznummer / Durchlaufzähler

Satznummer
Beschreibung | Legt die Satznummer fest, bei der die tatsächliche Bearbeitung fortgesetzt werden soll.
Typ | UNS32
Wertebereich | [ 0; MAX_UNS32 ]
HMI Elemente | mc_cmd_bs_block_number_r, mc_cmd_bs_ block_number_w
Zugriff | Read, write
IndexOffsetADS | 0x77, 0x5f (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)

Durchlaufzähler
Beschreibung | Wenn die gleiche Satznummer mehrmals durchlaufen wird (z.B. in Schleifen), dann kann der Anwender über den Durchlaufzähler angeben, beim wievielten Durchlauf die Bearbeitung starten soll.
Typ | UNS32
Wertebereich | [ 1; MAX_UNS32 ], Default 1
HMI Elemente | mc_cmd_bs_block_number_pass_r, mc_cmd_bs_block_number_pass_w
Zugriff | Read, write
IndexOffsetADS | 0x78, 0x60 (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal)


Ein / Aus-Handshake mit SPS

Während dem Satzvorlauf wird die SPS, genauso wie im Normalbetrieb auch, über jede Technologie-M-Funktion informiert. Jedoch wird die Ausführung dieser Anforderung simuliert. Dazu wird die SPS über jeden Wechsel des Satzvorlaufbetriebes (Ein/Aus) informiert und quittiert diesen Wechsel an die NC. Das Warten der NC auf die Quittierung der SPS erfolgt in gleicher Weise wie bei synchronisierten M-Funktionen.

Ist während einem NC-Reset der Satzvorlauf aktiv, so wird der Satzvorlauf ohne Handshake abgewählt (die SPS darf über die reset-spezifische ControlUnit informiert werden).

Satzvorlauf Ein / Aus

Beschreibung

Bei jeder Ein/Aus-Anforderung des Satzvorlaufes veranlaßt die NC einen Handshake mit der SPS: SPS informieren und auf die Quittierung von der SPS warten.

Zu diesem Zweck muss die SPS durch setzen des Elementes X_Enable anzeigen, daß sie über jeden Wechsel des Satzvorlaufbetriebes informiert werden möchte.

Datentyp

LCControlBoolUnit, siehe Beschreibung Control Unit

Zugriff

NCK setzt den Wert auf TRUE bei Anfrage der SPS ob Satzvorlauf Ein. Die SPS quittiert durch setzen von X_State auf TRUE (und umgekehrt).

ST-pfad

pMC[channel_idx]^.addr^.LCControlBahn_Data.LCControlBoolUnit_BlockSearch

Sollwert

ST-Element

LCControlBoolUnit_BlockSearch.X_Command

Informationsfluss

NCK → PLC

Datentyp

BOOLEAN

Wertebereich

[TRUE = Satzvorlauf aufgrund Resetanforderung von NCK an PLC,
FALSE = Satzvorlauf AUS]

Rückgabewert

ST-Element

LCControlBoolUnit_BlockSearch.X_State

Informationsfluss

PLC → NCK

Datentyp

BOOLEAN

Wertebereich

[TRUE = PLC hat Satzvorlauf EIN quittiert, FALSE = Satzvorlauf AUS]

Anforderung

ST-Element

LCControlBoolUnit_BlockSearch.X_Enable


Bekannte Einschränkungen

q Wenn das Programm nach dem Satzvorlauf mit einem Offset fortgesetzt wird, weil es nicht vollständig an der Kontur wiederaufgesetzt worden ist, so ist dieser Offset bis zum Programmende bzw. Reset gültig. Wird das Programm erneut gestartet, so wird wieder ohne Offset gefahren.

q Enthält ein zum Wiederaufsetzen vorgesehener NC-Satz Verfahr- und Technologiebefehle (z.B. N100), so wird nur der verbliebene Bewegungsbefehl tatsächlich ausgeführt. Sämtliche Technologiebefehle im Satz N100 werden nur simuliert (Satzvorlaufbetrieb).

N90 X90

N100 X100 S1000 M3 M111

N110

Sollen auch die Technologiebefehle real ausgeführt werden, so darf der Anwender im obigen Beispiel im Satzvorlauf nur bis an das Ende von Satz N90 mit einem zurückgelegten Weg von 100% fahren. Folgende Punkte sind beim automatischen Wiederanfahren an die Kontur zu beachten:

q Die Achsen werden auf einer Geraden zurückbewegt. Die Anfahrbewegung erfolgt mit den Eilganggrenzwerten (G00). Wenn auf dieser Geraden Hindernisse liegen, so muß vor dem automatischen Wiederanfahren an die Kontur eine manuelle Vorpositionierung durchgeführt werden.

q Bei aktivem Soft-Gantry wird die Anfahrbewegung für die Slave-Achsen entkoppelt durchgeführt, d.h die Achsen bewegen sich erst nach dem Anfahrsatz im gekoppelten Modus.

q Ein Achstausch im Satzvorlauf ist dann zulässig und ermöglicht weiterhin die Rückführung an die Kontur, wenn die Achsen mit Anforderung der Positionen vom Interpolator angefordert werden (Defaulteinstellung, nicht bei #CALL AX FAST).

Achsen, die während des Satzvorlaufes verfahren werden und vor dem Umschalten auf Realbetrieb abgegeben werden, können nicht automatisch an die letzte bekannte Position angefahren werden.

N00 X10 Y20

N10 #CALL AX [B, 4, 3]

N20 B45 (B-Achse wird nicht berücksichtigt)

N30 #PUT AX [B]

N30 Z100

N50 #PUT AX [Z] (Z-Achse abgegeben, kann nicht
(restauriert werden)

N10 #CALL AX [C, 5, 4] (C-Achse am Prgr.start unbekannt,

Position wird vom IPO geholt)

N30 Z100

N30 #PUT AX [X,Y]

N10 #CALL AX [X, 1, 1] [Y, 2, 0] (Austausch X/Y)
(berücksichtigt)

N100 X100 Y200 (Normale Bearbeitung nach Satzvorlauf)
(fortsetzen)

M30

Im obigen Beispiel wird die B-Achse nicht auf Position 45 zurückgefahren, wenn das automatische Wiederanfahren an die Kontur angewählt ist. Ebenso wird die Z-Achse nicht verfahren. Die C-Achse wird korrekt an die Kontur wieder angefahren.

Soll die Programmbearbeitung nach einem Abbruch mit Hilfe der Satzvorlauffunktion an der Abbruchposition fortgesetzt werden, so können die Parameter direkt aus den in der PLC vorliegenden Zustandsdaten gewonnen werden. Bei direkter Vorgabe der Satzvorlaufparameter auf Basis des NC- Programms ist zu berücksichtigen, daß konturbeeinflussende Funktionen wie z.B. Werkzeugradiuskorrektur, Polynomüberschleifen die ursprünglich vorhandenen Zielpositionen und Satzgrenzen beeinflussen.


Beispiele

Typ 4 :
Satznummer und Durchlaufanzahl

Satzvorlauftyp = 4, Satznummer = 100

Durchlaufanzahl auf 1 setzen und Programm starten

Programm hält bei Fortsetzposition X = 8 Y = 10. Nach dem Fortsetzen wird der restliche Teil des Quadrates gefahren.

NC-Programm

%t_sv_number.nc

N00 G00 G90 X0 Y0

P1 = 0

N80 G01 G91 X10 F500

N095 Y10

$FOR P1 = 1, 5, 1

N100 X-2

$ENDFOR

N120 Y-10

N130 M30

Durchlaufanzahl = 0

Durchlaufanzahl = 4

Zurückgelegter Weg

Satzvorlauftyp = 4, Satznummer = 100, Durchlaufanzahl = 1

Zurückgelegten Weg setzen und Programm starten

Nach dem Fortsetzen wird der restliche Teil des Quadrates gefahren.

NC-Programm

N00 G00 G90 X0 Y0

P1 = 0

N80 G01 G91 X10 F500

N095 Y10

N100 X-10

N120 Y-10

N130 M30

1.Ohne Satzvorlauf, 2. Zurückgelegter Weg 0, 3. Zurückgelegter Weg 600, 4. Zurückgelegter Weg 1000

Satzzähler

Satzvorlauftyp = 3, Satzzähler = 100

Programm starten

Programm wird bis zur Fortsetzposition ausgeführt, NC wartet auf Fortsetzen. Nach dem Fortsetzen wird der restliche Teil des Quadrates gefahren.

NC-Programm

Satzzähler

%t_sv_count.nc 1

N00 G00 G90 X0 Y0 2

P1 = 0 3

N80 G01 G91 X10 F500 4

N095 Y10 5

6

$FOR P1 = 1, 5, 1 7, 9, 11, 13, 15

N100 X-2 8, 10, 12, 14, 16

$ENDFOR 17

18

N120 Y-10 19

N130 M30 20

Satzzähler = 8

Satzzähler = 16

Ändern des Offsets während Satzvorlauf

Programm mit automatischem Wiederanfahren an die Kontur in N100 starten.

Automatisches Wiederanfahren erreicht die korrekte Kontur.

NC-Programm

(Test mit G92)

%t_sv_g92.nc

N907090 G00 G90 X0 Y0

N80 G01 X10 F500

N85 G92 X10 Y20

N095 Y-10

N100 X-10

N120 Y-20

N907091 M30


Ausnahmen / Fehler

Satzvorlauf zu einem Satz ohne Bewegung

Programm starten und in N100 bei 10% zurückgelegtem Weg fortsetzen.

Da N100 keine Bewegung beinhaltet wird der Satz nicht bei 10% aufgeteilt.

NC-Programm

%t_sv_p.nc

N907090 G01 X0 Y0 Z0 F1000

N070 Y10

N095 X2.1 Y2.2 Z2.3

N100 P100 = 1

N110 G00 G91 X10

N120 G90 X3.1 Y3.2 Z3.3

N907091 M30

Fortsetzposition nicht gefunden

Satzvorlauftyp = 4, Programm starten

Durchlaufanzahl zu hoch/ zu niedrig setzen. Unbekannte Satznummer setzen.

Wenn die Durchlaufanzahl kleiner als 2 ist, wird das erste Auftreten der Satznummer als Fortsetzposition genommen.

Wenn die Durchlaufanzahl grösser als 5 ist, so wird die Fortsetzposition nicht gefunden und die Meldung 20704 erzeugt.

Wenn die Satznummer zum Fortsetzen nicht gefunden wird, so wird ebenfalls eine Meldung (Warning) ausgegeben und das gesamte NC-Programm wird im Satzvorlaufmode beendet.

NC-Programm

%t_sv_number.nc

N00 G00 G90 X0 Y0

P1 = 0

N80 G01 G91 X10 F500

N095 Y10

$FOR P1 = 1, 5, 1

N100 X-2

$ENDFOR

N120 Y-10

N130 M30