Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


TCPlcLibCP66xxSystem_Overview

TwinCAT PLC Library: SystemCP66xx

Overview

This library contains functions and function blocks which are using special features of the Control Panel PC CP66xx.

With new targets like CX1000, CX1020, CX9000, CX9010 libraries TcSystemCX1000, TcSystemCX1020, TcSystemCX9000, TcSystemCX9010 should be used respectively instead of the TcSystemCP66xx.lib.

Functions

Name | Description
F_CP66xxSetWatchDog | activates/deactivates hardware watchdog (auto-reboot of CP66xx in case of PLC problems)
F_GetVersionTcSystemCP66xx | The function returns library version info.

Function Blocks

Name | Description
FB_CP66xxTemperatureSensor | The function returns the temperature value measured by sensor PT100, PT1000 or NI1000.

Requirements

Component | Version
TwinCAT on the development PC | 2.10 Build 1329 or higher
CP66xx-Windows CE-Image | 2.20b or higher


FUNCTION F_CP66xxSetWatchdog

The function F_CP66xxSetWatchdog activates a hardware watchdog on the CP66xx-xxxx-0000. The watchdog is enabled with bEnable = TRUE and a timeout time. The minimum timeout time is a few times the cycle time in which the function F_CP66xxSetWatchdog is called, the maximum timeout time is 64sec and 431 millisec.

Once the watchdog is activated, the function has to be called cyclically, because if the tTimeOut-time expires then the CP66xx-xxxx-0000 automatically reboots. The watchdog can be used to reboot the system if the PLC gets stuck (i.e. in an endless loop).

The watchdog can be disabled by bEnable = FALSE.

Attention:
The Watchdog has to be disabled before using breakpoints, before a PLC reset or PLC reset all, before a TwinCAT Stop, a change to Config Mode or before activating the configuration, otherwise the CP66xx-xxxx-0000 reboots immediately after the timeout time has expired!

FUNCTION F_CP66xxSetWatchdog : BOOL

VAR_INPUT

VAR_INPUT
    tTimeout		: TIME;
    bEnable 		: BOOL;
END_VAR

tTimeOut : Watchdog time, if expired a reboot is automatically executed.

bEnable : Activate or deactivate the watchdog.

Development environment | Target platform | PLC Libraries to include
TwinCAT v2.10.0 | CP66xx-xxxx-0000 (ARM) | TcSystemCP66xx.Lib


FUNCTION F_GetVersionTcCP66xxSystem

TwinCAT PLC Library: SystemCP66xx

FUNCTION F_GetVersionTcSystemCP66xx

The function returns library version info.

FUNCTION F_GetVersionTcSystemCP66xx : UINT

VAR_INPUT
    nVersionElement : INT;
END_VAR

nVersionElement : Version element:

  • 1 : major number;
  • 2 : minor number;
  • 3 : revision number;
Development environment | Target platform | PLC Libraries to include
TwinCAT v2.10.0 | CP66xx (ARM) | TcSystemCP66xx.Lib


FUNCTION BLOCK FB_CP66xxTemperatureSensor

This functional block serves the purpose of delivering the temperature value in degree Celsius (°C) measured by temperature sensors PT100, PT1000 or NI1000 connected to the Building Automation control panel PC CP6608. The temperature sensor is connected directly to the 12 pole I/O connector available on the control panel exterior. The temperature value supported is -50°C to 200°C only.

Insert the device named 'CP PC (CP6608)' under I/O Devices.

Further on, the variable 'Analog Input 1' is to be mapped to the PLC input variable.

FUNCTION BLOCK FB_CP66xxTemperatureSensor

VAR_INPUT

VAR_INPUT
    uiRawValue 		: UINT;
     eSensorType 		: E_SensorType;
     rTemperatureOffset 	: REAL;
END_VAR

uiRawValue : Analog Input 1 read from System Manager device CP PC(CP6608) is assigned to this variable.

eSensorType : Enum, including the sensor types supported.

TYPE E_SensorType :
(

eSensorType_PT100 := 0,
eSensorType_PT1000 := 1,
eSensorType_Ni1000TK := 2,
eSensorType_Ni1000DIN := 3
);
END_TYPE

rTemperatureOffset : Offset due to cable impedance or temperature offset can be given here.

VAR_OUTPUT

VAR_OUTPUT
    rTemperature 		: REAL;
     bErrorBrokenSensor 	: BOOL;
     bErrorOverRange 		: BOOL;
     bErrorUnderRange 		: BOOL;
END_VAR

rTemperture : The Temperature value calculated is shown here.

bErrorBrokenSensor : In case of broken sensor, short circuit or open circuit, error message is delivered.

bErrorOverRange : This variable is set to TRUE if rTemperature variable is greater than 200°C.

bErrorUnderRange : This variable is set to TRUE if rTemperature variable is less than -50°C.

Development environment | Target platform | PLC Libraries to include
TwinCAT v2.10.0 | CP6608 (ARM) | TcSystemCP66xx.Lib