TS6100 | TwinCAT OPC UA
Home
twincat communication web


Vorwort

TS6100 | TwinCAT OPC UA
Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Übersicht

Übersicht
Übersicht
OPC Unified Architecture (OPC UA) ist die nächste Generation des klassischen OPC-Standards. Es handelt sich hierbei um ein weltweit standardisiertes Kommunikationsprotokoll, mit dessen Hilfe sich Maschinendaten sowohl Hersteller-, als auch Plattformunabhängig austauschen lassen. Hierbei integriert OPC UA bereits direkt im Protokoll gängige Sicherheitsstandards. Ein weiterer großer Vorteil von UA gegenüber dem klassischen OPC-Standard ist die Unabhängigkeit vom COM/DCOM-System. Für detaillierte Informationen zu OPC UA sei auf die Webseiten der OPC Foundation verwiesen.
Komponenten
Folgende Softwarekomponenten wurden für Win32/64- und Windows CE-basierte Systeme eingebunden:
Software-Komponente | Beschreibung
OPC UA Server | Stellt eine OPC-UA-Server-Schnittstelle zur Verfügung, damit UA-Clients auf die TwinCAT-Laufzeit zugreifen können.
OPC UA Client | Stellt eine OPC-UA-Client-Funktionalität zur Verfügung, damit die Kommunikation mit anderen OPC UA Servern auf der Grundlage von PLCopen-genormten Funktionsbausteinen sowie einem einfach zu konfigurierenden I/O-Gerät möglich ist.
Folgenden Softwarekomponenten wurden für Win32/64-basierte Systeme eingebunden:
Software-Komponente (nur Windows) | Beschreibung
OPC UA Konfigurator | Grafische Benutzerschnittstelle für die Konfiguration des TwinCAT OPC UA Server
OPC UA Sample Client | Grafische Beispielimplementierung eines OPC UA Clients um einen ersten Verbindungstest mit dem TwinCAT OPC UA Server durchführen zu können.
OPC UA Gateway | Wrapper-Technologie, die sowohl eine OPC‑COM-DA-Server-Schnittstelle als auch OPC-UA-Server-Aggregationsfähigkeiten zur Verfügung stellt.
Weiterführende Informationen
•
Szenarien
•
Wichtige Information für OPC UA Clients
•
Versionsübersicht
•
Anwendungsbeispiele


Szenarien

Übersicht [image] Szenarien
Szenarien
Im Folgenden werden einige Szenarien erläutert, gemäß derer die Komponenten je nach Anwendungsfall und Infrastruktur des Kunden implementiert und verwendet werden können:
▪
OPC UA Server: Integriert in Industrie-PC oder Embedded-PC
▪
OPC UA Server: Läuft auf einem Zentralrechner mit Verbindung zu ferner(n) TwinCAT‑Laufzeit(en).
▪
OPC UA Server: Zugriff auf BC Controller
OPC UA Server: Integriert in Industrie-PC oder Embedded-PC
Hinweis
Empfohlenes Szenario
Dieses Szenario beschreibt, wie der TwinCAT OPC UA Server unter normalen Umständen eingesetzt werden sollte.
Einer der größten Vorteile des TwinCAT OPC UA Servers besteht darin, dass er selbst in die kleinste Embedded-Plattform, z. B. die CX8000-Baureihe, integriert werden kann. Dank dieser Integration ist das allgemeine Handling sehr einfach und komfortabel. OPC UA Clients, z. B. HMI-oder MES/ERP-Systeme, können eine Verbindung mit dem OPC UA Server herstellen und aus der TwinCAT-Laufzeit stammende Symbolinformationen lesen oder schreiben.
Auf dem zentralen Server laufen folgende Softwarekomponenten und Konfigurationen:
▪
Dritter OPC UA Client, der z. B. ein HMI-, MES-, oder ERP-System sein kann.
Auf dem Industrie-PC oder Embedded-PC laufen folgende Softwarekomponenten und Konfigurationen:
▪
Der TwinCAT OPC UA Server stellt automatisch eine Verbindung mit der ersten lokalen TwinCAT‑SPS‑Laufzeit her.
▪
TwinCAT-Laufzeit
Dieses Szenario hat folgende Vorteile:
▪
Die Netzwerknutzung ist optimiert, weil sie auf OPC-UA-Kommunikationstechniken aufbaut, z. B. OPC-UA-Registrierungen.
▪
Die Speichernutzung ist dezentral. Jedes Gerät ist ausschließlich für den eigenen Speicherbedarf zuständig.
▪
Sicherheit – OPC UA verfügt über direkt ins Protokoll integrierte Sicherheitsmechanismen. Dies ist z. B. sehr praktisch, wenn einer der Industrie-PCs oder Embedded-PC übers Internet verbunden ist.
OPC UA Server: Läuft auf einem Zentralrechner mit Verbindung zu ferner(n) TwinCAT-Laufzeit(en)
Dieses Szenario beschreibt die klassische Implementierung von OPC-Server. Server, die die alte OPC‑DA‑Technologie verwenden, waren häufig auf einem zentralen Server implementiert, statt auf dem Industrie-PC, auf dem die TwinCAT-Laufzeit ausgeführt wird, um die DCOM-Konfigurationen zu vermeiden. (Zur Erinnerung: Im Gegensatz zu OPC UA basiert OPC DA auf COM/DCOM‑Technologien)
Auf dem zentralen Server laufen folgende Softwarekomponenten und Konfigurationen:
▪
TwinCAT 3 ADS (oder TwinCAT 2 CP) für die erforderliche ADS-Konnektivität
▪
TwinCAT OPC UA Server mit Datenzugriffsgeräten für ferne TwinCAT-Laufzeiten konfiguriert
▪
ADS-Routen zu fernen TwinCAT-Laufzeiten
▪
Symboldateien von jeder fernen TwinCAT-Laufzeit
▪
OPC UA Client, der z. B. ein HMI-, MES- oder ERP-System sein kann.
Auf dem Industrie-PC oder Embedded-PC laufen folgende Softwarekomponenten und Konfigurationen:
▪
TwinCAT-Laufzeit
▪
ADS-Route zum zentralen Server
Je mehr ferne TwinCAT-Laufzeiten mit dem zentralen TwinCAT OPC-US Server verbunden werden, desto höher ist die Netzwerknutzung
Der OPC UA Server verwendet fortschrittliche ADS-Aufzeichnungstechniken, um die Symbolwerte von der TwinCAT-Laufzeit abzufragen. Je mehr Symbole vorhanden sind, desto mehr zyklische Abfragen sind unterwegs. Demzufolge findet die optimierte OPC-UA-Kommunikation nur lokal auf dem zentralen Server statt (zwischen OPC UA Client und OPC UA Server).
Dieses Szenario weist im Vergleich zu Szenario 1 folgende Nachteile auf:
▪
Die Netzwerknutzung kann abhängig von der Anzahl vorhandener Geräte und Symbole sehr hoch sein.
▪
Der Speicherbedarf auf dem zentralen Server ist sehr hoch, weil der OPC UA Server Symbolinformationen von jeder TwinCAT-Laufzeit importieren muss.
▪
Keine Sicherheit zwischen zentralem Server und der TwinCAT-Laufzeit dank Datenverschlüsselung – ADS wurde auf hohe Leistung ausgelegt.
▪
Die Notwendigkeit, bei jeder SPS-Programmänderung Symboldateien zwischen TwinCAT‑Laufzeit und zentralem Server auszutauschen.
OPC UA Server: Zugriff auf BC Controller
Auch wenn kleine BC Controller nicht in der Lage sind, einen eigenen OPC UA Server auszuführen, können Sie trotzdem Zugriff auf die auf einem fernen BC Controller, z. B. ein BC9191, ausgeführte SPS‑Laufzeit haben und deren Symbolwerte über OPC UA veröffentlichen. Bei diesem Szenario muss der OPC UA Server zusammen mit einer TwinCAT 3 ADS (oder TwinCAT 2 CP) auf einem anderen Rechner ausführt und das Szenario auf die gleiche Weise wie Szenario 2 konfiguriert werden.


Wichtige Information für OPC UA Clients

Übersicht [image] Wichtige Information für OPC UA Clients
Wichtige Information für OPC UA Clients
In der nachfolgenden Änderungsübersicht werden wichtige Unterschiede zwischen den Produktversionen dargestellt. Diese Informationen sind wichtig, wenn das Softwareprodukt eine bedeutende Softwareaktualisierung erfährt.
Änderungsübersicht TwinCAT OPC UA Server
Wichtige Änderungen in der Version | Komponente | Anmerkungen
Alle Versionen | Arrays in einem SPS-Programm | Standardmäßig werden Array-Elemente eines SPS-Arrays nicht als getrennte Knoten im UA-Namensraum angezeigt. Stattdessen wird nur ein Knoten für das gesamte Array verwendet und UA-Clients können auf jedes Element über dessen IndexRange zugreifen. Siehe auch: Verwendung von Arrays
2.1 | Aufzählungen (Enums) in einem SPS-Programm | Standardmäßig werden Aufzählungen in einem SPS-Programm nicht als EnumTypen im UA-Namensraum angezeigt. In der vorherigen Version waren diese einfach ein Int16.
2.1 | NamespaceName | Seit der Version 2.1 wird der NamespaceName gemäß dem URI-Konzept generiert und beinhaltet stets den Hostnamen des Rechners, auf dem der UA-Server läuft. In älteren Versionen ist der NamespaceName gleich dem Namen, der im Configurator Tool festgelegt wurde, z. B. „PLC1“. Diese Information ist besonders dann wichtig, wenn ein UA-Client vor dem Zugriff auf einen Knoten den NamespaceName in einen NamespaceIndex auswertet. Für Kompatibilitätszwecke und zur Vereinfachung der Aktualisierung ohne Eingriff auf den UA-Client, bietet die Version 2.2 des TwinCAT OPC UA Servers einen Mechanismus, um das alte NamespaceName-Konzept zu aktivieren. Siehe auch: TwinCAT OPC UA Server
2.2 | Strukturen in SPS | Seit Version 2.2.x kann auf Strukturen in einem SPS-Programm über ein StructuredType im UA-Namensraum zugegriffen werden. Dadurch können UA‑Clients Typen von Elementen im STRUCT interpretieren. Siehe auch: Strukturierte Typen
2.2 | Namensraum-Auslegung einer C++-Modulinstanz | Im Vergleich zu älteren Versionen (bis 2.1.x) wurde der UA-Namensraum eines C++‑Moduls in Version 2.2.x neu entworfen, um fortschrittliche Funktionalitäten, wie Methodenaufruf für eine C++‑Modulinstanz zuzulassen.


Versionsübersicht

Übersicht [image] Versionsübersicht
Versionsübersicht
Das Supplement/Function-Produkt TwinCAT OPC UA wird in verschiedenen Setupversionen ausgeliefert, welche unterschiedliche Entwicklungsstände widerspiegeln. Für neue Projekte wird der Wechsel auf die aktuellste Setupversion empfohlen, um alle neuen Produktfunktionalitäten verwenden zu können. Für Bestandsprojekte stehen weiterhin ältere Setupversionen zum Download bereit.
Aktuell gibt es zwei Versionsstände:
▪
Setupversion 3.x.x: Langjährige Bestandsversion, welche bereits eine Vielzahl an Funktionen bietet. Die Version wird weiterhin im Hinblick auf Optimierungen gepflegt.
▪
Setupversion 4.x.x: Neue Version. Zukünftige Weiterentwicklungen und neue Produktfunktionalitäten finden nur noch in dieser Version statt.
Die folgende Tabelle gibt einen Überblick über die verschiedenen Versionsstände im Hinblick auf deren Produktfunktionalitäten.
Funktionalität | 3.x.x | 4.x.x | Bemerkungen
Data Access SPS | ja | ja | Ermöglicht Lese/Schreib-Zugriff auf die TwinCAT-2/3-SPS
Data Access TcCOM | ja | ja | Ermöglicht Lese/Schreib-Zugriff auf TwinCAT-3-TcCOM-Module
Data Access I/O Task | ja | ja | Ermöglicht Lese/Schreib-Zugriff auf die TwinCAT-2/3-I/O-Task
Data Access BC Steuerungen | ja | ja | Ermöglicht Lese/Schreib-Zugriff auf Beckhoff-BC-Steuerungen
Historical Access SPS | ja | ja | Ermöglicht die Aktivierung von Variablen aus der TwinCAT-2/3-SPS für Historical Access
Historical Access TcCOM | ja (nur TC3 C++) | ja | Ermöglicht die Aktivierung von Variablen aus einem TwinCAT-3-TcCOM-Modul für Historical Access
Historical Access I/O Task | nein | ja | Ermöglicht die Aktivierung von Variablen aus einer TwinCAT-2/3-I/O-Task für Historical Access
Historical Access BC Steuerungen | nein | ja | Ermöglicht die Aktivierung von Variablen aus einer Beckhoff-BC-Steuerung für Historical Access
Historical Access für existierende Projekte | nein | ja | Ermöglicht die Aktivierung von Variablen für Historical Access ohne dabei das Laufzeitprojekt anpassen zu müssen
Alarms & Conditions SPS | ja | ja | Ermöglicht die Aktivierung von Variablen aus der TwinCAT 2/3 SPS für Alarms & Conditions
Alarms & Conditions TcCOM | nein | ja | Ermöglicht die Aktivierung von Variablen aus einem TwinCAT-3-TcCOM-Modul für Alarms & Conditions
Alarms & Conditions I/O Task | nein | ja | Ermöglicht die Aktivierung von Variablen aus einer TwinCAT-2/3-I/O-Task für Alarms & Conditions
Alarms & Conditions BC Steuerungen | nein | ja | Ermöglicht die Aktivierung von Variablen aus einer Beckhoff-BC-Steuerung für Alarms & Conditions
Alarms & Conditions für existierende Projekte | nein | ja | Ermöglicht die Aktivierung von Variablen für Alarms & Conditions ohne dabei das Laufzeitprojekt anpassen zu müssen
Methodenaufrufe SPS | ja | ja | OPC UA Server ermöglicht die Aktivierung und Darstellung von TwinCAT‑3‑SPS‑Methoden als OPC‑UA‑Methode
Methodenaufrufe TcCOM | ja (nur TC3 C++) | ja | OPC UA Server ermöglicht die Aktivierung und Darstellung von TwinCAT‑3‑C++‑Methoden als OPC‑UA‑Methode
Security X509 Zertifikate self-signed | ja | ja, konfiguierbar | Generierung von selbst-signierten Zertifikaten
Security X509 Zertifikate custom | ja | ja | Ermöglicht die Verwendung von eigenen Zertifikatsautoritäten
Security Benutzerauthentifizierung | ja | ja | OPC UA Server ermöglicht Authentifizierung von lokalen oder Domänenbenutzern
Security Zugriffslevel Namespace-Ebene | nein | ja | OPC UA Server ermöglicht Definition von verschiedenen Zugriffsleveln auf Namensraum-Ebene
Security Zugriffslevel Node-Ebene | nein | ja | OPC UA Server ermöglicht Definition von verschiedenen Zugriffsleveln auf Node-Ebene
Konfigurator im Visual Studio | nein | ja | -
Konfigurator Remotezugriff | nein | ja | Konfigurator ermöglicht die Remote-Konfiguration von TwinCAT OPC UA Servern unabhängig vom verwendeten Betriebssystem auf dem Zielgerät.


Anwendungsbeispiele

Übersicht [image] Anwendungsbeispiele
Anwendungsbeispiele
Weiterführende Informationen
•
Nachbearbeitung in der Cloud


Nachbearbeitung in der Cloud

Übersicht [image] Anwendungsbeispiele [image] Nachbearbeitung in der Cloud
Nachbearbeitung in der Cloud
Das Gesamtkonzept zur Bereitstellung einer generischen, standardisierten und aufrufbaren Schnittstelle in der Cloud, die eingehende Daten zur weiteren Analyse akzeptiert, basiert – neben den dezentralisierten Clients, die diesen Service aufrufen – auf einem Endpunkt in der Cloud, der entweder eine Windows-basierte virtuelle Maschine oder ein echte Hardware ist, auf der ein Windows Betriebssystem läuft. In dieser Dokumentation wird dieses Gerät im Allgemeinen als „OPC UA Server” (in der Cloud) bezeichnet.
Grafik aus Post-processing in the Cloud (ie2en0n1.png)
Anwendungsbeispiel: Daten-Logger
Das Gesamtdokument zeigt, wie auf Rechenressourcen in der Cloud zugegriffen werden kann und dezentrale TwinCAT-SPS-Geräte angeschlossen werden können, um diese Ressourcen zu nutzen. Als erstes Anwendungsbeispiel kann dieser Anwendungsfall auf ein typisches Datenspeicherungsszenario angewandt werden, in dem dezentrale TwinCAT-SPS-Geräte Daten an die Cloud senden, in der die eingehenden Daten in einer SQL-Datenbank über den TwinCAT Database Server gespeichert werden. Obwohl das allgemeine Szenario ebenfalls das Hin- und Zurücksenden von Daten umfasst (d. h. Senden von Parametern an die Cloud, Ausführung der Berechnungen in der Cloud und dann Rücksendung der berechneten Ergebnisse), erfordert dieses spezifische Szenario nicht die Rückgabe von Ergebnissen aus der Cloud.
Grafik aus Post-processing in the Cloud (ifdspl62.png)
Systemanforderungen: OPC UA Server („Die Cloud“)
Die Cloud muss in der Lage sein, eine der folgenden Betriebssystemvarianten zu hosten. Beachten Sie dabei, dass die Verwendung von Virtualisierungstechnologie eine kostenintensivere Lösung für 64‑Bit‑Betriebssysteme erfordert.
Gerät ist eine virtuelle Maschine
▪
32-Bit-Windows-Betriebssystem
▪
64-Bit-Windows-Betriebssystem mit CPU Core Isolation (mindestens 2 Kerne erforderlich)
Gerät ist eine dedizierte Hardware
▪
32-Bit-Windows-Betriebssystem
▪
64-Bit-Windows-Betriebssystem
Zusätzlich müssen die folgenden Softwarekomponenten auf dem Gerät installiert werden:
▪
TwinCAT 3 XAR (nur Runtime) oder XAE (Runtime und Engineering)
▪
TwinCAT 3 Function TF6100 OPC UA
Beachten Sie, dass bei Installation eines kompletten TwinCAT 3 XAE weitere Konfigurationseinstellungen sinnvoll sein können, wie z. B. das Handling von Lizenzen oder die Möglichkeit zum Debuggen des Geräts direkt in der Cloud. Zum Speichern von Daten in einer zentralen Datenbank die von einem Client eingehen, müssen die folgenden Softwarekomponenten installiert sein:
▪
TwinCAT 3 Function TF6420 Database
Systemanforderungen: Dezentralisierter OPC UA Client
Der dezentralisierte OPC UA Client basiert auf einer TwinCAT-3-SPS-Laufzeit und kann daher auf jeder Hardwarekonfiguration gehostet werden, die den Betrieb einer TwinCAT-3-SPS unterstützt. Zudem muss die TwinCAT 3 Function TF6100 OPC UA auf dem Client-Gerät installiert werden, um den TwinCAT OPC UA Client nutzen zu können, um UA-Methoden auf dem Server in der Cloud auszuführen.
Technische Beschreibung
Die Realisierung eines OPC UA Servers in der Cloud ist sehr anwendungsspezifisch. Beckhoff stellt eine allgemeine Architekturbeschreibung zur Verfügung, unabhängig von dem Anwendungsfall im Einzelnen. Als Anwendungsbeispiel beschreibt dieser Artikel häufig ein Datenaggregationsszenario, bei dem Prozessdaten von dezentralisierten Clients über OPC UA zu einem zentralen Server übertragen werden, auf welchem die Daten in einer zentralen Datenbank angesammelt werden. Der Vorteil von OPC UA besteht in diesem Fall nicht nur in der standardisierten Schnittstelle (und daher zur Nutzung dieses Konzepts für jede Art von OPC UA Client), sondern auch in der Möglichkeit, den Kommunikationskanal zu sichern, indem der integrierte Sicherheitsmechanismus von OPC UA eingesetzt wird.
Der TwinCAT OPC UA Server wird verwendet, um die in der IEC61131-3 SPS-definierten Methoden dem OPC‑UA‑Namensraum offenzulegen. Diese Methoden können von jedem TwinCAT OPC UA Client (auf der Grundlage der PLCopen‑Funktionsbausteine) oder von 3rd-Party OPC UA Clients aufgerufen werden.
Dezentralisierter OPC UA Client
Der Hauptzweck des OPC UA Clients besteht darin, Methoden auf dem Remote-Server aufzurufen. Der Client ist mit großer Wahrscheinlichkeit ein TwinCAT-3-Embedded-Gerät, das den dezentralen Teil der Anwendung erfüllt. Dies würde für das Datenaggregations-Beispiel bedeuten, Prozessdaten abzufragen und sie durch Aufruf einer Methode an den Server zu senden.
Schnittstellenbeschreibung (zur Cloud)
Als Schnittstelle zu einem zentralisierten Cloud-System gibt es nur zwei vom Server bereitgestellte Methoden:
▪
int Send(data): Diese Methode überträgt die Daten über einen OPC-UA-Methodenaufruf vor und gibt eine JobID zurück
▪
int QueryState(jobID): Unter Verwendung der zuvor abgerufenen JobID kann der Client zyklisch den aktuellen Status des Jobs abfragen. Dies könnte ausgelassen werden, wenn der Server in der Cloud alle Situationen bearbeiten kann oder der Client bei Problemen ohnehin nicht aushelfen kann.
Die Kommunikation zwischen Clients und der Cloud kann durch die eingebauten Sicherheitskonzepte von OPC UA gesichert werden, z. B. durch die Verwendung von Client- und Server-Zertifikaten zur Verschlüsselung der Datenkommunikation.
Die Cloud
Der OPC UA Server in der Cloud basiert auf TwinCAT-3-SPS-Methoden, die dem OPC‑UA‑Namensraum offengelegt werden. Das SPS-Projekt enthält die folgenden drei Komponenten:
▪
MethodCall Provider: Diese Komponente bietet die zuvor erwähnte Send-Methode, bei der Daten gesammelt, eine JobID erstellt und die Daten als verschiedene Jobs in die Queue eingestellt werden. Darüber hinaus könnte es eine QueryState-Methode geben, um es OPC UA Clients zu ermöglichen, den aktuellen Jobstatus abzufragen.
▪
Queue: Die Warteschlange speichert eine Liste der Jobs, die ausgeführt werden sollen. Jeder Job in der Warteschlange enthält die folgenden Informationen: {ID, Status, Data}. Neue Elemente (Jobs) werden durch den MethodCall Provider hinzugefügt und können durch diesen auch gelöscht werden. Die gesamte Warteschlange kann innerhalb des SPS-Programms auf einer Hash-Tabelle basieren.
▪
Aggregator: Die Anwendung, die die Jobs verarbeitet. Sie schaut zyklisch in der Queue, ob es zu bearbeitende Jobs gibt. Wenn dies der Fall ist, übernimmt sie den Job (stellt den Status auf „verarbeitet“) und beginnt mit der Verarbeitung des Jobs, z. B. der Verbindung zu einer Datenbank über die Funktionsbausteine des TwinCAT Database Server. Beachten Sie, dass es mehr als einen Aggregator geben kann, um eine parallele Verarbeitung der Queue zu ermöglichen.
Grafik aus Post-processing in the Cloud (ivkkemq1.png)
Beispiel
Das folgende Beispiel illustriert das Szenario durch die Ausführung einfacher Jobs: Jobs können dem Server von einem OPC UA Client vorgelegt werden. In diesem Beispiel bestehen die Jobdaten aus einem definierbaren Zeitintervall, das vom Aggregator aufgenommen wird, um den Job fertigzustellen. Das Beispiel besteht aus den folgenden SPS-Komponenten auf dem OPC UA Server:
▪
ST_JobEntry: Repräsentiert einen Job in der Queue. Der Job besteht bei den Daten lediglich aus einem Namen und einer Zeitdauer. Eine Dauer definiert die Zeitspanne, die ein Job benötigt.
▪
E_JobState: Repräsentiert den Status eines Jobs. Die Beispielimplementierung definiert die folgenden Werte: QUEUED, PROCESSING, READY, FAILED und INVALID.
▪
LongTerm: Repräsentiert den MethodCall Server (besteht aus den Methoden Calc_Request und Calc_Response) sowie den Aggregator, der den Job verarbeitet (der im Funktionsbaustein implementiert ist)
▪
FB_SpecialHashTableCtrl: Repräsentiert die Queue in Form einer Hash-Tabelle, wie dies durch SPS-Beispiele vom Beckhoff Informationssystem wiedergegeben ist. Hier werden verschieden Methoden zum Umgang mit der Warteschlange gegeben (Hinzufügen, Zählen, GetFirst, GetNext, Lookup, Entfernen, Zurücksetzen).
Verwendung des Beispiels
Der UA-Expert könnte als Beispiel-Client verwendet werden, um die Methoden aufzurufen, die vom OPC UA Server in der Cloud bereitgestellt werden. Durch Aufruf der Methode Calc_Request erhält der Client eine JobID (oder 0 zur Anzeige eines Fehlers):
Grafik aus Post-processing in the Cloud (ij24v1l1.png)
Indem die zurückgegebene JobId zur Methode Calc_Response gebracht wird, kann der Client den JobState abfragen.
Grafik aus Post-processing in the Cloud (igclmg7.png)
Zudem werden die vorher eingestellte Dauer und der Jobname als spätere Referenz zurückgegeben.
Installation
Das folgende Kapitel beschreibt die Installation und Konfiguration jeder Softwarekomponente, die auf dem Server in der Cloud erforderlich ist.
Nur Runtime
Wenn der Server nicht die Engineering‑Umgebung von TwinCAT 3 hostet, muss die TwinCAT‑3‑XAR‑Installation verwendet werden. Beachten Sie, dass in diesem Fall das gesamte Handling zur ordnungsgemäßen Funktion mehrere Schritte involviert und die zukünftige Wartung ggf. schwieriger ist, da der XAR-Installation die Programmierungs- und Debugging-Umgebung fehlt. In diesem Szenario muss der Benutzer sicherstellen, dass die Pflege der ADS-Routen zwischen dem tatsächlichen Engineering-Computer (auf dem das SPS-Programm für den Server entwickelt wird) und dem Gerät, das den Server in der Cloud hostet, nicht nur den Download und das Debugging des SPS-Programms erlauben muss, sondern auch die Aktivierung von Lizenzen für die TwinCAT‑3‑Laufzeit. Beachten Sie, dass Sie die Firewall-Ports öffnen müssen, um ADS-Verkehr zu ermöglichen. In der ADS‑Dokumentation erhalten Sie weitere Informationen. Zur einfacheren Handhabung der TwinCAT‑3‑Laufzeitlizenzen wurde das Tool TC3 License Request Generator entwickelt. Dieses kann über den Beckhoff FTP-Server heruntergeladen werden und ermöglicht die Erstellung von License Request Files und den Import von License Response Files:
Runtime und Engineering
Dies ist das empfohlene Setup-Szenario. Der Server in der Cloud hostet eine TwinCAT 3 Runtime und die entsprechenden Engineering‑Komponenten, um das Debuggen und eine einfachere Handhabung des Laufzeitsystems zu ermöglichen. In diesem Fall ist es erforderlich, TwinCAT 3 XAE auf dem System zu installieren.
Zusätzliche Software
Nach erfolgreicher Installation von TwinCAT XAE oder XAR müssen die folgenden Softwarekomponenten auf dem Gerät installiert und konfiguriert werden:
TF6100 OPC UA
Die Function TF6100 installiert einen OPC UA Server (und Client) auf dem Gerät. Der Server ist erforderlich, um den OPC UA Clients die SPS-Methoden zur Verfügung zu stellen. Wenn das SPS-Programm in die Laufzeit heruntergeladen wird, importiert der OPC UA Server automatisch die erste SPS-Laufzeit in seinen Namensraum. Sämtliche Variablen und Methoden der SPS, die als verfügbar über OPC UA gekennzeichnet sind, werden in den OPC-UA-Namensraum importiert und werden für Clients verfügbar. In der TF6100-Dokumentation erhalten Sie weitere Informationen.
TF6420 Database
Wenn der Server die von den Clients erhaltenen Daten in einer Datenbank speichern soll, muss die TF6420-Function verwendet werden. Sie bietet generische Funktionsblöcke für die TwinCAT-3-SPS für den Zugriff auf die Datenbank, z. B. um Werte in eine Datenbanktabelle einzufügen. Installieren Sie das TF6420-Setup und konsultieren Sie die TF6420-Dokumentation für weitere Informationen zur Nutzung der entsprechenden Funktionsbausteine.
Lizenzierung
Alle TwinCAT‑3‑Softwareprodukte erfordern eine Lizenz, um auf dem Server verfügbar zu sein. Die Lizenz kann entweder aus einer 7-Tage-Testlizenz oder aus einer uneingeschränkten Lizenz bestehen. Lizenzen können unter Verwendung des TwinCAT 3 XAE Lizenzmanagers aktiviert werden. Wenn eine TwinCAT-3-XAR-Installation auf dem Server verwendet wird, verwenden Sie den TC3 License Generator.


Installation

Installation
Installation
Weiterführende Informationen
•
Systemvoraussetzungen
•
Installation
•
Installation Windows CE
•
Installation TC2
•
Installation Windows CE TC2
•
Lizenzierung
•
Lizenzierung TC2


Systemvoraussetzungen

Installation [image] Systemvoraussetzungen
Systemvoraussetzungen
OPC UA Server | Beschreibung
Betriebssystem | Windows 7, 10 Windows CE 6/7 Windows Embedded Standard 2009 Windows Embedded 7 Windows Server 2008 R2 Windows Server 2012
Zielplattformen | PC Architektur (x86, x64)
.NET Framework | 4.5.2 (nur benötigt für Konfigurator)
TwinCAT-Version | TwinCAT 2, TwinCAT 3
TwinCAT-Installationslevel | TwinCAT 2 CP, PLC, NC-PTP TwinCAT 3 XAE, XAR, ADS
Benötigte TwinCAT-Lizenz | TS6100 TwinCAT OPC UA (für TwinCAT 2) TF6100 TC3 OPC UA (für TwinCAT 3)
OPC UA Client | Beschreibung
Betriebssystem | Windows 7, 10 Windows CE 6/7 Windows Embedded Standard 2009 Windows Embedded 7 Windows Server 2008 R2 Windows Server 2012
Zielplattformen | PC Architektur (x86, x64)
.NET Framework | ---
Minimale TwinCAT-Version | TwinCAT 2, TwinCAT 3
Minimales TwinCAT-Installationslevel | TwinCAT 2 PLC, NC-PTP TwinCAT 3 XAE, XAR
Benötigte TwinCAT-Lizenz | TS6100 TwinCAT OPC UA (für TwinCAT 2) TF6100 TC3 OPC UA (für TwinCAT 3)
OPC UA Gateway | Beschreibung
Betriebssystem | Windows 7, 10 Windows Embedded Standard 2009 Windows Embedded 7 Windows Server 2008 R2 Windows Server 2012
Zielplattformen | PC Architektur (x86, x64)
.NET Framework | ---
Minimale TwinCAT-Version | ---
Minimales TwinCAT-Installationslevel | ---
Benötigte TwinCAT-Lizenz | ---
OPC UA Konfigurator | Beschreibung
Betriebssystem | Windows 7, 10 Windows Embedded Standard 2009 Windows Embedded 7 Windows Server 2008 R2 Windows Server 2012
Zielplattformen | PC Architektur (x86, x64)
.NET Framework | 4.5.2
Minimale TwinCAT-Version | TwinCAT 2 (Standalone-Tool, bis Setupversion 3) TwinCAT 3 (Visual Studio integriert, ab Setupversion 4)
Minimales TwinCAT-Installationslevel | TwinCAT 2 CP, PLC, NC-PTP (Standalone-Tool, bis Setupversion 3) TwinCAT 3 XAE, XAR, ADS (Standalone-Tool, bis Setupversion 3) TwinCAT 3 XAE (Visual Studio integriert, ab Setupversion 4)
Benötigte TwinCAT-Lizenz | ---
OPC UA Sample Client | Beschreibung
Betriebssystem | Windows 7, 10 Windows Embedded Standard 2009 Windows Embedded 7 Windows Server 2008 R2 Windows Server 2012
Zielplattformen | PC Architektur (x86, x64)
.NET Framework | 4.0
Minimale TwinCAT-Version | ---
Minimales TwinCAT-Installationslevel | ---
Benötigte TwinCAT-Lizenz | ---


Installation

Installation [image] Installation
Installation
Die Installation der TwinCAT 3 Function für Windows basierte Betriebssysteme erfolgt Schritt-für-Schritt.
1.
Führen Sie einen Doppelklick auf die herunter geladene Datei TFxxxx aus.
Hinweis: Bitte starten Sie die Installation unter Windows per Als Administrator ausführen, indem Sie die Setup-Dateien mit der rechten Maus anklicken und die entsprechende Option im Kontextmenü auswählen.
2.
Klicken Sie auf Next und akzeptieren Sie die Endbenutzervereinbarung.
3.
Geben Sie Ihre Benutzerdaten ein.
4.
Für eine vollständige Installation wählen Sie Complete als Installationstyp. Alternativ können Sie jede Komponente separat installieren, indem Sie Custom wählen.
5.
Wählen Sie Next und Install um die Installation zu beginnen.

Das TwinCAT System muss gestoppt werden um mit der Installation fortzufahren.
6.
Bestätigen Sie den Dialog mit Yes.
7.
Wählen Sie Finish um das Setup zu beenden.
⇨
Damit ist die Installation abgeschlossen.
Der nächste Schritt nach einer erfolgreichen Installation ist die Lizenzierung der TC3 Function.


Installation Windows CE

Installation [image] Installation Windows CE
Installation Windows CE
Nachfolgend wird beschrieben, wie die TwinCAT 3 Function TF6100 OPC UA auf einem Beckhoff Embedded Controller mit Windows CE installiert wird.
Die Installation besteht aus vier Schritten:
▪
Download der Setup-Datei
▪
Installation auf einem Host-Computer
▪
Übertragung der ausführbaren Datei auf das Windows-CE-Gerät
▪
Installation der Software
Wenn schon eine ältere TF6100-Version auf dem Windows-CE-Gerät installiert ist, kann diese aktualisiert werden:
▪
Upgrade der Software
Download der Setup-Datei
Die für Windows CE ausführbare Datei ist Teil des TF6100-OPC-UA-Setups. Dieses wird Ihnen auf der Beckhoff Homepage www.beckhoff.com zur Verfügung gestellt und enthält automatisch alle Versionen für Windows XP, Windows 7 und Windows CE (x86 und ARM).
Die Installation für das TF6100-OPC-UA-Setup ist im Abschnitt Installation beschrieben.
Installation auf einem Host-Computer
Nach der Installation enthält der Installationsordner drei Verzeichnisse - jeweils ein Verzeichnis pro Hardwareplattform:
▪
CE-ARM: ARM-basierte Embedded Controller, welche unter Windows CE laufen, z. B. CX8090, CX9020
▪
CE-X86: X86-basierte Embedded Controller, welche unter Windows CE laufen, z. B. CX50xx, CX20x0
▪
Win32: Embedded Controller, welche unter Windows XP, Windows 7 oder Windows Embedded Standard laufen
Die Verzeichnisse CE-ARM und CE-X86 enthalten die CAB-Dateien der TF6100 Function für Windows CE in Bezug auf die jeweilige Hardwareplattform des Windows-CE-Geräts. Übertragen Sie diese ausführbaren Dateien auf das Windows-CE-Gerät.
Übertragen der ausführbaren Datei auf das Windows-CE-Gerät
Für die Übertragung der ausführbaren Dateien, stehen Ihnen verschiedene Möglichkeiten zur Verfügung:
▪
über Netzwerkfreigaben
▪
über den integrierten FTP-Server
▪
über ActiveSync
▪
über CF/SD Karten
Weitere Informationen finden Sie im Beckhoff Informationssystem im Windows‑CE‑Bereich.
Installation der Software
Nachdem Sie die Datei auf das Windows-CE-Gerät übertragen haben, führen Sie die Datei dort mit einem Doppelklick aus. Den Installationsdialog können Sie mit OK bestätigen. Starten Sie das CE-Gerät anschließend neu.
Nach dem Neustart des Geräts werden die ausführbaren Dateien (Client und Server) automatisch im Hintergrund geladen und sind verfügbar.
Die Software wird in dem folgenden Verzeichnis auf dem CE-Gerät installiert:
\Hard Disk\TwinCAT\Functions\TF6310-TCP-IP
Upgrade der Software
Wenn Sie schon eine ältere TF6100-Version auf dem Windows-CE-Gerät installiert haben, führen Sie die folgenden Schritte auf dem Windows-CE-Gerät durch, um auf eine neuere Version zu upgraden:
1.
Um den CE-Explorer zu öffnen, klicken Sie auf Start > Run, geben Sie „explorer“ und bestätigen Sie die Eingabe.
2.
Navigieren Sie nach \Hard Disk\TwinCAT\Functions\Tf6100-OPC-UA\Server bzw. (in einem zweiten Schritt) \Hard Disk\TwinCAT\Functions\Tf6100-OPC-UA\Client.
3.
Benennen Sie die Datei TcOpcUaServer.exe bzw. TcOpcUaClient.exe um.
4.
Starten Sie das Windows-CE-Gerät neu.
5.
Übertragen Sie die neue CAB-Datei auf das Windows-CE-Gerät.
6.
Installieren Sie die neue CAB-Datei.
7.
Löschen Sie die alten (umbenannten) Dateien.
8.
Starten Sie das Windows-CE-Gerät neu.
⇨
Nach dem Neustart ist die neue Version aktiv.


Installation TC2

Installation [image] Installation TC2
Installation TC2
Nachfolgend wird beschrieben, wie TwinCAT OPC UA unter Windows XP installiert wird.
Die Installation besteht aus drei Schritten:
▪
Download der Setup-Datei
▪
Starten der Installation
▪
Nach der Installation
Download der Setup-Datei
Genauso wie viele andere TwinCAT-Ergänzungsprodukte steht OPC UA als 30‑Tage‑Demoversion oder Vollversion zum Download auf der Beckhoff Homepage zur Verfügung.
Starten der Installation
1.
Doppelklicken Sie auf die heruntergeladene Setupdatei TcOpcUaSvr.exe. HINWEIS! Unter Windows 7 32bit/64bit starten Sie die Installation über den Befehl „Als Administrator ausführen“. Klicken Sie mit der rechten Maustaste auf die Setup-Datei und wählen Sie den entsprechenden Befehl im Kontextmenü.
2.
Wählen Sie eine Installationssprache.
3.
Klicken Sie auf Weiter und stimmen Sie der Lizenzvereinbarung zu.
Grafik aus Installation Tc2 (i7ud5kc1.png)
4.
Geben Sie Ihre Benutzerinformationen ein. Alle Felder müssen ausgefüllt werden. Wenn Sie eine 30-Tage-Demo installieren möchten, geben Sie bitte „DEMO“ als Lizenzschlüssel ein.
Grafik aus Installation Tc2 (iimv13l2.png)
5.
Klicken Sie auf Installieren, um die Installation zu starten.
Grafik aus Installation Tc2 (i4gasnj.png)
6.
Starten Sie den Computer neu, um die Installation abzuschließen.
Nach der Installation
Die TwinCAT-Ergänzung OPC UA wird automatisch während der Installation konfiguriert und es sind keine weiteren Einstellungen für die Nutzung dieses Produkts erforderlich. Zu den weiteren Schritten gehören gegebenenfalls:
▪
Stellen Sie eine erste Verbindung mit dem installierten UA-Server her und testen Sie dessen Konfiguration mit dem OPC UA Sample Client. (Siehe TwinCAT OPC UA Sample Client)
▪
Personalisieren Sie das UA-Server-Setup mithilfe des OPC‑UA‑Konfigurators. (Siehe Konfiguration)
▪
Vergewissern Sie sich zudem, dass Ihre Firewall den TCP Port 4870 öffnet, weil der OPC UC Server diesen Port benötigt.


Installation Windows CE TC2

Installation [image] Installation Windows CE TC2
Installation Windows CE TC2
Nachfolgend wird beschrieben, wie TwinCAT OPC UA auf einer Windows-CE-basierten Beckhoff-Embedded-PC-Steuerung, z. B. CX1000, CX1020, CX9000, CX9001, CX9010, CX8090, CP62xx, C69xx, … installiert wird.
Die Installation besteht aus vier Schritten:
▪
Download der Setup-Datei
▪
Installation auf einen Host-Computer
▪
Übertragen der Setup-Datei auf ein Windows-CE-Gerät
▪
Ausführen des Setup auf dem Windows-CE-Gerät
Hinweis
Installation auf kleinen Embedded-Plattformen (CX9001, CX9010)
Sehr kleine Embedded-Geräte erfordern möglicherweise einige zusätzliche manuelle Schritte, damit die CAB-Datei installiert werden kann. Zu diesen Schritten gehört möglicherweise die Löschung von unnötigen Dateien im Speicher der Geräte, damit ausreichend Platz bereitsteht, um alle Dateien der Anwendung zu installieren.
Download der Setup-Datei
Genauso wie viele andere TwinCAT-Ergänzungsprodukte steht OPC UA für CE als Download auf dem Beckhoff FTP-Server zur Verfügung.
Installation auf einen Host-Computer
Damit Sie die Installierungsdateien für Windows CE erhalten können, müssen Sie zunächst die heruntergeladene Setup-Datei auf einem Host-Computer installieren. Dieser kann ein beliebiges Windows-CE-basiertes System sein kann.
1.
Doppelklicken Sie auf die heruntergeladene Datei TcOpcUaSvrCE.exe
2.
Wählen Sie eine Installationssprache.
3.
Klicken Sie auf Weiter und stimmen Sie der Lizenzvereinbarung zu.
Grafik aus Installation Windows CE Tc2 (irb07pl3.png)
4.
Geben Sie ihre Benutzerinformationen ein. Alle Felder müssen ausgefüllt werden. Beachten Sie, dass OPC UA für CE derzeit nicht als Demo-Version verfügbar ist. Demzufolge benötigen Sie einen gültigen Lizenzschlüssel, um mit der Installierung fortzufahren.
Grafik aus Installation Windows CE Tc2 (ikeeluv2.png)
5.
Wählen Sie als Installationsart Vollständig und klicken Sie auf Weiter
Grafik aus Installation Windows CE Tc2 (ip6f7ll3.png)
6.
Klicken Sie auf Installieren, um die Installation zu starten.
⇨
Nach der Installierung finden Sie die Setup-Dateien für Windows CE im Verzeichnis .\TwinCAT\CE. Dieses Verzeichnis beinhaltet Setup-Dateien für die folgenden CE-Plattformen:
▪
TwinCAT OPC UA Client CE\I586: OPC UA Client (SPS-Bibliothek) für x86 basierte CPUs (wie CX10xx, CP62xx, C69xx, ...)
▪
TwinCAT OPC UA Client CE\ARMV4I: OPC UA Client (SPS-Bibliothek) für ARM basierte CPUs (wie CX9001, CX9010, CP6608, ...)
▪
TwinCAT OPC UA Server CE\I586: OPC UA Server für x86 basierte CPUs (wie CX10xx, CP62xx, C69xx, ...)
▪
TwinCAT OPC UA Server CE\ARMV4I: OPC UA Server für ARM basierte CPUs (wie CX9001, CX9010, CP6608, ...)
Übertragen der Setup-Datei auf ein Windows-CE-Gerät
Übertragen Sie die entsprechende Setup-Datei auf Ihr CE-Gerät. Für die Übertragung der Setup-Datei stehen Ihnen verschiedene Möglichkeiten zur Verfügung:
▪
über einen freigegebenen Ordner
▪
über den integrierten FTP-Server
▪
über ActiveSync
▪
über eine CF-Karte
Weitere Informationen finden Sie im Beckhoff Informationssystem im Windows‑CE‑Bereich.
Ausführen des Setup auf dem Windows-CE-Gerät
Führen Sie die übertragene Setup-Datei TcOpcUaSvrCe.xxxx.CAB auf dem CE Gerät aus:
1.
Navigieren Sie zu dem Verzeichnis, in das Sie die Setup-Datei übertragen haben.
Grafik aus Installation Windows CE Tc2 (ipb21v32.png)
2.
Doppelklicken Sie auf die CAB-Datei. Wird ein Meldungsdialog eingeblendet, dass dieses Programm nicht mit dem aktuellen Betriebssystem kompatibel ist, vergewissern Sie sich, dass Sie die richtige CAB-Datei (ARM, I586) für Ihren IPC/Embedded-PC verwenden.
3.
Wenn Sie sicher sind, dass die CAB-Datei zum Embedded-PC/IPC passt, bestätigen Sie diesen Meldungsdialog mit Ja.
Grafik aus Installation Windows CE Tc2 (i7nd0cg1.png)
4.
Wählen Sie \Hard Disk\System\ als Zielverzeichnis
Grafik aus Installation Windows CE Tc2 (i51h2g12.png)
5.
Klicken Sie auf OK, um die Installation zu starten.
Grafik aus Installation Windows CE Tc2 (irag07u2.png)
⇨
Nach der Installierung wird die Setup-Datei automatisch gelöscht.
HINWEIS! Wenn Sie den OPC UA Server installiert haben, wird diese Komponente nach einem Neustart Ihres CE-Geräts verfügbar.


Lizenzierung

Installation [image] Lizenzierung
Lizenzierung
Die TwinCAT 3 Function ist zusätzlich zur Vollversion auch in einer 7-Tage Testversion freischaltbar. Beide Lizenztypen sind über TwinCAT XAE aktivierbar. Weitere Information zum TwinCAT 3 Lizenzierungsverfahren finden Sie im TwinCAT 3 Hilfesystem. Das folgende Dokument beschreibt den Lizenzierungsvorgang einer TwinCAT 3 Function und gliedert sich dabei in die folgenden beiden Unterkapitel:
▪
Lizenzierung einer 7-Tage Testversion
▪
Lizenzierung einer Vollversion
Lizenzierung einer 7-Tage Testversion
1.
Starten Sie TwinCAT XAE
2.
Öffnen Sie ein bestehendes TwinCAT 3 Projekt, oder legen Sie ein neues Projekt an
3.
Navigieren Sie im Solution Explorer zum Eintrag System\License
4.
Öffnen Sie die Registerkarte Manage Licenses und fügen Sie eine Runtime License für Ihr Produkt hinzu (in diesem Screenshot TE1300: TC3 Scope View Professional)
5.
Optional : Möchten Sie die Lizenz für ein Remote Gerät hinzufügen, müssen Sie sich zunächst mit diesem Gerät über die TwinCAT XAE Toolbar verbinden

6.
Aktivieren Sie in der Registerkarte Order Information über den Button Activate 7 Days Trial License... eine Testversion

7.
Starten Sie im Anschluss daran das TwinCAT 3 System einmal neu
Lizenzierung einer Vollversion
1.
Starten Sie TwinCAT XAE
2.
Öffnen Sie ein bestehendes TwinCAT 3 Projekt oder legen Sie ein neues Projekt an
3.
Navigieren Sie im Solution Explorer zum Eintrag SYSTEM/License
4.
Öffnen Sie die Registerkarte Manage Licenses und fügen Sie eine Runtime License für Ihr Produkt hinzu (in diesem Screenshot TE1300: TC3 Scope View Professional).
5.
Optional: Möchten Sie die Lizenz für ein Remote Gerät hinzufügen, müssen Sie sich zunächst mit diesem Gerät über die TwinCAT XAE Toolbar verbinden
6.
Öffnen Sie die Registerkarte Order Information
Die Felder System-ID und HW Platform können nicht geändert werden, sie beschreiben die zu lizensierende Plattform. Generell wird eine TwinCAT 3 Lizenz an zwei Kennzahlen gebunden:
Die System-ID identifiziert Ihr Gerät eindeutig.
Die HW Platform ist eine Kennzahl für die Performanz des Gerätes.
7.
Tragen Sie optional eine eigene Bestellnummer und einen Kommentar für Ihre Zwecke ein
8.
Generieren Sie in der Registerkarte Order Information über den Button Generate License Request File... eine Lizenzanforderungs-Datei, die durch einen Beckhoff-Lizenzserver validiert wird (wenn Ihnen Ihre Beckhoff License ID nicht bekannt ist, wenden Sie sich an Ihren Ansprechpartner aus dem Beckhoff Vertrieb).
9.
Nachdem Sie das License Request File gespeichert haben, fragt das System, ob die Datei per Mail an den Beckhoff Lizenz Server geschickt werden soll:

10.
Wenn Sie den Dialog mit Yes bestätigen, öffnet sich Ihr Standard E-Mail Client und erzeugt eine neue E-Mail für tclicense@beckhoff.com, die das License Request File enthält
11.
Senden Sie diesen Activation Request an Beckhoff
HINWEIS! das License Response File wird an die dieselbe E-Mail Adresse versendet, die das License Request File verschickt hat
12.
Kurz darauf erhalten Sie vom Beckhoff-Lizenzserver eine Lizenzdatei,
importieren Sie diese über den Button Activate License Response File..., um das Produkt zu aktivieren

13.
Wählen Sie in Ihrem Ordnersystem das erhaltene License Response File aus

14.
Das License Response File wird importiert und alle enthaltenen Lizenzen werden aktiviert, sämtliche betroffenen Demo-Lizenzen werden entfernt
15.
Starten Sie TwinCAT neu, um die Lizenz zu aktivieren

HINWEIS! Das Lizenzfile wird automatisch auf Ihre lokale Festplatte unter ...\TwinCAT\3.1\Target\License kopiert.


Lizenzierung TC2

TS6100 | TwinCAT OPC UA
Installation [image] Lizenzierung TC2
Lizenzierung TC2
Die Lizenzierung der TwinCAT OPC UA für TC2 erfolgt im Rahmen der Installation per Eingabe eines Lizenzschlüssels.


Technische Einführung

Technische Einführung
Technische Einführung
Weiterführende Informationen
•
TwinCAT OPC UA Server
•
TwinCAT OPC UA Client
•
TwinCAT OPC UA Gateway
•
TwinCAT OPC UA Sample Client


TwinCAT OPC UA Server

Technische Einführung [image] TwinCAT OPC UA Server
TwinCAT OPC UA Server
Weiterführende Informationen
•
Übersicht
•
Quick Start
•
SPS
•
C++
•
I/O
•
Matlab/Simulink
•
Dateiübertragung
•
Sicherheit
•
Verschiedenes


Übersicht

Technische Einführung [image] TwinCAT OPC UA Server [image] Übersicht
Übersicht
Der TwinCAT OPC UA Server bietet eine standardisierte Kommunikationsschnittstelle für den Zugriff auf Symbolwerte aus der TwinCAT-SPS- und C++‑Laufzeit bzw. I/O‑Task.
Dieser Teil der Dokumentation beschreibt die Basiskonfiguration des TwinCAT OPC UA Servers.
Sie beinhaltet folgende Themenbereiche:
▪
OPC UA Configurator: Grafische Oberfläche zur Konfiguration des OPC UA Servers.
▪
OPC UA DA (Data Access): Zugriff auf TwinCAT-PLC- und IO-Task-Werte via OPC UA
▪
OPC UA HA (Historical Access): Bietet Möglichkeiten zur Speicherung von historischen Daten, z. B. im lokalen RAM, in einer Datei oder einer Datenbank
▪
OPC UA AC (Alarm & Conditioning): Bietet Condition-Monitoring-Funktionalitäten für SPS‑Variablen
▪
OPC UA Security: Beschreibt die in OPC UA integrierten Sicherheitsmechanismen
HINWEIS! Beachten Sie die Quick-Start-Anleitung zum Einstieg in die Thematik.
Erweiterte Konfiguration
Je nach Art der Betriebsumgebung sind gegebenenfalls zusätzliche Konfigurationsparameter erforderlich, um die folgenden Dinge einzustellen:
▪
Konfigurationsdatei: Beschreibung der Konfigurationsdatei ServerConfig.xml des OPC UA Servers. Diese Datei sollte üblicherweise über den OPC-UA-Konfigurator editiert werden (siehe Themenbereiche oben)
▪
Konfiguration von SPS-Variablen: Bietet eine Übersicht über alle konfigurierbaren Optionen (über SPS-Kommentare) an einer SPS-Variablen
▪
Weitere ADS-Geräte: Beschreibt, wie weitere TwinCAT-Geräte in den Namensraum des OPC UA Servers integriert werden
▪
Mehrere UA-Server: Beschreibt, wie Sie mehrere OPC-UA-Server-Instanzen auf einem Gerät starten können
▪
UA über NAT: Beschreibt, wie Sie eine OPC-UA-Kommunikation über ein NAT-Gerät herstellen, z. B. eine Firewall oder einen Router
▪
Ändern der Handhabung von Arrays im OPC‑UA‑Namensraum: Beschreibt zwei Darstellungsoptionen von SPS-Arrays im OPC-UA-Namensraum


Quick Start

Technische Einführung [image] TwinCAT OPC UA Server [image] Quick Start
Quick Start
Diese Quick‑Start‑Anleitung setzt voraus, dass der OPC UA Server auf demselben System wie die SPS-Laufzeit installiert ist.
Nach der erfolgreichen Installation und Lizenzierung können die folgenden Schritte durchgeführt werden, um eine erste Verbindung zu einer SPS-Laufzeit über den OPC UA Server aufzubauen:
▪
Schritt 1: Konfiguration von SPS‑Variablen für den OPC-UA-Zugriff
▪
Schritt 2: Konfiguration des OPC‑UA‑Namensraums
▪
Schritt 3: Herstellen einer Verbindung zum OPC UA Server
Schritt 1: Konfiguration von SPS-Variablen für den OPC-UA‑Zugriff
Öffnen Sie ein bestehendes SPS-Projekt und fügen Sie den folgenden Kommentar vor den ausgewählten Variablen ein:
TwinCAT 3 (mit TMC-Import):
{attribute 'OPC.UA.DA' := '1'}
bVariable : BOOL;
TwinCAT 2 (mit TPY-Import):
bVariable : BOOL; (*~ (OPC:1:some description) *)
Schritt 2: Konfiguration des OPC-UA-Namensraums
Der OPC UA Server stellt standardmäßig eine Verbindung mit der ersten SPS-Laufzeit auf dem lokalen System her (lokal = das gleiche System, auf dem auch der OPC UA Server installiert ist) und verwendet deren entsprechende Symboldatei (TMC-Datei) für die Konfiguration des OPC‑UA‑Namensraums.
Damit die Symboldatei automatisch an die SPS-Laufzeit übergeben wird, aktivieren Sie den Download der Symboldatei in den Einstellungen des SPS-Projekts.
Bei jeder Aktivierung des SPS-Projekts wird die Symboldatei automatisch in das Verzeichnis C:\TwinCAT\3.x\Boot\Plc\ kopiert und dort nach dem entsprechenden ADS-Port des SPS-Projekts benannt, z. B. „Port_851.tmc“ für die erste SPS-Laufzeit.
Die Standardkonfiguration des OPC UA Servers liest diese Symboldatei automatisch beim Start.
Hinweis
Lizenz
Prüfen Sie, ob eine Lizenz vorhanden ist. In TwinCAT 3 können Sie eine TF6100-Lizenz in der TwinCAT-Lizenzverwaltung eintragen.
Aktivieren Sie die Konfiguration und starten Sie TwinCAT neu. Loggen Sie sich anschließend in die SPS-Laufzeit ein und starten Sie das SPS-Programm.
Schritt 3: Herstellen einer Verbindung zum OPC UA Server
Um eine Verbindung von einem OPC UA Client herzustellen, muss der Client eine Verbindung mit der URL des OPC UA Servers herstellen. Diese URL wird folgendermaßen beschrieben:
opc.xxx://<ip or name>:port
▪
opc = vordefiniert
▪
xxx = Transport an OPC UA Server, z. B. „tcp“
▪
port = Portnummer von OPC UA Server, z. B. 4840 (standardmäßig)
Hinweis
Standard-Port 4840
Beachten, dass der Standard-Port 4840 eventuell von anderen OPC UA Servern verwendet wird, z. B. dem Local Discovery Server (LDS) von der OPC Foundation, die von manchen Anbietern mit OPC‑UA‑Softwarepaketen eingesetzt wird.
Beispiele:
▪
opc.tcp://CX_0215AF:4840
▪
opc.tcp://172.16.2.80:4840
Starten Sie den mitgelieferten UA Sample Client (bei Windows-Systemen mit aktiviertem UAC, z. B. Windows 7, mit dem Befehl Run As Administrator) und stellen Sie eine Verbindung mit der URL des OPC UA Servers her, z. B. opc.tcp://localhost:4840, indem Sie auf Endpunkte erhalten und anschließendem auf Verbinden klicken.
HINWEIS! Sie finden den UA Sample Client unter dem Windows Startmenü oder im Installationsverzeichnis des Produkts, z. B. C:\TwinCAT\Functions\TF6100-OPC-UA\Win32\SampleClient\.
Nach erfolgreicher Herstellung der Verbindung finden Sie die SPS-Laufzeit „PLC1“ mit den veröffentlichten Variablen (siehe Schritt 1) im UA-Namensraum unterhalb des Knotens „Objects“.


SPS

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS
SPS
Weiterführende Informationen
•
Zugriff auf SPS-Laufzeit
•
Historical Access
•
Alarms & Conditions
•
Methodenaufruf
•
Analog Item Types
•
Typsystem
•
Strukturierte Typen
•
Verwendung von Arrays
•
Liste der Attribute und Kommentare
•
Statuscode


Zugriff auf SPS-Laufzeit

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Zugriff auf SPS-Laufzeit
Zugriff auf SPS-Laufzeit
In diesem Teil der Dokumentation wird beschrieben, wie der Namensraum des TwinCAT OPC UA Servers konfiguriert werden kann. Der UA-Namensraum beschreibt die Struktur, in welche die SPS-Variablen abgebildet werden. Damit eine SPS-Variable über den UA‑Namensraum erreichbar ist, muss sie dafür freigegeben werden. Der folgende Leitfaden beschreibt mehrere Möglichkeiten, um Variablen in einem SPS-Programm freizugeben.
Beachten Sie, dass sich der OPC UA Server sich standardmäßig immer mit dem ersten lokalen SPS-Laufzeitsystem verbindet, eine Konfiguration ist also in den meisten Fällen nicht erforderlich (siehe auch Quick Start). Nur in Ausnahmefällen muss eine separate Konfiguration erfolgen, z. B. wenn im UA-Namensraum weitere Laufzeiten angezeigt werden sollen oder wenn auf die SPS eines BC-Geräts zugegriffen werden muss.
Dieser Abschnitt beinhaltet folgende Themen:
▪
Allgemeine Informationen
▪
Schritt 1: SPS-Variablen auswählen, die über OPC UA öffentlich zugänglich werden sollen.
▪
Schritt 2: Symbolbeschreibung herunterladen und im SPS-Projekt aktivieren
▪
[Optional] Schritt 3: Datenzugriffgerät in OPC UA Server konfigurieren
▪
Explizites Ausblenden von Variablen
Allgemeine Informationen
Für die Konfiguration des OPC-UA-Namensraums und den Zugriff auf SPS-Variablen stehen mehrere Parameter zur Verfügung, die je nachdem, wie die SPS-Laufzeit angezeigt wird und wie die Kommunikation stattfindet, unterschiedliche Auswirkungen haben.
Sie können diese Parameter bequem mithilfe des OPC-UA-Konfigurators festlegen. Alternativ dazu können Sie diese auch direkt in der Konfigurationsdatei ServerConfig.xml festlegen.
Die folgende Tabelle gibt einen Überblick über alle Parameter, die beim Zugriff auf eine SPS-Laufzeit von Bedeutung sind:
Parameter | Beschreibung | Mögliche Werte
ADS Port | Definiert den ADS-Port, unter dem die SPS-Laufzeit zugänglich ist. Der ADS-Port kann in den Eigenschaften des SPS-Projekts gelesen werden. | 800 (BC Controller) 801 (TwinCAT 2) 811 (TwinCAT 2) … 851 (TwinCAT 3 - standardmäßig) 852 (TwinCAT 3) …
AutoCfg | Definiert zunächst den Typ der für die Kommunikation verwendeten Ziel-Laufzeit, z. B. SPS, C++, I/O. Anschließend kann eine weitergehende Unterscheidung innerhalb dieser Kategorien stattfinden. Jede AutoCfg-Option steht sowohl als ungefilterte, als auch gefilterte Option zur Verfügung. Gefiltert bedeutet, dass der Nutzer bestimmen kann, welche SPS-Symbole über OPC UA via SPS-Kommentaren veröffentlicht werden sollten (siehe unten). Bei Verwendung einer ungefilterten Option wird jedes SPS-Symbol an OPC UA veröffentlicht. | 7 TwinCAT 2 (TPY) 8 TwinCAT 2 (TPY) gefiltert 4040 TwinCAT 3 (TMC) 4041 TwinCAT 3 (TMC) gefiltert
AutoCfgSymFile | Symboldatei der jeweiligen SPS-Laufzeit. Standardmäßig wird die automatisch erzeugte Symboldatei der ersten SPS-Laufzeit des lokalen Systems importiert. | Pfad zur Symboldatei. Zeigt standardmäßig auf die Symboldatei (TMC) der ersten lokalen SPS-Laufzeit.
IoMode | Definiert die Methode für den Zugriff auf Symbole. Dies ist besonders wichtig für den Zugriff auf BC-Geräte. | 1 (Zugriff über Handle - standardmäßig) 3 (Zugriff auf BC Controller)
ArraySubItemLegacySupport | Unterelemente eines Array werden standardmäßig nicht als separate Knoten im UA-Namensraum abgebildet. Stattdessen wird lediglich das Array als ein einzelnes Element abgebildet. Nichtsdestotrotz können UA-Clients über deren sogenannten „IndexRange“ auf Unterelemente zugreifen. Unglücklicherweise unterstützen einige ältere OPC UA Clients diese Möglichkeit noch nicht. Dieses Flag wurde eingeführt, sodass der Zugriff nichtsdestotrotz für diese Clients möglich wird. Das Flag sorgt dafür, dass jede Array-Position als separater Knoten im UA-Namensraum angezeigt wird. HINWEIS! Dies führt zu einem höheren Speicherbedarf des OPC UA Servers. | 0 (deaktiviert - standardmäßig) 1 (aktiviert)
Disabled | Deaktiviert die SPS-Laufzeit im UA‑Namensraum, woraufhin der entsprechende Knoten nicht angezeigt wird. Es wird empfohlen, diesen Parameter zu aktivieren, wenn bestimmte SPS-Laufzeiten zum Zeitpunkt der Projektplanung noch nicht verfügbar sind, weil z. B. die entsprechenden Geräte noch nicht ans Netzwerk angeschlossen sind. | 0 (deaktiviert - standardmäßig) 1 (aktiviert)
Im nachfolgenden Abschnitt wird anhand eines Beispiels gezeigt, wie die Variablen aus einem SPS‑Programm in den UA‑Namensraum importiert werden können. Es wird hierbei vorausgesetzt, dass der OPC UA Server, in seiner Standardkonfiguration (Lieferzustand nach Installierung), und die SPS‑Laufzeit sich auf dem gleichen Computer befinden.
Hinweis
AutoCfg-Optionen
Die in diesem Artikel enthaltenen Informationen, einschließlich die folgenden SPS-Kommentare/Pragmas, basieren auf TwinCAT 3 und müssen demzufolge mit den AutoCfg-Optionen „4041 TwinCAT 3 (TMC) gefiltert“ (Standardkonfiguration) verwendet werden.
Beachten Sie, dass die AutoCfg-Optionen für TwinCAT 2 ein anderes SPS‑Kommentarformat verwenden (*~ (OPC:1:description) *), das nicht mehr in TwinCAT 3 verwendet wird, aber weiterhin aus Gründen der Kompatibilität unter Verwendung der AutoCfg‑Option „8“ verfügbar ist.
Schritt 1: SPS-Variablen auswählen, die über OPC UA öffentlich zugänglich werden sollen.
Der OPC UA Server stellt automatisch eine Verbindung zur ersten SPS-Laufzeit auf dem lokalen System her. Die im SPS-Programm (TwinCAT-SPS-Steuerung) für OPC UA gekennzeichneten SPS-Symbole werden bereitgestellt. Die Kennzeichnung erfolgt über einen Kommentar an der geeigneten Stelle (Instanz, Struktur, Variable) im SPS-Programmcode (siehe nachfolgende Beispiele).
Beispiel 1:
In diesem Beispiel sind die SPS-Variablen bMemFlag1, bMemFlag2, bMemAlarm2 und iReadOnly über OPC UA freigegeben. Die SPS-Variable bMemAlarm1 sollte nicht über den OPC UA Server zugänglich sein. Das SPS-Programm in PLC-Control würde dann – abhängig von der von Ihnen verwendeten TwinCAT‑Version - so aussehen:
TwinCAT 3 (mit TMC-Import):
{attribute 'OPC.UA.DA' := '1'}
bMemFlag1 : BOOL;

{attribute 'OPC.UA.DA' := '1'}
bMemFlag2 : BOOL;

bMemAlarm1 : BOOL;

{attribute 'OPC.UA.DA' := '1'}
bMemAlarm2 : BOOL;

{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.Access' := '1'}
iReadOnly : INT;
TwinCAT 2 (mit TPY-Import):
bMemFlag1 : BOOL; (*~ (OPC:1:some description) *)

bMemFlag2 : BOOL; (*~ (OPC:1:some description) *)

bMemAlarm1 : BOOL;

bMemAlarm2 : BOOL; (*~ (OPC:1:some description) *)

iReadOnly : INT; (*~ (OPC:1:some description)
(OPC_PROP[0005]:1:read-only flag) *)
Die TPY Formatierung kann auch in TwinCAT‑3‑SPS‑Projekten für Migrationszwecke verwendet werden, wenn z. B. ein TwinCAT-2-Projekt bequem in ein TwinCAT‑3‑Projekt konvertiert werden soll.
Wegen des zusätzlichen Kommentars „OPC.UA.DA.Access“ wird die Zugriffsebene für die Variable iReadOnly auf „ReadOnly“ gesetzt. Die verschiedenen Möglichkeiten finden Sie in der vollständigen Liste der SPS-Kommentare (siehe Liste der Attribute und Kommentare).
Um einer Variablen im UA-Namensraum eine Beschreibung zu geben, fügen Sie hinter der entsprechenden Variablen einen einfachen SPS-Kommentar ein, z. B.:
TwinCAT 3 (mit TMC-Import):
{attribute 'OPC.UA.DA' := '1'}
bMemFlag1 : BOOL; (* Description for variable bMemFlag1 *)
TwinCAT 2 (mit TPY-Import): Funktion nicht verfügbar
Dieser Kommentar wird automatisch zum Beschreibungsattribut des Knotens im UA-Namensraum.
Beispiel 2:
In diesem Beispiel sollen die beiden Instanzen fbTest1 und fbTest2 des Funktionsbausteins FB_BLOCK1 über OPC UA verfügbar sein. Wenn eine ganze Instanz freigegeben wird, sind über OPC UA auch alle ihre Symbole verfügbar. Das SPS-Programm könnte folgendermaßen aussehen, z. B.:
TwinCAT 3 (mit TMC-Import):
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
fbTest1 : FB_BLOCK1;
fbTest2 : FB_BLOCK1;
END_VAR
FUNCTION_BLOCK FB_BLOCK1
VAR_INPUT
{attribute 'OPC.UA.DA' := '1'}
ni1 : INT;
ni2 : INT;
END_VAR
VAR_OUTPUT
{attribute 'OPC.UA.DA' := '1'}
no1 : INT;
no2 : INT;
END_VAR
VAR
{attribute 'OPC.UA.DA' := '1'}
nx1 : INT;
nx2 : INT;
END_VAR
TwinCAT 2 (mit TPY-Import):
PROGRAM MAIN
VAR
fbTest1 : FB_BLOCK1; (*~ (OPC:1:some description) *)
fbTest2 : FB_BLOCK1;
END_VAR
FUNCTION_BLOCK FB_BLOCK1
VAR_INPUT
ni1 : INT; (*~ (OPC:1:some description) *)
ni2 : INT;
END_VAR
VAR_OUTPUT
no1 : INT; (*~ (OPC:1:some description) *)
no2 : INT;
END_VAR
VAR
nx1 : INT; (*~ (OPC:1:some description) *)
nx2 : INT;
END_VAR
Die Instanz fbTest1 wird für OPC UA freigegeben, wodurch alle enthaltenen Symbole automatisch auch für OPC UA freigegeben werden, sprich fbTest.ni1, fbTest.ni2, usw. Die Instanz fbTest2 ist nicht für OPC UA gekennzeichnet, allerdings wurden die drei enthaltenen Variablen - ni1, no1 und nx1 – im Funktionsbaustein gekennzeichnet. Diese sind demzufolge in allen Instanzen über OPC UA verfügbar.
Schritt 2: Symbolbeschreibung herunterladen und im SPS-Projekt aktivieren
Die sogenannte Symboldatei enthält Informationen über alle in einem SPS-Projekt verfügbaren SPS‑Variablen. Der OPC UA Server benötigt diese Informationen für den Aufbau seines Namensraums. Die aktuellen Symbolinformationen werden standardmäßig automatisch in eine Symboldatei heruntergeladen. Diese befindet sich im Projektordner des entsprechenden TwinCAT‑Projekts. Damit die Symboldatei in die Ziel-Laufzeit übertragen wird, aktivieren Sie den Download der Symboldatei in den Einstellungen des SPS‑Projekts.
TwinCAT 3:
TwinCAT 2:
Grafik aus Step 2_ TwinCAT PLC Control_ Download symbol description to target PLC runtime (iijv2oe2.png)
Bei der Erstellung eines Bootprojekts wird die Symboldatei automatisch in das Bootverzeichnis der SPS-Laufzeit kopiert. Der gibt Dateiname Auskunft über den entsprechenden ADS-Port der SPS-Laufzeit.
Wenn sich OPC UA Server und SPS-Laufzeit auf dem gleichen System befinden, müssen Sie nichts anderes tun, als den OPC UA Server neu zu starten. Der OPC UA Server wird automatisch so konfiguriert, dass er die Symboldatei aus dem TwinCAT Bootverzeichnis lädt und seinen Namensraum auf der Grundlage der in dieser Datei enthaltenen Symbolinformationen generiert. Wenn eine andere Symboldatei verwendet werden soll, konfigurieren Sie diese entweder im OPC‑UA‑Konfigurator oder direkt in der Datei ServerConfig.xml konfigurieren.
[Optional] Schritt 3: Datenzugriffgerät in OPC UA Server konfigurieren
Standardmäßig verbindet sich OPC UA Server mit der ersten SPS-Laufzeit auf dem lokalen System. Wenn Sie mehr als eine SPS-Laufzeit im UA-Namensraum veröffentlichen möchten, müssen Sie zusätzliche Datenzugriffsgeräte im OPC‑UA‑Konfigurator konfigurieren. Das kann bei folgenden Szenarien erforderlich sein:
▪
Sie haben eine andere (zweite oder dritte) SPS-Laufzeit, von der Sie Symbolinformationen an OPC UA veröffentlichen möchten.
▪
Sie haben einen anderen Industrie-PC oder Embedded-PC, dessen SPS-Laufzeit und entsprechenden Symbolinformationen Sie OPC UA öffentlich zugänglich machen möchten.
Um zusätzliche Geräte für den Datenzugriff zu konfigurieren, öffnen Sie den OPC‑UA‑Konfigurator und fügen Sie neue Datenzugriffsgeräte hinzu.
Konfigurieren Sie alle weiteren notwendigen Parameter wie oben unter Allgemeines beschrieben. Wenn Sie einen entfernten Industrie-PC oder Embedded-PC konfigurieren, müssen Sie die richtigen Parameter für AdsNetId, AdsPort eingeben und die entsprechende Symboldatei des SPS-Programms auf diesem PC bereitstellen.
Explizites Ausblenden von Symbolen
Neben den regulären SPS-Attributen zum Aktivieren eines SPS-Symbols, z. B. Variablen, können Sie auch SPS-Symbole explizit von einer Veröffentlichung im OPC UA Namensraums ausschließen. Dafür kann es mehrere Gründe geben:
▪
Sie möchten eine Datenstruktur veröffentlichen, aber nicht alle ihre Unterelemente (Beispiel 1).
▪
Sie haben eine Datenstruktur bei der Definition aktiviert und möchten z. B. eine einzelne Instanz dieser Datenstruktur ausblenden (Beispiel 2).
▪
Sie wollen das Hochfahren des OPC UA Servers beschleunigen (Beispiel 3).
Beispiel 1:
{attribute 'OPC.UA.DA' := '1'}
TYPE ST_TEST :
STRUCT
a : INT;
{attribute 'OPC.UA.DA' := '0'}
b : DINT;
END_STRUCT
END_TYPE

PROGRAM MAIN
VAR
instance1 : ST_TEST;
instance2 : ST_TEST;
END_VAR
In diesem Fall wurde das SPS-Attribut zur Strukturdefinition hinzugefügt, wodurch jede Instanz dieser Struktur auf dem OPC UA Server verfügbar sein soll. Das Unterelement „b“ (und all seine Unterelemente, falls „b“ eine weitere Datenstruktur ist) wird (werden) von der Veröffentlichung auf dem OPC UA Server ausgeschlossen.
Beispiel 2:
{attribute 'OPC.UA.DA' := '1'}
TYPE ST_TEST :
STRUCT
a : INT;
b : DINT;
END_STRUCT
END_TYPE

PROGRAM MAIN
VAR
instance1 : ST_TEST;
{attribute 'OPC.UA.DA' := '0'}
instance2 : ST_TEST;
END_VAR
Obwohl das SPS-Attribut zur Strukturdefinition hinzugefügt wird, wodurch jede Instanz dieser Struktur auf dem OPC UA Server verfügbar ist, erhält instance2 das SPS-Attribut zum Deaktivieren dieser Vererbung. Dadurch ist nur instance1 im UA-Namensraum verfügbar, instance2 nicht.
Beispiel 3:
Beim Hochfahren analysiert der TwinCAT OPC UA Server die SPS-Symboldateien zum Aufbau seines Namensraums. Dafür werden alle gefundenen Datenstrukturen vollständig analysiert, um alle Typendefinitionen zu finden machen und einzubinden. Wird ein OPC.UA.DA:=0 SPS-Attribut entdeckt, stoppt die Analyse aller nachfolgenden Unterelemente, wodurch das Hochfahren je nach Größe der Datenstrukturen erheblich beschleunigt werden kann.


Historical Access

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Historical Access
Historical Access
In diesem Abschnitt werden die notwendigen Schritte zur Konfiguration der Variablen im Namensraum des TwinCAT OPC UA Servers für Historical Access (HA) beschrieben.
Historical Access ist der Name einer Function von OPC UA, bei der die Variablenwerte entweder dauerhaft auf einem Datenträger (Datei oder Datenbank) oder in der Geräte-RAM gespeichert werden, damit sie später vom Client abgerufen werden können. Die Art und Weise wie der OPC UA Server die Variablenwerte liest und speichert kann konfiguriert werden.
Weiterführende Informationen
•
Setupversion 3.x.x
•
Setupversion 4.x.x
•
Anzeige von historischen Daten


Setupversion 3.x.x

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Historical Access [image] Setupversion 3.x.x
Setupversion 3.x.x
Allgemeines
Die folgenden Schritte müssen einmal ausgeführt werden, um einen Werteverlauf von SPS‑Variablen über OPC UA Historical Access zu aktivieren:
▪
Aktivierung von Historical Access auf dem UA-Server
▪
Aktivierung von Historical Access im TwinCAT‑SPS‑Programm
▪
Aktivierung von Historical Access im TwinCAT‑C++‑Modul
▪
Anzeige von Historical-Access-Werten in einem OPC UA Client (siehe Anzeige von historischen Daten)
Diese Schritte werden nachfolgend ausführlicher erläutert. Am Ende des Abschnitts wird beschrieben, wie Sie über Historical Access gespeicherte Variablenwerte mithilfe der UA‑Expert‑Software abrufen können.
Voraussetzungen
Es gelten die folgenden Voraussetzungen zur Nutzung von Historical Access:
▪
Das Laufzeitsystem, dessen Symbole für Historical Access gespeichert werden sollen, muss als Data Access konfiguriert sein.
▪
▪
Um eine SQL-Compact-Datenbank als Speichermedium nutzen zu können, muss auf dem Rechner, auf dem der OPC-UA-Server läuft, SQL Compact Runtime 3.5 SP2 installiert sein.
▪
Zur Verwendung einer SQL-Server-Datenbank muss mindestens OPC-UA-Version 2.0 installiert sein.
▪
SQL-Compact-Datenbanken werden auch unter Windows CE unterstützt.
▪
SQL-Server-Datenbanken werden unter Windows CE nicht unterstützt.
Aktivierung von Historical Access auf dem UA-Server
Es können verschiedene Speichermedien für die Speicherung von Werteverläufen verwendet werden. Diese Medien müssen einmal im OPC UA Server aktiviert werden. Diese Einstellungen können entweder in der ServerConfig.xml-Datei oder bequem mithilfe des OPC‑UA‑Konfigurators vorgenommen werden. Das SPS-Programm bestimmt anschließend, welches Speichermedium zu verwenden ist. Nachdem ein oder mehrere Speichermedien auf dem OPC UA Server aktiviert wurden, wählt das SPS-Programm das Speichermedium aus, dass für jedes Symbol zu verwenden ist (siehe Schritt 2). Derzeit werden die folgenden vier Speichermedien unterstützt:
▪
Hauptspeicher: Speichert die Symbolwerte in der RAM des Geräts, auf dem der OPC UA Server läuft.
▪
Datei: Speichert die Werte in einer Datei mit angegebenem Pfad.
▪
SQL Compact Database: Speichert die Werte in einer SQL Compact Database mit angegebenem Pfad. In diesem Fall muss die SQL Compact Runtime 3.5 SP2 als entsprechende Datenbankversion auf dem OPC UA Server installiert sein.
▪
SQL Server Database: Speichert die Werte in einer SQL Server Database, die mit den Parametern Servername, Databasename, Username und Password spezifiziert wird.
Die folgende Abbildung zeigt die Konfiguration dieser Modi mithilfe des OPC‑UA‑Konfigurators und direkt über die ServerConfig.xml-Datei.
Die unten gezeigten XML Tags müssen zwischen <OpcServerConfig><UaServerConfig> und </UaServerConfig></OpcServerConfig> in der ServerConfig.xml-Datei eingefügt werden.
<HaModes>
<HaMode Type="RAM"/>
<HaMode Type="File" DataStore="C:\Temp\"/>
<HaMode Type="SQLServerCompact" DbName="C:\Temp\TcOpcUaServer.sdf"/>
<HaMode Type=”SQLServer” Servername=”SERVERNAME\SQLEXPRESS” DbName=”TcOpcUaServer” User=”sa” Pass=”123”/>
</HaModes>
Die für den jeweiligen Modus notwendigen Parameter sind:
Modus | Erforderliche Parameter
Speicher | Speichert die Werte in der RAM des Geräts, auf dem der OPC UA Server läuft. Es sind keine weiteren Parameter erforderlich. HINWEIS! Nach einem Neustart des Geräts sind die gespeicherten Werte nicht mehr verfügbar. Das Speichermedium ist demzufolge kein dauerhaftes.
Datei | Speichert die Werte in mehreren Dateien, deren Speicherort mit dem Parameter DataStore festgelegt wird. Jedem für dieses Speichermedium konfigurierten Symbol (siehe Schritt 2) wird dessen eigene Datei in diesem Verzeichnis zugeordnet. Darüber hinaus besteht eine Sicherungskopie der Datei für jedes Symbol, die dann erzeugt wird, sobald die Pufferlänge (siehe Schritt 2) erreicht ist. Der Inhalt der Datendatei wird dann als Sicherungskopie gespeichert und es wird eine neue Datei erzeugt.
SQL Server Compact | Speichert die Werte in eine SQL Compact Database, dessen Speicherort mit dem Parameter DbName festgelegt wird. Es gelten die oben aufgeführten Anforderungen.
SQL Server | Speichert die Werte in einer SQL Server Database, die mit den Parametern Servername, DbName, User und Pass spezifiziert wird.
Aktivierung von Historical Access im TwinCAT‑SPS‑Programm
Wenn eine SPS-Laufzeit als ein Datenzugriffsgerät konfiguriert ist, dann werden die SPS-Variablen, die hierfür im SPS-Programm mithilfe von Kommentaren aktiviert wurden, automatisch durch den OPC UA Server via OPC UA verfügbar gemacht. Auf die gleiche Weise, wie Variablen für den Zugriff via OPC UA freigegeben werden können, können einzelne Variablen für Historical Access freigegeben oder gesperrt werden. Dies geschieht auf ähnliche Weise im SPS-Programm mittels Eingabe von Kommentaren auf der rechten Seite eines Symbols. Die folgenden Parameter können hier spezifiziert werden:
TwinCAT 3 (mit TMC-Import):
Parameter | Kommentar | Beschreibung
Aktivieren | {attribute 'OPC.UA.DA' := '1'} | Aktiviert das Symbol für Datenzugriff. Dies ist erforderlich, um das Symbol auch für Historical Access zur Verfügung zu stellen.
Für HA aktivieren | {attribute 'OPC.UA.HA' := '1'} | Aktiviert das Symbol für Historical Access.
Speichermedium | {attribute 'OPC.UA.HA.Storage' := '1'} | Legt das für die Speicherung der Symbolwerte zu verwendende Speichermedium fest (1 = RAM, 2 = Datei, 3 = SQL Compact Database, 4 = SQL Server Database).
Aufzeichnungsrate | {attribute 'OPC.UA.HA.Sampling' := '50'} | Definiert die Rate, mit der die Variablenwerte aus der Steuerung zu lesen und auf dem entsprechenden Speichermedium zu speichern sind. Der OPC UA Server verwendet vordefinierte feste Aufzeichnungsraten, die hier verwendet werden können. Die Aufzeichnungsraten können gegebenenfalls in ServerConfig erweitert werden. Allerdings ist dies normalerweise nicht erforderlich, und es wird auch davon abgeraten, diese Einstellungen vorzunehmen.
Pufferlänge | {attribute 'OPC.UA.HA.Buffer' := '10000'} | Legt die Anzahl Elemente fest, die der Puffer aufnehmen soll.
TwinCAT 2 (mit TPY-Import):
Parameter | Kommentar | Beschreibung
Aktivieren | (*~ (OPC:1:some description) *) | Aktiviert das Symbol für Datenzugriff. Dies ist erforderlich, um das Symbol auch für Historical Access zur Verfügung zu stellen.
Speichermedium | (*~ (OPC_UA_PROP[5000]:1:RAM) *) | Legt das für die Speicherung der Symbolwerte zu verwendende Speichermedium fest (1 = RAM, 2 = Datei, 3 = SQL Compact Database, 4 = SQL Server Database).
Aufzeichnungsrate | (*~ (OPC_UA_PROP[5000][1]:50:SamplingRate) *) | Definiert die Rate, mit der die Variablenwerte aus der Steuerung zu lesen und auf dem entsprechenden Speichermedium zu speichern sind. Der OPC UA Server verwendet vordefinierte feste Aufzeichnungsraten, die hier verwendet werden können. Die Aufzeichnungsraten können gegebenenfalls in ServerConfig erweitert werden. Allerdings ist dies normalerweise nicht erforderlich, und es wird auch davon abgeraten, diese Einstellungen vorzunehmen.
Pufferlänge | (*~ (OPC_UA_PROP[5000][2]:5000:Buffer) *) | Legt die Anzahl Elemente fest, die der Puffer aufnehmen soll.
Der folgende Auszug eines SPS-Programms beschreibt die Verwendung der oben aufgeführten Parameter unter Verwendung von vier SPS-Variablen:
TwinCAT 3 (mit TMC-Import):
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.HA' := '1'}
{attribute 'OPC.UA.HA.Storage' := '1'}
{attribute 'OPC.UA.HA.Sampling' := '5'}
{attribute 'OPC.UA.HA.Buffer' := '1000'}
_HistoryMem : UINT;

{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.HA' := '1'}
{attribute 'OPC.UA.HA.Storage' := '2'}
{attribute 'OPC.UA.HA.Sampling' := '20'}
{attribute 'OPC.UA.HA.Buffer' := '200'}
_HistoryFile : UINT;

{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.HA' := '1'}
{attribute 'OPC.UA.HA.Storage' := '3'}
{attribute 'OPC.UA.HA.Sampling' := '50'}
{attribute 'OPC.UA.HA.Buffer' := '10000'}
_HistoryDBcompact : UINT;

{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.HA' := '1'}
{attribute 'OPC.UA.HA.Storage' := '4'}
{attribute 'OPC.UA.HA.Sampling' := '5'}
{attribute 'OPC.UA.HA.Buffer' := '1000000'}
_HistoryDB : UINT;
TwinCAT 2 (mit TPY-Import):
_HistoryMem : UINT; (*~ (OPC:1:available for OPC UA Clients)
(OPC_UA_PROP[5000]:1:Memory)
(OPC_UA_PROP[5000][1]:5:SamplingRate)
(OPC_UA_PROP[5000][2]:1000:Buffer) *)

_HistoryFile : UINT; (*~ (OPC:1:available for OPC UA Clients)
(OPC_UA_PROP[5000]:2:File)
(OPC_UA_PROP[5000][1]:20:SamplingRate)
(OPC_UA_PROP[5000][2]:200:Buffer) *)

_HistoryDBcompact : UINT; (*~ (OPC:1:available for OPC UA Clients)
(OPC_UA_PROP[5000]:3:SQLCompact)
(OPC_UA_PROP[5000][1]:50:SamplingRate)
(OPC_UA_PROP[5000][2]:10000:Buffer) *)

_HistoryDB : UINT; (*~ (OPC:1:available for OPC UA Clients)
(OPC_UA_PROP[5000]:4:SQL)
(OPC_UA_PROP[5000][1]:5:SamplingRate)
(OPC_UA_PROP[5000][2]:1000000:Buffer) *)
Aktivierung von Historical Access im TwinCAT-C++-Modul
Jedes TwinCAT‑3‑C++‑Symbol, dessen Verlauf aufgezeichnet werden soll, muss entsprechend konfiguriert werden. Vergleichbar mit der Konfiguration von SPS-Symbolen für Historical Access (siehe oben), müssen die gleichen Parameter für ein C++‑Symbol konfiguriert werden, wie die folgende Tabelle zeigt:
Parameter | Kommentar | Beschreibung
Aktivieren | OPC.UA.DA := 1 | Aktiviert das Symbol für Datenzugriff. Dies ist erforderlich, um das Symbol auch für Historical Access zur Verfügung zu stellen.
HA aktivieren | OPC.UA.HA := 1 | Aktiviert das Symbol für Historical Access.
Speichermedium | OPC.UA.HA.Storage := 1 | Legt das für die Speicherung der Symbolwerte zu verwendende Speichermedium fest (1 = RAM, 2 = Datei, 3 = SQL Compact Database, 4 = SQL Server Database).
Aufzeichnungsrate | OPC.UA.HA.Sampling := 50 | Definiert die Rate, mit der die Variablenwerte aus der Steuerung zu lesen und auf dem entsprechenden Speichermedium zu speichern sind. Der OPC UA Server verwendet vordefinierte feste Aufzeichnungsraten, die hier verwendet werden können. Die Aufzeichnungsraten können gegebenenfalls in ServerConfig erweitert werden. Allerdings ist dies normalerweise nicht erforderlich, und es wird auch davon abgeraten, diese Einstellungen vorzunehmen.
Pufferlänge | OPC.UA.HA.Buffer := 10000 | Legt die Anzahl Elemente fest, die der Puffer aufnehmen soll.
Allerdings müssen in TwinCAT 3 C++ diese Parameter im TMC-Code-Editor des entsprechenden C++-Moduls konfiguriert werden. Navigieren Sie mithilfe des TMC-Code-Editors zu dem Symbol, das für Historical Access freigegeben werden soll, und fügen diese Parameter in den Bereich Optionale Eigenschaften der Symboleigenschaften hinzu. Vergewissern Sie sich, dass Sie das Kontrollkästchen Symbol erzeugen aktiviert haben.
Produkte | Setupversionen | Zielplattform
TS6100, TF6100 | 3.x.x | IPC oder CX (x86, x64, ARM)


Setupversion 4.x.x

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Historical Access [image] Setupversion 4.x.x
Setupversion 4.x.x
Ab Setupversion 4.x.x wird Historical Access nicht mehr länger über Attribute bzw. Kommentare konfiguriert. Dies hat den Vorteil, dass die Historical-Access-Funktionalität nun auch für Laufzeiten zur Verfügung steht, dies dies bisher nicht unterstützt haben, z. B. Variablen von einem BC9191 Controller. Des Weiteren kann eine Historical‑Access‑Konfiguration nun auch nachträglich, d. h. ohne Anpassung des SPS-Projekts durchgeführt werden.
Die Historical‑Access‑Konfiguration ist nun XML-basiert (TcUaHaConfig.xml) und kann über den OPC UA Server Konfigurator vorgenommen werden (siehe Konfiguration von Historical Access). Diese XML-Datei befindet sich in demselben Verzeichnis wie die TcOpcUaServer.exe. Der Vollständigkeit halber wird der Aufbau der XML-Datei an dieser Stelle jedoch kurz erklärt.
<HistoryConfig>
<HistoryController>
<HistoryAdapter Type="Volatile" Id="0" File="" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="File" Id="1" File="historydb.dat" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="SQL" Id="2" File="" Server="" Database="database123" User="user" Password="pwd"/>
<HistoryAdapter Type="SQLCompact" Id="3" File="historydb.xyz" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="SQLCompact" Id="4" File="historydb2.xyz" Server="" Database="" User="" Password=""/>
</HistoryController>
<HistoryNodes>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_SingleNode.nMyValue"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.nMyValue1"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.nMyValue2"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.fMyValue3"/>
</HistoryNodes>
</HistoryConfig>
In dem Bereich <HistoryController> können alle unterstützten Datenspeicher konfiguriert werden. Aktuell werden die folgenden Speicherorte unterstützt:
▪
Arbeitsspeicher („Volatile“)
▪
Datei („File“)
▪
SQL Compact
▪
SQL Server (wird nicht unter Windows CE unterstützt)
Jeder <HistoryAdapter> (außer „Volatile“) kann hierbei mehrfach verwendet werden, z. B. wenn die historischen Werte für einzelne Variablen in unterschiedlichen Datenspeichern abgelegt werden sollen.
Im Bereich <HistoryNodes> werden die einzelnen Nodes konfiguriert, einem Datenspeicher zugewiesen und mit einer SamplingRate sowie einer maximalen Größe für den zu verwendenden Ringbuffer im Datenspeicher versehen.
Das Attribut HistoryWriteable="true" bewirkt, dass der Datenspeicher für diese Node über einen HistoryUpdate() Aufruf mit Werten befüllt werden kann. Ein solcher Aufruf wird z.B. von unserem TwinCAT OPC UA Client über den UA_HistoryUpdate() Funktionsbaustein zur Verfügung gestellt. Wird eine Node mit diesem Attribut konfiguriert, dann sampled üblicherweise der Server selbst nicht die Werte, sondern bekommt diese von anderen Clients reingereicht. Die SamplingRate ist daher bei einer solchen Konfiguration üblicherweise gleich 0.
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Anzeige von historischen Daten

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Historical Access [image] Anzeige von historischen Daten
Anzeige von historischen Daten
Anzeige von Historical‑Access‑Werten in einem OPC UA Client
Die folgende Schritt-für-Schritt-Anleitung beschreibt, wie die Software UA-Expert konfiguriert werden kann, um auf historische Daten zuzugreifen.
1.
Starten Sie die UA-Expert-Software und stellen Sie eine Verbindung mit dem OPC UA Server her.
2.
Fügen Sie eine neue „History Trend Ansicht“ hinzu.
3.
Durchsuchen Sie den PLC1-Namensraum und fügen Sie die SPS-Variablen _HistoryDB, _HistoryDBcompact, _HistoryFast und _HistorySlowPersist per Drag-and-drop hinzu.
⇨
Sie können nun den gewünschten Zeitraum, für den die Symbolwerte angezeigt werden sollen, mithilfe der Steuerelemente StartTime und EndTime festlegen, oder falls erforderlich ein CyclicUpdate für diese Variablen starten.


Alarms & Conditions

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Alarms & Conditions
Alarms & Conditions
In diesem Abschnitt werden die notwendigen Schritte zur Konfiguration von OPC UA Alarms & Conditions (A&C) auf dem TwinCAT OPC UA Server beschrieben. Das Grundkonzept ist unabhängig von der TwinCAT‑Laufzeit. Demzufolge sind die Konfigurationsschritte für SPS, C++, TcCOM-Laufzeit oder nur I/O-Task gleich.
OPC UA Alarms & Conditions (Teil 9 der OPC-UA-Spezifikation) beschreibt ein Modell für die Überwachung von Prozesswerten und das Ausgeben von Alarmen und Ereignissen bei Zustandsänderungen eines Laufzeit-Symbols.
Voraussetzungen
Die folgenden Voraussetzungen gelten für die Verwendung von OPC UA Alarms & Conditions:
▪
Das zu überwachende Laufzeitsymbol muss im Namensraum verfügbar sein.
▪
Der OPC UA Client muss A&C unterstützen. In diesem Abschnitt wird der UA-Expert (von Unified Automation) als Referenz‑UA‑Client verwendet.
Allgemeines
Die folgenden Schritte müssen einmalig ausgeführt werden, um ein Symbol für A&C freizugeben:
▪
Schritt 1: Laufzeitsymbol für Datenzugriff aktivieren (damit das Symbol generell via OPC UA zugänglich wird.)
▪
Schritt 2: A&C für ein Symbol aktivieren
▪
Schritt 3: Eigene Benutzerdaten mit einem Ereignis übermitteln
▪
Schritt 4: Ereignis über die FireEvent-Methode auslösen
▪
Schritt 5: Mehrsprachige Alarmtexte konfigurieren
▪
Schritt 6: A&C bei einem Referenz-OPC-UA-Client anmelden
Diese Schritte werden nachfolgend ausführlicher erläutert. Am Ende des Abschnitts finden Sie Informationen zum Empfang von konfigurierten Alarmen über A&C mit dem UA‑Expert‑Referenz‑Client.
Unterstützte Alarmtypen
Die Implementierung von TwinCAT OPC UA A&C unterstützt derzeit die folgenden Alarmtypen:
▪
LimitAlarmType: Verschiedene Grenzen für ein Symbol definieren. Wird eine Grenze erreicht, gibt der UA-Server einen Alarm aus.
▪
OffNormalAlarmType: Einen Wert definieren, der „normal“ ist. Wenn der aktuelle Wert vom „normalen“ Wert abweicht, gibt der UA-Server einen Alarm aus.
Schritt 1: Laufzeitsymbol für Datenzugriff aktivieren
Als Voraussetzung dafür, dass Variablen für Alarms & Conditions konfiguriert werden können, muss die entsprechende Variable zunächst im OPC UA Server zur Verfügung stehen. Im Falle einer SPS‑Variablen muss diese zunächst entsprechend mit einem Attribut konfiguriert werden, wie im Abschnitt Zugriff auf SPS-Laufzeit beschrieben.
Schritt 2: A&C für ein Symbol aktivieren
Mit dem TwinCAT-OPC-UA-Server-Konfigurator kann ein Laufzeitsymbol einfach für A&C konfiguriert werden. Dieser Konfigurator hat eine einfache grafische Bedienoberfläche, um die dahinter stehende XML-Datei zu bearbeiten. Der Konfigurator steht, je nach Setupversion, in zwei Varianten zur Verfügung: Standalone und integriert in das Visual Studio.
Der folgende Programmausschnitt zeigt ein Beispiel dieser XML-Datei, um das allgemeine Verhalten und den Aufbau der A&C-Implementierung besser zu verstehen.
<TcUaAcConfig>
<ConditionController Name="ConditionController1" >
<Condition Name="Counter" Severity="200">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.nCounter1" />
</Condition>
<Condition Name="Switch" Severity="500">
<OffNormalAlarmType Normal="0" MessageNormal="100" MessageOffNormal="20" />
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.bSwitch" />
</Condition>
<Condition Name="Struct" Severity="300">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.stStruct" />
</Condition>
</ConditionController>
<ConditionController Name="ConditionController2" >
<Condition Name="Counter2" Severity="200">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.nCounter2" />
</Condition>
</ConditionController>
</TcUaAcConfig>
Eine „Bedingung“ definiert das zu überwachende Laufzeitsymbol und die Alarmgrenzen und -texte. Jede „Bedingung“ ist in einem so genannten „ConditionController“ organisiert, dem Objekt, das die OPC UA Clients später abonnieren.
Bei der Erstellung einer Bedingung (Condition) müssen NamespaceName (NS) und NodeID spezifiziert werden, um auf den zu überwachenden UA-Knoten zu verweisen. Der Konfigurator bietet einen einfachen Browsing-Mechanismus, um einen Knoten auszuwählen. In der XML kann durch den Platzhalter „[NodeName]“ in NamespaceName die XML-Datei einfach zwischen zwei verschiedenen Hardwaresystemen hin und her wechseln. HINWEIS! NamespaceName beinhaltet immer den Hostnamen des IPC oder Embedded-PC, auf dem der OPC UA Server läuft. Wird „[NodeName]“ gewählt, wird dieser Tag durch den Hostnamen des aktuellen IPCs oder Embedded-PCs ersetzt, auf dem der UA-Server läuft.
SamplingRate bestimmt, wie oft der UA-Server einen Wert vom Knoten abfragen soll, um festzustellen, ob eine der Alarmgrenzen erreicht wurde.
Die Alarmtexte werden über eine ID identifiziert. Die ID identifiziert eindeutig einen Alarmtext aus der Ressourcendatei (siehe Schritt 5: Mehrsprachige Alarmtexte konfigurieren).
Schritt 3: Eigene Benutzerdaten mit einem Alarm übermitteln
Alarme können Felder mit eigenen Benutzerdaten enthalten, die die mit dem Alarm ausgegebenen Daten ergänzen. Diese Benutzerdatenfelder können in der Laufzeitanwendung erzeugt und ausgefüllt werden, indem ein STRUCT erstellt wird, dessen erstes Element „value“ genannt wird. Bei einem Alarm werden dann alle folgenden Elemente in einem zusätzlichen Benutzerdatenfeld gesendet.
Beispiel SPS-Anwendung:
TYPE ST_CustomStruct :
STRUCT
value : INT;
data : ST_SomeStruct;
END_STRUCT
END_TYPE

TYPE ST_SomeStruct :
STRUCT
Data1 : INT;
Data2 : REAL;
Data3 : LREAL;
END_STRUCT
END_TYPE
Die Instanz von ST_CustomStruct wird dann über den regulären Mechanismus, z. B. in TwinCAT 3, für den Datenzugriff aktiviert: Das STRUCT muss als StructuredDataType aktiviert sein.
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '1'}
stCustomStruct : ST_CustomStruct;
END_VAR
Bei der Anmeldung bei einem ConditionController müssen die OPC UA Clients besondere AlarmConditionTypes, sogenannte „BkUaLimitAlarmType“ und „BkUaOffNormalAlarmType“, abonnieren, damit sie die besonderen Benutzerdatenfelder beim Eingang eines Alarms empfangen können.
Der OPC UA Client empfängt dann die Benutzerdaten in den Feldern „BkUaEventData“ und „BkUaEventValue“ des eingehenden Alarms. Im obigen Beispiel sind das der Wert der SPS-Variablen sowie die Benutzerdaten, die mit der SPS-Struktur „ST_SomeStruct“ dargestellt sind.
Grafik aus Alarms _ Conditions (i1d631q3.png)
Schritt 4: Ereignis über die FireEvent-Methode auslösen
Jeder ConditionController umfasst eine FireEvent-Methode, mit der die OPC UA Clients ein allgemeines Ereignis mit benutzerdefinierten EventFields auslösen können.
Wird diese Methode ausgeführt, dann wird ein Ereignis auf dem TwinCAT OPC UA Server ausgegeben. Andere OPC UA Clients können diese Ereignisse empfangen, wenn sie den entsprechenden ConditionController abonnieren.
Die benutzerdefinierten EventFields werden als „UserEventData“ an das Ereignis angehängt. Diesen Daten können von OPC UA Clients empfangen werden, die beim SimpleEventType „UserEventType“ angemeldet sind.
Schritt 5: Mehrsprachigen Alarmtexten konfigurieren
Die A&C-Implementierung im TwinCAT OPC UA Server unterstützt die Verwendung von mehrsprachigen Alarmtexten. Abhängig von der Sprache, mit der sich der UA-Client mit dem Server verbindet, wird ein entsprechender Alarmtext verwendet. Alarmtexte werden in XML-Dateien konfiguriert, für jede Sprache gibt es eine eigene Datei. Diese Dateien befinden sich im Ordner „res“ (Ressource) des TwinCAT OPC UA Servers. Mit dem Konfigurator können Alarmtexte bequem hinzugefügt oder entfernt werden, ohne dass die XML-Dateien direkt bearbeitet werden müssen. Jeder Alarmtext hat eine eigene ID, die in der Datei nur einmal vorkommt.
Beispiel:
<TcOpcUaSvrRes Lang="en">
<Text ID="0">Text not available</Text>
<Text ID="1">Some alarm text</Text>
<Text ID="2">Value is High range</Text>
<Text ID="3">Value is HighHigh range</Text>
<Text ID="4">Value is OffNormal</Text>
...
</TcOpcUaSvrRes>
Schritt 6: A&C bei einem Referenz-OPC-UA-Client anmelden
Ein OPC UA Client muss sich bei einem ConditionController anmelden, damit er Ereignisse für Bedingungen empfangen kann, die für diesen besonderen ConditionController konfiguriert sind. Der UA‑Expert stellt Funktionen zur Verfügung, um UA-Ereignisse zu abonnieren und zu empfangen. Nachdem UA-Expert gestartet und eine Verbindung zum TwinCAT OPC UA Server hergestellt wurde, fügen Sie Ihrem Arbeitsbereich eine neue Dokumentenansicht, genannt „Event View“, hinzu.
Sie können einen ConditionController dann durch Ziehen des entsprechenden Objekts in EventView abonnieren. Die Ereignisse für diesen ConditionController werden im „Event Window“ angezeigt.
Möglicherweise müssen spezielle Alarm- und/oder Ereignistypen abonniert werden, damit Sie alle Felder eines eingehenden Ereignisses oder Alarms empfangen können.


Methodenaufruf

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Methodenaufruf
Methodenaufruf
Methodenaufrufe sind ein grundlegender Teil der OPC-UA-Spezifikation. Mit der Einführung dieser Funktionalitäten in die SPS-Welt bietet TwinCAT 3 die Möglichkeit zur effizienten Ausführung von RPC‑Aufrufen in der IEC61131-Welt und verringert somit die klassischen Handshake-Pattern bei der Kommunikation zwischen den Geräten. Der TwinCAT OPC UA Server importiert SPS‑Methoden wie OPC‑UA‑Methoden über seinen TMC-Import.
Hinweis
IEC61131-Methode
Auch wenn die SPS-Methode eine normale Methode im UA-Namensraum zu sein scheint, ist sie immer noch eine IEC61131-Methode, die innerhalb des Echtzeit-Kontexts ausgeführt wird und somit unter den Kontext einer Echtzeit-Task fällt. Der SPS-Entwickler muss daher Vorsichtsmaßnahmen treffen, sodass die Ausführungszeit der Methode in die Task-Zykluszeit passt.
Grafik aus Method Call (icv0vpv2.png)
Methoden in IEC61131-3
Methoden in der IEC61131-Welt werden immer unterhalb eines Funktionsbausteins konfiguriert. Auf Hochsprachenebene kann der Funktionsbaustein als umgebende Klasse der Methode betrachtet werden. Die Methode selbst muss mit einem speziellen SPS-Attribut deklariert werden, sodass das TwinCAT-System weiß, dass die Methode für einen Remote-Methodenaufruf aktiviert werden soll.
{attribute 'TcRpcEnable':='1'}
METHOD M_Sum : INT
VAR_INPUT
a : INT;
b : INT;
END_VAR
Gefilterter oder ungefilterter Modus
In Abhängigkeit davon, welcher Importmodus verwendet wird, muss der umgebende Funktionsbaustein ebenfalls für den OPC‑UA‑Zugriff aktiviert werden. Dies kann durch Verwendung der normalen SPS‑Attribute für den OPC‑UA‑Zugriff erfolgen.
Beispiel: Die Methode M_Sum befindet sich im Funktionsbaustein FB_Mathematics. Die Deklaration der Funktionsbausteininstanz verwendet das SPS-Attribut, das den Funktionsbaustein und damit die Methode ebenfalls für den OPC-UA-Zugriff aktiviert hat.
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA':='1'}
fbMathematics : FB_Mathematics;
END_VAR
Beachten Sie dabei, dass Sie nur dann die SPS-Attribute verwenden müssen, wenn der gefilterte Modus verwendet wird, um Symbole aus der SPS für den Zugriff über OPC UA freizugeben. Dies ist die Standardeinstellung des OPC UA Servers.


Analog Item Types

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Analog Item Types
Analog Item Types
„AnalogItemTypes“ sind ein Bestandteil der OPC-UA-Spezifikation und ermöglichen es, Metainformationen wie z. B. Einheiten an eine Variable zu heften. In der TwinCAT 3 SPS können diese Metainformationen in Form von SPS-Attributen definiert werden.
Folgende Einstellungen können vorgenommen werden:
▪
EngineeringUnits: Einheiten, definiert über die OPC-UA-Spezifikation
▪
EURange: Maximaler Wertebereich der Variablen
▪
InstrumentRange: Normaler Wertebereich der Variablen
▪
WriteBehavior: Verhalten, wenn bei einem Schreibvorgang der Wertebereich überschritten wird.
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.AnalogItemType' := '1'}
{attribute 'OPC.UA.DA.AnalogItemType.EngineeringUnits' := '20529'}
{attribute 'OPC.UA.DA.AnalogItemType.EURange' := '0:100'}
{attribute 'OPC.UA.DA.AnalogItemType.InstrumentRange' := '10:90'}
{attribute 'OPC.UA.DA.AnalogItemType.WriteBehavior' := '1'}
fillLevel : UINT;
Das obige Beispiel konfiguriert die Variable „fillLevel“ als AnalogItemType und setzt hierbei die folgenden Parameter:
▪
Einheit: 20529 („Prozent“, definiert in OPC UA Spezifikation)
▪
Max. Wertebereich: 0 bis 100
▪
Normaler Wertebereich: 10 bis 90
▪
Schreibverhalten: 1 (Clamping)
Die „EngineeringUnits“ können hierbei anhand der in OPC UA spezifizierten Ids (Teil 8 der OPC‑UA‑Spezifikation) konfiguriert werden. Die Ids orientieren sich hierbei nach den weit verbreiteten und akzeptierten „Codes for Units of Measurement (Recommendation N.20)“, welche vom „United Nations Centre for Trade Facilitation and Electronic Business“ veröffentlicht wurden. Der „CommonCode“, welcher die dreistellige, alphanumerische ID angibt, wird von OPC UA laut Spezifikation in einen Int32-Wert konvertiert und referenziert. Dies passiert über die folgende Vorgehensweise (Auszug aus OPC‑UA‑Spezifikation v1.02, Pseudo-Code):
Int32 unitId = 0;
Int32 c;
for (i=0; i<=3;i++)
{
c = CommonCode[i];
if (c == 0)
break; // end of Common Code
unitId = unitId << 8; // shift left
unitId = unitId | c; // OR operation
}
Schreibverhalten
Beim Schreiben einer AnalogItemType-Variablen kann definiert werden, wie der OPC UA Server mit dem neuen Wert in Bezug auf den Wertebereich umgehen soll. Hierbei gibt es die folgenden Möglichkeiten:
▪
0: Alle Werte sind zugelassen und werden bei einem Schreibvorgang übernommen.
▪
1: Der zu schreibende Wert wird passend zum Wertebereich abgeschnitten.
▪
2: Der zu schreibende Wert wird abgewiesen, falls er den Wertebereich überschreitet.


Typsystem

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Typsystem
Typsystem
Einer der größten Vorteile von OPC UA ist das Meta-Modell, welches zur Bereitstellung von Basistypen genauso verwendet werden kann wie zur Erweiterung des Typsystems durch eigene Modelle. Derselbe Mechanismus wird zur Darstellung realer Objekte (Nodes) verwendet, sodass OPC UA Clients einen Objekttyp bestimmen können.
Der TwinCAT 3 OPC UA Server veröffentlicht Typinformationen von der IEC61131-Welt in seinen Namensraum. Dies umfasst nicht nur Basistypen wie z. B. BOOL, INT, DINT oder REAL, sondern auch erweiterte Typinformationen, wie z. B. die aktuelle Klasse (Funktionsbaustein) oder Struktur, die ein Objekt repräsentiert.
Typinformationen
Typinformationen sind Bestandteil des UA-Namensraums. Der TwinCAT OPC UA Server erweitert die Basistypinformationen wie folgt:
▪
Lokale Typinformationen, die nur für eine Laufzeit gültig ist, werden in demselben Namensraum wie die Laufzeitsymbole gespeichert.
▪
Globale Typinformationen, die über verschiedene Laufzeiten gültig sein können, werden in einem eigenen globalen Namensraum gespeichert.
Das Typsystem ist ebenfalls virtuell verfügbar und kann in Types Sektion des OPC UA Servers eingesehen werden:
Grafik aus Type system (ibf6eok2.png)
Jeder Nichtstandard-Datentyp wird im Verzeichnis BeckhoffCtrlTypes eingetragen.
Grundlagen
Angenommen, die TwinCAT 3 SPS besteht aus einem SPS-Programm mit verschiedenen STRUCTs. Jeder STRUCT wird als Knoten in einem UA Namensraum repräsentiert, mit jedem Element der Struktur als untergeordneten Knoten.
Grafik aus Type system (i8a83g13.png)
In dem vorstehenden Beispiel besteht der STRUCT stSampleStruct aus drei untergeordneten Elementen: einer Variable nValue1 des Typs INT, einer Variable bValue2 des Typs BOOL und einem weiteren STRUCT stSubStruct, der lediglich ein untergeordnetes Element enthält – eine Variable nValue des Typs INT.
Die Struktur selbst ist lediglich eine reguläre Variable im UA-Namensraum, die den Datentyp ByteString hat. Die Clients können daher einfach mit dem Wurzelelement (der Struktur selbst) verbunden werden und dessen Werte durch Interpretation des ByteString gelesen/geschrieben werden. Damit die Interpretation jedes untergeordneten Elements vereinfacht wird, enthält das Typsystem mehr Informationen über die Struktur selbst, in erster Linie in der Referenz zur Instanz:
Grafik aus Type system (igrjfpt2.png)
Dann enthält das Typsystem mehr Informationen über ST_SampleStruct:
Grafik aus Type system (iun9n673.png)
Und in den Referenzen von ST_SampleStruct:
Grafik aus Type system (ibkg1h5.png)
Tatsache ist, wenn ein Client die Struktur weiter interpretieren will, kann das Typsystem sehr nützliche Informationen bieten.
Objektorientierte Erweiterungen
Angenommen, die TwinCAT-3-SPS-Laufzeit enthält ein SPS-Programm, dessen Struktur wie folgt visualisiert werden kann:
Grafik aus Type system (i9g54s22.jpg)
Die zwei Funktionsbausteine „Scanner“ und „Drive“ sind von der Basisklasse „Device“ abgeleitet, indem objektorientierte Erweiterungen der IEC61131-3 verwendet werden. Das MAIN-Programm enthält nun die folgenden Deklarationen:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA':='1'}
Scanner1 : Scanner;
{attribute 'OPC.UA.DA':='1'}
Scanner2 : Scanner;
{attribute 'OPC.UA.DA':='1'}
DriveX : Drive;
END_VAR
Alle drei Objekte sind vom Typ „Device“, aber auch von ihrem speziellen Datentyp. Der OPC UA Server importiert nun die Objekte wie folgt:
Grafik aus Type system (igooqku2.png)
Der zugrundeliegende Datentyp kann nun in der Referenz jedes Objekts bestimmt werden, z. B. Objekt „Scanner1“:
Grafik aus Type system (im6d77g.png)
Entsprechend des zugrundeliegenden IEC61131-Programms ist das Objekt „Scanner1“ vom Datentyp „Scanner“ und zeigt ebenfalls, welche Variablen enthalten sind und welcher Art die Variable ist: Eine Eingangs-, Ausgangs- oder interne (lokale) Variable. Das Diagramm oben zeigt, dass nicht nur die Variablen des tatsächlichen Funktionsbausteins hier wiedergegeben werden, sondern auch die abgeleiteten Variablen der Basisklasse. Die gesamte IEC61131-3-Vererbungskette wird im UA-Namensraum repräsentiert.


Strukturierte Typen

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Strukturierte Typen
Strukturierte Typen
Strukturierte Typen erlauben es, Strukturen zu lesen oder zu schreiben ohne dafür jedes Byte zu interpretieren, weil der UA-Server den Informationstyp jedes Elements der Struktur zurückgibt. Durch komplexe Funktionen in modernen OPC UA SDK’s können OPC UA Clients diese strukturellen Informationen durchsuchen und interpretieren.
Ab Version 2.2.x des TwinCAT OPC UA Servers werden Strukturen von der TwinCAT‑3‑Laufzeit (nur TMC- und TMI-Import) als ein StructuredType im UA‑Namensraum erzeugt. Beispiel:
STRUCT ST_Communication:
TYPE ST_Communication :
STRUCT
a : INT;
b : INT;
c : INT;
END_STRUCT
END_TYPE
Programm MAIN:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '1'}
stCommunication : ST_Communication;
END_VAR
Hinweis
Gefilterter Modus
Werden Filter eingesetzt, um Symbole über OPC UA verfügbar zu machen, muss ein im ein STRUCT oder Funktionsbaustein im UA‑Namensraum voll verfügbar sein, um als StructuredDataType angezeigt zu werden.
Die Instanz „stCommunication“ wird dann im UA-Namensraum als „StructuredType“ angezeigt:
Alternativ kann die struct-Definition auch das SPS Attribut erhalten, um alle Instanzen von STRUCT als StructuredType verfügbar zu machen.
{attribute 'OPC.UA.DA.StructuredType' := '1'}
TYPE ST_Communication :
STRUCT
a : INT;
b : INT;
c : INT;
END_STRUCT
END_TYPE
Um „StructuredType“ einer bestimmten Instanz zu deaktivieren, kann das folgende Attribut verwendet werden:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '0'}
stCommunication : ST_Communication;
END_VAR
Funktionsbaustein StructuredType
Zusätzlich enthält jeder Funktionsbaustein der TwinCAT 3 SPS auch einen Kind-Knoten, „FunctionBlock“, der den gesamten Funktionsbaustein als „StructuredDataType“ beinhaltet.
Beispiel:
Funktionsbaustein:
FUNCTION_BLOCK FB_FunctionBlock
VAR_INPUT
Input1 : INT;
Input2 : LREAL;
END_VAR
VAR_OUTPUT
Output1 : LREAL;
END_VAR
Instanz eines Funktionsbausteins:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '1'}
fbFunctionBlock : FB_FunctionBlock;
END_VAR
Instanz des Funktionsbausteins im OPC‑UA‑Namensraum:
FunctionBlock-Knoten mit StructuredDataType:
Alternativ kann der Funktionsbaustein auch ein SPS-Attribut erhalten, um alle Instanzen des Funktionsbausteins als „StructuredType“ zur Verfügung zu stellen.
{attribute 'OPC.UA.DA.StructuredType' := '1'}
FUNCTION_BLOCK FB_FunctionBlock
VAR_INPUT
Input1 : INT;
Input2 : LREAL;
END_VAR
VAR_OUTPUT
Output1 : LREAL;
END_VAR
Um StructuredType einer bestimmten Instanz zu deaktivieren, kann das folgende Attribut verwendet werden:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '0'}
fbFunctionBlock : FB_FunctionBlock;
END_VAR
Hinweis
Maximale Größe der Struktur
Die maximale Größe einer Struktur ist standardmäßig auf 16 kByte festgelegt. Jedes STRUCT tauscht ständig Daten mit dem Basis-ADS-Gerät aus, d.h. mit jedem Lese-/Schreibbefehl eines Structured Type wird eine große ADS-Meldung verschickt. Damit der ADS-Router nicht mit großen Meldungen überflutet wird, ist die maximale Größe beschränkt. Der Nutzer kann diese Vorgabe in der Datei ServerConfig.xml ändern. Dazu muss der Schlüssel <MaxStructureSize> zu OpcServerConfig\UaServerConfig\ hinzugefügt und ein neuer Wert für die maximale Größe einer Struktur in Bytes festgelegt werden. Wenn eine Struktur die Größe <MaxStructureSize> überschreitet, wird sie als FolderType importiert, wo jedes Strukturelement als einzelner Knoten verfügbar ist.


Verwendung von Arrays

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Verwendung von Arrays
Verwendung von Arrays
Standardmäßig werden Arrays im UA-Namensraum als einzelner Knoten betrachtet. Dies bedeutet, dass, wenn Sie z. B. in der SPS ein Array dyn_BOOL[10] definieren (und dieses auch für OPC UA freigegeben haben), es anschließend im UA-Namensraum wie folgt auftaucht:
Der Vorteil dieser Vorgehensweise ist eine deutliche Reduzierung der Komplexität des UA-Namensraums und des Speicherverbrauchs, da nicht jede Position eines Arrays als einzelner Knoten im Namensraum zur Verfügung gestellt werden muss. Moderne UA-Clients können jedoch weiterhin auf die einzelnen Array-Positionen über den sogenannten „RangeOffset“ zugreifen.
Damit jedoch auch ältere UA-Clients unterstützt werden, welche dieses Feature nicht bieten, können Sie die Positionen eines Arrays auch als einzelne Knoten im UA-Namensraum verfügbar machen. Dies würde sich dann wie folgt darstellen:
Diese Einstellung ist durch Aktivierung der Option Legacy Array Handling im UA-Konfigurator innerhalb der jeweiligen Namensraum-Konfiguration verfügbar.
HINWEIS! Je nach Umfang des SPS-Projekts gewinnt der UA-Namensraum hierdurch deutlich an Komplexität, was sich wiederum in einer erhöhten Speicherauslastung des UA-Servers widerspiegelt.
Eine Änderung der oben genannten Einstellungen wird erst aktiv, wenn Sie den UA-Server neu starten.


Liste der Attribute und Kommentare

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Liste der Attribute und Kommentare
Liste der Attribute und Kommentare
Die Konfiguration der Laufzeitvariablen für verschiedene OPC‑UA‑Funktionen (z. B. Data Access oder Historical Access) erfolgt direkt im SPS-Programm oder im TMC Code Editor (bei Verwendung von TwinCAT 3 C++). Der Vorteil ist, dass ein SPS-Entwickler direkt in dem Programm, mit dem er vertraut ist, entscheiden kann, ob und wie eine Variable für OPC UA freizugeben ist. Die Aktivierung erfolgt dann durch Einfügen eines Kommentars und des entsprechenden OPC-UA-Tags vor der Variablen, z. B.:
TwinCAT 3 SPS (TMC):
{attribute 'OPC.UA.DA' := '1'}
bVariable : BOOL;
TwinCAT 2 SPS (TPY):
bVariable : BOOL; (*~ (OPC:1:available)*)
Eine detaillierte Beschreibung zur Verwendung von Attributen und Kommentaren erhalten Sie im Kapitel über die entsprechenden Laufzeitkomponenten:
▪
SPS
▪
C++
▪
I/O
▪
Matlab/Simulink
Die folgende Tabelle zeigt einen Überblick aller definierbaren Tags und ihrer Bedeutung. In den Unterschnitten der entsprechenden Funktion finden Sie eine ausführliche Beschreibung des Funktionsprinzips.
TwinCAT 3 (TMC):
OPC-UA-Funktion | SPS-Tag | C++ TMC Code Editor (Optionale Eigenschaften) | Bedeutung
Data Access (DA) | {attribute 'OPC.UA.DA' := '0'} | Name: OPC.UA.DA Wert: 0 | Sperrt eine Variable für OPC UA, woraufhin diese im UA‑Namensraum nicht mehr sichtbar ist.
Data Access (DA) | {attribute 'OPC.UA.DA' := '1'} | Name: OPC.UA.DA Wert: 1 | Aktiviert eine Variable für OPC UA, woraufhin diese im UA‑Namensraum sichtbar wird. Dieses Tag muss immer gesetzt sein, wenn eine Variable für UA verwendet werden soll.
Data Access (DA) | {attribute 'OPC.UA.DA.Access' := 'x'} | Name: OPC.UA.DA.Access Wert: siehe rechte Spalte | Setzt Lese-/Schreib-Zugriff für eine Variable, je nach Parameter „x“. 0 = Kein 1 = Schreibgeschützt 2 = Nur Schreibzugriff 3 = Lese- und Schreibzugriff (Standardwert, wenn kein Tag verwendet wird)
Data Access (DA) | {attribute 'OPC.UA.DA.StructuredType' := '0'} | Name: OPC.UA.DA.StructuredType Wert: 0 | Deaktiviert StructuredType für ein STRUCT oder einen Funktionsbaustein
Data Access (DA) | {attribute 'OPC.UA.DA.StructuredType' := '1'} | Name: OPC.UA.DA.StructuredType Wert: 1 | Aktiviert StructuredType für ein STRUCT oder einen Funktionsbaustein
Data Access | {attribute 'OPC.UA.DA.Status' := 'quality'} | Name: OPC.UA.DA.Status Wert: quality | Statuscode eines Symbols im UA‑Namensraum manuell festlegen. Nur für Datenstrukturen. Der Wert „quality“ legt fest, welches DINT Unterelement der Datenstruktur den Statuscode festlegt. Siehe entsprechenden Artikel der Dokumentation für weitere Informationen.
Historical Access (HA) | {attribute 'OPC.UA.HA' := '1'} | Name: OPC.UA.HA Wert: 1 | Aktiviert eine Variable für „Historical Access“. Muss mit {attribute 'OPC.UA.DA' := '1'} verwendet werden.
Historical Access (HA) | {attribute 'OPC.UA.HA.Storage' := 'x'} | Name: OPC.UA.HA.Storage Wert: siehe rechte Spalte | Definiert den Speicherort für Historical Access, abhängig von Parameter “x” 1 = Speicher 2 = Datei 3 = SQL Compact Database 4 = SQL Server Database
Historical Access (HA) | {attribute 'OPC.UA.HA.Sampling' := 'x'} | Name: OPC.UA.HA.Sampling Wert: siehe rechte Spalte | Legt die Abtastrate fest, mit der die Variablenwerte zu speichern sind, in Abhängigkeit des Parameters „x“ in [ms]
Historical Access (HA) | {attribute 'OPC.UA.HA.Buffer' := 'x'} | Name: OPC.UA.HA.Buffer Wert: siehe rechte Spalte | Definiert die maximale Anzahl Werte, die im Datenspeicher bleiben, in Abhängigkeit des Parameters „x“.
TwinCAT 2 (TPY):
OPC‑UA‑Funktion | SPS‑Tag | Bedeutung
Data Access (DA) | (*~ (OPC:0:not available) *) | Sperrt eine Variable für OPC UA, woraufhin diese im UA‑Namensraum nicht mehr sichtbar ist.
Data Access (DA) | (*~ (OPC:1:available) *) | Aktiviert eine Variable für OPC UA, woraufhin diese im UA‑Namensraum sichtbar wird. Dieses Tag muss immer gesetzt sein, wenn eine Variable für UA verwendet werden soll.
Data Access (DA) | (*~ (OPC_PROP[0005]:1:Schreibgeschützt) *) | Setzt den Schreibschutz für eine Variable. Muss zusammen mit (*~ (OPC:1: available) *) verwendet werden.
Data Access (DA) | (*~ (OPC_UA_PROP[5100] : x: Alias name) *) | Bestimmt x als Knotennamen im UA‑Namensraum, sogenanntes Alias Mapping.
Historical Access (HA) | (*~ (OPC_UA_PROP[5000]:x:Storage media) *) | Aktiviert eine Variable für „Historical Access“. Muss zusammen mit (*~ (OPC:1: available) *) verwendet werden. x definiert das Speichermedium für die Speicherung der Datenwerte: 1 = Speicher 2 = Datei 3 = SQL Compact Database 4 = SQL Server Database
Historical Access (HA) | (*~ (OPC_UA_PROP[5000][1]:x:SamplingRate) *) | Legt die Abtastrate fest, mit der die Variablenwerte zu speichern sind, in Abhängigkeit des Parameters „x“ in [ms]
Historical Access (HA) | (*~ (OPC_UA_PROP[5000][2]:x:Buffer) *) | Definiert die maximale Anzahl Werte, die im Datenspeicher bleiben, in Abhängigkeit des Parameters „x“.


Statuscode

Technische Einführung [image] TwinCAT OPC UA Server [image] SPS [image] Statuscode
Statuscode
Der TwinCAT OPC UA Server ermöglicht einer SPS-Anwendung die Änderung des OPC UA StatusCode.
Führen Sie die folgenden Schritte aus, um den StatusCode einer Variablen zu konfigurieren und auf diesen einzuwirken:
SPS-Struct erstellen
Damit die Datenkonsistenz gewährleistet ist, basiert das Konzept der Änderung des OPC UA StatusCode auf StructuredDataTypes. Jede Variable, auf deren UA‑StatusCode eingewirkt werden soll, muss in ein STRUCT eingeschlossen sein. Erzeugen Sie ein neues STRUCT und fügen Sie ein SPS-Attribut vor der STRUCT-Definition hinzu.
{attribute 'OPC.UA.DA.STATUS' := 'quality'}
TYPE ST_StatusCodeOverride :
STRUCT
value : REAL;
quality: DINT;
END_STRUCT
END_TYPE
Das STRUCT enthält die Variable selbst und eine Variable vom Datentyp DINT, die den StatusCode darstellt. Auf diese Variable wird ebenfalls mittels ihres Namens im Attribut vor der STRUCT‑Definition verwiesen.
Erstellen Sie nun eine Instanz von diesem STRUCT, z. B. im MAIN-Programm, und fügen das reguläre SPS-Attribut hinzu, damit diese Instanz über OPC UA verfügbar wird.
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
stStatusCodeOverride : ST_StatusCodeOverride;
END_VAR
Diese Instanz ist nun innerhalb des OPC‑UA‑Namensraums als ein „StructuredDataType“ verfügbar.
StatusCode überschreiben
Um den UA StatusCode für das STRUCT zu überschreiben, bearbeiten Sie einfach den Wert der Variablen „quality“, indem Sie diesen z. B. auf „-2147155968“ setzen, ändert sich der StatusCode des STRUCT zu „BadCommunicationError“.
Der Wert muss entsprechend der Definition in der OPC‑UA‑Spezifikation festgelegt werden.
In der nachfolgenden Tabelle werden nur einige der verfügbaren Statuscodes und deren entsprechende dezimale Darstellung aufgelistet. Konsultieren Sie die offizielle OPC‑UA‑Spezifikation für eine umfassendere Liste der Statuscodes.
StatusCode | Hex | Decimal
BadUnexpectedError | 0x80010000 | -2147418112
BadInternalError | 0x80020000 | -2147352576
BadCommunicationError | 0x80050000 | -2147155968
BadTimeout | 0x800A0000 | -2146828288
BadServiceNotSupported | 0x800B0000 | -2146762752
Hinweis
UA‑StatusCodes
Achten Sie bei der Berechnung der dezimalen Darstellung anderer UA-Statuscodes auf der Grundlage ihrer hexadezimalen Darstellung darauf, dass Ihr Rechner auf DWORD eingestellt ist, z. B. der Windows Rechner ("Programmierer" Ansicht).


C++

Technische Einführung [image] TwinCAT OPC UA Server [image] C++
C++
Weiterführende Informationen
•
Zugriff auf C++-Laufzeit
•
Historical Access
•
Alarms & Conditions
•
Methodenaufruf
•
Strukturierte Typen
•
Liste der Attribute und Kommentare


Zugriff auf C++-Laufzeit

Technische Einführung [image] TwinCAT OPC UA Server [image] C++ [image] Zugriff auf C++-Laufzeit
Zugriff auf C++-Laufzeit
In diesem Teil der Dokumentation wird beschrieben, wie der Namensraum des TwinCAT OPC UA Servers zu konfigurieren ist, um Zugriff auf die Symbole eines TwinCAT‑3‑C++‑Moduls zu erhalten. Hierzu können Sie entweder den OPC‑UA‑Konfigurator verwenden, oder die Konfiguration direkt und per Hand in der ServerConfig.xml-Datei des OPC UA Servers vornehmen.
Dieser Abschnitt beinhaltet folgende Themen:
▪
Schritt 1: Projektbezogene Einstellungen
▪
Schritt 2: Konfiguration des UA-Servers
Schritt 1: Projektbezogene Einstellungen
Um bestimmte, in einer Instanz eines TwinCAT‑3‑C++‑Moduls enthaltene Symbole so zu konfigurieren, dass sie über OPC UA zugänglich werden, sind die folgenden Schritte in den Einstellungen der entsprechenden C++‑Modulinstanz in TwinCAT XAE erforderlich:
1.
Der OPC UA Server benötigt die TMI‑Symboldatei, die standardmäßig nicht an die Ziel-Laufzeit übergeben wird. Aktivieren Sie die Übertragung durch Setzen der folgenden Optionen:
⇨
Die erzeugte TMI-Datei wird nach der ObjectId benannt, z. B. „Obj_01010020.tmi“ und in das TwinCAT‑Bootverzeichnis, z. B. C:\TwinCAT\Boot\Tmi\, abgelegt.
2.
Legen Sie fest, welche Symbole für die entsprechenden Variablen zugänglich gemacht werden sollen, indem Sie das Kontrollkästchen Create Symbol im TMC-CodeGenerator aktivieren. Führen Sie den TMC-CodeGenerator anschließend aus
Schritt 2: Konfiguration des UA-Servers
Sie können den Zugang zu TwinCAT‑3‑C++‑Modulen bequem mithilfe des OPC‑UA‑Konfigurators konfigurieren und parametrisieren. Fügen Sie hierzu im Bereich Datenzugriff ein neues Gerät vom Typ „CPP TwinCAT 3 (TMI) gefiltert“ hinzufügen.
Das Feld SymbolFile muss auf die TMI-Datei zeigen, die für die C++‑Modulinstanz erzeugt wurde. Diese TMI-Datei befindet sich im TwinCAT‑Bootverzeichnis, z. B. C:\TwinCAT\Boot\Tmi\, und wurden nach der ObjectId der TwinCAT‑3‑C++‑Modulinstanz benannt.
Die einstellbaren Parameter beschreiben die folgenden Funktionen:
Parameter | Beschreibung | Mögliche Werte
ADS Port | Definiert den ADS-Port, unter dem die C++‑Modulinstanz zugänglich ist. Der ADS Port kann in den Eigenschaften des C++ Tasks gelesen werden. | 351 352 …
AutoCfg | Definiert zunächst den Typ der für die Kommunikation verwendeten Ziel-Laufzeit, z. B. SPS, C++, I/O. Anschließend kann eine weitergehende Unterscheidung innerhalb dieser Kategorien stattfinden. Jede AutoCfg‑Option steht sowohl als ungefilterte, als auch gefilterte Option zur Verfügung. Gefiltert bedeutet, dass der Nutzer bestimmen kann, welche C++‑Symbole über OPC UA öffentlich zugänglich gemacht werden. Bei Verwendung einer ungefilterten Option wird jedes C++‑Symbol an OPC UA veröffentlicht. | 4020 CPP TwinCAT 3 (TMI) 4021 CPP TwinCAT 3 (TMI) gefiltert
AutoCfgSymFile | Symboldatei (TMI) der entsprechenden C++‑Modulinstanz. | Pfad zur Symboldatei. (TMI)
IoMode | Definiert die Methode für den Zugriff auf Symbole. | 1 (Zugriff über Handle - standardmäßig)
ArraySubItemLegacySupport | Unterelemente eines Array werden standardmäßig nicht als separate Knoten im UA-Namensraum abgebildet. Stattdessen wird lediglich das Array als ein einzelnes Element abgebildet. Nichtsdestotrotz können UA-Clients über deren sogenannten „IndexRange“ auf Unterelemente zugreifen. Unglücklicherweise unterstützen einige ältere OPC UA Clients diese Möglichkeit noch nicht. Dieses Flag wurde eingeführt, sodass der Zugriff nichtsdestotrotz für diese Clients möglich wird. Das Flag sorgt dafür, dass jede Array-Position als separater Knoten im UA‑Namensraum angezeigt wird. HINWEIS! Dies führt zu einem höheren Speicherbedarf des OPC UA Servers. | 0 (deaktiviert - standardmäßig) 1 (aktiviert)
Disabled | Deaktiviert die C++‑Modulinstanz im UA‑Namensraum, woraufhin der entsprechende Knoten nicht angezeigt wird. Es wird empfohlen diesen Parameter zu aktivieren, wenn bestimmte C++‑Laufzeiten zum Zeitpunkt der Projektplanung noch nicht verfügbar sind, weil z. B. die entsprechenden Geräte noch nicht ans Netzwerk angeschlossen sind. | 0 (deaktiviert - standardmäßig) 1 (aktiviert)


Historical Access

Technische Einführung [image] TwinCAT OPC UA Server [image] C++ [image] Historical Access
Historical Access
Weiterführende Informationen
•
Setupversion 4.x.x
•
Anzeige von historischen Daten


Setupversion 4.x.x

Technische Einführung [image] TwinCAT OPC UA Server [image] C++ [image] Historical Access [image] Setupversion 4.x.x
Setupversion 4.x.x
Ab Setupversion 4.x.x wird Historical Access nicht mehr länger über Attribute bzw. Kommentare konfiguriert. Dies hat den Vorteil, dass die Historical-Access-Funktionalität nun auch für Laufzeiten zur Verfügung steht, dies dies bisher nicht unterstützt haben, z. B. Variablen von einem BC9191 Controller. Des Weiteren kann eine Historical‑Access‑Konfiguration nun auch nachträglich, d. h. ohne Anpassung des SPS-Projekts durchgeführt werden.
Die Historical‑Access‑Konfiguration ist nun XML-basiert (TcUaHaConfig.xml) und kann über den OPC UA Server Konfigurator vorgenommen werden (siehe Konfiguration von Historical Access). Diese XML-Datei befindet sich in demselben Verzeichnis wie die TcOpcUaServer.exe. Der Vollständigkeit halber wird der Aufbau der XML-Datei an dieser Stelle jedoch kurz erklärt.
<HistoryConfig>
<HistoryController>
<HistoryAdapter Type="Volatile" Id="0" File="" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="File" Id="1" File="historydb.dat" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="SQL" Id="2" File="" Server="" Database="database123" User="user" Password="pwd"/>
<HistoryAdapter Type="SQLCompact" Id="3" File="historydb.xyz" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="SQLCompact" Id="4" File="historydb2.xyz" Server="" Database="" User="" Password=""/>
</HistoryController>
<HistoryNodes>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_SingleNode.nMyValue"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.nMyValue1"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.nMyValue2"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.fMyValue3"/>
</HistoryNodes>
</HistoryConfig>
In dem Bereich <HistoryController> können alle unterstützten Datenspeicher konfiguriert werden. Aktuell werden die folgenden Speicherorte unterstützt:
▪
Arbeitsspeicher („Volatile“)
▪
Datei („File“)
▪
SQL Compact
▪
SQL Server (wird nicht unter Windows CE unterstützt)
Jeder <HistoryAdapter> (außer „Volatile“) kann hierbei mehrfach verwendet werden, z. B. wenn die historischen Werte für einzelne Variablen in unterschiedlichen Datenspeichern abgelegt werden sollen.
Im Bereich <HistoryNodes> werden die einzelnen Nodes konfiguriert, einem Datenspeicher zugewiesen und mit einer SamplingRate sowie einer maximalen Größe für den zu verwendenden Ringbuffer im Datenspeicher versehen.
Das Attribut HistoryWriteable="true" bewirkt, dass der Datenspeicher für diese Node über einen HistoryUpdate() Aufruf mit Werten befüllt werden kann. Ein solcher Aufruf wird z.B. von unserem TwinCAT OPC UA Client über den UA_HistoryUpdate() Funktionsbaustein zur Verfügung gestellt. Wird eine Node mit diesem Attribut konfiguriert, dann sampled üblicherweise der Server selbst nicht die Werte, sondern bekommt diese von anderen Clients reingereicht. Die SamplingRate ist daher bei einer solchen Konfiguration üblicherweise gleich 0.
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Anzeige von historischen Daten

Technische Einführung [image] TwinCAT OPC UA Server [image] C++ [image] Historical Access [image] Anzeige von historischen Daten
Anzeige von historischen Daten
Anzeige von Historical‑Access‑Werten in einem OPC UA Client
Die folgende Schritt-für-Schritt-Anleitung beschreibt, wie die Software UA-Expert konfiguriert werden kann, um auf historische Daten zuzugreifen.
1.
Starten Sie die UA-Expert-Software und stellen Sie eine Verbindung mit dem OPC UA Server her.
2.
Fügen Sie eine neue „History Trend Ansicht“ hinzu.
3.
Durchsuchen Sie den PLC1-Namensraum und fügen Sie die SPS-Variablen _HistoryDB, _HistoryDBcompact, _HistoryFast und _HistorySlowPersist per Drag-and-drop hinzu.
⇨
Sie können nun den gewünschten Zeitraum, für den die Symbolwerte angezeigt werden sollen, mithilfe der Steuerelemente StartTime und EndTime festlegen, oder falls erforderlich ein CyclicUpdate für diese Variablen starten.


Alarms & Conditions

Technische Einführung [image] TwinCAT OPC UA Server [image] C++ [image] Alarms & Conditions
Alarms & Conditions
In diesem Abschnitt werden die notwendigen Schritte zur Konfiguration von OPC UA Alarms & Conditions (A&C) auf dem TwinCAT OPC UA Server beschrieben. Das Grundkonzept ist unabhängig von der TwinCAT‑Laufzeit. Demzufolge sind die Konfigurationsschritte für SPS, C++, TcCOM-Laufzeit oder nur I/O-Task gleich.
OPC UA Alarms & Conditions (Teil 9 der OPC-UA-Spezifikation) beschreibt ein Modell für die Überwachung von Prozesswerten und das Ausgeben von Alarmen und Ereignissen bei Zustandsänderungen eines Laufzeit-Symbols.
Voraussetzungen
Die folgenden Voraussetzungen gelten für die Verwendung von OPC UA Alarms & Conditions:
▪
Das zu überwachende Laufzeitsymbol muss im Namensraum verfügbar sein.
▪
Der OPC UA Client muss A&C unterstützen. In diesem Abschnitt wird der UA-Expert (von Unified Automation) als Referenz‑UA‑Client verwendet.
Allgemeines
Die folgenden Schritte müssen einmalig ausgeführt werden, um ein Symbol für A&C freizugeben:
▪
Schritt 1: Laufzeitsymbol für Datenzugriff aktivieren (damit das Symbol generell via OPC UA zugänglich wird.)
▪
Schritt 2: A&C für ein Symbol aktivieren
▪
Schritt 3: Eigene Benutzerdaten mit einem Ereignis übermitteln
▪
Schritt 4: Ereignis über die FireEvent-Methode auslösen
▪
Schritt 5: Mehrsprachige Alarmtexte konfigurieren
▪
Schritt 6: A&C bei einem Referenz-OPC-UA-Client anmelden
Diese Schritte werden nachfolgend ausführlicher erläutert. Am Ende des Abschnitts finden Sie Informationen zum Empfang von konfigurierten Alarmen über A&C mit dem UA‑Expert‑Referenz‑Client.
Unterstützte Alarmtypen
Die Implementierung von TwinCAT OPC UA A&C unterstützt derzeit die folgenden Alarmtypen:
▪
LimitAlarmType: Verschiedene Grenzen für ein Symbol definieren. Wird eine Grenze erreicht, gibt der UA-Server einen Alarm aus.
▪
OffNormalAlarmType: Einen Wert definieren, der „normal“ ist. Wenn der aktuelle Wert vom „normalen“ Wert abweicht, gibt der UA-Server einen Alarm aus.
Schritt 1: Laufzeitsymbol für Datenzugriff aktivieren
Als Voraussetzung dafür, dass Variablen für Alarms & Conditions konfiguriert werden können, muss die entsprechende Variable zunächst im OPC UA Server zur Verfügung stehen. Im Falle einer SPS‑Variablen muss diese zunächst entsprechend mit einem Attribut konfiguriert werden, wie im Abschnitt Zugriff auf SPS-Laufzeit beschrieben.
Schritt 2: A&C für ein Symbol aktivieren
Mit dem TwinCAT-OPC-UA-Server-Konfigurator kann ein Laufzeitsymbol einfach für A&C konfiguriert werden. Dieser Konfigurator hat eine einfache grafische Bedienoberfläche, um die dahinter stehende XML-Datei zu bearbeiten. Der Konfigurator steht, je nach Setupversion, in zwei Varianten zur Verfügung: Standalone und integriert in das Visual Studio.
Der folgende Programmausschnitt zeigt ein Beispiel dieser XML-Datei, um das allgemeine Verhalten und den Aufbau der A&C-Implementierung besser zu verstehen.
<TcUaAcConfig>
<ConditionController Name="ConditionController1" >
<Condition Name="Counter" Severity="200">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.nCounter1" />
</Condition>
<Condition Name="Switch" Severity="500">
<OffNormalAlarmType Normal="0" MessageNormal="100" MessageOffNormal="20" />
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.bSwitch" />
</Condition>
<Condition Name="Struct" Severity="300">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.stStruct" />
</Condition>
</ConditionController>
<ConditionController Name="ConditionController2" >
<Condition Name="Counter2" Severity="200">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.nCounter2" />
</Condition>
</ConditionController>
</TcUaAcConfig>
Eine „Bedingung“ definiert das zu überwachende Laufzeitsymbol und die Alarmgrenzen und -texte. Jede „Bedingung“ ist in einem so genannten „ConditionController“ organisiert, dem Objekt, das die OPC UA Clients später abonnieren.
Bei der Erstellung einer Bedingung (Condition) müssen NamespaceName (NS) und NodeID spezifiziert werden, um auf den zu überwachenden UA-Knoten zu verweisen. Der Konfigurator bietet einen einfachen Browsing-Mechanismus, um einen Knoten auszuwählen. In der XML kann durch den Platzhalter „[NodeName]“ in NamespaceName die XML-Datei einfach zwischen zwei verschiedenen Hardwaresystemen hin und her wechseln. HINWEIS! NamespaceName beinhaltet immer den Hostnamen des IPC oder Embedded-PC, auf dem der OPC UA Server läuft. Wird „[NodeName]“ gewählt, wird dieser Tag durch den Hostnamen des aktuellen IPCs oder Embedded-PCs ersetzt, auf dem der UA-Server läuft.
SamplingRate bestimmt, wie oft der UA-Server einen Wert vom Knoten abfragen soll, um festzustellen, ob eine der Alarmgrenzen erreicht wurde.
Die Alarmtexte werden über eine ID identifiziert. Die ID identifiziert eindeutig einen Alarmtext aus der Ressourcendatei (siehe Schritt 5: Mehrsprachige Alarmtexte konfigurieren).
Schritt 3: Eigene Benutzerdaten mit einem Alarm übermitteln
Alarme können Felder mit eigenen Benutzerdaten enthalten, die die mit dem Alarm ausgegebenen Daten ergänzen. Diese Benutzerdatenfelder können in der Laufzeitanwendung erzeugt und ausgefüllt werden, indem ein STRUCT erstellt wird, dessen erstes Element „value“ genannt wird. Bei einem Alarm werden dann alle folgenden Elemente in einem zusätzlichen Benutzerdatenfeld gesendet.
Beispiel SPS-Anwendung:
TYPE ST_CustomStruct :
STRUCT
value : INT;
data : ST_SomeStruct;
END_STRUCT
END_TYPE

TYPE ST_SomeStruct :
STRUCT
Data1 : INT;
Data2 : REAL;
Data3 : LREAL;
END_STRUCT
END_TYPE
Die Instanz von ST_CustomStruct wird dann über den regulären Mechanismus, z. B. in TwinCAT 3, für den Datenzugriff aktiviert: Das STRUCT muss als StructuredDataType aktiviert sein.
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '1'}
stCustomStruct : ST_CustomStruct;
END_VAR
Bei der Anmeldung bei einem ConditionController müssen die OPC UA Clients besondere AlarmConditionTypes, sogenannte „BkUaLimitAlarmType“ und „BkUaOffNormalAlarmType“, abonnieren, damit sie die besonderen Benutzerdatenfelder beim Eingang eines Alarms empfangen können.
Der OPC UA Client empfängt dann die Benutzerdaten in den Feldern „BkUaEventData“ und „BkUaEventValue“ des eingehenden Alarms. Im obigen Beispiel sind das der Wert der SPS-Variablen sowie die Benutzerdaten, die mit der SPS-Struktur „ST_SomeStruct“ dargestellt sind.
Grafik aus Alarms _ Conditions (i1d631q3.png)
Schritt 4: Ereignis über die FireEvent-Methode auslösen
Jeder ConditionController umfasst eine FireEvent-Methode, mit der die OPC UA Clients ein allgemeines Ereignis mit benutzerdefinierten EventFields auslösen können.
Wird diese Methode ausgeführt, dann wird ein Ereignis auf dem TwinCAT OPC UA Server ausgegeben. Andere OPC UA Clients können diese Ereignisse empfangen, wenn sie den entsprechenden ConditionController abonnieren.
Die benutzerdefinierten EventFields werden als „UserEventData“ an das Ereignis angehängt. Diesen Daten können von OPC UA Clients empfangen werden, die beim SimpleEventType „UserEventType“ angemeldet sind.
Schritt 5: Mehrsprachigen Alarmtexten konfigurieren
Die A&C-Implementierung im TwinCAT OPC UA Server unterstützt die Verwendung von mehrsprachigen Alarmtexten. Abhängig von der Sprache, mit der sich der UA-Client mit dem Server verbindet, wird ein entsprechender Alarmtext verwendet. Alarmtexte werden in XML-Dateien konfiguriert, für jede Sprache gibt es eine eigene Datei. Diese Dateien befinden sich im Ordner „res“ (Ressource) des TwinCAT OPC UA Servers. Mit dem Konfigurator können Alarmtexte bequem hinzugefügt oder entfernt werden, ohne dass die XML-Dateien direkt bearbeitet werden müssen. Jeder Alarmtext hat eine eigene ID, die in der Datei nur einmal vorkommt.
Beispiel:
<TcOpcUaSvrRes Lang="en">
<Text ID="0">Text not available</Text>
<Text ID="1">Some alarm text</Text>
<Text ID="2">Value is High range</Text>
<Text ID="3">Value is HighHigh range</Text>
<Text ID="4">Value is OffNormal</Text>
...
</TcOpcUaSvrRes>
Schritt 6: A&C bei einem Referenz-OPC-UA-Client anmelden
Ein OPC UA Client muss sich bei einem ConditionController anmelden, damit er Ereignisse für Bedingungen empfangen kann, die für diesen besonderen ConditionController konfiguriert sind. Der UA‑Expert stellt Funktionen zur Verfügung, um UA-Ereignisse zu abonnieren und zu empfangen. Nachdem UA-Expert gestartet und eine Verbindung zum TwinCAT OPC UA Server hergestellt wurde, fügen Sie Ihrem Arbeitsbereich eine neue Dokumentenansicht, genannt „Event View“, hinzu.
Sie können einen ConditionController dann durch Ziehen des entsprechenden Objekts in EventView abonnieren. Die Ereignisse für diesen ConditionController werden im „Event Window“ angezeigt.
Möglicherweise müssen spezielle Alarm- und/oder Ereignistypen abonniert werden, damit Sie alle Felder eines eingehenden Ereignisses oder Alarms empfangen können.


Methodenaufruf

Technische Einführung [image] TwinCAT OPC UA Server [image] C++ [image] Methodenaufruf
Methodenaufruf
Methodenaufrufe sind ein grundlegender Teil der OPC‑UA‑Spezifikation. Mit der Einführung dieser Funktionalitäten in die SPS-Welt bietet TwinCAT 3 die Möglichkeit zur effizienten Ausführung von RPC-Aufrufen im C++‑Echtzeitkontext und verringert somit die klassischen Handshake‑Pattern bei der Kommunikation zwischen den Geräten. Der TwinCAT OPC UA Server importiert C++‑Methoden wie OPC‑UA‑Methoden über dessen TMI-Import.
Hinweis
Echtzeit-Methode
Auch wenn die C++-Methode eine normale Methode im UA-Namensraum zu sein scheint, ist sie immer noch eine Echtzeit-Methode, die innerhalb des Echtzeit-Kontexts ausgeführt wird und somit unter den Kontext einer Echtzeit-Task fällt. Der TwinCAT-C++-Entwickler muss daher Vorsichtsmaßnahmen treffen, sodass die Ausführungszeit der Methode in die Task-Zykluszeit passt.
Grafik aus Method Call (iu8otbl.png)
Methoden in TwinCAT 3 C++
TwinCAT‑Module könnten Schnittstellen implementieren, die über vordefinierte Methoden verfügen (siehe TcCOM‑Module). Die Methode selbst muss für RPC-Aufrufe während ihrer Definition aktiviert sein (siehe TwinCAT Module Class Wizard Dokumentation), sodass der OPC UA Server weiß, dass sie zur Ausführung bereitsteht.
Grafik aus Method Call (iilm68u2.png)
Damit auch der ReturnValue der Methode zur Verfügung steht, muss das entsprechende Feld markiert sein. Beachten Sie, dass die Schnittstelle, unter der die Methode erstellt wurde, implementiert werden muss.
Grafik aus Method Call (iv8eni22.png)
Gefilterter oder ungefilterter Modus
In Abhängigkeit davon, welcher Importmodus verwendet wird, muss die Methode für den Zugriff über OPC UA deklariert werden. Dies kann durch Verwendung des TMC Editors und der üblichen OPC‑UA‑Attribute als optionale Eigenschaften erfolgen.
Grafik aus Method Call (ige1dvt3.png)


Strukturierte Typen

Technische Einführung [image] TwinCAT OPC UA Server [image] C++ [image] Strukturierte Typen
Strukturierte Typen
Strukturierte Typen erlauben es, Strukturen zu lesen oder zu schreiben ohne dafür jedes Byte zu interpretieren, weil der UA-Server den Informationstyp jedes Elements der Struktur zurückgibt. Durch komplexe Funktionen in modernen OPC UA SDK’s können OPC UA Clients diese strukturellen Informationen durchsuchen und interpretieren.
Ab Version 2.2.x des TwinCAT OPC UA Servers werden Strukturen von der TwinCAT‑3‑Laufzeit (nur TMC- und TMI-Import) als ein StructuredType im UA‑Namensraum erzeugt. Beispiel:
STRUCT ST_Communication:
TYPE ST_Communication :
STRUCT
a : INT;
b : INT;
c : INT;
END_STRUCT
END_TYPE
Programm MAIN:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '1'}
stCommunication : ST_Communication;
END_VAR
Hinweis
Gefilterter Modus
Werden Filter eingesetzt, um Symbole über OPC UA verfügbar zu machen, muss ein im ein STRUCT oder Funktionsbaustein im UA‑Namensraum voll verfügbar sein, um als StructuredDataType angezeigt zu werden.
Die Instanz „stCommunication“ wird dann im UA-Namensraum als „StructuredType“ angezeigt:
Alternativ kann die struct-Definition auch das SPS Attribut erhalten, um alle Instanzen von STRUCT als StructuredType verfügbar zu machen.
{attribute 'OPC.UA.DA.StructuredType' := '1'}
TYPE ST_Communication :
STRUCT
a : INT;
b : INT;
c : INT;
END_STRUCT
END_TYPE
Um „StructuredType“ einer bestimmten Instanz zu deaktivieren, kann das folgende Attribut verwendet werden:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '0'}
stCommunication : ST_Communication;
END_VAR
Funktionsbaustein StructuredType
Zusätzlich enthält jeder Funktionsbaustein der TwinCAT 3 SPS auch einen Kind-Knoten, „FunctionBlock“, der den gesamten Funktionsbaustein als „StructuredDataType“ beinhaltet.
Beispiel:
Funktionsbaustein:
FUNCTION_BLOCK FB_FunctionBlock
VAR_INPUT
Input1 : INT;
Input2 : LREAL;
END_VAR
VAR_OUTPUT
Output1 : LREAL;
END_VAR
Instanz eines Funktionsbausteins:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '1'}
fbFunctionBlock : FB_FunctionBlock;
END_VAR
Instanz des Funktionsbausteins im OPC‑UA‑Namensraum:
FunctionBlock-Knoten mit StructuredDataType:
Alternativ kann der Funktionsbaustein auch ein SPS-Attribut erhalten, um alle Instanzen des Funktionsbausteins als „StructuredType“ zur Verfügung zu stellen.
{attribute 'OPC.UA.DA.StructuredType' := '1'}
FUNCTION_BLOCK FB_FunctionBlock
VAR_INPUT
Input1 : INT;
Input2 : LREAL;
END_VAR
VAR_OUTPUT
Output1 : LREAL;
END_VAR
Um StructuredType einer bestimmten Instanz zu deaktivieren, kann das folgende Attribut verwendet werden:
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '0'}
fbFunctionBlock : FB_FunctionBlock;
END_VAR
Hinweis
Maximale Größe der Struktur
Die maximale Größe einer Struktur ist standardmäßig auf 16 kByte festgelegt. Jedes STRUCT tauscht ständig Daten mit dem Basis-ADS-Gerät aus, d.h. mit jedem Lese-/Schreibbefehl eines Structured Type wird eine große ADS-Meldung verschickt. Damit der ADS-Router nicht mit großen Meldungen überflutet wird, ist die maximale Größe beschränkt. Der Nutzer kann diese Vorgabe in der Datei ServerConfig.xml ändern. Dazu muss der Schlüssel <MaxStructureSize> zu OpcServerConfig\UaServerConfig\ hinzugefügt und ein neuer Wert für die maximale Größe einer Struktur in Bytes festgelegt werden. Wenn eine Struktur die Größe <MaxStructureSize> überschreitet, wird sie als FolderType importiert, wo jedes Strukturelement als einzelner Knoten verfügbar ist.


Liste der Attribute und Kommentare

Technische Einführung [image] TwinCAT OPC UA Server [image] C++ [image] Liste der Attribute und Kommentare
Liste der Attribute und Kommentare
Die Konfiguration der Laufzeitvariablen für verschiedene OPC‑UA‑Funktionen (z. B. Data Access oder Historical Access) erfolgt direkt im SPS-Programm oder im TMC Code Editor (bei Verwendung von TwinCAT 3 C++). Der Vorteil ist, dass ein SPS-Entwickler direkt in dem Programm, mit dem er vertraut ist, entscheiden kann, ob und wie eine Variable für OPC UA freizugeben ist. Die Aktivierung erfolgt dann durch Einfügen eines Kommentars und des entsprechenden OPC-UA-Tags vor der Variablen, z. B.:
TwinCAT 3 SPS (TMC):
{attribute 'OPC.UA.DA' := '1'}
bVariable : BOOL;
TwinCAT 2 SPS (TPY):
bVariable : BOOL; (*~ (OPC:1:available)*)
Eine detaillierte Beschreibung zur Verwendung von Attributen und Kommentaren erhalten Sie im Kapitel über die entsprechenden Laufzeitkomponenten:
▪
SPS
▪
C++
▪
I/O
▪
Matlab/Simulink
Die folgende Tabelle zeigt einen Überblick aller definierbaren Tags und ihrer Bedeutung. In den Unterschnitten der entsprechenden Funktion finden Sie eine ausführliche Beschreibung des Funktionsprinzips.
TwinCAT 3 (TMC):
OPC-UA-Funktion | SPS-Tag | C++ TMC Code Editor (Optionale Eigenschaften) | Bedeutung
Data Access (DA) | {attribute 'OPC.UA.DA' := '0'} | Name: OPC.UA.DA Wert: 0 | Sperrt eine Variable für OPC UA, woraufhin diese im UA‑Namensraum nicht mehr sichtbar ist.
Data Access (DA) | {attribute 'OPC.UA.DA' := '1'} | Name: OPC.UA.DA Wert: 1 | Aktiviert eine Variable für OPC UA, woraufhin diese im UA‑Namensraum sichtbar wird. Dieses Tag muss immer gesetzt sein, wenn eine Variable für UA verwendet werden soll.
Data Access (DA) | {attribute 'OPC.UA.DA.Access' := 'x'} | Name: OPC.UA.DA.Access Wert: siehe rechte Spalte | Setzt Lese-/Schreib-Zugriff für eine Variable, je nach Parameter „x“. 0 = Kein 1 = Schreibgeschützt 2 = Nur Schreibzugriff 3 = Lese- und Schreibzugriff (Standardwert, wenn kein Tag verwendet wird)
Data Access (DA) | {attribute 'OPC.UA.DA.StructuredType' := '0'} | Name: OPC.UA.DA.StructuredType Wert: 0 | Deaktiviert StructuredType für ein STRUCT oder einen Funktionsbaustein
Data Access (DA) | {attribute 'OPC.UA.DA.StructuredType' := '1'} | Name: OPC.UA.DA.StructuredType Wert: 1 | Aktiviert StructuredType für ein STRUCT oder einen Funktionsbaustein
Data Access | {attribute 'OPC.UA.DA.Status' := 'quality'} | Name: OPC.UA.DA.Status Wert: quality | Statuscode eines Symbols im UA‑Namensraum manuell festlegen. Nur für Datenstrukturen. Der Wert „quality“ legt fest, welches DINT Unterelement der Datenstruktur den Statuscode festlegt. Siehe entsprechenden Artikel der Dokumentation für weitere Informationen.
Historical Access (HA) | {attribute 'OPC.UA.HA' := '1'} | Name: OPC.UA.HA Wert: 1 | Aktiviert eine Variable für „Historical Access“. Muss mit {attribute 'OPC.UA.DA' := '1'} verwendet werden.
Historical Access (HA) | {attribute 'OPC.UA.HA.Storage' := 'x'} | Name: OPC.UA.HA.Storage Wert: siehe rechte Spalte | Definiert den Speicherort für Historical Access, abhängig von Parameter “x” 1 = Speicher 2 = Datei 3 = SQL Compact Database 4 = SQL Server Database
Historical Access (HA) | {attribute 'OPC.UA.HA.Sampling' := 'x'} | Name: OPC.UA.HA.Sampling Wert: siehe rechte Spalte | Legt die Abtastrate fest, mit der die Variablenwerte zu speichern sind, in Abhängigkeit des Parameters „x“ in [ms]
Historical Access (HA) | {attribute 'OPC.UA.HA.Buffer' := 'x'} | Name: OPC.UA.HA.Buffer Wert: siehe rechte Spalte | Definiert die maximale Anzahl Werte, die im Datenspeicher bleiben, in Abhängigkeit des Parameters „x“.
TwinCAT 2 (TPY):
OPC‑UA‑Funktion | SPS‑Tag | Bedeutung
Data Access (DA) | (*~ (OPC:0:not available) *) | Sperrt eine Variable für OPC UA, woraufhin diese im UA‑Namensraum nicht mehr sichtbar ist.
Data Access (DA) | (*~ (OPC:1:available) *) | Aktiviert eine Variable für OPC UA, woraufhin diese im UA‑Namensraum sichtbar wird. Dieses Tag muss immer gesetzt sein, wenn eine Variable für UA verwendet werden soll.
Data Access (DA) | (*~ (OPC_PROP[0005]:1:Schreibgeschützt) *) | Setzt den Schreibschutz für eine Variable. Muss zusammen mit (*~ (OPC:1: available) *) verwendet werden.
Data Access (DA) | (*~ (OPC_UA_PROP[5100] : x: Alias name) *) | Bestimmt x als Knotennamen im UA‑Namensraum, sogenanntes Alias Mapping.
Historical Access (HA) | (*~ (OPC_UA_PROP[5000]:x:Storage media) *) | Aktiviert eine Variable für „Historical Access“. Muss zusammen mit (*~ (OPC:1: available) *) verwendet werden. x definiert das Speichermedium für die Speicherung der Datenwerte: 1 = Speicher 2 = Datei 3 = SQL Compact Database 4 = SQL Server Database
Historical Access (HA) | (*~ (OPC_UA_PROP[5000][1]:x:SamplingRate) *) | Legt die Abtastrate fest, mit der die Variablenwerte zu speichern sind, in Abhängigkeit des Parameters „x“ in [ms]
Historical Access (HA) | (*~ (OPC_UA_PROP[5000][2]:x:Buffer) *) | Definiert die maximale Anzahl Werte, die im Datenspeicher bleiben, in Abhängigkeit des Parameters „x“.


I/O

Technische Einführung [image] TwinCAT OPC UA Server [image] I/O
I/O
Weiterführende Informationen
•
Zugriff auf IO-Task
•
Historical Access
•
Alarms & Conditions


Zugriff auf IO-Task

Technische Einführung [image] TwinCAT OPC UA Server [image] I/O [image] Zugriff auf IO-Task
Zugriff auf IO-Task
Nachfolgend wird beschrieben, wie IO‑Taskvariablen über die Datenzugriffsfunktionen des OPC UA Servers zugänglich gemacht werden können.
Um IO-Variablen über OPC UA zugänglich zu machen, müssen die beiden Schritte einmalig durchgeführt werden.
▪
Schritt 1: TwinCAT‑I/O‑Task konfigurieren, um das Symbolhandling zu aktivieren.
▪
Schritt 2: I/O-Task dem OPC‑UA‑Namensraum hinzufügen
Allgemeine Informationen
Die Variablen eines Tasks mit Prozessabbild können über OPC UA veröffentlicht werden.
Die Art und Weise, wie die Variablen angezeigt und wie mit ihnen kommuniziert wird, wird anhand von verschiedener Parameter festgelegt. Diese Parameter können Sie bequem mithilfe des OPC‑UA‑Konfigurators festlegen. Alternativ dazu können Sie diese auch direkt in der ServerConfig.xml‑Konfigurationsdatei festlegen. Die folgende Tabelle gibt einen Überblick über alle Parameter, die beim Zugriff auf das I/O‑Task von Bedeutung sind.
Parameter | Beschreibung | Mögliche Werte
ADS Port | Definiert den ADS-Port, unter dem das I/O‑Task zugänglich ist. Der ADS Port kann in den Eigenschaften des I/O‑Tasks ausgelesen werden. | 301 302 …
AutoCfg | Definiert zunächst den Typ der für die Kommunikation verwendeten Ziel-Laufzeit, z. B. SPS, C++, I/O. Anschließend kann eine weitergehende Unterscheidung innerhalb dieser Kategorien stattfinden. Jede AutoCfg-Option steht sowohl als ungefilterte, als auch gefilterte Option zur Verfügung. Gefiltert bedeutet, dass die Nutzer bestimmen können, welche I/O‑Variablen dem OPC UA über Kommentare öffentlich zugänglich gemacht werden. Bei Verwendung einer ungefilterten Option wird jede Task‑Variable an OPC UA veröffentlicht. | 107 I/O TwinCAT 2/3 108 I/O TwinCAT 2/3 gefiltert
AutoCfgSymFile | Bestimmt den Pfad der CurrentConfig.xml‑Datei, die sich normalerweise im Ordner C:\TwinCAT\3.1\Boot\ befindet. | Pfad von CurrentConfig.xml
Disabled | Deaktiviert die I/O Task im UA‑Namensraum, woraufhin der entsprechende Knoten nicht angezeigt wird. Wir empfehlen die Aktivierung dieses Parameters wenn bestimmte Laufzeiten zum Zeitpunkt der Projektplanung noch nicht verfügbar sind, weil z. B. die entsprechenden Geräte noch nicht ans Netzwerk angeschlossen sind. | 0 (deaktiviert - standardmäßig) 1 (aktiviert)
Die folgenden Schritte beschreiben, wie Variablen von einem I/O‑Task in den UA-Namensraum importiert werden können. Es wird vorausgesetzt, dass der OPC UA Server und die Laufzeit sich auf dem gleichen Rechner befinden.
Schritt 1: TwinCAT‑I/O‑Task konfigurieren, um das Symbolhandling zu aktivieren.
Öffnen Sie die I/O‑Task‑Einstellungen und aktivieren Sie die Option Symbole erzeugen. Notieren Sie an dieser Stelle auch den ADS-Port des I/O‑Tasks (im Beispiel ist das 301).
TwinCAT 3:
TwinCAT 2:
Grafik aus Access to IO task (i8692v52.png)
Schritt 2: I/O‑Task dem OPC-UA-Namensraum hinzufügen
Konfigurieren Sie den OPC UA Server so konfigurieren, dass er Zugriff auf das I/O‑Task bietet. Fügen Sie mithilfe des OPC-UA‑Konfigurators ein neues „IO TwinCAT 2/3“‑Gerät hinzu und konfigurieren Sie dessen Einstellungen für AdsNetId, AdsPort und SymbolFile (Pfad zur CurrentConfig.xml‑Datei).
Starten Sie, nachdem Sie die entsprechenden Eigenschaften eingestellt haben, den OPC UA Server neu, damit diese Einstellungen aktiv werden.


Historical Access

Technische Einführung [image] TwinCAT OPC UA Server [image] I/O [image] Historical Access
Historical Access
Weiterführende Informationen
•
Setupversion 4.x.x
•
Anzeige von historischen Daten


Setupversion 4.x.x

Technische Einführung [image] TwinCAT OPC UA Server [image] I/O [image] Historical Access [image] Setupversion 4.x.x
Setupversion 4.x.x
Ab Setupversion 4.x.x wird Historical Access nicht mehr länger über Attribute bzw. Kommentare konfiguriert. Dies hat den Vorteil, dass die Historical-Access-Funktionalität nun auch für Laufzeiten zur Verfügung steht, dies dies bisher nicht unterstützt haben, z. B. Variablen von einem BC9191 Controller. Des Weiteren kann eine Historical‑Access‑Konfiguration nun auch nachträglich, d. h. ohne Anpassung des SPS-Projekts durchgeführt werden.
Die Historical‑Access‑Konfiguration ist nun XML-basiert (TcUaHaConfig.xml) und kann über den OPC UA Server Konfigurator vorgenommen werden (siehe Konfiguration von Historical Access). Diese XML-Datei befindet sich in demselben Verzeichnis wie die TcOpcUaServer.exe. Der Vollständigkeit halber wird der Aufbau der XML-Datei an dieser Stelle jedoch kurz erklärt.
<HistoryConfig>
<HistoryController>
<HistoryAdapter Type="Volatile" Id="0" File="" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="File" Id="1" File="historydb.dat" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="SQL" Id="2" File="" Server="" Database="database123" User="user" Password="pwd"/>
<HistoryAdapter Type="SQLCompact" Id="3" File="historydb.xyz" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="SQLCompact" Id="4" File="historydb2.xyz" Server="" Database="" User="" Password=""/>
</HistoryController>
<HistoryNodes>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_SingleNode.nMyValue"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.nMyValue1"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.nMyValue2"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.fMyValue3"/>
</HistoryNodes>
</HistoryConfig>
In dem Bereich <HistoryController> können alle unterstützten Datenspeicher konfiguriert werden. Aktuell werden die folgenden Speicherorte unterstützt:
▪
Arbeitsspeicher („Volatile“)
▪
Datei („File“)
▪
SQL Compact
▪
SQL Server (wird nicht unter Windows CE unterstützt)
Jeder <HistoryAdapter> (außer „Volatile“) kann hierbei mehrfach verwendet werden, z. B. wenn die historischen Werte für einzelne Variablen in unterschiedlichen Datenspeichern abgelegt werden sollen.
Im Bereich <HistoryNodes> werden die einzelnen Nodes konfiguriert, einem Datenspeicher zugewiesen und mit einer SamplingRate sowie einer maximalen Größe für den zu verwendenden Ringbuffer im Datenspeicher versehen.
Das Attribut HistoryWriteable="true" bewirkt, dass der Datenspeicher für diese Node über einen HistoryUpdate() Aufruf mit Werten befüllt werden kann. Ein solcher Aufruf wird z.B. von unserem TwinCAT OPC UA Client über den UA_HistoryUpdate() Funktionsbaustein zur Verfügung gestellt. Wird eine Node mit diesem Attribut konfiguriert, dann sampled üblicherweise der Server selbst nicht die Werte, sondern bekommt diese von anderen Clients reingereicht. Die SamplingRate ist daher bei einer solchen Konfiguration üblicherweise gleich 0.
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Anzeige von historischen Daten

Technische Einführung [image] TwinCAT OPC UA Server [image] I/O [image] Historical Access [image] Anzeige von historischen Daten
Anzeige von historischen Daten
Anzeige von Historical‑Access‑Werten in einem OPC UA Client
Die folgende Schritt-für-Schritt-Anleitung beschreibt, wie die Software UA-Expert konfiguriert werden kann, um auf historische Daten zuzugreifen.
1.
Starten Sie die UA-Expert-Software und stellen Sie eine Verbindung mit dem OPC UA Server her.
2.
Fügen Sie eine neue „History Trend Ansicht“ hinzu.
3.
Durchsuchen Sie den PLC1-Namensraum und fügen Sie die SPS-Variablen _HistoryDB, _HistoryDBcompact, _HistoryFast und _HistorySlowPersist per Drag-and-drop hinzu.
⇨
Sie können nun den gewünschten Zeitraum, für den die Symbolwerte angezeigt werden sollen, mithilfe der Steuerelemente StartTime und EndTime festlegen, oder falls erforderlich ein CyclicUpdate für diese Variablen starten.


Alarms & Conditions

Technische Einführung [image] TwinCAT OPC UA Server [image] I/O [image] Alarms & Conditions
Alarms & Conditions
In diesem Abschnitt werden die notwendigen Schritte zur Konfiguration von OPC UA Alarms & Conditions (A&C) auf dem TwinCAT OPC UA Server beschrieben. Das Grundkonzept ist unabhängig von der TwinCAT‑Laufzeit. Demzufolge sind die Konfigurationsschritte für SPS, C++, TcCOM-Laufzeit oder nur I/O-Task gleich.
OPC UA Alarms & Conditions (Teil 9 der OPC-UA-Spezifikation) beschreibt ein Modell für die Überwachung von Prozesswerten und das Ausgeben von Alarmen und Ereignissen bei Zustandsänderungen eines Laufzeit-Symbols.
Voraussetzungen
Die folgenden Voraussetzungen gelten für die Verwendung von OPC UA Alarms & Conditions:
▪
Das zu überwachende Laufzeitsymbol muss im Namensraum verfügbar sein.
▪
Der OPC UA Client muss A&C unterstützen. In diesem Abschnitt wird der UA-Expert (von Unified Automation) als Referenz‑UA‑Client verwendet.
Allgemeines
Die folgenden Schritte müssen einmalig ausgeführt werden, um ein Symbol für A&C freizugeben:
▪
Schritt 1: Laufzeitsymbol für Datenzugriff aktivieren (damit das Symbol generell via OPC UA zugänglich wird.)
▪
Schritt 2: A&C für ein Symbol aktivieren
▪
Schritt 3: Eigene Benutzerdaten mit einem Ereignis übermitteln
▪
Schritt 4: Ereignis über die FireEvent-Methode auslösen
▪
Schritt 5: Mehrsprachige Alarmtexte konfigurieren
▪
Schritt 6: A&C bei einem Referenz-OPC-UA-Client anmelden
Diese Schritte werden nachfolgend ausführlicher erläutert. Am Ende des Abschnitts finden Sie Informationen zum Empfang von konfigurierten Alarmen über A&C mit dem UA‑Expert‑Referenz‑Client.
Unterstützte Alarmtypen
Die Implementierung von TwinCAT OPC UA A&C unterstützt derzeit die folgenden Alarmtypen:
▪
LimitAlarmType: Verschiedene Grenzen für ein Symbol definieren. Wird eine Grenze erreicht, gibt der UA-Server einen Alarm aus.
▪
OffNormalAlarmType: Einen Wert definieren, der „normal“ ist. Wenn der aktuelle Wert vom „normalen“ Wert abweicht, gibt der UA-Server einen Alarm aus.
Schritt 1: Laufzeitsymbol für Datenzugriff aktivieren
Als Voraussetzung dafür, dass Variablen für Alarms & Conditions konfiguriert werden können, muss die entsprechende Variable zunächst im OPC UA Server zur Verfügung stehen. Im Falle einer SPS‑Variablen muss diese zunächst entsprechend mit einem Attribut konfiguriert werden, wie im Abschnitt Zugriff auf SPS-Laufzeit beschrieben.
Schritt 2: A&C für ein Symbol aktivieren
Mit dem TwinCAT-OPC-UA-Server-Konfigurator kann ein Laufzeitsymbol einfach für A&C konfiguriert werden. Dieser Konfigurator hat eine einfache grafische Bedienoberfläche, um die dahinter stehende XML-Datei zu bearbeiten. Der Konfigurator steht, je nach Setupversion, in zwei Varianten zur Verfügung: Standalone und integriert in das Visual Studio.
Der folgende Programmausschnitt zeigt ein Beispiel dieser XML-Datei, um das allgemeine Verhalten und den Aufbau der A&C-Implementierung besser zu verstehen.
<TcUaAcConfig>
<ConditionController Name="ConditionController1" >
<Condition Name="Counter" Severity="200">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.nCounter1" />
</Condition>
<Condition Name="Switch" Severity="500">
<OffNormalAlarmType Normal="0" MessageNormal="100" MessageOffNormal="20" />
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.bSwitch" />
</Condition>
<Condition Name="Struct" Severity="300">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.stStruct" />
</Condition>
</ConditionController>
<ConditionController Name="ConditionController2" >
<Condition Name="Counter2" Severity="200">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.nCounter2" />
</Condition>
</ConditionController>
</TcUaAcConfig>
Eine „Bedingung“ definiert das zu überwachende Laufzeitsymbol und die Alarmgrenzen und -texte. Jede „Bedingung“ ist in einem so genannten „ConditionController“ organisiert, dem Objekt, das die OPC UA Clients später abonnieren.
Bei der Erstellung einer Bedingung (Condition) müssen NamespaceName (NS) und NodeID spezifiziert werden, um auf den zu überwachenden UA-Knoten zu verweisen. Der Konfigurator bietet einen einfachen Browsing-Mechanismus, um einen Knoten auszuwählen. In der XML kann durch den Platzhalter „[NodeName]“ in NamespaceName die XML-Datei einfach zwischen zwei verschiedenen Hardwaresystemen hin und her wechseln. HINWEIS! NamespaceName beinhaltet immer den Hostnamen des IPC oder Embedded-PC, auf dem der OPC UA Server läuft. Wird „[NodeName]“ gewählt, wird dieser Tag durch den Hostnamen des aktuellen IPCs oder Embedded-PCs ersetzt, auf dem der UA-Server läuft.
SamplingRate bestimmt, wie oft der UA-Server einen Wert vom Knoten abfragen soll, um festzustellen, ob eine der Alarmgrenzen erreicht wurde.
Die Alarmtexte werden über eine ID identifiziert. Die ID identifiziert eindeutig einen Alarmtext aus der Ressourcendatei (siehe Schritt 5: Mehrsprachige Alarmtexte konfigurieren).
Schritt 3: Eigene Benutzerdaten mit einem Alarm übermitteln
Alarme können Felder mit eigenen Benutzerdaten enthalten, die die mit dem Alarm ausgegebenen Daten ergänzen. Diese Benutzerdatenfelder können in der Laufzeitanwendung erzeugt und ausgefüllt werden, indem ein STRUCT erstellt wird, dessen erstes Element „value“ genannt wird. Bei einem Alarm werden dann alle folgenden Elemente in einem zusätzlichen Benutzerdatenfeld gesendet.
Beispiel SPS-Anwendung:
TYPE ST_CustomStruct :
STRUCT
value : INT;
data : ST_SomeStruct;
END_STRUCT
END_TYPE

TYPE ST_SomeStruct :
STRUCT
Data1 : INT;
Data2 : REAL;
Data3 : LREAL;
END_STRUCT
END_TYPE
Die Instanz von ST_CustomStruct wird dann über den regulären Mechanismus, z. B. in TwinCAT 3, für den Datenzugriff aktiviert: Das STRUCT muss als StructuredDataType aktiviert sein.
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '1'}
stCustomStruct : ST_CustomStruct;
END_VAR
Bei der Anmeldung bei einem ConditionController müssen die OPC UA Clients besondere AlarmConditionTypes, sogenannte „BkUaLimitAlarmType“ und „BkUaOffNormalAlarmType“, abonnieren, damit sie die besonderen Benutzerdatenfelder beim Eingang eines Alarms empfangen können.
Der OPC UA Client empfängt dann die Benutzerdaten in den Feldern „BkUaEventData“ und „BkUaEventValue“ des eingehenden Alarms. Im obigen Beispiel sind das der Wert der SPS-Variablen sowie die Benutzerdaten, die mit der SPS-Struktur „ST_SomeStruct“ dargestellt sind.
Grafik aus Alarms _ Conditions (i1d631q3.png)
Schritt 4: Ereignis über die FireEvent-Methode auslösen
Jeder ConditionController umfasst eine FireEvent-Methode, mit der die OPC UA Clients ein allgemeines Ereignis mit benutzerdefinierten EventFields auslösen können.
Wird diese Methode ausgeführt, dann wird ein Ereignis auf dem TwinCAT OPC UA Server ausgegeben. Andere OPC UA Clients können diese Ereignisse empfangen, wenn sie den entsprechenden ConditionController abonnieren.
Die benutzerdefinierten EventFields werden als „UserEventData“ an das Ereignis angehängt. Diesen Daten können von OPC UA Clients empfangen werden, die beim SimpleEventType „UserEventType“ angemeldet sind.
Schritt 5: Mehrsprachigen Alarmtexten konfigurieren
Die A&C-Implementierung im TwinCAT OPC UA Server unterstützt die Verwendung von mehrsprachigen Alarmtexten. Abhängig von der Sprache, mit der sich der UA-Client mit dem Server verbindet, wird ein entsprechender Alarmtext verwendet. Alarmtexte werden in XML-Dateien konfiguriert, für jede Sprache gibt es eine eigene Datei. Diese Dateien befinden sich im Ordner „res“ (Ressource) des TwinCAT OPC UA Servers. Mit dem Konfigurator können Alarmtexte bequem hinzugefügt oder entfernt werden, ohne dass die XML-Dateien direkt bearbeitet werden müssen. Jeder Alarmtext hat eine eigene ID, die in der Datei nur einmal vorkommt.
Beispiel:
<TcOpcUaSvrRes Lang="en">
<Text ID="0">Text not available</Text>
<Text ID="1">Some alarm text</Text>
<Text ID="2">Value is High range</Text>
<Text ID="3">Value is HighHigh range</Text>
<Text ID="4">Value is OffNormal</Text>
...
</TcOpcUaSvrRes>
Schritt 6: A&C bei einem Referenz-OPC-UA-Client anmelden
Ein OPC UA Client muss sich bei einem ConditionController anmelden, damit er Ereignisse für Bedingungen empfangen kann, die für diesen besonderen ConditionController konfiguriert sind. Der UA‑Expert stellt Funktionen zur Verfügung, um UA-Ereignisse zu abonnieren und zu empfangen. Nachdem UA-Expert gestartet und eine Verbindung zum TwinCAT OPC UA Server hergestellt wurde, fügen Sie Ihrem Arbeitsbereich eine neue Dokumentenansicht, genannt „Event View“, hinzu.
Sie können einen ConditionController dann durch Ziehen des entsprechenden Objekts in EventView abonnieren. Die Ereignisse für diesen ConditionController werden im „Event Window“ angezeigt.
Möglicherweise müssen spezielle Alarm- und/oder Ereignistypen abonniert werden, damit Sie alle Felder eines eingehenden Ereignisses oder Alarms empfangen können.


Matlab/Simulink

Technische Einführung [image] TwinCAT OPC UA Server [image] Matlab/Simulink
Matlab/Simulink
Weiterführende Informationen
•
Zugriff auf Matlab/Simulink-Module
•
Historical Access
•
Alarms & Conditions


Zugriff auf Matlab/Simulink-Module

Technische Einführung [image] TwinCAT OPC UA Server [image] Matlab/Simulink [image] Zugriff auf Matlab/Simulink-Module
Zugriff auf Matlab/Simulink-Module
Der TwinCAT OPC UA Server bietet die Funktionalität zur Nutzung von TwinCAT‑3‑TMI‑Dateien zum Aufbau der Namensräume. TMI-Dateien werden von TcCOM-Modulen generiert und somit zum Beispiel TwinCAT‑3‑C++‑Modulinstanzen und auch Matlab/Simulink‑Modulinstanzen.
TMI-Import für TcCOM-Module
Der Import von TMI-Dateien kann im TwinCAT‑OPC‑UA‑Konfigurator konfiguriert werden. Damit eine TMI-Datei generiert und TwinCAT automatisch die TMI-Datei zum Zielsystem kopieren kann, aktivieren Sie die Option Copy TMI to Target in den Einstellungen des TcCOM-Moduls:
Grafik aus Access to Matlab_Simulink modules (i1sg7jh1.png)
Grafik aus Access to Matlab_Simulink modules (iu98e452.png)
Das Bootverzeichnis des Ziels enthält dann die TMI-Datei für das TcCOM-Modul, welche dann wiederum unter Verwendung des OPC‑UA‑Konfigurators in den OPC‑UA‑Namensraum importiert werden kann:
Grafik aus Access to Matlab_Simulink modules (i5kqgjs3.png)
Der konfigurierte OPC‑UA‑Namensraum enthält dann eine Repräsentation des Matlab/Simulink‑Blockdiagramms:
Grafik aus Access to Matlab_Simulink modules (i7cvs461.png)
Grafik aus Access to Matlab_Simulink modules (iocmtge2.png)
Gefilterter oder ungefilterter Modus
Beachten Sie, dass es derzeit keinen gefilterten Modus für generische TcCOM-Modulinstanzen gibt. Der gefilterte Modus ist lediglich für TwinCAT‑3‑C++‑Modulinstanzen möglich, wenn der TMC Code Editor verwendet wird. Die TwinCAT‑Matlab/Simulink‑Integration bietet einige Filtermöglichkeiten. Diese werden in der Dokumentation TE1400 im Abschnitt Datenaustausch beschrieben.
Wenn eine generische TcCOM‑Modulinstanz (z. B. ein Matlab/Simulink-Modul) importiert werden soll, muss die ungefilterte Option verwendet werden und daher werden alle Symbole der Module im OPC‑UA‑Namensraum veröffentlicht.


Historical Access

Technische Einführung [image] TwinCAT OPC UA Server [image] Matlab/Simulink [image] Historical Access
Historical Access
Weiterführende Informationen
•
Setupversion 4.x.x
•
Anzeige von historischen Daten


Setupversion 4.x.x

Technische Einführung [image] TwinCAT OPC UA Server [image] Matlab/Simulink [image] Historical Access [image] Setupversion 4.x.x
Setupversion 4.x.x
Ab Setupversion 4.x.x wird Historical Access nicht mehr länger über Attribute bzw. Kommentare konfiguriert. Dies hat den Vorteil, dass die Historical-Access-Funktionalität nun auch für Laufzeiten zur Verfügung steht, dies dies bisher nicht unterstützt haben, z. B. Variablen von einem BC9191 Controller. Des Weiteren kann eine Historical‑Access‑Konfiguration nun auch nachträglich, d. h. ohne Anpassung des SPS-Projekts durchgeführt werden.
Die Historical‑Access‑Konfiguration ist nun XML-basiert (TcUaHaConfig.xml) und kann über den OPC UA Server Konfigurator vorgenommen werden (siehe Konfiguration von Historical Access). Diese XML-Datei befindet sich in demselben Verzeichnis wie die TcOpcUaServer.exe. Der Vollständigkeit halber wird der Aufbau der XML-Datei an dieser Stelle jedoch kurz erklärt.
<HistoryConfig>
<HistoryController>
<HistoryAdapter Type="Volatile" Id="0" File="" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="File" Id="1" File="historydb.dat" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="SQL" Id="2" File="" Server="" Database="database123" User="user" Password="pwd"/>
<HistoryAdapter Type="SQLCompact" Id="3" File="historydb.xyz" Server="" Database="" User="" Password=""/>
<HistoryAdapter Type="SQLCompact" Id="4" File="historydb2.xyz" Server="" Database="" User="" Password=""/>
</HistoryController>
<HistoryNodes>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_SingleNode.nMyValue"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.nMyValue1"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.nMyValue2"/>
<HistoryNode HistoryWriteable="true" SamplingRate="0" MaxSamples="100000" AdapterId="0" NS="urn:BeckhoffAutomation:Ua:PLC1" NodeId="s=PRG_HA_MultipleNodes.fMyValue3"/>
</HistoryNodes>
</HistoryConfig>
In dem Bereich <HistoryController> können alle unterstützten Datenspeicher konfiguriert werden. Aktuell werden die folgenden Speicherorte unterstützt:
▪
Arbeitsspeicher („Volatile“)
▪
Datei („File“)
▪
SQL Compact
▪
SQL Server (wird nicht unter Windows CE unterstützt)
Jeder <HistoryAdapter> (außer „Volatile“) kann hierbei mehrfach verwendet werden, z. B. wenn die historischen Werte für einzelne Variablen in unterschiedlichen Datenspeichern abgelegt werden sollen.
Im Bereich <HistoryNodes> werden die einzelnen Nodes konfiguriert, einem Datenspeicher zugewiesen und mit einer SamplingRate sowie einer maximalen Größe für den zu verwendenden Ringbuffer im Datenspeicher versehen.
Das Attribut HistoryWriteable="true" bewirkt, dass der Datenspeicher für diese Node über einen HistoryUpdate() Aufruf mit Werten befüllt werden kann. Ein solcher Aufruf wird z.B. von unserem TwinCAT OPC UA Client über den UA_HistoryUpdate() Funktionsbaustein zur Verfügung gestellt. Wird eine Node mit diesem Attribut konfiguriert, dann sampled üblicherweise der Server selbst nicht die Werte, sondern bekommt diese von anderen Clients reingereicht. Die SamplingRate ist daher bei einer solchen Konfiguration üblicherweise gleich 0.
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Anzeige von historischen Daten

Technische Einführung [image] TwinCAT OPC UA Server [image] Matlab/Simulink [image] Historical Access [image] Anzeige von historischen Daten
Anzeige von historischen Daten
Anzeige von Historical‑Access‑Werten in einem OPC UA Client
Die folgende Schritt-für-Schritt-Anleitung beschreibt, wie die Software UA-Expert konfiguriert werden kann, um auf historische Daten zuzugreifen.
1.
Starten Sie die UA-Expert-Software und stellen Sie eine Verbindung mit dem OPC UA Server her.
2.
Fügen Sie eine neue „History Trend Ansicht“ hinzu.
3.
Durchsuchen Sie den PLC1-Namensraum und fügen Sie die SPS-Variablen _HistoryDB, _HistoryDBcompact, _HistoryFast und _HistorySlowPersist per Drag-and-drop hinzu.
⇨
Sie können nun den gewünschten Zeitraum, für den die Symbolwerte angezeigt werden sollen, mithilfe der Steuerelemente StartTime und EndTime festlegen, oder falls erforderlich ein CyclicUpdate für diese Variablen starten.


Alarms & Conditions

Technische Einführung [image] TwinCAT OPC UA Server [image] Matlab/Simulink [image] Alarms & Conditions
Alarms & Conditions
In diesem Abschnitt werden die notwendigen Schritte zur Konfiguration von OPC UA Alarms & Conditions (A&C) auf dem TwinCAT OPC UA Server beschrieben. Das Grundkonzept ist unabhängig von der TwinCAT‑Laufzeit. Demzufolge sind die Konfigurationsschritte für SPS, C++, TcCOM-Laufzeit oder nur I/O-Task gleich.
OPC UA Alarms & Conditions (Teil 9 der OPC-UA-Spezifikation) beschreibt ein Modell für die Überwachung von Prozesswerten und das Ausgeben von Alarmen und Ereignissen bei Zustandsänderungen eines Laufzeit-Symbols.
Voraussetzungen
Die folgenden Voraussetzungen gelten für die Verwendung von OPC UA Alarms & Conditions:
▪
Das zu überwachende Laufzeitsymbol muss im Namensraum verfügbar sein.
▪
Der OPC UA Client muss A&C unterstützen. In diesem Abschnitt wird der UA-Expert (von Unified Automation) als Referenz‑UA‑Client verwendet.
Allgemeines
Die folgenden Schritte müssen einmalig ausgeführt werden, um ein Symbol für A&C freizugeben:
▪
Schritt 1: Laufzeitsymbol für Datenzugriff aktivieren (damit das Symbol generell via OPC UA zugänglich wird.)
▪
Schritt 2: A&C für ein Symbol aktivieren
▪
Schritt 3: Eigene Benutzerdaten mit einem Ereignis übermitteln
▪
Schritt 4: Ereignis über die FireEvent-Methode auslösen
▪
Schritt 5: Mehrsprachige Alarmtexte konfigurieren
▪
Schritt 6: A&C bei einem Referenz-OPC-UA-Client anmelden
Diese Schritte werden nachfolgend ausführlicher erläutert. Am Ende des Abschnitts finden Sie Informationen zum Empfang von konfigurierten Alarmen über A&C mit dem UA‑Expert‑Referenz‑Client.
Unterstützte Alarmtypen
Die Implementierung von TwinCAT OPC UA A&C unterstützt derzeit die folgenden Alarmtypen:
▪
LimitAlarmType: Verschiedene Grenzen für ein Symbol definieren. Wird eine Grenze erreicht, gibt der UA-Server einen Alarm aus.
▪
OffNormalAlarmType: Einen Wert definieren, der „normal“ ist. Wenn der aktuelle Wert vom „normalen“ Wert abweicht, gibt der UA-Server einen Alarm aus.
Schritt 1: Laufzeitsymbol für Datenzugriff aktivieren
Als Voraussetzung dafür, dass Variablen für Alarms & Conditions konfiguriert werden können, muss die entsprechende Variable zunächst im OPC UA Server zur Verfügung stehen. Im Falle einer SPS‑Variablen muss diese zunächst entsprechend mit einem Attribut konfiguriert werden, wie im Abschnitt Zugriff auf SPS-Laufzeit beschrieben.
Schritt 2: A&C für ein Symbol aktivieren
Mit dem TwinCAT-OPC-UA-Server-Konfigurator kann ein Laufzeitsymbol einfach für A&C konfiguriert werden. Dieser Konfigurator hat eine einfache grafische Bedienoberfläche, um die dahinter stehende XML-Datei zu bearbeiten. Der Konfigurator steht, je nach Setupversion, in zwei Varianten zur Verfügung: Standalone und integriert in das Visual Studio.
Der folgende Programmausschnitt zeigt ein Beispiel dieser XML-Datei, um das allgemeine Verhalten und den Aufbau der A&C-Implementierung besser zu verstehen.
<TcUaAcConfig>
<ConditionController Name="ConditionController1" >
<Condition Name="Counter" Severity="200">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.nCounter1" />
</Condition>
<Condition Name="Switch" Severity="500">
<OffNormalAlarmType Normal="0" MessageNormal="100" MessageOffNormal="20" />
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.bSwitch" />
</Condition>
<Condition Name="Struct" Severity="300">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.stStruct" />
</Condition>
</ConditionController>
<ConditionController Name="ConditionController2" >
<Condition Name="Counter2" Severity="200">
<LimitAlarmType LowLowLimit="-10" LowLimit="0" HighLimit="10" HighHighLimit="20" MessageNormal="100" MessageLowLow="10" MessageLow="11" MessageHigh="12" MessageHighHigh="13"/>
<ItemToMonitor SamplingRate="100" NS="urn:[NodeName]:BeckhoffAutomation:Ua:PLC1" NodeId="s=MAIN.nCounter2" />
</Condition>
</ConditionController>
</TcUaAcConfig>
Eine „Bedingung“ definiert das zu überwachende Laufzeitsymbol und die Alarmgrenzen und -texte. Jede „Bedingung“ ist in einem so genannten „ConditionController“ organisiert, dem Objekt, das die OPC UA Clients später abonnieren.
Bei der Erstellung einer Bedingung (Condition) müssen NamespaceName (NS) und NodeID spezifiziert werden, um auf den zu überwachenden UA-Knoten zu verweisen. Der Konfigurator bietet einen einfachen Browsing-Mechanismus, um einen Knoten auszuwählen. In der XML kann durch den Platzhalter „[NodeName]“ in NamespaceName die XML-Datei einfach zwischen zwei verschiedenen Hardwaresystemen hin und her wechseln. HINWEIS! NamespaceName beinhaltet immer den Hostnamen des IPC oder Embedded-PC, auf dem der OPC UA Server läuft. Wird „[NodeName]“ gewählt, wird dieser Tag durch den Hostnamen des aktuellen IPCs oder Embedded-PCs ersetzt, auf dem der UA-Server läuft.
SamplingRate bestimmt, wie oft der UA-Server einen Wert vom Knoten abfragen soll, um festzustellen, ob eine der Alarmgrenzen erreicht wurde.
Die Alarmtexte werden über eine ID identifiziert. Die ID identifiziert eindeutig einen Alarmtext aus der Ressourcendatei (siehe Schritt 5: Mehrsprachige Alarmtexte konfigurieren).
Schritt 3: Eigene Benutzerdaten mit einem Alarm übermitteln
Alarme können Felder mit eigenen Benutzerdaten enthalten, die die mit dem Alarm ausgegebenen Daten ergänzen. Diese Benutzerdatenfelder können in der Laufzeitanwendung erzeugt und ausgefüllt werden, indem ein STRUCT erstellt wird, dessen erstes Element „value“ genannt wird. Bei einem Alarm werden dann alle folgenden Elemente in einem zusätzlichen Benutzerdatenfeld gesendet.
Beispiel SPS-Anwendung:
TYPE ST_CustomStruct :
STRUCT
value : INT;
data : ST_SomeStruct;
END_STRUCT
END_TYPE

TYPE ST_SomeStruct :
STRUCT
Data1 : INT;
Data2 : REAL;
Data3 : LREAL;
END_STRUCT
END_TYPE
Die Instanz von ST_CustomStruct wird dann über den regulären Mechanismus, z. B. in TwinCAT 3, für den Datenzugriff aktiviert: Das STRUCT muss als StructuredDataType aktiviert sein.
PROGRAM MAIN
VAR
{attribute 'OPC.UA.DA' := '1'}
{attribute 'OPC.UA.DA.StructuredType' := '1'}
stCustomStruct : ST_CustomStruct;
END_VAR
Bei der Anmeldung bei einem ConditionController müssen die OPC UA Clients besondere AlarmConditionTypes, sogenannte „BkUaLimitAlarmType“ und „BkUaOffNormalAlarmType“, abonnieren, damit sie die besonderen Benutzerdatenfelder beim Eingang eines Alarms empfangen können.
Der OPC UA Client empfängt dann die Benutzerdaten in den Feldern „BkUaEventData“ und „BkUaEventValue“ des eingehenden Alarms. Im obigen Beispiel sind das der Wert der SPS-Variablen sowie die Benutzerdaten, die mit der SPS-Struktur „ST_SomeStruct“ dargestellt sind.
Grafik aus Alarms _ Conditions (i1d631q3.png)
Schritt 4: Ereignis über die FireEvent-Methode auslösen
Jeder ConditionController umfasst eine FireEvent-Methode, mit der die OPC UA Clients ein allgemeines Ereignis mit benutzerdefinierten EventFields auslösen können.
Wird diese Methode ausgeführt, dann wird ein Ereignis auf dem TwinCAT OPC UA Server ausgegeben. Andere OPC UA Clients können diese Ereignisse empfangen, wenn sie den entsprechenden ConditionController abonnieren.
Die benutzerdefinierten EventFields werden als „UserEventData“ an das Ereignis angehängt. Diesen Daten können von OPC UA Clients empfangen werden, die beim SimpleEventType „UserEventType“ angemeldet sind.
Schritt 5: Mehrsprachigen Alarmtexten konfigurieren
Die A&C-Implementierung im TwinCAT OPC UA Server unterstützt die Verwendung von mehrsprachigen Alarmtexten. Abhängig von der Sprache, mit der sich der UA-Client mit dem Server verbindet, wird ein entsprechender Alarmtext verwendet. Alarmtexte werden in XML-Dateien konfiguriert, für jede Sprache gibt es eine eigene Datei. Diese Dateien befinden sich im Ordner „res“ (Ressource) des TwinCAT OPC UA Servers. Mit dem Konfigurator können Alarmtexte bequem hinzugefügt oder entfernt werden, ohne dass die XML-Dateien direkt bearbeitet werden müssen. Jeder Alarmtext hat eine eigene ID, die in der Datei nur einmal vorkommt.
Beispiel:
<TcOpcUaSvrRes Lang="en">
<Text ID="0">Text not available</Text>
<Text ID="1">Some alarm text</Text>
<Text ID="2">Value is High range</Text>
<Text ID="3">Value is HighHigh range</Text>
<Text ID="4">Value is OffNormal</Text>
...
</TcOpcUaSvrRes>
Schritt 6: A&C bei einem Referenz-OPC-UA-Client anmelden
Ein OPC UA Client muss sich bei einem ConditionController anmelden, damit er Ereignisse für Bedingungen empfangen kann, die für diesen besonderen ConditionController konfiguriert sind. Der UA‑Expert stellt Funktionen zur Verfügung, um UA-Ereignisse zu abonnieren und zu empfangen. Nachdem UA-Expert gestartet und eine Verbindung zum TwinCAT OPC UA Server hergestellt wurde, fügen Sie Ihrem Arbeitsbereich eine neue Dokumentenansicht, genannt „Event View“, hinzu.
Sie können einen ConditionController dann durch Ziehen des entsprechenden Objekts in EventView abonnieren. Die Ereignisse für diesen ConditionController werden im „Event Window“ angezeigt.
Möglicherweise müssen spezielle Alarm- und/oder Ereignistypen abonniert werden, damit Sie alle Felder eines eingehenden Ereignisses oder Alarms empfangen können.


Dateiübertragung

Technische Einführung [image] TwinCAT OPC UA Server [image] Dateiübertragung
Dateiübertragung
Weiterführende Informationen
•
Zugriff auf Dateien und Ordner über OPC UA


Zugriff auf Dateien und Ordner über OPC UA

Technische Einführung [image] TwinCAT OPC UA Server [image] Dateiübertragung [image] Zugriff auf Dateien und Ordner über OPC UA
Zugriff auf Dateien und Ordner über OPC UA
Ab OPC‑UA‑Spezifikation Version 1.02 enthält OPC UA einen spezialisierten ObjectType zur Dateiübertragung, der in Anlage C der Spezifikation beschrieben ist. Dieser spezielle ObjectType namens „FileType“ beschreibt das Informationsmodell für die Datenübertragung. Dateien können in OPC UA mit ByteStrings als einfache Variablen modelliert werden. FileType ist eine Datei mit Methoden zum Zugriff auf die Datei. In der OPC‑UA‑Spezifikation erhalten Sie weitere Informationen zu FileType sowie Aufbau und Handhabung der zugrundeliegenden Methoden und Eigenschaften zum Zugriff auf eine Datei im OPC‑UA‑Namensraum.
Beckhoff hat einen generischen Weg implementiert, um Dateien und Ordner von einer lokalen Festplatte in den OPC‑UA‑Namensraum zu laden. Jede Datei wird durch einen FileType repräsentiert und ermöglicht Lese- und Schreibvorgänge für diese Datei. Zusätzlich enthält jeder Ordner eine Methode CreateFile, um neue Dateien auf der Festplatte zu erstellen und einen eigenen FolderPath, um den tatsächlichen Pfad zum Ordner auf dem OPC UA Server festzulegen.
Grafik aus Access files and folders via OPC-UA (i0vu4ul.png)
Hinweis
FileTransfer im Device Manager OPC UA Server
Diese Funktion hat nur der OPC UA Server des Beckhoff Device Managers (IPC Diagnose). Der TwinCAT OPC UA Server stellt ebenfalls einige Teile dieser Dateiübertragung bereit. Die allgemeine Funktion, die eine Offenlegung aller Dateien und Ordner ermöglicht, steht aber nur im OPC UA Server zur Verfügung, der zum Gerätemanager gehört, der automatisch auf jedem Beckhoff Industrie-PC oder Embedded-PC verfügbar ist. In der Gerätemanagerdokumentation erhalten Sie weitere Informationen.
Konfiguration
FileType-Objekte werden in einem separaten Namensraum mit der Bezeichnung „FileTransfer” erstellt. Zur Konfiguration dieses Namensraums und zur Auswahl der über OPC UA verfügbaren Dateien und Ordner dient eine XML-Datei (files.xml), die im selben Verzeichnis wie die ausführbare Datei des OPC UA Servers sein muss. Damit die Konfiguration aktiviert wird, ist ein Neustart des Systems erforderlich. Die XML-Datei enthält Informationen über den Ordnerpfad und eine Suchmaske, die definiert, welche Dateien im OPC‑UA‑Namensraum veröffentlicht werden:
<Files>
<FolderObject DisplayName="TwinCAT">
<FolderObject DisplayName="3.1">
<FolderObject DisplayName="Boot" Path="c:/TwinCAT/3.1/Boot" Search="*.*" >
<FolderObject DisplayName="Plc" Path="c:/TwinCAT/3.1/Boot/Plc" Search="*.*" ></FolderObject>
<FolderObject DisplayName="Tmi" Path="c:/TwinCAT/3.1/Boot/Tmi" Search="*.*" ></FolderObject>
</FolderObject>
</FolderObject>
</FolderObject>
</Files>
Beispiel: Lesen einer Datei mit UA-Expert
Der allgemeine Umgang mit Dateien ist in Anhang C der OPC-UA-Spezifikation beschrieben. Das Lesen einer Datei via UA kann in folgende Schritte unterteilt werden:
▪
Aufruf der Open-Methode einer Datei. Diese Methode gibt ein Dateihandle zurück, das für den späteren Zugriff gespeichert werden muss. Der Modus legt fest, ob die Datei gelesen oder in sie geschrieben wird. (siehe Dateimodi)
▪
Bestimmen der Größe der Datei mit der Eigenschaft „Size“. So kann die ganze Datei bei Aufruf der Read-Methode gelesen werden.
▪
Aufruf der Read-Methode. Dateihandle und Dateigröße als Eingaben einfügen. Zielordner wählen, in den der Dateiinhalt NACH dem Aufruf der Methode zu speichern ist.
▪
Aufruf der Close-Methode zur Freigabe des Dateihandles.
Dateimodi
Die folgende Tabelle zeigt alle verfügbaren Dateimodi.
Feld | Bit | Beschreibung
Lesen | 1 | Die Datei wird zum Lesen geöffnet. Wenn dieses Bit nicht gesetzt ist, kann Read nicht ausgeführt werden.
Schreiben | 4 | Die Datei wird zum Schreiben geöffnet. Wenn dieses Bit nicht gesetzt ist, kann Write nicht ausgeführt werden.
EraseExisting | 6 | Der vorhandene Dateiinhalt wird gelöscht und es wird eine leere Datei zur Verfügung gestellt.
Append | 10 | Die Datei wird geöffnet und ans Ende positioniert, sonst auf den Anfang. Diese Position kann mit SetPosition geändert werden.


Sicherheit

Technische Einführung [image] TwinCAT OPC UA Server [image] Sicherheit
Sicherheit
Weiterführende Informationen
•
Übersicht
•
Authentifizierung
•
Zertifikatsaustausch
•
Zugriffsrechte


Übersicht

Technische Einführung [image] TwinCAT OPC UA Server [image] Sicherheit [image] Übersicht
Übersicht
Sicherheit ist eine zentrale Anforderung bei der Entwicklung von OPC UA. Sie wird in verschiedenen Bereichen adressiert:
▪
Verschlüsselung
▪
Integrität
▪
Authentifizierung
Die Vertraulichkeit der ausgetauschten Information wird durch die Verschlüsselung der ausgetauschten Nachrichten sichergestellt. Dabei werden moderne Kryptographie-Algorithmen verwendet. Um auch den zukünftigen Sicherheitsanforderungen gewachsen zu sein, können im Nachhinein noch stärkere und modernere Algorithmen einer Anwendung hinzugefügt werden, ohne das Protokoll zu verändern.
Entsprechend der Anforderungen der jeweiligen Anwendung können verschiedene Sicherheitsstufen gewählt werden. In einigen Bereichen ist es ausreichend die Nachrichten zu signieren, um Änderungen durch Dritte auszuschließen, in anderen Fällen dürfen Daten auch nicht von Dritten gelesen werden und ein zusätzliches Verschlüsseln der Nachrichten ist erforderlich.
TF6100 OPC UA bietet die folgenden Security-Level (Security-Endpunkte) an, mit denen Clients sich verbinden können:
▪
None: Keine Sicherheit
▪
Sign: Signiert Nachrichten
▪
Sign&Encrypt: Signiert und verschlüsselt Nachrichten
Das Signieren der Nachrichten verhindert das Ändern des Inhalts einer Nachricht durch einen Dritten. So wird verhindert, dass beispielsweise eine Schreibanweisung zum Öffnen eines Schalters durch einen Dritten verfälscht wird und der Schalter stattdessen geschlossen wird.
OPC‑UA‑Anwendungen identifizieren sich über so genannte Software- und Applikationsinstanz-Zertifikate. Mithilfe von Software-Zertifikaten ist es möglich, bestimmten Client Anwendungen einen erweiterten Zugriff auf Informationen eines OPC UA Servers zu geben, beispielsweise für das Engineering eines OPC UA Servers. Durch Applikationsinstanz-Zertifikate kann sichergestellt werden, dass ein OPC UA Server nur mit vorkonfigurierten Clients kommuniziert. Ein Client kann durch das Applikationsinstanz-Zertifikat des Servers sicherstellen, dass er mit dem richtigen Server spricht (ähnlich der Zertifikate eines Web-Browsers). Die Berücksichtigung dieser Zertifikate ist optional, d. h. ein OPC UA Server kann auch jedem Client den gleichen Zugriff abhängig der Benutzerrechte geben.
Der TwinCAT OPC UA Client und TwinCAT OPC UA Server erzeugen ein selbst-signiertes Zertifikat während des ersten Startvorgangs. Dieses Zertifikat besteht aus einem privaten und einem öffentlichen Schlüssel. Der private Schlüssel wird in dem Verzeichnis \PKI\CA\private und der entsprechende öffentliche Schlüssel unter \PKI\CA\certs abgelegt. Wenn ein beliebiger OPC UA Client eine gesicherte Verbindung über einen der Security-Endpunkte (Sign, Sign&Encrypt) mit dem Server herstellen will, muss der Client den öffentlichen Schlüssel des OPC UA Servers kennen. Umgekehrt muss der OPC UA Server den öffentlichen Schlüssel des Clients kennen. Dieser sogenannte Schlüsselaustausch wird in den folgenden Artikeln beschrieben:
▪
Authentifizierung
▪
Zertifikatsaustausch
▪
Zugriffsrechte


Authentifizierung

Technische Einführung [image] TwinCAT OPC UA Server [image] Sicherheit [image] Authentifizierung
Authentifizierung
Zusätzlich zum Zertifikataustausch bietet der TwinCAT OPC UA Server die Möglichkeit, eine Authentifizierung über Benutzername/Passwort durchzuführen. Ein OPC UA Client muss dann eine gültige Benutzername/Passwort-Kombination verwenden, damit die Herstellung einer Verbindung zum Server erfolgreich ist.
Der TwinCAT OPC UA Server verwendet Mechanismen des Betriebssystems für die Validierung der Benutzernamen und Passwörter. Wenn der Computer, auf dem der TwinCAT OPC UA Server läuft, Mitglied einer Windows-Domäne ist (z. B. Active Directory), dann wird eine Anfrage an den entsprechenden Domänencontroller durchgeführt. Wenn der betreffende Computer ein Einzelgerät ist, dann wird die lokale Benutzerdatenbank des Betriebssystems überprüft.
Die Konfiguration des TwinCAT OPC UA Servers ermöglicht zwei Einstellungen:
▪
Aktivierung/Deaktivierung anonymer Zugriffe (ohne Benutzerauthentifizierung)
▪
Aktivierung/Deaktivierung der Benutzernamen-/Passwort-Validierung
Beide Einstellungen können im TwinCAT‑OPC‑UA‑Server‑Konfigurator vorgenommen werden.


Zertifikatsaustausch

Technische Einführung [image] TwinCAT OPC UA Server [image] Sicherheit [image] Zertifikatsaustausch
Zertifikatsaustausch
Die Kommunikation zwischen einem OPC UA Client und einem OPC UA Server kann optional durch Kommunikation mit einem gesicherten Endpunkt abgesichert werden. Standardmäßig generieren sowohl der TwinCAT OPC UA Server als auch der TwinCAT OPC UA Client beim ersten Start ein maschinenspezifisches, selbstsigniertes Zertifikat zur Authentifizierung.
Wenn Sie in Ihrer Umgebung eine solche verschlüsselte Kommunikationsverbindung verwenden möchten, müssen Sie ein Vertrauensverhältnis zwischen OPC UA Server und OPC UA Client herstellen.
Grafik aus Certificate exchange (i1oenvg2.png)
Vertrauenseinstellungen auf dem Server
Möchten Sie einen oder mehrere OPC UA Clients über Zertifikate am OPC UA Server authentifizieren, so muss der OPC UA Server den öffentlichen Schlüsseln der Clients vertrauen. Dies kann zum Beispiel über das Dateisystem erfolgen. Der Server verwaltet die Vertrauenseinstellungen für Zertifikate über das Dateisystem.
▪
Vertrauenswürdige Zertifikate: %InstallDir%\Server\PKI\CA\trusted\certs
▪
Abgewiesene Zertifikate: %InstallDir%\Server\PKI\CA\rejected\certs
Durch Verschieben von Client-Zertifikaten zwischen diesen Verzeichnissen können die Vertrauenseinstellungen entsprechend angepasst werden.
Auslesen des Client-Zertifikats
Die folgende Anleitung beschreibt einen einfachen Weg, wie man an das Client-Zertifikat gelangt. Hierbei bauen Sie, ohne vorher das Clientzertifikat auf den UA-Server kopiert zu haben, eine Verbindung zum UA-Server unter Verwendung eines sicheren Endpunkts auf (z. B. Basic128Rsa15/Sign&Encrypt). Diese Verbindung wird vom UA-Server initial natürlich abgewiesen, da dieser dem UA-Client zum derzeitigen Zeitpunkt noch nicht vertraut. Der TwinCAT OPC UA Client würde in diesem Fall z. B. den Fehler 0xE4DD0102 zurückliefern. Nach Abweisen der Verbindungsaufforderung speichert der UA-Server jedoch eine Kopie des Client-Zertifikats im oben genannten „Rejected“-Verzeichnis ab. Der Name des Zertifikats entspricht hierbei dem „Thumbprint“ des Zertifikats und lässt sich somit eindeutig dem Client-Zertifikat zuordnen. Diese Datei können Sie nun direkt in das oben genannte „Trusted“-Verzeichnis verschieben, damit der UA-Server bei allen weiteren Verbindungsanforderungen dem UA-Client vertraut und die Verbindung akzeptiert.
Bekanntmachen des OPC UA Servers beim OPC UA Client
Abhängig vom verwendeten OPC UA Client müssen eventuell unterschiedliche Schritte vorgenommen werden, damit der OPC UA Client dem OPC UA Server vertraut. Typischerweise erfolgt bei Client‑Applikationen mit grafischer Benutzeroberfläche ein Warnhinweis bei der ersten Verbindung mit dem Server, wobei das Server-Zertifikat dann als vertrauenswürdig eingestuft werden kann.
Die folgende Anweisung ist daher nur für den TwinCAT OPC UA Client gültig.
Der öffentliche Schlüssel des OPC UA Servers befindet sich als DER-Datei in dem folgenden Verzeichnis: %InstallDir%\Server\PKI\CA\own\certs
Diese Datei muss beim TwinCAT OPC UA Client in das entsprechende „Trusted“-Verzeichnis kopiert werden: %InstallDir%\Client\PKI\CA\certs


Zugriffsrechte

Technische Einführung [image] TwinCAT OPC UA Server [image] Sicherheit [image] Zugriffsrechte
Zugriffsrechte
Der TwinCAT OPC UA Server ermöglicht die Konfiguration von Berechtigungen auf Namespace- und Node-Ebene. Hierdurch kann sowohl der Zugriff auf ADS-Geräte (z. B. auf verschiedene SPS‑Laufzeiten) als auch Variablen feingranular eingestellt werden. Diese Sicherheitseinstellungen sind für alle ADS-Geräte verfügbar, welche im Server-Namespace dargestellt werden können.
Graphic from Access Level (i6k0pr22.png)
Konfiguration
Die Konfiguration der Berechtigungen erfolgt auf Basis einer XML-basierten Konfigurationsdatei (TcUaSecurityConfig.xml), welche in demselben Verzeichnis wie der Server liegt. Momentan muss diese Datei noch händisch konfiguriert werden bis entsprechende Mechanismen im TwinCAT‑OPC‑UA‑Server‑Konfigurator zur Verfügung stehen. Die Konfigurationsdatei besteht aus den drei Bereichen Users, Groups und AccessInfos, welche im Folgenden näher erläutert werden sollen.
Der folgende Ausschnitt zeigt diese Datei im Auslieferungszustand.
<TcUaSecurityConfig>
<Groups></Groups>
<Users>
<User Name="Anonymous" Auth="None" IsRoot="true"></User>
</Users>
<AccessInfos></AccessInfos>
</TcUaSecurityConfig>
Benutzer
Im Bereich <Users> können Benutzeraccounts konfiguriert werden, welche vom OPC UA Server als Login akzeptiert werden sollen. Hierbei gibt es drei verschiedene Authentifizierungsmethoden:
▪
OS: Es werden die Mechanismen vom Betriebssystem verwendet, um Benutzername und Passwort zu validieren. Der Benutzeraccount obliegt vollständig der Kontrolle des Betriebssystems und/oder der Domäne. Dies ist die empfohlene Authentifizierungsmethode.
▪
Server: Benutzername und Passwort sind nur dem TwinCAT OPC UA Server bekannt. Beide Informationen werden hierbei im Klartext in der XML-Datei hinterlegt. (nicht empfohlen)
▪
None: Es wird nur der Benutzername vom Server ausgewertet, das Passwort wird ignoriert.
Benutzer können mit einem <DefaultAccess>‑Tag konfiguriert werden, welches den Standardzugriff des Benutzers auf einen bestimmten Namespace angibt.
Beispiel:
<TcUaSecurityConfig>
<Groups></Groups>
<Users>
<User Name="MaxM" Auth="OS">
<DefaultAccess Namespace="*" Access="0x000003FF"/>
</User>
</Users>
<AccessInfos></AccessInfos>
</TcUaSecurityConfig>
In obigem Beispiel erhält der Betriebssystem-Benutzer MaxM Vollzugriff (0x3FF) auf alle Namespaces auf dem Server. Der Namespace wird hierbei über dessen Namespace-Name (z. B. urn:BeckhoffAutomation:Ua:PLC1) referenziert.
Das Zugriffslevel setzt sich auf Basis einer Bitmaske wie folgt zusammen:
enum PermissionType
{
UA_ATTRREADABLE = 0x0001, // read all non value attributes
UA_READABLE = 0x0002, // read value attribute
UA_WRITABLE = 0x0004, // write value attribute
UA_BROWSEABLE = 0x0008, // browse node
UA_HISTORYREADABLE = 0x0010, // read history
UA_HISTORYINSERT = 0x0020, // insert into history
UA_HISTORYMODIFY = 0x0040, // modify existing history
UA_HISTORYDELETE = 0x0080, // delete from history
UA_EVENTREADABLE = 0x0100, // receive events
UA_EXECUTABLE = UA_WRITABLE, // execute method call
UA_ATTRWRITABLE = 0x0200, // write non-value attributes
UA_PERMISSION_ALL = 0x03FF // full access
}
Wenn der Zugriff z.B. UA_AttrReadable, UA_Readable, UA_Writeable sein soll, dann würde der AccessLevel 0x0007 sein.
Benutzer können Mitglied einer oder mehrerer Gruppen sein. Dies kann über das MemberOf‑Attribut spezifiziert werden. Bei Mitgliedschaft in mehreren Gruppen werden die Gruppen durch ein Semikolon voneinander getrennt.
Beispiel:
<TcUaSecurityConfig>
<Groups></Groups>
<Users>
<User Name="MaxM" Auth="OS" MemberOf="Administrators;Users">
<DefaultAccess Namespace="*" Access="0x000003FF"/>
</User>
</Users>
<AccessInfos></AccessInfos>
</TcUaSecurityConfig>
Gruppen
Um eine einfachere Konfiguration mit mehreren Benutzeraccounts zu ermöglichen, können die Benutzer in Gruppenzusammengefasst werden.
<TcUaSecurityConfig>
<Groups>
<Group Name="Administrators" MemberOf="Users">
<DefaultAccess Namespace="*" Access="0x000003FF"/>
</Group>
<Group Name="Users">
<DefaultAccess Namespace="urn:BeckhoffAutomation:TcOpcUaServer:1" Access="0x000003FF"/>
<DefaultAccess Namespace="urn:BeckhoffAutomation:Ua:PLC1" Access="0x000003FF"/>
</Group>
</Groups>
<Users>
<User Name="Administrator" Auth="OS" MemberOf="Administrators"></User>
<User Name="MaxM" Auth="OS" MemberOf="Users"></User>
</Users>
<AccessInfos></AccessInfos>
</TcUaSecurityConfig>
Gruppen können ebenfalls mit einem <DefaultAccess>‑Tag versehen werden. Gruppen können über das MemberOf‑Attribut verschachtelt werden. Bei Mitgliedschaft in mehreren Gruppen werden diese über ein Semikolon voneinander getrennt.
AccessInfos
Falls eine feingranulare Einstellung von Berechtigungen auf Node-Ebene erfolgen soll, so können zusätzlich <AccessInfos> konfiguriert werden, welche die Zugriffsberechtigungen auf Nodes spezifizieren. Zugriffsrechte können hierbei auf Unterelemente vererbt werden. Obwohl AccessInfos die feingranularste Konfigurationsmöglichkeit von Berechtigungen ermöglichen, so wird eine solche Konfiguration auch schnell unübersichtlich. Prüfen Sie daher, ob eine Konfiguration von Zugriffsrechten auf Namespace-Ebene (siehe oben) nicht ausreichend ist.
<TcUaSecurityConfig>
<Groups></Groups>
<Users>
<User Name="MaxM" Auth="OS"></User>
</Users>
<AccessInfos>
<AccessInfo>
<NodeId NS="urn:BeckhoffAutomation:Ua:PLC1" Id="s=MAIN.nCounter" Depth="-1"/>
<User Name="MaxM" Access="0x000003FF"/>
</AccessInfo>
</AccessInfos>
</TcUaSecurityConfig>
Die AccessInfo für eine Node beinhaltet die folgenden Einstellungen:
▪
NS: konfiguriert den NamespaceName, in welchem die Node lokalisiert ist
▪
Id: konfiguriert den Identifier der Node, inklusive des IdentifierTypes (z.B. s=String)
▪
Depth: Vererbungstiefe der Berechtigungen (-1 für unendlich)
▪
User/Group: Benutzer oder Gruppe die auf diese Node Zugriff erhalten soll, inklusive des AccessLevels
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Verschiedenes

Technische Einführung [image] TwinCAT OPC UA Server [image] Verschiedenes
Verschiedenes
Weiterführende Informationen
•
Endpunkte und Standard-Port
•
Generierung von NamespaceUri
•
Konfigurationsdatei
•
Konfiguration mehrerer TwinCAT-Laufzeiten
•
Konfiguration mehrerer Server-Instanzen
•
Konfiguration von Firewalls
•
Konfiguration des Namensraums


Endpunkte und Standard-Port

Technische Einführung [image] TwinCAT OPC UA Server [image] Verschiedenes [image] Endpunkte und Standard-Port
Endpunkte und Standard-Port
Standardmäßig bietet der TwinCAT OPC UA Server die folgenden Endpunkte und Standard-Port für OPC UA Clients zur Verbindung an:
Grafik aus Endpoints and default port (ir0btqq3.png)
Hinweis
Standard-Port
Beachten Sie, dass der Standard-Port 4840 eventuell von anderen OPC UA Servern verwendet wird, z. B. dem Local Discovery Server (LDS) von der OPC Foundation, die von manchen Anbietern mit OPC‑UA‑Softwarepaketen eingesetzt wird.
Endpunkt | Beschreibung
Keine - Keine | Keine Sicherheit
Basic128Rsa15 - Sign & Encrypt | Signatur und Verschlüsselung von Nachrichten für mittlere Sicherheitsanforderungen. Erfordert Zertifikataustausch und die Verwaltung der Vertrauenslisten. Weitere Informationen erhalten Sie im OPC-UA‑Server‑Sicherheitskapitel.
Basic256 - Sign & Encrypt | Signatur und Verschlüsselung von Nachrichten für mittlere bis hohe Sicherheitsanforderungen. Erfordert mehr Rechenzeit (höhere Anforderungen an die CPU des Computers). Erfordert Zertifikataustausch und die Verwaltung der Vertrauenslisten. Weitere Informationen erhalten Sie im OPC-UA‑Server‑Sicherheitskapitel.


Generierung von NamespaceUri

Technische Einführung [image] TwinCAT OPC UA Server [image] Verschiedenes [image] Generierung von NamespaceUri
Generierung von NamespaceUri
Der NamespaceUri ist wichtig für die einzigartige Identifizierung eines Knotens im UA‑Namensraum. Jede NodeID besteht aus einem NamespaceIndex, einem IdentifierType und einem Bezeichner. Weil der NamespaceIndex dynamisch von einem OPC UA Server generiert werden kann, sollte ein UA-Client immer den statischen NamespaceUri verwenden, um diesen in dessen tatsächlichen NamespaceIndex aufzulösen. Alle NamespaceUris und deren entsprechender NamespaceIndex werden im sogenannten NamespaceArray eines OPC UA Servers aufgelistet.
Weitere Informationen bezüglich des NamespaceArray und seines Inhalts finden Sie im Abschnitt Wie Kommunikationsparameter zu bestimmen sind.
Für jede TwinCAT‑Laufzeit wird der NamespaceUri gemäß folgendem Benennungsschema generiert:
urn:[NodeName]:BeckhoffAutomation:Ua:[Name]
▪
[NodeName] steht für den Hostnamen des Computers, auf dem der TwinCAT OPC UA Server läuft
▪
[Name] ist eine Zeichenkette, die über die Konfigurationsdatei des Servers oder über den TwinCAT‑OPC‑UA‑Konfigurator festgelegt werden kann.
Beachten Sie, dass ältere Versionen des TwinCAT OPC UA Servers nicht das URI-basierte Format zur Generierung des NamespaceUri, sondern lediglich das <Name>-Attribut, wie es in der Konfigurationsdatei des Servers festgelegt wurde, verwendeten. Weil dies beim Upgrading von älteren Versionen eine unüberbrückbare Veränderung sein kann, bietet der TwinCAT OPC UA Server einen sogenannten Legacy‑URI‑Formatwechsel, der für jede TwinCAT‑Laufzeit in der Konfigurationsdatei des Servers oder über den OPC‑UA‑Konfigurator aktiviert werden kann.
<UaNodeManager>
<Name>PLC1</Name>
<AdsPort>851</AdsPort>
<AdsNetId>127.0.0.1.1.1</AdsNetId>
<AdsTimeout>2000</AdsTimeout>
<AdsTimeSuspend>20000</AdsTimeSuspend>
<AutoCfg>4041</AutoCfg>
<IoMode>1</IoMode>
<AutoCfgSymFile>C:\TwinCAT\3.1\Boot\Plc\Port_851.tmc</AutoCfgSymFile>
<Disabled>0</Disabled>
<ArraySubItemLegacySupport>0</ArraySubItemLegacySupport>
<MaxGetHandle>100</MaxGetHandle>
<ReleaseAdsVarHandles>0</ReleaseAdsVarHandles>
<LegacyUriFormat>1</LegacyUriFormat>
</UaNodeManager>
Wird der Legacy‑URI‑Formatwechsel auf „0“ gesetzt, dann wird der NamespaceName gemäß dem oben beschriebenen Schema generiert. Wird er auf „1“ gesetzt, dann ist der NamespaceName gleich dem XML-Tag <Name> und wird demzufolge wie in älteren Versionen des TwinCAT OPC UA Servers generiert.


Konfigurationsdatei

Technische Einführung [image] TwinCAT OPC UA Server [image] Verschiedenes [image] Konfigurationsdatei
Konfigurationsdatei
Alle Einstellungen für den TwinCAT OPC UA Server können mithilfe eines Konfigurators vorgenommen werden, der über das Setup vom UA-Server-Version 1.6.80 geliefert wird. Der Konfigurator macht es für den Benutzer einfacher, den UA-Server über seine ServerConfig.xml-Konfigurationsdatei zu konfigurieren. Die Konfigurationsdatei enthält eine hierarchische, XML-basierte Struktur aller einstellbaren Parameter des UA-Servers. Die folgende Abbildung gibt eine Beispielstruktur dieser Datei wieder.
In Allgemeinen wird die Verwendung des OPC‑UA‑Konfigurators empfohlen, da auf diese Weise Fehler bei der Konfiguration vermieden werden können.
Die Konfigurationsdatei befindet sich immer in demselben Verzeichnis wie TcOpcUaServer.exe, zum Beispiel:
▪
Windows XP / 7 mit TwinCAT 2: %TwinCATDIR%\OPC\UA\
▪
Windows XP / 7 mit TwinCAT 3: %TwinCATDIR%\Functions\TF6100-OPC-UA\Win32\Server\
▪
Windows CE TwinCAT 2 : HardDisk\System
▪
Windows CE TwinCAT 3 : HardDisk\TwinCAT\Functions\TF6100-OPC-UA\Server\


Konfiguration mehrerer TwinCAT-Laufzeiten

Technische Einführung [image] TwinCAT OPC UA Server [image] Verschiedenes [image] Konfiguration mehrerer TwinCAT-Laufzeiten
Konfiguration mehrerer TwinCAT-Laufzeiten
Sie können optional weitere TwinCAT-ADS-Geräte zum UA-Namensraum hinzufügen. Durch die Konfiguration des Namensraums weiß der OPC UA Server, welches TwinCAT-ADS-Gerät (z. B. PLC, IO‑Task, C++‑Laufzeit,...) über den OPC UA Server verfügbar gemacht werden soll und blendet entsprechend dessen Symbolinformationen im UA-Namensraum ein. Diese Konfiguration muss nur einmalig durchgeführt werden.
Hinzufügen/Entfernen von weiteren ADS-Geräten zu/aus dem UA‑Namensraum
Der TwinCAT OPC UA Server ist per Default so konfiguriert, dass er sich zur ersten SPS-Laufzeit des lokalen Systems verbindet. Um weitere ADS-Geräte bzw. weitere Laufzeiten über den UA-Namensraum verfügbar zu machen, führen Sie folgende Schritte durchführen:
▪
Wenn es sich bei dem hinzuzufügenden Gerät um ein lokales Gerät handelt:
–
Hinzufügen des Remotegeräts zur Konfiguration des OPC UA Servers, z. B. über den OPC‑UA‑Konfigurator oder durch direktes Editieren der ServerConfig.xml-Datei
▪
Wenn es sich bei dem hinzuzufügenden Gerät um ein Remotegerät handelt:
–
Herstellen von ADS-Routen zwischen dem Rechner auf dem sich der OPC UA Server befindet und dem Remotesystem
–
Hinzufügen des Remotegeräts zur Konfiguration des OPC UA Servers, z. B. über den OPC‑UA‑Konfigurator oder durch direktes Editieren der ServerConfig.xml-Datei
Verwenden des OPC-UA-Konfigurators
Verwenden Sie den OPC-U- Konfigurator, um weitere ADS-Geräte zum UA-Namensraum hinzuzufügen.
Im Bereich Data Access des OPC-UA-Konfigurators können Sie die im UA-Namensraum eingebundenen ADS-Geräte verwalten bzw. neue Geräte hinzufügen oder existierende Geräte entfernen.
Zum Hinzufügen wählen Sie zunächst den Typ des Geräts aus der zugehörigen Drop-Down-Liste (z. B. „8 (PLC: Subset)“) und klicken dann auf Add. Es wird ein zusätzlicher Eintrag zur Liste der ADS-Geräte hinzugefügt. Nehmen Sie die gewünschten Einstellungen vor. Wenn Sie die Konfiguration sofort aktivieren möchten, klicken Sie anschließend im Menü Configuration auf Activate.
Abhängig vom hinzuzufügenden Gerät müssen unterschiedliche Einstellungen für die einzelnen Parameter vorgenommen werden (siehe Data Access).
Beachten Sie, dass Sie den OPC UA Server neu starten müssen, damit die Änderungen wirksam werden. Dies können Sie ebenfalls über den Konfigurator erledigen, indem Sie im Menü Server die Option Restart auswählen. Alternativ reicht hierzu auch ein TwinCAT‑Neustart.
[Optional] Editieren der ServerConfig.xml
Sie können die ServerConfig.xml-Datei auch direkt editieren, um weitere ADS-Geräte zum UA‑Namensraum hinzuzufügen. In dieser Konfigurationsdatei gibt es einen Bereich <UaNodeManager>, welcher jeweils den Zugriff auf ein ADS-Gerät definiert, zum Beispiel:
Abhängig vom hinzuzufügenden Gerät müssen unterschiedliche Einstellungen für die einzelnen Parameter vorgenommen werden (siehe Data Access).
Beachten Sie, dass Sie den OPC UA Server neu starten müssen, damit die Änderungen wirksam werden. Dies können Sie ebenfalls über den Konfigurator erledigen, indem Sie im Menü Server die Option Restart auswählen. Alternativ reicht hierzu auch ein TwinCAT‑Neustart.


Konfiguration mehrerer Server-Instanzen

Technische Einführung [image] TwinCAT OPC UA Server [image] Verschiedenes [image] Konfiguration mehrerer Server-Instanzen
Konfiguration mehrerer Server-Instanzen
Es besteht die Möglichkeit, mehrere TwinCAT OPC UA Server auf einem System zu installieren. Dieser Teil der Dokumentation beschreibt die hierfür notwendigen Konfigurationsschritte. Die Konfiguration ist unter Windows-CE- und Windows-XP-basierten Betriebssystemen identisch und besteht aus den folgenden Teilschritten:
▪
Schritt 1: Installation des TwinCAT OPC UA Servers
▪
Schritt 2: Kopieren der installierten UA‑Server‑Dateien in ein neues Verzeichnis
▪
Schritt 3: Anpassen der Konfigurationsdatei des zweiten UA-Servers
Lediglich die Pfade bei den beiden Betriebssystemvarianten sind unterschiedlich. In der Beschreibung der einzelnen Schritte wird jeweils auf die Unterschiede hingewiesen.
HINWEIS! Der TwinCAT OPC UA Server ermöglicht eine Nutzung von OPC UA direkt aus der SPS-Ebene heraus. Hierfür wurde ein ADS-Server in das Produkt integriert, damit SPS-Programmierer per Funktionsbaustein Daten über OPC UA verschicken können. Möchten Sie, wie in dieser Anleitung beschrieben, mehrere TwinCAT OPC UA Server parallel auf einem System laufen lassen, so gilt zu beachten, dass nur die erste Instanz des UA-Servers per Funktionsbaustein angesprochen werden kann.
Schritt 1: Installation des TwinCAT OPC UA Servers
Die Erst-Installation des TwinCAT OPC UA Servers erfolgt über die auf dem Beckhoff FTP-Server erhältliche Setup-Datei. Standardmäßig wird der UA-Server in dem folgenden Verzeichnis installiert:
▪
Windows XP: %TwinCATDIR%\Function\TF6100-OPC-UA\Win32\Server\
▪
Windows CE: HDD\System
Schritt 2: Kopieren der installierten UA‑Server‑Dateien in ein neues Verzeichnis
Die installierten UA-Server‑Dateien müssen in ein neues Verzeichnis kopiert werden. Erstellen Sie ein neues Verzeichnis namens „Server2“ in einem Ordner Ihrer Wahl, z. B.
▪
Windows XP: %TWINCATDIR%\Function\TF6100-OPC-UA\Win32\Server2\
▪
Windows CE: HDD\System\UA2
Kopieren Sie die Inhalte des Ursprungsordners in das neu erstellte Verzeichnis. Der Inhalt dieses Ordners sollte dann wie folgt aussehen:
Schritt 3: Anpassen der Konfigurationsdatei des zweiten UA-Servers
Damit der zweite UA-Server einen anderen TCP-Port benutzt, muss einmalig dessen Konfigurationsdatei angepasst werden. Hierzu öffnen Sie die Datei ServerConfig.xml mit einem Texteditor Ihrer Wahl, zum Beispiel „Notepad“.
Weitere Informationen zur Konfigurationsdatei des UA‑Servers finden Sie im Abschnitt Konfigurationsdatei.
1.
Suchen Sie in dieser Datei den Eintrag <Url>opc.tcp://[NodeName]:4840</Url> unterhalb des Knotens <UaEndpoint> und ändern Sie dessen Portnummer (4840) in einen TCP-Port Ihrer Wahl, zum Beispiel „4849“:
2.
Passen Sie zusätzlich den Knoten <ServerInstanceUri>[NodeName]/Beckhoff/TcOpcUaServer/ 1 </ServerInstanceUri> an und vergeben Sie eine neue Nummer, zum Beispiel:
⇨
Durch Ausführen der Datei können Sie nun den zweiten TwinCAT OPC UA Server starten:
▪
Windows XP: %TWINCATDIR%\Function\TF6100-OPC-UA\Win32\Server2\TcOpcUaServer.exe -console


Konfiguration von Firewalls

TS6100 | TwinCAT OPC UA
Technische Einführung [image] TwinCAT OPC UA Server [image] Verschiedenes [image] Konfiguration von Firewalls
Konfiguration von Firewalls
Um eine OPC‑UA‑Kommunikation auch über ein NAT-Gerät, z. B. einen Internet-Router, zu ermöglichen, muss dieses entsprechend den verwendeten UA-Port an den TwinCAT OPC UA Server weiterleiten können (sogenanntes Port Forwarding). Standardmäßig wird der TwinCAT OPC UA Server für eine UA-Kommunikation über den TCP-Port 4840 konfiguriert, diese Konfiguration kann jedoch bei Bedarf selbst angepasst werden; entweder über die Server-Konfigurationsdatei oder den OPC‑UA‑Konfigurator. Das folgende Schaubild verdeutlicht noch einmal den Zusammenhang von Port Forwarding und dem UA-Server.
In diesem Beispiel baut der OPC UA Client eine UA-Verbindung über den TCP-Port 4840 zum NAT‑Gerät auf, welches dann diese Kommunikationsverbindung über ein Port Forwarding an den TwinCAT OPC UA Server weiterleitet. Das NAT-Gerät muss also nur den im TwinCAT OPC UA Server konfigurierten UA-Port an das Zielgerät weiterleiten. Den vom UA-Server verwendeten Port können Sie entweder in der Server-Konfigurationsdatei einsehen oder auch ganz bequem über den UA‑Konfigurator (im Auslieferungszustand ist dieser immer der TCP-Port 4840). Die entsprechende Konfiguration Ihres NAT-Geräts für ein Port Forwarding entnehmen Sie bitte dessen Dokumentation.


Konfiguration des Namensraums

Technische Einführung [image] TwinCAT OPC UA Server [image] Verschiedenes [image] Konfiguration des Namensraums
Konfiguration des Namensraums
Ab der Version 2.1.x bietet der TwinCAT OPC UA Server eine separate Konfiguration des Namensraums, die die folgenden Funktionalitäten enthält:
▪
Verwaltung der ServerConfig (Lesen/Schreiben-Zugriff) des OPC UA Servers
▪
Zertifikatmanagement für vertrauenswürdige/abgelehnte Client-Zertifikate
Grafik aus Configuration namespace (i0mi0gg3.png)
Verwaltung der ServerConfig
Die ServerConfig wird im Namensraum als regulärer OPC UA FileType veröffentlicht und bietet daher die entsprechenden Methoden und Eigenschaften, um Zugriff auf die Datei zu erhalten.
Verwaltung von Client-Zertifikaten
Jedes Client-Zertifikat, das dem Server bekannt ist, wird im Namensraum als OPC‑UA‑Zertifikattyp veröffentlicht. Zertifikate werden in „abgelehnte” und „vertrauenswürdige“ Zertifikate unterteilt, was durch einen separaten Ordner im Namensraum repräsentiert wird.
Durch Aufruf der Methode Move() kann ein Zertifikat zwischen den Vertrauenslisten verschoben werden.
Zudem bieten verschiedene Eigenschaften zur einfacheren Identifikation weitere Informationen über die Zertifikate selbst.
Verwendung der Namensraum-Konfiguration
Die Namensraum-Konfiguration darf nur von authentifizierten Benutzern verwendet werden. Dies bedeutet, dass ein OPC UA Client sich selbst gegenüber dem OPC UA Server durch Bereitstellung einer gültigen Benutzername-/Passwort-Kombination authentifizieren muss. Gültige Benutzernamen sind entweder lokale Benutzer oder auch Benutzer von einer Windows-Domäne, wenn der Computer, auf dem der OPC UA Server läuft, ein Mitglied einer Windows-Domäne ist.
In seiner ServerConfig-Datei stellt der OPC UA Server die folgenden XML-Tags bereit, um den Zugriff auf die Namensraum-Konfiguration zu konfigurieren:
<ServerConfigNamespace Exposed="True" MinUserlevel="14" />
<Users>
<User Level="15">Administrator</User>
<User Level="10">domain\RegularUser</User>
</Users>
In dem vorstehenden Beispiel ist dem lokalen Benutzernamen „Administrator" der Zugriff auf den Konfiguration des Namensraums gestattet, wohingegen das Benutzerkonto „domain\RegularUser” der Windows-Domäne nicht auf diesen Namensraum zugreifen darf, da die Benutzerebene zu niedrig ist.


TwinCAT OPC UA Client

Technische Einführung [image] TwinCAT OPC UA Client
TwinCAT OPC UA Client
Weiterführende Informationen
•
Übersicht
•
I/O
•
Unterstützte Datentypen
•
Best Practice
•
Sicherheit


Übersicht

Technische Einführung [image] TwinCAT OPC UA Client [image] Übersicht
Übersicht
Der TwinCAT OPC UA Client bietet mehrere Möglichkeiten direkt aus der Steuerungslogik heraus mit einem oder mehreren OPC UA Servern zu kommunizieren. Zum einen steht eine OPC‑UA‑Schnittstelle direkt aus der SPS zur Verfügung, bei der über PLCopen genormte Funktionsbausteine eine Verbindung mit einem OPC UA Server initiiert werden kann. Zum anderen gibt es ein TwinCAT OPC UA Client I/O‑Gerät, welches eine einfache, Mapping-basierte Schnittstelle bietet.
SPS‑Funktionsbausteine
Die folgende Tabelle gibt einen Überblick über die angebotenen Funktionalitäten:
Funktionalität | Beschreibung | Relevante Funktionsbausteine
Connect/Disconnect | Herstellen und Trennen von Verbindungen zu OPC UA Servern. | UA_Connect UA_Disconnect
Polling (Read/Write) | Lesen und Schreiben von Variablen im UA-Namensraum im Polling-Modus. Beinhaltet keine Subscriptions. | UA_Connect UA_Disconnect UA_Read UA_Write UA_GetNamespaceIndex UA_NodeGetHandle UA_NodeReleaseHandle
Method-Call | Ausführen von Methoden im UA‑Namensraum. | UA_Connect UA_Disconnect UA_MethodGetHandle UA_MethodReleaseHandle UA_MethodCall
Security | Herstellen einer verschlüsselten Verbindung zu einem OPC UA Server. | UA_Connect UA_Disconnect
Die Schnittstellen jedes Funktionsbausteins sind im Rahmen dieser Dokumentation ausführlich im Abschnitt SPS API beschrieben.
I/O Gerät
Weitere Informationen zum TwinCAT OPC UA Client I/O‑Gerät finden Sie im Abschnitt I/O.


I/O

Technische Einführung [image] TwinCAT OPC UA Client [image] I/O
I/O
Zusätzlich zu den genormten Funktionsbausteinen der SPS-Bibliothek Tc3_PLCopen_OpcUa steht auch ein TwinCAT‑3‑I/O‑Gerät („Virtual OPC UA Client“) zur Verfügung, welches OPC‑UA‑Client‑Funktionalitäten besitzt. Dieses I/O Gerät ermöglicht somit die einfache Konfiguration eines Datenaustauschs zwischen einem OPC UA Server und TwinCAT.
Graphic from I_O (imst5i41.png)
Die zu kommunizierenden OPC‑UA‑Nodes können hierbei über das reguläre TwinCAT‑Mapping mit Variablen in der SPS oder C++ verknüpft werden.
Der zugehörige „Virtual OPC UA Client“ wird mit dem TF6100 Setup ab Version 4 ausgeliefert und kann ab TwinCAT 3.1 Build 4022.4 verwendet werden.
Quick Start
Die im Folgenden beschriebene Kurzanleitung ermöglicht einen schnellen Start mit dieser Komponente. In der Kurzanleitung wird ein SPS‑Projekt erzeugt, welches zum einen eine Variable über den TwinCAT OPC UA Server freigibt (zur Simulation eines UA‑Servers) und die freigegebene Variable wieder über den I/O‑OPC‑UA‑Client einliest. Dies kann natürlich auch auf zwei Projekte und zwei Steuerungen aufgesplittet werden.
Variablen für Server freigeben
Zur Simulation eines OPC UA Servers soll in diesem QuickStart der TwinCAT OPC UA Server verwendet werden.
1.
Erstellen Sie ein neues TwinCAT‑Projekt und fügen Sie dem Projekt ein neues SPS‑Projekt hinzu.
2.
Legen Sie im SPS-Projekt eine neue Variable „nQuickStartOut“ vom Datentyp INT an. Dies soll die Variable sein, die über den OPC UA Server freigegeben wird.
3.
Setzen Sie das OPC‑UA‑Attribut für diese Variable, um die Variable über den TwinCAT OPC UA Server freizugeben.
4.
Aktivieren Sie die Checkbox für den TMC-Datei-Download.
5.
Aktivieren Sie die Konfiguration.
⇨
Die Variable ist für den Server freigegeben.
Konfiguration des I/O UA Clients
1.
Legen Sie in demselben SPS-Projekt eine weitere Variable „nQuickStartIn“ vom Datentyp INT an und definieren Sie diese als Eingangsvariable (AT%I*). Dies soll die Variable sein, die vom OPC UA Client I/O‑Gerät über das Mapping mit der Variablen vom Server verknüpft wird.
2.
Kompilieren Sie das Projekt, sodass die Eingangsvariable im SPS‑Prozessabbild zur Verfügung steht.
3.
Fügen Sie ein neues „Virtual OPC UA Device“ hinzu.
4.
Fügen Sie einen neuen „OPC UA Client“ zum Device hinzu und öffnen Sie dessen Einstellungen.
5.
Navigieren Sie zur Registerkarte Settings. Tragen Sie dort die Server-URL des OPC UA Servers ein. In diesem Beispiel lautet diese „opc.tcp://localhost:4840“.
6.
Klicken Sie auf Add Nodes.
7.
Navigieren Sie zur freigegebenen Variable „nQuickStartOut“ auf dem OPC UA Server (zu finden unterhalb von PLC1 > MAIN) und selektieren Sie diese. Die Variable wird nun zum Prozessabbild des „Virtual OPC UA Device“ hinzugefügt.
Graphic from I_O (iv8g0st.png)
Graphic from I_O (ijr9k1v.png)
8.
Erweitern Sie die neu hinzugefügte Variable im Prozessabbild und doppelklicken Sie auf Input\Value. Verknüpfen Sie die Variable mit der Variablen „nQuickStartIn“ aus dem SPS-Prozessabbild.
9.
Aktivieren Sie die Konfiguration.
⇨
Sie sollten nun die nachfolgend dargestellte Konfiguration vorfinden. Die beiden Prozessabbild-Variablen nQuickStartIn und nQuickStartOut sind miteinander verknüpft.
Graphic from I_O (iqj1ph6.png)
10.
Nach dem Aktivieren der Konfiguration, loggen Sie sich in das SPS-Programm ein.
Graphic from I_O (imoapfd2.png)
Der aktuelle Wert kann natürlich auch im Prozessabbild-Mapping eingesehen werden.
Graphic from I_O (i9p5rfm2.png)
11.
Über die Einstellungen am OPC UA Client können Sie Parameter wie z. B. die Samplingrate modifizieren.
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Unterstützte Datentypen

Technische Einführung [image] TwinCAT OPC UA Client [image] Unterstützte Datentypen
Unterstützte Datentypen
Der TwinCAT OPC UA Client ermöglicht einen Zugriff auf OPC UA Server direkt aus der Echtzeitlogik heraus. Um Daten zu lesen und zu schreiben müssen die Datentypen beider Umgebungen zugeordnet werden (Mapping). Nachfolgend wird diese Zuordnung beschrieben.
Basisdatentypen
Die Zuordnung der Basisdatentypen wird in PLCopen OPC UA Information Model for IEC 61131-3 beschrieben.
OPC‑UA‑Datentyp | SPS‑Datentyp
Boolean | BOOL
SByte | SINT
Byte | USINT
Int16 | INT
Int32 | DINT
String | STRING
USint | BYTE
Float | REAL
Double | LREAL
UInt16 | UINT
UInt32 | UDINT
Int64 | LINT
UInt64 | ULINT
DateTime | DT
Abgeleitete Datentypen
OPC UA definiert Basisdatentypen. Andere Datentypen sind davon abgeleitet.
Auf Client-Seite ist nur mit SPS-Datentypen Zugriff auf alle UA-Datentypen möglich. Datentypen, welche von den Basisdatentypen abgeleitet sind, werden ab TcOpcUaClient Version 2.1.0.36 ebenfalls unterstützt.
Derzeit unterstützte Nicht-Basisdatentypen auf Client-Seite sind:
▪
Counter (UDINT in SPS nutzen)
Zugriff auf Arrays
Beim Anlegen eines Knotenhandle prüft das System Möglichkeiten des Zugriffs auf den Knoten. Weitere Prüfungen erfolgen beim Lesen und Schreiben.
Für den Zugriff auf Array-Knoten sowie Ein- und Ausgabeparameter von Methodenaufrufen müssen bestimmte Bedingungen erfüllt sein.
▪
Für den Zugriff auf Knoten: Array-Dimension und Datenlänge müssen beim Lesen und Schreiben zu den bereitgestellten Daten passen.
▪
Lesen von Zeichenketten: Sobald EINE Zeichenkette die vorgegebene Länge für SPS‑Zeichenketten überschreitet, schlägt der Lesevorgang fehl.
▪
Es werden nur Array-Dimensionen bis zu drei Ebenen unterstützt.


Best Practice

Technische Einführung [image] TwinCAT OPC UA Client [image] Best Practice
Best Practice
Weiterführende Informationen
•
Wie Kommunikationsparameter zu bestimmen sind
•
Wie eine Verbindung hergestellt wird
•
Wie die Knoten auszulesen sind
•
Wie Knoten zu schreiben sind
•
Wie Methoden aufzurufen sind


Wie Kommunikationsparameter zu bestimmen sind

Technische Einführung [image] TwinCAT OPC UA Client [image] Best Practice [image] Wie Kommunikationsparameter zu bestimmen sind
Wie Kommunikationsparameter zu bestimmen sind
Ganz gleich, welche OPC-UA-Funktionalität Sie implementieren möchten, es gibt doch ein paar Dinge, die bei der SPS-Projektentwicklung hilfreich sind. Es ist allgemeine Praxis, einen grafischen OPC UA Client zu verwenden, um bei der Bestimmung der Attribute eines Knotens oder einer Methode zu helfen, die zusammen mit den SPS-Funktionsbausteinen verwendet werden müssen, z. B.:
▪
Node Identifier
▪
Node Namespace Index und entsprechender Namespace URI
▪
Node Data Type
▪
Method Node ID und Object Node ID
Die folgende Dokumentation verwendet den generischen OPC UA Client UA-Expert als Beispiel. Dieser Client kann von den Websites von Unified Automation erworben werden: www.unified-automation.com.
Node Identifier
Eine sehr allgemeine Aufgabe besteht aus dem Lesen oder Schreiben von Variablen, die im Allgemeinen im Hinblick auf OPC UA als Knoten bezeichnet werden. Knoten sind durch die folgenden drei Elemente gekennzeichnet:
▪
Namespace Index: Der Namensraum, in dem sich der Knoten befindet, z. B. die SPS-Laufzeit
▪
Identifier: Eindeutiger Bezeichner des Knotens innerhalb seines Namensraums
▪
Identifier Type: Es gibt drei verschiedene Typen: String, Guid und Numeric.
Diese Attribute stellen die sogenannte NodeID dar – die Darstellung eines Knotens auf einem OPC UA Server – und sie werden von manchen Funktionsbausteinen benötigt. Durch Verwendung von UA-Expert können Entwickler diese Attribute einfach durch Verbindung zum OPC UA Server und Browsen zum gewünschten Knoten bestimmen. Die Attribute sind dann im Attributes-Panel sichtbar, z. B.:
Grafik aus General information (inhhs0l2.png)
Node Namespace Index und entsprechender Namespace URI
Nach der OPC‑UA‑Spezifikation kann der Namespace Index (wie vorstehend wiedergegeben) ein dynamisch generierter Wert sein. Daher müssen OPC UA Clients immer den entsprechenden Namespace URI zur Auflösung des Namespace Index verwenden, bevor ein Knotenhandle erfasst wird. Dies erfolgt durch Verwendung des Funktionsbausteins UA_GetNamespaceIndex. Um diesen Funktionsbaustein jedoch verwenden zu können, muss der Namespace URI bekannt sein. Der Namespace URI kann einfach durch Verwendung von UA-Expert bestimmt werden. An den OPC UA Server anschließen und zu folgendem Knoten browsen:
Grafik aus General information (i5q6eif.png)
Dieser Knoten enthält Informationen über alle eingetragenen Namespaces auf dem OPC UA Server. Sie können die entsprechenden Namespace URIs in dem Attributes-Panel sehen.
Grafik aus General information (ibn3o203.png)
Beispiel: Im Abschnitt über Node Identifier (siehe vorstehend) haben wir eine NodeID gesehen, in der der Namespace Index 5 war. Nach dem vorstehenden Namespace Array ist der entsprechende Namespace URI urn://SVENG-NB04/BeckhoffAutomation/Ua/PLC1. Dieser URI kann nun für den Funktionsbaustein UA_GetNamespaceIndex verwendet werden. Der OPC UA Server stellt sicher, dass dieser URI immer derselbe bleibt, auch nach einem Neustart. Der vorgenannte Namespace Index kann sich jedoch ändern, weshalb der Namespace URI und der Funktionsbaustein UA_GetNamespaceIndex immer zur Auflösung des korrekten Namespace Index zur späteren Nutzung mit anderen Funktionsbausteinen genutzt werden sollte, wie z. B. UA_Read, UA_Write.
Node Data Type
Der Datentyp eines Knotens ist erforderlich, um zu sehen, welcher SPS-Datentyp verwendet werden muss, um einen ausgelesenen Wert zuzuordnen oder welcher SPS-Datentyp verwendet werden muss, wenn in einen Knoten geschrieben werden soll. Bei Verwendung von UA-Expert, einfach mit dem OPC UA Server verbinden, zur Variablen browsen und deren Data Type auf dem Attributes-Panel auslesen, z. B.:
Grafik aus General information (icm6j963.png)
In diesem Fall ist der Data Type Int16, was einem äquivalenten Datentyp in der SPS zugeordnet werden sollte, z. B. INT. Die PLCopen IEC61131‑zu‑OPC‑UA‑Spezifikation beschreibt das definierte Datentyp-Mapping. Die folgende Tabelle ist ein Auszug aus dieser Spezifikation:
IEC61131 elementare Datentypen | OPC UAeingebaute Datentypen
BOOL | Boolean
SINT | SByte
USINT | Byte
INT | Int16
UINT | UInt16
DINT | Int32
UDINT | UInt32
LINT | Int64
ULINT | UInt64
BYTE | Byte
WORD | UInt16
DWORD | UInt32
LWORD | UInt64
REAL | Float
LREAL | Double
STRING | String
CHAR | Byte
WSTRING | String
WCHAR | UInt16
DT DATE_AND_TIME | DateTime
DATE | DateTime
TOD TIME_OF_DAY | DateTime
TIME | Double
Method Node ID und Object Node ID
Beim Aufruf von Methoden aus dem OPC‑UA‑Namensraum sind zwei Identifier erforderlich, wenn der Methodenhandle unter Verwendung des Funktionsbausteins UA_MethodGetHandle erfasst wird:
▪
Object Node ID: Identifiziert das UA-Objekt, das die Methode enthält
▪
Method Node ID: Identifiziert die Methode selbst
Beide NodeIDs können einfach durch Verwendung von UA-Expert bestimmt werden. An den OPC UA Server anschließen und zu der gewünschten Methode browsen, z. B.:
Grafik aus General information (iqsq5541.png)
Der Method Identifier kann dann vom Attributes-Panel aus ausgelesen werden:
Grafik aus General information (i31b57r2.png)
Browsen Sie anschließend zu dem UA-Objekt, das diese Methode enthält. In dem vorstehenden Beispiel ist dies das Objekt fbMathematics:
Grafik aus General information (if4km5i3.png)
Der Object Identifier kann dann vom Attributes-Panel aus ausgelesen werden:
Grafik aus General information (idkncii3.png)


Wie eine Verbindung hergestellt wird

Technische Einführung [image] TwinCAT OPC UA Client [image] Best Practice [image] Wie eine Verbindung hergestellt wird
Wie eine Verbindung hergestellt wird
Im nachfolgenden Abschnitt wird beschrieben, wie die TcX_PLCopen_OpcUa-Funktionsbausteine verwendet werden sollten, um eine Verbindung zu einem lokalen oder entfernten OPC UA Server herzustellen. Diese Verbindung kann dann verwendet werden, um weitere Funktionalitäten aufzurufen, z. B. Knoten auslesen oder schreiben, oder Methoden aufrufen.
Der Abschnitt beinhaltet folgende Themen:
▪
Übersicht
▪
Schematischer Arbeitsablauf
▪
Zu berücksichtigende Punkte
▪
Code-Ausschnitt
Übersicht
Die folgenden Funktionsbausteine sind erforderlich, um eine Verbindung zu einem OPC UA Server herzustellen und später die Sitzung zu unterbrechen: UA_Connect, UA_Disconnect.
HINWEIS! Lesen Sie zunächst den Abschnitt „Wie Kommunikationsparameter zu bestimmen sind“, um bestimmte UA-Funktionalitäten besser verstehen zu können (z. B. wie Node Identifier bestimmt werden können).
Schematischer Arbeitsablauf
Der schematische Arbeitsablauf jedes TwinCAT OPC UA Client kann in drei verschiedene Phasen kategorisiert werden: Preparation, Work und Cleanup.
Der in diesem Abschnitt beschriebene Verwendungsfall kann wie folgt visualisiert werden:
Grafik aus How to establish a connection (i687mi41.emf)
Zu berücksichtigende Punkte
Der Funktionsbaustein UA_Connect erfordert die folgenden Informationen, um eine Verbindung zu einem lokalen oder entfernten OPC UA Server herstellen zu können:
▪
Server URL
▪
Session Connect Information
Die Server URL besteht grundsätzlich aus einem Präfix, einem Hostnamen und einem Port. Das Präfix beschreibt das OPC‑UA‑Transportprotokoll, das für die Verbindung verwendet werden sollte, z. B. “opc.tcp://” für eine binäre TCP-Verbindung (Standard). Der Hostname bzw. IP-Adressenteil beschreibt die Adressinformationen des OPC‑UA‑Zielservers, z. B. „192.168.1.1“ oder „CX-12345“. Die Portnummer ist der Zielport des OPC UA Servers, z. B. „4840“. Insgesamt kann die Server URL wie folgt aussehen: opc.tcp://CX-12345:4840.
Code-Ausschnitt
Deklaration:
(* Declarations for UA_Connect *)
fbUA_Connect : UA_Connect;
SessionConnectInfo : ST_UASessionConnectInfo;
nConnectionHdl : DWORD;

(* Declarations for UA_Disconnect *)
fbUA_Disconnect : UA_Disconnect;

(* Declarations for state machine and output handling *)
iState : INT;
bDone : BOOL;
bBusy : BOOL;
bError : BOOL;
nErrorID : DWORD;
Implementierung:
CASE iState OF

0:
bError := FALSE;
nErrorID := 0;
SessionConnectInfo.tConnectTimeout := T#1M;
SessionConnectInfo.tSessionTimeout := T#1M;
SessionConnectInfo.sApplicationName := '';
SessionConnectInfo.sApplicationUri := '';
SessionConnectInfo.eSecurityMode := eUASecurityMsgMode_None;
SessionConnectInfo.eSecurityPolicyUri := eUASecurityPolicy_None;
SessionConnectInfo.eTransportProfileUri := eUATransportProfileUri_UATcp;
stNodeAddInfo.nIndexRangeCount := nIndexRangeCount;
stNodeAddInfo.stIndexRange := stIndexRange;
iState := iState + 1;

1:
fbUA_Connect(
Execute := TRUE,
ServerURL := ‘opc.tcp://192.168.1.1:4840’,
SessionConnectInfo := SessionConnectInfo,
Timeout := T#5S,
ConnectionHdl => nConnectionHdl);
IF NOT fbUA_Connect.Busy THEN
fbUA_Connect(Execute := FALSE);
IF NOT fbUA_Connect.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_Connect.ErrorID;
nConnectionHdl := 0;
iState := 0;
END_IF
END_IF

2:
fbUA_Disconnect(
Execute := TRUE,
ConnectionHdl := nConnectionHdl);

IF NOT fbUA_Disconnect.Busy THEN
fbUA_Disconnect(Execute := FALSE);
IF NOT fbUA_Disconnect.Error THEN
iState := 0;
ELSE
bError := TRUE;
nErrorID := fbUA_Disconnect.ErrorID;
iState := 0;
nConnectionHdl := 0;
END_IF
END_IF

END_CASE


Wie die Knoten auszulesen sind

Technische Einführung [image] TwinCAT OPC UA Client [image] Best Practice [image] Wie die Knoten auszulesen sind
Wie die Knoten auszulesen sind
Im nachfolgenden Abschnitt wird beschrieben, wie die TcX_PLCopen_OpcUa-Funktionsbausteine verwendet werden sollten, um einen OPC‑UA‑Knoten von einem lokalen oder entfernten OPC UA Server auszulesen.
HINWEIS! Lesen Sie zunächst den Abschnitt „Wie eine Verbindung hergestellt wird“.
Dieser Abschnitt beinhaltet folgende Themen:
▪
Übersicht
▪
Schematischer Arbeitsablauf
▪
Zu berücksichtigende Punkte
▪
Code-Ausschnitt
Übersicht
Die folgenden Funktionsbausteine sind erforderlich, um eine Verbindung zu einem OPC UA Server herzustellen, UA-Knoten auszulesen und später die Sitzung zu unterbrechen: UA_Connect, UA_GetNamespaceIndex, UA_NodeGetHandle, UA_Read, UA_NodeReleaseHandle, UA_Disconnect.
HINWEIS! Lesen Sie zunächst den Abschnitt „Wie Kommunikationsparameter zu bestimmen sind“, um bestimmte UA-Funktionalitäten besser verstehen zu können (z. B. wie Node Identifier bestimmt werden können).
Schematischer Arbeitsablauf
Der schematische Arbeitsablauf jedes TwinCAT OPC UA Client kann in drei verschiedene Phasen kategorisiert werden: Preparation, Work und Cleanup.
Der in diesem Abschnitt beschriebene Verwendungsfall kann wie folgt visualisiert werden:
Grafik aus How to read nodes (i4flrbo.emf)
Zu berücksichtigende Punkte
▪
Der Funktionsbaustein UA_Connect erfordert die folgenden Informationen, um eine Verbindung zu einem lokalen oder entfernten OPC UA Server herstellen zu können (siehe auch Wie eine Verbindung hergestellt wird):
–
Server URL
–
Session Connect Information
▪
Der Funktionsbaustein UA_GetNamespaceIndex erfordert einen Connection Handle (von UA_Connect) und Namespace URI zur Auflösung in einen Namespace Index, was später von UA_NodeGetHandle verwendet wird, um einen Knotenhandle zu erfassen.
Das Konzept von Namespace URIs und Namespace Index wird im Abschnitt Wie Kommunikationsparameter zu bestimmen sind erläutert.
▪
Der Funktionsbaustein UA_NodeGetHandle erfordert einen Connection Handle (von UA_Connect) und NodeID (von ST_UANodeID), um einen Knotenhandle zu erfassen.
Das Konzept von NodeID wird im Abschnitt Wie Kommunikationsparameter zu bestimmen sind erläutert.
▪
Der Funktionsbaustein UA_Read erfordert einen Verbindungshandle (von UA_Connect), Knotenhandle (von UA_NodeGetHandle) und Zeiger zur Zielvariablen (wo der ausgelesene Wert gespeichert werden sollte).
Stellen Sie dabei sicher, dass die Zielvariable den korrekten Datentyp aufweist (siehe Wie Kommunikationsparameter zu bestimmen sind).
▪
Der Funktionsbaustein UA_NodeReleaseHandle erfordert den Verbindungshandle (von UA_Connect) und Knotenhandle (von UA_NodeGetHandle).
Code-Ausschnitt
Deklaration:
(* Declarations for UA_GetNamespaceIndex *)
fbUA_GetNamespaceIndex : UA_GetNamespaceIndex;
nNamespaceIndex : UINT;

(* Declarations for UA_NodeGetHandle *)
fbUA_NodeGetHandle : UA_NodeGetHandle;
NodeID : ST_UANodeID;
nNodeHdl : DWORD;

(* Declarations for UA_Read *)
fbUA_Read : UA_Read;
stIndexRange : ARRAY [1..nMaxIndexRange] OF ST_UAIndexRange;
nIndexRangeCount : UINT;
stNodeAddInfo : ST_UANodeAdditionalInfo;
sNodeIdentifier : STRING(MAX_STRING_LENGTH) := 'MAIN.nCounter';
nReadData : INT;
cbDataRead : UDINT;

(* Declarations for UA_NodeReleaseHandle *)
fbUA_NodeReleaseHandle : UA_NodeReleaseHandle;
Implementierung:
CASE iState OF
0:
[...]

2: (* GetNS Index *)
fbUA_GetNamespaceIndex(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NamespaceUri := sNamespaceUri,
NamespaceIndex => nNamespaceIndex
);
IF NOT fbUA_GetNamespaceIndex.Busy THEN
fbUA_GetNamespaceIndex(Execute := FALSE);
IF NOT fbUA_GetNamespaceIndex.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_GetNamespaceIndex.ErrorID;
iState := 6;
END_IF
END_IF

3: (* UA_NodeGetHandle *)
NodeID.eIdentifierType := eUAIdentifierType_String;
NodeID.nNamespaceIndex := nNamespaceIndex;
NodeID.sIdentifier := sNodeIdentifier;
fbUA_NodeGetHandle(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NodeID := NodeID,
NodeHdl => nNodeHdl);
IF NOT fbUA_NodeGetHandle.Busy THEN
fbUA_NodeGetHandle(Execute := FALSE);
IF NOT fbUA_NodeGetHandle.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_NodeGetHandle.ErrorID;
iState := 6;
END_IF
END_IF

4: (* UA_Read *)
fbUA_Read(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NodeHdl := nNodeHdl,
cbData := SIZEOF(nReadData),
stNodeAddInfo := stNodeAddInfo,
pVariable := ADR(nReadData));
IF NOT fbUA_Read.Busy THEN
fbUA_Read( Execute := FALSE, cbData_R => cbDataRead);
IF NOT fbUA_Read.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_Read.ErrorID;
iState := 6;
END_IF
END_IF

5: (* Release Node Handle *)
fbUA_NodeReleaseHandle(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NodeHdl := nNodeHdl);
IF NOT fbUA_NodeReleaseHandle.Busy THEN
fbUA_NodeReleaseHandle(Execute := FALSE);
IF NOT fbUA_NodeReleaseHandle.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_NodeReleaseHandle.ErrorID;
iState := 6;
END_IF
END_IF

6:
[...]

END_CASE


Wie Knoten zu schreiben sind

Technische Einführung [image] TwinCAT OPC UA Client [image] Best Practice [image] Wie Knoten zu schreiben sind
Wie Knoten zu schreiben sind
Im nachfolgenden Abschnitt wird beschrieben, wie die TcX_PLCopen_OpcUa-Funktionsbausteine verwendet werden sollten, um Werte in einem OPC‑UA‑Knoten von einem lokalen oder entfernten OPC UA Server zu schreiben.
HINWEIS! Lesen Sie zunächst den Abschnitt „Wie eine Verbindung hergestellt wird“.
Dieser Abschnitt beinhaltet folgende Themen:
▪
Übersicht
▪
Schematischer Arbeitsablauf
▪
Zu berücksichtigende Punkte
▪
Code-Ausschnitt
Übersicht
Die folgenden Funktionsbausteine sind erforderlich, um eine Verbindung zu einem OPC UA Server herzustellen, UA-Knoten zu schreiben und später die Sitzung zu unterbrechen: UA_Connect, UA_GetNamespaceIndex, UA_NodeGetHandle, UA_Write, UA_NodeReleaseHandle, UA_Disconnect.
HINWEIS! Lesen Sie zunächst den Abschnitt „Wie Kommunikationsparameter zu bestimmen sind“, um bestimmte UA-Funktionalitäten besser verstehen zu können (z. B. wie Node Identifier bestimmt werden können).
Schematischer Arbeitsablauf
Der schematische Arbeitsablauf jedes TwinCAT OPC UA Client kann in drei verschiedene Phasen kategorisiert werden: Preparation, Work und Cleanup.
Der in diesem Abschnitt beschriebene Verwendungsfall kann wie folgt visualisiert werden:
Grafik aus How to write nodes (i6bamlo2.emf)
Zu berücksichtigende Punkte
▪
Der Funktionsbaustein UA_Connect erfordert die folgenden Informationen, um eine Verbindung zu einem lokalen oder entfernten OPC UA Server herstellen zu können (siehe Wie eine Verbindung hergestellt wird):
–
Server URL
–
Session Connect Information
▪
Der Funktionsbaustein UA_GetNamespaceIndex erfordert einen Connection Handle (von UA_Connect) und Namespace URI zur Auflösung in einen Namespace Index, was später von UA_NodeGetHandle verwendet wird, um einen Knotenhandle zu erfassen.
Das Konzept von Namespace URIs und Namespace Index wird im Abschnitt Wie Kommunikationsparameter zu bestimmen sind erläutert.
▪
Der Funktionsbaustein UA_NodeGetHandle erfordert einen Connection Handle (von UA_Connect) und NodeID (von ST_UANodeID), um einen Knotenhandle zu erfassen.
Das Konzept von NodeID wird im Abschnitt Wie Kommunikationsparameter zu bestimmen sind beschrieben.
▪
Der Funktionsbaustein UA_Write erfordert einen Verbindungshandle (von UA_Connect), Knotenhandle (von UA_NodeGetHandle) und Zeiger zu einer Variablen, die den Wert enthält, der geschrieben werden soll.
Stellen Sie dabei sicher, dass die Zielvariable den korrekten Datentyp aufweist (siehe Wie Kommunikationsparameter zu bestimmen sind).
▪
Der Funktionsbaustein UA_NodeReleaseHandle erfordert den Verbindungshandle (von UA_Connect) und Knotenhandle (von UA_NodeGetHandle).
Code-Ausschnitt
Deklaration:
(* Declarations for UA_GetNamespaceIndex *)
fbUA_GetNamespaceIndex : UA_GetNamespaceIndex;
nNamespaceIndex : UINT;

(* Declarations for UA_NodeGetHandle *)
fbUA_NodeGetHandle : UA_NodeGetHandle;
NodeID : ST_UANodeID;
nNodeHdl : DWORD;

(* Declarations for UA_Write *)
fbUA_Write : UA_Write;
stIndexRange : ARRAY [1..nMaxIndexRange] OF ST_UAIndexRange;
nIndexRangeCount : UINT;
stNodeAddInfo : ST_UANodeAdditionalInfo;
sNodeIdentifier: STRING(MAX_STRING_LENGTH) := 'MAIN.nNumber';
nWriteData: INT := 42;

(* Declarations for UA_NodeReleaseHandle *)
fbUA_NodeReleaseHandle : UA_NodeReleaseHandle;
Implementierung:
CASE iState OF
0:
[...]

2: (* GetNS Index *)
fbUA_GetNamespaceIndex(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NamespaceUri := sNamespaceUri,
NamespaceIndex => nNamespaceIndex
);
IF NOT fbUA_GetNamespaceIndex.Busy THEN
fbUA_GetNamespaceIndex(Execute := FALSE);
IF NOT fbUA_GetNamespaceIndex.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_GetNamespaceIndex.ErrorID;
iState := 6;
END_IF
END_IF

3: (* UA_NodeGetHandle *)
NodeID.eIdentifierType := eUAIdentifierType_String;
NodeID.nNamespaceIndex := nNamespaceIndex;
NodeID.sIdentifier := sNodeIdentifier;
fbUA_NodeGetHandle(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NodeID := NodeID,
NodeHdl => nNodeHdl);
IF NOT fbUA_NodeGetHandle.Busy THEN
fbUA_NodeGetHandle(Execute := FALSE);
IF NOT fbUA_NodeGetHandle.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_NodeGetHandle.ErrorID;
iState := 6;
END_IF
END_IF

4: (* UA_Write *)
fbUA_Write(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NodeHdl := nNodeHdl,
stNodeAddInfo := stNodeAddInfo,
cbData := SIZEOF(nWriteData),
pVariable := ADR(nWriteData));
IF NOT fbUA_Write.Busy THEN
fbUA_Write(
Execute := FALSE,
pVariable := ADR(nWriteData));
IF NOT fbUA_Write.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_Write.ErrorID;
iState := 6;
END_IF
END_IF

5: (* Release Node Handle *)
fbUA_NodeReleaseHandle(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NodeHdl := nNodeHdl);
IF NOT fbUA_NodeReleaseHandle.Busy THEN
fbUA_NodeReleaseHandle(Execute := FALSE);
IF NOT fbUA_NodeReleaseHandle.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_NodeReleaseHandle.ErrorID;
iState := 6;
END_IF
END_IF

6:
[...]

END_CASE


Wie Methoden aufzurufen sind

Technische Einführung [image] TwinCAT OPC UA Client [image] Best Practice [image] Wie Methoden aufzurufen sind
Wie Methoden aufzurufen sind
Im nachfolgenden Abschnitt wird beschrieben, wie die TcX_PLCopen_OpcUa-Funktionsbausteine verwendet werden sollten, um Methoden auf einem lokalen oder entfernten OPC UA Server aufzurufen.
HINWEIS! Lesen Sie zunächst den Abschnitt „Wie eine Verbindung hergestellt wird“.
Dieser Abschnitt beinhaltet folgende Themen:
▪
Übersicht
▪
Schematischer Arbeitsablauf
▪
Zu berücksichtigende Punkte
▪
Code-Ausschnitt
Übersicht
Die folgenden Funktionsbausteine sind erforderlich, um eine Verbindung zu einem OPC UA Server herzustellen, UA-Methoden aufzurufen und später die Sitzung zu unterbrechen: UA_Connect, UA_GetNamespaceIndex, UA_MethodGetHandle, UA_MethodCall, UA_MethodReleaseHandle, UA_Disconnect.
HINWEIS! Lesen Sie zunächst den Abschnitt „Wie Kommunikationsparameter zu bestimmen sind“, um bestimmte UA-Funktionalitäten besser verstehen zu können (z. B. wie Method Identifier bestimmt werden können).
Schematischer Arbeitsablauf
Der schematische Arbeitsablauf jedes TwinCAT OPC UA Client kann in drei verschiedene Phasen kategorisiert werden: Preparation, Work und Cleanup.
Der in diesem Abschnitt beschriebene Verwendungsfall kann wie folgt visualisiert werden:
Grafik aus How to call methods (ih9iml21.emf)
Zu berücksichtigende Punkte
▪
Der Funktionsbaustein UA_Connect erfordert die folgenden Informationen, um eine Verbindung zu einem lokalen oder entfernten OPC UA Server herstellen zu können (siehe Wie eine Verbindung hergestellt wird):
–
Server URL
–
Session Connect Information
▪
Der Funktionsbaustein UA_GetNamespaceIndex erfordert einen Connection Handle (von UA_Connect) und Namespace URI zur Auflösung in einen Namespace Index, was später von UA_NodeGetHandle verwendet wird, um einen Knotenhandle zu erfassen.
Das Konzept von Namespace URIs und Namespace Index wird im Abschnitt Wie Kommunikationsparameter zu bestimmen sind erläutert.
▪
Der Funktionsbaustein UA_MethodGetHandle erfordert einen Connection Handle (von UA_Connect), eine Object NodeID und Method NodeID, um einen Methodenhandle zu erfassen.
Die Konzepte von Object und Method NodeID werden im Abschnitt Wie Kommunikationsparameter zu bestimmen sind erläutert.
▪
Der Funktionsbaustein UA_MethodCall erfordert einen Verbindungshandle (von UA_Connect), Methodenhandle (von UA_MethodGetHandle) und Informationen über die Eingangs- und Ausgangsargumente der Methode, die aufgerufen werden soll. Informationen über die Eingangsargumente werden durch die Eingangsparameter pInputArgInfo und pInputArgData von UA_MethodCall repräsentiert. Information über die Ausgangsparameter werden durch die pOutputArgInfo und pOutputArgData Eingangsparameter von UA_MethodCall repräsentiert. Der Eingangsparameter pOutputArgInfoAndData stellt dann einen Zeiger zu einer Struktur dar, die die Ergebnisse des Methodenaufrufs enthält, einschließlich aller Ausgangsparameter. In dem nachstehenden Code-Ausschnitt werden die pInputArgInfo und pInputArgData Parameter in der M_Init() Methode berechnet und erstellt.
▪
Der Funktionsbaustein UA_NodeReleaseHandle erfordert den Verbindungshandle (von UA_Connect) und Methodenhandle (von UA_MethodGetHandle).
Code-Ausschnitt
M_Init–Initialisierungsmethode des Funktionsbausteins, der den UA Methodenaufruf enthält
MEMSET(ADR(nInputData),0,SIZEOF(nInputData));
nArg := 1;

(********** Input parameter 1 **********)
InputArguments[nArg].DataType := eUAType_Int16;
InputArguments[nArg].ValueRank := -1; (* Scalar = -1 or Array *)
InputArguments[nArg].ArrayDimensions[1] := 0; (* Number of Dimension in case its an array *)
InputArguments[nArg].nLenData := SIZEOF(numberIn1); (* Length if its a STRING *)
IF nOffset + SIZEOF(numberIn1) > nInputArgSize THEN
bInputDataError := TRUE;
RETURN;
ELSE
MEMCPY(ADR(nInputData)+nOffset,ADR(numberIn1),SIZEOF(numberIn1)); (* VALUE in BYTES FORM *)
nOffset := nOffset + SIZEOF(numberIn1);
END_IF
nArg := nArg + 1;

(********** Input parameter 2 **********)
InputArguments[nArg].DataType := eUAType_Int16;
InputArguments[nArg].ValueRank := -1; (* Scalar = -1 or Array *)
InputArguments[nArg].ArrayDimensions[1] := 0; (* Number of Dimension in case its an array *)
InputArguments[nArg].nLenData := SIZEOF(numberIn2); (* Length if its a STRING *)
IF nOffset + SIZEOF(numberIn2) > nInputArgSize THEN
bInputDataError := TRUE;
RETURN;
ELSE
MEMCPY(ADR(nInputData)+nOffset,ADR(numberIn2),SIZEOF(numberIn2));(* VALUE in BYTES FORM *)
nOffset := nOffset + SIZEOF(numberIn2);
END_IF

cbWriteData := nOffset;
Deklaration:
(* Declarations for UA_GetNamespaceIndex *)
fbUA_GetNamespaceIndex : UA_GetNamespaceIndex;
nNamespaceIndex : UINT;

(* Declarations for UA_MethodGetHandle *)
fbUA_MethodGetHandle: UA_MethodGetHandle;
ObjectNodeID: ST_UANodeID;
MethodNodeID: ST_UANodeID;
nMethodHdl: DWORD;

(* Declarations for UA_MethodCall *)
fbUA_MethodCall: UA_MethodCall;
sObjectNodeIdIdentifier : STRING(MAX_STRING_LENGTH) := 'MAIN.fbMathematics';
sMethodNodeIdIdentifier : STRING(MAX_STRING_LENGTH) := 'MAIN.fbMathematics#M_Mul';
nAdrWriteData: PVOID;
numberIn1: INT := 42; // change according to input value and data type
numberIn2: INT := 42; // change according to input value and data type
numberOutPro: DINT; // result (output parameter of M_Mul())
cbWriteData: UDINT; // calculated automatically by M_Init()
InputArguments: ARRAY[1..2] OF ST_UAMethodArgInfo; // change according to input parameters
stOutputArgInfo: ARRAY[1..1] OF ST_UAMethodArgInfo; // change according to output parameters
stOutputArgInfoAndData: ST_OutputArgInfoAndData;
nInputData: ARRAY[1..4] OF BYTE; // numberIn1(INT16)(2) + numberIn2(INT16)(2)
nOffset: UDINT; // calculated by M_Init()
nArg: INT; // used by M_Init()

(* Declarations for UA_MethodReleaseHandle *)
fbUA_MethodReleaseHandle: UA_MethodReleaseHandle;
Implementierung:
CASE iState OF
0:
[...]

2: (* GetNS Index *)
fbUA_GetNamespaceIndex(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
NamespaceUri := sNamespaceUri,
NamespaceIndex => nNamespaceIndex);
IF NOT fbUA_GetNamespaceIndex.Busy THEN
fbUA_GetNamespaceIndex(Execute := FALSE);
IF NOT fbUA_GetNamespaceIndex.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_GetNamespaceIndex.ErrorID;
iState := 7;
END_IF
END_IF

3: (* Get Method Handle *)
ObjectNodeID.eIdentifierType := eUAIdentifierType_String;
ObjectNodeID.nNamespaceIndex := nNamespaceIndex;
ObjectNodeID.sIdentifier := sObjectNodeIdIdentifier;
MethodNodeID.eIdentifierType := eUAIdentifierType_String;
MethodNodeID.nNamespaceIndex := nNamespaceIndex;
MethodNodeID.sIdentifier := sMethodNodeIdIdentifier;

M_Init();

IF bInputDataError = FALSE THEN
iState := iState + 1;
ELSE
bBusy := FALSE;
bError := TRUE;
nErrorID := 16#70A; //out of memory
END_IF

4: (* Method Get Handle *)
fbUA_MethodGetHandle(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
ObjectNodeID := ObjectNodeID,
MethodNodeID := MethodNodeID,
MethodHdl => nMethodHdl);
IF NOT fbUA_MethodGetHandle.Busy THEN
fbUA_MethodGetHandle(Execute := FALSE);
IF NOT fbUA_MethodGetHandle.Error THEN
iState := iState + 1;
ELSE
bError := TRUE;
nErrorID := fbUA_MethodGetHandle.ErrorID;
iState := 6;
END_IF
END_IF

5: (* Method Call *)
stOutputArgInfo[1].nLenData := SIZEOF(stOutputArgInfoAndData.pro);
fbUA_MethodCall(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
MethodHdl := nMethodHdl,
nNumberOfInputArguments := nNumberOfInputArguments,
pInputArgInfo := ADR(InputArguments),
cbInputArgInfo := SIZEOF(InputArguments),
pInputArgData := ADR(nInputData),
cbInputArgData := cbWriteData,
pInputWriteData := 0,
cbInputWriteData := 0,
nNumberOfOutputArguments := nNumberOfOutputArguments,
pOutputArgInfo := ADR(stOutputArgInfo),
cbOutputArgInfo := SIZEOF(stOutputArgInfo),
pOutputArgInfoAndData := ADR(stOutputArgInfoAndData),
cbOutputArgInfoAndData := SIZEOF(stOutputArgInfoAndData));
IF NOT fbUA_MethodCall.Busy THEN
fbUA_MethodCall(Execute := FALSE);
IF NOT fbUA_MethodCall.Error THEN
iState := iState + 1;
numberOutPro := stOutputArgInfoAndData.pro;
ELSE
bError := TRUE;
nErrorID := fbUA_MethodCall.ErrorID;
iState := 6;
END_IF
END_IF

6: (* Release Method Handle *)
fbUA_MethodReleaseHandle(
Execute := TRUE,
ConnectionHdl := nConnectionHdl,
MethodHdl := nMethodHdl);
IF NOT fbUA_MethodReleaseHandle.Busy THEN
fbUA_MethodReleaseHandle(Execute := FALSE);
bBusy := FALSE;
IF NOT fbUA_MethodReleaseHandle.Error THEN
iState := 7;
ELSE
bError := TRUE;
nErrorID := fbUA_MethodReleaseHandle.ErrorID;
iState := 7;
END_IF
END_IF

7:
[...]

END_CASE


Sicherheit

Technische Einführung [image] TwinCAT OPC UA Client [image] Sicherheit
Sicherheit
Weiterführende Informationen
•
Übersicht
•
Zertifikatsaustausch


Übersicht

Technische Einführung [image] TwinCAT OPC UA Client [image] Sicherheit [image] Übersicht
Übersicht
Sicherheit ist eine zentrale Anforderung bei der Entwicklung von OPC UA. Sie wird in verschiedenen Bereichen adressiert:
▪
Verschlüsselung
▪
Integrität
▪
Authentifizierung
Die Vertraulichkeit der ausgetauschten Information wird durch die Verschlüsselung der ausgetauschten Nachrichten sichergestellt. Dabei werden moderne Kryptographie-Algorithmen verwendet. Um auch den zukünftigen Sicherheitsanforderungen gewachsen zu sein, können im Nachhinein noch stärkere und modernere Algorithmen einer Anwendung hinzugefügt werden, ohne das Protokoll zu verändern.
Entsprechend der Anforderungen der jeweiligen Anwendung können verschiedene Sicherheitsstufen gewählt werden. In einigen Bereichen ist es ausreichend die Nachrichten zu signieren, um Änderungen durch Dritte auszuschließen, in anderen Fällen dürfen Daten auch nicht von Dritten gelesen werden und ein zusätzliches Verschlüsseln der Nachrichten ist erforderlich.
TF6100 OPC UA bietet die folgenden Security-Level (Security-Endpunkte) an, mit denen Clients sich verbinden können:
▪
None: Keine Sicherheit
▪
Sign: Signiert Nachrichten
▪
Sign&Encrypt: Signiert und verschlüsselt Nachrichten
Das Signieren der Nachrichten verhindert das Ändern des Inhalts einer Nachricht durch einen Dritten. So wird verhindert, dass beispielsweise eine Schreibanweisung zum Öffnen eines Schalters durch einen Dritten verfälscht wird und der Schalter stattdessen geschlossen wird.
OPC‑UA‑Anwendungen identifizieren sich über so genannte Software- und Applikationsinstanz-Zertifikate. Mithilfe von Software-Zertifikaten ist es möglich, bestimmten Client Anwendungen einen erweiterten Zugriff auf Informationen eines OPC UA Servers zu geben, beispielsweise für das Engineering eines OPC UA Servers. Durch Applikationsinstanz-Zertifikate kann sichergestellt werden, dass ein OPC UA Server nur mit vorkonfigurierten Clients kommuniziert. Ein Client kann durch das Applikationsinstanz-Zertifikat des Servers sicherstellen, dass er mit dem richtigen Server spricht (ähnlich der Zertifikate eines Web-Browsers). Die Berücksichtigung dieser Zertifikate ist optional, d. h. ein OPC UA Server kann auch jedem Client den gleichen Zugriff abhängig der Benutzerrechte geben.
Der TwinCAT OPC UA Client und TwinCAT OPC UA Server erzeugen ein selbst-signiertes Zertifikat während des ersten Startvorgangs. Dieses Zertifikat besteht aus einem privaten und einem öffentlichen Schlüssel. Der private Schlüssel wird in dem Verzeichnis \PKI\CA\private und der entsprechende öffentliche Schlüssel unter \PKI\CA\certs abgelegt. Wenn ein beliebiger OPC UA Client eine gesicherte Verbindung über einen der Security-Endpunkte (Sign, Sign&Encrypt) mit dem Server herstellen will, muss der Client den öffentlichen Schlüssel des OPC UA Servers kennen. Umgekehrt muss der OPC UA Server den öffentlichen Schlüssel des Clients kennen. Dieser sogenannte Schlüsselaustausch wird in den folgenden Artikeln beschrieben:
▪
Authentifizierung
▪
Zertifikatsaustausch
▪
Zugriffsrechte


Zertifikatsaustausch

Technische Einführung [image] TwinCAT OPC UA Client [image] Sicherheit [image] Zertifikatsaustausch
Zertifikatsaustausch
Die Kommunikation zwischen einem OPC UA Client und einem OPC UA Server kann optional durch Kommunikation mit einem gesicherten Endpunkt abgesichert werden. Standardmäßig generieren sowohl der TwinCAT OPC UA Server als auch der TwinCAT OPC UA Client beim ersten Start ein maschinenspezifisches, selbstsigniertes Zertifikat zur Authentifizierung.
Wenn Sie in Ihrer Umgebung eine solche verschlüsselte Kommunikationsverbindung verwenden möchten, müssen Sie ein Vertrauensverhältnis zwischen OPC UA Server und OPC UA Client herstellen.
Grafik aus Certificate exchange (i1oenvg2.png)
Vertrauenseinstellungen auf dem Server
Möchten Sie einen oder mehrere OPC UA Clients über Zertifikate am OPC UA Server authentifizieren, so muss der OPC UA Server den öffentlichen Schlüsseln der Clients vertrauen. Dies kann zum Beispiel über das Dateisystem erfolgen. Der Server verwaltet die Vertrauenseinstellungen für Zertifikate über das Dateisystem.
▪
Vertrauenswürdige Zertifikate: %InstallDir%\Server\PKI\CA\trusted\certs
▪
Abgewiesene Zertifikate: %InstallDir%\Server\PKI\CA\rejected\certs
Durch Verschieben von Client-Zertifikaten zwischen diesen Verzeichnissen können die Vertrauenseinstellungen entsprechend angepasst werden.
Auslesen des Client-Zertifikats
Die folgende Anleitung beschreibt einen einfachen Weg, wie man an das Client-Zertifikat gelangt. Hierbei bauen Sie, ohne vorher das Clientzertifikat auf den UA-Server kopiert zu haben, eine Verbindung zum UA-Server unter Verwendung eines sicheren Endpunkts auf (z. B. Basic128Rsa15/Sign&Encrypt). Diese Verbindung wird vom UA-Server initial natürlich abgewiesen, da dieser dem UA-Client zum derzeitigen Zeitpunkt noch nicht vertraut. Der TwinCAT OPC UA Client würde in diesem Fall z. B. den Fehler 0xE4DD0102 zurückliefern. Nach Abweisen der Verbindungsaufforderung speichert der UA-Server jedoch eine Kopie des Client-Zertifikats im oben genannten „Rejected“-Verzeichnis ab. Der Name des Zertifikats entspricht hierbei dem „Thumbprint“ des Zertifikats und lässt sich somit eindeutig dem Client-Zertifikat zuordnen. Diese Datei können Sie nun direkt in das oben genannte „Trusted“-Verzeichnis verschieben, damit der UA-Server bei allen weiteren Verbindungsanforderungen dem UA-Client vertraut und die Verbindung akzeptiert.
Bekanntmachen des OPC UA Servers beim OPC UA Client
Abhängig vom verwendeten OPC UA Client müssen eventuell unterschiedliche Schritte vorgenommen werden, damit der OPC UA Client dem OPC UA Server vertraut. Typischerweise erfolgt bei Client‑Applikationen mit grafischer Benutzeroberfläche ein Warnhinweis bei der ersten Verbindung mit dem Server, wobei das Server-Zertifikat dann als vertrauenswürdig eingestuft werden kann.
Die folgende Anweisung ist daher nur für den TwinCAT OPC UA Client gültig.
Der öffentliche Schlüssel des OPC UA Servers befindet sich als DER-Datei in dem folgenden Verzeichnis: %InstallDir%\Server\PKI\CA\own\certs
Diese Datei muss beim TwinCAT OPC UA Client in das entsprechende „Trusted“-Verzeichnis kopiert werden: %InstallDir%\Client\PKI\CA\certs


TwinCAT OPC UA Gateway

Technische Einführung [image] TwinCAT OPC UA Gateway
TwinCAT OPC UA Gateway
Weiterführende Informationen
•
Übersicht
•
Quick Start
•
Lizenzierung
•
Setup‑Szenarien
•
Konfigurator
•
Migration von Tx6120


Übersicht

TS6100 | TwinCAT OPC UA
Technische Einführung [image] TwinCAT OPC UA Gateway [image] Übersicht
Übersicht
Das TwinCAT OPC UA Gateway ist die neueste Erweiterung des TS6100/TF6100-Softwareprodukts. Es beinhaltet nicht nur eine herkömmliche OPC‑DA‑Schnittstelle, um ältere OPC‑COM‑DA‑Anwendungen mit dem TwinCAT OPC UA Server zu verbinden und kann demzufolge als der Nachfolger des alten TwinCAT OPC DA Servers (TS6120/TF6120) betrachtet werden, sondern es bietet auch eine OPC‑UA‑Schnittstelle, um mehrere grundlegende TwinCAT OPC UA Server in einen zentralen OPC‑UA‑Serverkanal zu bündeln.
Grafik aus Overview (imgmlqb.png)


Quick Start

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Quick Start
Quick Start
Das TS6100/TF6100‑Setup installiert automatisch das TwinCAT OPC UA Gateway und registriert die Anwendung als einen Windows Service. Das Setup konfiguriert automatisch den Zugang zu einem TwinCAT OPC UA Server, der auf demselben Computer wie das Gateway läuft.
Werden dem Gateway mehr als ein TwinCAT OPC UA Server hinzugefügt, oder läuft der Server auf einem anderen Computer, müssen Änderungen an der Standardkonfiguration vorgenommen werden. Verwenden Sie den Konfigurator, um diese Einstellungen zu konfigurieren.
Hinweis
Konfiguration des TwinCAT OPC UA Servers
Prüfen Sie die Konfiguration des TwinCAT OPC UA Servers und vergewissern Sie sich, dass er wie erwartet arbeitet, bevor Sie fortfahren.
Für weitere Informationen bezüglich der Konfiguration des TwinCAT OPC UA Servers lesen Sie den Quick Start im Kapitel „TwinCAT OPC UA Server“.
QuickStart OPC COM DA
Um einen OPC COM DA Client mit dem Gateway zu verbinden, starten Sie den Client und stellen Sie eine Verbindung zu der folgenden ProgId her:
UnifiedAutomation.UaGateway.1
Grafik aus Quick Start (Capture.PNG)
Beim Durchsuchen des Gateway werden ein oder mehrere TwinCAT OPC UA Server im Namensraum des Gateway sichtbar.
Grafik aus Quick Start (Capture2.PNG)
QuickStart OPC UA
Das Gateway bietet nicht nur eine OPC‑COM‑DA‑Schnittstelle, sondern erlaubt die Aggregation von einem oder mehreren TwinCAT OPC UA Servern. Hierzu öffnet das Gateway ebenfalls eine OPC‑UA‑Schnittstelle. Das Gateway ist über folgende OPC UA Server URL erreichbar:
opc.tcp://[HostnameOrIpAddressOrLocalhost]:48050
Grafik aus Quick Start (iis6mv71.png)
Der Namensraum des Gateway beinhaltet dann alle zugrundeliegenden TwinCAT OPC UA Server.
Grafik aus Quick Start (ihjcbaf1.png)


Lizenzierung

TS6100 | TwinCAT OPC UA
Technische Einführung [image] TwinCAT OPC UA Gateway [image] Lizenzierung
Lizenzierung
Das TwinCAT OPC UA Gateway wird den Kunden kostenfrei geliefert. Es ist kein weiterer Lizenzerwerb erforderlich. Beachten Sie, dass die Gateway‑Komponente ausschließlich für die Verbindung mit TwinCAT OPC UA Servern verwendet werden kann. Die Verbindung mit UA-Servern von Drittanbietern wird programmierungstechnisch verhindert. Wenn die Umgebung des Kundens die Verbindung mit einem UA-Server eines Drittanbieters erforderlich macht, wird das Unified Automation UA-Gateway empfohlen. Diese kann bei http://www.unified-automation.com erworben werden.


Setup‑Szenarien

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Setup‑Szenarien
Setup‑Szenarien
Aufgrund der offenen und flexiblen PC-basierten Automatisierungstechnik von Beckhoff kann das TwinCAT OPC UA Gateway auf verschiedene Arten und Weisen betrieben und installiert werden. Im folgenden Abschnitt werden die verschiedenen Setup-Szenarien beschrieben und die Vor- und Nachteile einer jeden Einrichtung erläutert.
Grafik aus Setup scenarios (io8o9tb3.png)
Gateway und UA‑Server auf demselben Computer
Bei diesem Szenario sind das Gateway und der UA-Server auf demselben Computer installiert. Das Gateway ist mit den Standardeinstellungen konfiguriert, um eine Verbindung mit dem lokalen TwinCAT OPC UA Server mit der folgenden Server-URL herzustellen: opc.tcp://localhost:4840.
Dieses Szenario funktioniert lediglich auf Nicht‑Windows‑CE‑Geräten.
HINWEIS! Der TwinCAT OPC UA Server ist auch für Windows CE erhältlich, aber das Gateway ist nur für big‑WindowsPlattformen erhältlich.
Gateway und UA-Server auf verschiedenen Computern
Bei diesem Szenario sind das Gateway und der UA-Server auf verschiedenen Computern installiert. Das Gateway ist für die Herstellung einer Verbindung mit dem Remote – TwinCAT OPC UA Server konfiguriert, indem dessen entsprechende Server‑URL, z. B. opc.tcp://192.168.1.1:4840, festgelegt wird.
Der TwinCAT OPC UA Server ist möglicherweise auf einem kleinen Embedded-Gerät (z. B. einem CX8090 mit Windows CE) installiert, während die Gateway‑Komponente auf einer getrennten big‑Windows‑Plattform, z. B. einem zentralen Server-Gerät, installiert ist.
Gateway mit mehreren UA-Servergeräten verbunden
Beachten Sie, dass, ungeachtet der oben beschriebenen Szenarien, es selbstverständlich möglich ist, andere TwinCAT OPC UA Server ebenfalls an das Gateway anzuschließen. So kann z. B. das Gateway konfiguriert werden, um auf folgende Server zuzugreifen:
▪
den lokalen TwinCAT OPC UA Server (z. B. opc.tcp://localhost:4840)
▪
einen Remote – TwinCAT OPC UA Server (z. B. opc.tcp://192.168.1.1:4840)
▪
einen anderen Remote - TwinCAT OPC UA Server (z. B. opc.tcp://192.168.1.21:4841)
▪
...


Konfigurator

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Konfigurator
Konfigurator
Weiterführende Informationen
•
Übersicht
•
Allgemeine Einstellungen
•
Zusätzliche UA‑Server
•
Zusätzliche Endpunkte
•
OPC‑COM‑DA‑Einstellungen


Übersicht

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Konfigurator [image] Übersicht
Übersicht
Das UA Gateway Administration Tool ist eine grafische Benutzerschnittstelle für die Konfiguration des Gateway und kann über das Kontextmenü des Gateway-Symbols in der Windows-Taskleiste erreicht werden.
Grafik aus Overview (ill0qe23.png)
Nach dem Starten des Verwaltungswerkzeugs über den Menüeintrag Administrate UaGateway wird die grafische Benutzerschnittstelle eingeblendet. Sie bietet mehrere Konfigurationsoptionen:
▪
Allgemeine Einstellungen
▪
Zusätzliche UA‑Server
▪
Zusätzliche Endpunkte
▪
OPC‑COM‑DA‑Einstellungen


Allgemeine Einstellungen

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Konfigurator [image] Allgemeine Einstellungen
Allgemeine Einstellungen
Grafik aus Overview (i4ohf7e3.png)
Autostart
In diesem Bereich können Sie das Autostart-Verhalten von UaGateway konfigurieren. Wählen Sie UaGateway Runtime Process um den UaGateway Service automatisch beim Einschalten des Computers zu starten. Wählen Sie Notification Area Icon, um das Symbol des Benachrichtigungsbereichs bei der Anmeldung eines Benutzers zu starten.
Startender User (Launching User)
Das UaGateway wird als Windows NT Service ausgeführt. Diesem Service wird ein spezifischer Userkontext zugewiesen, damit COM/DCOM ordnungsgemäß konfiguriert werden können. Der User, den Sie auswählen, wird dem UaGateway Service zugeordnet. Darüber hinaus wird dem User ein LogOnAsService Recht eingeräumt (so kann er/sie den Service starten) und er wird einer lokalen Nutzergruppe hinzugefügt („UaGatewayUsers“). Diese Gruppe wird der Zugriffskontrollliste (ACL, Access Control List) der lokalen Maschine hinzugefügt. Für die ordnungsgemäße COM/DCOM Konfiguration müssen Sie nun nur noch alle User, denen es möglich sein sollte, das UaGateway zu starten und auf es zuzugreifen, zu dieser Gruppe hinzufügen.
Konfigurationsberechtigungen (Configuration Permissions)
Es besteht die Möglichkeit, nur bestimmten Benutzern zu erlauben, die Konfiguration des UaGateway zu verändern, sprich Verbindungen zu grundlegenden Servern hinzuzufügen oder zu entfernen. Sie können aus folgenden Einstellungen auswählen:
▪
Jeder (Everyone)
Jeder (auch die anonym bei UA angemeldeten User), der mit dem UaGateway in Verbindung treten kann, kann die Konfiguration verändern.
▪
Beschränkt auf Betriebssystemnutzer (Limit to operating system users)
Nur lokale User und User von der gleichen Domain können die Konfiguration ändern.
▪
Beschränkt auf Nutzer dieser Gruppe (Limit to users of this group)
Die Berechtigung, die Konfiguration zu ändern, nur den Usern einer bestimmten Gruppe zugestehen. Wenn nicht alle verfügbaren Gruppen in der Drop-down-Liste Group angezeigt werden (oder eine neu erstellt Gruppe fehlt), kann mittels Drücken der Schaltfläche Refresh diese Gruppe erneut eingelesen werden.
Remote‑DCOM‑Zugriff (Remote DCOM Access)
Bei der Aktivierung von Allow Remote Connection to UaGateway OPC COM Server, werden DCOM Port 135 und das ausführbare UaGateway der Firewall-Ausnahmeliste hinzugefügt.
Wird Allow starting UaGateway by DCOM Clients deaktiviert, dann können DCOM‑Clients das UaGateway nicht starten. In diesem Fall kann UaGateway weiterhin mithilfe des Notification Area Icon oder den Startmenüeinträgen gestartet oder gestoppt werden.
UA‑Discovery‑Anmeldung (UA Local Discovery Server)
An dieser Stelle können Sie bestimmen, ob das UaGateway beim OPC UA LDS (Local Discovery Server), falls einer installiert ist, angemeldet werden soll.


Zusätzliche UA‑Server

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Konfigurator [image] Zusätzliche UA‑Server
Zusätzliche UA‑Server
Die Registerkarte Configured UA Servers bietet Optionen für die Konfiguration der zugrundeliegenden TwinCAT OPC UA Server. Standardmäßig stellt das Gateway bereits eine Verbindung mit dem lokalen TwinCAT OPC UA Server (der auf demselben Computer läuft) her.
Grafik aus Additional OPC-UA Servers (issvfbq2.png)
Um weitere TwinCAT OPC UA Server zu konfigurieren oder aus der Konfiguration zu entfernen, klicken Sie auf die Plus- und Minus-Tasten unten rechts und anschließend auf Übernehmen (Apply), um die Änderungen zu speichern.


Zusätzliche Endpunkte

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Konfigurator [image] Zusätzliche Endpunkte
Zusätzliche Endpunkte
Der UA Endpunkt (Endpoint) ist die Verbindungsinformation, die ein UA Client benötigt, um eine Verbindung mit dem Gateway herzustellen. In den folgenden Abschnitten wird die UA‑Endpunktkonfiguration beschrieben.
Allgemeines
Spezifizieren Sie mithilfe der Kontrollkästchen die Anmeldemethoden, die ein Client für die Herstellung einer Verbindung mit Ihrem UaGateway verwenden kann.
Endpunkte
An dieser Stelle können Sie alle notwendigen Einstellungen für verschiedene UA Endpunkte festlegen. Der Endpunkt wird standardmäßig mit Voreinstellungen konfiguriert. Diese stellen einen einzelnen UA Endpunkt dar, der zwei Sicherheitsoptionen anbietet: Keine und Basic128RSsa15.
Die Sicherheitsoption „Keine“ erlaubt jedem UA‑Client die Herstellung einer Verbindung mit dem UaGateway und wird lediglich für die Inbetriebnahme und Prüfung empfohlen, während diese Konfiguration in der Produktionsumgebung ausgeschaltet werden sollte.
Die verschiedenen Konfigurationselemente werden in den folgenden Abschnitten beschrieben.
Netzwerkkonfiguration
Endpunkt URL
Dies ist die Endpunkt URL des UaGateway, so wie sie in FindServers und GetEndpoint Aufrufen zu sehen ist.
Protokoll
Dies ist das für diesen Endpunkt verwendete Protokoll.
Hostname/IP
Dies ist der Hostname des UaGateway (es kann sich auch um die IP-Adresse des PC handeln, auf dem das UaGateway ausgeführt wird).
Netzwerkadapter
Dies ist der Netzwerkadapter, mit dem eine Bindung herzustellen ist. Zur Auswahl stehen:
▪
Alle
Auswahl, dass eine Bindung mit allen IP-Adressen des Computers herzustellen ist. Der Endpunkt wird über den gegebenen Anschluss auf allen IP-Adressen erreichbar sein.
▪
Netzwerkadapter
Wählen Sie einen Netzwerkadapter und eine IP-Adresse (unten), um lediglich eine Bindung mit dieser Adresse herzustellen. Der Endpunkt wird nur für Clients erreichbar sein, die mit der ausgewählten IP-Adresse eine Verbindung herstellen.
▪
Nur lokal
Bei dieser Auswahl stellt das UaGateway lediglich eine Bindung mit dem Loopback-Adapter her. Der Endpunkt ist lediglich für die Clients erreichbar, die auf derselben Maschine wie das UaGateway laufen.
Port
Dies ist das TCP Port des Endpunkts (normalerweise 48050).
Sicherheit
Die unterstützten Sicherheitseinstellungen des Endpunkts können an dieser Stelle konfiguriert werden. Aktivieren Sie die Kontrollkästchen vor den Sicherheitsoptionen, die für einen bestimmten Endpunkt gelten sollen. Für die Optionen ungleich „Keine“, muss der (müssen die) verfügbare(n) Nachrichtensicherheitsmodus (modi) angegeben werden. Die Signierung sorgt dafür, dass Nachrichten nicht verändert werden können und dass sie zwischen den Anwendungen, die eine Verbindung hergestellt haben, ausgetauscht werden. Die Verschlüsselung garantiert, dass niemand die Nachrichten lesen kann.


OPC‑COM‑DA‑Einstellungen

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Konfigurator [image] OPC‑COM‑DA‑Einstellungen
OPC‑COM‑DA‑Einstellungen
Im folgenden Abschnitt wird die Konfiguration des COM DA Servers des UaGateway unter Verwendung des Administrationstools beschrieben.
Allgemeines
ItemIDs des COM DA Server werden aus dem URI‑Namensraum und dem Bezeichner des Variablenknotens im OPC‑UA‑Adressenraum gebildet. Der Namensraumteil kann im Fall eines einzigen Namensraums weggelassen werden. Im Drop-down-Feld Default Name Space kann der standardmäßige Namensraum mit dem Namensraum eines Zugrundeliegenden OPC‑Servers festgelegt werden. Die ItemIDs dieses bestimmten Namensraums können dann mittels ausschließlicher Angabe des Bezeichners erreicht werden, weil beim Zugriff auf ein Element der standardmäßige Namensraum intern automatisch hinzugefügt wird. Dieses Merkmal kann dazu verwendet werden, alle ItemIDs im Client, der auf den UaGateway Server zugreift, neu zu konfigurieren, wenn Letzterer als Tunnellösung für einen zugrundeliegenden COM DA Server fungiert, und um dabei die ItemIDs des ursprünglichen COM DA Servers beizubehalten.
Im zweiten Drop-down-Feld kann die Timestamp Source (Zeitstempelquelle) festgelegt werden. Folgende Optionen stehen zur Auswahl:
▪
Interner
Die Zeitstempel werden vom OPC COM DA Server erzeugt.
▪
SourceTimestamp
Die SourceTimestamps werden als Zeitstempel, die vom OPC COM DA Server bereitgestellt werden, verwendet.
▪
ServerTimestamp
Die ServerTimestamps werden als Zeitstempel, die vom OPC COM DA Server bereitgestellt werden, verwendet.
Eigenschaften-Mapping vom UA zum COM DA
Bei der Herstellung der Verbindung mit dem OPC‑COM‑DA‑Server des UaGateway werden alle sechs Standardeigenschaften (DataType, Value, Quality, TimeStamp, AccessRights und ScanRate) automatisch zugeordnet. Zugrundeliegende OPC‑Server können weitere Eigenschaften (z.B. benutzerdefinierte Eigenschaften, DI-Eigenschaften, usw.) bereitstellen. Diese Eigenschaften können herstellerspezifischen Eigenschaften (PropertyID ≧ 5000) im COM DA Server des UaGateway zugeordnet werden.
Diese herstellerspezifischen PropertyIDs werden automatisch zugeordnet, wenn die Eigenschaften das erste Mal angefordert werden. Mithilfe dieses Dialogs können Sie die zugeordneten PropertyIDs ändern oder konfigurieren, wie die OPC‑UA‑Eigenschaften im UaGateway‑Adressenraum den herstellerspezifischen COM‑DA‑Eigenschaften zuzuordnen sind. Sie müssen den UA-seitigen Eigenschaftennamen und den Namensraum der Eigenschaft im UaGateway festlegen und diese den COM DA PropertyIDs zuordnen. Bei der Herstellung der Verbindung mit dem COM‑DA‑Server des UaGateway können Sie die verfügbaren Eigenschaften (QueryAvailableProperties) eines einzelnen OPCItems durchsuchen und dann werden Sie die zugeordneten Eigenschaften, so wie diese (im Bereich der herstellerspezifischen PropertyIDs oberhalb 5000) konfiguriert wurden, sehen können.
Drücken Sie die Tasten „+“ oder „-“, um eine bestimmte Eigenschaft hinzuzufügen bzw. zu entfernen. Um den Inhalt eines bestimmten Feldes zu ändern, doppelklicken Sie auf dieses und geben die gewünschten Werte ein. Wenn Sie auf einen Wert in der Spalte UA Property NameSpace URI doppelklicken, wird ein Drop-down-Menü eingeblendet, in dem Sie eine Auswahl treffen können.
Wenn Sie durch Drücken auf „+“ eine neue Eigenschaft hinzufügen, werden die Werte des letzten Eintrags in die neue Zeile kopiert und die Property ID automatisch inkrementiert.


Migration von Tx6120

Technische Einführung [image] TwinCAT OPC UA Gateway [image] Migration von Tx6120
Migration von Tx6120
Einer der vorrangigen Zwecke des UA Gateway ist die Bereitstellung einer zukunftsfähigen Konnektivität, um das Supplement Tx6120 OPC DA zu ersetzen. Nutzer, die von Tx6120 OPC DA nach UA Gateway migrieren möchten, müssen einige Dinge bedenken und konfigurieren.
Übersicht der Standardkonfiguration
Die Standardkonfiguration des UA‑Gateway stellt automatisch eine Verbindung mit dem lokalen TwinCAT OPC UA Server her und bietet den OPC DA Clients eine OPC‑DA‑Schnittstelle. Bei einer Verbindung auf der Grundlage dieser Standardkonfiguration müssen die OPC‑DA‑Clients folgende Dinge berücksichtigen:
▪
Die standardmäßige ProgID des UA-Gateway lautet „UnifiedAutomation.Gateway.1“. Der TwinCAT OPC DA Server verwendet eine andere ProgID („Beckhoff.TwinCATOpcServerDA“).
▪
Das UA-Gateway verwendet stets eine ProgID anstelle von mehreren Klonen.
▪
Der Item Identifier eines OPC‑Symbols wird im UA-Gateway anders erzeugt. Dieses Verhalten kann geändert werden.
Wie die Syntax eines Item Identifiers geändert werden kann
Die Syntax, die das UA-Gateway für Item Identifier verwendet, kann verändert werden, damit letztere eher der Art des TwinCAT OPC DA Servers entsprechen. Standardmäßig verwendet das UA‑Gateway bei der Bildung seiner Identifier eine andere Syntax als der TwinCAT OPC DA Server.
Beispiel UA‑Gateway:
Grafik aus Migrating from Tx6120 (ijlkg2r2.png)
Beispiel TwinCAT OPC DA Server:
Grafik aus Migrating from Tx6120 (ih3fnei1.png)
Das UA‑Gateway verwendet ein Präfix, sodass der zugrundeliegende OPC UA Client, von dem die Variable stammt, eindeutig identifiziert werden kann.
Um das UA‑Gateway so zu konfigurieren, dass es seine Identifier in etwa so bildet, wie der TwinCAT OPC DA Server, sind die nachfolgenden Schritte erforderlich. Die Funktionalität wurde implementiert, um den Migrationsprozess zu vereinfachen.
1.
Öffnen Sie die UA-Gateway‑Konfigurationsdatei
C:\Program Files (x86)\UnifiedAutomation\UaGateway\bin\uagateway.config.xml
2.
Suchen Sie nach den folgenden XML-Tags in der XML-Datei:
<OpcServerConfig>
<ComDaServerConfig>
<ComDaNamespaceUseAlias>false</ComDaNamespaceUseAlias>
</ComDaServerConfig>
</OpcServerConfig>
1.
Wenn das ComDaNamespaceUseAlias XML-Tag auf „true“ gesetzt wird, können benutzerdefinierte Präfixes bestimmt werden. Suchen Sie hierfür nach dem folgenden XML-Tag in derselben XML-Datei:
<OpcServerConfig>
<UaServerConfig>
<ConfiguredNamespaces>
...
</ConfiguredNamespaces
</UaServerConfig>
</OpcServerConfig>
1.
Identifizieren Sie in dieser XML‑Struktur den TwinCAT‑OPC‑UA‑Server‑Namensraum. Standardmäßig sollte dieser folgendermaßen lauten:
<OpcServerConfig>
<UaServerConfig>
<ConfiguredNamespaces>
...
<Namespace>
<Index>...</Index>
<Uri>TcOpcUaServer/urn:Hostname:BeckhoffAutomation:Ua:PLC1</Uri>
<AllowRenameUri>false</AllowRenameUri>
<UniqueId>TcOpcUaServer#TcOpcUaServer/urn:Hostname:BeckhoffAutomation:Ua:PLC1</UniqueId>
<ComAlias>...</ComAlias>
</Namespace>
...
</ConfiguredNamespaces
</UaServerConfig>
</OpcServerConfig>
1.
Auf Ihrem Computer kann der Platzhalter „...” anders aussehen. Setzen Sie <ComAlias> auf das von Ihnen bevorzugte Präfix, zum Beispiel „PLC1“. Daraufhin werden die Bezeichner mit dem Präfix „PLC1“ gebildet.
Grafik aus Migrating from Tx6120 (i6tlpkc.png)


TwinCAT OPC UA Sample Client

Technische Einführung [image] TwinCAT OPC UA Sample Client
TwinCAT OPC UA Sample Client
Weiterführende Informationen
•
Übersicht
•
Sichere Verbindung mit OPC UA Server herstellen
•
Im UA-Namensraum browsen
•
Watchliste verwenden


Übersicht

Technische Einführung [image] TwinCAT OPC UA Sample Client [image] Übersicht
Übersicht
Ab Version 1.6.80 des TwinCAT OPC UA Servers wird ein kleines Programm „UA Sample Client“ automatisch installiert. Diese Software ermöglicht den Nutzern, den OPC‑UA‑Namensraum zu durchsuchen und die UA‑Server‑Installierung zu testen. Es befindet sich im Windows Startmenü und im Installationsverzeichnis des/der Supplements/Function. Sie können diesen UA-Client sowohl direkt auf dem UA-Server als auch auf einem Computer in Ihrem Netzwerk ausführen.
Derzeit bietet der UA Sample Client die folgenden Funktionalitäten:
▪
Verbindung mit OPC UA Server herstellen
▪
Sichere Verbindung mit OPC UA Server herstellen (siehe Sichere Verbindung mit OPC UA Server herstellen)
▪
Durchsuchen des UA‑Namensraums eines OPC UA Servers (siehe Im UA-Namensraum browsen)
▪
Hinzufügen eines UA Nodes aus dem Namensraum in die Watchliste, die den Wert des Knotens regelmäßig liest (siehe Watchliste verwenden)
Diese Anwendung ist lediglich ein OPC‑UA‑Beispiel‑Client. Sie bietet keine anspruchsvollen Funktionalitäten, sondern wurde entwickelt, um den Benutzern eine einfach zu bedienende Schnittstelle zur Verfügung zu stellen, um ersteTests beim TwinCAT OPC UA Server durchzuführen
Um die Anwendung zu starten, führen Sie die Datei UA SampleClient.exe mit dem Befehl Als Administrator ausführen aus.
Hinweis
Endpunkte des OPC UA Servers
Der OPC‑UA‑Beispiel‑Client verbindet sich zuerst mit einer spezifizierten Server‑URL. Der Client akquiriert alle Endpunkte des OPC UA Servers (siehe Drop-Down-Liste „Endpunkte”). Die an den Server zurückgesandte Liste enthält dann mehr Informationen über alle verfügbaren Endpunkte, mit denen sich der Client verbinden kann. Jeder Endpunkt kann den Hostnamen des OPC UA Servers anstatt der IP-Adresse enthalten. Der Client verwendet dann die Informationen aus dem Endpunkt zur Verbindung mit dem Server. Wenn die Namenslösung nicht im Netzwerk des Benutzers funktioniert, kann der Client die Verbindung nicht herstellen. Wenn der Endpunkt, mit dem sich der Client verbinden soll, den Hostnahmen des Servers enthält, stellen Sie sicher, dass die Namenslösung in Ihrem Netzwerk funktioniert und dass der Hostname auf dem Server erreichbar ist!


Sichere Verbindung mit OPC UA Server herstellen

Technische Einführung [image] TwinCAT OPC UA Sample Client [image] Sichere Verbindung mit OPC UA Server herstellen
Sichere Verbindung mit OPC UA Server herstellen
1.
Geben Sie im oberen Textfeld des UA Sample Client die URL eines OPC UA Servers ein.
2.
Klicken Sie auf die Schaltfläche Get Endpoints.
⇨
Die vom UA-Server bereitgestellten Endpunkte werden daraufhin in der Drop‑Down-Liste Endpoints angezeigt.
3.
Wählen Sie in diesem Beispiel den Eintrag „<SomeName>/Beckhoff/TcOpcUaServer/1 [Basic128Rsa15, SignAndEncrypt] [opc.tcp://<SomeName>:4840]“ und klicken Sie auf Connect.
HINWEIS! Sie müssen den Public Key vom Zertifikat des UA Sample Clients auf den UA Server kopieren, damit dieser dem Sample Client „vertraut“. Anderenfalls wird der Verbindungsversuch über den sicheren Kanal vom UA‑Server abgewiesen („BadSecureChannelClosed“). Weitere Informationen über das Zertifikatsmanagement beim TwinCAT OPC UA Server finden Sie im Abschnitt Zertifikatsaustausch.
⇨
Über den Browser in der linken Hälfte des Fensters können Sie nun durch den UA‑Namensraum navigieren.


Im UA-Namensraum browsen

TS6100 | TwinCAT OPC UA
Technische Einführung [image] TwinCAT OPC UA Sample Client [image] Im UA-Namensraum browsen
Im UA-Namensraum browsen
Über den Browser in der linken Hälfte des UA Sample Client können Sie nach erfolgreichem Aufbau einer Verbindung durch den UA‑Namensraum navigieren. Unterhalb des Knotens PLC1 finden Sie das momentan laufende SPS-Programm und können sich die dort deklarierten und für UA freigegebenen Variablen anzeigen lassen.


Watchliste verwenden

TS6100 | TwinCAT OPC UA
Technische Einführung [image] TwinCAT OPC UA Sample Client [image] Watchliste verwenden
Watchliste verwenden
Sie können SPS-Variablen aus dem UA-Namensraum in eine Watchlist einfügen, zum Beispiel um deren Werte zyklisch von dem UA Sample Client lesen zu lassen. Öffnen Sie dazu das Kontextmenü einer Variablen und wählen Sie Add to Watchlist. Die Variable wird daraufhin in die Watchlist übernommen und deren Werte werden automatisch zyklisch aus der SPS ausgelesen.


Konfiguration

Konfiguration
Konfiguration
Weiterführende Informationen
•
Setup Version 3.x.x
•
Setup Version 4.x.x


Setup Version 3.x.x

Konfiguration [image] Setup Version 3.x.x
Setup Version 3.x.x
Weiterführende Informationen
•
Übersicht
•
Data Access
•
Historical Access
•
Sicherheit
•
Alarms & Conditions (A&C)
•
Online Panel


Übersicht

Konfiguration [image] Setup Version 3.x.x [image] Übersicht
Übersicht
Dieser Abschnitt soll einen Einblick in den Umgang mit dem TwinCAT‑OPC‑UA‑Konfigurator geben. Der OPC‑UA‑Konfigurator parametrisiert den TwinCAT OPC UA Server bzw. ist eine grafische Benutzeroberfläche zur Konfiguration der ServerConfig.xml-Datei. Er bietet hierbei die folgenden Konfigurationsmöglichkeiten:
▪
Hinzufügen/Entfernen von Geräten zum Data Access (SPS-Laufzeiten, TwinCAT‑3‑C++‑Instanzen, I/O-Tasks)
▪
Aktivieren/Deaktivieren von Historical Access
▪
Aktivieren/Deaktivieren von anonymen Zugriffen bzw. Benutzername/Passwort‑Authentifizierung
▪
Neustart oder Shutdown des OPC UA Servers
Beim Starten des TwinCAT‑OPC‑UA‑Konfigurators wird automatisch die derzeit aktive Konfiguration des TwinCAT OPC UA Servers geladen, welche sich standardmäßig als Datei ServerConfig.xml im Verzeichnis \%InstallDir%\Server\ befindet. Sie können über das Menü aber auch andere ServerConfig.xml-Dateien laden, abspeichern und aktivieren.
Die Benutzeroberfläche des OPC‑UA‑Konfigurators besteht aus den folgenden Bereichen:
▪
Menü-Bereich: Speichern und Aktivieren von Konfigurationen
▪
Kategorien-Bereich: Gruppiert die Einzelparameter in verschiedene Kategorien, z. B. Data Access
▪
Parameter-Bereich: Einzelparameter zum Aktivieren/Deaktivieren bestimmter Features
Konsultieren Sie die Dokumentation der jeweiligen Kategorien, um die Bedeutung der einzelnen Konfigurationsparameter zu erfahren:
▪
Data Access
▪
Historical Access
▪
Sicherheit
▪
Alarms & Conditions (A&C)
▪
Online Panel


Data Access

Konfiguration [image] Setup Version 3.x.x [image] Data Access
Data Access
Die Registerkarte Data Access enthält die Konfigurationseinstellung für TwinCAT‑Runtime‑Geräte. Hier muss ein Gerät konfiguriert werden, wenn es über OPC UA verfügbar sein soll.
Für jedes TwinCAT‑Runtime‑Gerät müssen folgenden Einstellungen erfolgen:
Einstellung | Beschreibung
Name | Anzeige Name der TwinCAT Runtime im OPC‑UA‑Namensraum
AdsNetId | AmsNetId der TwinCAT Runtime. 127.0.0.1.1.1 für eine lokale Laufzeit oder die entsprechende AmsNetId eines Remote-Geräts. ADS-Routen müssen konfiguriert werden, wenn mit einem Remote-Gerät kommuniziert wird.
AdsPort | AdsPort der TwinCAT‑Runtime, z. B. 851 für die erste TwinCAT‑3‑SPS‑Laufzeit.
SymbolFile | Symboldatei, die Informationen über alle verfügbaren Variablen und Objektinstanzen der Laufzeit enthält.
AdsTimeout | Timeout-Einstellung, wenn mit der Ziel-Runtime kommuniziert wird. Es wird empfohlen, diese Einstellung auf dem Standardwert zu belassen.
AdsTimeSuspend | TimeSuspend-Einstellung, wenn mit der Ziel-Runtime kommuniziert wird. Es wird empfohlen, diese Einstellung auf dem Standardwert zu belassen. TimeSuspend Timeout wird ausgelöst, wenn eine Ziel-Runtime vorübergehend nicht verfügbar ist. Der OPC UA Server startet nach TimeSuspend einen erneuten Kommunikationsversuch.
Typ | Typ der Ziel-Runtime, mit der der OPC UA Server kommunizieren soll, z. B. TwinCAT 3 SPS, TwinCAT 2 SPS, ...
AccessMode | Der Zugriffsmodus wird normalerweise nur benötigt, wenn der OPC UA Server mit einer auf einem Beckhoff BC/BX‑Gerät gehosteten Laufzeit kommunizieren soll. In so einem Fall muss die entsprechende Einstellung aktiviert werden. Sonst ist die Standardeinstellung in Ordnung.
LegacyArrayHandling | Wenn auf veralteten OPC UA Clients Array-Elemente als separate UA-Knoten verfügbar sein müssen, aktivieren Sie diese Einstellung.
LegacyUriFormat | Aktiviert verschiedene Namensschemata zum Generieren von NamespaceUri, wie im Abschnitt Generierung von NamespaceUri beschrieben.
ReleaseHandles | Aktiviert die Freigabe von Handles für TwinCAT‑Laufzeitsymbole, wenn UaClients einen Knoten nicht mehr „benötigen“. Das ist der Fall, wenn ein Knoten aus der Überwachung entfernt wird, (DeleteMonitoredItem) oder der Überwachungsmodus eines Elements deaktiviert wird.
ForceIdentifierCase | Gilt nur für die Typen TPY und SYM. Erzwingt die Groß- oder Kleinschreibung der Bezeichner aller Knoten.
Disabled | Kontrollkästchen anklicken, um die Laufzeit zu deaktivieren, sodass sie nicht im OPC‑UA‑Namensraum erscheint.
Weitere Informationen über laufzeitspezifische Parameter erhalten Sie im Abschnitt TwinCAT OPC UA Server.


Historical Access

Konfiguration [image] Setup Version 3.x.x [image] Historical Access
Historical Access
Die Registerkarte Historical Access wird verwendet, um die allgemeinen Einstellungen für Historical Access zu konfigurieren. Hier werden Speichermedien, die für Historical Access verwendet werden sollen, aktiviert und konfiguriert.
Grafik aus Historical Access (ic7f01n1.png)
Weitere Informationen zu Historical Access erhalten Sie im Abschnitt TwinCAT OPC UA Server.


Sicherheit

Konfiguration [image] Setup Version 3.x.x [image] Sicherheit
Sicherheit
Die Registerkarte Server Security ermöglicht allgemeine Einstellungen zu Sicherheits- und Endpunktmechanismen des OPC UA Servers.
Grafik aus Security (in6g9r9.png)
Die folgende Tabelle bietet einen Überblick über die möglichen Einstellungen:
Einstellung | Beschreibung
Benutzeridentität | Aktivierung oder Deaktivierung einer bestimmten Benutzeridentität, z. B. Deaktivierung des Kontrollkästchens „Anonymous Access“ (Anonymer Zugriff), um eine Benutzerauthentifizierung zu erzwingen.
Endpunkte | Aktivierung oder Deaktivierung bestimmter Endpunkte, z. B. zur Deaktivierung des Endpunkts „No security“ (Keine Sicherheit), um UA-Clients zu zwingen, sich mit dem Endpunkt „Sign and Encrypt“ (Signieren und Verschlüsseln) zu verbinden.
Konfiguration des Namensraums | Ermöglicht die Aktivierung oder Deaktivierung der Konfiguration des Namensraums und die Einstellung einer spezifischen Sicherheitsstufe, die für den Zugriff dieses Namensraums erforderlich ist (Benutzerauthentifizierung erforderlich).
Benutzerverwaltung | Ermöglicht die Konfiguration bestehender Benutzerkonten und stellt eine Zugriffsebene für jedes Konto ein. Zugriffsebenen werden derzeit lediglich zur Konfiguration des Zugriffs auf die Konfiguration des Namensraums verwendet. Beachten Sie, dass das Benutzerkonto - wenn der Computer, auf dem der OPC UA Server läuft, ein Mitglied einer Windows-Domäne ist - ebenfalls ein Konto in dieser Domäne sein kann.
Client-Zertifikate | Ermöglicht das Verschieben von OPC‑UA‑Client‑Zertifikaten zwischen den Vertrauenslisten „Abgelehnt“ und „Akzeptiert“. Hier können Client-Zertifikate einfach identifiziert, ihnen vertraut oder diese abgelehnt werden, wenn die Clients mit einem der sicheren Endpunkte verbunden werden.


Alarms & Conditions (A&C)

Konfiguration [image] Setup Version 3.x.x [image] Alarms & Conditions (A&C)
Alarms & Conditions (A&C)
Der Konfigurator Alarms & Conditions ist ein separates grafisches Tool. Es erstellt eine XML-basierte Konfigurationsdatei, mit der der OPC UA Server seine A&C-Konfiguration erstellt.
Graphic from Alarms _ Conditions (io325pi2.png)
Der A&C‑Konfigurator befindet sich im Installationsverzeichnis von TwinCAT OPC UA: C:\TwinCAT\Functions\TF6100-OPC-UA\Win32\ConfiguratorAc.
Der Konfigurator wird folgendermaßen verwendet:
1.
Stellen Sie eine Verbindung mit dem OPC UA Server her, dessen Alarms & Conditions konfiguriert werden sollen. Geben Sie dazu die Server-URL ein und wählen Sie einen Endpunkt, mit dem sich der Konfigurator verbinden soll.
2.
Wenn die Verbindung hergestellt und der Namensraum des Servers sichtbar ist, erstellen Sie einen oder mehrere ConditionController. Ein ConditionController ist eine administrative Einheit, die die aktuelle Alarmkonfiguration als eine oder mehrere Conditions enthält.
3.
Wählen Sie einen ConditionController aus und erzeugen Sie eine oder mehrere Conditions, indem Sie zu überwachende Variablen in das Conditions-Fenster in der unteren rechten Ecke ziehen und dort ablegen.
4.
Folgen Sie schrittweise den Anweisungen der QuickStart-Information des Konfigurators.
Graphic from Alarms _ Conditions (i596mue1.png)


Online Panel

Konfiguration [image] Setup Version 3.x.x [image] Online Panel
Online Panel
Das Online Panel erweitert den TwinCAT‑OPC‑UA‑Konfigurator um OPC‑UA‑Client‑Funktionalitäten. Es ermöglicht den Benutzern die lokale oder Fernverbindung mit einem TwinCAT OPC UA Server zwecks Erhalt von Diagnose- oder Verwaltungsfunktionalitäten.
Grafik aus Online Panel (ids7tsp2.png)
Die folgende Tabelle beschreibt die Bereiche im Online Panel:
Bereich
Beschreibung
Serverinformationen
Liefert allgemeine Diagnoseinformationen des derzeit mit dem TwinCAT OPC UA Server verbundenen Teilnehmers. Mögliche nützliche Informationen:
▪
Lizenzstatus
▪
Anzahl der derzeit hergestellten OPC‑UA‑Client‑Sitzungen
▪
Anzahl verfügbarer Knoten (Berechnung kann einige Zeit in Anspruch nehmen)
▪
Server-Version
Server-Protokollierung
Stellt Funktionalitäten zur Verfügung, um eine Logdatei auf dem TwinCAT OPC UA Server zu aktivieren. Diese sollte aber nur dann verwendet werden, wenn sie vom Beckhoff-Support empfohlen wurde, da die Erstellung der Logdatei die allgemeine Systemleistung beeinträchtigen kann.
Gerätezustände
Stellt Diagnoseinformationen über jedes auf dem TwinCAT OPC UA Server konfigurierte ADS-Gerät zur Verfügung. Diese Information kann sehr hilfreich sein, wenn die Verbindung mit einem ADS-Gerät überprüft werden muss. Häufig auftretendes Konfigurationsproblem kann z.B. darin bestehen, dass die entsprechende Symboldatei (TPY, TMC) nicht vom TwinCAT OPC UA Server geladen werden kann. Das Device States Panel wird in diesem Falle eine entsprechende Fehlermeldung ausgeben.


Setup Version 4.x.x

Konfiguration [image] Setup Version 4.x.x
Setup Version 4.x.x
Weiterführende Informationen
•
Übersicht
•
Anlegen eines neuen Projekts
•
Auswahl eines Zielgeräts
•
Hinzufügen von ADS-Geräten
•
Download/Upload der Konfiguration
•
Import/Export von Konfigurationsdateien
•
Konfiguration von Historical Access
•
Konfiguration von Alarms & Conditions
•
Konfiguration von Alarmtexten
•
Konfiguration der Endpunkte
•
Konfiguration von Zertifikats-Vertrauenseinstellungen
•
Neustart des Servers
•
Troubleshooting & Logging


Übersicht

Konfiguration [image] Setup Version 4.x.x [image] Übersicht
Übersicht
Das TF6100‑Setup (Version 4.x.x und höher) liefert die aktuellste Version des TwinCAT‑OPC‑UA‑Server‑Konfigurators mit aus. Dieser wurde für ein durchgängiges und einheitliches Engineering-Konzept in Microsoft Visual Studio als eigener Projekttyp integriert. Es können alle unterschiedlichen Facetten vom OPC UA Server konfiguriert und hierbei auch Source‑Control‑Mechanismen wie z. B. Team Foundation Server oder Subversion Integrationen verwendet werden.
Graphic from Übersicht (2017-10-24 09_37_24-Windows 7 Professional (32-bit) (Sicherungspunkt 2) [wird ausgeführt] - Oracle V.png)
Toolbar
Über die Toolbar des OPC‑UA‑Konfigurators kann eine Verbindung mit einem lokalen oder remote TwinCAT OPC UA Server hergestellt werden. Sämtliche Konfigurationseinstellungen können dann für den jeweils selektierten Server vorgenommen werden.
Graphic from Übersicht (irmvtih1.png)
Wenn die Toolbar nicht eingeblendet ist, können Sie diese über die Toolbar-Liste von Visual Studio hinzufügen.
Graphic from Übersicht (ifr7kfv2.png)
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Anlegen eines neuen Projekts

Konfiguration [image] Setup Version 4.x.x [image] Anlegen eines neuen Projekts
Anlegen eines neuen Projekts
Das Projektpaket vom TwinCAT‑OPC‑UA‑Server‑Konfigurator bindet sich in das sogenannte Connectivity-Paket ein und kann beim Anlegen eines neuen Visual‑Studio‑Projekts ausgewählt werden.
Graphic from Anlegen eines neuen Projekts (2017-11-02 14_27_36-Windows 7 Professional (32-bit) (Sicherungspunkt 2) [wird ausgeführt] - Oracle V.png)
Graphic from Anlegen eines neuen Projekts (2017-11-02 14_29_00-Windows 7 Professional (32-bit) (Sicherungspunkt 2) [wird ausgeführt] - Oracle V.png)
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Auswahl eines Zielgeräts

Konfiguration [image] Setup Version 4.x.x [image] Auswahl eines Zielgeräts
Auswahl eines Zielgeräts
Der TwinCAT‑OPC‑UA‑Server‑Konfigurator ermöglicht die vollständige Parametrisierung des Servers über OPC UA. Ähnlich wie im TwinCAT‑XAE‑System kann über eine Toolbar ein Ziel-OPC-UA-Server ausgewählt werden.
Graphic from Auswahl eines Zielgeräts (2017-11-02 14_39_54-Windows 7 Professional (32-bit) (Sicherungspunkt 2) [wird ausgeführt] - Oracle V.png)
Sämtliche Einstellungen in der Konfiguration werden dann für diesen OPC UA Server vorgenommen. Grundlage hierfür ist der sogenannte Konfigurations-Namespace des Servers.
Graphic from Auswahl eines Zielgeräts (ito06p.png)
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Hinzufügen von ADS-Geräten

Konfiguration [image] Setup Version 4.x.x [image] Hinzufügen von ADS-Geräten
Hinzufügen von ADS-Geräten
Der TwinCAT OPC UA Server kann mit einem oder mehreren ADS-Geräten „sprechen“. Zur Herstellung einer Verbindung ist eine Route zu dem jeweiligen ADS-Gerät erforderlich. Im Konfigurator werden ADS-Geräte im Bereich Data Access angelegt, konfiguriert und somit dem OPC UA Server bekannt gegeben. Über das Kontextmenü und den dortigen Befehl Add new Device Type können neue ADS-Geräte hinzugefügt werden. Nach Ausführung des Befehls öffnet sich ein Dialogfenster, in dem Verbindungsparameter für dieses Gerät konfiguriert werden können, z. B. AMS Net ID, ADS-Port oder auch die Symboldatei.
Graphic from Hinzufügen von ADS Geräten (Configurator_AddNewDataAccessDevice.png)
Graphic from Hinzufügen von ADS Geräten (Configurator_AddNewDataAccessDeviceDialog.png)
Nachdem ein Gerät hinzugefügt wurde, können diese Parameter über das Eigenschaftenfenster von Visual Studio bei Bedarf nachträglich modifiziert werden.
Graphic from Hinzufügen von ADS Geräten (Configurator_DataAccessPropertiesWindow.png)
Auswahl der Symboldatei
Auf dem ausgewählten Zielgerät vorhandene Symboldateien können direkt eingelesen werden. Diese Symboldateien können dabei entweder im TwinCAT‑Bootverzeichnis oder im Symbolverzeichnis des OPC UA Servers hinterlegt sein. Über den entsprechenden Dialog bei der Symboldatei-Konfiguration können diese Dateien selektiert werden.
Graphic from Hinzufügen von ADS Geräten (iodgp4h2.png)
Der TwinCAT OPC UA File Explorer kann entweder mit dem lokalen TwinCAT‑Verzeichnis oder dem Remote‑Bootverzeichnis verbunden werden. Letzteres wird über den Configuration-Namespace des Servers eingelesen (siehe Konfiguration des Namensraums).
Graphic from Hinzufügen von ADS Geräten (2017-11-03 14_08_33-sveng - Remotedesktopverbindung.png)
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Download/Upload der Konfiguration

Konfiguration [image] Setup Version 4.x.x [image] Download/Upload der Konfiguration
Download/Upload der Konfiguration
Bei der Benutzung des Konfigurators kann der Anwender sowohl den Download/Upload von kompletten Server-Konfigurationen anstoßen, als auch jede einzelne Facette (Data Access, Historical Access, etc.) einzeln auf ein Zielgerät aufspielen bzw. von dort öffnen. Die hierfür notwendigen Funktionen sind sowohl in die Toolbar als auch in das Kontextmenü der jeweiligen Kategorie eingebunden.
Öffnen einer Konfiguration vom Zielgerät
Durch die entsprechende Schaltfläche in der Toolbar kann die Konfiguration des selektierten Zielgeräts geöffnet werden.
Graphic from Download_Upload der Konfiguration (irs51f33.png)
Siehe auch: Auswahl eines Zielgeräts
Aktivieren einer Konfiguration auf ein Zielgerät
Durch die entsprechende Schaltfläche in der Toolbar kann die aktuell geöffnete Konfiguration auf das selektierte Zielgerät heruntergeladen werden.
Graphic from Download_Upload der Konfiguration (i7rler63.png)
Siehe auch: Auswahl eines Zielgeräts
Öffnen einer Teilkonfiguration
Im Kontextmenü einer bestimmten Facette der Konfiguration kann diese Teilkonfiguration vom selektierten Zielgerät geöffnet werden.
Graphic from Download_Upload der Konfiguration (ijrrk6j1.png)
Siehe auch: Auswahl eines Zielgeräts
Herunterladen einer Teilkonfiguration
Im Kontextmenü einer bestimmten Facette der Konfiguration kann diese Teilkonfiguration auf das selektierte Zielgerät heruntergeladen werden.
Graphic from Download_Upload der Konfiguration (iv2n4541.png)
Siehe auch: Auswahl eines Zielgeräts


Import/Export von Konfigurationsdateien

Konfiguration [image] Setup Version 4.x.x [image] Import/Export von Konfigurationsdateien
Import/Export von Konfigurationsdateien
Das Kontextmenü ermöglicht den Import/Export von Konfigurationsdateien des TwinCAT OPC UA Servers.
Importieren einer Teilkonfiguration
Zum Importieren einer Teilkonfiguration (z. B. Historical Access) aus einer XML-Konfigurationsdatei, kann der entsprechende Eintrag im Kontextmenü aufgerufen werden.
Graphic from Import_Export von Konfigurationsdateien (i3tlrqm.png)
Exportieren einer Teilkonfiguration
Zum Exportieren einer Teilkonfiguration (z. B. Historical Access) in eine XML-Konfigurationsdatei, kann der entsprechende Eintrag im Kontextmenü aufgerufen werden.
Graphic from Import_Export von Konfigurationsdateien (im87nhb3.png)


Konfiguration von Historical Access

Konfiguration [image] Setup Version 4.x.x [image] Konfiguration von Historical Access
Konfiguration von Historical Access
Zur Konfiguration von Historical Access müssen zunächst die History Adapter eingerichtet werden. Hierbei handelt es sich um die unterschiedlichen Speicherorte für die historischen Daten, z. B. RAM, Datei, SQL Server. Über das Kontextmenü können diese Adapter zur Konfiguration hinzugefügt werden. Je nach Adaptertyp müssen weitere Parameter spezifiziert werden, z. B. der gewünschte Pfad zur Dateiablage oder die Zugangsdaten zum SQL Server.
Graphic from Konfiguration von Historical Access (Configurator_HistoricalAccessAddAdapter.png)
Graphic from Konfiguration von Historical Access (Configurator_HistoricalAccessAddAdapter2.png)
Nachdem der History Adapter angelegt wurde, können die gewünschten Variablen zu diesem Adapter hinzugefügt werden. Diese Variablen müssen zum Zeitpunkt des Engineerings bereits auf dem selektierten OPC UA Server vorliegen. Zur Selektion der Variablen kann der integrierte OPC UA Target Browser verwendet werden.
Graphic from Konfiguration von Historical Access (Configurator_TargetBrowser.png)
Per Drag-and-drop kann eine Variable aus dem Target Browser zum History Adapter hinzugefügt werden. Im Eigenschaftenfenster der neu hinzugefügten Variable können weitere Parameter spezifiziert werden, z. B. die gewünschte SamplingRate oder die Größe des zu verwendenden Ringbuffers im History Adapter.
Graphic from Konfiguration von Historical Access (Configurator_HistoricalAccessPropertiesWindow.png)
Siehe auch: Auswahl eines Zielgeräts


Konfiguration von Alarms & Conditions

Konfiguration [image] Setup Version 4.x.x [image] Konfiguration von Alarms & Conditions
Konfiguration von Alarms & Conditions
Zur Konfiguration von Alarms & Conditions müssen zunächst die Condition Controller eingerichtet werden. Hierbei handelt es sich um Container-Einheiten, die Alarme gruppieren. Über das Kontextmenü können diese Controller zur Konfiguration hinzugefügt werden.
Graphic from Konfiguration von Alarms _ Conditions (Configurator_AlarmsConditionsAddController.png)
Nachdem der Condition Controller angelegt wurde, können die gewünschten Variablen zu diesem Controller hinzugefügt und im Sinne des Alarms & Conditions überwacht werden. Für jede Variable wird hierbei eine Condition angelegt, welche die Parameter für die Überwachung spezifiziert. Diese Variablen müssen zum Zeitpunkt des Engineerings bereits auf dem selektierten OPC UA Server vorliegen. Zur Selektion der Variablen kann der integrierte OPC UA Target Browser verwendet werden.
Graphic from Konfiguration von Historical Access (Configurator_TargetBrowser.png)
Per Drag-and-drop kann eine Variable aus dem Target Browser zum Condition Controller hinzugefügt werden. In dem sich öffnenden Dialogfenster können der Condition-Typ und die weiteren Parameter für die Überwachung definiert werden, z. B. SamplingRate und Severity.
Graphic from Konfiguration von Alarms _ Conditions (Configurator_AlarmsConditionsAddCondition2.png)
Danach können, je nach ausgewähltem Condition-Typ, zusätzliche Parameter im Eigenschaftenfenster der Condition definiert werden. Die Schwellenwerte für den jeweiligen Condition‑Typ werden als einzelne Items in der Baumansicht der Konfiguration angezeigt. Auch hier lassen sich die entsprechenden Parameter im Eigenschaftenfenster konfigurieren.
Graphic from Konfiguration von Alarms _ Conditions (Configurator_AlarmsConditionsPropertyWindow.png)
Anschließend müssen die entsprechenden Alarmtexte definiert werden, die beim Triggern einer Condition an den OPC UA Client versendet werden sollen. Das Anlegen von Alarmtexten wird im Abschnitt Konfiguration von Alarmtexten beschrieben. Die Alarmtexte können per Drag-and-drop auf den jeweiligen Schwellenwert einer Condition gezogen werden.
Graphic from Konfiguration von Alarms _ Conditions (Configurator_AlarmsConditionsDragDropAlarmText.png)
OffNormal-Alarmtyp
Bei einem OffNormal‑Alarmtyp lässt sich ein Normalwert definieren, den eine Variable üblicherweise haben sollte. Weicht der Variablenwert hiervon ab, wird ein Alarm ausgelöst. Entsprechend muss dieser Normalwert konfiguriert werden.
Graphic from Konfiguration von Alarms _ Conditions (Configurator_AlarmsConditionsOffNormalAlarmPropertyWindow.png)
Anschließend müssen die entsprechend zu versendenden Alarmtexte per Drag-and-drop aus dem Resources-Bereich selektiert und auf den jeweiligen Schwellenwert der Condition gezogen werden.
Limit-Alarmtyp
Bei einem Limit-Alarmtyp lassen sich unterschiedliche Schwellenwerte definieren, bei deren Erreichen ein Alarm verschickt werden soll. Diese Schwellenwerte müssen entsprechend konfiguriert werden.
Graphic from Konfiguration von Alarms _ Conditions (Configurator_AlarmsConditionsLimitAlarmPropertyWindow.png)
Anschließend müssen die entsprechend zu versendenden Alarmtexte per Drag-and-drop aus dem Resources-Bereich selektiert und auf den jeweiligen Schwellenwert der Condition gezogen werden.
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)
Siehe auch: Auswahl eines Zielgeräts


Konfiguration von Alarmtexten

Konfiguration [image] Setup Version 4.x.x [image] Konfiguration von Alarmtexten
Konfiguration von Alarmtexten
Der TwinCAT‑OPC‑UA‑Server‑Konfigurator ermöglicht die (mehrsprachige) Verwaltung von Alarmtexten, die zum Beispiel beim Alarms & Conditions verwendet werden. Die Konfiguration der Texte erfolgt im Bereich Resources.
Graphic from Konfiguration von Alarmtexten (Configurator_ResourcesAddItem.png)
Jeder Alarmtext wird durch eine eindeutige ID identifiziert. Dieser ID können dann mehrere Sprachtexte zugeordnet werden.
Graphic from Konfiguration von Alarmtexten (Configurator_ResourcesAddLanguage.png)
Über das Kontextmenü können sogenannte „Resource Items“ angelegt und mit neuen Sprachelementen versehen werden.
Das Eigenschaftenfenster ermöglicht die weitere Parametrisierung eines Sprachelementen, zum Beispiel der Sprachtext und die zugeordnete Sprache. Beim Setzen der Sprache wird die zugehörige Locale ID automatisch gesetzt. Die Locale ID wird vom OPC UA Client angefordert um anzugeben in welcher Sprache er Alarmtexte erwartet.
Graphic from Konfiguration von Alarmtexten (Configurator_ResourcesPropertyWindow.png)
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Konfiguration der Endpunkte

Konfiguration [image] Setup Version 4.x.x [image] Konfiguration der Endpunkte
Konfiguration der Endpunkte
Die Endpunkte des TwinCAT OPC UA Servers geben an, welche Security-Mechanismen bei der Verbindungsherstellung eines Clients benutzt werden sollen. Diese reichen von „unverschlüsselt“ bis zu „verschlüsselt und signiert“, basierend auf verschiedenen Schlüsselstärken. Die Endpunkte können über den Konfigurator aktiviert/deaktiviert werden. Zum Beispiel kann es sinnvoll sein, den unverschlüsselten Endpunkt zu deaktivieren, damit sich alle Clients nur mit gültigem und als vertrauenswürdig eingestuftem Zertifikat verbinden können. Die Konfiguration der Endpunkte erfolgt direkt auf Ebene des OPC‑UA‑Server‑Projekts. Durch einen Doppelklick auf das Projekt können in der Registerkarte UA Endpoints die entsprechenden Einstellungen vorgenommen werden. Diese Einstellungen werden nach einem Aktivieren der Konfiguration und einem anschließenden Neustart des Servers wirksam (siehe Download/Upload der Konfiguration und Neustart des Servers).
Graphic from Konfiguration der Endpunkte (Configurator_Endpoints.png)
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)


Konfiguration von Zertifikats-Vertrauenseinstellungen

Konfiguration [image] Setup Version 4.x.x [image] Konfiguration von Zertifikats-Vertrauenseinstellungen
Konfiguration von Zertifikats-Vertrauenseinstellungen
Die auf dem Server vorhandenen Client-Zertifikate können über den Konfigurator komfortabel verwaltet werden. In den Projekteinstellungen können im Bereich UA Endpoints > Client-Zertifikate als vertrauenswürdig eingestuft oder verweigert werden.
Graphic from Konfiguration von Zertifikats-Vertrauenseinstellungen (Configurator_CertificateManagementTrustList.png)
Nachdem ein OPC UA Client zum ersten Mal versucht hat, sich mit einem sicheren Endpunkt des Servers zu verbinden, wird das Client-Zertifikat auf dem Server hinterlegt und als „rejected“ deklariert. Anschließend kann der Server-Administrator über oben gezeigten Dialog das Zertifikat freischalten. Ein anschließender Verbindungsversuch des Clients mit einem gesicherten Endpunkt wird dann erfolgreich sein.


Neustart des Servers

Konfiguration [image] Setup Version 4.x.x [image] Neustart des Servers
Neustart des Servers
Der TwinCAT‑OPC‑UA‑Server‑Konfigurator ermöglicht das Antriggern eines Neustarts vom OPC UA Server. Dies kann lokal oder remote erfolgen und bezieht sich auf das jeweils selektierte Zielgerät. Beachten Sie, dass ein Neustart des Servers immer einen Verbindungsverlust aller verbundenen Clients nach sich zieht. Der Neustart kann über die Toolbar getriggert werden.
Graphic from Neustart des Servers (iu8vdei2.png)
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)
Siehe auch: Auswahl eines Zielgeräts


Troubleshooting & Logging

Konfiguration [image] Setup Version 4.x.x [image] Troubleshooting & Logging
Troubleshooting & Logging
Für eine erweiterte Diagnose kann eine Loggingfunktion des TwinCAT OPC UA Servers aktiviert werden. In der Registerkarte Online Panel des Projekts kann diese Funktion lokal oder remote, je nach selektiertem Zielgerät, aktiviert oder deaktiviert werden.
Graphic from Troubleshooting _ Logging (Configurator_ServerLogging.png)
AppTrace
In den meisten Fällen ist es ausreichend ein sogenanntes „AppTrace“ zu erstellen. Je höher der Trace level, desto detailliertere (und mehr) Daten werden geschrieben.
StackTrace
In einigen wenigen Fällen ist es zusätzlich notwendig ein sogenanntes „StackTrace“ zu erstellen. Auch hier gilt: Je höher der Trace level, desto detailliertere (und mehr) Daten werden geschrieben.
Hinweis
Aktivierung des Loggings
Beachten Sie, dass die Loggingfunktion so lange aktiv ist, bis sie wieder über den Konfigurator deaktiviert oder bis der TwinCAT OPC UA Server neu gestartet wird.
Hinweis
Schreiben der Logdatei
Durch das Aktivieren der Loggingfunktion auf dem Server wird eine Protokolldatei auf dem Dateisystem geschrieben. Stellen Sie sicher, dass ausreichend Speicherplatz zur Verfügung steht und setzen Sie die Loggingparameter (Anzahl Logdateien, Größe pro Logdatei) entsprechend.
Hinweis
Performance- und Timingverhalten
Beachten Sie, dass sich durch Aktivieren der Protokollfunktionen das Timing-Verhalten des OPC UA Servers verändert und hierdurch, je nach Plattform und Projekt, Geschwindigkeitseinbußen entstehen können.
Produkte | Setupversionen | Zielplattform
TF6100 | 4.x.x | IPC oder CX (x86, x64, ARM)
Siehe auch: Auswahl eines Zielgeräts


SPS API

SPS API
SPS API
Weiterführende Informationen
•
Funktionsbausteine
•
Datentypen


Funktionsbausteine

SPS API [image] Funktionsbausteine
Funktionsbausteine
Weiterführende Informationen
•
UA_Connect
•
UA_Disconnect
•
UA_GetNamespaceIndex
•
UA_MethodCall
•
UA_MethodGetHandle
•
UA_MethodReleaseHandle
•
UA_NodeGetHandle
•
UA_NodeGetHandleList
•
UA_NodeReleaseHandle
•
UA_NodeReleaseHandleList
•
UA_Read
•
UA_ReadList
•
UA_Write


UA_Connect

SPS API [image] Funktionsbausteine [image] UA_Connect
UA_Connect
Dieser Funktionsbaustein stellt eine OPC-UA-Remote-Verbindung zu einem anderen OPC UA Server her, der via ServerUrl und SessionConnectInfo spezifiziert wird. Der Funktionsbaustein gibt ein Verbindungshandle zurück, der für andere Funktionsbausteine, z. B. UA_Read, verwendet werden kann.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ServerUrl : STRING(MAX_STRING_LENGTH);
SessionConnectInfo : ST_UASessionConnectInfo;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ServerUrl: OPC UA Server URL. d. h. 'opc.tcp://172.16.3.207:4840' oder 'opc.tcp://CX_0193BF:4840'.
SessionConnectInfo: Verbindungsinformation (siehe ST_UASessionConnectInfo)
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
HINWEIS! ST_UASessionConnectInfo.tSessionTimeout muss kürzer sein als dieses Timeout.
VAR_OUTPUT
VAR_OUTPUT
ConnectionHdl : DWORD;
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : DWORD;
END_VAR
ConnectionHdl: OPC‑UA‑Verbindungshandle.
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in ErrorID enthalten.
ErrorID: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_Disconnect

SPS API [image] Funktionsbausteine [image] UA_Disconnect
UA_Disconnect
Dieser Funktionsbaustein schließt eine OPC-UA-Remote-Verbindung zu einem anderen OPC UA Server. Die Verbindung wird über ihr Verbindungshandle spezifiziert.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : DWORD;
END_VAR
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in nErrID enthalten.
ErrorID: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_GetNamespaceIndex

SPS API [image] Funktionsbausteine [image] UA_GetNamespaceIndex
UA_GetNamespaceIndex
Dieser Funktionsbaustein erfasst den Namespace Index für einen Namespace URI. Der Namespace Index wird für die Identifizierung von Symbolen benötigt, z. B. wenn die Funktionsbausteine UA_Read oder UA_Write genutzt werden.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
NamespaceUri : STRING(MAX_STRING_LENGTH);
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
NamespaceUri: Namensraum-URI, der aufgelöst werden soll. Beim TwinCAT OPC UA Server ist das für die erste SPS-Laufzeit „PLC1“.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
NamespaceIndex : UINT;
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : DWORD;
END_VAR
NamespaceIndex: Namespace Index des gegebenen Namensraum-URI. Dieser kann in anderen Funktionsbausteinen verwendet werden, z. B. UA_Read oder UA_Write.
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout'“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in ErrorID enthalten.
ErrorID: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_MethodCall

SPS API [image] Funktionsbausteine [image] UA_MethodCall
UA_MethodCall
Dieser Funktionsbaustein ruft eine Methode auf einem Remote-UA-Server auf. Die Methode wird durch eine Verbindung und ein Methodenhandle bestimmt. Erstere kann durch UA_Connect und letzterer durch UA_MethodGetHandle abgefragt werden.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
MethodHdl : DWORD;
nNumberOfInputArguments : UDINT;
pInputArgInfo : POINTER TO ST_UAMethodArgInfo;
cbInputArgInfo : UDINT;
pInputArgData : PVOID;
cbInputArgData : UDINT;
pInputWriteData : PVOID;
cbInputWriteData : UDINT;
nNumberOfOutputArguments : UDINT;
pOutputArgInfo : POINTER TO ST_UAMethodArgInfo;
cbOutputArgInfo : UDINT;
pOutputArgInfoAndData : PVOID;
cbOutputArgInfoAndData : UDINT;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
MethodHdl: Methodenhandle, zuvor vom Funktionsbaustein UA_MethodGetHandle ausgegeben.
nNumberOfInputArguments: Anzahl Eingabeparameter.
pInputArgInfo: Zeigt auf die Pufferadresse, wo Eingabeparameterinformationen in Form eines Arrays ST_UAMethodArgInfo hinterlegt sind.
cbInputArgInfo: Größe des Puffers, wo die Eingabeparameterinformation hinterlegt ist.
pInputArgData: Zeigt auf die Pufferadresse, wo Eingabeparameter (konstanter Länge) hinterlegt sind.
cbInputArgData: Größe des Eingabepuffers, wo Eingabeparameter (mit konstanter Länge) hinterlegt sind.
pInputWriteData: Zeiger auf Pufferadresse, wo Eingabeparameter (dynamischer Länge) hinterlegt sind.
cbInputWriteData: Größe des Eingabepuffers, wo Eingabeparameter (mit dynamischer Länge) hinterlegt sind.
nNumberOfOutputArguments: Anzahl Ausgabeparameter.
pOutputArgInfo: Zeigt auf die Pufferadresse, wo Ausgabeparameterinformationen als Array ST_UAMethodArgInfo hinterlegt sind.
Für die Bestimmung des Zielspeichers der einzelnen Ausgabeparameter ist nLenData erforderlich.
Die anderen Elemente können so gesetzt werden, dass eine Typprüfung der zurückgegebenen Parameter erfolgt oder undefiniert bleiben.
cbOutputArgInfo: Größe des Puffers, wo die Ausgabeparameterinformation hinterlegt ist.
pOutputArgInfoAndData: Zeigt auf die Adresse des Puffers, wo die Output-Parameter als BYTE-Array gespeichert werden sollen. Das BYTE Array enthält die Anzahl der Output-Parameter als DINT, 4 reservierte Bytes und Parameterinformationen als ARRAY OF (mit der Länge der Output-Parameter) gefolgt von reinen Daten. Beachten Sie, dass die Daten als 1-byte-Alignment gepackt sind.
cbOutputArgInfoAndData: Größe des Puffers, in dem die Output-Parameter als BYTE-Array gespeichert werden sollen.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
cbRead_R : UDINT;
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : UDINT;
END_VAR
cbRead_R: Zählung aller empfangenen Bytes.
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in nErrID enthalten.
ErrorID: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa


UA_MethodGetHandle

SPS API [image] Funktionsbausteine [image] UA_MethodGetHandle
UA_MethodGetHandle
Dieser Funktionsbaustein erfasst ein Handle für eine UA-Methode, das dann für den Aufruf einer Methode über UA_MethodCall verwendet werden kann.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
ObjectNodeID : ST_UANodeID;
MethodNodeID : ST_UANodeID;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
ObjectNodeID: Objektknoten-ID der aufzurufenden Methode. (Typ: ST_UANodeID)
MethodNodeID: Methoden-Knoten-ID der aufzurufenden Methode. Entspricht dem ID-Atttribut im UA‑Namensraum. (Typ: UA_Connect)
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
MethodHdl : DWORD;
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : UDINT;
END_VAR
MethodHdl: Gibt ein Methodenhandle zurück, das für den Aufruf einer Methode über UA_MethodCall verwendet werden kann.
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in nErrID enthalten.
ErrorID: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa


UA_MethodReleaseHandle

SPS API [image] Funktionsbausteine [image] UA_MethodReleaseHandle
UA_MethodReleaseHandle
Dieser Funktionsbaustein gibt das spezifizierte Methodenhandle frei.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
MethodHdl : DWORD;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
MethodHdl: Methodenhandle, das zuvor vom Funktionsbaustein UA_MethodGetHandle ausgegeben wurde.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : UDINT;
END_VAR
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in nErrID enthalten.
ErrorID: Enthält den befehlsspezifischen ADS Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa


UA_NodeGetHandle

SPS API [image] Funktionsbausteine [image] UA_NodeGetHandle
UA_NodeGetHandle
Dieser Funktionsbaustein fragt ein Knotenhandle für ein gegebenes Symbol im UA-Namensraum ab. Das Symbol wird durch ein Verbindungshandle und seine Knoten-ID spezifiziert.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
NodeID : ST_UANodeID;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
Node ID: Knotenhandle, der zuvor vom Funktionsbaustein UA_NodeGetHandle ausgegeben wurde.
Timeout: Zeit bis zum Abbruch der Function. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
NodeHdl : DWORD;
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : DWORD;
END_VAR
NodeHdl: Knotenhandle, das für andere Funktionsbausteine verwendet werden kann, z. B. UA_Read oder UA_Write.
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in ErrorID enthalten.
ErrorID: Enthält den befehlsspezifischen ADS Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_NodeGetHandleList

SPS API [image] Funktionsbausteine [image] UA_NodeGetHandleList
UA_NodeGetHandleList
Graphic from UA_NodeGetHandleList (il01v4n3.png)
Dieser Funktionsbaustein fragt Knotenhandles für Knoten im UA-Namensraum ab.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
NodeIDCount : UINT;
NodeIDs : ARRAY[1..nMaxNodeIDsInList] OF ST_UANodeID;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
NodeIDCount: Anzahl Knoten, für die ein Knotenhandle erforderlich ist.
NodeIDs: Array von NodeIDs, die mit der struct ST_UANodeID erstellt wurden.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
NodeHdls : ARRAY[1..nMaxNodeIDsInList] OF DWORD;
NodeErrorIDs : ARRAY[1..nMaxNodeIDsInList] OF DWORD;
cbData_R : UDINT;
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : DWORD;
END_VAR
NodeHdls: Array angeforderter Knotenhandles.
NodeErrorIDs: Array von Fehler-IDs, falls keine Knotenhandles zur Verfügung stehen.
cbData_R: Größe der gelesenen Daten.
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode steht in nErrID.
ErrorID: Enthält die Fehler-ID, wenn ein Fehler auftritt.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_NodeReleaseHandle

SPS API [image] Funktionsbausteine [image] UA_NodeReleaseHandle
UA_NodeReleaseHandle
Dieser Funktionsbaustein gibt ein Knotenhandle frei.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
NodeHdl : DWORD;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
NodeHdl: Freizugebendes Knotenhandle.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : DWORD;
END_VAR
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in ErrorID enthalten.
ErrorID: Enthält den befehlsspezifischen ADS Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_NodeReleaseHandleList

SPS API [image] Funktionsbausteine [image] UA_NodeReleaseHandleList
UA_NodeReleaseHandleList
Graphic from UA_NodeReleaseHandleList (i76r9at2.png)
Dieser Funktionsbaustein gibt mehrere Knotenhandles frei.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
NodeHdlCount : UINT;
NodeHdls : ARRAY[1..nMaxNodeIDsInList] OF DWORD;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
NodeHdlCount: Anzahl Knotenhandles.
NodeHdls: Array von Knotenhandles, die freizugeben sind.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
NodeErrorIDs : ARRAY[1..nMaxNodeIDsInList] OF DWORD;
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : DWORD;
END_VAR
NodeErrorIDs: Array von Fehler-IDs, falls ein Knotenhandle nicht freigegeben werden konnte.
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode steht in nErrID.
ErrorID: Enthält die Fehler-ID, wenn ein Fehler auftritt.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_Read

SPS API [image] Funktionsbausteine [image] UA_Read
UA_Read
Dieser Funktionsbaustein liest Werte aus einem gegebenen Knoten- und Verbindungshandle.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
NodeHdl : DWORD;
stNodeAddInfo : ST_UANodeAdditionalInfo;
pVariable : PVOID;
cbData : UDINT;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
NodeHdl: Knotenhandle, das zuvor vom Funktionsbaustein UA_NodeGetHandle ausgegeben wurde.
stNodeAddInfo: Definiert zusätzliche Informationen, z. B. welches Attribut aus dem UA‑Namensraum gelesen (Standard: 'Value'-Attribut) oder welcher IndexRange verwendet werden soll. Wird durch STRUCT ST_UANodeAdditionalInfo spezifiziert.
pVariable: Zeiger auf Daten, wo die gelesen Daten gespeichert werden.
cbData: Bestimmt die Größe der zu lesenden Daten.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : UDINT;
cbData_R : UDINT;
END_VAR
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in nErrID enthalten.
ErrorID: Enthält den befehlsspezifischen ADS‑Fehlercode des zuletzt ausgeführten Befehls.
cbData_R: Anzahl zu lesender Bytes.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_ReadList

SPS API [image] Funktionsbausteine [image] UA_ReadList
UA_ReadList
Grafik aus UA_ReadList (i9hmrgm2.png)
Dieser Funktionsbaustein liest Werte aus einem gegebenen Knoten- und Verbindungshandle.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
NodeHdlCount : UINT;
NodeHdls : ARRAY[1..nMaxNodeIDsInList] OF DWORD;
stNodeAddInfo : ARRAY[1..nMaxNodeIDsInList] OF ST_UANodeAdditionalInfo;
pVariable : PVOID;
cbData : ARRAY[1..nMaxNodeIDsInList] UDINT;
cbDataTotal : UDINT;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
NodeHdlCount: Anzahl Knotenhandles, die in der Eingangsvariablen NodeHdls gespeichert sind.
NodeHdls: Array von Knotenhandles, die vorher vom Funktionsbaustein UA_NodeGetHandle oder UA_NodeGetHandleList erhalten wurden.
stNodeAddInfo: Definiert zusätzliche Informationen, z. B. welches Attribut aus dem UA‑Namensraum gelesen (Standard: 'Value'-Attribut) oder welcher IndexRange verwendet werden soll. Wird durch STRUCT ST_UANodeAdditionalInfo spezifiziert.
pVariable: Zeiger auf Daten, wo die gelesen Daten gespeichert werden.
cbData: Bestimmt die Größe der zu lesenden Daten.
cbDataTotal: Gesamtgröße der zu empfangenden Daten.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : UDINT;
cbData_R : UDINT;
END_VAR
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode steht in nErrID.
ErrorID: Enthält den befehlsspezifischen ADS‑Fehlercode des zuletzt ausgeführten Befehls.
cbData_R: Anzahl der gelesenen Bytes
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


UA_Write

SPS API [image] Funktionsbausteine [image] UA_Write
UA_Write
Dieser Funktionsbaustein schreibt Werte in ein gegebenes Knoten- und Verbindungshandle.
VAR_INPUT
VAR_INPUT
Execute : BOOL;
ConnectionHdl : DWORD;
NodeHdl : DWORD;
stNodeAddInfo : ST_UANodeAdditionalInfo;
pVariable : PVOID;
cbData : UDINT;
Timeout : TIME := DEFAULT_ADS_TIMEOUT;
END_VAR
Execute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
ConnectionHdl: Verbindungshandle, das vorher vom Funktionsbaustein UA_Connect ausgegeben wurde.
NodeHdl: Knotenhandle, der zuvor vom Funktionsbaustein UA_NodeGetHandle ausgegeben wurde.
stNodeAddInfo: Definiert zusätzliche Informationen, z. B. auf welchen IndexRange oder welches Attribut geschrieben werden soll (standardmäßig wird das 'Value'-Attribut verwendet). Wird durch STRUCT ST_UANodeAdditionalInfo spezifiziert.
pVariable: Zeiger auf zu schreibende Daten.
cbData: Legt die Größe der zu schreibenden Werte fest.
Timeout: Zeit bis zum Abbruch der Funktion. DEFAULT_ADS_TIMEOUT ist eine globale Konstante, gesetzt auf 5 Sekunden.
VAR_OUTPUT
VAR_OUTPUT
Done : BOOL;
Busy : BOOL;
Error : BOOL;
ErrorID : DWORD;
END_VAR
Done: Schaltet auf TRUE, wenn der Funktionsbaustein erfolgreich ausgeführt wurde.
Busy: Dieser Ausgang ist TRUE, bis der Baustein einen Befehl ausführt hat, maximal für die Dauer des „Timeout“ am Eingang. Solange Busy = TRUE ist, akzeptieren die Eingänge keinen neuen Befehl. Es wird nicht die Zeit der Verbindung sondern die Empfangszeit überwacht.
Error: Dieser Ausgang schaltet auf TRUE, wenn bei der Ausführung eines Befehls ein Fehler auftritt. Der befehlsspezifische Fehlercode ist in ErrorID enthalten.
ErrorID: Enthält den befehlsspezifischen ADS‑Fehlercode des zuletzt ausgeführten Befehls.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


Datentypen

SPS API [image] Datentypen
Datentypen
Weiterführende Informationen
•
E_UAAttributeID
•
E_UADataType
•
E_UAIdentifierType
•
E_UASecurityMsgMode
•
E_UASecurityPolicy
•
E_UATransportProfile
•
ST_UASessionConnectInfo
•
ST_UAIndexRange
•
ST_UAMethodArgInfo
•
ST_UANodeID
•
ST_UANodeAdditionalInfo


E_UAAttributeID

SPS API [image] Datentypen [image] E_UAAttributeID
E_UAAttributeID
E_UAAttributeID
TYPE E_UAAttributeID:
(
eUAAI_NodeID := 1,
eUAAI_NodeClass := 2,
eUAAI_BrowseName := 3,
eUAAI_DisplayName := 4,
eUAAI_Description := 5,
eUAAI_WriteMask := 6,
eUAAI_UserWriteMask := 7,
eUAAI_IsAbstract := 8,
eUAAI_Symmetric := 9,
eUAAI_InverseName := 10,
eUAAI_ContainsNoLoops := 11,
eUAAI_EventNotifier := 12,
eUAAI_Value := 13,
eUAAI_DataType := 14,
eUAAI_ValueRank := 15,
eUAAI_ArrayDimensions := 16
)DINT;
END_TYPE
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


E_UADataType

SPS API [image] Datentypen [image] E_UADataType
E_UADataType
E_UADataType
TYPE E_UADataType:
(
eUAType_Undefinied := -1,
eUAType_Null := 0,
eUAType_Boolean := 1,
eUAType_SByte := 2,
eUAType_Byte := 3,
eUAType_Int16 := 4,
eUAType_UInt16 := 5,
eUAType_Int32 := 6,
eUAType_UInt32 := 7,
eUAType_Int64 := 8,
eUAType_UInt64 := 9,
eUAType_Float := 10,
eUAType_Double := 11,
eUAType_String := 12,
eUAType_DateTime := 13,
eUAType_Guid := 14,
eUAType_ByteString := 15,
eUAType_XmlElement := 16,
eUAType_NodeId := 17,
eUAType_ExpandedNodeId := 18,
eUAType_StatusCode := 19,
eUAType_QualifiedName := 20,
eUAType_LocalizedText := 21,
eUAType_ExtensionObject:= 22,
eUAType_DataValue := 23,
eUAType_Variant := 24,
eUAType_DiagnosticInfo := 25
)DINT;
END_TYPE
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


E_UAIdentifierType

SPS API [image] Datentypen [image] E_UAIdentifierType
E_UAIdentifierType
E_UATransportProfile
TYPE E_UAIdentifierType:
(
eUAIdentifierType_String := 1,
eUAIdentifierType_Numeric := 2,
eUAIdentifierType_GUID := 3,
eUAIdentifierType_Opaque := 4
)DINT;
END_TYPE
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


E_UASecurityMsgMode

SPS API [image] Datentypen [image] E_UASecurityMsgMode
E_UASecurityMsgMode
E_UASecurityMsgMode
TYPE E_UASecurityMsgMode:
(
eUASecurityMsgMode_BestAvailable := 0,
eUASecurityMsgMode_None := 1,
eUASecurityMsgMode_Sign := 2,
eUASecurityMsgMode_Sign_Encrypt := 3
)DINT;
END_TYPE
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


E_UASecurityPolicy

SPS API [image] Datentypen [image] E_UASecurityPolicy
E_UASecurityPolicy
E_UASecurityPolicy
TYPE E_UASecurityPolicy:
(
eUASecurityPolicy_BestAvailable := 0
eUASecurityPolicy_None := 1,
eUASecurityPolicy_Basic128 := 2,
eUASecurityPolicy_Basic128Rsa15 := 3,
eUASecurityPolicy_Basic256 := 4
)DINT;
END_TYPE
None: Richtlinie für Konfigurationen mit geringsten Sicherheitsanforderungen.
Basic128: Richtlinie für Konfigurationen mit geringen bis mittleren Sicherheitsanforderungen.
Basic128Rsa15: Definiert Sicherheitsrichtlinie für Konfigurationen mit mittlerer bis hoher Sicherheit.
Basic256: Definiert eine Sicherheitsrichtlinie für Konfigurationen mit hohen Sicherheitsanforderungen.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


E_UATransportProfile

SPS API [image] Datentypen [image] E_UATransportProfile
E_UATransportProfile
E_UATransportProfile
TYPE E_UATransportProfile:
(
eUATransportProfileUri_UATcp := 1,
eUATransportProfileUri_WSHttpBinary := 2,
eUATransportProfileUri_WSHttpXmlOrBinary := 3,
eUATransportProfileUri_WSHttpXml := 4
)DINT;
END_TYPE
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


ST_UASessionConnectInfo

SPS API [image] Datentypen [image] ST_UASessionConnectInfo
ST_UASessionConnectInfo
ST_UASessionConnectInfo
TYPE ST_UASessionConnectInfo:
STRUCT
sApplicationUri : STRING(MAX_STRING_LENGTH);
sApplicationName : STRING(MAX_STRING_LENGTH);

eSecurityMode : E_UASecurityMsgMode;
eSecurityPolicyUri : E_UASecurityPolicy;
eTransportProfileUri : E_UATransportProfile;

tSessionTimeout : TIME;
tConnectTimeout : TIME;
END_STRUCT
END_TYPE
sApplicationUri: Anwendungs-Uri maximale Zeichenkettenlänge 255.
Ab TcUAClient 2.0.0.14 wird diese automatisch vom Zertifikat vorgegeben, wie in der PLCOpen Spezifikation definiert.
sApplicationName: Anwendungsname mit maximaler Zeichenkettenlänge von 255.
eSecurityMode: Sicherheitsmeldungsmodus. Verfügbare Modi siehe E_UASecurityMsgMode.
eSecurityPolicyUri: Sicherheitsrichtlinien-Uri. Verfügbare Sicherheitsrichtlinien-Uri siehe E_UASecurityPolicy.
eTransportProfileUri: Transportprofil-Uri. Verfügbare Transportprofil-Uri siehe E_UATransportProfile;
nSessionTimeout: Wert Sitzungstimeout.
nConnectTimeout: Wert Verbindungstimeout.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


ST_UAIndexRange

SPS API [image] Datentypen [image] ST_UAIndexRange
ST_UAIndexRange
ST_UAIndexRange
TYPE ST_UAIndexRange:
STRUCT
nStartIndex : UDINT;
nEndIndex : UDINT;
END_STRUCT
END_TYPE
Für alle Dimensionen:
▪
StartinIndex und EndIndex müssen zugewiesen werden.
▪
StartIndex muss kleiner als EndIndex sein.
▪
Um auf alle Elemente in einer Dimension zugreifen zu können, müssen StartIndex und EndIndex abhängig von der Gesamtzahl Elemente in der Dimension zugewiesen werden.
▪
Einzelne Elemente einer Dimension können ausgewählt werden, indem der gleiche StartIndex und EndIndex angegeben wird.
nStartIndex: Startindex der Daten.
nEndIndex: Endindex der Daten.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


ST_UAMethodArgInfo

SPS API [image] Datentypen [image] ST_UAMethodArgInfo
ST_UAMethodArgInfo
ST_UAMethodArgInfo
TYPE ST_UAMethodArgInfo:
STRUCT
DataType : E_UADataType := -1;
ValueRank : DINT := 2147483647;
ArrayDimensions : ARRAY[1..3] OF UDINT := [0,0,0];
nLenData : DINT;
END_STRUCT
END_TYPE
E_UADataType: Legt den UA‑Datentyp für den Methodenparameter fest. (E_UADataType)
ValueRank: Legt fest, ob der Parameter Skalar (-1) oder Array ist.
ArrayDimensions: Wenn der Parameter ein Array ist, spezifiziert dieser die Dimensionen des Arrays. Jedes Element bestimmt die Länge pro Dimension.
nLenData: Spezifiziert die Länge des Arguments. Bei Ausgabeinformationen wird von STRUCT nur dieses Element gefordert.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


ST_UANodeID

SPS API [image] Datentypen [image] ST_UANodeID
ST_UANodeID
ST_UANodeID
TYPE ST_UANodeID:
STRUCT
nNamespaceIndex : UINT;
nReserved : ARRAY [1..2] OF BYTE; //fill bytes
sIdentifier : STRING(MAX_STRING_LENGTH);
eIdentifierType : E_UAIdentifierType;
END_STRUCT
END_TYPE
nNamespaceIndex: Namensraum-Index unter dem der Knoten verfügbar ist. Kann mit dem Funktionsbaustein UA_GetNamespaceIndex bestimmt werden.
sIdentifier: Bezeichner wie im UA‑Namensraum gezeigt (Attribut 'Identifier').
eIdentifierType: Typ der Variablen, beschrieben mittels E_UAIdentifierType.
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


ST_UANodeAdditionalInfo

SPS API [image] Datentypen [image] ST_UANodeAdditionalInfo
ST_UANodeAdditionalInfo
ST_UANodeAdditionalInfo
TYPE ST_UANodeAdditionalInfo:
STRUCT
eAttributeID : E_UAAttributeID;
nIndexRangeCount : UINT;
nReserved : ARRAY[1..2] OF BYTE; // fill bytes
stIndexRange : ARRAY[1..nMaxIndexRange] OF ST_UAIndexRange;
END_STRUCT
END_TYPE
eAttributeID: Spezifiziert die ID des OPC‑UA‑Attributs. Standardmäßig wird eUAAI_Value verwendet. (E_UAAttributeID)
nIndexRangeCount: Legt fest, wie viele Indexbereiche in stIndexRange verwendet werden.
stIndexRange: Spezifiziert einen Indexbereich für das Lesen von Werten aus einem Array. (ST_UAIndexRange)
Voraussetzungen
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT 3.1 | Win32, Win64, CE-X86, CE-ARM | Tc3_PLCopen_OpcUa
TwinCAT 2.11 R3 Build 2245 | Win32, CE-X86, CE-ARM | Tc2_PLCopen_OpcUa


Beispiele

Beispiele
Beispiele
Übersicht
Beispiel
Kategorie
TwinCAT-Version
Beschreibung
Download
TF6100_OPCUA_ServerSample
OPC UA Server
TC3 (>=3.1.4020.0)
Das Beispiel beinhaltet eine SPS zur Bereitstellung von Variablen für den TwinCAT OPC UA Server (Data Access).
TF6100_OPCUA_ClientSample
OPC UA Client
TC3 (>=3.1.4020.0)
Beispiele für UA_Read, UA_Write, UA_ReadList und UA_MethodCall (Tc3_PLCopen_OpcUa)
Das Projekt beinhaltet eine zweite SPS zur exemplarischen Bereitstellung der OPC UA Server Definition (Data Access).
TF6100_OPCUA_HASample
OPC UA Server
TC3 (>=3.1.4020.0)
Historical Access: SPS-Beispielprogramm
TS6100_OPCUA_ClientSample
OPC UA Client
TC2
Beispiele für UA_Read und UA_Write
TS6100_OPCUA_HASample
OPC UA Server
TC2
Historical Access: SPS-Beispielprogramm


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Fehlerdiagnose
•
OPC-UA-Server-Fehlercodes
•
OPC-UA-Client-Fehlercodes
•
ADS Return Codes
•
Support und Service


Fehlerdiagnose

Anhang [image] Fehlerdiagnose
Fehlerdiagnose
Die folgende Tabelle bietet einige hilfreiche Informationen zur Fehlerdiagnose.
TwinCAT OPC UA Server
Verhalten | Hinweise
Ein OPC UA Client sieht den PLC Namespace nicht | TF6100 Setup Version 3.x und kleiner: Dieser Status ist ein Hinweis auf eine fehlende Lizenz. Überprüfen Sie, ob Sie eine gültige TF6100 Lizenz aktiviert haben.
Ein OPC UA Client bekommt bei Auslesen von Nodes den StatusCode 0x810e0000 | TF6100 Setup Version 4.x: Dieser Status ist ein Hinweis auf eine fehlende Lizenz. Überprüfen Sie, ob Sie eine gültige TF6100 Lizenz aktiviert haben.
Die über Kommentare/Attribute freigegebenen Variablen werden nicht im OPC UA Server angezeigt | Überprüfen Sie, ob die Symboldatei ordnungsgemäß auf die Steuerung übertragen wurde (z. B. Auswahlkästchen im SPS-Projekt), im Bootverzeichnis vorhanden ist und der Pfad zur Symboldatei in der Konfigurationsdatei des Servers auf die richtige Symboldatei verweist. Sie können auch über die DeviceState Node im jeweiligen Namespace eventuell aufgetretene ErrorMessages überprüfen. Hier wird z. B. auch eingetragen, wenn die Symboldatei nicht gefunden wurde. Überprüfen Sie auch die ordnungsgemäße Schreibweise der Kommentare/Attribute.
Die vom OPC UA Client geforderte Samplingrate/PublishingInterval werden vom Server nicht eingehalten | OPC UA Client/Server ist kein Echtzeitprotokoll, d. h. dass es keine Garantie gibt, dass der Server eine vom Client geforderte Samplingrate oder PublishingInterval auch immer zu 100% einhält. Die zur Verfügung stehenden Samplingraten und PublishingIntervalle können in der Konfigurationsdatei des Servers eingesehen und bei Bedarf modifiziert werden (<AvailableSamplingRates> und <MinPublishingInterval>).
Ein OPC UA Client kann sich nicht mit dem Server verbinden, obwohl der Server im Windows Task Manager angezeigt wird. Es erscheint die Fehlermeldung „Host unreachable“ (o.ä.) | Überprüfen Sie, ob gegebenenfalls Firewall-Einstellungen eine Kommunikation mit dem Server verhindern. Der Serverport muss für eine eingehende TCP-Kommunikation geöffnet sein, damit sich ein Client verbinden kann.
Ein OPC UA Client sieht zwar die Endpunkte des Servers, eine Verbindung mit diesen schlägt jedoch mit der Fehlermeldung „Host unreachable“ fehl | Überprüfen Sie, ob die Namensauflösung in Ihrem Netzwerk ordnungsgemäß funktioniert und der Server unter seinem Hostnamen erreichbar ist. Auch wenn sich der OPC UA Client augenscheinlich mit der IP-Adresse des Servers verbindet (z. B. opc.tcp://192.168.0.1:4840), um auf die Endpunkte des Servers zuzugreifen, so returniert der Server in seinen Endpunkten dennoch immer den eigenen Hostnamen. Wenn sich nun der Client direkt mit einem der Endpunkte verbindet, so verwendet er wieder den Hostnamen des Servers. Im Falle einer nicht funktionierenden Namensauflösung schlägt dann die Verbindung fehl.
Ein OPC UA Client sieht zwar die Endpunkte des Servers, eine Verbindung mit einem sicheren Endpunkt schlägt jedoch fehl. Es erscheint die Fehlermeldung „BadSecurityChecksFailed“ | Überprüfen Sie, ob der Server dem Client-Zertifikat vertraut. Die notwendigen Konfigurationsschritte können Sie im Abschnitt Zertifikatsaustausch nachlesen.
Bei Verwendung eines SQL Servers zur Speicherung von Historical Access Informationen, werden die Werte nicht zur SQL-Datenbank hinzugefügt | Überprüfen Sie die Zugangsdaten zum SQL Server und dass der SQL Server auch im Netzwerk erreichbar ist. Stellen Sie auch sicher, dass Sie ein „Big Windows“-Betriebssystem auf dem TwinCAT OPC UA Server verwenden, da SQL Server nicht unter Windows CE für Historical Access verwendet werden können (SQL Compact hingegen schon).
Beim Auslesen von Variablen erhält ein OPC UA Client die Fehlermeldung „BadDeviceFailure“ | Dies ist ein Hinweis darauf, dass das zugehörige ADS-Gerät nicht erreichbar ist, z. B. wenn kein SPS-Programm gestartet ist. Überprüfen Sie die Konnektivität mit dem ADS-Gerät und stellen Sie sicher, dass die entsprechende Laufzeit aktiv ist.
Arrays werden nicht voll aufgelöst im Namespace dargestellt | Standardmäßig werden Arrays von einfachen Datentypen nicht „aufgeklappt“ im Namensraum dargestellt. Einzelne Array-Indizes sind dennoch über die sogenannte IndexRange Funktion von OPC UA adressierbar. Ein OPC UA Client sollte diese Funktion entsprechend unterstützen. Ist dies nicht der Fall, so kann über einen Optionsschalter in der Konfigurationsdatei des Servers bewirkt werden, dass ein Array „aufgeklappt“ dargestellt und somit jedes einzelne Arrayelement als separate Node adressierbar ist. Dieser Optionsschalter ist im Abschnitt Verwendung von Arrays beschrieben.


OPC-UA-Server-Fehlercodes

Anhang [image] OPC-UA-Server-Fehlercodes
OPC-UA-Server-Fehlercodes
Die folgende Tabelle gibt eine Übersicht über die globalen OPC-UA-Fehlermeldungen und ihre Bedeutung.
Hex | Description
0xE4DD0000 | general UA Server error
0xE4DA0000 | general ADS error
0xE4DB0000 | general API error
0xE4DD0100 | Server is already connected
0xE4DD0101 | general error while establishing a connection to the UA server
0xE4DD0100 | Server is already connected
0xE4DD0101 | general error while establishing a connection to the UA server
0xE4DD0102 | failed to setup UA security
0xE4DD0103 | item ID already exists
0xE4DD0104 | item does not exist
0xE4DD0105 | invalid or unsupported item type
0xE4DD0106 | var types cannot be converted
0xE4DD0107 | device is suspended
0xE4DD0108 | vartype conversion is not supported for this type
0xE4DD0109 | a namespace with the requested name cannot be found
0xE4DD0110 | target host not found
0xE4DD0111 | timeout due to missing reply from target host
0xE4DD0112 | UA Client session handle is invalid
0xE4DD0113 | invalid node ID


OPC-UA-Client-Fehlercodes

Anhang [image] OPC-UA-Client-Fehlercodes
OPC-UA-Client-Fehlercodes
Die Funktionsbausteine des TwinCAT OPC UA Client besitzen eigene Fehlercodes, die das Auftreten eines Fehlers signalisieren und mit einer ErrorID weitere Informationen zum aufgetretenen Problem anzeigen. Diese Fehlercodeliste führt die möglichen Werte auf.
Name | Beschreibung | Oberen Bytes | Unteren Bytes
UAC_E_FAIL | Aufruf von UA Service fehlgeschlagen | 0xE4DD | 0x0001
UAC_E_CONNECTED | Server bereits verbunden |  | 0x0100
UAC_E_CONNECT | Allgemeiner Fehler beim Aufbau einer Verbindung |  | 0x0101
UAC_E_UASECURITY | UA Security konnte nicht eingerichtet werden |  | 0x0102
UAC_E_ITEMEXISTS | Element ID bereits vorhanden |  | 0x0103
UAC_E_ITEMNOTFOUND | Element existiert nicht |  | 0x0104
UAC_E_ITEMTYPE | Ungültiger oder nicht unterstützter Elementtyp |  | 0x0105
UAC_E_CONVERSION | Variablentypen können nicht konvertiert werden |  | 0x0106
UAC_E_SUSPENDED | Gerät hängt. Bitte später erneut versuchen... |  | 0x0107
UAC_E_TYPE_NOT_SUPPORTED | Konvertierung Variablentyp wird nicht unterstützt. |  | 0x0108
UAC_E_NSNAME_NOTFOUND | Kein Namensraum mit dem angegebenen Namen gefunden. |  | 0x0109
UAC_E_CONNECT_NOTFOUND | Verbindung fehlgeschlagen: Ziel-Host konnte nicht gefunden werden. |  | 0x0110
UAC_E_TIMEOUT | Timeout: d. h. Ziel-Host antwortet nicht |  | 0x0111
UAC_E_INVALIDHDL | Sitzungshandle ungültig |  | 0x0112
UAC_E_INVALIDNODEID | UA-Knoten-ID unbekannt |  | 0x0113
UAC_E_INVAL_IDENTIFIER_TYPE | Bezeichnertyp der UaNodeId ungültig |  | 0x0114
UAC_E_IDENTIFIER_NOTSUPP | Bezeichnertyp UaNodeId wird nicht unterstützt |  | 0x0115
UAC_E_INVAL_NODE_HDL | Ungültiges Knotenhandle |  | 0x0116
UAC_E_UAREADFAILED | UA Read aus unbekannter Ursache fehlgeschlagen |  | 0x0117
UAC_E_UAWRITEFAILED | UA Write aus unbekannter Ursache fehlgeschlagen |  | 0x0118
UAC_E_INVAL_NODEMETHOD_HDL | Ungültiges Methodenhandle |  | 0x0119
UAC_E_CALL_FAILED | Aufruf fehlgeschlagen, Ursache unbekannt |  | 0x011A
UAC_E_CALLDECODE_FAILED | Aufruf erfolgreich, Decodierung Rückgabewert fehlgeschlagen |  | 0x011B
UAC_E_NOTMAPPEDTYPE | Nicht zugeordneter Datentyp in Rückgabewert |  | 0x011C
UAC_E_CALL_FAILED_BADINTERNAL | Aufruf fehlgeschlagen mit UA_BadInternal |  | 0x011D
UAC_E_METHODIDINVALID | Unbekannte MethodenID (bei Aufruf zurückgegeben, auch wenn von GetMethodHdl bereitgestellt) |  | 0x011E
UAC_E_TOOMUCHDIM | Methodenaufruf hat Parameter mit mehr als 3 Dimensionen zurückgegeben - wird nicht unterstützt. |  | 0x011F
UAC_E_CALL_FAILED_INVALIDARG | Aufruf fehlgeschlagen mit OpcUa_BadInvalidArgument |  | 0x0120
UAC_E_CALL_FAILED_TYPEMISMATCH | Aufruf fehlgeschlagen mit UAC_E_CALL_FAILED_TYPEMISMATCH |  | 0x0121
UAC_E_CALL_FAILED_OUTOFRANGE | Aufruf fehlgeschlagen mit UAC_E_CALL_FAILED_OUTOFRANGE |  | 0x0122
UAC_E_CALL_FAILED_BADSTRUCTURE | Aufruf fehlgeschlagen mit OpcUa_BadStructureMissing |  | 0x0123
UAC_E_CALL_TYPEMISMATCH_OUTPARAM | Aufruf erfolgreich, aber keine Typenübereinstimmung der bereitgestellten Ausgabeinformation |  | 0x0124
UAC_E_NONVALIDTYPEINFO | Knoten hat unzureichende Typinformationen |  | 0x0125
UAC_E_INVALIDATTRIBID | Zugriff auf ungültiges Attribut von Knoten |  | 0x0126
UAC_E_NOTSUPPORTED | Das Kommando wird vom verbundenen UaServer nicht unterstützt, z.B. beim Aufruf von UA_HistoryUpdate. |  | 0x0128
DEVICE_INVALIDSIZE | Parametergröße nicht korrekt |  | 0x705
DEVICE_INVALIDDATA | Ungültige Parameterwerte |  | 0x706
Siehe auch ADS Return Codes für weitere Rückgabecodes.


ADS Return Codes

Anhang [image] ADS Return Codes
ADS Return Codes
Fehlercode: 0x000..., 0x500..., 0x700..., 0x1000......
Globale Fehlercodes
Hex | Dec | Beschreibung
0x0 | 0 | Kein Fehler
0x1 | 1 | Interner Fehler
0x2 | 2 | Keine Echtzeit
0x3 | 3 | Zuweisung gesperrt-Speicherfehler
0x4 | 4 | Postfach voll
0x5 | 5 | Falsches HMSG
0x6 | 6 | Ziel-Port nicht gefunden
0x7 | 7 | Zielrechner nicht gefunden
0x8 | 8 | Unbekannte Befehl-ID
0x9 | 9 | Ungültige Task-ID
0xA | 10 | Kein IO
0xB | 11 | Unbekannter ADS-Befehl
0xC | 12 | Win32 Fehler
0xD | 13 | Port nicht angeschlossen
0xE | 14 | Ungültige ADS-Länge
0xF | 15 | Ungültige AMS Net ID
0x10 | 16 | niedrige Installationsebene
0x11 | 17 | Kein Debugging verfügbar
0x12 | 18 | Port deaktiviert
0x13 | 19 | Port bereits verbunden
0x14 | 20 | ADS Sync Win32 Fehler
0x15 | 21 | ADS Sync Timeout
0x16 | 22 | ADS Sync AMS Fehler
0x17 | 23 | Keine Index-Map für ADS Sync vorhanden
0x18 | 24 | Ungültiger ADS-Port
0x19 | 25 | Kein Speicher
0x1A | 26 | TCP Sendefehler
0x1B | 27 | Host nicht erreichbar
0x1C | 28 | Ungültiges AMS Fragment
Router Fehlercodes
Hex | Dec | Name | Beschreibung
0x500 | 1280 | ROUTERERR_NOLOCKEDMEMORY | Lockierter Speicher kann nicht zugewiesen werden.
0x501 | 1281 | ROUTERERR_RESIZEMEMORY | Die Größe des Routerspeichers konnte nicht geändert werden.
0x502 | 1282 | ROUTERERR_MAILBOXFULL | Das Postfach hat die maximale Anzahl der möglichen Meldungen erreicht. Die aktuell gesendete Nachricht wurde abgewiesen.
0x503 | 1283 | ROUTERERR_DEBUGBOXFULL | Das Postfach hat die maximale Anzahl der möglichen Meldungen erreicht. Die gesendete Nachricht wird nicht im ADS Monitor angezeigt.
0x504 | 1284 | ROUTERERR_UNKNOWNPORTTYPE | Der Porttyp ist unbekannt.
0x505 | 1285 | ROUTERERR_NOTINITIALIZED | Router ist nicht initialisiert.
0x506 | 1286 | ROUTERERR_PORTALREADYINUSE | Die gewünschte Portnummer ist bereits vergeben.
0x507 | 1287 | ROUTERERR_NOTREGISTERED | Der Port ist nicht registriert.
0x508 | 1288 | ROUTERERR_NOMOREQUEUES | Die maximale Anzahl von Ports ist erreicht.
0x509 | 1289 | ROUTERERR_INVALIDPORT | Der Port ist ungültig.
0x50A | 1290 | ROUTERERR_NOTACTIVATED | Der Router ist nicht aktiv.
Allgemeine ADS Fehlercodes
Hex | Dec | Name | Beschreibung
0x700 | 1792 | ADSERR_DEVICE_ERROR | Gerätefehler
0x701 | 1793 | ADSERR_DEVICE_SRVNOTSUPP | Service wird vom Server nicht unterstützt
0x702 | 1794 | ADSERR_DEVICE_INVALIDGRP | Ungültige Index-Gruppe
0x703 | 1795 | ADSERR_DEVICE_INVALIDOFFSET | Ungültiger Index-Offset
0x704 | 1796 | ADSERR_DEVICE_INVALIDACCESS | Lesen und schreiben nicht gestattet.
0x705 | 1797 | ADSERR_DEVICE_INVALIDSIZE | Parametergröße nicht korrekt
0x706 | 1798 | ADSERR_DEVICE_INVALIDDATA | Ungültige Parameter-Werte
0x707 | 1799 | ADSERR_DEVICE_NOTREADY | Gerät ist nicht betriebsbereit
0x708 | 1800 | ADSERR_DEVICE_BUSY | Gerät ist beschäftigt
0x709 | 1801 | ADSERR_DEVICE_INVALIDCONTEXT | Ungültiger Kontext (muss in Windows sein)
0x70A | 1802 | ADSERR_DEVICE_NOMEMORY | Nicht genügend Speicher
0x70B | 1803 | ADSERR_DEVICE_INVALIDPARM | Ungültige Parameter-Werte
0x70C | 1804 | ADSERR_DEVICE_NOTFOUND | Nicht gefunden (Dateien,...)
0x70D | 1805 | ADSERR_DEVICE_SYNTAX | Syntax-Fehler in Datei oder Befehl
0x70E | 1806 | ADSERR_DEVICE_INCOMPATIBLE | Objekte stimmen nicht überein
0x70F | 1807 | ADSERR_DEVICE_EXISTS | Objekt ist bereits vorhanden
0x710 | 1808 | ADSERR_DEVICE_SYMBOLNOTFOUND | Symbol nicht gefunden
0x711 | 1809 | ADSERR_DEVICE_SYMBOLVERSIONINVALID | Symbol-Version ungültig
0x712 | 1810 | ADSERR_DEVICE_INVALIDSTATE | Gerät im ungültigen Zustand
0x713 | 1811 | ADSERR_DEVICE_TRANSMODENOTSUPP | AdsTransMode nicht unterstützt
0x714 | 1812 | ADSERR_DEVICE_NOTIFYHNDINVALID | Notification Handle ist ungültig
0x715 | 1813 | ADSERR_DEVICE_CLIENTUNKNOWN | Notification-Client nicht registriert
0x716 | 1814 | ADSERR_DEVICE_NOMOREHDLS | Keine weitere Notification Handle
0x717 | 1815 | ADSERR_DEVICE_INVALIDWATCHSIZE | Größe der Notification zu groß
0x718 | 1816 | ADSERR_DEVICE_NOTINIT | Gerät nicht initialisiert
0x719 | 1817 | ADSERR_DEVICE_TIMEOUT | Gerät hat einen Timeout
0x71A | 1818 | ADSERR_DEVICE_NOINTERFACE | Interface Abfrage fehlgeschlagen
0x71B | 1819 | ADSERR_DEVICE_INVALIDINTERFACE | Falsches Interface angefordert
0x71C | 1820 | ADSERR_DEVICE_INVALIDCLSID | Class-ID ist ungültig
0x71D | 1821 | ADSERR_DEVICE_INVALIDOBJID | Object-ID ist ungültig
0x71E | 1822 | ADSERR_DEVICE_PENDING | Anforderung steht aus
0x71F | 1823 | ADSERR_DEVICE_ABORTED | Anforderung wird abgebrochen
0x720 | 1824 | ADSERR_DEVICE_WARNING | Signal-Warnung
0x721 | 1825 | ADSERR_DEVICE_INVALIDARRAYIDX | Ungültiger Array-Index
0x722 | 1826 | ADSERR_DEVICE_SYMBOLNOTACTIVE | Symbol nicht aktiv
0x723 | 1827 | ADSERR_DEVICE_ACCESSDENIED | Zugriff verweigert
0x724 | 1828 | ADSERR_DEVICE_LICENSENOTFOUND | Fehlende Lizenz
0x725 | 1829 | ADSERR_DEVICE_LICENSEEXPIRED | Lizenz abgelaufen
0x726 | 1830 | ADSERR_DEVICE_LICENSEEXCEEDED | Lizenz überschritten
0x727 | 1831 | ADSERR_DEVICE_LICENSEINVALID | Lizenz ungültig
0x728 | 1832 | ADSERR_DEVICE_LICENSESYSTEMID | Lizenz der System-ID ungültig
0x729 | 1833 | ADSERR_DEVICE_LICENSENOTIMELIMIT | Lizenz nicht zeitlich begrenzt
0x72A | 1834 | ADSERR_DEVICE_LICENSEFUTUREISSUE | Lizenzproblem: Zeitpunkt in der Zukunft
0x72B | 1835 | ADSERR_DEVICE_LICENSETIMETOLONG | Lizenz-Zeitraum zu lang
0x72c | 1836 | ADSERR_DEVICE_EXCEPTION | Exception beim Systemstart
0x72D | 1837 | ADSERR_DEVICE_LICENSEDUPLICATED | Lizenz-Datei zweimal gelesen
0x72E | 1838 | ADSERR_DEVICE_SIGNATUREINVALID | Ungültige Signatur
0x72F | 1839 | ADSERR_DEVICE_CERTIFICATEINVALID | öffentliches Zertifikat
0x740 | 1856 | ADSERR_CLIENT_ERROR | Clientfehler
0x741 | 1857 | ADSERR_CLIENT_INVALIDPARM | Dienst enthält einen ungültigen Parameter
0x742 | 1858 | ADSERR_CLIENT_LISTEMPTY | Polling-Liste ist leer
0x743 | 1859 | ADSERR_CLIENT_VARUSED | Var-Verbindung bereits im Einsatz
0x744 | 1860 | ADSERR_CLIENT_DUPLINVOKEID | Die aufgerufene ID ist bereits in Benutzung
0x745 | 1861 | ADSERR_CLIENT_SYNCTIMEOUT | Timeout ist aufgetreten
0x746 | 1862 | ADSERR_CLIENT_W32ERROR | Fehler im Win32 Subsystem
0x747 | 1863 | ADSERR_CLIENT_TIMEOUTINVALID | Ungültiger Client Timeout-Wert
0x748 | 1864 | ADSERR_CLIENT_PORTNOTOPEN | ADS-Port nicht geöffnet
0x750 | 1872 | ADSERR_CLIENT_NOAMSADDR | Interner Fehler in Ads-Sync
0x751 | 1873 | ADSERR_CLIENT_SYNCINTERNAL | Hash-Tabelle-Überlauf
0x752 | 1874 | ADSERR_CLIENT_ADDHASH | Schlüssel nicht gefunden im Hash
0x753 | 1875 | ADSERR_CLIENT_REMOVEHASH | Keine weitere Symbole im Cache
0x754 | 1876 | ADSERR_CLIENT_NOMORESYM | Ungültige Antwort empfangen
0x755 | 1877 | ADSERR_CLIENT_SYNCRESINVALID | Sync Port ist gesperrt
RTime Fehlercodes
Hex | Dec | Name | Beschreibung
0x1000 | 4096 | RTERR_INTERNAL | Interner Fehler im TwinCAT Echtzeit-System.
0x1001 | 4097 | RTERR_BADTIMERPERIODS | Timer-Wert ist nicht gültig.
0x1002 | 4098 | RTERR_INVALIDTASKPTR | Task-Pointer hat den ungültigen Wert 0 (null).
0x1003 | 4099 | RTERR_INVALIDSTACKPTR | Task Stackpointer hat den ungültigen Wert 0.
0x1004 | 4100 | RTERR_PRIOEXISTS | Die Request Task Priority ist bereits vergeben.
0x1005 | 4101 | RTERR_NOMORETCB | Kein freies TCB (Task Control Block) zur Verfügung. Maximale Anzahl von TCBs beträgt 64.
0x1006 | 4102 | RTERR_NOMORESEMAS | Keine freien Semaphoren zur Verfügung. Maximale Anzahl der Semaphoren beträgt 64.
0x1007 | 4103 | RTERR_NOMOREQUEUES | Kein freier Platz in der Warteschlange zur Verfügung. Maximale Anzahl der Plätze in der Warteschlange beträgt 64.
0x100D | 4109 | RTERR_EXTIRQALREADYDEF | Ein externer Synchronisations-Interrupt wird bereits angewandt.
0x100E | 4110 | RTERR_EXTIRQNOTDEF | Kein externer Synchronisations-Interrupt angewandt.
0x100F | 4111 | RTERR_EXTIRQINSTALLFAILED | Anwendung des externen Synchronisierungs- Interrupts ist fehlgeschlagen
0x1010 | 4112 | RTERR_IRQLNOTLESSOREQUAL | Aufruf einer Service-Funktion im falschen Kontext
0x1017 | 4119 | RTERR_VMXNOTSUPPORTED | Intel VT-x Erweiterung wird nicht unterstützt.
0x1018 | 4120 | RTERR_VMXDISABLED | Intel VT-x Erweiterung ist nicht aktiviert im BIOS.
0x1019 | 4121 | RTERR_VMXCONTROLSMISSING | Fehlende Funktion in Intel VT-x Erweiterung.
0x101A | 4122 | RTERR_VMXENABLEFAILS | Aktivieren von Intel VT-x schlägt fehl.
TCP Winsock-Fehlercodes
Hex | Dec | Name | Beschreibung
0x274c | 10060 | WSAETIMEDOUT | Verbindungs Timeout aufgetreten. Fehler beim Herstellen der Verbindung, da die Gegenstelle nach einer bestimmten Zeitspanne nicht ordnungsgemäß reagiert hat, oder die hergestellte Verbindung konnte nicht aufrecht erhalten werden, da der verbundene Host nicht reagiert hat.
0x274d | 10061 | WSAECONNREFUSED | Verbindung abgelehnt. Es konnte keine Verbindung hergestellt werden, da der Zielcomputer dies explizit abgelehnt hat. Dieser Fehler resultiert normalerweise aus dem Versuch, eine Verbindung mit einem Dienst herzustellen, der auf dem fremden Host inaktiv ist—das heißt, einem Dienst, für den keine Serveranwendung ausgeführt wird.
0x2751 | 10065 | WSAEHOSTUNREACH | Keine Route zum Host Ein Socketvorgang bezog sich auf einen nicht verfügbaren Host.
 |  |  | Weitere Winsock-Fehlercodes: Win32-Fehlercodes


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.