Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


OPC Allgemein

Definition OPC

OPC steht für "Openess Productivity Collaboration" und bezeichnet eine Initiative zur Standardisierung des Datenaustausches in der Automatisierung.

Beckhoff ist aktives Mitglied der OPC-Foundation. (Weitere Information über OPC erhalten Sie unter www.opcfoundation.org )

OPC-Schnittstelle

Bislang waren Applikationen, z.B. Bedien- und Beobachtungs-Software, an die unterschiedlichen Zugriffsverfahren der jeweiligen Steuerungshersteller gebunden.
OPC ist die Spezifikation einer einheitlichen und herstellerunabhängigen Software-Schnittstelle. Diese eröffnet die Möglichkeit, auf Prozessdaten beliebiger Hersteller in einheitlicher Art und Weise zuzugreifen.

OPC-Server

Ein OPC-Server ist eine Software-Komponente, welche anderen Applikationen eine spezifizierte OPC-Schnittstelle bietet.


OPC XML DA CE Server : Overview

TS6120-0030 | TwinCAT OPC Server CE

Overview

Prerequisites

TwinCAT OPC-DA-CE requires a BECKHOFF CE device (like CX1000, CX1020, CX9001...) with large memory.

TwinCAT OPC DA CE does not support DCOM.


Overview

An OPC server represents a standardised interface for the management of process data. The process data available in the TwinCAT system must therefore be known to the OPC server, or must be made known to it at the time of configuration.
To represent this "hierarchical process space" clearly, the "Devices" are subdivided into subsidiary items.

The OPC client can browse through this representation and use it for the server's actual configuration. The TwinCAT OPC server supports the optional browser OPC interface.

Note:
This hierarchical display is not to be confused with the configuration of the OPC server that exists at run-time. The run-time configuration of the OPC server, i.e. the creation of groups, specification of the refresh time, the insertion of tags etc. is performed dynamically by the OPC client.

General

The advantage of configuration via XML with links to the symbols of the ADS devices is that this configuration only has to be carried out once. Even if, for instance, the PLC project changes (e.g. if variables are deleted, or if new variables are defined) it is not necessary to change the configuration in the OPC server: each time the OPC service starts, the namespace of the OPC server is correctly built up.

Device Definition

A device represents a TwinCAT ADS device (e.g. a PLC run-time system) that is uniquely identified by the <AdsAmsServerNetID> and the <AdsAmsPortID>.
Further information about the concept of devices in TwinCAT can be found in the general TwinCAT ADS documentation.

Configuration of the TwinCAT OPC server

  • Receiving data from the TwinCAT PLC: Configuration by variable import from TwinCAT PLC control


TwinCAT OPC Server CE for MP370 : Installation und Konfiguration

TS6120-0030 | TwinCAT OPC Server CE

TwinCAT OPC Server CE for MP370

Diese Beschreibung zeigt die Möglichkeit zur Datenkopplung eines Siemens ProTool / WinCC-Flexibel auf einem MP370 Panel via Ethernet mit einem BECKHOFF TwinCAT Gerät.

Dabei wird der TwinCAT-OPC-Server-CE (für MIPS) mit Hilfe der Siemens-Software ProSave auf das Siemens-MP370 Panel installiert. ProTool / WinCC Flexibel arbeitet als OPC-Client und kommuniziert auf dem MP370 lokal mit dem TwinCAT-OPC-Server-CE. Der OPC-Server sammelt die TwinCAT Variablen über Ethernet mit dem Beckhoff-Protokoll ADS von den TwinCAT Geräten ein.

Installation und Konfiguration

Stellen Sie sicher, dass das MP370 und der Projektierungsrechner korrekt miteinander verbunden sind. Eine geeignete Testmethode für eine korrekte Netzwerkverbindung ist das Programm "ping.exe" in der Eingabeaufforderung. Nähere Informationen über ping.exe erhalten sie durch den Befehl "ping /?" .

1. Installation des TwinCAT OPC Servers für MP370 auf dem Projektierungsrechner mit Integration in die Siemens-ProSave Umgebung

Als Voraussetzung muss ein korrekt installiertes Simatic ProTool 6.0 SP2 auf dem Projektierungsrechner vorhanden sein.

Die Installation des TwinCAT-OPC-Server-MP370 befindet sich im Verzeichnis < Installationsordner \ MP370 (MIPS) \ TwinCAT_OPC_CE_MP370.exe >.
Folgen Sie den Installationsanweisungen um den TwinCAT OPC Server CE in die ProSave-Umgebung auf dem PC zu installieren.

2. Übertragung des TwinCAT OPC Servers für MP370 mit Siemens ProSave auf das MP370 Gerät

Starten Sie ProSave mit "Start - Simatic - ProSave" und konfigurieren entsprechend Ihrer Kommunikationsvorraussetzungen Ihre Verbindung zum Simatec MP370.
In diesem Beispiel erfolgt die Kommunikation über eine serielle Verbindung :

Um den TwinCAT OPC Server CE auf das Siemens MP370 zu transferieren, wechseln Sie bitte in ProSave auf die Registriekarte "Optionen". Im Fenster verfügbare Optionen finden Sie den Eintrag "TwinCAT OPC Server CE for MP370". Um den Datentransfer zwischen Projektierungsrechner und Siemens MP370 zu ermöglichen, starten Sie auf dem Siemens MP370 zunächst den Transfermodus. Dies geschieht im Loader über den Button Transfer.
Anschließend können Sie die Installation über einen Klick auf den "»" - Button im ProSave starten. Der TwinCAT OPC Server CE wird daraufhin auf dem MP370 in den Ordner \hard disk\simatic installiert.

Sollte kein Datenaustausch entstehen, überprüfen Sie zunächst Ihre Verbindung zum Siemens MP370.
Weitere Hilfe liefert Ihnen hier der Siemens Support.

3. Konfiguration des OPC Servers

Im vorherigen Schritt haben Sie erfolgreich den Beckhoff OPC Server CE auf dem Siemens MP370 installiert. Es folgen nun zwei weitere Schritte, die einmalig durchlaufen werden müssen:

  • Für eine Kommunikation zwischen TwinCAT-OPC-Server auf dem MP370 und einem TwinCAT-Gerät (z.B. einem CX1000) müssen nun diese Kommunikationspartner miteinander bekannt gemacht werden.
    Dies geschieht auf dem MP370 mit dem Programm TwinCAT AMS Remote Manager.
  • Der TwinCAT OPC-Server CE muss konfiguriert werden um zu wissen, welche Daten (von welcher SPS ..) für OPC zur Verfügung stehen.

TwinCAT AMS Remote Manager

Sie finden das Programm "TcAmsRemoteMgr.exe" in einer MIPS-kompatiblen Version auf dem Simatic MP370 im OPC-Installationsverzeichnis "\flash\simatic". Auf dem TwinCAT-Gerät finden Sie diesen Dialog entweder im TwinCAT-System-Service oder z.B. auf dem CX1000 eine entsprechende x86-Version im Verzeichnis "\Hard Disk\System" .

Bild 3

Starten Sie bitte sowohl auf dem CX1000 als auch auf dem MP370 den TwinCAT AMS Remote Manager (siehe Bild 3). Über einen Klick auf den Button Add können Sie neue Remote Computers auf dem CX1000/MP370 einrichten. Tragen sie dazu im folgendem Fenster die entsprechenden Daten ein:

Name
 Symbolischer Name des "Remote Computers". Dieser Name kann frei vergeben werden.

AMS Net Id
 AMS Net ID des "Remote Computers". Die AMS Net Id finden sie im Eintrag "Local Computer" im TwinCAT Remote Manager.

Adresse
 IP-Adresse des "Remote Computers".

Transport
 Die Transportschicht mit der AMS Nachrichten befördert werden. TCP/IP als Transportschicht ist die Defaulteinstellung, weitere unterstützte Varianten hängen auch von der eingesetzten Hardware ab.

In diesem Beispiel ist folgende Konfiguration vorhanden:

TcAMs Remote Manager auf dem PC/CX:

  • PC/CX mit AMSNetId : 192.6.100.142.1.1
  • Auf dem PC/CX wird unter "Remote Computer" das MP370 Gerät mit der AMSNetId 192.168.0.163.1.1 eingetragen

TcAMs Remote Manager auf dem MP370:

  • MP370 mit AMSNetId : 192.168.0.163.1.1
  • Auf dem MP370 wird unter "Remote Computer" der PC/CX mit der AMSNetId 192.6.100.142.1.1 eingetragen

TwinCAT OPC Server : Konfiguration des Namespace

Einmalig muss nun der sogenannte OPC-Namespace des TwinCAT-OPC-Server-CE konfiguriert werden. Damit wird festgelegt, welche Variablen auf welchem ADS-Gerät für den OPC-Server zugänglich sind und somit via OPC für ProTool zur Verfügung stehen. Die Konfiguration des TwinCAT-OPC-Server-CE erfolgt über die Datei "CurrentConfigOPC.xml". Des Weiteren muss für jedes ADS-Gerät (z.B. jede SPS) eine <SPS-Projektname<.tpy Datei vorhanden sein.

In diesem Beispiel wird eine Exportdatei eines TwinCAT-SPS-Projektes auf das MP370 kopiert. Zu diesem Zweck finden Sie in Ihrem Simatic ProSave den Eintrag "TwinCAT OPC Configuration Update for MP370". Damit nun Ihre Konfiguration auf das MP370 kopiert wird, sind folgende Schritte nötig:

1.Schritt

  • Erstellen Sie ein TwinCAT-SPS Projekt mit den Variablen, die Sie im ProTool nutzen wollen. Mit dem Kompilieren wird eine <Projektname>.tpy Datei erzeugt.
    Kopieren Sie die <SPS-Projektname>.tpy-Datei in das Verzeichnis Simatic Protool Installationspfad\Common\PTProSave\Addon\TcOPCSvr_Config\mips.

    ACHTUNG:
    Die ProSave-Projektdatei geht von einer Datei "Plc1.tpy" aus. Wenn ir SPS-Projekt einen anderen Namen hat, so müssen Sie:
    entweder die TPY-Datei für den Transport zum MP370 umbenennen (von <projektname.tpy> nach "Plc1.tpy")
    oder die OPCconfig.pii anpassen und dort den Eintrag umbenennen (von "Plc1.tpy" nach <projektname.tpy>)

2.Schritt

  • Im selben Verzeichnis finden sie ein XML-Dokument CurrentConfigOPC.xml. Öffnen Sie diese Datei mit einem Editor (z.B. Notepad.exe) und passen sie die Datei entsprechend Ihrer Konfiguration an folgenden Punkten an:
XML Tag | Beschreibung
<Name> | Symbolischer Name der OPC-Verbindung
<AdsNetId> | AMS Net Id des Gerätes, von dem die Daten bezogen werden (z.B. vom CX1000)
<AdsPort> | ADS Port des Gerätes, von dem die Daten bezogen werden (z.B. von der CX1000-SPS : 801)
<AutoCfg> | 7 : Import aller globalen Variablen aus der TPY Datei 8 : Import der gekennzeichneten Variablen aus der TPY Datei. Diese Variante ist dringend zu empfehlen, da nicht alle SPS-Variablen geladen werden, sondern (speichersparend) nur die für OPC-vorgesehenden Variablen
<AutoCfgSymFile> | Pfad zur tpy-Datei auf dem MP370 (default: OPC-Installationsverzeichnis)

  • Speichern Sie die Änderungen in der CurrentConfigOPC.xml Datei ab und kopieren Sie die neue Konfiguration über das Simatic ProSave auf das MP370.

Ein Beispiel für die Konfiguration könnte so aussehen:

Die Konfiguration ist beendet, der TwinCAT OPC Server ist auf dem MP370 konfiguriert und kann mit dem konfigurierten ADS-Gerät Daten austauschen.

4. OPC Freischaltung für ProTool

Kopieren Sie die im Verzeichnis ... \Beckhoff OPC CX1000 -- MP370\Installation Siemens\patch_regdat enthaltenen Dateien und Ordner im das Protool – Verzeichnis und starten Sie die Datei „_patch_ptreg_dat.bat“. Alle vier Dialogfenster mit ok bestätigen.

Die Datei Protool.ini im Protool-Verzeichnis ergänzen Sie wie folgt:

[Device List ] / am Anfang der Datei
ReInit=1

[OPC] / am Ende der Datei
ServerOnMP=0
DCOM/DeviceCOM=1
[Protocol Exclude List]
[Recent File List]

Die [Protocol Exclude List] muss leer sein.
Bei der [Recent File List] dürfen Einträge stehen.

Die Konfiguration ist beendet, der TwinCAT OPC Server ist auf dem MP370 konfiguriert und kann mit dem konfigurierten ADS-Gerät Daten austauschen.

5. Update des TwinCAT OPC Server CE for MP370

Um ein Update des TwinCAT OPC Server CE for MP370 auf dem Panel zu installieren, kopieren Sie die neue „TcOpcSvrInprocServer.dll“ Datei in folgenden Ordner: ...SIEMENS\Common\PTProSave\AddOn\TcOPCSrvCE\mips

Zum Übertragen der Änderungen auf das Panel bitte Schritt 2 wiederholen.


TwinCAT OPC Server CE for MP370 : Installation und Konfiguration

TS6120-0030 | TwinCAT OPC Server CE

TwinCAT OPC Server CE : Optimierungen

Diese Beschreibung zeigt die Möglichkeit zur Minimierung des OPC-Namespace im TwinCAT-OPC-Server.

So sollten auf keinem Fall alle SPS-Variablen in den Namespace des OPC-Servers geladen werden, sondern nur eine kleinere Menge wirklich benötigter SPS-Variablen die via OPC angefragt werden.

Gerade unter einer CE-Umgebung, die für kleine Applikationen mit kleinem Speicherausbau designed ist, sollten diese Hinweise angewendet werden !

Hinweis

Generell wertet der OPC-Server die OPC-XML Konfigurationsdatei aus und findet dort die weiteren Informationen für jedes projektierte ADS-Gerät.

  • Die Option <AutoCfg>7</AutoCfg> wird dazu genutzt, um alle Variablen der TPY Datei einzulesen
    Einschränkung aktuell : Nur die globalen Variablen vom Elementardatentyp werden eingelesen. (also aktuell keine Strukturen)
  • Die Option <AutoCfg>8</AutoCfg> wird dazu genutzt, um nur die SPS- Variablen der TPY Datei einzulesen, die im SPS-Quelltext als OPC-Variablen markiert wurden.
    Einschränkung aktuell : Nur die globalen Variablen vom Elementardatentyp werden eingelesen. (also aktuell keine Strukturen)

    In diesem Fall wird die SPS-Variable bMemAlarm1 nicht im OPC-Server zur Verfügung stehen.
    Die Variable iReadOnly ist als OPC-Variable markiert und steht somit für den OPC-Client zur Verfügung. Sie wird aber mit dem OPC-Item-Property 5 (definiert von der OPC-Foundation) vom OPC-Server als "Read-Only" behandelt, es erfolgt somit kein Schreibezugriff vom OPC-Server auf diese SPS Variable.

    Im SPS-IEC1131 Editor wird das Verhalten des OPC-Servers als Kommentar hinter einer SPS Variablendeklaration modifiziert:


OPC XML DA CE Server : Overview

TS6120-0030 | TwinCAT OPC Server CE

Overview

Prerequisites

TwinCAT OPC-XML-DA-CE requires a BECKHOFF CE device (like CX1000, CX1020, CX9000, ...) with large memory.
The Microsoft IIS (Internet Information Server) web server is required on that CE devices.


OPC XML DA CE Server : Installation

TS6120-0030 | TwinCAT OPC Server CE

Installation

This document describes how to install the TwinCAT OPC XML DA Server on BECKHOFF embedded PC Controller based on CE operating system like CX1000, CX1020, CX9000 or EthernetPanels.

Prerequisites

TwinCAT OPC-XML-DA-CE requires a BECKHOFF CE device like CX1000, CX1020, etc with large memory. The Microsoft IIS (Internet Information Server) web server is required.

Step1 : Installation on host PC

Install TwinCAT supplement product "TwinCATOPCServerCE.exe" on your host PC.

License : During installation a license number will be checked. Note that OPC-CE products cost royalties per CPU.

With a correct license number the product will be installed into folder C:\TwinCAT\CE\OPC

This folder will contain a number of different CE-installation files :

  • TcOpcXmlSvrCe.I586.CAB : OPC Server XML DA (XML based) for X86 based CPUs (like CX1000)
  • TcOpcSvrCe_I586.cab : OPC Server DA (COM based) for X86 based CPUs (like CX1000)
  • TcOpcSvrCe_StrongARM.cab : OPC Server DA (COM based) for ARM based CPUs with OS PocketPC (like IPAQ)
  • TcOpcSvrCe_MIPS.cab : OPC Server DA (COM based) for MIPS based CPUs (like Siemens Panels)
  • MIPS_MP370\TwinCAT_OPC_CE_MP370.exe : Seperat installation for installation on Siemens panels with ProSave

Step 2 : Deploy installation to CE device

Deploy the file TcOpcXmlSvrCe.I586.CAB onto the CF card of the Beckhoff-CE device, this can be done

  • via shared folder (Public folder)
  • via FTP
  • via ActiveSync
  • via a CF adapter

Step 3 : Installation on CE device

The installation file "TcOpcXmlSvrCe.I586.CAB" is to be executed via regular double-click on it.

NOTE:

  • As target directory, the pre-selected (default) directory "\hard disk\www\TcOpcXmlDa" has to be confirmed with "OK"!
  • After installation of the component into the correct target folder "\hard disk\www\TcOpcXmlDa" the installation file TcOpcXmlSvrCe.I586.CAB gets removed automatically.

After confirmation with "OK", the installation into the correct target folder "\hard disk\www\TcOpcXmlDa" gets executed.

  • There is no need for a restart of the CE device.

Step 4 : Test

The URL of the OPC-XML-DA server on the CE system can be checked from host PC. Open the Internet explorer and enter the URL of the OPC Server XML DA on CE system like :
http://<ip-adress or name of CE device>/tcopcxmlda/tcopcxmlda.dll

Sample :
http://cx_0027e8/tcopcxmlda/tcopcxmlda.dll

The TcOpcXmlDa server will reply with a status page containing the product version :

HINT :
In case of problems (like receiving no HTML status data) please check if a proxy server is activated on your host PC.
After deactivating the proxy and reloading the URL the Opc XML DA server should reply with status info.


OPC XML DA CE Server : Configuration

TS6120-0030 | TwinCAT OPC Server CE

Configuration

This chapter describes how to configure the OPC XML DA Server on BECKHOFF CE based systems.

Summary :

The OPC-XML DA server is configured with default xml-configuration file. Just activate once a checkbox in PLC-Control to download the symbol information to target device.

TwinCAT Version :

  • With TwinCAT 2.10 Build 1240 (or higher) there is no manual configuration required, just acticate one check box.
  • With previous TwinCAT versions please refer to section "Manual or specific configurations" on this page.

Activate one check box

To download the current symbol information in a TPY file navigate in the PLC-Control to "Project-->Options-->TwinCAT" and check the option "Download Symbol description"

With each download of the PLC-code now also the <project-name>.TPY file is downloaded as "\hard disk\TwinCAT\Boot\CurrentPlc_1.tpy" containing information about symbols of first run time system.
(Second runtime system would be "\hard disk\TwinCAT\Boot\CurrentPlc_2.tpy" etc.)

Summary:

The OPC-XML DA server is configured with default xml-configuration file. Just activate the checkbox to download the symbol information within PLC-Control environment.

NOTE:
OPC-XML DA Server checks configuraton on startup. See notes to reload configuration today (without reboot)

Previous TwinCAT 2.10 Build 1240 / Manual or specific configurations ?

If the default configuration is not available you have to configure the opc-xml-da configuration file "\hard disk\www\TcOpcXmlDa\TcOpcXmlSvrCfg.xml" manual.

  • The <plc-project-name>.tpy file has to be deployed to the CE device. Deplayment can be done via Shared (public) folder / FTP server / ActiveSync connection / CF adapter
  • If required the opc-xml configuration file can be edited with help of "\hard disk\system\Notepadce.exe"

Sample for OPC XML DA CE server accessing multiple ADS devices

<?xml version="1.0"
encoding="utf-8" standalone="no"?>
<TcOpcXmlSvrConfiguration>
<Namespace>
    <Devices>
        <Device>
            <Name>PLC1</Name>
            <AdsNetId>0.0.0.0.0.0</AdsNetId>
            <AdsPort>801</AdsPort>
            <AdsTimeout>2000</AdsTimeout>

<AdsTimeSuspend>20000</AdsTimeSuspend>
            <AutoCfg>7</AutoCfg>
            <!-- NOTE: CurrentPlc_1.tpy will be downloaded from
PLC-Control -->
            <AutoCfgSymFile>\hard
disk\TwinCAT\Boot\CurrentPlc_1.tpy</AutoCfgSymFile>
            <Disabled>0</Disabled>
        </Device>
        <Device>
            <Name>PLC2</Name>
            <AdsNetId>0.0.0.0.0.0</AdsNetId>
            <AdsPort>811</AdsPort>
            <AdsTimeout>2000</AdsTimeout>

<AdsTimeSuspend>20000</AdsTimeSuspend>
            <AutoCfg>7</AutoCfg>
            <!-- NOTE: CurrentPlc_2.tpy will be downloaded from
PLC-Control -->
            <AutoCfgSymFile>\hard
disk\TwinCAT\Boot\CurrentPlc_2.tpy</AutoCfgSymFile>
            <Disabled>0</Disabled>
        </Device>
    </Devices>
</Namespace>
</TcOpcXmlSvrConfiguration>

NOTE:
OPC-XML DA Server checks configuraton on startup. See notes to reload configuration today (without reboot)


OPC XML DA Server : Nice to know

TS6120-0030 | TwinCAT OPC Server CE

Nice to know

This chapter describes nice helpful hints for OPC-XMLDA server (XP and CE)

OPC specification descripes the interfaces which an OPC-XMLDA server have to (MUST) implement.

As an addOn the TwinCAT OPC-XMLDA server provides additional "nice to have" functionalities..

These additional functions are initiated via the URL of the OPC-XML-DA server.
Open the Internet explorer and enter the URL of the OPC Server XML DA on target system like :

http://<ip-adress or name of device>/TcOpcXmlDa/TcOpcXmlDa.dll<Services>

<Services> could be like this :

  • Status information
  • Log information
  • Reload configuration
  • Display configuration
  • Restart server
  • Stop server

1. Status information

<Services> = "" (nothing)

SAMPLE : http://<ip-adress or name of device>/TcOpcXmlDa/TcOpcXmlDa.dll

The TcOpcXmlDa server will reply with a status page containing the product version :

2. Log information

<Services> = ?info=log

Sample : http://<ip-adress or name of device>/TcOpcXmlDa/TcOpcXmlDa.dll?info=log

3. Reload configuration file

<Services> = ?info=reload

Sample : http://<ip-adress or name of device>/TcOpcXmlDa/TcOpcXmlDa.dll?info=reload

4. Display configuration

<Services> = ?info=config

Sample : http://<ip-adress or name of device>/TcOpcXmlDa/TcOpcXmlDa.dll?info=config

NOTE : not implemented now, under construction

1. Restart of OPC-XMLDA server

<Services> = ?action=restart

Sample : http://<ip-adress or name of device>/TcOpcXmlDa/TcOpcXmlDa.dll?action=restart

2. Stop of OPC-XMLDA server

<Services> = ?action=stop

Sample : http://<ip-adress or name of device>/TcOpcXmlDa/TcOpcXmlDa.dll?action=stop

NOTE : not implemented now, under construction


OPC client : AJAX (Asynchronous Java XML)

Download complete Sample

This demo is about Java-XML driven (AJAX) HTML pages within a building automation scenario to communicate via OPC-XMLDA to the TwinCAT PLC.


Datenübernahme aus TwinCAT PLC

html> Datenübernahme aus TwinCAT PLC
TwinCAT OPC Server: Configuration

Configuration OPC Alarm & Event

TwinCAT OPC-Server offers OPC-specification OPC AE.

Sample
See this complete sample including PLC-project and the OPC-AE-configuration.

1. Step: Configuration of Alarms for TwinCAT OPC Server AE

Start TwinCAT-OPC-Configurator "Start - All Programs - TwinCAT System - TwinCAT OPC - TwinCAT OPC Configurator"

Navigate to "Alarm Definitions", right click and select menue "New".

  • Select "Digital Alarm" or "Limit Alarm".
  • For "Name" please enter a name for this alarm definition.
    This name has to be OPC conform, no special characters allowed.

Option 1 : Digital Alarm

After selecting "Digital Alarm" and entering "OK" you get into the dialog to configure in details your new "Digital Alarm".

Following settings can be done :

Type | Req./Opt. | Description
Name | Required | Name for alarm
Alarm ID | Required | Unique Alarm-ID Later, this Alarm-ID has to be linked to a PLC variable in the PLC-control
Update Rate | Required | Update rate of alarm
Value | Req |
Message | Optional | Message
Serverity | Optional |
Req. Acknowledge | Optional |
Return to Normal |  |
Disable | Optional | Disables this alarm. OPC-Server will ignore this alarm.

Option 2 : Limit Alarm

After selecting "Limit Alarm" and entering "OK" you get into the dialog to configure in details your new "Limit Alarm".

Following settings can be done :

Type | Req./Opt. | Description
Name | Required | Name for alarm
Alarm ID | Required | Unique Alarm-ID Later, this Alarm-ID has to be linked to a PLC variable in the PLC-control
Update Rate | Required | Update rate of alarm
Deadband | Required | Update rate of alarm
HiHi | Req |
Value | Optional | Message
Message | Optional |
Serverity | Optional |
Req. Acknowledge |  |
Disable | Optional | Disables this alarm. OPC-Server will ignore this alarm.

2. Step: Check and save configuration

Save new configuration by selecting menue "File - Save As...".

After successfully creating and saving of new OPC-configurationfile the next dialog offers to activate this new configuration.

Select "OK" to activate the configuration. With next startup the OPC-Server will work with new settings.

NOTE:
In case of opc server offers old previous configuration to opc-clients but a new configuration was activated this means, that OPC-server was not restarted to load fresh configuration.

3. Step: Link of PLC-Variable with Alarm-Type

With previous steps we defined a "Alarm-Template" with detailed information about alarm handling.
Now we define, which PLC variable should be handled like an alarm.

This link is configured in PLC-Control as and additional information for IEC1131-variable declaration.

Take care on following settings :

Add a comment behind PLC-variable deklaration. This comment will be interpreted by the opc-server and links this plc-variable to a previous defined alarm-template.
The alarm-template with the unique Alarm-ID was configured in step 1.

NOTE:
Today just global PLC-variables can be linked to Alarm-Templates. Elements of structures or arrays can not be configured as an OPC-alarm.
Future versions of OPC-Server will not have this limitation.

Sample :

  • PLC-Variable of Typ BOOL bAlarm1 and bAlarm2 are defined, both variables are linked to alarm-template with Alarm-ID 111. The OPC-AE-Server will publish this variable as an AE-variable.
  • PLC-Variable of Typ LREAL dblAlarmCounter is a OPC-AE variable as Limit-Alarm with alarm-template 112.

Note, the syntax is important :

bAlarm1 : BOOL; (* ~
( OPC : 1 : Enables this variable to be an OPC variable)
( OPC_PROP[6008] : 1 : Enables the Alarm)
( OPC_PROP[6009] : 111 : Description of Alarm)
*)

Each time compiling the PLC-project the PLC-Control will create the file <PLC-projectname>.tpy. This XML based file contains information about PLC-variables and their link to OPC-AE.
The OPC server will analyze this information of the TPY file., so configure the OPC-Server to know the file <PLC-projectname>.tpy Details


OPC Server : Configuration of conversions

html> OPC Server : Configuration of conversions
TwinCAT OPC Server: Configuration

Configuration OPC conversions

The OPC server offers the feature to online convert process data.

The OPC-Server takes care of online-conversion in both communication directions : :

  • Processvalue --> Communication to OPC-Server --> convertion within OPC-Server --> Communication to OPC-Client --> OPC-Client
  • OPC-Client --> Communication to OPC-Server --> convertion within OPC-Server --> Communication to process --> Processvalue

Sample :
- KL3202 offers process value of temperatures in unit 1/10 Grad Celsius, e.g. 200.
- The opc-server is configured with a conversion "Factor 10" which is linked to this plc-variable.
- The opc-client gets the process value 20 Grad.
- If opc-client writes a new value 25 Grad celsius to OPC-server, the server will convert this to 250 and writes this value to the PLC.

Sample
The complete sample contains a PLC project and an OPC conversion definition.

NOTE:
OPC-Server presents a converted variable as Datatyp "VT_R8 / Double" to OPC-client - independend of numerical datatyp in the PLC.

1. Step: Configuration of conversion for TwinCAT OPC Server

Start TwinCAT-OPC-Configurator "Start - All Programs - TwinCAT System - TwinCAT OPC - TwinCAT OPC Configurator"

Navigate to "Conversions", right click and select menue "New".

For "Name" please enter a name for this alarm definition.
This name has to be OPC conform, no special characters allowed.

With "OK" you see the dialog to configure in detail your new "Conversion".

Following settings can be done :

Type | Req./Opt. | Description
Conversion ID | Required |
Type | Required |
Claming |  |
High EU | Req |
Low EU | Optional |
High IR | Optional |
Low IR | Optional |
H Clamping |  |
L Clamping |  |
Disable | Optional | Disables this conversion. OPC-Server will ignore this conversion.

Step: Check and save configuration

Save new configuration by selecting menue "File - Save As...".

After successfully creating and saving of new OPC-configurationfile the next dialog offers to activate this new configuration.

Select "OK" to activate the configuration. With next startup the OPC-Server will work with new settings.

NOTE:
In case of opc server offers old previous configuration to opc-clients but a new configuration was activated this means, that OPC-server was not restarted to load fresh configuration.

3. Step: Link of PLC-Variable with Conversion-template

With previous steps we defined a "conversion-Template" with detailed information about conversion handling.
Now we define, which PLC variable should be handled with conversion.
This link is configured in PLC-Control as and additional information for IEC1131-variable declaration.

Take care on following settings :
Add a comment behind PLC-variable deklaration. This comment will be interpreted by the opc-server and links this plc-variable to a previous defined conversion-template.
The conversion-template with the unique conversion-ID was configured in step 1.

NOTE:
Today just global PLC-variables can be linked to conversion-templates. Elements of structures or arrays can not be configured as an OPC-conversion.
Future versions of OPC-Server will not have this limitation.

Sample :

  • PLC-Variable of Typ INT intMemCounterConversion is an OPC-DA variable which is converted by the opc-server as defined in conversion template 102.

Note, the syntax is important :

intMemCounterConversion : INT; (* ~
(OPC : 1 : available for OPC-clients)
(OPC_PROP[6010] : 1 : OPC_PROP_CONV_ENABLE)
(OPC_PROP[6011] : 102 : OPC_PROP_CONV_ID)
*)

Each time compiling the PLC-project the PLC-Control will create the file <PLC-projectname>.tpy. This XML based file contains information about PLC-variables and their link to the OPC-server.
The OPC server will analyze this information of the TPY file., so configure the OPC-Server to know the file <PLC-projectname>.tpy Details


Datenübernahme aus TwinCAT PLC

html> Datenübernahme aus TwinCAT PLC
TwinCAT OPC Server: Configuration

Configuration OPC Property IDs

OPC-spezification allows to add additional information to single OPC-items (opc-item means : a TwinCAT variable). These optional functionality is named "OPC-Item-Properties" in the OPC-spec and allows an opc-client to browse and read these additional properties.

Sample :
As an option the PLC variable "temperature" can hold addition informaton like comment (OPC-Property-ID 101) and also UNIT (OPC-Property-ID 100) which can be offered by the opc-server.

Configuration of OPC Propery ID in the PLC

Add a comment behind PLC-variable deklaration. This comment will be interpreted by the opc-server and will define OPC-Item-Properties.

NOTE:
Today just global PLC-variables can be hold item-properties. Elements of structures or arrays can not be configured.
Future versions of OPC-Server will not have this limitation.

Sample of PLC variable-declaration:
NOTE : All item-properties are optional.

lTemperatur : DWORD;
(* ~
(OPC : 1 : Make variable visible for OPC-Server)
(OPC_PROP[0005] : 3 : OPC_PROP_RIGHTS, here Read AND Write Access)
(OPC_PROP[0100] : Grad F : OPC_PROP_UNIT)
(OPC_PROP[0101] : Demovariable : OPC_PROP_DESC)
(OPC_PROP[0205] : We are the champions : OPC_PROP_SND)
(OPC_PROP[0206] : ..\..\info.html : OPC_PROP_HTML)
(OPC_PROP[0207] : ..\..\service.avi : OPC_PROP_AVI)
*)

Each time compiling the PLC-project the PLC-Control will create the file <PLC-projectname>.tpy. This XML based file contains information about PLC-variables and their link to the OPC-server.
The OPC server will analyze this information of the TPY file., so configure the OPC-Server to know the file <PLC-projectname>.tpy Details

List of supported OPC-item properties of OPC-Specification :

Property ID laut OPC Spec | Req./Opt. | Description
OPC_PROP[0005] | Optional | OPC_PROP_RIGHTS 1 : OPC-Server will publish this variable with access : OPC_READABLE 2 : OPC-Server will publish this variable with access : OPC_WRITEABLE 3 : OPC-Server will publish this variable with access : OPC_READABLE AND OPC_WRITEABLE Default : 3 : ReadWrite Zugriff
OPC_PROP[0100] | Optional | OPC_PROP_UNIT : Unit
OPC_PROP[0101] | Optional | OPC_PROP_DESC : Description
OPC_PROP[0102] | Optional | OPC_PROP_HIEU
OPC_PROP[0103] | Optional | OPC_PROP_LOEU
OPC_PROP[0106] | Optional | OPC_PROP_CLOSE
OPC_PROP[0107] | Optional | OPC_PROP_OPEN
OPC_PROP[0200] | Optional | OPC_PROP_DSP
OPC_PROP[0201] | Optional | OPC_PROP_FGC
OPC_PROP[0202] | Optional | OPC_PROP_BGC
OPC_PROP[0203] | Optional | OPC_PROP_BLINK
OPC_PROP[0204] | Optional | OPC_PROP_BMP
OPC_PROP[0205] | Optional | OPC_PROP_SND
OPC_PROP[0206] | Optional | OPC_PROP_HTML
OPC_PROP[0207] | Optional | OPC_PROP_AVI
OPC_PROP[6007] | Optional | BECKHOFF Defined : Simulation ID
OPC_PROP[6008] | Optional | BECKHOFF Defined : Alarm enabled
OPC_PROP[6009] | Optional | BECKHOFF Defined : Alarm ID
OPC_PROP[6010] | Optional | BECKHOFF Defined : Conversion enabled
OPC_PROP[6011] | Optional | BECKHOFF Defined : Conversion ID


Datenübernahme aus TwinCAT PLC

html> Datenübernahme aus TwinCAT PLC
TwinCAT OPC Server: Configuration

Configuration OPC Simulation

The OPC-Server offers to simulate process-values. In this case no communication to the ADS-device (like PLC) is done instead simulated values are send to OPC-client.
Different simulation templates like sinus, ramp, random etc. are available to be configured with detailed behaviour (amplitude, start /stop values).

The feature "Simulation" ist available in OPC Server version V4.0.x.x.
OPC-Server version V4.1.x.x offers a multiple more performant access to TwinCAT-devices, the simulation-mode is under construction andnot supported today.

The OPC-Server offers

  • simulation of all process values
  • simulation of some specific process values

It is not possible to combine both simulated and real-process values.

Sample
The complete sample contains both, the PLC project and the definition of OPC-simulation.

1. Step: Configuration of simulation-templates for TwinCAT OPC Server

Start TwinCAT-OPC-Configurator "Start - All Programs - TwinCAT System - TwinCAT - TwinCAT OPC Configurator"

Navigate to "Simulations", right click and select menue "New".

For "Name" please enter a name for this simulation template.
This name has to be OPC conform, no special characters allowed.

With "OK" you get into the dialog to configure in details your new "Simulations Signal".

Following settings can be done :

Signal Type | Req./Opt. | Description
0 : ReadCount | Optional |
1 : WriteCount | Optional |
2 : Random | Optional |
3 : Ramp | Optional |
4 : Sine | Optional |
5 : Square | Optional |
6 : Triangle | Optional |
7 : Stepp | Optional |
Disable | Optional | Disables this signal. OPC-Server will ignore this signal.

2. Step: Check and save configuration

Save new configuration by selecting menue "File - Save As...".

After successfully creating and saving of new OPC-configurationfile the next dialog offers to activate this new configuration.

Select "OK" to activate the configuration. With next startup the OPC-Server will work with new settings.

NOTE:
In case of opc server offers old previous configuration to opc-clients but a new configuration was activated this means, that OPC-server was not restarted to load fresh configuration.

3. Step: Link of PLC-Variable with Alarm-Type

With previous steps we defined a "simulation-template" with detailed information about simulation behaviour.
Now we define, which PLC variable should be handled like an simluation.

This link is configured in PLC-Control as and additional information for IEC1131-variable declaration.

Take care on following settings :

Add a comment behind PLC-variable deklaration. This comment will be interpreted by the opc-server and links this plc-variable to a previous defined simulation-template.
The simulation-template with the unique Simulation-ID was configured in step 1.

NOTE:
Today just global PLC-variables can be linked to Simulation-Templates. Elements of structures or arrays can not be configured as an simulated variable.
Future versions of OPC-Server will not have this limitation.

Sample :

  • PLC-Variable of Typ LREAL dblMemAlarmCounter is a OPC variable linked to simulation template 6.
    The OPC-Server will not access this PLC variable, but instead give simulated values back to OPC-client.

Note, the syntax is important :

dblMemAlarmCounter : LREAL; (* ~
(OPC : 1 : available for OPC-clients)
(OPC_PROP[6006] : 1 : OPC_PROP_SIMU_ENABLE)
(OPC_PROP[6007] : 6 : OPC_PROP_SIMU_ID)
*)

Each time compiling the PLC-project the PLC-Control will create the file <PLC-projectname>.tpy. This XML based file contains information about PLC-variables and their link to simulation templates.
The OPC server will analyze this information of the TPY file., so configure the OPC-Server to know the file <PLC-projectname>.tpy Details


OPC DA CE Server : Configuration

TwinCAT OPC-DA CE server: Configuration

Configuration

This chapter describes how to configure the TwinCAT OPC DA Server CE on BECKHOFF CE based systems.

Summary :

The OPC-DA server CE is configured with default xml-configuration file. Just activate once a checkbox in PLC-Control to download the symbol information to target device.

With TwinCAT 2.10 Build 1240 (or higher) there is no manual configuration required. Please refer to section "Zero configuration" on this page.

With previous TwinCAT versions please refer to section "Manual or specific configurations" on this page.

Zero configuration (requires TwinCAT 2.10 on host PC)

Details :

  • The OPC-DA-CE configuration file "\hard disk\TwinCAT\OPC\CurrentConfigOPC.xml" contains the list of ADS-devices which are available via OPC-DA-CE interface.
  • By default this list is pre-configured for one local PLC-runtime system (first PLC runtime-system on ADS-port 801)
  • By default the required symbol-information is linked to \hard disk\TwinCAT\Boot\CurrentPlc_1.tpy

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<TcOpcXmlSvrConfiguration>
<Namespace>
<Devices>

<Device>
<Name>PLC1</Name>
<AdsNetId>0.0.0.0.0.0</AdsNetId>
<AdsPort>801</AdsPort>
<AdsTimeout>2000</AdsTimeout>
<AdsTimeSuspend>20000</AdsTimeSuspend>
<AutoCfg>7</AutoCfg>
<!-- NOTE: CurrentPlc_1.tpy will be downloaded from PLC-Control -->
<AutoCfgSymFile>\hard disk\TwinCAT\Boot\CurrentPlc_1.tpy</AutoCfgSymFile>
<Disabled>0</Disabled>
</Device>

</Devices>
</Namespace>
</TcOpcXmlSvrConfiguration>

With TwinCAT Version 2.10 Build 1240 the PLC Control allows to download the symbol file <plc-project-name>.TYP to the target TwinCAT machine. The TPY file contains information about all available PLC-variables in the PLC-project.
OPC-DA-CE Server requires this TPY-information.

To download the current symbol information in a TPY file navigate in the PLC-Control to "Project-->Options-->TwinCAT" and check the option "Download Symbol description"

With each download of the PLC-code now also the <project-name>.TPY file is downloaded as "C:\TwinCAT\Boot\CurrentPlc_1.tpy" containing information about symbols of first run time system.
(Second runtime system would be "C:\TwinCAT\Boot\CurrentPlc_2.tpy" etc.)

Summary:

The OPC-DA-CE server is configured with default xml-configuration file. Just activate the checkbox to download the symbol information within PLC-Control environment.
OPC-DA-CE Server checks configuraton on startup of OPC-Server. If new tpy varaibles are downloaded into PLC and these variables should be available via OPC-Server the OPC-server needs a restart. (Normally this is done by just starting up OPC-client again)

Optional manual or specific configurations ?

If the default configuration is not available you have to configure the opc-da-CE configuration file "\hard disk\TwinCAT\OPC\CurrentConfigOPC.xml" manual.

Sample for OPC-DA-CE server accessing multiple ADS devices

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<TcOpcXmlSvrConfiguration>
<Namespace>
<Devices>

<Device>
<Name>PLC1</Name>
<AdsNetId>0.0.0.0.0.0</AdsNetId>
<AdsPort>801</AdsPort>
<AdsTimeout>2000</AdsTimeout>
<AdsTimeSuspend>20000</AdsTimeSuspend>
<AutoCfg>7</AutoCfg>
<!-- NOTE: CurrentPlc_1.tpy will be downloaded from PLC-Control -->
<AutoCfgSymFile>\hard disk\TwinCAT\Boot\CurrentPlc_1.tpy</AutoCfgSymFile>
<Disabled>0</Disabled>
</Device>

<Device>
<Name>PLC2</Name>
<AdsNetId>0.0.0.0.0.0</AdsNetId>
<AdsPort>811</AdsPort>
<AdsTimeout>2000</AdsTimeout>
<AdsTimeSuspend>20000</AdsTimeSuspend>
<AutoCfg>7</AutoCfg>
<!-- NOTE: CurrentPlc_2.tpy will be downloaded from PLC-Control -->
<AutoCfgSymFile>\hard disk\TwinCAT\Boot\CurrentPlc_2.tpy</AutoCfgSymFile>
<Disabled>0</Disabled>
</Device>

</Devices>
</Namespace>
</TcOpcXmlSvrConfiguration>


Receiving data from the TwinCAT PLC

TwinCAT OPC server: Configuration

Receiving Data from the TwinCAT I/O task

1st Step TwinCAT I/O task configuration

In the TwinCAT System Manager navigate through "System configuration ->Additional tasks -> Task x". Once there, activate "Create symbol entry".

.

2nd Step Import into the TwinCAT OPC server

Start TwinCAT-OPC-Configurator "Start - All Programs - TwinCAT System - TwinCAT OPC - TwinCAT OPC Configurator"

In the left navigationtree please select "I/O Devices" with a right click the menu item "New".

Enter a name for that ADS device in field "Name".

The name has to be OPC conform. Special characters are not allowed.

The device-name will be part of the ItemID later.
Sample: TwinCAT-PLC was defined with a variable "Temp". Choosing the devicename as "IO1" the opc-server present the variable as "IO1.Temp".

With click on "OK" we get the new dialog for further settings of device :

Following settings have to be checked :

Type | Req./Opt. | Description
Name | Req | Name for device like "IO1". OPC-Client browse this name
Description | Optional |
AutoCfg | Optional | 5 : Upload symbolic from ADS-device
AutoCfgFile | Optional | will be ignored
AdsPort | Req | Number of ADS-PortID, like 301 for first IO task 302 for next IO task ...
AdsNetId | Optional | specific ADS-NetId, like "174.12.15.45.1.1" Note: If not specified or like "0.0.0.0.0.0", the OPC-Server will always communicate to AdsNetId of local ADS-router
AdsTimeout | Optional | ADS timeout in ms for this ADS device. If ADS device will not replay within this time, the OPC-Server will set the requested variables to "BAD QUALITY"
AdsTimeSuspend | Optional | ADS suspend time in ms for this ADS device, if the ads communication fails. If an ADS device is running, it does not make sense to communicate with high frequence to that device. In case of ads-communication trouble the OPC-Server will wait till next ads-request to that device.
Disable | Optional | Disables this device. OPC-Server will ignore this device.

See detailed description in apendix.

3 rd step : Check and save configuration

Save the configuration unter current name or select menu "File - Save As..." to insert a new name.
The OPC-Configurator will save the XML based file.

After saving the OPC-configurationfile we get the option to activate this configuration to be the configuration for next startup of OPC-Server.

After selecting "Yes" this current configuration will be the start-configuration of the opc-server. With next start of OPC-Server this new configuration will be active.

NOTE:
If you activated a new OPC-configuration, but the OPC-Server still has old namespace and settings the reason is that the OPC-Server was not stopped and restartet.


Übersicht

Ein OPC-Server stellt eine standardisierte Schnittstelle zur Verarbeitung von Prozessdaten dar. Die im TwinCAT-System zur Verfügung stehenden Prozessdaten müssen daher dem OPC-Server bekannt sein, bzw. zur Zeit per Konfiguration bekannt gegeben werden.
Für eine übersichtliche Darstellung dieses sogenannten hierarchischen Prozessraumes wird dieser in "Devices" mit unterlagerten Items gegliedert.

Der OPC-Client kann durch diese Darstellung browsen und dies zur eigentlichen Konfiguration des Servers nutzen. Der TwinCAT-OPC-Server unterstützt die optionale OPC-Schnittstelle des Browsers.

Hinweis:
Diese hierarchische Darstellung ist nicht zu verwechseln mit der zur Laufzeit existierenden Konfiguration des OPC-Servers. Die Laufzeit-Konfiguration des OPC-Server, d.h. das Anlegen von Groups, der Festlegung der Refreshzeit, das Hinzufügen der Tags etc., erfolgt dynamisch durch den OPC-Client.

Allgemein

Der Vorteil der Konfiguration per XML mit Links auf die Symbolik der ADS-Devices besteht darin, dass diese Konfiguration nur einmalig durchgeführt werden muss: Auch wenn sich z.B. das SPS -Projekt ändert (z.B. Variablen entfallen oder neue Variablen werden definiert) so muss die Konfiguration im OPC-Server nicht geändert werden: Bei jedem Start des OPC-Servers wird der Namespace des OPC-Servers korrekt aufgebaut.

Definition Device

Ein Device stellt ein TwinCAT-ADS-Gerät (z.B. ein SPS-Laufzeitsystem) dar, welches eindeutig durch die <AdsAmsServerNetID> und <AdsAmsPortID> gekennzeichnet ist.
Weitere Informationen zum TwinCAT-Geräte Konzept entnehmen Sie der allgemeinen TwinCAT-ADS Dokumentation.

Konfiguration TwinCAT OPC Server

  • Datenübernahme aus TwinCAT PLC: Konfiguration per Variablenimport aus der TwinCAT-PLC-Control


Lizensierung

TwinCAT OPC Server: OPC Compliance Zertifikat

OPC Compliance Zertifikat

Die OPC Foundation bietet Mitgliedern der Organisation ein Compliance-Testtool. Dieses Tool testet die Funktionalitäten und Schnittstellen der OPC-Server. Für OPC-Clients ist aktuell kein Testtool verfügbar.

Der Test eines Servers sollte nur von fachkundigem Personal durchgeführt werden, ansonsten könnte es das Ergebnis verfälschen.
Beispiel:
In einem Testfall schreibt das OPC-Compliance-Testtool auf Variablen im OPC-Server, liesst diese anschliessend wieder zurück und führt einen Vergleich der Werte durch.
Würde es sich bei dieser Testvariable um eine SPS-Variable handeln welche sich zyklisch in der SPS verändert, so wird dieser OPC-Testfall nicht bestanden.

Compliance Zertifikat

Diese und weitere aktuelle OPC-Zertifikate sind bei der OPC-Foundation im Web gelistet:

OPC Zertifikate im Web : http://www.opcfoundation.org/05_products/05_self_cert.asp


Übersicht

  • OPC Spezifikation DataAccess 1.0a und 2.0
  • Freie Auswahl der TwinCAT Geräte (ADS-Devices): PLC / IO / NC / CAM / ...
  • Zugriff via TwinCAT PLC / TwinCAT I/O bzw. BusController auf alle von TwinCAT unterstützten Feldbusse (Lightbus / Profibus DP / Interbus-S / CANopen / DeviceNet / ...)
  • Zugriff auf TwinCAT-Variablen per Adresse / per Name / per generischem ADS-IndexGroup und IndexOffset
  • Optimierter Datenzugriff vom OPC-Server auf TwinCAT-Variablen
  • Simulationsmodus (Sinus, Rampe, Random, None) für Variablen
    (z.B. für Test einer OPC-Client/Server Kommunikation ohne Zugriff auf physikalisches I/O)
  • Einfache, einmalig notwendige Konfiguration per XML

Eigenschaften Evaluierungsversion

Bei der Evaluierungsversion handelt es sich um eine, für die Dauer von 30 Tagen, zeitlich begrenzte Vollversion. Anschließend schaltet der OPC-Server auf seinen internen Simulationsmodus um. Dadurch werden die Prozesswerte simuliert, es findet kein Zugriff mehr auf die ADS-Geräte statt.

Die zeitliche Begrenzung der Evaluierungsversion kann durch Erwerb einer TwinCAT-OPC Software-Lizenz mit der Eingabe eines gültigen Registrierungsschlüssel aufgehoben werden.

Integration in das TwinCAT System

Der OPC-Server stellt als Gateway via ADS die Verbindung zum TwinCAT System her und bietet OPC-Clients das spezifizierte OPC-DA / AE -Interface an.

Voraussetzungen

  • Microsoft Windows NT 4 / Windows 2000 / XP / CE (MIPS / ARM / X86)
  • TwinCAT v2.6 (oder höher)

Bitte verwenden Sie aktuelle Service-Packs.

Lieferumfang

Die Installationsversion umfasst

  • TwinCAT OPC Server (DataAccess und Alarm & Events)
  • Dokumentation
  • OPC-Test-Client (für lokalen Zugriff auf OPC-Server)


Übersicht

TwinCAT OPC Server: Eigenschaften

Die folgenden Informationen gelten für den OPC-Server auf einer PC Plattform. Auf einer CE-Plattform sind diese Informationen nicht relevant.

OPC Server als EXE / DLL (Out-of-Process / Inprocess)

Der TwinCAT OPC V4.1 steht in der Form eines "Out-of-Process"-Servers (Dateiendung EXE) und als "Inprocess"-Servers (Dateiendung DLL) zur Verfügung.

ProgID
Der OPC-Client verwendet für den Kommunikationsaufbau zum OPC-Server die sogenannte ProgID. Für den TwinCAT-OPC-Server V4.1 ist diese ProgID "BECKHOFF.TwinCATOpcServerDA".
Die PROGID ist für den OPC-Server als EXE und die DLL Version identisch.

Diagnose : Welcher Typ (EXE oder DLL) ist aktiv ?

Starten Sie den TwinCAT-OPC-Konfigurator "Start - Alle Programme - TwinCAT System - TwinCAT OPC - TwinCAT OPC Configurator"

Wählen Sie den Bereich "OPC Server Settings". Unter "Server Modus" können Sie die aktuelle Einstellung ablesen.

Aktivierung des TwinCAT OPC-Servers als Inproc-Server (DLL)

Wählen Sie unter "Server Mode" die Option "Inproc (DLL)" und bestätigen Sie die Wahl mit "Apply"

Resultat :
Der TwinCAT-OPC-Server arbeitet nun als DLL im Prozessraum des jeweiligen OPC-Clients. Der TwinCAT-OPC Server ist somit als eigenständiger Prozess nicht im Taskmanager sichtbar.

Vorteil:
Der wesentliche Vorteil dieser Variante kommt zum Tragen, wenn mehrere OPC-Clients gleichzeitig mit dem TwinCAT OPC-Server arbeiten. In diesem Fall bekommt jeder OPC-Client seinen "eigenen, für ihn persönlich zuständigen" OPC-Server.
Jeder OPC-Client hat somit seinen eigenen performanten OPC-Kanal zu den TwinCAT-Geräten.
Vor allem Schreib-Aufträge über den OPC-Server zum ADS-Gerät sind deutlich performanter.

Nachteil:
Jeder OPC-Client bekommt seinen "eigenen, für ihn persönlich zuständigen" OPC-Server. Jeder OPC-Server hat seine eigene ADS Kommunikation zum ADS-Gerät, Daten werden somit ggf. mehrfach vom ADS-Gerät angefragt.

Aktivierung des TwinCAT OPC-Servers als Out-of-process-Server (EXE)

Wählen Sie unter "Server Mode" die Option "Out-of-Process (EXE)" und bestätigen Sie die Wahl mit "Apply"

Resultat :
Der TwinCAT-OPC-Server arbeitet nun als EXE, jeder OPC-Client arbeitet mit der einen, einzigen Instanz des OPC-Servers.
Der TwinCAT-OPC Server ist in dieser Variante als eigenständiger Prozess im Taskmanager sichtbar.

Vorteil:
Wenn mehrere OPC-Clients gleichzeitig mit dem TwinCAT OPC-Server arbeiten, werden sämtliche Anfragen von einer einzigen Instanz des OPC-Servers bearbeitet. Diese eine Instanz des OPC-Servers eliminiert bzw. minimiert doppelte Anfragen von Variablen vom ADS-Gerät.

DCOM:
1. Von DCOM Verbindungen raten wir ab.
2. Sollte die DCOM Verbindung dennoch notwendig sein, so erfolgt dies mit dem OPC-Server in der Option "Out-of-process".


Netzwerk via TwinCAT ADS

Der TwinCAT-OPC-Server führt die Kommunikation mit den TwinCAT-Komponenten (SPS-Laufzeitsysteme, BusKlemmen Controller etc.) über TwinCAT-ADS durch. Da diese Dienste auch im Netzwerk zur Verfügung stehen, kann der TwinCAT-OPC-Server auch mit im Netzwerk vorhandenen TwinCAT-Komponenten kommunizieren.

Die für eine ADS-Kommunikation über Netzwerk erforderlichen Einstellungen entnehmen Sie bitte der ADS Referenz.

Einstellungen im OPC-Server

Ein ADS-Kommunikationspartner wird prinzipiell durch zwei Parameter festgelegt: Der sog. "AdsAmsNetId" (z.B. 1.2.3.4.5.6") und der "PortId" (z.B. 801 für das erste SPS-Laufzeitsystem).

Sollen per ADS mit z.B. dem ersten SPS-Laufzeitsystem auf einem weiteren PC Daten ausgetauscht werden, so muss im OPC-Server unter den "Device-Einstellungen" die AdsAmsNetId des Ziel-PCs und "801" als PortId eingetragen werden.

Hinweis

Wenn möglich, sollte aus Performancegründen die Option "Netzwerk via Client" - Protokoll gewählt werden.


Netzwerk via Client Protokoll

Visualisierungs-Systeme bieten teilweise ein eigenes Protokoll zur Überbrückung des Netzwerkes an. Dazu wird ein OPC-Client des Visualisierungs-Anbieters mit auf dem TwinCAT-Steuerungs-PC installiert.

Der Datenfluss erfolgt somit wie folgt:

Performance-Vorteil

Der wesentliche Vorteil dieser Konfiguration besteht darin, dass das Netzwerk wesentlich weniger ausgelastet ist, da dort nur die veränderten Prozesswerte ausgetauscht werden: Der OPC-Server prüft zyklisch den gesamten Prozess, gibt an den OPC-Client jedoch nur die Veränderungen im Prozess weiter.


Netzwerk via DCOM

Falls Sie einen Datenaustausch zwischen einem OPC-Client und dem TwinCAT-OPC Server über Netzwerk via DCOM ermöglichen wollen (müssen), muss diese DCOM-Zugriffsart zuvor konfiguriert sein.

Der Datenfluss stellt sich dann wie folgt dar:

In den folgenden Schritten werden die notwendigen Einstellungen für den PC beschrieben, auf dem der TwinCAT-OPC-Server installiert ist.
(Für den PC auf dem der OPC-Client installiert ist übernehmen Sie den Schritt 1. )

Voraussetzung

Es wird vorausgesetzt, dass sämtliche PC's, welche via DCOM eine OPC-Client/Server Verbindung aufnehmen sollen, bereits für den Netzwerkbetrieb eingerichtet sind (d.h. konfigurierte Netzwerkkarte mit TCP/IP-Protokoll).

Schritt 1

Über "Start"->"Ausführen…" starten Sie "DCOMcnfg" und wählen den Dialog "Default Einstellungen".

  • Aktivieren Sie "Enable Distributed COM on this computer"
  • Wählen Sie "None" bei "Default Authentication Level"
  • Wählen Sie "Anonymous" bei "Default Impersonation Level"

Schritt 2

Wählen Sie den Dialog „Applications" und anschließend den Eintrag „TwinCAT OPC Server DA" in der Liste aus. Per Doppelklick oder über „Einstellungen" gelangen Sie in einen weiteren Dialog.

Schritt 3

Wählen Sie den Dialog „Location" und aktivieren Sie dort „Run application on this computer".

Schritt 4

Wählen Sie den Dialog „Security".

  • Aktivieren Sie "Use custom access permissions" und wählen „Jeder"
  • Aktivieren Sie „Use custom configuration permissions" und wählen für „Jeder" den Zugriff „Full control"
  • Aktivieren Sie „Use custom launch permissions" und wählen Sie „Jeder"


TwinCAT OPC Server CE for MP370 : Installation und Konfiguration

TwinCAT OPC Server

TwinCAT OPC Server : Optimierungen

Bei Problemen z.B. mit der Performance vom OPC-Server sollten folgende Punkte geprüft werden:

1. Minimierung des OPC-Namespace im TwinCAT-OPC-Server:

  • Es sollten im OPC-Namespace grob nur die Variablen zur Verfügung gestellt werden, die auch per OPC-Interface zur Verfügung stehen müssen.

    Es macht keinen Sinn 700.000 SPS Variablen in den Namespace des OPC-Servers zu laden, obwohl ein Scada-System möglicherweise nur 10.000 Variablen benötigt.

    Die Größe des OPC-Namespace macht sich bemerkbar im längeren Aufstartverhalten des OPC-Servers und im notwendigen Speicherverbrauch.

    Optimierungsmöglichkeit:
    1. Variante: Export der für OPC relevanten POUs aus der SPS.

    Wählen Sie in der TwinCAT-PLC Entwicklungsumgebung "Projekt" ->"Optionen" ->"Symbolkonfiguration". Aktivieren Sie dort "Symboleinträge erzeugen" und wählen Sie unter "Symbolfile konfigurieren.." mit der Maus die Bereiche aus, die Sie exportieren möchten. (z.B. globale Variablen).

    In dem SPS-Projektverzeichnis liegt nach einem Kompilieren des SPS Projektes nun eine Symboldatei mit der Endung "<Projektname>.sym".

    HINWEIS:

    • Bei jedem Kompilieren des SPS-Projektes wird die *.SYM Datei automatisch erneuert.
    • Der OPC-Server importiert auch Struktur- und Array-Elemente aus SYM-Dateien

    2. Variante: Markierung der für OPC relevanten Variablen in der SPS.

    Diese Variante basiert auf der TwinCAT-Exportdatei *.TPY
    Anleitung

2. OPC-Server als EXE oder als DLL ?

  • Argumente für den Einsatz als EXE:
    - Ein einziger OPC-Client greift auf Daten des TwinCAT-OPC-Server zu.
    - Der OPC-Client befindet sich auf einem anderen PC als der OPC-Server. Das Netzwerk wird per DCOM überbrückt.
  • Argumente für den Einsatz als DLL:
    - Mehr als ein einziger OPC-Client greift auf Daten des TwinCAT-OPC-Server zu : Anstatt das ein einziger OPC-Server als EXE seine CPU Zeit aufteilen muss um mehrere OPC-Clients zu bedienen, kann der OPC-Server als DLL arbeiten. Somit hat jeder OPC-Client seinen "eigenen" OPC-Server mit einem "eigenen" ADS-Kommunikationskanal in die SPS. Dies führt zu einem deutlichen Performance Vorteil.

Konfiguration als EXE oder als DLL

3. OPC-Server via DCOM

  • Bei der Installation von OPC-Produkten wird neben dem eigentlichen OPC-Server auch sogenannte "OPC common components" installiert. Diese Dateien werden von der OPC-Foundation zur Verfügung gestellt.

    Die Installation der BECKHOFF-OPC-Produkte wurden überarbeitet um diese Komponenten in der von der OPC-Foundation empfohlenen Variante zu installieren.

    Installationsänderungen erfolgt : 07/2004 ab TwinCAT OPC-Server V4.1.0.37


Lizensierung

TwinCAT OPC Server: Lizenzierung

Die folgenden Informationen gelten für den OPC-Server auf einer PC Plattform. Auf einer CE-Plattform sind diese Informationen nicht relevant.

Lizenzierung

TwinCAT-OPC ist ohne Registrierungsschlüssel als Evaluierungsversion für die Dauer von 30 Tagen kostenlos nutzbar. Für eine weitergehende Verwendung ist eine Registrierung erforderlich. Über diese Registrierung erwirbt man eine Lizenz zur Nutzung der Software.

Registrierungs-Anleitung

Während der Installation

Bei der Installation von TwinCAT-OPC kann der Registrierungs-Schlüssel (z.B. K123-4567-8901) in das entsprechende Feld des Setup-Programms eingetragen werden. Die zeitliche Begrenzung der Evaluierungsversion ist somit aufgehoben.

Ist zum Zeitpunkt der Installation kein Schlüssel verfügbar, so geben Sie als Schlüssel bitte "DEMO" ein. Die auf 30 Tage zeitlich begrenzte TwinCAT-OPC-Evaluierungsversion wird installiert.

Nachträgliche Registrierung einer Evaluierungsversion

Starten Sie den TwinCAT OPC Konfigurator TcOpcCfg.exe und wählen SIe den Bereich "Registration".
Tragen Sie einen gültigen Registriernummer im entsprechenden Feld ein und bestätigen Sie die Eingabe mit "Register". Nun wird die zeitliche Begrenzung der Evaluierungsversion aufgehoben.


Licensing

TwinCAT OPC server: XML Schemata

Beschreibung der TwinCAT-OPC-Server XML-Konfiguration

Schemata

Namespace

Devices

Device <see Device-Parameters>

Device <see Device-Parameters>

SimulationSignals

Simulation <see Signal-Parameters>

Simulation <see Signal-Parameters>

Simulation <see Signal-Parameters>

Simulation <see Signal-Parameters>

...

Conversions

Conversion <see Conversion-Parameters>

Conversion <see Conversion-Parameters>

Conversion <see Conversion-Parameters>

Conversion <see Conversion-Parameters>

...

Device-Parameters

Type | Req./Opt. | Description
Name | Req | Name for device like "PLC1". OPC-Client browse this name
Description | Optional |
AdsPort | Req | Number of ADS-PortID, like 801 for first PLC-runtime system
AdsNetId | Optional | specific ADS-NetId, like "174.12.15.45.1.1" Note: If not specified or like "0.0.0.0.0.0", the OPC-Server will always communicate to AdsNetId of local ADS-router
AdsTimeout | Optional | ADS timeout in ms for this ADS device
AdsTimeSuspend | Optional | ADS suspend time in ms for this ADS device, if the ads communication fails
AutoCfg | Optional | 0 : do not include symbol-file defined under <AutoCfgSymFile> 1 : Include sym-file of TwinCAT-PLC defined under <AutoCfgSymFile> 2 : Include sym-file of TwinCAT-BCxxxx-project defined under <AutoCfgSymFile> 5 : Upload symbolic from ADS-device 7 : Include tpy-file of TwinCAT28-project defined under <AutoCfgSymFile> 8 : Include tpy-file of TwinCAT28-project defined under <AutoCfgSymFile>, but import only symbols with symbol-property "OPC=1"
AutoCfgSymFile | Optional | full path and name of symbol-file to be included like "C:\Test\demo.sym" or "\\User1\Test\demo.sym" or "C:\User1\Test\demo.tpy"

Signal-Parameters

Type | Req./Opt. | Description
SignalID | Req | unique ID-number which identifies this simulation-signal
SignalDesc | Optional
SignalType Req 0 : Read Count

1 : Write Count
2 : Random
3 : Ramp
4 : Sine
5 : Square
6 : Triangle
7 : Step
8 : Reserver
9 : Step

Read Count : incremented by one every time when the item is read

Write Count : incremented by one every time when the item is written

Random: generates random value within the Amplitude range starting with Position

Ramp, Sine, Square, Triangle, Step: (periodical signals) Their time behavior is influenced by Period and Phase parameters. Period specifies the signal frequency, while Phase moves the signal origin on the time axis

Square and Triangle signal types have one more parameter: Ratio. Ratio defines Triangle signal steepness, or Square signal H/L proportions. NumSteps parameter of the Step signal defines a number of steps signal amplitude will be divided into.

NumSteps | Optional, depends on <SignalType>
Amplitude | Optional, depends on <SignalType>
Period | Optional, depends on <SignalType>
Phase | Optional, depends on <SignalType>
Position | Optional, depends on <SignalType>
Ratio | Optional, depends on <SignalType>

Conversion-Parameters

Type | Req./Opt. | Description
ConversionID | Req | unique ID-number which identifies this conversion
ConversionDesc | Optional |
ConversionType | Req | 0 : NoConversion 1 : LinearConversion
Clamping | Optional | 0 : No clamping 1 : Clamp on EU 2 : Clamp as specified If clamping is active, the data value will be limited to its High clamp/EU value, when it exceeds the upper limit, and similarly with Low clamp parameter.
HighClamp | Optional, depends on <ConversionType>/<Clamping> | 1.0 (Default)
LowClamp | Optional, depends on <ConversionType>/<Clamping> | 0.0 (Default)
HighEU | Optional, depends on <ConversionType>/<Clamping> | engineering unit (client scale) 1.0 (Default)
LowEU | Optional, depends on <ConversionType>/<Clamping> | engineering unit (client scale) 0.0 (Default)
HighIR | Optional, depends on <ConversionType>/<Clamping> | instrument range (device scale) 10000 (Default)
LowIR | Optional, depends on <ConversionType>/<Clamping> | instrument range (device scale) 0 (Default)


TwinCAT OPC Server CE for MP370 : Installation und Konfiguration

TwinCAT OPC Server CE for MP370

TwinCAT OPC Server CE für MP370

Diese Beschreibung zeigt die Möglichkeit zur Datenkopplung eines Siemens ProTool / WinCC-Flexibel auf einem MP370 Panel via Ethernet mit einem BECKHOFF TwinCAT Gerät.

Dabei wird der TwinCAT-OPC-Server-CE (für MIPS) mit Hilfe der Siemens-Software ProSave auf das Siemens-MP370 Panel installiert. ProTool / WinCC Flexibel arbeitet als OPC-Client und kommuniziert auf dem MP370 lokal mit dem TwinCAT-OPC-Server-CE.
Der OPC-Server sammelt die TwinCAT Variablen über Ethernet mit dem Beckhoff-Protokoll ADS von den TwinCAT Geräten ein.

Installation und Konfiguration

Stellen Sie sicher, dass das MP370 und der Projektierungsrechner korrekt miteinander verbunden sind. Eine geeignete Testmethode für eine korrekte Netzwerkverbindung ist das Programm "ping.exe" in der Eingabeaufforderung. Nähere Informationen über ping.exe erhalten sie durch den Befehl "ping /?" .

1. Installation des TwinCAT OPC Servers für MP370 auf dem Projektierungsrechner mit Integration in die Siemens-ProSave Umgebung

Als Voraussetzung muss ein korrekt installiertes Simatic ProTool 6.0 SP2 auf dem Projektierungsrechner vorhanden sein.

Die Installation des TwinCAT-OPC-Server-MP370 befindet sich im Verzeichnis < Installationsordner \ MP370 (MIPS) \ TwinCAT_OPC_CE_MP370.exe >.
Folgen Sie den Installationsanweisungen um den TwinCAT OPC Server CE in die ProSave-Umgebung auf dem PC zu installieren.

2. Übertragung des TwinCAT OPC Servers für MP370 mit Siemens ProSave auf das MP370 Gerät

Starten Sie ProSave mit "Start - Simatic - ProSave" und konfigurieren entsprechend Ihrer Kommunikationsvoraussetzungen Ihre Verbindung zum Simatec MP370.
In diesem Beispiel erfolgt die Kommunikation über eine serielle Verbindung :

Um den TwinCAT OPC Server CE auf das Siemens MP370 zu transferieren, wechseln Sie bitte in ProSave auf die Registriekarte "Optionen". Im Fenster verfügbare Optionen finden Sie den Eintrag "TwinCAT OPC Server CE for MP370". Um den Datentransfer zwischen Projektierungsrechner und Siemens MP370 zu ermöglichen, starten Sie auf dem Siemens MP370 zunächst den Transfermodus. Dies geschieht im Loader über den Button "Transfer".
Anschließend können Sie die Installation über einen Klick auf den "»" - Button im ProSave starten. Der TwinCAT OPC Server CE wird daraufhin auf dem MP370 in den Ordner \hard disk\simatic installiert.

Sollte kein Datenaustausch entstehen, überprüfen Sie zunächst Ihre Verbindung zum Siemens MP370.
Weitere Hilfe liefert Ihnen hier der Siemens Support.

3. Konfiguration des OPC Servers

Im vorherigen Schritt haben Sie erfolgreich den Beckhoff OPC Server CE auf dem Siemens MP370 installiert. Es folgen nun zwei weitere Schritte, die einmalig durchlaufen werden müssen:

  • Für eine Kommunikation zwischen TwinCAT-OPC-Server auf dem MP370 und einem TwinCAT-Gerät (z.B. einem CX1000) müssen nun diese Kommunikationspartner miteinander bekannt gemacht werden.
    Dies geschieht auf dem MP370 mit dem Programm TwinCAT AMS Remote Manager.
  • Der TwinCAT OPC-Server CE muss konfiguriert werden um zu wissen, welche Daten (von welcher SPS ..) für OPC zur Verfügung stehen.

TwinCAT AMS Remote Manager

Sie finden das Programm "TcAmsRemoteMgr.exe" in einer MIPS-kompatiblen Version auf dem Simatic MP370 im OPC-Installationsverzeichnis "\flash\simatic". Auf dem TwinCAT-Gerät finden Sie diesen Dialog entweder im TwinCAT-System-Service oder z.B. auf dem CX1000 eine entsprechende x86-Version im Verzeichnis "\Hard Disk\System" .

Bild 3

Starten Sie bitte sowohl auf dem CX1000 als auch auf dem MP370 den TwinCAT AMS Remote Manager (siehe Bild 3). Über einen Klick auf den Button "Add" können Sie neue Remote Computer auf dem CX1000/MP370 einrichten. Tragen Sie dazu im folgendem Fenster die entsprechenden Daten ein:

Name
Symbolischer Name des "Remote Computers". Dieser Name kann frei vergeben werden.

AMS Net Id
AMS Net ID des "Remote Computers". Die AMS Net Id finden Sie im Eintrag "Local Computer" im TwinCAT Remote Manager.

Adresse
IP-Adresse des "Remote Computers".

Transport
Die Transportschicht mit der AMS Nachrichten befördert werden. TCP/IP als Transportschicht ist die Defaulteinstellung, weitere unterstützte Varianten hängen auch von der eingesetzten Hardware ab.

In diesem Beispiel ist folgende Konfiguration vorhanden:

TcAMs Remote Manager auf dem PC/CX:

  • PC/CX mit AMSNetId : 192.6.100.142.1.1
  • Auf dem PC/CX wird unter "Remote Computer" das MP370 Gerät mit der AMSNetId 192.168.0.163.1.1 eingetragen

TcAMs Remote Manager auf dem MP370:

  • MP370 mit AMSNetId : 192.168.0.163.1.1
  • Auf dem MP370 wird unter "Remote Computer" der PC/CX mit der AMSNetId 192.6.100.142.1.1 eingetragen

TwinCAT OPC Server : Konfiguration des Namespace

Einmalig muss nun der sogenannte OPC-Namespace des TwinCAT-OPC-Server-CE konfiguriert werden. Damit wird festgelegt, welche Variablen auf welchem ADS-Gerät für den OPC-Server zugänglich sind und somit via OPC für ProTool zur Verfügung stehen. Die Konfiguration des TwinCAT-OPC-Server-CE erfolgt über die Datei "CurrentConfigOPC.xml". Des Weiteren muss für jedes ADS-Gerät (z.B. jede SPS) eine <SPS-Projektname<.tpy Datei vorhanden sein.

In diesem Beispiel wird eine Exportdatei eines TwinCAT-SPS-Projektes auf das MP370 kopiert. Zu diesem Zweck finden Sie in Ihrem Simatic ProSave den Eintrag "TwinCAT OPC Configuration Update for MP370". Damit nun Ihre Konfiguration auf das MP370 kopiert wird, sind folgende Schritte nötig:

1.Schritt

  • Erstellen Sie ein TwinCAT-SPS Projekt mit den Variablen, die Sie im ProTool nutzen wollen. Mit dem Kompilieren wird eine <Projektname>.tpy Datei erzeugt.
    Kopieren Sie die <SPS-Projektname>.tpy-Datei in das Verzeichnis Simatic Protool Installationspfad\Common\PTProSave\Addon\TcOPCSvr_Config\mips.

    ACHTUNG:
    Die ProSave-Projektdatei geht von einer Datei "Plc1.tpy" aus. Wenn Ihr SPS-Projekt einen anderen Namen hat, so müssen Sie:
    entweder die TPY-Datei für den Transport zum MP370 umbenennen (von <projektname.tpy> nach "Plc1.tpy")
    oder die OPCconfig.pii anpassen und dort den Eintrag umbenennen (von "Plc1.tpy" nach <projektname.tpy>)

2.Schritt

  • Im selben Verzeichnis finden Sie ein XML-Dokument CurrentConfigOPC.xml. Öffnen Sie diese Datei mit einem Editor (z.B. Notepad.exe) und passen Sie die Datei entsprechend Ihrer Konfiguration an folgenden Punkten an:

XML Tag

Beschreibung

<Name>

Symbolischer Name der OPC-Verbindung

<AdsNetId>

AMS Net Id des Gerätes, von dem die Daten bezogen werden (z.B. vom CX1000)

<AdsPort>

ADS Port des Gerätes, von dem die Daten bezogen werden (z.B. von der CX1000-SPS : 801)

<AutoCfg>

7 : Import aller globalen Variablen aus der TPY Datei
8 : Import der gekennzeichneten Variablen aus der TPY Datei. Diese Variante ist dringend zu empfehlen, da nicht alle SPS-Variablen geladen werden, sondern (speichersparend) nur die für OPC-vorgesehenen Variablen

<AutoCfgSymFile>

Pfad zur tpy-Datei auf dem MP370 (default: OPC-Installationsverzeichnis)

  • Speichern Sie die Änderungen in der CurrentConfigOPC.xml Datei ab und kopieren Sie die neue Konfiguration über das Simatic ProSave auf das MP370.

Ein Beispiel für die Konfiguration könnte so aussehen:

Die Konfiguration ist beendet, der TwinCAT OPC Server ist auf dem MP370 konfiguriert und kann mit dem konfigurierten ADS-Gerät Daten austauschen.

4. OPC Freischaltung für ProTool

Kopieren Sie die im Verzeichnis ... \Beckhoff OPC CX1000 -- MP370\Installation Siemens\patch_regdat enthaltenen Dateien und Ordner im das Protool – Verzeichnis und starten Sie die Datei „_patch_ptreg_dat.bat“. Alle vier Dialogfenster mit ok bestätigen.

Die Datei Protool.ini im Protool-Verzeichnis ergänzen Sie wie folgt:

[Device List ] / am Anfang der Datei
ReInit=1

[OPC] / am Ende der Datei
ServerOnMP=0
DCOM/DeviceCOM=1
[Protocol Exclude List]
[Recent File List]

Die [Protocol Exclude List] muss leer sein.
Bei der [Recent File List] dürfen Einträge stehen.

Die Konfiguration ist beendet, der TwinCAT OPC Server ist auf dem MP370 konfiguriert und kann mit dem konfigurierten ADS-Gerät Daten austauschen.

5. Update des TwinCAT OPC Server CE for MP370

Um ein Update des TwinCAT OPC Server CE for MP370 auf dem Panel zu installieren, kopieren Sie die neue „TcOpcSvrInprocServer.dll“ Datei in folgenden Ordner: ...SIEMENS\Common\PTProSave\AddOn\TcOPCSrvCE\mips

Zum Übertragen der Änderungen auf das Panel bitte Schritt 2 wiederholen.


TwinCAT OPC Server CE for MP370 : Installation und Konfiguration

TwinCAT OPC XML Server CE

Installation

This document describes how to install the TwinCAT OPC XML DA Server on BECKHOFF embedded PC Controller based on CE operating system like CX1000, CX1020, CX9000 or EthernetPanels.

Prerequisites

TwinCAT OPC-XML-DA-CE requires a BECKHOFF CE device like CX1000, CX1020, etc with large memory. The Microsoft IIS (Internet Information Server) web server is required.

Step1 : Installation on PC

Install TwinCAT supplement product "TwinCATOPCServerCE.exe" on your host PC.

License : During installation a license number will be checked. Note that OPC-CE products cost royalties per CPU.

With a correct license number the product will be installed into folder C:\TwinCAT\CE\OPC

This folder will contain a number of different CE-installation files :

  • TcOpcXmlSvrCe.I586.CAB : OPC Server XML DA (XML based) for X86 based CPUs (like CX1000)
  • TcOpcSvrCe_I586.cab : OPC Server DA (COM based) for X86 based CPUs (like CX1000)
  • TcOpcSvrCe_StrongARM.cab : OPC Server DA (COM based) for ARM based CPUs with OS PocketPC (like IPAQ)
  • TcOpcSvrCe_MIPS.cab : OPC Server DA (COM based) for MIPS based CPUs (like Siemens Panels)
  • MIPS_MP370\TwinCAT_OPC_CE_MP370.exe : Seperat installation for installation on Siemens panels with ProSave

Step 2 : Deploy installation to CE device

Deploy the file TcOpcXmlSvrCe.I586.CAB onto the CF card of the Beckhoff-CE device, this can be done

  • via shared folder (Public folder)
  • via FTP
  • via ActiveSync
  • via a CF adapter

Step 3 : Installation on CE device

The installation file "TcOpcXmlSvrCe.I586.CAB" is to be executed via regular double-click on it.

NOTE:

  • As target directory, the pre-selected (default) directory "\hard disk\www\TcOpcXmlDa" has to be confirmed with "OK"!
  • After installation of the component into the correct target folder "\hard disk\www\TcOpcXmlDa" the installation file TcOpcXmlSvrCe.I586.CAB gets removed automatically.

After confirmation with "OK", the installation into the correct target folder "\hard disk\www\TcOpcXmlDa" gets executed.

  • There is no need for a restart of the CE device.

Step 4 : Test

The URL of the OPC-XML-DA server on the CE system can be checked from host PC. Open the Internet explorer and enter the URL of the OPC Server XML DA on CE system like :
http://<ip-adress or name of CE device>/tcopcxmlda/tcopcxmlda.dll

Sample :
http://cx_0027e8/tcopcxmlda/tcopcxmlda.dll

The TcOpcXmlDa server will reply with a status page containing the product version :

HINT :
In case of problems (like receiving no HTML status data) please check if a proxy server is activated on your host PC.
After deactivating the proxy and reloading the URL the Opc XML DA server should reply with status info.


OPC XML DA PC Server : Configuration

TwinCAT OPC XML DA PC server: Configuration

Configuration

This chapter describes how to configure the OPC XML DA Server on BECKHOFF PC based systems.

Summary :

The OPC-XML DA server is configured with default xml-configuration file. Just activate once a checkbox in PLC-Control to download the symbol information to target device.

With TwinCAT 2.10 Build 1240 (or higher) there is no manual configuration required. Please refer to section "Zero configuration" on this page.

With previous TwinCAT versions please refer to section "Manual or specific configurations" on this page.

Zero configuration (requires TwinCAT 2.10 on host PC)

Details :

  • The OPC-XMLDA configuration file "...\wwwroot\TcOpcXmlDa\TcOpcXmlSvrCfg.xml" contains the list of ADS-devices which are available via OPC-XML-DA interface.
  • By default this list is pre-configured for one local PLC-runtime system (first PLC runtime-system on ADS-port 801)
  • By default the required symbol-information is linked to C:\TwinCAT\Boot\CurrentPlc_1.tpy

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<TcOpcXmlSvrConfiguration>
<Namespace>
<Devices>

<Device>
<Name>PLC1</Name>
<AdsNetId>0.0.0.0.0.0</AdsNetId>
<AdsPort>801</AdsPort>
<AdsTimeout>2000</AdsTimeout>
<AdsTimeSuspend>20000</AdsTimeSuspend>
<AutoCfg>7</AutoCfg>
<!-- NOTE: CurrentPlc_1.tpy will be downloaded from PLC-Control -->
<AutoCfgSymFile>C:\TwinCAT\Boot\CurrentPlc_1.tpy</AutoCfgSymFile>
<Disabled>0</Disabled>
</Device>

</Devices>
</Namespace>
</TcOpcXmlSvrConfiguration>

With TwinCAT Version 2.10 Build 1240 the PLC Control allows to download the symbol file <plc-project-name>.TYP to the target TwinCAT machine. The TPY file contains information about all available PLC-variables in the PLC-project.
OPC-XML DA CE Server requires this TPY-information.

To download the current symbol information in a TPY file navigate in the PLC-Control to "Project-->Options-->TwinCAT" and check the option "Download Symbol description"

With each download of the PLC-code now also the <project-name>.TPY file is downloaded as "C:\TwinCAT\Boot\CurrentPlc_1.tpy" containing information about symbols of first run time system.
(Second runtime system would be "C:\TwinCAT\Boot\CurrentPlc_2.tpy" etc.)

Summary:

The OPC-XML DA server is configured with default xml-configuration file. Just activate the checkbox to download the symbol information within PLC-Control environment.

NOTE:
OPC-XML DA Server checks configuraton on startup. See notes to reload configuration today (without reboot)

Optional manual or specific configurations ?

If the default configuration is not available you have to configure the opc-xml-da configuration file "...\wwwroot\TcOpcXmlDa\TcOpcXmlSvrCfg.xml" manual.

  • If required the opc-xml configuration file can be done with TwinCAT OPC COnfigurator

Sample for OPC XML DA server accessing multiple ADS devices

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<TcOpcXmlSvrConfiguration>
<Namespace>
<Devices>

<Device>
<Name>PLC1</Name>
<AdsNetId>0.0.0.0.0.0</AdsNetId>
<AdsPort>801</AdsPort>
<AdsTimeout>2000</AdsTimeout>
<AdsTimeSuspend>20000</AdsTimeSuspend>
<AutoCfg>7</AutoCfg>
<!-- NOTE: CurrentPlc_1.tpy will be downloaded from PLC-Control -->
<AutoCfgSymFile>C:\TwinCAT\Boot\CurrentPlc_1.tpy</AutoCfgSymFile>
<Disabled>0</Disabled>
</Device>

<Device>
<Name>PLC2</Name>
<AdsNetId>0.0.0.0.0.0</AdsNetId>
<AdsPort>811</AdsPort>
<AdsTimeout>2000</AdsTimeout>
<AdsTimeSuspend>20000</AdsTimeSuspend>
<AutoCfg>7</AutoCfg>
<!-- NOTE: CurrentPlc_2.tpy will be downloaded from PLC-Control -->
<AutoCfgSymFile>C:\TwinCAT\Boot\CurrentPlc_2.tpy</AutoCfgSymFile>
<Disabled>0</Disabled>
</Device>

</Devices>
</Namespace>
</TcOpcXmlSvrConfiguration>

NOTE:
OPC-XML DA Server checks configuraton on startup. Reconfiguration might require a new start today.


OPC XML DA CE Server : Installation

TwinCAT OPC XML Server PC

Install TwinCAT OPC XML DA on a PC (here: Windows XP)

This chapter describes the IIS configuration required for OPC XML DA for operating system XP. (Note : For other Windows-OS the configuration can differ in details).

Requirements :

The TwinCAT OPC XML DA server has to be installed on the PC. This chapter describes how to configure the Microsoft IIS.

Step 1: Create "Virtual Directory" in IIS (Internet Information Service)

  • Open "Internet Information Services" (under "Control Panel/Administrative Tools/").
  • Right click on "Default Web Site"
  • Select "New" and "Virtual Directory..."

Everybody is welcome, so just click next.

Please enter the alias "TcOpcXmlDa" and click "Next"

With "Browse..." you have to specify the folder which contains the TwinCAT OPC Xml DA Server. By default the folder should be like "C:\TwinCAT\OPC\Server XMLDA".

Select "Next" to proceed.

Check options "Read", "Run scripts" and "Execute" and click "Next".

Select "Finish" to finish the configuration of TwinCAT OPC XML DA Server.

Step 2 : Test

The URL of the OPC-XML-DA server on the PC system can be checked locally or from a remote PC: In both cases open the Internet explorer and enter the URL of the OPC Server XML DA on PC system like :
http://<ip-adress or name of PC device>/tcopcxmlda/tcopcxmlda.dll

Sample :
http://192.16.17.5/tcopcxmlda/tcopcxmlda.dll
or
http://localhost/tcopcxmlda/tcopcxmlda.dll

The TcOpcXmlDa server will reply with a status page containing the product version :

HINT :
In case of problems (like receiving no HTML status data) please check if a proxy server is activated on your host PC.
After deactivating the proxy and reloading the URL the Opc XML DA server should reply with status info.


OPC XML DA PC Server : Overview

TwinCAT OPC XML Server PC

Overview

Prerequisites

TwinCAT OPC-XML-DA requires a PC operating system (Windows 2000 / XP / XPE)
The Microsoft IIS (Internet Information Server) web server is required on that PC.


Datenübernahme aus TwinCAT PLC

html> Datenübernahme aus TwinCAT PLC
TwinCAT OPC Server: Anbindung an das Prisma-System (Daimler)

Anbindung von BECKHOFF Steuerungen an das Daimler-PRISMA System

EInleitung

PRISMA steht für "Produktionsleit- und Informationssystem für Maschinen und Anlagen" und stellt das Daimler-Leitrechnersystem dar. Die Anbindung von Maschinensteuerungen beliebiger Steuerungshersteller an dieses Prisma-System erfolgt über die Daimler-Software "ObjectBroker". Diese Software agiert als OPC-Client der OPC-Spezifikation DataAccess 2 und erwartet für Beckhoff-Steuerungen einen TwinCAT-OPC-Server welcher bestimmte Daten zur Verfügung stellt.

Beispiel (SPS-Projekt und OPC-Server Konfiguration):

In dieser Sektion stehen alle Informationen zur Verfügung um eine Beckhoff-Steuerung an das Daimler-Prisma System anzubinden.
Dieses vollständiges Beispiel enthält ein SPS-Projekt und die OPC-Konfiguration : Beispiel.zip

Diese Informationen sind in enger Abstimmung zwischen Daimler und Beckhoff erstellt worden.

Architektur:

  • Der Daimler-ObjectBroker wird mit auf der BECKHOFF-Steuerung installiert und agiert als OPC-Client.
  • Der OPC-Client fordert zyklisch ca. 35 festgelegte Variablen im 500ms Takt von dem TwinCAT-OPC-Server an und meldet diese über ein internes Daimler-Protokoll an die überlagerte Leitebene weiter.
  • Der OPC-Server holt die Daten aus der TwinCAT-SPS aus vordefinierten Strukturen ab. Die SPS-Datenstruktur muss vom Maschinenbauer entsprechend der Prisma Vorgaben mit Daten gefüllt werden.

Anlage 1 : Spezifikation Prisma von Daimler

PRISMA Spezifikation als PDF : ObjectBroker.pdf

Anlage 2 : SPS-Datenstruktur für PRISMA

Nach Prisma Spezifikation sind zwei unterschiedliche Datensätze vorhanden, je nach Maschinentyp und Maschinenfunktion sind eine oder mehrere Instanzen dieser SPS-Strukturen nach den Vorgaben von Daimler anzulegen.

  • ST_PRISMA_M
  • ST_PRISMA_ST

TYPE ST_PRISMA_M :
STRUCT
Aus : BOOL; (* Maschine ist ausgeschaltet *)
Schutztuer : BOOL; (* Schutztür geöffnet *)
Automatik : BOOL; (* Betriebsart Automatik, bzw. verketteter Betrieb angewählt *)
Einzelbetrieb : BOOL; (* Betriebsart Einzelbetrieb angewählt *)
Einzelschritt : BOOL; (* Betriebsart Einzelschritt angewählt *)
Einrichtbetrieb : BOOL; (* Betriebsart Einrichtbetrieb angewählt *)
Sofort_Halt : BOOL; (* Alle Bewegungen stillgestetzt *)
Zufuehrteilemangel : BOOL; (* Zufuehrteil fehlt - Montagestation *)
Ohne_Bearbeitung : BOOL; (* Fahren ohne Teil *)
Stoerung_wird_behoben : BOOL; (* Taste Stoerung wird behoben *)
Stillsetzungscode : DINT; (* Stillsetzungscode, welcher vom HMI-Bild Stillsetzungsgründe erzeugt wird.
Dazu muß die Datei mit den Stillsetzungsgründen mit Pfad in der Konfiguration hinterlegt werden *)
Werkstuecktyp : INT; (* Nummer des Werkstuecktyps, der aktuell gefertigt wird, bzw. sich am Auslauf befindet *)
Teile_ID : STRING; (* Teileidentifikation eines sicherheitsrelevanten Werkstuecks, welches aktuell gefertigt wird, bzw. sich am Auslauf befindet *)
Stoerung_Selektion : BOOL; (* Zuordnungssignal für die Störung in der HMI (optional) *)
Halt_nach_Taktende : BOOL; (* Halt nach Taktende erreicht *)
Start : BOOL; (* Start betätigt *)
Kein_Teil_am_Einlauf : BOOL; (* Anlagenstopp, da kein Teil am Einlauf *)
Auslauf_belegt : BOOL; (* Anlagenstopp, da Auslauf belegt *)
Leertakten : BOOL; (* Anlage wird leergetaktet *)
Beladen : BOOL; (* Anlage wird beladen *)
Teilbearbeitung : BOOL; (* Nacharbeit *)
Stueckzahl_Typ_IO : DINT; (* UDINT : der aktuelle IO-Stückzähler des entsprechenden Werkstücktyps *)
(* alternativ :
Stueckzahl_Typ_IO : ARRAY[0..32] OF UDINT; (* ARR_UDINT_32_SZ : Array mit 32 IO-Stückzähler, einer je Werkstücktyp *)
*)
Stueckzahl_Typ_NIO : DINT; (* UDINT : der aktuelle NIO-Stückzähler des entsprechenden Werkstücktyps *)
(* alternativ :
Stueckzahl_typ_NIO : ARRAY[0..32]OF UDINT; (* 32 typbezogene Zähler NIO-Teile *)
*)
Taktzeit : INT; (* Ist-Taktzeit der Anlage in 1/10 Sekunde *)
Stueckzahl_gesamt_IO : DINT; (* Stückzähler gesamt i.O. Teile aller Typen *)
Stueckzahl_gesamt_NIO : DINT; (* Stückzähler gesamt n.i.O. Teile aller Typen *)
MPS_Code : INT; (* MPS-Code. Dazu muß die Datei mit den MPS-Texten mit Pfad in der Konfiguration hinterlegt werden *)
Allgemeine_Stoerung : DINT; (* Störcode (0 = keine Störung) *)
Ablauf_Stoerung : DINT; (* Code einer Ablaufstörung (0 = keine Störung) *)
NC_Stoerung : DINT; (* Code einer NC-Störung (0 = keine Störung) *)
Allgemein_Stoertext : STRING; (* Störtext einer allgemeinen Störung *)
Ablauf_Stoertext : STRING; (* Störtext einer Ablaufstörung *)
NC_Stoertext : STRING; (* Störtext einer NC-Störung *)
END_STRUCT
END_TYPE

TYPE ST_PRISMA_ST :
STRUCT
Aus : BOOL; (* Maschine ist ausgeschaltet *)
Schutztuer : BOOL; (* Schutztür geöffnet *)
Automatik : BOOL; (* Betriebsart Automatik, bzw. verketteter Betrieb angewählt *)
Einzelbetrieb : BOOL; (* Betriebsart Einzelbetrieb angewählt *)
Einzelschritt : BOOL; (* Betriebsart Einzelschritt angewählt *)
Einrichtbetrieb : BOOL; (* Betriebsart Einrichtbetrieb angewählt *)
Sofort_Halt : BOOL; (* Alle Bewegungen stillgestetzt *)
Zufuehrteilemangel : BOOL; (* Zufuehrteil fehlt - Montagestation *)
Ohne_Bearbeitung : BOOL; (* Fahren ohne Teil *)
Stoerung_wird_behoben : BOOL; (* Taste Stoerung wird behoben *)
Stillsetzungscode : DINT; (* Stillsetzungscode, welcher vom HMI-Bild Stillsetzungsgründe erzeugt wird.
Dazu muß die Datei mit den Stillsetzungsgründen mit Pfad in der Konfiguration hinterlegt werden *)
Werkstuecktyp : INT; (* Nummer des Werkstuecktyps, der aktuell gefertigt wird, bzw. sich am Auslauf befindet *)
Teile_ID : STRING; (* Teileidentifikation eines sicherheitsrelevanten Werkstuecks, welches aktuell gefertigt wird, bzw. sich am Auslauf befindet *)
Logistik_Stoerung : BOOL; (* Logistikstoerung an der Einheit *)
Taktzeit_Einheit : UINT; (* Ist-Taktzeit der Anlage in 1/10 Sekunde *)
MPS_Code : INT; (* MPS-Code. Dazu muß die Datei mit den MPS-Texten mit Pfad in der Konfiguration hinterlegt werden *)
Allgemeine_Stoerung : DINT; (* Störcode (0 = keine Störung) *)
Ablauf_Stoerung : DINT; (* Code einer Ablaufstörung (0 = keine Störung) *)
NC_Stoerung : DINT; (* Code einer NC-Störung (0 = keine Störung) *)
Allgemein_Stoertext : STRING; (* Störtext einer allgemeinen Störung *)
Ablauf_Stoertext : STRING; (* Störtext einer Ablaufstörung *)
NC_Stoertext : STRING; (* Störtext einer NC-Störung *)
END_STRUCT
END_TYPE

Beispiel : Instanz einer SPS-Datenstruktur ST_PRISMA_ST

VAR_GLOBAL
ST01 : ST_PRISMA_ST; (* Demo : Instanz von ST_PRISMA_ST Typ *)
END_VAR

Anlage 2 : TwinCAT OPC-Server Konfiguration

Für die Konfiguartion des TwinCAT OPC-Servers steht der OPC-Konfigurator zur Verfügung. Als Ergebnis des einmaligen Konfigurationsvorganges entsteht eine OPC-XML-Konfigurationsdatei :

Die Werte für die Parameter AmsNetId, AdsPort und AutoCfgSymFile sind applikationsspezifisch und müssen entsprechend angepasst werden.

<?xml version="1.0"?>
<!-- By Stefan Hoppe (Beckhoff) -->

<TcOpcConfiguration xmlns="www.beckhoff.com/Schemas/TwinCAT/Opc/TcOpcSvrCfg">
<Namespace>

<Devices>

<Device>
<Name>Plc1</Name>
<AdsNetId>0.0.0.0.0.0</AdsNetId>
<AdsPort>801</AdsPort>
<AutoCfgSymFile>C:\Projects\Demo_DC_PRISMA.SYM</AutoCfgSymFile>
<AutoCfg>1</AutoCfg>
</Device>

</Devices>

</Namespace>
</TcOpcConfiguration>

Kontrolle

Nach erfolgreicher Konfiguration der TwinCAT-SPS und dem TwinCAT-OPC-Server stehen die Daten nun entsprechend der PRISMA Spezifikation zur Verfügung.

Der Daimler-ObjectBroker als OPC-Client muss nun entsprechend konfiguriert werden um die Daten vom TwinCAT-OPC-Server abzuholen.
Die notwendige sogenannte ProgID des OPC-Servers ist "BECKHOFF.TwinCATOpcServerDA"

WICHTIGER HINWEIS :
Stellen Sie sicher, dass der OPC-Client die Daten vom OPC-Server nicht mit maximal möglicher Geschwindigkeit ausliesst. Diese Zykluszeit-Parameter (Updaterate_Event und Updaterate_Info) werden im ObjectBroker eingestellt und sollten auf 500ms begrenzt sein.
Mit dem EIntrag 0 (0x0) würde der OPC-Server zyklisch im 60ms Takt die Daten aus der TwinCAT-SPS auslesen.