Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Einleitung

TS1500 | TwinCAT Valve Diagram Editor

TwinCAT Kennlinien - Einleitung

Bei dem Einsatz von Hydraulikzylindern in Verbindung mit den entsprechenden Ventilen ergibt sich durch die Bauart der Zylinder und der Ventile bedingt oftmals ein nichtlineares Übertragungsverhalten der Achse und somit der zu regelnden Strecke. Das heißt, die Geschwindigkeit des Hydraulikzylinders ist nicht proportional zu dem Ansteuersignal des Ventils. Ein solcher Fall liegt beispielsweise dann vor, wenn ein Hydraulikzylinder eingesetzt wird, dessen Flächenverhältnis der beiden Druckseiten ungleich Eins ist. Ein anderer typischer Fall ergibt sich durch eine nichtlineare Ventilkennlinie. Ein möglicher Verlauf einer solchen Kennlinie ist in dem folgenden Bild dargestellt.

Kennlinien-Linearisierung

Bei dem Vorhandensein einer solchen nichtlinearen Regelstrecke kommt es zu dem Problem, dass sich ein linearer Reglerentwurf auf Basis dieser nichtlinearen Regelstrecke als unzureichend erweist, da der Regler nur in einem Arbeitsbereich optimal ausgelegt werden kann. Folglich ergeben sich bei vielen Anwendungsfällen Einbußen in der Regelgüte, oder es ergibt sich sogar ein nicht akzeptables Regelverhalten.

Ziel der hier vorgestellten Kennlinien-Linearisierung ist es, weiterhin die bekannten und erprobten Verfahren zur Auslegung von linearen Regelkreisen einzusetzen, aber die Regelgüte zu verbessern. Durch die Vorschaltung eines Kennliniengliedes wird die Nichtlinearität der Reglestrecke kompensiert, so dass sich ein annähernd lineares Verhalten ergibt. Diese Vorgehensweise ist in dem folgenden Wirkungsplan dargestellt.

Die bei diesem Verfahren eingesetzte Kennlinie muss möglichst exakt das inverse Übertragungsverhalten der eingesetzten Ventil - Hydraulikzylinderkombination beschreiben, so dass sich durch die Reihenschaltung dieser Kennlinie mit der real vorhandenen Regelstrecke ein annähernd linearer Verlauf ergibt.

Insbesondere ist Wert auf eine möglichst exakte Kennlinie in den Knickstellen zu legen, da diese Punkte bezüglich der Linearisierung besonders kritisch sind.

Für den TwinCAT Achsregelkreis ergibt sich bei Einsatz der Kennlinien-Linearisierung der folgende Wirkungsplan:

Die für die Linearisierung benötigte Kennlinie kann mit dem Valve Diagram Editor erstellt und editiert werden. Nachdem die Kennlinie erstellt und in die Echtzeitumgebung geladen worden ist, kann sie in dem Achsregelkreis wirksam gemacht werden. Dieses erfolgt im System-Manager auf dem Analog-Reiter des Drives oder allgemein per ADS-Kommando .

In die Zeile 'Ventilkennlinie: Id der Kennlinie' muss die eindeutige Tabellen-Id der Ventilkennlinie eingetragen werden. In der Zeile 'Ventilkennlinie: Interpolations-Typ' kann zwischen den Typen 'Linear' und 'Spline' gewählt werden. (In der Echtzeitumgebung wird eine Tabelle mit äquidistantem Stützstellenabstand hinterlegt, welche zur Laufzeit linear- oder mit einer Spline-Funktion interpoliert wird.)

Weiterhin ist es möglich, einen Ausgabe-Offset vor und nach der Kennlinie aufzuschalten.

Im Signalfluss vor der Kennlinie wirkt der Parameter 'Driftkompensation (DAC-Offset)'. Hier kann eine Offsetkorrektur in Form einer Geschwindigkeit (z.B. in mm/s) addiert werden.

Im Signalfluss nach der Kennlinie kann ein Offset mit dem Parameter 'Ventilkennlinie Ausgangsoffset [-1.0 ... 1.0]' aufgeschaltet werden. An dieser Stelle im Signalfluss wird der Offset als Prozentwert, bezogen auf die maximale Ausgangsgröße, angegeben.

Hinweise:

Die Hydraulik-Kennlinie kann nur dann durch das Eintragen der Tabellen-Id aktiviert werden, wenn

1) die Tabelle in die Echtzeitumgebung geladen worden ist

2) die Reglerfreigaben für die Achse nicht erteilt sind

Die beschriebenen Parameter auf dem Analog-Reiter des Drives können auch über ADS-Kommandos (z. B. aus der SPS) vorgegeben werden.

Drive-Typen:

Die beschriebe Kennlinien-Linerarisierung wird von den folgenden Drive-Typen unterstützt:

  • M2400 DAC 1/ DAC 2 / DAC 3 / DAC 4
  • KL4XXX/KL2503-30K/KL2521
  • Drive (universal)


Einleitung

Zum Entwerfen der Kennlinie eines Hydraulik Ventils dient ein grafisch orientierter Editor, der dem Kurvenscheibeneditor ähnlich ist. Der in das TwinCAT integrierte Valve Diagram Editor ist im System Manager unter der NC-Configuration unter dem Punkt Tables zu finden. Nach der Anwahl der Tables in der Baumansicht kann mit der rechten Maustaste und dem Befehl Append Table in dem Fenster Insert Master der Typ des Masters gewählt werden. Mit der Auswahl Valve Diagram entscheidet man sich für den Valve Diagram Editor.

Unter diesen können entsprechende Slaves eingefügt werden (rechte Maustaste). Wenn man in dem Baum auf den Master klickt, können auf den Eigenschaftsseiten nicht nur die Eigenschaften des Masters sondern auch die der zugehörigen Slaves eingestellt werden. Die Struktur von Master und Slave stammt dabei aus dem Kurvenscheibeneditor und hat hier den Vorteil, dass man Messwerte in einen separaten Slave legen kann und diese dann als Grafik im Hintergrund für die Konstruktion einer idealisierten Kennlinie verwenden kann.

Die Bedienung des Valve Diagram Editors ist grafisch orientiert. Nach der grafisch interaktiven Eingabe der Punkte in dem Grafikfenster werden die Koordinaten der Punkte in dem Tabellenfenster darüber dargestellt. Neue Punkte können nur über die Grafik hinzugefügt werden und vorhanden Punkte könne auch nur über die Grafik gelöscht werden. Die Eigenschaften der Punkte - die Werte der Koordinaten - können auch interaktiv in dem Tabellenfenster manipuliert werden. Die Punkte werden standardmäßig durch Geraden miteinander verbunden. Durch Eingabe eines Übergangsbereichs (Range) werden die Geradenübergänge geglättet. Der Range lässt sich nur über das Tabellenfenster ändern.

Das Kreuz, welches den Schnittpunkt der Geraden angibt, wird in horizontaler Länge dem Range angepasst.
In dem grafischen Bereich lassen sich nicht nur die Spannung in Abhängigkeit von Geschwindigkeit, sondern auch deren Ableitungen darstellen.
Den Wechsel der Darstellung kann man durch rechten Mausklick im Grafikfenster in dem folgenden Menü umstellen:

So wird für jede Ableitung ein separates Grafikfenster eröffnet.


Eigenschaften des Master

TS1500 | TwinCAT Valve Diagram Editor

Eigenschaften des Masters

Auf der Eigenschaftsseite des Masters:

kann der Name des Masters eingegeben werden.

Zum importieren von Slaves kann per rechtem Mausklick auf den Master in der Baumansicht in dem Menü

der Punkt Import Slave... gewählt werden.

Hier können die Daten des Masters inklusiv der Slavedaten auch exportiert werden. Der Import dieser Daten ist über die Baumansicht unter dem Punkt Tables möglich.


Eigenschaften des Slaves

TS1500 | TwinCAT Valve Diagram Editor

Eigenschaften des Slaves:

Auf der Eigenschaftsseite des Slaves:

kann der Name des Slaves editiert werden. Dem Slave kann eine der Achsen zugeordnet werden.

Mit Import können Dateien in der Form (Geschwindigkeitswert, Spannungswert) eingelesen werden. Die Werte werden dann als kubische Splines dargestellt. Der Typ des Splines muss in Abhängigkeit der Werte dabei noch in der Tabelle angepasst werden.

Wenn das Kontrollkästchen Automatic Area Ratio aktiviert wird, kann ein festes Flächenverhältnis der beiden Kolbenseiten in dem Feld Area Ratio A/B angeben werden. Die Spannungen werden dann automatisch für die B-Seite berechnet und daher lassen sich diese Werte nicht mehr in der Grafik oder der Tabelle ändern.

Durch die Auswahl Velocity Percent oder Absolute wird entschieden, ob man mit der Geschwindigkeit prozentual oder absolut arbeitet. In dem Fall Velocity Percent werden bei einer Änderung der Velocity A 100% die Geschwindigkeitswerte des Diagramms so umskaliert, dass die prozentualen Werte konstant bleiben.

Die Table Id gibt die eindeutige Identifikationszahl (1..255) der Tabelle an, mit der die Tabellendaten in der NC abgelegt werden. Sie kann per rechtem Mausklick in dem Menü

mit dem Befehl Change Id... verändert werden.

Mit Export Slave... können die Daten des Bewegungsdiagramms in einer Exportdatei (*.tce) gespeichert werden. Diese Daten können unter einem Master wieder importiert werden.


Grafikfenster

Die Kennlinie (Geschwindigkeit in Abhängigkeit von der Geschwindigkeit) des Slaves und deren Ableitungen wird jeweils in einem separatem Grafikfenster dargestellt.

In der zugehörigen Toolbar gibt es zum einen Buttons, die sich nur auf die Grafik beziehen,

und zum anderen die speziellen Befehle des Kurvenscheibeneditors

Die Grafikbefehle unterteilen sich in den Eingabemodus: und die Zoom und Verschiebebefehle:

Zoom

Zoom alles

Verschieben (Wenn der Schalter Pan outside im Popupmenü eingeschaltet ist, kann man auch über die Grenzen hinweg verschieben.
Dieser Befehl ist erst dann aktiv, wenn der Zoombefehl aufgerufen wurde.

Übersichtsfenster ein/ausschalten. Das Fenster lässt sich nur dann einschalten, wenn man in das Fenster hineingezoomt hat.

Wenn das Übersichtsfenster eingeschaltet ist, kann man in dem Fenster nicht nur erkennen, in welchen Ausschnitt die Grafik ist, sondern man kann darin den Ausschnitt verschieben oder einen neuen Ausschnitt zoomen.

Mit den horizontalen und vertikalenScrollBars kann man den Grafikausschnitt verschieben, wobei der horizontale Scrollbar für alle Grafikfenster gleichzeitig gilt.

Wenn man eine IntelliMouse mit ScrollWheel verwendet, kann man mit dem ScrollWheel zoomen.

Die Toolbar mit den Befehlen kann durch rechten Mausklick (im Grafikfenster) in dem folgenden Menü ein- oder ausgeblendet werden:

Mit eingeschalteter Option Horizontal Scroll Bar ist für dieses Fenster ebenfalls ein horizontaler Scroll Bar vorhanden. Alle horizontalen Scroll Bars sind synchronisiert.

Mit der Option Cross on Point werden die Anfangs- und Endpunkte der Bewegungsabschnitte mit einem Kreuz gekennzeichnet.

Der Show Online Data stellt die Tabellendaten, die sich momentan in der NC befinden mit der zugehörigen Tabellen ID, als kubischen Spline dar. Dadurch kann es momentan zu einer verzerrten Darstellung kommen, da die linearen Tabellen als natürliche Splines (zweite Ableitung an den Rändern gleich Null) dargestellt werden. Die Daten werden in der gleichen Farbe nur gestrichelt dargestellt.

Die Daten werden automatisch per ADS übertragen, sobald der Online Mode eingeschaltet wird. Durch ein und ausschalten des Modus können die aktuellen Daten gelesen werden.

Beim Speichern des Projektes in der Registry werden automatisch die Informationen für das Erzeugen und Übertragen der Tabellen in die NC erzeugt.


Tabellenfenster

In dem Tabellenfenster werden die Werte der Bewegungsabschnitte dargestellt.:

Tabellenüberschrift | Beschreibung
Function | Gibt den Funktionstyp an (siehe Funktionstypen)
Velocity | absoluter Geschwindigkeitswert
Velocity [%] | prozentualer Geschwindigkeitswert
Voltage [%] | prozentuale Spannung
Range | absoluter Wert des Übergangsbereiches
Range[%] | prozentualer Wert des Übergangsbereiches

Die Werte können per Tastatur geändert werden. Die prozentualen und absoluten Werte hängen dabei direkt zusammen, so daß eine Änderung des einen den anderen direkt mitändert (nach dem Drücken der Returntaste oder Verlassen des Feldes).

Funktionstypen

Der Funktionstyp kann neben den Standardtypen (Synchron/Automatic) , die per Kommando in der Grafik verändert werden können, auch in der Kombobox verändert werden. Beim ersten Anklicken der Kombobox - oder eines Feldes der ersten Spalte - wird im Fenster der Position temporär ein Rechteck aufgespannt mit den Eckpunkten Anfangspunkt und Endpunkt des Abschnitts. Sobald man ein anderes Feld im Tabellenfenster antippt, wird entweder für dieses das Rechteck gezeigt oder kein Rechteck mehr angezeigt.

Die Typen entsprechen denen der VDI-Richtlinie 2143 zusätzlich kommen noch die kubischen Splines mit den Randbedingungen natürlich, tangential und periodisch hinzu.

Typ | Beschreibung | Randbedingung
Synchron | Synchrone Bewegung ( konstantes Übersetzungsverhältnis von Slave zu Master entspricht der normierten Geschwindigkeit ) | konstante Geschwindigkeit v, Beschleunigung a=0
Automatic | Automatische Anpassung an die Randwerte (Geschwindigkeit, Beschleunigung) |
Spline | Innerer Abschnitt eines kubischen Splines |
Spline Natural | Start- oder Endabschnitt eines natürlichen kubischen Splines | a=0
Spline Tangential | Start- oder Endabschnitt eines tangentialen kubischen Splines |
Spline Periodic | Start- oder Endabschnitt eines zyklischen kubischen Splines |

Das Ändern des Splinetyps beim ersten Punkt bedingt auch die Änderung des Splinetyps insgesamt und damit auch den vom Endpunkt.


Kommandos

Die Kommandos des Valve Diagramm Editors, die durch die Toolbar des jeweiligen Grafikfenster aufrufbar sind:

können nur dann aufgerufen werden, wenn von den Grafikbefehlen

der Eingabemodus [image] aktiviert ist.

Die Kommandos gelten jeweils nur für das jeweilige Fenster.

Anpassung an die Extremwerte

Die Koordinaten des Fensters werden an die Extremwerte der Bewegung angepasst

Messen des Abstand

Von dem zuerst mit der linken Maustaste angeklicktem Punkt wird der horizontale und vertikale Abstand zu dem aktuellen Punkt oben rechts im Fenster ausgegeben (Maustaste bitte gedrückt lassen).

Aktuelle Position

Von dem aktuellen mit der linken Maustaste angeklicktem Punkt wird die absolute horizontale und vertikale Position oben rechts im Fenster ausgegeben (Maustaste bitte gedrückt lassen).

Die folgenden Befehle gelten nur in dem Grafikfenster der Position:

Horizontale Verschiebung

Verschiebt den ausgewählten Punkt horizontal

Im Geschwindigkeitsfenster für synchrone Funktionen: Verschiebung auf der Geraden im Positionsfenster

Temporär kann der linke Rand des Grafikbereichs damit verschoben werden, um die Skala besser lesen zu können.

Vertikale Verschiebung

Verschiebt den ausgewählten Punkt vertikal

Verschiebung

Verschiebt den ausgewählten Punkt

Punkt einfügen

Fügt an der Position des Cursors einen Punkt ein

Punkt löschen

Der ausgewählte Punkt wird gelöscht und der entsprechende Abschnitt ebenso


Beispiel

TS1500 | TwinCAT Valve Diagram Editor

Beispiel:

Hier soll die Vorgehensweise für das Laden von Messwerten und das Konstruieren einer entsprechend angepassten Kennlinie gezeigt werden.

Zuerst legt man einen neuen Slave unter dem bereits vorhanden Master an. Auf der Eigenschaftsseite des Slaves können mit dem Import Befehl die gemessenen Werte eingelesen werden. Die Frage nach dem Löschen der aktuellen Daten sollte mit OK bestätigt werden.

Durch das Kommando Anpassung an die Extremwerte wird das Grafikfenster den eingelesenen Daten angepasst. Die gemessenen Daten werden dabei als kubischer Spline dargestellt. Falls die Schwankungen der Messwerte zu groß ist kann es dabei in der Darstellung zu Überschwingern kommen. Durch manuelles Ändern des Funktionstyps in der Tabelle lässt sich dieses Verhalten ändern.

Für die Kennlinie fügt man jetzt einen neuen Slave ein bzw. wechselt zu dem bereits vorhandenen Slave, den man modifizieren will. Mit dem Kommando (rechte Maustaste in der Grafik) Show other Slave legt man die Messwerte in den Hintergrund.

Jetzt kann man zum Beispiel durch Verschieben die Punkte und eventuelles Zoomen der aktuellen Kennlinie diese an die Messpunkte anpassen. Normalerweise werden die Messpunkte nicht den ganzen Bereich der Kennlinie ausfüllen, die aktuelle Kennlinie geht also über die gemessenen Werte hinaus.

Falls man mehrere Messungen hat, kann man jede einzelne in einen separaten Slave ablegen und mit dem Befehl Disabled in der Baumansicht die im Moment in der Ansicht im Hintergrund nicht benötigten Wegblenden.