KL6831 und KL6841 - SMI-Masterklemme

BECKHOFF Feldbuskomponenten

Dokumentation zur

KL6831 und KL6841

SMI-Masterklemme

Version: 1.1.0
Datum: 27.10.2014


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


KL6831 und KL6841 - Ausgabestände der Dokumentation

BECKHOFF KL6831 und KL6841: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
1.1.0
  • Kapitel Registerbeschreibung aktualisiert
  • Kapitel Arbeitsweise korrigiert
1.0.0 | Erste Veröffentlichung
0.0.x | Interne Versionen für Produktmanagement und Entwicklung

Firm- und Hardware-Stände

Dokumentation Version | KL6831 |  | KL6841
 | Firmware | Hardware | Firmware | Hardware
1.1.0 | 1C | 00 | 1C | 00
1.0.0 | 1C | 00 | 1C | 00

Den Firm- und Hardware-Stand (Auslieferungszustand) der Klemme können Sie der auf der Seite aufgedruckten Seriennummer entnehmen.

Syntax der Seriennummer

Aufbau der Seriennummer: WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Jahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 44 13 B1 00:

44 - Produktionswoche 44
13 - Produktionsjahr 2013
1C - Firmware-Stand 1C
00 - Hardware-Stand 00


KL6831 und KL6841 - Einführung

BECKHOFF KL6831 und KL6841: Produktübersicht

Einführung

Die SMI-Masterklemme KL6831 und KL6841 ermöglicht den direkten Anschluss an das SMI-Bussystem.

Mit dem SMI-Bussystem (Standard Motor Interface) wird in der Gebäudeautomatisierung die Rolladen- und Sonnenschutzautomation vereinfacht. Mit SMI-Antrieben können exakte Positionen bei Rollladen und gradgenaue Winkelpositionen bei Jalousieantrieben angefahren werden. Die SMI-Antriebe können Ist-Positionen, Fehlermeldungen und Serviceinformationen an die SMI-Masterklemme zurücksenden.

Die KL6831 ist für Installationen mit 24 V LoVo SMI-Antrieben und die KL6841 für Installationen mit 230 V AC SMI Antrieben ausgelegt.

Achtung 		Verwendung der KL6831 und KL6841
Die KL6831 und KL6841 dürfen nur an den vorgesehenen SMI-Antrieben betrieben werden. Ein Vertauschen von 24 V LoVo SMI-Antrieben mit 230 V AC SMI-Antrieben oder ein Mischbetrieb ist nicht zulässig und kann zu Fehlfunktionen und Zerstörung von Baugruppen führen.

Der Verdrahtungsaufwand ist im Vergleich zu Standardantrieben reduziert, da pro SMI-Masterklemme bis zu 16 SMI-Antriebe angesteuert werden können.

Weitere Informationen über den SMI-Bus und SMI-Antrieben werden von der SMI-Group unter www.smi-group.com zur Verfügung gestellt.

Die KL6831 und KL6841 enthält ein integriertes Netzteil für die galvanisch getrennte SMI-Spannungsversorgung. Für den Betrieb von SMI-Antrieben sind keine weiteren Komponenten notwendig. Die KL6831 und KL6841 arbeiten feldbusunabhängig.

Mit der kostenlosen TwinCAT PLC Lib SMI (siehe TwinCAT Information System) werden die SMI-Masterklemmen direkt aus dem PLC-Programm angesteuert. Des Weiteren stehen leistungsfähige SPS-Bausteine für die Raumautomation nach VDI 3813 in der TwinCAT-HVAC-Bibliothek zur Verfügung.

Hinweis 		Unterstützung der KL6831 und KL6841
Die KL6831 und KL6841 werden nur in Verbindung mit der TwinCAT Bibliothek für die SMI-Masterklemme unterstützt!

Bei Einsatz der KL6831 oder KL6841 unter einer anderen Steuerung als TwinCAT werden keine Buskoppler (BK) unterstützt.
Hier ist die Verwendung eines Busklemmen-Controllers (BC oder BX) erforderlich!

Die Unterstützung der KL6831 oder KL6841 an einem Embedded-PC (CX) ohne TwinCAT PLC ist nicht gegeben.


KL6831 und KL6841 - Diagnose-LEDs

BECKHOFF KL6831 und KL6841: Produktübersicht

Diagnose-LEDs

Die LEDs zeigen den Betriebszustand der KL6831 und KL6841 an.

Bedeutung der LED-Anzeigen
LED | Farbe | Zustand und Bedeutung
 |  | Ein | Aus | Blinkt
Run-LED | grün | K-Buskommunikation OK | keine K-Bus Kommunikation | K-Bus Kommunikation
Send-LED | grün | SMI-Telegramme werden versendet | kein Senden | Senden aktiv
+ 24 V Power-LED | grün | Spannungsversorgung okay | 24 V Spannungsversorgung fehlt | -
Input 1 Status-LED | grün | DI 1 ist eingeschaltet oder war aktiv und ist noch nicht quittiert worden. | DI 1 ist ausgeschaltet | -
Error-LED | rot | Hardware-Fehler | kein Fehler | -
Receive-LED | grün | SMI-Telegramme werden empfangen | kein Empfangen | Empfangen aktiv
Input 2 Status-LED | grün | DI 2 ist eingeschaltet oder war aktiv und ist noch nicht quittiert. | DI 2 ist ausgeschaltet | -


KL6831 und KL6841 - Technische Daten

BECKHOFF KL6831 und KL6841: Produktübersicht

Technische Daten

Technische Daten | KL6831 | KL6841
Anzahl Kanäle | 1
Anzahl SMI-Slaves | maximal 16
Potenzialtrennung (K-Bus / SMI-Bus) | 1500 V
Bitbreite im K-Bus E/A | 2 x 22 Bit Ein- und Ausgangsdaten, 1 x 16 Bit Control-/Status-Word
Bitbreite im Eingangsprozessabbild | 22 Bit Eingangsdaten, 16 Bit Control-/ Status-Word
Bitbreite im Ausgangsprozessabbild | 22 Bit Ausgangsdaten, 16 Bit Control-/ Status-Word
Konfiguration | Über Funktionsbausteine der Automatisierungs-Software TwinCAT
Besondere Eigenschaften | 2 Digital-Eingänge zur vereinfachten Inbetriebnahme, TwinCAT-Library vorhanden, nur mit Beckhoff-Steuerung verwendbar
Spannungsversorgung für Elektronik | über den K-Bus
Stromaufnahme aus dem K-Bus | typisch 55 mA
Kurzschlussfestigkeit | ja, automatischer Wideranlauf
Eingangsspannung | 24 VDC (-15%/+ 20%)
Isolationsspannung | SMI-Bus / K-Bus: dauerhaft 1500 VAC SMI-Bus / 24 V DC Stromversorgung: dauerhaft 1500 VAC K-Bus / 24 V DC Stromversorgung: dauerhaft 500 VAC
SMI | normkonform, Leerlaufspannung ca. 18 VDC
Übertragungsraten | 2400 Baud
SMI-System | LoVo | 230 VAC
Überspannungsfestigkeit (effektiv) | dauerhaft 275 VAC
Gewicht | ca. 80 g
Abmessungen (B x H x T) | ca. 15mm x 100mm x 70mm
Montage | auf 35 mm Tragschiene nach EN 50022
Verlustleistung | 0,5 W + Verlustleistung verursacht durch die angeschlossenen SMI-Slaves
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


ELxxxx, KLxxxx - Tragschienenmontage

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Tragschienenmontage

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Montage

Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:

  1. Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
  2. Auf der rechten Seite des Feldbuskoppler werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
    Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.

Hinweis 		Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein.
Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät.
Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.

Demontage

Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:

  1. Ziehen Sie die Klemme an ihren orangefarbige Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
  2. Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.

Verbindungen innerhalb eines Busklemmenblocks

Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:

  • Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
  • Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.

Hinweis 		Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen.
Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.

PE-Powerkontakt

Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.

Achtung 		Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbraucher mit 230 V Nennspannung).

Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.

WARNUNG 		Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Anschlusstechnik

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Anschlusstechnik

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Übersicht

Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:

  • Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
  • Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
  • Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.

Standardverdrahtung

Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und
integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.

Steckbare Verdrahtung

Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt.
Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.

Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.

Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.

Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.

Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.

High-Density-Klemmen (HD-Klemmen)

Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.

Hinweis 		Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.

Ultraschall-litzenverdichtete Leiter

Hinweis 		Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschall verschweißte) Leiter angeschlossen werden.
Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!

Verdrahtung

Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx

Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.

Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm

High-Density-Klemmen ELx8xx, KLx8xx (HD)

Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässige Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.

Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm

Schirmung

Hinweis 		Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL6831 und KL6841 - Anschluss

BECKHOFF KL6831 und KL6841: Montage und Verdrahtung

Anschluss

Klemmstelle | Nr. | Anschluss für
+ 24 V DC | 1 | 24 V Versorgungsspannung
Input 1 | 2 | 24 V Digitaleingang zur Ausführung von frei definierbaren SMI-Befehlen, Voreinstellung "alle SMI-Antriebe hochfahren"
SMI+ | 3 | SMI-Busleitung I+
SMI- | 4 | SMI-Busleitung I-
0 V | 5 | Masse
Input 2 | 6 | 24 V Digitaleingang zur Ausführung von frei definierbaren SMI-Befehlen, Voreinstellung "alle SMI-Antriebe runterfahren"
SMI+ | 7 | SMI-Busleitung I+
SMI- | 8 | SMI-Busleitung I-

Hinweis 		Input 1 und Input 2
Die digitalen Eingänge Input 1 und Input 2 (Klemmstelle 2 und 6) funktionieren nur, wenn die 24 V Versorgungsspannung anliegt und der K-Bus mit Spannung versorgt ist.

Hinweis 		Input 1 und Input 2, Auswirkung auf den Automatikmodus
Die digitalen Eingänge Input 1 und Input 2 (Klemmstelle 2 und 6) haben gegenüber der automatischen Steuerung durch das PLC-Programm eine Vorangstellung. Werden die digitalen Eingänge betätigt, so werden andere PLC gesteuerte SMI-Befehle gesperrt. Zur Freigabe muss eine positve Flanke an den bResetInactiveProcessImage Eingang des FB_KL6831KL6841Communication gelegt werden. Siehe Dokumentation TwinCAT PLC Lib:SMI.


Feldbuskomponennten - SMI-Übersicht

BECKHOFF Feldbuskomponennten: SMI

SMI - Übersicht

Einführung SMI

Mit dem SMI-Bussystem (Standard Motor Interface) wird in der Gebäudeautomatisierung die Rollladen- und Sonnenschutzautomation vereinfacht. Mit SMI-Antrieben können exakte Positionen bei Rollladen und gradgenaue Winkelpositionen bei Jalousieantrieben angefahren werden. Die SMI-Antriebe können Ist-Positionen, Fehlermeldungen und Serviceinformationen an die SMI-Masterklemme zurücksenden.

Bedeutende europäische Hersteller haben sich zum SMI-Arbeitskreis zusammengeschlossen und das digitale Interface entwickelt. Über diese einheitliche Schnittstelle werden Antriebe mittels Telegrammen angesteuert. Mit Standard-Befehlen lassen sich Funktionen realisieren, die bei konventionellen Antrieben nicht so leicht möglich sind. Beispiele sind das präzise Anfahren von Positionen, die Rückmeldung der aktuellen Position so wie die Diagnose. Für die Verstellung von Lammelen der Verschattungsanlage können z.B. Winkelauflösungen von 2° erreicht werden. Damit ist eine sonnenstandsabhängige Nachführung der Lammelen zur Konstantlichtregelung möglich.

Es sind Distanzen bis 350 Meter zwischen Steuerung und Antrieb möglich. Zur Verkabelung kann ein normales 5-adriges Stromkabel verwendet werden (mit PE, N, L so wie dem SMI spezifischen I+ und I-), wobei I+ und I- verpolungssicher sind. Bis zu 16 Antriebe können parallel geschaltet und einzeln adressiert werden. SMI-Antriebe gibt es für Netzspannung (230 VAC) und für Kleinspannung ( 24 VDC).

Um die Kompatibilität der SMI-Produkte untereinander zu gewährleisten, müssen alle Produkte, die mit dem SMI-Logo gekennzeichnet werden sollen, zertifiziert werden. Eine positive Zertifizierung lässt sich auf der Homepage der SMI-Group (www.smi-group.com) nachlesen. Dort finden sie auch weitere Informationen über den SMI-Bus und SMI-Antriebe.


KL6831 und KL6841 - Arbeitsweise

BECKHOFF KL6831 und KL6841: SMI

Arbeitsweise

Die beiden SMI-Masterklemmen KL6831 und KL6841 erlaubt den Betrieb von 16 SMI-Antrieben (Jalousien/Rollläden) je Klemme und unterstützt den kompletten SMI-Funktionsumfang. Mit vorgefertigten Bausteine werden im PLC-Anwenderprogramm neben Auf-/Abfahr- und Stopp-Befehlen auch das Anfahren beliebiger Positionen, das Einstellen des Lamellenwinkels sowie Rückmeldungen zur aktuellen Position des Motors/der Jalousie realisiert. Die SMI-Masterklemmen setzen die Prozessdaten (Fahrbefehle im PLC-Programm) in das SMI-Protokoll inkl. Pegelwandlung um. Zur Speisung müssen die Klemmen mit einer extern 24V Gleichspannung versorgt werden. K-Bus, 24 V Versorgung und die SMI-Anschlüsse besitzen gegeneinander eine galvanische Trennung.

Adressierung der SMI-Antriebe und Programmierung der SMI-Masterklemme

Die Adressierung der SMI-Antriebe und Programmierung der SMI-Masterklemme ist in der Softwaredokumentation im Beckhoff Information System enthalten:

TwinCAT 2: TwinCAT 2 PLC Lib: SMI

TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_SMI

Hinweise zur Inbetriebnahme mit DI1 und DI2

Das Verhalten der digitalen Eingänge DI1 und DI2 kann über die Bibliotheksbausteine verändert werden.
Zur Unterstützung der Inbetriebnahme ist folgendes Verhalten hinterlegt.

Digitaleingang | SMI-Komando
Steigende Flanke an DI1 | Alle SMI-Antriebe fahren bei steigender Flanke an DI1 AUF (Werkseinstellung)
Fallende Flanke an DI1 | Alle SMI-Antriebe stoppen bei fallender Flanke an DI1 (Werkseinstellung)
Steigende Flanke an DI2 | Alle SMI-Antriebe fahren bei steigender Flanke an DI2 AB (Werkseinstellung)
Fallende Flanke an DI2 | Alle SMI-Antriebe stoppen bei fallender Flanke an DI2 (Werkseinstellung)
Auswirkung bei der Betätigung von den digitalen Eingängen DI1 und DI2 auf den Automatikmodus

Die digitalen Eingänge Input 1 und Input 2 (Klemmstelle 2 und 6) haben gegenüber der automatischen Steuerung durch das PLC-Programm eine Vorrangstellung. Werden die digitalen Eingänge betätigt, so werden andere PLC gesteuerte SMI-Befehle gesperrt. Zur Freigabe muss eine positive Flanke an den bResetInactiveProcessImage Eingang des FB_KL6831KL6841Communication gelegt werden. Siehe Dokumentation TwinCAT PLC Lib:SMI.


KL6831 und KL6841 - Programmierung

BECKHOFF KL6831 und KL6841: Programmierung

TwinCAT-Bibliotheken

Software-Dokumentation im Beckhoff Information System:

TwinCAT 2: TwinCAT 2 PLC Lib: SMI

TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_SMI


KL6831, KL6841 - Registerübersicht

BECKHOFF KL6831, KL6841: Zugriff aus dem Anwenderprogramm

Registerübersicht

Die Register dienen zur Parametrierung der Schnittstellenklemmen. Sie können über die Registerkommunikation ausgelesen oder beschrieben werden.

Register-Nr. | Kommentar |  | Default-Wert |  | R/W | Speicher
R0 | reserviert |  | 0x0000 | 0dez | - | -
... | ... |  | ... | ... | ... | ...
R5 | reserviert |  | 0x0000 | 0dez | - | -
R6 | Diagnose-Register |  | variabel | variabel | R | RAM
R7 | Komando-Register |  | 0x0000 | 0dez | R/W | RAM
R8 | Klemmentyp | KL6831 | 0x1AAF | 6831dez | R | ROM
 |  | KL6841 | 0x1AB9 | 6841dez | R | ROM
R9 | Firmware-Stand |  | variabel | variabel | R | ROM
R10 | reserviert |  | 0x0000 | 0dez | - | -
... | ... |  | ... | ... | ... | ...
R15 | reserviert |  | 0x0000 | 0dez | - | -
R16 | Hardware-Version |  | z.B. 0x0000 | z.B.: 0dez | ... | EEPROM
R17 | reserviert |  | 0x0000 | 0dez | - | -
... | ... |  | ... | ... | ... | ...
R28 | reserviert |  | 0x0000 | 0dez | - | -
R29 | Klemmentyp - Sonderkennung |  | 0x0000 | 0dez | R | EEPROM
R30 | reserviert |  | 0x0000 | - | - | -
R31 | Kodewort-Register |  | 0x0000 | 0dez | R/W | RAM
R32 | Feature-Register |  | 0x0000 | 0dez | R/W | EEPROM
R33 | Watchdog-Register |  | variabel | variabel | R/W | RAM
R34 | Watchdog-Register |  | variabel | variabel | R/W | RAM
R35 | Watchdog-Register |  | variabel | variabel | R/W | RAM
R36 | DI-Register |  | variabel | variabel | R/W | RAM
... | ... |  | ... | ... | ... | ...
R47 | DI-Register |  | variabel | variabel | R/W | RAM
... | ... |  | ... | ... | ... | ...
R63 | reserviert |  | 0x0000 | 0dez | - | -


KL6831, KL6841 - Registerbeschreibung

BECKHOFF KL6831, KL6841: Zugriff aus dem Anwenderprogramm

Registerbeschreibung

Alle Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemmen.

Das Verhalten bei K-Bus Watchdog (R33 ... R35) und das Verhalten der Eingänge DI1 und DI2 (R36 ... R47) kann über Bibliotheksbausteine verändert werden.

R6: Diagnose-Register

Bit | Beschreibung |  | default
R6.5-15 | - | reserviert | -
R6.4 | 1bin | Buffer ist voll | 0bin
R6.3 | 1bin | Overrun Error ist aufgetreten | 0bin
R6.2 | 1bin | Framing Error ist aufgetreten | 0bin
R6.1 | 1bin | Parity Error ist aufgetreten | 0bin
R6.0 | 1bin | Der Empfangsbuffer ist übergelaufen, ankommende Daten gehen verloren | 0bin

R7: Kommando-Register

Hinweis 		Anwender-Kodewort
Um die folgenden Kommandos auszuführen muss zuvor in Register R31 das Anwender-Kodewort 0x1235 eingetragen sein!
Kommando 0x7000: Restore Factory Settings

Mit dem Eintrag 0x7000 in Register R7 werden für die folgenden Register die Werte des Auslieferungszustands wiederhergestellt:

R33, 34 und 35: Keine SMI-Kommando bei K-Bus Watchdog kommt
R36, 37 und 38: Alle SMI-Antriebe fahren bei steigender Flanke an DI1 AUF
R39, 40 und 41: Alle SMI-Antriebe stoppen bei fallender Flanke an DI1
R42, 43 und 44: Alle SMI-Antriebe fahren bei steigender Flanke an DI2 AB
R45, 46 und 47: Alle SMI-Antriebe stoppen bei fallender Flanke an DI2

R8: Klemmentyp

Im Register R8 steht die Bezeichnung der Klemme:
KL6831: 0x1AAF (6831dez)
KL6841: 0x1AB9 (6841dez)

R9: Firmware-Stand

Im Register R9 steht in ASCII-Codierung der Firmware-Stand der Klemme, z.B. 0x3143 = '1C'. Hierbei entspricht die '0x31' dem ASCII-Zeichen '1' und die '0x43' dem ASCII-Zeichen 'C'.
Dieser Wert kann nicht verändert werden.

R16: Hardware-Versionsnummer

Im Register R16 steht der Hardware-Stand der Klemme.

R31-R47: Anwenderregister

R31: Kodewort-Register

  • Wenn Sie in die Anwender-Register Werte schreiben ohne zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen zu haben, werden diese Werte von der Klemme nicht übernommen.
  • Wenn Sie in die Anwender-Register Werte schreiben und haben zuvor das Anwender-Kodewort (0x1235) in das Kodewort-Register eingetragen, werden diese Werte in die RAM-Register und in die EEPROM-Register geschrieben und bleiben somit bei einem Neustart der Klemme erhalten.

Das Kodewort wird bei einem Neustart der Klemme zurückgesetzt.

R32: Feature Register

Das Feature Register R32 ist nicht belegt.

R33, R34 und R35: Watchdog

Das R33, 34 und 35 legt das Verhalten der Klemme beim Auftreten eines K-Bus Watchdog fest.

Werkseinstellung steht auf: Kein SMI-Kommando beim auslösen des K-Bus Watchdogs.

Das Verhalten kann über die Bibliotheksbausteine verändert werden.

R36 bis R47: Verhalten der DI1 und DI2

Das Verhalten der digitalen Eingänge DI 1 und DI2 kann über die Bibliotheksbausteine verändert werden.

Digitaleingang | SMI-Komando
Steigende Flanke an DI1 | Alle SMI-Antriebe fahren bei steigender Flanke an DI1 AUF (Werkseinstellung)
Fallende Flanke an DI1 | Alle SMI-Antriebe stoppen bei fallender Flanke an DI1 (Werkseinstellung)
Steigende Flanke an DI2 | Alle SMI-Antriebe fahren bei steigender Flanke an DI2 AB (Werkseinstellung)
Fallende Flanke an DI2 | Alle SMI-Antriebe stoppen bei fallender Flanke an DI2 (Werkseinstellung)


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.