KL4112 - Zweikanalige Analogausgangsklemme, 0 bis 20 mA, 16 Bit
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Beckhoff Identification Code (BIC)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.2
▪
Update Kapitel „Hinweise zum ESD-Schutz“
▪
Kapitel „Beckhoff Identification Code (BIC)“ eingefügt
3.1
▪
Update Technische Daten
▪
Strukturupdate
3.0
▪
Migration
▪
Update Technische Daten
▪
Strukturupdate
▪
Kapitel Konfigurations-Software KS2000 und Zugriff aus dem Anwenderprogramm hinzugefügt
Firmware (FW)- und Hardware (HW)-Stände
Dokumentation, Version | KL4112
 | FW | HW
3.1 | 3D | 03
3.0 | 3D | 03
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 04 1B 01:
35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


Beckhoff Identification Code (BIC)

Vorwort [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
KL4112 - Einführung
•
KL4112 - Technische Daten
•
Grundlagen zur Funktion


KL4112 - Einführung

Produktübersicht [image] KL4112 - Einführung
KL4112 - Einführung
KL4112
Die analoge Ausgangsklemme KL4112 erzeugt analoge Ausgangssignale im Bereich von 0 mA bis 20 mA. Der Strom wird mit einer Auflösung von 16 Bit (Default: 15 Bit) galvanisch getrennt zur Prozessebene gespeist. Die Ausgangskanäle einer Busklemme besitzen ein gemeinsames Massepotenzial mit der Versorgung 24 VDC. Die Ausgangsstufen werden durch die 24-V-Versorgung gespeist. Den Datenaustausch mit dem Buskoppler zeigen die beiden Run-LEDs an.


KL4112 - Technische Daten

Produktübersicht [image] KL4112 - Technische Daten
KL4112 - Technische Daten
Technische Daten | KL4112
Anzahl der Ausgänge | 2
Spannungsversorgung für Elektronik | 24 VDC über die Powerkontakte
Signalstrom | 0 mA…20 mA
Bürde | < 500 Ω
Genauigkeit | < ±0,1 % (vom Messbereichsendwert), bei 23 °C
Auflösung | 15 Bit , konfigurierbar 16 Bit
Potenzialtrennung | 500 V (K-Bus / Signalspannung)
Wandlungszeit | ~ 3,5 ms
Stromaufnahme aus dem K-Bus | typisch 60 mA
Bitbreite im K-Bus E /A | Output: 2 x 16 Bit Daten (optional 2 x 8 Bit Control/Status)
Konfiguration | Keine Adress- oder Konfigurationseinstellung
Gewicht | ca. 80 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE, cULus, ATEX


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die analoge Ausgangsklemme KL4112 erzeugt Signale im Bereich von 0 mA bis 20 mA. Die Ausgangsspannung wird mit bis zu 16 Bit Auflösung von der Klemme ausgegeben. Die Ausgangsspannung wird galvanisch getrennt von der Klemmenbusebene ausgegeben.
Die LEDs geben den Betriebszustand des dazugehörigen Klemmenkanals wieder.
▪
grüne Run-LED:
–
Ein: normaler Betrieb
–
Aus: Watchdog-Timer Overflow ist aufgetreten. Werden vom Buskoppler 100 ms keine Prozessdaten übertragen, so erlöschen die grünen LEDs. Der Ausgang nimmt eine vom Anwender vorgegebene Spannung an (s. Feature-Register).
Eingabeformat der Prozessdaten
Die Prozessdaten werden im Auslieferungszustand im Zweierkomplement dargestellt (integer -1 entspricht 0xFFFF).
Ausgabewert | Prozessdatum
 | dez | hex
0 mA | 0 | 0x0000
10 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
Prozessdaten
Die Prozessdaten, die vom Buskoppler kommen, werden wie folgt an den Prozess ausgegeben:
Y_0 = B_a + A_a*X
Y_dac = Y_0
(1.0)
Weder Anwender- noch Herstellerskalierung aktiv.
Y_1 = B_h + A_h * X
Y_dac = Y_1
(1.1)
Herstellerskalierung aktiv
Y_2 = B_w + A_w * X
Y_dac = Y_2
(1.2)
Anwenderskalierung aktiv
Y_1 = B_h + A_h * X
Y_dac = B_w + A_w * Y_1
(1.3)
(1.4)
Hersteller- und Anwenderskalierung aktiv
Legende
Name | Bezeichnung | Register
X | Prozessdaten der SPS | -
B_a | Hardware-Abgleich Offset | R17
A_a | Hardware-Abgleich Gain | R18
B_h | Hersteller-Skalierung: Offset | R19
A_h | Hersteller-Skalierung: Gain | R20
B_w | Anwender-Skalierung: Offset | R33
A_w | Anwender-Skalierung: Gain | R34
Y_dac | Ausgabewert zum D/A-Wandler | -
Die Geradengleichungen werden über Register R32 aktiviert


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
KL4112 - Anschluss und LED-Beschreibung
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endklemme KL9010 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KL4112 - Anschluss und LED-Beschreibung

Montage und Verdrahtung [image] KL4112 - Anschluss und LED-Beschreibung
KL4112 - Anschluss und LED-Beschreibung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
KL4112 - Anschluss und LEDs
Anschluss KL4112
Klemmstelle | Nr. | Kommentar
Output1 | 1 | + Ausgang 1
+24 V | 2 | 24 V (intern verbunden mit Klemmstelle 6 und positivem Power-Kontakt)
GND | 3 | 0 V (intern verbunden mit Klemmstelle 7 und negativem Power-Kontakt)
Shield | 4 | PE-Kontakt (intern verbunden mit Klemmstelle 8)
Output2 | 5 | + Ausgang 2
+24 V | 6 | 24 V (intern verbunden mit Klemmstelle 2 und positivem Power-Kontakt)
GND | 7 | 0 V (intern verbunden mit Klemmstelle 3 und negativem Power-Kontakt))
Shield | 8 | PE-Kontakt (intern verbunden mit Klemmstelle 4)
LED Beschreibung KL4112
LED | Farbe | Beschreibung
LED Run1 LED Run2 | grün | Ein: | Normaler Betrieb
 |  | Aus: | Watchdog-Timer Overflow ist aufgetreten. Werden zum Buskoppler 100 ms keine Prozessdaten übertragen, so erlöschen die grünen LEDs. Der Ausgang nimmt eine vom Anwender vorgegebene Spannung an (s. Feature-Register).


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Konfigurations-Software KS2000

Konfigurations-Software KS2000
Konfigurations-Software KS2000
Weiterführende Informationen
•
KS2000 - Einführung


KS2000 - Einführung

Konfigurations-Software KS2000 [image] KS2000 - Einführung
KS2000 - Einführung
Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler / Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.
Konfigurations-Software KS2000
Projektierung
Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, das heißt vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.
Parametrierung
KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.
Inbetriebnahme
KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.
KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:
▪
Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
▪
Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.
Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


Zugriff aus dem Anwenderprogramm

Zugriff aus dem Anwenderprogramm
Zugriff aus dem Anwenderprogramm
Weiterführende Informationen
•
KL4112 - Klemmenkonfiguration
•
Mapping im Buskoppler
•
Registerübersicht
•
Registerbeschreibung
•
Control und Status Byte
•
Beispiele für die Register-Kommunikation


KL4112 - Klemmenkonfiguration

Zugriff aus dem Anwenderprogramm [image] KL4112 - Klemmenkonfiguration
KL4112 - Klemmenkonfiguration
Die Klemme kann über die interne Registerstruktur konfiguriert und parametriert werden. Jeder Klemmenkanal wird im Buskoppler gemappt. In Abhängigkeit vom Typ des Buskopplers und von der eingestellten Mapping-Konfiguration (z. B. Motorola-/Intel-Format, Word-Alignment usw.), werden die Daten der Klemme unterschiedlich im Speicher des Buskopplers abgebildet. Zur Parametrierung einer Klemme ist es erforderlich, das Control- und Status-Byte mit abzubilden.
Lightbus-Koppler BK2000
Beim Lightbus-Koppler BK2000 wird neben den Datenbytes auch immer das Control-/Statusbyte gemappt. Dieses liegt stets im Low-Byte auf der Offsetadresse des Klemmenkanals.
Mapping im Lightbus-Koppler - Beispiel für KL4112
Profibus-Koppler BK3000
Beim Profibus-Koppler BK3000 muss in der Masterkonfiguration festgelegt werden, für welche Klemmenkanäle das Control- und Status-Byte mit eingeblendet werden soll. Werden Control- und Status-Byte nicht ausgewertet, belegen die Klemmen 2 Byte pro Kanal:
▪
KL4112: 4 Byte Ausgangsdaten
Mapping im Profibus-Koppler - Beispiel für KL4112
Interbus-Koppler BK4000
Der Interbus-Koppler BK4000 mappt die KL4112 im Auslieferungs-zustand mit 4 Byte Ausgangsdaten (2 Byte Nutzdaten pro Kanal). Eine Parametrierung über den Feldbus ist nicht möglich. Soll das Control- und Status-Byte verwendet werden, wird die Konfigurations-Software KS2000 benötigt.
Mapping im Interbus-Koppler - Beispiel für KL4112
Andere Buskoppler und weitere Angaben
Nähere Angaben zur Mapping-Konfiguration von Buskopplern finden Sie im jeweiligen Buskoppler-Handbuch im Anhang unter Konfiguration der Master.
Im Kapitel Mapping im Buskoppler befindet sich eine Übersicht über die möglichen Mapping-Konfigurationen in Abhängigkeit der einstellbaren Parameter.
Parametrierung mit KS2000
Mit der Konfigurations-Software KS2000 können die Parametrierungen unabhängig vom Feldbussystem über die serielle Schnittstelle des Buskopplers durchgeführt werden.


Mapping im Buskoppler

Zugriff aus dem Anwenderprogramm [image] Mapping im Buskoppler
Mapping im Buskoppler
Wie bereits im Kapitel Klemmenkonfiguration beschrieben wurde, wird jede Busklemme im Buskoppler gemappt. Dieses Mapping vollzieht sich im Standardfall mit der Defaulteinstellung im Buskoppler / Busklemme. Mit der Konfigurations-Software KS2000 oder mit einer Master Konfigurationssoftware (z. B. ComProfibus oder TwinCAT System Manager) ist es möglich diese Defaulteinstellung zu verändern.
Wenn die Klemmen komplett ausgewertet werden, belegen sie Speicherplatz im Eingangs- und Ausgangs-Prozessabbild.
Die folgenden Tabellen geben darüber Auskunft wie sich die Klemmen, abhängig von den eingestellten Parametern, im Buskoppler mappen.
Weiterführende Informationen
•
KL4112


KL4112

Zugriff aus dem Anwenderprogramm [image] Mapping im Buskoppler [image] KL4112
KL4112
Default-Mapping für: CANopen-, CANCAL-,DeviceNet-, ControlNet-, Modbus-, RS232- und RS485-Koppler
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: nein Motorola-Format: nein Word-Alignment: egal | 0 | Ch0 D1 | Ch0 D0
 | 1 | Ch1 D1 | Ch1 D0
 | 2 | - | -
 | 3 | - | -
Default-Mapping für: Profibus- und Interbus-Koppler
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: nein Motorola-Format: ja Word-Alignment: egal | 0 | Ch0 D0 | Ch0 D1
 | 1 | Ch1 D0 | Ch1 D1
 | 2 | - | -
 | 3 | - | -
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: nein | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D1
 | 2 | Ch1 D1 | Ch1 D0
 | 3 | - | -
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: nein | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D0
 | 2 | Ch1 D0 | Ch1 D1
 | 3 | - | -
Default-Mapping für: Lightbus- und Ethernet-Koppler sowie Busklemmen Controller (BCxxxx, BXxxxx)
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: ja Motorola-Format: nein Word-Alignment: ja | 0 | Res. | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | Res. | Ch1 CB/SB
 | 3 | Ch1 D1 | Ch1 D0
Bedingungen | Wort-Offset | High Byte | Low Byte
Komplette Auswertung: ja Motorola-Format: ja Word-Alignment: ja | 0 | Res. | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | Res. | Ch1 CB/SB
 | 3 | Ch1 D0 | Ch1 D1
Legende
Komplette Auswertung | Die Klemme wird mit Control- und Status-Byte gemappt.
Motorola-Format | Es ist Motorola- oder Intel-Format einstellbar.
Word-Alignment | Die Klemme liegt auf einer Wortgrenze im Buskoppler.
Ch n CB | Control-Byte für Kanal n (erscheint im Prozessabbild der Ausgänge).
Ch n SB | Status-Byte für Kanal n (erscheint im Prozessabbild der Eingänge).
Ch n D0 | Kanal n, Datenbyte 0 (niederwertigste Byte)
Ch n D1 | Kanal n, Datenbyte 1 (höchstwertigste Byte)
"-" | Dieses Byte wird von der Klemme nicht benutzt und belegt.
Res. | Reserviert: dieses Byte belegt den Prozessdatenspeicher, hat aber kein Funktion.


Registerübersicht

Zugriff aus dem Anwenderprogramm [image] Registerübersicht
Registerübersicht
Diese Register sind für jeden Kanal einmal vorhanden
Adresse | Bezeichnung | Defaultwert | R/W | Speichermedium
R0…R4 | reserviert | 0x0000 | R | RAM
R5 | DAC-Rohwert | variabel | R |
R6 | Diagnose-Register | 0x0000 | R | RAM
R7 | Kommando-Register | 0x0000 | R |
R8 | Klemmentyp | 4112 | R | ROM
R9 | Software-Versionsnummer | 0x???? | R | ROM
R10 | Multiplex-Schieberegister | 0x0218 | R | ROM
R11 | Signalkanäle | 0x0218 | R | ROM
R12 | minimale Datenlänge | 0x9800 | R | ROM
R13 | Datenstruktur | 0x0000 | R | ROM
R14 | reserviert | 0x0000 | R |
R15 | Alignment-Register | variabel | R/W | RAM
R16 | Hardware Versionsnummer | 0x???? | R/W | SEEROM
R17 | Hardware-Abgleich: Offset | spezifisch | R/W | SEEROM
R18 | Hardware-Abgleich: Gain | spezifisch | R/W | SEEROM
R19 | Hersteller-Skalierung: Offset | 0x0000 | R/W | SEEROM
R20 | Hersteller-Skalierung: Gain | 0x0000 | R/W | SEEROM
R21…R30 | reserviert | 0x0000 | R/W | SEEROM
R31 | Code-Word-Register | variabel | R/W | RAM
R32 | Feature-Register | 0x0020 | R/W | SEEROM
R33 | Anwender-Skalierung: Offset | 0x0000 | R/W | SEEROM
R34 | Anwender-Skalierung: Gain | 0x0100 | R/W | SEEROM
R35 | Anwender-Einschaltwert | 0x0000 | R/W | SEEROM
R36…R63 | reserviert | 0x0000 | R/W | SEEROM


Registerbeschreibung

Zugriff aus dem Anwenderprogramm [image] Registerbeschreibung
Registerbeschreibung
Die Register können über die Registerkommunikation ausgelesen oder beschrieben werden. Sie dienen zur Parametrierung der Klemme.
R0 bis R7: Register im internen RAM der Klemme
Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion klemmenspezifisch.
▪
R0 bis R4: reserviert
▪
R5: DAC-Rohwert (Y_dac)
Als DAC-Rohwert wird der zum D/A-Wandler übertragene 16-Bit Wert bezeichnet. Dieser berechnet sich aus den Prozessdaten über die Hersteller- und Anwenderskalierung.
▪
R6 bis R7: reserviert
R8 bis R15: Register im internen ROM der Klemme
Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur ausgelesen und nicht verändert werden.
▪
R8: Klemmentyp
Der Klemmentyp in Register R8 wird zur Identifizierung der Klemme benötigt.
▪
R9: Softwareversion (X.y)
Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.
▪
R10: Datenlänge
R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit.
Der Buskoppler sieht diese Struktur.
▪
R11: Signalkanäle
Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z. B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.
▪
R12: Minimale Datenlänge
Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control- und Status-Byte nicht zwingend notwendig für die Funktion der Klemme und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen.
▪
R13: Datentypregister
Datentypregister | Bedeutung
0x00 | Klemme ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Doppelwort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
▪
R14: reserviert
▪
R15: Alignment-Bits (RAM)
Mit den Alignment-Bits wird die Analogklemme im Buskoppler auf eine Bytegrenze gelegt.
R16 bis R30: Bereich der Herstellerparameter (SEEROM)
Die Herstellerparameter sind spezifisch für jeden Klemmentyp. Sie sind vom Hersteller programmiert, können jedoch auch von der Steuerung geändert werden. Die Herstellerparameter sind spannungsausfallsicher in einem seriellen EERPOM in der Klemme gespeichert.
Diese Register können nur nach dem Setzen eines Code-Worts in R31 geändert werden.
▪
R17: Hardware-Abgleich - Offset (B_a)
Über dieses Register erfolgt der hardwaremäßige Offset-Abgleich.
▪
R18: Hardware-Abgleich - Gain (A_a)
Gain-Hardware*2-16
Über dieses Register erfolgt der hardwaremäßige Gain-Abgleich.
0xFFFF entspricht 1
▪
R19: Hersteller-Skalierung - Offset (B_h)
Dieses Register beinhaltet den Offset der Herstellergeradengleichung (Gl. 1.1). Die Geradengleichung wird über Register R32 aktiviert.
▪
R20: Hersteller-Skalierung - Gain (A_h)
16 Bit unsigned Integer*2-8 [0x0100]
Dieses Register beinhaltet den Skalierungsfaktor der Herstellergeradengleichung (Gl. 1.1). Die Geradengleichung wird über Register R32 aktiviert.
Eine 1 entspricht dem Registerwert 0x0100.
R31 bis R47: Bereich der Anwenderparameter (SEEROM)
Die Anwenderparameter sind spezifisch für jeden Klemmentyp. Sie können vom Programmierer geändert werden. Die Anwenderparameter sind spannungsausfallsicher in einem seriellen EEPROM in der Klemme gespeichert. Der Anwenderbereich ist über ein Code-Wort schreibgeschützt.
• R31: Code-Wort-Register im RAM
Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Registers zurückgegeben. Ist der Schreibschutz aktiv, enthält das Register den Wert Null.
▪
R32: Feature-Register
[0x0020]
Dieses Register legt die Betriebsarten der Klemme fest.
Hinweis zum Ausgabeformat
Aus Kompatibilitätsgründen ist das Standard-Ausgabeformat 16-Bit signed Integer (defaultmäßig eingestellt). Der positive Wertebereich für 0 mA bis 20 mA erstreckt sich demzufolge von 0 bis 32767 (0x7FFF). Dies entspricht 15 Bit. Um alle 16 Bit der Klemme zu nutzen, muss die Herstellerskalierung deaktiviert werden.
Feature Bit Nr. |  | Beschreibung der Betriebsart
Bit 0 | 1 | Anwender Skalierung (R33, R34) aktiv [0]
Bit 1 | 1 | Hersteller Skalierung (R19, R20) aktiv [1]
Bit 2 | 0 | Watchdog-Timer aktiv [0] Der Watchdog-Timer ist im Auslieferungszustand eingeschaltet. Bei einem Watchdog Overflow wird entweder der Hersteller- oder der Anwendereinschaltwert an den Ausgang der Klemme gelegt.
Bit 3…7 | - | Reserviert, dont`t change
Bit 8 | 0/1 | 0bin: Hersteller-Einschaltwert [0] 1bin: Anwender-Einschaltwert
Bit 9…15 | - | Reserviert, dont`t change
▪
R33: Anwender Skalierung - Offset (B_w)
16 Bit signed Integer [0x0000]
Dieses Register beinhaltet den Offset der Anwendergeradengleichung (Gl. 1.4). Die Geradengleichung wird über das Register R32 aktiviert.
▪
R34: Anwender Skalierung - Gain (A_w)
16 Bit signed Integer*2-8 [0x0100]
Dieses Register beinhaltet den Skalierungsfaktor der Anwendergeradengleichung (Gl. 1.4). Die Geradengleichung wird über das Register R32 aktiviert.
▪
R35: Anwender-Einschaltwert
16 Bit signed Integer [0x0000]
Ist der Anwender-Einschaltwert im Register R32 aktiviert, wird dieser Wert nach einem System-Reset oder einem Watchdog-Timer-Overflow (Klemme hat 100 ms keine Prozessdaten empfangen) an den Ausgang der Klemme gelegt.


Control und Status Byte

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte
Control und Status Byte
Das Control-und Status-Byte wird von der Steuerung zur Klemme übertragen. Es kann
▪
im Registermodus (REG = 1bin) oder
▪
im Prozessdatenaustausch (REG = 0bin) genutzt werden.
Weiterführende Informationen
•
Prozessdatenaustausch
•
Registerkommunikation


Prozessdatenaustausch

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte [image] Prozessdatenaustausch
Prozessdatenaustausch
Control-Byte im Prozessdatenaustausch (REG=0)
Mit dem Control-Byte kann ein Gain- und Offsetabgleich der Klemme durchgeführt werden. Damit ein Abgleich der Klemme durchgeführt werden kann, muss das Code-Wort (0xAFFE) in R31 eingetragen werden. Anschließend kann der Gain und Offset der Klemme abgeglichen werden. Erst durch Zurücksetzen des Code-Worts werden die Parameter permanent gespeichert!
Bit | Beschreibung
Bit 7 | 0bin
Bit 6 | 1bin: Abgleichfunktion der Klemme wird aktiviert
Bit 5 | reserviert
Bit 4 | 1bin: Gain-Abgleich
Bit 3 | 1bin: Offset-Abgleich
Bit 2 | 0bin: langsamer Takt = 1000 ms 1bin: schneller Takt = 50 ms
Bit 1 | 1bin: rauf
Bit 0 | 1bin: runter
Status-Byte im Prozessdatenaustausch (REG=0)
Das Statusbyte wird von der Klemme zur Steuerung übertragen. Bei der KL4112 hat das Status-Byte im Prozessdatenaustausch keine Funktion.


Registerkommunikation

Zugriff aus dem Anwenderprogramm [image] Control und Status Byte [image] Registerkommunikation
Registerkommunikation
Registerzugriff über den Prozessdatenaustausch
▪
Bit 7=1: Registermodus
Wenn Bit 7 des Control-Bytes gesetzt wird, werden die ersten zwei Byte der Nutzdaten nicht zum Prozessdatenaustausch verwendet, sondern in den Registersatz der Klemme geschrieben oder daraus ausgelesen.
▪
Bit 6=0: lesen, Bit 6=1: schreiben
In Bit 6 des Control-Bytes legen Sie fest, ob ein Register ausgelesen oder beschrieben werden soll.
–
Bit 6=0: Ein Register wird ausgelesen, ohne es zu verändern. Der Wert kann dem Eingangs-Prozessabbild entnommen werden.
–
Bit 6=1: Die Nutzdaten werden in ein Register geschrieben. Sobald das Status-Byte im Eingangs-Prozessabbild eine Quittung geliefert hat, ist der Vorgang abgeschlossen (siehe Bsp.).
▪
Bit 0 bis 5: Adresse
In die Bits 0 bis 5 des Control-Bytes wird die Adresse des anzusprechenden Registers eingetragen
Control-Byte im Register-Modus (REG=1)
MSB
REG=1
W/R
A5
A4
A3
A2
A1
A0
REG = 0bin: Prozessdatenaustausch
REG = 1bin: Zugriff auf Registerstruktur
W/R = 0bin: Register lesen
W/R = 1bin: Register schreiben
A5..A0 = Registeradresse
Mit Adressen A5...A0 sind insgesamt 64 Register adressierbar.
Register-Modus Control Byte
Das Control- bzw. Status-Byte belegt die niedrigste Adresse eines logischen Kanals. Die entsprechenden Registerwerte befinden sich in den folgenden 2-Datenbytes. (Ausnahme ist der BK2000: hier wird nach dem Control- bzw. Status-Byte ein nicht genutztes Daten-Byte eingeschoben, und somit der Registerwert auf eine Word-Grenze gelegt).
Beispiel 1:
Lesen des Registers 8 im BK2000 mit einer KL4112 und der Endklemme:
Werden die folgenden Bytes von der Steuerung zur Klemme übertragen,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataOUT 1 | DataOUT 0 | Nicht benutzt | Control-Byte
Wert | 0xXX | 0xXX | 0xXX | 0x88
So liefert die Klemme die folgende Typ-Bezeichnung zurück (0x1010 entspricht im unsigned Integer 4112)
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataIN 1 | DataIN 0 | Nicht benutzt | Status-Byte
Wert | 0x10 | 0x10 | 0x00 | 0x88
Beispiel 2:
Schreiben des Registers 31 im BK2000 mit einer intelligenten Klemme und der Endklemme:
Werden die folgenden Bytes (Code-Wort) von der Steuerung zur Klemme übertragen,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataOUT 1 | DataOUT 0 | Nicht benutzt | Control-Byte
Wert | 0x12 | 0x35 | 0xXX | 0xDF
So wird das Code-Wort gesetzt und die Klemme liefert als Quittung die Registeradresse mit dem Bit 7 für Registerzugriff zurück.
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataIN 1 | DataIN 0 | Nicht benutzt | Status-Byte
Wert | 0x00 | 0x00 | 0x00 | 0x9F


Beispiele für die Register-Kommunikation

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation
Beispiele für die Register-Kommunikation
Die Nummerierung der Bytes in den Beispielen entspricht der Darstellung ohne Word-Alignment.
Weiterführende Informationen
•
Beispiel 1: Lesen des Firmware-Stands aus Register 9
•
Beispiel 2: Beschreiben eines Anwender-Registers


Beispiel 1: Lesen des Firmware-Stands aus Register 9

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 1: Lesen des Firmware-Stands aus Register 9
Beispiel 1: Lesen des Firmware-Stands aus Register 9
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 00 1001bin die Registernummer 9 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x89 | 0x33 | 0x41
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den Firmware-Stand 0x3341 zurück. Dies ist als ASCII-Code zu interpretieren:
–
ASCII-Code 0x33 steht für die Ziffer 3
–
ASCII-Code 0x41 steht für den Buchstaben A
Die Firmware-Version lautet also 3A.


Beispiel 2: Beschreiben eines Anwender-Registers

Zugriff aus dem Anwenderprogramm [image] Beispiele für die Register-Kommunikation [image] Beispiel 2: Beschreiben eines Anwender-Registers
Beispiel 2: Beschreiben eines Anwender-Registers
Code-Wort
Im normalen Betrieb sind bis auf das Register 31, alle Anwender-Register schreibgeschützt. Um diesen Schreibschutz aufzuheben, müssen Sie das Code-Wort (0x1235) in Register 31 schreiben. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder. Beachten Sie, dass Änderungen an einigen Registern erst nach einem Neustart (Power-Off/Power-ON) der Klemme übernommen werden.
I. Schreiben des Code-Worts (0x1235) in Register 31
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält das Code-Wort (0x1235) um den Schreibschutz zu deaktivieren.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
II. Lesen des Register 31 (gesetztes Code-Wort überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0x12 | 0x35
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Code-Wort-Registers zurück.
III. Schreiben des Register 32 (Inhalt des Feature-Registers ändern)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält den neuen Wert für das Feature-Register.
SmallWarningYellow VORSICHT
Beachten Sie die Registerbeschreibung!
Der hier angegebene Wert 0x0002 ist nur ein Beispiel!
Die Bits des Feature-Registers verändern die Eigenschaften der Klemme und haben je nach Klemmen-Typ unterschiedliche Bedeutung. Informieren Sie sich in der Beschreibung des Feature-Registers ihrer Klemme (Kapitel Registerbeschreibung) über die Bedeutung der einzelnen Bits, bevor Sie die Werte verändern.
Eingangsdaten (Antwort der Busklemme)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!
IV. Lesen des Register 32 (geändertes Feature-Register überprüfen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 nicht gesetzt bedeutet: lesen des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 10 0000bin die Registernummer 32 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim Lesezugriff ohne Bedeutung.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung den Wert des Control-Bytes zurück.
▪
Die Klemme liefert im Eingangsdatenwort (Byte 1 und Byte 2) den aktuellen Wert des Feature-Registers zurück.
V. Schreiben des Register 31 (Code-Wort zurücksetzen)
Ausgangsdaten
Byte 0: Control-Byte | Byte 1: DataOUT1, High-Byte | Byte 2: DataOUT1, Low-Byte
0xDF (1101 1111bin) | 0x00 | 0x00
Erläuterung:
▪
Bit 0.7 gesetzt bedeutet: Register-Kommunikation eingeschaltet.
▪
Bit 0.6 gesetzt bedeutet: schreiben des Registers.
▪
Bit 0.5 bis Bit 0.0 geben mit 01 1111bin die Registernummer 31 an.
▪
Das Ausgangsdatenwort (Byte 1 und Byte 2) enthält 0x0000 um den Schreibschutz wieder zu aktivieren.
Eingangsdaten (Antwort der Busklemmen)
Byte 0: Status-Byte | Byte 1: DataIN1, High-Byte | Byte 2: DataIN1, Low-Byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Erläuterung:
▪
Die Klemme liefert im Status-Byte als Quittung einen Wert zurück der sich nur in Bit 0.6 vom Wert des Control-Bytes unterscheidet.
▪
Das Eingangsdatenwort (Byte 1 und Byte 2) ist nach dem Schreibzugriff ohne Bedeutung. Eventuell noch angezeigte Werte sind nicht gültig!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Support und Service


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.