EPP2xxx - EtherCAT-P-Box-Module mit digitalen Ausgängen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
EtherCAT P® ist eine eingetragene Marke und patentierte Technologie, lizensiert durch die Beckhoff Automation GmbH & Co. KG, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
1.0.2
▪
Modulübersicht EPP2xxx aktualisiert
1.0.1
▪
EtherCAT-P-Anschluss aktualisiert
1.0.0
▪
Erste Veröffentlichung
0.5
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT-P-Box - Einführung
•
Modulübersicht EPP2xxx
•
EPP2008-000x
•
EPP2816-0008
•
EPP2308-000x, EPP2318-000x
•
EPP2316-000x
•
EPP2338-x00x


EtherCAT-P-Box - Einführung

Produktübersicht [image] EtherCAT-P-Box - Einführung
EtherCAT-P-Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-P-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-P-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-P-Netzwerk anschließbar. Durch einen Adapter kann eine EtherCAT-P-Box mit einer EtherCAT-Box verbunden werden, wobei Spannung extern eingespeist werden muss. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule und EtherCAT-Box-Module. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT‑P‑Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT‑P-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT P-Box-Module im EtherCAT-Netzwerk
EtherCAT-P-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT‑P-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT P- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT‑P‑ und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT‑P-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT-P-Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT-P-Box mit M12-Anschlüssen für Sensor/Aktoren
Hinweis
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
Hinweis
XML-Dateien
XML-Dateien (XML Device Description Files) zu EtherCAT‑P-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Modulübersicht EPP2xxx

Produktübersicht [image] Modulübersicht EPP2xxx
Modulübersicht EPP2xxx
Digitale Ausgangsmodule
Modul | Signalanschluss | Anzahl Ausgänge | Strom | Kommentar
EPP2008-0001 | 8 x M8 | 8 | 0,5 A (Σ 3 A) | Summe aller Ausgänge maximal 3 A
EPP2008-0002 | 4 x M12 | 8 | 0,5 A (Σ 3 A) | Summe aller Ausgänge maximal 3 A
EPP2816-0008 | 1 x D-Sub 25 | 16 | 0,5 A (Σ 3 A) | Summe aller Ausgänge maximal 3 A
Digitale Kombimodule
Modul | Signalanschluss | Anzahl Ausgänge | Strom | Anzahl Eingänge | Filter
EPP2308-0001 | 8 x M8 | 4 | 0,5 A | 4 | 3,0 ms
EPP2308-0002 | 4 x M12 | 4 | 0,5 A | 4 | 3,0 ms
EPP2316-0003 | 2 x ZS2001 | 8 | 0,5 A | 8 | 10 µs
EPP2316-0008 | 1 x D-Sub 25 | 8 | 0,5 A | 8 | 10 µs
EPP2318-0001 | 8 x M8 | 4 | 0,5 A | 4 | 10 µs
EPP2318-0002 | 4 x M12 | 4 | 0,5 A | 4 | 10 µs
EPP2338-0001 | 8 x M8 | 0 bis 8 | 0,5 A (Σ 4 A) | 8 bis 0 | 10 µs
EPP2338-0002 | 4 x M12 | 0 bis 8 | 0,5 A (Σ 4 A) | 8 bis 0 | 10 µs
EPP2338-1001 | 8 x M8 | 0 bis 8 | 0,5 A (Σ 4 A) | 8 bis 0 | 3,0 ms
EPP2338-1002 | 4 x M12 | 0 bis 8 | 0,5 A (Σ 4 A) | 8 bis 0 | 3,0 ms


EPP2008-000x

Produktübersicht [image] EPP2008-000x
EPP2008-000x
Weiterführende Informationen
•
EPP2008-000x - Einführung
•
EPP2008-000x - Technische Daten
•
EPP2008-000x - Prozessabbild


EPP2008-000x - Einführung

Produktübersicht [image] EPP2008-000x [image] EPP2008-000x - Einführung
EPP2008-000x - Einführung
EPP2008-0001
EPP2008-0002
EPP2008-000x | 8-Kanal-Digital-Ausgang 24 V DC, IMAX = 0,5 A
Die EtherCAT-P-Box EPP2008 mit digitalen Ausgängen schaltet binäre Steuersignale der Steuerung zur Prozessebene an die Aktoren weiter. Die acht Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über schraubbare M8- (EPP2008-0001) oder M12-Steckverbinder (EPP2008-0002). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Quick Links
Installation
Inbetriebnahme/Konfiguration


EPP2008-000x - Technische Daten

Produktübersicht [image] EPP2008-000x [image] EPP2008-000x - Technische Daten
EPP2008-000x - Technische Daten
Technische Daten | EPP2008-0001 | EPP2008-0002
Feldbus | EtherCAT
Businterface | Einspeisung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert Weiterleitung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert
Anzahl Ausgänge | 8
Anschluss Ausgänge | M8, schraubbar | M12, schraubbar
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Lastart | ohmsch induktiv, Lampenlast
Ausgangsstrom | max. 0,5 A je Kanal, Summenstrom aller Ausgänge max. 3 A
Kurzschlussstrom | typisch 1,5 A
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme der Modulelektronik | typisch 55 mA
Versorgung der Ausgangstreiber | aus der Lastspannung UP
Stromaufnahme der Ausgangstreiber | typisch 8 mA je Kanal
Prozessabbild | 8 Ausgangsbits
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE


EPP2008-000x - Prozessabbild

Produktübersicht [image] EPP2008-000x [image] EPP2008-000x - Prozessabbild
EPP2008-000x - Prozessabbild
Channel 1 bis Channel 8
Unter Channel 1 bis Channel 8 finden Sie die 8 digitalen Ausgänge des Moduls (hier als Beispiel das EPP2008-0001)
EPP2008-000x, Prozessabbild


EPP2816-0008

Produktübersicht [image] EPP2816-0008
EPP2816-0008
Weiterführende Informationen
•
EPP2816-0008 - Einführung
•
EPP2816-0008 - Technische Daten
•
EPP2816-0008 - Status-LEDs
•
EPP2816-0008 - Prozessabbild


EPP2816-0008 - Einführung

Produktübersicht [image] EPP2816-0008 [image] EPP2816-0008 - Einführung
EPP2816-0008 - Einführung
EPP2816-0008
EPP2816-0008 | 16-Kanal-Digital-Ausgang 24 V DC, IMAX = 0,5 A (∑ 3 A)
Die EtherCAT-P-Box EPP2816 mit digitalen Ausgängen schaltet binäre Steuersignale der Steuerung zur Prozessebene an die Aktoren weiter. Die sechzehn Ausgänge verarbeiten Lastströme bis jeweils 0,5 A, wobei der Gesamtstrom auf 3 A begrenzt ist. Damit eignen sich diese Baugruppen besonders für Anwendungen, bei denen nicht alle Ausgänge gleichzeitig aktiv sind oder bei denen nicht alle Aktoren Signalströme von 0,5 A benötigen. Ein Kurzschluss am Ausgang wird erkannt und an die Steuerungsebene weitergeleitet.
Der Signalzustand wird gruppenweise über Leuchtdioden angezeigt. Der Signalanschluss erfolgt über eine 25-polige D-Sub-Buchse (EPP2816-0008), somit eignet sich die EPP2816 optimal für Ventilinseln mit Multipol-Anschluss. Alle Ausgänge sind kurzschlussfest, verpolungsgeschützt und diagnosefähig.
Quick Links
Installation
Inbetriebnahme/Konfiguration


EPP2816-0008 - Technische Daten

Produktübersicht [image] EPP2816-0008 [image] EPP2816-0008 - Technische Daten
EPP2816-0008 - Technische Daten
Technische Daten | EPP2816-0008
Feldbus | EtherCAT
Businterface | Einspeisung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert Weiterleitung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert
Anzahl Ausgänge | 16
Anschluss Ausgänge | D-Sub-Buchse, 25-polig
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Lastart | ohmsch induktiv, Lampenlast
Ausgangsstrom | max. 0,5 A je Kanal, einzeln kurzschlussfest, Summenstrom aller Ausgänge max. 3 A
Kurzschlussstrom | typisch 1,5 A
Distributed-Clocks | ja
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme der Modulelektronik | typisch 65 mA
Versorgung der Ausgangstreiber | aus der Lastspannung UP
Stromaufnahme der Ausgangstreiber | max. 30 mA für alle Kanäle
Prozessabbild | 16 Ausgangsbits, 16 Eingangsbits (Diagnose)
Besondere Eigenschaften | ideal für Ventilinseln mit Multipol-Anschluss
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE


EPP2816-0008 - Status-LEDs

Produktübersicht [image] EPP2816-0008 [image] EPP2816-0008 - Status-LEDs
EPP2816-0008 - Status-LEDs
EPP2816-0008 - Status-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
STATUS 1-8 | leuchtet grün | mindestens ein Ausgang der Kanäle 1-8 ist gesetzt
 | leuchtet rot | mindestens ein Ausgang der Kanäle 1-8 hat einen Kurzschluss
STATUS 9-16 | leuchtet grün | mindestens ein Ausgang der Kanäle 9-16 ist gesetzt
 | leuchtet rot | mindestens ein Ausgang der Kanäle 9-16 hat einen Kurzschluss
US | aus | Versorgungsspannung US nicht vorhanden
 | leuchtet grün | Versorgungsspannung US vorhanden
UP | aus | Versorgungsspannung UP nicht vorhanden
 | leuchtet grün | Versorgungsspannung UP vorhanden


EPP2816-0008 - Prozessabbild

Produktübersicht [image] EPP2816-0008 [image] EPP2816-0008 - Prozessabbild
EPP2816-0008 - Prozessabbild
DIG DIAG Inputs Channel 1
Unter DIG DIAG Inputs Channel 1 finden Sie die Diagnose-Eingänge der ersten 8 digitalen Ausgänge des Moduls.
EPP2816-0008 DIG Diag Inputs
EPP2816-0008, DIG Diag Inputs Channel 1
Diag Input n
Zeigt einen Fehler an Ausgang n an.
DIG Diag Inputs Channel 2
Unter DIGDiag Inputs Channel 2 finden Sie die Diagnose-Eingänge der zweiten 8 digitalen Ausgänge des Moduls.
EPP2816-0008 DIG Diag Inputs Channel 2
EPP2816-0008, DIG Diag Inputs Channel 2
Diag Input n
Zeigt einen Fehler an Ausgang n an.
DIG Inputs Device
Unter DIGInputs Device finden Sie die Status-Eingänge des Moduls.
EPP2816-0008 DIG Inputs Device
EPP2816-0008, DIG Inputs Device
Safe state active
Zeigt an, ob der sichere Zustand angenommen wurde. Die Anzeige funktioniert nur wenn das Netzwerk Prozesseingangsdaten überträgt, also in den Netzwerkzuständen Pre-Operational (PRE-OP) und Operational (OP), nicht aber im Netzwerkzustand INIT.
Error channel X
Zeigt einen Fehler auf Kanal X an.
Sync Error
Siehe EtherCAT-Systemdokumentation. Die EtherCAT-Systemdokumentation steht Ihnen auf der Beckhoff Homepage unter Downloads zur Verfügung.
TxPDO Toggle
Siehe EtherCAT-Systemdokumentation.
DIG Outputs Channel 1
Unter DIGOutputs Channel 1 finden Sie die ersten 8 digitalen Ausgänge des Moduls.
EPP2816-0008 DIG Outputs Channel 1
EPP2816-0008, DIG Outputs Channel 1
DIG Outputs Channel 2
Unter DIGOutputs Channel 2 finden Sie die zweiten 8 digitalen Ausgänge des Moduls.
EPP2816-0008 DIG Outputs Channel 2
EPP2816-0008, DIG Outputs Channel 2
DIG Outputs Device
Unter DIG Outputs Device finden Sie die Control-Ausgänge des Moduls.
EPP2816-0008 DIG Outputs Device
EPP2816-0008, DIG Outputs Device
Set safe state
Setzt das Modul in den sicheren Zustand.
Reset outputs
Setzt die Fehlerbits „Error channel X“ des Moduls zurück. Die Ausgänge werden wieder aktiviert.


EPP2308-000x, EPP2318-000x

Produktübersicht [image] EPP2308-000x, EPP2318-000x
EPP2308-000x, EPP2318-000x
Weiterführende Informationen
•
EPP2308-000x, EPP2318-000x - Einführung
•
EPP2308-000x, EPP2318-000x - Technische Daten
•
EPP2308-000x, EPP2318-000x - Prozessabbild


EPP2308-000x, EPP2318-000x - Einführung

Produktübersicht [image] EPP2308-000x, EPP2318-000x [image] EPP2308-000x, EPP2318-000x - Einführung
EPP2308-000x, EPP2318-000x - Einführung
EPP23x8-0001
EPP23x8-0002
EPP2308-000x, EPP2318-000x | 4 x Digital-Eingang + 4 x Digital-Ausgang 24 V DC, IMAX = 0,5 A
Die EtherCAT-P-Box-Module EPP2308 und EPP2318 kombinieren vier digitale Eingänge und vier digitale Ausgänge auf einem Gerät.
Der Signalzustand wird jeweils über Leuchtdioden angezeigt. Der Anschluss der Signale erfolgt wahlweise über M8- (EPP2308-0001, EPP2318-0001) oder M12-Steckverbinder (EPP2308-0002, EPP2318-0002). Die Ausgänge verarbeiten Lastströme bis 0,5 A und sind kurzschlussfest sowie verpolungsgeschützt.
Quick Links
Installation
Inbetriebnahme/Konfiguration


EPP2308-000x, EPP2318-000x - Technische Daten

Produktübersicht [image] EPP2308-000x, EPP2318-000x [image] EPP2308-000x, EPP2318-000x - Technische Daten
EPP2308-000x, EPP2318-000x - Technische Daten
Technische Daten | EPP2308-0001 | EPP2308-0002 | EPP2318-0001 |  | EPP2318-0002
Feldbus | EtherCAT
Businterface | Einspeisung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert Weiterleitung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert
Anzahl Eingänge | 4
Anschluss Eingänge | M8, schraubbar | M12, schraubbar |  | M8, schraubbar |  | M12, schraubbar
Spezifikation | EN 61131-2, Typ 1/3
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Eingangsfilter | 3,0 ms | 3,0 ms |  | 10 µs |  | 10 µs
Signalspannung "0" | -3...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" | +11...+30 V (EN 61131-2, Typ 3)
Eingangsstrom | typisch 6 mA (EN 61131-2, Typ 3)
Sensorversorgung | aus Steuerspannung US, max. 0,5 A, gesamt kurzschlussfest
Anzahl Ausgänge | 4
Anschluss Ausgänge | M8, schraubbar | M12, schraubbar |  | M8, schraubbar |  | M12, schraubbar
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Ausgangsstrom | max. 0,5 A je Kanal
Kurzschlussstrom | maximal 1,5 A
Versorgung der Modulelektronik | aus der Steuerspannung US
Stromaufnahme der Modulelektronik | typisch 60 mA
Versorgung der Ausgangstreiber | aus der Lastspannung UP
Stromaufnahme der Ausgangstreiber | typisch 8 mA je Kanal
Prozessabbild | 4 Eingangsbits, 4 Ausgangsbits
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE


EPP2308-000x, EPP2318-000x - Prozessabbild

Produktübersicht [image] EPP2308-000x, EPP2318-000x [image] EPP2308-000x, EPP2318-000x - Prozessabbild
EPP2308-000x, EPP2318-000x - Prozessabbild
Digitale Eingänge
Unter Channel 1 bis Channel 4 finden Sie die 4 digitalen Eingänge des Moduls (als Beispiel das Prozessabbild der EPP2308-0002).
EPP23x8-000x, Prozessabbild digitale Eingänge
Digitale Ausgänge
Unter Channel 5 bis Channel 8 finden Sie die 4 digitalen Ausgänge des Moduls (als Beispiel das Prozessabbild der EPP2308-0002).
EPP23x8-000x, Prozessabbild digitale Ausgänge


EPP2316-000x

Produktübersicht [image] EPP2316-000x
EPP2316-000x
Weiterführende Informationen
•
EPP2316-000x - Einführung
•
EPP2316-000x - Technische Daten
•
EPP2316-0008 - Status-LEDs
•
EPP2316-000x - Prozessabbild


EPP2316-000x - Einführung

Produktübersicht [image] EPP2316-000x [image] EPP2316-000x - Einführung
EPP2316-000x - Einführung
EPP2316-0003
EPP2316-0008
EPP2316-000x | 8 x Digital-Eingang + 8 x Digital-Ausgang 24 V DC, IMAX = 0,5 A
Die EtherCAT-P-Box EPP2316 kombiniert acht digitale Eingänge und acht digitale Ausgänge auf einem Gerät. Die Eingänge stehen mit einer Filterkonstante von 10 μs zur Verfügung.
Die Ausgänge verarbeiten Lastströme bis 0,5 A und sind kurzschlussfest und verpolungsgeschützt.
Der Signalanschluss erfolgt bei der EPP2316-0008 über eine 25-polige D-Sub-Buchse. Der Signalanschluss erfolgt bei der EPP2316-0003 über zwei ZS2001-Steckverbinder mit Federkrafttechnik, optional erhältlich in ein- und dreipoliger Ausführung. Das Modul wird ohne Steckverbinder ausgeliefert.
Signalzustand und Status werden gruppenweise über Leuchtdioden angezeigt.
Quick Links
Installation
Inbetriebnahme/Konfiguration


EPP2316-000x - Technische Daten

Produktübersicht [image] EPP2316-000x [image] EPP2316-000x - Technische Daten
EPP2316-000x - Technische Daten
Technische Daten |  | EPP2316-0008 | EPP2316-0003
Feldbus |  | EtherCAT
Businterface |  | Einspeisung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert Weiterleitung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert
Anzahl Eingänge |  | 8
Anschluss Eingänge |  | D-Sub-Buchse, 25-polig (Pin 1…8) | ZS2001 Steckverbinder mit Federkrafttechnik
Spezifikation |  | EN 61131-2, Typ 1/3
Nennspannung Eingänge |  | 24 VDC (-15%/+20%)
Eingangsfilter |  | 10 µs
Signalspannung "0" |  | -3...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" |  | +11...+30 V (EN 61131-2, Typ 3)
Eingangsstrom |  | typisch 6 mA (EN 61131-2, Typ 3)
Sensorversorgung |  | aus Steuerspannung US, max. 0,5 A, gesamt kurzschlussfest
Anzahl Ausgänge |  | 8
Anschluss Ausgänge |  | D-Sub-Buchse, 25-polig (Pin 9…16) | ZS2001 Steckverbinder mit Federkrafttechnik
Lastart |  | ohmsch, induktiv, Lampenlast
Nennspannung Ausgänge |  | 24 VDC (-15%/+20%)
Ausgangsstrom |  | max. 0,5 A je Kanal, einzeln kurzschlussfest, Summenstrom aller Ausgänge max. 3 A
Kurzschlussstrom |  | maximal 1,5 A
Versorgung der Modulelektronik |  | aus der Steuerspannung US
Stromaufnahme der Modulelektronik |  | typisch 65 mA
Versorgung der Ausgangstreiber |  | aus der Lastspannung UP
Stromaufnahme der Ausgangstreiber |  | max. 30 mA für alle Kanäle
Prozessabbild | Prozessdaten | 8 Eingangsbits, 8 Ausgangsbits
 | Diagnose | 8 Diagnose-Eingangsbits
Zulässige Umgebungstemperatur im Betrieb |  | -25°C ... +60°C
Zulässige Umgebungstemperatur bei Lagerung |  | -40°C ... +85°C
Vibrations- / Schockfestigkeit |  | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung |  | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart |  | IP65, IP66, IP67 (gemäß EN 60529) | IP20
Einbaulage |  | beliebig
Zulassungen |  | CE


EPP2316-0008 - Status-LEDs

Produktübersicht [image] EPP2316-000x [image] EPP2316-0008 - Status-LEDs
EPP2316-0008 - Status-LEDs
EPP2316-0008 - Status-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
STATUS 1-8 | leuchtet grün | mindestens an einem Eingang der Kanäle 1-8 liegt ein Signal (24 V) an
STATUS 9-16 | leuchtet grün | mindestens ein Ausgang der Kanäle 9-16 ist gesetzt
 | leuchtet rot | mindestens ein Ausgang der Kanäle 9-16 hat einen Fehler
US | aus | Versorgungsspannung US nicht vorhanden
 | leuchtet grün | Versorgungsspannung US vorhanden
UP | aus | Versorgungsspannung UP nicht vorhanden
 | leuchtet grün | Versorgungsspannung UP vorhanden


EPP2316-000x - Prozessabbild

Produktübersicht [image] EPP2316-000x [image] EPP2316-000x - Prozessabbild
EPP2316-000x - Prozessabbild
Als Beispiel wird nachfolgend das Prozessabbild der EPP2316-0008 gezeigt.
DIG Inputs
Unter DIG Inputs finden Sie die 8 digitalen Eingänge des Moduls.
EPP2316-0008 DIG Inputs
EPP2316-0008, DIG Inputs
DIG Diag Inputs
Unter DIG Diag Inputs finden Sie die Diagnose-Eingänge der 8 digitalen Ausgänge des Moduls.
EPP2316-0008 DIG Diag Inputs
EPP2316-0008, DIG Diag Inputs
Diag Input n
Zeigt einen Fehler an Ausgang n an.
DIG Inputs Device
Unter DIG Inputs Device finden Sie die Status-Eingänge des Moduls.
EPP2316-0008 DIG Inputs Device
EPP2316-0008, DIG Inputs Device
Safe state active
Zeigt an, ob der sichere Zustand angenommen wurde. Die Anzeige funktioniert nur wenn das Netzwerk Prozesseingangsdaten überträgt, also in den Netzwerkzuständen Pre-Operational (PRE-OP) und Operational (OP), nicht aber im Netzwerkzustand INIT.
Error channel X
Zeigt einen Fehler auf Kanal X an.
Sync Error
Siehe EtherCAT-Systemdokumentation. Die EtherCAT-Systemdokumentation steht Ihnen auf der Beckhoff Homepage unter Downloads zur Verfügung.
TxPDO Toggle
Siehe EtherCAT-Systemdokumentation.
DIG Outputs
Unter DIG Outputs finden Sie die 8 digitalen Ausgänge des Moduls.
EPP2316-0008 DIG Outputs
EPP2316-0008, DIG Outputs
DIG Outputs Device
Unter DIG Outputs Device finden Sie die Control-Ausgänge des Moduls.
EPP2316-0008 DIG Outputs Device
EPP2316-0008, DIG Outputs Device
Set safe state
Setzt das Modul in den sicheren Zustand.
Reset outputs
Setzt die Fehlerbits „Error channel X“ des Moduls zurück. Die Ausgänge werden wieder aktiviert.


EPP2338-x00x

Produktübersicht [image] EPP2338-x00x
EPP2338-x00x
Weiterführende Informationen
•
EPP2338-x00x - Einführung
•
EPP2338-x00x - Technische Daten
•
EPP2338-x00x - Prozessabbild


EPP2338-x00x - Einführung

Produktübersicht [image] EPP2338-x00x [image] EPP2338-x00x - Einführung
EPP2338-x00x - Einführung
EPP2338-x001
EPP2338-x002
EPP2338-x00x | 8-Kanal-Digital-Ein- oder -Ausgang 24 V DC
Die EtherCAT-P-Box EPP2338 verfügt über acht digitale Kanäle die jeweils wahlweise als Ein- oder Ausgange betrieben werden können. Eine Konfiguration, ob ein Kanal als Eingang oder Ausgang verwendet werden soll ist nicht erforderlich; die Eingangsschaltung ist intern fest mit dem Ausgangstreiber verbunden, so dass ein gesetzter Ausgang automatisch im Eingangsprozessabbild angezeigt wird.
Die Ausgänge verarbeiten Lastströme bis 0,5 A und sind kurzschlussfest und verpolungsgeschützt.
Die Eingänge haben eine Filterkonstante von 10 μs (EPP2338-0001, EPP2338-0002) oder eine Filterkonstante von 3 ms (EPP2338-1001, EPP2338-1002).
Der Signalzustand wird jeweils über Leuchtdioden angezeigt. Der Anschluss der Signale erfolgt wahlweise über M8- (EPP2338-x001) oder M12-Steckverbinder (EPP2338-x002).
Hinweis
Versorgung der angeschlossenen Sensoren aus UP, nicht aus US
Die EtherCAT-P-Box EPP2338 versorgt digitale Sensoren im Gegensatz zu vielen anderen Modulen aus der Peripheriespannung UP und nicht aus der Steuerspannung US! Dies erfolgt, weil die Anschlüsse wahlweise als Ein- oder Ausgang genutzt werden können. Trotzdem wird eine Überlastung der Sensorversorgung (Strom > 0,5 A) auch hier durch rotes Leuchten der LED US angezeigt.
Quick Links
Installation
Inbetriebnahme/Konfiguration


EPP2338-x00x - Technische Daten

Produktübersicht [image] EPP2338-x00x [image] EPP2338-x00x - Technische Daten
EPP2338-x00x - Technische Daten
Technische Daten | EPP2338-0001 | EPP2338-0002 | EPP2338-1001 | EPP2338-1002
Feldbus | EtherCAT
Businterface | Einspeisung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert Weiterleitung: 1 x M8 Buchse, geschirmt, schraubbar, 4-polig, EtherCAT-P-kodiert
Anzahl Eingänge | 0 bis 8
Anschluss Eingänge | M8, schraubbar | M12, schraubbar | M8, schraubbar | M12, schraubbar
Spezifikation | EN 61131-2, Typ 1/3
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Eingangsfilter | 10 µs | 10 µs | 3,0 ms | 3,0 ms
Signalspannung "0" | -3...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" | +11...+30 V (EN 61131-2, Typ 3)
Eingangsstrom | typisch 6 mA (EN 61131-2, Typ 3)
Sensorversorgung | aus Peripheriespannung UP, max. 0,5 A, gesamt kurzschlussfest
Anzahl Ausgänge | 8 bis 0
Anschluss Ausgänge | M8, schraubbar | M12, schraubbar | M8, schraubbar | M12, schraubbar
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Ausgangsstrom | max. 0,5 A je Kanal, einzeln kurzschlussfest, Summenstrom aller Ausgänge max. 3 A
Kurzschlussstrom | maximal 1,5 A
Versorgung der Modulelektronik | aus der Steuerspannung US
Stromaufnahme der Modulelektronik | typisch 55 mA
Versorgung der Ausgangstreiber | aus der Lastspannung UP
Stromaufnahme der Ausgangstreiber | typisch 20 mA
Prozessabbild | 8 Eingangsbits, 8 Ausgangsbits
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE


EPP2338-x00x - Prozessabbild

Produktübersicht [image] EPP2338-x00x [image] EPP2338-x00x - Prozessabbild
EPP2338-x00x - Prozessabbild
Dig Inputs
Unter Channel 1 bis Channel 8 finden Sie die 8 digitalen Eingänge des Moduls. Nachfolgend als Beispiel das Prozessabbild der EPP2338-0001).
EPP2338-0001 Dig Inputs
EPP2338-0001, Dig Inputs
Dig Outputs
Unter Channel 1 bis Channel 8 finden Sie die 8 digitalen Ausgänge des Moduls. Nachfolgend als Beispiel das Prozessabbild der EPP2338-0001.
EPP2338-0001 Dig Outputs
EPP2338-0001, Dig Outputs


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Montage
•
EtherCAT P
•
EtherCAT-P-Versorgung
•
Verkabelung
•
UL-Anforderungen
•
ATEX-Hinweise


Montage

Montage und Verkabelung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsmomente für Steckverbinder


Abmessungen

Montage und Verkabelung [image] Montage [image] Abmessungen
Abmessungen
Abmessungen der EtherCAT P-Box-Module
Alle Maßangaben sind in Millimeter angegeben.
Achtung
FE-Kontakt im Gehäuse der EtherCAT P-Box
Im Gehäuse der EtherCAT-P-Box befindet sich oben rechts eine FE-Buchse (siehe nachfolgende Abbildung), um die EPP-Box mit dem Maschinenbett zu verbinden. Sollte die Maschine über keinen FE-Anschluss verfügen, ist die EtherCAT-P-Box niederimpedant mit einer alternativen Funktionserde zu verbinden.
FE-Buchse im Gehäuse1
FE-Buchse im Gehäuse der EtherCAT P-Box
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 125 g, je nach Modultyp


Befestigung

Montage und Verkabelung [image] Montage [image] Befestigung
Befestigung
Hinweis
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsmomente für Steckverbinder

Montage und Verkabelung [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EPP-Box mit M8 Steckverbindern
EtherCAT P-Box mit M8 Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EPP-Box mit M12 Steckverbindern
EtherCAT P-Box mit M8- und M12 Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Hinweis
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (siehe ZB8800, ZB8801-0000)!


EtherCAT P

Montage und Verkabelung [image] EtherCAT P
EtherCAT P
Weiterführende Informationen
•
EtherCAT P - Spannungs- und Signalversorgung
•
EtherCAT-P-LEDs


EtherCAT P - Spannungs- und Signalversorgung

Montage und Verkabelung [image] EtherCAT P [image] EtherCAT P - Spannungs- und Signalversorgung
EtherCAT P - Spannungs- und Signalversorgung
Für den ankommenden und weiterführenden EtherCAT-P-Anschluss verfügt die EtherCAT-P-Box (EPPxxxx) über zwei rot gekennzeichnete M8-Buchsen.
EtherCAT-P-Box: M8, 30 mm Gehäuse
Belegung
Als Kabel wird ein Industrie-CAT5-Kabel verwendet, an das ein EtherCAT-P-kodierter M8-Steckverbinder angeschlossen wird. Nachfolgend die Belegung der Beckhoff-EtherCAT-P-Kabel.
EtherCAT P |  |  |  | Steckverbinder | Aderfarben Kabel
Signal | Beschreibung | Spannung | Beschreibung | M8 | ZB7000, ZB7001
Tx + | Transmit Data+ | GNDS | GND für US | 1 | gelb1
Rx + | Receive Data+ | GNDP | GND für UP | 2 | weiß1
Rx - | Receive Data- | UP | Peripheriespannung für Aktoren | 3 | blau1
Tx - | Transmit Data- | US | System- und Sensorversorgung | 4 | orange1
Shield | Abschirmung | Shield | Abschirmung | Schirm | Schirm
*1) Aderfarben nach EN 61918
Hier finden Sie die EtherCAT-P-Kabel.


EtherCAT-P-LEDs

Montage und Verkabelung [image] EtherCAT P [image] EtherCAT-P-LEDs
EtherCAT-P-LEDs
EtherCAT-P-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-P-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-P-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-P-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-P-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-P-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-P-Modul
Run | aus | EtherCAT-P-Modul ist im Status Init
 | blinkt schnell | EtherCAT-P-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-P-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-P-Modul ist im Status Operational
Hinweis
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-P-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.


EtherCAT-P-Versorgung

Montage und Verkabelung [image] EtherCAT-P-Versorgung
EtherCAT-P-Versorgung
Weiterführende Informationen
•
EtherCAT-P-Anschluss
•
Status-LEDs für die Spannungsversorgung


EtherCAT-P-Anschluss

Montage und Verkabelung [image] EtherCAT-P-Versorgung [image] EtherCAT-P-Anschluss
EtherCAT-P-Anschluss
Achtung
Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT/EtherCAT-P-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
Die Einspeisung und Weiterleitung von EtherCAT P erfolgt über zwei EtherCAT-P-kodierte M8-Steckverbinder am oberen Ende der Module:
▪
IN: linker M8-Steckverbinder in EtherCAT-P-kodierung zur Einspeisung von EtherCAT P
▪
OUT: rechter M8-Steckverbinder in EtherCAT-P-kodierung zur Weiterleitung von EtherCAT P
EtherCAT P Anschluss und Weiterleitung
EtherCAT-P-Box, Anschlüsse für EtherCAT P
Pinbelegung M8, EtherCAT P In und EtherCAT P Out
Kontaktbelegung
Kontakt | Signal | Spannung
1 | Tx + | GNDs
2 | Rx + | GNDp
3 | Rx - | Peripheriespannung UP, +24 VDC
4 | Tx - | Steuerspannung US, +24 VDC
Gehäuse | Schirm | Schirmung
Die Kontakte der EtherCAT-P-kodierten M8-Steckverbinder tragen einen maximalen Strom von 3 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Steuerspannung US 24 VDC
Aus der 24 VDC Steuerspannung US werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt.
Peripheriespannung UP 24 VDC
Die Peripheriespannung UP versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Achtung
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung von EtherCAT P, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 3 A nicht überschritten wird!
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDS) und Peripheriespannung (GNDP) galvanisch voneinander getrennt!
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDS) und Peripheriespannung (GNDP) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus UP versorgt - damit kann z.B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an UP angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).


Status-LEDs für die Spannungsversorgung

Montage und Verkabelung [image] EtherCAT-P-Versorgung [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Spannungs LEDs EPP-Box
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
US (Steuerspannung) | aus | Versorgungsspannung US nicht vorhanden
 | leuchtet grün | Versorgungsspannung US vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung US erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
UP (Peripheriespannung) | aus | Versorgungsspannung UP nicht vorhanden
 | leuchtet grün | Versorgungsspannung UP vorhanden


Verkabelung

Montage und Verkabelung [image] Verkabelung
Verkabelung
Eine Auflistung der EtherCAT-P-Kabel, EtherCAT-Kabel, Powerkabel, Sensorkabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: http://download.beckhoff.com/download/document/catalog/main_catalog/german/Beckhoff_EtherCAT-Box-Zubehoer.pdf
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link: http://beckhoff.de/german/fieldbus_box/data_sheets.htm?id=69033899254355
EtherCAT-P-Kabel
Für die Verbindung von EtherCAT P stehen konfektionierte M8-Kabel in verschiedenen Längen und den Varianten: Stecker – offenes Ende, Stecker – Stecker oder Stecker – Buchse zur Verfügung.
Verkabelung EtherCAT P M8
EtherCAT-P-Kabel: ZK700x-0100-0xxx, ZK700x-0101-0xxx und ZK700x-0102-0xxx
Verwenden Sie zur Verbindung von EtherCAT-P-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
Hinweis
Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.beckhoff.de zum Download zur Verfügung steht.
Feldkonfektionierbare Steckverbinder für EtherCAT P
Für EtherCAT P stehen feldkonfektionierbare M8-Steckverbinder als Stecker (ZS7000) und als Buchse (ZS7001) zur Verfügung.
feldkonfektionierbare Steckverbinder EtherCAT P
EtherCAT P: Feldkonfektionierbare Steckverbinder
Sensorkabel
Sensorkabel - Beckhoff.png
Auswahl verschiedener Sensorkabel von Beckhoff


UL-Anforderungen

Montage und Verkabelung [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module / EtherCAT‑P‑Box‑Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
VORSICHT
VORSICHT!
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module / EtherCAT‑P‑Box‑Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module / EtherCAT‑P‑Box‑Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module / EtherCAT‑P‑Box‑Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module / EtherCAT‑P‑Box‑Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


ATEX-Hinweise

Montage und Verkabelung [image] ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000-0000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

Montage und Verkabelung [image] ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen / EtherCAT‑P‑Box‑Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit dem Schutzgehäuse BG2000-0000 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen / EtherCAT‑P‑Box‑Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT‑Box‑Module / EtherCAT‑P‑Box‑Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT‑Box‑Module / EtherCAT‑P‑Box‑Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000-0000 - Schutzgehäuse für EtherCAT Box

Montage und Verkabelung [image] ATEX-Hinweise [image] BG2000-0000 - Schutzgehäuse für EtherCAT Box
BG2000-0000 - Schutzgehäuse für EtherCAT Box
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
Das Schutzgehäuse BG2000-0000 wird über eine einzelne EtherCAT Box montiert, um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen.
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses BG2000-0000.
BG2000-0000, Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000-0000, Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuses BG2000-0000 über der EtherCAT Box.
BG2000-0000, Schutzgehäuse montieren


ATEX-Dokumentation

Montage und Verkabelung [image] ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweis
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) oder EtherCAT‑P‑Box‑Modulen (EPPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) und EtherCAT‑P‑Box‑Modulen (EPPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Signalanschluss

Signalanschluss
Signalanschluss
Weiterführende Informationen
•
Digitale Ausgänge M8 und M12
•
Digitale Ausgänge D-Sub 25, 16 Kanäle
•
Digitale Ein-/Ausgänge M8 und M12
•
Digitale Eingänge M8 und M12
•
Digitale Ein- und Ausgänge D-Sub 25
•
Digitale Ein- und Ausgänge ZS2001, 8 Kanäle


Digitale Ausgänge M8 und M12

Signalanschluss [image] Digitale Ausgänge M8 und M12
Digitale Ausgänge M8 und M12
Die digitalen Ausgangsmodule schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktoren weiter.
Der Signalanschluss erfolgt über M8-Steckverbinder (EPP2xxx-0001) oder M12-Steckverbinder (EPP2xxx-0002).
Digitale Ausgänge M8 und M12
Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Leuchtdioden zeigen den Signalzustand der Ausgänge an.


Digitale Ausgänge D-Sub 25, 16 Kanäle

Signalanschluss [image] Digitale Ausgänge D-Sub 25, 16 Kanäle
Digitale Ausgänge D-Sub 25, 16 Kanäle
Die digitalen Ausgangsmodule EPP2816 schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktoren weiter.
Die 16 Ausgänge liefern Lastströme bis 0,5 A, wobei der Gesamtstrom aller Ausgänge 4 A nicht überschreiten darf.
Der Signalanschluss erfolgt über eine 25-polige D-Sub-Buchse.
Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Digitale Ausgänge D-Sub 25, 16 Ausgänge


Digitale Ein-/Ausgänge M8 und M12

Signalanschluss [image] Digitale Ein-/Ausgänge M8 und M12
Digitale Ein-/Ausgänge M8 und M12
Die EPP2338-x00x verfügen über digitale Kanäle die wahlweise als Ein- oder Ausgänge betrieben werden können.
Werden die Kanäle als digitaler Eingang betrieben, erfassen die Module die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Die Sensoren werden aus der Lastspannung UP versorgt.
Werden die Kanäle als digitaler Ausgang betrieben, schalten die Module die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktoren weiter. Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Der Signalanschluss erfolgt über M8-Steckverbinder (EPPxxxx-xxx1) oder M12-Steckverbinder (EPPxxxx-xxxx2).
Digitale Ein-/Ausgänge M8
Digitale Ein-/Ausgänge M12
Leuchtdioden zeigen den Signalzustand der Eingänge/Ausgänge an.


Digitale Eingänge M8 und M12

Signalanschluss [image] Digitale Eingänge M8 und M12
Digitale Eingänge M8 und M12
Die digitalen Eingangsmodule erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät.
Der Signalanschluss erfolgt über M8-Steckverbinder (EPPxxxx-0001) oder M12-Steckverbinder (EPPxxxx-0002).
Digitale Eingänge M8 und M12
Die Sensoren werden aus der Steuerspannung US mit einem gemeinsamen, maximalen Strom von 0,5 A versorgt.
Leuchtdioden zeigen den Signalzustand der Eingänge an.


Digitale Ein- und Ausgänge D-Sub 25

Signalanschluss [image] Digitale Ein- und Ausgänge D-Sub 25
Digitale Ein- und Ausgänge D-Sub 25
Das digitale Kombimodul EPP2316-008
▪
schaltet die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktoren weiter.
▪
erfasst die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät und
Die 8 Ausgänge liefern Lastströme bis 0,5 A, wobei der Gesamtstrom aller Ausgänge 4 A nicht überschreiten darf. Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Die Sensoren werden aus der Steuerspannung Us versorgt.
Digitale Ein- und Ausgänge D-Sub 25


Digitale Ein- und Ausgänge ZS2001, 8 Kanäle

Signalanschluss [image] Digitale Ein- und Ausgänge ZS2001, 8 Kanäle
Digitale Ein- und Ausgänge ZS2001, 8 Kanäle
Die digitalen Ausgänge schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktoren weiter. Die 8 Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an. Der Signalanschluss erfolgt wahlweise über verschiedene ZS2001-Steckverbinder. Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Die digitalen Eingänge erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt wahlweise über verschiedene ZS2001-Steckverbinder.
Die Sensoren werden aus der Steuerspannung US versorgt. Die Lastspannung UP, wird für die Ausgangstreiber benötigt. Falls UP und US weitergeführt werden, darf der maximale Strom 4 A nicht überschreiten.
Eingänge
Digitale Eingänge ZS2001, 8 Kanäle
Die Grafik zeigt den Anschluss von 8 Sensoren in Einleitertechnik sowie von jeweils einem Sensor in Zwei- und Dreileitertechnik.
Bitte beachten Sie für Steckverbinder ZS2001-0004: zwei Brücken (24 V und 0 V) sind erforderlich um die Klemmstellen für Zwei- und Dreileiteranschlusstechnik zu versorgen.
Ausgänge
Digitale Ausgänge ZS2001, 8 Kanäle
Die Grafik zeigt den Anschluss von 8 Aktoren in Einleitertechnik sowie von jeweils einem Aktor in Zwei- und Dreileitertechnik.
Bitte beachten Sie für Steckverbinder ZS2001-0004: zwei Brücken (24 V und 0 V) sind erforderlich um die Klemmstellen für Zwei- und Dreileiteranschlusstechnik zu versorgen.
Weiterführende Informationen
•
Bestellangaben für KM-Steckverbinder
•
Technische Daten der KM-Steckverbinder


Bestellangaben für KM-Steckverbinder

Signalanschluss [image] Digitale Ein- und Ausgänge ZS2001, 8 Kanäle [image] Bestellangaben für KM-Steckverbinder
Bestellangaben für KM-Steckverbinder
ZS2001-0001, ZS2001-0002: KM-Steckverbinder für Einleiteranschlusstechnik
ZS2001-0004: KM-Steckverbinder für Dreileiteranschlusstechnik
Bestellbezeichnung | Signal LEDs | Anschlusstechnik
 |  | Einleiter | Zweileiter | Dreileiter
ZS2001-0001 | nein | ja | nein | nein
ZS2001-0002 | ja | ja | nein | nein
ZS2001-0004 | ja | ja | ja | ja


Technische Daten der KM-Steckverbinder

Signalanschluss [image] Digitale Ein- und Ausgänge ZS2001, 8 Kanäle [image] Technische Daten der KM-Steckverbinder
Technische Daten der KM-Steckverbinder
Technische Daten | ZS2001-0001 | ZS2001-0002 | ZS2001-0004
Anzahl der Klemmstellen | 10 | 10 | 30
Signal-LEDs | nein | ja | ja
Nennspannung | 50 VDC | 24 VDC | 24 VDC
Nennstrom | 2 A
Leitungsquerschnitt | 0,5 mm2 ... 1,5 mm2
Abisolierlänge | 8 mm
Abmessungen (B x H x T) | ca. 42mm x 10,3mm x 26,9mm | ca. 42mm x 12,7mm x 26,9mm | ca. 42mm x 20,8mm x 26,9mm
Gewicht | ca. 10 g | ca. 10 g | ca. 20 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Konfigurationserstellung TwinCAT - Manuell
•
Konfigurationserstellung TwinCAT - Online scan
•
Konfiguration mit TwinCAT
•
Wiederherstellen des Auslieferungszustandes


Konfigurationserstellung TwinCAT - Manuell

Inbetriebnahme/Konfiguration [image] Konfigurationserstellung TwinCAT - Manuell
Konfigurationserstellung TwinCAT - Manuell
In diesem Teil der Dokumentation wird die manuelle Konfiguration einer EtherCAT-Box/EtherCAT-P-Box in TwinCAT beschrieben.
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden (wie nachfolgend unter Konfigurationserstellung TwinCAT - Manuell beschrieben ist).
Ist die vorgesehene Steuerung bereits an das EtherCAT-System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT-/ EtherCAT-P-Master bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen. Dieser Test kann in den erweiterten Device-Einstellungen parametriert werden.
Damit die aktuellsten Features/Einstellungen des Masters genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Hinweis
Installation der neusten ESI-XML-Device-Description
Der TwinCAT Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT-/EtherCAT-P-Geräte bereitgehalten (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140). Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…)
Update EtherCAT Device Description 1439726603
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-/EtherCAT-P-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Appending a new I/O device
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Select the device (EtherCAT)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Appending a new box
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B. EPP1322-0001), bestätigen Sie mit OK.
Select a box
Auswahl einer Box (z.B. EPP1322-0001)


Konfigurationserstellung TwinCAT - Online scan

Inbetriebnahme/Konfiguration [image] Konfigurationserstellung TwinCAT - Online scan
Konfigurationserstellung TwinCAT - Online scan
In diesem Teil der Dokumentation wird die Konfiguration einer physisch vorhandenen EtherCAT-/EtherCAT-P-Box in TwinCAT beschrieben.
Online Konfigurationserstellung „Scannen“ (TwinCAT 3.x)
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden (wie unter Konfigurationserstellung TwinCAT - Manuell beschrieben ist). Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft die EtherCAT‑/EtherCAT‑P‑Box bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen. Damit die aktuellsten Features/Einstellungen der EtherCAT‑EtherCAT‑P‑Box genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Hinweis
Installation der neusten ESI-XML-Device-Description
Der TwinCAT Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT‑/EtherCAT‑P‑Geräte bereitgehalten (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140). Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…) Update EtherCAT Device Description 1439726603
Zur Konfigurationserstellung
▪
muss die reale EtherCAT‑/EtherCAT‑P‑ und IO-Link-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
die Geräte/Module müssen über EtherCAT‑/EtherCAT‑P‑Kabel oder IO-Link-Kabel so verbunden sein wie sie später eingesetzt werden sollen.
▪
die Geräte/Module müssen mit Energie versorgt werden und kommunikationsbereit sein.
▪
TwinCAT muss auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT‑/EtherCAT‑P‑Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT‑/EtherCAT‑P‑Teilnehmer. Dieser Schritt kann auch unabhängig vom vorherigen Schritt durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.
Erkennen/Scan des EtherCAT‑/EtherCAT‑P Geräts
Befindet sich das TwinCAT-System im Config-Modus (TwinCAT Icon blau bzw. blaue Anzeige im Systemmanager) kann online nach Geräten gesucht werden.
TwinCAT Anzeige Config-Modus
Hinweis
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich.
Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten. Das TwinCAT-Icon neben der Windows-Uhr stellt immer den TwinCAT-Modus des lokalen IPC dar. Im Systemmanager-Fenster wird dagegen der TwinCAT-Zustand des Zielsystems gezeigt.
TwinCAT target und local System
Im Konfigurationsbaum bringt Sie ein Rechtsklick auf den Punkt „I/O Devices“ zum Such-Dialog.
Scan Devices
Dieser Scan-Modus versucht nicht nur EtherCAT‑/EtherCAT‑P‑Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer Gerätescan
Hinweis automatischer Gerätescan
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT‑/EtherCAT‑P‑Gerät angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
erkannte Ethernet-Geräte
Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen (siehe nachfolgende Abbildung).
Erkennen/Scan der EtherCAT Teilnehmer
Hinweis
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Information des EtherCAT‑/EtherCAT‑P Devices aus dem Device-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan for Boxes
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT-/EtherCAT-P-Gerätes
Die Konfiguration wurde aufgebaut und direkt in den Online-Zustand (OPERATIONAL) versetzt. Das EtherCAT System sollte sich in einem funktionsfähigen zyklischen Betrieb, wie in der nachfolgenden Abbildung dargestellt, befinden.
beispielhafte Online-Anzeige
Zu beachten sind:
▪
Alle Boxen sollten im OP-State sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Wie in der nachfolgenden Abbildung sichtbar, wird die angeschlossene EtherCAT‑/EtherCAT‑P‑Box (hier: EPP1322-0001 und EPP1008-0002) im TwinCAT Baum angezeigt.
Master-Anzeige nach Scan for Boxes
Box-Anzeige nach „Scan for boxes“
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT‑/EtherCAT‑P‑Device für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der Systemmanager an, die im Gerät eventuell vorliegende ESI auszulesen.
▪
Teilnehmer werden nicht richtig erkannt
Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Device hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z.B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Scan über bestehender Konfiguration
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Configuration is identical
Identische Konfiguration
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Beispiel-Korrekturdialog
Es wird empfohlen das Häkchen „Extended Information“ zu setzen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe | Erläuterung
grün | dieses EtherCAT-/EtherCAT-P-Device findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau | dieses EtherCAT-/EtherCAT-P-Device ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich. Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau | dieses EtherCAT-/EtherCAT-P-Device wird ignoriert (Button "Ignore")
rot | dieses EtherCAT-/EtherCAT-P-Device ist auf der Gegenseite nicht vorhanden.
Hinweis
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Device/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT-EtherCAT‑P‑Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen oder EtherCAT-/EtherCAT‑P‑Boxen ist anzunehmen:
Geräte-Revision in der Anlage >= Geräte Revision in der Konfiguration
Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich). Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1019 oder höher (-1020, -1021) eingesetzt werden.
Wenn im TwinCAT-System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Beispiel-Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch „OK“ in die reale *.tsm-Konfiguration übernommen werden.


Konfiguration mit TwinCAT

Inbetriebnahme/Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT-P-Box die Sie konfigurieren möchten (in diesem Beispiel EPP3174-0002).
Baumzweig der zu konfigurierenden EtherCAT-P-Box
Baumzweig der zu konfigurierenden EtherCAT-P-Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT-P-Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-P-Geräts
Id | Laufende Nr. des EtherCAT-P-Geräts
Typ | Typ des EtherCAT-P-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-P-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-P-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-P-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-P-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-P-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-P-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-P-master die Adressen an die EtherCAT-P-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-P-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-P-Slaves. Diese Adresse wird vom EtherCAT-P-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-P-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-P-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-P-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-P-Geräts.
Karteireiter EtherCAT P
Ab TwinCAT 3 Build 4020 verfügt TwinCAT über das Tab „EtherCAT P“. Dieses Tab bietet ein Planungstool, um Spannungen, Ströme und Kabellängen des EtherCAT-P-Systems zu berechnen. Die nachfolgende Abbildung zeigt das Tab EtherCAT P wenn kein Device an dem Verteiler-Device angeschlossen ist (A).
No box at EP1322
Karteireiter EtherCAT P: Kein Device an Verteiler-Device angeschlossen
Sobald ein Device an dem Verteiler-Device angeschlossen ist (A), wird auch die Nummer/Buchstabe des Ports angezeigt (siehe nachfolgende Abbildung, B).
One box at EPP1322
Karteireiter EtherCAT P: Ein Device an Verteiler-Device angeschlossen
Sind drei Devices an den drei Ports des Verteiler-Devices angeschlossen (A), werden diese wie in der nachfolgenden Abbildung dargestellt, angezeigt (B).
EtherCAT P tab 3 boxes at 3 ports
Karteireiter EtherCAT P: Drei Devices am Verteiler-Device angeschlossen
Wie Sie sich die Topologie Ihres EtherCAT-P-Systems in TwinCAT anzeigen lassen können, wird hier beschrieben.
Port | Kennzeichnung der Ports mit Nummern/Buchstaben wie zuvor beschrieben
Wire Gauge | Auswahl der Aderquerschnittsfläche des Kabels welches verwendet werden soll AWG 22 = 0,34 mm² AWG 24 = 0,22 mm² AWG 26 = 0,14 mm²
Length (m) | Angabe der Kabellänge die verwendet werden soll
Check EtherCAT P System | Ist mindestens ein Device an der Steuerung angeschlossen, kann das angeschlossene EtherCAT-P-System geprüft werden.
Type | Auflistung der beiden Spannungen: Steuerspannung US, Lastspannung UP
Actual Voltage (V) | Die jeweilige Spannung mit der das System versorgt wird, kann manuell eingetragen werden. Die Default-Einstellung ist 24,00 V.
Min Voltage (V) | Die minimale Spannung wird durch das Device vorgegeben und in der ESI-Datei beschrieben. Nach dieser ist das EtherCAT-P-System auszulegen. Diese Spannung gilt es nicht zu unterschreiten.
Internal Load (A) | Der Strom den das Device verbraucht, wird aus der ESI-Datei der jeweiligen Box gelesen
Load (A) | Der Gesamtverbrauch der an den Schnittstellen angeschlossenen Sensoren/Aktoren kann hier angegeben werden, z.B. 100 mA.
Load Type | An dieser Stelle kann die Charakteristik der Last, welche an die Devices angeschlossen wird, ausgewählt werden. Welche der drei Auswahlmöglichkeiten (Sw Regulator, LDO, Resistor) auf Ihre Last zutrifft, müssen Sie dem zugehörigen Datenblatt entnehmen. Im Zweifelsfall wählen Sie bitte den Default-Wert „Sw Regulator“ aus. Sw Regulator: Schaltregler, verbrauchen mehr Energie und benötigen deshalb ein effizientes Netzteil LDO: Low-Drop-Spannungsregler, häufig ist der Energiebedarf klein und die Wärmeabfuhr stellt kein Problem dar Beispiel: Näherungssensor Resistor: elektronische, passive Bauteile Beispiel: Relais, Spule
Wenn Sie auf den Button „Check EtherCAT P System“ klicken, werden alle Devices die an Ihrem TwinCAT-Baum angefügt sind wie nachfolgend dargestellt aufgelistet.
Check EtherCAT P System 1
Check EtherCAT P System
Check US, Check UP | Auswahl, welche der beiden Spannungen überprüft werden soll.
Name | Bezeichnungen des im TwinCAT Baum angefügten Devices
Supply Voltage (V) | Spannung mit der die Boxen versorgt werden. Für Device 1 kann die Spannung manuell eingetragen werden.
Min Voltage (V) | Siehe Beschreibung oben
Input Resistance (Ω) | Eingangswiderstand, der über die Kabellänge und den Kabelquerschnitt berechnet wird.
Current (A) | Anzeige für den Strom
Load (A) | Siehe Beschreibung oben
Cable Length (m) | Die verwendete Kabellänge muss manuell eingegeben werden.
Wire Gauge | Siehe Beschreibung oben
Anwendungsbeispiel mit Problemfall und Problembehebung
In der nachfolgenden Abbildung weist die Planung des EtherCAT-P-Systems kein Problem auf. Alle Spannungen in der Spalte „Supply Voltage (V)“ sind grün hinterlegt.
Check EtherCAT P System Fehlerfall behoben
Check EtherCAT P System ohne Fehler
In der nachfolgenden Abbildung weist die Planung einen Fehler auf. Die „Supply Voltage (V)“ der Box 5 unterschreitet die „Min. Voltage (V)“. Das entsprechende Feld ist rot hinterlegt. Der Fehler tritt auf, da längere Kabel verwendet (einstellbar in Cable Length (m)) und zudem AWG 24 anstatt AWG 22 Kabel (einstellbar in Wire Gauge) verwendet werden.
Check EtherCAT P System Fehlerfall
Check EtherCAT P System Fehlerfall
Es bieten sich die folgenden drei Möglichkeiten das System anzupassen, damit kein Fehler auftritt:
Eine höhere Spannung einspeisen: Es sind max. 28.8 V möglich
Ein EtherCAT-P-Kabel mit einer größeren Aderquerschnittsfläche verwenden (AWG 22 anstatt AWG 24)
Spannung neu einspeisen
Topologie des EtherCAT-P-Systems
Sie können sich die Topologie Ihres EtherCAT-P-Systems, wie in der nachfolgenden Abbildung beschrieben, anschauen:
A: Im TwinCAT-Baum „Device1 (EtherCAT)“ anklicken
B: Karteireiter „EtherCAT“ anklicken
C: Button „Topology“ anklicken
D: Die Topologie Ihres EtherCAT-P-Systems wird angezeigt. Hier als Beispiel: Drei Devices sind an den drei Ports des Verteiler-Devices angeschlossen.
Topology 3 Boxes at 3 ports way
Topologie die EtherCAT-P-Systems
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-P-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-P-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Process data tab
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-P-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung des System-Managers als Variablen des EtherCAT-P-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Hinweis
Aktivierung der PDO-Zuordnung
•
der EtherCAT-P-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System-Manager die EtherCAT-P-Slaves neu laden (Schaltfläche Reload Devices)
PDO-Liste
Liste aller von diesem EtherCAT-P-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-P-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-P-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-P-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der während des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-P-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-P-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-P-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-P-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-P-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-P-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-P-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-P-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-P-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-P-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-P-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-P-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-P-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-P-Gerät lesen.


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den EPPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Hinweis
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Hinweis
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter www.beckhoff.de.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.