BC9191 - Raum-Controller für die Gebäudeautomatisierung

BECKHOFF Feldbuskomponenten

Start.jpg (207194 Byte)

Dokumentation für

BC9191-0000 und BC9191-0100

Raum-Controller für die Gebäudeautomatisierung

Version: 1.1.0
Datum: 21.01.2014


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


BC9191 - Ausgabestände der Dokumentation

BECKHOFF BC9191: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
1.1.0 | Kapitel BC9191 im Master-/Slave-Modus erweitert
1.0.0 | Erste Version

Firmware BC9191

Welche Firmware im Auslieferungszustand auf dem Buskoppler ist, erkennen Sie an dem Aufkleber unter dem Koppler.

Beispiel:
2713 SW:3.0 HW:4.1 0000
Die Firmware im Beispiel ist 3.0.

Firmware | Beschreibung
3.0 | Erste Firmwareversion ab Serienlieferung


Das Beckhoff Busklemmensystem

Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform

Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.

Dezentrale Verdrahtung der E/A-Ebene

Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.

Industrie-PCs als Steuerung

Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.

Buskoppler für alle gängigen Bussysteme

Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.

Montage auf genormten Tragschienen

Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 50022, 35 mm) und die direkte Verdrahtung von Akttoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.

Die geringe Baugröße und die große Flexibilität des Busklemme-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.

Modularität

Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.

Anzeige des Kanalzustands

Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.

K-Bus

Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.

Potential-Einspeiseklemmen für potentialgetrennte Gruppen

Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.

In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.

Buskoppler für verschiedene Feldbus-Systeme

Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.

Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.

Die Schnittstellen

Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


BC9191 - Einführung

BECKHOFF BC9191: Produktübersicht

Einführung

Der BC9191 ist ein Raum-Controller in kompakter Bauform mit dezentraler Intelligenz.

Die integrierten digitalen und analogen Anschlüsse decken bereits die typischen Standardfunktionalitäten der Raumtemperaturregelung ab.
Das K-Bus-Interface ermöglicht Erweiterungen aus dem gesamten Signalspektrum des Beckhoff Busklemmensystems.

Zwei Ethernet-Schnittstellen stehen zur Kommunikation mit einem übergeordneten Leitrechner oder anderen BC9191 zur Verfügung.

Weiterhin ist ein zusätzlicher Sub-Bus vorhanden:

Varianten des BC9191

Der BC9191 ist in zwei Varianten erhältlich. Dies unterscheiden sich durch den Subbus, dem Speicherausbau und der Zykluszeit.

  • Die Variante BC9191-0000 stellt einen CAN-Bus zum Anschluss des EnOcean-Transceiver KL6583 zur Verfügung.
  • Die Variante BC9191-0100 stellt eine RS485-Schnittstelle zur effizienten Anbindung von Raumbediengeräten zur Verfügung.
 | BC9191-0000 | BC9191-0100
SubBus | EnOcean KL6853 | RS485 / Modbus RTU / DMX
PLC-Speicher | 48 kByte | 128 kByte
Datenspeicher | 32 kByte | 128 kByte
PLC Zykluszeit (für 1.000 Befehle ohne I/O-Zyklus und K-Bus) | ca. 0,9 ms* | ca. 0,7 ms*
Quick-Links

Installation

Konfiguration


BC9191 - Technische Daten

BECKHOFF BC9191: Produktübersicht

Technische Daten

Busklemmen-Controller | BC9191-0000 | BC9191-0100
Anzahl der Busklemmen | 64
maximale Byteanzahl Feldbus | 512 Byte Eingang, 512 Byte Ausgang
Digitale Eingänge | 3, zum Anschluss potentialfreier Kontakte (z.B. für Fensterkontakt, Taupunktsensor, Präsenzsensor)
Digitale Ausgänge | 1 x LED-Ausgang (10 mA) 1 x 230 VAC, 10 A, Relais (z.B. für Lufterhitzer) 3 x 230 VAC, 1 A, Relais (z.B. für 3-Stufen-Ventilator) 2 x 230 VAC, 1 A, Triac (z.B. für Ventile für Heizung und Kühlung)
Analoge Eingänge | 3 x 0...10 V (z. B. für CO2-Sensor, Luftgütesensor, Helligkeitssensor) 1 x PT/Ni1000 (PT1000: -20…+60°C, NI1000: -15...+55°C) zur Lufttemperaturmessung 1 x Widerstandsmessung zur Sollwertvorgabe ( 0...10kOhm)
Analoge Ausgänge | 2 x 0…10 V (z. B. Luftvolumenstrom-Regler)
Sub-Bussysteme | 1 x K-Bus 1 x System-Bus für KL6583 (EnOcean) | 1 x K-Bus 1 x RS485 (z.B. Modbus-RTU/DMX)
Spannungsfestigkeit | 500 V (Versorgungsspannung/Feldbus)
Versorgungsspannung | 110 ... 240 VAC
Stromaufnahme | typisch 80 mA (an 230 V), max. 220 mA (an 85 V)
Verlustleistung | max. 15 W
K-Bus-Stromversorgung | max. 200 mA
Gewicht | ca. 350 g
Zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
Zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C
Zulässige relative Feuchte | max. 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Zulässige Einbaulage | senkrecht auf waagerecht an der Wand montierter Tragschiene (siehe Kapitel Einbaulage)
Schutzart | IP20
Zulassung | CE
SPS | BC9191-0000 | BC9191-0100
Programmierung/Konfiguration | mit TwinCAT über Ethernet (TwinCAT 2.11 Build 2034 oder höher, kein TC3)
Programmspeicher | 48 kByte | 128 kByte
Datenspeicher | 32 kByte | 128 kByte
Remanente Merker | 2 kByte | 2 kByte
SPS-Zykluszeit für 1.000 Befehle (ohne I/O-Zyklus, K-Bus) | ca. 0,9 ms | ca. 0,7 ms
Anzahl Laufzeitsysteme | 1
Programmiersprachen | IEC 6-1131-3 (AWL, KOP, FUP, ST, AS)
Online Change | ja
Feldbus | BC9191-0000 | BC9191-0100
Feldbus | Ethernet
Ethernet-Anschluss | 2 x RJ45 (interner Switch)
Auto-Crossing | ja
Übertragungsrate | 10/100 MBaud
Protokolle | Modbus-TCP/IP, Ethernet-TCP/IP, Beckhoff ADS über TCP und UDP
Übertragungsmedium | 4 x 2 Twisted-Pair Kupferkabel; Kategorie 3 (10 MBaud), Kategorie 5 (100 MBaud)
Länge zwischen Modulen | 100 m (Verteiler Hub bis BC9191) Linie: max. 100 m zwischen zwei BC9191
Topologie | - sternförmige Verkabelung - Linie (maximal 20 x BC9191 in einer Linie)
Anzahl der E/A-Module | nur durch IP-Adressraum begrenzt
Anzahl der E/A-Punkte | Abhängig von der übergeordneten Steuerung
Verbindungen | BC9191-0000 | BC9191-0100
Anzahl der ADS-Verbindungen über TCP/IP | 5
Anzahl der ADS-Verbindungen über UDP/IP | 1
Anzahl der ModbusTCP-Verbindungen | 3
SMTP (Simple Mail Transfer Protocol) | ja
SNTP (Simple Network Time Protocol) | ja
BootP/DHCP | ja/ja
UDP-Socket-Verbindungen | 3
TCP-Socket-Verbindungen | 3


BC9191 - Schnittstellen und Anschlüsse

BECKHOFF BC9191: Produktübersicht

Schnittstellen und Anschlüsse

Schnittstelle | Anzahl | Anwendungsbeispiele
Digitaler Eingang | 3 | Fensterkontakt, Taupunkt, Präsenzsensor
LED-Ausgang | 1 | LED Präsenzmeldung
Analoger Eingang, 0 …10 V | 3 | CO2 Sensor, Luftgütesensor, Helligkeitssensor
Widerstandsmessung | 1 | Sollwertvorgabe mit Potentiometer (z.B. Raumtemperaturvorgabe)
Eingang für PT/NI1000 | 1 | Lufttemperaturmessung (-20°C… +60°C)
Analoger Ausgang, 0…10 V | 2 | Luftvolumen-Stromregelung
Relaisausgang, 10 A | 1 | Lufterhitzer
Relaisausgang, 1 A | 3 | dreistufiger Ventilator
Triac-Ausgang, 1 A | 2 | Ventile für Heizung und Kühlung
Sub-Bus | 1 | BC9191-0000 | CAN-Bus | Anschluss eines Raumbediengeräts oder EnOcean-Moduls (KL6583)
 |  | BC9191-0100 | RS485 | z.B. Modbus-RTU


BC9191 - Abmessungen

BECKHOFF BC9191: Montage und Verdrahtung

Abmessungen


BC9191 - Einbaulage und Mindestabstände

BECKHOFF BC9191: Montage und Verdrahtung

Einbaulage und Mindestabstände

Achtung 		Montagevorgaben

Im eine optimale Funktion des BC9191 sicher zu stellen beachten Sie sie bei dessen Montage die Vorgaben bezüglich

  • Einbaulage
  • Mindestabstände
  • Umgebungstemperatur

Einbaulage

Montieren Sie die Tragschiene waagerecht, so dass die Anschlussflächen des aufgerasteten BC9191 nach vorne weisen (siehe Abbildung).
Der BC9191 wird dann von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektion ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.

Mindestabstände

Halten Sie bei der Montage die in der oben stehenden Abbildung angegebenen Mindestabstände zu anderen Komponenten und den Wänden des verwendeten Schaltschrank oder Klemmenkasten ein.

Umgebungstemperatur

Sorgen Sie für ausreichende Belüftung, so dass im verwendeten Schaltschrank oder Klemmenkasten der für den BC9191 zulässige Umgebungstemperaturbereich (siehe technische Daten) eingehalten wird !


Tragschienenmontage

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage

Montage

Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 50022) aufgerastet:

  1. Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
  2. Auf der rechten Seite des Feldbuskoppler werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
    Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.

Achten Sie bei der Montage der Busklemmen darauf, dass der Verriegelungsmechanismus der Klemmen nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät.

Demontage

Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:

  1. Ziehen Sie vorsichtig die orangefarbige Lasche ca. 1 cm aus der zu demontierenden Klemme heraus, bis die Lasche locker hervorsteht. Jetzt ist für diese Klemme die Verriegelung mit der Tragschiene gelöst und die Klemme kann ohne großen Kraftaufwand von der Tragschiene gezogen werden.
  2. Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen Sie die Klemme von der Tragschiene weg.

Verbindungen innerhalb eines Busklemmenblocks

Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:

  • Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
  • Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler.

Hinweis 		Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen.
Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.

PE-Powerkontakt

Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.

Achtung 		Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbraucher mit 230 V Nennspannung).

Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen

Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!

Verdrahtung

Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.

Hinweis 		Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden


Potentialgruppen, Isolationsprüfung und PE

Potentialgruppen

Die Beckhoff Busklemmenstationen verfügen in der Regel über drei verschiedene Potentialgruppen:

  • Die Feldbusschnittstelle ist (außer bei einzelnen Low Cost Kopplern) galvanisch getrennt und bildet die erste Potentialgruppe
  • Buskoppler- / Busklemmen-Controller-Logik, K-Bus und Klemmenlogik bilden eine zweite galvanisch getrennte Potentialgruppe
  • Die Ein- und Ausgänge werden über die Powerkontakte gespeist und bilden weitere Potentialgruppen.

Gruppen von E/A-Klemmen lassen sich durch Potentialeinspeiseklemmen oder Trennklemmen zu weiteren Potentialgruppen zusammenfassen.

Isolationsprüfung

Die Verbindung zwischen Buskoppler- / Busklemmen-Controller und Busklemmen wird durch das Zusammenstecken der Komponenten automatisch realisiert. Die Übertragung der Daten und die Versorgungsspannung der intelligenten Elektronik der Busklemmen übernimmt der K-Bus. Die Versorgung der Feldelektronik wird über die Powerkontakte durchgeführt. Die Powerkontakte stellen durch das Zusammenstecken eine Versorgungsschiene dar. Da einige Busklemmen (z.B. analoge Busklemmen oder digitale Vierkanal-Busklemmen) diese Powerkontakte nicht oder nicht vollständig durchschleifen, sind die Kontaktbelegungen der Busklemmen zu beachten.

Die Einspeiseklemmen unterbrechen die Powerkontakte und stellen den Anfang einer neuen Versorgungsschiene dar. Der Buskoppler- / Busklemmen-Controller kann auch zur Einspeisung der Powerkontakte eingesetzt werden.

PE-Powerkontakte

Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.

Es ist zu beachten, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann zu falschen Ergebnissen und auch zur Beschädigung der Klemme bei der Isolationsprüfung führen (z. B. Isolationsdurchschlag an einem 230V-Verbraucher zur PE-Leitung). Die PE-Zuleitung am Buskoppler- / Busklemmen-Controller muss zur Isolationsprüfung abgeklemmt werden. Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können die Einspeiseklemmen aus dem Verbund der übrigen Klemmen mindestens 10 mm herausgezogen werden. Die PE-Zuleitungen müssen in diesem Fall nicht abgeklemmt werden.

Der Powerkontakt PE darf nicht für andere Potentiale verwendet werden.


BK90x0, BK91x0, BC90x0, BC9191 - Ethernet-Topologien

BECKHOFF Feldbuskomponenten: Einbau und Verdrahtung

Ethernet-Topologien

BK9000, BK9050, BC9000, BC9020, BC9050

Diese Buskoppler und Busklemmen-Controller besitzen einen einfachen Ethernet-Anschluss. Dieser kann direkt an einen externen Switch angeschlossen werden. Somit ist er Aufbau der für Ethernet typischen Sterntopologie möglich.

BK9100, BC9100, BC9120, BC9191

Diese Buskoppler und Busklemmen-Controller besitzen einen internen Dreifach-Switch mit zwei externen und einem intern Port. Der interne Switch ermöglicht den einfachen Aufbau einer Linien-Topologie. Sie könne maximal 20 BK9100/BC91x0/BC9191 zu einer physikalischen Linie hintereinander schalten. Dabei darf die Distanz zwischen zwei Ethernet-Geräten maximal 100 m betragen. Die gesamte Länge der so aufgebauten Linie darf also 2 km betragen. In diese Linie dürfen keine weiteren Switche eingebaut werden.

Natürlich ist auch mit diesen Buskopplern und Busklemmen-Controllern der Aufbau einer klassischen Sterntopologie möglich.


BC9191 - Ethernet-Anschluss

BECKHOFF BC9191: Ethernet

Ethernet-Anschluss

Der Anschluss an den Ethernet-Bus erfolgt über einen RJ45-Stecker (Westernstecker).

BC9000_Connector.jpg (6645 Byte)

Belegung des RJ45-Steckers

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | - | reserviert
5 | - | reserviert
6 | RD - | Receive -
7 | - | reserviert
8 | - | reserviert

Direkte Verbindung zwischen PC mit Ethernet-Karte und BC9191

Um den PC direkt mit dem Busklemmen Controller zu verbinden, kann ein gekreuztes oder ein nicht gekreuztes Ethernet-Kabel genommen werden. Der interne Switch des BC9191 erkennt dies Automatisch.


BC9191-0000 - Klemmleiste X1

BECKHOFF BC9191-0000: Montage und Verdrahtung

BC9191-0000: Klemmleiste X1

Klemmstelle | Bezeichnung | Belegung | Kommentar
1 | DI 1 | Eingang für Schaltkontakt 1 | Für potentialfreien Kontakt z.B. Fensterkontakt
2 | GND | GND | GND für Schaltkontakt 1
3 | DI 2 | Eingang für Schaltkontakt 2 | Für potentialfreien Kontakt z.B. Taupunkt
4 | GND | GND | GND für Schaltkontakt 2
5 | DI 3 | Eingang für Schaltkontakt 3 | Für potentialfreien Kontakt z.B. Präsenztaster
6 | GND | GND | GND für Schaltkontakt 3 und LED
7 | DO1 | LED Ausgang | Ausgang für LED, z.B. Anzeige am Raumbediengerät
8 | PT1000 | Eingang PT/NI 1000 | Anschluss für PT/NI 1000
9 | GND | GND | GND für PT/NI 1000 und Sollwertsteller
10 | Poti | Potentiometer | Anschluss für Sollwertsteller (Poti 1KΩ …10kΩ)
11 | AI 1 | Analogeingang 1 | Analogeingang 0…10 V (auch als 24 V Digitaleingang nutzbar)
12 | AI 2 | Analogeingang 2 | Analogeingang 0…10 V (auch als 24 V Digitaleingang nutzbar)
13 | AI 3 | Analogeingang 3 | Analogeingang 0…10 V (auch als 24 V Digitaleingang nutzbar)
14 | GND | GND | 0 V Potential der Analog-Eingangssignale
15 | GND | GND | GND der Datenleitung für KL6583 (Schirm der Datenleitung sollte auf PE gelegt werden)
16 | +24V | +24V Gleichspannung | Max. 100 mA zur Versorgung von KL6583 (EnOcean) oder externem Bediengerät. Interne PolySwitch Sicherung, die nach Auslösen durch Ausschalten des BC9191 zurückgesetzt werden kann.
17 | CAN+ | CAN + | Datenleitung für KL6583 (enOcean)
18 | CAN+ | CAN -


BC9191-0100 - Klemmleiste X1

BECKHOFF BC9191-0100: Montage und Verdrahtung

BC9191-0100: Klemmleiste X1

Klemmstelle | Bezeichnung | Belegung | Kommentar
1 | DI 1 | Eingang für Schaltkontakt 1 | Für potentialfreien Kontakt z.B. Fensterkontakt
2 | GND | GND | GND für Schaltkontakt 1
3 | DI 2 | Eingang für Schaltkontakt 2 | Für potentialfreien Kontakt z.B. Taupunkt
4 | GND | GND | GND für Schaltkontakt 2
5 | DI 3 | Eingang für Schaltkontakt 3 | Für potentialfreien Kontakt z.B. Präsenztaster
6 | GND | GND | GND für Schaltkontakt 3 und LED
7 | DO1 | LED Ausgang | Ausgang für LED, z.B. Anzeige am Raumbediengerät
8 | PT1000 | Eingang PT/NI 1000 | Anschluss für PT/NI 1000
9 | GND | GND | GND für PT/NI 1000 und Sollwertsteller
10 | Poti | Potentiometer | Anschluss für Sollwertsteller (Poti 1KΩ …10kΩ)
11 | AI 1 | Analogeingang 1 | Analogeingang 0…10 V (auch als 24 V Digitaleingang nutzbar)
12 | AI 2 | Analogeingang 2 | Analogeingang 0…10 V (auch als 24 V Digitaleingang nutzbar)
13 | AI 3 | Analogeingang 3 | Analogeingang 0…10 V (auch als 24 V Digitaleingang nutzbar)
14 | GND | GND | 0 V Potential der Analog-Eingangssignale
15 | GND | GND | GND des RS485 (Schirm der Busleitung sollte auf PE gelegt werden)
16 | +24V | +24V Gleichspannung | Max. 100 mA zur Versorgung von 24V Verbrauchern. Absicherung über eine interne PolySwitch Sicherung, die nach Auslösen durch Ausschalten des BC9191 zurückgesetzt werden kann.
17 | RS485 | RS485/A | Datenleitung RS485, z.B. Modbus-RTU
18 | RS485 | RS485/B


BC9191 - Klemmleisten X2 und X3

BECKHOFF BC9191-0000, BC9191-0100: Montage und Verdrahtung

Klemmleiste X2 und X3

Klemmleiste X2

Klemmstelle | Bezeichnung | Belegung | Kommentar
20 | AO 1 | Analogausgang 1 | Analogausgang 0...10 V, z.B. Luftvolumenregelung
21 | GND | GND | GND für Analogausgänge
22 | AO 2 | Analogausgang 2 | Analogausgang 0...10 V, z.B. Luftvolumenregelung

Klemmleiste X3

Klemmstelle | Bezeichnung | Belegung | Kommentar
30 | 2 kW | K1 | Potentialfreies Relais, 230 V~, 10 A, z.B. für elektrische Zusatzheizung
31 | 2 kW | K2 | Potentialfreies Relais, 230 V~, 10 A, z.B. für elektrische Zusatzheizung
32 | FAN 1 | Fan speed 1 | Relaisausgang, 230V~ , z.B. Ventilatorgeschwindigkeit niedrig
33 | FAN 2 | Fan speed 2 | Relaisausgang, 230V~ , z.B. Ventilatorgeschwindigkeit mittel
34 | FAN 3 | Fan speed 3 | Relaisausgang, 230V~ , z.B. Ventilatorgeschwindigkeit hoch
35 | L | Phase | Einspeisung für Relais Fan speed 1 bis 3
36 | N | N-Leiter | Neutralleiter, z.B. für Ventilator
37 | Y1 | Triac-Ausgang 1 | Triac-Ausgang 1, 230V~ , max 1A, schaltet im Nulldurchgang, z.B. Ventil „Heizen“
38 | N | N | N-Leiter für Triac-Ausgang 1
39 | Y2 | Triac-Ausgang 2 | Triac-Ausgang 2, 230V~ , max 1A, schaltet im Nulldurchgang, z.B. Ventil „Kühlen“
40 | N | N | N-Leiter für Triac-Ausgang 2
41 | L1 | L1 | Stromversorgungsanschluss 230 V~
42 | N | N-Leiter | Stromversorgungsanschluss N
43 | FE | Funktionserde | Erdungsanschluss, kapazitiv mit GND verbunden


BC9191 - Anlaufverhalten

BECKHOFF BC9191: Parametrierung und Inbetriebnahme

Anlaufverhalten

Nach dem Einschalten prüft der BC9191 seinen Zustand, konfiguriert den K-Bus, erstellt anhand der gesteckten Busklemmen eine Aufbauliste und startet seine lokale SPS.

Beim Hochlauf des Busklemmen-Controllers leuchten und blinken die I/O-LEDs. Im Fehlerfreien Zustand sollte nach ca. 3-5 Sekunden keine I/O-LED mehr Blinken.
Im Fehlerfall hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose-LEDs).


BC9191 - Parametrierung über DIP-Schalter

BECKHOFF BC9191: Parametrierung und Inbetriebnahme

Parametrierung über DIP-Schalter

Die folgende Parametrierungen können Sie ohne Konfigurationssoftware mit Hilfe des DIP-Schalters und der Endklemme (KL9010) vornehmen.
Dieser Parametrierungsmode ist nur dann aktiv, wenn am BC9191 nur eine Endklemme (KL9010) gesteckt ist. Sonst gelten die normale Einstellungen.

Wiederherstellen der Hersteller-Einstellungen

  • Schalten Sie den BC9191 aus und stecken Sie nur die Endklemme (KL9010).
  • Stellen Sie die DIP-Schalter 1 bis 8 auf 255 (alle auf ON, 11111111bin), DIP-Schalter 9 und 10 auf 0 (alle auf OFF, 00bin) und schalten Sie den BC9191 wieder ein.
  • Nach erfolgreichem Einstellen der Default-Parameter leuchtet die LED Error und die LEDs I/O RUN und I/O ERR blinken abwechselnd.
  • Danach können Sie den BC9191 ausschalten um gegebenenfalls Busklemmen wieder anzureihen und wie gewohnt fortfahren.

Löschen des Bootprojektes (ab Firmware-Version 2.11)

  • Schalten Sie den BC9191 aus und stecken Sie nur die Endklemme (KL9010).
  • Stellen Sie die DIP-Schalter 1 bis 8 auf 254 (Schalter 2 bis 8 auf ON, Schalter 1 auf OFF, 11111110bin) und schalten Sie den BC9191 wieder ein.
  • Nach erfolgreichem Löschen des Bootprojektes blinken die LEDs I/O RUN und I/O ERR abwechselnd.
  • Danach können Sie den BC9191 ausschalten, um gegebenenfalls Busklemmen wieder anzureihen und wie gewohnt fortfahren.

Löschen der TC-Config (ab Firmware-Version 2.11)

  • Schalten Sie den BC9191 aus und stecken Sie nur die Endklemme (KL9010).
  • Stellen Sie die DIP-Schalter 1 bis 8 auf 253 (Schalter 3 bis 8 auf ON, Schalter 2 auf OFF, Schalter 1 auf ON, 11111101bin) und schalten Sie den BC9191 wieder ein.
  • Nach erfolgreichem Löschen der TC-Config blinken die LEDs I/O RUN und I/O ERR abwechselnd.
  • Danach müssen Sie den BC9191 ausschalten!
  • Sie können dabei gegebenenfalls Busklemmen wieder anreihen und wie gewohnt fortfahren.

Einstellung der Ethernet-Parameter

  • Schalten Sie den BC9191 aus und stecken Sie nur die Endklemme (KL9010).
  • Stellen Sie alle DIP-Schalter auf OFF und schalten Sie den BC9191 wieder ein.
  • Die LEDs I/O RUN und I/O ERR leuchten konstant.
  • Nehmen Sie nun anhand der folgenden Tabelle die gewünschte Einstellung vor.
DIP-Schalter | Parameter | Auswahl | Einstellung | Kommentar
1 | Baud-Rate | 10 MBaud | OFF (0)
100 MBaud | ON (1) | Default
2 | Auto-Baud-Rate | Disable | OFF (0)
Enable | ON (1) | Default
3 | Übertragungsart | Halbduplex | OFF (0)
Vollduplex | ON (1) | Default
  • Schalten Sie zur um Übernahme der Werte den DIP-Schalter 10 auf ON.
    Der BC9191 zeigt nun durch blinken der LEDs I/O RUN und I/O ERR, das er die Parameter übernommen hat.
  • Danach können Sie den BC9191 ausschalten, die Busklemmen anschließen und wie gewohnt fortfahren.


BC9191 - IP-Adresse

BECKHOFF Automation GmbH

IP-Adresse

In Vorbereitung


BC9191 - PT1000 / NI1000 / NI1000Tk5000 Analogeingang

BECKHOFF BC9191: Parametrierung und Inbetriebnahme

PT1000 / NI1000 / NI1000Tk5000 Analogeingang

An den Anschlüssen 8 und 9 der Klemmleiste X1 kann direkt ein Temperatursensor angeschlossen werden.

Die Art des Temperaturfühlers ist im Standard auf PT1000 eingestellt und kann über das Register R32 oder der KS2000 Software verändert werden.

Temperaturfühler | Messbereich | Ausgabe der Prozessdaten | Registereintrag (Bin / Hex)
PT1000 | -20°C bis + 60°C | in 1/10 Grad Schritte. -20°C = -200dez 0°C = 0dez +20°C = +200dez +40°C = +400dez +60°C = +600dez | 2# 0010 0000 0000 0000 16# 2000
NI1000 | -15°C bis +55°C |  | 2# 0101 0000 0000 0000 16# 5000
NI1000Tk5000 | -20°C bis +60°C |  | 2# 0111 0000 0000 0000 16# 7000
Widerstand (direkt) | 910 Ω bis 1.330 Ω | in 1/10 Ohm Schritte. 910 Ω = 9.100dez 1.000 Ω = 10.000dez 1.330 Ω = 13.300dez | 2# 1110 0000 0000 0000 16# E000


BC9191 - Potentiometereingang

BECKHOFF BC9191: Parametrierung und Inbetriebnahme

Potentiometereingang

An den Anschlüssen 9 und 10 der Klemmleiste X1 kann direkt ein Sollwertpoti für die Vorgabe der Raumtemperatur angeschlossen werden.

Es wird empfohlen, ein Potentiometer mit dem Nennwert 10 kΩ zu verwenden.

Die Veränderung des Widerstandswertes von 0 bis 10 kΩ wird in dem Prozesswert als 0 bis 10000 Schritten dargestellt.

Die Auflösung beträgt 10 Bit.


BC9191 - Analogeingänge (10 Volt)

BECKHOFF BC9191: Parametrierung und Inbetriebnahme

Analogeingänge (10 Volt)

An den Anschlüssen 11, 12 und 13 der Klemmleiste X1 stehen 3 Analogeingänge mit einer Auflösung von 10 Bit zur Verfügung.

Eingangsspannung | Prozesswert
0 V | 0dez
5 V | 16383dez
10 V | 32767dez


BC9191 - Analogausgänge (10 Volt)

BECKHOFF BC9191: Parametrierung und Inbetriebnahme

Analogausgänge (10 Volt)

An den Anschlüssen 20 und 22 der Klemmleiste X2 stehen 2 Analogausgänge mit einer Auflösung von 10 Bit zur Verfügung.
Anschluss 21 ist die gemeinsame Masse.

Prozesswert | Ausgangsspannung
0dez | 0 V
16383dez | 5 V
32767dez | 10 V


Konfigurations-Software KS2000

Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler/Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.

Projektierung

Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, d. h. vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.

Parametrierung

KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.

Inbetriebnahme

KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.

KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:

  • Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
  • Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.

Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


BC9191 - Konfigurations-Software KS2000

BECKHOFF Feldbuskomponenten: Konfigurations-Software KS2000

Konfigurations-Software KS2000

Die Konfigurations-Software KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung von Feldbuskopplern und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Feldbuskoppler/Feldbus Box und PC wird über ein serielles Konfigurationskabel oder über den Feldbus hergestellt.

Projektierung

Sie können mit der Konfigurations-Software KS2000 die Feldbusstationen offline projektieren, d. h. vor der Inbetriebnahme den Aufbau der Feldbusstation mit sämtlichen Einstellungen der Buskoppler und Busklemmen bzw. der Feldbus Box Module vorbereiten. Diese Konfiguration kann später in der Inbetriebnahmephase per Download an die Feldbusstation übertragen werden. Zur Dokumentation wird Ihnen der Aufbau der Feldbusstation, eine Stückliste der verwendeten Feldbus-Komponenten, eine Liste der von Ihnen geänderten Parameter etc. aufbereitet. Bereits existierende Feldbusstationen stehen nach einem Upload zur weiteren Bearbeitung zur Verfügung.

Parametrierung

KS2000 bietet auf einfache Art den Zugriff auf die Parameter einer Feldbusstation: Für sämtliche Buskoppler und alle intelligenten Busklemmen sowie Feldbus Box Module stehen spezifische Dialoge zur Verfügung, mit deren Hilfe die Einstellungen leicht modifiziert werden können. Alternativ haben Sie vollen Zugriff auf sämtliche internen Register. Die Bedeutung der Register entnehmen Sie bitte der Registerbeschreibung.

Inbetriebnahme

KS2000 erleichtert die Inbetriebnahme von Maschinenteilen bzw. deren Feldbusstationen: Projektierte Einstellungen können per Download auf die Feldbus-Module übertragen werden. Nach dem Login auf die Feldbusstation besteht die Möglichkeit, Einstellungen an Koppler, Klemmen und Feldbus Box Modulen direkt online vorzunehmen. Dazu stehen die gleichen Dialoge und der Registerzugriff wie in der Projektierungsphase zur Verfügung.

KS2000 bietet den Zugriff auf die Prozessabbilder von Buskoppler und Feldbus Box:

  • Sie können per Monitoring das Ein- und Ausgangsabbild beobachten.
  • Zur Inbetriebnahme der Ausgangsmodule können im Ausgangsprozessabbild Werte vorgegeben werden.

Sämtliche Möglichkeiten des Online-Modes können parallel zum eigentlichen Feldbus-Betrieb der Feldbusstation vorgenommen werden. Das Feldbus-Protokoll hat dabei natürlich stets die höhere Priorität.


BC9191 - Ventilatorsteuerung mit Raumtemperaturregelung

BECKHOFF BC9191: Programmierung

Ventilatorsteuerung mit Raumtemperaturregelung

Dreistufige Ventilatorsteuerung mit Raumtemperaturregelung (Heizen / Kühlen) für ein 4-Rohr-System.

Beispielprogramm zum Download als ZIP-Datei:

Anwendung

Mit der vorinstallierten Standard Klimatisierungsapplikation ist es möglich den höchsten Energieeffizienzstandard der EN15232 Klasse A zu erreichen. Die Standardapplikation beinhaltet die grundlegenden Raumklimafunktionen nach VDI 3813.

Die Applikation beinhaltet Grundfunktionsbausteine und Grundfunktionen wie:

  • eine lokale Temperaturmessung mit Glättungsfunktion und mit einem Kompensationswert,
  • eine lokale Sollwertverschiebung/Sollwertkorrektur
  • eine Skalierungsfunktion
  • eine Ansteuerung von stetigen Stellorganen
  • einen PI-Regler mit Eingabe über das Proportionalband
  • Präsenzerkennung und Präsenzmeldung
  • Fensterüberwachung
  • lokale Übersteuerung der Ventilatorstufen möglich
  • Lastoptimierung möglich

Des Weiteren sind Raumklimafunktionen implementiert wie:

  • Energieniveauwahl
  • Funktionswahl
  • Sollwertermittlungsbaustein für die verschiedenen Energieniveaus
  • 3-stufige Ventilatorsteuerung (FanCoil)
Hinweise
  • Die vorinstallierte Standard Klimatisierungsapplikation ist als eine Defaultkonfiguration abgebildet, d.h. der TwinCAT SystemManager wird nicht benötigt zur Verknüpfung der SPS-Variablen mit der I/O-Ebene.
  • Per ADS oder Modbus TCP kann auf die IndexGroup16#4020 und 16#4021 lesend wie schreibend von einer übergeordneten Steuerung z.B. GLT oder Etagencontroller zugegriffen werden. Dies ist in der Applikation berücksichtigt.
  • Parameter von Einzelnen Unterprogramme werden Spannungsausfallsicher gesichert. Siehe auch PersistentDataGlobalState.

Main_1(Hauptprogramm)

Im Hauptprogramm der Standard Applikation werden alle Unterprogramme aufgerufen. Die Verbindungen und Kommunikation der Programmblöcke untereinander sind in dem Hauptprogramm durch die Verbindungslinien gegeben. So sind alle Programmblöcke in einem funktionalen Zusammenhang zu sehen.

Verbindung von Block 0 zu Block 1

Das Unterprogramm Energieniveau Auswahl_ Sollwertgenerierung_Funktionsauswahl (EL_SP_FS) überträgt die Information des Energieniveaus, die Sollwertwerte der vier Energieniveaus für den Heizbetrieb und Kühlbetrieb, die Regelfunktion (Heizen/Kühlen/AUS) und die aktuelle Raumtemperatur (zu den Blöcken 2 und 4).

Verbindung von Block 1 zu Block 2

Der FB_BC9191Room gibt die Kühlfunktion frei mit dem gültigen/errechneten Energieniveausollwert.

Verbindung von Block 1 zu Block 4

Der FB_BC9191Room gibt die Heizfunktion frei mit dem gültigen/errechneten Energieniveausollwert.

Verbindung von Block 1 zu Block 6

Wenn Heizfunktion oder Kühlfunktion aktiviert sind, geben diese den Fan-Coil frei an Block 7.

Verbindung von Block 2 zu Block 3

Der Regler für Kühlen überträgt seine Stellgröße (0..100%) an das Regelventil. Diese Stellgröße wird auf das Ausgangssignal mit dem Wertebereich 0..32767 skaliert; Block 3.

Verbindung von Block 4 zu Block 5

Der Regler für Heizen überträgt seine Stellgröße (0..100%) an das Regelventil. Diese Stellgröße wird auf das Ausgangssignal mit dem Wertebereich 0..32767 skaliert; Block 5.

Block 7

3-stufiger Fan Coil, der in Abhängigkeit vom Stellsignal des Reglers die Stufen automatisch schaltet.

Anlagenschema

Datenpunktliste

DP | Name | Typ | Programmblock / Funktionsbausteine | Variable | Merkmal | Klemmleiste
Y01 | Heizventil | AA | PI_Heating / fbBC9191AO_0_10V_Heating | stOutData.KL4001_02_AO2_X2_22_21_DataOut | bindend | X2 Kontakt X2:22; X2:21
Y02 | Kühlventil | AA | PI_Cooling / fbBC9191AO_0_10V_Cooling | stOutData.KL4001_01_AO1_X2_20_21_DataOut | bindend | X2 Kontakt X2:20; X2:21
Q1 | 3-stufiger FanCoil | DA | FanCoil | stOutData.KL9191_DO_DataOut.2 stOutData.KL9191_DO_DataOut.3 stOutData.KL9191_DO_DataOut.4 | bindend bindend bindend | X3 Kontakt X3:32; X3:35 Kontakt X3:33; X3:35 Kontakt X3:34; X3:35
D01 | Fensterkontakt | DE | EnergyLevel | stInData.KL9191_DI_DataIn.0 | bindend | X1 Kontakt X1:1; X1:2
D03 | Präsenzmelder | DE | EnergyLevel | stInData.KL9191_DI_DataIn.2 | bindend | X1 Kontakt X1:5; X1:6
B01 | Raumtemperatur | AE PT /NI 1000 NI1000Tk5000 | EL_SP_FS / fbBC9191TemperatureSensor | stInData.KL3201_AI_RTD_X1_8_9_DataIn stInData.KL3201_AI_RTD_X1_8_9_State | bindend bindend | X1 Kontakt X1:8; X1:9 Kontakt X1:8; X1:9
R01 | lokaler Sollwertsteller | AE 0 - 10.000 Ω | EL_SP_FS / fbBC9191Poti / F_BC9191Scale | stInData.KL3061_01_AI_Poti_X1_10_9_DataIn stInData.KL3061_01_AI_Poti_X1_10_9_State | bindend bindend | X1 Kontakt X1:10; X1:9 Kontakt X1:10; X1:9
Legende

AE: Analogeingang
AA: Analogausgang
DE: Digitaleingang
DA: Digitalausgang


BC9191 - Interne Funktionsbausteine und Unterprogramme

BECKHOFF BC9191: Programmierung

Interne Funktionsbausteine und Unterprogramme

FB_BC9191TemperatureSensor

Der Funktionsbaustein erfasst und verarbeitet den Temperaturwert. Über die Eingangsvariable iRawValue wird der Temperaturrohwert in 1/10 ºC dem Funktionsbaustein übergeben und über den rPresentValue als Fießkommazahl ausgegeben.
Über die Eingangsvariable usiStateRawValue wird der Status des angeschlossenen Temperatursensors überwacht und im Falle eines Kabelbruchs oder eines Kurzschlusses über die Variablen bErrTempSensor und udiErrId der Steuerung zurück gemeldet. Sollte ein Fehlerfall vorliegen wird der letzte gültige Wert als aktueller Wert für die Temperaturregelung verwendet.

Die Temperaturmessung kann über die ADD-Funktion mit einem Temperaturabgleich angepasst werden.

Der Temperaturwert wird dann an die Unterprogramme FctSelection, PI_Cooling, PI_Heating und FanCoil übergeben.

FB_BC9191Poti und F_BC9191Scale

Der Funktionsbaustein erfasst einen Widerstandswert (0..10kΩ), hier als Beispiel ist ein Drehpotentiometer angeschlossen mit einem Wert von 4,7kΩ. Über die Eingangsvariable iRawValue wird der gemessene Rohwert 1:1 über rPresentValue ausgegeben. Dieser Wert wird dann an die Funktion F_BC9191Scale übergeben, der dann auf einen Bereich von +/- 3K skaliert wird.
Über die Eingangsvariable usiStateRawValue wird der Status des angeschlossenen Widerstandswertes überwacht. Eine Überschreitung des Nennbereiches wird über die Variablen bErrTempSensor und udiErrId der Steuerung zurück gemeldet. Sollte ein Fehlerfall vorliegen wird der letzte gültige Wert verwendet.

Der skalierte Wert (Sollwertberschiebung/Sollwertkorrektur) wird an das SetpointRoom Unterprogramm übergeben.

EnergyLevel (PRG)

Das Energienieveau wird aus der Auswertung der Information Präsenz und Fensterkontakt dezentral ausgewählt. Die Grundapplikation ist so konzipiert worden, dass die Möglichkeit besteht zentral per ADS-Kommunikation, z.B. von einem Etagencontroller aus, Zeitschaltfunktionen für die Energieniveaus Protection, Economy und PreComfort einzubinden. Wie das genau gemacht wird, ist unter ADS-Kommunikation dokumentiert.

Das Energieniveauwahl Programm muss über die Eingangsvariable _bEnable freigegeben sein, andernfalls wird das Energieniveau Protection ausgewählt. Die Eingangsvariable _bWindow an dem der Digitalkontakt_1 (X1:1; X1:2) angeschlossen ist, schaltet das Energieniveau Protection aktiv, wenn der Digitalkontakt TRUE ist.

Die Eingangsvariable _bComfort an dem der Digitalkontakt_3 (X1:5; X1:6) angeschlossen ist, schaltet das Energieniveau Comfort aktiv, wenn der Digitalkontakt TRUE ist.

Der Enumerator _eEnergyLevel ist mit einer Instanz von dem FB_BC9191Room verbunden.

Der Voreinstellwert für den internen Parameter _eCtrlMode vom Typ E_BC9191EnergyLevel ist auf _eCtrlMode:= eEnergyLevel_AUTO_II := 5 gesetzt. (* an presence detection in this mode switches from energy level protection OR economy OR precomfort directly to energy level comfort *) In dem EnergyLevel - Programm ist eine Instanz von dem FB_BC9191EnergyLevel implementiert. Die Dokumentation dazu finden Sie unter TcHVAC/FB_BAREnergyLevel.

Funktionsbaustein Beschreibung vom FB_BC9191EnergyLevel

SetpointRoom (PRG)

Das SetpointRoom Programm muss über die Eingangsvariable _bEnable_SPR freigegeben werden, damit die Sollwertberechnung aktiv ist. Dieses generiert die resultierenden Sollwerte aller Energieniveaus für den Heiz- und Kühlbetrieb anhand des Basissollwertes und der lokalen Sollwertverschiebung eine zentrale Verschiebung ist auch möglich. Diese kann per ADS-Befehl erfolgen. Für jedes Energieniveau gibt es einen eigenen Sollwert zum Heizen und Kühlen.

Die Variablen _rSetpointShiftHeat_SPR und_rSetpointShiftUserCool_SPR können für raumspezifische Änderungen genutzt werden, dies kann per ADS-Befehl erfolgen.
_rSetpointShiftUser_SPR ist die lokale Sollwertverschiebung die vom BC9191 erfasst und skaliert wurde. Die Ausgangsstruktur _stSetpoint_SPR beinhaltet die resultierenden Sollwerte und wird mit dem einer Instanz vom FB_BC9191Room verbunden.

Funktionsbaustein Beschreibung vom FB_BC9191SetpointRoom.

FctSelection (PRG)

Das FctSelection Programm muss über die Eingangsvariable _bEnable freigegeben werden. Die Standard Klimatisierungsapplikation unterstützt ein 4-Rohr-System hierbei erfolgt die Umschaltung zw. Heizbetrieb und Kühlbetrieb anhand des Vergleiches von dem Raumtemperatursollwert und dem Raumtemperaturistwert. Ein 2-Rohr-System via change over ist auch möglich, dies kann per ADS-Befehle erfolgen, wenn keine weitere I/Os an dem BC9191 gesteckt sind, vorausgesetzt die baulichen Voraussetzungen sind gegeben.
Funktionsbaustein Beschreibung vom FB_BC9191FctSelection.

fbBC9191Room (FB)

Dieser Funktionsbaustein gibt in Abhängigkeit der Enumeration (eCtrlFct) den PI-Regler zum Heizen oder Kühlen frei. Weitere Eingänge sind die Information des aktuellen Energieniveaus (eActaulEnergyLevel) und die Struktur (stSetpointRoom) mit den resultierenden Sollwerte der einzelnen Energieniveaus. Als Ausgänge gibt jeweils für Heizen und Kühlen eine Freigabe und einen Sollwert für die Raumtemperaturregelung.

PI_Cooling (PRG) / PI_Heating (PRG) / FB_BC9191AO_0_10V

Die PI_Cooling und PI_Heating Programme beinhalten einen PI-Regler. Die Regler werden über eine Instanz vom FB_BC9191Room freigegeben. Innerhalb der Reglerprogramme befinden sich Parameter zum Einstellen der Regler, diese Parameter können auch über ADS-Befehle eingestellt werden. Die Stellgrösse der Regler am Ausgang wird auf 0..100% skaliert. Der jeweilige Reglerausgang wird mit einer Instanz vom FB_BC9191AO_0_10V verbunden.
Der Wirksinn des Reglers wird mit dem Eingangsparameter bDirection vorgegeben. Bei dem Regler für Kühlen muss der Eingang auf TRUE gesetzt werden.

Der Funktionsbaustein FB_BC9191AO_0_10V gibt einmal die aktuelle Stellgröße in 0...100% (rY) aus und einmal als skalierte Größe mit einem Wertebereich (0...32767) aus, den ich direkt auf das analoge Ausgangsignal legen kann.
AO1 (X2:22; X2:21) ==> Heizen (0...10VDC)
AO2 (X2:20; X2:21) ==> Kühlen (0...10VDC)

Funktionsbaustein Beschreibung vom FB_BC9191PICtrl.

FanCoil (PRG)

Das FanCoil Programm wird über die Ausgänge bEnableCooling ODER bEnableHeating der fbBC9191Room Instanz oder über stBC9191FanCoilFunctions.bEnable freigegeben. An _rY_C wird die Stellgrösse (0..100%) vom Kühlregler angelegt und an _rY_H wird die Stellgrösse (0..100%) vom Heizregler angelegt.
Die Information ob Heizbetrieb oder Kühlbetrieb ist, kommt vom FctSelection Programm. Über die Parameter können die Grenzwerte jeweils für Heizen und Kühlen für die drei Lüfterstufen, die Mindesteinschaltzeit der Stufen, die Betriebsart und das Zeitfenster für die manuelle Übersteuerung eingestellt werden.
Über die Eingänge _bStageUp / _bStageDown ist eine manuelle Übersteuerung realisiert durch das hoch und runter Schalten, z.B durch weitere I/Os oder über ADS-Befehle. Über _iStageManual kann direkt eine Zahl zw. (0..4) vorgegeben werden, z.B. über ADS-Befehl. Des Weiteren gibt es einen Parameter mit dem man eine Mindesteinschaltzeit einstellt, die dann für jede Stufe gültig ist.
Über die Ausgänge _bStageOff /_bStageAuto wird der Zustand des FanCoils gemeldet. Die Ausgänge _bStage01 (X3:32; X3:35), _bStage02 (X3:33; X3:35) und _bStage03(X3:34; X3:35) sind direkt mit den Ausgängen vom BC9191 verbunden. Ist einer von den drei Ausgängen TRUE, wird dies an dem Ausgang _bFanCoilActive gemeldet.
Findet eine manuelle Übersteuerung statt über die Eingänge bStageUp / _bStageDown / _iStageManual wird ein Zeitfenster aktiviert ,das abläuft, und es wird Präsenz gemeldet (_bPresence = TRUE). Nach Ablauf des Zeitfensters wird wieder zurückgeschaltet in den Automatik Modus.

Zentral über einen ADS-Befehl kann _iStageManual manuell eingestellt werden.

Funktionsbaustein Beschreibung vom FB_BC9191FanCoil

PersistentDataGlobalState (PRG)

Der Funktionsbaustein PersistentData ist in der TcSystemBCxx50.lbx enthalten:

Auf dem BC9191 stehen 1000Byte für persistente Daten zu Verfügung von den insgesamt 4kByte an lokierten Merkern. Das aktivieren der Herstellereinstellung löscht die persistenten Daten und der Befehl im PLC Control Online==> Urlöschen.

Um die persistenten Daten zu nutzen, müssen diese erst einmal mit einem Funktionsbaustein aus der SPS heraus aktiviert werden. Dabei muss einmal die Größe der persistenten Daten in Anzahl von Bytes angegeben werden; hier im Beispiel sind das 120 Bytes und einmal die Startadresse; hier im Beispiel 100.

(fbPersistent_Data.WriteSize:= 120;
fbPersistent_Data.WriteOffset:= 100;)

Die Parameter der einzelnen Funktionseinheiten und Regler sind spannungsausfallsicher gesichert. Die Daten werden nach jedem SPS Zyklus gesichert. Hierfür sind zwei Puffer vorgesehen, die wechselseitig beschrieben werden.
Ändert sich die Größe der persistenten Daten muss der Funktionsbaustein neu initialisiert werden über die globale Variable bWriteParameterPersistent.


BC9191 - FB_BC9191EnergyLevel

BECKHOFF BC9191: Anwender PLC-Programm

FB_BC9191EnergyLevel

Applikation

Der Funktionsbaustein dient der Anpassung der Energieabgabe an die Nutzung des Gebäudes. Die Raumnutzungsart wird von der GLT vorgegeben. Je länger ein Gebäude bzw. ein Raum nicht genutzt wird, desto weiter kann sein Energieniveau abgesenkt werden. Das von dem Funktionsbaustein aktuell ausgewählte Energieniveau wird an die Raumtemperaturregelung übertragen.

Protection:

Diese Betriebsart wird bei langen Abwesenheitszeiten z.B. in den Betriebsferien oder auch bei einem geöffneten Fenster aktiviert. Das Energieniveau ist sehr niedrig und dient lediglich dem Schutz des Gebäudes vor Frost- oder Überhitzungsschäden.

Economy:

Das Energieniveau Economy wird für den Absenkbetrieb genutzt. Der Absenkbetrieb wird zum Beispiel Nachts durch einen Zeitschaltplan aktiviert.

PreComfort:

Das Energieniveau PreComfort ist für einen ungenutzten Raum, der jedoch in Kürze wieder belegt sein kann. Die Aktivierung des Bereitschaftsbetriebes geschieht häufig durch einen Zeitschaltplan.

Comfort:
Wenn der Raum belegt ist befindet er sich im Komfortbetrieb. Die Aktivierung des Komfortbetriebes kann durch eine Zeitschaltplanung oder durch eine Anwesenheitserkennung erfolgen.

VAR_INPUT

Name                                : Type
bSetDefault                         : BOOL;
bEnable                             : BOOL;
bWindow                             : BOOL;
bProtection                         : BOOL;
bEconomy                            : BOOL;
bPreComfort                         : BOOL;
bComfort                            : BOOL;

bSetDefault: Wenn die Variable TRUE ist, werden die Default-Werte der VAR_IN_OUT Variablen übernommen.

bEnable: Über ein TRUE an diesem Eingang wird der Funktionsbaustein aktiviert.

bWindow: An diesen Eingang wird der Fensterkontakt angeschlossen. TRUE, entspricht das Fenster ist AUF. FALSE, entspricht das Fenster ist ZU.

bProtection: Mit dem Eingang bProtection wird der Schutzbetrieb aktiviert. Der Schutzbetrieb ist aktiv, wenn der Eingang TRUE ist.

bEconomy: Mit dem Eingang bEconomy wird der Absenkbetrieb aktiviert. Der Absenkbetrieb ist aktiv, wenn der Eingang TRUE ist.

bPreComfort: Mit diesem Eingang wird das Bereitschaftsniveau aktiviert. Das Bereitschaftsniveau ist aktiv, wenn der Eingang TRUE ist.

bComfort: Bei Raumbelegung wird mit diesem Eingang das Komfortniveau aktiviert.

VAR_OUTPUT

Name                          : Type
eEnergyLevel                  : E_BC9191EnergyLevel;
bStateProtection              : BOOL;
bStateEconomy                 : BOOL;
bStatePreComfort              : BOOL;
bStateComfort                 : BOOL;

eEnergyLevel: Dieser Ausgang enthält das aktuelle Energieniveau.

bStateProtection: Der Status von dem bProtection Eingang wird in der Betriebsart eEnergyLevel_AUTO_I und eEnergyLevel_AUTO_II nach außen weitergegeben.

bStateEconomy: Der Status von dem bEconomy Eingang wird in der Betriebsart eEnergyLevel_AUTO_I und eEnergyLevel_AUTO_II nach außen weitergegeben.

bStatePreComfort: Der Status von dem bPreComfort Eingang wird in der Betriebsart eEnergyLevel_AUTO_I und eEnergyLevel_AUTO_II nach außen weitergegeben.

bStateComfort: Der Status von dem bComfort Eingang wird in der Betriebsart eEnergyLevel_AUTO_I und eEnergyLevel_AUTO_II nach außen weitergegeben.

VAR_IN_OUT

Name                                   : Type                        Persistent      Default
eCtrlMode                              : E_BC9191EnergyLevel;              X          eEnergyLevel_AUTO_I

eCtrlMode: Über dieses ENUM kann die Betriebsart von der Gebäudeleitebene aus vorgewählt werden.


BC9191 - FB_BC9191FanCoil

BECKHOFF BC9191: Anwender PLC-Programm

FB_BC9191FanCoil

Anwendung

Der Funktionsbaustein bildet einen 3-stufigen Ventilator ab. Über die Stellgröße (0..100%) vom Heiz- oder Kühlregler werden die drei Stufen geschaltet. Des Weiteren hat man die Möglichkeit über den Eingang iStageManual bzw. bStageUp oder bStageDown die Ventilatorsteuerung manuell zu übersteuern. Über den Eingang udiSecMINPowerOnTime kann eine Mindesteinschaltzeit eingestellt werden, die dann für jede Stufe gültig ist.

VAR_INPUT

Name                                         : Type
bSetDefault                                  : BOOL;
bEnable                                      : BOOL;
eCtrlFct                                     : E_BC9191CtrlFct;
rY_C                                         : REAL;
rY_H                                         : REAL;
bStageUp                                     : BOOL;
bStageDown                                   : BOOL;
iStageManual                                 : INT;
bReset                                       : BOOL;

bSetDefault: Wenn die Variable TRUE ist, werden die Default-Werte der VAR_IN_OUT Variablen übernommen.

bEnable: Ist die Variable bEnable TRUE, dann ist der Funktionsbaustein aktiviert. Bei einem FALSE ist keine Ventilatorstufe angesteuert.

eCtrlFct: Dieser Eingang wird mit dem Ausgang eCtrlFct von dem FB_BC9191FctSelection verbunden. Diese Information ist wichtig um zu wissen, ob die Anlage sich im Heiz- oder Kühlbetrieb befindet. Im Automatikbetrieb werden die Ventilatorstufen nur dann angesteuert, wenn z.B. laut Regelabweichung ist die Anforderung für Heizen aktiv ist und die Anlage befindet sich im Heizbetrieb. Oder laut Regelabweichung ist die Anforderung für Kühlen aktiv und die Anlage befindet sich im Kühlbetrieb.

rY_C: Eingang für die Stellgröße vom Kühlregler.

rY_H: Eingang für die Stellgröße vom Heizregler.

bStageUp: Lokale Verstellung der Ventilatorstufe, schrittweise Hochtasten.

bStageDown: Lokale Verstellung der Ventilatorstufe, schrittweise Runtertasten.

iStageManual: Über diesen Eingang kann/wird die manuelle Ventilatorstufe zentral eingestellt.
iStageManual: = 0 entspricht der Ventilatorstufe AUS
iStageManual: = 1 entspricht der Ventilatorstufe AUTO
iStageManual: = 2 entspricht der Ventilatorstufe01 aktiv
iStageManual: = 3, entspricht der Ventilatorstufe02 aktiv
iStageManual: = 4, entspricht der Ventilatorstufe03 aktiv

bReset: Quittierungseingang bei einer Störung oder bei einem falschen Parameter.

VAR_OUTPUT

Name                          : Type
bStageOff                     : BOOL;
bStageAuto                    : BOOL;
bStage01                      : BOOL;
bStage02                      : BOOL;
bStage03                      : BOOL;
bFanCoilActive                : BOOL;
bPresence                     : BOOL;
byState                       : BYTE;
byError                       : BYTE;
udiSecRT_MINPowerOnTime       : UDINT;
udiRT_TimePeriod              : UDINT;
bInvalidParameter             : BOOL;

bStageOff: TRUE, Ventilatorstufen sind ausgeschaltet.

bStageAuto: TRUE, Ventilatorsteuerung befindet sich im Automatikbetrieb.

bStage01: TRUE, Ventilatorstufe01 aktiv.

bStage02: TRUE, Ventilatorstufe02 aktiv.

bStage03: TRUE, Ventilatorstufe03 aktiv.

bFanCoilActive: TRUE, wenn eine von den drei Ventilatorstufen aktiv ist. Dieser Ausgang kann/wird zur Freigabe von Regler verwendet, damit ein Hitze- bzw. Kältestau vermieden wird.

bPresence: TRUE entspricht, dass über die Eingänge bStageUp, bStageDown oder iStageManual Präsenz detektiert wurde.

byState: Zeigt den Status der Ventilatorsteuerung an.
byState.0:= Baustein ist aktiviert
byState.3:= manuelle Ventilatorstufen Vorgabe ist aktiv
byState.4:= bReset
byState.5:= Ventilatorstufe01 aktiv
byState.6:= Ventilatorstufe02 aktiv
byState.7:= Ventilatorstufe03 aktiv

byError: Ausgabe der Fehler als Byte.
byError.1:= bInvalidParameter

udiSecRT_MINPowerOnTime: Zeigt, die verbleibende Zeit der Mindesteinschaltdauer an.

udiRT_TimePeriod: Zeigt, die verbleibende Zeit der manuellen Übersteuerung an.

bInvalidParameter: Zeigt an, dass ein falscher Eingangsparameter anliegt. bInvalidParameter muss mit bReset quittiert werden.

VAR_IN_OUT

Name                                   : Type             Persistent      Default
rValvePositionH_Stage01                : REAL;                X              0      %
rValvePositionH_Stage02                : REAL;                X             21      %
rValvePositionH_Stage03                : REAL;                X             76      %
rValvePositionC_Stage01                : REAL;                X              0      %
rValvePositionC_Stage02                : REAL;                X             21      %
rValvePositionC_Stage03                : REAL;                X             76      %
udiSecMINPowerOnTime                   : UDINT;               X             120    sec
iFctModeFanCoil                        : INT;                 X             3
udiTimePeriod                          : UDINT;               X             60 min

rValvePositionH_Stage01: Grenzwert der Regelstellgröße vom Heizregler ab dem die Ventilatorstufe01 eingeschaltet wird.

rValvePositionH_Stage02: Grenzwert der Regelstellgröße vom Heizregler ab dem die Ventilatorstufe02 eingeschaltet wird.

rValvePositionH_Stage03: Grenzwert der Regelstellgröße vom Heizregler ab dem die Ventilatorstufe03 eingeschaltet wird.

rValvePositionC_Stage01: Grenzwert der Regelstellgröße vom Kühlregler ab dem die Ventilatorstufe01 eingeschaltet wird.

rValvePositionC_Stage02: Grenzwert der Regelstellgröße vom Kühlregler ab dem die Ventilatorstufe02 eingeschaltet wird.

rValvePositionC_Stage03: Grenzwert der Regelstellgröße vom Kühlregler ab dem die Ventilatorstufe03 eingeschaltet wird.

udiSecMINPowerOnTime: Mindesteinschaltzeit, die ein Ventilator in einer Stufe laufen muss bis er auf eine andere Stufe schaltet bzw. ausschaltet. Eingabe in Sekunden (z.B. 120 entspricht 120s).

iFctModeFanCoil: Über die Wertigkeit der Variable hat der Anwender die Möglichkeit die Ventilatorsteuerung für den Heizbetrieb oder Kühlbetrieb oder für beide Betriebe zu aktivieren. Gültige Werte sind 1,2 oder 3 andere Werte sind ungültig und bInvalidParameter wird auf TRUE gesetzt.

Cooling | Heating | Wertigkeit
0 | 1 | 1 (entspricht Ventilatorsteuerung im Heizbetrieb aktiv)
1 | 0 | 2 (entspricht Ventilatorsteuerung im Kühlbetrieb aktiv)
1 | 1 | 3 (entspricht Ventilatorsteuerung im Heizbetrieb und Kühlbetrieb aktiv)

udiTimePeriod: Zeitfenster indem die manuelle Übersteuerung aktiv ist bei Präsenz. Angabe in Minuten


BC9191 - FB_BC9191FctSelection

BECKHOFF BC9191: Programmierung

FB_BC9191FctSelection

Anwendung

Der Funktionsbaustein dient zur Freigabe einer Raumheizung oder Raumkühlung. Er kann für 2-Leiter Rohrleitungssysteme (change over) oder 4-Leiter Rohrleitungssysteme verwendet werden.
Bei einem 4-Leiter Rohrleitungssystem erfolgt die Umschaltung vom Heiz- in den Kühlbetrieb automatisch anhand des Vergleiches von dem Raumtemperatursollwert und dem Raumtemperaturistwert.

Skizze:

Bei einem 2-Leiter Rohrleitungssystem darf die Freigabe des Heizbetriebes oder des Kühlbetriebes nur dann erfolgen, wenn Heizmedium bzw. Kühlmedium ansteht. diese Information bekommt die Raumtemperaturregelung von den Primäranlagen.

Sowohl in 2-Leiter Rohrleitungssystemen als auch in 4-Leiter Rohrleitungssystemen kann das Umschalten zwischen dem Heizbetrieb und dem Kühlbetrieb durch einen Timer verzögert werden. Dafür muss die Eingangsvariable udiChangeOverDelay größer Null sein.

Folgende Tabellen beschreiben den Zusammenhang zwischen den Eingängen und dem Ausgang eCtrlFct des Funktionsbausteins FB_BC9191FctSelection.

im 2-Leiter Rohrleitungssystem
bEnable | bPipeSystem | bFeedbHeatMedium | bFeedbCoolMedium | interim Result | bDewPoint | eCtrlFct
0 | 0 | 0 | 0 | OFF | TRUE / FALSE | OFF
1 | 0 | 0 | 0 | Heating | TRUE / FALSE | Heating
1 | 0 | 0 | 1 | Cooling | TRUE | OFF
 |  |  |  |  | FALSE | Cooling
1 | 0 | 1 | 0 | Heating | TRUE / FALSE | Heating
1 | 0 | 1 | 1 | Heating | TRUE / FALSE | Heating
im 4-Leiter Rohrleitungssystem
bEnable | bPipeSystem | T_Room < = Tsetpoint | T_Room > Tsetpoint | interim Result | bDewPoint | eCtrlFct
0 | 1 | 0 | 0 | OFF | TRUE / FALSE | OFF
1 | 1 | 0 | 1 | Cooling | TRUE | OFF
 |  |  |  |  | FALSE | Cooling
1 | 1 | 1 | 0 | Heating | TRUE / FALSE | Heating
1 | 1 | 1 | 1 | Heating | TRUE / FALSE | Heating

VAR_INPUT

Name                                         : Type
bSetDefault                                  : BOOL;
bEnable                                      : BOOL;
bPipeSystem                                  : BOOL;
bFeedbHeatMedium                             : BOOL;
bFeedbCoolMedium                             : BOOL;
bDewPoint                                    : BOOL;
rRoomTemp                                    : REAL;
stSetpoint                                   : ST_BC9191SetpointRoom;

bSetDefault: Wenn die Variable TRUE ist, werden die Default-Werte der VAR_IN_OUT Variablen übernommen.

bEnable: TRUE, Freigabe des Bausteines. Liegt ein FALSE an, ist der Baustein gesperrt und eCtrlFct := eCtrlFct_Off.

bPipeSystem: FALSE, bedeutet ein 2-Leitersystem ist vorhanden. TRUE, bedeutet ein 4-Leitersystem ist vorhanden.

bFeedbHeatMedium: Meldung von der Energieerzeugung bzw. Verteilung, dass Heizmedium zur Verfügung steht.

bFeedbCoolMedium: Meldung von der Energieerzeugung bzw. Verteilung, dass Kühlmedium zur Verfügung steht.

bDewPoint: An diesen Eingang wird der Taupunktfühler angeschlossen, löst dieser aus wird die Kühlregelfunktion deaktiviert und eCtrlFct := eCtrlFct_Off gesetzt.

rRoomTemp: Über diese Eingangsvariable wird dem Funktionsbaustein die aktuelle Raumtemperatur übergeben.

stSetpoint: STRUKTUR, die die Sollwerte der einzelnen Energieniveaus beinhaltet.

VAR_OUTPUT

Name                          : Type
eCtrlFct                      : E_BC9191CtrlFct;
uiReqHeating                  : UINT;
uiReqCooling                  : UINT;
udiRT_ChangeOverDelay         : UDINT;

eCtrlFct: Dieser Ausgang enthält die aktuelle Regelfunktion.

uiReqHeating: Ist 1, wenn der Raum/Zone Heizenergie anfordert. Ist 0, wenn kein Heizbedarf vorhanden ist.

uiReqCooling: Ist 1, wenn der Raum/Zone Kühlenergie anfordert. Ist 0, wenn kein Kühlbedarf vorhanden ist.

udiRT_ChangeOverDelay: Zeigt die verbleibende Zeit an, bis die aktive Regelfunktion umgeschaltet wird.

VAR_IN_OUT

Name                           : Type                        Persistent      Default
udiChangeOverDelay             : UDINT;                            x           	0

udiChangeOverDelay: Umschaltzeit zw. den Regelfunktionen. Die Angabe muss in Sekunden erfolgen. Ist die Eingabe größer 0, wird diese immer beachtet. Soll zw. den Regelfunktionen keine Umschaltzeit sein, muss die Variable 0 sein.


BC9191 - FB_BC9191SetpointRoom

BECKHOFF BC9191: Programmierung

FB_BC9191SetpointRoom

Anwendung

Der Funktionsbaustein FB_BC9191SetpointRoom weist den Energieniveaus Protection, Economy, PreComfort und Comfort jeweils einen Sollwert für den Kühl- und Heizbetrieb zu. In Verbindung mit dem Funktionsbaustein FB_BC9191EnergyLevel werden der Raumtemperaturregelung entsprechend der Raumnutzung und der Funktionsauswahl Heiz- oder Kühlbetrieb energetisch optimalen Sollwert zugewiesen.

Der resultierende Sollwert für die verschiedenen Energieniveaus setzt sich zusammen aus:

  1. dem Basissollwert
  2. der lokalen Sollwertverschiebung (nicht bei den Protection Sollwerte)
  3. der zentralen Sollwertverschiebung (nicht bei den Protection Sollwerte)

Die lokale Verschiebung durch einen Raumsollwertsteller wie auch die Fernverstellung der Sollwerte über eine Gebäudeleittechnik wirken nur auf die Energieniveaus Comfort und PreComfort.

VAR_INPUT

Name                                         : Type
bSetDefault                                  : BOOL;
bEnable                                      : BOOL;
rSetpointShiftHeat                           : REAL;
rSetpointShiftCool                           : REAL;
rSetpointShiftUser                           : REAL;
bReset                                       : BOOL;

bSetDefault: Wenn die Variable TRUE ist, werden die Default-Werte der VAR_IN_OUT Variablen übernommen.

bEnable: Ist die Variable bEnable TRUE, dann ist der Funktionsbaustein aktiviert.

rSetpointShiftHeat: Zur Anpassung des ComfortHeating Sollwertes von der Gebäudeleittechnik dient die Variable rSetpointShiftHeat.

Bei einer Erhöhung des ComfortHeating Sollwertes wird der Sollwert des ComfortCooling und PreComfortCooling mit erhöht.
Beispiel:

Energieniveaus |  | ProtectionHeating | EconomyHeating | PreComfortHeating | ComfortHeating | ComfortCooling | PreComfortCooling | EconomyCooling | ProtectionCooling
Basissollwert [°C] |  | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
SetpointShiftHeat [K] | +3 | - | - | - | +3 | +3 | +3 | - | -
resultierender Sollwert [°C] |  | 12 | 15 | 19 | 24 | 27 | 31 | 35 | 40

Eine Senkung des ComfortHeating Sollwertes bezieht sich nur auf den ComfortHeating und PreComfortHeating Sollwert.
Beispiel:

Energieniveaus |  | ProtectionHeating | EconomyHeating | PreComfortHeating | ComfortHeating | ComfortCooling | PreComfortCooling | EconomyCooling | ProtectionCooling
Basissollwert [°C] |  | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
SetpointShiftHeat [K] | -3 | - | - | -3 | -3 | - | - | - | -
resultierender Sollwert [°C] |  | 12 | 15 | 16 | 18 | 24 | 28 | 35 | 40

rSetpointShiftCool: Zur Anpassung des ComfortCooling Sollwertes von der Gebäudeleittechnik dient die Variable rSetpointShiftCool.

Bei einer Erhöhung des ComfortCooling Sollwertes wird der Sollwert des PreComfortCooling mit erhöht.
Beipiel:

Energieniveaus |  | ProtectionHeating | EconomyHeating | PreComfortHeating | ComfortHeating | ComfortCooling | PreComfortCooling | EconomyCooling | ProtectionCooling
Basissollwert [°C] |  | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
SetpointShiftCool [K] | +3 | - | - | - | - | +3 | +3 | - | -
resultierender Sollwert [°C] |  | 12 | 15 | 19 | 21 | 27 | 31 | 35 | 40

Eine Senkung des ComfortCooling Sollwertes bezieht sich nur auf den ComfortCooling. Der PreComfortCooling wird dabei nicht verändert.
Beispiel:

Energieniveaus |  | ProtectionHeating | EconomyHeating | PreComfortHeating | ComfortHeating | ComfortCooling | PreComfortCooling | EconomyCooling | ProtectionCooling
Basissollwert [ °C ] |  | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
SetpointShiftCool [K] | -3 | - | - | - | - | -3 | - | - |
resultierender Sollwert [°C] |  | 12 | 15 | 19 | 21 | 21 | 28 | 35 | 40

Falls der Sollwert der Energieniveaus PreComfort über den Sollwert der Niveaus Economy hinaus verschoben wird, nimmt der Sollwert des Niveaus Economy den Wert des Niveaus PreComfort an.
Beispiel:

Energieniveaus |  | ProtectionHeating | EconomyHeating | PreComfortHeating | ComfortHeating | ComfortCooling | PreComfortCooling | EconomyCooling | ProtectionCooling
Basissollwert [°C] |  | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
SetpointShiftCool [K] | +8 | - | - | - | - | +8 | +8 | - | -
resultierender Sollwert [°C] |  | 12 | 15 | 19 | 21 | 32 | 36 | 36 | 40

rSetpointShiftUser: Zur lokalen Sollwertverschiebung des Nutzers dient die Variable rSetpointShiftUser.
Ein positiver Wert von rSetpointShiftUser wirkt sich auf den Sollwert von ComfortHeating,ComfortCooling und PreComfortColling aus.
Beispiel:

Energieniveaus |  | ProtectionHeating | EconomyHeating | PreComfortHeating | ComfortHeating | ComfortCooling | PreComfortCooling | EconomyCooling | ProtectionCooling
Basissollwert [°C] |  | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
SetpointShiftUser [K] | +3 | - | - | - | +3 | +3 | +3 | - | -
resultierender Sollwert [°C] |  | 12 | 15 | 19 | 24 | 27 | 31 | 35 | 40

Ein negativer Wert von rSetpointShiftUser wirkt sich auf den Sollwert von PreComfortHeating, ComfortHeating und ComfortCooling.
Beispiel:

Energieniveaus |  | ProtectionHeating | EconomyHeating | PreComfortHeating | ComfortHeating | ComfortCooling | PreComfortCooling | EconomyCooling | ProtectionCooling
Basissollwert [°C] |  | 12 | 15 | 19 | 21 | 24 | 28 | 35 | 40
SetpointShiftUser [K] | -3 | - | - | -3 | -3 | -3 | - | - | -
resultierender Sollwert [°C] |  | 12 | 15 | 16 | 18 | 21 | 28 | 35 | 40

bReset: Quittierungseingang bei einer Störung oder bei einem falschen Parameter.

VAR_OUTPUT

Name                                  : Type
stSetpoint                            : ST_BC9191SetpointRoom;
bInvalidParameter                     : BOOL;

stSetpoint: Struktur, die die Sollwerte für alle Energieniveaus beinhaltet.

bInvalidParameter: Zeigt an, dass ein falscher Eingangsparameter anliegt. bInvalidParameter muss mit bReset quittiert werden.

VAR_IN_OUT

Name                                   : Type                        Persistent      Default         Range
rSetpointComfortHeat                   : REAL;                          X              21.0
rSetpointPreComfortHeat                : REAL;                          X              19.0
rSetpointEconomyHeat                   : REAL;                          X              15.0
rSetpointProtectionHeat                : REAL;                          X              12.0
rSetpointComfortCool                   : REAL;                          X              24.0
rSetpointPreComfortCool                : REAL;                          X              28.0
rSetpointEconomyCool                   : REAL;                          X              35.0
rSetpointProtectionCool                : REAL;                          X              40.0

rSetpointComfortHeat: Sollwert für das Energieniveau Comfort-Heizen.

rSetpointPreComfortHeat: Sollwert für das Energieniveau PreComfort-Heizen.

rSetpointEconomyHeat: Sollwert für das Energieniveau Economy-Heizen.

rSetpointProtectionHeat: Sollwert für das Energieniveau Protection-Heizen.

rSetpointComfortCool: Sollwert für das Energieniveau Comfort-Kühlen.

rSetpointPreComfortCool: Sollwert für das Energieniveau PreComfort-Kühlen.

rSetpointEconomyCool: Sollwert für das Energieniveau Economy-Kühlen.

rSetpointProtectionCool: Sollwert für das Energieniveau Protection-Kühlen.


BC9191 - ADS-Zugriff einer übergeordneten Steuerung

BECKHOFF BC9191: Programmierung

ADS-Zugriff einer übergeordneten Steuerung

Der Building-Automation-Raum-Controller unterstützt die Protokolle Beckhoff ADS und Modbus TCP.
Die TCP-Port-Nummer beträgt für das ADS-Protokoll 48898. Die UDP-Port-Nummer beträgt für das ADS-Protokoll 48899.
Die TCP-Port-Nummer von Modbus TCP wurde auf den Wert 502 standardisiert

In diesem Teil der Dokumentation wird der Zugriff über das Beckhoff ADS-Protokoll beschrieben. ADS ist die Abkürzung für Automation Device Specification und beschreibt eine geräte- und feldbusunabhängige Schnittstelle. Das Beckhoff ADS-Protokoll ist auf das TCP/IP- oder UDP/IP-Protokoll aufgesetzt. Es ermöglicht dem Benutzer innerhalb des Beckhoff-Systems über nahezu beliebige Verbindungswege mit allen angeschlossenen Geräten zu kommunizieren und diese zu parametrieren. Dafür können ADS-Funktionsbausteine im TwinCAT PLC Control verwendet werden. Die Funktionsbausteine sind in der Bibliothek TcSystem.lib enthalten.

Aufbau des ADS-Protokolls

AMSNetID

Die AMSNetID beschreibt das anzusprechende Gerät. Diese wird aus der eingestellten TCP/IP-Adresse und zusätzlichen 2 Byte erstellt. Diese zusätzlichen 2 Byte bestehen aus "1.1" und sind nicht veränderbar.
Beispiel von einem BC9191 :

IP-Adresse 172.16.21.10
AMSNetID 172.16.21.10.1.1

Port-Nummer

Die Portnummer unterscheidet im angeschlossenen Gerät Unterelemente.
Port 800: lokale Prozessdaten (z.B. BC9191)

Index Group

Die Index Group unterscheidet innerhalb eines Ports verschiedene Daten.
0x4020 Merker
0x4021 Merker Bit

Index Offset (Wertebereich)

Gibt den Offset an, ab welchem Byte gelesen oder geschrieben werden soll.
Merker 0...4095
Merker Bit 0...32760

Beispiel Merker: Port 800 / Index Group 16#4020 / Byte Offset 100

Beispiel Merker Bit: Port 800 / Index Group 16#4021 / Bit Offset 792


BC9191 im Master-/Slave-Modus

Voraussetzungen

  • auf dem BC9191 (Slave) ist das Grundapplikationsprogramm installiert und die Defaultkonfiguration ist aktiv
  • auf der übergeordneten Steuerung, hier im Beispiel ein CX5020 (Master) ist eine Applikation installiert, die im Master-Slave-Mode die Steuerungs- und Regelalgorithmen aller angeschlossenen BC9191 übernimmt. Auf der Mastersteuerung ist eine TwinCAT-Konfiguration aktiv.

Grundinformationen

Im Auslieferungszustand (Default Configuration) des BC9191 haben die OnBoard I/Os feste Adressen. Die Daten für die Ethernet-Kommunikation beginnen ab dem Adress-Offset 1000dez, dies ist ein Leistungsmerkmal vom BC9191. Dieses Leistungsmerkmal wird für die Master-Slave-Kommunikation genutzt.

Eingänge | Ausgänge
Busklemme %IB0 ... | Busklemmen %QB0 ...
Ethernet DATEN (SPS- Variablen) %IB1000 ...(ModbusTCP/ADS-TCP/ADS-UDP) | Ethernet DATEN (SPS- Variablen) %QB1000 ...(ModbusTCP/ADS-TCP/ADS-UDP)
... %IB2047 Maximal | ... %QB2047 Maximal

Detaillierte Beschreibung der TwinCAT-Konfiguration der Mastersteuerung

  • neues TSM file erzeugen und abspeichern unter MasterSlave_TcSM.tsm
  • Gerät anfügen ==> Virtuelle Ethernet Schnittstelle

  • Box Anfügen ==> BC9191 auswählen und mit OK bestätigen / ==> keine Vorlage öffnen, sondern mit dem Button Abrechen bestätigen

  • SPS Projekt Anfügen, damit die selbstdefinierten Variablentypen verfügbar sind.

  • SPS Variablen (für die Ethernet-Kommunikation) einfügen ==> Eingänge und Ausgänge vom Typ ST_BC9191InData / ST_BC9191OutData unter der Box1 BC9191
  • eindeutigen Namen editieren z.B stInData_BC9191_10 und stOutData_BC9191_10 (Bezug auf den Namen der Struktur und auf den BC9191 (z.B 172.16.21.10))

  • Box 1 (BC9191) parametrieren
  • eindeutige / zuordnungsbare Namen deklarieren z.B. BC9191_10
  • Kommunikationseinstellungen im Karteireriter IP Adresse vornehmen ==> UDP einstellen und IP-Adresse setzen

  • wenn die Box1 BC9191 fertig parametriert ist, kann diese je nach Bedarf markiert und kopiert werden
  • dann muss der jeweilige Name, die IP-Adresse und der Namen der zusätzlichen Eingänge und Ausgänge editiert werden.

  • nachdem die zugefügten BC9191 fertig parametriert sind, werden die Eingänge und Ausgänge der SPS-Task mit den eingefügten SPS Variablen verknüpft

Detaillierte Beschreibung des TwinCAT PLC Programms der Mastersteuerung

(CX5020_BC9191_TcPLC.pro als ZIP-Datei)

(MasterSlave_TcSM.tsm als ZIP-Datei)

  • Je nachdem wieviele BC9191 in der Master/Slave Applikation integriert sind, ist es notwendig die stInData_BC9191 und die stOutData_BC9191 entsprechend mehrfach global als lokierte Variablen zu deklarieren

  • für die Ethernet-Kommunikation, die bei der Master/Slave Kommunikation verwendet wird, ist auf der Seite vom BC9191 die Deklaration der SPS-Variablen notwendig ab dem Adress-Offset 1000dez

  • in dem Unterprogramm Monitoring(); wird die Master/Slave Kommmunikation überwacht.
  • wird die Verbindung zw. Master und Slave unterbrochen, fällt der Wert der Strukturvariable .BC9191_uiMonitoring auf 0. In diesem Fall wird der Raum/Zone nicht mehr zentral gesteuert, sondern lokal von dem BC9191. Die Steuerungsfunktionen werden dann von der lokalen SPS vom BC9191 übernommen.

In der Masterapplikation ist eine Visualisierung enthalten. Anhand der VISU und der Kommunikation über Beckhoff ADS ist es möglich mit den angebundenen BC9191 Lese- und Schreibbefehle auszuführen
IndexGroup 16#4020 und 16#4021 ==> IndexOffset, siehe Bild

HINWEISE
  • Der BC9191 (C165) und CX/PC (x86) haben unterschiedliche Speicherausrichtungen, dies muss bei Datenstrukturen, die zw. den beiden Steuerungsplattformen ausgetauscht werden, berücksichtigt werden werden. ==> Siehe auch Art und Weise wie die ST_BC9191InData und ST_BC9191OutData aufgebaut sind.
    BC (165) ==> Datenstrukturen haben eine WORD (2Byte) Speicherausrichtung
    PC / CX (x86) ==> Datenstrukturen haben eine BYTE (1Byte) Speicherausrichtung
    CX (ARM) ==> Datenstrukturen haben eine DWORD (4Byte) Speicherausrichtung
  • Damit Variablen vom Datentyp REAL von einem PC über das Netzwerk per Beckhoff ADS auf einem BC9191 richtig dargestellt werden, müssen die Variablen vom Datentyp REAL in das richtige Format konvertiert werden. Das muss auch dann gemacht werden, wenn vom BC9191 auf den PC zugegriffen wird. Das Konvertieren, sprich das tauschen von HI- und LOW-Word einer REAL Variable kann auf der BC9191 oder der PC Seite gemacht werden mit Hilfe der Funktion (F_SwapRealEx).

Der SPS-Code, der dezentral auf einem BC9191 im Fall einer Kommunikationsunterbrechung läuft, ist auf der Mastersteuerung je angebundenen BC9191 noch mal abgebildet und im Normalfall aktiv am regeln und steuern.

Blau und orange markierte Programmteile gehören funktionell zusammen.

In den einzelnen Programmen, die sich auf einen expliziten BC9191 beziehen, muss die Zuordnung der physikalischen Eingänge und Ausgänge in der entsprechenden Strukturen stInData_BC9191_xx und stOutData_BC9191_xx erfolgen.

Beispiel für den BC9191_10

In dem Programmteil EL_SP_FS_BC9191_10(PRG) findet die Zuordnung zu den physikalischen Eingänge statt. (stInData_BC9191_10 : ST_BC9191InData;)
In dem Programmteil MAIN_BC9191_10(PRG) findet die Zuordnung zu den physikalischen Ausgänge statt. (stOutData_BC9191_10 : ST_BC9191OutData;)


BC9191 - Diagnose-LEDs

BECKHOFF BC9191: Fehlerbehandlung und Diagose

Diagnose-LEDs

Zur Statusanzeige besitzen der BC9191-0000 und BC9191-0100 LEDs.

BC9191

LEDs zur Diagnose SPS

LED | Bedeutung
PLC | an - PLC läuft, blinkt - Zykluszeit wird überschritten, aus - Zykluszeit dauerhaft überschritten oder PLC im Stopp
TC/DC | an - TwinCAT Konfiguration aktiv, aus - Default Konfiguration aktiv, blinkt TwinCAT Konfiguration fehlerhaft

LEDs zur Diagnose des Ethernet

LED | Bedeutung
LINK/ACT (RJ45) | an - LINK vorhanden, blinkt - LINK vorhanden und Kommunikation
COM | Kommunikation mit Controller vorhanden
ERROR | blinkt - DHCP oder BootP aktiv. Es wird auf eine IP-Adresse gewartet

LEDs zur Diagnose der Spannungsversorgung

LED | Bedeutung
Power LED Us | an - interne Spannungsversorgung 5 VDC okay
Power LED Up | an - Spannungsversorgung 24 VDC für externe Geräte okay

LEDs zur Diagnose des K-Bus

LED | Bedeutung
K-Bus RUN | an oder blinkt - K-Bus läuft
K-Bus ERR | blinkt (siehe Fehler Code)

Fehlercode zur K-Bus-Diagnose

Fehler-
Code 		Fehler-
argument 		Beschreibung Abhilfe
- ständiges blinken EMV-Probleme
  • Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
  • EMV-Maßnahmen ergreifen
  • Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiederein-
    schalten des BC9191) der Fehler lokalisiert werden
1 | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
2 | Unbekannter Datentyp | Software Update des BC9191 notwendig
2 - Reserve -
3 0 K-Bus-Kommandofehler
  • Keine Busklemme gesteckt
  • Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen
    ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter
    durchführen, bis die defekte Busklemme lokalisiert ist.
4 | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme KL9010 gesteckt ist
5 | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
6 | 0 | Fehler bei der Initialisierung | Buskoppler tauschen
1 | Interner Datenfehler | Hardware-Reset des BC9191 (aus - und wieder einschalten)
2 | DIP-Schalter nach einem Software-Reset verändert | Hardware-Reset des BC9191 (aus - und wieder einschalten)
3 | IP-Adresse bereits vergeben | Überprüfen Sie ob die IP Adresse bereits im Netzwerk vorhanden ist.
7 0 Hinweis: Zykluszeit wurde überschritten Warning: Die eingestellte Zykluszeit wurde überschritten. Dieser Hinweis (blinken der LEDs)
kann nur durch erneutes booten des BC9191 gelöscht werden.
Kurzfristiege Abhilfe: Zykluszeit erhöhen
9 | 0 | Checksummenfehler im Programm-Flash | Programm erneut zum BC übertragen
1 | Falsche oder fehlerhaft Bibliothek implementiert | Entfernen Sie die fehlerhaft Bibliothek
10 | n | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existiert überein | Die n-te Busklemme überprüfen. Sollte eine n-te Busklemme gewollt eingefügt worden sein, muss das Bootprojekt gelöscht werden.
14 | n | n-te Busklemme hat das falsche Format | BC9191 erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 | n | Anzahl der Busklemmen stimmt nicht mehr | BC9191 erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
16 | n | Länge der K-Bus-Daten stimmt nicht mehr | Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen


BC9191 - Erste Schritte

BECKHOFF Automation GmbH

Erste Schritte

In Vorbereitung


BC9191 - Allgemeine Betriebsbedingungen

BECKHOFF Feldbuskomponenten: Anhang

Allgemeine Betriebsbedingungen

Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.

Bedingungen an die Umgebung

Betrieb

An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:

  • unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
  • bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | 0°C ...+55°C
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4

Transport und Lagerung

Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m

Schutzklasse und Schutzart

Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz

Kennzeichnung der Komponenten

Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:

Auf dem Aufkleber sind folgende Informationen abzulesen:

Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung | 24 VDC
Übertragungsrate | 2,5 MBaud
Hersteller | Beckhoff Automation GmbH
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen

Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA.

C = Kanada, US = USA, LISTED 22ZA (unter diesem Eintrag sind die Prüfergebnisse einsehbar)
Produktionsbezeichnung

Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern).

In diesem Fall handelt es sich also um einen BK2000
- produziert in der 9. Kalenderwoche
- de Jahres 2001
- mit der Firmware-Version BF
- in der 6. Hardwareversion
- ohne Sonderbezeichnung


Prüfnormen für Geräteprüfung

EMV

EMV-Festigkeit

EN 61000-6-2

EMV-Aussendung

EN 61000-6-4

Vibrations-/ Schockfestigkeit

Vibrationsfestigkeit

EN 60068-2-6

Schockfestigkeit

EN 60068-2-27, EN 60068-2-29


Literaturverzeichnis

TCP/IP

TCP/IP (deutsch)
Aufbau und Betrieb eines TCP/IP Netzes
von Kevin Washburn, Jim Evans
Verlag: ADDISON-WESLEY Longmann Verlag

TCP/IP (englisch)
Illustrated, Volume1 The Protocols
von W. Richard Stevens
Verlag: ADDISON-WESLEY Longmann Verlag

Modbus/TCP

http://www.modicon.com/
http://www.modbus.org

TwinCAT

BECKHOFF Information System
http://infosys.beckhoff.com


Abkürzungsverzeichnis

ADS

Automation Device Specification

IP (20)

Schutzart der Busklemmen

IPC

Industrie-PC

E/A

Ein- und Ausgänge

K-Bus

Klemmen-Bus

KS2000

Konfigurationssoftware für Busklemmen, Bus Koppler, Busklemmen Controller, Feldbus Box Module usw.

PE

Der PE-Powerkontakt kann als Schutzerde verwendet werden.

TwinCAT

The Windows Control and Automation Technology


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


BC9191 - E_BC9191CtrlFct

BECKHOFF BC9191: Anwender PLC-Programm

E_BC9191CtrlFct

TYPE E_BC9191CtrlFct:
(
     eCtrlFct_Off             := 0,
     eCtrlFct_Heating         := 1,
     eCtrlFct_Cooling         := 2
);
END_TYPE
eCtrlFct_Off

Function selection OFF active.

eCtrlFct_Heating

Function selection for heating operation active.

eCtrlFct_Cooling

Function selection for cooling operation active.


BC9191 - E_BC9191EnergyLevel

BECKHOFF BC9191: Anwender PLC-Programm

E_BC9191EnergyLevel

TYPE E_BC9191EnergyLevel:
(
     eEnergyLevel_AUTO_I         := 0,
     eEnergyLevel_Protection     := 1,
     eEnergyLevel_Economy        := 2,
     eEnergyLevel_PreComfort     := 3,
     eEnergyLevel_Comfort        := 4,
     eEnergyLevel_AUTO_II        := 5
);
END_TYPE
eEnergyLevel_AUTO_I

Automatik-Modus-I bedeutet, dass in dieser Betriebsart erst in das nächst höhere Energieniveau geschaltet werden kann, wenn die darunter liegenden Energieniveaus bereits TRUE sind. In dieser Betriebsart werden die Zustände der Eingänge bProtection, bEconomy, bPreComfort und bComfort ausgewertet für die Wahl des Energieniveaus. Siehe bitte Diagramm.

eEnergyLevel_Protection

In dieser Betriebsart, die von der Gebäudeleitebene manuell einstellbar ist, wird der Raum/Zone/Bereich in einem minimalen Energiezustand gehalten. Diese Betriebsart ist ein reiner Gebäudeschutzbetrieb.

eEnergyLevel_Economy

In dieser Betriebsart, die von der Gebäudeleitebene manuell einstellbar ist, wird der Raum/Zone/Bereich im Absenkbetrieb gehalten. Diese Betriebsart ist bei längeren Abwesenheitszeiten oder Nachts einzustellen.

eEnergyLevel_PreComfort

In dieser Betriebsart, die von der Gebäudeleitebene manuell einstellbar ist, wird der Raum/Zone/Bereich im Bereitschaftsbetrieb gehalten. Diese Betriebsart ist bei kurzen Abwesenheitszeiten einzustellen.

eEnergyLevel_Comfort

In dieser Betriebsart, die von der Gebäudeleitebene manuell einstellbar ist, wird der Raum/Zone/Bereich im Komfortbetrieb gehalten. Diese Betriebsart ist einzustellen bei Anwesenheit.

eEnergyLevel_AUTO_II

Automatik-Modus-II bedeutet, dass in dieser Betriebsart bei Präsenzerkennung direkt aus dem Energieniveau Protection, Economy oder PreComfort in das Energieniveau Comfort geschaltet wird. Siehe bitte Diagramm.


BC9191 - FB_BC9191PICtrl

BECKHOFF BC9191: Anwender PLC-Programm

FB_BC9191PICtrl

Einfacher PI-Regler

Dieser PI-Regler arbeitet nicht direkt mit einem Verstärkungsfaktor Kp arbeitet, sondern berechnet sich diesen intern aus dem so genannten Proportionalband (Eingang rXp) bezogen auf die Stellgrößengrenzen (rYmin und rYmax).

Einstellung über das Proportionalband

Die Einstellung des Verstärkungsfaktors Kp eines Reglers birgt oft die Schwierigkeit für den Anwender, dass der Größenbezug zur Anwendung fehlt. Arbeitet eine Heizungsregelung normalerweise im zweistelligen Bereich, so kann eine Volumenstromregelung Werte im fünfstelligen Bereichen annehmen. Es macht daher Sinn, den Kp-Faktor so darzustellen, dass er einen Bezug zur möglichen Regelabweichung und Stellgrößenänderung hat. Zur Dimensionierung des Kp-Faktors betrachtet man den P-Anteil des Reglers.
Für diesen gilt:

  • Stellgröße = Regelabweichung x Verstärkungsfaktor → Y = E * Kp

dieser Zusammenhang gilt auch für die Änderungen der Regelabweichung und der Stellgröße:

  • Stellgrößen-Änderung = Regelabweichungs-Änderung • Verstärkungsfaktor → ΔY = ΔE * Kp

Bezogen auf den Minimal- und Maximalwert der Stellgröße, Y min und Ymax:

  • Ymax - Ymin = (E (Ymax) -E (Ymin)) * Kp

Diese Differenz, E(Ymax)-E(Ymin), wird Proportionalband (Xp) genannt. Umgestellt lautet die Gleichung dann:

  • Kp = (Ymax - Ymin) / Xp

Das folgende Diagramm verdeutlicht den funktionalen Zusammenhang:

Das Proportionalband Xp gibt demnach die Größe des Bereiches der Regelabweichung an, die am Regler ausgangsseitig zu einer Ausgabe von Ymin bis Ymax führen.

Ein kleineres Xpführt zu einer steileren Funktion und damit zu einer Erhöhung des Kp-Faktors. Allerdings verschieben sich die Regelabweichungs-Grenzwerte E(Ymax)-E(Ymin):

Wirkungsweise des Bausteines

Sprungantwort. Reaktion des Ausganges Y(t) auf einen Einheitssprung am Eingang E(t).

Grundlegende Funktion

Ein TRUE-Signal am Eingang bEnable aktiviert den Baustein. Der interne Regelalgorithmus wird nun abgearbeitet. Der Eingangswert uiCtrlCycleCall gibt dabei vor, nach wie vielen SPS-Zyklen der interne Regelalgorithmus abgearbeitet wird. Ist uiCtrlCycleCall =1, so erfolgt die Neuberechnung in jedem SPS-Zyklus, ist er hingegen auf 100 eingestellt, so erfolgt eine erneute Berechnung der Ausgangsgrößen nur alle hundert SPS-Zyklen. Die SPS-Zykluszeit geht mit in die Stellgrößenberechnung ein. Ein falscher Eingabewert führt zu fehlerhafter Berechnung.
Die Eingänge rW (Sollwert), rX (Istwert), rXp (Proportionalband) und rTn (Nachstellzeit) sind die Eingangsgrößen des PI-Reglers. Mit Ihnen werden in jedem Berechnungszyklus die Ausgangsgrößen rY (Stellgröße) und rE (Regelabweichung) ermittelt. Die Stellgröße lässt sich zusätzlich durch die Eingänge rYMin und rYMax begrenzen.
Im ersten Berechnungszyklus (das heißt nach Neuaktivierung oder Austritt aus dem Fehlerfall, siehe unten) wird der I-Anteil so gesetzt, dass die Stellgröße rY am Ausgang ihrem unteren Grenzwert rYmin entspricht.

Anti-Reset-Windup (ARW)

"Läuft" der Regler in diese Begrenzung, so wird der I-Anteil intern auf dem letzten Wert festgehalten. Würde dies nicht gemacht werden, so könnte der I-Anteil während des Begrenzungsfalles ungehindert sehr große Werte annehmen, die im Falle einer Wirksinn-Umkehrung des Reglers zunächst wieder eliminiert werden müssten. Diese Funktion wird "Anti-Reset-Windup" (ARW). Ist diese Funktion im Eingriff, so ist der Ausgang bARW gesetzt.

Sonderfall Tn=0 als Abschaltung des I-Anteiles

Aus dem oben aufgeführten Sprungantwort-Diagramm geht hervor, dass der Einfluss des I-Anteiles umso schwächer ist, je größer die Nachstellzeit Tn eingestellt wurde. Geht die Nachstellzeit gegen Unendlich, so ist der Einfluss vom I-Anteil gleich Null. Umgekehrt würde eine immer kleiner werdende Nachstellzeit den Einfluss des I-Anteiles wachsen lassen, mit Tn=0 ginge die Stellgröße gegen unendlich. Dieser Sonderfall jedoch dazu genutzt, den I-Anteil abzuschalten. Es handelt sich hierbei um eine intern gebildete Ausnahme, da die Nachstellzeit direkt zum I-Anteil gehört und durch den Nulleintrag auch bildlich eine Abschaltung zur Folge haben soll.

Synchronisation

Eine positive Flanke an bSync setzt den Reglerausgang rY unmittelbar auf rSyncValue, sofern der Regler durch ein TRUE.-Signal an bEnable aktiviert ist. Ist dies nicht der Fall, bleibt die positive Flanke an bSync unberücksichtigt.

Fehlerfall/Baustein nicht aktiviert

Ist der Regler fehlerhaft parametriert, so wird die Abarbeitung gestoppt, der Ausgang bError gesetzt und an udiErrorID die entsprechende Fehlerkennung ausgegeben. Der Baustein ist ebenfalls gestoppt, wenn der Eingang bEnable nicht gesetzt ist. In beiden Fällen sind die Ausgänge wie folgt gesetzt:

rY | 0.0
rE | 0.0
bARW | FALSE
bMaxLimit | FALSE
bMinLimit | FALSE

Des weiteren wird der I-Anteil intern gelöscht. Beim erneuten Anlauf des Bausteines beginnt die Stellgrößenberechnung wieder ab dem unteren Grenzwert rYmin.

VAR_INPUT

bEnable         : BOOL;
bDirection      : BOOL;
rW              : REAL;
rX              : REAL;
rXp             : REAL;
tTn             : TIME;
rYMin           : REAL;
rYMax           : REAL;
tTaskCycleTime  : TIME;
uiCtrlCycleCall : UINT;
bSync           : BOOL;
rSyncValue      : REAL;

bEnable: Solange dieser Eingang auf TRUE steht, ist der Baustein aktiv. Ein FALSE-Signal hingegen stoppt die Abarbeitung.

bDirection: Mit dem Parameter bDirection kann der Wirksinn des Reglers verändert werden. Ist bDirection TRUE ist der direkte Wirksinn für einen Kühlbetrieb des Reglers aktiv.
Wenn bDirection FALSE ist, ist der indirekte Wirksinn des Regler für den Heizbetrieb aktiviert.

rW: Sollwert.

rX: Istwert.

rXp: Proportionalband.

tTn: Nachstellzeit des I-Anteiles. Sonderfall: tTn=t#0ms: Der I-Anteil ist deaktiviert.

rYMin: Untergrenze der Stellgröße.

rYMax: Obergrenze der Stellgröße.

tTaskCycleTime: Zykluszeit der Task in der der Baustein läuft.

uiCtrlCycleCall: Aufrufzyklus des Bausteines als Vielfaches der Zykluszeit.
Beispiel: tTaskCycleTime = 20ms, uiCtrlCycleCall =10 -> Der Regelalgorithmus wird alle 200ms aufgerufen. Damit werden aber auch nur alle 200ms die Ausgänge aktualisiert.

bSync,rSyncValue: Eine steigende Flanke an diesem Eingang setzt den (internen) I-Anteils so, dass am Stellgrößenausgang rSyncValue ausgegeben wird. Ist der I-Anteil hingegen durch tTn=0ms deaktiviert, so wird dieses Kommando ignoriert.

VAR_OUTPUT

rY         : REAL;
rE         : REAL;
bARW       : BOOL;
bMaxLimit  : BOOL;
bMinLimit  : BOOL;
bError     : BOOL;
udiErrorId : UDINT;

rY: Stellgröße.

rE: Regelabweichung (Sollwert-Istwert).

rEMin: unterer Regelabweichungs-Grenzwert, welcher sich aus dem eingegebenen Proportionalband ergibt.

rEMax: oberer Regelabweichungs-Grenzwert, welcher sich aus dem eingegebenen Proportionalband ergibt.

bARW: Anti-Reset-Windup-Funktion ist aktiv.

bMaxLimit: Die Stellgröße hat ihren oberen Grenzwert erreicht.

bMinLimit: Die Stellgröße hat ihren unteren Grenzwert erreicht.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn die eingetragenen Parameter fehlerhaft sind.

udiErrorId: Enthält den Fehlercode, sollten die eingetragenen Werte fehlerhaft sein.


BC9191 - ST_BC9191SetpointRoom

BECKHOFF BC9191: Programmierung

ST_BC9191SetpointRoom

TYPE ST_BC9191SetpointRoom :
STRUCT
  stSetpointRoom_ComfortHeat       : REAL:= 21.0;
  stSetpointRoom_PreComfortHeat    : REAL:= 19.0;
  stSetpointRoom_EconomyHeat       : REAL:= 15.0;
  stSetpointRoom_ProtectionHeat    : REAL:= 12.0;
  stSetpointRoom_ComfortCool       : REAL:= 24.0;
  stSetpointRooom_PreComfortCool   : REAL:= 28.0;
  stSetpointRoom_EconomyCool       : REAL:= 35.0;
  stSetpointRoom_ProtectionCool    : REAL:= 40.0;
END_STRUCT
END_TYPE

Die Werte in der Struktur sind mit den Voreinstellwerten deklariert.


To do - In Vorbereitung

BECKHOFF Automation GmbH

Neues Kapitel

In Vorbereitung