Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

Der TwinCAT System Manager ist das zentrale Konfigurationswerkzeug des TwinCAT Systems. Hier werden die Ein- und Ausgänge der beteiligten Software Tasks und die physikalischen Ein- und Ausgänge der angeschlossenen Feldbusse verwaltet. Die einzelnen Software Tasks (z. B. SPS Tasks ) arbeiten jeweils auf einem eigenen, privaten Prozessabbild, so dass die Adressen der im Prozessabbild abgelegten Symbole (Variablen) nur lokal innerhalb der jeweiligen Tasks gültig und relevant sind.

Im TwinCAT System Manager werden die E/A-Informationen der einzelnen Software Tasks eingelesen bzw. eingegeben. Darüber hinaus werden die installierten Feldbusse und daran angeschlossene Module bzw. Boxen beschrieben. Durch das Verknüpfen von Variablen der Software Tasks und Variablen der Feldbusse werden die logischen und physikalischen Ein- und Ausgänge einander zugeordnet.

Task-Task Kommunikation:

Mit Hilfe des TwinCAT System Managers können "Ein- und Ausgänge " einer Task mit den "Aus- und Eingängen" einer anderen Task zyklisch ausgetauscht werden. Die Datenkonsistenz bleibt dabei gewahrt.

Variablenorientiert:

Die kleinste ansprechbare und verknüpfbare Einheit ist eine Variable. Variablen können einzelne Bits sein, Bytes, 16 Bit Datenwort, 32 Bit Datenwort, usw.. Variablen können aber auch Strukturen oder Arrays (Felder) bestehend aus anderen Datentypen sein.

Prozessabbilder:

Variablen sind immer genau einem Prozessabbild zugeordnet, d.h. die Adresse der Variablen ist innerhalb ihres Prozessabbildes eindeutig - aber auch nur innerhalb dieses Prozessabbildes. Jede Software Task und jeder Feldbus besitzt genau ein Prozessabbild (Ausnahme: Tasks eines SPS-Laufzeitsystems teilen sich ein gemeinsames Prozessabbild).

Zuordnungen:

Das Ergebnis des TwinCAT System Managers sind einzelne Zuordnungen, die die erstellten Verknüpfungen beinhalten. Zuordnungen werden jeweils zwischen Software Tasks und Feldbusgeräten sowie zwischen zwei Software Tasks erzeugt, wenn sie gegenseitig verknüpfte Variablen besitzen. D.h. wenn Variablen einer SPS Task mit den Variablen eines Feldbusses verknüpft sind, dann wird genau eine Zuordnung zwischen diesen beiden Elementen erzeugt. Wenn dieselbe SPS Task noch Variablen mit einem anderen Feldbus verknüpft hat, so wird hierfür eine zweite Zuordnung generiert. Die Zuordnungen beinhalten die entsprechenden Kopiervorschriften um zur Laufzeit die entsprechenden Variablen austauschen zu können.

Feldbusunabhängigkeit:

Bei der Definition und Programmierung der am TwinCAT System beteiligten Software Tasks braucht die Art und der Aufbau des, bzw. der verwendeten Feldbusse nicht bekannt zu sein. Die Programmierung erfolgt mit Hilfe logischer Variablen, die lokal innerhalb der jeweiligen Software definiert werden. Erst im TwinCAT System Manager werden diese logischen Variablen mit anderen Variablen verknüpft, die entweder physikalischen Ein- und Ausgängen auf dem Feldbus oder logischen Variablen anderer Tasks entsprechen. Der Typ und die speziellen Eigenschaften der jeweiligen Feldbusse brauchen nicht bekannt sein bzw. nicht berücksichtigt werden.

TwinCAT System Manager unterstützt alle verbreiteten Feldbusse und einige andere Standardschnittstellen des PCs:

  • Beckhoff Lightbus
  • Profibus DP, MC (DP-V2)
  • Interbus
  • CANopen
  • SERCOS
  • DeviceNet
  • EtherCAT
  • Ethernet
  • Echtzeit Ethernet (Beckhoff)
  • PC-Printer Port (8 Eingänge und 8 Ausgänge auf TTL-Basis)
  • Serielle Buskoppler BK8100 an COM
  • USB Buskoppler BK9500
  • Memory Interface (DPRAM) für PC Karten
  • NOVRAM (Non-Volatile RAM)
  • System Management Bus (SMB) zur Diagnose von PC Hardware wie z.B. Lüfter, ...

Detaillierte Informationen zu den unterschiedlichen Feldbuskarten und anderen unterstützten E/A-Geräten finden Sie in der Referenz.

TwinCAT System Manager starten:

Um den TwinCAT System Manager zu öffnen, betätigen Sie mit der Maus im Startmenü von Windows 'Start' -> 'Programme' -> TwinCAT System' -> ' TwinCAT System Manager' oder das TwinCAT Icon im System Tray von Windows und wählen dann dort den 'System Manager'-Eintrag im aufklappenden Pop-up-Menü, wie nachfolgend gezeigt:

Bestandteile des System Managers:

Das Fenster des System Managers ist, wie auf dem folgenden Bild zu erkennen, aufgebaut (bis einschl. TwinCAT v2.8):

In der oberen blauen Leiste steht der Name das Projekts, in diesem Fall Maschine.wsm, darunter befindet sich die Menüleiste und die Toolbar (Symbolleiste), deren Funktion im nachfolgenden Kapitel Bedienung beschrieben wird.

Im linken großen Fenster ist eine Baumstruktur dargestellt, in der alle Komponenten zur Systemkonfiguration enthalten sind.

Ganz unten befindet sich die Statuszeile, sie stellt Informationen zum aktuellen Status des Systems bereit. In diesem Fall läuft das System, dies ist an der Information 'Echtzeit' (wie bereits gesagt, bis zur TwinCAT v2.8) zu erkennen.

Die Beschreibung des TwinCAT System Manager Hauptfensters der Version 2.9 finden sie unter: TwinCAT System Manager -> Einleitung.

Systemkonfigurationsmodule des TwinCAT System Managers

Nachfolgend sind die verschiedenen Hauptkomponenten des TwinCAT System Managers aufgelistet. Die Existenz der Konfigurationskomponenten hängt von dem Level des installierten TwinCAT Systems ab.

Konfigurations-Module | Beschreibung
Echtzeit - Konfiguration | Die grundsätzlichen Systemeinstellungen werden hier durchgeführt. Es wird die Basiszeit des System vorgegeben. Außerdem können benutzerdefinierte Tasks hier eingebunden werden.
SPS - Konfiguration | Bis zu vier SPS Programme in den maximal vier Laufzeitsystem können eingebunden werden. Die bis zu vier Task pro Laufzeitsystem werden aufgeführt und die Verknüpfung der einzelnen Task zu den Variablen wird konfiguriert.
Nocken - Konfiguration | Das optionale elektronische Nockenschaltwerk wird hier konfiguriert.
E/A - Konfiguration Alle Geräte- und Feldbuskomponenten werden hier aufgelistet und konfiguriert. Hierzu zählen:
  • alle Feldbuskarten, die darunter liegenden Boxen und die an den Boxen angeschlossenen Klemmen.
  • die unterbrechungsfreie Stromversorgung (seriell oder 24V)
  • serielle und parallele Schnittstellen
  • Motherboard Diagnose Schnittstellen (SMB).

Weitere Informationen zur Anwendung des TwinCAT System Managers entnehmen Sie bitte der Dokumentation TwinCAT Quick Start .


Einleitung

Im unteren Bild ist das TwinCAT System Manager Hauptfenster (TwinCAT v2.9) dargestellt.
Hyperlinks zu den jeweiligen Beschreibungen der einzelnen Elemente dieses Hauptfensters sind in der Tabelle darunter aufgelistet.

Das rot unterlegte Feld im Bereich unten rechts zeigt an, daß der System Manager momentan mit einem Zielsystem verbunden ist, welches sich nicht auf dem lokalen PC befindet. Man spricht hier auch von einem Remote-System. Der Text in diesem Feld nennt das aktuell verbundene Remote-System (im obigen Fall ist es ein Gerät mit dem TwinCAT Router-Namen 'CX Headless' und der AmsNetId '1.1.1.1.1.1'). Zusätzlich wird der Name des Remote-Systems auch noch in der Titelleiste angezeigt. Ein Doppelklick auf dieses Feld öffnet den Dialog zur Auswahl des Zielsystems. Ist das Feld nicht rot unterlegt, sondern grau wie der Rest des Rahmens, bedeutet dies, daß der System Manager auf das lokale System eingestellt ist.

Das im Bild blau unterlegte Feld zeigt an, daß sich das Zielsystem gerade im Konfig-Modus ("Config Mode") befindet. Es kann auch die Farbe grün ("Run-Modus") oder gelb (Verbindungsaufbau / Timeout) annehmen. Das lokale System kann, unabhängig vom entfernten Zielsystem, natürlich aktuell einen anderen Zustand haben (auf obiges Bild bezogen, könnte sich das lokale System z.B. gerade im "Run Modus" befinden).

Information über | Beschreibung
Menüleiste | Die Menüleiste und Hauptmenüs des TwinCAT System Managers
SYSTEM - Konfiguration | Systemkonfiguration und Echtzeiteinstellungen des lokalen bzw. Zielsystems
NC - Konfiguration | Konfiguration der TwinCAT - NC / NCI (minimale Voraussetzung ist Level "TwinCAT NC")
SPS - Konfiguration | Für den TwinCAT System Manager relevante SPS-Einstellungen (minimale Voraussetzung ist Level "TwinCAT PLC")
Nocken - Konfiguration | Konfiguration des (optionalen) TwinCAT Nockenschaltwerks
E/A - Konfigurationen | Konfiguration der E/A-Ebene des lokalen bzw. Zielsystems
E/A Geräte | Im Zielsystem (lokal oder Remote) konfigurierte Ein- und Ausgabegeräte (Feldbuskarten, NOVRAM, Systemschnittstellen,..) und deren Prozessabbilder
Zuordnungen | Informationen über die Zuordnungen (Mappings) zu anderen TwinCAT Geräten bzw. deren Prozessabbildern


Hauptmenüs

Im Folgenden werden die Bedienelemente, genauer die Menüleiste und die Toolbar (Symbolleiste) des TwinCAT System Managers, beschrieben.

Die Menüleiste besteht aus folgenden sechs Einträgen:

Datei, Bearbeiten, Aktionen, Ansicht, Optionen und ?(Hilfe).

Sofern vorhanden, sind neben den Menüeinträgen auch die entsprechenden Icons der Symbolleiste dargestellt.

In der Titelzeile ist der Name des aktuell geladenen TwinCAT System Manager-Projektes angegeben bzw. "Unbenannt", falls ein neues Projekt noch nicht unter einem Namen gesichert wurde.

Außerdem sind in der rechten Ecke der Titelleiste die Windows-üblichen Fenster-Bedienelemente:

Bewegt den System Manager auf die Taskbar ohne das Projekt zu schließen

/ [image] Versetzt die System Manager Ansicht in die Klein- bzw. Vollbild-Darstellung (Minimize / Maximize).

Beendet / schließt den TwinCAT System Manager.

Hinweis:

Da der TwinCAT System Manager kontext-sensitiv arbeitet, sind nicht alle Menüeinträge jederzeit aktiv!

Menü "Datei"

Neu

Erzeugt ein neues System Manager Projekt (leere Konfiguration).

Öffnen

Öffnet einen Dialog zur Auswahl eines bereits gesicherten System Manager Projekts.

Öffnen aktives

Öffnet die Projektdatei, deren Konfiguration aktiv im TwinCAT System geladen ist.

Speichern

Sichert die aktuelle Konfiguration in die geöffnete *.wsm-Datei (bzw. *.tsm-Datei ab TwinCAT v2.9).

Speichern unter

Sichert die aktuelle Konfiguration in eine .wsm-Datei mit frei wählbarem Namen.

Hinweis: Ab TwinCAT 2.9 wird standardmässig ein neu implementiertes Format (Structured Storage) zur Sicherung der Systemkonfiguration verwendet. Dieses neue Dateiformat trägt die Endung .tsm.
 Alternativ können aber noch weiterhin WSM-Dateien unter TwinCAT 2.9 eingelesen werden, bzw. neu erstellte Konfigurationen mit der Dateiendung *.wsm gesichert werden. Hierzu wählt man einfach die entsprechende Dateiendung im "Speichern unter..." Auswahldialog.

Enable Compression

Um die Systemkonfiguration bei den Embedded Controllern der CX1000 und BXxxxx Serie möglichst resourcenschonend lokal auf dem Zielsystem ablegen zu können, wurde ab TwinCAT Version 2.9 beim oben beschriebenen TSM-Format eine optionale Dateikompression eingeführt. "Enable Compression" ist standardmässig aktiviert und bringt je nach Projekt eine Platzersparnis von 80% und mehr.

Properties

Hier sind ab TwinCAT v2.9 erweiterte Dateiinformationen zum erstellten System Manager Dokument abgelegt.

Drucken

Ermöglicht das Ausdrucken

Seitenansicht

Stellt den aktiven Fensterinhalt (abhängig vom angewählten Bereich des System Managers) in Seitenansicht dar.

Druckereinrichtung

Ruft den Dialog zu den Druckereinstellungen auf.

Beenden

Beendet den TwinCAT System Manager.

Menü "Bearbeiten"

Rückgängig

Macht die letzte Änderung rückgängig.

Ausschneiden

Kopiert angewähltes Objekt in die Zwischenablage und entfernt es dabei aus der aktuellen Konfiguration.

Kopieren

Kopiert angewähltes Objekt in die Zwischenablage.

Einfügen

Fügt Element aus Zwischenablage an die aktuelle Position ein.

Einfügen mit Verknüpfungen

Fügt Element mit vorhandener Verknüpfung aus der Zwischenablage an die aktuelle Position ein.

Hinweis:

Nicht alle o.g. Funktionen sind in jedem Kontext verfügbar.

Menü "Aktionen"

Zuordnung erzeugen

Erzeugt Zuordnungen zwischen zwei Prozessabbildern.

Überprüfen der Konfiguration

Überprüft die aktuelle Konfiguration, auf Plausibilität.

Aktiviert Konfiguration

Sichert und aktiviert die aktuelle Konfiguration. Diese Funktion kann auch ohne das Öffnen des System Managers von der Kommandozeile aus aufgerufen werden.

Hinweis:

Ab der Version TwinCAT 2.8 werden die projektbezogenen Konfigurationsdaten nicht mehr in der Windows Registry gesichert, sondern in einer neu eingeführten XML-Datei mit dem Namen "CurrentConfig.xml". Diese Datei kann im Unterverzeichnis: \TwinCAT\Boot gefunden werden.

Starten/Restarten von TwinCAT in Run-Modus

Startet bzw. Restartet das TwinCAT System mit der aktuell gesicherten Konfiguration. Ab der TwinCAT Version 2.9 wird mit dieser Schaltfläche auch vom CONFIG in den RUN-Modus umgeschaltet. Hierbei wird außerdem ein eventuell konfiguriertes SPS Bootprojekt geladen und bei entsprechender Aktivierung von "Auto Boot" gestartet (siehe dazu auch die Beschreibung:TwinCAT System -> Benutzerinterface -> TwinCAT System Control ). Diese Funktion kann auch ohne Öffnen des System Managers, und zwar von der Kommandozeile aus, aufgerufen werden.

Hinweis:

Ab der TwinCAT 2.9 wird mit dieser Schaltfläche das per "Auswahl des Zielsystems" angewählte TwinCAT Zielsystem mit der aktuell geladenen Konfiguration gestartet (in der Voreinstellung ist das Zielsystem immer der lokale PC). Die ADS-AMSNetID sowie der Name der aktuell angewählten Zielsystem-Maschine (TwinCAT-PC, CX1000 oder sonstiges TwinCAT Zielsystem) wird in der rechten unteren Ecke des System Managers angezeigt. Ist das Zielsystem der lokale PC, wird statt dem Netzwerknamen der Name "Lokal" eingeblendet. Ist das aktuell angewählte Ziel ein Remote-System, wird dessen Name auch noch in der Titelzeile angezeigt. Der aktuelle Modus wird in der rechten unteren Ecke des System Manager-Fensters, sowie zusätzlich anhand eines Farbwechsels am TwinCAT System Control (in diesem Fall auf die Farbe grün), angegeben.

Starten/Restarten von TwinCAT in Konfig-Modus

Diese Fernkonfigurationsmöglichkeit (auch "Remote-Konfiguration" genannt), ist mit der TwinCAT Version 2.9 neu hinzugekommen. Sie versetzt das TwinCAT System in den Konfig-Modus. Diese Funktionalität wird unter anderem benötigt, um z.B. Geräte der Klasse Beckhoff CX1000, welche den TwinCAT System Manager nicht lokal vorhalten, konfigurieren zu können (siehe auch: "Auswahl des Zielsystems"). Der aktuelle Modus bzw. Status wird ganz rechts in der unteren Ecke des System Manager-Fensters, sowie bei lokalem Zielsystem anhand eines Farbwechsels am TwinCAT System Control (im Konfig-Modus ist dies z.B. die Farbe blau), angezeigt.

Neuladen der Konfiguration

Verwirft die aktive E/A-Treiberkonfiguration des Laufzeitsystems und lädt stattdessen die aktuelle Konfiguration, und zwar so wie diese in der Baumansicht vorgenommen wurde.

Auswahl des Zielsystems

Hier kann das zu konfigurierende Zielsystem selektiert werden (siehe auch: "Starten/Restarten von TwinCAT in Konfig-Modus").

Lese Ziel-Server Versionen

Liest die aktuellen Versionsnummern, der auf dem Zielsystem installierten TwinCAT Server, aus.

Update Buskoppler/ IP Link Firmware

Hier erscheint ein Dialog zum Update der Firmware eines Beckhoff Buskopplers oder einer Feldbusbox über die serielle Schnittstelle des PC.

Buskoppler/ IP Link Registerzugriff

Alle verfügbaren Register von angeschlossenen Buskopplern und Feldbusbox-Modulen können, nach Angabe der jeweiligen COM-Schnittstelle oder TCP/IP-Adresse im dann erscheinenden Dialog, von hier aus erreicht werden.

Export XML Beschreibung

Exportiert die Konfigurationsinformationen des, in der Baumansicht aktivierten, Baumeintrags in eine XML-Beschreibungsdatei mit der Dateiendung *.xml.

Import XML Beschreibung

Importiert eine vorhandene XML-Beschreibungsdatei mit deren Konfigurationsinformationen eines Baumeintrags.

Überprüfe Variablenverknüpfungen

Prüft, ob die vorhandenen Verknüpfungsinformationen korrekt und damit aktivierbar sind.

Menü "Ansicht"

Symbolleiste

Blendet die Symbolleiste ein oder aus.

Statusleiste

Blendet die Statusleiste ein oder aus. Die Statusleiste ist im eingeblendeten Zustand der untere Rand des Hauptfensters.

Splitten

Aktiviert das Verschieben der Trennlinie zwischen der Baumansicht und den Dialogen im System Manager Hauptfenster.

Zeige Logger Ausgabe

Stellt das Logger-Fenster am unteren Rand des System Managers dar, bzw. entfernt es.

Z eige Watch Fenster

Blendet das Watch-Fenster im System Manager ein, bzw. aus.

Zeige aktuelle Echtzeitauslastung (toggelt Echtzeitauslastungsanzeige)

Blendet in der unteren, rechten Ecke des Hauptfensters die Echtzeitauslastung des (gestarteten) TwinCAT Systems ein, bzw. aus.

Zeige Online Daten

Blendet die Anzeige von Online Daten der konfigurierten Variablen ein- oder aus. Die aktuelle Konfiguration muss für eine Anzeige aktiv, d.h. gesichert in der Registry, sowie das TwinCAT System gestartet sein.

Zeige Unter-Variablen

Stellt die Unter-Variablen von Variablen dar.

Zeige Experten Modus

Stellt selten benutzte Parameter bei verschiedenen Einstelldialogen im System Manager dar, bzw. wählt deren Darstellung ab.

Menü "Optionen"

Sprache

Ruft das Auswahlmenü für die Sprachumschaltung zu verschiedenen, vom TwinCAT System Manager unterstützten, Landessprachen auf.

Hinweis: Sind die anderen Landessprachen ausgegraut, hat der System Manager die zugehörigen DLLs zwar gefunden, diese sind jedoch nicht aktuell.

Überprüfe IEC1131 Projekt Änderungen

Bei angewählter Option, wird bei gespeicherten Änderungen von konfigurierten SPS-Projekten, eine Messagebox, als Aufforderung zum Neu Einlesen (SPS-Konfiguration) des Projektes, aufgerufen

Automatisches Öffnen des Loggerfensters

Öffnet beim Start des System Managers automatisch das Logger-Fenster und stellt damit auflaufende TwinCAT Ereignisse dar.

Automatisches Öffnen des letzten Projektes

Öffnet beim Start des System Managers automatisch die zuletzt gespeicherte *.wsm- Datei.

Automatisches Selektieren des letzten Baumelementes

Öffnet die Baumstruktur automatisch beim Start des System Managers in der zuletzt gespeicherten Ansicht.

Generieren einer BAK-Datei

Bei angewählter Option wird eine "Aktueller Name".bak Datei als Sicherung erzeugt.

Auto Sichern im Zielsystem

Sichert bei Aktivierung dieser Einstellung, die Konfiguration zusätzlich zum lokalen System auch noch auf dem Zielsystem. Dieses geschieht per Voreinstellung in einer komprimierten Variante der Konfigurationsdatei. Siehe auch "Enable Compression".

Liste Echtzeit Ethernet kompatible Geräte

Ruft einen Dialog zur Anzeige von Beckhoff Echtzeit Ethernet kompatiblen Geräten auf. Für weitere Details siehe:Referenz | "Ethernet Miniport (Echtzeit)".

PCMCIA Basisadresse verändern

Ruft den Einstelldialog zur Änderung der PC-Card Basisadresse auf. Nach einer Änderung ist ein Neustart des Windows Systems notwendig.

Menü "Hilfe" (?)

Hilfe Themen

Ruft die TwinCAT System Manager Hilfe auf. Die Hilfe ist Teil des Beckhoff Information Systems. Wird eine englische Hilfe benötigt, so muss auch das englisch-sprachige Beckhoff Information System installiert werden.

Hilfe Kontext

Ruft, bei installiertem Beckhoff Information System, die Hilfeseite auf, die dem angewählten Bereich im System Manager entspricht.

Info über TwinCAT System Manager

Hier werden die Informationen über die aktuell installierte Version des TwinCAT System Managers aufgerufen.

Sonstige Schaltelemente der Button-Leiste

Finden

Ruft Dialog zur Objektsuche innerhalb des System Managers auf.

Geräte Suchen

Falls man links in der Baumansicht den Eintrag "E/A-Geräte" (unterhalb von E/A - Konfiguration) angewählt hat, kann über die hier gezeigte Schaltfläche der Symbolleiste eine Geräte-Suchfunktion ausgelöst werden. Im ersten Schritt gestartet wird mit dem Suchen nach unterstützten E/A-Geräten und - sofern diese gefunden wurden - dann fortgesetzt mit der Suche nach angeschlossenen Teilnehmern ("Boxen") und deren Klemmenbestückung, bzw. IP-Link Erweiterungsmodulen.

Hinweis:

Erst ab TwinCAT 2.9 ist diese Funktionionalität durchgängig implementiert. Um sie ausführen zu können, muß sich das Zielsystem im Config Mode befinden (der aktuelle Modus wird in der rechten unteren Ecke des Hauptfensters angezeigt).

Free Run Status wechseln

Nach Aktivierung dieser Schaltfläche können, bei einem im Config Mode befindlichen Zielsystem, unterstützte E/A-Geräte in den Freilauf-Modus versetzt werden. E/A-Variablen von Busklemmen können danach auch ohne konfigurierter und aktivierter Task (z.B. ohne SPS-Projekt) geschrieben werden.

Hinweis:

Falls sich das Zielsystem vorher im Run-Modus befand, muß einmalig die Schaltfläche "Neuladen der E/A-Geräte" (Neuladen der Konfiguration) in der Werkzeugleiste betätigt werden, um die E/A-Geräte in den Free-Run Modus versetzen zu können.

Ausklappen des Baumes unterhalb des selektierten Elements

Nach Betätigung dieser Schaltfläche wird der, in der Baumansicht markierte, Eintrag in der komplett ausgeklappten Ansicht dargestellt.


Auswahl Zielsytem

TwinCAT System Manager: Bedienelemente & Anzeigen

Auswahl des Zielsystems

Mit Hilfe des, in TwinCAT 2.9 neu hinzugekommenen, Menüeintrags Auswahl des Zielsystems können Zielsysteme bzw. Remote-Systeme zur weiteren Konfiguration ausgewählt werden. Der Auswahldialog kann unter anderem von der Menüleiste des System Managers, unterhalb der Rubrik "Aktionen", aufgerufen werden.
Da die Unterscheidung der beiden Begriffe "Zielsystem" und "Remote-System" im weiteren Verlauf sehr wichtig ist, werden sie unter "Definition der Begriffe Remote- bzw. Zielsystem" genauer erläutert.

Dialog "Wähle Zielsystem"

Nach Aufrufen des Auswahldialogs wie zu vorab beschrieben, öffnet sich der folgende Dialog mit dem Namen "Wähle Zielsystem". Hier erscheint nun eine Baumansicht der möglichen Konfigurationsziele, die aktuell am lokalen TwinCAT Router angemeldet sind. Dementsprechend ist der oberste Eintrag das lokale TwinCAT System mit der für das eigene System vergebenen ADS-AmsNetId. Die als Unterelemente angeordneten Konfigurationsziele, werden im TwinCAT System auch "Statische Routes" genannt. Zu finden sind diese in der Baumansicht des System Managers unterhalb von "SYSTEM - Konfiguration", Unterelement "Route Settings". Sofern das gewünschte Zielsystem verfügbar ist (Netzwerk ist verbunden, TwinCAT ist gestartet bzw. im Konfig-Modus), kann es als Zielsystem angewählt werden. So kann man sich z.B. mit einem CX1000 verbinden, um diesen zu konfigurieren. Heißt, falls man aktuell lokal auf '172.16.5.116.1.1' eingeloggt ist, würde ein Doppelklick auf 'CX_002F10' eine Verbindung zu genau diesem Zielsystem herstellen.

Falls man sich aber auf nicht gelistete Ziele einloggen möchte, kann man durch Betätigen der Schaltfläche "Search..." weitere - von "Lokal" erreichbare - Zielsystem suchen lassen. Dazu öffnet sich der Dialog "Add Route Dialog". Hierdurch werden neue TwinCAT Zielsysteme zur Liste der aktuellen "Routes" hinzufügefügt.

Will man stattdessen nach zusätzlichen Zielen suchen, welche logisch gesehen hinter einem der gelisteten Zielsysteme liegen (wir sprechen hier von sog. "Remote-Systemen"), so muß man das Zielsystem, von dem aus geroutet werden soll, anwählen und dann die "Search..." Schaltfläche betätigen. In nachfolgend gezeigtem Beispiel soll von 'CX_002F10' aus nach möglichen Remote-System gesucht werden.

Nach Betätigen der "Search..." Schaltfläche wird der "Add Route Dialog" aufgerufen. Nun kann nach den Remote-Systemen gesucht werden, welche im Router des Gerätes 'CX_002F10' konfiguriert und erreichbar sind. Dies könnten z.B. am 'CX_002F10' angeschlossene Profibus-Teilnehmer mit ADS-Schnittstelle oder ein AX2xxx-B200 Antrieb mit Lightbus Interface (ist natürlich auch ein ADS-Gerät) sein.
Es ist aber auch denkbar, dass hier ein anderer PC als Remote-PC zugefügt werden soll, da das lokale Konfigurationssystem keine Rechte für das Remote-System hat, wohl aber das Zielsystem 'CX_002F10'. Es wird damit quasi über das Zielsystem 'CX_002F10' auf den Remote-PC geroutet.

Dialog "Add Route Dialog"

Eine Beschreibung des Dialogs, der bei Betätigung von "Search..." erscheint, finden sie hier...


System Manager im Config Mode

TwinCAT System Manager: Bedienelemente & Anzeigen

Der System Manager im Config Mode

In Vorbereitung...


Watch-Fenster

Bei angewählter Watch-Fenster Anzeige, erscheint am unteren Rand des System Managers folgendes Fenster (hier mit einigen Beispiel-Variablen):

Variable

Gibt den Namen der beobachteten Variable an. Zudem wird per Pfeilsymbol angezeigt, ob die Variable verknüpft ist oder nicht.

Online

Zeigt den aktuellen Wert der Variablen an. Bei nicht-boolschen Variablen wird der Wert im hexadezimalen und dezimalen Format (in Klammern) angezeigt. Bei Variablen die geforct wurden, ist der Wert zusätzlich in spitzen Klammern eingefasst.

Source

Gibt die Quelle der Variable an. Die Information setzt sich aus "Variablenname, Ein- oder Ausgang, Taskname, SPS-Projektname" zusammen.

Watchlist Kontext-Menü

Bei rechtem Mausklick in das Watch-Fenster, erscheint das Kontextmenü.

Löschen

Entfernt die Variable aus dem Watch-Fenster.

Öffnen

Öffnet bereits erstellte und gespeicherte Watch-Fenster Konfigurationen.

Sichern

Ruft Dialog zur Speicherung der Watch-Fenster Konfiguration auf (Dateiendung: *.tcw).

Schließen

Entfernt das Watch-Fenster aus der aktuellen Ansicht des System Managers. Die Konfiguration bleibt aber erhalten und kann jederzeit über das Menü Ansicht / Zeige Watch-Fenster wieder aufgerufen werden.


Logger-Ansicht (Ereignisanzeige)

Bei angewählter Logger-Ausgabe erscheint, im unteren Bereich des System Managers, folgendes Fenster (hier mit einigen Beispiel-Meldungen):

Server

Gibt den Namen und die Port-Nr. des Servers an, der die Meldung generiert hat. Außerdem gibt ein Icon an, wie schwerwiegend der Fehler war (z.B. System gestoppt, etc..).

Timestamp

Zeigt Datum und Uhrzeit der aufgelaufenen Fehlermeldung an.

Message

Beschreibt den aufgetretenen Fehler anhand einer kurzen Beschreibung.

Kontext-Menü der Ereignisanzeige

Bei einem rechtem Mausklick ins Fenster der Logger-Ausgabe, erscheint dessen Kontextmenü.

Löschen

Entfernt alle Meldungen aus der Logger-Ausgabe

Filter

Ist z.Zt. noch in Bearbeitung.

Schließen

Entfernt die Ereignisanzeige aus der aktuellen Ansicht des System Managers. Die Konfiguration bleibt aber im Laufe der Sitzung erhalten und kann jeder Zeit über das Menü unter Ansicht / Zeige Logger-Ausgabe wieder aufgerufen werden.


Statusanzeige Ein-/Ausgänge

Bei Anwahl der Einträge Eingänge bzw. Ausgänge in der Baumansicht des System Managers, erscheint auf der rechten Seite eine Listenansicht der jeweiligen Ein-/Ausgangsvariablen der Task (im Folgenden beispielhaft an Eingängen dargestellt). Hat man in der Baumansicht ein Prozessabbild angewählt, erscheinen in der Listenansicht Ein- und Ausgänge.

Name

Gibt den Namen der physikalischen E/A-Variablen an. Ein kleiner Pfeil im Symbol gibt an (genau wie das X in der darauffolgenden Spalte) das die Variable verknüpft ist. Durch Klick auf die Spaltenüberschrift, kann die Variablenliste alphabetisch auf- oder absteigend sortiert werden.

Online

Zeigt den aktuellen Wert der Variablen an. Bei Nicht-boolschen Variablen wird der Wert im hexadezimalen und dezimalen Format (in Klammern) angezeigt. Bei Variablen die geforct wurden, ist der Wert zusätzlich in spitzen Klammern eingefasst (siehe hierzu auch Watch-Fenster).

Typ

Gibt den Datentyp der jeweiligen Variable an. Durch Klick auf die Spaltenüberschrift kann die Variablenreihenfolge nach der Datentypgröße sortiert werden.

Größe

Gibt die Größe der Variable in Bytes an.

Adresse

Zeigt die Adresse, an der die Variable liegt, an. Die spitze Klammer vor Adresse gibt an, ob die Adresse der physik. E/A-Variable oder die der verknüpften Zielvariable (z.B. Variable einer SPS-Task) angezeigt wird. Durch Klick auf die Spaltenüberschrift, kann man die Adressreihenfolge ab- oder aufsteigend sortieren lassen. Durch Adressen Verschieben im Kontextmenü, kann die Adresse im Prozessabbild nachträglich noch geändert werden.

Ein/Aus

Definiert, ob physik. E/A-Variable ein Ein-/ oder Ausgang ist.

User ID

Vom Benutzer definierbare Kennung. Ist vorgesehen für zukünftige System Manager Funktionalitäten.

Verknüpft mit

Gibt die Zielvariable mit der gesamten Hierarchie-Auflistung an. Durch Klick auf die Spaltenüberschrift kann die Zielvariablenliste alphabetisch auf- oder absteigend sortiert werden.

Dokumentation von Variablenlisten

Bei rechtem Mausklick in eine freie Zeile der Listenansicht, erscheint ein Kontextmenü mit Dokumentationsfunktionen.

Kontext-Menü

Liste Drucken

Gibt die Liste auf installierte Drucker aus.

Liste Kopieren

Kopiert die Liste in die Zwischenablage

Liste Exportieren

Exportiert die Variablenliste in eine csv-Datei (durch Komma getrennter Text), zur weiteren Bearbeitung z.B. mit einem Tabellenkalkulationsprogramm.


History Settings

TwinCAT System Manager: Bedienelemente & Anzeigen

Einstellungen History-Anzeige

Bei angezeigtem Online View (z.B. Taskauslastungsanzeige, grafische Anzeige von Variablenwerten, usw..) erscheint bei rechtem Mausklick innerhalb der Anzeige folgendes Menü:

Stop

Bei angewähltem Stop (signalisiert durch einen Haken) wird die ansonsten kontinuierlich fortlaufende, historielle Anzeige angehalten.

Einstellungen

Öffnet den unten beschriebenen Dialog zur Einstellung des Anzeigenrasters.

Dialog "History Settings"

Bei rechtem Mausklick in das Watch-Fenster, erscheint das Kontextmenü.

Maximum

Dieses, durch die Pfeiltasten oder durch Direkteingabe, einstellbare Feld, definiert den Maximalwert der grafischen Anzeige, also den Wert bei Vollausschlag der Anzeige an der oberen Kante des Gitters.

Minimum

Definiert den Minimalwert, also den Wert bei Ausschlag der Anzeige entlang der untere Kante des Gitters.

Grid X

Definiert die Gitterskalieung der Anzeige im horizontalen Bereich (Zeitachse). Der in diesem Feld voreingestellte Wert (Default) ist '10'.

Grid Y

Definiert die Gitterskalieung der Anzeige im vertikalen Bereich wie folgt: Maximum / Grid Y = Anzahl vertikaler Felder.
Beispiel: Ein unter Maximum eingestellter Wert von '100000' und ein unter Grid Y eingestellter Wert von '20000' resultiert in 5 angezeigten Feldern in der Y-Achse.

Velocity

Hier kann die Vorschubgeschwindigkeit der kontinuierlichen Anzeige (Zeitachse) eingestellt werden. Der voreingestellte Wert (Default) ist '2'.

OK

Übernimmt die getätigten Änderungen

Cancel

Bricht die Einstellungen ohne die Übernahme geänderter Werte ab und schließt diesen Dialog.


Dialog Dokumenteigenschaften

Ab der TwinCAT Version 2.9 werden beim Speichern erweiterte Informationen zum jeweiligen Dokument mitgesichert. Diese Informationen können bei der Projektierung erweitert werden und damit z.B. der Versionsverwaltung dienen.

Beim Öffnen des TwinCAT System Manager Dialogs "Properties...", aufrufbar über das "Datei"-Menü, erscheint folgender Dialog:

Title

Hier kann ein Titel für das Projekt editiert werden.

Author

Hier kann der Name und die Firmenzugehörigkeit angegeben werden. Standardmässig werden hierfür die, bei der TwinCAT-Installation angegebenen, Informationen ausgelesen und angezeigt.

Revision

Hier kann der von der projektierenden Person eine, dem Versionsstand der Maschine bzw. Anlage entsprechende, Revisionsnummer eingetragen werden.

Comment

Hier sollte vom Projekteur ein sinvoller Kommentar zum Projektstatus editiert werden (z.B. eventuelle Einschränkungen der aktuellen Konfiguration, etc..).

TwinCAT

Die TwinCAT Version (Build-Nummer des TwinCAT-Gesamtsystems in Klammern), mit der die jeweilige System Manager Konfiguration erstellt wurde, wird vorab ausgelesen und an dieser Stelle automatisch eingetragen.

Hinweis:

Wenn die jeweilige *.tsm Datei anschliessend weitergegeben wird, bleibt die ursprüngliche Information des Entwicklungssystems hier solange erhalten, bis die Datei vom aktuellen System neu überschrieben wird.

Licence

Zeigt den TwinCAT-Registrierungsschlüssel des Entwicklungssystems an, auf dem die jeweilige Konfiguration zuletzt gespeichert wurde.

Created

Zeigt das Datum an, an welchem die Konfigurationsdatei zum letzten Mal gespeichert wurde.

OK

Übernimmt etwaige Änderungen bei den hier beschriebenen Dokumenteigenschaften und schließt den Dialog.

Cancel

Schließt den Dialog ohne etwaige Änderungen zu übernehmen.

ToolTip-Anzeige zur System Manager Datei im Windows Explorer

Die angegebenen Informationen unter "Document Properties" bei *.tsm-Dateien sind konform zu den in der Windows-Welt üblichen ToolTips und werden daher auch auszugsweise, beim Bewegen der Maus über die jeweilige Datei, im Windows Explorer angezeigt:

Dialog "Dateiinfo" im Windows Explorer

Da *.tsm Dateien vom Typ Structured Storage sind, kann zusätzlich ein Großteil der oben geschilderten Informationen auch im Windows Explorer per Rechtsklick auf die Datei und Auswahl von Eigenschaften unterhalb des Karteireiters "Dateiinfo", wie nachfolgend gezeigt, abgerufen werden.


Bedienungsmöglichkeiten von der Kommandozeile

TwinCAT System Manager: Bedienelemente & Anzeigen

Bedienmöglichkeiten von der Kommandozeile

Wenn man automatisiert ein Applikationsprogramm inklusive der applikationsspezifischen TwinCAT-Dateien installiert, liegt der Wunsch nahe, auch das Aktivieren der System Manager Konfiguration sowie das Starten des TwinCAT Systems automatisiert durchzuführen.

Kommandozeilen-Befehle

Gibt man in der Kommandozeile den gesamten Pfad zum TwinCAT System Manager, den Pfad und Namen der *.wsm Datei und die unten beschriebene Schalter an, so kann man damit die Ausführung der unten genannten Funktionen automatisch veranlassen.

Unterstützte Schalter:

/SaveToRegistry

/StartTwinCAT

Eine nähere Erklärung der Befehle findet man unter Bedienelemente - Hauptmenüs.

Syntax:

TCatSysManager.exe [WSM Path [/SaveToRegistry [/StartTwinCAT]]]

Beispiel 1:

F:\TwinCAT\IO\TCatSysManager.exe Test1.wsm /SaveToRegistry

Die System Manager-Konfiguration Test1 soll mit Hilfe der Kommandozeile geladen werden.

Beispiel 2:

F:\TwinCAT\IO\TCatSysManager.exe Test1.wsm /SaveToRegistry /StartTwinCAT

Die System Manager-Konfiguration Test1 soll mit Hilfe der Kommandozeile geladen und das TwinCAT System danach gestartet oder restartet werden.


Variablen Konfiguration

An Prozessabbildern können Ein- und Ausgangsvariablen angefügt werden, welche dann mit den verschiedenen E/A-Geräten oder Variablen anderer Tasks verknüpft werden können. In diesem Kapitel wird das Manipulieren von Variablen (HI / LO Swap, Force,..) beschrieben.

Einfügen von Variablen

Unter den Unterpunkten Eingänge und Ausgänge können Variablen eingefügt werden, welche dann ins Prozessabbild der Task eingeordnet werden. Bei SPS Tasks ist das Anfügen von Variablen im System Manager nicht möglich. Die SPS Variablen werden mit dem TwinCAT PLC Control im SPS Projekt angelegt (mit fester Adressvergabe für das SPS Prozessabbild, bzw. über %Q* oder %I*) und anschließend durch Neu Einlesen des SPS-Projektes im System Manager bekannt gemacht..

Wenn man bei Tasks auf die Rubrik Eingänge bzw. Ausgänge geht, kann man mit einem rechten Mausklick folgendes Kontextmenü aufrufen:

Kontextmenü:

Adressen neu Berechnen

Berechnet die Adressen der Variablen im Prozessabbild neu.

Variable Einfügen

Ruft folgenden Dialog auf:

Name

Definiert den Namen der Variable.

Kommentar

Definiert einen optionalen Kommentar zu der neuen Variable.

Startadresse

Legt die Adresse der Variablen im Prozessabbild der Task fest. Diese Adresse muss mit derjenigen Adresse übereinstimmen, an der die Task die entsprechende Variable erwartet. Die Adresse der Variablen kann später mit Adresse Verschieben geändert werden.

mehrfach

Es können mehrere Variablen gleichen Typs mit fortlaufenden Adressen erzeugt und eingefügt werden.

Variablentyp

Listet alle im TwinCAT System Manager z.Zt. bekannten Datentypen auf, aus denen der Typ der neuen Variable(n) gewählt werden kann.

Sortiert nach

Erlaubt die Liste der Variablentypen entsprechend zu sortieren.

Hinweis:

Durch Einfügen neuer Variablen wird die Größe des Prozessabbildes der Task automatisch angepasst.

Variablen Informationen

Unter Variablen Informationen werden der Variablendialog, sowie die Flags und der Online-Dialog erklärt.


Variablen Informationen

Bei Anwahl einer Variable in der Baumansicht unterhalb einer Task oder eines E/A-Gerätes (im folgenden Bild eine SPS Variable am BC), werden auf der rechten Seite Dialoge mit Informationen sowie Einstellmöglichkeiten und ein Online-Dialog mit Force-Option angeboten.

Karteireiter "Variable"

Name

Definiert den Namen der in der Baumansicht angewählten Variable.

Typ

Gibt den Datentyp der Variablen an.

Gruppe

Gibt an, ob die Variable ein Ein- oder Ausgang ist.

Größe

Gibt die Größe der Variable in Bytes in an.

Adresse

Zeigt die Adresse der Variablen im Prozessabbild. Sollte wie im Beispiel zusätzlich eine externe Adresse angegeben sein (z.B bei Variablen der Busklemmen Controller) so muss der Wert hinter "ext:" auf den Offset der Datenaustauschvariablen (welcher im Dialog "PLC" definiert ist) aufaddiert werden.

User ID

Editierbare Kennung für zukünftige System Manager Funktionalitäten.

Verknüpft m.

Zeigt gegebenenfalls die, mit der angewählten Variable verknüpfte, Variable an. Ein Betätigen des Buttons ruft den Auswahldialog zur Variablenverknüpfung auf.

Kommentar

Frei editierbares Kommentarfeld.

ADS Info

Gibt die Informationen an, die für einen Zugriff per ADS (z.B. TwinCAT Scope View, ..) auf die angewählte Variable benötigt werden. Die Information besteht aus Port-Nummer, Index Group, Index Offset und der Länge der Variable in Bytes.

Karteireiter "Flags"

Swap LOBYTE and HIBYTE

Bei entsprechender Aktivierung werden das niederwertige und das höherwertige Byte innerhalb der Variable getauscht und so dem Prozessabbild zur Verfügung gestellt (z.B. nötig bei manchen Profibus Fremdgeräten).

Swap LOWORD and HIWORD

Bei entsprechender Aktivierung werden das niederwertige und höherwertige Wort innerhalb einer 32Bit Variablen getauscht und so dem Prozessabbild zur Verfügung gestellt.

Karteireiter "Online"

Wert

Zeigt den aktuellen Wert der angewählten Variable an.

Force

Ruft den Dialog zum Forcen der Variable auf. Das Überschreiben mit dem neuen Wert hält solange an, bis das Kommando mit Aufheben zurückgenommen wird oder das TwinCAT System neu gestartet wird. Bei einer geforcten Variable wird der Wert in roter Farbe dargestellt.

Release

Releases the variable to its regular process image value.

Schreiben

Ruft den Dialog zum Ändern des Variablenwertes auf einen benutzerdefinierten Wert auf. Hierbei wird der Wert nur einmal, für einen Taskzyklus, überschrieben.

Des weiteren gibt es eine kontinuierlich fortlaufende, grafische Anzeige des aktuellen Online-Wertes, welche besonders bei numerischen Variablen deren Änderung über die Zeit verdeutlicht. Details hierzu finden sie unter: Einstellungen History-Anzeige.


Variablen Verknüpfungen

Die verschiedenen Ein- oder Ausgangsvariablen der Tasks, können bei deren Anwahl entweder mit dem Kontext-Menü oder dem, auf der rechten Seite erscheinenden Dialog, z.B. mit der E/A-Konfiguration verknüpft werden.

Kontext-Menü

Einige der Auswahlmöglichkeiten im Kontext-Menü sind nur bei aktiver Konfiguration und laufendem System verfügbar, d.h. ansonsten sind sie ausgegraut.

Verknüpfung Ändern

Ruft den Auswahldialog zur Bestimmung der zu verknüpfenden Zielvariablen auf.

Verknüpfung(en) löschen

Hebt die Verknüpfung (erkennbar am kleinen Pfeil links neben dem Variablensymbol) von Variablen wieder auf.

Gehe zu verknüpfter Variable

Springt zur verknüpften Zielvariable (z.B. Kanal einer Busklemme oder Ein-/Ausgangsvariable einer anderen Task) im Baum des System Managers.

Variable Einfügen

Fügt weitere Variable in Task ein (nicht sinnvoll bei SPS-Tasks, da dort die Variablen im SPS -Projekt angelegt werden sollten).

Variable Löschen

Löscht entsprechende Variable aus der Liste.

Adresse Verschieben

Verschiebt die Adresse der Variablen innerhalb des Prozessabbildes.

Online Schreiben

Überschreibt für einen Zyklus den aktuellen Variablenwert mit einem benutzerdefiniertem Wert.

Online Forcen

Überschreibt solange den aktuellen Variablenwert mit einem benutzerdefiniertem Wert, bis das Forcen mit Forcen Zurücknehmen wieder aufgehoben wird.

Forcen Zurücknehmen

Hebt das Forcen der Variablen auf und lässt damit den eigentlichen Variablenwert wieder durch.

Zum Watchfenster hinzufügen

Fügt die angewählte Variable zum Watchfenster hinzu. Dort ist dann eine ständige Beobachtung der aktuellen Online-Werte von Variablen möglich.

Aus dem Watchfenster entfernen

Löscht die angewählte Variable aus dem Watchfenster.

Verknüpfte Variable erzeugen in

Fügt verknüpfte Variable in ein existierendes SPS-Projekt ein.


Variablen Verknüpfungen

TwinCAT System Manager: Variablen Verknüpfungen aus dem System Manager

Variablen Verknüpfungen aus dem System Manager

Normalerweise werden Ein- und Ausgangsvariablen zwischen Steuerung und Hardware in einer Task angelegt - entweder in der PLC oder einer zusätzlichen Task. Diese Variablen werden dann im System Manager mit der entsprechenden Hardware Variable verknüpft.

In der Beckhoff TwinCAT Software ist aber auch der andere Weg möglich: Einscannen der vorliegenden Hardware (oder manuell konfigurieren) und auf dieser Grundlage PLC-Variablen erzeugen (lassen). Dieser Weg wird nachstehend beschrieben - "Verknüpfte Variable erzeugen in".

Vorgehensweise

Es soll nun aus der Hardware Konfiguration heraus eine Hardware Variable mit einer Task (PLC) verknüpft werden, obwohl dort noch gar keine entsprechende Variable definiert wurde.

Legen Sie im System Manager eine Hardware Konfiguration manuell oder durch Einscannen an. Legen Sie eine Task an, die die Hardware verwalten wird. In Abb. 1. ist das das Projekt "test" mit der Task "Standard" und den bereits enthaltenen Eingängen "InVar1" bis "InVar4" und einigen Ausgängen.

Abb. 1: Hardware Konfiguration

Rechtsklick auf die gewünschte Hardware Variable (hier: Output Kanal 2 einer KL 2012) öffnet den Dialog zum Erzeugen einer verknüpften Variable in einer Task. Es wird in der ausgewählten Task eine neue Variable angelegt, s. Abb. 2.

Abb. 2: bidirektionale Variable

Da dieser Typ Variable in beide Richtungen (Input/Output) benutzt werden kann, ist das Symbol blau und mit einem Doppelpfeil versehen. Dieser Typ Variable wird im üblichen Prozessdatenbereich (hier: IndexGroup 0xF03x) wie alle anderen Ausgangsvariablen angelegt, Eingangsvariablen entsprechend im Eingangsprozessabbild.

Das PLC-Projekt muss von dieser neuen Variable noch informiert werden, s. Abb. 3.

Abb. 3: Import der Variable ins PLC-Projekt

In Abb. 3 ist die Startaddresse für so angelegte PLC-Variablen veränderbar, gerechnet mit Binärpräfixen. In Abb. 3 liegt die Startaddresse bei 7 KB = 7186dez Byte = E000hex Byte.

Durch "Export Variablen Sichern" werden so erzeugte Task-Variablen in das PLC-Projekt übernommen. In der PLC erscheint eine Import-Datei, s. Abb. 4:

Abb. 4: TwinCAT_Import, Read Only


Variablen Auswahldialog

Nach Anwahl Verknüpfung Ändern.. bzw. Verknüpft m. erscheint folgender Auswahldialog:

In der Baumansicht des Auswahldialogs werden alle in Frage kommenden verknüpfbaren Zielvariablen angezeigt (abhängig von der angewählten Variablenart (Eingangs- bzw. Ausgangsvariable).

Zeige Variablen

Unbenutzt: Ist diese Option angewählt, werden nur Variablen angezeigt, die noch nicht verknüpft sind.
Alle: Bei dieser Option werden auch bereits verknüpfte Variablen mit angezeigt. Dies macht z.B. bei mehrfach zu verknüpfenden Ausgängen Sinn.

Zeige Variablen Typen

Passender Typ: Nur passende Variablentypen werden zur Auswahl in der Baumansicht angeboten.
Passende Größe: Nur Variablentypen (z.B. auch Strukturen) mit der passenden Größe werden angeboten.
Alle Typen: Alle verfügbaren Variablentypen werden zur Auswahl angeboten.

Offsets

Kontinuierlich: Bei Multi-Verknüpfung werden die Variablen mit dieser Option, Offset-bezogen in kontinuierlicher Reihenfolge gemappt.
Öffne Dialog: Bei dieser Option wird ein Offset-Dialog, zur freien Bestimmung der zu mappenden Bits zweier Variablen, geöffnet.

Okay

Bestätigt die Verknüpfung der Variablen und schließt den Dialog

Abbruch

Schließt den Dialog ohne eine Verknüpfung auszuführen


Unsymmetrische Variablenverknüpfung

Wenn im Variablen Auswahldialog der Offline Dialog zur Anzeige angewählt ist, bzw. wenn zwei unterschiedlich große Variablen miteinander verknüpft werden sollen, wird folgender Dialog aufgeschlagen:

Im obigen Beispiel wird die Variable dwStatus ab ihrem 11 Bit mit den ersten 8 Bit der selektierten Zielvariable verknüpft.

Zugeordnete Var.

Zeigt den Namen der zu verknüpfenden Variablen (angewählte Variable im System Manager-Baum) an.

Größe

Gibt die Größe der zu verknüpfenden Variablen in Bits an.

Offset

Gibt den Bitoffset, als Startbit der Verknüpfung, innerhalb der Variablen an. Mit den Aufwärts-/ Abwärts-Pfeiltasten (Spin-Buttons) kann das Offsetbit ausgewählt werden.

Eigene Variable

Ist die Zielvariable, mit der die angewählte Variable verknüpft werden soll . Auch hier werden Größe und Offset angezeigt. Der Offset kann wiederum über die Pfeiltasten angepasst werden.

Überlappend

Sagt aus, wieviele Bits ab dem Startoffset miteinander verknüpft werden sollen.

Okay

Bestätigt die Verknüpfung der Variablen und schließt den Dialog.

Abbruch

Schließt den Dialog ohne eine Verknüpfung auszuführen.


Erweiterte Verknüpfungsmöglichkeiten

Bei Anwahl der Hauptrubrik Eingänge bzw. Ausgänge in der Baumansicht des System Managers, erscheint auf der rechten Seite eine Listenansicht der jeweiligen Ein-/Ausgangsvariablen der Task. Bei rechtem Mausklick auf eine oder mehrere (Windows-übliche Mehrfachauswahl) angewählte Variablen, erscheint ein spezielles Kontextmenü mit erweiterten Verknüpfungsmöglichkeiten. Zusätzlich sind auch Dokumentationsfunktionen hierüber aufrufbar.

Kontextmenü

Einzel-Verknüpfung Ändern

Ruft den Auswahldialog zur Bestimmung der zu verknüpfenden Zielvariablen auf.

Multi-Verknüpfung Ändern

Ruft den Auswahldialog zur Multi-Verknüpfung mehrerer aufeinanderfolgender Variablen auf.

Variablen Löschen

Löscht entsprechende Variablen aus der Liste.

Adressen Verschieben

Ruft den Dialog zur Änderung der Variablen-Adresse im Prozessabbild auf.

Zum Watchfenster hinzufügen

Fügt die angewählte Variable zum Watchfenster im System Manager hinzu. Dort ist dann eine ständige Beobachtung der aktuellen Online-Werte von Variablen möglich.

Aus dem Watchfenster entfernen

Löscht die angewählte Variable aus dem Watchfenster.

Liste Drucken

Druckt die Liste aus. Unter E/A-Konfiguration - Zuordnungen findet man weitere Dokumentationsfunktionen des System Managers.

Liste Kopieren

Kopiert die Liste in die Zwischenablage.

Liste Exportieren

Exportiert die Variablenliste im csv-Dateiformat (durch Komma getrennter Text). Diese Datei kann dann weiter bearbeitet werden (z.B. mit Tabellenkalkulationen,...).

Verschieben nach

Ermöglicht das Verschieben der angewählten Variablen in eine andere Task des SPS-Projektes.


Prozessabbilder

In der Baumansicht werden, unterhalb der verschiedenen Konfigurationen, die Prozessabbilder der Tasks bzw. Geräte angezeigt.

Bei Anwahl solcher Prozessabbilder, wie im Beispiel dargestellt, werden auf der rechten Seite die entsprechende Dialoge mit den erweiterten Informationen zum Prozessabbild angezeigt. Darunter erscheint das Prozessabbild mit einer Auflistung aller verknüpften und nicht verknüpften E/A-Variablen.

Dialog "Allgemein"

Name

Name des Prozessabbildes.

Typ

Definiert, ob Prozessabbild nach Verknüpfung als Master- oder als Slave-Prozessabbild fungiert (siehe hierzu auch Beschreibung "Zuordungstyp" unter Zuordnungsarten).

ID

Gibt die Identifikationsnummer des Prozessabbildes an.

Kommentar

Frei editierbares Kommentarfeld.

Dialog "Größe / Offset"

Eingangsgröße

Größe des Bereichs Eingänge im generierten Prozessabbild.

Eingangsoffset

Hier ist ein eventueller Startoffset für den Eingangsbereich eingetragen (geräteabhängig).

Ausgangsgröße

Größe des Bereichs Ausgänge im generierten Prozessabbild.

Ausgangssoffset

Hier ist ein eventueller Startoffset für den Ausgangsbereich eingetragen (geräteabhängig).

Dialog "Eingang" bzw. "Ausgang"

Im Dialog von Eingang bzw. Ausgang wird der jeweilige Prozessabbildbereich in byte-weiser, hexadezimaler Form dargestellt (eventuell zusätzlich als Zeichen in eigener Spalte, sofern die Option "Zeige Zeichen" angewählt ist).
Bei der Anzeige von Prozessabbildern von Geräten mit gemischtem E/A-Bereich im DPRAM (z.B. Beckhoff C1220 Lightbuskarte), werden bei Eingang auch Ausgangswerte angezeigt und umgekehrt.

Weitere Informationen zu Prozessabbildern und deren Verknüpfungen, findet man unter Zuordnungen.


Vergleich Datentypen

System Manager | IEC61131-3 | Entsprechender .NET Typ | C# Keyword | Visual Basic Keyword | Bemerkung
BIT | BOOL | System.Boolean | bool | Boolean | Weitere Informationen zu den SPS-Datentypen sind zu finden unter: TwinCAT PLC Control - Datentypen
BIT8 | BOOL | System.Boolean | bool | Boolean |
BITARR8 | BYTE | System.Byte | byte | Byte |
BITARR16 | WORD | System.UInt16 | ushort | - |
BITARR32 | DWORD | System.UInt32 | uint | - |
INT8 | SINT | System.SByte | sbyte | - |
INT16 | INT | System.Int16 | short | Short |
INT32 | DINT | System.Int32 | int | Integer |
INT64 | LINT | System.Int64 | long | Long | Integer-Typ mit einer Größe von 8 Byte. Wird von TwinCAT PLC momentan nicht unterstützt.
UINT8 | USINT | System.Byte | byte | Byte |
UINT16 | UINT | System.UInt16 | ushort | - |
UINT32 | UDINT | System.UInt32 | uint | - |
UINT64 | ULINT | System.UInt64 | ulong | - | Vorzeichenloser Integer-Typ mit einer Größe von 8 Byte. Wird von TwinCAT PLC momentan nicht unterstützt.
FLOAT | REAL | System.Single | float | Single |
DOUBLE | LREAL | System.Double | double | Double |


Geräteeinstellungen ADS

TwinCAT System Manager: E/A- Konfiguration

ADS-Einstellungen bei E/A-Geräten

Geräte, welche zwar ADS-Dienste transportieren können, aber keinen eigenen ADS-Server bereitstellen (z.B. die virtuelle Ethernet- oder USB-Schnittstelle), besitzen den im Folgenden beschriebenen Dialog.

Karteireiter "ADS"

ADS Kommunikation aktivieren

Aktiviert die Kommunikation mit ADS-fähigen Geräten. Die Checkbox muss aktiviert sein, um eine ADS-Kommunikation zu ermöglichen.

Port

Gibt die ADS Port-Nummer des Gerätes an..

Ändern

Falls diese Schaltfläche aktiviert ist, kann hier die ADS Port-Nummer geändert werden. Im Normalfall ist ein Ändern der Portnummer bei dieser Art von E/A-Geräte aber nicht möglich.

Max Timeout

Bestimmt die maximal erlaubte Antwortzeit bei ADS-Kommunikation zum Gerät (in Sekunden). Falls dieses Feld aktiviert ist, kann hier die maximale Antwortzeit ausgewählt werden.


Geräteeinstellungen ADS/AMS

TwinCAT System Manager: E/A- Konfiguration

ADS/AMS-Einstellungen bei E/A-Geräten

Geräte mit eigener ADS-AmsNetId (z.B. der Beckhoff AX2000-Antrieb) haben den im Folgenden beschriebenen Dialog zur Konfiguration der Einstellungen für die asynchrone Kommunikation.

Bei Geräten ohne eigene NetId ist nur eine Teilmenge der Optionen vorhanden, die verbleibenden haben jedoch die selbe Bedeutung.

Karteireiter "ADS/AMS"

Enable String Communication

Aktiviert den asynchronen Nachrichtenkanal bei Geräten mit Beckhoff Lightbus-Interface.

Port

Gibt die ADS Port-Nummer des Gerätes an..

Change

Ermöglicht ein Ändern der AMS Port - Nummer des Gerätes.

Max Timeout

Bestimmt die maximal erlaubte Antwortzeit bei ADS-Kommunikation zum Gerät (in Sekunden).

Enable AMS / ADS

Bei Geräten mit eigener NetId muss diese Checkbox aktiviert sein.

NetId

Gibt die ADS-AmsNetId des Gerätes an.

Remote Name

Nennt den Namen des Gerätes, wie es in der Liste der möglichen AMS Remote-Verbindungen auftaucht. Dieses Feld ist editierbar.


ADS Kommando - Eingabefenster

Nachfolgend wird die manuelle Eingabemöglichkeit von ADS-Kommandos zum Ansprechen von ADS-fähigen E/A-Geräten (z.B. Beckhoff USB Buskoppler BK9500 oder Ethernet Buskoppler BK9000) erläutert.

Karteireiter "ADS Commands"

Address (Port): Gibt die AMS-Net ID und Port Nummer (letztere in Klammern) für das auszuführende ADS-Kommando an.

Type:: Gibt den Telegrammtyp des auszuführenden Komandos an (T-RW entspricht z.B. Typ Read/Write).

IGroup: Spezifiziert die Index-Group für das gewünschte ADS-Kommando.

IOffs: Spezifiziert den Index-Offset das gewünschte ADS-Kommando.

RLen: Länge der vom ADS-Gerät zu lesenden Daten (in Byte).

WLen: Länge der an das ADS-Gerät zu schreibenden Daten (in Byte).

ROffs: Offset der zu lesenden Daten (in Byte).

WOffs: Offset der zu schreibenden Daten (in Byte).

New: Fügt ein neues ADS-Kommando an die Liste an.

Delete: Löscht das angewählte ADS-Kommando aus der Liste.

Edit: Ermöglicht das Editieren, d.h. das Ändern der Werte in den einzelnen Spalten des Kommandos.


Übersicht

In der SYSTEM - Konfiguration können unter anderem Echtzeit-Einstellungen, sowie projektabhängige Einstellungen für das TwinCAT System, vorgenommen werden.

Zusätzlich können hier benutzerdefinierte Tasks angelegt werden, um z.B. direkt aus Applikationen (Visual Basic-, Visual C++, C# .NET, VB.NET oder Delphi) Werte auf E/A-Geräte auszugeben oder von ihnen zu lesen.

SYSTEM - Konfiguration | Beschreibung
Boot Einstellungen | Boot- / Auto-Start-Einstellungen für das lokale System, bzw. für das Zielsystem
Echtzeit-Einstellungen | Anzeige/Anpassung der Echtzeiteinstellungen sowie grafische Anzeige der Echtzeitauslastung
Prioritäten | Anzeige/Änderung (= Advanced User) der verschiedenen von TwinCAT vergebenen Task-Prioritäten
Benutzerdefinierte Tasks ("Zusätzliche Tasks") | Konfiguration eventueller zusätzlicher (benutzerdefinierter) Tasks
Task Einstellungen für "Zusätzliche Tasks" (falls konfiguriert) | Einstelldialog für die zusätzlichen benutzerdefinierten Tasks
Online-Anzeige Taskauslastung (falls zusätzliche Tasks konfiguriert wurden) | Grafische Darstellung der aktuellen Auslastung benutzerdefinierter Tasks
Task Prozessabbild (falls zusätzliche Tasks konfiguriert wurden) | Verknüpfungsinformationen zu den zusätzlichen Tasks
Routing-Einstellungen ("Route Settings") | Informationen zum "Routing" der TwinCAT Zielsysteme

Dialog "General"

Dieser Dialog wird nur eingeblendet, wenn kein Remote-System (siehe: "Auswahl des Zielsystems") angewählt wurde, der System Manager also auf das lokale TwinCAT System eingestellt ist.
Er entspricht ansonsten dem nachfolgend beschriebenen Dialog "Version [Lokal]".

Dialog "Version (Lokal)"

Der folgende Dialog zeigt das installierte TwinCAT Level des lokalen Systems (im unten gezeigten Beispiel ist dies "TwinCAT NC I" ) sowie die Version und "Build"-Nummer des Systems an (dementsprechend die Version 2.9 [Build 931]).

Dialog "Version [Zielsystem]"

Neben der Anzeige mit Informationen über die lokal installierte TwinCAT Version befindet sich auch noch ein Karteireiter mit dementsprechenden Angaben zum angewählten Zielsystem. Im nachfolgenden Beispiel ist dies die Version 2.9 [Build 0].

Zielsystem wählen: Ruft den Auswahldialog für die per TwinCAT Router erreichbaren Zielsysteme auf (siehe auch Hauptmenüs -> Menü "Aktionen").


Echtzeit - Einstellungen

Als zentrales Konfigurationswerkzeug des TwinCAT Systems, enthält der TwinCAT System Manager unterhalb der Rubrik SYSTEM -Konfiguration den Eintrag Echtzeit-Einstellungen. Hier werden die Basiseinstellungen des TwinCAT Systems angezeigt, beziehungsweise im Bedarfsfall auch geändert.

Bei Anwahl dieses Eintrags erscheint auf der rechten Seite im System Manager der im Folgenden beschriebene Dialog "Einstellungen", sowie die weiter unten beschriebenen Dialoge "Online" und "Priorities".

Karteireiter "Einstellungen"

Basiszeit

Der TwinCAT Scheduler wechseln mit jedem Tick von Windows zur TwinCAT Echtzeit. Dann werden die in der TwinCAT Echtzeit notwendigen und eingeplanten Task ausgeführt. Spätestens mit Erreichen des CPU Limit (s.u.) wird wieder zu Windows gewechselt. Die TwinCAT Basiszeit ist damit die kürzest mögliche Zykluszeit einer Task. Als Zykluszeit können auch Vielfache der Basiszeit angenommen werden. Die Basiszeit sollte nur bei Bedarf und entsprechend schnellen PC-Systemen kleiner eine Millisekunde eingestellt werden. Möglich sind: (keine), 1ms, 500µs, 333µs, 250µs, 200µs, 125µs, 100µs, 66µs und 50µs.

Wenn der Wert der Basiszeit auf (keine) gesetzt wird, dann ist es möglich TwinCAT ohne Echtzeit zu benutzen. Ausführungen, die keine Echtzeit benötigen, arbeiten uneingeschränkt weiter (AMS Router, TwinCAT Scope, ADS OCX, ...)

Einschränkung:

Echtzeit Tasks, wie beispielsweise SPS Tasks, Software Tasks und I/O Tasks (Profibus, DeviceNet, Sercos oder Lightbus) können nicht ausgeführt werden.

CPU Limit

Gibt den prozentualen CPU-Anteil an, den die TwinCAT Echzeit maximal belegt, der Rest wird garantiert für Windows (und somit u.a. für Oberflächenprogramme) reserviert. Der Wert kann sehr hoch eingestellt werden, da automatisch zu Windows zurückgeschaltet wird, wenn die Echtzeittasks mit ihrem Zyklus zu Ende sind.

Fast Tick

Nur für spezielle TwinCAT Erweiterungen, die unabhängig zur Basiszeit noch einen schnelleren Tick benötigen (z.B. Nockenschaltwerk).

Jitter Warnung

Die TwinCAT Echtzeit funktioniert auf beinahe allen PC-Systemen mit extrem geringen Schwankungen (Jitter). Diese Schwankungen werden ständig gemessen. Bei Überschreitung einer einstellbaren Grenze kann vom System eine Warnung erzeugt werden.

Router Speicher

Der TwinCAT Router dient zum Verwalten der Kommunikation aller Teilnehmer. Eine Veränderung des Routerspeichers wird erst nach einem Neustart des Betriebsystems übernommen.

Karteireiter "Online"

Die Online Anzeige gibt Auskunft über die momentane CPU-Auslastung. Dies ist die Zeit, die von den Echtzeit-Tasks benötigt wird. Die hellgrüne Linie zeigt dabei den eingestellten CPU-Limit Wert.
Zusätzlich wird im unteren Fenster der aktuelle Jitter (System-Latenzzeit) angegeben.

Details zur kontinuierlich fortlaufenden, grafischen Anzeige des aktuellen Online-Wertes finden sie unter: Einstellungen History-Anzeige.

Karteireiter "Priorities"

Hier finden Sie Informationen zu den Prioritäten im TwinCAT System.


Systemleistung / Echtzeiteinstellungen (Realtime Settings)

Der NT Task-Manager stellt dem Bediener u.a. eine Liste der laufenden Prozesse und deren CPU-Zeitverbrauch dar. Diese Darstellung ist mit laufendem TwinCAT differenzierter zu interpretieren:

Windows NT kann nicht die Auslastung der CPU durch das TwinCAT System anzeigen. Sie sehen nur im Dialog "Echtzeit" die reale Belastung der CPU durch das TwinCAT System.

Die TwinCAT-Echtzeiterweiterung stellt dem NT Betriebssystem Rechenzeit zur Verfügung. Dieser Teil wird vom NT-Betriebssystem als 100% CPU-Zeit gewertet. Im NT Task-Manager bezieht sich die Anzeige der CPU-Zeit von Prozessen somit nicht auf die CPU-Zeit, sondern auf die verbleibende Zeit, welche NT zur Verfügung steht.

Beispiel:

Sollte TwinCAT eine konstante Auslastung von 35% der CPU benötigen (siehe Einstellungen in "Echtzeiteinstellungen"),

und ein weiterer Prozess im NT-Task-Manager mit 97% "CPU-Zeit" angezeigt werden,

so würde dieser Prozess eigentlich 63,05% der wirklichen CPU Zeit verbrauchen.


Echtzeit - Prioritäten

TwinCAT System Manager: Echtzeit Konfiguration

Echtzeit Konfiguration - Prioritäten

Zusätzlich zu Einstellungen und Online, enthält der Bereich Echtzeit-Konfiguration im TwinCAT System Manager auch einen Dialog, welcher die Prioritäten der verschiedenen Tasks darstellt. Bei Aktivierung des Experten Modus ist es sogar möglich, die Prioritäten der verschiedenen Tasks manuell zu ändern. Eine Task ist von höherer Priorität, je kleiner die angegebene Zahl ist.

Karteireiter "Priorities"

Priorität

Priorität der jeweiligen Task im TwinCAT System. Außerdem wird in dieser Spalte die Taskart durch unterschiedliche Icons differenziert. Siehe hierzu auch die Erläuterungen zur Spalte Task. Je kleiner die hier angegebene Zahl ist, desto höher ist die Priorität der Task innerhalb des TwinCAT Systems.

Cycle

Zykluszeit der jeweiligen Task in Millisekunden (ms).

Task

Erläutert die Funktion der jeweiligen Task. Bei SPS-Tasks wird zwischen folgenden Taskarten unterschieden:

- SPS Kommunikations-Task: Diese Task, die der ADS-Kommunikation dient, sollte aus Gründen der Datenkonsistenz die niedrigste Priorität (bezogen auf die maximal 6 Tasks eines Laufzeitsystems) haben

- SPS Boost Priority: Priorität einer SPS-Task, sobald diese sich im Monitoring / Debug Modus befindet. Diese Task sollte, aus Gründen der Datenkonsistenz, die höchste Priorität, bezogen auf die Tasks eines Laufzeitsystems, haben

- generellen TwinCAT Task (hellblaues Icon)

- reservierten Prioritäten für mögliche weitere SPS-Tasks (z.B. bisher eventuell im Projekt nicht genutzte Tasks 1, 2 und 3 eines SPS-Laufzeitsystems). Diese erhalten ein hellgraues Icon.

Kommentar

Beschreibt die Herkunft der jeweiligen Task (z.B. SPS-Laufzeitsystem und Projektname).

Show All

Zeigt bei angewählter Checkbox auch nicht verwendete Taskprioritäten in der Auflistung an.

Change Priorities

Ermöglicht bei aktiviertem Show All die Änderung der Prioritäten innerhalb des TwinCAT Gesamtsystems.

Move Up

Bewegt bei aktiviertem Experten Modus die angewählte Task nach oben und macht sie damit höherprior.

Move Down

Bewegt bei aktiviertem Experten Modus die angewählte Task nach unten und macht sie damit niederprior.

PLC Standard

Organisiert die Prioritäten der SPS-Tasks standardmäßig, d.h. so, wie diese auch ohne Eingriff priorisiert sind (alle Tasks des 1. LZS vor den Task-Prioritäten des 2. LZS usw ..).

PLC Optimized

Organisiert die Task-Prioritäten innerhalb des TwinCAT Systems so in ihrer Reihenfolge, dass die hochprioren Tasks der verschiedenen SPS Laufzeitsysteme, jeweils ihrem Boost Priorities folgend, hintereinander gestaffelt werden.

Im folgenden Bild wird diese Einstellung verdeutlicht:


Benutzerdefinierte Tasks - Zusätzliche Tasks

TwinCAT System Manager: Echtzeit Konfiguration

Benutzerdefinierte Tasks (Zusätzliche Tasks)

Übersicht

Zusätzlich zu den jeweils vier konfigurierbaren Tasks in den SPS Laufzeitsystemen unterstützt das TwinCAT System auch weitere (nicht SPS) Software-Tasks, die E/A Variablen besitzen können. Diese Tasks werden im TwinCAT System Manager unter dem Punkt "Zusätzliche Tasks" (unterhalb der "SYSTEM - Konfiguration" in TwinCAT v2.9) verwaltet. Diese Tasks können z.B. benutzt werden, falls keine SPS vorhanden ist. Auf Variablen dieser Tasks kann direkt aus Applikationen wie z.B. dem TwinCAT OPC Server, Visual Basic, Delphi, VB.NET, VC++, C#.NET, etc.. per ADS-OCX, ADS-Dll oder TcADS-DLL zugegriffen werden.

Hinweis:

Einstellungen, die unter diesem Punkt durchgeführt werden, erfordern genauere Kenntnisse des TwinCAT Systems.

Kontext-Menü

Task Anfügen

Fügt eine weitere Task an.

Task Importieren

Integriert eine bereits erstellte und exportierte Task (Dateiendung *.tce) in die bestehende Konfiguration. Siehe Task Exportieren...

Einfügen

Fügt eine weitere Task aus Zwischenablage ein.

Einfügen mit Verkn.

Fügt eine weitere Task mit Verknüpfungen aus der Zwischenablage ein.

Nach Auswahl von Task Anfügen erscheint folgender Dialog:

Der Name sollte hierbei beschreibend gewählt werden. Zusätzlich kann die Aufgabe der benutzerdefinierten Task mit einigen beschreibenden Sätzen unter Kommentar erklärt werden.

Im Baum erscheint danach die zusätzliche Task. Diese enthält automatisch die Unterpunkte Prozessabbild, Eingänge und Ausgänge.

Weitere Informationen zu den Ein- und Ausgängen von Tasks findet man unter: Variablen-Konfiguration.

Kontextmenü "Task"

Bei angewählter Task und Betätigung der rechten Maustaste erscheint folgendes Kontextmenü:

Task Exportieren

Exportiert Task-Konfigurationen mit Unterelementen und Verknüpfungen in eine Datei mit der Endung *.tce . Sie kann so , wie zuvor beschrieben, in andere Projekte importiert werden.

Header Datei Exportieren

Exportiert die konfigurierten Ein- und Ausgangsvariablen der Task in ein C/C++ Header File, zur weiteren Verwendung in TwinCAT Ring 3 I/O Applikationen.

Ausschneiden

Kopiert die Task in die Zwischenablage und entfernt sie aus der aktuellen Konfiguration.

Kopieren

Kopiert die Task in die Zwischenablage.

Disabled

Schließt die aktuelle Task von der Berechnung und Bearbeitung durch das TwinCAT System aus. Konfigurationen und Verknüpfungen bleiben erhalten und werden nach erneuter Betätigung dieser Funktion wieder reaktiviert.

Karteireiter "Task"

Für die Tasks im TwinCAT System existieren verschiedene Einstellmöglichkeiten. Welche Auswirkungen und Funktionen diese Optionen bieten, wird unter Task-Einstellungen erklärt. Nachfolgend sind die Optionen beschrieben, die für typische TwinCAT I/O Applikationen wichtig sind.

Port

Die ADS-Portnummer des jeweiligen ADS Gerätes. Bei der ersten zusätzlichen Task ist dies im Regelfall die Portnummer 301.

Auto-Start

Veranlaßt den TwinCAT System Manager das Start-Kommando für die Task zu erzeugen, so dass beim Neustart von TwinCAT die Task mit den angegebenen Daten automatisch gestartet wird.

Zyklusticks

Die Auffrischungszeit der Task (und damit der eventuell verknüpften Variablen bzw. dem Feldbus an dem sie konfiguriert sind) kann hier konfiguriert werden.

Symbole erzeugen

Sollte man anwählen, um z.B. per TwinCAT OPC Server v4 oder TwinCAT Scope View entsprechend die Symbole (Variablen per deren Namen) vom ADS-Gerät (Port) hochlesen zu können (beim OPC Server muß hierfür AutoCfg Optionstyp = 5 eingestellt sein).

Die weiteren Einstelloptionen werden im Bereich Task-Einstellungen erklärt.

Karteireiter "Online"

Informationen hierzu finden sie unter: Online-Anzeige Taskauslastung.


Task-Einstellungen

TwinCAT ist ein preemptives Multitasking-System. Im Folgenden werden die Einstelloptionen dieser Tasks erklärt. Allerdings sind nicht alle Optionen bei allen Tasks möglich.

Karteireiter "Task"

Die im Folgenden angesprochenen Einstelloptionen sind nicht bei jeder Task aktivierbar.

Taskname

Editiert den internen Namen der Task.

Port

Definiert die AMS-Portnummer der Task. Dieser Wert muss angegeben werden! Bei manchen Tasks ist der Wert allerdings schon voreingestellt (z.B. bei SPS-Tasks).

Auto-Start

Veranlasst den TwinCAT System Manager das Start-Kommando für die Task zu erzeugen, so dass beim Neustart von TwinCAT die Task mit den angegebenen Daten automatisch gestartet wird.

Priorität

Definiert die in TwinCAT gültige Priorität der Task (Es ist darauf zu achten, dass keine Prioritäten doppelt vergeben werden). Die Priorität ist nur dann relevant, wenn Auto-Start angewählt wird.

Zyklusticks

Legt die Zykluszeit in Ticks (abhängig von der eingestellten TwinCAT Basis Zeit) der Task fest. Die Zykluszeit ist nur dann relevant, wenn Auto-Start angewählt wird.

Warnung bei Überschreitung

Veranlasst das TwinCAT System bei Überschreitung der eingstellten Taskzykluszeit eine Meldung abzusetzen.

Messagebox

Gibt die oben genannte Warnung zusätzlich als Messagebox aus.

I/O am Taskanfang

Es wird ein I/O-Zyklus am Taskanfang vorweg ausgeführt.

Disable

Ermöglicht das zeitweise disablen der Task. D.h. die Task wird beim Generieren der E/A Informationen nicht berücksichtigt (z.B. während der Inbetriebnahme). Die durchgeführten Verknüpfungsinformationen bleiben jedoch erhalten.

Symbole erzeugen

Macht es bei entsprechender Aktivierung möglich, auf Variablen der Task per ADS (z.B. aus TwinCAT Scope View) zuzugreifen. Weitere Informationen hierzu findet man unter: Variablen Konfiguration.

Extern synchronisieren

Ist diese Option aktiviert, wird die Task mit einem konfiguriertem Gerät mit Sync-Master Interrupt (z.B. einige SERCOS Karten) synchronisiert.

Karteireiter "Online"

Hier finden Sie Informationen zur Online-Anzeige Taskauslastung.


Online-Anzeige Taskauslastung

Bei geladener aktueller Konfiguration, können unter "Online" die Werte der Taskauslastung grafisch dargestellt werden.

Karteireiter "Online"

Anzeige "CPU"

Zeigt die reine CPU-Zeit, die für die letzte Taskausführung benötigt wurde.

Anzeige "Total"

Gibt die Zeit an, die zwischen Beginn und Ende der Taskausführung vergangen ist. Die Differenz zwischen CPU- und absoluter (totaler) Ausführungszeit, kann z.B. aus einer Unterbrechung der aktuellen, durch höherpriore Tasks bzw. Windows, resultieren.

Überschreitungszähler

Zählt die Anzahl der aufgetretenen Zykluszeitüberschreitungen.

Reset

Setzt den Überschreitungszähler zurück auf 0.

Details zur kontinuierlich fortlaufenden, grafischen Anzeige des aktuellen Online-Wertes finden sie unter: Einstellungen History-Anzeige.


Boot Einstellungen

In diesem Karteireiter werden die Boot- bzw. Auto-Start-Einstellungen für das lokale System oder für das Zielsystem definiert.

Soll TwinCAT beim Systemstart automatisch ein oder mehrere SPS-Programm(e) abarbeiten, müssen zunächst die Anzahl der Laufzeitsysteme festgelegt werden ( siehe SPS Einstellungen) und die Bootprojekte geladen werden.

Auto Boot:

Mit Anwahl des 'Run Modus (Enable)' unter 'Auto-Boot' wird der Systemstart mit einer Benutzer-Anmeldung durchgeführt.

Auto Logon:

Wird zusätzlich die Option 'Auto Logon' gewählt, startet TwinCAT im 'Run-Modus' und die geladenen und freigegebenen Bootprojekte werden selbstständig abgearbeitet.

Hinweis:

Wird per "Remote Desktop" mit einem CX Gerät mit Windows XP embedded gearbeitet, ist die Default Einstellung zu beachten: Default User: Administrator, Default Passwort: 1.


Routing - Einstellungen

Unter TwinCAT 2.9 sind die Routing-Möglichkeiten von TwinCAT erheblich erweitert worden. TwinCAT speichert z.B. die "Routes" nicht mehr in der Windows Registry ab, sondern liest immer den jeweils angewählten Router des gewünschten TwinCAT Zielsystems aus. Die "Routes" werden dabei in sogenannte Aktuelle-, Statische- und Projekt Routes unterteilt. Nach dem Verbindungsaufbau bzw. Auslesen des Routers werden die gefundenen Routes in die Rubrik "Statische Routes" , und automatisch auch immer in den Dialog "Aktuelle Routes", übernommen.

Karteireiter "Aktuelle Routes"

Route

Zeigt den Namen des, am aktuellen TwinCAT Router angemeldeten, möglichen Zielsystems an.

AmsNetID

Zeigt die ADS-AmsNetId des gelisteten Zielsystems an.

Adresse

Nennt die Adresse des gelisteten TwinCAT Zielsystems. Die Adresse ist abhängig vom verwendeten Transportprotokoll. Möglich sind dabei neben TCP/IP-Adressen auch z.B. Adressen von Profibus-Teilnehmern etc., die ihrerseits natürlich das ADS Protokoll unterstützen müssen, um als "Zielsystem" bzw. "Remote-System" angesprochen werden zu können.

Typ

Nennt das Protokoll, welches zur Kommunikation mit dem Zielsystem verwendet wird.

Kommentar

Falls für das jeweilige System konfiguriert, wird hier der Kommentar angezeigt

Anfügen

Ruft den Dialog zum "Anfügen..." weiterer TwinCAT Zielsysteme in die Routing-Tabelle auf.

Löschen

Löscht in der Liste markierte Einträge aus der Routing-Tabelle des lokalen TwinCAT Routers.

Eigenschaften

Ruft den Dialog zur Anzeige der "Eigenschaften" des Zielsystems auf.

Karteireiter "Statische Routes"

Statische Routes sind die Routen, die im aktuell angewählten Router bereits konfiguriert sind. Der System Manager liest bei der Anwahl eines Zielsystem dessen "Routes" aus und stellt sie wie unten dargestellt - und oben bereits beschrieben - dar. Beim Speichern der TwinCAT System Manager Projektdatei, werden diese Statischen Routes mitgesichert. Ein erneutes Laden der *.tsm Datei stellt sie dann wieder zur Verfügung. Ansonsten entsprechen die "Statischen Routes" quasi dem Dialog "AMS Router", wie er in TwinCAT schon immer vorhanden ist.

Die einzelnen Felder und Schaltflächen sind unterhalb von "Aktuelle Routes" beschrieben.

Karteireiter "Projekt Routes"

Die einzelnen Felder und Schaltflächen sind unterhalb von "Aktuelle Routes" beschrieben.


Übersicht

Wenn TwinCAT mit NC-Funktionalität installiert ist (mindestens TwinCAT Level NC-PTP), existiert in der Baumansicht des System Managers ein Punkt "NC-Konfiguration". Hierüber lassen sich die benötigten Achsen anlegen sowie deren Parameter einstellen. Zudem können hier auch, bei gestartetem TwinCAT System, Achsen über entsprechende Online-Dialoge ( NC - Handmenü, Online-Anzeige Achskanal) verfahren werden, sowie weitere Achsfunktionen (manuelle Kopplung, etc..) ausgeführt werden.

NC - Konfiguration | Beschreibung
Tasks | Einstellungen bei NC-Tasks
Kanal | Informationen über Achskanäle
Achsen | Konfiguration der einzelnen Achsen
Kurvenscheiben | Konfiguration von Kurvenscheiben mit dem TwinCAT Kurvenscheibeneditor (TwinCAT Cam Design Tool)
Hydraulik Ventilkennlinien | Konfiguration spezieller Kennlinien für Hydraulikventile mit dem TwinCAT Valve Diagram Editor

Dialog "Allgemein"

Dieser Dialog wird nur eingeblendet, wenn kein Remote-System (siehe: "Auswahl des Zielsystems") angewählt wurde, der System Manager also auf das lokale TwinCAT System eingestellt ist.
Der Inhalt entspricht ansonsten dem nachfolgend beschriebenen Dialog "Version [Zielsystem]".

Dialog "Version [Zielsystem]"

Der nachfolgende Dialog zeigt den, diesem Modul zugrundeliegenden, TwinCAT Server des Zielsystems an. Im dargestellten Fall ist dies die - im Zielsystem aktive - Version 2.9 [Build 531] des TwinCAT NC Servers.


NC-Tasks

Bei Anwahl des Eintrags NC-Konfiguration, können durch rechten Mausklick die beiden NC-Tasks angefügt werden, sofern dies nicht bereits geschehen ist..

Kontextmenü:

Durch Einfügen einer NC-Task wird eine NC-Konfiguration in die aktuelle System-Konfiguration integriert und die entsprechenden Initialisierungsbefehle für den NC-Server erzeugt.
Implizit wird neben der NC-SAF Task (Satzausführung) auch eine NC-SVB Task (Satzvorbereitung) erzeugt. Auf der rechten Seite erscheinen die entsprechenden Dialoge.

Karteireiter "Task"

Weitere Informationen zu diesem Karteireiter findet man unter: Taskeinstellungen.

Karteireiter "Retain"

None

Bei entsprechender Anwahl, wird eine Unterstützung von Retain-Daten (remanente Daten), von dieser Task nicht gefordert.

Store only

Die Retain-Daten werden beim ordnungsgemäßen Herunterfahren des Systems gespeichert.

Load/Store

Die Retain-Daten werden beim Herunterfahren des Systems gespeichert und bei Systemstart geladen.

Karteireiter "Online"

Weitere Informationen hierzu findet man unter: Karteireiter "Online".

NC Prozessabbild

Unterhalb der SAF- und SVB-Tasks gibt es den Eintrag NC-"Taskname" - Prozessabbild. Bei dessen Anwahl werden rechts die Prozessabbild-Dialoge eingeblendet, sowie eine Auflistung aller verknüpften und nicht verknüpften Variablen des Prozessabbildes angezeigt.

NC Kanal "Achsen"

Der Eintrag Achsen wird ebenfalls automatisch angelegt. Bei entsprechender Anwahl in der Baumansicht, wird auf der rechten Seite der allgemeine Dialog zum Objekt angezeigt. Zusätzlich ist hier ein Online Dialog "Achsen" mit den wichtigsten aktuellen Soll- und Istwerten der, unter diesem Kanal konfigurierten, Achsen anwählbar (das System muss dafür natürlich mit der aktuellen Konfiguration gestartet worden sein).


NC Kanal

Eine TwinCAT NC Konfiguration hat mindestens einen, eventuell aber auch mehrere Kanäle. Bei Anwahl des SAF Task-Eintrags in der Baumansicht, kann mit dem nachfolgend beschriebenen Kontextmenü ein Achskanal zugefügt werden.

Kontextmenü:

Kanal Anfügen

Fügt weiteren Achskanal zur Konfiguration hinzu. Nähere Erläuterungen findet man dazu unter NC Kanal Anfügen.

Löschen

Enfernt den aktuell angewählten Kanal aus der Konfiguration.

Kanal Importieren

Importiert eine, im Vorfeld exportierte, Kanalkonfiguration (Endung *.tce) in die aktuelle NC-Konfiguration.

Karteireiter "Allgemein"

Mit dem Eintrag "Achsen" wird automatisch unterhalb des NC-Prozessabbildes ein Achskanal angelegt. Bei entsprechender Anwahl in der Baumansicht, wie im folgenden Bild gezeigt , wird auf der rechten Seite der Dialog "Allgemein" zum Objekt angezeigt. Des weiteren ist ein Online Dialog für den Achskanal vorhanden.

Name

Editierbarer Name des Achskanals.

Id

Identifikationsnummer des Achskanals..

Typ

Typ des Achskanals.

Kommentar

Frei verfügbareres Editierfeld für Bemerkungen. Die EditBox lässt nur Strg+Enter (Ctrl+Enter) für einen Zeilenumbruch zu.

Karteireiter "Online"

Bei den Achskanälen ist ein spezieller Online Dialog mit den wichtigsten aktuellen Soll- und Istwerten der, unter diesem Kanal konfigurierten Achsen, anwählbar (das System muss dafür natürlich mit der aktuellen Konfiguration gestartet worden sein).


Achsen

TwinCAT System Manager: NC Konfiguration

NC Achsen

Nach Anwahl des Achskanals in der Baumansicht und Betätigung der rechten Maustaste, erscheint folgendes

Kontextmenü:

Achse Anfügen

Fügt eine Achse an die Konfiguration an.

Achse Importieren

Ruft Auswahldialog für den Import einer bereits exportierten Achse auf.

Nach dem Öffnen einer Achse in der Baumansicht, sieht man folgendes Bild:

Auf der rechten Seite erscheinen bei Anwahl einer Achse mehrere Dialoge, unter anderem der:

Karteireiter "Allgemein"

Name

Editierbarer Name der Achse.

Id

Identifikationsnummer der Achse. Sie wird unter anderem beim Zugriff auf die Achse, per Funktionsbausteine der SPS, benötigt.

Typ

Typ der Achse. Hier wird unter anderem zwischen kontinuierlichen, virtuellen, Eil-/Schleich-, sowie Schrittmotor-Achsen unterschieden.

Kommentar

Frei verfügbareres Editierfeld für Bemerkungen zur Achse. Die EditBox läßt nur Strg+Enter (Ctrl+Enter) für einen Zeilenumbruch zu.

Symbole Erzeugen

Für den symbolischen Zugriff (per Name) auf die Bestandteile der Achse per ADS (z.B. TwinCAT mit ScopeView), muss das Erzeugen von Symbolen hier angewählt sein.


Achsen - Dialog: Einstellungen

Bei einer neu eingefügten Achse sind vorab einige Grundeinstellungen nötig. Vor allem die Angabe des Achstyps spielt für die weiteren Schritte eine wichtige Rolle.

Achstyp

Hier ist die richtige Verbindungsart (abhängig von der E/A-Konfiguration) der Achse zu definieren. Gemeint ist die Art der Soll- / Istwertübergabe an die Achse bzw. von der Achse.

Verknüpft mit

Hier kann bei manchen Achstypen (AX2000, SERCOS, Profidrive,...) eine Achse komplett mit dem physikalischen Antrieb unterhalb der jeweiligen Feldbus-Karte verknüpft werden. Bei Achsen mit analogem Interface, wie im Beispiel oben eingestellt, müssen die Verknüpfungen bei NC-Encoder sowie NC-Antrieb erstellt werden.

Einheit

Gibt an, in welcher Einheit die Berechnungen und Eingaben zur Achssteuerung erwartet werden. Die Einstellung sollte ist eigentlich immer mm bzw. Grad sein.

Anzeige

Bei geforderter Abweichung von der Standarddarstellung mancher Achswerte, können diese hier aktiviert werden. Dies ist für Position und Geschwindigkeit möglich.

Ergebnis

Hier werden die aktuell eingestellten Einheiten der Achse noch einmal aufgeführt.


Achsen - Dialog: Global

Jede Achse hat betriebsartabhängige Einstellparameter. Diese Basisparameter werden hier unter "Global" festgelegt. Die Werte müssen nach Änderungen mit Enter übernommen werden. Die Eingabe eines Kommas ist nicht möglich, stattdessen muss bei Gleitpunktzahlen ein Punkt verwendet werden.

Maximal erlaubte Geschwindigkeit

Der Wert der, mechanisch oder funktionell, die maximal zulässige Geschwindigkeit der Achse begrenzt.

Überschrift |  |
Wertebereich: | Default: | Einheit:

Eilganggeschwindigkeit

Hier wird der Geschwindigkeitswert für den Eilgang der Achse angegeben.

Wertebereich: Default: Einheit:

Geschwindigkeit Hand Max

Gibt die maximale Geschwindigkeit bei Tippbetrieb (Schnell) an.

Wertebereich: Default: Einheit:

Geschwindigkeit Hand Min

Gibt die Geschwindigkeit bei Tippbetrieb (Langsam) an.

Wertebereich: Default: Einheit:

Geschwind. Ref. in pos. Richtung

Gibt die Geschwindigkeit bei Referenzierfahrt in positiver Richtung an.

Wertebereich: Default: Einheit:

Geschwind. Ref. in neg. Richtung

Gibt die Geschwindigkeit bei Referenzierfahrt in negativer Richtung an.

Wertebereich: Default: Einheit:

BETRIEBSART: Min-Endlagenüberwachung

Hier wird die Endlagenüberwachung (oft auch als Software-Endschalter bezeichnet) der negativen Richtung eingeschaltet und der Grenzwert angegeben.

Wertebereich: Default: Einheit:

BETRIEBSART: Max-Endlagenüberwachung

Hier wird die Endlagenüberwachung der positiven Richtung eingeschaltet und der Grenzwert angegeben.

Wertebereich: Default: Einheit:

BETRIEBSART: Schleppüberwachung Position

Hier wird die Schleppabstandsüberwachung aktiviert, sowie der Grenzwert angegeben. Zusätzlich kann eine Filterzeit angegeben werden.

Wertebereich: Default: Einheit:

BETRIEBSART: Zielpositionsüberwachung

Die Überwachung und Rückmeldung der NC-Achse "Achse in Zielposition" wird hier aktiviert sowie das Zielpositionsfenster angegeben. Zusätzlich wird der Überwachungszeitraum angegeben.

Wertebereich: Default: Einheit:

BETRIEBSART: PEH-Zeitüberwachung

Bei Aktivierung dieser Option, muss die Achse innerhalb der Überwachungszeit die Zielposition erreicht haben, sonst gibt es eine Fehlemeldung.

Wertebereich: Default: Einheit:

Download

Schreibt geänderte (*) und markierte Parameter in das NC Laufzeitsystem hinunter. Für eine dauerhafte Änderung muss die Konfiguration zusätzlich in die Registry geschrieben werden.

Upload

Liest markierte Parameter aus dem NC Laufzeitsystem aus und stellt sie dar.

Select All

"Alles markieren" macht einen kompletten Down- oder Upload der dargestellten Parameter möglich.


Achsen - Dialog: Dynamik

Im TwinCAT System Manager ist eine leicht zu handhabende Einstellmöglichkeit der Dynamik-Parameter implementiert. Es ist sogar möglich, mit einem Schieber die gewünschte Beschleunigungskennlinie zu verändern (bei Aktivierung "Indirekt über Hochlaufzeit"). Auch die direkte Eingabe errechneter Werte ist möglich (Option "Direkt").

Maximalgeschwindigkeit (V max)

Die unter Global eingestellte Maximalgeschwindigkeit der Achse wird hier angezeigt.

Hochlaufzeit

Hochlaufzeit der Achse bis Vmax erreicht ist.

Bremszeit

Zeit, die von Vmax bis zu Geschwindigkeit 0 mm/s benötigt wird.

Beschleunigungskennlinie

Schieber zur indirekten Einstellung der Hochlauf- und Bremszeit.

Beschleunigung

Gibt die Beschleunigung in mm/s² an.

Verzögerung

Gibt die Verzögerung in mm/s² an.

Ruck

Gibt den Ruck an, der für die angestrebte Beschleunigung benötigt wird.


Achsen - Dialog: Funktionen

Gerade in der Zeit der Erstinbetriebnahme von Achsen, ist man auf Hilfsmittel von Seiten der Software oder Hardware angewiesen. Der Vorteil z.B. einer softwaremäßig angesteuerten, direkten Rohwertausgabe an den Antrieb, statt Benutzung eines Batteriekastens, ist klar ersichtlich.

Soll-Position

Neben der Ist-Position (großes Anzeigefeld) wird auch die momentane Soll-Position des Antriebs angezeigt.

Erweiterter Achsstart

Starttyp: Hier wird zwischen relativem, absolutem, Modulo-, etc... Start der Achse unterschieden.

Zielposition: Gewünschte Zielposition der Achse.

Geschwindigkeit: Gewünschte Positioniergeschwindigkeit nach dem Hochlauf der Achse.

Beschleunigung: Falls keine automatisch berechnete Beschleunigung erwünscht ist, kann mit der Checkbox die Annahme des rechts eingegebenen Wertes aktiviert werden.

Verzögerung: Die Checkbox aktiviert die Annahme des rechts eingegebenen Verzögerungswertes, falls dessen manuelle Eingabe gewünscht ist.

Ruck: Die Checkbox aktiviert die Annahme des rechts eingegebenen Wertes für den Ruck (im Beispiel ist noch kein Wert eingegeben).

Start: Startet die Achspositionierung mit den eingegebenen bzw. berechneten Werten.

Stop: Stoppt die Ausführung der Achspositionierung.

Antriebs-Ausgabe

Ausgabeart: Hier ist nur eine prozentuale Ausgabe (z.B. entsprechen 100% = 10V) an den Antrieb auswählbar.

Ausgabewert: Prozentualer Sollwert vom maximal möglichen Ausgabewert der Klemme oder des Mxxxx - Moduls.

Start: Startet die Ausgabe des eingestellten Wertes an den Antrieb. Sicherheitsmechanismen, wie z.B. Software-Endlagenüberwachungen etc.. werden nicht berücksichtigt.

Stop: Stoppt die Ausgabe des eingestellten Wertes an den Antrieb.

Ist-Position setzen

Hier lässt sich manuell die Ist-Position der Achse setzen (als Absolut-, Relativ- oder Modulowert).

Ziel-Position setzen

Mit dieser Funktion lässt sich manuell die Ziel-Position der Achse setzen (als Absolut-, Relativ- oder Modulowert).


Achsen - Dialog: Kopplung

Um das Koppeln der Achsen manuell testen zu können, gibt es im TwinCAT System Manager diesen speziellen Dialog.

Soll-Position

Neben der Ist-Position (großes Anzeigefeld) wird auch die momentane Sollposition des Antriebs angezeigt.

Master/Slave Kopplung

Masterachse: Hier wird die Achse ausgewählt, der die aktuell bearbeitete Achse als Slave folgen soll.

Koppelart: Es sind z.Zt. die lineare Kopplung, sowie die Fliegende Säge als Koppelarten implementiert.

Getriebefaktor: Gewünschtes Verhältnis zwischen Master- und Slave-Geschwindigkeit als reelle Zahl.

Parameter 2-4: Bekommen erst Gültigkeit bei gewählter Koppelart "Fliegende Säge".

Koppeln: Aktiviert die Kopplung von Master und Slave.

Entkoppeln: Versetzt beide Achsen zurück in den eigenständigen Zustand.

Faktor ändern: "On the Fly"-Änderung des Getriebefaktors.

Stop: Bezieht sich auf das Stillsetzen der Achse bei der Koppelart "Fliegende Säge".


Encoder - Dialog: NC-Encoder

Unterhalb der Achsen, in der Baumansicht, gibt es bei Axis_Enc auf der rechten Seite des System Managers einige Einstelldialoge Einer davon ist der Dialog "NC-Encoder", welcher im Folgenden beschrieben ist:

Typ

Hier ist die verwendete Interface-Typ, an der der Encoder der Achse angeschlossen ist, auszuwählen. Folgende Typen werden unterstützt:

Unterstützte Typen | Beschreibung
Simulations Encoder | Zu Simulationszwecken oder als virtueller Encoder kann mit diesem Encoder-Typ eine interne, direkte Soll-/Istwert Rückspeisung eingeschaltet werden. Dieser Encoder-Typ ist per Default eingestellt.
Encoder an M3000 | Als Encoder-Interface wird der Beckhoff Lightbus M3000 Absolut-Encoder eingesetzt.
Encoder an M31x0 / M3200 | Als Encoder-Interface wird der Beckhoff Lightbus M31x0 bzw. M3200 Incremental-Encoder eingesetzt.
Encoder an M2510 | Das Beckhoff Lightbus M2510 Analog Ein-/Ausgabemodul wird bei diesem Encoder-Typ zur Positionsrückmeldung verwendet.
Encoder an KL51x1 | Zur Positionsrückmeldung wird ein KL5101 Incremental Encoder Interface genutzt.
Encoder an KL5001 | Zur Positionsrückmeldung wird ein KL5001 SSI-Geber (absolut Encoder) Interface genutzt.
Encoder an KL5051 / KL2502 | Die bidirektionale KL5051 BI-SSI Interface Klemme wird hierbei zur Positionrückmeldung verwendet. Dies dürfte i.d. Regel bei Digifas 7x00 Antrieben der Fa. Seidel der Fall sein.
Encoder an KL30xx | Ein Kanal der Analog-Eingangsklemme KL30xx dient hier zur Positionsrückmeldung.
Encoder an FOX-50 | Als Interface zur Positionsrückmeldung dient hier ein FOX-50 Modul.
Encoder an SERCOS (Position) | Positionsrückmeldung gemäß SERCOS Spezifikation.
Encoder an SERCOS (Position+Geschw.) | Positions- und Geschwindigkeitsrückmeldung gemäß SERCOS Spezifikation.
Encoder an dig. Eingang (binär) |
Hydraulik-Encoder | Die Kraft aus Pa, Pb, Aa und Ab wird bei dieser Einstellung als Rückmeldung eingespeist.
Encoder an AX2000 | Der Resolver des Motors, bzw. angeschlossene externe Encoder des AX2000-B200 Antriebs, sorgt für die Positionsrückmeldung.
Encoder an ProfiDrive | Positionsrückmeldung gemäß ProfiDrive Spezifikation.
Encoder der NC-Rückwand | Die Beckhoff NC-Rückwand übermittelt hier die Positionierungsdaten.
Encoder (universell einsetzbar) | Universell einsetzbarer Encoder
Encoder an CANopen | Die Positionsrückmeldung erfolgt synchron über die CANopen Feldbusschnittstelle (möglich z.B. mit der FC510x ).

Verknüpft mit

Hier ist die Klemme/das Modul der E/A-Konfiguration auszuwählen, die/welches elektrisch mit dem Encoder der Achse verbunden ist. Es werden nur Klemmen bzw. Module zur Verknüpfung angeboten, die mit dem eingestellten Typ übereinstimmen.

Verknüpfung eines Universal-Encoders

Der Typ Encoder (universell einsetzbar) kann für Geber-Systeme verwendet werden, die in der Typ-Liste nicht aufgeführt sind. In diesem Fall müssen der Zählwert des Gebers manuell verknüpft und der und Wertebereich eingestellt werden. Die Verknüpfung erfolgt direkt über die Input-Variablen des Achs-Encoders

Die Input/Output-Variablen des Encoders haben folgende Bedeutung:

nInData1 - (16 bzw. 32 Bit) Positionswert der Achse in Inkrementen

nInData2 - (16 bzw. 32 Bit) optionaler Latchwert für Messtasterfunktion oder Referenzieren mit Nullimpuls (Referenzmodus: HARDWARE SYNC)

nStatus1 - Status-Byte des Encoders

nStatus2..4 - weitere optionale Status-Bytes des Encoders

nCtrl1 - Control-Byte des Encoders

nCtrl2…4 - weitere optionale Control-Bytes des Encoders

Nach der Verknüpfung des Positionszählwertes mit nInData1 wird in den globalen Encoder-Einstellungen noch der maximale Zählwert bis zum Überlauf festgelegt (Encoder-Maske).

In einigen Fällen enthält das Wort oder Doppelwort des Zählers noch Statusinformationen, die ausgeblendet werden können. Dazu werden die entsprechenden Bits in der Encoder Bit Rejection Filter Mask aktiviert. In den meisten Fällen bleibt diese Maske Null.


Drive - Dialog: NC-Antrieb

Unterhalb der Achsen, in der Baumansicht, gibt es bei xxx_Drive auf der rechten Seite des System Managers einige Einstelldialoge Einer davon ist der Dialog "NC-Antrieb", welcher im Folgenden beschrieben ist:

Typ

Hier wird die Art der verwendeten Sollwertausgabe zum Antrieb ausgewählt. Folgende Typen werden unterstützt:

Unterstützte Typen | Beschreibung
Antrieb an M2400 DAC n | Das Beckhoff Lightbus M2400 Ein-/Ausgabemodul wird zur Sollwertausgabe zum Antrieb verwendet.
Antrieb an KL4XXX / KL2502 | Hierbei bekommt der Antrieb seine Sollwert von einer KL4xxx Analogausgabe Klemme oder von einer Pulsweitenmodulations Klemme KL2502.
Eil-/ Schleich-Antrieb | Der Antrieb kann bei dieser Einstelloption mit einer digitalen Ausgangsklemme mit 2 Geschwindigkeiten angesteuert werden (z.B. Dahlander-Motor, Frequenzumformer,..).
Schrittmotor-Antrieb | Die Sollwertvorgabe dieser sogenannten "Low Cost" Schrittmotor-Achse geschieht über digitale Ausgangsklemmen.
DAC der NC-Rückwand | Ein Digital/Analogkonverter der Beckhoff NC-Rückwand gibt den Sollwert an den Antrieb aus.
Antrieb (universell einsetzbar) | Universell einsetzbare Antriebsschnittstelle.
Antrieb an CANopen | Der Antrieb bekommt seinen Sollwert synchron über die CANopen Feldbusschnittstelle (z.B. möglich mit der FC510x ).

Verknüpft mit

Hier ist die Klemme (inkl. dem richtigen Kanal der Klemme) oder das Mxxxx-Modul der E/A-Konfiguration auszuwählen, die/welches elektrisch mit dem Sollwerteingang des Antriebs verbunden ist. Es werden nur Klemmen/Module zur Verknüpfung angeboten, die mit dem eingestellten Typ übereinstimmen.

Verknüpfung eines universellen Antriebs

Der Typ Antrieb (universell einsetzbar) kann für Ausgabe-Systeme verwendet werden, die in der Typ-Liste nicht aufgeführt sind. In diesem Fall muss der Ausgabewert der Achse manuell verknüpft und skaliert werden. Die Verknüpfung erfolgt direkt über die Output-Variablen des Achs-Drives.

Die Input/Output-Variablen des Antriebs haben folgende Bedeutung:

nOutData1 - (16 bzw. 32 Bit) Positionswert der Achse in Inkrementen

nOutData2 - (16 bzw. 32 Bit) optionaler Geschwindigkeitswert der Achse in Inkrementen

nStatus1 - Status-Byte des Antriebs

nStatus2..4 - weitere optionale Status-Bytes des Antriebs

nCtrl1 - Control-Byte des Antriebs

nCtrl2…4 - weitere optionale Control-Bytes des Antriebs


NC Handmenü

Übersicht

Das Onlinemenü ist das Haupmenü zur Online-Achsbedienung. Hier kann, nach setzen der Freigaben, die entsprechende Achse von Hand verfahren werden. Zusätzlich werden bei aktiver Konfiguration die wichtigsten Achszustände an Hand von Häkchen dargestellt.

Das Menü gliedert sich in Anzeigen, Eingabefelder und Funktionstasten.

Anzeigen

- Ist-Position und Soll-Position,
- Schleppabstand mit Minimal- und Maximalwert seit dem lezten Reset,
- Ist-Geschwindigkeit und Soll-Geschwindigkeit,
- Override in %, Gesamt- und Reglerausgabe in %, Fehlercode,
- Achsstatus:
- Betriebsbereit, Referenziert. In Stillstand (logisch),
- Hat Auftrag, Fährt größer, Fährt kleiner,Gekoppelt, In Zielposition (d.h. im eingestellten Zielfenster für eine voreigestellte Zeit), In Positionsbereich (d.h. im voreingestellten Positionsbereich).
- Freigaben für Regler, Vorschub+, Vorschub-.

Eingabefelder

Teilweise mit Download durch Mausklick auf den rechteckigen Knopf. Nach Drücken dieses Pfeilsymbols wird der Wert des Eingabefeldes in den NC Server übertragen.

Freigabe | Datentyp | Wert | Einheit | Beschreibung
Kv-Faktor | FLOAT | >=0 | [mm/s]/mm | P-Regler Kv-Faktor.
Bezugs-Geschwindigkeit | FLOAT | >0 | mm/s | Bezugsgeschwindigkeit (auch Referenzgeschwindigkeit genannt) bei maximaler Ausgabegröße (z.B. bei 10 Volt).
Zielposition | FLOAT |  | mm | Zielposition wobei der Download die Funktion „Neue Zielposition“ aufruft.
Fahr-Geschwindigkeit | FLOAT | >0 | mm/s | Globale Sollgeschwindigkeit. Ist die Strecke zu kurz um diese Geschwindigkeit erreichen zu können, wird automatisch eine kleinere geeignete Sollgeschwindigkeit berechnet und aktiviert.

Funktionstasten

Taste | Funktion
F1 | Rückwärts fahren mit Geschwindigkeit Hand Max
F2 | Rückwärts fahren mit Geschwindigkeit Hand Min
F3 | Vorwärts fahren mit Geschwindigkeit Hand Min
F4 | Vorwärts fahren mit Geschwindigkeit Hand Max
F5 | Start mit den in den Eingabefeldern gesetzten und den im Menü „Dynamik“ gesetzten Werten
F6 | Stop
F8 | Reset
F9 | Eichen mit den im Menü „Global“ gesetzten Werten. Hinweis: Das Signal einer Referenznocke muss durch die SPS in die Achsdatenstruktur (Axis.PlcToNc.ControlDword.5) eingeblendet werden, damit der mit F9 angestoßene Ablauf auf die Nocke reagieren kann.

„Set“-Fenster

Dieses Fenster erlaubt es – ohne SPS – bestimmt Freigaben und Werte zu setzen. Ist eine SPS aktiv, dann werden die gesetzten Werte i.A, periodisch überschrieben und kommen nicht zur Wirkung.

Freigabe | Datentyp | Wert | Einheit | Beschreibung
Regler | BOOL |  |  | Ohne Reglerfreigabe ist der Regler nicht aktiv und es wird 0 Volt ausgegeben.
Vorschub+ | BOOL |  |  | Ohne Freigabe Vorschub+ kann die Achse nicht in positive Richtung gestartet werden. Fährt die Achse in positive Richtung und wird die Freigabe Vorschub+ weggenommen, dann wird die Achse gestoppt (die Achse fährt nicht wieder an, wenn später die Freigabe wieder gesetzt wird).
Vorschub- | BOOL |  |  | Ohne Freigabe Vorschub- kann die Achse nicht in negative Richtung gestartet werden. Fährt die Achse in negative Richtung und wird die Freigabe Vorschub- weggenommen, dann wird die Achse gestoppt (die Achse fährt nicht wieder an, wenn später die Freigabe wieder gesetzt wird).
Override | FLOAT | >0 | % | Geschwindigkeits-Override in % im Bereich [0.0,100.0] bezogen auf die Sollgeschwindigkeit.


Online-Anzeige Achskanal

Bei gestartetem TwinCAT System und geladener, aktueller Konfiguration, können unter "Online" die Soll- und Ist-Werte des, in der Baumansicht angewählten, Achskanals in Listenansicht angezeigt werden.

Karteireiter "Online"

Name

Zeigt den Achsnamen.

Ist-Position

Gibt die aktuelle Position der jeweiligen Achse an.

Soll-Position

Zeigt die Position an, welche die Achse eigentlich zum aktuellen Zeitpunkt haben sollte.

Schleppabstand

Differenz zwischen der Soll- und Ist-Position.

Fehler

Bei aufgetretenem NC Fehler an einer oder mehreren Achsen, wird dieser hier angezeigt.

-- F1

Mit dieser Schaltfläche kann die Achse im Tippbetrieb schnell in negative Richtung verfahren werden.

- F2

Mit dieser Schaltfläche kann die Achse im Tippbetrieb langsam in negative Richtung verfahren werden.

+ F3

Mit dieser Schaltfläche kann die Achse im Tippbetrieb langsam in positive Richtung verfahren werden.

++ F4

Mit dieser Schaltfläche kann die Achse im Tippbetrieb schnell in positive Richtung verfahren werden.


NC Kanal Anfügen

Nach Aufruf von Kanal Anfügen erscheint folgender Dialog:

Name

Hier editiert man einen geeigneten Namen für den zusätzlichen Kanal.

Typ

Man kann zwischen einem Kanal für Interpolation (TwinCAT Level NC-I) oder FiFo-Achsen auswählen.

Kommentar

Editierbare Kommentarbox. Ein Zeilenumbruch wird hier mit 'Strg'+'Enter' eingeleitet.

Okay

Fügt neuen NC Kanal in die Baumstruktur und damit NC-Konfiguration ein.

Abbruch

Verläßt den Dialog, ohne einen neuen Kanal einzufügen.

Karteireiter "Override"

Nach dem Anfügen eines zusätzlichen Kanals, erscheint auf der rechten Seite, im Unterschied zum Standard-Achskanal, bei beiden möglichen Typen ein Dialog "Override". In diesem Dialog kann man, wie nachfolgend gezeigt, den Kanal-Achsen-Override setzen. Der Kanal-Spindel-Override wird z.Zt. noch nicht unterstützt.

Voller Override kann zusätzlich per Taste "Setze auf 100%" eingestellt werden.


Übersicht

Bei installiertem Nockenschaltwerk (TwinCAT Digital Cam Server), finden Sie im TwinCAT System Manager den zugehörigen Eintrag zu dessen Konfiguration.

Die Erläuterung zu den Einstellparametern ist unter TwinCAT Digital Cam-Server beschrieben.


Übersicht

Wenn TwinCAT mit SPS-Funktionalität (mindestens TwinCAT Level PLC) installiert ist, existiert in der Baumansicht des System Managers ein Punkt "SPS - Konfiguration". Hier lassen sich SPS-Projekte anfügen sowie deren Einstellungen (Nummer des Laufzeitsystems, Port-Nr., Zykluszeiten,...) überprüfen. Zusätzlich können hier auch die Pfad-Einstellungen für das SPS-Projekt angepasst werden.

SPS - Konfiguration | Beschreibung
SPS Einstellungen | Einstellungen zur SPS-Umgebung (Anzahl der Laufzeitsysteme, Handling der persistenten Daten, etc..)
SPS Projekteinstellungen ("IEC1131") | Pfadangaben, etc.. bezüglich des angefügten SPS-Projekts
Prozessabbild | Übersicht der Verknüpfungen von SPS-Variablen mit anderen Prozessabbildern (E/A-Geräte, NC-Variablen, etc..)
Task | Informationen zu den Tasks des angefügten SPS-Projekts

Dialog "Allgemein"

Dieser Dialog wird nur eingeblendet, wenn kein Remote-System (siehe: "Auswahl des Zielsystems") angewählt wurde, der System Manager also auf das lokale TwinCAT System eingestellt ist.
Der Inhalt entspricht ansonsten dem nachfolgend beschriebenen Dialog "Version [Zielsystem]".

Dialog "Version [Zielsystem]"

Der nachfolgende Dialolog zeigt den, diesem Modul zugrundeliegenden, TwinCAT Server des Zielsystems an. Im dargestellten Fall ist dies die - im Zielsystem aktive - Version 2.9 [Build 433] des TwinCAT PLC Servers.


Erzeugen der SPS-Konfiguration

Durch Anwahl von SPS-Konfiguration in der Baumansicht des System Managers und anschließendem rechten Mausklick, öffnet sich das entsprechende Kontextmenü.

Kontextmenü:

IEC Projekt Anfügen

öffnet einen Dialog zur Auswahl und anschließendem Anfügen eines SPS-Projektes in die aktuelle Konfiguration.

Einfügen

Fügt ein SPS-Projekt, welches sich aktuell in der Zwischenablage befindet, in die Konfiguration ein.

Einfügen mit Verkn.

Dieses Kommando verhält sich genauso wie Einfügen, versucht aber zusätzlich vorhandene Variablenverknüpfungen wiederherzustellen.

Karteireiter "IEC61131"

Durch Anfügen eines, im TwinCAT PLC Control ohne Fehler übersetzten und danach gespeicherten Projektes, wird eine SPS-Konfiguration in die aktuelle System-Konfiguration integriert und die an Adressen lokierten E/A-Variablen eingelesen. Bei Anwahl des angefügten SPS-Projektes im Baum, erscheint auf der rechten Seite der dazugehörige Dialog IEC61131.

Projekt

Zeigt den Namen des jeweils angewählten SPS-Projektes.

Pfad

Definiert den Pfad des jeweiligen SPS-Projekts. Dieser Pfad zeigt auf das aktuell bearbeitete SPS-Projekt.

Hinweis:

Der Pfad zeigt auf eine *.tpy Datei. Dateinamen mit der Endung *.tpy sind XML-Dateien, welche Informationen über die im SPS Projekt vorhandenen und an Adressen gebundenen Variablen und deren zugrundeliegenden Datentypen sowie allgemeine Projektinformationen beinhalten.
Neu hinzugekommen sind die ebenfalls je Projekt einmalig vorhandenen, und ebenfalls XML basierten *.tpa Dateien, welche die letztendlich aufgelösten Adressen aus eventuellen Variablen_Konfigurationen oder Globale_Variablen-Listen mit entsprechend lokierten Variablen (%I* bzw. %Q*) bereithalten. Angezeigt werden die zugewiesenen Adressen im Bereich Resourcen | "TwinCAT_Configuration (VAR_CONFIG)" im TwinCAT PLC Control.

Laufzeit-Nr.

Gibt das Laufzeitsystem an, für welches das angewählte SPS-Projekt konfiguriert ist. Einstellungsänderungen können unter

Online-Einstellungen im TwinCAT PLC Control vorgenommen werden.

Port

Definiert die AMS-Portnummer des Laufzeitsystems. Die angezeigte Nummer ist abhängig von der oben beschriebenen Laufzeit-Nr.

Zielsystem

Definiert das Zielsystem, für welches der jeweilige SPS-Code generiert wurde. Läuft die SPS auf dem PC, so wird i386 Code erzeugt.

I/O am Taskanfang

Es wird ein I/O-Zyklus am Taskanfang ausgeführt. Damit erhält man ein jitterfreies, von der Laufzeit der Task unabhängiges, Abtasten der E/A (ist bei SPS-Konfigurationen normalerweise nicht aktiviert).

Task Zykluszeiten werden in Ticks interpretiert

Diese Checkbox ist in der Regel deaktiviert. Sie wird nur benötigt, wenn die Basiszeit von dem standardmässig voreingestellten Wert von 1ms abweicht. Dies ist beispielsweise der Fall, wenn SPS Task-Intervalle kleiner 1ms gewünscht sind.

Neu Einlesen

Liest die aktuelle SPS-Konfiguration erneut ein. Geänderte Konfigurationen (z.B. neue E/A-Variablen) erscheinen dann im System Manager-Konfiguration.

Ändern

Mit diesem Kommando kann der Pfad für das SPS-Projekt angepasst werden. Dies ist nötig, falls sich der Ablageort des Projektes geändert hat oder man ein anderes SPS-Projekt als aktives Projekt auswählen möchte.

SPS-Konfiguration - Prozessabbild

Unterhalb des SPS-Projektnamens erscheint ein Eintrag 'Projektname'-Prozessabbild (wie im Bild unten zu sehen). Nähere Informationen hierzu, findet man unter: Prozessabbilder.

SPS- Konfiguration - Taskinformationen

Wenn der Baum unterhalb des Prozessabbildes wie unten dargestellt geöffnet wird, sieht man die Namen der, im SPS-Projekt konfigurierten, Tasks. Auf der rechten Seite im System Manager erscheint der dazugehörige Dialog, siehe Task-Einstellungen.

Da ein SPS-Projekt aus bis zu 4 Tasks bestehen kann, sind bei entsprechenden Multitasking-Projekten im Baum mehrere Tasknamen angegeben, wie untenstehende Grafik mit den beiden Tasks 'Standard' und 'FastTask' verdeutlicht.

Die Ein- und Ausgangsvariablen sind nach Einlesen des SPS-Projektes immer der ersten Task zugeordnet, können aber z.B. per Drag&Drop, auch anderen Tasks zugeordnet werden. Dies bedeutet, dass die Werte der Variablen, abhängig von den jeweils eingestellten Taskzykluszeiten, aufgefrischt werden.

Bei Anwahl einer Ein- oder Ausgangsvariablen kann diese entweder mit dem Kontextmenü, oder dem, auf der rechten Seite erscheinenden Dialog, per Variablenverknüpfung verknüpft werden.

Erweiterte Verknüpfungsmöglichkeiten

Hier sind erweiterte Verknüpfungs- und Dokumentationsfunktionen für Variablenlisten beschrieben.


SPS Einstellungen

Im System Manager-Menü 'SPS-Konfiguration' unter der Registerkarte 'SPS Einstellungen', werden die Einstellungen zur SPS Umgebung vorgenommen.

Anzahl Laufzeitsysteme:

Sie können die Anzahl der zur Verfügung stehenden Laufzeitsysteme festlegen.
Hier konfigurieren Sie ebenfalls, welches Laufzeitsystem ein Boot-Projekt aufnehmen soll.

Boot Projekt

Für jedes Laufzeitsystem kann separat das Laden eines Bootprojekts aktiviert werden. Durch einen Mausklick auf die entsprechende Zeile wird das Bootprojekt eines Laufzeitsystems aktiviert oder deaktiviert. Zum Erzeugen eines Bootprojekts starten Sie bitte das TwinCAT PLC Control, im Online-Menü finden Sie die Anwahl "Erzeugen eines Bootprojekts".

Laden/Speichern der Retain Daten

Falls ein Bootprojekt für ein Laufzeitsystem angewählt ist, können für dieses Laufzeitsystem auch remanente Daten geladen bzw. geschrieben werden. Diese Option kann über die Auswahlbox an- bzw. abgewählt werden.


Übersicht

Ein wichtiger Bestandteil des TwinCAT System Managers ist die E/A - Konfiguration. Die geringste Ausbaustufe von TwinCAT ist TwinCAT Level I/O), d.h. es existiert in der Baumansicht des System Managers in jedem Fall ein Punkt "E/A-Konfiguration". Nachdem die jeweiligen Konfigurationen der verschiedenen Tasks durchgeführt wurden und dem System Manager damit alle relevanten Variablen bekannt sind, ist die Hardware (in der Regel ein Feldbus mit E/A-Modulen) unter dieser Rubrik zu konfigurieren. Alternativ kann die E/A-Konfiguration natürlich auch vorab durchgeführt werden, mit anschliessender Konfiguration der anderen Tasks des Systems (z.B. der SPS Tasks).

E/A - Konfiguration | Beschreibung
E/A Geräte | Im Zielsystem (lokal oder Remote) konfigurierte Ein- und Ausgabegeräte (Feldbuskarten, NOVRAM, Systemschnittstellen,..) und deren Prozessabbilder
Zuordnungen | Informationen über die Zuordnungen (Mappings) zu anderen TwinCAT Geräten bzw. deren Prozessabbildern

Dialog "Allgemein"

Dieser Dialog wird nur eingeblendet, wenn kein Remote-System (siehe: "Auswahl des Zielsystems") angewählt wurde, der System Manager also auf das lokale TwinCAT System eingestellt ist.
Der Inhalt entspricht ansonsten dem nachfolgend beschriebenen Dialog "Version [Zielsystem]".

Dialog "Version [Zielsystem]"

Der nachfolgende Dialog zeigt den, diesem Modul zugrundeliegenden, TwinCAT Server des Zielsystems an. Im dargestellten Fall ist dies die - im Zielsystem aktive - Version 2.9 [Build 418] des TwinCAT IO Servers.


Anfügen eines E/A-Gerätes

Durch rechten Mausklick auf E/A-Geräte öffnet sich folgendes Kontextmenü:

Gerät Anfügen

Ruft den Auswahldialog für die unterstützten Feldbuskarten und andere Hardware-Geräte (wie z.B. allgemeine PC-Schnittstellen) auf.

Gerät Importieren

Integriert bereits erstellte und exportierte E/A-Geräte Konfigurationen in das aktuelle System Manager Projekt.

Geräte Suchen

Scannt den PC nach unterstützten Geräten ab. Gefundene Geräte werden dann in der Baumansicht unterhalb von "E/A Geräte" aufgelistet.
Ab TwinCAT 2.9 muß sich das angewählte Zielsystem für diese Funktion im Konfig-Modus (Config-Mode) befinden.

Einfügen

Fügt ein weiteres Gerät an aktueller Stelle (vor markiertem Gerät) in die Konfiguration ein.

Einfügen mit Verkn.

Macht dasselbe wie Einfügen, übernimmt allerdings bereits bestehende Variablenverknüpfungen aus der importierten Datei.

Auf der rechten Seite in der System Manager-Ansicht erscheint nach dem Einfügen eines Gerätes ein Dialog mit Eigenschaftsseiten.

Weitere Informationen zum Karteireiter "Allgemein": Karteireiter "Allgemein" .

Weitere Informationen zu E/A-Geräten: Referenz | E/A-Geräte.
Die aktuellen Werte im Dual-Ported-Memory können per Karteireiter DPRAM (Online) online beobachtet werden.

E/A Geräte - Prozessabbild

Unterhalb des Gerätenamens erscheint ein Eintrag 'Gerätename'-Prozessabbild. Nähere Informationen hierzu, findet man unter: Prozessabbilder.

E/A Geräte - Status- und Control Informationen

Nach Öffnen des Baumes unterhalb des E/A-Gerätes, findet man die Status- und Control-Informationen des jeweiligen Gerätes:

Dies sind Eingangs- und Ausgangsvariablen, die standardmäßig, z.B. mit passenden SPS-Variablen, verknüpft werden können und damit den Status des Gerätes zum SPS-Laufzeitsystem melden können. Weitere Informationen zum Thema Verknüpfungen findet man unter: Variablen Verknüpfungen.

Anfügen von Ein-/Ausgabemodulen

Die Beschreibung zur Auswahl und Konfiguration der verschiedenen E/A-Module (Boxen) finden sie unter: "Anfügen von E/A-Modulen (Boxen)".


Feldbuskarten Auswahl

TwinCAT System Manager: E/A - Konfiguration

E/A-Geräte - Auswahl

Nach Anwahl von Gerät Anfügen... erscheint der folgende Auswahldialog für die spezifischen E/A-Geräte (verschiedene Feldbuskarten, spezifische Beckhoff Hardware, diverse PC-Schnittstellen, etc..):

In der Baumansicht des Auswahldialogs werden alle in Frage kommenden E/A-Geräte, hier gerade z.B. einen EtherCAT-fähigen Ethernet-Port (siehe auch Auflistung: E/A-Geräte im Bereich Referenz), angeboten.

Typ

Bietet eine Auflistung der von TwinCAT unterstützten Feldbusprotokolle und dazugehörigen E/A-Geräten (Feldbuskarten) an.

Name

Hier kann der Bezeichner in der Baumansicht für das gewählte Geräte nach eigenen Vorstellungen editiert werden.

Zielsystem

Bietet dem Nutzer einen Auswahlfilter zur Einschränkung der Anzeige auf nur solche E/A-Geräte an, welche auch von der aktuell vorhandenen Beckhoff Zielplattform unterstützt werden. Standardmässig werden allerdings alle E/A-Geräte angezeigt.

Okay

Bestätigt die Auswahl des E/A-Gerätes und schließt den Dialog. Alternativ kann auch ein Doppelklick verwendet werden.

Abbruch

Schließt den Dialog, ohne ein E/A-Gerät in die Baumansicht - und damit in die aktuelle Konfiguration - zu übernehmen.


Anfügen von Ein-/ Ausgabe-Modulen (Boxen)

Unterhalb der konfigurierten Feldbuskarten werden nun die verschiedenen Ein- und Ausgabemodule (Boxen) angefügt und konfiguriert, bzw. mit den Variablen der SPS-Projekte oder anderen Laufzeitsystemen (z.B. einer Zusätzlichen Task) verknüpft.

Durch einen rechten Mausklick auf das konfigurierte E/A-Gerät (im Beispiel eine Beckhoff FC200x Lightbus PCI Karte) öffnet sich ein Kontextmenü. Wie der Name sagt, ist dieses Menü kontextabhängig, d.h. für unterschiedliche Feldbuskarten sind oft auch unterschiedliche Kontextmenüs vorhanden. Bei der folgenden Beschreibung werden daher nur die gemeinsamen Menüeinträge behandelt, detaillierte Geräte-Informationen entnehmen Sie bitte der Technischen Referenz.

Box Anfügen

Ruft, abhängig von dem konfigurierten Feldbus-System, den Auswahldialog für die unterstützten E/A-Module auf.

Gerät Löschen

Löscht das E/A-Gerät aus der Baumansicht und damit aus der Konfiguration.

Online Reset

Führt einen I/O-Reset auf der Karte aus. Dies ist natürlich nur bei aktiver Konfiguration und laufendem System möglich.

Gerät Exportieren

Sichert die gesamte Konfiguration (mit bereits angefügten Boxen) des angewählten Gerätes in eine Export-Datei.

Box Importieren

Integriert eine bereits konfigurierte und exportierte Feldbusstation in das aktuelle System.

Ausschneiden

Kopiert das aktuelle E/A-Gerät in die Zwischenablage und entfernt es aus der E/A-Konfiguration.

Kopieren

Kopiert das aktuelle E/A-Gerät in die Zwischenablage.

Einfügen

Fügt ein weiteres Gerät aus Zwischenablage an aktueller Stelle (vor markiertem Gerät) in die Konfiguration ein.

Einfügen mit Verkn.

Macht dasselbe wie Einfügen, übernimmt allerdings bereits bestehende Variablenverknüpfungen, wenn möglich.

Disabled

Nimmt die markierte Box aus der aktuellen Berechnung der Konfiguration heraus. Die Konfiguration der deaktivierten Station bleibt inklusive der Verknüpfungsinformationen erhalten und kann daher jederzeit durch nochmaliges Betätigen von Disabled reaktiviert werden. Diese Funktion ist u.a. zum Inbetriebnehmen von einzelnen Anlagenteilen vorgesehen.


Box-Auswahl

TwinCAT System Manager: Auswahl E/A-Modul

Box Auswahl

Nach Anwahl von Box Anfügen... erscheint, abhängig vom gewählten Feldbussystem (hier Beckhoff Lightbus), ein Auswahldialog für die spezifischen E/A-Modul

In der Baumansicht des Auswahldialogs werden alle in Frage kommenden E/A-Module, hier Module für Beckhoff Lightbus (siehe auch Technische Referenz ), angeboten. Teilweise sind diese zur besseren Übersicht nach Herstellern geordnet.

Die Feldbussysteme Profibus und DeviceNet unterstützen eine E/A-Konfiguration über mitgelieferte (oder von der jeweiligen Hersteller gelieferte) Beschreibungs-/Konfigurationsdateien. Das Einfügen solcher GSD/GSE- bzw. EDS-Boxen, wird unter Einfügen von Fremdgeräten beschrieben.

Typ

Zeigt die in Frage kommenden E/A-Module. Dies können kompakte oder modulare E/A-Geräte sein, sowie Antriebe mit digitalem Interface (wie im Beispiel der AX2000 Antrieb).

Name

Hier kann der Bezeichner für das gewählte Modul editiert werden.

Okay

Bestätigt die Auswahl des Moduls und schließt den Dialog. Alternativ kann auch ein Doppelklick verwendet werden.

Abbruch

Schließt den Dialog, ohne ein Modul in den System Manager einzutragen.


GSD- und EDS-Boxen anfügen

Bei den Feldbussystemen Profibus und DeviceNet gibt es gerätespezifische Konfigurationsdateien, die vom Hersteller der jeweiligen Hardware zur Verfügung gestellt werden. Sie dienen zur Einbindung dieser Fremdgeräte in beliebige Steuerungssysteme, welche den jeweiligen Feldbus unterstützen. Bei Profibus werden sie als GSD (Geräte-Stamm-Daten) und bei DeviceNet als EDS (Electronic Data Sheet) -Dateien bezeichnet.

Nach Anwahl von Box Anfügen... erscheint, abhängig vom gewählten Feldbussystem (hier Profibus), im Baum unter Verschiedenes ein Auswahldialog für 'Generic (Allgemeine) Profibus Box.(GSD)'.

Bei DeviceNet würde hier dementsprechend 'DeviceNet Node (EDS)' erscheinen.

Danach erscheint dann ein Windows-Dialog zur Auswahl der jeweiligen Datei.

Im oberen Bild stehen GSD Dateien, die der Hersteller dieser Box zur Verfügung stellt, zur Auswahl. Nach der Selektion den Öffnen Button betätigen, um das Gerät in die System Manager Konfiguration aufzunehmen.

Wichtig:
Für die GSD bzw. EDS-Dateien sind die Hersteller der jeweiligen Hardware zuständig, d.h. die Beckhoff Automation GmbH stellt keine GSD/GSE (Geräte-Stamm-Daten in englischer Sprache) und EDS-Dateien für Fremdgeräte zur Verfügung oder übernimmt Gewähr für deren Funktion.

Gerätebeschreibung

Durch den spezifizierten Aufbau der GSD/GSE- bzw. EDS-Dateien (spezifiziert durch die jeweiligen Nutzerorganisationen (PNO bzw. ODVA)), ist es dem TwinCAT System Manager möglich die Geräteinformationen (Hersteller, Gerätetyp, ..) auszulesen und darzustellen. Dies geschieht im rechten Dialog Allgemein bei angewähltem Gerät im Baum.

Innerhalb dieses Dialoges findet man den Gerätenamen, den Typ, Hersteller und die Revisionsnummer der GSD/GSE bzw. EDS-Datei. Vor allem letztere könnte sich bei Unstimmigkeiten als wichtig erweisen.
Zusätzlich gibt es eine "Checkbox" zum disablen des Gerätes, d.h. bei angewählter Option wird das Gerät auf Treiberseite nicht mit in die aktuelle Zusammenstellung des Feldbus-Telegramms aufgenommen, kann aber trotzdem Hardware-seitig in der Konfiguration verbleiben, solange keine Adressüberschneidung mit anderen Geräten vorliegt.

Kompakte und Modulare Geräte

Die eingebundenen Fremdgeräte können kompakt oder modular sein. Bei einem kompakten Gerät ist die Länge der Ein- und Ausgangsdaten, die über den Feldbus übertragen werden, festgelegt. Bei einem modularen Gerät ist die Anzahl der Ein- und Ausgangsdatenbytes des Geräts konfigurierbar. Nähere Informationen findet man dazu in der Technischen Referenz unter Modulare Profibus-Geräte, sowie zu den spezifischen Einstellungen bei oben zu sehendem Karteireiter Profibus unter GSD-Gerät. Beim Feldbussystem DeviceNet findet man die Informationen unter DeviceNet Node.


Anfügen von Busklemmen (KLxxxx)

Unterhalb des konfigurierten Buskopplers werden die verschiedenen Ein- und Ausgangsklemmen angefügt und die Kanäle mit den Variablen der Tasks verknüpft.

Durch einen rechten Mausklick auf die konfigurierte Box (im Beispiel ein Beckhoff BK2000 Buskoppler) öffnet sich folgendes Kontextmenü.

Kontextmenü

Klemme Anfügen

Ruft den Auswahldialog für die verschiedenen Beckhoff Busklemmen auf.

Box Einfügen

Fügt eine Box, vor der im Baum aktuell angewählten (hier Box 1), ein.

Box Löschen

Löscht die Box aus der Baumansicht und damit aus der Konfiguration.

Box Importieren

Integriert eine bereits konfigurierte und exportierte Feldbusstation in das aktuelle System.

Box Exportieren

Sichert die angewählte Feldbusstation in einer Export-Datei (*.tce).

Ausschneiden

Kopiert die aktuell angewählte Feldbusstation in die Zwischenablage und entfernt sie aus der E/A-Konfiguration.

Kopieren

Kopiert die aktuelle Feldbusstation in die Zwischenablage.

Einfügen

Fügt ein weitere Box aus Zwischenablage an aktueller Stelle (vor markiertem Gerät) in die Konfiguration ein.

Einfügen mit Verknüpfungen

Arbeitet identisch wie Einfügen, übernimmt allerdings bereits bestehende Variablenverknüpfungen, wenn möglich.

Deaktiviert

Nimmt die Box aus der aktuellen Systemkonfiguration heraus, ohne sie zu löschen. Die Box kann daher jederzeit wieder aktiviert werden.


Klemmen Auswahldialog

Nach Anwahl von Klemme Anfügen..., erscheint ein Auswahldialog für die verschiedenen Klemmen.

Die Klemmen am Bus Controller (BC) werden unter Klemmen - Auswahl bei Busklemmen Controllern beschrieben.

Einzelheiten zu den verschiedenen Beckhoff Busklemmen-Typen sind unter Klemmen - Technischen Referenz beschrieben.

Name

Hier kann der Bezeichner, der in der Baumansicht erscheinen soll, für die gewählte Klemme editiert werden.

Typ

Zeigt die Liste der verschiedenen Beckhoff Busklemmen, sortiert nach deren Hauptgruppen, an.

Mehrfach

Fügt n Klemmen des gewählten Typs hintereinander in die Konfiguration ein.

Okay

Übernimmt die gewählte Klemme in die Konfiguration.

Abbruch

Schließt den Dialog ohne eine Klemme in die Konfiguration einzutragen.

Weitere Informationen zur Konfiguration der Klemmen im System Manager finden Sie unter: Klemmenspezifische Dialoge


Konfiguration Klemmen

Nach Einfügen der Klemme erscheint diese in der Baumansicht des System Managers. Auf der rechten Seite erscheinen die allgemeinen und klemmenspezifischen Dialoge:

Name

Hier kann der Bezeichner für die gewählte Klemme editiert werden, der dann in der Baumansicht und beim Export von Variablen Informationen erscheint.

Typ

Benennt den gewählten Klemmentyp und dessen Funktion..

Kommentar

Frei editierbarer Kommentar zur verwendeten Klemme (z.B. spezielle, benutzerdefinierte Einstellungen in den Klemmenregistern). Der hier angegebene Kommentar wird bei Konfigurationen unter Busklemmen Controller - Konfigurationen und nachfolgendem Export von Variablen Informationen auch in der globalen Variablenliste des BC angezeigt. Außerdem werden diese Informationen auch bei Import der E/A-Variablen in den TwinCAT OPC Server erscheinen.

Disabled

Setzt den Klemmeneintrag für die aktuelle Konfiguration inaktiv (transparent), d.h. die Klemme fließt nicht mit in die Konfiguration und Berechnung ein.

Variablenverknüpfung - Klemmenkanal-Dialoge

Dieser Bereich ist kontextabhängig, d.h. die Dialogart hängt zum Teil von der ausgewählten Klemme ab. Es gibt zwei Möglichkeiten die Klemmenvariablen mit den Taskvariablen (z.B. Ein-/Ausgänge einer SPS-Task) zu verknüpfen.

1. Möglichkeit

Man öffnet in der Baumansicht die Klemme bis auf die unterste Ebene und wählt die physik. E/A-Variable aus, die man verknüpfen möchte (im Beispiel 'Daten Aus', der Prozessdaten-Ausgang dieser Klemme).

Name

Bezeichner der angewählten physik. E/A-Variable.

Typ

Datentyp der angewählten physik. E/A-Variable.

Gruppe

Der Kanal, zu der die angewählte physik. E/A-Variable gehört.

Größe

Anzahl der Datenbytes dieser physik. E/A-Variable.

Adresse

Offset des Parameters im lokalen Prozessabbild des Kopplers.

User ID

Vom Benutzer definierbare Identifikationsnummer für diese Variable.

Verknüpft m.

Ruft den Auswahldialog zur Variablenverknüpfung auf.

Kommentar

Frei editierbarer Kommentar zur physik. E/A-Variable.

2. Möglichkeit

Man wählt in der Baumansicht die Klemme an und geht dann, im Dialog auf der rechten Seite, auf den gewünschten Kanal. Im Dialog sind alle physik. E/A-Variablen untereinander aufgelistet. Hier kann man die Prozessdatenein- bzw. ausgänge und eventuelle Control/Status-Informationen der Klemme mit Variablen der Tasks verknüpfen (Auswahldialog).

Einzelheiten zu den verschiedenen Beckhoff Busklemmen-Typen sind unter Klemmen - Technische Referenz beschrieben.


Übersicht

Für einige Feldbuskarten (z.B. Ethernet, Profibus und Lightbus) können außer den Standard Ein-/Ausgabe - Modulen (Boxen) auch programmierbare Busklemmen Controller (BC) angefügt werden. Diese Controller enthalten eine Mini-SPS. Bei dieser Geräteart gibt es einige zusätzliche Einstellungen, welche unter Konfiguration Busklemmen Controller beschrieben sind.


Kontextmenü Busklemmen Controller

Unterhalb der E/A-Geräte kann durch einen rechten Mausklick auf die angefügte Box (im Beispiel ein Beckhoff BC3100 Profibus BC) ein Kontextmenü geöffnet werden, welches folgende Einträge enthält:.

Klemme Anfügen

Ruft den Busklemmen Controller-spezifischen Auswahldialog für die verschiedenen Klemmentypen auf.

Export Variablen Info

Hier kann ein Dialog für den Export einer Klemmenkonfiguration aufgerufen werden, um einen späteren Import der Variablenliste in TwinCAT PLC Control zu ermöglichen. Durch diese Vorgehensweise sind die E/A-Variablennamen, Adressoffsets und Kommentare der konfigurierten Klemmen und Datenaustauschvariablen in der globalen Variablenliste des BC nach dem Import bereits richtig vorgegeben. Dies gilt natürlich auch bei Import der entstandenen Datei in den TwinCAT OPC Server.

Klemmenkonfiguration über COMx

Ruft den Auswahldialog zum Laden einer Klemmenkonfiguration in den BC (über die serielle Schnittstelle) auf.

Nicht aufgeführte Menüeinträge sind unter Anfügen von Busklemmen beschrieben.


Klemmen - Auswahldialog bei Busklemmen Controllern

Nach Anwahl von Klemme Anfügen... unterhalb eines Busklemmen Controllers (z.B. BC3100, BC2000 oder BC9000) erscheint ein Auswahldialog für die verschiedenen digitalen, analogen und Sonderklemmen. Das Besondere hierbei ist, dass wie im folgenden Bild zu erkennen ist, alle Klemmen einmal wie bei Buskopplern üblich und zusätzlich auch für die BC SPS als nicht verknüpfbare, und darin lokal benutzte Klemmen, aufgeführt sind.

Einzelheiten zu den verschiedenen Beckhoff Busklemmen-Typen sind unter Klemmen - Technische Referenz beschrieben.

Typ

Zeigt die Liste der verschiedenen Beckhoff Busklemmen, sortiert nach deren Hauptgruppen.
Analog- und Sonderklemmen werden dabei je nach Feldbussystem

kompakt: Die Klemme wird nur mit Ihren Datenbytes, in das Prozessabbild der System Manager-Gerätekonfiguration auf dem PC, eingebunden
komplex: Die Klemme wird mit Daten- und Control/Status-Bytes, in das Prozessabbild der Gerätekonfiguration auf dem PC, eingebunden
PLC - kompakt: Die Klemme nur mit Ihren Datenbytes, und nur für das lokale Prozessabbild des BCs, vorgesehen
PLC - komplex: Die Klemme wird mit Daten- und Control/Status-Bytes, für das lokale Prozessabbild des BCs, vorgesehen

aufgelistet.

Name

Hier kann der Name für die gewählte Klemme editiert werden. Der editierte Name wird auch beim Exportieren der Variablen Info verwendet.

Mehrfach

Fügt n Klemmen des gewählten Typs hintereinander in die Konfiguration ein.

Okay

Übernimmt die gewählte Klemme in die Konfiguration.

Abbruch

Schließt den Dialog ohne eine Klemme in die Konfiguration einzutragen.

Weitere Informationen zur Konfiguration der Klemmen im System Manager finden Sie unter: Klemmenspezifische Dialoge.


Datenaustausch PC / Busklemmen Controller

Bei Busklemmen Controllern können, unterhalb von SPS Variablen, Datenaustauschvariablen (siehe Beispiel in der Baumansicht weiter unten) für die Feldbus-basierende PC zu BC-Kommunikation definiert werden.
Bei Anwahl eines BCs in der Baumansicht des TwinCAT System Managers, erscheint auf der rechten Seite u.a. der folgende BC Mini-SPS-spezifische Dialog:

Dialog "PLC"

PLC Cycle Time

Die reservierte Zykluszeit der Mini SPS. In dieser Zeitspanne werden vom BC keine Daten an den Feldbus übergeben.

Background Time

Zeit für die Bearbeitung der Kommunikation über den Feldbus (u.a. auch Programm Download, Debugging,..).

PLC Var. Offs IN

Startoffset der Datenaustauschvariablen im Eingangsbereich des BC-Prozessabbildes.

PLC Var. Offs OUT

Startoffset der Datenaustauschvariablen im Ausgangsbereich des BC-Prozessabbildes.

AMS Response during download

Kann aus Kompatiblitätsgründen bei alten Busklemmen Controllern (bei BC3100 und BC2000) deaktiviert werden. Neuere Bus Controller Firmware-Stände quittieren den Erhalt einzelner Download-Sequenzen. Daher muss hier die Checkbox aktiviert sein (bei BC9000 in jedem Fall).

Start with Configuration Error

Auch wenn der konfigurierte BC9000 nicht am Netzwerk angeschlossen ist, lässt sich, sofern diese Checkbox aktiviert ist, das TwinCAT System starten.

Retain Data

Store Retain Data: Aktiviert den Support remanenter Daten im Busklemmen Controller.

Size: Größe des remanenten Merkerbereichs innerhalb des Busklemmen Controllers (%Mx0 .. %Mxyy).

KBus Update

Double Cycle:: Aktiviert die Ausführung von I/O-Zyklen (KBus Update) innerhalb der BC-Station vor und nach jedem SPS-Zyklus.

Before PLC: Vor Ausführung des SPS-Zyklus wird ein KBus Update ausgeführt.

After PLC: Nach Ausführung des SPS-Zyklus wird ein KBus Update ausgeführt.

Firmware Update (via COMx)

Das Update einer BC-Firmware kann über diese Funktion ausgeführt werden.

Dialog "Variable"

Nach Anfügen von Variablen, unterhalb des Baumeintrags SPS Variablen, erscheint auf der rechten Seite der zur Variablen gehörende Dialog, wie in der Rubrik Variablen Informationen beschrieben.

Es sollten natürlich sinnvolle Namen für die Datenaustauschvariablen gewählt werden, da sie bei Export von Variablen Informationen als Variablennamen im lokalen BC-Prozessabbild verwendet werden.

Anschließend hat man die Möglichkeit, die Datenaustauschvariablen mit vorhandenen Tasks zu verknüpfen.

Beispielkonfiguration eines BC:

Im folgenden Bild sind sowohl Datenaustauschvariablen, als auch die Feldbus Variablen dargestellt. Der BC verwaltete die Klemmen 4 - 9 lokal.


Beispiel:Globale Variablenlisten

TwinCAT System Manager: Konfiguration Busklemmen Controller

Beispiel: Globale Variablenlisten

TwinCAT PLC Control

Nach Import einer, im TwinCAT System Manager mit Export Variablen Info... exportierten Datei, erscheint unter Ressourcen im Ordner Global_Variables eine Variablenliste mit dem Namen TwinCAT_Import.

Die Variablen setzen sich aus dem, im System Manager konfigurierten, Namen und dem Typ der Klemme, sowie der Kanalnummer und der Bedeutung der Klemmenvariablen zusammen. Die Adresse im lokalen BC Prozessabbild (in IEC61131-3 Notation), sowie der Datentyp der Variablen werden angegeben.

Die Variablen der Zeilen 2 bis 8 sind über den Feldbus zu übertragende Ein-/Ausgangsvariablen (SPS Variablen). Sie dienen zum Datenaustausch zwischen dem BC SPS-Programm und dem übergeordneten Steuerungssystem. Sie können z.B. mit TwinCAT PLC, TwinCAT OPC oder über ADS auf Applikationsebene weiterverarbeitetet werden. Beispielsweise sind die, für das Prozessabbild der Ausgänge deklarierte Austauschvariablen (Zeile 2, 3, u. 4), Eingänge im übergeordneten Steuerungssystem. Die Variablen der Zeile 5 - 8 sind dementsprechend Ausgänge des übergeordneten Steuerungssystems.

Im lokalen BC Prozessabbild fangen die zu übertragenden Austauschvariablen ab dem Offset 128 an (wie im Beispiel zu sehen). Allerdings ist dieser Offset auch in einem System Manager-Dialog einstellbar, falls notwendig.

Einzelheiten zu den verschiedenen Beckhoff Busklemmen-Typen (z.B. Bedeutung der Bezeichnungen Ctrl und State und Data_x) sind unter Klemmen - Technische Referenz beschrieben.


Einstellungen des BC2000

TwinCAT System Manager: Konfiguration Busklemmen Controller

Busklemmen Controller BC2000 im TwinCAT System Manager einbinden

Grundeinstellungen

Im TwinCAT System Manager werden die grundlegenden Eigenschaften des Busklemmen Controllers getätigt.
Die Klemmen des Busklemmen Controllers können direkt dem Lightbus Master oder dem BC2000 zugeordnet werden. Klemmen die dem BC2000 direkt zugeordnet sind, werden im System Manager mit "PLC" dargestellt und sind für den Master nicht sichtbar. Bei den analogen PLC-Klemmen kann noch zwischen "Komplex" und "Kompakt" unterschieden werden.

Komplex: Vollständige Darstellung der analogen Klemmen mit Control/Status, 4Byte Input/Output pro Kanal
Kompakt: Nur Nutzdaten, 2 Byte pro Kanal

Die Klemmen, die man dem Master zuweist, sind für den Busklemmen Controller unsichtbar. Möchte man eine Klemme für beide Systeme sichtbar machen, muss die Klemme erst dem BC2000 zugeordnet werden. Über die SPS Variablen werden die Daten dann von der Klemme zum Master übertragen.

Die Einstellungen für die SPS im Busklemmen Controller findet man unter dem Karteireiter "PLC". Dort werden alle Grundeinstellungen getätigt, die die Eigenschaften der SPS auf dem BC2000 regeln.

PLC Cycle Time

Die PLC Cycle Time bestimmt die Wiederholungssequenz des Programms. Diese Zeit ist nicht deterministisch. Das Bedeutet, wenn das Programm auf dem Busklemmen Controller mehr Zeit benötigt steigt die PLC Cycle Time an. Braucht das Programm unter der Zeit, der Cycle Time wird das Programm mit der eingestellten Cycle Time wiederholt. In der Background Time läuft die Bearbeitung des Lightbusses und der seriellen Schnittstelle. Diese sollte auf ca. 20 % der PLC Cycle Time eingestellt sein.

Beispiel zum Optimieren der Zykluszeit

Um das System zu optimieren misst man die "Mittlere Zykluszeit". Dies finden Sie im PLC Control unter Online\Koppler. Die dort ermittelt Zeit gibt man einen Aufschlag von 20% - 30% und trägt die Zeit als PLC Cycle Time ein. Die Backgroud Time stellt man auf 20% der PLC Cycle Time ein.

PLC Cycle Time = Mittlere Zykluszeit + 20% = 10 ms + 20% = 12 ms

Background Time = PLC Cycle Time * 0,2 = 12 ms * 0,2 = 2,4 ms " 2 ms

Mittlere Zykluszeit

Die gemessenen Zykluszeit beinhaltet auch den K-Bus Update. Daher besteht ein Zusammenhang zwischen der Anzahl der gesteckten Klemmen und der Zykluszeit. Der Busklemmen Controller führt vor dem Programmaufruf einen K-Bus Update aus, um die Eingänge abzufragen. Nach der Programmbearbeitung führt der BC2000 erneut ein K-Bus Update durch, um die aktuellen Ausgänge zu schreiben. Danach folgt die Background Time. Man kann die Zykluszeit verkürzen, in dem man den K-Bus Update für Ein- und Ausgänge gleichzeitig ausführen lässt (siehe K-Bus Update).

SPS Variablen

SPS Variablen sind Variablen, die im BC2000 ab Adresse %IB128 und %QB128 liegen. Diesen Offset kann man Verschieben. Diese Adressen sind keiner Klemme zugeordnet, d.h. es können Signale oder Daten über die SPS Variablen zum Master übertragen oder empfangen werden.

Remanente Variablen

Retain- oder remanente Variablen sind Daten, die bei einem Spannungsausfall den Variablenwert speichern. Im PLC Control werden diese Daten auf den lokierten Merkerbereich gelegt. In der Default Einstellung bedeutet dies, dass alle Variablen von %MB0 - %MB63 RETAIN Daten sind. Die maximale Einstellung beträgt 512 Byte.

K-Bus Update

Double Cycle: Klemmbuseingänge vor dem SPS Zyklus, Klemmbusausgänge nach dem SPS Zyklus

Before PLC: Klemmbuseingänge - und ausgänge vor dem SPS Zyklus

After PLC: Klemmbuseingänge - und ausgänge nach dem SPS Zyklus

Programm-Download über den LWL Ring

TwinCAT bietet die Eigenschaft, das Programm über den LWL Ring auf den BC2000 zu spielen. Dafür muss im System Manager, unter dem Karteireiter ADS/AMS, die String Communication und das Ams/Ads aktiviert sein. Nach dem Sichern der Konfiguration startet man das TwinCAT System. Nun kann im PLC Control das Zielsystem der BC2000 angewählt werden.

Auswahl der Zielplattform:

Beim Neustart des TwinCAT PLC Control fragt das Programm nach der Zielplattform, d.h. auf welchem Gerät der Anwender sein Programm später laufen lassen möchte. TwinCAT bietet zwei Zielplattformen, den PC als Steuerung und den BC2000 Koppler. Für die Programmierübertragung mit dem Busklemmen Controller gibt es wiederum zwei Möglichkeiten. Das "AMS" für die Kommunikation über den Feldbus und die "serielle" Kommunikation über die serielle Schnittstelle des PCs und der Programmierschnittstelle des BC2000.

Auswahl des Zielsystems:

Nachdem das Programm geschrieben wurde, wird unter der Symbolleiste "Online" das Zielsystem ausgewählt. In diesem Beispiel die C1220 mit der Box1 und die Run-Time1 des Busklemmen Controllers.

Programm-Download über RS232 Schnittstelle

Jeder Busklemmen Controller bietet die Möglichkeit, über die RS232 Schnittstelle des PC programmiert zu werden. Dies ist über ein spezielles Kabel realisierbar.

Dafür wird im PLC Control die serielle Schnittstelle angewählt.

Kommunikationsparameter

Unter Online/Kommunikationsparameter findet man im PLC Control die Einstellungen zur seriellen Schnittstelle, Portnummer, Baudrate usw. Der Busklemmen Controller benötigt folgende Einstellung:

Baudrate: 19200

Stop Bits: 1

Parity: Gerade


BC3100 im System Manager einbinden

E/A-Konfiguration:

Im TwinCAT System Manager werden die grundlegenden Eigenschaften des Busklemmen Controllers getätigt.
Die Klemmen des Busklemmen Controllers können direkt dem Profibus Master oder dem BC3100 zugeordnet werden. Klemmen die dem BC3100 direkt zugeordnet sind, werden im System Manager mit "PLC" dargestellt und sind für den Master nicht sichtbar. Bei den analogen PLC-Klemmen kann noch zwischen "Komplex" und "Kompakt" unterschieden werden.
Komplex: Vollständige Darstellung der analogen Klemmen mit Control/Status, 4Byte Input/Output pro Kanal
Kompakt: Nur Nutzdaten, 2 Byte pro Kanal
Die Klemmen, die man dem Master zuweist, sind für den Busklemmen Controller unsichtbar. Möchte man eine Klemme für beide Systeme sichtbar machen, muss die Klemme erst dem BC3100 zugeordnet werden. Über die SPS Variablen werden die Daten dann von der Klemme zum Master übertragen.

Beim Einfügen der SPS Variablen, wird folgendes Fenster geöffnet, welches die Startadresse festlegt.

Die Einstellungen für die SPS im Busklemmen Controller findet man unter dem Karteireiter "PLC". Dort werden alle Grundeinstellungen getätigt, welche die Eigenschaften der SPS auf dem BC3100 regeln.

PLC Cycle Time

Die PLC Cycle Time bestimmt die Wiederholungssequenz des Programms. Diese Zeit ist nicht deterministisch. Das Bedeutet, wenn das Programm auf dem Busklemmen Controller mehr Zeit benötigt steigt die PLC Cycle Time an. Braucht das Programm unter der Zeit, der Cycle Time wird das Programm mit der eingestellten Cycle Time wiederholt. In der Background Time läuft die Bearbeitung des Profibus und der seriellen Schnittstelle. Diese sollte auf ca. 20 % der PLC Cycle Time eingestellt sein.

Beispiel zum Optimieren der Zykluszeit

Um das System zu optimieren misst man die "Mittlere Zykluszeit". Dies finden Sie im PLC Control unter Online\Koppler. Die dort ermittelt Zeit gibt man einen Aufschlag von 20% - 30% und trägt die Zeit als PLC Cycle Time ein. Die Background Time stellt man auf 20% der PLC Cycle Time ein.

PLC Cycle Time = Mittlere Zykluszeit + 20% = 10 ms + 20% = 12 ms

Background Time = PLC Cycle Time * 0,2 = 12 ms * 0,2 = 2,4 ms " 2 ms

Mittlere Zykluszeit

Die gemessenen Zykluszeit beinhaltet auch den K-Bus Update. Daher besteht ein Zusammenhang zwischen der Anzahl der gesteckten Klemmen und der Zykluszeit. Der Busklemmen Controller führt vor dem Programmaufruf einen K-Bus Update aus, um die Eingänge abzufragen. Nach der Programmbearbeitung führt der BC3100 erneut ein K-Bus Update durch, um die aktuellen Ausgänge zu schreiben. Danach folgt die Background Time. Man kann die Zykluszeit verkürzen, in dem man den K-Bus Update für Ein- und Ausgänge gleichzeitig ausführen lässt (siehe K-Bus Update).

SPS Variablen

SPS Variablen sind Variablen, die im BC3100 ab Adresse %IB128 und %QB128 liegen. Diesen Offset kann man Verschieben. Diese Adressen sind keiner Klemme zugeordnet, d.h. es können Signale oder Daten über die SPS Variablen zum Master übertragen oder empfangen werden.

Remanente Variablen

Retain- oder remanente Variablen sind Daten, die bei einem Spannungsausfall den Variablenwert speichern. Im PLC Control werden diese Daten auf den lokierten Merkerbereich gelegt. In der Default Einstellung bedeutet dies, dass alle Variablen von %MB0 - %MB63 RETAIN Daten sind. Die maximale Einstellung beträgt 512 Byte.

K-Bus Update

Double Cycle: Klemmbuseingänge vor dem SPS Zyklus, Klemmbusausgänge nach dem SPS Zyklus

Before PLC: Klemmbuseingänge und -ausgänge vor dem SPS Zyklus

After PLC: Klemmbuseingänge und -ausgänge nach dem SPS Zyklus

Programm-Download über den Profibus

TwinCAT bietet die Eigenschaft, das Programm über den Profibus auf den BC3100 zu spielen. Dafür muss im System Manager, unter dem Karteireiter ADS, Erzeuge Port und NetID aktiviert sein.

Dadurch ändert sich der PLC Karteireiter wie folgt:

Bei größeren Programmen muss AMS Response during download angewählt sein.

Nach dem Sichern der Konfiguration startet man das TwinCAT System. Nun kann im PLC Control das Zielsystem des BC3100 angewählt werden.

Auswahl der Zielplattform:

Beim Neustart des TwinCAT PLC Control fragt das Programm nach der Zielplattform, d.h. auf welchem Gerät der Anwender sein Programm später laufen lassen möchte. TwinCAT bietet zwei Zielplattformen, den PC als Steuerung und den BC3100 Koppler. Für die Programmierübertragung mit dem Busklemmen Controller gibt es wiederum zwei Möglichkeiten. Das "AMS" für die Kommunikation über den Feldbus und die "serielle" Kommunikation über die serielle Schnittstelle des PCs und der Programmierschnittstelle des BC3100. (Zu öffnen unter dem Karteireiter Resourcen -> Steuerungskonfiguration)

Auswahl des Zielsystems:

Nachdem das Programm geschrieben wurde, wird unter der Symbolleiste "Online" das Zielsystem ausgewählt. In diesem Beispiel die FC310x mit der Box1 und die Run-Time BC des Busklemmen Controllers.

Programm Download über die RS232 Schnittstelle

Jeder Busklemmen Controller kann über die RS232 Schnittstelle des PCs programmiert werden. Dies kann mit Hilfe eines speziellen Kabels implementiert werden. Hierzu wird die serielle Schnittstelle in TwinCAT PLC Control angewählt:

Kommunikationsparameter

Die Einstellungen für die serielle Schnittstelle, Portnummer, Baudrate usw. befinden sich unter den Online/Kommunikationsparametern in TwinCAT PLC Control..Der Busklemmen Controller benötigt folgende Einstellungen:

Baudrate: 19200

Stop Bits: 1

Parity: gerade


Zuordnungen

Die erstellten Variablenverknüpfungen der verschiedenen Prozessabbilder können nachträglich in einer grafischen Darstellung kontrolliert werden. Dafür ist unterhalb von E/A-Konfiguration die Rubrik Zuordnungen zuständig.

Kontext-Menü

Durch einen rechten Mausklick auf Zuordnungen, erscheint das dazugehörige Kontextmenü. Bei der Anwahl des Eintrags "Zuordnungen Erzeugen", werden die Kopieraktionen zwischen den konfigurierten Tasks und Geräten neu berechnet.

Zuordnungen Erzeugen

Auf der rechten Seite erscheint der entsprechende Dialog für die erzeugten Zuordnungen, wie im Folgenden zu sehen. Deren Querverweislisten erscheinen bei Anwahl der jeweiligen Gerätezuordnung.

Die Einstellmöglichkeiten im Dialog Querverweise

Adresse A

Zeigt die Adressen der verknüpften Variablen des Prozessabblides A an. Dies sind bei SPS-Tasks (wie im Beispiel der Task Standard des RunningSystem-SPS-Projektes) die Adressen, an denen die Variablen mit %I... bzw. %Q... lokiert wurden. In der Auflistung darunter erscheint bei Anwahl dieser Option die Spalte Adresse. Bei Klick auf die Spaltenüberschrift, werden die Variablen nach ihren Adressen in auf- oder absteigender Reihenfolge sortiert angezeigt.

Adresse B

Zeigt die Adressen innerhalb des Prozessabbildes B an. Prozessabbild B kann eine Task für physik. E/A (im Beispiel eine Task zum Update einer C1220-Karte) oder eine andere verknüpfte Task innerhalb der Systemkonfiguration sein.

Typ(en)

Blendet die Spalte mit den Datentyp-Informationen ein oder aus.

Größe(n)

Blendet die Spalte mit den Informationen zur Bytegröße des jeweiligen Datentyps ein oder aus.

Tausche Abbilder

Vertauscht Prozessabbild A und B in der Auflistung.

Auto Spaltenbreite

Paßt bei langen Variablennamen die Spaltenbreite automatisch an.

Lange Namen

Zeigt die verknüpfte Zielvariable, in deren Spalte mit detaillierten Informationen an (Kopplername, Klemmenname,..).

Kontext - Menü

Bei rechtem Mausklick in das Auflistungsfenster, erscheint das Kontext-Menü für die Dokumentationsfunktionen.

Liste Drucken

Gibt die Liste mit den dargestellten Informationen auf installierte Drucker aus. Weitere Dokumentationsfunktionen finden Sie unter: Erweiterte Verknüpfungsmöglichkeiten.

Liste Kopieren

Kopiert die Liste in die Zwischenablage.

Liste Exportieren

Exportiert die Variablenliste im csv-Dateiformat (durch Komma getrennter Text) zur weiteren Bearbeitung (z.B. mit Tabellenkalkulationen, etc..).

Zuordnungen: Export Verknüpfungsinfo

Dieser Eintrag des Kontextmenüs von Zuordnungen, ruft eine Dateiauswahl Box zum Abspeichern der Verknüpfungsinformationen des aktuellen System Manager Projekts ( XML-Textdatei) auf.

Durch späteren Import dieser Datei, können bei Konfigurationsänderungen oder Verlust der Mappinginformationen die ehemaligen Verknüpfungen wieder hergestellt werden. Für diesen Vorgang dürfen sich die Namen der Variablen natürlich nicht geändert haben.

Falls das Speichern der Verknüpfungsinformationen eines ausgewählten Mappings gewünscht ist, kann dies durch Anwahl der entsprechenden Zuordnung, links in der Baumansicht, geschehen.

Weitere Informationen zu den Zuordnungen der Tasks bzw. Geräte findet man unter: Prozessabbilder. Hier wird unter anderem auch die grafische Darstellung der Verknüpfungen erklärt.


Zuordnungsarten und grafische Darstellung

Unterhalb des Baumeintrags Zuordnungen, gibt es eine Auflistung aller Prozessabbild-Verknüpfungen.

Auf der rechten Seite erscheint der entsprechende Dialog für die angewählte Zuordnung, wie im Folgenden zu sehen.

Zuordnungs-ID

Identifikationsnummer zur internen Verwaltung der verschiedenen Zuordnungen (Mappings).

Zuordnungsname

Nennt die Namen der beiden verknüpften Prozessabbilder.

Zuordnungstyp

Synchron: Ein Prozessabbild ist Master, ein zweites Slave. Der Master gibt die Ausgänge zum Schreiben frei (z.B. auf Feldbuskarte C1220, ..) und schaut ob die Gegenseite mit ihrem I/0-Zyklus fertig ist um die aktuellen Eingänge zu lesen. Die Gegenseite hat dabei keinen eigenen Zeittakt (engl. Timekeeper).

Asynchron: Wird z.B. bei Verknüpfungen von zwei Tasks eingesetzt, oder bei Geräten, die mit eigenem Zeittakt arbeiten (z.B. COM-Port) und damit die Auffrischung von Ein- und Ausgängen selbständig regeln. Der Austausch der Informationen zwischen zwei Prozessabbildern geschieht daher beim asynchronen Mapping mit Hilfe des Drei-Puffer-Prinzips.

Bei manchen Gerätetypen (z.B. die Multitasking-fähige Profibuskarte FC310x) wird eine Mischform aus synchroner und asynchroner Zuordnung (Mapping) verwendet. Die Task mit der höheren Priorität verhält sich daher synchron, die niederpriore asynchron zum Gerät.

Watchdog

Beim asynchronen Mapping (siehe Zuordnungstyp) kann es passieren, dass sich eine Task nicht mehr korrekt beendet wird (Endlosschleife), die andere Task aber weiterbearbeitet wird und daher immer ständig alte Werte aus den Puffern ausliest. Daher ist hier ein Maximalwert für einen Lebenszykluszähler eingebbar. Wird der Wert erreicht, werden alle Werte der Puffer auf '0' gesetzt.

Zeitmessung

Aktiviert die Zeitmessung bei einer synchronen Zuordnung (siehe Zuordnungstyp).

Prozessabbild A

Hier ist der Taskname, der dem Prozessabbild A zugeordnet ist, eingetragen.

Prozessabbild B

Hier ist der Taskname, der dem Prozessabbild B zugeordnet ist, eingetragen.

Zeige A -> B bzw. B-> A

Vertauscht die Sichtweise auf die beiden Prozessabbilder in der dargestellten Ansicht.

Die Farben grün und rose bedeuten Prozessabbild A und B, die Farben gelb und blau Ein- bzw. Ausgänge des Prozessabbildes. Wenn man mit der Maus auf die Ein- bzw. Ausgänge geht, erscheint ein sogenannter "Tooltip" mit dem Variablennamen.

Kontext-Menü

Bei rechtem Mausklick erscheint das Kontext-Menü zur Einstellung der Zoom-Auflösung des Zuordnungsgraphen. Je höher der eingestellte Pixelwert pro Byte, desto einfacher ist es, die Verknüpfungen einzelner Variablen zu begutachten.

Karteireiter "A -> B" bzw. "B -> A"

Number

Laufende Nummer der Kopieraktionen.

Offset A

Gibt den Offset innerhalb von Prozessabbild A an, von dem die Kopieraktion ausgeht.

Offset B

Gibt den Offset innerhalb von Prozessabbild B an, von dem die Kopieraktion ausgeht.

Size

Länge der zu kopierenden Werte ab jeweiligem Offset (bei Wert 0.1 würde z.B. ein Bit kopiert).

Karteireiter "Online"

Hier findet man, bei aktiver Konfiguration und gestartetem System, eine grafische Darstellung der Zeit (in Nanosekunden), welche für die Kopieraktion von Prozessabbild A nach B, bzw. B nach A aktuell benötigt wird. Dieser Dialog existiert seit TwinCAT 2.8 bei synchronen und asynchronen Zuordnungen (siehe auch "Zuordnungstypen" weiter oben).

Asynchrone Zuordnungen:

Die angegebene Zeit neben

A: A->B bezieht sich auf das Kopieren aller Daten dieser Zuordnung von Prozessabbild A in den Puffer für B.

A: B->A bezieht sich auf das Kopieren aller Daten dieser Zuordnung von Prozessabbild A aus dem Puffer von B.

B: A->B bezieht sich auf das Kopieren aller Daten dieser Zuordnung von Prozessabbild B aus dem Puffer von A.

B: B->A bezieht sich auf das Kopieren aller Daten dieser Zuordnung von Prozessabbild B in den Puffer für A.

Synchrone Zuordnungen:

Die angegebene Zeit neben

A->B bezieht sich auf das Kopieren aller Daten dieser Zuordnung von Prozessabbild A nach B.

B->A bezieht sich auf das Kopieren aller Daten dieser Zuordnung von Prozessabbild A von B.

GetIoState bezieht sich auf die Dauer der Überprüfungsfunktion GetIoState(), die abhängig von der verwendeten Feldbuskarte unterschiedlich aufwendig ist.

StartIo bezieht sich auf die Dauer der Function StartIo(), die den Bus startet und abhängig von der verwendeten Feldbuskarte unterschiedlich aufwendig ist.

Hinweis:

Alle Zeiten werden als Differenzzeiten zwischen Beginn und Ende der jeweiligen Aktion gemessen und können daher bei Unterbrechungen stark schwanken.

Details zur kontinuierlich fortlaufenden, grafischen Anzeige des aktuellen Online-Wertes finden sie unter: Einstellungen History-Anzeige.

Busy counter

Bei synchroner Zuordnung von Prozessabbilder schaut das Master-Prozessabbild nach, ob der Slave mit seinem I/O-Zyklus fertig ist und neue Eingänge zur Abholung bereit stehen. Sollte dies nicht der Fall sein, wird der Busy counter durch den Master inkrementiert und in dem oben gezeigten Feld angezeigt. Bei asynchronen Zuordnungen bleibt das Feld leer.

Reset

Setzt den Busy counter zurück auf '0'.


Übersicht E/A-Geräte bei TwinCAT 2.9

TwinCAT System Manager: Reference

Übersicht unterstützter E/A-Geräte bei TwinCAT 2.9

Vom TwinCAT I/O System bzw. dem System Manager werden unter TwinCAT 2.9 folgende E/A Geräte unterstützt:

Beckhoff Lightbus

Beckhoff FC2001 PCI Master-Karte

Beckhoff FC2002 PCI Master-Karte (2-kanalig)

Beckhoff C1220 ISA Master-Karte

Beckhoff C1200 ISA Master-Karte (max. 2 Telegramme)

Beckhoff CX1500-M200 PC104 Master-Anschaltung

Profibus DP / MC

Beckhoff FC3101 PCI Master-Karte

Beckhoff FC3102 PCI Master-Karte (2-kanalig)

Beckhoff CX1500-M310 PC104 Master-Anschaltung

Beckhoff FC310x PCI Slave-Karte

Beckhoff CX1500-B310 PC104 Slave-Anschaltung

Beckhoff BX3100 Slave

Siemens CP5412A2 ISA Master-Karte (FC3100)

Hilscher CIF30-DPM ISA Master-Karte, (FC3000)

Hilscher CIF30-PB ISA Master-Karte, 8k DPRAM (FC3015)

Hilscher CIF50-PB PCI Master-Karte, 8k DPRAM (FC3020)

Hilscher CIF60-PB PCMCIA Master-Karte, 8k DPRAM (FC3060)

Hilscher CIF104-DPM PC104 Master-Karte (2k DPRAM)

Hilscher CIF104-PB PC104-Master-Karte (8k DPRAM)

Beckhoff AH2000 Profibus MC Slave

Siemens IM182 ISA Slave-Karte (SPC3)

Beckhoff FC310x Profibus Monitor, PCI

Interbus

Phoenix IBS ISA SC/I-T ISA Master-Karte

Phoenix IBS PCI SC/I-T PCI Master-Karte

Phoenix IBS ISA SC/RI/RT-LK ISA Master-Karte

Phoenix IBS PCI SC/RI/I-T/RI-LK PCI Master-Karte

Hilscher CIF30-IBM ISA Master-Karte (2k DPRAM)

Hilscher CIF50-IBM PCI Master-Karte (2k DPRAM)

Hilscher CIF60-IBM PCMCIA Master-Karte (8k DPRAM)

Hilscher CIF104-IBM PC104 Master-Karte (2k DPRAM)

Hilscher CIF40-IBSM ISA Master-Karte, 2k DPRAM (FC4000)

Hilscher CIF50-IBS PCI Interbus-S Slave-Karte, 8k DPRAM

CANopen

Beckhoff FC5101 PCI Master-Karte

Beckhoff FC5102 PCI Master-Karte (2-kanalig)

Beckhoff CX1500-M510 PC104 Master-Anschaltung

Beckhoff CX1500-B510 PC104 Slave-Anschaltung

Beckhoff BX-SSB Master

Hilscher CIF30-CAN ISA-Masterkarte (8k DPRAM)

Hilscher CIF50-CAN PCI-Masterkarte (8k DPRAM)

Hilscher CIF60-CAN PCMCIA Master-Karte (8k DPRAM)

Hilscher CIF104-CAN PC104 Master-Karte (8k DPRAM)

Beckhoff FC510x CANopen Monitor, PCI

DeviceNet

Beckhoff FC5201 PCI Master-Karte

Beckhoff FC5202 PCI Master-Karte (2-kanalig)

Beckhoff CX1500-M520 PC104 Master-Anschaltung

Beckhoff FC520x PCI Slave-Karte

Beckhoff CX1500-B520 PC104 Slave-Anschaltung

Hilscher CIF30-DNM ISA Master-Karte, 8k DPRAM (FC5200)

Hilscher CIF50-DNM PCI Master-Karte, 8k DPRAM (FC5250)

Hilscher CIF60-DNM PCMCIA Master-Karte, 8k DPRAM (FC5260)

Hilscher CIF104-DNM PC104 Master-Karte (8k DPRAM)

Beckhoff FC520x DeviceNet Monitor, PCI

SERCOS

Beckhoff FC7501 PCI Master/Slave-Karte

Beckhoff FC7502 PCI-Master/Slave-Karte (2-kanalig)

Beckhoff CX1500-M750 PC104 Master-Anschaltung

Indramat SERCANS PCI SCS-P PCI Master-Karte (FC7550)

Indramat SERCANS ISA SCS-P ISA Master-Karte (FC7500)

Ethernet

Ethernet Miniport (Echtzeit)

Virtuelle Ethernet-Schnittstelle

USB

Virtuelle USB-Schnittstelle

Beckhoff Hardware

Beckhoff CP9030 ISA-Karte für CP-Link (Anschluss von Control Panel), inkl. USV-Unterstützung

Beckhoff CP9035 PCI-Karte für CP-Link (Anschluss von Control Panel), inkl. USV-Unterstützung

Beckhoff CP9040 für CP PC (Control Panel-PC CP71xx)

Beckhoff C1230S ISA-Karte für Sondertasten- und USV-Unterstützung in Beckhoff IPCs

Beckhoff NC-Rückwand

Beckhoff AH2000 Backplane

Beckhoff CX1100-BK Netzteil/Klemmenanschaltung

Beckhoff BX-KBus Interface

Verschiedenes

Serielle COM-Schnittstellen zur Unterstützung von externen USVs, seriellen Buskopplern (BK8x00) oder direkt als serielle Schnittstelle mit einem Protokoll, welches an die KL6xx1 angelehnt ist

Drucker Schnittstelle, Parallelport (LPTx) des PC zur Nutzung als kleines E/A-Gerät

Allgemeines NOV / DP-RAM zur Unterstützung von nichtflüchtigem Speicher bestimmter Beckhoff Feldbuskarten bzw. Unterstützung beliebiger PC-Karten mit DP-RAM Interface.

System Management Bus (SMB) Motherboard-Bus zur Diagnose von Temperaturen und Lüfterdrehzahlen


Beckhoff C1220/FC200x/CX1500-M200

Die C1220 ist eine aktive ISA-Masterkarte für den Beckhoff I/O-Lightbus. Es können bis zu 254 Feldbusboxen in einer Ringstruktur angeschlossen werden. Einzelne Boxen und teilweise einzelne E/A Daten der Boxen können selektiv und prioritätsgesteuert aktualisiert werden. Das DPRAM der C1220 ist vier kByte groß. Es werden keine Interrupts benutzt.

Die FC2001und FC2002 sind PCI-Bus Karten, die sich ansonsten nicht von der C1220 unterscheiden, außer dass die FC2002 zwei Lightbus-Ringe unterstützt. Es sind damit zwei unabhängige C1220-Funktionalitäten auf einer Karte vorhanden.

Die CX1500-M200 ist eine Lightbus Master-Anschaltung für den CX1000 Embedded-PC. Auch sie unterscheidet sich, von der Funktionalität her gesehen, ansonsten nicht von einer C1220.

Kontextmenü

Box Anfügen... <Einfg>

Fügt Beckhoff Lightbus-Boxen an. Die sich ergebende Reihenfolge muss der physikalischen Reihenfolge im LWL-Ring entsprechen. Für eine Liste der unterstützten Beckhoff Lightbus-Geräte schauen sie bitte auf der "Lightbus - Übersicht " -Seite nach.

Gerät Löschen... <Entf>

Entfernt die Lightbus Master-Karte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem LWL-Ring.

Bruchstellentest

Initiiert einen Bruchstellentest auf dem LWL-Ring. Bei einem eventuell unterbrochenem Ring wird die Box-Nummer gemeldet, vor der sich die Unterbrechung aktuell befindet.

Gerät Exportieren...

Exportiert alle Geräteeinstellungen in eine Datei (*.tce), inclusive eventuell vorhandener Mapping Informationen mit Diagnose Eingängen.

Box Importieren...

Importiert bereits vorhandene ("Box") Konfigurationen, inklusive hinzugefügter Busklemmen und verfügbarer Variablen Links.

Boxen scannen

Durchsucht den Bus nach angeschlossenen Lightbus Teilnehmern und eventuell daran angeschlossenen Busklemmen. Gefundene Teilnehmer werden, ihrer Reihenfolge nach, anschließend links in der Baumansicht dargestellt.

Karteireiter „C1220“, "FC200x", "CX1500-M200"

Adresse: (C1220) Hier kann / muss die DPRAM Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert und kann folgende Werte annehmen (dazu die entsprechenden Jumperstellungen der Jumper J1 – J6):

  • 0xC8000 00 1000
  • 0xD0000 01 0100 (Standard)
  • 0xD8000 10 0010
  • 0xE0000 11 0001

    Hinweis:
    Bei der CX1500-M200 Anschaltung wird die Adresse automatisch vergeben bzw. ab Werk voreingestellt.

PCI Slot/Ring: (FC2001/FC2002) Angabe des logischen PCI-Slots und bei FC2002 zusätzlich ob Ring A oder Ring B genutzt wird.

Suchen: Sucht im Rechner vorhandene C1220 bzw. FC2001/FC2002 oder am CX1000 vohandene CX1500-M200 Anschaltungen und stellt die Adresse bzw. Slotnummer entsprechend ein.

Upload: Scannt den Lightbus-Ring nach angeschlossenen Teilnehmern und daran vorhandenen Ein-/Ausgängen ab (siehe hierzu auch Scan Boxes...).

Überprüfe Anzahl der Boxen: Ist diese Checkbox angewählt, wird beim Initialisieren der Karte die physikalisch vorhandene Anzahl von Boxen mit der Anzahl verglichen, die unterhalb dieser Karte im System Manager angegeben ist. Stimmt die Anzahl nicht überein wird ein Fehler generiert.

System Start auch bei LWL-Fehler: Statt den TwinCAT Start abzubrechen wird nur eine Warnung ausgegeben.

K-Bus Update mit Broadcasttelegramm (0x80): Entscheidet, ob bei angeschlossenen Buskopplern das K-Bus Update pro Buskoppler einzeln erfolgt oder per Broadcast-Telegramm gleichzeitig für alle Buskoppler.

Reservierte CDL’s: Die Lightbus Master-Karten besitzen acht Prioritätkanäle (CDL’s), die im Normalfall auch vom System Manager frei benutzt werden. Sollen – in Spezialanwendungen – einzelne CDL’s unbenutzt bleiben, so sind sie hier zu markieren.

Firmware: Gibt die Firmware-Revision einer gefundenen Karte an (bei älteren C1220 wird nur "Found" angegeben).

Auslastung (%): Schätzt die Busauslastung anhand der Auslastung aller erforderlichen CDL's in der Summe ab. Anhand dieses Wertes kann z.B. entschieden werden, ob ein weiterer Ring aufgemacht, bzw. ob mit der triggernden Zycluszeit hochgegangen werden muß.

Karteireiter „DPRAM (Online)“

Siehe unter: „Online – Anzeige des DPRAMs“.

Karteireiter „CDL“

Siehe unter: "CDL - Konfiguration"

Diagnose Eingänge

Die Lightbus Master-Karten verfügen nach dem Einfügen automatisch über Status- bzw. Diagnoseeingangsbytes, die den Zustand der Karte und des LWL-Rings beschreiben:

Variable | Beschreibung
DeviceState | Allgemeiner Status, der nur die Werte 0 (o.k.) und 1 (Fehler) annimmt
DeviceIioFunc | Funktionsnummer, die den Fehler ausgelöst hat (siehe. z.B. Handbuch der C1220)
DeviceIioFuncArg | Funktionsargument (siehe. z.B. Handbuch der C1220)
BoxWithError | Boxnummer des Teilnehmers, bei dem der Fehler aufgetreten ist
ErrorCounter | Zählerstand Summenfehler Die Lightbus-Karte verfügt über mehrere Zähler zur Erfassung von I/O Problemen. Die Zähler sind im DPRAM ab dem Offset 0xEE0 als 16 Bit Werte abgelegt. Es erfolgt keine Überlaufverarbeitung bzw. kein Löschen der Zähler durch die C1220/FC200x. Der Zähler, der die Fehler des internen Adresschecks erfasst (0xEEA) inkrementiert nicht den Summenfehler
ErrCntRec1 | Fehler im Receiver 1 Empfangene Adress- und/oder Control-Bytes sind ungleich der gesendeten Bytes. Receiver 1 alterniert mit Receiver 2, um die Bearbeitungszeit der jeweils zuständigen Interrupt Service Routine (ISR) auszugleichen. Die Fehlerzähler beider Empfänger erhöhen den Summenfehlerzähler (ErrorCounter, siehe oben)
ErrCntRec2 | Fehler im Receiver 2 Empfangene Adress- und/oder Control-Bytes sind ungleich der gesendeten Bytes. Receiver 2 alterniert mit Receiver 1, um die Bearbeitungszeit der jeweils zuständigen Interrupt Service Routine (ISR) auszugleichen. Die Fehlerzähler beider Empfänger erhöhen den Summenfehlerzähler (ErrorCounter, siehe oben)
ErrCntTimeout | Zeitüberlauf bei Telegrammempfang
ErrCntParity | Telegramm mit CRC-Fehler empfangen
AddressCheckErrCnt | Fehler beim internen Adresscheck (DPRAM-Offset 0xEEA). Bei Inkrementierung dieses Zählers wird ein Adresscheck und Count-Telegramm mit logisch falschem Inhalt (AD <> D3) empfangen
AddressCheckModule | Wird in der C1220/FC200x Fehlermaske das Bit 1 gesetzt, enthält diese Zelle die Moduladresse der Box, die den Fehler verursacht hat

Ausgänge

Über den General Control Block (GCB) wird die Kontrolle der Fertigstellung der einzelnen Prozessabbilder abgewickelt. Die Steuerbits, die zur Fehleranalyse vom Anwender beeinflusst werden können, sind nachfolgend beschrieben.

Variable | Beschreibung
GCB-C0 | Ist dieses Bit gesetzt (default), ist der Adresscheck aktiv. Um Parity-Fehler erkennen zu können, muss dieses Bit gesetzt sein
GCB-C1 | Ist dieses Bit gesetzt, ist der Adresscheck auch bei LWL-Fehler aktiv


Hilscher CIFx0-DPM und -PB

Die CIF30-DPM ist eine Profibus ISA-Masterkarte (2kByte DPRAM).

Die CIF104-DPM ist eine Profibus PC104-Masterkarte (2kByte DPRAM).

Die CIF30-PB ist eine Profibus ISA-Masterkarte (8kByte DPRAM).

Die CIF50-PB ist eine Profibus PCI-Masterkarte (8kByte DPRAM).

Die CIF60-PB ist eine Profibus PCMCIA-Masterkarte (8kByte DPRAM).

Die CIF104-PB ist eine Profibus PC104-Masterkarte (8kByte DPRAM).

Kontextmenü

Box Anfügen... <Einfg>

Fügt Profibus Slaves (Boxen) an. Da die Adressierung im Profibus über fest einzustellende Stationsnummern erfolgt spielt die Reihenfolge der angefügten Boxen keine Rolle.

Z.Zt. werden folgende Boxen unterstützt (nähere Beschreibung zu den Boxen folgen weiter hinten):
Unterstützte Boxen | Beschreibung
BK3000 | Buskoppler (max. 1,5 MBaud)
BK3100 | Buskoppler (max. 12 MBaud)
BK3010 | Economy Buskoppler (max. 1,5 MBaud)
BK3110 | Economy Buskoppler (max. 12 MBaud)
BK3500 | Buskoppler (LWL, max. 1,5 MBaud)
LC3100 | Low-cost Buskoppler (max. 12 MBaud)
BC3100 | Buscontroller mit integrierter SPS (max. 12 MBaud)
GSD-Gerät | Allgemeines Profibus Gerät (GSD-Datei des Herstellers erforderlich)

Gerät Löschen... <Entf>

Entfernt die CP5412A2 Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem Profibus.

Karteireiter "CIF x0 DPM / PB"

Adresse: Hier kann / muss die DPRAM Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert und kann folgende Werte annehmen: von 0xC8000 bis 0xEF800 in Schritten von 0x800 (und 0x2000 bei CIF 30-PB)

Suchen: Hierüber können im Rechner vorhandene CIF-30 Karten gesucht werden (nur bei aktivem TwinCAT)

Stations-Nr.: Jeder Profibusteilnehmer benötigt eine eindeutige Stations-Nr. - auch der Master

Baudrate: Hier wird die Profibus Baudrate eingestellt. Es wird automatisch überprüft ob die angeschlossenen Slaves diese Baudrate auch unterstützen

Zyklusticks: Hier wird automatisch die kleinste mögliche Zykluszeit eingestellt, die mit den momentan definierten Slaves möglich ist, sie kann manuell hoch gesetzt werden (in ms)

Syncron Mode.: Die höstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, übernimmt die Ansteuerung des Feldbuszyklus und ist somit mit dem Feldbus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient.

Karteireiter "Profibus"

Siehe unter "Siemens CP5412A2"

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs"


Siemens CP5412 A2

Das DPRAM der CP5412A2 ist 16 oder 64 KByte groß. Es werden keine Interrupts benutzt. Es bestehen keine funktionalen Unterschiede zwischen der 16k und 64k Einstellung. In der Regel ist daher die 16k Einstellung vorzuziehen.

Kontextmenü

Box Anfügen... <Einfg>

Fügt Profibus Slaves (Boxen) an. Da die Adressierung im Profibus über fest einzustellende Stationsnummern erfolgt spielt die Reihenfolge der angefügten Boxen keine Rolle.

Z.Zt. werden folgende Boxen unterstützt (nähere Beschreibung zu den Boxen folgen weiter hinten):
Unterstützte Boxen | Beschreibung
BK3000 | Buskoppler (max. 1,5 MBaud)
BK3100 | Buskoppler (max. 12 MBaud)
BK3010 | Economy Buskoppler (max. 1,5 MBaud)
BK3110 | Economy Buskoppler (max. 12 MBaud)
BK3500 | Buskoppler (LWL, max. 1,5 MBaud)
LC3100 | Low-cost Buskoppler (max. 12 MBaud)
BC3100 | Buscontroller mit integrierter SPS (max. 12 MBaud)
GSD-Gerät | Allgemeines Profibus Gerät (GSD-Datei des Herstellers erforderlich)

Gerät Löschen... <Entf>

Entfernt die CP5412A2 Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem Profibus.

Karteireiter "CP 5412"

Adresse: Hier wird die DPRAM Adresse der Karte eingestellt werden. Diese Adresse wird beim Initialisieren der Karte softwaremäßig eingestellt

HINWEIS:

Bei neueren Motherboard/BIOS kann es nötig werden, den DPRAM-Bereich den die Karte nutzen wird, im BIOS des Rechners zu reservieren. Die entsprechende Enstellung ist meistens im PNP-BIOS aufgeführt und wird als ISA Memblock bezeichnet.

16 / 64kByte: Hier wird eingestellt, ob die Karte 16 oder 64 kByte DPRAM nutzen soll. Es bestehen keine funktionalen Unterschiede zwischen der 16k und 64k Einstellung. In der Regel ist daher die 16k Einstellung vorzuziehen.

Port: Hier wird die Port Adresse der Karte eingestellt, die auf der Karte per DIL-Schalter eingestellt wird. Über den Port wird beim Initialisieren der Karte die oben angegebene DPRAM Adresse eingestellt. Verfügbare Ports (in Hex) sind (dazu die entsprechenden DIL-Schalter 1-4):

  • 240-243 0000 (Standard)
  • 244-247 0001
  • 248-24B 0010
  • 24C-24F 0011
  • 280-283 0100
  • 284-287 0101
  • 288-28B 0110
  • 28C-28F 0111
  • 300-303 1000
  • 304-307 1001
  • 308-30B 1010
  • 30C-30F 1011
  • 390-393 1100
  • 394-397 1101
  • 398-39B 1110
  • 39C-39F 1111

Stations-Nr.: Jeder Profibusteilnehmer benötigt eine eindeutige Stations-Nr. - auch der Master

Baudrate: Hier wird die Profibus Baudrate eingestellt. Es wird automatisch überprüft ob die angeschlossenen Slaves diese Baudrate auch unterstützen

Zyklusticks: Hier wird automatisch die kleinste mögliche Zykluszeit eingestellt, die mit den momentan definierten Slaves möglich ist, sie kann manuell hoch gesetzt werden (in ms)

Syncron Mode.: Die höchstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, übernimmt die Ansteuerung des Feldbuszyklus und ist somit mit dem Feldbus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient.

Karteireiter "Profibus"

Die hier einzustellenden Parameter sind in der PROFIBUS-Norm (DIN 19245 Teil 3 - PROFIBUS-DP), Kapitel 7 beschrieben und sollten nur von sachkundigen Benutzern verändert werden.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs".

Diagnose Eingänge

Die Siemens CP5412A2 verfügt automatisch über zwei Eingangsbytes, die den Zustand der Karte und des Profibusses beschreiben:

DeviceState: Allgemeiner Status, der nur die Werte 0=OK und1=Fehler annimmt

DeviceDpState: DeviceDpState ist ein Flagbyte, die einzelnen Bits haben folgende Bedeutung:

0x00 = No error

0x01 = Transmitter fault

0x02 = Master address fault

0x04 = HSA fault

0x08 = Baudrate fault

0x80 = Temp fault

Hinweis

Wird die CP5412A2 in einem Beckhoff IPC mit 24V-USV und/oder Sondertasten eingesetzt, muss die Portadresse von 0x240 auf einen anderen Wert eingestellt werden, da 0x240 vom IPC belegt ist.


Siemens IM182 - Profibus Slave

Mit Hilfe der Profibus DP - Slave Feldbuskarte kann das TwinCAT System als Slave in einem Profibus eingesetzt werden.
Die Größe des DPRAM beträgt 1536 (0x600) Byte. Es werden keine Interrupts belegt.

Kontextmenü

Gerät Löschen... <Entf>

Entfernt die IM182 Feldbuskarte aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem Profibus.

Karteireiter "SPC3 / IM182"

Adresse: Hier kann / muss die DPRAM Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert

Port: Die Karte belegt einen der beiden Ports 0x320 oder 0x330

Stations-Nr.: Jeder Profibusteilnehmer benötigt eine eindeutige Stations-Nr.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs"

Diagnose Eingänge

Die Siemens SPC3/IM182 verfügt automatisch über ein Eingangsbyte, das den Zustand der Karte und des Profibusses beschreibt:

Flags: Die einzelnen Bits haben folgende Bedeutung:

  • 0x01 = NEW_OUTPUTS
  • 0x02 = CLEAR_MODE
  • 0x04 = NO_DATA_EXCH
  • 0x08 = BAUD_SEARCHING
  • 0x10 = SYNC_MODE
  • 0x20 = FREEZE_MODE

Für den Datenaustausch mit einem Profibus-Master können unterhalb der Ein- und Ausgänge Variablen definiert werden. Diese Variablen werden mit dem Profibus-Master ausgetauscht und können innerhalb von TwinCAT verknüpft werden.
Das Einfügen der Variablen erfolgt analog wie bei den "Zusätzliche Tasks" im Punkt "Einfügen von Variablen"


Hilscher CIFxx-IBM

Die CIF30-IBM ist eine Interbus ISA-Masterkarte.

Die CIF50-IBM ist eine Interbus PCI-Masterkarte.

Die CIF60-IBM ist eine Interbus PCMCIA-Masterkarte.

Die C104-IBM ist eine Interbus PC104-Masterkarte.

Das DPRAM der CIFx0-IBM ist 2 KByte groß (CIF60-IBM 8 KByte). Es werden keine Interrupts benutzt.

Die folgende Beschreibung bezieht sich auf die CIF30-IBM. Die anderen Karten unterscheiden sich aus Sicht von TwinCAT nur durch den Formfaktor.

Kontextmenü

Box Anfügen... <Einfg>

Fügt InterBus Boxen an. Eine detaillierte Liste aller unterstützten Boxen finden sie unter: Übersicht.

Gerät Löschen... <Entf>

Entfernt die CIF40-IBSM Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem InterBus-S.

Karteireiter "CIF-x0 IBM"

Adresse: Hier kann / muss die DPRAM Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert und kann folgende Werte annehmen: von 0xC8000 bis 0xEF800 in Schritten von 0x800

Suchen: Hierüber können im Rechner vorhandene CIF-40 Karten gesucht werden (nur bei aktivem TwinCAT)

Zyklusticks: Hier wird die Zykluszeit eingestellt, mit der der InterBus-S bedient werden soll (in ms)

Syncron Mode.: Die höstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, übernimmt die Ansteuerung des Feldbuszyklus und ist somit mit dem Feldbus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient.

Konfiguration lesen: Um die Konfiguration einlesen zu können muss das System mit einer leeren Konfiguration gestartet werden.

  • Bis TwinCAT 2.9 Build <= 1000: Nach dem Systemstart wird der Button freigeschaltet.
  • Ab TwinCAT 2.9 Build > 1000: TwinCAT muss zuerst im Config-Mode gestartet werden. Nach dem "Neuladen der Konfiguration" kann die Buskonfiguration über die Toolbar-Funktion "Suchen nach Geräten" ausgelesen werden.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs"

Diagnose Eingänge

Die CIF-40 verfügt automatisch über zwei Eingangsbytes, die den Zustand der Karte und des Interbusses beschreiben:

GlobalFlags: Die einzelnen Bits haben folgende Bedeutung:

  • 0x01 = Ctrl: Parametrierungsfehler
  • 0x02 = W1Err: mindestens eine defekte W1-Schnittstelle
  • 0x04 = W2Err: mindestens eine defekte W2-Schnittstelle
  • 0x08 = SysErr: Systemfehler aufgetreten
  • 0x10 = Mod: min. ein Slave meldet Modulfehler
  • 0x20 = Rec: min. ein Slave fordert Rekonfiguration an

ErrorEvent: Der Wert ist abhängig von den GlobalFlags:

Bei W1Err, W2Err, Mod oder Rec wird die Nummer des zugehörigen Slaves angezeigt. Ansonsten gelten folgende Bedingungen:

= 101, SysErr Unterschiede zwischen Konfigurationsliste und vorhandenem Aufbau
= 103, SysErr Netzwerkveränderung während des Busbetriebes
= 104, SysErr Mehrfacher Datenzyklusfehler
= 105, SysErr Zeitüberwachungsfehler
= 106, SysErr Nicht lokalisierbarer Netzwerkfehler
= 108, SysErr Keine Verbindung zum Netzwerk
= 170, Ctrl Kommunikation wurde nicht initialisiert
= 171, Ctrl Zu viele Module (> 112) parametriert
= 172, Ctrl Es sind mehr Module angeschlossen als parametriert
= 173, Ctrl Es sind weniger Module angeschlossen als parametriert
= 174, Ctrl Nicht unterstützter Längencode
= 175, Ctrl Falsch parametrierter Längencode
= 176, Ctrl Falsch parametrierter Identcode
= 177, Ctrl Falsch parametrierte Installationstiefe
= 178, SysErr Anwenderprogramm bediente Watchdog nicht innerhalb der projektierten Zeit
= 180, Ctrl Unbekannter Betriebsmodus
= 181, SysErr Anwenderprogramm hat Datenzyklus nicht quittiert


Hilscher CIF40-IBSM

Die CIF40-IBSM ist eine InterBus Masterkarte.
Das DPRAM der CIF40-IBSM ist 2 KByte groß. Es werden keine Interrupts benutzt.

Kontextmenü

Box Anfügen... <Einfg>

Fügt InterBus-Teilnehmer ("Boxen") an. Eine detaillierte Liste aller unterstützten Boxen finden sie unter: Übersicht.

Gerät Löschen... <Entf>

Entfernt die CIF40-IBSM Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem InterBus-S.

Karteireiter "CIF-40 IBSM"

Adresse: Hier kann / muss die DPRAM Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert und kann folgende Werte annehmen: von 0xC8000 bis 0xEF800 in Schritten von 0x800

Suchen: Hierüber können im Rechner vorhandene CIF-40 Karten gesucht werden (nur bei aktivem TwinCAT)

Zyklusticks: Hier wird die Zykluszeit eingestellt, mit der der InterBus bedient werden soll (in ms)

Syncron Mode.: Die höstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, übernimmt die Ansteuerung des Feldbuszyklus und ist somit mit dem Feldbus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs"

Diagnose Eingänge

Die CIF-40 verfügt automatisch über zwei Eingangsbytes, die den Zustand der Karte und des Interbusses beschreiben:

GlobalFlags: Die einzelnen Bits haben folgende Bedeutung:

  • 0x01 = Ctrl: Parametrierungsfehler
  • 0x02 = W1Err: mindestens eine defekte W1-Schnittstelle
  • 0x04 = W2Err: mindestens eine defekte W2-Schnittstelle
  • 0x08 = SysErr: Systemfehler aufgetreten
  • 0x10 = Mod: min. ein Slave meldet Modulfehler
  • 0x20 = Rec: min. ein Slave fordert Rekonfiguration an

ErrorEvent: Der Wert ist abhängig von den GlobalFlags:

Bei W1Err, W2Err, Mod oder Rec wird die Nummer des zugehörigen Slaves angezeigt. Ansonsten gelten folgende Bedingungen:

=101, SysErr Unterschiede zwischen Konfigurationsliste und vorhandenem Aufbau
=103, SysErr Netzwerkveränderung während des Busbetriebes
=104, SysErr Mehrfacher Datenzyklusfehler
=105, SysErr Zeitüberwachungsfehler
=106, SysErr Nicht lokalisierbarer Netzwerkfehler
=108, SysErr Keine Verbindung zum Netzwerk
=170, Ctrl Kommunikation wurde nicht initialisiert
=171, Ctrl Zu viele Module (> 112) parametriert
=172, Ctrl Es sind mehr Module angeschlossen als parametriert
=173, Ctrl Es sind weniger Module angeschlossen als parametriert
=174, Ctrl Nicht unterstützter Längencode
=175, Ctrl Falsch parametrierter Längencode
=176, Ctrl Falsch parametrierter Identcode
=177, Ctrl Falsch parametrierte Installationstiefe
=178, SysErr Anwenderprogramm bediente Watchdog nicht innerhalb der projektierten Zeit
=180, Ctrl Unbekannter Betriebsmodus
=181, SysErr Anwenderprogramm hat Datenzyklus nicht quittiert


Phoenix IBS SC/I-T

TwinCAT System Manager: Reference

Phoenix IBS SC/I-T und IBS SC/RI/RT-LK

Die IBS ISA SC-I/T ist eine InterBus-S Masterkarte. Die IBS ISA SC/RI/RT-LK ist eine InterBus-S Masterkarte mit zusätzlichem Slave-Interface zur Kopplung an überlagerte Steuerungen über den Interbus (Systemkoppler). Die INTERBUS-Schnittstellen der IBS SC/RI/RT-LK Karte sind in Lichtwellenleitertechnik und bei der IBS ISA SC/I-T in Kupfertechnik ausgeführt.

Das DPRAM (MPM) der IBS ISA SC-I/T und der IBS ISA SC/RI/RT-LK ist 4 KByte groß. Es werden keine Interrupts benutzt.

Kontextmenü

Box Anfügen... <Einfg>

Fügt InterBus-S Boxen an. Eine detaillierte Liste aller unterstützten Boxen finden sie unter: Übersicht.

Gerät Löschen... <Entf>

Entfernt die IBS ISA SC-I/T Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem InterBus-S. Die Karte wird anschließend in den Zustand RUN versetzt (vergl. Bussteuerung).

Karteireiter "IBS ISA SC-I/T " und "IBS ISA SC/RI/RT-LK"

Adresse: Hier kann / muss die DPRAM Adresse der Karte eingestellt werden. Diese Adresse kann folgende Werte annehmen: von 0xC8000 bis 0xEF000 in Schritten von 0x1000

Port: Hier kann / muss die Port Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert und kann folgende Werte annehmen: von 0x100 bis 0x3F8 in Schritten von 0x8

IBS Zyklus: Die Laufzeit des Interbusses wird ungefähr anhand der konfigurierten Geräte berechnet und angezeigt.

Syncron Mode.: Die höstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, übernimmt die Ansteuerung des Feldbuszyklus und ist somit mit dem Feldbus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient.

"Activate_Configuration" beim Startup: Aktiviert die geladene Konfiguration während der Startphase von TwinCAT (Standardeinstellung). Kann abgeschaltet werden, wenn vor der Aktivierung noch andere Firmwaredienste aufgerufen werden (vergl. Systemstart mit unvollständiger Konfiguration).

"Start_Data_Transfer" beim Startup: Startet den zyklischen Datenverkehr auf dem Interbus beim Systemstart von TwinCAT.

Auslesen der Buskonfiguration: Hierüber kann die aktuelle Gerätekonfiguration des Interbusses eingelesen werden. Voraussetzung ist, dass eine TwinCAT-Konfiguration gestartet wird, in der unter der Interbus-Masterkarte keine Geräte konfiguriert wurden!

  • Bis TwinCAT 2.9 Build <= 1000: Das TwinCAT-System wird mit einer Fehlermeldung abbrechen (0 Boxen konfiguriert und x Boxen erwartet. Anschließend wird der Button "Auslesen der Buskonfiguration" freigeschaltet. Hierüber wird die zuvor erkannte Konfiguration im Baum sichtbar.
  • Ab TwinCAT 2.9 Build > 1000: TwinCAT muss zuerst im Config-Mode gestartet werden. Nach dem "Neuladen der Konfiguration" kann die Buskonfiguration über die Toolbar-Funktion "Suchen nach Geräten" ausgelesen werden.

Slave Diagnosis: Diese Option is nur bei den Masterkarten verfügbar die ein zusätzliches Slave-Interface besitzen (Systemkoppler). Es werden dann zusätzlich 2 Eingengswörter mit Slave-Diagnosedaten in die Prozesdaten des Masters gemappt (siehe unten: SlaveDiag und SlaveDiagPara).

Lesen der Firmware Version: Liest über den Firmwaredienst "Get_Version_Info" die Firmware Version der Karte (vergl. Anwenderhandbuch der Karte).

HINWEIS:

Bei neueren Motherboard/BIOS kann es nötig werden, den DPRAM-Bereich den die Karte nutzen wird im BIOS des Rechners zu reservieren. Die entsprechende Einstellung ist meistens im PNP-BIOS aufgeführt und wird als ISA Memblock bezeichnet.

Karteireiter "CFG"

Listet den Konfigurationsrahmen auf, der sich auf Grund der konfigurierten Teilnehmer ergibt und der beim Systemstart in die Karte geladen wird. Dient als Übersicht, insbesondere wenn zur Laufzeit per ADS die Konfiguration beeinflusst werden soll.

Firmwaredienste

Nahe zu alle Firmwaredienste der SC/I-T können per ADS von jedem TwinCAT Programm aufgerufen werden. Dazu muss der SC/I-T ein AMS Port zugewiesen werden. Auf dem Karteireiter "ADS" wird dieser Port aktiviert. Die Portnummer ist fest auf 0x7000 + die ID der SC/I-T vorgegeben. Außerdem wird eine SPS-Bibliothek angeboten, die die wesentlichen Firmwaredienste zur Bussteuerung in einfach nutzbarer Form anbietet.

Karteireiter "ADS"

Über eine AdsReadWriteReq (vergl. ADS Dokumentation) können die Dienste in folgender Form aufgerufen werden:

IndexGroup = 0x00010001

IndexOffset = Code des Firmwaredienstes (z.B. 0x00000713 für Control_Active_Configuration)

Die Parameteranzahl wird automatisch anhand der Write-Daten ermittelt. Die Write-Daten werden von TwinCAT nicht in das Motorola-Format umgesetzt, dieses muss bei Bedarf vom Anwender durchgeführt werden.

In den Read-Daten wird das Ergebnis (die Confirmation) des Firmwaredienstes zurückgegeben.

Beispiel: Abschalten eines Teilnehmers im laufenden Busbetrieb (vergl. Interbus Box - Karteireiter "CAC/CDF")

Der Teilnehmer mit der logischen Teilnehmernummer 3.1 soll im laufenden Busbetrieb abgeschaltet werden:

IndexGroup: 0x00010001

IndexOffset: 0x00000713 (Control_Active_Configuration)

Write-Daten:

Wort 0 0x0200 (Device_Off im Motorola Format)

Wort 1 0x0100 (Ein Entry im Motorola Format)

Wort 2 0x0103 (3.1 im Motorola Format)

Die Write-Länge beträgt 6 Bytes, so dass der Firmware der Parameter_Count 3 (Worte) übergeben wird.

Confirmation:

Die positive Confirmation lautet:

Read-Daten:

Wort 0 0x0000

Die negative Confirmation lautet:

Read-Daten:

Wort 0 0xXXXX (Result im Motorola Format)

Wort 1 0xXXXX (Add_Err_Info Motorola Format)

Karteireiter "Firmware Commands"

Ermöglicht typische Firmware Kommandos zur Bussteuerung per ADS abzusetzen (Voraussetzung ist, dass ein ADS-Port angewählt ist).

Bussteuerung

Die Bussteuerung kann mit den oben genannten Firmwarediensten wie im folgenden Bild dargestellt beeinflusst werden:

Über den Status der Karte kann der aktuelle Zustand erkannt werden:

  • State & 0x00E0 == 0x0080 -> PAR_READY
  • State & 0x00E0 == 0x00C0 -> ACTIVE
  • State & 0x00E0 == 0x00E0 -> RUN

Diagnose Eingänge

Die IBS ISA SC-I/T verfügt automatisch über zwei Eingangswörter, die bzw. deren Bits den Zustand der Karte und des Interbusses beschreiben:

State: 0x0001 = Anwenderfehler

0x0002 = Peripherie-Fehler

0x0004 = Bus-Fehler

0x0008 = Hardware-Fehler (Anschaltbaugruppe)

0x0010 = Diagnoseroutine aktiv

0x0020 = Datenübertragung aktiv

0x0040 = Ausgewählte Konfiguration ist betriebsbereit

0x0080 = Anschaltbaugruppe ist betriebsbereit

0x0100 = Bussegment ist abgeschaltet

0x0200 = Befehlsausgabe sperren

0x0400 = Standardfunktion negativ bearbeitet

0x0800 = Synchronisationsfehler aufgetreten

0x1000 = Fehlerhafte Datenzyklen

0x2000 = Festgelegte Wartezeit überschritten

0x4000 = Festgelegte Fehlerdichte überschritten

0x8000 = Meldung zur Steuerung liegt an

DiagPara: Der Inhalt ist abhängig von dem Inhalt von State.

- Bei gesetztem Bit 0x0001 oder 0x0008 steht der Fehlercode im DiagPara.

- Bei gesetztem Bit 0x0002 oder 0x0004 steht die Segmentadresse des Fehlerortes im DiagPara.

Vergleiche Firmware-Referenzhandbuch IBS SYS FW G4 LIB UM (Art-Nr.: 27 45 13 0) unter der Funktion GetIBSDiagnostic.

Bei den Systemkopplern können noch zusätzlich 2 Eingangswörter mit den Diagnosedaten des Slaves zu den Przessdaten hinzugefügt werden:

SlaveState:

0x0001 = Slave data transfer. Es findet ein Datenaustausch mit der Slave-Baugruppe statt
0x0002 = Fail. Es ist ein Peripherie-Fehler auf der Slave-Baugruppe aufgetreten
0x0004 = Slave initialized. Die Initialisierung der Baugruppe ist abgeschlossen
0x0008 = Power on. Die Versorgungsspannung liegt an
0x0010 = Ready. Die Slave-Baugruppe befindet sich im Zustand 'READY'

SlaveDiagPara: Der Inhalt ist abhängig von dem Inhalt von SlaveState.

Systemstart mit unvollständiger Konfiguration

Soll ein Systemstart mit einer unvollständigen Konfiguration erfolgen, bestehen mehrere Möglichkeiten:

  1. Alternativen Definition: Werden die potenziell nicht vorhandenen Teilnehmer einer Alternative zugeordnet, werden sie beim Systemstart als inaktiv geschaltet (dies kann durch explizites Aktivieren per Control_Active_Configuration umgangen werden (vergl. Karteireiter "InterBus-S" des Teilnehmers)).
  2. Spezielle Einstellung beim Teilnehmer: Bei den einzelnen Teilnehmern kann ein Control_Active_Configuration Kommando definiert werden, dass vor dem Aktivieren der Konfiguration ausgeführt wird (vergl. Karteireiter "InterBus-S" des Teilnehmers). Zu beachten ist, dass ein Control_Active_Configuration Kommando auch abhängig Teilnehmer betrifft!
  3. Spezielle Konfiguration während des Systemstarts durch die SPS: Es besteht die Möglichkeit die Karte nur in den Zustand PAR_READY beim Systemstart schalten zulassen und dann die weitere Konfiguration und Bussteuerung von der SPS durchzuführen. Dazu sollte folgende Vorgehensweise eingehalten werden:
  1. Automatisches "Active_Configuration" abwählen. Dadurch verbleibt die Karte im Zustand PAR_READY
  2. Nach dem Systemstart werden die nicht vorhandenen Teilnehmer einzeln oder per Gruppendefinition abgewählt (Control_Active_Configuration), so dass nur noch die vorhandenen Teilnehmer aktiv geschaltet sind. Das Abschalten erfolgt i.d.R. aus der SPS heraus per ADS. Hierzu kann die SPS-Bibliothek "PlcIbsScit.lib" eingebunden werden, die die nötigen ADS-Kommandos als Bausteine zur Verfügung stellt
  3. "Active_Configuration" per ADS auslösen
  4. "Start_Data_Transfer" per ADS auslösen

Sollen später die inaktiven Teilnehmer hinzugefügt werden, kann dieses ebenfalls per "Control_Active_Configuration" im Zustand RUN per ADS erfolgen.

ISA IBS SC/RI/RT-LK Slave-Interface (Systemkoppler)

Die Konfiguration des Slave-Interfaces wird von dem untergeordneten INTERBUS-System durchgeführt. Die Prozessdatenlänge des Slave-Interfaces ist konfigurierbar und beträgt maximal 10 Worte. Beim Hinzufügen der IBS SC/RI/RT-LK in die E/A-Konfiguration wird die Prozessdatenlänge des Systemkopplers auf 10 Worte und die Parameterkanaldatenlänge auf 0 Bit eingestellt (kein PCP). Die INTERBUS-Schnittstellen der IBS SC/RI/RT-LK werden von einem Medium-Converter von Kupfer- in Lichtwellenleitertechnik umgesetzt. Der Medium-Converter hat den ID-Code 0x08 mit dem Längencode 0x0 und wird vom System Manager zu der E/A-Konfiguration der Karte automatisch hinzugefügt. Nehmen Sie das überlagerte INTERBUS-System erst dann in Betrieb, wenn der Systemkoppler die endgültige Konfiguration besitzt, da bei Änderungen der Konfiguration das überlagerte System in den Fehlerzustand übergeht.

Die Prozessdatenlänge und Parameterkanallänge des Systemkopplers kann über die Kontextmenübefehle des Slaves konfiguriert werden. Das Kontextmenü des Slaves kann über einen Mausklick mit der rechten Maustaste auf den Slave im Baum der E/A.Geräte aufgerufen werden.

Die maximal verfügbare Länge des Prozessdatenkanals ist Abhängig von der ausgewählten Länge des Parameterkanals. Die Prozessdatenlänge von 10 Worten kann nur nach der Deaktivierung des Parameterkanals konfiguriert werden. Der ID-Code des Systemkopplers ergibt sich aus gewählten Länge des Parameterkanals und kann folgende Werte annehmen:

  • ID-Code 3 : Kein PCP, maximale Prozessdatenlänge 10 Worte;
  • ID-Code 235 Parameterkanallänge 1 Wort, maximale Prozessdatenlänge 9 Worte;
  • ID-Code 232 Parameterkanallänge 2 Worte, maximale Prozessdatenlänge 8 Worte;
  • ID-Code 233 Parameterkanallänge 4 Worte, maximale Prozessdatenlänge 6 Worte;

Der Systemkoppler kann mit einer externen Spannung versorgt werden, um beim Ausfall des unterlagerten Masters den weiteren Datenaustausch im überlagerten System zu gewährleisten. Die Konfiguration des Slaves kann nicht auf der IBS SC/RI/RT-LK Karte dauerhaft abgespeichert werden und wird beim Restart oder Neustart des PC's auf Defaultwerte zurückgesetzt. Der Konfigurationsspeicher der Karte wird zurückgesetzt und das überlagerte System meldet einen Peripheriefehler. In der Defaultkonfiguration besitzt der Systemkoppler den ID-Code 233 und den Längencode 0x4 (4 Worte). Der Parameterkanal hat dann die Länge von 64 Bit.

Konfiguration des IBS SC/RI/RT-LK Slave-Interfaces in dem überlagerten INTERBUS-System

Dem Systemkoppler in dem überlagerten System wird eine Busklemme mit dem ID-Code 0x0C und dem Längencode 0x0 vorgeschaltet. Der ID-Code und Längencode des Systemkopplers ist durch die Konfiguration des Systemkopplers in dem unterlagerten System vorgegeben.


Hilscher CIF50-IBS

Systemvoraussetzungen:

  • TwinCAT 2.9 Build > 1000 und höher.

Die CIF50-IBS ist eine Interbus-S Slave PCI-Karte mit 8 KByte DPRAM. Unterstützte Baudraten: 500KBit und 2MBit. Die Baudrate kann über einen DIP-Schalter auf der Karte konfiguriert werden. Die neue Baudrate wird erst nach dem System-Neustart (Power OFF) übernommen. Die Slave-Karte wird in zwei Varianten angeboten: mit einer Kupfer- oder Lichtwellenleiter-Feldbusschnittstelle. Die TwinCAT Konfiguration verläuft in beiden Fällen aber auf gleiche Weise ab.

Karteireiter "Allgemein"

Siehe unter Karteireiter "Allgemein"

Karteireiter "CIF50-IBS"

Preserve Database: Ist diese Option angewählt, dann wird die statische (FLASH) Konfiguration beim TwinCAT Start nicht gelöscht. Default: Nicht angewählt.

PCI Bus/Slot: Zeigt an, in welchem logischen PCI-Slot die Karte gefunden wurde.

Suchen: Hierüber kann nach den im Rechner vorhandenen CIF50-IBS Karten gesucht werden.

Firmware Update: Hierüber kann ein Firmwareupdate durchgeführt werden.

Watchdog: Watchdog-Zeit in ms. Default: 0 ms (deaktiviert).

Die Generierung des Modul-Fehlers an den Interbus-Master kann über folgende Optionen konfiguriert werden:

Cause Error on Watchdog: Die Watchdogüberwachung soll einen Modulfehler an den Master senden. Die Watchdogzeit muss auf einen Wert <> 0 konfiguriert werden. Ein Modulfehler wird nach einem TwinCAT-Stop, nach dem die Watchdogzeit abgelaufen ist, an den Master gesendet. Default: angewählt.

Cause Error on NOT READY: Es wird ein Modulfehler an den Master gemeldet wenn sich der Slave im NOT READY-Zustand befindet. Der Slave wird in den NOT READY-Zustand bei einem TwinCAT-Stop versetzt. Default: angewählt.

Cause Error on Init Error: Es wird ein Modulfehler an den Master gemeldet wenn bei der Initialisierung ein Fehler aufgetreten ist. Default: angewählt.

Cause Error on Init Command: Es wird ein Modulfehler an den Master gemeldet nach einem Initialisierungskommando. Default: angewählt.

Über den Modulfehler kann der Master erkennen im welchen Zustand sich die Slave-Karte befindet.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs"

CIF50-IBS Diagnose-Eingänge

Die CIF50-IBS verfügt automatisch über 8 Eingangsbytes, die den Zustand der Karte und des Interbusses beschreiben:

GlobalFlags: Die einzelnen Bits haben folgende Bedeutung:

  • 0x01 = Bus Active (0 = Bus not active)
  • 0x02 = Data Exchange Active (0 = No data exchange)
  • 0x04 = PCP Communication Established (0 = No PCP communication)
  • 0x08 = Initializaition Error Detected (0 = No initialization fault)
  • 0x10 = Runtime Error Detected (0 = No runtime error)
  • 0x20 = Application is in 'NotReady' State (0 = System running)

Über diese Flags kann die Slave-Applikation erkennen im welchen Zustand sich der InterBus (Master) befindet. Im Datenaustausch mit dem Master sind die Bits: Bus Active und Data Exchange Active gesetzt. Bei einem nicht konfigurierten Master ist z.B. das Bit: Application is in 'NotReady' State gesetzt.

LengthCode: Zeigt den aktuellen Längen-Code des Slavemoduls. Default: 21 ( = 10 Worte Eingangs- und Ausgangs-Prozessdatenlänge).

IdentCode: Zeigt den aktuellen Ident-Code des Slavemoduls. Default: Digital I/O Slave ( ID code = 0x03 ).

ErrorCounter: Anzahl der erkannten Fehler seit dem Einschalten des Moduls.

ErrorEvent: Fehlercode des zuletzt erkannten Fehlers. Siehe CIF50-IBS Error Codes.

AddParam: Zusätzliche Parameter zum Fehlercode (optional). Siehe CIF50-IBS Error Codes.

CIF50-IBS Slave Data (Slave-Prozessdaten)

Die Länge der Prozessdaten kann über das "Slave Data"-Kontextmenue konfiguriert werden.

"Slave Data"-Kontextmenue

Nach einem Mausklick mit der rechten Maustaste auf "Slave Data" im Konfigurationsbaum erscheint folgendes Menue:

Prozess Data Width: Hierüber kann die Länge der Prozessdaten des Slaves konfiguriert werden.

PCP Channel: Die PCP-Kommunikation wird zur Zeit nicht unterstützt.

Es können folgende Prozessdatenlängen konfiguriert werden:

Slave length code | Real data width of the Slave in Bytes (Words)
1 | 2 (1)
2 | 4 (2)
3 | 6 (3)
4 | 8 (4)
5 | 10 (5)
6 | 16 (8)
7 | 18 (9)
14 | 12 (6)
15 | 14 (7)
21 | 20 (10)
22 | 24 (12)

Systemverhalten der CIF50-IBS in einem TwinCAT-System

Um die Karte als Interbus-S Slave an einem Interbus-Master betreiben zu können muss diese zuerst konfiguriert (initialisiert) werden. Die Konfiguration der Karte kann entweder in einem statischen FLASH oder einem nicht statischen Speicher abgelegt werden. Die statische Konfiguration hat eine höhere Priorität und wird (wenn vorhanden) beim Einschalten der Spannungsversorgung zuerst geladen. Um eine nicht statische Konfiguration laden zu können muss die vorhandene statische Konfiguration vorher gelöscht werden.

Wichtiger Hinweis:

Die statische (FLASH) Konfiguration kann nur mit der SyCon-Konfigurationssoftware geladen werden. Mit TwinCAT System Manager kann nur die nicht statische Konfiguration geladen werden. Eine eventuel vorhandene statische Konfiguration wird von der TwinCAT-Software vorher gelöscht. Die Slave-Karte behält die nicht statische Konfiguration nur solange bis diese Spannungslos gemacht wurde (z.b. PC ausgeschaltet und die externe Spannungsversorgung AUS).

Die Slave-Karte kann zusätzlich mit einer externen 24V Spannung versorgt werden. Die externe Spannungsversorgung kann nur verwendet werden, wenn das Zusatz-Modul COP 50-EPS auf die Karte aufgesteckt wurde. Durch die externe Spannungsversorgung behält die Slave-Karte auch dann ihre nicht statische Konfiguration wenn sich der PC im ausgeschalteten Zustand befindet. Wenn aber auch diese Spannungsversorgung unterbrochen wurde und keine statische Konfiguration geladen wurde, dann muss die Karte erneut konfiguriert werden. Eine nicht konfigurierte Slave-Karte meldet an den Master einen Initialisierungsfehler. Die Konfiguration des Masters kann nicht aktiviert und der Datenaustausch nicht gestartet werden (das nicht initialisierte Slave-Segment kann in der Konfiguration des Masters zuerst abgeschaltet und später (wenn initialisiert) zugeschaltet werden).


CIF50-IBS error codes

The following error description should help to solve problems quickly.

VFD = Virtual Field Device

CRL = Communication Reference List

CR = Communication Reference

OD = Object Description

ID Code = Identification Code

PDU = Process Data Unit

Initialization Errors

Error number | Description
0 | No Error / Success No error detected (default value)
50 | No User Task The user task could not been found (internal error). Additional Code: 0 (not used)
51 | No Global Data The global data area could not been accessed (internal error). Additional Code: 0 (not used)
52 | No PLC Task The PLC task could not been found (internal error). Additional Code: 0 (not used)
53 | Unknown Mode The detected data exchange mode is not supported. Additional Code: 0 (not used)
54 | Invalid Data Length The detected data length is undefined / reserved. Additional Code: 0 (not used)
55 | Length Code Out Of Range The detected data length code exceed the max. defined value. Additional Code: Detected length code
56 | Invalid ID Code The detected ID code is none of the defined ID codes. Additional Code: Detected ID Code
57 | Initializiation Of The CRL Failed The internal loading procedure for CRL has failed. Additional Code: 0 (not used)
58 | No CRL Header Found The CRL header could not been found. Additional Code: 0 (not used)
59 | CRL Not Found The CRL could not been found. Additional Code: 0 (not used)
60 | CRL Termination Failed The CRL could not been terminated. Additional Code: 0 (not used)
61 | Invalid CRL Header An error detected during scanning the CRL header (global error). Additional Code: 0 (not used)
62 | Invalid Communication Reference (® CRL Header) The detected communication reference is invalid and has set to 0 for CRL header. Additional Code: Detected CR
63 | Invalid Size (® CRL Header) The entry for the 'size' field within the CRL exceed the max. defined value for this entry. Additional Code: Found CRL size entry
64 | Acyclic Control Interval (ACI) Out Of Range (® CRL Header) The value for the ACI exceed the max. value specified for this entry. Additional Code: 0 (not used)
65 | Symbol Length Out Of Range (® CRL Header) The value for the symbol length exceed the max. specified value for this entry (here: 11). Additional Code: Found symbol length entry
66 | VFD Pointer Error (® CRL Header) The VFD pointer is not supported. This value within the CRL header has to be set to 0 (= FALSE). Additional Code: 0 (not used)
67 | Invalid CRL (® CRL) Error detected during scanning the the CRL (global error). Additional Code: 0 (not used)
68 | CRL Entries Does Not Match (® CRL) The count of CRLs found does not match the 'size' field of CRL Header. Additional Code: CR of deficient entry
69 | Missing CRL Entry (® CRL) CRL entry could not been found. Additional Code: CR of deficient entry
70 | Double Communication Reference Found (® CRL) At least one communication reference is already in use. Additional Code: CR of deficient entry
71 | Communication Reference Out Of Range (® CRL) The detected communication reference exceed the specified value for this entry (here: max. 3). Additional Code: CR of deficient entry
72 | Invalid Remote Address Found (® CRL) The detected remote address exceed the specified value for this entry (here: max. 62). Additional Code: CR of deficient entry
73 | Double Remote Address Found (® CRL) The detected remote address is already in use. Additional Code: CR of deficient entry
74 | Invalid Connection Type Found (® CRL) The dectected connection type is unsupported; only MMAZ is possible. Additional Code: CR of deficient entry
75 | Invalid LLI SAP Found (® CRL) The detected LLI SAP is not supported. Additional Code: CR of deficient entry
76 | Invalid Connection Attribute (® CRL) The detected connection attribute is unsupported; only CONN_ATTR_D is defined. Additional Code: CR of deficient entry
77 | Send/Receive - Conf./Ack. Counter Out Of Range (® CRL) One of the max. values for Send_Conf, Recveive_Conf, Send_Ack, or Receive_Ack counters is out of range. Additional Code: CR of deficient entry
78 | PDU Length Out Of Range (® CRL) One of the values of the PDU for Req_Len_High, Req_Len_Low, Ind_Len_High, Ind_Len_Low is out of range. Additional Code: CR of deficient entry
79 | Unsupported Service Detected (® CRL) At least one unsupprted service was detected (client and/or server). Additional Code: CR of deficient entry
80 | Symbol Length Out Of Range (® CRL) The value for the symbol length exceed the max. specified value for this entry (here: 11). Additional Code: CR of deficient entry
81 | Max. Allowed Object Entry Reached (® OD) The detected count of objects exceed the max. defined value. Additional Code: 0 (not used)
82 | Invalid Object Description (® OD) Error detected during scanning OD (global error). Additional Code: 0 (not used)
83 | Unknown Object Code (® OD) The detected object code is not one of SIMPLE_VAR or ARRAY Object Code. Additional Code: Object index of deficient entry
84 | Object Index Out Of Range (® OD) The value for the object index exceed the max. specified value for this entry. Additional Code: Object index of deficient entry
85 | Double Object Index Detected (® OD) At least one object index is already in use. Additional Code: Object index of deficient entry
86 | Undefined Data Type (® OD) The detected object data type is unsupported / undefined. Additional Code: Object index of deficient entry
87 | Number Of Elements Out Of Range (® OD) The number of elements does not correspond to the related object Code: for SIMPLE_VAR Object: Nof_Elements = 1, for ARRAY Object: 1 < Nof_Elements < 256 Additional Code: Object index of deficient entry
88 | Object Length Out Of Range (® OD) The object length exceed the max. value specified for data types VISIBLE_STRING and OCTET_STRING, respectively does not correspond to the data types of the other objects. Additional Code: Object index of deficient entry
89 | OD Inconsistent
90 .. 99 | RFU Reserved for further use

Runtime Errors

Error number | Description
110 | Watchdog Failure A watchdog failure has occur. Additional Code: Data exchange mode
111 | No Data Ackknowledge The user has failed to ackknowleged the data cycle (in data exchange mode 0). Additional Code: Data exchange mode
112 | Bus Not Active The InterBus is NOT_ACTIVE state. Additional Code: 0 (not used)
113 | Bus Reset The InterBus is in RESET state. Additional Code: 0 (not used)
114 | Application An application (USER) error has been detected by the ALI task. Additional Code: One of the error numbers marked with *.
115 * | No Bus Communication The state of the VFD object is not 'Ready For Communication', or the communication state of the InterBus is not 'Active' (i.g., the board is not connected).
116 | Negative Read.Confirmation Received A negative Read.Confirmation has been received from a communi-cation partner. Additional Code: CR of deficient confirmation
117 | Negative Write.Confirmation Received A negative Write.Confirmation has been received from a communi-cation partner. Additional Code: CR of deficient confirmation
118 * | Object Non Existent The task could not find the requested object.
119 * | Client Not Ready The state of the PCP client is NOT_READY; a request is still active.
119 | Client Not Ready The state of the PCP client is NOT_READY; a request is still active. Additional Code: CR of active request
120 | Negative Initiate.Confirmation Received A negative Initiate.Confirmation is received. Additional Code: CR of deficient confirmation
121 * | Invalid Communication Reference The task could not find the requested communication reference.
122 * | Request Still Active A request is queued internally; the request is still active.
123 * | Communication Reference Not Open The requested communication reference is not open.
124 | Nothing to Process There is no request to process. Additional Code: CR of deficient confirmation
125 | Object Attribute Inconsistent The task has detected an invalid object index for a Read / Write.Request or an invalid data length. Additional Code: Object index of the deficient request
126 | Type Conflict The task has detected an invalid data type for BOOLEAN, respectively for VISIBLE_STRING within a Write.Indication. Additional Code: Object index of the deficient request
127 | Invalid PDU Size The task has detected an invalid PDU size for a Read.Request. Additional Code: Object index of the deficient request
128 | Abort.Indication Received The task has received an Abort.Indication from a communication partner. Additional Code: CR of connection
129 | Reject.Indication Received The task has received an Reject.Indication from a communication partner. Additional Code: HighByte = PduType, LowByte = RejectCode
130 | Negative Initiate.Response The task has received an Initiate.Indication from outside world, but it has sent a negative response to the requester. Additional Code: CR of deficient response
131 | Invalid Invoke ID The task has detected an invalid invoke ID. Additional Code: Received invoke ID (from the application) or object index of the deficient indication
132 | PNM7 Event.Indication The task received a PNM7_Event.Indication. Additional Code: HighByte = ReasonCode, LowByte = AddDetail
133 | Unknown Table The detected download table is unknown
134 | Invalid Download Function The detected download function in unknown
135 | Invalid Table Length The detected table length is invalid
136 | Requested ComRef not Closed The requested Communication Reference number is not closed.
137 | Invalid Device Model
138 .. 149 | RFU Reserved for further use.

Other Errors

Error number | Description
152 | Unknown Command The detected command is unknown. Additional Code: 0 (not used)
167 | Function Error Error in msg.bFunction detected. Additional Code: 0 (not used)
202 | Segment Failure The task could not get a message segment. Additional Code: 0 (not used)
210 | Database Not Found The task could not found the internal database. Additional Code: 0 (not used)
212 | Database Error The task has detected an error during reading the database. Additional Code: 0 (not used)
217 | System Failure A general system failure has been detected by the device. Additional Code: 0 (not used)


Beckhoff FC510x

Die FC510x ist eine CANopen Masterkarte mit einem (FC5101) bzw. zwei Kanälen (FC5102). Sie unterstützt alle CANopen Kommunikationsarten und entspricht der CANopen Spezifikation DS301V4.01. Die Karte kann die zugehörige SPS bzw. NC Task mit dem CANopen SYNC synchronisieren. Im Master Synchronisations-Modus ist eine Antriebsregelung über den Bus besonders gut möglich, da die SYNC Objekte im Mittel quarzgenau übertragen werden und der Prozessdatenaustausch zur Applikation durchsynchronisiert ist.

Die CANopen Masterkarte verfügt über vielfältige Diagnosemöglichkeiten. Emergency Objekte werden gespeichert und können per ADS ausgelesen werden.

Die zweikanalige Karte FC5102 verfügt über zwei unabhängige Mikroprozessorsysteme. Dadurch beeinflussen sich die beiden Kanäle nicht gegenseitig. Die CAN Schnittstellen sind galvanisch getrennt. (-> Hardwarebeschreibung).

Kontextmenü

Box Anfügen... <Einfg>

Fügt CANopen Slaves ("Boxen") an. Eine detaillierte Liste aller unterstützten Boxen finden sie unter: Übersicht.

Gerät Löschen... <Entf>

Entfernt die FC510x Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem CANopen Bus.

Karteireiter "FC510x"

PCI Bus/Slot:

Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde.

Master-Node-ID:

Knotenadresse der FC5100. Wertebereich: 1...127. Bestimmt den Identifier des Master-Heartbeat Telegramms. Darf nicht mit einer Slave-Knotenadresse übereinstimmen.

Baudrate:

Hier wird die Baudrate eingestellt. Es wird automatisch überprüft ob die angeschlossenen Slaves diese Baudrate auch unterstützen.

Synchronization Mode:

Der Synchronisations-Modus bestimmt die Genauigkeit, mit der das CANopen SYNC Telegramm generiert wird.

Die höchstpriore Task, die mit der FC510x-Karte verknüpft ist, übernimmt die Ansteuerung der CANopen Karte und ist somit mit dem CANopen Bus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient. Bei allen Betriebsarten kann die Kommunikationsart für jedes Prozessdatenobjekt (PDO) individuell eingestellt werden - ereignisgesteuert oder synchron (im jeweiligen PDO-Reiter). Falls eines der PDOs für eine synchrone Betriebsart konfiguriert wurde, so wird am Anfang des Zyklus ein SYNC-Telegramm gesendet, mit dem sich die Slaves auf den Master-Zyklus synchronisieren können.

Je nach Anforderung an die SYNC-Genauigkeit können unterschiedliche Modi ausgewählt werden. Hierbei ist zu beachten, dass einzelne SYNC Telegramme bei CAN Systemen prinzipbedingt um eine Telegrammlänge jittern wenn der Bus zum Zeitpunkt des SYNCs belegt ist. Die SYNC-Genauigkeit bezieht sich also in erster Linie auf die Langzeitstabilität. Busknoten, die sich über ein PLL-Verfahren synchronisieren, sind besonders auf gute Langzeitstabilität angewiesen.

Slave

In der Slave Betriebsart erhält die Karte Ihre Zeitbasis von einem SYNC-Master. Der Sync Master wird über das entsprechende Feld angewählt.

  • Sync Master: PC-Task. Dies ist die Default Einstellung. Der PC gibt mit Hilfe der TwinCAT-Echtzeit die Zeitbasis vor. Je nach Einstellung löst der Task-Start (Default bei TwinCAT NC) bzw. das Task Ende (Default bei TwinCAT SPS) das SYNC Telegramm aus.
  • Sync Master: Balanced PC Task. Auch in dieser Betriebsart wird der Sync Zyklus im Mittel mit der Genauigkeit der PC-Zeitbasis erzeugt. Allerdings ist der Abstand zwischen zwei SYNC Telegrammen genauer als beim Sync Master "PC-Task":
    - Laufzeitunterschiede (etwa durch fallabhängige Programmverzweigungen) werden ausgeglichen,
    - die FC510x Karte verzögert anstehende Sende-Telegramme bis nach dem SYNC-Telegramm,
    - die einzelnen SYNC-Abstände werden durch den quarzgenauen Timer der FC510x Karte ermittelt.
    Der Karten-Timer wird gegebenenfalls in kleinen Schritten auf den PC-Timer nachjustiert, wenn dieser um den bei "PLL Sync Time" eingestellten Wert vom Karten-Timer abweicht.
    Das Sync-Telegramm wird in dieser Betriebsart gegenüber dem Abschluss der TwinCAT Task um die Shift Time verzögert. Die Shift Time sollte in dieser Betriebsart möglichst klein gewählt werden - aber ausreichend gross, damit der Prozessdatenzugriff durch die TwinCAT Task erfolgen kann. Bei der Einstellung der optimalen Shift Time hilft die Funktion "Calculate Equi-Times", die nach Erzeugen der Zuordnungen (Mappings) durch Anklicken des entsprechenden Buttons ausgelöst wird.

Master

In der Master Betriebsart erzeugt die Karte Ihre Zeitbasis lokal, das SNYC-Telegramm ist im Mittel quarzgenau. Der Start der TwinCAT Task wird von der Karte vorgegeben und ist gegenüber dem SYNC Telegramm um die Shift Time verzögert. In dieser Betriebsart ist die Shift Time möglichst gross zu wählen. Bei der Einstellung der optimalen Shift Time hilft die Funktion "Calculate Equi-Times", die nach Erzeugen der Zuordnungen (Mappings) durch Anklicken des entsprechenden Buttons ausgelöst wird.

Cycle-Time:

Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt . Die Anzeige wird aktualisiert sobald das Mapping erzeugt wird.

Sync-Cycle Multiplier:

CANopen SYNC Cycle Time = (Task) Cycle-Time x Sync-Cycle Multiplier. Häufig werden bei CANopen ereignisgesteuerte PDO-Kommunikation und zyklisch synchrone PDO-Kommunikation kombiniert. Um schnell auf ein Ereignis reagieren zu können muss die TwinCAT Task Zyklus-Zeit kleiner sein als die CANopen SYNC Zyklus Zeit. Wird der Sync-Cycle Multiplier auf Werte >1 eingestellt, so wird die TwinCAT Task entsprechend mehrfach aufgerufen bevor das SYNC Telegramm erneut gesendet wird.

Sync-Cycle Time:

Hier wird die Zyklus Zeit des CANopen Sync-Telegramms angezeigt. Sie ergibt sich aus der Task-Zykluszeit der höchstprioren Task, deren Prozessdaten mit der Karte verknüpft sind, und aus dem Sync-Cycle Multiplier.

Sync-Tx-PDO Delay:

Direkt nach dem SYNC Telegramm senden die synchronisierten Slaves ihre Eingangsdaten bzw. Istwerte. Die FC510x kann das Senden der Ausgangsdaten bzw. Sollwerte (TxPDOs aus Sicht der Karte) verzögern, um den Telegramm-Burst direkt nach dem SYNC zu minimieren. Mit dem Parameter Sync-Tx-PDO Delay wird diese Verzögerung in Prozent der SYNC-Zykluszeit eingestellt.

Beispiel:

Task Cycle Time = 2000µs, Sync-Cycle Multiplier = 5, Sync Tx-PDO Delay =40. Alle 2ms können ereignisgesteuerte PDOs von der SPS Task verarbeitet werden, der CANopen Sync Cycle beträgt 10ms, 4ms (=40% von 10ms) nach dem SYNC sendet die FC510x ihre synchronen PDOs.

Search...:

Hierüber werden alle vorhandene FC510x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC5102 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC5101-Karten verhalten.

Hardware Configuration...:

Hiermit kann die Adresse der FC510x in den unteren Memory-Bereich (unterhalb von 1 MB) des PCs eingestellt werden.

Upload Configuration:

Hiermit wird das CANopen Netz gescannt und alle gefunden Geräte werden dem Device (der FC510x) hinzugefügt (es darf keine Box angefügt sein). Bei Beckhoff-Boxen wird die Konfiguration genau ausgelesen, bei Fremdgeräten werden die PDO Konfiguration und das Identity Objekt gelesen und ausgewertet.

Verify Configuration:

Erlaubt den Vergleich der erwarteten (eingetragenen) Netzwerk-Konfiguration mit den tatsächlich im Netz vorhandenen Geräten. Es werden die Daten aus dem CANopen Identity Objekt ausgelesen und verglichen. Bei Beckhoff Boxen werden die angeschlossenen Busklemmen bzw. Erweiterungsmodule ausgelesen und verglichen (in Vorbereitung).

Firmware:

Hier wird die aktuelle Firmware-Version der FC510x angezeigt.

Firmware Update...:

Hierüber kann die Firmware der FC510x-Karte aktualisiert werden. Achtung: Das TwinCAT System muss hierzu gestoppt sein.

Karteireiter "ADS"

Die FC510x ist ein ADS-Device mit einer eigenen Net-ID, die hier verändert werden kann. Alle ADS-Dienste (Diagnose, azyklische Kommunikation), die an die FC510x gehen, müssen die Karte mittels dieser Net-ID adressieren.

Karteireiter "Box States"

Hier wird eine Übersicht aller aktuellen Box-States angezeigt.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs".

Diagnose Eingänge

Die FC510x verfügt automatisch über verschiedene Diagnosevariablen, die den Zustand der Karte und des CANopen-Netzwerks beschreiben:

cycleCounter: wird am Ende jedes Firmware Zyklus inkrementiert, sodass man mit dieser Variable feststellen kann, ob der letzte Zyklus beendet war, bevor die Task gestartet wurde

error: Zeigt die Anzahl der Slaves an, deren Box-State ungleich null ist. Nur wenn dieser Wert ungleich 0 ist, muss der BoxState der Slaves überprüft werden

actualCycleTime: zeigt die aktuelle Zykluszeit in 4/25 µs an. Diese Variable wird nur aktualisiert, falls alle Slaves im Datenaustausch sind (also error gleich 0 ist)

DiagFlag: Zeigt an, ob sich die Diagnoseinformationen der Karte geändert haben, die dann mit ADS-Read ausgelesen werden können. Dazu ist die Net-ID der FC510x, die Port-Nummer 200 und die IndexGroup 0xF100 anzugeben. Der IndexOffset und die Länge beziehen sich dann auf die Diagnosedaten. (Hinweis: die Box States stehen bei den Boxen als Variable auch direkt zur Verfügung.)

Offset 1-127: BusStatus-Liste, je Stationsadresse 1-127 ein Byte, das den Status der Station enthält (s. BoxState bei den CANopen-Boxen)

Global State: Verschiedene Diagnose und Statusanzeigen der FC510x. Das Byte in GlobalState(0) zeigt den Status der Karte in Bezug auf das TwinCAT System an: RUN, RESET, OFFLINE und STOP werden unterschieden. GlobalState(2) gibt Informationen über den Zustand des CAN Controllers: "CAN Warning Limit erreicht" und "Bus-Off" werden angezeigt. Warning Limit erreicht bedeutet dass der Sende- oder Empfangsfehlerzähler des CAN Controllers den Wert 96 überstiegen hat; BusOff bedeutet dass der CAN Controller aufgrund zu vieler CAN Fehler (Error Frames) nicht mehr am Busverkehr teilnimmt. In diesem Fall liegt ein schwerwiegender physikalischer Fehler im CAN-Netz vor. (z.B. zu wenige oder zu viele Abschlusswiderstände, mindestens ein Teilnehmer mit falscher Baudrate, Kurzschluss, etc.) Der Zustand Bus-Off kann nur durch einen Reset der Karte verlassen werden. Details über weitere Global State Daten siehe Kommentar im "Online"-Reiter.

LastAdsError: zeigt den Fehlercode des letzten aufgetretenen ADS-Zugriffsfehlers an - z.B. wenn versucht wurde, die Diagnosedaten eines deaktivierten Knotens zu lesen.

CycleFailedCounter: zählt die Anzahl der Firmwarezyklen, die nicht beendet werden konnten, bevor die zugehörige Task wieder das Prozessabbild lesen bzw. schreiben wollte. Falls dieser Zähler inkrementiert wird, so ist die Taskzykluszeit zu klein gewählt für die aktuelle Netzwerkkonfiguration.

BusLoad: zeigt die aktuelle Busbelastung in % an. Die Buslast ist ein wichtiges Auslegungskriterium für CAN Netzwerke. Dargestellt wird ein Mittelwert über 100ms.


Beckhoff FC510x Hardware Beschreibung

Die FC510x ist eine CANopen Masterkarte mit einem (FC5101) bzw. zwei Kanälen (FC5102). Die CAN Kanäle verfügen über eine galvanische Trennung.

CAN-Abschlusswiderstand

Auf der Karte sind CAN Abschlusswiderstände (120 Ohm) vorhanden. Diese können über einen Jumper (bis Hardwarestand 3) bzw. Schiebeschalter (ab Hardwarestand 4) nahe der CAN Stecker aktiviert werden.

Der Flash Disk Sockel ist unbestückt.

Steckerbelegung

Die CAN Busleitung wird über 9polige SubD-Buchsen mit folgender Steckerbelegung angeschlossen.

Pin | Belegung
2 | CAN low (CAN-)
3 | CAN Ground (intern verbunden mit Pin 6)
5 | Schirm
6 | CAN Ground (intern verbunden mit Pin 3)
7 | CAN high (CAN+)

Die nicht aufgeführten Pins sind nicht verbunden.

Hinweis: an Pin 9 darf eine Hilfsspannung bis 30VDC angeschlossen sein (wird von manchen CAN Geräten zur Versorgung der Transceiver genutzt).

LED Verhalten

Anhand der roten Error LED und der grünen Run LED lassen sich die wichtigsten Zustände der Karte schnell diagnostizieren:

Error LED (rot) | Run LED (grün) | Bedeutung
aus | aus | TwinCAT ist gestoppt
aus | an | Alle konfigurierten Busteilnehmer fehlerfrei (Box State=0), TwinCAT Task oder Prozess läuft.
aus | blinkt mit 2 Hz | Task, deren Prozessdaten mit der Karte verknüpft sind, läuft nicht. Alle konfigurierten Busteilnehmer gefunden und fehlerfrei (Box State=0)
blinkt mit 2Hz | an | Mindestens ein Box State ist ungleich null (z.B. Teilnehmer nicht gefunden, falsche Konfiguration, Teilnehmer in Störung), TwinCAT Task läuft
blinkt mit 2 Hz | aus | Mindestens ein Box State ist ungleich null (z.B. Teilnehmer nicht gefunden, falsche Konfiguration, Teilnehmer in Störung), TwinCAT Task läuft nicht.
an | aus | TwinCAT läuft, CAN Controller ist Bus OFF. Physikalisches CAN Problem. Mögliche Fehlerursachen: z.B. fehlender Abschlusswiderstand, zu lange Busleitung, falsche Baudrate, Knotenadresse doppelt vergeben, Verdrahtungsfehler, Kurzschluss. Neustart erforderlich
blinkt mit 20Hz | blinkt mit 20Hz | Konfigurations-Upload wird durchgeführt
blinkt mit 20Hz | aus | Karte ist in STOP Modus


FC510x: Box-Diagnose

Die CANopen Feldbuskarte FC510x verfügt über umfangreiche Diagnosemöglichkeiten für die angeschlossenen Netzwerkknoten.

Für jeden CANopen Feldbusknoten gibt es die Eingangsvariable Node State, die den Status des jeweiligen Slaves zur Laufzeit signalisiert und z.B. mit der SPS verknüpft werden kann.

Node-State

DiagFlag:

Zeigt an, ob sich die Diagnoseinformationen der Box geändert haben.

CANopen Emergency Nachrichten

CANopen Emergencies und weitere Diagnosedaten können mit ADS-Read ausgelesen werden (neue Daten sind vorhanden, sobald das DiagFlag gesetzt ist). Dazu sind die ADS Net-ID der FC510x anzugeben. Weitere ADS Parameter:

Port: 200

IndexGroup: Lo-Word = 0xF180, Hi-Word = Node-Nummer.

IndexOffset: siehe unten

Länge: siehe unten

Wenn mehr als 26 Bytes Diagnosedaten ausgelesen werden, wird der Emergency-Speicher zurückgesetzt.

Die Diagnosedaten habe folgende Bedeutung:

Offset 0,1: | Bit 1: | Boot-Up-Message nicht empfangen oder fehlerhaft
 | Bit 2: | Emergency-Overflow
 | Bit 0, Bit 3-15: | reserviert
Offset 2,3: | Bit 0-14: | TX-PDO (i+1) empfangen
 | Bit 15: | alle TX-PDOs 16-n empfangen
Offset 4,5: | Bit 0-4: | 1: falsche TX-PDO-Länge
 |  | 2: synchrone TX-PDO fehlt
 |  | 3: Node meldet PRE-OPERATIONAL
 |  | 4: Event-Timer bei einer TX-PDO abgelaufen
 |  | 5: keine Antwort beim Guarden
 |  | 6: mehrmals kein Toggeln beim Guarden
 | Bit 5-15: | zugehörige COB-ID
Offset 6: | Bit 0-7: | 1: falscher Wert bei einem SDO-Upload
 |  | 2: falsche Länge bei einem SDO-Upload
 |  | 3: Abort bei einem SDO-Up-/Download
 |  | 4: falsches Datum bei einer Boot-Up-Message
 |  | 5: Timeout beim Warten auf Boot-Up-Message
Offset 7: | Bit 0-7: | 2: falscher SDO-Command specifier
 |  | 3: SDO-Toggle-Bit hat sich nicht geändert
 |  | 4: SDO-Länge zu groß
 |  | 5: SDO-Abort
 |  | 6: SDO-Timeout
Offset 8,9 | Bit 0-7: | Index des SDO-Up/Downloads
Offset 10: | Bit 0-7: | Subindex des SDO-Up/Downloads
Offset 11: | Bit 0-7: | reserviert
Offset 12: | Bit 0-7: | errorClass des Aborts
Offset 13: | Bit 0-7: | errorCode des Aborts
Offset 14,15: | Bit 0-15: | additionalCode des Aborts
Offset 16-19: |  | gelesener Wert (falls Offset 6 = 1)
Offset 20-23: |  | erwarteter Wert (falls Offset 6 = 1)
Offset 24-25: |  | Anzahl der folgenden Emergencies
Offset 26 - n: |  | Emergencies (jeweils 8 Byte)


Hilscher CIFxx-CAN

Die CIF30-CAN ist eine CANopen ISA-Masterkarte.

Die CIF50-CAN ist eine CANopen PCI-Masterkarte.

Die CIF60-CAN ist eine CANopen PCMCIA-Masterkarte.

Die C104-CAN ist eine CANopen PC104-Masterkarte.

Das DPRAM der CIFx0-CAN ist 8 KByte groß. Es werden keine Interrupts benutzt.

Die folgende Beschreibung bezieht sich auf die CIF30-CAN. Die anderen Karten unterscheiden sich aus Sicht von TwinCAT nur durch den Formfaktor.

Kontextmenü

Box Anfügen... <Einfg>

Fügt CANopen Boxen an.

Z.Zt. werden folgende Boxen unterstützt (nähere Beschreibung zu den Boxen folgen weiter hinten):
Unterstützte Boxen | Beschreibung
BK5100 | Buskoppler
BK5110 | Economy Buskoppler
BK5120 | Buskoppler
LC5100 | Low-Cost Buskoppler
CANopen Node | Allgemeines CANopen Gerät

Gerät Löschen... <Entf>

Entfernt die CIF30-CAN Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem CAN Bus.

Karteireiter "CIF-30 CAN"

Address: Hier wird die DPRAM Adresse der Karte eingestellt (CIF30-CAN und C104-CAN). Diese Adresse wird auf der Karte gejumpert bzw. konfiguriert und kann folgende Werte annehmen: von 0xC8000 bis 0xEE000 in Schritten von 0x2000

PCI Slot/Ring: (CIF50-CAN) Angabe des logischen PCI-Slots in der die Karte gesteckt ist.

Search: Hierüber können im Rechner vorhandene CIF-30 Karten gesucht werden (nur bei aktivem TwinCAT)

Synch Cycle: Hier wird die Zykluszeit eingestellt, mit der Sync Telegramme verschickt werden.

Baudrate: Hier wird die Baudrate eingestellt, mit der der CAN-Bus betrieben wird.

Watchdog: Watchdog mit dem die CANopen-Karte TwinCAT überwacht.

AutoClear: Ist diese Box angewählt, so führt der Ausfall eines Knotens zum Anhalten des gesamten Netzes, ansonsten wird versucht, den Knoten wieder aufzunehmen und der Betrieb fortgesetzt.

Syncron Mode: Die höchstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, übernimmt die Ansteuerung des Feldbuszyklus und ist somit mit dem Feldbus I/O update synchronisiert (nicht aber mit dem CANopen SYNC; dieses wird auf der Karte freilaufend erzeugt). Alle anderen Tasks werden asynchron über entsprechende Puffer bedient.

Firmware Update... Hier kann die Firmware der CIF-30 CAN aktualisiert werden. Im Fenster erscheint die derzeit geladene Firmwareversion - in rot, wenn TwinCAT eine aktuellere kennt und erwartet.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs"

Diagnose Eingänge

Die CIF-30 verfügt automatisch über vier Eingangsbytes, die den Zustand der Karte und des CAN-Busses beschreiben:

GlobalFlags: Die einzelnen Bits haben folgende Bedeutung:

  • 0x01 = Ctrl: Parametrierungsfehler
  • 0x02 = ACtrl: Gerät stopped die Kommunikation aufgrund eines Guarding-Fehlers zu einem Node
  • 0x04 = NData: mindestens eine Node kommuniziert nicht oder hat eine Konfigurationsfehler
  • 0x08 = Fatal: Schwerer Busfehler aufgetreten
  • 0x10 = Event: Kommunikationsfehler erkannt
  • 0x20 = NRdy: Host ist nicht bereit

ErrorRemAddr: Addresse des verursachenden Nodes, Adresse 255 ist die Masterkarte selbst

ErrorEvent:

Wenn ErrorRemAddr ungleich 255 gelten folgende Bedingungen:

  • =30: Guarding fehlerhaft
  • =31: Node hat Zustand verändert
  • =32: Sequence-Fehler im Guarding-Protokoll
  • =33: keine Antwort von einer Remote-Frame-PDO
  • =34: keine Antwort während der Konfiguration des Nodes
  • =35: Profilnummer des Nodes stimmt nicht
  • =36: Device Type des Nodes stimmt nicht
  • =37: unbekannte SDO-Response empfangen
  • =38: SDO-Syntax-Fehler
  • =39: Node in STOP-Modus

Wenn ErrorRemAddr 255 anzeigt gelten folgende Bedingungen:

  • =52 Unbekannter Handshake Mode wurde konfiguriert
  • =56 Baudrate nicht definiert
  • =60 Node Adresse wurde doppelt vergeben
  • =220 Host Watchdog Fehler
  • =210 keine Datenbank
  • =212 Fehlerhafte Datenbank

ErrorCounter: Anzahl der aufgetretenen Busfehler


CIFx0-CAN: Box-Diagnose

Die CANopen Feldbuskarte CIFx0-CAN verfügen über umfangreiche Diagnosemöglichkeiten für die angeschlossenen Netzwerkknoten.

Für jeden CANopen Feldbusknoten gibt es die Eingangsvariable Box State, die den Status des jeweiligen Slaves zur Laufzeit signalisiert und z.B. mit der SPS verknüpft werden kann.

BoxState

DataExchange

Über dieses Bit wird angezeigt, ob sich der Knoten im Datenaustausch befindet. Es können nur Knoten überwacht werden, bei denen das Guarding Protokoll aktiviert wurde.

CANopen-Emergency-Objekt

Einige CANopen-Statusdaten sowie bis zu 5 empfangene Emergency-Objekte eines Nodes können per ADS von jedem TwinCAT Programm gelesen bzw. an jedes TwinCAT-Programm gemeldet werden. Dabei sind die ADS-Parameter wie folgt einzustellen:

Port: 300

IndexGroup: 0x5000 + Device-ID

IndexOffset: Hi-Word: Node-ID, Lo-Word: 0x100

Länge: 8 - 48

Die Diagnosedaten sind wie folgt aufgebaut:

Offset: 0: Nodestatus-Bits

Bit 7: Node ist deaktiviert

Bit 3: Guarding-Protokoll ist aktiv

Bit 2: Parametrierfehler

Bit 1: Emergency-Buffer Überlauf

Bit 0: Node antwortet nicht

Offset: 1,2: Node-Type (Index 0x1000)

Offset: 3,4: Profile-Number

Offset: 5: Node-State

1: Disconnecting

2: Connecting

3: Preparing

4: Prepared

5: Operational

127: Pre-Operational

Offset: 6: aktueller Fehler

30: Guarding fehlerhaft

31: Node hat Zustand verändert

32: Sequence-Fehler im Guarding-Protokoll

33: keine Antwort von einer Remote-Frame-PDO

34: keine Antwort während der Konfiguration des Nodes

35: Profilnummer des Nodes stimmt nicht

36: Device Type des Nodes stimmt nicht

37: unbekannte SDO-Response empfangen

38: SDO-Syntax-Fehler

39: Node in STOP-Modus

Offset: 7: Anzahl Emergency-Meldungen

Offset: 8-47: Emergency-Buffer (-> Node-Beschreibung)

Die Daten enthalten den aktuellen Status. Im Emergency-Buffer stehen die zuletzt empfangenen Emergency-Meldungen. Die Nodestatus-Bits sind im Diagnose-Eingang Box-State zusammengefaßt.


Beckhoff FC520x

Die FC520x ist eine DeviceNet Masterkarte mit einem (FC5201) bzw. zwei Kanälen (FC5202). Sie kann sowohl als DeviceNet Master und-/oder als DeviceNet Slave betrieben werden. Im Master-Betrieb können Daten mit bis zu 63 Slaves ausgetauscht werden. Für den Austausch von IO-Daten stehen alle von DeviceNet definierten IO-Betriebsarten zur Auswahl. Durch die Unterstützung des Offline-Connection Sets steht eine leistungsfähige Diagnoseschnittstelle zur Verfügung. Die Funktionalität des "Auto-Device-Replacements" ermöglicht den einfachen Austausch von defekten Knoten.

Kontextmenü

Box Anfügen... <Einfg>

Fügt DeviceNet Slaves ("Boxen") an. Eine detaillierte Liste aller unterstützten Boxen finden sie unter: Übersicht.

Gerät Löschen... <Entf>

Entfernt die FC520x Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf den DeviceNet Master.

Karteireiter "FC5200"

PCI Slot/Irq: Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde und welcher IRQ ihr zugewiesen wurde. Der IRQ wird nicht benutzt.

Search...: Hierüber werden alle gesteckten FC520x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC5202 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC5201-Karten verhalten.

PCI-Configuration...: Hiermit kann die Adresse der FC520x in den unteren Memory-Bereich (unterhalb von 1 MB) des PCs eingestellt werden.

Upload Configuration...: Hiermit wird das DeviceNet Netzwerk gescannt und alle gefunden Geräte werden dem Device hinzugefügt (es darf keine Box angefügt sein). Bei Beckhoff-Boxen wird die Konfiguration genau ausgelesen, bei Fremdgeräten wird versucht, die zugehörige EDS-Datei zu finden.

Firmware: Hier wird die aktuelle Firmware-Version der FC520x angezeigt.

Firmware Update...: Hierüber kann die Firmware der FC520x-Karte aktualisiert werden.

Stations-No.: Jeder DeviceNet-Teilnehmer benötigt eine eindeutige Stations-Nr. (MAC-ID)- auch der Master.

Baudrate: Hier wird die DeviceNet Baudrate eingestellt. Auswählbar sind 125KBaud, 250KBaud und 500 KBaud

Operation Mode: In der Betriebsart CDLSYSNCHRON übernimmt die höchstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, die Ansteuerung des DeviceNet-Zyklus und ist somit mit dem Feldbus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient.

Shift-Time: Der DeviceNet-Zyklus wird durch den Echtzeit-Timer gestartet, aber nur wenn zum Zeitpunkt des Timer-Überlaufs, die TwinCAT-Task die Outputdaten bereits übergeben hat (Freischaltung der Outputdaten). Das hat zur Folge, dass Echtzeit-Timer auf der Karte und die höchstpriore TwinCAT-Task zwar die gleiche Zykluszeit haben, aber um eine bestimmte Zeitdifferenz zueinander verschoben sind, wobei die Shift-Time größer als der maximale TwinCAT-Jitter plus die maximale Mapping-Time (s. Karteireiter Equi-Diag) sein sollte.

PLL-Sync-Time: Da der Echtzeit-Timer der Karte und die höchstpriore TwinCAT-Task mit der Zeit auseinander laufen, muss der Echtzeit-Timer der Karte nachgeregelt werden. Die PLL-Sync-Time gibt die Intervalle an, bei deren Überschreiten der Differenz der Echtzeit-Timer der Karte nachgeregelt wird. Eine kleine PLL-Sync-Time bewirkt dabei ein stärkeres Schwingen der Zykluszeit des Echtzeit-Timers der Karte, was einen größeren Jitter zur Folge hat.

Safety-Time: Ruhezeit auf dem Bus vor dem Start des nächsten Zyklusses.

Cycle-Time: Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt .

Estimated Cycle: Hier wird die voraussichtliche DeviceNet-Zykluszeit angezeigt.

IO-Cycle Time: Legt die Zykluszeit der IO-Verbindungen fest. Dieser Wert wird als Default-Wert für neu angefügte Boxen verwendet.

Heartbeat Time: Zykluszeit für DeviceNet Heartbeat Nachrichten. Heartbeat Nachrichten dienen der Überwachung der sich im Netz befindlichen Knoten.

Karteireiter "ADS"

Die FC520x ist ein ADS-Device mit einer eigenen Net-ID, die hier verändert werden kann. Alle ADS-Dienste (Diagnose, azyklische Kommunikation), die an die FC520x gehen, müssen diese Net-ID adressieren.

Karteireiter "BoxStates (Diag)"

Hier wird eine Übersicht aller aktuellen Box-States angezeigt.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs".

Diagnose Eingänge

Die FC520x verfügt automatisch über verschiedene Diagnosevariablen, die den Zustand der Karte und des DeviceNet Netzwerkes beschreiben:

CdlInfo:

CdlInfo.error: Zeigt die Anzahl der Slaves an, mit denen kein Datenaustausch mehr durchgeführt werden konnte, nur wenn dieser Wert ungleich 0 ist, muss der BoxState der Slaves überprüft werden

CdlInfo.cycleCounter: wird am Ende jedes DeviceNet-Zyklusses inkrementiert. Mit dieser Variable kann festgestellt werden ob der letzte Zyklus beendet war, bevor die Task gestartet wurde

CdlInfo.actualCycleTime: zeigt die aktuelle Zykluszeit in 4/25 µs an, diese Variable wird nur aktualisiert, falls alle Slaves im Datenaustausch sind (also CdlInfo.error gleich 0 ist)

DiagFlag: Zeigt an, ob sich die Diagnoseinformationen der Karte geändert haben, die dann mit ADS-Read ausgelesen werden können. Dazu ist die Net-ID der FC520x, die Port-Nummer 200 und die IndexGroup 0xF100 anzugeben. Der IndexOffset und die Länge beziehen sich dann auf die Diagnosedaten.


Hilscher CIFxx-DNM

Die CIF30-DNM ist eine DeviceNet ISA-Masterkarte.

Die CIF50-DNM ist eine DeviceNet PCI-Masterkarte.

Die CIF60-DNM ist eine DeviceNet PCMCIA-Masterkarte.

Die C104-DNM ist eine DeviceNet PC104-Masterkarte.

Das DPRAM der CIFx0-DNM ist 8 KByte groß. Es werden keine Interrupts benutzt.

Die folgende Beschreibung bezieht sich auf die CIF30-DNM. Die anderen Karten unterscheiden sich aus Sicht von TwinCAT nur durch den Formfaktor.

Kontextmenü

Box Anfügen... <Einfg>

Fügt DeviceNet Boxen an.

Z.Zt. werden folgende Boxen unterstützt (nähere Beschreibung zu den Boxen folgen weiter hinten):
Unterstützte Boxen | Beschreibung
BK5200 | Buskoppler
BK5210 | Economy Buskoppler
LC5200 | Low-Cost Buskoppler
DeviceNet Node | Allgemeines DeviceNet Gerät

Gerät Löschen... <Entf>

Entfernt die CIF30-DNM Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem DeviceNet.

Karteireiter "CIF-30 DNM"

Address: Hier wird die DPRAM Adresse der Karte eingestellt (CIF30-DNM und C104-DNM). Diese Adresse wird auf der Karte gejumpert bzw. konfiguriert und kann folgende Werte annehmen: von 0xC8000 bis 0xEE000 in Schritten von 0x2000

PCI Slot/Ring: (CIF50-DNM) Angabe des logischen PCI-Slots in der die Karte gesteckt ist.

Search: Hierüber können im Rechner vorhandene CIFxx-CAN Karten gesucht werden

MAC-ID: Hier wird die Knotenadresse der Master (Scanner)-Karte eingestellt. Diese darf im Netz nicht nochmals vergeben sein.

Heartbeat: Hier wird die Rate eingestellt, mit der die DeviceNet-Karte Heartbeat-Nachrichten absetzt (wird derzeit noch nicht unterstützt).

Baudrate: Hier wird die Baudrate eingestellt, mit der das DeviceNet betrieben wird.

Watchdog: Watchdog mit dem die DeviceNet-Karte TwinCAT überwacht.

VendorID: Gibt die Vendor-ID an, mit der sich die Scanner-Karte im Netz identifiziert (z.B. im Duplicate MAC ID Detection Protocol)

AutoClear: Ist diese Box angewählt, so führt der Ausfall eines Knotens zum Anhalten des gesamten Netzes, ansonsten wird versucht, den Knoten wieder aufzunehmen und der Betrieb fortgesetzt.

Syncron Mode: Die höchstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, übernimmt die Ansteuerung des Feldbuszyklus und ist somit mit dem Feldbus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient.

Firmware Update... Hier kann die Firmware der CIFxx-DNM aktualisiert werden. Im Fenster erscheint die derzeit geladene Firmwareversion - in rot, wenn TwinCAT eine aktuellere kennt und erwartet.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs"

Diagnose

Global Flags

Error Code | Description | Troubleshooting
0x00 | No error |
0x01 | Ctrl: Parameter error | Check Master Parameter
0x02 | AClr: Device stops the transmission to all nodes | Check cabling, Reconfigure Master
0x04 | NExc: at least one node has not reached the data exchange state | Check ErrorRemAddr and ErrorEvent. inspect the field device indicated by ErrorRemAddr.
0x08 | Fatal error because of heavy buserror | Check cabling, inspect the field devices, may one node makes trouble on the bus, Check DeviceNet Voltage
0x10 | Event: transmission errors were detected | Check cabling, inspect the field devices, may one node makes trouble on the bus, Check Baudrate and MAC Id
0x20 | NRdy: HOST is not ready | Check TwinCAT System for generell errors
0x40 | Duplicate MacId detected | Check Masters MacId
0x80 | Duplicate MacId Test active | Check Baudrate and cabling, Master is may not able to set up his Duplicate Mac Id messages

Error Rem Addr

Error Code | Description | Troubleshooting
Station Number | Number of faulted slave device | Inspect the field device with the indicated MAC id, Check ErrorEvent Diagnoses
255 | Error inside Device | Check Master Parameter, Check ErrorEvent Diagnoses

ErrorEvent (for ErrorRemAddr = 255, Error inside device)

Error Code | Description | Troubleshooting
57 | Duplicate MAC Id detected | Check the addresses of the field devices, change Masters MAC Id
58 | Master Config Error, download error of Master parameter | Contact technical support
212 | Failure in reading masters data base | Contact technical support

ErrorEvent (for ErrorRemAddr = Station Number, MacId)

Error Code | Description | Troubleshooting
30 | device access timeout, device stopped communicating | Inspect the field device, verify connections, check cabling
32 | Device rejects access with unknown error code | Check IO features of the device, check explicite access to device, check object class, instance and attribute id
35 | Device responses in allocation process with connection error | Check IO features of the device, check explicite access to device, check object class, instance and attribute id
36 | Produced connection length is different to the configured one | Check number of Bytes to be produced by the device, check devices IO configuration
37 | Consumed connection length is different to the configured one | Check number of Bytes to be consumed by the device, check devices IO configuration
38 | Device service response telegram unknown | Contact technical support of the device manufacturer
39 | Connection already in Request | Check cabling, inspect device, Master is not able to set up a connection to the device
40 | Number of CAN-message data bytes in read produced or consumed size response not matches expected one | Contact technical support of the device manufacturer
41 | Predefined Master- / Slave Connection Set already exists | Check number of Masters connected to the network, device my already in use by another master
42 | Polling IO data length is different to the configured one | Check number of Bytes to be produced by the field device, check field devices IO configuration, contact technical support of the device manufacturer
43 | Sequence Error in fragmented polling IO transmission | Inspect device, contact technical support of the device manufacturer
44 | Fragment Error in fragmented pollingIO transmission | Inspect device, contact technical support of the device manufacturer
45 | Sequence Error in fragmented polling IO transmission | Inspect device, contact technical support of the device manufacturer
46 | Polling IO data length is different to the configured one | Check number of Bytes to be produced by the device, check devices IO configuration, contact technical support of the device manufacturer
47 | Sequence Error in fragmented Change of State / Cyclic IO transmission | Inspect device, contact technical support of the device manufacturer
48 | Sequence Error in fragmented Change of State / Cyclic IO transmission | Inspect device, contact technical support of the device manufacturer
49 | Sequence Error in fragmented Change of State IO transmission | Inspect device, contact technical support of the device manufacturer
50 | Change of State / Cyclic IO data length is different to the configured one | Check number of Bytes to be produced by the device, check devices IO configuration, contact technical support of the device manufacturer


Beckhoff FC750x

TwinCAT System Manager: Reference

Beckhoff FC7501/FC7502

Die FC7501 ist eine einkanalige und die FC7502 eine zweikanalige passive SERCOS Karte (SERCOS = SEriell Realtime COmmunication System) mit PCI Interface. Sie kann sowohl als Sercos Master und-/oder als Sercos Slave betrieben werden. Es wird das Sercos Asic SERCON816 verwendet, dass neben 2 und 4MBaud auch 8 und 16MBaud unterstützt. Z.Zt. sind die verwendeten Sender und Empfänger noch nicht für 16 MBaud spezifiziert, so dass diese Eigenschaft noch nicht garantiert werden kann.

Kontextmenü

Box Anfügen... <Einfg>

Fügt SERCOS -Teilnehmer ("Boxen") an. Eine Liste aller unterstützten Boxen finden sie unter: Übersicht.

Gerät Löschen... <Entf>

Entfernt die FC750x Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf den Sercos Master, d.h. ein Phasenumschalten auf Phase 0 und dann wieder auf die davor aktuelle Phase.

Karteireiter "FC7500"

PCI Slot/Irq: Zeigt an, in welchem logischen PCI-Slot die Karte gefunden wurde und welcher IRQ ihr zugewiesen wurde. Der IRQ wird nicht benutzt.

Suchen...: Hierüber werden alle gesteckten FC750x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC7502 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC7501-Karten verhalten.

PCI-Cfg...: Hiermit kann die Adresse der FC750x in den unteren Memory-Bereich (unterhalb von 1 MB) des PCs eingestellt werden.

Bus absuchen...: Hiermit wird der Sercos Ring gescannt und alle gefundenen Geräte werden dem Device hinzugefügt. Bei Beckhoff-Boxen wird die Konfiguration genau ausgelesen.

Datenrate: Hier wird die Sercos Baudrate eingestellt. Auswählbar sind 2MBaud, 4MBaud, 8MBaud und 16MBaud.

Sendeleistung: Hier wird die Sendeleistung des Transmitters in Abhängigkeit der dort verwendeten Lichtwellenleiterlänge eingestellt.

Betriebsart: Die FC750x kann sowohl als Sercos Master als auch als Sercos Slave verwendet werden. In beiden Betriebsarten kann die Karte als Synchron Master (der PC und andere synchrone Geräte werden erhalten vom Sync Master ihren Takt) oder als Synchron Slave (die Karte, bzw. der Kartenkanal, erhält das Sync Signal vom anderen Kanal oder über das Flachbandkabel von einer anderen Karte) verwendet werde. Innerhalb eines PCs ist nur ein Synchron Master möglich. Werden bei einer FC7502 beide Kanäle verwendet, dann kann nur der A-Kanal (der Kanal, der näher am Motherboard ist) als Sync Master verwendet werden.

Startup auf Phase 4: Wenn angewählt, wird bei jedem TwinCAT Start versucht den Sercos Bus in Phase 4 und damit in den zyklischen Datenaustausch zu versetzen. Ist diese Option nicht angewählt verbleibt die Karte in Phase 2 und muss später per ADS z.B. von der SPS in Phase 4 versetzt werden.

Überprüfe Timing: Wenn angewählt, wird in jedem Zyklus das exakte Echtzeitverhalten beim Zugriff auf die Karte überwacht und bei Verletzungen (Istwerte werden zu früh gelesen oder Sollwerte werden zu spät geschrieben) wird ein entsprechender Zähler, der in den Prozessdaten zu finden ist, inkrementiert. Die Überwachung benötigt nur sehr wenig Performance, so dass sie in normalen Anwendungen ohne Nachteile mitlaufen kann. In Anwendungen mit sehr kurzer Zykluszeit und Performance Engpässen kann sie dagegen abgeschaltet werden.

Watchdog: Das verwendete Sercos Asic SERCON816 besitzt einen Hardware Watchdog, der den regelmäßigen Zugriff des PC's überwacht und bei ausbleibenden Zugriffen die Phase 0 aktiviert. Hier kann angegeben werden wie viele Zyklen Toleranz der Watchdog erlaubt. Mit einer Toleranz von 0 wird der Watchdog deaktiviert.

NC Zugriffszeit: Hier wird angegeben wie lange die NC benötigt um pro Zyklus die Istwerte zu lesen und die Sollwerte zu schreiben. Dieser Wert wird nur für die interne Zeitschlitzberechnung verwendet um bereits im Vorfeld mögliche Zeitschlitzprobleme (vergl. Check Timing Errors) zu erkennen.

NC Shift Zeit: Mit Hilfe der NC Shift Zeit kann der Zeitpunkt an dem die NC anfängt die Istwerte zu lesen verschoben werden. Dieser Wert gibt die Anzahl der µs nach dem letzen AT an. Der Defaultwert von 50µs stellt im Normalfall sicher, das auch bei geringem Jitter des Echtzeitsystems die ATs, und damit die Istwerte, sicher beim Master angekommen sind, bevor die NC zugreift. Wenn mehr als ein Sercos Ring verwendet wird, muss dieser Wert eventuell angepasst werden, da der NC Zugriff für alle Ringe quasi gleichzeitig erfolgt, das letzte AT des jeweiligen Ringes auf Grund der angeschlossenen Teilnehmer aber zu unterschiedlichen Zeiten eintrifft. Da die Sercos Ringe auf dem Bus hardwaremäßig synchronisiert sind gilt folgende Regel: Die NC Shift Zeit sollte bei allen Ringen so eingestellt werden, das die resultierende Zeit tNcAccess (siehe Timing) bei allen Ringen etwa gleich ist. Außerdem sollte die NC Shift Zeit bei keinem Ring wesentlich kleiner als etwa 20 µs betragen.

Cycle-Time(3-4): Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt , diese wird in den Phasen 3 und 4 verwendet .

Cycle-Time(0-2): Hier wird die Zykluszeit in den Phasen 0 bis 2 angegeben, die für den Hochlauf des Busses verwendet werden.

Die nachfolgenden Werte ermöglichen die interne Zeitschlitzberechnung zu beeinflussen um bei Kommunikationsproblemen oder Auslastungsproblemen noch einige µs zu verändern. Dieses sollte aber nur durchgeführt werden, wenn entsprechendes Sercos Know-how vorliegt und die Einflüsse abgeschätzt werden können.

JT1 User: Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JT1.

JT2 User: Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JT2.

JTSCyc User: Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JTSCyc.

T3 User: Der eingestellte Wert verändert die intern bei der Zeitschlitzberechnung errechnete Zeit T3.

T4 User: Der eingestellte Wert verändert die intern bei der Zeitschlitzberechnung errechnete Zeit T4.

Karteireiter "Timing (Online/Offline)"

Der Timing-Karteireiter informiert über interne Details der Zeitschlitzberechnung. Da für die Zeitschlitzberechnung auch Parameter aus den Teilnehmern ausgelesen werden und in Berechnung mit eingehen, wird zwischen einem Online und Offline Modus unterschieden. Im Offline Modus (TwinCAT ist gestoppt) werden Defaultwerte für die normalerweise aus den Teilnehmern ausgelesenen Timingwerte verwendet, so dass diese Berechnung geringfügig von den tatsächlich verwendeten Werten abweichen kann. Für eine recht gute Abschätzung des Bustimings reicht die Offline Berechnung in der Regel jedoch aus. Im Online Modus (TwinCAT ist gestartet und der Sercos Bus muss in Phase 3 oder 4 sein) werden die exakten Werte angezeigt und geben dem fachkundigen Anwender genaueste Informationen über das Timing auf dem Bus.

Die Grafik im unteren Teil gibt einen guten Überblick über die erzeugte Buslast bzw. über die noch vorhandenen Kapazitäten. Zwischen den beiden roten Master Steuer Telegrammen (MST) wird ein Sercos Zyklus dargestellt. Nach dem MST senden die Teilnehmer als erstes ihre Antriebstelegramme (grün) und nach der NC Shift Zeit beginnt die NC Zugriffszeit (gestrichelter Bereich), in der die NC die Istwerte übernimmt und neue Sollwerte übergibt. Der nachfolgende freie Bereich bis zum Master Daten Telegramm (MDT, blau) kennzeichnet noch "frei Buslast" und könnte für weitere Teilnehmer bzw. zusätzliche Daten der vorhandenen Teilnehmer genutzt werden.

Kurz hinter dem MDT wird vom Master bereits ein weiteres MST gesendet und damit der nächste Zyklus gestartet. Die Zeiten T3 und T4 geben an, wann die Teilnehmer alle gleichzeitig die Sollwerte übernehmen bzw. die Istwerte erfassen sollen.

Karteireiter "Online"

Über den Online-Reiter kann die aktuelle Phase des Sercos Ringes ermittelt und verändert werden. Drei rote Striche "---" als Phasenangabe deuten auf einen nicht geschlossenen Ring hin. Eine Phasenangabe der Art "2->3" zeigt an, dass gerade eine Phasenumschaltung aktiv ist, die unter Umständen länger dauern kann.

SERCOS basiert auf der Lichtwellenleitertechnik (LWL) und hat ein sehr deterministisches Zeitverhalten. Um dieses Zeitverhalten zu erreichen, werden während der Initialisierung im mehreren Phasen Parameter zwischen Master und Antrieb ausgetauscht. Die Bedeutung der einzelnen Phasen wird in der folgenden Tabelle dargestellt.

Phase | Beschreibung
0 | - Es wird in dieser Phase überprüft, ob der Lichtwellenleiterring physikalisch geschlossen ist
1 | - Die Adressen der Antriebe im Ring werden auf Eindeutigkeit überprüft. Jeder Antrieb muss dabei den Empfang, eines an ihn gerichteten Telegramms, bestätigen.
2 | - Jeder Antrieb tritt in azyklischen Datenaustausch mit dem Master. Dabei werden die im Antrieb hinterlegten Zeiten für die Zeitschlitzberechnung abgefragt. - Der Master berechnet die Zeitschlitze und schreibt die spezifischen Werte zurück in den jeweiligen Antrieb - Falls Startup-Parameter angegeben sind, werden diese jetzt in den Antrieb heruntergeschrieben
3 | - Das berechnete Timing ist ab jetzt aktiv - Prozessdaten sind noch nicht aktiv / gültig
4 | - Prozessdaten sind ab jetzt gültig - Über Ctrl/Stat Bits kann der Antrieb nun in Regelung versetzt werden - Die Initialisierung ist abgeschlossen

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs". Nahtlos im Anschluss an das DPRAM des SERCON816 sind die Register des Asics ab Adresse 0x1000 zu sehen.

Diagnose Eingänge

Die FC750x verfügt automatisch über verschiedene Diagnosevariablen, die den Zustand der Karte und des Sercos Ringes beschreiben:

ActualPhase: Es wird die aktuelle Phase des Sercos Ringes angezeigt.

RequestedPhase: Es wird die aktuell angeforderte Phase (z.B. von der SPS) angezeigt. Die Karte bzw. der Treiber versucht gerade diese Phase zu aktivieren.

SystemState: Gibt genaueren Aufschluss über die
momentane Phase:
0xE001 = Phase 0
0xE002 = Phase 1
0xE003 = Phase 2
0xE004 = Phase 3
0xE005 = Phase 4
0xE008 = Break
0xE011 = Phase switch 0 -> 1
0xE012 = Phase switch 1 -> 2
0xE013 = Phase switch 2 -> 3
0xE014 = Phase switch 3 -> 4

SystemError: zeigt den
aktuellen Fehler an:
0x0000 = No error
0x8005 = Drive addresses are incorrect
0x8006 = HS-timeout (service channel)
0x8007 = Double AT-failure
&    0x8009 = LWL-bus is interrupted
0xD002 = Switch from 2->3 failure (S-0-0127)
0xD003 = Switch from 3->4 failure (S-0-0128)
0xF001 = Configuration error (actual/nominal channel)
0xF002 = Error in the time slot calculation
0xF003 = Incorrect phase setting by the NC
0xF004 = Internal error
0xF005 = Error lifecounter
0xF008 = Double MDT-failure
0xF009 = Double MST-failure
0xF00A = Sync-In signal failure

TTimingErrorCnt1/b>: Ein Zähler, der inkrementiert wird, wenn die NC zu spät neue Sollwerte liefert ('Überprüfe Timing" muss angewählt sein).

TimingErrorCnt2reme: Ein Zähler, der inkrementiert wird, wenn die NC zu früh auf die Istwerte zugreift ('Überprüfe Timing" muss angewählt sein).

RDistErrorCnter zerstört empfangene Telegramme zählt (vergl. RDIST im Reference Manual des SERCON816). Ursache könnte eine falsche Baudrate sein.

FibBrErrorCnt: Ein Fehlerzähler, der zerstört empfangene Telegramme zählt (vergl. FIBBR im Reference Manual des SERCON816). Ursache könnte eine falsche Baudrate sein.

RErrErrorCnt: Ein Fehlerzähler, der verlorene oder zum falschen Zeitpunkt empfangene Telegramme zählt (vergl. RERR im Reference Manual des SERCON816).

MstLateErrorCnt: Ein Fehlerzähler, der zu spät empfangene MSTs zählt (vergl. MSTLATE im Reference Manual des SERCON816).

MstEarlyErrorCnt: Ein Fehlerzähler, der zu früh empfangene MSTs zählt (vergl. MSTEARLY im Reference Manual des SERCON816).


Indramat SERCANS SCS-P

TwinCAT System Manager: Reference

Indramat SERCANS SCS-P (ISA) und sci-worx SERCANS PCI

Die SERCANS SCS-P ist eine SERCOS Masterkarte für bis zu acht Achsen. Sie wird sowohl als ISA wie auch als PCI Typ unterstützt.

Das DPRAM der SERCANS SCS-P ist 4 KByte groß. Es wird eine Interrupt genutzt, den die Karte auslöst und im TwinCAT System zur Synchronisierung genutzt wird.

Kontextmenü

Box Anfügen... <Einfg>

Unterstützte Boxen | Beschreibung
SERCOS Achse | Sercos Achse
BK7500 | Buskoppler

Gerät Löschen... <Entf>

Entfernt die SERCANS SCS-P Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Karteireiter "Sercans SCS-P"

Adresse: ISA: Hier kann / muss die DPRAM Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert und kann folgende Werte annehmen: von 0xC0000 bis 0xEF000 in Schritten von 0x1000
PCI: Hier wird die PCI Slotnummer und der PCI Interrupt sowie DPRAM Adresse angezeigt.

Suchen: Hierüber können im Rechner vorhandene SERCANS-Karten von dem entsprechenden Typ (ISA / PCI) gesucht werden.

Cyclic IRQ: Hierüber wird der zyklische Interrupt eingetragen, den die benutzt. Er muss mit der Karteneinstellung (Jumper, nur ISA) übereinstimmen. Der nichtzyklische Interrupt der Karte wird nicht benötigt und darf auf der Karte nicht gejumpert werden (nur ISA).

Sync Master: Vergleiche "Synchronisierung mehrerer SERCANS Karten".

Phase 4: Hierüber wird angegeben, ob beim TwinCAT System Start die Karte in Phase 4 hochfahren soll, ansonsten bleibt sie in Phase 2 stehen und kann später per ADS in Phase 4 versetzt werden.

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs"

Synchronisierung mehrerer SERCANS Karten

Werden mehr als acht Achsen benötigt, müssen 2 oder mehrere SERCANS Karten eingesetzt werden. Diese Karten müssen untereinander synchronisiert werden, da nur eine Karte das TwinCAT System steuern kann. Die Karte, die TwinCAT synchronisiert wird als "Sync Master" bezeichnet und die entsprechende Checkbox darf nur bei dieser Karte angewählt sein. Die Vorgehensweise bei der Synchronisierung unterscheidet sich ob ISA oder PCI Karten eingesetzt werden, eine gemischte Verwendung von ISA und PCI Karten ist nicht möglich!

Synchronisierung von ISA Karten

Bei den "Slave" Karten muss der gleiche zyklische Interrupt eingestellt werden wie bei der "Master" Karte. Außerdem muss die Verbindung J100 auf der Rückseite der Karte getrennt werden (die Leiterbahn muss durchtrennt werden)! J100 befindet sich auf der Rückseite neben den durchgesteckten Interrupt-Jumpern. Soll die Karte später wieder als Master eingesetzt werden, so ist J100 durch einen Lötpunkt wieder zu schließen.

Synchronisierung von PCI Karten

Bei PCI Karten erfolgt die Synchronisierung über ein 10poliges Flachbandkabel (abgewinkelte Flachbandbuchse an der Oberseite), über das alle SERCANS Karten parallel verbunden werden. Außerdem muss bei der "Master" Karte am J108 ein Jumper zwischen PIN 1 und 2 gesetzt werden. Auf den "Slave" Karten darf dieser Jumper nicht gesetzt werden.


EtherCAT (Direct Mode) device

TwinCAT System Manager: EtherCAT

EtherCAT(Direct Mode) device

The EtherCAT(Direct Mode) is a Real Time Ethernet Device that only supports the EtherCAT protocol. Internally it uses the same network drivers as the standard Real-Time Ethernet device(see Ethernet Miniport (Real-Time)) . Install instructions for the network drivers can be viewed under Appendix C. The EtherCAT (Direct Mode) device should be used, if only EtherCAT slave devices are connected to the network adapter. It offers additional features not available in the standard Real-time Ethernet device. If you scan for the device, at least one EtherCAT slave device should be connected to the device, otherwise the Rt-Ethernet device is selected. To change the device type from Real-Time Ethernet device to EtherCAT(Direct Mode), you have to open the context menu of the device in the System Manager tree view. Then you have to select the menu entry "Change To/ EtherCAT(Direct Mode)":

EtherCAT(Direct Mode) "Adapter" tab

After adding an EtherCAT(Direct Mode) to the I/O configuration, the following "Adapter" tab is available on the right:

The Ethernet adapter currently selected is shown on this "Adapter" tab.

Search...: Looks for TwinCAT Real-Time Ethernet compatible devices and displays them.

MAC Address: MAC Address of this Ethernet controller

IP Address: Settings taken from Windows Registry. These can be changed under "Control Panel | Network Connections" in the TCP/IP 'Properties..' section.. If Real-Time Ethernet and "normal" Ethernet are both used on the same system with two different network adapters, the subnet addresses of these adapters (NICs) must differ! Nevertheless, the Real-Time Ethernet belonging devices have to be configured with the same subnet address (first two quadruples) as the Ethernet Miniport adapter and vice-versa, of course.

Freerun Cycle: The cycle time used if Free-Run is active (Config Mode only), can be set here. The cycle time in Run mode results automatically in reference to the task with the highest priority linked to the variables of the adapter or one of its nodes.

Lock I/O after Link Error: If this box is checked, the process data exchange doesn't resume automatically after a resolved link problem (e.g. when the network cable has been unplugged). In such a situation, an I/O Reset is necessary afterwards, instead.

Promiscuous Mode(use with Netmon/Ethereal only): This check box should only be enabled, if one wants to capture the network traffic with tools like Ethereal or the Microsoft Network monitor. If this box is checked, the Real-Time Ethernet miniport device copies all frames to the NDIS protocol layer of windows. This allows protocol drivers to capture the frames.

EtherCAT(Direct Mode) "EtherCAT" tab:

NetId: This is the NetId of the EtherCAT master device. The NetId is a parameter necessary for communicating with the EtherCAT master device via ADS. The ADS port of the EtherCAT master is always 0xFFFF(65535) and the Ads Port of an EtherCAT slave device is equal to the fixed address (see EtherCAT Addr) of the slave.

Advanced Settings...: Opens the Advanced Settings Dialog. This dialog contains additional settings for the EtherCAT master device.

Export Configuration File...: Creates the XML Master Configuration file . This file describes the process data and the frames sent during the EtherCAT state transitions.

Sync Unit Assignment...: Opens the "Sync Unit Assignment" dialog. This dialog can be used to group EtherCAT slave devices into separate sync units.

Topology...: Opens the Topology dialog. This dialog displays the topology of the configured EtherCAT slave devices.

The list view at the bottom displays all cyclic EtherCAT commands sent by the EtherCAT master:

Column | Description
Frame | The cyclic frame the EtherCAT command is contained in. One EtherCAT frame can contain one or more EtherCAT commands.
Cmd | The type of the command.
Addr | Address of the data section of the EtherCAT slave devices this command addresses. If the EtherCAT command uses logical addressing (LRW, LW or LR) "Addr" specifies the logical address. Otherwise the upper 16 Bit always specifies the physical memory address and the lower 16 Bits either the fixes address of the device (see EtherCAT Addr) or the auto increment address of the device (see Auto Inc Addr) dependent on the type of the command.
Len | Length of the data section.
WC | Expected working counter. Each EtherCAT slave that is addressed by an EtherCAT command increments the working counter. If it is a Logical Read Write(LRW) command each EtherCAT slave device data is written to increases the working counter by 2 and each EtherCAT slave data is read from increases the working counter by 1.
Sync Unit | Sync Unit the EtherCAT command belongs to.
Cycle Time(ms) | Cycle time with which the frame is sent.

EtherCAT(Direct Mode) "Online" tab:

Actual State: Shows the current state of the EtherCAT master device.

Send Frames: Shows the number of frames sent by the EtherCAT master device.

Frames: Shows the number of sent frames per second.

Init: Requests the 'Init' state from the master.

Pre-Op: Requests the 'Pre-Op' state from the master.

Safe-Op: Requests the 'Safe-Op' state from the master.

Op: Requests the 'Op' state from the master.

Clear CRC: Clears the CRC counters of the EtherCAT slave devices.

ClearFrames: Resets the counter displayed in the "Send Frames" edit box to 0.

The list view shows all the EtherCAT slave devices and their corresponding states and CRC counters:

Column | Description
No | Physical position of the device in the communication ring
Addr | Fixed address (see EtherCAT Addr) of the slave device.
Name | Name of the EtherCAT device
State | State of the EtherCAT slave device. The state can be either INIT, PRE-OP, SAFE-OP or OP. If the device cannot be found by the master or the slave is unable to change the state, ERR + the last known valid state is displayed.
CRC | CRC counter of the EtherCAT slave device. If an individual slave device is selected in the list, the CRC counters of the ports A,B and C(if in use) are listed in brackets.

To request a specific state from an individual EtherCAT slave device one has to right click on the slave device in the list view. This opens following context menu:

Now one can select one of the "Request 'xxx' state" menu items to set the device into a different state.


EtherCAT Master Diagnostics

TwinCAT System Manager: EtherCAT

EtherCAT Diagnostic Inputs

FrmXState: Variable of type WORD (or UINT), that shows the state of the frame X. For each EtherCAT command in the frame, a bit is reserved in FrmXState:

Bit | Description
0 (0x0001) | 1. EtherCAT command not sent (NOP requested)
1 (0x0002) | 2. EtherCAT command not sent (NOP requested)
2 (0x0004) | 3. EtherCAT command not sent (NOP requested)
...
14 (0x4000) | 15. EtherCAT command not sent (NOP requested)
15 (0x8000) | complete frame not sent

FrmXWcState: Variable of type WORD(or UINT), that shows the working counter states of the individual EtherCAT commands of the cyclic frame X. For each EtherCAT command in the frame, a bit is reserved in FrmXWcState:

Bit | Description
0 (0x0001) | wrong working counter of 1. EtherCAT command received
1 (0x0002) | wrong working counter of 2. EtherCAT command received
2 (0x0004) | wrong working counter of 3. EtherCAT command received
...
14 (0x4000) | wrong working counter of 15. EtherCAT command received
15 (0x8000) | complete frame missing

An EtherCAT frame can consist of one or more EtherCAT commands. Each of these commands has an expected working counter value. In other words the master knows, how many slave devices are addressed by an individual command and can calculate the expected working counter. If the master receives a wrong working counter this indicates, that one or more slaves have a problem. In this case the corresponding bit in FrmXWcState is set.

In the Example above only one frame (Frame0) is sent cyclically during process data communication. In the "EtherCAT" tab of the EtherCAT device one can see the individual cyclic frames and the EtherCAT commands contained in them :

The first command is a Logical Read Write command and the second is a broadcast read command. The LRW command is responsible for reading the inputs and writing to the outputs of one or more slave devices. The BRD(Broad Cast Read) command reads out the combined states of all slaves.

Slave Count: Number of slave devices connected to the EtherCAT master.

DevState: Device status information as WORD (or UINT) variable, assumes the following values:

Bit | Description:
0 (0x0001) | Link error detected.
1 (0x0002) | I/O locked after link error (I/O reset required)
2 (0x0004) | Link error (redundancy adapter)
3 (0x0008) | Missing one frame (redundancy mode)
4 (0x0010) | Out of send resources (I/O reset required)
5 (0x0020) | Watchdog triggered
6 (0x0040) | Ethernet driver (miniport) not found
7 (0x0080) | I/O reset active
8 (0x0100) | At least one device in 'INIT' state
9 (0x0200) | At least one device in 'PRE-OP' state
10 (0x0400) | At least one device in 'SAFE-OP' state
11 (0x0800) | At least one device indicates an error state
12 (0x1000) | DC not in sync

The bits 8-11 of the device state variable indicate if one or more Slave devices are in a specific state. During process data communication the slaves are in the state Operational. In this case bits 8-11 are set to 0. If one slave device is in the Init state instead of Operational, the bit 8 would be set (DevState = 0x0100).

EtherCAT Slave Device

Additionally to diagnostics inputs of the EtherCAT device, each slave device as a optional diagnostic input variable called WcState:

WcState: Variable of type BOOL, that shows the working counter state of the EtherCAT slave device. A value of 0 indicates a valid working counter and a value of 1 an invalid working counter. If the working counter is invalid, this indicates that the EtherCAT command, that is responsible for updating the inputs and outputs for this device, has an incorrect working counter. Because this command can address more than 1 slave device, the variable WcState of all involved devices will be set to invalid and one cannot determine the device that causes the problem with the help of this variable. To determine if an individual slave device has a problem, one can read out the state of the device with the help of the InfoData.State variable.

Info Data

If 'Info Data' is enabled (see Master Settings), the 'Info' device image is added to the EtherCAT device. Additionally an entry 'InfoData' is added to the EtherCAT device and to the connected EtherCAT slave devices. 'InfoData' contains input variables, that supply information about the EtherCAT device, that normally do not change very often. Variables mapped to the 'Info' images are not updated cyclically but only if the image has changed.

ChangeCnt: The ChangeCnt shows how often the contents of the image has changed.

DevId(optional): This is the device id of the EtherCAT device.

AmsNetId(optional): The AmsNetId is a parameter necessary for communicating with the EtherCAT master device via ADS. The ADS port of the EtherCAT master is always 0xFFFF(65535) and the Ads Port of an EtherCAT slave device is equal to the fixed address (see EtherCAT Addr) of the slave.

EtherCAT Slave Device

State: The 'State' variable holds the current EtherCAT state and link status of the EtherCAT slave device.

Value | Description
0x___1 | Slave in 'INIT' state
0x___2 | Slave in 'PREOP' state
0x___3 | Slave in 'BOOT' state
0x___4 | Slave in 'SAFEOP' state
0x___8 | Slave in 'OP' state
0x0010 | Slave signals error
0x0020 | Invalid vendorId, productCode... read
0x0100 | Slave not present
0x0200 | Slave signals link error
0x0400 | Slave signals missing link
0x0800 | Slave signals unexpected link
0x1000 | Communication port A
0x2000 | Communication port B
0x4000 | Communication port C
0x8000 | Communication port D

AdsAddr( optional ): The variable 'AdsAddr' holds the Ams netId and Ams port of the slave device. These are necessary parameters for communicating with the EtherCAT slave device via ADS. The variable 'AdsAddr' is added by default, if the slave supports a mailbox.

Chn0( optional for drives only): Drive channel.

Additional Diagnostic information

Additional non cyclic diagnostic information can be found on the Online tab of the EtherCAT device.


ADS Interface

Acyclic data can be transmitted to or from the EtherCAT device via ADS-Read or ADS-Write commands. It possible to communicate with the mailboxes of EtherCAT slave devices via ADS. Every EtherCAT device has its own Net-ID. The port depends on the individual Ads service :

Port | Description
65535 (0xFFFF) | General Ads services handled by the master directly.
0x1 - 0xFFFE (fixed address of a slave device) | This is an Ads services directed at an individual slave device. The port number is the same as the EtherCAT address of the slave device.

The NetId can be found in the edit field "NetId" on the EtherCAT tab of the EtherCAT master device:

The NetId can also be read out from the variable InfoData.AmsNetId:

Master Ads Port (0xFFFF)

The following table lists the Ads commands supported by the EtherCAT master port(0xFFFF):

Index Group | Index Offset | Access | Data type | Phys. unit | Def. range | Description | Remarks
0x00000003 0x00000100 R UINT16 Returns current state of master. Following values are returned by this service:

0x0000: Init State
0x0002: Pre-Operational State
0x0003: Bootstrap State
0x0004: Safe-Operational State
0x0008: Operational State

0x00000003 | requested state | W | Request State from master.
0x00000006 | 0x00000000 | R | UINT16 | Returns the number of projected slaves.
0x00000007 | 0x00000000 | R | UINT16[nSlaves] | Returns the fixed addresses of all slaves.
0x00000009 0x00000000 R { Returns the EtherCAT status and the Link status of all Slaves:
BYTE EtherCAT state of a slave. The state can adopt one of the following values:

0x0000: Init State
0x0002: Pre-Operational State
0x0003: Bootstrap State
0x0004: Safe-Operational State
0x0008: Operational State

Additionally following bits can be set:
0x0010: Error State
0x0020: Invalid VPRS( VendorId, Product Code, RevisionsNo or SerialNo)
0x0040: Initialization command error

BYTE Link status of an EtherCAT slave. The Link status can consist of an ORing of the following bits:

0x0000: Link ok.
0x0001: Link not present
0x0002: No communication
0x0004: Link missing
0x0008: Additional link
0x0010: Port A
0x0020: Port B
0x0040: Port C
0x0080: Port D

exampe: 0x0024 = Missing Link at port B.

}[nSlaves]
0x00000009 0x00000001-0x0000FFFF

(EtherCAT slave address)

R { Returns the EtherCAT status of the EtherCAT slave specified in the index offset.
BYTE EtherCAT state of a slave. The state can adopt one of the following values:

0x0000: Init State
0x0002: Pre-Operational State
0x0003: Bootstrap State
0x0004: Safe-Operational State
0x0008: Operational State

Additionally following bits can be set:
0x0010: Error State
0x0020: Invalid VPRS( VendorId, Product Code, RevisionsNo or SerialNo)
0x0040: Initialization command error

BYTE Link status of an EtherCAT slave. The Link status can consist of an ORing of the following bits:

0x0000: Link ok.
0x0001: Link not present
0x0002: No communication
0x0004: Link missing
0x0008: Additional link
0x0010: Port A
0x0020: Port B
0x0040: Port C
0x0080: Port D

exampe: 0x0024 = Missing Link at port B.

}
0x00000009 0x00000001-

0x0000FFFF

(EtherCAT slave address)

W UINT16 Request a new state from the selected EtherCAT slave.
0x00000011 0x00000001-

0x0000FFFF

(EtherCAT slave address)

R { Returns the CANopen identity object of an EtherCAT slave device.
UINT32 | Vendor Id
UINT32 | Product Code
UINT32 | Revision Number
UINT32 | Serial Number
}
0x00000012 0x00000000 R { Returns the Crc error counters of all slaves.
UINT32 Crc error counter of port A +

error counter of port B +
error counter of port C +
error counter of port D +

}[nSlaves]
0x00000012 0x00000001-

0x0000FFFF

(EtherCAT slave address)

 R { Returns the Crc error counters of the EtherCAT slave specified in the index offset.
UINT32 | Crc error counter of port A.
UINT32 | Crc error counter of port B.
UINT32 | Crc error counter of port C.
UINT32 | Crc error counter of port D.
}
0x0000000C 0 R { Returns frame counters and and lost frame counters
UINT32 | system time
UINT32 | number of cyclic frames sent by master
UINT32 | number of lost cyclic frames
UINT32 | number of acyclic frames sent by master
UINT32 | number of lost acyclic frames
}
0x0000000C | 0 | W | Resets the frame counters and lost frames counters

Slave Ads Port(0x1 - 0xFFFE)

The following table lists the Ads commands that can be sent to an EtherCAT slave device. The port number is same as the fixed address of the slave device:

Index Group | Index Offset | Access | Data type | Phys. unit | Def. range | Description | Remarks
CANopen over EtherCAT
0x0000F302 Index and Subindex of an SDO.

HIWORD(0xyyyy0000)= index

LOBYTE(0x000000yy)= subindex

Example:

0x1c120001:

index = 0x1c12
subindex = 1

HIBYTE of LOWORD (0x0000yy00):
0x01 Complete
Access

R/W UINT8[n] SDO Upload/Download Request. The object is selected with the index offset.
0x0000F3FC List type = HIWORD(0xyyyy0000)

Example

0x00000000: return length of the indiviual list types

0x00010000: return indexes of all objects

R { Returns the indexes of the list type specified in the index offset. If 0 is passed as index offset the length of each list type is returned.
UINT16 list type = 0 :number of list types

list type > 0 :list type

UINT16[n] list type = 0: length of the list type n+1

list type > 0: length of the selected list

}
0x0000F3FD | index = HIWORD(0xyyyy0000) | R | Get SDO info description
0x0000F3FE index = HIWORD(0xyyyy0000)

subindex = LOBYTE of LOWORD
(0x000000yy)

valueInfo = HIBYTE of LOWORD
(0x0000yy00)

R Get SDO info entry description
Servo Drive over EtherCAT
0x0000F420 IDN = LOWORD(0x0000yyyy)

element = LOBYTE of HIWORD
(0x00yy0000) :

0x01 | Data Status
0x02 | Name (read only)
0x04 | Attribute
0x08 | Unit
0x10 | Minimum
0x20 | Maximum
0x40 | Value
0x80 | Default

Drive Number = Bits 1-3 of HIBYTE of HIWORD
(0xy0000000)

Command Flag = Bit 8 of HIBYTE of HIWORD
(0xy0000000)

R/W UINT8[n] Upload/Download IDN


EtherCAT Slave Device

TwinCAT System Manager: EtherCAT

Sync Units

A Sync Unit describes a module, that defines a set of process data, that should be exchanged synchronously and consistently between the master and one or more EtherCAT slave devices. For each Sync Unit a separate EtherCAT command is sent synchronous with the cycle, to exchange the process data with the EtherCAT slave devices. Every Sync Unit has a diagnostic input, that is synchronous with the cycle and shows, if the complete data is valid (see WcState). Sync Units are useful in applications, where parts of the machine should keep on operating, although others parts have dropped out or have been deactivated.

Sync Unit Assignment

For each EtherCAT slave device, one can define one or more process data areas, that should be exchanged synchronously and consistently. These individual process data areas can be configured in the Process Data tab of a slave device. Normally every PDO object is assigned to the same process data area(Sync Unit). This is indicated by the column SU(Sync Unit) in the PDO List View:

In the example above all channels are assigned to the Sync unit 0. The number of independent process data areas of an EtherCAT slave device, depends on the implementation and resources of its EtherCAT slave controller(Sync Manager and Fmmu). The Sync Units of the EtherCAT slave devices can be assigned to Sync Units of a specific Sync Task. These Sync Units are marked with freely definable names. One can either assign each Sync Unit of a slave individually to a Sync Unit, by pressing the "Sync Unit Assignment..." on the "Process data" tab of a slave(see dialog above), or one can assign one or more slave Sync Units by pressing the "Sync Unit Assignment..." button on the "EtherCAT" tab of the EtherCAT master device:

Sync Unit Assignment dialog

To assign a Sync Unit to a process data area of an EtherCAT slave device, select an entry in the list view above. Then type the name of the Sync Unit in the edit field below or select one of the entries in the list box below. In the example above 'sync unit 1' of Task 1 is assigned to Sync Unit 0 of Term 1 and 'sync unit 2' of Task 1 is assigned to Sync Unit 0 of Term 3.

The 'EtherCAT' tab of the EtherCAT slave devices displays the cyclic frames sent by the EtherCAT master for the process data communication:

For each sync task taking part in process data communication a separate frame is sent. The maximal number of sync tasks is set to 4 by default. To change the maximal number of sync tasks, one has to open the Advanced Settings Dialog and select the Sync Tasks page. It is possible to assign one or more Sync Units for a specific task. Each of these Sync Units is assigned to a process data area of a slave device. For each Sync Unit of a sync task the EtherCAT frame contains a separate EtherCAT command. In the example above the first EtherCAT command of the first EtherCAT frame exchanges the process data of the EtherCAT devices assigned to the Sync Unit 1 of Task 1. In this case it is only the one EtherCAT slave device Term1(EL9800)(see Sync Unit Assignment dialog above). For each Sync Unit of a task an expected working counter is calculated, that is displayed in the column 'WC'.

Working Counter: The working counter of an EtherCAT command is a 16 bit counter. The counter is incremented by each EtherCAT slave, that is successfully addressed by the command. If only inputs are read from the EtherCAT slave device, the working counter is incremented by 1. If outputs are written to the EtherCAT slave device, the working counter is incremented by 2. If both inputs and outputs variables are exchanged the working counter is incremented by 3. If the working counter is incorrect the EhterCAT master discards the received inputs of the EtherCAT command.

For each frame the master has an diagnostic input 'FrmXWcState' (X =frame number), that shows the working counter states of the individual EtherCAT commands of the frame (see FrmXWcState). With 'FrmXWcState' it is not possible to verify which Term is responsible for the incorrect working counter . To retrieve more detailed information about the states of the individual slave devices, one has to read out the input variable InfoData.State of the slaves.

Example:

1. Open a new System Manager Project

2. Add a EtherCAT device to the I/O devices in the tree view of the system manager

3. Append an EK1100 and three EL1004 to the EtherCAT device.

4. Expand the entry 'System-Configuration' in the tree view of the system manager

5. Open the context menu of 'Additional Task' by right clicking on the subitem 'Additional Task' of 'System-Configuration'

6. Select the menu entry 'Append Task...' to add Task1

7. In the tab 'Task' of the additional task 'Task1' check the Auto-Start box and change the cycle time to 1 ms.

8. Repeat step 5 to 7 to add another task and set the cycle time to 5ms. The current configuration should look like this:

9. Next we will add input variables to the Task 2 and map these to the inputs of the terms. Right click on the entry 'Inputs' of Task 2 and select 'Insert Variable...' in the context menu. In the 'Insert Variable' dialog select 'Bit' as variable type and press the 'OK' button.

10. Double click on the newly created variable and map this variable to first input of Term 2. Add another two variables to Task 2 and map these to the first input of Term 3 and the first input of Term 4 :

11. Select the EtherCAT device in the tree view of the system manager and open the 'EtherCAT' tab on the right:

In the list view of this page we can see that one frame containing two EtherCAT commands is sent by the master. The first command is a LRW(Logical Read Write) command and is responsible for reading the inputs and writing to the outputs of one or more slave devices. The column 'Sync Unit' specifies the Sync Unit this command is assigned to. Because we have not yet assigned any Sync Units, the default Sync Unit is used. Because all variables are mapped to Task2, the value 'Cycle (ms)' is set to 5ms, the cycle time of Task2. The expected working counter(WC) is set to 3, one for each slave device. This is the case because the connected slaves devices have only input variables.

12. Next we will add two Sync Units and will assign one to the process data of the first EL1004(Term 2) and the others to Term 3 and Term4 . Press the button 'Sync Unit Assignment...' on the EtherCAT page to open the 'Sync Unit Assignment' dialog :

Select the first entry and type 'sync unit 1' into the edit field below. Now we have created a new Sync Unit called 'sync unit 1' and have assigned it to the Sync Unit 0 of Term2(EL2004). Then select the Term 3 and type 'sync unit 2' into the edit field and finally select term 4 and type 'sync unit 2' into the edit field again. Press the 'OK' button to close the dialog:

As a consequence of the Sync Unit assignment another EtherCAT command has been added to the list of cyclic commands. The first 'LRW' command is responsible for the process data communication of all EtherCAT slave devices belonging to the Sync Unit 'sync unit 1'. In our case this is only the Term 2. The second 'LRW' command is responsible for the process data communication of all EtherCAT slave devices belonging to the Sync Unit 'sync unit 2' (here Term 3 and Term 4). Now it is possible to monitor the working counter state of the first command and second command separately with help of the 'Frm0WcState' input variable:

If Term 2 returns an incorrect working counter bit 1 of the variable 'Frm0WcState' would be set to 1, indicating that a wrong working counter has been received for the first EtherCAT command. As a consequence the received data will be discarded and will not be copied to the input variable. If the second EtherCAT command has a correct working counter the received data for Term 3 and Term 4 will be processed normally. If the second EtherCAT command returns an incorrect working counter, bit 2 of 'Frm0WcState' is set. This indicates that either Term 3 or Term 3 or even both Term 2 and Term 3 have not incremented the working counter correctly. Therefore it is not possible to verify with 'Frm0WcState', which Term is responsible for the incorrect working counter . To retrieve more detailed information about the states of the individual slave devices one has to read out the variable InfoData.State.

13. Finally we will add a input variable to Task 1and map this variable to Channel 2 of Term 4:

14.Select the EtherCAT device in the tree view of the system manager and open the 'EtherCAT' tab on the right:

Here we can see that another frame has been added to the list. The first frame consists of only one LRW EtherCAT command with the cycle time of 1 ms, corresponding to the cycle time of Task 1 . This command is sent cyclically by the Task 1 and is responsible for reading the inputs of Term 4. Although the first input of Term 4 is mapped to the Task 2 the input is also read out by the EtherCAT command belonging to the Task 1. This is the case because Term 4 only has one process data area. In this case the task with the highest priority is selected for the process data communication with the slave device. The second frame is sent cyclically by the Task 2 with a cycle time of 5ms. The BRD command is always sent by the task with the lowest priority. The individual Sync Units can be viewed by pressing the 'Sync Unit Assignment ...' button:

Here we can see that the Sync Unit 0 of Term 4 is assigned to 'sync unit 2' of Task 2. Because we now have two frames, the input variables 'Frm1State' and 'Frm1WcState' have been added to the device. With the help of these inputs the state and the working counter state of the second frame can be read out.


EtherCAT Advanced Settings Dialog

After adding an EtherCAT(Direct Mode) to the I/O configuration, open the "EtherCAT" tab on the right and press the "Advanced Settings..." button. This opens the "Advance Settings" dialog. Following dialogs are included in the 'Advanced Settings' dialog:

Dialog |  | Description
StateMachine | Master Settings | General settings of the master.
 | Slave Settings | With the help of the 'Slave Settings' dialog the user can change settings for all EtherCAT slaves. To change these settings for an individual EtherCAT slave device, open the 'Advanced settings' dialog of the slave and open the 'Behaviour' dialog.
Cyclic Frames | Sync Tasks | With the help of 'Sync Tasks' dialog one can set the maximal number of sync tasks and the MTU of the cyclic Ethernet Frames sent by the master.
Distributed Clocks | Master | The 'Distributed Clocks Master' dialog enables the user to view and change the master settings of the distributed clocks.
Diagnosis | Online View | The 'Online View' dialog enables the user to add additional columns to the list view of the 'Online' tab of the EtherCAT device.

State Machine Master Settings:

Startup State: The EtherCAT master runs to checked state after startup . If for instance 'OP' is checked the EtherCAT master runs through all EtherCAT states to arrive at 'OP' state. To stay in the state 'INIT' after startup one would have to check the 'INIT' button.

Run Time Behaviour

Log Topology Changes: If this box is checked, topology changes are logged.

Log CRC Counters: If this box is checked, the CRC counters are logged.

ReInit after Communication Error: If this box is checked, all slaves are set to init after a communication error has occurred.

Info Data

Enable: If this box is checked, the 'Info' device image is added to the EtherCAT device:

Additionally an entry 'InfoData' is added to the EtherCAT device and to the connected EtherCAT slave devices. 'InfoData' contains input variables that supply information about the EtherCAT device, that normally do not change very often. Variables mapped to the 'Info' images are not updated cyclically, but only if the image has changed. The ChangeCnt shows how often the contents of the image has changed.

Include Device Id: If this box is checked, the input variable 'DevId' is added to InfoData. This is the device id of the EtherCAT device.

Include Ads NetId: If this box is checked, the input variable 'AmsNetId' is added to InfoData. The AmsNetId is a parameter necessary for communicating with the EtherCAT master device via ADS. The ADS port of the EtherCAT master is always 0xFFFF(65535) and the Ads Port of an EtherCAT slave device is equal to the fixed address (see EtherCAT Addr) of the slave.

State Machine Slave Settings:

With the help of the 'Slave Settings' dialog the user can change settings for all EtherCAT slaves. To change these settings for an individual EtherCAT slave device, open the 'Advanced settings' dialog of the slave and open the 'Behaviour' dialog.

Startup Checking

The user can specify which slave information should be checked by the master during startup.

Check Vendor Ids: If this box is checked, the master checks if the vendor id of each slave device is the same as the configured one.

Check Product Codes: If this box is checked, the master checks if the product code of each slave device is the same as the configured one.

Check Revision Numbers: If this box is checked, the master checks if the revision number of each slave device is the same as the configured one.

Check Serial Numbers: If this box is checked, the master checks if the serial number of each slave device is the same as the configured one.

State Machine

Auto Restore States: If this box is checked, the EtherCAT master tries to restore the state of an EtherCAT slave automatically. If an EtherCAT slave device changes from error state (ERR SAFE-OP, ERR OP etc.) to a valid state(SAFE-OP, OP etc), the EtherCAT master tries to set the device to the current state of the master.

ReInit after Comm. Error:

Info Data

To enable this group, the Info Data has to be enabled in the 'Master Settings' dialog.

Include State: If this box is checked, the input variable 'State' is added to the InfoData entry of each EtherCAT slave. This variable holds the current EtherCAT state and link status of an EtherCAT slave.

Include Ads Address: If this box is checked, the input variable 'AdsAddress' is added to the InfoData entry Info of each EtherCAT slave. This variable is added by default for all EtherCAT slaves, that support a mailbox protocol like CoE(CANopen over EtherCAT) or SoE.

Include Drive Channels: If this box is checked, the input variables 'ChnX'(X=Channel number) are added to the InfoData entry of every drive.

Synchronization Sync Tasks:

With the help of 'Sync Tasks' dialog one can set the maximal number of sync tasks and the MTU of the cyclic Ethernet Frames sent by the master.

Max Sync Tasks: Maximal number of tasks that can take part in process data communication. How many tasks really take part in the process data communication, depends on the mapping of the variables of the EtherCAT slave devices. For each task that takes part in process data communication at least one EtherCAT frame is sent cyclically. If "Max Sync Tasks" is set to two and the configuration consists of two EtherCAT slave devices whose variables are mapped to two different tasks, two tasks would take part in the process data communication. If the variables were mapped to the same task, only one task would take part in the process data communication.

MTU: The MTU(Maximum Transmission Unit) specifies the maximum size in bytes of the cyclic Ethernet Frames sent by the master. The minimum size is 28 Bytes ( 14 Bytes(Ethernet-Header) + 2 Bytes(E88A4-Header) + 10 Bytes(EtherCAT-Header) + 0 Byte( EtherCAT Data) + 2 Bytes(EtherCAT working counter)) and the maximum size 1514 (14 Bytes(Ethernet-Header) + 2 Bytes(E88A4-Header) + 10 Bytes(EtherCAT-Header) + 1486 Bytes( EtherCAT Data) + 2 Bytes(EtherCAT working counter)).

Synchronization Distributed Clocks:

The 'Distributed Clocks Master' dialog enables the user to view and change the master settings of the distributed clocks.

No Sync: In this mode no synchronization of the EtherCAT devices takes place.

Topology Only: In this mode no synchronization of the EtherCAT devices takes place, but the topology is calculated by the master. The master needs to know the topology to be able to calculate the delay time between the slaves. As a consequence this calculation is always performed in the "Sync Slave" and "Sync Master" mode.

Sync Slave: In this mode synchronization of the EtherCAT devices takes place, and the EtherCAT master is used as reference clock. As a consequence the Master sends a BWR(Broad cast write) command cyclically to distribute the system time to all slaves. Because the master clock is not as accurate as the clock of an EtherCAT slave device one should normally prefer the 'Sync Master' mode and set the first EtherCAT device as reference clock.

Sync Master: In this mode synchronization of the EtherCAT devices takes place, and the EtherCAT slave right to "Sync Master" is set as reference clock. As a consequence the master cyclically sends an EtherCAT command to read out the system time of the "Sync master" device and distributes this time to all other slave devices.

The "Sync Master" mode is disabled if no device is set as reference clock. To activate this mode one has to configure a slave device as a reference clock device (see Distributed Clock Settings ). The first three Sync modes are disabled if a reference clock device is set. To be able to select one of these modes no slave device is allowed to be set as reference clock:

1. Select the "Sync Master" device in the tree view of the System Manager

2. Go to the EtherCAT tab and press the "Advanced Settings..." button. This opens the Advanced Settings dialog.

3. Select the entry "DistributedClocks/Settings" in the tree view of the dialog.

4. Uncheck the entry "Reference Clock Device"

Diagnosis Online View:

The "Online View" dialog enables the user to add additional columns to the list view of the "Online" tab of the EtherCAT device. The additional columns display the contents of the ESC registers selected in this dialog. One can either select a specific register by checking a specific item in the list view or typing an address in the edit field and pressing the "Add" button.

Show Change Counters: If this box is checked, a column is added to the list view of the "Online" tab displaying two counters separated by a slash. The first counter displays the number of abnormal state change. The second counter displays how often the communication to the slave device has been lost.

Example:

To display the physical address and the Soccom Build of an EtherCATSlave device we would have to select the item 0002 and the item 0010 in the list view:

Next you have to close the "Advanced Settings" dialog and go to the "Online" tab of the EtherCAT master device. Here you can see that two new columns have been added to the list view, one for the "Soccom Build"(Reg:0002) and one for the physical address of the EtherCAT device(Reg:0010).


EtherCAT Topology Dialog

TwinCAT System Manager: EtherCAT

EtherCAT Topology-Dialog

Selektieren Sie in der Baumansicht das EtherCAT Gerät, dessen Topologie Sie anzeigen wollen. Dann öffnen Sie den EtherCAT-Reiter in der rechten Seite und betätigen Sie die Topologie... Schaltfläche. Dies öffnet den Topology-Dialog:

Menü View

Zoom (1.0 x)

Ansicht wird in Orginalgröße angezeigt.

Zoom (1.5 x)

Ansicht wird um den Faktor 1,5 vergrößert angezeigt.

Zoom (2.0 x)

Ansicht wird um den Faktor 2,0 vergrößert angezeigt.

Menü Offline

Show Topolgy

Zeigt die Offline-Topologie des selektierten EtherCAT-Gerätes an.

Menü Online

Show Topolgy

Zeigt die konfigurierte Online-Topologie des selektierten EtherCAT-Gerätes an (siehe Online Anzeige ).

Compare To->Found Devices

Führt ein Scan des Busses durch und vergleicht die eigentliche Topologie mit der konfigurierten Topologie.

Compare To->Offline Configuration

Vergleicht die Topologie der aktivierten Online-Konfiguration mit der Topologie der geöffneten System-Manager Konfiguration.


EtherCAT Cable Redundancy

TwinCAT System Manager: EtherCAT Kabel-Redundanz

EtherCAT Kabel-Redundanz

TwinCAT verwendet einen zweiten Netzwerk-Adapter um die EtherCAT Kabel-Redundanz zu realisieren. Die EtherCAT-Frames werden von beiden Netzwerk-Adaptern gleichzeitig verschickt. Der zweite Netzwerk-Adapter muss an einen freien Ethernet-Port eines EtherCAT-Slaves angeschlossen sein. Die EtherCAT-Frames wandern nun vom ersten Adapter durch alle Slaves und kommen dann am zweiten Adapter an. Die EtherCAT Frames vom zweiten Adaptern bewegen sich in die entgegengesetzte Richtung. Im Fall eines einzigen Kabel-Fehlers entlang des Redunanz-Pfades vom ersten EtherCAT-Adapter zum zweiten Adapter, sind immer noch alle EtherCAT-Slaves erreichbar.

Konfigurieren der Kabel-Redundanz

Folgende Schritte beschreiben wie die Kabel-Redundanz mit dem System-Manager konfiguriert wird:

1. Verbindung zum zweiten Ethernet-Adapter trennen.

2. Selektieren Sie das EtherCAT-Gerät in der Baumansicht des System-Managers und öffnen Sie das Kontext-Menu mit einem Rechts-Klick. Im Kontext-Menu selektieren Sie den Eintrag "Scan Boxes..".

3. Öffnen Sie den "EtherCAT"-Reiter des EtherCAT-Gerätes und drücken Sie die "Erweiterte Einstellungen..." Schaltfläche, um den "Erweiterte Einstellungen"-Dialog zu öffnen.

4. Selektieren Sie den Eintrag "Redundanz/Modus" in der Baumansicht auf der rechten Seite des "Erweiterte Einstellungen"-Dialoges:

5. Wählen Sie den Eintrag "Zweiter Adapter" aus und drücken Sie die "Suchen..."-Schaltfläche um den Ethernet-Adapter für die Redundanz auszuwählen.

6. Als nächstes müssen Sie unten den Redundanz-Port auswählen. Dies ist der Ethernet-Port eines EtherCAT-Slaves, an den der zweiter Adapter angeschlossen ist. Abhängig von der Topologie kann man zwischen einem oder mehreren Ports auswählen. Hierbei ist es wichtig, dass im Betrieb der zweite Ethernet-Adapter genau an diesem Port angeschlossen ist. Ansonsten funktioniert die Redundanz nicht ordnungsgemäß.

Beispiel:

Die obige Konfiguration hat folgende Topologie:

Der Redundanz-Adapter kann nun entweder am freien Port von Term 2 (EK1100):

oder am freien Port von Term 6 (EK1100):

oder am freien Port von Term 8 (EK1110) :

Die blau Linie zeigt den Redundanz-Pfad an. Entlang dieses Pfades ist ein einziger Kabel-Fehler möglich, ohne dass die Kommunikation zu den EtherCAT-Slaves unterbrochen wird.

7. Verbinden Sie den zweiten Adapter mit dem unter 6 eingestellten Ethernet-Port.

8. Aktivieren Sie die Konfiguration oder Laden Sie die Geräte neu im Config-Modus, um den Redundanz-Modus zu aktivieren


EtherCAT (Direct Mode) device

TwinCAT System Manager: EtherCAT

Unterstützte Netzwerk Controller (Supported Network Controller by Beckhoff Ethernet Driver)

Intel Fast Ethernet Controllers (Vendor ID: 0x8086)

Device ID | Description
0x1029 | 82559
0x1030 | 82559
0x1031 | 82801CAM
0x1032 | 82801CAM
0x1033 | 82801CAM
0x1034 | 82801CAM
0x1038 | 82801CAM
0x1039 | 82801CAM
0x103A | 82801DB
0x103B | 82801DB
0x103C | 82801DB
0x103D | 82801DB
0x103E | 82801DB
0x1050 | 82801EB/ER
0x1051 | 82801EB/ER
0x1052 | 82801EB/ER
0x1053 | 82801EB/ER
0x1054 | 82801EB/ER
0x1055 | 82801EB/ER
0x1056 | 82801EB/ER
0x1057 | 82801EB/ER
0x1059 | 82551QM
0x1064 | 82801EB/ER
0x1067 | Intel PRO/100
0x1068 | 82562
0x1069 | Intel PRO/100
0x106A | Intel PRO/100
0x106B | Intel PRO/100
0x1094 | Intel PRO/100
0x1209 | 8255xER/IT
0x1229 | 82557/8/9/0/1
0x1249 | 82559ER
0x1259 | 82801E
0x245D | 82801E
0x27DC | Intel PRO/100

Intel Gigabit Ethernet Controllers (Vendor ID: 0x8086)

Device ID | Description
0x1000 | 82542
0x1001 | 82543GC
0x1004 | 82543GC
0x1008 | 82544EI
0x1009 | 82544EI
0x100C | 82544EI
0x100D | 82544GC
0x100E | 82540EM
0x100F | 82545EM
0x1010 | 82546EB
0x1011 | 82545EM
0x1012 | 82546EB
0x1013 | 82541EI
0x1014 | 82541ER
0x1015 | 82540EM
0x1016 | 82540EP
0x1017 | 82540EP
0x1018 | 82541EI
0x1019 | 82547EI
0x101A | 82547EI
0x101D | 82546EB
0x101E | 82540EP
0x1026 | 82545GM
0x1027 | 82545GM
0x1028 | 82545GM
0x1049 | 82566MM
0x104A | 82566DM
0x104B | 82566DC
0x104C | 82562V
0x104D | 82566MC
0x104E | 82571EB
0x104F | 82571EB
0x1060 | 82571EB
0x1075 | 82547EI
0x1076 | 82541GI
0x1077 | 82547EI
0x1078 | 82541ER
0x1079 | 82546EB
0x107A | 82546EB
0x107B | 82546EB
0x107C | 82541GI
0x107D | 82572EI
0x107E | 82572EI
0x107F | 82572EI
0x108A | 82546GB
0x108B | 82573E
0x108C | 82573E
0x1096 | 80003ES2LAN
0x1098 | 80003ES2LAN
0x1099 | 82546GB
0x109A | 82573L
0x10A4 | 82571EB
0x10A7 | 82575
0x10A9 | 82575
0x10B5 | 82546GB
0x10B9 | 82572EI
0x10BA | 80003ES2LAN
0x10BB | 80003ES2LAN
0x10BC | 82571EB
0x10BD | 82566DM
0x10C4 | 82562GT
0x10C5 | 82562G
0x10C9 | 82576
0x10CB | 82567V - ICH9
0x10D3 | 82574L
0x10E5 | 82567LM-4 - ICH9
0x10E6 | 82576 (Fiber)
0x10E7 | 82576 (Serdes)
0x10E8 | 82576 (Quad Copper)
0x10EA | 82577LM
0x10EB | 82577LC
0x10EF | 82578DM
0x10F0 | 82578DC
0x10F2 | 82579LM
0x10F3 | 82567LM
0x10F5 | 82579V


Ethernet Miniport (Echtzeit)

Der Echtzeit Ethernet Treiber ermöglicht mit entsprechend kompatiblen Ethernet Adaptern eine gleichzeitige Nutzung eines Ethernet Netzes für TwinCAT Echtzeit Anwendungen und "normalen" Anwendungen, die über den Stack des Betriebssystems gehen (z.B. per TCP/IP).

Echtzeit Ethernet kompatible Geräte

Der Echtzeit Ethernet Miniport Treiber von TwinCAT kann mit allen Ethernet Adaptern der Intel 8255x Familie und dem integrierten Ethernet Adapter des Intel I/O Hubs ICH4 (z.B. integriert im i845 Chipset) genutzt werden. Hierbei ist mindestens Windows 2000 als Betriebssystem Voraussetzung. Zur Nutzung in der Echtzeit-Umgebung von TwinCAT ist vorher der automatisch vom Betriebssystem installierte Treiber zu ersetzen. Außerdem wird ein weiterer Protokoll-Treiber "TwinCAT Ethernet Protokoll" benötigt. Wie dieses durchgeführt wird, ist im Anhang C beschrieben.

Um festzustellen, ob kompatible Ethernet Adapter im System vorhanden sind, hilft der Dialog "TwinCAT Ethernet kompatible Geräte", der über das Menü "Optionen | Liste Echtzeit Ethernet kompatible Geräte..."des System Managers zu erreichen ist:

"TwinCAT Ethernet Protokoll" installiert: Die Checkbox zeigt an, ob der TwinCAT Protokoll Treiber bereits installiert ist.

Installierte und benutzbare Geräte: Listet die bereits mit dem TwinCAT Treiber versehenen Adapter auf. Diese Adapter sollten im System Manager verfügbar sein.

Installierte Geräte aber ohne notwendiges Binding zu 'TwinCAT Ethernet Protokoll': Hier werden die Adapter aufgelistet, die zwar den TwinCAT Treiber benutzen, denen aber das notwendige Binding zum Protokoll fehlt. Bitte überprüfen Sie die Installation anhand der Beschreibung aus Anhang C.

Kompatible Geräte mit inkompatiblem Treiber: Listet alle vorhandenen Adapter auf, die durch Austausch des Treibers Echtzeit Ethernet unterstützen (siehe Anhang C).

WARNUNG: Windows Update oder Service Pack Installationen

Der Vorteil, dass bei Echtzeit Ethernet auf Standard Hardware zurückgegriffen wird, hat auch einen kleinen Nachteil: Das Betriebssystem kennt die entsprechende Hardware und versucht in bestimmten Situationen die seiner Meinung nach neuesten und "besten" Treiber für diese Hardware zu installieren. Dieses wird einerseits beim "Windows Update" als auch beim Installieren eines Service Packs durchgeführt. Nach einer Service Pack Installation muss daher der Schritt aus Anhang C wiederholt werden. Das automatische Windows Update lässt sich unterbinden und bei manuellen Updates sollte der Vorschlag, den "Intel Networking Driver" auszutauschen nicht angenommen werden. Nach einem entsprechendem Vorgang kann in jedem Fall die aktuelle Installation mit dem oben aufgeführten Dialog überprüft werden.

Ethernet Miniport "Adapter"

Auf dem Karteireiter "Adapter" wird der aktuell ausgewählte Ethernet Adapter angezeigt und konfiguriert.

Suchen...: Es werden alle kompatiblen Geräte angezeigt und zur Auswahl angeboten.

IP Addresse: Die angezeigte IP-Adresse wurde aus der Windows Registry ausgelesen. Mit der Hilfe von "Systemsteuerung | Netzwerkverbindungen" kann die Adresse im Bereich TCP/IP 'Eigenschaften..' geändert werden. Falls Echtzeit Ethernet and "normales" Ethernet auf dem selben System mit zwei unterschiedlichen Netzwerkadaptern genutzt werden, müssen sich die Subnet-Adressen dieser beiden Adapter unterscheiden! Natürlich müssen die zum Echtzeit Ethernet gehörenden Geräte mit der selben Subnet-Adresse (ersten zwei Stellen der TCP/IP Adresse) konfiguriert werden, wie der Ethernet Miniport Adapter, und umgekehrt.

Freerun Zykluszeit: Hier kann die Zykluszeit im Freerun (nur im Konfig Modus) in Millisekunden vorgegeben werden. Die Zykluszeit im Run Modus ergibt sich automatisch durch die Zykluszeit der höchstprioren Task, die mit Variablen des Adapters oder eines seiner Teilnehmer verknüpft ist.

E/A nach Link Fehler sperren: Wird diese Checkbox angewählt, wird nach einem behobenem Link Fehler (z.B. Ziehen und Wiederaufstecken des Netzwerkkabels) nicht automatisch wieder mit dem Prozessdaten Austausch begonnen, sondern es ist zuvor ein E/A Reset notwendig.

Unterstützte Geräte / Protokolle

Eine Auflistung der unterstützten Geräte zeigt die Übersicht. Da mit Hilfe des TwinCAT Echtzeit Ethernet Treibers alle Ethernet Protokolle betrieben werden können, sowohl Standard Protokolle als auch spezielle Echtzeit Protokolle ist die Liste der unterstützten Geräte nur eine Momentaufnahme und wird sicher in Zukunft weiter ausgebaut.

Status-Informationen

Unterhalb eines konfigurierten RT Ethernet Adapters findet man eine Status und eine Control Variable. Diese Variablen können mit denen anderer Tasks verküpft werden (z.B. mit einer TwinCAT PLC Tasks).

Eingänge:

Variable | Beschreibung
DevState | Gerätestatusinformation als WORD (oder UINT) Variable. Die Variable kann folgende Werte annehmen: 0x0001 = Link Error (Netzwerkverbindung physikalisch unterbrochen) 0x0002 = E/A gesperrt nach Link Error (E/A Reset notwendig nach Behebung) 0x0010 = Keine Senderesourcen vorhanden (E/A Reset notwendig nach Behebung) 0x0020 = Watchdog hat zugeschlagen 0x0040 = TwinCAT Real-Time Ethernet Treiber nicht gefunden 0x0080 = E/A Reset aktiv

Ausgänge:

Variable | Beschreibung
DevCtrl | Steuervariable für das Gerät vom Typ WORD (oder UINT). Hat momentan (noch) keine Auswirkung auf den Netzwerkadapter!


Virtuelle Ethernet-Schnittstelle

Die virtuelle Ethernet-Schnittstelle bindet, im Windows NT / 2000 / XP-System konfigurierte, Netzwerkadapter in das TwinCAT System ein. Von dieser Netzwerkkarten-unabhängigen, virtuellen Ethernet-Schnittstelle ausgehend, können dann im weiteren Verlauf Beckhoff Ethernet-Feldbusgeräte zur TwinCAT E/A-Konfiguration hinzugefügt bzw. angesprochen werden.

Kontextmenü

Box Anfügen... <Einfg>

Fügt Ethernet-Teilnehmer ("Boxen") an. Eine detaillierte Liste aller unterstützten Boxen finden sie unter: Übersicht

Gerät Löschen... <Entf>

Entfernt die virtuelle Ethernet-Schnittstelle und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf allen, von dieser virtuellen Ethernet-Schnittstelle aus angesprochenen, Beckhoff Ethernet Slaves.

Karteireiter "ADS"

Siehe unter: "Einstelldialog ADS".


Virtuelle USB-Schnittstelle

Die virtuelle USB-Schnittstelle bindet eine, in einem Windows2000 oder Windows XP-System konfigurierte, USB-Schnittstelle in das TwinCAT System ein. Von dieser virtuellen USB-Schnittstelle ausgehend, können dann im weiteren Verlauf sowohl Beckhoff USB-Feldbusgeräte, als auch Tastererweiterungen an Beckhoff Control Panel mit USB-Schnittstelle, zur TwinCAT E/A-Konfiguration hinzugefügt und angesprochen werden.

Kontextmenü

Box Anfügen... <Einfg>

Fügt Beckhoff USB-Teilnehmer ("Boxen") an. Eine detaillierte Liste aller unterstützten Boxen finden sie unter: Übersicht

Gerät Löschen... <Entf>

Entfernt die virtuelle USB-Schnittstelle und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf allen, von dieser virtuellen USB-Schnittstelle aus angesprochenen, Beckhoff USB Slaves

Scan and create USB devices

Sucht nach angeschlossenen Beckhoff USB-Geräten (einschließlich eventuell daran angeschlossener Beckhoff Busklemmen) und konfiguriert Baumeinträge zu den gefundenen Geräten, entsprechend deren Einstellungen.

Karteireiter "ADS"

Siehe unter: "Einstelldialog ADS".

mk:@MSITStore:BkWeb.chm::/HTML/german/busterm/bk9000.htm

mk:@MSITStore:BkWeb.chm::/HTML/german/busterm/bk9500.htm

mk:@MSITStore:BkWeb.chm::HTML/german/ipc/cp6000.htm


Virtuelle USB-Schnittstelle - Anbindung von Control Panel mit DVI/USB-Anschluss

TwinCAT System Manager: Reference

Virtuelle USB-Schnittstelle- Anbindung von CP68xx, CP69xx, CP78xx und CP79xx

Folgende Einstellungen sollten für die Ansteuerung von Control Panel mit DVI/USB-Anschluss (CP68xx, CP69xx, CP78xx und CP79xx ) beachtet werden, siehe Screeenshot:

  • Zykluszeit:
    Die SPS-Zykluszeit für USB Geräte sollte zwischen 50 und 80 ms liegen. Gegebenenfalls muss eine zusätzliche Task angelegt werden.
  • Async Mode:
    Kann keine weitere Task angelegt werden oder zu Testzwecken kann auch der Async Mode genutzt werden. Dieser ist unabhängig von anderen Zykluszeiten und erlaubt trotzdem Verknüpfungen zur schnelleren Task. Allerdings wird das I/O Abbild dementsprechend langsamer erneuert.
  • Mapping:
    Im Mapping kann kontrolliert werden, ob man zufällig eine schnellere Task mit dem USB-Gerät verbunden hat.


Beckhoff CP9030

Die CP9030 ISA-Karte dient als PC-seitiger Anschluss des Beckhoff Control Panel - Link Systems . Hierüber können Beckhoff Control Panel über ein Koaxialkabel in großer Entfernung zum PC angeschlossen werden. Neben der Übertragung der Bildsignale, Mauspad/Touchscreen und Tastatureingaben können die Control-Panels zusätzliche Sondertasten und LEDs besitzen, die über TwinCAT gelesen bzw. geschrieben werden können (siehe auch: Beckhoff IPC - Sondertasten und USV).

Karteireiter "CP9030"

Adresse: Hier kann / muss die DPRAM Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert und kann Werte von 0xC8000 bis 0xEF000, in Schritten von 0x0080, annehmen.

Suchen: Hierüber können im PC gesteckte CP9030 Karten gesucht werden. Alternativ kann der PC nach TwinCAT unterstützte I/O Geräte, über -> "Geräte Suchen", durchsucht werden. Die eingestellten Adressen der gefundenen CP9030 Karten, werden danach automatisch unter Adresse angezeigt.

Tasten: Hier wird die Anzahl der am Control Panel vorhanden Sondertasten eingestellt (siehe hierzu auch "BECKHOFF Knowledge Base").

LEDs: Hier wird die Anzahl der am Control Panel vorhanden LEDs eingestellt (siehe hierzu auch "BECKHOFF Knowledge Base").

Async Mode: Bei aktivierter Checkbox läuft die Kommunikation des I/O-Treibers mit der CP-Link Karte auch dann weiter, wenn die verknüpfte Task (z.B. eine SPS Task) nicht aktiv ist.

Firmware: Zeigt die Firmware-Version der eingebauten CP9030 Karte an.

Firmware Update: Mit dieser Funktionalität kann man ein Update der CP9030 Firmware einleiten.

Hinweis: Einstelloptionen, die im obigen Bild ausgegraut sind, sind nicht relevant für die CP9030 sondern beziehen sich auch die Beckhoff CP9035.

Karteireiter "USV"

Siehe: "Beckhoff IPC - Sondertasten und USV"

Karteireiter "ADS"

Siehe -> "ADS/AMS Einstellungen bei E/A Geräten"

Karteireiter "DPRAM (Online)"

Siehe "Online - Anzeige des DPRAMs"

E/A Variablen:

Eingänge:

S1 - Sn: Eingangsstatus der entsprechenden Sondertasten (siehe Beckhoff Knowledge Base)

TermDiag: Hier kann die Statusvariable für die -> "Erweiterte Klemmendiagnose" verknüpft werden.

PlcIFace: Hier kann die Statusvariable des SPS-Interfaces verknüpft, bzw. deren aktueller Wert überprüft werden.

KBusErr: Fehlerzustand eines eventuell am Control Panel angeschlossenen K-Busses

CnfErr: Konfigurationsfehler

PDLenErr: Prozessdatenlängenfehler

ExtVoltageOk: Zustand der externen Spannung (bei aktiver USV)

AkkuVoltageOk: Zustand der Batterie-Spannung (bei aktiver USV)

AkkuCharging: Batterie wird geladen (bei aktiver USV)

AkkuNotPresent: Batterie nicht gefunden (bei aktiver USV)

AkkuCharged: Batterie vollständig geladen (bei aktiver USV)

AkkuWaiting: Ladezustand der Batterie wird überprüft. Ladevorgang ist momentan unterbrochen

IdentSwitch: Wert des auf der Karte eingestellten Dip-Switch

ComErr: Kommunikationsfehler zwischen Control Panel und CP9030 Karte

Ausgänge:

LED 1 -n: Ausgangsbits zum Ansteuern der LEDs (siehe Beckhoff Knowledge Base)

TermDiag: Hier kann die Statusvariable für die -> "Erweiterte Klemmendiagnose" verknüpft werden.

PlcIFace: Hier kann die Statusvariable des SPS-Interfaces verknüpft, bzw. deren aktueller Wert überprüft werden.

EnableUPS: Ausgangsbit zum manuellen Aktivieren der USV (nur zu benutzen, wenn die USV nicht über die USV-Konfiguration aktiviert wurde)

DisplayOff: Schaltet die Hintergrundbeleuchtung des Control Panels aus

KbdOff: Schaltet die Tastatur des angeschlossenen Control Panels aus (wichtig, wenn mehrere Control Panels über mehrerer CP9030 Karten angeschlossen sind)

HINWEIS:

Damit die Daten zwischen Control Panel und CP9030 ausgetauscht werden, muss mindestens eine Variable verknüpft sein. Die verknüpfte Task muss laufen, oder der weiter oben erwähnte Async Mode muss eingestellt sein! Ansonsten wird das Handshake zwischen PC und CP9030 nicht bedient, d.h. es werden keine Daten mit dem Control Panel ausgetauscht.


Beckhoff CP9035

Die CP9035 Karte dient als PC-seitiger Anschluss des Beckhoff Control Panel - Link Systems. Im Gegensatz zur CP9030 Karte, belegt die CP9035 einen PCI-, statt eines ISA-Slots.
Über CP-Link können Beckhoff Control Panel über ein Koaxialkabel in großer Entfernung zum PC angeschlossen werden. Neben der Übertragung der Bildsignale, Mauspad/Touchscreen und Tastatureingaben, können die Control Panels zusätzliche Sondertasten und LEDs besitzen, die über TwinCAT gelesen bzw. beschrieben werden können (siehe auch: Beckhoff IPC - Sondertasten und USV).

Karteireiter "CP9035"

PCI Bus/Slot: Hier kann / muss der verwendete PCI Slot, in dem die CP9035 Karte steckt, eingestellt werden (siehe auch Suchen).

Suchen: Hierüber können die, im Rechner vorhandenen, CP9035 Karten gesucht werden. Der jeweils verwendete PCI Slot wird hierbei automatisch erkannt. Alternativ kann der PC auch über -> "Geräte Suchen" nach, von TwinCAT unterstützte, I/O Geräte untersucht werden.

Tasten: Hier wird die Anzahl der am Control Panel vorhanden Sondertasten eingestellt (siehe hierzu auch "BECKHOFF Knowledge Base").

LEDs: Hier wird die Anzahl der am Control Panel vorhanden LEDs eingestellt (siehe hierzu auch "BECKHOFF Knowledge Base").

Async Mode: Bei aktivierter Checkbox läuft die Kommunikation des I/O-Treibers mit der CP-Link Karte auch dann weiter, wenn die verknüpfte Task (z.B. eine SPS Task) nicht aktiv ist.

PCI-Cfg: Durch Nutzung dieser Schaltfläche kann die Adresse der CP9035 im PC in einen tieferen Bereich gesetzt werden (unterhalb 1 MB).

Upload Configuration: Scannt den K-Bus-Anschluss der CP9020 im Control Panel nach eventuell angeschlossenen Busklemmen (z.B. für Handräder oder Potentiometer).

Firmware: Zeigt die Firmware-Version der eingebauten Karte an.

Firmware Update: Mit dieser Funktionalität kann man ein Update der CP9035 Firmware einleiten.

Karteireiter "USV"

Siehe "Beckhoff IPC - Sondertasten und USV"

Karteireiter "ADS"

Siehe "ADS/AMS Einstellungen bei E/A-Geräten"

Karteireiter "DPRAM (Online)"

Siehe "Online - Anzeige des DPRAMs"

E/A Variablen:

Eingänge:

S1 - Sn: Eingangsstatus der entsprechenden Sondertasten

TermDiag: Hier kann die Statusvariable für die -> "Erweiterte Klemmendiagnose" verknüpft werden.

PlcIFace: Hier kann die Statusvariable des SPS-Interfaces verknüpft, bzw. deren aktueller Wert überprüft werden.

Fan: Aktuell nicht verwendet

KBusErr: Fehlerzustand eines eventuell am Control-Panel angeschlossenen K-Busses

CnfErr: Konfigurationsfehler (z.B. Checksummenfehler bei Download-Versuch zum Flash)

PDLenErr: Prozessdatenlängenfehler (Anzahl konfigurierter Sondertasten/LEDs paßt nicht mit der am Control Panel vorhandenen überein)

ExtVoltageOk: Zustand der externen Spannung (bei aktiver USV)

AkkuVoltageOk: Zustand der Batterie-Spannung (bei aktiver USV)

AkkuCharging: Batterie wird geladen (bei aktiver USV)

AkkuNotPresent: Batterie nicht gefunden (bei aktiver USV)

AkkuCharged: Batterie vollständig geladen (bei aktiver USV)

AkkuWaiting: Ladezustand der Batterie wird überprüft. Ladevorgang ist momentan unterbrochen

IdentSwitch: Wert des auf der Karte eingestellten Dip-Switch

ComErr: Kommunikationsfehler zwischen Control Panel und CP9030 Karte

Ausgänge:

LED 1 - n: Ausgangsbits zum Ansteuern der LEDs

EnableUPS: Ausgangsbit zum manuellen Aktivieren der USV (nur zu benutzen, wenn die USV nicht über die USV-Konfiguration aktiviert wurde)

DisplayOff: Schaltet die Hintergrundbeleuchtung des Control Panels aus

KbdOff: Schaltet die Tastatur des angeschlossenen Control Panels aus (wichtig, wenn mehrere Control Panels über mehrere CP9035 Karten angeschlossen sind)

HINWEIS:

Damit die Daten zwischen Control Panel und CP9035 ausgetauscht werden, muss mindestens eine Variable verknüpft sein. Die verknüpfte Task muss laufen, oder der weiter oben erwähnte Async Mode muss eingestellt sein! Ansonsten wird das Handshake zwischen PC und CP9035 nicht bedient, d.h. es werden keine Daten mit dem Control Panel ausgetauscht.


Beckhoff CP9040

Die CP9040 Anschaltelektronik dient zum Ansteuern von eventuellen Sondertasten und/oder Tastererweiterungen in einem Beckhoff Control Panel PC.

Karteireiter "Serielle Schnittstellen"

Die Beschreibung der einzelnen Felder dieses Dialogs finden sie unter: "COM-Schnittstellen" in der TwinCAT System Manager - Referenz.
Felder, die in dem obigen Karteireiter nicht aktiviert sind, sind für den Betrieb einer CP9040 nicht von Bedeutung.

E/A Variablen:

Eingänge:

Diag State: Hier kann die Statusvariable für die -> "Erweiterte Klemmendiagnose" verknüpft werden.

PLC State: Hier kann die Statusvariable des SPS-Interfaces verknüpft, bzw. deren aktueller Wert überprüft werden.

Buttons: Nach dem Öffnen dieses Bit-Arrays, können die einzelnen Sondertasten mit Variablen einer anderen Task (z.B. der SPS) verknüpft werden. Weitere Infos dazu, findet man in der -> "BECKHOFF Knowledge Base".

State: Dieses Bit-Array enthält Status-Bits der CP9040 Kommunikation. Die möglichen Zustände (Bits), werden in dem zugehörigen Kommentarfeld auf der rechten Seite aufgelistet.

Ausgänge:

Diag Ctrl: Hier kann die Steuervariable für die -> "Erweiterte Klemmendiagnose" verknüpft werden

PLC Ctrl: Hier können die Statusvariablen des SPS-Interfaces verknüpft, bzw. deren aktueller Wert überprüft werden.

Display Ctrl: Hier können Variablen zur Ansteuerung des Displays (z.B. für das An-/Ausschhalten der Hintergrundbeleuchtung) verknüpft werden. Weitere Infos dazu, findet man in der -> "BECKHOFF Knowledge Base".

LEDs: Hier können Variablen zum Ansteuern der LED's in den Sondertasten des Beckhoff Control Panels verknüpft werden. Weitere Infos dazu, findet man in der -> "BECKHOFF Knowledge Base".


Beckhoff IPC - Sondertasten und USV

An einigen der Beckhoff Industrie PC werden zusätzliche Sondertasten und darin integrierte LEDs angeboten. Diese Tasten und LEDs können als normale Ein- und Ausgänge benutzt und verknüpft werden.

Durch Einfügen des Beckhoff PC unter E/A Geräte in der Baumansicht, werden automatisch je 10 Bitvariablen unter den Ein- und Ausgängen erzeugt.

S 1 .. n: Inputs from corresponding Special Keys.

ExtVoltageOk: If this bit is linked and its state isTRUE, the external power to the PC is ok.

LED 1 .. n: Outputs for corresponding LED's inside Special Keys.

Karteireiter "USV"

Manche Beckhoff Industrie PCs verfügen über eine integrierte 24V USV (Unterbrechungsfreie Stromversorgung), welche über ADS Ports angesprochen wird.

Aktiviere USV: Um die USV unter TwinCAT zu aktivieren, muss diese Checkbox angewählt sein.

Enable Automatic System Shutdown: TwinCAT leitet das Herunterfahren des Windows NT Systems bei Stromausfall nur ein, wenn diese Checkbox aktiviert ist.

Wartezeit: Gibt die Zeit in Sekunden an, die nach Ausfall der externen Spannung bis zum Herunterfahren von Windows NT gewartet wird.

Kein Abbruch: Wenn diese Checkbox aktiviert ist, wird bei eventueller Wiederkehr der externen Spannung, der eingeleitete Shutdown abgebrochen, d.h. das System wird dann nicht mehr heruntergefahren. Dafür darf die eingestellte Wartezeit, zum Zeitpunkt der Spannungswiederkehr, natürlich noch nicht abgelaufen sein.

Karteireiter "ADS"

Die Erklärung zu den einzelnen Feldern finden Sie unter: "ADS/AMS-Einstellungen bei E/A-Geräten"

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs


Beckhoff NC-Rückwand

Im folgenden werden die Einstelloptionen der Beckhoff NC-Rückwand erklärt.

Karteireiter "NC Rückwand"

Adresse: Hier muss die an der NC-Rückwand eingestellte Adresse ausgewählt werden, und zwar im Bereich 0xCC00 bis 0xCCC0, in Schritten von 0x400 (siehe auch Suchen).

Suchen: Hierüber kann eine im PC vorhandene NC-Rückwand gesucht werden. Alternativ kann der PC auch über -> "Geräte Suchen" nach, durch TwinCAT unterstützte I/O Geräte, durchsucht werden. Die eingestellte Adresse der gefundenen NC-Rückwand wird dann automatisch unter Adresse angezeigt.

ADC n Gain: Hier wird ... (in Vorbereitung)

ADC n Offset: Hier wird ... (in Vorbereitung)

Karteireiter "DPRAM (Online)"

Siehe "Online - Anzeige des DPRAMs"

E/A Variablen:

Eingänge:

Status1: Eingangsstatus

Status2: Eingangsstatus

Status3: Eingangsstatus

Status4: Eingangsstatus

Counter1: Zähler

Counter2: Zähler

Counter3: Zähler

Counter4: Zähler

ZeroReg1: Text

ZeroReg2: Text

ZeroReg3: Text

ZeroReg4: Text

ADC1: Text

ADC2: Text

ADC3: Text

ADC4: Text

In 1: Text

In 1: Text

In 1: Text

In 1: Text

Ausgänge:

Control1: Text

Control2: Text

Control3: Text

Control4: Text

DAC1: Text

DAC2: Text

DAC3: Text

DAC4: Text

Out 1: Text

Out 2: Text

Out 3: Text

Out 4: Text


AH2000

Nachfolgend wird der Beckhoff AH2000 Hydraulikregler in Bezug auf die, im AH2000 selbst zu aktivierende TwinCAT System Manager Konfiguration, beschrieben.

Der AH2000 hat entweder 1 (Bestellbezeichnung: AH2001) oder 3 (Bestellbezeichnung: AH2003) Kanäle. Dementsprechend erfolgt die nachfolgend beschriebene Konfiguration im System Manager beim AH2001 einfach und beim AH2003 dreifach.

Karteireiter "AH2000"

Address: Hier wird die Basisadresse, der am jeweiligen Kanal angeschlossenen Peripherie (ADC, DAC), eingestellt.

Search: Sucht nach der Basisadresse der angeschlossenen Peripherie, und zwar der des jeweiligen Kanals.

Firmware: Hier wird die aktuelle Firmware-Version des AH2000 angezeigt.

Hardware: Hier wird die aktuelle Hardware-Version des AH2000 angezeigt.

Buffered I/O access: Diese, standardmäßig aktivierte, Checkbox ruft einen gepufferten I/O-Zugriff hervor. Auch bei dieser Zugriffsart verläuft das Lesen bzw. Schreiben der I/O-Daten synchron zur entsprechenden SPS-Task, allerdings über einen Puffer.

Diagnose Eingänge

Nachfolgend werden die, je Kanal zu verknüpfenden, AH2000 E/A-Variablen beschrieben.

Eingänge:

IN_REG: Dieses Bit-Array enthält die Hardware Status-Bits des jeweiligen Kanals. Die Bedeutung der einzelnen Bits kann der untenstehenden Tabelle oder dem zu IN_REG gehörenden Kommentarfeld entnommen werden.

SIN_A: ADC Wert des Sinus-Anteils des Sinus/Cosinus-Gebers.

COS_B: ADC Wert des Cosinus-Anteils des Sinus/Cosinus-Gebers.

V1_IST: ADC Wert der analogen Ventilrückmeldung.

P1_IST: ADC Werte des ersten analog Eingangs.

P2_IST: ADC Werte des zweiten analog Eingangs.

INC_POS: Hier wird der Hardware-Increment Counter dargestellt. Dieser Wert entspricht der Ist-Position des jeweiligen Kanals.

Ausgänge:

OUT_REG: Dieses Bit-Array enthält die Hardware Control-Bits des jeweiligen Kanals. Die Bedeutung der einzelnen Bits kann der untenstehenden Tabelle oder dem zu OUT_REG gehörenden Kommentarfeld entnommen werden.

V1_SOLL: DAC Wert für den analogen Ventilsollwert

Bedeutung der Status-Bits in den Bit-Arrays:

Variable | Datentyp | Bit | Kurzform | Beschreibung
IN_REG | BITARR16 | 0 | V1_Stat | Status Ventil
 |  | 1 | EncStat | Status Encoder
 |  | 2 | Ref | Status der Referenzierung
 |  | 3 | In0 | Status Eingang 0 (Status des ersten Eingangs)
 |  | 4 | In1 | Status Eingang 1 (Status des zweiten Eingangs)
 |  | 5 | FB_P | Rückmeldung Versorgungsspannung Analogeingänge
 |  | 6 | V1_EnAck | Rückmeldung der Freigabe Ventil
 |  | 7 | FB_V1 | Rückmeldung Ventil
 |  | 8 | IncDir | Rückmeldung der Zählrichtung
 |  | 9 | Reserv. |
 |  | 10 | Reserv. |
 |  | 11 | Reserv. |
 |  | 12 | Reserv. |
 |  | 13 | Reserv. |
 |  | 14 | Reserv. |
 |  | 15 | Reserv. |
Variable | Datentyp | Bit | Kurzform | Beschreibung
OUT_REG | BITARR16 | 0 | Gl_RES | Global Reset (alles Rücksetzen)
 |  | 1 | IncRes | Zähler Rücksetzen
 |  | 2 | EnRef | Freigabe zur Referenzierung
 |  | 3 | Out0 | Ausgang 0 (erster Ausgang)
 |  | 4 | Out1 | Ausgang 1 (zweiter Ausgang)
 |  | 5 | P_Pwr | Freigabe Versorgungsspannung Analogeingänge
 |  | 6 | V1_En | Freigabe Ventil
 |  | 7 | V1_Pwr | 0: Versorgungsspannung Ventil AUS; 1: Versorgungsspannung Ventil EIN
 |  | 8 | EnTTL | 0: Externer Encoder Sinus-Cosinus; 1: Externer Encoder TTL
 |  | 9 | EnShdw | Freigabe Shadow Register (enthält die Referenzierungswerte)
 |  | 10 | RefSel | 0: Auswertung Nullimpuls des Gebers; 1: Auswertung externes Referenzsignal
 |  | 11 | RefPol | 0: Auswertung der steigenden Flanke; 1: Auswertung der fallenden Flanke Auswertung RefPol ist nur aktiv, wenn RefSel = 1
 |  | 12 | Reserv. |
 |  | 13 | Reserv. |
 |  | 14 | Reserv. |
 |  | 15 | Reserv. |


CX1100 Netzteil/Klemmenanschaltung

TwinCAT System Manager: Reference

CX1100 Netzteil/Klemmenanschaltung (CX1100-BK)

Wenn der Embedded-PC CX1000 mit dem optionalen Netzteil CX1100-0002 oder CX1100-0003 bestellt wurde, besitzt er automatisch eine Schnittstelle für die Anbindung der Beckhoff Busklemmen. Bei der Konfiguration des CX1000 mit dem TwinCAT System Manager, wird die (K-Bus-)Schnittstelle zu den Busklemmen als E/A-Gerät mit dem Gerätenamen "CX1100-BK" behandelt.

Dialog "Allgemein"

Id

Gibt die Geräte-ID der CX1100-BK Anschaltung an. Dies wird hier besonders hervorgehoben, da diese Identifikationsnummer benötigt wird, um das 2-zeilige LC-Display im Netzteil ansprechen zu können (z.B. mit Funktionsbausteinen aus der SPS heraus).

Für eine Beschreibung der restlichen Felder auf diesem Dialog, siehe: "E/A-Konfiguration | Anfügen eines E/A-Gerätes".

Dialog "CX 1100"

Adresse

Wird beim Suchen von EA-Geräten mit dem TwinCAT System Manager automatisch erkannt. Alternativ kann die Schaltflache "Suchen..." verwendet werden.

Initialisieren

Bei Deaktivierung wird das Display beim Starten des CX nicht initialisiert. Siehe auch "Schreibe". In der Grundeinstellung ist das Initialisieren aktiviert.

Schreibe

Falls aktiviert, werden die Zeichenketten, die unter "Zeile 1" bzw. "Zeile 2" angegeben wurden, bei Systemstart auf das Display geschrieben. In der Grundeinstellung ist "Schreibe" aktiviert.

Zeile 1

16 Zeichen langer String, der zur oberen Zeile des 2-zeiligen LC-Displays geschrieben wird (falls "Schreibe" aktiviert ist). Die hier angegebene Zeichenkette wird bei eventuell aktiviertem SPS-Programm ggfs. sofort nach dem Start überschrieben.

Zeile 2

16 Zeichen langer String, der zur unteren Zeile des 2-zeiligen LC-Displays geschrieben wird (falls "Schreibe" aktiviert ist). Die hier angegebene Zeichenkette wird bei eventuell aktiviertem SPS-Programm ggfs. sofort nach dem Start überschrieben.

Dialog "Display"

Dialog zur manuellen Ansteuerung des 2-zeiligen LC-Displays des CX1100 Netzteils.

Dialog "DPRAM [Online]"

Siehe "Online - Anzeige des DPRAMs"


BX Klemmenanschaltung (BX-BK)

Der Beckhoff BX Controller (BX3100, BX5100, BX5200) besitzt eine Schnittstelle für die Anbindung der Beckhoff Busklemmen. Bei der Konfiguration des BX mit dem TwinCAT System Manager, wird die (K-Bus-)Schnittstelle zu den Busklemmen als E/A-Gerät mit dem Gerätenamen "BX-BK" behandelt.

Dialog "BX Settings"

... in Vorbereitung ...


COM-Schnittstellen

TwinCAT System Manager: Reference

Serielle COM-Schnittstellen

Die COM-Schnittstellen des PCs können von TwinCAT genutzt werden. Dazu stehen zwei Betriebsarten zur Verfügung:

  1. Unterbrechungsfreie Stromversorgung (USV)
  2. COM-Port Betrieb

Der COM-Port Betrieb unterteilt sich in die Unterbetriebsarten:

  1. Anschluss von seriellen Buskopplern (BK8xx0)
  2. Allgemeine Datenschnittstelle (Simulation einer KL6xx1)

Karteireiter "Serielle Schnittstelle"

Betriebsart: USV

In der Betriebsart USV kann eine externe USV an die serielle Schnittstelle angeschlossen und von TwinCAT gesteuert werden. Z.Zt. werden die Pinbelegungen von APC und EFFEKTA unterstützt.

Im Gegensatz, zum bei Windows NT vorhandenen USV-Service, entspricht das Verhalten der USV, die über TwinCAT gesteuert wird, eher dem was an einer Maschinensteuerung benötigt wird. Der NT-Service versucht den PC solange wie möglich mit Spannung zu versorgen und erst bei Abfall der Batteriespannung den Rechner zu stoppen.

Wird die USV über TwinCAT gesteuert (der NT-Service darf nicht aktiviert sein), wird der Rechner nach einer angebbaren Wartezeit heruntergefahren.

Betriebsart: COM - BK8xx0

Unterhalb des E/A Gerätes können serielle Buskoppler angefügt werden, die wiederum mit beliebigen Klemmen ausgestattet werden können.

HINWEIS:

Um RS485 (BK80x0) zu betreiben, ist eine intelligente Schnittstellenkarte erforderlich, die selbstständig die RTS/CTS Leitungen kontrolliert (Senden und Empfangen).

Betriebsart: COM - KL6xx1

Die Klemmen vom Typ KL6xx1 ermöglichen eine serielle Kommunikation z.B. von der SPS über einen Feldbus - Buskoppler und - die Klemme zu einem externen seriellen Gerät (z.B. ein Barcode Leser). Über das Prozessabbild der Klemme werden die Datenbytes ausgetauscht und das notwendige Handshake gesteuert.

Diese Funktionalität kann für die im PC vorhandenen seriellen Schnittstellen nachgebildet werden. Zum einen kann ein wesentlich größerer Datendurchsatz erreicht werden, da zum einen die Baudrate höher eingestellt werden kann und zum anderen pro Zyklus mehr Datenbytes übertragen werden können (maximal fünf bei KL6xx1).

Datenbytes:

Die Anzahl der maximal zu übertragenden Datenbytes kann zwischen 16 und 4096 eingestellt werden. Zusätzlich kann die interne Puffergröße eingestellt werden, die insbesondere für den Empfang von Datenbytes benötigt wird (zwischen 4096 und 65535).

Über das Ctrl- und Status-Word wird das Handshake abgewickelt. Diese Worter sind sehr ähnlich dem Ctrl- und Status-Byte der KL6xx1 aufgebaut, mit dem Unterschied, dass die angebbare Datenlänge statt 3 Bits zwölf Bits beträgt (maximal 4096).

  • Status Bit 0: TA: Transmit Accepted
  • Bit 1: RR: Receive Request
  • Bit 2: IA: Init Accepted
  • Bit 3: BUF_F: Pufferüberlauf (möglicher Datenverlust)
  • Bit 4-12: nIn Anzahl der im Puffer vorhanden Daten
  • Ctrl Bit 0: TR: Transmit Request
  • Bit 1: RA: Receive Accepted
  • Bit 2: IR: Init Request
  • Bit 3: unbenutzt
  • Bit 4-12: nOut Anzahl der zu sendenen Daten

TA / TR

Eine Zustandsänderung von TR bewirkt, dass die in nOut festgesetzte Anzahl von Daten (maximal 4096 Bytes) von Data0-DataN in den Sende-Puffer geladen wird. Die Schnittstelle signalisiert über TA die Ausführung dieses Befehls.

RA / RR

Über eine Zustandsänderung von RR teilt die Schnittstelle der Steuerung mit, dass sich die in nIn angezeigte Anzahl von Daten in Data0-DataN befindet. Die Übernahme der Daten wird im Control-Wort mit RA quittiert, erst daraufhin werden neue Daten von der Schnittstelle zur Steuerung übertragen.

IA / IR

Ist IR high, so führt die Schnittstelle eine Initialisierung durch. Die Sende und Empfangsfunktionen werden gesperrt, die FIFO-Zeiger werden zurückgesetzt. Die Ausführung der Initialisierung wird von der Schnittstelle mit IA quittiert.

BUF_F

Der Empfangs-Puffer ist voll. Daten, die jetzt empfangen werden, gehen verloren.

Extended Ctrl/Status:

Ab TwinCAT v2.10 Build >= 1313 (CE image v2.16(x86), v2.17(ARM) und höher). Diese Option wird nur von den standard PC Schnittstellen COMx unterstützt. Wenn diese Option angewählt ist wird ein zusätzliches Wort an Prozessausgangsdaten (ExtCtrl) und Prozesseingangsdaten (ExtStatus) zu den vorhandenen Daten eingeblendet. Über diese Prozessdaten können folgende RS232-Steuerleitungen gesetzt oder abgefragt werden.

ExtCtrl Bits:
0x0001 = DTR
0x0002 = RTS
Beim Setzen/Zurücksetzen des entsprechenden Bits wird die dazugehörige RS232-Leitung gesetzt oder zurückgesetzt. Alle anderen Bits sind reserviert.

ExtStatus Bits:
0x0001 = CTS
0x0002 = DSR
0x0004 = RI
0x0008 = DCD
0x8000 = TX buffer empty (dieses Bit wird gesetzt wenn alle Sendepuffer (inklusive des Hardware-Fifos leer sind).
Durch das Ausmaskieren der Bits kann der Status der RS232-Leitungen abgefragt werden. Alle anderen Bits sind reserviert.

Sync Mode:

Im Sync Mode wird die Kommunikation mit der Schnittstellenhardware synchron zur Kommunikationstask abgewickelt. Diese Einstellung bietet normalerweise Vorteile bei hohen Baudraten, solange die Zykluszeit der Kommunikationstask kurz genug ist. Bei 115 kBaud werden beispielsweise pro Millisekunde 12 Zeichen empfangen. Die Schnittstelle muss also mindestens in einem 1 ms Zyklus bedient werden, damit das Hardware-FIFO von 16 Bytes nicht überlaufen kann. Bei zu langen Zykluszeiten besteht die Gefahr eines Pufferüberlaufs.

Bei abgeschaltetem Sync Mode wird die Schnittstelle unabhängig von der Task-Zykluszeit jede Millisekunde im Windows-Timer-Interrupt bedient. Diese Betriebsart ist nicht echtzeitfähig und es kann bei sehr hoher Rechnerauslastung auch zu längeren Bedienintervallen kommen. Bei sehr hohen Baudraten besteht dann ebenfalls die Gefahr eines Pufferüberlaufs.

Es wird empfohlen, den Sync Mode zu aktivieren und die Zykluszeit der Kommunikationstask so an die Baudrate anzupassen, dass der 16 Byte Hardware Puffer nicht überläuft. Bei kleinen Baudraten und gleichzeitig langsamer Kommunkationstask kann der Sync Mode evtl. deaktiviert werden.


Druckerschnittstelle

TwinCAT System Manager: Reference

Druckerschnittstelle (LPT Port)

Mit Hilfe der "Feldbus-Schnittstelle" LPT Port, stehen dem TwinCAT System je Parallelport acht Ein- und Ausgänge zur Verfügung. Die Interpretation der Signale auf den einzelnen Pins, kann den Bit-Array Elementen unterhalb der E/A-Variablen entnommen werden.

Karteireiter "LPT Port"

Es stehen drei Portadressen zur Wahl, die in Standard-PC die Schnittstellen LPT1, LPT2 und LPT3 widerspiegeln. Welcher LPT Port auf Ihrem Rechner welcher Portadresse entspricht, entnehmen Sie dem Handbuch des PC bzw. der aktuellen Einstellung im BIOS.

Durch Einfügen der Druckerschnittstelle unter E/A Geräte in der Baumansicht werden automatisch je acht Bitvariablen unter den Ein- und Ausgängen erzeugt. Bei den Eingängen ist zu beachten, dass die Logik der einzelnen Bit unterschiedlich ist. Die meisten Eingänge liefern eine logische Eins wenn der jeweilige Pin nicht mit Masse verbunden ist und eine logische Null wenn der Pin mit Masse verbunden ist. Bei den mit inv gekennzeichneten Eingängen ist die Logik genau umgekehrt.

Eine bidirektionale Schnittstelle ist Voraussetzung für den einwandfreien Betrieb des "Feldbusses".


Allgemeines DP-/NOV-RAM

TwinCAT System Manager: Reference

Allgemeines NOV/DP-RAM

Um weitere, namentlich nicht unterstützt PC-Karten in TwinCAT einbinden zu können, kann unter E/A-Geräte | Verschiedenes die entsprechende Karte mit vorhandenem DP-RAM Interface als "Allgemeines NOV/DP-RAM" eingebunden und somit angesprochen werden.

Kontextmenü

Gerät Löschen... <Entf>

Entfernt die jeweilige Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem Feldbus.

Karteireiter "Allgemeines DPRAM"

PCI Slot/Irq: Zeigt die Adresse (unter 1 MB bei einer ISA-Karte) einer unterstützten Steckkarte an und auch welcher IRQ ihr zugewiesen wurde. Bei einer PCI-Karte zeigt sie auch an, in welchem logischen PCI-Slot die Karte gefunden wurde. Der IRQ wird bei PCI-Karten nicht benutzt.

Länge: Hier kann die Länge des Speicherbereichs verändert werden, sollte nur bei ISA-Karten passieren, bei PCI-Karten wird sie automatisch ausgelesen.

Suchen...: Hierüber wird die Adresse der PCI-Karte entsprechend der Vendor ID, Device ID und der Base Address gesucht.

PCI-Vendor ID: Hier wird die PCI-Vendor ID eingeben

PCI-Device ID: Hier wird die PCI-Device ID eingeben

PCI BaseAddr: Hier wird der entsprechende Speicherbereich ausgewählt (ein PCI-Chip kann bis zu 4 Speicherbereiche adressieren, entspricht Base-Address 2-5 des PCI-Chips, Base 0 und 1 sind für die PCI-Register, auf die bisher noch nicht zugegriffen werden kann)

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs".


Allgemeines NOV-RAM

Ein Non-Volatile Random Access Memory (im Allgemeinen abgekürzt bezeichnet als NOVRAM, NV-RAM oder NOV-RAM) ist ein spezieller Typ von Speicherbaustein, der prinzipbedingt zyklich beschrieben werden darf, bei dem aber trotzdem, bei auftretendem externen Spannungsausfall, der letztgültige Dateninhalt im internen ROM-Bereich gesichert wird. Ein im NOVRAM integrierter Kondensator liefert hierbei die Energie die nötig ist, um bei Ausfall der extern anglegten Spannung den Inhalt des, jeweils ebenfalls im NOVRAM integrierten, RAM-Bereichs in den ROM-Bereich umzukopieren. Die Applikation (in diesem Fall TwinCAT) schreibt zyklisch nur in den RAM-Bereich des IC's.

Um die optionale NOV-RAM-Erweiterung der Beckhoff Feldbuskarten (z.B. FC3101-0002 / FC3102-0002, FC3151-0002 , FC5101-0002 / FC5102-0002, FC5151-0002, FC5201-0002 / FC5202-0002, FC5251-0002, FC7551-0002 ) unter TwinCAT nutzen zu können, muss ein zusätzliches E/A-Gerät, zu finden im Bereich E/A-Geräte | Verschiedenes, als "Allgemeines DP-/NOV-RAM " eingebunden werden.

Bei den CX1100-000x Netzteilmodulen aus der Beckhoff CX10xx-Serie, wird der stets vorhandene, hier 8 kByte große, NOVRAM-Baustein automatisch beim Einlesen erkannt.

Bei dem CX900x wird der stets vorhandene, hier 128 kByte große, NOVRAM-Baustein, automatisch beim Einlesen erkannt.

Des Weiteren unterstützt die unten beschriebene Vorgehensweise natürlich auch die Mini-PCI NOVRAM Module mit den Bestellnummern C9900-R230, C9900-R231 und C9900-R232.

Hinweis (nur bei TwinCAT 2.8): Ein Schreiben von Daten auf angefügte und verknüpfte Ausgangsvariablen per SPS E/A-Auffrischung, ohne die Nutzung der SPS-Funktionsbausteine, hätte bei Systemstop ein Zu-Nullschreiben der jeweiligen Datenbereiche im NOVRAM zur Folge. Siehe hierzu auch: Konfigurationsbeispiel fürTwinCAT 2.8

Konfigurationsbeispiel (TwinCAT 2.9/2.10):

Unter anderem bei der Projektierung von CX-Steuerungen und anderen Embedded -Geräten (C69xx, CP62xx, CP66xx) ist es wichtig, dass gewisse Betriebsdaten bei einem Neustart erhalten bleiben. Beim CX ist in diesem Fall die NOVRAM-Unterstützung besonders wichtig, da dort oftmals keine USV (optional: CX1100-0910, CX1100-0920) verwendet wird. Neu unter TwinCAT 2.9 ist, dass keine SPS-Funktionsbausteine zum Lesen und Schreiben, und damit zur Synchronisation von Neustart-überlebenden SPS-Variablenwerten (Anmerkung: Der Begriff "persistent" ist hier absichtlich nicht gewählt worden), benötigt werden. Diese Funktionalität kann natürlich auch mit den FCxxxx-0002 Feldbuskarten genutzt werden.

Der nachfolgende Dialog zeigt die Einstellungen, welche nötig sind, um vom I/O-Treiber eine Synchronisation mit ausgewählten SPS-Ausgangsvariablen zu ermöglichen.

Adresse: Die hier zu definierende Adresse wird bei einem Online-Suchen der Geräte automatisch vergeben, ebenso wie die Größe ("Länge") des gefundenen NOVRAM Bausteins.

Auto Init linked PLC Outputs: Die Checkbox muss bei der Einbindung remanenter, d.h. mit der SPS bei Neustart synchronisierter Daten, aktiviert sein.

Vorab werden unter "Ausgänge" per "Variable einfügen..." im Baum in passender Größe definierten Ausgangsvariablen (im oberen Fall sind dies die Array-Variablen "Betriebsdaten1" und "Betriebsdaten2") und - ggfs. an passender Adresse im NOVRAM - mit Ausgangsvariablen der SPS verknüpft. Diese werden automatisch bei einem Systemstart bzw. nach einem Bootvorgang und folgender Aktivierung des Bootprojekts, mit den zuletzt gültigen Variablen aus dem NOVRAM synchronisiert (also vorinitialisiert). Das SPS-Programm wird dadurch nach jedem Neustart mit zuletzt gültigen Variablenwerten aus dem NOVRAM fortgeführt.

Eine spezielle Deklaration der Variablen in der SPS ist nicht notwendig (außer das man sie natürlich als lokierte Ausgangsvariablen deklarieren muß, z.B. als AT %Q* ). Speziell eine Deklaration als VAR xxx PERSISTENT oder VAR xxx RETAIN, ist in diesem Fall nicht zulässig!

Export Data to Disk: Schreibt den aktuellen Inhalt des NOVRAM Bausteins - zur besseren Übersicht unterteilt in 1k (1024 Byte) große Blöcke - in eine XML Datei auf einen auszuwählenden Datenträger. Für diese Schreibroutine muß sich das gerade aktive Zielsystem zwingend im Konfigurationsmodus ("Config Mode") befinden.

Import Data from Disk: Liest Daten einer zuvor erstelten NOVRAM XML-Datei ein und schreibt die Dateiinhalt in den jeweils deklarierten Adressbereich des NOVRAM-Bausteins. Da die Daten in 1k große Blöcke unterteilt sind, kann man auch eigene Konfigurationsdateien erstellen, welche alle oder nur einen Teil der 1k Blöcke enthalten, um, im zweitgenannten Fall z.B. nur einen Teilbereich eines NOVRAMs mit Ausgangsdaten herstellerseitig vorzubelegen. Ein Blick in eine selbstexportierte NOVRAM XML-Datei verdeutlicht die Verwendungsmöglichkeiten!

Konfigurationsbeispiel für TwinCAT 2.8:

Im Gegensatz zu einer Konfiguration des Systems mit einer gewöhnlichen DP-RAM Karte muss hier beachtet werden, dass die zu sichernden Daten nicht per E/A-Variablen unterhalb des Geräts zu konfigurieren sind, sondern in diesem Fall per ADS-Kommando direkt zu dem NOV-RAM Baustein auf der Feldbuskarte geschrieben werden. Dies bedeutet, dass im Normalfall keine Variablen unterhalb von "Eingänge" oder "Ausänge" (siehe dazu auch nachfolgende Abbildung) konfiguriert und verknüpft werden müssen, um Daten im NOVRAM der Karte sichern zu können. Das Schreiben der Daten darf hierbei prinzipbedingt auch zyklisch geschehen.

Nachfolgend ein Beispiel einer möglichen Konfiguration allerdings ohne die notwendigerweise korrekt einzustellende PCI-Adresse und sonstiger PCI Geräteinformationen.

Die Adressen und Längenangaben, die hier anzugeben sind, entnehmen sie bitte der bereits erfolgten Feldbuskartenkonfiguration (im obigen Fall ist dies die FC3101-0002), bzw. ermitteln Sie diese mit Hilfe der Schaltfläche:

Suchen...: Hierüber wird die Adresse der PCI-Karte entsprechend der Vendor ID, Device ID und der Base Address gesucht.

Weitere Details zu den dabei ermittelten Werten können der Beschreibung der jeweiligen Karte entnommen werden.

Zugriff auf das NOV-RAM durch die SPS-Funktionsbausteine:

Mit Hilfe des Funktionsbausteins "FB_NovRamReadWrite", welcher standardmäßig in der Bibliothek "TcIOFunctions.lib" ab der TwinCAT Version 2.8 > Build 722 mitinstalliert wird, kann lesend bzw. schreibend auf den NOVRAM-Baustein der Beckhoff Feldbuskarte zugegriffen werden. Wichtig ist hierbei die TwinCAT System Manager Geräte-ID des NOV-RAM Gerätes (im nachfolgenden Beispiel zum Beispiel die ID 2). Ein Auslesen der Geräte-ID per Name ist hierbei auch möglich. Siehe hierzu auch: "IOF_GetDeviceIDByName". Nähere Details hierzu entnehmen Sie bitte der Bibliotheksbeschreibung.


DPRAM-Online

Bei aktivem TwinCAT kann zu Diagnosezwecken direkt auf das DPRAM der jeweiligen Feldbuskarte, bzw. sonstiger Anschaltung mit DPRAM Schnittstelle, lesend zugegriffen werden. Für genauere Information wird auf die Beschreibung der jeweiligen Karte, bzw. des Gerätes, verwiesen.


System Management Bus (SMB)

Neuere Motherboards besitzen Diagnosebausteine, über die Temperaturen, Lüfterdrehzahlen und die Betriebsspannungen des PCs überwacht werden können. Diese Werte können mit Hilfe des "Motherboard - SMB (System Management Bus)" "E/A-Gerätes" in TwinCAT gelesen werden. Leider gibt es z. Zt. noch keine einheitlichen Normen, wie diese Werte zur Verfügung gestellt werden.

Unterstützt werden neuere Motherboards mit Intel-Chipsatz. Diese verfügen i.d.R. über die PCI-ISA-Bridge PIIX-4. Über die PCI-ISA-Bridge kann auf die Register der Diagnosebausteine und auf den SMB zugegriffen und so die Diagnosedaten ermittelt werden. Aber auch bei anderen Chipsätzen können einzelne Werte ermittelt werden (wenn sie z.B. über einen LM75 Baustein oder kompatiblen verfügen). Welche Werte auf einem speziellen Board messbar sind, muss daher getestet werden.

Zur Zeit können in den meisten Fällen von TwinCAT folgende Diagnose-IC's erkannt und deren Daten interpretiert werden:

  • LM78 (National) ( z.B auf ASUS P2B-LS )
  • LM78J (National) ( z.B. auf ASUS P2L97-DS Board)
  • LM80 (National) ( z.B. auf QDI BrillantX IS Board )
  • LM85B, LM85C (z.B. auf Intel's D865GLC oder D865GBF Board )
  • W83781D (Winbond) ( z.B . auf ASUS P2B und P2B-F Boards )
  • W83782D (Winbond) ( z.B. auf einigen EPOX Boards)
  • W83783S (Winbond) ( z.B. auf ABIT BE6 Board )
  • W83627HF (Winbond) (z.B. auf BECKHOFF CB1050, CB1051, CB2050, CB2051, CB3051, CB3050, CB3053, CB5053, EPOX EP-4B2A oder EP-M845B Board)
  • CX1020 / CX1030 Diagnose IC's (nur ab Hardwarerevision 2.0)

Temperatur

Alle IC's gehören zu der LM78-Familie. Der LM78 ist der Basis-Chip zu dem alle andere Chips verglichen werden können. Die Winbond-IC's besitzen im Gegensatz zu den LM7x-IC's keinen internen Temperatur Sensor. Über den internen Temperatur Sensor wird in den meisten Fällen die Temperatur vom Motherboard gemessen. Die CPU-Temperatur wird entweder über einen Sensor unter der CPU, oder über die Pentium Thermo-Diode gemessen. Andere Temperatur Sensoren können über externe Anschlüsse auf dem Board angeschlossen werden. Befindet sich der CPU-Temperatursensor unter der CPU, muss zu der gemessenen Temperatur ein Korrekturwert aufgeschlagen werden. Dieser richtet sich nach der Größe des Luftspalts zwischen der CPU und dem Sensor. Wird die Temperatur über die Pentium Thermo-Diode gemessen, muss auf den gemessenen Wert ebenfalls ein Korrekturwert aufgeschlagen werden. Dieser hängt von dem Typ der Thermo-Diode ab. Falls an den gemessenen Werten gezweifelt wird, können die Temperaturwerte meistens in BIOS-Setup kontrolliert werden.

Lüfter

Alle IC's besitzen Eingänge um die Drehzahlen von drei Lüftern (LM80 nur zwei Lüfter) gleichzeitig messen zu können (CPU-Lüfter [CPU FAN], Gehäuse-Lüfter [CHASSIS FAN] und Netzteil-Lüfter [PWR FAN] ). Bei den Lüftern muss es sich um spezielle Lüfter mit Tachometer-Ausgang handeln. Solche Lüfter besitzen meistens drei Anschlussleitungen. Je nach Board kann der CPU-Lüfter vom Hersteller am unterschiedlichen Eingang des Diagnose-IC's verdrahtet sein. In den meisten Fällen sind für zwei Lüfter (CHASSIS FAN und PWR FAN ) die Eingänge als externe Anschluss-Pins auf dem Board ausgeführt.

Spannungen

Die Diagnose IC's können über die analogen Eingänge positive und negative Spannungen messen. Meistens können von dem IC maximal 4.096V am Eingang gemessen werden. Um größere Spannungen messen zu können werden Spannungsteiler vorgeschaltet. Der gemessene Wert errechnet sich aus dem Wert der vorgeschalteten Widerstände und dem Wert des ADC (Analog Digital Converter).

Als Widerstandswerte für den Spannungsteiler werden von TwinCAT die vorgeschlagenen Standardwerte des jeweiligen IC-Herstellers benutzt (aus der technischen Dokumentation zu dem IC). Hat ein Board-Hersteller andere Widerstandswerte auf seinem Board verdrahtet, können die gemessenen Werte von den realen abweichen. Die korrekten Spannungen können im BIOS-Setup kontrolliert werden.

Mappping der Diagnosedaten im TwinCAT System Manager

Die ermittelten Diagnosedaten werden im TwinCAT System Manager in folgende Struktur gemappt:

Die Temperaturen werden in °C angegeben.

Die Lüfterdrehzahlen werden in Umdrehungen pro Minute angegeben.

Die Spannungen werden in 1/100 Volt angegeben. Negative Spannungen werden als positive Werte ausgegeben.

Folgende Tabellen geben eine Übersicht über das Mapping der Diagnosedaten im TwinCAT-Prozessabbild bei den unterschiedlichen Mainboard- und SMBus-IC-Typen.

Winbond W83782D

Motherboard | EPOX EP-3BXA
Variable | Hardware/Anschlussbezeichnung auf dem Board | Bemerkungen
Temp MB | 3TH THERMAL | Temperatur eines externen Sensors. Ist dieser nicht angeschlossen, liefert die variable den Wert 0. In BIOS hat dieser Sensor die Bezeichnung: "Extended JP2".
Fan 0 | CPU FAN | CPU Lüfter
Fan 1 | CHASIS FAN | Gehäuse Lüfter
Fan 2 | PWR FAN | Netzteil Lüfter
Volt 2a | Vccp1 | In BIOS als "Vcore" bezeichnet
Volt 2b | Vtt | In BIOS als "Vio" bezeichnet
Volt 3.3 | +3.3V Spannung |
Volt 5 | +5V Spannung |
Volt 12 | +12V Spannung |
Volt -12 | -12V Spannung |
Volt -5 | -5V Spannung |
Temp 0 | CPU Temperatur | Temperatur an der Pentium Thermo-Diode
Temp 1 | RT1 | In BIOS als "System Temperatur" bezeichnet. Auf dem Board befindet sich ein Thermo-Fühler (beschriftet als RT1).
Temp 2 bis Temp 7 | nicht benutzt |

Winbond W83627HF

Motherboard | BECKHOFF CB1050, CB1051, CB2050, CB2051, CB3051, CB3050, CB3053, CB5053 |  | EPOX EP-4B2A |  | EPOX EP-M845B |  | EPOX IP-4GVI63
Variable | Hardware/Anschlussbezeichnung | Bemerkungen | Hardware/Anschlussbezeichnung | Bemerkungen | Hardware/Anschlussbezeichnung | Bemerkungen | Hardware/Anschlussbezeichnung | Bemerkungen
Temp MB | System Board Temperature | Thermistor in der nähe der CPU | nicht benutzt | Der Eingang ist offen. | nicht benutzt | Der Eingang ist offen. | nicht benutzt | Der Eingang ist offen.
Fan 0 | FAN1 |  | CPU FAN | CPU Lüfter | Fan 3 (CHASIS FAN) | In BIOS bezeichnet als Chasis FAN | CHASIS | In BIOS bezeichnet als Chasis FAN
Fan 1 | FAN2 |  | CHASIS FAN | Gehäuse Lüfter | Fan 1 | CPU Lüfter | CPU | CPU Lüfter
Fan 2 | FAN3 |  | PWR FAN | Netzteil Lüfter | Fan 2 | In BIOS bezeichnet als Power FAN | PWR | In BIOS bezeichnet als Power FAN
Volt 2a | VCCCORE | In BIOS als CPU Core bezeichnet | Vccp1 |  | Vccp1 |  | Vagp | In BIOS bezeichnet als Vagp
Volt 2b | CS_VCCCORE | In BIOS als GMCH Core bezeichnet | Vtt |  | Vtt |  | Vcore |
Volt 3.3 | +3.3V Spannung |  | +3.3V Spannung |  | +3.3V Spannung |  | +2.5V Spannung! | In BIOS bezeichnet als Vdimm
Volt 5 | +5V Spannung |  | +5V Spannung |  | +5V Spannung |  | +5V Spannung |
Volt 12 | +12V Spannung | ³) | +12V Spannung |  | +12V Spannung |  | +12V Spannung |
Volt -12 | -12V Spannung | ¹) | -12V Spannung |  | -12V Spannung |  | -12V Spannung |
Volt -5 | -5V Spannung | ¹) | -5V Spannung |  | -5V Spannung |  | -5V Spannung |
Temp 0 | CPU Temperatur | ²) | CPU Temperatur | Temperatur an der Pentium Thermo-Diode | CPU Temperatur | Temperatur an der Pentium Thermo-Diode | CPU Temperatur |
Temp 1 | System DDR Temperature | Thermistor in der Nähe der RAM-Slots | RT1 | In BIOS als "System Temperatur" bezeichnet. Auf dem Board befindet sich ein Thermo-Fühler (beschriftet als RT1). | TR1 | In BIOS als "System Temperatur" bezeichnet. Auf dem Board befindet sich ein Thermo-Fühler (beschriftet als TR1). | TR1 | In BIOS als "System Temperatur" bezeichnet. Auf dem Board befindet sich ein Thermo-Fühler (beschriftet als TR1).
Temp 2 | Power Controller Temp. | Unterstützt nur von BIOS v0.80 und höher | nicht benutzt |  | nicht benutzt |  | nicht benutzt
Temp 3 bis 7 | nicht benutzt |  | nicht benutzt |  | nicht benutzt |  | nicht benutzt
 | Der FAN4-Lüfter kann nicht überwacht werden. ¹) Bei CB2051, CB3050, CB3051 nicht vorhanden. ²) DTS (Digital Thermal Sensor) bei Core™ Duo/Core™2 Duo MAX(core 1..core n) und Atom. Temperatur an der Pentium Thermo-Diode bei anderen Prozessoren. ³) Bei CB3053, CB5053 nicht vorhanden. |  |  |  | Das EP-M845B-Board besitzt noch einen weiteren Lüfter-Anschluss ( beschriftet mit Fan 4 ). Dieser Lüfter kann nicht überwacht werden, weil der Winbond-IC nur 3-Lüftereingänge besitzt.. |  |

Winbond W83781D

Motherboard | ASUS - P2B oder P2B-F
Variable | Hardware/Anschlussbezeichnung auf dem Board | Bemerkungen
Temp MB | RT1S | Sensor auf dem Board in der Nähe von dem Winbond IC (System Temperatur)
Fan 0 | CHA FAN | Gehäuse Lüfter
Fan 1 | CPU_FAN | CPU Lüfter
Fan 2 | PWR_FAN | Netzteil Lüfter
Volt 2a | Vccp1 |
Volt 2b | Vccp2 |
Volt 3.3 | +3.3V Spannung |
Volt 5 | +5V Spannung |
Volt 12 | +12V Spannung |
Volt -12 | -12V Spannung |
Volt -5 | -5V Spannung |
Temp 0 | JTPWR | Anschluss für einen externen Sensor für die Netzteil-Temperatur
Temp 1 | JTCPU | Anschluss für einen Sensor für die CPU-Kühlertemperatur
Temp 2 bis Temp 7 | nicht benutzt |

LM80

Motherboard | QDI - BrillantX IS
Variable | Hardware/Anschlussbezeichnung auf dem Board | Bemerkungen
Temp MB | Interner Temperatursensor im LM80 IC | Mainboard Temperatur
Fan 0 | CHASFAN | Gehäuse Lüfter
Fan 1 | CPUFAN | CPU Lüfter
Fan 2 | nicht benutzt |
Volt 2a | nicht benutzt |
Volt 2b | +1.48V Spannung |
Volt 3.3 | +3.3V Spannung |
Volt 5 | +5V Spannung |
Volt 12 | +12V Spannung |
Volt -12 | -12V Spannung |
Volt -5 | -5V Spannung |
Temp 0 bis Temp 7 | nicht benutzt |

W83783S oder LM75

Motherboard | ABIT - BE6 |  | BOSER HS-6237 Version 2.2 |  | BOSER HS-6237 Version 3.0
Variable | Hardware/Anschlussbezeichnung auf dem Board | Bemerkungen | Hardware/Anschlussbezeichnung auf dem Board | Bemerkungen | Hardware/Anschlussbezeichnung auf dem Board | Bemerkungen
Temp MB | CON2 | Anschluss für einen externen Sensor für die CPU-Kühlertemperatur | nicht benutzt |  | JP14 | Temperatur eines externen Sensors. Ist dieser nicht angeschlossen, dann liefert dieser Eingang einen undefinierten Wert.
Fan 0 | FAN2 | Anschluss für einen Lüfter in der Nähe der CPU | nicht benutzt |  | CN2 | In BIOS als CPUFAN1 speed bezeichnet
Fan 1 | FAN3 | Anschluss für einen Lüfter in der Nähe der ISA Slots | nicht benutzt |  | CN25 | In BIOS als CPUFAN2 speed bezeichnet
Fan 2 | FAN1 | Anschluss für einen Lüfter in der Nähe der CPU | nicht benutzt |  | CN26 | In BIOS als CPUFAN3 speed bezeichnet
Volt 2a | +2V Spannung |  | nicht benutzt |  | Vcore |
Volt 2b | nicht benutzt |  | nicht benutzt |  | nicht benutzt |
Volt 3.3 | +3.3V Spannung |  | nicht benutzt |  | +3.3V Spannung |
Volt 5 | +5V Spannung |  | nicht benutzt |  | +5V Spannung |
Volt 12 | +12V Spannung |  | nicht benutzt |  | +12V Spannung |
Volt -12 | -12V Spannung |  | nicht benutzt |  | -12V Spannung |
Volt -5 | nicht benutzt |  | nicht benutzt |  | nicht benutzt |
Temp 0 | RT1 | System Temperatur. Auf dem Board befindet sich ein Thermo-Fühler (beschriftet als RT1). | CPU Temperatur | Auf dem Board befindet sich nur ein Temperatursensor (LM75) | CPU Temperatur | In BIOS als CPU1 Temperature bezeichnet. Auf den gelesenen Temperaturwert muss ein Offset von ~30°C aufaddiert werden um annähernd die tatsächliche Temperatur zu ermitteln!. CPUtemp = TwinCATtemp + 30°C
Temp 1 bis Temp 7 | nicht benutzt |  | nicht benutzt |  | nicht benutzt |

LM85B oder LM85C

Wichtige Systemvoraussetzungen:

  • Der Intel(R) SMBus 2.0 Treiber für den ICH5/ICH5-M SMBus Controller-24D3 muss installiert und aktiv sein;
  • Andere Monitoring-Applikationen (z.B. Intel's Active Monitor) dürfen nicht aktiv sein oder müssen falls vorhanden vom System entfernt werden;
  • In BIOS muss die Option "Fan control" deaktiviert werden;
Motherboard | Intel D865GLC oder D865GBF
Variable | Hardware/Anschlussbezeichnung auf dem Board | Bemerkungen
Temp MB | Ambient temperature sensor (internal to hardware monitoring and fan control ASIC) | In BIOS hat dieser Sensor die Bezeichnung: "System Zone 1 Tempearature".
Fan 0 | CPU FAN | CPU Lüfter
Fan 1 | FRONT CHASIS FAN | Vorderer Gehäuse-Lüfter
Fan 2 | REAR CHASIS FAN | Hinterer Gehäuse-Lüfter
Volt 2a | Vccp | In BIOS als "Vccp" bezeichnet
Volt 2b | +1.5V Spannung | In BIOS als "+1.5Vin" bezeichnet
Volt 3.3 | +3.3V Spannung |
Volt 5 | +5V Spannung |
Volt 12 | +12V Spannung |
Volt -12 | nicht vorhanden | Diese Spannung wird nicht überwacht
Volt -5 | nicht vorhanden | Diese Spannung wird nicht überwacht
Temp 0 | Thermal diode, located on processor die | Temperatur an der Pentium Thermo-Diode. In BIOS als "Processor Zone Temperature" bezeichnet.
Temp 1 | Remote ambient temperature sensor | In BIOS als "System Zone 2 Temperature" bezeichnet.
Temp 2 bis Temp 7 | nicht benutzt |

Bemerkung

Falls die Variablen Temp 0 oder Temp 1 einen konstanten Wert 0xD0 liefern, dann ist möglicherweise kein externer Sensor auf dem Board angeschlossen (offener Thermoeingang).

Winbond W83627HF + LM63

 | Beckhoff CX1020 / CX1030
Variable | Hardware/Anschlussbezeichnung auf dem Board | Bemerkungen
Temp MB | Board CX1021 | Board-Temperatur
Fan 0 | FAN | reserviert, zur Zeit nicht benutzt
Fan 1 | FAN | Nur CX1030: CPU/Gehäuselüfter sonst nicht benutzt
Fan 2 | FAN | reserviert, zur Zeit nicht benutzt
Volt 2a | CPU-Voltage |
Volt 2b | CPU-Voltage |
Volt 3.3 | +3.3V Spannung |
Volt 5 | +5V Spannung |
Volt 12 | +12V Spannung |
Volt -12 | nicht benutzt |
Volt -5 | nicht benutzt |
Temp 0 | Board CX1021 | Board-Temperatur
Temp 1 | nicht benutzt |
Temp 2 | Board CX1020 (LM63) | CPU-Temperatur
Temp 3 | Board CX1020 (LM63) | Board-Temperatur
Temp 4 bis Temp 7 | nicht benutzt |


Übersicht

Die Beckhoff Busklemme ist ein offenes Feldbus-neutrales Peripheriekonzept, bestehend aus elektronischen Reihenklemmen. Der Kopf einer elektronischen Reihenklemme ist der Buskoppler mit Feldbusschnittstelle. Es folgt eine Auflistung der Feldbusse, die duch spezifische Buskoppler unterstützt werden.

Beckhoff Lightbus

Übersicht

Profibus DP/ MC

Übersicht

Interbus-S

Übersicht

CANopen

Übersicht

DeviceNet

Übersicht

SERCOS Interface

Übersicht

Ethernet TCP/IP Interface

Übersicht

Real-Time Ethernet Interface

Übersicht

USB Interface

Übersicht

Sonstige

CX1100-BK

Kontextmenü

Klemme Anfügen... <Einfg>

Fügt eine Busklemme unterhalb des Buskopplers an. Es erscheint der Klemmen Auswahldialog.

Box Einfügen...

Fügt eine weitere Box oberhalb der markierten ein.

Box Löschen... <Entf>

Löscht die momentan markierte Box und deren Unterelemente aus der E/A Konfiguration.

Box Importieren...

Fügt eine Box oberhalb der markierten ein. Die Beschreibung der neuen Box und deren Unterelemente wird aus einer Datei mit der Endung "*.tce" gelesen. Diese Datei wird mit dem folgenden Menüpunkt erzeugt.

Box Exportieren...

Exportiert die Informationen der momentan selektierten Box und die Informationen deren Unterelemente in eine Datei mit der Endung "*.ioe".


BK20x0 (Lightbus)

Die Buskoppler BK20x0 bzw. Busklemmen Controller BC2000 werden im Beckhoff Lightbus eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich hierbei von anderen Buskopplern unterscheiden. Eine Übersicht aktuell unterstützter Lightbus Buskoppler BK20x0, finden Sie hier. ..

Karteireiter „BK2xx0“

K-Bus Update: Berechnet die voraussichtliche Dauer für einen vollständigen Update des Klemmenbusses (ist abhängig von Anzahl und Art der angeschlossenen Klemmen).

2 Byte SPS Interface: Wenn angewählt, werden jeweils eine Ein- und Ausgangsvariable für das 2 Byte SPS Interface unterhalb des Kopplers eingefügt.

Überprüfe Klemmen beim Start: Wenn angewählt (nur möglich wenn das 2 Byte SPS Interface aktiv ist), werden während der Systemstart-Phase die projektierten und die physikalisch vorhandenen Klemmen am Koppler verglichen. Bei erkannten Differenzen wird die Systemstart-Phase mit entsprechender Meldung abgebrochen.

Überprüfe Online-Status: Wenn angewählt, wird das Statusbyte des Buskopplers (Adresse =0xFF) ausgewertet und bei Fehlern ein entsprechender Loggereintrag erzeugt.

Zeige Messagebox bei Fehlern: Wenn angewählt (nur möglich wenn das Überprüfen des Online-Status aktiv ist), werden eventuelle Fehler nicht nur geloggt sondern es wird zusätzlich eine Messagebox geöffnet.

Erzeuge eigenen K-Bus-Update: Das Update des Klemmenbusses kann beeinflusst werden. Wenn dieses Update nicht per Broadcast von der C1220 durchgeführt wird, muss ein eigener K-Bus-Update erfolgen (Standard).

Nach den eigene Daten: Das Update erfolgt direkt nach dem Übertragen der eigenen Daten.

Nach allen Daten: Das Update erfolgt nachdem alle Daten der aktuellen CDL übertragen worden sind.

Check K-Buis ready: Überprüfen ob der K-Bus bereit ist

Diagnose Ein- und Ausgänge

Es werden Eingangs- und Ausgangsbytes für Diagnose- und Einstellungszwecke zur Verfügung gestellt:

Eingänge | Beschreibung
TermDiag | Siehe auch Handbuch BK2000
 | Bit 0-7 = Terminal No
 | Bit 8-9 = Channel No
 | Bit 10-11 = Diag Code
 | Bit 12-14 = Diag Code Ex
 | Bit 15 = Fail
State | Inhalt des ersten Bytes des Wortes 255 aus dem Prozessabbild des Buskopplers (vgl. Handbuch des BK2000).
 | Bit 0 = Command Err
 | Bit 1 = Input Data Err
 | Bit 2 = Output Data Err
 | Bit 3 = Timeout
 | Bit 4 = K-Bus Reset Failure
 | Bit 6 = K-Bus Overrun (hat keine Funktion beim BK2000)

Ausgänge | Beschreibung
TermDiag | Siehe Handbuch BK2000
Ctrl0 | Inhalt des ersten Bytes des Wortes 254 aus dem Prozessabbild des Buskopplers (vgl. Handbuch des BK2000).
Ctrl1 | Ctrl1: Inhalt des zweiten Bytes des Wortes 254 aus dem Prozessabbild des Buskopplers (vgl. Handbuch des BK2000).


BK3xx0/BC3100 (Profibus)

Die Buskoppler BK3xx0 und der Busklemmen Controller BC3100, sowie der Antriebsverstärker AX2000-B310 werden im Profibus eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich von anderen Buskopplern unterscheiden. Eine Übersicht aktuell unterstützter Profibus Buskoppler, finden Sie hier...

Karteireiter "Profibus"

Stations-Nr.: Jeder Profibusteilnehmer benötigt eine eindeutige Stations-Nr.

Watchdog: Schaltet eine Watchdog-Funktionalität ein. Die Zeitdauer kann bei eingeschalteter Ansprechüberwachung eingestellt werden (in ms). Die Ansprechüberwachungszeit sollte mindestens 6 x größer als die Zykluszeit eingestellt werden, der minimale Wert ist 10 ms.

PrmData: Erlaubt die Profibus-spezifischen Parameterdaten zu editieren (-> Dokumentation der Buskoppler BK3xx0). Die Größe der aktuellen Parameterdaten wird angezeigt. Die PrmData können auch textuell (-> PrmData (Text)) oder teilweise über den Karteireiter "BK3xx0 / BC3x00" eingestellt werden

CfgData: Die aktuellen Konfigurationsdaten (ergeben sich aus den angefügten Klemmen) sowie deren Länge werden angezeigt.

Die Einstellungen DP-Class 1, DP-Class 2, DPV1-Class 2, Set und Reset Slave sind nur bei der FC310x aktiviert (-> PROFIBUS DP-Slaves an FC310x)

Karteireiter "BK3xx0 / BC3x00"

2 Byte SPS Interface: Schaltet das 2 Byte SPS Interface des Kopplers ein. Dadurch lassen sich Registereinstellungen im Koppler z.B. von der SPS durchführen.

Karteireiter "PrmData (Text)"

Durch Anklicken einer Zeile kann der aktuelle Wert verändert werden.

Diagnose

Die Diagnose der PROFIBUS DP-Slaves an der FC310x ist in einem gesonderten Kapitel beschrieben, im Folgenden die Diagnose bei anderen E/A-Geräten beschrieben.

Diagnose Eingänge

Jede Profibus-Slave Box erhält zwei Diagnose-Eingangsbytes, die den Status des jeweiligen Slaves zur Laufzeit signalisieren und z.B. mit der SPS verknüpft werden können:

BoxState

Wert | Beschreibung
0 | No Error
1 | Error - genauere Beschreibung im DpState

DpState

Wert | Beschreibung
0 | No Error - Station ist im Datenaustausch
1 | Station deactivated - Slave wurde deaktiviert, tritt zur Zeit nur temporär beim Hochlauf auf
2 | Station not exists - Slave antwortet nicht am Bus -> Prüfen, ob Slave eingeschaltet, ob PROFIBUS-Stecker angeschlossen, ob Stationsadresse korrekt oder ob Busverkablung korrekt
3 | Master lock - Slave ist mit anderem Master im Datenaustausch -> anderen Master vom Bus nehmen oder Slave mit anderem Master wieder freigeben
4 | Invalid slave response - falsche Antwort des Slaves, tritt temporär auf, wenn Slave aufgrund eines lokalen Ereignisses den Datenaustausch beendet hat
5 | Parameter fault - Parametrierungsfehler -> Prüfen, ob Buskoppler bzw. GSD-Datei korrekt, ob Stationsadresse korrekt oder ob UserPrmData-Einstellungen korrekt
6 | Not supported - DP-Funktion wird nicht unterstützt -> Prüfen, ob GSD-Datei korrekt oder ob Stationsadresse korrekt
7 | Config fault - Konfigurationsfehler -> Prüfen, ob die angefügten Klemmen bzw. Module korrekt sind
8 | Station not ready -> Station im Hochlauf, wird während des Hochlaufs temporär angezeigt
9 | Static diagnosis - Slave meldet statische Diagnose und kann zur Zeit keine gültigen Daten liefern -> Betriebszustand am Slave prüfen

PROFIBUS-Diagnosedaten

Die PROFIBUS-Diagnosedaten, die ein PROFIBUS-Slave sendet, können per ADS von jedem TwinCAT Programm gelesen bzw. an jedes TwinCAT-Programm gemeldet werden. Dabei sind die ADS-Parameter wie folgt einzustellen:

Net-ID: Net-ID des PCs

Port: 300

IndexGroup: 0x5000 + Device-ID

IndexOffset: Hi-Word: Stationsadresse, Lo-Word: 0x100

Länge: 6 - 244

Die Diagnosedaten sind wie in der DP-Norm beschrieben aufgebaut.


BK40x0 (Interbus)

Der Buskoppler BK4xx0 wird im InterBus eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich von anderen Buskopplern unterscheiden. Eine Übersicht aktuell unterstützter Interbus Buskoppler, finden Sie hier ...

Karteireiter "BK4xx0"

Ident-Code: Zeigt den Ident-Code des Buskopplers an. Er wird dynamisch - in Abhängigkeit der angeschlossenen Klemmen - berechnet.

Längen-Code: Zeigt den Längen-Code des Buskopplers an. Er wird dynamisch - in Abhängigkeit der angeschlossenen Klemmen - berechnet.

Installationstiefe: Zeigt die Installationstiefe des Buskopplers an. Sie wird dynamisch - in Abhängigkeit der hierarchischen Struktur des InterBus-S - berechnet.

Diagnose: Fügt je zwei Byte Diagnosedaten in das Prozessabbild der Ein- und Ausgänge ein (siehe Handbuch BK4000).

2 Byte SPS Interface: Fügt das zwei Byte SPS Interface in das Prozessabbild der Ein- und Ausgänge ein.

Diagnose Eingänge

Jede InterBus-S Box erhält ein Diagnose-Eingangsbyte, das den Status des jeweiligen Slaves zur Laufzeit signalisieren und z.B. mit der SPS verknüpft werden können:
Variable | Wert | Beschreibung
BoxState | 0x01 | Rec: Rekonfiguration
 | 0x02 | Mod: Modulfehler
 | 0x04 | W2Err: Fehler an der W2-Schnittstelle
 | 0x08 | W1Err: Fehler an der W1-Schnittstelle
 | 0x10 | W2: Zustand der W2-Schnittstelle inaktiv
 | 0x20 | W1: Zustand der W1-Schnittstelle inaktiv


BK51x0/LC5100/IPxxxx-B510 (CANopen)

Der Buskoppler BK51x0 sowie die FeldbusBox IPxxx-B510 werden im CANopen Bus eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich von anderen Buskopplern bzw. Feldbus Box Modulen unterscheiden. Eine Übersicht aktuell unterstützter CANopen Buskoppler BK51x0, finden Sie hier...

Karteireiter "BK51x0/IX-B510"

Node Id: Stellt die Node ID des CAN Bus Teilnehmers ein (zwischen 1 und 63 (BK51x0) bzw. 1 und 99 (IPxxxx-B510)). Dieser Wert muss mit dem am Buskoppler bzw. an der Kompakt Box eingestellten Wert übereinstimmen.

Guard Time: Zykluszeit für die Knotenüberwachung (Nodeguarding).

Life Time Factor: Mit Guard Time multipliziert ergibt sich die Watchdog-Zeit für die Überwachung des Masters durch den Koppler (Lifeguarding). Lifeguarding ist deaktiviert, wenn Life Time Factor zu null gesetzt wird.

Inhibit Time: Gibt den minimalen Sendeabstand für PDOs (Telegramme) mit analogen und Sondersignalen an. Wenn mehr als 64 digitale Signale vorhanden, werden diese auch mit dieser Inhibit-Zeit versehen.

Event Time: Ereignis-Timer für Sende-PDOs. Der Ablauf dieses Timers wird als zusätzlich eingetretenes Ereignis für das entsprechende PDO gewertet, das PDO wird also dann gesendet. Wenn das Applikationsereignis während einer Timer-Periode auftritt, so wird ebenfalls gesendet und der Timer wird zurückgesetzt.

K-Bus Update: Berechnet die voraussichtliche Dauer für einen vollständigen Update des Klemmenbusses (ist abhängig von Anzahl und Art der angeschlossenen Klemmen).

Trans.Type: Gibt den Transmission Type für digitale bzw. analoge Eingangstelegramme an. 254 + 255 entspricht der Ereignisgesteuerten Übertragung, 1...240 sind synchrone Übertragungsarten. Näheres siehe auch Handbuch BK51X0.

Firmware Update: Ermöglicht die Aktualisierung der Koppler-Firmware über die serielle Schnittstelle (erfordert Schnittstellenkabel des KS2000 Softwarepakets).

Diagnose Eingänge

FC510x: Jeder CANopen Feldbusknoten erhält ein Diagnose-Eingangsbyte (Node-State), das den Status des jeweiligen Slaves zur Laufzeit signalisiert und z.B. mit der SPS verknüpft werden kann. Zusätzlich wird über das Bit "Diag-Flag" signalisiert, ob eine neue Diagnose Information auf der Karte vorhanden ist. Diese kann dann über ADS READ ausgelesen werden.

CIF30-CAN: Jeder CANopen Feldbusknoten erhält ein Diagnose-Eingangsbyte (Box-State), das den Status des jeweiligen Slaves zur Laufzeit signalisiert und z.B. mit der SPS verknüpft werden kann. Zusätzlich gibt es ein weiteres Bit "DataExchange", das anzeigt ob der Knoten im Datenaustausch ist.

Karteireiter "SDOs"

Auf dieser Seite werden SDO Einträge angezeigt/verwaltet, die beim Startup zum Knoten geschickt werden. Einträge deren Objekt-Index in spitzen Klammern stehen, sind automatisch aufgrund der aktuellen Klemmenkonfiguration erzeugt worden. Weitere Einträge können über "Anfügen", "Einfügen", "Löschen" und "Bearbeiten" verwaltet werden.

Karteireiter "ADS"

Um SDO-Objekte auch zur Laufzeit schreiben und Lesen zu können (z.B. aus der SPS heraus), kann dem Knoten (Buskoppler) ein ADS-Port zugewiesen werden (CIFx0-CAN). Die FC510x verfügt stets über einen ADS-Port für jeden Knoten, da die Diagnoseinformationen über ADS transportiert werden. Über diesen können SDO-Objekte per ADS Read Request bzw. Write Request gelesen und geschrieben werden.

Der ADS IndexGroup beinhaltet den CANopen Object Index und der ADS IndexOffset beinhaltet den CANopen SubIndex.

CANopen-Emergency-Objekt

Einige CANopen-Statusdaten sowie empfangene Emergency-Objekte eines Nodes können per ADS von jedem TwinCAT Programm gelesen bzw. an jedes TwinCAT-Programm gemeldet werden. Die Datenstrukturen und Adressen unterscheiden sich zwischen FC510x und CIFx0-CAN.


BK52x0/LC5200 (DeviceNet)

Der Buskoppler BK52x0 wird im DeviceNet Bus eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich von anderen Buskopplern unterscheiden. Eine Übersicht aktuell unterstützter DeviceNet Buskoppler BK52x0, finden Sie hier...

Karteireiter "BK52x0"

MAC Id: Stellt die Node Id des DeviceNet Teilnehmers ein (zwischen 0 und 63). Dieser Wert muss mit dem am Buskoppler eingestellten Wert übereinstimmen.

Cycle Time: Legt die Zykluszeit der IO-Verbindung fest. Dieser Wert wird zudem in das Expected Packet Rate (EPR) Attribute des DeviceNet Slaves eingetragen und dient der Timeout-Überwachung von IO-Verbindungen.

Electronic Key: Dient der Überprüfung der sich im Netz befindlichen Geräte beim Systemstart. Der Electronic Key wird bei jedem Systemstart aus den Geräten ausgelesen und mit der gespeicherten Konfiguration verglichen.

Polled: Produced/Consumed: Aktivierung der Betriebsart "Polling", zyklisches Schreiben und Lesen von IO-Daten. Einstellung des Dateninhaltes der über die Polled IO Verbindung übertragenen Daten. Zur Auswahl stehen digitale Daten, analoge Daten oder beides. Die Auswahl hängt hierbei von den am BK52xx angeordneten Klemmen ab.

Bit-Strobed: Produced/Consumed: Aktivierung der Betriebsart "Bit-Strobe". Mit einer Broadcast Message werden alle Knoten aufgefordert, ihre Bit-Strobe Message (bis 7 Bytes Eingangs- oder Statusdaten) zu senden. Einstellung des Dateninhaltes der über die Bit-Strobed IO Verbindung übertragenen Daten. Zur Auswahl stehen hierbei digitale Daten oder Diagnosedaten.

Change of State / Cyclic:

- Produced/Consumed: Einstellung des Dateninhaltes der über die Change of Sate / Cyclic IO Verbindung übertragenen Daten. Zur Auswahl stehen digitale Daten, analoge Daten oder beides. Die Auswahl hängt hierbei von den am BK52xx angeordneten Klemmen ab.

- Change of State / Cyclic: Auswahl der entsprechenden Betriebsart

- Heartbeat Rate / Scan Rate: Die Heartbeat Rate gibt bei der Betriebsart "Change of State" die Cycle-Time an mit der IO-Daten untergelagert, d.h. zusätzlich zum ereignisgesteuerten senden, zyklisch gesendet werden. Die Scan Rate gibt bei der Betriebsart "Cyclic" die Cycle-Time an mit der IO-Daten gesendet werden.

Inhibit Time: Verzögerungszeit bei der Betriebsart "Change of State", IO-Daten werden nach einem Zustandswechsel frühestens nach der hier eingestellten Zeit gesendet.

Acknowledge Timeout: Zeitspanne bis zur Sendewiederholung bei fehlendem Acknowledge auf eine Change of State / Cyclic Nachricht.

Acknowldege Retry Limit: Maximale Anzahl Sendewiederholungen bis IO-Verbindung in Fehlerzustand übergeht

K-Bus Update: Berechnet die voraussichtliche Dauer für ein vollständiges Update des Klemmenbusses (ist abhängig von den angeschlossenen Klemmen).

Diagnose Eingänge:

Jeder DeviceNet Feldbusknoten erhält ein Diagnose-Eingangsbyte, das den Status des jeweiligen Slaves zur Laufzeit signalisiert und z.B. mit der SPS verknüpft werden kann:

CouplerState

Error Code | Description | Troubleshooting
0x00 | No error |
0x01 | IO Error Data exchange between coupler and terminals has faulted | Check the IO error LEDs at the coupler, see error code in coupler manual
0x02 | Coupler configuration error, devices non-volatile parameters are not valid | Set Manufacturers Setting e.g. with KS2000 or via register communication and reset coupler
0x08 | Diagnoses of analog terminals, this feature has first to be activated via KS200 or register communication | Read the terminal diagnoses via explicite messages or via the Bit-Strobe Connection. The Bit is reseted after reading of the diagnosis data
0x80 | Fieldbus Error / Idle Mode | Check Communication Parameter of the IO Connections. Send correct IO data, Check if the Device is in the Idle mode. The bit is reseted if the device receives valid IO data

BoxState

Error Code | Description | Troubleshooting
0x02 | Station not exists, device is not responding | Inspect the device, verify connections, check cabling
0x05 | Parameter fault | Check explicite access to devices attributes, check object class, instance and attribute id
0x07 | Configuration fault | Check configuration settings of device
0x09 | Device is deactivated | Check master and device configuration

DataExchange

Error Code | Description | Troubleshooting
0x00 | No data exchange between node and master | Inspect the field device, verify connections, check cabling
0x01 | Data Exchange is active |

Karteireiter "Attribute"

Auf dieser Seite werden DeviceNet Attribute/Parameter angezeigt/verwaltet, die beim Startup zum Knoten geschickt werden. Die Einträge können über "Neu", "Löschen" und "Bearbeiten" verwaltet werden.

Karteireiter "ADS"

Um Attribute auch zur Laufzeit schreiben und lesen zu können (z.B. aus der SPS heraus), kann dem Knoten (Buskoppler) ein ADS-Port zugewiesen werden. Über diesen können die Attribute per ADS Read Request bzw. Write Request gelesen und geschrieben werden.

Der ADS IndexGroup beinhaltet die ClassId und der ADS IndexOffset beinhaltet InstanceId und AttributeId (InstanceId * 256 + AttributeId).

Diagnosedaten

DeviceNet-Statusdaten eines Nodes können per ADS von jedem TwinCAT Programm gelesen bzw. an jedes TwinCAT-Programm gemeldet werden.

Karteireiter "Parameter"

Die Parameter werden beim Anlegen der Box aus dem EDS ausgelesen. Ist das System noch nicht gestartet, werden unter dem Value-Eintrag immer die im EDS hinterlegten Default-Werte angezeigt.


BK7500 (SERCOS interface)

TwinCAT System Manager: Reference

BK75x0 (SERCOS interface)

Der Buskoppler BK75x0 wird am SERCOS Interface eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich von anderen Buskopplern unterscheiden.

Der Koppler ist in enger Anlehnung an die Sercos I/O Spezifikation gehalten und generiert entsprechende I/O Datenkanäle, die über IDNs angesprochen werden können. Damit sollte er an allen SERCOS Interface konformen Steuerungen eingesetzt werden können. Eine Übersicht aktuell unterstützter SERCOS Buskoppler BK75x0, finden Sie hier...

Karteireiter "BK7500"

Adresse: Hierüber wird die Sercos Adresse eingestellt, mit der sich der Koppler am Bus meldet.

K-Bus Update: Anhand der angehängten Klemmen wird die voraussichtliche K-Bus Laufzeit berechnet und angegeben.

Strict Mode: Es kann über den herstellerspezifischen Parameter P-0-0001 eingestellt werden ob die Vergabe der I/O Datenkanäle strikt nach der Sercos I/O Spezifikation erfolgen soll oder eine IDN sparende Variante genutzt werden soll, da einige Steuerungen nur eine begrenzte Anzahl von IDN in das Master Daten Telegramm (MDT) bzw. Antriebstelegramm (AT) aufnehmen können. Die Checkbox auf diesem Reiter zeigt den gewählten Modus nur an. Verändert werden kann er auf dem nächsten Reiter unter Startup, indem dem Koppler bei jedem Startup (Phasenwechsel von 2 auf 3) dieser Parameter mitgeteilt wird und die Vergabe der I/O Datenkanäle entsprechend durchgeführt wird.

Firmware Update...: Die Firmware des Kopplers kann hierüber mit einem sogenannten KS2000 Kabel upgedatet werden.

Karteireiter "Startup"

Im "Startup" Karteireiter können beliebige IDNs angegeben werden (2 und 4 Byte Werte), die zum Koppler beim Phasenwechsel von 2 auf 3 gesendet werden. Hier können weitere Werte hinzugefügt und auch gelöscht werden.

Karteireiter "Ist-/Sollwertkanal"

Sowohl der Koppler als auch der TwinCAT System Manager berechnet die Vergabe der I/O Datenkanäle anhand der angeschlossenen Klemmen. Hierbei wird der Wert in P-0-0001 berücksichtig, der normalerweise immer in den Startup Parametern mitaufgenommen sein sollte, damit sowohl der Koppler und der System Manager von der gleichen Berechnung ausgehen. Die berechneten I/O Datenkanäle werden in die Liste der IDNs des ATs (S-0-0016, Istwertkanal), bzw. des MDTs (S-0-0024, Sollwertkanal). Zusätzlich zu den automatisch generierten Einträgen können weitere IDNs in das AT und MDT aufgenommen werden (wie im Bild die IDN S-0-0364).

Karteireiter "Online"

Über den Online Reiter können zur Laufzeit ab Phase 2 auf alle IDNs des Kopplers lesend und schreibend zugegriffen werden.


BK9000 (Ethernet Interface)

Der Buskoppler BK9000 wird unterhalb der "Virtuellen Ethernet-Schnittstelle" konfiguriert. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich beim BK9000 von denen anderer Buskoppler unterscheiden.

Der Ethernet Koppler kommuniziert via TCP/IP oder UDP (und darauf aufgesetztem ADS als Benutzerschnittstelle / Application Layer) mit dem TwinCAT-System. Eine Übersicht aktuell unterstützter Buskoppler BK90x0, finden Sie hier...

Karteireiter "Bx9000"

Diagnosis: Diese Checkbox ist beim BK9000 deaktiviert.

2 Byte PLC Interface: Diese Checkbox ist beim BK9000 deaktiviert.

No Real time Flag: If unchecked, the BK9000 bypasses at all incoming Ethernet frames its internal TCP/IP stack (default if used with Beckhoff TwinCAT Real-Time Ethernet in Run Mode). If, i.e. for configuration purposes in Config Mode sessions the TCP/IP part has to be enabled, this flag may be activated.

K-Bus Update: Anhand der angehängten Klemmen wird die voraussichtliche K-Bus Laufzeit berechnet und angegeben.

Firmware Update: The firmware update dialog is called by pushing this button. With this function, the most recent firmware version for the BK9000 can be loaded to this device (via LAN or COM port).

Data Exchange: The data exchange with devices can be adapted to their local K-Bus update time and related application. The following description is based on the fact, that the I/O driver resolves an internal cycle counter which is always present.

Scenario: A network contains two Bus Couplers. One Coupler (A) has only a few digital Bus Terminals attached and needs to be updated fast. Another Coupler (B) has analog Bus Terminals and doesn't need to get updated that fast. In that case, at Bus Coupler (B) the

- Divider: would be set e.g. to '4' to force the I/O system to only exchange data with this device in every 4th I/O cycle

and the

- Modulo: factor takes care (in the above case it can be set to value between 0..3) that (B) doesn't get an update in the same cycle (A) gets it.

VLAN Support:

- Enable: Activates the VLAN support (see: IEEE 802.1Q, RFC3518) for the communication with this device. If enabled, the Ethernet frame is getting extended by 4 byte. These extension is called VLAN tag and contains information about ID and priority for instance

- Priority: A 3 bit VLAN priority value as defined by IEEE 802.1D. Most switches contain two queues, a high and a low priority one. Therefore priorities between 0..3 are assigned to the high priority queue and 4..7 are assigned to the low priority queue at those switch types.

- Id: 12 bit VLAN identifier number as defined by IEEE 802.1Q.

Karteireiter "IP Address"

Informationen zu diesem Karteireiter finden sie unter -> Karteireiter "IP Address".

Karteireiter "ADS Commands"

Informationen zum -> "ADS Kommando-Eingabefenster".

Diagnose Eingänge

Jedes Feldbusmodul besitzt Status-Informationen, welche in TwinCAT verknüpft werden können (z.B. mit der SPS). Diese Statusinformationen sind größtenteils identisch bei allen Beckhoff Feldbusknoten (siehe CouplerState, MissedCnt)) und werden daher, außer dem nachfolgend erklärten, spezifischen BoxState, an anderer Stelle, nämlich unter -> "Statusinformationen - Beckhoff Feldbusknoten", erklärt. Zusätzlich wird jede Status-Variable im zu ihr gehörenden Kommentarfeld beschrieben.

Variable "BoxState" at BK9000 couplers underneath a Virtual Ethernet Interface device:

Variable | Datentyp | Wert | Beschreibung
BoxState | UINT16 | 0x0000 | Kein Fehler
 |  | 0x0001 | Keine aktuellen Eingangsinformationen erhalten
 |  | 0x0002 | Ausgänge gesperrt (nur bei UDP)
 |  | 0xnn00 | nn = aktuelles Warning-Level (nur bei UDP)

Hinweis:

Die Task-Zeit ("Zyklusticks") der jeweiligen Task sollte so hoch gewählt werden, daß der bei MissedCnt angezeigte Wert immer konstant ist. Im Zweifelsfall ist es dabei besser, eine etwas höhere Zykluszeit zu wählen.

Beispiel:

Minimale Zykluszeit bei gewähltem Protokoll UDP: 30ms

Minimale Zykluszeit bei gewähltem Protokoll TCP: 50ms

Variable "BoxState" at BK9000 couplers within an Ethernet Miniport (real-time) subnet:

Variable | Datentyp | Wert | Beschreibung
BoxState | UINT16 | 0x0000 | No error
 |  | 0x0001 | No Inputs received
 |  | 0x0002 | Outputs disabled
 |  | 0x0004 | No communication
 |  | 0x0008 | Old inputs
 |  | 0x0010 | Invalid input length (configured input process variables don't match attached Bus Terminals)
 |  | 0x0020 | Invalid output length (configured output process variables don't match attached Bus Terminals)


BC9000 (Ethernet Interface)

Der IEC1131-3 programmierbare Busklemmen Controller BC9000 wird an der "Virtuellen Ethernet-Schnittstelle" eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich von anderen Buskopplern oder Busklemmen Controllern unterscheiden. Der Ethernet Busklemmen Controller kommuniziert via TCP/IP oder UDP (und darauf aufgesetztem ADS als Benutzerschnittstelle / Application Layer) mit dem TwinCAT-System. Eine Übersicht aktuell unterstützter Ethernet Busklemmen Controller, finden Sie hier...

Diagnose Eingänge

Die direkt unter dem Busklemmen Controller aufgeführten SPS Variablen, werden unter "Datenaustausch PC / Busklemmen Controller" erklärt.

Jedes Feldbusmodul besitzt Status-Informationen, welche in TwinCAT verknüpft werden können (z.B. mit der SPS). Diese Statusinformationen sind größtenteils identisch bei allen Beckhoff Feldbusknoten (siehe CouplerState, MissedCnt)) und werden daher, außer dem nachfolgend erklärten, spezifischen BoxState an anderer Stelle, nämlich unter -> "Statusinformationen - Beckhoff Feldbusknoten", erklärt. Zusätzlich wird jede Status-Variable im zu ihr gehörenden Kommentarfeld beschrieben.

Variable | Datentyp | Wert | Beschreibung
BoxState | UINT16 | 0x0000 | Kein Fehler
 |  | 0x0001 | Keine aktuellen Eingangsinformationen erhalten
 |  | 0x0002 | Ausgänge gesperrt (nur bei UDP)
 |  | 0xnn00 | nn = aktuelles Warning-Level (nur bei UDP)

Karteireiter "Bx9000"

Diagnosis: Diese Checkbox ist beim BC9000 deaktiviert.

2 Byte PLC Interface: Diese Checkbox ist beim BC9000 deaktiviert.

K-Bus Update: Anhand der angehängten Klemmen wird die voraussichtliche K-Bus Laufzeit berechnet und angegeben.

Karteireiter "PLC"

Informationen zu diesem Karteireiter finden sie unter -> "Datenaustausch PC / Busklemmen Controller".

Karteireiter "IP Address"

Informationen zu diesem Karteireiter finden sie unter -> Karteireiter "IP Address".

Karteireiter "ADS Commands"

Informationen zum -> "ADS Kommando-Eingabefenster".

Hinweis:

Die Task-Zeit ("Zyklusticks") der jeweiligen Task sollte so hoch gewählt werden, daß der bei MissedCnt angezeigte Wert immer konstant ist. Im Zweifelsfall ist es dabei besser, eine etwas höhere Zykluszeit zu wählen.

Beispiel:

Minimale Zykluszeit bei gewähltem Protokoll UDP: 30ms

Minimale Zykluszeit bei gewähltem Protokoll TCP: 50ms


BK9500 (USB Interface)

Der Buskoppler BK9500 wird an der virtuellen USB-Schnittstelle eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich von anderen Buskopplern unterscheiden.

Der USB Buskoppler kommuniziert via ADS mit dem TwinCAT-System. Eine Übersicht aktuell unterstützter USB Buskoppler BK95x0, finden Sie hier...

Diagnose Eingänge

Jedes Feldbusmodul besitzt Status-Informationen, welche in TwinCAT verknüpft werden können (z.B. mit der SPS). Diese Statusinformationen sind größtenteils identisch bei allen Beckhoff Feldbusknoten (siehe CouplerState, MissedCnt)) und werden daher, außer dem nachfolgend erklärten, spezifischen BoxState an anderer Stelle, nämlich unter -> "Statusinformationen - Beckhoff Feldbusknoten", erklärt. Zusätzlich wird jede Status-Variable im zu ihr gehörenden Kommentarfeld beschrieben.

Variable | Datentyp | Wert | Beschreibung
BoxState | UINT16 | 0x0000 | Kein Fehler
 |  | 0x0001 | Keine aktuellen Eingangsinformationen erhalten

Karteireiter "BK95x0/CPx8xx"

Dip-Switch: Gibt die Dip-Switch-Einstellung (Adresse) bei USB Buskopplern an. Falls der BK9500 (und seine Klemmen) durch ->"Geräte Suchen" gefunden wurden, ist die korrekte Adresse hier automatisch eingetragen worden.

Diagnosis: Diese Checkbox ist beim BK9500 deaktiviert.

2 Byte PLC Interface: Diese Checkbox ist beim BK9500 deaktiviert.

K-Bus Update: Anhand der angehängten Klemmen wird die voraussichtliche K-Bus Laufzeit berechnet und angegeben.

Search: Das Betätigen dieser Schaltfläche löst ein manuelles Suchen des Device Handles aus (normalerweise nicht notwendig).

Device Handle: Zeigt, bei aktivierter Konfiguration und gestartetem TwinCAT, das vom Betriebssystem vergebene und momentan gültige USB Device Handle an.

Karteireiter "ADS Commands"

Weitere Informationen zum -> "ADS Kommando-Eingabefenster".


Control Panel CPx8xx (USB Interface)

TwinCAT System Manager: Reference

CP68xx / CP78xx (USB Interface)

Das Beckhoff Control Panel CP68xx bzw. CP78xx besitzt eine USB-Schnittstelle (inkl. integriertem USB-Hub), um die Kommunikation der Sondertasten oder jegliche sonstige, am Panel angeschlossenen USB-Geräte, mit dem PC zu ermöglichen. Mit dem TwinCAT System kommunizieren die Sondertasten, bzw. am Panel angeschlossene Beckhoff USB Feldbusgeräte, via ADS.

Typen | Beschreibung
CP68xx / CP78xx | Beckhoff Control Panel mit DVI und USB Interface

Karteireiter "BK95x0/CPx8xx"

Dip-Switch: Gibt die Dip-Switch-Einstellung (Adresse) bei Beckhoff USB Geräten an. Falls das USB Control Panel (und eventuelle Busklemmen) mittels ->"Geräte Suchen" gefunden wurde, ist die korrekte Adresse hier automatisch eingetragen worden.

Buttons: Gibt die Anzahl der logisch vorhandenen Tasten an. Hierzu zählen auch die in der Tastererweiterung nicht bestückten, logisch aber trotzdem vorhandenen, Eingänge. Der voreingestellte Wert is 27, was für die meisten Beckhoff Control Panel gilt (siehe auch -> "BECKHOFF Knowledge Base").

LEDs: Gibt die Anzahl der logisch vorhandenen Ausgänge (LEDs/Leuchtmelder) in den Sondertasten an. Hierzu zählen auch die in der Tastererweiterung nicht bestückten, logisch aber trotzdem vorhandenen, Leuchtmelder. Der voreingestellte Wert ist 27, was für die meisten Beckhoff Control Panel gilt (siehe auch -> "BECKHOFF Knowledge Base").

K-Bus Update: Anhand der angehängten Klemmen wird die voraussichtliche K-Bus Laufzeit berechnet und angegeben.

Diagnosis: Diese Checkbox ist beim CPx8xx deaktiviert.

2 Byte PLC Interface: Diese Checkbox ist beim CPx8xx deaktiviert.

Search: Das Betätigen dieser Schaltfläche löst ein manuelles Suchen des Device Handles aus (normalerweise nicht notwendig).

Device Handle: Zeigt, bei aktivierter Konfiguration und gestartetem TwinCAT, das vom Betriebssystem vergebene und momentan gültige USB Device Handle an.

Karteireiter "ADS Commands"

Informationen zum -> ADS Kommando-Eingabefenster.

E/A-Variablen:

Eingänge:

PanelState: Dieses Bit-Array wird momentan nicht benutzt (reserviert).

S 1 - n: Hier kann der Status der Control Panel-Sondertasten sowie der Taster und Schalter von eventuellen Tastererweiterungen abgefragt, und mit Eingangsvariablen der anderen Task (z.B. TwinCAT PLC) verknüpft werden.

CouplerState: Siehe "Status Informationen - Beckhoff Feldbusknoten"

BoxState: Siehe "BK9500 (USB Interface)"

MissedCnt: Siehe "Status Informationen - Beckhoff Feldbusknoten"

Hinweis:

USB ist spezifiziert für Segmentlängen von bis zu 5 m (vom Hub zum Endgerät, bzw. nächstem Hub). Falls der MissedCnt-Wert im Normalbetrieb hochzählt, sollte zu Testzwecken ein kurzes handelsübliches USB-Kabel (z.B. mit einer Länge von 3 m) eingesetzt werden. Damit ließe sich ermitteln, ob das Problem eventuell durch eine grenzwertige USB-Kabellänge (Gesamtlänge) hervorgerufen wird.

Ausgänge:

PanelCtrl: Mit diesem Bit-Array kann das Control Panel gesteuert werden. Momentan ist nur das Ausschalten der Hintergrundbeleuchtung implementiert (siehe auch zugehöriges Kommentarfeld).

Variable (Bit in DWORD) | Datentyp | Wert | Beschreibung
PanelCtrl[5] | BOOL | 0 | Display: Hintergrundbeleuchtung = AN
 |  | 1 | Display: Hintergrundbeleuchtung = AUS

LED 1 - n: Hier können die Ausgangsvariablen der anderen Task (z.B. TwinCAT PLC) verknüpft, bzw. deren Status überprüft werden. Ein '1'-Signal an der jeweiligen Variable schaltet die zugehörige LED der Folientaste bzw. das Leuchtmittel des Leuchttasters an.


Statusinformationen - Beckhoff Feldbusknoten

Jedes Feldbusmodul besitzt Status-Informationen, welche in TwinCAT verknüpft werden können (z.B. mit der SPS). Diese Statusinformationen sind bei Beckhoff Feldbusknoten größtenteils identisch (siehe nachfolgend CouplerState, MissedCnt) und werden hier daher, außer dem spezifischen BoxState (siehe jeweilige Komponente, z.B. BC9000) unter -> TwinCAT System Manager - Referenz), für alle Beckhoff Buskoppler, Busklemmen Controller und Feldbusboxen gemeinsam, erklärt.

Diagnose Eingänge

Variable | Wert | Beschreibung
CouplerState | 0x0000 | Kein Fehler
 | 0x0001 | Klemmenbusfehler (weitere Informationen sind in der jeweiligen Hardware-Dokumentation zu finden)
 | 0x0002 | Konfigurationsfehler (z.B. falsche Anzahl konfigurierter Klemmen. Weitere Informationen sind in der jeweiligen Hardware-Dokumentation zu finden).

Variable | Wert | Beschreibung
MissedCnt | numerisch | Wird inkrementiert in jedem I/O-Zyklus, in dem keine neuen (aktuellen) Eingänge gelesen wurden.


Ethernet Feldbuskomponenten - IP Adresse

TwinCAT System Manager: Reference

Karteireiter "IP Address"

Ethernet-Komponenten benötigen eine eindeutige IP-Adresse im Netzwerk. Nachfolgend ist der, für die Konfiguration des Feldbusknotens im TwinCAT System notwendige, Einstelldialog beschrieben. Der gezeigte Dialog erscheint bei Anwahl / Anfügen eines BK9000, BC9000 oder eines anderen Beckhoff Ethernet Feldbusgerätes im Baum der System Manager Konfiguration.

Hostname: Hier kann der Name der Beckhoff Ethernet-Komponente editiert werden.

IP-Address: Hier muss die IP-Adresse der Komponente (z.B. eines BK9000 Ethernet Buskopplers) eingetragen werden.
 | Bit7 | Bit6 | Bit5 | Bit4 | Bit3 | Bit2 | Bit1 | Bit0
Feste IP-Adresse | 0 | 0 | Letzte Stelle der IP Adresse z. B. 135.122.57. {Bit5-Bit0}
Boot P | 0 | 1 | 0-5 auf ON wird die BootP Adresse Permanent gespeichert |  |  | 0-5 auf OFF wird die BootP Adresse Flüchtig gespeichert
DHCP | 1 | 0 | Die Einstellung fließt in den DHCP-Namen ein

GetHostByName: Durch Betätigung dieser Schaltfläche kann, ab BK9000 Firmware-Version "B2", eine IP-Adresse von einem Windows 2000 DHCP (Dynamic Host Configuration Protocol) Server, bezogen werden.

Set IP Address: Bei TwinCAT Real-Time Ethernet Busknoten kann diese Schaltfläche betätigt werden, um die IP Adresse konform zum Subnet des genutzten Ethernet Miniport (real-time) Adapters einzustellen.

AMS Address: Gibt die AMS-Net ID des Buskopplers an. Sie wird automatisch aus der IP-Adresse + zwei zusätzlichen Byte-Werten (z.B.: ".1.1") generiert.

BootP: Diese Checkbox ist aktivierbar, falls der Beckhoff BootP Server installiert und gestartet ist (ab TwinCAT Version 2.8).

New MAC Addresses: Bei gestartetem -> "Beckhoff Bootp Server", können durch Betätigung dieser Schaltfläche die neuen MAC (Media Access Controller) -Adressen angezeigt werden. Die erhaltene MAC-Adresse wird danach in dem Feld angezeigt, welches sich unter der Schaltfläche befindet. Falls nur ein neues Beckhoff Ethernet Feldbusgerät angeschlossen ist, wird dementsprechend auch nur eine neue MAC-Adresse angezeigt, welcher dann eine gewünschte IP-Adresse, im oben beschriebenem Feld IP Address, zugewiesen werden kann. Bei Anschluß einer weiteren Beckhoff Ethernet Feldbuskomponente, kann man dann diesen Vorgang auf dem hier beschriebenen Karteireiter der neuen Box, wiederholen.

Communication Settings:

TCP: Wenn diese Option aktiv ist (Voreinstellung z.B. beim BC9000), wird die Kommunikation über TCP (Transmission Control Protocol ) abgewickelt. Dies bedeutet, die Telegrammpakete vom und zum Buskoppler werden über einen gesicherten (bestätigten) Mechanismus ausgetauscht.

ADS (verfügbar bei TwinCAT Echtzeit Ethernet Komponenten): Falls diese Option ausgewählt wurde,...

UDP: Wenn diese Option ausgewählt wurde, wird die Kommunikation über UDP (User Datagram Protocol ) abgewickelt. Im Gegensatz zum TCP sind hierbei die einzelnen Telegrammpakete nicht gesichert, d.h., sie werden nicht jeweils nach deren Erhalt vom Empfänger bestätigt. Zerstörte oder in der Reihenfolge vertauschte Telegrammpakete werden nicht erneut gesendet oder sortiert. Der Vorteil des UDP besteht aus kalkulierbaren Telegrammlaufzeiten, da nicht erst auf eine Antwort vom Empfänger gewartet werden muss. UDP ist im Gegensatz zu TCP/IP die schnellere Kommunikationsart, da hierfür kein TCP/IP Protokoll-Stack benötigt wird.

RAW (verfügbar bei TwinCAT Echtzeit Ethernet Komponenten): Diese Option ist standardmäßig bei TwinCAT Echtzeit Ethernet Komponenten voreingestellt.

Max. Warning Level: Diese Einstelloption ist nur bei UDP aktiv. Hier kann der maximale Wert des Fehlerzählers eingetragen werden. Bei Erreichen des eingestellten Maximalwertes, wird nicht mehr auf ein Antworttelegramm des Feldbusknotens gewartet. Stattdessen werden nur noch Lesetelegramme, basierend auf einer höheren Zykluszeit, zum Feldbusknoten geschickt.

No Auto Retries: Diese Checkbox ist auch nur bei aktivierter Option UDP anwählbar. Bei Erreichen des eingestellten Wertes unter Max. Warning Level, ist bei aktivierter Checkbox ein Ausführen der Funktion "Online Reset" notwendig.

Karteireiter "ADS Commands"

Für Informationen zu diesem Karteireiter, siehe: "ADS Kommando-Eingabefenster".


Übersicht

Nachfolgend aufgeführte Geräte werden im Beckhoff Lightbus eingesetzt und natürlich auch von TwinCAT unterstützt.

Lightbus - Teilnehmer ("Box") | Beschreibung | Einschränkungen / Anmerkung
BK2000 | Buskoppler |
BK2010 | Economy Buskoppler |
BK2020 | "Economy plus" Buskoppler |
IPxxxx-B200 | Feldbus Kompakt Box: Lightbus Ein-/Ausgabebaugruppe in Schutzart IP67 |
ILxxxx-B200 | Feldbus Koppler Box: Erweiterbare Lightbus Ein-/Ausgabebaugruppe in Schutzart IP67 |
Allgemeine 32-bit Box | Allgemeines 4 Byte Telegramm. Hiermit können die Boxen bedient werden, die nicht gesondert aufgeführt sind |
M1110 | Digitales Ein-/Ausgabemodul mit Lightbus Interface (IP65), einzubinden als "Allgemeine 32-bit Box" |
M1200, M1210 | Lightbus - Interface Modul, einzubinden als "Allgemeine 32-bit Box" |
M1400 | Box mit 32 digitalen Ein-/Ausgängen, einzubinden als "Allgemeine 32-bit Box" |
M1410 | Box mit 16 digitalen Ein-/Ausgängen, einzubinden als "Allgemeine 32-bit Box" |
M2400 | Analoge Ausgangsbox (4-kanalig) |
M2510 | Analog Eingabe-Modul (12 Bit Auflösung, ±10 V, 0-10 V oder 4-20 mA einstellbar) |
M3000 | Absolut-Encoder (24 Bit Auflösung, Multi-Turn, 4096 Schritte/Umdrehung) mit Lightbus Interface, konfigurierbar als M3000 Box |
M3100 | Inkremental-Encoder Interface (24 Bit Auflösung) mit Lightbus Interface, Schutzart IP65, konfigurierbar als 1-kanalige M3120 Box |
M3120 | Inkremental-Encoder Interface Box (1-4 kanalig), konfigurierbar als M3120 Box |
M3200 | Inkremental-Encoder (24 Bit Auflösung) mit Lightbus Interface, konfigurierbar als 1-kanalige M3120 Box |
M63x0 | Befehlsgeräte M6310, M6320, M6330 und M6350 mit Lightbus Interface, konfigurierbar als "Allgemeine 32-bit Box" |
C1120 | Schnittstelle zu Siemens S5 Steuerungen als Slave-Station für das TwinCAT System |
FOX 20 | Das Fox-20 Modul besitzt vier Steckplätze, welche digitale und analoge Submodule aufnehmen können |
FOX 50 | Das Fox-50 Modul ist ein zweikanaliges SSI-Geber-Interface |
FOX RK001/002 | Das Fox-Rk001 und Fox-Rk002 Modul sind Koppelmodule, die den LWL-Ring mit einem anderen LWL-Ring (Rk001) oder mit einem Profibus (Rk002) koppeln. |
AX2000-B200 | Digitaler Servo-Antriebsverstärker mit Lightbus Interface |


Allgemeines 32-Bit Gerät

Über den Boxtyp "Allgemeine 32-Bit Box" können alle die Beckhoff Lightbus Boxen bedient werden, die nicht extra aufgeführt sind. Beim Lightbus werden pro Telegramm 32-Bit bzw. 4 Byte Daten zur Box geschickt (Ausgänge auf dem Feldbus) und wieder 32-Bit Daten eingelesen (Eingänge auf dem Feldbus).

Die Bedeutung der einzelnen Bits bzw. Bytes bei den unterschiedlichen Boxen entnehmen Sie dem jeweiligen Handbuch der Box.

Kontextmenü

Box Einfügen...

Fügt eine weitere Box oberhalb der markierten ein.

Box Löschen... <Entf>

Löscht die momentan markierte Box und deren Unterelemente aus der E/A Konfiguration.

Box Importieren...

Fügt eine Box oberhalb der markierten ein. Die Beschreibung der neuen Box und deren Unterelemente wird aus einer Datei mit der Endung "*.tce" gelesen. Diese Datei wird mit dem folgenden Menüpunkt erzeugt.

Box Exportieren...

Exportiert die Informationen der momentan selektierten Box und die Informationen deren Unterelemente in eine Datei mit der Endung "*.ioe".

Variablen

Unterhalb der Box werden automatisch je vier Byte Ein- und Ausgänge definiert, die entweder als Bytes oder als einzelne Bits angesprochen bzw. verknüpft werden können.

Karteireiter "32-Bit"

Die Verknüpfung der einzelnen Variablen kann über den Karteikartenreiter "32 Bit" übersichtlich für alle Variablen gleichzeitig erfolgen. Natürlich bleibt die Möglichkeit erhalten, die Verknüpfung über das Kontextmenü oder die Karteiansicht der jeweiligen Variablen durchzuführen.

D0 Eing...: Öffnet den Verknüpfungsdialog für das erste Eingangsbyte bzw. für ein Bit des ersten Eingangsbyte wenn bitweise angewählt wurde. Bei bitweisem Verknüpfen kann das jeweils relevante Bit angewählt werden.

D1 Eing...: dito.


M2400

Die M2400 ist eine bis zu vierkanalige analoge Ausgangsbox, die zusätzlich noch zwei digitale Datenbytes besitzt. Ob die Datenbytes als Ein- oder Ausgang fungieren wird in der Box gejumpert (siehe Handbuch der M2400). Besitzt die Box weniger als vier analoge Kanäle dürfen die entsprechenden DAC's nicht verknüpft werden.

Hinweis:

Wird die Box mit mehreren Tasks verknüpft (z.B. DAC's mit NC und Datenbytes mit SPS), so wird das Datentelegramm nur für die höherpriore Task erzeugt. Dies ist insbesondere während der Inbetriebnahme zu beachten, wenn z.B. nur die SPS läuft.

Kontextmenü

Box Einfügen...

Fügt eine weitere Box oberhalb der markierten ein.

Box Löschen... <Entf>

Löscht die momentan markierte Box und deren Unterelemente aus der E/A Konfiguration.

Box Importieren...

Fügt eine Box oberhalb der markierten ein. Die Beschreibung der neuen Box und deren Unterelemente wird aus einer Datei mit der Endung "*.tce" gelesen. Diese Datei wird mit dem folgenden Menüpunkt erzeugt.

Box Exportieren...

Exportiert die Informationen der momentan selektierten Box und die Informationen deren Unterelemente in eine Datei mit der Endung "*.ioe".

Variablen

Es werden vier 16-Bit Ausgangsvariablen mit den Bezeichnungen DAC 1 bis DAC 4 angelegt und können verknüpft werden. Die beiden Datenbytes werden entsprechend ihrer Zugehörigkeit unter Eingängen und/oder unter Ausgängen angeordnet. Die Zugehörigkeit wird im Karteireiter "Daten Bytes" angegeben. Die Datenbytes sind sowohl byte- als auch bitweise anzusprechen.

Karteireiter "DAC's"

Die Verknüpfung der einzelnen Variablen kann über die Karteikartenreiter "DAC's" und "Daten Bytes" übersichtlich für alle Variablen erfolgen. Natürlich bleibt die Möglichkeit erhalten, die Verknüpfung über das Kontextmenü oder die Karteiansicht der jeweiligen Variablen durchzuführen.

DAC 1...: Öffnet den Verknüpfungsdialog für den ersten analogen Ausgangskanal.

DAC 2...: dito...

Karteireiter "Daten Bytes"

D 2...: Öffnet den Verknüpfungsdialog für das erste Datenbyte (D2 im Telegramm).

Eingang / Ausgang: Bestimmt ob das Datenbyte als Ein- oder Ausgang behandelt wird (muss der Hardwareeinstellung entsprechen).

byteweise / bitweise: Bestimmt ob der Verknüpfungsdialog für das gesamte Byte oder für einzelne Bits geöffnet wird.


M3000

Der M3000 Absolut-Encoder hat eine integrierte Beckhoff Lightbus - Schnittstelle und ermöglicht eine ausfallsichere Wegerfassung mit einem Messumfang von 24-Bit.

Variablen

Variable | Datentyp | Beschreibung
Value | UINT24 | Diese 24-Bit breite Eingangsvariable enthält den aktuell erfassten Positions-Istwert des Encoders.
Data3 | USINT | Diese Eingangsvariable ist ein Füll-Byte. Dies wird benötigt, da Value sinnvollerweise ein 24-Bit Variable ist, Lightbus-Module aber jeweils ein 32-Bit Interface für die Ein- und Ausgangsrichtung besitzen. Daher wird Data3 auch standardmässig mitgemappt wenn der Encoder zu einer NC-Achse verbunden wird.
Data | ARRAY [0..3] OF USINT | Die Datenbytes dieses Arrays sind Ausgangsvariablen* zum Encoder. * Die Verwendung dieser Bytes ist ausschliesslich für den Programmierbetrieb des Encoders vorgesehen (wird unter TwinCAT nicht benötigt!).

TwinCAT NC Encoder

Wenn man im NC-Bereich des System Managers eine Achse einrichtet und dabei den Encoder-Typ festlegt, kann man für den M3000 die folgende Auswahl treffen (manipuliert den Wert 'Geber Maske (Maximalwert des Gebers)' im Dialog 'Global', welcher weiter unten dargestellt wird):
Encoder-Typ | TwinCAT NC Einstelldialog | Beschreibung
Encoder an M3000 (24bit Multi-Turn) | Achse x_Enc | 'NC-Encoder' | Wurde dieser Encoder-Typ in TwinCAT NC ausgewählt und zum M3000 Encoder gemappt, interpretiert die NC das von Value erhaltene Bitmuster als 24bit Multi-Turn Wert.
Encoder an M3000 (25bit Multi-Turn) | Achse x_Enc | 'NC-Encoder' | Wurde dieser Encoder-Typ in TwinCAT NC ausgewählt und zum M3000 Encoder gemappt, interpretiert die NC das von Value erhaltene Bitmuster als 25bit Multi-Turn Wert.
Encoder an M3000 (12bit Single-Turn) | Achse x_Enc | 'NC-Encoder' | Wurde dieser Encoder-Typ in TwinCAT NC ausgewählt und zum M3000 Encoder gemappt, interpretiert die NC das von Value erhaltene Bitmuster als 12bit Single-Turn Wert.
Encoder an M3000 (13bit Single-Turn) | Achse x_Enc | 'NC-Encoder' | Wurde dieser Encoder-Typ in TwinCAT NC ausgewählt und zum M3000 Encoder gemappt, interpretiert die NC das von Value erhaltene Bitmuster als 13bit Single-Turn Wert.

Bei einem eventuellen Austausch des Encoders ist es wichtig, die Zählrichtung und den Startwert des Encoders anzupassen. Dies geschieht mit den im Achsinterface ( 'Axis x_Enc') auf dem Reiter 'Global' verfügbaren Parametern:

- 'Nullpunktverschiebung/Positionsoffset' bzw.

- 'Geberzählrichtung invers (Polarität)'

Im Betrieb sollten sich die Geberwerte innerhalb des möglichen Verfahrweges unbedingt zwischen dem minimalen Wert (0) und dem maximalen Zählwert bewegen.

TwinCAT NC - Encoder 'Global'

Der entsprechende Dialog für die mögliche Anpassung von 'Nullpunktverschiebung/Positionsoffset' und 'Geberzählrichtung invers (Polarität)' wird nachfolgend gezeigt.

Die folgende Betriebsart wird nur der Vollständigkeit halber erwähnt, da sie eigentlich beim Einsatz von TwinCAT nicht benötigt wird.

Der M3000 Absolut-Encoder ist über den LWL programmierbar, welches somit auch über das SPS-Anwendungsprogramm geschehen kann. Die programmierten Einstellungen werden innerhalb des Encoders gespeichert.

Sollte dieser Programmiermodus wider Erwarten in TwinCAT genutzt werden, muß die NC gestoppt werden solange der Programmierbetrieb aktiv ist!

Programmierbetrieb:

Im Programmiermodus sind sowohl die Ausgangs- als auch die Eingangsvariablen/-bytes aktiv.

Die Funktion der 4 Ein-/ bzw. Ausgansbytes des 32-Bit Moduls teilt sich wie folgt auf:

Data[0] = Gewünschter Datenwert zur Übertragung zum Encoder (Ausgang)

Data[1] = Status-Bits (Quittung) der Programmierung/Datenübertragung vom Encoder (Eingang, Value) mit folgender Bedeutung:

Bit 0: = Rückmeldung für Umschaltung Programmierbetrieb

Bit 1: Nicht belegt

Bit 2: = Quittierung Übertragungsblock Ok., Daten übernommen

Bit 3: = Quittierung Übernahme Datenbyte

Bit 4 -7: Nicht belegt

Data[2] = Datenrückmeldung (geschriebener Datenwert) vom Encoder (Eingang, Value). D.h., die von Data[0] empfangenen Daten werden zurückgesendet.

Data[3] = Control-Bits im Programmierbetrieb (Ausgang). Diese Bits steuern die Programmierfunktionen des Encoders und damit das Handshake-Protokoll. Das Byte wird im Eingangsbereich unter Data3 gespiegelt.

Die entsprechende Bitbelegung teilt sich wie folgt auf:

Bit 0: '0' = Geberbetrieb, '1' = Programierbetrieb (Betriebsart)

Bit 1: = Preset 1 Übernahmeanweisung an den Encoder

Bit 2: = Preset 2 Übernahmeanweisung an den Encoder

Bit 3: = Strobe-Bit für Übergabe Datenbyte

Bit 4-6: Nicht belegt

Sonderfunktion Bit 7: Freigabe Latch-Funktion.

Eine genauere Beschreibung finden Sie im Handbuch des M3000 Encoders, zu finden u.a. im Download-Bereich unter www.beckhoff.com.


M3120

Die M3120 ist eine bis zu vier kanalige Inkremental-Encoder Box. Sie wird in vier verschiedenen Versionen ausgeliefert, mit einem, zwei, drei und vier Kanälen. Beim Einfügen der Box ist die richtige Version auszuwählen, da jeder Kanal sich logisch als einzelne Box darstellt und daher bei einer Fehleingabe die Gesamtzahl der Boxen differiert.

Die Kanäle der M3120 sind mit INC 4, INC 3, INC 2 und INC 1 bezeichnet, diese Bezeichnungen entsprechen der Beschriftung auf der Box!

Variablen

Jeder Kanal der M3120 besitzt vier Variablen, zwei Eingangs- und zwei Ausgangsvariablen:

  1. Statusbyte (8 Bit Eingangsvariable), zeigt den Status des jeweiligen Kanals an.
  2. Wert (24 Bit Eingangsvariable), liefert den momentanen Zählerstand bzw. den Latchwert .
  3. Kontrollbyte (8 Bit Ausgangsvariable), ermöglicht u.a. das Umschalten zwischen Zähl- und Latchwert.
  4. Setzwert (24 Bit Ausgangsvariable), zum Setzen des Zählwertes.

Eine genauere Beschreibung finden Sie im Handbuch der M3120


Fox20

Das Fox-20 Modul besitzt vier Steckplätze, die digitale und analoge Submodule aufnehmen können (der erste Steckplatz kann nur analoge Submodule aufnehmen).

Variablen

Im Baum werden alle möglichen Variablen angezeigt. Je nach Bestückung des Fox-20 Moduls müssen/können die Variablen verknüft werden. Ist ein Steckplatz mit einem analogen Submodul bestückt, können die Wort-Variablen Modx_Chny jeweils im Eingangs- und/oder Ausgangsbereich verknüft werden. Wobei x für den Steckplatz des Submoduls und y für den Kanal des jeweiligen Steckplatzes steht.

Bei digitalen Submodulen (nur ein Kanal möglich) müssen die Bit-Variablen unterhalb der Modx_Chn1 Variablen verknüpft werden.

Der TwinCAT System Manager erkennt anhand der Verknüpungen ob er LWL-Telegramme für ein digitales oder ein analoges Submodul erzeugt.


Fox50

Das Fox-50 Modul ist ein zweikanaliges SSI-Gerber-Interface.

Variablen

Im Baum werden je Kanal ein Status-Byte und ein 24-bit Wert eingefügt, diese können manuell oder aus der NC-Konfiguration (Enkoder-Typ FOX50) verknüpft werden.


FoxRk001/002

Das Fox-Rk001 und Fox-Rk002 Modul sind Koppelmodule, die den LWL-Ring mit einem anderen LWL-Ring (Rk001) oder mit einem Profibus (Rk002) koppeln.

Variablen

(RK001 mit je 4 Wörtern)

Beim Einfügen der Module erfolgt eine Abfrage der gewünschten Anzahl von Eingangs- und Ausgangswörtern (maximal 254 Rk001 bzw. 16 Rk002).

Die angegebene Anzahl Variablen werden im Baum erzeugt.

Bei dem Rk001-Modul wird zusätzlich noch je ein IdentNo-Wort im Eingangs- und Ausgangsbereich angefügt, das mit dem Wort 0xFE im Modul ausgetauscht wird.


AX2xxx-B200 Drive

Der Beckhoff AX2000 und AX2500 Antriebsverstärker wird mit verschiedenen (im Fall AX2000 optionalen) Feldbusschnittstellen ausgeliefert. Nachfolgend werden die Einstelldialoge für den AX2000 mit Beckhoff Lightbus Interface (z.B. Bestellbezeichnung: AX2003-B200) beschrieben. Diese sind identisch mit denen für den AX2500 Antriebsverstärker, da der AX2500 Software-seitig kompatibel zum AX2000 ist.

"AX2000" Tab

State: Hier kann die Eingangs-Variable "State" des AX2xxx-B200 Servoverstärkers mit einer Variable eines anderen Prozessabbildes (z.B. des Prozessabbildes der SPS) verknüpft werden.

K-Bus Update: Stellt die errechnete Zeit für das Update der optional am Antrieb anschließbaren Busklemmen dar.

Firmware Update: Hiermit ist es möglich, den Firmware-Stand der Lightbus-Anschaltung im AX2xxx Antrieb über die serielle Schnittstelle des PCs zu erneuern.

Firmware Version: Nach Betätigung dieser Schaltfläche, wird im Feld rechts daneben der Firmware-Stand der Lightbus-Anschaltung dargestellt.

2 Byte PLC Interface: Bei aktivierter Checkbox werden unterhalb der Ein- und Ausgangsvariablen des Antriebs die Variablen für das SPS-Interface eingeblendet.

Check Terminals at Startup: Überprüft während der Initialisierungsphase, ob alle konfigurierten Klemmen auch physikalisch vorhanden sind (diese Funktion hat bei Antrieben ohne K-Bus Erweiterung keine Bewandnis).

Check State while Online: Überprüft bei aktivierter Checkbox den Zustand der Status-Variable der Lightbus-Anschaltung im AX2xxx Antrieb. Bei auftretendem Fehler wird eine Meldung in der Logger-Ansicht des System Managers angezeigt.

Show Message Box on Error: Gibt im Fehlerfall zusätzlich zur Meldung in der Logger-Ansicht eine Messagebox aus

Generate own K-Bus update: Aktivierung des K-Bus Zyklusses bei Erhalt des 0x30 Telegramms falls die Lightbuskarte kein Broadcast-Telegramm sendet. Checkbox ist default-mäßig aktiviert beim AX2xxx Antrieb.

After own data: Das Update erfolgt direkt nach dem Übertragen der eigenen Daten.

After all data: Das Update erfolgt nachdem alle Daten der aktuellen CDL übertragen worden sind.

Variable I/O Data: Ab der Firmwareversion 'B5' der Lightbus-Anschaltung im AX2000 Antrieb, kann der Aufbau des Lightbus-Telegramms zum Antrieb optimiert werden (beim AX2500 Antrieb bei allen Firmware-Versionen möglich). Hierfür muß diese und die folgende Checkbox aktiviert werden. Aus Kompatibilitätsgründen wird die Checkbox "Variable I/O Data" beim An-/Einfügen des AX2xxx Antriebs in die Konfiguration nicht aktiviert. Bezgl. der bei Aktivierung erscheinenden Dialoge Eingänge und Ausgänge, siehe unten...

Optimized Telegram Count: Siehe: Variable I/O Data.

Save Configuration to Flash: Bei aktivierter Checkbox wird bei jedem TwinCAT-Start die Konfiguration (bei Änderung eines Parameters) in den Flash-Speicher des Antriebs geschrieben (nur wenn sich mindestens ein Patrameter geändert hat)

Reset Config and Clear Flash: Der Flash-Speicher des Antriebs kann durch Betätigung dieser Taste urgelöscht werden.

Dialog "ADS/AMS"

Für weiterführende Informationen hierzu, siehe: " ADS/AMS-Einstellungen bei E/A-Geräten".

Dialog "Online"

Für weiterführende Informationen hierzu, siehe: "AX2xxx Dialog - Online".

Dialog "Eingänge"

Für weiterführende Informationen hierzu, siehe: "AX2xxx Dialog - Eingänge"

Dialog "Ausgänge"

Für weiterführende Informationen hierzu, siehe: "AX2xxx Dialog - Ausgänge"

Diagnose Eingänge (optional)

Falls die Variablen DriveError, DriveState (alternativ DriveState2 und DriveState3) durch Aktivierung von Variable I/O Data hinzugefügt wurden, können diese zu Diagnosezwecken verwendet werden (z.B. per Mapping zum SPS-Prozessabbild um sie dort zu evaluieren).

Für weitere Informationen zu den Status-, Fehler- und Warnmeldungen des AX2xxx Antriebs, siehe: "AX2xxxx - Warnmeldungen und Fehlercodes".


AX2xxx Dialog - Eingänge

Dialog "Eingänge"

Falls im Dialog "AX2000" die Option Variable I/O Data angewählt ist, erscheinen zusätzlich die Dialoge "Eingänge" sowie "Ausgänge". Im Bereich "Eingänge" können die gewünschten Eingangsvariablen, welche nachher im Eingangsbereich des Antriebs in der Baumansicht erscheinen sollen, manuell hinzugefügt oder auch herausgenommen werden.

Anfügen: Ruft nachfolgend beschriebenen Dialog zur Auswahl der Variable inklusive Datentyp auf, und fügt die Variable im Eingangsbereich des Antriebs ans Ende an.

Einfügen: Ruft nachfolgend beschriebenen Dialog auf und fügt die Variable im Eingangsbereich des Antriebs an bestimmter Stelle ein.

Löschen: Löscht die, im nachfolgend beschriebenen Dialog ausgewählte, Variable aus der Baumansicht des Antriebs-Eingangsbereichs (und damit aus dem Lightbus-Telegramm).

Bearbeiten: Ermöglicht ein Editieren des Variablennamens im nachfolgenden Dialog.

Offs (Byte): Automatisch vergebener Offset der Variable im Telegramm des Antriebs.

(Bit): Bit-Offset der Variable.

Swap Word: Aktiviert den Tausch der beiden Wörter in den 32Bit-Telegrammen zur Bereitstellung im Prozessabbild (default-mäßig aktiviert).

Bit Addr: Bestimmt die Bitadresse einer Variablen für das automatische Ausmaskieren.

Name: Gibt den Namen der selektierten Variable an.

OK: Führt die Änderung des Telegramms aus.

Cancel: Schließt den Dialog ohne das Telegramm zu beeinflussen.

Wichtig: Sollten die hinzugefügten Variablen mit einen nicht NC-SAF_Task verknüpft werden, so ist diese Task mit einer geringeren Priorität (Prioritätszahl größer) zu betreiben.

Liste der Eingangsvariablen.

Name | DatenType/Wertebereich | Beschreibung
DriveError | UDINT | Siehe DriveError
ActualTorque | ARRAY 0..1 of UINT16 0..3280 -> 0..IPEAK | Aktueller Strom / Moment des AX2000-B200 oder B900. Der angegebene Wert bezieht sich auf den eingestellten Spitzenstrom des Stromreglers. ASCII-Komando IPEAK. Errechnung des Momentes durch Multiplikation mit der Drehmomentkonstante des eingesetzten Motors.
ActualVelo | UDINT / u/min * 139,8 | Aktuelle Geschwindigkeit
ActualPos | UINT16 / 0..FFFF | Aktuelle Position. Über ein Hardwarezähler 16 Bit bei OPMODE = 0.
DriveState | UDINT | Siehe DriveState
DriveStateErrBit | BIT DriveState.7 | Antriebsfehler
DriveStateAmplEnableBit | BIT DriveState.6 | Endstufe freigegeben
DriveStateInitReadyBit | BIT DriveState.2 | Betriebsbereit
ActualPosEx | UDINT | Enthält den Positionswert eines im Motor eingebauten Absolutwertgebers (z. B. EnDAT, Hiperface). Abhängig von dem Parameter PRBASE
PulseConnect | UINT16 | Unbehandelte Istposition in Inkrementen ohne SI -Einheiten
LatchPos | UINT16 | Gelatchte Position
LatchValid | Byte | Latch aufgetreten
LatchPosValidBit | LatchValid.0 | Positiver Latch aufgetreten
LatchNegValidBit | LatchValid.1 | Negativer Latch aufgetreten
DigInputBit n | BIT | Digitaler Eingang 1,2,3,4
AnaInput n | UINT16 / 10V -> 404 Dig | Monitor Ausgang
Button n | BYTE | Anzeige der Taster unter der 7-Segmentanzeige

Liste der Ausgangsvariablen.

Name | DatenType/Wertebereich | Beschreibung
DriveCtrl 0..3 | UDINT | Regler Controlbytes
DriveCtrlEnable | DriveCtrl1.0 | 1-> Endstufe Enabled 0-> Endstufe Disabled. Eine negative Flanke dieses Bits 0 erzeugt auf dem Regler ein Reset.
DriveCtrlDigCurrent | DriveCtrl0.1 |
DriveCtrlEnableLatchPos | DriveCtrl3.0 | Freigabe positiver Latch
DriveCtrlEnableLatchNeg | DriveCtrl3.1 | Freigabe negativer Latch
NominalTorque | UDINT | Vorgabe des Stromsollwertes bei der digitalen Drehmomentschnittstelle (OPMODE 2)
NominalVelo24 | UINT24 / u/min * 139,8 | Sollgeschwindigkeit optimiert auf 24 Bit
NominalPos | UDINT | Sollposition. Abhängig von der Einstellung des Parameters PRBASE
CurrentLimiting | UINT16 | Vorgabe des Sollstroms bei der digitalen Drehzahl Schnittstelle (OPMODE 1) als Nebenbetriebsart
DigOutputBit 1& 2 | BIT | Digitale Monitor Ausgänge
AnaOutput 1 & 2 | UINT16 / 1,25mV/dig | Analoger Monitor Ausgänge
NullImpulse | BIT | Nulldurchgang des Resolvers
LED-Control | BYTE | Wird hier ein Wert ungleich Null eingetragen ist die Schnittstelle zur 7-Segmentanzeige aktiv.
LEDs 1,2,3 | BIT | Wert für die drei 7-Segmentanzeigen


AX2xxx Dialog - Ausgänge

Dialog "Ausgänge"

Dieser Karteireiter ist für ähnliche Aufgaben wie der Karteireiter "Eingänge" vorgesehen, allerdings werden hier stattdessen Ausgangsvariablen zum AX2xxx Antriebstelegramm hinzugefügt oder herausgenommen.

Weiterführende Informationen zur Vorgehensweise, sind zu finden unter: AX2xxx Dialog - Eingänge.


AX2xxx Dialog - Online

Dialog "Online" des AX2000-B200

Dialog "Online" des AX2000-B900

Hier werden die ASCII Objekte des AX2xxx Antriebsverstärkers aufgelistet und mit den jeweils aktuellen Werten dargestellt. Die Werte wurden in dem Moment gelesen, als der Dialog "Online" angewählt wurde (siehe dazu auch Refresh ).

Refresh: Eine Betätigung der Schaltfläche aktualisiert die Werte innerhalb der Anzeige.

Drive to Disk: Speichert die Parameter mit den aktuell angezeigten Werten im ASCII-Format (Dateiendung *.axp) auf einem Datenträger.

Disk to Drive: Lädt die Werte der Parameter einer vorher gespeicherten *.axp-Datei in den AX2xxx Antrieb.

CLRFAULT: Ruft das Kommando zum Löschen bestimmter Antriebsfehlers auf (siehe dazu auch AX2xxx Dokumentation, ausgeliefert auf der "Beckhoff Drive Technology" CD).

COLDSTART: Ruft das Kommando zum erneuten Initialisieren des Antriebs (der Firmware) auf. Aktuelle Fehler werden hierbei gelöscht.

SAVE (EEPROM): Speichert die herunter geschriebenen Parameter in das EEPROM des Antriebs, so dass sie auch nach einem Kaltstart des Verstärkers wirksam sind.

Send String: Sendet ein einzelnes Kommando (eingegeben in dem Feld rechts neben der Schaltfläche) mit Parameteranfrage zum Antrieb. Der erhaltene Wert wird zusammen mit dem Parameter in einer Messagebox angezeigt.

Beispiel:

Mit Eingabe der Zeichenkette FW wird der aktuellen AX2xxx Firmware-Stand gelesen.

Beispiel.

Eine Eingabe der Zeichenkette In3mode 2 verändert die Funktion des dritten digitalen Eingags (PSTOP).


AX2xxx - Warnmeldungen und Fehlercodes

Bei AX2xxx-B200 Antriebsverstärkern werden die Variablen DriveError, DriveState und Status per Variable I/O Data zugefügt.
Bei AX2xxx-B900 Antriebsverstärkern sind die Variablen DriveState2 und DriveState3 per Voreinstellung unterhalb "Eingänge" konfiguriert, die DriveError -Variablen müssen bei Bedarf manuell zugefügt werden. Für weiterführende Informationen siehe: AX2xxx Dialog - Eingänge.

Diese Eingansvariablen können zu Diagnosezwecken genutzt werden (wenn sie z.B. mit einem TwinCAT PLC Prozessabbild verlinkt werden, können sie innerhalb der SPS diagnostiziert werden).

Zusätzlich werden die Fehlercodes und Warnmeldungen in jedem Fall in der 7-Segmentanzeige des AX2xxx angezeigt (siehe Spalte: "Anzeige Display").

Folgende Warnmeldungen und Fehlercodes können auftreten:

Variable | Datentyp | Wert | Anzeige Display | Beschreibung
DriveError (kann auch Byteweise mit mit Hilfe der Variablen DriveError0, DriveError1, DriveError2 und DriveError3 gemappt werden) Das equivalente serielle Kommando ist: ERRCODE * bzw. ERRCODE" | UINT32 | 0x00000001 | F01 | Fehler Kühlkörpertemperatur wird gesetzt, sobald die aktuelle Kühlkörpertemperatur (TEMPH) den maximal zulässigen Wert (MAXTEMPH) überschreitet.
 |  | 0x00000002 | F02 | Fehler Überspannung wird gesetzt, sobald die Zwischenkreisspannung den max. zulässigen Wert (VBUSMAX) überschreitet
 |  | 0x00000004 | F03 | Schleppfehler wird bei Ausführung der externen Trajektorie gesetzt, sobald die Geschwindigkeit, die über die externe Trajektorie(OPMODE=6/SERCOS) vorgegeben wird, die max. Drehzahl (VLIM / VLIMN) überschreitet.
 |  | 0x00000008 | F04 | Feedback-Fehler (Resolver) wird gesetzt, wenn die Amplitude der Resolver/Encoder-Signale den minimalen Grenzwert unterschreitet.
 |  | 0x00000010 | F05 | Fehler Unterspannung wird gesetzt, sobald die Zwischenkreisspannung den min. zulässigen Wert (VBUSMIN) unterschreitet
 |  | 0x00000020 | F06 | Fehler Motortemperatur wird gesetzt, sobald der Widerstand des Motortemperaturfühlers (TEMPM) den maximal zulässigen Wert (MAXTEMPM) überschreitet
 |  | 0x00000040 | F07 | Interne Versorgungsspannung fehlerhaft.
 |  | 0x00000080 | F08 | Fehler Überdrehzahl wird gemeldet, wenn die aktuelle Motordrehzahl (V) den max. zulässigen Wert (VOSPD) überschreitet.
 |  | 0x00000100 | F09 | Fehler EEPROM wird gesetzt, wenn beim Lesen/Schreiben des seriellen EEPROM's ein Fehler aufgetreten ist. Dieser Fehler wird entweder durch ein fehlerhaftes EEPROM oder durch eine fehlerhafte Daten-Checksumme hervorgerufen. Im zweiten Fall kann der Fehler durch erneutes Abspeichern der Daten beseitigt werden.
 |  | 0x00000200 | F10 | Reserve
 |  | 0x00000400 | F11 | Fehler Bremse wird gesetzt, wenn der Bremseingang einen Fehler meldet (z.B. Bremse nicht angeschlossen).
 |  | 0x00000800 | F12 | Reserve
 |  | 0x00001000 | F13 | Fehler Umgebungstemperatur wird gesetzt, sobald die aktuelle Umgebungstemperatur (TEMPE) den maximal zulässigen Wert (MAXTEMPE) überschreitet.
 |  | 0x00002000 | F14 | Fehler Endstufe Es sind folgende Ursachen möglich: Erdschluss, Motorkurzschluss oder Ballastkurzschluss.
 |  | 0x00004000 | F15 | Fehler I2Tmax überschritten wird gesetzt, wenn I2T 115 % (bei FOLDMODE=0) bzw. 105 % (bei FOLDMODE=1) erreicht hat.
 |  | 0x00008000 | F16 | Kein Netz-BTB Hinweise zur Betriebsbereit-Meldung sind der detaillierten AX2xxx Dokumentation zu entnehmen.
 |  | 0x00010000 | F17 | Fehler A/D-Wandler wird gesetzt, wenn beim Einschalten des Verstärkers zu große Stromoffsetwerte gemessen werden.
 |  | 0x00020000 | F18 | Ballast-Fehler wird bei defektem Ballasttransistor bzw. bei Vorwahl "Ballastwiderstand extern" und Anschluss des internen Ballastwiderstandes gesetzt.
 |  | 0x00040000 | F19 | Fehlende Netzphase bei PMODE=2.
 |  | 0x00080000 | F20 | Slot-Error Diese Fehlermeldung wird generiert, wenn bei vorhandener Slot-Erweiterungskarte (z.B. AX2xxx-B200) ein Fehler erkannt wurde. Die mögliche Fehlerursache hängt von der Art der Slot-Erweiterungskarte ab. In der Regel weist diese Fehlermeldung auf einen Hardwaredefekt der Erweiterungskarte hin.
 |  | 0x00100000 | F21 | PROFIBUS Handling Error Fehler kann nur bei Verwendung einer PROFIBUS-Erweiterungskarte auftreten (Bestellnummer: AX2xxx-B310).
 |  | 0x00200000 | F22 | Erdschluß
 |  | 0x00400000 | F23 | Fehler in der CAN Kommunikation Die Fehlermeldung BUSOFF wird direkt von der Schicht 2 (CAN Controller) generiert.
 |  | 0x00800000 | F24 | Fehler Watchdog zugeschlagen Dieser Fehler wird ausgegeben, wenn die in EXTWD eingestellte Watchdog-Zeit überschritten wurde, d.h. wenn in der eingestellten Zeit vom Feldbus kein Prozeßdaten-Update erfolgt ist.
 |  | 0x01000000 | F25 | Fehler in der Kommutierung Bei dieser Fehlermeldung hat der Motor ein Problem mit der Kommutierung (er geht durch). Der Grenzwert der Kommutierungsüberwachung wird unter VCOMM in der Einheit UPM (Umdrehung pro Minute) angegeben.
 |  | 0x02000000 | F26 | Fehler bei Referenzfahrt (Hardware-Endschalter) ist definiert durch REFLS.
 |  | 0x04000000 | F27 | Fehler AS-Option Diese Fehlermeldung wird generiert, wenn bei Aktivierung der Anlaufsperren-Option (Bestellnummer: AX20xx-yyyy-0001) die Endstufe freigegeben war.
 |  | 0x08000000 | F28 | Fehler "externe Trajektorie" wird generiert, wenn der Sollwertsprung bei der externen Positions-Trajektorie den maximal zulässigen Wert überschreitet.
 |  | 0x10000000 | F29 | Sercos-Fehler
 |  | 0x20000000 | F30 | SERCOS NotStop Time-out
 |  | 0x40000000 | F31 | Reserve
 |  | 0x80000000 | F32 | Systemfehler zeigt einen internen Fehler an. Dieser Fehler wird beim Einschalten des Verstärkers generiert, wenn die Systemüberprüfung während der Initialisierungsphase nicht erfolgreich abgeschlossen werden konnte. Detaillierte Hinweise hierzu sind der detaillierten AX2xxx Dokumentation zu entnehmen.
DriveState (kann auch Byteweise mit mit Hilfe der Variablen DriveState0, DriveState1, DriveState2 und DriveState3 gemappt werden) Das equivalente serielle Kommando ist: DRVSTAT | UINT32 | 0x00000001 | n01 | I2T-Meldeschwelle überschritten wird gesetzt, wenn I2T die eingestellte Schwelle I2TLIM überschreitet.
 |  | 0x00000002 | n02 | Ballast-Meldung wird gesetzt, wenn die die aktuelle Ballastleistung die Schwelle PBALMAX überschreitet. Sie wird gelöscht, sobald PBALMAX unterschritten wird.
 |  | 0x00000004 | n03 | Meldung Schleppfehler wird gesetzt, sobald der Abstand zwischen der Ist-Position und der Lagereglertrajektorie den eingestellten Wert PEMAX überschreitet. Sie wird gelöscht mit dem Kommando CLRFAULT.
 |  | 0x00000008 | n04 | Meldung Ansprechüberwachung aktiv (Watchdog) wird gesetzt, wenn die Bus/Slot-Ansprechüberwachungszeit EXTWD überschritten wurde.
 |  | 0x00000010 | n05 | Meldung Netzphase fehlt wird gesetzt, sobald das Fehlen einer der 3 Netzphasen festgestellt wird.
 |  | 0x00000020 | n06 | Meldung Software-Endschalter 1 unterschritten wird gesetzt, sobald die eingestellte Position des Software-Endschalters SWE1 unterschritten wird. Sie wird auch gesetzt, sobald ein Fahrauftrag gestartet wird, dessen Zielposition unterhalb des im Antrieb hinterlegten SWE1 Wertes liegt. Sie wird gelöscht, sobald SWE1 überschritten und ein positiver Drehzahl-/Geschwindigkeitssollwert vorgegeben wird, bzw. wenn ein Fahrauftrag mit gültigen Positionswerten abgesetzt wird.
 |  | 0x00000040 | n07 | Meldung Software-Endschalter 2 überschritten wird gesetzt, sobald die eingestellte Position des Software-Endschalters SWE2 überschritten wird. Sie wird auch gesetzt, sobald ein Fahrauftrag gestartet wird, dessen Zielposition oberhalb des im Antrieb hinterlegten SWE2 Wertes liegt. Sie wird gelöscht, sobald SWE2 unterschritten und ein negativer Drehzahl-/Geschwindigkeitssollwert vorgegeben wird, bzw. wenn ein Fahrauftrag mit gültigen Positionswerten abgesetzt wird.
 |  | 0x00000080 | n08 | Meldung Fehlerhafter Fahrautrag gestartet wird gesetzt, wenn versucht wird einen nicht vorhandenen (fehlende Checksumme) Fahrauftrag zu starten. Sie wird gelöscht, wenn ein gültiger Fahrsatz gestartet wird.
 |  | 0x00000100 | n09 | Meldung Referenzpunkt nicht gesetzt wird gesetzt, wenn ein Fahrsatz gestartet wird ohne zuvor eine Referenzfahrt durchgeführt zu haben.
 |  | 0x00000200 | n10 | Meldung PSTOP aktiv wird gesetzt, solange der Hardware-Endschalter PSTOP aktiv ist. Sie wird zurückgenommen, sobald der Endschalter frei wird.
 |  | 0x00000400 | n11 | Meldung NSTOP aktiv wird gesetzt, solange der Hardware-Endschalter NSTOP aktiv ist. Sie wird zurückgenommen, sobald der Endschalter frei wird.
 |  | 0x00000800 | n12 | Meldung Default-Motordaten geladen wird beim Einschalten des Verstärkers gesetzt, wenn die Motornummer aus dem seriellen EEPROM und die Motornummer aus dem SINCOS-Geber unterschiedlich ist.
 |  | 0x00001000 | n13 | Slot-Warnung (I/O-Karte) wird gesetzt, beim Auftreten von Fehlern in Zusammenhang mit der optionalen I/O-Interfacekarte zum Starten von fest hinterlegten Fahraufträgen (Bestellnummer: AX2090-I001).
 |  | 0x00002000 | n14 | Ermittlung von MPHASE (FBTYPE=7) wird gesetzt, beim Einschalten des Verstärkers. Wird gelöscht wenn die Endstufe freigegeben wurde und der Wert für MPHASE ermittelt werden konnte.
 |  | 0x00004000 | n15 | Fehlerhafter VCT-Eintrag angewählt wird gesetzt, sobald bei konfigurierter VC-Tabelle ein fehlerhafter VCT-Eintrag angewählt und übernommen werden soll.
 |  | 0x00008000 | n16 | Warnung n17 ... n31 aktiv Steht an, falls eine oder mehrere Warnungen im Bereich n17... n31 aktiv sind.
 |  | 0x00010000 |  | Auftrag aktiv (Lageregelung) wird gesetzt, sobald ein Lagereglerauftrag gestartet wird (Fahrsatz,Tippbetrieb,Referenzfahrt). Wird gelöscht, wenn der Lagereglerauftrag abgeschlossen bzw. abgebrochen wird (STOP).
 |  | 0x00020000 |  | Referenzpunkt gesetzt gesetzt nach einer Referenzfahrt bzw. beim Einsatz eines Absolutwertgebers (Multiturn). Wird gelöscht, beim Einschalten des Verstärkers bzw. beim Starten einer Referenzfahrt
 |  | 0x00040000 |  | Home-Position ist gesetzt, solange der Referenzschalter belegt ist. Wird gelöscht,sobald der Referenzschalter wieder frei ist
 |  | 0x00080000 |  | In-Position wird gesetzt, sobald der Abstand zwischen der Zielposition eines Lagereglerauftrages und der aktuellen Ist-Position kleiner als PEINPOS ist. Wird gelöscht, sobald der Abstand größer als PEINPOS. Die Meldung In-Position wird unterdrückt, wenn in der Zielposition ein Folgefahrsatz gestartet werden soll.
 |  | 0x00100000 |  | Positionslatch erfolgte (positive Flanke) wird gesetzt, wenn eine steigende Flanke an dem als Latch-Eingang konfigurierten INPUT2 (IN2MODE=26) erkannt wird. Wird gelöscht, wenn die gelatchte Position ausgelesen wird ( LATCH16 / LATCH32)
 |  | 0x00200000 |  | Meldung Position 0 wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG2, SWE0, SWE0N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE0, beim Unterschreiten von SWE0, beim Erreichen des Positionsfensters SWE0...SWE0N oder beim Verlassen des Positionsfensters SWE0...SWE0N gesetzt
 |  | 0x00400000 |  | Meldung Position 1 wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG, SWE1, SWE1N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE1, beim Unterschreiten von SWE1, beim Erreichen des Positionsfensters SWE1...SWE1N oder beim Verlassen des Positionsfensters SWE1...SWE1N gesetzt
 |  | 0x00800000 |  | Meldung Position 2 wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG, SWE2, SWE2N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE2, beim Unterschreiten von SWE2, beim Erreichen des Positionsfensters SWE2...SWE2N oder beim Verlassen des Positionsfensters SWE2...SWE2N gesetzt.
 |  | 0x01000000 |  | Meldung Position 3 wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG, SWE3, SWE3N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE3, beim Unterschreiten von SWE3, beim Erreichen des Positionsfensters SWE3...SWE3N oder beim Verlassen des Positionsfensters SWE3...SWE3N gesetzt.
 |  | 0x02000000 |  | Meldung Position 4 wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG, SWE4, SWE4N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE4, beim Unterschreiten von SWE4, beim Erreichen des Positionsfensters SWE4...SWE4N oder beim Verlassen des Positionsfensters SWE4...SWE4N gesetzt.
 |  | 0x04000000 |  | Initialisierung beendet wird gesetzt, nachdem die interne Initialisierung des Verstärkers abgeschlossen ist
 |  | 0x08000000 |  | Meldung Position 5 wird gesetzt, wenn die konfigurierte Bedingung für diese Meldung (SWCNFG2, SWE5, SWE5N) erfüllt ist. Je nach der Konfiguration wird dieses Bit beim Überschreiten von SWE5, beim Unterschreiten von SWE5, beim Erreichen des Positionsfensters SWE5...SWE5N oder beim Verlassen des Positionsfensters SWE5...SWE5N gesetzt
 |  | 0x10000000 |  | Motorstillstand wird gesetzt, wenn die Motordrehzahl die Stillstandschwelle (VEL0) unterschreitet. Wird gelöscht, wenn die Motordrehzahl größer als die Stillstandschwelle VEL0
 |  | 0x20000000 |  | Sicherheitsrelais wird gesetzt, wenn das Sicherheitsrelais (AS-Option, Bestellnummer: AX20xx-yyyy-0001) offen ist. Wird gelöscht, wenn das Sicherheitsrelais wieder geschlossen ist
 |  | 0x40000000 |  | Endstufe freigegeben (!) wird gesetzt, wenn Software- und Hardware-Enable gesetzt sind.
 |  | 0x80000000 |  | Fehler steht an (!) wird gesetzt, wenn der Verstärker gestört wird (Endstufe gesperrt, Fehlernummer Fxx wird auf dem Display angezeigt). Mit dem Kommando ERRCODE kann der Fehler im Klartext ausgegeben werden. Das Bit wird gelöscht, beim Einschalten des Verstärkers bzw. beim Kommando CLRFAULT oder beim Aufruf der Funktion „Fehler löschen“.
State | UINT8 | 0x01 |  | Kommando-Fehler von der AX2xxx-Bx00 Anschaltung.
 |  | 0x02 |  | Fehler in den Eingangsdaten von der AX2xxx-Bx00 Anschaltung.
 |  | 0x04 |  | Fehler in den Ausgangsdaten von der AX2xxx-Bx00 Anschaltung.
 |  | 0x08 |  | Timeout von der AX2xxx-Bx00 Anschaltung.
 |  | 0x10 |  | Fehler K-Bus Reset von der AX2xxx-Bx00 Anschaltung.


ASCII Objektbeschreibung

Der AX2000 und AX2500 Antriebsverstärker enthält eine Vielzahl von ASCII-Objekten um interne Parameter auszulesen oder zu verändern. Auf diese Parameter kann feldbusunabhängig lesend und teilweise auch schreibend mit ASCII-Kommandos zugegriffen werden. Manche Feldbusvarianten nutzen die ASCII-Kommandos auch während der Initialisierungsphase der Achsen durch TwinCAT (z.B. Beckhoff Lightbus, Beckhoff Real-Time Ethernet). Aber nicht alle vorhandenen Kommandos bzw. ASCII-Objekte sind in der Kombination mit TwinCAT - NC / NC-I relevant.
Generell hängt die Unterstützung des jeweiligen Parameters von der Firmware-Revisionsnummer des angeschlossenen Antriebs ab (=> VER)!

Eine Auflistung der unterstützten Kommandos finden sie unter: AX2xxx Referenz - ASCII Objektbeschreibung.

Sollte ein, mit einem ASCII-Objekt vergleichbarer, Parameter auch in der SERCOS-Norm IEC 61491 definiert sein, ist das entsprechende ASCII-Kommando in der AX2xxx-B750 Referenz -Dokumentation innerhalb der Tabelle der jeweiligen IDN vermerkt (beispielsweise: S-0-0030 == VER).


Übersicht

Nachfolgend aufgeführte Geräte mit Profibus Slave-Schnittstelle, werden aktuell von TwinCAT unterstützt.

(Hinweis: Über das ebenfalls aufgeführte "GSD-Gerät" werden selbstverständlich alle Profibus-Geräte, für die eine gültige GSD-Datei vorhanden ist, unterstützt!)

Profibus - Teilnehmer ("Boxen") | Beschreibung | Einschränkungen / Anmerkung
BK3000 | Buskoppler (max. 1,5 MBaud) |
BK3100 | Buskoppler(max. 12 MBaud) |
BK3010 | Economy Buskoppler (max. 1,5 MBaud) |
BK3110 | Economy Buskoppler (max. 12 MBaud) |
BK3120 | "Economy plus" Buskoppler (max. 12 MBaud) |
BK3500 | Buskoppler (LWL, max. 1,5 MBaud) |
BK3520 | "Economy plus" Buskoppler (LWL, max. 12 MBaud) |
LC3100 | Low-cost Buskoppler (max. 12 MBaud) |
BC3100 | Busklemmen Controller mit integrierter SPS (max. 12 MBaud) |
IPxxxx-B310 | Feldbus Kompakt Box: Profibus Ein-/Ausgabebaugruppe in Schutzart IP67 (max. 12 MBaud) |
ILxxxx-B310 | Feldbus Koppler Box: Erweiterbare Ein-/Ausgabebaugruppe in Schutzart IP67 (max. 12 MBaud) |
ILxxxx-C310 | Feldbus SPS Box: Koppler Box mit integrierter SPS in Schutzart IP67 (max. 12 MBaud) |
AX2xxx-B310 | Beckhoff Antriebsverstärker AX2000-B310 oder AX2500-B310 Profibus DP Slave, unterstützt durch spezielle SPS Funktionsbausteine. |
AH200x | Beckhoff AH2001 bzw. AH2003 mit Profibus MC Schnittstelle | Die AH200x Beschreibung befaßt sich ausschliesslich mit Dokumentation der internen E/A-Status- und Control-Informationen. Sie bezieht sich nicht auf die intern verwendeten Regelungsalgorithmen oder die externe PROFIBUS MC Konfiguration für diesen Slave-Typ. Für detaillierte Informationen über den AH2001 / AH2003 und wie er an einer überlagerten TwinCAT Master-Steuerung zu konfigurieren ist, wird auf die BECKHOFF Drive Technology | AH2000 Dokumentation verwiesen. Wird nicht unterstützt von der CP5412-A2 (FC3000) bzw. den CIF Profibus-Karten
Simodrive 611u | Siemens Antriebsverstärker mit Profibus MC Schnittstelle | Wird nicht unterstützt von der CP5412-A2 (FC3000) bzw. den CIF Profibus-Karten
GSD-Gerät | Allgemeines Profibus Gerät (GSD-Datei des Herstellers erforderlich) |


GSD Gerät

Profibusgeräte, die nicht im TwinCAT System Manager bekannt sind, können mit Hilfe ihrer Gerätestammdatendatei (GSD) eingelesen werden. Wenn eine Feldbusbox vom Typ "GSD-Box" eingefügt wird, erscheint ein Datei Öffnen Dialog, in dem die entsprechende GSD-Datei ausgewählt werden muss. Detailliert beschrieben ist das Vorgehen unter Auswahl von GSD- und EDS-Boxen.

Kontextmenü

Modul Anfügen... <Einfg>

Fügt bei modularen GSD-Boxen Ein- bzw. Ausgangsmodule (Variablen) an. Nähere Erläuterungen hierzu findet man unter Modulare Profibus-Geräte.

Box Einfügen...

Fügt eine weitere Box oberhalb der markierten ein.

Box Löschen... <Entf>

Löscht die momentan markierte Box und deren Unterelemente aus der E/A Konfiguration.

Box Importieren...

Fügt eine Box oberhalb der markierten ein. Die Beschreibung der neuen Box und deren Unterelemente wird aus einer Datei mit der Endung "*.tce" gelesen. Diese Datei wird mit dem folgenden Menüpunkt erzeugt.

Box Exportieren...

Exportiert die Informationen der momentan selektierten Box und die Informationen deren Unterelemente in eine Datei mit der Endung "*.tce".

Karteireiter "Profibus"

Stations-Nr.: Jeder Profibusteilnehmer benötigt eine eindeutige Stations-Nr.

Watchdog: Schaltet eine Watchdog-Funktionalität ein. Die Zeitdauer kann bei eingeschalteter Ansprechüberwachung eingestellt werden (in ms). Die Ansprechüberwachungszeit sollte mindestens 6 x größer als die Zykluszeit eingestellt werden, der minimale Wert ist 10 ms.

PrmData: Erlaubt die Profibus-spezifischen Parameterdaten zu editieren (-> Dokumentation der Buskoppler BK3xx0). Die Größe der aktuellen Parameterdaten wird angezeigt. Die PrmData können auch textuell (-> PrmData (Text)) oder teilweise über den Karteireiter "BK3xx0 / BC3x00" eingestellt werden

CfgData: Die aktuellen Konfigurationsdaten (ergeben sich aus den angefügten Klemmen) sowie deren Länge werden angezeigt.

Die Einstellungen DP-Class 1, DP-Class 2, DPV1-Class 2, Set und Reset Slave sind nur bei der FC310x aktiviert (-> PROFIBUS DP-Slaves an FC310x)

Karteireiter "PrmData (Text)"

Durch Anklicken einer Zeile kann der aktuelle Wert verändert werden.

Diagnose

Die Diagnose der PROFIBUS DP-Slaves an der FC310x ist in einem gesonderten Kapitel beschrieben, im Folgenden die Diagnose bei anderen E/A-Geräten beschrieben.

Diagnose Eingänge

Jede Profibus-Slave Box erhält zwei Diagnose-Eingangsbytes, die den Status des jeweiligen Slaves zur Laufzeit signalisieren und z.B. mit der SPS verknüpft werden können:

BoxState

Wert | Beschreibung
0 | No Error
1 | Error - genauere Beschreibung im DpState

DpState

Wert | Beschreibung
0 | No Error - Station ist im Datenaustausch
1 | Station deactivated - Slave wurde deaktiviert, tritt zur Zeit nur temporär beim Hochlauf auf
2 | Station not exists - Slave antwortet nicht am Bus -> Prüfen, ob Slave eingeschaltet, ob PROFIBUS-Stecker angeschlossen, ob Stationsadresse korrekt oder ob Busverkablung korrekt
3 | Master lock - Slave ist mit anderem Master im Datenaustausch -> anderen Master vom Bus nehmen oder Slave mit anderem Master wieder freigeben
4 | Invalid slave response - falsche Antwort des Slaves, tritt temporär auf, wenn Slave aufgrund eines lokalen Ereignisses den Datenaustausch beendet hat
5 | Parameter fault - Parametrierungsfehler -> Prüfen, ob Buskoppler bzw. GSD-Datei korrekt, ob Stationsadresse korrekt oder ob UserPrmData-Einstellungen korrekt
6 | Not supported - DP-Funktion wird nicht unterstützt -> Prüfen, ob GSD-Datei korrekt oder ob Stationsadresse korrekt
7 | Config fault - Konfigurationsfehler -> Prüfen, ob die angefügten Klemmen bzw. Module korrekt sind
8 | Station not ready -> Station im Hochlauf, wird während des Hochlaufs temporär angezeigt
9 | Static diagnosis - Slave meldet statische Diagnose und kann zur Zeit keine gültigen Daten liefern -> Betriebszustand am Slave prüfen

PROFIBUS-Diagnosedaten

Die PROFIBUS-Diagnosedaten, die ein PROFIBUS-Slave sendet, können per ADS von jedem TwinCAT Programm gelesen bzw. an jedes TwinCAT-Programm gemeldet werden. Dabei sind die ADS-Parameter wie folgt einzustellen:

Net-ID: Net-ID des PCs

Port: 300

IndexGroup: 0x5000 + Device-ID

IndexOffset: Hi-Word: Stationsadresse, Lo-Word: 0x100

Länge: 6 - 244

Die Diagnosedaten sind wie in der DP-Norm beschrieben aufgebaut.


Modulare Profibus Geräte

Modulare Profibus Geräte erlauben die Variablen eines Gerätes durch das Auswählen eines oder mehrerer Module zu definieren. Dazu sind in der GSD-Datei des entsprechenden Gerätes Module und deren Ein- und Ausgänge definiert. Beim An- bzw. Einfügen eines Moduls erscheint folgender Dialog:

Variablen

Die Variablen eines Moduls können einen von sechs Typen annehmen:

  1. Byte (8 Bit)
  2. Wort (16 Bit)
  3. Bytefeld (n * 8 Bit)
  4. Wortfeld (n * 16 Bit)
  5. Bytestring (n * 8 Bit, konsistent)
  6. Wortstring (n * 16 Bit, konsistent)

Das Modul kann Ein- und/oder Ausgänge - auch unterschiedlichen Typs - besitzen.


Übersicht

Nachfolgend aufgeführte Geräte mit Interbus Slave-Schnittstelle, werden aktuell von TwinCAT unterstützt:

(Hinweis: Über die ebenfalls aufgeführte "Allg. Interbus Box"", werden selbstverständlich alle Interbus-konformen Slaves mit entsprechenden Einstellungen für Ident.-Code und Längen-Code, unterstützt!)

Interbus - Teilnehmer ("Boxen") | Beschreibung | Einschränkungen / Anmerkung
BK4000 | Standard Buskoppler |
BK4010 | Economy Buskoppler |
BC4020 | "Economy plus" Buskoppler |
BC4000 | Busklemmen Controller mit Interbus Slave-Schnittstelle |
IPxxxx-B400 | Feldbus Kompakt Box: Interbus Ein-/Ausgabebaugruppe in Schutzart IP67 (max. 12 MBaud) |
ILxxxx-B400 | Feldbus Koppler Box: Erweiterbare Ein-/Ausgabebaugruppe in Schutzart IP67 (max. 12 MBaud) |
ILxxxx-C400 | Feldbus SPS Box: Koppler Box mit integrierter SPS in Schutzart IP67 (max. 12 MBaud) | (aktuell noch nicht verfügbar)
Allg. Interbus Box | Allgemeines Interbus Gerät. Es müssen der Ident.-Code und die Längen-Code angegeben werden, bzw. vordefinierte Boxen ausgewählt werden. |


InterBus-S Gerät

InterBus-S Boxen, die nicht im TwinCAT System Manager bekannt sind, können durch die InterBus-S spezifische Eingabe ihres Längen- und Ident-Codes eingefügt werden. Der Längen- und Ident-Code ist dem Handbuch des jeweiligen Gerätes zu entnehmen und ist auch häufig auf dem Gerät selbst vermerkt.

Beim Anfügen einer InterBus-S Box erscheint folgender Dialog:

Kontextmenü

Box Anfügen... <Einfg>

Fügt bei InterBus-S Busklemmen eine Box an den Lokal- oder Fernbus an.

Durch Betätigen des Buttons "Liste..." erscheint eine Liste von gebräuchlichen InterBus-S Boxen, deren Längen- und Ident-Code bekannt sind:

Beim Anfügen einer weiteren InterBus-S Box erscheint folgender Dialog:

Box Einfügen...

Fügt eine weitere Box oberhalb der Markierten ein.

Box Löschen... <Entf>

Löscht die momentan markierte Box und deren Unterelemente aus der E/A Konfiguration.

Box Importieren...

Fügt eine Box oberhalb der Markierten ein. Die Beschreibung der neuen Box und deren Unterelemente wird aus einer Datei mit der Endung "*.tce" gelesen. Diese Datei wird mit dem folgenden Menüpunkt erzeugt.

Box Exportieren...

Exportiert die Informationen der momentan selektierten Box und die Informationen deren Unterelemente in eine Datei mit der Endung "*.tce".

Karteireiter "InterBus-S"

Ident-Code: Zeigt den Ident-Code des Buskopplers an. Er wird dynamisch - in Abhängigkeit der angeschlossenen Klemmen - berechnet.

Längen-Code: Zeigt den Längen-Code des Buskopplers an. Er wird dynamisch - in Abhängigkeit der angeschlossenen Klemmen - berechnet.

Installationstiefe: Zeigt die Installationstiefe des Buskopplers an. Sie wird dynamisch - in Abhängigkeit der hierarchischen Struktur des InterBus-S - berechnet.

Die folgenden Einstellungen sind nur bei der Phoenix IBS ISA ST-I/T möglich.

Gruppe: Ermöglicht die Zuordnung des Teilnehmers zu einer Gruppe (vergl. Interbus Anwenderhandbuch)

Alternative: Ermöglicht die Zuordnung des Teilnehmers zu einer Alternative (vergl. Interbus Anwenderhandbuch)

Datenkonsistenz: Ermöglicht die Erhöhung der Datenkonsistenz für diesen Teilnehmer

Startup: Ermöglicht beim Systemstart ein Control_Active_Configuration Kommando für diesen Teilnehmer auszuführen:

  • Default: Es wird kein Kommando für diesen Teilnehmer ausgeführt
  • Segment Off: Es wird ein Segment_Off ausgeführt
  • Segment On: Es wird ein Segment_On ausgeführt

Karteireiter "CAC/CDF"

Ermöglicht einige Firmwaredienste der Phoenix IBS ISA ST-I/T auszuführen, wenn bei der Masterkarte ein ADS-Port aktiv ist. Vergleiche Interbus Anwenderhandbuch. Zu beachten ist, dass ein Control_Active_Configuration Kommando auch untergeordnete Teilnehmer betrifft!

Diagnose Eingänge

Jede InterBus-S Box erhält ein Diagnose-Eingangsbyte, das den Status des jeweiligen Slaves zur Laufzeit signalisieren und z.B. mit der SPS verknüpft werden kann:
Variable | Wert | Beschreibung
BoxState | 0x01 | Rec: Rekonfiguration
 | 0x02 | Mod: Modulfehler
 | 0x04 | W2Err: Fehler an der W2-Schnittstelle
 | 0x08 | W1Err: Fehler an der W1-Schnittstelle
 | 0x10 | W2: Zustand der W2-Schnittstelle inaktiv
 | 0x20 | W1: Zustand der W1-Schnittstelle inaktiv

PCP - Kommunikation

Einige InterBus-S Geräte können neben dem zyklischen Prozessdatenaustausch auch azyklische Kommunikation mit der Masterkarte durchführen (nicht CIF40-IBSM). Die Kommunikation wird beim InterBus-S PCP-Kommunikation genannt (Peripherals Communication Protocol).

Die Geräte werden an ihrem Identcode erkannt und erhalten einen zusätzlichen Karteireiter:

Durch das "Enablen" der PCP-Kommunikation wird dem Gerät ein AMS-Port zugewiesen, über den per ADS die PCP-Kommunikation abgewickelt wird.

InterBus-seitig erhält die Kommunikationsverbindung zwischen diesem Gerät und der Masterkarte eine Kommunikationsnummer (CR = Communication Reference). Es können zusätzlich ein Passwort und eine Access Gruppe angegeben werden (siehe Beschreibung der PCP-Kommunikation).

PCP-Dienste

Es werden z.Zt. folgende Dienste unterstützt:

  1. Read (0x0081)
  2. Write (0x0082)
  3. Start (0x0083)
  4. Stop (0x0084)
  5. Resume (0x0089)
  6. Reset (0x008A)

Der gewünschte Dienst wird durch die Angabe der o.a. Diensterkennung im HIWORD des ADS-IndexGroup angegeben (vergl. ADS-Dokumentation).

Zur Vereinfachung kann beim Read-Dienst bei einem AdsReadReq und bei einem Write-Dienst und einem AdsWriteReq die Kennung 0 verwendet werden.

Index: Der gewünschte PCP-Index wird im LOWORD des IndexGroup angegeben.

Subindex: Der gewünschte PCP-Subindex wird im IndexOffset angegeben.


Übersicht

Nachfolgend aufgeführte Geräte mit CANopen Slave-Schnittstelle, werden aktuell von TwinCAT unterstützt:

(Hinweis: Über den ebenfalls aufgeführten, allgemeinen "CANopen Node", werden selbstverständlich alle CAN[open]-konformen Slaves mit entsprechenden Einstellungen, unterstützt.)

CANopen - Teilnehmer ("Boxen") | Beschreibung | Einschränkungen / Anmerkung
BK5100 | Buskoppler |
BK5110 | Economy Buskoppler |
BK5120 | Buskoppler (Nachfolger von BK5100) |
LC5100 | Low-cost Buskoppler |
IPxxxx-B510 | Feldbus Kompakt Box: CANopen Ein/Ausgabebaugruppe in Schutzart IP67 |
ILxxxx-B510 | Feldbus Koppler Box: Erweiterbare CANopen Ein/Ausgabebaugruppe in Schutzart IP67 |
AX2000-B510 | Antriebsverstärker AX2000 mit integriertem CANopen Interface (X6) |
CANopen Slave FC510x | Beckhoff Feldbuskarte FC5101 bzw. FC5102 als CANopen Slave-Teilnehmer |
CANopen Node | Allgemeines CANopen Gerät oder allgemeines CAN Gerät (Zugriff über CAN Schicht 2) |


CANopen Gerät

CANopen Geräte, die nicht im TwinCAT System Manager bekannt sind, können durch Anwahl der Box "CANopen Node" ins Netz aufgenommen werden. Für diese Geräte können die CAN(open)-Nachrichten (PDOs) direkt konfiguriert werden. Damit wird die maximale Flexibilität dieser allgemeinen CANopen Schnittstelle gewährleistet.

Bei Verwendung der FC510x können mit Hilfe dieser Box auch beliebige CAN Identifier gesendet und empfangen werden - damit ist die Kommunikation mit beliebigen CAN Knoten möglich. Einzige Voraussetzung ist die Unterstützung mindestens einer der von der FC510x unterstützten Baudraten.

Karteireiter "CAN Node"

Node ID: Hier wird die Knotenadresse des allgemeinen CANopen Gerätes eingestellt. Wenn die Box "Auto Anpassen der PDO COB Ids" angewählt ist, so werden die Default-Identifier der Prozessdatenobjekte bei Änderung der Node-ID entsprechend nachgeführt.

Profile No.: Nach CANopen enthält der Parameter 0x1000 "Device Type" in den beiden niederwertigsten Bytes die Nummer des vom Gerät unterstützten Geräteprofils. Diese wird hier eingetragen und beim Systemstart mit dem im Gerät vorhandenen Parameter verglichen. Falls kein Geräteprofil unterstützt wird, so enthält der Parameter den Wert 0.

Add Info: Die Additional Info steht in den beiden höchstwertigen Bytes des Objektverzeichniseintrages 0x1000 (Device Type).

FC510x: Der Vergleich Soll/Istkonfiguration erfolgt nur, wenn Profile No. oder Add. Info (also Objektverzeichniseintrag 0x1000) auf Wert ungleich null konfiguriert sind. Falls die erwarteten Werte beim Systemstart nicht mit den vorhandenen übereinstimmen, so wird der Start dieses Knotens abgebrochen und eine entsprechende Fehlermeldung im Diag-Reiter angezeigt.

CIFx0-CAN: Die Werte werden stets verglichen (auch wenn in beiden "0" eingetragen ist). Bei fehlender Übereinstimmung Abbruch des Knotenstarts.

Guard Time: Die Guard Time bestimmt das Intervall, in dem der Knoten überwacht wird (Node Guarding). 0 bedeutet keine Überwachung.

Life Time Factor: Guard Time x Life Time Factor bestimmt die Watchdog-Länge für die gegenseitige Überwachung von Karte und CANopen Knoten. 0 bedeutet, dass der CANopen Knoten die Karte nicht überwacht. Bei 0 nimmt die Karte die Guard Time direkt als Watchdog-Länge.

FC510x: Diese Karte unterstützt auch das Heartbeat-Protokoll und versucht zunächst, diese Form der Knotenüberwachung auf dem CANopen-Knoten zu starten (Schreibzugriff auf die Objekte 0x1016 und 0x1017 im Objektverzeichnis). Falls dieser Versuch fehlschlägt, wird Guarding aktiviert. Eingetragen werden die Guard Time als Producer Heartbeat Time und (Guard Time x Life Time Factor) als Consumer Heartbeat Time. Die Karte sendet dann ihr Heartbeat Telegramm mit der kleinsten konfigurierten Guard Time aus (die Guard Times können ja für jeden Knoten individuell eingestellt werden).

Emcy COB Id. und Guard COB Id. sind die Identifier für Emergency Nachrichten bzw. Guarding Protocol. Diese ergeben sich aus der Knotenadresse.

Automatic PDO... Gibt an, ob TwinCAT die PDO-Kommunikationsparameter beim Systemstart zum Knoten downloaden soll.

FC510x: Falls der Download der PDO Parameter fehlschlägt versucht die Karte diese Parameter zu lesen und mit den konfigurierten Werten zu vergleichen. Auf diese Weise werden auch Knoten unterstützt, die z.B. die Default-Identifier als read-only Werte implementiert haben.

CIFx0-CAN: die PDO Parameter werden zwar zu den CANopen Knoten übertragen, es wird aber toleriert, wenn die Knoten diese Einträge nicht unterstützen - erforderlich ist lediglich eine Bestätigung des SDO Zugriffs (ein SDO Abort Response genügt).

Vendor ID, Product Code, Serial Nr., Revision Nr. (nur FC510x): Falls hier Werte ungleich null eingetragen sind, so werden diese Einträge des Indentity Objektes (0x1018 im Objektverzeichnis) beim Systemstart ausgelesen und mit den konfigurierten Werten verglichen. Nur wenn die Werte übereinstimmen, wird der entsprechende Knoten gestartet. Es ist auch möglich, nur einen Teil der Werte (z.B. die Vendor ID und den Product Code) zu vergleichen - dann sind lediglich die nicht gewünschten Parameter auf null zu setzen.

Node-Fehler Reaktion (nur FC510x):

Stop Node: nach einem erkannten Knotenfehler wird der Knoten in den "Stopped" Zustand gesetzt (NMT Kommando "Stop Remote Node"). Damit können die Knoten (je nach Geräteprofil) über die Netzwerkstatusmaschine in einen sicheren Zustand gezwungen werden - ein Ansprechen über SDO ist dann allerdings nicht mehr möglich.

keine Reaktion: kein NMT Stop Remote Node Kommando nach Knotenfehler

Node-Restart(nur FC510x):

Restart automatisch: nach einem erkannten Knotenfehler versucht die Karte automatisch, den Knoten wieder aufzustarten. Der Aufstartversuch wird von einem Reset-Node Kommando eingeleitet.

Restart manuell: Nach Knotenfehler bleibt dieser Knoten im Fehlerzustand und wird nicht automatisch gestartet. Ein Neustart ist über "I/O-Reset" möglich.

Netzwerk Reaktion(nur FC510x):

keine Reaktion: der Ausfall eines Knotens hat keine Auswirkungen auf die anderen Busteilnehmer

Alle Nodes stoppen: Nach Ausfall eines Knotens werden alle anderen zuvor gestarteten Knoten gestoppt (NMT Kommando stop remote node). Ein Neustart des Systems ist dann erforderlich.

Allgemeiner CAN Node (nur FC510x): wenn diese Checkbox angewählt ist, so ist das gesamte CANopen Netzwerkmanagement für diesen Teilnehmer deaktiviert: er wird nicht gestartet, überwacht etc.. Die PDO-Einträge werden als reine CAN (Schicht 2-) Telegramme aufgefasst und ereignisgesteuert der Steuerung zur Verfügung gestellt.

Achtung: da die CANopen Terminologie auch beim allgemeinen CAN Knoten beibehalten wird ist zu berücksichtigen, dass RxPDOs die Telegramme sind, die von der Fc510x gesendet werden und TxPDOs die empfangenen Telegramme sind.

Mit dieser Option lassen sich beliebige CAN Knoten an TwinCAT anbinden, falls die Baudrate und die Bit-Timing Parameter übereinstimmen. Das jeweilige Protokoll kann dann im SPS Programm nachgebildet werden. Es ist auch möglich, CANopen-Teilnehmer und allgemeine CAN Knoten im gleichen Netz zu betreiben - falls es keine Identifier-Überschneidungen gibt (Systembedingt können keine Identifier doppelt verwendet werden).

CANopen PDOs

Prozessdatenobjekte (PDOs) sind CAN-Telegramme, die Prozessdaten ohne Protokoll-Overhead transportieren. RxPDOs werden vom Knoten empfangen, TxPDOs werden vom Knoten gesendet. Diese Bezeichnung wird im System Manager aus Sicht des konfigurierten Knotens beibehalten, d.h. RxPDOs werden von TwinCAT gesendet, TxPDOs werden von TwinCAT empfangen.

Karteireiter "PDO"

COB Id: Der CAN-Identifier dieses PDOs. Für jeweils zwei Sende- und Empfangs-PDOs je Knoten stellt CANopen Default-Identifier zur Verfügung. Diese können dann geändert werden.

Trans.Type: Der Transmission Type bestimmt das Sendeverhalten des PDOs. 255 entspricht dem ereignisgesteuerten Senden.

Inhibit Time: Sendeverzögerung zwischen zwei gleichen PDOs. Wird in Vielfachen von 0,1 ms angegeben.

Length: Die Länge des PDOs ergibt sich aus den gemappten Variablen und kann daher hier nicht editiert werden.

Event Time (nur FC510x): Hier wird der Wert für den Event Timer in ms eingetragen. Bei Sende-PDOs (hier: RxPDOs, siehe oben) löst der Ablauf dieses Timers ein zusätzliches Senden des PDOs aus, bei Empfangs-PDOs (hier: TxPDOs) wird das Eintreffen eines PDOs innerhalb des eingestellten Wertes überwacht und ggf. der Box-State des Knotens verändert. Bei 0 wird der Parameter nicht zum Knoten übertragen.

TwinCAT erzeugt aus den hier eingegebenen Parametern entsprechende Einträge im Objektverzeichnis des Knotens, die beim Systemstart über SDO übertragen werden. Die Einträge können beim Karteireiter SDOs eingesehen werden. Ist dieses Verhalten unerwünscht, so kann es über die Checkbox "Auto-Download der PDO Parameter" beim Karteireiter CAN Node deaktiviert werden.

Baumdarstellung:

TwinCAT sieht für einen allgemeinen CANopen-Knoten zunächst je zwei Sende- und Empfangs-PDOs vor, die mit Default-Identifiern versehen sind. Überzählige PDOs können angewählt und entfernt werden.

TxPDOs werden vom CANopen Knoten gesendet und enthalten im allgemeinen Fall Eingänge. RxPDOs werden vom Knoten empfangen, also von TwinCAT gesendet

Die PDOs werden mit Variablen gefüllt, indem man "Eingänge" bzw. "Ausgänge" mit der rechten Maustaste anklickt und die entsprechende(n) Variablen auswählt. Werden mehrere Variablen des gleichen Typs mit einer Aktion eingefügt, so wird der Offset innerhalb des PDOs automatisch erzeugt. Werden Variablen hintereinander eingefügt, so ist der entsprechende Offset (Start-Adresse innerhalb des CAN-Telegramms) für jede Variable einzustellen.

Achtung: TwinCAT ordnet die PDOs der angezeigten Reihenfolge nach den Objektverzeichniseinträgen im Knoten zu. So werden z.B. die PDO Kommunikationsparameter des dritten aufgelisteten TxPDOs stets auf Index 0x1802 geschrieben - unabhängig von der Bezeichung des PDOs im System Manager. Falls also nur PDO1 und PDO3 verwendet werden sollen, so ist ein PDO2 ebenfalls einzutragen - in diesem Fall ohne das Variablen zugeordnet werden. PDOs ohne Variablen werden nicht gesendet und auch nicht erwartet.

Kontextmenü:

Das nebenstehende Menü erhält man, indem man den allgemeinen CANopen Knoten mit der rechten Maustaste anklickt. Hier können weitere Tx- bzw. Rx-PDOs eingefügt werden.

Karteireiter "SDOs"

Auf dieser Seite werden SDO Einträge angezeigt/verwaltet, die beim Startup zum Knoten geschickt werden. Einträge deren Objekt-Index in spitzen Klammern stehen, sind automatisch aufgrund der aktuellen Klemmenkonfiguration erzeugt worden. Weitere Einträge können über "Anfügen", "Einfügen", Löschen" und "Bearbeiten" verwaltet werden.

Karteireiter "ADS"

Um SDO-Objekte auch zur Laufzeit schreiben und lesen zu können (z.B. aus der SPS heraus), kann dem Knoten (Buskoppler) ein ADS-Port zugewiesen werden (CIFx0-CAN). Die FC510x verfügt stets über einen ADS-Port für jeden Knoten, da die Diagnoseinformationen über ADS transportiert werden. Über diesen können SDO-Objekte per ADS Read Request bzw. Write Request gelesen und geschrieben werden.

Der ADS IndexGroup beinhaltet den CANopen Object Index und der ADS IndexOffset beinhaltet den CANopen SubIndex.

CANopen-Emergency-Objekt

Einige CANopen-Statusdaten sowie bis zu 5 empfangene Emergency-Objekte eines Nodes können per ADS von jedem TwinCAT Programm gelesen bzw. an jedes TwinCAT-Programm gemeldet werden. Dabei sind die ADS-Parameter wie folgt einzustellen:

Port: 300

IndexGroup: 0x5000 + Device-ID

IndexOffset: Hi-Word: Node-ID, Lo-Word: 0x100

Länge: 8 - 48

Die Diagnosedaten sind wie folgt aufgebaut:

Offset: 0: Nodestatus-Bits

Bit 7: Node ist deaktiviert

Bit 3: Guarding-Protokoll ist aktiv

Bit 2: Parametrierfehler

Bit 1: Emergency-Buffer Überlauf

Bit 0: Node antwortet nicht

Offset: 1,2: Node-Type (Index 0x1000)

Offset: 3,4: Profile-Number

Offset: 5: Node-State

1: Disconnecting

2: Connecting

3: Preparing

4: Prepared

5: Operational

127: Pre-Operational

Offset: 6: aktueller Fehler

30: Guarding fehlerhaft

31: Node hat Zustand verändert

32: Sequence-Fehler im Guarding-Protokoll

33: keine Antwort von einer Remote-Frame-PDO

34: keine Antwort während der Konfiguration des Nodes

35: Profilnummer des Nodes stimmt nicht

36: Device Type des Nodes stimmt nicht

37: unbekannte SDO-Response empfangen

38: SDO-Syntax-Fehler

39: Node in STOP-Modus

Offset: 7: Anzahl Emergency-Meldungen

Offset: 8-47: Emergency-Buffer (-> Node-Beschreibung)

Die Daten enthalten den aktuellen Status. Im Emergency-Buffer stehen die zuletzt empfangenen Emergency-Meldungen. Die Nodestatus-Bits sind im Diagnose-Eingang Box-State zusammengefaßt.


CAN Box Reset

Der CAN Box Reset erfolgt in 8 Schritten.

1.Schritt:

Zunächst muss die Box angefügt werden. Dazu wird die Dialogbox unter dem Gerät, hier FC510x (CANopen Master, PCI) geöffnet.

2.Schritt:

Im Dialog 'Anfügen eines Gerätes', wird unter 'Verschiedenes' CANopenNode ausgewählt.

3.Schritt:

Die Box besitzt jeweils 2 Ein- und Ausgänge. Bis auf den Ausgang RxPDO 1 werden alle gelöscht.

4.Schritt:

Im zugehörigen Karteireiter der Box CANopen Node ist folgende Einstellung vorzunehmen:

5.Schrtt:

Im Karteireiter des AusgangsRxPDO 1, ist die COB ID, wie dargestellt, auf Null zu setzen.

6.Schritt:

Durch Öffnen der Dialogbox unter RxPDO 1 'Ausgänge' können weitere Variablen eingefügt werden.

7.Schritt:

Im geöffneten Dialog 'Einfügen von Variablen' sind folgende Einstellungen notwendig:

8.Schritt:

Daraus ergibt sich unter 'Zuordnungen' folgende Darstellung.

Damit ist der CAN Box Reset beendet.


AX2000-B510

TwinCAT System Manager: Reference

AX2000-B510 Achse (mit zyklischem CANopen Interface)

Der Beckhoff AX2000 Antriebsverstärker wird mit verschiedenen optionalen Feldbusschnittstellen ausgeliefert. Neben diesen optionalen Feldbusschnittstellen bringt der Antriebsverstärker aber auch schon von Haus aus ein CAN Interface mit (im weiteren Verlauf wird der AX2000, bei Einbindung dieser Schnittstelle unter TwinCAT, als "AX2000-B510" bezeichnet). Der AX2000 (ab der Firmware Revision 4.94, empfohlen wird hier die Revision 5.53) ist in der Lage, die von der FC5101 bzw. FC5102 gemäß CANopen Spezifikation DS301 V4.01 übermittelten SYNC-Telegramme auszuwerten und damit synchron die aktuellen Eingangsdaten bereitzustellen bzw. Ausgangsdaten zu übernehmen.

Einleitung

Unter TwinCAT v2.9 kann ein AX2000-B510 genauso in die TwinCAT NC eingebunden und verknüpft werden, wie jede andere unterstützte NC-Achstype. Dies bedeutet, eine Achse (z.B. "Achse 1") kann zur NC-Task hinzugefügt werden und der CAN-spezifische Achstyp "AX2000-B510 Drive (CANopen)" kann danach unter "Einstellungen | Achstyp" ausgewählt werden. Dieser kann dann mit einem bereits angefügten E/A-Knoten vom Typ "AX2000-B510" unterhalb einer konfigurierten "FC510x" (wichtig ist hier das es sich um eine Beckhoff FC5101 oder FC5102 handelt), verknüpft werden.

Die nachfolgende Beschreibung stellt die Eigenheiten eines CANopen-Knotens im Bezug auf das CANopen Antriebsprofil, und die hierzu auf der Antriebsseite notwendigen Einstellungen vor. Für weitergehende Informationen zum AX2000 in der CAN-Betriebsart, werden die Handbücher im Bereich Antriebstechnik | Dokumentation | Digital Kompakt Servoverstärker AX2000 (zu finden z.B. auf der Beckhoff Webseite bzw. auf der Beckhoff Produkt CD) empfohlen.

Karteireiter "CAN Node"

Node Id: Hier wird die Stationsadresse des Antriebs im CAN Netzwerk eingestellt. Die Einstellung der Node Id kann entweder über die Konfigurationssoftware "Drive" erfolgen oder über die ASCII - Kommunikation vorgenommen werden.

Profile No.: + Add. Information : Dieses Objekt (0x1000) beschreibt den Gerätetyp (Servoantrieb) und die Gerätefunktionalität (DS402 Antriebsprofil).

Es setzt sich folgendermaßen zusammen:

Beschreibung |  | Wert |  | Bit
Nummer des Geräteprofils: | Antriebsprofil | 402 (dezimal) | 0x192 (hex.) | 0 - 15
Typ: | Servoantrieb | 2 (dezimal) | 0x2 (hex.) | 16 - 23
Mode Bits: (Nicht sichtbar im Dialogfeld. Bits werden bei Bedarf in das High-Byte des Hi-WORDs einmaskiert): | Hersteller-spezifisch | 0 |  | 24-31

Guard Time (ms): Ansprechüberwachung in Millisekunden.

Life Time Factor: Gibt die Art der Behandlung der "Guard Time" an. Wird hier der Wert "0" eingetragen, ist die Ansprechüberwachung inaktiv. Grundeinstellung ist "3".

Restliche Parameter siehe allg. CANopen

Einstellung der Adresse und Baudrate in der "Drive" Konfigurationssoftware

Für den CANbus relevanten Einstellungen (Node Id, Baudrate,..) können über die Basiseinstellungen der "Drive" Software vorgenommen werden. Voreingestellt sind Adresse 1 und die Baudrate 500kb. Anschliessend ist ein Speichern im EEPROM per SAVE-Befehl und ein nachfolgender COLDSTART erforderlich.

Einstellung der Adresse und Baudrate über die serielle Schnittstelle (HyperTerminal)

Das MS Windows Hyperterminal (Start | Ausführen... | hypertrm.exe) starten. Interface-Einstellung : '9600 Baud, 8 Bit, 1 Stop Bit, kein Parity, kein Handshake'. In das Fenster klicken und Enter Taste betätigen.

Ist das serielle Kabel richtig angeschlossen (X6 ----- RS232), erscheint im Fenster der Cursor " -->".

Hinweis: Wenn sie bei dem seriellen Kabel an beiden Buchsen zwischen dem Pin 7 und 8 eine Brücke einlöten, ist das Kabel symmetrisch und es ist nachher egal, welcher Stecker an welches der beiden Endgeräte angeschlossen wird.

Möchte man den aktuellen Parameter lesen, gibt man das ASCII - Kommando ohne Parameter an (z. B. ADDR). In der nächsten Zeile wird das Ergebnis angezeigt.

Möchte man die Adresse schreiben, wird hinter dem ASCII - Kommando die Adresse angehängt (z. B. ADDR 1).

Karteireiter "AX2000-B510"

Auf diesem Karteireiter wird die Betriebsart für den AX2000 ausgewählt. Es stehen zwei Operations-Modi zur Verfügung.

Position Control: Per Default eingestellt ist "Position Control". In dieser Betriebsart gibt die NC zyklisch eine neue Position vor. Das Verfahrprofil wird durch das TwinCAT NC generiert. Mit der Zykluszeit der SAF-Task (z. B. 10ms) werden Positionswerte an den AX2000 über die CAN Schnittstelle übermittelt. Auf dem AX2000 sind 3 in einander kaskadierte Regler (Strom (65µs), Drehzahl (250µs), Position (entspricht der Zykluszeit der triggernden SAF-Task)). Die Positionsregelung wird vollständig vom AX2000 erledigt . Über das zyklische Interface meldet der AX2000 die Istposition an die NC zurück.

Velocity Control: Optional kann "Velocity Control" aktiviert werden. In dieser Betriebsart dient die Geschwindigkeit als Stellgröße für den AX2000. Dadurch reduziert sich die Anzahl der internen Regelkreise des AX2000 auf 2, nämlich den Strom- (65µs) und Drehzahl-Regler (250µs). Die Einhaltung der Sollposition wird in der TwinCAT NC kontrolliert. Die Istposition wird über das zyklische Interface übertragen. Da die Geschwindigkeitsregelung auf der TwinCAT NC kürzere Abtastzeiten benötigt, wird die Zykluszeit der SAF-Task auf 2ms eingestellt.

Save: Beim Wechsel der Zykluszeit der Triggernden Task (Im Regelfall ist dies die NC SAF - Task ) oder beim Wechsel des Operations-Modes (OPMODE), sollte hier jeweils der "SAVE" Button betätigt werden.

Coldstart: Sind die Daten gespeichert (ca. 3s nach "SAVE" ) ist ein Kaltstart ("COLDSTART") des Reglers notwendig.

Hinweis:

Die Kommandos SAVE und COLDSTART können auch bei freigeschaltetem Regler ausgeführt werden!

Karteireiter "SDOs"

Auf diesem Karteireiter besteht die Möglichkeit den CAN Node in der Aufstartphase über die Service Daten Objekte (SDO's) zu parametrieren. Einträge, deren Objekt-Index in spitzen Klammern stehen, sind automatisch, aufgrund der aktuellen Klemmenkonfiguration, erzeugt worden. Weitere Einträge können über "Anfügen", "Einfügen", Löschen" und "Bearbeiten" verwaltet werden.

Die SDO's werden in erster Linie zur Parametrierung des CAN Nodes und der CAN PDOs. Mit den ersten zwei Einträgen werden die Eigenschaften des TxPDO1 festgelegt:

Object Index | Sub Idx | Length | Value | Description
0x1800 | 1 | 4 | 0x18B | Cob ID (Adresse für die Sende Nachricht von Knoten 11) Default Identifier
0x1800 | 2 | 1 | 1 | Transmission Type

Analog hierzu wird das RxPDO konfiguriert.

Selbst definierte SDO's

Regler Konfiguration

Object Index | Sub Idx | Length | Value | Description
0x6040 | 2 | 2 | 0 | Setzt das Antriebs-ControlWord auf Null. Damit ist der Regler im Zustand "Switch On Disable". Der AX2000 ist einschaltbereit, Parameter können übertragen werden, Zwischenkreisspannung kann eingeschaltet werden, Fahrfunktionen können noch nicht ausgeführt werden
0x3683 | 1 | 1 | 3 | ASCII-Kommando: SYNCSRC
0x363b | 1 | 1 | 3 | Synchronisierungs Mode speziell auf die CAN Schnittstelle abgestimmt ASCII-Kommando: FPGA
0x35d5 | 1 | 1 | 40 | Wert = Task Cycl / Drehzahlregler Cycl 40 = 1000µs / 250µs ASCII-Kommando: PTBASE
0x6060 | 0 | 2 | 0xFA | Hiermit wird der OPMODE des Antriebs festgelegt: 0xFA = Position Control 0xFE = Velocity Control
0x3672 | 1 | 1 | 2 | Beeinflussung der CANopen-Zustandsmaschine durch Enable/Disable.

PDO Mapping

Der AX2000 besitzt 4 Sende- (TxPDO1..4) und 4 Empfangs-PDOs (RxPDO1..4). Womit diese Nachrichten (PDOs) gefüllt werden hängt von der Betriebsart und dem Mapping ab. Es existieren 7 vordefinierte RxPDOs und 6 vordefinierten TxPDOs. Daneben besteht die Möglichkeit die Zusammensetzung der Nachricht selbst vorzunehmen.

Hinweis: Nicht jedes Objekt kann in einem frei definierbaren PDO gemappt werden.

Beim "Position Control" wurde sowohl das RxPDO als auch das TxPDO frei konfiguriert. Beim "Velocity Control" wurde das TxPDO aus dem Pool der vordefinierten PDOs genommen. Das RxPDO wurde frei definiert.

Beispiel:

Object Index | Sub Idx | Length | Value | Description
0x2600 | 0 | 1 | 0x25 | Anwahl eines frei definierbaren RxPDOs (37..40)
0x1600 | 0 | 0 | 0 | Das Mapping löschen
0x1600 | 1 | 4 | 0x60400010 | Das erste Element der Nachricht ist das ControlWord (0x6040) Unterelement SI (0x00) Länge (0x10) 16 Bit
0x1600 | 2 | 4 | 0x20220420 | Das erste Element der Nachricht ist das SollPosition (0x2022) Unterelement SI (0x04) Länge (0x20) 32 Bit

Karteireiter "ADS"

Über die hier angegebene AmsNetID + Port Adresse besteht die Möglichkeit, Parameter vom AX2000 z.B. von der SPS aus zu lesen bzw. zu schreiben.

Beispiel: Zum Lesen des Gerätetyps wird Objektinformation Index: 0x1000, SI 0x0 genutzt.

Karteireiter "DIAG"

Unter diesem Karteireiter werden eventuelle Fehlermeldungen im Klartext angezeigt. Bei einer falsch konfigurierten Additionional Information erkennt der CANopen Master z.B. die Differenz zwischen dem konfigurierten, und den im Regler vorhandenen Wert.

Diagnose - Eingänge des AX2000-B510

Die Diagnose-Eingänge eines AX2000-B510 unterscheiden sich nicht von denen anderer TwinCAT CANopen-Teilnehmer (siehe hierzu auch: "FC510x: Box-Diagnose").

Prozessabbild

Die TxPDO's und die RxPDOs sind aus der Sicht der Slaves zu sehen. Das Eingangsprozessabbild (TxPDO) besteht aus einem "State" und "ActualPos". Das Ausgangsprozessabbild (RxPDO) besteht aus einem "Ctrl" und "NominalPos".

"State": Objektinformation Index: 0x6041, SI: 0x0, Len: 2

Bit | Name | Bit | Name
0 | Ready to switch on | 8 | Manufacturer specific (reserviert)
1 | Switched on | 9 | Remote (nicht unterstützt)
2 | Operation enable | 10 | Target reached
3 | Fault (i.V.) | 11 | Internal limit active (nicht unterstützt)
4 | Disable voltage | 12 | Operation mode specific (reserviert)
5 | Quick stop | 13 | Operation mode specific (reserviert)
6 | Switch on disabled | 14 | Manufacturer specific (reserviert)
7 | Warning | 15 | Manufacturer specific (reserviert)

"ActualPos": Istposition. Objektinformation Index: 0x2070, SI: 0x3, Len: 4

Über diesen Index kann der Inkrementalwert der Istposition gelesen werden. Eine Umdrehung wird dabei mit einer Inkrementzahl von 20 Bit aufgelöst. Es gilt also: 1 Umdrehung 2 expt 20 Inkremente = 1048576 Inkremente. Die eingestellte Auflösung pro Umdrehung kann über den ASCII - Befehl "PRBASE" überprüft werden. Voreingestellte Wert 20 bit/U.

"Ctrl": Objektinformation Index: 0x6040, SI: 0x0, Len: 2

Bit | Name | Bit | Name
0 | Switch on | 8 | Halt (Zwischenstopp)
1 | Disable Voltage | 9 | (reserviert)
2 | Quick Stop | 10 | (reserviert)
3 | Enable Operation | 11 | Schleppfehler und Ansprechüberwachung quittieren
4 | Operation mode-specific | 12 | Rücksetzen der Position
5 | Operation mode-specific | 13 | Manufacturer specific (reserviert)
6 | Operation mode-specific | 14 | Manufacturer specific (reserviert)
7 | Reset Fault (nur wirksam bei Fehlern) | 15 | Manufacturer specific (reserviert)

"NominalPos": Sollposition. Objektinformation Index: 0x2022, SI: 0x4, Len: 4

Über diesen Parameter wird der Inkrementalwert der Sollposition vorgegeben.

"NominalVelo": Sollgeschwindigkeit. Objektinformation Index: 0x2060, SI: 0x0, Len: 4

Über diesen Parameter wird die skalierte Sollgeschwindigkeit vorgegeben.


Übersicht

Nachfolgend aufgeführte Geräte mit DeviceNet Slave-Schnittstelle, werden aktuell von TwinCAT unterstützt.

(Hinweis: Über den ebenfalls aufgeführten, allgemeinen "DeviceNet Node" werden selbstverständlich alle DeveiceNet-Geräte, für die eine gültige EDS-Datei vorhanden ist, unterstützt.)

DeviceNet - Teilnehmer ("Boxen") | Beschreibung | Einschränkungen / Anmerkung
BK5200 | Buskoppler |
BK5210 | Economy Buskoppler |
BK5220 | "Economy plus" Buskoppler |
LC5200 | Low-Cost Buskoppler |
IPxxxx-B520 | Feldbus Kompakt Box: DeviceNet Ein-/Ausgabebaugruppe in Schutzart IP67 |
ILxxxx-B520 | Feldbus Koppler Box: Erweiterbare DeviceNet Ein-/Ausgabebaugruppe in Schutzart IP67 |
FC5201 Slave | Externe FC5201 bzw. FC5202 als Slave-Teilnehmer am Bus |
DeviceNet Node | Allgemeines DeviceNet Slave-Gerät |


DeviceNet Gerät

Über die Auswahl DeviceNet Node können allgemeine DeviceNet Geräte integriert werden. Für diese Geräte müssen dann die Verbindungsparameter angegeben werden.

Karteireiter "DeviceNet Node"

MAC Id: Stellt die Node Id des DeviceNet Teilnehmers ein (zwischen 0 und 63). Dieser Wert muss mit dem am Knoten eingestellten Wert übereinstimmen.

Cycle Time: Legt die Zykluszeit der IO-Verbindung fest. Dieser Wert wird zudem in das Expected Packet Rate (EPR) Attribute des DeviceNet Slaves eingetragen und dient der Timeout-Überwachung von IO-Verbindungen.

Electronic Key: Dient der Überprüfung der sich im Netz befindlichen Geräte beim Systemstart. Der Electronic Key wird bei jedem Systemstart aus den Geräten ausgelesen und mit der gespeicherten Konfiguration verglichen.

Polled: Produced/Consumed: Aktivierung der Betriebsart "Polling", zyklisches Schreiben und Lesen von I/O-Daten

Bit-Strobed: Produced/Consumed: Aktivierung der Betriebsart "Bit-Strobe". Mit einer Broadcast Message werden alle Knoten aufgefordert, Ihre Bit-Strobe Message (bis 7 Bytes Eingangs- oder Statusdaten) zu senden

Change of State / Cyclic: Produced/Consumed: Aktivierung der Betriebsart "Change of State", ereignisgesteuertes Senden von I/O-Daten oder "Cyclic", zyklisches Senden von IO-Daten.

- Change of State / Cyclic: Auswahl der entsprechenden Betriebsart

- Heartbeat Rate / Scan Rate: Die Heartbeat Rate gibt bei der Betriebsart "Change of State" die Cycle-Time an mit der I/O-Daten untergelagert, d.h. zusätzlich zum ereignisgesteuerten Senden, zyklisch gesendet werden. Die Scan Rate gibt bei der Betriebsart "Cyclic" die Cycle-Time an mit der I/O-Daten gesendet werden.

Inhibit Time: Vezögerungszeit bei der Betriebsart Change of State, I/O-Daten werden nach einem Zustandswechsel frühestens nach der hier eingestellten Zeit gesendet

Acknowledge Timeout: Zeitspanne bis zur Sendewiederholung bei fehlendem Acknowledge auf eine Change of State / Cyclic Nachricht

Acknowldege Retry Limit: Maximale Anzahl Sendewiederholungen bis I/O-Verbindung in Fehlerzustand übergeht.

K-Bus Update: Berechnet die voraussichtliche Dauer für ein vollständiges Update des Klemmenbusses (ist abhängig von den angeschlossenen Klemmen).

Diagnose Eingänge:

Jeder DeviceNet Feldbusknoten erhält ein Diagnose-Eingangsbyte, das den Status des jeweiligen Slaves zur Laufzeit signalisiert und z.B. mit der SPS verknüpft werden kann:

BoxState

Error Code | Description | Troubleshooting
0x02 | Station not exists, device is not responding | Inspect the device, verify connections, check cabling
0x05 | Parameter fault | Check explicite access to devices attributes, check object class, instance and attribute id
0x07 | Configuration fault | Check configuration settings of device
0x09 | Device is deactivated | Check master and device configuration

DataExchange

Error Code | Description | Troubleshooting
0x00 | No data exchange between node and master | Inspect the field device, verify connections, check cabling
0x01 | Data Exchange is active |

Karteireiter "Attribute"

Auf dieser Seite werden DeviceNet Attribute/Parameter angezeigt/verwaltet, die beim Startup zum Knoten geschickt werden. Die Einträge können über "Neu", "Löschen" und "Bearbeiten" verwaltet werden.

Karteireiter "ADS"

Um Attribute auch zur Laufzeit schreiben und lesen zu können (z.B. aus der SPS heraus), kann dem Knoten (Buskoppler) ein ADS-Port zugewiesen werden. Über diesen können die Attribute per ADS Read Request bzw. Write Request gelesen und geschrieben werden.

Der ADS IndexGroup beinhaltet die ClassId und der ADS IndexOffset beinhaltet InstanceId und AttributeId (InstanceId * 256 + AttributeId).

Diagnosedaten

DeviceNet-Statusdaten eines Nodes können per ADS von jedem TwinCAT Programm gelesen bzw. an jedes TwinCAT-Programm gemeldet werden.

Karteireiter "Parameter"

Die Parameter werden beim Anlegen der Box aus dem EDS ausgelesen. Ist das System noch nicht gestartet, werden unter dem Value-Eintrag immer die im EDS hinterlegten Default-Werte angezeigt.


Übersicht

Nachfolgend aufgeführte Geräte mit SERCOS Interface, werden aktuell von TwinCAT unterstützt:

SERCOS - Teilnehmer ("Boxen") | Beschreibung | Einschränkungen / Anmerkung
SERCOS Achse | Allgemeine Sercos Achse | Die TwinCAT SERCOS Implementierung ist generisch ausgeführt, d. h. unabhängig vom jeweiligen SERCOS Antrieb.
BK7500 | Beckhoff Standard Buskoppler |
BK7520 | Beckhoff "Economy plus" Buskoppler |


SERCOS Achse

Karteireiter "Sercos Achse"

Adresse: SERCOS Achsadresse, die mit der auf dem Antriebsverstärker eingestellten übereinstimmen muss.

Betriebsart: Stellt die SERCOS Betriebsart der Achse ein. Unterstützt werden z.Zt. die Geschwindigkeitsbetriebsart, in der Geschwindigkeitssollwerte an den Antrieb gesendet werden und die Lageregelung im PC erfolgt. Zusätzlich wird die Positionsbetriebsart unterstützt, bei der Positionen zum Antrieb gesendet werden und die Lageregelung im Antrieb erfolgt.

Betriebsart | Beschreibung
Geschwindigkeit | Der Antrieb erhält digitale Geschwindigkeitssollwerte, welche per Lageregelung durch den TwinCAT NC Regler auf dem PC generiert werden.
Position 1 | Der Antrieb erhält zyklisch digitale Positionssollwerte, generiert durch den TwinCAT NC, die Lageregelung erfolgt im Antrieb. Als Encoder wird der eingebaute Resolver (Lage-Istwert 1, Motorgeber, S-0-0051) verwendet.
Position 2 | Der Antrieb erhält zyklisch digitale Positionssollwerte, , generiert durch den TwinCAT NC, die Lageregelung erfolgt im Antrieb. Als Encoder wird ein extern angeschlossener Geber (Lage-Istwert 2, S-0-0053) verwendet.
Position 1+2 | Der Antrieb erhält zyklisch digitale Positionssollwerte, die Lageregelung erfolgt im Antrieb. Als Encoder werden sowohl der Motorgeber (Resolver) als auch der externe Geber verwendet.
Position 1 ohne Schleppabstand | Antriebsinterne Interpolation (bei Einbindung der Achse ohne Verknüpfung zum TwinCAT NC Regler). Als Encoder wird der eingebaute Resolver (Lage-Istwert 1, Motorgeber, S-0-0051) verwendet.
Position 2 ohne Schleppabstand | Antriebsinterne Interpolation (bei Einbindung der Achse ohne Verknüpfung zum TwinCAT NC Regler). Als Encoder wird ein extern angeschlossener Geber (Lage-Istwert 2, S-0-0053) verwendet.
Position 1+2 ohne Schleppabstand | Antriebsinterne Interpolation (bei Einbindung der Achse ohne Verknüpfung zum TwinCAT NC Regler). Als Encoder werden sowohl der Motorgeber (Resolver) als auch der externe Geber verwendet.

HINWEIS:

In der Positionsbetriebsart ist darauf zu achten, dass bei Endlosachsen in der Wichtungsart für Lagedaten (S-0-0076) die Modulofunktion eingeschaltet ist und der resultierende Modulowert (S-0-0103) in TwinCAT bekannt ist (vergl. Kartenreiter "SERCOS).

HINWEIS:

In der Geschwindigkeitsbetriebsart ist darauf zu achten, dass die Ausgabeskalierung für den Antrieb im TwinCAT System richtig eingestellt wird (vergl. Karteireiter "SERCOS").

Telegrammtyp: Stellt den Telegrammaufbau zum/vom Antrieb ein. Defaultmäßig ist der Typ "Konfigurierbares Telegramm" ausgewählt (siehe nachfolgende Tabelle).

Telegrammtyp | Beschreibung
Vorzugstelegramm 1 (80 / -) | Das Telegramm zum Antrieb enthält nur den Dehmomentsollwert (IDN 80). Ein Rücktelegramm vom Antrieb gibt es bei diesem Telegrammtyp nicht.
Vorzugstelegramm 2 (36 / 40) | Telegramm zum Antrieb: Geschwindigkeits-Sollwert (IDN 36) Telegramm vom Antrieb: Geschwindigkeits-Istwert (IDN 40)
Vorzugstelegramm 3 (36 / 51) | Telegramm zum Antrieb: Geschwindigkeits-Sollwert (IDN 36) Telegramm vom Antrieb: Lage-Istwert (IDN 51)
Vorzugstelegramm 3 ext. (36 / 53) | Telegramm zum Antrieb: Geschwindigkeits-Sollwert (IDN 36) Telegramm vom Antrieb: Lage-Istwert vom externen Geber (IDN 53)
Vorzugstelegramm 4 (47 / 51) | Telegramm zum Antrieb: Lage-Sollwert (IDN 47) Telegramm vom Antrieb: Lage-Istwert (IDN 51)
Vorzugstelegramm 4 ext. (47 / 53) | Telegramm zum Antrieb: Lage-Sollwert (IDN 47) Telegramm vom Antrieb: Lage-Istwert vom externen Geber (IDN 53)
Vorzugstelegramm 5 (47 36 / 51 40) | Telegramm zum Antrieb: Lage- und Geschwindigkeits-Sollwert Telegramm vom Antrieb: Lage- und Geschwindigkeits-Istwert
Vorzugstelegramm 5 ext. (47 36 / 53 40) | Telegramm zum Antrieb: Lage- und Geschwindigkeits-Sollwert Telegramm vom Antrieb: Lage- (externer Geber) und Geschwindigkeits-Istwert
Vorzugstelegramm 6 (36 / -) | Das Telegramm zum Antrieb enthält nur den Geschwindigkeits-Sollwert (IDN 36). Ein Rücktelegramm vom Antrieb gibt es bei diesem Telegrammtyp nicht.
Konfigurierbares Telegramm | Es kann eine eigene Telegrammkonfiguration mit allen gewünschten Soll- und Istwerten vorgenommen werden.

HINWEIS:

Die bei der FC750x im Bereich Karteireiter "Timing Offline" beschriebene Berechnung, geht von einer Basistelegrammart (Telegrammtyp 2-4) aus.

Karteireiter "Startup"

Hier können SERCOS Parameter eingetragen werden, die bei jedem TwinCAT Start über den NC-Service Kanal an den Antrieb gesendet werden und somit die im Antrieb vorhanden Werte überschreiben.

Karteireiter "Istwertkanal"

Hier werden die SERCOS Parameter eingetragen, die im Istwertkanal der jeweiligen Achse ausgetauscht werden. Es werden automatisch entsprechende Variablen unterhalb der Achse im Baum angelegt, die entsprechend verknüpft werden können.

Ein Lageistwert ist in jedem Fall nötig!

Neu...: Zusätzliche Variablen können mit dem folgenden Dialog in die obige Liste aufgenommen werden:

Bei Id. No.: wird ein vom Antriebsverstärker unterstützter S- bzw. P-Patrameter spezifiziert, unter Name: kann der gewünschter Name (sinnvollerweise der echte Name des Parameters) editiert werden. Zusätzlich muß der Datentyp in der rechts dargestellten Auswahl selektiert werden.

Karteireiter "Sollwertkanal"

Ähnlich wie im Istwertkanal werden hier Variablen angegeben, die im Sollwertkanal ausgetauscht werden. Je nach Betriebsart der Achse muss der Geschwindigkeits- oder der Lagesollwert im Sollwertkanal vorhanden sein.

Karteireiter "ADS"

Auf diesem ADS-Einstelldialog wird die ADS-Port Nummer eingestellt, über die alle ADS-Zugriffe auf die antriebsinternen Parameter erfolgen.

Karteireiter "Online"

Über den Online-Reiter kann der NC-Service Kanal bedient werden. TwinCAT muss dazu gestartet sein und der SERCOS Ring muss mindestens in der Phase 2 sein.

Diagnose: Durch Betätigung dieser Schaltfläche kann eine Diagnoseanforderung ausgelöst werden (vergl. S-0-0095). Das Ergebnis wird im Feld rechts neben der Schaltfläche dargestellt.

Reset: Hiermit kann SERCOS-spezifischer Reset der Achse bzw. des Antriebverstärkers durchgeführt werden (vergl. S-0-0099).

In der unteren Liste werden alle SERCOS Parameter mit ihren aktuellen Werten angezeigt. Diese Daten werden online aus dem Antrieb gelesen (inkl. Texte und Einheiten), so dass das Blättern in der Liste etwas Zeit benötigt. Wenn der Antrieb dieses unterstützt, kann zwischen englischer und deutscher Ausgabe gewechselt werden (siehe hierzu auch Advanced...)

Das Ändern der Parameter erfolgt durch einen Doppelklick auf die jeweilige Id-Nr., es geht ein entsprechender Dialog auf.

Kontextmenü:

Die Liste der SERCOS Parameter kann auch gedruckt und exportiert werden (auch per Drag and Drop z.B. in Excel). Über die rechte Maustaste wird folgendes Kontextmenü geöffnet:

Print List: Ausgabe der Parameterliste auf einen Drucker.

Liste Kopieren: Kopiert die Liste in die Windows Zwischenablage

Copy selected IDN to Startup: Sofern aktiv, kann hiermit die ausgewählte IDN zu den Startup-Parametern hinzugefügt werden.

Liste exportieren (CSV): Nach dem Export in eine sogenannte CSV-Datei, können die Daten in beliebigen Programmen, die das *.csv Format unterstützen, weiterverarbeitet werden.

Liste exportieren (PAR): Export der Parameterdaten ins DriveTop *.par Format.

Update Liste: Über diesen Button können die Werte der aktuellen Ansicht neu vom Antrieb geladen werden.

Auto Update: Nach Aktivierung dieser Checkbox wird ein automatisches, per Timer gesteuertes, Update durchgeführt (Update-Rate ca. 2sec.).

Advanced: Nach Betätigung dieser Schaltfläche wird folgender Dialog für die erweiterten Einstellungen aufgerufen:

Die obere, linke Listbox erlaubt eine Eingrenzung der in der unteren Liste dargestellten Werte. Hierzu werden eine Reihe von Gruppen vom System vorgeschlagen, die in bestimmten Situationen sinnvoll zusammenhängende Werte definieren. Als letzte Gruppe ist eine benutzerdefinierte Gruppe aufgelistet, hier kann in der rechten Liste eine beliebige Zusammenstellung vorgenommen werden.

Backup / Restore: Hiermit können die vom Antrieb vorgeschlagenen Parameter (definiert in S-0-0192) in einer Datei gespeichert (Backup) und später eventuell in einem ausgetauschten Antrieb wieder restauriert werden (Restore). Das Format der Backup Datei entspricht dem Parameter Format (*.par ), das bei dem DriveTop-Tool der Firma Rexroth-Indramat genutzt wird. Dadurch ist ein Austausch mit diesem Tool möglich.

SERCOS IDs per ADS

SERCOS IDs können auch zur Laufzeit per ADS gelesen und geschrieben werden (z.B. aus der SPS heraus). Dazu muss der Achse über den ADS-Reiter ein ADS-Port zugewiesen werden, welches standardmäßig durchgeführt wird.

Über diesen Port kann ein ADS Read oder Write Request durchgeführt werden. Der IndexGroup entspricht der gewünschten SERCOS ID und der IndexOffset dem Element des SERCOS Wertes:

Port No.: Nummer von der ADS-Seite (Karteireiter)

IndexGroup: SERCOS-ID, z.B.:

S-0-0123 = 123 (0x007B)

S-7-0101 = 101 + 0x7000 = 0x7065

P-0-0002 = 2 + 0x8000 = 0x8002

P-7-0004 = 4 + 0x8000 + 0x7000 = 0xF004

IndexOffset gewünschtes Element:

0 oder 7 = Wert,

1 = DatenStatus,

2 = Name (nur lesen),

3 = Attribut (vergl. SERCOS Spezifikation),

4 = Einheit,

5 = Minimum,

6 = Maximum

Reset per ADS

Ein Reset der Antriebsverstärkers (z.B. nach einem Schleppfehler) kann ebenfalls über ADS erfolgen, und zwar indem ein ADSWrite-Kommando an die ID S-0-0099 bei Verwendung der

- FC7501 bzw. FC7502:

per IndexGroup: 0x0063, IndexOffset: 8, eine 3 (also die Adresse der Konstanten 3), gesendet wird und zwar "ByRef" (SrcAddr).

oder bei einer

- SERCANS SCS-P Master-Karte:

per IndexGroup: 0x0063, IndexOffset: 7, hintereinander die Werte 3, 0, 3 und wieder 0 gesendet werden , natürlich ebenfalls "ByRef" (SrcAddr).

(genau dieses wird vom TwinCAT System Manager durchgeführt, wenn der Reset-Button auf dem Karteireiter "Online" betätigt wird).

Diagnose Eingänge

Das Antriebsstatuswort (Antriebs Status Wort) ist ein in SERCOS spezifiziertes Rücktelegramm, welches jeder Antrieb liefern muss.

Variable | Datentyp | Bit | Beschreibung
Antriebs Status Wort | UINT16 | 0..2 | Steuerinformationen für Service-Kanal
 |  | 5 | Kommando: Bit Statuswechsel
 |  | 6+7 | Real-Time Statusbits 1 + 2
 |  | 8+9 | Aktueller Betriebsmodus 00: Hauptbetriebsart aktiv 01: Nebenbetriebsart aktiv
 |  | 11 | Bitwechsel Klasse 3 Diagnose
 |  | 12 | Bitwechsel Klasse 2 Diagnose
 |  | 13 | Antriebssperre, Fehler in Klasse 1 Diagnose
 |  | 14+15 | Betriebsbereit 00: Antrieb nicht einschaltbereit, da interne Prüfung fehlgeschlagen 01: Antrieb einschaltbereit 10: Steuer- und Lastkreis betriebsbereit, keine Lageregelung 11: In Betrieb, Lageregelung aktiv


AX2xxx-B750 Achse (SERCOS)

TwinCAT System Manager: Reference

AX2xxx-B750 Achse

Der Beckhoff AX2000 und der AX2500 Antriebsverstärker wird mit verschiedenen (optionalen) Feldbusschnittstellen ausgeliefert. Eine Variante ist hierbei das SERCOS-Interface (Bestellbezeichnung: AX2000-B750).

Der AX2000-B750 bzw. AX2500-B750 ist in TwinCAT wie eine allgemeine "SERCOS Achse" implementiert, wie dies auch im folgenden Bild am Karteireiter "SERCOS Achse" erkennbar ist.
Im Folgenden wird daher nur darauf eingegangen, wie sich die internen Objekte (Parameter) des AX2000/AX2500 als SERCOS IDNs in der Online-Anzeige darstellen.

Karteireiter "Online"

Die Schaltflächen auf dem oben gezeigten Dialog sind, wie bereits erwähnt, innerhalb des Kapitels " SERCOS Achse" dokumentiert.

Die im Bild dargestellten, sowie sonstige, vom Antrieb unterstützten SERCOS S - und P - Parameter, sind im Bereich "Drive Technology: AX2000-B750 - IDN Reference" aufgeführt.


AX2000-B750 Introduction

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

Introduction

The AX2000 drive is available with different Fieldbus interfaces. One of these interfaces is the optional SERCOS interface (order number: AX2000-B750). Inside this reference documentation, the SERCOS IDNs supported by AX2000 are described.

Hint:

Beckhoff provides this preliminary document for informational purposes only. Beckhoff makes no warranties, expressed or implied, in this document.

Index | Remarks
Nomenclature | Abbreviations used inside this documentation
IDN notation format | How to read the IDN descriptions
IDN By Function Overview | IDN's sorted by function (Torque Control, Velocity Control, Homing,...)
IDN By Function Overview II | IDN's for general use, sorted by function (Monitoring & Trouble Shooting, Fault & Safety Detection, Configurable I/O,..)
General Information | Informations on how to configure basic settings like baud rate, address,.. of the AX2000-B750 drive
IDN Set Supported By AX2000-B750 | Listing of all currently supported S- and P - parameters (with specific ADS Index Group information for accessing these IDNs with TwinCAT)


AX2000-B750 Abbreviations

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

Nomenclature

IDN description abbreviations

AqB | Incremental encoder signaling scheme. The A and B signals are in quadrature
AT | Amplifier telegram (telegram from drive)
C1D | Class 1 diagnostic (fault)
C2D | Class 2 diagnostic (warning)
C3D | Class 3 diagnostic (status)
CCT | Communication cycle time (IDN 2)
CCW | Counter clockwise. CW and CCW are viewed from the output end of the motor
CUCT | Control unit cycle time (IDN 1)
CUSB | Control unit synchronization bit (MDT control word bit 10)
CW | Clockwise. CW and CCW are viewed from the output end of the motor
CPx | Communication phase
IC | Continuous current
IDN | Identification number
IP | Peak current
LSB | Least significant bit
MDT | Master data telegram
MSB | Most significant bit
MST | Master synchronization telegram
PFB | Position feedback
ROD | Refer to AqB
RTC | Real time control bit
RTS | Real time status bit
SC | Sercos Service channel
mI | Micro-Interpolator


AX2000-B750 IDN Notation

Drive Technology: AX2000-B750 - IDN Reference

IDN Notation Format

The IDN set supported by AX2000-B750 is listed in numerical order with a short description for each IDN. The descriptions use the following format:

Below you'll find an example of the IDN description structure.

IDN 1 Numeric Cycle Time

The cycle time of the numeric controller (TNcyc). This time corresponds to IDN 2, which specifies the SERCOS cycle time (TScyc).

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 1000 | Run-Up Check: | CP2
Maximum: | 8000 | Cyclic Transfer: |
Default: | 2000 | Serial Equiv: |
Units: | μs | Version: |
IDN Type: | SC | ADS Index Group (hex.): | 0x0001

Note:

Not all IDN descriptions require all of the fields listed above. Only the applicable fields are filled within an IDN description. The field definitions are as follows:

IDN x

The identification number in short-hand notation.

S-x-xxxx / P-x-xxxx

According to IEC 61491 specified notation of a SERCOS identification number.
S-x-xxxx are SERCOS standard-specific identification numbers, versus P-x-xxxx are product-specific ones.

Title

A descriptive title of the IDN (in above case it is: Numeric Cycle Time).

Description

Information of the IDN purpose and relations/dependencies to other IDN's are named here.

Data Length

The length of IDN element 0 resp. 7, in bytes. Possible entries for this field are as follows:

2 bytes - The length of the operating data is 2 bytes.

4 bytes - The length of the operating data is 4 bytes.

1 byte var. - The length of the operating data is variable. The length of one data element is 1 byte.

2 bytes var. - The length of the operating data is variable. The length of one data element is 2 bytes.

4 bytes var. - The length of the operating data is variable. The length of one data element is 4 bytes.

Data Format

The format for interpreting and displaying the operating data. Possible entries for this field are binary, unsigned decimal, signed decimal, hexadecimal, text and IDN.

Minimum / Maximum

The allowed range of IDN element 7 data. IDN element 7 is checked for range compliance in the service channel. In general, if the range is blank in the IDN description, this means that IDN elements 5 and 6 are not supported. The ranges of some IDNs are dependent upon the value of other IDNs, drive parameters or motor parameters.

Default

The default value for IDN element 7 data. An IDN will revert to its default value after a firmware upgrade. The default may be a fixed value, or it may be stored in non-volatile memory. A blank “Default” field indicates that the IDN does not have a default value.

Units

The units of IDN element 7 data and of the minimum, maximum, and default fields. The units of some IDNs are obtained from the operating data of other IDNs. IDNs of data type “binary”, “text”, or “IDN” do not have units and the “Units” field is left blank in the IDN description.

Non-Volatile

Indicates whether the IDN operation data can be saved in non-volatile memory. Possible entries for this field are as follows:

(blank) - The operating data is stored in volatile memory and is lost when logic power is removed.
Yes - The operating data may be stored in non-volatile memory and will be retained after power down.

Write Access

The SERCOS communication phases (CPx) during which an IDN may be written. In general an IDN may be read through the service channel during communication phases CP2 and above. However writing to an IDN may be restricted during some communication phases or while the drive is enabled. An entry of “Read-only” indicates that the IDN cannot be written during any communication phase.

Run-Up Check

The SERCOS communication phases (CPx) during which the validity of the operating data is checked. Possible entries for this field are as follows:

(blank) - The validity of the operating data is not checked.
CP2 - The validity of the operating data will be checked in the procedure “S-0-0127 Communication phase 3 transition check.”
CP3 - The validity of the operating data will be checked in the procedure “S-0-0128 Communication phase 4 transition check.”

Cyclic Transfer

Indicates whether cyclic transfer is possible for IDN element 7. Possible entries for this field are as follows:

(blank) - The operating data is not cyclic.
MDT - The IDN may be transferred within the MDT as cyclic data.
AT - The IDN may be transferred within the AT as cyclic data.

Serial Equivalent

An equation of equivalent protocol commands that may be issued through the RS-232/485 serial port (e.g. through the Microsoft Windows® HyperTerminal program to be started with: Start | Run ... type hypertrm.exe) to obtain the IDN data. The contents of the IDN can be obtained by evaluating the equation. The field is blank in the IDN description, if no equivalent serial commands are available.

Version

The drive Firmware version from which on this IDN is supported.

IDN Type

The

IndexGroup

Names the ADS IndexGroup to use for accessing this IDN via ADS in a hexa-decimal format. The IndexOffset, which is also necessary for the ADS command, specifies the required element from this SERCOS IDN in this context. The IndexOffset (IdxOffs) to use, varies from case to case.

IndexOffset specification:

0 or 7 = value,

1 = Data Status,

2 = Name (read only),

3 = Attribute (refer to SERCOS specification IEC 61491),

4 = Unit,

5 = Minimum,

6 = Maximum

TwinCAT PLC contains a function block library (TcSystem.lib) for the ADSREAD and ADSWRITE access of objects accessible via the ADS protocol.


AX2000-B750 IDN By Function Overview

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN By Function Overview

Sorted overview of ident numbers necessary for dedicated drive control functions as for:

Current / Torque Control, Velocity Control, Position Control, Accel / Decel Control and Homing.

For general communication types see: "IDN By Function Overview II".

Current / Torque Control

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 32 | (S-0-0032) | Primary Operation Mode | 0x0020
IDN 33 | (S-0-0033) | Secondary Operation Mode 1 | 0x0021
IDN 84 | (S-0-0084) | Torque Feedback Value | 0x0054
IDN 86 | (S-0-0086) | Torque/Force Data Scaling Type | 0x0056
IDN 92 | (S-0-0092) | Bipolar Torque Limit | 0x005C
IDN 106 | (S-0-0106) | Current Loop Proportional Gain 1 | 0x006A
IDN 107 | (S-0-0107) | Current Loop Integral Action Time 1 | 0x006B
IDN 110 | (S-0-0110) | Amplifier Peak Current | 0x006E
IDN 112 | (S-0-0112) | Amplifier Rated Current | 0x0070
IDN 114 | (S-0-0114) | System Load Limit | 0x0072
IDN 3020 | (P-0-3020) | System Rated Current | 0xB020

Velocity Control

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 32 | (S-0-0032) | Primary Operation Mode | 0x0020
IDN 33 | (S-0-0033) | Secondary Operation Mode 1 | 0x0021
IDN 36 | (S-0-0036) | Velocity Command Value | 0x0024
IDN 38 | (S-0-0038) | Positive Velocity Limit Value | 0x0026
IDN 39 | (S-0-0039) | Negative Velocity Limit Value | 0x0027
IDN 40 | (S-0-0040) | Velocity Feedback Value | 0x0028
IDN 41 | (S-0-0041) | Homing Velocity | 0x0029
IDN 44 | (S-0-0044) | Velocity Data Scaling Type | 0x002C
IDN 45 | (S-0-0045) | Velocity Data Scaling Factor | 0x002D
IDN 46 | (S-0-0046) | Velocity Data Scaling Exponent | 0x002E
IDN 91 | (S-0-0091) | Bipolar Velocity Limit | 0x005B
IDN 100 | (S-0-0100) | Velocity Loop Proportional Gain | 0x0064
IDN 101 | (S-0-0101) | Velocity Loop Integral Action Time | 0x0065
IDN 296 | (S-0-0296) | Velocity Feed Forward Gain | 0x0128
IDN 392 | (S-0-0392) | Velocity Feedback Filter Time Constant | 0x0188
IDN 3021 | (P-0-3021) | Over Speed | 0x8BCD
IDN 3027 | (P-0-3027) | Manufacturer Homing Modes | 0x8BD3

Position Control

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 32 | (S-0-0032) | Primary Operation Mode | 0x0020
IDN 33 | (S-0-0033) | Secondary Operation Mode 1 | 0x0021
IDN 41 | (S-0-0041) | Homing Velocity | 0x0029
IDN 42 | (S-0-0042) | Homing Acceleration | 0x002A
IDN 47 | (S-0-0047) | Position Command Value | 0x002F
IDN 51 | (S-0-0051) | Position Feedback Value 1 (Motor Feedback) | 0x0033
IDN 52 | (S-0-0052) | Reference Distance 1 | 0x0034
IDN 57 | (S-0-0057) | Position Window | 0x0039
IDN 76 | (S-0-0076) | Position Data Scaling Type | 0x004C
IDN 79 | (S-0-0079) | Rotational Position Resolution | 0x004F
IDN 104 | (S-0-0104) | Position Loop Proportional Gain | 0x0068
IDN 105 | (S-0-0105) | Position Loop Integral Action Time | 0x0069
IDN 130 | (S-0-0130) | Probe 1 Positive Edge Value | 0x0082
IDN 131 | (S-0-0131) | Probe 1 Negative Edge Value | 0x0083
IDN 147 | (S-0-0147) | Homing Parameter | 0x0093
IDN 148 | (S-0-0148) | Procedure: Drive Controlled Homing | 0x0094
IDN 159 | (S-0-0159) | Monitoring Window | 0x009F
IDN 169 | (S-0-0169) | Probe Control Parameter | 0x00A9
IDN 170 | (S-0-0170) | Procedure: Probing | 0x00AA
IDN 179 | (S-0-0179) | Probe Position Latch Status | 0x00B3
IDN 189 | (S-0-0189) | Following Distance | 0x00BD
IDN 298 | (S-0-0298) | Home Switch Distance | 0x012A
IDN 336 | (S-0-0336) | Status “In Position” | 0x0150
IDN 400 | (S-0-0400) | Home Switch Status | 0x0190
IDN 401 | (S-0-0401) | Probe 1 | 0x0191
IDN 402 | (S-0-0402) | Probe 2 | 0x0192
IDN 403 | (S-0-0403) | Position Feedback Status | 0x0193
IDN 405 | (S-0-0405) | Probe 1 Enable | 0x0195
IDN 406 | (S-0-0406) | Probe 2 Enable | 0x0196
IDN 409 | (S-0-0409) | Probe 1 Positive Edge Latched Status | 0x0199
IDN 410 | (S-0-0410) | Probe 1 Negative Edge Latched Status | 0x019A
IDN 411 | (S-0-0411) | Probe 2 Positive Edge Latched Status | 0x019B
IDN 412 | (S-0-0412) | Probe 2 Negative Edge Latched Status | 0x019C
IDN 3011 | (P-0-3011) | Encoder Emulation Mode | 0x8BC3
IDN 3027 | (P-0-3027) | Manufacturer Homing Modes | 0x8BD3

Accel / Decel Control

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 42 | (S-0-0042) | Homing Acceleration | 0x002A
IDN 136 | (S-0-0136) | Positive Acceleration Limit Value | 0x0088
IDN 137 | (S-0-0137) | Negative Acceleration Limit Value | 0x0089
IDN 160 | (S-0-0160) | Acceleration Data Scaling Type | 0x00A0
IDN 3022 | (P-0-3022) | Quick Deceleration Rate | 0x8BCE

Homing

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 41 | (S-0-0041) | Homing Velocity | 0x0029
IDN 42 | (S-0-0042) | Homing Acceleration | 0x002A
IDN 147 | (S-0-0147) | Homing Parameter | 0x0093
IDN 148 | (S-0-0148) | Procedure: Drive Controlled Homing | 0x0094
IDN 170 | (S-0-0170) | Procedure: Probing | 0x0AA
IDN 298 | (S-0-0298) | Home Switch Distance | 0x012A
IDN 400 | (S-0-0400) | Home Switch Status | 0x0190
IDN 403 | (S-0-0403) | Position Feedback Status | 0x0193
IDN 3000 | (P-0-3000) | Configurable I/O: Digital Input 1 Mode | 0x8BB8
IDN 3027 | (P-0-3027) | Manufacturer Homing Modes | 0x8BD3


AX2000-B750 IDN By Function Overview II

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN By Function Overview II

Sorted overview of ident numbers necessary for dedicated drive features as for:

Motor Compatibility, Feedback Devices, Monitoring & Troubleshooting, Fault & Safety Detection, Configurable I/O, General Features and Systems Communication.

Motor Compatibility

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 109 | (S-0-0109) | Motor Peak Current | 0x006D
IDN 111 | (S-0-0111) | Motor Continuous Stall Current | 0x006F
IDN 113 | (S-0-0113) | Maximum Motor Speed | 0x0071

Feedback Devices

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 116 | (S-0-0116) | Resolution of Rotational Feedback 1 (Motor Feedback) | 0x0074
IDN 117 | (S-0-0117) | Resolution of Rotational Feedback 2 (External Feedback) | 0x0075
IDN 3010 | (P-0-3010) | Feedback Type | 0x8BC2

Monitoring & Troubleshooting

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 11 | (S-0-0011) | Class 1 Diagnostic (C1D) | 0x000B
IDN 12 | (S-0-0012) | Class 2 Diagnostic (C2D) | 0x000C
IDN 13 | (S-0-0013) | Class 3 Diagnostic (C3D) | 0x000D
IDN 14 | (S-0-0014) | Interface Status | 0x000E
IDN 95 | (S-0-0095) | Diagnostic Message | 0x005F
IDN 96 | (S-0-0096) | Slave Arrangement | 0x0060
IDN 97 | (S-0-0097) | Class 2 Diagnostic Mask | 0x0061
IDN 98 | (S-0-0098) | Class 3 Diagnostic Mask | 0x0062
IDN 99 | (S-0-0099) | Procedure: Reset Class 1 Diagnostic | 0x0063
IDN 129 | (S-0-0129) | Manufacturer Class 1 Diagnostic (MC1D) | 0x0081
IDN 186 | (S-0-0186) | Maximum Length of MDT Configurable Data | 0x00BA
IDN 271 | (S-0-0271) | Drive ID | 0x010F
IDN 304 | (S-0-0304) | Real-Time Status Bit 1 | 0x0130
IDN 305 | (S-0-0305) | Allocation of Real-time Status Bit 1 | 0x0131
IDN 306 | (S-0-0306) | Real-Time Status Bit 2 | 0x0132
IDN 307 | (S-0-0307) | Allocation of Real-time Status Bit 2 | 0x0133

Fault & Safety Detection

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 91 | (S-0-0091) | Bipolar Velocity Limit | 0x005B
IDN 92 | (S-0-0092) | Bipolar Torque Limit | 0x005C
IDN 95 | (S-0-0095) | Diagnostic Message | 0x005F
IDN 99 | (S-0-0099) | Procedure: Reset Class 1 Diagnostic | 0x0063
IDN 114 | (S-0-0114) | System Load Limit | 0x0072
IDN 129 | (S-0-0129) | Manufacturer Class 1 Diagnostic (MC1D) | 0x0081
IDN 159 | (S-0-0159) | Monitoring Window | 0x009F
IDN 3020 | (P-0-3020) | System Rated Current | 0x8BCC
IDN 3021 | (P-0-3021) | Over Speed | 0x8BCD

Configurable I/O

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 400 | (S-0-0400) | Home Switch Status | 0x0190
IDN 3000 | (P-0-3000) | Configurable I/O: Digital Input 1 Mode | 0x8BB8
IDN 3001 | (P-0-3001) | Configurable I/O: Digital Input 2 Mode | 0x8BB9
IDN 3002 | (P-0-3002) | Configurable I/O: Digital Input 3 Mode | 0x8BBA
IDN 3003 | (P-0-3003) | Configurable I/O: Digital Input 4 Mode | 0x8BB8
IDN 3004 | (P-0-3004) | Position Switch Configuration | 0x8BBC
IDN 3005 | (P-0-3005) | Configurable I/O: Digital Output 1 Mode | 0x8BBD
IDN 3006 | (P-0-3006) | Configurable I/O: Digital Output 2 Mode | 0x8BBE
IDN 3030 | (P-0-3030) | Configurable I/O: Digital Input 1 Status | 0x8BD6
IDN 3031 | (P-0-3031) | Configurable I/O: Digital Input 2 Status | 0x8BD7
IDN 3032 | (P-0-3032) | Configurable I/O: Digital Input 3 Status | 0x8BD8
IDN 3033 | (P-0-3033) | Configurable I/O: Digital Input 4 Status | 0x8BD9
IDN 3034 | (P-0-3034) | Analog Input 1 Value | 0x8BDA
IDN 3035 | (P-0-3035) | Analog Input 2 Value | 0x8BDB
IDN 3036 | (P-0-3036) | Configurable I/O: Digital Output 1 Control/Status | 0x8BDC
IDN 3037 | (P-0-3037) | Configurable I/O: Digital Output 2 Control/Status | 0x8BDD

General Features

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 30 | (S-0-0030) | Manufacturer Version | 0x001E
IDN 142 | (S-0-0142) | Application Type | 0x008E
IDN 192 | (S-0-0192) | IDN List of Back-up Operation Data | 0x00C0
IDN 262 | (S-0-0262) | Procedure: Load Default Values | 0x0106
IDN 264 | (S-0-0264) | Procedure: Back-up Working Memory | 0x0108
IDN 288 | (S-0-0288) | IDN List of Data Programmable in CP2 | 0x0120
IDN 289 | (S-0-0289) | IDN List of Data Programmable in CP3 | 0x0121

Systems Communication

Ident Number | Sercos Parameter | Description | ADS IndexGroup
IDN 2 | (S-0-0002) | Communication Cycle Time | 0x0002
IDN 3 | (S-0-0003) | Shortest AT Transmission Starting Time | 0x0003
IDN 4 | (S-0-0004) | Transmit/Receive Transition Time | 0x0004
IDN 5 | (S-0-0005) | Minimum Feedback Processing Time | 0x0005
IDN 6 | (S-0-0006) | AT Transmission Starting Time (T1) | 0x0006
IDN 7 | (S-0-0007) | Feedback Acquisition Capture Point | 0x0007
IDN 8 | (S-0-0008) | Command Value Valid Time | 0x0008
IDN 9 | (S-0-0009) | Position of Data Record in MDT | 0x0009
IDN 10 | (S-0-0010) | Length of MDT | 0x000A
IDN 15 | (S-0-0015) | Telegram Type Parameter | 0x000F
IDN 16 | (S-0-0016) | Configuration List of AT Cyclic Data | 0x0010
IDN 17 | (S-0-0017) | IDN List of All Operation Data | 0x0011
IDN 18 | (S-0-0018) | IDN List of Operation Data for CP2. | 0x0012
IDN 19 | (S-0-0019) | IDN List of Operation Data for CP3. | 0x0013
IDN 21 | (S-0-0021) | IDN List of Invalid Operation Data for CP2. | 0x0015
IDN 22 | (S-0-0022) | IDN List of Invalid Operation Data for CP3. | 0x0016
IDN 24 | (S-0-0024) | Configuration List of MDT Cyclic Data | 0x0018
IDN 25 | (S-0-0025) | IDN List of All Procedure Commands | 0x0019
IDN 28 | (S-0-0028) | MST Error Counter | 0x001C
IDN 29 | (S-0-0029) | MDT Error Counter | 0x001D
IDN 88 | (S-0-0088) | Receive to Receive Recovery Time | 0x0058
IDN 89 | (S-0-0089) | MDT Transmission Starting Time | 0x0059
IDN 90 | (S-0-0090) | Command Value Processing Time | 0x005A
IDN 96 | (S-0-0096) | Slave Arrangement | 0x0060
IDN 97 | (S-0-0097) | Class 2 Diagnostic Mask | 0x0061
IDN 98 | (S-0-0098) | Class 3 Diagnostic Mask | 0x0062
IDN 127 | (S-0-0127) | Procedure: Communication Phase 3 Transition Check | 0x007F
IDN 128 | (S-0-0128) | Procedure: Communication Phase 4 Transition Check | 0x0080
IDN 134 | (S-0-0134) | Master Control Word | 0x0086
IDN 135 | (S-0-0135) | Drive Status Word | 0x0087
IDN 143 | (S-0-0143) | SYSTEM Interface Version | 0x008F
IDN 185 | (S-0-0185) | Maximum Length of AT Configurable Data | 0x00B9
IDN 186 | (S-0-0186) | Maximum Length of MDT Configurable Data | 0x00BA
IDN 187 | (S-0-0187) | List of AT Configurable Data IDNs | 0x00BB
IDN 188 | (S-0-0188) | List of MDT Configurable Data IDNs | 0x00BC
IDN 304 | (S-0-0304) | Real-Time Status Bit 1 | 0x0130
IDN 305 | (S-0-0305) | Allocation of Real-time Status Bit 1 | 0x0131
IDN 306 | (S-0-0306) | Real-Time Status Bit 2 | 0x0132
IDN 307 | (S-0-0307) | Allocation of Real-time Status Bit 2 | 0x0133
IDN 3026 | (P-0-3026) | Non-Volatile Memory Data Checksum | 0x8BD2


AX2000-B750 General Information

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

General Information

AX2000-B750 Configuration

Configure the address, baud rate and optical power on the drive to operate properly with the SERCOS master. These values can be adjusted through a terminal emulator program such as Microsoft Windows® HyperTerminal (Start | Run ... type hypertrm.exe) by the use of the following commands.

  1. Change the desired parameters by using the commands ADDR, SBAUD and SLEN, as explained below.
  2. Type save to save the new values.
  3. Type coldstart to reset the amplifier.

Changing the Drive Address

In the terminal program, use the command ADDR #, where '#' is the new drive address. The SERCOS address can also be changed via key operation on the front panel of the AX2000-B750. (Please refer to the “Digital Servo Amplifier AX2000” manual, e.g. available from http://www.beckhoff.com/english/download/drives.htm). The drive address can be set between 0 and 63. An address of zero designates the drive as a repeater on the SERCOS ring.

Changing the Baud Rate and Optical Power

In the terminal program, change the SERCOS baud rate by using the command "SBAUD 2" for a baud rate of 2 MBaud or "SBAUD 4" for a baud rate of 4 MBaud. The default is 4 MBaud. Change the optical power by using the command SLEN #, where # is the length of plastic optical cable, in meters, from 1 to 45 meters. The default is 5 meters. This parameter can be used to set the optical range (in meters) for a standardized 1mm² plastic optical fiber cable (e.g. BECKHOFF part number "Z1101") Also new is the command SLEN 0 for very short lengths.

SLEN |
0 | very short connection
1…< 15 | Length of the connection of a 1mm plastic cable (e.g. BECKHOFF Z1101)
15…<30 | "
>= 30 | "

The baud rate and the optical power can also be changed via the so-called Drive software. Please refer to the user’s manual “Inbetriebnahme-Software SR600 für AX2000".
If the optical power is not adjusted properly, there will be errors in the telegram transmission, and the red error LED on the drive will light. In normal communication, the green transmit and receive LEDs will blink rapidly, causing the LEDs to appear faintly lit.

MDT CONTROL BITS 13 - 15

The following table gives a detailed description of the operation of the drive in regard to bits 13, 14 and 15 of the MDT Control Word. Please note that the three bits are ordered in the table according to priority.

Enable Drive | Drive On/Off | Halt/Restart | Description
14 | 15 | 13
0 | x | x | When the “Enable Drive” bit changes from 1 to 0, the power stage is disabled and the motor coasts to a stop.
1 | 0 | x | When the “Drive On/Off” bit changes from 1 to 0, the drive decelerates at the quick deceleration rate (P-0-3022). The power stage is disabled when the internal velocity command is zero and the velocity feedback is below 5 RPM.
1 | 1 | 0 | When the “Enable Drive” bit and the “Drive On/Off” bits are set, the power stage is enabled. When the “Halt/Restart” bit changes from 1 to 0, the drive decelerates at the acceleration limit value defined by S-0-0137 or S-0-0042.
1 | 1 | 1 | When the “Halt/Restart” bit changes from 0 to 1, the drive follows the master’s command values. In velocity mode, accelerations are limited by IDN 136 or IDN 137, and the velocity command is limited by S-0-0038, S-0-0039 or S-0-0091. In position mode, the drive monitors the position command and sets a fault if successive position commands exceed the velocity limit (S-0-0038, S-0-0039 or S-0-0091). In position mode, it is the master’s responsibility to limit successive position commands in order to maintain the desired acceleration and velocity limits.


IDN Set Supported by AX2000-B750

Ident Number | Sercos Parameter | Description | ADS IndexGroup (hex.)
IDN 1 | (S-0-0001) | Control unit Cycle time (t Ncyc) | 0x0001
IDN 2 | (S-0-0002) | Communication Cycle Time | 0x0002
IDN 3 | (S-0-0003) | Shortest AT Transmission Starting Time | 0x0003
IDN 4 | (S-0-0004) | Transmit/Receive Transition Time | 0x0004
IDN 5 | (S-0-0005) | Minimum Feedback Processing Time | 0x0005
IDN 6 | (S-0-0006) | AT Transmission Starting Time (T1) | 0x0006
IDN 7 | (S-0-0007) | Feedback Acquisition Capture Point | 0x0007
IDN 8 | (S-0-0008) | Command Value Valid Time | 0x0008
IDN 9 | (S-0-0009) | Position of Data Record in MDT | 0x0009
IDN 10 | (S-0-0010) | Length of MDT | 0x000A
IDN 11 | (S-0-0011) | Class 1 Diagnostic (C1D) | 0x000B
IDN 12 | (S-0-0012) | Class 2 Diagnostic (C2D) | 0x000C
IDN 13 | (S-0-0013) | Class 3 Diagnostic (C3D) | 0x000D
IDN 14 | (S-0-0014) | Interface Status | 0x000E
IDN 15 | (S-0-0015) | Telegram Type Parameter | 0x000F
IDN 16 | (S-0-0016) | Configuration List of AT Cyclic Data | 0x0010
IDN 17 | (S-0-0017) | IDN List of All Operation Data | 0x0011
IDN 18 | (S-0-0018) | IDN List of Operation Data for CP2. | 0x0012
IDN 19 | (S-0-0019) | IDN List of Operation Data for CP3. | 0x0013
IDN 21 | (S-0-0021) | IDN List of Invalid Operation Data for CP2. | 0x0015
IDN 22 | (S-0-0022) | IDN List of Invalid Operation Data for CP3. | 0x0016
IDN 24 | (S-0-0024) | Configuration List of MDT Cyclic Data | 0x0018
IDN 25 | (S-0-0025) | IDN List of All Procedure Commands | 0x0019
IDN 28 | (S-0-0028) | MST Error Counter | 0x001C
IDN 29 | (S-0-0029) | MDT Error Counter | 0x001D
IDN 30 | (S-0-0030) | Manufacturer Version | 0x001E
IDN 32 | (S-0-0032) | Primary Operation Mode | 0x0020
IDN 33 | (S-0-0033) | Secondary Operation Mode 1 | 0x0021
IDN 36 | (S-0-0036) | Velocity Command Value | 0x0024
IDN 38 | (S-0-0038) | Positive Velocity Limit Value | 0x0026
IDN 39 | (S-0-0039) | Negative Velocity Limit Value | 0x0027
IDN 40 | (S-0-0040) | Velocity Feedback Value | 0x0028
IDN 41 | (S-0-0041) | Homing Velocity | 0x0029
IDN 42 | (S-0-0042) | Homing Acceleration | 0x002A
IDN 43 | (S-0-0043) | Velocity Polarity Parameter | 0x002B
IDN 44 | (S-0-0044) | Velocity Data Scaling Type | 0x002C
IDN 45 | (S-0-0045) | Velocity Data Scaling Factor | 0x002D
IDN 46 | (S-0-0046) | Velocity Data Scaling Exponent | 0x002E
IDN 47 | (S-0-0047) | Position Command Value | 0x002F
IDN 49 | (S-0-0049) | Positive Position Limit Switch | 0x0031
IDN 50 | (S-0-0050) | Negative Position Limit Switch | 0x0032
IDN 51 | (S-0-0051) | Position Feedback Value 1 (Motor Feedback) | 0x0033
IDN 52 | (S-0-0052) | Reference Distance 1 | 0x0034
IDN 53 | (S-0-0053) | Position Feedback Value 2 (External Feedback) | 0x0035
IDN 54 | (S-0-0054) | Reference Distance 2 | 0x0036
IDN 55 | (S-0-0055) | Position Polarity Parameter | 0x0037
IDN 57 | (S-0-0057) | Position Window | 0x0039
IDN 59 | (S-0-0059) | Position Switch Flag Parameter | 0x003B
IDN 60 | (S-0-0060) | Position Switch Point 1 | 0x003C
IDN 61 | (S-0-0061) | Position Switch Point 2 | 0x003D
IDN 62 | (S-0-0062) | Position Switch Point 3 | 0x003E
IDN 63 | (S-0-0063) | Position Switch Point 4 | 0x003F
IDN 64 | (S-0-0064) | Position Switch Point 5 | 0x0040
IDN 65 | (S-0-0065) | Position Switch Point 6 | 0x0041
IDN 66 | (S-0-0066) | Position Switch Point 7 | 0x0042
IDN 67 | (S-0-0067) | Position Switch Point 8 | 0x0043
IDN 76 | (S-0-0076) | Position Data Scaling Type | 0x004C
IDN 77 | (S-0-0077) | Linear Position Data Scaling Factor | 0x004D
IDN 78 | (S-0-0078) | Linear Position Data Scaling Exponent | 0x004E
IDN 79 | (S-0-0079) | Rotational Position Resolution | 0x004F
IDN 80 | (S-0-0080) | Torque Command Value | 0x0050
IDN 84 | (S-0-0084) | Torque Feedback Value | 0x0054
IDN 86 | (S-0-0086) | Torque/Force Data Scaling Type | 0x0056
IDN 88 | (S-0-0088) | Receive to Receive Recovery Time | 0x0058
IDN 89 | (S-0-0089) | MDT Transmission Starting Time | 0x0059
IDN 90 | (S-0-0090) | Command Value Processing Time | 0x005A
IDN 91 | (S-0-0091) | Bipolar Velocity Limit | 0x005B
IDN 92 | (S-0-0092) | Bipolar Torque Limit | 0x005C
IDN 95 | (S-0-0095) | Diagnostic Message | 0x005F
IDN 96 | (S-0-0096) | Slave Arrangement | 0x0060
IDN 97 | (S-0-0097) | Class 2 Diagnostic Mask | 0x0061
IDN 98 | (S-0-0098) | Class 3 Diagnostic Mask | 0x0062
IDN 99 | (S-0-0099) | Procedure: Reset Class 1 Diagnostic | 0x0063
IDN 100 | (S-0-0100) | Velocity Loop Proportional Gain | 0x0064
IDN 101 | (S-0-0101) | Velocity Loop Integral Action Time | 0x0065
IDN 103 | (S-0-0103) | Modulo Value | 0x0067
IDN 104 | (S-0-0104) | Position Loop Proportional Gain | 0x0068
IDN 105 | (S-0-0105) | Position Loop Integral Action Time | 0x0069
IDN 106 | (S-0-0106) | Current Loop Proportional Gain 1 | 0x006A
IDN 107 | (S-0-0107) | Current Loop Integral Action Time 1 | 0x006B
IDN 108 | (S-0-0108) | Feedrate Override | 0x006C
IDN 109 | (S-0-0109) | Motor Peak Current | 0x006D
IDN 110 | (S-0-0110) | Amplifier Peak Current | 0x006E
IDN 111 | (S-0-0111) | Motor Continuous Stall Current | 0x006F
IDN 112 | (S-0-0112) | Amplifier Rated Current | 0x0070
IDN 113 | (S-0-0113) | Maximum Motor Speed | 0x0071
IDN 114 | (S-0-0114) | System Load Limit | 0x0072
IDN 116 | (S-0-0116) | Resolution of Rotational Feedback 1 (Motor Feedback) | 0x0074
IDN 117 | (S-0-0117) | Resolution of Rotational Feedback 2 (External Feedback) | 0x0075
IDN 119 | (S-0-0119) | Current Loop Proportional Gain 2 | 0x0077
IDN 120 | (S-0-0120) | Current Loop Integral Action Time 2 | 0x0078
IDN 121 | (S-0-0121) | Input revolutions of load gear | 0x0079
IDN 122 | (S-0-0122) | Output revolutions of load gear | 0x007A
IDN 123 | (S-0-0123) | Feed Constant | 0x007B
IDN 127 | (S-0-0127) | Procedure: Communication Phase 3 Transition Check | 0x007F
IDN 128 | (S-0-0128) | Procedure: Communication Phase 4 Transition Check | 0x0080
IDN 129 | (S-0-0129) | Manufacturer Class 1 Diagnostic (MC1D) | 0x0081
IDN 130 | (S-0-0130) | Probe 1 Positive Edge Value | 0x0082
IDN 131 | (S-0-0131) | Probe 1 Negative Edge Value | 0x0083
IDN 132 | (S-0-0132) | Probe 2 Positive Edge Value | 0x0084
IDN 133 | (S-0-0133) | Probe 2 Negative Edge Value | 0x0085
IDN 134 | (S-0-0134) | Master Control Word | 0x0086
IDN 135 | (S-0-0135) | Drive Status Word | 0x0087
IDN 136 | (S-0-0136) | Positive Acceleration Limit Value | 0x0088
IDN 137 | (S-0-0137) | Negative Acceleration Limit Value | 0x0089
IDN 140 | (S-0-0140) | (S-0-0140) | 0x008C
IDN 141 | (S-0-0141) | Motor Type | 0x008D
IDN 142 | (S-0-0142) | Application Type | 0x008E
IDN 143 | (S-0-0143) | SYSTEM Interface Version | 0x008F
IDN 147 | (S-0-0147) | Homing Parameter | 0x0093
IDN 148 | (S-0-0148) | Procedure: Drive Controlled Homing | 0x0094
IDN 159 | (S-0-0159) | Monitoring Window | 0x009F
IDN 160 | (S-0-0160) | Acceleration Data Scaling Type | 0x00A0
IDN 161 | (S-0-0161) | Acceleration Data Scaling Factor | 0x00A1
IDN 162 | (S-0-0162) | Acceleration Data Scaling Exponent | 0x00A2
IDN 169 | (S-0-0169) | Probe Control Parameter | 0x00A9
IDN 170 | (S-0-0170) | Procedure: Probing | 0x00AA
IDN 179 | (S-0-0179) | Probe Position Latch Status | 0x00B3
IDN 182 | (S-0-0182) | Manufacturer Class 3 Diagnostic (MC3D) | 0x00B6
IDN 185 | (S-0-0185) | Maximum Length of AT Configurable Data | 0x00B9
IDN 186 | (S-0-0186) | Maximum Length of MDT Configurable Data | 0x00BA
IDN 187 | (S-0-0187) | List of AT Configurable Data IDNs | 0x00BB
IDN 188 | (S-0-0188) | List of MDT Configurable Data IDNs | 0x00BC
IDN 189 | (S-0-0189) | Following Distance | 0x00BD
IDN 192 | (S-0-0192) | IDN List of Back-up Operation Data | 0x00C0
IDN 196 | (S-0-0196) | Motor Rated Current | 0x00C4
IDN 203 | (S-0-0203) | Amplifier Shutdown Temperature | 0x00CB
IDN 205 | (S-0-0205) | Cooling Error Shutdown Temperature | 0x00CD
IDN 208 | (S-0-0208) | Temperature Data Scaling Type | 0x00D0
IDN 257 | (S-0-0257) | Multiplication Factor 2 | 0x0101
IDN 262 | (S-0-0262) | Procedure: Load Default Values | 0x0106
IDN 264 | (S-0-0264) | Procedure: Back-up Working Memory | 0x0108
IDN 271 | (S-0-0271) | Drive ID | 0x010F
IDN 288 | (S-0-0288) | IDN List of Data Programmable in CP2 | 0x0120
IDN 289 | (S-0-0289) | IDN List of Data Programmable in CP3 | 0x0121
IDN 296 | (S-0-0296) | Velocity Feed Forward Gain | 0x0128
IDN 298 | (S-0-0298) | Home Switch Distance | 0x012A
IDN 301 | (S-0-0301) | Allocation of Real-time Control Bit 1 | 0x012D
IDN 303 | (S-0-0303) | Allocation of Real-time Control Bit 2 | 0x012F
IDN 304 | (S-0-0304) | Real-Time Status Bit 1 | 0x0130
IDN 305 | (S-0-0305) | Allocation of Real-time Status Bit 1 | 0x0131
IDN 306 | (S-0-0306) | Real-Time Status Bit 2 | 0x0132
IDN 307 | (S-0-0307) | Allocation of Real-time Status Bit 2 | 0x0133
IDN 323 | (S-0-0323) | Status “Target position outside of travel range” | 0x0143
IDN 336 | (S-0-0336) | Status “In Position” | 0x0150
IDN 380 | (S-0-0380) | DC Bus Voltage | 0x017C
IDN 384 | (S-0-0384) | Amplifier Temperature | 0x0180
IDN 392 | (S-0-0392) | Velocity Feedback Filter Time Constant | 0x0188
IDN 400 | (S-0-0400) | Home Switch Status | 0x0190
IDN 401 | (S-0-0401) | Probe 1 | 0x0191
IDN 402 | (S-0-0402) | Probe 2 | 0x0192
IDN 403 | (S-0-0403) | Position Feedback Status | 0x0193
IDN 405 | (S-0-0405) | Probe 1 Enable | 0x0195
IDN 406 | (S-0-0406) | Probe 2 Enable | 0x0196
IDN 409 | (S-0-0409) | Probe 1 Positive Edge Latched Status | 0x0199
IDN 410 | (S-0-0410) | Probe 1 Negative Edge Latched Status | 0x019A
IDN 411 | (S-0-0411) | Probe 2 Positive Edge Latched Status | 0x019B
IDN 412 | (S-0-0412) | Probe 2 Negative Edge Latched Status | 0x019C
IDN 3000 | (P-0-3000) | Configurable I/O: Digital Input 1 Mode | 0x8BB8
IDN 3001 | (P-0-3001) | Configurable I/O: Digital Input 2 Mode | 0x8BB9
IDN 3002 | (P-0-3002) | Configurable I/O: Digital Input 3 Mode | 0x8BBA
IDN 3003 | (P-0-3003) | Configurable I/O: Digital Input 4 Mode | 0x8BBB
IDN 3004 | (P-0-3004) | Position Switch Configuration | 0x8BBC
IDN 3005 | (P-0-3005) | Configurable I/O: Digital Output 1 Mode | 0x8BBD
IDN 3006 | (P-0-3006) | Configurable I/O: Digital Output 2 Mode | 0x8BBE
IDN 3007 | (P-0-3007) | Configurable I/O: Digital Output 1 Trigger | 0x8BBF
IDN 3008 | (P-0-3008) | Configurable I/O: Digital Output 2 Trigger | 0x8BC0
IDN 3010 | (P-0-3010) | Feedback Type | 0x8BC2
IDN 3011 | (P-0-3011) | Encoder Emulation Mode | 0x8BC3
IDN 3012 | (P-0-3012) | Difference Probe Edge Value 1 | 0x8BC4
IDN 3013 | (P-0-3013) | Difference Probe Edge Value 2 | 0x8BC5
IDN 3014 | (P-0-3014) | Probe Difference Control Parameter | 0x8BC6
IDN 3015 | (P-0-3015) | Hardware Limit Switch Consequence | 0x8BC7
IDN 3016 | (P-0-3016) | Reset Command Consequence | 0x8BC8
IDN 3018 | (P-0-3018) | Configuration of the Positionlatch | 0x8BCA
IDN 3019 | (P-0-3019) | Select of the FPGA Program | 0x8BCB
IDN 3020 | (P-0-3020) | System Rated Current | 0x8BCC
IDN 3021 | (P-0-3021) | Over Speed | 0x8BCD
IDN 3022 | (P-0-3022) | Quick Deceleration Rate | 0x8BCE
IDN 3026 | (P-0-3026) | Non-Volatile Memory Data Checksum | 0x8BD2
IDN 3027 | (P-0-3027) | Manufacturer Homing Modes | 0x8BD3
IDN 3030 | (P-0-3030) | Configurable I/O: Digital Input 1 Status | 0x8BD6
IDN 3031 | (P-0-3031) | Configurable I/O: Digital Input 2 Status | 0x8BD7
IDN 3032 | (P-0-3032) | Configurable I/O: Digital Input 3 Status | 0x8BD8
IDN 3033 | (P-0-3033) | Configurable I/O: Digital Input 4 Status | 0x8BD9
IDN 3034 | (P-0-3034) | Analog Input 1 Value | 0x8BDA
IDN 3035 | (P-0-3035) | Analog Input 2 Value | 0x8BDB
IDN 3036 | (P-0-3036) | Configurable I/O: Digital Output 1 Control/Status | 0x8BDC
IDN 3037 | (P-0-3037) | Configurable I/O: Digital Output 2 Control/Status | 0x8BDD
IDN 3038 | (P-0-3038) | Probe 1 and 2 Enable | 0x8BDE
IDN 3039 | (P-0-3039) | Probe 1 and 2 Control Parameter | 0x8BDF
IDN 3040 | (P-0-3040) | Interpolation Method | 0x8BE0
IDN 3041 | (P-0-3041) | Position Switch On/Off Parameter | 0x8BE1
IDN 3042 | (P-0-3042) | Position Switch Enable/Disable Parameter | 0x8BE2
IDN 3043 | (P-0-3043) | Position Switch Polarity Parameter | 0x8BE3
IDN 3044 | (P-0-3044) | Kind Of Position Switch Parameter | 0x8BE4
IDN 3045 | (P-0- 3045) | (P-0- 3045) | 0x8BE5
IDN 3046 | (P-0- 3046) | Motor Number | 0x8BE6


BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 1 (S-0-0001) Control unit Cycle time (t Ncyc)


IDN 2 (S-0-0002) Communication Cycle Time

The period at which MST, AT, and MDT telegrams are transmitted. The “Communication Cycle Time” (CCT) may be varied from 1 ms to 8 ms, in 1 ms increments. Linear interpolator is applied to the command every 250 (s when the CCT is 1, 2, 3 or 4 ms. For the interpolation method please refer to IDN 3040

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 1000 | Run-Up Check: | CP2
Maximum: | 8000 | Cyclic Transfer: |
Default: | 2000 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0002


IDN 3 (S-0-0003) Shortest AT Transmission Starting Time

The time required by the drive between the end of the MST and the beginning of the drive's AT.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 40 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0003


IDN 4 (S-0-0004) Transmit/Receive Transition Time

The time required by the drive between the end of the AT and the beginning of the next MDT.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 40 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0004


IDN 5 (S-0-0005) Minimum Feedback Processing Time

The time required by the drive for receiving and processing cyclic feedback. This time period is measured from the beginning of the feedback acquisition to the end of the next MST.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 200 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0005


IDN 6 (S-0-0006) AT Transmission Starting Time (T1)

The time at which the drive should transmit its AT during CP3 and CP4, measured from the end of the MST. The “AT Transmission Starting Time” must be downloaded from the master during CP2. IDN 6 is limited by the “Shortest AT Transmission Starting Time” ( IDN 3 ), the “MDT Transmission Starting Time” ( IDN 89 ) and the “Transmit/Receive Transition Time” ( IDN 4 ), according to the following equation:

IDN 3 < IDN 6 < IDN 89 – IDN 4

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | None | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0006


IDN 7 (S-0-0007) Feedback Acquisition Capture Point

The time at which the drive should latch the feedback values after the end of the MST. The “Feedback Acquisition Capture Point” is limited by the CCT ( IDN 2 ) and the “Minimum Feedback Processing Time” ( IDN 5 ) according to the following equation.

IDN 7 ( IDN 2 – IDN 5

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | IDN 2 – IDN 5 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0007


IDN 8 (S-0-0008) Command Value Valid Time

The time at which the drive is allowed to access the new command values after the MST. The “Command Value Valid Time” is limited by the “MDT Transmission Starting Time” ( IDN 89 ), the “Command Value Processing Time” ( IDN 90 ) and the CCT ( IDN 2 ) according to the following equation.

IDN 89 + MDT Transmission Time + IDN 90 < IDN 8 ( IDN 2

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | IDN 2 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0008


IDN 9 (S-0-0009) Position of Data Record in MDT

The offset of the drive's data record within the MDT. The offset is measured in bytes from the MDT's address field. The data record position within the MDT must be downloaded from the master during CP2 and becomes active during CP3. The value must be greater than zero and must be an odd number not exceeding 65531.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | None | Serial Equiv: |
Units: | Bytes | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0009


IDN 10 (S-0-0010) Length of MDT

The length of the MDT's data field, expressed in bytes. This length does not include the MDT delimiters, address field, or cyclic redundancy check (CRC). The MDT length must be downloaded from the master during CP2 and becomes active during CP3. The MDT length must be an even number, and it must be greater than or equal to 4, but not exceeding 65534.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | None | Serial Equiv: |
Units: | Bytes | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x000A


IDN 11 (S-0-0011) Class 1 Diagnostic (C1D)

The current fault status of the drive. When a fault occurs, the drive decelerates to a stop and is disabled. The C1D status bit (AT bit 13) is set, and the corresponding fault bits are set within IDN 11. All faults are latched within IDN 11 and are reset through the “Procedure: Reset Class 1 Diagnostic” ( IDN 99 ). IDN 99 performs a cold start automatically when required. Those faults which require a cold start are noted in the table below. The error messages which appear on the front panel of the drive are also shown below.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ERRCODE
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x000B
Definition:
Bit | Description | Coldstart | LED Error
LSB 0 | Overload fault ( IDN 114 ). | no | F15
1 | Amplifier over temperature fault ( IDN 203 ). | no | F01
2 | Motor over temperature fault. | yes | F06
3 | Cooling system fault ( IDN 205 ). | no | F13
4 | Control voltage fault ((15V). | yes | F07
5 | Feedback loss fault. | yes | F04
6 | Commutation fault. Set to 0. | yes | F25
7 | Over current fault. | yes | F14
8 | Over voltage fault. | no | F02
9 | Under voltage fault. | no | F05
10 | Power supply phase fault. | no | F12, F19
11 | Excessive position deviation ( IDN 159 ). | no | F03
12 | Communication interface fault ( IDN 14 ). | no | F29
13 | Software limit switch fault ( IDN 49 and 50). | no | F24
14 | Reserved. Set to 0. |  |
MSB 15 | Manufacturer defined fault ( IDN 129 ). | IDN 129 |


IDN 12 (S-0-0012) Class 2 Diagnostic (C2D)

Warning flags that may indicate an impending shutdown. When an unmasked warning condition changes state , the corresponding warning bits are changed within IDN 12, and the C2D change bit (AT status word, bit 12) is set. The warning bits within IDN 12 are not latched and will automatically reset when the warning condition is no longer valid. The C2D change bit is reset when IDN 12 is read through the service channel. IDN 97 may be used to mask warnings and their affect on the C2D change bit.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x000C
Definition:
Bit | Description
LSB 0 | Overload warning ( IDN 114 and 310).
1 | Reserved: Amplifier over temperature warning.
2 | Reserved: Motor over temperature warning ( IDN 312 ).
3 | Reserved: Cooling system warning (set to 0).
4 | Reserved.
5 | Reserved: Positioning velocity ( n Limit ( IDN 315 ).
6 | Reserved.
7 | Reserved.
8 | Reserved.
9 | Reserved.
10 | Reserved.
11 | Reserved.
12 | Reserved.
13 | Target position outside of travel range ( IDN 323 ).
14 | Reserved.
MSB 15 | Reserved: Manufacturer defined warning flags ( IDN 181 ).


IDN 13 (S-0-0013) Class 3 Diagnostic (C3D)

Status flags for the drive. When an unmasked status condition changes state, the corresponding status bit changes within IDN 13, and the C3D change bit (AT status word, bit 11) is set. The status bits within IDN 13 are not latched and will automatically reset when the status condition is no longer valid. The C3D change bit is reset when IDN 13 is read through the service channel. IDN 98 may be used to mask particular status conditions and their affect on the C3D change bit.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x000D
Definition:
Bit | Description
LSB 0 | Reserved: Nfdbk = Ncmd ( IDN 330 ).
1 | Reserved: Nfdbk = 0 ( IDN 124 and IDN 331 ).
2 | Reserved: |Nfdbk| < |N threshold| ( IDN 332 ).
3 | Reserved: |Torque| ( |Torque threshold| ( IDN 333 ).
4 | Reserved: |Torque| ( |Torque limit| ( IDN 334 ).
5 | Reserved: |Ncmd| > |N limit| ( IDN 335 ).
6 | In Position ( IDN 57 and IDN 336 ).
7 | Reserved: |Power| ( |Power threshold| ( IDN 337 ).
8 | Reserved.
9 | Reserved: |Nfdbk| ( Min spindle speed ( IDN 339 ).
10 | Reserved: |Nfdbk| ( Max spindle speed ( IDN 340 ).
11 | Reserved: In Coarse Position ( IDN 341 ).
12 | Reserved: Target Position Attained ( IDN 342 )
13 | Reserved: Interpolator Halted ( IDN 343 ).
14 | Reserved.
MSB 15 | Manufacturer defined status flags ( IDN 182 ).


IDN 14 (S-0-0014) Interface Status

The communication phase (CPx) and communication fault flags. In the event of a communication fault the drive decelerates to a stop and is disabled, and the drive's communication phase returns to 0. The communication interface fault summary bit ( IDN 11 , bit 12) is set. The cause of the communication fault is latched within IDN 14 along with the communication phase in which the fault occurred. The master may retrieve this information from the drive by reading IDN 14 before issuing a “Reset Class 1 Diagnostic” procedure ( IDN 99 ).

If both bit 3 and bit 4 (MST and MDT failures) are set, this could indicate a signal loss (e.g. a broken optical fiber cable). In this case, the MST and MDT error counters ( IDN 28 and IDN 29 ) will not be incremented.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x000E
Definition:
Bit | Description
2 – 0 | Communication Phase (CPx).
3 | MST failure.
4 | MDT failure.
5 | Invalid phase (CP > 4)
6 | Error during phase advance.
7 | Error during phase regression.
8 | Reserved: Phase switch without proper acknowledgment.
9 | Switching to an uninitialized operation mode.
10 | Reserved: Duplicate drive addresses.
11 - 15 | Reserved.


IDN 15 (S-0-0015) Telegram Type Parameter

The master uses IDN 15 to select the contents of the AT and MDT cyclic data fields. Selecting a pre-defined or standard telegram type completely defines the contents and order of cyclic data within the AT and MDT. Within IDN 15, the ServoSTAR 600 supports values 1 through 7 (indicated in bold-face type in the table below). Telegram type 7, or the application type telegram, allows the master to define the contents and order of the AT and MDT cyclic data. The IDNs that may be transferred as cyclic data within the AT and MDT are listed in IDN 187 and IDN 188 respectively. The maximum amount of AT and MDT cyclic data that the drive can transfer is specified in IDN 185 and IDN 186 respectively. When the application telegram is selected, the master writes the desired cyclic data IDNs for the AT into IDN 16 and for the MDT into IDN 24 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | 4 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x000F
Definition:
IDN 15 Value | Telegram Type | Telegram Cyclic Data
 |  | MDT (Commands) | AT (Feedback)
0 | Standard telegram 0 | Reserved: None | Reserved: None
1 | Standard telegram 1 | Torque ( IDN 80 ) | None
2 | Standard telegram 2 | Velocity ( IDN 36 ) | Velocity ( IDN 40 )
3 | Standard telegram 3 | Velocity ( IDN 36 ) | Motor Position ( IDN 51 )
 |  |  | External Position ( IDN 53 )
4 | Standard telegram 4 | Position ( IDN 47 ) | Motor Position ( IDN 51 )
 |  |  | External Position ( IDN 53 )
5 | Standard telegram 5 | Pos/Vel ( IDN 47 /36) | Motor Pos/Vel ( IDN 51 /40)
13 |  |  | External Pos/Vel ( IDN 53 /40)
6 | Standard telegram 6 | Velocity ( IDN 36 ) | None
7 | Application telegram | Contents defined in IDN 24 | Contents defined in IDN 16


IDN 16 (S-0-0016) Configuration List of AT Cyclic Data

An IDN list of the AT's cyclic data. The master fills this list with IDNs in CP2 selected from a list of configurable AT data ( IDN 187 ) when an application telegram has been selected through IDN 15 .

Data Length: | 2 byte elements, variable length array | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | Empty list. | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0010


IDN 17 (S-0-0017) IDN List of All Operation Data

An IDN list of all data IDNs that are supported by the drive.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0011


IDN 18 (S-0-0018) IDN List of Operation Data for CP2.

An IDN list of all data that must be written by the master during CP2. The drive's CP2 to CP3 transition procedure ( IDN 127 ) will fail if this data is not supplied by the master. IDN 16 and IDN 24 are not included in this list, but they need to be written by the master in CP2 if the application telegram (type 7) is selected. If IDN 16 and IDN 24 are not written during CP2, then the application telegram will be empty.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0012


IDN 19 (S-0-0019) IDN List of Operation Data for CP3.

An IDN list of all data that must be written by the master during CP3. The drive's CP3 to CP4 transition procedure ( IDN 128 ) will fail if this data is not supplied by the master.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0013


IDN 21 (S-0-0021) IDN List of Invalid Operation Data for CP2.

A list of all IDNs which are considered invalid by the CP2 to CP3 transition procedure ( IDN 127 ).

Data Length: | 2 byte elements, variable length array | Non-Volatile: | No
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | Empty list. | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0015


IDN 22 (S-0-0022) IDN List of Invalid Operation Data for CP3.

A list of all IDNs which are considered invalid by the CP3 to CP4 transition procedure ( IDN 128 ).

Data Length: | 2 byte elements, variable length array | Non-Volatile: | No
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | Empty list. | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0016


IDN 24 (S-0-0024) Configuration List of MDT Cyclic Data

An IDN list of the MDT's cyclic data. The master fills this list with IDNs selected from a list of configurable MDT data ( IDN 188 ) when an application telegram has been selected through IDN 15 .

Data Length: | 2 byte elements, variable length array | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | Empty list. | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0018


IDN 25 (S-0-0025) IDN List of All Procedure Commands

An IDN list of all procedure IDNs that are supported by the drive.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0019


IDN 28 (S-0-0028) MST Error Counter

A count of all invalid MSTs in CP3 and CP4. In the case where more than two consecutive MST’s are invalid, only two are counted, and the drive returns to CP0. The MST error counter counts to a maximum of 65535 and does not roll over to 0. If a value of 65535 is in the counter, there may have been a noisy transmission over a long period of time. The MST error counter is cleared on the transition from CP2 to CP3.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x001C


IDN 29 (S-0-0029) MDT Error Counter

A count of all invalid MDTs in CP4. In the case where more than two consecutive MDTs are invalid, only two are counted, and the drive returns to CP0. The MDT error counter counts to a maximum of 65535 and does not roll over to 0. If a value of 65535 is in the counter, there may have been a noisy transmission over a long period of time. The MDT error counter is cleared on the transition from CP2 to CP3.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x001D


IDN 30 (S-0-0030) Manufacturer Version

A text string of the SERCOS firmware version.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | VER *
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x001E


IDN 32 (S-0-0032) Primary Operation Mode

Defines the drive's operational mode when the AT status word bits 8 and 9 are both 0. The master requests a particular operation mode through the MDT control word (bits 8 and 9). The master can switch between the operation modes defined within this IDN and the mode defined within the secondary operation mode 1 ( IDN 33 ) with this bits in realtime. Switch into position control during fast moving, could result a jerk. The following table may be used to define the primary operation mode. All reserved bits are not supported and must be zero. When the drive powers-up the operational mode is undefined, and the master must define a primary operational mode in CP3. The gain for bit 3 is defined by IDN 296 , Velocity Feed Forward Gain. It is not possible to select position control with motor feedback in IDN 32 and position control using external feedback in IDN 33 , also the reverse setting of this IDNs is not possible and will be checked by the drive (refer to IDN 117 ). For position control with external feedback 2, all position data, e.g. also IDN 51 , are used for the external feedback.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: | CP3
Maximum: |  | Cyclic Transfer: |
Default: | 3 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS:VE:CT | ADS Index Group (hex.): | 0x0020
Definition:
Bit | Value | Description
3 – 0 | 0000 | Reserved: No mode of operation.
 | 0001 | Torque control
 | 0010 | Velocity control
 | x011 | Position control using motor feedback.
 | x100 | Position control using external feedback.
 | x101 | Reserved: Position control using motor and external feedback.
3 | 0 | Position control with following error.
 | 1 | Position control without following error ( IDN 296 ).
4 – 13 | 0 | Reserved.
14 | 0 | Command values are issued as cyclic data.
 | 1 | Reserved: Command values are issued through service channel.
15 | 0 | Bits 0-14 are as defined above.
 | 1 | Reserved: Bits 0-14 are defined by the manufacturer.


IDN 33 (S-0-0033) Secondary Operation Mode 1

Defines the drive's operational mode when the AT status word bit 9 is clear and bit 8 is set. The master requests a particular operation mode through the MDT control word (bits 8 and 9). The master can switch between the operation modes defined within this IDN and the mode defined within the primary operation mode ( IDN 32 ) with this bits in realtime. Switch into position control during fast moving, could result a jerk. The following table may be used to define the secondary operation mode 1. All reserved bits are not supported and must be zero. The gain for bit 3 is defined by IDN 296 , Velocity Feed Forward Gain. It is not possible to select position control with motor feedback in IDN 32 and position control using external feedback in IDN 33, also the reverse setting of this IDNs is not possible and will be checked by the drive (refer to IDN 117 ). For position control with external feedback 2, all position data, e.g. also IDN 51 , are used for the external feedback.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: | CP3
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS:VE:CT | ADS Index Group (hex.): | 0x0021
Definition:
Bit | Value | Description
3 - 0 | 0000 | No mode of operation.
 | 0001 | Torque control
 | 0010 | Velocity control
 | x011 | Position control using motor feedback.
 | x100 | Position control using external feedback.
 | x101 | Reserved: Position control using motor and external feedback.
3 | 0 | Position control with following error.
 | 1 | Position control without following error ( IDN 296 ).
4 - 13 | 0 | Reserved.
14 | 0 | Command values are issued as cyclic data.
 | 1 | Reserved: Command values are issued through service channel.
15 | 0 | Bits 0-14 are as defined above.
 | 1 | Reserved: Bits 0-14 are defined by the manufacturer.


IDN 36 (S-0-0036) Velocity Command Value

The master issues the velocity command to the drive through IDN 36. The velocity scaling type is fixed ( IDN 44 ), and the scaling parameters are adjustable ( IDN 45 and 46).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: |  | Serial Equiv: | J
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0024


IDN 38 (S-0-0038) Positive Velocity Limit Value

Establishes the maximum acceptable velocity command in the positive direction. In velocity mode and during homing, velocity commands that exceed the positive velocity limit are clamped to the positive velocity limit. In position mode, the velocity is monitored, and if the positive velocity exceeds the positive velocity limit, a fault is generated ( IDN 129 , bit 10).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed Decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | IDN 113 | Cyclic Transfer: |
Default: | 3000 RPM | Serial Equiv: |
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0026


IDN 39 (S-0-0039) Negative Velocity Limit Value

Establishes the maximum acceptable velocity command in the negative direction. In velocity mode and during homing, velocity commands that exceed the negative velocity limit are clamped to the negative velocity limit. In position mode, the velocity is monitored, and if the negative velocity exceeds the negative velocity limit, a fault is generated ( IDN 129 , bit 10).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed Decimal | Write Access: | CP2, CP3, CP4
Minimum: | – IDN 113 | Run-Up Check: |
Maximum: | 0 | Cyclic Transfer: |
Default: | – 3000 RPM | Serial Equiv: | VLIMN
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0027


IDN 40 (S-0-0040) Velocity Feedback Value

The master retrieves the velocity feedback from the drive through IDN 40. The velocity scaling type is fixed ( IDN 44 ), and the scaling parameters are adjustable ( IDN 45 and 46).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | V
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0028


IDN 41 (S-0-0041) Homing Velocity

The drive's velocity during the “Drive-Controlled Homing” procedure command ( IDN 148 ). The actual homing velocity may be limited by the Bipolar, Positive, or Negative Velocity Limit Values ( IDN 91 , 38, 39 respectively). The velocity scaling type is fixed ( IDN 44 ), and the scaling parameters are adjustable ( IDN 45 and 46).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 231 – 1 | Cyclic Transfer: |
Default: | 23 RPM | Serial Equiv: | VREF*32 / (140 * IDN 45 * 10 IDN 46 )
Units: | IDN 44 , 45, 46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | PS:VE | ADS Index Group (hex.): | 0x0029


IDN 42 (S-0-0042) Homing Acceleration

The drive's maximum acceleration and deceleration during the “Drive Controlled Homing” procedure ( IDN 148 ). The homing acceleration is defined as the number of milliseconds to reach the homing velocity.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 1 | Run-Up Check: |
Maximum: | 32767 | Cyclic Transfer: |
Default: | 10 | Serial Equiv: | ACCR, DECR
Units: | IDN 160 , 161, 162 | Version: | 5.04
IDN Type: | PS:AD | ADS Index Group (hex.): | 0x002A


IDN 43 (S-0-0043) Velocity Polarity Parameter

The velocity polarity parameter is used to switch the polarities of velocity data. Polarities are not switched internally but externally, this means on the in- and output of a closed loop system. The motor shaft turns clockwise when there is a positive velocity command and no inversion.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2
Minimum: | 0 | Run-Up Check: |
Maximum: | 0005H | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SERCSET (bits 12-15)
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x002B
Definition:
Bit |  | Description
0 | Velocity command value | 0 = non-inverted
 |  | 1 = inverted
1 | Reserved: Additive velocity command value | 0 = non-inverted
 |  | 1 = Reserved (inverted)
2 | Velocity feedback value | 0 = non-inverted
 |  | 15-7


IDN 44 (S-0-0044) Velocity Data Scaling Type

Defines the scaling options for all velocity data. The scaling types which are supported are indicated in bold-face type. If preferred rotational scaling is selected, the velocity scaling factor ( IDN 45 ) will set to 1 and the velocity data scaling exponent ( IDN 46 ) will set to –4 (refer to IDN 45 and 46).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: | 0002H | Run-Up Check: |
Maximum: | 000AH | Cyclic Transfer: |
Default: | 000AH | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x002C
Definition:
Bit |  | Description
2 – 0 | Scaling Method | 000 = Reserved: No Scaling
 |  | 001 = Reserved: Linear Scaling
 |  | 010 = Rotational Scaling
3 | Standard Scaling Type | 0 = Preferred Scaling
 |  | 1 = Parameter Scaling
4 | Units for Linear Scaling | 0 = Meters (m)
 |  | 1 = Inches (in)
4 | Units for Rotational Scaling | 0 = Revolutions (R)
 |  | 1 = Reserved
5 | Time Units | 0 = Minutes (min)
 |  | 1 = Reserved: Seconds (s)
6 |  |
15-7 | Reserved. |


IDN 45 (S-0-0045) Velocity Data Scaling Factor

The scaling factor for all velocity data in the drive. The exponent is defined with IDN 46 , so that the LSB weight of all rotational velocity data is derived from the following equation:

The scaling may be defined within the following range: 1x10-5 to 1x100. IDN 45 and IDN 46 must be integers. If preferred rotational scaling is selected in IDN 44 , the velocity scaling factor (IDN 45) and the velocity data scaling exponent ( IDN 46 ) will fixed set to there default values (refer to IDN 44 ). By the velocity scaling it is possible to get a rounding error in the LSBits.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 1 | Run-Up Check: |
Maximum: | 10-( IDN 46 ) | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x002D


IDN 46 (S-0-0046) Velocity Data Scaling Exponent

The scaling exponent for all velocity data in the drive. Refer to IDN 45 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3
Minimum: | – 5 | Run-Up Check: |
Maximum: | – log ( IDN 45 ) | Cyclic Transfer: |
Default: | – 4 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x002E


IDN 47 (S-0-0047) Position Command Value

The master issues position commands to the drive as cyclic data through IDN 47. Position commands written via the service channel do not take affect. The “Position Command Value” has a fixed scaling type ( IDN 76 ) and a fixed resolution ( IDN 79 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: |  | Serial Equiv: |
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x002F


IDN 49 (S-0-0049) Positive Position Limit Switch

This IDN defines the maximum position in positive direction. The positive position limit switch is active, when the limit switch is enabled (Refer to IDN 55 and IDN 3004 ). If linear scaling is selected in IDN 76 , the positive limit switch will be automatically calculated, with the feed constant IDN 123 and enabled with the enable bit in IDN 55 . When the position command value reaches the limit switch, the drive decelerates to a stop and in the LED the error “F24” ant the warning “n07” are flashing and the fault bit 13 in IDN 11 and also the warning bits in IDN 323 and IDN 12 Bit 13 are set. With linear position scaling the maximum value is 1024 feed constant.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | -231+1 | Run-Up Check: |
Maximum: | 231-1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SWE2
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0031


IDN 50 (S-0-0050) Negative Position Limit Switch

This IDN defines the minimum position in negative direction. The positive position limit switch is active, when the limit switch is enabled (Refer to IDN 55 and IDN 3004 ). If linear scaling is selected in IDN 76 , the positive limit switch will be automatically calculated, with the feed constant IDN 123 and enabled with the enable bit in IDN 55 . When the position command value reach the limit switch, the drive decelerate to a stop and in the LED the error “F24” ant the warning “n06” are flashing and the fault bit 13 in IDN 11 and also the warning bits in IDN 323 and IDN 12 Bit 13 are set. With linear position scaling the maximum value is 1024 feed constant.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | -231+1 | Run-Up Check: |
Maximum: | 231-1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SWE1
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0032


IDN 51 (S-0-0051) Position Feedback Value 1 (Motor Feedback)

The master retrieves the motor's position feedback from the drive through IDN 51. The scaling type and the resolution will be defined within IDN 76 , 77, 78 and 79.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | PFB
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0033


IDN 52 (S-0-0052) Reference Distance 1

The distance from the machine zero point to the home position, referenced through the motor feedback.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | – 231 + 1 | Run-Up Check: |
Maximum: | 231 – 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ROFFS
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0034


IDN 53 (S-0-0053) Position Feedback Value 2 (External Feedback)

The external position feedback of the drive from an external rotary encoder, in rotational position resolution within IDN 79 . For linear position scaling this IDN is in counts, not in SERCOS units (refer to IDN 76 and 79).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | PFB0
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0035


IDN 54 (S-0-0054) Reference Distance 2

The distance from the machine zero point to the home position for the secondary feedback. If homing is done the position feedback value 2 ( IDN 53 ) contains the value of this IDN (refer to 148).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | – 231 + 1 | Run-Up Check: |
Maximum: | 231 – 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ROFFS0
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0036


IDN 55 (S-0-0055) Position Polarity Parameter

The position polarity parameter is used to switch the polarities of position data. Polarities are not switched internally but externally, this means on the in- and output of a closed loop system. The motor shaft turns clockwise when there is a positive position command difference and no inversion. Bit 4 disable or enable the SW-Limit switches. If linear scaling of the position data is selected (refer to IDN 76 ), these Bit will automatic set and it is not possible to disable the position limit values (refer to IDN 49 and 50). If the Position limit switches are set, the drive set a software limit switch fault (Bit 13 in IDN 11 ), if the drive reach the not allowed area. A new value in bit 4 will not become active until the parameter is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2
Minimum: | 0 | Run-Up Check: |
Maximum: | 001D H | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SERCSET (Bits 4 - 11)
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0037
Definition:
Bit |  | Description
0 | Position command value | 0 = non-inverted 1 = inverted
1 | Reserved: Additive position command value | 0 = non-inverted 1 = Reserved (inverted)
2 | Position feedback value 1 | 0 = non-inverted 1 = inverted
3 | Position feedback value 2 | 0 = non-inverted 1 = inverted
4 | Position limit values | 0 = disabled 1 = enabled
15-5 | Reserved |


IDN 57 (S-0-0057) Position Window

Defines the maximum absolute distance between the position command value and the position feedback value. When the following error is within the “Position Window,” the drive sets the status flag “In Position” ( IDN 13 , bit 6). This function is only active while the drive is in position control. The “In Position” flag may be selected as a RTS bit through IDN 336 (refer to IDN 159 , 189, 336).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 7FFF FFFF | Serial Equiv: |
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0039


IDN 59 (S-0-0059) Position Switch Flag Parameter

The position switch flag parameter depends on the position feedback value, the settings of the “Position Switch Polarity Parameter” ( IDN 3043 and the “Kind of Position Switch Parameter” ( IDN 3044 . The behavior of the position switch flag bits are described below (please refer also to the IDN 3043 and IDN 3044 ). A digital output may also be configured to duplicate a position switch flag through the “Digital Output 1 Mode” ( IDN 3005 ), the “Digital Output 1 Trigger” ( IDN 3007 ), the “Digital Output 2 Mode” ( IDN 3006 ) and the “Digital Output 2 Trigger” ( IDN 3008 ).

The corresponding bits of IDN 3043 and IDN 3044 are set to “0”, which is the default. Then the associated flag bit is set to “0” if the position feedback value is smaller than the position switching point. The associated flag is set to “1” if the position feedback value is greater than or equal to the position switching point.

The corresponding bits of IDN 3043 is set to “1” and of IDN 3044 is set to “0”. Then the associated flag bit is set to “1” if the position feedback value is smaller than the position switching point. The associated flag is set to “0” if the position feedback value is greater than or equal to the position switching point

If the corresponding bit of IDN 3044 is set to “1”, then the associated flag is checked once according to the polarity setting of IDN 3043 and latched till the associated flag is enabled again.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: | 0000H | Run-Up Check: |
Maximum: | 00FFH | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | M POSRSTAT
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003B
Definition:
Bit | Description
LSB 0 | Position switch point 1 ( IDN 60 )
1 | Position switch point 2 ( IDN 61 )
2 | Position switch point 3 ( IDN 62 )
3 | Position switch point 4 ( IDN 63 )
4 | Position switch point 5 ( IDN 64 )
5 | Position switch point 6 ( IDN 65 )
6 | Position switch point 7 ( IDN 66 )
7 | Position switch point 8 ( IDN 67 )
8 – 15 | Reserved.


IDN 60 (S-0-0060) Position Switch Point 1

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003C


IDN 61 (S-0-0061) Position Switch Point 2

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003D


IDN 62 (S-0-0062) Position Switch Point 3

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003E


IDN 63 (S-0-0063) Position Switch Point 4

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x003F


IDN 64 (S-0-0064) Position Switch Point 5

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0040


IDN 65 (S-0-0065) Position Switch Point 6

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0041


IDN 66 (S-0-0066) Position Switch Point 7

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0042


IDN 67 (S-0-0067) Position Switch Point 8

Each position switch point IDN defines a feedback position that determines the state of a corresponding position status flag within IDN 59 (refer to IDN 59 ).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT (60 + 61)
Default: | 0 | Serial Equiv: | P1, P2, P3, P4, P5, P6, P7 and P8
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0043


IDN 76 (S-0-0076) Position Data Scaling Type

Defines the scaling options for all position data. The supported scaling types are indicated in bold-face type. The following scaling types are available : 0001(Hex), 0081(Hex), 0009(Hex), 0089(Hex), 000A(Hex) and 008A(Hex). If linear scaling is selected without modulo format on (bit 7 = 1), the software limit switches are automatic switched on (refer to IDN 49 , 50, 55 and IDN 3004 ). If modulo format is selected, the drive operates without interpolation. If rotational scaling is selected and the rotational position resolution ( IDN 79 ) is different from 1048576 or 65536 the modulo format must switch on, this will check during run up. A change of bit 7 will initiate a warm start procedure (refer to IDN 128 during run up. With set the operation mode within IDN 32 or 33 to position control with external feedback, this IDN will set to 004A(Hex) as a fixed setting. The drive can only operate with a fixed rotational scaling for the position data in this case (refer to IDN 79 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2
Minimum: | 0001H | Run-Up Check: | CP3
Maximum: | 008AH | Cyclic Transfer: |
Default: | 000AH | Serial Equiv: | SERCSET (Bits 24 – 31)
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x004C
Definition:
Bit | Description | Value | Description
2 - 0 | Scaling Method | 000 001 010 | Reserved: No Scaling Linear Scaling Rotational Scaling
3 | Standard Scaling Type | 0 1 | Preferred Scaling Parameter Scaling
4 | Reserved: Units for Linear Scaling | 0 1 | Meters (m) Inches (in)
4 | Units for Rotational Scaling | 0 1 | Degrees Reserved
5 | Reserved |  |
6 | Data Reference | 0 1 | At the Motor Shaft At the Load (Only for rotational scaling)
7 | Processing Format | 0 1 | Absolute Format Modulo Format (See IDN 103 )
15-8 | Reserved |  |


IDN 77 (S-0-0077) Linear Position Data Scaling Factor

This parameter defines the scaling factor for all position data in the drive, when linear scaling in IDN 76 is selected.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x004D


IDN 78 (S-0-0078) Linear Position Data Scaling Exponent

This parameter defines the scaling exponent for all position data in the drive, when linear scaling in IDN 76 is selected. Refer to IDN 77 .

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | -7 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x004E


IDN 79 (S-0-0079) Rotational Position Resolution

The rotational position resolution for all position data in the drive. The LSB weight of rotational position data is determined by the following equation:

If the rotational position resolution is different from 65536 or 1048576, it is necessary that the modulo format is switched on in IDN 76 . Only the values 65536 and 1048576 could save in the non-volatile memory. If position control with external feedback is selected, the drive will calculate the rotational position resolution with the resolution of the rotational feedback 2 ( IDN 117 ). This value for IDN 79 is then write protected and could only read by the master. By using parameter 121 and 122 the minimum changes to min: 100 x ( IDN 122 / IDN 121 )and the maximum to max: 100 000 000 x ( IDN 122 / IDN 121 )

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 100 | Run-Up Check: |
Maximum: | 100 000 000 | Cyclic Transfer: |
Default: | 1048576 | Serial Equiv: | PRBASE
Units: | Counts / Revolution | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x004F


IDN 80 (S-0-0080) Torque Command Value

The master issues torque commands to the drive as cyclic data through IDN 80. Torque commands written via the service channel do not take affect.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: |  | Serial Equiv: | ICMD ( (1000 / MICONT)
Units: | IDN 86 | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0050


IDN 84 (S-0-0084) Torque Feedback Value

The master retrieves the motor's torque feedback from the drive through IDN 84.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | I ( (1000 / MICONT)
Units: | IDN 86 | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0054


IDN 86 (S-0-0086) Torque/Force Data Scaling Type

Defines the scaling options for all torque or force data. The scaling types which are supported are indicated in bold-face type. The weight of the LSB for percentage scaling is defined as 0.1% of the motor’s continuous current ( IDN 111 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0056
Definition:
Bit |  | Description
2 – 0 | Scaling Method | 000=Percentage Scaling 001=Reserved: Linear Scaling 010=Reserved: Rotational Scaling
3 | Reserved: Standard Scaling Type | 0=Preferred Scaling 1=Parameter Scaling
4 | Reserved: Units for Force | 0=Newton (N) 1=Pound Force (lbf)
4 | Reserved: Units for Torque | 0=Newton-Meter (Nm) 1=Inch Pound-Force (in-lbf)
5 | Reserved |
6 | Data Reference | 0=At the Motor Shaft 1=Reserved: At the Load
15-7 | Reserved |


IDN 88 (S-0-0088) Receive to Receive Recovery Time

The time required by the drive between the end of the MDT and the beginning of the MST.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 50 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0058


IDN 89 (S-0-0089) MDT Transmission Starting Time

The time at which the master should transmit the MDT, after the end of the MST, during CP3 and CP4. The MDT Transmission Starting Time must be downloaded from the master during CP2. The “MDT Transmission Starting Time” is limited by the CCT ( IDN 2 ), the “Transmit/Receive Transmission Time” ( IDN 4 ) the “AT Transmission Starting Time” ( IDN 6 ) and the “Receive to Receive Recovery Time” ( IDN 88 ) according to the following restrictions.

IDN 89 ( IDN 6 + AT Transmission Time + AT Jitter + IDN 4 + MDT Jitter

IDN 89 ( IDN 2 – max IDN 88 from all drives – MDT Transmission Time

– MST Transmission Time – MDT Jitter – CCT Jitter

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: |  | Run-Up Check: | CP2
Maximum: |  | Cyclic Transfer: |
Default: | None | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0059


IDN 90 (S-0-0090) Command Value Processing Time

The minimum time required by the drive from the end of the MDT to the point at which the received command values may be used by the drive.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 50 | Serial Equiv: |
Units: | µs | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x005A


IDN 91 (S-0-0091) Bipolar Velocity Limit

Establishes the maximum acceptable velocity command in both the clockwise and counter-clockwise directions. In velocity mode and during homing, velocity commands that exceed the bipolar velocity limit are clamped to the bipolar velocity limit. In position mode, the velocity is monitored, and if the velocity exceeds the bipolar velocity limit, a fault is generated ( IDN 129 , bit 10).

The “Bipolar Velocity Limit” (IDN 91) is linked to the “Positive and Negative Velocity Limit Values” ( IDN 38 and IDN 39 ). When a value is written to IDN 91, the same value is also written to IDN 38 and IDN 39 (with the appropriate signs). IDN 38 and IDN 39 must have the same absolute value in order for IDN 91 to be valid. If they do not have the same absolute value when IDN 91 is read, then the drive will return error message 7008, “Invalid Data” for IDN 91.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | IDN 113 | Cyclic Transfer: |
Default: | 3000 RPM | Serial Equiv: | VLIM, VLIMN
Units: | IDN 44 ,45,46 (Default: RPM / 10 000) | Version: | 5.04
IDN Type: | VE:FS | ADS Index Group (hex.): | 0x005B


IDN 92 (S-0-0092) Bipolar Torque Limit

Defines the maximum torque limit in both the clockwise and counter-clockwise directions.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | Minimum of IDN 109 and IDN 110 | Cyclic Transfer: |
Default: | Minimum of IDN 109 and IDN 110 | Serial Equiv: | (IPEAK)
Units: | IDN 86 | Version: | 5.04
IDN Type: | CT:FS | ADS Index Group (hex.): | 0x005C


IDN 95 (S-0-0095) Diagnostic Message

The master may read a text message that describes the status of the drive.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | No
Data Type: | Text | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | SSTAT
Units: |  | Version: | 5.04
IDN Type: | FS:MT | ADS Index Group (hex.): | 0x005F


IDN 96 (S-0-0096) Slave Arrangement

The SERCOS address of the drive is contained in both the upper and lower bytes of this IDN. The drive’s address may range from 0 to 63 and may be selected through the front panel of the drive. A drive with an address of zero is a repeater on the SERCOS ring and does not participate in the communication phase run-up. A new drive has a default address of zero.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Hexadecimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | (ADDR << 8) | ADDR
Units: |  | Version: | 5.04
IDN Type: | SC:MT | ADS Index Group (hex.): | 0x0060


IDN 97 (S-0-0097) Class 2 Diagnostic Mask

A mask for the C2D ( IDN 12 ). When a warning condition within IDN 12 changes state, the C2D change bit (AT status word, bit 12) is set. The warning bits within IDN 12 are not latched (i.e. they will automatically set or reset as warning conditions change). The C2D change bit is reset when IDN 12 is read through the service channel. IDN 97 may be used to mask the effect of a particular warning condition on the C2D change bit: when a masked warning changes state, the C2D change bit will not be set. However, the warning bits in IDN 12 will continue to change state according to the warning conditions. When a bit in IDN 97 is clear, the corresponding bit in IDN 12 is masked.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 1111 1111 1111 1111 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC:MT | ADS Index Group (hex.): | 0x0061


IDN 98 (S-0-0098) Class 3 Diagnostic Mask

A mask for the C3D ( IDN 13 ). When a status condition within IDN 13 changes state, the C3D change bit (AT status word, bit 11) is set. The status bits within IDN 13 are not latched (i.e. they will automatically set or reset as status conditions change). The C3D change bit is reset when IDN 13 is read through the service channel. IDN 98 may be used to mask the effect of a particular status condition on the C3D change bit: when a masked status changes state, the C3D change bit will not be set. However, the status bits in IDN 13 will continue to change state according to the status conditions. When a bit in IDN 98 is clear, the corresponding bit in IDN 13 is masked.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 1111 1111 1111 1111 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC:MT | ADS Index Group (hex.): | 0x0062


IDN 99 (S-0-0099) Procedure: Reset Class 1 Diagnostic

Attempts to clear the latched faults contained in IDN 11 , IDN 14 and IDN 129 . Faults that are still active are not cleared. If all the faults are cleared successfully, the C1D status bit (AT bit 13) is also cleared. The fault reset procedure will fail if faults have been latched and the master has not reset the drive enable control bits (MDT bits 13-15). Some faults specified in IDN 11 and IDN 129 require a cold start, which IDN 99 performs automatically when required. The IDN 99 procedure will not reset faults if MDT bits 14 and 15 are set while CP3 or CP4.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | FS:MT | ADS Index Group (hex.): | 0x0063


IDN 100 (S-0-0100) Velocity Loop Proportional Gain

The proportional gain for the proportional-integral velocity loop controller. Typical gain values are between 10 and 20. If the gain is too low, then the drive may respond slowly or have poor damping. If the value is too high, then the drive may whistle or run roughly.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 200 | Cyclic Transfer: |
Default: | 1 | Serial Equiv: | GV * 100
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0064


IDN 101 (S-0-0101) Velocity Loop Integral Action Time

The integral action time for the proportional-integral velocity loop controller. When IDN 101 is zero, the integrator is switched off. If the value is too low, then the drive may run roughly or may have a large overshoot when coupled to a high-inertia load. If the value is too high, the drive response may be sluggish.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 10 000 | Cyclic Transfer: |
Default: | 100 | Serial Equiv: | GVTN * 10
Units: | 0.1 ms | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0065


IDN 103 (S-0-0103) Modulo Value

If the modulo format is on ( IDN 76 bit 7 = 1), the modulo value determines at which numeric value the position data roll over to 0. The following conditions for the modulo value will check during runup:

If linear scaling and modulo format is selected within IDN 76 and the feed constant IDN 123 is smaller then 2^20, the modulo value must be smaller then 1024 * IDN 123 .

If rotational scaling and modulo format is selected within IDN 76 and rotational position resolution IDN 79 is smaller then 2^20, the modulo value must be smaller then 1024 * IDN 79 .

If rotational scaling and modulo format is selected within IDN 76 and rotational position resolution IDN 79 is greater then 2^20, the modulo value must be smaller then 2^50 / IDN 79 .

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 1 | Run-Up Check: | CP3
Maximum: | 2^31-1 | Cyclic Transfer: |
Default: | 2^31-1 | Serial Equiv: | ERND
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0067


IDN 104 (S-0-0104) Position Loop Proportional Gain

The proportional gain for the proportional-integral position loop controller. If the value is too low, the settling time may be too long, and the drive may be too sluggish. If the value is too high, the drive may be noisy and may oscillate.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 60 | Run-Up Check: |
Maximum: | 60 000 | Cyclic Transfer: |
Default: | 900 | Serial Equiv: | GP * 6000
Units: | 0.01 (m/min)/mm ( 0.01 (in/min)/mil | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0068


IDN 105 (S-0-0105) Position Loop Integral Action Time

The integral time for the proportional-integral position loop controller.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 10 | Run-Up Check: |
Maximum: | 2 000 | Cyclic Transfer: |
Default: | 500 | Serial Equiv: | GPTN * 10
Units: | 0.1 ms | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0069


IDN 106 (S-0-0106) Current Loop Proportional Gain 1

The proportional gain for the torque producing current (D) within the proportional-integral current loop controller.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 1 | Run-Up Check: |
Maximum: | 3 000 | Cyclic Transfer: |
Default: | 100 | Serial Equiv: | MLGQ * 100
Units: |  | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x006A


IDN 107 (S-0-0107) Current Loop Integral Action Time 1

The integral time for the torque producing current within the proportional-integral current loop controller.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 200 | Run-Up Check: |
Maximum: | 10 000 | Cyclic Transfer: |
Default: | 600 | Serial Equiv: | KTN * 1000
Units: | µs | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x006B


IDN 108 (S-0-0108) Feedrate Override

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 108 (S-0-0108) Feed rate Override

The feedrate override is activated only with drive controlled procedure commands. In such a case, the velocity command is calculated by the drive internally. This IDN 108 has multiplying effects on the velocity command value.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 10000 | Cyclic Transfer: |
Default: | 10000 | Serial Equiv: |
Units: | 0.01% | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x006C


IDN 109 (S-0-0109) Motor Peak Current

The motor's peak current. If the motor peak current is less than that of the amplifier, the amplifier is automatically limited to the level of the motor peak current.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0.1 * IDN 110 | Run-Up Check: |
Maximum: | 2 * IDN 110 | Cyclic Transfer: |
Default: | IDN 110 | Serial Equiv: | MIPEAK * 1000
Units: | mA | Version: | 5.04
IDN Type: | MR | ADS Index Group (hex.): | 0x006D


IDN 110 (S-0-0110) Amplifier Peak Current

The amplifier's peak current. This value is defined by the hardware and is set to twice the continuous rated current of the drive.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | Hardware defined | Serial Equiv: | DIPEAK * 1000
Units: | mA | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x006E


IDN 111 (S-0-0111) Motor Continuous Stall Current

The current at which the motor produces the continuous standstill torque, according to the motor specification sheet. This parameter is used as a reference for all torque data and for determining motor-related current values from torque data.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0.1 * IDN 112 | Run-Up Check: |
Maximum: | 2.0 * IDN 112 | Cyclic Transfer: |
Default: | IDN 112 | Serial Equiv: | MICONT * 1000
Units: | mA | Version: | 5.04
IDN Type: | MR | ADS Index Group (hex.): | 0x006F


IDN 112 (S-0-0112) Amplifier Rated Current

The amplifier's continuous current rating. This hardware-defined variable is automatically determined by the drive.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | Hardware defined | Serial Equiv: | DICONT * 1000
Units: | mA | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0070


IDN 113 (S-0-0113) Maximum Motor Speed

The motor's maximum recommended speed, as listed in the motor specification sheet provided by the manufacturer.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 12000 RPM | Cyclic Transfer: |
Default: | 3000 RPM | Serial Equiv: | MSPEED
Units: | IDN 44 ,45,46 (Default: RPM / 10000) | Version: | 5.04
IDN Type: | MR | ADS Index Group (hex.): | 0x0071


IDN 114 (S-0-0114) System Load Limit

The system’s continuous load rating. The continuous load rating is defined as a percentage of the system’s continuous current. When the load limit is exceeded, the drive sets the overload warning bit in the C2D ( IDN 12 , bit 0). If the load limit is exceeded by 15%, the drive sets the overload shutdown bit in C1D (bit 0).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 100 | Cyclic Transfer: |
Default: | 80 | Serial Equiv: | I2TLIM
Units: | % of min ( IDN 111 , 112, or P3020) | Version: | 5.04
IDN Type: | CT: FS | ADS Index Group (hex.): | 0x0072


IDN 116 (S-0-0116) Resolution of Rotational Feedback 1 (Motor Feedback)

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 116 (S-0-0116) Resolution of Rotational Feedback 1

(Motor Feedback)

The motor's rotary feedback resolution (refer to IDN 79 ).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: | 65536 | Run-Up Check: |
Maximum: | 1048576 | Cyclic Transfer: |
Default: | 1048576 | Serial Equiv: | 2^PRBASE
Units: | Counts | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x0074


IDN 117 (S-0-0117) Resolution of Rotational Feedback 2 (External Feedback)

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 117 (S-0-0117) Resolution of Rotational Feedback 2

(External Feedback)

The resolution of the rotational feedback 2 contains the cycles per revolution of an rotary encoder as an external feedback ( IDN 53 ). The resolution of the external position feedback depends on this parameter and the multiplication factor 2 ( IDN 257 ). The resolution could be calculated with the following calculation rule: resolution = external feedback (IDN117) x 4 x multiplication factor 2 ( IDN 257 ).The maximum resolution is set within IDN 79 divide by 4, the drive checks during runup, that the setting will not give a bigger value. In this case the drive automatically calculates a new multiplication factor 2 ( IDN 257 ).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 12 | Run-Up Check: |
Maximum: | 262144 (16384) | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | FB2RES
Units: | Lines per revolution | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x0075


IDN 119 (S-0-0119) Current Loop Proportional Gain 2

The proportional gain for the field producing current (D) within the proportional-integral current loop controller. This gain has the same value within the proportional gain 1 in the torque producing loop controller (see also IDN 106 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: | 1 | Run-Up Check: |
Maximum: | 3 000 | Cyclic Transfer: |
Default: | 100 | Serial Equiv: | MLGD * 100
Units: |  | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0077


IDN 120 (S-0-0120) Current Loop Integral Action Time 2

The integral time for the field producing current within the proportional-integral current loop controller. This time has the same value within the integral action time 1 in the torque producing loop controller (see also IDN 107 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: | 200 | Run-Up Check: |
Maximum: | 10 000 | Cyclic Transfer: |
Default: | 600 | Serial Equiv: | KTN * 1000
Units: | µs | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x0078


IDN 121 (S-0-0121) Input revolutions of load gear

Input revolution values must be entered as integers.

The relation between IDN 121 and 122 can be between 0.01 and 100.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP 3
Minimum: | IDN 122 /100 | Run-Up Check: |
Maximum: | IDN 122 x 100 | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x0079


IDN 122 (S-0-0122) Output revolutions of load gear

Output revolution values must be entered as integers.

The relation between IDN 121 and 122 can be between 0.01 and 100.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP 3
Minimum: | IDN 121 /100 | Run-Up Check: |
Maximum: | IDN 121 x 100 | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x007A


IDN 123 (S-0-0123) Feed Constant

The feed constant describes the machine element which converts a rotational motion into a linear motion. The feed constant indicates the linear distance during one revolution of the feed spindle. This IDN is only active when linear scaling in IDN 76 is selected. This IDN also describes the feed at linear rotational speed scaling.

The maximum is now 10 000 000.

By using parameter 121 and 122 the minimum changes to min: 100 x ( IDN 122 / IDN 121 )and the maximum to max: 100 000 000 x ( IDN 122 / IDN 121 )

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2
Minimum: | 100 | Run-Up Check: |
Maximum: | 10 000 000 | Cyclic Transfer: |
Default: | 100 000 | Serial Equiv: |
Units: | IDN 76 , 77, 78 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x007B


IDN 127 (S-0-0127) Procedure: Communication Phase 3 Transition Check

Ensures that the drive is ready to switch from CP2 to CP3. The master must successfully execute this procedure prior to switching from CP2 to CP3. If the procedure fails, IDN 21 will contain a list of IDNs that the drive considers invalid.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x007F


IDN 128 (S-0-0128) Procedure: Communication Phase 4 Transition Check

Ensures that the drive is ready to switch from CP3 to CP4. The master must successfully execute this procedure prior to switching from CP3 to CP4. If the procedure fails, IDN 22 will contain a list of IDNs that the drive considers invalid.

If any of the macros have been changed in CP2 or CP3, the drive will re-compile the macro program and perform a warm start, which may take up to 3 minutes. During the warm start, the LED on the front panel of the drive add with the three dots will flashing. During the warm start IDN 182 Bit 1 is set, it will cleared after the warm start. Alternatively, the serial interface may be used to save all values and reset the drive before the CP4 transition check procedure is executed. (For an explanation of the macros, please consult our applications department.)

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0080


IDN 129 (S-0-0129) Manufacturer Class 1 Diagnostic (MC1D)

Lists the status of the latched manufacturer defined drive faults. When a manufacturer defined fault occurs, the drive decelerates to a stop and disables. The C1D status bit (AT status bit 13) is set, IDN 11 bit 15 is set, and the corresponding manufacturer-defined fault bit is set within IDN 129. All manufacturer defined faults are latched within IDN 129 and are reset through the “Reset Class 1 Diagnostic” procedure ( IDN 99 ). IDN 99 performs a cold start automatically when required. Those faults which require a cold start are noted in the table below. The error messages which appear on the front panel of the drive are also shown below.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ERRCODE
Units: |  | Version: | 5.04
IDN Type: | MT:FS | ADS Index Group (hex.): | 0x0081

Definition:

Bit | Description | Cold start | LED Error
LSB 0 | Reserved |  |
1 | Non-volatile memory check-sum fault | yes | F09, F10
2 | Warning fault (actual warning is mask to a fault) | no | F24
3 | Motor brake fault | yes | F11
4 | Supply voltage not present | no | F16
5 | A/D converter fault | yes | F17
6 | Regeneration fault | yes | F18
7 | System fault | yes | F32
8 | Reserved |  |
9 | Motor over speed fault | no | F08
10 | Excessive position command difference | No | F28
11 | Non-permissible software-enable (no hardware-enable; no SERCOS control) | No | F29
12 – 15 | Reserved |  |


IDN 130 (S-0-0130) Probe 1 Positive Edge Value

The “Probing” procedure ( IDN 170 ) is used to capture the motor position ( IDN 51 ) when a digital input changes. IDN 130 will contain the captured position when the “Probe Control Parameter” ( IDN 169 , bit 0) is configured for probe 1 to capture the position on the rising edge of the digital input.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | LATCH32
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0082


IDN 131 (S-0-0131) Probe 1 Negative Edge Value

The “Probing” procedure ( IDN 170 ) is used to capture the motor position ( IDN 51 ) when a digital input changes. IDN 131 will contains the captured position when the “Probe Control Parameter” ( IDN 169 , bit 1) is configured for probe 1 to capture the position on the falling edge of the digital input.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | LATCH32N
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0083


IDN 132 (S-0-0132) Probe 2 Positive Edge Value

The “Probing” procedure ( IDN 170 ) is used to capture the external position ( IDN 53 ) when a digital input changes. IDN 132 will contains the captured position when the “Probe Control Parameter” ( IDN 169 , bit 2) is configured for probe 2 to capture the position on the rising edge of the digital input.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | LATCHX32
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0084


IDN 133 (S-0-0133) Probe 2 Negative Edge Value

The “Probing” procedure ( IDN 170 ) is used to capture the external position ( IDN 53 ) when a digital input changes. IDN 133 will contains the captured position when the “Probe Control Parameter” ( IDN 169 , bit 3) is configured for probe 2 to capture the position on the falling edge of the digital input.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | LATCHX32N
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0085


IDN 134 (S-0-0134) Master Control Word

The drive’s control word within the MDT is stored within IDN 134 as a diagnostic aid.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0086


IDN 135 (S-0-0135) Drive Status Word

The AT telegram status word is stored within IDN 135 as a diagnostic aid.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x0087


IDN 136 (S-0-0136) Positive Acceleration Limit Value

Defines the drive's maximum positive acceleration when the drive is in velocity mode. The positive acceleration limit is defined as the number of milliseconds to reach the maximum velocity limit from standstill ( IDN 38 , 39, 91).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 1 | Run-Up Check: |
Maximum: | 32767 | Cyclic Transfer: |
Default: | 10 | Serial Equiv: | ACC
Units: | IDN 160 , 161, 162 | Version: | 5.04
IDN Type: | AD | ADS Index Group (hex.): | 0x0088


IDN 137 (S-0-0137) Negative Acceleration Limit Value

Defines the drive's maximum deceleration (negative acceleration) when the drive is in velocity mode. The drive alternatively uses the quick deceleration limit ( IDN 3022 under the following conditions: position limits are encountered, a fault has occurred, or the master has requested an active disable (MDT control word, bit 15). The quick deceleration limit ( IDN 3022 is always used by the drive when those conditions occur. The negative acceleration limit is defined as the number of milliseconds to go from the maximum velocity limit to standstill ( IDN 38 , 39, 91).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | -32767 | Run-Up Check: |
Maximum: | -1 | Cyclic Transfer: |
Default: | -10 | Serial Equiv: | DEC
Units: | IDN 160 , 161, 162 | Version: | 5.04
IDN Type: | AD | ADS Index Group (hex.): | 0x0089


IDN 140 (S-0-0140)

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | VER *
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x008C


IDN 141 (S-0-0141) Motor Type

The master may use this IDN to read or write the motor type text describing. The master can select the motor that is used from the motor database of the drive.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | “NN” | Serial Equiv: | MNAME
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x008D


IDN 142 (S-0-0142) Application Type

The master may use this IDN to store text describing the drive’s application.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | “DRIVE0” | Serial Equiv: | ALIAS
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x008E


IDN 143 (S-0-0143) SYSTEM Interface Version

Contains the version number of the SERCOS specification. The drive conforms this version of the specification.

Data Length: | 1 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | Text | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | “V01.02” | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x008F


IDN 147 (S-0-0147) Homing Parameter

The “Drive Controlled Homing” procedure ( IDN 148 ) is configured through IDN 41 , IDN 42 and IDN 147. Only the bits 0, 5 and 6 are supported, if the home switch is evaluated to the drive bit 1 must set to 0 and bit 2 must set 1. All other reserved bits must be set as indicated by the bold type within the following table. To the different homing types refer also to IDN 3027 If the position control is set on the external encoder , bit 3 must be set to 1.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0085H | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0093
Definition:
Bit | Description | Setting
LSB 0 | Homing direction | 0 = CW 1 = CCW
1 | Home switch polarity | 1 = Active on falling edge
2 | Home switch location | 0 = Master
4 | Reserved: Home enable evaluation | Set to 0
6 | Marker pulse evaluation | 1 = Not evaluated
7 | Reserved: Stop condition | 1 = On home position ( IDN 52 , 54)
8 – 15 | Reserved. | Set to 0


IDN 148 (S-0-0148) Procedure: Drive Controlled Homing

The drive automatically enters an internal position mode and homes the drive. Homing is configured through the “Homing Velocity” ( IDN 41 ), “Homing Acceleration” ( IDN 42 ) and the “Homing Parameter” ( IDN 147 ). The homing procedure should fail under the following conditions:

1) The drive is disabled, or the master clears any of the enable bits (MDT bits 13-15) during drive-controlled homing.

2) The “Probing” procedure ( IDN 170 ) is active.

3) The home switch is located on the drive ( IDN 147 , bit 2 is set) and will be evaluated during homing ( IDN 147 , bit 5 is clear) and a configurable input has not been configured as a home switch input.

4) A fault occurs during drive controlled homing.

The home switch is located on the master ( IDN 147 , bit 2 is clear) and will be evaluated during homing ( IDN 147 , bit 5 is clear) and the “Homing Enable” signal ( IDN 407 ) has not been configured as a real time control bit.

The master should not cancel the drive controlled homing procedure until it has aligned its position command with the drive’s present position command. The master may abort drive controlled homing by first stopping the drive through the start/stop bit (MDT control bit 13), aligning its position command with the drive and then canceling the procedure.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0094


IDN 159 (S-0-0159) Monitoring Window

The monitoring window defines the maximum position error. When the absolute distance between the active position command and active position feedback exceeds the monitoring window, an “excessive position deviation” fault is generated ( IDN 11 , bit 11).

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 7FFF FFFFH | Cyclic Transfer: |
Default: | 262144 | Serial Equiv: | PEMAX
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS:FS | ADS Index Group (hex.): | 0x009F


IDN 160 (S-0-0160) Acceleration Data Scaling Type

Defines the scaling options for all acceleration data. The scaling types which are supported are indicated in bold face type. The rotational parameter scaling setting (IDN 160 = 000A H), could not save in the EEPROM (refer to IDN 161 , 162). For the no scaling option, all acceleration data are scaled in ms, to reach the bipolar velocity limit. A new value will not become active until the parameter is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 000AH | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | ACCUNIT
Units: |  | Version: | 5.04
IDN Type: | AD | ADS Index Group (hex.): | 0x00A0
Definition:
Bit |  | Description
2 - 0 | Scaling Method | 000=No scaling 001=reserved: Linear Scaling 010=Rotational Scaling
3 | Standard Scaling Type | 0=Preferred Scaling 1=Parameter Scaling
4 | Reserved: Units for Linear Scaling | 0=Meters (m) 1=Inches (in)
4 | Units for Rotational Scaling | 0=Radian 1=Reserved
5 | Time Units | 0=Seconds (s) 1=Reserved
6 | Data Reference | 0=At the Motor Shaft 1=Reserved: At the Load
15-7 | Reserved |


IDN 161 (S-0-0161) Acceleration Data Scaling Factor

This parameter defines the scaling factor for all acceleration data in the drive, when rotational parameter scaling in IDN 160 is selected (Refer to IDN 160 , 162).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 1 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00A1


IDN 162 (S-0-0162) Acceleration Data Scaling Exponent

This parameter defines the scaling exponent for all acceleration data in the drive, when rotational parameter scaling in IDN 160 is selected (Refer to IDN 160 , 161).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3
Minimum: | -3 | Run-Up Check: |
Maximum: | 0 | Cyclic Transfer: |
Default: | -3 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00A2


IDN 169 (S-0-0169) Probe Control Parameter

The probe control parameter defines the input signal edge that will result in a position capture during the “Probing” procedure ( IDN 170 ). Each probe may be used to capture positions on both probe signal edges, but the probe edges must be separated by at least 2 milliseconds. The table below describe the fixed settings if only the digital input 2 is used for the latched function, for the other settings please refer also to IDN 3018

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 15 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00A9
Definition:
Bit | Description | Setting
LSB 0 | Probe 1 – Capture motor position on positive edge | 0 = Inactive. 1 = Active.
1 | Probe 1 – Capture motor position on negative edge | 0 = Inactive. 1 = Active.
2 | Probe 2 – Capture external position on positive edge | 0 = Inactive. 1 = Active.
3 | Probe 2 – Capture external position on negative edge | 0 = Inactive. 1 = Active.
4 - 15 | Reserved. | Set to 0.


IDN 170 (S-0-0170) Procedure: Probing

Probing is used to capture position data when a digital input changes. Each probe may trigger a position capture using both edges (rising and/or falling) of the digital input signal, as long as the edges are separated by at least 2 milliseconds. The “Probe Control Parameter” ( IDN 169 ) is used to configure the digital input edges that will trigger a position capture. Once the probe procedure is started by the master (set IDN 170 to 3), it will continue indefinitely until either the master cancels the probing procedure or a probing error occurs. The probing procedure will fail under the following conditions:

1) The “Homing” procedure ( IDN 148 ) is active.

2) A digital input has not been configured as a position capture input ( IDN 3001 .

During the probing procedure, the master arms the probe trigger by setting a “Probe Enable” signal ( IDN 405 or IDN 406 ). After the probe trigger has been armed, the next rising and/or falling edge(s) (as specified in IDN 169 ) on the probe inputs ( IDN 401 or IDN 402 ) will latch the motor position and cause the corresponding “Probe Position Latch Status” ( IDN 179 ) bits to set. Any further changes in the probe input are ignored until the master re-arms the probe trigger by clearing and setting the probe enable signal. The master may read captured positions through the “Probe Positive Edge Value” ( IDN 130 and IDN 132 ) and the “Probe Negative Edge Value” ( IDN 131 and IDN 133 ).

The drive supports two physical probe input that must be pre-configured through IDN 3001 and IDN 3000 before starting the probe procedure. It will be select with IDN 3018 Probe 1 with the physical input 2 and Probe 2 with the physical input 1 and all combination for the feedback types for both probes.

Although it is possible to use only one physical probe input (digital input 2) with the two logical probes that are operated independently. Logical probe 1 supports capturing the motor feedback while logical probe 2 supports capturing the external feedback.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00AA


IDN 179 (S-0-0179) Probe Position Latch Status

The probe status parameter indicates whether a position has been captured and latched within one of the “Probe Edge Value” IDNs ( IDN 130 0 through 133). IDN 179 duplicates the information found in IDN 409 9 through 412.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00B3
Definition:
Bit | Description | Setting
LSB 0 | Probe 1 – Position latched on positive edge ( IDN 130 ) | 0 = No. 1 = Latched.
1 | Probe 1 – Position latched on negative edge ( IDN 131 ) | 0 = No. 1 = Latched.
2 | Probe 2 – Position latched on positive edge ( IDN 132 ) | 0 = No. 1 = Latched.
3 | Probe 2 – Position latched on negative edge ( IDN 133 ) | 0 = No. 1 = Latched.
4 - 15 | Reserved. | Set to 0.


IDN 182 (S-0-0182) Manufacturer Class 3 Diagnostic (MC3D)

Lists of the manufacturer defined status flags for the drive. If a status condition is set or reset within IDN182, the manufacturer class 3 diagnostic bit ( IDN 13 bit 15) is set as well. When IDN 182 is read via the service channel, the bit 15 of IDN 13 will reset to 0.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x00B6
Definition:
Bit | Description | Setting
LSB 0 | Hardware enable | 0 = not exist 1 = exist
1 | Warm start ( IDN 128 ) | 0 = not running 1 = still running
2-15 | Reserved |


IDN 185 (S-0-0185) Maximum Length of AT Configurable Data

Defines the maximum length, in bytes, of the AT's cyclic data field. The master may use this IDN to determine how many IDNs may be placed within the application telegram (refer to IDN 15 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 24 | Serial Equiv: |
Units: | Bytes | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x00B9


IDN 186 (S-0-0186) Maximum Length of MDT Configurable Data

Defines the maximum length, in bytes, of the MDT's cyclic data field. The master may use this IDN to determine how many IDNs may be placed within an application telegram (refer to IDN 15 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 12 | Serial Equiv: |
Units: | Bytes | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x00BA


IDN 187 (S-0-0187) List of AT Configurable Data IDNs

Lists all the IDNs that may be transferred as AT cyclic data. The master may use this IDN to determine the IDNs that may be placed within an application telegram (refer to IDN 15 ). The following IDNs may be assigned as AT cyclic data:

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x00BB
Definition:
IDN | Description
40 | Velocity Feedback Value
51 | Position Feedback Value 1 (motor)
53 | Position Feedback Value 2 (external)
59 | Position Switch Flag Parameter
84 | Torque Feedback Value
130 | Probe 1 Positive Edge Value
131 | Probe 1 Negative Edge Value
132 | Probe 2 Positive Edge Value
133 | Probe 2 Negative Edge Value
189 | Following Distance
IDN 3012 | Difference Probe Edge Value 1
IDN 3013 | Difference Probe Edge Value 2
IDN 3030 | Configurable I/O: Digital Input 1 Status
IDN 3031 | Configurable I/O: Digital Input 2 Status
IDN 3032 | Configurable I/O: Digital Input 3 Status
IDN 3033 | Configurable I/O: Digital Input 4 Status
IDN 3034 | Analog Input 1 Value
IDN 3035 | Analog Input 2 Value


IDN 188 (S-0-0188) List of MDT Configurable Data IDNs

Lists all the IDNs that may be transferred as MDT cyclic data. The master may use this IDN to determine the IDNs that may be placed within an application telegram (refer to IDN 15 ). The following IDNs may be assigned as MDT cyclic data:

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x00BC
Definition:
IDN | Description
36 | Velocity Command Value
47 | Position Command Value
60 | Position Switch Point 1
61 | Position Switch Point 2
80 | Torque Command Value
IDN 3036 | Configurable I/O: Digital Output 1 Control/Status
IDN 3037 | Configurable I/O: Digital Output 2 Control/Status


IDN 189 (S-0-0189) Following Distance

The distance between the position command value and the appropriate position feedback value (1 or 2). The drive calculates this value by subtracting the position feedback value (1 or 2) from the position command value.

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | PE
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x00BD


IDN 192 (S-0-0192) IDN List of Back-up Operation Data

A list of all IDNs which are essential for drive operation. The master may use this list to back-up the drive parameters. If the drive is replaced, the IDNs within this list may be reloaded into the replacement drive using the order defined within IDN 288 and IDN 289 or direct the order of the list within this IDN.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x00C0


IDN 196 (S-0-0196) Motor Rated Current

The motor's rated current. If the motor rated current is less than that of the amplifier, the amplifier is automatically limited to the level of the motor rated current.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0.1 * IDN 112 | Run-Up Check: |
Maximum: | 2 * IDN 112 | Cyclic Transfer: |
Default: | IDN 112 | Serial Equiv: | MICONT * 1000
Units: | MA | Version: | 5.04
IDN Type: | MR | ADS Index Group (hex.): | 0x00C4


IDN 203 (S-0-0203) Amplifier Shutdown Temperature

When the amplifier temperature ( heat sink temperature) exceed the value of the amplifier shutdown temperature, the drive sets the fault bit for amplifier over temperature fault in C1D ( IDN 11 bit 1).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 200 | Run-Up Check: |
Maximum: | 850 | Cyclic Transfer: |
Default: | 800 | Serial Equiv: | MAXTEMPH ( 10
Units: | IDN 208 | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x00CB


IDN 205 (S-0-0205) Cooling Error Shutdown Temperature

When the temperature inside the drive housing exceed the value of the cooling error shutdown temperature, the drive sets the fault bit for cooling system fault in C1D ( IDN 11 bit 3).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 100 | Run-Up Check: |
Maximum: | 800 | Cyclic Transfer: |
Default: | 700 | Serial Equiv: | MAXTEMPE ( 10
Units: | IDN 208 | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x00CD


IDN 208 (S-0-0208) Temperature Data Scaling Type

Defines the scaling options for all temperature data. The scaling types which are supported are indicated in bold-face type.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0000H | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x00D0
Definition:
Bit |  | Description
0 | Scaling Method | 0 = 0,1 °C 1=Reserved: 0,1 F
15-1 | Reserved | 15-1


IDN 257 (S-0-0257) Multiplication Factor 2

The multiplication factor 2 defines the drive internal multiplication of an rotary encoder as an external feedback for the position feedback value 2 ( IDN 53 ). If the resolution of the rotational feedback 2 ( IDN 117 ) is not a result of 2x, the drive may use an additional scaling for IDN 53 . If the master write IDN 117 the drive calculate automatic the “Multiplication factor 2” (IDN 257), for the external feedback, and an additional scaling factor if necessary, to scale the external rotary encoder to the rotational position resolution set within IDN 79 (refer to IDN 53 , 79 and 117). The drive also do the automatic calculation for position control with external feedback.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 256 | Serial Equiv: | EXTMUL
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x0101


IDN 262 (S-0-0262) Procedure: Load Default Values

This procedure loads the manufacturer’s default parameters into volatile memory. The parameters stored in non-volatile memory remain unchanged. The default parameters allow the drive to operate without problems, but the operation is not necessarily optimized.

This procedure will normally modify the macro program, and the drive will re-compile the macro program and perform a warm start in the CP4 transition check, which may take up to 3 minutes. During the warm start, the LED on the front panel of the drive add with the three dots will flashing. During the warmstart IDN 182 Bit 1 is set, it will cleared after the warmstart. Alternatively, the serial interface may be used to save all values and reset the drive before the CP4 transition check procedure is executed. (For an explanation of the macros, please consult our applications department.)

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | RSTVAR
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x0106


IDN 264 (S-0-0264) Procedure: Back-up Working Memory

This command saves all data essential for drive operation from the active memory to the non-volatile memory. IDN 192 defines which data is essential for drive operation. Previously saved data is overwritten.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SAVE
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x0108


IDN 271 (S-0-0271) Drive ID

The master may store a unique drive identification number within this IDN. The identification number is saved to non-volatile memory when the “Back-up Working Memory” procedure ( IDN 264 ) is executed. The identification number is reset to zero when the “Load Default Values” procedure ( IDN 262 ) is executed.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 32 767 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | UID
Units: |  | Version: | 5.04
IDN Type: | MT | ADS Index Group (hex.): | 0x010F


IDN 288 (S-0-0288) IDN List of Data Programmable in CP2

A list of all IDNs that may be written by the master in CP2. The IDNs are listed in the order that the master should write them to avoid data dependency problems. Data dependency problems may arise, for example, when the range of one IDN depends upon an IDN that has not yet been written.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x0120


IDN 289 (S-0-0289) IDN List of Data Programmable in CP3

A list of all IDNs that may be written by the master in CP3. The IDNs are listed in the order that the master should write them to avoid data dependency problems. Data dependency problems may arise, for example, when the range of one IDN depends upon an IDN that has not yet been written.

Data Length: | 2 byte elements, variable length array | Non-Volatile: | Yes
Data Type: | IDN | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | GE | ADS Index Group (hex.): | 0x0121


IDN 296 (S-0-0296) Velocity Feed Forward Gain

Defines a multiplier for an additive velocity command that is generated from the position profile. Velocity feed forward helps to reduce the velocity dependent following error. Velocity feed forward is added to the velocity command when the active operational mode defined by IDN 32 and/or IDN 33 has bit 3 set and is in position control mode.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 2000 | Cyclic Transfer: |
Default: | 1000 | Serial Equiv: | GPFFV
Units: | 0.1% | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0128


IDN 298 (S-0-0298) Home Switch Distance

The distance the home switch is from the “optimal” location after homing. The “optimal” location is defined as half the distance between successive marker pulses (encoder) or null points (resolvers). The home switch distance may be used to ensure that the home switch is located correctly to avoid inconsistent homing. The home switch distance is not valid until homing has completed successfully ( IDN 403 is set).

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x012A


IDN 301 (S-0-0301) Allocation of Real-time Control Bit 1

Assigns a control signal IDN to the real-time control bit 1 (RTC bit 1, MDT control word bit 6). Two RTC bits are defined within the MDT control word (bits 6 and 7) and may be updated every communication cycle by the master. The following rules govern the assignment and use of RTC bit:

Only certain control signal IDNs of type binary may be assigned to the real time control allocation IDNs. The exception is IDN 0 , which indicates that the real time control bit is undefined. The following IDNs may be assigned as RTC signals: IDN 0 , IDN 405 ( IDN 3039 = 0), IDN 406 ( IDN 3039 = 0) and IDN 3038 ( IDN 3039 = 1).

A new RTC bit assignment must be valid within the drive, before the service channel busy bit is being reset. After the service channel busy bit from the drive is reset, the master can operate with the RTC bit 1 in the master control word.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x012D


IDN 303 (S-0-0303) Allocation of Real-time Control Bit 2

Assigns a control signal IDN to the real-time control bit 2 (RTC bit 2, MDT control word bit 7). Two RTC bits are defined within the MDT control word (bits 6 and 7) and may be updated every communication cycle by the master. For further information refer to IDN 301 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x012F


IDN 304 (S-0-0304) Real-Time Status Bit 1

The value of the IDN assigned to RTS bit 1.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x0130


IDN 305 (S-0-0305) Allocation of Real-time Status Bit 1

The IDN of a real-time status signal that appears in real-time status bit 1 (AT status word, bit 6). Two real time status bits are defined within the AT status word (bits 6 and 7) and are continuously updated by the drive during CP4. The following rules govern the assignment and use of a real time status bit (i.e. writing IDN 305 or 307):

Only status signal IDNs of type binary may be assigned to the real time status allocation IDNs. The exception is IDN 0 , which indicates that the real time status bit is undefined. The following IDNs may be assigned as RTS signals: IDN 0 , IDN 336 , IDN 400 , IDN 403 , IDN 409 , IDN 410 , IDN 411 and IDN 412 .

The master should no longer evaluate a previous real time status assignment after transmitting a write request for element 7 of a real time status bit allocation IDN. The previously assigned real time status bit will remain valid until the service channel busy bit is set.

The master should not start evaluating a new real time status bit assignment until the service channel busy bit is reset by the drive.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x0131


IDN 306 (S-0-0306) Real-Time Status Bit 2

The value of the IDN assigned to RTS bit 2.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x0132


IDN 307 (S-0-0307) Allocation of Real-time Status Bit 2

The IDN of a real-time status signal that appears in real-time status bit 2 (AT status word, bit 7). Two real time status bits are defined within the AT status word (bits 6 and 7) and are continuously updated by the drive during CP4. For further information, refer to IDN 305 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | IDN | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | MT:SC | ADS Index Group (hex.): | 0x0133


IDN 323 (S-0-0323) Status “Target position outside of travel range”

A warning signal IDN that is set (Bit 0 = 1) when the target position is outside of the travel range. This IDN will set if the HW- or SW-Limit Switch is active. The drive show this with flashing the warning “n10” or “n07” for outside of positive range or “n11” or “n06” outside of negative range. IDN 323 duplicates the C2D “Target position outside of travel range” warning bit ( IDN 12 , bit 13).

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |


IDN 336 (S-0-0336) Status “In Position”

A status signal IDN that is set when the difference between the position command value and the position feedback value falls within the range defined by the “Position Window” ( IDN 57 ). IDN 336 duplicates the C3D “In Position” status bit ( IDN 13 , bit 6) and may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0150


IDN 380 (S-0-0380) DC Bus Voltage

The master retrieves the drive’s DC bus voltage through this IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: | 0 | Run-Up Check: |
Maximum: | 900 | Cyclic Transfer: |
Default: |  | Serial Equiv: | VBUS
Units: | Volt | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x017C


IDN 384 (S-0-0384) Amplifier Temperature

The master retrieves the amplifier temperature (heat sink temperature) from the drive through this IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | TEMPH ( 10
Units: | IDN 208 | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0180


IDN 392 (S-0-0392) Velocity Feedback Filter Time Constant

The velocity feedback is passed through a first order low pass filter before being applied to the velocity loop. The filter is useful for improving the step response and operational smoothness, particularly for very small, highly dynamic motors. If the filter’s time constant is to low, then the motor may run roughly. If the filter’s time constant is to high, then the motor’s response may be soft and unstable. The filter’s time constant may be adjusted in intervals of 100 (s.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 65500 | Cyclic Transfer: |
Default: | 400 | Serial Equiv: | GVFBT
Units: | µs | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x0188


IDN 400 (S-0-0400) Home Switch Status

Contains the state of the home switch. The digital input used as home switch input is assigned through the use of digital input mode IDNs ( IDN 3000 IDN 3001 IDN 3002 or IDN 3003 . IDN 400 is useful for assigning the home switch signal to a RTS bit.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | PS:IO | ADS Index Group (hex.): | 0x0190


IDN 401 (S-0-0401) Probe 1

Contains the state of the probe 1 input. The digital input used as a probe is assigned through the use of IDN 3001 The drive updates the probe 1 IDN only when the probing procedure ( IDN 170 ) is active and the probe 1 enable ( IDN 405 ) is set.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | IN2
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0191


IDN 402 (S-0-0402) Probe 2

Contains the state of the probe 2 input. The digital input used as a probe is assigned through the use of IDN 3001 The drive updates the probe 2 IDN only when the probing procedure ( IDN 170 ) is active and the probe 2 enable ( IDN 406 ) is set.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | IN2
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0192


IDN 403 (S-0-0403) Position Feedback Status

The position feedback status flag is set by the drive during homing when the position feedback is referenced to the machine zero point. The status flag is reset after power-up, and when the “Drive Controlled Homing” procedure ( IDN 148 ) is started. IDN 403 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0193


IDN 405 (S-0-0405) Probe 1 Enable

Used to arm the position capture mechanism so that the next valid probing signal edge captures the current position into IDN 130 or 131. IDN 405 may be assigned to a RTC bit (MDT control word bit 6 or 7) through IDN 301 or IDN 303 . This IDN is write-protected while it is assigned to a RTC bit and could only reset to 0 via the SC. Refer to IDN 170 for more information.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0195


IDN 406 (S-0-0406) Probe 2 Enable

Used to arm the position capture mechanism so that the next valid probing signal edge captures the current position into IDN 132 or 133. IDN 406 may be assigned to a RTC bit (MDT control word bit 6 or 7) through IDN 301 or IDN 303 . This IDN is write-protected while it is assigned to a RTC bit and could only reset to 0 via the SC. Refer to IDN 170 for more information.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0196


IDN 409 (S-0-0409) Probe 1 Positive Edge Latched Status

Indicates whether captured position data has been latched within IDN 130 after the rising edge of the probe 1 input signal ( IDN 401 ). Position data can only be latched on the positive edge of probe 1 if the “Probing” procedure ( IDN 170 ) is active and the “Probe Control Parameter” ( IDN 169 ) has been configured to use the positive edge of probe 1. Additionally, probe 1 must be armed by setting the “Probe 1 Enable” ( IDN 405 ). After arming probe 1, the next probe 1 rising edge will capture the current position and the “probe 1 positive edge latched status” will set when the captured data is available in IDN 130 . Once the latched status has been set, no more position captures will occur on the rising edges of the probe 1 input until the master re-arms probe 1 by clearing and setting the probe 1 enable. Clearing the probe 1 enable signal will reset the latch status.

IDN 409 duplicates information found in the probe status ( IDN 179 , bit 0). IDN 409 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x0199


IDN 410 (S-0-0410) Probe 1 Negative Edge Latched Status

Indicates whether captured position data has been latched within IDN 131 after the falling edge of the probe 1 input signal ( IDN 401 ). Position data can only be latched on the negative edge of probe 1 if the probing procedure ( IDN 170 ) is active and the “Probe Control Parameter” ( IDN 169 ) has been configured to use the negative edge of probe 1. Additionally, probe 1 must be armed by setting the “Probe 1 Enable” ( IDN 405 ). After arming probe 1, the next probe 1 falling edge will capture the current position and the “probe 1 negative edge latched status” will set when the captured data is available in IDN 131 . Once the latched status has been set, no more position captures will occur on the falling edges of the probe 1 input until the master re-arms probe 1 by clearing and setting the probe 1 enable. Clearing the probe 1 enable signal will reset the latch status.

IDN 410 duplicates information found in the probe status ( IDN 179 , bit 1). IDN 410 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x019A


IDN 411 (S-0-0411) Probe 2 Positive Edge Latched Status

Indicates whether captured position data has been latched within IDN 132 after the rising edge of the probe 2 input signal ( IDN 402 ). Position data can only be latched on the positive edge of probe 2 if the “Probing” procedure ( IDN 170 ) is active and the “Probe Control Parameter” ( IDN 169 ) has been configured to use the positive edge of probe 2. Additionally, probe 2 must be armed by setting the “Probe 2 Enable” ( IDN 406 ). After arming probe 2, the next probe 2 rising edge will capture the current position and the “probe 2 positive edge latched status” will set when the captured data is available in IDN 132 . Once the latched status has been set, no more position captures will occur on the rising edges of the probe 2 input until the master re-arms probe 2 by clearing and setting the probe 2 enable. Clearing the probe 2 enable signal will reset the latch status.

IDN 411 duplicates information found in the probe status ( IDN 179 , bit 2). IDN 411 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x019B


IDN 412 (S-0-0412) Probe 2 Negative Edge Latched Status

Indicates whether captured position data has been latched within IDN 133 after the falling edge of the probe 2 input signal ( IDN 402 ). Position data can only be latched on the negative edge of probe 2 if the probing procedure ( IDN 170 ) is active and the “Probe Control Parameter” ( IDN 169 ) has been configured to use the negative edge of probe 2. Additionally, probe 2 must be armed by setting the “Probe 2 Enable” ( IDN 406 ). After arming probe 2, the next probe 2 falling edge will capture the current position and the “probe 2 negative edge latched status” will set when the captured data is available in IDN 133 . Once the latched status has been set, no more position captures will occur on the falling edges of the probe 2 input until the master re-arms probe 2 by clearing and setting the probe 2 enable. Clearing the probe 2 enable signal will reset the latch status.

IDN 412 duplicates information found in the probe status ( IDN 179 , bit 3). IDN 412 may be assigned to a RTS bit (AT status word bit 6 or 7) through IDN 305 or IDN 307 .

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x019C


IDN 3000 (P-0-3000) Configurable I/O: Digital Input 1 Mode

Determines the functionality of digital inputs 1 through 4. The digital inputs may be read directly through IDN 3030 through IDN 3033 . The following table describes the functions that are available. A new input mode will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | InxMODE (x = 1, 2, 3, or 4).
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BB8
Definition:
INx-Mode | Description | Active Edge | Digital Input
 |  |  | 1 | 2 | 3 | 4
0 | Reserved | – |  |  |  |
1 | Reset |  | x |  |  |
2 | PSTOP | Active low |  |  | x | x
3 | NSTOP | Active low |  |  | x | x
4 | PSTOP+Intg.Off | Active low |  |  | x |
5 | NSTOP+Intg.Off | Active low |  |  |  | x
6 | PSTOP+NSTOP | Active low |  |  | x |
7 | P/NSTOP+Intg.Off | Active low |  |  | x |
8 | SETP.1/SETP.2 |  | x | x | x | x
9 | MT_No_Bit |  | x | x | x | x
10 | Intg.Off | Rising | x | x | x | x
11 | v/Torq.Contr. | Active high | x | x | x | x
12 | Reference | IDN 147 | x | x | x | x
13 | ROD/SSI | Low/High | x | x | x | x
14 | FError_clear |  | x | x | x | x
15 | Start_MT Next |  | x | x | x | x
16 | Start_MT No x |  | x | x | x | x
17 | Start_ MT IO |  | x | x | x | x
18 | Ipeak2x |  | x | x | x | x
19 | Reserved |  |  |  |  |
20 | Start_Jog v=x |  | x | x | x | x
21 | U_Mon.off | High | x | x | x | x
22 | MT Restart |  | x | x | x | x
23 | Start2_MT No x |  | x | x | x | x
24 | Switch over OPMODE |  | x | x | x | x
25 | Zero_latch |  | x | x | x | x
26 | Position Latch | IDN 169 | x | x |  |
27 | Emergency Stop |  | x | x | x | x
28 | Reserved |  |  |  |  |
29 | Reserved |  |  |  |  |
30 | Command Buffer 1 |  | x | x | x | x
31 | Command Buffer 2 |  | x | x | x | x
32 | Brake |  | x | x | x | x
33 | see 30 |  | x | x | x | x
34 | see 31 |  | x | x | x | x
35 | Select Velocity/Current Entry |  | x | x | x | x
36 | Give Offset to Gearing Function |  | x | x | x | x
37 | Change source of actual position at EXTPOS=1 |  | x | x | x | x
38 | Enable signal for following motion task |  | x |  |  |
39 | Constant Speed for defined time |  | x | x | x | x
40 | Additional hardware input (enable) |  | x | x | x | x
41 | Fast emergency stop |  | x | x | x | x


IDN 3001 (P-0-3001) Configurable I/O: Digital Input 2 Mode

Determines the functionality of digital inputs 1 through 4. The digital inputs may be read directly through IDN 3030 through IDN 3033 . The following table describes the functions that are available. A new input mode will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | InxMODE (x = 1, 2, 3, or 4).
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BB9

Definition

INx-Mode | Description | Active Edge | Digital Input
 |  |  | 1 | 2 | 3 | 4
0 | Reserved | – |  |  |  |
1 | Reset |  | x |  |  |
2 | PSTOP | Active low |  |  | x | x
3 | NSTOP | Active low |  |  | x | x
4 | PSTOP+Intg.Off | Active low |  |  | x |
5 | NSTOP+Intg.Off | Active low |  |  |  | x
6 | PSTOP+NSTOP | Active low |  |  | x |
7 | P/NSTOP+Intg.Off | Active low |  |  | x |
8 | SETP.1/SETP.2 |  | x | x | x | x
9 | MT_No_Bit |  | x | x | x | x
10 | Intg.Off | Rising | x | x | x | x
11 | v/Torq.Contr. | Active high | x | x | x | x
12 | Reference | IDN 147 | x | x | x | x
13 | ROD/SSI | Low/High | x | x | x | x
14 | FError_clear |  | x | x | x | x
15 | Start_MT Next |  | x | x | x | x
16 | Start_MT No x |  | x | x | x | x
17 | Start_ MT IO |  | x | x | x | x
18 | Ipeak2x |  | x | x | x | x
19 | Reserved |  |  |  |  |
20 | Start_Jog v=x |  | x | x | x | x
21 | U_Mon.off | High | x | x | x | x
22 | MT Restart |  | x | x | x | x
23 | Start2_MT No x |  | x | x | x | x
24 | Switch over OPMODE |  | x | x | x | x
25 | Zero_latch |  | x | x | x | x
26 | Position Latch | IDN 169 | x | x |  |
27 | Emergency Stop |  | x | x | x | x
28 | Reserved |  |  |  |  |
29 | Reserved |  |  |  |  |
30 | Command Buffer 1 |  | x | x | x | x
31 | Command Buffer 2 |  | x | x | x | x
32 | Brake |  | x | x | x | x
33 | see 30 |  | x | x | x | x
34 | see 31 |  | x | x | x | x
35 | Select Velocity/Current Entry |  | x | x | x | x
36 | Give Offset to Gearing Function |  | x | x | x | x
37 | Change source of actual position at EXTPOS=1 |  | x | x | x | x
38 | Enable signal for following motion task |  | x |  |  |
39 | Constant Speed for defined time |  | x | x | x | x
40 | Additional hardware input (enable) |  | x | x | x | x
41 | Fast emergency stop |  | x | x | x | x


IDN 3002 (P-0-3002) Configurable I/O: Digital Input 3 Mode

Determines the functionality of digital inputs 1 through 4. The digital inputs may be read directly through IDN 3030 through IDN 3033 . The following table describes the functions that are available. A new input mode will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | InxMODE (x = 1, 2, 3, or 4).
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBA
Definition:
INx-Mode | Description | Active Edge | Digital Input
 |  |  | 1 | 2 | 3 | 4
0 | Reserved | – |  |  |  |
1 | Reset |  | x |  |  |
2 | PSTOP | Active low |  |  | x | x
3 | NSTOP | Active low |  |  | x | x
4 | PSTOP+Intg.Off | Active low |  |  | x |
5 | NSTOP+Intg.Off | Active low |  |  |  | x
6 | PSTOP+NSTOP | Active low |  |  | x |
7 | P/NSTOP+Intg.Off | Active low |  |  | x |
8 | SETP.1/SETP.2 |  | x | x | x | x
9 | MT_No_Bit |  | x | x | x | x
10 | Intg.Off | Rising | x | x | x | x
11 | v/Torq.Contr. | Active high | x | x | x | x
12 | Reference | IDN 147 | x | x | x | x
13 | ROD/SSI | Low/High | x | x | x | x
14 | FError_clear |  | x | x | x | x
15 | Start_MT Next |  | x | x | x | x
16 | Start_MT No x |  | x | x | x | x
17 | Start_ MT IO |  | x | x | x | x
18 | Ipeak2x |  | x | x | x | x
19 | Reserved |  |  |  |  |
20 | Start_Jog v=x |  | x | x | x | x
21 | U_Mon.off | High | x | x | x | x
22 | MT Restart |  | x | x | x | x
23 | Start2_MT No x |  | x | x | x | x
24 | Switch over OPMODE |  | x | x | x | x
25 | Zero_latch |  | x | x | x | x
26 | Position Latch | IDN 169 | x | x |  |
27 | Emergency Stop |  | x | x | x | x
28 | Reserved |  |  |  |  |
29 | Reserved |  |  |  |  |
30 | Command Buffer 1 |  | x | x | x | x
31 | Command Buffer 2 |  | x | x | x | x
32 | Brake |  | x | x | x | x
33 | see 30 |  | x | x | x | x
34 | see 31 |  | x | x | x | x
35 | Select Velocity/Current Entry |  | x | x | x | x
36 | Give Offset to Gearing Function |  | x | x | x | x
37 | Change source of actual position at EXTPOS=1 |  | x | x | x | x
38 | Enable signal for following motion task |  | x |  |  |
39 | Constant Speed for defined time |  | x | x | x | x
40 | Additional hardware input (enable) |  | x | x | x | x
41 | Fast emergency stop |  | x | x | x | x


IDN 3003 (P-0-3003) Configurable I/O: Digital Input 4 Mode

Determines the functionality of digital inputs 1 through 4. The digital inputs may be read directly through IDN 3030 through IDN 3033 . The following table describes the functions that are available. A new input mode will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | InxMODE (x = 1, 2, 3, or 4).
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBB

Definition:

INx-Mode | Description | Active Edge | Digital Input
 |  |  | 1 | 2 | 3 | 4
0 | Reserved | – |  |  |  |
1 | Reset |  | x |  |  |
2 | PSTOP | Active low |  |  | x | x
3 | NSTOP | Active low |  |  | x | x
4 | PSTOP+Intg.Off | Active low |  |  | x |
5 | NSTOP+Intg.Off | Active low |  |  |  | x
6 | PSTOP+NSTOP | Active low |  |  | x |
7 | P/NSTOP+Intg.Off | Active low |  |  | x |
8 | SETP.1/SETP.2 |  | x | x | x | x
9 | MT_No_Bit |  | x | x | x | x
10 | Intg.Off | Rising | x | x | x | x
11 | v/Torq.Contr. | Active high | x | x | x | x
12 | Reference | IDN 147 | x | x | x | x
13 | ROD/SSI | Low/High | x | x | x | x
14 | FError_clear |  | x | x | x | x
15 | Start_MT Next |  | x | x | x | x
16 | Start_MT No x |  | x | x | x | x
17 | Start_ MT IO |  | x | x | x | x
18 | Ipeak2x |  | x | x | x | x
19 | Reserved |  |  |  |  |
20 | Start_Jog v=x |  | x | x | x | x
21 | U_Mon.off | High | x | x | x | x
22 | MT Restart |  | x | x | x | x
23 | Start2_MT No x |  | x | x | x | x
24 | Switch over OPMODE |  | x | x | x | x
25 | Zero_latch |  | x | x | x | x
26 | Position Latch | IDN 169 | x | x |  |
27 | Emergency Stop |  | x | x | x | x
28 | Reserved |  |  |  |  |
29 | Reserved |  |  |  |  |
30 | Command Buffer 1 |  | x | x | x | x
31 | Command Buffer 2 |  | x | x | x | x
32 | Brake |  | x | x | x | x
33 | see 30 |  | x | x | x | x
34 | see 31 |  | x | x | x | x
35 | Select Velocity/Current Entry |  | x | x | x | x
36 | Give Offset to Gearing Function |  | x | x | x | x
37 | Change source of actual position at EXTPOS=1 |  | x | x | x | x
38 | Enable signal for following motion task |  | x |  |  |
39 | Constant Speed for defined time |  | x | x | x | x
40 | Additional hardware input (enable) |  | x | x | x | x
41 | Fast emergency stop |  | x | x | x | x


IDN 3004 (P-0-3004) Position Switch Configuration

Extends the functionality of the “Position Switch Points” ( IDN 60 0 through 63). A new position switch configuration will not be active until the parameter set is saved to non-volatile memory and a cold start or warm start ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | SWCNFG
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBC

Definition:

Bit | Description | Setting
LSB 0 | Control of negative SW-Limit switch ( IDN 50 and 55) | 0 = Control switched off 1 = Control active
1 | Reserved. | 0
2 | IDN 50 is working as a SW-Limit switch | 0 = Only report 1 = SW-Limit switched on
3 | Reserved | 0
4 | Control of positive SW-Limit switch ( IDN 49 and 55) | 0 = Control switched off 1 = Control active
5 | Reserved. | 0
6 | IDN 49 is working as a SW-Limit switch | 0 = Only report 1 = SW-Limit switched on
7 | Reserved. | 0
8 | Enable extended function for “Position Switch Point 1” ( IDN 60 ). | 0 = Disabled. 1 = Enabled.
9 | Switch point 1 digital output polarity. Note: A digital output mode ( IDN 3005 or 3006 ) must be set to 14. | 0 = PFB ( IDN 51 ) > IDN 60 1 = PFB ( IDN 51 ) < IDN 60
10 – 11 | Reserved. | 0
12 | Enable extended function for “Position Switch Point 2” ( IDN 61 ). | 0 = Disabled. 1 = Enabled.
13 | Switch point 2 digital output polarity. Note: A digital output mode ( IDN 3005 or 3006 ) must be set to 15. | 0 = PFB ( IDN 51 ) > IDN 61 1 = PFB ( IDN 51 ) < IDN 61
14 – 15 | Reserved. | 0


IDN 3005 (P-0-3005) Configurable I/O: Digital Output 1 Mode

Sets the functionality of the digital outputs. The digital outputs may be read through IDN 3036 and IDN 3037 A new digital output mode will not be active until the parameter set is saved to non-volatile memory and a coldstart or warmstart ( IDN 128 procedure is initiated. The following functions are available:

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | O1MODE, O2MODE
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBD
Definition:
Mode | Description | Logic
0 | Reserved | –
1 | V_act |
2 | V_act>x |
3 | Mains-RTO | High
4 | Regen off | Low
5 | Sw_limit |
6 | Pos.>x |
7 | InPos | High
8 | I_act |
9 | I_act>x |
10 | Ferror |
11 | I2t | High
12 | Posreg.1 |
13 | Posreg.2 |
14 | Posreg.3 | High
15 | Posreg.4 | High
16 | Next-InPos |
17 | Error/Warn |
18 | Error |
19 | DC_Link>x |
20 | DC_Link>x |
21 | ENABLE | High
22 | Zero_pulse | High
23 | Slot-DPR |
24 | Ref_OK | High
25-27 | Reserved |
28 | Posreg.0 |
29 | Posreg.5 |
30 | OR-Operation of all Posreg. |
31-34 | Reserved |
35 | Internal Enable |
36 | Logical OR: DRVSTAT – x |
37 | Logical AND: DRVSTAT – x |
38 | Logical OR: TRJSTAT -x |
39 | Logical AND: TRJSTAT -x |
40 | Logical OR: POSRSTAT -x |
41 | Logical AND: POSRSTAT - x |
42 |  |
43 | The sign of the actual speed |
44 | Velocity In-Position (active high) |
45 | Velocity In-Position (active low) |
46 | Current in Window (low active) |
47 | Current not in Window (low active) |


IDN 3006 (P-0-3006) Configurable I/O: Digital Output 2 Mode

Sets the functionality of the digital outputs. The digital outputs may be read through IDN 3036 and IDN 3037 A new digital output mode will not be active until the parameter set is saved to non-volatile memory and a coldstart or warmstart ( IDN 128 procedure is initiated. The following functions are available:

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | O1MODE, O2MODE
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BBE
Definition:
Mode | Description | Logic
0 | Reserved | –
1 | V_act |
2 | V_act>x |
3 | Mains-RTO | High
4 | Regen off | Low
5 | Sw_limit |
6 | Pos.>x |
7 | InPos | High
8 | I_act |
9 | I_act>x |
10 | Ferror |
11 | I2t | High
12 | Posreg.1 |
13 | Posreg.2 |
14 | Posreg.3 | High
15 | Posreg.4 | High
16 | Next-InPos |
17 | Error/Warn |
18 | Error |
19 | DC_Link>x |
20 | DC_Link>x |
21 | ENABLE | High
22 | Zero_pulse | High
23 | Slot-DPR |
24 | Ref_OK | High
25-27 | Reserved |
28 | Posreg.0 |
29 | Posreg.5 |
30 | OR-Operation of all Posreg. |
31-34 | Reserved |
35 | Internal Enable |
36 | Logical OR: DRVSTAT – x |
37 | Logical AND: DRVSTAT – x |
38 | Logical OR: TRJSTAT -x |
39 | Logical AND: TRJSTAT -x |
40 | Logical OR: POSRSTAT -x |
41 | Logical AND: POSRSTAT - x |
42 |  |
43 | The sign of the actual speed |
44 | Velocity In-Position (active high) |
45 | Velocity In-Position (active low) |
46 | Current in Window (low active) |
47 | Current not in Window (low active) |


IDN 3007 (P-0-3007) Configurable I/O: Digital Output 1 Trigger

Sets a help or trigger value to the functionality of the digital outputs (refer to IDN 3005 and P3006).

Sets a help or trigger value to the functionality of the digital outputs (refer to IDN 3005 and IDN 3006 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | OxTRIG
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BBF


IDN 3008 (P-0-3008) Configurable I/O: Digital Output 2 Trigger

Sets a help or trigger value to the functionality of the digital outputs (refer to IDN 3005 and P3006).

Sets a help or trigger value to the functionality of the digital outputs (refer to IDN 3005 and IDN 3006 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | OxTRIG
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BC0


IDN 3010 (P-0-3010) Feedback Type

Sets the motor feedback type. A new feedback type will not be active until the parameter set is saved to non-volatile memory and a coldstart or warmstart ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | FBTYPE
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x8BC2
Definition:
Mode | Function | Comments
0 | Resolver | The 6SM series motors have 2-pole hollow-shaft resolvers. 2, 4 or 6-pole resolvers are supported. Cycle time 62.5 (s.
1 | Reserved |
2 | HIPERFACE( With Zero Pulse | HIPERFACE( compatible feedback interface with a commutation track (e.g. SNS 50 from Stegmann). The rotor position after power-on is transmitted asynchronously as an absolute value to the servo amplifier (error (3(). The axis must be rotated through a full turn in order to evaluate the zero pulse. A reset is not possible during the zeroing movement. The encoder emulation is valid only after the zeroing movement has completed. Cycle time 125 (s.
3 | Resolver, EnDAT oder Hiperface |
4 | EnDat | High-resolution absolute encoder (single or multi-turn) with a EnDat compatible feedback interface (e.g. ECN 1313 or EQN 1325 from Heidenhain). Cycle time 125 (s.
5 | Reserved. |
6 | Sine/Cosine Encoder |
7 | Sine/Cosine Encoder |
8 | RS422 & Wake&Shake |
9 | RS422 Feedback Device; MPHASE is loaded out of the EEPROM |
10 | Without Feedback Device (sensorless) |
11 | Sine encoder feedback with hall’s |
12 | RS422 feedback device with hall’s |
13-15 | Reserved |
16 | Start-up with resolver (commutation), then switch over to Sine/Cosine encoder (FBTYPE=7) |


IDN 3011 (P-0-3011) Encoder Emulation Mode

Sets the signaling format for the encoder emulation on connector X5. A new emulation mode will not become active until the parameter set is saved to non-volatile memory and a coldstart or warmstart ( IDN 128 procedure is initiated.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: | ENCMODE
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BC3
Definition:
Mode | Function | Comments
0 | Input | The interface is used as an input.
1 | AqB (ROD) | Incremental encoder emulation. Incremental encoder compatible pulses (max. 250 kHz) are transmitted as two signals (A and B) with a 90( electrical phase difference (quadrature). A zero marker pulse is also transmitted. If an encoder with a commutation track is used, then the output of the zero marker pulse is inhibited until the zero pulse from the encoder has been evaluated.
2 | SSI | Synchronous serial interface (SSI) for absolute encoder emulation. The standard SSI absolute encoder format transmits 24 bits. The upper 12 bits are fixed to zero and the lower 12 bits contain position information. For ‘N’ pole resolver feedback systems, the transmitted position refers to the position within 2/N turns of the motor. If an encoder with a commutation track is used as feedback, then the upper 12 bits are set to 1 (invalid data) until homing is performed.


IDN 3012 (P-0-3012) Difference Probe Edge Value 1

The amount of the difference between two latched values of probe 1 is stored here. Which latched values are used to calculate the edge difference is defined with the IDN 3014 “Probe Difference control parameter”. The value will direct computed when a new value is latched (refer to IDN 3014 .

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: | 0 | Run-Up Check: |
Maximum: | 7FFF FFFFH | Cyclic Transfer: | AT
Default: | 0 | Serial Equiv: |
Units: | IDN 76 , 77, 78, 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BC4


IDN 3013 (P-0-3013) Difference Probe Edge Value 2

The amount of the difference between two latched values of probe 2 is stored here. Which latched values are used to calculate the edge difference is defined with the IDN 3014 “Probe Difference control parameter”. The value will direct computed when a new value is latched (refer to IDN 3014 .

Data Length: | 4 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: | 0 | Run-Up Check: |
Maximum: | 7FFF FFFFH | Cyclic Transfer: | AT
Default: | 0 | Serial Equiv: |
Units: | IDN 76 , 79 | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BC5


IDN 3014 (P-0-3014) Probe Difference Control Parameter

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 6 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x8BC6
Definition:
Value | Description
0 | Difference probe edge function is off
1 | Compute distance between one positive edge and one negative edge
2 | Compute distance between one negative edge and one positive edge
3 | Compute distance between two successive positive edges
4 | Compute distance between two successive negative edges
5 | Compute distance between the first positive and negative edge
6 | Compute distance between the first negative and positive edge


IDN 3015 (P-0-3015) Hardware Limit Switch Consequence

This parameter define the consequence off the Hardware Limit Switch, if the corresponding digital inputs ( IDN 3002 and/or IDN 3003 ) are set to the limit switches. If the hardware limit switch consequence is set to 0, then the Limit switch consequence is a warning. Else if the IDN P3015 is set to 1, then the switch consequence is a fault and the drive ramp down with setting the following fault bits, in IDN 11 bit 15 and in IDN 129 the bit 2. After the reset class 1 diagnostic command ( IDN 99 ) the drive could enable again and move back in the valid range. During the procedure drive controlled homing ( IDN 148 ), the hardware limit switch could use in the normal way (refer to IDN 3027 .

This parameter define the consequence off the Hardware Limit Switch, if the corresponding digital inputs ( IDN 3002 and/or IDN 3003 ) are set to the limit switches. If the hardware limit switch consequence is set to 0, then the Limit switch consequence is a warning. Else if the IDN IDN 3015 is set to 1, then the switch consequence is a fault and the drive ramp down with setting the following fault bits, in IDN 11 bit 15 and in IDN 129 the bit 2. After the reset class 1 diagnostic command ( IDN 99 ) the drive could enable again and move back in the valid range. During the procedure drive controlled homing ( IDN 148 ), the hardware limit switch could use in the normal way (refer to IDN 3027 .

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SERCSET (Bit 0)
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x8BC7


IDN 3016 (P-0-3016) Reset Command Consequence

This parameter define the consequence off the reset class 1 diagnostic command ( IDN 99 ), for faults which require a coldstart. If this IDN is set, faults which require a coldstart will not clear. The reset command will abort with the SC message “Command execution not possible” (refer to IDN 11 , 99 and 129).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | SERCSET (Bit 1)
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x8BC8


IDN 3018 (P-0-3018) Configuration of the Positionlatch

BECKHOFF Drive Technology: AX2000-B750 - IDN Reference

IDN 3018 (P-0-3018) Configuration of the Position latch

This IDN defines, the source of Position information of the latch function, if the digital input 1 and 2 are set for the latch function (IN1MODE = 26 and IN2MODE = 26). If both inputs are select for position latch, with the digital input 2 ( IDN 3031 the Probe 1 function will be support and with the digital input 1 ( IDN 3030 the Probe 1 function will be supported (refer to IDN 169 , 170, 40 and 406). If IN1MODE is different from 26 this IDN IDN 3018 (EXTLATCH) has no function , with an edge at the digital input 2 both (Probe 1 and 2) will be latched.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 2 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | EXTLATCH
Units: |  | Version: | 5.04
IDN Type: | FB | ADS Index Group (hex.): | 0x8BCA
Definition:
IDN 3000 (IN1MODE) NOT_EQUAL 26 IDN P3001 (IN2MODE) = 26 |  | IDN 3000 (IN1MODE) = 26 IDN 3001 (IN2MODE) = 26 |  |
IDN 3031 (IN2) | IDN 3030 (IN1) | IDN 3031 (IN2) | IDN 3030 (IN1) | IDN P3018 (EXTLATCH)
Probe1=Motor Fbk. Probe2=ext. Fbk. | No Latch Function | Probe1 = Motor Fbk. | Probe2=Motor Fbk. | 0
 |  | Probe1 = Motor Fbk. | Probe2=ext. Fbk. (inc. Encoder) | 1
 |  | Probe1=ext. Fbk. (inc. Encoder) | Probe2=ext. Fbk. (inc. Encoder) | 2


IDN 3019 (P-0-3019) Select of the FPGA Program

This IDN select the FPGA program of the drive, which will be download to the FPGA in the initialization.

FPGA = 0: Standard FPGA program

FPGA = 1: Program with Up/Down counter (this allows the usage of a high resolution feedback and Master/ Slave functionality; Program with second counter for latch function on the digital input 1

It exist a third FPGA program, for reading of external SSI encoder as a second encoder. This program is automatically selected if GEARMODE = 7 is selected.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | FPGA
Units: |  | Version: | 5.04
IDN Type: | CT:FS | ADS Index Group (hex.): | 0x8BCB


IDN 3020 (P-0-3020) System Rated Current

Allows setting the rated output current of the drive/motor system.

Data Length: | 4 bytes | Non-Volatile: | yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3
Minimum: | 10% of IDN 112 . | Run-Up Check: |
Maximum: | Minimum of IDN 111 and IDN 112 . | Cyclic Transfer: |
Default: | 50% of the minimum of IDN 112 . | Serial Equiv: | ICONT
Units: | MA | Version: | 5.04
IDN Type: | CT:FS | ADS Index Group (hex.): | 0x8BCC


IDN 3021 (P-0-3021) Over Speed

The maximum motor speed threshold. If the maximum motor speed is exceeded, then an over speed fault ( IDN 129 , bit 9) occurs.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1.2 * IDN 113 | Cyclic Transfer: |
Default: | 36 000 000 | Serial Equiv: | VOSPD * 10 000
Units: | 0.0 001 RPM | Version: | 5.04
IDN Type: | VE:FS | ADS Index Group (hex.): | 0x8BCD


IDN 3022 (P-0-3022) Quick Deceleration Rate

The drive uses the quick deceleration rate during an active disable (MDT control bit 15, a fault or a limit switch). The quick deceleration limit is defined as the number of milliseconds required to decelerate from the maximum velocity limit ( IDN 38 , 39, 91) to a standstill.

Data Length: | 4 bytes | Non-Volatile: | Yes
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | 1 | Run-Up Check: |
Maximum: | 32767 | Cyclic Transfer: |
Default: | 10 | Serial Equiv: | DECSTOP
Units: | IDN 160 , 161, 162 | Version: | 5.04
IDN Type: | AD | ADS Index Group (hex.): | 0x8BCE


IDN 3026 (P-0-3026) Non-Volatile Memory Data Checksum

A checksum of the data stored within non-volatile memory. The checksum is updated after a “Back-up Working Memory” procedure ( IDN 264 ) has been executed successfully.

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Unsigned decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: |
Default: |  | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | SC | ADS Index Group (hex.): | 0x8BD2


IDN 3027 (P-0-3027) Manufacturer Homing Modes

Selection of manufacturer defined homing modes. Use IDN 41 , IDN 42 and IDN 147 to set the homing velocity, acceleration and direction. This IDN contains the saved serial command NREF after reset. Write this P IDN or write IDN 147 through the service channel, could change the used homing mode for the drive controlled homing ( IDN 148 ). After or while homing with SERCOS the parameter NREF contains the value of this IDN. A following SAVE command can save this value permanent.

For an explanation of the homing modes 0, 3, 4, 5 and 6 please refer to the Kollmorgen manual “Setup Software SR600.exe for ServoSTAR 600.”

Standard SERCOS homing (mode 1): For an explanation of the standard homing mode, please refer to the IEC 61491 Standard or to the Kollmorgen manual “Setup Software SR600.exe for ServoSTAR 600.” This is the default value also for IDN 147 (refer to IDN 147 ).

Hardware Limit Switch Homing (mode 2): This homing mode uses a hardware limit switch as the home switch. The following diagrams show this homing option, without reference switch, in both the positive and the negative directions of motion with zero mark of the feedback.

Warning: Hardware limit switches must be present and connected. The appropriate limit switch functions must be switched on, i.e. digital input 3 must be PSTOP ( IDN 3002 mode 2) and/or digital input 4 must be NSTOP ( IDN 3003 mode 3).

Mechanical Stop Homing (mode 7): This homing mode uses the mechanical stop instead of a separate homing switch or a hardware limit switch. Set the maximum current (torque) limit through IDN 92 , to limit the torque applied against the mechanical stop. The mechanical stop must be fixed in place and hardware limit switches must be disabled in the direction of the mechanical stop. It is not possible to re-enable or disable hardware limit switches in CP4. When motion toward the stop is no longer possible, the following error increases and triggers a movement back to the first zero mark. The following diagrams show this homing option, in both the positive and the negative directions of motion.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Unsigned decimal | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 7 | Cyclic Transfer: |
Default: | 1 | Serial Equiv: | NREF
Units: |  | Version: | 5.04
IDN Type: | PS:VE | ADS Index Group (hex.): | 0x8BD3
Definition:
Mode | Function | IDN 147 (bits 7-0)
0 | Set reference point to the actual position | 1110 0xxx
1 | Traverse to the reference switch with zero-mark recognition | 1000 010x
2 | Move to hardware limit-switch, with zero-mark recognition | 1000 010x
3 | Move to reference switch, without zero-mark recognition | 1100 010x
4 | Move to hardware limit-switch, without zero-mark recognition | 1100 010x
5 | Move to the next zero-mark of the feedback unit | 1010 0xxx
6 | Set reference at actual position, without loosing target position | 1110 0xxx
7 | Move to mechanical stop with zero-mark recognition | 1000 010x
8 | Move to absolute SSI-position |
9 | Move to mechanical stop without zero-mark recognition |


IDN 3030 (P-0-3030) Configurable I/O: Digital Input 1 Status

Reflects the state of a digital input (connector X3 pins 11 - 14) in the least significant bit of the IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BD6


IDN 3031 (P-0-3031) Configurable I/O: Digital Input 2 Status

Reflects the state of a digital input (connector X3 pins 11 - 14) in the least significant bit of the IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BD7


IDN 3032 (P-0-3032) Configurable I/O: Digital Input 3 Status

Reflects the state of a digital input (connector X3 pins 11 - 14) in the least significant bit of the IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BD8


IDN 3033 (P-0-3033) Configurable I/O: Digital Input 4 Status

Reflects the state of a digital input (connector X3 pins 11 - 14) in the least significant bit of the IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | IN1, IN2, IN3, IN4
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BD9


IDN 3034 (P-0-3034) Analog Input 1 Value

Returns the differential voltage at an analog input, which may vary from +10V to -10V. Analog input 1 is located on connector X3 (pins 4 and 5). Analog input 2 is located on connector X3 (pins 6 and 7).

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | ANIN1, ANIN2
Units: | mV | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDA


IDN 3035 (P-0-3035) Analog Input 2 Value

Returns the differential voltage at an analog input, which may vary from +10V to -10V. Analog input 1 is located on connector X3 (pins 4 and 5). Analog input 2 is located on connector X3 (pins 6 and 7).

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | Read-only
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | AT
Default: |  | Serial Equiv: | ANIN1, ANIN2
Units: | mV | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDB


IDN 3036 (P-0-3036) Configurable I/O: Digital Output 1 Control/Status

The master may set and read the state of a digital output in the least significant bit of the corresponding digital output control/status IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: | 0 | Serial Equiv: | O1, O2
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDC


IDN 3037 (P-0-3037) Configurable I/O: Digital Output 2 Control/Status

The master may set and read the state of a digital output in the least significant bit of the corresponding digital output control/status IDN.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: |  | Run-Up Check: |
Maximum: |  | Cyclic Transfer: | MDT
Default: | 0 | Serial Equiv: | O1, O2
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDD


IDN 3038 (P-0-3038) Probe 1 and 2 Enable

Used to arm the position capture mechanism for probe 1 and 2 so that the next valid probing signal edge captures the current position into IDN 130 and 132 or 131 and 133. This IDN could only used if the IDN 3039 is set to 1 by the master. IDN IDN 3038 may be assigned to a RTC bit (MDT control word bit 6 or 7) through IDN 301 or IDN 303 . This IDN is write-protected while it is assigned to a RTC bit.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDE


IDN 3039 (P-0-3039) Probe 1 and 2 Control Parameter

The master may use this IDN to configure the probe enable IDNs. If this IDN is set to 0, the master can enable both probes with IDN 405 and 406 and if it is set to 1, the master can enable both probes with IDN 3038 at the same time. The following rules govern the assignment and use of this IDN:

This IDN can not set to 0, if the IDN 3038 is actual assign to a real time control bit through IDN 301 or 303.

This IDN can not set to 0, if the IDN 3038 is actual set to 1.

This IDN can not set to 1, if the IDN 405 or 406 is actual assign to a real time control bit through IDN 301 or 303.

This IDN can not set to 1, if the IDN 405 or 406 is actual set to 1.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BDF


IDN 3040 (P-0-3040) Interpolation Method

The master may determine the fine interpolation method within the drive with this IDN. If this IDN is set to 1 the drive work, by a 3 ms and 4 ms cycle time, with a spline interpolation for the command values instead of a liner interpolation.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | IO | ADS Index Group (hex.): | 0x8BE0


IDN 3041 (P-0-3041) Position Switch On/Off Parameter

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | WPOS
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BE1


IDN 3042 (P-0-3042) Position Switch Enable/Disable Parameter

This IDN could use to enable or disable the check of each position switch point for the position switch flag parameter ( IDN 59 ) (refer to IDN 59 , IDN 3041 , 3043 and P3044).

This IDN could use to enable or disable the check of each position switch point for the position switch flag parameter ( IDN 59 ) (refer to IDN 59 , IDN 3041 , 3043 and IDN 3044 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0000H | Run-Up Check: |
Maximum: | 00FFH | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | WPOSE
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BE2
Definition:
Bit | Description | Setting
LSB 0 | Position switch point 1 ( IDN 60 ) | 0 = Disable 1 = Enable Position Switch Flag
1 | Position switch point 2 ( IDN 61 )
2 | Position switch point 3 ( IDN 62 )
3 | Position switch point 4 ( IDN 63 )
4 | Position switch point 5 ( IDN 64 )
5 | Position switch point 6 ( IDN 65 )
6 | Position switch point 7 ( IDN 66 )
7 | Position switch point 8 ( IDN 67 )
8-15 |  | Reserved


IDN 3043 (P-0-3043) Position Switch Polarity Parameter

With this IDN it is possible to select the polarity for each position switch flag to the corresponding flag bit ( IDN 59 ) or the digital output (refer to IDN 59 , IDN 3041 , 3042 and IDN 3044 ).

With this functionality it is possible to implement a cam function with a positive or negative polarity.

Application Example : Positive Cam Function

IDN 60 = 2/8 Revolution IDN 3041 0001Hex IDN 3042 = 0003Hex

IDN 61 = 3/8 Revolution IDN IDN 3043 = 0002Hex IDN 3044 = 0

IDN 3005 = 41 IDN 3007 = 0003Hex

Application Example : Negative Cam Function

IDN 60 = 2/8 Revolution IDN 3041 0001Hex IDN 3042 = 0003Hex

IDN 61 = 3/8 Revolution IDN IDN 3043 = 0001Hex IDN 3044 = 0

IDN 3005 = 40 IDN 3007 = 0003Hex

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0000H | Run-Up Check: |
Maximum: | 00FFH | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | WPOSP
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BE3
Definition
Bit | Description | Setting
LSB 0 | Position switch point 1 ( IDN 60 ) | 0= The flag will set to “1” if the position feedback is greatern than or equal to the position switch point. 1 = The flag will set to “0” if the position feedback value is smaller than the position switching point.
1 | Position switch point 2 ( IDN 61 )
2 | Position switch point 3 ( IDN 62 )
3 | Position switch point 4 ( IDN 63 )
4 | Position switch point 5 ( IDN 64 )
5 | Position switch point 6 ( IDN 65 )
6 | Position switch point 7 ( IDN 66 )
7 | Position switch point 8 ( IDN 67 )
8-15 |  | Reserved


IDN 3044 (P-0-3044) Kind Of Position Switch Parameter

With this IDN it is possible to select the kind of the position check for each position switch flag to the corresponding flag bit ( IDN 59 ) or the digital output (refer to IDN 59 , IDN 3041 , 3042 and P3043).

With this IDN it is possible to select the kind of the position check for each position switch flag to the corresponding flag bit ( IDN 59 ) or the digital output (refer to IDN 59 , IDN 3041 , 3042 and IDN 3043 ).

Data Length: | 2 bytes | Non-Volatile: | Yes
Data Type: | Binary | Write Access: | CP2, CP3, CP4
Minimum: | 0000H | Run-Up Check: |
Maximum: | 00FFH | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | WPOSX
Units: |  | Version: | 5.04
IDN Type: | PS | ADS Index Group (hex.): | 0x8BE4
Definition:
Bit | Description | Setting
LSB 0 | Position switch point 1 ( IDN 60 ) | 0 = The position check is operating the hole time. 1 = The position flag is check once. The corresponding bit in IDN 59 will set and latched and the corresponding enable bit in IDN 3042 will reset.
1 | Position switch point 2 ( IDN 61 )
2 | Position switch point 3 ( IDN 62 )
3 | Position switch point 4 ( IDN 63 )
4 | Position switch point 5 ( IDN 64 )
5 | Position switch point 6 ( IDN 65 )
6 | Position switch point 7 ( IDN 66 )
7 | Position switch point 8 ( IDN 67 )
8-15 |  | Reserved


IDN 3045 (P-0- 3045)

With this parameter the integral part of the current controller can be loaded. This could be necessary by switching into the operation mode torque control under load, in order to ensure a transition without jerks.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3, CP4
Minimum: | -1640 | Run-Up Check: |
Maximum: | 1640 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: |
Units: |  | Version: | 5.04
IDN Type: | CT | ADS Index Group (hex.): | 0x8BE5


IDN 3046 (P-0- 3046) Motor Number

The command “MNUMBER nr” is used to load a motor data set with the number “nr” from the motor database. If MNUMBER 0 is entered, then no data set will be loaded, but the variable MNUMBER will simply be set to 0. This setting indicates a customer-specific motor data set.

Data Length: | 2 bytes | Non-Volatile: | No
Data Type: | Signed decimal | Write Access: | CP2, CP3
Minimum: | 0 | Run-Up Check: |
Maximum: | 215 - 1 | Cyclic Transfer: |
Default: | 0 | Serial Equiv: | MNUMBER
Units: |  | Version: | 5.04
IDN Type: | VE | ADS Index Group (hex.): | 0x8BE6


Übersicht

Nachfolgend aufgeführte Geräte mit Ethernet TCP/IP-Schnittstelle, werden aktuell von TwinCAT unterstützt:

Beckhoff Ethernet - Teilnehmer ("Boxen") | Beschreibung | Einschränkungen / Anmerkung
BK9000 | Beckhoff Ethernet Standard Buskoppler |
BC9000 | Beckhoff Ethernet Busklemmen Controller |
IPxxxx-B900 | Beckhoff Ethernet Kompakt Box | (aktuell noch nicht verfügbar)
ILxxxx-B900 | Beckhoff Ethernet Koppler Box | (aktuell noch nicht verfügbar)
ILxxxx-C900 | Beckhoff Ethernet SPS Box | (aktuell noch nicht verfügbar)


Übersicht

Nachfolgend aufgeführte Geräte für Beckhoff TwinCAT Real-Time Ethernet, werden aktuell von TwinCAT unterstützt:

Real-Time Ethernet - Teilnehmer ("Boxen") | Beschreibung | Einschränkungen / Anmerkung
BK9000 | BK9000 für Beckhoff Real-Time Ethernet | BK9000 Firmware-Version ab 'B8' erforderlich
AX2000-B900 | AX20xx drive with optional Real-Time Ethernet interface card | AX2000-B900 Firmware ab 'B8' erforderlich (Ethernet Interface)
Netzwerkvariable "Subscriber" | Beckhoff TwinCAT Zielsystemvariable als "Subscriber" |
Netzwerkvariable "Publisher" | Beckhoff TwinCAT Zielsystemvariable als "Publisher" |

Hinweis:

Eine Anleitung zur Installation des Beckhoff Real-Time Ethernet Treibers finden Sie hier...


Real-Time Ethernet - Netzwerkvariable Publisher

TwinCAT System Manager: Reference

Netzwerkvariable Publisher

The Beckhoff TwinCAT Real-Time Ethernet solution contains from TwinCAT v2.9 on the ability to configure variables for deterministic data exchange between several TwinCAT-based controllers. The last could be other TwinCAT PCs or CX controllers. These varaibles are the so-called Network Variables. For this solution it is required to configure the Ethernet Miniport (Real-Time) I/O device type at first.
For an Overview of TwinCAT Real-Time Ethernet devices, see..

The Publisher is the send-type network variable. It sends its informations out without waiting for acknowledgement. The communication is only monitored by the Subscriber.

Dialog "Allgemein"

Standard dialog as for all TwinCAT I/O devices. Nevertheless, a descriptive name for this Publisher (sender) should be edited here. Additionally, a useful comment (i.e. about the target/subscriber this publisher sends its data to) could be very helpful.

Id: A Real-Time Ethernet Publisher ident. number.

Hint:
If several Publisher variables have to be set up in same network at other TwinCAT controllers, make sure that they all have network-unique Id's (means in above case for instance, that '1' is already in use and can't be assigned to a second Publisher network variable).

Dialog "Publishen"

Sending Options

Broadcast: If this option is selected and the node receives the Ethernet frame in its receiving queue, it evaluates whether the data is addressed to him or not. This is not a very "economical" way of communication.

Multicast: If this option is selected, the Ethernet frame is getting evaluated by all attached nodes of the subnet. But instead of processing it with the receive queue, the Ethernet controller detects whether the data is for "him" or not.

Unicast: If selected, the switch opens parallel communication paths and forwards the Ethernet frame directly to the appropriate Subscriber (receiver).

MAC Address: Subscriber MAC Address. For further informations, see: Ethernet Miniport (Real-Time)

AMS Netid: ...

Data Exchange: see: BK9000

VLAN Support: see: BK9000

Diagnose

Inputs

Variable | Description
FrameState | Real-Time Ethernet frame status information as WORD (or UINT) variable, assumes the following values: 0x0001 = Not sent (frame skipped), means FrameCtrl is currently = '1' 0x0002 = Error (frame oversized)

Outputs

Variable | Description
FrameCtrl | Real-Time Ethernet frame control as WORD (or UINT) variable, accepts the following values: 0x0001 = Disable sending If FrameCtrl receives above value (e.g. from mapped PLC variable), this frame doesn't get sent. The sending will be continued if FrameCtrl has been released again (= '0'). The FrameState variable assumes the value '1' in the meantime. The related subscriber variables CycleIndex and Quality will notice on the other side that the frame transmission has been suppressed.

Kontextmenü

Insert Network Variable: Please see description under Subscriber

Other items: Please see Adding Input/Output Modules

Publisher Variable - Ausgänge

Variable | Data type | Description
VarCtrl | UINT | Can be set to 0x0001 = Disable publishing The transmission of this publisher variable is suppressed in above case (until VarCtrl becomes '0' again). The subscriber CycleIndex variable stays static and the Quality counts up (to a maximum of 65535).
VarData | as specified | To be linked to the output variable (e.g. PLC output) to be transmitted via TwinCAT Real-Time Ethernet.


Real-Time Ethernet - Netzwerkvariable Subscriber

TwinCAT System Manager: Reference

Netzwerkvariable Subscriber

The Beckhoff TwinCAT Real-Time Ethernet solution contains from TwinCAT v2.9 on the ability to configure variables for deterministic data exchange between several TwinCAT-based controllers. The last could be other TwinCAT PCs or CX100x controllers. For this solution it is required to configure the Ethernet Miniport (Real-Time) I/O device type first.
For an Overview of TwinCAT Real-Time Ethernet devices, see..

The Subscriber is the receive-type variable of the TwinCAT target system. It receives values from the Publisher variable of the networked TwinCAT controller.

Dialog "Allgemein"

Standard dialog as for all TwinCAT I/O devices. Nevertheless, a descriptive name for this Subscriber should be edited here. Additionally, a useful comment (i.e. about the Publisher the data is coming from) could be very helpful.

Diagnose

Inputs

Variable | Description
FrameState | This variable is currently not in use at subscribers

Outputs

Variable | Description
FrameCtrl | This variable is currently not in use at subscribers

Kontextmenü

Netzwerk Variable einfügen: Ruft den folgenden Auswahldialog auf:

Browse for Computer: Calls the Choose Target System dialog.

Browse for File: Calls the file selection dialog for existing TwinCAT System Manager project files (*.tsm). If Publisher variables have been found in the selected file, these variables get listed in the Name, Id, Size, Type section of above dialog.

Create new Variable: Calls the Insert Network Variable dialog described below.

Dialog "Einfügen Netzwerk Variable"

Name: A descriptive name for the subscriber variable should be edited here.

Id: ...

Comment: Space for a helpful comment about this subscriber variable.

Type: Lists available data types for this variable. The appropriate type has to be selected here. This could be standard data type, an array or a complex structure.
If e.g. the process image of the configured PLC project contains a user-defined data type (i.e. a structure) with the name 'MyType', it would show up on the list like shown above.

Subscriber variable - Inputs

Variable | Data type | Description
VarState | UINT | This variable is currently not in use
Quality | UINT | This variable shows how "old" the value of this subscriber variable is. Means, every 100μs the data variable is not updated this value gets increased by 1. This could happen e.g. when the link of the network connection is lost. After re-establishing it, the value is set back to 0 again. Max. value of Quality is 65535.
CycleIndex | UINT | This variable value increments with every I/O cycle the publisher does. The subscriber extracts this value out of the Ethernet frame.
VarData | as specified | To be linked to input variable (e.g. to PLC input).

Variable | Data type | Description
VarCtrl | UINT | This variable is currently not in use


AX2xxx-B900 Axis (Real-Time Ethernet)

TwinCAT System Manager: Reference

AX2xxx-B900 Axis (Real-Time Ethernet Interface)

The Beckhoff AX2000 resp. AX2500 drive is available with different (optional) Fieldbus interfaces. One variant is the AX2000 with TwinCAT Real-Time Ethernet interface (part no.: AX20xx-B900). The AX2xxx-B900 is implemented in TwinCAT as a real-time capable device if used in an Ethernet Miniport subnet. For an Overview of all currently supported devices for Ethernet Miniport, please see...

Hint: If Real-Time Ethernet and "normal" Ethernet are both used on the same system with two different network adapters, the subnet addresses of these adpaters (NICs) must differ! The AX2xxx-B900 has to be configured with the same subnet address (first two quadruples) as the Ethernet Miniport adapter in this case of course.

"AX2000-B900" tab

Diagnosis: This checkbox is deactivated for the AX2000-B900.

2 Byte PLC Interface: This checkbox is deactivated for the AX2000-B900.

No Real Time Flag: If the AX2000-B900 belongs to an Ethernet Miniport subnet, but is not intended to be used for real-time data exchange, this box has to be checked.

K-Bus Update: Estimated internal update time for the -B900 interface.

Firmware Update: The firmware update dialog is called by pushing this button. With this function, the most recent firmware version for the -B900 slot interface can be loaded (via LAN or COM port).

Data Exchange:

- Divider: see: BK9000

- Modulo: see: BK9000

VLAN Support:

- Enable: Activates the VLAN support (see: IEEE 802.1Q, RFC3518) for the communication with this device. If enabled, the Ethernet frame is getting extended by 4 byte. These extension is called VLAN tag and contains for instance informations about ID and priority .

- Priority: A 3 bit VLAN priority value as defined by IEEE 802.1D. Most switches contain two queues, a high and a low priority one. Therefore priorities between 0..3 are assigned to the high priority queue and 4..7 are assigned to the low priority queue at those switch types.

- Id: 12 bit VLAN identifier number as defined by IEEE 802.1Q.

"IP Address" Tab

For further informations about this tab, see -> "IP Address" Tab.

"ADS Commands" Tab

For further informations about this tab, see -> "ADS Command Window".

"Online" Tab

For further informations about this tab, see: "AX2xxx Drive Tab - Online".

"Inputs" Tab

For further informations about this tab, see: "AX2xxx Drive Tab - Inputs"

"Outputs" Tab

For further informations about this tab, see: "AX2xxx Drive Tab - Outputs"

Diagnosis Inputs

The below shown variable DriveError has been added manually!

If the variables DriveError, DriveState2 (default) and DriveState3 (default) are added as described under AX2xxx Drive Tab - Inputs, they can be used for diagnosis purposes. If they are linked to a TwinCAT PLC process image for instance, they can be evaluated inside the PLC run-time system.

For further informations about the error and warning codes of the AX2xxx drive, see: "AX2xxxx Drive - Status and Error Codes".


EtherCAT Slave Device

TwinCAT System Manager: EtherCAT

Overview

With EtherCAT the division into boxes and bus terminals does not exist any more. Every terminal has an EtherCAT Slave controller(ESC) integrated and therefore is a full EtherCAT slave device. An EtherCAT slave device can either be added to the EtherCAT(Direct Mode) Device or to the Real-Time Ethernet device. The basic property pages for the EtherCAT slaves devices are the same for every connected device, be it a terminal, a drive or a bus coupler.

Tab | Description
General | General information.
EtherCAT | EtherCAT specific configuration.
Process Data | Configuration of the process data.
Online | Displays online information about the EtherCAT slave device.

Intelligent devices( for instance drives) that support a mailbox protocol for asynchronous communication have one or more of the following additional tabs:

Tab | Description
Mailbox | Mailbox configuration
Startup | The "Startup" tab is displayed, if the slave device has a mailbox and supports either the CANopen over EtherCAT(Coe) protocol or the Servo Drive over EtherCAT(SoE) protocol. With the help of the "Startup" tab the user can configure which download requests are sent to the mailbox during startup.
Coe-Online | If the EtherCAT slave device supports the CANopen over EtherCAT(CoE) protocol the additional tab "CoE-Online" appears. This tab enables the user to view the contents of the object dictionary of the slave(SDO-Upload) and to change the contents of an object in the dictionary(SDO-Upload).
SoE-Online | If the EtherCAT slave device supports the CANopen over EtherCAT(SoE) protocol the additional tab "SoE-Online" appears.


EtherCAT Slave Device

EtherCAT Slave Device "EtherCAT" tab:

Type: Name of the EtherCAT Slave device.

Product/Revision: Product and Revision number of the EtherCAT slave device.

Auto Inc Addr: The Auto Increment Address of the EtherCAT slave device. Auto-increment addressing can be used to address each slave device via its physical position in the communication ring. Auto-increment addressing is used during the start-up phase, during which the master assigns the EtherCAT Address to the slaves. The first slave in the ring has an address of 0 and for each following the addresses is decremented (0xFFFF(-1),0xFFFE(-2) etc.).

EtherCAT Addr: The fixed Address of the EtherCAT slave device. This address is set by the master during the start-up phase. To change the default value you have to check the box left to the address.

Advanced Settings: Opens the Advanced Settings dialog.

Previous Port: The port and name of the EtherCAT slave device this device is connected to. If it is possible to connect this device to a different without changing the order of the EtherCAT slave devices in the communication ring, the combo box is enabled and one can select the EtherCAT device this device should be connected to.

EtherCAT Slave Device "Process Data" tab:

Displays the configuration of the process data. The input and output variables of the slave device are displayed as CANopen Process Data Objects(PDO). If supported by the slave device this dialog enables the user to select a different PDO via PDO Assignment and to alter to contents of an individual PDO.

Sync Manager: Lists the configuration of the sync managers. If the device has a mailbox the sync manager 0 is used for the mailbox output and the sync manager 1 is used for the mailbox input. The next Sync Manager is used for the process data outputs and the last sync manager for the process data inputs. If an item is selected the corresponding PDO Assignment is displayed in the list view "PDO Assignment(0x1C1Sm)" (where Sm is the number of the sync manager).

PDO Assignment(0x1C1Sm) (where Sm is the number of the sync manager): PDO Assignment for the selected Sync Manager. Here all PDOs defined for this Sync Manager type are listed with their index. If the Outputs Sync Manager is selected in the "Sync Manager" list view, all TxPDOs are displayed. If the Inputs Sync Manager is selected, all RxPDOs are selected. The checked items are the PDOs, that take part in the process data communication. These PDOs are displayed in the tree view of the System Manager as variables of this EtherCAT slave device. The name of the variable is identical to the Parameter "Name" of the PDO, as displayed in the list view "PDO List". If an item in the "PDO Assignment" list is disabled(unchecked and gray), it indicates that this item is excluded for the current PDO assignment. To be able to select this PDO, one has to uncheck the currently checked PDOs.

PDO List: Lists all PDOs supported by this EtherCAT slave device. The content of the selected PDO is displayed in the "PDO Content(index of PDO):" list view. By double clicking on an entry one can change the configuration of the PDO.

Column | Description:
Index | Index of the PDO.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a sync manager, it appears as variable of the slave device with this Parameter as name.
Flags | F | Fixed Content. The content of the PDO is fixed and cannot be changed by the System Manager.
M | Mandatory PDO. This PDO is mandatory and therefore must be assigned to a Sync Manager. As a consequence one cannot uncheck this item in the "PDO Assignment" list.
SM | The Sync Manager this PDO is assigned to. If this entry is empty the PDO does not take part in the process data communication.
SU | Sync Unit this PDO is assigned to.

PDO Content(Index of PDO ):

Displays the contents of a PDO. If the Fixed Content Flag(Flag = F) of the PDO is not set, the content can be changed by the user.

Download:

If the device is an intelligent device and has a mailbox, the configuration of the PDOs and the PDO assignments can be downloaded to the device. This is an optional feature and is not supported by all slave devices.

PDO Assignment: If this box is checked, the PDO Assignment configured in the "PDO Assignment" list view is downloaded to the slave device during startup. The necessary commands sent to the device can be viewed in the "Startup" tab.

PDO Configuration: If this box is checked, the configuration of the individual PDOs as displayed in the "PDO List" and PDO Content" view are downloaded to the EtherCAT slave device.

EtherCAT Slave Device "Online" tab:

Displays online information about the EtherCAT slave device.

State Machine:

Init: Tries to set the EtherCAT slave device to the Init State.

Pre-Op: Tries to set the EtherCAT slave device to the Pre-Operational State.

Safe-Op: Tries to set the EtherCAT slave device to the Safe-Operational State.

Op: Tries to set the EtherCAT slave device to the Operational State.

Bootstrap: Tries to set the EtherCAT slave device to the Bootstrap State.

Clear Error: Tries to clear the error flag. If a slave device fails to change to another state, it sets the error flag. For instance a slave device is currently in the Pre-Operational state. Then the master requests the Safe-Operational state. If the slave device fails to change to Safe-Operational, it sets the error flag. The current state would be displayed as "ERR PREOP". After pressing the Clear Error the error flag is cleared and the current state would be displayed as "PREOP" again.

Current State: Current EtherCAT State of the slave device.

Requested State: EtherCAT State the master tried to set the slave to.

Dll Status:

The Data Link Layer (DLL) Status contains status information concerning the individual ports(A, B and C) of a slave device. Four different values for the DLL status are possible:

Status | Description
Carrier / Open | No carrier signal is present on the port but the port is open.
Carrier / Closed | No carrier signal is present on the port and the port is closed
Carrier / Open | Carrier signal is present on the port and the port is open.
Carrier / Closed | Carrier signal is present on the port but the port is closed.

EtherCAT Slave Device "Mailbox" tab:

If the EtherCAT slave devices supports one or more mailbox protocols the additional tab "mailbox" appears. In this dialog the supported mailbox protocols are listed and the configuration of the mailbox can be changed.

Mailbox Polling:

Cyclic: If this box is checked, the master cyclically tries to read out the mailbox .

Cycle Time(ms): If the "Cyclic" box is checked, this value determines how often the master reads out the mailbox of the slave.

State Change: If this box is checked, the master checks a status bit of the slave, to determine if unread data is available in the mailbox. Only then does the master read out the total mailbox. This mode is more efficient than the "Cyclic" mode, because the master can read out the status of several slave mailboxes with one EtherCAT command(LRD).

CANOpen over EtherCAT(CoE): If this box is checked, the slave supports the CANOpen over EtherCAT(CoE) mailbox protocol.

SDO Info Support: If this box is checks, the object dictionary of the slave device can be loaded by the master.

File Access over EtherCAT(FoE): If this box is checked, the master supports the File Access over EtherCAT(Foe) mailbox protocol.

Servo Drive over EtherCAT(SoE): If this group is enabled, the slave supports the Servo Drive over EtherCAT mailbox protocol.

Configuration..: Opens a dialog for configuring the Servo Drive over EtherCAT mailbox protocol.

ADS Info: The ADS identification of the EtherCAT slave device. The ADS Net id is the same as the NetId of the EtherCAT device, the ADS Port is the same as the fixed address of the EtherCAT device (see EtherCAT Addr). With the help of ADS one can communicate with the the mailbox of the slave device (e.g. SDO Upload Request).

EtherCAT Slave Device "CoE-Online" tab:

If the EtherCAT slave device supports the CANopen over EtherCAT(CoE) protocol, the additional tab "CoE-Online" appears. This tab enables the user to view the contents of the object dictionary of the slave(SDO-Upload) and to change the contents of an object in the dictionary(SDO-Upload).

Object List View:

Column | Description
Index | Index and Subindex of the object.
Name | Name of the object.
Flags | RW | The object can be read out and data can be written to the object.
 | RO | The object can be read out but is not possible to write data to the object.
 | P |
Value | Value of the object.

Update List: Updates all objects displayed in the list view.

Auto Update: If this box is checked, the contents of the objects is updated automatically.

Select Dictionary...: Opens the Select Dictionary dialog. Here one can specify which objects are displayed in the list view.

Online - via SDO information: If this box is selected, the list of objects contained in the object dictionary of the slave is uploaded from the slave via SDO information. In the list view below one can specify which type of objects should be uploaded.

Offline - via EDS File: If this box is selected, the list of objects contained in the object dictionary is read from an EDS File supplied by the user.

EtherCAT Slave Device "Startup" tab:

The "Startup" tab is displayed if the slave device has a mailbox and supports either the CANopen over EtherCAT(Coe) protocol or the Servo Drive over EtherCAT(SoE) protocol. With the help of the "Startup" tab the user can view which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list view. The download requests are sent to the slave in the same order as displayed in the list view.

Column | Description
Transition | Transition the request is sent in. This can be either Pre-Operational to Safe-Operational (PS) or Safe-Operational to Operational(SO). If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be changed or deleted by the user.
Protocol | Mailbox protocol.
Index | Index of the object.
Data | Data that is downloaded to the object.
Comment | Description of the request sent to the mailbox.

Move Up: Moves the selected request up one position in the list.

Move Down: Moves the selected request down one position in the list.

New..: Adds a new mailbox Download request, that should be sent during startup, to the list.

Delete..: Deletes the selected item

Edit...: Edits an existing request.


EtherCAT Slave Device Advanced Settings

TwinCAT System Manager: EtherCAT

Advanced Settings Dialog

To open the 'Advanced Settings' of an EtherCAT slave device, select the slave in the tree view of the system manager and open the 'EtherCAT' tab on the right. Next press the "Advanced Settings..." button, to open the "Advance Settings" dialog. Following dialogs are included in the 'Advanced Settings' dialog:

Dialog |  |  | Description
General | Behaviour |  | General behaviour settings
 | FMMU/SM |  | The "FMMU/SM" dialog displays the current configuration of the FMMUs and Sync Managers and allows the user to change these configurations.
 | Init Commands |  | Displays the init commands sent by the master during specific state transition.
Distributed Clock | Settings |  | With the help of the "Distributed Clock Settings" dialog the user can select the reference clock device and configure the sync signals of the slave.
ESC Access | E²PROM | Smart View | Displays the contents of the E²PROM.
 |  | Hex View | Displays the contents of the E²PROM in hex format.
 | FPGA |  | Enables the user to read out the current FPGA and to update the FPGA.
 | Memory |  | The memory dialog allows the user to read out and write data into the memory of the EtherCAT slave controller.

Behaviour Dialog

Startup Checking:

The user can specify which slave information should be checked by the master during startup.

Check Vendor Ids: If this box is checked, the master checks if the vendor id of the slave device is the same as the configured one.

Check Product Codes: If this box is checked, the master checks if the product code of the slave device is the same as the configured one.

Check Revision Numbers: If this box is checked, the master checks if the revision number of the slave device is the same as the configured one.

Check Serial Numbers: If this box is checked, the master checks if the serial number of the slave device is the same as the configured one.

State Machine:

Auto Restore States: If this box is checked, the EtherCAT master tries to restore the state of the slave automatically. If an EtherCAT slave device changes from error state (ERR SAFE-OP, ERR OP etc.) to a valid state (SAFE-OP, OP etc), the EtherCAT master tries to set the device to the current state of the master.

ReInit after Comm. Error: If this box is checked, the master sets the Slave back to the "Init" after an communication error.

Process Data:

Use LRD/LWR instead of LRW: If this box is checked, a LRD (Logical Read) command is used for reading out the inputs of this device and a LWR (Logical Write) command is used for writing data to the outputs of this device. Otherwise a LRW (Logical Read Write) command is used for reading out the inputs and writing data to the outputs.

Include WC State Bit: If this box is checked, a input variable is added to the slave device, that shows the working counter state of the EtherCAT slave device :

FMMU/SM Dialog

The "FMMU/SM" dialog displays the current configuration of the FMMUs and Sync Managers and allows the user to change these configurations.

The first list view displays the configuration of the FMMUs

Column | Description
L Start | Specifies from which logical address the FMMU starts to map the data. The start bit is set according to the number that follows the point (0Xnnnnnnnnn.StartBit.)
Length | Specifies how many bytes are mapped by the logical addressing.
L EndBit | End bit of the logical address. If the logical address should be configured to a byte, the start bit must be configured to 0( L Start = 0xnnnnnnnn.0) and this entry must be set to 7.
P Start | Specifies the physical address the logical address points to.

The second list view displays the configuration of the Sync Manager:

Column | Description
Start | Specifies from which address the Sync channel is active.
Length | Length of the Sync channel in bytes. If the length is 0 the Sync channel is not activated.
Data | Configuration data written to the sync manager.

Smart View dialog

The smart view dialog display the settings stored in the E2Prom of the EtherCAT slave controller. To view the binary contents of the E2Prom choose the Hex View dialog.

Write E²Prom...: Opens the "Write EEPROM" dialog:

To write a EEProm Description to the device select a description in the list view and press OK.

Read E²Prom...: Enables the user to save the contents of the E²Prom in binary format.

Memory Dialog

The memory dialog allows the user to read out and write data into the memory (DPRAM) of the EtherCAT slave controller. The list view below displays the memory of the EtherCAT slave controller. The start offset is equal to the value configured in the edit box "Start Offset". Each entry displays one register( 2 bytes). If the System Manager has a description for a register, it is displayed in the "Offs" column of the list view. To write a value to a register one has to edit the "Dec", "Hex" or "Char" field of the register. After selecting a different register or setting the focus to different control in the dialog, the edited register value is displayed in red and the "Write" button is enabled. Now one can press the "Write" button, to write the data to the slave.

Start Offset: Start Address of the first register to be displayed in the list view. The format of the number is hexadecimal.

Length: Length of the data to be displayed in bytes. The format of the number is hexadecimal. The maximal length is 0400(=1024).

Working Counter: If the master succeeded in writing to or reading from the slave, the working counter is 1, otherwise the working counter is 0.

Auto Reload: If this box is checked, the memory is read out cyclically.

Compact View: If this box is checked, only the registers are displayed, for which the System manager has a description for.

Write: Tries to write the changed register entries (displayed in red) to the slave.


EtherCAT Slave Device Distributed Clock Settings

TwinCAT System Manager: EtherCAT

Distributed Clock Settings:

To open the 'Distributed Clock Settings' dialog, open the 'Advanced Settings' Dialog of the EtherCAT slave device and select the entry 'Distributed Clock/Settings' in the tree view of the dialog:

Reference Clock:

Reference Clock Device: Displays the name of the EtherCAT slave device, that is used as reference clock. If the checkbox on the left is checked, this slave device is used as reference clock device. If another slave device is already set as reference clock, the checkbox is disabled. To be able to set this device as reference clock, one would have to select the current reference clock device and uncheck the "Reference Clock Device" checkbox in the dialog above.

Cycle Time (µs): The cycle time of the reference clock in microsecond . This is a read only value. To change the cycle time of the reference clock, select the current reference clock device in the tree view of the System Manager and open the "Distributed Clocks/Settings" dialog ( see above) for this device. Then change the settings for SYNC 0 accordingly.

Cyclic Mode:

Enable: Enables/Disable the cyclic mode. If the check box "Enable" is checked the settings for SYNC 0 and SYNC 1 are enabled.

SYNC 0:

Here one can set the cycle time and shift time of the SYNC 0 signal. If the current device is the reference clock device ( checkbox "Reference Clock Device" checked), the cycle time of the reference clock is set to the same value as the cycle time of SYNC 0.

Task Cycle (if reference clock device) : If this checkbox is enabled, the cycle time of SYNC 0 is set to a multiple of the task cycle time. The multiplier can be set in the combo box next to the checkbox.

or Ref. Clock Cycle (if not reference clock device): If this checkbox is enabled, the cycle time of SYNC 0 is set to a multiple of the cycle time of the reference clock. The multiplier can be set in the combo box next to the checkbox.

User defined: If this checkbox is enabled, the cycle time can be defined by the user in the "Cycle Time (µs)" edit box.

Cycle Time (µs): Cycle time of the SYNC 0 signal in microseconds. If the "User defined" checkbox is not checked, this is a read only value.

Shift Time (µs): Shift time in microseconds between the task cycle(if reference clock device) or reference clock cycle and the SYNC 0 signal.

Enable SYNC 0: Enables/Disables the SYNC 0 signal. If this checkbox is set the SYNC 0 signal is enabled.

SYNC 1:

Here one can set the cycle time and shift time of the SYNC 1 signal. The cycle time is always a multiple of the cycle time of the SYNC 0 signal.

Task Cycle (if reference clock device) : If this checkbox is enabled, the cycle time of SYNC 1 is set to a multiple of SYNC 0 cycle time. The multiplier can be set in the combo box next to the checkbox.

Cycle Time (µs): Cycle time of the SYNC 1 signal in microseconds.

Shift Time (µs): Shift time between the SYNC 1 and the SYNC 0 signal in microseconds.

Enable SYNC 1: Enables/Disables the SYNC 1 signal. If this checkbox is set the SYNC 1 signal is enabled.

How to configure the Distributed Clocks with the System Manager

The first step is to set the EtherCAT slave device that should be used as reference clock. This should normally be the first Slave Device ( Auto Inc Addr. = 0 ) connected to the EtherCAT master device.

Set Reference Clock Device

  1. Select the first EtherCAT slave device connected to the master in the tree view of the System Manager. .
  2. Next select the tab "EtherCAT" of this device:

  3. press the "Advanced Settings..." button to open the "Advanced Settings" dialog.
  4. Select the tree view item "Distributed Clocks/Settings" (see Distributed Clock Settings) in the "Advanced Settings".
  5. Check the "Reference Clock Device." check box to set this device as reference clock:

As default the cycle time of the reference clock is set to the task cycle time. To change this cycle time one has to change the cycle time of the SYNC 0 signal (see Distributed Clock Settings).

Configuring SYNC 0 and SYNC 1Signals

Now we can set the SYNC 0 and SYNC 1 signals of the other EtherCAT slave devices:

  1. select the EtherCAT slave device you want to enable the SYNC 0 and SYNC 1 signals for
  2. go to the "EtherCAT" page of this device
  3. open the "Advanced Settings" dialog
  4. select the entry "Distributed Clock/Settings" in the "Advanced Settings" dialog.
  5. Enable Cyclic Mode by checking the "Enable" button.
  6. Enable the SYNC 0 signal by checking the "Enable SYNC 0" button :

  7. Set the desired cycle time and shift time of the SYNC 0 signal (see Distributed Clock Settings). As default the cycle time is equal to the cycle time of the reference clock. To set a different cycle time one can change the multiplier in the "Ref. Clock Cycle" Combo Box.

If SYNC 1 is required as well:

  8. check the "Enable SYNC 1" button.
  9. Set the desired cycle time and shift time of the SYNC 1 signal (see Distributed Clock Settings). The cycle time of SYNC 1 is always a multiple of the cycle time of the SYNC 0 signal. Additionally you can set a shift time between the SYNC 0 and SYNC 1 signal.


Übersicht

Nachfolgend aufgeführte Geräte mit USB-Anschluß, werden aktuell von TwinCAT unterstützt:

USB - Teilnehmer ("Boxen") | Beschreibung | Einschränkungen / Anmerkung
BK9500 | Beckhoff USB Buskoppler |
Control Panel (USB) | Beckhoff Control Panel / Control Panel PC CP68xx / CP78xx, CP63xx, CP64xx und CP65xx mit DVI und USB Interface |


Beckhoff Busklemmen

Kontextmenü

Klemme Einfügen... <Einfg>

Fügt eine weitere Klemme vor der momentan markierten Klemme ein. Es öffnet sich der entsprechende Dialog.

Klemme Löschen... <Entf>

Löscht die momentan markierte Klemme.

Digitale Klemmen

Digitale Klemmen erzeugen automatisch dem jeweiligen Typ entsprechende Bit-Variablen. Diese Variablen sind in Kanälen angeordnet, deren Anzahl vom Typ der Klemme abhängig sind.

Variablen

Links ist beispielhaft die Baumansicht der digitalen Eingangsklemme KL1002 mit zwei Kanälen dargestellt. Es sind zwei Kanäle erzeugt worden, die jeweils eine binäre Eingangsvariable beinhalten.

Karteireiter "Variablen"

Die Verknüpfung der einzelnen Variablen kann über den Karteikartenreiter "Variablen" übersichtlich für alle Variablen gleichzeitig erfolgen. Natürlich bleibt die Möglichkeit erhalten, die Verknüpfung über das Kontextmenü oder die Karteiansicht der jeweiligen Variablen durchzuführen.

Kanal 1...: Öffnet den Verknüpfungsdialog für die binäre Variable des ersten Kanals.

Kanal 2...: dito.

Analoge Klemmen

Analoge Klemmen erzeugen automatisch dem jeweiligen Typ entsprechende Variablen. Diese Variablen sind in Kanälen angeordnet, deren Aufbau und Anzahl vom Typ der Klemme abhängig sind.

Variablen

Links ist beispielhaft die Baumansicht der analogen Ausgangsklemme KL4032 mit zwei Kanälen dargestellt. Es sind zwei Kanäle erzeugt worden, die jeweils zwei Eingangs- und zwei Ausgangsvariablen besitzen (I/O Lightbus und Profibus).

Analoge Ein- und Ausgangsklemmen besitzen pro Kanal ein Statusbyte (8 Bit Eingang), ein Eingangsdatenwort (16 Bit Eingang), ein Kontrollbyte (8 Bit Ausgang) und ein Ausgangsdatenwort (16 Bit Ausgang). Beim InterBus-S entfallen das Status- und Kontrollbyte.

Die Anzahl der angebotenen Variablen pro Kanal ist abhängig vom verwendeten Feldbus!

Karteireiter "Kanal X"

Die Verknüpfung der einzelnen Variablen eines Kanals kann über den Karteikartenreiter "Kanal X" übersichtlich für alle Variablen gleichzeitig erfolgen. Natürlich bleibt die Möglichkeit erhalten, die Verknüpfung über das Kontextmenü oder die Karteiansicht der jeweiligen Variablen durchzuführen.

Status...: Öffnet den Verknüpfungsdialog für das Statusbyte.

Daten Ein...: Öffnet den Verknüpfungsdialog für das Eingangsdatenwort.

Kontrolle...: Öffnet den Verknüpfungsdialog für das Kontrollbyte.

Daten Aus...: Öffnet den Verknüpfungsdialog für das Ausgangsdatenwort.


Beckhoff Busklemmen - Übersicht Signaltypen

Eine Übersicht über die verschiedenen Beckhoff Busklemmen können mit Hilfe der Links in der folgenden Tabelle erreicht werden. Die spezifische Busklemme kann dann innerhalb der jeweiligen Kategorie selektiert werden.

Kategorie | Kurzbeschreibung
Busklemmen - Digital Input KL/KS1xxx | Klemmen für 5 V, 12 V, 24 V, 120 V und 230 V Eingangsspannungspegel, Zähler, ...
Busklemmen - Digital Output KL/KS2xxx | Klemmen für 5 V, 24 V Ausgangspannungspegel, Relais, Triac, PWM, Schritt-/DC-Motoransteuerung, ...
Busklemmen - Analog Input KL/KS3xxx | Klemmen für diverse analoge Eingangspegel, Widerstandssensoren, Thermoelemente, Leistungsmessung, ...
Busklemmen - Analog Output KL/KS4xxx | Klemmen für diverse analoge Ausgangspegel
Busklemmen - Sonderfunktionen KL/KS5xxx, KL/KS6xxx, KL8xxx | Klemmen zur Wegerfassung, Kommunikation, Elektronische Motorschutzrelais, ...
Safety-Klemmen KLx90x | TwinSAFE Busklemmen: Eingangs-, Ausgangs und Safety-Logik-Busklemme
Systemklemmen KL/KS9xxx | Klemmen zur Potenzialeinspeisung, ...
Sonderklemmen KL/KSxxxx-yyyy | Applikationsspezifisch angepasste Klemmen und Sondervarianten

Weitere Informationen dazu finden Sie auf unserer Webseite unter Busklemmen.


Überischtsseite zu Beckhoff Busklemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff Busklemmen

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Busklemmen

TwinCAT System Manager: Reference

Übersicht zu digitalen Ausgangsklemmen von Beckhoff

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Busklemmen

TwinCAT System Manager: Reference

Übersicht zu analogen Eingangsklemmen von Beckhoff

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Busklemmen

TwinCAT System Manager: Reference

Übersicht zu analogen Ausgangsklemmen von Beckhoff

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Busklemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff Busklemmen mit Sonderfunktionen

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Busklemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff TwinSAFE-Busklemmen

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Busklemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff Systemklemmen

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Busklemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff Sonderklemmen

siehe Beckhoff-Produktseite


Beckhoff EtherCAT-Klemmen - Übersicht Signaltypen

Eine Übersicht über die verschiedenen Beckhoff EtherCAT-Klemmen können mit Hilfe der Links in der folgenden Tabelle erreicht werden. Die spezifische EtherCAT-Klemme kann dann innerhalb der jeweiligen Kategorie selektiert werden.

Kategorie |
EtherCAT-Klemmen - Digital Input EL/ES1xxx | Klemmen für 5 V, 12 V, 24 V, 120 V, 230 V Eingangsspannungspegel, Zähler, ...
EtherCAT-Klemmen - Digital Output EL/ES2xxx | Klemmen für 5 V, 24 V Ausgangspannungspegel, Relais, Triac, PWM, ...
EtherCAT-Klemmen - Analog Input EL/ES3xxx | Klemmen für diverse analoge Eingangspegel, Widerstandssensoren, Thermoelemente, Leistungsmessung, ...
EtherCAT-Klemmen - Analog Output EL/ES4xxx | Klemmen für diverse analoge Ausgangspegel
EtherCAT-Klemmen - Sonderfunktionen EL/ES5xxx, EL/ES6xxx, EL/ES7xxx | Klemmen zur Wegerfassung, Kommunikation, Motion, ...
EtherCAT-Klemmen - Systemklemmen EL/ES9xxx | Klemmen zur Potenzialeinspeisung, ...


Überischtsseite zu Beckhoff EtherCAT-Klemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff EtherCAT-Klemmen - Digital-Input

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff EtherCAT-Klemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff EtherCAT-Klemmen - Digital-Output

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff EtherCAT-Klemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff EtherCAT-Klemmen - Analog-Input

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff EtherCAT-Klemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff EtherCAT-Klemmen - Analog-Output

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff EtherCAT-Klemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff EtherCAT-Klemmen - Sonderfunktionen

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff EtherCAT-Klemmen

TwinCAT System Manager: Reference

Übersicht zu Beckhoff EtherCAT-Klemmen - Systemklemmen

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Feldbus Box

TwinCAT System Manager: Reference

Übersicht zum Beckhoff Feldbus Box System

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Feldbus Box

TwinCAT System Manager: Reference

Übersicht zum Beckhoff Kompakt Box

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Feldbus Box

TwinCAT System Manager: Reference

Übersicht zum Beckhoff Koppler Box

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Feldbus Box

TwinCAT System Manager: Reference

Übersicht zum Beckhoff SPS Box

siehe Beckhoff-Produktseite


Überischtsseite zu Beckhoff Feldbus Box

TwinCAT System Manager: Reference

Übersicht zum Beckhoff Erweiterungs-Box

siehe Beckhoff-Produktseite


PROFIBUS-Verkablung

Ein PROFIBUS-Kabel (bzw. ein Kabel-Segment bei Verwendung von Repeatern) kann mit ein paar einfachen Widerstandsmessungen überprüft werden. Dazu sollte das Kabel von allen Stationen abgezogen werden:

1. Widerstand zwischen A und B am Anfang der Leitung: ca. 110 Ohm

2. Widerstand zwischen A und B am Ende der Leitung: ca. 110 Ohm

3. Widerstand zwischen A am Anfang und A am Ende der Leitung: ca. 0 Ohm

4. Widerstand zwischen B am Anfang und B am Ende der Leitung: ca. 0 Ohm

5. Widerstand zwischen Schirm am Anfang und Schirm am Ende der Leitung: ca. 0 Ohm

Falls diese Messungen erfolgreich sind, ist das Kabel in Ordnung. Wenn trotzdem noch Bus-Störungen auftreten, liegt es meistens an EMV-Störungen, dann sollten die Installationshinweise der PROFIBUS-Nutzer-Organisation beachtet werden (www.profibus.com).


CANopen Einführung

CANopen ist eine weit verbreitete CAN-Anwendungsschicht, die im CAN-in-Automation Verband entwickelt und inzwischen zur internationalen Normung angenommen wurde.

Gerätemodell

CANopen besteht aus der Protokolldefinition (Kommunikationsprofil) so wie den Geräteprofilen, die den Dateninhalt für die jeweilige Geräteklasse normieren. Zur schnellen Kommunikation der Ein- und Ausgangsdaten dienen die Prozessdatenobjekte (PDO). Die CANopen Geräteparameter und Prozessdaten sind in einem Objektverzeichnis strukturiert. Der Zugriff auf beliebige Daten dieses Objektverzeichnisses erfolgt über die Servicedatenobjekte (SDO). Weiter gibt es einige Spezialobjekte (bzw. Telegrammarten) für Netzwerkmanagement (NMT), Synchronisation, Fehlermeldungen etc.

Kommunikationsarten

CANopen definiert mehrere Kommunikationsarten für die Ein- und Ausgangsdaten (Prozessdatenobjekte):

  • Ereignisgesteuert: Telegramme werden versendet, sobald sich der Inhalt geändert hat. Hier wird nicht ständig das Prozessabbild, sondern nur die Änderung desselben übertragen.
  • Zyklisch synchron: Über ein SYNC Telegramm werden die Baugruppen veranlasst, die vorher empfangenen Ausgangsdaten zu übernehmen und neue Eingangsdaten zu senden.
  • Angefordert: Über ein CAN Datenanforderungstelegramm werden die Baugruppen veranlasst ihre Eingangsdaten zu senden.

Die gewünschte Kommunikationsart wird über den Parameter "Transmission Type" eingestellt.

Geräteprofil

Die Beckhoff CANopen Geräte unterstützen alle E/A- Kommunikationsarten und entsprechen dem Geräteprofil für digitale und analoge Ein-/Ausgabebaugruppen (DS401).

Übertragungsraten

Neun Übertragungsraten von 10 kBaud bis 1 MBaud stehen für unterschiedliche Buslängen zur Verfügung. Durch die effektive Nutzung der Busbandbreite erreicht CANopen kurze Systemreaktionszeiten bei vergleichsweise niedrigen Datenraten.

Topologie

CAN basiert auf einer linienförmigen Topologie. Die Anzahl der Teilnehmer pro Netz ist dabei von CANopen logisch auf 128 begrenzt, physikalisch erlaubt die aktuelle Treiber-Generation bis zu 64 Knoten in einem Netzsegment. Die bei einer bestimmten Datenrate maximal mögliche Netzausdehnung ist durch die auf dem Busmedium erforderliche Signallaufzeit begrenzt. Bei 1 MBaud ist z.B. eine Netzausdehnung von 25 m, bei 50 kBaud eine Netzausdehnung von 1000 m möglich. Bei niedrigen Datenraten kann die Netzausdehnung durch den Einsatz von Repeatern erhöht werden, diese ermöglichen auch den Aufbau von Baumstrukturen.

Buszugriffsverfahren

CAN arbeitet nach dem Verfahren Carrier-Sense Multiple Access (CSMA), d.h. jeder Teilnehmer ist bezüglich des Buszugriffs gleichberechtigt und kann auf den Bus zugreifen, sobald dieser frei ist (Multi-Master-Buszugriff). Der Nachrichtenaustausch ist dabei nicht Teilnehmerbezogen sondern Nachrichtenbezogen. Das bedeutet, dass jede Nachricht mit einem priorisierten Identifier eindeutig gekennzeichnet ist. Damit beim Verschicken der Nachrichten verschiedener Teilnehmer keine Kollisionen auf dem Bus entstehen, wird beim Start der Datenübertragung eine bitweise Busarbitrierung durchgeführt. Die Busarbitrierung vergibt die Busbandbreite an die Nachrichten in der Reihenfolge ihrer Priorität, am Ende der Arbitrierungsphase belegt jeweils nur ein Busteilnehmer den Bus, Kollisionen werden vermieden und die Bandbreite wird optimal genutzt.

Konfiguration und Parametrierung

Mit dem TwinCAT System Manager können alle CANopen Parameter komfortabel eingestellt werden. Für die Parametrierung der Beckhoff CANopen Geräte mit Konfigurationstools dritter Hersteller steht ein eds-File (electronic data sheet) auf der Beckhoff Website zur Verfügung.

Zertifizierung

Die Beckhoff CANopen Geräte verfügen über eine leistungsfähige Protokollimplementierung und sind vom CAN-in- Automation Verband (CiA) zertifiziert.


Prozessdatenobjekte (PDO)

Einführung

Bei vielen Feldbussystemen wird ständig das gesamte Prozessabbild übertragen - meist mehr oder weniger zyklisch. CANopen ist nicht auf dieses Kommunikationsprinzip beschränkt, da CAN durch die Multi-Master Buszugriffsregelung auch andere Möglichkeiten bietet: die Prozessdaten werden bei CANopen nicht im Master/Slave-Verfahren übertragen, sondern folgen dem Produzenten/Konsumenten-Modell ("Producer-Consumer"). Hierbei sendet ein Busknoten seine Daten von sich aus (Producer), beispielsweise durch den Eintritt eines Ereignisses getriggert; alle anderen Knoten hören mit und entscheiden anhand des Identifiers, ob sie sich für dieses Telegramm interessieren und verarbeiten es entsprechend (Consumer).

Bei CANopen werden die Prozessdaten in Segmente zu maximal 8 Byte aufgeteilt. Diese Segmente heißen Prozessdatenobjekte (PDOs). Die PDOs entsprechen jeweils einem CAN-Telegramm und werden über dessen spezifischen CAN-Identifier zugeordnet und in ihrer Priorität bestimmt. Man unterscheidet Empfangs- (Receive-, Rx-) PDOs und Sende- (Transmit-, Tx-)PDOs, wobei die Bezeichnung jeweils aus Gerätesicht erfolgt: eine Ein-/Ausgabebaugruppe sendet ihre Eingangsdaten mit TxPDOs, und empfängt die Ausgangsdaten in den RxPDOs. Diese Bezeichnung wird im TwinCAT System Manager beibehalten.

Kommunikationsparameter

Die PDOs können je nach Applikationsanforderung mit unterschiedlichen Kommunikationsparametern versehen werden. Wie alle CANopen Parameter stehen auch diese im Objektverzeichnis des Gerätes, auf sie kann über die Service Daten Objekte zugegriffen werden. Die Parameter für die Empfangs-PDOs stehen bei Index 0x1400 (RxPDO1) und folgende, bis zu 512 RxPDOs können vorhanden sein (Bereich bis Index 0x15FF). Entsprechend finden sich die Einträge für die Sende-PDOs bei Index 0x1800 (TxPDO1) bis 0x19FF (TxPDO512).

Für den Prozessdatenaustausch stehen auf den Buskopplern bzw. Feldbus Box Baugruppen jeweils 16 RxPDO und TxPDOs zur Verfügung (bei den Economy und LowCost Kopplern BK5110 und LC5100 sowie den Kompakt Box Modulen sind es jeweils 5 PDOs, da diese Geräte über weniger Prozessdaten verfügen).

Für jedes vorhandene Prozessdatenobjekt ist ein zugehöriges Kommunikationsparameter-Objekt vorhanden. Der TwinCAT Systemmanager ordnet die eingestellten Parameter automatisch den jeweiligen Objektverzeichniseinträgen zu. Im Folgenden werden diese Einträge samt ihrer Bedeutung für das Kommunikationsverhalten der Prozessdaten erläutert.

PDO Identifier

Der wichtigste Kommunikationsparameter eines PDOs ist der CAN-Identifier (auch Communication Object Identifier, COB-ID genannt). Er dient zur Identifizierung der Daten und bestimmt deren Priorität beim Buszugriff. Für jedes CAN-Datentelegramm darf es nur einen Sendeknoten (Producer) geben; da CAN jedoch alle Nachrichten im Broadcast-Verfahren sendet kann ein Telegramm wie beschrieben von beliebig vielen Knoten empfangen werden (Consumer). Ein Knoten kann also seine Eingangsinformation mehreren Busteilnehmern gleichzeitig zur Verfügung stellen - auch ohne Weiterleitung durch einen logischen Busmaster. Der Identifier steht in Subindex 1 des Kommunikationsparametersatzes. Er ist als 32-Bit Wert kodiert, wobei die niederwertigsten 11 Bits (Bit 0...10) den eigentlichen Identifier enthalten. Die Datenbreite von 32 Bit erlaubt auch den Eintrag von 29 Bit Identifiern nach CAN 2.0B, allerdings beziehen sich die Default-Identifier stets auf die üblichere 11Bit-Variante. Allgemein geht CANopen sparsam mit den zur Verfügung stehenden Identifiern um, sodass der Einsatz der 29Bit-Variante auf Sonderanwendungen beschränkt bleibt. Über das höchstwertige Bit (Bit 31) lässt sich das Prozessdatenobjekt aktivieren bzw. abschalten.

Hier finden Sie eine komplette Identifier-Liste.

PDO Linking

Im System der Default-Identifier kommunizieren alle Knoten (hier: Slaves) mit einer Zentrale (Master), da kein Slave-Knoten per Default auf die Sende-Identifier eines anderen Slave-Knotens hört).

Default Identifier Verteilung: Master/Slave PDO Linking: Peer to Peer

Wenn das Consumer-Producer Modell der CANopen PDOs zum direkten Datenaustausch zwischen Knoten (ohne Master) genutzt werden soll, so muss die Identifierverteilung entsprechend angepasst werden, damit der TxPDO-Identifier des Producers mit dem RxPDO-Identifier des Consumers übereinstimmt. Dieses Verfahren nennt man PDO Linking. Es ermöglicht beispielsweise den einfachen Aufbau von elektronischen Getrieben, bei denen mehrere Slave-Achsen gleichzeitig auf den Ist-Wert im TxPDO der Master-Achse hören.

PDO Kommunikationsarten: Überblick

CANopen bietet vielfältige Möglichkeiten, die Prozessdaten zu übertragen (siehe auch: Hinweise zur PDO Parametrierung)

.

Ereignisgesteuert

Das "Ereignis" ist die Änderung eines Eingangswertes, die Daten werden sofort nach dieser Änderung verschickt. Durch die Ereignissteuerung wird die Busbandbreite optimal ausgenutzt, da nicht ständig das Prozessabbild, sondern nur die Änderung desselben übertragen wird. Gleichzeitig wird eine kurze Reaktionszeit erreicht, da bei Änderung eines Eingangswertes nicht erst auf die nächste Abfrage durch einen Master gewartet werden muss.

Gepollt

Die PDOs können auch durch Datenanforderungstelegramme (Remote Frames) gepollt werden. Auf diese Art kann etwa das Eingangsprozessabbild bei ereignisgesteuerten Eingängen auch ohne deren Änderung auf den Bus gebracht werden, beispielsweise bei einem zur Laufzeit ins Netz aufgenommenen Monitor- oder Diagnosegerät. Das zeitliche Verhalten von Remote Frame und Antworttelegramm hängt von den verwendeten CAN-Controllern ab (Bild8): Bausteine mit integrierter kompletter Nachrichtenfilterung ("FullCAN") beantworten ein Datenanforderungstelegramm in der Regel direkt und versenden sofort die im entsprechenden Sendebuffer stehenden Daten - dort muss die Applikation dafür Sorge tragen, dass die Daten ständig aktualisiert werden. CAN-Controller mit einfacher Nachrichtenfilterung ("BasicCAN") reichen die Anforderung dagegen an die Applikation weiter, die nun das Telegramm mit den aktuellen Daten zusammenstellen kann. Das dauert länger, dafür sind die Daten "frisch". Beckhoff verwendet CAN Controller nach dem Basic CAN Prinzip.

Da dieses Geräteverhalten für den Anwender meist nicht transparent ist und zudem noch CAN-Controller in Verwendung sind, die Remote Frames überhaupt nicht unterstützen, kann die gepollte Kommunikationsart nur bedingt für den laufenden Betrieb empfohlen werden.

Synchronisiert

Nicht nur bei Antriebsanwendungen ist es sinnvoll, das Ermitteln der Eingangsinformation sowie das Setzen der Ausgänge zu synchronisieren. CANopen stellt hierzu das SYNC-Objekt zur Verfügung, ein CAN-Telegramm hoher Priorität ohne Nutzdaten, dessen Empfang von den synchronisierten Knoten als Trigger für das Lesen der Eingänge bzw. für das Setzen der Ausgänge verwendet wird.

PDO Übertragungsart: Parametrierung

Der Parameter PDO Übertragungsart bzw. Transmission Type legt fest, wie das Versenden des PDOs ausgelöst wird bzw. wie empfangene PDOs behandelt werden:

Übertr.-Art | Zyklisch | Azyklisch | Synchron | Asynchron | Nur RTR
0 |  | X | X |  |
1-240 | X |  | X |  |
241-251 | - reserviert -
252 |  |  | X |  | X
253 |  |  |  | X | X
254, 255 |  |  |  | X |

Azyklisch Synchron

PDOs der Übertragungsart 0 arbeiten synchron, aber nicht zyklisch. Ein RxPDO wird erst nach Empfang des nächsten SYNC-Telegramms ausgewertet. Damit lassen sich beispielsweise Achsgruppen nacheinander mit neuen Zielpositionen versehen, die alle beim nächsten SYNC gültig werden - ohne dass ständig Stützstellen ausgegeben werden müssen. Ein Gerät, dessen TxPDO auf Übertragungsart 0 konfiguriert ist, ermittelt seine Eingangsdaten beim Empfang des SYNC (synchrones Prozessabbild) und sendet sie anschließend, falls die Daten einem Ereignis entsprechen (beispielsweise eine Eingangsänderung) eingetreten ist. Die Übertragungsart 0 kombiniert also den Sendegrund "ereignisgesteuert" mit dem Sende- (und möglichst Sample-) bzw. Verarbeitungs-Zeitpunkt "SYNC-Empfang".

Zyklisch Synchron

Bei Übertragungsart 1-240 wird das PDO zyklisch gesendet: nach jedem "n-ten" SYNC (n=1...240). Da die Übertragungsart nicht nur im Netz, sondern auch auf einem Gerät kombiniert werden dürfen, kann so z.B. ein schneller Zyklus für digitale Eingänge vereinbart werden (n=1), während die Daten der Analogeingänge in einem langsameren Zyklus übertragen werden (z.B. n=10). RxPDOs unterscheiden in der Regel nicht zwischen den Übertragungsarten 0...240: ein empfangenes PDO wird beim nächsten SYNC-Empfang gültig gesetzt. Die Zykluszeit (SYNC-Rate) kann überwacht werden (Objekt 0x1006), das Gerät reagiert bei SYNC-Ausfall dann entsprechend der Definition des Geräteprofils und schaltet z.B. seine Ausgänge in den Fehlerzustand.

Die CANopen PC-Karten CIFx0 senden stets ereignisgesteuert - auch wenn die Übertragungsart im Bereich von 1-240 eingestellt ist. Dieses Verhalten entspricht etwa der Übertragungsart 0. Die PC Karten FC510x unterstützen die Zyklisch Synchrone Übertragungsart vollständig.

Nur RTR

Die Übertragungsarten 252 und 253 gelten für Prozessdatenobjekte, die ausschließlich auf Anforderung durch ein Remote Frame übertragen werden. 252 ist synchron: beim Empfang des SYNCs werden die Prozessdaten ermittelt, gesendet werden sie nur auf Anforderung. 253 ist asynchron, hier werden die Daten ständig ermittelt und auf Anforderung verschickt. Diese Übertragungsart wird von den Beckhoff PC-Karten nicht unterstützt.

Asynchron

Die Übertragungsarten 254 + 255 sind asynchron oder auch ereignisgesteuert. Bei Übertragungsart 254 ist das Ereignis herstellerspezifisch, bei 255 im Geräteprofil definiert. Im einfachsten Fall ist das Ereignis die Veränderung eines Eingangswertes - es wird also jede Werteänderung übertragen.

Inhibit Zeit

Über den Parameter "Inhibit-Zeit" kann ein "Sende-Filter" aktiviert werden, der die Reaktionszeit bei der relativ ersten Eingangsänderung nicht verlängert, aber bei unmittelbar darauffolgenden Änderungen aktiv ist. Die Inhibit-Zeit (Sendeverzögerungszeit) beschreibt die Zeitspanne, die zwischen dem Versenden zweier gleicher Telegramme mindestens abgewartet werden muss. Wenn die Inhibit-Zeit genutzt wird, so kann die maximale Busbelastung und damit die Latenzzeit im "worst case"-Fall ermittelt werden.

Die Beckhoff PC-Karten FC510x können zwar die Inhibit-Zeit auf Slave-Geräten parametrieren, unterstützen sie jedoch selbst nicht. Eine Spreizung der gesendeten PDOs (Sendeverzögerung) ergibt sich automatisch aus der gewählten Zyklus-Zeit der SPS - und es macht wenig Sinn, die SPS schneller laufen zu lassen als es die Busbandbreite zulässt. Zudem kann die Busbelastung wirkungsvoll über die synchrone Kommunikation beeinflusst werden.

Event Timer

Über Subindex 5 der Kommunikationsparameter lässt sich ein Ereignis-Timer (Event Timer) für Sende-PDOs festlegen. Der Ablauf dieses Timers wird als zusätzlich eingetretenes Ereignis für das entsprechende PDO gewertet, das PDO wird also dann gesendet. Wenn das Applikationsereignis während einer Timer-Periode auftritt, so wird ebenfalls gesendet und der Timer wird zurückgesetzt .

Bei Empfangs-PDOs wird der Timer-Parameter dazu verwendet, die Überwachungszeit für dieses PDO anzugeben: Die Applikation wird benachrichtigt, wenn kein entsprechendes PDO innerhalb der eingestellten Zeit empfangen wurde.

Hinweise zur PDO Parametrierung

PDO Mapping

Unter PDO Mapping versteht man die Abbildung der Applikationsobjekte (Echtzeitdaten) aus dem Objektverzeichnis in die Prozessdatenobjekte. Die CANopen-Geräteprofile sehen für jeden Gerätetyp ein Default-Mapping vor, das für die meisten Anwendungen passend ist. So bildet das Default-Mapping für digitale E/A einfach die Ein- bzw. Ausgänge ihrer physikalischen Reihenfolge gemäß in die Sende- bzw. Empfangs-Prozessdatenobjekte ab.

Im zweiten PDO finden sich die ersten 4 analogen Ein- bzw. Ausgänge. Dementsprechend werden diese PDOs von den Beckhoff Feldbus I/O Modulen belegt - falls z.B. keine digitalen Ausgänge vorhanden sind, bleibt das RxPDO1 leer.

Bei den Kompakt Box Modulen ist die PDO-Belegung demnach durch die jeweilige Signalvariante bestimmt: digitale Ein/Ausgangsdaten befinden sich in PDO1, analoge in PDO2, Sondersignale in PDO3.

Die erweiterbaren I/O Baugruppen belegen die PDOs automatisch: der Koppler liest in der Aufstartphase ein, welche Klemmen gesteckt sind bzw. welche Erweiterungs-Box Module vorhanden sind und ordnet die Daten den PDOs zu. Hierbei werden digitale, analoge und Sonderklemmen unterschieden und die PDOs jeweils "sortenrein" belegt. Es werden also keine unterschiedlichen Datentypen (z.B. digitale und analoge Eingänge) in ein PDO verpackt, sondern für jeden weiteren Datentyp wird ein neues PDO begonnen.

Automatische PDO Belegung bei Beckhoff Buskopplern

Die Default-PDOs für Antriebe enthalten jeweils 2 Byte Steuer- bzw. Statuswort und Soll- bzw. Istwert für die betreffende Achse.

Das aktuelle Mapping kann über entsprechende Einträge im Objektverzeichnis, die sogenannten Mapping-Tabellen, ausgelesen werden . An erster Stelle der Mapping Tabelle (Subindex 0) steht die Anzahl der gemappten Objekte, die im Anschluss aufgelistet sind. Die Tabellen befinden sich im Objektverzeichnis bei Index 0x1600 ff. für die RxPDOs bzw. 0x1A00ff für die TxPDOs.

Dummy-Mapping

Eine weiteres Feature von CANopen ist das Mappen von Platzhaltern ("Dummy"- Einträge). Als Platzhalter dienen die im Objektverzeichnis hinterlegten Datentyp-Einträge, die ja selbst nicht mit Daten versehen sind. Sind solche Einträge in der Mapping-Tabelle enthalten, so werden die entsprechenden Daten vom Gerät nicht ausgewertet. Auf diese Art können beispielsweise mehrere Antriebe über ein einziges CAN-Telegramm mit neuen Sollwerten versorgt werden oder Ausgänge auf mehreren Knoten auch im ereignisgesteuerten Modus gleichzeitig gesetzt werden.


PDO Parametrierung

Auch wenn die meisten CANopen-Netze in der Default-Einstellung und damit mit minimalem Konfigurationsaufwand zufriedenstellend arbeiten, so sollte zumindest überprüft werden, ob die vorhandene Buslast vertretbar ist: 80% Busauslastung mag für ein rein zyklisch synchron arbeitendes Netzwerk akzeptabel sein, für ein rein ereignisgesteuertes Netz ist dieser Wert in der Regel zu hoch, da kaum Bandbreite für zusätzliche Ereignisse zur Verfügung steht.

Applikationsanforderungen berücksichtigen

Die Prozessdatenkommunikation sollte hinsichtlich einiger sich teilweise widersprechender Applikationsanforderungen optimiert werden. Hierzu gehören

  • Geringer Parametrieraufwand - optimal sind brauchbare Defaultwerte
  • Garantierte Reaktionszeit auf bestimmte Ereignisse
  • Zykluszeit bei Regelvorgängen über den Bus
  • Sicherheitsreserven für Busstörungen (genügend Bandbreite für Nachrichtenwiederholung)
  • Maximale Baudrate - hängt von der maximalen Buslänge ab
  • Gewünschte Kommunikationspfade - wer spricht mit wem

Der bestimmende Faktor ist meist die zur Verfügung stehende Busbandbreite (Buslast).

Baudrate

Allgemein wird man beginnen, die Baudrate so groß zu wählen, wie es die Buslänge erlaubt. Hierbei sollte man berücksichtigen, dass serielle Bussysteme grundsätzlich um so empfindlicher auf Störeinflüsse reagieren, je höher die Baudrate ist - es gilt also die Regel "so schnell wie nötig". 1000 kbit/s sind meist nicht erforderlich und uneingeschränkt nur bei Netzwerken innerhalb eines Schaltschrankes ohne galvanische Trennung der Busknoten empfehlenswert. Die Erfahrung zeigt auch, dass das Abschätzen der verlegten Buskabellänge häufig zu optimistisch erfolgt - die tatsächliche Kabellänge also größer ist.

Kommunikationsart bestimmen

Ist die Baudrate gewählt, so gilt es nun die PDO Kommunikationsart(en) zu bestimmen. Diese haben unterschiedliche Vor- und Nachteile:

  • Die zyklisch synchrone Kommunikation ergibt eine genau vorhersagbare Busbelastung und damit ein definiertes Zeitverhalten - man könnte auch sagen, der worst case ist Standard. Sie ist einfach zu konfigurieren: mit dem Parameter SYNC-Rate kann die Buslast global eingestellt werden. Die Prozessabbilder werden synchronisiert: Eingänge werden gleichzeitig gelesen, Ausgangsdaten gleichzeitig gültig gesetzt - die Qualität dieser Synchronisierung ist allerdings implementierungsabhängig. Die Beckhoff PC-Karten FC510x sind in der Lage, das CANopen Bussystems mit den Zyklen der Anwendungsprogramme (SPS bzw. NC) zu synchronisieren.

    Die garantierte Reaktionszeit ist bei der zyklisch synchronen Kommunikation immer mindestens so groß wie die Zykluszeit, und die Busbandbreite wird nicht optimal genutzt, da auch "alte", sich nicht ändernde Daten ständig übertragen werden. Es ist aber möglich, das Netz durch die Wahl unterschiedlicher SYNC-Vielfacher (Transmission Types 1...240) zu optimieren und sich langsam ändernde Daten seltener zu übertragen als z.B. zeitkritische Eingänge. Berücksichtigt werden sollte jedoch, dass Eingangszustände, die kürzer anstehen als die Zykluszeit, nicht unbedingt kommuniziert werden. Ist dies gefordert, so sollten die entsprechenden PDOs für asynchrone Kommunikation vorgesehen werden.
  • Die ereignisgesteuerte, asynchrone Kommunikation ist optimal hinsichtlich Reaktionszeit und Verwendung der Busbandbreite - man könnte sie als "CAN pur" bezeichnen. Bei ihrer Wahl muss allerdings berücksichtigt werden, dass u.U. viele Ereignisse gleichzeitig auftreten und sich dann entsprechende Verzögerungszeiten einstellen können, bis ein relativ niederpriores PDO verschickt werden kann - eine seriöse Netzwerkplanung erfordert demnach eine worst-case Betrachtung. Auch muss, z.B. durch Verwendung der Inhibit Zeit, verhindert werden, dass ein sich ständig ändernder Eingang mit hoher PDO Priorität den Bus blockiert (Fachbegriff: "babbling idiot"). Aus diesem Grund ist beispielsweise die Ereignissteuerung bei Analogeingängen im Geräteprofil per Default abgeschaltet und muss gezielt aktiviert werden. Über den Ablauf-Timer lassen sich Zeitfenster für die Sende-PDOs einstellen: Das Telegramm wird frühestens nach Ablauf der Inhibit-Zeit und spätestens nach Verstreichen des Ablauf-Timers erneut gesendet.
  • Parametriert wird die Kommunikationsart über den Transmission Type.

Es ist auch möglich, beide PDO Kommunikationsprinzipien zu kombinieren. So kann es beispielsweise sinnvoll sein, die Soll- und Istwerte einer Achsregelung zyklisch synchron auszutauschen, während Endschalter oder die mit Grenzwerten versehene Motortemperatur mit ereignisgesteuerten PDOs überwacht werden. So kombiniert man die Vorteile beider Prinzipien: Synchronität der Achskommunikation und kurze Reaktionszeit für Endschalter. Durch die dezentrale Grenzwertüberwachung wird trotz Ereignissteuerung vermieden, dass der Temperatur-Analogwert ständig zur Buslast beiträgt.

Im genannten Beispiel kann es auch sinnvoll sein, die Identifierverteilung gezielt zu beeinflussen, um den Buszugriff durch die Prioritätsverteilung zu optimieren: die höchste Priorität bekommt das PDO mit den Endschalterdaten, die niedrigste das mit den Temperaturwerten.

In aller Regel ist es aber nicht erforderlich, die Identifierverteilung anzupassen, um die Latenzzeit beim Buszugriff zu optimieren. Dagegen müssen die Identifier verändert werden, um eine "masterlose" Kommunikation zu ermöglichen (PDO Linking). Im genannten Beispiel könnte je ein RxPDO der Achsen denselben Identifier wie das TxPDO des Endschalters zugewiesen bekommen und dadurch eine Veränderung des Eingangswertes verzögerungsfrei empfangen.

Buslast bestimmen

In jedem Fall ist es sinnvoll, die Buslast zu bestimmen. Doch welche Buslastwerte sind "zulässig" bzw. sinnvoll? Unterscheiden sollte man zunächst den kurzfristigen "Burst" von Telegrammen, bei dem eine Anzahl CAN-Nachrichten direkt aufeinander folgt - kurzzeitig 100% Buslast. Das ist nur dann problematisch, wenn die dadurch ausgelöste Folge von Empfangsinterrupts auf den CAN-Knoten nicht mehr abgearbeitet werden kann, es also zu einem Datenüberlauf ("CAN-Queue-Overrun") kommt. Das kann bei sehr hohen Baudraten (> 500 kBit/s) bei Knoten mit Software-Telegrammfilterung und relativ langsamen oder stark ausgelasteten Microcontrollern vorkommen, wenn z.B. eine direkte Folge von Remote Frames (diese enthalten keine Datenbytes und haben daher minimale Länge) auf dem Bus ist (bei 1 Mbit/s kann so alle 40 µs ein Interrupt erzeugt werden; Beispiel: ein NMT-Master sendet alle Guarding-Anforderungen direkt hintereinander). Durch geschickte Implementierung läßt sich das vermeiden, der Anwender sollte davon ausgehen können, dass von den Geräteanbietern hierfür Sorge getragen wurde. Ein Burst-Zustand ist z.B. direkt nach dem SYNC Telegramm völlig normal: vom SYNC getriggert versuchen alle synchron arbeitenden Knoten quasi gleichzeitig Ihre Daten zu senden, es finden viele Arbitrierungsvorgänge statt, die Telegramme sortieren sich nacheinander in der Reihenfolge ihrer Priorität auf den Bus. Das ist in der Regel unkritisch, da es sich hier um Telegramme mit einigen Datenbytes handelt und die Telegrammfolge damit zwar eine schnelle, aber überschaubare Folge von Empfangsinterrupts auf den CAN-Knoten auslöst.

Unter Buslast versteht man meist den gemittelten Wert über mehrere Primärzyklen, also z.B. das Mittel über 100-500 ms. CAN, und damit CANopen, ist zwar in der Lage, nahe 100% Buslast auf Dauer zu bewältigen, aber dann steht keine Bandbreite für eventuelle Wiederholungen bei Störeinflüssen, asynchrone Fehlermeldungen, Parametrierung etc. zur Verfügung. Selbstverständlich hat die vorherrschende Art der Kommunikation einen großen Einfluss auf die sinnvolle Buslast: ein komplett zyklisch synchron arbeitendes Netz befindet sich ja bereits nahe am "worst case" Zustand und kann daher mit Werten von 70-80% betrieben werden. Für ein rein ereignisgesteuertes Netz ist diese Zahl nur schwer anzugeben: es muss hier abgeschätzt werden, wie viele zusätzliche Ereignisse im Vergleich zum derzeitigen Anlagenzustand auftreten können und für wie lange das zu einem Burst führt - also wie lange die relativ niederpriorste Nachricht dann verzögert würde. Ist dieser Wert von der Applikation her zulässig, so ist die aktuelle Buslast akzeptabel. Als "Daumenwert" kann meist angenommen werden, dass ein ereignisgesteuertes Netz mit 30-40% Grundlast genügend Reserven für worst-case-Szenarien hat - diese Annahme macht aber eine sorgfältige Analyse nicht überflüssig, wenn Verzögerungen zu kritischen Anlagenzuständen führen können.

Die Beckhoff PC Karten FC510x zeigen die Buslast über den System Manager ein. Diese Variable kann auch in der SPS verarbeitet oder in der Visualisierung zur Anzeige gebracht werden.

Neben den Kommunikationsparametern ist natürlich die Datenbelegung der Prozessdatenobjekte entscheidend: das PDO Mapping.


Automatisches PDO Mapping

BK51x0, IL23x0-B510

PDO1 und PDO2 werden, wie beschrieben, mit digitalen und analogen Prozessdaten belegt. Für jedes weitere PDO geht der CANopen Knoten nach folgendem Verfahren vor und belegt die PDOs in der folgenden Reihenfolge mit Prozessdaten:

1. Digitale E/As (wenn mehr als 64 vorhanden)

2. 1-Byte Sonderklemmen

3. Analoge E/As

4. 2-Byte Sonderklemmen

5. 3-Byte Sonderklemmen

6. ...10. 8-Byte Sonderklemmen

Datentypen werden nicht gemischt, es wird für jeden neuen Datentyp ein neues PDO befüllt. Beispiel

Das Vorgehen ist in untenstehendem Ablaufdiagramm dargestellt.

Beispiel

Ein BK5120 CANopen Koppler verfügt insgesamt über 78 digitale Ein- und 48 digitale Ausgänge, 6 analoge Eingänge und 10 analoge Ausgänge, 1 SSI-Geber Interface (per default 2 x 2 Byte E), 1 serielle Schnittstelle (per default je 2 x 2 Byte E+A) sowie ein Inkrementalencoderinterface (je 6 Byte E+A):

PDO | Dateninhalt (Mapping) | PDO | Dateninhalt (Mapping)
RxPDO1 | digitale Ausgänge 1..48 | TxPDO1 | digitale Eingänge 1..64
RxPDO2 | analoge Ausgänge 1..4 | TxPDO2 | analoge Eingänge 1..4
RxPDO3 | analoge Ausgänge 5..8 | TxPDO3 | digitale Eingänge 65...78
RxPDO4 | analoge Ausgänge 9+10 | TxPDO4 | analoge Eingänge 5+6
RxPDO5 | 2x2 serielle Schnittstelle | TxPDO5 | 2x2 SSI+2x2 seriell
RxPDO6 | 6 Byte Encoder Aus | TxPDO6 | 6 Byte Encoder Ein


Bit Timing

Folgende Baudraten und Bittiming Register Einstellungen werden von den Beckhoff CANopen Geräten unterstützt:

Baudrate [kbaud] | BTR0 | BTR1
1000 | 00 | 14
800 | 00 | 16
500 | 00 | 1C
250 | 01 | 1C
125 | 03 | 1C
100 | 43 | 2F
50 | 47 | 2F
20 | 53 | 2F
10 | 6F | 2F

Die angegebenen Bit-Timing Register Einstellungen (BTR0, BTR1) gelten z.B. für die CAN-Controller Philips 82C200, SJA1000, Intel 80C527, Siemens 80C167, und andere. Sie sind für maximale Buslänge optimiert.


Identifier Verteilung

Default Identifier

CANopen sieht für die wichtigsten Kommunikationsobjekte Default-Identifier vor, die aus der 7-Bit Knotenadresse (Node-ID) und einem 4-Bit Function Code nach folgendem Schema abgleiten werden:

Für die Broadcast-Objekte wird die Node-ID "0" eingesetzt. Damit ergeben sich folgende Default-Identifier:

Broadcast Objekte
Objekt | Funktion | Function Code | resultierende COB ID hex / dez | Objekt für Comm. Parameter / Mapping
NMT | Boot-Up | 0 | 0x00 / 0 | - / -
SYNC | Synch. | 1 | 0x80 / 128 | 0x1005 + 0x1006 / -
Peer-to-Peer Objekte
Objekt | Funktion | Function Code | resultierende COB ID hex / dez | Objekt für Comm. Parameter / Mapping
Emergency | Status / Fehler | 1 | 0x81 - 0xFF/ 129 - 255 | - / -
PDO1 (tx) | dig. Eingänge | 11 | 0x181 - 0x1FF / 385 - 511 | 0x1800 / 0x1A00
PDO1 (rx) | digitale Ausgänge | 100 | 0x201 - 0x27F/ 513-639 | 0x1400 / 0x1600
PDO2 (tx) | analoge Eingänge | 101 | 0x281 - 0x2FF/ 641-767 | 0x1801 / 0x1A01
PDO2 (rx) | Analoge Ausgänge | 110 | 0x301 - 0x37F/ 769-895 | 0x1401 / 0x1601
SDO (tx) | Parameter | 1011 | 0x581 - 0x5FF/ 1409-1535 | - / -
SDO (rx) | Parameter | 1100 | 0x601 - 0x67F/ 1537-1663 | - / -
Guarding | Life-/Node-guarding | 1110 | 0x701 - 0x77F/ 1793-1919 | (0x100C, 0x100D, 0x100E)

Hinweis: Bis zur CANopen Spezifikation Version 3 waren jeweils 2 PDOs mit Default-Identifiern versehen. Die Beckhoff Buskoppler entsprechen diesem Stand der Spezifikation. Ab Version 4 sind Default Identifier für bis zu 4 PDOs vorgesehen.

Herstellerspezische Default Identifier für zusätzliche PDOs

Den zusätzlichen PDOs, die von den Beckhoff Buskopplern nach dem Standardschema befüllt werden, wird kein Identifier zugeordnet. Der Anwender muss in das Objektverzeichnis einen Identifier für diese PDOs eintragen. Einfacher ist es, die belegten PDOs über das Objekt 0x5500 zu aktivieren.

Über diesen Eintrag im Objektverzeichnis wird die Default-Identifierverteilung auf bis zu 11 PDOs ausgedehnt. Es ergeben sich folgende Identifier:

Objekt | Function Code | resultierende COB ID (hex) | resultierende COB ID (dez)
PDO3 (tx) | 111 | 0x381 - 0x3BF | 897 - 959
PDO3 (rx) | 1000 | 0x401 - 0x43F | 1025 - 1087
PDO4 (tx) | 1001 | 0x481 - 0x4BF | 1153 - 1215
PDO4 (rx) | 1010 | 0x501 - 0x53F | 1281- 1343
PDO5 (tx) | 1101 | 0x681 - 0x6BF | 1665 - 1727
PDO5 (rx) | 1111 | 0x781 - 0x7BF | 1921- 1983
PDO6 (tx) | 111 | 0x1C1 - 0x1FF | 449 - 511
PDO6 (rx) | 1001 | 0x241 - 0x27F | 577 - 639
PDO7 (tx) | 1011 | 0x2C1 - 0x2FF | 705 - 767
PDO7 (rx) | 1101 | 0x341 - 0x37F | 833 - 895
PDO8 (tx) | 1111 | 0x3C1- 0x3FF | 961 - 1023
PDO8 (rx) | 10001 | 0x441 - 0x47F | 1089 - 1151
PDO9 (tx) | 10011 | 0x4C1 - 0x4FF | 1217 - 1279
PDO9 (rx) | 10101 | 0x541 - 0x57F | 1345 - 1407
PDO10 (tx) | 10111 | 0x5C1 - 0x5FF | 1473 - 1535
PDO10 (rx) | 11001 | 0x641 - 0x67F | 1601- 1663
PDO11 (tx) | 11011 | 0x6C1 - 0x6FF | 1729 - 1791
PDO11 (rx) | 11101 | 0x741 - 0x77F | 1857 - 1919

Anmerkung: Es ist darauf zu achten, dass der Index 0x5500 nicht genutzt wird, wenn Buskoppler mit mehr als 5 PDOs in Netzen mit Knotennummern >64 vorhanden sind, da es sonst zu Identifierüberschneidungen kommen kann.


Identifier Gesamtliste

mit * gekennzeichnete Identifier werden auf den Buskopplern nach Beschreiben von Index 0x5500 herstellerspezifisch vergeben

0x201 0x301 0x401 0x501 0x601 0x701

dez | hex | Bedeutung | dez | hex | Bedeutung | dez | hex | Bedeutung
0 | 0 | NMT | 874 | 36A | RxPDO7*, Nd.42 | 1430 | 596 | SDO Tx Nd.22
128 | 80 | SYNC | 875 | 36B | RxPDO7*, Nd.43 | 1431 | 597 | SDO Tx Nd.23
129 | 81 | EMCY Nd.1 | 876 | 36C | RxPDO7*, Nd.44 | 1432 | 598 | SDO Tx Nd.24
130 | 82 | EMCY Nd.2 | 877 | 36D | RxPDO7*, Nd.45 | 1433 | 599 | SDO Tx Nd.25
131 | 83 | EMCY Nd.3 | 878 | 36E | RxPDO7*, Nd.46 | 1434 | 59A | SDO Tx Nd.26
132 | 84 | EMCY Nd.4 | 879 | 36F | RxPDO7*, Nd.47 | 1435 | 59B | SDO Tx Nd.27
133 | 85 | EMCY Nd.5 | 880 | 370 | RxPDO7*, Nd.48 | 1436 | 59C | SDO Tx Nd.28
134 | 86 | EMCY Nd.6 | 881 | 371 | RxPDO7*, Nd.49 | 1437 | 59D | SDO Tx Nd.29
135 | 87 | EMCY Nd.7 | 882 | 372 | RxPDO7*, Nd.50 | 1438 | 59E | SDO Tx Nd.30
136 | 88 | EMCY Nd.8 | 883 | 373 | RxPDO7*, Nd.51 | 1439 | 59F | SDO Tx Nd.31
137 | 89 | EMCY Nd.9 | 884 | 374 | RxPDO7*, Nd.52 | 1440 | 5A0 | SDO Tx Nd.32
138 | 8A | EMCY Nd.10 | 885 | 375 | RxPDO7*, Nd.53 | 1441 | 5A1 | SDO Tx Nd.33
139 | 8B | EMCY Nd.11 | 886 | 376 | RxPDO7*, Nd.54 | 1442 | 5A2 | SDO Tx Nd.34
140 | 8C | EMCY Nd.12 | 887 | 377 | RxPDO7*, Nd.55 | 1443 | 5A3 | SDO Tx Nd.35
141 | 8D | EMCY Nd.13 | 888 | 378 | RxPDO7*, Nd.56 | 1444 | 5A4 | SDO Tx Nd.36
142 | 8E | EMCY Nd.14 | 889 | 379 | RxPDO7*, Nd.57 | 1445 | 5A5 | SDO Tx Nd.37
143 | 8F | EMCY Nd.15 | 890 | 37A | RxPDO7*, Nd.58 | 1446 | 5A6 | SDO Tx Nd.38
144 | 90 | EMCY Nd.16 | 891 | 37B | RxPDO7*, Nd.59 | 1447 | 5A7 | SDO Tx Nd.39
145 | 91 | EMCY Nd.17 | 892 | 37C | RxPDO7*, Nd.60 | 1448 | 5A8 | SDO Tx Nd.40
146 | 92 | EMCY Nd.18 | 893 | 37D | RxPDO7*, Nd.61 | 1449 | 5A9 | SDO Tx Nd.41
147 | 93 | EMCY Nd.19 | 894 | 37E | RxPDO7*, Nd.62 | 1450 | 5AA | SDO Tx Nd.42
148 | 94 | EMCY Nd.20 | 895 | 37F | RxPDO7*, Nd.63 | 1451 | 5AB | SDO Tx Nd.43
149 | 95 | EMCY Nd.21 | 897 | 381 | TxPDO3*, Nd.1 | 1452 | 5AC | SDO Tx Nd.44
150 | 96 | EMCY Nd.22 | 898 | 382 | TxPDO3*, Nd.2 | 1453 | 5AD | SDO Tx Nd.45
151 | 97 | EMCY Nd.23 | 899 | 383 | TxPDO3*, Nd.3 | 1454 | 5AE | SDO Tx Nd.46
152 | 98 | EMCY Nd.24 | 900 | 384 | TxPDO3*, Nd.4 | 1455 | 5AF | SDO Tx Nd.47
153 | 99 | EMCY Nd.25 | 901 | 385 | TxPDO3*, Nd.5 | 1456 | 5B0 | SDO Tx Nd.48
154 | 9A | EMCY Nd.26 | 902 | 386 | TxPDO3*, Nd.6 | 1457 | 5B1 | SDO Tx Nd.49
155 | 9B | EMCY Nd.27 | 903 | 387 | TxPDO3*, Nd.7 | 1458 | 5B2 | SDO Tx Nd.50
156 | 9C | EMCY Nd.28 | 904 | 388 | TxPDO3*, Nd.8 | 1459 | 5B3 | SDO Tx Nd.51
157 | 9D | EMCY Nd.29 | 905 | 389 | TxPDO3*, Nd.9 | 1460 | 5B4 | SDO Tx Nd.52
158 | 9E | EMCY Nd.30 | 906 | 38A | TxPDO3*, Nd.10 | 1461 | 5B5 | SDO Tx Nd.53
159 | 9F | EMCY Nd.31 | 907 | 38B | TxPDO3*, Nd.11 | 1462 | 5B6 | SDO Tx Nd.54
160 | A0 | EMCY Nd.32 | 908 | 38C | TxPDO3*, Nd.12 | 1463 | 5B7 | SDO Tx Nd.55
161 | A1 | EMCY Nd.33 | 909 | 38D | TxPDO3*, Nd.13 | 1464 | 5B8 | SDO Tx Nd.56
162 | A2 | EMCY Nd.34 | 910 | 38E | TxPDO3*, Nd.14 | 1465 | 5B9 | SDO Tx Nd.57
163 | A3 | EMCY Nd.35 | 911 | 38F | TxPDO3*, Nd.15 | 1466 | 5BA | SDO Tx Nd.58
164 | A4 | EMCY Nd.36 | 912 | 390 | TxPDO3*, Nd.16 | 1467 | 5BB | SDO Tx Nd.59
165 | A5 | EMCY Nd.37 | 913 | 391 | TxPDO3*, Nd.17 | 1468 | 5BC | SDO Tx Nd.60
166 | A6 | EMCY Nd.38 | 914 | 392 | TxPDO3*, Nd.18 | 1469 | 5BD | SDO Tx Nd.61
167 | A7 | EMCY Nd.39 | 915 | 393 | TxPDO3*, Nd.19 | 1470 | 5BE | SDO Tx Nd.62
168 | A8 | EMCY Nd.40 | 916 | 394 | TxPDO3*, Nd.20 | 1471 | 5BF | SDO Tx Nd.63
169 | A9 | EMCY Nd.41 | 917 | 395 | TxPDO3*, Nd.21 | 1473 | 5C1 | TxPDO10*, Nd.1
170 | AA | EMCY Nd.42 | 918 | 396 | TxPDO3*, Nd.22 | 1474 | 5C2 | TxPDO10*, Nd.2
171 | AB | EMCY Nd.43 | 919 | 397 | TxPDO3*, Nd.23 | 1475 | 5C3 | TxPDO10*, Nd.3
172 | AC | EMCY Nd.44 | 920 | 398 | TxPDO3*, Nd.24 | 1476 | 5C4 | TxPDO10*, Nd.4
173 | AD | EMCY Nd.45 | 921 | 399 | TxPDO3*, Nd.25 | 1477 | 5C5 | TxPDO10*, Nd.5
174 | AE | EMCY Nd.46 | 922 | 39A | TxPDO3*, Nd.26 | 1478 | 5C6 | TxPDO10*, Nd.6
175 | AF | EMCY Nd.47 | 923 | 39B | TxPDO3*, Nd.27 | 1479 | 5C7 | TxPDO10*, Nd.7
176 | B0 | EMCY Nd.48 | 924 | 39C | TxPDO3*, Nd.28 | 1480 | 5C8 | TxPDO10*, Nd.8
177 | B1 | EMCY Nd.49 | 925 | 39D | TxPDO3*, Nd.29 | 1481 | 5C9 | TxPDO10*, Nd.9
178 | B2 | EMCY Nd.50 | 926 | 39E | TxPDO3*, Nd.30 | 1482 | 5CA | TxPDO10*, Nd.10
179 | B3 | EMCY Nd.51 | 927 | 39F | TxPDO3*, Nd.31 | 1483 | 5CB | TxPDO10*, Nd.11
180 | B4 | EMCY Nd.52 | 928 | 3A0 | TxPDO3*, Nd.32 | 1484 | 5CC | TxPDO10*, Nd.12
181 | B5 | EMCY Nd.53 | 929 | 3A1 | TxPDO3*, Nd.33 | 1485 | 5CD | TxPDO10*, Nd.13
182 | B6 | EMCY Nd.54 | 930 | 3A2 | TxPDO3*, Nd.34 | 1486 | 5CE | TxPDO10*, Nd.14
183 | B7 | EMCY Nd.55 | 931 | 3A3 | TxPDO3*, Nd.35 | 1487 | 5CF | TxPDO10*, Nd.15
184 | B8 | EMCY Nd.56 | 932 | 3A4 | TxPDO3*, Nd.36 | 1488 | 5D0 | TxPDO10*, Nd.16
185 | B9 | EMCY Nd.57 | 933 | 3A5 | TxPDO3*, Nd.37 | 1489 | 5D1 | TxPDO10*, Nd.17
186 | BA | EMCY Nd.58 | 934 | 3A6 | TxPDO3*, Nd.38 | 1490 | 5D2 | TxPDO10*, Nd.18
187 | BB | EMCY Nd.59 | 935 | 3A7 | TxPDO3*, Nd.39 | 1491 | 5D3 | TxPDO10*, Nd.19
188 | BC | EMCY Nd.60 | 936 | 3A8 | TxPDO3*, Nd.40 | 1492 | 5D4 | TxPDO10*, Nd.20
189 | BD | EMCY Nd.61 | 937 | 3A9 | TxPDO3*, Nd.41 | 1493 | 5D5 | TxPDO10*, Nd.21
190 | BE | EMCY Nd.62 | 938 | 3AA | TxPDO3*, Nd.42 | 1494 | 5D6 | TxPDO10*, Nd.22
191 | BF | EMCY Nd.63 | 939 | 3AB | TxPDO3*, Nd.43 | 1495 | 5D7 | TxPDO10*, Nd.23
385 | 181 | TxPDO1, DI, Nd.1 | 940 | 3AC | TxPDO3*, Nd.44 | 1496 | 5D8 | TxPDO10*, Nd.24
386 | 182 | TxPDO1, DI, Nd.2 | 941 | 3AD | TxPDO3*, Nd.45 | 1497 | 5D9 | TxPDO10*, Nd.25
387 | 183 | TxPDO1, DI, Nd.3 | 942 | 3AE | TxPDO3*, Nd.46 | 1498 | 5DA | TxPDO10*, Nd.26
388 | 184 | TxPDO1, DI, Nd.4 | 943 | 3AF | TxPDO3*, Nd.47 | 1499 | 5DB | TxPDO10*, Nd.27
389 | 185 | TxPDO1, DI, Nd.5 | 944 | 3B0 | TxPDO3*, Nd.48 | 1500 | 5DC | TxPDO10*, Nd.28
390 | 186 | TxPDO1, DI, Nd.6 | 945 | 3B1 | TxPDO3*, Nd.49 | 1501 | 5DD | TxPDO10*, Nd.29
391 | 187 | TxPDO1, DI, Nd.7 | 946 | 3B2 | TxPDO3*, Nd.50 | 1502 | 5DE | TxPDO10*, Nd.30
392 | 188 | TxPDO1, DI, Nd.8 | 947 | 3B3 | TxPDO3*, Nd.51 | 1503 | 5DF | TxPDO10*, Nd.31
393 | 189 | TxPDO1, DI, Nd.9 | 948 | 3B4 | TxPDO3*, Nd.52 | 1504 | 5E0 | TxPDO10*, Nd.32
394 | 18A | TxPDO1, DI, Nd.10 | 949 | 3B5 | TxPDO3*, Nd.53 | 1505 | 5E1 | TxPDO10*, Nd.33
395 | 18B | TxPDO1, DI, Nd.11 | 950 | 3B6 | TxPDO3*, Nd.54 | 1506 | 5E2 | TxPDO10*, Nd.34
396 | 18C | TxPDO1, DI, Nd.12 | 951 | 3B7 | TxPDO3*, Nd.55 | 1507 | 5E3 | TxPDO10*, Nd.35
397 | 18D | TxPDO1, DI, Nd.13 | 952 | 3B8 | TxPDO3*, Nd.56 | 1508 | 5E4 | TxPDO10*, Nd.36
398 | 18E | TxPDO1, DI, Nd.14 | 953 | 3B9 | TxPDO3*, Nd.57 | 1509 | 5E5 | TxPDO10*, Nd.37
399 | 18F | TxPDO1, DI, Nd.15 | 954 | 3BA | TxPDO3*, Nd.58 | 1510 | 5E6 | TxPDO10*, Nd.38
400 | 190 | TxPDO1, DI, Nd.16 | 955 | 3BB | TxPDO3*, Nd.59 | 1511 | 5E7 | TxPDO10*, Nd.39
401 | 191 | TxPDO1, DI, Nd.17 | 956 | 3BC | TxPDO3*, Nd.60 | 1512 | 5E8 | TxPDO10*, Nd.40
402 | 192 | TxPDO1, DI, Nd.18 | 957 | 3BD | TxPDO3*, Nd.61 | 1513 | 5E9 | TxPDO10*, Nd.41
403 | 193 | TxPDO1, DI, Nd.19 | 958 | 3BE | TxPDO3*, Nd.62 | 1514 | 5EA | TxPDO10*, Nd.42
404 | 194 | TxPDO1, DI, Nd.20 | 959 | 3BF | TxPDO3*, Nd.63 | 1515 | 5EB | TxPDO10*, Nd.43
405 | 195 | TxPDO1, DI, Nd.21 | 961 | 3C1 | TxPDO8*, Nd.1 | 1516 | 5EC | TxPDO10*, Nd.44
406 | 196 | TxPDO1, DI, Nd.22 | 962 | 3C2 | TxPDO8*, Nd.2 | 1517 | 5ED | TxPDO10*, Nd.45
407 | 197 | TxPDO1, DI, Nd.23 | 963 | 3C3 | TxPDO8*, Nd.3 | 1518 | 5EE | TxPDO10*, Nd.46
408 | 198 | TxPDO1, DI, Nd.24 | 964 | 3C4 | TxPDO8*, Nd.4 | 1519 | 5EF | TxPDO10*, Nd.47
409 | 199 | TxPDO1, DI, Nd.25 | 965 | 3C5 | TxPDO8*, Nd.5 | 1520 | 5F0 | TxPDO10*, Nd.48
410 | 19A | TxPDO1, DI, Nd.26 | 966 | 3C6 | TxPDO8*, Nd.6 | 1521 | 5F1 | TxPDO10*, Nd.49
411 | 19B | TxPDO1, DI, Nd.27 | 967 | 3C7 | TxPDO8*, Nd.7 | 1522 | 5F2 | TxPDO10*, Nd.50
412 | 19C | TxPDO1, DI, Nd.28 | 968 | 3C8 | TxPDO8*, Nd.8 | 1523 | 5F3 | TxPDO10*, Nd.51
413 | 19D | TxPDO1, DI, Nd.29 | 969 | 3C9 | TxPDO8*, Nd.9 | 1524 | 5F4 | TxPDO10*, Nd.52
414 | 19E | TxPDO1, DI, Nd.30 | 970 | 3CA | TxPDO8*, Nd.10 | 1525 | 5F5 | TxPDO10*, Nd.53
415 | 19F | TxPDO1, DI, Nd.31 | 971 | 3CB | TxPDO8*, Nd.11 | 1526 | 5F6 | TxPDO10*, Nd.54
416 | 1A0 | TxPDO1, DI, Nd.32 | 972 | 3CC | TxPDO8*, Nd.12 | 1527 | 5F7 | TxPDO10*, Nd.55
417 | 1A1 | TxPDO1, DI, Nd.33 | 973 | 3CD | TxPDO8*, Nd.13 | 1528 | 5F8 | TxPDO10*, Nd.56
418 | 1A2 | TxPDO1, DI, Nd.34 | 974 | 3CE | TxPDO8*, Nd.14 | 1529 | 5F9 | TxPDO10*, Nd.57
419 | 1A3 | TxPDO1, DI, Nd.35 | 975 | 3CF | TxPDO8*, Nd.15 | 1530 | 5FA | TxPDO10*, Nd.58
420 | 1A4 | TxPDO1, DI, Nd.36 | 976 | 3D0 | TxPDO8*, Nd.16 | 1531 | 5FB | TxPDO10*, Nd.59
421 | 1A5 | TxPDO1, DI, Nd.37 | 977 | 3D1 | TxPDO8*, Nd.17 | 1532 | 5FC | TxPDO10*, Nd.60
422 | 1A6 | TxPDO1, DI, Nd.38 | 978 | 3D2 | TxPDO8*, Nd.18 | 1533 | 5FD | TxPDO10*, Nd.61
423 | 1A7 | TxPDO1, DI, Nd.39 | 979 | 3D3 | TxPDO8*, Nd.19 | 1534 | 5FE | TxPDO10*, Nd.62
424 | 1A8 | TxPDO1, DI, Nd.40 | 980 | 3D4 | TxPDO8*, Nd.20 | 1535 | 5FF | TxPDO10*, Nd.63
425 | 1A9 | TxPDO1, DI, Nd.41 | 981 | 3D5 | TxPDO8*, Nd.21 | 1537 | 601 | SDO Rx Nd.1
426 | 1AA | TxPDO1, DI, Nd.42 | 982 | 3D6 | TxPDO8*, Nd.22 | 1538 | 602 | SDO Rx Nd.2
427 | 1AB | TxPDO1, DI, Nd.43 | 983 | 3D7 | TxPDO8*, Nd.23 | 1539 | 603 | SDO Rx Nd.3
428 | 1AC | TxPDO1, DI, Nd.44 | 984 | 3D8 | TxPDO8*, Nd.24 | 1540 | 604 | SDO Rx Nd.4
429 | 1AD | TxPDO1, DI, Nd.45 | 985 | 3D9 | TxPDO8*, Nd.25 | 1541 | 605 | SDO Rx Nd.5
430 | 1AE | TxPDO1, DI, Nd.46 | 986 | 3DA | TxPDO8*, Nd.26 | 1542 | 606 | SDO Rx Nd.6
431 | 1AF | TxPDO1, DI, Nd.47 | 987 | 3DB | TxPDO8*, Nd.27 | 1543 | 607 | SDO Rx Nd.7
432 | 1B0 | TxPDO1, DI, Nd.48 | 988 | 3DC | TxPDO8*, Nd.28 | 1544 | 608 | SDO Rx Nd.8
433 | 1B1 | TxPDO1, DI, Nd.49 | 989 | 3DD | TxPDO8*, Nd.29 | 1545 | 609 | SDO Rx Nd.9
434 | 1B2 | TxPDO1, DI, Nd.50 | 990 | 3DE | TxPDO8*, Nd.30 | 1546 | 60A | SDO Rx Nd.10
435 | 1B3 | TxPDO1, DI, Nd.51 | 991 | 3DF | TxPDO8*, Nd.31 | 1547 | 60B | SDO Rx Nd.11
436 | 1B4 | TxPDO1, DI, Nd.52 | 992 | 3E0 | TxPDO8*, Nd.32 | 1548 | 60C | SDO Rx Nd.12
437 | 1B5 | TxPDO1, DI, Nd.53 | 993 | 3E1 | TxPDO8*, Nd.33 | 1549 | 60D | SDO Rx Nd.13
438 | 1B6 | TxPDO1, DI, Nd.54 | 994 | 3E2 | TxPDO8*, Nd.34 | 1550 | 60E | SDO Rx Nd.14
439 | 1B7 | TxPDO1, DI, Nd.55 | 995 | 3E3 | TxPDO8*, Nd.35 | 1551 | 60F | SDO Rx Nd.15
440 | 1B8 | TxPDO1, DI, Nd.56 | 996 | 3E4 | TxPDO8*, Nd.36 | 1552 | 610 | SDO Rx Nd.16
441 | 1B9 | TxPDO1, DI, Nd.57 | 997 | 3E5 | TxPDO8*, Nd.37 | 1553 | 611 | SDO Rx Nd.17
442 | 1BA | TxPDO1, DI, Nd.58 | 998 | 3E6 | TxPDO8*, Nd.38 | 1554 | 612 | SDO Rx Nd.18
443 | 1BB | TxPDO1, DI, Nd.59 | 999 | 3E7 | TxPDO8*, Nd.39 | 1555 | 613 | SDO Rx Nd.19
444 | 1BC | TxPDO1, DI, Nd.60 | 1000 | 3E8 | TxPDO8*, Nd.40 | 1556 | 614 | SDO Rx Nd.20
445 | 1BD | TxPDO1, DI, Nd.61 | 1001 | 3E9 | TxPDO8*, Nd.41 | 1557 | 615 | SDO Rx Nd.21
446 | 1BE | TxPDO1, DI, Nd.62 | 1002 | 3EA | TxPDO8*, Nd.42 | 1558 | 616 | SDO Rx Nd.22
447 | 1BF | TxPDO1, DI, Nd.63 | 1003 | 3EB | TxPDO8*, Nd.43 | 1559 | 617 | SDO Rx Nd.23
449 | 1C1 | TxPDO6*, Nd.1 | 1004 | 3EC | TxPDO8*, Nd.44 | 1560 | 618 | SDO Rx Nd.24
450 | 1C2 | TxPDO6*, Nd.2 | 1005 | 3ED | TxPDO8*, Nd.45 | 1561 | 619 | SDO Rx Nd.25
451 | 1C3 | TxPDO6*, Nd.3 | 1006 | 3EE | TxPDO8*, Nd.46 | 1562 | 61A | SDO Rx Nd.26
452 | 1C4 | TxPDO6*, Nd.4 | 1007 | 3EF | TxPDO8*, Nd.47 | 1563 | 61B | SDO Rx Nd.27
453 | 1C5 | TxPDO6*, Nd.5 | 1008 | 3F0 | TxPDO8*, Nd.48 | 1564 | 61C | SDO Rx Nd.28
454 | 1C6 | TxPDO6*, Nd.6 | 1009 | 3F1 | TxPDO8*, Nd.49 | 1565 | 61D | SDO Rx Nd.29
455 | 1C7 | TxPDO6*, Nd.7 | 1010 | 3F2 | TxPDO8*, Nd.50 | 1566 | 61E | SDO Rx Nd.30
456 | 1C8 | TxPDO6*, Nd.8 | 1011 | 3F3 | TxPDO8*, Nd.51 | 1567 | 61F | SDO Rx Nd.31
457 | 1C9 | TxPDO6*, Nd.9 | 1012 | 3F4 | TxPDO8*, Nd.52 | 1568 | 620 | SDO Rx Nd.32
458 | 1CA | TxPDO6*, Nd.10 | 1013 | 3F5 | TxPDO8*, Nd.53 | 1569 | 621 | SDO Rx Nd.33
459 | 1CB | TxPDO6*, Nd.11 | 1014 | 3F6 | TxPDO8*, Nd.54 | 1570 | 622 | SDO Rx Nd.34
460 | 1CC | TxPDO6*, Nd.12 | 1015 | 3F7 | TxPDO8*, Nd.55 | 1571 | 623 | SDO Rx Nd.35
461 | 1CD | TxPDO6*, Nd.13 | 1016 | 3F8 | TxPDO8*, Nd.56 | 1572 | 624 | SDO Rx Nd.36
462 | 1CE | TxPDO6*, Nd.14 | 1017 | 3F9 | TxPDO8*, Nd.57 | 1573 | 625 | SDO Rx Nd.37
463 | 1CF | TxPDO6*, Nd.15 | 1018 | 3FA | TxPDO8*, Nd.58 | 1574 | 626 | SDO Rx Nd.38
464 | 1D0 | TxPDO6*, Nd.16 | 1019 | 3FB | TxPDO8*, Nd.59 | 1575 | 627 | SDO Rx Nd.39
465 | 1D1 | TxPDO6*, Nd.17 | 1020 | 3FC | TxPDO8*, Nd.60 | 1576 | 628 | SDO Rx Nd.40
466 | 1D2 | TxPDO6*, Nd.18 | 1021 | 3FD | TxPDO8*, Nd.61 | 1577 | 629 | SDO Rx Nd.41
467 | 1D3 | TxPDO6*, Nd.19 | 1022 | 3FE | TxPDO8*, Nd.62 | 1578 | 62A | SDO Rx Nd.42
468 | 1D4 | TxPDO6*, Nd.20 | 1023 | 3FF | TxPDO8*, Nd.63 | 1579 | 62B | SDO Rx Nd.43
469 | 1D5 | TxPDO6*, Nd.21 | 1025 | 401 | RxPDO3*, Nd.1 | 1580 | 62C | SDO Rx Nd.44
470 | 1D6 | TxPDO6*, Nd.22 | 1026 | 402 | RxPDO3*, Nd.2 | 1581 | 62D | SDO Rx Nd.45
471 | 1D7 | TxPDO6*, Nd.23 | 1027 | 403 | RxPDO3*, Nd.3 | 1582 | 62E | SDO Rx Nd.46
472 | 1D8 | TxPDO6*, Nd.24 | 1028 | 404 | RxPDO3*, Nd.4 | 1583 | 62F | SDO Rx Nd.47
473 | 1D9 | TxPDO6*, Nd.25 | 1029 | 405 | RxPDO3*, Nd.5 | 1584 | 630 | SDO Rx Nd.48
474 | 1DA | TxPDO6*, Nd.26 | 1030 | 406 | RxPDO3*, Nd.6 | 1585 | 631 | SDO Rx Nd.49
475 | 1DB | TxPDO6*, Nd.27 | 1031 | 407 | RxPDO3*, Nd.7 | 1586 | 632 | SDO Rx Nd.50
476 | 1DC | TxPDO6*, Nd.28 | 1032 | 408 | RxPDO3*, Nd.8 | 1587 | 633 | SDO Rx Nd.51
477 | 1DD | TxPDO6*, Nd.29 | 1033 | 409 | RxPDO3*, Nd.9 | 1588 | 634 | SDO Rx Nd.52
478 | 1DE | TxPDO6*, Nd.30 | 1034 | 40A | RxPDO3*, Nd.10 | 1589 | 635 | SDO Rx Nd.53
479 | 1DF | TxPDO6*, Nd.31 | 1035 | 40B | RxPDO3*, Nd.11 | 1590 | 636 | SDO Rx Nd.54
480 | 1E0 | TxPDO6*, Nd.32 | 1036 | 40C | RxPDO3*, Nd.12 | 1591 | 637 | SDO Rx Nd.55
481 | 1E1 | TxPDO6*, Nd.33 | 1037 | 40D | RxPDO3*, Nd.13 | 1592 | 638 | SDO Rx Nd.56
482 | 1E2 | TxPDO6*, Nd.34 | 1038 | 40E | RxPDO3*, Nd.14 | 1593 | 639 | SDO Rx Nd.57
483 | 1E3 | TxPDO6*, Nd.35 | 1039 | 40F | RxPDO3*, Nd.15 | 1594 | 63A | SDO Rx Nd.58
484 | 1E4 | TxPDO6*, Nd.36 | 1040 | 410 | RxPDO3*, Nd.16 | 1595 | 63B | SDO Rx Nd.59
485 | 1E5 | TxPDO6*, Nd.37 | 1041 | 411 | RxPDO3*, Nd.17 | 1596 | 63C | SDO Rx Nd.60
486 | 1E6 | TxPDO6*, Nd.38 | 1042 | 412 | RxPDO3*, Nd.18 | 1597 | 63D | SDO Rx Nd.61
487 | 1E7 | TxPDO6*, Nd.39 | 1043 | 413 | RxPDO3*, Nd.19 | 1598 | 63E | SDO Rx Nd.62
488 | 1E8 | TxPDO6*, Nd.40 | 1044 | 414 | RxPDO3*, Nd.20 | 1599 | 63F | SDO Rx Nd.63
489 | 1E9 | TxPDO6*, Nd.41 | 1045 | 415 | RxPDO3*, Nd.21 | 1601 | 641 | RxPDO10*, Nd.1
490 | 1EA | TxPDO6*, Nd.42 | 1046 | 416 | RxPDO3*, Nd.22 | 1602 | 642 | RxPDO10*, Nd.2
491 | 1EB | TxPDO6*, Nd.43 | 1047 | 417 | RxPDO3*, Nd.23 | 1603 | 643 | RxPDO10*, Nd.3
492 | 1EC | TxPDO6*, Nd.44 | 1048 | 418 | RxPDO3*, Nd.24 | 1604 | 644 | RxPDO10*, Nd.4
493 | 1ED | TxPDO6*, Nd.45 | 1049 | 419 | RxPDO3*, Nd.25 | 1605 | 645 | RxPDO10*, Nd.5
494 | 1EE | TxPDO6*, Nd.46 | 1050 | 41A | RxPDO3*, Nd.26 | 1606 | 646 | RxPDO10*, Nd.6
495 | 1EF | TxPDO6*, Nd.47 | 1051 | 41B | RxPDO3*, Nd.27 | 1607 | 647 | RxPDO10*, Nd.7
496 | 1F0 | TxPDO6*, Nd.48 | 1052 | 41C | RxPDO3*, Nd.28 | 1608 | 648 | RxPDO10*, Nd.8
497 | 1F1 | TxPDO6*, Nd.49 | 1053 | 41D | RxPDO3*, Nd.29 | 1609 | 649 | RxPDO10*, Nd.9
498 | 1F2 | TxPDO6*, Nd.50 | 1054 | 41E | RxPDO3*, Nd.30 | 1610 | 64A | RxPDO10*, Nd.10
499 | 1F3 | TxPDO6*, Nd.51 | 1055 | 41F | RxPDO3*, Nd.31 | 1611 | 64B | RxPDO10*, Nd.11
500 | 1F4 | TxPDO6*, Nd.52 | 1056 | 420 | RxPDO3*, Nd.32 | 1612 | 64C | RxPDO10*, Nd.12
501 | 1F5 | TxPDO6*, Nd.53 | 1057 | 421 | RxPDO3*, Nd.33 | 1613 | 64D | RxPDO10*, Nd.13
502 | 1F6 | TxPDO6*, Nd.54 | 1058 | 422 | RxPDO3*, Nd.34 | 1614 | 64E | RxPDO10*, Nd.14
503 | 1F7 | TxPDO6*, Nd.55 | 1059 | 423 | RxPDO3*, Nd.35 | 1615 | 64F | RxPDO10*, Nd.15
504 | 1F8 | TxPDO6*, Nd.56 | 1060 | 424 | RxPDO3*, Nd.36 | 1616 | 650 | RxPDO10*, Nd.16
505 | 1F9 | TxPDO6*, Nd.57 | 1061 | 425 | RxPDO3*, Nd.37 | 1617 | 651 | RxPDO10*, Nd.17
506 | 1FA | TxPDO6*, Nd.58 | 1062 | 426 | RxPDO3*, Nd.38 | 1618 | 652 | RxPDO10*, Nd.18
507 | 1FB | TxPDO6*, Nd.59 | 1063 | 427 | RxPDO3*, Nd.39 | 1619 | 653 | RxPDO10*, Nd.19
508 | 1FC | TxPDO6*, Nd.60 | 1064 | 428 | RxPDO3*, Nd.40 | 1620 | 654 | RxPDO10*, Nd.20
509 | 1FD | TxPDO6*, Nd.61 | 1065 | 429 | RxPDO3*, Nd.41 | 1621 | 655 | RxPDO10*, Nd.21
510 | 1FE | TxPDO6*, Nd.62 | 1066 | 42A | RxPDO3*, Nd.42 | 1622 | 656 | RxPDO10*, Nd.22
511 | 1FF | TxPDO6*, Nd.63 | 1067 | 42B | RxPDO3*, Nd.43 | 1623 | 657 | RxPDO10*, Nd.23
513 | 201 | RxPDO1, DO, Nd.1 | 1068 | 42C | RxPDO3*, Nd.44 | 1624 | 658 | RxPDO10*, Nd.24
514 | 202 | RxPDO1, DO, Nd.2 | 1069 | 42D | RxPDO3*, Nd.45 | 1625 | 659 | RxPDO10*, Nd.25
515 | 203 | RxPDO1, DO, Nd.3 | 1070 | 42E | RxPDO3*, Nd.46 | 1626 | 65A | RxPDO10*, Nd.26
516 | 204 | RxPDO1, DO, Nd.4 | 1071 | 42F | RxPDO3*, Nd.47 | 1627 | 65B | RxPDO10*, Nd.27
517 | 205 | RxPDO1, DO, Nd.5 | 1072 | 430 | RxPDO3*, Nd.48 | 1628 | 65C | RxPDO10*, Nd.28
518 | 206 | RxPDO1, DO, Nd.6 | 1073 | 431 | RxPDO3*, Nd.49 | 1629 | 65D | RxPDO10*, Nd.29
519 | 207 | RxPDO1, DO, Nd.7 | 1074 | 432 | RxPDO3*, Nd.50 | 1630 | 65E | RxPDO10*, Nd.30
520 | 208 | RxPDO1, DO, Nd.8 | 1075 | 433 | RxPDO3*, Nd.51 | 1631 | 65F | RxPDO10*, Nd.31
521 | 209 | RxPDO1, DO, Nd.9 | 1076 | 434 | RxPDO3*, Nd.52 | 1632 | 660 | RxPDO10*, Nd.32
522 | 20A | RxPDO1, DO, Nd.10 | 1077 | 435 | RxPDO3*, Nd.53 | 1633 | 661 | RxPDO10*, Nd.33
523 | 20B | RxPDO1, DO, Nd.11 | 1078 | 436 | RxPDO3*, Nd.54 | 1634 | 662 | RxPDO10*, Nd.34
524 | 20C | RxPDO1, DO, Nd.12 | 1079 | 437 | RxPDO3*, Nd.55 | 1635 | 663 | RxPDO10*, Nd.35
525 | 20D | RxPDO1, DO, Nd.13 | 1080 | 438 | RxPDO3*, Nd.56 | 1636 | 664 | RxPDO10*, Nd.36
526 | 20E | RxPDO1, DO, Nd.14 | 1081 | 439 | RxPDO3*, Nd.57 | 1637 | 665 | RxPDO10*, Nd.37
527 | 20F | RxPDO1, DO, Nd.15 | 1082 | 43A | RxPDO3*, Nd.58 | 1638 | 666 | RxPDO10*, Nd.38
528 | 210 | RxPDO1, DO, Nd.16 | 1083 | 43B | RxPDO3*, Nd.59 | 1639 | 667 | RxPDO10*, Nd.39
529 | 211 | RxPDO1, DO, Nd.17 | 1084 | 43C | RxPDO3*, Nd.60 | 1640 | 668 | RxPDO10*, Nd.40
530 | 212 | RxPDO1, DO, Nd.18 | 1085 | 43D | RxPDO3*, Nd.61 | 1641 | 669 | RxPDO10*, Nd.41
531 | 213 | RxPDO1, DO, Nd.19 | 1086 | 43E | RxPDO3*, Nd.62 | 1642 | 66A | RxPDO10*, Nd.42
532 | 214 | RxPDO1, DO, Nd.20 | 1087 | 43F | RxPDO3*, Nd.63 | 1643 | 66B | RxPDO10*, Nd.43
533 | 215 | RxPDO1, DO, Nd.21 | 1089 | 441 | RxPDO8*, Nd.1 | 1644 | 66C | RxPDO10*, Nd.44
534 | 216 | RxPDO1, DO, Nd.22 | 1090 | 442 | RxPDO8*, Nd.2 | 1645 | 66D | RxPDO10*, Nd.45
535 | 217 | RxPDO1, DO, Nd.23 | 1091 | 443 | RxPDO8*, Nd.3 | 1646 | 66E | RxPDO10*, Nd.46
536 | 218 | RxPDO1, DO, Nd.24 | 1092 | 444 | RxPDO8*, Nd.4 | 1647 | 66F | RxPDO10*, Nd.47
537 | 219 | RxPDO1, DO, Nd.25 | 1093 | 445 | RxPDO8*, Nd.5 | 1648 | 670 | RxPDO10*, Nd.48
538 | 21A | RxPDO1, DO, Nd.26 | 1094 | 446 | RxPDO8*, Nd.6 | 1649 | 671 | RxPDO10*, Nd.49
539 | 21B | RxPDO1, DO, Nd.27 | 1095 | 447 | RxPDO8*, Nd.7 | 1650 | 672 | RxPDO10*, Nd.50
540 | 21C | RxPDO1, DO, Nd.28 | 1096 | 448 | RxPDO8*, Nd.8 | 1651 | 673 | RxPDO10*, Nd.51
541 | 21D | RxPDO1, DO, Nd.29 | 1097 | 449 | RxPDO8*, Nd.9 | 1652 | 674 | RxPDO10*, Nd.52
542 | 21E | RxPDO1, DO, Nd.30 | 1098 | 44A | RxPDO8*, Nd.10 | 1653 | 675 | RxPDO10*, Nd.53
543 | 21F | RxPDO1, DO, Nd.31 | 1099 | 44B | RxPDO8*, Nd.11 | 1654 | 676 | RxPDO10*, Nd.54
544 | 220 | RxPDO1, DO, Nd.32 | 1100 | 44C | RxPDO8*, Nd.12 | 1655 | 677 | RxPDO10*, Nd.55
545 | 221 | RxPDO1, DO, Nd.33 | 1101 | 44D | RxPDO8*, Nd.13 | 1656 | 678 | RxPDO10*, Nd.56
546 | 222 | RxPDO1, DO, Nd.34 | 1102 | 44E | RxPDO8*, Nd.14 | 1657 | 679 | RxPDO10*, Nd.57
547 | 223 | RxPDO1, DO, Nd.35 | 1103 | 44F | RxPDO8*, Nd.15 | 1658 | 67A | RxPDO10*, Nd.58
548 | 224 | RxPDO1, DO, Nd.36 | 1104 | 450 | RxPDO8*, Nd.16 | 1659 | 67B | RxPDO10*, Nd.59
549 | 225 | RxPDO1, DO, Nd.37 | 1105 | 451 | RxPDO8*, Nd.17 | 1660 | 67C | RxPDO10*, Nd.60
550 | 226 | RxPDO1, DO, Nd.38 | 1106 | 452 | RxPDO8*, Nd.18 | 1661 | 67D | RxPDO10*, Nd.61
551 | 227 | RxPDO1, DO, Nd.39 | 1107 | 453 | RxPDO8*, Nd.19 | 1662 | 67E | RxPDO10*, Nd.62
552 | 228 | RxPDO1, DO, Nd.40 | 1108 | 454 | RxPDO8*, Nd.20 | 1663 | 67F | RxPDO10*, Nd.63
553 | 229 | RxPDO1, DO, Nd.41 | 1109 | 455 | RxPDO8*, Nd.21 | 1665 | 681 | TxPDO5*, Nd.1
554 | 22A | RxPDO1, DO, Nd.42 | 1110 | 456 | RxPDO8*, Nd.22 | 1666 | 682 | TxPDO5*, Nd.2
555 | 22B | RxPDO1, DO, Nd.43 | 1111 | 457 | RxPDO8*, Nd.23 | 1667 | 683 | TxPDO5*, Nd.3
556 | 22C | RxPDO1, DO, Nd.44 | 1112 | 458 | RxPDO8*, Nd.24 | 1668 | 684 | TxPDO5*, Nd.4
557 | 22D | RxPDO1, DO, Nd.45 | 1113 | 459 | RxPDO8*, Nd.25 | 1669 | 685 | TxPDO5*, Nd.5
558 | 22E | RxPDO1, DO, Nd.46 | 1114 | 45A | RxPDO8*, Nd.26 | 1670 | 686 | TxPDO5*, Nd.6
559 | 22F | RxPDO1, DO, Nd.47 | 1115 | 45B | RxPDO8*, Nd.27 | 1671 | 687 | TxPDO5*, Nd.7
560 | 230 | RxPDO1, DO, Nd.48 | 1116 | 45C | RxPDO8*, Nd.28 | 1672 | 688 | TxPDO5*, Nd.8
561 | 231 | RxPDO1, DO, Nd.49 | 1117 | 45D | RxPDO8*, Nd.29 | 1673 | 689 | TxPDO5*, Nd.9
562 | 232 | RxPDO1, DO, Nd.50 | 1118 | 45E | RxPDO8*, Nd.30 | 1674 | 68A | TxPDO5*, Nd.10
563 | 233 | RxPDO1, DO, Nd.51 | 1119 | 45F | RxPDO8*, Nd.31 | 1675 | 68B | TxPDO5*, Nd.11
564 | 234 | RxPDO1, DO, Nd.52 | 1120 | 460 | RxPDO8*, Nd.32 | 1676 | 68C | TxPDO5*, Nd.12
565 | 235 | RxPDO1, DO, Nd.53 | 1121 | 461 | RxPDO8*, Nd.33 | 1677 | 68D | TxPDO5*, Nd.13
566 | 236 | RxPDO1, DO, Nd.54 | 1122 | 462 | RxPDO8*, Nd.34 | 1678 | 68E | TxPDO5*, Nd.14
567 | 237 | RxPDO1, DO, Nd.55 | 1123 | 463 | RxPDO8*, Nd.35 | 1679 | 68F | TxPDO5*, Nd.15
568 | 238 | RxPDO1, DO, Nd.56 | 1124 | 464 | RxPDO8*, Nd.36 | 1680 | 690 | TxPDO5*, Nd.16
569 | 239 | RxPDO1, DO, Nd.57 | 1125 | 465 | RxPDO8*, Nd.37 | 1681 | 691 | TxPDO5*, Nd.17
570 | 23A | RxPDO1, DO, Nd.58 | 1126 | 466 | RxPDO8*, Nd.38 | 1682 | 692 | TxPDO5*, Nd.18
571 | 23B | RxPDO1, DO, Nd.59 | 1127 | 467 | RxPDO8*, Nd.39 | 1683 | 693 | TxPDO5*, Nd.19
572 | 23C | RxPDO1, DO, Nd.60 | 1128 | 468 | RxPDO8*, Nd.40 | 1684 | 694 | TxPDO5*, Nd.20
573 | 23D | RxPDO1, DO, Nd.61 | 1129 | 469 | RxPDO8*, Nd.41 | 1685 | 695 | TxPDO5*, Nd.21
574 | 23E | RxPDO1, DO, Nd.62 | 1130 | 46A | RxPDO8*, Nd.42 | 1686 | 696 | TxPDO5*, Nd.22
575 | 23F | RxPDO1, DO, Nd.63 | 1131 | 46B | RxPDO8*, Nd.43 | 1687 | 697 | TxPDO5*, Nd.23
577 | 241 | RxPDO6*, Nd.1 | 1132 | 46C | RxPDO8*, Nd.44 | 1688 | 698 | TxPDO5*, Nd.24
578 | 242 | RxPDO6*, Nd.2 | 1133 | 46D | RxPDO8*, Nd.45 | 1689 | 699 | TxPDO5*, Nd.25
579 | 243 | RxPDO6*, Nd.3 | 1134 | 46E | RxPDO8*, Nd.46 | 1690 | 69A | TxPDO5*, Nd.26
580 | 244 | RxPDO6*, Nd.4 | 1135 | 46F | RxPDO8*, Nd.47 | 1691 | 69B | TxPDO5*, Nd.27
581 | 245 | RxPDO6*, Nd.5 | 1136 | 470 | RxPDO8*, Nd.48 | 1692 | 69C | TxPDO5*, Nd.28
582 | 246 | RxPDO6*, Nd.6 | 1137 | 471 | RxPDO8*, Nd.49 | 1693 | 69D | TxPDO5*, Nd.29
583 | 247 | RxPDO6*, Nd.7 | 1138 | 472 | RxPDO8*, Nd.50 | 1694 | 69E | TxPDO5*, Nd.30
584 | 248 | RxPDO6*, Nd.8 | 1139 | 473 | RxPDO8*, Nd.51 | 1695 | 69F | TxPDO5*, Nd.31
585 | 249 | RxPDO6*, Nd.9 | 1140 | 474 | RxPDO8*, Nd.52 | 1696 | 6A0 | TxPDO5*, Nd.32
586 | 24A | RxPDO6*, Nd.10 | 1141 | 475 | RxPDO8*, Nd.53 | 1697 | 6A1 | TxPDO5*, Nd.33
587 | 24B | RxPDO6*, Nd.11 | 1142 | 476 | RxPDO8*, Nd.54 | 1698 | 6A2 | TxPDO5*, Nd.34
588 | 24C | RxPDO6*, Nd.12 | 1143 | 477 | RxPDO8*, Nd.55 | 1699 | 6A3 | TxPDO5*, Nd.35
589 | 24D | RxPDO6*, Nd.13 | 1144 | 478 | RxPDO8*, Nd.56 | 1700 | 6A4 | TxPDO5*, Nd.36
590 | 24E | RxPDO6*, Nd.14 | 1145 | 479 | RxPDO8*, Nd.57 | 1701 | 6A5 | TxPDO5*, Nd.37
591 | 24F | RxPDO6*, Nd.15 | 1146 | 47A | RxPDO8*, Nd.58 | 1702 | 6A6 | TxPDO5*, Nd.38
592 | 250 | RxPDO6*, Nd.16 | 1147 | 47B | RxPDO8*, Nd.59 | 1703 | 6A7 | TxPDO5*, Nd.39
593 | 251 | RxPDO6*, Nd.17 | 1148 | 47C | RxPDO8*, Nd.60 | 1704 | 6A8 | TxPDO5*, Nd.40
594 | 252 | RxPDO6*, Nd.18 | 1149 | 47D | RxPDO8*, Nd.61 | 1705 | 6A9 | TxPDO5*, Nd.41
595 | 253 | RxPDO6*, Nd.19 | 1150 | 47E | RxPDO8*, Nd.62 | 1706 | 6AA | TxPDO5*, Nd.42
596 | 254 | RxPDO6*, Nd.20 | 1151 | 47F | RxPDO8*, Nd.63 | 1707 | 6AB | TxPDO5*, Nd.43
597 | 255 | RxPDO6*, Nd.21 | 1153 | 481 | TxPDO4*, Nd.1 | 1708 | 6AC | TxPDO5*, Nd.44
598 | 256 | RxPDO6*, Nd.22 | 1154 | 482 | TxPDO4*, Nd.2 | 1709 | 6AD | TxPDO5*, Nd.45
599 | 257 | RxPDO6*, Nd.23 | 1155 | 483 | TxPDO4*, Nd.3 | 1710 | 6AE | TxPDO5*, Nd.46
600 | 258 | RxPDO6*, Nd.24 | 1156 | 484 | TxPDO4*, Nd.4 | 1711 | 6AF | TxPDO5*, Nd.47
601 | 259 | RxPDO6*, Nd.25 | 1157 | 485 | TxPDO4*, Nd.5 | 1712 | 6B0 | TxPDO5*, Nd.48
602 | 25A | RxPDO6*, Nd.26 | 1158 | 486 | TxPDO4*, Nd.6 | 1713 | 6B1 | TxPDO5*, Nd.49
603 | 25B | RxPDO6*, Nd.27 | 1159 | 487 | TxPDO4*, Nd.7 | 1714 | 6B2 | TxPDO5*, Nd.50
604 | 25C | RxPDO6*, Nd.28 | 1160 | 488 | TxPDO4*, Nd.8 | 1715 | 6B3 | TxPDO5*, Nd.51
605 | 25D | RxPDO6*, Nd.29 | 1161 | 489 | TxPDO4*, Nd.9 | 1716 | 6B4 | TxPDO5*, Nd.52
606 | 25E | RxPDO6*, Nd.30 | 1162 | 48A | TxPDO4*, Nd.10 | 1717 | 6B5 | TxPDO5*, Nd.53
607 | 25F | RxPDO6*, Nd.31 | 1163 | 48B | TxPDO4*, Nd.11 | 1718 | 6B6 | TxPDO5*, Nd.54
608 | 260 | RxPDO6*, Nd.32 | 1164 | 48C | TxPDO4*, Nd.12 | 1719 | 6B7 | TxPDO5*, Nd.55
609 | 261 | RxPDO6*, Nd.33 | 1165 | 48D | TxPDO4*, Nd.13 | 1720 | 6B8 | TxPDO5*, Nd.56
610 | 262 | RxPDO6*, Nd.34 | 1166 | 48E | TxPDO4*, Nd.14 | 1721 | 6B9 | TxPDO5*, Nd.57
611 | 263 | RxPDO6*, Nd.35 | 1167 | 48F | TxPDO4*, Nd.15 | 1722 | 6BA | TxPDO5*, Nd.58
612 | 264 | RxPDO6*, Nd.36 | 1168 | 490 | TxPDO4*, Nd.16 | 1723 | 6BB | TxPDO5*, Nd.59
774 | 306 | RxPDO2, AO, Nd.6 | 1329 | 531 | RxPDO4*, Nd.49 | 1885 | 75D | RxPDO11*, Nd.29
775 | 307 | RxPDO2, AO, Nd.7 | 1330 | 532 | RxPDO4*, Nd.50 | 1886 | 75E | RxPDO11*, Nd.30
776 | 308 | RxPDO2, AO, Nd.8 | 1331 | 533 | RxPDO4*, Nd.51 | 1887 | 75F | RxPDO11*, Nd.31
777 | 309 | RxPDO2, AO, Nd.9 | 1332 | 534 | RxPDO4*, Nd.52 | 1888 | 760 | RxPDO11*, Nd.32
778 | 30A | RxPDO2, AO, Nd.10 | 1333 | 535 | RxPDO4*, Nd.53 | 1889 | 761 | RxPDO11*, Nd.33
779 | 30B | RxPDO2, AO, Nd.11 | 1334 | 536 | RxPDO4*, Nd.54 | 1890 | 762 | RxPDO11*, Nd.34
780 | 30C | RxPDO2, AO, Nd.12 | 1335 | 537 | RxPDO4*, Nd.55 | 1891 | 763 | RxPDO11*, Nd.35
781 | 30D | RxPDO2, AO, Nd.13 | 1336 | 538 | RxPDO4*, Nd.56 | 1892 | 764 | RxPDO11*, Nd.36
782 | 30E | RxPDO2, AO, Nd.14 | 1337 | 539 | RxPDO4*, Nd.57 | 1893 | 765 | RxPDO11*, Nd.37
783 | 30F | RxPDO2, AO, Nd.15 | 1338 | 53A | RxPDO4*, Nd.58 | 1894 | 766 | RxPDO11*, Nd.38
784 | 310 | RxPDO2, AO, Nd.16 | 1339 | 53B | RxPDO4*, Nd.59 | 1895 | 767 | RxPDO11*, Nd.39
785 | 311 | RxPDO2, AO, Nd.17 | 1340 | 53C | RxPDO4*, Nd.60 | 1896 | 768 | RxPDO11*, Nd.40
786 | 312 | RxPDO2, AO, Nd.18 | 1341 | 53D | RxPDO4*, Nd.61 | 1897 | 769 | RxPDO11*, Nd.41
787 | 313 | RxPDO2, AO, Nd.19 | 1342 | 53E | RxPDO4*, Nd.62 | 1898 | 76A | RxPDO11*, Nd.42
788 | 314 | RxPDO2, AO, Nd.20 | 1343 | 53F | RxPDO4*, Nd.63 | 1899 | 76B | RxPDO11*, Nd.43
789 | 315 | RxPDO2, AO, Nd.21 | 1345 | 541 | RxPDO9*, Nd.1 | 1900 | 76C | RxPDO11*, Nd.44
790 | 316 | RxPDO2, AO, Nd.22 | 1346 | 542 | RxPDO9*, Nd.2 | 1901 | 76D | RxPDO11*, Nd.45
791 | 317 | RxPDO2, AO, Nd.23 | 1347 | 543 | RxPDO9*, Nd.3 | 1902 | 76E | RxPDO11*, Nd.46
792 | 318 | RxPDO2, AO, Nd.24 | 1348 | 544 | RxPDO9*, Nd.4 | 1903 | 76F | RxPDO11*, Nd.47
793 | 319 | RxPDO2, AO, Nd.25 | 1349 | 545 | RxPDO9*, Nd.5 | 1904 | 770 | RxPDO11*, Nd.48
794 | 31A | RxPDO2, AO, Nd.26 | 1350 | 546 | RxPDO9*, Nd.6 | 1905 | 771 | RxPDO11*, Nd.49
795 | 31B | RxPDO2, AO, Nd.27 | 1351 | 547 | RxPDO9*, Nd.7 | 1906 | 772 | RxPDO11*, Nd.50
796 | 31C | RxPDO2, AO, Nd.28 | 1352 | 548 | RxPDO9*, Nd.8 | 1907 | 773 | RxPDO11*, Nd.51
797 | 31D | RxPDO2, AO, Nd.29 | 1353 | 549 | RxPDO9*, Nd.9 | 1908 | 774 | RxPDO11*, Nd.52
798 | 31E | RxPDO2, AO, Nd.30 | 1354 | 54A | RxPDO9*, Nd.10 | 1909 | 775 | RxPDO11*, Nd.53
799 | 31F | RxPDO2, AO, Nd.31 | 1355 | 54B | RxPDO9*, Nd.11 | 1910 | 776 | RxPDO11*, Nd.54
800 | 320 | RxPDO2, AO, Nd.32 | 1356 | 54C | RxPDO9*, Nd.12 | 1911 | 777 | RxPDO11*, Nd.55
801 | 321 | RxPDO2, AO, Nd.33 | 1357 | 54D | RxPDO9*, Nd.13 | 1912 | 778 | RxPDO11*, Nd.56
802 | 322 | RxPDO2, AO, Nd.34 | 1358 | 54E | RxPDO9*, Nd.14 | 1913 | 779 | RxPDO11*, Nd.57
803 | 323 | RxPDO2, AO, Nd.35 | 1359 | 54F | RxPDO9*, Nd.15 | 1914 | 77A | RxPDO11*, Nd.58
804 | 324 | RxPDO2, AO, Nd.36 | 1360 | 550 | RxPDO9*, Nd.16 | 1915 | 77B | RxPDO11*, Nd.59
805 | 325 | RxPDO2, AO, Nd.37 | 1361 | 551 | RxPDO9*, Nd.17 | 1916 | 77C | RxPDO11*, Nd.60
806 | 326 | RxPDO2, AO, Nd.38 | 1362 | 552 | RxPDO9*, Nd.18 | 1917 | 77D | RxPDO11*, Nd.61
807 | 327 | RxPDO2, AO, Nd.39 | 1363 | 553 | RxPDO9*, Nd.19 | 1918 | 77E | RxPDO11*, Nd.62
808 | 328 | RxPDO2, AO, Nd.40 | 1364 | 554 | RxPDO9*, Nd.20 | 1919 | 77F | RxPDO11*, Nd.63
809 | 329 | RxPDO2, AO, Nd.41 | 1365 | 555 | RxPDO9*, Nd.21 | 1921 | 781 | RxPDO5*, Nd.1
810 | 32A | RxPDO2, AO, Nd.42 | 1366 | 556 | RxPDO9*, Nd.22 | 1922 | 782 | RxPDO5*, Nd.2
811 | 32B | RxPDO2, AO, Nd.43 | 1367 | 557 | RxPDO9*, Nd.23 | 1923 | 783 | RxPDO5*, Nd.3
812 | 32C | RxPDO2, AO, Nd.44 | 1368 | 558 | RxPDO9*, Nd.24 | 1924 | 784 | RxPDO5*, Nd.4
813 | 32D | RxPDO2, AO, Nd.45 | 1369 | 559 | RxPDO9*, Nd.25 | 1925 | 785 | RxPDO5*, Nd.5
814 | 32E | RxPDO2, AO, Nd.46 | 1370 | 55A | RxPDO9*, Nd.26 | 1926 | 786 | RxPDO5*, Nd.6
815 | 32F | RxPDO2, AO, Nd.47 | 1371 | 55B | RxPDO9*, Nd.27 | 1927 | 787 | RxPDO5*, Nd.7
816 | 330 | RxPDO2, AO, Nd.48 | 1372 | 55C | RxPDO9*, Nd.28 | 1928 | 788 | RxPDO5*, Nd.8
817 | 331 | RxPDO2, AO, Nd.49 | 1373 | 55D | RxPDO9*, Nd.29 | 1929 | 789 | RxPDO5*, Nd.9
818 | 332 | RxPDO2, AO, Nd.50 | 1374 | 55E | RxPDO9*, Nd.30 | 1930 | 78A | RxPDO5*, Nd.10
819 | 333 | RxPDO2, AO, Nd.51 | 1375 | 55F | RxPDO9*, Nd.31 | 1931 | 78B | RxPDO5*, Nd.11
820 | 334 | RxPDO2, AO, Nd.52 | 1376 | 560 | RxPDO9*, Nd.32 | 1932 | 78C | RxPDO5*, Nd.12
821 | 335 | RxPDO2, AO, Nd.53 | 1377 | 561 | RxPDO9*, Nd.33 | 1933 | 78D | RxPDO5*, Nd.13
822 | 336 | RxPDO2, AO, Nd.54 | 1378 | 562 | RxPDO9*, Nd.34 | 1934 | 78E | RxPDO5*, Nd.14
823 | 337 | RxPDO2, AO, Nd.55 | 1379 | 563 | RxPDO9*, Nd.35 | 1935 | 78F | RxPDO5*, Nd.15
824 | 338 | RxPDO2, AO, Nd.56 | 1380 | 564 | RxPDO9*, Nd.36 | 1936 | 790 | RxPDO5*, Nd.16
825 | 339 | RxPDO2, AO, Nd.57 | 1381 | 565 | RxPDO9*, Nd.37 | 1937 | 791 | RxPDO5*, Nd.17
826 | 33A | RxPDO2, AO, Nd.58 | 1382 | 566 | RxPDO9*, Nd.38 | 1938 | 792 | RxPDO5*, Nd.18
827 | 33B | RxPDO2, AO, Nd.59 | 1383 | 567 | RxPDO9*, Nd.39 | 1939 | 793 | RxPDO5*, Nd.19
828 | 33C | RxPDO2, AO, Nd.60 | 1384 | 568 | RxPDO9*, Nd.40 | 1940 | 794 | RxPDO5*, Nd.20
829 | 33D | RxPDO2, AO, Nd.61 | 1385 | 569 | RxPDO9*, Nd.41 | 1941 | 795 | RxPDO5*, Nd.21
830 | 33E | RxPDO2, AO, Nd.62 | 1386 | 56A | RxPDO9*, Nd.42 | 1942 | 796 | RxPDO5*, Nd.22
831 | 33F | RxPDO2, AO, Nd.63 | 1387 | 56B | RxPDO9*, Nd.43 | 1943 | 797 | RxPDO5*, Nd.23
833 | 341 | RxPDO7*, Nd.1 | 1388 | 56C | RxPDO9*, Nd.44 | 1944 | 798 | RxPDO5*, Nd.24
834 | 342 | RxPDO7*, Nd.2 | 1389 | 56D | RxPDO9*, Nd.45 | 1945 | 799 | RxPDO5*, Nd.25
835 | 343 | RxPDO7*, Nd.3 | 1390 | 56E | RxPDO9*, Nd.46 | 1946 | 79A | RxPDO5*, Nd.26
836 | 344 | RxPDO7*, Nd.4 | 1391 | 56F | RxPDO9*, Nd.47 | 1947 | 79B | RxPDO5*, Nd.27
837 | 345 | RxPDO7*, Nd.5 | 1392 | 570 | RxPDO9*, Nd.48 | 1948 | 79C | RxPDO5*, Nd.28
838 | 346 | RxPDO7*, Nd.6 | 1393 | 571 | RxPDO9*, Nd.49 | 1949 | 79D | RxPDO5*, Nd.29
839 | 347 | RxPDO7*, Nd.7 | 1394 | 572 | RxPDO9*, Nd.50 | 1950 | 79E | RxPDO5*, Nd.30
840 | 348 | RxPDO7*, Nd.8 | 1395 | 573 | RxPDO9*, Nd.51 | 1951 | 79F | RxPDO5*, Nd.31
841 | 349 | RxPDO7*, Nd.9 | 1396 | 574 | RxPDO9*, Nd.52 | 1952 | 7A0 | RxPDO5*, Nd.32
842 | 34A | RxPDO7*, Nd.10 | 1397 | 575 | RxPDO9*, Nd.53 | 1953 | 7A1 | RxPDO5*, Nd.33
843 | 34B | RxPDO7*, Nd.11 | 1398 | 576 | RxPDO9*, Nd.54 | 1954 | 7A2 | RxPDO5*, Nd.34
844 | 34C | RxPDO7*, Nd.12 | 1399 | 577 | RxPDO9*, Nd.55 | 1955 | 7A3 | RxPDO5*, Nd.35
845 | 34D | RxPDO7*, Nd.13 | 1400 | 578 | RxPDO9*, Nd.56 | 1956 | 7A4 | RxPDO5*, Nd.36
846 | 34E | RxPDO7*, Nd.14 | 1401 | 579 | RxPDO9*, Nd.57 | 1957 | 7A5 | RxPDO5*, Nd.37
847 | 34F | RxPDO7*, Nd.15 | 1402 | 57A | RxPDO9*, Nd.58 | 1958 | 7A6 | RxPDO5*, Nd.38
848 | 350 | RxPDO7*, Nd.16 | 1403 | 57B | RxPDO9*, Nd.59 | 1959 | 7A7 | RxPDO5*, Nd.39
849 | 351 | RxPDO7*, Nd.17 | 1404 | 57C | RxPDO9*, Nd.60 | 1960 | 7A8 | RxPDO5*, Nd.40
850 | 352 | RxPDO7*, Nd.18 | 1405 | 57D | RxPDO9*, Nd.61 | 1961 | 7A9 | RxPDO5*, Nd.41
851 | 353 | RxPDO7*, Nd.19 | 1406 | 57E | RxPDO9*, Nd.62 | 1962 | 7AA | RxPDO5*, Nd.42
852 | 354 | RxPDO7*, Nd.20 | 1407 | 57F | RxPDO9*, Nd.63 | 1963 | 7AB | RxPDO5*, Nd.43
853 | 355 | RxPDO7*, Nd.21 | 1409 | 581 | SDO Tx Nd.1 | 1964 | 7AC | RxPDO5*, Nd.44
854 | 356 | RxPDO7*, Nd.22 | 1410 | 582 | SDO Tx Nd.2 | 1965 | 7AD | RxPDO5*, Nd.45
855 | 357 | RxPDO7*, Nd.23 | 1411 | 583 | SDO Tx Nd.3 | 1966 | 7AE | RxPDO5*, Nd.46
856 | 358 | RxPDO7*, Nd.24 | 1412 | 584 | SDO Tx Nd.4 | 1967 | 7AF | RxPDO5*, Nd.47
857 | 359 | RxPDO7*, Nd.25 | 1413 | 585 | SDO Tx Nd.5 | 1968 | 7B0 | RxPDO5*, Nd.48
858 | 35A | RxPDO7*, Nd.26 | 1414 | 586 | SDO Tx Nd.6 | 1969 | 7B1 | RxPDO5*, Nd.49
859 | 35B | RxPDO7*, Nd.27 | 1415 | 587 | SDO Tx Nd.7 | 1970 | 7B2 | RxPDO5*, Nd.50
860 | 35C | RxPDO7*, Nd.28 | 1416 | 588 | SDO Tx Nd.8 | 1971 | 7B3 | RxPDO5*, Nd.51
861 | 35D | RxPDO7*, Nd.29 | 1417 | 589 | SDO Tx Nd.9 | 1972 | 7B4 | RxPDO5*, Nd.52
862 | 35E | RxPDO7*, Nd.30 | 1418 | 58A | SDO Tx Nd.10 | 1973 | 7B5 | RxPDO5*, Nd.53
863 | 35F | RxPDO7*, Nd.31 | 1419 | 58B | SDO Tx Nd.11 | 1974 | 7B6 | RxPDO5*, Nd.54
864 | 360 | RxPDO7*, Nd.32 | 1420 | 58C | SDO Tx Nd.12 | 1975 | 7B7 | RxPDO5*, Nd.55
865 | 361 | RxPDO7*, Nd.33 | 1421 | 58D | SDO Tx Nd.13 | 1976 | 7B8 | RxPDO5*, Nd.56
866 | 362 | RxPDO7*, Nd.34 | 1422 | 58E | SDO Tx Nd.14 | 1977 | 7B9 | RxPDO5*, Nd.57
867 | 363 | RxPDO7*, Nd.35 | 1423 | 58F | SDO Tx Nd.15 | 1978 | 7BA | RxPDO5*, Nd.58
868 | 364 | RxPDO7*, Nd.36 | 1424 | 590 | SDO Tx Nd.16 | 1979 | 7BB | RxPDO5*, Nd.59
869 | 365 | RxPDO7*, Nd.37 | 1425 | 591 | SDO Tx Nd.17 | 1980 | 7BC | RxPDO5*, Nd.60
870 | 366 | RxPDO7*, Nd.38 | 1426 | 592 | SDO Tx Nd.18 | 1981 | 7BD | RxPDO5*, Nd.61
871 | 367 | RxPDO7*, Nd.39 | 1427 | 593 | SDO Tx Nd.19 | 1982 | 7BE | RxPDO5*, Nd.62
872 | 368 | RxPDO7*, Nd.40 | 1428 | 594 | SDO Tx Nd.20 | 1983 | 7BF | RxPDO5*, Nd.63
873 | 369 | RxPDO7*, Nd.41 | 1429 | 595 | SDO Tx Nd.21 |  |  |


TwinCAT Ethernet Driver Installation

TwinCAT System Manager: Reference

TwinCAT Ethernet Treiber - Installation

Der auf Intel 8255x basierende Netzwerkadapter (NIC) sollte nach dem Einbau automatisch von Windows XP / 2000 gefunden werden. Nach der automatischen Erkennung, muss der Microsoft-spezifische Treiber für dieses Gerät durch einen Beckhoff-eigenen ausgetauscht werden. Dazu muss unter 'Netzwerkverbindungen' (z.B. über die Systemsteuerung) der Dialog 'Eigenschaften' der Netzwerkverbindung geöffnet werden. Falls im System mehr als ein Netzwerkadapter installiert ist, ist der Adapter auszuwählen, welcher für Echtzeit-Ethernet vorgesehen ist.

Folgende Dialoge zeigen die notwendigen Schritte zur Installation unter Windows XP Professional.

Der Dialog 'Eigenschaften' erscheint. Bitte betätigen Sie hier die Schaltfläche 'Konfigurieren...'.

Bitte wählen Sie den Karteireiter 'Treiber' aus, und betätigen Sie dort die 'Aktualisieren...' Schaltfläche.

Der 'Hardwareupdate-Assistent' erscheint. Hier bitte 'Software von einer Liste oder bestimmte Quelle installieren' selektieren und auf 'Weiter >' klicken...

Bitte 'Nicht suchen, sondern den zu installierenden Treiber selbst wählen' selektieren und auf 'Weiter >' klicken.

Wählen sie den 'TwinCAT-Intel PCI Ethernet Adapter' und klicken auf 'Weiter >'.

Nun erscheint eine Warnung, dass der ausgewählte Treiber nicht von Microsoft "digital signiert" ist. Quittieren sie die Abfrage mit 'Installation fortsetzen'.

Die Treiberinstallation ist nun erledigt, nur der Protokolltreiber muss noch installiert werden. Bitte die Schaltfläche 'Fertig stellen' betätigen.

Bitte öffnen sie erneut den Dialog 'Eigenschaften' der Echtzeit-Ethernet Netzwerkverbindung. Der neue Netzwerkadapter sollte nun hier zur Auswahl angeboten werden, wie im nachfolgenden Dialog gezeigt.

Bitte im oberen Dialog die Schaltfläche 'Installieren...' betätigen und im dann erscheinenden und nachfolgend gezeigten Dialog 'Protokoll' auswählen und 'Hinzufügen...' betätigen.

Hier bitte 'Beckhoff' und 'TwinCAT Ethernet Protocol' auswählen. Erscheint es nicht in der Liste, betätigen sie die Schaltfläche "Datenträger..." und wechseln in das \Windows\Inf (Windows XP) bzw. \WinNt\Inf (Windows 2000) Verzeichnis. Sollte das Verzeichnis nicht sichtbar sein, muss im Explorer unter Extras/Ordneroptionen/Ansicht "Alle Dateien und Ordner anzeigen" angewählt werden. Nach Auswahl des Verzeichnisses (egal welche Datei darin selektiert ist) sollte das Beckhoff / TwinCAT Ethernet Protocol nun aufgeführt sein.

Das neue Protokoll sollte nun in der Liste der verwendeten Elemente erscheinen.

Der "Quality of Service" (QoS) Paket Abwicklerfilter kann deaktiviert werden, denn er hat keine Funktion in Verbindung mit dem TwinCAT Treiber.

Nun sind alle erforderlichen Schritte durchgeführt worden. Nur das "TwinCAT Ethernet Protocol" ist beim ersten Mal nicht automatisch gestartet. Man hat hier nun die Möglichkeit, den PC zu rebooten oder das Protokoll manuell zu starten (nur notwendig beim allerersten Mal). Um das Protokoll manuell zu starten (z.B. per 'Ausführen...' von der Kommandozeile nach der Eingabe von 'cmd'), ist im Erscheinenden Bildschirm "net start TcEther" wie unten gezeigt einzugeben und mit 'Enter' zu übernehmen.

Nach diesen Schritten sollte der TwinCAT System Manager den Echtzeit-Ethernet Adapter als "E/A - Gerät" finden.


Einführung von TwinCAT-Echtzeit-Ethernet

Ethernet Echtzeit-Kommunikation

Ethernet meistert die nächste Hürde als „Feldbus“ in der Beckhoff TwinCAT-Steuerung. Neben der Erfüllung hoher Echtzeit-Anforderungen ermöglicht es auch den Einsatz von Standardkomponenten „in derselben Leitung“. Der BK9000 Ethernet-Buskoppler und der AX2000-B900 Servoverstärker besitzen als erste Feldbuskomponenten Echtzeitfähigkeit. Neue Netzwerkvariablen beschleunigen den Echtzeit-Datenaustausch zwischen den einzelnen Controllern; eine Implementierung ist so einfach wie der Anschluss eines weiteren digitalen Eingangs.

Beckhoff Ethernet-Produkte sind seit vielen Jahre bewährt und erfreuen sich immer größerer Beliebtheit. Die Vorteile des Einsatzes alltäglicher Ethernet Standardlösungen in Industrieanlagen liegen auf der Hand:
- Einsatz von Standard-Hardwarekomponenten (z.B. marktüblicher Standard-Switch)
- Standardprotokolle können eingesetzt werden
- Die Datenübertragungsraten sind im Vergleich zu anderen Netzwerken sehr hoch
- Das Netzwerk kann einfach über das Internet mit dem Rest der Welt verbunden werden
- Fernwartung und –diagnose

Kommunikation über Ethernet ist in der industriellen Automation bereits weitgehend akzeptiert; viele Gruppen und Ausschüsse beschäftigen sich mit diesem Thema. Durch die fehlende Echtzeitfähigkeit war der Einsatz von Ethernet im klassischen Feldbusbereich jedoch eingeschränkt. Es gibt einige Techniken, die eine gewisse Echtzeitfähigkeit ermöglichen. Diese basieren aber auf selbst entwickelten Systemen, die nicht parallel auf Standardkomponenten und Protokolle zugreifen können.
- Der Begriff „Echtzeitfähigkeit“ wird in der Steuerungstheorie unterschiedlich interpretiert.
- Was „Echtzeit“ ist, hängt in hohem Maße von den Anforderungen der jeweiligen Anwendung ab, ebenso wie von den Regelkreisen, in denen die Automatisierungskomponenten eingesetzt werden. Auf Grundlage der Automatisierungstechnik und vor dem Hintergrund dessen, was Feldbusspezialist Beckhoff anbietet, kann man eine grobe Einteilung vornehmen:
- Die höchsten Anforderungen betreffen Zykluszeiten von ca. 50 µs und einen zulässigen Jitter (Abweichungen von der gewünschten Zykluszeit) von ca. 10 µs. Noch höhere Anforderungen werden derzeitig noch eher mit spezieller Hardware realisiert als direkt mit Feldbussen. Die Anforderungen an Zykluszeiten für positionsgesteuerte Antriebe bewegen sich im Allgemeinen im Millisekundenbereich (1-4 ms), die Jitterzeiten sollten unter 20 µs liegen. Reine SPS-Anwendungen erfordern oft Zykluszeiten von mindestens 10 ms; die Jitterzeiten können hier also auch entsprechend länger sein und sich im Millisekundenbereich bewegen. Der Datenaustausch zwischen Controller und Überwachungssystem kann oft mit Jitterzeiten im Sekundenbereich zufriedenstellend realisiert werden. Er muss hier nicht unbedingt zyklisch konfiguriert werden, sondern kann ereignisgesteuert sein.

Ein weiterer wichtiger Punkt ist die Fernwartung und –diagnose. Hier sind die Zyklus- und Jitterzeiten weniger wichtig als die Reaktionszeiten und die generelle Möglichkeit, über Grenzen eines Netzwerks hinaus zu kommunizieren. TwinCAT-Automatisierungssoftware mit Echtzeit-Ethernet heißt, dass alle oben erwähnten Kommunikationsanforderungen mit derselben Technologie erfüllt werden, sowohl hinsichtlich der eingesetzten Geräte, als auch der genutzten Protokolle.

Funktionsprinzip

Der Treiber der TwinCAT-Netzwerkkarte ist so in das System eingebunden, dass er als Betriebssystem konformer Netzwerktreiber und zusätzlich als TwinCAT Feldbuskarte erscheint. Auf Sendeseite wird über interne Priorisierung und Puffer sichergestellt, dass anstehende Ethernet-Frames des Echtzeitsystems immer eine freie Sendeleitung vorfinden. Ethernet-Frames des Betriebssystems werden erst später verschickt, in den „Lücken“, wenn genügend Zeit ist.
Auf Empfangsseite werden alle empfangenen Ethernet-Frames vom TwinCAT I/O System überprüft und die Echtzeit relevanten herausgefiltert. Alle anderen Frames werden nach Überprüfung an das Betriebssystem übergeben, ohne Kontext zum Echtzeitsystem.

Durch handelsübliche Switches, die alle einen Vollduplexbetrieb bei 100 Mbaud unterstützen, werden die übertragenen Frames mit konstanter Verzögerung an den Empfänger weitergeleitet. Ein Switch stellt sicher, dass Kollisionen vermieden werden und nur Verzögerungen auftreten. Daher muss in einem zyklischen Steuerungssystem nur gewährleistet sein, dass alle wichtigen Eingangsinformationen angekommen sind, bevor der nächste Zyklus startet. Wann oder in welcher Reihenfolge sie ankommen spielt dabei keine Rolle.
Voraussetzung für eine Echtzeit-Ethernetkommunikation ist, dass die Anzahl von Teilnehmern oder die Framerate entsprechend der erforderlichen Zykluszeit beschränkt ist.

Das Bild oben zeigt das Prinzip, wie der original Windows-Protokollstack (TCP/IP und UDP/IP) parallel zum TwinCAT-Echtzeitethernet benutzt wird. Dieses Prinzip bezeichnen wir als „Y-Treiber“-Architektur.

Betriebsarten/Protokolle

Im Gegensatz zu den weit verbreiteten TCP/IP- und UDP/IP-Protokollen, die weltweit für die Zustellung individueller Ethernet-Frames verantwortlich sind, geht Echtzeitkommunikation nie über das lokale Subnetz hinaus. Der Overhead aus TCP/IP und UDP/IP ist unnötig, Geräte können direkt über die Hardware-Adressen (MAC-ID) der Netzwerkkarten adressiert werden. Die Struktur der Ethernet Frames stellt sicher, dass eine Koexistenz mit anderen Protokollen immer möglich ist; auch „Echtzeit-Frames“ können mit TCP oder UDP übertragen werden, wenn sie ihr eigenes Subnetz verlassen müssen.
Für den Einsatz in der Steuerungstechnik wurde eine Reihe von Betriebsarten definiert. Sie haben unterschiedliche Kommunikationsaufgaben und können natürlich auch simultan eingesetzt werden.

1.) Master - Slave Prozessdatenkommunikation

Zyklische oder ereignisgesteuerte Übertragung von I/O-Daten – die typische Anwendung moderner Feldbusse

2.) Publisher - Subscriber Prozessdatenkommunikation

Prozessdaten nach dem Publisher-Subscriber-Modell (auch Netzwerkvariablen genannt) werden für die reguläre Kommunikation zwischen Controllern verwendet, wenn ein feststehendes Master-Slave-Verhältnis unangemessen wäre. Der Publisher sendet Informationen wahllos ohne Zielangabe aus. Die Kommunikation wird nur vom Subscriber überwacht. Gegenseitige Verhältnisse zwischen Publishern und Subscribern erlauben bidirektionale und multidirektionale Kommunikation. Der Publisher kann so konfiguriert werden, dass Daten per Broadcast, Multicast oder Unicast gesendet werden. Multicast verringert die Belastung der Eingangswarteschlangen der Netzwerkgeräte, da die Meldungen sofort bei Ankunft am Ethernetcontroller bewertet werden. Nur bei Unicast kann der Switch (ohne umfangreiche Konfiguration) parallele Kommunikationspfade öffnen und die nutzbare Bandweite erhöhen.

3.) Datenkommunikation nach Bedarf

Diese Art der Kommunikation wird im TwinCAT-System durch ADS-Kommunikation ermöglicht. Sie sendet Kommunikationsstrings „bei Bedarf“ von einem Gerät zum anderen. So werden Dienste ausgeführt und Parameter ausgetauscht.

Dank der gewählten Protokollstruktur können andere Betriebsarten oder Kommunikationsprofile zukünftig leicht integriert werden und problemlos mit den vorhandenen Betriebsarten koexistieren.

Kompatible Komponenten

Die ersten Beckhoff-Komponenten, die für die Echtzeit-Ethernetanwendung erweitert wurden, sind der BK9000 -Ethernet Buskoppler und der AX2000-B900-Servoverstärker. Mit diesen beiden Komponenten kann fast der ganze Bereich an Industriesignalen und –anwendungen abgedeckt werden.
Alle TwinCAT-Controller (ab Version 2.9) sind kompatibel und können sowohl als „Feldbusmaster“ als auch bei Kommunikationen mit Netzwerkvariabeln einsetzt werden. TwinCAT Echtzeit-Ethernet unterstützt alle Controller (Netzwerkadapter) der Intel 8255x-Familie. Das sind die meistverbreiteten Ethernetcontroller. Sie sind Komponenten des aktuellen Intel Chip-Sets, das bereits eine kompatible Netzwerkverbindung enthält. Angesichts der großen Popularität der Intelfamilie und der Tatsache, dass sie sogar mit Gigabit Ethernet kompatibel ist (Intel 8254x-Familie), kann eine Unterstützung anderer Ethernetcontroller zukünftig zwar in Betracht gezogen werden, ist jedoch nicht unbedingt notwendig. Der neue Embedded-PC CX1000 Kleinsteuerung wird natürlich immer mit einem entsprechenden Ethernetcontroller kombiniert.

Leistung

Eine Beurteilung der Leistung eines Feldbussystems ausschließlich auf Basis der Baudrate wäre zweifellos zu einseitig, da andere wichtige Kommunikationsparameter wie z.B. Protokolleffizienz, Reaktionszeit, Jitter, minimale Telegrammlänge, Pausen usw. einfach ignoriert würden. Trotzdem erlaubt 100 MBaud eine bedeutend schnellere Datenübertragung als derzeit in Feldbusumgebungen üblich. Zudem bieten die eingesetzten Protokolle, insbesondere bei kurzen Datentelegrammen, eine deutlich erhöhte Effizienz gegenüber der TCP- oder UDP-Kommunikation .
Ein Faktor, der bei der Betrachtung der Kapazität eines Feldbussystems oft ignoriert wird, ist die Datenübertragung zwischen Controller-CPU und Kommunikationschip oder –prozessor, d.h. zwischen Hostsystemspeicher und Subsystemspeicher. Bei PC-basierten Controllern werden die Daten meist via ISA- oder PCI-Bus in den DPRAM einer Feldbus-Masterkarte kopiert und umgekehrt. Da PC-Prozessoren heute Geschwindigkeiten von bis zu 3 GHz erreichen, ist selbst der „schnelle“ PCI-Bus zu einem Engpass geworden; 20-30 % der CPU-Leistung gehen allein bei PCI-Übertragung verloren.
Moderne Netzwerkcontroller arbeiten im sogenannten „Busmaster DMA-Modus“, greifen also direkt auf den Speicher des Hostsystems zu. Das erfolgt parallel zu anderen CPU-Tasks, wodurch die CPU-Auslastung deutlich verringert werden kann.

Anwendungen/Anbindung an TwinCAT

Die hohe Datenübertragungskapazität, die fundamentale Echtzeitfähigkeit und die eingesetzten Protokolle decken alle Kommunikationsanforderungen einer schnellen Maschinensteuerung ab. Betrachtet man all diese Eigenschaften, liegt die Schlussfolgerung nahe, dass herkömmliche Feldbusse überflüssig sind.
Allerdings muss sich die Ethernettechnologie erst noch auf Feldebene bewähren und die dortigen Anforderungen erfüllen: z.B. einfache Installation und Konfiguration, gegenseitige Kompatibilität, EMV-Festigkeit und nicht zuletzt Effizienz und Gerätekosten, die für einen industriellen Einsatz relevant sind. Standard-Feldbusse sind weitverbreitet und es gibt viele Geräte von vielen Anbietern (u.a. Beckhoff). Deshalb werden sie am Markt weiterhin einen großen Stellenwert haben. Auch hier bietet das flexible I/O-System von TwinCAT eine Lösung: Mit ihm können mehrere Feldbusse völlig transparent gegenüber der Anwendung parallel arbeiten – natürlich auch herkömmliche Feldbusse parallel zu Echtzeit-Ethernet.

Anwendungsbeispiel 1:

Für relativ einfache Anwendungen ist nur eine Ethernetverbindung erforderlich, um sowohl die Echtzeitkommunikation zur I/O-Ebene als auch die übergeordnete Kommunikation für Verwaltung und Ferndiagnose zu realisieren. Die verwendete Priorisierung stellt sicher, dass die Echtzeitkommunikation problemlos erfolgt.

Anwendungsbeispiel 2:

Bei größeren Anwendungen wird eine zweite Ethernetverbindung eingerichtet, die die Echtzeitkommunikation und die übergeordnete Kommunikation zwischen zwei Netzwerken voneinander trennt. Das Routing, das beispielsweise für eine Ferndiagnose an einem mit einem Echtzeitnetzwerk verbundenen Treiber benötigt wird, wird vom IP-Stack des Betriebssystems automatisch ausgeführt und erfordert keine spezielle Konvertierung in ein anderes Protokoll.

Anwendungsbeispiel 3:

Bei sehr großen Anwendungen, für die auch die Rechenleistung eines 3 GHz-Systems nicht ausreicht, können die Steuerungsaufgaben zwischen mehreren PC-Controllern aufgeteilt werden. So können mit echtzeitfähigen Netzwerkvariablen selbst große Datenmengen quasi zeitgleich mit den Zyklen ausgetauscht werden (selbst bei Geschwindigkeiten unter einer Millisekunde).


Einführung

Netzwerkvariablen sind beliebige Variablen, die zwischen PC/CX1000 mit TwinCAT zyklisch ausgetauscht werden können. Es können Variablen mit beliebigen, auch komplexen, Datentypen ausgetauscht werden. Es wird das Publisher/Subscriber Modell verwendet. Zur hochdeterministischen Kommunikation muss der Echtzeit-Ethernet Treiber für TwinCAT installiert sein.

Publisher/Subscriber Modell

Beim Publisher/Subscriber Modell stellt der Publisher Variablen zur Verfügung. Subscriber können sich für eine Variable einschreiben. Der Publisher kann die Variable einem Subscriber, mehreren Subscribern oder allen Subscribern zur Verfügung stellen. Bei Broadcast wird die Variable allen PCs zur Verfügung gestellt, bei Multicast einigen Ausgewählten und bei Unicast einem einzigen ausgesuchten PC. Ein Subscriber kann gleichzeitig auch Publisher sein. Damit kann auch eine bidirektionale Datenverbindung hergestellt werden.

Unicast

Der Publisher stellt die Netzwerkvariable nur einem einzigen ausgesuchten PC zur Verfügung.

Multicast

Der Publisher stellt die Netzwerkvariable einigen ausgesuchten PCs zur Verfügung.

Broadcast

Der Publisher stellt die Netzwerkvariable allen PCs zur Verfügung.


Konfiguration vom Publisher

Im TwinCAT System Manager wird unterhalb des Gerätes RT-Ethernet eine neue Box für den Publisher eingefügt.

Einfügen einer Publisher Box

Unterhalb des Gerätes RT-Ethernet muß für einen Publisher eine einsprechende Box angefügt werden.

Einfügen einer Netzwerkvariablen

Unterhalb der Box kann man dann Netzwerkvariablen einfügen. Dazu ist es nötig einen Namen (im Beispiel nCounterPub) und einen Datentyp (im Beispiel UINT32 entsprechend UDINT) anzugeben.

Unterhalb der jetzt eingefügten Variablen sind Eingänge und Ausgänge angelegt worden.

Der FrameState Eingang unterhalb der Box gibt Auskunft über den momentanen Status der versendeten Ethernet Frames.

Folgende Werte sind für den FrameState möglich:

Kurzbeschreibung | Wert | Beschreibung
Not sent (frame skipped) | 0x0001 |
Error (frame oversized) | 0x0001 | Die maximale Größe eines Ethernet Frames ist überschritten worden. Die verknüpfte Variable muss kleiner gewählt werden.

Im FrameCtrl Ausgang unterhalb der Box kann ein Control Wort geschrieben werden

Folgende Werte sind für das FrameCtrl möglich:

Kurzbeschreibung | Wert | Beschreibung
Disable sending | 0x0001 | Das Senden des Frames wird unterbrochen. Erst wenn der Wert wieder auf 0 ist, beginnt das Senden des Frames erneut.

Der VarState Eingang unterhalb der Netzwerkvariablen gibt Auskunft über den momentanen Status der Netzwerkvariablen.

Folgende Werte sind für den VarState möglich:

Kurzbeschreibung | Wert | Beschreibung
Not sent (variable skipped) | 0x0001 |

Im VarCtrl Ausgang unterhalb der Netzwerkvariablen kann ein Control Wort geschrieben werden

Folgende Werte sind für das FrameCtrl möglich:

Kurzbeschreibung | Wert | Beschreibung
Disable publishing | 0x0001 | Das Senden der Netzwerkvariablen wird unterbrochen. Erst wenn der Wert wieder auf 0 ist, beginnt das Senden der Netzwerkvariablen erneut.

Verknüpfungen

Die Netzwerkvariable des Publishers kann mit jeder beliebigen Ausgangsvariablen des passenden Datentyps verknüpft werden. Im Beispiel wird die Netzwerkvariable mit einer Ausgangsvariablen einer SPS verknüpft.


Konfiguration vom Subscriber

Im TwinCAT System Manager wird unterhalb des Gerätes RT-Ethernet eine neue Box für den Subscriber eingefügt.

Einfügen einer Subscriber Box und Verbindung der Netzwerkvariablen

Unterhalb des Gerätes RT-Ethernet muss für einen Subscriber eine einsprechende Box angefügt werden.

Unterhalb der Subscriber Box wird dann eine Netzwerkvariable angelegt.

Die Verbindung zu einer Variablen eines Publishers kann automatisch hergestellt werden. Hierzu ist der Publisher Computer zu suchen. In einer Liste werden alle Variablen dieses Publishers aufgelistet.

Unterhalb der jetzt eingefügten Variablen sind Eingänge und Ausgänge angelegt worden.

Der FrameState Eingang und der FrameCtrl Ausgang unterhalb der Box geben Auskunft über den momentanen Status bzw. Control der empfangenen Ethernet Frames. FrameState und FrameCtrl sind reserviert und werden momentan nicht unterstützt.

Der VarState Eingang und der VarCtrl Ausgang unterhalb der Netzwerkvariablen geben Auskunft über den momentanen Status bzw. Control der empfangenen Netzwerkvariablen. VarState und VarCtrl sind reserviert und werden momentan nicht unterstützt.

Qualität der Netzwerkvariablen

Die Qualität einer Netzwerkvariablen wird auf der Subscriber Seite beurteilt. Hierzu stehen zwei Eingangsvariablen unterhalb der Netzwerkvariablen zur Verfügung. Die Variable Quality liefert einen Zähler in 100µs Auflösung. Der Zählerwert zeigt an, wie lange die Variable zu spät eintrifft. Das untere Beispiel zeigt den online Wert von Quality, nach Ziehen des Netzwerksteckers (Anstieg des Zählers) und erneutem Neuverbinden (Zählerstand 0).

Neben der Quality Variablen wird die CycleIndex Variable bei jedem Publisher Zyklus inkrementiert.


Beckhoff Netzwerk Variablen - Einstellungen

Mit den Beckhoff Netzwerkvariablen (NWV) können zyklisch oder azyklisch Daten zwischen Windows-basierten PC verschickt werden. In einem Teilnehmer als Publisher (Sender) deklariert, wird eine solche Netzwerkvariable auf der Gegenseite von einem mit dem gleichen Typ deklarierten Subscriber (Abonnent) empfangen. Dieser Datenverkehr ist dem Namen nach netzwerkbasiert und setzt in seiner Konfiguration direkt auf den verwendeten Protokollen auf.

Zur Auswahl stehen dabei:

  • MAC: Es wird ein ISO-Layer-2-Frame mit einer Absender- und Empfänger-MAC-Adresse verschickt, Ethertype 0x0806. Ein IP-Teil mit Ziel-IP-Adresse (z.B. 192.168.0.1) ist nicht enthalten. Deshalb kann das Telegramm über einen Switch, normalerweise aber nicht über einen Router weiterverarbeitet werden.
    MAC bedeutet Media Access Control und steht hier für die (eindeutige) Hardware-Adresse, die jedes Ethernet-Gerät ab Herstellung hat. Der Ethernet-Port eines Beckhoff-PC könnte z.B. die MAC-Kennung 00:01:05:34:05.84 haben - "00:01:05" ist die Beckhoff-Kennung, der Rest bei der Herstellung gewählt. Über die Quell/Source-MAC und die Ziel/Destination-MAC-Adresse ist der Weg eines jeden Ethernet-Telegramm zwischen 2 Ethernet-Kabelenden bestimmt.
    Das Ethernet-Telegramm wird durch den Ethertype x88A4 als Beckhoff Echtzeit-Ethernet identifiziert - als "Echtzeit Ethernet-Telegramm" (RT-Ethernet) wird es am regulären Windows-TCP-Stack vorbeigeschleust und bevorzugt d.h. "sofort" über den angegebenen Ethernetport des PC versendet.
    Es ist einstellbar, ob das gesendete Telegramm von allen (Broadcast), vielen (Multicast) oder einem einzigen Subscriber (Unicast) empfangen werden soll.
  • UDP/IP: Der Empfänger wird über einen zusätzlichen IP-Header im Ethernet-Telegramm identifiziert, der UDP-Ethernet-Frame kann damit über einen Router weiterverarbeitet werden.
    Auch hier stehen Broad-, Multi- und Unicast zur Verfügung und das Ethernet-Telegramm wird durch den Ethertype 0x88A4 als Beckhoff Echtzeit-Ethernet identifiziert und als RT-Protokoll im TwinCAT-PC behandelt.
    Als verbindungsloses Protokoll verlangt UDP im Gegensatz zu TCP keine Empfangsbestätigung der Nachricht, der Publisher weiß also nicht ob der Subscriber die Nachricht empfangen hat. Deshalb wird zur Gegenstellenüberwachung von TwinCAT das ARP-Protokoll eingesetzt.

Über diese Adressierungsarten kommt das Telegramm mit den Prozessdaten beim Empfängergerät (Netzwerkport) an. Im Ethernet-Gerät/TwinCAT wird die Zuordnung mehrerer transportierter Prozessdaten dann über eine "Variable ID" hergestellt

Alle zu verwendenden Netzwerkvariablen müssen vor der Benutzung im System Manager deklariert werden.

Folgende Eingriffsmöglichkeiten stehen dann während des Betriebs zur Verfügung:

  • das Versenden einer konfigurierten Netzwerkvariable kann dynamisch gesperrt werden
  • die Ziel-IP oder Ziel-MAC kann dynamisch verändert werden
  • Die Variablen-ID "Variable ID" kann dynamisch verändert werden
  • der NWV-Inhalt kann verändert werden, nicht aber der Umfang (Bitgröße)

Diagnosevariablen auf Publisher- und Subscriberseite geben über die Verbindungsqualität Auskunft.

Bei der Verwendung von Netzwerkvariablen sind die zeitlichen Randbedingungen der verwendeten Netzwerkarchitektur zu berücksichtigen: Geswitcht (MAC-Adressierung) können rd. 10 ms Kommunikationszyklus und darunter erreicht werden, geroutet (IP-Adressierung) fallweise auch einige 100 ms.

Hinweis 		Diagnosevariable "Quality"
Wenn die verarbeitenden Tasks mit unterschiedlichen Zykluszeiten arbeiten oder vom Anwender der DataExchangeDivider verändert wird, ist das bei der Auswertung der Diagnosevariablen entsprechend zu berücksichtigen - ein langsamer Publisher (z.B. 100 ms) führt bei einem schnellen Subscriber (z.B. 10 ms) zu einer schlechten Verbindungsqualität im Sinne der Diagnosevariable "Quality".
Ebenso ist zu berücksichtigen, wenn das Versenden eines Publishers dynamisch zeitweise gesperrt wird. Der Subscriber registriert dann eine schlechte Quality.

Hinweis 		Diagnosevariable "CycleIndex"
Beachten Sie unteren Hinweise um zu entscheiden, ob die Variable CycleIndex von Ihnen bedient werden muss.

Grundlagen zu Beckhoff Netzwerkvariablen

  • Quality:
    Zeit in [100 µs], um die diese NWV zu spät beim Publisher ankam.
    Bezogener Ankunftsort:
    Eingangsprozessabbild des TwinCAT-Systems
    Bezogene Ankunftszeit:
    Zeitpunkt, wenn im nächsten Zyklus das Eingangsabbild geladen wird

    Hinweis    :
    Die angezeigte "Verspätung" wird deshalb so fein skaliert ermittelt, weil die NWV-Verwaltung zyklusunabhängig direkt vom IO-Treiber verwaltet wird. Ungeachtet dessen werden die Daten einer um einige Prozent der Zykluszeit zu spät angekommene NWV erst im nächsten Task-Zyklus mit dem Lesen des Eingangsprozessabbildes berücksichtigt.

    Hinweis EL6601/EL6614    :
    Auch bei Verwendung der EL66xx ist der Ankunftszeitpunkt der NWV dann, wenn die Daten im Eingangsprozessabbild des RT-Gerätes vorliegen, nicht wenn sie bei der EL66xx oder im Eingangsabbild des EtherCAT-Gerätes ankommen.

    Abb. 1: Zusammenhang Quality und verspätet angekommenen Netzwerkvariable
  • Variable ID
    Die Variablen-ID (16 Bit) dient zur globalen Identifizierung der einzelnen Prozessdaten - deshalb darf innerhalb eines TwinCAT-Devices eine ID in der Gruppe der Publisher oder Subscriber nicht mehrmals verwendet werden, s. Abb. 2: Publisher 1 und 2 auf PC1 müssen unterschiedliche ID (10 und 8) haben, in Publisher 2 und Subscriber 1 darf aber jeweils eine ID = 8 verwendet werden.

    Hinweis     		Auswahl der Variablen-ID
    Um eine eindeutige Zuordnung zu erreichen wird empfohlen, für jede Datenübertragung zwischen zusammenhängenden PCs unterschiedliche IDs zu verwenden.

    Begründung: in Abb. 2 erhält PC2/Subscriber2 nicht nur die vorgesehene ID=8-Variable von PC1/Publisher2, sondern, da als Broadcast (!) gesendet, auch die NWV von PC3/Publisher1. Eine Unterscheidung ist in PC2 dann nicht mehr möglich!

  • Cycle Index
    Der 16 Bit Cycle Index ist ein Zähler, der vom Publisher mit den Daten mitgesendet wird. Üblicherweise wird er mit jeder Sendung inkrementiert und lässt so einen Rückschluss auf eine ununterbrochene Übertragung zu. Er ist auf der Subscriber-Seite als CycleIndex auslesbar. Dabei unterscheidet sich sein Auftreten je nach Publisher-Plattform:
    - Publisher auf einem PC: die Variable CycleIndex ist nicht sichtbar und wird autoamtisch zyklisch vom System Manager inkrementiert
    - Publisher auf einer EL66xx: die Variable CycleIndex ist sichtbar und muss vom Anwender inkrementiert/bedient werden, damit sie auf der Subscriber-Seite ungleich 0 ist.

Abb. 2: Beispielhafte Kommunikation über Netzwerkvariablen

Hinweis 		Datendarstellung auf unterschiedlichen Plattformen
Bitte beachten Sie, dass einfache wie komplexe Daten (WORD, ARRAYs, REAL, STRING, benutzerdefinierte Strukturen) auf unterschiedlichen Plattformen intern unterschiedlich dargestellt werden!

x86-Plattformen arbeiten im Byte-Alignment, andere (ARM) im 2- oder 4-Byte-Alignment.

Das bedeutet, wenn eine komplexe Struktur in je einem x86/PC-PLC-Projekt und einem ARM-PLC-Projekt angelegt wird, sie jeweils eine andere effektive Größe und einen anderen inneren Aufbau haben kann.

Im Beispiel ist die Struktur im CX (und damit die dort anzulegende Netzwerkvariable) größer als im PC, auch passen die Word- und Real-Variablen nicht zueinander da im PC auf jeder Byte-Position eine Variable beginnen kann, im CX nur an jeder geradzahligen.

Empfehlung zum Aufbau von Strukturen, gleichlautend auf beiden Endgeräten

  • Zuerst alle 4-Byte-Variablen (müssen auf einer durch 4 teilbaren Adresse liegen)
  • dann alle 2-Byte-Variablen (müssen auf einer durch 2 teilbaren Adresse liegen)
  • dann alle 1-Byte-Variablen

Weitere Empfehlung

  • wenn STRING(x) verwendet wird, dann gilt das "EndOfString"-Nul ebenfalls als Zeichen; somit muss x+1 durch 4 teilbar sein
  • obige Regeln gelten auch für Unter-Strukturen.

Bitte beachten Sie dazu die Hinweise im Infosys, Abschnitt Struktur.

Verwendung von Busklemmen-Controllern (BCxxxx, BXxxxx)

Da auf Busklemmen-Controllern (BCxxxx, BXxxxx) die Darstellung von Fließkommazahlen (REAL) von der im x86 abweicht, können diese nicht übertragen werden. Für vorzeichenbehaftete Werte können z.B. "SINT" verwendet werden.

Einstellungen im System Manager

Hinweis 		Erscheinungsbild der Variablen
Je nach verwendeter Plattform (PC oder EL66xx) stellen sich Publisher/Subscriber unterschiedlich dar. Ein Publisher/Subscriber kann angelegt werden
  • auf einer PC-Netzwerkschnittstelle, s. Abb. 3
  • auf einer EL66xx, s. Beckhoff Netzwerk Variablen - Einstellungen

Folgende Einstellungen können im Beckhoff System Manager TwinCAT 2.10 build 1328 vorgenommen werden:

Publisher, Box

Abb. 3: Einstellungen Publisher - RT Ethernet

Einstellungen zum RT-Ethernet:

  • MAC-Broadcast: Sendung geht an alle Netzwerkteilnehmer, Destination-MAC FF:FF:FF:FF:FF:FF.
  • Multicast: Eine Destination-MAC-Adresse wird dann zu einer Multicast-Adresse, wenn das erste Bit im ersten Byte der MAC gesetzt ist, das sog. Gruppenbit. Mit der Beckhoff-Kennung "00 01 05" wird so in Abb. 3 die Default-Ziel-Adresse "01 01 05 04 00 00" gebildet.
    Für den allgemeinen Multicast-Einsatz ist der MAC-Bereich 01:00:5E:00:00:00 bis 01:00:5E:FF:FF:FF vorgesehen - dabei sind die ersten 3 Byte von der IEEE fest definiert, die hinteren 3 Byte leiten sich aus dem unteren Teil der IP-Adresse des Ziel-PC ab. Die dabei entstehende Ziel-MAC ist also im Netzwerk nie physikalisch vorhanden, sondern die Ziel-Netzwerkkarte erkennt solchermaßen gebildete Ethernet-Frames als zu ihr gesendete Multicast-Frames, obwohl der Ethernet-Port selbst eine andere, eindeutige MAC-Adresse haben kann. Da auch noch andere Regeln auf die Bildung von Multicast-MAC/IP-Adressen einwirken, sei im Weiteren auf die entsprechende Literatur verwiesen.
  • Unicast: entweder direkte Eingabe der Ziel-MAC oder über die AMS-Net-ID des Ziel-Gerätes, z.B. 123.456.123.456.1.1 - dann muss diese Route aber im lokalen AMS-Router eingetragen sein (Rechtsklick TwinCAT Icon in der Taskleiste --> Eigenschaften --> AMS Router)

Hinweis 		Verwendung von Broadcast und Multicast
Netzwerkvariablen, die als Broad- oder Multicast auf MAC- oder IP-Ebene verschickt werden, erzeugen je nach Zykluszeit eine hohe Netzwerklast, da sie ins gesamte anhängende Netz multipliziert werden! Einfache Netzwerkgeräte wie z.B. Drucker können dann abstürzen, bei kurzen Zykluszeiten kann auch der gesamte Netzwerkverkehr blockiert werden!

Die Verwendung der Unicast-Adressierung wird dringend empfohlen, auch unter Berücksichtigung der o.a. Variablenidentifizierung.

Weitere Einstellungen:

  • Data Exchange: verwendete Taskzykluszeit * Divider ist der Rhythmus, in dem diese Netzwerkvariable versendet wird. (nicht bei EL66xx)
  • VLAN Support: in Verbindung mit managebaren Switchen kann dem hier parametrierten Ethernet-Frame durch das VLAN-Tagging (Virtual Local Area Network) eine feste Route vorgegeben werden

Abb. 4: Einstellungen Publisher - UDP/IP

Einstellungen zum UDP/IP - es wird das Adressierungsverfahren der IP-Vermittlungsschicht mit IP-Adressen benutzt, UDP ist ein verbindungsloses Protokoll ohne Rückmeldung.

  • Broadcast: Versand an alle Teilnehmer mit Destination-IP(v4) 255.255.255.255
  • Multicast: die Ziel-IP ist anzugeben, s. Anmerkungen zum MAC-Multicast
  • Unicast: das Zielgerät (z.B: 192.168.0.1) angeben, dabei auf Erreichbarkeit durch die SubNetz-Maske achten

Hinweis 		Verwendung von Broadcast und Multicast
Netzwerkvariablen, die als Broad- oder Multicast auf MAC- oder IP-Ebene verschickt werden, erzeugen je nach Zykluszeit eine hohe Netzwerklast, da sie ins gesamte anhängende Netz multipliziert werden! Einfache Netzwerkgeräte wie z.B. Drucker können dann abstürzen, bei kurzen Zykluszeiten kann auch der gesamte Netzwerkverkehr blockiert werden!

Die Verwendung der Unicast-Adressierung wird dringend empfohlen, auch unter Berücksichtigung der o.a. Variablenidentifizierung.

Weitere Einstellungen:

  • "ARP Retry Interval": Um sich über die Anwesenheit des Empfängers zu informieren, sendet der Publisher in diesem Abstand eine ARP-Anfrage (ARP Request) an das Zielgerät. Arbeitet die Netzwerkverwaltung des Empfänger-PC, antwortet dieser mit einem "ARP Reply". Deshalb nur bei Unicast sinnvoll.
    In der Diagnosevariable "FrameState" wird im Fehlerfall Bit 3 gesetzt (0x0004).
    Anmerkung: das ARP-Handling (ARP = Address Resolution Protocol: Zuordnung von Hardware/MAC-Adressen zu Netzwerkadressen [IP] ) wird vom Betriebssystem (Windows) verwaltet.
  • "Disable Subscriber Monitoring": schaltet das vorgenannte Verfahren ab
  • "Target Address changeable": dann kann die Ziel-IP dynamisch geändert werden

Publisher, Variable

Abb. 5: Einstellungen Publisher - Variable

Einstellungen:

  • "Variable ID": Identifizierungsnummer, mit der diese Variable versendet wird, ggf. über PLC online veränderbar
  • "Data Exchange": s.o. (nicht bei EL66xx)
  • "On change only": NWV wird nur bei Änderung des Wertes versendet (nicht bei EL66xx)

Subscriber, Box

Abb. 6: Einstellungen Subscriber

Einstellungen:

  • "Receiving Options": lässt für diesen Subscriber nur NWV eines bestimmten Publishers zu
  • "Multicast Configuration": dto.

Prozessdaten:

  • "VarId": wenn aktiviert, dann ist die Variablen-Id online änderbar

Subscriber, Variable

Abb. 7: Einstellungen Subscriber - Variable

Einstellungen:

  • "Variable ID": lässt für diesen Subscriber nur NWV mit einer bestimmten ID zu, ggf. über PLC dynamisch veränderbar
  • "Ignore Data Type Hash": die Hash-Berechnung wird z.Z. noch nicht unterstützt

Prozessdaten:

  • "Quality": siehe o.a. Erläuterungen
  • "CycleIndex": wird mit jeder erfolgreichen Übertragung inkrementiert, WENN die Gegenseite = der Publisher dies vornimmt. Wenn der Publisher ein EL66x ist, muss dort der Anwender CycleIdx inkrementieren.
  • "VarData": übertragene Daten


EtherCAT Topology View Introduction

EtherCAT Topology View ActiveX Control

Einleitung

Das EtherCAT Topology View ActiveX Control dient zur Anzeige der aktuellen Topologie eines TwinCAT EtherCAT-Masters. Das ActiveX Control zeigt entweder die Topologie der aktivierten Konfiguration oder die aktuelle Topologie, die durch einen Bus-Scan ermittelt wird, an. Das Topologie-Control unterstützt drei unterschiedliche Darstellungs-Modi:

  • Offline-Anzeige

    Zeigt die Topologie eines EtherCAT Gerätes, aus einem geöffnet System-Manager Projekt, an

  • Online-Anzeige:

    Zeigt die Topologie eines, in der aktullen TwinCAT Konfiguration enthaltenem, EtherCAT Gerätes an. Die Topologie-Anzeige zeigt folgende Online-Informationen der einzelnen EtherCAT-Slaves, die an den EtherCAT-Master angeschlossen sind, an:

    • EtherCAT Status(Init, Pre-Operational, Safe-Operational, Operational und Bootstrap)
    • Crc-Fehler
    • Link-Status
    • Kommunikations-Fehler
  • Topologie-Vergleich

Sie haben zwei Möglichkeiten das Topology-Control zu verwenden:

  • öffnen des Topology-Dialoges im System-Manager
  • Einbinden des Controls in eine eigene Applikation (C++, .Net, VB etc.).


EtherCAT Topology Online View

EtherCAT Topology View ActiveX Control

Online Topologie-Anzeige

Das TwinCAT-Icon repräsentiert in der Anzeige den EtherCAT-Master, von dem die Kommunikation ausgeht. Die an den Master angeschlossenen Slave-Geräte werden rechts vom Master dargestellt:

EtherCAT Status-Anzeige

Jedes Gerät in der Ansicht hat einen Status-Balken, der den aktuellen EtherCAT-Status des Slaves anzeigt :

Keine Kommunikation

Wenn keine Kommunikation mit dem Slave-Gerät möglich ist, wird das Gerät rot umrandet:

Crc-Fehler

Wenn ein Crc-Fehler an einem Port (A,B,C oder D) des EtherCAT-Slaves festgestellt wird, wird pro Port, der einen Crc-Fehler hat, ein roter Kreis unter dem Gerät dargestellt:

Im Tooltip der einzelnen Ports können Sie die Anzahl der Crc-Fehler erkennen.

Slave-Informations Dialog

Wenn ein EtherCAT-Slave durch drücken der linken-Maustaste selektiert wird, öffnet sich der Slave-Information Dialog:

Karteireiter EtherCAT:

Name: | Name des EtherCAT-Slaves
Type: | Typ des EtherCAT-Slaves
EhterCAT Addr: | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben.
Auto Inc Addr: | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
Identity: |  | Identität des Slave-Gerätes
 | Vendor Id: | Vendor-Id des Slaves
 | Product Code: | Produkt-Code des Slaves
 | Revision No: | Revisions-Nummer des Slaves
 | Serial No: | Serien-Nummer des Slaves
 | Product/Revision: | Lesbarer Name der aus dem Produkt-Code und der Revisions-Nummer generiert wird

Karteireiter Online:

State Machine

Init: Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op: Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op: Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap: Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op: Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Clear Error: Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag.

Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.

Current State: Zeigt den aktuellen Status des EtherCAT-Geräts an. Folgende Abkürzungen werden hier verwendet
Abkürzung | Beschreibung
INIT | EtherCAT-Gerät ist im Status Init
PREOP | EtherCAT-Gerät ist im Status Pre-Operational
SAFEOP | EtherCAT-Gerät ist im Status Safe-Operational
OP | EtherCAT-Gerät ist im Status Operational
BOOT | EtherCAT-Gerät ist im Status Bootstrap
ERR | EtherCAT-Gerät ist im Fehlerzustand
VPRS | Vendor-Id, Produkt-Code, Revisions-Nummer oder Serien-Nummer des EtherCAT-Gerätes ist ungültig
NO_COMM | Keine Kommunikation mit dem EtherCAT-Gerät möglich
LNK_MIS Port | Link am angegebenen Port fehlt (Port = A, B, C or D).
LNK_ADD Port | Ein zusätzlicher Link wurde am angegebenen Port festgestellt
LNK_ERR Port | Ein Link ohne Kommunikation wurde festgestellt
Requested State: Zeigt den für das EtherCAT-Gerät angeforderten Status an.

Crc Error Counters

Port A: | Zeigt die Anzahl der Crc-Fehler am Port A an
Port B: | Zeigt die Anzahl der Crc-Fehler am Port B an
Port C: | Zeigt die Anzahl der Crc-Fehler am Port C an
Port D: | Zeigt die Anzahl der Crc-Fehler am Port D an


EtherCAT Topology View Interfaces

EtherCAT Topology View ActiveX Control

Einbinden des ActiveX Controls

Das ActiveX-Control besitzt zwei Properties mit denen das EtherCAT-Master, dessen Topologie angezeigt werden soll, eindeutig bestimmt wird:

  • TargetNetId
  • DeviceId

TargetNetId

Die TargetNetId bestimmt das TwinCAT-System mit dem sich das ActiveX Control verbinden soll. Die am lokalen System angemeldeten TwinCAT-System können Sie mit Hilfe des System-Managers anzeigen. Drücken Sie dazu in der Symbolleiste des System Managers das Wählen Zielsystem... Icon( [image]) :

In diesem Fall können Sie also als TargetNetId '172.16.2.133.1.1' oder einen Leerstring übergeben, um sich mit dem lokalen TwinCAT-System zu verbinden. Mit der TargetNetId '5.0.39.217.1.1' verbinden Sie sich mit dem TwinCAT-System auf dem Remote-Rechner CX_0027D9.

DeviceId

Die DeviceId ist die eindeutige Id des EtherCAT-Master Gerätes im TwinCAT E/A-System. Diese Id finden Sie im System Manager in den Einstellungen des EtherCAT-Gerätes wieder. Dazu selektieren Sie das EtherCAT-Gerät in der Baumansicht des System Managers und selektieren Sie den Karteireiter Allgemein. Die Geräte-Id wird im Textfeld Id angezeigt:

In diesem Fall müssen Sie also als DeviceId die 1 verwenden.

Anzeigen der Online-Topologie

Sie können entweder die Topologie der aktuellen Konfiguration oder die Topologie, die durch einen Bus-Scan ermittelt wird, anzeigen. Hierfür wird das Property OnlineMode verwendet:

  • gescannte Topologie: OnlineMode = TOPOLOGY_ONLINE_MODE_SCANNED
  • aktuell konfigurierte Topologie: OnlineMode = TOPOLOGY_ONLINE_MODE_CONFIGURED

Als nächstes müssen Sie die Methode ShowOnlineTopology aufrufen, um die Topologie anzuzeigen:

Eigenschaften des ActiveX-Controls

DeviceId

Beschreibung

Die Eigenschaft DeviceId bestimmt von welchem EtherCAT-Gerät des TwinCAT-Zielsystemes die Topologie angezeigt werden soll. Die DeviceId ist die eindeutige Id des EtherCAT-Master Gerätes im TwinCAT E/A-System

Property-Typ

Read-write property

Default Wert

0

Syntax (C#)

int DeviceId { set; get; }
    Member of IEcTopologyCtrl

Beispiel (C#)

//DeviceId vom SystemManager auslesen
axEcTopologyCtrl1.DeviceId = 1;
axEcTopologyCtrl1.ShowOnlineTopology();

//DeviceId über das IEnumEtherCATDevices interface ermitteln
IEnumEtherCATDevices devices;
IEtherCATDevice device;

axEcTopologyCtrl1.GetEnumEtherCATDevices(out devices);
uint fetched = 0;

devices.Next(1, out device, out fetched);
if (fetched == 1)
    axEcTopologyCtrl1.DeviceId = device.DeviceId;

axEcTopologyCtrl1.ShowOnlineTopology();

TargetNetId

Beschreibung

Die Eigenschaft TargetNetId bestimmt mit welchen TwinCAT-System das ActiveX-Control sich verbinden soll. Bei der TargetNetId handelt es sich um die AMS NetId, die im TwinCAT-System zur Idententifizierung eines TwinCAT-Rechners verwendet wird.

Property-Typ

Read-write property

Default Wert

AMS NetId des lokalen Systems

Syntax (C#)

string TargetNetId { set; get; }
    Member of IEcTopologyCtrl

Beispiel (C#)

axEcTopologyCtrl1.TargetNetId = ""; 			// Verbindung zum lokalen TwinCAT-System
//axEcTopologyCtrl1.TargetNetId = "172.16.2.122.1.1";	// Verbindung zum TwinCAT-System mit der AMS NetId 172.16.2.122.1.1
axEcTopologyCtrl1.DeviceId = 1;
axEcTopologyCtrl1.ShowOnlineTopology();

ZoomFactor

Beschreibung

Die Eigenschaft ZoomFactor bestimmt den Zoom-Faktor, der bei der Anzeige der Topologie verwenden werden soll. Hiermit können Sie also die Anzeige vergrößern oder verkleinern.

Property-Typ

Read-write property

Default Wert

3

Syntax (C#)

double ZoomFactor { set; get; }
    Member of IEcTopologyCtrl

SlaveDescriptionPath

Beschreibung

Die Eigenschaft SlaveDescriptionPath bestimmt den Pfad, in dem sich die Gerätebeschreibungen der EtherCAT-Slaves befinden. Im Normalfall muss diese Eigenschaft nicht geändert werden, da er auf den Pfad eingestellt wird, in dem TwinCAT die Gerätebeschreibungen speichert.

Property-Typ

Read-write property

Default Wert

%\TwinCAT\Io\EtherCAT

Syntax (C#)

string SlaveDescriptionPath { set; get; }
    Member of IEcTopologyCtrl

OnlineMode

Beschreibung

Die Eigenschaft OnlineMode bestimmt welche Topologie angezeigt werden soll, wenn die Methode ShowOnlineTopology aufgerufen wird. OnlineMode kann folgende Werte annehmen:

OnlineMode | Beschreibung
TOPOLOGY_ONLINE_MODE_SCANNED | Die Topologie, die durch einen Bus-Scan ermittelt worden ist, wird angezeigt.
TOPOLOGY_ONLINE_MODE_CONFIGURED | Die aktuell konfigurierte Topologie wird angezeigt.

Property-Typ

Read-write property

Default Wert

TOPOLOGY_ONLINE_MODE_CONFIGURED

Syntax (C#)

ECTOPOLOGYLib.TOPOLOGY_ONLINE_MODE OnlineMode { set; get; }
    Member of IEcTopologyCtrl

Beispiel (C#)

axEcTopologyCtrl1.TargetNetId = "172.16.2.122.1.1";	// Verbindung zum TwinCAT-System mit der AMS NetId 172.16.2.122.1.1
axEcTopologyCtrl1.DeviceId = 1;
axEcTopologyCtrl1.OnlineMode = TOPOLOGY_ONLINE_MODE.TOPOLOGY_ONLINE_MODE_CONFIGURED; //Topologie der aktuellen Konfiguration anzeigen
axEcTopologyCtrl1.ShowOnlineTopology();

MasterState

Beschreibung

Die Read-Only Eigenschaft beinahltet den aktuellen Status des Masters.

MasterState | Beschreibung
TOPOLOGY_MASTER_STATE_INVALID | Master ist in einem ungültigen Zustand.
TOPOLOGY_MASTER_STATE_INT | Master ist im EtherCAT-Status Init.
TOPOLOGY_MASTER_STATE_PREOP | Master ist im EtherCAT-Status Pre-Operational.
TOPOLOGY_MASTER_STATE_SAFEOP | Master ist im EtherCAT-Status Safe-Operational.
TOPOLOGY_MASTER_STATE_OP | Master ist imEtherCAT-Status Operational.
TOPOLOGY_MASTER_STATE_OFFLINE | Es besteht zur Zeit keine Online-Verbindung mit dem Master. Dies ist z.B. der Fall, wenn das TwinCAT-System gestoppt ist.

Property-Typ

Read-Only property

Default Wert

Syntax (C#)

ECTOPOLOGYLib.TOPOLOGY_MASTER_STATE MasterState { get; }
    Member of IEcTopologyCtrl

ShowCrcErrorMarker

Beschreibung

Die Eigenschaft ShowCrcErrorMarker bestimmt, ob das Vorhanden sein von Crc-Fehler in der Online-Anzeige grafisch dargestellt werden soll. Ist dieser Wert auf true gesetzt, wird ein roter Kreis, für jeden Ethernet Port an dem ein Fehler registriert worden ist, unter dem EtherCAT-Slave dargestellt.

Property-Typ

Read-write property

Default Wert

false

Syntax (C#)

bool ShowCrcErrorMarker { set; get; }
    Member of IEcTopologyCtrl

ShowSlaveInfo

Beschreibung

Die Eigenschaft ShowSlaveInfo bestimmt, ob der Informations-Dialog für ein selektiertes Gerät in der Online-Anzeige dargestellt werden. Der Dialog wird im rechten unterem Rand der Ansicht angezeigt und enthält zusätzliche Information des EtherCAT-Slave (siehe Slave-Informations Dialog).

Property-Typ

Read-write property

Default Wert

false

Syntax (C#)

bool ShowSlaveInfo { set; get; }
    Member of IEcTopologyCtrl

ShowAdvancedSettingsMenu

Beschreibung

Die Eigenschaft ShowAdvancedSettingsMenu bestimmt, ob bei der Offline-Anzeige(siehe ShowOfflineTopology) im Kontext-Menu eines EtherCAT-Slaves der Eintrag AdvanceSettings... hinzugefügt werden soll oder nicht. Wenn dieser Menü-Eintrag vom Anwender ausgewählt wird, wird das Event OnAdvancedSettings Control gefeuert.

Property-Typ

Read-write property

Default Wert

false

Syntax (C#)

bool ShowAdvancedSettingsMenu { set; get; }
    Member of IEcTopologyCtrl

BackColor

Beschreibung

Die Eigenschaft BackColor bestimmt die Hintergrunds-Farbe des Controls

Property-Typ

Read-write property

Default Wert

0x00FFFFFF(white)

Syntax (C#)

uint BackColor { set; get; }
    Member of IEcTopologyCtrl

Methoden des ActiveX-Controls

ShowOnlineTopology

Beschreibung

Zeigt die Onine-Topologie eines EtherCAT-Gerätes an. Das EtherCAT-Gerät wird mit den Properties DeviceId und TargetNetId ausgewählt. Mit Hilfe des Parameters OnlineMode kann man zusätzlich bestimmen, wie die Topologie ermittelt wird.

Syntax (C#)

void ShowOnlineTopology()
    Member of IEcTopologyCtrl

Beispiel (C#)

axEcTopologyCtrl1.TargetNetId = "172.16.2.122.1.1";	// Verbindung zum TwinCAT-System mit der AMS NetId 172.16.2.122.1.1
axEcTopologyCtrl1.DeviceId = 1;			// EtherCAT-Gerät mit der Id 1
axEcTopologyCtrl1.ShowOnlineTopology();		// anzeigen der Topologie

ShowOfflineTopology

Beschreibung

Zeigt die Offline-Topologie eines EtherCAT-Gerätes aus einer geöffneten System Manager Konfiguration an.

Parameter

TCatSysManagerLib.ITcSmTreeItem pEtherCATDevice

interface auf das System Manager TreeItem-Interfaces eines EtherCAT-Gerätes

Syntax (C#)

void ShowOfflineTopology(TCatSysManagerLib.ITcSmTreeItem pEtherCATDevice)
    Member of IEcTopologyCtrl

GetEnumEtherCATDevices

Beschreibung

Mit Hilfe der Methode GetEnumEtherCATDevices erhält man das Enumartions-Interface für die im TwinCAT-System geöffneten EtherCAT-Geräte. Hiermit kann man dann über die einzelnen EtherCAT-Geräte enumerieren und den Namen und die DeviceId der einzelnen EtherCAT-Geräte auslesen.

Parameter

out IEnumEtherCATDevices ppEnum

Interface IEnumEtherCATDevices

Syntax (C#)

void GetEnumEtherCATDevices(out IEnumEtherCATDevices ppEnum)
    Member of IEcTopologyCtrl

Beispiel (C#)

//DeviceId über das IEnumEtherCATDevices interface ermitteln
IEnumEtherCATDevices devices;
IEtherCATDevice device;

axEcTopologyCtrl1.GetEnumEtherCATDevices(out devices);
uint fetched = 0;

do
{
    devices.Next(1, out device, out fetched);
    if (fetched == 1)
        Console.WriteLine(String.Format("Name:{0} Device Id:{0:d}", device.Name, device.DeviceId));
} while (fetched == 1);


Dialog: Route Hinzufügen

Die Liste der erreichbaren Zielsysteme bzw. Remote-Systeme kann mit Hilfe des folgenden Dialogs erweitert werden:

Enter Host Name / IP

Führt das Kommando 'GetHostByName' aus. Das bedeutet, der im Feld eingegebene Name wird im Netzwerk (Subnet) als mögliches TwinCAT Zielsystem bzw. Remote-System gesucht.

Broadcast Search

Sucht nach allen am aktuellen Subnet angeschlossenen TwinCAT Systemen. Damit die Ziele vom System Manager gefunden werden können, muß sich TwinCAT auf ihnen entweder im Konfig-Modus oder im Run-Modus befinden.

Host Name

Name des Remote- bzw. Zielsystems im Netzwerk.

Connected

Gibt den Status der Verbindung an.

Address

Nennt die Adresse des jeweiligen Teilnehmers. Die Art der Adresse ist abhängig von dem jeweils verwendeten Transportprotokoll. Sollte dies 'TCP/IP' sein, ist es folglich die TCP/IP-Adresse.

AMS NetId

Die Identifikationsadresse des Teilnehmers für den TwinCAT Router. Siehe: ADS-AmsNetId.

TwinCAT

Nennt die jeweilige Versions- und "Build"-Nummer des TwinCAT Zielsystems.

OS Version

Nennt das installierte Bertriebssystem des Zieles.

Route Name [Target], AmsNetId, Transport Type

Spiegeln bei Auswahl eines Zieles aus der Liste dessen Angaben in der jeweiligen Spalte wieder.

Address Info

Siehe Host Name bzw. IP Address.

- Host Name

Die Address Info ist der Name des Zieles.

- IP Address

Die Address Info ist die IP Adresse des Zieles.

Add Route

Fügt das ausgewählte Ziel zu den "Routes" hinzu.

Route Name (Remote)

...

Dialog "Logon Information"

Um ein Remote- bzw. Zielsystem konfigurieren zu dürfen, muß man die entsprechenden Rechte besitzen. Sollte dies nicht der Fall sein, erscheint der folgender Dialog:

Hat man das Passwort und den Benutzernamen für die geforderte Benutzergruppe, kann man sie hier eintragen und bekommt damit die Konfigurationsmöglichkeit für das System eingeräumt.

Hinweis: Ein CX100x-xx1x, also ein Gerät mit dem Betriebssystem MS WIndows CE.NET benötigt momentan noch kein Passwort, daher kann man den Dialog einfach mit "Okay" bestätigen ohne in die beiden Zeilen etwas eintragen zu müssen.

Nach Bestätigung mit "Okay" muß im oben beschriebenen "Add Route Dialog" beim zugefügten Teilnehmer unterhalb von "Connected" ein 'x' erscheinen. Damit ist der Vorgang abgeschlossen und man kann das gewünschte Ziel, wie unter Auswahl des Zielsystems beschrieben, anwählen.


Definition Remote- bzw. Target System

TwinCAT System Manager: System Konfiguration

Definition Remote- bzw. Zielsystem

Um die erweiterten Möglichkeiten der Auswahl von Zielsystemen unter TwinCAT 2.9 nutzen zu können, müssen die Begriffe "Zielsystem" und "Remote-System" verdeutlicht werden. Im Kontext der möglichen Fernkonfiguration von TwinCAT Systemen (dies können sowohl andere TwinCAT-PCs, als auch z.B. Geräte der CX1000 oder BX Familie sein), ist ein Zielsystem (Target System) das System, welches am Konfigurations-PC primär unter "Statische Routes" konfiguriert (angemeldet) ist. Das Zielsystem kann direkt angewählt werden. Dies bedeutet z.B. auch, das der Konfigurations-PC auf jeden Fall die Rechte besitzt, um auf das "Zielsystem" zugreifen zu dürfen. Letzteres wird bereits beim Hinzufügen des Zielsystems zu den statischen Routes abgeprüft. Des Weiteren kann man aber vom Zielsystem aus auch noch eine Suchanfrage nach dort freigegebenen (und per TwinCAT Router erreichbaren) TwinCAT Systemen starten. Ein dann gefundenes und zur Konfiguration freigegebenes System, wird im weiteren Verlauf als "Remote-System" bezeichnet.

Rechte auf dem Remote-System

Die obere Erklärung bedeutet auch, daß der Konfigurations-PC nicht zwingend die Rechte auf dem Remote-System benötigt, um dieses konfigurieren zu können. Das Zielsystem, über welches zum Remote-System hin geroutet wurde, benötigt diese Rechte aber schon.

Das folgende Schaubild soll das Prinzip der Klassifizierung von Zielsystem (Target System) und Remote-System zum besseren Verständnis noch einmal verdeutlichen.


PROFIBUS MC (Äquidistanz)

Die Äquidistanz-Funktionalität von PROFIBUS MC ist voll kompatibel mit Standard PROFIBUS DP. Der Unterschied zu Standard-PROFIBUS DP liegt darin, dass Master- und Slave-Applikation miteinander synchronisiert sind, so dass insbesondere zeitkritische Regelungen über den PROFIBUS erfolgen können. Die Slave-Applikationen werden mit der Master-Applikation über das zyklische Global_Control-Telegramm synchronisiert. Der Jitter zwischen zwei Global_Control-Telegrammen beträgt nur wenige Mikrosekunden und addiert sich über die Zeit zu Null.

Die FC310x unterstützt zur Synchronisation der Master-Applikation mit dem PROFIBUS-Zyklus zwei unterschiedliche Verfahren, im ersten Verfahren sychronisiert sich die FC310x auf den zyklischen Interrupt einer Applikationstask (Task-Synchron), im zweiten Verfahren synchronisiert sich die Applikationstask auf den zyklischen Interrupt der FC310x (Bus-Synchron). Das Task-Synchrone Verfahren hat den Vorteil, dass mehrere FC310x-Kanäle parallel mit PROFIBUS MC betrieben werden können (im Bus-Synchronen Verfahren kann nur ein FC310x-Kanal betrieben werden), aber den Nachteil, dass die Applikations-Task echtzeitfähig mit einem Jitter sein muss, der sich über die Zeit zuaddiert (je nach PROFIBUS-Zykluszeit kann die FC310x größere Jitter als wenige Mikrosekunden ausgleichen). In beiden Verfahren wird der PROFIBUS-Zyklus durch einen Echtzeit-Timer auf der FC310x gestartet, beim Task-Synchronen Verfahren wird der Echtzeit-Timer entsprechend des Zyklusses der Applikations-Task nachgeregelt, beim Bus-Synchronen Verfahren erzeugt der Echtzeit-Timer der FC310x einen Interrupt im PC, so dass sich die Applikations-Task darauf einregeln kann.

Da TwinCAT die Echtzeit-Anforderungen erfüllt, wird die Karte standardmäßig im Task-Synchronen Verfahren betrieben, bei Fremd-Applikationen muss in der Regel das Bus-Synchrone Verfahren gewählt werden.

Zyklischer Ablauf beim Task-Sychronen Verfahren

Die PC-Echtzeit gibt das Synchronisationssignal (SYN) vor (auf der FC310x wird ein Interrupt ausgelöst). Da der Jitter der PC-Echtzeit ggf. ausgeglichen werden muss und der PROFIBUS-Zyklus erst nach dem Aktualisieren der Ein- und Ausgänge gestartet werden darf, ist der Anfang des PROFIBUS-Zyklusses bezüglich des SYN-Signal verschoben. Diese Shift-Time (Ts) muss mindestens so groß wie der maximale Jitter plus die maximale Mapping-Time sein (beides kann mit dem TwinCAT-System-Manager gemessen werden). Um einen optimalen Gesamt-Zyklus zu bekommen, empfiehlt es sich, dass am Anfang des PROFIBUS-Zyklusses der Datenaustausch mit den MC-Slaves (S1 - S5 im Bild) stattfindet (die Slaves werden von der FC310x in der Reihenfolge angesprochen, in der sie im System-Manager an dem FC310x-Device hängen). Bei den MC-Slaves kann weiterhin die Zeit To (Sollwertübernahme) und Ti (Istwertübergabe) in den jeweiligen UserPrmData projektiert werden. Dabei ist darauf zu achten, dass TO > TDX und TI < (TDP - TDX) gilt. Die Zykluszeit der Applikations-Task (TRT) muss kleiner als die PROFIBUS-Zykluszeit TCYC sein, die im System-Manager berechnet und von der FC310x gemessen wird. Um die Dauer der MC-Telegramme im PROFIBUS-Zyklus (TDX) zu bestimmen, sollte vor dem Projektieren der Standard-Slaves im System-Manager die so berechnete Zykluszeit genommen werden.

Die FC310x unterstützt verschiedene Statusvariablen, mit denen überprüft werden kann, ob die verschiedenen Äquidistanz-Parameter richtig eingestellt wurden (im System-Manager auf der Karteikarte Equi-Diag).

Falls einer der Fehlerzähler Sync-Failed-Counter, PLL-Underflow-Counter oder PLL-Overflow-Counter während des Betriebs hochzählt, sollte die Shift-Time vergrößert werden.

Nach dem Ende des PROFIBUS-Zyklusses sendet die Karte in der verbleiben Zeit ggf. noch andere niederpriore Telegramme (StartUp, Diagnose, DPV1, GAP-Update, etc.). Vor jedem Senden prüft die Karte, ob das entsprechende Telegramm bei fehlerfreiem Senden und Empfangen noch in der verbleibenden Zeit gesendet werden kann. Um Schwankungen etwas ausgleichen zu können, kann noch eine Sicherheitszeit (Safety-Time) eingestellt werden (z.B. sollte diese Safety-Time etwas höher sein, wenn bestimmte Geräte ab und zu geschaltet werden)

Falls einer der Fehler-Zähler Time-Control-Failed-Counter oder Time-Control-Missed-Counter während des Betriebs hochläuft, sollte die Safety-Time erhöht werden.

Da die Quarze von PC und FC310x mit der Zeit auseinander laufen, wird der Nachladewert des Echtzeit-Timers auf der FC310x nachgeregelt. Mit der PLL-Sync-Time kann eingestellt werden, bei welcher Abweichung von der TwinCAT-Task und PROFIBUS-Zyklus der Nachladewert des Echtzeit-Timers der FC310x verändert werden kann.

Wenn der max. FCxxxx-Jitter zu groß wird (ca. größer 5) oder die MC-Slaves einen Taktausfall melden (bei TwinCAT: Meldung „LZZ wurde auf 0 gesetzt“ von der NC), sollte die PLL-Sync-Time erhöht werden. Wenn durch Erhöhen der PLL-Sync-Time keine Abhilfe geschafft werden kann, kann der maximal zulässige Jitter noch in den UserPrmData der MC-Slaves erhöht werden.

Grundsätzlich sollte immer zuerst überprüft werden, ob die Busverkablung okay ist, wenn ein Fehler auftritt (wenn alle Boxen melden, dass sie im Datenaustausch sind und sich daran auch nichts ändert, dann kann man davon ausgehen, dass der Bus okay ist, eine Überprüfung der Verkablung kann aber mit einem einfachen Ohm-Meter erfolgen, wenn alle Stationen abgezogen sind -> Überprüfung der PROFIBUS-Verkablung).Im System-Manager kann man eine Übersicht der BoxStates im Diag-Feld des FC310x-Devices bekommen, im Diag-Feld der Box wird dann noch eingetragen, ob fehlerhafte Telegramme oder Wiederholungen zu der entsprechenden Box auftraten.


AX2000-B310

Der Beckhoff AX2000 Antriebsverstärker wird mit verschiedenen (optionalen) Feldbusschnittstellen ausgeliefert. Nachfolgend werden die Einstelldialoge für den AX2000 mit Profibus Interface (Bestellbezeichnung: AX20xx-B310) beschrieben.

Für detaillierte Informationen zur Einbindung und Ansteuerung des Antriebs, siehe: Übersicht, zu finden innerhalb von "TwinCAT PLC Library: IO Functions | AX200x Profibus".


Beckhoff C1200

Die C1200 ist eine passive ISA-Masterkarte für den Beckhoff II/O Lightbus. Sie besitzt keinen eigenen Mikrocontroller für das Telegramm-Handling und wird deshalb nur für die Ausführung von sehr schnellen I/O Tasks mit wenig Prozessdaten verwendet (wie z.B. beim TwinCAT Nockenschaltwerk). Daher unterstützt die C1200 unter TwinCAT nur maximal 2 Telegramme (je 32-Bit), was in der Praxis auf eine Anbindung von 2 Lightbus Modulen hinausläuft.

Kontextmenü

Gerät Löschen... <Entf>

Entfernt die C1200 und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem LWL-Ring.

Gerät Exportieren

Die Gerätekonfiguration kann hierduch in eine *.tce exportiert werden. Später kann sie unter diesem Namen in eine andere System Manager Konfiguration übernommen werden.

Change Id

Hier kann die unter Karteireiter "Allgemein" angegebene Device-ID ("Id' ) geändert werden.

Disabled

Deaktiviert den I/O-Treiber der C1200 in der Konfiguration, ohne die Karte, oder vorhandene Variablenverknüpfungen, zu löschen.

Karteireiter „C1200“

Adresse: Hier kann / muss die Adresse der Karte eingestellt werden. Diese Adresse wird auf der Karte gejumpert und kann folgende Werte annehmen (dazu die entsprechenden Jumperstellungen der Jumper J1 – J6):

  • 0xC8000 00 1000 (Standard)
  • 0xD0000 01 0100
  • 0xD8000 10 0010
  • 0xE0000 11 0001

Suchen: Sucht im Rechner vorhandene C1200 Karten und stellt bei entsprechend gefundener Hardware die Adresse richtig ein.

Diagnose Eingänge

Die Lightbus C1200 Karte verfügt nach dem Einfügen automatisch über Status- bzw. Diagnoseeingänge, die den Zustand der Karte und des LWL-Rings beschreiben:

Variable | Beschreibung
Data 1 |
Data 1 |
State 1 |
State 2 |
Missed Telegram 1 |
Missed Telegram 2 |
Overrun 1 |
Overrun 2 |
CRC Failure 1 |
CRC Failure 2 |

Control Ausgänge

Zusätzlich zu den Statuseingängen besitzt die C1200 natürlich auch noch Daten- bzw. Steuerausgänge für die beiden 32-Bit Telegramme.

Variable | Beschreibung
Data 1 |
Data 2 |
Ctrl 1 |
Ctrl 2 |


Beckhoff FC310x

Die FC310x unterstützt die PROFIBUS-Protokolle PROFIBUS-DP (als Master, Slave und Multi-Slave), PROFIBUS-DPV1 (als Master) und PROFIBUS-MC (als Master), d.h. entsprechenden Teilnehmer können im sogenannten Äquidistanz-Modus betrieben werden. In diesem Modus ist eine Antriebsregelung über den Bus möglich, da sowohl die Sollwertvorgabe als auch die Istwerterfassung in einem festen Zeitraster erfolgt (-> Eigenschaften der FC310x).

Kontextmenü

Box Anfügen... <Einfg>

Fügt Profibus Slaves (Boxen) an. Die Reihenfolge der angefügten Boxen entspricht der Reihenfolge, in der die einzelnen Slaves zyklisch gepollt werden.

Eine detaillierte Liste aller unterstützten Boxen finden sie unter: Übersicht

Gerät Löschen... <Entf>

Entfernt die FC310x Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf dem Profibus.

Karteireiter "FC3100"

PCI Slot/Irq: Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde und welcher IRQ ihr zugewiesen wurde. Der IRQ wird nicht benutzt.

Search...: Hierüber werden alle gesteckten FC310x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC3102 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC3101-Karten verhalten.

Hardware-Configuration...: Hiermit wird die Hardware-Version der FC310x angezeigt.

Upload Configuration...: Hiermit wird der PROFIBUS gescannt und alle gefunden Geräte werden dem Device hinzugefügt (es darf keine Box angefügt sein). Bei Beckhoff-Boxen wird die Konfiguration genau ausgelesen, bei Fremdgeräten wird versucht, die zugehörige GSD-Datei zu finden (im Unterverzeichnis Profibus des Verzeichnisses, in dem sich der System-Manager befindet).

Firmware: Hier wird die aktuelle Firmware-Version der FC310x angezeigt.

Firmware Update...: Hierüber kann die Firmware der FC310x-Karte aktualisiert werden.

Stations-No.: Jeder Profibusteilnehmer benötigt eine eindeutige Stations-Nr. - auch der Master.

Baudrate: Hier wird die Profibus Baudrate eingestellt. Es wird automatisch überprüft ob die angeschlossenen Slaves diese Baudrate auch unterstützen.

Operation Mode: Bei allen drei Betriebsarten übernimmt die höchstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, die Ansteuerung des PROFIBUS-Zyklus und ist somit mit dem Feldbus synchronisiert. Alle anderen Tasks werden asynchron über entsprechende Puffer bedient. Der Jitter des PROFIBUS-Zyklusses entspricht dem Jitter der höchstprioren Task. Bei den äquidistanten Betriebsarten (DP (Equidistant/ no GC) bzw. DP/MC (Equidistant)) wird der PROFIBUS-Zyklus von einem Echtzeit-Timer auf der FC310x-Karte gesteuert, wodurch der maximale Jitter auf ca. 1 µs begrenzt ist. Bei der Betriebsart DP/MC wird am Anfang des Zyklusses ein Global_Control-Broadcast-Telegramm gesendet, mit dem sich die Slave-Zyklen auf den Master-Zyklus synchronisieren können (PROFIBUS MC).

Bei allen Betriebsarten kann je Slave eine Poll-Rate eingestellt werden (im Profibus-Reiter der jeweiligen Box). Der I/O-Access-Divider gibt dabei an, in jedem wievielten Zyklus der Slave gepollt werden soll, mit dem Modulo können Slaves, die den gleichen I/O-Access-Divider haben, auf verschiedene Zyklen aufgeteilt werden, um den Buszyklus zu optimieren. Die Reihenfolge der Slaves im PROFIBUS-Zyklus entspricht der Reihenfolge, in der sie in dem Baum unter dem Device hängen.

Sync-Mode: Hiermit kann eingestellt werden, ob sich TwinCAT auf den Echtzeit-Timer der FC310x-Karte (Master, geringer Jitter auf dem PROFIBUS) oder die FC310x-Karte auf TwinCAT (Disabled, mehrere FC310x-Kanäle können miteinander synchronisiert werden) synchronisiert.

Bei den äquidistanten Betriebsarten sind weitere Parameter einzustellen:

NC-Access-Time: Hier ist wird die Zugriffszeit der höchstprioren Task anzugeben, die sich aus der maximalen Mapping-Zeit (falls IO am Taskanfang nicht angewählt ist, muss die Tasklaufzeit auch mit berücksichtigt werden (ist beim Karteireiter Equi-Diag der Fall) und geht die Task-Laufzeit in die Messung der Mapping-Zeit mit ein) und dem maximalen TwinCAT-Jitter zusammensetzt (s. Karteireiter Equi-Diag).

PLL-Sync-Time (nur bei Sync-Mode = disabled): Da der Echtzeit-Timer der Karte und die höchstpriore TwinCAT-Task mit der Zeit auseinander laufen, muss der Echtzeit-Timer der Karte nachgeregelt werden. Die PLL-Sync-Time gibt die Intervalle an, bei deren Überschreiten der Differenz der Echtzeit-Timer der Karte nachgeregelt wird. Eine kleine PLL-Sync-Time bewirkt dabei ein stärkeres Schwingen der Zykluszeit des Echtzeit-Timers der Karte, was einen größeren Jitter zur Folge hat.

Safety-Time: Ruhezeit auf dem Bus vor dem Start des nächsten Zyklusses.

Cycle-Time: Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt .

Watchdog-Time: Hier kann ein Watchdog auf der FC310x enabled werden, der den PC überwacht (z.B. im falle eines Blue-Screens) .

Estimated Cycle: Hier wird die voraussichtliche PROFIBUS-Zykluszeit angezeigt.

Karteireiter "Profibus"

Die hier einzustellenden Parameter sind in der PROFIBUS-Norm (DIN 19245 Teil 3 - PROFIBUS-DP), Kapitel 7 beschrieben und sollten nur von sachkundigen Benutzern verändert werden.

GAP-Update: Das GAP-Update, mit dem alle Stationen bis zur HSA ab und zu angefragt werden, ob sie vorhanden sind, kann ein- oder ausgeschaltet werden. Das GAP-Update ist nur bei Multi-Master-Betrieb von Bedeutung, bei Single-Master-Betrieb hat es zur Folge, dass der Jitter des PROFIBUS-Zyklusses größer ist, daher ist es defaultmäßig ausgeschaltet.

PROFIBUS-Mode: Hier kann die Master-Funktionalität (Standard) oder die Slave (Standard-Slave-Funktionalität, ab Version 1.x) ausgewählt werden.

Für die Slave-Funktionalität ist wie folgt vorzugehen:

  1. Auf dem Reiter Profibus den PROFIBUS-Mode Slave bzw. Master/Slave einschalten
  2. Auf dem Reiter FC3100 die Stationsadresse des Slaves einstellen
  3. Für die Slave-Funktionalität eine GSD-Box anfügen und die GSD-Datei TCDPSLAV.gsd auswählen
  4. Beliebige Module anfügen, wobei darauf zu achten ist, dass genauso viele Inputs wie Outputs ausgewählt werden
  5. Im Gegensatz zu anderen Slaves unterstützt die Slave-Funktionalität der FC310x keine automatische Baudratenerkennung, daher muss darauf geachtet werden, dass die Baudrate richtig eingestellt ist

Beim Speichern des Projektes in der Registry wird die GSD-Datei TCDP310X.GSD erzeugt, die die aktuellen Einstellungen für den FC310x-Slave beinhaltet, und die auf der Master-Seite eingebunden werden kann.

Karteireiter "ADS"

Die FC310x ist ein ADS-Device mit einer eigenen Net-ID, die hier verändert werden kann. Alle ADS-Dienste (Diagnose, azyklische Kommunikation), die an die FC310x gehen, müssen diese Net-ID adressieren.

Karteireiter "General Diag"

Auf diesem Karteireiter werden Busphysikprobleme und DP-Zyklus-Statistiken angezeigt

detected bus-errors: Hier wird die Anzahl der festgestellten Busfehler angezeigt.

detected bus-errors/sec.: Hier wird die Anzahl der festgestellten Busfehler pro Sekunde angezeigt.

CycleWithRepeatCounter: Hier wird angezeigt, in wie vielen DP-Zyklen mindestens ein Telegramm wiederholt wurde (zählt nicht hoch, wenn der Slave gar nicht mehr antwortet)

Max. Repeat/Cycle: Hier wird die maximale Anzahl von Wiederholungen in einem DP-Zyklus angezeigt.

Max. Cycle-Time: Hier wird die maximale DP-Zykluszeit angezeigt (sie wird nur berechnet, wenn alle DpStates 0 waren und keine Wiederholungen auftraten)

Min. Cycle-Time: Hier wird die minimale DP-Zykluszeit angezeigt (sie wird nur berechnet, wenn alle DpStates 0 waren und keine Wiederholungen auftraten)

actual Cycle-Time: Hier wird die aktuelle DP-Zykluszeit angezeigt (sie wird nur berechnet, wenn alle DpStates 0 waren und keine Wiederholungen auftraten)

CycleWithNoDxchCounter: Hier wird die Anzahl der Zyklen hochgezählt, in denen mindestens ein Slave ein DpState ungleich 0 hatte.

Karteireiter "Diag oder Box States"

Hier wird eine Übersicht aller aktuellen Box-States, aller RepeatCounter (zeigt wie Telegramme zu dem entsprechenden Slave wiederholt werden mussten) sowie aller NoAnswer-Counter (zeigt an, wie oft der Slave nicht geantwortet hat, kann beim Start des Systems immer vorkommen, da die Slaves in der Regel erst die Baudrate finden müssen) angezeigt.

Karteireiter "EquiDiag"

In den äquidistanten Betriebsarten werden hier verschiedene Diagnosevariablen angezeigt:

max. TwinCAT-Jitter: Hier wird der maximale TwinCAT-Jitter in µs angezeigt, der maximale TwinCAT-Jitter ist bei der Einstellung der NC-Access-Time (s.o.) zu berücksichtigen.

max. Mapping-Time/min. Mapping-Time: Die Mapping-Time bezeichnet die Zeit zwischen dem Synchronisations-Interrupt, den TwinCAT auf der FC310x auslöst und Freischalten der Ausgänge, die maximale Mapping-Time ist bei der Einstellung der NC-Access-Time (s.o.) zu berücksichtigen.

max. FCxxxx-Jitter (nur bei Sync-Mode = disabled): hier wird der maximale Jitter der FC310x in Ticks (4/25 µs) angegeben.

Sync-Failed-Counter: zählt hoch, wenn der Echtzeit-Timer auf der Karte den PROFIBUS-Zyklus startet, die Outputdaten aber von der TwinCAT-Task noch nicht freigegeben wurden (die NC-Access-Time ist zu klein eingestellt)

Time-Control-Failed-Counter: zählt hoch, wenn beim Start des PROFIBUS-Zyklusses der Bus nicht frei war (Stationen sind projektiert, die am Bus nicht antworten oder Cycle-Time ist zu klein (< Estimated Cycle-Time))

PLL-Overflow-Counter (nur bei Sync-Mode = disabled): zählt hoch, wenn die beiden Timer (Echtzeit-Timer auf der Karte und TwinCAT-Timer zu weit auseinander gelaufen sind, die NC-Access-Time ist zu klein oder die PLL-Sync-Time zu groß)

PLL-Underflow-Counter (nur bei Sync-Mode = disabled): zählt hoch, wenn die beiden Timer (Echtzeit-Timer auf der Karte und TwinCAT-Timer zu weit auseinander gelaufen sind, die NC-Access-Time ist zu klein oder die PLL-Sync-Time zu groß)

CycleWithRepeatCounter: Hier wird angezeigt, in wie vielen DP-Zyklen mindestens ein Telegramm wiederholt wurde (zählt nicht hoch, wenn der Slave gar nicht mehr antwortet)

Max. Repeat/Equi-Cycle, max. Equi-Cycle, min. Equi-Cycle, EquiCycleRepeat-Counter, EquiCycleNoDxch-Counter: s. Karteireiter GeneralDiag Max. Repeats/Cycle, Max. Cycle-Time, Min. Cycle-Time, CycleWithRepeat-Counter, CycleWithNoDxch-Counter, wobei hier nur die MC-Slaves berücksichtigt werden

calc. To-Reserve: Hier wird die berechnete To-Reserve für die MC-Slaves angegeben

max. To-Reserve: Hier wird die maximale, gemessene To-Reserve für die MC-Slaves angegeben

min. To-Reserve: Hier wird die minimale, gemessene To-Reserve für die MC-Slaves angegeben

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs".

Diagnose Eingänge

Die FC310x verfügt automatisch über verschiedene Diagnosevariablen, die den Zustand der Karte und des Profibusses beschreiben:

CdlInfo:

CdlInfo.error: Zeigt die Anzahl der Slaves an, mit denen kein Datenaustausch im letzten Zyklus durchgeführt werden konnte, nur wenn dieser Wert ungleich 0 ist, muss der BoxState der Slaves überprüft werden

CdlInfo.cycleCounter: wird am Ende jedes PROFIBUS-Zyklusses inkrementiert, so dass man mit dieser Variable feststellen kann, ob der letzte Zyklus beendet war, bevor die Task gestartet wurde

CdlInfo.actualCycleTime: zeigt die aktuelle Zykluszeit in 4/25 µs an, diese Variable wird nur aktualisiert, falls alle Slaves im Datenaustausch sind (also CdlInfo.error gleich 0 ist)

Debug: interne Informationen

DiagFlag: Zeigt an, ob sich die Diagnoseinformationen der Karte geändert haben, die dann mit ADS-Read ausgelesen werden können. Dazu ist die Net-ID der FC310x, die Port-Nummer 200 und die IndexGroup 0xF100 anzugeben. Der IndexOffset und die Länge beziehen sich dann auf die Diagnosedaten.

Offset 0-125: BusStatus-Liste, je Stationsadresse 0-125 ein Byte, das den Status der Station enthält (s. BoxState bei den PROFIBUS-Boxen, zusätzlich für nicht projektierte Stationen: 0x80 - nicht vorhanden, 0x81 - Slave, 0x82 - Master nicht bereit für Token-Ring, 0x83 - Master bereit für Token-Ring, 0x84 - Master im Token-Ring)

Offset 126-127: reserviert

Offset 128-135: Zustand der FC310x (->GlobalState)

Offset 136-137: Sende-Fehler-Zähler über alle gesendeten Telegramme
Offset 138-139: Empfangs-Fehler-Zähler über alle empfangenen Telegramme

Offset 140-255: reserviert für Erweiterungen
Offset 256-257: Sync-Failed-Counter (s. Karteireiter Equi-Diag)
Offset 258-259: Zyklus-Start-Fehler-Zähler, zählt hoch, wenn der PROFIBUS-Zyklus erneut gestartet wird bevor der alte Zyklus beendet wurde (wird vom TwinCAT-IO-Treiber abgefangen, nur bei kundenspezifischen Treibern möglich)
Offset 260-261: Time-Control-Failed-Counter (s. Karteireiter Equi-Diag)
Offset 262-263: reserviert für Erweiterungen
Offset 264-265: minimaler Nachladewert des Echtzeittimers
Offset 266-267: maximaler Nachladewert des Echtzeittimers (max. FCxxxx-Jitter (s. Karteireiter Equi-Diag) = max. Nachladewert - min. Nachladewert)
Offset 268-269: PLL-Overflow-Counter (s. Karteireiter Equi-Diag)
Offset 270-271: PLL-Underflow-Counter (s. Karteireiter Equi-Diag)

GlobalState: GlobalState[0] gibt den Zustand der FC310x an, GlobalState[1-3] sind reserviert für Erweiterungen:

RESET (1): Router der Karte wurde nicht gestartet (nach dem Hochlauf des PCs)

INIT (2): Router gestartet, Karte aber nicht am PROFIBUS aktiv

STOP (3): Karte am PROFIBUS aktiv, aber kein zyklischer Datenaustausch

STOPPING (4): Karte beendet den zyklischen Datenaustausch

RUN (0): Karte im zyklischen Datenaustausch

GlobalState[1] zählt die festgestellten Bus-Errors (ab FC310x, Version 1)

GlobalState[2] enthält die Betriebsart CLEAR (Bit 1 = 1) oder OPERATE (Bit 1 = 0), die anderen Bits (0, 2..7) sind reserviert für Erweiterungen (ab FC310x, Version 1)

LastAdsError: Wenn der Hochlauf der Karte nicht klappt, erscheint in der Regel immer eine MessageBox mit der Fehlermeldung "Fehler beim Init6 "SetDeviceState" mit einem ADS-Fehlercode". Da dieser Code relativ allgemeingültig ist, wird in der Variablen LastAdsError ein eindeutiger Fehlercode angezeigt.

CycleFailedCounter: Dieser Zähler zeigt an, wie oft beim Start der TwinCAT-Task der PROFIBUS-Zyklus der FC310x noch nicht fertig war.


Error-Codes der FC310x

Fehlercode | Bedeutung
0x1129 | IndexOffset zu groß beim Lesen der FC310x-Diagnosedaten
0x112B | IndexOffset zu groß beim Lesen der Slave-Diagnosedaten
0x112D | ungueltige Stationsadresse beim Lesen der Slave-Diagnosedaten
0x2023 | ungültiger IndexOffset beim Rücksetzen der FC310x-Diagnosedaten
0x2024 | ungültige Daten beim Rücksetzen der FC310x-Diagnosedaten
0x2025 | ungültige Datenlänge beim Rücksetzen der FC310x-Diagnosedaten
0x2101 | DPV1-Read: zyklische Verbindung zu Slave noch nicht aufgebaut
0x2102 | PKW-Read: nur die Datenlängen 2 und 4 sind erlaubt
0x2103 | PKW-Read: Slave nicht im Datenaustausch
0x2105 | PKW-Read: Slave unterstuetzt kein PKW
0x2106 | PKW-Read: falscher IndexOffset
0x2107 | PKW-Read: falsche IndexGroup
0x2109 | DPV1-Read: FDL-Fehler (antwortet nicht, etc.)
0x210A | DPV1-Read: Syntax-Fehler (DPV1-Syntax nicht korrekt)
0x210B | DPV1-Read: DPV1-Fehler (4 Byte Fehlercode in den Diagnosedaten des Slave)
0x210F | DPV1-Write: zyklische Verbindung zu Slave noch nicht aufgebaut
0x2110 | PKW-Write: nur die Datenlaengen 2 und 4 sind erlaubt
0x2111 | PKW-Write: falscher Index-Offset
0x2112 | PKW-Write: Slave unterstuetzt kein PKW
0x2113 | PKW-Write: falsche IndexGroup
0x2114 | Read allgemein: falsche indexGroup
0x2115 | DPV1-Write: FDL-Fehler (antwortet nicht, etc.)
0x2116 | DPV1-Write: Syntax-Fehler (DPV1-Syntax nicht korrekt)
0x2117 | DPV1-Write: DPV1-Fehler (4 Byte Fehlercode in den Diagnosedaten des Slave)
0x211C | Read allgemein: falsche indexGroup
0x211D | SetSlaveAdress: falscher IndexOffset
0x211E | FDL-AGAG-Write: falscher IndexOffset
0x211F | FDL-AGAG-Read: falscher IndexOffset
0x2120 | FDL-AGAG-Write: falsche Laenge
0x2121 | SetSlaveAddress: falsche Laenge
0x2122 | FDL-AGAG-Read: falsche Laenge
0x2131 | Write allgemein: falsche indexGroup
0x2132 | Write allgemein: falsche indexGroup
0x2137 | PKW-Read: Datenlaenge bei AK 1 ist falsch
0x2138 | PKW-Read: Datenlaenge bei AK 2 ist falsch
0x2139 | PKW-Read: nicht AK 1 oder 2 oder 7 empfangen bei Lesen eines einfachen Parameters
0x213A | PKW-Read: Datenlaenge bei AK 4 ist falsch
0x213B | PKW-Read: Datenlaenge bei AK 5 ist falsch
0x213C | PKW-Read: nicht AK 4 oder 5 oder 7 empfangen bei Lesen eines Array-Parameters
0x213D | PKW-Write: nicht AK 2 oder 7 empfangen bei Schreiben eines Array-DWORD-Parameters
0x213E | PKW-Write: nicht AK 1 oder 7 empfangen bei Schreiben eines WORD-Parameters
0x213F | PKW-Write: nicht AK 2 oder 7 empfangen bei Schreiben eines DWORD-Parameters
0x2140 | PKW-Write: nicht AK 1 oder 7 empfangen bei Schreiben eines Array-WORD-Parameters
0x2142 | SetSlaveAddress: falscher Parameter beim Setzen der Adresse im Slave-Mode
0x2600-0x26FF | AK 7 (Fehler) bei PKW-Bearbeitung erhalten, Fehlercode in Lo-Byte
0x2700-0x27FF | Fehler bei DPV1-Bearbeitung, 4 Bytes Fehlercode in den Slave-Diagnosedaten, Byte 3 des Fehlercodes (Error-Class, Error-Code) steht in Lo-Byte


ADS-Interface

Sämtliche azyklischen Daten werden mit ADS-Read, ADS-Write oder ADS-Write-Control an die bzw. von der FC310x übertragen. Die FC310x hat eine eigene Net-ID und unterstützt die folgenden Ports:

Port | Beschreibung
200 | damit wird die FC310x selbst adressiert, d.h. Daten, die lokal auf der FC310x liegen, bei denen in der Regel kein zusätzlicher Buszugriff nötig ist
0x1000 - 0x107E | damit wird ein angeschlossener PROFIBUS-Teilnehmer adressiert, wobei sich Adresse aus Port-0x1000 berechnet, es wird auch immer ein Buszugriff durchgeführt

ADS-Read

Es folgt eine Übersicht der von der FC310x unterstützten IndexGroup/IndexOffset bei ADS-Read.

IndexGroup bei lokaler Adressierung der FC310x (Port 200)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Beschreibung
0xF100 | 0x00 | BYTE-Offset innerhalb der Daten | Damit werden die Diagnosedaten der FC310x ausgelesen. Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, enthalten die Daten die im Kapitel PROFIBUS-DP beschriebenen Diagnosedaten der FC310x. Die FC310x setzt dabei das DiagFlag der FC310x zurück, das dann wieder gesetzt wird, wenn sich die Diagnosedaten der FC310x erneut ändern.
0xF181 | 0x00-0x7E | BYTE-Offset innerhalb der Daten | Damit werden die Diagnosedaten eines projektierten DP-Slaves ausgelesen, die Stationsadresse berechnet sich aus dem IndexGroup(Hi-Word). Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, enthalten die Daten die im Kapitel PROFIBUS-DP-Slaves beschriebenen Diagnosedaten eines projektierten DP-Slaves.
0xF830 | 0x8000-0x807E | immer 0 | Damit kann festgestellt werden, welche DP-Slaves am PROFIBUS vorhanden sind, unabhängig davon, ob sie projektiert wurden oder nicht, die Stationsadresse berechnet sich aus IndexGroup(Hi-Word)-0x8000. Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, hat der entsprechende DP-Slave korrekt geantwortet, die Daten enthalten die Ident-Nummer des Slaves (BYTE-Offset 0-1) und die ausgelesenen CfgData (ab BYTE-Offset 2).
0xF840 | 0 | BYTE-Offset innerhalb der Daten | Damit werden Firmware-Version und Stationsadresse der FC310x ausgelesen. Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, enthalten die Daten die Firmware-Version (BYTE-Offset 0-1) und die Stationsadresse der FC310x (BYTE-Offset 2).

IndexGroup bei Adressierung eines projektierten PROFIBUS-Teilnehmer (Port 0x1000-0x107E)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Beschreibung
0x00-0xFF | 0x00 | 0x00-0xFF | Damit wird ein DPV1-Read an den entsprechenden, projektierten DPV1-Slave über eine Class 1-Verbindung gesendet, die DPV1-Slot-Nummer entspricht der IndexGroup, der DPV1-Index entspricht dem IndexOffset. Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, enthalten die Daten die ausgelesenen DPV1-Daten (-> Kapitel PROFIBUS-DP-Slaves)
0x100-0x1FF | 0x00 | 0x00-0xFF | Damit wird ein DPV1-Read an den entsprechenden, projektierten DPV1-Slave über eine Class 2-Verbindung gesendet, die DPV1-Slot-Nummer entspricht der IndexGroup - 0x100, der DPV1-Index entspricht dem IndexOffset. Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, enthalten die Daten die ausgelesenen DPV1-Daten (-> Kapitel PROFIBUS-DP-Slaves)
0x0000 - 0xFFF | 0x10000000 - 0xF0000000 | 0x00-0xFF | Damit wird ein PKW-Read an den entsprechenden, projektierten PROFIDRIVE-Slave gesendet, die Parameternummer (PNU) steht im Lo-Word der IndexGroup, der Sub-Index bei Zugriff auf ein Array steht im IndexOffset, die angesprochene Achse steht in den Bits 28-31 der IndexGroup (bei einem 1-Achser muss hier eine 1 stehen), in Bit 26,27 kann noch die PKW-Kompatibilität angepasst werden (leider sind nicht alle PROFIDRIVE-Slaves hier kompatibel, -> Kapitel PROFIBUS-DP-Slaves).
0 | 0x01000000 | 0 | Damit wird FDL-Read für die Siemens AG-Kopplung an die entsprechende projektierte FDL-Station gesendet.

ADS-Write

Es folgt eine Übersicht der von der FC310x unterstützten IndexGroup/IndexOffset bei ADS-Write.

IndexGroup bei lokaler Adressierung der FC310x (Port 200)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Beschreibung
0xF100 | 0x00 | 0 -2 | Damit werden die Equidistant-Diagnosedaten (IndexOffset = 0), die Repeat-Counter (IndexOffset = 1) oder die NoAnswer-Counter (IndexOffset = 2) der FC310x zurückgesetzt.

IndexGroup bei Adressierung eines projektierten PROFIBUS-Teilnehmer (Port 0x1000-0x107E)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Beschreibung
0x00-0xFF | 0x00 | 0x00-0xFF | Damit wird ein DPV1-Write an den entsprechenden, projektierten DPV1-Slave über eine Class 1-Verbindung gesendet, die DPV1-Slot-Nummer entspricht der IndexGroup, der DPV1-Index entspricht dem IndexOffset (-> Kapitel PROFIBUS-DP-Slaves).
0x100-0x1FF | 0x00 | 0x00-0xFF | Damit wird ein DPV1-Write an den entsprechenden, projektierten DPV1-Slave über eine Class 2-Verbindung gesendet, die DPV1-Slot-Nummer entspricht der IndexGroup - 0x100, der DPV1-Index entspricht dem IndexOffset (-> Kapitel PROFIBUS-DP-Slaves).
0x0000 - 0xFFF | 0x10000000 - 0xF0000000 | 0x00-0xFF | Damit wird ein PKW-Write an den entsprechenden, projektierten PROFIDRIVE-Slave gesendet, die Parameternummer (PNU) steht im Lo-Word der IndexGroup, der Sub-Index bei Zugriff auf ein Array steht im IndexOffset, die angesprochene Achse steht in den Bits 28-31 der IndexGroup (bei einem 1-Achser muss hier eine 1 stehen), in Bit 26,27 kann noch die PKW-Kompatibilität angepasst werden (leider sind nicht alle PROFIDRIVE-Slaves hier kompatibel, -> Kapitel PROFIBUS-DP-Slaves).
0 | 0x01000000 | 0 | Damit wird FDL-Write für die Siemens AG-Kopplung an die entsprechende projektierte FDL-Station gesendet.
0 | 0x02000000 | 0 | Damit wird ein SetSlaveAddress-Kommando an einen projektierten DP-Slave gesendet, wobei der DP-Slave mit der neuen Stationsadresse projektiert werden mus, die alte Stationsadresse ist dann am BYTE-Offset 0 der ADS-Write-Daten einzutragen. Weiterhin muss unter BYTE-Offset 1 und 2 die Ident-Nummer des Slaves stehen und unter BYTE-Offset 3, ob die Slave später noch einmal geändert werden darf (0) oder nicht (ungleich 0). Insgesamt sind also 4 Bytes ADS-Write-Daten zu übergeben.

ADS-WriteControl

Es folgt eine Übersicht der von der FC310x unterstützten ADS-Write-Control-Kommandos.

ADS-WriteControl bei lokaler Adressierung der FC310x (Port 200)

AdsState | DeviceState | State der FC310x | Beschreibung
STOP (6) | 0x00 | RUN (5) | Damit wird die FC310x gestoppt, d.h. die Prozessdatenverbindungen zu allen DP-Slaves (Data_Exchange) werden abgebaut (mit SetPrm,Unlock).
RUN (5) | 0x00 | STOP (6) | Damit wird die FC310x nach einem Stoppen erneut gestartet, d.h. die Prozessdatenverbindungen zu allen DP-Slaves (Data_Exchange) werden wieder aufgebaut (normaler DP-Hochlauf).

ADS-WriteControl bei Adressierung eines projektierten PROFIBUS-Teilnehmer (Port 0x1000-0x107E)

AdsState | DeviceState | State der FC310x | Beschreibung
STOP (6) | 0x00 | RUN (5) | Damit wird der Slave gestoppt, d.h. die Prozessdatenverbindung zu dem entsprechenden DP-Slave (Data_Exchange) wird abgebaut (mit SetPrm,Unlock).
RUN (5) | 0x00 | STOP (6) | Damit wird der Slave nach einem Stoppen erneut gestartet, d.h. die Prozessdatenverbindung zu dem entsprechenden DP-Slave (Data_Exchange) wird wieder aufgebaut (normaler DP-Hochlauf).

ADS-Fehlercodes

Der 32-Bit-ADS-Fehlercode besteht immer aus einem allgemeinen ADS-Fehlercode (Lo-Word, siehe ADS-Dokumentation) und einem FC310x-spezifischen, eindeutigen Fehlercode (Hi-Word, -> Kapitel FC310x-ADS-Fehlercodes). Die entsprechende Meldung wird auch im Logger des TwinCAT System Managers textuell angezeigt.


DP-State der Slaves

Wert | Beschreibung
0 | No Error - Station ist im Datenaustausch
1 | Station deactivated - Slave wurde deaktiviert, tritt zur Zeit nur temporär beim Hochlauf auf
2 | Station not exists - Slave antwortet nicht am Bus -> Prüfen, ob Slave eingeschaltet, ob PROFIBUS-Stecker angeschlossen, ob Stationsadresse korrekt oder ob Busverkablung korrekt
3 | Master lock - Slave ist mit anderem Master im Datenaustausch -> anderen Master vom Bus nehmen oder Slave mit anderem Master wieder freigeben
4 | Invalid slave response - falsche Antwort des Slaves, tritt temporär auf, wenn Slave aufgrund eines lokalen Ereignisses den Datenaustausch beendet hat
5 | Parameter fault - Parametrierungsfehler -> Prüfen, ob Buskoppler bzw. GSD-Datei korrekt, ob Stationsadresse korrekt oder ob UserPrmData-Einstellungen korrekt
6 | Not supported - DP-Funktion wird nicht unterstützt -> Prüfen, ob GSD-Datei korrekt oder ob Stationsadresse korrekt
7 | Config fault - Konfigurationsfehler -> Prüfen, ob die angefügten Klemmen bzw. Module korrekt sind
8 | Station not ready -> Station im Hochlauf, wird während des Hochlaufs temporär angezeigt
9 | Static diagnosis - Slave meldet statische Diagnose und kann zur Zeit keine gültigen Daten liefern -> Betriebszustand am Slave prüfen
10 | Diagnosis overflow - Slave meldet einen Diagnose-Überlauf -> Diagnosedaten (mit ADS-Read, s.u.) und Betriebszustand am Slave prüfen
11 | Physical fault - physikalischer Fehler bei Antwort eines Slaves -> Verkablung prüfen
13 | Severe Bus fault - schwerer Busfehler -> Verkablung prüfen
14 | Telegram fault - Slave antwortet mit einem ungültigen Telegramm -> darf nicht auftreten
15 | Station has no ressources -> Slave hat nicht genügend Ressourcen für das Telegramm -> Prüfen, ob GSD-Datei korrekt
16 | Service not activated -> temporärer Fehler, falls Slave aufgrund eines lokalen Ereignisses den Datenaustausch beendet, oder prüfen, ob DP-Funktionalität beim Slave disabled ist
17 | Unexpected telegram -> unerwartetes Telegramm, kann temporär auftreten, falls zwei PROFIBUS-Netze zusammengesteckt werden oder prüfen, ob Buszeiten bei zweitem Master gleich eingestellt sind.
18 | Station ready -> tritt temporär beim Hochlauf auf und solange die Task noch nicht gestartet ist
128 | FC310x in Slave-Mode, waiting for data transfer -> Slave wurde parametriert und konfiguriert hat aber noch keine Data_Exchange-Telegramm empfangen
129 | FC310x in Slave-Mode, waiting for configuration -> Slave wurde parametriert, hat aber noch kein Chk_Cfg-Telegramm empfangen
130 | FC310x in Slave-Mode, waiting for parameter -> Slave wurde noch nicht parametriert, wartet auf Set_Prm (Lock)-Telegramm


Hardware-Beschreibung

Eine FC3102 Profibus Feldbuskarte verhält sich logisch wie zwei FC3101-Karten, d.h. alle Komponenten (mit Ausnahme des PCI-Interfaces und des optionalen NOV-RAMs) sind auf der FC3102-Karte doppelt vorhanden. Jeder Kanal der FC310x-Karte besteht aus den folgenden Komponenten:

- 80165-Mikrocontroller mit 25 MHz

- 512k RAM

- 256k Flash

- 4k DP-RAM

- Feldbus-Interface (Altera 6016 mit 48 MHz, RS485-Busanschaltung, 9-poliger SUB-D-Stecker)

- 2 LEDs (1 x grün, 1 x rot)

- 1 vierpoliger und ein zweipoliger Stecker für den Bootstrap-Lademodus

Die folgenden Komponenten sind nur einfach vorhanden:

- PCI-Interface (PLX9050: je Kanal ein Interrupt-Eingang, ein Interrupt-Ausgang sowie ein Chip-Select-Signal zum DP-RAM und eine Reset-Leitung für beide Kanäle)

- optional sind 32k NOV-RAM bestückbar, die über eine weitere Chip-Select-Leitung adressiert werden

Bedeutung der LEDs

Zustand der FC310x | Anzeige der LEDs
RESET, OFFLINE | rote LED an, grüne LEDs aus
STOP | grüne LED aus, rote LED blinkt (mit 10 Hz) während Upload der Bus-Konfiguration läuft: grüne und rote LED blinken (mit 10Hz)
RUN | wenn zugehörige TwinCAT-Task gestartet wurde ist die grüne LED an, sonst ist blinkt die grüne LED (mit 1 Hz) wenn alle Boxen fehlerfrei ist die rote LED aus, sonst blinkt die rote LED (mit 1 Hz)

Zustände der FC310x

RESET, OFFLINE

Nach dem Power-On ist die FC310x im Zustand RESET, sie verläßt den Zustand RESET durch den Start von TwinCAT, nach dem Stop von TwinCAT (oder einem schwerem Busfehler) geht sie in den Zustand OFFLINE. Im Zustand OFFLINE ist die FC310x nicht am Bus aktiv.

STOP

Nach dem Start von TwinCAT oder beim Auslesen der Bus-Konfiguration aus dem System-Manager geht die FC310x in den Zustand STOP, in dem sie am Bus aktiv ist, aber noch keinen Datenaustausch (Data_Exchange) mit der DP-Slaves durchführt. Während des TwinCAT-Starts oder auch während eines IO-Resets ist die FC310x im Zustand STOP, der Zustand STOP wird sowohl beim TwinCAT-Start als auch beim IO-Reset automatisch verlassen und die FC310x geht in den Zustand RUN über.

RUN

Im Zustand RUN baut die FC310x automatisch die DP-Verbindungen mit allen projektierten DP-Slaves auf. Sobald die zugehörige TwinCAT-Task gestartet wurde, kommuniziert sie mit den DP-Slaves per Data_Exchange, solange die zugehörige TwinCAT-Task noch nicht gestartet wurde, fragt sie nur die Diagnose ab. Wenn die zugehörige Task gestoppt wird (z.B. PLC-STOP, Breakpoint in der PLC), geht die FC310x automatisch in den CLEAR-Mode (Ausgänge auf 0 bzw. es wird slavespezifisch reagiert, wenn dieser den FailSafe-Mode unterstützt). Wenn die zugehörige Task wieder läuft, geht die FC310x wieder automatisch in den OPERATE-Mode (alle Ausgänge auf den von TwinCAT gesetzten Werten).


Beckhoff FC310x als PROFIBUS-Monitor

Die FC3101 bzw. FC3102 kann ab Firmware-Version 1.60 statt als Master oder Slave auch als PROFIBUS-Monitor eingesetzt werden. Die von der FC310x aufgezeichneten Telegramme werden von der mit der FC310x verknüpften Task in einem Ring-Puffer zwischengespeichert, auf die gespeicherten Telegramme kann dann per ADS zugegriffen werden. Es gibt ein PROFIBUS-Monitor-Programm von Beckhoff als Share-Ware, mit der im Folgenden beschriebenen ADS-Schnittstelle können aber auch eigene Anwendungen auf die Monitor-Daten zugreifen.

Verknüpfen der FC310x mit einer Task

Der Zugriff auf die Monitor-Daten erfolgt aus der TwinCAT-Echtzeit beim Start einer Task. Daher muß eine zusätzliche Task im System-Manager angelegt werden, die mindestens eine UINT16-Eingangsvariable enthält, die mit einer der Variablen der FC310x zu verknüpfen ist.

Die Verknüpfung dient nur dazu, daß aus der Echtzeit mit der Zykluszeit der Task auf die FC310x zugegriffen werden kann. Die Zykluszeit der zusätzlichen Task ist abhängig von der Baudrate wie folgt einzustellen:

Baudrate | Zykluszeit der zusätzlichen Task
12 MBaud | <= 1 ms
6 MBaud | <= 2 ms
3 MBaud | <= 4 ms
1,5 MBaud | <= 8 ms
500 kBaud | <= 24 ms
187.5 kBaud | <= 60 ms
93.75 kBaud | <= 120 ms
19.2 kBaud | <= 625 ms
9.6 kBaud | <= 1250 ms

Weiterhin ist die Check-Box Auto-Start zu setzen (s. Bild oben).

Karteireiter "Monitor"

PCI Slot/Irq: Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde.

Search...: Hierüber werden alle gesteckten FC310x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC3102 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC3101-Karten verhalten.

Hardware Configuration...: Hier kann die Hardware-Versionsnummer der FC310x angezeigt werden

Firmware: Hier wird die aktuelle Firmware-Version der FC310x angezeigt.

Firmware Update...: Hierüber kann die Firmware der FC310x-Karte aktualisiert werden.

Baudrate: Hier wird die Profibus Baudrate eingestellt.

Ring-Puffer: Hier wird die Größe des Ring-Puffers eingestellt, außerdem ist die Aufzeichnungsdauer für die eingestellte Ring-Puffer-Größe bei voller Buslastung angegeben.

Auto-Start: Wenn die Check-Box Auto-Start angeklickt ist, wird die Monitor-Aufzeichnung beim TwinCAT-Start gestartet, andernfalls muß der Start per ADS erfolgen.

Time-Stamp: Wenn die Check-Box Time-Stamp angeklickt ist, wird am Anfang des Telegramms ein 16-Bit-Zähler (Einheit 1/12µs) gespeichert, der den zeitlichen Anfang eines Telegramms kennzeichnet (erst ab Firmware-Version 2.0)

ADS-Schnittstelle

Im Folgenden ist die ADS-Schnittstelle des FC310x-Monitors beschrieben.

Start der Aufzeichnung

Mit dem folgenden ADS-Write-Kommando wird die Monitor-Aufzeichnung gestartet:

NET-ID: AMS-Net-ID des PCs

PORT: 300

IDXGRP: IndexGroup ist 0x5000 + Id (auf Karteireiter Allgemein des FC310x-Monitors) des FC310x-Monitors

IDXOFFS: IndexOffset ist 0xFFFF1000

LEN: Datenlänge ist 2

DATA: Es ist ein Wort mit dem Wert 1 zu übertragen

Stop der Aufzeichnung

Mit dem folgenden ADS-Write-Kommando wird die Monitor-Aufzeichnung gestoppt:

NET-ID: AMS-Net-ID des PCs

PORT: 300

IDXGRP: IndexGroup ist 0x5000 + Id (auf Karteireiter Allgemein des FC310x-Monitors) des FC310x-Monitors

IDXOFFS: IndexOffset ist 0xFFFF1000

LEN: Datenlänge ist 2

DATA: Es ist ein Wort mit dem Wert 0 zu übertragen

Aufbau des Ring-Puffers

Der Ring-Puffer, in dem die aufgezeichneten Telegramme gespeichert werden, ist in 4 kByte-Pages aufgeteilt. Jede Page ist wie folgt aufgebaut:

Offset | Beschreibung
0x0000 - 0x0FEF | Aufgezeichnete Telegramme (s.u.)
0x0FF0 - 0x0FF3 | reserviert
0x0FF4 - 0x0FF7 | Länge der tatsächlich gelesenen Daten (nur in der ersten gelesenen Page)
0x0FF8 - 0x0FF9 | 1: noch weitere Pages gespeichert, 0: keine weiteren Pages mehr gespeichert
0x0FFA - 0x0FFB | reserviert
0x0FFC - 0x0FFD | Ende der aufgezeichneten Telegramme in dieser Page (zeigt auf die erste Speicherstelle nach dem letzten Telegramm)
0x0FFE - 0x0FFF | Page-Nummer

Lesen der aufgezeichneten Telegramme

Mit dem folgenden ADS-Read-Kommando können die aufgezeichneten Monitor-Telegramme ausgelesen werden:

NET-ID: AMS-Net-ID des PCs

PORT: 300

IDXGRP: IndexGroup ist 0x5000 + Id (auf Karteireiter Allgemein des FC310x-Monitors) des FC310x-Monitors

IDXOFFS: IndexOffset ist 0xFFFF0000 - 0xFFFF1FFF (Bit 0-11: Nummer der ersten zu lesenden Page, Bit 12 = 0: nur volle Pages lesen, Bit 12 = 1: ggf. auch die nicht volle letzte Page lesen)

LEN: Als Datenlänge sind 0x1000 (1 Page), 0x2000 (2 Pages), 0x3000 (3 Pages) oder 0x4000 (4 Pages) erlaubt

DATA: Es werden die entsprechenden Pages geliefert

Telegrammstruktur

Die aufgezeichneten Telegramme sind wie folgt aufgebaut:

Offset | Beschreibung
0-1 | Time-Stamp (in 1/12 µs), falls angewählt
i (i = 0 ohne Time-Stamp, i = 2 mit Time-Stamp) | Telegrammheader (SD1 = 0x10, SD2 = 0x68, SD4 = 0xDC, SD5 = 0xE5)
i+1 | SD1, SD4: DA (Destination Address) SD2: LE (Länge der folgenden Bytes) SD5: egal
i+2 | SD1, SD4: SA (Source Address) SD2: DA (Destination Address) SD5: egal
i+3 | SD1: FC (Function Code) SD2: SA (Source Address) SD4: egal SD5: egal
 | ab Byte 4 nur noch SD2-Telegramme
i+4 | SD2: FC (Function Mode)
i+5 | SD2: wenn DA.7 = 1, dann DSAP sonst wenn SA.7 = 1, dann SSAP sonst erstes DATA-Byte
i+6 | SD2: wenn DA.7 = 1 und SA.7 = 1 dann SSAP sonst wenn SA.7 = 1 dann erstes DATA-Byte sonst zweites DATA-Byte
.. |
i + LE + 1 | letztes DATA-Byte


PKW-Interface von PROFIDRIVE-Slaves

Das PKW-Interface ist in der FC310x (ab Version 1.3B) integriert, es kann dann aus der PLC oder jedem anderen TwinCAT-Programm per ADS darauf zugegriffen werden. Dazu sind die folgenden ADS-Parameter einzustellen:

PKW-Read (mit ADS-Read):

NET-ID = Net-ID der FC310x
PORT = 0x1000 + Stationsadresse des Slaves
IDXGRP = Bit 0-11: Parameter-Nummer (PNU), Bit 28-31: Nummer der Achse (bei
1-Achsen-Modulen immer 1), Bit 27: 1 = ARRAY-Codes werden nicht unterstützt von
PROFIDRIVE-Slave, Bit 26: 1 = Subindex in Octet 3 (Standard), 0 = Subindex in
Octet 4 (Simodrive 611U), restliche Bits müssen 0 sein
IDXOFFS = Subindex (bei ARRAY-Zugriffen)
LEN = Parameter-Länge (2 oder 4)

PKW-Write (mit ADS-Write):

NET-ID = Net-ID der FC310x
PORT = 0x1000 + Stationsadresse des Slaves
IDXGRP = Bit 0-11: Parameter-Nummer (PNU), Bit 28-31: Nummer der Achse (bei
1-Achsen-Modulen immer 1), Bit 27: 1 = ARRAY-Codes werden nicht unterstützt von
PROFIDRIVE-Slave, Bit 26: 1 = Subindex in Octet 3 (Standard), 0 = Subindex in
Octet 4 (Simodrive 611U), restliche Bits müssen 0 sein
IDXOFFS = Subindex (bei ARRAY-Zugriffen)
LEN = Parameter-Länge (2 oder 4)


PROFIBUS DP

Die FC310x unterstützt die PROFIBUS-Protokolle PROFIBUS-DP (als Master oder Slave), PROFIBUS-DPV1 (als Master) und PROFIBUS-MC (als Master).

Karteireiter "FC310x"

PCI Slot/Irq: Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde.

Search...: Hierüber werden alle gesteckten FC310x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC3102 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC3101-Karten verhalten.

Hardware Configuration...: Hier kann die Hardware-Versionsnummer der FC310x angezeigt werden

Upload Configuration...: Hiermit wird der PROFIBUS gescannt und alle gefunden Geräte werden dem FC310x-Device hinzugefügt (bei TwinCAT 2.8 darf keine Box angefügt sein, ab TwinCAT 2.9 kann auch bei angefügten Boxen gescannt werden, die FC310x übernimmt dann die neue Konfiguration, zeigt aber Änderungen an). Bei Beckhoff-Boxen wird die Konfiguration genau ausgelesen, bei Fremdgeräten wird versucht, die zugehörige GSD-Datei zu finden.

Verify Configuration...: Hiermit wird der PROFIBUS gescannt und mit den aktuell angefügten Boxen verglichen, Änderungen werden angezeigt (ab TwinCAT 2.9).

Firmware: Hier wird die aktuelle Firmware-Version der FC310x angezeigt.

Firmware Update...: Hierüber kann die Firmware der FC310x-Karte aktualisiert werden.

Stations-No.: Jeder Profibusteilnehmer benötigt eine eindeutige Stations-Nr. - auch der Master.

Baudrate: Hier wird die Profibus Baudrate eingestellt.

Operation Mode: Bei allen drei Betriebsarten übernimmt die höchstpriore Task, die mit dem entsprechendem Gerät verknüpft ist, die Ansteuerung des PROFIBUS-Zyklusses und ist somit mit dem DP-Zyklus synchronisiert (s. Kapitel Synchronisierung). Wenn diese Task gestoppt wird oder auf einen Breakpoint läuft, schaltet die FC310x in den CLEAR-Mode (Ausgänge gehen bei den Slaves auf 0 oder auf sichere Werte) (s. Kapitel Fehlerreaktionen). Alle anderen Tasks werden asynchron über entsprechende Puffer bedient. Wenn eine dieser Tasks gestoppt wird oder auf einen Breakpoint läuft, kommt in der Regel im System-Manager die Meldung, dass der Watchdog des entsprechenden asynchronen Mappings zugeschlagen hat und die entsprechenden Ausgänge werden auf 0 gesetzt. Bei allen Betriebsarten kann je Slave eine Poll-Rate eingestellt werden (im Karteireiter Features der Box). Die Reihenfolge der Slaves im PROFIBUS-Zyklus entspricht der Reihenfolge, in der sie in dem Baum unter dem FC310x-Device hängen. Die Betriebsart "DP" ist für den Standard-DP-Betrieb, die Betriebsarten "DP/MC (Equidistant)" und "Equidistant (no GC)" sind im Kapitel PROFIBUS-MC beschrieben, ebenso wie die Parameter NC-Access-Time, Relation NC-Access-Time/Cycle-Time, PLL-Sync-Time und Safety-Time sowie die Sync-Mode-Einstellungen und der Button Calculate Equi-Times, die nur für PROFIBUS MC von Bedeutung sind.

Cycle-Time: Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt .

Estimated Cycle: Hier wird die voraussichtliche PROFIBUS-Zykluszeit angezeigt.

Watchdog Time: Hier kann ein Watchdog aktiviert werden, der dazu führt, dass bei einem Absturz des PCs die FC310x in den STOP-Zustand geht und den Datenaustausch mit allen projektierten Slaves beenden würde (s. Fehlerreaktionen). Die Zeit ist wichtig im Redundanz-Mode beim Primary-Master.

Calculate DP-Slave Watchdog Time: Hier wird die DP-Watchdog-Time aller DP-Slaves auf einen vernünftigen Wert gestellt, nach der Formel Estimated-Cycle-Time * 10

Karteireiter "Profibus"

Die meisten der hier einzustellenden Parameter sind in der PROFIBUS-Norm (DIN 19245 Teil 3 - PROFIBUS-DP), Kapitel 7 beschrieben und sollten nur von sachkundigen Benutzern verändert werden.

Max-Retry-Limit: Das Max-Retry-Limit gibt an, wie oft ein Telegramm zu wiederholen ist, wenn der adressierte Teilnehmer nicht antwortet. Hier sollte minimal ein Wert von 1 eingestellt werden, damit bei azyklischen Telegrammen im Fehlerfall mindestens einmal wiederholt wird.

Max-Retry-Limit (DX): Da das Data_Exchange-Telegramm zyklisch wiederholt wird, könnte man für die Wiederholung des Data_Exchange-Telegrammes hier den Wert 0 eintragen, um im Equidistant-Betrieb den Zyklus auch bei einem nicht antwortenden Teilnehmer einigermaßen konstant zu halten. In diesem Fall sollte aber sinnvollerweise auf dem Karteireiter Features der Box eingestellt werden, dass ein Nicht-Antworten nicht zum Verlassen des DATA-EXCH führt. Dass ein Teilnehmer nicht geantwortet hat, kann man immer am DpState erkennen, der dann für einen Zyklus auf ungleich 0 wäre.

GAP-Update: Das GAP-Update, mit dem alle Stationen bis zur HSA ab und zu angefragt werden, ob sie vorhanden sind, kann ein- oder ausgeschaltet werden. Das GAP-Update ist eigentlich nur bei Multi-Master-Betrieb von Bedeutung, das Abschalten kann aber dazu führen, dass Slaves schlechter die Baudrate finden. Bei Single-Master-Betrieb hat es zur Folge, dass der Jitter des PROFIBUS-Zyklusses größer ist, daher ist es defaultmäßig ausgeschaltet.

PROFIBUS-Mode: Hier kann zwischen Master-Funktionalität (Standard) und Slave (Standard-Slave-Funktionalität, ab Version 1.x) unterschieden werden.

Für die Slave-Funktionalität ist wie folgt vorzugehen:

  1. GSD-Datei TCDPSLAV.GSD in das Verzeichnis TwinCAT\Io\Profibus kopieren
  2. Auf dem Reiter Profibus den PROFIBUS-Mode Slave bzw. Master/Slave einschalten
  3. Beim Anfügen einer Box werden jetzt nur noch GSD-Dateien angezeigt, die den Eintrag "FC310xSlaveIntern = 1" haben.
  4. Beliebige Module anfügen, wobei darauf zu achten ist, dass genauso viele Inputs wie Outputs ausgewählt werden
  5. Im Gegensatz zu anderen Slaves unterstützt die Slave-Funktionalität der FC310x keine automatische Baudratenerkennung, daher muss darauf geachtet werden, dass die Baudrate richtig eingestellt ist
  6. Ab TwinCAT 2.8 kann man mit der rechten Maustaste auf das FC310x-Device gehen und eine GSD-Datei mit den aktuellen Einstellungen exportieren, die im Konfigurator des DP-Masters eingefügt werden kann, dann sind dort keine weiteren Einstellungen mehr zu machen.

Falls keine GSD-Datei exportiert wurde, ist auf der Master-Seite (egal ob TwinCAT oder Fremd-Master) die GSD-Datei TCDPSLAV.GSD einzubinden, und die Module sind in der gleichen Reihenfolge anzufügen, wie das bei der FC310x-Slave-GSD-Box getan wurde

Karteireiter "ADS"

Die FC310x ist ein ADS-Device mit einer eigenen Net-ID, die hier verändert werden kann. Alle ADS-Dienste (Diagnose, azyklische Kommunikation), die an die FC310x gehen, müssen diese Net-ID adressieren.

Karteireiter "Box States"

Hier wird eine Übersicht aller aktuellen Box-States, der Repeat-Counter (zählt bei jeder Telegrammwiederholung zu dem Slave hoch) und der NoAnswer-Counter (zählt jedes Mal hoch, wenn der Slave nicht geantwortet hat) angezeigt.

Karteireiter "General Diag"

Hier werden Busverkablungsprobleme und DP-Zykluszeiten angezeigt:

detected bus-errors: Hier wird die Anzahl der festgestellten Busfehler angezeigt, wenn dieser Zähler ungleich 0 ist, sollte die Verkablung geprüft werden (falls keine PROFIBUS-Stecker abgezogen oder gesteckt wurden (in der Regel gibt es beim Abziehen oder Stecken von PROFIBUS-Steckern auch kurze Busstörungen)).

CycleWithRepeatCounter: Hier wird die Anzahl der PROFIBUS-Zyklen angezeigt, in denen mindestens einmal ein Telegramm wiederholt wurde. Wiederholungen sind auch ein Anzeichen dafür, dass die Busphysik nicht völlig okay ist.

max. Repeat/Cycle: Hier die maximale Anzahl von Wiederholungen innerhalb eines Zyklusses angezeigt.

min./max./actual Cycle-Time: Hier werden minimale, maximale und aktuelle DP-Zykluszeit angezeigt, wobei nur Zyklen berücksichtigt werden, in denen alle Slaves im Datenaustausch waren und keine Wiederholungen auftraten.

CycleWithNoDxch-Counter: zählt hoch, wenn nicht alle Slaves im Datenaustausch sind (d.h. einen DpState ungleich 0 haben)

Karteireiter "DPRAM (Online)"

Siehe unter "Online - Anzeige des DPRAMs".

Diagnose Eingänge

Die FC310x verfügt automatisch über verschiedene Diagnosevariablen, die den Zustand der Karte und des Profibusses beschreiben:

CdlInfo:

CdlInfo.error: Zeigt die Anzahl der Slaves an, mit denen kein Datenaustausch im letzten Zyklus durchgeführt werden konnte, nur wenn dieser Wert ungleich 0 ist, muss der BoxState der Slaves überprüft werden

CdlInfo.cycleCounter: wird am Ende jedes PROFIBUS-Zyklusses inkrementiert, so dass man mit dieser Variable feststellen kann, ob der letzte Zyklus beendet war, bevor die Task gestartet wurde

CdlInfo.actualCycleTime: zeigt die aktuelle Zykluszeit in 4/25 µs an, diese Variable wird nur aktualisiert, falls alle Slaves im Datenaustausch sind (also CdlInfo.error gleich 0 ist)

Debug: interne Informationen

DiagFlag: Zeigt an, ob sich die Diagnoseinformationen der Karte geändert haben, die dann mit ADS-Read ausgelesen werden können. Dazu ist die Net-ID der FC310x, die Port-Nummer 200 und die IndexGroup 0xF100 anzugeben. Der IndexOffset und die Länge beziehen sich dann auf die Diagnosedaten.
Offset | Beschreibung
0 -125 | BusStatus-Liste, je Stationsadresse 0-125 ein Byte, das den Status der Station enthält (s. BoxState bei den PROFIBUS-Boxen, zusätzlich für nicht projektierte Stationen: 0x80 - nicht vorhanden, 0x81 - Slave, 0x82 - Master nicht bereit für Token-Ring, 0x83 - Master bereit für Token-Ring, 0x84 - Master im Token-Ring)
126 - 127 | reserviert
128 - 135 | Zustand der FC310x (->GlobalState)
136 - 137 | Sende-Fehler-Zähler über alle gesendeten Telegramme
138 - 139 | Empfangs-Fehler-Zähler über alle empfangenen Telegramme
140 - 255 | reserviert für Erweiterungen
256 - 257 | Sync-Failed-Counter (s. Karteireiter Equi-Diag)
258 - 259 | Zyklus-Start-Fehler-Zähler, zählt hoch, wenn der PROFIBUS-Zyklus erneut gestartet wird bevor der alte Zyklus beendet wurde (wird vom TwinCAT-IO-Treiber abgefangen, nur bei kundenspezifischen Treibern möglich)
260 - 261 | Time-Control-Failed-Counter (s. Karteireiter Equi-Diag)
262 - 263 | reserviert für Erweiterungen
264 - 265 | minimaler Nachladewert des Echtzeittimers
266 - 267 | maximaler Nachladewert des Echtzeittimers (max. FCxxxx-Jitter (s. Karteireiter Equi-Diag) = max. Nachladewert - min. Nachladewert)
268 - 269 | PLL-Overflow-Counter (s. Karteireiter Equi-Diag)
270 - 271 | PLL-Underflow-Counter (s. Karteireiter Equi-Diag)

GlobalState: GlobalState[0] gibt den Zustand der FC310x an, GlobalState[1-3] sind reserviert für Erweiterungen:

RESET (1): Router der Karte wurde nicht gestartet (nach dem Hochlauf des PCs)

INIT (2): Router gestartet, Karte aber nicht am PROFIBUS aktiv

STOP (3): Karte am PROFIBUS aktiv, aber kein zyklischer Datenaustausch

STOPPING (4): Karte beendet den zyklischen Datenaustausch

RUN (0): Karte im zyklischen Datenaustausch

GlobalState[1] zählt die festgestellten Bus-Errors (ab FC310x, Version 1)

GlobalState[2]: Bit 0 ist gesetzt, wenn keine 11 Bit-Ruhezeit auf dem PROFIBUS erkannt wird (-> Verkablung prüfen), Bit 1 enthält die Betriebsart CLEAR (Bit 1 = 1) oder OPERATE (Bit 1 = 0), die anderen Bits (2..7) sind reserviert für Erweiterungen (ab FC310x, Version 1)

GlobalState[3] ist reserviert für Erweiterungen

CycleFailedCounter: Dieser Zähler zeigt an, wie oft beim Start der TwinCAT-Task der PROFIBUS-Zyklus der FC310x noch nicht fertig war.


PROFIBUS DP-Slaves

Hier sind die Karteireiter der PROFIBUS-Slaves (Buskoppler, IP-Boxen, GSD-DP-Slaves, MC-Slaves, etc.) bei Verwendung an einer FC310x beschrieben.

Karteireiter "Profibus"

Stations-Nr.: Hier ist die auf dem jeweiligen Slave eingestellte PROFIBUS-Stationsadresse einzustellen. Es gibt Slaves, bei denen die Stationsadresse nicht hardwaremäßig eingestellt werden kann, sondern nur über den SetSlaveAddress-Dienst. In dem Fall ist der Button "Set.." zu drücken, woraufhin ein Dialog aufgeht, mit dem das Senden eines SetSlaveAddress-Telegramms ausgelöst werden kann.

Watchdog: Schaltet den DP-Watchdog ein. Wenn der Slave bei eingeschaltetem Watchdog für die Dauer der Watchdog-Zeit kein DP-Telegramm empfängt, verlässt er automatisch den Datenaustausch. Die minimal einzustellende Watchdog-Zeit hängt von der Anzahl der Slaves ab und sollte größer als der nach der folgenden Formel berechnete Wert sein: Estimated-Cycle-Time * Anzahl der DP-Slaves * 4

Da der Defaultwert von 200 ms bei vielen Slaves zu klein ist und es sehr mühsam ist bei allen Slaves den Watchdog manuell zu verändern, gibt es ab TwinCAT 2.8 unter dem FC310x-Device auf der Karteikarte FC310x einen Button, mit dem die Watchdog-Zeit nach der obigen Formel bei allen Slaves eingestellt wird.

Ident Nr: Hier wird die Ident-Nummer aus der GSD-Datei angezeigt

PrmData: Erlaubt die Profibus-spezifischen Parameterdaten zu editieren, die Größe der aktuellen Parameterdaten wird ebenfalls angezeigt. Die PrmData können aber in der Regel textuell (-> PrmData (Text)) oder bei Beckhoff-DP-Slaves teilweise über den Karteireiter "Beckhoff" eingestellt werden

CfgData: Die aktuellen Konfigurationsdaten (ergeben sich aus den angefügten Modulen bzw. Klemmen) sowie deren Länge werden angezeigt.

Sync/Freeze: In der Betriebsart DP/MC (Equidistant) der FC310x können Slaves mit Sync und Freeze betrieben werden.

DPV1 Class 2 (ab Firmware-Version 2.0): Bei der FC310x kann eine DPV1-Klasse 2-Verbindung zu einem DPV1-Slave aktiviert werden. Das ist z.B. sinnvoll, wenn der DP-Slave mit einem anderen Master im Datenaustausch ist, aber trotzdem von TwinCAT azyklisch angesprochen werden soll. Mit dem Parameter Timeout wird die Verbindungsüberwachungszeit der Klasse 2-Verbindung eingestellt.

DP Class 2 (ab Firmware-Version 2.0): Wenn der DP-Slave mit einem anderen Master im Datenaustausch ist, aber trotzdem von TwinCAT azyklisch angesprochen oder die DP-Inputs und Outputs zyklisch gelesen werden sollen, ist unter DP-Class 2 "No Cyclic Connection" oder "ReadOnly" auszuwählen. Wenn "ReadOnly" ausgewählt ist, sind wie bei der normalen zyklischen Verbindung die Module auszuwählen, die aber im TwinCAT-System alle mit Input-Variablen erscheinen, egal ob es sich dabei um Input- oder um Output-Module handelt.

ResetSlave: Mit diesem Button kann bei gestartetem TwinCAT der zyklische Datenaustausch zu dem DP-Slave abgebaut und gleich wieder aufgebaut werden (entspricht einem IO-Reset aber nur für den einen Slave).

Karteireiter "Features"

Data_Exchange Poll-Rate: Je Slave kann eine unterschiedliche Polling-Rate (Divider) eingestellt werden, Divider 1 bedeutet, dass der Slave jeden Zyklus gepollt wird, Divider 2 bedeutet jeden 2. Zyklus, usw. Mit dem Modulo können Slaves mit Divider größer 1 auf unterschiedliche Zyklen aufgeteilt werden, um die maximale Zykluszeit zu verkürzen (Divider 2 und Modulo 0 bedeutet, dass der Slave in jedem geraden Zyklus gepollt wird, Divider 2 und Modulo 1 bedeutet, dass der Slave in jedem ungeraden Zyklus gepollt wird).

NoAnswer-Reaction: Je Slave kann angegeben werden, ob dieser weiterhin in Data-Exch bleiben soll, auch wenn er nicht oder fehlerhaft antwortet. In diesem Fall (Stay in Data-Exch) wird der Datenaustausch erst verlassen, wenn der Slave innerhalb der Ansprechüberwachungszeit nie korrekt geantwortet hat (falls der Watchdog aktiviert ist, andernfalls wird der Datenaustausch erst beendet, wenn der Slave 65535 mal nicht korrekt geantwortet hat).

Restart-Behaviour: Je Slave kann angegeben werden, ob dieser nach einem Verlassen von Data-Exch automatisch wieder hochlaufen oder im Zustand Wait-Prm bleiben soll.

Reaction of the Master: Je Slave kann angegeben werden, ob dessen Verlassen von Data-Exch zum Stop des PROFIBUS-Zyklusses führen soll (alle Slaves verlassen den Datenaustausch und gehen nach Wait-Prm, Wiederanlauf nur durch IO-Reset oder Restart des TwinCAT-Systems).

Changes of the Input Data: Je Slave kann angegeben werden, ob beim Verlassen von Data-Exch (DpState wird ungleich 0) dessen Inputdaten auf 0 gesetzt oder unverändert bleiben sollen.

Karteireiter "BK3xx0/IX-B310"

2 Byte SPS Interface: Schaltet das 2-Byte SPS Interface des Beckhoff-DP-Slaves ein.

FirmwareUpdate: Mit diesem Button kann die Firmware eines Beckhoff-DP-Slaves per KS2000-Kabel über die serielle Schnittstelle aktualisiert werden

K-Bus-Update: Hier ist bei Buskopplern die erwartete interne Zykluszeit (K-Bus-Zyklus + Übergabe der DP-Puffer angegeben).

Die folgenden Einstellungen können auch auf der Karteireiter "PrmData (Text)" gemacht werden (-> UserPrmData-Beschreibung des entsprechenden Slaves)

Karteireiter "PrmData (Text)"

Durch Anklicken einer Zeile kann der aktuelle Wert verändert werden. Die Beschreibung der jeweiligen Einstellungen ist der Dokumentation des entsprechenden Herstellers zu nehmen.

Diagnose

Karteireiter "Diag"

Hier können die folgenden Informationen angezeigt werden:

BoxState: Hier wird der aktuelle DpState angezeigt

Receive-Error-Counter: Anzahl der gestörten Telegramme von dem Slave

Repeat-Counter: Anzahl der notwendigen Wiederholungen aufgrund keiner oder einer gestörten Antwort des Slaves

NoAnswer-Counter: Anzahl der Telegramme, auf die der Slave nicht geantwortet hat

letzter DPV1-Fehler: Error-Decode, Error-Class, Error-Code und Error-Code 2 (-> Beschreibung des Herstellers)

Slave-Handler-State: Zustand des Slave-Handlers auf der FC310x

Bei Beckhoff DP-Slaves werden noch weitere Diagnoseinformationen angezeigt.

Diagnose Eingänge

Jede Profibus-Slave Box erhält zwei Diagnose-Eingangsbytes, die den Status des jeweiligen Slaves zur Laufzeit signalisieren und z.B. mit der SPS verknüpft werden können. Der DpState enthält den aktuellen Zustand des Slaves (Echtzeit-Zustand, d.h. wenn der DpState 0 ist, sind die Inputdaten des Slaves aktuell, bei einem DpState ungleich 0 wurden die Inputdaten defaultmäßig (s. o. Karteireiter Features) von der FC310x auf 0 gesetzt). Das ExtDiagFlag zeigt an, ob der Slave über neue PROFIBUS-Diagnosedaten verfügt. Sobald die Diagnosedaten mit ADS-Read ausgelesen wurden, wird das Flag zurückgesetzt (damit das Flag zurückgesetzt wird, müssen die kompletten 276 Bytes ausgelesen werden oder (ab Firmware-Version 1.4E der FC310x) kann alternativ im Lo-Word der IndexGroup 0xF181 angegeben werden (s.u.)).

PROFIBUS-Diagnosedaten

Die PROFIBUS-Diagnosedaten, die ein PROFIBUS-Slave sendet, können per ADS von jedem TwinCAT Programm gelesen bzw. an jedes TwinCAT-Programm gemeldet werden (s. Beispielprogramm FC310x_Diag.pro). Dabei sind die ADS-Parameter wie folgt einzustellen:

Net-ID: Net-ID der FC310x

Port: 200

IndexGroup: Lo-Word: 0xF180 (oder 0xF181 ab Firmware-Version 1.4E), Hi-Word: Stationsadresse

IndexOffset: 0

Länge: 32 - 276

Die Diagnosedaten sind wie folgt aufgebaut:
Offset | Beschreibung
0 | Receive-Error-Counter (WORD): Anzahl der fehlerhaften Telegramme bei der Kommunikation mit diesem Slave
2 | ab FC310x, Version 1.11: Repeat-Counter[9] (WORD): Die Repeat-Counter zeigen an, wie oft wie viele Repeats (1..MaxRetryLimit, MaxRetryLimit ohne Antwort) gemacht werden mussten. Repeat-Counter[0] zeigt an, wie oft ein Telegramm zu diesem Slave einmal wiederholt werden mußte, Repeat-Counter[1], wie oft ein Telegramm zu diesem Slave zweimal wiederholt werden musste, etc. Der Parameter MaxRetryLimit kann in den PROFIBUS-Parametern eingestellt werden (Wertebereich 0..8)
20 | NoAnswer-Counter (DWORD): Anzahl der Telegramme bei der Kommunikation mit diesem Slave, auf die nicht geantwortet und bei denen kein Repeat durchgeführt wurde. Wenn ein Slave das erste Mal nicht antwortet, wird bis zu MaxRetryLimit mal das Telegramm wiederholt, wenn er auch dann nicht geantwortet hat, wird beim nächsten Mal keine Wiederholung mehr durchgeführt.
24-31 | reserved for future use
32-37 | PROFIBUS-Norm-Diagnose
38-275 | PROFIBUS-Norm-Extended-Diagnose (-> Dokumentation des Herstellers)

Die Daten enthalten den zuletzt empfangenen Wert und werden aktualisiert, wenn sich die erweiterten Diagnosedaten geändert haben. Der Stationsstatus1-3 der PROFIBUS-Norm-Diagnose ist im Diagnose-Eingang DpState zusammengefasst.

DPV1-Read/Write

Bei DP-Slaves, die die DPV1-Dienste Read und Write unterstützen (in der GSD-Datei müssen dafür die Zeile "DPV1_Slave = 1" und die Schlüsselwörter "C1_Max_Data_Len" oder "C2_Max_Data_Len" mit einer entsprechenden Länge eingetragen sein), kann per ADS azyklisch auf die DPV1-Daten zugegriffen werden. Auf dem Karteireiter ADS steht die dazu anzugebene ADS-Adresse, die ADS-Parameter sind wie folgt einzustellen (s. Beispielprogramm FC310x_DPV1.pro):

Net-ID: Net-ID der FC310x

Port: 0x1000 + Stationsadresse

IndexGroup: DPV1-Slot_Number (bei DPV1-Class 2-Zugriff muss zusätzlich das Bit 8 der IndexGroup gesetzt werden)

IndexOffset: DPV1-Index

Länge: Länge der zu lesenden bzw. zu schreibenden Daten

Die per DPV1-Slot_Number und DPV1-Index adressierbaren Daten sind der Beschreibung des Herstellers zu entnehmen.


PROFIBUS MC

PROFIBUS MC unterscheidet sich von PROFIBUS DP dadurch, daß der PROFIBUS-Zyklus mit einem konstanten Zyklus mit wenigen Mikrosekunden Jitter erfolgt (bei PROFIBUS DP ist der Jitter größer 100µs) und am Anfang des Zyklusses ein Broadcast-Global-Control-Telegramm gesendet wird, auf das sich die MC-Slaves synchronisieren können. Dadurch ist es möglich, Antriebsregelkreise genau mit der NC zu synchronisieren.

Die genaue Synchronisierung hat aber zur Folge, daß Busstörungen, Ausschalten von Slaves, Abziehen von Bussteckern, etc. in der Regel dazu führen, daß die Synchronität zwischen Master und Slave verloren geht, da sich das Bus-Timing dadurch verändert.

FC310x mit Simodrive 611U ist Plug&Play

Um einen Simodrive 611U an einer FC310x in Betrieb zu nehmen, ist das Folgende zu tun:

1. FC310x auf Betriebsart "DP/MC (Equidistant)" stellen

2. Box "Siemens AG, Profidrive MC" anfügen

3. Stationsadresse des 611Us anpassen (Box-Karteireiter "Profibus")

4. Achse (bzw. 2 Achsen bei 611U mit 2 Achsen) an NC-Task anhängen, Achstyp "kontinuierliche Achse" auswählen

5. Achse (bzw. Achsen) mit 611U verknüpfen (in Achs-Karteireiter "Settings" den Achstyp "ProfiDrive MC" auswählen, dann mit 611U verknüpfen, bei einem 2-Achs-611U sind immer beide Achsen zu verknüpfen, sonst gibt es einen Fehler auf dem 611U)

6. An der FC310x auf dem Karteireiter "FC310x" den Button "Calculate Equi-Times" drücken

7. Projekt in der Registry speichern, TwinCAT starten, der 611U müßte dann auf RUN gehen, die Achse kann im NC-Online-Menü bedient werden

Falls das nicht Fall ist, sollten die folgenden Dinge überprüft werden:

DpState des 611Us in TwinCAT ist 2: Stationsadresse des 611Us prüfen

DpState des 611Us in TwinCAT ist 5: Prüfen, ob das richtige PROFIBUS-Modul am 611U gesteckt ist

DpState des 611Us in TwinCAT ist 7: Prüfen, ob P922 auf dem richtigen Standardtelegramm steht (entsprechend Karteireiter ProcessData beim 611U im System-Manager)

DpState des 611Us in TwinCAT ist 0, aber 611U trotzdem nicht im RUN: die Firmware-Version des 611Us überprüft werden, bei Firmware-Versionen kleiner 3.4.3 läßt sich ein Synchronisierungsfehler auf dem 611U (Fehler 597 bzw. 598) nur durch einen Hardware-Reset des 611Us beheben, ansonsten Fehlercode im Siemens-Handbuch nachschauen

Wenn mehrere 611Us konfiguriert werden, müssen ggf. die Equidistant-Zeiten angepaßt werden (s.u.).

Einstellung DP/MC-Equidistant-Mode

Um die FC310x mit PROFIBUS MC zu betreiben, muß im System-Manager unter dem FC310x-Device auf dem Karteireiter FC310x der Operation Mode "DP/MC(Equidistant)" eingestellt werden. Zusätzlich kann noch der Sync-Mode ausgewählt werden, die festlegt, wo das Synchronisationssignal generiert wird.

Disabled (PC ist Sync-Master)

Das Synchronisationssignal wird vom PC generiert, die FC310x synchronisiert sich auf den PC (Jitter des PROFIBUS-Zyklusses ca. 2-4 µs).

Die NC-Access-Time gibt an, um wie viel der PROFIBUS-Zyklus zum TwinCAT-Zyklus verschoben ist, die PLL-Sync-Time sollte auf ca. 10% der Shift-Time eingestellt werden (max. 50 µs).

Sync-Slave

Das Synchronisierungssignal kommt von einem anderen Device, dessen Sync-Mode auf "Sync-Master" eingestellt sein muss. Die Verbindung zwischen Sync-Master und Sync-Slave erfolgt durch einen Hardware-Link, der erst ab Hardware-Version 4 der FC310x unterstützt wird. Zeiten sind keine einzustellen.

Sync-Master

Das Synchronisationssignal wird von der FC310x generiert, der PC synchronisiert sich auf die FC310x (Jitter des PROFIBUS-Zyklusses ca. 1 µs).

Die NC-Access-Time gibt an, um wie viel der TwinCAT-Zyklus zum PROFIBUS-Zyklus verschoben ist.

Einstellung der Equidistant-Zeiten

Mit dem Button Calculate Equi-Times werden alle Equidistant-Parameter automatisch eingestellt. Der einzige Parameter, der danach ggf. noch angepasst werden muss, ist die NC-Access-Time, da diese vom maximalen TwinCAT-Jitter und der maximalen Mapping-Time (geht über alle Devices, d.h. das Hinzufügen von und Verknüpfen von Boxes an anderen Devices führt bei der FC310x dazu, dass ggf. dessen NC-Access-Time zu ändern ist). Falls nicht das Flag "I/O at Task-Begin" (bei NC defaultmäßig ein, bei PLC defaultmäßig aus) gesetzt ist, hängt die NC-Access-Time auch noch von der Task-Laufzeit ab. Damit nach dem Drücken des Buttons Calculate Equi-Times die NC-Access-Time nicht jedesmal manuell angepasst werden muss, kann das Verhältnis von NC-Access-Time zu Cycle-Time festgelegt werden (defaultmäßig auf 15%).

Disabled (PC ist Sync-Master) bzw. Sync-Master

Die NC-Access-Time muss größer als Max. TwinCAT-Jitter plus Max. Mapping-Time (plus Task-Laufzeit der höchstprioren mit der FC310x verknüpften Task (falls "I/O at Task begin" bei der höchstprioren mit der FC310x verknüpften Task nicht gesetzt ist)) sein.

Diagnose der Equidistant-Zeiten

Es gibt den Karteireiter "EquiDiag", auf dem Online verschiedene Equidistant-Überwachungsparameter angezeigt werden:

TcIo-Statistics

max. TwinCAT-Jitter: Hier wird der maximale TwinCAT-Jitter angezeigt, die Messung wird zurückgesetzt, sobald der Karteireiter nicht mehr aktiv ist.

min./max. Mapping-Time bzw. NC-Access-Time: Hier die minimale bzw. maximale NC-Access-Time angezeigt, wobei diese neben der Mapping-Zeit noch die Task-Laufzeit enthält (falls "IO am Taskanfang" bei der höchstprioren mit der FC310x verknüpften Task (in der Regel die NC-Task) gesetzt ist).

Die NC-Access-Time sollte größer als die Addition dieser beiden gemessenen Zeiten (max. TwinCAT-Jitter plus max. Mapping-Time bzw. NC-Access-Time) mit einem Sicherheitsaufschlag (ca. 10%) eingestellt werden.

max. FCxxxx-Jitter: Ist nur bei Sync-Mode = "Disabled" von Bedeutung, wenn der Wert größer als 5 wird, jittert die Echtzeit zu stark, es sollte dann ein leistungsfähigerer PC genommen werden.

FC310x-Statistics

Da die PROFIBUS MC-Slaves immer zuerst an das FC310x-Device angefügt werden sollten, werden diese auch immer vor den DP-Slaves im DP-Zyklus angesprochen, dieser Teil des DP-Zyklusses wird im Folgenden als Equi-Cycle bezeichnet. Wenn der Equi-Cycle größer als die To-Zeit der MC-Slaves wird, bekommen die letzten MC-Slaves am FC310x-Device in der Regel einen Synchronisationsfehler (Fehler 597 oder 598 bei Simodrive 611U).

max. Repeats/Equi-Cycle: Hier wird angezeigt, wie viele Data_Exchange-Telegramme während eines Equi-Cycles maximal wiederholt wurden, dadurch verlängert sich der Equi-Cycle, normalerweise sollten keine Wiederholungen auftreten (es sein denn, dass Busstecker gezogen oder ein MC-Slave ausgeschaltet wurde)

min./max. Equi-Cycle: Hier wird die minimale bzw. die maximale Equi-Cycle-Time angezeigt.

Equi-Cycle-Repeat-Counter: Hier wird angezeigt, wie oft im Equi-Cycle Telegramm-Wiederholungen auftraten.

Equi-Cycle-NoDxch-Counter: Hier wird angezeigt, wie oft im Equi-Cycle nicht alle MC-Slaves im Datenaustausch waren.

FC310x-Failed-Counter

Sync-Failed-Counter: Dieser Zähler zählt hoch, wenn TwinCAT-Task und DP-Zyklus nicht miteinander synchronisiert sind. Das kann beim Hochlauf des TwinCAT-Systems passieren, danach sollte dieser Zähler nicht hochzählen.

Time-Control-Failed-Counter: Dieser Zähler zählt hoch, wenn zum Zeitpunkt des DP-Zyklus-Starts der PROFIBUS nicht frei war. Ursache dafür können Busstörungen, nicht vorhandenen Teilnehmer, ein zweiter Master oder eine zu kleine Safety-Time sein.

PLL-Overflow-/-Underflow-Counter: Dieser Zähler ist nur beim Sync-Mode "Disabled" relevant und zählt hoch, falls die TwinCAT-Task, auf die sich der DP-Zyklus synchronisiert, zu stark jittert (kann z.B. passieren, falls der DP-Zyklus nicht mit der höchstprioren Task synchronisiert ist)

To-Statistics

Mit der To-Zeit wird bei jedem MC-Slave festgelegt, wann, bezogen auf den DP-Zyklusstart, dieser die vom Master empfangenen Outputs übernehmen soll. Die MC-Slaves können miteinander synchronisiert werden, wenn bei allen MC-Slaves der gleiche Wert für To eingestellt wird. Dieser muss aber mindestens so groß wie die Equi-Cycle-Time plus eine Sicherheitsreserve von ca. 200 µs sein. Die To-Zeit wird bei allen MC-Slaves mit dem Button "Calc. Equi-Times" (s.o.) berechnet .

calc. To-Reserve: Hier steht die kalkulierte To-Reserve (To-Zeit - Equi-Cycle-Time)

min./max. To-Reserve: Hier wird die min. bzw. max. To-Reserve gemessen.

max. GC-Jitter (ab TwinCAT 2.8)

Hier wird der maximale Jitter des DP-Zyklusses gemessen (GC für Global-Control-Telegramm, das immer am Anfang eines Zyklusses gesendet wird). Beim Hochlauf kann der Jitter etwas größer sein, im eingeschwungenen Zustand sollte er 1 µs (bei Sync-Mode "Sync-Master") bzw. 2 µs (bei Sync-Mode "Disabled") nicht überschreiten.

Anfügen von PROFIBUS MC-Slaves

Hier sind nur die PROFIBUS MC-Parameter beschrieben, die PROFIBUS-Parameter verhalten sich wie beiden PROFIBUS DP-Slaves beschrieben.

AH2000 (ab TwinCAT 2.8)

Unter Beckhoff Automation kann ein 1-Achser "AH2000-1 Channel" oder ein 3-Achser "AH2000-3 Channels" ausgewählt werden. Unter dem Karteireiter "ADS" kann die AMS-Adresse des AH2000 eingestellt werden, über die mit dem Zusatzprogramm "AH2000.exe" die Parameter eingestellt werden können. Auf dem Karteireiter "SlaveDiag" werden verschiedene Diagnoseinformationen angezeigt:

min./max. Cycle-Time: Hier die minimale bzw. maximale Differenz zwischen zwei AH2000-TwinCAT-Task-Zyklen gemessen.

max. TwinCAT-Jitter: hier wird der maximale TwinCAT-Jitter auf dem AH2000 angezeigt.

max. pos/neg Shift-Time: hier wird die minimale bzw. maximale Shift-Time zwischen PROFIBUS-Zyklus und TwinCAT-Task angezeigt, sie sollte 250 µs nicht überschreiten.

Input-Failed-Counter: Dieser Zähler zählt hoch, wenn die TwinCAT-Task des AH2000 zum Zeitpunkt der Istwertübergabe (Ti) keinen Zugriff auf das DP-RAM der PROFIBUS-Anschaltung hatte, ggf. ist Ti zu groß gewählt worden oder es gibt Busstörungen.

Output-Failed-Counter: Dieser Zähler zählt hoch, wenn zum Zeitpunkt der Sollwertübernahme (To) der TwinCAT-Task des AH2000 noch keine neuen Sollwerte auf der PROFIBUS-Anschaltung empfangen wurden, ggf. ist To zu klein gewählt worden oder es gibt Busstörungen.

Weiterhin wird ab der AH2000-Firmware-Version 01.4E die aktuelle Firmware-Version des AH2000 angezeigt, mit dem Button "Restart Remote-TwinCAT" kann das TwinCAT-System des AH2000 über den PROFIBUS neu gestartet werden.

Allgemeiner PROFIBUS MC-Slave

Unter Siemens AG bzw. Profidrive MC können die Boxen Profidrive MC und Profidrive MC (2-fach) ausgewählt werden. Standardmäßig bekommt die Box die Einstellungen für einen Simodrive 611U mit Standardtelegramm 3. Für andere PROFIBUS MC-Slaves ist die Ident-Nummer auf dem Karteireiter Profibus entsprechend zu ändern. Der gewünschte Telegrammtyp kann auf dem Karteireiter ProcessData eingestellt werden und muss in der Regel mit dem Parameter 922 des PROFIBUS MC-Slaves übereinstimmen, der über ein herstellerspezifisches Konfigurationstool (SimoCon U bei Simodrive 611U) eingestellt werden kann .

Auf diesem Karteireiter gibt es auch eine Check-Box "PKW-Interface", die das PKW-Interface aktiviert. darüber können online die Parameter der Box auf dem Karteireiter Online angezeigt werden (bisher funktioniert das nur mit dem Simodrive 611U, da ein Parameterfile erforderlich ist, dass der SimoCon U erzeugt). Auf jeden Fall ist es möglich, die Parameter über das PKW-Interface per ADS zu lesen und schreiben (Lesen und Schreiben von PROFIDRIVE-Parametern über PKW-Interface mit ADS).

Bild


Sync/Freeze-Funktionalität

Mit Sync will man bei mehreren Slaves gleichzeitig Ausgänge ausgeben, mit Freeze will man bei mehreren Slaves gleichzeitig Eingänge einlesen.

Der Ablauf in TwinCAT mit FC310x und Buskopplern (im K-Bus-Synchronen Mode) wäre also der folgende:

- Am Ende des Task-Zyklusses werden die Ausgänge geschrieben
- Dadurch wird der PROFIBUS-Zyklus gestartet
- Am Anfang des PROFIBUS-Zyklusses wird ein Sync/Freeze-Telegramm gesendet
- Dadurch starten die Buskoppler einen K-Bus-Zyklus mit den Ausgängen aus dem letzten Task-Zyklus und übergeben die Eingänge aus dem letzten K-Bus-Zyklus
- Dann sendet der Master zu jedem Slave die aktuellen Ausgänge und holt die übergebenen Eingänge
- Am Anfang des nächsten Task-Zyklusses werden die Eingänge gelesen
- usw.

Ausgänge und Eingänge sind also immer einen Zyklus alt.

An der FC310x ist die Betriebsart auf DP/MC (Equidistant) zu stellen, an den Boxen, die per Sync/Freeze betrieben werden sollen, ist das Sync/Freeze-Flag anzuklicken.


Funktionalität der FC310x

Die FC310x unterstützt die folgenden Funktionalitäten (Version 0: ab 04/00, Version 1: ab 11/00, Version 2: ab 01/01, Version 3: ab 04/01):

Funktionsklasse | Funktionalität | Ab Version
Standard PROFIBUS DP | DP-Master Klasse 1 (Data_Exchange, Slave_Diag, Set_Prm, Chk_Cfg, Global_Control Ohne Sync und Freeze)) mit bis zu 125 Slaves und 244 Byte Daten | 00.00
 | DP-Master Klasse 2 (Set_Slave_Address, Get_Cfg) | 00.00
 | DP-Slave | 01.00
 | DP-Master-Master-Funktionen | 03.00
 | DP-Master Klasse 1 (Sync, Freeze) | 02.00
PROFIBUS DPV1 | DPV1-Master Klasse 1 (Read, Write, Data_Transport) mit bis zu 125 Slaves und 240 Bytes Daten, Erweiterte Datentypen | 00.00
 | DPV1-Master Klasse 1 (Alarme) | 03.00
 | DPV1-Master Klasse 2 | 03.00
 | DPV1-Write (Klasse 1) beim DP-Hochlauf (-> Betriebsparameter werden bei jedem DP-Hochlauf automatisch gesendet, bevor Datenaustausch mit dem DP-Slave durchgeführt wird) | 03.00
 | DPV1-Slave Klasse 1 und 2 | 04.00
PROFIBUS MC | Äquidistanz (FC310x synchronisiert sich auf TwinCAT) | 00.00
 | Äquidistanz (TwinCAT synchronisiert sich auf FC310x) | 02.00
 | PKW-Interface über ADS | 00.00
 | Data_Exchange-Broadcast (Slave-To-Slave-Kommunikation) | 03.00
PROFIBUS FDL | Siemens AG-AG-Verbindungen | 01.00
 | Siemens MPI-Verbindungen | 01.00
 | freie FDL-Verbindungen | 03.00
CDL-Betrieb | Poll-Rate je DP-Slave (-> kurze Zykluszeiten für wichtige Slaves unabhängig von der Anzahl der Slaves möglich) | 00.00
 | Aufteilung der DP-Slaves in Poll-Listen (CDLs) mit unterschiedlichen Prioritäten, die unabhängig voneinander gestartet werden können, wobei eine höher priore Poll-Liste eine niederpriore unterbrechen kann | 03.00
Diagnose | je CDL ein Fehlerbyte im Dual-Port-RAM, dass die Anzahl der Stationen anzeigt, die nicht im Datenaustausch sind | 00.00
 | je DP-Slave ein Statusbyte im Dual-Port-RAM, das den aktuellen Status des Slaves anzeigt | 00.00
 | je DP-Slave ein Flag im Dual-Port-RAM, das anzeigt ob sich die DP-Diagnosedaten des Slaves verändert haben | 00.00
 | DP-Diagnose kann ausgelesen oder bei Änderung gemeldet werden | 00.00
Fehlerreaktion | Fehlerreaktion der Box, Restart-Verhalten der Box, Device-Reaktion bei Box-Fehler | 00.00
Sonstiges | DP-Master/DP-Slave parallel | 04.00
 | Multi-DP-Slave | 04.00


Beckhoff FC510x als CANopen-Monitor

Die FC5101 bzw. FC5102 kann ab Firmware-Version 1.00 und TwinCAT 2.8 (Build 740) statt als Master bzw. Slave auch als CANopen-Monitor eingesetzt werden.

So kann z.B. der zweite Kanal der FC5102 für diesen Zweck genutzt werden, wobei der erste Kanal weiterhin als CANopen Master oder Slave fungiert, oder umgekehrt. In diesem Fall müssen beide Kanäle an das gleiche CAN Netzwerk angeschlossen werden (Der Datenaustausch innerhalb der Karte ist nicht vorgesehen, da dieser nicht rückwirkungsfrei erfolgen könnte).

Die von der FC510x aufgezeichneten Telegramme werden von der mit der FC510x verknüpften Task in einem Ring-Puffer zwischengespeichert, auf die gespeicherten Telegramme kann dann per ADS zugegriffen werden. Es gibt ein CANopen-Monitor-Programm (CANMON) mit Filter und Trigger-Möglichkeiten von Beckhoff als Free-Ware (siehe http://www.beckhoff.com im Download Bereich).

Einfügen FC510x als CANopen Monitor

Kontextmenü Gerät anfügen: CANopen Monitor einfügen

Danach muss der entsprechende Kanal (PCI-Speicheradresse) ausgewählt werden.

Verknüpfen der FC510x mit einer Task

Der Zugriff auf die Monitor-Daten erfolgt aus der TwinCAT-Echtzeit beim Start einer Task. Daher muß eine zusätzliche Task im System-Manager angelegt werden, die mindestens eine UINT16-Eingangsvariable enthält, die mit einer der Variablen der FC510x zu verknüpfen ist.

Die Verknüpfung dient nur dazu, daß aus der Echtzeit mit der Zykluszeit der Task auf die FC510x zugegriffen werden kann. Die Zykluszeit der zusätzlichen Task ist abhängig von der Baudrate wie folgt einzustellen:

Baudrate | Zykluszeit der zusätzlichen Task
1 MBaud | <= 10 ms
800 kBaud | <= 12 ms
500 kBaud | <= 20 ms
250 kBaud | <= 40 ms
125 kBaud | <= 80 ms
100 kBaud | <= 100 ms
50 kBaud | <= 200 ms
20 kBaud | <= 500 ms
10 kBaud | <= 1000 ms

Weiterhin ist die Check-Box Auto-Start zu setzen (s. Bild oben).

Karteireiter "FCxxxx-Monitor"

PCI Slot/Irq: Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde.

Search...: Hierüber werden alle gesteckten FC510x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC5102 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC5101-Karten verhalten.

Hardware Configuration...: Hier kann die Hardware-Versionsnummer der FC510x angezeigt werden

Firmware: Hier wird die aktuelle Firmware-Version der FC510x angezeigt.

Firmware Update...: Hierüber kann die Firmware der FC510x-Karte aktualisiert werden.

Baudrate: Hier wird die CAN-Baudrate eingestellt.

Ring-Puffer: Hier wird die Größe des Ring-Puffers eingestellt, außerdem ist die Aufzeichnungsdauer für die eingestellte Ring-Puffer-Größe bei voller Buslastung angegeben.

Auto-Start: Wenn die Check-Box Auto-Start angeklickt ist, wird die Monitor-Aufzeichnung beim TwinCAT-Start gestartet, andernfalls muß der Start per ADS (via Monitor-Software) erfolgen.

Monitor Software

Die Monitor Software holt die Trace-Daten aus der FC510x Karte ab und legt sie als File auf dem gewünschten Massenspeicher ab. Zusätzlich zum eigentlichen Monitor-Programm (CAN-Monitor.exe) wird lediglich die DLL (TcRouterHelper.dll) benötigt. Diese hat im gleichen Verzeichnis wie das Monitor-Programm zu liegen.

Nach dem Start des Monitor-Programmes muss die Device-ID des FC5101-Kanals ausgewählt werden, der für das Monitoring verwendet wird.

Es öffnet sich das folgende Fenster:

Device-ID: Hier ist diejenige ID einzutragen, die vom System-Manager dem FC510x-Monitor-Kanal zugeteilt wurde:

Storing: Hier kann die Größe des Ringpuffer-Speichers für die Bildschirmausgabe (Display) und für die Dateiausgabe (File) eingestellt werden.

Display: Hier kann ein Filter für die Display-Ausgabe angegeben werden.

Trigger: Es können Trigger-Bedingungen angegeben werden, bei denen die Messung gestoppt werden soll. So kann beispielsweise bei Auftreten eines Fehlers ein bestimmter, sonst unbenutzter Ausgang gesetzt und auf dieses Bit im RxPDO der Ausgangsbaugruppe getriggert werden.

Post Trigger: Hier kann eingestellt werden, wie viele Telegramme nach Auftreten der Triggerbedingung noch aufgezeichnet werden sollen. Die Telegrammanzahl vor Auftreten der Triggerbedingung ist nur durch die eingestellte Pufferspeichergröße beschränkt.

Trigger und Display-Filter funktionieren so, dass bei der Auswahl der Identifier (ID) bzw. der Datenbytes (Data) nur diejenigen Bits berücksichtigt werden, bei denen die Maske 1 ist. Es werden dann diese Bits auf Übereinstimmung mit den in Value angegebenen Werten überprüft. Die Defaulteinstellung (Maske ID = 0x7FF und Maske Daten = 0x00) schlägt also zu, wenn der in Value ausgewählte Identifier (ID), unabhängig von den Daten, erkannt wird. Wenn bei Value ein Identifier (ID) größer 0x7FF (z.B. 0x800, Default) eingetragen wird, ist der Filter bzw. Trigger abgeschaltet (disabled).

Beispiel:
Die Messung soll nach 250 Telegrammen gestoppt werden, nachdem das Bit 0 im 2. Datenbyte des Telegramms mit Identifier 0x201gleich 1 ist. Hierzu ist folgendes einzutragen:

Start der Aufzeichnung

TwinCAT muss gestartet sein, und eine Variable einer zyklische Task (z.B. die Auto-Start-Task) muss mit der Dummy Variable der FC510x im Monitoring Mode verknüpft sein. Nun kann die Aufzeichnung durch Anklicken des grünen Ampel-Symbols gestartet werden.

Falls der Aufstart-Vorgang eines weiteren CANopen Kanals im System aufgezeichnet werden soll, so ist die Check Box "Auto-Start" im Karteireiter FC-Monitor des System Managers anzuwählen. Die Karte puffert dann bis zu 25000 CAN Nachrichten. Die Aufzeichnung via Monitor-Software muss dann lediglich gestartet werden, bevor der Puffer der CAN Karte überläuft.

Stopp der Aufzeichnung

Zum Beenden der Aufzeichnung ist das rote Ampel-Symbol anzuklicken. Es öffnet sich folgender Dialog:

Es werden automatisch zwei Trace Files erzeugt: ein ASCII File mit der Endung *.mon, das mit jedem Text-Editor lesbar ist. Zusätzlich wird ein File mit der Endung *.ASC erzeugt, das mit dem CANalyzer® Tool der Firma Vector Informatik eingelesen und weiterverarbeitet werden kann.

Beispiel-Trace

Dargestellt ist der Beginn eines CANopen Boot-Ups mit zwei Knoten (Node ID 1 und Node ID 50).

Number Time(100 µs) Telegram
 0 0.0638 Id: 000 Len: 2 Data: 82 00
 1 0.0649 Id: 632 Len: 8 Data: 40 00 10 00 00 00 00 00
 2 0.0653 Id: 601 Len: 8 Data: 40 00 10 00 00 00 00 00
 3 2.0722 Id: 632 Len: 8 Data: 80 00 00 00 00 00 04 05
 4 2.0725 Id: 601 Len: 8 Data: 80 00 00 00 00 00 04 05
 5 2.2686 Id: 732 Len: 1 Data: 00
 6 2.7440 Id: 701 Len: 1 Data: 00
 7 4.0802 Id: 632 Len: 8 Data: 40 00 10 00 00 00 00 00
 8 4.0806 Id: 601 Len: 8 Data: 40 00 10 00 00 00 00 00
 9 4.0813 Id: 5b2 Len: 8 Data: 43 00 10 00 91 01 02 00
10 4.0823 Id: 632 Len: 8 Data: 40 18 10 01 00 00 00 00
11 4.0826 Id: 581 Len: 8 Data: 43 00 10 00 91 01 07 00
12 4.0835 Id: 601 Len: 8 Data: 40 18 10 01 00 00 00 00
13 4.0838 Id: 5b2 Len: 8 Data: 43 18 10 01 02 00 00 00
14 4.0848 Id: 632 Len: 8 Data: 23 00 14 01 32 02 00 00
15 4.0853 Id: 581 Len: 8 Data: 43 18 10 01 02 00 00 00
16 4.0863 Id: 601 Len: 8 Data: 23 00 18 01 81 01 00 00


Beckhoff FC520x als DeviceNet-Monitor

Die FC5201 bzw. FC5202 kann ab Firmware-Version 1.04 statt als Master oder Slave auch als DeviceNet-Monitor eingesetzt werden. Die von der FC520x aufgezeichneten Telegramme werden von der mit der FC520x verknüpften Task in einem Ring-Puffer zwischengespeichert, auf die gespeicherten Telegramme kann dann per ADS zugegriffen werden. Es gibt ein DeviceNet-Monitor-Programm von Beckhoff als Share-Ware, mit der im Folgenden beschriebenen ADS-Schnittstelle können aber auch eigene Anwendungen auf die Monitor-Daten zugreifen.

Verknüpfen der FC520x mit einer Task

Der Zugriff auf die Monitor-Daten erfolgt aus der TwinCAT-Echtzeit beim Start einer Task. Daher muss eine zusätzliche Task im System-Manager angelegt werden, die mindestens eine UINT16-Eingangsvariable enthält, die mit einer der Variablen der FC520x zu verknüpfen ist.

Die Verknüpfung dient nur dazu, dass aus der Echtzeit mit der Zykluszeit der Task auf die FC520x zugegriffen werden kann. Die Zykluszeit der zusätzlichen Task ist abhängig von der Baudrate wie folgt einzustellen:

Baudrate | Zykluszeit der zusätzlichen Task
500 kBaud | <= 20 ms
250 kBaud | <= 40 ms
125 kBaud | <= 80 ms

Weiterhin ist die Check-Box Auto-Start zu setzen (s. Bild oben).

Karteireiter "FCxxxx-Monitor"

PCI Slot/Irq: Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde.

Search...: Hierüber werden alle gesteckten FC520x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC5202 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC5201-Karten verhalten.

Hardware Configuration...: Hier kann die Hardware-Versionsnummer der FC520x angezeigt werden

Firmware: Hier wird die aktuelle Firmware-Version der FC520x angezeigt.

Firmware Update...: Hierüber kann die Firmware der FC520x-Karte aktualisiert werden.

Baudrate: Hier wird die CAN- Baudrate eingestellt.

Ring-Puffer: Hier wird die Größe des Ring-Puffers eingestellt, außerdem ist die Aufzeichnungsdauer für die eingestellte Ring-Puffer-Größe bei voller Buslastung angegeben.

Auto-Start: Wenn die Check-Box Auto-Start angeklickt ist, wird die Monitor-Aufzeichnung beim TwinCAT-Start gestartet, andernfalls muss der Start per ADS erfolgen.

ADS-Schnittstelle

Im Folgenden ist die ADS-Schnittstelle des FC520x-Monitors beschrieben.

Start der Aufzeichnung

Mit dem folgenden ADS-Write-Kommando wird die Monitor-Aufzeichnung gestartet:

NET-ID: AMS-Net-ID des PCs

PORT: 300

IDXGRP: IndexGroup ist 0x5000 + Id (auf Karteireiter "Allgemein" des FC520x-Monitors) des FC520x-Monitors

IDXOFFS: IndexOffset ist 0xFFFF1000

LEN: Datenlänge ist 2

DATA: Es ist ein Wort mit dem Wert 1 zu übertragen

Stop der Aufzeichnung

Mit dem folgenden ADS-Write-Kommando wird die Monitor-Aufzeichnung gestoppt:

NET-ID: AMS-Net-ID des PCs

PORT: 300

IDXGRP: IndexGroup ist 0x5000 + Id (auf Karteireiter Allgemein des FC520x-Monitors) des FC520x-Monitors

IDXOFFS: IndexOffset ist 0xFFFF1000

LEN: Datenlänge ist 2

DATA: Es ist ein Wort mit dem Wert 0 zu übertragen

Aufbau des Ring-Puffers

Der Ring-Puffer, in dem die aufgezeichneten Telegramme gespeichert werden, ist in 4 kByte-Pages aufgeteilt. Jede Page ist wie folgt aufgebaut:

Offset | Beschreibung
0x0000 - 0x0FEF | Aufgezeichnete Telegramme (s.u.)
0x0FF0 - 0x0FF3 | reserviert
0x0FF4 - 0x0FF7 | Länge der tatsächlich gelesenen Daten (nur in der ersten gelesenen Page)
0x0FF8 - 0x0FF9 | 1: noch weitere Pages gespeichert, 0: keine weiteren Pages mehr gespeichert
0x0FFA - 0x0FFB | reserviert
0x0FFC - 0x0FFD | Ende der aufgezeichneten Telegramme in dieser Page (zeigt auf die erste Speicherstelle nach dem letzten Telegramm)
0x0FFE - 0x0FFF | Page-Nummer

Lesen der aufgezeichneten Telegramme

Mit dem folgenden ADS-Read-Kommando können die aufgezeichneten Monitor-Telegramme ausgelesen werden:

NET-ID: AMS-Net-ID des PCs

PORT: 300

IDXGRP: IndexGroup ist 0x5000 + Id (auf Karteireiter Allgemein des FC520x-Monitors) des FC520x-Monitors

IDXOFFS: IndexOffset ist 0xFFFF0000 - 0xFFFF1FFF (Bit 0-11: Nummer der ersten zu lesenden Page, Bit 12 = 0: nur volle Pages lesen, Bit 12 = 1: ggf. auch die nicht volle letzte Page lesen)

LEN: Als Datenlänge sind 0x1000 (1 Page), 0x2000 (2 Pages), 0x3000 (3 Pages) oder 0x4000 (4 Pages) erlaubt

DATA: Es werden die entsprechenden Pages geliefert

Telegrammstruktur

Die aufgezeichneten Telegramme sind wie folgt aufgebaut:

Offset | Beschreibung
0-2 | Time-Stamp in 8/25 µs
3 | 0x00: Telegramm, 0xFF: Error
4 | COB-ID, Hi-Byte
5 | COB-ID, Lo-Byte
6-13 | Daten des Telegramms


Karteireiter "Allgemein"

Zeigt allgemeine Geräteinformationen zum ausgewählen Gerät an.

Name

Zeigt den frei editierbaren Namen des, links im Baum angewählten, Gerätes.

ID

Identifikationsnummer zur internen Verwaltung im System Manager.

Typ

Gibt den Typ des jeweiligen E/A-Gerätes (Feldbusart, Bussystem etc..) an.

Kommentar

Frei wählbarer Kommentar zur näheren Erläuterung des Gerätes.

Disabled

Stellt eine Option zur Verfügung, um Konfigurationen zu Testzwecken auch ohne die jeweilige Hardware betreiben zu können. Default: Nicht angewählt.

Symbole erzeugen

Über diese Option kann die Generierung der Symbole für die Prozessdaten der IO-Task aktiviert/deaktiviert werden. Default: Nicht angewählt.


Übersicht

Unterstützte E/A Geräte (Feldbuskarten, Ethernet, USB, Sonstige...)
TwinCAT 2.8
TwinCAT 2.9