Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Einleitung

Mit TwinCAT EtherCAT Redundancy kann der TwinCAT-EtherCAT-Master um die Möglichkeit, eine Kabelredundanz zu realisieren, erweitert werden.
Vom letzten logischen Teilnehmer wird ein Kabel zum Master zurückgeführt. Konfiguration und Diagnose erfolgen im TwinCAT System Manager.

Im Fall einer einzelnen Kabelunterbrechung werden alle EtherCAT Slaves noch entweder über den Primäradapter oder über den Zweitadapter (Redundanzadapter) erreicht. Dieser Fehler muss komplett behoben sein, bevor der nächste Fehler behandelt werden kann.

Momentan ist es nicht möglich, EtherCAT Redundanz mit Distributed Clocks oder Hot Connect zu kombinieren.

Konfiguration

Die Konfiguration der Redundanz erfolgt über die Erweiterten Einstellungen beim EtherCAT Master.

Ein zweiter EtherCAT Adapter muss als Redundanzadapter ausgewählt werden. Der EtherCAT Adapter kann über den "Suchen..."-Schalter ausgewählt werden.

Zusätzlich muss der Redundanzport angewählt werden, mit dem der logisch letzte EtherCAT Slave mit dem Redundanzadapter verbunden ist. Der System Manager zeigt alle freien EtherCAT ports von den vorhandenen EtherCAT Slaves in einer Liste an.

Siehe Beispiele.

Diagnose

Im Fall eines Kabelfehlers wird die Unterbrechung über den SlaveCount (SlaveCount <> 0) und den SlaveCount2 (SlaveCount2 < CfgSlaveCount) angezeigt. CfgSlaveCount ist Bestandteil der InfoData des EtherCAT Masters. Die Zähler können in die SPS verknüpft und dort ausgewertet werden.

Zusätzlich können die States der EtherCAT Slaves ausgewertet werden. Die Unterbrechung wird als Paar von Missing Links (fehlende Verbindung) am herausgehenden Port (z.B. Port B) eines EtherCAT Slaves und dem hereinkommenden Port (z.B. Port A) des logisch folgenden EtherCAT Slaves angezeigt.

Beispiel A

Der Redundanzring wird über den Port B des EK1110 geschlossen.

Im Fall einer Kabelunterbrechung wird die Stelle in der Topologie-Ansicht Online angezeigt.

Beispiel B

Der Redundanzring wird über den Port C des EK1101 geschlossen.

Im Fall einer Kabelunterbrechung wird die Stelle in der Topologie-Ansicht Online angezeigt.


Installation

Die Installation schaltet die EtherCAT Redundanz auf dem PC frei, auf dem die Redundanz installiert wird.

Es gibt drei Versionen der EtherCAT Redundanz, die durch den Produktkey definiert werden:

- für bis 250 benutzte EtherCAT Slaves

- für bis 1000 benutzte EtherCAT Slaves

- für über 1000 benutzte EtherCAT Slaves

Voraussetzung:

TwinCAT 2.10 Build 1340 oder höher, bzw. TwinCAT 2.11 Build 1536 oder höher.