KL2819 - HD Bus Terminal, 16-channel digital output 24 V DC with diagnostics
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status
•
Non-reactive Bus Terminals


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
1.0.0
▪
First published
Firmware and hardware versions
Documentation Version | KL2819
 | Firmware | Hardware
1.0.0 | 1A | 00
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 40 15 1A 00:
40 - week of production 40
15 - year of production 2015
1A - firmware version 1A
00 - hardware version 00


Non-reactive Bus Terminals

Foreword [image] Non-reactive Bus Terminals
Non-reactive Bus Terminals
Note
Use of non-reactive Bus Terminals in safety applications
If a Bus Terminal is described as non-reactive, this means that the downstream terminal behaves passively in a safety application (e.g. in the case of the all-pole switch-off of a potential group).
In this case the terminals do not represent an active part of the safety controller and do not affect the Safety Integrity Level (SIL) or Performance Level (PL) attained in the safety application.
For details, please refer to chapter 2.17f in the TwinSAFE application manual.
Attention
Pay attention to the hardware version
Please pay attention to the information about the hardware version and non-reactivity of the respective Bus Terminal in the chapters "Technical Data" or "Firmware Compatibility"!
Only terminals with the appropriate hardware version may be used without the attained SIL/PL being affected!


KL2819 - Introduction and technical data

KL2819 - Introduction and technical data
KL2819 - Introduction and technical data
Additional information
•
Introduction and pin assignment
•
Technical data
•
Overload protection


Introduction and pin assignment

KL2819 - Introduction and technical data [image] Introduction and pin assignment
Introduction and pin assignment
KL2819
HD Bus Terminal, 16-channel digital output 24 V DC, 0.5 A, with diagnostics
The KL2819 Bus Terminal has 16 digital output channels for the switching of 24 V loads up to 0.5 A. The integrated diagnostics can be evaluated by the controller and indicated by the LEDs. Overtemperature and the lack of a voltage supply to the terminal are supplied as diagnostic information. Moreover, each of the channels can signal e.g. a short circuit. The switching state and any error of the output are indicated by the LED. Maintenance of the application is simplified by the diagnostic function. The power contacts are connected through; reference ground of the outputs is the 0 V power contact. The outputs are electrically isolated from the fieldbus side.
KL2819 – LEDs
LED | Color | Meaning
OUTPUT 1- 16 | green | off | No output signal
 |  | on | Output signal 24 V
DIAGNOSE 1- 16 | red | on | ERROR: Overcurrent / Overtemperature
KL2819 – pin assignment
Terminal point |  | Description
Name | No.
Output 1 | 1 | Output 1
Output 2 | 2 | Output 2
Output 3 | 3 | Output 3
Output 4 | 4 | Output 4
Output 5 | 5 | Output 5
Output 6 | 6 | Output 6
Output 7 | 7 | Output 7
Output 8 | 8 | Output 8
Output 9 | 9 | Output 9
Output 10 | 10 | Output 10
Output 11 | 11 | Output 11
Output 12 | 12 | Output 12
Output 13 | 13 | Output 13
Output 14 | 14 | Output 14
Output 15 | 15 | Output 15
Output 16 | 16 | Output 16


Technical data

KL2819 - Introduction and technical data [image] Technical data
Technical data
Technical data | KL2819
Connection technology | 1-wire
Number of Outputs | 16
Rated load voltage | 24 V DC (-15 %/+20 %)
Current consumpt. K-bus | typ. 30 mA
Load type | ohmic, inductive, lamp load
Max. output current | 0.5 A (short-circuit-proof) per channel
Short circuit current | < typ. 1.1 A
Breaking energy | < 300 mJ/channel
Reverse voltage protection | yes
Current consumption power contacts | typ. 50 mA + load
Electrical isolation | 500 V (K-bus/field potential)
Output stage | push (high-side switch)
Bit width in the process image | 16 bit output and diagnostics (2 x 8-Bit-control/status optional)
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Weight | approx. 70 g
Mounting | on 35 mm mounting rail according to EN 60715
Permissible ambient temperature range during operation | 0°C ... +55°C
Permissible ambient temperature range during storage | -25°C ... +85°C
Permissible relative humidity | 95 %, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6/EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2/EN 61000-6-4
Installation pos. | Variable, see section "Installation positions" of chapter "Mounting and wiring"
Protect. class | IP20
Approvals | CE


Overload protection

KL2819 - Introduction and technical data [image] Overload protection
Overload protection
The maximum continuous output current per output is around 0.5 A.
When switching on lamp loads, high starting currents occur that are limited by the output circuit of the terminals. This ensures that the upstream circuit breaker does not trip (see fig. Overload current limitation).
Overload current limitation
Schematic illustration of the thermal switch-off in case of overload
In case of a long-term overload and/or short-circuit, the output is protected by the thermal switch-off of the channel.
The output circuit of the terminal limits the current. The terminal maintains this current until important self-heating of the channel occurs.
On exceeding the upper temperature limit, the terminal switches the channel off.
The channel is switched on again after it has cooled down to below the lower temperature limit.
The output signal is clocked until the output is switched off by the controller or the short-circuit is eliminated (see fig. Schematic illustration of the thermal switch-off in case of overload). The clock frequency depends on the ambient temperature and the load of the other terminal channels. This overload cause the device temperature to rise further.
If several channels are overloaded, this leads to a rapid increase in the device temperature. The overloaded channels are switched off when the upper limit for the device temperature is exceeded. The channels are only switched on again if the temperature falls below the lower limit values for both the device and the channel. The non-overloaded channels continue operating properly.
When switching off inductive loads, high induction voltages result from interrupting the current too quickly. These are limited by an integrated freewheeling diode to approx. -35 V. Since the current reduces only slowly, a delayed switch-off can occur in many control applications. For example, a valve remains open for many milliseconds. Switch-off times are realized that correspond, for instance, to the switch-on time of the coil.
Switch-off of inductive loads


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Connection system
•
Installation positions
•
ATEX - Special conditions
•
ATEX Documentation


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection system

Mounting and wiring [image] Connection system
Connection system
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring
Standard wiring
The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring
Pluggable wiring
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Note
Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Note
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!
Wiring
Terminals for standard wiring ELxxxx / KLxxxx and terminals for steady wiring ESxxxx / KSxxxx
Mounting a cable on a terminal connection
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals ELx8xx, KLx8xx (HD)
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm
Shielding
Note
Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Attention
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. “Recommended distances for standard installation position”). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. “Recommended distances for standard installation position” is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


ATEX - Special conditions

Mounting and wiring [image] ATEX - Special conditions
ATEX - Special conditions
WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The Beckhoff fieldbus components certified for potentially explosive areas bear one of the following markings:
II 3 G Ex nA II T4 KEMA 10ATEX0075 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 KEMA 10ATEX0075 X Ta: 0 - 55°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Note
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


KS2000 Configuration software

KS2000 Configuration software
KS2000 Configuration software
Additional information
•
KS2000 - Introduction
•
Register


KS2000 - Introduction

KS2000 Configuration software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Register

KS2000 Configuration software [image] Register
Register
You can access the registers of the KL2819 directly under Register.– The meaning of the register is explained in the register overview.
Register view in KS2000


Access from the user programm

Access from the user programm
Access from the user programm
Additional information
•
Control and status bytes
•
Register overview
•
Register description


Control and status bytes

Access from the user programm [image] Control and status bytes
Control and status bytes
Additional information
•
Process data mode
•
Register communication


Process data mode

Access from the user programm [image] Control and status bytes [image] Process data mode
Process data mode
Control byte (for process data mode)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | Name | Description
CB.7 | RegAccess | 0bin | Register communication off (process data mode)
CB.6 | - | reserved
CB.5 | - | reserved
CB.4 | - | reserved
CB.3 | - | reserved
CB.2 | - | reserved
CB.1 | - | reserved
CB.0 | - | reserved
Status byte (in process data mode)
The status byte (SB) is located in the input image and is transmitted from terminal to the controller.
Bit | Name |  | Beschreibung
SB.7 | RA | RegAccess | Register access (0 = process data mode enabled)
SB.6 | DCF | Diagnostic Common Fault | A diagnostic common fault (OR Combination of all Faults)
SB.5 | MV | Missing Voltage | No Voltage for the Outputs (Up < 10 V)
SB.4 | UV | Under Voltage | Low Voltage for the Outputs (Up < 17 V)
SB.3 | OTD | Overtemperature Device | Temperature of the terminal too high
SB.2 | r | - | reserved
SB.1 | r | - | reserved
SB.0 | r | - | reserved


Register communication

Access from the user programm [image] Control and status bytes [image] Register communication
Register communication
Control byte (for register communication)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | Name | Description
CB.7 | RegAccess | 1bin | Register communication switched on
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 to CB.0 | Reg. no. | Register number: Enter here the number of the register that you wish - to read with input data word DataIN, or - to write with output data word DataOUT.
Status byte (for register communication)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | Name | Description
SB.7 | RegAccess | 1bin | Acknowledgement for register access
SB.6 | R | 0bin | Read access
SB.5 to SB.0 | Reg. no. | Number of the register that was read or written.


Register overview

Access from the user programm [image] Register overview
Register overview
The registers are used for parametering the Bus Terminals and are available for each channel. They can be read or written by means of register communication.
Register no. | Comment | Default value |  | R/W | Memory
 |  | hex | dec
R0 | reserved | 0x0000 | 0dec | - | -
… | ... | ... | … | ... | ...
R7 | Command register | 0x0000 | 0dec | - | -
R8 | Terminal type | 0x0B03 | 2819dec | R | ROM
R9 | Firmware version number | 0x3141 | 1AASCII | R | ROM
R10 | Multiplex shift register | 0x0118 | 280dec | R | ROM
R11 | Signal channels | 0x0118 | 280dec | R | ROM
R12 | Minimum data length | 0x9898 | 39064dec | R | ROM
R13 | Data structure | 0x0004 | 4dec | R | ROM
R14 | reserved | 0x0000 | 0dec | - | -
R15 | Alignment register | Typical 0x7F80 | Typical 32640dec | R/W | RAM
R16 | Hardware version number | 0x0000 | 00ASCII | R | SEEPROM
R17 | reserved | 0x0000 | 0dec | - | -
… | ... | ... | … | ... | ...
R28 | reserved | 0x0000 | 0dec | - | -
R29 | Terminal type, special identification | 0x0000 | 0dec | R | ROM
R30 | reserved | 0x0000 | 0dec | - | -
R31 | Code word register | 0x0000 | 0dec | R/W | RAM
R32 | Feature register | 0x001F | 31dec | R/W | SEEPROM
R33 | Activated Channel Diagnostic Register | 0xFFFF | 65535dec | R/W | SEEPROM
R34 | Watchdog Channel Outputs Register | 0x0000 | 0dec | R/W | SEEPROM
R35 | reserved | 0x0000 | 0dec | - | -
… | ... | ... | … | ... | ...
R63 | reserved | 0x0000 | 0dec | - | -


Register description

Access from the user programm [image] Register description
Register description
Die folgenden Register dienen zur Parametrierung der KL2819. Sie können mit Hilfe von Control-, Status- und Daten-Bytes über die Registerkommunikation ausgelesen oder beschrieben werden.
R8: Terminal description
Register R8 contains the designation of the KL2819 terminal: 0x0B03 (2819dez).
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 (1A)ASCII. '0x31' corresponds to the ASCII character '1' and '0x41' to the ASCII character 'A'. This value can not be changed.
R10: Data length (multiplex shift register)
R10 contains the number of multiplexed shift registers and their length in bits.
R11: Signal channels
Unlike R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.
R12: Minimum data length
The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control and status byte is not necessarily required for the terminal function and is not transferred to the control, if the Bus Coupler is configured accordingly.
R13: Data structure (data type register)
Data type register | Meaning
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure: 1 byte, n bytes
0x03 | Word array
0x04 | Structure: 1 byte, n words
0x05 | Double word array
0x06 | Structure: 1 byte, n double words
0x07 | Structure: 1 byte, 1 double word
0x08 | Structure: 1 byte, 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure: 1 byte, n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure: 1 byte, n words with variable logical channel length
0x15 | Double word array with variable logical channel length
0x16 | Structure: 1 byte, n double words with variable logical channel length
R15: Alignment register
Via the alignment register bits, the Bus Coupler arranges the address range of an analog terminal such that it starts at a byte boundary.
R16: Hardware version number
Register R16 contains the hardware revision level of the terminal; this value can not be changed.
R31: Code word register
▪
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset with each restart of the terminal.
R32: Feature-Register
The feature register specifies the terminal's configuration. Default: 0x001F (31dez)
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | Reserved
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | Reserved |  | WDEn | Reserved
WDEn (Watchdog Enable)
State | Effect
0 | The last state of the outputs will be conserved in case of a bus error.
1 | The defined states of register R34 will be switched to the outputs in case of a bus error.
R33: Active Channel Diagnostic
The register “Active Channel Diagnostic” switches the diagnostic function for each channel on or off:
▪
0: Diagnostic function active on channel
▪
1: Diagnostic function not active on channel
Default: 0xFFFF (65535dez)
Bit | R33.15 | R33.14 | R33.13 | R33.12 | R33.11 | R33.10 | R33.9 | R33.8
Name | Diag. on Channel 16 | Diag. on Channel 15 | Diag. on Channel 14 | Diag. on Channel 13 | Diag. on Channel 12 | Diag. on Channel 11 | Diag. on Channel 10 | Diag. on Channel 9
Bit | R33.7 | R33.6 | R33.5 | R33.4 | R33.3 | R33.2 | R33.1 | R33.0
Name | Diag. on Channel 8 | Diag. on Channel 7 | Diag. on Channel 6 | Diag. on Channel 5 | Diag. on Channel 4 | Diag. on Channel 3 | Diag. on Channel 2 | Diag. on Channel 1
R34: Watchdog Outputs Register
Das Watchdog Ausgangs Register legt die Zustände der Ausgänge bei einem Busfehler fest, wenn WDEn des Feature Regsiters R32 aktiviert ist.
The Watchdog Outputs Register defines the state of the Channel Outputs in case of a bus error.
Default: 0x0000.
Bit | R34.15 | R34.14 | R34.13 | R34.12 | R34.11 | R34.10 | R34.9 | R34.8
Name | Definition output Channel 16 | Definition output Channel 15 | Definition output Channel 14 | Definition output Channel 13 | Definition output Channel 12 | Definition output Channel 11 | Definition output Channel 10 | Definition output Channel 9
Bit | R34.7 | R34.6 | R34.5 | R34.4 | R34.3 | R34.2 | R34.1 | R34.0
Name | Definition output Channel 8 | Definition output Channel 7 | Definition output Channel 6 | Definition output Channel 5 | Definition output Channel 4 | Definition output Channel 3 | Definition output Channel 2 | Definition output Channel 1


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com