EP31xx-xxxx - EtherCAT Box modules with analog inputs
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.6
▪
Front page updated
2.5
▪
EP3174-0092: Technical data updated
▪
Structural update
2.4
▪
EP3184-x002 - Introduction: graphics corrected
▪
Structural update
2.3.0
▪
Nut torques for connectors updated
▪
EP3174-0092 added
▪
Chapter Mounting updated
▪
Chapter Operation modes updated
▪
Structural update
2.2.0
▪
EP3162-0002 - M12 analog voltage inputs updated
▪
EP3162-0002 - M12 analog current inputs updated
▪
EP3162-0002 - Electrical isolation of the channels updated
▪
Notes on the analog specification added
▪
Cabling updated
2.1.0
▪
EP3162-0002 added
▪
EP31x4 - Object description and parameterization updated
▪
EP31x2 - Object description and parameterization added
▪
EP31x4 - Object overview updated
▪
EP31x2 - Object overview added
▪
Nut torques for connectors updated
▪
Power supply added
2.0.0
▪
Migration
1.5.0
▪
Connection description for analog current inputs (M12) revised
▪
Chapter "Settings and operation modes" updated
1.4.0
▪
Signal settings amended
▪
Connection of the sensors updated
1.3.0
▪
Object description updated
1.2.0
▪
Technical data updated
▪
Overview of EtherCAT cables extended
▪
Mounting and Cabling updated
1.1.0
▪
Description of the Power LEDs expanded
▪
Object description extended
▪
Technical data updated
1.0.1
▪
Object description corrected
1.0.0
▪
Description of the Status LEDs revised
0.6
▪
EP3182-1002 added
▪
Accessories added
▪
Nut torque for connectors added
▪
Object description corrected
0.5
▪
First preliminary version
Firm and hardware version
The documentation refers to the firm and hardware status that was valid at the time it was prepared.
The properties of the modules are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D number) printed at the side of the EtherCAT Box.
Syntax of the batch number (D number)
D: WW YY FF HH | Example with D No. 29 10 02 01:
WW - week of production (calendar week) | 29 - week of production 29
YY - year of production | 10 - year of production 2010
FF - firmware version | 02 - firmware version 02
HH - hardware version | 01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product overview

Product overview
Product overview
Additional information
•
Module overview
•
EP3162
•
EP3182
•
EP31x4


Module overview

Product overview [image] Module overview
Module overview
Analog input modules, 24 VDC
Module | Number of analog inputs | Number of digital outputs | Signal connection | Comment
EP3162-0002 | 2 | 0 | 2 x M12 | Single-ended inputs
EP3174-0002 | 4 | 0 | 4 x M12 | Differential inputs
EP3174-0092 | 4 | 0 | 4 x M12 | Differential inputs, TwinSAFE Single Channel
EP3182-1002 | 2 | 2 | 2 x M12 | Single-ended inputs, digital outputs
EP3184-0002 | 4 | 0 | 4 x M12 | Single-ended inputs
EP3184-1002 | 4 | 0 | 2 x M12 | Single-ended inputs, two inputs per connection


EP3162

Product overview [image] EP3162
EP3162
Additional information
•
EP3162 - Introduction
•
EP3162 - Technical data
•
EP3162 - Scope of supply
•
EP3162 - Process image


EP3162 - Introduction

Product overview [image] EP3162 [image] EP3162 - Introduction
EP3162 - Introduction
EP3162-0002
2-channel analog input ± 10 V or 0/4...20 mA, electrically isolated, single-ended, 16-bit
The EP3162 EtherCAT Box has two analog inputs that can be individually parameterized to process signals either in the range from -10 V to +10 V or from 0/4 mA to 20 mA. The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.
The two input channels are electrically isolated from each other. The input filter and therefore the conversion times are configurable in a wide range. The inputs can, if required, be scaled differently, and automatic limit value monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.
Quick Links


EP3162 - Technical data

Product overview [image] EP3162 [image] EP3162 - Technical data
EP3162 - Technical data
Technical data
EP3162-0002
Fieldbus
Fieldbus
EtherCAT
Connection
2x M8 socket, 4-pin, green
Electrical isolation
500 V (fieldbus / IO)
Distributed Clocks
Yes
Supply voltages
Connection
Input: 1 x M8 plug, 4-pin, black
Downstream connection: 1 x M8 socket, 4-pin, black
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Consumers
▪
Module electronics: 120 mA
▪
Sensors 2)
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Consumers
None. UP is only forwarded.
Analog inputs
Number
2
Connection
2x M12 socket, 5-pin
Input type
Single-ended
Signal range
Parameterizable:
▪
-10 .. +10 V (default)
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA
▪
-20 .. +20 mA
Digital resolution
16-bit, including sign
Measuring error
max 0.3%, relative to the full scale value
Input resistance
Voltage measurement: min. 200 kΩ
Current measurement: 85 Ω + diode voltage
Dielectric strength
max. 30 V
Electrical isolation
300 V between the input channels
Conversion time
approx. 100 µs
Input filter limit frequency
5 kHz
Input filter characteristic
Parameterizable
Sensor supply voltage UA 3)
24 VDC, isolated potential.
Output current per channel:
max. continuous current 50 mA
max. peak current 100 mA
1) This value corresponds to the current carrying capacity of the connections for the supply voltages.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Technical data | EP3162-0002
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cURus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 conforms to EN 60529
Mechanics
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cURus


EP3162 - Scope of supply

Product overview [image] EP3162 [image] EP3162 - Scope of supply
EP3162 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP3162-0002
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP3162 - Process image

Product overview [image] EP3162 [image] EP3162 - Process image
EP3162 - Process image
AI Standard Channel 1 and 2
You will find the data of the 1st analog channel under AI Standard Channel 1.
The data of the 2nd channel (AI Standard Channel 2) are structured identically to those of the 1st channel.


EP3182

Product overview [image] EP3182
EP3182
Additional information
•
EP3182 - Introduction
•
EP3182 - Technical data
•
EP3182 - Scope of supply
•
EP3182 - Process image


EP3182 - Introduction

Product overview [image] EP3182 [image] EP3182 - Introduction
EP3182 - Introduction
EP3182-1002
2-channel analog input ±10 V or 0/4...20 mA, parameterizable, single-ended, 16-bit, 2 digital control outputs 24 VDC, short-circuit proof
Analog inputs (single-ended)
The EP3182-1002 EtherCAT Box has two analog inputs which can be individually parameterized, so that they process signals either in the -10 V to +10 V range or the 0/4 mA…20 mA range.
The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.
The two input channels are single-ended and share a common internal ground potential. The input filter and therefore the conversion times are configurable in a wide range.
The inputs can, if required, be scaled differently, and automatic limit value monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.
Digital outputs
In addition, the EP3182-1002 EtherCAT Box has two digital outputs via which it forwards the binary control signals from the controller to the actuators at the process level.
These two outputs (sink/source type) are intended for the switching of logic inputs or outputs with a minimum impedance of 10 kOhm (e.g. reset inputs of digital sensors) and can process currents up to 2 mA. They indicate their signal state by LEDs and are short-circuit proof.
The signals are also connected via the two M12 connectors.
Quick-Links


EP3182 - Technical data

Product overview [image] EP3182 [image] EP3182 - Technical data
EP3182 - Technical data
Technical data
EP3182-1002
Fieldbus
Fieldbus
EtherCAT
Connection
2x M8 socket, 4-pin, green
Electrical isolation
500 V (fieldbus / IO)
Supply voltages
Connection
Input: 1 x M8 plug, 4-pin, black
Downstream connection: 1 x M8 socket, 4-pin, black
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Consumers
Module electronics: 120 mA
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Consumers
▪
Sensors 2)
▪
Loads at digital outputs
Analog inputs
Number
2
Connection
2x M12 socket, 5-pin
Input type
Single-ended
Signal range
Parameterizable:
▪
-10 .. +10 V (default)
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA
Digital resolution
16-bit, including sign
Measuring error
max 0.3%, relative to the full scale value
Input resistance
Voltage measurement: min. 200 kΩ
Current measurement: 85 Ω + diode voltage
Dielectric strength
max. 30 V
Conversion time
approx. 100 µs
Input filter limit frequency
5 kHz
Input filter characteristic
Parameterizable
Sensor supply voltage UA 3)
24 VDC taken from the peripheral voltage UP,
not short-circuit proof
1) This value corresponds to the current carrying capacity of the connections for the supply voltages.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Technical data | EP3182-1002
Digital outputs
Number | 2
Connection | M12 sockets of the analog inputs
Nominal voltage | 24 VDC from peripheral voltage UP
Output current IOUT | 2 mA per output, short-circuit proof
Internal resistance | approx. 2350 Ω (high level)
Impedance of connected inputs | min. 10 kΩ
Environmental conditions
Ambient temperature during operation | 0 .. +55 °C
Ambient temperature during storage | -40 .. +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cURus


EP3182 - Scope of supply

Product overview [image] EP3182 [image] EP3182 - Scope of supply
EP3182 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP3182-1002
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP3182 - Process image

Product overview [image] EP3182 [image] EP3182 - Process image
EP3182 - Process image
Analog inputs
AI Standard Channel 1
You will find the data of the 1st analog channel under AI Standard Channel 1.
AI Standard Channel 2
The data of the second analog channel have the same structure as those of the first channel.
Digital outputs
DO Outputs
The digital outputs of the module can be found under DO Outputs.


EP31x4

Product overview [image] EP31x4
EP31x4
Additional information
•
EP3174-0002 - Introduction
•
EP3174-0092 - Introduction
•
EP3184-0002 - Introduction
•
EP3184-1002 - Introduction
•
EP31x4 - Technical data
•
EP31x4 - Scope of supply
•
EP31x4 - Process image
•
EP3174-0092 – Process image (with TwinSAFE SC modules)


EP3174-0002 - Introduction

Product overview [image] EP31x4 [image] EP3174-0002 - Introduction
EP3174-0002 - Introduction
EP3174-0002
4-channel analog input ±10 V or 0/4...20 mA, parameterizable, differential input, 16-bit
The EP3174-0002 EtherCAT Box has four analog inputs which can be individually parameterized, so that they process signals either in the -10 V to +10 V range or the 0/4 mA…20 mA range.
The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.
The four input channels have differential inputs and possess a common, internal ground potential. The input filter and therefore the conversion times are configurable in a wide range.
The inputs can, if required, be scaled differently, and automatic limit value monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.
Quick Links


EP3174-0092 - Introduction

Product overview [image] EP31x4 [image] EP3174-0092 - Introduction
EP3174-0092 - Introduction
EP3174-0092
4-channel analog input ±10 V or 0/4...20 mA, differential input, 16-bit, TwinSAFE Single Channel
In addition to the full range of functions of the EP3174-0002, the EP3174-0092 supports the TwinSAFE SC technology (TwinSAFE Single Channel). This enables the use of standard signals for safety tasks in any networks of fieldbuses.
Quick Links
Technical data
Process image
Dimensions
Signal connection
Configuration
Object description and parameterization
Objects TwinSAFE Single Channel
TwinSAFE SC process data


EP3184-0002 - Introduction

Product overview [image] EP31x4 [image] EP3184-0002 - Introduction
EP3184-0002 - Introduction
EP3184-0002
4-channel analog input ±10 V or 0/4...20 mA, parameterizable, single-ended, 16-bit
The EP3184-0002 EtherCAT Box has four analog inputs which can be individually parameterized, so that they process signals either in the -10 V to +10 V range or the 0/4 mA…20 mA range.
The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.
The four input channels are single-ended and share a common internal ground potential. The input filter and therefore the conversion times are configurable in a wide range.
The inputs can, if required, be scaled differently, and automatic limit value monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.
Quick Links


EP3184-1002 - Introduction

Product overview [image] EP31x4 [image] EP3184-1002 - Introduction
EP3184-1002 - Introduction
EP3184-1002
4-channel analog input ±10 V or 0/4...20 mA, parameterizable, single-ended, 16-bit
The EP3184-1002 EtherCAT Box has four analog inputs which can be individually parameterized, so that they process signals either in the -10 V to +10 V range or the 0/4 mA…20 mA range.
Two inputs are combined in each case on sockets 1 and 3. Sockets 2 and 4 have no function.
The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.
The four input channels are single-ended and share a common internal ground potential. The input filter and therefore the conversion times are configurable in a wide range.
The inputs can, if required, be scaled differently, and automatic limit value monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.
Quick Links


EP31x4 - Technical data

Product overview [image] EP31x4 [image] EP31x4 - Technical data
EP31x4 - Technical data
Technical data
EP3174-0002
EP3174-0092
EP3184-0002
EP3184-1002
Fieldbus
Fieldbus
EtherCAT
Connection
2 x M8 socket, green
Electrical isolation
500 V (fieldbus / IO)
Distributed Clocks
Yes
Supply voltages
Connection
Feed: 1 x M8 plug, 4-pin, black
Downstream connection: 1 x M8 socket, 4-pin, black
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Consumers
Module electronics: 120 mA
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Consumers
Sensors 2)
Analog inputs
Number
4
Connection
4x M12 socket, 5-pin
2x M12 socket,
5-pin
Input type
Differential
Single-ended
Signal range
Parameterizable:
▪
-10 .. +10 V (default)
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA
Digital resolution
16-bit, including sign
Measuring error
max 0.3%, relative to the full scale value
Input resistance
Voltage measurement: min. 200 kΩ
Current measurement: 85 Ω + diode voltage
Common-mode voltage UCM
max. 35 V
-
Dielectric strength
max. 30 V
Conversion time
approx. 100 µs
Input filter limit frequency
5 kHz
Input filter characteristic
Parameterizable
Sensor supply voltage UA 3)
24 VDC from peripheral voltage UP
1) This value corresponds to the current carrying capacity of the connections for the supply voltages.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Technical data | EP3174-0002 | EP3174-0092 | EP3184-0002 | EP3184-1002
Environmental conditions
Ambient temperature during operation | -25 .. +60 °C -25 .. +55 °C conforms to cURus 0 .. +55 °C conforms to ATEX
Ambient temperature during storage | -40 .. +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 conforms to EN 60529
Mechanics
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cURus, ATEX


EP31x4 - Scope of supply

Product overview [image] EP31x4 [image] EP31x4 - Scope of supply
EP31x4 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP3174-0002 / EP3174-0092 / EP3184-0002 / EP3184-1002
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP31x4 - Process image

Product overview [image] EP31x4 [image] EP31x4 - Process image
EP31x4 - Process image
The process data of the EP3174-0002, EP3174-0092, EP3184-0002 and EP3184-1002 modules are identical in the default setting and are illustrated here taking the EP3174-0002 as an example.
AI Standard Channel 1
You will find the data of the 1st analog channel under AI Standard Channel 1.
AI Standard Channel 2 to 4
The data of analog channels 2 to 4 have the same structure as those of the 1st channel.


EP3174-0092 – Process image (with TwinSAFE SC modules)

Product overview [image] EP31x4 [image] EP3174-0092 – Process image (with TwinSAFE SC modules)
EP3174-0092 – Process image (with TwinSAFE SC modules)
In the following illustration the process data are shown after inserting the TwinSAFE SC module as described in the chapter TwinSAFE SC configuration.
Under Module 1 (EP3174-0092) you will find
▪
the TSC input data and

▪
the TSC output data.

You will find the data of the 1st analog channel under AI Standard Channel 1.
AI Standard Channel 2 to 4
The data of analog channels 2 to 4 have the same structure as those of the 1st channel.


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT
•
Supply voltages
•
UL Requirements
•
ATEX notes
•
EP3162-0002 - Electrical isolation of the channels
•
EP3162-0002 – Signal connection and Status LEDs
•
EP3174-00x2 - Signal connection and Status LEDs
•
EP3182-1002 – Signal connection and Status LEDs
•
EP3184-0002 – Signal connection and Status LEDs
•
EP3184-1002 – Signal connection and Status LEDs


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Tightening torques for plug connectors


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Tightening torques for plug connectors

Mounting and cabling [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


EtherCAT

Mounting and cabling [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and cabling [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and cabling [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and cabling [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Supply voltages

Mounting and cabling [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.
▪
Control voltage US
▪
Peripheral voltage UP
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and cabling [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs

Mounting and cabling [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and cabling [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


UL Requirements

Mounting and cabling [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX notes

Mounting and cabling [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Mounting and cabling [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Mounting and cabling [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Mounting and cabling [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


EP3162-0002 - Electrical isolation of the channels

Mounting and cabling [image] EP3162-0002 - Electrical isolation of the channels
EP3162-0002 - Electrical isolation of the channels
The block diagram shown below illustrates the principle of the electrical isolation of the two channels. The 24 V with which the channels are supplied come from an electrically isolated DC/DC and are thus UA instead of US.
Blockschaltbild galvanische Trennung
Block diagram: electrical isolation
Electrical isolation of GND
The GNDs of channel 1 (GNDA) and channel 2 (GNDB) are electrically isolated from each other.


EP3162-0002 – Signal connection and Status LEDs

Mounting and cabling [image] EP3162-0002 – Signal connection and Status LEDs
EP3162-0002 – Signal connection and Status LEDs
Additional information
•
Analog voltage inputs M12, one single-ended input per socket
•
M12 analog current inputs, one single-ended input per socket
•
Status LEDs at the M12 connections


Analog voltage inputs M12, one single-ended input per socket

Mounting and cabling [image] EP3162-0002 – Signal connection and Status LEDs [image] Analog voltage inputs M12, one single-ended input per socket
Analog voltage inputs M12, one single-ended input per socket
Analog input, -10 V to +10 V or 0 V to +10 V
Analoge Spannungseingänge M12_ein Single Ended Eingang_1
M12 analog voltage input, channel 1
Analoge Spannungseingänge M12_ein Single Ended Eingang_Kanal2
M12 analog voltage input, channel 2
Refer to the chapter EP3162-0002 - Electrical isolation of the channels for additional information.


M12 analog current inputs, one single-ended input per socket

Mounting and cabling [image] EP3162-0002 – Signal connection and Status LEDs [image] M12 analog current inputs, one single-ended input per socket
M12 analog current inputs, one single-ended input per socket
Analog input, 0 mA to 20 mA, 4 to 20 mA or -20 mA to 20 mA
Analoge Stromeingänge M12_ein Single Ended Eingang_1
M12 analog current inputs, channel 1
Analoge Stromeingänge M12_ein Single Ended Eingang_Kanal2
M12 analog current inputs, channel 2
Refer to the chapter EP3162-0002 - Electrical isolation of the channels for additional information.


Status LEDs at the M12 connections

Mounting and cabling [image] EP3162-0002 – Signal connection and Status LEDs [image] Status LEDs at the M12 connections
Status LEDs at the M12 connections
Status LEDs an den M12-Anschlüssen_grün
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket no. 0-1 | R left | off | No data transfer to the A/D converter
 |  | green | Data transfer to A/D converter
 | E right | off | Function OK
 |  | red | Error: Broken wire or measured value outside the measuring range
Correct function is indicated if the green RUN LED is on and the red Error LED is off.


EP3174-00x2 - Signal connection and Status LEDs

Mounting and cabling [image] EP3174-00x2 - Signal connection and Status LEDs
EP3174-00x2 - Signal connection and Status LEDs
Additional information
•
M12 analog voltage inputs, one differential input per socket
•
M12 analog current inputs, one differential input per socket
•
Status LEDs at the M12 connections


M12 analog voltage inputs, one differential input per socket

Mounting and cabling [image] EP3174-00x2 - Signal connection and Status LEDs [image] M12 analog voltage inputs, one differential input per socket
M12 analog voltage inputs, one differential input per socket
Analog inputs, -10 V to +10 V differential
M12 analog voltage inputs, one differential input per socket


M12 analog current inputs, one differential input per socket

Mounting and cabling [image] EP3174-00x2 - Signal connection and Status LEDs [image] M12 analog current inputs, one differential input per socket
M12 analog current inputs, one differential input per socket
Analog inputs, 0 mA to 20 mA or 4 mA to 20 mA differential
M12 analog current inputs, one differential input per socket


Status LEDs at the M12 connections

Mounting and cabling [image] EP3174-00x2 - Signal connection and Status LEDs [image] Status LEDs at the M12 connections
Status LEDs at the M12 connections
Status LEDs an den M12-Anschlüssen_grün
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket no. 1-4 | R left | off | No data transfer to the A/D converter
 |  | green | Data transfer to A/D converter
 | E right | off | Function OK
 |  | red | Error: Broken wire or measured value outside the measuring range
Correct function is indicated if the green RUN LED is on and the red Error LED is off.


EP3182-1002 – Signal connection and Status LEDs

Mounting and cabling [image] EP3182-1002 – Signal connection and Status LEDs
EP3182-1002 – Signal connection and Status LEDs
Additional information
•
Analog voltage inputs, M12 digital output, one single-ended input and one digital output per socket
•
Analog current inputs, M12 digital output, one single-ended input and one digital output per socket
•
Status LEDs at the M12 connections


Analog voltage inputs, M12 digital output, one single-ended input and one digital output per socket

Mounting and cabling [image] EP3182-1002 – Signal connection and Status LEDs [image] Analog voltage inputs, M12 digital output, one single-ended input and one digital output per socket
Analog voltage inputs, M12 digital output, one single-ended input and one digital output per socket
Analog input, -10 to +10 V, digital output
M12 analog voltage inputs


Analog current inputs, M12 digital output, one single-ended input and one digital output per socket

Mounting and cabling [image] EP3182-1002 – Signal connection and Status LEDs [image] Analog current inputs, M12 digital output, one single-ended input and one digital output per socket
Analog current inputs, M12 digital output, one single-ended input and one digital output per socket
Analog input, 0 to 20 mA, 4 to 20 mA, digital output
M12 current inputs


Status LEDs at the M12 connections

Mounting and cabling [image] EP3182-1002 – Signal connection and Status LEDs [image] Status LEDs at the M12 connections
Status LEDs at the M12 connections
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket no. 1-2 | R left | off | Analog input: No data transfer to the A/D converter
 |  | green | Analog input: Data transfer to A/D converter
 |  | red | Error at the analog input: Broken wire or measured value outside the measuring range
 | 1 right | off | Digital output switched off
 |  | green | Digital output switched on
Function is without error if the left-hand LED is green.


EP3184-0002 – Signal connection and Status LEDs

Mounting and cabling [image] EP3184-0002 – Signal connection and Status LEDs
EP3184-0002 – Signal connection and Status LEDs
Additional information
•
Analog voltage inputs M12, one single-ended input per socket
•
M12 analog current inputs, one single-ended input per socket
•
Status LEDs at the M12 connections


Analog voltage inputs M12, one single-ended input per socket

Mounting and cabling [image] EP3184-0002 – Signal connection and Status LEDs [image] Analog voltage inputs M12, one single-ended input per socket
Analog voltage inputs M12, one single-ended input per socket
Analog input, -10 V to +10 V
Analog voltage inputs M12, one single-ended input per socket
GND connections
If several sensors are connected to a box whose GND connections are not electrically isolated, GND must be connected to GNDp.


M12 analog current inputs, one single-ended input per socket

Mounting and cabling [image] EP3184-0002 – Signal connection and Status LEDs [image] M12 analog current inputs, one single-ended input per socket
M12 analog current inputs, one single-ended input per socket
Analog input, 0 to 20 mA, or 4 to 20 mA
M12 analog current inputs, one single-ended input per socket
GND connections
If several sensors are connected to a box whose GND connections are not electrically isolated, GND must be connected to GNDp.


Status LEDs at the M12 connections

Mounting and cabling [image] EP3184-0002 – Signal connection and Status LEDs [image] Status LEDs at the M12 connections
Status LEDs at the M12 connections
Status LEDs an den M12-Anschlüssen_grün
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket no. 1-4 | R left | off | No data transfer to the A/D converter
 |  | green | Data transfer to A/D converter
 | E right | off | Function OK
 |  | red | Error: Broken wire or measured value outside the measuring range
Correct function is indicated if the green RUN LED is on and the red Error LED is off.


EP3184-1002 – Signal connection and Status LEDs

Mounting and cabling [image] EP3184-1002 – Signal connection and Status LEDs
EP3184-1002 – Signal connection and Status LEDs
Additional information
•
M12 analog voltage inputs, two single-ended inputs per socket
•
M12 analog current inputs, two single-ended inputs per socket
•
Status LEDs at the M12 connections


M12 analog voltage inputs, two single-ended inputs per socket

Mounting and cabling [image] EP3184-1002 – Signal connection and Status LEDs [image] M12 analog voltage inputs, two single-ended inputs per socket
M12 analog voltage inputs, two single-ended inputs per socket
Analog inputs, -10 V to +10 V
M12 analog voltage inputs, two single-ended inputs per socket
GND connections
If several sensors are connected to a box whose GND connections are not electrically isolated, GND must be connected to GNDp.


M12 analog current inputs, two single-ended inputs per socket

Mounting and cabling [image] EP3184-1002 – Signal connection and Status LEDs [image] M12 analog current inputs, two single-ended inputs per socket
M12 analog current inputs, two single-ended inputs per socket
Analog inputs, 0 mA to 20 mA or 4 mA to 20 mA
M12 analog current inputs, two single-ended inputs per socket
GND connections
If several sensors are connected to a box whose GND connections are not electrically isolated, GND must be connected to GNDp.


Status LEDs at the M12 connections

Mounting and cabling [image] EP3184-1002 – Signal connection and Status LEDs [image] Status LEDs at the M12 connections
Status LEDs at the M12 connections
Status LEDs an den M12-Anschlüssen_grün
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket no. 1, 3 Sockets 2 and 4 are not used. | R left | off | No data transfer to the A/D converter
 |  | green | Data transfer to A/D converter
 | E right | off | Function OK
 |  | red | Error: Broken wire or measured value outside the measuring range
Correct function is indicated if the green RUN LED is on and the red Error LED is off.


Configuration

Configuration
Configuration
Additional information
•
Inserting into the EtherCAT network
•
Configuration via TwinCAT
•
EtherCAT State Machine
•
CoE interface
•
Notices on analog specifications
•
EP31xx - Settings and operating modes
•
Data stream
•
Measuring ranges
•
Calibration
•
Calculation of process data
•
TwinSAFE SC
•
EP3174-0092 - TwinSAFE SC process data
•
EP3162-0002 - Object overview
•
EP3182-1002 - Object overview
•
EP31x4-x002 - Object overview
•
EP3174-0092 - Object overview
•
EP31x2 - Object description and parameterization
•
EP31x4 - Object description and parameterization
•
Objects TwinSAFE Single Channel (EP3174-0092)
•
Restoring the delivery state
•
Decommissioning


Inserting into the EtherCAT network

Configuration [image] Inserting into the EtherCAT network
Inserting into the EtherCAT network
Installation of the latest XML device description
Please ensure that you have installed the latest XML device description in TwinCAT. This can be downloaded from the Beckhoff website (http://www.beckhoff.de/english/download/elconfg.htm?id=1983920606140) and installed according to the installation instructions.
At the Beckhoff TwinCAT System Manager the configuration tree can be build in two different ways:
▪
by scanning for existing hardware (called "online") and
▪
by manual inserting/appending of fieldbus devices, couplers and slaves.
Automatic scanning in of the box
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode), and scan in the devices (see Fig. 1). Acknowledge all dialogs with "OK", so that the configuration is in "FreeRun" mode.
Scanning in the configuration (I/O Devices -> right-click -> Scan Devices...)
Appending a module manually
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode)
▪
Append a new I/O device. In the dialog that appears select the device EtherCAT (Direct Mode), and confirm with OK.
Appending a new I/O device (I/O Devices -> right-click -> Append Device...)
Selecting the device EtherCAT
▪
Append a new box.
Appending a new box (Device -> right-click -> Append Box...)
▪
In the dialog that appears select the desired box (e.g. EP2816-0008), and confirm with OK.
Selecting a Box (e.g. EP2816-0008)
Appended Box in the TwinCAT tree


Configuration via TwinCAT

Configuration [image] Configuration via TwinCAT
Configuration via TwinCAT
In the left-hand window of the TwinCAT System Manager, click on the branch of the EtherCAT Box you wish to configure (EP2816-0008 in this example).
Branch of the EtherCAT box to be configured
In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the EtherCAT Box.
General tab
General tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this checkbox is activated.
EtherCAT tab
EtherCAT tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the checkbox to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combobox is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
Process Data tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
•
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
•
and the System Manager has to reload the EtherCAT slaves ( [image] button)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.
Startup tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
Startup tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
CoE - Online tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object directory of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
CoE - Online tab
Object list display
Column | Description
Index | Index and subindex of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Advanced settings
Online - via SDO information | If this option button is selected, the list of the objects included in the object directory of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS file | If this option button is selected, the list of the objects included in the object directory is read from an EDS file provided by the user.
Online tab
Online tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


EtherCAT State Machine

Configuration [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
Mailbox and process data communication is possible in the Safe-Op state, but the slave keeps its outputs in the safe state. However, the input data are cyclically updated.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE interface

Configuration [image] CoE interface
CoE interface
General description
The CoE interface (CANopen over EtherCAT) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the properties.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
Organization takes place on 2 levels by means of hexadecimal numbering: the (main) index is named first, then the subindex. The value ranges are:
▪
Index 0 to 65535
▪
Subindex: 0…255
A parameter localized in this way is normally written as 0x8010:07, with preceding "0x" to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: In some EtherCAT devices the channel parameters are stored here (as an alternative to the 0x8000 range).
▪
0x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs ("output" from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
CoE-Online tab
The CoE objects from 0x1000 to 0x1600, which are available in the example device "EL2502", can be seen in the above figure; the subindices from 0x1018 are expanded.
Data management
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (figure above) by clicking. This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterized and enter a value in the SetValue dialog.
▪
from the control system/PLC via ADS, e.g. through function blocks from the TcEtherCAT.lib library This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If CoE parameters on the slave are changed online, this is saved fail-safe in the device (EEPROM) in Beckhoff devices. This means that the changed CoE parameters are still retained after a restart. The situation may be different with other manufacturers.
Startup list
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the factory settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager. The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list. The order of the Startup entries is usually irrelevant.
StartUp-Liste im TwinCAT System Manager
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline directory
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE directory is visible according to the figure "CoE-Online tab", but the connectivity is displayed as offline/online.
▪
If the slave is offline
–
the offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
the configured status is shown under Identity
–
no firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red
Offline list
▪
If the slave is online
–
the actual current slave directory is read. This may take several seconds, depending on the size and cycle time.
–
the actual identity is displayed
–
the firmware and hardware version of the equipment according to the electronic information is displayed.
–
Online is shown in green
Online list
Channel-based order
The CoE directory is located in EtherCAT devices that usually encompass several functionally equivalent channels. e.g. a 4-channel 0 – 10 V analog input terminal also has 4 logical channels and thus 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
…
This is generally written as 0x80n0. Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Notices on analog specifications

Configuration [image] Notices on analog specifications
Notices on analog specifications
Beckhoff I/O devices (terminals, boxes) with analog inputs are characterized by a number of technical characteristic data; refer to the technical data in the respective documents.
Some explanations are given below for the correct interpretation of these characteristic data.
Full scale value
An I/O device with an analog input measures over a nominal measuring range that is limited by an upper and a lower limit (initial value and end value); these can usually be taken from the terminal/box designation. The range between the two limits is called the measuring span and corresponds to the equation (end value - initial value). Analogous to pointing devices this is the measuring scale (see IEC 61131) or also the dynamic range. For analog I/O devices from Beckhoff the rule is that the limit with the largest value is chosen as the full scale value of the respective product (also called the reference value) and is given a positive sign. This applies to both symmetrical and asymmetrical measuring spans.
Measuring range
For the above examples this means:
▪
Measuring range 0 to 10 V: asymmetric unipolar, full scale value = 10 V, measuring span = 10 V
▪
Measuring range 4 to 20 mA: asymmetric unipolar, full scale value = 20 mA, measuring span = 16 mA
▪
Measuring range -200 to 1370 °C: asymmetric bipolar, full scale value = 1370 °C, measuring span = 1570 °C
▪
Measuring range -10 to +10 V: symmetric bipolar, full scale value = 10 V, measuring span = 20 V
This applies equally for analog output terminals/boxes.
± Measuring error [% of the full scale value] (also: measurement error)
The relative measuring error is referenced to the full scale value and is calculated as the quotient of the largest numerical deviation from the true value (‘measuring error’) referenced to the full scale value.
The measuring error is generally valid for the entire permitted operating temperature range, also called the ‘usage error limit’ and contains random and systematic portions of the referred device (i.e. ‘all’ influences such as temperature, inherent noise, aging, etc.).
It always to be regarded as a positive/negative span with ±, even if it is specified without ± in some cases.
The maximum deviation can also be specified directly.
Example: Measuring range 0 to 10 V and measuring error < ± 0.3 % full scale value → maximum deviation ± 30 mV in the permissible operating temperature range.
Notice: since this specification also includes the temperature drift, a significantly lower measuring error can usually be assumed in case of a constant ambient temperature and thermal stabilization of the device. This applies equally for analog output terminals/boxes.
Single-ended/differential typification
For analog inputs Beckhoff makes a basic distinction between two types: single-ended (SE) and differential (DIFF), referring to the difference in electrical connection with regard to the potential difference.
The diagram shows two-channel versions of an SE module and a DIFF module as examples for all multi-channel versions.
Single-ended/differential typification
Notice: Dashed lines indicate that the respective connection may not necessarily be present in each SE or DIFF module.
The basic rule:
▪
Analog measurements always take the form of voltage measurements between two potential points. For voltage measurements a large R is used, in order to ensure a high impedance. For current measurements a small R is used as shunt. If the purpose is resistance measurement, corresponding considerations are applied.
–
Beckhoff generally refers to these two points as input+/signal potential and input-/reference potential.
–
For measurements between two potential points two potentials have to be supplied.
–
Regarding the terms "single-wire connection" or "three-wire connection", please note the following for pure analog measurements: three- or four-wire connections can be used for sensor supply, but are not involved in the actual analog measurement, which always takes place between two potentials/wires. In particular this also applies to SE, even though the term suggest that only one wire is required.
▪
The term "electrical isolation" should be clarified in advance. Beckhoff IO modules feature 1…8 or more analog channels; with regard to the channel connection a distinction is made in terms of:
–
how the channels WITHIN a module relate to each other, or
–
how the channels of SEVERAL modules relate to each other.
The property of electrical isolation indicates whether the channels are directly connected to each other.
▪
Beckhoff terminals/boxes always feature electrical isolation between the field/analog side and the bus/EtherCAT side. In other words, if two analog terminals/boxes are not connected via the power contacts, the modules are effectively electrically isolated.
▪
If channels within a module are electrically isolated, or if a single-channel module has no power contacts, the channels are effectively always differential. See also explanatory notes below. Differential channels are not necessarily electrically isolated.
▪
Analog measuring channels are subject to technical limits, both in terms of the recommended operating range (continuous operation) and the destruction limit. Please refer to the respective terminal documentation for further details.
Explanation
▪
Differential
–
Differential measurement is the most flexible concept. The user can freely choose both connection points, input+/signal potential and input-/reference potential, within the framework of the technical specification.
–
A differential channel can also be operated as SE, if the reference potential of several sensors is linked. This interconnection may take place via the system GND.
–
Since a differential is configured symmetrically internally (see diagram), there will be a mid-potential (X) between the two supplied potentials that is the same as the internal ground/reference ground for this channel. If several DIFF channels are used in a module without electrical isolation, the technical property VCM (common-mode voltage) indicates the degree to which the mean voltage of the channels may differ.
–
The internal reference ground may be accessible as connection point at the terminal/box, in order to stabilize a defined GND potential in the terminal/box. In this case it is particularly important to pay attention to the quality of this potential (noiselessness, voltage stability). At this GND point a wire may be connected to make sure that VCM,max is not exceeded in the differential sensor cable. If differential channels are not electrically isolated, usually only one VCM,max is permitted. If the channels are electrically isolated this limit should not apply, and the channels voltages may differ up to the specified separation limit.
–
Differential measurement in combination with correct sensor wiring has the special advantage that any interference affecting the sensor cable (ideally the feed and return line are arranged side by side, so that interference signals have the same effect on both wires) has very little effect on the measurement, since the potential of both lines varies jointly (hence the term common mode). In simple terms: Common-mode interference has the same effect on both wires in terms of amplitude and phasing.
–
Nevertheless, the suppression of common-mode interference within a channel or between channels is subject to technical limits, which are specified in the technical data.
▪
Single Ended
–
If the analog circuit is designed as SE, the input/reference wire is internally fixed to a certain potential that cannot be changed. This potential must be accessible from outside on at least one point for connecting the reference potential, e.g. via the power contacts.
–
In other words, in situations with several channels SE offers users the option to avoid returning at least one of the two sensor cables to the terminal/box (in contrast to DIFF). Instead, the reference wire can be consolidated at the sensors, e.g. in the system GND.
–
A disadvantage of this approach is that the separate feed and return line can result in voltage/current variations, which a SE channel may no longer be able to handle. See common-mode interference. A VCM effect cannot occur, since the module channels are internally always 'hard-wired' through the input/reference potential.
Typification of the 2/3/4-wire connection of current sensors
Current transducers/sensors/field devices (referred to in the following simply as ‘sensor’) with the industrial 0/4-20 mA interface typically have internal transformation electronics for the physical measured variable (temperature, current, etc.) at the current control output. These internal electronics must be supplied with energy (voltage, current). The type of cable for this supply thus separates the sensors into self-supplied or externally supplied sensors:
▪
Self-supplied sensors
–
The sensor draws the energy for its own operation via the sensor/signal cable + and -. So that enough energy is always available for the sensor’s own operation and open-circuit detection is possible, a lower limit of 4 mA has been specified for the 4-20 mA interface; i.e. the sensor allows a minimum current of 4 mA and a maximum current of 20 mA to pass.
–
For a 2-wire connection; see IEC60381-1
–
Such current transducers generally represent a current sink and thus like to sit between + and – as a ‘variable load’. Refer also to the sensor manufacturer’s information.
Therefore, they are to be connected according to the Beckhoff terminology as follows:
▪
preferably to ‘single-ended’ inputs if the +Supply connections of the terminal/box are also to be used - connect to +Supply and Signal
▪
the sensor draws the energy/operating voltage for its own operation from 2 supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
Externally supplied sensors
▪
3- and 4-wire connection see Fig. Connection of externally supplied sensors, cf. IEC60381-1
▪
the sensor draws the energy/operating voltage for its own operation from 2 supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
1.
sensor cable: according to the Beckhoff terminology such sensors are to be connected to ‘single-ended’ inputs in 3 cables with +/-/Signal lines and if necessary FE/shield
2.
sensor cables: In the case of sensors with 4-wire connection according to +-/+Signal/-Signal, you must check whether +Signal may be connected to +Supply or –Signal to –Supply.
–
Yes: then you can connect accordingly to a Beckhoff ‘single-ended’ input.
–
the Beckhoff ‘differential’ input for +Signal and –Signal is to be selected; +Supply and –Supply are to be connected via additional cables.
Notice: expert organizations such as NAMUR demand a usable measuring range <4 mA/>20 mA for error detection and adjustment, see also NAMUR NE043.
The Beckhoff device documentation must be consulted in order to see whether the respective device supports such an extended signal range.
In general the polarity/direction of current is to be observed due to the internal diode!
2/3/4-wire connection as single-ended or differential connection technology


EP31xx - Settings and operating modes

Configuration [image] EP31xx - Settings and operating modes
EP31xx - Settings and operating modes
Additional information
•
Settings
•
Operation modes


Settings

Configuration [image] EP31xx - Settings and operating modes [image] Settings
Settings
Table of contents
▪
Selection of the analog signal type
▪
Representation
▪
Siemens bits
▪
Underrange, Overrange
▪
Limit 1 and Limit 2
Selection of the analog signal type, index 0xF800:0n
In delivery state, all channels of the EP31xx are set for analog voltage measurement (-10 V …+10 V).
Note
Setting the correct signal type before connecting the sensors
Set the correct signal type before connecting the sensors!
This setting can be made individually for each channel in the CoE object 0xF800:0n. Changes are immediately effective.
EP3174-0002 Auswahl des Eingangssignals
EP31x4-0002: Selection of the signal type
In the case of the EP31x2 the signal type -20 mA to +20 mA can additionally be selected (see illustration below).
EP31x2: Selection of the signal type
Presentation, index 0x80n0:02
The measured value output is set in factory to two's complement representation (signed integer).
Index 0x80n0:02 offers the possibility to change the method of representation of the measured value.
▪
Signed integer representation
The negative output value is represented in two’s complement (negated + 1).
Maximum representation range with 16-bit = -32768 .. +32767dec
Input signal |  |  |  | Value
+/- 10 V | 0...20 mA | 4...20 mA | 0...10 V | decimal | hexadecimal
10 V | 20 mA | 20 mA | 10 V | 32767 | 0x7FFF
5 V | 10 mA | 12 mA | 5 V | 16383 | 0x3FFF
0 V | 0 mA | 4 mA | 0 V | 0 | 0x0000
-5 V | - | - | - | -16383 | 0xC001
-10 V | - | - | - | -32767 | 0x8000
Overview of further representations
▪
Unsigned integer representation
The output value is represented with 15-bit resolution without sign, therefore polarity detection is no longer possible.
Maximum representation range with 16-bit = 0 .. +32767dec
▪
Absolute value with MSB as sign - representation
The output value is displayed in magnitude-sign format: MSB=1 (highest bit) in the case of negative values.
Maximum representation range with 16-bit = -32768 .. +32767dec
Input values (+/- 10 V) | Representation (values dec. / values hex.)
 | unsigned integer | Absolute value with MSB as sign
10 | 32767 / 0x7FFF | 32767 / 0x7FFF
5 V | 16383 / 0x3FFF | 16383 / 0x3FFF
0 V | 0 / 0x0000 | 0 / 0x0000
-5 | 16384 / 0x4000 | [-16384] / 0xC000
-10 | 32767 / 0x7FFF | [-32767] / 0xFFFF
Presentation types
The presentation types Unsigned integer and Absolute value with MSB as sign have no function for unipolar modules. There is no change in the presentation in the positive range.
Siemens bits, index 0x80n0:05
If this bit is set, status displays are superimposed on the lowest three bits. In the error case "overrange" or "underrange", bit 0 is set.
Undershoot and overshoot of the measuring range (underrange, overrange), index 0x60n0:01, 0x60n0:02
Chapter Data stream and correction calculation contains a clear description of the correction calculation between the raw values and the output values if the limit ranges are exceeded.
The underrange bit is set if, based on the raw value, a value of 0x1300 is undershot by 1 bit.
The overrange bit is set if the value of 0x7FFF is exceeded by 1 bit.
Error bit (index 0x60n0:07), Error LED
The Error bit and the Error LED are set if, based on the raw value,
a value of approx. 0.5 mA below 4 mA is undershot or
a value of approx. 0.5 mA above 20 mA is exceeded.
•
This prevents the triggering of the Error LED if the sensor transmits a little more than 20 mA.
Limit 1 ad Limit 2, index 0x80n0:13, index 0x80n0:14
If the limits of the values that can be entered in indices 0x80n0:13 and 0x80n0:14 are violated, the bits in indices 0x60n0:03 and 0x60n0:05 are set accordingly (see sample below). The indices 0x80n0:07 or 0x80n0:08 serve to activate the limit value monitoring.
Output limit n (2-bit):
▪
0: not active
▪
1: Value < limit value
▪
2: Value > limit value
▪
3: Value = limit value
Limit evaluation
The limit evaluation assumes a signed representation. The conversion to the desired representation (index 0x80n0:02) only takes place after the limit evaluation.
Linking in the PLC with 2-bit values
•
PLC:
IEC61131-PLC contains no 2-bit data type that can be linked with this process data directly. In order to transmit the limit information, therefore, define an input byte, e.g.

and link the limit to the VariableSizeMismatch dialog as described in the chapter Process data.
•
Additional task
2-bit variables can be created in the System Manager.

Linking of 2-bit variable to additional task
Sample
Channel 1; Limit 1 and Limit 2 enabled, Limit 1 = 2.8 V, Limit 2 = 7.4 V, representation: signed integer
Entry in index (Limit 1): 0x8000:13
(2.8 V / 10 V) x 216 / 2 - 1 = 9,174dec
Entry in index (Limit 2): 0x8000:14
(7.4 V / 10 V) x 216 / 2 - 1 = 24,247dec
Output:
Input channel 1 | Index 0x6000:03 | Index 60x6000:05
1.8 V | 0x01hex, (Limit 1, limit value undershot) | 0x01hex, (Limit 2, limit value undershot)
2.8 V | 0x03hex, (Limit 1, limit value reached) | 0x01hex, (Limit 2, limit value undershot)
4.2 V | 0x02hex, (Limit 1, limit value exceeded) | 0x01hex, (Limit 2, limit value undershot)
8.5 V | 0x02hex, (Limit 1, limit value exceeded) | 0x02hex, (Limit 2, limit value exceeded)
Swap Limit index 0x80n0:0E
The limit function can be inverted by SwapLimitBits in index 0x80n0:0E.
Output Limit n (2-bit):
SwapLimitBits setting
Value
FALSE (default setting)
▪
0: not active
▪
1: value < limit value
▪
2: value > limit value
▪
3: Value is equal to the limit value
TRUE
▪
0: not active
▪
1: value > limit value
▪
2: value < limit value
▪
3: Value is equal to the limit value
The Swap Limit function is available according to the table below
Terminal | Swap Limit function from rev.
EP3162-0002 | -0016
EP3174-0002 | -0018
EP3174-0092 | -0016
EP3182-1002 | -0017
EP3184-0002 | -0017
EP3184-1002 | -0018


Operation modes

Configuration [image] EP31xx - Settings and operating modes [image] Operation modes
Operation modes
The EP31xx supports three different operation modes:
▪
Freerun (filter on, timer interrupt)
▪
Synchronous (filter off, SyncManager interrupt) and
▪
DC (DC-Sync-Interrupt)
Fig. 3: Relationship of operation modes
The module switches between the Freerun (filter on) and Synchron modes by activating/deactivating the filter via the index. This takes place while the module is in OP mode. The changeover may result in longer sampling times and step changes in the process data until the filters have assumed a steady state.
DC mode can only be used when the filters are switched off. Likewise, it is not possible to switch the filters on in DC mode. The DC mode is parameterized via the DC tab in the TwinCAT System Manager.
Synchron mode
In synchronous operation process data are generated frame-triggered, so that a new value is available with each PLC cycle. Synchronous mode is used automatically with the EP31xx modules (filter off, no DC). The minimum cycle times are 80 µs (EL31x1/EL31x2), and 120 µs (EL31x4) for standard IPCs.
DC operation
In DC mode the analog sampling is triggered by DC-interrupt. As a result, the temporal jitter between two frames is no longer important and the sampling point is the same across the entire system.
The "input-based" mode shifts the sync-interrupt in such a way that the process data are ready for collection shortly before the current process data cycle.
If the frame jitter is too large, it is possible that data may be collected twice or there may be interruptions in the transmission. In that case the jitter is to be reduced through TwinCAT system measures or a slower cycle time is to be chosen.
Filter operation (FIR and IIR), index 0x80n0:06, 0x80n0:15
The EP31xx modules incorporate a digital filter which, depending on its settings, can adopt the characteristics of a Finite Impulse Response filter (an FIR filter), or an Infinite Impulse Response filter (an IIR filter). The filter is deactivated by default. Please observe the following note regarding activation with index 0x8000:06.
Activation of the filter (index 0x8000: 06), setting of the filter properties (index 0x8000:15)
The filter frequencies are set centrally for all channels of the EP3xxx modules via index 0x8000:15 (channel 1). The corresponding indices 0x80n0:15 of the other channels have no parameterization function.
FIR filter
The filter works as a notch filter and determines the conversion time of the module. It is parameterized via the index 0x8000:15. The higher the filter frequency, the faster the conversion time. A 50 Hz and a 60 Hz filter are available.
Notch filter means that the filter has zeros (notches) in the frequency response at the filter frequency and multiples thereof, i.e. it attenuates the amplitude at these frequencies.
The FIR filter operates as a non-recursive filter.
typical attenuation curve of notch filter at 50 Hz
Filter data FIR filter (1- to 4-channel modules)
Filter | Attenuation | Limit frequency (-3 dB) | Conversion time
50 Hz FIR | > 50 dB | 22 Hz | 625 µs
60 Hz FIR | > 45 dB | 26 Hz | 521 µs
IIR filter
The filter with IIR characteristics is a discrete time, linear, time invariant filter that can be set to eight levels (level 1 = weak recursive filter, up to level 8 = strong recursive filter)
The IIR can be understood to be a moving average value calculation after a low-pass filter.
Through the synchronization mode FreeRun the IIR filter operates with an internal cycle time of 180 µs (1 or 2 channels) or 500 µs (4 channels).
Filter characteristics for IIR filters
IIR filter | -3 dB cut-off frequency with 500 µs sampling time
IIR 1 | 400 Hz
IIR 2 | 220 Hz
IIR 3 | 100 Hz
IIR 4 | 50 Hz
IIR 5 | 24 Hz
IIR 6 | 12 Hz
IIR 7 | 6.2 Hz
IIR 8 | 3.0 Hz


Data stream

Configuration [image] Data stream
Data stream
The following flow chart illustrates the data stream of the EPI31xx (processing of raw data).
Diagram showing the data stream in the EP31xx


Measuring ranges

Configuration [image] Measuring ranges
Measuring ranges
The following diagrams show the output values of the measuring ranges as well as the behavior when the limits ranges are exceeded.
EP3162-0002 (+/- 20 mA)
Data flow with correction calculation for +/- 20 mA
EP3162-0002, EP3174-xxxx, EP318x-xxxx (0…20 mA)
Data flow with correction calculation for 0…20 mA
EP3162-0002, EP3174-xxxx, EP318x-xxxx (4…20 mA)
Data flow with correction calculation for 4…20 mA
EP3162-0002, EP3174-xxxx, EP318x-xxxx (+/- 10 V)
Data flow with correction calculation for +/- 10 V
EP3162-0002, EP3174-xxxx, EP318x-xxxx (0…10 V)
Data flow with correction calculation for 0…10 V


Calibration

Configuration [image] Calibration
Calibration
The concept "calibration", which has historical roots at Beckhoff, is used here even if it has nothing to do with the deviation statements of a calibration certificate.
▪
Vendor calibration, index 0x80n0:0B
The vendor calibration is enabled via index 0x80n0:0B. The parameterization takes place via the indices:
–
0x80nF:01 vendor calibration: Offset
–
0x80nF:02 vendor calibration: Gain
▪
User calibration, index 0x80n0:0A
The user calibration is enabled via index 0x80n0:0A. The parameterization takes place via the indices:
–
0x80n0:17 User calibration: Offset
–
0x80n0:18 User calibration: Gain
▪
User scaling, index 0x80n0:01
The user scaling is enabled via index 0x80n0:01. The parameterization takes place via the indices:
–
0x80n0:11 User scaling: Offset
–
0x80n0:12 User scaling: Gain
Vendor calibration
The vendor reserves the right to carry out the basic calibration of the terminal/box modules. Therefore, the vendor calibration cannot be changed.


Calculation of process data

Configuration [image] Calculation of process data
Calculation of process data
The terminal/box constantly records measured values and saves the raw values from its A/D converter in the ADC raw value object 0x80nE:01. The calculation of the correction with the vendor calibration values takes place after each acquisition of the analog signal. This is followed (optionally) by user scaling:
YH= (XADC-BH) * AH measured value after vendor calibration (corresponds to XADC if index 0x80n0:0B inactive)
YA= (YH-BA) * AA measured value after user calibration (corresponds to YH if index 0x80n0:0A inactive)
YS= YA * AS * 22-16 + BS measured value after user scaling (corresponds to YA if index 0x80n0:01 is inactive)
Key
Name | Name | Index
XADC | Output value of the A/D converter | 0x80nE:01
BH | Vendor calibration offset (can only be changed if the object Producer codeword 0xF008 is set) | 0x80nF:01
AH | Vendor calibration gain (can only be changed if the object Producer codeword 0xF008 is set) | 0x80nF:02
YH | Measured value after vendor calibration | -
BA | User calibration offset | 0x80n0:11
AA | User calibration gain | 0x80n0:12
YS | Measured value after user calibration | -
BS | User scaling offset (can be activated via index 0x80x0:0A) | 0x80n0:17
AS | User scaling gain (can be activated via index 0x80x0:0A) | 0x80n0:18
YS | Process data for control, measured value after user scaling | -


TwinSAFE SC

Configuration [image] TwinSAFE SC
TwinSAFE SC
Additional information
•
TwinSAFE SC - operating principle
•
TwinSAFE SC - configuration


TwinSAFE SC - operating principle

Configuration [image] TwinSAFE SC [image] TwinSAFE SC - operating principle
TwinSAFE SC - operating principle
The TwinSAFE SC (Single Channel) technology enables the use of standard signals for safety tasks in any networks of fieldbuses. To do this, EtherCAT Terminals from the areas of analog input, angle/displacement measurement or communication (4…20 mA, incremental encoder, IO-Link, etc.) are extended by the TwinSAFE SC function. The typical signal characteristics and standard functionalities of the I/O components are retained. TwinSAFE SC I/Os have a yellow strip at the front of the housing to distinguish them from standard I/Os.
The TwinSAFE SC technology enables communication via a TwinSAFE protocol. These connections can be distinguished from the usual safe communication via Safety over EtherCAT.
The data of the TwinSAFE SC components are transferred via a TwinSAFE protocol to the TwinSAFE logic, where they can be used in the context of safety-relevant applications. Detailed examples for the correct application of the TwinSAFE SC components and the respective normative classification, which were confirmed/calculated by TÜV SÜD, can be found in the TwinSAFE application manual.


TwinSAFE SC - configuration

Configuration [image] TwinSAFE SC [image] TwinSAFE SC - configuration
TwinSAFE SC - configuration
The TwinSAFE SC technology enables communication with standard EtherCAT terminals via the Safety over EtherCAT protocol. These connections use another checksum, in order to be able to distinguish between TwinSAFE SC and TwinSAFE. Eight fixed CRCs can be selected, or a free CRC can be entered by the user.
By default the TwinSAFE SC communication channel of the respective TwinSAFE SC component is not enabled. In order to be able to use the data transfer, the corresponding TwinSAFE SC module must first be added under the Slots tab. Only then is it possible to link to a corresponding alias device.
Adding the TwinSAFE SC process data under the component, e.g. EL5021-0090
Additional process data with the ID TSC Inputs, TSC Outputs are generated (TSC - TwinSAFE Single Channel).
Prozessdaten TwinSAFE SC Komponente (iankfd11.png)
TwinSAFE SC component process data, example EL5021-0090
A TwinSAFE SC connection is added by adding an alias devices in the safety project and selecting TSC (TwinSAFE Single Channel)
Adding a TwinSAFE SC connection
After opening the alias device by double-clicking, select the Link button Grafik aus Konfiguration TwinSAFE SC (iak9opa.png) next to Physical Device, in order to create the link to a TwinSAFE SC terminal. Only suitable TwinSAFE SC terminals are offered in the selection dialog.
Grafik aus Konfiguration TwinSAFE SC (i8d09251.png)
Creating a link to TwinSAFE SC terminal
The CRC to be used can be selected or a free CRC can be entered under the Connection tab of the alias device.
Entry Mode | Used CRCs
TwinSAFE SC CRC 1 master | 0x17B0F
TwinSAFE SC CRC 2 master | 0x1571F
TwinSAFE SC CRC 3 master | 0x11F95
TwinSAFE SC CRC 4 master | 0x153F1
TwinSAFE SC CRC 5 master | 0x1F1D5
TwinSAFE SC CRC 6 master | 0x1663B
TwinSAFE SC CRC 7 master | 0x1B8CD
TwinSAFE SC CRC 8 master | 0x1E1BD
Selecting a free CRC
These settings must match the settings in the CoE objects of the TwinSAFE SC component.
The TwinSAFE SC component initially makes all available process data available. The Safety Parameters tab typically contains no parameters. The process data size and the process data themselves can be selected under the Process Image tab.
Selecting the process data size and the process data
The process data (defined in the ESI file) can be adjusted to user requirements by selecting the Edit button in the dialog Configure I/O element(s).
Selection of the process data
The safety address together with the CRC must be entered on the TwinSAFE SC slave side. This is done via the CoE objects under TSC settings of the corresponding TwinSAFE SC component (here, for example, EL5021-0090, 0x8010: 01 and 0x8010: 02). The address set here must also be set in the alias device as FSoE address under the Linking tab.
Under the object 0x80n0:02 Connection Mode the CRC to be used is selected or a free CRC is entered. A total of 8 CRCs are available. A free CRC must start with 0x00ff in the high word.
Grafik aus Konfiguration TwinSAFE SC (iv9tkmo3.png)
CoE objects 0x8010:01 and 0x8010:02
Object TSC Settings
Depending on the terminal, the index designation of the configuration object TSC Settings can vary.
Example:
- EL3214-0090 and EL3314-0090, TSC Settings, Index 8040
- EL5021-0090, TSC Settings, Index 8010
- EL6224-0090, TSC Settings, Index 800F
Grafik aus Konfiguration TwinSAFE SC (isvth0a2.png)
Entering the safety address and the CRC
TwinSAFE SC connections
If several TwinSAFE SC connections are used within a configuration, a different CRC must be selected for each TwinSAFE SC connection.


EP3174-0092 - TwinSAFE SC process data

Configuration [image] EP3174-0092 - TwinSAFE SC process data
EP3174-0092 - TwinSAFE SC process data
The EP3174-0092 transmits the following process data to the TwinSAFE logic:
Index (hex) | Name | Type | Size
6000:11 | AI Module 1.Value | INT | 2.0
6010:11 | AI Module 2.Value | INT | 2.0
6020:11 | AI Module 3.Value | INT | 2.0
6030:11 | AI Module 4.Value | INT | 2.0
The process data of all four channels are initially transmitted. Individual channels can be completely deselected on the "Process Image" tab in the Safety Editor.
Depending on the TwinCAT 3.1 version, process data can be automatically renamed when linking to the Safety Editor.


EP3162-0002 - Object overview

Configuration [image] EP3162-0002 - Object overview
EP3162-0002 - Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x012C1389 (19665801dec)
1008 |  | Device name | RO | EP3162-0002
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0C5A4052 (207241298dec)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x11 (11dec)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x11 (11dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A01:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A01:08 | SubIndex 008 | RO | 0x6010:0E, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:0F, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A01:0B | Subindex011 | RO | 0x6010:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
 | 1C12:01 | SubIndex 001 | RW | -
 | 1C12:02 | SubIndex 002 | RW | -
1C13:0 | Subindex | TxPDO assign | RW | 0x02 (2dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dec)
 | 1C13:03 | SubIndex 003 | RW | -
 | 1C13:04 | SubIndex 004 | RW | -
Index (hex) |  |  | Name | Flags | Default value
1C32:0 |  | Subindex | SM output parameter | RO | 0x20 (32dec)
 |  | 1C32:01 | Sync mode | RW | 0x0000 (0dec)
 |  | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 |  | 1C32:03 | Shift time | RO | 0x00000000 (0dec)
 |  | 1C32:04 | Sync modes supported | RO | 0xC009 (49161dec)
 |  | 1C32:05 | Minimum cycle time | RO | 0x00055730 (350000dec)
 |  | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dec)
 |  | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dec)
 |  | 1C32:08 | Command | RW | 0x0000 (0dec)
 |  | 1C32:09 | Maximum Delay time | RO | 0x00000000 (0dec)
 |  | 1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 |  | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 |  | 1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 |  | 1C32:20 | Sync error | RO | 0x00 (0dec)
1C33:0 |  | Subindex | SM input parameter | RO | 0x20 (32dec)
 |  | 1C33:01 | Sync mode | RW | 0x0000 (0dec)
 |  | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 |  | 1C33:03 | Shift time | RO | 0x00001388 (5000dec)
 |  | 1C33:04 | Sync modes supported | RO | 0xC009 (49161dec)
 |  | 1C33:05 | Minimum cycle time | RO | 0x00055730 (350000dec)
 |  | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 |  | 1C33:07 | Minimum delay time | RO | 0x00001388 (5000dec)
 |  | 1C33:08 | Command | RW | 0x0000 (0dec)
 |  | 1C33:09 | Maximum Delay time | RO | 0x00001388 (5000dec)
 |  | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 |  | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 |  | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 |  | 1C33:20 | Sync error | RO | 0x0000 (0dec)
6000:0 |  | Subindex | AI Inputs Ch. 1 | RO | 0x11 (17dec)
 |  | 6000:01 | Underrange | RO | 0x00 (0dec)
 |  | 6000:02 | Overrange | RO | 0x00 (0dec)
 |  | 6000:03 | Limit 1 | RO | 0x00 (0dec)
 |  | 6000:05 | Limit 2 | RO | 0x00 (0dec)
 |  | 6000:07 | Error | RO | 0x00 (0dec)
 |  | 6000:0E | Sync Error | RO | 0x00 (0dec)
 |  | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 |  | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 |  | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 |  | Subindex | AI Inputs Ch. 2 | RO | 0x11 (17dec)
 |  | 6010:01 | Underrange | RO | 0x00 (0dec)
 |  | 6010:02 | Overrange | RO | 0x00 (0dec)
 |  | 6010:03 | Limit 1 | RO | 0x00 (0dec)
 |  | 6010:05 | Limit 2 | RO | 0x00 (0dec)
 |  | 6010:07 | Error | RO | 0x00 (0dec)
 |  | 6010:0E | Sync error | RO | 0x00 (0dec)
 |  | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 |  | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 |  | 6010:11 | Value | RO | 0x0000 (0dec)
8000:0 |  | Subindex | AI Settings Ch. 1 | RW | 0x18 (24dec)
 |  | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 |  | 8000:02 | Presentation | RW | 0x00 (0dec)
 |  | 8000:06 | Enable filter | RW | 0x01 (1dec)
 |  | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 |  | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 |  | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 |  | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 |  | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 |  | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 |  | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 |  | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 |  | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 |  | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 |  | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 |  | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
800E:0 |  | Subindex | AI Internal data Ch. 1 | RW | 0x01 (1dec)
 |  | 800E:01 | ADC raw value | RW | 0x0000 (0dec)
800F:0 |  | Subindex | AI Vendor data Ch. 1 | RW | 0x06 (6dec)
 |  | 800F:01 | offset U | RW | 0x0000 (0dec)
 |  | 800F:02 | gain U | RW | 0x4000 (16384dec)
 |  | 800F:03 | offset I | RW | 0x0000 (0dec)
 |  | 800F:04 | gain I | RW | 0x4000 (16384dec)
 |  | 800F:05 | offset I4 | RW | 0x0000 (0dec)
 |  | 800F:06 | gain I4 | RW | 0x4000 (16384dec)
8010:0 |  | Subindex | AI Settings Ch. 2 | RW | 0x18 (24dec)
 |  | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 |  | 8010:02 | Presentation | RW | 0x00 (0dec)
 |  | 8010:06 | Enable filter | RW | 0x00 (0dec)
 |  | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 |  | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 |  | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 |  | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 |  | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 |  | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 |  | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 |  | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 |  | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 |  | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 |  | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 |  | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
801E:0 |  | Subindex | AI Internal data Ch. 2 | RW | 0x01 (1dec)
 |  | 801E:01 | ADC raw value | RW | 0x0000 (0dec)
801F:0 |  | Subindex | AI Vendor data Ch. 2 | RW | 0x06 (6dec)
 |  | 801F:01 | offset U | RW | 0x0000 (0dec)
 |  | 801F:02 | gain U | RW | 0x4000 (16384dec)
 |  | 801F:03 | offset I | RW | 0x0000 (0dec)
 |  | 801F:04 | gain I | RW | 0x4000 (16384dec)
 |  | 801F:05 | offset I4 | RW | 0x0000 (0dec)
 |  | 801F:06 | gain I4 | RW | 0x4000 (16384dec)
F000:0 |  | Subindex | Modular device profile | RO | 0x02 (2dec)
 |  | F000:01 | Module index distance | RO | 0x0010 (16dec)
 |  | F000:02 | Maximum number of modules | RO | 0x0002 (2dec)
F008 |  |  | Code word | RW | 0x0000 (0dec)
F010:0 | Subindex |  | Module list | RW | 0x02 (2dec)
 | F010:01 |  | SubIndex 001 | RW | 0x0000012C (300dec)
 | F010:02 |  | SubIndex 002 | RW | 0x0000012C (300dec)
F800:0 | Subindex |  | AI Range Settings | RW | 0x02 (2dec)
 | F800:01 |  | Input type Ch1 | RW | 0x0000 (0dec)
 | F800:02 |  | Input type Ch2 | RW | 0x0000 (0dec)
Key
Flags: |
RO (Read Only): | this object can be read only
RW (Read/Write): | this object can be read and written to


EP3182-1002 - Object overview

Configuration [image] EP3182-1002 - Object overview
EP3182-1002 - Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EP3182-1002
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0C6E4052 (208552018dec)
 | 1018:03 | Revision | RO | 0x001403EA (1311722dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1600:0 | Subindex | DO RxPDO-Map Outputs | RO | 0x03 (3dec)
 | 1600:01 | Subindex 001 | RO | 0x7020:01, 1
 | 1600:02 | Subindex 002 | RO | 0x7020:02, 1
 | 1600:03 | Subindex 003 | RO | 0x0000:0,14
1800:0 | Subindex | AI TxPDO-Par Standard Ch.1 | RO | 0x06 (6dec)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI TxPDO-Par Compact Ch.1 | RO | 0x06 (6dec)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI TxPDO-Par Standard Ch.2 | RO | 0x06 (6dec)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | AI TxPDO-Par Compact Ch.2 | RO | 0x06 (6dec)
 | 1801:06 | Exclude TxPDOs | RO | 02 1A
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x11 (11dec)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Compact Ch.1 | RO | 0x01 (1dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
1A02:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x11 (11dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A02:08 | SubIndex 008 | RO | 0x6010:0E, 1
 | 1A02:09 | SubIndex 009 | RO | 0x6010:0F, 1
Index (hex) |  |  | Name | Flags | Default value
1A02:0 |  | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 |  | 1A02:0B | Subindex011 | RO | 0x6010:11, 16
1A03:0 |  | Subindex | AI TxPDO-Map Compact Ch.2 | RO | 0x01 (1dec)
 |  | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1C00:0 |  | Subindex | Sync manager type | RO | 0x04 (4dec)
 |  | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 |  | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 |  | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 |  | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 |  | Subindex | RxPDO assign | RW | 0x01 (1dec)
 |  | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632)
1C13:0 |  | Subindex | TxPDO assign | RW | 0x02 (2dec)
 |  | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 |  | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dec)
1C32:0 |  | Subindex | SM output parameter | RO | 0x20 (32dec)
 |  | 1C32:01 | Sync mode | RW | 0x0001 (1dec)
 |  | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 |  | 1C32:03 | Shift time | RO | 0x00001388 (5000dec)
 |  | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dec)
 |  | 1C32:05 | Minimum cycle time | RO | 0x00030D40 (200000dec)
 |  | 1C32:06 | Calc and copy time | RO | 0x00001388 (5000dec)
 |  | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dec)
 |  | 1C32:08 | Command | RW | 0x0000 (0dec)
 |  | 1C32:09 | Maximum Delay time | RO | 0x00000000 (0dec)
 |  | 1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 |  | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 |  | 1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 |  | 1C32:20 | Sync error | RO | 0x00 (0dec)
1C33:0 |  | Subindex | SM input parameter | RO | 0x20 (32dec)
 |  | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 |  | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 |  | 1C33:03 | Shift time | RO | 0x00001388 (5000dec)
 |  | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 |  | 1C33:05 | Minimum cycle time | RO | 0x00001388 (5000dec)
 |  | 1C33:06 | Calc and copy time | RO | 0x00002710 (10000dec)
 |  | 1C33:07 | Minimum delay time | RO | 0x00001388 (5000dec)
 |  | 1C33:08 | Command | RW | 0x0000 (0dec)
 |  | 1C33:09 | Maximum Delay time | RO | 0x00001388 (5000dec)
 |  | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 |  | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 |  | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 |  | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 |  | Subindex | AI Inputs Ch. 1 | RO | 0x11 (17dec)
 |  | 6000:01 | Underrange | RO | 0x00 (0dec)
 |  | 6000:02 | Overrange | RO | 0x00 (0dec)
 |  | 6000:03 | Limit 1 | RO | 0x00 (0dec)
 |  | 6000:05 | Limit 2 | RO | 0x00 (0dec)
 |  | 6000:07 | Error | RO | 0x00 (0dec)
 |  | 6000:0E | Sync Error | RO | 0x00 (0dec)
 |  | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 |  | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 |  | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 |  | Subindex | AI Inputs Ch. 2 | RO | 0x11 (17dec)
 |  | 6010:01 | Underrange | RO | 0x00 (0dec)
 |  | 6010:02 | Overrange | RO | 0x00 (0dec)
 |  | 6010:03 | Limit 1 | RO | 0x00 (0dec)
 |  | 6010:05 | Limit 2 | RO | 0x00 (0dec)
 |  | 6010:07 | Error | RO | 0x00 (0dec)
 |  | 6010:0E | Sync error | RO | 0x00 (0dec)
 |  | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 |  | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 |  | 6010:11 | Value | RO | 0x0000 (0dec)
7020:0 |  | Subindex | DO Outputs | RO | 0x02 (2dec)
 |  | 7020:01 | Digital Output 1 | RO | 0x00 (0dec)
 |  | 7020:02 | Digital Output 2 | RO | 0x00 (0dec)
8000:0 |  | Subindex | AI Settings Ch. 1 | RW | 0x18 (24dec)
 |  | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 |  | 8000:02 | Presentation | RW | 0x00 (0dec)
 |  | 8000:06 | Enable filter | RW | 0x01 (1dec)
 |  | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 |  | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 |  | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 |  | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 |  | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 |  | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 |  | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 |  | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 |  | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 |  | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 |  | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 |  | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
800E:0 |  | Subindex | AI Internal data Ch. 1 | RW | 0x01 (1dec)
 |  | 800E:01 | ADC raw value | RW | 0x0000 (0dec)
800F:0 |  | Subindex | AI Vendor data Ch. 1 | RW | 0x06 (6dec)
 |  | 800F:01 | offset U | RW | 0x0000 (0dec)
 |  | 800F:02 | gain U | RW | 0x4000 (16384dec)
 |  | 800F:03 | offset I | RW | 0x0000 (0dec)
 |  | 800F:04 | gain I | RW | 0x4000 (16384dec)
 |  | 800F:05 | offset I4 | RW | 0x0000 (0dec)
 |  | 800F:06 | gain I4 | RW | 0x4000 (16384dec)
8010:0 |  | Subindex | AI Settings Ch. 2 | RW | 0x18 (24dec)
 |  | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 |  | 8010:02 | Presentation | RW | 0x00 (0dec)
 |  | 8010:06 | Enable filter | RW | 0x00 (0dec)
 |  | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 |  | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 |  | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 |  | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 |  | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 |  | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 |  | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 |  | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 |  | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 |  | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 |  | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 |  | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
801E:0 |  | Subindex | AI Internal data Ch. 2 | RW | 0x01 (1dec)
 |  | 801E:01 | ADC raw value | RW | 0x0000 (0dec)
801F:0 |  | Subindex | AI Vendor data Ch. 2 | RW | 0x06 (6dec)
 |  | 801F:01 | offset U | RW | 0x0000 (0dec)
 |  | 801F:02 | gain U | RW | 0x4000 (16384dec)
 |  | 801F:03 | offset I | RW | 0x0000 (0dec)
 |  | 801F:04 | gain I | RW | 0x4000 (16384dec)
 |  | 801F:05 | offset I4 | RW | 0x0000 (0dec)
 |  | 801F:06 | gain I4 | RW | 0x4000 (16384dec)
F000:0 |  | Subindex | Modular device profile | RO | 0x02 (2dec)
 |  | F000:01 | Module index distance | RO | 0x0010 (16dec)
 |  | F000:02 | Maximum number of modules | RO | 0x0003 (3dec)
F008 |  |  | Code word | RW | 0x0000 (0dec)
F010:0 | Subindex |  | Module list | RW | 0x02 (2dec)
 | F010:01 |  | SubIndex 001 | RW | 0x0000012C (300dec)
 | F010:02 |  | SubIndex 002 | RW | 0x0000012C (300dec)
 | F010:03 |  | SubIndex 003 | RW | 0x000000C8 (200dec)
F800:0 | Subindex |  | AI Range Settings | RW | 0x02 (2dec)
 | F800:01 |  | Input type Ch1 | RW | 0x0000 (0dec)
 | F800:02 |  | Input type Ch2 | RW | 0x0000 (0dec)
Key
Flags: |
RO (Read Only): | this object can be read only
RW (Read/Write): | this object can be read and written to


EP31x4-x002 - Object overview

Configuration [image] EP31x4-x002 - Object overview
EP31x4-x002 - Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x012C1389 (19665801dec)
1008 |  | Device name | RO | EP3174-0002
1009 |  | Hardware version | RO | -
100A |  | Software version | RO | -
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0C664052 (208027730dec)
 | 1018:03 | Revision | RO | 0x00000000 (0dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1800:0 | Subindex | AI TxPDO-Par Standard Ch. 1 | RO | 0x06 (6dec)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI TxPDO-Par Compact Ch.1 | RO | 0x06 (6dec)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI TxPDO-Par Standard Ch.2 | RO | 0x06 (6dec)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | AI TxPDO-Par Compact Ch.2 | RO | 0x06 (6dec)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1804:0 | Subindex | AI TxPDO-Par Standard Ch.3 | RO | 0x06 (6dec)
 | 1804:06 | Exclude TxPDOs | RO | 05 1A
1805:0 | Subindex | AI TxPDO-Par Compact Ch.3 | RO | 0x06 (6dec)
 | 1805:06 | Exclude TxPDOs | RO | 04 1A
1806:0 | Subindex | AI TxPDO-Par Standard Ch.4 | RO | 0x06 (6dec)
 | 1806:06 | Exclude TxPDOs | RO | 07 1A
1807:0 | Subindex | AI TxPDO-Par Compact Ch.4 | RO | 0x06 (6dec)
 | 1807:06 | Exclude TxPDOs | RO | 06 1A
Index (hex) |  | Name | Flags | Default value
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x0B (11dec)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Compact Ch.1 | RO | 0x01 (1dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
1A02:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x0B (11dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A02:08 | SubIndex 008 | RO | 0x1802:07, 1
 | 1A02:09 | SubIndex 009 | RO | 0x1802:09, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6010:11, 16
1A03:0 | Subindex | AI TxPDO-Map Compact Ch.2 | RO | 0x01 (1dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1A04:0 | Subindex | AI TxPDO-Map Standard Ch.3 | RO | 0x0B (11dec)
 | 1A04:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A04:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A04:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A04:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A04:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A04:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A04:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A04:08 | SubIndex 008 | RO | 0x6020:0E, 1
 | 1A04:09 | SubIndex 009 | RO | 0x6020:0F, 1
 | 1A04:0A | SubIndex 010 | RO | 0x6020:10, 1
 | 1A04:0B | SubIndex 011 | RO | 0x6020:11, 16
1A05:0 | Subindex | AI TxPDO-Map Compact Ch.3 | RO | 0x01 (1dec)
 | 1A05:01 | SubIndex 001 | RO | 0x6020:11, 16
1A06:0 | Subindex | AI TxPDO-Map Standard Ch.4 | RO | 0x0B (11dec)
 | 1A06:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A06:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A06:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A06:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A06:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A06:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A06:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A06:08 | SubIndex 008 | RO | 0x6030:0E, 1
 | 1A06:09 | SubIndex 009 | RO | 0x6030:0F, 1
 | 1A06:0A | SubIndex 010 | RO | 0x6030:10, 1
 | 1A06:0B | SubIndex 011 | RO | 0x6030:11, 16
1A07:0 | Subindex | AI TxPDO-Map Compact Ch.4 | RO | 0x01 (1dec)
 | 1A07:01 | SubIndex 001 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A04 (6660dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A06 (6662dec)
1C33:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00001388 (5000dec)
 | 1C33:04 | Sync modes supported | RO | 0xC00B (49163dec)
 | 1C33:05 | Minimum cycle time | RO | 0x0003D090 (250000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00001388 (5000dec)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum Delay time | RO | 0x00001388 (5000dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | AI inputs | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | -
 | 6000:05 | Limit 2 | RO | -
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | AI inputs | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | -
 | 6010:05 | Limit 2 | RO | -
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
6020:0 | Subindex | AI inputs | RO | 0x11 (17dec)
 | 6020:01 | Underrange | RO | 0x00 (0dec)
 | 6020:02 | Overrange | RO | 0x00 (0dec)
 | 6020:03 | Limit 1 | RO | -
 | 6020:05 | Limit 2 | RO | -
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:0E | Sync error | RO | 0x00 (0dec)
 | 6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | AI inputs | RO | 0x11 (17dec)
 | 6030:01 | Underrange | RO | 0x00 (0dec)
 | 6030:02 | Overrange | RO | 0x00 (0dec)
 | 6030:03 | Limit 1 | RO | -
 | 6030:05 | Limit 2 | RO | -
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:0E | Sync error | RO | 0x00 (0dec)
 | 6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
8000:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:05 | Siemens bits | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x01 (1dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
800E:0 | Subindex | AI internal data | RO | 0x01 (1dec)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dec)
800F:0 | Subindex | AI vendor data | RW | 0x06 (6dec)
 | 800F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 800F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 800F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 800F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 800F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 800F:06 | R2 Gain | RW | 0x4000 (16384dec)
8010:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:05 | Siemens bits | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
801E:0 | Subindex | AI internal data | RO | 0x01 (1dec)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dec)
801F:0 | Subindex | AI vendor data | RW | 0x06 (6dec)
 | 801F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 801F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 801F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 801F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 801F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 801F:06 | R2 Gain | RW | 0x4000 (16384dec)
8020:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:02 | Presentation | RW | 0x00 (0dec)
 | 8020:05 | Siemens bits | RW | 0x00 (0dec)
 | 8020:06 | Enable filter | RW | 0x01 (1dec)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8020:15 | Filter settings | RW | 0x0000 (0dec)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dec)
802E:0 | Subindex | AI internal data | RO | 0x01 (1dec)
 | 802E:01 | ADC raw value | RO | 0x0000 (0dec)
802F:0 | Subindex | AI vendor data | RW | 0x06 (6dec)
 | 802F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 802F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 802F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 802F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 802F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 802F:06 | R2 Gain | RW | 0x4000 (16384dec)
8030:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:02 | Presentation | RW | 0x00 (0dec)
 | 8030:05 | Siemens bits | RW | 0x00 (0dec)
 | 8030:06 | Enable filter | RW | 0x01 (1dec)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8030:15 | Filter settings | RW | 0x0000 (0dec)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dec)
803E:0 | Subindex | AI internal data | RO | 0x01 (1dec)
 | 803E:01 | ADC raw value | RO | 0x0000 (0dec)
803F:0 | Subindex | AI vendor data | RW | 0x06 (6dec)
 | 803F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 803F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 803F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 803F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 803F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 803F:06 | R2 Gain | RW | 0x4000 (16384dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x04 (4dec)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dec)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dec)
 | F010:03 | SubIndex 003 | RW | 0x0000012C (300dec)
 | F010:04 | SubIndex 004 | RW | 0x0000012C (300dec)
F800:0 | Subindex | AI Range Settings (new modules) | RW | 0x04 (4dec)
 | F800:01 | Input type Ch1 | RW | 0x0000 (0dec)
 | F800:02 | Input type Ch2 | RW | 0x0000 (0dec)
 | F800:03 | Input type Ch3 | RW | 0x0000 (0dec)
 | F800:04 | Input type Ch4 | RW | 0x0000 (0dec)
 | F800:05 | Enable Filter Settings Per Channel | RW | -
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


EP3174-0092 - Object overview

Configuration [image] EP3174-0092 - Object overview
EP3174-0092 - Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x012C1389 (19665801dec)
1008 |  | Device name | RO | EP3174-0092
1009 |  | Hardware version | RO | -
100A |  | Software version | RO | -
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0C664052 (208027730dec)
 | 1018:03 | Revision | RO | 0x00000000 (0dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1610:0 | Subindex | TSC RxPDO-Map Master Message | RW | 0x04 (4dec)
 | 1610:01 | Subindex 001 | RW | 0x7040:01, 8
 | 1610:02 | Subindex 002 | RW | 0x0000:00, 8
 | 1610:03 | Subindex 003 | RW | 0x7040:03, 16
 | 1610:04 | Subindex 004 | RW | 0x7040:02, 16
1800:0 | Subindex | AI TxPDO-Par Standard Ch. 1 | RO | 0x06 (6dec)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI TxPDO-Par Compact Ch.1 | RO | 0x06 (6dec)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI TxPDO-Par Standard Ch.2 | RO | 0x06 (6dec)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | AI TxPDO-Par Compact Ch.2 | RO | 0x06 (6dec)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1804:0 | Subindex | AI TxPDO-Par Standard Ch.3 | RO | 0x06 (6dec)
 | 1804:06 | Exclude TxPDOs | RO | 05 1A
1805:0 | Subindex | AI TxPDO-Par Compact Ch.3 | RO | 0x06 (6dec)
 | 1805:06 | Exclude TxPDOs | RO | 04 1A
1806:0 | Subindex | AI TxPDO-Par Standard Ch.4 | RO | 0x06 (6dec)
 | 1806:06 | Exclude TxPDOs | RO | 07 1A
1807:0 | Subindex | AI TxPDO-Par Compact Ch.4 | RO | 0x06 (6dec)
 | 1807:06 | Exclude TxPDOs | RO | 06 1A
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x0B (11dec)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Compact Ch.1 | RO | 0x01 (1dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
Index (hex) |  | Name | Flags | Default value
1A02:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x0B (11dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A02:08 | SubIndex 008 | RO | 0x1802:07, 1
 | 1A02:09 | SubIndex 009 | RO | 0x1802:09, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6010:11, 16
1A03:0 | Subindex | AI TxPDO-Map Compact Ch.2 | RO | 0x01 (1dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1A04:0 | Subindex | AI TxPDO-Map Standard Ch.3 | RO | 0x0B (11dec)
 | 1A04:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A04:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A04:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A04:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A04:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A04:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A04:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A04:08 | SubIndex 008 | RO | 0x6020:0E, 1
 | 1A04:09 | SubIndex 009 | RO | 0x6020:0F, 1
 | 1A04:0A | SubIndex 010 | RO | 0x6020:10, 1
 | 1A04:0B | SubIndex 011 | RO | 0x6020:11, 16
1A05:0 | Subindex | AI TxPDO-Map Compact Ch.3 | RO | 0x01 (1dec)
 | 1A05:01 | SubIndex 001 | RO | 0x6020:11, 16
1A06:0 | Subindex | AI TxPDO-Map Standard Ch.4 | RO | 0x0B (11dec)
 | 1A06:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A06:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A06:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A06:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A06:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A06:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A06:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A06:08 | SubIndex 008 | RO | 0x6030:0E, 1
 | 1A06:09 | SubIndex 009 | RO | 0x6030:0F, 1
 | 1A06:0A | SubIndex 010 | RO | 0x6030:10, 1
 | 1A06:0B | SubIndex 011 | RO | 0x6030:11, 16
1A07:0 | Subindex | AI TxPDO-Map Compact Ch.4 | RO | 0x01 (1dec)
 | 1A07:01 | SubIndex 001 | RO | 0x6030:11, 16
1A10:0 | Subindex | TSC TxPDO-Map Slave Message | RO | 0x0A (10dec)
 | 1A10:01 | SubIndex 001 | RO | 0x6040:01, 8
 | 1A10:02 | SubIndex 002 | RO | 0x6000:11, 16
 | 1A10:03 | SubIndex 003 | RO | 0x6040:03, 16
 | 1A10:04 | SubIndex 004 | RO | 0x6010:11, 16
 | 1A10:05 | SubIndex 005 | RO | 0x6040:04, 16
 | 1A10:06 | SubIndex 006 | RO | 0x6020:11, 16
 | 1A10:07 | SubIndex 007 | RO | 0x6040:05, 16
 | 1A10:08 | SubIndex 008 | RO | 0x6030:11, 16
 | 1A10:09 | SubIndex 009 | RO | 0x6040:06, 16
 | 1A10:0A | SubIndex 010 | RO | 0x6040:02, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
 | 1C12:00 | SubIndex 001 | RW | 0x1610 (5648dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x05 (5dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A04 (6660dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A06 (6662dec)
 | 1C13:05 | SubIndex 005 | RW | 0x1A10 (6672dec)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dec)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C32:03 | Shift time | RO | 0x000448E0 (280800dec)
 | 1C32:04 | Sync modes supported | RO | 0xC00B (49163dec)
 | 1C32:05 | Minimum cycle time | RO | 0x00041EB0 (270000dec)
 | 1C32:06 | Calc and copy time | RO | 0x000087F0 (34800dec)
 | 1C32:07 | Minimum delay time | RO | 0x0003C0F0 (246000dec)
 | 1C32:08 | Command | RW | 0x0000 (0dec)
 | 1C32:09 | Maximum Delay time | RO | 0x0003C0F0 (246000dec)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C32:20 | Sync error | RO | 0x00 (0dec)
1C33:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x0002FC10 (195600dec)
 | 1C33:04 | Sync modes supported | RO | 0xC00B (49163dec)
 | 1C33:05 | Minimum cycle time | RO | 0x00041EB0 (270000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000708 (1800dec)
 | 1C33:07 | Minimum delay time | RO | 0x0002FC10 (195600dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum Delay time | RO | 0x0002FC10 (195600dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | AI inputs | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | -
 | 6000:05 | Limit 2 | RO | -
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | AI inputs | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | -
 | 6010:05 | Limit 2 | RO | -
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
6020:0 | Subindex | AI inputs | RO | 0x11 (17dec)
 | 6020:01 | Underrange | RO | 0x00 (0dec)
 | 6020:02 | Overrange | RO | 0x00 (0dec)
 | 6020:03 | Limit 1 | RO | -
 | 6020:05 | Limit 2 | RO | -
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:0E | Sync error | RO | 0x00 (0dec)
 | 6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | AI inputs | RO | 0x11 (17dec)
 | 6030:01 | Underrange | RO | 0x00 (0dec)
 | 6030:02 | Overrange | RO | 0x00 (0dec)
 | 6030:03 | Limit 1 | RO | -
 | 6030:05 | Limit 2 | RO | -
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:0E | Sync error | RO | 0x00 (0dec)
 | 6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
6040:0 | Subindex | TSC Slave Frame Elements | RO | 0x06 (6dec)
 | 6040:01 | TSC__Slave Cmd | RO | 0x00 (0dec)
 | 6040:02 | TSC__Slave ConnID | RO | 0x0000 (0dec)
 | 6040:03 | TSC__Slave CRC_0 | RO | 0x0000 (0dec)
 | 6040:04 | TSC__Slave CRC_1 | RO | 0x0000 (0dec)
 | 6040:05 | TSC__Slave CRC_2 | RO | 0x0000 (0dec)
 | 6040:06 | TSC__Slave CRC_3 | RO | 0x0000 (0dec)
7040:0 | Subindex | TSC Master Frame Elements | RO | 0x03 (3dec)
 | 7040:01 | TSC__Master Cmd | RO | 0x00 (0dec)
 | 7040:02 | TSC__Master ConnID | RO | 0x0000 (0dec)
 | 7040:03 | TSC__Master CRC_0 | RO | 0x0000 (0dec)
8000:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:05 | Siemens bits | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x01 (1dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x0000 (0dec)
800E:0 | Subindex | AI internal data | RO | 0x01 (1dec)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dec)
800F:0 | Subindex | AI vendor data | RW | 0x06 (6dec)
 | 800F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 800F:02 | R0 Gain | RW | 0x0000 (0dec)
 | 800F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 800F:04 | R1 Gain | RW | 0x0000 (0dec)
 | 800F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 800F:06 | R2 Gain | RW | 0x0000 (0dec)
8010:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:05 | Siemens bits | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
801E:0 | Subindex | AI internal data | RO | 0x01 (1dec)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dec)
801F:0 | Subindex | AI vendor data | RW | 0x06 (6dec)
 | 801F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 801F:02 | R0 Gain | RW | 0x0000 (0dec)
 | 801F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 801F:04 | R1 Gain | RW | 0x0000 (0dec)
 | 801F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 801F:06 | R2 Gain | RW | 0x4000 (16384dec)
8020:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:02 | Presentation | RW | 0x00 (0dec)
 | 8020:05 | Siemens bits | RW | 0x00 (0dec)
 | 8020:06 | Enable filter | RW | 0x01 (1dec)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8020:15 | Filter settings | RW | 0x0000 (0dec)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:18 | User calibration gain | RW | 0x0000 (0dec)
802E:0 | Subindex | AI internal data | RO | 0x01 (1dec)
 | 802E:01 | ADC raw value | RO | 0x0000 (0dec)
802F:0 | Subindex | AI vendor data | RW | 0x06 (6dec)
 | 802F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 802F:02 | R0 Gain | RW | 0x0000 (0dec)
 | 802F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 802F:04 | R1 Gain | RW | 0x0000 (0dec)
 | 802F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 802F:06 | R2 Gain | RW | 0x0000 (0dec)
8030:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:02 | Presentation | RW | 0x00 (0dec)
 | 8030:05 | Siemens bits | RW | 0x00 (0dec)
 | 8030:06 | Enable filter | RW | 0x01 (1dec)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8030:15 | Filter settings | RW | 0x0000 (0dec)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:18 | User calibration gain | RW | 0x0000 (0dec)
803E:0 | Subindex | AI internal data | RO | 0x01 (1dec)
 | 803E:01 | ADC raw value | RO | 0x0000 (0dec)
803F:0 | Subindex | AI vendor data | RW | 0x06 (6dec)
 | 803F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 803F:02 | R0 Gain | RW | 0x0000 (0dec)
 | 803F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 803F:04 | R1 Gain | RW | 0x0000 (0dec)
 | 803F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 803F:06 | R2 Gain | RW | 0x0000 (0dec)
8040:0 | 8040:0 | TSC Settings | RW | 0x02 (2dec)
 | 8040:01 | Address | RW | 0x0000 (0dec)
 | 8040:02 | Connection Mode | RW | 0x00000000 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x04 (4dec)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dec)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dec)
 | F010:03 | SubIndex 003 | RW | 0x0000012C (300dec)
 | F010:04 | SubIndex 004 | RW | 0x0000012C (300dec)
F800:0 | Subindex | AI Range Settings (new modules) | RW | 0x04 (4dec)
 | F800:01 | Input type Ch1 | RW | 0x0000 (0dec)
 | F800:02 | Input type Ch2 | RW | 0x0000 (0dec)
 | F800:03 | Input type Ch3 | RW | 0x0000 (0dec)
 | F800:04 | Input type Ch4 | RW | 0x0000 (0dec)
 | F800:05 | Enable Filter Settings Per Channel | RW | 0x000003B6 (950dec)
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


EP31x2 - Object description and parameterization

Configuration [image] EP31x2 - Object description and parameterization
EP31x2 - Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the Set Value Dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 AI settings Ch.1 (parameterization of channel 1)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | AI Settings Ch.1 | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8000:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8000:05 EP3182-1002 only | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x00 (0dec)
8000:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8000:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8000:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | This object determines the digital filter settings for all channels of the module, if it is activated via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8000:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x4000 (16384dec)
Index 8010 AI Settings (parameterization of channel 2)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8010:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8000:05 EP3182-1002 only | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8010:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8010:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable user calibration | 1 | Enables user calibration | BOOLEAN | RW | 0x00 (0dec)
8010:0B | Enable vendor calibration | 1 | Enable vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8010:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8010:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8010:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x4000 (16384dec)
Index F800 AI Range Settings (EP3174/EP3184 from firmware version 04 as well as all EP3182)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
F800:0 | AI Range Settings | Maximum subindex |  | UINT8 | RO | 0x02 (2dec)
F800:01 | Input type Ch1 | Input signal range for channel 1 |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | -10 V...+10 V
 |  | 1 | 0 mA...20 mA
 |  | 2 | 4 mA...20 mA
 |  | 4 | -20 mA…20 mA
 |  | 6 | 0 V...10 V
F800:02 | Input type Ch2 | Input signal range for channel 2 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
Additional objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | EP3162-0001: 0x012C1389 (19665801dec) EP3182-1002: 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP3162-0002 EP3182-1002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 01
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | EP3162.0002: 0x0C5A4052 (207241298dec) EP3182-1002: 0x0C6E4052 (208552018dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 DO RxPDO-Map Outputs (EP3182-1002 only)
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | DO RxPDO-Map Outputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DO Outputs), entry 0x01 (Digital output 1)) | UINT32 | RO | 0x7020:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DO Outputs), entry 0x02 (Digital output 2)) | UINT32 | RO | 0x7020:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1800 AI TxPDO-Par Standard Ch.1 (EP3182-1002 only)
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | AI TxPDO-Par Standard Ch.1 | PDO parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
Index 1801 AI TxPDO-Par Compact Ch.1 (EP3182-1002 only)
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | AI TxPDO-Par Compact Ch.1 | PDO parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI TxPDO-Par Standard Ch.2 (EP3182-1002 only)
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | AI TxPDO-Par Standard Ch.2 | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
Index 1803 AI TxPDO-Par Compact Ch.2 (EP3182-1002 only)
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | AI TxPDO-Par Compact Ch.2 | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 1A00 AI TxPDO-Map Standard Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | AI TxPDO-Map Standard Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs, entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x16 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Standard Ch.2 (EP3162-0002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1802:07, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1802:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:11, 16
Index 1A01 AI TxPDO-Map Compact Ch.1 (EP3182-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A02 AI TxPDO-Map Standard Ch.2 (EP3182-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (AI Inputs, entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (AI inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60102 (AI inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 AI TxPDO-Map Compact Ch.2 (EP3182-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign (EP3162-0002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
1C12:01 | SubIndex 001 |  | UINT8 | RW | -
1C12:02 | SubIndex 002 |  | UINT8 | RW | -
Index 1C12 RxPDO assign (EP3182-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT8 | RW | 0x1600 (5632dec)
Index 1C13 TxPDO assign (EP3162-0002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | -
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | -
Index 1C13 TxPDO assign (EP3182-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6657dec)
Index 1C32 SM output parameter (EP3162-0002)
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C33:08)
UINT16
RO
0xC009 (49161dec)
1C32:05
Minimum cycle time
UINT32
RO
0x00055730 (350000dec)
1C32:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
BOOLEAN
RO
0x00 (0dec)
Index 1C32 SM output parameter (EP3182-1002)
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0001 (0dec)
1C32:02
Cycle time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
UINT32
RO
0x00030D40 (200000dec)
1C32:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM output parameter (EP3162-0002)
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM output parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C33:08)
UINT16
RO
0xC009 (49161dec)
1C33:05
Minimum cycle time
UINT32
RO
0x00055730 (350000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00001388 (5000dec)
1C33:08
Command
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C33:0B
SM event missed counter
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter (EP3182-1002)
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
UINT32
RO
0x00030D40 (200000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00002710 (10000dec)
1C33:07
Minimum delay time
UINT32
RO
0x00001388 (5000dec)
1C33:08
Command
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C33:0B
SM event missed counter
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
BOOLEAN
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 AI Inputs Ch. 1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6000:0 | AI Inputs Ch. 1 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | -
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | -
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6010 AI Inputs Ch. 2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6010:0 | AI Inputs Ch. 2 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | -
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | -
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 7020 DO Outputs (EP3182-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
7020:0 | DO Outputs | Maximum subindex | UINT8 | RO | 0x02 (2dec)
7020:01 | Digital output 1 |  | BOOLEAN | RO | 0x00 (0dec)
7020:02 | Digital output 2 |  | BOOLEAN | RO | 0x00 (0dec)
Index 800E AI Internal data Ch. 1
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
800E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 800F AI Vendor data Ch. 1
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
800F:01 | offsetU | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:02 | gainU | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
800F:03 | offsetI | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:04 | gainI | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
800F:05 | offsetI4 | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:06 | gainI4 | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 801E AI Internal data Ch. 2
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | AI Internal data Ch. 2 | Maximum subindex | UINT8 | RO | 0x01 (1dec)
801E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 801F AI Vendor data Ch. 2
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
801F:01 | offsetU | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:02 | gainU | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
801F:03 | offsetI | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:04 | gainI | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
801F:05 | offsetI4 | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:06 | gainI4 | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | EP3162-0002: 0x0002 (2dec) EP3182-1002: 0x0003 (3dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list (EP3162-0002)
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dec)
Index F010 Module list (EP3182-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x000000C8 (200dec)


EP31x4 - Object description and parameterization

Configuration [image] EP31x4 - Object description and parameterization
EP31x4 - Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 AI Settings (parameterization of channel 1)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8000:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8000:05 | Siemens bits | 1 | Status indicators are displayed on the lowest 3 bits in the status word. | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8000:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8000:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8000:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | This object determines the digital filter settings for all channels of the module, if it is activated via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8000:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8010 AI Settings (parameterization of channel 2)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8010:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8010:05 | Siemens bits | 1 | Status indicators are displayed on the lowest 3 bits in the status word. | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8010:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8010:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable user calibration | 1 | Enables user calibration | BOOLEAN | RW | 0x00 (0dec)
8010:0B | Enable vendor calibration | 1 | Enable vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8010:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8010:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8010:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8020 AI Settings (parameterization of channel 3)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8020:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8020:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8020:05 | Siemens bits | 1 | Status indicators are displayed on the lowest 3 bits in the status word. | BOOLEAN | RW | 0x00 (0dec)
8020:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8020:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8020:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration | 1 | Enables user calibration | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration | 1 | Enable vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8020:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8020:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8020:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8020:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8020:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8020:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8030 AI Settings (parameterization of channel 4)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8030:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8030:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8030:05 | Siemens bits | 1 | Status indicators are displayed on the lowest 3 bits in the status word. | BOOLEAN | RW | 0x00 (0dec)
8030:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8030:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8030:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable user calibration | 1 | Enables user calibration | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration | 1 | Enable vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8030:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8030:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8030:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8030:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8030:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8030:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x0000 (0dec)
Index F800 AI Range Settings (EP3174/EP3184 from firmware version 04)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
F800:0 | AI Range Settings | Maximum subindex |  | UINT8 | RO | 0x04 (4dec)
F800:01 | Input type Ch1 | Input signal range for channel 1 |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | -10 V...+10 V
 |  | 1 | 0 mA...20 mA
 |  | 2 | 4 mA...20 mA
 |  | 6 | 0 V...10 V
F800:02 | Input type Ch2 | Input signal range for channel 2 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:03* | Input type Ch3 | Input signal range for channel 3 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:04* | Input type Ch4 | Input signal range for channel 4 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:05 | Enable Filter Settings Per Channel |  |  | BOOLEAN | RW | -
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP3174-0002, EP3174-0092, EP3184-0002, EP3184-1002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 01
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0C664052 (208027730dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1800 AI TxPDO-Par Standard Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | AI TxPDO-Par Standard Ch.1 | PDO parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
Index 1801 AI TxPDO-Par Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | AI TxPDO-Par Compact Ch.1 | PDO parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI TxPDO-Par Standard Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | AI TxPDO-Par Standard Ch.2 | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
Index 1803 AI TxPDO-Par Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | AI TxPDO-Par Compact Ch.2 | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 1804 AI TxPDO-Par Standard Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | AI TxPDO-Par Standard Ch.3 | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET-STRING[2] | RO | 05 1A
Index 1805 AI TxPDO-Par Compact Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | AI TxPDO-Par Compact Ch.3 | PDO parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 6 | OCTET-STRING[2] | RO | 04 1A
Index 1806 AI TxPDO-Par Standard Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1806:0 | AI TxPDO-Par Standard Ch.4 | PDO parameter TxPDO 7 | UINT8 | RO | 0x06 (6dec)
1806:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 7 | OCTET-STRING[2] | RO | 07 1A
Index 1807 AI TxPDO-Par Compact Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1807:0 | AI TxPDO-Par Compact Ch.4 | PDO parameter TxPDO 8 | UINT8 | RO | 0x06 (6dec)
1807:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 8 | OCTET-STRING[2] | RO | 06 1A
Index 1A00 AI TxPDO-Map Standard Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | AI TxPDO-Map Standard Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x6000:0E, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A02 AI TxPDO-Map Standard Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1802:07, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1802:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 AI TxPDO-Map Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A04 AI TxPDO-Map Standard Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Standard Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0B (11dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6020:03, 2
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6020:05, 2
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x6020:0E, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1804 (AI TxPDO-Par Standard Ch.3), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1804 (AI TxPDO-Par Standard Ch.3), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1804 (AI TxPDO-Par Standard Ch.3), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6020:11, 16
Index 1A05 AI TxPDO-Map Compact Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | AI TxPDO-Map Compact Ch.3 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A06 AI TxPDO-Map Standard Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | AI TxPDO-Map Standard Ch.4 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0B (11dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6030:03, 2
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6030:05, 2
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x6030:0E, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1806 (AI TxPDO-Par Standard Ch.4), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1806 (AI TxPDO-Par Standard Ch.4), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1806 (AI TxPDO-Par Standard Ch.4), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6030:11, 16
Index 1A07 AI TxPDO-Map Compact Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | AI TxPDO-Map Compact Ch.4 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign (EP31x4-x002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C12 RxPDO assign (EP3174-0092)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1610 (5648dec)
Index 1C13 TxPDO assign (EP31x4-x002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
Index 1C13 TxPDO assign (EP3174-0092)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A10 (6672dec)
Index 1C32 SM output parameter (EP3174-0092)
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 2 event
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x000448E0 (280800dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 3:2 = 10: DC mode is supported
▪
Bit 5:4 = 01: Output Shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC00B (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00041EB0 (270000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x000087F0 (34800dec)
1C32:07
Minimum delay time
UINT32
RO
0x0003C0F0 (246000dec)
1C32:08
Command
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum Delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x0003C0F0 (246000dec)
1C32:0B
SM event missed counter
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
EP31x4-x002:
0x00001388 (5000dec)
EP3174-0092:
0x0002FC10 (195600dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C33:08)
UINT16
RO
0xC00B (49163dec)
1C33:05
Minimum cycle time
UINT32
RO
EP31x4-x002:
0x0003D090 (250000dec)
EP3174-0092:
0x00041EB0 (270000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
EP31x4-x002:
0x00002710 (10000dec)
EP3174-0092:
0x00000708 (1800dec)
1C33:07
Minimum delay time
UINT32
RO
EP31x4-x002:
0x00001388 (5000dec)
EP3174-0092:
0x0002FC10 (195600dec)
1C33:08
Command
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
EP31x4-x002:
0x00001388 (5000dec)
EP3174-0092:
0x0002FC10 (195600dec)
1C33:0B
SM event missed counter
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
BOOLEAN
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 AI Inputs
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6000:0 | AI inputs | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6010 AI Inputs
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6010:0 | AI inputs | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6020 AI Inputs
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6020:0 | AI inputs | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6020:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6030 AI Inputs
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6030:0 | AI inputs | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6030:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6030:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6030:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6030:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 800E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
800E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 800F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
800F:01 | R0 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:02 | R0 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
800F:03 | R1 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:04 | R1 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
800F:05 | R2 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:06 | R2 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 801E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
801E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 801F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
801F:01 | R0 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:02 | R0 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
801F:03 | R1 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:04 | R1 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
801F:05 | R2 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:06 | R2 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 802E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
802E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
802E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 802F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
802F:01 | R0 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:02 | R0 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
802F:03 | R1 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:04 | R1 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
802F:05 | R2 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:06 | R2 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 803E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
803E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
803E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 803F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
803F:01 | R0 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:02 | R0 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
803F:03 | R1 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:04 | R1 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
803F:05 | R2 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:06 | R2 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | EP31x4-x002: 0x0004 (4dec) EP3174-092: 0x0005 (5dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x05 (5dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dec)
F010:05* | SubIndex 005 |  | UINT32 | RW | 0x000003B6 (950dec)
*) EP3174-0092 only


Objects TwinSAFE Single Channel (EP3174-0092)

Configuration [image] Objects TwinSAFE Single Channel (EP3174-0092)
Objects TwinSAFE Single Channel (EP3174-0092)
Index 1610 TSC RxPDO-Map Master Message
Index (hex) | Name | Meaning | Data type | Flags | Default
1610:0 | TSC RxPDO-Map Master Message | PDO Mapping RxPDO | UINT8 | RO | 0x04 (4dec)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x01 (TSC___Master Cmd)) | UINT32 | RO | 0x7040:01, 8
1610:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x03 (TSC__Master CRC_0)) | UINT32 | RO | 0x7040:03, 16
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x02 (TSC__Master ConnID)) | UINT32 | RO | 0x7040:02, 16
Index 1A10 TSC TxPDO-Map Slave Message
Index (hex) | Name | Meaning | Data type | Flags | Default
1A10:0 | TSC TxPDO-Map Slave Message | PDO Mapping TxPDO | UINT8 | RW | 0x0A (10dec)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x01 (TSC___Slave Cmd)) | UINT32 | RW | 0x6040:01, 8
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 16
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x03 (TSC__Slave CRC_0)) | UINT32 | RW | 0x6040:03, 16
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 16
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x04 (TSC__Slave CRC_1)) | UINT32 | RW | 0x6040:04, 16
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 16
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x05 (TSC__Slave CRC_2)) | UINT32 | RW | 0x6040:05, 16
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6030:11, 16
1A10:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x06 (TSC__Slave CRC_3)) | UINT32 | RW | 0x6040:06, 16
1A10:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x02 (TSC__Slave ConnID)) | UINT32 | RW | 0x6040:02, 16
Index 6040 TSC Slave Frame Elements
Index (hex) | Name | Meaning | Data type | Flags | Default
6040:0 | TSC Slave Frame Elements | Max. Subindex | UINT8 | RO | 0x06 (6dec)
6040:01 | TSC__Slave Cmd | reserved | UINT8 | RO | 0x00 (0dec)
6040:02 | TSC__Slave ConnID | reserved | UINT16 | RO | 0x0000 (0dec)
6040:03 | TSC__Slave CRC_0 | reserved | UINT16 | RO | 0x0000 (0dec)
6040:04 | TSC__Slave CRC_1 | reserved | UINT16 | RO | 0x0000 (0dec)
6040:05 | TSC__Slave CRC_2 | reserved | UINT16 | RO | 0x0000 (0dec)
6040:06 | TSC__Slave CRC_3 | reserved | UINT16 | RO | 0x0000 (0dec)
Index 7040 TSC Master Frame Elements
Index (hex) | Name | Meaning | Data type | Flags | Default
7040:0 | TSC Master Frame Elements | Max. Subindex | UINT8 | RO | 0x03 (3dec)
7040:01 | TSC__Master Cmd | reserved | UINT8 | RO | 0x00 (0dec)
7040:02 | TSC__Master ConnID | reserved | UINT16 | RO | 0x0000 (0dec)
7040:03 | TSC__Master CRC_0 | reserved | UINT16 | RO | 0x0000 (0dec)
Index 8040 TSC Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8040:0 | TSC Settings | Max. Subindex | UINT8 | RO | 0x02 (2dec)
8040:01 | Address | TwinSAFE SC Address | UINT16 | RO | 0x0000 (0dec)
8040:02 | Connection Mode | Selection of the TwinSAFE SC CRC | UINT32 | RO | 0x00000000 (0dec)


Restoring the delivery state

Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
Ordering information | Description
ZK1090-3xxx-xxxx | EtherCAT cable M8, green link to the website
ZK1093-3xxx-xxxx | EtherCAT cable M8, yellow link to the website
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensor cable M12 5-wire Link to website
ZK2000-6xxx-xxxx | Sensor cable M12 4-wire Link to website
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5000-0020 | Protective cap M12, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8801-0002 | Torque cable key for M12 / wrench size 13 for ZB8801-0000
ZB8801-0003 | Torque cable key for M12 field assembly / wrench size 18 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com