EP31xx - EtherCAT Box Module with configurable analog inputs

BECKHOFF Fieldbus Components

Documentation for

EP3174-0002, EP3182-1002, EP3184-0002, EP3184-1002

EtherCAT Box with configurable analog inputs

Version: 1.5.0
Date: 2014-03-14

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


EP31xx - Documentation issue status

BECKHOFF EP31xx: Foreword

Documentation issue status

Version Comment
1.5.0
  • description of connection for analog current inputs (M12) overworked
  • chapter Settings and operating modes updated
1.4.0
  • signal settings added
  • connection diagrams updated
1.3.0
  • object description updated
1.2.0
  • technical data updated
  • overview of EtherCAT cables extended
  • mounting and cabling updated
1.1.0
  • description of status LED extended
  • object description extended
  • technical data updated
1.0.1
  • object description corrected
1.0.0
  • description of status LED overworked
0.6
  • EP3182-1002 added
  • accessories added
  • nut torque for connectors added
  • object description corrected
0.5
  • first preliminary version

Firm and hardware version

The documentation refers to the firm and hardware status that was valid at the time it was prepared.

The properties of the modules are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.

Documentation Version | EP3174-0002 |  | EP3182-1002 |  | EP3184-0002 |  | EP3184-1002
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
1.5.0 | 10 | 06 | 02 | 05 | 05 | 06 | 05 | 06
1.4.0 | 10 | 05 | 02 | 05 | 05 | 06 | 05 | 06
1.3.0 | 09 | 05 | 02 | 04 | 05 | 06 | 05 | 06
1.2.0 | 07 | 05 | 02 | 04 | 05 | 05 | 05 | 05
1.1.0 | 04 | 03 | 01 | 00 | 04 | 01 | 04 | 01
1.0.1 | 04 | 03 | 01 | 00 | 04 | 01 | 04 | 01
1.0.0 | 04 | 03 | 01 | 00 | 04 | 01 | 04 | 01
0.6 | 04 | 03 | 01 | 00 | 04 | 01 | 04 | 01
0.5 | 01 | 01 | - | - | 00 | 00 | 00 | 00

The firmware and hardware version (delivery state) can be found in the batch number (D number) printed at the side of the EtherCAT Box.

Syntax of the batch number (D number)

WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 09 3A 01:

12 - week of production 12
09 - year of production 2009
3A - firmware version 3A
01 - hardware version 01


EtherCAT Box - Introduction

The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.

The extremely low dimensions of only 126 x 30 x 26.5 mm (H x W x D) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.

The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.

Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.

The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP 67:

  • digital inputs with different filters (3.0 ms or 10 μs)

  • digital outputs with 0.5 or 2 A output current

  • analog inputs and outputs with 16 bit resolution

  • Thermocouple and RTD inputs

  • Stepper motor modules

XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.

EtherCAT Box with M8 connections for sensors/actuators | EtherCAT Box with M12 connections for sensors/actuators

Note 		Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.

Note 		XML files
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


EP31xx - Module overview

BECKHOFF EterCAT Box: Product overview

Module overview

Analog input modules, 24 VDC
Module | Number of analog inputs | Number of digital outputs | Signal connection | Comment
EP3174-0002 | 4 | 0 | 4 x M12 | four configurable analog differential inputs
EP3182-1002 | 2 | 2 | 2 x M12 | two configurable analog single-ended inputs two digital outputs
EP3184-0002 | 4 | 0 | 4 x M12 | four configurable analog single-ended inputs
EP3184-1002 | 4 | 0 | 2 x M12 | four configurable analog single-ended inputs


EP3174-0002 - Introduction

EtherCAT Box with four configurable analog differential inputs

The EP3174-0002 EtherCAT Box has four analog inputs which can be individually parameterized, so that they process signals either in the -10…+10 V or the 0/4…20 mA range.

The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.

The four input channels have differential inputs and possess a common, internal ground potential. The input filter and therefore the conversion times are configurable in a wide range.

If required, the inputs can be scaled differently, and automatic limit monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.

Quick-Links

Installation

Configuration

UL Requirements for UL approved modules

ATEX - Special conditions for ATEX approved modules


EP3182-1002 - Introduction

EtherCAT Box with two configurable analog inputs and two digital outputs

Analog inputs (single-ended)

The EP3182-1002 EtherCAT Box has two analog inputs which can be individually parameterized, so that they process signals either in the -10…+10 V or the 0/4…20 mA range.

The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.

The two input channels have single-ended inputs and possess a common, internal ground potential. The input filter and therefore the conversion times are configurable in a wide range.

If required, the inputs can be scaled differently, and automatic limit monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.

Digital outputs

Furthermore the EP3182-1002 EtherCAT Box has two digital outputs to connect binary control signals from the controller to the actuators at the process level.

This 2 outputs (sink/source type) are intended to switch logic in or outputs with a minimum impedance of 10 kOhm (e.g. reset inputs of digital sensors) handle load currents of up to 2 mA. They are short circuit proof and indicate their status through light emitting diodes.

The signals are also connected via the two M12 connectors

Quick-Links

Installation

Configuration


EP3184-0002 - Introduction

EtherCAT Box with four configurable analog single-ended inputs

The EP3184-0002 EtherCAT Box has four analog inputs which can be individually parameterized, so that they process signals either in the -10…+10 V or the 0/4…20 mA range.

The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.

The four input channels have single-ended inputs and possess a common, internal ground potential. The input filter and therefore the conversion times are configurable in a wide range.

If required, the inputs can be scaled differently, and automatic limit monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.

Quick-Links

Installation

Configuration

UL Requirements for UL approved modules

ATEX - Special conditions for ATEX approved modules


EP3184-1002 - Introduction

EtherCAT Box with four configurable analog single-ended inputs

The EP3184-1002 EtherCAT Box has four analog inputs which can be individually parameterized, so that they process signals either in the -10…+10 V or the 0/4…20 mA range.

Two inputs at a time are integrated into connectors 1 and 3. Connectors 2 and 4 are unused.

The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.

The four input channels have single-ended inputs and possess a common, internal ground potential. The input filter and therefore the conversion times are configurable in a wide range.

If required, the inputs can be scaled differently, and automatic limit monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module.

Quick-Links

Installation

Configuration


EP3174, EP3184 - Technical Data

Technical data | EP3174-0002 | EP3184-0002 | EP3184-1002 | EP3182-1002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 4
Input / output connections | 4 x M12 socket | 4 x M12 socket | 2 x M12 socket | 2 x M12 socket
Connection type | 2-wire, 4-wire | single ended | single ended | single ended
Signal type | configurable: 0…+10 V -10…+10 V 0…20 mA 4…20 mA
Internal resistance | > 200 kΩ (typ. 85 Ω + diode voltage)
Common-mode voltage UCM | max. 35 V
Resolution | 16 bit (incl. sign)
Input filter | configurable
Input filter limit frequency | 5 kHz
Conversion time | ~ 100 µs
Measuring error | < ±0.3 % (relative to full scale value)
Number of outputs | 0 | 0 | 0 | 2
Rated output voltage | - | - | - | 24 VDC
Internal resistance | - | - | - | app. 2350 Ω
Output current | - | - | - | 2 mA (short circuit proof)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | from load supply voltage Up, DC, any value up to 30 V
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | Inputs: 4 x 16 Bit Status: 4 x 8 Bit
Electrical isolation | Control voltage / fieldbus: yes
Permissible ambient temperature during operation | -25°C ... +60°C |  | 0°C ... +55°C
 | 0°C ... +55°C (according to ATEX, see special conditions)
 | 0°C ... +55°C (according to cULus see UL Requirements)
Permissible ambient temperature during storage | -40°C ... +85°C |  | -25°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cULus, ATEX |  | CE


EtherCAT Box - Dimensions

BECKHOFF EtherCAT Box: Mounting and cabling

Dimensions

All dimensions are given in millimeters.

General

Technical data | EtherCAT Box
Housing material | PA6 (polyamide), casting compound: Polyurethane
Mounting | 2 x fastening holes for M3
Metal parts | Brass, nickel-plated
Contacts | CuZn, gold-plated
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance/emission | IEC EN 50082-2 / EN 50081-2
Permissible ambient temperature during operation | 0 ... 55°C
Permissible ambient temperature during storage | -25 ... + 85°C
Installation position | variable
Protection class | IP65/66/67 when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm
Approvals | CE
Weight | approx. 120 g - 200 g, depending on module type


EPxxxx - Fixing

BECKHOFF EtherCAT Box: Mounting and cabling

Fixing

Note 		Note or pointer
While mounting the modules, protect all connectors, especially the IP-Link, against contamination!

Only with connected cables or plugs the protection class IP67 is guaranteed!
Unused connectors have to be protected with the right plugs! See for plug sets in the catalogue.

Modules with narrow housing are mounted with two M3 bolts.
Modules with wide housing are mounted with two M3 bolts to the fixing holes located at the corners or mounted with two M4 bolts to the fixing holes located centrally.

The bolts must be longer than 15 mm. The fixing holes of the modules are not threaded.

When assembling, remember that the fieldbus connectors increases the overall height. See chapter accessories.

Mounting Rail ZS5300-0001

The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of modules.

The rail is made of stainless steel, 1.5 mm thick, with already pre-made M3 threads for the modules. The rail has got 5.3 mm slots to mount it via M5 screws to the machine.

The mounting rail is 500 mm long, that way 15 narrow modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.


EPxxxx - Nut tourque for connectors

BECKHOFF EtherCAT Box: Mounting and cabling

Nut torque for connectors

M8 connectors

It is recommended to pull the M8 connectors tight with a nut torque of 0.4 Nm.

M12 connectors

It is recommended to pull the M12 connectors tight with a nut torque of 0.6 Nm.

Torque socket wrenches

Note 		Ensure the right torque
Use the torque socket wrenches available by Beckhoff to pull the connectors tight (see accessories)!


EtherCAT connection

For the incoming and ongoing EtherCAT connection,

  • the EtherCAT Box (EPxxxx) has two M8 sockets, marked in green
  • the Coupler Box (FBB-x110) has two M12 sockets
EtherCAT Box: M8 | Coupler Box: M12

Assignment

There are various different standards for the assignment and colors of connectors and cables for Ethernet/EtherCAT.

Ethernet/EtherCAT |  | Plug connector |  |  | Cable |  | Standard
Signal | Description | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Shield | Housing |  | Shroud | Screen | Screen | Screen

1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003

2) wire colors according to EN 61918

3) wire colors

Note 		Assimilation of color coding for cable ZB9030, ZB9032 and ZK1090-3xxxx-xxxx (with M8 connectors)

For unification the prevalent cables ZB9030, ZB9032 and ZK1090-3xxx-xxxx
this means the pre assembled cables with M8 connectors
were changed to the colors of EN61918 (yellow, orange, white, blue).

So different color coding exists. But the electrical properties are absolutely identical.

EtherCAT connectors

The following connectors can be supplied for use in Beckhoff EtherCAT systems.

Designation | Plug connector | Comment
ZS1090-0003 | RJ45 | four-pin, IP20, for field assembly
ZS1090-0004 | M12 | four-pin, IP67, for field assembly
ZS1090-0005 | RJ45 | eight-pin, IP20, for field assembly, suitable for GigaBit Ethernet
ZS1090-0006 | M8 | four-pin, IP67, for field assembly


EPxxxx - Fieldbus LEDs

BECKHOFF EtherCAT Box: Installation

EtherCAT- Fieldbus LEDs

LED displays
LED | Display | Meaning
IN L/A | off | no connection to the preceding EtherCAT module
 | Lit | LINK: connection to the preceding EtherCAT module
 | flashing | ACT: Communication with the preceding EtherCAT module
OUT L/A | off | no connection to the following EtherCAT module
 | Lit | LINK: connection to the following EtherCAT module
 | flashing | ACT: Communication with the following EtherCAT module
Run | off | Status of the EtherCAT module is Init
 | flashes quickly | Status of the EtherCAT module is pre-operational
 | flashes slowly | Status of the EtherCAT module is safe-operational
 | Lit | Status of the EtherCAT module is operational

Note 		EtherCAT statuses
The various statuses in which an EtherCAT module may be found are described in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.


EtherCAT cable

For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used.

Note 		Recommendations about cabling
You may get detailed recommendations about cabling EtherCAT from the documentation "Recommendations for the design of the infrastructure for EtherCAT/Ethernet", that is available for download at www.Beckhoff.com.

EtherCAT uses 4 wires for signal transfer. Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

A selection of cables for EtherCAT follows. Other cables with various lengths will be found in the full Beckhoff catalogue, and under www.beckhoff.com.

Sold by meter

Designation | Description
ZB9010 | CAT 5e, 4-core, for fixed laying, not for M8 connectors
ZB9020 | CAT 5e, 4-core, suitable for drag chain use, not for M8 connectors
ZB9030 | PVC, dmr. 4.9 mm for M8 connectors
ZB9031 | PUR, dmr. 4.8 mm for M8 connectors
ZB9032 | PUR, dmr. 5.4 mm for M8 connectors, high flexibility

Preassembled cables

ZK1090-3100-0xxx: M8 plug - open end, PUR, high flexibility, preassembled

ZK1090-3100- | 0020 | 0050
Length | 2 m | 5 m

ZK1090-3100-3xxx: M8 plug - open end, PVC, high flexibility, preassembled

ZK1090-3100- | 3020 | 3050
Length | 2 m | 5 m

ZK1090-3131-0xxx: 2 x M8 plug, PUR, high flexibility, ready-assembled

ZK1090-3131- | 0001 | 0003 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0075 | 0100
Length | 0.15 m | 0.3 m | 0.5 m | 1.0 m | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 7.5 m | 10 m
ZK1090-3131- | 0150 | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Length | 15 m | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m

ZK1090-3131-3xxx: 2 x M8 plug, PVC, ready-assembled

ZK1090-3131- | 3020 | 3030 | 3040 | 3050 | 3075 | 3100 | 3150 | 3200 | 3250 | 3300
Length | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 7.5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3131- | 3350 | 3400 | 3450 | 3500
Length | 35 m | 40 m | 45 m | 50 m

ZK1090-3132-0xxx: M8 plug - M8 socket, PUR, high flexibility, ready-assembled

ZK1090-3132- | 0002 | 0004 | 0020 | 0050 | 0075 | 0100 | 0150 | 0200 | 0250 | 0300
Length | 0.2 m | 0.4 m | 2.0 m | 5.0 m | 7.5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3132- | 0400 | 0500
Length | 40 m | 50 m

ZK1090-3132-3xxx: M8 plug - M8 socket, PVC, ready-assembled

ZK1090-3132- | 0020 | 0050 | 0100 | 0150 | 0200 | 0250 | 0300 | 0400 | 0500
Length | 2.0 m | 5.0 m | 10 m | 15 m | 20 m | 25 m | 30 m | 40 m | 50 m

ZK1090-3191-0xxx: M8 plug - RJ45 plug, PUR, high flexibility, ready-assembled

ZK1090-3191- | 0004 | 0005 | 0010 | 0020 | 0035 | 0050 | 0070 | 0100 | 0150 | 0200
Length | 0.4 m | 0.5 m | 1 m | 2 m | 3,5 m | 5 m | 7 m | 10 m | 15 m | 20 m
ZK1090-3191- | 0250
Length | 25 m

ZK1090-3191-3xxx: M8 plug - RJ45 plug, PVC, ready-assembled

ZK1090-3191- | 3005 | 3020 | 3050
Length | 0.5 m | 2 m | 5 m

ZK1090-3291-3xxx: M8 socket - RJ45 plug, PVC, ready-assembled

ZK1090-3291- | 0004 | 0005 | 0010 | 0020 | 0050 | 100 | 200 | 250
Length | 0.4 m | 0.5 m | 1 m | 2 m | 5 m | 10 m | 20 m | 25 m

ZK1090-3161-0xxx: M8 plug - M12 plug (d-coded), ready-assembled

ZK1090-3161- | 0010 | 0020 | 0050
Length | 1.0 m | 2.0 m | 5.0 m

ZK1090-6161-0xxx: 2 x M12 plug (d-coded), PVC, ready-assembled

ZK1090-6161- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Length | 0.5 m | 1.0 m | 2.0 m | 2.5 m | 5.0 m | 10 m

ZK1090-6191-0xxx: M12 plug - RJ45 plug, ready-assembled

ZK1090-6191- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Length | 0.5 m | 1.0 m | 2.0 m | 2.5 m | 5.0 m | 10 m

ZK1090-6292-0xxx: M12 socket - RJ45 plug, ready-assembled

ZK1090-6292- | 0005 | 0020 | 0050 | 0100
Length | 0.5 m | 2 m | 5 m | 10 m

ZK1090-9191-0xxx: 2 x RJ45 plug, patch cable

ZK1090-9191- | 0001 | 0002 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0100 | 0150
Length | 0.17 m | 0.26 m | 0.5 m | 1.0 m | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 10 m | 15 m
ZK1090-9191- | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Length | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m


EtherCAT Box - Power Connection

BECKHOFF EtherCAT Box: Mounting and cabling

Power Connection

The feeding and forwarding of supply voltages is done via two M8 connectors at the bottom end of the modules:

  • IN: left M8 connector for feeding the supply voltages
  • OUT: right M8 connector for forwarding the supply voltages
PIN assignment
Pin | Voltage
1 | Control voltage Us, +24 VDC
2 | Auxiliary voltage Up, +24 VDC
3 | GNDs* | *) may be connected internally to each other depending on the module: see specific module descriptions
4 | GNDp*

The pins M8 connectors carry a maximum current of 4 A.

Two LEDs display the status of the supply voltages.

Attention 		Don't confuse the power connectors with the EtherCAT connectors!
Never connect the power cables (M8, 24 VDC) with the green marked EtherCAT sockets of the EtherCAT Box Modules! This can damage the modules!

Control voltage Us: 24 VDC

Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the 24 VDC control voltage Us. The control voltage is electrically isolated from the fieldbus circuitry.

Auxiliary voltage Up 24 VDC

The Auxiliary voltage Up supplies the digital outputs; it can be brought in separately. If the load voltage is switched off, the fieldbus functions and the power supply and functionality of the inputs are retained.

Redirection of the supply voltages

The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages Us and Up can thus easily be transferred from EtherCAT Box to EtherCAT Box.

Attention 		Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages Us and Up, the maximum permissible current for M8 connectors of 4 A must not be exceeded!

Electrical isolation

Digital modules

In the digital input/output modules, the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are connected to each other!

Analog modules

In the analog input/output modules the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are separated from each other in order to ensure electrical isolation of the analog signals from the control voltage.

In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0...10 V inputs, any reference voltage (0...30 V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers).

Details of the power supply may be taken from the specific module descriptions.

Attention 		Electrical isolation may be cancelled!
If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes are no longer electrically isolated from the control voltage!


EtherCAT Box - Status LEDs for power supply

BECKHOFF EtherCAT Box: Mounting and cabling

Status LEDs for power supply

LED | Display | Meaning
Us (Control voltage) | off | The power supply voltage Us is not present
 | green illuminated | The power supply voltage Us is present
 | reed illuminated | Because of overload (current > 0.5 A) the sensor supply generated from power supply voltage Us was switched off for all sensors fed from this.
Up (Auxiliary voltage) | off | The power supply voltage Up is not present
 | green illuminated | The power supply voltage Up is present


Power cables

Ordering data

Order designation | Power lead | Screw-in connector | Contacts | Cross- section | Length
ZK2020-3200-0020 | Straight socket, open end | M8 | 4-pin | 0.34 mm2 | 2.00 m
ZK2020-3200-0050 |  |  |  |  | 5.00 m
ZK2020-3200-0100 |  |  |  |  | 10.00 m
ZK2020-3400-0020 | Angled socket, open end |  |  |  | 2.00 m
ZK2020-3400-0050 |  |  |  |  | 5.00 m
ZK2020-3400-0100 |  |  |  |  | 10.00 m
ZK2020-3132-0001 | Straight socket, straight socket |  |  |  | 0.15 m
ZK2020-3132-0005 |  |  |  |  | 0.50 m
ZK2020-3132-0010 |  |  |  |  | 1.00 m
ZK2020-3132-0020 |  |  |  |  | 2.00 m
ZK2020-3132-0050 |  |  |  |  | 5.00 m
ZK2020-3334-0001 | Angled socket, angled socket |  |  |  | 0.15 m
ZK2020-3334-0005 |  |  |  |  | 0.50 m
ZK2020-3334-0010 |  |  |  |  | 1.00 m
ZK2020-3334-0020 |  |  |  |  | 2.00 m
ZK2020-3334-0050 |  |  |  |  | 5.00 m

Further available power cables may be found in the Beckhoff catalog or on our internet pages (http://www.beckhoff.com).

Technical data

Technical data
Rated voltage according to IEC60 664-1 | 60 VAC / 75 VDC
Contamination level according to IEC 60 664-1 | 3/2
Insulation resistance IEC 60 512-2 | >109 W
Current carrying capacity according to IEC 60512-3 | 4 A
Volume resistance according to IEC 60512-2 | < 5 mW
Protection class according to IEC 60529 | IP65/66/67, when screwed together
Ambient temperature | -30°C to +80°C


ZK2020 - Power cable conductor losses

BECKHOFF Fieldbus Components: Mounting and cabeling

Power cable conductor losses

The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.

Example

8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.


EtherCAT Box - UL Requirements

BECKHOFF EtherCAT Box: Mounting and cabling

UL Requirements

The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.

Supply voltage

CAUTION 		CAUTION!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
  • by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
  • by a 24 VDC power source, that has to satisfy NEC class 2.
    A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!

CAUTION 		CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!

Networks

CAUTION 		CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!

Ambient temperature range

CAUTION 		CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!

Marking for UL

All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.


EtherCAT Box - ATEX - Special conditions

BECKHOFF EtherCAT Box: Monting and wiring

ATEX - Special conditions

WARNING 		Observe the special conditions for the intended use of
EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
  • The certified components are to be installed in the BG2000-0000 protection enclosure that guarantees a protection against mechanical hazards!
  • If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
  • Observe the permissible ambient temperature range of 0 - 55°C for the use of EtherCAT Box modules in potentially explosive areas!
  • Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
  • The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!

Standards

The fundamental health and safety requirements are fulfilled by compliance with the following standards:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Marking

The EtherCAT Box modules certified for potentially explosive areas bear the following marking:

II 3 G Ex nA II T4

DEKRA 11ATEX0080 X Ta: 0 - 55°C

or

II 3 G Ex nA nC IIC T4

DEKRA 11ATEX0080 X Ta: 0 - 55°C

Batch number (D number)

The EtherCAT Box modules bear a batch number (D number) that is structured as follows:

D: WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Beispiel mit Ser. Nr.: 29 10 02 01:

29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000-0000 - Protective housing for EtherCAT Box

BECKHOFF BG2000-0000: Monting and wiring

BG2000-0000 - EtherCAT Box protection enclosure

WARNING 		Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!

ATEX

The BG2000-0000 protection enclosure has to be mounted over a single EtherCAT Box to fulfill the special conditions according to ATEX.

Installation

1.

Put the wires for EtherCAT, power supply and sensors/actuators through the hole of the BG2000-0000 protection enclosure.

2.

Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.

3.

Mount the BG2000-0000 protection enclosure over the EtherCAT Box.


EtherCAT Box - ATEX Documentation

BECKHOFF EtherCAT Box: Mounting and Cabling

ATEX Documentation

Note 		Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Analog voltage inputs M12

One differential input per socket

Analog inputs, -10 to +10 V

The signal is measured using a differential signal.

Status LEDs at the M12 connectors

Connector | LED | Display | Meaning
M12 socket No. 1-4 | R left | off | no data transmission to A/D converter
 |  | green | data transmission to A/D converter
 | E right | off | correct operation
 |  | rot | Error: wire breakage or measured value out of range

The device is functioning correctly if the Run LED is lit and the Error LED is unlit.

Note 		GND connections
If sensors with not isolated GNDs are connected to the Box, the sensors GND has to be connected with the GNDp of the Box.


Analog current inputs M12

One differential input per socket

Analog input, 0 to 20 mA or 4 to 20 mA

The signal is measured using a differential signal.

Status LEDs at the M12 connectors

Connector | LED | Display | Meaning
M12 socket No. 1-4 | R left | off | no data transmission to A/D converter
 |  | green | data transmission to A/D converter
 | E right | off | correct operation
 |  | rot | Error: wire breakage or measured value out of range

The device is functioning correctly if the Run LED is lit and the Error LED is unlit.

Note 		GND connections
If sensors with not isolated GNDs are connected to the Box, the sensors GND has to be connected with the GNDp of the Box.


Analog voltage inputs, digital outputs M12

One single ended input and one digital output per socket

Analog input, -10 to +10 V, digital output

Status LEDs at the M12 connectors

Connector | LED | Display | Meaning
M12-Buchse Nr. 1-2 | R left | off | analog input: no data transmission to A/D converter
 |  | green | analog input: data transmission to A/D converter
 |  | rot | error at analog input: wire breakage or measured value out of range
 | 1 right | off | digital output is not set
 |  | green | digital output is set

The device is functioning correctly if the left LED shines green.


Analog current inputs, digital outputs M12

One single ended input and one digital output per socket

Analog input, 0 to 20 mA or 4 to 20 mA, digital output

Status LEDs at the M12 connectors

Connector | LED | Display | Meaning
M12-Buchse Nr. 1-2 | R left | off | analog input: no data transmission to A/D converter
 |  | green | analog input: data transmission to A/D converter
 |  | rot | error at analog input: wire breakage or measured value out of range
 | 1 right | off | digital output is not set
 |  | green | digital output is set

The device is functioning correctly if the left LED shines green.


Analog voltage inputs M12

One single ended input per socket

Analog input, -10 to +10 V

Status LEDs at the M12 connectors

Connector | LED | Display | Meaning
M12 socket No. 1-4 | R left | off | no data transmission to A/D converter
 |  | green | data transmission to A/D converter
 | E right | off | correct operation
 |  | rot | Error: wire breakage or measured value out of range

The device is functioning correctly if the Run LED is lit and the Error LED is unlit.

Note 		GND connections
If sensors with not isolated GNDs are connected to the Box, the sensors GND has to be connected with the GNDp of the Box.


EtherCAT Box - Analog current inputs M12

BECKHOFF EtherCAT Box: Cabeling

Analog current inputs M12

One single ended input per socket

Analog input, 0 to 20 mA or 4 to 20 mA

Status LEDs at the M12 connectors

Connector | LED | Display | Meaning
M12 socket No. 1-4 | R left | off | no data transmission to A/D converter
 |  | green | data transmission to A/D converter
 | E right | off | correct operation
 |  | rot | Error: wire breakage or measured value out of range

The device is functioning correctly if the Run LED is lit and the Error LED is unlit.

Note 		GND connections
If sensors with not isolated GNDs are connected to the Box, the sensors GND has to be connected with the GNDp of the Box.


Analog voltage inputs M12

Two single ended inputs per socket

Analog inputs, -10 to +10 V

Status LEDs at the M12 connectors

Connector | LED | Display | Meaning
M12 socket No. 1-4 | R left | off | no data transmission to A/D converter
 |  | green | data transmission to A/D converter
 | E right | off | correct operation
 |  | rot | Error: wire breakage or measured value out of range

The channel is functioning correctly if the Run LED is lit and the Error LED is unlit.


Analog current inputs M12

Two single ended inputs per socket

Analog input, 0 to 20 mA or 4 to 20 mA

Status LEDs at the M12 connectors

Connector | LED | Display | Meaning
M12 socket No. 1-4 | R left | off | no data transmission to A/D converter
 |  | green | data transmission to A/D converter
 | E right | off | correct operation
 |  | rot | Error: wire breakage or measured value out of range

The channel is functioning correctly if the Run LED is lit and the Error LED is unlit.


EtherCAT Box - Inserting into the EtherCAT network

BECKHOFF EtherCAT Box: Commissioning/Configuration

Inserting into the EtherCAT network

Note 		Installation of the latest XML device description
Please ensure that you have installed the latest XML device description in TwinCAT. This can be downloaded from the Beckhoff website (http://www.beckhoff.de/english/default.htm?download/elconfg.htm) and installed according to the installation instructions.

At the Beckhoff TwinCAT System Manager the configuration tree can be build in two different ways:

  • by scanning for existing hardware (called "online") and
  • by manual inserting/appending of fieldbus devices, couplers and slaves.

Automatic scanning in of the box

  • The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
  • Switch on the operating voltage, open the TwinCAT System Manager (Config mode), and scan in the devices (see Fig. 1). Acknowledge all dialogs with "OK", so that the configuration is in "FreeRun" mode.

Fig. 1: Scanning in the EtherCAT configuration (I/O Devices-> right-click -> Scan Devices...

Appending a module manually

  • The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
  • Switch on the operating voltage, open the TwinCAT System Manager (Config mode)
  • Append a new I/O device (see Fig. 2). In the dialog that appears select the device EtherCAT (Direct Mode), see Fig. 3 and confirm with OK.

Fig. 2: Appending a new I/O device (I/O Devices-> right-click -> Append Device... )

Fig. 3: Selecting the device EtherCAT

  • Append a new box (see Fig. 4).

Fig. 4: Appending a new box (Device -> right-click -> Append Box... )

  • In the dialog that appears select the desired box, and confirm with OK.

Fig. 5: Selecting a Box

Fig. 6: Appended Box in the TwinCAT tree


EPxxxx - Configuration via TwinCAT System Manager

BECKHOFF EtherCAT Box: Configuration

Configuration via TwinCAT System Manager

In the left-hand window of the TwinCAT System Manager, click on the branch of the EtherCAT Box you wish to configure.

In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the EtherCAT Box.

General tab

Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.

EtherCAT tab

Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.

The link at the bottom of the tab points to the product page for this EtherCAT device on the web.

Process Data tab

Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.

Sync Manager

Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.

If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.

PDO Assignment

PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:

  • If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
  • If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.

The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.

Note 		Activation of PDO assignment
If you have changed the PDO assignment, in order to activate the new PDO assignment,
  • the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
  • and the System Manager has to reload the EtherCAT slaves ( [image] button)

PDO list

List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.

Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.

PDO Content

Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.

Download

If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.

PDO Assignment

If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.

PDO Configuration

If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.

Startup tab

The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.

Column | Description
Transition Transition to which the request is sent. This can either be
  • the transition from pre-operational to safe-operational (PS), or
  • the transition from safe-operational to operational (SO).

If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol | Type of mailbox protocol
Index | Index of the object
Data | Date on which this object is to be downloaded.
Comment | Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.

CoE - Online tab

The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.

Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.

Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.

Online tab

State Machine

Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.

DLL Status

Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:

Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.

File Access over EtherCAT

Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


EP3174, EP3184 - Settings and operating modes

BECKHOFF EP3174, EP3184: Commissioning

Settings and operating modes

Contents
  • Settings
    • Representation
    • Siemens Bits
    • Underrange, Overrange
    • Limit 1 and Limit 2
  • Operating modes
    • Synchronous operation mode
    • Distributed Clocks (DC) operation mode
    • Filter operation mode

Settings

Setting the analog signal type, Index F800:0n

In delivery state all channels of EP31x4 are set for analog voltage measuring (-10 ... +10 V).

Attention 		Set signal type properly before connecting the sensors
Set the right signal type before connecting the sensors.

At CoE object 0xF800:0n this setting can be done for each channel individually. Changes are effective immediately.

Presentation, index 80n0:02

In the delivery state, the measured value is output in two's complement format (signed integer).
Index 80n0:02 offers the possibility to change the method of representation of the measured value.

Signed Integer representation

The negative output value is represented in two’s complement (negated + 1).
Maximum representation range for 16 bits = -32768 to +32767dec

Input signal |  |  |  | Value
+/- 10 V | 0...20 mA | 4...20 mA | 0...10 V | Decimal | Hexadecimal
10 V | 20 mA | 20 mA | 10 V | 32767 | 0x7FFF
5 V | 10 mA | 12 mA | 5 V | 16383 | 0x3FFF
0 V | 0 mA | 4 mA | 0 V | 0 | 0x0000
-5 V | - | - | - | -16383 | 0xC001
-10 V | - | - | - | -32767 | 0x8000

Overview of other representations

Unsigned Integer representation

The output value is represented with 15-bit resolution without sign, therefore polarity detection is no longer possible.
Maximum representation range for 16 bits = 0 to +32767dec

Absolute value with MSB as sign - representation

The output value is displayed in magnitude-sign format: MSB=1 (highest bit) in the case of negative values.
Maximum representation range for 16 bits = -32768 to +32767dec

Input values (+/- 10 V) | representation (values dec. / values hex.)
 | unsigned integer | absolute value with MSB as sign
10 | 32767 / 0x7FFF | 32767 / 0x7FFF
5 V | 16383 / 0x3FFF | 16383 / 0x3FFF
0 V | 0 / 0x0000 | 0 / 0x0000
-5 | 16384 / 0x4000 | [-16384] / 0xC000
-10 | 32767 / 0x7FFF | [-32767] / 0xFFFF

Note 		Presentation type
The presentation types Unsigned Integer and Absolute value with MSB as sign have no function for unipolar modules. There is no change in the presentation in the positive range.

Siemens Bits, index 80n0:05

If this bit is set, status displays are superimposed on the lowest three bits. In the error case "overrange" or "underrange", bit 0 is set.

Undershoot and overshoot of the measuring range (under-range, over-range), index 60n0:02, 60n0:03

In the chapter Data flow and correction calculation you will find a depict illustration of the correction calculation of the raw data to the output data, if the limit values are exceeded.

Note 		Error bit (Index 60n0:07)
The Error bit is set, if the measuring range is over- or undershot. For the 4...20 mA setting, an over- or undershot will be caused from approx. 3.5 mA.

Limit 1 and Limit 2, index 80n0:13, index 80n0:14

If the value exceeds or falls below these values, which can be entered in the indices 80n0:13 and 80n0:14, then the bits in the indices 60n0:03 and 60n0:05 are set accordingly (see example below). The indices 80n0:07 or 80n0:08 respectively serve to activate the limit value monitoring.

Output Limit n (2-bit):

  • 0: not active
  • 1: Value is smaller than the limit value
  • 2: Value is larger than the limit value
  • 3: Value is equal to the limit value

Note 		Limit evaluation
The limit evaluation assumes a signed representation. The conversion to the desired representation (index 80n0:02) only takes place after the limit evaluation.

Note 		Linking in the PLC with 2-bit values
The limit information consists of 2 bits. Limitn can be linked to the PLC or a task in the System Manager:
  • PLC:
    IEC61131-PLC contains no 2-bit data type that can be linked with this process data directly. In order to transmit the limit information, therefore, define an input byte, e.g.

    and link the limit to the VariableSizeMismatch dialog, as described in chapter process data, fig. 7
  • Additional task
    2-bit variables can be created in the System Manager.

    Fig. 2: Linking of 2-bit variable to additional task

Example

Channel 1; Limit 1 and Limit 2 enabled, Limit 1 = 2.8 V, Limit 2 = 7.4 V, representation: signed integer

Entry in index 8000:13 (Limit 1):
(2.8 V / 10 V) x 216 / 2 - 1 = 9.174dec

Entry in index 8000:14 (Limit 2):
(7.4 V / 10 V) x 216 / 2 - 1 = 24.247dec

Output:

Input channel 1 | Index 6000:03 | Index 6000:05
1.8 V | 0x01hex, (Limit 1, limit value undershot) | 0x01hex, (Limit 2, limit value undershot)
2.8 V | 0x03hex, (Limit 1, limit value reached) | 0x01hex, (Limit 2, limit value undershot)
4.2 V | 0x02hex, (Limit 1, limit value exceeded) | 0x01hex, (Limit 2, limit value undershot)
8.5 V | 0x02hex, (Limit 1, limit value exceeded) | 0x02hex, (Limit 2, limit value exceeded)

Operating modes

The EP31xx supports three different operating modes:

  • Freerun (filter on, timer interrupt)
  • Synchron (filter off, SyncManager interrupt)
  • and DC (DC Sync interrupt)

Fig. 3: Relationship of operating modes

The module switches between the Freerun (filter on) and Synchron modes by activating/deactivating the filter via the index. The module remains in OP mode during this process. The changeover may result in longer sampling times and step changes in the process data until the filters have assumed a steady state.

DC mode can only be used when the filters are switched off. Likewise, it is not possible to switch the filters on in DC mode. The DC mode is parameterized via the DC tab in the TwinCAT System Manager.

Note 		Combinations of filters, FastOp mode and Synchronization mode
Other combination options of filter, FastOp mode and Synchronization mode are expressly not recommended.

Synchron mode

In synchron mode process data are generated frame-triggered, so that a new value is available with each PLC cycle. In the EL31xx modules synchron mode is used automatically (filter off, no DC). The minimum cycle times are 80 µs (EL31x1/EL31x2), and 120 µs (EL31x4) for standard IPCs.

DC mode

In DC mode the process data are requested via DC interrupt. This results in the temporal jitter between two frames being equalised, so that the sampling time is uniform across the system. The DC mode requires minimum cycle times of 100 µs (EL31x1/EL31x2) or 150 µs (EL31x4) for standard IPCs. In input-based mode the sync interrupt is shifted automatically, so that the process data are ready just before the current process data cycle.

Filter mode (FIR and IIR), index 80n0:06, 80n0:15

The EP31xx modules incorporate a digital filter which, depending on its settings, can adopt the characteristics of a Finite Impulse Response filter (an FIR filter), or an Infinite Impulse Response filter (an IIR filter). The filter can also be deactivated.
The filter is deactivated by defalut. For activation with Index 8000:06 , please read the following note:

Note 		Activation of the filter via Index 8000:06 and setting the filter characteristics via index 8000:15
The filter frequencies are set for all channels of the EP31xx modules centrally via index 8000:15 (channel 1).
The corresponding indices 80n0:15 of the other channels have no parameterization function.

FIR filter

The filter performs a notch filter function and determines the conversion time of the module. It is parameterized via the index 8000:15. The higher the filter frequency, the faster the conversion time. A 50 Hz and a 60 Hz filter are available.
Notch filter means that the filter has zeros (notches) in the frequency response at the filter frequency and multiples thereof, i.e. it attenuates the amplitude at these frequencies.

The FIR filter functions as a non-recursive filter.

Fig. 4: typical attenuation curve of notch filter at 50 Hz
Filter characteristics FIR filter (1- to 4-channel modules)
Filter | Attenuation | Limit frequency (-3 dB) | Conversion time
50 Hz FIR | > 50 dB | 22 Hz | 625 µs
60 Hz FIR | > 40 dB | 26 Hz | 521 µs

IIR filter

The filter with IIR characteristics is a discrete time, linear, time invariant filter that can be set to eight levels (level 1 = weak recursive filter, up to level 8 = strong recursive filter).
The IIR can be understood to be a moving average value calculation after a low-pass filter.

By means of the synchronization mode FreeRun, the IIR filter works with an internal cycle time of 180 µs (1 or 2 channels) or 500 µs (4 channels).

Filter characteristcs for IIR filter
IIR filter | -3 dB Limit frequency for a 50 µs sample time
IIR 1 | 400 Hz
IIR 2 | 220 Hz
IIR 3 | 100 Hz
IIR 4 | 50 Hz
IIR 5 | 24 Hz
IIR 6 | 12 Hz
IIR 7 | 6,2 Hz
IIR 8 | 3,0 Hz


EP3174, EP3184 - Data flow and correction calculation

BECKHOFF EP3174, EP3184: Commissioning

Data flow and correction calculation

Contents
  • Data flow
  • Calculation of correction
  • Calibration
    • Manufacturer compensation
    • User compensation
    • User scaling
    • Calculation of process data

Dataflow

The flowchart below (fig. 1) shows demonstrative the dataflow of the EP31xx (processing of the raw data).

Fig. 1: Flowchart of the dataflow EP31xx

Calculation of correction

Fig. 2 - 5 show the correcting calculation of the raw values to the output values if the limits are over- or undershot.

EP31xx (+/- 10 V or +/- 10 mA)

Abb. 2.: Dataflow with correction calculation for +/- 10 V or +/- 10 mA

EP31xx (0...20 mA)

Abb. 3.: Dataflow with correction calculation for 0...20 mA

EP31xx (4...20 mA)

Abb. 4.: Dataflow with correction calculation for 4...20 mA

EP31xx (0...10 V)

Abb. 5.: Dataflow with correction calculation for 0...10 V

Calibration

User scaling, index 80n0:01

The user scaling is enabled via index 80n0:01. Parameterization takes place via the indices

  • 80n0:11
    User scaling offset
  • 80n0:12
    User scaling gain

User compensation, index 80n0:0A

The user compensation is enabled via index 80n0:0A. Parameterization takes place via the indices

  • 80n0:17
    User offset compensation
  • 80n0:18
    User gain compensation

Manufacturer compensation, index 80n0:0B

The manufacturer compensation is enabled via index 80n0:0B. Parameterization takes place via the indices

  • 80nF:01
    Offset (manufacturer compensation)
  • 80nF:02
    Gain (manufacturer compensation)

Note 		Vendor calibration
The manufacturer reserves the authority for the basic calibration of the terminals. The vendor calibration is therefore reserved.

Process data calculation

The terminal records measured values continuously and places the raw value of its A/D converter into the ADC raw value object 80nE:01 or 80nE:02. The calculation of the correction with the manufacturer’s calibration values takes place after each acquisition of the analog signal. User scaling then follows (optionally):
YH = (XADC - BH) x AH | Measured value following manufacturer calibration (corresponds to XADC , if index 80n0:0B is inactive)
YA = (YH - BA) x AA | Measured value following user calibration (corresponds to YH if index 80n0:0A is inactive)
YS = YA x AS x 22-16 + BS | Measured value following user scale (corresponds to YA, if index 80n0:01 is inactive)
Key
Name | Designation | Index
XADC | Output value of the A/D converter | 80nE:01
BH | Manufacturer calibration offset (only changeable if the object Producer codeword F008 is set) | 80nF:01,
AH | Manufacturer calibration gain (only changeable if the object Producer codeword F008 is set) | 80nF:02
YH | Measuring value after manufacturer calibration | -
BA | User calibration offset | 80n0:11
AA | User calibration gain | 80n0:12
YS | Measuring value after manufacturer calibration |
BS | User scaling offset (can be activated via index 80n0:0A) | 80n0:17
AS | User scaling gain (can be activated via index 80n0:0A) | 80n0:18
YS | Process data for controller, measuring value after manufacturer calibration | -


EP31xx - Object overview

BECKHOFF EP31xx: Configuration

Object Overview

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.
Index |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x012C1389 (19665801dec)
1008 |  | Device name | RO | EP3174-0002
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0C664052 (208027730dec)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1600:0 | Subindex | DO RxPDO-Map Outputs | RO | 0x05 (5dec)
 | 1600:01 | SubIndex 001 | RO | 0x7020:01, 1
 | 1600:02 | SubIndex 002 | RO | 0x7020:02, 1
 | 1600:03 | SubIndex 003 | RO | 0x0000:00, 10
 | 1600:04 | SubIndex 004 | RO | 0x7020:0D, 1
 | 1600:05 | SubIndex 005 | RO | 0x0000:00, 3
1800:0 | Subindex | AI TxPDO-Par Standard Ch.1 | RO | 0x09 (9dec)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
 | 1800:07 | TxPDO State | RO | 0x00 (0dec)
 | 1800:09 | TxPDO Toggle | RO | 0x00 (0dec)
1801:0 | Subindex | AI TxPDO-Par Compact Ch.1 | RO | 0x06 (6dec)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI TxPDO-Par Standard Ch.2 | RO | 0x09 (9dec)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
 | 1802:07 | TxPDO State | RO | 0x00 (0dec)
 | 1802:09 | TxPDO Toggle | RO | 0x00 (0dec)
1803:0 | Subindex | AI TxPDO-Par Compact Ch.2 | RO | 0x06 (6dec)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1804:0 | Subindex | AI TxPDO-Par Standard Ch.3 | RO | 0x09 (9dec)
 | 1804:06 | Exclude TxPDOs | RO | 05 1A
 | 1804:07 | TxPDO State | RO | 0x00 (0dec)
 | 1804:09 | TxPDO Toggle | RO | 0x00 (0dec)
1805:0 | Subindex | AI TxPDO-Par Compact Ch.3 | RO | 0x06 (6dec)
 | 1805:06 | Exclude TxPDOs | RO | 04 1A
1806:0 | Subindex | AI TxPDO-Par Standard Ch.4 | RO | 0x09 (9dec)
 | 1806:06 | Exclude TxPDOs | RO | 07 1A
 | 1806:07 | TxPDO State | RO | 0x00 (0dec)
 | 1806:09 | TxPDO Toggle | RO | 0x00 (0dec)
1807:0 | Subindex | AI TxPDO-Par Compact Ch.4 | RO | 0x06 (6dec)
 | 1807:06 | Exclude TxPDOs | RO | 06 1A
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x0A (10dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A00:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A00:08 | SubIndex 008 | RO | 0x1800:07, 1
 | 1A00:09 | SubIndex 009 | RO | 0x1800:09, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Compact Ch.1 | RO | 0x01 (1dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
1A02:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x0A (10dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A02:08 | SubIndex 008 | RO | 0x1802:07, 1
 | 1A02:09 | SubIndex 009 | RO | 0x1802:09, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6010:11, 16
1A03:0 | Subindex | AI TxPDO-Map Compact Ch.2 | RO | 0x01 (1dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1A04:0 | Subindex | AI TxPDO-Map Standard Ch.3 | RO | 0x0A (10dec)
 | 1A04:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A04:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A04:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A04:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A04:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A04:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A04:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A04:08 | SubIndex 008 | RO | 0x1804:07, 1
 | 1A04:09 | SubIndex 009 | RO | 0x1804:09, 1
 | 1A04:0A | SubIndex 010 | RO | 0x6020:11, 16
1A05:0 | Subindex | AI TxPDO-Map Compact Ch.3 | RO | 0x01 (1dec)
 | 1A05:01 | SubIndex 001 | RO | 0x6020:11, 16
1A06:0 | Subindex | AI TxPDO-Map Standard Ch.4 | RO | 0x0A (10dec)
 | 1A06:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A06:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A06:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A06:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A06:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A06:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A06:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A06:08 | SubIndex 008 | RO | 0x1806:07, 1
 | 1A06:09 | SubIndex 009 | RO | 0x1806:09, 1
 | 1A06:0A | SubIndex 010 | RO | 0x6030:11, 16
1A07:0 | Subindex | AI TxPDO-Map Compact Ch.4 | RO | 0x01 (1dec)
 | 1A07:01 | SubIndex 001 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A04 (6660dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A06 (6662dec)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dec)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C32:03 | Shift time | RO | 0x00001388 (5000dec)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C32:05 | Minimum cycle time | RO | 0x00009C40 (40000dec)
 | 1C32:06 | Calc and copy time | RO | 0x00001388 (5000dec)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C32:08 | Command | RW | 0x0000 (0dec)
 | 1C32:09 | Maximum Delay time | RO | 0x00000000 (0dec)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C32:20 | Sync error | RO | 0x00 (0dec)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00001388 (5000dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x00009C40 (40000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00002710 (10000dec)
 | 1C33:07 | Minimum delay time | RO | 0x00001388 (5000dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum Delay time | RO | 0x00001388 (5000dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | AI Inputs | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | 0x00 (0dec)
 | 6000:05 | Limit 2 | RO | 0x00 (0dec)
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | AI Inputs | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | 0x00 (0dec)
 | 6010:05 | Limit 2 | RO | 0x00 (0dec)
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
6020:0 | Subindex | AI Inputs | RO | 0x11 (17dec)
 | 6020:01 | Underrange | RO | 0x00 (0dec)
 | 6020:02 | Overrange | RO | 0x00 (0dec)
 | 6020:03 | Limit 1 | RO | 0x00 (0dec)
 | 6020:05 | Limit 2 | RO | 0x00 (0dec)
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | AI Inputs | RO | 0x11 (17dec)
 | 6030:01 | Underrange | RO | 0x00 (0dec)
 | 6030:02 | Overrange | RO | 0x00 (0dec)
 | 6030:03 | Limit 1 | RO | 0x00 (0dec)
 | 6030:05 | Limit 2 | RO | 0x00 (0dec)
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
7020:0 | Subindex | DO Outputs | RO | 0x02 (2dec)
 | 7020:01 | Digital output 1 | RO | 0x00 (0dec)
 | 7020:02 | Digital output 2 | RO | 0x00 (0dec)
 | 7020:0D | Diag | RO | 0x00 (0dec)
8000:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x01 (1dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
800E:0 | Subindex | AI Internal data | RO | 0x01 (1dec)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dec)
800F:0 | Subindex | AI Vendor data | RW | 0x06 (6dec)
 | 800F:01 | R0 offset | RW | 0x0000 (0dec)
 | 800F:02 | R0 gain | RW | 0x4000 (16384dec)
 | 800F:03 | R1 offset | RW | 0x0000 (0dec)
 | 800F:04 | R1 gain | RW | 0x4000 (16384dec)
 | 800F:05 | R2 offset | RW | 0x0000 (0dec)
 | 800F:06 | R2 gain | RW | 0x4000 (16384dec)
8010:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x01 (1dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
801E:0 | Subindex | AI Internal data | RO | 0x01 (1dec)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dec)
801F:0 | Subindex | AI Vendor data | RW | 0x06 (6dec)
 | 801F:01 | R0 offset | RW | 0x0000 (0dec)
 | 801F:02 | R0 gain | RW | 0x4000 (16384dec)
 | 801F:03 | R1 offset | RW | 0x0000 (0dec)
 | 801F:04 | R1 gain | RW | 0x4000 (16384dec)
 | 801F:05 | R2 offset | RW | 0x0000 (0dec)
 | 801F:06 | R2 gain | RW | 0x4000 (16384dec)
8020:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:02 | Presentation | RW | 0x00 (0dec)
 | 8020:06 | Enable filter | RW | 0x01 (1dec)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8020:15 | Filter settings | RW | 0x0000 (0dec)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dec)
802E:0 | Subindex | AI Internal data | RO | 0x01 (1dec)
 | 802E:01 | ADC raw value | RO | 0x0000 (0dec)
802F:0 | Subindex | AI Vendor data | RW | 0x06 (6dec)
 | 802F:01 | R0 offset | RW | 0x0000 (0dec)
 | 802F:02 | R0 gain | RW | 0x4000 (16384dec)
 | 802F:03 | R1 offset | RW | 0x0000 (0dec)
 | 802F:04 | R1 gain | RW | 0x4000 (16384dec)
 | 802F:05 | R2 offset | RW | 0x0000 (0dec)
 | 802F:06 | R2 gain | RW | 0x4000 (16384dec)
8030:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:02 | Presentation | RW | 0x00 (0dec)
 | 8030:06 | Enable filter | RW | 0x01 (1dec)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8030:15 | Filter settings | RW | 0x0000 (0dec)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dec)
803E:0 | Subindex | AI Internal data | RO | 0x01 (1dec)
 | 803E:01 | ADC raw value | RO | 0x0000 (0dec)
803F:0 | Subindex | AI Vendor data | RW | 0x06 (6dec)
 | 803F:01 | R0 offset | RW | 0x0000 (0dec)
 | 803F:02 | R0 gain | RW | 0x4000 (16384dec)
 | 803F:03 | R1 offset | RW | 0x0000 (0dec)
 | 803F:04 | R1 gain | RW | 0x4000 (16384dec)
 | 803F:05 | R2 offset | RW | 0x0000 (0dec)
 | 803F:06 | R2 gain | RW | 0x4000 (16384dec)
8040:0 | Subindex | AI Range Settings (old modules) | RW | 0x05 (5dec)
 | 8040:01 | Codeword | RW | 0x00000000 (0dec)
 | 8040:02 | Input type Ch1 | RW | 0x0000 (0dec)
 | 8040:03 | Input type Ch2 | RW | 0x0000 (0dec)
 | 8040:04 | Input type Ch3 | RW | 0x0000 (0dec)
 | 8040:05 | Input type Ch4 | RW | 0x0000 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0005 (5dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x05 (5dec)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dec)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dec)
 | F010:03 | SubIndex 003 | RW | 0x0000012C (300dec)
 | F010:04 | SubIndex 004 | RW | 0x0000012C (300dec)
 | F010:05 | SubIndex 005 | RW | 0x0000012C (300dec)
F800:0 | Subindex | AI Range Settings (new modules) | RW | 0x04 (4dec)
 | F800:01 | Input type Ch1 | RW | 0x0000 (0dec)
 | F800:02 | Input type Ch2 | RW | 0x0000 (0dec)
 | F800:03 | Input type Ch3 | RW | 0x0000 (0dec)
 | F800:04 | Input type Ch4 | RW | 0x0000 (0dec)
8040:0 | Subindex | AI Range Settings | RW | 0x05 (5dec)
 | 8040:01 | Codeword | RW | 0x00000000 (0dec)
 | 8040:02 | Input type Ch1 | RW | 0x0000 (0dec)
 | 8040:03 | Input type Ch2 | RW | 0x0000 (0dec)
 | 8040:04 | Input type Ch3 | RW | 0x0000 (0dec)
 | 8040:05 | Input type Ch4 | RW | 0x0000 (0dec)
Key

Flags:
RO = Read Only
RW = Read/Write


EP31xx - Object description and parameterization

BECKHOFF EP31xx: Configuration

Object description and parameterization

Note 		Parameterization
Terminals' parameterization will be conducted by the CoE online tab (double-click on the referring object) or the Process data tab (PDO assignment).

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization during commissioning
  • Objects intended for regular operation, e.g. through ADS access
  • Objects for indicating internal settings (may be fixed)
  • Further profile-specific objects indicating inputs, outputs and status information

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for parameterization during commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 AI Settings (Parameterizing of Channel 1)
Index | Name | Meaning |  | Data type | Flags | Default
8000:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8000:01 | Enable user scale | 1 | User scale is enabled | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign
8000:06 | Enable filter | 1 | Filter enabled, the cycle-synchronous data exchange is not applied | BOOLEAN | RW | 0x01 (1dec)
8000:07 | Enable limit 1 | 1 | Enable Limit 1 | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Enable limit 2 | 1 | Enable Limit 2 | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | 1 | User calibration is enabled | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | 1 | Vendor calibration is enabled | BOOLEAN | RW | 0x01 (1dec)
8000:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | User scale gain The gain is represented in fixed-point format, with the factor 2-16. A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000hex) and is limited to 0x7FFFF. |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | This object defines the digital filter settings of all the modules channels, if it is activated with index 80n0:06. The possible settings are numbered consecutively |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5IIR 1 | IIR 4
 |  | 6IIR 1 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8000:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | User calibration gain |  | INT16 | RW | 0x4000 (16384dec)
Index 8010 AI Settings (Parameterizing of Channel 2)
Index | Name | Meaning |  | Data type | Flags | Default
8010:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8010:01 | Enable user scale | 1 | User scale is enabled | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign
8010:06 | Enable filter | 1 | Filter enabled, the cycle-synchronous data exchange is not applied | BOOLEAN | RW | 0x01 (1dec)
8010:07 | Enable limit 1 | 1 | Enable Limit 1 | BOOLEAN | RW | 0x00 (0dec)
8010:08 | Enable limit 2 | 1 | Enable Limit 2 | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable user calibration | 1 | User calibration is enabled | BOOLEAN | RW | 0x00 (0dec)
8010:0B | Enable vendor calibration | 1 | Vendor calibration is enabled | BOOLEAN | RW | 0x01 (1dec)
8010:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | User scale gain The gain is represented in fixed-point format, with the factor 2-16. A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000hex) and is limited to 0x7FFFF. |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are defined for all channels of the module via channel 1. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8010:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | User calibration gain |  | INT16 | RW | 0x4000 (16384dec)
Index 8020 AI Settings (Parameterizing of Channel 3)

(Not available for EP3182-1002)

Index | Name | Meaning |  | Data type | Flags | Default
8020:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8020:01 | Enable user scale | 1 | User scale is enabled | BOOLEAN | RW | 0x00 (0dec)
8020:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign
8020:06 | Enable filter | 1 | Filter enabled, the cycle-synchronous data exchange is not applied | BOOLEAN | RW | 0x01 (1dec)
8020:07 | Enable limit 1 | 1 | Enable Limit 1 | BOOLEAN | RW | 0x00 (0dec)
8020:08 | Enable limit 2 | 1 | Enable Limit 2 | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration | 1 | User calibration is enabled | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration | 1 | Vendor calibration is enabled | BOOLEAN | RW | 0x01 (1dec)
8020:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain | User scale gain The gain is represented in fixed-point format, with the factor 2-16. A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000hex) and is limited to 0x7FFFF. |  | INT32 | RW | 0x00010000 (65536dec)
8020:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8020:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8020:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are defined for all channels of the module via channel 1. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8020:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain | User calibration gain |  | INT16 | RW | 0x4000 (16384dec)
Index 8030 AI Settings (Parameterizing of Channel 4)

(Not available for EP3182-1002)

Index | Name | Meaning |  | Data type | Flags | Default
8030:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8030:01 | Enable user scale | 1 | User scale is enabled | BOOLEAN | RW | 0x00 (0dec)
8030:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign
8030:06 | Enable filter | 1 | Filter enabled, the cycle-synchronous data exchange is not applied | BOOLEAN | RW | 0x01 (1dec)
8030:07 | Enable limit 1 | 1 | Enable Limit 1 | BOOLEAN | RW | 0x00 (0dec)
8030:08 | Enable limit 2 | 1 | Enable Limit 2 | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable user calibration | 1 | User calibration is enabled | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration | 1 | Vendor calibration is enabled | BOOLEAN | RW | 0x01 (1dec)
8030:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain | User scale gain The gain is represented in fixed-point format, with the factor 2-16. A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000hex) and is limited to 0x7FFFF. |  | INT32 | RW | 0x00010000 (65536dec)
8030:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8030:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8030:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are defined for all channels of the module via channel 1. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5IIR 1 | IIR 4
 |  | 6IIR 1 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8030:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain | User calibration gain |  | INT16 | RW | 0x4000 (16384dec)
Index F800 AI Range Settings (EP3174/EP3184 from Firmware-Version 04 and all EP3182)
Index | Name | Meaning |  | Data type | Flags | Default
F800:0 | AI Range Settings | Maximum subindex |  | UINT8 | RO | 0x04 (4dec)
F800:01 | Input type Ch1 | Input signal range for channel 1 |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | -10...+10 V
 |  | 1 | 0...20 mA
 |  | 2 | 4...20 mA
 |  | 6 | 0...10 V
F800:02 | Input type Ch2 | Input signal range for channel 2 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:03* | Input type Ch3 | Input signal range for channel 3 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:04* | Input type Ch4 | Input signal range for channel 4 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)

*) Not available on EP3182-1002

Index 8040 AI Range Settings (EP3174/EP3184 until firmware version 01)
Index | Name | Meaning |  | Data type | Flags | Default
8040:0 | AI Range Settings | Maximum subindex |  | UINT8 | RO | 0x05 (5dec)
8040:01 | Codeword | Enter codeword (31743174hex) to change input types |  | UINT32 | RW | 0x00000000 (0dec)
8040:02 | Input type Ch1 | Input signal range for channel 1 |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | -10...+10 V
 |  | 1 | 0...20 mA
 |  | 2 | 4...20 mA
 |  | 3 | 0...10 V
8040:03 | Input type Ch2 | Input signal range for channel 2 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
8040:04 | Input type Ch3 | Input signal range for channel 3 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
8040:05 | Input type Ch4 | Input signal range for channel 4 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)

Objects for normal operation

The EP3174 does not have objects like this.

Further objects

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x012C1389 (19665801dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP3174-0002
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 01
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains information to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0C664052 (208027730dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x00100002 (1048578dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains information for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dec)
Index 1600 DO RxPDO-Map Outputs

(Only available for EP3182-1002)

Index | Name | Meaning | Data type | Flags | Default
1600:0 | DO RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x05 (5dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (AI Outputs Ch.1), entry 0x01 (Digital Output)) | UINT32 | RO | 0x7020:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x7020:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (DO Outputs), entry 0x0D (Diag)) | UINT32 | RO | 0x7020:0D, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
Index 1800 AI TxPDO-Par Standard Ch.1
Index | Name | Meaning | Data type | Flags | Default
1800:0 | AI TxPDO-Par Standard Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1800:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1800:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1801 AI TxPDO-Par Compact Ch.1
Index | Name | Meaning | Data type | Flags | Default
1801:0 | AI TxPDO-Par Compact Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI TxPDO-Par Standard Ch.2
Index | Name | Meaning | Data type | Flags | Default
1802:0 | AI TxPDO-Par Standard Ch.2 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1802:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
1802:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1802:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1803 AI TxPDO-Par Compact Ch.2
Index | Name | Meaning | Data type | Flags | Default
1803:0 | AI TxPDO-Par Compact Ch.2 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 1804 AI TxPDO-Par Standard Ch.3
Index | Name | Meaning | Data type | Flags | Default
1804:0 | AI TxPDO-Par Standard Ch.3 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1804:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 5 | OCTET-STRING[2] | RO | 05 1A
1804:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1804:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1805 AI TxPDO-Par Compact Ch.3
Index | Name | Meaning | Data type | Flags | Default
1805:0 | AI TxPDO-Par Compact Ch.3 | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 6 | OCTET-STRING[2] | RO | 04 1A
Index 1806 AI TxPDO-Par Standard Ch.4
Index | Name | Meaning | Data type | Flags | Default
1806:0 | AI TxPDO-Par Standard Ch.4 | PDO Parameter TxPDO 7 | UINT8 | RO | 0x09 (9dec)
1806:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 7 | OCTET-STRING[2] | RO | 07 1A
1806:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1806:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1807 AI TxPDO-Par Compact Ch.4
Index | Name | Meaning | Data type | Flags | Default
1807:0 | AI TxPDO-Par Compact Ch.4 | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dec)
1807:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 8 | OCTET-STRING[2] | RO | 06 1A
Index 1A00 AI TxPDO-Map Standard Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | AI TxPDO-Map Standard Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1800:07, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1800:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Compact Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A02 AI TxPDO-Map Standard Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0A (10dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1802:07, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1802:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 AI TxPDO-Map Compact Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A04 AI TxPDO-Map Standard Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Standard Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0A (10dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6020:03, 2
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6020:05, 2
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1804:07, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1804 (AI TxPDO-Par Standard Ch.3), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1804:09, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1804 (AI TxPDO-Par Standard Ch.3), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6020:11, 16
Index 1A05 AI TxPDO-Map Compact Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A05:0 | AI TxPDO-Map Compact Ch.3 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A06AI TxPDO-Map Standard Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A06:0 | AI TxPDO-Map Standard Ch.4 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0A (10dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6030:03, 2
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6030:05, 2
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1806:07, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1806 (AI TxPDO-Par Standard Ch.4), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1806:09, 1
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1806 (AI TxPDO-Par Standard Ch.4), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6030:11, 16
Index 1A07 AI TxPDO-Map Compact Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A07:0 | AI TxPDO-Map Compact Ch.4 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:03 | Subindex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:04 | Subindex 004 | 4. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A06 (6662dec)
Index 1C32 SM output parameter

(Only available for EP3182-1002)

Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter |  | UINT8 | RO | 0x20 (32dec)
1C32:01 | Sync mode |  | UINT16 | RW | 0x0001 (1dec)
1C32:02 | Cycle time |  | UINT32 | RW | 0x000F4240 (1000000dec)
1C32:03 | Shift time |  | UINT32 | RO | 0x00001388 (5000dec)
1C32:04 | Sync modes supported |  | UINT16 | RO | 0xC007 (49159dec)
1C32:05 | Minimum cycle time |  | UINT32 | RO | 0x00009C40 (40000dec)
1C32:06 | Calc and copy time |  | UINT32 | RO | 0x00001388 (5000dec)
1C32:07 | Minimum delay time |  | UINT32 | RO | 0x00000000 (0dec)
1C32:08 | Command |  | UINT16 | RW | 0x0000 (0dec)
1C32:09 | Maximum Delay time |  | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM event missed counter |  | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter |  | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter |  | UINT16 | RO | 0x0000 (0dec)
1C32:20 | Sync error |  | BOOLEAN | RO | 0x00 (0dec)
Index 1C33 SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (no Outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs available)
 UINT16 RW 0x0022 (34dec)
1C33:02 | Cycle time | same as 1C32:02 | UINT32 | RW | 0x000F4240 (1000000dec)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00001388 (5000dec)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: Free Run is supported
  • Bit 1: Synchron with SM 2 Event is supported (Outputs available)
  • Bit 1: Synchron with SM 3 Event is supported (no Outputs available)
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08 or 1C33:08)
 UINT16 RO 0xC007 (49159dec)
1C33:05 | Minimum cycle time | same as 1C32:05 | UINT32 | RO | 0x00009C40 (40000dec)
1C33:06 | Calc and copy time | time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RO | 0x00002710 (10000dec)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00001388 (5000dec)
1C33:08 | Command | same as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum Delay time | time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00001388 (5000dec)
1C33:0B | SM event missed counter | same as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | same as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | same as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
1C33:20 | Sync error | same as 1C32:32 | BOOLEAN | RO | 0x00 (0dec)

Profile specific objects (0x6000-0xFFFF)

The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 AI Inputs
Index | Name | Meaning |  | Data type | Flags | Default
6000:0 | AI Inputs | Maximum sub index |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Is set if the operating range of the sensor is under-runned or if the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Is set if the operating range of the sensor is over-runned or if the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Only if limit check is activated |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Set limit under-runned
 |  | 2 | Set limit over-runned
 |  | 3 | Set limit reached
6000:05 | Limit 2 | Only if limit check is activated |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Set limit under-runned
 |  | 2 | Set limit over-runned
 |  | 3 | Set limit reached
6000:07 | Error | The error bit is set if process data is not valid (open circuit, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of data of assigned TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Analog input data |  | INT16 | RO | 0x0000 (0dec)
Index 6010 AI Inputs
Index | Name | Meaning |  | Data type | Flags | Default
6010:0 | AI Inputs | Maximum sub index |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Is set if the operating range of the sensor is under-runned or if the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Is set if the operating range of the sensor is over-runned or if the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Only if limit check is activated |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Set limit under-runned
 |  | 2 | Set limit over-runned
 |  | 3 | Set limit reached
6010:05 | Limit 2 | Only if limit check is activated |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Set limit under-runned
 |  | 2 | Set limit over-runned
 |  | 3 | Set limit reached
6010:07 | Error | The error bit is set if process data is not valid (open circuit, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State | Validity of data of assigned TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value | Analog input data |  | INT16 | RO | 0x0000 (0dec)
Index 6020 AI Inputs
Index | Name | Meaning |  | Data type | Flags | Default
6020:0 | AI Inputs | Maximum sub index |  | UINT8 | RO | 0x11 (17dec)
6020:01 | Underrange | Is set if the operating range of the sensor is under-runned or if the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Overrange | Is set if the operating range of the sensor is over-runned or if the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Limit 1 | Only if limit check is activated |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Set limit under-runned
 |  | 2 | Set limit over-runned
 |  | 3 | Set limit reached
6020:05 | Limit 2 | Only if limit check is activated |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Set limit under-runned
 |  | 2 | Set limit over-runned
 |  | 3 | Set limit reached
6020:07 | Error | The error bit is set if process data is not valid (open circuit, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State | Validity of data of assigned TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value | Analog input data |  | INT16 | RO | 0x0000 (0dec)
Index 6030 AI Inputs
Index | Name | Meaning |  | Data type | Flags | Default
6030:0 | AI Inputs | Maximum sub index |  | UINT8 | RO | 0x11 (17dec)
6030:01 | Underrange | Is set if the operating range of the sensor is under-runned or if the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:02 | Overrange | Is set if the operating range of the sensor is over-runned or if the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:03 | Limit 1 | Only if limit check is activated |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Set limit under-runned
 |  | 2 | Set limit over-runned
 |  | 3 | Set limit reached
6030:05 | Limit 2 | Only if limit check is activated |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Set limit under-runned
 |  | 2 | Set limit over-runned
 |  | 3 | Set limit reached
6030:07 | Error | The error bit is set if process data is not valid (open circuit, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State | Validity of data of assigned TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value | Analog input data |  | INT16 | RO | 0x0000 (0dec)
Index 7020 DO Outputs

(Only available for EP3182-1002)

Index | Name | Meaning | Data type | Flags | Default
7020:0 | DO Outputs | Maximum sub index | UINT8 | RO | 0x02 (2dec)
7020:01 | Digital output 1 |  | BOOLEAN | RO | 0x00 (0dec)
7020:02 | Digital output 2 |  | BOOLEAN | RO | 0x00 (0dec)
7020:0D | Diag |  | BOOLEAN | RO | 0x00 (0dec)
Index 800E AI Internal data
Index | Name | Meaning | Data type | Flags | Default
800E:0 | AI Internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
800E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 800F AI Vendor data
Index | Name | Meaning | Data type | Flags | Default
800F:0 | AI Vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
800F:01 | R0 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:02 | R0 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
800F:03 | R1 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:04 | R1 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
800F:05 | R2 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:06 | R2 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 801E AI Internal data
Index | Name | Meaning | Data type | Flags | Default
801E:0 | AI Internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
801E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 801F AI Vendor data
Index | Name | Meaning | Data type | Flags | Default
801F:0 | AI Vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
801F:01 | R0 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:02 | R0 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
801F:03 | R1 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:04 | R1 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
801F:05 | R2 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:06 | R2 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 802E AI Internal data
Index | Name | Meaning | Data type | Flags | Default
802E:0 | AI Internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
802E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 802F AI Vendor data
Index | Name | Meaning | Data type | Flags | Default
802F:0 | AI Vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
802F:01 | R0 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:02 | R0 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
802F:03 | R1 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:04 | R1 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
802F:05 | R2 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:06 | R2 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 803E AI Internal data
Index | Name | Meaning | Data type | Flags | Default
803E:0 | AI Internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
803E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 803F AI Vendor data
Index | Name | Meaning | Data type | Flags | Default
803F:0 | AI Vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
803F:01 | R0 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:02 | R0 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
803F:03 | R1 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:04 | R1 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
803F:05 | R2 offset | offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:06 | R2 gain | gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | general information about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | number of channels | UINT16 | RO | 0x0005 (5dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum sub index | UINT8 | RW | 0x05 (5dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x0000012C (300dec)


ELxxxx - restoring the delivery state

BECKHOFF ELxxxx: Configuration

Restoring the delivery state

To restore the delivery state for backup objects in ELxxxx terminals, the CoE object "Restore default parameters", SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. 1)

Fig. 1 Selecting the "Restore default parameters" PDO

Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field "Dec" or the value 0x64616F6C in field "Hex" and confirm with OK (Fig. 2).
All backup objects are reset to the delivery state.

Fig. 2 Entering a restore value in the Set Value dialog

Note 		Alternative restore value

In some older terminals the backup objects can be switched with an alternative restore value:

Decimal value: "1819238756"

Hexadecimal value: "0x6C6F6164"

An incorrect entry for the restore value has no effect.


EP3174-0002 - Process image

AI Standard Channel 1
Under AI Standard Channel 1 you can find the data of the module's 1st analog channel.
AI Standard Channel 2 to 4

The data of the 2nd to 3rd analog channels are organized in the same way as the data of the 1st channel.


EP3182-1002 - Process image

Analog Inputs

AI Standard Channel 1
Under AI Standard Channel 1 you can find the data of the module's 1st analog channel.
AI Standard Channel 2

The data of the 2nd analog channel is organized in the same way as the data of the 1st channel.

Digital Outputs

DO Outputs
Under DO Outputs you can find the date of the module's digital outputs.


EP3184-0002 - Process image

AI Standard Channel 1
Under AI Standard Channel 1 you can find the data of the module's 1st analog channel.
AI Standard Channel 2 to 4

The data of the 2nd to 3rd analog channels are organized in the same way as the data of the 1st channel.


EP3184-1002 - Process image

AI Standard Channel 1
Under AI Standard Channel 1 you can find the data of the module's 1st analog channel.
AI Standard Channel 2 to 4

The data of the 2nd to 3rd analog channels are organized in the same way as the data of the 1st channel.


General operating conditions

Protection degrees (IP-Code)

The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.

1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø12,5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø2,5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.

*) These protection classes define only protection against water!

Chemical Resistance

The Resistance relates to the Housing of the Fieldbus Box and the used metal parts.

Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key

resistant: Lifetime several months
non inherently resistant: Lifetime several weeks
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box - Accessories

Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | Torque socket wrench with ratchet wrench for M8 connectors (over molded)
ZB8800-0001 | ratchet wrench for M8 connectors (field assembly)
ZB8800-0002 | ratchet wrench for M12 connectors (over molded)

Note 		Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under www.beckhoff.com.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com