AX2000 - Konfigurationsbeispiel

BECKHOFF Antriebstechnik

Konfigurationsbeispiel für AX2000

Version: 2.0
Datum: 15.10.2007


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


AX2000-Konfigurationsbeispiel - Sicherheitshinweise zu Servoverstärkern

BECKHOFF AX2000: Vorwort

Sicherheitshinweise zu Servoverstärkern

Nur qualifiziertes Fachpersonal darf Arbeiten wie Transport, Installation, Inbetriebnahme und Instandhaltung ausführen. Qualifiziertes Fachpersonal sind Personen, die mit Transport, Aufstellung, Montage, Inbetriebnahme und Betrieb des Produktes vertraut sind und über die ihrer Tätigkeit entsprechenden Qualifikationen verfügen.

Das Fachpersonal muss folgende Normen bzw. Richtlinien kennen und beachten:

  • IEC 364 bzw. CENELEC HD 384 oder DIN VDE 0100
  • IEC-Report 664 oder DIN VDE 0110
  • nationale Unfallverhütungsvorschriften oder BGV A2
Gefahr Lesen Sie vor der Installation und Inbetriebnahme das Installations-Handbuch. Falsches Handhaben des Servoverstärkers kann zu Personen- oder Sachschäden führen. Halten Sie die technischen Daten und die Angaben zu den Anschlussbedingungen (Typenschild und Dokumentation) unbedingt ein.

Achtung Die Servoverstärker enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können. Entladen Sie Ihren Körper, bevor Sie den Servoverstärker berühren. Vermeiden Sie den Kontakt mit hochisolierenden Stoffen (Kunstfaser, Kunststofffolien, etc.). Legen Sie den Servoverstärker auf eine leitfähige Unterlage.

Gefahr Öffnen Sie die Geräte nicht. Halten Sie während des Betriebes alle Abdeckungen und Schaltschranktüren geschlossen. Es besteht die Gefahr von Tod oder schweren gesundheitlichen oder materiellen Schäden.

Gefahr Während des Betriebes können Servoverstärker ihrer Schutzart entsprechend spannungsführende, blanke Teile besitzen. Steuer- und Leistungsanschlüsse können Spannung führen, auch wenn sich der Motor nicht dreht.

Gefahr Während des Betriebes können Servoverstärker heiße Oberflächen besitzen. Da die Frontplatte als Kühlelement verwendet wird, kann sie Temperaturen über 80°C erreichen.

Gefahr Lösen Sie die elektrischen Anschlüsse der Servoverstärker nie unter Spannung. In ungünstigen Fällen können Lichtbögen entstehen und Personen und Kontakte schädigen.

Gefahr Warten Sie nach dem Trennen der Servoverstärker von den Versorgungsspannungen mindestens fünf Minuten, bevor Sie spannungsführende Geräteteile (z.B. Kontakte) berühren oder Anschlüsse lösen. Kondensatoren führen bis zu fünf Minuten nach Abschalten der Versorgungsspannung gefährliche Spannung. Messen Sie zur Sicherheit die Spannung im Zwischenkreis und warten Sie, bis die Spannung unter 40 V abgesunken ist.


AX2000-Konfigurationsbeispiel - Ausgabestände der Dokumentation

BECKHOFF AX2000: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
2.0 | Support und Service aktualisiert
1.0 | Erste Veröffentlichung


AX2000-Konfigurationsbeispiel - Einleitung

BECKHOFF AX2000: Konfigurationsbeispiel

Einleitung

Hinweis Diese Dokumentation ist nur eine zusätzliche Hilfe und kein Ersatz für die Montage- und Installationsanleitung!
Sie zeigt die ersten Schritte der Einbindung und der Konfiguration des Digitalen Servoverstärkers AX2000 von Beckhoff.

In den Beispielen wird der Motor ohne Last eingebunden. Der Motor kann sich frei drehen.

Für die weitere Inbetriebnahme im eingebauten Zustand lesen Sie bitte das Kapitel Erste Schritte. Informationen über die AX2000-Software erhalten Sie in der Dokumentation Quickstart.

Gefahr Bitte beachten Sie bei der Inbetriebnahme unbedingt die Sicherheitshinweise.

Download des Beispielprogramms: AX2000DEMO.PRO unter Schritt 4.


AX2000-Konfigurationsbeispiel - Schritt 1: Einbinden der Schnittstellenkarten

Schritt 1: Einbinden der Schnittstellenkarten

Die Schnittstellenkarte FC2001 und den AX2000 neu in den System Manager Einbinden.

FC2001 / FC2002

AX2000

Auswählen des E/A Gerätes durch betätigen der Rechten Maustaste auf dem Symbol "E/A - Konfiguration" --> "E/A Geräte".

Betätigen des Symbols "Gerät Anfügen...".

Auswählen der Buskarte die in Ihrem IPC steckt. (In diesem Beispiel wird die Beckhoff Lightbus Karte C1220 verwendet.)

Die Auswahl erfolgt durch Doppelklick der Angewählten Karte "II/O Lightbus FC200x, PCI" oder über den Butten "Okay".

Um den AX2000 an die Feldbuskarte anzubinden werden wieder die gleichen Schritte wie zuvor ausgeführt.

Auswählen der E/A Box durch betätigen der Rechten Maustaste auf dem Symbol:

"E/A - Konfiguration" --> "E/A Geräte" --> "Gerät 1 (FC200x)" --> "Box Anfügen...".

Die Auswahl erfolgt durch Doppelklick der Angewählten Box "AX2000 Antrieb (Lightbus)" oder über den Butten "Okay".

Jetzt ist die Hardware des AX2000 eingebunden.

Unter "Name:" kann der Name der Achse frei vergeben werden. (z.B. Hubachse Greifer 1 Station 1)

Hinweis Spätestens nach jedem Schritt sollten Sie Ihr Projekt speichern!

Weiter geht es mit dem 2. Schritt.


AX2000-Konfigurationsbeispiel - Schritt 2: NC Task Anfügen

Schritt 2: NC Task Anfügen

Auswählen des NC Task durch Betätigen der rechten Maustaste auf dem Symbol "NC - Konfiguration" und Betätigen des Buttons "Task Anfügen..." .

Eintragen des Namens des NC -Task´s. Der Name kann frei vergeben werden.

Bestätigen mit dem Button "Okay".

Sicherheitsmassnahme Überwachung bei Tasklaufzeitüberschreitung

Zu Diagnose- und Analysezwecken sollte die Überwachung der Tasklaufzeitüberschreitung aktiviert sein. Inhaltlich hat diese Überwachung keinen Einfluss, aber falls es einmal zu einer unerwarteten Tasklaufzeitüberschreitung kommen sollte, wird hierauf mit einer Meldebox und einem zusätzlichen Eintrag in der Ereignisanzeige reagiert.

Diese Sicherheitsfunktion wird eingeschaltet unter "NC-Task1 SAF" durch anklicken der Checkbox "Warnung bei Überschreitung".

Und danach durch anklicken der Checkbox "Messagebox".

SAF = Satz Ausführungs- Task

Priorität: Die Default Einstellung sollte nicht geändert werden. ( 4 )

Zyklusticks: Die Default Einstellung sollte nicht geändert werden. ( 2 )

Warnung bei Über.: Einschalten. ( *)

Messagebox: Einschalten. ( *)

Optionen

I/O am Taskanfang: Die Default Einstellung sollte nicht geändert werden. ( *)

Disable: Die Default Einstellung sollte nicht geändert werden. ( [image] )

Symbole erzeugen: Die Default Einstellung sollte nicht geändert werden. ( [image] )
Wird nur für die Anzeige im Scope oder in der Visualisierung benötigt und sollte nur

eingeschaltet werden wenn es benötigt wird. (Ressourcen

)

Sicherheitsmassnahme Überwachung bei Tasklaufzeitüberschreitung

Zu Diagnose- und Analysezwecken sollte die Überwachung der Tasklaufzeitüberschreitung aktiviert sein. Inhaltlich hat diese Überwachung keinen Einfluss, aber falls es einmal zu einer unerwarteten Tasklaufzeitüberschreitung kommen sollte, wird hierauf mit einer Meldebox und einem zusätzlichen Eintrag in der Ereignisanzeige reagiert.

Diese Sicherheitsfunktion wird eingeschaltet unter "NC-Task1 SVB" durch anklicken der Checkbox "Warnung bei Überschreitung".

SVB = Satz Vorbereitungs- Task

Priorität: Die Default Einstellung sollte nicht geändert werden. ( 8 )

Zyklusticks: Die Default Einstellung sollte nicht geändert werden. ( 10 )

Warnung bei Über.: Einschalten. ( *)

Messagebox: Einschalten. ( *)

Optionen

Disable: Die Default Einstellung sollte nicht geändert werden. ( [image] )

Symbole erzeugen: Die Default Einstellung sollte nicht geändert werden. ( [image] )
Wird nur für die Anzeige im Scope oder in der Visualisierung benötigt und sollte nur
eingeschaltet werden wenn es benötigt wird. (Ressourcen

)

Als nächstes wird die Achse Angefügt. Durch betätigen der Rechten Maustaste auf dem Symbol "Achsen" und betätigen des Buttons "Achse Anfügen..." .

Es muss der Typ: "Kontinuierliche Achse (inkl. SERCOS)" ausgewählt sein.

Hier sollte unter "Name:" der gleiche Name der Achse eingetragen werden wie vorher in Schritt 1. (z.B. Hubachse Greifer 1 Station 1)

Mit dem Button "Okay" wird die NC-Achse eingefügt.

Jetzt beginnt die Konfiguration der Achse.

Symbole erzeugen: Die Default Einstellung sollte nicht geändert werden. ( [image] )

Wird nur für die Anzeige im Scope oder in der Visualisierung benötigt und sollte nur

eingeschaltet werden wenn es benötigt wird. (Ressourcen

)

Hinweis Spätestens nach jedem Schritt sollten Sie Ihr Projekt speichern!

Weiter geht es mit dem 3. Schritt Konfiguration der AX2000.


AX2000-Konfigurationsbeispiel - Schritt 3: Ausschalten des Experten-Modus

Schritt 3: Ausschalten des Experten-Modus

Für die Erstinbetriebnahme sollte der Experten Modus ausgeschaltet sein. Dadurch wird die Anzahl der Parameter auf die unbedingt notwendigen reduziert.

Der Experten Modus wird ausgeschaltet durch das Betätigen der linken Maustaste über "Ansicht" und dem Button "Experten Modus".

oder

direkt über den Button " [image] " in der Hauptleiste.

Weiter geht es mit dem Schritt 3.1 Einstellungen.


AX2000-Konfigurationsbeispiel - Schritt 3.1: Einstellungen

Schritt 3.1: Einstellungen

Änderung der Einstellungen des AX2000 durch Betätigen der linken Maustaste auf dem Reiter "Einstellungen".

Einstellen des richtigen "Achstyps:".

"AX2000 Antrieb (Lightbus)"

Achtung!!! Diese Einheit ist für alle weiteren Einstellungen die Grundlage.

Erstellen der Verknüpfung mit der Hardware durch Betätigung des Buttons "Verknüpft m...".

Verknüpfen mit der Hardware Box "Box 1 (AX2000)" (Wenn Sie die "Box1 (AX2000)" umbenannt haben steht hier ihr Name.)

Hinweis Spätestens nach jedem Schritt sollten Sie Ihr Projekt speichern!

Weiter geht es mit dem Schritt 3.2 Globale Achs Daten.


AX2000-Konfigurationsbeispiel - Schritt 3.2: Globale Achsdaten

Schritt 3.2: Globale Achsdaten

Ändern der Globalen Achs Daten des AX2000 durch betätigen der linken Maustaste auf dem Reiter "Global".

Daten von der Mechanik

Von der Mechanik müssen für die Konfigurierung Folgende Daten bekannt sein:

Übersetzung: 1 Motorumdrehung = xxx.xx mm Weg (oder Grad, Rad u.s.w.)

In unserem Beispiel wird angenommen das die Übersetzung = 1 mm beträgt.

Zulässige Maximale Geschwindigkeit: (Konstruktiv Bedingt!)

In unserem Beispiel = 50mm/s

Beschleunigung:

Verzögerung:

Beschleunigungsänderung (Ruck):

Daten vom Antrieb

Vom Antrieb müssen für die Konfigurierung Folgende Daten bekannt sein:

Enddrehzahl: In unserem Beispiel 3000 1/min.

Maximal vom Motor abhängig! (Dise Daten bekommen Sie aus der mit dem AX2000 Ausgelieferten Parametriersoftware. Drehzahlregler)

Übersetzung:

Der AX2000 liefert dem TwinCAT immer 65535 Impulse pro Antriebsumdrehung! (Die Einstellung vom AX2000 wird im TwinCAT immer auf 65535 umgerechnet!)

Skalierungsfaktor:

Der Skalierungsfaktor berechnet sich aus dem Weg pro Motorumdrehungen Dividiert durch die Impulse pro Motorumdrehung. In unserem Beispiel 1:65635= 1,5259021896696421759365224689097e-5.

Bezugsgeschwindigkeit:

Die Berechnete Bezugsgeschwindigkeit in unserem Beispiel beträt 50mm/s.

Jetzt werden unsere berechneten Werte eingetragen.

Die Auswahl erfolgt mit der linken Maustaste.

Mit einem "Doppelklick" der linken Maustaste kann ich diesen Wert parametrieren.

Aus Sicherheitsgründen ziehen wir noch 10% von unserer Maximal erlaubten Geschwindigkeit ab.
In unserem Beispiel: 50mm/s - 10% = 45 mm/s.

Wichtig!! Nach dem Eintrag der Zahl, diese mit der Taste "Enter" bestätigen.

Alle geänderten Werte werden mit einem Stern gekennzeichnet.

Die Eilganggeschwindigkeit entspricht der Maximal erlaubten Geschwindigkeit.

Die Hand Min und Max Geschwindigkeit stellen wir in unserem Beispiel auf 5% und 10% der Maximal erlaubten Geschwindigkeit.

Die Referenz Geschwindigkeit stellen wir in unserem Beispiel auf 5% der Maximal erlaubten Geschwindigkeit ein.

Die Endlagenüberwachung ist für die Erstinbetriebnahme nicht nötig und wird in unserem Beispiel nicht aktiviert.

Wichtig!!!

Die Endlagenüberwachung sollte nach dem Mechanischen Einbau unbedingt eingestellt und aktiviert werden.

Die Schleppabstandsüberwachung sollte unbedingt eingeschaltet werden.

Durch "Doppel Klick" öffnet sich ein Fenster Menü. Hier muss TRUE ausgewählt und angeklickt werden.

Die Werte der Voreinstellung reichen in den meisten Fällen aus. In unserem Beispiel bleiben die voreingestellten Werte bestehen.

Die Werte der Voreinstellung reichen in den meisten Fällen aus. In unserem Beispiel lassen wir die Werte der Voreinstellung stehen.

Auch bei der PEH - Zeitüberwachung können wir die Voreinstellung stehen lassen.

Jetzt haben Sie alle wichtigen Parameter der Globalen Einstellungen auf Ihren Antrieb angepasst.
Weiter geht es mit den Dynamischen Einstellungen.

Hinweis Spätestens nach jedem Schritt sollten Sie Ihr Projekt speichern!

Weiter geht es mit dem Schritt 3.3 Dynamik.


AX2000-Konfigurationsbeispiel - Schritt 3.3: Dynamik

Schritt 3.3: Dynamik

Ändern der Dynamik des AX2000 durch betätigen der linken Maustaste auf dem Reiter "Dynamik".

In dieser Maske sollte die Box "Indirekt über Hochlaufzeit" ausgewählt werden.

Hinweis Hier sollte die in der Maske "Global" eingestellte Maximalgeschwindigkeit stehen.

Die Bremszeit sollte "wie oben" eingestellt sein.

Mit der linken Maustaste kann man den Slider für die Beschleunigungs- und Verzögerungskennlinie verstellen.

Für die Inbetriebnahme sollte der Slider auf die Mitte gezogen werden.

Hinweis Spätestens nach jedem Schritt sollten Sie Ihr Projekt speichern!

Weiter geht es mit dem Schritt 3.4 NC-Controller.


AX2000-Konfigurationsbeispiel - Schritt 3.4: NC-Controller

Schritt 3.4: NC-Controller

Öffnen Sie die Maske mit dem Namen xxx_Ctrl in unserem Beispiel Hubachse Greifer 1 Station 1_Ctrl.

Wählen Sie aus den Reiter PID aus.

Bitte geben Sie 0.0001 ein.

Dieser Wert wird aus Sicherheitsgründen für die Erstinbetriebnahme eingegeben. Der Wert wird im Laufe der weiteren Inbetriebnahme langsam wieder erhöht.

Spätestens nach jedem Schritt sollten Sie Ihr Projekt speichern!

Jetzt übertragen wir die Konfiguration in den Rechner.

Betätigen Sie nach einander die Button´s:

"Zuordnung Erzeugen"

"Überprüfen der Konfiguration"

"Sichern der Konfiguration".

Danach starten Sie das TwinCAT System neu.

Speichern Sie Ihr Projekt noch einmal ab.

Weiter geht es mit dem Schritt 3.5 Online.


AX2000-Konfigurationsbeispiel - Schritt 3.5: Online

Schritt 3.5: Online

Hinweis Spätestens nach jedem Schritt sollten Sie Ihr Projekt speichern!

Weiter geht es mit dem Schritt 4.


AX2000-Konfigurationsbeispiel - Schritt 4: Software-Projekt Einfügen

Schritt 4: Software-Projekt Einfügen

In dieser Dokumentation ist ein Beispiel-Projekt mit dem Namen AX2000DEMO.PRO und AX2000DEMO.wsm enthalten. Dieses Projekt wird jetzt beispielhaft eingebunden. Sie müssen das Beispielprojekt durch ihr eigenes Projekt ersetzen.

Auswählen des SPS Programms durch Betätigen der rechten Maustaste auf dem Symbol "SPS - Konfiguration" und Betätigen des Buttons "IEC Projekt Anfügen...".

Wählen Sie die Datei AX2000DEMO.pro aus und bestätigen Sie mit dem Button "Öffnen" oder durch Doppelklick auf die angewählte Datei.

Jetzt ist die Software in dem System Manager eingebunden.

Variablen einbinden!!!!!

Hinweis Spätestens nach jedem Schritt sollten Sie Ihr Projekt speichern!

Weiter geht es mit der Konfiguration der AX2000.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.