EL6752 - Master-/Slave-Klemme DeviceNet
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.1
▪
Kapitel “Explizite Nachrichten ergänzt”
▪
Aktualisierung Kapitel “Technische Daten”
▪
Update Struktur
▪
Update Revisionstatus
2.0
▪
Migration
▪
Struktutrupdate
1.4
▪
Hinzugefügt: Kapitel "Konfiguration": DeviceNet Adresse und Baudrate über ADS ändern
▪
Strukturupdate
1.3
▪
Korrekturen Kapitel "Technische Daten"
▪
Hinzugefügt: Kapitel "Firmware Status"
▪
Strukturupdate
1.2
▪
Korrekturen Kapitel "Montage und Verdrahtung
1.1
▪
Korrekturen Kapitel "Montage und Verdrahtung
1.0
▪
Korrekturen und Ergänzungen, erste Veröffentlichung
0.2
▪
Korrekturen und Ergänzungen
0.1
▪
Interne Vorabversion


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten


Einführung

Produktübersicht [image] Einführung
Einführung
EL6752
Master- und Slave-Klemmen für DeviceNet
Die Master- und Slave-Klemmen für DeviceNet entsprechen der Beckhoff PCI-Karte FC5201. Durch den Anschluss via EtherCAT kann im PC auf PCI-Slots verzichtet werden. Im EtherCAT-Klemmenverbund erlaubt die Klemme die Integration beliebiger DeviceNet-Geräte.
Die EL6752 ist wahlweise als Master- oder Slave-Ausführung erhältlich und verfügt über eine leistungsfähige Protokollimplementierung mit vielen Features:
▪
Alle I/O-Modi des DeviceNet werden unterstützt: Polling, Change-of-State, Cyclic, Strobed
▪
Unconnected-Message-Manager (UCMM)
▪
Leistungsfähige Parameter- und Diagnoseschnittstellen
▪
Error-Management für jeden Busteilnehmer frei konfigurierbar
Eine Beschreibung aller Funktionalitäten und Betriebsmodi finden Sie im Kapitel "Konfiguration" und den entsprechenden Unterkapiteln.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | EL6752-0000 | EL6752-0010
Bus-System | DeviceNet
Variante | Master | Slave
Anzahl Feldbuskanäle | 1
Übertragungsrate | 125, 250 oder 500 kBaud
Bus-Interface | Open-Style-Connector 5-polig gemäß DeviceNet-Spezifikation, galvanisch entkoppelt, Stecker wird mitgeliefert
Busteilnehmer | maximal 63 Slaves
Kommunikation | DeviceNet-Netzwerkmaster (Scanner) | DeviceNet-Slave
Diagnose | Status-LEDs
Spannungsversorgung | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 260 mA
Potenzialtrennung | 500 V (E-Bus/CANopen)
Konfiguration | mit TwinCAT System-Manager
Gewicht | ca. 70 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 52 mm
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


DeviceNet Grundlagen

DeviceNet Grundlagen
DeviceNet Grundlagen
Systemvorstellung
DeviceNet ist ein offenes System das auf der Basis von CAN aufsetzt. CAN wurde vor einigen Jahren von der Firma R. Bosch für die Datenübertragung in Kraftfahrzeugen entwickelt. Seitdem sind Millionen von CAN-Chips im Einsatz. Nachteilig für einen Einsatz in der Automatisierungstechnik ist, dass CAN keine Definitionen für die Applikationsschicht enthält. CAN definiert nur die physikalische und Datensicherungsschicht.
Mit DeviceNet ist eine einheitliche Applikationsschicht festgelegt, mit der das CAN-Protokoll für Industrieanwendungen nutzbar wird. Die ODVA (Open DeviceNet Vendor Association) unterstützt Hersteller und Anwender des Systems DeviceNet als unabhängiger Verein. Die ODVA stellt sicher, dass alle Geräte, die der Spezifikation entsprechen, herstellerneutral zusammen in einem System arbeiten. CAN bietet durch das Verfahren der Bitarbitration grundsätzlich die Möglichkeit Kommunikationsnetze mit Master/Slave- und Multimaster- Zugriffsverfahren zu betreiben.
Weitere Details finden Sie auf der offiziellen Webseite der ODVA (http://www.odva.org).
Beispiel für eine Vernetzung mit DeviceNet
Buskabel
Als Buskabel dient eine 2x2 adrig verdrillte und geschirmte Leitung. Ein Adernpaar übernimmt die Datenübertragung und das zweite Adernpaar ist für die Stromversorgung zuständig. Es kann Ströme bis zu 8 Ampere führen. Die maximal zulässige Leitungslänge ist vorrangig von der Baudrate abhängig. Wird die höchste Baudrate (500 kBaud) gewählt, sind max. 100 m Leitung zulässig. Bei der geringsten Baudrate (125 kBaud) ist eine gesamte Kabellänge von 500 m realisierbar. Details siehe im Kapitel "Montage und Verdrahtung"
Beispiel DeviceNet Verkabelung


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Empfohlene Tragschienen
•
Montage und Demontage - Zughebelentriegelung
•
Montage und Demontage - Frontentriegelung oben
•
DeviceNet Verkabelung
•
Einbaulagen
•
Positionierung von passiven Klemmen
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)


Hinweise zum ESD-Schutz

Montage und Verkabelung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Empfohlene Tragschienen

Montage und Verkabelung [image] Empfohlene Tragschienen
Empfohlene Tragschienen
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:
▪
Tragschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
▪
Tragschiene TH 35-15 mit 1,5 mm Materialstärke
Materialstärke der Tragschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Tragschiene TH 35-15 mit 2,2 bis 2,5 mm Materialstärke (nach EN 60715)!


Montage und Demontage - Zughebelentriegelung

Montage und Verkabelung [image] Montage und Demontage - Zughebelentriegelung
Montage und Demontage - Zughebelentriegelung
Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-15) auf der Montagefläche befestigt.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung der empfohlenen Tragschienen unter den Klemmen flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene Einrastet (2).
▪
Schließen Sie die Leitungen an.
Demontage
▪
Entfernen Sie alle Leitungen. Dank der KM/EM-Steckverbinder müssen Sie hierzu nicht alle Leitungen einzeln entfernen, sondern pro KM/EM-Steckverbinder nur 2 Schrauben lösen um diese abziehen zu können (stehende Verdrahtung)!
▪
Hebeln Sie auf der linken Seite des Klemmenmoduls mit einem Schraubendreher (3) den Entriegelungshaken nach oben. Dabei
–
ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück,
–
bewegt sich der Entriegelungshaken nach vorne (3b) und rastet ein
▪
Bei 32- und 64-kanaligen Klemmenmodulen (KMxxx4 und KMxxx8 bzw. EMxxx4 und EMxxx8) hebeln Sie nun den zweiten Entriegelungshaken auf der rechten Seite des Klemmenmoduls auf die gleiche Weise nach oben.
▪
Ziehen Sie (4) das Klemmenmodul von der Montagefläche weg.


Montage und Demontage - Frontentriegelung oben

Montage und Verkabelung [image] Montage und Demontage - Frontentriegelung oben
Montage und Demontage - Frontentriegelung oben
Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-15) auf der Montagefläche befestigt.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung der empfohlenen Tragschienen unter den Klemmen flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene einrastet (2).
▪
Schließen Sie die Leitungen an.
Demontage
▪
Entfernen Sie alle Leitungen.
▪
Ziehen Sie mit Daumen und Zeigefinger die orange Entriegelungslasche (3) zurück. Dabei ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück.

▪
Ziehen Sie (4) das Klemmenmodul von der Montagefläche weg. Vermeiden Sie ein Verkanten; stabilisieren Sie das Modul ggf. mit der freien Hand


DeviceNet Verkabelung

Montage und Verkabelung [image] DeviceNet Verkabelung
DeviceNet Verkabelung
Weiterführende Informationen
•
CAN / DeviceNet Topologie
•
Buslänge
•
Stichleitungen
•
Sternverteiler (Multiport Tap)
•
CAN-Kabel
•
Schirmung
•
Kabelfarben und Pin-Belegung


CAN / DeviceNet Topologie

Montage und Verkabelung [image] DeviceNet Verkabelung [image] CAN / DeviceNet Topologie
CAN / DeviceNet Topologie
CAN / DeviceNet ist ein 2-Draht-Bussystem, an dem alle Teilnehmer parallel (d.h. mit kurzen Stichleitungen) angeschlossen werden (Abb. DeviceNet Topologie). Der Bus muss an jedem Ende mit einem Abschlusswiderstand von 120 (bzw. 121) Ohm abgeschlossen werden, um Reflexionen zu vermeiden. Dies ist auch bei sehr kurzen Leitungslängen erforderlich!
DeviceNet Topologie
Da die CAN-Signale als Differenzpegel auf dem Bus dargestellt werden, ist die CAN-Leitung vergleichsweise unempfindlich gegen eingeprägte Störungen (EMI). Es sind jeweils beide Leitungen betroffen, somit verändert die Störung den Differenzpegel kaum.
Geringe Störeinwirkung durch Differenzpegel


Buslänge

Montage und Verkabelung [image] DeviceNet Verkabelung [image] Buslänge
Buslänge
Die maximale Buslänge wird bei CAN vorwiegend durch die Signallaufzeit beschränkt. Das Multi-Master-Buszugriffsverfahren (Arbitrierung) erfordert, dass die Signale quasi gleichzeitig (vor der Abtastung innerhalb einer Bitzeit) an allen Knoten anliegen. Da die Signallaufzeit in den CAN-Anschaltungen (Transceiver, Optokoppler, CAN-Controller) nahezu konstant sind, muss die Leitungslänge an die Baud-Rate angepasst werden.
Baud-Rate | Buslänge
500 kBit/s | < 100 m
250 kBit/s | < 250 m
125 kBit/s | < 500 m


Stichleitungen

Montage und Verkabelung [image] DeviceNet Verkabelung [image] Stichleitungen
Stichleitungen
Stichleitungen ("drop lines") sind nach Möglichkeit zu vermeiden, da sie grundsätzlich zu Signalreflexionen führen. Die durch Stichleitungen hervorgerufenen Reflexionen sind jedoch in der Regel unkritisch, wenn sie vor dem Abtastzeitpunkt vollständig abgeklungen sind. Bei den in den Buskopplern gewählten Bit-Timing-Einstellungen kann dies angenommen werden, wenn folgende Stichleitungslängen nicht überschritten werden:
Baud-Rate | Länge Stichleitung | gesamte Länge aller Stichleitungen
500 kBit/s | < 6 m | < 39 m
250 kBit/s | < 6 m | < 78 m
125 kBit/s | < 6 m | < 156 m
Stichleitungen dürfen nicht mit Abschlusswiderständen versehen werden (Abb. Topologie Stichleitungen).
Topologie Stichleitungen


Sternverteiler (Multiport Tap)

Montage und Verkabelung [image] DeviceNet Verkabelung [image] Sternverteiler (Multiport Tap)
Sternverteiler (Multiport Tap)
Beim Einsatz von passiven Verteilern ("Multiport Taps"), z. B. der Beckhoff Verteilerbox ZS5052-4500 sind kürzere Stichleitungslängen einzuhalten. Die folgende Tabelle gibt die maximalen Stichleitungslängen und die maximale Länge der Trunk Line (ohne Stichleitungen) an:
Richtwerte
Die folgenden Werte sind Empfehlungen von BECKHOFF!
Baud-Rate | Länge Stichleitung bei Multiport Topologie | Länge Trunk Line (ohne Stichleitungen)
500 kBit/s | < 1,2 m | < 66 m
250 kBit/s | < 2,4 m | < 120 m
125 kBit/s | < 4,8 m | < 310 m


CAN-Kabel

Montage und Verkabelung [image] DeviceNet Verkabelung [image] CAN-Kabel
CAN-Kabel
Für die CAN-Verdrahtung wird die Verwendung von paarig verdrillten, geschirmten Kabeln (2x2) mit einem Wellenwiderstand von 108...132 Ohm empfohlen. Wenn das Bezugspotential der CAN-Transceiver (CAN-Ground) nicht verbunden werden soll, so kann auf das zweite Adernpaar verzichtet werden (nur bei kleinen Netzausdehnungen mit gemeinsamer Speisung aller Teilnehmer empfehlenswert).
ZB5200 CAN / DeviceNet-Kabel
Das Kabelmaterial ZB5200 entspricht der DeviceNet Spezifikation und eignet sich ebenso für CANopen Systeme. Aus diesem Kabelmaterial sind auch die vorkonfektionierten Busleitungen ZK1052-xxxx-xxxx für die Feldbus Box Baugruppen gefertigt. Es hat folgende Spezifikation:
▪
2 x 2 x 0,34 mm² (AWG 22) paarig verseilt
▪
doppelt geschirmt - Schirmgeflecht mit Beilauflitze
▪
Wellenwiderstand (1 MHz): 126 Ohm
▪
Leiterwiderstand 54 Ohm/km
▪
Mantel: PVC grau, Außendurchmesser 7,3 mm
▪
Bedruckt mit "InterlinkBT DeviceNet Type 572" sowie UL und CSA Ratings
▪
Litzenfarben entsprechen DeviceNet Spezifikation
▪
UL anerkanntes AWM Type 2476 Rating
▪
CSA AWM I/II A/B 80°C 300V FT1
▪
Entspricht DeviceNet "Thin Cable" Spezifikation
Aufbau DeviceNet Kabel


Schirmung

Montage und Verkabelung [image] DeviceNet Verkabelung [image] Schirmung
Schirmung
Der Schirm ist über das gesamte Buskabel zu verbinden und nur an einer Stelle galvanisch zu erden um Masseschleifen zu vermeiden.
Das Schirmungskonzept mit HF-Ableitung von Störungen über R/C-Glieder auf die Tragschiene geht davon aus, dass die Tragschiene entsprechend geerdet und störungsfrei ist. Sollte dies nicht der Fall sein, so kann es vorkommen, dass HF-Störpegel über die Tragschiene auf den Schirm des Buskabels übertragen werden. In diesem Fall sollte der Schirm an den Kopplern nicht aufgelegt werden - aber dennoch komplett durchverbunden sein.


Kabelfarben und Pin-Belegung

Montage und Verkabelung [image] DeviceNet Verkabelung [image] Kabelfarben und Pin-Belegung
Kabelfarben und Pin-Belegung
Steckerbelegung (Draufsicht EL6752)
Vorschlag für die Verwendung der Beckhoff CAN-Kabel an Busklemme und Feldbus Box:
Pin | Belegung EL6752 | Kabelfarbe ZB5200
1 | V+ (24 V) | rot
2 | CAN-High | weiß
3 | Schirm | Beilauflitze
4 | CAN-Low | blau
5 | V- | schwarz


Einbaulagen

Montage und Verkabelung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Positionierung von passiven Klemmen

Montage und Verkabelung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verkabelung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


DeviceNet Kommunikation

DeviceNet Kommunikation
DeviceNet Kommunikation
Weiterführende Informationen
•
DeviceNet Einführung
•
Explizite Nachrichten


DeviceNet Einführung

DeviceNet Kommunikation [image] DeviceNet Einführung
DeviceNet Einführung
DeviceNet
DeviceNet ist ein offenes System das auf der Basis von CAN aufsetzt. CAN wurde vor einigen Jahren von der Firma R. Bosch für die Datenübertragung in Kraftfahrzeugen entwickelt. Seitdem sind Millionen von CAN-Chips im Einsatz. Nachteilig für einen Einsatz in der Automatisierungstechnik ist, dass CAN keine Definitionen für die Applikationsschicht enthält. CAN definiert nur die physikalische und Datensicherungsschicht.
Mit DeviceNet ist eine einheitliche Applikationsschicht festgelegt, mit der das CAN-Protokoll für Industrieanwendungen nutzbar wird. Die ODVA (Open DeviceNet Vendor Association) unterstützt Hersteller und Anwender des Systems DeviceNet als unabhängiger Verein. Die ODVA stellt sicher, dass alle Geräte, die der Spezifikation entsprechen, herstellerneutral zusammen in einem System arbeiten.
Beispiel für eine Vernetzung mit DeviceNet
DeviceNet ist ein Sensor-/Aktorbussystem. Es ist international genormt (EN50325) und basiert auf CAN (Controller Area Net-work). DeviceNet unterstützt mehrere Kommunikationsarten für die Ein- und Ausgangsdaten:
▪
Polling: die Masterbaugruppe („Scanner") versendet die Ausgangsdaten zyklisch zu den zugeordneten Teilnehmern und erhält die Eingangsdaten im Antworttelegramm.
▪
Change-of-State: Telegramme werden versendet, sobald sich der Inhalt geändert hat.
▪
Cyclic: Die Baugruppen versenden die Daten nach Ablauf einer Zykluszeit selbstständig.
▪
Strobed: Der Scanner fordert die Eingangsdaten mit einem Broadcast-Telegramm an alle Teilnehmer an.
Die DeviceNet-Geräte unterstützen alle I/O-Kommunikationsarten.
Parametriert werden Device-Net-Geräte über azyklische Dienste (Explicit-Messaging).
Durch die effektive Nutzung der Busbandbreite erreicht DeviceNet vor allem im Change-of-State-Modus kurze Systemreaktionszeiten trotz der vergleichsweise niedrigen Datenraten. Die BECKHOFF DeviceNet-Geräte verfügen über eine leistungsfähige Protokollimplementierung. Durch aktive Mitarbeit in den technischen Gremien der ODVA trägt BECKHOFF zur weiteren Entwicklung dieses Bussystems bei und verfügt damit über profundes DeviceNet-Know-how.
Konfiguration
Die Knotenadresse wird mit zwei dezimal kodierten Drehwahlschaltern im Bereich von 0 bis 63 eingestellt. Die am DeviceNet-Scanner eingestellte Übertragungsrate wird von der DeviceNet-Box selbstständig erkannt (Auto-Baudrate). Für DeviceNet-Konfigurationstools stehen „elektronische Datenblätter" (EDS-Files) zum Download von der Beckhoff-Internetseite (http://www.beckhoff.de) sowie auf den BECKHOFF Produkt-CDs bereit. Spezielle I/O-Parameter, die nicht vom DeviceNet-Standard abgedeckt werden, können über die KS2000-Software (serielle Verbindung) oder über azyklische Explicit-Messages eingestellt werden.
Diagnose
Die umfangreichen Diagnosefunktionen der BECKHOFF DeviceNet-Geräte ermöglichen die schnelle Fehlerlokalisierung. Die Diagnosemeldungen werden über den Bus übertragen und beim Master zusammengefasst. Der Status der Netzwerkverbindung, der Gerätestatus, der Status der Ein- und Ausgänge sowie der Spannungsversorgung werden mit LEDs dargestellt.
Übertragungsraten
Drei Übertragungsraten von 125 kBaud bis 500 kBaud stehen für unterschiedliche Buslängen zur Verfügung. Durch die effektive Nutzung der Busbandbreite erreicht DeviceNet kurze Systemreaktionszeiten bei vergleichsweise niedrigen Datenraten.
Topologie
DeviceNet basiert auf einer linienförmigen Topologie. Die Anzahl der Teilnehmer pro Netz ist dabei von DeviceNet logisch auf 64 begrenzt, physikalisch erlaubt die aktuelle Treiber-Generation bis zu 64 Knoten in einem Netzsegment. Die bei einer bestimmten Datenrate maximal mögliche Netzausdehnung ist durch die auf dem Busmedium erforderliche Signallaufzeit begrenzt. Bei 500 kBaud ist z. B. eine Netzausdehnung von 100 m, bei 125 kBaud eine Netzausdehnung von 500 m möglich. Bei niedrigen Datenraten kann die Netzausdehnung durch den Einsatz von Repeatern erhöht werden, diese ermöglichen auch den Aufbau von Baumstrukturen.
Buszugriffsverfahren
CAN arbeitet nach dem Verfahren Carrier Sense Multiple Access (CSMA), d.h. jeder Teilnehmer ist bezüglich des Buszugriffs gleichberechtigt und kann auf den Bus zugreifen, sobald dieser frei ist (Multi-Master-Buszugriff). Der Nachrichtenaustausch ist dabei nicht Teilnehmerbezogen sondern Nachrichtenbezogen. Das bedeutet, dass jede Nachricht mit einem priorisierten Identifier eindeutig gekennzeichnet ist. Damit beim Verschicken der Nachrichten verschiedener Teilnehmer keine Kollisionen auf dem Bus entstehen, wird beim Start der Datenübertragung eine bitweise Busarbitrierung durchgeführt. Die Busarbitrierung vergibt die Busbandbreite an die Nachrichten in der Reihenfolge ihrer Priorität, am Ende der Arbitrierungsphase belegt jeweils nur ein Busteilnehmer den Bus, Kollisionen werden vermieden und die Bandbreite wird optimal genutzt.
Konfiguration und Parametrierung
Mit dem TwinCAT System Manager können alle DeviceNet Parameter komfortabel eingestellt werden. Für die Parametrierung der BECKHOFF DeviceNet-Geräte mit Konfigurationstools dritter Hersteller steht Ihnen auf der BECKHOFF Website (http://www.beckhoff.de) ein eds-File (electronic data sheet) zur Verfügung.


Explizite Nachrichten

DeviceNet Kommunikation [image] Explizite Nachrichten
Explizite Nachrichten
Programmbeispiel „ExplMessageEditor“:
Mit den folgenden ADS – Befehlen können über die EL6752 Explizit Messages genutzt werden.
GET_ATTRIBUTE_SINGLE via ADSRead Data Transfer
SET_ATTRIBUTE_SINGLE via ADSWrite Data Transfer
COMMON SERVICE via ADSReadWrite Data Transfer
Für die ADS NetID und den Port sind die Werte aus dem Systemmanager einzusetzen.
(*
GET_ATTRIBUTE_SINGLE via ADSRead Data Transfer

IDXGRP: Index GroupNumber = Object Class
IDXOFFS: Index OffsetNumber = (Object Instance *. 0x100) + Attribute Id
LEN: Read Data Lengths in Bytes
DESTADDR: Address of DataBuffer to read with the Get-Attribute Single Service
*)
fbADSRead(
NETID:= ADSNetId,
PORT:= ADSPort,
IDXGRP:= IGrp_ADSRead,
IDXOFFS:= IOff_ADSRead,
LEN:= ADSReadLen,
DESTADDR:= ADR(GetAttributeData[0]),
READ:= ADSReadCommand,
TMOUT:= T#5s,
BUSY=> ADSReadBusy,
ERR=> ADSReadErr,
ERRID=> ADSReadErrID);
(*
COMMON SERVICE via ADSReadWrite Data Transfer

IDXGRP: Index GroupNumber = Object Class
IDXOFFS: Index OffsetNumber = (Object Instance *. 0x100) + Service Id
WRITELEN: Write Data Lengths in Bytes
READLEN: Read Data Lengths in Bytes
SRCADDR: Address of DataBuffer to write
DESTADDR: Address of DataBuffer to read
*)

fbADSReadWrite(
NETID:= ADSNetId,
PORT:= ADSPort,
IDXGRP:= Grp_ADSReadWrite,
IDXOFFS:= IOff_ADSReadWrite,
WRITELEN:= ADSReadWriteWriteLen,
READLEN:= ADSReadWriteReadLen,
SRCADDR:= ADR(CommonServiceWriteData[0]),
DESTADDR:= ADR(CommonServiceReadData[0]),
WRTRD:= ADSReadWriteCommand,
TMOUT:= T#5s,
BUSY=> ADSReadWriteBusy,
ERR=> ADSReadWriteErr,
ERRID=> ADSReadWriteErrID);
und
(*
SET_ATTRIBUTE_SINGLE via ADSWrite Data Transfer
IDXGRP: Index GroupNumber = Object Class
IDXOFFS: Index OffsetNumber = (Object Instance *. 0x100) + Attribute Id
LEN: Write Data Lengths in Bytes
SRCADDR: Address of DataBuffer to write with the Set-Attribute Single Service
*)
fbADSWrite(
NETID:= ADSNetId,
PORT:= ADSPort,
IDXGRP:= IGrp_ADSWrite,
IDXOFFS:= IOff_ADSWrite,
LEN:= ADSWriteLen,
SRCADDR:= ADR(SetAttributeWriteData[0]),
WRITE:= ADSWriteCommand,
TMOUT:= T#5s,
BUSY=> ADSWriteBusy,
ERR=> ADSWriteErr,
ERRID=> ADSWriteErrID);
ADS NetID und Port aus Systemmanager einsetzen


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
CoE-Interface
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
TwinCAT System Manager
•
Beckhoff DeviceNet Buskoppler
•
Allgemeines DeviceNet Gerät
•
EtherCAT Beschreibung


CoE-Interface

Parametrierung und Inbetriebnahme [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Allgemeine Hinweise zur Watchdog-Einstellung

Parametrierung und Inbetriebnahme [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Parametrierung und Inbetriebnahme [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


TwinCAT System Manager

Parametrierung und Inbetriebnahme [image] TwinCAT System Manager
TwinCAT System Manager
Zur Konfiguration der EL6752 DeviceNet Master-/Slave Klemme dient das TwinCAT System Manager Tool. Der System Manager stellt die Anzahl und Programme der TwinCAT SPS-Systeme, die Konfiguration der Achsregelung und die angeschlossenen E/A-Kanäle als Struktur dar und organisiert das Mapping des Datenverkehrs.
TwinCAT System Manager Logo
Für Applikationen ohne TwinCAT SPS oder NC konfiguriert das TwinCAT System Manager Tool die Programmierschnittstellen für vielfältige Applikationsprogramme:
▪
ActiveX-Control (ADS-OCX) für z. B. Visual Basic, Visual C++, Delphi, etc
▪
DLL-Interface (ADS-DLL) für z. B. Visual C++ Projekte
▪
Script-Interface (ADS-Script DLL) für z. B. VBScript, JScript, etc.
System Manager – Eigenschaften
▪
Verbindung zwischen Server-Prozessabbildern und E/A-Kanälen bitweise
▪
Standard-Datenformate, z. B. Arrays und Strukturen
▪
Benutzerdefinierte Datenformate
▪
Fortlaufende Verbindung von Variablen
▪
Drag und Drop
▪
Import und Export auf allen Ebenen
Konfiguration mit dem TwinCAT System Manager
Im Folgenden werden das Vorgehen und die Konfigurationsmöglichkeiten im System Manager beschrieben:
EL6752 - DeviceNet Master Klemme
EL6752-0010 - DeviceNet Slave Klemme
EL6752 - DeviceNet Master Klemme
Gerät anfügen
Das Anfügen der Klemme in die E/A-Konfiguration kann entweder durch die "Geräte suchen"-Routine im TwinCat System Manager durchgeführt oder durch die manuelle Auswahl des "DeviceNet Master EL6752, EtherCAT" aus den möglichen DeviceNet-Geräten eingefügt werden (Abb. Anfügen des Gerätes „DeviceNet Master EL6752, EtherCAT“). Durch Rechtsklick besteht die Auswahl aus folgendem Kontextmenü:
Anfügen des Gerätes „DeviceNet Master EL6752, EtherCAT“
Karteireiter "EL6752"
Klicken Sie im TwinCAT Baum auf das "Gerät EL6752" und anschließend auf den EL6752-Reiter:
Karteireiter „EL6752“
EtherCAT
Bezeichnung der Klemme im Klemmenverbund.
MAC-ID
Jedes DeviceNet Gerät - einschließlich Master - benötigt eine eindeutige Stationsnummer die MAC-ID (Medium Access Identifier) - Wertebereich: 0...63.
Baudrate
Einstellung der Baudrate: 125 kBaud, 250 kBaud oder 500 kBaud.
Zykluszeit
Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt. Die Anzeige wird aktualisiert sobald das Mapping erzeugt wird.
IO-Cycle time
Einstellung der Zykluszeit für die E/A Verbindungen. Dieser Wert ist der Standardwert für neu eingefügte Boxen.
Watchdog time
Zeit bis zum Triggern des Watchdogs
Suchen...
Hierüber werden alle vorhandenen Kanäle der EL6752 gesucht, und es kann der gewünschte ausgewählt werden.
Konfiguration überprüfen
In Vorbereitung.
Firmware
Hier wird die aktuelle Firmware-Version der EL6752 angezeigt.
Firmware Update...
Hierüber kann die Firmware der EL6752 aktualisiert werden. Achtung: Das TwinCAT System muss hierzu gestoppt sein.
Karteireiter "ADS"
Karteireiter „ADS“
Die EL6752 ist ein ADS-Device mit einer eigenen Net-ID, die hier verändert werden kann. Alle ADS-Dienste (Diagnose, azyklische Kommunikation), die an die EL6752 gehen, müssen die Karte mittels dieser Net-ID adressieren.
Karteireiter "Box States"
Karteireiter „Box States“
Hier wird eine Übersicht aller aktuellen Box-States angezeigt.
EL6752-0010 - DeviceNet Slave Klemme
Zunächst in der Baumstruktur der Systemkonfiguration mittels rechtem Mausklick auf E/A Geräte und "Gerät anfügen" die Auswahlliste der unterstützten Feldbuskarten öffnen.
EL6752-0010 CANopenSlave auswählen. TwinCAT sucht nach der Klemme und zeigt die gefundenen Speicheradressen bzw. Slots an. Entsprechende Adresse auswählen und bestätigen.
Anfügen des Gerätes „DeviceNet Slave EL6752, EtherCAT“
Fügen Sie anschließend durch Rechtsklick bei "Gerät (EL6752-0010)" die Box für die EL6752-0010 ein:
Anfügen der Box „DeviceNet Slave EL6752, EtherCAT“
Bei Anwahl des E/A Gerätes für die EL6752-0010 in der Baumstruktur öffnet sich ein Dialog mit verschiedenen Konfigurationsmöglichkeiten:
Karteireiter "EL6752-0010"
Karteireiter „EL6752-0010“
EtherCAT
Bezeichnung der Klemme im Klemmenverbund.
MAC-ID
Jedes DeviceNet Gerät benötigt eine eindeutige Stationsnummer die MAC-ID (Medium Access Identifier) - Wertebereich: 0...63.
Baudrate
Hier wird die Baudrate eingestellt.
Zyklus-Zeit
Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt. Die Anzeige wird aktualisiert sobald das Mapping erzeugt wird. Die Netzwerkvariablen werden im Takt dieser Task aktualisiert.
Watchdog-Zeit
Zeit, bis der Watchdog triggert
Suchen...
Hierüber werden alle vorhandenen EL6752-0010 Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC5102 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC5101-Karten verhalten.
Firmware
Hier wird die aktuelle Firmware-Version der EL6752-0010 angezeigt.
Firmware Update...
Hierüber kann die Firmware der EL6752-0010 aktualisiert werden. Achtung: Das TwinCAT System muss hierzu gestoppt sein.
Karteireiter "ADS"
Karteireiter „ADS“
Die EL6752-0010 ist ein ADS-Device mit einer eigenen Net-ID, die hier verändert werden kann. Alle ADS-Dienste (Diagnose, azyklische Kommunikation), die an die EL6752-0010 gehen, müssen die Karte mittels dieser Net-ID adressieren. Zusätzliche ADS Net-IDs können eingetragen werden, um unterlagerte ADS Geräte (z. B. eine weitere Feldbus-Karte im gleichen PC) über die Karte anzusprechen.
Karteireiter "DPRAM (Online)"
Zu Diagnosezwecken kann lesend direkt auf das DPRAM der Karte zugegriffen werden.
Box EL6752-0010 Slave
Es wird automatisch eine Box "EL6752-0010 (DeviceNet Slave)" angelegt. Hier sind weitere Parameter einzustellen:
Karteireiter Box EL6752-0010:
Karteireiter "Allgemein", Box EL6752-0010
DeviceNet IO-Betriebsarten
Die EL6752-0010 unterstützt die DeviceNet-Betriebsarten zyklisches Polling, Change of State / Cyclic und Bit-Strobe. Die IO-Betriebsarten können entsprechend den DeviceNet-Spezifikation selektiert werden.
Die DeviceNet IO-Betriebsart zyklisches Polling wird per Default für die EL6752-0010 selektiert:
IO-Betriebsart | Eingangsdatenlänge / Byte | Ausgangsdatenlänge / Byte
Polling | 0 - 255 | 0 - 255
Change of State | 0 - 255 | 0 - 255
Cyclic | 0 - 255 | 0 - 255
Bit-Srobe | 1 Bit | 0-8
Polling / Change of State (COS) / Cyclic
Die Betriebsart zyklisches Polling ist charakterisiert durch ein zyklisches Abfragen bzw. Pollen der IO-Daten durch den Master. Die Betriebsart Change of State ist charakterisiert durch das ereignisorientierte Versenden der IO-Daten. In der Betriebsart Cyclic werden die IO-Daten zyklisch nach den durch den Master konfigurierten Kommunikationsparametern versendet. Da die Kommunikationseinstellungen durch den Master vorgegeben werden sind hier keine weiteren Einstellungen mehr möglich. Mehr Informationen zu den Betriebsarten sind dem Kapitel DeviceNet Kommunikation zu entnehmen. Die Einstellungen sind für die genannten Betriebsarten identisch.
Die Eingangs- und Ausgangsdatenlängen sind mit je 8 Byte vorinitialisiert:
Vorinitialisierte Ein- und Ausgangsdatenlängen bei Betriebsart Polling
Nach Bedarf und Applikation können weitere Eingangs- bzw. Ausgangsdaten durch Rechtsklick (Abb. Einfügen von weiteren Variablen) angefügt werden. Hierbei können beliebige Datentypen ausgewählt werden:
Einfügen von weiteren Variablen
Die Datenlänge wird entsprechend der DeviceNet Spezifikation in ein Byte-Stream umgerechnet und auf dem Karteireiter der entsprechenden Verbindung zur Anzeige gebracht:
Karteireiter „Verbindung“ mit Anzeige der Verbindungsart „Polling“ und der Ein- und Ausgangsgrößen
Maximale Ausgangs-Datenlänge
Die maximale Datenlänge darf 255 Bytes pro Datenrichtung betragen.
Die angezeigten Eingangs- und Ausgangsdatenlängen müssen beim zugehörigen DeviceNet-Master entsprechend konfiguriert werden.
Bit Strobe
Die IO-Betriebsart Bit-Strobe beinhaltet ein 8-Byte Kommando des Master an die Slaves. Für jeden mögliche Adresse/MAC-ID (DeviceNet Adressraum: 64) ist entsprechend 1 Bit Nutzdaten reserviert. Die Antwort-Nachricht des Slaves darf maximal 8 Byte lang sein und wird unmittelbar nach Erhalt des Bit-Strobe Kommandos an den Master gesendet.
Anzeige der Ausgangsgrößen in Verbindungsart „Bit Strobe“ im TwinCAT-Baum
Maximale Ausgangs-Datenlänge
Die maximale Ausgangs-Datenlänge darf 8 Bytes betragen. Die Eingangsdatenlänge ist fest vorgegeben.
Da die Kommunikationseinstellungen durch den Master vorgegeben werden sind hier keine weiteren Einstellungen mehr möglich.


Beckhoff DeviceNet Buskoppler

Parametrierung und Inbetriebnahme [image] Beckhoff DeviceNet Buskoppler
Beckhoff DeviceNet Buskoppler
Der Buskoppler BK52xx sowie die FeldbusBox IPxxx-B520 werden im DeviceNet Bus eingesetzt. Nachfolgend werden die spezifischen Eigenschaften beschrieben, die sich von anderen Buskopplern bzw. Feldbus Box Modulen unterscheiden.
Typen | Beschreibung
BK5210 | Economy Buskoppler
BK5220 | Economy + Buskoppler
LC5200 | Low-Cost Buskoppler
BK5250 | Kompakt Buskoppler
BC5250 | Kompakt Busklemmen Controller mit 48 kByte Programmspeicher
BX5200 | BX Busklemmen Controller mit 256 kByte Programmspeicher
IPxxxx-B520 | Feldbus Kompakt Box: DeviveNet Ein-/Ausgabebaugruppe in Schutzart IP67
Die Parametrierung findet mit folgenden Karteireitern statt:
• Karteireiter "BK52x0"
• Karteireiter "Startup-Attributes"
• Karteireiter "ADS"
• Karteireiter "Parameter"
• Karteireiter "Diag"
Karteireiter "BK52x0"
Karteireiter „BK52x0“
MAC-ID
Stellt die MAC-ID, d.h. die Geräteadresse des DeviceNet Teilnehmers ein (zwischen 0 und 63). Dieser Wert muss mit dem am Buskoppler bzw. an der Kompakt Box eingestellten Wert übereinstimmen.
Cycle-Time
Stellt die Zyklus-Zeit der IO-Verbindung Polling und Bit-Strobe ein. Der Wert wird gemäß DeviceNet Spezifikation als "Expected Packet Rate" Attribute des "Connection Objects" verwendet.
Electronic Key
Dient der Überprüfung der sich im Netz befindlichen Geräte beim Systemstart. Der Electronic Key wird bei jedem Systemstart aus den Geräten ausgelesen und mit der gespeicherten Konfiguration verglichen.
Polled
Produced/Consumed
Aktivierung der Betriebsart "Polling", zyklisches Schreiben und Lesen von IO-Daten. Einstellung des Dateninhaltes der über die Polled IO Verbindung übertragenen Daten. Zur Auswahl stehen digitale Daten, analoge Daten oder beides. Die Auswahl hängt hierbei von den am BK52xx angeordneten Klemmen ab.
Bit-Strobed
Produced/Consumed
Aktivierung der Betriebsart "Bit-Strobe". Mit einer Broadcast Message werden alle Knoten aufgefordert, ihre Bit-Strobe Message (bis 7 Bytes Eingangs- oder Statusdaten) zu senden. Einstellung des Dateninhaltes der über die Bit-Strobed IO Verbindung übertragenen Daten. Zur Auswahl stehen hierbei digitale Daten oder Diagnosedaten.
Change of State / Cyclic
Produced/Consumed
Einstellung des Dateninhaltes der über die Change of Sate / Cyclic IO Verbindung übertragenen Daten. Zur Auswahl stehen digitale Daten, analoge Daten oder beides. Die Auswahl hängt hierbei von den am BK52xx angeordneten Klemmen ab.
Change of State / Cyclic
Auswahl der entsprechenden Betriebsart.
Heartbeat-Rate / Send-Rate
Die Heartbeat Rate gibt bei der Betriebsart "Change of State" die Cycle-Time an mit der IO-Daten untergelagert, d.h. zusätzlich zum ereignisgesteuerten senden, zyklisch gesendet werden. Die Send-Rate gibt bei der Betriebsart "Cyclic" die Cycle-Time an mit der IO-Daten gesendet werden.
Inhibit-Time
Verzögerungszeit bei der Betriebsart "Change of State", IO-Daten werden nach einem Zustandswechsel frühestens nach der hier eingestellten Zeit gesendet.
Acknowledge Timeout
Zeitspanne bis zur Sendewiederholung bei fehlendem Acknowledge auf eine Change of State / Cyclic Nachricht.
Acknowldege Retry Limit
Maximale Anzahl Sendewiederholungen bis IO-Verbindung in Fehlerzustand übergeht.
K-Bus Update
Berechnet die voraussichtliche Dauer für ein vollständiges Update des Klemmenbusses (ist abhängig von den angeschlossenen Klemmen).
Auto Device Replacement (ADR)
Nicht unterstützt.
Karteireiter "Startup-Attribute"
Karteireiter „Startup-Attribute“
Die Startup-Attribute werden vor dem zyklischen Datenaustausch zum Slave gesendet. Die Nachrichten werden vor dem eigentlichen IO-Datenverkehr gesendet.
Die Konfiguration erfolgt über den "Neu" oder "Bearbeiten" Button:
Attribut Eintrag editieren
Die Attribute werden mit dem Class/Instance/Attribute initialisiert. Zu beachten ist hierbei die "Wert" - Angabe in hexadezimaler Form.
Karteireiter "ADS"
Karteireiter „ADS“
Um DeviceNet Objekte auch zur Laufzeit Schreiben und Lesen zu können (z. B. aus der SPS heraus), wird dem Knoten (Buskoppler) ein ADS-Port zugewiesen. Dieser kann bei Bedarf verändert werden. Eine detaillierte Beschreibung zur Ausführung von Expliziten Nachrichten ist im Kapitel "DeviceNet Kommunikation" unter "Explizite Nachrichten" beschrieben.
Über den Online Access kann auf DeviceNet Objekte zugegriffen werden. Hierzu sind die DeviceNet-spezifischen Angaben wie Class/Instance/Attribute einzugeben.
Read
Lesen eines Objekt-Attributes via DeviceNet "Get_Attribute_Single" Service. Eine Dienstkennung braucht hierbei nicht angegeben werden.
Write
Schreiben eines Objekt-Attributes via DeviceNet "Set_Attribute_Single" Service. Eine Dienstkennung braucht hierbei nicht angegeben werden.
Read/Write
Ausführen eines beliebigen DeviveNet Dienstes. Hierzu ist die Angabe der "Service-Id" erforderlich.
Karteireiter "Parameter"
Karteireiter „Parameter“
Unter dem Karteireiter "Parameter" werden die aus der EDS-Datei ausgelesenen Parameter angezeigt. Hierbei besteht die Möglichkeit diese zu Lesen, zu Schreiben und in die Liste der Startup-Parameter zu übernehmen.
Karteireiter "Diag"
Karteireiter „Diag“
Der Karteireiter "Diag" gibt den Zustand der Box wieder. Eine weitere Diagnose ist nicht verfügbar.


Allgemeines DeviceNet Gerät

Parametrierung und Inbetriebnahme [image] Allgemeines DeviceNet Gerät
Allgemeines DeviceNet Gerät
DeviceNet Teilnehmer werden als allgemeine DeviceNet Geräte eingebunden.
Einfügen eines DeviceNet Gerätes (E/A-Geräte -> Gerät n (EL6752) -> Rechte Maustaste -> Box anfügen…)
Weiterführende Informationen
•
Einbinden eines DeviceNet Gerätes mit EDS-File
•
Einbinden eines DeviceNet Gerätes ohne EDS-File
•
Parametrierung eines DeviceNet Gerätes


Einbinden eines DeviceNet Gerätes mit EDS-File

Parametrierung und Inbetriebnahme [image] Allgemeines DeviceNet Gerät [image] Einbinden eines DeviceNet Gerätes mit EDS-File
Einbinden eines DeviceNet Gerätes mit EDS-File
Steht ein EDS-File für das einzubindende DeviceNet Gerät zur Verfügung muss dieses in das ..TwinCAT/IO/DeviceNet Verzeichnis kopiert werden.
Im Anschluss erscheint das Gerät unter der Auswahl "Box Anfügen" s. Abb. Einfügen eines DeviceNet Gerätes (E/A-Geräte -> Gerät n (EL6752) -> Rechte Maustaste -> Box anfügen…), mit der Kennung der Herstellernamens:
Einfügen der Box mit der Kennung des Herstellernamens
Alternativ kann unter der Auswahl "Verschiedenes" ein DeviceNet Gerät mit EDS-File eingebunden werden:
Einfügen der Box ohne EDS-File
Je nach Angaben im EDS-File erscheint ein DeviceNet Knoten mit/ohne Karteireiter Parameter.
Die IO-Betriebsart und die zugehörigen Datenlängen werden durch das EDS-File vorgegeben.


Einbinden eines DeviceNet Gerätes ohne EDS-File

Parametrierung und Inbetriebnahme [image] Allgemeines DeviceNet Gerät [image] Einbinden eines DeviceNet Gerätes ohne EDS-File
Einbinden eines DeviceNet Gerätes ohne EDS-File
Unter der Auswahl "Verschiedenes" ist es möglich ein DeviceNet Gerät ohne EDS-File einzubinden:
Einfügen der Box ohne EDS-File („Abbrechen“ klicken)
Die Auswahl des EDS-Files muss mit "Abbrechen" beendet werden. Es wird ein allgemeines DeviceNet Gerät angelegt.
Die Auswahl der IO-Betriebsart sowie der allgemeinen Konfiguration muss dann manuell vorgenommen werden.
DeviceNet IO-Betriebsarten
Die EL6752 unterstützt für DeviceNet Geräte die DeviceNet-Betriebsarten zyklisches Polling, Change of State / Cyclic und Bit-Strobe. Die IO-Betriebsarten können entsprechend den DeviceNet-Spezifikation selektiert werden.
Die DeviceNet IO-Betriebsart zyklisches Polling wird per Default für die EL6752 selektiert:
IO-Betriebsart | Eingangsdatenlänge / Byte | Ausgangsdatenlänge / Byte
Polling | 0 - 255 | 0 - 255
Change of State | 0 - 255 | 0 - 255
Cyclic | 0 - 255 | 0 - 255
Bit-Srobe | 1 Bit | 0-8
Summe alle EA-Daten | max. xxx Byte | max. xxx Byte
Polling / Change of State (COS) / Cyclic
Die Betriebsart zyklisches Polling ist charakterisiert durch ein zyklisches Abfragen bzw. Pollen der IO-Daten durch den Master. Die Betriebsart Change of State ist charakterisiert durch das ereignisorientierte Versenden der IO-Daten. In der Betriebsart Cyclic werden die IO-Daten zyklisch nach den durch den Master konfigurierten Kommunikationsparametern versendet. Die Einstellungen sind für die genannten Betriebsarten identisch.
Die Eingangs- und Ausgangsdatenlängen muss entsprechend der Gerätekonfiguration ergänzt werden:
Ergänzung der Ein- und Ausgangsdaten
Je nach Gerätekonfiguration müssen Eingangs- bzw. Ausgangsdaten angefügt werden. Hierbei können beliebige Datentypen ausgewählt werden:
Einfügen von Variablen
Die Datenlänge wird entsprechend der DeviceNet Spezifikation in ein Byte-Stream umgerechnet und auf dem Karteireiter der entsprechenden Verbindung zur Anzeige gebracht:
Karteireiter „Verbindung“ mit Anzeige der Verbindungsart „Polling“ und der Ein- und Ausgangsgrößen
Maximale Datenlänge
Die maximale Datenlänge darf 255 Bytes pro Datenrichtung betragen.
Bit Strobe
Die IO-Betriebsart Bit-Strobe beinhaltet ein 8-Byte Kommando des Master an die Slaves. Für jeden mögliche Adresse/Mac-Id (DeviceNet Adressraum: 64) ist entsprechend 1 Bit Nutzdaten reserviert. Die Antwort-Nachricht des Slaves darf maximal 8 Byte lang sein und wird unmittelbar nach Erhalt des Bit-Strobe Kommandos an den Master gesendet.
Nach Auswahl der Bit-Strobe Betriebsart sind die Eingangsdaten entsprechend zu konfigurieren. Hierbei können beliebige Datentypen ausgewählt werden (siehe Polling/ COS / Cyclic). Die Datenlänge wird entsprechend der DeviceNet Spezifikation in ein Byte-Stream umgerechnet und auf dem Karteireiter der Bit-Strobe Verbindung zur Anzeige gebracht:
Karteireiter „Verbindung“ mit Anzeige der Verbindungsart „Bit Strobe“ und der Ein- und Ausgangsgrößen
Maximale Datenlänge
Die maximale Eingangs-Datenlänge darf 8 Bytes betragen. Die Ausgangsdatenlänge ist fest vorgegeben.
Da die Kommunikationseinstellungen durch den Master vorgegeben werden sind hier keine weiteren Einstellungen mehr möglich.


Parametrierung eines DeviceNet Gerätes

Parametrierung und Inbetriebnahme [image] Allgemeines DeviceNet Gerät [image] Parametrierung eines DeviceNet Gerätes
Parametrierung eines DeviceNet Gerätes
Die Parametrierung der DeviceNet Geräte findet mit folgenden Karteireitern statt:
▪
Karteireiter "DeviceNet Node"
▪
Karteireiter "Startup-Attributes"
▪
Karteireiter "ADS"
▪
Karteireiter "Parameter"
▪
Karteireiter "Diag"
Karteireiter "DeviceNet Node"
Karteireiter „DeviceNet Node“
MAC-ID
Stellt die MAC-ID, d.h. die Geräteadresse des DeviceNet Teilnehmers ein (zwischen 0 und 63). Dieser Wert muss mit dem am Buskoppler bzw. an der Kompakt Box eingestellten Wert übereinstimmen.
Cycle-Time
Stellt die Zyklus-Zeit der IO-Verbindung Polling und Bit-Strobe ein. Der Wert wird gemäß DeviceNet Spezifikation als "Expected Packet Rate" Attribute der "Connection Objects" verwendet.
Electronic Key
Dient der Überprüfung der sich im Netz befindlichen Geräte beim Systemstart. Der Electronic Key wird bei jedem Systemstart aus den Geräten ausgelesen und mit der gespeicherten Konfiguration verglichen.
Polled
Produced/Consumed
Aktivierung der Betriebsart "Polling", zyklisches Schreiben und Lesen von IO-Daten. Einstellung des Dateninhaltes der über die Polled IO Verbindung übertragenen Daten. Zur Auswahl stehen digitale Daten, analoge Daten oder beides. Die Auswahl hängt hierbei von den am BK52xx angeordneten Klemmen ab.
Bit-Strobed
Produced/Consumed
Aktivierung der Betriebsart "Bit-Strobe". Mit einer Broadcast Message werden alle Knoten aufgefordert, ihre Bit-Strobe Message (bis 7 Bytes Eingangs- oder Statusdaten) zu senden. Einstellung des Dateninhaltes der über die Bit-Strobed IO Verbindung übertragenen Daten. Zur Auswahl stehen hierbei digitale Daten oder Diagnosedaten.
Change of State / Cyclic
Produced/Consumed
Einstellung des Dateninhaltes der über die Change of Sate / Cyclic IO Verbindung übertragenen Daten. Zur Auswahl stehen digitale Daten, analoge Daten oder beides. Die Auswahl hängt hierbei von den am BK52xx angeordneten Klemmen ab.
Change of State / Cyclic
Auswahl der entsprechenden Betriebsart.
Heartbeat-Rate / Send-Rate
Die Heartbeat Rate gibt bei der Betriebsart "Change of State" die Cycle-Time an mit der IO-Daten untergelagert, d.h. zusätzlich zum ereignisgesteuerten senden, zyklisch gesendet werden. Die Send-Rate gibt bei der Betriebsart "Cyclic" die Cycle-Time an mit der IO-Daten gesendet werden.
Inhibit-Time
Verzögerungszeit bei der Betriebsart "Change of State", IO-Daten werden nach einem Zustandswechsel frühestens nach der hier eingestellten Zeit gesendet.
Acknowledge Timeout
Zeitspanne bis zur Sendewiederholung bei fehlendem Acknowledge auf eine Change of State / Cyclic Nachricht.
Acknowldege Retry Limit
Maximale Anzahl Sendewiederholungen bis IO-Verbindung in Fehlerzustand übergeht.
K-Bus Update
Berechnet die voraussichtliche Dauer für ein vollständiges Update des Klemmenbusses (ist abhängig von den angeschlossenen Klemmen).
Auto Device Replacement (ADR)
Nicht unterstützt.
Karteireiter "Startup-Attribute"
Karteireiter „Startup-Attribute“
Die Startup-Attribute werden vor dem zyklischen Datenaustausch zum Slave gesendet. Die Nachrichten werden vor dem eigentlichen IO-Datenverkehr gesendet.
Die Konfiguration erfolgt über den "Neu" oder "Bearbeiten" Button:
Attribut Eintrag editieren
Die Attribute werden mit dem Class/Instance/Attribute initialisiert. Zu beachten ist hierbei die "Wert" - Angabe in hexadezimaler Form.
Karteireiter "ADS
Karteireiter „ADS“
Um DeviceNet Objekte auch zur Laufzeit Schreiben und Lesen zu können (z. B. aus der SPS heraus), wird dem Knoten (Buskoppler) ein ADS-Port zugewiesen. Dieser kann bei Bedarf verändert werden. Eine detaillierte Beschreibung zur Ausführung von Expliziten Nachrichten ist im Kapitel "DeviceNet Kommunikation" unter "Explizite Nachrichten" beschrieben.
Über den Online Access kann auf DeviceNet Objekte zugegriffen werden. Hierzu sind die DeviceNet-spezifischen Angaben wie Class/Instance/Attribute einzugeben.
Read
Lesen eines Objekt-Attributes via DeviceNet "Get_Attribute_Single" Service. Eine Dienstkennung braucht hierbei nicht angegeben werden.
Write
Schreiben eines Objekt-Attributes via DeviceNet "Set_Attribute_Single" Service. Eine Dienstkennung braucht hierbei nicht angegeben werden.
Read/Write
Ausführen eines beliebigen DeviveNet Dienstes. Hierzu ist die Angabe der "Service-Id" erforderlich.
Karteireiter "Parameter"
Karteireiter „Parameter“
Unter dem Karteireiter "Parameter" werden die aus der EDS-Datei ausgelesenen Parameter angezeigt. Hierbei besteht die Möglichkeit diese zu Lesen, zu Schreiben und in die Liste der Startup-Parameter zu übernehmen.
Karteireiter "Diag"
Karteireiter „Diag“
Der Karteireiter "Diag" gibt den Zustand der Box wieder. Eine weitere Diagnose ist nicht verfügbar.


EtherCAT Beschreibung

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung
EtherCAT Beschreibung
Weiterführende Informationen
•
Einführung
•
Objektbeschreibung und Parametrierung


Einführung

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Einführung
Einführung
Die verschiedenen DeviceNet Funktionalitäten sowie Konfigurationsmöglichkeiten sind in Abhängigkeit der unterschiedlichen EtherCAT Zustände veränderbar bzw. parametrierbar.
EtherCAT Zustände
Die EtherCAT Zustände (INIT, PREOP, SAFEOP, OP) haben entsprechend den feldbusspezifischen Funktionen folgende Bedeutung:
EtherCAT Zustand | Bedeutung
INIT | Feldbus läuft nicht
PREOP | Feldbuskonfiguration laden
SAFEOP | Feldbus zyklischer Betrieb, sicherer Zustand. Eingänge werden gelesen, Ausgänge werden nicht geschrieben
OP | Feldbus zyklischer Betrieb. Eingänge werden gelesen, Ausgänge werden geschrieben
Im Folgenden werden das Vorgehen und die Konfigurationsmöglichkeiten beschrieben
Weiterführende Informationen
•
EL6752 - DeviceNet Master Konfiguration
•
EL6752-0010 - DeviceNet Slave Konfiguration
•
EL6752-0010 - DeviceNet Adresse und Baudrate über ADS ändern


EL6752 - DeviceNet Master Konfiguration

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Einführung [image] EL6752 - DeviceNet Master Konfiguration
EL6752 - DeviceNet Master Konfiguration
Die Konfiguration des DeviceNet Masters sowie der zugehörigen DeviceNet Slaves wird im EtherCAT-Zustand PREOP durchgeführt. Die DeviceNet Master Parameter werden über das EtherCAT Objekt 0xF800 geschrieben, die Slave Parameter werden über die EtherCAT Objekte ab 0x80n0 geschrieben, siehe Kapitel EtherCAT Objekt Beschreibung.
Die EtherCAT Zustände werden wie folgt auf DeviceNet abgebildet:
EtherCAT Stati in Abbildung auf EL6752-0000
Das EtherCAT PDO-Mapping (EtherCAT Objekte 0x16yy, 0x1Ayy) sowie das PDO-Assignment (EtherCAT Objekte 0x1C12, 0x1C13) kann nach dem Schreiben der DeviceNet Master Parameter und dem Schreiben der DeviceNet Slave Parameter gelesen werden. Im Anschluss daran wird entsprechend das Prozessabbild generiert.
Nach dem die DeviceNet Master Parameter über das EtherCAT Objekt 0xF800 geschrieben worden sind, meldet sich der DeviceNet Master am Netzwerk an und führt den Duplicate MAC-ID Check durch.
Starten des Feldbusses
Beim EtherCAT Zustandsübergang von PREOP nach SAFEOP startet der DeviceNet Master die Datenkommunikation mit den Slaves und allokiert die konfigurierten Betriebsarten. Im EtherCAT Zustand SAFEOP befindet sich der DeviceNet Master im IDLE Mode. Beim EtherCAT Zustandsübergang von SAFEOP nach OP schaltet der DeviceNet Master in den RUN Mode.
Laden einer neuen Konfiguration
Eine neue DeviceNet Konfiguration kann nur durch einen EtherCAT Zustandsübergang nach IDLE oder PREOP geladen werden. Im Anschluss müssen wieder die DeviceNet Master Parameter und die DeviceNet Slave Parameter geschrieben werden.


EL6752-0010 - DeviceNet Slave Konfiguration

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Einführung [image] EL6752-0010 - DeviceNet Slave Konfiguration
EL6752-0010 - DeviceNet Slave Konfiguration
Die Konfiguration des DeviceNet Slaves wird im EtherCAT-Zustand PREOP durchgeführt. Die allgemeinen DeviceNet Slave Parameter werden über das EtherCAT Objekt 0xF800 geschrieben, die Slave Konfigurationsdaten, d.h. die Kommunikationseigenschaften und die IO-Konfiguration wird über das EtherCAT Objekt 0x8000 geschrieben, siehe Kapitel EtherCAT Objekt Beschreibung.
Die EtherCAT Zustände werden wie folgt auf DeviceNet abgebildet:
EtherCAT Stati in Abbildung auf EL6752-0010
Das EtherCAT PDO-Mapping (EtherCAT Objekte 0x1600, 0x1A00, 0x1A80) sowie das PDO-Assignment (EtherCAT Objekte 0x1C12, 0x1C13) kann nach dem Schreiben der DeviceNet Slave Parameter und dem Schreiben der DeviceNet Slave Konfigurationsdaten gelesen werden. Im Anschluss daran wird entsprechend das Prozessabbild generiert.
Nach dem die DeviceNet Slave Parameter über das EtherCAT Objekt 0xF800 geschrieben worden sind meldet sich der DeviceNet Slave am Netzwerk an und führt den Duplicate MAC-ID Check durch.
Starten des Feldbusses
Beim EtherCAT Zustandsübergang von PREOP nach SAFEOP startet der DeviceNet Slave die Datenkommunikation, d.h. er ist nun bereit zur Kommunikation mit einem DeviceNet Master. Im EtherCAT Zustand SAFEOP befindet sich der DeviceNet Slave im IDLE Mode. Beim EtherCAT Zustandsübergang von SAFEOP nach OP schaltet der DeviceNet Slave in den RUN Mode.
Laden einer neuen Konfiguration
Eine neue DeviceNet Konfiguration kann nur durch einen EtherCAT Zustandsübergang nach IDLE oder PREOP geladen werden. Im Anschluss müssen wieder die DeviceNet Slave Parameter und die DeviceNet Slave Konfigurationsdaten geschrieben werden.


EL6752-0010 - DeviceNet Adresse und Baudrate über ADS ändern

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Einführung [image] EL6752-0010 - DeviceNet Adresse und Baudrate über ADS ändern
EL6752-0010 - DeviceNet Adresse und Baudrate über ADS ändern
Die DeviceNet Adresse (MACId) und die Baudrate der DeviceNet Slave Klemme EL6752-0010 kann neben den bekannten Funktionen wie sie bereits im Kapitel "Konfiguration mit dem TwinCAT System Manager" beschrieben sind auch über ein ADS-Kommando gesetzt werden
ADS-Kommando
Setzen der MAC-ID und der Baudrate über ADS
IDXGRP=0x1F480
Index Offset 0x00

LEN=6

DATA[0]=0x45
DATA[1]=0x23
DATA[2]=MACId (0 _ 63)
DATA[3]=0
DATA[4]=Baudrate (1=500k, 2=250k, 3=125k)
DATA[5]=0

Ams Net Id: die der EL6752
Ams Port: 200
Nach dem Schreiben des Kommandos muss die Klemme einmal in INIT und zurück in OP geschaltet werden. Die gesetzten Daten können im Objekt 0xF800 Index 1 (MAC ID) und Index 2 (Baudrate) gelesen werden.
Kommando am Beispiel des TwinCAT AMS ADS Viewer
ADS Kommando mit den Daten 3C - MACId (60dez) und 01 - Baudrate (500k)
Rücksetzen
Werden die MAC ID und die Baudrate einmal über den ADS Befehl gesetzt, speichert die Klemme die Informationen persistent ab. Sind diese Daten einmal geschrieben worden, werden die Einträge der Objekte 0x8000:01, 0xF800:01 und 0xF800:02 nicht beachtet. ! Dies betrifft die Startup Commands, welche dann von der Klemme ignoriert werden.
Beispiel von Startup CMD, welche bei erfolgreich über ADS gesetzter MACId und Baudrate von der Slave-Klemme ignoriert werden (0x8000:01; 0xF800:01 und 0xF800:02)
ADS Kommando (Rücksetzen)
IDXGRP=0x1F480
Index Offset 0x00

LEN=6

DATA[0]=0
DATA[1]=0
DATA[2]=0
DATA[3]=0
DATA[4]=0
DATA[5]=0

Ams Net Id: die der EL6752
Ams Port: 200
So können die Daten wieder dauerhaft gelöscht werden und die Klemme verhält sich wie im Auslieferungszustand.
Rücksetz - Kommando am Beispiel des TwinCAT AMS ADS Viewer
Rücksetzen der persistenten Daten für MAC ID und Baudrate


Objektbeschreibung und Parametrierung

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
Weiterführende Informationen
•
DeviceNet Master - EL6752
•
DeviceNet Slave - EL6752-0010


DeviceNet Master - EL6752

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Master - EL6752
DeviceNet Master - EL6752
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff-Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE-Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
"CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte, die zu Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte, die interne Settings anzeigen und ggf. nicht veränderlich sind.
Im Folgenden werden zuerst die zur Parametrierung und zum normalen Betrieb benötigten Objekte vorgestellt. Alle weiteren Objekte, die für den normalen Anwendungsfall nicht erforderlich sind, sind im unteren Tabellenabschnitt zu finden.
Weiterführende Informationen
•
Objekte für die Parametrierung
•
Objekte für interne Settings


Objekte für die Parametrierung

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Master - EL6752 [image] Objekte für die Parametrierung
Objekte für die Parametrierung
Index 8000-803E Configuration Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000+n*16:0 | Configuration Data | (for each module one object is defined (0 ≤ n < maximum number of modules)) | UINT8 | RW | 0x33 (51dez)
(8000+n*16):01 | MAC ID | DeviceNet Geräte Adresse (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):03 | ProductName | Produktname | OCTET-STRING[32] | RW | {0}
(8000+n*16):04 | Device Type | Gerätetyp (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):05 | Vendor ID | Herstellerkennung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):06 | Product Code | Produktkennung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):07 | Revision Number | Versionsnummer (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):08 | Serial Number | Seriennummer (siehe DeviceNet-Spezifikation) | UINT32 | RW | 0x00000000 (0dez)
(8000+n*16):1D | Network Flags | reserviert für AMS über DeviceNet | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):1E | Network Port | reserviert für AMS über DeviceNet | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):1F | Network Segment Address | reserviert für AMS über DeviceNet | OCTET-STRING[6] | RW | {0}
(8000+n*16):20 | Allocation Choice | DeviceNet Betriebsarten-Auswahl (siehe DeviceNet-Spezifikation) Bit 0: reserved (0) Bit1: Polled Bit2: Bit-Strobed Bit3: reserved (0) Bit4: Change of State Bit5: Cyclic Bit6: Acknowledge Suppression Bit7: reserved(0) | UINT16 | RW | 0x0100 (256dez)
(8000+n*16):21 | Expected Packet Rate - Poll | Timing-Parameter der Poll-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):22 | Expected Packet Rate - Bit Strobe | Timing-Parameter der Bit-Strobe-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):23 | Expected Packet Rate - COS/Cyclic | Timing-Parameter der COS/Cyclic-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):24 | Produced Data Size - Poll | Datenlänge im Poll-Modus | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):25 | Produced Data Size - Bit Strobe | Datenlänge im Bit-Strobe-Modus | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):26 | Produced Data Size - COS/Cyclic | Datenlänge im Change of State / Cyclic Modus | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):27 | Consumed Data Size - Poll | Datenlänge im Poll-Modus | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):28 | Condumed Data Size - Bit Strobe | Datenlänge im Bit-Strobe-Modus | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):29 | Consumed Data Size - COS/Cyclic | Datenlänge im Change of State / Cyclic Modus | UINT16 | RW | 0x0000 (0dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
(8000+n*16):2A | Electronic Key | Electronic Key Bit-Maske: Bit 0: Check Vendor Id Bit 1: Check DeviceType Bit 2: Check Product Code Bit 3: Check Revision Bit 4: reserved(0) Bit 5: reserved(0) Bit 6: reserved(0) Bit 7: reserved(0) | UINT16 | RW | 0x0100 (256dez)
(8000+n*16):2B | Acknowledge Timer | Timing-Parameter der COS/Cyclic-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):2C | Acknowledge Retry Limit | Timing-Parameter der COS/Cyclic-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0100 (256dez)
(8000+n*16):2D | Inhibit Time | Timing-Parameter der COS/Cyclic-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):2E | Produced Datentyp - Poll | reserved | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):2F | Produced Datentyp - Bit Strobe | reserved | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):30 | Produced Datentyp - COS/Cyclic | reserved | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):31 | Consumed Datentyp - Poll | reserved | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):32 | Consumed Datentyp - Bit Strobe | reserved | UINT16 | RW | 0x0000 (0dez)
(8000+n*16):33 | Consumed Datentyp - COS/Cyclic | reserved | UINT16 | RW | 0x0000 (0dez)


Objekte für interne Settings

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Master - EL6752 [image] Objekte für interne Settings
Objekte für interne Settings
Weiterführende Informationen
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Standardobjekte (0x1000-0x1FFF)

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Master - EL6752 [image] Objekte für interne Settings [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x14501389 (340792201dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL6752
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1A603052 (442511442dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 1A85 DNM TxPDO-Map Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A85:0 | DNM TxPDO-Map Device | PDO Mapping TxPDO 134 | UINT8 | RW | 0x09 (9dez)
1A85:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF100 (DeviceNet status), entry 0x01 (Communication status)) | UINT32 | RW | 0xF100:01, 8
1A85:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A85:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF100 (DeviceNet status), entry 0x10 (TxPdoState)) | UINT32 | RW | 0xF100:10, 1
1A85:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF101 (Network status), entry 0x01 (Device status)) | UINT32 | RW | 0xF101:01, 8
1A85:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF101 (Network status), entry 0x09 (CAN BUS-OFF)) | UINT32 | RW | 0xF101:09, 1
1A85:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF101 (Network status), entry 0x0A (CAN warning limit)) | UINT32 | RW | 0xF101:0A, 1
1A85:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF101 (Network status), entry 0x0B (CAN Overrun)) | UINT32 | RW | 0xF101:0B, 1
1A85:08 | SubIndex 008 | 8. PDO Mapping entry (5 bits align) | UINT32 | RW | 0x0000:00, 5
1A85:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF101 (Network status), entry 0x11 (CAN BUS load)) | UINT32 | RW | 0xF101:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
1C12:01 |  | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) |  |  |
... |  |  |  |  |
1C12:FF |  | 255. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) |  |  |
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 |  | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) |  |  |
... |  |  |  |  |
1C13:FF |  | 255. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) |  |  |


Profilspezifische Objekte (0x6000-0xFFFF)

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Master - EL6752 [image] Objekte für interne Settings [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000-603E Poll Produced Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000+n*16:0 | Poll Produced Data | Ausgangsdaten der Polling Verbindung | UINT8 | RO | 0x01 (1dez)
(6000+n*16):01 |  |  |  |  |
... |  |  |  |  |
(6000+n*16):01 |  |  |  |  |
Index 6001-603F COS Produced Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6001+n*16:0 | COS Produced Data | Ausgangsdaten der Change of State Verbindung | UINT8 | RO | 0x01 (1dez)
(6001+n*16):01 |  |  |  |  |
... |  |  |  |  |
(6001+n*16):01 |  |  |  |  |
Index 7000-703E Poll Consumed Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000+n*16:0 | Poll Consumed Data | Eingangsdaten der Polling Verbindung | UINT8 | RO | 0x01 (1dez)
(7000+n*16):01 |  |  |  |  |
... |  |  |  |  |
(7000+n*16):01 |  |  |  |  |
Index 7001-703F COS Consumed Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7001+n*16:0 | COS Consumed Data | Eingangsdaten der Change of State Verbindung | UINT8 | RO | 0x01 (1dez)
(7001+n*16):01 |  |  |  |  |
... |  |  |  |  |
(7001+n*16):01 |  |  |  |  |
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x00FF (255dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Liste der an der EL6752 angeschlossenen DeviceNet Slaves. | UINT8 | RW | 0x00 (0dez)
F010:01 |  | Product-Code des ersten DeviceNet-Slaves | UINT16 | RO | 0x00 (0dez)
... |  |  |  |  |
F010:FF |  |  |  |  |
Index F100 DeviceNet status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F100:0 | DeviceNet status | DeviceNet Status der EL6752 | UINT8 | RO | 0x10 (16dez)
F100:01 | Number of Slaves not in Run | Anzahl der DeviceNet Slaves die nicht im RUN-Zustand sind | UINT8 | RO | 0x00 (0dez)
F100:10 | TxPdoState | Status der Tx-PDO | BOOLEAN | RO | 0x00 (0dez)
Index F101 Network status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F101:0 | Network status | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F101:01 | Device status | 0: RUN MODE 1: IDLE MODE 2: Duplicate MacId Check failed, MAC ID used 3: Status: Selftest 4: Status: Standby 5: Status:Major Recoverable Fault 6: Status:Minor Recoverable Fault 7: DeviceNet Voltage Error 8: DeviceNet Access Error | UINT8 | RO | 0x00 (0dez)
F101:09 | CAN BUS-OFF | CAN-Controller der EL6752 ist im Zustand Bus-Off | BOOLEAN | RO | 0x00 (0dez)
F101:0A | CAN warning limit | CAN-Controller der EL6752 hat das Warning Limit überschritten | BOOLEAN | RO | 0x00 (0dez)
F101:0B | CAN Overrun | CAN-Controller der EL6752 ist im Zustand Bus-Off | BOOLEAN | RO | 0x00 (0dez)
F101:11 | CAN BUS load | CAN Busauslastung 0 - 100% | UINT16 | RO | 0x0000 (0dez)
Index F800 Bus Parameter set
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F800:0 | Bus Parameter set | Max. Subindex | UINT8 | RW | 0x08 (8dez)
F800:01 | MAC ID | Geräteadresse des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:03 | Product Name | Produktname des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | OCTET-STRING[32] | RW | {0}
F800:04 | DeviceType | Gerätetyp des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:05 | Vendor ID | Herstellerkennung des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:06 | Product Code | Produktkennung des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:07 | Revision Number | Versionsnummer des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:08 | Serial Number | Seriennummer des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT32 | RW | 0x00350000 (3473408dez)
F800:09 | Baud rate | DeviceNet Baud Rate | UINT16 | RW | 0x0100 (256dez)


DeviceNet Slave - EL6752-0010

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Slave - EL6752-0010
DeviceNet Slave - EL6752-0010
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff-Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE-Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
"CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte, die zu Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte, die interne Settings anzeigen und ggf. nicht veränderlich sind.
Im Folgenden werden zuerst die zur Parametrierung und zum normalen Betrieb benötigten Objekte vorgestellt. Alle weiteren Objekte, die für den normalen Anwendungsfall nicht erforderlich sind, sind im unteren Tabellenabschnitt zu finden.
Weiterführende Informationen
•
Objekte für die Parametrierung
•
Objekte für interne Settings


Objekte für die Parametrierung

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Slave - EL6752-0010 [image] Objekte für die Parametrierung
Objekte für die Parametrierung
Index 8000 Configuration Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | Configuration Data | Max. Subindex | UINT8 | RW | 0x33 (51dez)
8000:01 | MAC ID | DeviceNet Geräte Adresse (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
8000:03 | ProductName | Produktname | OCTET-STRING[32] | RW | {0}
8000:04 | Device Type | Gerätetyp (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
8000:05 | Vendor ID | Herstellerkennung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
8000:06 | Product Code | Produktkennung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
8000:07 | Revision Number | Versionsnummer (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
8000:08 | Serial Number | Seriennummer (siehe DeviceNet-Spezifikation) | UINT32 | RW | 0x00000000 (0dez)
8000:1D | Network Flags | reserviert für AMS über DeviceNet | UINT16 | RW | 0x0000 (0dez)
8000:1E | Network Port | reserviert für AMS über DeviceNet | UINT16 | RW | 0x0000 (0dez)
8000:1F | Network Segment Address | reserviert für AMS über DeviceNet | OCTET-STRING[2] | RW | {0}
8000:20 | Allocation Choice | DeviceNet Betriebsarten-Auswahl (siehe DeviceNet-Spezifikation) Bit 0: reserved (0) Bit 1: Polled Bit 2: Bit-Strobed Bit 3: reserved (0) Bit 4: Change of State Bit 5: Cyclic Bit 6: Acknowledge Suppression Bit 7: reserved(0) | UINT16 | RW | 0x0100 (256dez)
8000:21 | Expected Packet Rate - Poll | Timing-Parameter der Poll-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
8000:22 | Expected Packet Rate - Bit Strobe | Timing-Parameter der Bit-Strobe-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
8000:23 | Expected Packet Rate - COS/Cyclic | Timing-Parameter der COS/Cyclic-Verbindung (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
8000:24 | Produced Data Size - Poll | Datenlänge im Poll-Modus | UINT16 | RW | 0x0000 (0dez)
8000:25 | Produced Data Size - Bit Strobe | Datenlänge im Bit-Strobe-Modus | UINT16 | RW | 0x0000 (0dez)
8000:26 | Produced Data Size - COS/Cyclic | Datenlänge im Change of State / Cyclic Modus | UINT16 | RW | 0x0000 (0dez)
8000:27 | Consumed Data Size - Poll | Datenlänge im Poll-Modus | UINT16 | RW | 0x0000 (0dez)
8000:28 | Condumed Data Size - Bit Strobe | Datenlänge im Bit-Strobe-Modus | UINT16 | RW | 0x0000 (0dez)
8000:29 | Consumed Data Size - COS/Cyclic | Datenlänge im Change of State / Cyclic Modus | UINT16 | RW | 0x0000 (0dez)


Objekte für interne Settings

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Slave - EL6752-0010 [image] Objekte für interne Settings
Objekte für interne Settings
Weiterführende Informationen
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Standardobjekte (0x1000-0x1FFF)

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Slave - EL6752-0010 [image] Objekte für interne Settings [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x145A1389 (341447561dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL6752-0010
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1A603052 (442511442dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x0010000A (1048586dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 1600 DNS RxPDO-Map
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DNS RxPDO-Map | PDO Mapping RxPDO 1 | UINT8 | RW | 0x00 (0dez)
1600:01 |  |  |  |  |
... |  |  |  |  |
1600:FF |  |  |  |  |
Index 1A00 DNS TxPDO-Map
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | DNS TxPDO-Map | PDO Mapping TxPDO 1 | UINT8 | RW | 0x00 (0dez)
1A00:01 |  |  |  |  |
... |  |  |  |  |
1A00:FF |  |  |  |  |
Index 1A01 DNM TxPDO-Map Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | DNM TxPDO-Map Device | PDO Mapping TxPDO 2 | UINT8 | RW | 0x09 (9dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF100 (DeviceNet status), entry 0x01 (Communication status)) | UINT32 | RW | 0xF100:01, 8
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF100 (DeviceNet status), entry 0x10 (TxPdoState)) | UINT32 | RW | 0xF100:10, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF101 (Network status), entry 0x01 (Device status)) | UINT32 | RW | 0xF101:01, 8
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF101 (Network status), entry 0x09 (CAN BUS-OFF)) | UINT32 | RW | 0xF101:09, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF101 (Network status), entry 0x0A (CAN warning limit)) | UINT32 | RW | 0xF101:0A, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF101 (Network status), entry 0x0B (CAN Overrun)) | UINT32 | RW | 0xF101:0B, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (5 bits align) | UINT32 | RW | 0x0000:00, 5
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF101 (Network status), entry 0x11 (CAN BUS load)) | UINT32 | RW | 0xF101:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Parametrierung und Inbetriebnahme [image] EtherCAT Beschreibung [image] Objektbeschreibung und Parametrierung [image] DeviceNet Slave - EL6752-0010 [image] Objekte für interne Settings [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000 Poll Produced Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | Poll Produced Data | Ausgangsdaten der Polling Verbindung | UINT8 | RO | 0x01 (1dez)
6000:01 |  |  |  |  |
... |  |  |  |  |
6000:01 |  |  |  |  |
Index 6001 COS Produced Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6001:0 | COS Produced Data | Ausgangsdaten der Change of State Verbindung | UINT8 | RO | 0x01 (1dez)
6001:01 |  |  |  |  |
... |  |  |  |  |
6001:01 |  |  |  |  |
Index 7000 Poll Consumed Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | Poll Consumed Data | Eingangsdaten der Polling Verbindung | UINT8 | RO | 0x01 (1dez)
7000:01 |  |  |  |  |
... |  |  |  |  |
7000:01 |  |  |  |  |
Index 7001 COS Consumed Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7001:0 | COS Consumed Data | Eingangsdaten der Change of State Verbindung | UINT8 | RO | 0x01 (1dez)
7001:01 |  |  |  |  |
... |  |  |  |  |
7001:01 |  |  |  |  |
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Liste der angeschlossenen Geräte | UINT8 | RW | 0x01 (1dez)
F010:01 | SubIndex 001 | Produktkennung EL6752-0010 | UINT32 | RW | 0x0000145A (5210dez)
Index F100 DeviceNet status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F100:0 | DeviceNet status | DeviceNet-seitiger Status der EL6752-0010 | UINT8 | RO | 0x10 (16dez)
F100:01 | Communication status | Kommunikationszustand der EL6752-0010: 0 = No error 1 = Station deactivated 2 = Station not exists 18 = Station ready 31 = only for EtherCAT gateways: WC-State of cyclic EtherCAT frame is 1 | UINT8 | RO | 0x00 (0dez)
F100:10 | TxPdoState | Status der Tx-PDO | BOOLEAN | RO | 0x00 (0dez)
Index F101 Network status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F101:0 | Network status | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F101:01 | Device status | 0: RUN MODE 1: IDLE MODE 2: Duplicate MacId Check failed, MAC ID used 3: Status: Selftest 4: Status: Standby 5: Status:Major Recoverable Fault 6: Status:Minor Recoverable Fault 7: DeviceNet Voltage Error 8: DeviceNet Access Error | UINT8 | RO | 0x00 (0dez)
F101:09 | CAN BUS-OFF | CAN-Controller der EL6752-0010 ist im Zustand Bus-Off | BOOLEAN | RO | 0x00 (0dez)
F101:0A | CAN warning limit | CAN-Controller der EL6752-0010 hat das Warning Limit überschritten | BOOLEAN | RO | 0x00 (0dez)
F101:0B | CAN Overrun | CAN-Controller der EL6752-0010 ist im Zustand Bus-Off | BOOLEAN | RO | 0x00 (0dez)
F101:11 | CAN BUS load | CAN Busauslastung 0 - 100% | UINT16 | RO | 0x0000 (0dez)
Index F800 Bus Parameter set
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F800:0 | Bus Parameter set | Max. Subindex | UINT8 | RW | 0x08 (8dez)
F800:01 | MAC ID | Geräteadresse des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:03 | Product Name | Produktname des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | OCTET-STRING[32] | RW | {0}
F800:04 | DeviceType | Gerätetyp des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:05 | Vendor ID | Herstellerkennung des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:06 | Product Code | Produktkennung des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:07 | Revision Number | Versionsnummer des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT16 | RW | 0x0000 (0dez)
F800:08 | Serial Number | Seriennummer des DeviceNet Gerätes (siehe DeviceNet-Spezifikation) | UINT32 | RW | 0x00350000 (3473408dez)
F800:09 | Baud rate | DeviceNet Baud Rate | UINT16 | RW | 0x0100 (256dez)


Fehlerbehandlung und Diagnose

Fehlerbehandlung und Diagnose
Fehlerbehandlung und Diagnose
Weiterführende Informationen
•
EL6752 - LED Beschreibung
•
EL6752/-0010 Diagnose
•
DeviceNet Geräte Diagnose
•
EL6752/-0010 - ADS Error Codes
•
DeviceNet / CAN Trouble Shooting


EL6752 - LED Beschreibung

Fehlerbehandlung und Diagnose [image] EL6752 - LED Beschreibung
EL6752 - LED Beschreibung
LEDs
LED Verhalten
Anhand der LED's lassen sich die wichtigsten Zustände der Klemme schnell diagnostizieren:
EL6752-0000 (DeviceNet Master Klemme)
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme; BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
MNS grün | grün | aus | Master ist offline
 |  | blinkend | Master ist online und vollzieht den Duplicate MAC-ID Check
 |  | an | Master ist online und kommuniziert mit den konfigurierten Slaves
MNS rot | rot | blinkend | Kommunikationsstörung des Masters mit einem der konfigurierten Slaves
 |  | an | DeviceNet Bus OFF, DeviceNet Voltage Error, Master failed Duplicate MAC-ID Check
EL6752-0010 (DeviceNet Slave Klemme)
LED | Color | Meaning
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme; BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
MNS grün | grün | aus | Slave ist offline
 |  | blinkend | Slave Port hat den Duplicate MAC-ID Check beendet (Netzwerk OK), Kommunikationsstörung mit dem Master.
 |  | an | Slave Port ist online und kommuniziert mit den Master.
MNS rot | rot | blinkend | Kommunikationsstörung des Slave Port mit dem Master, Timeout des Slave Port
 |  | an | DeviceNet Bus OFF, DeviceNet Voltage Error, Slave Port Fehler, Fehler Duplicate MAC-ID Check


EL6752/-0010 Diagnose

Fehlerbehandlung und Diagnose [image] EL6752/-0010 Diagnose
EL6752/-0010 Diagnose
Die EL6752/-0010 verfügen über verschiedene Diagnosevariablen, die den Zustand der Klemme sowie des DeviceNet beschreiben und die in der SPS verknüpft werden können:
Es wird empfohlen, folgende Prozessdaten in jedem Zyklus zu überwachen:
•
WcState: wenn ≠ 0, dieser EtherCAT Teilnehmer nimmt nicht am Prozessdatenverkehr teil
•
State: wenn ≠ 8, der EtherCAT Teilnehmer ist nicht im OP (Operational) Status
Es wird empfohlen, folgende Prozessdaten zu überwachen:
•
Error: wenn ≠ 0, die angezeigte Anzahl DeviceNet Geräte hat einen BoxState ungleich Null, d.h. es muss geprüft werden welche DeviceNet Geräte nicht korrekt am Bus arbeiten
•
DiagFlag: zeigt eine anstehende Diagnose an
Weiterführende Informationen
•
EL6752/-0010 - WC-State
•
EL6752/-0010 - State
•
EL6752/-0010 - Error / DiagFlag


EL6752/-0010 - WC-State

Fehlerbehandlung und Diagnose [image] EL6752/-0010 Diagnose [image] EL6752/-0010 - WC-State
EL6752/-0010 - WC-State
Zur Überwachung der EtherCAT Kommunikation muss der WC-State (Working-Counter) der EL6752/-0010 überprüft werden. Bei einem WC-State ungleich "0" ist die EtherCAT-Kommunikation gestört, d.h. Daten die zum Slave bzw. zum Master gesendet werden, werden nicht mehr korrekt übertragen und sind nicht gültig.
WCState im TwinCAT Baum
WcState
0: Daten sind gültig
1: Daten sind nicht gültig, es liegt ein Problem in der EtherCAT Kommunikation vor


EL6752/-0010 - State

Fehlerbehandlung und Diagnose [image] EL6752/-0010 Diagnose [image] EL6752/-0010 - State
EL6752/-0010 - State
Die State-Diagnose Variable gibt den aktuellen EtherCAT-Zustand der EL6752/-0010 wieder.
State Diagnose Variable im TwinCAT Baum
State
0x___1 = Slave in 'INIT' state
0x___2 = Slave in 'PREOP' state
0x___3 = Slave in 'BOOT' state
0x___4 = Slave in 'SAFEOP' state
0x___8 = Slave in 'OP' state
0x001_ = Slave signals error
0x002_ = Invalid vendorId, productCode... read
0x004_ = Initialization error occurred
0x010_ = Slave not present
0x020_ = Slave signals link error
0x040_ = Slave signals missing link
0x080_ = Slave signals unexpected link
0x100_ = Communication port A
0x200_ = Communication port B
0x400_ = Communication port C
0x800_ = Communication port D


EL6752/-0010 - Error / DiagFlag

Fehlerbehandlung und Diagnose [image] EL6752/-0010 Diagnose [image] EL6752/-0010 - Error / DiagFlag
EL6752/-0010 - Error / DiagFlag
Error und DiagFlag im TwinCAT Baum
Error
0: alle DeviceNet Geräte haben BoxState gleich Null
>0: Anzahl der DeviceNet-Geräte mit BoxState ungleich Null.
DiagFlag
0 = es liegen keine Diagnose-Daten an
1 = es liegen Diagnose-Daten vor, diese können über ADSRead-Dienste ausgelesen werden


DeviceNet Geräte Diagnose

Fehlerbehandlung und Diagnose [image] DeviceNet Geräte Diagnose
DeviceNet Geräte Diagnose
DeviceNet Slave Geräte verfügen über verschiedene Diagnosevariablen die den DeviceNet-Kommunikationszustand beschreiben und die in der SPS verknüpft werden können:
Es wird empfohlen, folgende Prozessdaten in jedem Zyklus zu überwachen:
•
MacState: wenn ≠ 0, dieser DeviceNet Teilnehmer nimmt nicht korrekt am Prozessdatenverkehr teil
•
CouplerState: für Beckhoff Buskoppler wenn ≠ 0, ist die Klemmenkommunikation des Buskopplers evtl. gestört oder es liegen Diagnose-Daten an
Weiterführende Informationen
•
DeviceNet Slave Gerät / EL6752-0010 - MacState
•
DeviceNet Slave Gerät / EL6752-0010 - DiagFlag
•
Beckhoff DeviceNet Slave Gerät - CouplerState


DeviceNet Slave Gerät / EL6752-0010 - MacState

Fehlerbehandlung und Diagnose [image] DeviceNet Geräte Diagnose [image] DeviceNet Slave Gerät / EL6752-0010 - MacState
DeviceNet Slave Gerät / EL6752-0010 - MacState
Zur Überwachung der DeviceNet Kommunikation muss der MacState der DeviceNet Teilnehmer / EL6752-0010 überprüft werden. Ist der MacState ungleich Null, nimmt der DeviceNet Slave nicht korrekt am DeviceNet Datenaustausch Teil.
MacState im TwinCAT Baum
MacState
0 = No error
1 = Station deactivated
2 = Station not exists
18 = Station ready
40 = Heartbeat Message not received
41 = Shutdown Message received
42 = Electronic Key Fault: Vendor Id
43 = Electronic Key Fault: Device Type
44 = Electronic Key Fault: Product Code
45 = Electronic Key Fault: Revision
46 = Fault while writing Start-Up Attributs
47 = wrong Produced IO-Data Size
48 = wrong Consumed IO-Data Size
49 = Idle Mode


DeviceNet Slave Gerät / EL6752-0010 - DiagFlag

Fehlerbehandlung und Diagnose [image] DeviceNet Geräte Diagnose [image] DeviceNet Slave Gerät / EL6752-0010 - DiagFlag
DeviceNet Slave Gerät / EL6752-0010 - DiagFlag
Das DiagFlag zeigt eine anstehende Diagnose an. Liegen Diagnosedaten an, so können diese über ein ADSRead Kommando ausgelesen werden.
DiagFlag im TwinCAT Baum
DiagFlag
0 = es liegen keine Diagnose-Daten an
1 = es liegen Diagnose-Daten vor, diese können über ADSRead-Dienste ausgelesen werden


Beckhoff DeviceNet Slave Gerät - CouplerState

Fehlerbehandlung und Diagnose [image] DeviceNet Geräte Diagnose [image] Beckhoff DeviceNet Slave Gerät - CouplerState
Beckhoff DeviceNet Slave Gerät - CouplerState
Der CouplerState gibt Information über die Klemmenbus-Kommunikation des Beckhoff-Buskoppler wieder. Diese Information steht für Beckhoff Buskoppler BK52x0, Geräte der IP-Box-Familie IPxxxx-B520 und der IP-Link-Familie zur Verfügung.
CouplerState im TwinCAT Baum
CouplerState
0x00 = I/O Run
0x01 = I/O Error (KBus, IO or Terminal Error)
0x80 = I/O Idle-Mode / Fieldbus Error, es werden keine Ausgangsdaten geschrieben
0x08= es liegt eine Diagnose-Information einer Analogen/- Sonderfunktionsklemme an. Diese Funktion muss zuvor an den Kopplern aktiviert werden. Die Diagnose-Daten können dann in den entsprechenden Registern der Klemmen, IP/-IL-Module ausgelesen werden


EL6752/-0010 - ADS Error Codes

Fehlerbehandlung und Diagnose [image] EL6752/-0010 - ADS Error Codes
EL6752/-0010 - ADS Error Codes
Die ADS Error Codes haben folgende Bedeutung:
Error | Beschreibung
 | Fehler bei der ADS/AMS - Datenaustausch
0x1001 | nicht genügend Speicher für AMS-Kommando
0x1101 | falsche Datenlänge bei StartFieldbus
0x1102 | falscher DeviceState bei StartFieldbus
0x1103 | Device kann nicht von INIT nach RUN wechseln
0x1104 | falscher AdsState im Zustand INIT
0x1105 | falscher DeviceState bei StopFieldbus
0x1106 | Device kann nicht STOP nach RUN wechseln, wenn keine CDL definiert ist
0x1107 | Device kann nicht STOP nach RUN wechseln, wenn keine Box definiert ist
0x1108 | falsche Datenlänge bei StartDataTransfer
0x1109 | falscher DeviceState bei StartDataTransfer
0x110A | falscher AdsState im Zustand STOP
0x110B | Device kann nicht von RUN nach INIT wechseln
0x110C | falsche Datenlänge bei StopDataTransfer
0x110D | falscher DeviceState bei StopDataTransfer
0x1110 | falscher AdsState im Zustand RUN
0x1111 | Laden der Device-Parameter nur im Zustand INIT erlaubt
0x1112 | falsche Datenlänge bei SetDeviceState
0x1113 | AddBox im Zustand INIT nicht erlaubt
0x1114 | falsche Datenlänge bei AddBox
0x1115 | DeleteBox im Zustand INIT nicht erlaubt
0x1116 | falscher IndexOffset bei DeleteBox
0x1117 | falsche Datenlänge bei DeleteBox
0x1118 | ReadBox nur mit AdsRead
0x1119 | AddCdl im Zustand INIT nicht erlaubt
0x111A | falsche Datenlänge bei AddCdl
0x111B | DeleteCdl im Zustand INIT nicht erlaubt
0x111C | falscher IndexOffset bei DeleteCdl
0x111D | falsche Datenlänge bei DeleteCdl
0x111E | falsche IndexGroup bei AdsWrite
0x111F | Device-Parameter können nicht gelesen werden
Error | Beschreibung
 | Fehler bei der ADS/AMS - Datenaustausch
0x1120 | Box-Parameter können nicht gelesen werden
0x1121 | Cdl-Parameter können nicht gelesen werden
0x1122 | DeleteBox bzw. DeleteCdl nur mit AdsWrite
0x1123 | ReadBox nur im Zustand STOP möglich
0x1124 | falscher IndexOffset bei ReadBox
0x1125 | falsche Datenlänge bei ReadBox
0x1126 | falsche IndexGroup bei AdsRead
0x1127 | AddDeviceNotification im Zustand INIT nicht erlaubt
0x1128 | DelDeviceNotification im Zustand INIT nicht erlaubt
0x1129 | IndexOffset zu groß beim Lesen der Device-Diagnosedaten
0x112B | IndexOffset zu groß beim Lesen der Box-Diagnosedaten
0x112F | nicht genügend Speicher für ReadBox-Response
0x1201 | AddCdl: Cdl-No ist zu groß
0x1202 | DeleteCdl nur möglich, wenn CDL gestoppt ist
0x1203 | DeleteCdl nicht möglich, da keine CDL definiert
0x1204 | Zyklus konnte innerhalb der internen Watchdog-Zeit nicht beendet werden
0x1301 | AddCdl: IO-Access-Multiplier ist zu groß
0x1302 | AddCdl: Start-Cycle muss kleiner als IO-Access-Multiplier sein
0x1303 | AddCdl: falsche Datenlänge der Output-Area
0x1304 | AddCdl: falsche Datenoffset der Output-Area
0x1305 | AddCdl: Output-Area ist bereits definiert
0x1306 | AddCdl: falsche Datenlänge der Input-Area
0x1307 | AddCdl: falsche Datenoffset der Input-Area
0x1308 | AddCdl: Input-Area ist bereits definiert
0x1309 | AddCdl: falscher Area-Typ
0x130A | AddCdl: BoxNo wurde nicht mit AddBox definiert
0x130B | AddCdl: falscher Aktions-Typ
0x130C | AddCdl: nicht genügend Speicher für Poll-Liste
0x130D | AddCdl: nicht genügend Speicher für Poll-Listen-Array
0x130E | AddCdl: nicht genügend Speicher für Aktionen
0x130F | AddCdl: CdlNo existiert bereits
Error | Beschreibung
 | Fehler bei der ADS/AMS - Datenaustausch
0x1310 | DeleteCdl: Cdl ist nicht gestoppt
0x1311 | AddCdl: nicht genügend Speicher für asynchrone Sende-Liste
0x1312 | AddCdl: nicht genügend Speicher für synchrone Empfangs-Liste
0x1313 | AddCdl: nicht genügend Speicher für asynchrone Empfangs-Liste
0x1316 | AddCdl: nicht genügend Speicher für synchrone Empfangs-Liste
0x1318 | AddCdl: nur Slave-Aktion erlaubt
0x1319 | AddCdl: nicht genügend Speicher für Slave-Liste
0x1601 | AddBox: BoxNo ist zu groß
0x1602 | AddBox: nicht genügend Speicher für ADS-StartUp-Telegramme
0x1604 | DeleteBox: Box ist nicht gestoppt
0x1605 | AddBox: nicht genügend Speicher für CDL-Telegramme
0x1606 | AddBox: Anzahl der CDL-Telegramme ist zu groß
0x1607 | BoxRestart: Box ist nicht gestoppt
0x1608 | BoxRestart: Syntaxfehler AdsWriteControl
0x1609 | BoxRestart: falscher AdsState
0x160A | Syntaxfehler bei AdsWrite an Box-Port
0x160B | AMS-CmdId wird von Box-Port nicht unterstützt
0x160E | AdsReadState wird von Box-Port nicht unterstützt
0x160F | AddBox: nicht genügend Speicher für das ADS-Interface
0x1610 | AddBox: AMS-Channel ist ungültig
0x1611 | Fehler Kommunikation zu einer AMS-Box
0x1613 | Fehler Kommunikation zu einer AMS-Box: Offset ist falsch
0x1614 | Fehler Kommunikation zu einer AMS-Box: Häppchen ist zu groß
0x1615 | Fehler Kommunikation zu einer AMS-Box: AMS-Kommando ist zu groß
0x1616 | Fehler Kommunikation zu einer AMS-Box: erstes Häppchen ist zu groß
0x1617 | Fehler Kommunikation zu einer AMS-Box: erster Offset ist falsch
Error | Beschreibung
 | Fehler bei der ADS/AMS - Datenaustausch
0x1701 | AddDeviceNotification: Länge der Device-Diagnosedaten zu klein
0x1702 | AddDeviceNotification: Länge der Device-Diagnosedaten zu groß
0x1703 | AddDeviceNotification: Länge der Box-Diagnosedaten zu klein
0x1704 | AddDeviceNotification: Länge der Box-Diagnosedaten zu groß
0x1705 | AddDeviceNotification: Box ist nicht definiert
0x1706 | AddDeviceNotification: falsche IndexGroup
0x1707 | AddDeviceNotification: keine Resourcen mehr für Client
0x1708 | DelDeviceNotification: falscher Handle
0x1801 | StartFieldbus: Im Equidistant-Betrieb müssen Shift-Time + Safety-Time + 2*PLL-Sync-Time größer als die Cycle-Time sein
0x1802 | StartFieldbus: Cycle-Time ist zu groß
0x1803 | StartFieldbus: Cycle-Time ist zu groß
0x1804 | StartFieldbus: Shift-Time ist zu groß
0x1805 | StartFieldbus: PLL-Sync-Time ist zu groß
0x1806 | StartFieldbus: Safety-Time ist zu groß
0x1807 | StartFieldbus: Cycle-Times kleiner 1 ms müssen ein ganzzahliger Teiler von 1 ms sein
0x1A01 | Speicher vom Huge-Heap konnte nicht alloziert werden, da er größer als 0x8000 Bytes war
0x1A02 | Speicher vom Near-Heap konnte nicht alloziert werden, da er größer als 0x1000 Bytes war
0x1A03 | Speicher vom Huge-Heap konnte nicht alloziert werden, da er 0 Bytes war
0x1A04 | Speicher vom Near-Heap konnte nicht alloziert werden, da er 0 Bytes war
 | Fehler bei der Initialisieren der DeviceNet-Kofiguration
0x2001 .. 0x2xxx |
 | Fehler bei Expliziten DeviceNet Datenaustausch
0x2300 | GENERR_RESUNAVAILABLE
0x2301 | ADSERR_DEVICE_SRVNOTSUPP
0x2302 | GENERR_INVALATTRVAL
0x2303 | GENERR_ALRERADYINREQU
0x2304 | GENERR_OBJECTSTATECONF
0x2305 | GENERR_ATTRNOTSETABLE
0x2306 | GENERR_PRIVVIOLATION
0x2307 | GENERR_REPLDATTOOLARGE
0x2308 | GENERR_NOTENOUGHDATA
0x2309 | GENERR_ATTRNOTSUPP
0x230A | GENERR_TOOMUCHDATA
0x230B | GENERR_OBJECTNOTEXIST
0x230C | GENERR_NOSTOREATTRDATA
0x230D | GENERR_STOREOPFAIL
0x230E | GENERR_VENDORSPEC
0x230F | GENERR_INVALPARAM
0x2310 | GENERR_INVALMEMBERID
0x2311 | GENERR_MEMBERNOTSET
0x2312 | ADSERR_DEVICE_SYMBOLNOTFOUND
0x2313 | GENERR_OBJECTSTATECONF


DeviceNet / CAN Trouble Shooting

Fehlerbehandlung und Diagnose [image] DeviceNet / CAN Trouble Shooting
DeviceNet / CAN Trouble Shooting
Error Frames
Fehler in der CAN-Verkabelung, der Adressvergabe und der Baud-Rateneinstellung zeigen sich u.a. durch eine erhöhte Anzahl an Error Frames: die Diagnose LEDs zeigen dann Warning Limit wird überschritten oder Bus-Off-Zustand erreicht.
DeviceNet / CAN Netzwerkanalyse
Überschrittenes CAN Warning Limit, Error Passive oder Bus-Off Zustand werden zunächst bei dem Knoten angezeigt, der die meisten Fehler entdeckt hat. Dieser Knoten muss nicht unbedingt die Ursache für das Auftreten dieser Error Frames sein! Wenn z. B. ein Knoten überdurchschnittlich stark zum Busverkehr beiträgt (z. B. weil er als einziger über analoge Eingänge verfügt, deren Daten in kurzen Abständen ereignisgesteuerte Nachrichten auslösen), so werden auch seine Telegramme mit großer Wahrscheinlichkeit zunächst gestört - entsprechend erreicht sein Fehlerzähler als erster kritische Zustände.
MAC-ID / Baud Rate Einstellung
Es muss sorgfältig darauf geachtet werden, dass keine Knotenadresse / MAC-ID doppelt vergeben ist.
Test 1
MAC-ID überprüfen. Falls die DeviceNet Kommunikation wenigstens zeitweise funktioniert und alle Geräte den Duplicat MAC-ID Check unterstützen, so kann die Adressvergabe auch durch Aufzeichnen der Duplicat MAC-ID Check -Nachrichten nach dem Einschalten der Geräte überprüft werden - hierdurch wird aber kein Vertauschen von Knotenadressen erkannt.
Test 2
Überprüfen, ob überall die gleiche Baud-Rate eingestellt ist.
Test der DeviceNet/CAN-Verkabelung
Diese Tests nicht ausführen, wenn das Netzwerk aktiv ist: Während der Tests sollte keine Kommunikation stattfinden. Die folgenden Tests sollten in der angegebenen Reihenfolge ausgeführt werden, da manche Tests davon ausgehen, dass der vorhergehende Test erfolgreich war. In der Regel sind nicht alle Tests notwendig.
Netzwerkabschluss und Signalleitungen
Für diesen Test sollten die Knoten ausgeschaltet oder die CAN-Leitung abgesteckt sein, da die Messergebnisse sonst durch die aktiven CAN-Transceiver verfälscht werden können.
Verdrahtungsplan für Testaufbau
Test 3
Widerstand zwischen CAN-high und CAN-low ermitteln - ggf. bei jedem Gerät.
Wenn der Messwert über 65 Ohm liegt, deutet dies auf fehlende Abschlusswiderstände oder den Bruch einer Signalleitung hin. Wenn der Messwert kleiner 50 Ohm ist, nach Kurzschluss zwischen CAN-Leitung, überzähligen Abschlusswiderständen oder fehlerhaften Transceivern suchen.
Test 4
Auf Kurzschluss zwischen CAN-Ground und den Signalleitungen sowie zwischen Schirm und Signalleitungen prüfen.
Test 5
Erdung von CAN-Ground und Schirm auftrennen. Auf Kurzschluss zwischen CAN-Ground und Schirm prüfen.
Topologie
Die Leitungslänge bei CAN Netzwerken hängt stark von der gewählten Baud-Rate ab. CAN toleriert dabei kurze Stichleitungen - ebenfalls in Abhängigkeit von der Baud-Rate. Die erlaubte Stichleitungslänge sollte nicht überschritten werden. Häufig wird die verlegte Leitungslänge unterschätzt - die Schätzung liegt teilweise Faktor 10 unter der tatsächlichen Länge. Deshalb empfiehlt sich folgender Test:
Test 6
Die Stichleitungslängen sowie die Busgesamtlänge nachmessen (nicht nur grob schätzen!) und mit den Topologieregeln (abhängig von der Baud-Rate) vergleichen.
Schirmung und Erdung
Stromversorgung und Schirm sollten sorgfältig, einmalig und niederohmig beim Netzteil geerdet werden. Alle Verbindungsstellen, Abzweige etc. im CAN-Kabel müssen neben den Signalleitungen (und evtl. CAN-GND) auch den Schirm durchverbinden. In den Beckhoff IP20 Buskopplern wird der Schirm über ein R/C-Glied hochfrequenzmäßig geerdet.
Test 7
Mit DC-Strommessgerät (16 A max.) Strom zwischen Spannungsversorgungs-Masse und Schirm am vom Netzteil entfernten Ende des Netzes messen. Es sollte ein Ausgleichsstrom vorhanden sein. Wenn kein Strom vorhanden ist, so ist der Schirm nicht durchgängig verbunden oder das Netzteil ist nicht richtig geerdet. Wenn das Netzteil in der Mitte des Netzwerkes angeordnet ist, so sollte an beiden Enden gemessen werden. Dieser Test kann u.U. auch an den Stichleitungsenden durchgeführt werden.
Test 8
Den Schirm an mehreren Stellen auftrennen und den Verbindungsstrom messen. Wenn ein Stromfluss vorhanden ist, so ist der Schirm an mehreren Stellen geerdet (Erdschleife).
Potentialunterschiede
Der Schirm muss für diesen Test durchgängig sein und darf keinen Strom führen (vorher getestet).
Test 9
Spannung zwischen Schirm und Spannungsversorgungs-Erde an jedem Knoten ermitteln und notieren. Der maximale Potentialunterschied zwischen zwei beliebigen Geräten sollte kleiner als 5 Volt sein.
Fehler erkennen und lokalisieren
Die Regel des "Low-tech-Ansatzes" ist die beste Lokalisierungsmethode: Teile des Netzes abhängen und beobachten, wann der Fehler verschwindet.
Aber: das Vorgehen nach dieser Methode ist unzureichend bei Problemen wie zu großen Potentialunterschieden, Masseschleifen, EMV und Signalverfälschung da die Verkleinerung des Netzes häufig das Problem löst, ohne dass der „fehlende“ Teil ursächlich war. Auch die Buslast ändert sich beim Verkleinern des Netzes - damit können externe Störungen seltener CAN-Telegramme "treffen".
Die Diagnose mittels Oszilloskop führt meist nicht zum Erfolg: CAN Signale sehen auch im ungestörten Zustand teilweise recht wirr aus. Unter Umständen kann mit einem Speicheroszilloskop auf Error Frames getriggert werden - diese Art der Diagnose ist aber Messtechnik-Experten vorbehalten.
Protokollprobleme
In seltenen Fällen sind auch Protokollprobleme (z. B. fehlerhafte oder unvollständige DeviceNet-Implementierung, unglückliches Timing im Boot-Up etc.) Ursache von Störungen. Hier ist dann ein Mitschrieb (Trace) des Busverkehrs mit anschließender Auswertung durch DeviceNet Experten erforderlich - das Beckhoff Support Team kann hier helfen.
Für solch einen Trace eignet sich z. B. ein freier Kanal einer Beckhoff FC5102 CANopen PCI-Karte - die erforderliche Trace-Software stellt Beckhoff im Internet zur Verfügung. Alternativ kann selbstverständlich auch ein handelsübliches CAN Analysetool eingesetzt werden.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
UL-Hinweise
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/EM/EPxxxx
•
ATEX-Dokumentation
•
Abkürzungen
•
Support und Service


UL-Hinweise

Anhang [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1.
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2.
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL6752
Hardware (HW) | Firmware (FW) | Revision-Nr. | Releasedatum
06 - 20* | 07 | EL6752-0000-0016 | 2008/06
 | 08 |  | 2008/11
 | 09 |  | 2010/05
 |  | EL6752-0000-0017 | 2011/10
 | 10 |  | 2012/01
 |  | EL6752-0000-0018 | 2012/10
 | 11 | EL6752-0000-0019 | 2014/07
 | 12 | EL6752-0000-0020 | 2014/06
 | 13* |  | 2015/02
EL6752-0010
Hardware (HW) | Firmware (FW) | Revision-Nr. | Releasedatum
06 - 20* | 06 | EL6752-0010-0016 | 2008/04
 | 07 |  | 2008/06
 | 08 |  | 2008/11
 |  | EL6752-0010-0017 | 2011/10
 | 09 |  | 2012/01
 | 10 |  | 2012/05
 |  | EL6752-0010-0018 | 2012/10
 | 11 | EL6752-0010-0019 | 2014/07
 | 12 | EL6752-0010-0020 | 2014/06
 | 13* |  | 2015/02
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


ATEX-Dokumentation

Anhang [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Abkürzungen

Anhang [image] Abkürzungen
Abkürzungen
Abkürzung | Beschreibung
CAN | Controller Area Network. In ISO 11898 standardisiertes serielles Bussystem, das als Basistechnologie für CANopen dient
CiA | CAN in Automation e.V.. Internationaler Hersteller- und Nutzerverband mit Sitz in Erlangen/Deutschland.
CoB | Communication Object. CAN-Telegramm mit bis zu 8 Datenbytes.
CoB-ID | Communication Object Identifier. Telegrammadresse (nicht zu verwechseln mit Knotenadresse). CANopen verwendet die 11-Bit Identifier nach CAN 2.0A.
CoE | CANopen over EtherCAT
ESC | EtherCAT Slave Controller
FBM | Feldbus Master
MC | Motion Control
NMT | Network Management. Eines der Dienstelemente der CANopen-Spezifikation. Das Netzwerkmanagement dient zur Netzwerkinitialisierung und zur Knotenüberwachung.
OP | OPERATIONAL
PDO | Process Data Object oder Prozessdatenobjekt. CAN-Telegramm zur Übertragung von Prozessdaten (z. B. E/A-Daten).
PREOP | PRE OPERATIONAL
RxPDO | Empfangs-PDO. PDOs werden immer aus Sicht des jeweiligen Gerätes bezeichnet. So wird ein TxPDO mit Eingangsdaten einer E/A Baugruppe zum RxPDO aus Sicht der Steuerung.
SAFEOP | SAFE OPERATIONAL
SDO | Service Data Object oder Servicedatenobjekt. CAN-Telegramm mit Protokoll zur Kommunikation mit Daten des Objektverzeichnisses (typisch Parameterdaten).
SI | Subindex
SM | SyncManager
SoE | Servo Profile over EtherCAT
TxPDO | Sende-PDO (aus Sicht des CAN-Knotens bezeichnet).


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.