CU15x1 - EtherCAT - Medienkonverter
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
CU15x1 - Produktübersicht
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


CU15x1 - Produktübersicht

Vorwort [image] CU15x1 - Produktübersicht
CU15x1 - Produktübersicht
CU1521 - EtherCAT-Medienkonverter Multimode-LWL
CU1521-0010 - EtherCAT-Medienkonverter Singlemode-LWL
CU1561 - EtherCAT-Medienkonverter LWL (POF)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.2
▪
Technische Daten aktualisiert
▪
Update Struktur
2.1
▪
Technische Daten aktualisiert
▪
Strukturupdate
2.0
▪
Migration
1.2
▪
Update Kapitel "Technische Daten"
1.1
▪
Update Kapitel "Anwendungshinweise"
1.0
▪
Ergänzungen, 1. Veröffentlichung
0.3
▪
Ergänzungen
0.2
▪
Ergänzungen
0.1
▪
Vorläufige Version


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten


Einführung

Produktübersicht [image] Einführung
Einführung
CU1561, CU1521
Die EtherCAT-fähigen CU1521, CU1521-0010 und CU1561 sind für Industrial-Fast-Ethernet/100 MBaud als Medienkonverter von Lichtwellenleiter- auf Kupfer-Physik und umgekehrt zu verwenden.
Oberes Bild: Ein Medienkonverter Kupfer -> Lichtwellenleiter,
Unteres Bild: 2 Medienkonverter Kupfer -> Lichtwellenleiter -> Kupfer
Aus Sicht der Übertragungsphysik ist der CU1521 geeignet für Multimode-, der CU1521-0010 dagegen für Singlemode-Lichtwellenleiter und somit für deutlich längere Übertragungsstrecken von bis zu 20 km.
Der CU1561 ist die Anbindung an POF-Lichtwellenleiter (plastic optical fibre), die sich durch das relativ preiswerte Kabelmaterial und die Feldkonfektionierbarkeit für die kleinräumigen Maschineninstallationen eignen.
Der Medienkonverter arbeitet bidirektional und kollisionsfrei. Dadurch sind die CU15x1-Geräte auch als Medienkonverter für beliebigen Ethernet-Verkehr geeignet. Sie unterstützen dabei „Link Loss Forwarding“, d.h. wenn am abgehenden Strang z. B. durch Kabelbruch der Link ausfällt, wird auch der ankommenden Leitung der Link entzogen und somit der eigentlich sendenden Stelle der Linkverlust mitgeteilt.
Die CU15x1 zeichnen sich insbesondere dadurch aus, dass sie die Anforderungen, die ein EtherCAT-Netzwerk an einen Konverter stellt, besonders unterstützen. Dazu gehören schnelle Link-Kontrolle (Aufbau und Abbau), Diagnose von Kommunikationsfehlern, konstante Frame-Verzögerung und auslesbare Identität (kein transparenter Betrieb). Wird der CU15x1 durch den Drehschalter auf EtherCAT-Betrieb gestellt, kann er als eigener EtherCAT-Teilnehmer diagnostiziert werden. So gewährleistet er im Gegensatz zu Standardmedienkonvertern auch im Störungsfall eine schnelle Linkkontrolle und damit einen sicheren Abschluss des EtherCAT-Stranges. Da die Übertragungsrichtung (Kupfer Þ LWL oder LWL Þ Kupfer) für den EtherCAT-Bus relevant ist, kann die Betriebsrichtung über den Drehschalter konfiguriert werden.
Der Einsatz der CU15x1 bietet sich an, wenn EtherCAT über große Distanzen übertragen werden soll oder erhöhte EMV-Belastungen der Busleitung zu erwarten sind.
Quick-Links


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | CU1521 |  | CU1521-0010 | CU1561
Funktion Ethernet "IP" | Medienkonverter FastEthernet/100Mbaud (sämtliche auf IEEE 802.3 basierende Protokolle) IEEE 802.3u Auto-Negotiation, Halb- oder Vollduplex, Einstellungen automatisch Link-loss-Forwarding (Melderichtung einstellbar) Store-and-Forward-Mode (FIFO) unmanaged
Funktion EtherCAT "EC" | Medienkonverter FastEthernet/100Mbaud cut-through-Mode Port-Handling/Link-Control
Anzahl Ethernet-Ports | 2
Ethernet-Interface X1 | 100BASE-FX Multimode-Glasfaser 50/125 µm (MM) typ. 1300 nm 2 x SC Duplex |  | 100BASE-FX Singlemode-Glasfaser 9/125 µm (SM) typ. 1300 nm 2 x SC Duplex | 100BASE-FX-POF-Glasfaser 980/1000 µm (POF); typ. 650 nm 2 x Versatile-Link für POF-Duplex-Stecker (Steckerset ZS1090-0008) Laser-Klasse 1, siehe Hinweis
Ethernet-Interface X2 | 10BASE-T/100BASE-TX Ethernet/EtherCAT-Kabel (min. CAT 5), geschirmt RJ45
Leitungslänge X1 max. | max. 2 km (100BASE-FX) |  | max. 20 km (100BASE-FX) | max. 50 m (100BASE-FX-POF)
Leitungslänge X2 max. | bis 100 m Twisted-Pair CAT5(e)
Diagnose | LED: Versorgungsspannung, Link/Activity X1/X2 EtherCAT: CRC
Versorgung | über dreipolige Federzugklemme (+, -, PE)
Versorgungsspannung | 24 VDC (18 VDC bis 30 VDC), verpolungssicher.
Stromaufnahme | typ. 95 mA |  | typ. 80 mA | typ. 60 mA
Gewicht | ca. 105 g
Abmessungen ohne Stecker (B x H x T) | ca. 34 x 98 x 77 (in mm)
Montage | auf 35 mm Tragschiene (Tragschiene nach EN 60715)
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich) | 0°C …+55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C | -25°C …+85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE cULus


Grundlagen

Grundlagen
Grundlagen
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
EtherCAT State Machine
•
CoE-Interface: Hinweis


EtherCAT-Grundlagen

Grundlagen [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EtherCAT State Machine

Grundlagen [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface: Hinweis

Grundlagen [image] CoE-Interface: Hinweis
CoE-Interface: Hinweis
Dieses Gerät hat kein CoE.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Abmessungen
•
Montage und Demontage
•
Empfohlene Tragschienen
•
Diagnose-LEDs
•
UL-Hinweise


Abmessungen

Montage und Verdrahtung [image] Abmessungen
Abmessungen
Platzbedarf im Schaltschrank
•
Die RJ45-Stecker erhöhen die Tiefe in Abhängigkeit ihrer Bauform und des verwendeten Ethernet-Kabels.
•
Berücksichtigen Sie oberhalb der Tragschiene zusätzlich ca. 10 mm Höhe um den Switch auf die Schiene aufrasten zu können.
CU1521-00x0
CU1521-00x0
CU1561
CU1561


Montage und Demontage

Montage und Verdrahtung [image] Montage und Demontage
Montage und Demontage
Die Konverter CU15xx werden mit Hilfe einer auf 35 mm Hutschiene (nach EN 60715) auf der Montagefläche befestigt.
Tragschienenmontage
Beachten Sie, dass der CU15x1 bis zum Kontakt mit der Tragschiene aufgeschoben wird und hörbar auf der Tragschiene einrastet. Siehe Kapitel Empfohlene Tragschienen.
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle.
▪
Hängen Sie den Konverter mit der Feder an der oberen Seite seines Rastflansches in die Tragschiene ein (1)
▪
Drücken Sie die untere Seite des Konverters (2) gegen die Montagefläche bis er auf der Tragschiene einrastet.
▪
Schließen Sie die Kabel an.
Montage
Demontage
▪
Entfernen Sie alle Kabel.
▪
Ziehen Sie die Lasche auf der Unterseite des Konverters (1) mit einem Schraubendreher nach unten
▪
Ziehen Sie den Konverter nach oben von der Montagefläche weg (2)
Demontage


Empfohlene Tragschienen

Montage und Verdrahtung [image] Empfohlene Tragschienen
Empfohlene Tragschienen
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:
▪
Tragschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
▪
Tragschiene TH 35-15 mit 1,5 mm Materialstärke
Materialstärke der Tragschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Tragschiene TH 35-15 mit 2,2 bis 2,5 mm Materialstärke (nach EN 60715)!


Diagnose-LEDs

Montage und Verdrahtung [image] Diagnose-LEDs
Diagnose-LEDs
Steckerbelegung CU1521, CU1521-0010, CU1561
LEDs zur Feldbus-Diagnose/Spannungsversorgung
LED | Farbe | Anzeige | Zustand | Beschreibung
L/A (X1) grün (X2) | grün | aus | - | keine Verbindung auf dem EtherCAT-Strang
 |  | an | linked | EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit EtherCAT-Teilnehmer
Power | grün | aus |  | Keine Versorgungsspannung
 |  | an |  | 24 V Versorgungsspannung liegt an
LED Diagnose EtherCAT State Machine
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | Einzelblitz | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | blinkend | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 | orange | an | CU15x1 ist im EtherCAT-Betrieb, Drehschalter wurde während Betrieb verändert Abhilfe: Wieder zurückstellen oder Spannungs-Reset
 | rot | an | CU15x1 ist im Ethernet-Betrieb, Drehschalter wurde während Betrieb verändert Abhilfe: Wieder zurückstellen oder Spannungs-Reset
 | rot/grün | blinkend | unzulässige Drehschalterstellung nach dem PowerOn Abhilfe: Drehschalter auf zulässige Stellung drehen


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1.
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2.
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Inbetriebnahme/Anwendungshinweise

Inbetriebnahme/Anwendungshinweise
Inbetriebnahme/Anwendungshinweise
Weiterführende Informationen
•
Anwendungshinweise
•
Hinweise für Konverter mit RJ45-LWL-Anschluss
•
Hinweise für Konverter mit RJ45-POF-Anschluss
•
Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008


Anwendungshinweise

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise
Anwendungshinweise
Inhaltsverzeichnis
• Standard Ethernet
• EtherCAT
• Erdung/Schirmung
• Firmware Update
• Allgemeine Hinweise
Die Medienkonverter CU1521, CU1521-0010, CU1561 (im folgenden CU15x1 genannt) setzen physikalisch 10/100 Mbit-Telegramme (FastEthernet) von Kupferphysik (Stecker RJ45) auf Lichtwellenleiter (Stecker SC bzw. Versatile Link) und zurück, um.
Je nachdem, ob EtherCAT- oder Standard-Ethernet-Telegramme übertragen werden sollen, wird ein besonderes Verhalten vom Konverter erwartet.
Verwendung in: Standard Ethernet 10/100 MBit
Eine Ethernet-Verbindung ist eine verwaltete Punkt-zu-Punkt-Verbindung zwischen 2 intelligenten Endgeräten.
Punkt-zu-Punkt-Verbindung zwischen zwei Ethernet-Geräten
Beide Geräte senden in Ihre Ethernet-Verbindung das sog. Idle-Muster - wenn sie auch ein entsprechendes empfangen, ist die Verbindung und damit der sog. Link hergestellt. In diesem Fall ist beiden Geräte bekannt, dass sie diese Verbindung benutzen können. Wird die Verbindung unterbrochen, besteht kein Link mehr und beide Geräte sind informiert.
Unterbrochene Punkt-zu-Punkt-Verbindung
Wenn ein Medienkonverter zwischen beide Stationen geschaltet wird, ist auch dieser ein intelligenter Sender/Empfänger. Würde hier die Verbindung C gestört, würde Teilnehmer A davon nicht unbedingt informiert, er würde weiter Daten an den Konverter über den bestehenden Link B schicken, wo die Daten "versickern". Deshalb unterstützt der CU15x1 Link Loss Forwarding (LLF) in eine auszuwählende Richtung. Die Melderichtung wird durch den Aufdruck am CU15x1 dargestellt. Stellt der Konverter also bei Schalterstellung 1 in Abb. Zwischengeschalteter Medienkonverter in Ethernet-Verbindung eine Unterbrechung von Verbindung C fest, entzieht er auch Verbindung B den Link.
Zwischengeschalteter Medienkonverter in Ethernet-Verbindung
In den beiden IP-Einstellungen arbeitet der CU15x1 als Store-and-Forward-Netzwerkgerät mit Checksummen-Prüfung. Fehlerhafte Frames (CRC-Fehler), zu kurze (<64 Bytes) und zu lange (>1536 Bytes) Frames werden nicht weitergeleitet.
Verwendung in: EtherCAT 100 MBit
Bei der Verwendung als Medienkonverter in einem EtherCAT-Netzwerk sind andere Eigenschaften erforderlich:
▪
konstante geringe Verzögerung bei der Frame-Durchleitung, unabhängig von der Framelänge
▪
schnelle Link-Detektion bei Auf- und Abbau der Verbindung
▪
Kennung als eigenes EtherCAT-Gerät mit Diagnose
EtherCAT-Slaves verarbeiten die EtherCAT-Telegramme in der Vorwärtsrichtung aus Sicht des Masters. Demzufolge kann bei den CU15x1 je nach Einsatzfall die Durchleitung X1 --> X2 oder X2 --> X1 die Vorwärtsrichtung sein. Diese ist am Drehschalter vor Inbetriebnahme einzustellen, die Pfeilrichtung von S1 gibt die eingestellte Vorwärtsrichtung wieder.
Einstellung der Vorwärtsrichtung am Medienkonverter
Es ist grundsätzlich auf die richtige Drehschalterstellung zu achten, so dass der CU15x1 in Vorwärtsrichtung betrieben wird. Beispielsweise ist in Abb. Kupfer -> LWL-> Kupfer- Betrieb zweier Medienkonverter der linke CU15x1 als Kupfer --> LWL (Drehschalterstellung 5), der rechts CU15x1 als LWL --> Kupfer (Drehschalterstellung 0) zu betreiben.
Kupfer -> LWL-> Kupfer- Betrieb zweier Medienkonverter
Wird die gegensätzliche Drehrichtung eingestellt ist das Folgeverhalten vom EtherCAT-Master abhängig. Unter Umständen wird der gescannte CU15x1 dann an einer anderen Position in die Topologie eingebaut oder er verursacht eine INIT_VPRS-Fehlermeldung des EtherCAT-Masters.
Erdung/Schirmung
Der FE-Kontakt an der Versorgungsbuchse ist direkt mit dem Tragschienenkontakt verbunden. Achten Sie bei der Montage auf eine leitfähige Verbindung zur Tragschiene.
Internes Erdungskonzept
Firmware Update
Ein Firmware-Update über EtherCAT ist bei den Geräten CU15x1 nicht möglich.
Allgemeine Hinweise
Der CU15x1 übernimmt die Einstellung des Drehschalters beim Anlegen der Betriebsspannung, es sei denn, der Drehschalter steht in einer unzulässigen Stellung. Dann übernimmt der CU15x1 die Einstellung, sobald der Drehschalter zum ersten Mal eine gültige Einstellung erreicht.
Wird der Drehschalter während des gültigen Betriebs verstellt, ändert der CU15x1 seine Funktion nicht, zeigt diesen Zustand aber durch seine LED an, siehe Diagnose. Vor dem nächsten Spannungs-Neustart ist die richtige Schalterstellung wiederherzustellen!
Drehschalter
Der schräge Einbau der LWL-Buchse im CU15x1 vermindert den Biegeradius des LWL-Kabels, wenn es im Schaltschrank auf die Kabelebene geführt wird (Abb. Schräger Einbau der LWL-Buchse).
Schräger Einbau der LWL-Buchse


Hinweise für Konverter mit RJ45-LWL-Anschluss

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Konverter mit RJ45-LWL-Anschluss
Hinweise für Konverter mit RJ45-LWL-Anschluss
Inhaltsverzeichnis
• Tragschienenmontage
• Hinweise zum verwendbaren LWL-Kabel
• Konnektieren und Lösen des LWL-Kabels am Abzweig
Tragschienenmontage
Montage
Beachten Sie, dass die CU15x1 bis zum Kontakt mit der Tragschiene aufgeschoben wird und hörbar auf der Tragschiene einrastet.
Siehe Tragschienenmontage und Empfohlene Tragschienen.
Hinweise zum verwendbaren LWL-Kabel
Allgemeine Informationen zu LWL-Typen
Man unterscheidet bei Lichtwellenleitern (LWL) nach Multimode- und Singlemodetypen und nach Stufen- und Gradientenindex.
Stufen- und Gradientenindex
Lichtwellenleiter bestehen aus 2 konzentrischen Materialien, dem Kern und einer Umhüllung. Dazu kommt noch ggf. ein (farbiger) Schutzmantel. Kern und Umhüllung haben einen unterschiedlichen Brechungsindex, deshalb werden die Lichtwellen (Moden; eine Mode ist eine Eigenwelle im LWL) an der Übergangsstelle reflektiert und in den Kern zurückgeworfen. Durch den sprunghaften Brechungsindexübergang wird diese Faser als Stufenindex bezeichnet. Wird durch Materialvermischung ein allmählicher/parabolischer Übergang vom Kernbrechungsindex zum Mantelbrechungsindex erreicht, wird dies als Gradientenindex bezeichnet. Bei der Gradientenindexfaser werden die Moden allmählich zum Kern zurückgebeugt, dadurch findet ein Laufzeitausgleich statt und die Qualität eines Lichtpulse am Austrittsende ist deutlich besser als bei einer Multimode-Stufenindexfaser, bei der verschiedene Lichtmoden unterschiedlich lange Signallaufzeiten haben (Modendispersion) - eine Flankenverschleifung ist dort die Folge.
Singlemode
Singlemode-Fasern haben einen sehr dünnen Kern (9 µm) und leiten deshalb nur eine einzige Mode des verwendeten Lichts mit hoher Signalgüte und fast ohne Modendispersion. Es gibt sie nur als Stufenindexfaser. Durch die hohe Signalgüte eignen sie sich für große Übertragungsbandbreiten > 10 GHz*km und Entfernungen > 50 km. Das Brechzahlprofil von Singlemode-Fasern ist so dimensioniert, dass die bei Multimode-Fasern problematische Mehrwegeausbreitung (intermodale Dispersion) entfällt – das Signallicht breitet sich in einer Singlemode-Faser nur in einem einzigen geführten Wellenleitermodus aus, daher die Bezeichnung single-mode. Damit sind wesentlich größere Übertragungsdistanzen und/oder -bandbreiten möglich, und der als nächstes auftretende limitierende Effekt ist die Farbverzerrung des übertragenen Modus.
Multimode
Multimode-LWL werden als Stufenindex oder Gradientenindex gefertigt. Stufenindex-Multimodefasern eignen sich für Übertragungsbandbreiten bis 100 MHz*km und Entfernungen bis max. 1 km. Gradientenindex-Multimodefasern mit einem Kern von 50 µm oder 62,5 µm erreichen Übertragungsbandbreiten > 1 GHz*km und Reichweiten > 10 km. Multimode bedeutet, dass der Kern des LWL-Kabels dick genug ist, damit sich mehrere Moden des verwendeten Lichts reflektierend im Kabel fortbewegen können.
Einsatz mit dem CU1521 und CU1521-0010
Der CU1521, CU1521-0010 ist zur Kombination mit LWL-Kabeln mit folgenden Eigenschaften bestimmt:
▪
SC Duplex Stecker.
▪
CU1521: Duplex Multimode 50/125 µm oder 62,5/125 µm (innerer/äußerer Kerndurchmesser). Der Einsatz von beiden Durchmessern ist möglich. Es wird jedoch die Verwendung von 50/125 µm aufgrund der geringeren Dämpfung empfohlen.
▪
CU1521-0010: Duplex Singlemode 9/125 µm (innerer/äußerer Kerndurchmesser). Ein typ. verwendbares Kabel kann nach der Spezifikation ITU-T G.652.D (0.4 dBm/km bei 1300 nm) gefertigt sein.
Empfohlene Stecker
Es wird der Einsatz von SC/PC -Steckern für die Konnektierung des CU1521, CU1521-0010 empfohlen. Der Vorteil dieser Stecker in "PC" (physical contact) Ausführung ist die ballige Endfläche, so dass beim Zusammenstecken der Stecker der für die Übertragung relevante Bereich des Faserkerns optimal verbunden wird. Weitere Ausführungen sind z. B. SC/UPC (ultrapolish PC), SC/HRL (high return loss) oder SC/APC-Stecker (angled physical contact).
Bei diesen Steckern wird zusätzlich durch die mit ca. 8° zur Faserachse angewinkelte Steckerendfläche reflektiertes Licht aus dem Kern über das Mantelglas in die Luft hinaus gebrochen, was Störungen in der Datenübertragung vermeidet und die Kerngröße der Rückstreuung optimiert.
50/125 µm oder 62,5/125 µm
Der Einsatz von beiden Durchmessern ist möglich. Es wird jedoch die Verwendung von 50/125 µm aufgrund der geringeren Dämpfung empfohlen.
Im LWL-Bereich werden üblicherweise die Wellenlängen 850 nm und 1300 nm für die Datenübertragung verwendet. Die am Markt verfügbaren Glasfaserkabel sind meist zur Verwendung in einem dieser Bereiche optimiert, da die Dämpfung des Signals (wie auch im Kupferkabel) frequenzabhängig ist. Mit Glasfaserkabeln werden große Reichweiten von mehreren Kilometer erzielt. Allgemein weisen Glasfaserkabel bei Wellenlängen 1300 nm eine geringere Dämpfung auf als bei 850 nm.
Im CU1521, CU1521-0010 wird ein Transceiver mit der Wellenlänge 1300 nm eingesetzt.
Reichweite und Bandbreitenprodukt
LWL-Kabel sind in verschiedenen Qualitäten von namhaften Herstellern erhältlich. Für den Anwender maßgebend ist u.a. das frequenzabhängige Bandbreitenprodukt eines Kabels, angegeben in [MHz*km. Je größer das Bandbreitenprodukt, desto geringer ist die Dämpfung - damit steigt die mit diesem Leiter erzielbare Reichweite (s. ITU-T G-651)]. Zur Erzielung der maximalen Reichweite mit dem CU1521, CU1521-0010 sind deshalb Lichtwellenleiter mit einem möglichst hohen Bandbreitenprodukt bei 1300 nm zu verwenden - empfohlen wird ein Einsatz von LWL der Klasse OM2 (EN50173:2002).
Standard-LWL verfügen über ein Bandbreitenprodukt von mindestens 500 MHz*km bei 1300 nm, höherwertigere für Entfernungen > 500 m über > 1000 MHz*km.
Um die Maximalreichweiten zu erzielen, muss die Gegenstelle zum CU1521, CU1521-0010 ebenfalls solche Reichweiten unterstützen.
Verlegehinweise
Beim Verlegen von LWL ist u.a. zu beachten
•
zulässiger Biegeradius
•
zulässige Zugfestigkeit
•
Empfindlichkeit der ungeschützten Kontaktenden
Zur weiteren Information können folgende weitere Quellen dienlich sein:
▪
ITU Empfehlung ITU-T G.651 - G.655
▪
EN 50173:2002
▪
EN 60793-2
Konnektieren und Lösen des LWL-Kabels am Abzweig
Hinweis
Beschädigung des Kabels möglich!
Zur Demontage des LWL-Kabels nur am Stecker ziehen, der die Verriegelung löst - niemals am LWL-Kabel allein!
Gekreuzte Kabel
Beachten Sie, dass bei der Verbindung der CU1521, CU1521-0010 zur Gegenstelle ggf. "gekreuzte" Kabel verwendet werden müssen um eine Verbindung herzustellen.
Praxistipp:
Der infrarote Lichtaustritt kann mittels einer Digital-/Handykamera sichtbar gemacht werden (siehe Abb. Visualisierung von infrarotem Licht am SC Duplex Stecker. Stellen Sie sicher, dass beim Stecken der LWL-Leitung nicht "Licht auf Licht" trifft (Tx -> Tx). In diesem Fall kann keine Verbindung aufgebaut werden und die Kabel sind zu kreuzen (Tx -> Rx).
Visualisierung von infrarotem Licht am SC Duplex Stecker
Verwendung von Blindstopfen
Zum Schutz des Transceivers vor Umwelteinflüssen sollten nicht verwendete Anschlussbuchsen mit den mitgelieferten Blindstopfen verschlossen werden! Siehe Abb.: Blindstopfen in nicht verwendeten Anschlussbuchsen
Blindstopfen in nicht verwendeten Anschlussbuchsen


Hinweise für Konverter mit RJ45-POF-Anschluss

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Konverter mit RJ45-POF-Anschluss
Hinweise für Konverter mit RJ45-POF-Anschluss
Weiterführende Informationen
•
Hinweise zum verwendbaren POF-Kabel
•
Konnektieren und Lösen des POF-Kabels am Abzweig


Hinweise zum verwendbaren POF-Kabel

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Konverter mit RJ45-POF-Anschluss [image] Hinweise zum verwendbaren POF-Kabel
Hinweise zum verwendbaren POF-Kabel
Allgemeine Informationen POF-Kabel
Die Standard-Polymerfaser ist 1 mm dick und besteht aus einem 0,98 mm dicken Kern aus Polymethylmethacrylat (PMMA) sowie einem dünnen Mantel. Um eine Lichtführung durch den Effekt der Totalreflexion im Kern zu ermöglichen, besteht der meist sehr dünne Mantel aus fluoriertem PMMA, welches einen geringeren Brechungsindex aufweist. Die Kerndurchmesser bewegen sich zwischen 0,06 mm und 1 mm, wodurch einfache Steckverbindungen unproblematisch zu realisieren sind. Weiterhin kann somit auf das zur Verbindung von Glasfasern häufig eingesetzte Spleißverfahren, und dem damit verbundenen unnötig hohen Aufwand, in der Regel verzichtet werden. Die maximale Einsatztemperatur von Standard-POF liegt bei etwa 60°C und hat ein Brechungsprofil mit Stufenindex (SI-POF). Der Brechungsindex des Kernmaterials liegt bei 1,49, der des Mantels bei 1,41. Die Differenz bestimmt die numerische Apertur (NA) und damit den maximalen Ausbreitungswinkel. Dieser liegt bei einer Differenz von 5 % bei etwa 20 Grad gegenüber der Faserachse, was zur Reduzierung der Bandbreite führt.
Aufgrund der im Vergleich zur Glasfaser einfachen und nahezu universell einsetzbaren Verbindungstechniken finden POF insbesondere Anwendung bei kurzen Datenübertragungsstrecken, so beispielsweise innerhalb von Räumen, technischen Geräten, mechanischen Anlagen oder auch Personenkraftwagen.
Die POF haben eine Dämpfung von etwa 140 dB/km bei einer Wellenlänge von 650 nm, so dass bei der Anwendung mit dem CU1561 eine Datenübertragungstrecke von max. 50 m zu erreichen ist.
Werden zusätzliche Steckverbindungen in die Strecke eingebracht, vergrößert dies die Signaldämpfung. Je zusätzlichem Steckverbinder reduziert sich somit die zulässige max. Streckenlänge um typ. 6,5 m.
Einsatz mit dem CU1561
Empfohlene Stecker und POF-Kabel
Es wird der Einsatz des bei Beckhoff erhältlichen Steckersets ZS1090-0008 (Versatile Link Duplex-Stecker) in Verbindung mit einer Duplex-Polymerfaser 2 x 2,2 mm Außendurchmesser (Z1190) für die Konnektierung des CU1561 empfohlen.
Verlegehinweise
Beim Verlegen von POF-Kabeln ist u.a. zu beachten:
•
zulässiger Biegeradius (im Allgemeinen gilt r ≥ 25 mm, Herstellerangaben beachten!)
•
zulässige Zugfestigkeit
•
Empfindlichkeit der ungeschützten Kontaktenden


Konnektieren und Lösen des POF-Kabels am Abzweig

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Konverter mit RJ45-POF-Anschluss [image] Konnektieren und Lösen des POF-Kabels am Abzweig
Konnektieren und Lösen des POF-Kabels am Abzweig
Zum Konnektieren des Kabels schieben Sie den Stecker (als Zubehör im Steckerset ZS1090-0008 erhältlich) bis zum hörbaren Einrasten in die Anschlussöffnung.
Rastnase mit Entriegelung am POF-Duplex-Stecker
Zum Lösen des Steckers die Entriegelung mit der Rastnase betätigen. Diese befindet sich dabei rechtseitig am Stecker (siehe Abb. Rastnase mit Entriegelung am POF-Duplex-Stecker)
Hinweis
Beschädigung des Kabels möglich!
Zum Lösen des Kabels die Entriegelung am Stecker drücken und gleichzeitig am Stecker ziehen - niemals am POF-Kabel allein!
Hinweis
Tx / Rx -Kanalbelegung
Achten Sie bei der Kabelkonfektionierung auf die Belegung der optischen Kanäle in der Anschlussbuchse. Beim CU1561 ist der lichtemittierende Transmitterkanal (Tx) der untere Auslass in der Anschlussbuchse (Abb. Transmitterkanal beim CU1561).
Beachten Sie unbedingt den Sicherheitshinweis zur Laser-Klasse 1!
Transmitterkanal beim CU1561
Hinweis
Verwendung von Blindstopfen
Zur Vermeidung von Unfällen durch Blendung (Laserstrahl Klasse 1, bitte Sicherheitshinweis beachten) und zum Schutz des Transceivers vor Umwelteinflüssen sollten nicht verwendete Anschlussbuchsen mit den mitgelieferten Blindstopfen verschlossen werden (Abb. Blindstopfen in nicht verwendeten Anschlussbuchsen)
Blindstopfen in nicht verwendeten Anschlussbuchsen


Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008

Inbetriebnahme/Anwendungshinweise [image] Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008
Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008
Inhaltsverzeichnis
• Schritt-für-Schritt-Anleitung zur Konfektionierung des POF-Kabels
1. Abisolieren des POF-Kabels
2. Anbringen des Steckverbinders
 3. Schleifen und Polieren
4. Feinpolitur
Duplex-Steckerset ZS1090-0008
Das Duplex-Steckerset ZS1090-0008 von Beckhoff besteht aus 10 Duplex Versatile-Link-Steckverbindern und mehreren Bögen Schleif- und Polierpapier.
Schritt-für-Schritt-Anleitung zur Konfektionierung des POF-Kabels
Die nachfolgende Schritt-für-Schritt-Anleitung beschreibt die korrekte Konfektionierung eines POF-Kabels mit einem Versatile-Link-Duplex-Steckverbinder. Die Steckverbinder werden mit Standard-Werkzeugen wie Cutter-Messer oder Abisolierzange an die Kabelenden angebracht. Die Endpolitur des konfektionierten Kabels wird mit dem im Steckerset beigefügten Polierset, bestehend aus einer Plastik-Schleiflehre, Schleifpapierbögen mit der Körnung 600 und rosa Polierbögen durchgeführt. Die konfektionierte Steckverbindung kann sofort nach der Bearbeitung benutzt werden.
Für die Arbeitsschritte benötigtes Material:
1. POF-Kabel (Polymeric optical fiber, z. B. Z1190 von Beckhoff)
2. Cutter-Messer oder Schere
3. Abisolierzange
4. Polierset (im Steckerset ZS1090-0008 von Beckhoff enthalten)
5. Versatile Link Duplex-Stecker (im Steckerset ZS1090-0008 von Beckhoff enthalten)
1. Abisolieren des POF-Kabels
Das Kabel sollte auf einer Länge zwischen 100 mm und 150 mm vom Kabelende aufgetrennt sein, um die nachfolgenden Arbeiten ordnungsgemäß durchführen zu können.
Nachdem Sie das Kabel auf die gewünschte Länge gekürzt haben, entfernen sie mittels Abisolierzange ca. 7 mm der äußeren Ummantelung der Einzeladern. Die beiden Kabelenden sollten ungefähr gleich lang abisoliert sein (Abb. POF-Kabel auf gleiche Länge abisoliert).
POF-Kabel auf gleiche Länge abisoliert
2. Anbringen des Steckverbinders
Schieben Sie beide Kabelenden in den Steckverbinder und ziehen Sie den Steckverbinder bis zum Anschlag zurück. Die Fasern sollten jetzt nicht mehr als 1,5 mm aus den vorderen Öffnungen herausragen (Abb. In den Steckverbinder eingelegtes Kabel).
Sie schließen den Steckverbinder, indem Sie die obere und untere Hälfte zusammenklappen und einrasten lassen (Abb. Geschlossener Steckverbinder).
In den Steckverbinder eingelegtes Kabel
Geschlossener Steckverbinder
Achten Sie beim Einlegen der Leiter in die Steckverbinder auf die gekreuzte Verbindung der optischen Kanäle zur Gegenseite (Tx1 --> Rx2; Tx2 --> Rx1). Als Orientierung dient die Nase des Scharniers am Stecker (Abb. Korrekt verbundene Optische Kanäle).
Korrekt verbundene Optische Kanäle
3. Schleifen und Polieren
Fasern, die mehr als 1,5 mm aus dem Steckverbinder herausragen, müssen mit einem Cutter-Messer oder einer Schere eingekürzt werden.
Schieben Sie nun den Steckverbinder komplett in die Schleiflehre, so dass die zu polierenden Enden auf der unteren Seite herausragen (Abb. Schleiflehre mit herausragenden Faserenden). Die Schleiflehre ist zum Polieren von einem oder zwei Simplex- oder einem Duplex-Steckverbinder geeignet.
Schleiflehre mit herausragenden Faserenden
Verschleißanzeige
Die Verschleißanzeige der Schleiflehre besteht aus 4 Punkten auf der Unterseite. Sollte einer dieser Punkte nicht mehr sichtbar sein, ist die Schleiflehre zu ersetzen.
Pressen Sie nun mit gleichmäßigen Druck und möglichst senkrecht die Schleiflehre auf das Schleifpapier. Um ein gleichmäßiges Schleifergebnis zu erzielen, beschreiben Sie beim Schleifen die Form einer "8" (Abb. Polieren in Form einer „8“), bis die Fasern bündig mit der Schleiflehre abschließen. Anschließend reinigen Sie die Schleiflehre und den Steckverbinder von unten mit einem weichen, trockenen Tuch.
Polieren in Form einer „8“
4. Feinpolitur
Fahren Sie nun mit der Feinpolitur und dem rosa Polierbogen in gleicher Art und Weise fort. Dazu den bündigen Steckverbinder mit der Schleiflehre auf der matten Seite des Polierbogens mit leichtem Druck aufsetzen und die Form einer "8" maximal 25 mal beschreiben. Nach Abschluss der Prozedur sollte das Faserende flach, glatt und sauber sein.
Verbesserung der Übertragungsperformance durch Feinpolitur
Die Feinpolitur mit dem Polierbogen bringt eine Verbesserung der Übertragungsperformance von Transmitter zu Receiver oder in der Kabelverbindung von bis zu 0,5 dB gegenüber der Behandlung nur mit dem Schleifbogen allein. Der Arbeitsschritt des Polierens kann allerdings für kurze Übertragungsentfernungen ausgelassen werden.
Feinpolierte Fasern im Steckverbinder


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
•
Firmware Kompatibilität
•
Firmware Update EL/ES/EM/EPxxxx
•
Support und Service


Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1

Anhang [image] Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
SmallWarningYellow VORSICHT
Laser-Klasse 1 Produkt - Unfallgefahr durch Blendung!
Folgende laserspezifische Verhaltensregeln sind für die in dieser Dokumentation beschriebenen Produkte der Laser-Klasse 1 zu beachten:
•
Der Laserstrahl darf nicht auf Personen gerichtet werden, da es durch Blendung zu Unfällen kommen kann.
•
Nicht in den direkten oder reflektierten Strahl blicken.
•
Falls Laserstrahlung ins Auge trifft, sind die Augen bewusst zu schließen und der Kopf sofort aus dem Strahl zu bewegen.
•
Bei der Verwendung des Lasers dürfen keine optischen Instrumente zur Betrachtung der Strahlungsquelle verwendet werden, da dies zu einer Überschreitung der Expositionsgrenzwerte führen kann.
•
Manipulationen (Änderungen) an der Lasereinrichtung sind unzulässig.
Hinweis


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Die Konverter CU1521-00x0 und CU1561-0000 verfügen über keine Firmware.


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.