EL5102 - 2-Kanal Inkremental Encoder Interface, 5 V, (RS422, TTL, Open Collector
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.0
▪
1. Veröffentlichung
0.3
▪
Erste vorläufige Dokumentation für EL5102


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät hat eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL5102 - Einführung
•
EL5102 - Technische Daten
•
Start
•
Übersicht EL51xx-Serie


EL5102 - Einführung

Produktübersicht [image] EL5102 - Einführung
EL5102 - Einführung
Zweikanalige Inkremental Encoder Interface Klemme
EL5102
Die EtherCAT-Klemme EL5102 ist ein Interface zum direkten Anschluss von zwei Inkremental-Encodern mit Differenzeingängen (RS422) oder single-ended Eingängen (TTL und Open Collector), parametrierbar je Kanal. Die Encoder können direkt aus der Klemme gespeist werden. Dabei bietet die EL5102 zwei separate Geberversorgungsspannungen an, die wahlweise zwischen 5 VDC, 12 VDC oder 24 VDC umgeschaltet werden können.
Pro Kanal steht ein 32-Bit-Zähler mit Quadraturdecoder zur Verfügung. Weiterhin kann über die Eingänge (Latch-, Gate/Latch und Nullimpuls C-Eingang) der Zählerwert separat gespeichert oder auf einen vorgegebenen Wert gesetzt werden. Zusätzlich besteht die Möglichkeit den Zähler zu verriegeln, wahlweise durch den Gate/Latch-Eingang oder direkt durch die Prozessdaten. An den Status-Input-Eingang der Klemme kann ein Statussignal des Inkrementalencoders angeschlossen werden.
Die EL5102 ermöglicht die Messung einer Periode, einer Frequenz und Geschwindigkeit, mit einer Auflösung von 10 ns. Weiterhin ist eine Duty-Cycle Messung des eingehenden Signals implementiert.
Durch die optionale interpolierende Mikroinkrementefunktionalität kann die EL5102 bei dynamischen Achsen noch genauere Achspositionen liefern. Zudem unterstützt sie über die hochpräzisen EtherCAT-Distributed-Clocks (DC) das synchrone Einlesen des Geberwertes zusammen mit anderen Eingangsdaten im EtherCAT-System. Zusätzlich bietet die EL5102 die Timestamp-Funktion an, so können die letzte registrierte Inkrementalflanke, die Flanke am Latch-Eingang und der Nullimpulsspur C mit einem Zeitstempel ausgegeben werden.
Quick-Links
Grundlagen der Kommunikation
Konfigurationserstellung TwinCAT
EL5102 - Prozessdaten
Konfigurationsdaten
EL5102 - Objektbeschreibung
LEDs und Anschlussbelegung


EL5102 - Technische Daten

Produktübersicht [image] EL5102 - Technische Daten
EL5102 - Technische Daten
Technische Daten | EL5102
Encodertyp | Inkremental, differentiell (RS422), Single-ended (TTL, Open Collector), Zähler, Impulsgeber
Geberanschluss | Differenzeingänge (RS422): A, A̅, B, B̅, C, C̅ Single-Ended-Anschluss (TTL, Open Collector): A, B, C Zähler, Impulsgeber: A, B
Anzahl Kanäle | 2 x A, B, C
zusätzliche Eingänge | Latch, Gate/Latch (24 VDC, tON > 1 µs) pro Kanal, Status-Input-Eingang (max. 5 VDC, negativ schaltend, tON > 10 µs) pro Kanal
Geberbetriebsspannung | 5 VDC (voreingestellt), 12 VDC, 24 VDC umschaltbar, 0,3 A pro Kanal (erzeugt aus den 24 VDC - Powerkontakten)
Zähler | 32 Bit (voreingestellt) oder 16 Bit umschaltbar
Grenzfrequenz | RS422-Mode: 20 Mio. Inkremente/s bei 4-fach-Auswertung, entspricht 5 MHz TTL-Mode: 4 Mio. Inkremente/s bei 4-fach Auswertung, entspricht 1 MHz Open Collector: 400.000 Inkremente/s bei 4-fach Auswertung, entspricht 100 kHz
Quadraturdecoder | 4-fach-Auswertung (voreingestellt), 2-fach-, 1-fach-Auswertung umschaltbar
Auflösung Mikroinkremente | 1/256 Bit Mikroinkremente
Drahtbrucherkennung zum Geber | Ja für RS422 Encoder
Distributed Clocks | Ja
Timestamp | Auflösung 1 ns
Besondere Funktionen | Frequenz-, Periodendauer- und Duty Cycle Messung, Mikroinkremente, einstellbare Störimpulsfilter, Zeitstempel auf: letzte Inkrementalflanke, Nullimpuls C, Latch-Eingang und Gate/Latch-Eingang
Zykluszeit | min. 100 µs
Stromaufnahme aus dem E-Bus | typ. 210 mA
Stromaufnahme aus den Powerkontakten | Typ. 20 mA + Last
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 100 g
Zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
Zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
Montieren Sie den EL5102 wie im Kapitel Montage und Verdrahtung beschrieben
▪
Konfigurieren Sie den EL5102 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.
▪
Parametrieren Sie den EL5102 wie im Kapitel EL5102 - Inbetriebnahme beschrieben.


Übersicht EL51xx-Serie

Produktübersicht [image] Übersicht EL51xx-Serie
Übersicht EL51xx-Serie
Technische Daten |  | EL5102 2 x A, B, C | EL5112 |  | EL5122 2 x A, B | EL5131 1 x A, B, C
 |  |  | 1 x A, B, C | 2 x A, B
Anzahl Kanäle |  | 2 | 1 | 2 | 2 | 1
Encodertyp, Inkremental | Differentiell RS422 | X | X | X | / | X
 | Single-ended TTL | X | X | X | X | X
 | OpenCollector | X | X | X | X | X
 | Zähler / Impulsgeber | X | X | X | X | X
Anzahl Digital Eingänge pro Kanal |  | 2 | 2 | 1 | 1 | 2
Anzahl Digital Ausgänge pro Kanal |  | / | / | / | / | 2
Geberbetriebsspannung 5 VDC, 12 VDC, 24 VDC umschaltbar |  | X | X | X | X | X
Geberausgangsstrom pro Kanal |  | 0,3 A | 0,3 A | Summenstrom 0,3 A | Summenstrom 0,3 A | 0,3 A
Grenzfrequenz |  | 20 Mio. Inkremente, entspr. 5 MHz | 20 Mio. Inkremente, entspr. 5 MHz | 20 Mio. Inkremente, entspr. 5 MHz | 4 Mio. Inkremente, entspr. 1 MHz | 20 Mio. Inkremente, entspr. 5 MHz
Funktionen |  | EL5102 2 x A, B, C | EL5112 |  | EL5122 2 x A, B | EL5131 1 x A, B, C
 |  |  | 1 x A, B, C | 2 x A, B
Zählerstand Reset über | Nullimpuls C | X | X | / | / | X
 | Latch-Eingang | X | X | X | X | X
Zählerstand setzen über | SPS Variable | X | X | X | X | X
 | Nullimpuls C | X | X | / | / | X
 | Latch-Eingang | X | X | X | X | X
 | Gate/Latch-Eingang | / | / | X | X | /
Zählerstand speichern über | Nullimpuls C | X | X | / | / | X
 | Latch-Eingang | X | X | X | X | X
 | Gate/Latch -Eingang | X | X | / | / | X
Zählerstand sperren über | SPS Variable | X | X | X | X | X
 | Gate/Latch -Eingang | X | X | X | X | X
Schalten an Vergleichswerten (Counter / Frequency / Period value) |  | / | / | / | / | X
Zählrichtung detektieren |  | X | X | / | / | X
Zählrichtungsumkehr detektieren |  | X | X | / | / | X
Frequenzmessung |  | X | X | X | X | X
Periodendauermessung |  | X | X | X | X | X
Geschwindigkeits-, Drehzahlberechnung |  | X | X | X | X | X
Duty Cycle Auswertung |  | X | X | / | / | X
Mikroinkremente |  | X | X | / | / | X
Zeitstempelfunktion |  | X | X | / | / | X
Einstellbare Störimpulsfilter |  | X | X | X | X | X
Plausibilitätsprüfung |  | X | X | X | X | X


Technologie

Technologie
Technologie
Die Inkremental-Encoder-Interface Klemmen der EL51xx-Serie ermöglicht den Anschluss von Inkremental-Encodern an Buskoppler bzw. die SPS.
Grundlagen Inkremental Encoder
Inkremental-Encoder teilen eine 360° - Drehung der Encoderachse in einzelne Schritte (Inkremente) auf und kennzeichnen eine volle Umdrehung durch eine Sondermarke (Nullimpuls). Ein RS422-Encoder überträgt das Signal symmetrisch als differentielles Leitungspaar. TTL- und Open Collector- Encoder nutzen einzelne Signalleitungen (Single-Ended).
Die Klemme wertet an Spur A und B die um 90° phasenverschobenen Rechtecksignale eines Inkremental-Encoders aus. Der Nullimpuls wird an Spur C erfasst. Zusätzlich werden bei differentiellem Anschluss auch die invertierten Signale (A̅, B̅, C̅) erfasst.
Diese Signale werden mit Hilfe des Quadraturdecoders und des 32 Bit Zählers in einen Positionswert mit wahlweise vierfach-, zweifach-, oder einfach - Auswertung gewandelt. Die digitalen Eingänge ermöglichen Latch-, Reset- und Set-Funktionalitäten und damit ein exaktes und geschwindigkeitsunabhängiges Referenzieren und Speichern des Zählerstandes.
Encodertyp |  | Inkrementalsignale
RS422 Encoder | mit Nullimpuls | A, A̅, B, B̅, C, C̅
RS422 Encoder | ohne Nullimpuls | A, A̅, B, B̅
RS422 Zähler oder Impulsgeber | mit Nullimpuls | A, A̅, C, C̅; Zählrichtungsvorgabe über Spur B (B, B̅)
RS422 Zähler oder Impulsgeber | ohne Nullimpuls | A, A̅; Zählrichtungsvorgabe über Spur B (B, B̅)
TTL, Open Collector Encoder | mit Nullimpuls | A, B, C
TTL, Open Collector Encoder | ohne Nullimpuls | A, B
TTL, Open Collector Zähler oder Impulsgeber | mit Nullimpuls | A, C; Zählrichtungsvorgabe über B
TTL, Open Collector Zähler oder Impulsgeber | ohne Nullimpuls | A, Zählrichtungsvorgabe über B
Die Phasenlage zwischen den Signalen an Spur A und Spur B gibt die Zählrichtung vor.
Vorwärts (cw): Signal an Spur A ist 90 ° voreilend gegenüber Spur B
Rückwärts (ccw): Signal an Spur A ist 90 ° nacheilend gegenüber Spur B.
Bei einfach - Auswertung werden die steigenden Flanken an Spur A gezählt.
Bei zweifach - Auswertung werden die steigenden und fallenden Flanken an Spur A gezählt.
Bei vierfach - Auswertung werden die steigenden und fallenden Flanken an Spur A und Spur B gezählt.
Inkremental-Signale
Absolutwertencoder liefern direkt nach dem Einschalten einen absoluten und über den kompletten Verfahrweg eindeutigen Positionswert. Bei Inkremental-Encodern muss nach dem Einschalten eine Referenzfahrt (Homing) durchgeführt werden, um eine eindeutige Position ermitteln zu können.
Das Referenzieren kann z. B. mit Hilfe von Referenznocken oder über den Nullimpuls des Gebers vorgenommen werden.
Hinweis
Differenzieller und Single-Ended Anschluss
•
Das RS422-Signal überträgt eine Differenzspannung, dadurch ist das Signal störunempfindlicher im Vergleich zu einem Single-Ended-Signal.
⇨
Soll das Gebersignal über längere Entfernung oder mit höheren Frequenzen übertragen werden, wird ein Encoder mit RS422-Signalen empfohlen.
⇨
Es sollten geschirmte und paarig verdrillte (Twisted Pair) Leitungen verwendet werden.


Technische Eigenschaften

Technische Eigenschaften
Technische Eigenschaften
Die Inkremental-Encoder-Interface Klemmen der EL51xx-Serie ermöglichen den Anschluss von Inkremental-Encodern. Neben den Gebereingängen A, B und optional Nullimpuls C stehen bis zu zwei zusätzliche 24 VDC Eingänge (Latch und Gate/Latch) zum Reset, Setzen, Sperren und Speichern des Zählerstandes zur Verfügung. Besitzt der Inkremental-Encoder einen Störmelde-Ausgang, so kann dieser an den Status Input Eingang (5 VDC) angeschlossen werden.
Es stehen folgende Eingänge mit den jeweiligen technischen Eigenschaften zur Verfügung:
▪
Geberanschluss: es werden differentielle Signale nach RS422 und Single-Ended-Signale von TTL-Encodern und Open Collector-Encodern unterstützt.
▪
Latch-Eingang und Gate/Latch-Eingang
▪
Status-Input-Eingang
Weiterhin stellt die Klemme auch eine parametrierbare Geberversorgung zur Verfügung.
▪
Geberbetriebsspannung
Hinweis
Schnelle Digitale Eingänge – Beeinflussung durch störende Geräte
Beachten Sie, dass die Eingangsbeschaltung nur eine sehr geringe Filterung aufweist. Sie ist auf schnelle Signalübertragung vom Eingang zur Auswerteeinheit optimiert. Schnelle Pegeländerungen/Pulse im µs-Bereich und/oder hochfrequente Störsignale von Geräten (z. B. Proportionalventilen, Schrittmotor- oder DC-Motor-Endstufen) treffen also nahezu ungefiltert/ungedämpft an der Auswerteeinheit ein. Diese Störungen können fälschlicherweise als Signal erfasst werden.
Um Störungen zu unterdrücken, kann ein zusätzlicher Eingangsfilter parametriert werden. Weiterhin werden eine EMV-gerechte Verkabelung und der Einsatz von getrennten Netzteilen für die Klemme und die Störungen verursachenden Geräte empfohlen.
Weiterführende Informationen
•
Signaltypen
•
Eingänge Latch und Gate/Latch
•
Eingang Status-Input
•
Geberbetriebsspannung (Supply voltage)


Signaltypen

Technische Eigenschaften [image] Signaltypen
Signaltypen
Unterstützte Encoder / Signaltypen
Als Geberanschluss sind differentielle Signale nach RS422 vorgesehen. Single-Ended-Signale von TTL-Encodern und auch Signale von Open Collector-Encodern sind durch interne Pull Up Widerstände möglich.
Folgende Signaltypen werden unterstützt:
Geber | Signaltyp | Einstellung in Index 0x80n1:1D „Counter mode“ | Grenzfrequenz | Bemerkungen
Encoder mit oder ohne Nullimpulsspur C | RS422 (diff. Input) | 0 | 20 Mio. Inkremente bei 4-fach Auswertung, entspricht 5MHz je Spur | Es werden Signalpegel nach RS422 erwartet Drahtbruch und Kurzschlusserkennung
Zähler/Impulsgeber mit oder ohne Nullimpulsspur C |  | 1
Encoder mit oder ohne Nullimpulsspur C | TTL (single ended) | 2 | 4 Mio. Inkremente bei 4-fach Auswertung, entspricht 1 MHz je Spur | Es wird ein Spannungspegel von nominell 2,0 V bis 6,0 V mit einem Strom von min. 2,1 mA erwartet. Keine Drahtbrucherkennung
Zähler/Impulsgeber mit oder ohne Nullimpulsspur C |  | 3
Encoder mit oder ohne Nullimpulsspur C | open collector | 4 | 400.000 Inkremente bei 4-fach Auswertung, entspricht 100 kHz je Spur | Keine Drahtbrucherkennung
Zähler/Impulsgeber mit oder ohne Nullimpulsspur C |  | 5
Die richtige Verdrahtung für den jeweiligen Encoder finden Sie im Kapitel Anschlussbelegung.
Signaltyp RS422 (diff. input)
Die Klemme erwartet die differenzielle Signalpegel nach RS422 bei folgenden Einstellungen im „Counter mode“ (0x80n1:1D):
▪
0: Encoder RS422 (diff. input)
▪
1: Counter RS422 (diff. input)
Es ist eine Grenzfrequenz bis max. 20 Mio. Inkremente pro Sekunde, bei 4-fach-Auswertung zulässig. Dies entspricht 5 MHz.
RS422 Signalpegel
Legende:
VCM | Common-Mode Spannungsbereich
VID | Differenzspannung
VIDLow | Differenzspannung zu niedrig
A, B, C | Signale A, B, C
A̅, B̅, C̅ | Invertierte Signale A̅, B̅, C̅
Hinweis
Überschreitung Common Mode Bereich
Eine Überschreitung des Common-Mode Spannungsbereichs kann zur Zerstörung des Gerätes führen.
RS422 - Drahtbruch- und Kurzschlusserkennung (open circuit)
In den RS422 (differentieller Input) Modi ist es möglich einen Drahtbruch und Kurzschluss an den einzelnen Encoder-Eingängen zu erkennen.
▪
Im Drahtbruchfall, z. B. zwischen dem Eingang A und Eingang A̅,
–
beträgt die Differenzspannung VID nahezu 0 V,
–
dies führt zu einem Fehler mit niedriger Differenzspannung.
▪
Beim Kurzschlussfall, z. B. zwischen dem Eingang A und Eingang A̅, ähnelt das Fehlerverhalten dem Drahtbruch, dies führt ebenfalls zu einer Fehlererkennung.
Aktivierung der Fehlererkennung je Kanal
Index (hex) | Name | Beschreibung
80n0:0B | Error detection A | TRUE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang A aktiviert
 |  | FALSE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang A deaktiviert
80n0:0C | Error detection B | TRUE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang B aktiviert
 |  | FALSE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang B deaktiviert
80n0:0D | Error detection C | TRUE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang C aktiviert
 |  | FALSE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang C deaktiviert
Fehlererkennung am Beispiel eines Drahtbruches oder Kurzschlusses zwischen den Eingängen A und A̅.
Fehlerdiagnose | Anzeige | Beschreibung
LED A1 | Grün | Ein TRUE Pegel liegt an
 | Rot | Ein Fehler (open circuit) wurde detektiert
0x60n07 „Open circuit“ | TRUE | Sammelfehlermeldung für „Open circuit“ Es ist ein Drahtbruch oder Kurzschluss an einem der Encoder-Eingängen aufgetreten
 | FALSE | Es liegt kein „Open circuit“ - Fehler vor.
0xA0n0:01 „Error A“ | TRUE | Ein „Open circuit“ - Fehler (Drahtbruch oder Kurzschluss) an Encoder-Eingang A ist aufgetreten.
 | FALSE | Es liegt kein „Open circuit“ - Fehler vor.
Hinweis
Differenzieller und Single-Ended Anschluss
•
Das RS422-Signal überträgt eine Differenzspannung, dadurch ist das Signal störunempfindlicher im Vergleich zu einem Single-Ended-Signal.
⇨
Soll das Gebersignal über längere Entfernung oder mit höheren Frequenzen übertragen werden, wird ein Encoder mit RS422-Signalen empfohlen.
⇨
Es sollten geschirmte und paarig verdrillte (Twisted Pair) Leitungen verwendet werden.
Signaltyp TTL (single ended) und Open-Collector
Bei folgenden Einstellungen im „Counter mode“ (0x80n1:1D) wird ein Spannungspegel von nominell 2,0 V bis 6,0 V mit einem Strom von min. 2,1 mA erwartet:
▪
2: Encoder TTL (single ended)
▪
3: Counter TTL (single ended)
▪
4: Encoder open collector
▪
5: Counter open collector
Für TTL-Encoder ist eine Grenzfrequenzen bis 4 Mio. Inkremente pro Sekunde, bei 4-fach Auswertung, zulässig. Dies entspricht 1 MHz.
Für Open-Collector-Encoder ist eine Grenzfrequenz bis 400.000 Inkremente pro Sekunde, bei 4-fach Auswertung, zulässig. Dies entspricht 100 kHz.
TTL, Open Collector Signalpegel (Single Ended Signal)
Legende:
VIN | Single ended Eingangsspannung
A, B, C | Encodersignale A, B, C
Hinweis
Drahtbrucherkennung (open circuit detection)
Die Drahtbrucherkennung (Open circuit detection) funktioniert prinzipbedingt nicht bei Single-Ended-Leitungen: TTL und Open Collector Encodern sowie Zählern/Impulsgebern.
Hinweis
Beschaltung Open Collector
Bei der Auswahl eines Open Collector Encoders unter „Counter mode“ (0x80n1:1D) werden die Eingänge A, B, C über PullUp Widerstände (1 kOhm) auf 5 V gelegt.


Eingänge Latch und Gate/Latch

Technische Eigenschaften [image] Eingänge Latch und Gate/Latch
Eingänge Latch und Gate/Latch
Die Klemme stellt zwei digitale 24 VDC Eingänge zur Verfügung. Die Funktion dieser Eingänge ist dem jeweiligen Kapitel zu entnehmen.
▪
Eingang Latch (Latch extern)
▪
Eingang Gate/Latch (Latch extern 2)
Beide Eingänge sind Typ 3 Eingänge gemäß EN61131-2, mit einer mind. Pulsdauer von tON > 1µs.
Digitaler Eingang Typ 3, gemäß EN61131-2 | Spannung [V] | Eingangsstrom [mA]
Signalspannung „0 - LOW“ | -3 V … +5 V typ. | 0 mA … 2,6 mA typ.
Signalspannung „1 - HIGH“ | 11 V … 30 V typ. | 2,5 mA typ.
Kennlinie Eingang 24 VDC Typ 3
Hinweis
Prellen beachten bei Verwendung von elektromechanischen Schaltern und Tastern
Bei der Verwendung von elektromechanischen Schaltern und Tastern kann bei Betätigung des Schalters bzw. Tasters ein mehrfaches Schließen und Öffnen des Tasters auftreten, das sogenannte Prellen.
•
Ist die Funktion 0x80n0:22 „Enable continuous latch extern“ oder 0x80n0:23 „Enable continuous latch extern 2“ aktiv, dann wird durch das Prellen der gespeicherte Wert mehrfach überschrieben. Dadurch erhält man nicht den zuerst, sondern den zuletzt gespeicherten Wert in Parameter 0x60n0:12 „Latch value“ bzw. 0x60n0:22 „Latch value 2“.
•
Ist die Funktion deaktiviert, so wird nur das erste Öffnen oder Schließen des Schalters bzw. Tasters erkannt und als Wert im entsprechenden Parameter gespeichert. Weitere Vorgänge bleiben unberücksichtigt.


Eingang Status-Input

Technische Eigenschaften [image] Eingang Status-Input
Eingang Status-Input
Die Klemme stellt einen Status Input Eingang zur Verfügung. Die Funktion ist Kapitel Eingang Status Input zu entnehmen.
Der Eingang ist 5 V kompatibel.
Digitaler Eingang, 5 V TTL Eingangscharakteristik | Spannung [V] | Eingangsstrom [mA]
Signalspannung „0 - LOW“ | -6 V … + 0,8 V | 5 mA typ.
Signalspannung „1 - HIGH“ | +2 V … +6 V | 0 mA typ.
Hinweis
Beschaltung „Status Input“-Eingang
In der Klemme ist der „Status Input“-Eingang intern über einen PullUp Widerstand (1 kOhm) auf 5 V gelegt. Der Encoder-Ausgang muss das Signal aktiv gegen GND ziehen. Der Widerstand ist dabei so zu dimensionieren, dass er < 120 Ohm beträgt.
Die externe Speisung wird nicht empfohlen. Wird extern gespeist sind max. 5 V gegen GND zulässig.


Geberbetriebsspannung (Supply voltage)

Technische Eigenschaften [image] Geberbetriebsspannung (Supply voltage)
Geberbetriebsspannung (Supply voltage)
Die Geberversorgung wird intern aus den 24 V der Powerkontakte erzeugt. In Index 0x80n1:17 „Supply voltage“ kann die Geberversorgung eingestellt werden. Voreingestellt ist eine Betriebsspannung von 5 VDC. Es können Spannungswerte 5 VDC, 12 VDC und 24 VDC ausgewählt werden. Die Einstellungen erfolgen für jeden Kanal separat.
Es gelten folgende Toleranzen
Spannungsbereich | Toleranz
5 VDC | +/- 5 % (4,75 V … 5,25 V)
12 VDC | +/- 10 % (10,8 V … 13,2 V)
24 VDC | -15 % bis +20 % (20,4 V … 28,8 V)
Hinweis
Geberversorgungsspannung einstellen
•
Stellen Sie vor dem Umschalten auf eine höhere Spannung sicher, dass der angeschlossene Encoder den gewählten Spannungsbereich unterstützt!
•
Zum Beschreiben von 0x80n1:17 „Supply voltage“ müssen Sie in Index 0xF008 „Code word“ den Wert 0x72657375 (ASCII: „user“) setzen.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, in der Regel ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
System Manager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z. B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z. B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z. B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach unten genanntem Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z. B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT System Manager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timer-Einstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel „Set SM-Watchdog“
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0...65535. Zusammen mit einem Multiplier in einem Bereich von 1...65535 deckt dies einen Watchdog-Zeitraum von 0...~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CAN application protocol over EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in zwei Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem „0x“ als Kennzeichen des hexadezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO („Eingang“ aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO („Ausgang“ aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen in der Regel. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis.
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter „CoE-Online“
In der oberen Abbildung sind die im Gerät „EL2502“ verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion „NoCoeStorage“
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. Karteireiter „CoE-Online“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im „SetValue“-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im System Manager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom System Manager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade „verfügbar“, also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z. B. hat eine 4 kanalige Analogeingangsklemme 0...10 V auch vier logische Kanäle und damit vier gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter „n“ für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für erhöhte mechanische Belastbarkeit
•
Anschluss
•
Einbaulagen
•
Positionierung von passiven Klemmen
•
EL5102 - Anschlussbelegung
•
EL5102 - LEDs


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für erhöhte mechanische Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für erhöhte mechanische Belastbarkeit
Montagevorschriften für erhöhte mechanische Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. Empfohlene Abstände bei Standard Einbaulage). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung „unten“ ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. Empfohlene Abstände bei Standard Einbaulage wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als zwei passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


EL5102 - Anschlussbelegung

Montage und Verdrahtung [image] EL5102 - Anschlussbelegung
EL5102 - Anschlussbelegung
EL5102 - Anschlussbelegung
Anschlussbelegung linke Seite (Encoder 1)
Klemmstelle | Nr. | Kommentar
A1 | 1 | Encoder-Eingang A1
B1 | 2 | Encoder-Eingang B1
C1 | 3 | Encoder-Eingang C1
Status Input 1 | 4 | Status-Eingang 1 Der Status Input-Eingang ist intern über einen PullUp-Widerstand auf 5 V gelegt. Der Encoder-Störmelde-Ausgang muss das Signal aktiv gegen GND ziehen. Die externe Speisung wird nicht empfohlen. Wird extern gespeist sind max. 5 V gegen GND zulässig.
+ Ue1 | 5 | Encoder-Versorgung (5 V default, parametrierbar 12 V, 24 V)
-Uo1 | 6 | 0 V Encoder-Versorgung
Latch 1 | 7 | Eingang Latch extern
n.c. | 8 | nicht verbunden
A̅1 | 9 | Encoder Eingang A̅1
B̅1 | 10 | Encoder Eingang B̅1
C̅1 | 11 | Encoder Eingang C̅1
n.c. | 12 | Klemmstelle nicht beschalten
+ Ue1 | 13 | Encoder-Versorgung (5 V default, parametrierbar 12 V, 24 V)
-Uo1 | 14 | 0 V Encoder-Versorgung
Gate 1 | 15 | Eingang Gate 1, kann als Gate-Eingang und als Latch extern 2-Eingang für Encoder 1 genutzt werden. Dieser Eingang wird auch als Gate/Latch 1 - Eingang bezeichnet.
n.c. | 16 | nicht verbunden
Anschlussbelegung rechte Seite (Encoder 2)
Klemmstelle | Nr. | Kommentar
A2 | 1' | Encoder-Eingang A2
B2 | 2' | Encoder-Eingang B2
C2 | 3' | Encoder-Eingang C2
Status Input 2 | 4' | Status-Eingang 2 Der Status Input-Eingang ist intern über einen PullUp-Widerstand auf 5 V gelegt. Der Encoder-Störmelde-Ausgang muss das Signal aktiv gegen GND ziehen. Die externe Speisung wird nicht empfohlen. Wird extern gespeist sind max. 5 V gegen GND zulässig
+ Ue2 | 5' | Encoder-Versorgung (5 V default, parametrierbar 12 V, 24 V)
-Uo2 | 6' | 0 V Encoder-Versorgung
Latch 2 | 7' | Eingang Latch extern
n.c. | 8' | nicht verbunden
A̅2 | 9' | Encoder Eingang A̅2
B̅2 | 10' | Encoder Eingang B̅2
C̅2 | 11' | Encoder Eingang C̅2
n.c. | 12' | Klemmstelle nicht beschalten
+ Ue2 | 13' | Encoder-Versorgung (5 V default, parametrierbar 12 V, 24 V)
-Uo2 | 14' | 0 V Encoder-Versorgung
Gate 2 | 15' | Eingang Gate 2, kann als Gate-Eingang und als Latch extern 2-Eingang für Encoder 2 genutzt werden. Dieser Eingang wird auch als Gate/Latch 2 - Eingang bezeichnet.
n.c. | 16' | nicht verbunden
Hinweis
Geberversorgungsspannung einstellen
•
Stellen Sie vor dem Umschalten auf eine höhere Spannung sicher, dass der angeschlossene Encoder den gewählten Spannungsbereich unterstützt!
•
Zum Beschreiben von 0x80n1:17 „Supply voltage“ müssen Sie in Index 0xF008 „Code word“ den Wert 0x72657375 (ASCII: „user“) setzen.
Weiterführende Informationen
•
RS422-Mode
•
TTL-Mode
•
Open Collector-Mode


RS422-Mode

Montage und Verdrahtung [image] EL5102 - Anschlussbelegung [image] RS422-Mode
RS422-Mode
Hinweis
Differenzieller und Single-Ended Anschluss
•
Das RS422-Signal überträgt eine Differenzspannung, dadurch ist das Signal störunempfindlicher im Vergleich zu einem Single-Ended-Signal.
⇨
Soll das Gebersignal über längere Entfernung oder mit höheren Frequenzen übertragen werden, wird ein Encoder mit RS422-Signalen empfohlen.
⇨
Es sollten geschirmte und paarig verdrillte (Twisted Pair) Leitungen verwendet werden.
Anschluss von RS422-Encodern mit oder ohne Nullimpuls
Anschluss Encoder RS422 - Mode mit Nullimpuls
Hinweise zum Anschluss
•
Bei Verwendung eines Encoders ohne Nullimpuls C werden die Klemmstellen für die C-Spur nicht beschaltet.
Anschluss von RS422-Zählern / Impulsgebern mit oder ohne Nullimpuls
Anschluss Zähler / Impulsgeber RS422 - Mode mit Nullimpuls
Hinweise zum Anschluss
•
Bei Anschluss eines Zählers / Impulsgebers gibt die B-Spur die Zählrichtung vor.
Im RS422-Mode wird auf der B̅-Spur ein differentielles Signal erwartet.
•
Bei Verwendung eines Zählers / Impulsgebers ohne Nullimpuls C werden die Klemmstellen für die C-Spur nicht beschaltet.


TTL-Mode

Montage und Verdrahtung [image] EL5102 - Anschlussbelegung [image] TTL-Mode
TTL-Mode
Anschluss von TTL-Encodern mit oder ohne Nullimpuls
Anschluss Encoder TTL - Mode mit Nullimpuls
Hinweise zum Anschluss
•
Im TTL-Mode werden die inversen Eingänge nicht beschaltet.
•
Bei Verwendung eines Encoders ohne Nullimpuls C werden die Klemmstellen für die C-Spur nicht beschaltet.
Anschluss von TTL-Zählern / Impulsgebern mit oder ohne Nullimpuls
Anschluss Zähler / Impulsgeber TTL - Mode mit Nullimpuls
Hinweise zum Anschluss
•
Im TTL-Mode werden die inversen Eingänge nicht beschaltet.
•
Bei Anschluss eines Zählers / Impulsgebers gibt die B-Spur die Zählrichtung vor.
Der Eingang B̅ wird nicht beschaltet.
•
Bei Verwendung eines Zählers / Impulsgebers ohne Nullimpuls C werden die Klemmstellen für die C-Spur nicht beschaltet.


Open Collector-Mode

Montage und Verdrahtung [image] EL5102 - Anschlussbelegung [image] Open Collector-Mode
Open Collector-Mode
Anschluss von Open Collector-Encodern mit oder ohne Nullimpuls
Anschluss Encoder Open Collector - Mode mit Nullimpuls
Hinweise zum Anschluss
•
Im Open Collector-Mode werden die inversen Eingänge nicht beschaltet.
•
Bei Verwendung eines Encoders ohne Nullimpuls C werden die Klemmstellen für die C-Spur nicht beschaltet.
Anschluss von Open Collector-Zählern / Impulsgebern mit oder ohne Nullimpuls
Anschluss Zähler / Impulsgeber Open Collector - Mode mit Nullimpuls
Hinweise zum Anschluss
•
Im Open Collector-Mode werden die inversen Eingänge nicht beschaltet.
•
Bei Anschluss eines Zählers / Impulsgebers gibt die B-Spur die Zählrichtung vor.
Der Eingang B̅ wird nicht beschaltet.
•
Bei Verwendung eines Zählers / Impulsgebers ohne Nullimpuls C werden die Klemmstellen für die C-Spur nicht beschaltet.


EL5102 - LEDs

Montage und Verdrahtung [image] EL5102 - LEDs
EL5102 - LEDs
EL5102 - LEDs
LEDs linke Seite
Nr.
Name
Farbe
Beschreibung
1
A1
grün, rot
grün an
jeweils TRUE Pegel anzeigend
2
B1
rot an
Es liegt ein Drahtbruch am jeweiligen Eingang vor. Die Diagnose ist nur möglich wenn die folgenden drei Bedingungen erfüllt sind.
▪
Der entsprechende Eingang ist differentiell verdrahtet. Entspricht:
„Counter mode“ 0x8001:1D =0 (Encoder RS422 (diff. Input)) oder
„Counter mode“ 0x8001:1D =1 (Counter RS422 (diff. Input))
▪
Die „Error Detection“ des jeweiligen Eingangs ist aktiviert:
„Error Detection A“ 0x8000:0B = TRUE
„Error Detection B“ 0x8000:0C = TRUE
„Error Detection C“ 0x8000:0D = TRUE.
▪
Die differentielle Spannung VID Low < typ. 0,67 V ist (Änderungen vorbehalten).
3
C1
4
Status Input 1
rot
Störmelde-Eingang von Drehgeber. Eingang ist intern über ein PullUp Widerstand auf 5 V gelegt. Der Encoder-Ausgang muss das Signal aktiv gegen GND ziehen.
an
Ausgang am Encoder aktiv, es liegt eine Störmeldung am Encoder an oder eine Überspannung am Eingang
aus
Ausgang am Encoder nicht aktiv, es liegt keine Störmeldung an
5
PowerENC.ch1
grün
Geberversorgungsspannung für Kanal 1 ist vorhanden
7
Latch 1
grün
leuchtet, wenn ein Signal (+24 V) am Latch 1-Eingang anliegt
9
Run
grün
Diese LED gibt den Betriebszustand der Klemme wieder:
aus
Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware Updates der Klemme
blinkend
Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
Einzelblitz
Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks.
Ausgänge bleiben im sicheren Zustand
an
Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
10
Diag
rot
Initialisierungsprozess aktiv oder Zustand der EtherCAT State Machine: BOOT
15
Gate 1
grün
leuchtet, wenn ein Signal (+24 V) am Gate 1-Eingang anliegt
LEDs rechte Seite
Nr.
Name
Farbe
Beschreibung
1
A2
grün, rot
grün an
jeweils TRUE Pegel anzeigend
2
B2
rot an
Es liegt ein Drahtbruch am jeweiligen Eingang vor. Die Diagnose ist nur möglich wenn die folgenden drei Bedingungen erfüllt sind.
▪
Der entsprechende Eingang ist differentiell verdrahtet. Entspricht:
„Counter mode“ 0x8011:1D =0 (Encoder RS422 (diff. Input)) oder
„Counter mode“ 0x8011:1D =1 (Counter RS422 (diff. Input))
▪
Die „Error Detection“ des jeweiligen Eingangs ist aktiviert:
„Error Detection A“ 0x8010:0B = TRUE
„Error Detection B“ 0x8010:0C = TRUE
„Error Detection C“ 0x8010:0D = TRUE.
▪
Die differentielle Spannung VID Low < typ. 0,67 V ist (Änderungen vorbehalten).
3
C2
4
Status Input 2
rot
Störmelde-Eingang von Drehgeber. Eingang ist intern über ein PullUp Widerstand auf 5 V gelegt. Der Encoder-Ausgang muss das Signal aktiv gegen GND ziehen.
an
Ausgang am Encoder aktiv, es liegt eine Störmeldung am Encoder an oder eine Überspannung am Eingang
aus
Ausgang am Encoder nicht aktiv, es liegt keine Störmeldung an
5
PowerENC.ch2
grün
Geberversorgungsspannung für Kanal 2 ist vorhanden
7
Latch 2
leuchtet, wenn ein Signal (+24 V) am Latch 2-Eingang anliegt
15
Gate 2
leuchtet, wenn ein Signal (+24 V) am Gate 2-Eingang anliegt


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT System Manager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d. h. „devices“ beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die „Scan“ - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
„offline“: der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
„online“: die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 VDC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 VDC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (System Manager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT „lokal“ oder per „remote“ zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT „lokal“ eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per „remote“ anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter „Aktionen“ → „Auswahl des Zielsystems...“, über das Symbol „ [image] “ oder durch Taste „F8“ wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels „Suchen (Ethernet)...“ wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter „Enter Host Name / IP:“ einzutragen (wie rot gekennzeichnet)
▪
einen „Broadcast Search“ durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den System Manager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl „Gerät Suchen..“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 System Manager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o. ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d. h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei („*.tpy“) enthält u.a. Variablenzuordnungen und ist dem System Manager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von „Kontinuierlich“ und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z. B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von „Goto Link Variable“ am Beispiel von „MAIN.bEL1004_Ch4“
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d. h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit „Ja“ zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT „lokal“ oder per „remote“ zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT „lokal“ eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per „remote“ anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels „Suchen (Ethernet)...“ wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter „Enter Host Name / IP:“ einzutragen (wie rot gekennzeichnet)
▪
einen „Broadcast Search“ durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o. ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d. h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in „SPS“
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm „Main“ des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von „Kontinuierlich“ und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z. B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von „MAIN.bEL1004_Ch4“
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d. h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Hinweis zur Art der Variablen-Zuordnung
Diese folgende Art der Variablen Zuordnung kann erst ab der TwinCAT Version V3.1.4024.4 verwendet werden und ist ausschließlich bei Klemmen mit einem Mikrocontroller verfügbar.
In TwinCAT ist es möglich eine Struktur aus den gemappten Prozessdaten einer Klemme zu erzeugen. Von dieser Struktur kann dann in der SPS eine Instanz angelegt werden, so dass aus der SPS direkt auf die Prozessdaten zugegriffen werden kann, ohne eigene Variablen deklarieren zu müssen.
Beispielhaft wird das Vorgehen an der EL3001 1-Kanal-Analog-Eingangsklemme -10…+10 V gezeigt.
1.
Zuerst müssen die benötigten Prozessdaten im Reiter „Prozessdaten“ in TwinCAT ausgewählt werden.
2.
Anschließend muss der SPS Datentyp im Reiter „PLC“ über die Check-Box generiert werden.
3.
Der Datentyp im Feld „Data Type“ kann dann über den „Copy“-Button kopiert werden.
Erzeugen eines SPS Datentyps
4.
In der SPS muss dann eine Instanz der Datenstruktur vom kopierten Datentyp angelegt werden.
Instance_of_struct
5.
Anschließend muss die Projektmappe erstellt werden. Das kann entweder über die Tastenkombination „STRG + Shift + B“ gemacht werden oder über den Reiter „Erstellen“/ „Build“ in TwinCAT.
6.
Die Struktur im Reiter „PLC“ der Klemme muss dann mit der angelegten Instanz verknüpft werden.
Verknüpfung der Struktur
7.
In der SPS können die Prozessdaten dann über die Struktur im Programmcode gelesen bzw. geschrieben werden.
Lesen einer Variable aus der Struktur der Prozessdaten
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration
•
NC - Konfiguration (Motion)


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im System Manager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im System Manager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter „Kompatible Geräte“ aufgeführt sind, über den „Install“ Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung „Internet Protocol TCP/IP“ eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z. B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → „Update EtherCAT Device Descriptions“
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verfügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung „EL2521-0025-1018“ zusammen aus:
▪
Familienschlüssel „EL“
▪
Name „2521“
▪
Typ „0025“
▪
und Revision „1018“
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z. B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der „üblichen“ Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z. B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u. U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei „OnlineDescription0000...xml“ an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom System Manager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung Kennzeichnung einer online erfassten ESI am Beispiel EL2521).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
„OnlineDescription0000...xml“ löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei „OnlineDescription0000...xml“ legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z. B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der System Manager bei Online-Zugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → „Update EtherCAT Device Descriptions“.
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z. B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die „Offline-Konfiguration“ möglich. Dann müssen alle Komponenten händisch in der Konfiguration z. B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte „Scannen“ vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der „EtherCAT“ Typ auszuwählen. „EtherCAT Automation Protocol via EL6601“ ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z. B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
„Ethernet“: Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
„E-Bus“: LVDS „Klemmenbus“,„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als „Extended Information“ eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox „Show Hidden Devices“ zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d. h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt „I/O Devices“ zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als „RT-Ethernet“ Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als „EtherCAT Device“ angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung „OK“ im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Default-Zustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d. h. aus der PLC „B.pro“ oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von „B.tsm“ oder gar „B.pro“ ist somit nicht nötig. Die Serienmaschinen können weiterhin mit „B.tsm“ und „B.pro“ gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration „B.tsm“ sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht „B.tsm“ verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration „B2.tsm“ ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. Beispielhafte Online-Anzeige befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im „Actual State“ OP sein
▪
„Frames/sec“ soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig „LostFrames“- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d. h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel „Hinweise zu ESI/XML“.
▪
Teilnehmer werden nicht richtig erkannt
Ursachen können sein
–
fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
–
Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z. Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder „Copy“ sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s. o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der „Extended Information“ wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtigung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button „Ignore“)
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtigung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d. h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch „OK“ in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog „Change to Compatible Type…“ (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z. B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z. B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z. B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im System Manager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten „intelligenten“ EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird davon abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist laut Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. Konfigurieren der Prozessdaten.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: Wählen Sie im Reiter „Process Data“ den Input- oder Output-Syncmanager (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im System Manager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv.
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes („Predefined PDO-settings“) verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann laut ESI-Beschreibung ein PDO als „fixed“ mit dem Flag „F“ gekennzeichnet sein (Abb. Konfigurieren der Prozessdaten, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet („Edit“). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration „G“ unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen „invalid SM cfg“ wird im System Manager ausgegeben: Diese Fehlermeldung „invalid SM IN cfg“ oder „invalid SM OUT cfg“ bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in „<>“ eingeschlossen ist (z. B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE - Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE - Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slaves an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


NC - Konfiguration (Motion)

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] NC - Konfiguration (Motion)
NC - Konfiguration (Motion)
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen und entsprechend der Installationsanweisungen installiert werden.
Nachfolgend wird die Achsen-Konfiguration und Verknüpfung im TwinCAT System Manager (Config mode) am Beispiel der EL5151 beschrieben. Gehen Sie bitte wie folgt vor:
Hinzufügen eines Motion-Elements
Klicken Sie mit der rechten Maustaste auf Motion
Wählen Sie im Pull-down Menü Neues Element hinzufügen… (Abb. Motion, Element hinzufügen).
Motion, Element hinzufügen
Wählen sie den Konfigurations-Typ NC/PTP NCI Configuration.
Bennen Sie die Task und bestätigen Sie mit OK (Abb. Typ auswählen, Task benennen und bestätigen)
Typ auswählen, Task benennen und bestätigen
Einfügen einer Achse
Klicken Sie mit der rechten Maustaste auf Achsen
Wählen Sie im Pull-down Menü Neues Element hinzufügen (Abb. Achse einfügen).
Achse einfügen
Wählen Sie einen Namen für die Axe
Wählen Sie den Typ Encoder Achse und bestätigen Sie mit OK (Abb. Achse benennen und Typ auswählen)
Achse benennen und Typ auswählen
Verknüpfung des Encoders
Nach der Anwahl des Karteireiters NC-Encoder wählen Sie im Pulldow-Menü Typ den Encoder an KL5101/Kl5111/IP5109/EL5101/EL5151/Profil MDP 511 (Abb. Auswahl des Encoders)
Klicken Sie den Button Verknüpft mit...
Auswahl des Encoders
Wählen Sie die Klemme EL5151 und bestätigen Sie mit OK (Abb. Encoder-Klemme auswählen und bestätigen)
Encoder-Klemme auswählen und bestätigen
Anzeige der verknüpften Ein- und Ausgänge
Die entsprechenden Eingänge und Ausgänge der EL5151 sind nun mit der NC-Task verknüpft (Abb. Verknüpfte Ein- und Ausgänge der EL5151 mit der NC-Task)
Verknüpfte Ein- und Ausgänge der EL5151 mit der NC-Task


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. Auswahl an Diagnoseinformationen eines EtherCAT Slave entspricht auch den Variablenfarben im System Manager, siehe Abb. Grundlegende EtherCAT Slave Diagnose in der PLC.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d. h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. Grundlegende EtherCAT Slave Diagnose in der PLC ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. EL3102, CoE-Verzeichnis:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter „Process Data“, „DC“, „Startup“ und „CoE-Online“ werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahme-Tool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog „Erweiterte Einstellung“ beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z. B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z. B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechenden Positionen im Klemmenstrang Einspeiseklemmen (z. B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung „E-Bus Power of Terminal...“ im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EL5102 - Inbetriebnahme

EL5102 - Inbetriebnahme
EL5102 - Inbetriebnahme
Weiterführende Informationen
•
Übersicht Funktionen EL5102
•
Prozessdaten
•
Basisfunktionen
•
Erweiterte Funktionen
•
Eingänge
•
Diagnose
•
EL5102 - Objektbeschreibung und Parametrierung


Übersicht Funktionen EL5102

EL5102 - Inbetriebnahme [image] Übersicht Funktionen EL5102
Übersicht Funktionen EL5102
Die EL5102 bietet einen breiten Funktionsumfang. Die nachfolgende Tabelle gibt einen Überblick der zur Verfügung gestellten Funktionen. Die genaue Beschreibung ist den einzelnen Kapiteln zu entnehmen.
Für die Nutzung der erweiterten Funktionen sind die entsprechenden Funktionen über die „Predefined PDO Assignment“ auszuwählen. Die Zuordnung ist dem Kapitel „Prozessdaten“ zu entnehmen.
Basis-Funktionen | Beschreibung
Auswahl Encodertyp | Es können Encoder oder Zähler/Impulsgeber mit den Signalpegel nach RS422, TTL oder OpenCollector ausgewählt werden.
Geberbetriebsspannung | Die Encoderversorgung kann separat für jeden Kanal wahlweise auf 5 VDC, 12 VDC oder 24 V DC eingestellt werden.
Auswertung des Zählerwerts | Das Eingangssignal kann in 4-fach, 2-fach oder 1-fach Auswertung erfolgen.
Zählergrenzen | Es kann der Wertebereich festgelegt werden, innerhalb dessen gezählt wird.
Zählerüberlauf / Zählerunterlauf | Wird die Zählgrenze über- oder unterschritten, wird dieses in einem separaten Prozessdatum angezeigt.
Zählrichtung | Die Zählrichtung kann an die Anwendung angepasst werden.
Zählrichtungsumkehr | Es kann die Zählrichtung und eine Zählrichtungsumkehr detektiert und über die Prozessdaten ausgegeben werden. Diese Funktion kann auch zur Stillstandsüberwachung genutzt werden.
Zählerstand reset | Erlaubt einen wiederkehrenden Reset des Zählerstandes über den Nullimpuls C oder eine Flanke (positiv/negativ) am Latch extern-Eingang.
Zählerstand setzen | Der Zählerstand kann zur Laufzeit auf einen vorgegebenen Zählerwert über eine SPS Variable, den Nullimpuls C oder eine Flanke (positiv/negativ) am Latch extern-Eingang gesetzt werden.
Zählerstand speichern | Der aktuelle Zählerstand kann, unabhängig von der Zykluszeit, in einem separaten Prozessdatum über eine Flanke (positiv/negativ) am Latch extern- und Gate/Latch-Eingang oder den Nullimpulse C gespeichert werden. Es kann parametriert werden, ob die Funktion bei jeder externen Flanke oder nur einmalig nach jeder Aktivierung ausgeführt wird. Durch die Nutzung beider Latch-Eingänge kann auch eine Werkstückmessung realisiert werden.
Zählerstand sperren | Der Zählerstand kann über eine Flanke (positiv/negativ) am Gate-Eingang oder eine SPS Variable gesperrt werden.
Erweiterte Funktionen | Beschreibung
Frequenzmessung | Die mittlere Frequenz des Eingangssignals innerhalb eines vorgegebenen Zeitfensters kann direkt ausgegeben werden.
Periodendauermessung | Die Periodendauer der letzten Periode innerhalb des SPS-Zyklus kann direkt ausgegeben werden.
Geschwindigkeits-, Drehzahlberechnung | Die mittlere Geschwindigkeit bzw. Drehzahl des Eingangssignals innerhalb eines vorgegebenen Zeitfensters kann direkt ausgegeben werden.
Duty Cycle Messung | Das Verhältnis der Impulsdauer tON zu Periodendauer T im letzten SPS Zyklus kann direkt ausgegeben werden.
Timestamp | Es kann je ein Zeitstempel (Timestamp), basierend auf dem Distributed-Clocks-System (DC), für den letzten Zählimpuls, den Nullimpuls und die Latch extern- und Latch extern 2-Eingänge ausgegeben werden.
Mikroinkremente | Erlaubt zwischen den gezählten Encoderinkrementen zusätzliche Inkremente (256 Schritte) zu interpolieren und somit die Auflösung des Zählwertes zu erhöhen.
Einstellbare Störimpulsfilter | Um Störungen zu unterdrücken, kann für die Eingangssignale jeweils ein Filter eingestellt werden.
Diagnosedaten | Über „DiagMessages“ werden an den EtherCAT Master / TwinCAT Fehlermeldungen mitgeteilt.
Prozessdaten | Beschreibung
Betriebsmodi | Der Umfang der Prozessdaten kann über das „Predefined PDO Assignment“ ausgewählt werden.
Betriebsart - Synchronität | Neben der framegetriggerten Betriebsart (SM-Betrieb) kann die Arbeitsweise auch durch die Distributed Clocks synchronisiert werden.
Beschreibung der Eingänge | Beschreibung
Nullimpuls C | Bei Inkremental-Encodern wird eine volle Umdrehung durch eine Sondermarke den Nullimpuls C gekennzeichnet. Dieser kann genutzt werden zum Reset, Setzen und Speichern des Zählerstands.
Latch extern | Es wird ein Latch-Eingang, für 24 VDC-Signale mit einer min. Pulsdauer von tON > 1 µs, zur Verfügung gestellt. Dieser kann genutzt werden zum Reset, Setzen und Speichern des Zählerstands.
Gate/Latch | Es wird ein externer Gate-Eingang, für 24 VDC-Signale mit einer min. Pulsdauer von tON > 1 µs, zur Verfügung gestellt. Dieser kann genutzt werden zum Reset, Setzen und Speichern des Zählerstands.
Status Input | Besitzt der Encoder einen Störmeldeausgang, so kann dieser ausgewertet werden.


Prozessdaten

EL5102 - Inbetriebnahme [image] Prozessdaten
Prozessdaten
Weiterführende Informationen
•
Sync Manager (SM)
•
PDO - Zuordnung
•
Predefined PDO Assignment
•
Betriebsart - Synchronität
•
EtherCAT Zykluszeit
•
„Legacy EL5101“-Mode


Sync Manager (SM)

EL5102 - Inbetriebnahme [image] Prozessdaten [image] Sync Manager (SM)
Sync Manager (SM)
Der Umfang der angebotenen Prozessdaten kann über den Reiter „Process Data“ verändert werden (siehe folgende Abb. Karteireiter Prozessdaten SM3, EL5102 (default)).
Eine detaillierte Beschreibung zur Einstellung der Prozessdaten finden Sie im Kapitel EtherCAT Teilnehmerkonfiguration.
EL5102 - Karteireiter Prozessdaten SM3 (default)


PDO - Zuordnung

EL5102 - Inbetriebnahme [image] Prozessdaten [image] PDO - Zuordnung
PDO - Zuordnung
Die EL5102 bietet einen großen Umfang an Funktionen und somit auch ein großen Umfang an Prozessdaten.
Weiterführende Informationen
•
SM3 - Inputs (0x1A00 .. 0x1A19)
•
SM2 - Outputs (0x1600 .. 0x160B)


SM3 - Inputs (0x1A00 .. 0x1A19)

EL5102 - Inbetriebnahme [image] Prozessdaten [image] PDO - Zuordnung [image] SM3 - Inputs (0x1A00 .. 0x1A19)
SM3 - Inputs (0x1A00 .. 0x1A19)
Channel 1 (0x1A00 .. 0x1A0C):
0x1A00 - ENC Status Channel 1 (16.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6000:01 - Status_Latch C valid (0.1) 0x6000:02 - Status_Latch extern valid (0.1) 0x6000:03 - Status_Set counter done (0.1) 0x6000:04 - Status_Counter underflow (0.1) 0x6000:05 - Status_Counter overflow (0.1) 0x6000:06 - Status_Status of input status (0.1) 0x6000:07 - Status_Open circuit (0.1) 0x6000:08 - Status_Extrapolation stall (0.1) 0x6000:09 - Status_Status of input A (0.1) 0x6000:0A - Status_Status of input B (0.1) 0x6000:0B - Status_Status of input C (0.1) 0x6000:0C - Status_Status of input gate (0.1) 0x6002:0D - Status_Status Diag (0.1) 0x6002:0E - Status_Status TxPDO State (0.1) 0x6002:0F - Status_Input cycle counter (0.2) 0x6002:11 - Status_Software gate valid (0.1) 0x6002:12 - Status_Latch extern 2 valid (0.1) 0x6002:13 - Status_Direction inversion detected (0.1) 0x6002:14 - Status_Status of extern Latch (0.1) 0x6002:15 - Status_Counter value out of range (0.1) 0x6000:11 - Counter value (4.0) 0x6000:12 - Latch value (4.0) 0x6000:22 - Latch value 2 (4.0) | 0x1A01 - ENC Status Compact Channel 1 (10.0) 0x1A02 - ENC Status Counter Channel 1 (8.0) 0x1A03 - ENC Status Compact Counter Channel 1 (6.0) 0x1A04 - ENC Status Legacy Channel 1 (10.0) 0x1A05 - ENC Status Compact Legacy Channel 1 (6.0)
0x1A01 - ENC Status Compact Channel 1 (10.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6000:01 - Status_Latch C valid (0.1) 0x6000:02 - Status_Latch extern valid (0.1) 0x6000:03 - Status_Set counter done (0.1) 0x6000:04 - Status_Counter underflow (0.1) 0x6000:05 - Status_Counter overflow (0.1) 0x6000:06 - Status_Status of input status (0.1) 0x6000:07 - Status_Open circuit (0.1) 0x6000:08 - Status_Extrapolation stall (0.1) 0x6000:09 - Status_Status of input A (0.1) 0x6000:0A - Status_Status of input B (0.1) 0x6000:0B - Status_Status of input C (0.1) 0x6000:0C - Status_Status of input gate (0.1) 0x6002:0D - Status_Status Diag (0.1) 0x6002:0E - Status_Status TxPDO State (0.1) 0x6002:0F - Status_Input cycle counter (0.2) 0x6002:11 - Status_Software gate valid (0.1) 0x6002:12 - Status_Latch extern 2 valid (0.1) 0x6002:13 - Status_Direction inversion detected (0.1) 0x6002:14 - Status_Status of extern Latch (0.1) 0x6002:15 - Status_Counter value out of range (0.1) 0x6000:11 - Counter value (2.0) 0x6000:12 - Latch value (2.0) 0x6000:22 - Latch value 2 (2.0) | 0x1A00 - ENC Status Channel 1 (16.0) 0x1A02 - ENC Status Counter Channel 1 (8.0) 0x1A03 - ENC Status Compact Counter Channel 1 (6.0) 0x1A04 - ENC Status Legacy Channel 1 (10.0) 0x1A05 - ENC Status Compact Legacy Channel 1 (6.0)
0x1A02 - ENC Status Counter Channel 1 (8.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6000:03 - Status_Set counter done (0.1) 0x6002:0D - Status_Status Diag (0.1) 0x6002:0E - Status_Status TxPDO State (0.1) 0x6002:0F - Status_Input cycle counter (0.2) 0x6002:11 - Status_Software gate valid (0.1) 0x6000:11 - Counter value (4.0) | 0x1A00 - ENC Status Channel 1 (16.0) 0x1A01 - ENC Status Compact Channel 1 (10.0) 0x1A03 - ENC Status Compact Counter Channel 1 (6.0) 0x1A04 - ENC Status Legacy Channel 1 (10.0) 0x1A05 - ENC Status Compact Legacy Channel 1 (6.0)
0x1A03 - ENC Status Compact Counter Channel 1 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6000:03 - Status_Set counter done (0.1) 0x6002:0D - Status_Status Diag (0.1) 0x6002:0E - Status_Status TxPDO State (0.1) 0x6002:0F - Status_Input cycle counter (0.2) 0x6002:11 - Status_Software gate valid (0.1) 0x6000:11 - Counter value (2.0) | 0x1A00 - ENC Status Channel 1 (16.0) 0x1A01 - ENC Status Compact Channel 1 (10.0) 0x1A02 - ENC Status Counter Channel 1 (8.0) 0x1A04 - ENC Status Legacy Channel 1 (10.0) 0x1A05 - ENC Status Compact Legacy Channel 1 (6.0)
0x1A04 - ENC Status Legacy Channel 1 (10.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6000:01 - Status_Latch C valid (0.1) 0x6000:02 - Status_Latch extern valid (0.1) 0x6000:03 - Status_Set counter done (0.1) 0x6000:04 - Status_Counter underflow (0.1) 0x6000:05 - Status_Counter overflow (0.1) 0x6000:06 - Status_Status of input status (0.1) 0x6000:07 - Status_Open circuit (0.1) 0x6000:08 - Status_Extrapolation stall (0.1) 0x6000:09 - Status_Status of input A (0.1) 0x6000:0A - Status_Status of input B (0.1) 0x6000:0B - Status_Status of input C (0.1) 0x6000:0C - Status_Status of input gate (0.1) 0x6000:0D - Status_Status of extern Latch(0.1) 0x6000:0E - Status_Sync error (0.1) 0x6000:0F - Status_ Status TxPDO State (0.1) 0x6000:10 - Status_ Status TxPDO Toggle (0.1) 0x6000:11 - Counter value (4.0) 0x6000:12 - Latch value (4.0) | 0x1A00 - ENC Status Channel 1 (16.0) 0x1A01 - ENC Status Compact Channel 1 (10.0) 0x1A02 - ENC Status Counter Channel 1 (8.0) 0x1A03 - ENC Status Compact Counter Channel 1 (6.0) 0x1A05 - ENC Status Compact Legacy Channel 1 (6.0)
0x1A05 - ENC Status Compact Legacy Channel 1 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6000:01 - Status_Latch C valid (0.1) 0x6000:02 - Status_Latch extern valid (0.1) 0x6000:03 - Status_Set counter done (0.1) 0x6000:04 - Status_Counter underflow (0.1) 0x6000:05 - Status_Counter overflow (0.1) 0x6000:06 - Status_Status of input status (0.1) 0x6000:07 - Status_Open circuit (0.1) 0x6000:08 - Status_Extrapolation stall (0.1) 0x6000:09 - Status_Status of input A (0.1) 0x6000:0A - Status_Status of input B (0.1) 0x6000:0B - Status_Status of input C (0.1) 0x6000:0C - Status_Status of input gate (0.1) 0x6000:0D - Status_Status of extern Latch(0.1) 0x6000:0E - Status_Sync error (0.1) 0x6000:0F - Status_ Status TxPDO State (0.1) 0x6000:10 - Status_ Status TxPDO Toggle (0.1) 0x6000:11 - Counter value (2.0) 0x6000:12 - Latch value (2.0) | 0x1A00 - ENC Status Channel 1 (16.0) 0x1A01 - ENC Status Compact Channel 1 (10.0) 0x1A02 - ENC Status Counter Channel 1 (8.0) 0x1A03 - ENC Status Compact Counter Channel 1 (6.0) 0x1A04 - ENC Status Legacy Channel 1 (10.0)
0x1A06 - ENC Frequency Channel 1 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6000:13 - Frequency value (4.0) | 0x1A07 - ENC Frequency Compact Channel 1 (2.0)
0x1A07 - ENC Frequency Compact Channel 1 (2.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6000:13 - Frequency value (2.0) | 0x1A06 - ENC Frequency Channel 1 (4.0)
0x1A08 - ENC Period Channel 1 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6000:14 - Period value (4.0) | 0x1A09 - ENC Period Compact Channel 1 (2.0)
0x1A09 - ENC Period Compact Channel 1 (2.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6000:14 - Period value (2.0) | 0x1A08 - ENC Period Channel 1 (4.0)
0x1A0A - ENC Duty Cycle Channel 1 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6000:23 - Duty cycle (2.0) 0x6000:24 - Duty cycle min (2.0) 0x6002:25 - Duty cycle max (2.0) | -
0x1A0B - ENC Timestamp Channel 1 (32.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6000:16 - Timestamp (8.0) 0x6000:1F - Timestamp C (8.0) 0x6000:20 - Timestamp latch (8.0) 0x6000:21 - Timestamp latch 2 (8.0) | 0x1A0C - ENC Timestamp Compact Channel 1 (16.0)
0x1A0C - ENC Timestamp Compact Channel 1 (16.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6000:16 - Timestamp (4.0) 0x6000:1F - Timestamp C (4.0) 0x6000:20 - Timestamp latch (4.0) 0x6000:21 - Timestamp latch 2 (4.0) | 0x1A0B - ENC Timestamp Channel 1 (32.0)
Channel 2 (0x1A0D .. 0x1A19):
0x1A0D - ENC Status Channel 2 (16.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6010:01 - Status_Latch C valid (0.1) 0x6010:02 - Status_Latch extern valid (0.1) 0x6010:03 - Status_Set counter done (0.1) 0x6010:04 - Status_Counter underflow (0.1) 0x6010:05 - Status_Counter overflow (0.1) 0x6010:06 - Status_Status of input status (0.1) 0x6010:07 - Status_Open circuit (0.1) 0x6010:08 - Status_Extrapolation stall (0.1) 0x6010:09 - Status_Status of input A (0.1) 0x6010:0A - Status_Status of input B (0.1) 0x6010:0B - Status_Status of input C (0.1) 0x6010:0C - Status_Status of input gate (0.1) 0x6012:0D - Status_Status Diag (0.1) 0x6012:0E - Status_Status TxPDO State (0.1) 0x6012:0F - Status_Input cycle counter (0.2) 0x6012:11 - Status_Software gate valid (0.1) 0x6012:12 - Status_Latch extern 2 valid (0.1) 0x6012:13 - Status_Direction inversion detected (0.1) 0x6012:14 - Status_Status of extern Latch (0.1) 0x6012:15 - Status_Counter value out of range (0.1) 0x6010:11 - Counter value (4.0) 0x6010:12 - Latch value (4.0) 0x6010:22 - Latch value 2 (4.0) | 0x1A0E - ENC Status Compact Channel 2 (10.0) 0x1A0F - ENC Status Counter Channel 2 (8.0) 0x1A10 - ENC Status Compact Counter Channel 2 (6.0) 0x1A11 - ENC Status Legacy Channel 2 (10.0) 0x1A12 - ENC Status Compact Legacy Channel 2 (6.0)
0x1A0E - ENC Status Compact Channel 2 (10.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6010:01 - Status_Latch C valid (0.1) 0x6010:02 - Status_Latch extern valid (0.1) 0x6010:03 - Status_Set counter done (0.1) 0x6010:04 - Status_Counter underflow (0.1) 0x6010:05 - Status_Counter overflow (0.1) 0x6010:06 - Status_Status of input status (0.1) 0x6010:07 - Status_Open circuit (0.1) 0x6010:08 - Status_Extrapolation stall (0.1) 0x6010:09 - Status_Status of input A (0.1) 0x6010:0A - Status_Status of input B (0.1) 0x6010:0B - Status_Status of input C (0.1) 0x6010:0C - Status_Status of input gate (0.1) 0x6012:0D - Status_Status Diag (0.1) 0x6012:0E - Status_Status TxPDO State (0.1) 0x6012:0F - Status_Input cycle counter (0.2) 0x6012:11 - Status_Software gate valid (0.1) 0x6012:12 - Status_Latch extern 2 valid (0.1) 0x6012:13 - Status_Direction inversion detected (0.1) 0x6012:14 - Status_Status of extern Latch (0.1) 0x6012:15 - Status_Counter value out of range (0.1) 0x6010:11 - Counter value (2.0) 0x6010:12 - Latch value (2.0) 0x6010:22 - Latch value 2 (2.0) | 0x1A0D - ENC Status Channel 2 (10.0) 0x1A0F - ENC Status Counter Channel 2 (8.0) 0x1A10 - ENC Status Compact Counter Channel 2 (6.0) 0x1A11 - ENC Status Legacy Channel 2 (10.0) 0x1A12 - ENC Status Compact Legacy Channel 2 (6.0)
0x1A0F - ENC Status Counter Channel 2 (8.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6010:03 - Status_Set counter done (0.1) 0x6012:0D - Status_Status Diag (0.1) 0x6012:0E - Status_Status TxPDO State (0.1) 0x6012:0F - Status_Input cycle counter (0.2) 0x6012:11 - Status_Software gate valid (0.1) 0x6010:11 - Counter value (4.0) | 0x1A0D - ENC Status Channel 2 (10.0) 0x1A0E - ENC Status Compact Channel 2 (10.0) 0x1A10 - ENC Status Compact Counter Channel 2 (6.0) 0x1A11 - ENC Status Legacy Channel 2 (10.0) 0x1A12 - ENC Status Compact Legacy Channel 2 (6.0)
0x1A10 - ENC Status Compact Counter Channel 2 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6010:03 - Status_Set counter done (0.1) 0x6012:0D - Status_Status Diag (0.1) 0x6012:0E - Status_Status TxPDO State (0.1) 0x6012:0F - Status_Input cycle counter (0.2) 0x6012:11 - Status_Software gate valid (0.1) 0x6010:11 - Counter value (2.0) | 0x1A0D - ENC Status Channel 2 (10.0) 0x1A0E - ENC Status Compact Channel 2 (10.0) 0x1A0F - ENC Status Counter Channel 2 (8.0) 0x1A11 - ENC Status Legacy Channel 2 (10.0) 0x1A12 - ENC Status Compact Legacy Channel 2 (6.0)
0x1A11 - ENC Status Legacy Channel 2 (10.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6010:01 - Status_Latch C valid (0.1) 0x6010:02 - Status_Latch extern valid (0.1) 0x6010:03 - Status_Set counter done (0.1) 0x6010:04 - Status_Counter underflow (0.1) 0x6010:05 - Status_Counter overflow (0.1) 0x6010:06 - Status_Status of input status (0.1) 0x6010:07 - Status_Open circuit (0.1) 0x6010:08 - Status_Extrapolation stall (0.1) 0x6010:09 - Status_Status of input A (0.1) 0x6010:0A - Status_Status of input B (0.1) 0x6010:0B - Status_Status of input C (0.1) 0x6010:0C - Status_Status of input gate (0.1) 0x6010:0D - Status_Status of extern Latch(0.1) 0x6010:0E - Status_Sync error (0.1) 0x6010:0F - Status_ Status TxPDO State (0.1) 0x6010:10 - Status_ Status TxPDO Toggle (0.1) 0x6010:11 - Counter value (4.0) 0x6010:12 - Latch value (4.0) | 0x1A0D - ENC Status Channel 2 (10.0) 0x1A0E - ENC Status Compact Channel 2 (10.0) 0x1A0F - ENC Status Counter Channel 2 (8.0) 0x1A10 - ENC Status Compact Counter Channel 2 (6.0) 0x1A12 - ENC Status Compact Legacy Channel 2 (6.0)
0x1A12 - ENC Status Compact Legacy Channel 2 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x6010:01 - Status_Latch C valid (0.1) 0x6010:02 - Status_Latch extern valid (0.1) 0x6010:03 - Status_Set counter done (0.1) 0x6010:04 - Status_Counter underflow (0.1) 0x6010:05 - Status_Counter overflow (0.1) 0x6010:06 - Status_Status of input status (0.1) 0x6010:07 - Status_Open circuit (0.1) 0x6010:08 - Status_Extrapolation stall (0.1) 0x6010:09 - Status_Status of input A (0.1) 0x6010:0A - Status_Status of input B (0.1) 0x6010:0B - Status_Status of input C (0.1) 0x6010:0C - Status_Status of input gate (0.1) 0x6010:0D - Status_Status of extern Latch(0.1) 0x6010:0E - Status_Sync error (0.1) 0x6010:0F - Status_ Status TxPDO State (0.1) 0x6010:10 - Status_ Status TxPDO Toggle (0.1) 0x6010:11 - Counter value (2.0) 0x6010:12 - Latch value (2.0) | 0x1A0D - ENC Status Channel 2 (10.0) 0x1A0E - ENC Status Compact Channel 2 (10.0) 0x1A0F - ENC Status Counter Channel 2 (8.0) 0x1A10 - ENC Status Compact Counter Channel 2 (6.0) 0x1A11 - ENC Status Legacy Channel 2 (10.0)
0x1A13 - ENC Frequency Channel 2 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6010:13 - Frequency value (4.0) | 0x1A14 - ENC Frequency Compact Channel 2 (2.0)
0x1A14 - ENC Frequency Compact Channel 2 (2.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6010:13 - Frequency value (2.0) | 0x1A13 - ENC Frequency Channel 2 (4.0)
0x1A15 - ENC Period Channel 2 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6010:14 - Period value (4.0) | 0x1A16 - ENC Period Compact Channel 2 (2.0)
0x1A16 - ENC Period Compact Channel 2 (2.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6010:14 - Period value (2.0) | 0x1A15 - ENC Period Channel 2 (4.0)
0x1A17 - ENC Duty Cycle Channel 2 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6010:23 - Duty cycle (2.0) 0x6010:24 - Duty cycle min (2.0) 0x6010:25 - Duty cycle max (2.0) | -
0x1A18 - ENC Timestamp Channel 2 (32.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6010:16 - Timestamp (8.0) 0x6010:1F - Timestamp C (8.0) 0x6010:20 - Timestamp latch (8.0) 0x6010:21 - Timestamp latch 2 (8.0) | 0x1A19 - ENC Timestamp Compact Channel 2 (16.0)
0x1A19 - ENC Timestamp Compact Channel 2 (16.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index Name Größe (Byte.Bit)
0x6010:16 - Timestamp (4.0) 0x6010:1F - Timestamp C (4.0) 0x6010:20 - Timestamp latch (4.0) 0x6010:21 - Timestamp latch 2 (4.0) | 0x1A18 - ENC Timestamp Channel 2 (32.0)


SM2 - Outputs (0x1600 .. 0x160B)

EL5102 - Inbetriebnahme [image] Prozessdaten [image] PDO - Zuordnung [image] SM2 - Outputs (0x1600 .. 0x160B)
SM2 - Outputs (0x1600 .. 0x160B)
Channel 1 (0x1600 .. 0x1605):
0x1600 - ENC Control Channel 1 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7000:01 - Control_Enable latch C (0.1) 0x7000:02 - Control_Enable latch extern on positive edge (0.1) 0x7000:03 - Control_Set counter (0.1) 0x7000:04 - Control_Enable latch extern on negative edge (0.1) 0x7000:08 - Control_Set counter on latch C (0.1) 0x7000:09 - Control_Set software gate (0.1) 0x7000:0A - Control_Set counter on latch extern on positive edge (0.1) 0x7000:0B - Control_Set counter on latch extern on negative edge (0.1) 0x7000:0C - Control_Enable latch extern 2 on positive edge (0.1) 0x7000:0D - Control_Enable latch extern 2 on negative edge (0.1) 0x7000:11 - Set counter value (4.0) | 0x1601 - ENC Control Compact Channel 1 (4.0) 0x1602 - ENC Control Counter Channel 1 (6.0) 0x1603 - ENC Control Compact Counter Channel 1 (4.0) 0x1604 - ENC Control Legacy Channel 1 (6.0) 0x1605 - ENC Control Compact Legacy Channel 1 (4.0)
0x1601 - ENC Control Compact Channel 1 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7000:01 - Control_Enable latch C (0.1) 0x7000:02 - Control_Enable latch extern on positive edge (0.1) 0x7000:03 - Control_Set counter (0.1) 0x7000:04 - Control_Enable latch extern on negative edge (0.1) 0x7000:08 - Control_Set counter on latch C (0.1) 0x7000:09 - Control_Set software gate (0.1) 0x7000:0A - Control_Set counter on latch extern on positive edge (0.1) 0x7000:0B - Control_Set counter on latch extern on negative edge (0.1) 0x7000:0C - Control_Enable latch extern 2 on positive edge (0.1) 0x7000:0D - Control_Enable latch extern 2 on negative edge (0.1) 0x7000:11 - Set counter value (2.0) | 0x1600 - ENC Control Channel 1 (6.0) 0x1602 - ENC Control Counter Channel 1 (6.0) 0x1603 - ENC Control Compact Counter Channel 1 (4.0) 0x1604 - ENC Control Legacy Channel 1 (6.0) 0x1605 - ENC Control Compact Legacy Channel 1 (4.0)
0x1602 - ENC Control Counter Channel 1 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7000:03 - Control_Set counter (0.1) 0x7000:09 - Control_Set software gate (0.1) 0x7000:11 - Set counter value (4.0) | 0x1600 - ENC Control Channel 1 (6.0) 0x1601 - ENC Control Compact Channel 1 (4.0) 0x1603 - ENC Control Compact Counter Channel 1 (4.0) 0x1604 - ENC Control Legacy Channel 1 (6.0) 0x1605 - ENC Control Compact Legacy Channel 1 (4.0)
0x1603 - ENC Control Compact Counter Channel 1 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7000:03 - Control_Set counter (0.1) 0x7000:09 - Control_Set software gate (0.1) 0x7000:11 - Set counter value (2.0) | 0x1600 - ENC Control Channel 1 (6.0) 0x1601 - ENC Control Compact Channel 1 (4.0) 0x1602 - ENC Control Counter Channel 1 (6.0) 0x1604 - ENC Control Legacy Channel 1 (6.0) 0x1605 - ENC Control Compact Legacy Channel 1 (4.0)
0x1604 - ENC Control Legacy Channel 1 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7000:01 - Control_Enable latch C (0.1) 0x7000:02 - Control_Enable latch extern on positive edge (0.1) 0x7000:03 - Control_Set counter (0.1) 0x7000:04 - Control_Enable latch extern on negative edge (0.1) 0x7000:11 - Set counter value (4.0) | 0x1600 - ENC Control Channel 1 (6.0) 0x1601 - ENC Control Compact Channel 1 (4.0) 0x1602 - ENC Control Counter Channel 1 (6.0) 0x1603 - ENC Control Compact Counter Channel 1 (4.0) 0x1605 - ENC Control Compact Legacy Channel 1 (4.0)
0x1605 - ENC Control Compact Legacy Channel 1 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7000:01 - Control_Enable latch C (0.1) 0x7000:02 - Control_Enable latch extern on positive edge (0.1) 0x7000:03 - Control_Set counter (0.1) 0x7000:04 - Control_Enable latch extern on negative edge (0.1) 0x7000:11 - Set counter value (2.0) | 0x1601 - ENC Control Compact Channel 1 (4.0) 0x1602 - ENC Control Counter Channel 1 (6.0) 0x1603 - ENC Control Compact Counter Channel 1 (4.0) 0x1604 - ENC Control Legacy Channel 1 (6.0) 0x1605 - ENC Control Compact Legacy Channel 1 (4.0)
Channel 2 (0x1606 .. 0x160B):
0x1606 - ENC Control Channel 2 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7010:01 - Control_Enable latch C (0.1) 0x7010:02 - Control_Enable latch extern on positive edge (0.1) 0x7010:03 - Control_Set counter (0.1) 0x7010:04 - Control_Enable latch extern on negative edge (0.1) 0x7010:08 - Control_Set counter on latch C (0.1) 0x7010:09 - Control_Set software gate (0.1) 0x7010:0A - Control_Set counter on latch extern on positive edge (0.1) 0x7010:0B - Control_Set counter on latch extern on negative edge (0.1) 0x7010:0C - Control_Enable latch extern 2 on positive edge (0.1) 0x7010:0D - Control_Enable latch extern 2 on negative edge (0.1) 0x7010:11 - Set counter value (4.0) | 0x1607 - ENC Control Compact Channel 2 (4.0) 0x1608 - ENC Control Counter Channel 2 (6.0) 0x1609 - ENC Control Compact Counter Channel 2 (4.0) 0x160A - ENC Control Legacy Channel 2 (6.0) 0x160B - ENC Control Compact Legacy Channel 2 (4.0)
0x1607 - ENC Control Compact Channel 2 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7010:01 - Control_Enable latch C (0.1) 0x7010:02 - Control_Enable latch extern on positive edge (0.1) 0x7010:03 - Control_Set counter (0.1) 0x7010:04 - Control_Enable latch extern on negative edge (0.1) 0x7010:08 - Control_Set counter on latch C (0.1) 0x7010:09 - Control_Set software gate (0.1) 0x7010:0A - Control_Set counter on latch extern on positive edge (0.1) 0x7010:0B - Control_Set counter on latch extern on negative edge (0.1) 0x7010:0C - Control_Enable latch extern 2 on positive edge (0.1) 0x7010:0D - Control_Enable latch extern 2 on negative edge (0.1) 0x7010:11 - Set counter value (2.0) | 0x1606 - ENC Control Channel 2 (6.0) 0x1608 - ENC Control Counter Channel 2 (6.0) 0x1609 - ENC Control Compact Counter Channel 2 (4.0) 0x160A - ENC Control Legacy Channel 2 (6.0) 0x160B - ENC Control Compact Legacy Channel 2 (4.0)
0x1608 - ENC Control Counter Channel 2 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7010:03 - Control_Set counter (0.1) 0x7010:09 - Control_Set software gate (0.1) 0x7010:11 - Set counter value (4.0) | 0x1606 - ENC Control Channel 2 (6.0) 0x1607 - ENC Control Compact Channel 2 (4.0) 0x1609 - ENC Control Compact Counter Channel 2 (4.0) 0x160A - ENC Control Legacy Channel 2 (6.0) 0x160B - ENC Control Compact Legacy Channel 2 (4.0)
0x1609 - ENC Control Compact Counter Channel 2 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7010:03 - Control_Set counter (0.1) 0x7010:09 - Control_Set software gate (0.1) 0x7010:11- Set counter value (2.0) | 0x1606 - ENC Control Channel 2 (6.0) 0x1607 - ENC Control Compact Channel 2 (4.0) 0x1608 - ENC Control Counter Channel 2 (6.0) 0x160A - ENC Control Legacy Channel 2 (6.0) 0x160B - ENC Control Compact Legacy Channel 2 (4.0)
0x160A - ENC Control Legacy Channel 2 (6.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7010:01 - Control_Enable latch C (0.1) 0x7010:02 - Control_Enable latch extern on positive edge (0.1) 0x7010:03 - Control_Set counter (0.1) 0x7010:04 - Control_Enable latch extern on negative edge (0.1) 0x7010:11 - Set counter value (4.0) | 0x1606 - ENC Control Channel 2 (6.0) 0x1607 - ENC Control Compact Channel 2 (4.0) 0x1608 - ENC Control Counter Channel 2 (6.0) 0x1609 - ENC Control Compact Counter Channel 2 (4.0) 0x160B - ENC Control Compact Legacy Channel 2 (4.0)
0x160B - ENC Control Compact Legacy Channel 2 (4.0)
Inhalt Index - Name Größe (Byte.Bit) | Ausgeschlossene PDOs Index - Name Größe (Byte.Bit)
0x7010:01 - Control_Enable latch C (0.1) 0x7010:02 - Control_Enable latch extern on positive edge (0.1) 0x7010:03 - Control_Set counter (0.1) 0x7010:04 - Control_Enable latch extern on negative edge (0.1) 0x7010:11 - Set counter value (2.0) | 0x1606 - ENC Control Channel 2 (6.0) 0x1607 - ENC Control Compact Channel 2 (4.0) 0x1608 - ENC Control Counter Channel 2 (6.0) 0x1609 - ENC Control Compact Counter Channel 2 (4.0) 0x160A - ENC Control Legacy Channel 2 (6.0)


Predefined PDO Assignment

EL5102 - Inbetriebnahme [image] Prozessdaten [image] Predefined PDO Assignment
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das „Predefined PDO Assignment“. Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
EL5102 - Prozessdaten, Predefined PDO (Default: 2.Ch Standard)
Es stehen 20 PDO-Zuordnungen in den Modi Legacy, Standard, Compact und Counter zur Auswahl:
Predefined PDO Assignments für den Legacy-mode
Predefined PDO Assignment | PDO-Zuordnung
1.Ch Standard, Legacy EL5101 | SM3: 0x1A04 - ENC Status Legacy Channel 1 (10.0) SM2: 0x1604 - ENC Control Legacy Channel 1 (6.0)
2.Ch Standard, Legacy EL5101 | SM3: 0x1A04 - ENC Status Legacy Channel 1 (10.0) 0x1A11 - ENC Status Legacy Channel 2 (10.0) SM2: 0x1604 - ENC Control Legacy Channel 1 (6.0) 0x160A - ENC Control Legacy Channel 2 (6.0)
1.Ch Compact, Legacy EL5101 | SM3: 0x1A05 - ENC Status Compact Legacy Channel 1 (6.0) SM2: 0x1605 - ENC Control Compact Legacy Channel 1 (4.0)
2.Ch Compact, Legacy EL5101 | SM3: 0x1A05 - ENC Status Compact Legacy Channel 1 (6.0) 0x1A12 - ENC Status Compact Legacy Channel 2 (6.0) SM2: 0x1605 - ENC Control Compact Legacy Channel 1 (4.0) 0x160B - ENC Control Compact Legacy Channel 2 (4.0)
Predefined PDO Assignments für den Compact-mode
Predefined PDO Assignment | PDO-Zuordnung
1.Ch Compact | SM3: 0x1A01 - ENC Status Compact Channel 1 (10.0) SM2: 0x1601 - ENC Control Compact Channel 1 (4.0)
2.Ch Compact | SM3: 0x1A01 - ENC Status Compact Channel 1 (10.0) 0x1A0E - ENC Status Compact Channel 2 (10.0) SM2: 0x1601 - ENC Control Compact Channel 1 (4.0) 0x1607 - ENC Control Compact Channel 2 (4.0)
Predefined PDO Assignments für den Standard-mode
Predefined PDO Assignment | PDO-Zuordnung
1.Ch Standard | SM3: 0x1A00 - ENC Status Channel 1 (16.0) SM2: 0x1600 - ENC Control Channel 1 (6.0)
2.Ch Standard | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A0D - ENC Status Channel 2 (16.0) SM2: 0x1600 - ENC Control Channel 1 (6.0) 0x1606 - ENC Control Channel 2 (6.0)
1.Ch Standard, extended DC mode, 32Bit time stamp | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A06 - ENC Frequency Channel 1 (4.0) 0x1A08 - ENC Period Channel 1 (4.0) 0x1A0A - ENC Duty cycle Channel 1 (6.0) 0x1A0C - ENC Timestamp Compact Channel 1 (16.0) SM2: 0x1600 - ENC Control Channel 1 (6.0)
2.Ch Standard, extended DC mode, 32Bit time stamp | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A06 - ENC Frequency Channel 1 (4.0) 0x1A08 - ENC Period Channel 1 (4.0) 0x1A0A - ENC Duty cycle Channel 1 (6.0) 0x1A0C - ENC Timestamp Compact Channel 1 (16.0) 0x1A0D - ENC Status Channel 2 (16.0) 0x1A13 - ENC Frequency Channel 2 (4.0) 0x1A15 - ENC Period Channel 2 (4.0) 0x1A17 - ENC Duty cycle Channel 2 (6.0) 0x1A19 - ENC Timestamp Compact Channel 2 (16.0) SM2: 0x1600 - ENC Control Channel 1 (6.0) 0x1606 - ENC Control Channel 2 (6.0)
1.Ch Standard, extended DC mode, 64Bit time stamp | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A06 - ENC Frequency Channel 1 (4.0) 0x1A08 - ENC Period Channel 1 (4.0) 0x1A0A - ENC Duty cycle Channel 1 (6.0) 0x1A0B - ENC Timestamp Channel 1 (32.0) SM2: 0x1600 - ENC Control Channel 1 (6.0)
2.Ch Standard, extended DC mode, 64Bit time stamp | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A06 - ENC Frequency Channel 1 (4.0) 0x1A08 - ENC Period Channel 1 (4.0) 0x1A0A - ENC Duty cycle Channel 1 (6.0) 0x1A0B - ENC Timestamp Channel 1 (32.0)) 0x1A0D - ENC Status Channel 2 (16.0) 0x1A13 - ENC Frequency Channel 2 (4.0) 0x1A15 - ENC Period Channel 2 (4.0) 0x1A17 - ENC Duty cycle Channel 2 (6.0) 0x1A18 - ENC Timestamp Channel 2 (32.0) SM2: 0x1600 - ENC Control Channel 1 (6.0) 0x1606 - ENC Control Channel 2 (6.0)
Predefined PDO Assignment | PDO-Zuordnung
1.Ch Standard, Period mode | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A08 - ENC Period Channel 1 (4.0) SM2: 0x1600 - ENC Control Channel 1 (6.0)
2.Ch Standard, Period mode | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A08 - ENC Period Channel 1 (4.0) 0x1A0D - ENC Status Channel 2 (16.0) 0x1A15 - ENC Period Channel 2 (4.0) SM2: 0x1600 - ENC Control Channel 1 (6.0) 0x1606 - ENC Control Channel 2 (6.0)
1.Ch Standard, Frequency mode, | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A06 - ENC Frequency Channel 1 (4.0) SM2: 0x1600 - ENC Control Channel 1 (6.0)
2.Ch Standard, Frequency mode, | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A06 - ENC Frequency Channel 1 (4.0) 0x1A0D - ENC Status Channel 2 (16.0) 0x1A13 - ENC Frequency Channel 2 (4.0) SM2: 0x1600 - ENC Control Channel 1 (6.0) 0x1606 - ENC Control Channel 2 (6.0)
1.Ch Standard, Duty cycle mode, | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A0A - ENC Duty cycle Channel 1 (6.0) SM2: 0x1600 - ENC Control Channel 1 (6.0)
2.Ch Standard, Duty cycle mode, | SM3: 0x1A00 - ENC Status Channel 1 (16.0) 0x1A0A - ENC Duty cycle Channel 1 (6.0) 0x1A0D - ENC Status Channel 2 (16.0) 0x1A17 - ENC Duty cycle Channel 2 (6.0) SM2: 0x1600 - ENC Control Channel 1 (6.0) 0x1606 - ENC Control Channel 2 (6.0)
Predefined PDO Assignments für den Counter-mode
Predefined PDO Assignment | PDO-Zuordnung
2.Ch Standard, Counter mode, | SM3: 0x1A02 - ENC Status Counter Channel 1 (8.0) 0x1A0F - ENC Status Counter Channel 2 (8.0) SM2: 0x1602 - ENC Control Counter Channel 1 (6.0) 0x1608 - ENC Control Counter Channel 2 (6.0)
2.Ch Compact, Counter mode, | SM3: 0x1A03 - ENC Status Compact Counter Channel 1 (6.0) 0x1A10 - ENC Status Compact Counter Channel 2 (6.0) SM2: 0x1603 - ENC Control Compact Counter Channel 1 (4.0) 0x1609 - ENC Control Compact Counter Channel 2 (4.0)


Betriebsart - Synchronität

EL5102 - Inbetriebnahme [image] Prozessdaten [image] Betriebsart - Synchronität
Betriebsart - Synchronität
Die Klemme kann in drei verschiedenen Betriebsarten betrieben werden. In Abhängigkeit von der Betriebsart werden die Prozessdaten von der Klemme zu verschiedenen Zeiten synchronisiert und dem EtherCAT-Frame bereitgestellt. Weitergehende Informationen sind dem Kapitel DC Einstellungen zu entnehmen.
Im Karteireiter „DC“ stehen folgende Betriebsarten zur Auswahl:
Operation mode | Beschreibung
FreeRun / SM Synchron | Zyklischer, Frame-getriggerter Austausch der Prozessdaten. Ein Ethernet-Frame löst die Prozessdatenbereitstellung für den nächsten abholenden Frame aus.
DC-Synchron | Zyklisch konstante Zählerstandermittlung durch die integrierte Distributed Clocks-Einheit. Die Konfiguration entspricht einer Ausgangsbaugruppe. Das lokale SYNC-Event wird kurz nach der Passage des EtherCAT-Frames ausgelöst. Dadurch werden die eben angelieferten Ausgangsdaten sofort ausgegeben.
DC-Synchron (input based) | Zyklisch konstante Zählerstandermittlung durch die integrierte Distributed Clocks-Einheit. Die Konfiguration entspricht einer Eingangsbaugruppe. Das lokale SYNC-Event wird vor dem EtherCAT-Frame ausgelöst. Dadurch stehen aktuelle Eingangsdaten zum Weitertransport zur Verfügung.


EtherCAT Zykluszeit

EL5102 - Inbetriebnahme [image] Prozessdaten [image] EtherCAT Zykluszeit
EtherCAT Zykluszeit
Die EtherCAT-Zykluszeit ist abhängig von der Auswahl der zu übertragenden Prozessdaten. Die folgende Tabelle gibt eine Übersicht über die empfohlene Zykluszeit in Abhängigkeit des „Predefined PDO Assignment“. Die Angaben beziehen sich jeweils auf ein Vielfaches der über den TwinCAT Master einzustellenden „Base Time“. Die tatsächlich funktionierenden minimalen Zykluszeiten können im Einzelfall abweichen. Wird eine schnellere Zykluszeit verwendet, ist durch das Prozessdatum 0x6002:0F „Input Cycle Counter“ zu überwachen, wann neue Prozessdaten geliefert werden.
EL5102 Predefined PDO Assignment | EtherCAT Zykluszeit
 | Minimale | Maximale
1. Ch. Standard Legacy EL5101 | typ. 76,6 µs | typ. 125 µs
2. Ch. Standard Legacy EL5101 | typ. 125 µs | typ. 200 µs
1. Ch. Compact Legacy EL5101 | typ. 71,4 µs | typ. 125 µs
2. Ch. Compact Legacy EL5101 | typ. 125 µs | typ. 200 µs
1. Ch. Standard | typ. 76,6 µs | typ. 125 µs
2. Ch. Standard | typ. 125 µs | typ. 214,2 µs
1. Ch. Compact | typ. 76,6 µs | typ.150 µs
2. Ch. Compact | typ. 125 µs | typ. 214,5 µs
1. Ch. Standard, extended DC mode, 32Bit time stamp | typ. 125 µs | typ. 200 µs
2. Ch. Standard, extended DC mode, 32Bit time stamp | typ. 187,5 µs | typ. 300 µs
1. Ch. Standard, extended DC mode, 64Bit time stamp | typ. 125 µs | typ. 200 µs
2. Ch. Standard, extended DC mode, 64Bit time stamp | typ. 200 µs | typ. 300 µs
1. Ch. Standard, Period mode | typ. 83,3 µs | typ. 150 µs
2. Ch. Standard, Period mode | typ. 125 µs | typ. 250 µs
1. Ch. Standard, Frequency mode | typ. 83,3 µs | typ. 150 µs
2. Ch. Standard, Frequency mode | typ. 125 µs | typ. 250 µs
1. Ch. Standard, Duty Cycle mode | typ. 100 µs | typ. 150 µs
2. Ch. Standard, Duty cycle mode | typ. 142,8 µs | typ. 250 µs
2. Ch. Standard, counter mode | typ. 125 µs | typ. 200 µs
2. Ch. Compact, counter mode | typ. 125 µs | typ.200 µs


„Legacy EL5101“-Mode

EL5102 - Inbetriebnahme [image] Prozessdaten [image] „Legacy EL5101“-Mode
„Legacy EL5101“-Mode
Das Prozessabbild der Klemme basiert auf dem MDP511 Profil. Dieses Profil wurde für eine verbesserte Funktionalität im Bereich der Status Bits erweitert. Die Klemme stellt in den jeweiligen „Predefined PDO Assignments“ unterschiedliche Status Informationen zur Verfügung. Ein kompatibles Prozessabbild zu der EL5101 wird über „Legacy EL5101“-Mode bereitgestellt. Das Prozessabbild der Klemme außerhalb des „Legacy EL5101“-Mode unterscheidet sich über folgende Status Bits im PDO Assignment:
EL5101 |  | EL5102, EL5112
„Standard / Line Motion“-Mode |  | „Legacy EL5101“-Mode (Ch.1 n=0, Ch.2 n=1) |  | „n.Ch. Standard / Compact / counter“-Mode (Ch.1 n=0, Ch.2 n=1)
0x6010:0D | Status_Status of extern Latch | 0x60n0:0D | Status_Status of extern Latch | 0x60n2:0D | Status_Status Diag
0x6010:0E | Status_Sync error | 0x60n0:0E | Status_Sync error | 0x60n2:0E | Status_Status TxPDO State
0x6010:0F | Status_Status TxPDO State | 0x60n0:0F | Status_Status TxPDO State | 0x60n2:0F | Status_Status Input cycle counter
0x6010:10 | Status_Status TxPDO Toggle | 0x60n0:10 | Status_Status TxPDO Toggle | 0x60n2:10 | -
- | - | - | - | 0x60n2:14 | Status_Status of extern Latch
Durch den „Legacy EL5101“-Mode wird die Verwendung von bestehenden Funktionsblöcken, welche die geänderten Status-Bits nutzen, ermöglicht.
EL5102 und EL5112 in Verbindung mit älteren TwinCAT Versionen
Ab TwinCAT Version 3.1 Build 4024 können alle Predefined PDOs der EL5102 und EL5112 automatisch zur NC verknüpf werden. Bei älteren TwinCAT Versionen ist der „Legacy EL5101“-Mode zu nutzen. Die damit verbundenen Einschränkungen im Funktionsumfang sind zu beachten.
Funktionskompatibilität zu EL5101
Die EL5102 und EL5112 stellen keine Funktionskompatibilität zur EL5101 dar. Interne Berechnungsverfahren sowie Timings können sich unterscheiden. Eine Kompatibilität zu bestehenden Projekten ist im Einzelfall zu prüfen.
Einschränkungen „Legacy EL5101“-Mode
Die folgende Tabelle gibt eine Übersicht der zur Verfügung stehenden Funktionen im „Legacy EL5101“-Mode:
Funktion |  | „Legacy“-Mode
Zählerstand setzen über | SPS Variable | X
 | Nullimpuls C | /
 | Latch-Eingang | /
Zählerstand Reset über | Nullimpuls C | X
 | Latch-Eingang | X
Zählerstand speichern über | Nullimpuls C | X
 | Latch-Eingang | X
 | Gate-Eingang/Latch extern 2 | /
Zählerstand sperren über | SPS Variable | /
 | Gate-Eingang/Latch extern 2 | X
Zählrichtung detektieren |  | /
Zählrichtungsumkehr detektieren |  | /
Frequenzberechnung |  | /
Periodendauerberechnung |  | /
Duty cycle Auswertung |  | /
Mikroinkremente |  | /
Zeitstempelfunktion |  | /
Filterfunktion |  | X
Plausibilitätsprüfung |  | X


Basisfunktionen

EL5102 - Inbetriebnahme [image] Basisfunktionen
Basisfunktionen
Weiterführende Informationen
•
Zählerstand (Counter Value)
•
Zählerstand reset
•
Zählerstand setzen
•
Zählrichtung detektieren
•
Zählerstand speichern
•
Zählerstand sperren


Zählerstand (Counter Value)

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand (Counter Value)
Zählerstand (Counter Value)
Der Zählerstand wird in Index 0x60n0:11 „Counter value“ angezeigt. Er gibt den aktuellen Zählerwert in der Klemme an. Diesen können Sie durch die folgenden Einstellungen an die Anwendung anpassen.
▪
Auswahl Encodertyp (Counter mode)
▪
Auswertung des Zählerwerts (Evaluation mode)
▪
Bestimmung der Zählergrenzen (Reset counter value / Limit counter value)
▪
Zählrichtungsumkehr (Reversion of rotation)
Weiterführende Informationen
•
Auswahl Encodertyp (Counter mode)
•
Geberbetriebsspannung (Supply voltage)
•
Auswertung des Zählerwerts
•
Bestimmung der Zählergrenzen (Reset counter value / Limit counter value)
•
Zählrichtungsumkehr (Reversion of rotation)


Auswahl Encodertyp (Counter mode)

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand (Counter Value) [image] Auswahl Encodertyp (Counter mode)
Auswahl Encodertyp (Counter mode)
Um eine korrekte Erfassung des Zählerwertes zu gewährleisten, müssen Sie zunächst den passenden Encodertyp auswählen.
Die Auswahl des angeschlossenen Encoders erfolgt über Index 0x80n1:1D „Counter mode“. Erläuterungen zu den unterstützen Encoder- und Signaltypen finden Sie im Kapitel „Unterstützte Encoder / Signaltypen“
Index (hex) | Name | Bedeutung
80n1:1D | Counter mode | Auswahl des Encoders
 | 0: Encoder RS422 (diff. input) | RS422 Encoder mit oder ohne Nullimpuls
 | 1: Counter RS422 (diff. input) | RS422 Zähler/Impulsgeber, mit oder ohne Nullimpuls. Richtungsvorgabe über Spur B
 | 2: Encoder TTL (single ended) | TTL Encoder mit oder ohne Nullimpuls
 | 3: Counter TTL (single ended) | TTL Zähler/Impulsgeber mit oder ohne Nullimpuls. Richtungsvorgabe über Spur B
 | 4: Encoder open collector | Open Collector Encoder mit oder ohne Nullimpuls
 | 5: Counter open collector | Open Collector Zähler/Impulsgeber mit oder ohne Nullimpuls, Richtungsvorgabe über Spur B
Im Folgenden werden die Einstellungen unter den Subindizes 0, 2 und 4 allgemein als „Encoder“ und die Einstellung unter den Subindizes 1, 3 und 5 allgemein als „Zähler/Impulsgeber“ bezeichnet.
Anschalten der Fehlererkennung der C-Spur
Im Auslieferungszustand ist die Fehlererkennung auf der C-Spur ausgeschaltet, das Objekt 0x80n0:0D „Error detection C“ ist per default FALSE.
Wird ein Encoder oder Zähler/Impulsgeber mit Nullimpuls C verwendet, so kann am Modul das Objekt 0x80n0:0D „Error detection C“ auf TRUE gesetzt werden. Über die entsprechende LED wird dann auch der Fehlerfall angezeigt.


Geberbetriebsspannung (Supply voltage)

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand (Counter Value) [image] Geberbetriebsspannung (Supply voltage)
Geberbetriebsspannung (Supply voltage)
Die Geberversorgung wird intern aus den 24 V der Powerkontakte erzeugt. In Index 0x80n1:17 „Supply voltage“ kann die Geberversorgung eingestellt werden. Voreingestellt ist eine Betriebsspannung von 5 VDC. Es können Spannungswerte 5 VDC, 12 VDC und 24 VDC ausgewählt werden. Die Einstellungen erfolgen für jeden Kanal separat.
Es gelten folgende Toleranzen
Spannungsbereich | Toleranz
5 VDC | +/- 5 % (4,75 V … 5,25 V)
12 VDC | +/- 10 % (10,8 V … 13,2 V)
24 VDC | -15 % bis +20 % (20,4 V … 28,8 V)
Hinweis
Geberversorgungsspannung einstellen
•
Stellen Sie vor dem Umschalten auf eine höhere Spannung sicher, dass der angeschlossene Encoder den gewählten Spannungsbereich unterstützt!
•
Zum Beschreiben von 0x80n1:17 „Supply voltage“ müssen Sie in Index 0xF008 „Code word“ den Wert 0x72657375 (ASCII: „user“) setzen.


Auswertung des Zählerwerts

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand (Counter Value) [image] Auswertung des Zählerwerts
Auswertung des Zählerwerts
Die Auswertung des Zählerwerts (Counter value) wird über Index 0x80n0:06 „Evaluation mode“ festgelegt.
▪
Auswertung der Eingangssignale (Index 0x80n0:06 „Evaluation mode“): Das Eingangssignal kann in 4-fach, 2-fach oder 1-fach Auswertung erfolgen.
–
1 - fach Auswertung: es werden die steigenden Flanken an Spur A gezählt.
–
2 - fach Auswertung: es werden die steigenden und fallenden Flanken an Spur A gezählt.
–
4 - fach Auswertung: es werden die steigenden und fallenden Flanken an Spur A und Spur B gezählt.
Im Auslieferungszustand ist die 4-fach Auswertung ausgewählt, da diese die höchste Auflösung des Eingangssignals ermöglicht.


Bestimmung der Zählergrenzen (Reset counter value / Limit counter value)

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand (Counter Value) [image] Bestimmung der Zählergrenzen (Reset counter value / Limit counter value)
Bestimmung der Zählergrenzen (Reset counter value / Limit counter value)
Zählergrenzen im Auslieferungszustand
Im Auslieferungszustand zählt der Zählerstand (Counter Value) in dem Bereich von 0 bis zur maximalen Zählertiefe. Bei Überschreiten der maximalen Zählertiefe (Counter overflow) beginnt der Zähler wieder von Null hochzuzählen. Die Überschreitung des Zählers wird über die Bits „Counter overflow“ angezeigt (vgl. Kapitel Bestimmung der Zählergrenzen (Reset counter value / Limit counter value)).
▪
PDO Assignment „Standard“: 0 bis 232-1
▪
PDO Assignment „Compact“: 0 bis 216-1
Bei Unterschreitung des Zählers, wird bei der maximalen Zählertiefe weitergezählt, auch wenn z. B. in Index 0x80n0:01 „Enable C reset“ aktiviert ist. Die Unterschreitung wird mit dem entsprechenden „Counter underflow“-Bit gekennzeichnet.
Über- und Unterschreitung der Zählergrenzen im Auslieferungszustand
Zählergrenzen mit festgelegtem Wertebereich
Soll nur in einem festgelegten Wertebereich gezählt werden, so können die Zählergrenzen angepasst werden.
Zählergrenzen einstellen
Zum Beschreiben von Index 0x80n1:1B „Reset counter value“ und Index 0x80n1:1A „Limit counter value“ muss in 0xF008 „Code word“ der Wert 0x72657375 (ASCII: „user“) gesetzt sein.
▪
Geben Sie die untere Zählergrenze in Index 0x80n1:1B „Reset counter value“ ein.
▪
Geben Sie die obere Zählergrenze in Index 0x80n1:1A „Limit counter value“ an.
Über- und Unterschreiten der Zählergrenzen mit festgelegtem Wertebereich
Zählergrenzen
•
Die untere Zählergrenze Index 0x80n1:1B „Reset counter value“ muss immer kleiner sein als die obere Zählergrenze 0x80n1:1A „Limit counter value“.
Ist dies nicht der Fall, wird der zuletzt eingegeben Wert nicht übernommen.
•
Ist die untere Zählergrenze in Index 0x80n1:1B „Reset counter value“ > 0 kann die Motion Control Anwendung (NC/CNC) nur in einem begrenzten Bereich genutzt werden.
Wird der Zähler zur Laufzeit auf einen Zählerstand außerhalb der Zählergrenzen parametriert, so wird dieser Zählerstand übernommen. Das Überschreiten der Zählergrenze wird über die Prozessdaten in Index 0x60n2:15 „Counter value out of range“ angezeigt.
Beispiel:
In 0x70n0:11 „Set counter value“ ist ein Wert parametriert, der außerhalb der Zählergrenzen liegt und das „Set counter“-Bit in Index 0x70n0:03 ist aktiviert.
→ Der in Index 0x70n0:11 vorgegebene Wert wird übernommen.
→ Das „Counter value out of range“-Bit in Index 0x60n2:15 wird gesetzt.
Werden die Zählergrenzen so parametriert, dass der aktuelle Zählerstand außerhalb dieser liegt, so wird das Unter- bzw. Überschreiten der Zählergrenze ebenfalls über die Prozessdaten in Index 0x60n2:15 „Counter value out of range“ angezeigt.
Überlauf (Counter overflow) und Unterlauf (Counter underflow) der Zählergrenzen
Ein Über- oder Unterlauf der Zählergrenzen wird über die Prozessdaten 0x60n0:04 „Counter underflow“ bzw. 0x60n0:05 „Counter overflow“ angezeigt.
▪
Das „Counter underflow“- Bit in Index 0x60n0:04 wird gesetzt, wenn ein Unterlauf 0x80n1:1B „Reset counter value“ → 0x80n1:1A „Limit counter value“ eintritt.
–
Mit den voreingestellten Parametern entspricht dies „..00 → ..FF“
Es wird zurückgesetzt, wenn 2/3 des Zählbereichs unterschritten werden.
–
Bei Zählgrenzen mit festgelegten Werteberich entspricht das:
2/3 * („Limit counter value“ - „Reset counter value“) + „Reset counter value“
▪
Das „Counter overflow“" Bit 0x60n0:05 wird gesetzt, wenn ein Überlauf 0x80n1:1A „Limit counter value“ → 0x80n1:1B „Reset counter value“ eintritt.
–
Mit Default-Parametern „..FF → ..00“
Es wird zurückgesetzt, wenn 1/3 des Zählbereiches überschritten werden.
–
Bei Zählgrenzen mit festgelegten Werteberich entspricht das:
1/3 * („Limit counter value“ - „Reset counter value“) + „Reset counter value“
Beispiel 1:
0x80n1:1A „Limit counter value“ = 212-1 = 4095
0x80n1:1B „Reset counter value“ = 0
„Counter underflow“ Bit wird zurückgesetzt wenn: 2/3 * 4095 = 2730 erreicht ist.
„Counter overflow“ Bit wird zurückgesetzt wenn: 1/3 * 4095 = 1365 erreicht ist.
Beispiel 2:
0x80n1:1A „Limit counter value“ = 212-1 = 4095
0x80n1:1B „Reset counter value“ = 400
„Counter underflow“ Bit wird zurückgesetzt, wenn: 2/3 * (4095-400) +400 = 2463 erreicht ist.
„Counter overflow“ Bit wird zurückgesetzt, wenn: 1/3 * (4095-95) +400 = 1232 erreicht ist.


Zählrichtungsumkehr (Reversion of rotation)

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand (Counter Value) [image] Zählrichtungsumkehr (Reversion of rotation)
Zählrichtungsumkehr (Reversion of rotation)
▪
Bei einem Encoder wird die Zählrichtung durch die Phasenlage der Signale an Spur A und Spur B vorgegeben.
–
Vorwärts (cw): Signal an Spur A ist 90° voreilend gegenüber Spur B
–
Rückwärts (ccw): Signal an Spur A ist 90° nacheilend gegenüber Spur B
Um die Zählrichtung an die Anwendung anzupassen, kann diese Logik durch das Setzten des Bits in Index 0x80n0:0E „Reversion of rotation“ invertiert werden.
Direction Inversion encoder
Zählrichtungsumkehr (Index 0x80n0:0E „Reversion of rotation“) bei einem Encoder
▪
Bei einem Zähler/Impulsgeber wird die Zählrichtung durch den Pegel an Spur B vorgeben.
–
Vorwärts (cw): LOW-Pegel an Spur B oder Eingang offen
–
Rückwärts (ccw): HIGH-Pegel an Spur B
Das Setzen des Bits in Index 0x80n0:0E „Reversion of rotation“ invertiert auch hier die Logik der Zählrichtung. Eine Übersicht der resultierenden Zählrichtung ist in der folgenden Tabelle dargestellt.
Über das Prozessdatum 0x60n0:0B „Status of input B“ wird der aktuelle Pegel am Eingang B angezeigt.
Direction Inversion Counter
Zählrichtungsumkehr (Index 0x80n0:0E „Reversion of rotation“) bei einem Zähler/Impulsgeber
0x80n1:1D “Counter mode” | Pegel am Eingang Spur B | 0x80n0:0E „Reversion of rotation” | Resultierende Zählrichtung
1: Counter RS422 (diff. input) | Eingang offen / LOW Pegel | FALSE | Positiv
 |  | TRUE | Negativ
 | RS422 Signalpegel | FALSE | Negativ
 |  | TRUE | Positiv
3: Counter TTL (Single-Ended) | Eingang offen / LOW Pegel, Spannungspegel < 0,8 V | FALSE | Positiv
 |  | TRUE | Negativ
 | TTL Spannungspegel 2.0 V bis 6,0 V, mit min. 2,1 mA Strom | FALSE | Negativ
 |  | TRUE | Positiv
5: Counter open collector | Eingang offen / LOW Pegel, Spannungspegel < 0,8 V | FALSE | Positiv
 |  | TRUE | Negativ
 | Open Collector Spannungspegel 2.0 V bis 6,0 V, mit min. 2,1 mA Strom | FALSE | Negativ
 |  | TRUE | Positiv
Status LED Eingang B als Counter RS422 (diff. Input)
Ist im Counter mode „RS422 (diff. Input)“ der Eingang der Spur B offen, so wird ein Drahtbruch detektiert und die Status LED des Eingangs B leuchtet rot. Die Fehlererkennung und Meldung über die LED kann über Index 0x80n0:0C „Error detection B“ ausgeschaltet werden.


Zählerstand reset

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand reset
Zählerstand reset
Ein wiederkehrendes Rücksetzen des Zählerstandes (Index 0x60n0:11 „Counter value“) auf „0“ kann erfolgen durch:
▪
Eingang Nullimpuls C: eine positive Flanke am Nullimpuls C Eingang („Enable C reset“)
▪
Eingang Latch: eine Flanke (positiv/negativ) am Latch extern-Eingang („Enable extern reset“)
Die Einstellungen werden in den Konfigurationsdaten vorgenommen, dadurch ist eine erneute Aktivierung, nach Ausführung des Resets, nicht notwendig.
Eine gleichzeitige Aktivierung der Funktionen „Enable C reset“ (Index 0x80n0:01) und „Enable extern reset“ (Index 0x80n0:02) ist nicht möglich.
Zählerstand Reset über den Eingang Nullimpuls C (Enable C reset)
Der Zählerstand kann zu jeder vollen Umdrehung des Gebers über den Nullimpuls C auf den im Index 0x80n0:1B „Reset counter value“ vorgegebenen Wert gesetzt werden.
▪
Vorgabe des Reset-Wertes über Index 0x80n1:1B „Reset counter value“ (Default: 0)
▪
Zu Aktivierung dieser Funktion setzen Sie das Bit im Index 0x80n0:01 „Enable C reset“.
▪
Es erfolgt keine Statusmeldung über die Prozessdaten.
Zählerstand Reset über den Latch extern-Eingang (Enable extern reset)
Der Zählerstand kann über den Latch extern-Eingang auf „0“ gesetzt werden.
▪
Vorgabe des Reset-Wertes über Index 0x80n1:1B „Reset counter value“, (Default: 0)
▪
Zur Aktivierung dieser Funktion setzen Sie das Bit im Index 0x80n0:02 „Enable extern reset“.
▪
Legen Sie über Index 0x80n0:10 „Extern reset polarity“ fest, bei welcher Flanke der Latch extern-Eingang aktiv ist.
–
0: „Fall“ - mit fallender Flanke wird der Zähler auf „0“ gesetzt
–
1: „Rise“ - mit steigender Flanke wird der Zähler auf „0“ gesetzt
Es erfolgt keine Statusmeldung über die Prozessdaten.


Zählerstand setzen

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand setzen
Zählerstand setzen
Der Zählerstand (Counter value) kann zur Laufzeit auf einen vorgegebenen Zählerwert gesetzt und damit zur Synchronisation mit anderen Prozessen genutzt werden. Die Vorgabe kann wie folgt aktiviert werden:
▪
SPS Variable: der Zählerstand kann aus der SPS Anwendung heraus gesetzt werden (Set counter value)
▪
Eingang Nullimpuls C: über den Nullimpuls C des Encoders (Set counter on latch C)
▪
Eingang Latch: eine positive oder negative Flanke am Latch extern Eingang (Set counter on latch extern on positive/negative edge)
Mehrfachaktivierung von „Set counter on ...“
Werden mehrere Befehle zu Übernahme des vorgegebenen Zählerstandes aktiviert, so wird nur der zuerst gesetzte Befehl von der Klemme akzeptiert. Alle anderen Befehle werden nicht berücksichtigt, bleiben aber systembedingt aktiviert.
•
Der Zählerstand wird bei dem zuerst aktivierten Ereignis, auf den vorgegebenen Zählerstand gesetzt und über das Bit „Set counter done“ (Index 0x60n0:03) bestätigt.
•
Eine erneute Aktivierung der Zählerwertvorgabe kann erst erfolgen, wenn alle aktivierten Befehle zur Übernahme des Zählerstandes deaktiviert wurden. Dies wird bestätigt, indem das „Set counter done“-Bit (Index 0x60n0:03) auf FALSE gesetzt wird.
Zählerstand setzen über eine SPS Variable (Set counter value)
Der Zählerstand kann zur Laufzeit über die Prozessdaten auf einen vorgegebenen Zählerwert gesetzt werden (0x70n0:03 „Set counter“). In der SPS kann dieses Bit z. B. mit einem digitalen Eingang verknüpft, oder auch direkt als Variable genutzt werden.
▪
Vorgabe des Zählerwerts über den Index 0x70n0:11 „Set counter value“
▪
Aktivierung der Zählwertvorgabe über die SPS Variable: Index 0x70n0:03 „Set counter“
▪
Zur Bestätigung wird das „Set counter done“- Bit in Index 0x60n0:03 auf TRUE gesetzt.
▪
Eine erneute Aktivierung der Zählwertvorgabe kann erst erfolgen, wenn der Index 0x70n0:03 „Set counter“ FALSE gesetzt wurde.
Zählerstand setzen über den Eingang Nullimpuls C (Set counter on Latch C)
Der Zählerstand kann zur Laufzeit über die Prozessdaten durch den Nullimpuls C auf einen vorgegebenen Zählerwert gesetzt werden.
▪
Zählwertvorgabe über Index 0x70n0:11 „Set counter value“
▪
Aktivierung der Zählwertvorgabe über den Nullimpuls C:
–
Index 0x70n0:08 „Set counter on latch C“ = TRUE
Beim nächsten Nullimpuls wird der Zählerwert (Counter value) auf den in Index 0x70n0:11(Set counter value) vorgegebenen Zählerwert gesetzt.
▪
Zur Bestätigung wird das „Set counter done“- Bit in Index 0x60n0:03, auf TRUE gesetzt.
▪
Eine erneute Aktivierung der Zählwertvorgabe über den Nullimpuls C kann erst erfolgen, wenn das „Set counter on latch C“-Bit in Index 0x70n0:08 auf FALSE gesetzt wurde.
Zählerstand setzen über den Latch extern-Eingang (Set counter on latch extern on positive/negative edge)
Der Zählerstand kann zur Laufzeit über die Prozessdaten durch die positive oder negative Flanke am Latch extern-Eingang auf einen vorgegebenen Zählerstand gesetzt werden.
▪
Zählwertvorgabe über Index 0x70n0:11 „Set counter value“
▪
Aktivierung der Zählwertvorgabe über
–
die positive Flanke am Latch extern-Eingang: Index 0x70n0:0A „Set counter on latch extern on positive edge“
–
die negative Flanke am Latch extern-Eingang: Index 0x70n0:0B „Set counter on latch extern on negative edge“
▪
Bei gesetztem Bit (TRUE) im Index 0x70n0:0A oder 0x070n0:0B wird bei der nächsten steigenden oder fallenden Flanke am Latch extern-Eingang der Zählerstand (Counter value) auf den vorgegebenen Zählerwert (Set counter value) gesetzt.
▪
Zur Bestätigung wird das „Set counter done“- Bit (Index 0x60n0:11) auf TRUE gesetzt.
▪
Eine erneute Aktivierung der Zählwertvorgabe kann erst erfolgen, wenn Index 0x70n0:0A/0B „Set counter on latch extern on positive/negative edge“ auf FALSE gesetzt wurde.


Zählrichtung detektieren

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählrichtung detektieren
Zählrichtung detektieren
Die Klemme kann über Index 0x80n1:1C „Direction inversion hysteresis“ wie folgt parametriert werden:
▪
Zählrichtung detektieren: positive Drehrichtung wird als „0“ und eine negative Drehrichtung als „1“ in den Prozessdaten über Index 0x60n2:13 „Direction inversion detected“ ausgegeben.
Oder
▪
Zählrichtungsumkehr detektieren: wird eine Drehrichtungsumkehr detektiert, wird dies in den Prozessdaten über Index 0x60n2:13 „Direction inversion detected“ ausgegeben. Diese Funktion kann auch zur Stillstandüberwachung genutzt werden.
Zählrichtung detektieren
▪
Setzen der Hysterese, über Index 0x80n1:1C „Direction inversion hysteresis“ = 0
▪
Für die Detektion der Zählrichtung wird der Positionswert vom letzten SPS Zyklus (pos 1) von dem Positionswert des aktuellen SPS Zyklus (pos 2) subtrahiert.
▪
Das Resultat wird beim nächste SPS Zyklus über Index 0x60n2:13 „Direction inversion detected“ ausgegeben. Dabei wird ein positives Ergebnis als positive Drehrichtung interpretiert (0x60n2:13 „Direction inversion detected“ = 0), ein negatives als negative Drehrichtung (0x60n2:13 „Direction inversion detected“ = 1).
0x80n1:1C „Direction inversion hysteresis“ = 0
Positionsänderung | Drehrichtung | 0x60n2:13 „Direction inversion detected“
pos 2 – pos 1 > 0 | Positive Drehrichtung (CW) | 0
pos 2 – pos 1 < 0 | Negative Drehrichtung (CCW) | 1
pos 2 – pos 1 = 0 | Keine Änderung der Drehrichtung | Keine Statusänderung
Überlauf / Counter overflow | Keine Änderung der Drehrichtung | Keine Statusänderung
Unterlauf / Counter underflow | Keine Änderung der Drehrichtung | Keine Statusänderung
▪
Beim hochstarten der Klemme wird im ersten SPS Zyklus von einer positiven Drehrichtung ausgegangen (0x60n2:13 „Direction inversion detected“ = 0), da hier zunächst ein zweiter Positionswert für die Berechnung fehlt.
▪
Wird ein Überlauf (0x60n0:05 „Counter overflow“) oder Unterlauf (0x60n0:04 „Counter underflow“) des Zählerstandes detektiert, so wird das Ergebnis für den nächsten SPS Zyklus intern korrigiert, siehe folgende Abb. (A).
▪
Wird der Zählerstand über die C-Spur oder den Eingang Latch extern geändert und führt dies zu einem negativen Positionssprung, so wird dies über das Prozessdatum 0x60n2:13 „Direction inversion detected“ angezeigt, siehe folgende Abb. (B)
▪
Wird die Zählrichtungsumkehr (Index 0x80n0:0E „Reversion of rotation“ = TRUE) aktiviert, so ändert sich auch die Logik der Detektion der Drehrichtung.
Detektion der Zählrichtung
Zählrichtungsumkehr detektieren
▪
Eingabe der Hysterese in Anzahl Inkremente, über Index 0x80n1:1C „Direction inversion hysteresis“. Es ist ein Wert > 0 zu wählen.
▪
Wird eine Richtungsumkehr detektiert, so wertet ein interner Zähler die direkt hintereinander detektierten Flanken für jede Drehrichtung aus und vergleicht diese mit der in Index 0x80n1:1C eingegebene Anzahl.
▪
Überschreitet der Zählerwert den in Index 0x80n1:1C eingegebenen Wert, so wird beim nächsten SPS Zyklus das Bit in Index 0x60n2:13 „Direction inversion detected“ gesetzt. Das Bit bleibt nur für einen Zyklus aktiv.
▪
Wird innerhalb des nächsten Zyklus eine weitere Drehrichtungsumkehr erkannt, so bleibt das Bit aktiv.
▪
Die Hysterese wird für jeden SPS Zyklus separat betrachtet, der Zähler wird somit für jeden Zyklus neu gestartet. Es findet keine SPS-Zyklusübergreifende Überwachung statt.
▪
Wird die Zählrichtungsumkehr (Index 0x80n0:0E „Reversion of rotation“ = TRUE) aktiviert, so ändert sich auch die Logik der Detektion der Drehrichtung.
▪
Treten mehrere Richtungsänderungen innerhalb eines SPS Zyklus auf, so wird lediglich angezeigt, dass mindestens eine Drehrichtungsänderung detektiert wurde.
Detektion der Zählrichtungsumkehr
Stillstandsüberwachung
Die Detektion der Richtungsumkehr kann auch zur Stillstandsüberwachung genutzt werden. Wird ein nahezu konstanter Zählerwert erwartet, so kann über die Hysterese (Index 0x80n1:1C) überwacht werden, ob sich der Wert innerhalb des Fensters befindet. Ein leichtes Zittern des Zählwertes wird somit noch als zulässiger Wert akzeptiert. Bei einer Überschreitung wird beim nächsten SPS Zyklus das Bit 0x60n2:13 „Direction inversion detected“ gesetzt.
▪
Ändert sich die Richtung innerhalb der in Index 0x80n1:1C angegebenen Hysterese [Anzahl Inkremente] erneut, wird kein Richtungswechsel angezeigt (Stillstand) s. folgende Abb. (A).
▪
Wird nach einem Richtungswechsel die in Index 0x80n1:1C angegebene Hysterese [Anzahl Inkremente] überschritten, wird der Richtungswechsel im nächsten Zyklus durch Setzen des „Direction inversion detected“-Bits in Index 0x60n2:13 angezeigt s. folgende Abb. (B).
Stillstandsüberwachung mit Hysterese und Detektion der Zählrichtungsumkehr
Wegdriften des Zählwertes
Die zuverlässige Erkennung eines wegdriftenden Zählwertes kann nur bei einem Wert in Index 0x80n1:1C „Direction inversion hysteresis“ von „1“ gewährleistet werden. Oder eine Zusätzliche Überwachung des Zählwertes in der SPS.


Zählerstand speichern

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand speichern
Zählerstand speichern
Die Latch Funktion ermöglicht das Abspeichern des aktuellen Zählerstandes in einem separaten Prozessdatum, unabhängig von der Zykluszeit. Der Gate/Latch-Eingang kann als zweiter externer Latch-Eingang, mit einem separaten Prozessdatum, parametriert werden. Die Latch Funktion kann wie folgt ausgelöst werden:
▪
Eingang Latch: positive/negative Flanke am Latch-Eingang (Enable latch extern on positive/negative edge)
▪
Eingang Gate/Latch : positive/negative Flanke am Gate/Latch-Eingang (Enable latch extern 2 on positive/negative edge)
▪
Eingang Nullimpuls C: über den Nullimpuls C (Enable latch C)
Über Index 0x80n0:22 „Enable continuous latch extern“ und 0x80n0:23 „Enable continuous latch extern 2“ kann parametriert werden, ob die Funktion bei jeder parametrierten externen Flanke am Latch-Eingang oder nur einmalig nach jeder Aktivierung ausgeführt wird.
Durch die Nutzung zweier unabhängiger Latch-Eingänge kann eine Werkstückmessung realisiert werden.
Mehrfachaktivierung der Latch-Funktion
Werden mehrere Befehle gleichzeitig zum Speichern des Zählerwerts im Prozessdatum „Latch value“ (Index 0x060n0:12) aktiviert, so wird nur der zuerst gesetzte Befehl von der Klemme akzeptiert.
•
Der Zählerstand wird bei dem nächsten auftretenden Ereignis im „Latch value“ (Index 0x60n0:12) gespeichert und mit dem entsprechenden Bit bestätigt.
•
Alle weiteren aktivierten Ereignisse werden ignoriert.
•
Eine erneute Aktivierung der Zählwertspeicherung kann erst erfolgen, wenn alle aktivierten Befehle zum Latchen des Wertes deaktiviert wurden. Dies gilt auch, wenn diese nach der Bestätigung durch das auftretende Ereignis aktiviert wurden.
Zählerstand speichern über eine positive/negative Flanke am Latch-Eingang (Enable latch extern on positive/negative edge)
▪
Speichern des Zählerstands am Latch extern-Eingang über:
–
Index 0x70n0:02 „Enable latch extern on positive edge“ = TRUE
Beim ersten externen Latchimpuls mit positiver Flanke wird der aktuelle Zählerwert in Index 0x60n0:12 „Latch value“ gespeichert.
–
Index 0x70n0:04 „Enable latch extern on negative edge“ = TRUE
Beim ersten externen Latchimpuls mit negativer Flanke wird der aktuelle Zählerwert in Index 0x60n0:12 „Latch value“ gespeichert.
–
Gleichzeitige Aktivierung von 0x70n0:02 und 0x70n0:04
beim ersten externen Latchimpuls, unabhängig von der Polarität der Flanke, wird der aktuelle Zählerwert in Index 0x60n0:12 „Latch value“ gespeichert.
▪
Festlegung ob eine erneute Aktivierung des Befehls zum Speichern des Zählerwerts erforderlich ist über:
–
„Enable continuous latch extern“ Index 0x80n0:22 = FALSE
Die folgenden Impulse am Latch extern-Eingang haben bei gesetztem Bit in Index 0x70n0:02 oder 0x70n0:04 keinen Einfluss auf den Latch-Wert in Index 0x60n0:12 „Latch value“.
Erst, wenn Index 0x60n0:02 „Latch extern valid“ FALSE ist, kann ein neuer Zählerwert auf den Latch-Eingang in Index 0x60n0:12 „Latch value“ geschrieben werden
–
„Enable continuous latch extern“ Index 0x80n0:22 = TRUE
Der Zählerwert wird bei jeder parametrierten Flanke am Latch extern-Eingang in Index 0x60n0:12 „Latch value“ geschrieben.
Eine erneute Aktivierung des Index 0x70n0:02 oder 0x70n0:04 entfällt.
▪
Das Speichern des Zählwerts im Index 0x60n0:12 „Latch value“ wird über das „Latch extern valid“-Bit (Index 0x60n0:02) bestätigt.
▪
Der Status des Latch extern-Eingangs kann über Index 0x60n2:14 „Status of extern latch“ erfasst werden.
Gleichzeitige Aktivierung von „Enable continuous latch extern“ u. „Enable latch C“
Bei Verwendung von 0x70n0:02/0x70n0:04 „Enable latch extern on positive/negative edge“, unter Aktivierung von 0x80n0:22 „Enable continuous latch extern“, gleichzeitig mit 0x70n0:01 „Enable latch C“
•
Es wird nur das erste Ereignis, entweder pos./neg. Flanke am Latch extern-Eingang oder der Nullimpuls C, in Index 0x60n0:12 „Latch value“ geschrieben.
•
Das Speichern des Zählwertes wird jeweils über Index 0x60n0:02 „Latch extern valid“ oder Index 0x60n01 „Latch C valid“ bestätigt.
•
Alle weiteren Flanken am Latch extern-Eingang werden ignoriert.
•
Eine erneute Aktivierung der Zählwertspeicherung kann erst erfolgen, wenn alle aktivierten Befehle zum Latchen des Wertes deaktiviert wurden.
Zählerstand speichern über eine positive/negative Flanke am Gate/Latch-Eingang (Enable latch extern 2 on positive/negative edge)
Die Klemme bietet die Möglichkeit den Gate/Latch-Eingang als einen zweiten Latch-Eingang (Latch extern 2) zu nutzen. Dazu sollte das Gate deaktiviert werden.
Deaktivierung des Gates
Setzen Sie das „Gate polarity“ Bit (Index 0x80n0:04) auf „0 – Disable gate“, um den Latch extern 2-Eingang nutzen zu können, ohne den Zählerstand nach dem Latch-Ereignis zu sperren.
▪
Speichern des Zählerstands am Latch extern 2-Eingang über:
–
Index 0x70n0:0C „Enable latch extern 2 on positive edge“ = TRUE
Beim ersten externen Impuls mit positiver Flanke am Gate/Latch-Eingang wird der aktuelle Zählerwert in Index 0x60n0:22 „Latch value 2“ gespeichert.
–
Index 0x70n0:0D „Enable latch extern 2 on negative edge“ = TRUE
Beim ersten externen Impuls mit negativer Flanke am Gate/Latch-Eingang wird der aktuelle Zählerwert in Index 0x60n0:22 „Latch value 2“ gespeichert.
–
Gleichzeitige Aktivierung von 0x70n0:0C und 0x70n0:0D
Beim ersten Impuls am Gate/Latch-Eingang, unabhängig von der Polarität der Flanke, wird der aktuelle Zählerwert in Index 0x60n0:22 „Latch value 2“ gespeichert.
▪
Festlegung ob eine erneute Aktivierung des Befehls zum Speichern des Zählerwerts erforderlich ist über:
–
„Enable continuous latch extern 2“ Index 0x80n0:23 = FALSE
Die folgenden Impulse am Gate/Latch-Eingang haben bei gesetztem Bit in Index 0x70n0:0C oder 0x70n0:0D keinen Einfluss auf den Latch-Wert in Index 0x60n0:22 „Latch value 2“.
Erst, wenn Index 0x60n2:12 „Latch extern 2 valid“ FALSE ist, kann ein neuer Zählerwert auf den Gate/Latch-Eingang in Index 0x60n0:22 „Latch value 2“ geschrieben werden.
–
„Enable continuous latch extern 2“ Index 0x80n0:23 = TRUE
Der Zählerwert wird bei jeder parametrierten Flanke am Gate/Latch-Eingang in Index 0x60n2:12 „Latch value 2“ geschrieben.
Eine erneute Aktivierung des Index 0x70n0:0C oder 0x70n0:0D entfällt.
▪
Der Status des Gate/Latch-Eingangs kann über Index 0x60n0:0C „Status of input gate“ erfasst werden.
▪
Das Speichern des Zählerwerts im Index 0x60n0:22 „Latch value 2“ wird über das Bit 0x60n2:12 „Latch extern 2 valid“ bestätigt.
Gleichzeitige Nutzung von Gate und Latch extern 2
Bei Verwendung von Index 0x80n0:04 „Gate polarity“(1 = „Enable pos. gate“) und gleichzeitiger Aktivierung von Index 0x70n0:0C „Enable latch extern 2 on positive edge“ wird bei positiver Flanke am Gate/Latch-Eingang der aktuelle Zählerwert zunächst in Index 0x60n0:22 „Latch value 2“ gespeichert. Danach wird der Zählerstand gesperrt.
Dasselbe gilt für die Verwendung von Index 0x80n0:04 „Gate polarity“ (2 = „Enable neg. gate“) und gleichzeitiger Aktivierung von Index 0x70n0:0D „Enable latch extern 2 on negative edge“ bei negativer Flanke am Gate/Latch-Eingang.
Zählerstand speichern über den Eingang Nullimpuls C (Enable latch C)
Der Zählerstand kann zur Laufzeit über die Prozessdaten durch den Nullimpuls in „Latch value“ (Index 0x60n0:12) gespeichert werden.
▪
Die Funktion wird aktiviert, indem das Bit in „Enable Latch C“ (Index 0x70n0:01) auf TRUE gesetzt wird.
▪
Bei dem nächsten Nullimpuls am Eingang C wird der aktuelle Zählerwert in „Latch value“ (Index 0x60n0:12) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch-Wert.
▪
Das „Latch C valid“- Bit (Index 0x60n0:01) wird auf TRUE gesetzt.
▪
Erst wenn der Wert des „Enable Latch C“-Bit (Index 0x70n0:01) und des „Latch C valid“-Bit (Index 0x60n0:01) FALSE sind, kann nach erneuter Aktivierung von „Enable Latch C“ (Index 0x70n0:01) ein neuer Zählerwert auf den Latch-Eingang geschrieben werden.
Werkstückmessung
Mit Hilfe der zwei Latch-Funktionen (Latch extern und Latch extern 2) können Werkstücke oder Abstände zwischen zwei Werkstücken erfasst werden. Um die Latch extern 2-Funktion zu nutzen, sollte das Gate deaktiviert werden über Index 0x80n0:04 „Gate polarity“ („Disable gate“ = 0).
Je nach Aktivierung der Indizes, kann der Zählerstand über eine steigende oder fallende Flanke gespeichert werden.
„Continuous latch“ bei Werkstückmessung
Um eine Überschreibung des gespeicherten Wertes zu verhindern, ist es empfehlenswert für die Werkstückmessung die Einstellung in Index 0x80n0:22 „Enable continuous latch extern“ auf FALSE zu setzen.
Beispielhafter Ablauf einer Werkstückmessung
▪
Index 0x70n0:02 „Enable latch extern on positive edge“ = TRUE:
beim ersten Impuls mit positiver Flanke am Latch extern-Eingang wird der aktuelle Zählerwert in Index 0x60n0:12 „Latch value“ gespeichert.
▪
Das Speichern des Zählwerts in Index 0x60n0:12 „Latch value“ wird über das Bit 0x60n0:02 „Latch extern valid“ bestätigt.
▪
Index 0x70n0:0D „Enable latch extern 2 on negative edge“ = TRUE:
beim ersten externen Impuls mit negativer Flanke am Gate/Latch-Eingang wird der aktuelle Zählerwert in Index 0x60n0:22 „Latch value 2“ gespeichert.
▪
Das Speichern des Zählerwerts im Index 0x60n0:22 „Latch value 2“ wird über das „Latch extern 2 valid“-Bit in Index 0x60n2:12 bestätigt.
▪
Das Ende der Messung wird über die beiden aktivierten Bits in Index 0x60n0:02 „Latch extern valid“ und Index 0x60n2:12 „Latch extern 2 valid“ bestätigt.
▪
Die Werkstücklänge kann aus der Differenz der beiden Werte „Latch value“ und „Latch value 2“ berechnet werden.
▪
Eine erneute Werkstückmessung kann gestartet werden, nachdem die Bits in Index 0x70n0:02 „Enable latch extern on positive edge“ und 0x70n0:0D „Enable latch extern 2 on negative edge“ deaktiviert wurden.


Zählerstand sperren

EL5102 - Inbetriebnahme [image] Basisfunktionen [image] Zählerstand sperren
Zählerstand sperren
Die Gate Funktion ermöglicht das Sperren des Zählers (0x60n0:11).
Der Zähler sperrt beim ersten Impuls am Gate/Latch-Eingang. Nachfolgende Impulse haben keinen Einfluss auf den Zählerstand. Dadurch kann ein Zeitfenster definiert werden, indem Zählsignale erfasst werden. Die Gate Funktion kann ausgelöst werden durch:
▪
Eingang Gate: eine positive / negative Flanke am Gate/Latch-Eingang (Enable pos./neg. gate),
▪
SPS Variable: der Zähler kann aus der SPS Anwendung heraus gesperrt werden (Set software gate).
Der Gate/Latch-Eingang kann auch als zweiter Latch-Eingang (Latch extern 2) genutzt werden.
Zählerstand sperren über eine positive/negative Flanke am Eingang Gate (Enable pos./neg. gate)
▪
Über Index 0x80n0:04 „Gate polarity“ kann der Pegel am Gate-Eingang festgelegt werden, bei dem der Zählerstand zur Laufzeit gesperrt wird.
–
0: Disable gate
Der Gate/Latch-Eingang ist deaktiviert. Er kann weiterhin als Latch extern 2-Eingang genutzt werden.
–
1: Enable pos. gate
Der Zählerstand wird mit HIGH-Pegel am Gate/Latch-Eingang gesperrt.
–
2: Enable neg. gate
Der Zählerstand wird mit LOW-Pegel am Gate/Latch-Eingang gesperrt.
▪
Über das Prozessdatum 0x60n0:0C „Status of input gate“ wird der aktuelle Pegel am Gate-Eingang angezeigt.
Gleichzeitige Nutzung von Gate und Latch extern 2
Bei Verwendung von Index 0x80n0:04 „Gate polarity“(1 = „Enable pos. gate“) und gleichzeitiger Aktivierung von Index 0x70n0:0C „Enable latch extern 2 on positive edge“ wird bei positiver Flanke am Gate/Latch-Eingang der aktuelle Zählerwert zunächst in Index 0x60n0:22 „Latch value 2“ gespeichert. Danach wird der Zählerstand gesperrt.
Dasselbe gilt für die Verwendung von Index 0x80n0:04 „Gate polarity“ (2 = „Enable neg. gate“) und gleichzeitiger Aktivierung von Index 0x70n0:0D „Enable latch extern 2 on negative edge“ bei negativer Flanke am Gate/Latch-Eingang.
Zählerstand sperren über eine SPS Variable (Set software gate)
Der Zählerstand kann aus der SPS Anwendung heraus gesperrt werden.
▪
Index 0x70n0:09 „Set software gate“ = TRUE
Der Zähler ist gesperrt.
▪
Zur Bestätigung wird das „Software gate valid“- Bit (0x60n2:11) auf TRUE gesetzt.
▪
Index 0x70n0:09 „Set software gate“ = FALSE
Der Zähler ist entsperrt.


Erweiterte Funktionen

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen
Erweiterte Funktionen
Weiterführende Informationen
•
Frequenzmessung
•
Periodendauermessung
•
Geschwindigkeits-, Drehzahlberechnung
•
Duty Cycle Auswertung
•
Mikroinkremente
•
Zeitstempelfunktion
•
Einstellbare Störimpulsfilter
•
Plausibilitätsprüfung


Frequenzmessung

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen [image] Frequenzmessung
Frequenzmessung
Die Klemme bietet die Möglichkeit neben dem reinen Zählwert auch den Frequenzwert (Frequency value) zu berechnen und auszugeben. Für die Messwertermittlung gelten folgende Grenzwerte:
Messwert- ausgabe | Messwertgrenze |  | Bemerkung
 | Untere | Obere
Frequency value | 0,095 Hz | 5 MHz | Bei 4-fach Auswertung Signaltyp: RS422 (diff. Input)
 | 0,095 Hz | 1 MHz | Bei 4-fach Auswertung Signaltyp: TTL (single ended), open collector
 | 0,095 Hz | 100 kHz | Bei 4-fach Auswertung Signaltyp: open collector
Ablauf Frequenzmessung (Frequency value)
Die Frequenz berechnet sich aus der Anzahl der Inkremente bzw. Positionswertänderungen in einem Zeitintervall. Das Ergebnis wird über die Prozessdaten in Index 0x60n0:13 „Frequency value“ ausgegeben.
Frequenz = Anzahl Perioden / Zeitintervall
Anzahl Perioden | Es wird die Anzahl ganzer Perioden auf Spur A im Zeitfenster (0x80n0:11) gemessen. Die Zählung wird mit der ersten steigenden Flanke im Zeitfenster (Index 0x80n0:11 „Frequency window“) gestartet.
Zeitintervall | Die Zeitmessung wird mit der ersten steigenden Flanke auf Spur A im Bereich des „Frequency window“ gestartet und mit der letzten fallenden Flanke innerhalb des "Frequency window" beendet. Die Zeitmessung wird mit einer Auflösung von 10 ns durchgeführt. Sonderfall: Wird innerhalb des Zeitfensters (Frequency window) keine volle Periode gemessen, wird ein weiteres Zeitfenster gestartet. Die maximale Zeitmessung zum Erfassen einer ganzen Periode ist über die Wartezeit (Frequency wait time) begrenzt.
Frequenzmessung - „Frequency value“
▪
Auswahl des Frequenzfensters in Index 0x80n0:11 „Frequency window“, Default-Wert 10 ms.
Beachten Sie die untenstehenden Hilfestellungen zur richtigen Wahl des Zeitfensters.
▪
„Frequency scaling“ (Index 0x80n0:13) gibt die Auflösung der ausgegebenen Frequenz an. Der Default-Wert beträgt 0,01 Hz. Die Frequenz kann auch in der Einheit 1 Hz (0x80n0:13 „Frequency scaling“ auf 1dez setzen) ausgegeben werden. Sind anderweitige Auflösungen gewünscht, kann die Umrechnung über 0x80n0:1D „Frequency numerator“ erfolgen.
▪
Über „Frequency value“ (Index 0x60n0:13) wird der berechnete Frequenzwert in den Prozessdaten ausgegeben.
▪
Die Berechnung wird azyklisch und ohne Bezug zum Distributed Clock-System ausgeführt und ist somit von der Betriebsart unabhängig.
▪
Ein Sperren des Zählerwertes über das Gate, ein C-Reset oder externer Reset haben keinen Einfluss auf die Frequenzberechnung.
Richtige Wahl des Zeitfensters:
Das Zeitfenster für die Frequenzmessung ist im Auslieferungszustand auf 10 ms eingestellt.
Die Genauigkeit und Größe der ermittelten Frequenz hängt von der Größe des Zeitfensters (0x80n0:11 „Frequency window“) ab, diese ist Applikationsspezifisch zu wählen. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden.
Bei konstanten Geschwindigkeiten wählen Sie ein größeres Zeitfenster, damit eine möglichst gute Mittelwertbildung erfolgen kann.
Treten jedoch vermehrt positive oder negative Beschleunigungen auf, wählen Sie das Zeitfenster kleiner, um auf die geänderten Positionswerte schneller reagieren zu können. Alternativ dazu kann bei wechselnden Geschwindigkeiten auch die Periodendauermessung genutzt werden.
Sonderfall Frequenzmessung
Wird Innerhalb des Zeitfensters „Frequency window“ (s. folgenden Abb. (1)), keine volle Periode detektiert, wird ein weiteres Zeitfenster „Frequency window“ (s. folgende Abb. (2) gestartet, um mindestens eine volle Periode aufzunehmen. Dies geschieht solange, bis die maximale Wartezeit (0x80n0:17 „Frequency wait time“) abgelaufen ist. Bis dahin wird der letzte gültige Wert im Index 0x60n0:13 „Frequency value“ ausgegeben.
Wird innerhalb der Wartezeit keine volle Periode detektiert, so wird die Messung verworfen und die Ausgabe in Index 0x60n0:13 „Frequency value“ auf „0“ gesetzt.
Frequency measurement wait time
Frequenzmessung außerhalb des Frequenzfensters mit Wartezeit
Unterschied Frequenz- und Periodendauermessung
Die Periodendauer wird für jeden Zyklus neu ermittelt und in den Prozessdaten ausgegeben. Die Frequenzmessung stellt immer eine Mittelung der gemessenen Perioden über ein Zeitfenster dar. Somit ist der „Period value“ ein aktueller Wert und der „Frequency value“ ein gemittelter Wert.


Periodendauermessung

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen [image] Periodendauermessung
Periodendauermessung
Die Klemme bietet die Möglichkeit neben dem reinen Zählwert auch die Periodendauer (Period value) zu berechnen und auszugeben.
Für die Messwertermittlung gelten folgende Grenzwerte:
Messwertausgabe | Messwertgrenze |  | Bemerkung
 | Untere | Obere
Period value | 0,20 µs | 21 s | Bei 4-fach Auswertung Signaltyp: RS422 (diff. Input)
 | 1 µs | 21 s | Bei 4-fach Auswertung Signaltyp: TTL (single ended), open collector
Ablauf Periodendauermessung (Period value)
▪
Bei der Periodendauermessung wird die Zeit zwischen zwei positiven Flanken von Eingang A, mit einer Auflösung von 10 ns gemessen.
▪
Es wird jeweils die letzte Periode innerhalb des SPS-Zyklus betrachtet und als separates Prozessdatum in Index 0x60n0:14 „Period value“ ausgegeben.
▪
„Period scaling“ (Index 0x80n0:14) gibt die Auflösung der ausgegebenen Periodendauer an. Der Default-Wert beträgt 10 ns. Die Periodendauer kann auch in der Einheit 100 ns (0x80n0:14 „Period scaling“ auf 100dez setzen) oder 500 ns (0x80n0:14 „Period scaling“ auf 500dez setzen) ausgegeben werden.
Periodendauermessung
▪
Wird Innerhalb eines SPS Zyklus keine volle Periode detektiert (zwei positive Flanken von Eingang A), so wird der letzte gültige Wert ausgegeben.
▪
Die Messung der Periode wird Zyklusübergreifend weiter fortgeführt. Sobald ein neuer Wert vorliegt, wird das Prozessdatum in Index 0x60n0:14 „Period value“ aktualisiert.
▪
Wird innerhalb von 21 s keine volle Periode detektiert, so wird die Messung verworfen und die Ausgabe in Index 0x60n0:14 „Period value“ wird auf den Maximalwert 2147483648 gesetzt.
Periodendauermessung langer Perioden
Unterschied Frequenz- und Periodendauermessung
Die Periodendauer wird für jeden Zyklus neu ermittelt und in den Prozessdaten ausgegeben. Die Frequenzmessung stellt immer eine Mittelung der gemessenen Perioden über ein Zeitfenster dar. Somit ist der „Period value“ ein aktueller Wert und der „Frequency value“ ein gemittelter Wert.


Geschwindigkeits-, Drehzahlberechnung

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen [image] Geschwindigkeits-, Drehzahlberechnung
Geschwindigkeits-, Drehzahlberechnung
Die EL5102 bietet die Möglichkeit neben dem reinen Zählerwert auch eine Geschwindigkeits- und Drehzahlmessung durchzuführen. Die Messwertermittlung erfolgt über Parametrierung der Frequenzwerte. Es gelten folgende Grenzwerte:
Messwertausgabe | Messwertgrenze |  | Bemerkung
 | Untere | Obere
Frequency value | 0,095 Hz | 5 MHz | Bei 4-fach Auswertung Signaltyp: RS422 (diff. Input)
 | 0,095 Hz | 1 MHz | Bei 4-fach Auswertung Signaltyp: TTL (single ended)
 | 0,095 Hz | 100 kHz | Bei 4-fach Auswertung Signaltyp: open collector
Die Frequenzmessung erfolgt wie in obenstehendem Kapitel „Frequenzmessung (Frequency value)“ beschrieben. Zusätzlich kann eine Umrechnung des Frequenzwertes über die beiden Indizes 0x80n0:1D „Frequency numerator“ und 0x80n0:1E „Frequency denominator“ erfolgen.
Index (hex) | Name | Bedeutung | Default
80n0:1D | Frequency numerator | Frequenz Zählerwert, Faktor zur Normierung der Frequenz z. B. der Zeiteinheit | 0x0000001 (1dez)
80n0:1E | Frequency denominator | Frequenz Nennerwert, Faktor zur Normierung der Frequenz z. B. Geschwindigkeitsberechnung | 0x0000001 (1dez)
So kann für eine Geschwindigkeitsmessung die Frequenz applikationsspezifisch normiert werden. Die Ausgabe des Messwertes in den Prozessdaten erfolgt weiterhin über „Frequency value“ (Index 0x60n0:13).
Der berechnete Messwert steht im folgenden Verhältnis zu Frequenz:
Beispiel Geschwindigkeitsberechnung in m/s
▪
Ein 200 mm Verfahrweg entspricht einer vollen mechanischen Umdrehung eines Encoders.
▪
Der Encoder hat eine 12 Bit Auflösung, d. h. 4096 Striche, dies entspricht 4096 Perioden auf Spur A.
Der Geschwindigkeitsmesswert bestimmt sich wie folgt:
Index (hex) | Name | Bsp. Geschwindigkeit in m/s | Bemerkung
80n0:1D | Frequency numerator | 0x00000C8 (200 dez) | Verfahrweg, Umrechnung in m über „Frequency denominator“
80n0:1E | Frequency denominator | 0x003E8000 (4096000 dez) | Angabe der Anzahl der Perioden über den Verfahrweg und Umrechnung des Verfahrwegs in m
Beispiel Berechnung der Drehzahl frot in Umdrehungen/s
▪
Nach einer vollen Umdrehung ergibt sich, bei einer 4-fach Auswertung (0x80n0:06 „Evaluation mode“), ein Zählerwert von 16384 Inkrementen. Dies entspricht 4096 Perioden auf Spur A.
▪
Für die Umrechnung der Zeiteinheit in Minuten kann „Frequency numerator“ genutzt werden. Dabei ist die Skalierung des Frequenzwertes (0x80n0:13 „Frequency scaling“) zu beachten:
Umrechnung in Minuten in Abhängigkeit von „Frequency scaling“
Index (hex) | Eintrag | Index (hex) | Eintrag
0x80n0:13 Frequency scaling | 100dez: 0.01 Hz | 0x80n0:1D Frequency numerator | 0x00001770 (6000dez)
 | 1dez: 1 Hz |  | 0x0000003C (60dez)
Index (hex) | Bsp. Drehzahl frot in U/min | Bemerkung
80n0:1D Frequency numerator | 0x0001770 (6000 dez) | Ausgabe des Wertes in 0,01 U/min
80n0:1E Frequency denominator | 0x0001000 (4096 dez) | Umrechnungsfaktor in Perioden / m


Duty Cycle Auswertung

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen [image] Duty Cycle Auswertung
Duty Cycle Auswertung
Der Duty Cycle beschreibt das Verhältnis der Impulsdauer tON zu Periodendauer T.
Duty Cycle [0,01%] = Impulsdauer tON / Periodendauer T * 100
Es stehen folgende Prozessdaten zur Verfügung:
Index (hex) | Name | Bedeutung | Default
60n0:23 | Duty cycle | Verhältnis Impulsdauer tON zu Periodendauer T. Ausgabe erfolgt in 1/100 | 0x0000 (0dez)
60n0:24 | Duty cycle min | Kleinster gemessener Duty cycle Wert während der aktuellen Messung | 0x2710 (10000dez)
60n0:25 | Duty cycle max | Größter gemessener Duty cycle Wert während der aktuellen Messung | 0x0000 (0dez)
Der Ablauf der Duty Cycle Messung ist wie folgt:
▪
die Impulsdauer tON wird gemessen. Dies ist die Zeit zwischen der steigenden und der fallenden Flanke von Eingang A.
▪
die Periodendauer T wird gemessen. Dies ist die Zeit zwischen zwei positiven Flanken von Eingang A.
▪
die Zeitmessungen erfolgen mit einer Auflösung von 10 ns.
▪
Es wird jeweils die letzte Periode innerhalb des SPS-Zyklus betrachtet und als separates Prozessdatum in Index 0x60n0:23 „Duty cycle“ ausgegeben.
▪
Die Ausgabe erfolgt als 1/100 des Messwertes.
▪
Die Duty Cycle Messung liefert im RS422 Modus bis 1 MHz valide Ergebnisse mit einer Genauigkeit von typ. 1 % - 2%. Bei Eingangsfrequenzen > 1 MHz können größere Messfehler auftreten.
Duty Cycle Messung
Der Kleinste und der Größte gemessene Duty cycle Wert können über das Command Objekt in Index 0xFB00:01 „Request“ zurückgesetzt werden.
0xFB001:01 „Request“ | Beschreibung
0x9130 | Setzen des Index 0x6000:24 „Duty cycle min“ für Kanal 1 auf Null
0x9140 | Setzen des Index 0x6000:25 „Duty cycle max“ für Kanal 1 auf Null
0x9131 | Setzen des Index 0x6010:24 „Duty cycle min“ für Kanal 2 auf Null
0x9141 | Setzen des Index 0x6010:25 „Duty cycle max“ für Kanal 2 auf Null


Mikroinkremente

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen [image] Mikroinkremente
Mikroinkremente
Die Funktion „Mikroinkremente“ bietet die Möglichkeit zwischen den gezählten Encoder-Inkrementen zusätzliche Inkremente zu interpolieren und somit die Auflösung des Zählwertes zu erhöhen.
Funktionsprinzip Mikroinkremente
Die folgende Abbildung zeigt das Funktionsprinzip der Mikroinkremente. Diese basiert auf der Interpolation von Inkrementen (orange) innerhalb real gemessener Encoder-Inkremente (blau). Für die vereinfachte Darstellung sind zwischen den Encoder-Inkrementen lediglich vier Mikroinkremente dargestellt. Es wird auf Basis der internen Periodendauermessung die aktuelle Geschwindigkeit gemessen und die Mikroinkremente entsprechend interpoliert. Die Interpolationsauflösung beträgt 8 Bit, dies entspricht 256 Werten. Somit nähert sich der Zählerwert mit Mikroinkrementen der realen Achsposition sehr gut an. Dies ist insbesondere bei langsamen Geschwindigkeiten hilfreich, da ein Encoder mit geringer Auflösung durch eingeschaltete Mikroinkremente so zu einem hochauflösenden Achsgeber wird.
Beispiel:
▪
Encoder mit 1.024 Strichen
▪
4-fach Auswertung
▪
eingeschalteten Mikroinkrementen 8 Bit
1024 Striche * 4-fach Auswertung * 256 Mikroinkremente = 1.048.567 Striche
Funktionsprinzip Mikroinkremente
DC Betriebsart für Mikroinkremente
Um die Funktion Mikroinkremente sinnvoll nutzen zu können, sollte die Klemme im Betriebsmodus „DC synchron“ oder „DC synchron (input based)“ betrieben werden. Durch die Distributed-Clocks-Technologie wird der Zählerstand zyklisch konstant ermittelt.
Ablauf Mikroinkremente
▪
Aktivierung der Mikroinkremente über den Index 0x80n0:0A „Enable micro increments“
▪
Die Mikroinkremente werden dabei in den letzten 8 Bit des Zählwertes Index 0x60n0:11 „Counter value“ dargestellt.
▪
Dabei sollte die Periodendauer des Eingangssignals > 1,34 µs betragen, so dass die Mikroinkremente noch berechnet werden können. Ist dies nicht der Fall wird die Überschreitung durch Index 0x60n0:08 „Extrapolation stall“ in den Prozessdaten angezeigt.
▪
Wenn das Bit „Extrapolation stall“ = TRUE ist, werden die 8 Bit der Mikroinkremente im „Counter value“ auf null gesetzt.


Zeitstempelfunktion

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen [image] Zeitstempelfunktion
Zeitstempelfunktion
Der Zeitstempel wird durch die Distributed-Clocks-Technologie im EtherCAT System ermöglicht. Mithilfe dieser lokalen Uhr kann die Datenerfassung synchronisiert werden.
Die EL5102 bietet einen Zeitstempel auf folgende Eingangssignale an:
▪
die letzte Zähleränderung im SPS Zyklus
▪
Eingang Nullimpuls C:
beim Speichern des Zählerstandes auf die positive Flanke des Nullimpulses C
▪
Eingang Latch:
beim Speichern des Zählerstandes auf die ausgewählte Flanke des Latch -Eingangs
▪
Eingang Gate/Latch :
beim Speichern des Zählerstandes auf die ausgewählte Flanke des Gate/Latch-Eingangs
Um die Zeitstempelfunktion nutzen zu können, sollte die EL5102 im Betriebsmodus „DC Synchron“ oder „DC-Synchron (input based)“ betrieben werden.
Die Klemme stellt den Zeitstempel in einem Umfang von 64 Bit, optional auch mit nur 32 Bit zur Verfügung. Die Zeitstempel sind in den folgenden „Predefined PDO Assignment“ enthalten:
Predefined PDO Assignment
1.Ch Standard, extended DC mode, 64 Bit time stamp
2.Ch Standard, extended DC mode, 64 Bit time stamp
1.Ch Standard, extended DC mode, 32 Bit time stamp
2.Ch Standard, extended DC mode, 32 Bit time stamp
Diese können auch als optionale PDOs kanalweise ab- oder angewählt werden.
PDO Zuordnung | Name | Beschreibung
0x1A0B | ENC Timestamp Channel 1 | Enthält Zeitstempel im 64 Bit Umfang für Kanal 1
0x1A0C | ENC Timestamp Compact Channel 1 | Enthält Zeitstempel im 32 Bit Umfang für Kanal 1
0x1A18 | ENC Timestamp Channel 2 | Enthält Zeitstempel im 64 Bit Umfang für Kanal 2
0x1A19 | ENC Timestamp Compact Channel 2 | Enthält Zeitstempel im 32 Bit Umfang für Kanal 2
Zeitstempel auf die letzte Zähleränderung im SPS Zyklus
Das Prozessdatum Index 0x60n0:16 „Timestamp“ gibt den Zeitstempel des letzten registrierten Zählimpulses im SPS Zyklus an. Dies bedeutet, je nach Auswahl der Zählerauswertung (Index 0x80n0:06 „Evaluation mode“) wird der Zeitstempel ausgegeben auf:
0x80n0:06 „Evaluation mode“ |  | 0x60n0:16 „Timestamp“
0 | 4-fold (default) | letzte steigende oder fallende Flanke an Spur A oder Spur B
1 | 1-fold | letzte steigende Flanke an Spur A
2 | 2-fold | letzte steigende oder fallende Flanke an Spur A
Zeitstempel auf Eingang Nullimpuls C
Das Prozessdatum Index 0x60n0:1F „Timestamp C“ gibt den Zeitstempel der letzten registrierten positiven Flanke des Nullimpulses C, beim Speichern des Zählerstandes, aus.
Parametrierung des Nullimpuls C-Eingangs |  | 0x60n0:1F: „Timestamp C“ gibt den Zeitstempel auf:
0x70n0:01 | Enable Latch C | die positive Flanke des Nullimpuls C, bei der der Zählerstand in Index 0x60n0:02 „Latch value“ gespeichert wurde
Zeitstempel auf den Latch extern-Eingang
Das Prozessdatum Index 0x60n0:20 „Timestamp latch“ gibt den Zeitstempel auf die ausgewählte Flanke des Latch extern-Eingangs an. Dies bedeutet, je nach Parametrierung des Latch extern-Eingangs, ist der Zeitstempel gültig für:
Parametrierung des Latch-Eingangs |  | 0x60n0:20 „Timestamp latch“ gibt den Zeitstempel auf:
0x70n0:02 | Enable Latch extern on positive edge | die letzte steigende Flanke am Latch extern-Eingang, bei der der Zählerstand in Index 0x60n0:02 „Latch value“ gespeichert wurde
0x70n0:04 | Enable Latch extern on negative edge | die letzte fallende Flanke am Latch extern-Eingang, bei der der Zählerstand in Index 0x60n0:02 „Latch value“ gespeichert wurde
Zeitstempel auf Eingang Gate/Latch
Das Prozessdatum 0x60n0:21 „Timestamp latch 2“ gibt den Zeitstempel auf die ausgewählte Flanke des Gate/Latch-Eingangs an. Der Gate/Latch-Eingang kann auch als Latch extern 2-Eingang genutzt werden. Je nach Parametrierung des Latch extern 2-Eingangs ist der Zeitstempel gültig für:
Parametrierung des Latch 2- Eingangs |  | 0x60n0:21 „Timestamp latch 2“ gibt den Zeitstempel auf:
0x70n0:0C | Enable Latch extern 2 on positive edge | die letzte steigende Flanke am Gate/Latch-Eingang, bei dem der Zählerstand in Index 0x60n0:22 „Latch value 2“ gespeichert wurde
0x70n0:0D | Enable Latch extern 2 on negative edge | die letzte fallende Flanke am Gate/Latch-Eingang, bei dem der Zählerstand in Index 0x60n0:22 „Latch value 2“ gespeichert wurde


Einstellbare Störimpulsfilter

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen [image] Einstellbare Störimpulsfilter
Einstellbare Störimpulsfilter
Eingangsfilter dienen zur Störunterdrückung an den Encoder- und Digitaleingängen. Die Klemme bietet die Möglichkeit anwendungsspezifisch verschiedene Filterfrequenzen zu parametrieren.
Dabei unterliegen die einzelnen Eingänge folgenden Filterfrequenzen:
Eingänge | Max. empfohlene Filterfrequenz
Encodereingänge: Spur A, Spur B, Spur C | RS422-Mode: 5 MHz TTL-Mode: 1 MHz Open Collector: 100 kHz
Latch-Eingang | 1 MHz
Gate/Latch-Eingang | 1 MHz
Status Input-Eingang | 100 kHz (nicht einstellbar)
Ablauf Filterfunktion
▪
Das Filter ist im Auslieferungszustand deaktiviert
▪
Über den Index 0x80n0:08 „Disable filter“ = FALSE kann das Filter aktiviert werden.
▪
Über Index 0x80n1:19 „Filter settings“ wird das Filter parametriert. Es stehen folgende Filterfrequenzen zur Verfügung:
Index 0x80n1:19 „Filter settings“ |  | Default Parameter für 0x80n1:1D „Counter mode“
Einstellung | Bedeutung | Einstellung | Bedeutung
10dez: 10 kHz | 10 kHz Filter |
25dez: 25 kHz | 25 kHz Filter |
50dez: 50 kHz | 50 KHz Filter |
100dez: 100 kHz | 100 kHz Filter | 0x80n1:1D „Counter mode“
 |  | 4dez | Encoder open collector
 |  | 5dez | Counter open collector
250dez: 250 kHz | 250 kHz Filter |
500dez: 500 kHz | 500 kHz Filter |
1000dez: 1 MHz | 1 MHz Filter | 0x80n1:1D „Counter mode“
 |  | 2dez | Encoder TTL (single ended)
 |  | 3dez | Counter TTL (single ended)
2500dez: 2.5 MHz | 2,5 MHz Filter |
5000dez: 5 MHz | 5 MHz Filter | 0x80n1:1D „Counter mode“
 |  | 0dez | Encoder RS422 (diff. Input)
 |  | 1dez | Counter RS422 (diff. Input)
▪
Wird das Filter < 1MHz parametriert, ist dieser auch für die Eingänge „Latch“ und „Gate“ aktiv.
▪
Wird beim aktivierten Filter (0x80n0:08 und 0x80n1:19) eine Frequenzüberschreitung festgestellt, so wird ein Zähler im Index 0xA0n0:16 inkrementiert.
Index (hex) | Name | Beschreibung
0xA0n0:14 | Filter violation counter extern latch | Zähler der Filterfrequenzüberschreitung des Latch extern-Eingangs
0xA0n0:15 | Filter violation counter input gate | Zähler der Filterfrequenzüberschreitung des Gate-Eingangs
0xA0n0:16 | Filter violation counter | Zähler der Filterfrequenzüberschreitung auf den Encoder-Eingangssignalen beim aktivierten Filter
Die internen Fehlerzähler können wie folgt zurückgesetzt werden:
▪
Übergang der Klemme vom Status „PREOP“ nach „OP“
oder
▪
Im Command Objekt „0xFB00:01 Request” folgende Eintrag eingeben
0xFB001:01 „Request“ | Beschreibung
0x9152 | Setzen des internen Fehlerzählers für 0xA000:14 „Filter violation counter extern latch“ für Kanal 1 auf Null
0x9153 | Setzen des internen Fehlerzählers für 0xA000:15 „Filter violation counter input gate“ für Kanal 1 auf Null
0x9154 | Setzen des internen Fehlerzählers für 0xA000:16 „Filter violation counter“ für Kanal 1 auf Null
0x9162 | Setzen des internen Fehlerzählers für 0xA010:14 „Filter violation counter extern latch“ für Kanal 2 auf Null
0x9163 | Setzen des internen Fehlerzählers für 0xA010:15 „Filter violation counter input gate“ für Kanal 2 auf Null
0x9164 | Setzen des internen Fehlerzählers für 0xA010:16 „Filter violation counter“ für Kanal 2 auf Null
Hinweis
Schnelle Digitale Eingänge – Beeinflussung durch störende Geräte
Beachten Sie, dass die Eingangsbeschaltung nur eine sehr geringe Filterung aufweist. Sie ist auf schnelle Signalübertragung vom Eingang zur Auswerteeinheit optimiert. Schnelle Pegeländerungen/Pulse im µs-Bereich und/oder hochfrequente Störsignale von Geräten (z. B. Proportionalventilen, Schrittmotor- oder DC-Motor-Endstufen) treffen also nahezu ungefiltert/ungedämpft an der Auswerteeinheit ein. Diese Störungen können fälschlicherweise als Signal erfasst werden.
Um Störungen zu unterdrücken, kann ein zusätzlicher Eingangsfilter parametriert werden. Weiterhin werden eine EMV-gerechte Verkabelung und der Einsatz von getrennten Netzteilen für die Klemme und die Störungen verursachenden Geräte empfohlen.


Plausibilitätsprüfung

EL5102 - Inbetriebnahme [image] Erweiterte Funktionen [image] Plausibilitätsprüfung
Plausibilitätsprüfung
Die Plausibilitätsprüfung der Eingangssignale dient als erweiterte Diagnose um Störsignale zu erkennen und die dadurch verursachten Sprünge im Zählerwert zu identifizieren und zu unterdrücken.
Funktionsprinzip Plausibilitätsprüfung
Die Rechtecksignale eines Inkrementalencoder mit Spur A und Spur B sind jeweils um 90° phasenverschoben. Dadurch sind nur bestimmte Übergänge im Signalverlauf zugelassen bzw. „plausibel“, so darf z. B. bei einer steigenden A-Flanke das Signal auf Spur B nicht ebenfalls steigen.
Diese Plausibilität des Signalverlaufs wird in der Klemme geprüft. Treten nicht gültige Signalübergänge auf, so werden diese, bei aktivierter Plausibilitätserkennung, erkannt und entsprechend dargestellt.
Ablauf Plausibilitätsprüfung
▪
Aktivierung der Plausibilitätsprüfung über Index 0x80n0:21 „Enable encoder plausibility check“
▪
Wird ein Plausibilitätsfehler erkannt, so wird dieser wie folgt dargestellt:
Fehlerdiagnose | Beschreibung
DiagMassage, Typ „Fehler“, Text-ID 0x8312 | Encoder Plausibilitätsfehler (Kanal n)
0xA0n0:13 „Encoder plausibility error counter“ | Fehlerzähler wird inkrementiert, wenn ein Plausibilitätsfehler erkannt wird
0x60n0:0E TxPDO State = 1 | Die zugehörigen TxPDO Daten sind nicht gültig
Der Fehlerzähler der Plausibilitätsfehler kann wie folgt zurückgesetzt werden:
▪
Übergang von PREOP nach OP
Oder
▪
Im Command Objekt in Index 0xFB00:01 „Request” folgenden Eintrag eingeben
0xFB001:01 „Request“ | Beschreibung
0x9151 | Setzen des internen Fehlerzählers 0xA000:13 „Encoder plausibility error counter“ für Kanal 1 auf Null
0x9161 | Setzen des internen Fehlerzählers 0xA010:13 „Encoder plausibility error counter“ für Kanal 2 auf Null


Eingänge

EL5102 - Inbetriebnahme [image] Eingänge
Eingänge
Funktionen der Eingänge
Die Tabelle gibt einen kurzen Überblick über die Funktionen der Eingänge. Lesen Sie die genaue Beschreibung der Funktionen in den jeweiligen Kapiteln.
Zählerstand | SPS Variable | Nullimpuls C (Latch C) | Latch-Eingang (Latch extern) | Gate/Latch-Eingang (Latch extern 2)
Setzen | Setzen aktivieren: 0x70n0:03 „Set counter“ = TRUE auf den Wert: 0x70n0:11 „Set counter value“ | Setzen aktivieren: 0x70n0:08 „Set counter on latch C“ = TRUE auf den Wert: 0x70n0:11 „Set counter value“ | Setzen aktivieren: 0x70n0:0A/0B „Set counter on latch extern on positive/negative edge“ = TRUE auf den Wert: 0x70n0:11 „Set counter value“ | -
Reset | - | Reset aktivieren: 0x80n0:01 „Enable C reset“ auf den Wert: 0x80n1:1B „Reset counter value“ | Reset aktivieren: 0x80n0:02 „Enable extern reset“ auf den Wert: 0x80n1:1B „Reset counter value" | -
Speichern | - | Speichern aktivieren: 0x70n0:01 „Enable latch C“ = TRUE Aktuellen Zählerwert speichern in: 0x60n0:12 „Latch value“ | Speichern aktivieren: 0x70n0:02/04 „Enable latch extern on positive/negative edge“ = TRUE Aktuellen Zählerwert speichern in: 0x60n0:12 „Latch value“ | Speichern über Latch extern 2-Eingang aktivieren: 0x70n0:0C/0D „Enable latch extern 2 on positive/negative edge“ = TRUE Aktuellen Zählerwert speichern in: 0x60n0:22 „Latch value 2“
Sperren | Sperren: 0x70n0:09 „Set software gate“ = TRUE | - | - | Sperren aktivieren mit HIGH-Pegel: 0x80n0:04 „Gate polarity“ = 1 mit LOW-Pegel: 0x80n0:04 „Gate polarity“ = 2
Weiterführende Informationen
•
Eingang Nullimpuls C
•
Eingang Latch (Latch extern)
•
Eingang Gate/Latch
•
Eingang „Status Input“


Eingang Nullimpuls C

EL5102 - Inbetriebnahme [image] Eingänge [image] Eingang Nullimpuls C
Eingang Nullimpuls C
Bei Inkremental-Encodern wird eine volle Umdrehung durch eine Sondermarke den Nullimpuls C gekennzeichnet. Dieser Impuls kann in der Klemme wie folgt genutzt werden:
▪
Zählerstand Reset: der Zählerstand wird auf den, in Index 0x80n1:1B „Reset counter value“ eingestellten Wert (Default-Einstellung: „0“) zurückgesetzt (Enable C reset)
▪
Zählerstand setzen: der Zählerstand wird auf einen vorgegebenen Zählerwert gesetzt (Set counter on Latch C)
▪
Zählerstand speichern: der Zählerstand wird im Latch Register gespeichert (Enable latch C)
Über das Prozessdatum 0x60n0:0B „Status of Input C“ wird der aktuelle Pegel am Nullimpuls-C-Eingang angezeigt.
Status of Input C
Der Nullimpuls C hat je nach Umdrehungsgeschwindigkeit, nur eine kurze Pulsdauer. Aufgrund der zyklischen Abfrage, kann es vorkommen, dass der HIGH-Pegel des Nullimpulses ggf. nicht deckungsgleich in das Prozessdatum 0x60n0:0B „Status of Input C“ übertragen wird.
Zählerstand Reset über den Eingang Nullimpuls C (Enable C reset)
Der Zählerstand kann zu jeder vollen Umdrehung des Gebers über den Nullimpuls C auf den im Index 0x80n0:1B „Reset counter value“ vorgegebenen Wert gesetzt werden.
▪
Vorgabe des Reset-Wertes über Index 0x80n1:1B „Reset counter value“ (Default: 0)
▪
Zu Aktivierung dieser Funktion setzen Sie das Bit im Index 0x80n0:01 „Enable C reset“.
▪
Es erfolgt keine Statusmeldung über die Prozessdaten.
Zählerstand setzen über den Eingang Nullimpuls C (Set counter on Latch C)
Der Zählerstand kann zur Laufzeit über die Prozessdaten durch den Nullimpuls C auf einen vorgegebenen Zählerwert gesetzt werden.
▪
Zählwertvorgabe über Index 0x70n0:11 „Set counter value“
▪
Aktivierung der Zählwertvorgabe über den Nullimpuls C:
–
Index 0x70n0:08 „Set counter on latch C“ = TRUE
Beim nächsten Nullimpuls wird der Zählerwert (Counter value) auf den in Index 0x70n0:11(Set counter value) vorgegebenen Zählerwert gesetzt.
▪
Zur Bestätigung wird das „Set counter done“- Bit in Index 0x60n0:03, auf TRUE gesetzt.
▪
Eine erneute Aktivierung der Zählwertvorgabe über den Nullimpuls C kann erst erfolgen, wenn das „Set counter on latch C“-Bit in Index 0x70n0:08 auf FALSE gesetzt wurde.
Mehrfachaktivierung von „Set counter on ...“
Werden mehrere Befehle zu Übernahme des vorgegebenen Zählerstandes aktiviert, so wird nur der zuerst gesetzte Befehl von der Klemme akzeptiert. Alle anderen Befehle werden nicht berücksichtigt, bleiben aber systembedingt aktiviert.
•
Der Zählerstand wird bei dem zuerst aktivierten Ereignis, auf den vorgegebenen Zählerstand gesetzt und über das Bit „Set counter done“ (Index 0x60n0:03) bestätigt.
•
Eine erneute Aktivierung der Zählerwertvorgabe kann erst erfolgen, wenn alle aktivierten Befehle zur Übernahme des Zählerstandes deaktiviert wurden. Dies wird bestätigt, indem das „Set counter done“-Bit (Index 0x60n0:03) auf FALSE gesetzt wird.
Zählerstand speichern über den Eingang Nullimpuls C (Enable latch C)
Der Zählerstand kann zur Laufzeit über die Prozessdaten durch den Nullimpuls in „Latch value“ (Index 0x60n0:12) gespeichert werden.
▪
Die Funktion wird aktiviert, indem das Bit in „Enable Latch C“ (Index 0x70n0:01) auf TRUE gesetzt wird.
▪
Bei dem nächsten Nullimpuls am Eingang C wird der aktuelle Zählerwert in „Latch value“ (Index 0x60n0:12) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch-Wert.
▪
Das „Latch C valid“- Bit (Index 0x60n0:01) wird auf TRUE gesetzt.
▪
Erst wenn der Wert des „Enable Latch C“-Bit (Index 0x70n0:01) und des „Latch C valid“-Bit (Index 0x60n0:01) FALSE sind, kann nach erneuter Aktivierung von „Enable Latch C“ (Index 0x70n0:01) ein neuer Zählerwert auf den Latch-Eingang geschrieben werden.
Mehrfachaktivierung der Latch-Funktion
Werden mehrere Befehle gleichzeitig zum Speichern des Zählerwerts im Prozessdatum „Latch value“ (Index 0x060n0:12) aktiviert, so wird nur der zuerst gesetzte Befehl von der Klemme akzeptiert.
•
Der Zählerstand wird bei dem nächsten auftretenden Ereignis im „Latch value“ (Index 0x60n0:12) gespeichert und mit dem entsprechenden Bit bestätigt.
•
Alle weiteren aktivierten Ereignisse werden ignoriert.
•
Eine erneute Aktivierung der Zählwertspeicherung kann erst erfolgen, wenn alle aktivierten Befehle zum Latchen des Wertes deaktiviert wurden. Dies gilt auch, wenn diese nach der Bestätigung durch das auftretende Ereignis aktiviert wurden.


Eingang Latch (Latch extern)

EL5102 - Inbetriebnahme [image] Eingänge [image] Eingang Latch (Latch extern)
Eingang Latch (Latch extern)
Die Klemme stellt einen Latch-Eingang (Latch extern), für 24 VDC-Signale mit einer min. Pulsdauer von tON > 1 µs, zur Verfügung. Dieser kann wie folgt genutzt werden:
▪
Zählerstand reset:
den Zählerstand auf den in Index 0x80n0:1B „Reset counter value“ gesetzten Wert (Default-Einstellung: „0“) zurück setzen (Enable extern reset)
▪
Zählerstand setzen:
den Zählerstand über eine positive oder negative Flanke auf einen vorgegebenen Zählerwert setzen (Set counter on latch extern on positive/negative edge)
▪
Zählerstand speichern:
den Zählerstand, in einem separaten Prozessdatum, über eine positive oder negative Flanke speichern (Enable latch extern on positive/negative edge)
Zählerstand Reset über den Latch extern-Eingang (Enable extern reset)
Der Zählerstand kann über den Latch extern-Eingang auf „0“ gesetzt werden.
▪
Vorgabe des Reset-Wertes über Index 0x80n1:1B „Reset counter value“, (Default: 0)
▪
Zur Aktivierung dieser Funktion setzen Sie das Bit im Index 0x80n0:02 „Enable extern reset“.
▪
Legen Sie über Index 0x80n0:10 „Extern reset polarity“ fest, bei welcher Flanke der Latch extern-Eingang aktiv ist.
–
0: „Fall“ - mit fallender Flanke wird der Zähler auf „0“ gesetzt
–
1: „Rise“ - mit steigender Flanke wird der Zähler auf „0“ gesetzt
Es erfolgt keine Statusmeldung über die Prozessdaten.
Zählerstand setzen über den Latch extern-Eingang (Set counter on latch extern on positive/negative edge)
Der Zählerstand kann zur Laufzeit über die Prozessdaten durch die positive oder negative Flanke am Latch extern-Eingang auf einen vorgegebenen Zählerstand gesetzt werden.
▪
Zählwertvorgabe über Index 0x70n0:11 „Set counter value“
▪
Aktivierung der Zählwertvorgabe über
–
die positive Flanke am Latch extern-Eingang: Index 0x70n0:0A „Set counter on latch extern on positive edge“
–
die negative Flanke am Latch extern-Eingang: Index 0x70n0:0B „Set counter on latch extern on negative edge“
▪
Bei gesetztem Bit (TRUE) im Index 0x70n0:0A oder 0x070n0:0B wird bei der nächsten steigenden oder fallenden Flanke am Latch extern-Eingang der Zählerstand (Counter value) auf den vorgegebenen Zählerwert (Set counter value) gesetzt.
▪
Zur Bestätigung wird das „Set counter done“- Bit (Index 0x60n0:11) auf TRUE gesetzt.
▪
Eine erneute Aktivierung der Zählwertvorgabe kann erst erfolgen, wenn Index 0x70n0:0A/0B „Set counter on latch extern on positive/negative edge“ auf FALSE gesetzt wurde.
Zählerstand speichern über eine positive/negative Flanke am Latch-Eingang (Enable latch extern on positive/negative edge)
▪
Speichern des Zählerstands am Latch extern-Eingang über:
–
Index 0x70n0:02 „Enable latch extern on positive edge“ = TRUE
Beim ersten externen Latchimpuls mit positiver Flanke wird der aktuelle Zählerwert in Index 0x60n0:12 „Latch value“ gespeichert.
–
Index 0x70n0:04 „Enable latch extern on negative edge“ = TRUE
Beim ersten externen Latchimpuls mit negativer Flanke wird der aktuelle Zählerwert in Index 0x60n0:12 „Latch value“ gespeichert.
–
Gleichzeitige Aktivierung von 0x70n0:02 und 0x70n0:04
beim ersten externen Latchimpuls, unabhängig von der Polarität der Flanke, wird der aktuelle Zählerwert in Index 0x60n0:12 „Latch value“ gespeichert.
▪
Festlegung ob eine erneute Aktivierung des Befehls zum Speichern des Zählerwerts erforderlich ist über:
–
„Enable continuous latch extern“ Index 0x80n0:22 = FALSE
Die folgenden Impulse am Latch extern-Eingang haben bei gesetztem Bit in Index 0x70n0:02 oder 0x70n0:04 keinen Einfluss auf den Latch-Wert in Index 0x60n0:12 „Latch value“.
Erst, wenn Index 0x60n0:02 „Latch extern valid“ FALSE ist, kann ein neuer Zählerwert auf den Latch-Eingang in Index 0x60n0:12 „Latch value“ geschrieben werden
–
„Enable continuous latch extern“ Index 0x80n0:22 = TRUE
Der Zählerwert wird bei jeder parametrierten Flanke am Latch extern-Eingang in Index 0x60n0:12 „Latch value“ geschrieben.
Eine erneute Aktivierung des Index 0x70n0:02 oder 0x70n0:04 entfällt.
▪
Das Speichern des Zählwerts im Index 0x60n0:12 „Latch value“ wird über das „Latch extern valid“-Bit (Index 0x60n0:02) bestätigt.
▪
Der Status des Latch extern-Eingangs kann über Index 0x60n2:14 „Status of extern latch“ erfasst werden.


Eingang Gate/Latch

EL5102 - Inbetriebnahme [image] Eingänge [image] Eingang Gate/Latch
Eingang Gate/Latch
Die Klemme stellt einen externen Gate/Latch-Eingang, für 24 VDC-Signale mit einer min. Pulsdauer von tON > 1 µs, zur Verfügung. Dieser kann wie folgt genutzt werden:
▪
Zählerstand sperren:
den Zählerstand über eine positive oder negative Flanke sperren (Enable pos/neg. gate)
▪
Zählerstand speichern:
den Zählerstand, in einem separaten Prozessdatum, über eine positive oder negative Flanke speichern (Enable latch extern 2 on positive(negative edge)
Zählerstand sperren über eine positive/negative Flanke am Eingang Gate (Enable pos./neg. gate)
▪
Über Index 0x80n0:04 „Gate polarity“ kann der Pegel am Gate-Eingang festgelegt werden, bei dem der Zählerstand zur Laufzeit gesperrt wird.
–
0: Disable gate
Der Gate/Latch-Eingang ist deaktiviert. Er kann weiterhin als Latch extern 2-Eingang genutzt werden.
–
1: Enable pos. gate
Der Zählerstand wird mit HIGH-Pegel am Gate/Latch-Eingang gesperrt.
–
2: Enable neg. gate
Der Zählerstand wird mit LOW-Pegel am Gate/Latch-Eingang gesperrt.
▪
Über das Prozessdatum 0x60n0:0C „Status of input gate“ wird der aktuelle Pegel am Gate-Eingang angezeigt.
Zählerstand speichern über eine positive/negative Flanke am Gate/Latch-Eingang (Enable latch extern 2 on positive/negative edge)
Die Klemme bietet die Möglichkeit den Gate/Latch-Eingang als einen zweiten Latch-Eingang (Latch extern 2) zu nutzen. Dazu sollte das Gate deaktiviert werden.
Deaktivierung des Gates
Setzen Sie das „Gate polarity“ Bit (Index 0x80n0:04) auf „0 – Disable gate“, um den Latch extern 2-Eingang nutzen zu können, ohne den Zählerstand nach dem Latch-Ereignis zu sperren.
▪
Speichern des Zählerstands am Latch extern 2-Eingang über:
–
Index 0x70n0:0C „Enable latch extern 2 on positive edge“ = TRUE
Beim ersten externen Impuls mit positiver Flanke am Gate/Latch-Eingang wird der aktuelle Zählerwert in Index 0x60n0:22 „Latch value 2“ gespeichert.
–
Index 0x70n0:0D „Enable latch extern 2 on negative edge“ = TRUE
Beim ersten externen Impuls mit negativer Flanke am Gate/Latch-Eingang wird der aktuelle Zählerwert in Index 0x60n0:22 „Latch value 2“ gespeichert.
–
Gleichzeitige Aktivierung von 0x70n0:0C und 0x70n0:0D
Beim ersten Impuls am Gate/Latch-Eingang, unabhängig von der Polarität der Flanke, wird der aktuelle Zählerwert in Index 0x60n0:22 „Latch value 2“ gespeichert.
▪
Festlegung ob eine erneute Aktivierung des Befehls zum Speichern des Zählerwerts erforderlich ist über:
–
„Enable continuous latch extern 2“ Index 0x80n0:23 = FALSE
Die folgenden Impulse am Gate/Latch-Eingang haben bei gesetztem Bit in Index 0x70n0:0C oder 0x70n0:0D keinen Einfluss auf den Latch-Wert in Index 0x60n0:22 „Latch value 2“.
Erst, wenn Index 0x60n2:12 „Latch extern 2 valid“ FALSE ist, kann ein neuer Zählerwert auf den Gate/Latch-Eingang in Index 0x60n0:22 „Latch value 2“ geschrieben werden.
–
„Enable continuous latch extern 2“ Index 0x80n0:23 = TRUE
Der Zählerwert wird bei jeder parametrierten Flanke am Gate/Latch-Eingang in Index 0x60n2:12 „Latch value 2“ geschrieben.
Eine erneute Aktivierung des Index 0x70n0:0C oder 0x70n0:0D entfällt.
▪
Der Status des Gate/Latch-Eingangs kann über Index 0x60n0:0C „Status of input gate“ erfasst werden.
▪
Das Speichern des Zählerwerts im Index 0x60n0:22 „Latch value 2“ wird über das Bit 0x60n2:12 „Latch extern 2 valid“ bestätigt.
Gleichzeitige Nutzung von Gate und Latch extern 2
Bei Verwendung von Index 0x80n0:04 „Gate polarity“(1 = „Enable pos. gate“) und gleichzeitiger Aktivierung von Index 0x70n0:0C „Enable latch extern 2 on positive edge“ wird bei positiver Flanke am Gate/Latch-Eingang der aktuelle Zählerwert zunächst in Index 0x60n0:22 „Latch value 2“ gespeichert. Danach wird der Zählerstand gesperrt.
Dasselbe gilt für die Verwendung von Index 0x80n0:04 „Gate polarity“ (2 = „Enable neg. gate“) und gleichzeitiger Aktivierung von Index 0x70n0:0D „Enable latch extern 2 on negative edge“ bei negativer Flanke am Gate/Latch-Eingang.
Mehrfachaktivierung der Latch-Funktion
Werden mehrere Befehle gleichzeitig zum Speichern des Zählerwerts im Prozessdatum „Latch value“ (Index 0x060n0:12) aktiviert, so wird nur der zuerst gesetzte Befehl von der Klemme akzeptiert.
•
Der Zählerstand wird bei dem nächsten auftretenden Ereignis im „Latch value“ (Index 0x60n0:12) gespeichert und mit dem entsprechenden Bit bestätigt.
•
Alle weiteren aktivierten Ereignisse werden ignoriert.
•
Eine erneute Aktivierung der Zählwertspeicherung kann erst erfolgen, wenn alle aktivierten Befehle zum Latchen des Wertes deaktiviert wurden. Dies gilt auch, wenn diese nach der Bestätigung durch das auftretende Ereignis aktiviert wurden.


Eingang „Status Input“

EL5102 - Inbetriebnahme [image] Eingänge [image] Eingang „Status Input“
Eingang „Status Input“
Besitzt der Encoder einen Störmelde- oder Statusausgang, so kann dieser an den „Status Input“-Eingang der Klemme angeschlossen und ausgewertet werden. Der Eingang ist 5 V kompatibel.
Handelsüblich ist der Störmelde- oder Statusausgang am Encoder mit einer negativen Logik ausgeführt. Dieser wird wie folgt von der Klemme angezeigt:
Encoder | EL5102
Störmeldeausgang | „Status Input“-Eingang (0x60n0:06 „Status of input status“) | Status Input LED | Bedeutung
HIGH Pegel / Ausgang offen | TRUE | Aus | z. B. Encoder in Ordnung
LOW Pegel / PullDown - Pegel wird aktiv auf LOW gezogen | FALSE | Rot | z. B. Encoder gestört
Liegt eine Überspannung an dem Eingang „Status Input“ an, so wird diese wie folgt angezeigt:
Fehlerdiagnose bei Überspannung an Eingang Status Input an Kanal n | Anzeige
DiagMassage, Typ „Error“, Text-ID 0x8315 | Error status input (channel n)
0xA0n0:05 “Error input status“ | TRUE
LED: Status Input Ch. n | Rot
Hinweis
Beschaltung „Status Input“-Eingang
In der Klemme ist der „Status Input“-Eingang intern über einen PullUp Widerstand (1 kOhm) auf 5 V gelegt. Der Encoder-Ausgang muss das Signal aktiv gegen GND ziehen. Der Widerstand ist dabei so zu dimensionieren, dass er < 120 Ohm beträgt.
Die externe Speisung wird nicht empfohlen. Wird extern gespeist sind max. 5 V gegen GND zulässig.


Diagnose

EL5102 - Inbetriebnahme [image] Diagnose
Diagnose
Weiterführende Informationen
•
Diagnose - Grundlagen zu Diag Messages
•
Diagnose EL5102


Diagnose - Grundlagen zu Diag Messages

EL5102 - Inbetriebnahme [image] Diagnose [image] Diagnose - Grundlagen zu Diag Messages
Diagnose - Grundlagen zu Diag Messages
Mit DiagMessages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem System Manager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.
Definition
Das System DiagMessages ist in der ETG (EtherCAT Technology Group) in der Richtlinie ETG.1020, Kap. 13 "Diagnosis Handling" definiert. Es wird benutzt, damit vordefinierte oder flexible Diagnosemitteilungen vom EtherCAT-Slave an den Master übermittelt werden können. Das Verfahren kann also nach ETG herstellerübergreifend implementiert werden. Die Unterstützung ist optional. Die Firmware kann bis zu 250 DiagMessages im eigenen CoE ablegen.
Jede DiagMessage besteht aus
▪
Diag Code (4 Byte)
▪
Flags (2 Byte; Info, Warnung oder Fehler)
▪
Text-ID (2 Byte; Referenz zum erklärenden Text aus der ESI/XML)
▪
Zeitstempel (8 Byte, lokale Slave-Zeit oder 64-Bit Distributed-Clock-Zeit, wenn vorhanden)
▪
dynamische Parameter, die von der Firmware mitgegeben werden
In der zum EtherCAT-Gerät gehörigen ESI/XML-Datei werden die DiagMessages in Textform erklärt: Anhand der in der DiagMessage enthaltenen Text-ID kann die entsprechende Klartextmeldung in den Sprachen gefunden werden, die in der ESI/XML enthalten sind. Üblicherweise sind dies bei Beckhoff-Produkten deutsch und englisch.
Der Anwender erhält durch den Eintrag NewMessagesAvailable Information, dass neue Meldungen vorliegen.
DiagMessages können im Gerät bestätigt werden: die letzte/neueste unbestätigte Meldung kann vom Anwender bestätigt werden.
Im CoE finden sich sowohl die Steuereinträge wie die History selbst im CoE-Objekt 0x10F3:
DiagMessages im CoE
Unter 0x10F3:02 ist der Subindex der neuesten DiagMessage auslesbar.
Unterstützung zur Inbetriebnahme
Das System der DiagMesssages ist vor allem während der Anlageninbetriebnahme einzusetzen. Zur Online-Diagnose während des späteren Dauerbetriebs sind die Diagnosewerte z. B. im StatusWord des Gerätes (wenn verfügbar) hilfreich.
Implementierung TwinCAT System Manager
Ab TwinCAT 2.11 werden DiagMessages, wenn vorhanden, beim Gerät in einer eigenen Oberfläche angezeigt. Auch die Bedienung (Abholung, Bestätigung) erfolgt darüber.
Implementierung DiagMessage-System im TwinCAT System Manager
Im Reiter Diag History (A) sind die Betätigungsfelder (B) wie auch die ausgelesene History (C) zu sehen. Die Bestandteile der Message:
▪
Info/Warning/Error
▪
Acknowledge-Flag (N = unbestätigt, Q = bestätigt)
▪
Zeitstempel
▪
Text-ID
▪
Klartext-Meldung nach ESI/XML Angabe
Die Bedeutung der Buttons ist selbsterklärend.
DiagMessages im ADS Logger/Eventlogger
Ab TwinCAT 3.1 build 4022 werden von einer Klemme abgesetzte DiagMessages auch im TwinCAT ADS Logger gezeigt. Da nun IO-übergreifend DiagMessages an einem Ort dargestellt werden, vereinfacht dies die Inbetriebnahme. Außerdem kann die Logger-Ausgabe in eine Datei gespeichert werden – somit stehen die DiagMessages auch langfristig für Analysen zur Verfügung.
DiagMessages liegen eigentlich nur lokal im CoE 0x10F3 in der Klemme vor und können bei Bedarf manuell z. B. über die oben genannte DiagHistory ausgelesen werden.
Bei Neuentwicklungen sind die EtherCAT-Klemmen standardmäßig so eingestellt, dass sie das Vorliegen einer DiagMessage über EtherCAT als Emergency melden; der Eventlogger kann die DiagMessage dann abholen. Die Funktion wird in der Klemme über 0x10F3:05 aktiviert, deshalb haben solche Klemmen folgenden Eintrag standardmäßig in der StartUp-Liste:
StartUp-Liste
Soll die Funktion deaktiviert werden weil z. B. viele Meldungen kommen oder der EventLogger nicht genutzt wird, kann der StartUp-Eintrag gelöscht oder auf 0 gesetzt werden.
Nachrichten in die PLC einlesen
- In Vorbereitung -
Interpretation
Zeitstempel
Der Zeitstempel wird aus der lokalen Uhr der Klemme zum Zeitpunkt des Ereignisses gewonnen. Die Zeit ist üblicherweise die Distributed-Clocks-Zeit (DC) aus Register x910.
Bitte beachten: die DC-Zeit wird in der Referenzuhr gleich der lokalen IPC/TwinCAT-Zeit gesetzt, wenn EtherCAT gestartet wird. Ab diesem Moment kann die DC-Zeit gegenüber der IPC-Zeit divergieren, da die IPC-Zeit nicht nachgeregelt wird. Es können sich so nach mehreren Wochen Betrieb ohne EtherCAT Neustart größere Zeitdifferenzen entwickeln. Als Abhilfe kann die sog. Externe Synchronisierung der DC-Zeit genutzt werden, oder es wird fallweise eine manuelle Korrekturrechnung vorgenommen: die aktuelle DC-Zeit kann über den EtherCAT Master oder durch Einsicht in das Register x901 eines DC-Slaves ermittelt werden.
Aufbau der Text-ID
Der Aufbau der MessageID unterliegt keiner Standardisierung und kann herstellerspezifisch definiert werden. Bei Beckhoff EtherCAT-Geräten (EL, EP) lautet er nach xyzz üblichwerweise:
x | y | zz
0: Systeminfo 1: Info 2: reserved 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O allgemein 7: reserved | Fehlernummer
Beispiel: Meldung 0x4413 --> Drive Warning Nummer 0x13
Übersicht Text-IDs
Spezifische Text-IDs sind in der Gerätedokumentation aufgeführt.
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x0001 | Information | System | No error | Kein Fehler
0x0002 | Information | System | Communication established | Verbindung aufgebaut
0x0003 | Information | System | Initialisation: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1012 | Information | System | EtherCAT state change Init - PreOp |
0x1021 | Information | System | EtherCAT state change PreOp - Init |
0x1024 | Information | System | EtherCAT state change PreOp - Safe-Op |
0x1042 | Information | System | EtherCAT state change SafeOp - PreOp |
0x1048 | Information | System | EtherCAT state change SafeOp - Op |
0x1084 | Information | System | EtherCAT state change Op - SafeOp |
0x1100 | Information | Allgemein | Detection of operation mode completed: 0x%X, %d | Erkennung der Betriebsart beendet
0x1135 | Information | Allgemein | Cycle time o.k.: %d | Zykluszeit o.k.
0x1157 | Information | Allgemein | Data manually saved (Idx: 0x%X, SubIdx: 0x%X) | Daten manuell gespeichert
0x1158 | Information | Allgemein | Data automatically saved (Idx: 0x%X, SubIdx: 0x%X) | Daten automatisch gespeichert
0x1159 | Information | Allgemein | Data deleted (Idx: 0x%X, SubIdx: 0x%X) | Daten gelöscht
0x117F | Information | Allgemein | Information: 0x%X, 0x%X, 0x%X | Information
0x1201 | Information | Kommunikation | Communication re-established | Kommunikation zur Feldseite wiederhergestellt Die Meldung tritt auf, wenn z. B. im Betrieb die Spannung der Powerkontakte entfernt und wieder angelegt wurde.
0x1300 | Information | Encoder | Position set: %d, %d | Position gesetzt - StartInputhandler
0x1303 | Information | Encoder | Encoder Supply ok | Encoder Netzteil OK
0x1304 | Information | Encoder | Encoder initialization successfully, channel: %X | Encoder Initialisierung erfolgreich abgeschlossen
0x1305 | Information | Encoder | Sent command encoder reset, channel: %X | Sende Kommando Encoder Reset
0x1400 | Information | Drive | Drive is calibrated: %d, %d | Antrieb ist kalibriert
0x1401 | Information | Drive | Actual drive state: 0x%X, %d | Aktueller Status des Antriebs
0x1705 | Information |  | CPU usage returns in normal range (< 85%%) | Prozessorauslastung ist wieder im normalen Bereich
0x1706 | Information |  | Channel is not in saturation anymore | Kanal ist nicht mehr in Sättigung
0x1707 | Information |  | Channel is not in overload anymore | Kanal ist nicht mehr überlastet
0x170A | Information |  | No channel range error anymore | Es liegt kein Messbereichsfehler mehr vor
0x170C | Information |  | Calibration data saved | Abgleichdaten wurden gespeichert
0x170D | Information |  | Calibration data will be applied and saved after sending the command “0x5AFE” | Abgleichdaten werden erst nach dem Senden des Kommandos „0x5AFE“ übernommen und gespeichert
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x2000 | Information | System | %s: %s |
0x2001 | Information | System | %s: Network link lost | Netzwerk Verbindung verloren
0x2002 | Information | System | %s: Network link detected | Netzwerk Verbindung gefunden
0x2003 | Information | System | %s: no valid IP Configuration - Dhcp client started | Ungültige IP Konfiguration
0x2004 | Information | System | %s: valid IP Configuration (IP: %d.%d.%d.%d) assigned by Dhcp server %d.%d.%d.%d | Gültige, vom DHCP-Server zugewiesene IP-Konfiguration
0x2005 | Information | System | %s: Dhcp client timed out | Zeitüberschreitung DHCP-Client
0x2006 | Information | System | %s: Duplicate IP Address detected (%d.%d.%d.%d) | Doppelte IP-Adresse gefunden
0x2007 | Information | System | %s: UDP handler initialized | UDP-Handler initialisiert
0x2008 | Information | System | %s: TCP handler initialized | TCP-Handler initialisiert
0x2009 | Information | System | %s: No more free TCP sockets available | Keine freien TCP Sockets verfügbar
Text-ID
Typ
Ort
Text Message
Zusätzlicher Kommentar
0x4000
Warnung
Warning: 0x%X, 0x%X, 0x%X
allgemeine Warnung, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x4001
Warnung
System
Warning: 0x%X, 0x%X, 0x%X
0x4002
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d API:%dms) from %d.%d.%d.%d successful
0x4003
Warnung
System
%s: %s Connection Close (IN:%d OUT:%d) from %d.%d.%d.%d successful
0x4004
Warnung
System
%s: %s Connection (IN:%d OUT:%d) with %d.%d.%d.%d timed out
0x4005
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Error: %u)
0x4006
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Input Data Size expected: %d Byte(s) received: %d Byte(s))
0x4007
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Output Data Size expected: %d Byte(s) received: %d Byte(s))
0x4008
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (RPI:%dms not supported -> API:%dms)
0x4101
Warnung
Allgemein
Terminal-Overtemperature
Übertemperatur. Die Innentemperatur der Klemme überschreitet die parametrierte Warnschwelle.
0x4102
Warnung
Allgemein
Discrepancy in the PDO-Configuration
Die ausgewählten PDOs passen nicht zur eingestellten Betriebsart.
Beispiel: Antrieb arbeitet im Velocity-Mode. Das Velocity-PDO ist jedoch nicht in die PDOs gemapped.
0x417F
Warnung
Allgemein
Warnung: 0x%X, 0x%X, 0x%X
0x428D
Warnung
Allgemein
Challenge is not Random
0x4300
Warnung
Encoder
Subincrements deactivated: %d, %d
Subinkremente deaktiviert (trotz aktivierter Konfiguration)
0x4301
Warnung
Encoder
Encoder-Warning
Allgemeiner Encoderfehler
0x4302
Warnung
Encoder
Maximum frequency of the input signal is nearly reached (channel %d)
Maximale Frequenz des Eingangssignals ist bald erreicht
0x4303
Warnung
Encoder
Limit counter value was reduced because of the PDO configuration (channel %d)
Limit-Zählergrenze wurde aufgrund der PDO-Konfiguration reduziert (Kanal %d)
0x4304
Warnung
Encoder
Reset counter value was reduced because of the PDO configuration (channel %d)
Reset-Zählergrenze wurde aufgrund der PDO-Konfiguration reduziert (Kanal %d)
0x4400
Warnung
Drive
Drive is not calibrated: %d, %d
Antrieb ist nicht kalibriert
0x4401
Warnung
Drive
Starttype not supported: 0x%X, %d
Starttyp wird nicht unterstützt
0x4402
Warnung
Drive
Command rejected: %d, %d
Kommando abgewiesen
0x4405
Warnung
Drive
Invalid modulo subtype: %d, %d
Modulo-Subtyp ungültig
0x4410
Warnung
Drive
Target overrun: %d, %d
Zielposition wird überfahren
0x4411
Warnung
Drive
DC-Link undervoltage (Warning)
Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden.
0x4412
Warnung
Drive
DC-Link overvoltage (Warning)
Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden.
0x4413
Warnung
Drive
I2T-Model Amplifier overload (Warning)
▪
Der Verstärker wir außerhalb der Spezifikation betrieben
▪
Das I2T-Modell des Verstärkers ist falsch parametriert
0x4414
Warnung
Drive
I2T-Model Motor overload (Warning)
▪
Der Motor wird außerhalb der parametrierten Nennwerte betrieben.
▪
Das I2T-Modell des Motors ist falsch parametriert.
0x4415
Warnung
Drive
Speed limitation active
Die maximale Drehzahl wird durch die parametrierten Objekte (z. B. velocity limitation, motor speed limitation) begrenzt. Die Warnung wird ausgegeben, wenn die Sollgeschwindigkeit größer ist, als eines der parametrierten Begrenzungen.
0x4416
Warnung
Drive
Step lost detected at position: 0x%X%X
Schrittverlust erkannt
0x4417
Warnung
Drive
Motor-Overtemperature
Die Innentemperatur des Motors übersteigt die parametrierte Warnschwelle.
0x4418
Warnung
Drive
Limit: Current
Limit: Strom wird limitiert
0x4419
Warnung
Drive
Limit: Amplifier I2T-model exceeds 100%%
Die Schwellwerte für den maximalen Strom wurden überschritten.
0x441A
Warnung
Drive
Limit: Motor I2T-model exceeds 100%%
Limit: Motor I2T-Modell übersteigt 100%
0x441B
Warnung
Drive
Limit: Velocity limitation
Die Schwellwerte für die maximale Drehzahl wurden überschritten.
0x441C
Warnung
Drive
STO while the axis was enabled
Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x4600
Warnung
Allgemein IO
Wrong supply voltage range
Versorgungsspannung im falschen Bereich
0x4610
Warnung
Allgemein IO
Wrong output voltage range
Ausgangsspannung im falschen Bereich
0x4705
Warnung
Processor usage at %d %%
Prozessorauslastung bei %d %%
0x470A
Warnung
EtherCAT Frame missed (change Settings or DC Operation Mode or Sync0 Shift Time)
EtherCAT Frame verpasst (Einstellungen, DC Operation Mode oder Sync0 Shift Time ändern)
Text-ID
Typ
Ort
Text Message
Zusätzlicher Kommentar
0x8000
Fehler
System
%s: %s
0x8001
Fehler
System
Error: 0x%X, 0x%X, 0x%X
allgemeiner Fehler, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8002
Fehler
System
Communication aborded
Kommunikation abgebrochen
0x8003
Fehler
System
Configuration error: 0x%X, 0x%X, 0x%X
allgemeine, Parameter je nach Ereignis.
Interpretation siehe Gerätedokumentation.
0x8004
Fehler
System
%s: Unsuccessful FwdOpen-Response received from %d.%d.%d.%d (%s) (Error: %u)
0x8005
Fehler
System
%s: FwdClose-Request sent to %d.%d.%d.%d (%s)
0x8006
Fehler
System
%s: Unsuccessful FwdClose-Response received from %d.%d.%d.%d (%s) (Error: %u)
0x8007
Fehler
System
%s: Connection with %d.%d.%d.%d (%s) closed
0x8100
Fehler
Allgemein
Status word set: 0x%X, %d
Fehlerbit im Statuswort gesetzt
0x8101
Fehler
Allgemein
Operation mode incompatible to PDO interface: 0x%X, %d
Betriebsart inkompatibel zum PDO-Interface
0x8102
Fehler
Allgemein
Invalid combination of Inputs and Outputs PDOs
Ungültige Kombination von In- und Output PDOs
0x8103
Fehler
Allgemein
No variable linkage
Keine Variablen verknüpft
0x8104
Fehler
Allgemein
Terminal-Overtemperature
Die Innentemperatur der Klemme überschreitet die parametrierte Fehlerschwelle. Das Aktivieren der Klemme wird unterbunden.
0x8105
Fehler
Allgemein
PD-Watchdog
Die Kommunikation zwischen Feldbus und Endstufe wird durch einen Watchdog abgesichert. Sollte die Feldbuskommunikation abbrechen, wird die Achse automatisch gestoppt.
▪
Die EtherCAT-Verbindung wurde im Betrieb unterbrochen
▪
Der Master wurde im Betrieb in den Config-Mode geschaltet
0x8135
Fehler
Allgemein
Cycletime has to be a multiple of 125 µs
Die IO- oder NC-Zykluszeit ist nicht ganzzahlig durch 125µs teilbar.
0x8136
Fehler
Allgemein
Configuration error: invalid sampling rate
Konfigurationsfehler: Ungültige Samplingrate
0x8137
Fehler
Allgemein
Elektronisches Typenschild: CRC-Fehler
Inhalt des Speicher des externen Typenschildes nicht gültig.
0x8140
Fehler
Allgemein
Sync Error
Echtzeitverletztung
0x8141
Fehler
Allgemein
Sync%X Interrupt lost
Sync%X Interrupt fehlt
0x8142
Fehler
Allgemein
Sync Interrupt asynchronous
Sync Interrupt asynchron
0x8143
Fehler
Allgemein
Jitter too big
Jitter Grenzwertüberschreitung
0x817F
Fehler
Allgemein
Error: 0x%X, 0x%X, 0x%X
0x8200
Fehler
Kommunikation
Write access error: %d, %d
Fehler beim Schreiben
0x8201
Fehler
Kommunikation
No communication to field-side (Auxiliary voltage missing)
▪
Es ist keine Spannung an den Powerkontakten angelegt
▪
Ein Firmware Update ist fehlgeschlagen
0x8281
Fehler
Kommunikation
Ownership failed: %X
0x8282
Fehler
Kommunikation
To many Keys founded
0x8283
Fehler
Kommunikation
Key Creation failed: %X
0x8284
Fehler
Kommunikation
Key loading failed
0x8285
Fehler
Kommunikation
Reading Public Key failed: %X
0x8286
Fehler
Kommunikation
Reading Public EK failed: %X
0x8287
Fehler
Kommunikation
Reading PCR Value failed: %X
0x8288
Fehler
Kommunikation
Reading Certificate EK failed: %X
0x8289
Fehler
Kommunikation
Challenge could not be hashed: %X
0x828A
Fehler
Kommunikation
Tickstamp Process failed
0x828B
Fehler
Kommunikation
PCR Process failed: %X
0x828C
Fehler
Kommunikation
Quote Process failed: %X
0x82FF
Fehler
Kommunikation
Bootmode not activated
Bootmode nicht aktiviert
0x8300
Fehler
Encoder
Set position error: 0x%X, %d
Fehler beim Setzen der Position
0x8301
Fehler
Encoder
Encoder increments not configured: 0x%X, %d
Enkoderinkremente nicht konfiguriert
0x8302
Fehler
Encoder
Encoder-Error
Die Amplitude des Resolvers ist zu klein.
0x8303
Fehler
Encoder
Encoder power missing (channel %d)
Encoderspannung nicht vorhanden (Kanal %d)
0x8304
Fehler
Encoder
Encoder communication error, channel: %X
Encoder Kommunikationsfehler
0x8305
Fehler
Encoder
EnDat2.2 is not supported, channel: %X
EnDat2.2 wird nicht unterstützt
0x8306
Fehler
Encoder
Delay time, tolerance limit exceeded, 0x%X, channel: %X
Laufzeitmessung, Toleranz überschritten
0x8307
Fehler
Encoder
Delay time, maximum value exceeded, 0x%X, channel: %X
Laufzeitmessung, Maximalwert überschritten
0x8308
Fehler
Encoder
Unsupported ordering designation, 0x%X, channel: %X (only 02 and 22 is supported)
Falsche EnDat Bestellbezeichnung
0x8309
Fehler
Encoder
Encoder CRC error, channel: %X
Encoder CRC Fehler
0x830A
Fehler
Encoder
Temperature %X could not be read, channel: %X
Temperatur kann nicht gelesen werden
0x830C
Fehler
Encoder
Encoder Single-Cycle-Data Error, channel. %X
CRC Fehler festgestellt. Überprüfen Sie den Übertragungsweg und das CRC Polynom
0x830D
Fehler
Encoder
Encoder Watchdog Error, channel. %X
Der Sensor hat nicht innerhalb einer vordefinierten Zeitspanne geantwortet
0x8310
Fehler
Encoder
Initialisation error
Initialisierungsfehler
0x8311
Fehler
Encoder
Maximum frequency of the input signal is exceeded (channel %d)
Maximale Frequenz des Eingangssignals ist überschritten (Kanal %d)
0x8312
Fehler
Encoder
Encoder plausibility error (channel %d)
Encoder Plausibilitätsfehler (Kanal %d)
0x8313
Fehler
Encoder
Configuration error (channel %d)
Konfigurationsfehler (Kanal %d)
0x8314
Fehler
Encoder
Synchronisation error
Synchronisierungsfehler
0x8315
Fehler
Encoder
Error status input (channel %d)
Fehler Status-Eingang (Kanal %d)
0x8400
Fehler
Drive
Incorrect drive configuration: 0x%X, %d
Antrieb fehlerhaft konfiguriert
0x8401
Fehler
Drive
Limiting of calibration velocity: %d, %d
Begrenzung der Kalibrier-Geschwindigkeit
0x8402
Fehler
Drive
Emergency stop activated: 0x%X, %d
Emergency-Stop aktiviert
0x8403
Fehler
Drive
ADC Error
Fehler bei Strommessung im ADC
0x8404
Fehler
Drive
Overcurrent
Überstrom Phase U, V, oder W
0x8405
Fehler
Drive
Invalid modulo position: %d
Modulo-Position ungültig
0x8406
Fehler
Drive
DC-Link undervoltage (Error)
Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden.
0x8407
Fehler
Drive
DC-Link overvoltage (Error)
Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden.
0x8408
Fehler
Drive
I2T-Model Amplifier overload (Error)
▪
Der Verstärker wir außerhalb der Spezifikation betrieben
▪
Das I2T-Modell des Verstärkers ist falsch parametriert
0x8409
Fehler
Drive
I2T-Model motor overload (Error)
▪
Der Motor wird außerhalb der parametrierten Nennwerte betrieben.
▪
Das I2T-Modell des Motors ist falsch parametriert.
0x840A
Fehler
Drive
Overall current threshold exceeded
Summenstrom überschritten
0x8415
Fehler
Drive
Invalid modulo factor: %d
Modulo-Faktor ungültig
0x8416
Fehler
Drive
Motor-Overtemperature
Die Innentemperatur des Motors übersteigt die parametrierte Fehlerschwelle. Der Motor bleibt sofort stehen. Das Aktivieren der Endstufe wird unterbunden.
0x8417
Fehler
Drive
Maximum rotating field velocity exceeded
Drehfeldgeschwindigkeit übersteigt den von Dual Use (EU 1382/2014) vorgeschriebenen Wert.
0x841C
Fehler
Drive
STO while the axis was enabled
Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x8550
Fehler
Inputs
Zero crossing phase %X missing
Nulldurchgang Phase %X fehlt
0x8551
Fehler
Inputs
Phase sequence Error
Drehrichtung Falsch
0x8552
Fehler
Inputs
Overcurrent phase %X
Überstrom Phase %X
0x8553
Fehler
Inputs
Overcurrent neutral wire
Überstrom Neutralleiter
0x8581
Fehler
Inputs
Wire broken Ch %D
Leitungsbruch Ch %d
0x8600
Fehler
Allgemein IO
Wrong supply voltage range
Versorgungsspannung im falschen Bereich
0x8601
Fehler
Allgemein IO
Supply voltage to low
Versorgungsspannung zu klein
0x8602
Fehler
Allgemein IO
Supply voltage to high
Versorgungsspannung zu groß
0x8603
Fehler
Allgemein IO
Over current of supply voltage
Überstrom der Versorgungsspannung
0x8610
Fehler
Allgemein IO
Wrong output voltage range
Ausgangsspannung im falschen Bereich
0x8611
Fehler
Allgemein IO
Output voltage to low
Ausgangsspannung zu klein
0x8612
Fehler
Allgemein IO
Output voltage to high
Ausgangsspannung zu groß
0x8613
Fehler
Allgemein IO
Over current of output voltage
Überstrom der Ausgangsspannung
0x8700
Fehler
Channel/Interface not calibrated
Kanal/Interface nicht abgeglichen
0x8701
Fehler
Operating time was manipulated
Betriebslaufzeit wurde manipuliert
0x8702
Fehler
Oversampling setting is not possible
Oversampling Einstellung nicht möglich
0x8703
Fehler
No slave controller found
Kein Slave Controller gefunden
0x8704
Fehler
Slave controller is not in Bootstrap
Slave Controller ist nicht im Bootstrap
0x8705
Fehler
Processor usage to high (>= 100%%)
Prozessorauslastung zu hoch (>= 100%%)
0x8706
Fehler
Channel in saturation
Kanal in Sättigung
0x8707
Fehler
Channel overload
Kanalüberlastung
0x8708
Fehler
Overloadtime was manipulated
Überlastzeit wurde manipuliert
0x8709
Fehler
Saturationtime was manipulated
Sättigungszeit wurde manipuliert
0x870A
Fehler
Channel range error
Messbereichsfehler des Kanals
0x870B
Fehler
no ADC clock
Kein ADC Takt vorhanden
0xFFFF
Information
Debug: 0x%X, 0x%X, 0x%X
Debug: 0x%X, 0x%X, 0x%X


Diagnose EL5102

EL5102 - Inbetriebnahme [image] Diagnose [image] Diagnose EL5102
Diagnose EL5102
Die EL5102 bietet folgende Diagnosemöglichkeiten:
▪
Überlauf und Unterlauf der Zählergrenzen
▪
RS422 - Drahtbruch- und Kurzschlusserkennung (open circuit)
▪
Überwachung der Geberbetriebsspannung
▪
Eingang Status Input Diagnose
▪
Plausibilitätsprüfung
▪
Filterfrequenzüberschreitung
Überlauf (Counter overflow) und Unterlauf (Counter underflow) der Zählergrenzen
Ein Über- oder Unterlauf der Zählgrenzen wird über die Prozessdaten 0x60n0:04 "Counter underflow" bzw. 0x60n0:05 "Counter overflow" angezeigt.
▪
Das "Counter underflow"- Bit in Index 0x60n0:04 wird gesetzt, wenn ein Unterlauf 0x80n1:1B "Reset counter value" → 0x80n1:1A "Limit counter value" eintritt. Mit Default-Parametern entspricht dies „..00 → ..FF“
Es wird zurückgesetzt, wenn 2/3 des Zählbereichs unterschritten werden.
▪
Das "Counter overflow" Bit 0x60n0:05 wird gesetzt, wenn ein Überlauf 0x80n1:1A "Limit counter value" → 0x80n1:1B "Reset counter value" eintritt. Mit Default-Parametern „..FF → ..00“
Es wird zurückgesetzt, wenn 1/3 des Zählbereiches überschritten werden.
RS422 - Drahtbruch- und Kurzschlusserkennung (open circuit)
In den RS422 (differentieller Input) Modi ist es möglich einen Drahtbruch und Kurzschluss an den einzelnen Encoder-Eingängen zu erkennen.
▪
Im Drahtbruchfall, z. B. zwischen dem Eingang A und Eingang A̅,
–
beträgt die Differenzspannung VID nahezu 0 V,
–
dies führt zu einem Fehler mit niedriger Differenzspannung.
▪
Beim Kurzschlussfall, z. B. zwischen dem Eingang A und Eingang A̅, ähnelt das Fehlerverhalten dem Drahtbruch, dies führt ebenfalls zu einer Fehlererkennung.
Aktivierung der Fehlererkennung je Kanal
Index (hex) | Name | Beschreibung
80n0:0B | Error detection A | TRUE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang A aktiviert
 |  | FALSE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang A deaktiviert
80n0:0C | Error detection B | TRUE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang B aktiviert
 |  | FALSE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang B deaktiviert
80n0:0D | Error detection C | TRUE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang C aktiviert
 |  | FALSE | Drahtbruch- und Kurzschlusserkennung für Encoder-Eingang C deaktiviert
Fehlererkennung am Beispiel eines Drahtbruches oder Kurzschlusses zwischen den Eingängen A und A̅.
Fehlerdiagnose | Anzeige | Beschreibung
LED A1 | Grün | Ein TRUE Pegel liegt an
 | Rot | Ein Fehler (open circuit) wurde detektiert
0x60n07 „Open circuit“ | TRUE | Sammelfehlermeldung für „Open circuit“ Es ist ein Drahtbruch oder Kurzschluss an einem der Encoder-Eingängen aufgetreten
 | FALSE | Es liegt kein „Open circuit“ - Fehler vor.
0xA0n0:01 „Error A“ | TRUE | Ein „Open circuit“ - Fehler (Drahtbruch oder Kurzschluss) an Encoder-Eingang A ist aufgetreten.
 | FALSE | Es liegt kein „Open circuit“ - Fehler vor.
Überwachung der Geberbetriebsspannung
Eine fehlende Geberbetriebsspannung wird dargestellt durch:
Fehlerdiagnose | Anzeige | Beschreibung
LED Power ENC. Ch.1 | grün | Geberversorgungsspannung ist vorhanden
 | aus | Geberversorgungsspannung nicht vorhanden
0xA0n0:04 „Field power failure“ | TRUE | Geberversorgungsspannung nicht vorhanden
 | FALSE | Geberversorgungsspannung ist vorhanden
DiagMessage, Text-ID | 0x8303 | Geberversorgungspannung nicht vorhanden
Hinweis
Geberbetriebsspannung erzeugt aus den 24 VDC - Powerkontakten
Die Geberbetriebsspannung wird aus den 24 VDC der Powerkontakte erzeugt. Bei fehlender Versorgung der Powerkontakte kann somit keine Geberbetriebsspannung zur Verfügung gestellt werden.
Eingang Status Input Diagnose
Besitzt der Encoder einen Störmelde- oder Statusausgang, so kann dieser an den „Status Input“-Eingang der Klemme angeschlossen und ausgewertet werden. Der Eingang ist 5 V kompatibel.
Handelsüblich ist der Störmelde- oder Statusausgang am Encoder mit einer negativen Logik ausgeführt. Dieser wird wie folgt von der Klemme angezeigt:
Encoder | EL5102
Störmeldeausgang | „Status Input“-Eingang (0x60n0:06 „Status of input status“) | Status Input LED | Bedeutung
HIGH Pegel / Ausgang offen | TRUE | Aus | z. B. Encoder in Ordnung
LOW Pegel / PullDown - Pegel wird aktiv auf LOW gezogen | FALSE | Rot | z. B. Encoder gestört
Liegt eine Überspannung an dem Eingang „Status Input“ an, so wird diese wie folgt angezeigt:
Fehlerdiagnose bei Überspannung an Eingang Status Input an Kanal n | Anzeige
DiagMassage, Typ „Error“, Text-ID 0x8315 | Error status input (channel n)
0xA0n0:05 “Error input status“ | TRUE
LED: Status Input Ch. n | Rot
Plausibilitätsprüfung
Die Plausibilitätsprüfung der Eingangssignale dient als erweiterte Diagnose um Störsignale zu erkennen und die dadurch verursachten Sprünge im Zählerwert zu identifizieren und zu unterdrücken.
Funktionsprinzip Plausibilitätsprüfung
Die Rechtecksignale eines Inkrementalencoder mit Spur A und Spur B sind jeweils um 90° phasenverschoben. Dadurch sind nur bestimmte Übergänge im Signalverlauf zugelassen bzw. „plausibel“, so darf z. B. bei einer steigenden A-Flanke das Signal auf Spur B nicht ebenfalls steigen.
Diese Plausibilität des Signalverlaufs wird in der Klemme geprüft. Treten nicht gültige Signalübergänge auf, so werden diese, bei aktivierter Plausibilitätserkennung, erkannt und entsprechend dargestellt.
Ablauf Plausibilitätsprüfung
▪
Aktivierung der Plausibilitätsprüfung über Index 0x80n0:21 „Enable encoder plausibility check“
▪
Wird ein Plausibilitätsfehler erkannt, so wird dieser wie folgt dargestellt:
Fehlerdiagnose | Beschreibung
DiagMassage, Typ „Fehler“, Text-ID 0x8312 | Encoder Plausibilitätsfehler (Kanal n)
0xA0n0:13 „Encoder plausibility error counter“ | Fehlerzähler wird inkrementiert, wenn ein Plausibilitätsfehler erkannt wird
0x60n0:0E TxPDO State = 1 | Die zugehörigen TxPDO Daten sind nicht gültig
Einstellbare Störimpulsfilterfunktion
Eingangsfilter dienen zur Störunterdrückung an den Encoder- und Digitaleingängen. Die Klemme bietet die Möglichkeit anwendungsspezifisch verschiedene Filterfrequenzen zu parametrieren.
Dabei unterliegen die einzelnen Eingänge folgenden Filterfrequenzen:
Eingänge | Max. empfohlene Filterfrequenz
Encodereingänge: Spur A, Spur B, Spur C | RS422-Mode: 5 MHz TTL-Mode: 1 MHz Open Collector: 100 kHz
Latch-Eingang | 1 MHz
Gate/Latch-Eingang | 1 MHz
Status Input-Eingang | 100 kHz (nicht einstellbar)
▪
Wird beim aktivierten Filter (0x80n0:08 und 0x80n1:19) eine Frequenzüberschreitung festgestellt, so wird ein Zähler im Index 0xA0n0:16 inkrementiert.
Index (hex) | Name | Beschreibung
0xA0n0:14 | Filter violation counter extern latch | Zähler der Filterfrequenzüberschreitung des Latch extern-Eingangs
0xA0n0:15 | Filter violation counter input gate | Zähler der Filterfrequenzüberschreitung des Gate-Eingangs
0xA0n0:16 | Filter violation counter | Zähler der Filterfrequenzüberschreitung auf den Encoder-Eingangssignalen beim aktivierten Filter


EL5102 - Objektbeschreibung und Parametrierung

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung
EL5102 - Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Kommando-Objekt
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnosedaten (kanalspezifisch)
•
Informations-/Diagnostikdaten (gerätespezifisch)
•
Standardobjekte


Restore-Objekt

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf „0x64616F6C“ setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe „0x6C6F6164“. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung [image] Konfigurationsdaten
Konfigurationsdaten
Index 80n0 ENC Settings 0 Ch.n (für n=0 [Kanal 1], n=1 [Kanal 2])
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | ENC Settings 0 Ch.n | Maximaler Subindex | UINT8 | RO | 0x23 (35dez)
80n0:01 | Enable C reset | Ein Reset des Zählers erfolgt über den C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
80n0:02 | Enable extern reset | Ein Reset des Zählers erfolgt über den externen Latch Eingang (24V) | BOOLEAN | RW | 0x00 (0dez)
80n0:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (Gate sperrt mit HIGH-Pegel) 2: Enable neg. gate (Gate sperrt mit LOW-Pegel) | BIT2 | RW | 0x01 (1dez)
80n0:06 | Evaluation mode | 0: 4-fold (Vierfachauswertung) 1: 1-fold (Einfachauswertung) 2: 2-fold (Zweifachauswertung | BIT2 | RW | 0x00 (0dez)
80n0:08 | Disable filter | 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C) 1: Deaktiviert Eingangsfilter Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. | BOOLEAN | RW | 0x01 (1dez)
80n0:0A | Enable micro increments | Bei Aktivierung interpoliert die EL5102 im DC-Modus zwischen die ganzzahligen Encoderinkremente Microinkremente hinein. Zur Anzeige werden die jeweils unteren 8 Bit des Counter-Value benutzt. Aus einem 32-Bit-Zähler wird so ein 24+8 Bit Zähler, aus einem 16-Bit-Zähler ein 8+8 Bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
80n0:0B | Error detection A | Ein Drahtbruch- oder Kurzschluss auf der A-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist. | BOOLEAN | RW | 0x01 (1dez)
80n0:0C | Error detection B | Ein Drahtbruch- oder Kurzschluss auf der B-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet. | BOOLEAN | RW | 0x01 (1dez)
80n0:0D | Error detection C | Ein Drahtbruch- oder Kurzschluss auf der C-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist. | BOOLEAN | RW | 0x00 (0dez)
80n0:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
80n0:10 | Extern reset polarity | 0: Fall (mit der fallenden Flanke wird der Zähler auf null gesetzt) 1: Rise (mit der steigenden Flanke wird der Zähler auf null gesetzt) | BIT1 | RW | 0x01 (1dez)
80n0:11 | Frequency window | Dies ist die minimale Zeit, über die die Frequenz ermittelt wird, Standardwert 10 ms [Auflösung: 1 µs]. Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. „Frequency Wait Time“ lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird in Index 0x6000:13 und als Prozessdatum ausgegeben. Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. | UINT16 | RW | 0x2710 (10000dez)
80n0:13 | Frequency scaling | Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält): 100: "0,01 Hz" (default) 1: "1 Hz" | UINT32 | RW | 0x00000064 (100dez)
80n0:14 | Period scaling | Auflösung der Periodendauer im Prozessdatum: 10: „10 ns“ Periodendauerwert ist Vielfaches von 10 ns 100: „100 ns“ Periodendauerwert ist Vielfaches von 100 ns 500: „500 ns“ Periodendauerwert ist Vielfaches von 500 ns | UINT32 | RW | 0x0000000A (10dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:17 | Frequency Wait Time | Wartezeit [ms] der Frequenzmessung Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums „Frequency“ erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. t >= 2* (1 / fmin) | UINT16 | RW | 0x53E2 (21474dez)
80n0:1D | Frequency numerator | Frequenz Zählerwert, Skalierung der Frequenz | UINT32 | RW | 0x00000001 (1dez)
80n0:1E | Frequency denominator | Frequenz Nennerwert, dient zur Skalierung der Frequenz und zur Geschwindigkeitsberechnung (Inkremente / Einheit). | UINT32 | RW | 0x00000001 (1dez)
80n0:21 | Enable encoder plausibility check | Aktivierung der Plausibilitätsprüfung | BOOLEAN | RW | 0x01 (0dez)
80n0:22 | Enable continuous latch extern | FALSE: Die folgenden Impulse am Latch-Eingang haben bei gesetztem Bit in Index 0x70n0:02 oder 0x70n0:04 keinen Einfluss auf den Latch-Wert in Index 0x60n0:12 „Latch value“. TRUE: Der Zählerwert wird bei jeder parametrierten Flanke am Latch-Eingang in Index 0x60n0:12 „Latch value“ geschrieben. Eine erneute Aktivierung des Index 0x70n0:02 oder 0x70n0:04 entfällt. | BOOLEAN | RW | 0x00 (0dez)
80n0:23 | Enable continuous latch extern | FALSE: Die folgenden Impulse am Latch extern 2-Eingang haben bei gesetztem Bit in Index 0x70n0:0C oder 0x70n0:0D keinen Einfluss auf den Latch-Wert in Index 0x60n0:22 „Latch value 2“. TRUE: Der Zählerwert wird bei jeder parametrierten Flanke am Latch extern 2-Eingang in Index 0x60n0:22 „Latch value 2“ geschrieben. Eine erneute Aktivierung des Index 0x70n0:02 oder 0x70n0:04 entfällt. | BOOLEAN | RW | 0x00 (0dez)
Index 80n1 ENC Settings 1 Ch.n (für n=0 [Kanal 1], n=1 [Kanal 2])
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | ENC Settings 1 Ch.n | Maximaler Subindex | UINT8 | RO | 0x1D (29dez)
80n1:17 | Supply voltage | Einstellung der Geberversorgung 50dez: 5.0 V (default) 120dez: 12.0 V 240dez: 24.0 V | UINT32 | RW | 0x00000032 (50dez)
80n1:19 | Filter settings | Filtereinstellungen: 10dez: 10 kHz 25dez: 25 kHz 50dez: 50 kHz 100dez: 100 kHz 250dez: 250 kHz 500dez: 500 kHz 1000dez: 1 MHz 2500dez: 2,5 MHz 5000dez: 5 MHz (default) | UINT32 | RW | 0x00001388 (5000dez)
80n1:1A | Limit counter value | Gibt den Wert für die obere Zählergrenze an. | UINT32 | RW | 0xFFFFFFFF (-1dez)
80n1:1B | Reset counter value | Gibt den Wert für die untere Zählergrenze an. | UINT32 | RW | 0x00000000 (0dez)
80n1:1C | Direction inversion hysteresis | Eingabe der Hysterese in Anzahl der Inkremente. Es ist ein Wer > 0 zu wählen. Überschreitet der Zählerwert den Wert, wird im nächsten SPS Zyklus das Bit in Index 0x60n2:13 „Direction inversion detected“ gesetzt. | UINT8 | RW | 0x0A (10dez)
80n1:1D | Counter mode | 0: Encoder RS422 (diff. Input) 1: Counter RS422 (diff. Input) 2: Encoder TTL (single ended) 3: Counter TTL (single ended) 4: Encoder open collector 5: Counter open collector | UINT32 | RW | 0x00000000 (0dez)


Kommando-Objekt

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung [image] Kommando-Objekt
Kommando-Objekt
Index FB00 RMB Command
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
FB00:0 | RMB Command | Max. Subindex |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | Über das Request-Objekt könne Kommandos an die Klemme abgesetzt werden. Befehl: |  | OCTET-STRING[2] | RW | {0}
 |  | Rücksetzen Duty cycle min./max:
 |  | 0x9130 | Index 0x6000:24 „Duty cycle min“ für Kanal 1 auf null setzen
 |  | 0x9131 | Index 0x6010:24 „Duty cycle min“ für Kanal 2 auf null setzen
 |  | 0x9140 | Index 0x6000:25 „Duty cycle max“ für Kanal 1 auf null setzen
 |  | 0x9141 | Index 0x6010:25 „Duty cycle max“ für Kanal 2 auf null setzen
 |  | Rücksetzen der Fehlerzähler für Plausibilitätsfehler:
 |  | 0x9151 | Index 0xA000:13 „Encoder plausibility error counter“ für Kanal 1 auf null setzen
 |  | 0x9161 | Index 0xA010:13 „Encoder plausibility error counter“ für Kanal 2 auf null setzen
 |  | Rücksetzen der internen Fehlerzähler:
 |  | 0x9152 | Index 0xA000:14 „Filter violation counter extern latch“ für Kanal 1 auf null setzen
 |  | 0x9153 | Index 0xA000:15 „Filter violation counter input gate“ für Kanal 1 auf null setzen
 |  | 0x9154 | Index 0xA000:16 „Filter violation counter“ für Kanal 1 auf null setzen
 |  | 0x9162 | Index 0xA010:14 „Filter violation counter extern latch“ für Kanal 2 auf null setzen
 |  | 0x9163 | Index 0xA010:15 „Filter violation counter input gate“ für Kanal 2 auf null setzen
 |  | 0x9164 | Index 0xA010:16 „Filter violation counter“ für Kanal 2 auf null setzen
FB00:02 | Status | Status des aktuell ausgeführten Kommandos 0: Kommando fehlerfrei ausgeführt 255: Kommando wird ausgeführt |  | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | Optionaler Rückgabewert des Kommandos |  | OCTET-STRING[4] | RO | {0}


Eingangsdaten

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung [image] Eingangsdaten
Eingangsdaten
Index 60n0 ENC Inputs Ch.n (für n=0 [Kanal 1], n=1 [Kanal 2])
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | ENC Inputs Ch.n | Maximaler Subindex | UINT8 | RO | 0x25 (37dez)
60n0:01 | Latch C valid | Der Zählerstand wurde mit dem Nullimpulse C-Eingang gespeichert. | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Latch extern valid | Der Zählerstand wurde über den Latch extern-Eingang gespeichert. | BOOLEAN | RO | 0x00 (0dez)
60n0:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
60n0:04 | Counter underflow | Die untere Zählergrenze wurde unterschritten. Das Bit wird zurückgesetzt, wenn der Zählerstand 2/3 des Zählbereichs unterschritten hat. | BOOLEAN | RO | 0x00 (0dez)
60n0:05 | Counter overflow | Die obere Zählergrenze wurde überschritten. Das Bit wird zurückgesetzt, wenn der Zählerstand 1/3 des Zählbereichs überschritten hat. | BOOLEAN | RO | 0x00 (0dez)
60n0:06 | Status of input status | Der Zustand des Status-Eingangs, (Störmeldeeingang „Input 1“) | BOOLEAN | RO | 0x00 (0dez)
60n0:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über Index 0x80n0:0A, 0x80n0:0B, 0x80n0:0C | BOOLEAN | RO | 0x00 (0dez)
60n0:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig. Die zur Nutzung der Mikroinkremente benötigte Mindestgeschwindigkeit wurde unterschritten | BOOLEAN | RO | 0x00 (0dez)
60n0:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
60n0:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
60n0:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
60n0:0C | Status of input gate | Der Zustand des Gate-Eingangs | BOOLEAN | RO | 0x00 (0dez)
60n0:0D | Status of extern latch | Nur im Legacy mode: Der Zustand des Latch extern-Eingangs | BOOLEAN | RO | 0x00 (0dez)
60n0:0E | Sync Error | Nur im Legacy mode: Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der Klemme ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
60n0:0F | TxPDO State | Nur im Legacy mode: Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
60n0:10 | TxPDO Toggle | Nur im Legacy mode: Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
60n0:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
60n0:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
60n0:13 | Frequency value | Die Frequenz (Einstellung der Skalierung und Auflösung in Index 0x80n0:13 und 0x80n0:15) | UINT32 | RO | 0x00000000 (0dez)
60n0:14 | Period value | Die Periodendauer (Einstellung der Skalierung und Auflösung in Index 0x80n0:14 und 0x80n0:16) | UINT32 | RO | 0x00000000 (0dez)
60n0:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |
60n0:1F | Timestamp C | Zeitstempel der letzten registrierten positiven Flanke des Nullimpulses C | UINT64 | RO |
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:20 | Timestamp latch | Zeitstempel der letzten Flanke (abhängig von der Parametrierung des Lacht-eingangs) am Latch extern. | UINT64 | RO |
60n0:21 | Timestamp latch 2 | Bei Nutzung des Gate/Latch-Eingangs als Latch extern 2-Eingang: Zeitstempel der letzten Flanke (abhängig von der Parametrierung des Gate/Latch-Eingangs) am Latch extern 2-Eingang. | UINT64 | RO |
60n0:22 | Latch value 2 | Latch-Wert des Latch extern 2-Eingangs (Gate-Eingang wird als 2. Latch-Eingang genutzt) | UINT32 | RO | 0x00000000 (0dez)
60n0:23 | Duty cycle | gibt das Verhältnis Impulsdauer / Periodendauer an. | UINT16 | RO | 0x0000 (0dez)
60n0:24 | Duty cycle min | Gibt den kleinsten gemessenen Duty cycle Wert | UINT16 | RO | 0x0000 (0dez)
60n0:25 | Duty cycle max | Gibt den höchsten gemessenen Duty cycle Wert | UINT16 | RO | 0x0000 (0dez)
Index 60n2 ENC Inputs status Ch. n (für n=0 [Kanal 1], n=1 [Kanal 2])
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n2:0 | ENC Inputs status Ch. n | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
60n2:0D | Diag | Zeigt an, dass eine neue Meldung in der „Diag History“ bereit steht | BOOLEAN | RO | 0x00 (0dez)
60n2:0E | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid) | BOOLEAN | RO | 0x00 (0dez)
60n2:0F | Input cycle counter | 2-Bit Zähler zu Synchronisierung (inkrementiert nur wenn ein neuer Wert vorliegt) | BIT2 | RO | 0x00 (0dez)
60n2:11 | Software gate valid | 0:Zähler entsperrt (Index 0x70n0:09 „Set software gate“ = FALSE) 1:Zähler ist gesperrt (Index 0x70n0:09 „Set software gate“ = TRUE) | BOOLEAN | RO | 0x00 (0dez)
60n2:12 | Latch extern 2 valid | 0:ein neuer Zählerwert kann in Index 0x60n0:22 „Latch value 2“ gespeichert werden 1: es werden keine weiteren Zählerwerte in 0x60n0:22 „Latch value 2“ gespeichert. | BOOLEAN | RO | 0x00 (0dez)
60n2:13 | Direction inversion detected | Zeigt die Umkehr der Zählrichtung an | BOOLEAN | RO | 0x00 (0dez)
60n2:14 | Status of extern latch | Der Zustand des ext. Latch extern-Eingangs | BOOLEAN | RO | 0x00 (0dez)
60n2:15 | Counter value out of range | Zeigt an, dass der Zählerwert außerhalb der parametrierten Zählergrenzen liegt | BOOLEAN | RO | 0x00 (0dez)


Ausgangsdaten

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung [image] Ausgangsdaten
Ausgangsdaten
Index 70n0 ENC Outputs Ch.n (für n=0 [Kanal 1], n=1 [Kanal 2])
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
70n0:0 | ENC Outputs Ch.n | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
70n0:01 | Enable latch C | Das Speichern über den Nullimpulse C Eingang aktivieren. | BOOLEAN | RO | 0x00 (0dez)
70n0:02 | Enable latch extern on positive edge | Das Speichern über den Latch extern-Eingang mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
70n0:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
70n0:04 | Enable latch extern on negative edge | Das Speichern über den Latch extern-Eingang mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
70n0:08 | Set counter on latch C | Aktivierung der Zählerwertvorgabe über den Nullimpuls C Eingang | BOOLEAN | RO | 0x00 (0dez)
70n0:09 | Set software gate | Sperrt den Zähler über eine SPS Variable 0: Zähler ist entsperrt 1: Zähler ist gesperrt | BOOLEAN | RO | 0x00 (0dez)
70n0:0A | Set counter on latch extern on positive edge | Aktiviert die Zählerwertvorgabe über eine positive Flanke am Latch extern-Eingang. Der Zählerwert wird in Index 0x70n0:11 „Set counter value“ vorgegeben. | BOOLEAN | RO | 0x00 (0dez)
70n0:0B | Set counter on latch extern on negative edge | Aktiviert die Zählerwertvorgabe über eine negative Flanke am Latch extern-Eingang. Der Zählerwert wird in Index 0x70n0:11 „Set counter value“ vorgegeben. | BOOLEAN | RO | 0x00 (0dez)
70n0:0C | Enable latch extern 2 on positive edge | Das Speichern über den Gate/Latch-Eingang mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
70n0:0D | Enable latch extern 2 on negative edge | Das Speichern über den Gate/Latch-Eingang mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
70n0:11 | Set counter value | Der über „Set counter“ (Index 0x70n0:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)


Informations-/Diagnosedaten (kanalspezifisch)

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung [image] Informations-/Diagnosedaten (kanalspezifisch)
Informations-/Diagnosedaten (kanalspezifisch)
Index A0n0 ENC Diag data Ch. n (für n=0 [Kanal 1], n=1 [Kanal 2])
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A0n0:0 | ENC Diag data Ch.n | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
A0n0:01 | Error A | Ein „open circuit“ Fehler an Eingang A liegt an | BOOLEAN | RO | 0x00 (0dez)
A0n0:02 | Error B | Ein „open circuit“ Fehler an Eingang B liegt | BOOLEAN | RO | 0x00 (0dez)
A0n0:03 | Error C | Ein „open circuit“ Fehler an Eingang Nullimpuls C liegt an | BOOLEAN | RO | 0x00 (0dez)
A0n0:04 | Field power failure | Geberversorgungsspannung nicht vorhanden | BOOLEAN | RO | 0x00 (0dez)
A0n0:05 | Error Input status | Über-/Unterspannung am Status Input-Eingang (Störmeldeeingang) | BOOLEAN | RO | 0x00 (0dez)
A0n0:13 | Encoder plausibility error counter | Anzahl der detektierten Plausibilitätsfehler | UINT16 | RO | 0x0000 (0dez)
A0n0:14 | Filter violation counter extern latch | Anzahl der detektierten Filterüberschreitungen am Latch -Eingang | UINT16 | RO | 0x0000 (0dez)
A0n0:15 | Filter violation counter input gate | Anzahl der detektierten Filterüberschreitungen am Gate/Latch-Eingang | UINT16 | RO | 0x0000 (0dez)
A0n0:16 | Filter violation counter | Anzahl der detektierten Filterüberschreitungen an den Encodereingängen | UINT16 | RO | 0x0000 (0dez)


Informations-/Diagnostikdaten (gerätespezifisch)

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung [image] Informations-/Diagnostikdaten (gerätespezifisch)
Informations-/Diagnostikdaten (gerätespezifisch)
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 16 Nachrichten gespeichert werden. | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Messages | Subindex der neuesten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Messages | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[20] | RO | {0}
… | … | … | … | … | …
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[20] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |


Standardobjekte

EL5102 - Inbetriebnahme [image] EL5102 - Objektbeschreibung und Parametrierung [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01FF1389 (33493897dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL5102
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 09
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 10
Index 100B Bootloader version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100B:0 | Bootloader version | Bootloader Version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13EE3052 (334377042dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 ENC RxPDO-Par Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control Ch.1 | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 02 16 03 16 04 16 05 16
Index 1401 ENC RxPDO-Par Control Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control Compact Ch.1 | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16 02 16 03 16 04 16 05 16
Index 1402 ENC RxPDO-Par Control Counter Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | ENC RxPDO-Par Control Counter Ch.1 | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 3 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 16 01 16 03 16 04 16 05 16
Index 1403 ENC RxPDO-Par Control Compact Counter Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | ENC RxPDO-Par Control Compact Counter Ch.1 | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16 01 16 02 16 04 16 05 16
Index 1404 ENC RxPDO-Par Control Legacy Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1404:0 | ENC RxPDO-Par Control Legacy Ch.1 | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dez)
1404:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 5 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 16 01 16 02 16 03 16 05 16
Index 1405 ENC RxPDO-Par Control Compact Legacy Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | ENC RxPDO-Par Control Compact Legacy Ch.1 | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 16 01 16 02 16 03 16 04 16
Index 1406 ENC RxPDO-Par Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1406:0 | ENC RxPDO-Par Control Ch.2 | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dez)
1406:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen | OCTET-STRING[6] | RO | 07 16 08 16 09 16 0A 16 0B 16
Index 1407 ENC RxPDO-Par Control Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1407:0 | ENC RxPDO-Par Control Compact Ch.2 | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dez)
1407:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 8 übertragen werden dürfen | OCTET-STRING[2] | RO | 06 16 08 16 09 16 0A 16 0B 16
Index 1408 ENC RxPDO-Par Control Counter Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1408:0 | ENC RxPDO-Par Control Counter Ch.2 | PDO Parameter RxPDO 9 | UINT8 | RO | 0x06 (6dez)
1408:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 9 übertragen werden dürfen | OCTET-STRING[6] | RO | 06 16 07 16 09 16 0A 16 0B 16
Index 1409 ENC RxPDO-Par Control Compact Counter Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1409:0 | ENC RxPDO-Par Control Compact Counter Ch.2 | PDO Parameter RxPDO 10 | UINT8 | RO | 0x06 (6dez)
1409:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 10 übertragen werden dürfen | OCTET-STRING[2] | RO | 06 16 07 16 08 16 0A 16 0B 16
Index 140A ENC RxPDO-Par Control Legacy Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
140A:0 | ENC RxPDO-Par Control Legacy Ch.2 | PDO Parameter RxPDO 11 | UINT8 | RO | 0x06 (6dez)
140A:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 11 übertragen werden dürfen | OCTET-STRING[6] | RO | 06 16 07 16 08 16 09 16 0B 16
Index 140B ENC RxPDO-Par Control Compact Legacy Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
140B:0 | ENC RxPDO-Par Control Compact Legacy Ch.2 | PDO Parameter RxPDO 12 | UINT8 | RO | 0x06 (6dez)
140B:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 12 übertragen werden dürfen | OCTET-STRING[6] | RO | 06 16 07 16 08 16 09 16 0A 16
Index 1600 ENC RxPDO-Map Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x0D (13dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x08 (Set Counter on latch C)) | UINT32 | RO | 0x7000:08, 1
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x09 (Set software gate)) | UINT32 | RO | 0x7000:09, 1
1600:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x0A (Set counter on latch extern on positive edge)) | UINT32 | RO | 0x7000:0A, 1
1600:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x0B (Set counter on latch extern on negative edge)) | UINT32 | RO | 0x7000:0B, 1
1600:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x0C (Enable latch extern 2 on positive edge)) | UINT32 | RO | 0x7000:0C, 1
1600:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x0D (Enable latch extern 2 on negative edge)) | UINT32 | RO | 0x7000:0D, 1
1600:0C | SubIndex 012 | 12. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1600:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1601 ENC RxPDO-Map Control Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control Compact Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x0D (13dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x08 (Set Counter on latch C)) | UINT32 | RO | 0x7000:08, 1
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x09 (Set software gate)) | UINT32 | RO | 0x7000:09, 1
1601:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x0A (Set counter on latch extern on positive edge)) | UINT32 | RO | 0x7000:0A, 1
1601:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x0B (Set counter on latch extern on negative edge)) | UINT32 | RO | 0x7000:0B, 1
1601:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x0C (Enable latch extern 2 on positive edge)) | UINT32 | RO | 0x7000:0C, 1
1601:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x0D (Enable latch extern 2 on negative edge)) | UINT32 | RO | 0x7000:0D, 1
1601:0C | SubIndex 012 | 12. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1601:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1602 ENC RxPDO-Map Control Counter Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | ENC RxPDO-Map Control Counter Ch.1 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7000:03, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x09 (Set software gate)) | UINT32 | RO | 0x7000:09, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1603 ENC RxPDO-Map Control Compact Counter Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | ENC RxPDO-Map Control Compact Counter Ch.1 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7000:03, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x09 (Set software gate)) | UINT32 | RO | 0x7000:09, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1603:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1604 ENC RxPDO-Map Control Legacy Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | ENC RxPDO-Map Control Legacy Ch.1 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x07 (7dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7000:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1605 ENC RxPDO-Map Control Compact Legacy Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | ENC RxPDO-Map Control Legacy Ch.1 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x07 (7dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7000:03, 1
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1605:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1605:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1606 ENC RxPDO-Map Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | ENC RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x0D (13dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7010:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7010:03, 1
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1606:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x08 (Set Counter on latch C)) | UINT32 | RO | 0x7010:08, 1
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x09 (Set software gate)) | UINT32 | RO | 0x7010:09, 1
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x0A (Set counter on latch extern on positive edge)) | UINT32 | RO | 0x7010:0A, 1
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x0B (Set counter on latch extern on negative edge)) | UINT32 | RO | 0x7010:0B, 1
1606:0A | SubIndex 010 | 10. PDO Mapping entry 0x7010 (ENC Outputs Ch.2), entry 0x0C (Enable latch extern 2 on positive edge)) | UINT32 | RO | 0x7010:0C, 1
1606:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x0D (Enable latch extern 2 on negative edge)) | UINT32 | RO | 0x7010:0D, 1
1606:0C | SubIndex 012 | 12. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1606:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1607 ENC RxPDO-Map Control Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | ENC RxPDO-Map Control Compact Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x0D (13dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7010:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7010:03, 1
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1607:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x08 (Set Counter on latch C)) | UINT32 | RO | 0x7010:08, 1
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x09 (Set software gate)) | UINT32 | RO | 0x7010:09, 1
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x0A (Set counter on latch extern on positive edge)) | UINT32 | RO | 0x7010:0A, 1
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x0B (Set counter on latch extern on negative edge)) | UINT32 | RO | 0x7010:0B, 1
1607:0A | SubIndex 010 | 10. PDO Mapping entry 0x7010 (ENC Outputs Ch.2), entry 0x0C (Enable latch extern 2 on positive edge)) | UINT32 | RO | 0x7010:0C, 1
1607:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x0D (Enable latch extern 2 on negative edge)) | UINT32 | RO | 0x7010:0D, 1
1607:0C | SubIndex 012 | 12. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1607:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1608 ENC RxPDO-Map Control Counter Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1608:0 | ENC RxPDO-Map Control Counter Ch.2 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x06 (6dez)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1608:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7010:03, 1
1608:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1608:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x09 (Set software gate)) | UINT32 | RO | 0x7010:09, 1
1608:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1608:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1609 ENC RxPDO-Map Control Compact Counter Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1609:0 | ENC RxPDO-Map Control Compact Counter Ch.2 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x06 (6dez)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1609:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7010:03, 1
1609:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1609:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x09 (Set software gate)) | UINT32 | RO | 0x7010:09, 1
1609:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1609:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 160A ENC RxPDO-Map Control Legacy Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160A:0 | ENC RxPDO-Map Control Legacy Ch.2 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x07 (7dez)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7010:01, 1
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
160A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7010:03, 1
160A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
160A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160A:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 160B ENC RxPDO-Map Control Compact Legacy Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160B:0 | ENC RxPDO-Map Control Compact Legacy Ch.2 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x07 (7dez)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7010:01, 1
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
160B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set Counter)) | UINT32 | RO | 0x7010:03, 1
160B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
160B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160B:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1800 ENC TxPDO-Par Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[14] | RO | 01 1A 02 1A 03 1A 04 1A 05 1A
Index 1801 ENC TxPDO-Par Status Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status Compact Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[14] | RO | 00 1A 02 1A 03 1A 04 1A 05 1A
Index 1802 ENC TxPDO-Par Status Counter Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | ENC TxPDO-Par Status Counter Ch.1 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[14] | RO | 00 1A 01 1A 03 1A 04 1A 05 1A
Index 1803 ENC TxPDO-Par Status Compact Counter Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Status Compact Counter Ch.1 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[14] | RO | 00 1A 01 1A 02 1A 04 1A 05 1A
Index 1804 ENC TxPDO-Par Status Legacy Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Status Legacy Ch.1 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[14] | RO | 00 1A 01 1A 02 1A 03 1A 05 1A
Index 1805 ENC TxPDO-Par Status Compact Legacy Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Status Compact Legacy Ch.1 | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[14] | RO | 00 1A 01 1A 02 1A 03 1A 04 1A
Index 1806 ENC TxPDO-Par Frequency Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1806:0 | ENC TxPDO-Par Frequency Ch.1 | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen | OCTET-STRING[14] | RO | 07 1A 00 00 00 00 00 00 00 00
Index 1807 ENC TxPDO-Par Frequency Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1807:0 | ENC TxPDO-Par Frequency Compact Ch.1 | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1807:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen | OCTET-STRING[14] | RO | 06 1A 00 00 00 00 00 00 00 00
Index 1808 ENC TxPDO-Par Period Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1808:0 | ENC TxPDO-Par Period Ch.1 | PDO Parameter TxPDO 9 | UINT8 | RO | 0x06 (6dez)
1808:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 9 übertragen werden dürfen | OCTET-STRING[14] | RO | 09 1A 00 00 00 00 00 00 00 00
Index 1809 ENC TxPDO-Par Period Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1809:0 | ENC TxPDO-Par Period Compact Ch.1 | PDO Parameter TxPDO 10 | UINT8 | RO | 0x06 (6dez)
1809:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 10 übertragen werden dürfen | OCTET-STRING[14] | RO | 08 1A 00 00 00 00 00 00 00 00
Index 180B ENC TxPDO-Par Timestamp Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180B:0 | ENC TxPDO-Par Timestamp Ch.1 | PDO Parameter TxPDO 11 | UINT8 | RO | 0x06 (6dez)
180B:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 11 übertragen werden dürfen | OCTET-STRING[14] | RO | 0C 1A 00 00 00 00 00 00 00 00
Index 180C ENC TxPDO-Par Timestamp Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180C:0 | ENC TxPDO-Par Timestamp Compact Ch.1 | PDO Parameter TxPDO 12 | UINT8 | RO | 0x06 (6dez)
180C:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 12 übertragen werden dürfen | OCTET-STRING[14] | RO | 0B 1A 00 00 00 00 00 00 00 00
Index 180D ENC TxPDO-Par Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180D:0 | ENC TxPDO-Par Status Ch.2 | PDO Parameter TxPDO 13 | UINT8 | RO | 0x06 (6dez)
180D:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 13 übertragen werden dürfen | OCTET-STRING[14] | RO | 0E 1A 0F 1A 10 1A 11 1A 12 1A
Index 180E ENC TxPDO-Par Status Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180E:0 | ENC TxPDO-Par Status Compact Ch.2 | PDO Parameter TxPDO 14 | UINT8 | RO | 0x06 (6dez)
180E:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 14 übertragen werden dürfen | OCTET-STRING[14] | RO | 0D 1A 0F 1A 10 1A 11 1A 12 1A
Index 180F ENC TxPDO-Par Status Counter Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180F:0 | ENC TxPDO-Par Status Counter Ch.2 | PDO Parameter TxPDO 15 | UINT8 | RO | 0x06 (6dez)
180F:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 15 übertragen werden dürfen | OCTET-STRING[14] | RO | 0D 1A 0E 1A 10 1A 11 1A 12 1A
Index 1810 ENC TxPDO-Par Status Compact Counter Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1810:0 | ENC TxPDO-Par Status Compact Counter Ch.2 | PDO Parameter TxPDO 16 | UINT8 | RO | 0x06 (6dez)
1810:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 16 übertragen werden dürfen | OCTET-STRING[14] | RO | 0D 1A 0E 1A 0F 1A 11 1A 12 1A
Index 1811 ENC TxPDO-Par Status Legacy Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1811:0 | ENC TxPDO-Par Status Legacy Ch.2 | PDO Parameter TxPDO 17 | UINT8 | RO | 0x06 (6dez)
1811:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 17 übertragen werden dürfen | OCTET-STRING[14] | RO | 0D 1A 0E 1A 0F 1A 10 1A 12 1A
Index 1812 ENC TxPDO-Par Status Compact Legacy Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1812:0 | ENC TxPDO-Par Status Compact Legacy Ch.2 | PDO Parameter TxPDO 18 | UINT8 | RO | 0x06 (6dez)
1812:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 18 übertragen werden dürfen | OCTET-STRING[14] | RO | 0D 1A 0E 1A 0F 1A 10 1A 11 1A
Index 1813 ENC TxPDO-Par Frequency Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1813:0 | ENC TxPDO-Par Frequency Ch.2 | PDO Parameter TxPDO 19 | UINT8 | RO | 0x06 (6dez)
1813:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 19 übertragen werden dürfen | OCTET-STRING[14] | RO | 14 1A 00 00 00 00 00 00 00 00
Index 1814 ENC TxPDO-Par Frequency Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1814:0 | ENC TxPDO-Par Frequency Compact Ch.2 | PDO Parameter TxPDO 20 | UINT8 | RO | 0x06 (6dez)
1814:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 20 übertragen werden dürfen | OCTET-STRING[14] | RO | 13 1A 00 00 00 00 00 00 00 00
Index 1815 ENC TxPDO-Par Period Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1815:0 | ENC TxPDO-Par Period Ch.2 | PDO Parameter TxPDO 21 | UINT8 | RO | 0x06 (6dez)
1815:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 21 übertragen werden dürfen | OCTET-STRING[14] | RO | 16 1A 00 00 00 00 00 00 00 00
Index 1816 ENC TxPDO-Par Period Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1816:0 | ENC TxPDO-Par Period Compact Ch.2 | PDO Parameter TxPDO 22 | UINT8 | RO | 0x06 (6dez)
1816:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 22 übertragen werden dürfen | OCTET-STRING[14] | RO | 15 1A 00 00 00 00 00 00 00 00
Index 1818 ENC TxPDO-Par Timestamp Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1818:0 | ENC TxPDO-Par Timesptamp Ch.2 | PDO Parameter TxPDO 23 | UINT8 | RO | 0x06 (6dez)
1818:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 23 übertragen werden dürfen | OCTET-STRING[14] | RO | 19 1A 00 00 00 00 00 00 00 00
Index 1819 ENC TxPDO-Par Timestamp Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1819:0 | ENC TxPDO-Par Timesptamp Compact Ch.2 | PDO Parameter TxPDO 24 | UINT8 | RO | 0x06 (6dez)
1819:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 24 übertragen werden dürfen | OCTET-STRING[14] | RO | 18 1A 00 00 00 00 00 00 00 00
Index 1A00 ENC TxPDO-Map Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x19 (25dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0D (Diag)) | UINT32 | RO | 0x6002:0D, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6002:0E, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6002:0F, 2
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x11 (Software gate valid)) | UINT32 | RO | 0x6002:11, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x12 (Latch extern 2 valid)) | UINT32 | RO | 0x6002:12, 1
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x13 (Direction inversion detected)) | UINT32 | RO | 0x6002:13, 1
1A00:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x14 (Status of extern latch)) | UINT32 | RO | 0x6002:14, 1
1A00:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x15 (Counter value out of range)) | UINT32 | RO | 0x6002:15, 1
1A00:15 | SubIndex 021 | 21. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A00:16 | SubIndex 022 | 22. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A00:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A00:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
1A00:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x22 (Latch value 2)) | UINT32 | RO | 0x6000:22, 32
Index 1A01 ENC TxPDO-Map Status Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x19 (25dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6002(ENC Inputs status Ch.1) entry 0x0D (Diag)) | UINT32 | RO | 0x6002:0D, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6002:0E, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6002:0F, 2
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x11 (Software gate valid)) | UINT32 | RO | 0x6002:11, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x12 (Latch extern 2 valid)) | UINT32 | RO | 0x6002:12, 1
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x13 (Direction inversion detected)) | UINT32 | RO | 0x6002:13, 1
1A01:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x14 (Status of extern latch)) | UINT32 | RO | 0x6002:14, 1
1A01:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x15 (Counter value out of range)) | UINT32 | RO | 0x6002:15, 1
1A01:15 | SubIndex 021 | 21. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A01:16 | SubIndex 022 | 22. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A01:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A01:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
1A01:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x22 (Latch value 2)) | UINT32 | RO | 0x6000:22, 16
Index 1A02 ENC TxPDO-Map Status Counter Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ENC TxPDO-Map Status Counter Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0D (Diag)) | UINT32 | RO | 0x6002:0D, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6002:0E, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6002:0F, 2
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x11 (Software gate valid)) | UINT32 | RO | 0x6002:11, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A03 ENC TxPDO-Map Status Compact Counter Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Status Compact Counter Ch.1 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0B (11dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0D (Diag)) | UINT32 | RO | 0x6002:0D, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6002:0E, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6002:0F, 2
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6002 (ENC Inputs status Ch.1), entry 0x11 (Software gate valid)) | UINT32 | RO | 0x6002:11, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
Index 1A04 ENC TxPDO-Map Status Legacy Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Status Legacy Ch.1 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x12 (18dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6002 (ENC Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A04:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A05 ENC TxPDO-Map Status Compact Legacy Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Status Compact Legacy Ch.1 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x12 (18dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A05:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A05:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A05:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A05:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A05:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A05:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A05:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6002 (ENC Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A05:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A05:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A06 ENC TxPDO-Map Frequency Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | ENC TxPDO-Map Frequency Ch.1 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A07 ENC TxPDO-Map Frequency Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | ENC TxPDO-Map Frequency Compact Ch.1 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 16
Index 1A08 ENC TxPDO-Map Period Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | ENC TxPDO-Map Period Ch.1 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14, 32
Index 1A09 ENC TxPDO-Map Period Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | ENC TxPDO-Map Period Compact Ch.1 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14, 32
Index 1A0A ENC TxPDO-Map Duty cycle Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | ENC TxPDO-Map Duty cycle Ch.1 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x03 (3dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x23 (Duty cycle)) | UINT32 | RO | 0x6000:23, 16
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x24 (Duty cycle min)) | UINT32 | RO | 0x6000:24, 16
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x24 (Duty cycle max)) | UINT32 | RO | 0x6000:25, 16
Index 1A0B ENC TxPDO-Map Timestamp Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | ENC TxPDO-Map Timestamp Ch.1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x04 (4dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x1F (Timestamp C)) | UINT32 | RO | 0x6000:1F, 64
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x20 (Timestamp latch )) | UINT32 | RO | 0x6000:20, 64
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x21 (Timestamp latch 2)) | UINT32 | RO | 0x6000:21, 64
Index 1A0C ENC TxPDO-Map Timestamp Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0C:0 | ENC TxPDO-Map Timestamp Compact Ch.1 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x04 (4dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x1F (Timestamp C)) | UINT32 | RO | 0x6000:1F, 32
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x20 (Timestamp latch )) | UINT32 | RO | 0x6000:20, 32
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x21 (Timestamp latch 2)) | UINT32 | RO | 0x6000:21, 32
Index 1A0D ENC TxPDO-Map Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0D:0 | ENC TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x19 (25dez)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6010:01, 1
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6010:06, 1
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6010:07, 1
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A0D:09 | SubIndex 009 | 9. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2),entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A0D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A0D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6010:0B, 1
1A0D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6010:0C, 1
1A0D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0D (Diag)) | UINT32 | RO | 0x6012:0D, 1
1A0D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6012:0E, 1
1A0D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6012:0F, 2
1A0D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x11 (Software gate valid)) | UINT32 | RO | 0x6012:11, 1
1A0D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x12 (Latch extern 2 valid)) | UINT32 | RO | 0x6012:12, 1
1A0D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x13 (Direction inversion detected)) | UINT32 | RO | 0x6012:13, 1
1A0D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x14 (Status of extern latch)) | UINT32 | RO | 0x6012:14, 1
1A0D:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x15 (Counter value out of range)) | UINT32 | RO | 0x6012:15, 1
1A0D:15 | SubIndex 021 | 21. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A0D:16 | SubIndex 022 | 22. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A0D:17 | SubIndex 023 | 23. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A0D:18 | SubIndex 024 | 24. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
1A0D:19 | SubIndex 025 | 25. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x22 (Latch value 2)) | UINT32 | RO | 0x6010:22, 32
Index 1A0E ENC TxPDO-Map Status Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0E:0 | ENC TxPDO-Map Status Compact Ch.2 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x19 (25dez)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6010:01, 1
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A0E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A0E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A0E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A0E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6010:06, 1
1A0E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6010:07, 1
1A0E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A0E:09 | SubIndex 009 | 9. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2),entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A0E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A0E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6010:0B, 1
1A0E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6010:0C, 1
1A0E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0D (Diag)) | UINT32 | RO | 0x6012:0D, 1
1A0E:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6012:0E, 1
1A0E:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6012:0F, 2
1A0E:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x11 (Software gate valid)) | UINT32 | RO | 0x6012:11, 1
1A0E:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x12 (Latch extern 2 valid)) | UINT32 | RO | 0x6012:12, 1
1A0E:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x13 (Direction inversion detected)) | UINT32 | RO | 0x6012:13, 1
1A0E:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x14 (Status of extern latch)) | UINT32 | RO | 0x6012:14, 1
1A0E:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x15 (Counter value out of range)) | UINT32 | RO | 0x6012:15, 1
1A0E:15 | SubIndex 021 | 21. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A0E:16 | SubIndex 022 | 22. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A0E:17 | SubIndex 023 | 23. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A0E:18 | SubIndex 024 | 24. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
1A0E:19 | SubIndex 025 | 25. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x22 (Latch value 2)) | UINT32 | RO | 0x6010:22, 16
Index 1A0F ENC TxPDO-Map Status Counter Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0F:0 | ENC TxPDO-Map Status Counter Ch.2 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x0B (11dez)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A0 F:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0F:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A0F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0D (Diag)) | UINT32 | RO | 0x6012:0D, 1
1A0F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6012:0E, 1
1A0F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6012:0F, 2
1A0F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x11 (Software gate valid)) | UINT32 | RO | 0x6012:11, 1
1A0F:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A0F:0A | SubIndex 010 | 10. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A0F:0B | SubIndex 011 | 11. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
Index 1A10 ENC TxPDO-Map Status Compact Counter Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | ENC TxPDO-Map Status Compact Counter Ch.2 | PDO Mapping TxPDO 17 | UINT8 | RO | 0x0B (11dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0D (Diag)) | UINT32 | RO | 0x6012:0D, 1
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6012:0E, 1
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6012:0F, 2
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6012 (ENC Inputs status Ch.2), entry 0x11 (Software gate valid)) | UINT32 | RO | 0x6012:11, 1
1A10:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A10:0A | SubIndex 010 | 10. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A10:0B | SubIndex 011 | 11. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
Index 1A11 ENC TxPDO-Map Status Legacy Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A11:0 | ENC TxPDO-Map Status Legacy Ch.2 | PDO Mapping TxPDO 18 | UINT8 | RO | 0x12 (18dez)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6010:01, 1
1A11:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A11:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A11:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A11:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A11:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6010:06, 1
1A11:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6010:07, 1
1A11:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A11:09 | SubIndex 009 | 9. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2),entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A11:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A11:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6010:0B, 1
1A11:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6010:0C, 1
1A11:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A11:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A11:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A11:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A11:11 | SubIndex 017 | 17. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A11:12 | SubIndex 018 | 18. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
Index 1A12 ENC TxPDO-Map Status Compact Legacy Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A12:0 | ENC TxPDO-Map Status Compact Legacy Ch.2 | PDO Mapping TxPDO 19 | UINT8 | RO | 0x12 (18dez)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6010:01, 1
1A12:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A12:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A12:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A12:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A12:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6010:06, 1
1A12:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6010:07, 1
1A12:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A12:09 | SubIndex 009 | 9. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2),entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A12:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A12:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6010:0B, 1
1A12:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6010:0C, 1
1A12:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A12:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A12:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A12:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A12:11 | SubIndex 017 | 17. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A12:12 | SubIndex 018 | 18. PDO Mapping entry (object object 0x6010 (ENC Inputs Ch.2), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
Index 1A13 ENC TxPDO-Map Frequency Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A13:0 | ENC TxPDO-Map Frequency Ch.2 | PDO Mapping TxPDO 20 | UINT8 | RO | 0x01 (1dez)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6010:13, 32
Index 1A14 ENC TxPDO-Map Frequency Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A14:0 | ENC TxPDO-Map Frequency Compact Ch.2 | PDO Mapping TxPDO 21 | UINT8 | RO | 0x01 (1dez)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6010:13, 16
Index 1A15 ENC TxPDO-Map Period Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A15:0 | ENC TxPDO-Map Period Ch.2 | PDO Mapping TxPDO 22 | UINT8 | RO | 0x01 (1dez)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x14 (Period value)) | UINT32 | RO | 0x6010:14, 32
Index 1A16 ENC TxPDO-Map Period Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A16:0 | ENC TxPDO-Map Period Compact Ch.2 | PDO Mapping TxPDO 23 | UINT8 | RO | 0x01 (1dez)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x14 (Period value)) | UINT32 | RO | 0x6010:14, 16
Index 1A17 ENC TxPDO-Map Duty cycle Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A17:0 | ENC TxPDO-Map Duty cycle Ch.2 | PDO Mapping TxPDO 24 | UINT8 | RO | 0x03 (3dez)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x23 (Duty cycle)) | UINT32 | RO | 0x6010:23, 16
1A17:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x24 (Duty cycle min)) | UINT32 | RO | 0x6010:24, 16
1A17:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x24 (Duty cycle max)) | UINT32 | RO | 0x6010:25, 16
Index 1A18 ENC TxPDO-Map Timestamp Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A18:0 | ENC TxPDO-Map Timestamp Ch.2 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x04 (4dez)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6010:16, 64
1A18:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x1F (Timestamp C)) | UINT32 | RO | 0x6010:1F, 64
1A18:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x20 (Timestamp latch )) | UINT32 | RO | 0x6010:20, 64
1A18:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x21 (Timestamp latch 2)) | UINT32 | RO | 0x6010:21, 64
Index 1A19 ENC TxPDO-Map Timestamp Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A19:0 | ENC TxPDO-Map Timestamp Compact Ch.2 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x04 (4dez)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6010:16, 32
1A19:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x1F (Timestamp C)) | UINT32 | RO | 0x6010:1F, 32
1A19:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x20 (Timestamp latch )) | UINT32 | RO | 0x6010:20, 32
1A19:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x21 (Timestamp latch 2)) | UINT32 | RO | 0x6010:21, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1606 (5638dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0D (6669dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x0807 (2055dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x000101D0 (66000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
Min. Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (000000dez)
1C32:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x0807 (2055dez)
1C33:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x000101D0 (66000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x000101D0 (66000dez)
1C33:07
Minimum delay time
Min. Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (000000dez)
1C33:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000001FF (511dez)
F010:02 | SubIndex 002 | reserviert | UINT32 | RW | 0x000001FF (511dez)


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL5102
Hardware (HW) | Firmware | Revision Nr. | Release-Datum
01 - 04* | 01* | EL5102-0000-0016 | 2020/06
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
Dieses Kapitel beschreibt das Geräte-Update für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu drei Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u. a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle drei Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z. B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z. B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z. B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
✓
Beim Herunterladen von neuen Gerätedateien ist zu beachten
1.
Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden.
2.
Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
3.
Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein.
⇨
Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im System Manager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d. h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. Änderungsdialog. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im System Manager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z. B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren zwei CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z. B. „Beckhoff EL5xxx.xml“) enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z. B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z. B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o. a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.