CU15x1 - EtherCAT media converter
Home


Foreword

Foreword
Foreword
Additional information
•
CU15x1 - Product overview
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


CU15x1 - Product overview

Foreword [image] CU15x1 - Product overview
CU15x1 - Product overview
CU1521 - EtherCAT media converter multimode fiber optic
CU1521-0010 - EtherCAT media converter singlemode fiber optic
CU1561 - EtherCAT media converter fiber optic (POF)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
2.2
▪
Update Technical Data
▪
Update structure
2.1
▪
Update Technical Data
▪
Update structure
2.0
▪
Migration
1.2
▪
Update chapter "Technical data"
1.1
▪
Update chapter "Application notes"
1.0
▪
Addenda and 1st public issue
0.3
▪
Addenda
0.2
▪
Addenda
0.1
▪
Preliminary version


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data


Introduction

Product overview [image] Introduction
Introduction
CU1561, CU1521
The EtherCAT-capable CU1521, CU1521-0010 and CU1561 devices should be used as media converter for industrial fast Ethernet/100 Mbaud from optical fiber to copper and vice versa.
Upper picture: one media converter, copper -> fiber optic,
Lower picture: two media converters, copper -> fiber optic -> copper
From the physical layer perspective the CU1521 is suitable for multimode, while the CU1521-0010 is suitable for single mode optical fiber and therefore for significantly longer transmission links up to 20 km.
The CU1561 is used for interfacing with POF (plastic optical fiber), which are suitable for small-scale machine installation thanks to relatively inexpensive cable material and field-configurability.
The media converter operates bidirectionally and collision-free. The CU15x1 devices are therefore also suitable as media converters for any Ethernet traffic. They support "Link Loss Forwarding", which means that, if the link fails at the outgoing strand, for example due to a broken wire, the link is also withdrawn from the incoming line, so that the sending device is notified of the link loss.
The CU15x1 devices are characterized by the fact that they support the requirements of an EtherCAT network for a converter particularly well. This includes fast link control (establishment and disconnection), diagnosis of communication errors, constant frame deceleration and readable identity (no transparent operation). If the CU15x1 is set to EtherCAT mode with the rotary switch, it can be diagnosed as a separate EtherCAT device. Hence, as opposed to standard media converters, he also ensures fast link control and thus the secure termination of an EtherCAT strand even in the event of a disruption. Since the transfer direction (copper Þ optical fiber or optical fibers Þ copper) is relevant for the EtherCAT bus, the operating direction can be configured via the rotary switch.
The CU15x1 are useful in applications where EtherCAT transfers over large distances are required or where higher EMC loads on the bus line are to be expected.
Quick links


Technical data

Product overview [image] Technical data
Technical data
Technical data | CU1521 |  | CU1521-0010 | CU1561
Function Ethernet "IP" | Media converter Fast Ethernet/100Mbaud (all IEEE 802.3-based protocols) IEEE 802.3u auto negotiation, half or full duplex, automatic settings Link Loss-Forwarding (notification direction configurable) Store and Forward Mode (FIFO) unmanaged
Function EtherCAT "EC" | Media converter Fast Ethernet/100Mbaud Cut-through mode Port handling/link control
Number of Ethernet ports | 2
Ethernet interface X1 | 100BASE-FX multimode glass fiber 50/125 µm (MM) typically 1300 nm 2 x SC Duplex |  | 100BASE-FX single mode glass fiber 9/125 µm (SM) typically 1300 nm 2 x SC Duplex | 100BASE-FX-POF glass fiber 980/1000 µm (POF); typically 650 nm 2 x versatile link for POF duplex connector (connector set ZS1090-0008) Laser class 1, see note
Ethernet interface X2 | 10BASE-T/100BASE-TX Ethernet/EtherCAT cable (min. CAT 5), screened 10BASE-T/100BASE-TX Ethernet/EtherCAT cable (min. CAT 5), screened
Cable length X1 max. | max. 2 km (100BASE-FX) |  | max. 20 km (100BASE-FX) | max. 50 m (100BASE-FX-POF)
Cable length X2 max. | up to 100 m twisted pair CAT5 (e)
Diagnostics | LED: Supply voltage, link/activity X1/X2 EtherCAT: CRC
Power supply | via three-pole spring loaded terminal (+, -, PE)
Supply voltage | 24 VDC (18 VDC to 30 VDC), protected against polarity reversal.
Current consumption | typ. 95 mA |  | typ. 80 mA | typ. 60 mA
Weight | approx. 105 g
Dimensions without plugs (W x H x D) | approx. 34 mm x 98 mm x 77 mm
Mounting | on 35 mm mounting rail (mounting rail according to EN 60715)
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range) | 0°C …+55°C
Permissible ambient temperature range during storage | -40°C ... +85°C | -25°C ... +85°C
Permissible relative humidity | 95 %, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE cULus


Basic principles

Basic principles
Basic principles
Additional information
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
EtherCAT State Machine
•
CoE - Interface: notes


EtherCAT basics

Basic principles [image] EtherCAT basics
EtherCAT basics
Please refer to the chapter EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Basic principles [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EtherCAT State Machine

Basic principles [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE - Interface: notes

Basic principles [image] CoE - Interface: notes
CoE - Interface: notes
This device has no CoE.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Dimensions
•
Mounting and demounting
•
Recommended mounting rails
•
Diagnostic LEDs
•
UL notice


Dimensions

Mounting and wiring [image] Dimensions
Dimensions
Space requirement in the control cabinet
•
The RJ45 connector increase the depth depending on their design and the Ethernet cable used.
•
Above the mounting rail an additional height of approx. 10 mm is required to enable latching of the switch onto the rail.
CU1521-00x0
CU1521-00x0
CU1561
CU1561


Mounting and demounting

Mounting and wiring [image] Mounting and demounting
Mounting and demounting
The CU15xx converters are mounted on the mounting surface with the aid of a 35 mm DIN rail (according to EN 60715).
Mounting rail installation
Please ensure that the CU15x1 engages properly on the mounting rail. See chapter Recommended mounting rails.
Mounting
▪
Fit the mounting rail to the planned assembly location.
▪
Position the converter in the mounting rail with the spring at the top of its latching flange (1)
▪
Push the lower side of the converter (2) against the mounting surface until it latches on the mounting rail.
▪
Attach the cable.
Mounting
Removal
▪
Remove all the cables.
▪
Pull the strap on the underside of the converter (1) downwards with a screwdriver
▪
Pull the converter upwards away from the mounting surface (2)
Removal


Recommended mounting rails

Mounting and wiring [image] Recommended mounting rails
Recommended mounting rails
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series can be snapped onto the following recommended mounting rails:
▪
DIN Rail TH 35-7.5 with 1 mm material thickness (according to EN 60715)
▪
DIN Rail TH 35-15 with 1,5 mm material thickness
Pay attention to the material thickness of the DIN Rail
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series does not fit to the DIN Rail TH 35-15 with 2,2 to 2,5 mm material thickness (according to EN 60715)!


Diagnostic LEDs

Mounting and wiring [image] Diagnostic LEDs
Diagnostic LEDs
Pin assignment CU1521, CU1521-0010, CU1561
LEDs for fieldbus diagnostics/power supply
LED | Color | Display | State | Description
L/A (X1) green (x2) | green | off | - | no connection on the EtherCAT strand
 |  | on | linked | EtherCAT device connected
 |  | flashing | active | Communication with EtherCAT device
Power | green | off |  | No supply voltage
 |  | on |  | 24 V supply voltage present
LED diagnostics EtherCAT State Machine
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | single flash | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | flashing | State of the EtherCAT State Machine: SAFEOP = verification of the sync manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates
 | orange | on | CU15x1 is in EtherCAT mode, rotary switch was moved during operation Remedy: Resetting or voltage reset
 | red | on | CU15x1 is in Ethernet mode, rotary switch was moved during operation Remedy: Resetting or voltage reset
 | red/green | flashing | Invalid rotary switch position after power-on Remedy: Move rotary switch to valid position


UL notice

Mounting and wiring [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
Two UL certificates are met in the Beckhoff EtherCAT product range, depending upon the components:
1.
UL certification according to UL508. Devices with this kind of certification are marked by this sign:
2.
UL certification according to UL508 with limited power consumption. The current consumed by the device is limited to a max. possible current consumption of 4 A. Devices with this kind of certification are marked by this sign:
Almost all current EtherCAT products (as at 2010/05) are UL certified without restrictions.
Application
If terminals certified with restrictions are used, then the current consumption at 24 VDC must be limited accordingly by means of supply
▪
from an isolated source protected by a fuse of max. 4 A (according to UL248) or
▪
from a voltage supply complying with NEC class 2.
A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2compliant voltage supply!
These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.


Commissioning/application notes

Commissioning/application notes
Commissioning/application notes
Additional information
•
Application notes
•
Notes on converters with RJ45 fiber-optic connection
•
Notes on converters with RJ45 POF connection
•
Notes regarding assembly of POF cables with the connector set ZS1090-0008


Application notes

Commissioning/application notes [image] Application notes
Application notes
Table of contents
• Standard Ethernet
• EtherCAT
• Earthing/Shielding
• Firmware update
• General notes
The media converters CU1521, CU1521-0010, CU1561 (referred to as CU15x1 below) physically convert 100 Mbit telegrams (Fast Ethernet) from copper physics (RJ45 connector) to optical fiber (SC connector or versatile link) and back.
Special behavior is expected from the converter, depending on whether EtherCAT or standard Ethernet telegrams are to be transferred.
Used for: Standard Ethernet 10/100 Mbit
An Ethernet connection is a managed point-to-point connection between two intelligent end devices.
Point-to-point connection between two Ethernet devices
Both devices send a so-called idle sample to their Ethernet connection. The link has been established if a corresponding sample is received. Both devices then know that they can use this connection. If the connection is interrupted, the link is lost and both devices are notified.
Interrupted point-to-point connection
If a media converter is placed between the two stations, it too becomes an intelligent transmitter/receiver. If connection C is interrupted, device A would not necessarily be informed and would continue to send data to the converter via the existing link B, and the data would "trickle away". The CU15x1 therefore supports Link Loss Forwarding (LLF) in a selected direction. The notification is indicated by a label on the CU15x1. If the converter detects an interruption of connection C in switch setting 1 in Fig. Interposed media converter in the Ethernet connection, it also interrupts link B.
Interposed media converter in the Ethernet connection
In both IP settings the CU15x1 operates as a store and forward network device with checksum function. Frames that are faulty (CRC error), too short (< 64 bytes) or too long (> 1536 bytes) are not passed on.
Used for: EtherCAT 100 Mbit
Other characteristics are required if it is used as a media converter in an EtherCAT network:
▪
Consistently low delay in the frame transit, irrespective of frame length
▪
Fast link detection when the connection is established and interrupted
▪
Identification as separate EtherCAT device with diagnostic function
EtherCAT slaves process the EtherCAT telegrams in forward direction from the perspective of the master. Accordingly, in the CU15x1 the forward direction may be X1 --> X2 or X2 --> X1, depending on the application. It has to be set at the rotary switch prior to commissioning. The direction of the arrow of S1 indicates the set forward direction.
Setting the forward direction at the media converter
Make sure the rotary switch is set to the right position, so that the CU15x1 operates in forward direction. For example, in Fig. Copper -> optical fiber-> copper operation of two media converters, the CU15x1 on the left operates as a copper --> optical fiber converter (rotary switch position 5), the CU15x1 on the right operates as an optical fiber --> copper converter (rotary switch position 0).
Copper -> optical fiber-> copper operation of two media converters
If the opposite direction of rotation is set, the subsequent behavior depends on the EtherCAT master. The scanned CU15x1 may be inserted at a different position in the topology, or an INIT_VPRS error message of the EtherCAT master may occur.
Earthing/Shielding
The FE contact on the supply socket must be directly connected to the mounting rail contact. During assembly, always take care of a conductive connection to the mounting rail.
Internal earthing concept
Firmware update
A firmware update via EtherCAT is not possible for devices of the CU15x1 series
General notes
The CU15x1 deals with setting the rotary switch when the supply voltage is applied, unless the rotary switch is in an invalid position. In this case the CU15x1 deals with the setting when the rotary switch reaches a valid position for the first time.
If the rotary switch is moved during valid operation, the CU15x1 does not alter its function but indicates this state through its LED, see Diagnostics. The switch setting must be rectified before the voltage is re-applied!
Rotary switch
Slanting installation of the optical fiber socket in the CU15x1 reduces the bending radius of the optical fiber cable during connection in the control cabinet (Fig. Slanting installation of the optical fiber socket).
Slanting installation of the optical fiber socket


Notes on converters with RJ45 fiber-optic connection

Commissioning/application notes [image] Notes on converters with RJ45 fiber-optic connection
Notes on converters with RJ45 fiber-optic connection
Table of contents
• Mounting rail installation
• Notes on suitable optical fiber cables
• Connecting and disconnecting the optical fiber cable
Mounting rail installation
Mounting
Please ensure that the CU15x1 engages properly on the mounting rail.
See Mounting rail installation and Recommended mounting rails.
Notes on suitable optical fiber cables
General information on optical fiber types
Optical fiber are available as multimode and single mode types with different step and graded indices.
Step and graded index
Optical fiber cables consist of 2 concentric materials, the core and cladding, plus a protective (colored) jacket. The core and the cladding have a different index of refraction, causing the light waves (modes; a mode is a natural wave in the optical fiber) to be reflected back into the core at the boundary. Due to the step change in the index of refraction this type of fiber is referred to as step index. A gradual/parabolic transition between the index of refraction in the core and the coating (referred to as graded index) can be achieved by mixing the materials. In a graded index fiber the modes are gradually diffracted back to the core, leading to propagation-time compensation and significantly higher quality of the light pulse at the outlet compared with a multimode step index fiber, where the different light modes have different signal run times (mode dispersion) with associated front distortion.
Single mode
Single mode fiber cables have a very thin core (9 µm) and therefore conduct only a single light mode with high signal quality and almost without mode dispersion. They are only available as step index fibers. Due to the high signal quality they are suitable for large transmission bandwidths > 10 GHz*km and distances > 50 km. The refractive index profile of single-mode fibers is dimensioned such that the multipath propagation (intermodal dispersion), which is a problem with multi-mode fibers, is omitted – the signal light propagates in a single-mode fiber only in a single guided fiber mode, hence the designation ‘single-mode’. This makes considerably larger transmission distances and/or bandwidths possible, and the limiting effect that arises next is the color distortion of the transmitted mode.
Multimode
Multimode fibers are manufactured as step index or graded index. Step index multimode fiber cables are suitable for transmission bandwidths up to 100 MHz*km and distances up to 1 km. Graded index multimode fiber cables with core diameters between 50 µm and 62.5 µm reach transmission bandwidths > 1 GHz*km and ranges > 10 km. Multimode means that the core of the optical fiber cable is thick enough to enable several light modes to propagate reflectively in the cable.
Application with CU1521 and CU1521-0010
The CU1521, CU1521-0010 are intended for application with optical fiber cables with the following characteristics:
▪
SC duplex connector.
▪
CU1521: Duplex multimode 50/125 µm or 62.5/125 µm (inner/outer core diameter). The use of both diameters is possible. However, the use of 50/125 µm is recommended due to the lower attenuation.
▪
CU1521-0010: Duplex single-mode 9/125 µm (inner/outer core diameter). A typically usable cable can be manufactured according to the specification ITU-T G.652.D (0.4.4dBm/km at 1300 nm).
Recommended connectors
The use of SC/PC connectors is recommended for connecting to the CU1521, CU1521-0010. The advantage of the "PC" (physical contact) version of this connector is the crowned end face, which allows the region of the fiber core that is relevant to transmission to be optimally joined when the connector is pushed together. Other versions include, for instance, the SC/UPC (ultra-polish PC), SC/HRL (high return loss) and the SC/APC plug (angled physical contact).
An additional feature of these connectors is that light that is reflected by the connector's end face, which is at an angle of about 8° to the fiber axis, is refracted from the core by the cladding glass into the air. This avoids interference with the data transmission, optimizing the core size of the back-scatter.
50/125 µm or 62.5/125 µm
The use of both diameters is possible. However, the use of 50/125 µm is recommended due to the lower attenuation.
In optical fibers the wavelengths 850 nm and 1300 nm are usually used for data transfer. Commercially available optical fiber cables are usually optimized for application in one of these ranges, since signal attenuation is frequency-dependent (like in copper cable), so that large ranges of several km can be achieved for the respective wavelength. In general, optical fiber cables exhibit a lower attenuation at a wavelength of 1300 nm than at 850 nm.
In the CU1521, CU1521-0010 a transceiver with the wavelength of 1300 nm is used.
Range and bandwidth product
Optical fiber cables are available in different qualities from reputable manufacturers. One of the relevant parameters for the user is the frequency-dependent bandwidth product of a cable, specified in [MHz*km]. The greater the bandwidth product, the lower the attenuation, and therefore the larger the range that can be achieved with this cable (see ITU-T G-651). To maximize the range with the CU1521, CU1521-0010 optical fiber cables with a maximum high bandwidth product at 1300 nm should therefore be used. We recommend optical fiber cables from the OM2 class (EN50173:2002).
Standard optical fiber cables have a minimum bandwidth product of 500 MHz*km at 1300 nm, higher-quality cables are suitable for distances > 500 m over > 1000 MHz*km.
For maximum distances the remote counterpart of the CU1521, CU1521-0010 should also support such ranges.
Installation notes
The following parameters must be taken into account in the installation of optical fiber cables
•
permitted bending radius
•
permitted tensile strength
•
sensitivity of the exposed contact ends
Further information can be found in the following documents:
▪
ITU recommendation ITU-T G.651 - G.655
▪
EN 50173:2002
▪
EN 60793-2
Connecting and disconnecting the optical fiber cable
Note
Risk of damage to the cable!
To disconnect the optical fiber cable always pull the connector to release the locking mechanism - never pull the optical fiber cable itself.
Crossover cables
Please note that when connecting the CU1521, CU1521-0010 to the remote station, it may be necessary to use "crossed" cables in order to establish a connection.
Practical tip:
The exit of the infrared light can be made visible using a digital or mobile phone camera (see Fig. Visualization of infrared light at the SC Duplex plug). Avoid 'light meeting light' when connecting the optical fiber cable (Tx -> Tx). In this case no connection can be established, and you have to cross the cables (Tx -> Rx).
Visualization of infrared light at the SC duplex connector
Use of blind plugs
To protect the transceiver from environmental influences, unused connection socket should be sealed with the blind plugs provided! See Fig.: Blind plugs in unused sockets
Blind plugs in unused sockets


Notes on converters with RJ45 POF connection

Commissioning/application notes [image] Notes on converters with RJ45 POF connection
Notes on converters with RJ45 POF connection
Additional information
•
Notes regarding suitable POF cables
•
Connecting and disconnecting the POF cable


Notes regarding suitable POF cables

Commissioning/application notes [image] Notes on converters with RJ45 POF connection [image] Notes regarding suitable POF cables
Notes regarding suitable POF cables
General information about POF cables
The standard polymer fiber is 1 mm thick and consists of a 0.98 mm thick core made of polymethyl methacrylate (PMMA) as well as a thin sheath. In order to enable the guidance of light using the effect of total reflection in the core, the usually very thin sheath consists of fluorinated PMMA, which has a low refractive index. The core diameters lie between 0.06 mm and 1 mm, as a result of which simple plug connections are easy to implement. Furthermore, the splicing process often used for the connection of glass fibers and the unnecessarily high expenditure associated with it can usually be dispensed with. The maximum operating temperature of standard POF is approximately 60°C and has a refraction profile with step index (SI-POF). The refractive index of the core material is around 1.49 and that of the sheath around 1.41. The difference determines the numerical aperture (NA) and thus the maximum propagation angle. With a difference of 5% this angle is about 20 degrees in relation to the fiber axis, which leads to a reduction in the bandwidth.
Due to the simple and almost universally applicable connection techniques compared to glass fibers, POFs are used in particular for short transmission distances, such as inside rooms, technical equipment, mechanical systems or cars.
POFs have an attenuation of about 140 dB/km at a wavelength of 650 Nm, so that a maximum data transmission distance of 50 m can be achieved when used with the CU1561.
Insertion of additional connectors in the route increases the signal attenuation. For each additional connector, the maximum permitted distances typically reduces by 6.5 m.
Application with CU1561
Recommended plug connectors and POF cables
For the connection of the CU1561 it is recommended to use the connector set ZS1090-0008 (Versatile Link Duplex plugs) in conjunction with a duplex polymer fiber with an outside diameter of 2 x 2.2 mm (Z1190), which are available from Beckhoff.
Installation notes
Among other things, the following items should be observed when laying POF cables:
•
permissible bending radius (in general r ≥ 25 mm, refer to the manufacturer’s data!)
•
permitted tensile strength
•
sensitivity of the exposed contact ends


Connecting and disconnecting the POF cable

Commissioning/application notes [image] Notes on converters with RJ45 POF connection [image] Connecting and disconnecting the POF cable
Connecting and disconnecting the POF cable
To connect the cable, insert the plug (available as an accessory in the connector set ZS1090-0008) into the connection opening until it audibly latches.
Latching lug with release catch on the POF duplex plug
To release the connector activate the release device with the latching lug. This is located on the right-hand side of the connector (see Fig. Latching lug with release catch on the POF duplex plug)
Note
Risk of damage to the cable!
To release the cable, press the release catch on the plug and pull the plug at the same time – never pull by the POF cable alone!
Note
TX / Rx channel assignment
During cable assembly note the assignment of the optical channels in the connection socket. In the case of the CU1561 the light-emitting transmitter channel (Tx) is the lower outlet in the connection socket (Fig. Transmitter channel of the CU1561).
Be sure to observe the safety instructions for class 1 lasers!
Transmitter channel of the CU1561
Note
Use of blind plugs
In order to avoid accidents due to glare (Class 1 laser, please observe the safety instructions) and to protect the transceiver against environmental influences, unused sockets should be sealed using the blind plugs provided (Fig. Blind plugs in unused sockets)
Blind plugs in unused sockets


Notes regarding assembly of POF cables with the connector set ZS1090-0008

Commissioning/application notes [image] Notes regarding assembly of POF cables with the connector set ZS1090-0008
Notes regarding assembly of POF cables with the connector set ZS1090-0008
Table of contents
• Step-by-step instructions for assembling the POF cable
1. Stripping the POF cable
 2. Attaching the connector
3. Grinding and polishing
4. Fine polishing
Duplex connector set ZS1090-0008
The duplex connector set ZS1090-0008 from Beckhoff consists of 10 duplex Versatile Link connectors and several sheets of abrasive paper and polishing paper.
Step-by-step instructions for assembling the POF cable
The following step-by-step guide describes the correct assembly of a POF cable with a Versatile Link duplex connector. The connectors are attached to the cable ends with standard tools such as cutter knife or wire strippers. Polish the assembled cable with the polishing set provided with the connector set, consisting of a plastic sanding gauge, sheets of abrasive paper with grain size 600 and pink polishing sheets. Once assembled, the connector can be used right away.
Materials required:
1. POF cable (Polymeric Optical Fiber, e.g. Z1190 from Beckhoff)
2. Cutter knife or shears
3. Wire strippers
4. Polishing set (included with connector set ZS1090-0008 from Beckhoff)
5. Versatile Link duplex connector (included in connector set ZS1090-0008 from Beckhoff)
1. Stripping the POF cable
The cable should be split over a length between 100 and 150 mm from the cable end, so that the following steps can be carried out properly.
Once you have shortened the cable to the required length, use the wire strippers to remove approx. 7 mm of the external sheathing of the individual wires. The two cable ends should be stripped over approximately the same length. (Fig. POF cable stripped over the same length).
POF cable stripped over the same length
2. Attaching the connector
Push the two cable ends into the connector and the connector back until it stops. The fibers should now protrude no more than 1.5 mm out of the front openings (Fig. Cable inserted in the connector).
Close the connector by folding the upper and lower halves together until they engage (Fig. Closed connector).
Cable inserted in the connector
Closed connector
When inserting the wires into the connector ensure the optical channels are crossed (Tx1 --> Rx2; Tx2 --> Rx1). The 'nose' at the connector hinge can be used as a guide (Fig. Correctly connected optical channels).
Correctly connected optical channels
3. Grinding and polishing
Any fibers protruding more than 1.5 mm from the connector should be shortened with a cutter knife or a pair of scissors.
Now push the connector fully into the sanding gauge, so that the ends to be polished protrude from the lower side (Fig. Sanding gauge with protruding fiber ends). The sanding gauge is suitable for polishing one or two simplex connectors or a duplex connector.
Sanding gauge with protruding fiber ends
Wear indicator
The wear indicator of the sanding gauge consists of four points on the underside. The sanding gauge should be replaced when one of these points is no longer visible.
Now press the sanding gauge onto the abrasive paper with uniform pressure and as perpendicular as possible. In order to achieve a uniform result, use the abrasive paper in the form of a figure of 8 (Fig. Polishing in the form of a figure "8"), until the fibers are flush with the sanding gauge. Then clean the sanding gauge and the connector from below with a soft, dry cloth.
Polishing in the form of a figure of "8"
4. Fine polishing
Now use the pink polishing sheet for fine polishing in the same manner. Apply the connector with the sanding gauge to the matt side of the polishing sheet with slight pressure and polish in the form of a figure of 8 up to 25 times. After the procedure the fiber end should be flat, smooth and clean.
Improving the transfer performance by fine polishing
Fine polishing with a polishing sheet can improve the transfer performance between the transmitter and the receiver or in the cable joint by up to 0.5 dB compared with to treatment with abrasive paper alone. For short transfer distances the polishing step can be omitted.
Fine-polished fibers in the connector


Appendix

Appendix
Appendix
Additional information
•
Safety instructions and behavioral rules for Class 1 laser
•
Firmware compatibility
•
Firmware Update EL/ES/EM/EPxxxx
•
Support and Service


Safety instructions and behavioral rules for Class 1 laser

Appendix [image] Safety instructions and behavioral rules for Class 1 laser
Safety instructions and behavioral rules for Class 1 laser
SmallWarningYellow CAUTION
Class 1 laser product – danger of accident due to glare!
The following laser-specific behavioral rules are to be followed for the Class 1 laser products described in this document:
•
The laser beam may not be directed toward persons, since accidents may be caused by glare.
•
Do not look into the direct or reflected beam.
•
If laser radiation meets the eye, the eyes must be consciously closed and the head turned away from the beam immediately.
•
When using the laser, no optical instruments may be used to view the radiation source, since this can lead to exposure limit values being exceeded.
•
Manipulations (modifications) of the laser device are not permitted.
Note


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
The CU1521-00x0 and CU1561-0000 converters have no firmware.


Firmware Update EL/ES/EM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com