Softwareendschalter (A2)

1.1 EinleitungPAGEREF _Toc304471589 \h2

1.2 Beschreibung 4

1.3 Parameter 6

1.3.1 Übersicht 6

1.3.2 Achsparameter 6

1.4 CNC-Programmierung 7

Mehr:

button Einleitung

button Beschreibung

button Parameter

button CNC-Programmierung


Einleitung

Aufgabe

Softwareendschalter dienen der Begrenzung des maximalen Verfahrweges einer Achse.

Wirksamkeit

Für folgende Achstypen können die Positionen der Softwareendschalter (P-AXIS-00177/P-AXIS-00178) parametriert werden:

q Linearachsen

q Rundachsen, die nicht als Moduloachsen betrieben werden

Parametrierung

Die Positionen der Softwareendschalter müssen für jede Achse im Achsparameterdatensatz [AXIS] parametriert werden.

Beauftragung

Im NC-Programm können die Positionen der Softwareendschalter durch die NC-Befehle G98/G99 gesetzt bzw. verändert werden.


Beschreibung

Aufgabe

Die Position der Softwareendschalter wird dazu verwendet, die Soll- und Istposition einer Achse zu überwachen. Für jede Achse kann ein positiver (P-AXIS-00178) und ein negativer Softwareendschalter (P-AXIS-00177) parametriert werden.

Die Positionen der Softwareendschalter sind immer auf das Achskoordinatensystem bezogen.

Wirksamkeit

Die Sollpositionen werden während des Look-Ahead, die Istpositionen bei der Lageregelung auf das Überschreiten der Softwareendschalterpositionen überwacht. Es wird deshalb zwischen sollwertseitiger und istwertseitiger Softwareendschalterüberwachung unterschieden.

Die Überwachung von Sollpositionen und Istpositionen unterscheidet sich dadurch, dass für Istpositionen eine Toleranz für die Überwachung auf Überschreiten der Softwareendschalterposition (P-AXIS-00179) parametriert werden kann. Damit kann für Istpositionen vermieden werden, dass geringfügiges Überschwingen zu einer Fehlermeldung der CNC führt.

Abbildung 1-1: Position und Wirksamkeit der Softwareendschalter

Aktivierung

Die Überwachung der Soll- und Istpositionen einer Achse durch die Softwareendschalterpositionen ist aktiviert, sobald diese Achse referenziert ist. Sie ist danach in allen zur Verfügung stehenden Betriebsarten aktiv. Dabei ist es zulässig, dass eine Achse die Softwareendschalterposition anfährt.

Die Überwachung der Soll- und Istpositionen auf Überschreiten der Softwareendschalterpositionen ist nicht wirksam bei rotatorischen Achsen, die als Moduloachsen konfiguriert wurden.

Meldungen

Automatikbetrieb und Handsatz, Achse referenziert

Wird durch einen NC-Satz eine Sollposition berechnet, die eine Softwareendschalterposition überschreitet, wird dieser NC-Satz nicht ausgeführt. Es wird eine Meldung [ID: 120002, bzw. 120003] erzeugt. Das NC-Programm wird an diesem NC-Satz abgebrochen und die an der Bewegung beteiligten Achsen angehalten. Die Sollkontur wird dabei nicht verletzt.

Die Steuerung muss durch einen Reset zurückgesetzt werden.

Überschreitet der Istwert der Achsposition die Softwareendschalterpositionen, wird eine Meldung (ID: 70021, bzw. 70022) erzeugt. Die betroffene Achse wird mit einem linearen Geschwindigkeitsprofil abgebremst. Die Sollkontur kann dabei verletzt werden, wenn mehrere Achsen an der Bewegung beteiligt waren.

Die Steuerung muss durch einen Reset zurückgesetzt werden.

Handbetrieb ohne parallele Interpolation (G200), Achse referenziert

Der Verfahrweg einer Achse wird durch die Softwareendschalterpositionen begrenzt. Beim Tippbetrieb (Continuous jog) wird die Softwareendschalterposition angefahren.

Bei Jogbetrieb (Incremental jog) wird der Schritt nicht mehr ausgeführt, der zu einer Überschreitung der Softwareendschalterposition führt. Es wird eine Meldung (ID: 150008) generiert. Die betroffene Achse kann in entgegengesetzter Verfahrrichtung bewegt werden.

Handbetrieb ohne parallele Interpolation (G200), Achse nicht referenziert

Ist die Achse nicht referenziert werden für die positive Softwareendschalterposition die positive Handbetriebsoffsetgrenze, für die negative Softwareendschalterposition die negative Handbetriebsoffsetgrenze verwendet. Diese sind im Achsparameterdatensatz über die Parameter P-AXIS-00137 / P-AXIS-00138 (offsetgrenze_neg / offsetgrenze_pos) definiert [FCT-A4].

Beim Tippbetrieb werden die Handbetriebsoffsetgrenzen angefahren.

Beim Jogbetrieb wird bei Überschreiten der Handbetriebsoffsetgrenzen, eine Meldung (ID: 150008) erzeugt. Der Jogschritt der zur Überschreitung der Handbetriebsoffsetgrenze führt wird nicht ausgeführt. Die Achse lässt sich in entgegengesetzter Richtung verfahren.


Parameter

Mehr:

button Übersicht

button Achsparameter


Übersicht

ID | Parameter | Beschreibung
P-AXIS-00177 | swe_neg | Position des negativen Softwareendschalters
P-AXIS-00178 | swe_pos | Position des positiven Softwareendschalters
P-AXIS-00179 | swe_toleranz | Toleranzbereich der Softwareendschalterposition bei Istpositionen


Achsparameter

P-AXIS-00177 | Position des negativen Softwareendschalters
Parameter | kenngr.swe_neg
Beschreibung | Position des negativen Softwareendschalters
Datentyp | SGN32
Datenbereich | MIN(SGN32) ≤ P-AXIS-00177 ≤ MAX(SGN32) und es gilt: P-AXIS-00177 < P-AXIS-00178
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | > Position des negativen Hardwareendschalters
Anmerkungen | Der Wert des Parameters wird bei Reset, Betriebsartenwechsel und Achstausch aus dem Achsdatensatz übernommen.

P-AXIS-00178 | Position des positiven Softwareendschalters
Parameter | kenngr.swe_pos
Beschreibung | Position des positiven Softwareendschalters
Datentyp | SGN32
Datenbereich | MIN(SGN32) ≤ P-AXIS-00178 ≤ MAX(SGN32) und es gilt: P-AXIS-00178 > P-AXIS-00177
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | < Position des positiven Hardwareendschalters
Anmerkungen | Der Wert des Parameters wird bei Reset, Betriebsartenwechsel und Achstausch aus dem Achsdatensatz übernommen.

P-AXIS-00179 | Toleranzbereich der Softwareendschalterposition bei Istpositionen
Parameter | kenngr.swe_toleranz
Beschreibung | Zur Vermeidung, dass bei geringfügigem Überschwingen einer Achse (z.B. programmierte Sollposition = Position des positiven Softwareendschalters und Istposition > Position des positiven Softwareendschalters) die istwertseitige Softwareendschalterüberwachung in der Lageregelung anspricht, wird der Software-Endschalterbereich in positiver und negativer Richtung jeweils um den Betrag des Parameters P-AXIS-00179 erweitert.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00179 ≤ MAX(UNS32)
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | 0
Anmerkungen |


CNC-Programmierung

Negativer Softwareendschalter

G98 setzt die negativen Softwareendschalterpositionen in den programmierten Achsen. Je nach gesetztem G90/G91 geschieht dies absolut oder additiv zur seitherigen Softwareendschalterposition.

Der Befehl G98 ist satzweise wirksam, die damit programmierten Softwareendschalterpositionen sind satzübergreifend wirksam.

Die über G98 programmierten Positionen für die negativen Softwareendschalter sind in den achsspezifischen Variablen V.A.-SWE.X, V.A.-SWE.Y, V.A.-SWE.Z, etc. abgelegt [PROG].

Die Variablen werden bei Reset, Betriebsartenwechsel und Achstausch mit dem Wert des Parameters P-AXIS-00177 der jeweiligen Achse vorbelegt.

Programmierbeispiel

N10 G90

...

N50 G98 X-1000 Y-2000 Setzt negativen Softwareendschalter
in X auf -1000 und in Y auf -2000

Meldungen

Berechnet die Steuerung nach der Programmierung mit G98 eine Position für den negativen Softwareendschalter, die kleiner als die durch den Parameter P-AXIS-00177 definierte Position ist, wird die Meldung mit der ID: 120013 angezeigt.

Die berechnete Softwareendschalterposition wird nicht als Position für den negativen Softwareendschalter übernommen, sondern der Wert des Parameters P-AXIS-00177.

Berechnet die Steuerung nach der Programmierung mit G98 eine Position des negativen Softwareendschalters, die gleich oder größer als die Position des positiven Softwareendschalters ist, wird die Meldung mit der ID: 120014 angezeigt.

Die berechnete Position des Softwareendschalters wird als Wert für den negativen Softwareendschalter von der Steuerung übernommen.

Ist nach der Programmierung von G98 die aktuelle Istposition der Achse kleiner als die des negativen Softwareendschalters, erhält man eine Meldung mit der ID: 120015 angezeigt.

Die Steuerung muss mit einem Reset zurückgesetzt werden.

Positiver Softwareendschalter

G99 setzt die positiven Softwareendschalterpositionen in den programmierten Achsen. Je nach gesetztem G90/G91 geschieht dies absolut oder additiv zur seitherigen Softwareendschalterposition.

Der Befehl G99 ist satzweise wirksam, die damit programmierten Softwareendschalterpositionen sind satzübergreifend wirksam.

Die über G99 programmierten Positionen für die positiven Softwareendschalter sind in den achsspezifischen Variablen V.A.+SWE.X, V.A.+SWE.Y, V.A.+SWE.Z, etc. abgelegt [PROG].

Die Variablen werden bei Reset, Betriebsartenwechsel und Achstausch mit dem Wert des Parameters P-AXIS-00178 der jeweiligen Achse vorbelegt.

Programmierbeispiel

N10 G90

...

N50 G99 X+1000 Y+2000 Setzt positiven Softwareendschalter
in X auf +1000 und in Y auf +2000

Meldungen

Berechnet die Steuerung nach der Programmierung mit G99 eine Position für den positiven Softwareendschalter, die größer als die durch den Parameter P-AXIS-00178 definierte Position ist, wird die Meldung mit der ID: 120009 angezeigt.

Die berechnete Softwareendschalterposition wird nicht als Position für den positiven Softwareendschalter übernommen, sondern der Wert des Parameters P-AXIS-00178.

Berechnet die Steuerung nach der Programmierung mit G99 eine Position des positiven Softwareendschalters, die gleich oder kleiner als die Position des negativen Softwareendschalters ist, wird die Meldung mit der ID: 120010 angezeigt.

Die berechnete Position des Softwareendschalters wird als Wert für den positiven Softwareendschalter von der Steuerung übernommen.

Ist nach der Programmierung von G99 die aktuelle Istposition der Achse größer als die des positiven Softwareendschalters, erhält man eine Meldung mit der ID: 120011 angezeigt.

Die Steuerung muss mit einem Reset zurückgesetzt werden.