Spindel (S1)

1.1 EinleitungPAGEREF _Toc304471375 \h3

1.2 Beschreibung 4

1.2.1 Steuerungstopologie 4

1.2.2 Spindelarten 5

1.2.2.1 NC-Spindel 5

1.2.2.1.1 Beispiel: Konfigurierung und Programmierung einer NC-Spindel 7

1.2.2.2 PLC-Spindel 8

1.2.2.2.1 Beispiel: Konfigurierung und Programmierung einer PLC-Spindel 9

1.2.2.3 Hauptspindel 10

1.2.2.4 Gesteuerte Spindel 11

1.2.2.4.1 Beispiel: Konfigurierung einer geberlosen Spindel 12

1.2.2.4.2 Beispiel: Konfigurierung einer gesteuerten Spindel mit Drehzahlrückmeldung 13

1.2.2.5 Sonderapplikation: Datenaustausch für PLC-Spindeln über den kanalspezifischen HLI-Bereich 14

1.2.2.5.1 Beispiel: Konfigurierung und Programmierung mehrerer Spindeln 15

1.2.2.5.2 Beispiel: Konfiguration eines 2-kanaligen Systems mit 3 Spindeln 16

1.2.3 Spindelbetriebsarten 18

1.2.3.1 Endlosdrehen 19

1.2.3.2 Positionieren 19

1.2.3.3 Spindel als Kanalachse 20

1.2.3.4 Spindel Override 20

1.2.3.5 Regelung durch CNC 21

1.2.3.6 Verhalten am NC-Programmende 21

1.2.4 Synchronisation 22

1.2.4.1 M-Funktionen 23

1.2.4.2 Spindeldrehzahl  Bahnbewegung 23

1.2.5 Spindelüberwachungen 25

1.2.6 Referenzpunktfahrt für NC-Spindeln 26

1.2.7 Spindelfunktionen 27

1.2.7.1 Vorsteuerung 27

1.2.7.2 Genauhalt 28

1.2.7.3 Getriebeschalten 29

1.2.7.4 Synchronbetrieb 33

1.2.7.5 Kennliniengeführte Beschleunigung 34

1.2.7.5.1 Methode 1: Kennlinie a(n) in Polynom- oder Hyperbelform 38

1.2.7.5.2 Methode 2: Kennlinie für asynchrone Antriebscharakteristik 40

1.2.7.6 Werkzeugbezogene Dynamikbegrenzung für Spindeln 41

1.2.7.7 Gewindebohren ohne Ausgleichsfutter 42

1.2.7.8 Gewindeschneiden mit endlos drehender Spindel 44

1.2.7.9 C-Achsbearbeitung (Stirn- und Mantelflächenbearbeitung) 45

1.2.7.10 Drehfunktionen 46

1.2.8 HLI Schnittstellenobjekte (NCK-PLC Schnittstelle) 47

1.2.9 HMI Schnittstellenobjekte 47

1.3 Parameter 50

1.3.1 Übersicht 50

1.3.2 Beschreibung 58

1.3.2.1 Kanalparameter 58

1.3.2.2 Achsparameter 60

1.3.2.3 Werkzeugparameter 74

Mehr:

button Einleitung

button Beschreibung

button Parameter


Einleitung

Bei einer Spindel handelt es sich um einen Antrieb, der hauptsächlich dazu dient, ein Werkzeug oder ein Werkstück aufzunehmen und es für die span-abhebende Bearbeitung in Rotation zu versetzen. Eine Spindel umfasst folgende Funktionsbereiche:

q Vorgabe der Spindeldrehrichtung (M3, M4)

q Vorgabe der Spindeldrehzahl (S..)

q Spindel Halt (M5)

q Spindelpositionierung (M19)

q Getriebestufenumschaltung (M40 bis M45)

q Automatische Getriebestufenwahl durch Drehzahlbereichstabellen

q Spindel als Kanalachse (Spindel wird im NC-Kanal als rotatorische Achse interpoliert)

q Gewindeschneiden mit endlos drehender Spindel (G33)

q Gewindebohren ohne Ausgleichsfutter (G63)

q Umdrehungsvorschub (G95)

q Konstante Schnittgeschwindigkeit (G96, G97, G196)

q Spindelüberwachungen auf min. und max. Drehzahl

q Werkzeugbezogene Dynamikbegrenzung

q Stirn- und Mantelflächenbearbeitung

q Beschleunigungskennlinien


Beschreibung

Mehr:

button Steuerungstopologie

button Spindelarten

button Spindelbetriebsarten

button Synchronisation

button Spindelüberwachungen

button Referenzpunktfahrt für NC-Spindeln

button Spindelfunktionen

button HLI Schnittstellenobjekte (NCK-PLC Schnittstelle)

button HMI Schnittstellenobjekte


Steuerungstopologie

Abbildung 1-1: Einbindung der Spindeln in die NC-Steuerungs-
topologie

§ Spindeln werden über Achsparameterlisten [AXIS] als NC- oder PLC-Spindel konfiguriert.

§ Über die Kanalparameterliste [CHAN] werden aus den vorhandenen Spindeln die für den NC-Kanal benötigten ausgewählt und parametriert.

§ Spindeln können über die Benutzerschnittstelle (NC-Programm, HMI) oder über die Schnittstelle zur PLC (HLI) beauftragt werden

Abbildung 1-2: Jeder NC-Kanal kann für den Zugriff auf alle vorhandenen Spindeln konfiguriert werden.


Spindelarten

Mehr:

button NC-Spindel

button PLC-Spindel

button Hauptspindel

button Gesteuerte Spindel

button Sonderapplikation: Datenaustausch für PLC-Spindeln über den kanalspezifischen HLI-Bereich


NC-Spindel

Die NC-Spindel wird durch einen Einzelachsinterpolator der Steuerung lagegeregelt betrieben.

Abbildung 1-3: NC-Spindel

Bei digitalen Antrieben (z.B. SERCOS) erfolgt die Regelung antriebs-seitig. Hier können auch die Betriebsarten Drehzahl- oder Momenten- Regelung aktiviert werden.

Parameter für die NC-Spindel |
 | P-AXIS-00015 | Betriebsmodus der Achse
 | P-AXIS-00016 | Logische Nummer der Achse
 | P-AXIS-00018 | Typ der Achse
 | P-AXIS-00020 | Antriebstyp der Achse

P-CHAN-00007 | Bezeichnung der Spindel
P-CHAN-00036 | Logische Achsnummer der Spindel
P-CHAN-00051 | Logische Achsnummer der Hauptspindel
P-CHAN-00053 | Bezeichnung der Hauptspindel
P-CHAN-00082 | Spindelanzahl

Mehr:

button Beispiel: Konfigurierung und Programmierung einer NC-Spindel


Beispiel: Konfigurierung und Programmierung einer NC-Spindel

Initialisierung in der Achsparameterliste

kopf.achs_nr 1

achs_typ 0x0004 Spindel

Initialisierung in der Kanalparameterliste (Kanal 1)

spdl_anzahl 1

main_spindle_ax_nr 1

main_spindle_name S

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 1

Programmierbeispiel

DIN Syntax:

N10 M03 S1000

N20 Z0

N30 M04 S1000

N40 Z100

N50 M05

N60 M19 S200 S.POS100

M30

Programmierbeispiel

Achsspezifische Syntax:

N10 S[M03 REV1000]

N20 Z0

N30 S[M04 REV1000]

N40 Z100

N50 S[M05]

N60 S[M19 REV200 POS100]

M30

Externe Beauftragung einer NC-Spindel

Über eine Zusatzschnittstelle im HLI kann die NC-Spindel aus dem PLC-Prozess beauftragt werden. Die Aufträge werden dabei von der Spindel in der Reihenfolge ihres Eingangs sequentiell bearbeitet.

Der PLC-Prozess erhält die Quittierungen, z. B. über die erreichte Drehzahl.

Abbildung 1-4: NC-Spindel mit externer Beauftragung


PLC-Spindel

Die PLC-Spindel wird durch die PLC angesteuert.

Abbildung 1-5: PLC-Spindel

Die Spindelachse wird wie eine NC-Spindel konfiguriert und parametriert. Da kein realer Antrieb durch die NC zu versorgen ist, muss der Antriebstyp Simulation oder virtuell gewählt werden.

PLC-Spindeln werden von der CNC über die PLC-Schnittstelle (HLI) mit Drehzahl- bzw. Positionskommandos beauftragt. Die Ansteuerung findet durch die PLC statt. Die CNC erhält lediglich eine Quittierung für an die Spindel ausgegebene M-Funktionen.

Parameter für die PLC-Spindel |
 | P-AXIS-00015 | Betriebsmodus der Achse
 | P-AXIS-00016 | Logische Nummer der Achse
 | P-AXIS-00018 | Typ der Achse
 | P-AXIS-00020 | Antriebstyp der Achse

P-CHAN-00007 | Bezeichnung der Spindel
P-CHAN-00036 | Logische Achsnummer der Spindel
P-CHAN-00051 | Logische Achsnummer der Hauptspindel
P-CHAN-00053 | Bezeichnung der Hauptspindel
P-CHAN-00082 | Spindelanzahl

Mehr:

button Beispiel: Konfigurierung und Programmierung einer PLC-Spindel


Beispiel: Konfigurierung und Programmierung einer PLC-Spindel

Initialisierung in der Achsparameterliste

achs_typ 0x00004 Spindel

achs_mode 0x40000 Extern kontrollierte
Spindel

antr_typ 0x00004 Simulation

Initialisierung in der Kanalparameterliste

spdl_anzahl 1

main_spindle_ax_nr 1

main_spindle_name S

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 1

Die Programmierung von NC-und PLC-Spindeln unterscheidet sich nicht

Programmierbeispiel

DIN Syntax:

N10 M03 S1000

N20 Z0

N30 M04 S1000

N40 Z100

N50 M05

N60 M19 S200 S.POS100

M30

Programmierbeispiel

Achsspezifische Syntax:

N10 S[M03 REV1000]

N20 Z0

N30 S[M04 REV1000]

N40 Z100

N50 S[M05]

N60 S[M19 REV200 POS100]

M30


Hauptspindel

Die Hauptspindel kann zusammen mit bestimmten Standardfunktionalitäten (z.B. Gewindebohren, Getriebeschalten etc.) in der herkömmlichen DIN-Syntax programmiert werden.

Die Definition der Hauptspindel erfolgt über die Belegung des Parameters P-CHAN-00051 (main_spindle_ax_nr). Hier wird die logische Achsnummer einer der Spindeln eingetragen, die in der Kanalparameterliste konfiguriert sind. Diese Spindel ist nach dem Hochlauf der Steuerung die Hauptspindel.

Durch den NC-Befehl #MAIN SPINDLE, siehe [PROG], kann jede andere Spindel im System zur Hauptspindel gemacht werden.

Der Hauptspindel wird über den Parameter P-CHAN-00053 (main_spindle-_name) eine Achsbezeichnung zugeordnet, mit der sie im Teileprogramm angesprochen werden kann. Diese Achsbezeichnung ist frei wählbar, muss jedoch mit dem Buchstaben S beginnen.

Auch wenn nur eine Spindel im System vorhanden ist, muss diese als Hauptspindel konfiguriert werden.

Parameter |
 | P-CHAN-00051 | Logische Achsnummer der Hauptspindel
 | P-CHAN-00053 | Bezeichnung der Hauptspindel

Beispieldatensatz

Beispiel: Spindel S1 wird als Hauptspindel definiert.

Initialisierung in der Kanalparameterliste

main_spindle_ax_nr 10

main_spindle_name S

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 10

spindel[1].bezeichnung S2

spindel[1].log_achs_nr 11

spindel[2].bezeichnung S3

spindel[2].log_achs_nr 12


Gesteuerte Spindel

Funktionalität

Für bestimme Anwendungen kann es ausreichend sein, eine Spindel nicht lagegeregelt zu betreiben, sondern die Spindel im rein gesteuerten Betrieb durch Ausgabe eines Drehzahlsollwertes zu bewegen.

Antriebstypen

Die Konfiguration einer gesteuerten Spindel ist für die Antriebstypen Terminal, Lightbus, und EtherCAT/Canopen möglich.

Wirkungsweise

Bei einer gesteuerten Spindel wird der Geschwindgkeitssollwert des Interpolators direkt an die Achse ausgegeben und nicht der Geschwindigkeitssollwert des Lagereglers.

Die Quittierung von Drehzahlkommandos an die Spindel wird dabei abhängig vom konfigurierten Istwerttelegramm aus den folgenden Istwerten abgeleitet:

1. Falls ein Lageistwert konfiguriert ist wird die Istdrehzahl aus den Lageistwerten berechnet. Hierzu muss die Auflösung des Gebers in der Achsparameterliste angegeben werden.

2. Falls ein Drehzahlistwert und kein Lageistwert konfiguriert ist wird der Drehzahlistwert zur Drehzahlquittierung verwendet.

3. Falls weder ein Lage- noch ein Drehzahlistwert konfiguriert ist (geberlose Spindel) wird die Drehzahlquittierung aus dem internen Drehzahlsollwert berechnet. Die Drehzahl wird dabei als erreicht betrachtet, wenn der interne, taktweise berechnete Drehzahlsollwert innerhalb der in der Achsparameterliste angegebenen Drehzahltoleranz liegt.

Naturgemäß kann eine geberlose Spindel nicht positioniert werden. Falls dies trotzdem versucht wird, erfolgt die Ausgabe einer Fehlermeldung.

Damit die tatsächliche Spindeldrehzahl mit der programmierten Spindeldrehzahl übereinstimmt, muss der Skalierungsfaktor für den Geschwindigkeitssollwert korrekt eingestellt sein.

Bei Terminalantrieben kann es bedingt durch Offsetspannungen im Analogeingangsteil des Antriebsreglers auch bei einer programmierten Spindeldrehzahl von 0 zu einer langsamen Drehbewegung der Spindel kommen.

Dies kann verhindert werden durch:

· Offsetabgleich des Antriebsverstärkers.

· Sperren des Antriebsverstärkers bei Drehzahl 0 seitens der SPS.

Mehr:

button Beispiel: Konfigurierung einer geberlosen Spindel

button Beispiel: Konfigurierung einer gesteuerten Spindel mit Drehzahlrückmeldung


Beispiel: Konfigurierung einer geberlosen Spindel

Beispiel

Für einen Terminalantrieb soll eine geberlose Spindel parametriert werden.

Die DA-Wandlerklemme liefert bei einem digitalen Eingangswert von 32767 Digits eine Ausgangsspannung von 10 V.

Bei einer Eingangsspannung von 10V dreht sich der Motor mit einer Geschwindigkeit von 3000 Umdrehungen/Minute.

Hierzu sind die folgenden Schritte nötig:

1. Konfiguration einer Spindel ohne Geber aber mit DA-Ausgabe-kanal.

2. Einstellen der Betriebsart auf gesteuerten Betrieb.

3. Parametrierung der Geschwindigkeitsskalierung.

1. Schritt

Konfiguration einer Spindel ohne Geber

Erfolgt mit Konfigurationswerkzeug, z. B. TwinCAT-Systemmanager. Die Grundkonfiguration erfolgt wie bei einer NC-Spindel (siehe Kap. 1.2.2.1 ).

2. Schritt

Drehzahlgesteuerten Betrieb für die Achse konfigurieren

Hierzu ist in der Achsparameterliste P-AXIS-00320 auf den Wert OPEN_POSITION_LOOP_MODE zu setzen.

antr.operation_mode OPEN_POSITION_LOOP_MODE

3. Schritt

Parametrierung der Geschwindigkeitsskalierung

Hierzu sind in der Achsparameterliste P-AXIS-00207 , P-AXIS-00206 und P-AXIS-00205 zu belegen:

Die Vorgabe der Sollgeschwindigkeit an den Antrieb erfolgt in Umdrehungen / Minute:

antr.v_time_base 0

Bei Ausgabe von 32767 Inkrementen dreht sich der Motor mit 3000 U/min. Dies entspricht einer Geschwindigkeit von 3000 * 360°/min = 1080000 °/min.

Umgerechnet in das interne Format ergibt dies:

1080000° * 1000 = 1080000000.

antr.v_reso_nom 32767

antr.v_reso_denom 1080000000

Parameter für die geberlose Spindel |
 | P-AXIS-00320 | Achsbetriebsart
 | P-AXIS-00207 | Zeitbasis Geschwindigkeitsskalierung
 | P-AXIS-00206 | Geschwindigkeitsskalierung Zähler
 | P-AXIS-00205 | Geschwindigkeitsskalierung Nenner


Beispiel: Konfigurierung einer gesteuerten Spindel mit Drehzahlrückmeldung

Beispiel

Es soll eine gesteuerte Spindel konfiguriert werden, bei der die Drehzahlquittierung über den Drehzahlistwert erfolgt.

Die Spindelachse dreht sich bei Ausgabe des Wertes 1 als Sollgeschwindigkeit mit einer Drehzahl von 1 U/min.

Hierzu sind die folgenden Schritte nötig:

1. Konfiguration einer Spindel mit Ausgabe eines Drehzahlsollwertes und Rückgabe eines Drehzahlistwertes.

2. Einstellen der Betriebsart auf gesteuerten Betrieb.

3. Parametrierung der Geschwindigkeitsskalierung.

1. Schritt

Konfiguration einer Spindel

Erfolgt mit Konfigurationswerkzeug, z. B. TwinCAT-Systemmanager. Die Grundkonfiguration erfolgt wie bei einer NC-Spindel (siehe Kap. 1.2.2.1 ).

2. Schritt

Drehzahlgesteuerten Betrieb für die Achse konfigurieren

Hierzu ist in der Achsparameterliste P-AXIS-00320 auf den Wert OPEN_POSITION_LOOP_MODE zu setzen.

antr.operation_mode OPEN_POSITION_LOOP_MODE

3. Schritt

Parametrierung der Geschwindigkeitsskalierung

Hierzu sind in der Achsparameterliste P-AXIS-00207 , P-AXIS-00206 und P-AXIS-00205 zu belegen:

Die Vorgabe der Sollgeschwindigkeit an den Antrieb erfolgt in Umdrehungen / Minute:

antr.v_time_base 0

Bei Ausgabe von 1 Inkrement dreht sich der Motor mit 1 U/min. Dies entspricht einer Geschwindigkeit von 1 * 360°/min = 360 °/min.

Umgerechnet in das interne Format ergibt dies:

360° * 1000 = 360000.

antr.v_reso_nom 1

antr.v_reso_denom 360000

Parameter für die geberlose Spindel |
 | P-AXIS-00320 | Achsbetriebsart
 | P-AXIS-00207 | Zeitbasis Geschwindigkeitsskalierung
 | P-AXIS-00206 | Geschwindigkeitsskalierung Zähler
 | P-AXIS-00205 | Geschwindigkeitsskalierung Nenner


Sonderapplikation: Datenaustausch für PLC-Spindeln über den kanalspezifischen HLI-Bereich

Der Einzelachsinterpolator der Steuerung ist bei dieser Konfiguration nicht vorhanden. Es besteht die Möglichkeit PLC-Spindeln direkt durch den NC-Kanal zu beauftragen.

Abbildung 1-6: Kanalspezifische Beauftragung einer PLC-Spindel

Parameter |
 | P-CHAN-00069 | PLC-gesteuerte Spindel

Beispiel: Spindel S1 wird als PLC-Spindel definiert

Initialisierung in der Kanalparameterliste

:

spindel[0].plc_control1

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 1

:

q Die logische Achsnummer ist beliebig, sie muß jedoch ungleich Null sein und sie darf keiner anderen Achse bereits zugeordnet sein.

q Für diese Art von PLC-Spindel ist keine Achsparameterliste erforderlich.

Mehr:

button Beispiel: Konfigurierung und Programmierung mehrerer Spindeln

button Beispiel: Konfiguration eines 2-kanaligen Systems mit 3 Spindeln


Beispiel: Konfigurierung und Programmierung mehrerer Spindeln

3 Spindeln

Initialisierung in der Achsparameterliste

achs_typ 0x00004 Spindel

achs_mode 0x40000 Extern kontrollierte Spindel

antr_typ 0x00004 Simulation

Initialisierung in der Kanalparameterliste

spdl_anzahl 3

main_spindle_ax_nr 6

main_spindle_name S

spindel[0].bezeichnung S1

spindel[0].log_achs_nr 6

spindel[1].bezeichnung S2

spindel[1].log_achs_nr 11

...

spindel[2].bezeichnung S3

spindel[2].log_achs_nr 30

...

Die Spindel S1 mit der logischen Achsnummer 6 wird als Hauptspindel definiert. Sie wird über den Spindelnamen S angesprochen. Die Spindeln mit den logischen Achsnummern 11 und 30 werden über ihre Bezeichnungen S2 und S3 programmiert.

Abbildung 1-7: Anbindung der 3 Spindeln an Kanal 1


Beispiel: Konfiguration eines 2-kanaligen Systems mit 3 Spindeln

Kanal 1

Initialisierung in der Kanalparameterliste Kanal 1:

3 Spindeln. Spindel mit der Achsnummer 11 (S2) soll Hauptspindel sein.

 | spdl_anzahl 3 main_spindle_ax_nr 11 main_spindle_name S main_spindle_gear_change 0 # spindel[0].bezeichnung S1 spindel[0].log_achs_nr 6 spindel[1].bezeichnung S2 spindel[1].log_achs_nr 11 spindel[2].bezeichnung S3 spindel[2].log_achs_nr 30 :
Kanal 2 | Initialisierung in der Kanalparameterliste Kanal 2: 2 Spindeln. Spindel mit der Achsnummer 11 (S2) soll Hauptspindel sein.
 | spdl_anzahl2 main_spindle_ax_nr 11 main_spindle_name S main_spindle_gear_change 0 # spindel[0].bezeichnung S1 spindel[0].log_achs_nr 6 spindel[1].bezeichnung S2 spindel[1].log_achs_nr 11 :

Beide Kanäle können die Spindel mit der logischen Achsnummer 11 als Hauptspindel über den Spindelnamen S ansprechen. Sie kann in herkömmlicher DIN-Syntax oder in spindelspezifischer Syntax programmiert werden. Die Spindel S1 kann ebenfalls von beiden Kanälen aus in spindelspezifischer Syntax programmiert werden. Spindel S3 ist ausschließlich in Kanal 1 verfügbar, in Kanal 2 ist diese Spindel unbekannt.

Abbildung 1-8: Anbindung der 3 Spindeln an Kanal 1 und Kanal 2


Spindelbetriebsarten

Analoge Spindeln

Im allgemeinen werden beim Einsatz analoger Spindeln folgende Maschinendaten [AXIS] belegt:

q In P-AXIS-00015 (achs_mode) darf die Betriebsart ACHSMODE_KEINE_AUTO_RPF nicht gesetzt sein.

q P-AXIS-00156 (ref_ohne_nocken) == TRUE

q P-AXIS-00157 (ref_ohne_rev) == TRUE

Basierend auf diesen Einstellungen gilt folgender Zustandsgraph:

Abbildung 1-9: Zustandsgraph der Spindelbetriebsarten für analoge Antriebe

Digitale Spindeln

Beim Einsatz digitaler Spindeln (SERCOS) ist bei der Einstellung der Maschinendaten [AXIS] folgendens zu beachten:

q In P-AXIS-00015 (achs_mode) muss die Betriebsart ACHSMODE_KEINE_AUTO_RPF gesetzt sein.

q Die Einstellung von P-AXIS-00156 (ref_ohne_nocken) und P-AXIS-00157 (ref_ohne_rev) ist im Gegensatz zu analogen Spindeln ohne Bedeutung.

Basierend auf diesen Einstellungen gilt folgender Zustandsgraph:

Abbildung 1-10: Zustandsgraph der Spindelbetriebsarten für digitale Antriebe (z.B. SERCOS)

Mehr:

button Endlosdrehen

button Positionieren

button Spindel als Kanalachse

button Spindel Override"

button Regelung durch CNC

button Verhalten am NC-Programmende


Endlosdrehen

Beim Endlosdrehen (M03/M04) wird die Drehzahl und Drehrichtung beauftragt. Es erfolgt eine konstante Beschleunigung der Spindel oder eine Beschleunigung gemäß einer Kennlinie. Das Endlosdrehen wird durch Spindelstopp (M05), eine Referenzpunktfahrt (G74) oder einen Richtsatz (M19) verlassen.

Programmierung DIN66025

M3/M4 S..

Erweiterte Syntax

S[M3/M4 REV..]


Positionieren

Die Spindel wird auf einen vorgegebenen Zielpunkt mit vorgegebener Drehzahl positioniert.

Programmierung DIN66025

M19 S.. S.POS.. M3/M4

Erweiterte Syntax

S[M19 REV.. POS.. M3/M4]

Bei der Drehrichtung ist folgendes zu beachten:

q Wenn zusammen mit M19 eine Drehrichtung programmiert ist, wird in diese Richtung gerichtet.

q Ohne Angabe einer Drehrichtung bei M19 wird

§ aus dem Stillstand wegoptimiert und

§ aus dem Endlosdrehen in der aktuellen Drehrichtung gerichtet.

Vorzugsdrehrichtung

Bei Angabe einer Vorzugsrichtung P-AXIS-00224 (vorz_richtung) und einer Drehrichtung P-AXIS-00031 (beweg_richt ) werden alle beauftragten Drehrichtungen auf Übereinstimmung mit der Vorzugsrichtung kontrolliert. Stimmen diese nicht, wird eine Fehlermeldung ausgegeben und in den Fehlerzustand übergegangen.


Spindel als Kanalachse

Für Bearbeitungsvorgänge wie Gewindebohren ohne Ausgleichsfutter, Stirn- und Mantelflächenbearbeitung, etc. wird die Spindel über den NC-Kanal wie eine normale Achse angesprochen.

Programmierung

Der Übergang in diesen Betriebsmodus erfolgt über die Programmierung im Teileprogramm [PROG]:

#CAX, G63..


Spindel Override"

TwinCAT CNC: Überblick

Spindel Override

Die Drehzahl bzw. Geschwindigkeit einer Spindel beim Endlosdrehen bzw. Positionieren kann über die Override-Schnittstelle [HLI] prozentual skaliert werden.

Durch den NC-Befehl G167 [PROG] kann die Beeinflussung durch die Override-Schnittstelle unterdrückt werden.

Beispiel

N10 S2[M3 REV1000] (Bei Override 50% ist Drehzahl 500 U/min.)

N20 S2[G167] (Overridebeeinflussung aus,)
(Spindel dreht mit 1000 U/min.)

N30 S2[REV3000] (Overridebeeinflussung wieder aktiv,)
(Drehzahl 1500 U/min.)

N40 M30 (Programmende)


Regelung durch CNC

Bei Spindeln kann bei höherer Drehzahl die Grenze, ab welcher das Meßsystem keine gültigen Signale mehr liefert, überschritten werden. Der Parameter P-AXIS-00220 (vb_regelgrenze) gibt an, ab welcher Geschwindigkeit der Lageregelkreis geöffnet und in den gesteuerten Betrieb über-gegangen wird. Dabei erfolgt automatisch eine Simulation der Istwerte, die über den Schleppabstand in Abhängigkeit von der vorgegebenen Drehzahl bestimmt werden.

Die Regelung wird aus dem Endlosdrehen bei der Unterschreitung der Regelgrenze automatisch wieder aufgenommen. Der Referenzpunkt ist dann jedoch verloren. Deshalb muss vor einer Positionierbewegung neu referenziert werden.

Bei digitalen Antriebssystemen (z.B. SERCOS) erfolgt die Regelung und Überwachung der Regelgrenze im Antrieb.


Verhalten am NC-Programmende

Die endlos drehende Spindel wird am NC-Programmende nur gestoppt, wenn in der Schnittstelle HLI das entsprechende Flag (Spindel Stopp am Programmende [HLI]) gesetzt wird. Bei CNC-Reset erfolgt immer ein Spindelstopp.


Synchronisation

Synchronisations-arten

Die Synchronisationsarten der Spindel-M-Funktionen M3,M4,M5,M19 sowie der Spindelfunktion S werden spindelspezifisch definiert. Folgende Synchronisationsarten sind verfügbar:

Konstante | Wert | Bedeutung
NO_SYNCH | 0x00000000 | Keine Ausgabe der S/M-Funktion an SPS
MOS | 0x00000001 | Ausgabe S/M-Funktion an SPS ohne Synchronis.
MVS_SVS | 0x00000002 | Ausgabe S/M-Funktion an SPS vor Bewegungssatz, Synchronisation vor Bewegungssatz
MVS_SNS | 0x00000004 | Ausgabe S/M-Funktion an SPS vor Bewegungssatz, Synchronisation nach Bewegungssatz
MNS_SNS | 0x00000008 | Ausgabe S/M-Funktion an SPS nach Bewegungsatz, Synchronisation nach Bewegungssatz
MNE_SNS | 0x00000020 | Ausgabe S/M-Funktion an SPS nach (Mess)Ereignis, Synchronisation nach Bewegungssatz (Nur für Option Kantenstoßen)
MVS_SLM | 0x00004000 | Späte Synchronisation, Ausgabe S/M-Funktion an SPS im Satz, Synchronisation bei Übergang zu G01/G02/G03 (Implizite Synchronisation)
MVS_SLP | 0x00008000 | Späte Synchronisation, Ausgabe S/M-Funktion an SPS im Satz, Synchronisation bei NC-Befehl #EXPL SYN (Explizite Synchronisation)
PLC_INFO | 0x00020000 | SPS informieren

PLC_INFO

Das Bit PLC_INFO, das zusätzlich zu den bestehenden Synchronisationsarten gesetzt werden kann, bestimmt ob auch die PLC informiert werden soll. Dabei ist folgendes zu beachten:

Bei PLC-Spindeln wird generell bei jeder Spindel M-Funktion automatisch auch die PLC informiert. Es ist somit nicht erforderlich, das PLC_INFO-Bit zusätzlich zu setzen.

Sinnvoll ist die Verwendung des PLC_INFO-Bits bei NC-Spindeln. Hier kann für jede Spindel M-Funktion zusätzlich zur Synchronisationsart das Bit PLC_INFO gesetzt werden, wodurch dann eine Information an die PLC ausgegeben wird.

Die Synchronisationsart der S-Funktion ist wirkungslos, wenn im NC-Satz eine Spindel M-Funktion programmiert wurde. Eine Synchronisation findet dann nur entsprechend der Einstellungen für die Spindel M-Funktion statt. Es gilt folgende Prioritätsreihenfolge:

M19 > M3/M4/M5 > S

Mehr:

button M-Funktionen

button Spindeldrehzahl - Bahnbewegung


M-Funktionen

Zur Steuerung von Spindeln sind in DIN66025 die M-Funktionen M3,M4,M5,M19 und M4045 reserviert worden ( P-CHAN-00043/-45/-47/-49). Diese M-Funktionen können mit einer auszuführenden Bahnbewegung synchronisiert werden. Die Synchronisation erfolgt bei M3, M4, M5 immer intern (Drehzahl erreicht) und optional additiv durch die PLC.

Darüber hinaus können alle frei verfügbaren M-Funktionen achsspezifisch an eine Spindel ausgegeben werden.

Weitere Einzelheiten zu M-Funktionen und PLC-Synchronisationen sind der Dokumentation [FCT-C1]zu entnehmen.

M-Funktion | Bedeutung
M03 | Spindel endlos drehen im Uhrzeigersinn
M04 | Spindel endlos drehen gegen den Uhrzeigersinn
M05 | Spindel stoppen
M19 | Spindel positionieren
M4045 | Getriebestufenauswahl für die Hauptspindel


Spindeldrehzahl - Bahnbewegung

TwinCAT CNC: Überblick

Spindeldrehzahl  Bahnbewegung

Für den Beginn der Bearbeitungsbewegung ist es notwendig, dass die Spindel die programmierte Drehzahl erreicht hat. Über den Parameter P-CHAN-00081 (s_synch) kann für jede Spindel eine Synchronisationsart für die Drehzahl festgelegt werden.

Die Synchronisationsart der S-Funktion ist wirkungslos, wenn im NC-Satz eine Spindel M-Funktion programmiert wurde. Eine Synchronisation findet dann nur entsprechend der Einstellungen für die Spindel M-Funktion statt. Es gilt folgende Prioritätsreihenfolge:

M19 > M3/M4/M5 > S

Beispiel 1: Spindel asynchron zu Bahnbewegung

spindel[i].s_synch 0x00000002 Ausgabe vor, Synch. vor Satz

spindel[i].m3_synch 0x00000001 Ohne Synch.

N20 X40 Y40 G1 F1500 M3 S500 Synch. Entsprechend M3: keine Synchronisation.

N30 M3 S100 X0 Y0

Beispiel 2: Spindel synchronisiert zur Bahnbewegung

spindel[i].s_synch 0x00000002 Ausgabe vor, Synch. vor Satz

spindel[i].m3_synch 0x00000001 Ohne Synch.

N10 M3

N20 X40 Y40 G1 F1500 S500 Bahnbewegung startet erst, wenn die Spindeldrehzahl erreicht wurde.

N30 S100 X0 Y0 Bahnbewegung wird zur Erniedrigung der Spindeldrehzahl unterbrochen.


Spindelüberwachungen

Übersicht über die Überwachungsmechanismen für eine NC-Spindel

q Dynamiküberwachung (Geschwindigkeit, Beschleunigung) [FCT-D1]

q Drehzahlüberwachung

q Positionsüberwachung [FCT-A3]

q Schleppabstandsüberwachung [FCT-A1]

q Zeitüberwachung [FCT-A3]

q Überwachung der Drehrichtung

Drehzahl

Über den Parameter P-AXIS-00217 (vb_prozent) wird definiert, ab welcher Ist-Drehzahl die Soll-Drehzahl als erreicht gilt.

Der Parameter P-AXIS-00216 (vb_min_null) legt die Drehzahlgrenze fest, unterhalb derer die Drehzahl Null angenommen wird.

Drehrichtung

Bei Angabe einer Vorzugsrichtung P-AXIS-00224 (vorz_richtung) und einer Drehrichtung P-AXIS-00031 (beweg_richt ) werden alle beauftragten Drehrichtungen auf Übereinstimmung mit der Vorzugsrichtung kontrolliert. Stimmen diese nicht, wird eine Fehlermeldung ausgegeben und in den Fehlerzustand übergegangen.


Referenzpunktfahrt für NC-Spindeln

Automatische
Referenzpunktfahrt

Um ein Positionieren der Spindel zu ermöglichen ist es notwendig, über eine Referenzmarke den Koordinatennullpunkt mit den Signalen des Istwertmeßsystems zu synchronisieren. Bei Spindeln kann dies während des Endlosdrehens ohne Stillstand erfolgen. Hierzu wird beispielsweise der Nulldurchgang des Istwertgebers verwendet.

Ist keine Referenzpunktfahrt für die Spindel durchgeführt worden, so erfolgt dies automatisch, bevor mit M19 positioniert wird oder wenn ein Posi-tionieren oder das Stoppen der Spindel mit M05 nach einer Überschreitung der Regelungsgrenzdrehzahl erfolgen soll (siehe Abbildung 1-9).

Bei digitalen Antriebssystemen (z.B. SERCOS) wird auf Kommando (G74) eine antriebsgeführte Referenzpunktfahrt durchgeführt. Es ist nicht möglich, eine automatische Referenzpunktfahrt durchzuführen. Diese muss über den Achsparameter P-AXIS-00015 (achs_mode) deaktiviert werden.

Programmierung

Beispiele

G74 S1 oder S[G74]

Die Referenzpunktfahrt von Spindeln und anderen Achsen kann zeitgleich gestartet werden, ist aber sonst nicht synchronisiert.

1. Die Referenzpunktfahrt der Spindel beginnt zeitgleich mit der der Y-Achse:

Nxx G74 X2 Y1 S1

2. Wie 1. Ohne abzuwarten, bis die Spindel referenziert ist, wird mit dem nächsten NC-Satz fortgefahren, so dass die X-Achse quasi-gleichzeitig referenziert wird:

Nxx G74 S1

Nyy G74 X1 Y2

3. Zuerst werden die Achsen X und Y referenziert. Danach beginnt die Spindel-Referenzierung:

Nxx G74 X1 Y2

Nyy G74 S1

Eine ausführliche Beschreibung der Referenzpunktfahrt für Achsen und Spindeln ist in der Dokumentation [FCT-M1] zu finden.


Spindelfunktionen

Mehr:

button Vorsteuerung

button Genauhalt

button Getriebeschalten

button Synchronbetrieb

button Kennliniengeführte Beschleunigung

button Werkzeugbezogene Dynamikbegrenzung für Spindeln

button Gewindebohren ohne Ausgleichsfutter

button Gewindeschneiden mit endlos drehender Spindel

button C-Achsbearbeitung (Stirn- und Mantelflächenbearbeitung)

button Drehfunktionen


Vorsteuerung

Durch den Einsatz einer Geschwindigkeits- und Beschleunigungs-vorsteuerung kann der Schleppabstand der Spindel minimiert werden. Eine Vorsteuerung der Spindel ist v.a. beim Gewindeschneiden mit endlos drehender Spindel erforderlich, da hier für das Erzielen eines guten Bearbeitungsergebnisses sowohl die Bahnachsen als auch die Spindel den Sollwertvorgaben möglichst schleppabstandsfrei folgen müssen.

Konventionelle
Vorsteuerung

Diese Art der Vorsteuerung ist nur für konventionelle Antriebe und für die Antriebsimulation möglich.

Hier wird der sich theoretisch einstellende Schleppfehler aufgrund der aktuellen Geschwindigkeit und Beschleunigung berechnet und auf den vom Interpolator vorgegebenen Sollwert aufaddiert. Die zu erwartenden Schleppabstände lassen sich nach der Beziehung

für konstante Geschwindigkeit und

für konstante Beschleunigung berechnen. Hierbei ist Ta die Antriebszeit-konstante, die in der Achsparameterliste P-AXIS-00225 / P-AXIS-00226 eingestellt werden kann.

Bei der Addition der Vorsteuergröße zum vorgegebenen Sollwert wird die Einhaltung der zulässigen Achsbeschleunigungen berücksichtigt.

Bahntreue

Voraussetzung für die beschriebenen Gleichungen ist die Verwendung eines P-Lagereglers, dessen Geschwindigkeitsverstärkung
für Linearachsen bzw.

für Rotationsachsen im wesentlichen von der Antriebsdynamik
bestimmt wird.

Wenn alle Achsen eines Systems den gleichen kv-Faktor besitzen, ergeben sich im eingeschwungenen Zustand weder bei einer Geradeaus- noch bei einer Kreisfahrt Abweichungen zur vorgegebenen Bahn. Hier stellt sich lediglich ein Schleppabstand gemäß den oben beschriebenen Gleichungen ein.

Abtastzeit und
Vorfilterung

Einstellungen

Einkoppeln der
Vorsteuerung

Bei der Ableitung der Geschwindigkeit v und der Beschleunigung a über die Differentiation des Weges ist auf genügend hohe Abtastzeiten zu achten, um das störende Quantisierungsrauschen in Maßen zu halten. Ein besseres Verhalten wird auch über eine Vorfilterung von v und a erreicht. Hierzu wird eine lineare Mittelung über mehrere Werte von v und a durchgeführt.

Die Vorsteuerung führt zu einer Erhöhung der dynamischen Beschleunigungsbeanspruchung und der Vergrößerung der Aussteuerbereiche. Die Verbesserung der Bahntreue durch die Vorsteuerung ist nur mit Lagereglereinstellungen möglich, deren Geschwindigkeitsverstärkung unter den für das Führungsverhalten optimalen Werten liegt, da sonst eine starke Neigung zum Überschwingen auftritt.

Das Ein- bzw. Ausschalten der Vorsteuerung während der Bewegung kann zu Schwingungen führen. Deshalb ist ein "weiches" Einkoppeln der Vor-steuerung unter Beachtung der maximal zulässigen Achsbeschleuni-gungen bzw. des maximalen Rucks (z.B. bei nichtlinearer Slope-Funktion) erforderlich. Dies ermöglicht ein beliebiges Ein- und Ausschalten der Vorsteuerung an Satzgrenzen ohne Unterbrechung der Bewegung. Der Antrieb, wie auch die Mechanik einer Werkzeugmaschine kann geschont werden, in dem nur bei exakt zu bearbeitenden Konturen während der Bearbeitung die Vorsteuerung aktiviert wird.

Weitere Informationen zum Thema Vorsteuerung und Parametrierung können der Funktionsbeschreibung [FCT-D2] entnommen werden.

Programmierung

S[G135] Spindelvorsteuerung ein

S[G136] Angabe der Gewichtung

S[G137] Spindelvorsteuerung aus

Bei digitalen Antriebssystemen (z.B. SERCOS) kann die Vorsteuerung im Antrieb aktiviert und parametriert werden.


Genauhalt

Nach Referenzpunktfahrt und Positionieren mit M19 wird die Spindel immer mit Genauhalt gestoppt.


Getriebeschalten

Aktivierung

Die Freigabe des Getriebeschaltens sowie die damit verbundene reservierte Verwendung der M-Funktionen M40-45 erfolgt durch den Kanalparameter P-CHAN-00052 (main_spindle_gear_change).

Das Getriebeschalten kann nur für die Hauptspindel in DIN-Syntax programmiert werden [PROG] .

Es stehen 6 Getriebestufen bzw. -datensätze zur Verfügung, die im Zusammenhang mit dem S-Wort und M40-45 programmiert werden können. Nach Hochlauf der NC-Steuerung ist die im Achsmaschinendatensatz angegebene Default-Getriebestufe P-AXIS-00079 (getriebe_stufe) gültig.

Anfahren der Schaltposition

Mit der im Achsmaschinendatensatz angegebenen Eilgangdrehzahl P-AXIS-00209 (vb_eilgang) wird auf die Schaltposition des aktuellen Getriebes P-AXIS-00078 (getr_schalt_pos) gefahren. Besitzt das Getriebe keine Vorzugsrichtung, so wird die Drehrichtung unter Optimierung des Fahrweges gewählt.

Der Vorgang des Einwechselns wird normalerweise durch die PLC übernommen. Auf Seite der NC-Steuerung werden Anpassungen an die neuen Kenngrößen des Getriebes erforderlich. Hierfür sind zwei Fälle zu unterscheiden:

q Das Meßsystem ist mit der Motorwelle gekoppelt. In Abhängigkeit der Getriebestufe ist eine Anpassung der Meßsystemauflösung (Faktoren im Achsmaschinendatensatz: P-AXIS-00233 (wegaufz), P-AXIS-00234 (wegaufn)) vorzunehmen.

q Das Meßsystem ist mit der Getriebewelle gekoppelt. Die Auflösung des Meßsystems ist beizubehalten, dafür muss die Regeldynamik an die Getriebestufe angepasst werden. Faktoren im Achsmaschinendatensatz: P-AXIS-00128 (multi_gain_n), P-AXIS-00129 (multi_gain_z), P-AXIS-00099 (kv).

Parametrierung der Drehzahlbereiche

Automatische Getriebestufenwahl

Manuelle Getriebestufenwahl

Minimierung von Schaltvorgängen

Jede der 6 Getriebestufen deckt einen bestimmten Drehzahlbereich ab, der durch eine minimale P-CHAN-00058 (min_speed) und eine maximale P-CHAN-00055 (max_speed) Drehzahl (Einheit U/min) definiert wird. Überlappungen der Drehzahlbereiche sind hierbei erlaubt. Die minimalen und maximalen Drehzahlen nicht benutzter Drehzahlbereiche müssen mit Null belegt werden.

Bei Verwendung der automatischen Getriebestufenwahl P-CHAN-00004 (autom_range=1) wird die Getriebestufe aus der programmierten Drehzahl S anhand der Drehzahltabelle bestimmt. Die M-Funktionen M40-M45 werden hierbei nicht programmiert.

Der Parameter P-CHAN-00074 (range_way) gibt an, in welcher Richtung die Tabelle bei der automatischen Getriebestufenwahl nach dem passenden Drehzahlbereich durchsucht wird (Von Stufe 1 nach 6 (Bottom up) oder von Stufe 6 nach 1 (Top down)).

Die manuelle Getriebestufenwahl P-CHAN-00004 (autom_range=0) erfordert die Programmierung der M-Funktionen M40-M45 zusammen mit der Drehzahl S. Wenn die Drehzahl S nicht im programmierten Drehzahlbereich liegt, erfolgt die Ausgabe einer Meldung.

Generell versucht die Steuerung, Schaltvorgänge zu minimieren. Kann eine neue Drehzahl bereits mit der aktuellen Getriebestufe gefahren werden, so wird die Getriebestufenanwahl nicht ausgeführt.

Konfigurations-beispiel

Definition von M40-M45 und Festlegung der Synchronisationsarten.

m_synch[1] 0x00000001 MOS

m_synch[2] 0x00000002 MVS_SVS

:

m_synch[40] 0x00000002 MVS_SVS

m_synch[41] 0x00000002 MVS_SVS

m_synch[42] 0x00000002 MVS_SVS

m_synch[43] 0x00000002 MVS_SVS

m_synch[44] 0x00000002 MVS_SVS

m_synch[45] 0x00000002 MVS_SVS

m_synch[48] 0x00000008 MNS_SNS

m_synch[49] 0x00000002 MVS_SVS

Freischalten der M-Funktionen M40-45 und des Getriebeschaltens:

:

main_spindle_gear_change 1 0: OFF 1: ON

:

Parametrierung des Spindelgetriebes (Suchrichtung, Drehzahlbereiche):

spindel[0].range_way 0 0:bottom up 1:top down

#

spindel[0].range_table[0].min_speed 50 (M40)

spindel[0].range_table[0].max_speed 560 (M40)

spindel[0].range_table[1].min_speed 400 (M41)

spindel[0].range_table[1].max_speed 800 (M41)

spindel[0].range_table[2].min_speed 700 (M42)

spindel[0].range_table[2].max_speed 3500 (M42)

spindel[0].range_table[3].min_speed 3501 (M43)

spindel[0].range_table[3].max_speed 4000 (M43)

spindel[0].range_table[4].min_speed 3800 (M44)

spindel[0].range_table[4].max_speed 5500 (M44)

spindel[0].range_table[5].min_speed 5400 (M45)

spindel[0].range_table[5].max_speed 7000 (M45)

#

Abbildung 1-11: Definition der Drehzahlbereiche gemäß Beispiel

Programmierbeispiel

Automatische Getriebestufenbestimmung: EIN

:

spindel[0].autom_range 1

:

NC-Programm:

S650 M03 OK, M41 ⇒ SPS

S750 OK, kein Schalten, M41 bereits angewählt

S950 OK, automatisches Schalten, M42 ⇒ SPS

S1050 OK, kein Schalten, M42 bereits angewählt

S750 OK, automatisches Schalten, M41 ⇒ SPS

S500 OK, kein Schalten, M41 bereits angewählt

S350 OK, kein Schalten, M41 bereits angewählt

S8000 Fehler, zu große Drehzahl

Eine programmierte Getriebestufe wird immer geprüft:

M41 S750 OK, "automatisches" Schalten, M41 ⇒ SPS

..aber

M40 S750 Fehler, falsche Getriebestufe

Programmierbeispiel

Automatische Getriebestufenbestimmung: AUS

:

spindel[0].autom_range 0

:

NC-Programm:

M41 S650 M03 OK, M41 ⇒ SPS

M41 S750 OK, kein Schalten, M41 bereits angewählt

M42 S950 OK, Schalten, M42 ⇒ SPS

M42 S1050 OK, kein Schalten, M42 bereits angewählt

M41 S750 OK, Schalten, M41 ⇒ SPS

M41 S500 OK, kein Schalten, M41 bereits angewählt

M41 S350 OK, kein Schalten, M41 bereits angewählt

M41 S200 Fehler, andere Getriebestufe (M40) programmieren

S950 Fehler, keine Getriebestufe (M42) programmiert


Synchronbetrieb

Bei aktivem Synchronbetrieb wird für gekoppelte Spindelachsen die Spindelbeauftragung von der Masterspindel auf die Slave-Spindeln abgebildet, d.h. es erfolgt eine implizite parallele Beauftragung der Slave-Achsen.

Die Definition von Kopplungsvorschriften von Spindelachsen erfolgt analog zu der von Bahnachsen [PROG].

Die gekoppelten Spindeln werden parallel beauftragt. Es erfolgt keine takt-synchrone Kopplung von Sollwerten.

Es entfällt die sonst erforderliche gesonderte Beauftragung der Slave-Spindel bzgl. Drehzahl oder Positionierbefehlen im NC-Programm sowie bzgl. der Technologiefunktionen und deren Quittierungen.

Abbildung 1-12: Beispielhafte Maschinenstruktur für Synchronbetrieb mit Spindeln

Eigenschaft

2 Achssysteme mit gemeinsamer X Achse

Master System: X, Y1, Z1,C1, S1,

Slave System: Y2, Z2, C2, S2

Defaultbelegung
in den
Kanalparametern

In den Kanalparametern [CHAN] können in der Kopplungsgruppe 0 Spindeln für einen Synchronbetrieb als Kopplungspaare vorbelegt werden:

Parameter |
 | P-CHAN-00037 | logische Nr. Master-Achse
 | P-CHAN-00038 | logische Nr. Slave-Achse
 | P-CHAN-00061 | Betriebsart (für Spindelachse: 1)

Vorbelegung von Achskopplungen:

koppelgruppe[0].paar[i].log_achs_nr_slave log. Nr. Slave-
Achse

koppelgruppe[0].paar[i].log_achs_nr_master log. Nr. Master-
Achse

koppelgruppe[0].paar[i].mode Spindelachse (1)

i: Kopplungspaar

Beispiel:

koppelgruppe[0].paar[0].log_achs_nr_slave 6

koppelgruppe[0].paar[0].log_achs_nr_master 1

koppelgruppe[0].paar[0].mode 1

Programmierung

Im NC-Programm wird der Synchronbetrieb von Spindeln über folgende NC-Befehle [PROG] programmiert:

Definition einer Kopplungsvorschrift:

#SET AX LINK[]

Anwahl Synchronbetrieb:

#ENABLE AX LINK[]

Abwahl Synchronbetrieb:

#DISABLE AX LINK

Die Defaultbelegung in den Kanalparametern kann im NC-Programm mit

#ENABLE AX LINK[0]

angewählt werden.

Synchronbetrieb für Spindeln ist nicht in Verbindung mit Drehfunktionen verwendbar


Kennliniengeführte Beschleunigung

Servo- und Hauptspindelmotoren können mit digitaler Antriebstechnik besser ausgenutzt werden, als dies in der analogen Antriebstechnik möglich ist, d.h. die Motoren können näher an ihrer Leistungsgrenze betrieben werden.

Um einen Motor beim Beschleunigen voll ausnutzen zu können, besteht die Möglichkeit, diesen an seiner Kommutierungsgrenzkennlinie zu betreiben. Diese Kennlinie legt das maximal zur Verfügung stehende Moment über der Drehzahl fest. Dabei kann festgestellt werden, daß die Motoren bis zur halben Nenndrehzahl ein teilweise 1,5 bis 2faches höheres Moment gegenüber der Nenndrehzahl abgeben können.

Für eine endlosdrehende Spindel besteht die Möglichkeit, die Sollwerterzeugung entsprechend einer solchen drehzahlabhängigen Beschleunigungskennlinie einzustellen.

Der Verlauf der Beschleunigung ist typischerweise im unteren Drehzahlbereich konstant und fällt ab einer Drehzahlgrenze ngrenz gemäß einer vorzugebenden Kennlinie ab:

Abbildung 1-13: Beschleunigungskennlinie in Abhängigkeit der Drehzahl

Da diese Beschleunigungskennlinie für die einzelnen Getriebestufen einer Spindel variiert, muß für jede Getriebestufe ein entsprechender Datensatz bereitgestellt werden.

Für die Festlegung der Beschleunigungskennlinie stehen zwei Methoden zur Verfügung, die über den Maschinenparameter P-AXIS-00202 angewählt werden können.

Mehr:

button Methode 1: Kennlinie a(n) in Polynom- oder Hyperbelform

button Methode 2: Kennlinie für asynchrone Antriebscharakteristik


Methode 1: Kennlinie a(n) in Polynom- oder Hyperbelform

Im Bereich oberhalb der Grenzdrehzahl wird die aktuelle Beschleunigung wahlweise über ein Polynom dritter Ordnung oder über eine Hyperbelfunktion vorgegeben. Bei beiden Kennlinien wird im Bereich unterhalb von n grenz eine konstante Beschleunigung a konst eingesetzt. Diese entspricht der Beschleunigung bei Nenndrehzahl. Die Kennlinien gelten sowohl für die Aufbau- als auch für die Abbauphase der Geschwindigkeit.

Abbildung 1- 14 : Verlauf der Beschleunigung gemäß Polynom oder Hyperbel

Zur Bestimmung der Koeffizienten der Kennlinien werden Stützpunkte auf der Antriebskennlinie a(n) verwendet. Vier bzw. drei Stützpunkte sind für die Bestimmung erforderlich.

Ein Stützpunkt P1=(n1, (a(n1)) liegt durch den Parameter für die konstante Beschleunigung akonst und die Grenzdrehzahl ngrenz bereits fest, die restlichen drei bzw. zwei können vom Anwender beliebig auf der Antriebskennlinie a(n) festgelegt werden. Sinnvollerweise läßt man die Abszissenwerte in konstantem Abstand laufen. Die Bestimmungsgleichungen für die Koeffizienten sind im folgenden aufgeführt.

Polynom

Beispiel Kennlinienbestimmung

Stützpkt. | Beschleunigung a [°/s2] | Drehzahl n [°/s]
1 | 16000 | 12000
2 | 8000 | 24000
3 | 4000 | 36000
4 | 2000 | 48000

a_konst = 16000[Grad/s2] bis ngrenz = 12000 [Grad/s]

Man erhält für die Koeffizienten:

b3 = -1.92901234E-10 [s/°2]

b2 = 2.08333333E-5 [1/°]

b1 = -0.88888888 [1/s]

b0 = a_konst = 16000 [°/s2]

Ab Nenndrehzahl (ngrenz) ergibt sich damit folgender Kennlinienverlauf

Hyperbel

Beispiel Kennlinienbestimmung

Stützpkt. | Beschleunigung a [°/s2] | Drehzahl n [°/s]
1 | 16000 | 12000
2 | 8000 | 24000
3 | 4000 | 36000

a_konst = 16000[Grad/s2] bis ngrenz = 12000 [Grad/s]

Man erhält für die Koeffizienten:

b2 = 4.166666E-1[]

b3 = 2.857142E-2[]

b1 = 2.285714E4[°/s2]

Ab Nenndrehzahl (ngrenz) ergibt sich damit folgender Kennlinienverlauf

Parameter |
 | P-AXIS-00202 | Kennlinientyp: 1 (Hyperbel) oder 2 (Polynom)
 | P-AXIS-00130 | Grenzdrehzahl ngrenz
 | P-AXIS-00007 | Konstante Beschleunigung akonst für n<ngrenz
 | P-AXIS-00010 | Minimale Beschleunigung amin
 | P-AXIS-00026 | Koeffizient b1
 | P-AXIS-00027 | Koeffizient b2
 | P-AXIS-00028 | Koeffizient b3

Parametrierungs-beispiele | # beschl_kennlinie.typ 1 Hyperbelform beschl_kennlinie.a_min 1400 [ ° /s*s] beschl_kennlinie.n_grenz 12000000 [10-3 ° /s] beschl_kennlinie.a_konst 16000 [ ° /s*s] beschl_kennlinie.b1 2.285714E4 [°/s*s] beschl_kennlinie.b2 4.166666E-1 [] beschl_kennlinie.b3 -2.857142E-2 [] #
 | # beschl_kennlinie.typ 2 Polynomform beschl_kennlinie.a_min 2000 [ ° /s*s] beschl_kennlinie.n_grenz 12000000 [10-3 ° /s] beschl_kennlinie.a_konst 16000 [ ° /s*s] beschl_kennlinie.b1 -0.88888888 [1/s] beschl_kennlinie.b2 2.08333333E-5 [1/Grad beschl_kennlinie.b3 -1.92901234E-10 [s/Grad²] #


Methode 2: Kennlinie für asynchrone Antriebscharakteristik

Für Spindelantriebe werden häufig Asynchronmotoren verwendet. Über die im folgenden Bild dargestellte drehzahlabhängige Spindelbeschleunigung a= f(n) kann der Anwender eine optimalere Anpassung an die typische Charakteristik des Spindelmotors erreichen.

Abbildung 1-15: Verlauf der Beschleunigung bei asynchroner Antriebs-charakteristik

Neben der maximal zulässigen Beschleunigung a_max , Drehzahl N1 für den konstanten Beschleunigungsbereich ist lediglich eine weitere Drehzahl N2 und die obere Minimalbeschleunigung a_min zu parametrieren. Der Beschleunigungsverlauf ist bis zur Drehzahl N1 konstant. Oberhalb von N1 ist der Beschleunigungsverlauf proportional zu 1/n, oberhalb von N2 proportional zu 1/n2.

Beispiel Kennlinienverlauf

N1=10000 Grad/s

N2=20000 Grad/s,

a_max=16000Grad/s

Ab Nenndrehzahl (ngrenz) ergibt sich damit folgender Kennlinienverlauf

Parameter |
 | P-AXIS-00202 | Kennlinientyp 3: Asynchronantrieb
 | P-AXIS-00010 | Minimale Beschleunigung amin
 | P-AXIS-00240 | Maximale Beschleunigung amax für n<N1
 | P-AXIS-00241 | Drehzahlgrenze N1 für maximales Moment
 | P-AXIS-00242 | Drehzahlgrenze N2 für maximale Leistung

Parametrierungs-beispiel

getriebe[0].beschl_kennlinie.typ 3 Asynchronantrieb

getriebe[0].beschl_kennlinie.a_max 16000 [°/s²]

getriebe[0].beschl_kennlinie.a_min 4000 [ ° /s*s]

getriebe[0].beschl_kennlinie.n1 10000000 [10-3 °/s]

getriebe[0].beschl_kennlinie.n2 20000000 [10-3 °/s]


Werkzeugbezogene Dynamikbegrenzung für Spindeln

Das dynamische Verhalten der Spindel kann abhängig vom Eintrag in den Werkzeugdaten durch Werkzeugwechsel verändert werden. Dadurch kann das Verhalten der Spindel auf die zulässigen dynamischen Belastungen des Werkzeugs angepasst werden.

Das Werkzeug wird in den Werkzeugdaten [TOOL] über die logische Achsnummer einer Spindel zugeordnet.

Die Werkzeugdynamikdaten werden nach der Programmierung eines neuen Werkzeuges (D-Wort, #TOOL DATA) automatisch beim Übergang der Spindel vom Stillstand in die Interpolation wirksam.

Nach Abwahl des Werkzeugs bleiben die dynamischen Kenngrößen des zuletzt angewählten Werkzeugs gültig.

Parameter |
 | P-TOOL-00012 | logische Achsnummer Spindelachse
 | P-TOOL-00013 | minimale Drehzahl
 | P-TOOL-00014 | maximale Drehzahl
 | P-TOOL-00015 | maximale Beschleunigung

Beispiel:

wz[i].log_ax_nr_spdl 6

wz[i].vb_min 60000 [10-3 °/s]

wz[i].vb_max 3000000 [10-3 °/s]

wz[i].a_max 3000 [°/s2]

Programmierung

D-Wort oder

#TOOL DATA

Die Übernahme neuer dynamischer Kenngrößen kann durch Eintragen der logischen Achsnummer 0 deaktiviert werden.


Gewindebohren ohne Ausgleichsfutter

Programmierung

Bei dieser Art des Gewindebohrens (G63) wird die Spindel durch die CNC synchron zur Bahnbewegung mitgeführt. Hierbei erfolgt eine genaue dynamische Abstimmung von Spindel und der an der Zustellbewegung beteiligten Achsen. Ein Ausgleichsfutter ist somit nicht erforderlich. Der programmierte Vorschub muß zur gewählten Spindeldrehzahl und zur Gewindesteigung des Bohrers passen und wird wie folgt berechnet:

Vorschub F [mm/min] = Drehzahl S [U/min] * Gewindesteigung [mm/U]

Die Spindel muß beim Aufruf von G63 stehen.

Das Schneiden eines Linksgewindes oder das Herausfahren aus einer Gewindebohrung wird mit negativem S-Wert programmiert.

G63 wird durch die Anwahl einer anderen Interpolationsart (z.B. G00, G01, G02, G03) abgewählt.

G63 F.. S.. Z..

Beispiel:

Es wird ein Gewinde mit einer Steigung von 1.25 mm und einer Tiefe von 50 mm gebohrt. Bei einer Spindeldrehzahl S von 200 U/min ergibt sich somit ein Vorschub von:

F = 200*1.25 = 250 mm/min

G63 Z-50 F250 S200 Gewinde bohren

Z50 S-200 Aus Gewindebohrung herausfahren

G01 F100 X100 ... Abwahl Gewindebohren, Linearinterpolation


Gewindeschneiden mit endlos drehender Spindel

Ein-/mehrgängige Gewinde

Beim Gewindeschneiden mit endlos drehender Spindel (G33) wird die Bahnbewegung auf den Nulldurchgang der Spindeldrehung synchronisiert. Der Gewindeschnitt kann deshalb auch in mehreren, aufeinanderfolgenden Durchgängen erfolgen. Durch optionale Angabe eines Versatzwinkels können auch mehrgängige Gewinde gefertigt werden.

Für das Erzielen eines guten Bearbeitungsergebnisses und zur minimierung von Konturfehlern kann für die Spindel sowie für die Bahnachsen eine Vorsteuerung angewählt werden.

Programmierung

G33 Z.. K.. [S.OFFSET..]

Abbildung 1-16: Darstellung der Beispielgeometrie

Schneiden eines Längsgewindes (M70x1.5) in mehreren Schnitten:

%L Laengsgewinde

N100 G33 Z48 K1.5 Gewindegang schneiden

N110 G00 X72 Rückzug und Fahren

N120 Z105 auf Startposition

N130 M29 Unterprogrammende

%G33 (Gewindetiefe 0.92 mm)

N10 G51 Anwahl Durchmesserprogrammierung

N15 T1 D1 M03 S400 Werkzeuganwahl, Spindel starten

N20 G00 X72 Z105 Anfahren

N25 G01 X69.54 F1000 Auf 1. Schnittiefe positionieren

N30 LL Laengsgewinde 1. Gewindeschnitt

N35 G01 X69.08 Auf 2. Schnittiefe positionieren

N30 LL Laengsgewinde 2. Gewindeschnitt

N35 G01 X68.62 Auf 3. Schnittiefe positionieren

N30 LL Laengsgewinde 3. Gewindeschnitt

N35 G01 X68.16 Auf Endtiefe positionieren

N30 LL Laengsgewinde 4. Gewindeschnitt

N35 G01 X68.16 Erneut auf Endtiefe positionieren

N30 LL Laengsgewinde Leerschnitt

N60 M05 X150 Z200 Fahren auf Endposition

N65 M30 Programmende

Schneiden eines 2-gängigen Längsgewindes (M70x1.5)

%G33_2 (2 Gewindegaenge, Gewindetiefe 0.92 mm)

N10 G51 Anwahl Durchmesserprogrammierung

N15 T1 D1 M03 S400 Werkzeuganwahl, Spindel starten

N20 G00 X72 Z105 Anfahren

N25 G01 X68.16 F1000 Auf Gewindetiefe positionieren

N30 G33 Z48 K1.5 1. Gewindegang schneiden

N35 G00 X72 Rückzug und Fahren

N40 Z105 auf nächste

N45 G01 X68.16 Startposition

N50 G33 Z48 K1.5 S.OFFSET=180 2. Gewindegang schneiden bei 180°

N55 G00 X72 Rückzug und Fahren

N60 M05 X150 Z200 auf Endposition

N65 M30 Programmende


C-Achsbearbeitung (Stirn- und Mantelflächenbearbeitung)

Diese Funktionalität ermöglicht die Stirn- und Mantelflächenbearbeitung von zylindrischen Werkstücken an Maschinen mit einer rotatorischen Achse für die Werkstückaufnahme (z.B. Drehmaschinen oder Fräsmaschinen mit Drehteller). Dabei wird das Werkstück von der rotatorischen Achse oder Spindel (C-Achse) und das angetriebene Werkzeug (z.B. ein Fräser) von den beiden translatorischen Achsen X (oder Y) und Z bewegt. Die Art der für die Stirnflächenbearbeitung verwendeten Maschine wird über den Maschinenparameter P-CHAN-00008 bestimmt. Die Achse muß über den Achsparameter P-AXIS-00015 als Achse für die kinematische C-Achs-Transformation markiert sein.

Die Stirnflächenbearbeitung und die Mantelflächenbearbeitung werden in kartesischen Koordinaten beschrieben.

Spindel als Kanalachse | Die Hauptspindel wird in eine rotatorische Bahnachse (z.B. "C") überführt.
Programmierung | #CAX [...] #CAX OFF
Stirnflächen-bearbeitung | #FACE[...] #FACE OFF
Mantelflächen-bearbeitung | #CYL #CYL OFF

Parameter |
 | P-CHAN-00008 | Die Art der für die Stirnflächenbearbeitung verwendeten Maschine
 | P-AXIS-00015 | Achsmodus für kinematische C-Achs-Transformation

Abbildung 1-17: Stirn- und Mantelflächenbearbeitung


Drehfunktionen

Eine nähere Beschreibung der Drehfunktionen ist der Programmieranleitung [PROG] zu entnehmen

Schneidenradius-korrektur | Die Schneidenradiuskorrektur wirkt in der mit G17, G18, G19 angewählten Bearbeitungsebene. In dieser Ebene muss eine der Achsen im Modus "Plandrehen", die andere im Modus "Längsdrehen" betrieben werden (P-AXIS-00015 (achs_mode)).
Programmierung | G40/G41/G42

Umdrehungs-vorschub | Beim Drehen mit Umdrehungsvorschub lässt sich über das F-Wort in mm/U unabhängig von der Spindeldrehzahl eine konstante Spandicke festlegen. Der Vorschub der Bahnachsen wird dabei an die Drehzahl der NC-Spindel gekoppelt.
Programmierung | G95

Konstante Schnitt-geschwindigkeit | Um bei der Drehbearbeitung eine konstante Relativgeschwindigkeit zwischen Werkstück und Drehwerkzeug bei allen Bearbeitungsdurchmessern zu erreichen, wird die Spindeldrehzahl an den Abstand der Zustellachse zur Drehmitte gekoppelt.
Programmierung | G96, G97, G196


HLI Schnittstellenobjekte (NCK-PLC Schnittstelle)

Die Beschreibung der an der PLC Schnittstelle verfügbaren spindelspezifischen Daten ist der separaten Dokumentation HLI-Schnittstelle [HLI] zu entnehmen.

Übersicht

Drehzahlen

Solldrehzahl

Ist-Drehzahl

Drehzahl programmiert

Positionen

Zielposition

Ist-Position

Statusinformationen

Betriebszustand

Drehzahlüberwachung aktiv

Solldrehzahl erreicht

Spindel steht

Drehzahlüberwachung ungültig

Restfahrweg

Auftragsfehler

Steuerkommandos

Spindelstopp bei Programmende

Spindel-Reset

Externe Spindelbeauftragung

Über die externe Schnittstelle kann alles beauftragt werden, was auch über den Kanal beauftragt werden kann.


HMI Schnittstellenobjekte

Die Beschreibung der spindelspezifischen HMI-Objekte ist der separaten Dokumentation HMI-Schnittstelle [HMI] zu entnehmen.


Parameter

Mehr:

button Übersicht

button Beschreibung


Übersicht

Konstante | Beschreibung
SLOPE_VB_MAX | Maximal parametrierbare Achsgeschwindigkeit
ACHS_NAME_LAENGE | Maximale Länge der Achsbezeichnung

ID | Parameter | Beschreibung
P-CHAN-00004 | autom_range | Automatischer Getriebestufenwechsel
P-CHAN-00007 | bezeichnung | Spindelbezeichnung
P-CHAN-00008 | cax_face_id | Variante der Stirnflächenbearbeitung (Drehen/Fräsen)
P-CHAN-00010 | default_ax_name_of_spindle | Name der Spindel als Kanalachse
P-CHAN-00036 | log_achs_nr | Spindel-Achsnummer
P-CHAN-00037 | log_achs_nr_master | Masterachse
P-CHAN-00038 | log_achs_nr_slave | Slaveachse
P-CHAN-00043 | m19_synch | Synchronisationsart der M19-Funktion
P-CHAN-00045 | m3_synch | Synchronisationsart der M03-Funktion
P-CHAN-00047 | m4_synch | Synchronisationsart der M04-Funktion
P-CHAN-00049 | m5_synch | Synchronisationsart der M05-Funktion
P-CHAN-00051 | main_spindle_ax_nr | Definition der Hauptspindel
P-CHAN-00052 | main_spindle_gear_change | Freigabe für Getriebeschalten
P-CHAN-00053 | main_spindle_name | Hauptspindelbezeichnung
P-CHAN-00055 | max_speed | Drehzahlbereichsgrenzen
P-CHAN-00058 | min_speed | Drehzahlbereichsgrenzen
P-CHAN-00061 | mode | Koppelmodus
P-CHAN-00069 | plc_control | PLC-gesteuerte Spindel über Kanalschnittstelle
P-CHAN-00074 | range_way | Suchrichtung in der Drehzahlbereichstabelle
P-CHAN-00081 | s_synch | Synchronisationsart der S-Funktion
P-CHAN-00082 | spdl_anzahl | Spindelanzahl im Kanal

ID | Parameter | Beschreibung
P-AXIS-00007 | a_konst | konstante Beschleunigung
P-AXIS-00010 | a_min | Beschleunigung Minimum
P-AXIS-00015 | achs_mode | Achsmode
P-AXIS-00016 | achs_nr | Achsnummer
P-AXIS-00018 | achs_typ | Achstyp
P-AXIS-00020 | antr_typ | Antriebstyp
P-AXIS-00026 | b1 | Koeffizient
P-AXIS-00027 | b2 | Koeffizient
P-AXIS-00028 | b3 | Koeffizient
P-AXIS-00031 | beweg_richt | Drehrichtung für rotatorische Achsen
P-AXIS-00041 | n1 | Drehzahlgrenze 1 für maximales Moment
P-AXIS-00078 | getr_schalt_pos | Getriebestufenwechselposition
P-AXIS-00079 | getriebe_stufe | Nummer der Defaultgetriebestufe
P-AXIS-00099 | kv | Proportionalfaktor kv für P-Lageregelung
P-AXIS-00120 | mod_komp | Aktivierung der Modulokompensation
P-AXIS-00124 | modulo_fehler | Modulofehler-Kompensation
P-AXIS-00125 | modulo_umdreh | Anzahl Umdrehungen
P-AXIS-00126 | moduloo | Obergrenze Modulobereich
P-AXIS-00127 | modulou | Untergrenze Modulobereich
P-AXIS-00128 | multi_gain_n | Anpassung der Antriebsstellgröße an den D/A-Konverter
P-AXIS-00129 | multi_gain_z | Anpassung der Antriebsstellgröße an den D/A-Konverter
P-AXIS-00130 | n_grenz | Grenzdrehzahl
P-AXIS-00156 | ref_ohne_nocken | Referenzieren ohne Nocken
P-AXIS-00157 | ref_ohne_rev | Referenzieren ohne Revertieren
P-AXIS-00159 | reverse | Vorzeichenumkehr Soll/Ist im Lageregler bei+/- 10 V
P-AXIS-00202 | typ | Kennlinientyp
P-AXIS-00205 | v_reso_denom | Geschwindigkeitsskalierung Nenner
P-AXIS-00206 | v_reso_nom | Geschwindigkeitsskalierung Zähler
P-AXIS-00207 | v_time_base | Zeitbasis Geschwindigkeitsskalierung
P-AXIS-00209 | vb_eilgang | Eilganggeschwindigkeit
P-AXIS-00216 | vb_min_null | Grenze für Drehzahl == 0 bei Drehzahlüberwachung
P-AXIS-00217 | vb_prozent | Faktor für Spindeldrehzahl erreicht
P-AXIS-00220 | vb_regelgrenze | Geschw. für Regelgrenze
P-AXIS-00224 | vorz_richtung | Einschränkung der Drehrichtung für rotatorische Achsen
P-AXIS-00233 | wegaufn | Wegauflösung des Meßsystems
P-AXIS-00234 | wegaufz | Wegauflösung des Meßsystems
P-AXIS-00240 | a_max | Maximale Spindelbeschleunigung
P-AXIS-00242 | n2 | Drehzahlgrenze 2 für maximale Leistung
P-AXIS-00265 | velocity_position_control_on | Umschaltgeschwindigkeit
P-AXIS-00266 | velocity_position_control_off | Rückschaltgeschwindigkeit

ID | Parameter | Beschreibung
P-TOOL-00012 | log_ax_nr_spdl | Logische Achsnummer der Spindel
P-TOOL-00013 | vb_min | Minimale Drehzahl
P-TOOL-00014 | vb_max | Maximale Drehzahl
P-TOOL-00015 | a_max | Maximale Beschleunigung


Beschreibung

Mehr:

button Kanalparameter

button Achsparameter

button Werkzeugparameter


Kanalparameter

Übersicht

In diesem Kapitel werden die kanalspezifischen Parameter zur Konfiguration von Spindeln beschrieben. Es ist zu beachten, dass nur die Spindeln, die in der Kanalparameterliste eingetragen sind, im Teileprogramm auch angesprochen werden können. Dies gilt sowohl für NC- als auch für PLC-Spindeln.

Die im Kanalparametersatz definierte Spindelkonfiguration ist die Defaultbelegung, die nach dem Hochlauf der Steuerung zur Verfügung steht.

P-CHAN-00082 | Spindelanzahl im Kanal
Parameter | spdl_anzahl
Beschreibung | Mit diesem Parameter wird die Gesamtzahl der im Kanal vorhandenen Spindeln vorgegeben.
Datentyp | UNS16
Datenbereich | 0 ≤ P-CHAN-00082 ≤ MAX(UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00010 | Name der Spindel als Kanalachse im Bahnverbund
Parameter | default_ax_name_of_spindle
Beschreibung | Wird eine Spindelachse als Kanalachse betrieben (z.B. C-Achs Bearbeitung), so kann sie über diese Defaultbezeichnung (z.B.C1) im NC-Programm angesprochen werden.
Datentyp | STRING
Datenbereich | 1 ≤ Stringlaenge ≤ ACHS_NAME_LAENGE
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00051

Definition der Hauptspindel

Parameter

main_spindle_ax_nr

Beschreibung

Zur Programmierung in der Standardsyntax ist es notwendig, eine Spindel als s.g. Hauptspindel zu deklarieren. Diese Hauptspindel kann zusammen mit bestimmten Standardfunktionali-täten (z.B. Gewindebohren, Getriebeschalten etc.) in der herkömmlichen DIN-Syntax programmiert werden. Auch wenn nur eine Spindel im System vorhanden ist, muß diese als Hauptspindel konfiguriert werden.

Die Definition der Hauptspindel erfolgt über den Parameter "main_spindle_ax_nr". Hier wird die logische Achsnummer einer der Spindeln eingetragen, die in der Kanalparameterliste konfiguriert sind. Diese Spindel ist nach dem Hochlauf der Steuerung die Hauptspindel.

Datentyp

UNS16

Datenbereich

1 ≤ P-CHAN-00051 ≤ MAX (UNS16)

Dimension

translatorisch: -

rotatorisch: -

Standardwert

-

Anmerkungen

Durch einen Befehl im Teileprogramm (#MAIN SPINDLE) kann jede andere Spindel im System nach dem Hochlauf zur Hauptspindel gemacht werden.

P-CHAN-00053 | Bezeichnung der Hauptspindel
Parameter | main_spindle_name
Beschreibung | Neben der logischen Achsnummer muss der Hauptspindel ein Name zugeordnet werden mit dem sie im Teileprogramm angesprochen werden kann. Dazu wird der Hauptspindel über den Parameter main_spindle_name eine Achsbezeichnung zugeordnet. Diese Achsbezeichnung ist frei wählbar, sie muss jedoch immer mit dem Buchstaben S beginnen.
Datentyp | STRING
Datenbereich | 1 ≤ Stringlaenge ≤ ACHS_NAME_LAENGE
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Die Bezeichnung der Hauptspindel kann im Teileprogramm nicht geändert werden. Jedoch gilt dieser Name bei Anwahl einer anderen Hauptspindel (#MAIN SPINDLE) auch für die neue Hauptspindel.

P-CHAN-0008 | Variante der Stirnflächenbearbeitung
Parameter | cax_face_id
Beschreibung | Parameter bestimmt die Art der für die Stirnflächenbearbeitung verwendeten Maschine.
Datentyp | UNS16
Datenbereich | 1: Drehmaschinen (180° Ausrichtung) 2: Fräsmaschinen (keine Ausrichtung)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00036 | Logische Achsnummer der Spindel
Parameter | spindel[i]. log_achs_nr
Beschreibung | Hier wird die logische Achsnummer der Spindel eingetragen. Die logische Achsnummer ist im gesamten System eindeutig. Über die logische Achsnummer erfolgt die Zuordnung der Spindelbezeichnung im NC-Programm zu den Achsdaten [AXIS]. Die logische Achsnummer "0" ist nicht erlaubt.
Datentyp | UNS16
Datenbereich | 1 ≤ P-CHAN-00037 ≤ MAX(UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Die logische Achsnummer darf nicht mehrfach zugeordnet werden. Die logische Achsnummer darf nicht gleichzeitig als Bahnachse und Spindelachse konfiguriert werden.

P-CHAN-00007 | Defaultbezeichnung einer Spindel
Parameter | spindel[i].bezeichnung
Beschreibung | Über diesen Parameter wird die Defaultbezeichnung definiert, mit der eine Spindel im NC-Programm programmiert werden kann. Hierbei ist zu beachten, dass eine Spindel, solange sie Hauptspindel ist, nur über den Hauptspindelnamen (P-CHAN-00053) programmiert werden kann. Die Defaultnamen sind in einem Kanal mit mehreren Spindeln für die "Neben"-Spindeln zu verwenden.
Datentyp | STRING
Datenbereich | 1 ≤ Stringlaenge ≤ ACHS_NAME_LAENGE
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Die Spindelbezeichnungen müssen mit den Buchstaben "S" beginnen. Danach sind alle Buchstaben und Ziffern möglich. Die Spindelbezeichnungen müssen eindeutig sein.

P-CHAN-00069 | PLC-gesteuerte Spindel über Kanalschnittstelle
Parameter | spindel[i].plc_control
Beschreibung | Eine gesteuerte Spindel (Open Loop) wird nicht durch einen Spindelinterpolator im NC-Kanal sondern direkt durch die PLC angesteuert. Hierbei ist zu beachten, daß dann sämtliche Synchronisationen nicht mehr (Spindel-) achsspezifisch sondern über den kanalspezifischen HLI-Bereich ausgegeben und behandelt werden. Die achsspezifische Syntax zur Programmierung der Spindelbefehle ist weiterhin erlaubt, jedoch ist diese dann auf die Angabe der Drehzahl und der M-Funktionen M3/M4/M5/M19 beschränkt.
Datentyp | BOOLEAN
Datenbereich | 0: Eine gesteuerte Spindel wird durch einen Spindelinterpolator im NC-Kanal angesteuert. 1: Eine gesteuerte Spindel wird direkt durch die PLC angesteuert.
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

Synchronisations-festlegungen

P-CHAN-00081 | Synchronisationsart der S-Funktion
Parameter | spindel[i].s_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der S-Funktion definiert
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00045 | Synchronisationsart für M03
Parameter | spindel[i].m3_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der M03-Funktion definiert.
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00047 | Synchronisationsart für M04
Parameter | spindel[i].m4_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der M04-Funktion definiert.
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00049 | Synchronisationsart für M05
Parameter | spindel[i].m5_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der M05-Funktion definiert.
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00043 | Synchronisationsart für M19
Parameter | spindel[i].m19_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der M19-Funktion definiert.
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

Getriebeschalten

P-CHAN-00052 | Freigabe Getriebeschalten für Hauptspindel
Parameter | main_spindle_gear_change
Beschreibung | Mit dem Flag "main_spindle_gear_change" wird für die Hauptspindel das Getriebeschalten freigeschaltet oder gesperrt.
Datentyp | BOOLEAN
Datenbereich | 0: Spindelgetriebeschalten für die Hauptspindel deaktiviert 1: Spindelgetriebeschalten für die Hauptspindel aktiviert
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | Die M-Funktionen zur Auswahl der Getriebestufen der Hauptspindel M40  45 werden durch den Parameter P-CHAN-00052 in der Kanalparameterliste aktiviert. Bei deaktiviertem Getriebeschalten können die M-Funktionen M40  45 frei verwendet werden.

P-CHAN-00074 | Spindelgetriebeschalten ; Suchrichtung in der Drehzahlbereichstabelle
Parameter | spindel[i].range_way
Beschreibung | Diese Variable bestimmt, ob bei sich überlappenden Drehzahlstufen die niedrigere oder die höhere Getriebestufe angewählt wird. Wenn "range_way = 0" gesetzt ist, startet die Suche von der niedrigsten Drehzahlstufe aus; wenn "range_way" > 0 von der obersten. Die richtige Drehzahl-(Getriebe)stufe ist diejenige, in der die programmierte Drehzahl zuerst gefunden wird.
Datentyp | UNS16
Datenbereich | 0 < P-CHAN-00074< MAX(UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | Das Getriebeschalten ist nur für die Hauptspindel möglich. Die Funktion muss mit P-CHAN-00052 freigeschaltet sein.

P-CHAN-00004

Spindelgetriebeschalten; Automatischer Getriebestufenwechsel

Parameter

spindel[i].autom_range

Beschreibung

Dieser Parameter legt fest, ob die Spindelgetriebestufe beim Auswerten des S-Wortes von der Steuerung automatisch bestimmt werden soll, oder ob bei der Programmierung des S-Wortes die entsprechende Getriebestufe durch M40 - M45 mit programmiert werden muss.

Datentyp

BOOLEAN

Datenbereich

0: Passende Getriebestufe muss bei der Programmierung des S-Wortes durch M40 - M45 mit programmiert werden.

1: Passende Getriebestufe wird implizit bei der Auswertung der Drehzahl (S-Wort) von der Steuerung bestimmt. Die M-Funktionen M40 bis M45 müssen nicht programmiert werden.

Dimension

translatorisch: -

rotatorisch: -

Standardwert

0

Anmerkungen

Das Getriebeschalten ist nur für die Hauptspindel möglich.
Die Funktion muss mit P-CHAN-00052 freigeschaltet sein.

P-CHAN-00058
P-CHAN-00055

Spindelgetriebeschalten; Drehzahlbereichsgrenzen in der Tabelle der Drehzahlstufen

Parameter

spindel[i]. range_table[j].min_speed
spindel[i].range_table[j].max_speed

Beschreibung

Die Steuerung ermöglicht die Definition von maximal 6 Drehzahlstufen (M40...M45) pro Spindel. Für jede Stufe wird eine minimale (P-CHAN-00058) und eine maximale (P-CHAN-00055) Drehzahl definiert (Einheit U/min).

Die Drehzahlstufen einer Spindel können mit oder ohne Überlappung definiert werden. Wird eine Stufe nicht genutzt, sind die entsprechenden Werte in der Tabelle mit Null zu belegen.

Datentyp

UNS16

Datenbereich

0 < P-CHAN-00058 < MAX(UNS16)
0 < P-CHAN-00055 < MAX(UNS16)

Dimension

U/min

Standardwert

-

Anmerkungen

Das Getriebeschalten ist nur für die Hauptspindel möglich.
Die Funktion muss mit P-CHAN-00052 freigeschaltet sein.

Synchronbetrieb

P-CHAN-00038 | Spindelsynchronbetrieb; Logische Achsnummer der Slaveachse
Parameter | synchro_data.koppel_gruppe[i].paar[j].log_achs_nr_slave
Beschreibung | Logische Achsnummer der Spindel, die in einem Achskoppelpaar die Slaveachse ist. Der Synchronbetrieb ist nur für die im Kanal bekannten Spindelachsen möglich.
Datentyp | UNS16
Datenbereich | 1 ≤ P-CHAN-00038 ≤ MAX(UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Eine Kombination von Bahn- und Spindelachsen innerhalb eines Koppelpaares ist nicht erlaubt.

P-CHAN-00037 | Spindelsynchronbetrieb; Logische Achsnummer der Masterachse
Parameter | synchro_data.koppel_gruppe[i].paar[j].log_achs_nr_master
Beschreibung | Logische Achsnummer der Spindel, die in einem Achskoppelpaar die Masterachse ist. Der Synchronbetrieb ist nur für die im Kanal bekannten Spindelachsen möglich.
Datentyp | UNS16
Datenbereich | 1 ≤ P-CHAN-00037 ≤ MAX(UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Eine Kombination von Bahn- und Spindelachsen innerhalb eines Koppelpaares ist nicht erlaubt.

P-CHAN-00061 | Spindelsynchronbetrieb; Modus des Achskoppelpaares
Parameter | synchro_data.koppel_gruppe[i].paar[j].mode
Beschreibung | Da neben dem Synchronbetrieb von Bahnachsen auch Spindelachsen gekoppelt werden können, muss für jedes Paar die Art der Kopplung angegeben werden.
Datentyp | UNS16
Datenbereich | 0: Koppelpaar besteht aus Bahnachsen 1: Koppelpaar besteht aus Spindelachsen
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | Eine Kombination von Bahn- und Spindelachsen innerhalb eines Koppelpaares ist nicht erlaubt.


Achsparameter

Übersicht

Es werden hier nur die spezifischen Parameter für Spindelachsen beschrieben. Weitere, zur Einstellung von Achsen verfügbare Parameter sind der Dokumentation [AXIS] zu entnehmen.

P-AXIS-00015

Achs-Betriebsart

Parameter

kenngr.achs_mode

Beschreibung

Betriebsart der Achse, hier speziell einer Spindel

Datentyp

UNS32

Datenbereich

1 ≤ P-AXIS-00015 ≤ 0x40000

0x00004: Es erfolgt stets eine Modulorechnung nach Erreichen der Zielposition. Unabhängig von der angewählten Betriebsart für rotatorische Achsen erfolgt im Lageregler stets eine Modulorechnung. Somit kann ggf. eine Modulokreiskompensation durchgeführt werden.

0x00100: Bei einer Spindel kann das automatische Referenzieren vor einem Spindel-Richten verhindert werden. Dies ist natürlich nur relevant, wenn die Achse nicht referenziert ist. Funktion ist antriebsabhängig.

0x00200: Achse für die kinematische "C-Achs"-Transformation

0x40000: Kennung für eine gesteuerte Spindel

Dimension

translatorisch: -

rotatorisch: -

Standardwert

-

Anmerkungen

Es sind nur die für die Spindel relevanten Achsbetriebsarten aufgeführt. Weitere Informationen sind der Dokumentation der Achsparameter [AXIS] zu entnehmen.

P-AXIS-00016 | Achsnummer
Parameter | kopf.achs_nr
Beschreibung | Zur Identifikation erhält jede Achse eine systemweit eindeutige logische Achsnummer.
Datentyp | UNS16
Datenbereich | 1 ≤ P-AXIS-00016 ≤ MAX(UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00018 | Achstyp
Parameter | kenngr.achs_typ
Beschreibung | Typ der Achse (Translator, Rotator, Spindel)
Datentyp | UNS16
Datenbereich | 1 ≤ P-AXIS-00018 ≤ 0x4 0x0001: Linearachse 0x0002: Rundachse 0x0004: Spindel
Dimension | translatorisch: - | rotatorisch: -
Standardwert | Für Spindeln ist immer der Achstyp 0x0004 zu wählen
Anmerkungen | -

P-AXIS-00020 | Antriebstyp
Parameter | kenngr.antr_typ
Beschreibung | Antriebstyp der Achse
Datentyp | UNS16
Datenbereich | 1 ≤ P-AXIS-00020 ≤ 0x20 0x0001: Konventionelle Antriebsschnittstelle 0x0002: Antriebsschnittstelle SERCOS 0x0004: Antriebssimulation 0x0010: Virtuelle Achse 0x0020: CAN-Bus
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00159 | Drehrichtung
Parameter | getriebe[i].reverse
Beschreibung | Dient zum Umdrehen der Vorzeichen der Ein- und Ausgangsdaten. Hierbei handelt es sich um eine Option, um geänderte Vorzeichen von Stellgröße und Istwerten beibehalten zu können.
Datentyp | BOOLEAN
Datenbereich | 0: Vorzeichen der Ein- und Ausgangsdaten werden nicht umgedreht. 1: Vorzeichen der Ein- und Ausgangsdaten werden umgedreht.
Dimension | translatorisch: - | rotatorisch: 0,001°/s
Standardwert | 0
Anmerkungen | -

P-AXIS-00234
P-AXIS-00233

Wegauflösung des Meßsystems

Parameter

getriebe[I].wegaufz
getriebe[i].wegaufn

Beschreibung

Die Wegauflösung des Meßsystems wird in der Dimension [Inkremente/0,1µm] für translatorische Achsen bzw. [Inkremente/0,0001 ° ] für rotatorische Achsen eingegeben. Die Anzahl der Inkremente ist in P-AXIS-00234 (Zähler), die Größe des Fahrwegs in [0,1µm] für translatorische Achsen bzw. in [0,0001 ° ] für rotatorische Achsen in P-AXIS-00233 (Nenner) einzutragen.

Datentyp

SGN32

Datenbereich

1 ≤ P-AXIS-00234 ≤ MAX(SGN32)
1 ≤ P-AXIS-00233 ≤ MAX(SGN32)

Dimension

translatorisch: siehe oben

rotatorisch: siehe oben

Standardwert

Anmerkungen

Diese Einträge werden beim Aktualisieren der Achsparameterliste nicht übernommen, zur Aktualisierung ist ein Neustart der Steuerung notwendig.

Wegen interner Formatwandlung muß die Wegauflösung des Meßsystems kleiner oder gleich eins eingestellt werden: P-AXIS-00234/P-AXIS-00233 ≤ 1.

P-AXIS-00129
P-AXIS-00128

Anpassung der Antriebsstellgröße an den D/A-Konverter

Parameter

getriebe[i].multi_gain_z
getriebe[i].multi_gain_n

Beschreibung

Der im Lageregler berechnete Geschwindigkeitssollwert muß an das D/A-Format des D/A-Konverters angepaßt werden. Es ist der Digitalwert am D/A-Konvertereingang (P-AXIS-00129/P-AXIS-00128) anzugeben, bei welchem die Achse mit der Geschwindigkeit von [1m/min] bzw. [1000°/min] verfährt.

Datentyp

UNS32

Datenbereich

1 ≤ P-AXIS-00129 ≤ MAX(UNS32)
1 ≤ P-AXIS-00128 ≤ MAX(UNS32)

Dimension

translatorisch: -

rotatorisch: -

Standardwert

-

Anmerkungen

-

P-AXIS-00099 | Proportionalfaktor kv für P-Lageregelung
Parameter | getriebe[i].kv
Beschreibung | Der P-Lageregler besitzt den Verstärkungsfaktor kv
Datentyp | UNS32
Datenbereich | 0 < P-AXIS-00099 ≤ MAX(UNS32)
Dimension | translatorisch: 0,01/s | rotatorisch: 0,01/s
Standardwert | -
Anmerkungen | -

Einstellungen für die Modulo-Rechnung

P-AXIS-00126 | Obere Modulo-Grenze
Parameter | getriebe[i].moduloo
Beschreibung | Für die Modulo-Rechnung bei rotatorischen Achsen ist eine obere Modulo-Grenze (z.B. 360°) einzugeben.
Datentyp | SGN32
Datenbereich | P-AXIS-00127 ≤ P-AXIS-00126 ≤ MAX(SGN32)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 360
Anmerkungen | Die Modulo-Rechnung wird für die Rundachsen und Spindeln (Achstypen 0x2 und 0x4) automatisch aktiviert.

P-AXIS-00127 | Untere Modulo-Grenze
Parameter | getriebe[i].modulou
Beschreibung | Für die Modulo-Rechnung bei rotatorischen Achsen ist eine untere Modulo-Grenze (z.B. 360°) einzugeben.
Datentyp | SGN32
Datenbereich | MIN(SGN32) ≤ P-AXIS-00127 ≤ P-AXIS-00126
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | Die Modulo-Rechnung wird für die Rundachsen und Spindeln (Achstypen 0x2 und 0x4) automatisch aktiviert

P-AXIS-00125 | Umdrehungen bei Modulofehler
Parameter | getriebe[i].modulo_umdreh
Beschreibung | Beim Betrieb einer rotatorischen Achse kann unter Umständen der Modulokreis der Führungsgrößen nicht fehlerfrei in den Modulokreis der Inkremente umgerechnet werden. Der Modulokreis der Inkremente ist um den Rundungsfehler kleiner. Dies wird mit der Modulokompensation so ausgeglichen, dass im Maschinendatum P-AXIS-00124 die fehlenden Inkremente pro Moduloumdrehung P-AXIS-00125 ganzzahlig vorgegeben werden können.
Datentyp | SGN16
Datenbereich | 0 ≤ P-AXIS-00125 ≤ MAX(SGN16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | Die Aktivierung dieser Funktion erfolgt über den Parameter P-AXIS-00120 .

P-AXIS-00124 | Modulofehler
Parameter | getriebe[i].modulo_fehler
Beschreibung | Angabe des Modulokreisfehlers bei P-AXIS-00125 Anzahl Umdrehungen.
Datentyp | SGN16
Datenbereich | MIN(SGN16) ≤ P-AXIS-00124 ≤ MAX(SGN16)
Dimension | translatorisch: Inkremente | rotatorisch: Inkremente
Standardwert | 0
Anmerkungen | Die Aktivierung dieser Funktion erfolgt über den Parameter P-AXIS-00120 .

P-AXIS-00120 | Modulokompensation
Parameter | getriebe[i].mod_komp
Beschreibung | Aktivierung der Modulokompensation
Datentyp | BOOLEAN
Datenbereich | 0: Modulokompensation im Lageregler deaktiviert 1: Modulokompensation im Lageregler aktiviert
Dimension | translatorisch: Inkremente | rotatorisch: Inkremente
Standardwert | 0
Anmerkungen |

Drehzahlen und
Geschwindigkeiten

P-AXIS-00220 | Grenzdrehzahl
Parameter | getriebe[i].vb_regelgrenze
Beschreibung | Bei Spindeln kann bei höherer Drehzahl die Grenze, ab welcher das Meßsystem fehlerhafte Signale liefert, überschritten werden. Die Grenzdrehzahl für den Lageistwertgeber gibt an, ab welcher Geschwindigkeit der Lageregler in den gesteuerten Betrieb umschalten muß.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00220 ≤ MAX(UNS32)
Dimension | translatorisch: µm/s | rotatorisch: 0,001°/s
Standardwert | 0
Anmerkungen | -

P-AXIS-00216 | Minimale Achsgeschwindigkeit
Parameter | getriebe[i].vb_min_null
Beschreibung | Nur speziell bei Spindeln liefert die Drehzahlüberwachung im Lageregler unterhalb der Grenze P-AXIS-000216 die Kennung "Drehzahl 0".
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00216 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: 0,001°/s
Standardwert | 0
Anmerkungen | -

P-AXIS-00217 | Drehzahlfaktor
Parameter | kenngr.vb_prozent
Beschreibung | Der Parameter definiert, ab welcher Ist-Drehzahl die Soll-Drehzahl als erreicht gilt.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00217 ≤ 1000
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 1000
Anmerkungen | -

P-AXIS-00209 | Eilganggeschwindigkeit
Parameter | getriebe[i].vb_eilgang
Beschreibung | Für die Positionierung im Eilgang (G00) wird die Eilgang-Geschwindigkeit vorgegeben.
Datentyp | UNS32
Datenbereich | 1 ≤ P--AXIS-00209 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: µm/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | -

Kennliniengeführte
Beschleunigung von Spindeln

Mit Hilfe der folgenden Parameter wird eine getriebestufenspezifische Beschleunigungskennlinie definiert. Die Funktionalität ist derzeit nur für Achsen vom Typ Spindel beim Endlosdrehen möglich.

P-AXIS-00202 | Typ der Beschleunigungskennlinie
Parameter | getriebe[i].beschl_kennlinie.typ
Beschreibung | -
Datentyp | UNS32
Datenbereich | 0: Konstante Beschleunigung 1: Hyperbel 2: Polynom 3: Asynchronantrieb
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00130 | Grenzdrehzahl der Beschleunigungskennlinie vom Typ 1 oder 2 (siehe P-AXIS-00202)
Parameter | getriebe[i].beschl_kennlinie. n_grenz
Beschreibung | Grenzdrehzahl, ab der die Beschleunigung in Polynom- oder Hyperbelform verläuft
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00130 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: 10-3 °/s
Standardwert | -
Anmerkungen | -

P-AXIS-00007 | Beschleunigung im konstanten Bereich der Beschleunigungskennlinie vom Typ 1 oder 2 (siehe P-AXIS-00202)
Parameter | getriebe[i].beschl_kennlinie.a_konst
Beschreibung | Konstante Beschleunigung im Bereich n<ngrenz
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00007 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: °/s²
Standardwert | -
Anmerkungen | -

P-AXIS-00010 | Minimale Beschleunigung der Beschleunigungskennlinie vom Typ 1 , 2 oder 3 (siehe P-AXIS-00202)
Parameter | getriebe[i].beschl_kennlinie.a_min
Beschreibung | Minimale Beschleunigung, die nicht unterschritten werden darf
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00010 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: °/s²
Standardwert | -
Anmerkungen | -

P-AXIS-00026 P-AXIS-00027 P-AXIS-00028 | Koeffizienten der Beschleunigungskennlinie zur Darstellung von Typ 1 oder 2 (siehe P-AXIS-00202 )
Parameter | getriebe[i].beschl_kennlinie.b1 getriebe[i].beschl_kennlinie.b2 getriebe[i].beschl_kennlinie.b3
Beschreibung | -
Datentyp | REAL64
Datenbereich | 0 ≤ P-AXIS-00026 ≤ MAX(REAL64)
Dimension | Typ 1: o/s2 Typ 2: 1/s
Datenbereich | 0 ≤ P-AXIS-00027 ≤ MAX(REAL64)
Dimension | Typ 1: - Typ 2: 1/o
Datenbereich | 0 ≤ P-AXIS-00028 ≤ MAX(REAL64)
Dimension | Typ 1: - Typ 2: s/o²
Standardwert | -
Anmerkungen | -

P-AXIS-00240 | Beschleunigungskennlinie Typ 3 (siehe P-AXIS-00202 ): Maximale Beschleunigung
Parameter | getriebe[i].beschl_kennlinie.a_max
Beschreibung | Diese Beschleunigungsgröße wird im konstanten Bereich n < N1 verwendet.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00240 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: °/s²
Standardwert | -
Anmerkungen | -

P-AXIS-00241 | Beschleunigungskennlinie Typ 3 (siehe P-AXIS-00202 ): Drehzahlgrenze 1
Parameter | getriebe[i].beschl_kennlinie.n1
Beschreibung | Ab dieser Drehzahl erfolgt der Übergang in die zu 1/n proportionale Kennliniencharakteristik.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00241 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: 10-3 °/s
Standardwert | -
Anmerkungen | -

P-AXIS-00242 | Beschleunigungskennlinie Typ 3 (siehe P-AXIS-00202 ): Drehzahlgrenze 2
Parameter | getriebe[i].beschl_kennlinie.n2
Beschreibung | Ab dieser Drehzahl erfolgt der Übergang in die zu 1/n2proportionale Kennliniencharakteristik.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00241 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: 10-3 °/s
Standardwert | -
Anmerkungen | -

Referenzieren

P-AXIS-00156 | Referenzieren: Referenzpunktfahrt ohne Nocken
Parameter | kenngr.ref_ohne_nocken
Beschreibung | Parameter bewirkt Umschaltung der Referenzpunktfahrtstrategie.
Datentyp | BOOLEAN
Datenbereich | 0: Referenzieren mit Nocken 1: Referenzieren ohne Nocken (z.B nur mit Nullimpuls), d.h. ohne Revertieren.
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Nur für analoge Spindeln zu belegen. Wenn P-AXIS-00156 mit 1 (TRUE) belegt ist, dann muss auch P-AXIS-00157 mit 1 (TRUE) belegt sein.

P-AXIS-00157 | Referenzieren: Referenzpunktfahrt ohne Revertieren
Parameter | kenngr.ref_ohne_rev
Beschreibung | Parameter beschränkt die Referenzpunktfahrt bzgl. revertieren.
Datentyp | BOOLEAN
Datenbereich | 0: Referenzpunktfahrt mit Revertieren 1: Referenzpunktfahrt ohne Revertieren
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Nur für analoge Spindeln zu belegen. P-AXIS-00157 muss mit 1 (TRUE) belegt sein, wenn P-AXIS-00156 mit 1 (TRUE) belegt ist,

Getriebeschalten

P-AXIS-00078 | Getriebeschaltposition
Parameter | getriebe[i].getr_schalt_pos
Beschreibung | Für jede Getriebestufe wird die Getriebeschaltposition angegeben.
Datentyp | SGN32
Datenbereich | P-AXIS-00177 (swe_neg) < P-AXIS-00078 < P-AXIS-00178 (swe_pos)
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | -
Anmerkungen | Die Definition dieses Parameters ist dann wesentlich, wenn mehrere Getriebestufen vorhanden sind.

P-AXIS-00079 | Nummer der Default-Getriebestufe
Parameter | getriebe[i].getriebe_stufe
Beschreibung | Der Parameter definiert die Getriebestufennummer, die nach dem Hochlauf der Steuerung aktiv sein soll.
Datentyp | UNS16
Datenbereich | 1 ≤ P-AXIS-00079 < MAX(UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

Drehrichtung
rotatorischer Achsen

P-AXIS-00224 | Einschränkung der Drehrichtung für rotatorische Achsen
Parameter | kenngr.vorz_richtung
Beschreibung | Parameter ist notwendig, wenn eine rotatorische Achse nur in einer Richtung betrieben werden darf.
Datentyp | BOOLEAN
Datenbereich | 0: Rotatorische Achse darf in beiden Richtungen betrieben werden. 1: Rotatorische Achse darf nur in einer Richtung betrieben werden.
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | -

P-AXIS-00031 | Festlegung der Drehrichtung für rotatorische Achsen
Parameter | kenngr.beweg_richt
Beschreibung | Ist bei rotatorischen Achsen nur eine Drehrichtung erlaubt, so wird mit P-AXIS-00031 die Drehrichtung definiert.
Datentyp | BOOLEAN
Datenbereich | 0: Negative Drehrichtung 1: Positive Drehrichtung
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | Positive Drehrichtung bedeutet, daß die Koordinatenwerte zunehmen. Negative Drehrichtung bedeutet, daß die Koordinatenwerte abnehmen. Dieser Parameter wird nur verwendet, wenn P-AXIS-00224 mit 1 (TRUE) belegt ist.

Geberlose Spindeln

P-AXIS-00205 | Nenner Geschwindigkeitsskalierung
Parameter | antr.v_reso_denom
Beschreibung | Nenner der Geschwindigkeitsskalierung.
Datentyp | UNS32
Datenbereich | 0 < v_reso_nom < MAX(UNS32)
Dimension | translatorisch: um | rotatorisch: 0,001°
Standardwert | 36
Anmerkungen |

P-AXIS-00206 | Zähler Geschwindigkeitsskalierung
Parameter | antr.v_reso_nom
Beschreibung | Zähler der Geschwindigkeitsskalierung.
Datentyp | UNS32
Datenbereich | 0 < v_reso_nom < MAX(UNS32)
Dimension | translatorisch: Inkremente | rotatorisch: Inkremente
Standardwert | 1
Anmerkungen |

P-AXIS-00207 | Zeitbasis Geschwindigkeitsskalierung
Parameter | antr.v_time_base
Beschreibung | Mit diesem Parameter wird die Zeitbasis für die Geschwindigkeitsskalierung eingestellt. Mögliche Werte sind: 0 : pro Minute 1 : pro Sekunde 2 : pro Abtastintervall
Datentyp | UNS16
Datenbereich | 0 .. 2
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0 (pro Minute)
Anmerkungen |

P-AXIS-00265 | Umschaltgeschwindigkeit
Parameter | antr.velocity_position_control_on
Beschreibung | Wird ein Drehzahl vorgegeben, welche höher als die Umschaltgeschwindigkeit ist, so wird auf Drehzahlregelung umgeschaltet.
Datentyp | SGN32
Datenbereich | 0 ≤ P-AXIS-00265 ≤ 1000000000
Dimension | translatorisch: | rotatorisch: [10-3 Grad/s]
Standardwert | 1000000000 (SLOPE_VB_MAX , Funktion deaktiviert)
Anmerkungen | Bei einer geberlosen Spindel ist nur eine Geschwindigkeit von 0 sinnvoll ! Hierdurch wird stets der Drehzahlsollwert des Interpolators ausgegeben und nicht der vom Lageregler berechnete Geschwindigkeitssollwert.

P-AXIS-00266 | Rückschaltgeschwindigkeit
Parameter | antr.velocity_position_control_off
Beschreibung | Falls die aktuelle Drehzahl bei einem Positioniervorgang mit M19 höher als die Rückschaltgeschwindigkeit ist, so wird zunächst auf diese abgebremst bevor die Positionsregelung eingeschaltet wird.
Datentyp | SGN32
Datenbereich | 0 ≤ P-AXIS-00266 ≤ 1000000000
Dimension | translatorisch: | rotatorisch: [10-3 Grad/s]
Standardwert | 0
Anmerkungen | Bei einer geberlosen Spindel ist nur eine Geschwindigkeit von 0 sinnvoll ! Hierdurch wird stets der Drehzahlsollwert des Interpolators ausgegeben und nicht der vom Lageregler berechnete Geschwindigkeitssollwert


Werkzeugparameter

Dynamikdaten

Je nach Applikation kann es erforderlich sein, für bestimmte Werkzeuge spezifische Dynamikdaten festzulegen. Diese werden in der Spindel während der Bearbeitung zur Begrenzung von Drehzahl und Beschleunigung verwendet. Damit die Dynamikdaten an die Spindel mit dem zugehörigen Werkzeug weitergeleitet werden können, ist die zusätzliche Angabe der logischen Achsnummer der Spindel erforderlich.

P-TOOL-00012 | Logische Spindelachsnummer
Parameter | wz[i].log_ax_nr_spdl
Beschreibung | Die Dynamikdaten des Werkzeuges sind über die logische Achsnummer der Spindel zugeordnet, die das Werkzeug nach dem Einwechseln tragen soll.
Datentyp | UNS16
Datenbereich | 0 ≤ P-TOOL-00012 ≤ MAX(UNS16)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | Wird die logische Achsnummer mit Null belegt, so werden beim Werkzeugwechsel keine Dynamikdaten an die Spindel weitergeleitet.

P-TOOL-00013
P-TOOL-00014

Minimale/Maximale Drehzahl

Parameter

wz[i].vb_min
wz[i].vb_max

Beschreibung

Zugehörige untere und obere Drehzahlgrenze des Werkzeuges.

Datentyp

UNS32

Datenbereich

0 ≤ P-TOOL-00013 ≤ MAX(UNS32)
0 ≤ P-TOOL-00014 ≤ MAX(UNS32)

Dimension

translatorisch: -

rotatorisch: 0,001°/s

Standardwert

-

Anmerkungen

Die Begrenzung auf die minimale Drehzahl P-TOOL-00013 erfolgt nur beim Endlosdrehen.

P-TOOL-00015 | Maximale Beschleunigung
Parameter | wz[i].a_max
Beschreibung | Zugehörige maximale Beschleunigung des Werkzeuges.
Datentyp | UNS32
Datenbereich | 0 ≤ P-TOOL-00015 ≤ MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: °/s2
Standardwert | 0
Anmerkungen | -