M- und H-Funktionen (C1)

1.1 EinleitungPAGEREF _Toc306972338 \h2

1.2 Beschreibung 3

1.2.1 Bereich der für den Anwender frei belegbaren M-/H- Nummern 6

1.2.2 Parametrierung der Synchronisationsarten 6

1.3 Programmierung am Beispiel M-Funktionen 7

1.3.1 Kanal- und achsspezifische M-Funktionen 7

1.3.1.1 Beispiel 1: Programmierung einer kanalspezifischen M-Funktion 7

1.3.1.2 Beispiel 2a: Programmierung einer achsspezifischen M-Funktion in erweiterter Syntax 7

1.3.1.3 Beispiel 2b: Programmierung einer achsspezifischen M-Funktion in DIN-Syntax 8

1.3.2 Spindel M-Funktionen 9

1.3.2.1 Beispiel 1a: CNC-Spindel, intern synchronisiert 10

1.3.2.2 Beispiel 1b: CNC-Spindel, intern und durch PLC synchronisiert 11

1.3.2.3 Beispiel 2a: PLC-Spindel 12

1.3.2.4 Beispiel 2b: PLC-Spindel mit Ausgabe der M-Funktionen über den Kanalbereich 13

1.3.3 Getriebestufenauswahl / Parametersatzumschaltung 14

1.3.4 Beispiele zu den Synchronisationsarten im Zusammenhang mit Bewegungen 26

1.3.5 Vorbelegte M-Funktionen 27

1.3.6 M/H-Funktionen mit Zusatzinformation 28

1.3.7 Fertigungszeitberechnung 29

1.3.8 CNC-Programmierung 31

1.3.9 Verfahren zum Anlegen einer M- oder H-Funktion in der Kanalparameterliste 32

1.3.10 Vorabausgabe von M-Funktionen (Mikrosteg) 35

1.3.10.1 Begrenzungen, Sonderfälle 40

1.3.11 Anwendungsbeispiele 45

1.3.12 HMI-Anzeige 45

1.4 Parameter 46

1.4.1 Übersicht 46

1.4.2 Beschreibung 53

1.4.2.1 Kanalparameter 53

Mehr:

button Einleitung

button Beschreibung

button Programmierung am Beispiel M-Funktionen

button Parameter


Einleitung

Maschinen-schaltfunktionen

Eigenschaften von M- und H-Funktionen

Die CNC-Befehle M und H dienen entsprechend DIN66025 zur Beauftragung von Maschinenschaltfunktionen und Hilfsfunktionen über die PLC. Ein Teil der M-Funktionen ist durch Normung festgelegt, während alle anderen und die H-Funktionen für den Anwender frei verfügbar sind.

Der zeitliche Verlauf der Ausgabe von M- und H-Funktionen an die PLC und die darauf folgende Reaktion durch die PLC kann auf unterschiedliche Art mit auszuführenden Bewegungen synchronisiert werden.

Zur Simulation der Bearbeitungszeit einer M- oder H-Funktion kann jeweils eine Zeitdauer angegeben werden, wodurch die Laufzeit eines CNC-Programms ermittelt werden kann.

M- und H- Funktionen werden von der PLC standardmäßig dem CNC-Kanal zugeordnet, in dem sie programmiert werden. Es besteht darüber hinaus die Möglichkeit, diese in einem achsspezifischen Bereich an die PLC auszugeben, was insbesondere bei Systemen mit mehreren CNC-Kanälen und gemeinsam von diesen verwendeten Achsen zu einer Vereinfachung bei der Realisierung von PLC Applikationen beitragen kann.

Synchronisationsart

Frei verfügbar oder vorbelegt nach DIN 66025

Bearbeitungszeit

Kanal- oder achsspezifische Ausgabe

Spindelspezifisch

Die CNC-Kanäle werden jeweils über eine Initialisierungsliste (Kanalparameterliste) parametriert. Hier sind alle M- und H-Funktionen anzugeben, wobei die Art der Synchronisation und optional statt der kanalspezifischen, eine achsspezifische Zuordnung festgelegt wird. An der Schnittstelle zur PLC (High Level Interface) [HLI] werden M-und H-Funktionen in den kanal- und achsspezifischen Bereichen ausgegeben und von der PLC entsprechend weiterverarbeitet und bestätigt.


Beschreibung

Ausgabe

Synchronisation

Die M- und H- Funktionen werden über ihre Synchronisationsart für jeden CNC-Kanal in der Kanalparameterliste freigeschaltet. Aus Sicherheitsgründen können M- und H- Funktionen ohne Angabe einer Synchronisationsart im CNC-Programm nicht verwendet werden (in diesem Fall erzeugt die CNC die Meldung 20157).

Für die Ausgabe zur PLC gibt es folgende Möglichkeiten:

q Keine Ausgabe

q Ausgabe vor Bewegung

q Ausgabe nach Ereignis

q Ausgabe nach Bewegung

Die Ausgabe kann in unterschiedliche Bereiche der Schnittstelle zur PLC (HLI) erfolgen:

§ Ausgabe im Kanalbereich

§ Ausgabe im Achsbereich

Zur Synchronisation mit einer auszuführenden Bewegung stehen folgende Möglichkeiten bereit:

q Keine Synchronisation

q Synchronisation vor der Bewegung,

q Synchronisation nach der Bewegung,

q Synchronisation beim Übergang in den nächsten Bewegungssatz mit Bearbeitungsvorschub (späte Synchronisation implizit).

q Synchronisation bei expliziter Anforderung (späte Synchronisation explizit).

q Synchronisation während eines Bewegungssatzes (Beispiel Kanten-stoßen)

Mehr:

button Bereich der für den Anwender frei belegbaren M-/H- Nummern

button Parametrierung der Synchronisationsarten


Bereich der für den Anwender frei belegbaren M-/H- Nummern

Für die M- bzw. H-Nummer ist der maximale Zahlenbereich von 0 bis 65535 vorgesehen. Der tatsächlich verfügbare Bereich ist versionsspezifisch eingeschränkt und der Dokumentation [SYSP] zu entnehmen. Dort ist auch die Einschränkung bezüglich der maximalen Anzahl von M- und H- Funktionen pro CNC-Satz sowie der maximalen Anzahl gleichzeitig aktiver Late - Synchronisationen pro Kanal und pro Achse aufgeführt.

Eine weitere Einschränkung ergibt sich durch die nach DIN66025 reservierten M-Funktionen (siehe Kapitel vorbelegte M-Funktionen)


Parametrierung der Synchronisationsarten

Synchronisationsart

In der Tabelle P-CHAN-00041 (m_synch) wird die Synchronisationsart der entsprechenden M-Funktion definiert. Dabei entspricht der Feldindex "MNr" der Nummer der M-Funktion. Der Wert gibt an, welche Synchronisationsart die M-Funktion besitzt, d.h. wann eine Ausgabe an die PLC und eine Überprüfung auf das Vorliegen der PLC-Quittierung erfolgt. Eine Bewegung wird nicht ausgeführt bzw. spätestens zum Satzende hin gestoppt, wenn keine Quittierung von der PLC eingetroffen ist.

Für H-Funktionen wird die entsprechende Tabelle P-CHAN-00027 (h_synch) verwendet.

Parameter

P-CHAN-00041 | Synchronisationsart der M-Funktion mit Nummer MNr
P-CHAN-00027 | Synchronisationsart der H-Funktion mit Nummer HNr

Die Synchronisationsart einer M/H-Funktion kann auch über das NC-Programm durch entsprechende Variablen (V.G.M_FCT[MNr].SYNCH oder V.G.H_FCT[HNr].SYNCH) verändert werden [PROG] .

Synchronisationsarten

Symbol | Wert | Bedeutung
NO_SYNCH | 0x00000000 | Keine Ausgabe der M/H-Funktion an die PLC
MOS | 0x00000001 | Ausgabe M/H-Funktion an PLC ohne Synchronisation
MVS_SVS | 0x00000002 | Ausgabe M/H-Funktion an PCL vor Bewegungssatz, Synchronisation vor Bewegungssatz
MVS_SNS | 0x00000004 | Ausgabe M/H-Funktion an PLC vor Bewegungssatz, Synchronisation nach Bewegungssatz
MNS_SNS | 0x00000008 | Ausgabe M/H-Funktion an PLC nach Bewegungssatz, Synchronisation nach Bewegungssatz
MNE_SNS | 0x00000020 | Ausgabe M/H-Funktion an PLC nach Ereignis (z.B. Mess-Interrupt), Synchronisation nach Bewegungssatz, (nur für Option Kantenstoßen)
Satzübergreifende Synchronisation ACHTUNG: Nur für M-Funktionen erlaubt!
MVS_SLM | 0x00004000 | Späte Synchronisation, Ausgabe M-Funktion am Satzbeginn. Synchronisation bei Übergang in Bewegungssatz mit Bearbeitungsvorschub (G01/G02/G03) (späte Synchronisation implizit, Sync. late movement)
MVS_SLP | 0x00008000 | Späte Synchronisation, Ausgabe M-Funktion am Satzbeginn. Synchronisation bei NC-Befehl #EXPL SYN (späte Syn-chronisation explizit, Sync. late program)
Vorgezogene Synchronisationsausgabe
MEP_SVS | 0x01000000 | Ausgabe M/H-Funktion an PLC bei angegebenem Weg, Synchronisation vor nächstem Satz
MET_S V S | 0x02000000 | Ausgabe M/H-Funktion an PLC bei angegebener Zeit, Synchronisation vor nächstem Satz
MOS_TS | 0x00040000 | ACHTUNG: Nur für M-Funktionen erlaubt! Ausgabe M-Funktion an die PCL vor Bewegungssatz ohne Synchronisation, Abtastzeitoffset als Parameter für hochgenaue zeitliche Ausgabe in PLC.

Ausgabe M bzw. H Synchronisation | Vor NC-SATZ | Nach NC-Satz | Nach Ereignis | Vorgezogen gemäß Weg-/Zeit-angabe | keine
Vor Bewegung | MVS_SVS |  |  | MEP_SVS, MEP_SVS |
Nach Bewegung | MVS_SNS | MNS_SNS | MNE_SNS |  |
Implizit bei nächstem Übergang zu G01/G02/G03 | MVS_SLM |  |  |  |
Programmierte Synchronisierung | MVS_SLP |  |  |  |
keine | MOS |  |  |  | NO_SYNCH
keine | MOS_TS |  |  |  |

Werden M- oder H-Funktionen ohne eine Bewegung im Satz programmiert, so ist das Verhalten für die Synchronisationsarten MVS_SVS, MVS_SNS, MNS_SNS identisch.

Beispiel

# ****************************************

# Festlegung der M-Funktionen und Synchronisationsarten

# ======================================================

m_synch[0] 0x00000002 MVS_SVS

m_synch[1] 0x00000001 MOS

m_synch[2] 0x00000002 MVS_SVS

m_synch[8] 0x00000008 MNS_SNS

m_synch[9] 0x00000000 NO_SYNCH

# Festlegung der H-Funktionen und Synchronisationsarten

# =====================================================

h_synch[0] 0x00000001 MOS

h_synch[1] 0x00000002 MVS_SVS

h_synch[2] 0x00000004 MVS_SNS

h_synch[3] 0x00000008 MNS_SNS

h_synch[4] 0x00000002 MVS_SVS

#


Programmierung am Beispiel M-Funktionen

Mehr:

button Kanal- und achsspezifische M-Funktionen

button Spindel M-Funktionen

button Getriebestufenauswahl / Parametersatzumschaltung

button Beispiele zu den Synchronisationsarten im Zusammenhang mit Bewegungen

button Vorbelegte M-Funktionen

button M/H-Funktionen mit Zusatzinformation

button Fertigungszeitberechnung

button CNC-Programmierung

button Verfahren zum Anlegen einer M- oder H-Funktion in der Kanalparameterliste

button Vorabausgabe von M-Funktionen (Mikrosteg)

button Anwendungsbeispiele

button HMI-Anzeige


Kanal- und achsspezifische M-Funktionen

Mehr:

button Beispiel 1: Programmierung einer kanalspezifischen M-Funktion

button Beispiel 2a: Programmierung einer achsspezifischen M-Funktion in erweiterter Syntax

button Beispiel 2b: Programmierung einer achsspezifischen M-Funktion in DIN-Syntax


Beispiel 1: Programmierung einer kanalspezifischen M-Funktion

Initialisierung in der Kanalparameterliste

m_synch[25] 0x0002

Programmierbeispiel


Beispiel 2a: Programmierung einer achsspezifischen M-Funktion in erweiterter Syntax

Initialisierung in der Kanalparameterliste

m_synch[25] 0x0002

Programmierbeispiel


Beispiel 2b: Programmierung einer achsspezifischen M-Funktion in DIN-Syntax

Kompatibilitätsmodus

Nach Einführung achsspezifischer M- und H- Funktionen wurde ein Kompatibilitätsmodus erforderlich, der es erlaubt, vorhandene CNC-Programme ohne Änderung der Syntax auch für die achsspezifische Ausgabe nutzen zu können.

Über die Kanal-Parameter

P-CHAN-00039 (m_default_outp_ax_name[MNr]) bzw.

P-CHAN-00025 (h_default_outp_ax_name[HNr])

kann die achsspezifische Ausgabe einer M- oder H-Funktion als Standard festgelegt werden. Eine kanalspezifische Ausgabe erfolgt dann nicht mehr.

Parameter

P-CHAN-00039 | Bezeichnung der Achse an die die M-Funktion mit Nummer MNr ausgegeben wird
P-CHAN-00025 | Bezeichnung der Achse an die die H-Funktion mit Nummer HNr ausgegeben wird

Initialisierung in der Kanalparameterliste

m_synch[25] 0x0002

m_default_outp_ax_name[25] X

Programmierbeispiel


Spindel M-Funktionen

Zur Steuerung von Spindeln sind in DIN66025 für Maschinen der Klasse 1 und 2 die M-Funktionen M3, 4, 5, 19 und M4045 reserviert worden. Diese M-Funktionen können mit einer auszuführenden Bahnbewegung synchronisiert werden. Die Synchronisation erfolgt bei M3, 4, 5 immer intern (Drehzahl erreicht) und optional zusätzlich durch die PLC (->PLC_INFO).

Die Verwendung der M-Funktionen M3, 4, 5, 19 auf Maschinen ohne Spindel kann mit dem Kanalparameter P-CHAN-00098 (spindle_m_fct_free) freigegeben werden.

Die M-Funktionen M4045 sind bei deaktiviertem Getriebeschalten (P-CHAN-00052 (main_spdl_gear_change)) ebenfalls frei verfügbar.

Darüber hinaus können alle frei verfügbaren M-Funktionen, gemäß der Beschreibung in 2.1.3.1.2 und 2.1.3.1.3 achsspezifisch an eine Spindel ausgegeben werden.

Spindeln werden durch einen Interpolator der CNC kontrolliert (CNC-Spindel) oder durch die PLC angesteuert (PLC-Spindel).

Zur Verwendung von Spindeln und zu den unterschiedlichen Spindeltypen siehe [FCT-S1].

Parameter

P-CHAN-00045 | Synchronisationsart der Spindelfunktion M3
P-CHAN-00047 | Synchronisationsart Spindelfunktion M4
P-CHAN-00049 | Synchronisationsart der Spindelfunktion M5
P-CHAN-00043 | Synchronisationsart Spindelfunktion M19
P-CHAN-00069 | Kennzeichnung einer PLC-Spindel mit Ausgabe von M-Funktionen über den Kanalbereich des HLI
P-CHAN-00098 | Freigabe von M3, 4, 5, 19 für beliebige Verwendung

Synchronisations-arten

Die Spindel M-Funktionen können mit den bekannten Synchronisationsarten NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP belegt werden.

PLC_INFO

Zusätzlich zu diesen bestehenden Synchronisationsarten kann das Bit PLC_INFO gesetzt werden. Es bestimmt, ob auch die PLC informiert werden soll. Dabei ist folgendes zu beachten:

Bei PLC-Spindeln wird generell bei jeder Spindel M-Funktion automatisch auch die PLC informiert. Es ist somit nicht erforderlich, das PLC_INFO-Bit zusätzlich zu setzen.

Sinnvoll ist die Verwendung des PLC_INFO-Bits bei NC-Spindeln. Hier kann für jede Spindel M-Funktion zusätzlich zur Synchronisationsart das Bit PLC_INFO gesetzt werden, wodurch dann eine Information an die PLC ausgegeben wird.

Mehr:

button Beispiel 1a: CNC-Spindel, intern synchronisiert

button Beispiel 1b: CNC-Spindel, intern und durch PLC synchronisiert

button Beispiel 2a: PLC-Spindel

button Beispiel 2b: PLC-Spindel mit Ausgabe der M-Funktionen über den Kanalbereich


Beispiel 1a: CNC-Spindel, intern synchronisiert

Initialisierung in der Achsparameterliste

kenngr.achtstyp 0x00000004 Spindel

Initialisierung in der Kanalparameterliste

spindel[0].m3_synch 0x00000002 MVS_SVS

spindel[0].m4_synch 0x00000004 MVS_SNS

spindel[0].m5_synch 0x00000004 MVS_SNS

spindel[0].m19_synch 0x00000004 MVS_SNS

Programmierbeispiel

Hauptspindel

Die Vorschubbewegung X100 wird gestartet, nachdem die Spindel die Ausführung des Kommandos M3 bestätigt hat. Die M-Funktion wird nicht an die PLC ausgegeben.

Programmierbeispiel

Das gleiche Beispiel in achsspezifischer Syntax für eine weitere Spindel

N10 S2[M3 REV1000] G01 F100 X100


Beispiel 1b: CNC-Spindel, intern und durch PLC synchronisiert

Um eine Ausgabe der M-Funktionen an die PLC zu erreichen, wird im Synchronisationsmode das Bit PLC_INFO gesetzt.

Die Spindel führt dabei immer sofort (asynchron) das entsprechende Kommando aus. Die Bahnbewegung wird jedoch entsprechend der Synchronisationsart zusätzlich mit der Quittung durch die PLC synchronisiert.

Initialisierung in der Achsparameterliste

kenngr.achtstyp 0x00000004 Spindel

Initialisierung in der Kanalparameterliste

spindel[0].m3_synch 0x00020002 MVS_SVS, PLC_INFO

spindel[0].m4_synch 0x00020004 MVS_SNS, PLC_INFO

spindel[0].m5_synch 0x00000004 MVS_SNS

spindel[0].m19_synch 0x00000004 MVS_SNS

Programmierbeispiel

Die Vorschubbewegung X100 wird gestartet, nachdem sowohl die Spindel als auch die PLC die Ausführung des Kommandos M3 bestätigt haben.


Beispiel 2a: PLC-Spindel

Für PLC-Spindeln erfolgt immer eine Ausgabe der M-Funktionen an die PLC. Das Bit PLC_INFO muss hier nicht gesetzt werden.

Zur Konfiguration einer PLC-Spindel, siehe [FCT-S1].

Initialisierung in der Achsparameterliste

kenngr.achtstyp 0x00000004 Spindel

achs_mode 0x00040000 Extern kontrollierte

Spindel

antr_typ 0x00000004 Simulation

Initialisierung in der Kanalparameterliste

spindel[0].m3_synch 0x00000002 MVS_SVS

spindel[0].m4_synch 0x00000004 MVS_SNS

spindel[0].m5_synch 0x00000004 MVS_SNS

spindel[0].m19_synch 0x00000004 MVS_SNS

Programmierbeispiel


Beispiel 2b: PLC-Spindel mit Ausgabe der M-Funktionen über den Kanalbereich

Eine PLC-Spindel kann auch über den kanalspezifischen Bereich des HLI mit M-Funktionen versorgt werden. Hierzu ist der Kanal-Parameter P-CHAN-00069 (plc_control) mit 1 zu belegen. Das Bit PLC_INFO muss für eine Ausgabe der M-Funktionen nicht gesetzt werden. Die Spindel wird hierbei nicht als CNC-Achse konfiguriert.

Initialisierung in der Kanalparameterliste

spindel[0].plc_control1

spindel[0].m4_synch 0x00000004 MVS_SNS

spindel[0].m5_synch 0x00000004 MVS_SNS

spindel[0].m19_synch 0x00000004 MVS_SNS

Programmierbeispiel


Getriebestufenauswahl / Parametersatzumschaltung

Die M-Funktionen zur Auswahl der Getriebestufen der Hauptspindel M4045 werden durch den Parameter P-CHAN-00052 (main_spindle_gear-_change) in der Kanalparameterliste aktiviert. Bei deaktiviertem Getriebeschalten können die M-Funktionen M4045 frei verwendet werden.

M-Funktion | Bedeutung
M40-45 | Getriebestufenauswahl für die Hauptspindel

Die M-Funktionen M4045 müssen bei aktiviertem Getriebeschalten P-CHAN-00052 (main_spindle_gear_change) über den Parameter P-CHAN-00041 (m_synch[..]) mit der Synchronisationsart MVS_SVS belegt werden!

Die Ausgabe erfolgt immer im spindelspezifischen Bereich, das Bit PLC_INFO wird hier nicht verwendet.

Möglich ist

q eine Ausgabe an andere Achsen durch achsspezifische Programmierung (z.B. X[M40]). Die Funktion Getriebeschalten wird dann nicht wirksam.

Nicht möglich ist

q eine Ausgabe an eine Spindel durch achsspezifische Programmierung

q eine Defaultausgabe an Achsen oder Spindeln (Kanalparameter)

Definition der M-Funktionen M40-M45 durch Festlegung der vorgeschrie-benen Synchronisationsart.

Initialisierung in der Kanalparameterliste

m_synch[40] 0x00000002 MVS_SVS

m_synch[41] 0x00000002 MVS_SVS

m_synch[42] 0x00000002 MVS_SVS

m_synch[43] 0x00000002 MVS_SVS

m_synch[44] 0x00000002 MVS_SVS

m_synch[45] 0x00000002 MVS_SVS

Aktivierung des Getriebeschaltens:

main_spindle_gear_change 1

Programmierbeispiel


Beispiele zu den Synchronisationsarten im Zusammenhang mit Bewegungen

In den folgenden Beispielen wird zu Vereinfachung die DIN-Syntax mit kanalspezifischer Ausgabe verwendet. Die Parametrierung erfolgt mit dem bekannten Parameter P-CHAN-00041 (m_synch[..]).

MVS_SVS

Freigabe der Bewegung erst nach Quittierung der M-Funktion durch die PLC

Initialisierung in der Kanalparameterliste

m_synch[..] 0x2

Programmierbeispiel

N20 G00 X25

N30 X50

N40 X75 M25 ( M25 vom Typ MVS_SVS )

N50 G01 X100 F2000

N60 X125 Z100

M30

Abbildung 1-1: Synchronisationsart MVS_SVS

Bei Bearbeitung des Satzes N40 wird M25 ausgegeben und vor Beginn der Bewegung in N40 auf die Quittierung der PLC gewartet.

MVS_SNS | Bearbeitung des nachfolgenden CNC-Satzes erst nach Quittierung der M-Funktion durch die PLC.
 | Initialisierung in der Kanalparameterliste m_synch[..] 0x4

Programmierbeispiel

N20 G00 G90 X25

N30 X50

N40 X75 M25 ( M25 vom Typ MVS_SNS )

N50 G01 X100 F2000

N60 X125 Z100

M30

Abbildung 1-2: Synchronisationsart MVS_SNS

Bei Bearbeitung des Satzes N40 wird M25 ausgegeben und die Bewegung fortgesetzt. Ist die Quittierung von M25 nicht rechtzeitig erfolgt, so wird am Ende von N40 angehalten.

MNS_SNS | Anhalten am Satzende bis zur Quittierung der M-Funktion durch die PLC.
 | Initialisierung in der Kanalparameterliste m_synch[..] 0x8

Programmierbeispiel

N20 G00 X25

N30 X50

N40 X75 M25 ( M25 vom Typ MNS_SNS )

N50 G01 X100 F2000

N60 X125 Z100

M30

Abbildung 1-3: Synchronisationsart MNS_SNS

Nach Bewegung in N40 wird in jedem Fall angehalten und nach Ausgabe von M25 auf die Quittierung durch die PLC gewartet.

MNE_SNS | Die Ausgabe der M-Funktion wird durch ein Ereignis ausgelöst. Bewegungsfreigabe über das Satzende hinaus erst nach Quittierung der M-Funktion durch die PLC.
 | Initialisierung in der Kanalparameterliste m_synch[..] 0x20

Programmierbeispiel

N05 X0 Y0

N10 G108 (Start Messen Kantenstoßen)

N20 G01 X90 Y90 F20

N30 G01 X150 Y150 M33 F8 ( M33 vom Typ MNE_SNS)

N40 G107 (Ende Messen Kantenstoßen)

N50 G00 X200 Y200

M30

Abbildung 1-4: Synchronisationsart MNE_SNS

Ein Messereignis in N30 führt zur Ausgabe von M33. Dann wird noch der durch das Messverfahren bestimmte Restweg zurückgelegt. Anschließend wird auf die Quittierung von M33 durch die PLC gewartet.

MVS_SLM | Satzübergreifende, implizite Synchronisation bei Übergang zum nächsten Vorschub-Bewegungssatz (G01, G02, G03). Bewegungsfreigabe über das Ende dieses Bewegungssatzes hinaus erst nach Quittierung der M-Funktion durch die PLC
 | Initialisierung in der Kanalparameterliste m_synch[..] 0x4000

Programmierbeispiel

N05 M24 (M24,Synchronisationstyp MVS_SLM)

N10 M25 G00 X25 (M25,Synchronisationstyp MVS_SLM)

N20 X50

N30 X75

N40 X100

N50 G01 X125 F2000 <--Triggerung von M24, M25 vor

Ausführung des Bewegungssatzes

N60 Z100

M30

Abbildung 1-5: Synchronisationsart MVS_SLM

Wird die MVS_SLM M-Funktion im Vorschubbewegungssatz programmiert, so erfolgt entsprechend MVS_SVS die Synchronisation vor Beginn dieser Bewegung.

Bsp. N10 G01 F100 M24

MVS_SLP | Programmierte Synchronisation (#EXPL_SYN)
 | Initialisierung in der Kanalparameterliste m_synch[..] 0x8000

Programmierbeispiel

N05 M26 G00 X25 (M26, Synchronisationstyp MVS_SLP)

N10 M27 (M27, Synchronisationstyp MVS_SLP)

N20 X50

N30 X75

N40 X100

N50 G01 X125 F2000

N60 #EXPL SYN Triggerung von M26, M27 vor

Ausführung des nächsten Satzes

N70 G00 X0

N80 X0 Y0

M30

Abbildung 1-6: Synchronisationsart MVS_SLP

Verhalten der
späten Synchronisation (MVS_SLM, MVS_SLP) bei
Programmende

Ist nach Programmierung einer MVS_SLM M-Funktion kein Vorschub Bewegungssatz, bzw. nach Programmierung einer M-Funktion mit Synchronisationsart MVS_SLP kein #EXPL SYN mehr im aktuellen CNC-Programm vorhanden, so bleibt die M-Funktion auch über das CNC-Programmende hinaus aktiv. Eine Synchronisation findet dann in einem folgenden CNC-Programm bei erreichen der Triggerbedingung statt.

Programmierbeispiel

%PRG1

N05 M26 G00 X25 (M26, Synchronisationstyp MVS_SLM)

N10 M27 (M27, Synchronisationstyp MVS_SLP)

M30 (M26, M27 am Programmende noch)
(aktiv)

%PRG2

N10 G01 F100 X10 <--Triggerung von M26 vor

Ausführung der Bewegung

N20 #EXPL SYN Triggerung von M27 vor

Ausführung des nächsten Satzes

M30

Sind beim Start eines CNC-Programms noch ausstehende M-Funktionen mit später Synchronisationsart aus dem vorangegangenen CNC-Pro-gramm vorhanden, so kann hier grundsätzlich eine Synchronisation erzwungen werden.

Hierzu ist der Kanalparameter P-CHAN-00033 (late_sync_ready) mit 1 zu belegen.

Initialisierung in der Kanalparameterliste

late_sync_ready 1

Programmierbeispiel

%PRG1

N05 M26 G00 X25 (M26, Synchronisationstyp MVS_SLM)

N10 M27 (M27, Synchronisationstyp MVS_SLP)

M30 (M26, M27 am Programmende noch aktiv)

%PRG2 <--Triggerung und warten auf Quittierung von

M26, M27 vor Start des Programms

N10 G01 F100 X10

M30

MET_SVS, MEP_SVS | Vorgezogene Ausgabe der M-Funktion gemäß Weg- oder Zeitangabe, Bewegungsfreigabe erst nach Quittierung der M-Funktion durch die PLC
 | Initialisierung in der Kanalparameterliste m_synch[..] 0x01000000 (synchronisation MEP_SVS) m_synch[..] 0x02000000 (synchronisation MET_SVS)

Programmierbeispiel

N10 G01 X10 G90 F5000

N20 X20

N30 X30

N40 X40

N50 M96 (M96 MEP_SVS m_pre_outp = 250000,)

(oder MET_SVS m_pre_outp = 300000us)

N55 X80

N60 X0

M30

Abbildung 1-7: Synchronisationsart MET_SVS, MEP_SVS

Festlegung des
Wegvorlaufes bzw. Zeitvorlaufes

Die Kanalparameter P-CHAN-00070 (m_pre_outp[i]) und P-CHAN-00107 (h_pre_outp[i]) werden in Verbindung mit den Synchronisationstypen MET_SVS und MEP_SVS verwendet. Die Parameter legen den Wert für die Ausgabe vor Bearbeitung der M/H-Funktionen im Bahninterpolator fest. Beim Typ MET_SVS erfolgt die Angabe des Zeitvorlaufs, beim Typ MEP_SVS erfolgt die Angabe des Wegvorlaufes

Beispielhafte Initialisierung in der Kanalparameterliste für 2 M-Funktionen:

q Die anwenderspezifische M-Funktion M96 soll 10 Millimeter vor Erreichen der Synchronisationsposition in der Satzsequenz an die PLC ausgegeben werden

q Die anwenderspezifische M-Funktion M97 soll 40 Millisekunden vor Erreichen des Synchronisationszeitpunktes in der Satzsequenz an die PLC ausgegeben werden.

# Festlegung der M-Funktionen und Synchronisationsarten

# ======================================================

:

m_synch[96] 0x01000000 MEP_SVS

m_synch[97] 0x02000000 MET_SVS

#

# Einstellung Vorausgabezeit/-weg mit MET_SVS, MEP_SVS

# =======================================================

m_pre_outp[96] 100000 in 0.1 um

m_pre_outp[97] 40000 in us

Die Festlegung des Weg-/Zeitvorlaufes einer M/H-Funktion kann auch über das NC-Programm durch entsprechende Variablen verändert werden (z.B. V.G.M_FCT[MNr].PRE_OUTP_PATH , siehe [PROG] ).

MOS_TS

Ausgabe der M-Funktion vor dem Satz, keine Synchronisation. Bei diesem Typ wird ein Zeitoffsetwert bezogen auf den Satzwechselpunkt bereitgestellt.

Bedingt durch die Abtastung mit der Zykluszeit tzykl liegt zwar der Ausgabepunkt einer M-Funktion auf Interpolatorebene zeitlich im Abtastraster, aber um maximal einen Abtasttakt zeitlich versetzt zum Satzwechselpunkt. In der PLC kann der exakte Ausgabezeitpunkt mit Hilfe des mitgeführten Zeitoffsets der M-Funktion in der PLC ermittelt und ausgeführt werden. (siehe auch [HLI] , pMHTechno^.D_Time).

Initialisierung in der Kanalparameterliste

m_synch[..] 0x00040000 (MOS_TS)

Programmierbeispiel

N10 G01 X25 G90 F5000

N20 X50

N30 M25 (M25 MOS_TS)

N40 X100

N50 X200

M30

Abbildung 1-8: Synchronisationsart MOS_TS

Der Ausgabepunkt der M-Funktion liegt zeitlich im Abtastraster, aber nicht exakt auf der Satzgrenze zwischen den beiden Bewegungsätzen N20 und N40. Zur Steuerung der hochgenauen Ausgabe in der PLC wird der Zeitoffset tcr (Bruchteil eines Zyklustaktes, kennzeichnet die exakte Lage des Abtasttaktes bezogen auf die Satzgrenze) bei der Berechnung des Ausgabezeitpunktes berücksichtigt.

Typischerweise wird die exakte zeitliche Ausgabe mit Hilfe einer speziellen zeitlich hochauflösenden Timer-Hardware realisiert.

Programmierbeispiel

Exakte wegsynchrone Ansteuerung von I/Os

Ein Laser (100µm Strahlbreite) soll beim Schneiden positionsgenau ein-/ausgeschaltet werden. Die Toleranz liegt im Bereich von 10 µs bzw. von ½ Strahlbreite = 50 µm. Die zeitliche Auflösung durch den Interpolationstakt der CNC (typisch 1ms) ist hierfür nicht ausreichend. Durch Verwendung einer zeitlich hochauflösenden Hardware und Algorithmen in der PLC lässt sich das Problem lösen.

Die Totzeit in der Systemkette CNC zum Antrieb muss größer sein als die Totzeit in der Systemkette zum Lasersystem.

Abbildung 1-9: Übersicht Totzeiten der Systemketten

Im vorliegenden Fall wird von einer typischen Totzeit von 800 μ s des Lasersystems ausgegangen. Bei der Positionierkette CNC  Antrieb liegt die Totzeit typisch bei 5 Taktzyklen (5 * 1 ms = 5 ms). Das Positionsregelsystem im Antrieb arbeitet schleppabstandsfrei (aktive Vorsteuerung). Wenn dennoch erforderlich, muß der Schleppabstand abgeschätzt werden. In der PLC wird die Totzeit der Positionierkette für die Ansteuerung des Lasers mit der Zeit TDPLC berücksichtigt. Die PLC verzögert also den von der CNC bereitgestellten M-Code des Bahninterpolators um n Takte. Das exakte Schaltsignal für den Laser innerhalb des Folgetaktes wird in der PLC auf Basis der Interpolationsdaten und der Totzeit berechnet und über eine Hardwareklemme mit einem hohen Basistakt (z. B. 1µs) erzeugt.

Abbildung 1-10: Schema der Totzeitkompensation


Vorbelegte M-Funktionen

Kanal M-Funktionen

Folgende M-Funktionen sind nach DIN66025 als CNC Kommando fest vorbelegt. Sie werden ohne entsprechende Angabe in der Kanalparameterliste weder ausgegeben noch synchronisiert.

M-Funktion | Bedeutung
M00 | Programmierter Halt
M01 | Wahlweiser Halt
M02, M30 | Hauptprogrammende
M17, M29 | Unterprogrammende
M10 | Optionale Funktion: Aktivierung Achsen klemmen (kanalspezifische Ausgabe) [SYSP - Kapitel 3.18] . Nur MNS_SNS zulässig
M11 | Optionale Funktion: Deaktivierung Achsen klemmen (kanalspezifische Ausgabe) [SYSP - Kapitel3.18] . Nur MVS_SVS zulässig.

Zur kanalspezifischen oder achsspezifischen Ausgabe ist eine Belegung des Parameters P-CHAN-00041 (m_synch[..]) erforderlich!

Spindel M-Funktionen

Folgende M-Funktionen sind nach DIN66025 für die Steuerung von Spindeln fest vorbelegt. Die Angabe einer Synchronisationsart erfolgt nicht wie für andere M-Funktionen, sondern für jede Spindel unter den speziellen Spindelparametern in der Kanalparameterliste [CHAN] (ausgenommen M40  45).

M-Funktion | Bedeutung
M03 | Spindel endlos drehen im Uhrzeigersinn
M04 | Spindel endlos drehen gegen den Uhrzeigersinn
M05 | Spindel stoppen
M19 | Spindel positionieren
M40  45 | Getriebestufenauswahl für die Hauptspindel

Beispiel

Ausgabe Spindel

spindel[0].m3_synch 0x00020002 PLC_INFO, MVS_SVS

spindel[0].m4_synch 0x00020004 PLC_INFO, MVS_SNS

Ausgabe Kanal

m_synch[3] 0x00000002 Ausgabe Kanal


M/H-Funktionen mit Zusatzinformation

Programmierung

Restriktionen

Bei M/H-Funktionen kann im NC-Programm optional ein Zusatzwert als negative oder positive Ganzzahl direkt oder als allgemeiner mathematischer Ausdruck programmiert werden. Er wird über die Technologieschnittstelle mit der M/H-Funktion der SPS zur Verfügung gestellt.

Beispiel: M50=123 oder H44=-256

Die s.g. internen M-Funktionen M00, M01, M02, M17, M29 und M30 sowie alle anwenderspezifischen M/H-Funktionen können in kanal- als auch in achsspezifischer Programmiersyntax mit einem Zusatzwert programmiert werden.

Die Spindel M-Funktionen M03, M04, M05, M19 sowie M40-M45 können mit keinem Zusatzwert programmiert werden!

Programmierbeispiel

(M-Funktionen mit Zusatzwert)

N10 M52=-345

N20 M12=123 (mit Kanalparameter m_default_outp_ax_name[12] Z)

N30 M10=321 (mit Kanalparameter m_default_outp_ax_name[10] S)

N35 P1 = 567 P2 = 345

N40 X[M54=P1]

N50 S[REV 1000 M03 M63=-789]

N60 M12=123 M10=321 M52=-345 X[M54=567] S[REV 1000 M03 M63=-789]

N70 M63=-789 M52=-P2 M54=567

N80 X[M52=-345 M54=567] Y[M63=-789] S[M05 M63=789 M54=-567] M54 M63

(H-Funktionen mit Zusatzwert)

N110 H5=-345

N120 H6=123 (mit Kanalparameter h_default_outp_ax_name[6] Z)

N130 H9=321 (mit Kanalparameter h_default_outp_ax_name[9] S)

N135 P3 = 567 P4 = -345

N140 X[H7=P3]

N150 S[REV 1500 M04 H8=-789]

N160 H6=123 H9=321 H5=-345 X[H7=567] S[REV 1500 M04 H8=-789]

N170 H8=-789 H5=P4 H7=567

N180 X[H8=-789 H4 H5=-345] Y[H7=567] S[M05 H5=345 H7=567] H3 H8

(Gemischte M/H- Funktionen mit Zusatzwert)

N200 X[M52=-345 H4 H8=-789 M54=567 H5=345] H3=333 M54=444 H7=567 M63

(M/H- Funktionen mit Zusatzwert in achsspezifischer Funktion(INDP))

N05 X[INDP G90 G01 FEED=2000 POS=555 M54=151 H8=-181]

N999 M30=111


Fertigungszeitberechnung

Bei der Planung von Fertigungsabläufen ist es wichtig zu wissen welche Produktionszeiten für die unterschiedlichen Aufträge benötigt werden. Dies gilt auch für die Zeit, die eine Maschine benötigt, um ein Teil zu fertigen.

Zur Simulation der Fertigungszeit werden in der Tabelle P-CHAN-00040 bzw. P-CHAN-00026 (*_prozess_zeit[i]) in der Kanalparameterliste die für M-/H-Funktionen vom Anwender empirisch ermittelten Laufzeiten in µs vorgegeben. Der Feldindex "i" gibt dabei die Nummer der M-/H-Funktion an [CHAN].

Parameter

P-CHAN-00040 | Bearbeitungszeit für die M-Funktion mit Nummer i
P-CHAN-00026 | Bearbeitungszeit für die H-Funktion mit Nummer i

Beispiel

Zur Bearbeitung von M07 und M08 werden 0,5s bzw. 1,3s benötigt:

m_prozess_zeit[7] 500000

m_prozess_zeit[8] 1300000

Für die vorbelegten Spindel M-Funktionen (sowie auch für die S-Funktion) wird die Bearbeitungszeit unter den Spindelparametern angegeben [CHAN].

Parameter

P-CHAN-00042 | Bearbeitungszeit für die Spindel M-Funktion M19
P-CHAN-00044 | Bearbeitungszeit für die Spindel M-Funktion M3
P-CHAN-00046 | Bearbeitungszeit für die Spindel M-Funktion M4
P-CHAN-00048 | Bearbeitungszeit für die Spindel M-Funktion M5
P-CHAN-00080 | Bearbeitungszeit für die Spindel S-Funktion

Beispiel

Zur Bearbeitung der Funktionen M03 und M19 werden 0,5 bzw. 1,5s benötigt:

spindel[0].m3_prozess_zeit 500000

spindel[0].m19_prozess_zeit 1500000


CNC-Programmierung

Kanalspezifisch

Die Programmierung erfolgt in herkömmlicher Art und Weise entsprechend DIN66025. Die M-/H-Funktion wird am kanalspezifischen Teil des HLI ausgegeben.

Für alle zu verwendenden M-/H-Funktionen muss in der Kanalparameterliste der Eintrag der Synchronisationsart unter den Parametern P-CHAN-00041 (m_synch[mnr]) und P-CHAN-00027 (h_synch[mnr]) vorhanden sein. Dies gilt nicht für die vorbelegten M-Funktionen.

Programmierbeispiel

N20 X75

N30 X50

N40 X25 M8

N50 X0 H1

Achsspezifisch
(Programmierung)

Zur Ausgabe einer M- oder H-Funktion an eine Achse wird eine erweiterte CNC-Syntax verwendet.

Soll die Ausgabe immer an eine bestimmte Achse erfolgen, so kann optional auf die erweiterte Syntax verzichtet werden und die M-/H- Funktion dieser Achse standardmäßig zugeordnet werden.

Die gewählte Achse muss im Kanal vorhanden sein. Dies geschieht durch entsprechende Belegung der Ausgangsachskonfiguration in der Kanalparameterliste oder durch Programmierung von Achstauschbefehlen während der Bearbeitung im CNC-Programm [PROG].

Achsspezifisch
(Parametrierung)

Konfiguration zur Standardausgabe am achsspezifischen Teil des HLI bei Programmierung in DIN66025-Syntax.

m_default_outp_ax_name[7] Z

Programmierbeispiel

N20 X75

N30 X50

N40 X25 M7 Ausgabe von M7 an die Z-Achse

N50 X[M7] Ausgabe von M7 an die X-Achse

Explizit
(erweiterte Syntax)

Programmierung in achsspezifischer Syntax [PROG] zur Ausgabe am achsspezifischen Teil des HLI. Eine Zuordnung aus der Kanalparameterliste bleibt bei expliziter Programmierung unberücksichtigt.

Programmierbeispiel

N20 X75

N30 X50

N40 X25 X[M7] Ausgabe von M7 an die X-Achse

N50 X0

Gemischte
Programmierung

Ausgabe von M- oder H-Funktionen an mehrere Achsen und den Kanalbereich im selben NC-Satz.

Programmierbeispiel

N10 X[M7] S[M7] M7 Gleichzeitige Ausgabe von M7 an die

X-Achse, die Hauptspindel S und den

Kanalbereich

N20 X[H1] S[H1] H1Entsprechendes Beispiel für H-Funktion


Verfahren zum Anlegen einer M- oder H-Funktion in der Kanalparameterliste

Abbildung 1- 11 : Ablaufdiagramm zum Anlegen einer M/H-Funktion


Vorabausgabe von M-Funktionen (Mikrosteg)

Wegbezogene
Vorabausgabe von
M-Funktionen

Über die Vorabausgabe kann eine M-Funktion an einer bestimmten Wegstelle automatisch vorab ausgegeben werden.

Dies kann z.B. bei M-Funktionen mit Zeitstempel MOS_TS für das vorgezogene Ausschalten eines Lasers verwendet werden, wodurch der Schnittprozess kurzfristig unterbrochen wird. Somit bleiben sogenannte Mikrostege stehen.

Die Ausgabe der vorgezogenen M-Funktion ist nicht an die ursprünglich programmierten Satzgrenzen gebunden. Der Bewegungssatz wird durch die CNC an der entsprechenden Positionen automatisch aufgetrennt und die M-Funktion eingefügt.

Abbildung 1- 12 : Programmierte Mikrostege im Teil

Programmierbeispiel

; M300 - Laser ein, M500 - Laser aus

N01 V.G.M_FCT[500].PRE_OUTP_PATH = 0.05

N00 G00 G90 X0 Y0

N01 L Laser_on.sub

N02 G01 F5000

N10 Y7

N11 M500 M300 (* Mikrosteg 1 *)

N15 Y10

N20 X14

N21 M500 M300 (* Mikrosteg 2 *)

N25 X20

N50 L Laser_off.sub

M30

Äquivalentes Beispiel bei expliziter Programmierung

; M300 - Laser ein

; M500 - Laser aus

N00 G00 G90 X0 Y0

N01 L Laser_on.sub

N02 G01 F5000

N10 Y6.95

N10 M500(* Mikrosteg 1 *)

N10 Y7

N11 M300

N15 Y10

N20 X13.95

N20 M500(* Mikrosteg 2 *)

N20 X14

N21 M300

N25 X20

N50 L Laser_off.sub

M30

M-/H-Funktionen für die Vorabausgabe

Neben der eigentlichen Verwendung der Vorabausgabe mit hochauflösenden MOS_TS ist die Ausgabe grundsätzlich auch für andere M- oder H-Funktionen möglich. Folgende Synchronisationsarten der M- und H-Funktionen werden bei der Vorabausgabe ausgewertet:

MOS, MVS_SVS, MVS_SNS, MNS_SNS, MOS_TS

Bezugsposition

Wird die M-Funktion zusammen mit einer Bewegung programmiert, so wird der Weg der Vorabausgabe bezüglich ihres Ausgabezeitpunkts zum Satz ermittelt. D.h. MOS, MVS_SVS und MVS_SNS werden bezüglich der Startposition des Satzes und MNS_SNS bezüglich der Endposition des Satzes positioniert.

Durch die Vorabausgabe wird die Trennung von Ausgabe- und Synchronisationsstelle jedoch grundsätzlich hinfällig.

D.h. wird die M-Funktion synchronisiert (MVS_SVS, MVS_SNS, MNS_SNS), so erfolgt die Ausgabe und Synchronisation an der gleichen Stelle. Dies entspricht der Programmierung der M-Funktion in einer separaten NC-Zeile.

Parametrierung über Listen

Die verwendeten M-Funktionen können in der Kanalliste freigeschaltet werden.

m_synch[100] MOS_TS

m_pre_outp[100] 500 in 0.1 um

m_synch[101] MOS_TS

m_pre_outp[101] 500 in 0.1 um

#

m_synch[25] MOS_TS

m_synch[26] MOS_TS

m_synch[27] MNS_SNS

Parametrierung über Programmierung

Alternativ zur Parametrierung der M-Funktionen kann die Synchronisationsart und der Weg auch direkt im NC-Programm angegeben werden.

V.G.M_FCT[11].SYNCH = 1

V.G.M_FCT[11].PRE_OUTP_PATH = 14 (* in [mm] *)

V.G.H_FCT[200].SYNCH = 4

V.G.H_FCT[200].PRE_OUTP_PATH = 40 (* in [mm] *)

Aktivierung und
Freischalten der
Funktion

Sobald ein pre-output-Weg angegeben ist, wird die M/H-Funktion vorgezogen.

Zusätzlich muss die Funktionalität zur Vorabausgabe in der Hochlaufliste entsprechend eingeschaltet werden:

configuration.channel[0].path_preparation.function FCT_DEFAULT | FCT_M_PRE_OUTPUT

Programmierbeispiel

%MicroJoint

; Synchronisationsarten als Makro

"MOS" = "1"

"MVS_SVS" = "2"

"MVS_SNS" = "4"

"MNS_SNS" = "8"

"MOS_TS" = "262144" ;0x40000

V.G.M_FCT[11].SYNCH = "MOS_TS"

V.G.M_FCT[11].PRE_OUTP_PATH = 11 (* in [mm] *)

V.G.M_FCT[13].SYNCH = "MNS_SNS"

V.G.M_FCT[13].PRE_OUTP_PATH = 23 (* in [mm] *)

V.G.H_FCT[12].PRE_OUTP_PATH = 12 (* in [mm] *)

V.G.H_FCT[12].SYNCH = "MVS_SVS"

N01 X0 G01 F500

N10 X100

N20 X200 M11 H12 M13

N30 X300

M30

Mehr:

button Begrenzungen, Sonderfälle


Begrenzungen, Sonderfälle

Beschränkung des Look-Ahead Bereichs

Aufgrund der Resourcenlimitierung und der Anforderung, dass das NC-Programm möglichst zeitnah nach Start anläuft, ist der betrachtete Look-Ahead-Bereich eingeschränkt. D.h. die maximale Anzahl von betrachteten Sätzen wird beschränkt (derzeit 10 Sätze, versionsabhängig). Je nach Satzlänge ergibt sich hierdurch eine maximale Stegbreite.

Programmierbeispiel

%microjoint4

N01 G00 G90 X0 Y0

N02 G01 F10000

N01 V.G.M_FCT[100].PRE_OUTP_PATH = 28.6 (* in mm *)

N20 G91 Y1

N21 Y1 ; -> geplanter MicroJoint bei Y1.4 mm

N22 Y1

N23 Y1

N24 Y1

N25 Y1

N37 Y1

N38 Y1

N39 Y1

; -> realer MicroJoint aufgrund Satzanzahlbeschraenkung

N40 Y1

N41 Y1

N42 Y1

N43 Y1

N44 Y1

N45 Y1

N46 Y1

N47 Y1

N48 Y1

N49 Y1

N50 M100 M26

N99 M30

Abbildung 1- 13 : Begrenzen des Wegvorlaufs der M-Funktion auf 10 Sätze

Explizites Aufheben des Look-Ahead Bereichs, #FLUSH

Durch ein Leeren des Kanals (#FLUSH bzw. #FLUSH WAIT) wird der Look-Ahead-Bereich der M-Funktionen zurückgesetzt. D.h. die Vorabausgabe der M-Funktionen kann nicht über die #FLUSH-Stelle hinaus zurück erfolgen.

Programmierbeispiel

%microjoint6

N01 G00 G90 X0 Y0

N02 G01 F10000

N01 V.G.M_FCT[100].PRE_OUTP_PATH = 28.6 (* in mm *)

N20 G91 Y1

N21 Y1 ; -> geplanter MicroJoint bei Y1.4 mm

N22 Y1

N23 Y1

N38 Y1

N39 Y1

N40 Y1

N41 Y1

N42 Y1

N43 Y1

N44 Y1

N400 #FLUSH ; -> eingefuegter MicroJoint bei Y24

N45 Y1

N46 Y1

N47 Y1

N48 Y1

N49 Y1

N50 M100 M26

N99 M30

Abbildung 1- 14 : Explizites Begrenzen des Wegvorlaufs der M-Funktion

Überlappende wegbezogene Vorabausgabe

Nach Erkennen einer wegbezogenen Vorabausgabe der M-Funktion werden alle seitherigen gespeicherten Bewegungssätze ausgegeben. Dies entspricht einem expliziten Leeren des Kanals (s. #FLUSH), wodurch eine verzögerte Abarbeitung der Bewegungssätze vermieden wird. Somit ist es nicht möglich, den Wegbereich von mehreren M-Funktionen überlappend zu legen.

Programmierbeispiel

%microjoint5

(* M100  Laser aus, M26  Laser ein *)

N01 G00 G90 X0 Y0

N02 G01 F10000

N01 V.G.M_FCT[101].PRE_OUTP_PATH = 5 (* in mm *)

N02 V.G.M_FCT[102].PRE_OUTP_PATH = 23

N03 V.G.M_FCT[103].PRE_OUTP_PATH = 31

N20 X10

N30 M101 M26

N40 X30

N50 M102 M26

N60 X40

N70 M103 M26

N80 M30

Abbildung 1- 15 : Theoretische Überlappung von Mikrostegen im Teil

Abbildung 1-16: Beschränkung der Überlappung von Mikrostegen imTeil

Vorrausgehende MNS_SNS

Eine vorausgehende M-Funktion des Typs MNS_SNS begrenzt den Ausgabebereich nachfolgender M-Funktionen mit Vorabausgabe.

D.h. es wirkt sich somit wie ein programmiertes #FLUSH an der Ausgabestelle der MNS_SNS-M-Funktion aus.

(Funktionalität ist eingeschränkt, da vollständige Behandlung aktuell noch nicht implementiert ist.).

Programmierbeispiel

%microjoint8

N01 G01 G90 X0 Y0 F10000

N02 V.G.M_FCT[100].PRE_OUTP_PATH = 35.6 (* in mm *)

N04 V.G.M_FCT[100].SYNCH = 1 ; MOS

N04 V.G.M_FCT[200].SYNCH = 8 ; MNS_SNS

N20 X10 M200

N40 X30

N60 X40 M100

N99 M30

Abbildung 1- 17 : Explizites Begrenzen des Wegvorlaufs der M-Funktion

Kombination von MNS_SNS mit und ohne Vorabausgabeweg

Die gleichzeitige Programmierung von MNS_SNS-M-Funktionen mit und ohne Vorabausgabeweg im gleichen NC-Satz inklusive einer Achsbewegung ist derzeit nicht erlaubt.

(Funktionalität ist eingeschränkt, da vollständige Behandlung aktuell noch nicht implementiert ist.).

Programmierbeispiel

%microjoint9

N01 G01 G90 X0 Y0 F10000

N02 V.G.M_FCT[100].PRE_OUTP_PATH = 35.6 (* in mm *)

N04 V.G.M_FCT[100].SYNCH = 8 ; MNS_SNS

N04 V.G.M_FCT[200].SYNCH = 8 ; MNS_SNS

N20 X10

N40 X30 M100 M200

N60 X40

N99 M30


Anwendungsbeispiele

Beispiel 1

Die M-Funktion M83 soll wahlweise an den Kanal oder die X-Achse ausgegeben werden können. Eine Synchronisation ist nicht erforderlich.

Kanalparameterliste

m_synch[83] 0x1

Programmierbeispiel

N10 M83 X[M83]

N20 M83

N30 X[M83]

Beispiel 2

Die H-Funktion H3 soll zukünftig immer an die Spindelachse S ausgegeben werden, ohne dass eine Änderung von CNC-Programmen notwendig wird. Eine Synchronisation ist vor Aufnahme einer Bewegung erforderlich. Zur Simulation der Fertigungszeit wird eine Bearbeitungsdauer von 1s angenommen.

Kanalparameterliste

h_synch[3] 0x2 MVS_SVS

h_default_outp_ax_name[3] S

h_prozess_zeit[3] 1000000

Programmierbeispiel

N10 X10 H3

Beispiel 3

Die vorbelegte M-Funktion M1 soll vor Aufnahme einer Bewegung synchronisiert werden. Zur Simulation der Fertigungszeit ist von einer Bearbeitungsdauer von 0,8s auszugehen.

Kanalparameterliste

m_synch[1] 0x2 MVS_SVS

m_prozess_zeit[1] 800000

Programmierbeispiel

N10 M1 X100


HMI-Anzeige

Anzeiger der aktiven M/H-Funktionen

Die aktiven M/H-Funktionen lassen sich z.B. via ADS abgreifen und an der Oberfläche anzeigen.

Neben einer kanalspezifischen Ansicht existiert hier noch eine achsspezifische Ansicht.

Aktive M/H-Funktionen, kanalspezifisch
Beschreibung | Zeigt die aktuell aktiven, d.h. auf der SPS-Schnittstelle auf Quittierung wartenden, M/H-Funktionen an.
Typ | Struktur: UNS32 Anzahl UNS32 active-M/H[12]
Wertebereich | [ 0; MAX_UNS32 ]
HMI Elemente | mc_active_m_functions_r, mc_active_h_functions_r
Zugriff | Read
IndexOffsetADS | 0x3d, 0x91 (IndexGroupADS = 0x000201<ii> mit <ii> = Kanal, [ 1 ; max])

Aktive M/H-Funktionen, achspezifisch
Beschreibung | Zeigt die achsspezifischen aktiven, d.h. auf der SPS-Schnittstelle auf Quittierung wartenden, M/H-Funktionen an.
Typ | Struktur: UNS32 Anzahl UNS32 active-M/H[12]
Wertebereich | [ 0; MAX_UNS32 ]
HMI Elemente | ac_<I>_active_m_functions_r, ac_<I>_active_h_functions_r
Zugriff | Read
IndexOffsetADS | 0x13, 0x17 (IndexGroupADS = 0x000202<ii> mit <ii> = Achsindex, [1;max])

Beispiel | Nach Programmierung eines Handsatzes H41, H42, H51 sind diese drei H-Funktionen auf der SPS-Schnittstelle aktiv und werden aktuell nicht quittiert.

Beispiel | Nach Programmierung eines Handsatzes X[H50] ist die achsspezifische H-Funktion auf der SPS-Schnittstelle aktiv, da dies noch nicht quittiert wird.


Parameter

Mehr:

button Übersicht

button Beschreibung


Übersicht

Konstante | Beschreibung
M_FKT_ANZ | Maximale Anzahl der M-Funktionen [SYSP - Kapitel 8.1]
H_FKT_ANZ | Maximale Anzahl der H-Funktionen [SYSP - Kapitel 8.2]
ACHS_NAME_LAENGE | Maximale Länge der Achsbezeichnung [SYSP - Kapitel 6.46]

ID | Parameter | Beschreibung
P-CHAN-00025 | h_default_output_ax_name[i] | Achsspezifische Ausgabe der H-Funktionen
P-CHAN-00026 | h_prozess_zeit[i] | Prozesszeit der H-Funktionen
P-CHAN-00027 | h_synch[i] | Synchronisationsarten für H-Funktionen
P-CHAN-00033 | late_sync_ready | Behandlung offener Late-Synchronisationen am CNC-Programmende
P-CHAN-00039 | m_default_output_ax_name[i] | Achsspezifische Ausgabe der M-Funktionen
P-CHAN-00040 | m_prozess_zeit[i] | Prozesszeit der M-Funktionen
P-CHAN-00041 | m_synch[i] | Synchronisationsarten für M-Funktionen
P-CHAN-00042 | m19_prozess_zeit | Prozesszeit der M19-Funktion
P-CHAN-00043 | m19_synch | Synchronisationsart M19
P-CHAN-00044 | m3_prozess_zeit | Prozesszeit der M03-Funktion
P-CHAN-00045 | m3_synch | Synchronisationsart M3
P-CHAN-00046 | m4_prozess_zeit | Prozesszeit der M04-Funktion
P-CHAN-00047 | m4_synch | Synchronisationsart M4
P-CHAN-00048 | m5_prozess_zeit | Prozesszeit der M05-Funktion
P-CHAN-00049 | m5_synch | Synchronisationsart M5
P-CHAN-00052 | main_spindle_gear_change | Spindelgetriebeschalten / Parametersatzumschaltung
P-CHAN-00069 | plc_control | Kennzeichnung einer PLC-Spindel mit Ausgabe von M-Funktionen über den Kanalbereich des HLI
P-CHAN-00070 | m_pre_outp[i] | Weg-/Zeitabhängige vorgezogene Ausgabe von M-Funktionen
P-CHAN-00080 | s_prozess_zeit | Prozesszeit der S-Funktion
P-CHAN-00098 | spindle_m_fct_free | Freie Verwendung der Spindel M-Funktionen M3, 4, 5, 19
P-CHAN-00107 | h_pre_outp[i] | Weg-/Zeitabhängige vorgezogene Ausgabe von H-Funktionen


Beschreibung

Mehr:

button Kanalparameter


Kanalparameter

P-CHAN-00039 | Definition einer achsspezifischen M-Funktion
Parameter | m_default_outp_ax_name[i]
Beschreibung | Will der Anwender für bestimmte M-Funktionen eine achsspezifische Behandlung erzwingen, so besteht die Möglichkeit durch den Kanalparameter P-CHAN-00039 diese so zu konfigurieren, daß sie achsspezifisch wirken. Dabei definiert der Feldindex "i" die Nummer der M-Funktion. Jeder M-Funktion kann ein Achsname zugeordnet werden, auf die sie wirken soll. Hierbei sind neben Spindelachsen auch Bahnachsen zulässig.
Datentyp | STRING
Datenbereich | 1 ≤ Stringlaenge ≤ ACHS_NAME_LAENGE
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Die Synchronisationsart der achsspezifischen M-Funktion wird wie bei kanalspezifischen M-Funktionen auch mit P-CHAN-00041 festgelegt.

P-CHAN-00025 | Definition einer achsspezifischen H-Funktion
Parameter | h_default_outp_ax_name[i]
Beschreibung | Will der Anwender für bestimmte H-Funktionen eine achsspezifische Behandlung erzwingen, so besteht die Möglichkeit durch den Kanalparameter P-CHAN-00025 diese so zu konfigurieren, daß sie achsspezifisch wirken. Dabei definiert der Feldindex "i" die Nummer der H-Funktion. Jeder H-Funktion kann ein Achsname zugeordnet werden, auf die sie wirken soll. Hierbei sind neben Spindelachsen auch Bahnachsen zulässig.
Datentyp | STRING
Datenbereich | 1 ≤ Stringlaenge ≤ ACHS_NAME_LAENGE
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Die Synchronisationsart der achsspezifischen H-Funktion wird wie bei kanalspezifischen H-Funktionen auch mit P-CHAN-00027 festgelegt.

P-CHAN-00052 | Freigabe Getriebeschalten für Hauptspindel
Parameter | main_spindle_gear_change
Beschreibung | Mit P-CHAN-00052 wird für die Hauptspindel das Getriebeschalten freigeschaltet oder gesperrt.
Datentyp | BOOLEAN
Datenbereich | 0: Spindelgetriebeschalten für die Hauptspindel deaktiviert 1: Spindelgetriebeschalten für die Hauptspindel aktiviert
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | Die M-Funktionen zur Auswahl der Getriebestufen der Hauptspindel M4045 werden durch den Parameter P-CHAN-00052 in der Kanalparameterliste aktiviert. Bei deaktiviertem Getriebeschalten können die M-Funktionen M4045 frei verwendet werden.

P-CHAN-00069 | PLC-Spindel über Kanalschnittstelle
Parameter | spindel[i].plc_control
Beschreibung | Eine Spindel wird nicht durch einen Spindelinterpolator im NC-Kanal sondern direkt durch die PLC angesteuert. Hierbei ist zu beachten, daß dann sämtliche Synchronisationen nicht mehr (Spindel-) achsspezifisch sondern über den kanalspezifischen HLI-Bereich ausgegeben und behandelt werden. Die achsspezifische Syntax zur Programmierung der Spindelbefehle ist weiterhin erlaubt, jedoch ist diese dann auf die Angabe der Drehzahl und der M-Funktionen M3/M4/M5/M19 beschränkt.
Datentyp | BOOLEAN
Datenbereich | 0: Eine Spindel wird durch einen Spindelinterpolator im NC-Kanal angesteuert. 1: Eine Spindel wird direkt durch die PLC angesteuert.
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00098

Umschalten der Bedeutung von M-Funktionen

Parameter

spindle_m_fct_free

Beschreibung

Gemäß DIN66025 haben bestimmte M-Funktionen abhängig vom Bearbeitungsverfahren und der Maschinengattung unterschiedliche Bedeutung.

Bei Maschinen zur spanenden Bearbeitung (z.B. Fräsen/Drehen/Bohren) sind M3/M4/M5/M19 den Spindelfunktionen (Drehrichtung, Stoppen, Positionieren) fest zugeordnet.

Bei Bearbeitungsverfahren wie z.B. Plasma-/Laserstrahlschneiden oder Drahterodieren werden die genannten M-Funktionen zur Steuerung anderer Technologiefunktionen verwendet.

Um eine freie Zuordnung zu ermöglichen, kann deshalb mit P-CHAN-00098 die Bedeutung der M-Funktionen M3/M4/M5/M19 umgeschaltet werden

Datentyp

BOOLEAN

Datenbereich

0: M3/M4/M5/M19 sind fest den Spindel-M-Funktionen zugeordnet (Default, wenn Spindeln konfiguriert sind).

1: M3/M4/M5/M19 sind frei verfügbar für andere Technologiefunktionen. Sie müssen in den Kanalparametern unter P-CHAN-00041 definiert werden. Die M-Funktionen sind keine Spindelfunktionen mehr!

Dimension

translatorisch: -

rotatorisch: -

Standardwert

0

Anmerkungen

-

Synchronisations-festlegungen

P-CHAN-00041

Synchronisationsarten für M-Funktionen

Parameter

m_synch[i]

Beschreibung

Im Array "m_synch[i]" wird die Synchronisationsart der entsprechenden M-Funktion definiert. Dabei definiert der Feldindex "i" die Nummer der M-Funktion. Die maximale Nummer bzw. Anzahl der M-Funktionen ist durch die Konstante M_FKT_ANZ begrenzt.

Der Wert von P-CHAN-00041 gibt an, welche Synchronisationsart die M-Funktion besitzt, d.h. wann eine Überprüfung auf das Vorliegen der SPS-Quittierung erfolgt. Eine Bewegung wird nicht ausgeführt bzw. spätestens zum Satzende hin gestoppt, wenn zum Zeitpunkt der Überprüfung keine Quittierung von der SPS eingetroffen ist.

Datentyp

UNS16

Datenbereich

NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP,MEP_SVS, MET_SVS

Dimension

translatorisch: -

rotatorisch: -

Standardwert

NO_SYNCH

Anmerkungen

-

P-CHAN-00027

Synchronisationsarten für H-Funktionen

Parameter

h_synch[i]

Beschreibung

Im Array "h_synch[i]" wird die Synchronisationsart der entsprechenden H-Funktion definiert. Dabei definiert der Feldindex "i" die Nummer der H-Funktion. Die maximale Nummer bzw. Anzahl der H-Funktionen ist durch die Konstante H_FKT_ANZ begrenzt.

Der Wert von P-CHAN-00027 gibt an, welche Synchronisationsart die H-Funktion besitzt, d.h. wann eine Überprüfung auf das Vorliegen der SPS-Quittierung erfolgt. Eine Bewegung wird nicht ausgeführt bzw. spätestens zum Satzende hin gestoppt, wenn zum Zeitpunkt der Überprüfung keine Quittierung von der SPS eingetroffen ist.

Datentyp

UNS16

Datenbereich

NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MEP_SVS, MET_SVS

Dimension

translatorisch: -

rotatorisch: -

Standardwert

NO_SYNCH

Anmerkungen

Für H-Funktionen stehen die Standardsynchronisationsarten MVS_SLM, MVS_SLP nicht zur Verfügung.

P-CHAN-00045 | Synchronisationsart für M03
Parameter | spindel[i].m3_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der M03-Funktion definiert.
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00047 | Synchronisationsart für M04
Parameter | spindel[i].m4_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der M04-Funktion definiert.
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00049 | Synchronisationsart für M05
Parameter | spindel[i].m5_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der M05-Funktion definiert.
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00043 | Synchronisationsart für M19
Parameter | spindel[i].m19_synch
Beschreibung | Mit diesem Parameter wird die Synchronisationsart der M19-Funktion definiert.
Datentyp | UNS16
Datenbereich | NO_SYNCH, MOS, MVS_SVS, MVS_SNS, MNS_SNS, MNE_SNS, MVS_SLM, MVS_SLP, PLC_INFO
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-CHAN-00070 | Weg-/Zeitabhängige vorgezogene Ausgabe von M-Funktionen
Parameter | m_pre_outp[i]
Beschreibung | P-CHAN-00070 wird in Verbindung mit den Synchronisationstypen MET_SVS und MEP_SVS verwendet. Dabei definiert der Feldindex "i" die Nummer der zugehörigen M-Funktion. Der Wert von P-CHAN-00070 legt die Ausgabe vor Bearbeitung der M-Funktion im Bahninterpolator fest. Beim Typ MET_SVS erfolgt die Angabe des Zeitvorlaufs, beim Typ MEP_SVS erfolgt die Angabe des Wegvorlaufes
Datentyp | UNS32
Datenbereich | 0 ≤ P-CHAN-00070 ≤ MAX(UNS32)
Dimension | 0.1µm (bei MEP_SVS ) oder μ s (bei MET_SVS)
Standardwert | -
Anmerkungen | -

P-CHAN-00107 | Weg-/Zeitabhängige vorgezogene Ausgabe von H-Funktionen
Parameter | h_pre_outp[i]
Beschreibung | P-CHAN-00107 wird in Verbindung mit den Synchronisationstypen MET_SVS und MEP_SVS verwendet. Dabei definiert der Feldindex "i" die Nummer der zugehörigen H-Funktion. Der Wert von P-CHAN-00107 legt die Ausgabe vor Bearbeitung der H-Funktion im Bahninterpolator fest. Beim Typ MET_SVS erfolgt die Angabe des Zeitvorlaufs, beim Typ MEP_SVS erfolgt die Angabe des Wegvorlaufes
Datentyp | UNS32
Datenbereich | 0 ≤ P-CHAN-00107 ≤ MAX(UNS32)
Dimension | 0.1µm (bei MEP_SVS ) oder μ s (bei MET_SVS)
Standardwert | -
Anmerkungen | -

P-CHAN-00033

Reaktion auf "Späte Synchronisation" am Programmende

Parameter

late_sync_ready

Beschreibung

Dieser Parameter wird in Verbindung mit den Synchronisationsarten MVS_SLM und MVS_SLP verwendet (Late Sync). Er bestimmt die Reaktion auf am Programmende noch offenen Late Sync M-Funktionen. Dies kann auftreten, wenn im NC-Programm kein G01 Satz bis Programmende folgte (bei MVS_SLM) oder die explizite Synchronisation nicht programmiert wurde (bei MVS_SLP).

Datentyp

BOOLEAN

Datenbereich

0: Die offenen Late Sync M-Funktionen am Programmende sind beim nächsten Programmstart weiterhin aktiv. Dies bedeutet, dass eine oder mehrere offene Late Sync M-Funktionen des ersten NC-Programmes erst durch ein Late Sync Event (G01 Satz oder #EXPL SYN) des zweiten NC-Programmes getriggert werden.

1: Am Programmende wird gewartet, bis alle offenen Late-Sync-M-Funktionen von der PLC quittiert sind.

Dimension

translatorisch: -

rotatorisch: -

Standardwert

-

Anmerkungen

-

Fertigungszeit-berechnung

P-CHAN-00040 | Prozesszeit der M-Funktion
Parameter | m_prozess_zeit[i]
Beschreibung | Im Array "m_prozess_zeit[i]" wird die Prozesszeit zur Fertigungszeitberechnung der zugehörigen M-Funktion definiert. Dabei definiert der Feldindex "i" die Nummer der M-Funktion. Die maximale Nummer bzw. Anzahl der M-Funktionen ist durch die Konstante M_FKT_ANZ begrenzt.
Datentyp | UNS32
Datenbereich | 0 < P-CHAN-00040 < MAX(UNS32)
Dimension | µs
Standardwert | -
Anmerkungen | Parameter ist nur im Zusammenhang mit der optionalen Funktion "Fertigungszeitberechnung" zu verwenden.

P-CHAN-00026 | Prozesszeit der H-Funktion
Parameter | h_prozess_zeit[i]
Beschreibung | Im Array "h_prozess_zeit[i]" wird die Prozesszeit zur Fertigungszeitberechnung der zugehörigen H-Funktion definiert. Dabei definiert der Feldindex "i" die Nummer der H-Funktion. Die maximale Nummer bzw. Anzahl der H-Funktionen ist durch die Konstante H_FKT_ANZ begrenzt.
Datentyp | UNS32
Datenbereich | 0 < P-CHAN-00026 < MAX(UNS32)
Dimension | µs
Standardwert | -
Anmerkungen | Parameter ist nur im Zusammenhang mit der optionalen Funktion "Fertigungszeitberechnung" zu verwenden.

P-CHAN-00080 | Prozesszeit der S-Funktion
Parameter | spindel[i].s_prozess_zeit
Beschreibung | Prozesszeit der S-Funktion zur Fertigungszeitberechnung.
Datentyp | UNS32
Datenbereich | 0 < P-CHAN-00080 < MAX(UNS32)
Dimension | µs
Standardwert | -
Anmerkungen | Parameter ist nur im Zusammenhang mit der optionalen Funktion "Fertigungszeitberechnung" zu verwenden.

P-CHAN-00044 | Prozesszeit der Spindelfunktion M03
Parameter | spindel[i].m3_prozess_zeit
Beschreibung | Prozesszeit der M03-Funktion zur Fertigungszeitberechnung.
Datentyp | UNS32
Datenbereich | 0 < P-CHAN-00044 < MAX(UNS32)
Dimension | µs
Standardwert | -
Anmerkungen | Parameter ist nur im Zusammenhang mit der optionalen Funktion "Fertigungszeitberechnung" zu verwenden.

P-CHAN-00046 | Prozesszeit der Spindelfunktion M04
Parameter | spindel[i].m4_prozess_zeit
Beschreibung | Prozesszeit der M04-Funktion zur Fertigungszeitberechnung.
Datentyp | UNS32
Datenbereich | 0 < P-CHAN-00046 < MAX(UNS32)
Dimension | µs
Standardwert | -
Anmerkungen | Parameter ist nur im Zusammenhang mit der optionalen Funktion "Fertigungszeitberechnung" zu verwenden.

P-CHAN-00048 | Prozesszeit der Spindelfunktion M05
Parameter | spindel[i].m5_prozess_zeit
Beschreibung | Prozesszeit der M05-Funktion zur Fertigungszeitberechnung.
Datentyp | UNS32
Datenbereich | 0 < P-CHAN-00048 < MAX(UNS32)
Dimension | µs
Standardwert | -
Anmerkungen | Parameter ist nur im Zusammenhang mit der optionalen Funktion "Fertigungszeitberechnung" zu verwenden.

P-CHAN-00042 | Prozesszeit der Spindelfunktion M19
Parameter | spindel[i].m19_prozess_zeit
Beschreibung | Prozesszeit der M19-Funktion zur Fertigungszeitberechnung.
Datentyp | UNS32
Datenbereich | 0 < P-CHAN-00042 < MAX(UNS32)
Dimension | µs
Standardwert | -
Anmerkungen | Parameter ist nur im Zusammenhang mit der optionalen Funktion "Fertigungszeitberechnung" zu verwenden.