Messen (C4)

1.1 EinleitungPAGEREF _Toc304470465 \h2

1.2 Grundeinstellungen 3

1.3 Programmierung 9

1.4 Messswerterfassung in der Antriebshardware 13

1.4.1 SERCOS 13

1.4.2 Lightbus 19

1.4.3 Terminal-Antriebe 20

1.4.4 EtherCAT 20

1.4.5 PROFIDRIVE 24

1.5 Messwerterfassung in der CNC 24

1.5.1 Messtastersignal über SPS-Schnittstelle 24

1.5.2 Messfahrt auf Festanschlag 27

1.6 Parameter 28

1.6.1 Übersicht 28

1.6.2 Beschreibung 29

1.6.2.1 Kanalparameter 29

1.6.2.2 Achsparameter 32

Mehr:

button Einleitung

button Grundeinstellungen

button Programmierung

button Messswerterfassung in der Antriebshardware

button Messwerterfassung in der CNC

button Parameter


Einleitung

Messen mit
G100, G310

Beim Messen über den NC-Befehl G100/G310 wird eine Achsposition nach dem Auslösen eines Messtasters gespeichert. Nach Auslösen des Meßinterrupt wird die aktuelle Position gespeichert (gelatcht) und die Messfahrt eventuell beendet.

Das Latchen der aktuellen Position erfolgt standardmäßig in der Antriebshardware, alternativ kann der Zustand des Messtasters der CNC über die PLC-Schnittstelle übergeben werden. Siehe [HLI - Steuerkommandos einer Achse].

Die Messfunktion wird für die im Messsatz programmierten Achsen initialisiert und aktiviert.

Die Messergebnisse können im NC-Programm durch entsprechende Variablen abgefragt oder eingerechnet werden.

Zur Verwendung der Messfunktion sind die Achs- und Kanalparameterlisten entsprechend zu parametrieren, ebenso müssen abhängig vom Antriebstyp diese ebenfalls parametriert werden.

Programmierbeispiel

%Messfahrt

N10 G00 X0 Y0 Z0

N20 X5

N30 G100 X10 Y10 F500

N40 G01 X7

N50 M30

Abbildung 1-1 zeigt eine Darstellung der sich ergebenden Bahn:

Abbildung 1-1: Programmierte Bahn


Grundeinstellungen

Kanalparameter,
Einstellen des
Default-Messtyps

Nach dem Hochlauf der Steuerung ist der Default-Meßtyp gültig, der in den Kanalparametern über P-CHAN-00057 (messtyp) angegeben ist.

Um zum Beispiel in einem NC-Kanal eine Messfahrt mit mehreren Achsen, bei der der Messvorschub über das F-Wort programmiert wird, durchführen zu können, ist in der Kanalparameterliste P-CHAN-00057 (messtyp) mit dem Wert 1 zu belegen. Folgende Meßtypen stehen zur Verfügung:

Wert | Bedeutung
1 | Meßfahrt (G100) mit mindestens einer Achse, Meßvorschub über F-Wort programmierbar.
2 | Meßfahrt (G100) mit genau einer Achse, Meßvorschub wird in der ACHS_MDS-Liste angegeben. Bei fehlendem Meßsignal wird eine Fehlermeldung ausgegeben !
3 | Meßfahrt (G100) mit mindestens einer Achse, Meßvorschub über F-Wort programmierbar, wahlweise Weiterfahrt bis zum Zielpunkt.
4 | Meßfahrt (G100) nur mit den maximal 3 Hauptachsen, Meßvorschub über F-Wort programmierbar.
5 | Unterbrechbare Meßfahrt (G310) mit mindestens einer Achse, Sprung über GOTO, Meßvorschub über F-Wort programmierbar.
6 | Unterbrechbare Meßfahrt (G310) mit mindestens einer SERCOS-Achse, Sprung über GOTO, Meßvorschub über F-Wort programmierbar.
7 | Meßfahrt (G100) durch Fahren auf Festanschlag mit mindestens einer Achse, Meßvorschub über F-Wort programmierbar.

NC-Programm, Umschalten des Messtyps | Im NC-Programm kann mit #MEAS MODE [ [<expr>] ] (modal) jederzeit ein neuer Meßtyp angewählt werden. Über die Programmierung von #MEAS MODE ohne Parameter wird der Default-Meßtyp angewählt, der in den Kanalparametern angegeben ist.
Achsparameter | In der Achsparameterliste sind die folgenden Parameter zu belegen:

P-AXIS-00118 | Achse kann als Messachse verwendet werden.
P-AXIS-00086 | Hub des Meßtasters. Definiert den maximal zulässigen Bremsweg für das Messen
P-AXIS-00215 | Messvorschub für das Messen (nur bei Meßtyp 2)
P-AXIS-00114 | Zulässige Wegstrecke nach Zielpunkt, wenn Meßtaster nicht betätigt wurde (nur bei Meßtyp 2)
P-AXIS-00115 | Berücksichtigung externer Meßsignale
P-AXIS-00117 | Einlesen des Meßtaster-Signal über die Hardware-Schnittstelle der Steuerung

Beispiel

kenngr.messachse 1

kenngr.hub_messtaster 100000

kenngr.vb_messen 10000

kenngr.mess_offset 0

kenngr.mess_signal_achs_steuer 0

kenngr.mess_signal_taster 0


Programmierung

Messenergebnisse,
V.A.MESS.<axis> V.A.MERF.<axis> V.A.MOFFS.<axis> V.A.MEIN.<axis>

Beim Messen über den NC-Befehl G100/G310 wird eine Achsposition nach dem Auslösen eines Messtasters gespeichert. Nach Auslösen des Meßinterrupt wird die aktuelle Position gespeichert (gelatcht) und die Messfahrt eventuell beendet. Die durch den Messvorgang erfassten Positionen können im NC-Programm durch die Befehle G101/G102 (Verrechnung des Messoffsets) sowie die folgenden achsspezifischen Variablen verwendet werden.

V.A.MESS.X Messwert von Achse X

V.A.MERF.X Messen ist erfolgt (TRUE/FALSE), gibt an, ob der Messinterrupt vor Erreichen der Zielposition eingetroffen ist

V.A.MOFFS.X Distanz zwischen Messposition und prog. Zielposition

V.A.MEIN.X Der aktuell mit G101 eingerechnete Messoffset der X-Achse. Dieser wirkt wie eine additive Verschiebung der programmierten Position:

PCS = PCS + MessoffsetG101

Weitere Informationen über die Verwendung der Funktionalität Messen können der Programmieranleitung [PROG], Kapitel Messfunktionen entnommen werden.

Einrechnen des
Messoffsets mit
G101, G102

Im NC-Programm kann mit

G101 <Achsname><fact> { <Achsname><fact> } (nicht modal)

ein Offset eingerechnet werden. Der Messoffset ist die Distanz zwischen aufgezeichneter Messposition und der programmierten Zielposition. Er berechnet sich wie folgt:

Messoffset = Messposition - Zielposition

Für die programmierten Koordinaten wird der aus den Meßwerten ermittelte Meßoffset als weitere Verschiebung zwischen programmierten und absoluten Koordinaten eingerechnet. Es erfolgt eine Fehlermeldung, wenn zuvor keine Meßwerte erfaßt wurden. Die Zahl hinter der Achsbezeichnung stellt den Faktor für die Einrechnung dar.

Die Verschiebung durch den Meßoffset gilt bis zur Abwahl mit G102.

G102 { <Achsname><dummy_expr> } (nicht modal)

Abbildung 1- 2 : Meßoffset

Werden mehrere Messfahrten sequentiell programmiert, so ist bei der Verwendung der achsspezifischen Variablen V.A.MERF zu berücksichtigen, dass für nicht programmierte Achsen die Werte aus der vorherigen Messung erhalten bleiben.

Für die Berechnung von V.A.MESS.* und V.A.MOFFS.* gelten folgende Zusammenhänge:

 | Ohne Transformation | Mit kartesische Trans-formation #CS ON | Mit kinematischer Transformation #TRAFO ON
V.A.MESS.<name> | ACS- Position | Umrechnung der Messposition ins aktive Koordinatensystem. | Umrechnung der Messposition ins aktive Koordinatensystem.
V.A.MOFFS.<name> | = V.A.MESS. <name>  V.A.PROG. <name>  Zero Shifts  Tool Offset | = V.A.MESS. <name>  V.A.PROG. <name>  Zero Shifts  Tool Offset | = V.A.MESS.  V.A.PROG.<name>  Zero Shifts

Programmierbeispiele

Annahme: Messtaster spricht bei ACS Position Z=100 an.

Messen im ACS ohne Verschiebungen:

%meas1

N05 #MEAS MODE[1]

N10 G01 G00 G90 Z200 F2000

N20 G100 Z20 F2000

N30 #MSG SYN["V.A.MESS.Z=%f", V.A.MESS.Z] -> V.A.MESS.Z = 100.0

N40 #MSG SYN["V.A.MOFFS.Z=%f", V.A.MOFFS.Z] -> V.A.MOFFS.Z = 80.0

N50 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N60 G101 Z1

N70 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 80.0

N80 G01 Z100 F1000

N90 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 180.0

N100 G102 Z1

N110 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N120 G01 Z100 F1000

N130 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 100.0

N140 M30

Abbildung 1- 3 : Messen ohne Verschiebungen

Messen mit Bezugspunktverschiebung G92:

%meas2

N05 #MEAS MODE[1]

N10 G92 Z33

N20 G01 G00 G90 Z200 F2000

N30 G100 Z20 F2000

N40 #MSG SYN["V.A.MESS.Z=%f", V.A.MESS.Z] -> V.A.MESS.Z = 100.0

N50 #MSG SYN["V.A.MOFFS.Z=%f", V.A.MOFFS.Z] -> V.A.MOFFS.Z = 47.0

N60 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N70 G101 Z1

N80 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 47.0

N90 G01 Z100 F1000

N100 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 180.0

N110 G102 Z1

N120 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N130 G01 Z100 F1000

N140 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 133.0

N150 M30

Abbildung 1- 4 : Messen mit Bezugspunktverschiebung

Messen mit Bearbeitungskoordinatensystem CS, Verschiebung:

%meas3

N05 #MEAS MODE[1]

N10 #CS ON[0,0,33,0,0,0]

N20 G01 G00 G90 Z200 F2000

N30 G100 Z20 F2000

N40 #MSG SYN["V.A.MESS.Z=%f", V.A.MESS.Z] -> V.A.MESS.Z = 67.0

N50 #MSG SYN["V.A.MOFFS.Z=%f", V.A.MOFFS.Z] -> V.A.MOFFS.Z = 47.0

N60 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N70 G101 Z1

N80 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 47.0

N90 G01 Z100 F1000

N100 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 147.0

N110 G102 Z1

N120 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N130 G01 Z100 F1000

N140 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 100.0

N150 #CS OFF

N160 M30

Abbildung 1- 5 : Messen mit CS, Verschiebung

Messen mit Bearbeitungskoordinatensystem CS, Verschiebung und Drehung:

Annahme: Der Meßtaster spricht bei der Z ACS-Position 55.5mm an.

%meas4

N05 #MEAS MODE[1]

N10 #CS ON[0,0,75,0,15,0]

N20 G01 G00 G90 X150 Z100 F2000

N30 G100 Z-10 F1000

N40 #MSG SYN["V.A.MESS.Z=%f", V.A.MESS.Z] -> V.A.MESS.Z = 20.0

N50 #MSG SYN["V.A.MOFFS.Z=%f", V.A.MOFFS.Z] -> V.A.MOFFS.Z = 30.0

N60 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N70 G101 Z1

N80 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 30.0

N90 G01 Z50 F1000

N100 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 80.0

N110 G102 Z1

N120 #MSG SYN["V.A.MEIN.Z=%f", V.A.MEIN.Z] -> V.A.MEIN.Z = 0.0

N130 G01 Z50 F1000

N140 #MSG SYN["V.A.ABS.Z=%f", V.A.ABS.Z] -> V.A.ABS.Z = 50.0

N150 #CS OFF

N160 M30

Abbildung 1- 6 : Messen mit CS, Verschiebung und Rotation


Messswerterfassung in der Antriebshardware

Mehr:

button SERCOS

button Lightbus

button Terminal-Antriebe

button EtherCAT

button PROFIDRIVE


SERCOS

Antriebsparameter

Zur Verwendung der Messfunktion müssen im Antrieb die folgenden Parametrierungen durchgeführt werden:

q verwendete Echtzeitsteuer- und Statusbits

q zu verwendenter Messtaster

q Messtaster-Steuerparameter

q Messwert im zyklischen Telegramm.

Die vom jeweiligen Antrieb unterstützten Parameter sind dabei der Antriebsdokumentation zu entnehmen.

Zusätzlich kann es noch sein, dass ein digitaler Eingang des Antriebsverstärkers als Messeingang parametriert werden muss. Einzelheiten hierzu sind ebenfalls der Dokumentation des Antriebsverstärkers zu entnehmen.

Echtzeitbits

Zum Messen werden beide Echtzeitstatusbits sowie ein Echtzeitsteuerbit benötigt.

Durch die Echtzeitstatusbits werden die folgenden Informationen vom Antrieb zum NC-Kern übertragen:

· Flanke am Messeingang aufgetreten (Messung erfolgt).

· Messtaster betätig.

Desweiteren wird ein Echtzeitsteuerbit benötigt, mit dem die Flankenauswertung des Messeingangs im Antrieb aktiviert wird (Freigabe Messen).

Die Zuordung der vom NC-Kern verwendeten Steuer- und Statusbits wird im NC-Kern durch den Parameter P-AXIS-00060 eingestellt. Zusätzlich müssem im Antriebsverstärker noch Parameter entsprechend eingestellt werden.

Die folgende Tabelle zeigt die NC-Kern-seitige Zuordnung von P-AXIS-00060 zu den verwendeten Status- und Steuerbits.

P-AXIS-00060 | Steuerbits | Statusbits
 | Messen Freigabe | Messung erfolgt | Messtaster betätigt
0, kein Eintrag | Echtzeitsteuerbit 1 | P-AXIS-00106 | Echtzeitstatusbit 2
1 | Echtzeitsteuerbit 1 | Echtzeitstatusbit 1 | Echtzeitstatusbit 2
2 | Echtzeitsteuerbit 2 | Echtzeitstatusbit 2 | Echtzeitstatusbit 1

Es wird empfohlen P-AXIS-00060 entweder auf dem Wert 1 oder 2 zu setzen. Der Wert 0 ist nur aus Gründen der Rückwärtskompatibilität vorhanden und erfordert zusätzliche Einstellungen (P-AXIS-00106).

Meßtaster-
Steuerparameter

Durch den Messtaster-Steuerparameter (S-0-0169) wird konfiguriert, welcher Messtaster und welche Flanke des Messsignals im Antrieb zum Messen verwendet werden soll. Abhängig von diesem Parameter werden die erfassten Positionen in unterschiedlichen SERCOS-Idents abgelegt, diese SERCOS-Idents müssen dann im zyklischen Istwerttelegramm des Antriebs übertragen werden.

Messtaster/Flanke | Messtaster-Steuerparameter S-0-0169 | Messwert-Ident
Messtaster 1, positive Flanke | S-0-0169 = 1 | S-0-0130
Messtaster 1, negative Flanke | S-0-0169 = 2 | S-0-0131
Messtaster 2, positive Flanke | S-0-0169 = 4 | S-0-0132
Messtaster 2, negative Flanke | S-0-0169 = 8 | S-0-0133

Parametrierung des
zyklischen
Telegramms

Je nach Wert des Messtaster-Steuerparameters ist im zyklischen Istwerttelegramm die in der obigen Tabelle angegebene Messwert-Ident zu konfigurieren.

Achsparameter

Für SERCOS-Antriebe sind in den Achsparameterlisten die folgenden Einträge zu belegen:

P-AXIS-00116 | Messen über SERCOS-Bus: kenngr.mess_signal_sercos 1
P-AXIS-00113 | Latchen bei positiver Meßsignalflanke: kenngr.mess_neg_flanke 0

Parametrierung eines SERCOS-Antriebes

Auf den folgenden beiden Seiten werden die zur Parametrierung eines SERCOS-Antriebes nötigen Schritte in Form eines Flußdiagrammes dargestellt.

Beispiel

Achsparameter

Zur Konfiguration der Messfunktion eines SERCOS-Antriebes mit der steigenden Flanke von Messtaster 1 unter Verwendung der Echtzeitsteuer- und Statusbits 1 sind im Antrieb und NC-Kern die folgenden Parameter nötig.

kenngr.hub_messtaster 2000

kenngr.vb_messen 2000

kenngr.messachse 1

kenngr.mess_signal_sercos 1

kenngr.echtzeit_bit_nr 1

Zyklisches
Telegramm

Bei der Konfiguration des zyklischen Telegramms muss Ident. S-0-0130 mit konfiguriert werden:

Antrieb

Es werden die Echtzeitbits 1 und Messtaster 1 verwendet:

q S-0-0301 = 405 (Echtzeitsteuerbit 1 = Messtaster 1 Freigabe)

q S-0-0305 = 409 (Echtzeitstatusbit 1 = Messwert 1, positiv erfasst)

q S-0-0307 = 401 (Echtzeitstatusbit 2 = Messtaster 1)

Messtaster-Steuerwort

Im Messtaster-Steuerwort ist der Wert 1 einzutragen:

q S-0-0169 = 1 (Messtaster 1 pos. Flanke)


Lightbus

Antriebsparameter

Zur Verwendung der Messfunktion muss im Antrieb der Digitaleingang 2 als Messeingang programmiert werden.

Dazu muss dem Antriebsparameter IN2MODE der Wert 26 zugewiesen werden.

Der Messtaster ist an den digitalen Eingang 2 (X3 Klemme 12) anzuschliessen.

Konfiguration Digitaleingang 2 als Messeingang

Achsparameter

Für Lightbus-Antriebe sind in den Achsparameterlisten die folgenden Einträge zu belegen:

P-AXIS-00113

Latchen bei positiver Meßsignalflanke:

kenngr.mess_neg_flanke 0


Terminal-Antriebe

Antriebsparameter /Meßtasteranschluß

Der Messtaster ist an Anschluß 4 des Inkremental Encoder Interfaces KL5101 anzuschließen.

Achsparameter

Für Terminal-Antriebe sind in den Achsparameterlisten die folgenden Einträge zu belegen:

P-AXIS-00113

Latchen bei positiver Messsignalflanke (Messen mit negativer Flanke wird vom Encoder Interface nicht unterstützt):

kenngr.mess_neg_flanke 0


EtherCAT

Antriebsparameter

Zur Verwendung der Messfunktion muss im Antrieb einem Digitaleingang die Funktion Positionslatch zugeweisen werden.

Dazu muss dem Antriebsparameter IN1MODE oder IN2Mode der Wert 26 zugewiesen werden.

Der Messtaster ist an den jeweils verwendeten digitalen Eingang (X3 Klemme 11 oder 12) anzuschliessen.

Desweiteren muss dem Antriebsparameter DRVCNFG2 der Wert 6 zugewiesen werden.

Konfiguration Digitaleingang 2 als Messeingang

Parametrierung des
zyklischen
Telegramms

Im zyklischen Istwerttelegramm muss bei Verwendung der Mess-Funktionalität ein Telegrammtyp konfiguriert werden, in dem die folgenden Daten übertragen werden:

· Latch status word

· Latch position

Im zyklischen Sollwerttelegramm muss ein Telegrammtyp konfiguriert werden, in dem das Latch control word übertagen wird.

Zyklisches Sollwerttelegramm zum Messen

Zyklisches Istwerttelegramm zum Messen

Achsparameter

Für EtherCAT-Antriebe sind in den Achsparameterlisten die folgenden Einträge zu belegen:

· Auswahl der Flanke des Messignals durch P-AXIS-00113.

· Auswahl des am Antrieb verwendeten Messeinganges (Digitaler Eingang 1 oder 2) mittels Parameter P-AXIS-00295.

P-AXIS-00113 | Latchen bei positiver Meßsignalflanke: kenngr.mess_neg_flanke 0
P-AXIS-00295 | Auswahl der Nummer des digitalen Messeingangs im Antrieb (1/2): antrieb.canopen.probing_input_number


PROFIDRIVE

Antriebsparameter

Zur Verwendung der Messfunktion muss im Antrieb der schnelle Digitaleingang I0.0, bzw. I0.X bei einem Doppelachsmodul, programmiert werden.

Dazu muss dem Antriebsparameter P0660 der Wert 80 zugewiesen werden.

Der Messtaster ist an den digitalen Eingang I0.0 bzw. I0.X anzuschliessen.

Achsparameter

Für PROVIDRIVE-Antriebe sind in den Achsparameterlisten die folgenden Einträge zu belegen:

P-AXIS-00113

Latchen bei positiver Meßsignalflanke:

kenngr.mess_neg_flanke 0


Messwerterfassung in der CNC

Für spezielle Anwendungen oder wenn die verwendete Antriebshardware keine Latch-Funktion bereitstellt, kann die Messwerterfassung in der CNC erfolgen.

Mehr:

button Messtastersignal über SPS-Schnittstelle

button Messfahrt auf Festanschlag


Messtastersignal über SPS-Schnittstelle

CNC - SPS

Hierbei wird der Zustand des Messtastersignals über die SPS-Schnittstelle an die CNC übergeben werden, die CNC übernimmt die Flankenauswertung und die Erfassung des Messwertes. Aufgabe der SPS ist das Einlesen des Messtastersignals und das Bereitstellen des Signals auf der SPS-Schnittstelle. Siehe auch [HLI - Steuerkommandos einer Achse] .

Als Messwert wird der aktuelle Istwert zum Zeitpunkt der Flanke des Messtastersignals verwendet.

Achsparameter

Zur Aktivierung dieser Funktion ist dem Achsparameter P-AXIS-00257 der Wert 1 zuzuweisen. Über diesen Parameter kann also exklusiv zwischen den Modi Messtastersignalerfassung über Antrieb oder Messtastersignalerfassung über PLC umgeschaltet werden.

Die Genauigkeit der erfassten Messwerte ist abhängig von der Zykluszeit der CNC und der SPS. Die Genauigkeit von antriebsintern erfassten Messwerten ist im allgemeinen genauer, da hier die Auswertung in der antriebsinternen Lageregler- bzw. Drehzahlreglerzykluszeit erfolgt.


Messfahrt auf Festanschlag

Grundeinstellung

Messen auf der Bahn

Messen mit Gantryachsen

Beim Messen durch Fahren auf Festanschlag muss in den beteiligten Antrieben eine Drehmomentbegrenzung aktiviert und eine eventuell vorhandene antriebsseitige Schleppabstandsüberwachung ausgeschaltet sein.

Die Meßfahrt wird beendet, sobald in einer der an der Messfahrt beteiligten Achsen der Festanschlag erfasst wurde.

Bei Gantry-Systemen (Soft- und Hardgantry) wird immer mit der Master-Achse gemessen. Während der Messfahrt werden die Slave-Achsen mitbewegt. Bei Fahren auf Festanschlag müssen daher in den Antrieben der Slaveachsen ebenfalls die Drehmomentbegrenzung aktiviert und die Schleppabstandsüberwachung ausgeschalten werden.

Bei TwinCAT-Systemen kann das Aktivieren der Drehmomentbegrenzung bzw. Deaktivieren der Schleppabstandsüberwachung in den Antrieben alternativ zum NC-Programm (#IDENT...) auch in der PLC (über ADS) ausgeführt werden.

Kanalparameter

Für das Messen durch Fahren auf Festanschlag muss in der Kanalparameterliste der Parameter P-CHAN-00057 (messtyp) belegt werden:

P-CHAN-00057

Messtyp 7 für Messen durch Fahren auf Festanschlag:

messtyp 7

Anwahl Messtyp im NC-Programm

Alternativ kann der Messtyp im NC-Programm über den Befehl #MEAS MODE[7] geändert werden.

Achsparameter

In den Achsparameterlisten sind die folgenden Einträge zu belegen:

P-AXIS-00330 | Anwahl der Meßsignalquelle Festanschlag: kenngr.meas_signal_fixed_stop 1
P-AXIS-00331 | Limit für Schleppabstand: kenngr.fixed_stop_pos_lag_limit z.B mit Wert 10000 [0,1 µm bzw. 0,0001°]
P-AXIS-00332 | Anzahl der Lagereglerzyklen: kenngr. fixed_stop_nbr_cycles z.B mit Wert 10

Ablauf der Messfahrt

Das Messen durch Fahren auf Festanschlag lässt sich z.B exemplarisch für SERCOS-Antriebe im folgenden Ablauf darstellen.

NC-Programm (Anwender):

1. Bipolarer Drehmomentgrenzwert S-0-0092 für alle an Messfahrt beteiligte Antriebe reduzieren (z.B. über den NC-Befehl #IDENT WR SYN)

2. Schleppabstandsüberwachung in den Antrieben ausschalten: Ident S-0-0159 = 0

3. Messfahrt starten (G100)

CNC:

4. Ausschalten der Schleppabstandsüberwachung im Lageregler für alle an der Messfahrt beteiligten Achsen

5. Beginn der Messfahrt

6. Übernahme der Istposition als Messwert sobald Schleppabstand vorgegebenen Grenzwert P-AXIS-00331 überschreitet. Bei Gantry-Systemen wird nur die Masterachse überwacht.

7. Interpolation auf Messwert um Schleppabstand der Achsen abzubauen

8. Einschalten der Schleppabstandsüberwachung im Lageregler

NC-Programm (Anwender):

9. Von Festanschlag wegfahren (z.B. G01)

10. Schleppabstandsüberwachung in den Antrieben aktivieren (S-0-0159 auf ursprünglichen Wert setzen)

11. NC-Programm: Drehmomentbegrenzung in den Antrieben aufheben (S-0-0092 auf ursprünglichen Wert setzen)

Programmierbeispiel

Messfahrt auf Festanschlag mit einem Gantry-System (Soft-Gantry):

%Meas_fixed_stop

; Soft-Gantry aktivieren

N010 G0 X100 X2=0

N020 #SET AX LINK[1,[X2=X,G,15,20]]

N030 #ENABLE AX LINK[1]

;Werte von Antrieben lesen

N040 #IDENT RD [AXNR 1 ID S-0-0092 P=P1092 TYP 2 DEC 0 SERC]

N050 #IDENT RD [AXNR 1 ID S-0-0159 P=P1159 TYP 4 DEC 0 SERC]

N060 #IDENT RD [AXNR 4 ID S-0-0092 P=P2092 TYP 2 DEC 0 SERC]

N070 #IDENT RD [AXNR 4 ID S-0-0159 P=P2159 TYP 4 DEC 0 SERC]

;Drehmomentbegrenzung aktivieren

N080 #IDENT WR SYN [AXNR 1 ID S-0-0092 VAL=100 TYP 2 DEC 0 SERC]

N090 #IDENT WR SYN [AXNR 4 ID S-0-0092 VAL=100 TYP 2 DEC 0 SERC]

;Schleppabstandsüberwachung in Antrieben ausschalten

N100 #IDENT WR SYN [AXNR 1 ID S-0-0159 VAL=0 TYP 4 DEC 0 SERC]

N110 #IDENT WR SYN [AXNR 4 ID S-0-0159 VAL=0 TYP 4 DEC 0 SERC]

;Messfahrt starten

N120 G100 X1000 Y1000 Z1000 Z2=1000 F1000

;Von Festanschlag wegfahren

N130 G01 X100 F1000

;Schleppabstandsüberwachung wieder einschalten

N140 #IDENT WR SYN [AXNR 1 ID S-0-0159 VAL=P1159 TYP 4 DEC 0 SERC]

N150 #IDENT WR SYN [AXNR 4 ID S-0-0159 VAL=P2159 TYP 4 DEC 0 SERC]

;Drehmomentbegrenzung aufheben

N160 #IDENT WR SYN [AXNR 1 ID S-0-0092 VAL=P1092 TYP 2 DEC 0 SERC]

N170 #IDENT WR SYN [AXNR 4 ID S-0-0092 VAL=P2092 TYP 2 DEC 0 SERC]

N180 M30


Parameter

Mehr:

button Übersicht

button Beschreibung


Übersicht

ID | Parameter | Beschreibung
P-CHAN-00057 | messtyp | Einstellung des Default-Meßtyps

ID | Parameter | Beschreibung
P-AXIS-00086 | hub_messtaster | Hub des Meßtasters
P-AXIS-00113 | mess_neg_flanke | Meßsignalflanke
P-AXIS-00114 | mess_offset | Zulässige Wegstrecke nach Zielpunkt bei Meßtyp 2
P-AXIS-00115 | mess_signal_achs_steuer | Berücksichtigung externer Meßsignale
P-AXIS-00116 | mess_signal_sercos | Einlesen des Meßsignals bei SERCOS
P-AXIS-00117 | mess_signal_taster | Meßtastersignal über Hardwareschnittstelle
P-AXIS-00118 | messachse | Achse kann als Meßachse verwendet werden
P-AXIS-00215 | vb_messen | Meßvorschub für Messen gemäß Meßtyp 2
P-AXIS-00060 | echtzeit_bit_nr | Nummer der verwendeten Echtzeit bits für SERCOS Antriebe
P-AXIS-00257 | probing_signal_via_plc | Messwerterfassung erfolgt in der CNC.
P-AXIS-00330 | meas_signal_fixed_stop | Messen durch Fahren auf Festanschlag
P-AXIS-00331 | fixed_stop_pos_lag_limit | Limit für Schleppabstand
P-AXIS-00332 | fixed_stop_nbr_cycles | Anzahl der Lagereglerzyklen


Beschreibung

Mehr:

button Kanalparameter

button Achsparameter


Kanalparameter

P-CHAN-00057

Einstellung des Default-Meßtyps

Parameter

messtyp

Beschreibung

Es stehen 7 verschiedene Meßtypen zur Verfügung. Mit diesem Element kann der gewünschte Meßtyp eingestellt werden.

Datentyp

UNS16

Datenbereich

1: Meßfahrt (G100) mit mindestens einer Achse,
Meßvorschub über F-Wort programmierbar

2: Meßfahrt (G100) mit genau einer Achse,
Meßvorschub wird in der ACHS_MDS-Liste angegeben

3: Meßfahrt (G100) mit mindestens einer Achse,
Meßvorschub über F-Wort programmierbar,
wahlweise Weiterfahrt bis zum Zielpunkt

4: Meßfahrt (G100) nur mit den maximal 3 Hauptachsen,
Meßvorschub über F-Wort programmierbar

5: Unterbrechbare Meßfahrt (G310) mit mindestens einer Achse,
Meßvorschub über F-Wort programmierbar

6: Unterbrechbare Meßfahrt (G310) mit mindestens einer SERCOS-Achse,
Meßvorschub über F-Wort programmierbar

7: Meßfahrt (G100) auf Festanschlag mit mindestens einer Achse,
Meßvorschub über F-Wort programmierbar.

Dimension

translatorisch: -

rotatorisch: -

Standardwert

-

Anmerkungen

Der Meßtyp kann im NC-Programm mit #MEAS MODE jederzeit geändert werden.


Achsparameter

P-AXIS-00086 | Hub des Meßtasters
Parameter | kenngr.hub_messtaster
Beschreibung | Da der Hub von mechanischen Meßsensoren begrenzt ist, erfolgt bei der Betätigung desselben eine Überprüfung, ob aufgrund der Beschleunigungsrampe und des aktuellen Vorschubs eine Verzögerung über die in der Achsparameterliste gewählten Rampen ausreicht. Der Parameter P-AXIS-00086 definiert also den maximal zulässigen Bremsweg für das Messen.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00086 ≤ MAX(UNS32)
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | -
Anmerkungen | Zwischen Interpolator und dem Lageregler existiert ein Puffer um die Parameter zur Vorsteuerung von Achsen zu berechnen. Daraus resultiert eine Totzeit zwischen der Berechnung eines Sollwertes vom Interpolator und der Ausführung desselben im Lageregler. Bei einer Meßfahrt kann im ungünstigsten Fall ein Fehler erzeugt werden, da der Interpolator, welcher den Meßtasterhub überwacht, die Weganteile im Puffer nicht berücksichtigt. Durch vergrößern des wirklichen Meßtaster-Hubs kann dies verhindert werden.

P-AXIS-00113 | Meßsignalflanke
Parameter | kenngr.mess_neg_flanke
Beschreibung | Definition der Flanke des Meßsignals, bei welcher der Zähler den Latchvorgang durchführt.
Datentyp | BOOLEAN
Datenbereich | 0: Latchen bei positiver Meßsignalflanke 1: Latchen bei negativer Meßsignalflanke
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00114 | Meßfahrtoffset
Parameter | kenngr.mess_offset
Beschreibung | Der Meßfahrtoffset P-AXIS-00114 gibt an, um welche Wegstrecke weiter als die programmierte Zielposition im Meßsatz gefahren werden darf, wenn der Meßtaster bis zum programmierten Zielpunkt noch nicht betätigt wurde. Kann innerhalb des Meßoffsets immer noch kein Meßsignal aufgenommen werden, so wird eine Fehlermeldung ausgegeben.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00114 ≤ MAX(UNS32)
Dimension | translatorisch: 0,1µm | rotatorisch: 0,0001°
Standardwert | -
Anmerkungen | Dieser Parameter wird nur für Messen gemäß Meßtyp 2 verwendet.

P-AXIS-00115

Meßsignal über achsspez. Steuerbitleiste

Parameter

kenngr.mess_signal_achs_steuer

Beschreibung

Um auch externe Meßsignale berücksichtigen zu können, wird ein Bit in der achsspezifischen Steuerbitleiste als Meßsignal behandelt. Dies kann über P-AXIS-00115 aktiviert werden.

Datentyp

BOOLEAN

Datenbereich

0: Keine Auswertung des Meßsignals über achsspez. Steuerbitleiste

1: Auswertung des Meßsignals über achsspez. Steuerbitleiste

Dimension

translatorisch: -

rotatorisch: -

Standardwert

-

Anmerkungen

Abhängig vom Antriebstyp sind folgende Meßmethoden zulässig:

 | Meßmethode
 | P-AXIS-00117 (mess_signal_taster) | P-AXIS-00116 (mess_signal_sercos) | P-AXIS-00115 (mess_signal_achs_steuer)
Antriebs-simulation | X | - | X
Konven-tionelle Antriebs-schnittstelle | X | - | X
SERCOS-Antriebsschnittstelle | X | X | X

P-AXIS-00116 | Messen mit SERCOS-Antrieben
Parameter | kenngr.mess_signal_sercos
Beschreibung | Mit Hilfe von P-AXIS-00116 wird festgelegt, ob das Meßsignal über die SERCOS-Schnittstelle einzulesen ist.
Datentyp | BOOLEAN
Datenbereich | 0: Meßsignal über Steuerbitleiste oder Hardwareschnittstelle einlesen (siehe P-AXIS-00115 bzw. P-AXIS-00117) 1: Meßsignal über die SERCOS-Schnittstelle einlesen
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00117 | Meßtaster-Signal über Hardware-Schnittstelle
Parameter | kenngr.mess_signal_taster
Beschreibung | Die Nutzung der Hardwareschnittstelle des NC-Kerns wird über P-AXIS-00117 ausgewählt.
Datentyp | BOOLEAN
Datenbereich | 0: Kein Einlesen des Meßtaster-Signals über die Hardware-Schnittstelle der Steuerung 1: Einlesen des Meßtaster-Signals über die Hardware-Schnittstelle der Steuerung
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00118 | Meßachse
Parameter | kenngr.messachse
Beschreibung | P-AXIS-00118 bestimmt, ob eine Achse an einer Meßfahrt beteiligt sein kann.
Datentyp | BOOLEAN
Datenbereich | 0: Achse kann nicht als Meßachse verwendet werden 1: Achse kann als Meßachse verwendet werden
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00215 | Meßvorschub für Messen
Parameter | kenngr.vb_messen
Beschreibung | Applikationsabhängig erfolgt die Meßfahrt nicht mit dem programmierten Vorschub, sondern mit dem durch P-AXIS-00215 definierten Vorschub.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00215 ≤ MAX(UNS32)
Dimension | translatorisch: µm/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | Dieser Parameter wird nur für Messen gemäß Meßtyp 2 verwendet.

P-AXIS-00060

Nummer der verwendeten Echtzeitbits für SERCOS-Antriebe

Parameter

kenngr.echtzeit_bit_nr

Beschreibung

Durch diesen Parameter erfolgt die Zuordnung der beim Messen mit SERCOS Antrieben verwendeten Echtzeit-Steuer- und Statusbits.

Die Zuordnung erfolgt gemäss der folgenden Tabelle.

P-AXIS-00060 | Steuerbits | Statusbits
 | Messen Freigabe | Messung erfolgt | Messtaster betätigt
0, kein Eintrag | Echtzeitsteuerbit 1 | P-AXIS-00106 | Echtzeitstatusbit 2
1 | Echtzeitsteuerbit 1 | Echtzeitstatusbit 1 | Echtzeitstatusbit 2
2 | Echtzeitsteuerbit 2 | Echtzeitstatusbit 2 | Echtzeitstatusbit 1

Datentyp

UNS08

Datenbereich

0 ≤ P-AXIS-00060 ≤ 2

Dimension

-

-

Standardwert

0

Anmerkungen

Es wird empfohlen den Wert 1 oder 2 zu benutzen.

P-AXIS-00257 | Messwerterfassung erfolgt in der CNC
Parameter | kenngr.probing_signal_via_plc
Beschreibung | Messwerterfassung erfolgt in der CNC, das Messtastersignal wird der CNC über die SPS-Schnittstelle übergeben.
Datentyp | BOOLEAN
Datenbereich | 0: Messwerterfassung erfolgt antriebsintern. 1: Messwerterfassung in der CNC.
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -

P-AXIS-00330 | Messen durch Fahren auf Festanschlag
Parameter | kenngr.meas_signal_fixed_stop
Beschreibung | Mit diesem Parameter wird die Meßsignalquelle "Festanschlag" ausgewählt.
Datentyp | BOOLEAN
Datenbereich | 0: Kein Messen auf Festanschlag möglich 1: Freigabe Messen auf Festanschlag
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | Der Anwender muß dafür sorgen, daß beim Fahren auf den Festanschlag in den beteiligten Antrieben eine Drehmomentbegrenzung aktiv ist und die Geschwindigkeit hinreichend klein ist. Alle anderen Meßsignalquellen (z.B. P-AXIS-00116 (kenngr.mess_signal_sercos)) müssen abgewählt sein.

P-AXIS-00331 | Limit für Schleppabstand
Parameter | kenngr.fixed_stop_pos_lag_limit
Beschreibung | Dieser Parameter legt das Limit für den Schleppabstand fest, nach dessen Überschreiten der Festanschlag detektiert und die Messposition übernommen wird.
Datentyp | UNS32
Datenbereich | 0 < fixed_stop_pos_lag_limit < MAX(UNS32)
Dimension | translatorisch: 0,1 µm | rotatorisch: 0,0001°/s
Standardwert | -
Anmerkungen | -

P-AXIS-00332 | Anzahl der Lagereglerzyklen
Parameter | kenngr.fixed_stop_nbr_cycles
Beschreibung | Dieser Parameter legt die Anzahl der Lagereglerzyklen fest, die nach Überschreiten des vorgegebenen Schleppabstandslimits P-AXIS-00331 gewartet wird, bevor der Messwert ermittelt wird. Sollte während dieser Zeit das Limit erneut unterschritten werden, wird mit der Zählung von vorne begonnen.
Datentyp | UNS32
Datenbereich | 0 < fixed_stop_nbr_cycles < MAX(UNS32)
Dimension | translatorisch: - | rotatorisch: -
Standardwert | -
Anmerkungen | -