Dynamik-Kenngrößen (D1)

1.1 KurzbeschreibungPAGEREF _Toc304468391 \h2

1.2 Beschreibung 4

1.2.1 Allgemeine Dynamikkenngrößen 4

1.2.2 Beschleunigungsprofile 6

1.2.2.1 Sprungförmiges Beschleunigungsprofil 8

1.2.2.2 Ruckbegrenztes Standard- Beschleunigungsprofil 11

1.2.2.3 Ruckbegrenztes HSC-Beschleunigungsprofil 12

1.2.3 Ruckbegrenzung und Kontur 14

1.2.3.1 Konturverlauf mit nicht tangentenstetigen Satzgrenzen 14

1.2.3.2 Konturverlauf mit tangentenstetigen Satzgrenzen 16

1.2.3.3 Ruckbegrenzung innerhalb der Kontur 21

1.2.4 Notfallbeschleunigung 22

1.2.5 Auswahl / Modifikation des Beschleunigungsprofils 23

1.2.5.1 Profiltyp und Gewichtungswirkung 23

1.2.5.2 Bahnspezifische Dynamikbegrenzung 24

1.2.6 Dynamische Grenzwerte für Handbetrieb 25

1.2.7 Parameter für Referenzpunktfahrt 27

1.2.8 Absolute Grenzwerte 28

1.2.9 Steuerflags 29

1.3 Parametrierung 30

1.3.1 Übersicht 30

1.3.1.1 Kanalparameter 30

1.3.1.2 Achsparameter 30

1.3.2 Beschreibung 32

1.3.2.1 Kanalparameter 32

1.3.2.2 Achsparameter 35

1.3.2.2.1 Allgemeine Parameter 35

1.3.2.2.2 Linearer Slope 38

1.3.2.2.3 Nicht linearer Slope 43

1.3.3 Beispiel Kanalliste 46

1.3.4 Beispiel Achsliste 46

Mehr:

button Kurzbeschreibung

button Beschreibung

button Parametrierung


Kurzbeschreibung

Aufgabe

Damit eine programmierte Bahnkontur mit einer bestimmten Geschwindigkeit gefahren werden kann, berechnet die CNC-Steuerung ein Bahnsollwertprofil. Die einzelnen NC-Achsen werden dabei mit vorgegebenen Beschleunigungswerten beschleunigt und abgebremst. Welche dynamischen Einstellungen bei einer Maschine die besten Ergebnisse hinsichtlich Bearbeitungszeit und Konturtreue ergeben, ist unter anderem von folgenden Einflüssen abhängig:

q Belastbarkeit der Maschinenkonstruktion

q Schwingungsverhalten der Maschine

q Drehmomentverhalten des Antriebsmotors

q Stromgrenze des Antriebsstellers

Die CNC berücksichtigt bei der Profilberechnung jede an der Bewegung beteiligte Maschinenachse. Die Bahngeschwindigkeit muß gegebenenfalls soweit reduziert werden, daß die achsspezifischen Geschwindigkeits- und Beschleunigungsgrenzwerte eingehalten werden. Die Maschinenachse mit der schwächsten Dynamik und dem größten relativen Fahrweg bestimmt letztendlich die maximal mögliche Bahngeschwindigkeit.

In dieser Funktionsbeschreibung wird die Parametrierung des dynamischen Verhaltens der Bewegungsführung beschrieben. Die spezifischen zusätzlichen dynamischen Parameter für Spindelachsen wie z.B. Kennlinienbeschleunigung sind in [FCT-S1] beschrieben.

Wirksamkeit

Die achsspezifischen Dynamik-Kenngrößen sind Parameter, die für eine einzelne Maschinenachse gelten. Wenn mehrere NC-Achsen im Bahnverbund zusammenwirken (Bahnbetrieb), bestimmt die Achse mit der jeweils schwächsten Dynamik und dem größten relativen Fahrweg die gesamte Bahndynamik.

Parametrierung

Die Dynamik-Kenngrößen werden für jede NC-Achse in der Achsparameterliste [AXIS] parametriert.

In der kanalspezifischen Parameterliste [CHAN] wird der Default-Typ des Beschleunigungsprofils mit der zugehörigen Gewichtungswirkung parametriert.


Beschreibung

Mehr:

button Allgemeine Dynamikkenngrößen

button Beschleunigungsprofile

button Ruckbegrenzung und Kontur

button Notfallbeschleunigung

button Auswahl / Modifikation des Beschleunigungsprofils

button Dynamische Grenzwerte für Handbetrieb

button Parameter für Referenzpunktfahrt

button Absolute Grenzwerte

button Steuerflags


Allgemeine Dynamikkenngrößen

Grenzwerte

Die unten aufgelisteten Parameter beschreiben dynamische Grenzwerte einer NC-Achse. Sie dienen als obere bzw. untere Begrenzung für weitere Parameter, die teilweise auch im NC-Programm verändert werden können.

Bei Gewichtung der in den nachfolgenden Kapiteln beschriebenen Beschleunigungs- und Rampenzeitwerte mit den G-Funktionen G130 - G133 [PROG] kann also die minimal zulässige Rampenzeit nicht unterschritten und die maximal zulässige Beschleunigung nicht überschritten werden.

q Maximal zulässige Achsbeschleunigung (P-AXIS-00008)

q Minimal zulässige Rampenzeit (P-AXIS-00201)

q Maximal zulässige Achsgeschwindigkeit (P-AXIS-00212)

Für die Einstellung der maximalen Achsgeschwindigkeit P-AXIS-00212 ist zu beachten:

q Für G01 oder G00 Bewegungen stellt dieser Wert die Obergrenze dar, die durch F Wort Programmierung bzw. G00 Programmierung erreicht werden kann.

q Bei translatorischen oder rotatorischen Achsen (keine Spindeln) wird davon ausgegangen, dass bei der Einstellung auch die Auflösungsgrenzen des Meßsystems berücksichtigt werden.

q Bei Spindelachsen wird die Grenzgeschwindigkeit für das Meßsystem P-AXIS-00220 als maximale Achsgeschwindigkeit eingestellt.

Weitere Grenzwerte

Max. zulässiger Geschwindigkeits-Override in Kanal P-CHAN-00056 oder Achse P-AXIS-00109

Zur Begrenzung des Kanalspezifischen Geschwindigkeits-Overrides wird der Parameter P-CHAN-00056 verwendet. Dieser Wert ist bei Bahnbewegungen wirksam (Achsen eines Kanals im Bahnverbund).

Zur Begrenzung des achsspezifischen Geschwindigkeits-Overrides wird der Parameter P-AXIS-00109 verwendet (unabhängige Achsen).

Eilganggeschwindigkeit P-AXIS-00209

Bei G00 Bewegungen berechnet die CNC basierend auf den achsspezifischen Eilganggeschwindigkeiten eine vom programmierten F-Wort unabhängige Eilgangbahngeschwindigkeit. Mit dieser Eilgangbahngeschwindigkeit wird bei G00 Programmierung gefahren.

Für die Positionierung im Eilgang (G00) kann mit dem Parameter
P-AXIS-00209 die Geschwindigkeit festgelegt werden.

Reduzierte Geschwindigkeit bei Vorschubbewegung P-AXIS-00214

Reduzierte Geschwindigkeit bei G00 P-AXIS-00155

Diese maximalen Geschwindigkeitswerte werden von der CNC nach Aktivierung über ein Steuersignal der PLC berücksichtigt. Dadurch kann z. B. bei geöffneten Schutztüren mit kleinerer Geschwindigkeit gefahren werden.

Reduzierte Geschwindigkeit im Sicherheitsbereich P-AXIS-00030

Dieser maximale Geschwindigkeitswert wird von der CNC nach Aktivierung über ein Steuersignal der PLC berücksichtigt, wenn sich die Achse innerhalb eines bestimmten Positionsbereiches befindet. Dadurch kann z. B. innerhalb eines Schutzbereiches mit kleinerer Geschwindigkeit gefahren werden.


Beschleunigungsprofile

Die Wahl des Beschleunigungsprofils bestimmt die Geschwindigkeit auf der programmierten Bahn unter Einhaltung der vorgegebenen zulässigen Geschwindigkeiten, Beschleunigungen und Rücke. Folgende Modi sind verfügbar:

q sprungförmiges Beschleunigungsprofil mit Begrenzung der Beschleunigung ohne Begrenzung des Rucks,

q trapezförmiges Beschleunigungsprofil

q sinusquadratförmiges Beschleunigungsprofil,

Je nach Wahl des Beschleunigungsprofils stellt sich der nachfolgend dargestellte Beschleunigungsverlauf ein:

Abbildung 1-1: Bahnbeschleunigungsprofile

Die NC-Steuerung berechnet aus der Weginformation und den Geschwindigkeitsvorgaben im NC-Programm sowie den dynamischen Kenngrößen der Maschinenachsen den im aktuellen Takt auszugebenden Fahrweg für die programmierte Bahn. Die Planung des daraus resultierenden Geschwindigkeitsprofils geht über mehrere Sätze hinweg und stellt sicher, dass jederzeit ohne Überschreitung der zulässigen Dynamikgrenzwerte angehalten werden kann (Look Ahead).

Parametrierung

Auswahl des Standard-Beschleunigungsprofils

In den Kanalparameterlisten [CHAN] wird das Standard-Beschleunigungsprofil mit dem Parameter P-CHAN-00071 ausgewählt. Wenn innerhalb des NC Programms kein anderes Profil angewählt wird, ist das Standard-Beschleunigungsprofil aktiv.

Beispiel: Auszug aus Kanalparameterliste

prog_start.slope.profile 0

Das Beschleunigungsprofil kann bei Bedarf im NC-Programm über den modal wirksamen Befehl #SET SLOPE PROFIL für diesen Kanal geändert werden [PROG].

Beispiel: Auszug aus NC-Programm

N20 #SET SLOPE PROFIL[1](trapezförm. Beschl.profil)

N30 G01 G90 X10 Y10 F5000

Bewegungssätze nach Satznummer N20 werden mit trapezförmigem Beschleunigungsprofil gefahren.

Unabhängige Achsen

Für unabhängige Achsen kann das Beschleunigungsprofil im NC-Programm über das Schlüsselwort SLOPE_PROFIL innerhalb des achsspezifischen Programmierbefehls parametriert werden [PROG - Unabhängige Achsen].

Mehr:

button Sprungförmiges Beschleunigungsprofil

button Ruckbegrenztes Standard- Beschleunigungsprofil

button Ruckbegrenztes HSC-Beschleunigungsprofil


Sprungförmiges Beschleunigungsprofil

Beschreibung
und
Eigenschaften

Bei diesem sehr häufig verwendeten Profil ist der Beschleunigungsverlauf treppenförmig. Daraus ergeben sich dynamische Bewegungsabschnitte für die einzelnen Achsen, in der diese über der Zeit mit linearem Geschwindigkeitsanstieg-/abfall geführt werden. Am Satzbeginn wird bis zum programmierten Vorschub beschleunigt und auf das Satzende mit maximal zulässiger Beschleunigung abgebremst. Bedingt durch das treppenförmige Beschleunigungsprofil treten beim Hochbeschleunigen und Bremsen der Achsen Rucksprünge auf. Bei schwingungskritischen Maschinenkonstruktionen kann sich dieses Verhalten negativ auswirken. Der große Vorteil liegt allerdings in dem optimalen Weg-Zeit-Verhalten, d.h. die Zeit für einen Bahnbewegungsabschnitt ist im Vergleich zu anderen Beschleunigungsverläufen am geringsten.

Für möglichst kleine Positionierzeiten ist also dieses Profil zu wählen.

Abbildung 1-2: Parameter des linearen Geschwindigkeitsprofils

Parametrierung

Das Beschleunigungsprofil besteht sowohl beim Anfahren als auch beim Abbremsen aus jeweils zwei Stufen, die mit zwei unterschiedlichen Beschleunigungen parametriert werden können. Die Stufe 1 wird mit dem Beschleunigungswert P-AXIS-00011, die Stufe 2 mit dem Beschleunigungswert P-AXIS-00012 sowohl beschleunigt als auch abgebremst. Mit P-AXIS-00221 wird die Umschaltgeschwindigkeit eingestellt, bei der auf den anderen Beschleunigungswert gewechselt wird. Das lineare Geschwindigkeitsprofil bzw. sprungförmige Beschleunigungsprofil bei einer typischen Parametrierungsvariante ist in Abbildung 1-2 dargestellt. Natürlich ist auch eine Einstellung möglich, bei dem der Beschleunigungswert 1 kleiner als der Beschleunigungswert 2 ist.

Parametrierung für Eilgang (G00)

Für dynamische Bewegungsabschnitte bei aktivem Eilgang (G00) steht ein weiterer Parametersatz zur Verfügung. In Stufe 1 wirkt der Beschleunigungswert P-AXIS-00005, in Stufe 2 der Beschleunigungswert P-AXIS-00006. Die Umschaltgeschwindigkeit ist im Eilgang mit dem Parameter P-AXIS-00211 parametrierbar.

Parametrierung
für Feedhold

Der Beschleunigungswert bei Vorschub-Stopp (Feedhold) zum Abbremsen bis zum Stillstand wird mit dem Parameter P-AXIS-00024 eingestellt.

Der Einfluß des Kanalparameters P-CHAN-00097 ist zu berücksichtigen (siehe Kapitel 1.2.9).


Ruckbegrenztes Standard- Beschleunigungsprofil

Beschreibung
und
Eigenschaften

Sowohl für Achsen im Bahnverbund als auch für unabhängige Achsen kann eine ruckbegrenzte Beschleunigung mit trapezförmigem oder sinusquadratförmigem Profil angewählt werden. Die Parametrierung erfolgt achsbezogen für beide Profile gleich. Das sinusquadratförmige Profil ermöglicht im Gegensatz zum trapezförmigen Profil weichere Beschleunigungs- und Bremsvorgänge.

Bei der ruckbegrenzten Beschleunigung wird die Bahnbewegung so geführt, dass die achsspezifischen Beschleunigungen keine sprungförmigen Änderungen aufweisen.

Für die HSC-Konturbearbeitung kann ein spezieller ruckbegrenzter Slope angewählt werden, der die Beschleunigung satzübergreifend optimal führt.

Bei schwingungskritischer Maschinenmechanik sind diese Profile zu verwenden. Die Rampenzeiten für den Beschleunigungsaufbau und Abbau sollten nur so groß wie erforderlich und so klein wie möglich eingestellt werden, da diese Parameter erheblichen Einfluß auf die Positionierzeiten haben.

Das ruckbegrenzte Beschleunigungsprofil kann in sieben Segmenten dargestellt werden (Abbildung 1-3).
I | Geschwindigkeitszunahme mit zunehmender Beschleunigung auf einen maximalen Beschleunigungswert innerhalb einer vorgegebenen Zeit.
II | Geschwindigkeitszunahme mit konstanter Beschleunigung.
III | Geschwindigkeitszunahme mit abnehmender Beschleunigung bis auf Beschleunigungswert 0 innerhalb einer vorgegebenen Zeit.
IV | Phase mit konstanter Geschwindigkeit, Beschleunigung 0
V | Geschwindigkeitsabnahme mit zunehmender Verzögerung auf einen maximalen Bremsbeschleunigungswert innerhalb einer vorgegebenen Zeit.
VI | Geschwindigkeitsabnahme mit konstanter Verzögerung.
VII | Geschwindigkeitsabnahme mit abnehmender Verzögerung bis auf die den Bremsbeschleunigungswert 0 innerhalb einer vorgegebenen Zeit.

Die Parameter in den Segmenten I, III, V und VII bestimmen den Achsruck, der durch das Beschleunigungsprofil verursacht wird.

Vorteile

Die Vorteile der ruckbegrenzten Beschleunigungsprofile sind:

q Bessere Ausnutzung der verfügbaren Maschinendynamik (z.B. Positionieren im Eilgang)

q Schonung der Mechanik durch Vermeidung von Stößen

q Geringe Schwingungsanregung

q Bessere Parametrierungsmöglichkeit von Verfahren zur Konturverbesserung (z.B. Vorsteuerung)

Abbildung 1-3: Parameter bei ruckbegrenztem Beschleunigungsprofil

Parametrierung

Die achsspezifischen Beschleunigungsrampen der ruckbegrenzten Beschleunigungsprofile werden durch Angabe einer maximalen Beschleunigung und einer maximalen Rampenzeit parametriert. Abbildung 1-3 zeigt die Profilverläufe von Geschwindigkeit, Beschleunigung und Ruck mit den entsprechenden Parametern.

Die maximale Beschleunigung bei zunehmender Geschwindigkeit wird mit P-AXIS-00001 eingestellt. Bei abnehmender Geschwindigkeit ist die maximale Verzögerung über den Parameter P-AXIS-00002 einzustellen. Die maximalen Rampenzeiten werden über die Parameter P-AXIS-00195, P-AXIS-00196, P-AXIS-00197 und P-AXIS-00198 festgelegt.

Mit den aufgeführten Parametern kann für jede Beschleunigungs- und Verzögerungsphase eine individuelle Beschleunigungsrampe eingestellt werden.

Bei der Parametrierung der Rampenzeit ist zu berücksichtigen, dass bei Rampenzeiten kleiner als die CNC-Zykluszeit das ruckbegrenzte Beschleunigungsprofil zum sprungförmigen Beschleunigungsprofil entartet.

Parametrierung für Eilgang (G00)

Für Bewegungen im Eilgang (G00) kann das ruckbegrenzte Beschleunigungsprofil mit steileren Beschleunigungsrampen parametriert werden. Alle Beschleunigungsrampen (Segmente: I, III, V, VII) werden mit der maximalen Bescheunigung P-AXIS-00004 und der maximalen Rampenzeit P-AXIS-00200 parametriert (Abbildung 1-4).

Abbildung 1-4: Parameter bei Ruckbegrenzung im Eilgang (G00)

Parametrierung
für Feedhold

Zum schnellen Abbremsen bei Vorschub-Stopp (Feedhold) bis zum Stillstand werden die Beschleunigungsrampen (Segmente: V, VII) mit der maximalen Beschleunigung P-AXIS-00053 und der maximalen Rampenzeit P-AXIS-00081 parametriert.

Der Einfluß des Kanalparameters P-CHAN-00097 ist zu berücksichtigen (siehe Kapitel 1.2.9).


Ruckbegrenztes HSC-Beschleunigungsprofil

Beschreibung
und
Eigenschaften

Dieses Profil kann für Bahnbewegungen aktiviert werden und ist bei kurzen Sätzen von Vorteil, wenn die Beschleunigung über relativ viele Sätze aufgebaut und wieder abgebaut werden muss.

Die Parametrierung der Beschleunigungsrampen bei Vorschubsätzen ist identisch mit den ruckbegrenzten Standardprofilen, allerdings erscheint die Parametrierung von unterschiedlichen Beschleunigungs- und Bremswerten im HSC-Bereich als wenig sinnvoll.

Die Einstellung der Profilparameter bei Eilgangsatz und Feedhold entspricht ebenso dem des ruckbegrenzten Standardprofils.

Unterschiede sind bei der Wirksamkeit der Rampenzeitparameter bei Vorschubsätzen vorhanden.

Als Rampenzeit wird das Maximum der Parameter P-AXIS-00195 , P-AXIS-00196 , P-AXIS-00197 und P-AXIS-00198 verwendet. Die Aufbau- und Abbauzeiten der Beschleunigung bzw. Verzögerung sind also identisch.

Abbildung 1- 5 : Parameter bei HSC Ruckbegrenzung und Vorschubsatz

Bestimmung der Rampenzeit und Optimierung

Bei Vorgabe der maximal zulässigen Beschleunigung und des maximal zulässigen Rucks kann die Rampenzeit entsprechend nachfolgender Gleichung bestimmt werden:

mit tr: Rampenzeit, j: zulässiger Ruck, a: zulässige Beschleunigung

Beispiel: a: 1000mm/s2, j: 20m/s3

getriebe[0].slope_profil.a_grenz 1000

getriebe[0].slope_profil.tr_grenz 50000

Die nachfolgende Prüfung empfiehlt sich, wenn die Dynamik der CNC Achsen auf die Antriebsdynamik eingestellt sind, die Antriebe beim Positionieren durch die CNC weit unterhalb der jeweils zulässigen Beschleunigungsgrenzwerte betrieben werden.

Abhängig von der maximalen Achsgeschwindigkeit bei Vorschubsätzen (P-AXIS-00212) bzw. Achsgeschwindigkeit bei G00 (P-AXIS-00209) lassen sich die Einstellungen für das ruckbegrenzte Beschleunigungsprofil u. U. optimieren.

Die Rampenzeit ist möglichst klein zu halten, da diese bei den Positionierzeiten ins Gewicht fallen.

Das Produkt aus Rampenzeit und Beschleunigung ergibt die Geschwindigkeitsdifferenz, die benötigt wird, damit die Beschleunigung voll aufgebaut werden kann. Ist dies nicht der Fall, so kann unter Berücksichtigung von (1) eine Parameterkorrektur durchgeführt werden.

Beispiel:

getriebe[0].vb_eilgang 100000

getriebe[0].slope_profil.a_grenz 5000

getriebe[0].slope_profil.tr_grenz 100000

Aus den genannten Parametern ergibt sich die Geschwindigkeitsdifferenz d_v = 500 000μm/s. Mit der angegebenen Parametrierung der Eilganggeschwindigkeit kann also die Eilgangbeschleunigung nie vollständig aufgebaut werden. Sofern sich die Eilganggeschwindigkeit nicht erhöhen läßt und der maximale Ruck beibehalten werden soll, empfiehlt sich die gleichzeitige Reduktion von Beschleunigung und Rampenzeit.

Man erhält bei unveränderter Eilganggeschwindigkeit:

getriebe[0].slope_profil.a_grenz 2200

getriebe[0].slope_profil.tr_grenz 45000

Kann der Ruck erhöht werden, so empfiehlt sich die alleinige Reduzierung der Rampenzeit.

getriebe[0].slope_profil.a_grenz 5000

getriebe[0].slope_profil.tr_grenz 20000

(1) Die Reduktion der Achsbeschleunigung hat Einfluß auf die maximal mögliche Bahngeschwindigkeit an Satzgrenzen mit nicht tangentialen Übergängen und bei gekrümmten Konturen wie Kreis oder Polynom.


Ruckbegrenzung und Kontur

Die nachfolgend beschriebenen Parameter in Kap. 1.2.3 sind nur in Verbindung mit den ruckbegrenzten Beschleunigungsprofilen relevant !

Mehr:

button Konturverlauf mit nicht tangentenstetigen Satzgrenzen

button Konturverlauf mit tangentenstetigen Satzgrenzen

button Ruckbegrenzung innerhalb der Kontur


Konturverlauf mit nicht tangentenstetigen Satzgrenzen

Beschreibung

An nicht tangentenstetigen Satzübergängen von Konturen wie z.B. Linearsätze bei einem prismatischen Werkstück treten Achsbeschleunigungssprünge auf, die zu sehr hohen Achsrücken führen wenn am Satzübergang die Bahngeschwindigkeit nicht auf 0 reduziert wird. Unabhängig davon stellt die Steuerung sicher, dass dabei die Beschleunigungssprünge unterhalb der Maximalbeschleunigungen der betroffenen Achsen liegen. Nachfolgend ist dies anhand des Geschwindigkeits-, Beschleunigungs- und Ruckverlaufs eines 45 Grad Knicks zwischen zwei Linearsätzen dargestellt.

Parametrierung

Über den Parameter P-AXIS-00013 wird die zulässige Beschleunigung am Satzübergang gewichtet.

Durch den Wert 0 wird die Ruckbegrenzung aktiviert, es gilt die Gewichtung der zulässigen Beschleunigung mit dem Faktor von Zykluszeit / Rampenzeit. Damit wird der zulässige Achsruck eingehalten. Es ergibt sich eine sehr niedrige Geschwindigkeit am Satzübergang.

Sollen höhere Geschwindigkeiten mit entsprechend höherem Achsruck am Satzübergang gefahren werden, wird der Parameter hoch eingestellt. Bei dem Wert 1000 (oberer Grenzwert) wird am Satzübergang die Maximalbeschleunigung eingehalten, der Ruck übersteigt die eingestellten Grenzwerte.

atrans = a * (P-AXIS-00013) / 1000.

jtrans = atrans /tzykl.

Ein Wert > 0 kann dann sinnvoll sein wenn es aus technologischen Gründen unerwünscht ist, das sich abhängig von der eingestellten Beschleunigung an geringfügig unstetigen Satzübergängen ein Einbruch der Bahngeschwindigkeit ergibt.

Ein Wert < 1000 kann dann sinnvoll sein, wenn die Maschine sehr schwingungskritisch ist.

Der Einfluss der Ruckbegrenzung bei P-AXIS-00013 = 0 auf die Satzübergangsgeschwindigkeit zwischen zwei nicht tangentenstetigen Bewegungssätzen und unterschiedlichen Knickwinkeln ist unten dargestellt.

Parametrierungsbeispiel

Auszug aus der Achsparameterliste:

mit Ruckbegrenzung

getriebe[0].dynamik.a_trans_weight 0

ohne Ruckbegrenzung

getriebe[0].dynamik.a_trans_weight 1000


Konturverlauf mit tangentenstetigen Satzgrenzen

Beschreibung

An tangentenstetigen Satzübergängen von Linear zu Zirkularsatz und umgekehrt bzw. bei Kreis-Kreis Konturen mit Radiusänderung oder Drehrichtungsänderung tritt ein Sprung in der Achsbeschleunigung und damit ein relativ großer Achsruck auf auch wenn die Bahngeschwindigkeit konstant ist. Im folgenden sind hier einige Beispiele mit Darstellung von Geschwindigkeit, Beschleunigung und Ruck in den Achsen aufgeführt.

1. Satzübergang Linearsatz -> Zirkularsatz

2. Satzübergang Kreis -> Kreis mit Drehrichtungsänderung G03 -> G02

3. Satzübergang Kreis -> Kreis mit Radiusänderung r2 != r1

Parametrierung

Die Ruckbegrenzung an tangentenstetigen Satzübergängen kann über den Kanalparameter P-CHAN-00009 aktiviert bzw. deaktiviert werden !

Über den Parameter P-AXIS-00154 wird der zulässige Ruck am Satzübergang von tangentenstetigen Konturen gewichtet. Mit dem Wert 1000 hat der Parameter den geringsten Einfluss auf die Geschwindigkeit am Satzübergang. Der Ruck ist hoch und entspricht dem Verhältnis von aktueller Beschleunigung zu Zykluszeit. Kleinere Werte als 1000 führen zu einer weiteren Reduktion der Geschwindigkeit am Satzübergang. Der Wert 0 führt zu einer Geschwindigkeitsreduktion, so dass der zulässige Ruck am Satzübergang entsprechend den Rampenzeitparametern P-AXIS-00195..- P-AXIS-00198 und den Beschleunigungsparametern P-AXIS-00011 und P-AXIS-00012 eingehalten wird.

jtrans = (P-AXIS-0004 / tr)*(P-AXIS-00154) / 1000.

Ein Wert > 0 bzw. eine eingeschränkte Ruckbegrenzung an tangentenstetigen Satzübergängen kann dann sinnvoll sein, wenn es aus technologischen Gründen unerwünscht ist, das sich abhängig vom eingestellten Ruck an tangentenstetigen Satzübergängen ein Einbruch der Bahngeschwindigkeit ergibt.

Ein Wert < 1000 kann dann sinnvoll sein, wenn die Maschine sehr schwingungskritisch ist und es aus technologischer Sicht und im Hinblick auf die Bearbeitungszeit zulässig ist, das die Bahngeschwindigkeit an tangentenstetigen Satzgrenzen einen relativ geringen Wert annimmt.

Der Einfluss der Ruckbegrenzung auf den Bahngeschwindigkeitsverlauf bei einer tangentenstetigen Kontur mit Linear und Zirkularsätzen ist unten dargestellt. Es wird angenommen das die Bahngeschwindigkeit im Kreis aufgrund der zulässigen Achsbeschleunigungen reduziert wird.

Bahngeschwindigkeitsverlauf

- ohne Ruckbegrenzung am Satzübergang

- mit Ruckbegrenzung am Satzübergang

Parametrierungsbeispiel

Ruckbegrenzung am Satzübergang:

Auszug aus der Achsparameterliste:

getriebe[0].dynamik.a_trans_weight 0

getriebe[0].dynamik.r_trans_weight 0

Auszug aus der Kanalparameterliste:

corr_v_trans_jerk 1

Keine Ruckbegrenzung am Satzübergang:

getriebe[0].dynamik.a_trans_weight 1000

getriebe[0].dynamik.r_trans_weight 1000

Sofern eine Sollkonturabweichung zulässig ist, kann durch Einsatz von Konturbeeinflussenden Verfahren wie z.B. dem Polynomüberschleifen im allgemeinen eine höher Satzübergangsgeschwindigkeit an Konturknicken oder tangentenstetigen Übergängen mit aktiver Ruckbegrenzung gefahren werden. Dies ist beispielhaft im untenstehenden Diagramms anhand eines nicht tangentenstetigen Satzübergangs mit einem Knickwinkel von 1 Grad dargestellt. Im Gegensatz zur Satzübergangsgeschwindigkeit ohne Überschleifen kann hier schon bei relativ kleinem Konturfehler mit relativ großer Bahngeschwindigkeit am Satzübergang gefahren werden.


Ruckbegrenzung innerhalb der Kontur

Parametrierung

Über den Parameter P-AXIS-00199 wird die Rampenzeit von geometrischen Konturen festgelegt. Beim Durchfahren eines Kreises oder eines Polynoms mit konstantem Vorschub lässt sich damit der auftretende Maximalruck begrenzen, der sich aufgrund der Konturkrümmung ergibt. Der Einfluss von Krümmungsänderungen auf den Ruck beim Ein-/und Austritt aus dem Konturabschnitt wird hierbei nicht berücksichtigt.

Bei Polynomkurven ist zusätzlich der Einfluss des Parameters P-CHAN-00110 zu berücksichtigen.

Der zulässige Ruck aufgrund geometrischer Konturen ergibt sich in der Defaulteinstellung aus dem Parameter P-AXIS-00199 und den Beschleunigungsparametern P-AXIS-00011 und P-AXIS-00012 bzw. P-AXIS-00004 abhängig vom Bewegungssatztyp wie folgt:

Beispiele:

Vorschubsatz: a=1m/s2, trgeom. = 0.1s, jgeom = 10m/s3

Eilgangsatz: a=2m/s2, trgeom. = 0.1s, jgeom = 20m/s3

Auszug aus der Achsparameterliste:

getriebe[0].slope_profil.a_beschl 1000

getriebe[0].slope_profil.a_brems 1000

getriebe[0].slope_profil.a_grenz 2000

.........

getriebe[0].dynamik.tr_geom 100000


Notfallbeschleunigung

Parametrierung

Über den Parameter P-AXIS-00003 wird die verwendete Beschleunigung im Notfall definiert. Bei bestimmten Fehlern führt die CNC die Notfallreaktion mit Fehlerreaktionsklasse 4 aus. Hierbei wechselt die CNC unabhängig vom aktuell aktivierten Beschleunigungsprofil auf das sprungförmige Beschleunigungsprofil und bremst achsspezifisch mit dieser Beschleunigung ab. Die Bahnkontur wird hierbei verlassen !

Auszug aus der Achsparameterliste:

getriebe[0].dynamik.a_emergency 5000


Auswahl / Modifikation des Beschleunigungsprofils

Mehr:

button Profiltyp und Gewichtungswirkung

button Bahnspezifische Dynamikbegrenzung


Profiltyp und Gewichtungswirkung

Parametrierung der Kanalparameter

Wirkung der Rampenzeitgewichtung

Mit dem Parameter P-CHAN-00073 aus der Kanalparameterliste kann eingestellt werden, auf welche Beschleunigungsrampe die Rampenzeitgewichtungen der NC-Funktionen G132 und G133 [PROG] wirken soll. Dieser Parameter ist haltend wirksam.

Wirkung der Beschleunigungsgewichtung

Mit dem Parameter P-CHAN-00001 aus der Kanalparameterliste kann eingestellt werden, auf welche Beschleunigung die Beschleunigungsgewichtungen der NC-Funktionen G130 und G131 [PROG] wirken soll. Dieser Parameter ist haltend wirksam.

Beispiele:

Bei Programmstart soll als Default das sprungförmige Beschleunigungsprofil aktiviert werden. Die Gewichtung wirkt auf alle Beschleunigungen.

Auszug aus der Kanalparameterliste:

prog_start.slope.profile 0

prog_start.slope.acceleration 0

Bei Programmstart soll das trapezförmige Beschleunigungsprofil initialisiert werden. Die Rampenzeitgewichtung wirkt auf alle Rampenzeiten und die Beschleunigungsgewichtung wirkt auf die Beschleunigung bei abnehmender Geschwindigkeit P-AXIS-00002.

Auszug aus der Kanalparameterliste:

prog_start.slope.profile 1

prog_start.slope.ramp_time 0

prog_start.slope.acceleration 2


Bahnspezifische Dynamikbegrenzung

Parametrierung der Kanalparameter

Wenn aus technologischen Gründen die Bahngeschwindigkeit unabhängig vom programmierten F Wort bestimmte Grenzwerte nicht überschreiten darf, kann über P-CHAN-00090 ein Maximalwert festgelegt werden, der bei Aktivierung im NC Programm die von der CNC berechnete Bahngeschwindigkeit begrenzt.

Wenn aus technologischen Gründen die Bahnbeschleunigung bestimmte Grenzwerte nicht überschreiten darf, kann über P-CHAN-00002 ein Maximalwert festgelegt werden, der bei Aktivierung im NC Programm die von der CNC berechnete Bahnbeschleunigung begrenzt.

Die Begrenzung der Bahnbeschleunigung wirkt nur bei Vorschubbewegungen d.h. bei G01, G02, G03 Bewegungssätzen bzw. bei Polynom- oder Spline-Konturen basierend auf G01, G02, G03 Sätzen.

Beispiel:

Auszug aus der Kanalparameterliste:

vector.velocity 1500

vector.acceleration 1800000

Über die Befehle #VECTORACC, #VECTORVEL [PROG] kann die Bahnspezifische Dynamikbegrenzung aktiviert werden.

Die Dynamikbegrenzung aufgrund der achsspezifischen Grenzwerte bleibt hiervon unberührt !

Bei Verwendung der oben aufgeführten bahnspezifischen Begrenzungsfunktionen kann sich bei Vorschubsätzen abhängig vom Parameter P-CHAN-00097 eine erhebliche Bremswegverlängerung nach Aktivierung von Feedhold ergeben. Bei Einsatz der oben aufgeführten Funktion zur Beschleunigungsbegrenzung wird deshalb empfohlen, den Parameter P-CHAN-00097 auf 1 zu setzen (siehe auch Kapitel1.2.9).

Beispiel:

Auszug aus der Kanalparameterliste:

use_drive_curr_limit 1


Dynamische Grenzwerte für Handbetrieb

Parametrierung

Bei aktivem Handbetrieb ist der Profilverlauf von den eingestellten Rampenzeiten P-AXIS-00359 und P-AXIS-00360 abhängig. Der Wert P-AXIS-00360 wird bei aktivem Vorschub-Stopp verwendet.

Sind diese Werte nicht oder mit 0 belegt so springt die Beschleunigung auf den Wert der gewichteten ( P-AXIS-00082 ) Beschleunigung P-AXIS-00011 oder der Beschleunigung P-AXIS-00009 , P-AXIS-00259 abhängig vom Slopetyp und dem angewählten Handbetriebsmodus (inklusiv oder exklusiv). Im anderen Fall wird die entsprechende Beschleunigung linear über die Zeit auf- und abgebaut (Trapezform). Die Rampenzeitparameter können unabhängig von den Parametern für die Bahnbewegung eingestellt werden.

Bei Aktivierung des exklusiven Handbetriebs G200 [PROG] sind als Maximalwert für die Beschleunigung P-AXIS-00009, als Maximalwert für die Geschwindigkeit P-AXIS-00213 zu berücksichtigen. Über den Parameter P-AXIS-00259 kann der Beschleunigungswert für den Bremsvorgang bei Vorschub-Stopp eingestellt werden. Damit diese Funktion wirksam ist muss der Kanalparameter P-CHAN-00097 auf 1 gesetzt sein.

Bei Aktivierung des inklusiven Handbetriebs G201 [PROG] wird die Dynamik einer Achse über eine prozentuale Gewichtung zwischen dem Handbetrieb und dem Bahnbetrieb aufgeteilt.

Als Maximalwert für die Summenbeschleunigung aus Handbetrieb und Bahnbetrieb ergibt sich die maximal zulässige Achsbeschleunigung P-AXIS-00008. Als maximale Achsgeschwindigkeit wird P-AXIS-00212 berücksichtigt.

Über P-AXIS-00083 wird der prozentuale Geschwindigkeitsanteil für den Handbetrieb eingestellt.

Über P-AXIS-00095 wird der prozentuale Geschwindigkeitsanteil für den Bahnbetrieb eingestellt.

Über P-AXIS-00082 wird der prozentuale Beschleunigungsanteil für den Handbetrieb eingestellt.

Über P-AXIS-00094 wird der prozentuale Beschleunigungsanteil für den Bahnbetrieb eingestellt.

Beispiel:

Auszug aus der Achsparameterliste:

handbetrieb.hb.a_feedh 5000

handbetrieb.hb.tr 50000

handbetrieb.hb.tr_feedh 25000

G200 Modus:

handbetrieb.hb.vb_max 60000

handbetrieb.hb.a_max 300

G201 Modus:

handbetrieb.ipo.hb_proz_v_max 30

handbetrieb.ipo.hb_proz_a_max 30

handbetrieb.ipo.ipo_proz_v_max 70

handbetrieb.ipo.ipo_proz_a_max 70

Aufgrund der Wegtreue des Handbetriebsmoduls ist die maximal zulässigen Geschwindigkeit bei Handradbetrieb so einzustellen, dass es nicht zu einem unnötig langen Bewegungsnachlauf bei Handradbetrieb kommt. Der pro CNC -Takt vorgegebene Weg sollte also die Maximalgeschwindigkeit nicht überschreiten.

Ebenso sind die inkrementellen Jogggeschwindigkeiten mit der maximal zulässigen Geschwindigkeit bei Handbetrieb abzugleichen so dass es nicht zu einem unnötig langen Bewegungsnachlauf nach Betätigung der Jogg Tasten kommt. Bei relativ kleinen Beschleunigungen ist immer mit einer gewissen Nachlaufzeit bei Loslassen der Jogg Taste zu rechnen.


Parameter für Referenzpunktfahrt

Parametrierung

Die nachfolgenden Parameter sind nur bei CNC-geführter Referenzpunktfahrt von Bedeutung. Bei Verwendung digitaler intelligenter Antriebe wird die Referenzpunktfahrt im allgemeinen vom Antrieb selbst mit antriebsspezifischen Parametern durchgeführt.

Die CNC verwendet bei Programmierung der Referenzpunkfahrt über G74 [PROG] das über den Parameter P-AXIS-00270 eingestellte Beschleunigungsprofil. Als Beschleunigungswert wird P-AXIS-00285 verwendet, die Rampenzeit in Verbindung mit nichtlinearen Profilen wird über P-AXIS-00286 eingestellt.

Auszug aus der Achsparameterliste:

getriebe[0].slope_type 1

getriebe[0].a_ref 500

getriebe[0].tr_ref 200000

Ohne explizite Parametrierung wird das lineare Profil verwendet, a_ref wird mit dem Minimum von P-AXIS-00005 und P-AXIS-00006 belegt.

Über P-AXIS-00218 wird die langsame Geschwindigkeit bei der Nocken und Nullimpulssuche eingestellt.

Über P-AXIS-00219 wird die schnelle Geschwindigkeit bei der Nocken und Nullimpulssuche eingestellt.

Auszug aus der Achsparameterliste:

getriebe[0].vb_refmax 20000

getriebe[0].vb_reflow 2000


Absolute Grenzwerte

Konstanten

Die nachfolgend aufgelisteten Konstanten sind applikationsspezifisch und begrenzen die maximalen Dynamikkenngrößen.

Diese Werte sind so gewählt, das bei den heute üblichen und möglichen Dynamikkenngrößen im allgemeinen kein Begrenzungseffekt auftritt.

Max. parametrierbare Achsgeschwindigkeit (SLOPE_VB_MAX)

Diese Konstante begrenzt die maximal zulässige Achsgeschwindigkeit P-AXIS-00212 .

Max. parametrierbare Achsbeschleunigung (SLOPE_BESCHL_MAX)

Diese Konstante begrenzt die maximal zulässige Achsbeschleunigung P-AXIS-00008.

Min. parametrierbare Rampenzeit (STD_TR_MIN)

Diese Konstante begrenzt die minimal zulässige Rampenzeit P-AXIS-00201 und die geometrische Rampenzeit P-AXIS-00199.

Max. parametrierbare Rampenzeit (STD_TR_MAX)

Diese Konstante begrenzt die Rampenzeiten P-AXIS-00081 und P-AXIS-00195P-AXIS-00200

Max. möglicher Geschwindigkeitsoverride (MAX_VB_OVERRIDE)

Diese Konstante begrenzt den maximalen Geschwindigkeits-Override P-AXIS-00109 .


Steuerflags

Parametrierung

Über den Parameter P-CHAN-00009 kann die Ruckbegrenzung an tangentialen Satzübergängen aktiviert werden. Ein Rucksprung tritt z. B. an tangentialen Übergängen zwischen zwei Kreisen mit unterschiedlichen Radien oder zwischen Kreis und Linearsatz auf.

Auszug aus der Kanalparameterliste:

corr_v_trans_jerk 1

Der oben genannte Parameter ist nur in Verbindung mit dem ruckbegrenzten Beschleunigungsprofil wirksam.

Über den Parameter P-CHAN-00110 kann die Ruckbegrenzung im Polynomsätzen aktiviert werden. Bei Zirkularsätzen ist die Rucküberwachung immer aktiv.

Polynomsätze werden in Verbindung mit Polynomüberschleif-, Spline- und HSC- Funktionen in der CNC erzeugt..

Auszug aus der Kanalparameterliste:

check_jerk_on_poly_path 1

Über den Parameter P-CHAN-00097 wird der Bremsmodus der CNC bei aktivem Vorschub Stopp ausgewählt. Bei gesetztem Flag wird der Feedhold-Parametersatz für den Bremsvorgang verwendet, d.h. es kann z. B. mit höherer Beschleunigung als bei der aktiven Teilebearbeitung oder Positionierung gebremst werden.

Auszug aus der Kanalparameterliste:

use_drive_curr_limit 1

Entsprechend den Beschreibungen für das ruckbegrenzte Beschleunigungsprofil ist hierbei zu beachten:

q Die Erhöhung der Verzögerungswerte bei konstanten Ruck führt noch nicht automatisch zu einem kürzeren Bremsweg. Beim ruckbegrenzten Profil hängt dies auch von der Rampenzeit und der abzubauenden Geschwindigkeitsdifferenz ab. Der Grenzfall ist in Kapitel 1.2.2.2 beschrieben.


Parametrierung

Mehr:

button Übersicht

button Beschreibung

button Beispiel Kanalliste

button Beispiel Achsliste


Übersicht

Konstante | Beschreibung
SLOPE_VB_MAX | maximal zulässige Achsgeschwindigkeit [SYSP,11.1]
SLOPE_BESCHL_MAX | maximal zulässige Achsbeschleunigung [SYSP,11.2]
STD_TR_MIN | minimal zulässige Rampenzeit [SYSP,11.3]
STD_TR_MAX | maximale Rampenzeit [SYSP,11.4]
MAX_VB_OVERRIDE | maximal zulässiger Override [SYSP,11.5]

Mehr:

button Kanalparameter

button Achsparameter


Kanalparameter

ID | Parameter | Beschreibung
P-CHAN-00001 | acceleration | Wirkung der Beschleunigungsgewichtung
P-CHAN-00071 | profile | Standard-Beschleunigungsprofil
P-CHAN-00073 | ramp_time | Wirkung der Rampenzeitgewichtung
P-CHAN-00009 | corr_v_trans_jerk | Ruckbegrenzung am tangentialen Satzübergang
P-CHAN-00097 | use_drive_curr_limit | Bremsverhalten bei Feedhold
P-CHAN-00110 | check_jerk_on_poly_path | Ruckbegrenzung im Polynom
P-CHAN-00056 | max_vb_override | Maximaler Kanaloverride
P-CHAN-00002 | acceleration | Maximale Bahnbeschleunigung
P-CHAN-00090 | velocity | Maximale Bahngeschwindigkeit


Achsparameter

Allgemeine Parameter

ID | Parameter | Beschreibung
P-AXIS-00003 | a_emergency | Achsbeschleunigung bei Notfall
P-AXIS-00008 | a_max | Maximal zulässige Achsbeschleunigung
P-AXIS-00209 | vb_eilgang | Geschwindigkeit im Eilgang(G00)
P-AXIS-00212 | vb_max | Maximal zulässige Achsgeschwindigkeit
P-AXIS-00214 | vb_max_red | Reduzierte Geschwindigkeit bei G01, G02, G03
P-AXIS-00155 | rapid_speed_red | Reduzierte Geschwindigkeit bei G00
P-AXIS-00030 | vb_max_red_zone | Reduzierte Geschwindigkeit im Sicherheitsbereich
P-AXIS-00219 | vb_refmax | Maximale Geschwindigkeit für Nocken- und Nullimpulssuche
P-AXIS-00218 | vb_ref_low | Minimale Geschwindigkeit für Nocken- und Nullimpulssuche
P-AXIS-00285 | a_ref | Beschleunigung bei CNC-geführter Referenzpunktfahrt

Parameter des sprungförmigen Beschleunigungsprofils

ID | Parameter | Beschreibung
P-AXIS-00005 | a_grenz_stufe_1 | Beschleunigung in der Stufe 1 im Eilgang (G00)
P-AXIS-00006 | a_grenz_stufe_2 | Beschleunigung in der Stufe 2 im Eilgang (G00)
P-AXIS-00011 | a_stufe_1 | Beschleunigung in der Stufe 1
P-AXIS-00012 | a_stufe_2 | Beschleunigung in der Stufe 2
P-AXIS-00024 | a_feedh | Beschleunigung bei Vorschub-Stopp (Feedhold)
P-AXIS-00211 | vb_grenz_stufe_1_2 | Umschaltgeschwindigkeit zwischen den Beschleunigungs-stufen im Eilgang (G00)
P-AXIS-00221 | vb_stufe_1_2 | Umschaltgeschwindigkeit zwischen den Beschleunigungs-stufen

Parameter der ruckbegrenzten Beschleunigungsprofile

ID | Parameter | Beschreibung
P-AXIS-00001 | a_beschl | Beschleunigung bei zunehmender Geschwindigkeit
P-AXIS-00002 | a_brems | Beschleunigung bei abnehmender Geschwindigkeit
P-AXIS-00004 | a_grenz | Beschleunigung im Eilgang (G00)
P-AXIS-00053 | a_feedh | Beschleunigung bei Vorschub-Stopp (Feedhold)
P-AXIS-00081 | tr_feedh | Rampenzeit bei Vorschub-Stopp (Feedhold)
P-AXIS-00195 | tr_beschl_ab | Rampenzeit für Beschleunigungsabbau
P-AXIS-00196 | tr_beschl_zu | Rampenzeit für Beschleunigungsaufbau
P-AXIS-00197 | tr_brems_ab | Rampenzeit für Verzögerungsabbau
P-AXIS-00198 | tr_brems_zu | Rampenzeit für Verzögerungsaufbau
P-AXIS-00200 | tr_grenz | Rampenzeit im Eilgang (G00)
P-AXIS-00199 | tr_geom | Geometrische Rampenzeit
P-AXIS-00186 | tr_ref | Rampenzeit bei Referenzpunktfahrt
P-AXIS-00201 | tr_min | Minimal zulässige Rampenzeit
P-AXIS-00013 | a_trans_weight | Gewichtung der Beschleunigung am Satzübergang
P-AXIS-00154 | r_trans_weight | Gewichtung des Rucks am Satzübergang

Parameter für Handbetrieb

ID | Parameter | Beschreibung
P-AXIS-00082 | hb_proz_a_max | Prozentuale Beschleunigung für Handbetrieb (G201)
P-AXIS-00083 | hb_proz_v_max | Prozentuale Geschwindigkeit für Handbetrieb (G201)
P-AXIS-00094 | ipo_proz_a_max | Prozentuale Beschleunigung für Bahnbetrieb (G201)
P-AXIS-00095 | ipo_proz_v_max | Prozentuale Geschwindigkeit für Bahnbetrieb (G201)
P-AXIS-00009 | a_max | Maximale Beschleunigung bei Handbetrieb (G200)
P-AXIS-00213 | vb_max | Maximale Geschwindigkeit bei Handbetrieb (G200)


Beschreibung

Mehr:

button Kanalparameter

button Achsparameter


Kanalparameter

P-CHAN-00001 | Wirkung der Beschleunigungsgewichtung
Parameter | prog_start.slope.acceleration
Beschreibung | Mit diesem Parameter kann eingestellt werden, auf welche Beschleunigung die Beschleunigungsgewichtungen der Funktionen G130 und G131 [PROG] wirken soll. Dieser Parameter ist haltend wirksam.
Datentyp | SGN16
Datenbereich | 0: Gewichtung wirkt auf alle Beschleunigungen 1: Gewichtung wirkt auf P-AXIS-00001 (a_beschl) 2: Gewichtung wirkt auf P-AXIS-00002 (a_brems)
Dimension | -
Standardwert | 0
Anmerkungen | Dieser Parameter ist nicht für unabhängige Achsen wirksam.

P-CHAN-00071

Standard-Beschleunigungsprofil

Parameter

prog_start.slope.profile

Beschreibung

Einstellung des angewählten Standard-Beschleunigungsprofils.

Datentyp

SGN16

Datenbereich

0: Sprungförmiges Beschleunigungsprofil

1: Trapezförmiges Beschleunigungsprofil

2: Sinusquadratförmiges Beschleunigungsprofil

3: Trapezförmiges HSC-Beschleunigungsprofil

Dimension

-

Standardwert

0

Anmerkungen

Das Beschleunigungsprofil und die zugehörige Beschleunigungs- und Rampenzeitgewichtung kann im NC-Programm mit dem Befehl #SET SLOPE PROFIL programmiert werden [PROG] .

Für jede unabhängige Achse kann das Beschleunigungsprofil auch im NC-Programm einzeln mit dem Schlüsselwort INDP_SYN bzw. INDP_ASYN programmiert werden [PROG] .

P-CHAN-00073 | Wirkung der Rampenzeitgewichtung
Parameter | prog_start.slope.ramp_time
Beschreibung | Mit diesem Parameter kann eingestellt werden, auf welche Rampenzeiten die Funktionen G132 und G133 [PROG] wirken. Dieser Parameter ist haltend wirksam.
Datentyp | SGN16
Datenbereich | 0: Gewichtung wirkt auf alle Rampenzeiten 1: Gewichtung wirkt auf tr_beschl_zu 2: Gewichtung wirkt auf tr_beschl_ab 3: Gewichtung wirkt auf tr_brems_zu 4: Gewichtung wirkt auf tr_brems_ab
Dimension | -
Standardwert | 0
Anmerkungen | Dieser Parameter ist nicht für unabhängige Achsen wirksam.

P-CHAN-00078 | Maximaler Kanaloverride
Parameter | max_vb_override
Beschreibung | Begrenzung des Overridewertes
Datentyp | UNS32
Datenbereich | 0..1000
Dimension | -
Standardwert | 1000
Anmerkungen | -

P-CHAN-00002 | Maximale Bahnbeschleunigung
Parameter | vector.acceleration
Beschreibung | Begrenzung der Bahnbeschleunigung. Die Aktivierung/Deaktivierung und Änderung der Grenzwerte erfolgt über einen NC Befehl. (siehe auch [PROG] )
Datentyp | REAL64
Datenbereich | 0 SLOPE_BESCHL_MAX
Dimension | mm/min2
Standardwert | 0
Anmerkungen | -

P-CHAN-00090 | Maximale Bahngeschwindigkeit
Parameter | vector.velocity
Beschreibung | Begrenzung der Bahngeschwindigkeit. Die Aktivierung/Deaktivierung und Änderung der Grenzwerte erfolgt über einen NC Befehl. (siehe auch [PROG] )
Datentyp | REAL64
Datenbereich | 0 SLOPE_VB_MAX
Dimension | mm/min
Standardwert | 0
Anmerkungen | -

P-CHAN-00097 | Steuerflag für Beschleunigungswert bei Feedhold
Parameter | use_drive_curr_limit
Beschreibung | Aktivierung der Feedholdbeschleunigung. Bei Feedhold wird abhängig vom Profiltyp mit der Feedhold-Beschleunigung P-AXIS-00024 bzw. P-AXIS-00053 gebremst
Datentyp | BOOLEAN
Datenbereich | 0: Bei Vorschub Stopp wird mit Standardverzögerung gebremst 1: Bei Vorschub Stopp wird der Feedhold-Verzögerung gebremst.
Dimension | -
Standardwert | 0
Anmerkungen | -

P-CHAN-00009 | Steuerflag für Ruckbegrenzung an tangentialen Satzübergängen
Parameter | corr_v_trans_jerk
Beschreibung | Aktivierung der Ruckbegrenzung an tangentialen Satzübergängen (Geschwindigkeitsstetiger Übergang). Der zulässige Ruck ergibt sich aus der aktiven Beschleunigung und Rampenzeit bei G01, G02, G03 oder G00 Bewegungssätzen.
Datentyp | BOOLEAN
Datenbereich | 0: Keine Ruckbegrenzung an tangentialen Satzübergängen 1: Ruckbegrenzung an tangentialen Satzübergängen
Dimension | -
Standardwert | 0
Anmerkungen | Abhängig vom zulässigen Ruck kann der Vorschub an tangentialen Satzübergängen wie z.B. Gerade -> Kreis stark reduziert werden. Ist dies z. B. aus technologischen Gründen nicht erwünscht so ist die Funktion zu deaktivieren.

P-CHAN-00110 | Steuervariable für Ruckbegrenzung im Polynom
Parameter | Check_jerk_on_poly_path
Beschreibung | Aktivierung der Ruckbegrenzung im Polynom
Datentyp | UNS32
Datenbereich | 0: Rucküberwachung im Polynom inaktiv 1: Rucküberwachung aktiv, maximal zulässige Ruckzeit über P-AXIS-00199 2: Rucküberwachung aktiv, maximal zulässige Ruckzeit über Minimum von P-AXIS-00195 , P-AXIS-00196 , P-AXIS-00197 , P-AXIS-00198
Dimension | -
Standardwert | 0
Anmerkungen | Abhängig von der Maschinenstruktur kann es bei sehr schwingungskritischen Maschinen erforderlich sein auch bei Überschleifvorgängen mit Ruckbegrenzung zu fahren. In diesem Fall ist die Funktion zu aktivieren. Die Überwachung kann auch über einen NC-Befehl aktiviert werden. [PROG]


Achsparameter

Mehr:

button Allgemeine Parameter

button Linearer Slope

button Nicht linearer Slope


Allgemeine Parameter

P-AXIS-00008 | Maximal zulässige Achsbeschleunigung
Parameter | getriebe[i].dynamik.a_max
Beschreibung | Maximal zulässige Achsbeschleunigung
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00008 ≤ SLOPE_BESCHL_MAX
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | -

P-AXIS-00003 | Notfallbeschleunigung
Parameter | getriebe[i].dynamik.a_emergency
Beschreibung | Über diesen Parameter wird die verwendete Beschleunigung im Notfall definiert. Bei bestimmten Fehlern bremst die CNC achsspezifisch mit dieser Beschleunigung ab. Achtung: Die Bahn wird hierbei verlassen !
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00003 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | P-AXIS-00008
Anmerkungen | -

P-AXIS-00212

Maximal zulässige Achsgeschwindigkeit

Parameter

getriebe[i].dynamik.vb_max

Beschreibung

Maximal zulässige Achsgeschwindigkeit

Datentyp

UNS32

Datenbereich

1 ≤ P-AXIS-00212 ≤ SLOPE_VB_MAX

Dimension

translatorisch: μ m/s

rotatorisch: 0,001°/s

Standardwert

-

Anmerkungen

Bei Achsen des Typs "ACHSTYP_TRANSLATOR" und "ACHSTYP_ROTATOR" wird davon ausgegangen, dass bei der Einstellung dieses Parameters P-AXIS-00212 auch die Auflösungsgrenzen des Meßsystems berücksichtigt werden.

Bei Achsen des Typs "ACHSTYP_SPINDEL", die von einem Spindelinterpolator betrieben werden, wird die Grenzgeschwindigkeit für das Meßsystem P-AXIS-00212 eingestellt.

P-AXIS-00209 | Geschwindigkeit im Eilgang(G00)
Parameter | getriebe[i].vb_eilgang
Beschreibung | Für die Positionierung im Eilgang (G00) wird die Eilganggeschwindigkeit vorgegeben.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00209 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | P-AXIS-00212
Anmerkungen | -

P-AXIS-00214 | Reduzierte Maximalgeschwindigkeit bei aktivem G01
Parameter | getriebe[i].vb_max_red
Beschreibung | Für Sicherheitsfunktionen oder für Inbetriebnahmezwecke kann über die PLC der NC-Steuerung mit Hilfe eines Steuersignals eine reduzierte Maximalgeschwindigkeit für aktives G01 in Echtzeit beauftragt werden. Die Geschwindigkeit der bewegten Achsen wird nach einem eventuell erforderlichen Bremsvorgang unter bzw. auf diesem Geschwindig-keitsgrenzwert gehalten.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00214 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | 0
Anmerkungen | Bei fehlendem Eintrag und Beauftragung über die PLC wird die Achsbewegung gestoppt !!

P-AXIS-00155 | Reduzierte Maximalgeschwindigkeit bei aktivem G00
Parameter | getriebe[i].rapid_speed_red
Beschreibung | Für Sicherheitsfunktionen oder für Inbetriebnahmezwecke kann über die PLC der NC-Steuerung mit Hilfe eines Steuersignals eine reduzierte Maximalgeschwindigkeit für aktives G00 in Echtzeit beauftragt werden. Die Geschwindigkeit der bewegten Achsen wird nach einem eventuell erforderlichen Bremsvorgang unter bzw. auf diesem Geschwindig-keitsgrenzwert gehalten.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00155 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | 0
Anmerkungen | Bei fehlendem Eintrag und Beauftragung über die PLC wird die Achsbewegung gestoppt !!

P-AXIS-00030 | Reduzierte Maximalgeschwindigkeit im Sicherheitsbereich
Parameter | getriebe[i]. vb_max_red_zone
Beschreibung | Für Sicherheitsfunktionen oder für Inbetriebnahmezwecke kann über die PLC der NC-Steuerung mit Hilfe eines Steuersignals eine reduzierte Maximalgeschwindigkeit in einem Sicherheitsbereich in Echtzeit beauftragt werden. Die Geschwindigkeit der bewegten Achsen wird nach einem eventuell erforderlichen Bremsvorgang unter bzw. auf diesem Geschwindig-keitsgrenzwert gehalten. Die Bereichsgrenzen werden achsspezifisch über P-AXIS-00085 und P-AXIS-00093 eingestellt.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00030 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | 0
Anmerkungen | Wenn unterschiedliche Positionen in P-AXIS-00085 und P-AXIS-00093 vorhanden sind, sich die Achsposition innerhalb des Sicherheitsbereichs befindet und der Eintrag in P-AXIS-00030 fehlt wird bei Beauftragung durch die PLC die Achsbewegung gestoppt !!

P-AXIS-00218 | Kleine Geschwindigkeit bei Referenzpunktfahrt
Parameter | getriebe[i].vb_reflow
Beschreibung | Dieser Parameter definiert die kleine Geschwindigkeit bei der Nocken und Nullimpulssuche
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00218 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | -

P-AXIS-00219 | Hohe Geschwindigkeit bei Referenzpunktfahrt
Parameter | getriebe[i].vb_refmax
Beschreibung | Dieser Parameter definiert die hohe Geschwindigkeit bei der Nocken und Nullimpulssuche
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00219 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | -

P-AXIS-00285 | Beschleunigung bei Referenzpunktfahrt
Parameter | getriebe[i].a_ref
Beschreibung | Dieser Parameter definiert die aktive Beschleunigung bei Referenzpunktfahrt
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00285 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | MIN[ P-AXIS-00005 , P-AXIS-00006 ]
Anmerkungen | Diese Beschleunigung wird beim linearen und nichtlinearen Slope-Profil verwendet.


Linearer Slope

P-AXIS-00005 | Beschleunigung in der Stufe 1 im Eilgang (G00)
Parameter | getriebe[i].lslope_profil.a_grenz_stufe_1
Beschreibung | Dieser Parameter definiert die Beschleunigung der Stufe 1 im Eilgang (G00). Für die Positionierung im Eilgang (G00) werden häufig steilere Rampen als für die Werkstückbearbeitung (z.B. G01, G02, G03) gewählt.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00005 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | P-AXIS-00008
Anmerkungen | Diese Grenzbeschleunigung wird in der Regel nahe der Stromgrenze eingestellt, um schnelles Positionieren und schnelle Bremsverzögerungen zu erreichen.

P-AXIS-00006 | Beschleunigung in der Stufe 2 im Eilgang (G00)
Parameter | getriebe[i].lslope_profil.a_grenz_stufe_2
Beschreibung | Dieser Parameter definiert die Beschleunigung der Stufe 2 im Eilgang (G00). Für die Positionierung im Eilgang (G00) werden häufig steilere Rampen als für die Werkstückbearbeitung (z.B. G01, G02, G03) gewählt.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00006 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | P-AXIS-00008
Anmerkungen | Diese Grenzbeschleunigung wird in der Regel nahe der Stromgrenze eingestellt, um schnelles Positionieren und schnelle Bremsverzögerungen zu erreichen.

P-AXIS-00011 | Beschleunigung in der Stufe 1
Parameter | getriebe[i].lslope_profil.a_stufe_1
Beschreibung | Dieser Parameter ist während der Bescheunigungs- und Verzögerungsphasen aktiv. Er definiert die Beschleunigung in der Stufe 1.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00011 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | Die Beschleunigung kann im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00012 | Beschleunigung in der Stufe 2
Parameter | getriebe[i].lslope_profil.a_stufe_2
Beschreibung | Dieser Parameter ist während der Bescheunigungs- und Verzögerungsphasen aktiv. Er definiert die Beschleunigung in der Stufe 2.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00012 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00024

Beschleunigung bei Vorschub-Stopp (Feedhold)

Parameter

getriebe[i].lslope_profil.a_feedh

Beschreibung

Dieser Parameter definiert für den Vorschub-Stopp (Feedhold) die Beschleunigung beim Bremsen, da hierbei häufig eine steilere Bremsrampe als beim Positionieren im Eilgang (G00) und bei der Werkstückbearbeitung (z.B. G01, G02, G03) benötigt wird.

Der Vorschub-Stopp kann entweder von einem Bediener explizit ausgelöst werden oder implizit bei der Messfahrt und der Referenzpunktfahrt ausgelöst werden.

Fehlt ein Eintrag für diesen Parameter, wird mit der maximalen Eilgangbeschleunigung ( P-AXIS-00005 bzw. P-AXIS-00006 ) gebremst.

Datentyp

UNS32

Datenbereich

1 ≤ P-AXIS-00024 ≤ P-AXIS-00008 (a_max)

Dimension

translatorisch: mm/s2

rotatorisch: °/s2

Standardwert

P-AXIS-00008

Anmerkungen

-

P-AXIS-00211

Umschaltgeschwindigkeit zwischen den Beschleunigungsstufen im Eilgang (G00)

Parameter

getriebe[i].lslope_profil. vb_grenz_stufe_1_2

Beschreibung

Für die Positionierung im Eilgang (G00) werden häufig steilere Rampen als für die Werkstückbearbeitung (z.B. G01, G02, G03) gewählt.

Dieser Parameter definiert die Umschaltgeschwindigkeit zwischen Stufe 1 ( P-AXIS-00005 ) und Stufe 2 ( P-AXIS-00006 ) für die Beschleunigungs- und Verzögerungsphase.

Datentyp

UNS32

Datenbereich

1 ≤ P-AXIS-00211 ≤ P-AXIS-00212 (vb_max)

Dimension

translatorisch: μ m/s

rotatorisch: : 0,001°/s

Standardwert

-

Anmerkungen

-

P-AXIS-00221 | Umschaltgeschwindigkeit
Parameter | getriebe[i].lslope_profil.vb_stufe_1_2
Beschreibung | Dieser Parameter definiert die Umschaltgeschwindigkeit zwischen Stufe 1 und Stufe 2 während der Beschleunigungs- und Verzögerungsphase.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00221 ≤ P-AXIS-00212 (vb_max)
Dimension | translatorisch: μ m/s | rotatorisch: 0,001°/s
Standardwert | -
Anmerkungen | -


Nicht linearer Slope

P-AXIS-00001 | Beschleunigung bei zunehmender Geschwindigkeit
Parameter | getriebe[i].slope_profil.a_beschl
Beschreibung | Dieser Parameter definiert die Achsbeschleunigung bei konstanter Geschwindigkeitszunahme.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00001 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert |
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00002 | Beschleunigung bei abnehmender Geschwindigkeit
Parameter | getriebe[i].slope_profil.a_brems
Beschreibung | Dieser Parameter beschreibt die Achsbeschleunigung bei konstanter Geschwindigkeitsabnahme.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00002 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00201 | Minimal zulässige Rampenzeit
Parameter | getriebe[i].dynamik.tr_min
Beschreibung | Mit diesem Parameter wird die minimal zulässige Rampenzeit des Antriebs festgelegt und somit der Achsruck, der durch das Geschwindigkeitsprofil entsteht, begrenzt.
Datentyp | UNS32
Datenbereich | TR_MIN ≤ P-AXIS-00201 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | -

P-AXIS-00195 | Rampenzeit für Beschleunigungsabbau
Parameter | getriebe[i].slope_profil.tr_beschl_ab
Beschreibung | Dieser Parameter definiert die Beschleunigungsrampenzeit für den Abbau der Beschleunigung bei zunehmender Geschwindigkeit P-AXIS-00001 .
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00195 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00196 | Rampenzeit für Beschleunigungsaufbau
Parameter | getriebe[i].slope_profil.tr_beschl_zu
Beschreibung | Dieser Parameter definiert die Beschleunigungsrampenzeit für den Aufbau der Beschleunigung bei zunehmender Geschwindigkeit P-AXIS-00001 .
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00196 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00197 | Rampenzeit für Verzögerungsabbau
Parameter | getriebe[i].slope_profil.tr_brems_ab
Beschreibung | Dieser Parameter definiert die Beschleunigungsrampenzeit für den Abbau der Verzögerung P-AXIS-00002 .
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00197 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00198 | Rampenzeit für Verzögerungsaufbau
Parameter | getriebe[i].slope_profil.tr_brems_zu
Beschreibung | Dieser Parameter definiert die Beschleunigungsrampenzeit für den Aufbau der Verzögerung P-AXIS-00002 .
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00198 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | Die Beschleunigungsrampen können im NC-Programm verändert werden. Die entsprechenden NC-Befehle sind in [PROG] näher beschrieben.

P-AXIS-00004 | Beschleunigung im Eilgang (G00)
Parameter | getriebe[i].slope_profil.a_grenz
Beschreibung | Dieser Beschleunigungsparameter ist bei Eilgangbewegungen (G00) beim Bremsen und Beschleunigen wirksam.
Datentyp | UNS32
Datenbereich | 1 ≤ P-AXIS-00004 ≤ P-AXIS-00008 (a_max)
Dimension | translatorisch: mm/s2 | rotatorisch: °/s2
Standardwert | MAX[ P-AXIS-00001 , P-AXIS-00002 ]
Anmerkungen | -

P-AXIS-00200 | Rampenzeit im Eilgang (G00)
Parameter | getriebe[i].slope_profil.tr_grenz
Beschreibung | Dieser Rampenzeitparameter ist bei Eilgangbewegungen (G00) beim Bremsen und Beschleunigen wirksam. Er ersetzt die Rampenzeiten P-AXIS-00195, P-AXIS-00196, P-AXIS-00197 und P-AXIS-00198.
Datentyp | UNS32
Datenbereich | P-AXIS-00201 ≤ P-AXIS-00200 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | MIN[ P-AXIS-00195 , P-AXIS-00196 , P-AXIS-00197 , P-AXIS-00198 ]
Anmerkungen | -

P-AXIS-00053

Beschleunigung bei Vorschub-Stopp (Feedhold)

Parameter

getriebe[i].slope_profil.a_feedh

Beschreibung

Dieser Parameter definiert für den Vorschub-Stopp (Feedhold) die Beschleunigung beim Bremsen, da hierbei häufig eine steilere Bremsrampe als beim Positionieren (G00) und bei der Werkstückbearbeitung (z.B. G01, G02, G03) benötigt wird.

Der Vorschub-Stopp kann entweder von einem Bedieners explizit ausgelöst werden oder implizit bei der Messfahrt und der Referenzpunktfahrt ausgelöst werden.

Fehlt ein Eintrag für diesen Parameter, wird mit der Eilgangbeschleunigung P-AXIS-00004 gebremst.

Datentyp

UNS32

Datenbereich

1 ≤ P-AXIS-00053 ≤ P-AXIS-00008(a_max)

Dimension

translatorisch: mm/s2

rotatorisch: °/s2

Standardwert

P-AXIS-00004

Anmerkungen

-

P-AXIS-00081

Rampenzeit bei Vorschub-Stopp (Feedhold)

Parameter

getriebe[i].slope_profil.tr_feedh

Beschreibung

Dieser Parameter definiert für den Vorschub-Stopp (Feedhold) die Rampenzeit beim Bremsen, da hierbei häufig eine steilere Bremsrampe als beim Positionieren (G00) und bei der Werkstückbearbeitung (z.B. G01, G02, G03) benötigt wird.

Der Vorschub-Stopp kann entweder von einem Bedieners explizit ausgelöst werden oder implizit bei der Messfahrt und der Referenzpunktfahrt ausgelöst werden.

Fehlt ein Eintrag für diesen Parameter, wird mit der Eilgangrampenzeit P-AXIS-00200 gebremst.

Datentyp

UNS32

Datenbereich

tr_min ≤ P-AXIS-00081≤ MAX(UNS32)

Dimension

μ s

Standardwert

P-AXIS-00200

Anmerkungen

-

P-AXIS-00286 | Rampenzeit bei Referenzpunktfahrt
Parameter | getriebe[i].tr_ref
Beschreibung | Dieser Parameter definiert die aktive Rampenzeit bei Referenzpunktfahrt
Datentyp | UNS32
Datenbereich | TR_MIN ≤ P-AXIS-00286 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | -
Anmerkungen | -

P-AXIS-00199 | Geometrische Rampenzeit
Parameter | getriebe[i].dynamik.tr_geom
Beschreibung | Dieser Parameter definiert die zulässige Rampenzeit des Rucks der sich aufgrund der Konturkrümmung innerhalb eines Bewegungssatzes in der Achse ergibt.
Datentyp | UNS32
Datenbereich | TR_MIN ≤ P-AXIS-00199 ≤ MAX(UNS32)
Dimension | μ s
Standardwert | P-AXIS-00201
Anmerkungen | -

P-AXIS-00013

Gewichtung der Beschleunigung am Satzübergang

Parameter

getriebe[i].dynamik.a_trans_weight

Beschreibung

Dieser Parameter gewichtet die zulässige Beschleunigung am Satzübergang.

Durch den Wert 0 wird der Einfluss dieses Parameters abgeschaltet, es gilt die Gewichtung der zulässigen Beschleunigung mit dem Faktor von Zykluszeit / Rampenzeit. Damit überschreitet der Ruck der sich aufgrund des unstetigen Konturverlaufs ergibt nicht den zulässigen Achsruck. Es ergibt sich eine sehr niedrige Geschwindigkeit an nicht tangentialen Konturübergangen.

Sollen höhere Geschwindigkeiten mit entsprechend höherem Ruck am Satzübergang gefahren werden, wird dieser Parameter P-AXIS-00013 entsprechend hoch eingestellt. Mit der maximalen Gewichtung (1000) wird am Satzübergang die Beschleunigung eingehalten, der Ruck übersteigt die eingestellten Grenzwerte.

Datentyp

UNS32

Datenbereich

0 ≤ P-AXIS-00013 ≤ 1000

Dimension

0,1%

Standardwert

0

Anmerkungen

Die zulässige Beschleunigung am Satzübergang ergibt sich aus der aktiven Beschleunigung die vom Satztyp (G00, G01) abhängt:

a_aktiv * a_trans_weight / 1000.

P-AXIS-00154 | Gewichtung des Rucks am Satzübergang
Parameter | getriebe[i].dynamik.r_trans_weight
Beschreibung | Am Satzübergang von Linear zu Zirkularsatz und umgekehrt tritt ein Sprung in der Beschleunigung auf. Mit diesem Parameter wird der zulässige Ruck an solchen Satzübergängen gewichtet. Mit der maximalen Gewichtung (1000) ist kein Einfluss mehr auf die Geschwindigkeit am Satzübergang vorhanden. Kleinere Gewichtungen (<1000) führen zu einer Verminderung der Geschwindigkeit am Satzübergang. Die minimaler Gewichtung (0) wird die Geschwindigkeit soweit vermindert, dass der zulässige Ruck (ergibt sich aus aktiver Beschleunigung und Rampenzeit) am Satzübergang nicht verletzt wird (siehe auch Parameter P-AXIS-00013). Die Verwendung dieses Parameters wird durch ein Steuerflag P-CHAN-00009 beeinflußt !.
Datentyp | UNS32
Datenbereich | 0 ≤ P-AXIS-00154 ≤ 1000
Dimension | 0,1%
Standardwert | 0
Anmerkungen | Der zulässige Ruck am Satzübergang ergibt sich aus der aktiven Beschleunigung, die vom Satztyp (G00, G01) und der zugehörigen Rampenzeit tr abhängt: (a_aktiv /tr_aktiv)* r_trans_weight / 1000.

1.3.3


Beispiel Kanalliste

Auszug aus Kanalparameterliste

Einheiten: Beschleunigung in [mm/min2], Geschwindigkeit in [mm/min], Gewichtungswert in Promille

slope.profile 0

slope.ramp_time 0

slope.acceleration 0

max_vb_override 1000

check_jerk_on_poly_path 0

corr_v_trans_jerk 0

use_drive_curr_limit 1

vector.acceleration 1800000

vector.velocity 1500


Beispiel Achsliste

Auszug aus Achsparameterliste

Einheiten: Beschleunigung in [mm/s2 bzw. Grad/s2], Geschwindigkeit in [μm/s bzw. 1E-3 Grad/s], Rampenzeit in [μs], Gewichtungswerte in Promille.

Allgemeine Grenzwerte:

getriebe[0].dynamik.vb_max 1000000

getriebe[0].dynamik.a_max 6000

getriebe[i].dynamik.a_emergency.......................6000

getriebe[0].vb_eilgang 1000000

getriebe[0].vb_max_red 40000

getriebe[0].rapid_speed_red 40000

getriebe[0].vb_max_red_zone 20000

getriebe[0].vb_reflow 10000

getriebe[0].vb_refmax 150000

getriebe[0].a_ref 1000

Trapez-/sinusquadratförmiges Beschleunigungsprofil

getriebe[0].slope_profil.a_beschl 1000

getriebe[0].slope_profil.a_brems 1000

getriebe[0].slope_profil.tr_beschl_zu 50000

getriebe[0].slope_profil.tr_beschl_ab 50000

getriebe[0].slope_profil.tr_brems_zu 50000

getriebe[0].slope_profil.tr_brems_ab 50000

getriebe[0].slope_profil.a_grenz 2500

getriebe[0].slope_profil.tr_grenz 10000

getriebe[0].slope_profil.a_feedh 6000

getriebe[0].slope_profil.tr_feedh 10000

getriebe[0].dynamik.tr_min 5000

getriebe[0].dynamik.tr_geom 5000

getriebe[0].dynamik.a_trans_weight 0

getriebe[0].dynamik.r_trans_weight 0

getriebe[0].tr_ref 100000

Sprungförmiges Beschleunigungsprofil

getriebe[0].lslope_profil.a_stufe_1 1000

getriebe[0].lslope_profil.a_stufe_2 1000

getriebe[0].lslope_profil.vb_stufe_1_2 1000000

getriebe[0].lslope_profil.a_grenz_stufe_1 5000

getriebe[0].lslope_profil.a_grenz_stufe_2 5000

getriebe[0].lslope_profil.vb_grenz_stufe_1_2 1000000

getriebe[0].lslope_profil.a_feedh 1500