Abstandsregelung (M3)

1.1 AbstandsregelungPAGEREF _Toc306719249 \h4

1.2 Beschreibung 8

1.3 Programmierung 9

1.4 PLC-Schnittstelle 11

1.4.1 Zustände und Transitionen der Abstandsregelung 11

1.4.2 Steuerkommandos für die Abstandsregelung 14

1.5 Parameter 19

1.5.1 Übersicht 19

1.5.2 Beschreibung 19

1.6 Fehlermeldungen 20

1.6.1 Übersicht 20

1.7 Testbeispiel mit Antriebssimulation 21

Mehr:

button Abstandsregelung

button Beschreibung

button Programmierung

button PLC-Schnittstelle

button Parameter

button Fehlermeldungen

button Testbeispiel mit Antriebssimulation


Abstandsregelung

Aufgabe

Durch elektronische Tastsysteme oder Sensoren werden Bewegungen erzeugt, die die programmierte Positionen der Achsen während der Interpolation eines NC-Programms überlagern sollen.

Dadurch ist es möglich, eine Abstandsregelung (z.B. Berühren einer gekrümmten Oberfläche einer Platte) oder Höhenregelung (z.B. Ausgleich von Dickentoleranzen des Werkstückes) einfach mit der Steuerung zu implementieren.

Eigenschaften

Über einen Geber wird ein zweites Meßsystem an die Steuerung angeschlossen. Über dieses Meßsystem können achsspezifische Korrekturwerte zusätzlich zum interpolierten Sollwert auf eine Achse ausgeben und damit die tatsächliche Position der Achse korrigiert werden.

Die Abstandsregelung wird im NC-Programm ein- bzw. ausgeschaltet.

Über die Achsmaschinendaten können für die Abstandsregelung relevanten Größen parametriert werden.

Die Abstandsregelung arbeitet im Interpolationstakt der Steuerung.

Die Abstandsregelung steht aktuell nur für Sercos-, Profidrive- oder CANopen-Antriebe zur Verfügung.

Übersicht über die Parametrierung

Die über die Abstandsregelung erzeugte Bewegung kann über Maschinendaten beeinflusst werden.

- Aktivierung eines Mittelwertfilters

- Maximal zulässiger Korrekturwert

- Maximale additive Geschwindigkeit der Achse

- Maximal zulässiger Istwertsprung des Tastsystems

- Maximale obere Achsposition

- Minimale untere Achsposition

- Toleranzwert

Die Aktivierung bzw. Deaktivierung erfolgt über das NC-Programm.

Übersicht über die
Konfigurierung

Der Geber des elektronischen Tastsystems wird als Istwertgeber 2 an die zu regelnde Achse angeschlossen. Es ist zu beachten, dass der erste konfigurierte Geber für die Lageregelung der Achse verwendet wird, der zweite Geber für die Abstandsregelung.

Abbildung 1-1: Konfigurationsbeispiel TwinCAT für SERCOS (Ident S-0-0053)

Abbildung 1-2: Konfigurationsbeispiel TwinCAT für CANopen DS402 (PDO 0x60E4, Subindex 1)

Abbildung 1-3: Konfigurationsbeispiel TwinCAT für ProfiDrive (G1_XIST2)

Der achsspezifische Override wirkt auf die Abstandsregelung. Bei Override 0 ist die Abstandsregelung nicht mehr aktiv, der aktuelle Wert ist eingefroren.


Beschreibung

Funktionsweise der Abstandsregelung

Die Abstandsregelung ist nach der Interpolation integriert und überlagert ggf. die programmierte Bewegung. Die Abstandsregelung wirkt unabhängig vom aktuellen Zustand des Interpolators, auch beim Warten auf Quittierungen (z.B. M-Funktionen) ist die Abstandsregelung aktiv.

Die Abstandsregelung ermittelt die tatsächliche Absolutposition der Werkstückoberfläche mit Hilfe des Motorgebers der Achse und eines zusätzlichen Sensorgebers. Die beiden Geber sind miteinander gekoppelt, d.h. beim Bewegen der Achse ändern sich die Werte der beiden Geber immer entgegengesetzt zueinander.

Abbildung 1- 4 : Tastung der Werkstückoberfläche

Berechnung der
Abweichung

Mit Hilfe der elektronischen Tastung wird in jedem Takt die Abweichung der realen Werkstückoberfläche zur vorgegebenen Sollposition (SET_POS) ermittelt. Sie ergibt sich durch:

Abweichung = Motorgeber + Sensorgeber - Sollposition (SET_POS)

= Istposition Werkstückoberfläche - Sollposition (SET_POS)

Um die Abweichung der Werkstückoberfläche auszugleichen, wird die Antriebsposition zusätzlich um den berechneten Offset der Abstandsregelung verschoben:

Sollwert Antrieb = Programmierter Sollwert (PCS) + Offset Abstandsregelung

Abbildung 1-5: Blockschaltbild der Abstandsregelung

An- und Abwahl über das NC-Programm

Über das NC-Programm wird die Abstandsregelung ein- bzw. ausgeschaltet oder auch der aktuelle Korrekturwert eingefroren.

Beispiel:

N10 Z[DIST_CTRL SET_POS=30] Position setzen

Nxx Z[DIST_CTRL ON] Anwahl

Nxx Z[DIST_CTRL OFF] Abwahl

N999 M30

Die vollständige CNC-Syntax ist im Kapitel 1.3 beschrieben.

Typischer Ablauf

Typischer Ablauf bei der Aktivierung der Abstandsregelung:

- Das Werkzeug wird eingewechselt

- X- und Y-Achsen fahren auf Bearbeitungsposition

- Die Abstandsregelung wird eingeschaltet und die Sollposition des Werkstücks wird gesetzt

- Z-Achse fährt nach unten

- Sensor oder Tastring meldet Abstand

- Abstandsregelung ist aktiv, Dickentoleranzen oder Lagedifferenzen werden ausgeglichen

Deaktivierung der Abstandsregelung:

- Ausschalten der Abstandsregelung über das NC-Programm

- Abstandsregelung ist inaktiv, Dickentoleranzen oder Lagedifferenzen werden nicht mehr ausgeglichen, der aktuelle Offset bleibt bis zur nächsten Positionsanforderung aktiv.

Wirkungsweise

Mit der Abstandsregelung können Abweichungen der Position der Werkstückoberfläche (Istposition) zu einer vorgegeben Sollposition automatisch korrigiert werden:

Abbildung 1- 6 : Ideales Werkstück

Abweichung

Eine Abweichung von der idealen Werkstückoberfläche (z.B. bei dünnerem Werkstück) wird durch den Sensor (Geber 2) detektiert:

Abbildung 1-7: Reales Werkstück ohne Abstandsregelung

Kompensation des Versatzes

Nach Einschalten der Abstandsregelung mit SET_POS=20 mm (erwartete Werkstückhöhe) wird der Versatz durch die Abstandsregelung kompensiert. Ein Anpassen des NC-Programms (PCS-Position) ist dadurch nicht notwendig:

Abbildung 1- 8 : Reales Werkstück mit Abstandsregelung

Die Abstandskontrolle wird bei einem Achsfehler, CNC-Reset oder bei Programmende des CNC-Kanals, der die Achse beauftragt hat, automatisch ausgeschaltet.


Programmierung

<Achsname> [ DIST_CTRL [ON | OFF] | [CHECK_POS | FREEZE | REF] SET_POS<expr>
 [VAL1<expr> -VAL5<expr>] ]

<Achsname> Name der werkzeugtragenden Achse.

DIST_CTRL Kennung für die Funktionalität "Getastete Spindeln". Muß immer als erstes Schlüsselwort programmiert sein.

ON Abstandskontrolle einschalten. Vor dem Einschalten muss eine Sollposition gesetzt sein (SET_POS).

OFF Abstandskontrolle ausschalten.

CHECK_POS Prüfen, ob Position im Toleranzfenster ist.

FREEZE Einfrieren des ausgeregelten Abstandes über Werkstück. Die Achsposition bzw. der ausgegebene Korrekturwert wird gehalten d.h. die Nachführung der Achse in Abhängigkeit der Werkstückoberfläche wird unterbrochen.

REF Meßsystem (Sensor) referenzieren (nur wenn kein Absolutmeßsystem vorhanden ist).

SET_POS<expr> Sollvorgabe der Werkstückoberfläche [mm] (Absolutposition). Bei Programmende oder Reset wird die Sollposition zurückgesetzt d.h. vor dem Einschalten der Abstandsregelung muss eine neue Sollposition vorgegeben werden.

VAL1<expr>-VAL5<expr> Frei belegbare Werte (5)

Die Schlüsselworte ON/OFF, FREEZE, CHECK_POS und REF schliessen sich gegenseitig im gleichen Befehl aus. Die Schlüsselworte SET_POS und VAL1-VAL5 können immer in Kombination mit programmiert werden. Ist bei Programmende die Funktion noch aktiv, so wird diese automatisch abgewählt (implizites "OFF").

Programmierbeispiele

%DIST_1

N10 Z[DIST_CTRL SET_POS=30] Sollposition der Werkstückoberfläche setzen

N20 Z[DIST_CTRL ON] Anwahl

:

Nxx Z[DIST_CTRL OFF] Abwahl

N999 M30

%DIST_2

N10 Z[DIST_CTRL ON SET_POS=30] Anwahl + erwarte Position Werk- stückoberfläche setzen

:

Nxx Z[DIST_CTRL FREEZE] Position halten. Nachführen beenden.

:

Nxx Z[DIST_CTRL OFF] Abwahl

N999 M30


PLC-Schnittstelle

Mehr:

button Zustände und Transitionen der Abstandsregelung

button Steuerkommandos für die Abstandsregelung


Zustände und Transitionen der Abstandsregelung

Alternative Beauftragung über PLC-Schnittstelle

Zusätzlich zum NC-Programm kann die Abstandsregelung auch über die PLC-Schnittstelle (s. [HLI] ) beauftragt werden, in dem über die Control-Unit DistanceControl die gewünschten Zustandstransitionen (z.B. Einschalten oder Ausschalten) und Sollpositionen vorgegeben werden. Voraussetzung ist, dass die Abstandsregelung für die Achse aktiviert ist (s. P-AXIS-00328 ).

Der aktuelle Zustand der Abstandsregelung kann im Status der Control-Unit DistanceControl abgelesen werden. Zusätzlich ist im Status der Control-Unit auch die aktuelle Istposition der Werkstückoberfläche und der gerade ausgegebene Positionsoffset enthalten.

Die Abstandsregelung verfügt über fünf interne Zustände, die in Abbildung 1-9 zusammen mit den zulässigen Transitionen dargestellt sind. Gestrichelt gezeichnete Transitionen, wie z.B. ein Übergang in den Fehlerzustand, erfolgen automatisch und können nicht kommandiert werden.

Abbildung 1-9: Zustandsgraph und Transitionen der Abstandsregelung

Eine detaillierte Beschreibung der Zustände und möglichen Transitionen können den folgenden Tabellen entnommen werden.

Tabelle 1- 1 : Zustände der Abstandsregelung

Zustand | Bedeutung
HLI_DIST_CTRL_STATE_INACTIVE | Die Abstandregelung ist deaktiviert. Der ausgegebene Offset (ActualOffset) ist null.
HLI_DIST_CTRL_STATE_TURNING_OFF | Die Abstandsregelung wurde ausgeschalten. Der aktuell wirksame Offset (ActualOffset) wird ausgefahren. Sobald er null ist, wird automatisch in den Zustand INACTIVE gewechselt.
HLI_DIST_CTRL_STATE_FREEZE | Die Abstandsregelung ist aktiv. Der Offset (ActualOffset) ist eingefroren d.h. ein nachführen der Achse an die Werkstückoberfläche erfolgt nicht.
HLI_DIST_CTRL_STATE_ACTIVE | Die Abstandsregelung ist aktiv und führt die Achse der Werkstückoberfläche nach.
HLI_DIST_CTRL_STATE_ERROR | Die Abstandsregelung befindet sich im Fehlerzustand z.B. auf Grund einer fehlerhaften Zustandstransition oder durch einen Fehler im Lageregler. Aus diesem Zustand ist nur eine Transition nach TURNING OFF möglich.

Tabelle 1- 2 : Zulässige Transitionen

Transition | Bedeutung
HLI_DIST_CTRL_ON | Einschalten der Abstandsregelung. Beim Einschalten muss eine Sollposition für die Werkstückoberfläche übergeben werden. Falls kein Absolutgeber verwendet wird, muss die Abstandsregelung vorab referenziert werden.
HLI_DIST_CTRL_OFF | Ausschalten der Abstandsregelung. Es wird in den Zustand TURNING OFF gewechselt, in dem der Positionsoffset ausgefahren wird. Anschließend wird automatisch in den Zustand INACTIVE umgeschalten.
HLI_DIST_CTRL_FREEZE | Einfrieren des aktuellen Positionsoffsets. Das Nachführen der Achse an die tatsächliche Werkstückoberfläche wird beendet.
HLI_DIST_CTRL_REF | Referenzieren der Abstandsregelung, falls kein Absolutgeber verwendet wird. Ein Referenzieren ist nur im Zustand INACTIVE erlaubt. Bei dieser Transition muss zusätzlich eine Referenzposition mit übergeben werden.


Steuerkommandos für die Abstandsregelung

Beauftragung der Abstandsregelung

Beschreibung

Über diese Control Unit kann die Abstandsregelung der Achse beeinflusst werden. Voraussetzung ist, dass sie in den Achsparametern angewählt ist (s. P-AXIS-00328 ).

Datentyp

MCControlDistCtrlUnit, (s. Beschreibung [HLI - Control-Unit mit Verbrauchskontrolle] )

Zugriff

PLC liest State und schreibt Command + X_Enable

ST-Pfad

pAC[axis_idx]^.addr^.McControlLr_Data.MCControl_DistanceControl

Flusskontrolle der kommandierten Werte

ST-Element

.X_CommandSemaphor

Signalfluss

PLC -> CNC

Datentyp

BOOL

Zugriff

Verbrauchsdatum

CNC übernimmt die kommandierten Werte, wenn dieses Element den Wert TRUE besitzt. Nach erfolgreicher Übernahme setzt die CNC diesen Wert auf FALSE.

PLC setzt dieses Element auf TRUE, wenn die kommandierten Werte zur Übernahme durch die CNC freigegeben werden. Eine Aktualisierung der kommandierten Werte durch die PLC kann nur dann erfolgen, wenn dieses Element den Wert FALSE besitzt.

Kommandierte Werte

ST-Element

.Command

Signalfluss

PLC -> CNC

Datentyp

HLIDistanceControlCommand

Zugriff

PLC schreibt

Zustand der Abstandsregelung

ST-Element

.State

Signalfluss

CNC -> PLC

Datentyp

HLIDistanceControlState

Zugriff

PLC liest

Umleitung

ST-Element

. X_Enable

Status der Abstandsregelung

Beschreibung

In diesem Eintrag kann der Zustand der Abstandsregelung gelesen werden.

Signalfluss

PLC -> CNC

Datentyp

HLIDistanceControlState

ST-Pfad

pAC[axis_idx]^.addr^.McControlLr_Data.MCControl_DistanceControl.State

Zugriff

PLC liest

Elemente des Datentyps

Element

.D_State

Datentyp

UDINT

Zugriff

PLC liest

Wertebereich

0 = HLI_DIST_CTRL_STATE_INACTIVE

1 = HLI_DIST_CTRL_STATE_ACTIVE

2 = HLI_DIST_CTRL_STATE_FREEZE

3 = HLI_DIST_CTRL_STATE_TURNING_OFF

4 = HLI_DIST_CTRL_STATE_ERROR

Beschreibung

· ..INACTIVE: Abstandsregelung ist aus

· ..ACTIVE: Abstandsregelung ist aktiv, Achse wird der Werkstückoberfläche nachgeführt

· ..FREEZE: Abstandsregelung ist aktiv, aber der Positionsoffset ist eingefroren. Kein Nachführen an Werkstückoberfläche

· ..TURNING_OFF: Abstandsregelung wird ausgeschalten

· ..ERROR: Fehlerzustand

Element

.D_ActualPosition

Datentyp

DINT

Zugriff

PLC liest

Wertebereich

0,1 µm bzw. 0,0001°

Beschreibung

Dieses Datum zeigt die aktuelle Istposition der Werkstückoberfläche an, die die Abtastregelung ermittelt hat.

Besonderheiten

Dieses Datum wird nur versorgt, falls in den Achsparametern die Abstandsregelung aktiviert ist (s. P-AXIS-00328 ).

Element

.D_ActualOffset

Datentyp

DINT

Zugriff

PLC liest

Wertebereich

0,1 µm bzw. 0,0001°

Beschreibung

Dieses Datum zeigt den aktuellen Positionsoffset der Abstandsregelung, um den die Achse auf Grund von Abweichungen zwischen der tatsächlichen Werkstückoberfläche und der vorgegebenen Position (SET_POS) verschoben wurde. Im stationären Zustand (konstante Werkstückoberfläche und Positionsoffset komplett ausgefahren) gilt: Positionsoffset = SET_POS  D_ActualPosition

Besonderheiten

Dieses Datum wird nur versorgt, falls in den Achsparametern die Abstandsregelung aktiviert ist (s. P-AXIS-00328 ).

Kommando für die Abstandsregelung

Beschreibung

In diesem Eintrag kann die Abstandsregelung beauftragt werden.

Signalfluss

PLC -> CNC

Datentyp

HLIDistanceControlCommand

ST-Pfad

pAC[axis_idx]^.addr^.McControlLr_Data.MCControl_DistanceControl.Command

Zugriff

PLC schreibt

Elemente des Datentyps

ST-Element

. D_ Transition

Datentyp

UDINT

Wertebereich

0 = HLI_DIST_CTRL_OFF

1 = HLI_DIST_CTRL_ON

2 = HLI_DIST_CTRL_FREEZE

3 = HLI_DIST_CTRL_REF

Beschreibung

· HLI_DIST_CTRL_OFF: Abstandsregelung wird ausgeschalten

· HLI_DIST_CTRL_ON: Sollposition wird gesetzt und die Abstandsregelung wird eingeschalten. Beim Einschalten muss zusätzlich immer eine Sollposition im Datum Position übergeben werden.

· HLI_DIST_CTRL_FREEZE: Positionsoffset der Abstandsregelung wird eingefroren, das Nachführen wird beendet.

· HLI_DIST_CTRL_REF: Referenzpostion des Sensors (Position) wird gesetzt. Die Referenzposition muss im Datum Position mit übergeben werden.

ST-Element

.D_Position

Datentyp

DINT

Wertebereich

[DINT_MIN, DINT_MAX]

Beschreibung

Die Bedeutung ist abhängig von der kommandierten Transition:

HLI_DIST_CTRL_ON: Sollposition der Werkstückoberfläche (SET_POS)

HLI_DIST_CTRL_REF: Referenzposition der Werkstückoberfläche (REF_POS)


Parameter

Mehr:

button Übersicht

button Beschreibung


Übersicht

ID | Parameter | Beschreibung
P-AXIS-00328 | lr_param.distance_control_on | Freischalten der Funktionalität Abstandsregelung
P-AXIS-00413 | kenngr.distc.n_cycles | Anzahl Punkte für Mittelwertfilter des Gebersignals
P-AXIS-00414 | kenngr.distc.max_deviation | Maximaler zulässiger Korrekturwert [0.1 µm]
P-AXIS-00415 | kenngr.distc.v_max | Maximal zulässige Geschwindigkeit für die Abstandsregelung [µm/s]
P-AXIS-00416 | kenngr.distc.a_max | Maximal zulässige Beschleunigung für die Abstandsregelung [mm/s^2]
P-AXIS-00417 | kenngr.distc.max_act_value_change | Maximal zulässiger Sprung des Abtastsignals innerhalb eines Taktes [0.1 µm/Takt]
P-AXIS-00418 | kenngr.distc.ref_offset | Offset zum Referenzpunkt
P-AXIS-00419 | kenngr.distc.max_pos | Obere Grenze des Sensors
P-AXIS-00420 | kenngr.distc.min_pos | Untere Grenze des Sensors
P-AXIS-00421 | kenngr.distc.tolerance | Toleranzband
P-AXIS-00428 | kenngr.distc.check_sw_limit_switch | Berücksichtigen des berechneten Offsets der Abstandsregelung in der Software-Endschalter-überwachung
P-AXIS-00422 | lr_hw[1].encoder_resolution_num | Wegauflösung des Sensormesssystems (Zähler) [Inkremente]
P-AXIS-00423 | lr_hw[1].encoder_resolution_denom | Wegauflösung des Sensormesssystems (Nenner) [0.1 µm]
P-AXIS-00230 | lr_hw[1].vz_istw | Vorzeichenumkehr der Sensoristwerte
P-AXIS-00424 | lr_hw[1].mode_act_pos | Festlegen des Sensorwertebereichs: Linearer Maßstab oder Modulobehandlung der Sensorwerte

Parameterbeispiel

kenngr.distc.n_cycles 10 # Zyklenzahl, Mittelwertfilter des Tastgebers

kenngr.distc.max_deviation 2000000 # [0.1um] Max. zulaessige Abweichung

kenngr.distc.v_max 1000 # [um/s] Max. Geschw. der Abstandsregelung

kenngr.distc.a_max 5000 # [mm/s*s] Max. Beschleunigung

kenngr.distc.max_act_value_change 5000000 # Max. Istwertsprung / Zyklus

kenngr.distc.ref_offset 0 # Offset Referenzpunkt

kenngr.distc.max_pos 1000000 # [0.1um] Max. Position

kenngr.distc.min_pos -1000000 # [0.1um] Min. Position

kenngr.distc.tolerance 50000 # [0.1um] Toleranzwert der Tasttiefe

kenngr.distc.check_sw_limit_switch 1 # Offset der Abstandsregelung überwachen


Beschreibung

P-AXIS-00328 | Freischalten der Funktionalität Abstandsregelung
Parameter | lr_param.distance_control_on
Beschreibung | In der Achskonfiguration muss diese Funktionalität grundsätzlich freigeschaltet werden, um über das NC-Programm die Abstandsregelung überhaupt einschalten zu können.
Datentyp | BOOLEAN
Datenbereich | TRUE / FALSE
Dimension | translatorisch: - | rotatorisch: -
Standardwert | FALSE
Anmerkungen | -

P-AXIS-00413 | Filterung der Geberwerte zur Abstandsregelung
Parameter | kenngr.distc.n_cycles
Beschreibung | Die Geberwerte sind u.U. verrauscht. Um die Anregung der Maschine niedrig zu halten, können die Sollwerte zur Abstandsregelung über einen Mittelwertfilter geglättet werden.
Datentyp | UNS32
Datenbereich | 0 <= Wert < 10
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 4
Anmerkungen | -

P-AXIS-00414 | Maximaler Positionsoffset durch Abstandsregelung
Parameter | kenngr.distc.max_deviation
Beschreibung | Der Korrekturwert der Achse, der über die Abstandsregelung berechnet wurde, darf dieses Maschinendatum nicht überschreiten. Wird dieser Wert überschritten, wird eine Fehlermeldung ausgegeben. Der Korrekturwert wird begrenzt.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 0,1 µm | rotatorisch: 1/10000 °
Standardwert | 50000, entspricht 5 mm
Anmerkungen | -

P-AXIS-00415 | Maximale Geschwindigkeit, mit der ein Positionsoffset ausgefahren wird
Parameter | kenngr.distc.v_max
Beschreibung | Die Korrektur des Abstandes wird dynamisch bzgl. der maximalen Geschwindigkeit begrenzt, um die resultierende Anregung zu begrenzen.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 1/1000 mm/s | rotatorisch: 1/1000°/s
Standardwert | 5000, entspricht 5 mm/s
Anmerkungen | -

P-AXIS-00416 | Maximale Beschleunigung, mit der ein Positionsoffset ausgefahren wird
Parameter | kenngr.distc.a_max
Beschreibung | Die Korrektur des Abstandes wird dynamisch bzgl. der maximalen Beschleunigung begrenzt, um die resultierende Anregung zu begrenzen. Falls keine Beschleunigung angegeben ist, wird automatisch die maximale Achsbeschleunigung verwendet (s. P-AXIS-00008)
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 1 mm/s^2 | rotatorisch: 1°/s^2
Standardwert | 0, es wird die maximale Achsbeschleunigung verwendet (s. P-AXIS-00008)
Anmerkungen | -

P-AXIS-00417 | Maximal zulässige Änderung des gemessenen Abstandes innerhalb eines Taktes
Parameter | kenngr.distc.max_act_value_change
Beschreibung | Nach Einschalten der Abstandsregelung werden die Istwerte des Sensors bzgl. ihrer Änderung überwacht. Durch das Einstellen eines Maximalwertes können Probleme bei der Istwerterfassung detektiert werden.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 0.1 µm | rotatorisch: 1/10000°
Standardwert | 5000, entspricht 0.5 mm
Anmerkungen | -

P-AXIS-00418 | Referenzpunktoffset für Meßsystem der Abstandsregelung
Parameter | kenngr.distc.ref_offset
Beschreibung | Der Wertebereich des Sensor-Meßsystems kann über dieses Maschinendatum um einen Offset verschoben werden. Dies ist z.B. bei Absolutgebern notwendig, um den Referenzpunkt festzulegen d.h. die Sensorposition, die sich einstellt, falls die Spindel die ideale Werkstückoberfläche berührt.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 0.1 µm | rotatorisch: 1/10000°
Standardwert | 0, kein Positionsoffset
Anmerkungen | -

P-AXIS-00419 | Obere Grenze für Meßsystem
Parameter | kenngr.distc.max_pos
Beschreibung | Folgender Wert definiert die obere Grenze des Sensor-Gebers. Wird diese bei aktiver Abstandsregelung überschritten, wird eine Fehlermeldung erzeugt.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 0.1 µm | rotatorisch: 1/10000°
Standardwert | 50000, entspricht 5 mm
Anmerkungen | -

P-AXIS-00420 | Untere Grenze für Meßsystem
Parameter | kenngr.distc.min_pos
Beschreibung | Folgender Wert definiert die untere Grenze des Sensor-Gebers. Wird diese bei aktiver Abstandsregelung überschritten, wird eine Fehlermeldung erzeugt.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 0.1 µm | rotatorisch: 1/10000°
Standardwert | -50000, entspricht - 5 mm
Anmerkungen | -

P-AXIS-00421 | Toleranzband für Grenzwerte
Parameter | kenngr.distc.tolerance
Beschreibung | Die Erfassung von Istwerten liefert immer sich ändernde Werte. Durch das Toleranzband sind auch Werte zulässig, die ggf. ausserhalb der konfigurierten Grenzen liegen, ohne dass eine Fehlermeldung erzeugt wird.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 0.1 µm | rotatorisch: 1/10000°
Standardwert | 0, entspricht 0 mm
Anmerkungen | -

P-AXIS-00428 | Berücksichtigen des Offsets in der Software-Endschalterüberwachung
Parameter | kenngr.distc.check_sw_limit_switch
Beschreibung | Dieser Parameter legt fest, ob der berechnete Offset der Abstandsregelung in der Softwareendschalterüberwachung (s. [FCT-A2]) berücksichtigt wird.
Datentyp | BOOLEAN
Datenbereich | TRUE / FALSE
Dimension | - | -
Standardwert | FALSE, Offset der Abstandsregelung wird in Software-Endschalterüberwachung nicht berücksichtigt.
Anmerkungen | -

P-AXIS-00422 | Wegauflösung des Sensormesssystems (Zähler)
Parameter | lr_hw[1].encoder_resolution_num
Beschreibung | Die Wegauflösung des Sensormesssystems wird als Quotient P-AXIS-00422 / P-AXIS-00423 in der Dimension [Inkremente/0,1 µm] für translatorische Achsen oder [Inkremente/10^-4°] für Rundachsen angegeben. In P-AXIS-00422 sind die Anzahl der Geberinkremente anzugeben.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: Inkremente | rotatorisch: Inkremente
Standardwert | 1
Anmerkungen | -

P-AXIS-00423 | Wegauflösung des Sensormesssystems (Nenner)
Parameter | lr_hw[1].encoder_resolution_denom
Beschreibung | Die Wegauflösung des Sensormesssystems wird als Quotient P-AXIS-00422 / P-AXIS-00423 in der Dimension [Inkremente/0,1 µm] für translatorische Achsen oder [Inkremente/10^-4°] für Rundachsen angegeben. In P-AXIS-00423 ist die Größe des Verfahrbereichs anzugeben.
Datentyp | UNS32
Datenbereich | 0 <= Wert < MAX_UNS32
Dimension | translatorisch: 0,1 µm | rotatorisch: 1/10000°
Standardwert | 1
Anmerkungen | -

P-AXIS-00230 | Vorzeichenumkehr der Geberwerte
Parameter | lr_hw[1].vz_istw
Beschreibung | Mit diesem Parameter kann das Vorzeichen der Geberwerte des Sensors invertiert werden
Datentyp | BOOLEAN
Datenbereich | TRUE / FALSE
Dimension | translatorisch: - | rotatorisch: -
Standardwert | FALSE
Anmerkungen | FALSE = keine Invertierung, TRUE = Vorzeichenumkehr der Geberistwerte

P-AXIS-00424 | Festlegen des Sensorwertebereichs
Parameter | lr_hw[1].mode_act_pos
Beschreibung | In diesem Parameter kann festgelegt werden, ob die Sensorpositionen linear oder als Modulwerte betrachtet werden. Die Behandlung kann dabei per default passend zum Achstyp erfolgen, oder es kann eine individuelle Voreinstellung festgelegt werden. Bei Behandlung der Geberwerte in Abhängigkeit des eingestellten Achstyps (s. P-AXIS-00018), wird für Achstyp TRANSLATOR eine lineare Betrachtung durchgeführt, während bei Achstyp ROTATOR eine Modulo-Behandlung verwendet wird.
Datentyp | BOOLEAN
Datenbereich | 0 / 1 / 2
Dimension | translatorisch: - | rotatorisch: -
Standardwert | 0
Anmerkungen | 0 : nach Achstyp (default) 1 : linear 2 : modulo


Fehlermeldungen

Mehr:

button Übersicht


Übersicht

Bei aktiver Abstandsregelung können folgende Fehlermeldungen auftreten:

70329

70330

70331

70332

70333

70334

70335

70336

Istwertsprung des Sensorsignales größer als Grenzwert

Sensor ganz ausgefahren

Tastabweichung zu groß

Abstandsregelung bei Programmende noch aktiv

Abstandsregelung für Achse aktiv, die abgegeben werden soll

Bei erneuter Anwahl Abwahl der Abstandsregelung noch nicht fertig

Anwahl Abstandsregelung ohne programmierte Position

Funktionalität steht nicht zur Verfügung


Testbeispiel mit Antriebssimulation

PLC Testumgebung

Konfiguration des CAN-Antriebs

Simulation in SPS

Abstandsregelung ab TwinCAT-CNC Build V2.10.1505.22

Konfiguration einer Z-Achse gemäß CANopen DS402 Antrieb mit einem zusätzlichen Abstandssensor (0x60E4_01).

Simulation des CAN-PDOs über SPS-Ein-/Ausgänge

Der Encoder des Antriebs sowie der Abstandssensor sind in der SPS zusätzlich mit einen kleinen Zufallswert verrauscht.

Einschalten der Antriebe

Anfahren einer Sollposition

Nach Setzen der Antriebsfreigaben (Antrieb ein, Drehmoment, Feedhold aus) kann der Antrieb verfahren werden.

Referenzieren des Sensor, sensor zero

Eintragen der Nennposition

Position=400000

Einschalten der Abstandsregelung

Transition=1 (ON)

Bei der übergebenen Nennposition (SET_POS) liefert der Abstandssensor den Wert = 0.

Verändern der Oberflächenposition Surface offset

Die geänderte Oberflächenposition ergibt eine Änderung des gemessenen Abstandssensors.

Dieser führt zu einer Nachregeln der tatsächlichen Achsposition, bis der Abstandssensor wieder den Wert = 0 aufweist. D.h. in diesem Falle wäre wieder der gewünschte Abstand zur Oberfläche erreicht.

Eingefrieren der aktuellen Höhe

Transition=2 (FREEZE)

Wird die Abstandsregelung unterbrochen (Transition = FREEZE = 2), so hat in dieser Zeit ein geänderter Sensorwert (20000) keine Einfluss auf die Achskorrektur.

Nach Reaktivierung der Regelung wird auf den aktuellen Sensorwert ausgeregelt.

Ausschalten

Transition=0 (OFF)

Nach Ausschalten der Abstandsregelung (Transition = OFF = 0) wird der Lageoffset, verursacht durch den Abstandssensor, wieder rückgängig gemacht.