CNC Zyklen (C21)

1.1 EinleitungPAGEREF _Toc305749720 \h2

1.2 Definition der Bearbeitungsrichtung 2

1.3 Zyklenspezifische Werkzeugdaten 3

1.4 Geometrie- und Bearbeitungsdaten 4

1.5 Bohrzyklen 6

1.5.1 Durchgangs-/Zentrierbohrung 6

1.5.2 Senken 8

1.5.3 Tieflochbohren 11

1.6 Gewindebohren (ohne Ausgleichsfutter) 13

1.7 Helikalfräsbohren 15

1.8 Taschenfräsen 17

1.9 Plausibilitätsprüfungen und Meldungen 19

Mehr:

button Einleitung

button Definition der Bearbeitungsrichtung

button Zyklenspezifische Werkzeugdaten

button Geometrie- und Bearbeitungsdaten

button Bohrzyklen

button Gewindebohren (ohne Ausgleichsfutter)

button Helikalfräsbohren

button Taschenfräsen

button Plausibilitätsprüfungen und Meldungen


Einleitung

Verfügbare Zyklen

Für die Bearbeitungsaufgaben

· Bohren

· Gewindebohren

· Helikalfräsbohren

· Taschenfräsung

sind die nachfolgend beschriebenen parametrierbaren Zyklen verfügbar.


Definition der Bearbeitungsrichtung

Ebenenabhängige
Bearbeitungsrichtung

Ein Werkstück kann in den Ebenen G17, G18, G19 jeweils von 2 Richtungen bearbeitet werden. Diese Bearbeitungsrichtung wird dem Zyklus in einem Aufrufparameter zur Verfügung gestellt, da dieser berücksichtigen muß, von welcher Seite in einer Ebene die Bearbeitung durchgeführt wird. So kann z.B. in der G17 Ebene von oben oder von unten bearbeitet werden (siehe Bild), was im Zyklus bei der Bestimmung der Sicherheitsabstände und Zustelltiefen beachtet werden muss.

Hierfür sind folgende Kennzahlen zu verwenden:

Ebene | Kennzahl | Bearbeitung in Richtung
G17 (X-Y) | +1 | +Z (von unten)
 | -1 | -Z (von oben)
G18 (Z-X) | +1 | +Y (von vorne)
 | -1 | -Y (von hinten)
G19 (Y-Z) | +1 | +X (von links)
 | -1 | -X (von rechts)

Bestimmung der Richtungskennzahl

Abbildung 1-1: Koordinatensystem zur Bestimmung der Richtungskennzahl


Zyklenspezifische Werkzeugdaten

Belegung der freien Werkzeugparameter (P-TOOL-00007)

Die in den Werkzeugdaten verfügbaren s.g. freien Parameter dienen in den Zyklen dazu, zusätzliche Informationen bereitzustellen, bestimmte Plausibilitätsprüfungen durchzuführen und Defaultwerte festzulegen. Für jedes Werkzeug können bis zu 60 freie Parameter in den Werkzeugdaten definiert werden. Ein Werkzeugparameter wird im jeweiligen Zyklus nur dann ausgewertet und verwendet, wenn er mit einem Wert ungleich 0 eingetragen ist. Ansonsten wird entweder die Plausibilitätsprüfung nicht durchgeführt oder ein entsprechend programmierter Versorgungsparameter ist gültig.

Es gilt folgende Vereinbarung bei der Belegung für die momentan verfügbaren Zyklen:

Parameter | Bedeutung | Einheit oder Wert | Auswirkung/Besonderheit | Belegung
[0] | Nutzbare Werkzeug-länge | 0,1µm | Fehlermeldung, wenn Bearbeitungsendtiefe größer als Parameterwert. | optional
[1] | Maximaler Bearbeitungshub | 0,1µm | Warning, wenn Zustelltiefe größer als Parameterwert. Zustelltiefe wird auf Parameterwert begrenzt. | optional
[2] | Vorschub | 1 µm/s | Wird momentan nicht verwendet. | -
[3] | Spindeldrehzahl | 10-3 °/s | Nur für Zyklus Gewindebohren | optional für Gewindebohrer
[4] | Spindelstart-position | 10-4 ° | Nur für Zyklus Gewindebohren | optional für Gewindebohrer
[5] | Gewinde-steigung | 0,1µm | Nur für Zyklus Gewindebohren | optional für Gewindebohrer
[6] | Kennung für ein Sonderwerkzeug | 0, 1, ... | 0 = Standardwerkzeug 1 = Gewindebohrer mit Senker 2 = ... | obligatorisch bei Sonderwerkzeugen
[7] | Metrische Gewindegröße | 1...16 | Nur für Zyklus Gewindebohren, Beispiel 6 bei M6 , ...10 bei M10 usw. | obligatorisch für Gewindebohrer mit Senker
[8] | Überlappungsfaktor | % | Nur für Zyklus Taschenfräsen | optional


Geometrie- und Bearbeitungsdaten

Beim Aufruf der Zyklen kann unterschieden werden zwischen:

· Geometrieparametern und

· Bearbeitungsparametern

Die Geometrieparameter umfassen die Daten für die Definition von

· Bezugsebene

· Rückzugsebene

· Sicherheitsabstand

· absolute bzw. relative Bearbeitungstiefe

...die bei allen Zyklen in gleicher Weise erforderlich sind sowie weitere

· bearbeitungsspezifische Koordinaten

Abbildung 1-2: Allgemeine Geometrieparameter

Die Bearbeitungsparameter haben spezifische Bedeutung und Wirkung und werden in den einzelnen Zyklen näher beschrieben. Sie umfassen vorwiegend technologische Informationen wie z.B. Verweilzeiten, Anzahl Zustellungen, Drehrichtungen etc., also Daten die für den Bearbeitungsprozess erforderlich sind.

Mit den Geometrie- und Bearbeitungsdaten werden die Versorgungsparameter des entsprechenden Zyklus belegt.


Bohrzyklen

Kombinierter
Bohrzyklus

Die Bearbeitung von Durchgangsbohrungen, Zentrierbohrungen, Senkungen und Tieflochbohrungen ist in einem gemeinsamen Zyklus zusammengefaßt. Die Auswahl der Bohrungsart sowie weitere erforderliche Daten werden beim Zyklusaufruf mit den Versorgungsparametern übermittelt.

Mehr:

button Durchgangs-/Zentrierbohrung

button Senken

button Tieflochbohren


Durchgangs-/Zentrierbohrung

Ablauf

Erforderliche
Parameter

Bei einer Durchgangs-/Zentrierbohrung bohrt das Werkzeug mit der angewählten Spindeldrehzahl und Vorschubgeschwindigkeit G01 bis zur angegebenen Bearbeitungstiefe. Die Bohrung wird in einem Arbeitsgang bis zur Endbohrtiefe durchgeführt. Danach wird nach Ablauf einer optional programmierten Verweilzeit zum Spänebrechen im Eilgang G00 auf die angegebene Rückzugsebene zurückgefahren.

Folgende Parameter sind für den Aufruf einer Durchgangs-/ Zentrierbohrung erforderlich:

Zyklusparameter | Beschreibung
@P1 | Rückzugsebene (absolut)
@P2 | Bezugsebene (absolut)
@P3 | Sicherheitsabstand (relativ zur Bezugsebene, ohne Vorzeichen)
@P4 | Endbohrtiefe (absolut) oder...
@P5 | ...Endbohrtiefe (relativ zur Bezugsebene, ohne Vorzeichen)
@P6 (optional) | Verweilzeit auf Endbohrtiefe
@P10 | Bearbeitungsrichtung (zur Verrechnung des Sicherheitsabstandes)

Syntax:

L CYCLE [NAME=drilling.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=.. @P6=.. @P10=..]

Abbildung 1-3: Ablauf Durchgangs-/Zentrierbohrung

Programmierbeispiel

(Herstellen von 2 Zentrierbohrungen)

N10 T5 D5 Akt. Werkzeugdaten

N20 M6 Werkzeugwechsel

N30 G00 G17 G90 F250 M03 S400 Technologiewerte

N40 Z100 Fahren auf Rückzugsebene

N50 Y20 X0 1. Bohrposition

N60 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=40 @P6=1 @P10=-1]

N70 Y60 X0 2. Bohrposition

N80 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=40 @P6=1 @P10=-1]

N90 Z200 M5 Parkposition,Spindelstop

N100 M30 Programmende


Senken

Abgrenzung Senkung/Bohrung

Ablauf

Erforderliche
Parameter

Eine Senkung unterscheidet sich von einer Durchgangs-/Zentrierbohrung nur durch das verwendete Werkzeug und einer kleineren Endtiefe. Ansonsten sind die Bewegungsabläufe und die zu belegenden Versorgungsparameter identisch.

Bei einer Senkung fährt das Werkzeug mit der angewählten Spindeldrehzahl und Vorschubgeschwindigkeit G01 bis zur angegebenen Bearbeitungstiefe. Die Senkung wird in einem Arbeitsgang bis zur Endbohrtiefe durchgeführt. Danach wird nach Ablauf einer programmierten Verweilzeit im Eilgang G00 auf die angegebene Rückzugsebene zurückgefahren.

Folgende Parameter sind für den Aufruf einer Senkung erforderlich:

Zyklusparameter | Beschreibung
@P1 | Rückzugsebene (absolut)
@P2 | Bezugsebene (absolut)
@P3 | Sicherheitsabstand (relativ zur Bezugsebene, ohne Vorzeichen)
@P4 | Endbohrtiefe (absolut) oder...
@P5 | ...Endbohrtiefe (relativ zur Bezugsebene, ohne Vorzeichen)
@P6 (optional) | Verweilzeit auf Endbohrtiefe
@P10 | Bearbeitungsrichtung (zur Verrechnung des Sicherheitsabstandes)

Syntax:

L CYCLE [NAME=drilling.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=.. @P6=.. @P10=..]

Abbildung 1-4: Ablauf Senken

Programmierbeispiel

(Herstellen von 2 Senkungen)

N10 T7 D7 Akt. Werkzeugdaten

N20 M6 Werkzeugwechsel

N30 G00 G17 G90 F150 M03 S300 Technologiewerte

N40 Z100 Fahren auf Rückzugsebene

N50 Y20 X0 1. Bohrposition

N60 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=75 @P6=3 @P10=-1]

N70 Y60 X0 2. Bohrposition

N80 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=75 @P6=3 @P10=-1]

N90 Z200 M5 Parkposition,Spindelstop

N100 M30 Programmende


Tieflochbohren

Ablauf

Späne brechen

Späne entladen

Erforderliche
Parameter

Bei einer Tieflochbohrung bohrt das Werkzeug mit der angewählten Spindeldrehzahl und Vorschubgeschwindigkeit G01 in mehrstufigen Arbeitsgängen bis zur angegebenen Bearbeitungstiefe, wobei die Anzahl der Zustellungen programmierbar ist. Die resultierende Zustelltiefe (Bohrhub) wird hieraus zyklusintern basierend auf der Endbohrtiefe bestimmt.

Über die Belegung der entsprechenden Parameter können zwei verschiedene Ablaufverfahren gewählt werden:

Beim ersten Verfahren wird der Bohrer nach jeder Zustelltiefe zum Spänebrechen um einen programmierten Weg zurückgezogen.

Beim zweiten Verfahren wird der Bohrer nach jeder Zustelltiefe zum Späne entladen aus der Bohrung auf die Bezugsebene+Sicherheitsabstand herausgefahren.

Nach Erreichen der Endbohrtiefe wird nach Ablauf einer programmierten Verweilzeit im Eilgang G00 auf die angegebene Rückzugsebene zurückgefahren.

Folgende Parameter sind für den Aufruf einer Tieflochbohrung erforderlich:

Zyklusparameter | Beschreibung
@P1 | Rückzugsebene (absolut)
@P2 | Bezugsebene (absolut)
@P3 | Sicherheitsabstand (relativ zur Bezugsebene, ohne Vorzeichen)
@P4 | Endbohrtiefe (absolut) oder...
@P5 | ...Endbohrtiefe (relativ zur Bezugsebene, ohne Vorzeichen)
@P6 (optional) | Verweilzeit auf Endbohrtiefe
@P7 | Anzahl der Zustellungen
@P8 | Rückzugsweg zum Spänebrechen bzw. Vorhalteabstand nach Späne entladen (ohne Vorzeichen)
@P9 | Ablaufverfahren (Späne brechen (1), Späne entladen (2))
@P10 | Bearbeitungsrichtung (zur Verrechnung des Sicherheitsabstandes)

Syntax:

          L
CYCLE [NAME=drilling.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=..
@P6=.. @P7=.. @P8=..
@P9=.. @P10=..]

Zustellung
und
Vorschub

Über die Anzahl der Zustellungen wird zyklusintern der Wert eines einzelnen Bohrhubes (Zustelltiefe) bestimmt.

Bei jeder Zustellung erfolgt eine Vorschubdegression um den Faktor 0.9. Dadurch können Späne besser abfliessen und die Gefahr eines Werkzeugbruchs kann minimiert werden.

Abbildung 1-5: Ablauf Tieflochbohren mit Späne brechen (@P9=1)

Abbildung 1-6: Ablauf Tieflochbohren mit Späne entladen (@P9=2)

Programmierbeispiel

(Herstellen von 2 Zentrierbohrungen)

N10 T4 D4 Akt. Werkzeugdaten

N20 M6 Werkzeugwechsel

N30 G00 G17 G90 F250 M03 S400 Technologiewerte

N40 Z100 Fahren auf Rückzugsebene

N50 Y20 X0 1. Bohrposition

(1.Tiefloch bohren in 3 Schritten, mit Späne entladen, Endbohrtiefe absolut)

N60 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P4=5 @P6=1 @P7= 3 @P8=0.5
@P9=2 @P10=-1]

N70 Y60 X0 2. Bohrposition

(2.Tiefloch bohren in 2 Schritten, mit Späne brechen, Endbohrtiefe relativ)

N80 L CYCLE [NAME=drilling.cyc @P1=100 @P2=80
@P3=5 @P5=70 @P6=1 @P7= 2 @P8=0.5
@P9=1 @P10=-1]

N90 Z200 M5 Parkposition,Spindelstop

N100 M30 Programmende


Gewindebohren (ohne Ausgleichsfutter)

Für die Verwendung des Gewindebohrzykluses ist es technologisch erforderlich, dass die Spindel als lagegeregelte Spindel betrieben werden kann, da sie vor dem Gewindebohren zyklusintern positioniert und als Bahnachse betrieben wird.

Ablauf

Erforderliche
Parameter

Bei einer Gewindebohrung bohrt das Werkzeug mit der angewählten Spindeldrehzahl und der aus der Gewindesteigung abgeleiteten Vorschubgeschwindigkeit G63 bis zur angegebenen Gewindetiefe. Das Gewinde wird in einem Arbeitsgang bis zur Endbohrtiefe gefertigt. Nach Drehrichtungsumkehr wird mit gleicher Drehzahl und Vorschub wieder aus der Gewindebohrung auf die angegebene Rückzugsebene zurückgefahren. Die Umkehr der Drehrichtung nach Erreichen der Gewindetiefe erfolgt zyklusintern.

Folgende Parameter sind für den Aufruf einer Gewindebohrung erforderlich:

Zyklusparameter | Beschreibung
@P1 | Rückzugsebene (absolut)
@P2 | Bezugsebene (absolut)
@P3 | Sicherheitsabstand (relativ zur Bezugsebene, ohne Vorzeichen)
@P4 | Gewindetiefe (absolut) oder...
@P5 | ...Gewindetiefe (relativ zur Bezugsebene, ohne Vorzeichen)
@P6 | Spindelposition für definierten Spindelstop vor Gewindebohren
@P7 | Spindeldrehzahl für Gewindebohren
@P8 | Gewindesteigung
@P9 | Bearbeitungsrichtung (zur Verrechnung des Sicherheitsabstandes)

Syntax:

L CYCLE [NAME=tapping.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=.. @P6=.. @P7=.. @P8=.. P9=..]

Abbildung 1-7: Ablauf Gewindebohren

Programmierbeispiel

(Herstellen einer Gewindebohrungen)

N10 T2 D2 Akt. Werkzeugdaten

N20 M6 Werkzeugwechsel

N30 G00 G17 G90 M03 Technologiewerte

N40 Z100 Fahren auf Rückzugsebene

N50 Y20 X0 Gewindebohrposition

N60 L CYCLE [NAME=tapping.cyc @P1=100 @P2=80
@P3=5 @P4=15 @P6=180 @P7=200
@P8=1.25 @P9=-1]

N70 Z200 M5 Parkposition,Spindelstop

N80 M30 Programmende


Helikalfräsbohren

Ablauf

Erforderliche
Parameter

Beim Helikalfräsbohren fährt das Werkzeug mit der angewählten Spindeldrehzahl und Vorschubgeschwindigkeit in einer Helikalbewegung G02/G03 bis zur angegebenen Bearbeitungstiefe. Die Bohrung wird in einem Arbeitsgang bis zur Endbohrtiefe durchgeführt. Der Endpunkt auf der ersten und zweiten Hauptachse wird zyklusintern berechnet. Danach wird ohne Verweilzeit im Eilgang G00 auf die angegebene Rückzugsebene zurückgefahren. Optional kann am Ende der Helikalbohrung eine plane Ausfräsung zu einem Grundloch beauftragt werden. Mit diesem Verfahren lässt sich somit eine Bohrung (bzw. Grundloch) erzeugen, deren Durchmesser größer als der Fräserdurchmesser ist.

Folgende Parameter sind für den Aufruf einer Helikalfräsbohrung erforderlich:

Zyklusparameter | Beschreibung
@P1 | Rückzugsebene (absolut)
@P2 | Bezugsebene (absolut)
@P3 | Sicherheitsabstand (relativ zur Bezugsebene, ohne Vorzeichen)
@P4 | Endbohrtiefe (absolut) oder...
@P5 | ...Endbohrtiefe (relativ zur Bezugsebene, ohne Vorzeichen)
@P6 | Radius der Helikalbewegung (ohne Vorzeichen)
@P7 | Steigung der Helikalbewegung (ohne Vorzeichen)
@P8 | Drehrichtung (G02 (2), G03 (3))
@P9 (optional) | Planfräsen Grund (nur Helikal (0), Helikal+Grund (1))
@P10 | Bearbeitungsrichtung (zur Verrechnung des Sicherheitsabstandes)

Syntax:

          L
CYCLE [NAME=helimill.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=..
@P6=.. @P7=.. @P8=..
@P9=.. @P10=.. ]

Abbildung 1-8: Ablauf Helikalfräsbohren

Programmierbeispiel

(Herstellen eines Grundloches)

N10 T9 D9 Akt. Werkzeugdaten

N20 M6 Werkzeugwechsel

N30 G00 G17 G90 M03 S10000 Technologiewerte

N40 Z100 Fahren auf Rückzugsebene

N50 Y15 X0 F800 G41 Fräsbohrposition

N60 L CYCLE [NAME=helimill.cyc @P1=100 @P2=80
@P3=5 @P4=20 @P6=30 @P7=1 @P8=3
@P9=1 @P10=-1]

N70 G00 Z150 M5 Parkposition,Spindelstop

N80 M30 Programmende


Taschenfräsen

Ablauf

Erforderliche
Parameter

Beim Taschenfräsen fertigt das Werkzeug mit der angewählten Spindeldrehzahl und Vorschubgeschwindigkeit eine beliebige Rechtecktasche in mehrstufigen Arbeitsgängen bis zur angegebenen Taschentiefe, wobei die Anzahl der Zustellungen programmierbar ist. Die resultierende Zustelltiefe wird hieraus zyklusintern basierend auf der Taschentiefe bestimmt. Der Zyklus kann abhängig von der Beauftragung entweder eine Schrupp- oder eine Schlichtbearbeitung oder mit einem Werkzeug eine kombinierte Schrupp/ Schlichtbearbeitung durchführen. Die Bearbeitung startet immer vom Taschenmittelpunkt.

Folgende Parameter sind für den Aufruf einer Taschenfräsung erforderlich:

Zyklusparameter | Beschreibung
@P1 | Rückzugsebene (absolut)
@P2 | Bezugsebene (absolut)
@P3 | Sicherheitsabstand (relativ zur Bezugsebene, ohne Vorzeichen)
@P4 | Taschentiefe (absolut) oder...
@P5 | ...Taschentiefe (relativ zur Bezugsebene, ohne Vorzeichen)
@P6 | 1. Taschenseite ("Länge", bzgl. 1. Hauptachse der Ebene, ohne Vorzeichen)
@P7 | 2. Taschenseite ("Breite", bzgl. 2. Hauptachse der Ebene, ohne Vorzeichen)
@P8 | Eckenradius (ohne Vorzeichen)
@P9 | Taschenmittelpunkt, 1. Hauptachse (absolut)
@P10 | Taschenmittelpunkt, 2. Hauptachse (absolut)
@P11 | Anzahl der Zustellungen
@P12 | Schlichtaufmass (ohne Vorzeichen)
@P13 | Fräsrichtung (Uhrzeigersinn (2), Gegenuhrzeigersinn (3))
@P14 | Bearbeitungsart (Schruppen (1), Schlichten (2), Schruppen+ Schlichten (3))
@P15 | Bearbeitungsrichtung (zur Verrechnung des Sicherheitsabstandes)
@P16 (optional) | Überlappungsfaktor der Fräsbahnen (in %)
@P17 (optional) | Eintauchverfahren (Schiefe Bahn (1-Default), Senkrecht (2), Helikal (3))

Syntax:

          L
CYCLE [NAME=pocketmill.cyc @P1=.. @P2=.. @P3=.. @P4=.. | @P5=..
@P6=.. @P7=.. @P8=..
@P9=.. @P10=.. @P11=.. @P12=.. @P13=.. @P14=..
@P15=.. @P16=.. @P17=..]

Abbildung 1-9: Zyklenparameter beim Taschenfräsen

Programmierbeispiel

(Herstellen einer Tasche, 15 mm tief)

N10 T8 D8 Akt. Werkzeugdaten

N20 M6 Werkzeugwechsel

N30 G00 G17 G90 M03 S4000 Technologiewerte

N40 Z100 Fahren auf Rückzugsebene

N50 Y50 X65 F500 Frässtartposition

(Tasche Schruppen, @P14=1)

N60 L CYCLE [NAME=pocketmill.cyc @P1=100 @P2=80
@P3=5 @P5=15 @P6=80 @P7=60 @P8=10
@P9=65 @P10=50 @P11=3 @P12=1 @P13=2
@P14=1 @P15=-1 @P16=40 @P17=3]

N65 M5

N70 T9 D10 Neue Werkzeugdaten

N75 M6 Werkzeugwechsel

N80 G00 G17 G90 M03 S5000 Technologiewerte

N85 Z100 Fahren auf Rückzugsebene

N90 Y50 X65 F500 Frässtartposition

(Tasche Schlichten, @P14=2)

N95 L CYCLE [NAME=pocketmill.cyc @P1=100 @P2=80
@P3=5 @P5=15 @P6=80 @P7=60 @P8=10
@P9=65 @P10=50 @P11=1 @P12=1
@P13=2 @P14=2 @P15=-1]

N100 G00 Z100 M5 Parkposition,Spindelstop

N110 M30 Programmende


Plausibilitätsprüfungen und Meldungen

Fehler und Warnings

Die Versorgungsparameter werden im Zyklus vor ihrer Verwendung auf Plausibilität geprüft. Werden dabei fehlerhafte, unbekannte oder in sonstiger Art und Weise nicht verwendbare Werte festgestellt, so wird im Zyklus über den #ERROR-Befehl [PROG] eine Meldung ausgegeben.

Handelt es sich bei dieser Meldung um einen FEHLER, wird der Zyklus abgebrochen. Ist die Meldung eine WARNING, so wird der Wert zyklusintern berichtigt und die Bearbeitung fortgesetzt.

Zur genaueren Diagnose sind die mit #ERROR erzeugten Meldungen nachfolgend beschrieben. Hierbei gibt es allgemeine Meldungen, die von jedem Zyklus erzeugt werden können und zyklusspezifische Meldungen.

ID 13100 | Sicherheitsabstand nicht definiert.
Beschreibung | Der Sicherheitsabstand begrenzt die Anfahrbewegung im Eilgang. Die Meldung wird erzeugt, wenn der Sicherheitsabstand  · mit Null · oder nicht programmiert ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Sicherheitsabstand prüfen, Versorgungsparameter korrigieren.
Meldungstyp | Allgemeine Meldung.

ID 13101 | Mehrfachdefinition der Bearbeitungstiefe.
Beschreibung | Die Bearbeitungstiefe muss entweder absolut oder relativ definiert werden. Die Meldung wird erzeugt, wenn bei der Bearbeitungstiefe beide Versorgungsparameter für absolute und relative Angabe belegt sind.
Reaktion | WARNING: Zyklus wird unter Verwendung der absoluten Bearbeitungstiefe fortgesetzt.
Abhilfe | Festlegen, ob Bearbeitungstiefe absolut oder relativ definiert werden soll und Versorgungsparameter entsprechend korrigieren.
Meldungstyp | Allgemeine Meldung.

ID 13102 | Programmierte Bearbeitungstiefe ueberschreitet zulaessige Werkzeuglaenge.
Beschreibung | In den Werkzeugparametern kann die maximal nutzbare Werkzeuglänge eingetragen werden (P[0] siehe Kapitel 1.3 ). Bei einem Wert ungleich Null wird geprüft, ob die programmierte Bearbeitungstiefe kleiner als die zulässige nutzbare Werkzeuglänge ist. Wenn nicht, wird die Meldung erzeugt.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Prüfen, ob die zulässige Werkzeuglänge richtig definiert ist. Eventuell für die Bearbeitung ein anderes Werkzeug mit einer für die Bearbeitungstiefe ausreichenden Werkzeuglänge verwenden.
Meldungstyp | Allgemeine Meldung.

ID 13103 | Anzahl der Zustellungen nicht definiert.
Beschreibung | Bei mehrstufigen Arbeitsgängen bis zur programmierten Bearbeitungstiefe wird im Zyklus die Anzahl der Zustellungen geprüft. Die Meldung wird erzeugt, wenn die Anzahl der Zustellungen  · mit Null · oder nicht programmiert ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Anzahl der Zustellungen prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Bohr- oder Taschenfräszyklus.

ID 13104 | Zustelltiefe ueberschreitet zulaessigen Bearbeitungshub.
Beschreibung | In den Werkzeugparametern kann der maximal zulässige Bearbeitungshub eingetragen werden [P[1] siehe Kapitel 1.3 ). Bei einem Wert ungleich Null wird geprüft, ob die berechnete Zustelltiefe kleiner als der maximal zulässige Bearbeitungshub ist. Wenn nicht, wird die Meldung erzeugt.
Reaktion | WARNING: Die Anzahl der Zustellungen bzw. der Wert eines Bearbeitungshubes wird zyklusintern auf Basis des Maximalhubes angepaßt und berechnet und der Zyklus fortgesetzt.
Abhilfe | Anzahl der Zustellungen im Versorgungsparameter entsprechend erhöhen bzw. prüfen, ob der zulässige Bearbeitungshub richtig definiert ist. Eventuell für die Bearbeitung ein anderes Werkzeug, mit einem für die Zustelltiefe ausreichenden Bearbeitungshub verwenden.
Meldungstyp | Meldung aus Bohr- oder Taschenfräszyklus.

ID 13105 | Rueckzugsweg/Vorhalteabstand nicht definiert.
Beschreibung | Beim Stufenbohren benötigt der Bohrzyklus die Angabe des Rueckzugweges bzw. Vorhalteabstandes. Die Meldung wird erzeugt, wenn dieser Wert  · mit Null · oder nicht programmiert ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Rueckzugsweg bzw. Vorhalteabstand prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Bohrzyklus.

ID 13106 | Falsche Definition von Bezugs- und Rückzugsebene.
Beschreibung | Im Zyklus wird richtungsabhängig geprüft, ob die Rückzugsebene vor der Bezugsebene liegt, d.h. ob die Rückzugsebene zur Endbohrtiefe einen größeren Abstand hat als die Bezugsebene. Die Meldung wird erzeugt, wenn  · die Abstände gleich oder · die Rückzugsebene unter der Bezugsebene liegt.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Lage von Rückzugsebene und Bezugsebene prüfen und Versorgungsparameter korrigieren.
Meldungstyp | Allgemeine Meldung.

ID 13107 | Falsche Definition des Sicherheitsabstandes.
Beschreibung | Im Zyklus wird auf Basis des programmierten Sicherheitsabstandes richtungsabhängig geprüft, ob die resultierende Sicherheitsebene unterhalb der Rückzugsebene liegt. Die Meldung wird erzeugt, wenn  · Sicherheits- und Rückzugsebene gleich oder · die Sicherheitsebene oberhalb der Rueckzugsebene liegt.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Sicherheitsabstand prüfen und Versorgungsparameter korrigieren.
Meldungstyp | Allgemeine Meldung.

ID 13108 | Keine oder unbekannte Bearbeitungsrichtung definiert.
Beschreibung | Die Bearbeitungsrichtung ist erforderlich, um die richtige Lage und Wirkung des Sicherheitsabstandes bestimmen zu können. Ist keine Bearbeitungsrichtung angegeben, so wird diese Meldung erzeugt.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Bearbeitungsrichtung prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Allgemeine Meldung.

ID 13109

Unbekanntes Ablaufverfahren definiert.

Beschreibung

Für das Bohren stehen verschiedene Ablaufverfahren zur Verfügung. Diese können durch die Angabe einer Kennzahl angewählt werden:

0: Zentrierbohren (Default)

1: Stufenbohren mit Späne brechen

2: Stufenbohren mit Späne entladen

Diese Meldung wird erzeugt, wenn eine andere Kennzahl als 0, 1 oder 2 im entsprechenden Versorgungsparameter programmiert wurde.

Reaktion

FEHLER:

Zyklus wird abgebrochen.

Abhilfe

Kennzahl des Ablaufverfahrens prüfen und festlegen, Versorgungsparameter korrigieren.

Meldungstyp

Meldung aus Bohrzyklus.

ID 13110 | Bearbeitungstiefe nicht definiert.
Beschreibung | Die Bearbeitungstiefe muss entweder absolut oder relativ definiert werden. Die Meldung wird erzeugt, wenn bei der Bearbeitungstiefe keiner der beiden Versorgungsparameter für absolute oder relative Angabe belegt ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Festlegen, ob Bearbeitungstiefe absolut oder relativ definiert werden soll und Versorgungsparameter entsprechend programmieren.
Meldungstyp | Allgemeine Meldung.

ID 13111 | Relative Bearbeitungstiefe ist Null.
Beschreibung | Die Bearbeitungstiefe muss entweder absolut oder relativ definiert werden. Die Meldung wird erzeugt, wenn bei Verwendung einer relativen Bearbeitungstiefe der Versorgungsparameter mit Null belegt ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Fuer eine relative Bearbeitungstiefe den Versorgungsparameter entsprechend mit einem Wert ungleich Null programmieren.
Meldungstyp | Allgemeine Meldung.

ID 13120

Unzulässige Spindelposition definiert.

Beschreibung

Für das Gewindebohren ist die Positionierung der Spindel zwischen 0° und 360° erforderlich. Die Meldung wird erzeugt, wenn die Spindelposition außerhalb dieses zulässigen Bereiches programmiert wurde.

Hinweis:

Die Spindelposition kann auch optional in den Werkzeugparametern vorbelegt werden (P[4] siehe Kapitel 1.3 ).

Reaktion

FEHLER:

Zyklus wird abgebrochen.

Abhilfe

Spindelposition prüfen und festlegen, Versorgungsparameter korrigieren.

Meldungstyp

Meldung aus Gewindebohrzyklus.

ID 13121 | Spindeldrehzahl nicht definiert.
Beschreibung | Für das Gewindebohren ist die Angabe der Spindeldrehzahl zur Berechnung des Vorschubes erforderlich. Die Meldung wird erzeugt, wenn die Spindeldrehzahl weder in den Versorgungsparametern programmiert noch in den Werkzeugparametern vorbelegt ist. (P[3] siehe Kapitel1.3).
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Spindelposition prüfen und festlegen, Versorgungsparameter oder Werkzeugparameter korrigieren. Sind beide belegt, so wird die Spindelposition aus dem Versorgungsparameter verwendet.
Meldungstyp | Meldung aus Gewindebohrzyklus.

ID 13122 | Gewindesteigung nicht definiert.
Beschreibung | Für das Gewindebohren ist die Angabe der Gewindesteigung zur Berechnung des Vorschubes erforderlich. Die Meldung wird erzeugt, wenn die Gewindesteigung weder in den Versorgungsparametern programmiert noch in den Werkzeugparametern vorbelegt ist. (P[5] siehe Kapitel 1.3 ).
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Gewindesteigung prüfen und festlegen, Versorgungsparameter oder Werkzeugparameter korrigieren. Sind beide belegt, so wird die Gewindesteigung aus dem Versorgungsparameter verwendet.
Meldungstyp | Meldung aus Gewindebohrzyklus.

ID 13123 | Gewindegroesse nicht definiert.
Beschreibung | Wird für die Bearbeitung ein Gewindebohrer mit Senker (Sonderwerkzeug (P[6] siehe Kapitel 1.3 ) verwendet, so ist für die Berechnung der Senkerbewegung die metrische Gewindegröße erforderlich. Die Meldung wird erzeugt, wenn die Gewindegröße in den Werkzeugparametern nicht vorbelegt ist. (P[7] siehe Kapitel 1.3 ).
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Gewindegröße prüfen und festlegen, Werkzeugparameter P[7] korrigieren.
Meldungstyp | Meldung aus Gewindebohrzyklus.

ID 13140 | Helikalradius nicht definiert.
Beschreibung | Für das Helikalfräsbohren ist die Angabe des Bohrungsradius zur Berechnung der Helikalbewegung erforderlich. Die Meldung wird erzeugt, wenn der Radius nicht programmiert ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Helikalradius prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Helikalfräsbohrzyklus.

ID 13141 | Helikalsteigung nicht definiert.
Beschreibung | Für das Helikalfräsbohren ist die Angabe einer Steigung zur Berechnung der Helikalbewegung erforderlich. Die Meldung wird erzeugt, wenn die Steigung nicht programmiert ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Helikalsteigung prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Helikalfräsbohrzyklus.

ID 13142

Unbekannte Drehrichtung definiert.

Beschreibung

Für das Helikalfräsbohren ist die Angabe einer Drehrichtung zur Berechnung der Helikalbewegung erforderlich. Diese kann durch die Angabe einer Kennzahl angewählt werden:

2: Drehrichtung im Uhrzeigersinn (CW)

3: Drehrichtung im Gegenuhrzeigersinn (CCW)

Diese Meldung wird erzeugt, wenn eine andere Kennzahl als 2 oder 3 im entsprechenden Versorgungsparameter programmiert wurde.

Reaktion

FEHLER:

Zyklus wird abgebrochen.

Abhilfe

Drehrichtung prüfen und festlegen, Versorgungsparameter korrigieren.

Meldungstyp

Meldung aus Helikalfräsbohrzyklus.

ID 13160 | Taschenlaenge nicht definiert.
Beschreibung | Für das Taschenfräsen ist die Angabe der 1. Taschenseite (Taschenlänge) zur Berechnung der Ausfräsbewegungen erforderlich. Die Meldung wird erzeugt, wenn die Taschenlänge nicht programmiert ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Taschenlänge prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Taschenfräszyklus.

ID 13161 | Taschenbreite nicht definiert.
Beschreibung | Für das Taschenfräsen ist die Angabe der 2. Taschenseite (Taschenbreite) zur Berechnung der Ausfräsbewegungen erforderlich. Die Meldung wird erzeugt, wenn die Taschenbreite nicht programmiert ist.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Taschenbreite prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Taschenfräszyklus.

ID 13162 | Eckenradius nicht definiert.
Beschreibung | Für das Taschenfräsen ist die Angabe des Eckenradius zur Berechnung der Ausfräsbewegungen erforderlich. Die Meldung wird erzeugt, wenn der Eckenradius nicht programmiert ist.
Reaktion | WARNING: Zyklus wird unter Verwendung des aktuellen (Fräser-)Werkzeugradius als Eckenradius fortgesetzt.
Abhilfe | Eckenradius prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Taschenfräszyklus.

ID 13163 | Werkzeugradius zu gross.
Beschreibung | Es wird geprüft, ob der Werkzeugdurchmesser des aktuellen Fräsers unter Berücksichtigung des Schlichtaufmasses kleiner als die programmierte Breite oder Länge der Tasche ist. Ist das Ergebnis eine Verletzung der Taschenkontur, wird diese Meldung erzeugt.
Reaktion | FEHLER: Zyklus wird abgebrochen.
Abhilfe | Für die Bearbeitung ein Werkzeug mit einem kleinerem Durchmesser verwenden, damit die Taschenkontur nicht verletzt wird.
Meldungstyp | Meldung aus Taschenfräszyklus.

ID 13164 | Schlichtaufmass ist Null.
Beschreibung | Für das Taschenfräsen mit Schrupparbeitsgängen ist die Angabe eines Schlichtaufmasses zur Berechnung der Ausfräsbewegungen erforderlich. Die Meldung wird erzeugt, wenn dieser Wert  · mit Null · oder nicht programmiert ist.
Reaktion | WARNING: Zyklus wird fortgesetzt. Es wird nur der Schrupparbeitsgang ausgeführt. Ein eventuell beauftragter Schlichtarbeitsgang wird verworfen.
Abhilfe | Schlichtaufmass prüfen und festlegen, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Taschenfräszyklus.

ID 13165

Unbekannte Fraesrichtung definiert.

Beschreibung

Für das Taschenfräsen ist die Angabe einer Fräsrichtung zur Berechnung der Ausfräsbewegungen erforderlich. Diese kann durch die Angabe einer Kennzahl angewählt werden:

2: Fräsrichtung im Uhrzeigersinn (CW)

3: Fräsrichtung im Gegenuhrzeigersinn (CCW)

Diese Meldung wird erzeugt, wenn eine andere Kennzahl als 2 oder 3 im entsprechenden Versorgungsparameter programmiert wurde.

Reaktion

FEHLER:

Zyklus wird abgebrochen.

Abhilfe

Fräsrichtung prüfen und festlegen, Versorgungsparameter korrigieren.

Meldungstyp

Meldung aus Taschenfräszyklus.

ID 13166

Unbekannte Bearbeitungsart definiert.

Beschreibung

Für das Taschenfräsen ist die Angabe einer Bearbeitungsart zur Berechnung der Ausfräsbewegungen erforderlich. Diese kann durch die Angabe einer Kennzahl angewählt werden:

1: Schruppen

2: Schlichten

3: Schruppen + Schlichten

Diese Meldung wird erzeugt, wenn eine andere Kennzahl als 1, 2 oder 3 im entsprechenden Versorgungsparameter programmiert wurde.

Reaktion

FEHLER:

Zyklus wird abgebrochen.

Abhilfe

Bearbeitungsart prüfen und festlegen, Versorgungsparameter korrigieren.

Meldungstyp

Meldung aus Taschenfräszyklus.

ID 13167 | Werkzeugradius groesser als Eckenradius.
Beschreibung | Es wird geprüft, ob der programmierte Eckenradius mit dem aktuellen Fräser gefertigt werden kann. Hierbei muß der Werkzeugradius kleiner oder maximal gleich dem Eckenradius sein. Wenn nicht, wird die Meldung erzeugt.
Reaktion | WARNING: Zyklus wird unter Verwendung des aktuellen (Fräser-)Werkzeugradius als neuem Eckenradius fortgesetzt. In diesem Fall entspricht der Eckenradius der fertigen Tasche also dem Werkzeugradius.
Abhilfe | Für die Bearbeitung ein Werkzeug mit einem Radius kleiner oder gleich dem programmierten Eckenradius verwenden.
Meldungstyp | Meldung aus Taschenfräszyklus.

ID 13168

Falsche Definition des Ueberlappungsfaktors.

Beschreibung

Wenn der (optionale) programmierte Überlappungsfaktor grösser 0% ist, wird geprüft, ob er im Bereich bis 100% liegt. Die Meldung wird erzeugt, wenn der Überlappungsfaktor außerhalb dieses zulässigen Bereiches programmiert wurde.

Hinweis:

Der Überlappungsfaktor kann auch alternativ in den Werkzeugparametern vorbelegt werden (P[8] siehe Kapitel 1.3 ).

Reaktion

FEHLER:

Zyklus wird abgebrochen.

Abhilfe

Überlappungsfaktor prüfen und festlegen, Versorgungsparameter korrigieren.

Ist der Überlappungsfaktor weder programmiert noch in den Werkzeugparametern vorbelegt, wird im Zyklus als Default ein Wert von 50% gesetzt.

Meldungstyp

Meldung aus Taschenfräszyklus.

ID 13169 | Eckenradius wird begrenzt, da zu gross.
Beschreibung | Bei der Schruppbearbeitung wird geprüft, ob die entstehende Kontur bei Verwendung des programmierten Eckenradius zu einer "Kreistasche" entartet. Ist dies der Fall, wird die Meldung erzeugt.
Reaktion | WARNING: Der Eckenradius wird auf einen bestimmtem Wert begrenzt, damit noch eine Rechtecktasche entsteht und der Zyklus fortgesetzt.
Abhilfe | Eckenradius wenn möglich verkleinern, Versorgungsparameter korrigieren.
Meldungstyp | Meldung aus Taschenfräszyklus.

ID 13170

Unbekanntes Eintauchverfahren definiert.

Beschreibung

Für das Taschenfräsen kann ein Eintauchverfahrens zur Berechnung der Ausfräsbewegungen (optional) angegeben werden. Bei einem Wert ungleich Null wird geprüft, ob eine der folgenden Kennzahlen gesetzt ist:

1: Eintauchen auf schiefer Bahn

2: Senkrechtes Eintauchen

3: Helikales Eintauchen

Diese Meldung wird erzeugt, wenn eine andere Kennzahl als 1, 2 oder 3 im entsprechenden Versorgungsparameter programmiert wurde.

Reaktion

WARNING:

Zyklus wird unter Verwendung des Eintauchverfahrens 1 (schiefe Bahn) fortgesetzt.

Abhilfe

Eintauchverfahren prüfen und festlegen, Versorgungsparameter korrigieren.

Meldungstyp

Meldung aus Taschenfräszyklus.