Schleppabstandsüberwachung (A1)

1.1 Übersicht PAGEREF _Toc304466133 \h2

1.2 Beschreibung 6

1.2.1 Typ 1: Standard Methode 7

1.2.2 Typ 2: Lineare Methode 8

1.2.3 Typ 4: Geschwindigkeitsunabhängige Methode 9

1.3 Parameter 11

1.3.1 Übersicht 11

1.3.2 Beschreibung 11

Mehr:

button Übersicht

button Beschreibung

button Parameter


Übersicht

Aufgabe

Einordnung ins Gesamtsystem

Die Achsen der NC-Steuerung werden sowohl im Stillstand als auch während der Bewegung permanent dahingehend überwacht, ob eine statische oder dynamische Größe einen bestimmten Grenzwert überschreitet. Die Überschreitung eines Grenzwertes meldet die Steuerung in einer Fehlermeldung.

Die Überwachung folgender Größen wird von der Steuerung unterstützt:

q Schleppabstand

q Position

q Software-Endschalter

q Kollisionsüberwachung

q Dynamiküberwachung

Die einzelnen Überwachungen werden im Achsparameterdatensatz für jede Achse parametriert.


Beschreibung

Aufgabe

Die Schleppabstandsüberwachung überwacht, ob der aktuelle Schleppabstand einer Achse einen Grenzwert überschreitet. Als Schleppabstand wird die Differenz zwischen ausgegebenem Sollwert (Stellgrösse) und rückgemeldetem Istwert bezeichnet.

Die Überwachung erfolgt hierbei sowohl im

q Stillstand als auch während der

q Bewegung einer Achse.

Im Stillstand kann die Achse durch äußere Krafteinwirkung auf die Mechanik aus der Stillstandsposition verschoben werden. Sobald die Achsposition das Toleranzfenster des Stillstands überschreitet, erzeugt die Schleppabstandsüberwachung eine Fehlermeldung (P-ERR-70081) und leitet entsprechende Maßnahmen zum Stillsetzen der Achse ein.

Wenn sich die Achse bewegt, berechnet die dynamische Schleppabstandsüberwachung den zulässigen Schleppabstand für die momentane Verfahrgeschwindigkeit. Bei Überschreitung des zulässigen Schleppabstands wird eine Fehlermeldung (P-ERR-70020) ausgegeben und entsprechende Maßnahmen zum Stillsetzen der Achse eingeleitet.

Voraussetzungen

Falls die Schleppabstandsüberwachung angewählt wurde, so ist diese nur aktiv, falls

q die Achse in Regelung ist (Reglerfreigabe gegeben) und

q kein Nachführbetrieb für diese Achse gesetzt ist.

Die Schleppabstandsüberwachung kann sowohl für analoge Antriebe, bei denen die CNC die Lageregelung übernimmt, als auch bei digitalen Antrieben, die selbst die Lageregelung durchführen, eingesetzt werden. Falls digitale Antriebe selbst eine Schleppabstandsüberwachung durchführen, so kann zusätzlich eine Überwachung durch die CNC erfolgen. Meist ist dies jedoch nicht mehr erforderlich.

Maßnahmen bei Überschreitung des zulässigen Schleppabstandes

Wenn der zulässige Schleppabstand einer Achse überschritten wird, werden von der Steuerung folgende Maßnahmen eingeleitet:

q Ausgabe einer Fehlermeldung der Fehlerreaktionsklasse 5 [DIAG]

q Die betroffene Achse wird mit einer in der Achsparameterliste einstellbaren Verzögerung angehalten.

q Alle Achsen, die mit der betroffenen Achse im Bahnverbund interpoliert werden, werden angehalten.

q Weitere Maßnahmen können von der PLC über die Steuerschnittstelle vorgenommen werden.

Methoden

Die NC-Steuerung bietet drei Methoden an, mit denen der maximal zulässige Schleppabstand berechnet wird:

q Typ 1: Standard Methode

q Typ 2: Lineare Methode

q Typ 4: Geschwindigkeitsunabhängige Methode

Mit allen Methoden kann der Schleppabstand während des Stillstandes überwacht werden. Der zulässige Schleppabstand einer fahrenden Achse wird bei den beiden ersten Methoden abhängig von der Sollgeschwindigkeit berechnet. Die Standard Methode (Typ 1) verwendet einen parametrierbaren Filter. Die Lineare Methode (Typ 2) geht von dem theoretischen Schleppabstand aus, der bis zu einem Faktor 2 vergrößert werden kann. Bei beiden Methoden kann über ein Zeitglied der zulässige Schleppabstand zeitlich verschoben werden.

Bei der Methode 4 wird auch während einer Achsbewegung auf einen geschwindigkeitsunabhängigen, konstanten Grenzwert geprüft, diese Methode kann zum Beispiel für Achsen mit aktiver Vorsteuerung verwendet werden.

Parametrierung

Die Schleppabstandsüberwachung kann durch Einstellungen der Achsparameter individuell für jede Achse parametriert werden.

Ein-/Ausschalten

Die Schleppabstandsüberwachung wird mit dem Parameter P-AXIS-00172 ein- oder ausgeschaltet (Parameter = 0). Ist die Überwachung ausgeschaltet, so wird keine maximal zulässiger Schleppabstand berechnet und es erfolgt keine Fehlermeldung.

Auswahl

Die Einstellung des Schleppabstandsüberwachungstyps erfolgt mit dem Parameter P-AXIS-00172. Folgende Schleppabstandstypen können parametriert werden:

q keine Schleppabstandsüberwachung

q Typ 1: Standard Methode

q Typ 2: Lineare Methode

q Typ 4: Geschwindigkeitsunabhängige Methode

Reaktion deaktivieren

Um die Schleppabstandsüberwachung einzustellen ist es erforderlich, den Grenzwert zu berechnen und anzuzeigen, ohne dass eine eigentliche Überwachung durchgeführt wird. Die Reaktion der Schleppabstandsüberwachung wird zu diesem Zweck deaktiviert. Die zulässigen Schleppabstände werden jedoch weiterhin mit der gewählten Methode berechnet und angezeigt. Eine Überschreitung des zulässigen Schleppabstandes hat jedoch keine Reaktion der Steuerung zur Folge und dient vor allem während der Inbetriebnahme zur Parametrierung der Schleppabstandsüberwachung.

Durch das Setzen des Parameter P-AXIS-00176 auf den Wert 1 wird die Schleppabstandsüberwachung deaktiviert.

Kausales System, Systemlaufzeit

Der theoretische Schleppabstand [image] hängt von der Sollgeschwindigkeit [image] und dem Verstärkungsfaktor [image] wie folgt ab.

An der realen Achse ergibt sich jedoch ein realer Schleppabstand, der eine Verzögerung zu dem theoretischen Schleppabstand aufweist. Diese Verzögerung wird durch eine systembedingte Taktverschiebung im Lageregler der Steuerung sowie durch die mechanische Zeitkonstante des Systems verursacht. (Abbildung 1-1)

Da die Methoden zur Berechnung des zulässigen Schleppabstandes diesen Einfluss nicht berücksichtigen, kann mit einem zusätzlichen Zeitglied (PT1) der zulässige Schleppabstand verschoben werden. Das Zeitglied wird mit dem Parameter P-AXIS-00170 parametriert.

Abbildung 1-1: Verschiebung des realen Schleppabstandes

Laufzeit bei digitalen Antrieben

Bei einem digitalen Antrieb kann die NC zusätzlich eine Schleppabstandsüberwachung durchführen. Aufgrund der Laufzeit eines Antriebsbusses und der Verarbeitung im Antrieb selbst wird nach Ausgabe des Sollwerts der Istwert erst einige Takte später von der CNC eingelesen. Hierbei ist es wichtig, dass der Schleppabstand als Differenz von zeitlich zusammengehörenden Soll- und Istwerten ermittelt wird.

Die zeitliche Verzögerung wird mit dem Parameter P-AXIS-00191 angegeben.

Abbildung 1-2: Verzögerung des Sollwerts zur Berechnung des Schleppfehlers.

Mehr:

button Typ 1: Standard Methode

button Typ 2: Lineare Methode

button Typ 4: Geschwindigkeitsunabhängige Methode


Typ 1: Standard Methode

Beschreibung

Die Standard Methode (Typ 1) wird durch Setzen des Parameter P-AXIS-00172 auf den Wert 1 angewählt.

Diese Methode verwendet ein parametrierbares Abschätzungsfilter zur Berechnung des zulässigen Schleppabstands (Abbildung 1-3). Mit der Zeitkonstante P-AXIS-00167 des Filters kann dieser parametriert werden. Der zulässige Schleppabstand wird abhängig von der Geschwindigkeit berechnet und liegt innerhalb des parametrierbaren Bereichs. Der minimale zulässige Schleppabstand P-AXIS-00169 beschreibt im Stillstand dem maximal zulässigen Schleppabstand und bei der dynamischen Schleppabstandsüberwachung die unteren Grenze des zulässigen Schleppabstandes. Der Parameter P-AXIS-00168 ist der maximal zulässige Schleppabstand. Eine zeitliche Verschiebung des zulässigen Schleppabstandes kann mit dem Parameter P-AXIS-00170 durchgeführt werden.

: berechneter zulässiger Schleppabstand

: aktuelle Verfahrgeschwindigkeit

Die Standard Methode (Typ 1) berücksichtigt bei der Berechnung des maximalen Schleppabstandes nicht den KV-Faktor. Das bedeutet, dass nach Veränderung des KV-Faktors die Schleppabstandsüberwachung geprüft und eventuell neu parametriert werden muss.

Abbildung 1-3: Schleppabstandsüberwachung Typ 1  Standard-Methode

Empfohlene Parametrierung

P-AXIS-00169 ≥ 5 · ∆sStillstand

∆sStillstand : realer Schleppabstand im Stillstand (Selbst im Stillstand der Achse erhält man bei einem P-Lageregler aufgrund der Auflösung des Gebers und des Messsystems eine bleibenden Schleppabstand ∆sStillstand).


Typ 2: Lineare Methode

Beschreibung

Die Lineare Methode (Typ 2) wird durch Setzen des Parameter P-AXIS-00172 auf den Wert 2 angewählt.

Die Lineare Methode geht von dem theoretischen Schleppabstand aus, der sich mit folgender Formel berechnet:

Im Stillstand bestimmt der Parameter P-AXIS-00169 den zulässigen Schleppabstand. Für eine bewegte Achse wird die untere Grenze des zulässigen Schleppabstandes mit dem Parameter P-AXIS-00168 eingestellt. Oberhalb dieser Grenze wird der zulässige Schleppabstand wie folgt berechet:

: berechneter zulässiger Schleppabstand

: Verstärkungsfaktor des Lagereglers

: aktuelle Verfahrgeschwindigkeit

Der Parameter P-AXIS-00167 beschreibt einen Faktor, mit dem der dynamische Anteil des zulässigen Schleppabstand beeinflusst werden kann.

Die zeitliche Verschiebung des zulässigen Schleppabstandes erfolgt mit dem Parameter P-AXIS-00170. Die Abbildung 1-4 zeigt die Bereiche des zulässigen Schleppabstands für die Lineare Methode.

Abbildung 1-4: Schleppabstandsüberwachung Typ 2 - Lineare Methode

Empfohlene Parametrierung

P-AXIS-00169 ≥ 5 · ∆sStillstand

∆sStillstand : realer Schleppabstand im Stillstand


Typ 4: Geschwindigkeitsunabhängige Methode

Beschreibung

Wenn eine Achse mit Vorsteuerung betrieben wird, so ist der Schleppfehler dieser Achse bei korrekter Parametrierung der Vorsteuerung und 100 % Vorsteuerung immer annähernd Null.

Die in den vorhergehenden Abschnitten beschriebenen Typen der Schleppabstandsüberwachung berechnen in diesem Fall insbesondere bei hohen Geschwindigkeiten einen zu hohen Grenzwert für den Schleppabstand.

Um auch solche Achsen überwachen zu können wird beim Typ 4 auch für eine bewegte Achse ein konstanter Grenzwert verwendet.

Diese Methode (Typ 4) wird durch Setzen des Parameter P-AXIS-00172 auf den Wert 4 angewählt.

Beim Stillstand der Achse wird der Schleppabstand auf den Wert von P-AXIS-00169 überwacht, bei bewegter Achse auf P-AXIS-00168.

Diese Methode der Schleppabstandsüberwachung ist nur sinnvoll für Achsen, die immer mit 100 % Vorsteuerung betrieben werden.


Parameter

Mehr:

button Übersicht

button Beschreibung


Übersicht

ID | Parameter | Beschreibung
P-AXIS-00167 | slep_dyn | Faktor für die dynamische Schleppabstandsüberwachung
P-AXIS-00168 | slep_max | Maximaler Schleppabstand
P-AXIS-00169 | slep_min | Minimaler Schleppabstand
P-AXIS-00170 | slep_time_const | Zeitkonstante für die dynamische Schleppabstandsüberwachung
P-AXIS-00172 | slep_ueberw_typ | Art der dynamischen Schleppabstandsüberwachung
P-AXIS-00176 | suppress_pos_lag_error | Unterdrücken der Schleppabstandsüberwachung, reine Berechnung und Anzeige des Grenzwerts
P-AXIS-00191 | nbr_delay_cycles | Anzahl der Verzögerungen zwischen Soll- und Istwerten aufgrund der Buslaufzeit.


Beschreibung

P-AXIS-00167

Faktor für die dynamische Schleppabstandsüberwachung

Parameter

getriebe[i].slep_dyn

Beschreibung

Abhängig von eingestellten Schleppastandsüberwachung P-AXIS-00172 hat der Parameter folgenden Bedeutung:

Typ 1: Standard Methode

Zeitkonstante eines Abschätzungsfilters für die dynamische Schleppabstandsüberwachung.

Typ 2: Lineare Methode

Faktor der den dynamischen Anteil des zulässigen Schleppabstandes additiv zum theoretischen Anteil festlegt.

Datentyp

SGN16

Datenbereich

Typ 1: 700 ≤ AXIS-00167 < 1024

Typ 2: 0 ≤ P-AXIS-00167 < 1024

Dimension

-

Standardwert

1000

Anmerkungen

Wenn der Wert > 1024 ist, wird eine Warnung ausgegeben und der Wert auf 1024 gesetzt, d.h. die Schleppabstandsüberwachung ist ausgeschaltet.

Dieser Parameter muss durch Aufzeichnung der theoretischen und realen Schleppabstände eingestellt werden.

P-AXIS-00168 | Maximaler Schleppabstand
Parameter | getriebe[i].slep_max
Beschreibung | Typ 1: Standard Methode § Maximal zulässiger Schleppabstand Typ 2: Lineare Methode § Untere Grenze des zulässigen Schleppabstands bei der dynamischen Schleppabstandsüberwachung Typ 4: Geschwindigkeitsunabhängige Methode § Grenze des zulässigen Schleppabstands wenn sich die Achse bewegt.
Datentyp | SGN32
Datenbereich | 0 ≤ P-AXIS-00168 ≤ MAX(SGN32)
Dimension | translatorisch: 0,1 μ m | rotatorisch: 0,0001°
Standardwert | 5000000
Anmerkungen | -

P-AXIS-00169 | Minimaler Schleppabstand
Parameter | getriebe[i].slep_min
Beschreibung | Typ 1: Standard Methode § Maximal zulässiger Schleppabstand im Stillstand § Untere Grenze des zulässigen Schleppabstands bei der dynamischen Schleppabstandsüberwachung Typ 2: Lineare Methode § Maximal zulässiger Schleppabstand im Stillstand Typ 4: Geschwindigkeitsunabhängige Methode § Maximal zulässiger Schleppabstand im Stillstand
Datentyp | SGN32
Datenbereich | 1 ≤ P-AXIS-00169 ≤ MAX(SGN32)
Dimension | translatorisch: 0,1 μ m | rotatorisch: : 0,0001°
Standardwert | 5000000
Anmerkungen | -

P-AXIS-00170 | Zeitkonstante für die dynamische Schleppabstandsüberwachung
Parameter | getriebe[i].slep_time_const
Beschreibung | Dieser Parameter beschreibt die Zeitkonstante eines PT1-Gliedes, mit dem der zulässige Schleppabstand zeitverzögert ermittelt wird.
Datentyp | UNS32
Datenbereich | -
Dimension | μ s
Standardwert | 0
Anmerkungen | Mit dieser Zeitverzögerung kann der Einfluss der Beschleunigung auf den Schleppabstand beim Beschleunigen und Abbremsen kompensiert werden.

P-AXIS-00172 | Art der dynamischen Schleppabstandsüberwachung
Parameter | getriebe[i].slep_ueberw_typ
Beschreibung | Mit diesem Parameter kann der Schleppabstandsüberwachungstyp ausgewählt werden.
Datentyp | UNS32
Datenbereich | 0: Schleppabstandsüberwachung ausgeschaltet 1: Standard- Schleppabstandsüberwachung 2: Lineare Schleppabstandsüberwachung 3: Nichtlineare Schleppabstandsüberwachung 4: Schleppabstandsüberwachung mit konstantem Grenzwert für bewegte Achsen.
Dimension | -
Standardwert | 0: Schleppabstandsüberwachung ausgeschaltet
Anmerkungen | -

P-AXIS-00176 | Unterdrücken der Schleppabstandsüberwachung
Parameter | lr_param.suppress_pos_lag_error
Beschreibung | Die Reaktion der Schleppabstandsüberwachung kann mit diesem Parameter deaktiviert werden, der maximal zulässige Schleppabstand wird weiterhin mit der gewählten Methode berechnet und angezeigt.
Datentyp | BOOLEAN
Datenbereich | 0: Schleppabstandsüberwachung ist eingeschaltet 1: Schleppabstandsüberwachung ist ausgeschaltet
Dimension | -
Standardwert | 0
Anmerkungen | Dieser Parameter kann für Inbetriebnahmezwecke verwendet werden.

P-AXIS-00191 | Verzögerung des Istwerts bei digitalem Antrieb
Parameter | antr_digital.nbr_delay_cycles
Beschreibung | Die Laufzeit zwischen Ausgabe der Sollwerte und Einlesen der zugehörigen Istwerte wir hiermit bei der Berechnung des Schleppabstands mitberücksichtigt.
Datentyp | UNS16
Datenbereich | 0: Keine Verzögerung der Istwerte > 0: Verzögerung der Istwerte in Takten
Dimension | Takte
Standardwert | 0
Anmerkungen | Dieser Parameter wird aktuell nur bei SERCOS-Antrieben verwendet.