Übersicht

Abhängig von dem verwendeten Betriebssystem, der USV-Hardware und Software wird die USV-Unterstützung unterschiedlich konfiguriert. Die USV-Unterstützung kann entweder mit dem TwinCAT- oder Windows-USV-Dienst konfiguriert werden. Der TwinCAT USV-Dienst bietet Unterstützung für folgende Geräte:

  • 230V USV-Geräte an der Seriellen Schnittstelle ( APC oder Effekta ) mit Basis-Signalisierung unter Win NT;
  • Beckhoff IPC's mit einer integrierten 24V USV an der CP9030-Karte unter Win NT und Win 2000;
  • Beckhoff IPC's mit einer integrierten 24V USV an der COM-Schnittstelle unter Win NT;

Folgende Kapitel beschreiben die Funktionsweise und Konfiguration der unterschiedlichen USV-Typen.

1. Allgemeine Informationen zum Windows USV-Dienst

1.1 Basis-Signalisierung unter NT 4.0 und ASCII-Kommunikation unter Win2K/XP

1.2 Unterschiedliche Kabel-Typen und Art der Signalisierung;

2. APC

  • 2.1 APC-Konfiguration unter NT 4.0

  • 2.2 APC-Konfiguration unter Win2K/XP

3. Integrierte USV der Beckhoff IPC's

  • 3.1 24V USV am CP903x Panel-Link unter NT4.0/Win2K/XP

  • 3.1.1 Konfiguration mit dem Windows USV-Dienst

  • 3.1.2 Konfiguration mit dem TwinCAT USV-Dienst

  • 3.1.3 Konfiguration mit dem ActiveX Control CP9090-S100

  • 3.2 24V USV an der COM-Schnittstelle

  • 3.2.1 Konfiguration mit dem TwinCAT USV-Dienst unter NT4.0

  • 3.2.2 Konfiguration mit dem TwinCAT USV-Dienst unter Win2K/XP

  • 3.2.3 Konfiguration mit dem NT 4.0 USV-Dienst

  • 3.2.4 Konfiguration mit dem Win2K/XP USV-Dienst

4.FAQ

  • 230 V USV, Win 2000 und TwinCAT. Was ist zu beachten?

  • 230 V USV, Win NT und TwinCAT. Umsteigen mit bestehender Applikation auf Win 2000. Was ist zu beachten?

  • 230 V USV, Win NT und TwinCAT. Umsteigen mit bestehender Applikation auf neuere TwinCAT-Version. Was ist zu beachten?

  • 24 V USV, Win 2000 und TwinCAT. Was ist zu beachten?

  • 24 V USV, Win NT und TwinCAT. Umsteigen mit bestehender Applikation auf Win 2000. Was ist zu beachten?

  • 24 V USV , Win NT und TwinCAT. Umsteigen mit bestehender Applikation auf neuere TwinCAT-Version. Was ist zu beachten?

  • Nach einem Update von Win NT auf Win 2000 hängt meine Visualisierung nach einem Shutdown durch den Win 2000 USV-Dienst. Unter NT 4.0 war es nicht der Fall.

  • Nach einem Update von Win NT auf Win 2000 hängt meine Visualisierung nach einem Shutdown aus dem Start-Menü in der Taskleiste. Unter NT 4.0 war es nicht der Fall.


Basis-Signalisierung unter NT 4.0 und ASCII-Kommunikation unter Win2K/XP

Der Windows USV-Dienst kommuniziert mit den USV-Geräten über die serielle COM-Schnittstelle. Unter Windows NT 4.0 wird der Status der USV anhand der Signal-Pegel an den Pins der seriellen Schnittstelle erkannt. Diese Art der Kommunikation mit der USV wird auch Basis-Signalisierung (Basic-Signaling oder Simple-Signaling) genannt. Bei fehlender Versorgungsspannung wird der Pegel bestimmter Pins auf High oder Low gesetzt. In dem USV-Konfigurationsdialog von NT 4.0 lassen sich die Pegel konfigurieren. Ob die USV im inaktivem Zustand einen High- oder Low-Pegel an dem Pin besitzt, ist von Gerät zu Gerät unterschiedlich und muss der Gerätedokumentation entnommen werden.

Mit Windows 2000 wurde Advanced-Signaling eingeführt. Die Basis-Signalisierung wird aber weiter unterstützt. Beim Advanced-Signaling kann das Betriebssystem mit der USV über serielle Schnittstelle ASCII-Kommunikation durchführen. Dabei können erweiterte Statusinformationen zu der USV ermittelt werden. Im Vergleich zu der Basis-Signalisierung bring die ASCII-Kommunikation im Wesentlichen folgende Vorteile:

  • Der Benutzer muss nicht mehr die Pin-Polarität konfigurieren;
  • Es kann die zu erwartende Lebensdauer/Kapazität der Batterie einfach ermittelt werden.

Folgende Grafik zeigt den Status der USV, die gesendeten USV-Signale zum Betriebssystem und die Reaktion vom Betriebssystem auf Meldungen von der USV. Der Ablauf ist in dem Basis- und Advanced-Mode gleich:

Beim Ausfall der Spannungsversorgung sendet die USV ein Power-Fail Signal an das Betriebssystem und schaltet auf den Batteriebetrieb um. Das Betriebssystem kann Meldungen (Notifications) in konfigurierbaren Zeitabständen an einen Benutzer oder eine Gruppe von Benutzern senden. Wird während des Batteriebetriebes der sogenannte Critical-Alarm erreicht (USV meldet Low-battery oder die konfigurierte On battery-Zeit ist abgelaufen), kann eine Task (Benutzerapplikation/Batchdatei) aufgerufen werden. Danach wird ein Shutdown des Betriebssystems eingeleitet. Beim Einleiten des Shutdowns kann die USV so konfiguriert werden, dass sie sich nach einer Wartezeit abschaltet (Remote-OFF) um die Batterie zu schonen.

Hinweis:

  • Mit dem Wechsel von NT 4.0 zu Windows 2000 hat sich das Shutdown-Verhalten geändert. Dies hat zur Folge, dass die unter Windows 2000 konfigurierten USV-Geräte mit Basis-Signalisierung nach dem Shutdown nicht abgeschaltet werden können (kein Remote-OFF der USV möglich). Damit die USV abgeschaltet wird, muss bei der Basis-Signalisierung auf einen Pin der seriellen Schnittstelle ein bestimmter Pegel für einige Sekunden angelegt werden. Unter NT 4.0 können einige Prozesse mit limitierten Resourcen nach dem Shutdown laufen. Dieses ermöglicht die USV einige Zeit nach dem Shutdown über die serielle Schnittstelle abzuschalten. Unter Windows 2000 werden beim Shutdown alle Prozesse unterbrochen. Dieses Verhalten verhindert die USV über die serielle Schnittstelle abzuschalten. Es gibt keine Lösung für dieses Problem. Einige USV-Geräte besitzen einen internen Timer, der teilweise konfiguriert werden kann. Nachdem die Timerzeit abgelaufen ist, schaltet die USV ab. Bei den Back UPS Pro "S"-Modellen kann dieser Timer z.B. folgende Werte annehmen: 20, 120,180, 300 und 600 Sekunden. Einige Modelle haben einen Timer der fix auf 20 Sekunden eingestellt ist. Die Konfiguration des Timers wird von dem USV-Dienst durchgeführt.


Unterschiedliche Kabel-Typen und Art der Signalisierung

Manche USV-Hersteller liefern mehrere Verbindungskabel um Basis- oder Advanced-Signalisierung zu unterstützen. Die Art der Signalisierung hängt aber auch von der Firmware des USV-Gerätes ab. Wenn die USV unter Windows 2000 konfiguriert wird und ein Gerät aus der Liste der USV-Geräte ausgewählt wurde, dann sollte immer das mitgelieferte Verbindungskabel benutzt werden. Die passende Art der Signalisierung wird dann automatisch ausgewählt. Unter NT 4.0 muss ein Verbindungskabel für die Basis-Signalisierung benutzt werden. Die meisten USV-Verbindungskabel sind keine Standard RS-232-Verbindungskabel. Bei APC ist z.B. die Typbezeichnung auf dem Verbindungsstecker aufgedruckt.

Hinweis:

  • Wenn die USV in dem Windows NT 4.0 USV-Dienst konfiguriert wurde, braucht man die Konfiguration nach einem Update auf Windows 2000 nicht zu ändern. Die Einstellungen werden übernommen.
  • Von TwinCAT wird nur die Basis-Signalisierung unterstützt. Achten Sie darauf, dass Sie ein passendes Verbindungskabel benutzen.

Folgende Tabelle zeigt die Signale, die Windows NT 4.0 bei der Basis-Signalisierung mit der USV benutzt:

RS-232 Signal | 9 Pin Connector Pin # | 25 Pin Connector Pin # | UPS Usage
CTS | 8 | 5 | Power failure
DCD | 1 | 8 | Low battery
DTR | 4 | 20 | UPS shutdown

Mit der folgenden Schaltung können Power-Fail und Low-Battery unter NT 4.0 simuliert werden (Die Pins für 25 Pin Connector in Klammern):

Test:

Schalten Sie beide Schalter: Switch1 und Switch2 so, dass Pin 8 und 1 mit Pin 7 verbunden sind. In dem NT 4.0 Konfigurationsdialog setzen Sie die Optionen: Power fail signal und Low battery signal at... auf negativen Pegel. Starten Sie den USV-Service. Um Power-Fail zu simulieren schalten Sie den Switch1 um (Pin 8 mit 3 verbinden). Low-Battery kann mit Switch2 simuliert werden (Pin 1 mit 3 verbinden).


APC NT4.0 Overview

TwinCAT UPS - Reference

APC Konfiguration unter NT 4.0

Da der NT 4.0 USV-Dienst nur die Basis-Signalisierung unterstützt, muss das USV-Gerät diese Art der Kommunikation unterstützen. Außerdem wird ein passendes Verbindungskabel benötigt. APC liefert zu den USV-Geräten unterschiedliche Kabel und eigene Konfigurationssoftware PowerChute. Mit der PowerChute - Software wird auch ASCII-Kommunikation mit der USV ermöglicht. Folgende Tabelle gibt eine Übersicht welche Kabeltypen mit welcher Software benutzt werden können. Die Typbezeichnung der APC-Kabel befindet sich auf den Kabelsteckern.

Kabel Typ | Konfiguration mit NT4.0 USV-Dienst | Konfiguration mit TwinCAT | Konfiguration mit PowerChute plus
940-0020B | Ja | Nein | Nein
940-0024C | Nein | Nein | Ja
940-0095A | Nein | Ja | Ja
940-0095B | Nein | Ja | Ja


APC NT4.0 TwinCAT Configuration

APC Konfiguration unter NT4.0 mit dem TwinCAT USV-Dienst

Beispiel:

APC Back-UPS Pro 280 am COM1 soll mit dem TwinCAT konfiguriert werden. Die USV soll nach 10 Sekunden Batteriebetrieb den PC herunterfahren und abschalten. Wenn die Versorgungsspannung wieder vorhanden ist, soll der Shutdown nicht mehr abgebrochen werden können:

Kabel: 940-0095A oder 940-0095B, keine PowerChute-Software installieren!

1. Im TwinCAT System Manager fügen Sie ein E/A-Gerät ein:

2. Aus der Liste der verfügbaren Geräte wählen Sie die serielle Schnittstelle aus und bestätigen dies mit OK:

3. Die serielle Schnittstelle wird auf folgende Weise konfiguriert:

Ist die Checkbox No Abort ausgewählt, dann wird der Shutdown nicht unterbrochen wenn die externe Spannungsversorgung wieder vorhanden ist.

Ab der TwinCAT-Version 2.7 Build 501 gibt es auf dem Konfigurationsdialog noch eine zusätzliche Option: Delayed (NT4 only) . Diese Option muss angewählt werden um ein verzögertes Abschalten der USV nach dem Shutdown zu ermöglichen. Ist diese Option nicht ausgewählt, schaltet die USV zu früh ( während des Shutdowns ) ab.


APC NT4.0 UPS Service Configuration

APC Konfiguration mit dem NT4.0 USV-Dienst

Beispiel:

APC Back-UPS Pro 280 am COM1 soll mit dem NT 4.0 Dienst konfiguriert werden:

Kabel: 940-0020B, keine PowerChute-Software installieren!

Um zu vermeiden, dass der USV Akku während des USV-Shutdowns vollständig entladen wird, sollte der NT 4.0 USV Dienst auf folgende Weise konfiguriert werden:

Wird die Option "Batteriewarnsignal mindestens 2 Minuten vor dem Herunterfahren" ausgewählt, dann läuft der PC solange mit der Batteriespannung bis die Batterie fast leer ist und von der USV das Batteriewarnsignal gesendet wird. Erst dann wird das Betriebssystem heruntergefahren.

Das Betriebssystem errechnet die zu erwartete Batterielebenszeit anhand der Batterieaufladezeit für eine Minute. Diese Zeit wird nur dann erreicht ( in unserem Beispiel 2 Minuten ) wenn der PC 200 Minuten ohne Spannungsausfall betrieben wurde. Wenn die erwartete Batterielebenszeit nicht erreicht wird, wird der Shutdown sofort ausgeführt.


APC W2K Overview

APC Konfiguration unter Win2K/XP

Unter Windows 2000 werden von dem USV-Dienst während des Shutdowns die laufenden Applikationen und Prozesse ohne vorherige Benachrichtigung terminiert. Dadurch kann keine der laufenden Applikationen den eingeleiteten Shutdown-Vorgang mitbekommen und entsprechend reagieren (z.B. geöffnete Projekte speichern, Applikationsfenster schließen). Probleme können dann auftreten, wenn Applikationen die ADS-Verbindungen aufbauen, diese Verbindungen vor dem Shutdown nicht auflösen bzw. freigeben. Der Shutdown-Vorgang kann dann mehrere Minuten dauern oder "hängen" bleiben. Der Windows 2000 USV-Dienst bietet die Möglichkeit vor dem eigentlichen Shutdown eine Applikation (Scheduled task) auszuführen. Diese Task kann auch eine Batch-Datei sein in der der TwinCAT System Service explizit gestoppt wird und die ADS-Verbindugen dadurch freigegeben werden. Dabei werden z.B. die persistenten Daten und die aktuelle Konfiguration auf Datenträger gesichert. Bei einem Shutdown über das Start-Menü in der Taskleiste werden Windows-Messages (WM_QUERYENDSESSION und WM_ENDSESSION) an alle laufenden Applikationen gesendet. Der USV-Dienst sendet keine Messages, sondern beendet die laufenden Prozesse. In diesem Artikel wird eine Lösung vorgestellt wie die langen Shutdownzeiten vermieden werden können.

APC-Beispielkonfiguration mit dem Win2K/XP USV-Dienst

APC-Konfiguration unter Win2K/XP mit dem TwinCAT USV-Dienst


APC W2K TwinCAT UPS Configuration

APC Konfiguration unter Win2K/XP mit dem TwinCAT USV-Dienst

Da die APC-USV unter Windows 2000 von TwinCAT über die serielle Schnittstelle nicht verzögert abgeschaltet werden kann, benutzen Sie den Win2K/XP USV-Dienst um die USV zu konfigurieren.


APC W2K UPS Service Configuration

APC Konfiguration mit dem Win2K/XP USV-Dienst

Beispielkonfiguration einer APC-USV vom Typ: Back-UPS Pro 280

Das mitgelieferte Verbindungskabel hat die Bezeichnung: 940-0095A (grau). Die USV wurde an die zweite serielle Schnittstelle (COM2) angeschlossen.

Der Konfigurationsdialog für die USV (UPS) befindet sich unter den Energieoptionen (Power Options) in der Systemsteuerung (Control Panel):

1. Öffnen Sie den Dialog und wechseln Sie zu dem UPS-Karteireiter. Der UPS-Karteireiter zeigt den aktuellen Status der USV. In unserem Fall wurde noch keine USV konfiguriert.

2. Wählen Sie das Kommando Select... In dem Dialogfenster wählen Sie den Hersteller, das Modell und konfigurieren Sie den COM-Port an dem die USV angeschlossen ist. Schließen Sie den Dialog.
Wird die USV aus der Liste der Geräte ausgewählt, dann sollte immer das vom Hersteller mitgelieferte Verbindungskabel benutzt werden.

3. Wählen Sie das Kommando Configure... In dem Dialog UPS Configuration kann das Systemverhalten bei Power-Fail konfiguriert werden.

Enable all notifications: Mit der Option kann das Betriebssystem dazu veranlasst werden, bei Power-Fail Meldungen an Benutzer zu senden.

Critical alarm: Der Alarm wird dann ausgelöst wenn die Batteriespannung auf einen bestimmten Pegel gesunken ist oder wenn der Batteriebetrieb eine bestimmte Zeit überschritten hat.

Minutes on battery before critical alarm: Mit dieser Option kann festgelegt werden, wie viele Minuten der Batteriebetrieb läuft bis der Critical-Alarm ausgelöst werden soll. Erst wenn der Alarm ausgelöst wird, wird der Shutdown des Betriebssystems ausgelöst. Wenn die Option nicht aktiviert wurde, wird ein Shutdown erst dann ausgeführt, wenn die Batteriespannung auf einen kritischen Pegel gesunken ist. Um die Batterie zu schonen, sollte diese Option angewählt werden.

Die kleinste On-Battery Zeit ist auf 2 Minuten festgelegt. Diese Zeit kann aber durch einen entsprechenden Eintrag in der Windows-Registrierung auf einen anderen Wert gesetzt werden:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UPS\Config\ShutdownOnBatteryWait REG_DWORD = 0x00000000

When the alarm occurs, run this program: Mit dieser Option kann beim Alarm eine Applikation ausgeführt werden. In unserem Beispiel wird eine Batch-Datei: TCShutdownJob.bat mit folgendem Inhalt aufgerufen.

net stop "TwinCAT System Service"

Mit net stop "TwinCAT System Service" kann das TwinCAT System Service gestoppt werden ( net start "TwinCAT System Service" startet das System). Dadurch werden die bestehenden ADS-Verbindungen "sauber" beendet und lange Shutdown-Zeiten vermieden.

Finally, turn off the UPS: Wenn die Option angewählt ist, wird die USV nach dem Shutdown abgeschaltet (Power-OFF) um Batterie zu schonen. Um die Option nutzen zu können muss die USV ASCII-Kommunikation unterstützen. Geräte die nur Basis-Signalisierung unterstützen können unter Windows 2000 nicht abgeschaltet werden.

Hinweis:

Unter Windows 2000 kann der USV nicht mitgeteilt werden dass der Shutdown abgeschlossen wurde. Es wird angenommen, dass nach 180 Sekunden der Shutdown abgeschlossen worden ist und der PC abgeschaltet werden kann. Diese Zeit ist fest codiert, kann aber in der Windows-Registrierung auf einen Wert 0 bis 180 gesetzt werden ( z.B. auf 5 Sekunden ). Diese Zeit wird dann an die USV als Verzögerungszeit für das Abschalten der USV gesendet. Nachdem die Verzögerungszeit abgelaufen ist, schaltet die USV ab. Bei den Back UPS Pro "S"-Modellen kann dieser Timer z.B. folgende Werte annehmen: 20, 120,180, 300 und 600 Sekunden. Einige Modelle haben einen Timer der fix auf 20 Sekunden eingestellt ist.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UPS\Config\TurnUPSOffWait REG_DWORD = 0x00000005 (5)

4. Nachdem die Konfiguration erfolgreich abgeschlossen wurde, werden die aktuellen Statusinformationen der USV in dem Dialog angezeigt.


Beckhoff IPC 24V UPS Overview

Beckhoff IPC's mit einer integrierten 24V USV

Die integrierte 24V USV der Beckhoff IPC's kann entweder mit der seriellen COM-Schnittstelle oder mit der CP903x-Karte ( Panel-Link-Karte ) verbunden werden. Die erste Variante wird in IPC's verwendet, die keine CP903x-Karte besitzen. Die USV-Elektronik ist über ein spezielles Kabel mit dem seriellen COM-Port des PC's verbunden. Bei der zweiten Variante ist die USV-Elektronik mit der CP903x-Karte (Panel-Link) verbunden .

Für das verzögerte Abschalten der USV ist ein interner Zähler der CP903x Karte zuständig. Der Zähler wird beim Einleiten des Shutdowns per Software konfiguriert und beginnt sofort rückwärts zu zählen. Beim Wert Null schaltet sich die USV ab. Die COM-Port Variante besitzt einen derartigen Zähler nicht. Dadurch kann die USV unter Windows 2000 nicht verzögert abgeschaltet werden.


IPC 24V USV CP903x NT4.0 Win2K XP TwinCAT Configuration

Konfiguration der IPC 24V USV (am CP903x-Panel-Link) mit dem TwinCAT USV-Dienst unter NT4.0/Win2K/XP

Um die integrierte USV der CP9030-Karte unter TwinCAT zu konfigurieren führen Sie folgende Schritte aus:

1. Im TwinCAT Systemmanager fügen Sie ein E/A-Gerät ein:

2. Aus der Liste der verfügbaren Geräte wählen Sie die CP9030-Karte aus und bestätigen mit OK:

3. Auf dem Karteireiter CP9030 konfigurieren Sie den Adressbereich der Karte:

4. Konfigurieren Sie den UPS Karteireiter:

Ist die Checkbox No Abort ausgewählt, dann wird das Shutdown nicht unterbrochen, wenn die Spannungsversorgung wieder vorhanden ist. Nachdem das Betriebssystem heruntergefahren ist, wird die USV nach 5 Sekunden abgeschaltet um die Batterie zu schonen. Diese Zeit kann nicht konfiguriert werden. Speichern Sie die Konfiguration in Registrierung und starten Sie das TwinCAT System.


IPC 24V USV CP903x NT4.0 Win2K XP Win-UPS Service Configuration

Konfiguration der IPC 24V USV (am CP903x Panel-Link) mit dem NT4.0/Win2K/XP-USV-Dienst

Die USV kann nicht mit dem Windows USV-Dienst konfiguriert werden.


IPC 24V USV CP903x NT4.0 Win2K XP ActiveX Configuration

Konfiguration der IPC 24V USV (am CP903x Panel-Link) mit der CP9090-S100 ActiveX Komponente unter NT4.0/W2K/XP

Um die USV-Funktionalität des PC's nutzen zu können muss diese entsprechend konfiguriert und aktiviert werden. Die CP9090-S100 ActiveX Komponente ermöglicht den Zugriff auf die CP-Link Karte bei PC's auf denen keine TwinCAT Software installiert wurde. Um die USV aus einer Visual Basic-Applikation konfigurieren zu können führen Sie folgende Schritte aus:

1. Installieren Sie die CP9090-S100 ActiveX Komponente:

2. Fügen Sie die Komponente in die Komponentenpalette von Visual Basic ein:

3. Erstellen Sie eine Visual Basic Applikation mit der ActiveX Komponente. Über die Eigenschaften und Methoden können sie die USV aktivieren/deaktivieren oder den Status der USV abfragen.

Eine Beispielapplikation:

Hier können Sie die Beispielapplikation mit kompletten Sourcen entpacken. Eine Beschreibung der Methoden und Eigenschaften der ActiveX Komponente finden sie in der CP9090-S100 Dokumentation. Informationen zum Shutdown des Betriebssystems finden Sie in der Win32 API. In der Beispielapplikation finden Sie einige Sourcen um ein Shutdown aus einer Visual Basic Applikation durchführen zu können. Diese können als Ansatzpunkt für eigene Implementierungen benutzt werden.

Enable UPS: aktiviert bzw. deaktiviert die USV;

Enable Shutdown: Ist diese Option ausgewählt, dann wird bei Fehlenden externen Versorgungsspannung ein Shutdown des Betriebssystems ausgeführt.

Enable Delayed OFF: Aktiviert das verzögerte Abschalten der USV. In der Beispielapplikation kann zwischen 5 und 60 Sekunden Verzögerungszeit gewählt werden; Die Verzögerungszeit wird über die Eigenschaft UpsDelay konfiguriert. Sobald diese Eigenschaft einen Wert <>0 besitzt, wird ein interner Zähler zurückgezählt der beim Wert 0 die USV abschaltet. Dieser Vorgang, wenn eingeleitet, kann nicht mehr gestoppt werden. Achten Sie darauf dass Sie eine ausreichende Verzögerungszeit z.B. für einen Shutdown konfigurieren. In dem Rahmen UPS state wird der aktuelle Status des Ladereglers und der Akku- und externen Versorgungsspannung angezeigt;

Das VB Programm:

Beim Programmstart wird die Adresse der CP9030-Karte der Eigenschaft DeviceAddr zugewiesen und der Kommunikationsport geöffnet.

Private Sub Form_Load()
    BkCp9030W9x1.DeviceAddr = CPAddr_0xCC000 'The address of CP9030 card

    BkCp9030W9x1.DeviceOpen = True

    If Not BkCp9030W9x1.DeviceOpen Then 'Check if opened succesfully
        Call MsgBox("CP9030 not initialized! Check the CP9030 address.", vbCritical, "CP9090-S100 error")
        GoTo ErrorExit
    End If

    Timer1.Interval = 1000
    Timer1.Enabled = True
    Option1(1).Value = True

    'check if UPS already enabled
    chkEnableUPS.Value = IIf(BkCp9030W9x1.EnableUPS = True, vbChecked, vbUnchecked)

ErrorExit:
End Sub

Beim Beenden des Programms wird der Kommunikationsport geschlossen.

Private Sub Form_Unload(Cancel As Integer)
    BkCp9030W9x1.DeviceOpen = False
End Sub

Die USV wird über die Eigenschaft EnableUSV aktiviert bzw. deaktiviert.

Private Sub chkEnableUPS_Click()
    BkCp9030W9x1.EnableUPS = IIf(chkEnableUPS.Value = vbChecked, True, False)
End Sub

Der Status der USV wird mit der Hilfe eines Multimedia-Timers zyklisch überprüft und bei fehlenden externen Spannung Shutdown durchgeführt. Der Status der USV kann durch das Abfragen der entsprechenden Eigenschaften der ActiveX Komponente ermittelt werden.

Private Sub Timer1_Timer()
    chkAkkuCharged = IIf(BkCp9030W9x1.AkkuCharged = True, vbChecked, vbUnchecked)
    chkAkkuCharging.Value = IIf(BkCp9030W9x1.AkkuCharging = True, vbChecked, vbUnchecked)
    chkAkkuNotPresent.Value = IIf(BkCp9030W9x1.AkkuNotPresent = True, vbChecked, vbUnchecked)
    chkAkkuVoltageOk.Value = IIf(BkCp9030W9x1.AkkuVoltageOk = True, vbChecked, vbUnchecked)
    chkAkkuWaiting.Value = IIf(BkCp9030W9x1.AkkuWaiting = True, vbChecked, vbUnchecked)
    chkExtVoltageOk.Value = IIf(BkCp9030W9x1.ExtVoltageOk = True, vbChecked, vbUnchecked)

    If chkExtVoltageOk.Value = vbUnchecked Then

        'set the delay time to turn OFF the UPS
        If chkDelayedOff.Value = vbChecked Then
            BkCp9030W9x1.UpsDelay = IIf(Option1(0).Value = True, CPUpsDelay_5, CPUpsDelay_60)
        Else
            BkCp9030W9x1.UpsDelay = CPUpsDelay_0
        End If

        If chkEnableShutdown.Value = vbChecked Then

         'E.g. perform shutdown or other tasks
    Call Shutdown

        End If

    End If

End Sub


Beckhoff IPC 24V UPS an COM TwinCAT Configuration

Konfiguration der Beckhoff IPC 24V USV (am COM-Port) mit dem TwinCAT USV-Dienst unter NT4.0

1. Im TwinCAT System Manager fügen Sie ein E/A-Gerät ein:

2. Aus der Liste der verfügbaren Geräte wählen Sie die serielle Schnittstelle und bestätigen mit OK:

3. Die serielle Schnittstelle kann auf folgende Weise konfiguriert werden:

Ab der TwinCAT-Version 2.7 Build 501 gibt es auf dem Konfigurationsdialog noch eine zusätzliche Option: Delayed (NT4 only) . Diese Option muss angewählt werden um ein verzögertes Abschalten der USV nach dem Shutdown zu ermöglichen. Ist diese Option nicht ausgewählt, schaltet die USV zu früh ( während des Shutdowns ) ab.


Beckhoff IPC 24V COM NT40 UPS Service Configuration

Konfiguration der Beckhoff IPC 24V USV (am COM-Port) mit dem NT4.0 USV-Dienst

Die USV kann nicht mit dem NT 4.0 USV Dienst konfiguriert werden.


IPC 24V USV COM W2K TwinCAT Configuration

Konfiguration der Beckhoff IPC 24V USV (am COM-Port) mit TwinCAT USV-Dienst unter Win2K/XP

Die Konfiguration unter TwinCAT ist zwar möglich, die USV schaltet aber zu früh (während des Shutdowns) ab. Der Grund: Die USV besitzt kein verzögertes Abschalten.


Beckhoff IPC's mit einer integrierten 24V USV an der COM-Schnittstelle unter Win 2000

Konfiguration der Beckhoff IPC 24V USV (am COM-Port) mit dem Windows 2000 USV-Dienst

Diese USV kann mit dem Win 2000 USV-Dienst nicht konfiguriert werden.


FAQ

230 V USV, Win 2000 und TwinCAT. Was ist zu beachten?

Die USV muss mit Win 2000 USV-Dienst konfiguriert werden. Der USV-Dienst teilt den laufenden Applikationen nicht mit, dass ein Shutdown eingeleitet wurde. Von dem Shutdown-Dienst kann eine Task (Applikation) aufgerufen werden. Diese Applikation kann z.B. andere Applikationen schließen, Daten sichern, TwinCAT System stoppen usw.. Die USV kann nur dann abgeschaltet werden, wenn sie die ASCII-Kommunikation unterstützt und einen internen Timer besitzt der ein verzögertes Ausschalten (POWER OFF) ermöglicht. Eine Konfiguration mit USV-Dienst von TwinCAT ist zwar möglich, die USV kann aber von TwinCAT entweder nicht abgeschaltet werden oder schaltet zu früh ab. Ursache: kein Zugriff auf COM-Schnittstelle nach dem Shutdown, was unter NT möglich war.

230 V USV, Win NT und TwinCAT. Umsteigen mit bestehender Applikation auf Win 2000. Was ist zu beachten?

Der USV-Dienst von TwinCAT sollte unter Win 2000 nicht benutzt werden. Die USV kann von TwinCAT unter Win 2000 nicht abgeschaltet werden oder schaltet zu früh ab (während des Shutdown-Vorgangs). Die USV muss unter Win 2000 mit dem Win 2000 USV-Dienst konfiguriert werden. Die USV sollte einen internen Timer für ein verzögertes Abschalten besitzen und die ASCII-Kommunikation unterstützen. Applikationen, die ADS-Kommunikation benutzen können während des Shutdowns "hängen". Der Shutdown kann so z.B. 10 Minuten oder länger dauern. Die Ursache liegt darin, dass die geöffneten ADS-Verbindungen nicht freigegeben werden. Die bestehenden ADS-Verbindungen können durch beenden des "TwinCAT System Services" freigegeben werden. Der TwinCAT System Service wird durch einen Aufruf in einer Batch-Datei beendet. Diese Batch-Datei kann von dem Win 2000 USV-Service beim Shutdown aufgerufen werden. Die Applikationen beim USV-Shutdown werden nicht mit WM_QUERYENDSESSION beendet. Die bestehenden Applikationen müssen eventuell geändert werden um auf den Shutdown richtig reagieren zu können. Wenn der Win 2000 USV Service benutzt wird kann aus der SPS nicht direkt über gemappte Variablen auf die Status-Informationen der USV zugegriffen werden. Die SPS-Applikationen müssen eventuell geändert werden.

230 V USV, Win NT und TwinCAT. Umsteigen mit bestehender Applikation auf neuere TwinCAT-Version. Was ist zu beachten?

Ein Umstieg auf eine neuere TwinCAT-Version innerhalb des gleichen Betriebssystems ist immer möglich. Es müssen keine besondere Vorkehrungen (Konfigurationsänderungen) getroffen werden.

24 V USV, Win 2000 und TwinCAT. Was ist zu beachten?

24V USV an der CP9030:

Die USV sollte mit TwinCAT konfiguriert werden. Handelt es sich um eine CP9030-Karte mit einer älteren Firmware, dann muss ein Update auf die neueste Firmware durchgeführt werden. In der neuesten Firmware (ab der Version 1.73xxx) ist das verzögerte Abschalten (POWER OFF) der USV implementiert.

24V USV an der COM-Schnittstelle:

Die USV kann zur Zeit unter Win 2000 mit TwinCAT USV-Dienst zwar konfiguriert aber nicht richtig abgeschaltet werden. Die USV schaltet zu früh oder gar nicht ab. Diese USV kann nicht verzögert abgeschaltet werden. Zur Zeit sollte ein anderer USV-Typ unter Win 2000 eingesetzt werden. Diese USV kann nicht mit dem Win 2000 USV -Dienst konfiguriert werden. Von dem Win 2000 USV-Dienst wird nur die APC-Pinbelegung unterstützt. Die USV besitzt aber EFFEKTA-Pinbelegung.

24 V USV, Win NT und TwinCAT. Umsteigen mit bestehender Applikation auf Win 2000. Was ist zu beachten?

24V USV an der CP9030:

Es müssen keine Änderungen an der Konfiguration vorgenommen werden. Handelt es sich um eine CP9030-Karte mit einer älteren Firmware, dann muss ein Update auf die neueste Firmware durchgeführt werden. In der neuesten Firmware (ab der Version 1.73xxx) ist das verzögerte Abschalten (POWER OFF) der USV implementiert.

24V USV an der COM-Schnittstelle:

Die USV kann zur Zeit unter Win 2000 mit TwinCAT USV-Dienst zwar konfiguriert aber nicht richtig abgeschaltet werden. Die USV schaltet zu früh oder gar nicht ab. Diese USV kann nicht verzögert abgeschaltet werden. Zur Zeit sollte ein anderer USV-Typ unter Win 2000 eingesetzt werden. Diese USV kann nicht mit dem Win 2000 USV -Dienst konfiguriert werden. Von dem Win 2000 USV-Dienst wird nur die APC-Pinbelegung unterstützt. Die USV besitzt aber EFFEKTA-Pinbelegung.

24 V USV , Win NT und TwinCAT. Umsteigen mit bestehender Applikation auf neuere TwinCAT-Version. Was ist zu beachten?

Ein Umstieg auf eine neuere TwinCAT-Version innerhalb des gleichen Betriebssystems ist immer möglich. Es müssen keine besondere Vorkehrungen (Konfigurationsänderungen) getroffen werden.

Nach einem Update von Win NT auf Win 2000 hängt meine Visualisierung nach einem Shutdown durch den Win 2000 USV-Dienst. Unter NT 4.0 war es nicht der Fall.

Möglicherweise verhindern die geöffneten ADS-Ports den Shutdown. Konfigurieren Sie unter dem Win 2000 USV-Dienst eine Shutdown-Task die den TwinCAT System Service beendet und die geöffneten ADS-Ports automatisch schließt.

In unserem Beispiel wird eine Batch-Datei: TCShutdownJob.bat mit folgendem Inhalt aufgerufen.

net stop "TwinCAT System Service"

Mit net stop "TwinCAT System Service" kann das TwinCAT System Service gestoppt werden ( net start "TwinCAT System Service" startet das System).

Nach einem Update von Win NT auf Win 2000 hängt meine Visualisierung nach einem Shutdown aus dem Start-Menü in der Taskleiste. Unter NT 4.0 war es nicht der Fall.

In der Applikation müssen Sie die Windows-Message: WM_ENDSESSION abfangen und beim Auftreten dieser Message geöffnete ADS-Ports schließen. Die geöffneten ADS-Ports verhindern den Shutdown.

Die USV ist mit dem Win 2000 USV-Service konfiguriert. Nach einem USV-Shutdown bootet der PC durch statt sich abzuschalten.

Sie benutzen ein ATX-Netzteil, das das Abschalten des PC's ermöglicht und eine USV die am COM-Port hängt. Möglicherweise ist die Aktivität der USV am COM-Port für das durchbooten des PC's verantwortlich. Sehen Sie in BIOS nach ob es da einen Parameter gibt, der den PC bei Aktivität am COM-Port einschaltet. Deaktivieren Sie diese Funktion.