Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

In der Bibliothek TcSUPS.Lib sind Funktionen und Funktionsbausteine enthalten, die zur Ansteuerung der Sekunden-USV nötig sind. Siehe Beispielprojekt Sample_S_UPS.pro.

Funktionsbausteine

Name | Beschreibung
FB_S_UPS | Baustein zur Ansteuerung der Sekunden-USV
FB_NT_QuickShutdown | Interner Baustein für den QuickShutdown, wird von dem FB_S_UPS verwendet.

Funktionen

Name | Beschreibung
F_GetVersionTcSUPS | Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.

Anforderungen

Komponente | Version
TwinCAT auf dem Entwicklungsrechner und auf der Steuerung | TwinCAT 2.11 Build 2016 oder höher (R2)


FUNCTION_BLOCK FB_S_UPS

Der Funktionsbaustein FB_S_UPS kann auf PCs mit Sekunden-USV verwendet werden, um die Sekunden-USV aus der SPS anzusteuern. Hiermit können bei Spannungsausfall noch die Persistenten Daten gespeichert und ein QuickShutdown ausgeführt werden. Wenn möglich sollten die Defaultwerte der INPUTs des FB_S_UPS beibehalten werden.

Achtung 		Datenverlust

Die Sekunden-USV kann bei Spannungsausfall nur für wenige Sekunden verwendet werden, um z.B. Persistente Daten zu speichern. Das Speichern der Daten muss im schnellen Persistent Modus "SPDM_2PASS" erfolgen, auch wenn es hier zu Echtzeitverletzungen kommen kann. Zum Speichern der Persistenten Daten muss hinreichend Routerspeicher konfiguriert werden!

Für das Überbrücken von Spannungsausfällen hat die Sekunden-USV nicht genügend Kapazität. Das Speichern kann nur auf der Compact Flash Karte erfolgen, da auch für den Betrieb einer Festplatte nicht genügend USV-Kapazität vorhanden ist.

Im Modus eSUPS_WrPersistData_Shutdown (Standardeinstellung) wird nach dem Speichern der Persistenten Daten automatisch ein QuickShutdown ausgeführt.

Im Modus eSUPS_WrPersistData_NoShutdown werden nur die Persistenten Daten gespeichert, es wird kein QuickShutdown ausgeführt.

Im Modus eSUPS_ImmediateShutdown wird sofort ein QuickShutdown ausgeführt, ohne das Speichern von Daten.

Im Modus eSUPS_CheckPowerStatus wird nur geprüft, ob ein Spannungsausfall auftrat. Ist dies der Fall, geht der Baustein erst nach Ablauf der tRecoverTime (10s) wieder in den Zustand PowerOK.

Unabhängig vom Modus und damit unabhängig vom Speichern oder Herunterfahren der Steuerung schaltet die USV nach Entladung der Kondensatoren das Mainboard ab, auch wenn die Spannung zwischenzeitlich wiederkehrt.

Achtung 		Achtung bei Verwendung von Dateien:
Falls andere Applikationen oder die SPS noch weitere Dateien offen halten oder in diese schreiben, kann es zu fehlerhaften Dateien kommen, wenn die USV die Steuerung abschaltet.

Achtung 		Achtung bei Verwendung von Windows XP embedded:
Zum Schutz der Windows XP embedded-Dateien muss auf Geräten mit der Sekunden-USV entweder der EWF (Enhanced Write Filter) oder der FBWF (File Based Write Filter) aktiviert sein.

Im Falle des EWF muss das TwinCAT\Boot-Verzeichnis auf einer ungeschützten Partition liegen (siehe in der Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\System\BootPrjPath).

Im Falle des FBWF muss das TwinCAT\Boot-Verzeichnis vom Schutz ausgenommen werden (siehe Beckhoff FBWF Manager, Exclusion Settings).

FUNCTION_BLOCK FB_S_UPS

VAR_INPUT

VAR_INPUT
    sNetID          : T_AmsNetId := '';               (* '' = local netid *)
    iPLCPort        : UINT := AMSPORT_R0_PLC_RTS1;    (* PLC Runtime System for writing persistent data *)
    iUPSPort        : UINT := 16#4A8;                 (* Port for reading Power State of UPS, dafault 16#4A8 *)
    tTimeout        : TIME := DEFAULT_ADS_TIMEOUT;    (* ADS Timeout *)
    eUpsMode        : E_S_UPS_Mode := eSUPS_WrPersistData_Shutdown; (* UPS mode (w/wo writing persistent data, w/wo shutdown) *)
    ePersistentMode : E_PersistentMode := SPDM_2PASS; (* mode for writing persistent data *)
    tRecoverTime    : TIME := T#10s;                  (* ON time to recover from short power failure in mode eSUPS_WrPersistData_NoShutdown/eSUPS_CheckPowerStatus *)
END_VAR

sNetID : AmsNetID der Steuerung.

iPLCPort : Portnummer des SPS-Laufzeitsystems (AMSPORT_R0_PLC_RTS1 = 801, AMSPORT_R0_PLC_RTS2 = 811, AMSPORT_R0_PLC_RTS3 = 821, AMSPORT_R0_PLC_RTS4 = 831).

iUPSPort : Portnummer über die der USV-Status gelesen wird (Standardwert ist 16#4A8).

tTimeout : Timeout für die Ausführung des QuickShutdowns.

eUpsMode : eUpsMode definiert, ob Persistente Daten geschrieben werden sollen und ob ein QuickShutdown ausgeführt werden soll.
Standardwert ist eSUPS_WrPersistData_Shutdown, d.h. mit Schreiben der Persistenten Daten und dann QuickShutdown. Siehe E_S_UPS_Mode.

ePersistentMode : Modus für das Schreiben der Persistenten Daten. Standardwert ist SPDM_2PASS.

tRecoverTime : Zeit, nach der die USV bei UPS-Modi ohne Shutdown wieder in den PowerOK Status zurück geht.
Die tRecoverTime muss etwas größer sein, als die maximale Haltezeit der USV, da die USV auch bei wiederkehrender Spannung abschaltet.

VAR_OUTPUT

VAR_OUTPUT
    bPowerFailDetect	: BOOL;            (* TRUE while powerfailure is detected *)
    eState 		: E_S_UPS_State;   (* current ups state *)
END_VAR

bPowerFailDetect : True während des Spannungsausfalls; False, wenn die Versorgungsspannung anliegt .

eState : Interner Zustand des Funktionsbausteins, Werte siehe E_S_UPS_State.

VAR_GLOBAL

VAR_GLOBAL
    eGlobalSUpsState : E_S_UPS_State;    (* current ups state *)
END_VAR

eGlobalUpsState : Interner Zustand des Funktionsbausteins als globale Kopie des VAR_OUTPUT eState, Werte siehe E_S_UPS_State.

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2016 oder höher (R2) | PC (i386) | Sekunden USV | TcSUPS.Lib


FUNCTION_BLOCK FB_NT_QuickShutdown

Mit dem Funktionsbaustein FB_NT_QuickShutdown führt die Steuerung einen unmittelbaren Reboot durch, ohne dass TwinCAT oder das Betriebssystem Windows gestoppt werden.

Achtung:

Achtung 		Datenverlust

Der Funktionsbaustein FB_NT_QuickShutdown wird intern vom FB_S_UPS verwendet und darf nicht eigenständig verwendet werden, da sonst mit Datenverlust zu rechnen ist!

FUNCTION_BLOCK FB_NT_QuickShutdown

VAR_INPUT

VAR_INPUT
    NETID :T_AmsNetId;
    START :BOOL;
    TMOUT :TIME := DEFAULT_ADS_TIMEOUT;
END_VAR

NETID : AmsNetID der Steuerung.

START : Steigende Flanke führt zum unmittelbaren Reboot der Steuerung.

TMOUT : Timeout-Zeit.

VAR_OUTPUT

VAR_OUTPUT
    BUSY  :BOOL;
    ERR   :BOOL;
    ERRID :UDINT;
END_VAR

BUSY : Der QuickShutdown wird ausgeführt.

ERR : Wird TRUE, sobald ein Fehler eintritt.

ERRID : Liefert bei einem gesetzten ERR-Ausgang die Fehlernummer.

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken


FUNCTION F_GetVersionTcSUPS

Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.

FUNCTION F_GetVersionTcSUPS : UINT

VAR_INPUT
    nVersionElement : INT;
END_VAR

nVersionElement : Versionselement, das gelesen werden soll. Mögliche Parameter:

  • 1 : major number;
  • 2 : minor number;
  • 3 : revision number;
Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken


TYPE E_S_UPS_Mode

eSUPS_WrPersistData_Shutdown: Schreiben der Persistenten Daten und dann QuickShutdown

eSUPS_WrPersistData_NoShutdown: Nur Schreiben der Persistenten Daten (kein QuickShutdown)

eSUPS_ImmediateShutdown: Nur QuickShutdown (kein Schreiben der Persistenten Daten)

eSUPS_CheckPowerStatus: Nur Status ermitteln (weder Schreiben der Persistenten Daten noch QuickShutdown)

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken


TYPE E_S_UPS_State

eSUPS_PowerOK:
    in allen Modi: Versorgungsspannung ist OK

eSUPS_PowerFailure:
    in allen Modi: Versorgungsspannung fehlerhaft (steht nur einen Zyklus an)

eSUPS_WritePersistentData:
    im Modus eSUPS_WrPersistData_Shutdown: Schreiben der Persistenten Daten ist aktiv
    im Modus eSUPS_WrPersistData_NoShutdown: Schreiben der Persistenten Daten ist aktiv

eSUPS_QuickShutdown:
    im Modus eSUPS_WrPersistData_Shutdown: QuickShutdown ist aktiv
    im Modus eSUPS_ImmediateShutdown: QuickShutdown ist aktiv

eSUPS_WaitForRecover:
    im Modus eSUPS_WrPersistData_NoShutdown: Warten auf Wiederkehr der Spannung
    im Modus eSUPS_CheckPowerStatus: Warten auf Wiederkehr der Spannung

eSUPS_WaitForPowerOFF:
    im Modus eSUPS_WrPersistData_Shutdown: Warten auf das Abschalten durch die USV
    im Modus eSUPS_ImmediateShutdown: Warten auf das Abschalten durch die USV

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken