Beckhoff TwinCAT - SPS und Motion Control auf dem PC

TwinCAT - SPS und Motion Control auf dem PC

The Windows Control and Automation Technology

Das Beckhoff-TwinCAT-Softwaresystem verwandelt nahezu jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. TwinCAT substituiert herkömmliche SPS- und NC/CNC-Steuerungen sowie Bediengeräte:

  • offene, kompatible PC-Hardware
  • Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
  • Programmiersystem und Laufzeit wahlweise auf einem PC oder getrennt
  • Anbindung an alle gängigen Feldbusse
  • PC-Schnittstellen werden unterstützt
  • Datenanbindung an Bedienoberflächen und andere Programme mittels offener Standards (OPC, OCX, DLL etc.)

TwinCAT-Architektur

TwinCAT besteht aus Laufzeitsystemen zur Echtzeitausführung von Steuerungsprogrammen und den Entwicklungsumgebungen zur Programmierung, Diagnose und Konfiguration. Alle Windows-Programme, beispielsweise Visualisierungen oder Office-Produkte, können über Microsoft-Schnittstellen auf TwinCAT-Daten zugreifen oder Kommandos ausführen.

Praxisorientierte Softwarelösung

TwinCAT bietet eine genaue Zeitbasis, die mit höchster Deterministik Programme unabhängig von anderen Prozessoraufgaben ausführt. Die Echtzeitlast auf einem PC wird mit TwinCAT eingestellt: Auf diese Weise wird ein definiertes Betriebsverhalten erreicht. TwinCAT zeigt die Systemlast für laufende Programme an. Eine Lastgrenze kann eingestellt werden, um für die Bedienprogramme und Windows NT/2000/XP/Vista eine definierte Rechenkapazität zur Verfügung zu stellen. Bei Überschreiten dieser Grenze wird eine Systemmeldung generiert.

TwinCAT unterstützt die Systemdiagnose

Die freie Verwendung von Hardware oder Software aus der offenen PC-Welt erfordert eine Prüfung: Ungeeignete Komponenten können das PC-System außer Tritt bringen. Beckhoff integriert eine praktische Anzeige des Jitters der Echtzeit, um dem Administrator ein einfaches Mittel zur Evaluierung von Hard- und Software an die Hand zu geben. Im Betrieb kann eine Systemmeldung auf Fehlerzustände aufmerksam machen.

Start-/Stoppverhalten

TwinCAT startet und stoppt, je nach Einstellung, durch manuellen Eingriff oder automatisch. Da TwinCAT als Service in Windows NT/2000/XP/Vista und Windows 7 integriert ist, wird zum Systemstart kein Bediener benötigt: Strom einschalten genügt.

Wiederanlauf und Datensicherung

TwinCAT lädt beim Start oder Wiederanlauf Programme und remanente Daten. Zur Datensicherung und zum korrekten Beenden von Windows NT/2000/XP/Vista und Windows 7 empfiehlt sich eine USV (unterbrechungsfreie Stromversorgung).

TwinCAT und „Blue Screen“

Das TwinCAT-System kann so konfiguriert werden, dass die Echtzeit im Falle eines Betriebssystemabsturzes BSOD (Blue-Screen-of-Death) funktionell erhalten bleibt. Echtzeittasks, wie z. B. die SPS und NC, können somit weiterlaufen und den gesteuerten Prozess in einen sicheren Zustand bringen. Letztlich liegt es in der Entscheidung des Programmierers, diese Eigenschaft zu nutzen, da Daten oder Programme durch den BSOD bereits zerstört sein können.

Weltweite Verbindung per Message-Routing – „Remote“-Verbindung ist systemimmanent

Die Softwaregeräte von TwinCAT können, je nach Anforderung, auf verschiedene Betriebsmittel verteilt werden: TwinCAT-SPS-Programme können auf PCs und auf Beckhoff Busklemmen Controllern ablaufen. Ein „Message-Router“ verwaltet und verteilt alle Nachrichten im System und über TCP/IP-Verbindungen. PC-Systeme lassen sich per TCP/IP miteinander verbinden; Busklemmen Controller werden über serielle Schnittstellen und über Feldbusse (EtherCAT, Lightbus, PROFIBUS DP, CANopen, RS232, RS485, Ethernet TCP/IP) angebunden.

Weltweiter Zugriff

Durch die Nutzung der Standard-TCP/IP-Dienste von Windows NT/2000/XP/Vista/CE und Windows 7, kann dieser Datenaustausch weltweit erfolgen. Das System bietet skalierbare Kommunikations-
leistung und Timeout-Zeiten zur Überwachung von Kommunikationen. Mittels OPC kann auf einem standardisierten Weg auf viele unterschiedliche SCADA/MES/ERP-Pakete zugegriffen werden.

Beckhoff Automation


Beckhoff TwinCAT | SPS und Motion Control auf dem PC

SPS und Motion Control auf dem PC

TwinCAT I/O – universelles I/O-Interface für alle gängigen Feldbusse

Viele PC-Feldbuskarten verschiedener Hersteller werden unterstützt. Es ist möglich, mehr als eine Feldbuskarte pro PC zu betreiben. Sowohl Master- als auch Slavefunktionalität werden, abhängig von der gewählten Feldbuskarte, unterstützt. Die komfortable Konfiguration und Diagnose der Feldbuskarten erfolgt im TwinCAT System Manager. TwinCAT I/O beinhaltet das TwinCAT-Echtzeitsystem, mit dem die Feldbusse betrieben werden, und eine DLL-Schnittstelle zu Anwenderprogrammen.

TwinCAT PLC – zentraler Pfeiler der Automatisierungssoftware

Als reine Software-SPS konzipiert, erlaubt TwinCAT PLC die Programmierung von bis zu vier virtuellen „SPS-CPUs“ mit jeweils bis zu vier Anwendertasks auf einem PC. Das SPS-Programm kann dabei wahlweise in einer oder in mehreren von der IEC 61131-3-Norm vorgesehenen Sprachen erfolgen:

  • IL (Anweisungsliste),
  • LD (Kontaktplan),
  • FBD/CFC (Funktionsblockdiagramm),
  • SFC (Ablaufsprache) und
  • ST (Strukturierter Text).

TwinCAT PLC umfasst unter den Betriebssystemen Windows NT/2000/XP/Vista sowohl Programmierumgebung als auch Laufzeit, sodass kein separates Programmiergerät benötigt wird. Unter dem Betriebssystem CE, sowie unter den Embedded-Betriebssystemen für die Controller der Serien BX und BC, gibt es nur die TwinCAT-Runtime. Programmänderungen werden über eine, auch netzwerkfähige, leistungsfähige Kommunikation zum Laufzeitsystem durchgeführt. Programmiert werden kann

  • lokal,
  • über TCP/IP oder
  • über den Feldbus (BXxxxx und BCxxxx).

IEC 61131-3 – moderner Programmierstandard für alle Beckhoff-Steuerungen

Das SPS-System TwinCAT PLC wird herstellerunabhängig nach IEC 61131-3 programmiert. TwinCAT unterstützt alle IEC 61131-3-Programmiersprachen mit komfortablen Editoren sowie einem schnellen, effektiven Compiler, sodass auch die Erstellung umfangreicher SPS-Programme in der Größenordnung mehrerer Megabytes in kurzen Entwicklungszyklen möglich ist. Inkrementelles Compilieren verhindert lange Turn-around-Zeiten. Es wird nur compiliert, was wirklich neu ist. Leistungsstarke Editor-Features, wie Autoformat, Autodeclare, Suchen und Ersetzen, ermöglichen ein schnelles Programmieren. Mit dem Projektvergleich lassen sich für alle Programmiersprachen Unterschiede leicht herausfinden und gegebenenfalls übernehmen. Soll ein Projekt (Kommentare, Verzeichnisse usw.) in eine andere Sprache als die Ursprungssprache übersetzt werden, so können alle Begriffe in eine Tabelle exportiert, übersetzt und wieder importiert werden. Wird in einem Team entwickelt, so können alle Objekte (Bausteine, Datentypen, Listen) mit dem TwinCAT-Engineering-Interface in einem Quellcodeverwaltungstool verwaltet werden. Damit lassen sich Änderungen zurückverfolgen und Differenzen zwischen einzelnen Versionen anzeigen.

Das Konzept der Instanziierung von Funktionsbausteinen mit jeweils eigenen Instanzdaten führt zu einer objektorientierten und strukturierten Programmierweise. Alle in der IEC 61131-3 spezifizierten und gebräuchlichen Datentypen werden unterstützt. Mehrdimensionale Felder und Strukturen sind ebenso möglich wie Enumerations- und Unterbereichstypen.

TwinCAT PLC ist nach dem Baselevel für die Sprachen IL und ST zertifiziert. Durch eine Online-Änderung (Online-Change) können Code- und/oder Datenänderungen bei laufender SPS mit maximalem Datenerhalt durchgeführt werden. Eine Quellcodespeicherung im Zielsystem ist möglich (außer bei Controllern der BCxxxx-Familie). Zum einfachen Detektieren von Prozessfehlern ist die Kriterienanalyse sehr hilfreich.

Die Wiederverwendung des Codes ist sehr einfach mit dem komfortablen Bibliotheksmanager zu realisieren. Zum Know-how-Schutz können die Programme und Bibliotheken mit einem mehrstufigen Passwortschutz versehen werden.

Vielfache Zielplattformen – ein Werkzeug

Die mit TwinCAT PLC erstellten SPS-Programme können auf unterschiedlichen Zielplattformen zur Ausführung gebracht werden. Neben den Industrie-PCs und Embedded-PCs kann das SPS-Projekt auch auf die Beckhoff-Feldbus-Controller der Serien BC und BX geladen werden. Die Programmentwicklung und das Debugging erfolgen – unabhängig von der ausführenden Einheit – in der gleichen Arbeitsumgebung.

Umfangreiche Zusatzbibliotheken

Als Ergänzung zu den von der IEC-Sprachnorm definierten Bausteinen bietet Beckhoff umfangreiche Zusatzbibliotheken zur Lösung typischer Anforderungen der Automatisierungstechnik: z. B. Bibliotheken zur Ansteuerung von elektrischen und hydraulischen Achsen über TwinCAT NC, serielle Kommunikationsbibliotheken, Systembibliotheken für Meldungsausgaben, Dateien schreiben/lesen, Regelungstechnikbausteine etc.

Hilfreiche Praxistools

Umfangreiche Fehlersuchfunktionen in TwinCAT PLC erleichtern die Problembehebung vor Ort oder über Fernwartung. Dazu bietet die SPS-Programmierumgebung in TwinCAT folgende Eigenschaften:

  • Monitoring,
  • Powerflow (Ablaufkontrolle),
  • Breakpoint,
  • Sampling-Trace von SPS-Variablen,
  • Single-Step,
  • Watchlist,
  • Aufrufhierachie und
  • Forcen von Variablen.

Ergänzend können mit dem TwinCAT ScopeView, einem Software-Oszilloskop, eine oder mehrere Variablen zeitgleich aufgezeichnet werden.

TwinCAT NC – Motion Control auf dem PC

Eine Software-NC besteht aus:

  • Positionierung (Sollwertgenerierung und Lageregelung)
  • integrierter SPS mit NC-Schnittstelle
  • Bedienprogrammen zur Inbetriebnahme
  • I/O-Anbindung für Achsen über Feldbus

Der Lageregler wird bei TwinCAT NC standardmäßig auf dem PC gerechnet und tauscht zyklisch Daten mit Antrieben und Messsystemen über den Feldbus aus.

Zentrale NC-Positionierung auf dem PC

Die Rechenleistung eines PCs ermöglicht, gleichzeitig mit der SPS, auch Achsen zu bewegen, wobei der Lageregler im Allgemeinen auf dem PC gerechnet wird: Mit der Leistung eines PCs können viele Achsen gleichzeitig positioniert werden.

Mit TwinCAT ist ein PC in der Lage, die Bedienprogramme, die SPS und die NC gleichzeitig zu bearbeiten. Die Auslegung der Systemlast wird von TwinCAT mit entsprechenden Funktionen unterstützt.

Analytische Bahnberechnung

Die von TwinCAT NC/NC I/CNC verwendeten Algorithmen zur Achsenansteuerung berücksichtigen die dynamischen Parameter der Achse: Geschwindigkeit, Beschleunigung und Ruck. Somit werden die Achsen zu jedem Zeitpunkt im Rahmen ihrer dynamischen Möglichkeiten bewegt und analytisch exakt koordiniert. Für die Reduzierung der in der Praxis auftretenden Abweichung von der Idealtrajektorie steht eine Auswahl verschiedener Regelalgorithmen zur Verfügung.

Einzeln oder zusammen

Aufbauend auf der normalen Positionierung einer einzelnen elektrischen Achse, von einem Ort zum Ziel (Point-to-Point-Positionierung), sind mit TwinCAT NC auch die koordinierten Bewegungen mehrerer Achsen im mehrstufigen Master-/Slavebetrieb (z. B. Getriebefunktionen oder Kurvenscheiben) ausführbar. Zusätzlich ist mit TwinCAT NC I das Abarbeiten eines nach DIN 66025 beschriebenen, interpolierenden Bahnablaufs mit bis zu drei beteiligten Achsen möglich.

Software-SPS inklusive

Software-NC und Software-SPS sind in TwinCAT zu einer leistungsfähigen Steuerung kombiniert. Die Kommunikation zwischen den beiden Paketen ist ein reiner Software-zu-Software-Kanal mit minimalen Verzögerungszeiten. Der Aufruf der NC-Funktionalitäten erfolgt aus dem SPS-Programm über standardisierte, von der PLCopen zertifizierte Funktionsbausteine.

Achsbewegungen können auch ohne reale Hardware simuliert werden; der Istwert wird dabei ideal dem Sollwert nachgeführt und der gesamte Maschinenablauf überprüft. Hilfreich für Inbetriebnahme und Service ist das TwinCAT ScopeView, mit dem alle Variablen einer Achse, wie Position, Geschwindigkeit, Beschleunigung und Ruck, aufgezeichnet werden.

Bequeme Inbetriebnahme

Wesentlich erleichtert wird die Inbetriebnahme durch die im TwinCAT System Manager vorhandenen Konfigurations- und Diagnosedialoge. Für jede Achse werden alle wichtigen Daten auf einen Blick angezeigt. Mit Funktionstasten können die Achsen verfahren werden. Auch Sonderfunktionen, wie Kopplungen, Kurvenscheiben und Streckenkompensationen, können im System Manager ausgelöst und beobachtet werden. In einem komfortablen Dialog lassen sich die Dynamikparameter einer Achse ermitteln.

TwinCAT NC I – Interpolierende Achsbewegungen

TwinCAT NC I (I für Interpolation) ist das NC-System für linear und zirkular interpolierende Bahnbewegungen von Achsgruppen mit bis zu acht Antrieben. Das System enthält den Interpreter, eine Sollwertgenerierung und den Lageregler. Die SPS-Funktionalität ist ebenso integriert wie die Anbindung der Achsen an den Feldbus.

Der Interpreter interpretiert den in DIN 66025 beschriebenen Code. Umfangreiche SPS-Bibliotheken ermöglichen eine Interaktion von NC und SPS. Zum Beispiel können NC-Programme direkt aus dem SPS-Programm in den Interpreter geladen werden. Alternativ zur
DIN 66025 kann die Bahninterpolation mit der TcPlcInterpolation-Library auch direkt von der SPS beschrieben werden. Dabei werden Geometrie- und Hilfsfunktionen (z. B. M-Funktionen) in einer Tabelle in der SPS beschrieben und dem NC-Kern übergeben. Dieses Verfahren eignet sich besonders für flexible Verfahrbewegungen, wie sie z. B. bei Pick-and-place auftreten.

TwinCAT CNC – die Software-CNC für harte Anforderungen

TTwinCAT CNC bietet CNC-Features: Bis zu 32 interpolierende Bahnachsen sowie umfangreiche Koordinaten- und Kinematiktransformationen sind möglich. Die Teileprogrammierung erfolgt nach DIN 66025 mit Hochsprachenerweiterungen. TwinCAT CNC arbeitet mit bis zu 64 Achsen/geregelten Spindeln, die auf bis zu zwölf CNC-Kanäle verteilt werden können. In einem CNC-Kanal können bis zu 32 Achsen simultan interpoliert und damit auch schwierigste Bewegungsaufgaben gelöst werden.

HSC-Technologie (High Speed Cutting)

Die moderne HSC-Frästechnologie erfordert von der CNC-Steuerungstechnik optimierte Lösungen für die Bewegungsführung, um optimale Ergebnisse hinsichtlich Bearbeitungszeit bei gleichzeitig hohen Anforderungen an Genauigkeit und Oberflächengüte am Werkstück zu erreichen.

Das TwinCAT CNC HSC Pack bietet hierfür als Option:

  • satzübergreifende Geschwindigkeits- und Beschleunigungsführung zur optimalen Ausnutzung der Achsdynamik und damit höhere erreichbare Bahngeschwindigkeiten
  • hohe Oberflächengüte durch geglätteten Dynamikverlauf und dadurch Reduktion von Schwingungsanregungen der Maschine
  • wirkungsvolle Kontrolle der vorgegebenen Konturtoleranzen
  • Bahnprogrammierung über Splines mit programmierbarem Spline-Typ (Akima-Spline, B-Spline) zur Reduktion der NC-Sätze bei Freiformflächen
© Beckhoff Automation


Beckhoff TwinCAT

Produktübersicht TwinCAT

Software SPS
PLC TwinCAT PLC
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | Windows NT/2000/XP/Vista, Windows 7/10, Windows NT/XP Embedded, Windows CE*
Echtzeit | Beckhoff-Real-Time-Kernel ( nur 32bit Betriebssysteme, nur ein Kern wird genutzt)
I/O-System | EtherCAT, Lightbus, PROFIBUS DP/MC, Interbus, CANopen, DeviceNet, SERCOS, Ethernet und PC-Hardware
Laufzeitsystem | 4 SPS-Laufzeitsysteme mit jeweils bis zu 4 Tasks, Entwicklungs- und Laufzeitsystem auf einem PC oder trennbar (CE: nur Runtime)
Speicher Prozessabbildgröße, Merkerbereich, Programmgröße, POU-Größe, Variablenanzahl nur durch Größe des Arbeitsspeichers begrenzt
(max. 2 GB bei NT/2000/XP/Vista)
Zykluszeit | ab 50 µs einstellbar
Verknüpfungszeit | 1 µs (Intel® Core™2 Duo) für 1.000 SPS-Befehle
Programmierung | IEC 61131-3: IL, FBD, LD, SFC, ST, CFC, leistungsfähige Bibliotheksverwaltung, komfortables Debugging
PLC | TwinCAT PLC Bibliotheken
Bibliotheken | TwinCAT PLC Controller Toolbox
TwinCAT PLC Temperature Controller
TwinCAT PLC Hydraulic Positioning
TwinCAT PLC Modbus RTU
TwinCAT PLC Serial Communication
TwinCAT PLC Building Automation
TwinCAT PLC IEC 60870-5-101/4
*versionsabhängig
Software NC PTP
NC PTP TwinCAT NC PTP
TwinCAT PLC PLC
inklusive
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | Windows NT/2000/XP/Vista, Windows 7/10, Windows NT/XP Embedded, Windows CE*
Echtzeit | Beckhoff-Real-Time-Kernel ( nur 32bit Betriebssysteme, nur ein Kern wird genutzt)
I/O-System | EtherCAT, Lightbus, PROFIBUS DP/MC, Interbus, CANopen, DeviceNet, SERCOS, Ethernet und PC-Hardware
Programmierung | erfolgt über Funktionsbausteine für TwinCAT PLC nach IEC 61131-3 (standardisierte PLCopen-Motion-Control-Bausteine), komfortable Achsen-Inbetriebnahmemenüs im System Manager
Laufzeitsystem | NC Point-to-Point inklusive TwinCAT PLC
Anzahl Achsen | bis zu 255 Achsen
Achstypen | elektrische und hydraulische Servoantriebe, Frequenzumrichterantriebe, Schrittmotorantriebe, geschaltete Antriebe (Eil-/Schleichachsen)
Zykluszeit | ab 50 µs, typisch 1 ms (frei einstellbar)
Achsfunktionen Standardachsfunktionen: Start/Stopp/Reset/Referenzieren, Geschwindigkeits-Override, Sonderfunktionen:
Master-/Slavekaskadierung, Kurvenscheiben, „Elektronisches Getriebe“, Online-Distanzkompensation von Strecken, „Fliegende Säge“
PLC | TwinCAT NC PTP Bibliotheken
Bibliotheken | TwinCAT NC Camming
TwinCAT NC FIFO Axes
TwinCAT NC Flying Saw
TwinCAT PLC Remote Synchronisation
*versionsabhängig
Software NC I
NC I TwinCAT NC I
TwinCAT PLC PLC
inklusive
TwinCAT NC PTP NC PTP
inklusive
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | Windows NT/2000/XP/Vista, Windows 7/10, Windows NT/XP Embedded, Windows CE*
Echtzeit | Beckhoff-Real-Time-Kernel ( nur 32bit Betriebssysteme, nur ein Kern wird genutzt)
I/O-System | EtherCAT, Lightbus, PROFIBUS DP/MC, Interbus, CANopen, DeviceNet, SERCOS, Ethernet
Programmierung | DIN 66025-Programme für NC-Interpolation, Zugriff über Funktionsbausteine aus TwinCAT PLC nach IEC 61131-3
Laufzeitsystem | NC-Interpolation inklusive TwinCAT NC PTP und PLC
Anzahl Achsen | max. 3 Bahnachsen und bis zu 5 Hilfsachsen pro Gruppe, 1 Gruppe pro Kanal, max. 31 Kanäle
Achstypen | elektrische Servoachsen, Schrittmotorantriebe
Interpreter-
funktionen 		Unterprogramm- und Sprungtechnik, programmierbares Schleifen, Nullpunktverschiebungen, Werkzeugkorrekturen, M- und H-Funktionen
Geometrien | Geraden und Kreise im 3-D-Raum, Kreise in allen Hauptebenen, Helices mit Basiskreisen in allen Hauptebenen, Linear-, Zirkular-, Helikalinterpolation in den Hauptebenen und frei definierbaren Ebenen, Look-ahead-Funktion
Achsfunktionen | Online-Umkonfiguration von Achsen in Gruppen, Bahnoverride, Slavekopplung an Bahnachsen, Hilfsachsen, Achsfehler- und Durchhangkompensation, Messfunktionen
Bedienung | Automatikbetrieb, Handbetrieb (Jog/Tipp), Einzelsatzbetrieb, Referenzieren, Handradbetrieb (Verfahren/Überlagern)
*versionsabhängig
Software CNC
CNC TwinCAT CNC
TwinCAT PLC PLC
inklusive
TwinCAT NC PTP NC PTP
inklusive
TwinCAT NC I NC I
inklusive
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | Windows NT/2000/XP/Vista, Windows 7/10, Windows NT/XP Embedded*
Echtzeit | Beckhoff-Real-Time-Kernel als Bestandteil von TwinCAT ( nur 32bit Betriebssysteme, nur ein Kern wird genutzt)
I/O-System | EtherCAT, Lightbus, PROFIBUS DP/MC, Interbus, CANopen, DeviceNet, SERCOS, Ethernet
Programmierung | DIN 66025-Programmiersprache mit Hochsprachenerweiterung, Zugriff über Funktionsbausteine aus TwinCAT PLC nach IEC 61131-3
Laufzeitsystem | CNC inklusive TwinCAT NC I, NC PTP, PLC
Achsen/Spindeln | 8 Bahnachsen/geregelte Spindeln, max. 64 Achsen/geregelte Spindeln (optional), max. 12 Kanäle
Achstypen | elektrische Servoachsen, Analog-/Encoderinterface über Feldbus, dig. Schnittstelle über Feldbus (EtherCAT, Lightbus, PROFIBUS MC, SERCOS)
Interpreter-
funtkionen 		Unterprogramm- und Sprungtechnik, programmierbare Schleifen, Nullpunktverschiebungen, Werkzeugkorrekturen, M- und H-Funktionen, mathematische Funktionen, Parameter-/Variablenprogrammierung, Anwendermakros, Spindel- und Hilfsfunktionen, Nullpunktverschiebungen, Werkzeugfunktionen
Geometrien | Linear-, Zirkular-, Helikalinterpolation in den Hauptebenen und frei definierbaren Ebenen, max. 32 interpolierende Bahnachsen pro Kanal, Look-Ahead-Funktion
Achsfunktionen | Koppel- und Gantry-Achsenfunktion, Override, Achsfehler- und Durchhangkompensation, Messfunktionen
Bedienung | Automatikbetrieb, Handbetrieb (Jog/Tipp), Einzelsatzbetrieb, Referenzieren, Satzvorlauf, Handradbetrieb (Verfahren/Überlagern)
CNC TwinCAT CNC Optionen
Optionen | TwinCAT CNC Axes Pack
TwinCAT CNC Channel Pack
TwinCAT CNC Transformation
TwinCAT CNC HSC Pack
TwinCAT CNC Spline Interpolation
TwinCAT CNC Virtual NCK Basis/Options
*versionsabhängig
TwinCAT Level
I/O | TwinCAT I/O
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | Windows NT/2000/XP/Vista, Windows 7, Windows NT/XP Embedded, Windows CE (nur Runtime)*
Echtzeit | Beckhoff-Real-Time-Kernel
Universelles I/O-Interface für alle gängigen Feldbussysteme, PC-Feldbuskarten und Schnittstelle mit integriertem Echtzeittreiber.
*versionsabhängig
CP | TwinCAT CP
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | Windows NT/2000/XP/Vista, Windows 7, Windows NT/XP Embedded*
Echtzeit | Beckhoff-Real-Time-Kernel
Windows-Treiber für Beckhoff Control Panel.
*versionsabhängig
Supplements | System

Supplements | Motion

Supplements | Communication

Supplements | Controller

Supplements | Building Automation
© Beckhoff Automation
TwinCAT CP TwinCAT CNC TwinCAT I/O TwinCAT PLC TwinCAT NC PTP TwinCAT NC I CommunicationMotionSystem Controller Building Automation System Manager


Beckhoff TwinCAT | TwinCAT PLC – IEC 61131-3-Multi-SPS auf dem PC

TwinCAT PLC – IEC 61131-3-Multi-SPS auf dem PC

TwinCAT PLC – IEC 61131-3-Multi-SPS auf dem PC

Software-SPS für Windows NT/2000/XP/Vista und Windows 7

Das SPS-System TwinCAT PLC wird herstellerunabhängig nach IEC 61131-3 programmiert. Eine Online-Verbindung mit SPS-Laufzeitsystemen ist weltweit über TCP/IP oder über Feldbus auf dem IPC realisierbar.

TwinCAT-PLC-Programmiersystem

TwinCAT PLC bietet alle definierten Sprachen der IEC 61131-3-Norm sowie eine leistungsfähige Entwicklungsumgebung für Programme, deren Codegröße und Datenbereiche weit über die Möglichkeiten herkömmlicher SPS-Systeme hinausgehen.

Netzwerkfähige Online-Verbindung

Programm- und Datenänderungen werden mit einer sehr leistungsfähigen Verbindung zu den Laufzeitsystemen unterstützt, die auch netzwerkfähig ist. Alle üblichen Eigenschaften einer SPS sind verfügbar.

Windows-Programme, beispielsweise Visualisierungen oder Office-Produkte, können über Microsoft-Schnittstellen auf TwinCAT-Daten zugreifen oder die SPS steuern.

Praxisorientierte Eigenschaften

  • alle definierten Programmiersprachen: AWL, FUP, KOP, AS, ST sowie CFC
  • zertifiziert entsprechend Baselevel (IL/ST)
  • strukturierte Programmierung mit modularer Programmverwaltung
  • Neucompilieren bei laufender SPS mit maximalem Datenerhalt (Online-Change)
  • Quellcodespeicherung im Zielsystem
  • Kriterienanalyse
  • komfortable Bibliotheksverwaltung
  • Konvertierung zwischen den Sprachen
  • inkrementelles Compilieren
  • alle gebräuchlichen Datentypen, Strukturen, Arrays, auch mehrdimensional
  • Programmierunterstützung: Autoformat, Autodeclare, Querverweis, Suchen/Ersetzen
  • komfortabler Projektvergleich
  • Programmkonvertierung in Fremdsprachen
  • Anschluss an Quellcodeverwaltungstools
TwinCAT PLC – IEC 61131-3-Multi-SPS auf dem PC

TwinCAT Multi-SPS

TwinCAT PLC – IEC 61131-3-Multi-SPS auf dem PC

IEC 61131-3-Sprachen

Diagnose mit den Standards der PC-Welt

Programm- und Datenänderungen werden in beliebiger Größe „online“ ausgeführt. Das Auffinden und Beheben von Fehlern (Debuggen) wird mit einer sehr leistungsfähigen Verbindung zu den Laufzeitsystemen unterstützt, die auch netzwerkfähig ist. Alle üblichen Eigenschaften einer SPS sind verfügbar.

Debugging-Eigenschaften

  • Online-Verbindung mit SPS-Laufzeitsystem weltweit über TCP/IP oder über Feldbus
  • „Online-Change“ von neuen Variablen, Instanzen, Programmen während der Laufzeit mit maximalem Datenerhalt
  • Online-Monitoring von Variablen in Variablenlisten, Watchfenstern, Editoren
  • Online-Status und Powerflow (Akkumulatorinhalt) von Programmen und Instanzen
  • Triggern, Forcen, Setzen von Variablen
  • Einzelzyklus, Breakpoints
  • Step-in, Step-over
  • Anzeige des aktuellen Aufrufstacks
  • Watchliste zeigt Auswahl von Variablen.
  • Tracefunktion zeichnet Variablenzyklus genau auf.
  • Online-Verwaltung aller Variablennamen und -strukturen systemweit
  • TwinCAT ScopeView als grafisches Diagnose- und Analysewerkzeug zum Anzeigen von Werten

Leistungsfähiges Debugging

Technische Daten | TX1200
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | versionsabhängig: Windows NT/2000/XP/Vista, Windows 7, Windows NT/XP Embedded, Windows CE (nur Runtime)
Zielsysteme | PC (x86), Windows-CE-Geräte, Beckhoff-Feldbus-Controller (BCxxxx, BXxxxx, IL230x-Cxxx)
Echtzeit | Beckhoff-Real-Time-Kernel als Bestandteil von TwinCAT
Laufzeitsystem | max. 4 Multitasking-SPSen mit je 4 Tasks pro SPS-Laufzeit, Entwicklungs- und Laufzeitsystem auf einem PC oder Remote-Programmierung via TCP/IP
Speicher | Prozessabbildgröße, Merkerbereich, Programmgröße, POU-Größe, Variablenanzahl nur durch Größe des Arbeitsspeichers begrenzt (max. 2 GB bei NT/2000/XP/Vista)
Zykluszeit | ab 50 µs einstellbar (typisch 1 ms)
Verknüpfungszeit | 1 µs (Intel® Core™2 Duo)
Programmierung | IEC 61131-3: IL (AWL), FBD (FUP), LD (KOP), SFC (AS), ST, CFC, leistungsfähige Bibliotheksverwaltung
Debugging | Online-Change in Programmen und Variablen, Online-Monitor, Ablaufkontrolle, Breakpoints, Write, Force, Step, Datentrace, Remote-Debugging über TCP/IP
Remanenz | remanente und persistente Daten, USV-gestützte Speicherung auf Festplatte, optional Speicherung auf NOVRAM
I/O-System | freie Feldbusauswahl: EtherCAT, PROFIBUS DP/MC, CANopen, DeviceNet, Interbus, SERCOS, Lightbus, Ethernet, PC-Hardware (Printer-Port, COM-Port, USB), PC-Karten: generische Memory-DPRAM-Unterstützung
Connectivity | Variablenzugriff über OPC, Beckhoff-ADS-OCX/DLL, .Net
Bestellangaben |
TX1200 | Lizenz zur Nutzung der IEC 61131-3-SPS-Automatisierungssoftware, enthält Programmiersoftware und Laufzeitsystem
Optionen |
TS4100 | Die TwinCAT-Controller-Toolbox-Bibliothek enthält Bausteine für Basisregler (P, I, D), komplexe Regler (PI, PID), Pulsweitenmodulation, Rampen, Signalgeneratoren, Filter.
TS4110 | IEC 61131-3-Softwarebibliothek für TwinCAT PLC zur Temperaturregelung
TS5810 | IEC 61131-3-Softwarebibliothek für TwinCAT PLC zum Steuern und Regeln hydraulischer Achsen
TS6255 | IEC 61131-3-Softwarebibliothek für TwinCAT PLC mit Modbus-RTU-Funktionsbausteinen zur seriellen Kommunikation mit Modbus-Endgeräten
TS6340 | IEC 61131-3-Softwarebibliothek für TwinCAT PLC zur Kommunikation über serielle Geräte
TS8010 | IEC 61131-3-Softwarebibliothek für TwinCAT PLC für die Ausführung von Grundfunktionen im Bereich der Gebäudeautomatisierung (Basisbibliothek)
TS1600 | Der TwinCAT Engineering Interface Server integriert Treiber zur Anbindung von Microsoft Visual Source Safe oder Subversion.


Beckhoff TwinCAT | TwinCAT NC PTP – Achspositionierung Punkt-zu-Punkt

TwinCAT NC PTP – Achspositionierung Punkt-zu-Punkt

TwinCAT NC PTP – Achspositionierung Punkt-zu-Punkt

Lageregelung mit dem PC

TwinCAT NC PTP besitzt eine Achspositionierung (Sollwertgenerierung, Lageregelung), eine integrierte Software-SPS mit NC-Schnittstelle, Bedienprogramme zur Inbetriebnahme und eine I/O-Anbindung der Achsen über verschiedenste Feldbusse: TwinCAT NC PTP substituiert herkömmliche Positionierbaugruppen und NC-Steuerungen.

NC-PTP-Software auf dem PC

Der Lageregler wird in der Regel auf dem PC-Prozessor gerechnet und tauscht zyklisch Daten über den Feldbus mit Antrieben und Messsystemen aus.

Die PC-Leistung erlaubt es, parallel zur SPS-Funktion Achsen zu bewegen: Mit der Leistung eines PCs können leicht einige Dutzend Achsen gleichzeitig positioniert werden.

Systemstruktur

Achsen werden in Kanälen für PTP-Bewegung und interpolierende Bewegungen strukturiert.

Achsstruktur

TwinCAT NC PTP führt Achsen mittels Variablen. Jede Achse erhält Variablen für Encoder, Antrieb und Regler. Die Achse kann mit I/O-Schnittstellen verknüpft, Parameter können eingestellt werden.

Achsfunktionen

  • Start (verschiedene Modi)
  • Stopp
  • neue Zielposition und Geschwindigkeit
  • konstante Antriebsausgabe
  • Ist-Position setzen/aufrufen

Achstypen

  • Servoachsen
  • Eil-/Schleichachsen
  • Schrittmotor-Achsen
  • „Low-Cost“-Schrittmotorachsen
  • Encoderachsen
  • Simulationsachsen
  • Gleichstromantriebe

Wegmesssysteme

Die Positionserfassung für den Lageregler erfolgt per:

  • Inkremental-Encoder
  • Absolut-Encoder
  • digitaler Schnittstelle zu den Antrieben

Antriebsschnittstellen

  • analog
  • EtherCAT
  • SERCOS
  • SSI
  • Lightbus
  • PROFIBUS DP/MC
  • Pulse-Train

Schnittstellen

  • Anbindung an alle gängigen Feldbusse, speziell EtherCAT, Lightbus, SERCOS, PROFIBUS MC, Synchron-CAN
  • Einbettung der Achsfunktion in das IEC 61131-3-SPS-System mittels Funktionsbausteinbibliotheken, die Funktionsbausteine entsprechen dem PLCopen-Standard.
  • Datenanbindung an Windows NT/2000/XP/Vista/CE Programme mittels offener Standards (OPC, Beckhoff-ADS)
TwinCAT NC PTP – Achspositionierung Punkt-zu-Punkt

Systembedienung

Positionierung

Die Positionierung erfolgt mittels modernem, leistungsfähigem Positionieralgorithmus, Profilgenerierung mit Ruckbegrenzung sowie Geschwindigkeits- und Beschleunigungsvorsteuerung zur Schleppabstandsminimierung.

Positioniereigenschaften:

  • Reglerstrukturen einstellbar
  • P-Regler
  • PID-Regler
  • PID mit Geschwindigkeitsvorsteuerung
  • PID mit Geschwindigkeits- und Beschleunigungsvorsteuerung
  • Override-Funktionalität

Inbetriebnahme/Wartung

Das Online-Menü erlaubt es, die wesentlichen Achsparameter, wie

  • Zielposition,
  • Sollgeschwindigkeit,
  • Beschleunigung, Ruck,
  • Referenzgeschwindigkeit,
  • Regler Kv-Faktor,

zu setzen und die allgemeinen Achsfunktionen, wie

  • Start,
  • Stopp/Not-Stopp,
  • neue Zielposition mit neuer Geschwindigkeit,

aufzurufen.

Sonderfunktionen

  • Linearkopplung (elektrisches Getriebe)
  • Positionskompensation
  • Online-Master-/Slave sowie Slave-/Masterumwandlung
  • „Fliegende Säge“ (Diagonalsäge)
  • Kurvenscheiben (Unterstützung durch TwinCAT Cam Design Tool)
  • FIFO-Achsen
  • umschaltbare Encoder/Regler
  • externe Sollwertgeneratoren
TwinCAT NC PTP TwinCAT NC PTP – Achspositionierung Punkt-zu-Punkt -

Verbindung zwischen NC-Software
und Antrieb per Drag-and-drop

TwinCAT NC PTP TwinCAT NC PTP – Achspositionierung Punkt-zu-Punkt -

Programmierung über IEC 61131-3-
Funktionsbausteine oder standardisierte
PLCopen-Motion-Control-
Bausteine

Technische Daten | TX1250
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | versionsabhängig: Windows NT/2000/XP/Vista, Windows 7, Windows NT/XP Embedded, Windows CE (nur Runtime)
Echtzeit | Beckhoff-Real-Time-Kernel als Bestandteil von TwinCAT
Laufzeitsystem | NC Point-to-Point (NC PTP), enthält TwinCAT PLC
Anzahl Achsen | bis 255 Achsen
Achstypen | elektrische und hydraulische Servoantriebe, Frequenzumrichterantriebe, Schrittmotorantriebe, Gleichstromantriebe, geschaltete Antriebe (Eil-/Schleichachsen)
Zykluszeit | ab 50 µs einstellbar (typisch 1 ms)
Achsfunktionen | Standardachsfunktionen: Start/Stopp/Reset/Referenzieren, Geschwindigkeits-Override, Ziel-Override; Sonderfunktionen: Master-/Slavekaskadierung, Elektronisches Getriebe, Online-Distanzkompensation von Strecken
Programmierung | erfolgt über IEC 61131-3-Funktionsbausteine in der TwinCAT PLC, komfortable Achsen-Inbetriebnahmemöglichkeiten
Debugging | Online-Monitor aller Achszustandsvariablen wie Ist-/Sollwerte, Freigaben, Regelungswerte, Online-Achstuning, Forcen von Achsvariablen
Konfiguration | alle Achsparameter wie Messsystem, Driveparameter und Lageregler komfortabel konfigurierbar
Remanenz | remanente Daten, USV-gestützte Speicherung auf Festplatte
I/O-System | freie Feldbusauswahl: EtherCAT, PROFIBUS DP/MC, CANopen, DeviceNet, Interbus, SERCOS, Lightbus, Ethernet
Connectivity | Variablenzugriff über OPC, Beckhoff-ADS-OCX/DLL
Bestellangaben |
TX1250 | Lizenz zur Nutzung der PTP-Positionierungssoftware mit integrierter IEC 61131-3-SPS TwinCAT PLC, enthält Programmiersoftware und Laufzeitsystem
Optionen |
TS5050 | IEC 61131-3-Softwarebibliothek für TwinCAT, implementiert Kurvenscheibenfunktionalität (Tabellenkopplung)
TS5060 | IEC 61131-3-Softwarebibliothek für TwinCAT, ermöglicht eine vorgegebene FIFO-Sollwertgenerierung
TS5055 | IEC 61131-3-Softwarebibliothek für TwinCAT, realisiert eine „Fliegende Säge“
TS1510 | grafisches Entwurfstool für Kurvenscheiben
TS1500 | grafisch orientierter Editor zum Entwerfen der Kennlinie eines Hydraulikventils


Beckhoff TwinCAT | TwinCAT NC I – Achsinterpolation in drei Dimensionen

TwinCAT NC I – Achsinterpolation in drei Dimensionen

TwinCAT NC I – Achsinterpolation in drei Dimensionen

Bahnen fahren mit dem PC

TwinCAT NC Interpolation (NC I) ist das NC-System für interpolierende Bahnbewegungen. TwinCAT NC I bietet eine 3-D-Interpolation (Interpreter, Sollwertgenerierung, Lageregler), eine integrierte SPS mit NC-Schnittstelle und eine I/O-Anbindung für Achsen über den Feldbus. Alle gängigen Feldbussysteme und Programmierstandards der CNC-Welt, wie DIN 66025, werden unterstützt. TwinCAT NC I substituiert herkömmliche Achsbaugruppen und CNC-Steuerungen durch offene PC-Lösungen. TwinCAT NC I nutzt die PC-Leistung und ermöglicht Achsregelung unter Windows NT/2000/XP/Vista/CE. Hardwarebaugruppen werden in Software nachempfunden und dadurch überflüssig.

TwinCAT-NC-I-Interpreter

Als bewährte Beschreibungssprache von Maschinenabläufen dient die in der DIN 66025 festgelegte Syntax. Ergänzend hierzu existiert eine Erweiterung der DIN-Syntax um praktisch einsetzbare Funktionen:

  • Unterprogramm- und Sprungtechnik
  • programmierte Schleifen
  • Nullpunktverschiebungen
  • Werkzeugkorrekturen
  • Werkzeuge
  • M- und H-Funktionen

3-D-Interpolation

Es werden folgende Geometrien vom Interpreter unterstützt:

  • Gerade im Raum
  • Kreise in allen Hauptebenen
  • Kreise im Raum
  • Helices mit Basiskreisen in den Hauptebenen

TwinCAT-NC-I-Bedienoberfläche

Eine im TwinCAT System Manager integrierte Bedienoberfläche informiert über sämtliche Soll- und Istwerte sowie über die physikalischen und logischen Zustände der Interpolationskanäle und Interpolationsachsen. Ferner werden mit dem System Manager die NC-Struktur und sämtliche NC-Parameter festgelegt.

TwinCAT NC I – Achsinterpolation in drei Dimensionen

NC-Programmeditor

TwinCAT NC I – Achsinterpolation in drei Dimensionen

Struktur einer Achsgruppe

Online-Umkonfiguration von Achsen

Einzelne PTP-Achsen können im Stillstand der Achsen zu neuen Interpolationsgruppen flexibel zusammengestellt und im Anschluss als PTP-Achsen rekonfiguriert werden. Somit lassen sich sämtliche PTP-Eigenschaften wie Referenzierfahrt, Werkzeugwechsel etc. nutzen.

SPS-Bausteine zur Interpolation

Um ein einfaches Interface zur Achsinterpolation zu schaffen, existieren SPS-Bausteine, mit denen durch eine anschauliche, tabellenförmige Beschreibung Aufträge für den Interpolationskanal erzeugt werden können.

TwinCAT-NC-I-Bahndynamik

Ruckbegrenztes Profil, das zu jedem Zeitpunkt Beschleunigung, Geschwindigkeit und Position auf der Bahn beschreibt, sowie die zugehörigen, transformierten kartesischen Achsgrößen. Die maximal zulässigen dynamischen Grenzwerte können jederzeit aus dem NC-Programm geändert werden.

TwinCAT-NC-I-Bahn-Override

TwinCAT NC I verfügt über einen Geschwindigkeitsoverride, der synchron auf sämtliche Achsen wirkt.

Mindestgeschwindigkeit an Geometrieübergängen

Für viele Anwendungen ist es nötig, während der Bearbeitung (Laser, Schweißen) eine Mindestgeschwindigkeit an Geometrieübergängen nicht zu unterschreiten. Zu diesem Zweck kann die Mindestgeschwindigkeit parametriert werden.

Kurvengeschwindigkeitsreduktion

TwinCAT NC I stellt zwei Reduktionsmethoden zur Verfügung, welche die Geschwindigkeit an benachbarten Geometrieübergängen heruntersetzt. Die Parameter für diese Geschwindigkeitsreduktion sind aus dem NC-Programm veränderbar.

„Look Ahead”

Der „Look Ahead“ arbeitet über alle eingegebenen Einträge und verbindet, soweit inhaltlich erlaubt, benachbarte Geometrien.

Slavekopplung an Bahnachsen

Eine Master-/Slavekopplung an eine Bahnachse ist möglich, unabhängig um welchen Slavetyp es sich hierbei handelt.

Geometrisch-dynamische Glättung mit Splines

Um eine bestmögliche geometrische und dynamische Glättung an Segmentübergängen zu erreichen, können automatisch Bezier-Splines eingefügt werden.

Diagnose- und Optimierungsmöglichkeiten

Zu Diagnose- und Analysezwecken können alle Zustandsvariablen ausgelesen und angezeigt werden. Ein ideales Tool stellt in diesem Zusammenhang das TwinCAT ScopeView dar, mit dem alle internen und externen Variablen aufgezeichnet werden. Zu diesen Variablen gehören z. B. Bahngrößen (Soll- und Istgrößen) wie Bahngeschwindigkeit, Bahnbeschleunigung, tangentialer und orthogonaler Bahnfehler, sowie sämtliche kartesische Größen wie Position, Geschwindigkeit, Schleppabstand etc.

TwinCAT NC I TwinCAT NC I – Achsinterpolation in drei Dimensionen - Struktur einer Achsgruppe

TwinCAT-Scope

Technische Daten | TX1260
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | Windows NT/2000/XP/Vista, Windows NT/XP Embedded, Windows CE
Echtzeit | Beckhoff-Real-Time-Kernel als Bestandteil von TwinCAT
Laufzeitsystem | NC-Interpolation inklusive TwinCAT NC PTP und PLC
Anzahl Achsen | 3 Achsen pro Gruppe, 1 Gruppe pro Kanal, max. 31 Kanäle, Hilfsachsen
Achstypen | elektrische Servoachsen, Schrittmotorantriebe
Interpreterfunktionen | Unterprogramm- und Sprungtechnik, programmierte Schleifen, Nullpunktverschiebungen, Werkzeugkorrekturen, M- und H-Funktionen, Restweglöschen
Geometriefunktionen | Geraden und Kreise im 3-D-Raum, Kreise in allen Hauptebenen, Helices mit Basiskreisen in allen Hauptebenen, Linear-, Zirkular-, Helikalinterpolation in den Hauptebenen und frei definierbaren Ebenen, Bezier-Splines, Look-ahead-Funktion
Achsfunktionen | Online-Umkonfiguration von Achsen in Gruppen, Bahnoverride, Slavekopplung an Bahnachsen, Hilfsachsen, Achsfehler- und Durchhangkompensation, Messfunktionen
Programmierung | DIN 66025-Programme für NC-Interpolation, Zugriff über Funktionsbausteine für TwinCAT PLC nach IEC 61131-3
Bedienung | Automatikbetrieb, Handbetrieb (Jog/Tipp), Einzelsatzbetrieb, Referenzieren, Handradbetrieb (Verfahren/Überlagern)
Debugging | Online-Monitoring im TwinCAT System Manager mit folgenden Anzeigen: aktuelle Soll-/Istposition (Schleppabstände aller Achsen), aktuell bearbeitete NC-Programmzeile, aktuell interpretierte NC-Programmzeile, Kanalstatus
I/O-System | EtherCAT, Lightbus, PROFIBUS DP/MC, Interbus, CANopen, DeviceNet, SERCOS, Ethernet
Bestellangaben |
TX1260 | Lizenz zur Nutzung der Interpolations- und PTP-Positionierungssoftware mit integrierter IEC 61131-3-SPS TwinCAT PLC, enthält Programmiersoftware und Laufzeitsystem
Optionen |
TS511x | SPS-Bibliothek zur Realisierung verschiedener Kinematik-Transformationen für TwinCAT PTP oder TwinCAT NC I


Beckhoff TwinCAT | TwinCAT CNC – High-Performance CNC-Lösung für komplexe Anwendungen

TwinCAT CNC – High-Performance CNC-Lösung für komplexe Anwendungen

TwinCAT CNC – High-Performance CNC-Lösung für komplexe Anwendungen

Komplexe Aufgaben – neue Lösungen

TwinCAT CNC bietet komplette CNC-Funktionalität als reine Softwarelösung auf PC-Basis. Der gesamte Bereich klassischer CNC-Bahnsteuerungen, bis hin zum Highend-System für komplexe Bewegungs- und Kinematikanforderungen, wird mit TwinCAT CNC abgedeckt. Die leistungsfähige, sich ständig weiterentwickelnde PC-Plattform und die harte Echtzeitbasis des TwinCAT-Real-Time-Kernels bieten dabei die idealen Voraussetzungen für die Software-CNC.

TwinCAT-Durchgängigkeit

TwinCAT CNC baut auf TwinCAT PLC, der IEC 61131-3-Software-SPS, auf. Beim Einsatz von TwinCAT NC PTP als Basis, steht zusätzlich die leistungsfähige Motion-Funktionalität für Positionieraufgaben zur Verfügung. Die Teileprogrammierung erfolgt nach DIN 66025 mit Hochsprachenerweiterungen. TwinCAT CNC erweitert die TwinCAT NC I um klassische CNC-Features. Bis zu 64 interpolierende Achsen sowie umfangreiche Koordinaten- und Kinematiktransformationen sind möglich.

Offen für I/O- und Antriebssysteme

In der CNC-Welt bietet TwinCAT CNC durch die konsequente Nutzung von Feldbustechnik eine einzigartige Offenheit zur I/O-Peripherie und zum Antriebssystem. Unterschiedlichste I/O-Baugruppen können über alle gängigen Feldbussysteme angeschlossen werden. Die Antriebssysteme können sowohl mit Analog-/Encoderschnittstelle oder direkt mit digitaler Antriebsschnittstelle (z. B. EtherCAT, PROFIBUS MC, SERCOS oder Lightbus) mit der CNC verbunden werden. Damit erhält der Anwender maximale Offenheit und Unabhängigkeit in der Auswahl der I/O- und Antriebssysteme.

Vielseitig in der Bearbeitung

Für unterschiedliche Bearbeitungstechnologien (z. B. Fräsen, Bohren, Handling, Sondermaschinen) stehen die benötigten Achs- und Spindelfunktionen, Interpolations- und Vorschubfunktionen, Werkzeug- und Hilfsfunktionen nach DIN 66025 mit spezifischen Erweiterungen zur Verfügung.

Interpolation mit 64 Achsen

Komplexe Bearbeitungsaufgaben erfordern häufig Bahnbewegungen mit einer Vielzahl von beteiligten Achsen und Spindeln. TwinCAT CNC arbeitet mit bis zu 64 Achsen oder 32 Bahnachsen und geregelten Spindeln, die auf bis zu 12 CNC-Kanäle verteilt werden können. In einem CNC-Kanal können bis zu 32 Achsen simultan interpoliert und damit auch schwierigste Bewegungsaufgaben gelöst werden.

HSC-Technologie (High Speed Cutting)

Die moderne HSC-Frästechnologie erfordert von der CNC-Steuerungstechnik optimierte Lösungen für die Bewegungsführung, um optimale Ergebnisse hinsichtlich Bearbeitungszeit bei gleichzeitig hohen Anforderungen an Genauigkeit und Oberflächengüte am Werkstück zu erreichen.

Das TwinCAT CNC HSC Pack bietet hierfür als Option:

  • satzübergreifende Geschwindigkeits- und Beschleunigungsführung zur optimalen Ausnutzung der Achsdynamik und damit höhere erreichbare Bahngeschwindigkeiten
  • hohe Oberflächengüte durch geglätteten Dynamikverlauf und dadurch Reduktion von Schwingungsanregungen der Maschine
  • wirkungsvolle Kontrolle der vorgegebenen Konturtoleranzen

Echtzeittransformationen

Komplexe Maschinenkinematiken mit schwierigen Bearbeitungsaufgaben erfordern für eine einfache und flexible Bedienung und Programmierung Echtzeittransformationen in der CNC. Damit werden z. B. unterschiedliche Koordinatensysteme innerhalb der Bearbeitung definiert oder automatisch Ausgleichsbewegungen von Rundachsen erzeugt. Klassischer Anwendungsfall ist hierfür die 5-Achs-Bearbeitung.

TwinCAT CNC stellt als Option spezielle CNC-Funktionen zur Verfügung:

  • RTCP-Funktion (Rotation Tool Center Point)
  • TLC-Funktion (Tool Length Compensation)
  • Kinematikauswahl aus Kinematikbibliothek
  • Definition verschiedener Koordinatensysteme
  • Werkzeugausrichtung im gewählten Koordinatensystem
  • Verkettung/Übergang von Koordinatensystemen
TwinCAT CNC TwinCAT CNC – High-Performance CNC-Lösung für komplexe Anwendungen -

CNC-Konfiguration und Diagnose

TwinCAT CNC TwinCAT CNC – High-Performance CNC-Lösung für komplexe Anwendungen -

Systembedienung zur Inbetriebnahme

Technische Daten | TX1270
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | Windows NT/2000/XP/Vista, Windows NT/XP Embedded
Echtzeit | Beckhoff-Real-Time-Kernel als Bestandteil von TwinCAT
Laufzeitsystem | CNC inklusive TwinCAT NC I, NC PTP und PLC
Anzahl Achsen/Spindeln | 8 Bahnachsen/6 geregelte Spindeln, max. 64 Achsen/12 geregelte Spindeln (Option), 1 CNC-Kanal, maximal 12 CNC-Kanäle (Option)
Achstypen | elektrische Servoachsen, Analog-/Encoderinterface über Feldbus (z. B. EtherCAT, Lightbus, PROFIBUS, CANopen), digitale Schnittstelle über Feldbus (EtherCAT, Lightbus, SERCOS, PROFIBUS MC)
Interpreterfunktionen | Unterprogramm- und Sprungtechnik, programmierbare Schleifen, Nullpunktverschiebungen, Werkzeugkorrekturen, M- und H-Funktionen, mathematische Funktionen, Parameter-/Variablenprogrammierung, Anwendermakros, Spindel- und Hilfsfunktionen, Nullpunktverschiebungen, Werkzeugfunktionen
Geometriefunktionen | Linear-, Zirkular-, Helikalinterpolation in den Hauptebenen und frei definierbaren Ebenen, max 32 interpolierende Bahnachsen pro Kanal, Look-ahead-Funktion
Achsfunktionen | Koppel- und Gantry-Achsenfunktion, Override, Achsfehler- und Durchhangkompensation, Messfunktionen
Programmierung | DIN 66025-Programmiersprache mit Hochsprachenerweiterung, mathematische Funktionen, Parameter-/Variablenprogrammierung, Anwendermakros, Unterprogrammtechnik, Spindel- und Hilfsfunktionen, Werkzeugfunktionen, Nullpunktverschiebungen
Bedienung | Automatikbetrieb, Handbetrieb (Jog/Tipp), Einzelsatzbetrieb, Referenzieren, Satzvorlauf, Handradbetrieb (Verfahren/Überlagern)
Debugging | Online-Monitoring im TwinCAT System Manager
I/O-System | EtherCAT, Lightbus, PROFIBUS DP/MC, Interbus, CANopen, DeviceNet, SERCOS, Ethernet
Connectivity | Variablenzugriff über OPC, Beckhoff-ADS-OCX/DLL
Bestellangaben |
TX1270 | Lizenz zur Nutzung der CNC-Bahnsteuerungssoftware auf Basis von TwinCAT PLC oder TwinCAT NC PTP
Optionen |
TS5220 | Ausbau auf insgesamt 64 Achsen/geregelte Spindeln, davon maximal 32 Bahnachsen und maximal 12 geregelte Spindeln
TS5230 | ein weiterer CNC-Kanal, maximal auf 12 Kanäle ausbaubar, Kanalsynchronisation, Achsübergabe zwischen Kanälen
TS5240 | Transformationsfunktionalität (5-Achsfunktionalität), Kinematikauswahl aus Kinematikbibliothek, RTCP-Funktion, TLC-Funktion, Definition verschiedener Koordinatensysteme, Verkettung/Übergang von Koordinatensystemen
TS5250 | satzübergreifende Geschwindigkeits- und Beschleunigungsführung zur optimalen Ausnutzung der Achsdynamik für höhere Bahngeschwindigkeiten, höchste Oberflächengüte durch geglätteten Dynamikverlauf, Kontrolle der vorgegebenen Konturtoleranzen, Bahnprogrammierung über Splines
TS5260 | Bahnprogrammierung über Splines mit programmierbarem Spline-Typ, Akima-Spline, B-Spline
TS5270 | TS5271 | virtuelle TwinCAT CNC zur Simulation in einer Windows-Umgebung


Beckhoff TwinCAT | TwinCAT I/O – I/O-Verbindung zu Windows-Programmen

TwinCAT I/O – I/O-Verbindung zu Windows-Programmen

TwinCAT I/O – I/O-Verbindung zu Windows-Programmen

TwinCAT I/O

TwinCAT I/O ist ein Echtzeittreiber für Windows-Programme unter Windows NT/2000/XP/Vista/CE: Die Programmvariablen, die im System vorhandenen I/O-Geräte und die angeschlossenen I/O-Kanäle werden miteinander in Beziehung gebracht.

TwinCAT I/O

  • verbindet I/O-Geräte und Tasks variablenorientiert
  • verbindet Tasks zu Tasks variablenorientiert
  • kleinste Einheit ist ein Bit
  • unterstützt synchrone oder asynchrone Beziehungen
  • Austausch konsistenter Datenbereiche und Prozessabbilder

Offenheit: alle Standards

TwinCAT I/O unterstützt alle verbreiteten Feldbusse – auch gleichzeitig.

  • EtherCAT
  • Lightbus
  • PROFIBUS DP (Master und Slave)
  • PROFIBUS MC (Motion Control)
  • Interbus
  • CANopen
  • SERCOS interface
  • DeviceNet
  • Ethernet
  • PC-Printer-Port
  • USB
  • serielle Buskoppler BK8100 an COM
  • Memory-Interface (DPRAM) für PC-Karten
  • SMB (System-Management-Bus)
TwinCAT I/O – I/O-Verbindung zu Windows-Programmen

Offene I/O-Schnittstelle

TwinCAT I/O – I/O-Verbindung zu Windows-Programmen

Online-Darstellung

TwinCAT-I/O-Eigenschaften

TwinCAT I/O stellt die angeschlossenen I/O-Kanäle als Struktur dar und organisiert die Mappings des Datenverkehrs.

TwinCAT I/O erlaubt die Verbindung zwischen Serverprozessabbildern und I/O-Kanälen bitweise und hält Werkzeuge bereit, die viele Kanäle fortlaufend mit nur einem Befehl verbinden. Die Verbindungen können per Drag-and-drop bewegt werden.

Verdrahtung der Software

Mit Hilfe des TwinCAT-I/O-Systems können Ein- und Ausgänge einer Task mit denen einer anderen zyklisch ausgetauscht werden. Die Datenkonsistenz bleibt dabei gewahrt. Das TwinCAT-I/O-System ist variablenorientiert, d. h. die kleinste ansprechbare und verknüpfbare Einheit ist eine Variable, deren kleinste Größe ein Bit.

Online-Analyse

Auf Feldbusebene und Prozessabbildebene der Server wird die Inbetriebnahme und Wartung durch Online-Darstellung erleichtert. TwinCAT I/O generiert Adressbeziehungen (Mappings) zwischen Tasks und I/O-Geräten und bietet leistungsfähige Online-Tools:

  • Online-Darstellung im Verzeichnisbaum
  • Online-Watchfenster
  • „Force und Write“ zur Inbetriebnahme und zum Test für Taskvariablen und I/O-Geräte

Für alle I/O-Geräte werden Diagnosedaten in einer einheitlichen Darstellung angeboten.

Import-/Exportfunktionen

TwinCAT I/O verwaltet Variablen; Import- und Exportfunktionen stehen auf allen Ebenen zur Verfügung.

TcTimer API unter CE

Auf Beckhoff-CE-Geräten steht TwinCAT I/O mit der Erweiterung TcTimer zur Verfügung. Das TcTimer API stellt den ab 100 µs skalierbaren Echtzeittimer und den Zugriff auf das logische Prozessabbbild zur Verfügung. Der Datenaustausch zum Feldbus wird mit einem Methodenaufruf angestoßen. Externe Applikationen können mit dem TcTimer API eine deterministische, bis in die IO-Feldbusebene synchronisierte Applikation erstellen.

TwinCAT I/O TwinCAT I/O – I/O-Verbindung zu Windows-Programmen - Online-Darstellung

Import-/Exportfunktionen

TwinCAT I/O TwinCAT I/O – I/O-Verbindung zu Windows-Programmen - Online-Darstellung

I/O-Konfiguration

Technische Daten | TC1100
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | versionsabhängig: Windows NT/2000/XP/Vista, Windows 7, Windows NT/XP Embedded, Windows CE (nur Runtime)
Echtzeit | Beckhoff-Real-Time-Kernel als Bestandteil von TwinCAT
Anwenderprogramm | Im User-Mode laufendes Anwenderprogramm, das z. B. zyklisch als Multimedia-Task ablaufen kann („weiche“ Echtzeit), der Zugriff auf das I/O-Prozessabbild erfolgt durch zyklischen Aufruf von DLL-Funktionen. Unter CE: harte Echtzeit mit synchronisiertem Zugriff auf das Prozessabbild
Speicher | nur durch Größe des Arbeitsspeichers begrenzt (max. 2 GB bei NT/2000/XP/Vista)
Zykluszeit | ab 50 µs einstellbar
Programmierung | Anwendungsprogramm in beliebiger Hochsprache z. B. C++, Delphi, Assembler
Debugging | über die Standard-Debugging-Werkzeuge der eingesetzten Hochsprache
I/O-System | freie Feldbusauswahl: EtherCAT, PROFIBUS DP/MC, CANopen, DeviceNet, Interbus, SERCOS, Lightbus, Ethernet (Printer-Port, COM-Port, USB), PC-Karten: generische Memory-DPRAM-Unterstützung
Connectivity | Variablenzugriff über OPC, Beckhoff-ADS-OCX/DLL (Automation-Device-Specification) (unter CE: zusätzlich TcTimer API)
Bestellangaben |
TX1100 | Lizenz zur Nutzung der I/O-DLL zum Datenaustausch mit Windows-Programmen


Beckhoff TwinCAT | TwinCAT CP – Treiber für Beckhoff Control Panel

TwinCAT CP – Treiber für Beckhoff Control Panel

TwinCAT CP – Treiber für Beckhoff Control Panel

TwinCAT CP ist ein Treiber für die Beckhoff Control Panel C6xxx und C7xxx, die industriellen Bedien- und Anzeigegeräte.

Control Panel sind für den Einsatz als Mensch-Maschine-Schnittstelle optimiert. Bedien- und Anzeigeelemente bilden eine eigenständige Einheit, getrennt vom PC durch eine einfache Kabelverbindung.

TwinCAT CP stellt die Treiberverbindung zwischen allgemeinen Windows-Programmen und den Bedien- und Anzeigeelementen der Beckhoff Control Panel her:

  • direkte Taster für schnelle Maschinenfunktionen
  • Tasterrückmeldung in Form von LEDs
  • USV-Unterstützung

Windows-Programme können die Funktionen des Control Panels über den Treiber variablenorientiert steuern.

TwinCAT CP – Treiber für Beckhoff Control Panel
Technische Daten | TX1000
PC-Hardware | Standard-PC/IPC-Hardware, keine Zusätze
Betriebssysteme | versionsabhängig: Windows NT/2000/XP/Vista, Windows 7, Windows NT/XP Embedded
Echtzeit | Beckhoff-Real-Time-Kernel als Bestandteil von TwinCAT
Anwenderprogramm | Im User-Mode laufendes Anwenderprogramm, das z. B. zyklisch als Multimedia-Task ablaufen kann („weiche“ Echtzeit), der Zugriff auf das I/O-Prozessabbild erfolgt durch zyklischen Aufruf von DLL-Funktionen.
Speicher | nur durch Größe des Arbeitsspeichers begrenzt (max. 2 GB bei NT/2000/XP/Vista)
Programmierung | Anwendungsprogramm in beliebiger Hochsprache z. B. C++, Delphi, Assembler
Debugging | über die Standard-Debugging-Werkzeuge der eingesetzten Hochsprache
I/O-System | Tasten, LEDs und USV-Funktionalität der Beckhoff Control Panel CP6xxx, CP7xxx in Verbindung mit der Beckhoff CP9030/CP9035-Einsteckkarte
Connectivity | OPC, Beckhoff ADS OCX/DLL (Automation-Device-Specification)
Bestellangaben |
TX1000 | Lizenz zur Nutzung des Treibers für Beckhoff Control Panel zur Kommunikation zwischen allgemeinen Windows-Programmen


Beckhoff TwinCAT System Manager

TwinCAT System Manager

E/A-Verbindung und Systemorganisation
Feldbusse und PC-Schnittstellen

TwinCAT System Manager

Der TwinCAT System Manager ist die Konfigurationszentrale des Systems: Die Anzahl und Programme der SPS-Systeme, die Konfiguration der Achsregelung und die angeschlossenen E/A-Kanäle werden miteinander in Beziehungen gebracht.

Der System Manager:

  • verbindet E/A-Geräte und Tasks variablenorientiert
  • verbindet Tasks zu Tasks variablenorientiert
  • kleinste Einheit ist ein Bit
  • unterstützt synchrone oder asynchrone Beziehungen
  • Austausch konsistenter Datenbereiche und Prozessabbilder

Offenheit: Alle Standards

TwinCAT I/O unterstützt alle verbreiteten Feldbusse – auch gleichzeitig:

  • EtherCAT
  • Lightbus
  • PROFIBUS DP (Master und Slave)
  • PROFIBUS MC (Motion Control)
  • ProfiNET
  • Interbus
  • CANopen
  • SERCOS interface
  • DeviceNet
  • Ethernet I/P
  • Ethernet
  • PC printer port (8 Eingänge und 8 Ausgänge auf TTL-Basis)
  • USB
  • Serielle Buskoppler BK8100 an COM
  • Memory Interface (DP RAM) für PC Karten
  • SMB (System Management Bus)

System Manager - Eigenschaften

Der System Manager stellt die Anzahl und Programme der SPS-Systeme, die Konfiguration der Achsregelung und die angeschlossenen E/A-Kanäle als Struktur dar und organisiert die Mappings des Datenverkehrs.

  • Verbindung zwischen Server-Prozess-abbildern und E/A-Kanälen bitweise
  • Standard-Datenformate, z.B. Arrays und Strukturen
  • Benutzerdefinierte Datenformate
  • fortlaufende Verbindung von Variablen
  • Drag und Drop
  • Import und Export auf allen Ebenen

Verdrahtung der Software

Mit Hilfe des TwinCAT E/A-Systems können "Ein- und Ausgänge" einer Task mit den "Aus- und Eingängen" einer anderen Task zyklisch ausgetauscht werden. Dabei unterstützt TwinCAT Datenkonsistenz, synchrone und asynchrone Kommunikationen

Online-Analyse

Auf Feldbusebene und Prozessabbildebene der Server wird die Inbetriebnahme und Wartung durch Onlinedarstellung erleichtert. Der TwinCAT System Manager generiert Adressbeziehungen (Mappings) zwischen Tasks und E/A-Geräten und bietet leistungsfähige Online Tools:

  • Online Darstellung im Verzeichnisbaum
  • Online-Watchfenster
  • Force und Write zur Inbetriebnahme und Test für Taskvariablen und E/A-Geräte
  • Für alle E/A-Geräte werden Diagnosedaten in einer einheitlichen Darstellung angeboten.

Import-/Export-Funktionen

TwinCAT System Manager verwaltet IEC-SPS Projekte und Taskvariablen. Import- und Exportfunktionen stehen auf allen Ebenen zur Verfügung.


Beckhoff TwinCAT | TwinCAT NC FIFO Axes

TwinCAT NC FIFO Axes

TwinCAT PLC Libraries

Supplements | System
TS1800 | TwinCAT PLC HMI
Darstellung von in PLC-Control erstellten Visualisierungen
TS1800-0030 | TwinCAT PLC HMI CE
Darstellung von in PLC-Control erstellten Visualisierungen für Windows-CE-Plattformen
TS1810 | TwinCAT PLC HMI Web
Darstellung von in PLC-Control erstellten Visualisierungen im Web-Browser
Supplements | Motion
TS5065 | TwinCAT PLC Motion Control XFC
hochgenaues Erfassen und Schalten von digitalen Signalen bezogen auf Achspositionen
TS5810 | TwinCAT PLC Hydraulic Positioning
Softwarebibliothek für TwinCAT-PLC zur Positions- und Druckregelung von hydraulischen Achsen
Supplements | Communication
TS6340 | TwinCAT PLC Serial Communication
Kommunikation über serielle Busklemmen oder PC-COM-Ports
TS6341 | TwinCAT PLC Serial Communication 3964R/RK512
Kommunikation über serielle Busklemmen oder PC-COM-Ports mittels 3964R- und RK512-Protokoll
TS6255 | TwinCAT PLC Modbus RTU
serielle Kommunikation mit Modbus-Endgeräten
TS650x | TwinCAT PLC IEC 60870-5-101/-102/-103/-104 Master
Realisierung von Mastern für IEC 60870-101, 102, -103, -104
TS6506-0030 | TwinCAT PLC IEC 60870-5-104 Master CE
Realisierung von Mastern für IEC 60870-104 unter Windows CE
TS650x | TwinCAT PLC IEC 60870-5-101/-104 Slave
Realisierung von Slaves für IEC 60870-101, -104
TS6507-0030 | TwinCAT PLC IEC 60870-5-104 Slave CE
Realisierung von Slaves für IEC 60870-104 unter Windows CE
TS6511 | TwinCAT PLC IEC 61850 Server
Kommunikation nach IEC 61850/IEC 61400-25
TS6509 | TwinCAT PLC IEC 61400-25 Server
Kommunikation nach IEC 61400-25
TS6600 | TwinCAT PLC RFID Reader Communication
Anschluss von RFID-Readern an die TwinCAT PLC
TS6610 | TwinCAT PLC S5/S7 Communication
Kommunikation zu S5/S7-Steuerungen
Supplements | Controller
TS4100 | TwinCAT PLC Controller Toolbox
Bausteine für Basisregler (P, I, D), komplexe Regler (PI, PID), Pulsweitenmodulation, Rampen,
Signalgeneratoren und Filter
TS4110 | TwinCAT PLC Temperature Controller
instanziierbarer Temperaturregler-Funktionsbaustein zum Überwachen und Regeln von verschiedenen Temperaturstrecken
Supplements | Building Automation
TS8010 | TwinCAT PLC Building Automation
Ausführung von Grundfunktionen im Bereich der Raumautomatisierung
TS8038 | TwinCAT PLC DALI
Kommunikation mit der DALI-Master-Busklemme KL6811
TS6342 | TwinCAT PLC EnOcean
Verarbeitung von Signalen batterieloser Sensoren mit EnOcean-Technologie
TS8100 | TwinCAT Building Automation Framework
Konfiguration und Inbetriebnahme von Building-Automation-Projekten
TS8000 | TwinCAT PLC HVAC
Automation von Heizungs-, Lüftungs-, Klima- und Sanitäranlagen
TwinCAT PLC EIB
zur Kommunikation über die EIB-Busklemme
TwinCAT PLC LON
zur Kommunikation über die LON-Busklemme
TS8039 | TwinCAT PLC M-Bus
Nutzung des M-Bus zur Erfassung von Verbrauchsdaten
TwinCAT PLC MP-Bus
zur Kommunikation über die MP-Bus-Busklemme
TwinCAT PLC DMX
zur Kommunikation über die DMX-EtherCAT-Klemme
TS8036 | TwinCAT Crestron Server
Kommunikation zwischen einer TwinCAT SPS und einer Crestron-Steuerung
TS8037 | TwinCAT Bang & Olufsen Server
Kommunikation zwischen einer TwinCAT SPS und einer Bang&Olufsen-Audio/Video-Installation
TS8020 | TwinCAT BACnet/IP
Kommunikation für Datennetze der Gebäudeautomatisierung und Gebäuderegelung
TS8035 | TwinCAT FIAS Server
Kommunikation zwischen einer TwinCAT SPS und einem System nach dem FIAS-Standard


Beckhoff TwinCAT | TwinCAT NC FIFO Axes

TwinCAT NC FIFO Axes

TwinCAT NC PTP Libraries TS50xx

Supplements | Motion
TS5060 | TwinCAT NC FIFO Axes
Realisierung einer vom Anwender vorgegebenen Sollwertgenerierung für eine NC-Achse
TS5055 | TwinCAT NC Flying Saw
Implementierung der Funktionalität „Fliegende Säge“
TS5066 | TwinCAT PLC Remote Synchronisation
Remote-Synchronisation
TS5050 | TwinCAT NC Camming
Nutzung der Kurvenscheibenfunktionalität (Tabellenkopplung) von TwinCAT NC


Beckhoff TwinCAT | TwinCAT ECAD Import

TwinCAT ECAD Import

TwinCAT Supplements – System | TSxxxx

Supplements | System
TS1120 | TwinCAT ECAD Import
Import von Engineering-Ergebnissen aus einem ECAD-Programm
TS1600 | TwinCAT Engineering Interface Server
Koordination von Programmierarbeiten über ein zentrales Quellcodeverwaltungssystem
TS1010 | TwinCAT Eventlogger
Alarm- und Diagnosesystem zum Loggen von auftretenden Events aus dem TwinCAT-System
TS6421 | TwinCAT XML Data Server
Lesen und Schreiben von XML-basierten Daten durch die PLC
TS1150 | TwinCAT Backup
Sichern und Wiederherstellen von Dateien, Betriebssystem- und TwinCAT-Einstellungen
TS1110 | TwinCAT Simulation Manager
vereinfachte Erstellung und Konfiguration einer Simulationsumgebung
TS6420 | TwinCAT Database Server
Zugriff auf Datenbanken aus der SPS
TS6420-0030 | TwinCAT Database Server CE
Zugriff auf Datenbanken aus der SPS für Windows-CE-Platformen
TS1800 | TwinCAT PLC HMI
Darstellung von in PLC-Control erstellten Visualisierungen
TS1800-0030 |TwinCAT PLC HMI CE
Darstellung von in PLC-Control erstellten Visualisierungen für Windows-CE-Plattformen
TS1810 |TwinCAT PLC HMI Web
Darstellung von in PLC-Control erstellten Visualisierungen im Web-Browser
TS1140 |TwinCAT Management Server
zentrale Administration von Beckhoff-CE-Steuerungen
TS3300 |TwinCAT Scope 2
grafisches Analysewerkzeug für die Anzeige von zeitkontinuierlichen Signalverläufen
TS622x |TwinCAT EtherCAT Redundancy
Erweiterung des TwinCAT-EtherCAT-Masters um die Kabelredundanzfähigkeit
TS3900 |TwinCAT Solar Position Algorithm
exaktes Ermitteln des Sonnenstandes


Beckhoff TwinCAT | TwinCAT PLC Motion Control XFC

TwinCAT PLC Motion Control XFC

TwinCAT Supplement Motion | TS5xxx

Supplements | Motion
TS5065 | TwinCAT PLC Motion Control XFC
hochgenauen Erfassen und Schalten von digitalen Signalen bezogen auf Achspositionen
TS5810 | TwinCAT PLC Hydraulic Positioning
Steuern und Regeln hydraulischer Achsen
TS5060 | TwinCAT NC FIFO Axes
Realisierung einer vom Anwender vorgegebenen Sollwertgenerierung für eine NC-Achse
TS5055 | TwinCAT NC Flying Saw
Implementierung der Funktionalität „Fliegende Säge“
TS5066 | TwinCAT PLC Remote Synchronisation
Remote-Synchronisation
TS5050 | TwinCAT NC Camming
Nutzung der Kurvenscheibenfunktionalität (Tabellenkopplung) von TwinCAT NC
TS1510 | TwinCAT Cam Design Tool
grafisches Entwurfstool für elektronische Kurvenscheiben
TS5800 | TwinCAT Digital Cam Server
schnelles Nockenschaltwerk als Software-Implementation
TS1500 | TwinCAT Valve Diagram Editor
grafisches Tool zum Entwerfen der Kennlinie eines Hydraulikventils
TS511x | TwinCAT Kinematic Transformation
Realisierung verschiedener Kinematik-Transformationen für TwinCAT PTP oder TwinCAT NC I


Beckhoff TwinCAT | TwinCAT PLC Serial Communication

TwinCAT PLC Serial Communication

TwinCAT Supplements Communication | TS6xxx

Supplements | Communication
TS6340 | TwinCAT PLC Serial Communication
Kommunikation über serielle Busklemmen oder PC-COM-Ports
TS6341 | TwinCAT PLC Serial Communication 3964R/RK512
Kommunikation über serielle Busklemmen oder PC-COM-Ports mittels 3964R- und RK512-Protokoll
TS6255 | TwinCAT PLC Modbus RTU
serielle Kommunikation mit Modbus-Endgeräten
TS6250 | TwinCAT Modbus TCP Server
Kommunikation mit Modbus-TCP-Geräten (Server- und Client-Funktionalität)
TS650x | TwinCAT PLC IEC 60870-5-101/-102/-103/-104 Master
Realisierung von Mastern für IEC 60870-101, 102, -103, -104
TS6506-0030 | TwinCAT PLC IEC 60870-5-104 Master CE
Realisierung von Mastern für IEC 60870-104 unter Windows CE
TS650x | TwinCAT PLC IEC 60870-5-101/-104 Slave
Realisierung von Slaves für IEC 60870-101, -104
TS6507-0030 | TwinCAT PLC IEC 60870-5-104 Slave CE
Realisierung von Slaves für IEC 60870-104 unter Windows CE
TS6511 | TwinCAT PLC IEC 61850 Server
Kommunikation nach IEC 61850
TS6509 | TwinCAT PLC IEC 61400-25 Server
Kommunikation nach IEC 61400-25
TS6371 | TwinCAT DriveTop Server
Konfiguration von Indramat-SERCOS-Antrieben mit der DriveTop-Software auf TwinCAT-Systemen
TS6370 | TwinCAT DriveCOM OPC Server
feldbusunabhängige Kommunikationsverbindung vom Engineeringtool zum Antrieb
TS6120 | TwinCAT OPC Server
Zugriff auf TwinCAT-Variablen, gemäß OPC-DA-/OPC-XML-DA-Spezifikation
TS6100 | TwinCAT OPC UA Server
Zugriff auf TwinCAT gemäß OPC UA: DA/HA/AC
TS6000 | TwinCAT ADS Communication Library
ADS-Kommunikationskomponenten
TS6350 | TwinCAT SMS/SMTP Server
Versenden von SMS und E-Mails aus der SPS
TS6310 | TwinCAT TCP/IP Server
Kommunikation über generische TCP-Server
TS6271 | TwinCAT PROFINET IO Controller
TwinCAT PROFINET IO Controller macht aus jeder PC-basierten Steuerung einen PROFINET-IO-Controller.
TS6270 | TwinCAT PROFINET IO Device
TwinCAT PROFINET IO Device macht aus jeder PC-basierten Steuerung ein PROFINET-IO-Device.
TS6280 | TwinCAT EtherNet/IP Slave
TwinCAT EtherNet/IP Slave macht aus jeder PC-basierten Steuerung einen EtherNet/IP-Slave
TS6360 | TwinCAT Virtual Serial COM Driver
virtueller Serial-COM-Treiber für Windows-XP- und Windows-CE-Plattformen
TS6300 | TwinCAT FTP Client
einfacher Zugriff von der TwinCAT SPS auf FTP-Server
TS6600 | TwinCAT PLC RFID Reader Communication
Anschluss von RFID-Readern an die TwinCAT PLC
TS6610 | TwinCAT PLC S5/S7 Communication
Kommunikation zu S5/S7-Steuerungen


Beckhoff TwinCAT | TwinCAT PLC Controller Toolbox

TwinCAT PLC Controller Toolbox

TwinCAT Supplement Controller | TS4xxx

Supplements | Controller
TS4100 | TwinCAT PLC Controller Toolbox
SPS-Bibliothek mit Bausteinen für Basisregler (P, I, D), komplexe Regler (PI, PID), Pulsweitenmodulation, Rampen, Signalgeneratoren und Filter
TS4110 | TwinCAT PLC Temperature Controller
SPS-Bibliothek mit instanziierbarem Temperaturregler-Funktionsbaustein zum Überwachen und Regeln von verschiedenen Temperaturstrecken


Beckhoff TwinCAT | TwinCAT PLC Building Automation

TwinCAT PLC Building Automation

TwinCAT Supplement Building Automation | TSxxxx

Supplements | Building Automation
TS8020 | TwinCAT BACnet/IP
Kommunikation für Datennetze der Gebäudeautomatisierung und Gebäuderegelung
TS8000 | TwinCAT PLC HVAC
SPS-Bibliothek zur Automation von Heizungs-, Lüftungs-, Klima- und Sanitäranlagen
TS8010 | TwinCAT PLC Building Automation Basic
SPS-Bibliothek zur Ausführung von Grundfunktionen im Bereich der Raumautomatisierung
TS8036 | TwinCAT Crestron Server
Kommunikation zwischen einer TwinCAT SPS und einer Crestron-Steuerung
TS8037 | TwinCAT Bang & Olufsen Server
Kommunikation zwischen einer TwinCAT SPS und einer Bang&Olufsen-Audio/Video-Installation über Ethernet
TS8035 | TwinCAT FIAS Server
Kommunikation zwischen einer TwinCAT SPS und einem System nach dem FIAS-Standard
TS8100 | TwinCAT Building Automation Framework
Framework zur Konfiguration und Inbetriebnahme von Building-Automation-Projekten
TwinCAT PLC DALI
SPS-Bibliothek zur Kommunikation über die DALI-Busklemme
TwinCAT PLC EnOcean
SPS-Bibliothek zur Kommunikation über die EnOcean-Busklemme
TwinCAT PLC EIB
SPS-Bibliothek zur Kommunikation über die EIB-Busklemme
TwinCAT PLC LON
SPS-Bibliothek zur Kommunikation über die LON-Busklemme
TwinCAT PLC M-Bus
SPS-Bibliothek zur Kommunikation über die M-Bus-Busklemme
TwinCAT PLC MP-Bus
SPS-Bibliothek zur Kommunikation über die MP-Bus-Busklemme
TwinCAT PLC DMX
SPS-Bibliothek zur Kommunikation über die DMX-EtherCAT-Klemme


Beckhoff TwinCAT Registrierung

TwinCAT Registrierung

TwinCAT ist 30 Tage lang kostenlos nutzbar. Für eine weitergehende Verwendung, ist eine Registrierung erforderlich. Über diese Registrierung erwirbt man eine Lizenz zur Nutzung der Software.

Das Lizenzierungs-Verfahren
Bei der Installation von TwinCAT generiert das Setup-Programm automatisch eine sogenannte System-ID (z.B. E2A4-90A6-242) aus den individuellen Kennnummern des Prozessors und der Festplatte, auf dem TwinCAT gerade installiert wird. So entsteht ein Code, der nur für diesen einen Prozessor und diese eine Festplatte gültig ist. Aus dieser System-ID wird bei der Registrierung der sogenannten Registrierungs-Schlüssel (z.B. 98DD-69E7-34BE-1AF7) erzeugt, den man dann in das entsprechende Feld des Setup-Programms einträgt. Dadurch wird dann die zeitliche Begrenzung von 30 Tagen aufgehoben.

Registrierungs-Anleitung:
Starten Sie das TwinCAT Setup und folgen Sie den erscheinenden Anweisungen, bis das Fenster "Benutzerinformationen" erscheint.

Geben Sie hier Ihren Namen und Firmennamen ein und wählen Sie "Weiter >"

Wählen Sie hier die mittlere Option und wählen Sie "Weiter >"

Den Registrierungsschlüssel erhalten Sie unter Angabe Ihrer System-ID per Telefon, Fax
oder E-Mail:

Telefon: +49 (0) 5246 963-0
fax: +49 (0) 5246 963-198
E-Mail: vertrieb@beckhoff.com

Sie erhalten dann den Registrierungs-Schlüssel, den Sie in das Feld "Reg.Key" eingeben. Danach wählen Sie "Weiter >"

Die Lizenzierung ist damit beendet. Fahren Sie mit dem Rest der Installation fort.