Beckhoff TwinCAT NC

Weitere Informationen zur NC

TwinCAT NC ADS Dokumentation

TwinCAT SPS Bibliotheken

Historie

Die NC Features, die in der Neuigkeiten Seite nicht mehr aufgeführt sind, finden Sie in der Historienliste.


Neuigkeiten im Bereich TwinCAT NC

TwinCAT NC: Übersicht

Historie der Neuigkeiten im Bereich TwinCAT NC

TwinCAT NC:

04 / 2002 | Totzeitkompensation bei Achskopplung an eine Encoder Achse (virtuelle Achse)
04 / 2002 | Encoder Auswerterichtung (Freigabe für log. Encoderzählrichtung)
04 / 2004 | Die Encoder-Klemmen KL5111 und KL5151 sowie die Feldbus Box IP5209 komplett eingebunden
04 / 2004 | Die 'CANOpen State Machine' für 'Drives and Motion Control' nach DSP 402 V2.0 ist eingebunden.
11 / 2004 | NC Schrittmotor-Achstyp für die Schrittmotorklemmen KL2531 und KL2541
04 / 2005 | Integration von kostengünstigen Stepper-Leistungsstufen
04 / 2005 | NC Zykluszeituntersetzung individuell für jede Achse konfigurierbar

TwinCAT PTP:

07 / 2002 | Verschmelzung der zwei Achsfunktionen 'Neustart' und 'Nachstarten auf ein neues Ziel'
10 / 2002 | Externe Sollwertgenerierung
11 / 2004 | Spezielle_Achsfunktionen_wie_Modulo-Start_und_Orientierter-Stop_für_Modulo-Achsen_(Rund-Achsen)
11 / 2004 | Dynamische_Linear-Kopplung_(Getriebekopplung)_mit_zyklisch_änderbarem_Getriebefaktor
11 / 2004 | Messtaster-Funktion_(Touch_Probe)_für_hochgenaues_Messen
04 / 2005 | Streckenkompensation (MC_MoveSuperImposedExt) mit neuen Betriebsarten
11 / 2005 | Neue PTP-Sollwertgenerierung

TwinCAT Universelle Fliegende Säge:

11 / 2003 | Universelle Fliegende Säge für das Aufsynchronisieren von Achsen aus beliebigen Bewegungszuständen
04 / 2004 | Universelle Fliegende Säge - Erweiterung der Features

TwinCAT Camming:

04 / 2002 | Online-Änderung von Tabellen-Skalierung und Tabellen-Offset mit Aktivierungsposition
11 / 2002 | Charakteristische Kennwerte von Tabellen (Kurvenscheiben)
04 / 2004 | Motion Function - Bewegungsgesetze in Echtzeit
11 / 2004 | Online_Änderung_der_Skalierung_und_des_Offsets_von_Kurvenscheiben
11 / 2004 | Online_Modifikation_der_Motion_Function
04 / 2005 | Rückmeldung im zyklischen Achsinterface dass neue Tabellen Skalierungen zur Übernahme anstehen (Daten zur Online Skalierung)
04 / 2005 | Streckenkompensation (MC_MoveSuperImposed) nun auch für Kurvenscheiben (MF und Positionstabelle)
11 / 2005 | Lesen der aktuellen Tabellen-Kopplungs-Information
11 / 2005 | Charakteristische Kennwerte von Tabellen
03 / 2006 | Online Wechsel der Kurvenscheibe

TwinCAT Cam Design Tool:

04 / 2002 | Cam Design Tool (Kurvenscheibeneditor) integriert in TwinCAT System Manager
07 / 2002 | Grafische Kontrolle der aktuellen Masterposition und Modifikation der Übertragungsfunktionen durch andere Applikationen

TwinCAT Hydraulik:

10 / 2002 | Hydraulik-Ventil-Kennlinien zur Linearisierung des Übertragungsverhaltens nichtlinearer Systeme TwinCAT Valve Diagram Editor
 | Hydraulik Regler (Ankündigung)

TwinCAT NCI:

06 / 2002 | Hilfsachsen im Teileprogramm
07 / 2002 | Satznummer des Teileprogramms kann ausgelesen werden
07 / 2002 | Anzahl der Werkzeugdaten erhöht
07 / 2002 | G70/G71 Inch/Metrisch-Umschaltung
10 / 2002 | NCI-EStop
10 / 2002 | Funktionsbausteine zur Generierung eines Teileprogramms
03 / 2003 | Berechne Rotation eines Vektors im Teileprogramm
03 / 2003 | Schreibe Werkzeugparameter aus dem Teileprogramm
03 / 2003 | Verschleifen mit Hilfsachsen
07 / 2003 | Lese verbleibende Bahnlänge
07 / 2003 | Zusätzliche Software-Endlagenüberwachung
03 / 2005 | Virtuelle Bewegungen überspringen
03 / 2005 | Zielpositionsüberwachung
06 / 2005 | Schreibe einstellbare Nullpunkverschiebung aus dem Teileprogramm
06 / 2005 | Absetzen von Meldungen aus dem Teileprogramm
06 / 2005 | Erweiterungen der Rotation
06 / 2005 | FBs zum Nullen der Werkzeugbeschreibungen und Nullpunktverschiebungen
10 / 2005 | Anzeige des Teileprogramms
10 / 2005 | Mittelpunktskorrektur ein/aus

TwinCAT NC:

04 / 2002: Totzeitkompensation bei Achskopplung an eine Encoder Achse (virtuelle Achse)

Mit dieser neuen Eigenschaft (s. TwinCAT System Manager: 'Encoder Achse -> Generator') kann bezüglich einer Achskopplung an eine Encoderachse eine Totzeitkompensation vorgenommen werden. Die Notwendigkeit hierfür liegt darin, dass die extern eingelesene Istposition der Encoder Achse 'alt' gegenüber dem in der Steuerung berechneten Sollwerten der Slaveachse ist. Da es sich hierbei um eine deterministische Totzeit handelt, kann diese in der Steuerung ausgeglichen werden.

(ab TwinCAT V2.8 Build 725)

04 / 2002: Encoder Auswerterichtung (Freigabe für log. Encoderzählrichtung)

Mit diesem neuen Encoderparameter (s. TwinCAT System Manager: 'Encoder -> Global') kann die ausgewertete logische Encoderzählrichtung festgelegt werden. Es wird zwischen folgenden Typen unterschieden:
'Positiv+Negativ' (0), 'Positiv' (1), 'Negativ' (2), 'Aus' (3).

Einsatzbeispiel:
Bei einer Achskopplung an ein Handrad (virtuelle Encoder Achse) darf beispielsweise zwingend nur eine Bewegung der Slaveachse in positiver Richtung ausgeführt werden. Der Encodermode 'Positiv' (1) würde eine Handradauswertung in entgegengesetzter negativer Richtung wie eine Art Freilauf verhindern.

(ab TwinCAT V2.8 Build 725)

Beschreibung

04 / 2004: Die Encoder-Klemmen KL5111 und KL5151 sowie die Feldbus Box IP5209 sind komplett in die NC PTP eingebunden.

(ab TwinCAT V2.9 Build 958)

04 / 2004: Die 'CANOpen State Machine' für 'Drives and Motion Control' nach DSP 402 V2.0 ist eingebunden.

(ab TwinCAT V2.9 Build 958)

11 / 2004: NC Schrittmotor-Achstyp für die Schrittmotorklemmen KL2531 und KL2541

Neuer spezieller Achstyp für optimale Integration der Schrittmotorklemmen KL2531 (2 x 1,5 A Spitzenstrom) und KL2541 (2 x 5,0 A Spitzenstrom und Inkremental-Encoder). Aufgrund dieser neuen Klemmentypen und zusätzlicher NC Eigenschaften können diese preiswerten Schrittmotor-Achsen nun ähnlich wie "Kleinservoachsen" verwendet werden.

(ab TwinCAT V2.9 Build 1020)

05 / 2005: Integration von kostengünstigen Stepper-Leistungsstufen

Durch die Integration von Stepper-Leistungsstufen in die Klemmen KL2531/Kl2541 sind kostengünstige Antriebslösungen im Low Power Bereich möglich geworden. Um den Einsatz dieser Motortechnologie zu erleichtern unterstützt jetzt die SPS Bibliothek "TcMc.Lib" mit dem Baustein "MC_PowerStepper" die automatische Handhabung von Problemen wie Stalling oder Drahtbruch. Für die SPS-Applikation unterscheidet sich die Stepper-Achse nicht mehr wesentlich von einem Servo.

(ab TwinCAT V2.9 Build 1030)

05 / 2005: NC Zykluszeituntersetzung individuell für jede Achse konfigurierbar

Die NC Zykluszeituntersetzung ermöglicht unterschiedliche Zykluszeiten pro Achse für NC und IO. Die NC-SAF-Task wird mit der kleinsten benötigten Zykluszeit konfiguriert. Für jede Achse oder Interpolations-Gruppe kann eine individuelle Zykluszeituntersetzung mit einem Faktor als ganzzahligem Vielfachen der NC-Task-Zykluszeit festgelegt werden. Zur Optimierung der Systemauslastung, können die Berechnungszeitpunkte optional mittels eines frei konfigurierbarem Offset ("Modulo Shift") festgelegt werden.

(ab TwinCAT V2.10 Build 1225)

TwinCAT PTP:

07 / 2002: Verschmelzung der zwei Achsfunktionen 'Neustart' und 'Nachstarten auf ein neues Ziel'

Die feste Unterscheidung zwischen einem 'Achsstart aus dem Stillstand' und dem online 'Nachstarten auf eine neue Zielposition' während einer aktiven Positionierung hat sich in der Vergangenheit in manchen Fällen als schwierig erwiesen. Für viele Anwendungen ist es einfacher und komfortabler nicht mehr zwischen diesen beiden Zuständen unterscheiden zu müssen. Jetzt hat man eine neue Funktionalität, die diese Unterscheidung aufhebt und eine Achse in jeder Situation auf ihre parametrierte Zielposition mit vorgegebener Fahrgeschwindigkeit begleitet.

Diese neue Funktion steht mit dem SPS Baustein 'MC_MoveAbsoluteOrRestart' in der 'TcMc.lib' zur Verfügung.

(ab TwinCAT V2.8 Build 736)

10 / 2002: Externe Sollwertgenerierung

Die externe Sollwertgenerierung ermöglicht es eigene Sollwertgeneratoren (z.B. in der SPS) zu implementieren, oder schon vorhandene interne und externe Generatoren entsprechend zu verschalten, und diese einfach und transparent in das TwinCAT System zu integrieren. Dadurch können Achsen entweder ausschließlich mit einem externen Sollwertgenerator positioniert werden oder aber die generierten Sollwerte werden den Daten eines internen Standardgenerators additiv überlagert. Hierdurch eröffnen sich ganz neue Einsatz- und Anwendungsgebiete.
Durch diese neuen Eigenschaften und die Tatsache, dass eine Achse zur Laufzeit ihre verschiedenen Betriebsarten wechseln kann (z.B. interpolierende Bahnachse (NCI), Master PTP-Achse, Slaveachse, externe Sollwertgenerierung), erhöht sich weiter die Flexibilität einer TwinCAT Achse.
Grundsätzlich ermöglicht die Überlagerung von internen und externen Sollwertquellen eine Vielzahl von neuen Anwendungen.

Einsatzbeispiele:

  • Die externe Sollwertvorgabe kann genutzt werden, um ein eigenes neues Sollwertprofil zu implementieren, das in der TwinCAT NC nicht verfügbar ist. Dieses Profil kann mathematisch sehr einfach oder auch beliebig komplex sein. Da das extern generierte Sollwertprofil auch dem Standardprofil überlagert werden kann, lassen sich somit auch korrigierende Funktionen ergänzen.
    So kann ein positionsbasiertes Sollwertprofil für schwer regelbare oder nichtlineare Systeme realisiert werden, beispielsweise eine positionsbasierte Bremsrampe bei Hydraulikachsen.
  • Eine Anwendung für das Überlagern (Mischen) zweier interner Sollwertquellen ist die Kombination aus interpolierender Bahnbearbeitung (NCI) und der Funktion 'Fliegende Säge' (PTP Slave). Somit wird eine mehrdimensionale Bearbeitung, z.B. ein Kreis, auf einem bewegtem Werkstück möglich, was zuvor nur mit einem ruhenden Werkstück möglich gewesen ist. Diese Maßnahme erhöht die Effizienz einer Maschine.
  • Die externe Sollwertgenerierung wird auch genutzt, um eine bestimmte Vorlaufzeit (im mehrstelligen Sekundenbereich) zwischen der sollwertgenerierenden Einheit (z.B. die Abarbeitung eines DIN-NC-Programme das virtuelle Achsen speist) und den realen Achsen zu ermöglichen. Hier können dann Kollisionsüberwachungen und Strategien zur Kollisionsvermeidung realisiert werden.
  • Ein weiterer wichtiger Anwendungsfall sind Koordinatentransformationen (beschränkt auf reguläre und eindeutige Transformationen ohne Singularitäten). Z.B. Geometrien wie ein 'Zweischlag' oder Umrechnung zwischen rotatorischen und translatorischen Koordinaten.

Diese neue Funktion steht mit den SPS Bausteinen MC_ExtSetPointGenEnable und MC_ExtSetPointGenDisable in der Bibliothek TcMc.lib zur Verfügung. Ferner gibt es ein Beispiel für einen externen Sollwertgenerator (3 Phasen Profil mit Beschleunigungsrechteck).

(ab TwinCAT V2.9 Build 906)

Beschreibung

11 / 2004: Spezielle Achsfunktionen wie Modulo-Start und Orientierter-Stop für Modulo-Achsen (Rund-Achsen)

Mit dem Funktionsbaustein MC_MoveModulo wird eine Positionierung durchgeführt, die sich auf die Modulo-Position einer Achse bezieht. Grundlage für eine Modulo-Umdrehung ist hierbei der einstellbare Achsparameter Modulo-Faktor (z. B. 360). Abhängig vom Direction Eingang werden drei mögliche Starttypen unterschieden: Positionierung in positive Richtung, Positionierung in negative Richtung und Positionierung auf kürzestem Weg.

Mit dem Funktionsbaustein MC_OrientedStop wird eine Achse an der angegebenen Modulo-Position "orientiert " gestoppt. Im Vergleich zum bisherigen regulären MC_Stop wird hier in Abhängigkeit der Geschwindigkeit und der Dynamikparameter der Achse diese an der nächst möglichen orientierten Position zum Stillstand gebracht.

(ab TwinCAT V2.9 Build 1020)

11 / 2004: Dynamische Linear-Kopplung (Getriebekopplung) mit zyklisch änderbarem Getriebefaktor

Mit dem Funktionsbaustein MC_GearInDyn wird ein lineare Master-Slave-Kopplung (Getriebekopplung) aktiviert. Der Getriebefaktor kann hierbei aber dynamisch, d. h. in jedem SPS-Zyklus angepasst werden. Somit lässt sich eine Regelung/[geschlossener Regelkreis] für die gekoppelte Slave-Achse aufbauen.

(ab TwinCAT V2.9 Build 1020)

11 / 2004: Messtaster-Funktion (Touch Probe) für hochgenaues Messen

Der Baustein MC_TouchProbe erfasst eine Achsposition zum Zeitpunkt eines digitalen Signals (Messtasterfunktion). Die Position wird üblicherweise nicht direkt in der SPS-Umgebung, sondern über ein externes Hardware-Latch erfasst und ist damit hochgenau und Zykluszeit-unabhängig. Der Baustein steuert diesen Mechanismus und ermittelt die extern erfasste Position.

(ab TwinCAT V2.9 Build 1020)

05 / 2005: Streckenkompensation (MC_MoveSuperImposedExt) mit neuen Betriebsarten.

Die Streckenkompensation (MC_MoveSuperimposed) kannte bisher eine Betriebsart, bei der auf einer vorgegebenen Strecke eine zusätzliche Distanz (positive oder negative Ausgleichsdistanz) aufgeholt werden kann. Der erweiterte Funktionsbaustein MC_MoveSuperimposedExt unterstützt vier Betriebsarten, die in unterschiedlichen Applikationen zur Anwendung kommen und dem Anwender die Berechnung einer Ausgleichsfahrt wesentlich vereinfachen:

  • Ausgleichsfahrt auf vorgegebener Strecke um eine zusätzliche Distanz.
    Dieses ist die klassische Betriebsart, in der sich die Strecke auf eine unkompensierte Bezugsachse, beispielsweise eine Masterachse, bezieht. Die Slave-Achse legt während der Operation eine um die Ausgleichsdistanz größere Gesamtstrecke zurück. Die Geschwindigkeit wird durch die Funktion berechnet.
  • Ausgleichsfahrt auf vorgegebener Strecke, wobei die auszugleichende Distanz enthalten ist.
    Diese Betriebsart ist beispielsweise bei Förderbändern interessant, bei der die Ausgleichsfahrt bis zum Ende des Bandes abgeschlossen sein muss. Unabhängig von der auszugleichenden Distanz wird die vorgegebene Strecke nicht überschritten.
  • Ausgleichsfahrt auf möglichst kurzer Strecke mit vorgegebener Maximalgeschwindigkeit.
    In dieser Betriebsart wird die zusätzliche Distanz so schnell wie möglich ausgefahren und ist damit beispielsweise für Winkelverstellungen interessant.
  • Ausgleichsfahrt auf möglichst kurzer Strecke, wobei die auszugleichende Distanz in der Strecke enthalten sein muss.
    In dieser Betriebsart wird die Verstellung ebenfalls so schnell wie möglich durchgeführt, es wird aber zusätzlich beachtet, dass die Gesamtstrecke während der Operation nicht überfahren wird. Diese Betriebsart ist ebenfalls für schnelle Verstelloperationen interessant, bei denen eine Endposition aber nicht überschritten werden darf.

(ab TwinCAT V2.9 Build 1030)

11 / 2005: Neuer PTP-Sollwertgenerator

Alternativ zum bisherigen PTP-Sollwertgenerator gibt es einen neuen PTP-Sollwertgenerator (kontinuierliches ruckbegrenztes 7 Phasen Profil), der einige verbesserte Eigenschaften und eine Vielzahl neuer Funktionalitäten besitzt.

Eigenschaften:

  • großer Wertebereich für Dynamikparameter wie Geschwindigkeit, Beschleunigung, Verzögerung und Ruck
    - bewährtes ruckbegrenztes 7 Phasen Profil
    - beschleunigungsbegrenztes 3 Phasen Profil durch entsprechende Parametrierung möglich
    - extrem schnelle Positionierzeiten auf kurze Distanzen, die im Sonderfall sogar in einem NC-Zyklus das Ziel erreichen können
  • zeit- und geschwindigkeitsoptimierte Bewegungsprofile ohne Zwischenphasen im Bewegungsprofil (z.B. kein unnötiges beschleunigungsfreies Fahren)
  • adaptiver Geschwindigkeits-Override, der den Anwenderparametern bestmöglich folgt
  • bestmögliche Umsetzung der Dynamikparameter des Anwenders. Das gilt vor allem für die Genauigkeit einer vorgegebenen Fahrgeschwindigkeit.
  • Transparenz bezüglich der Parametrierung, da eine stetige monotone Änderung der Dynamikparameter immer einer stetigen monotonen Änderung der Wirkung entspricht
  • Neue Achs-Funktionalitäten:
    - Änderung der Dynamikparameter wie Beschleunigung, Verzögerung und Ruck während der Positionierung.
    - Änderung der Fahrgeschwindigkeit. Dabei kann die Änderung sowohl ab einer bestimmten Position eingeleitet werden, als auch die Geschwindigkeit an einer bestimmten Position erreicht werden.
    - Abkoppeln einer Slave-Achse mit gleichzeitiger Anschlusspositionierung. Nach dem Abkoppeln kann mit demselben Kommando beispielsweise eine Zielposition angefahren werden, eine Endlosfahrt gestartet oder eine Achse gestoppt werden.

(ab TwinCAT V2.10 Build 1243)

TwinCAT Universelle Fliegende Säge:

11 / 2003: Universelle Fliegende Säge für das Aufsynchronisieren von Achsen aus beliebigen Bewegungszuständen

Die bereits im TwinCAT System enthaltene fliegende Säge wurde durch die Universelle Fliegende Säge ergänzt. Die bisherige fliegende Säge im TwinCAT-System forderte beim Start den Stillstand der Slaveachse, um dann mit maximaler Dynamik auf die Masterachse auf zu synchronisieren. Die neue Funktionalität erlaubt nun das Synchronisieren auf einen fahrenden Master, wobei die Anfangsdynamik des Slaves beliebig ist. Dies bedeutet für viele Applikationen deutlich mehr Freiheitsgrade, da die Slaveachse zum Zeitpunkt des Ankoppelns bereits mit positiver oder negativer Geschwindigkeit und Beschleunigung einen vorherigen Fahrauftrag ausführen kann. Bei einer zyklischen Slaveachse kann nach jeder abgeschlossenen Bearbeitung der nächste Zyklus mit einer neuen Synchronposition gestartet werden. Der Getriebefaktor dieser Master-Slave-Kopplung kann beliebige Werte ungleich Null annehmen.

Diese neue Funktion steht mit den SPS Bausteinen MC_GearInPos und MC_GearInVelo in der Bibliothek TcNcFlyingSaw.lib zur Verfügung.

Einsatzbeispiel:
Werkstückbearbeitung während des Transportes.

(ab TwinCAT V2.9 Build 950)

Beschreibung

04 / 2004: Universelle Fliegende Säge - Erweiterung der Features

Im Bereich TwinCAT NC PTP ist die universelle fliegende Säge um einige Features erweitert worden. Beim zyklischen Bearbeiten von Werkstücken kann nach Beendigung der Bearbeitung des einen Werkstückes und Vorliegen der Position des neuen Werkstückes direkt auf die neue Position gekoppelt werden. Das System errechnet dann intern die optimale Geschwindigkeit in Abhängigkeit von der maximalen Beschleunigung.

Für das Synchronisieren auf Geschwindigkeit ("MC_GearInVelo") existiert ein neues ruckbegrenztes 7-Phasen-Profil, das eine Slaveachse mittels instantaner Entscheidungen immer optimal an den Grenzen der parametrierten Slavedynamik (Beschleunigung, Verzögerung, Ruck) führt. Dies geschieht unabhängig und rückwirkungsfrei in Bezug auf die Masterdynamik, wodurch eine ungewollte Beeinflussung der Slaveachse auf Grund der Masterdynamik ausgeschlossen ist.

Die Universelle Fliegende Säge hat nun auch die Eigenschaft der Streckenkompensation/Positionskompensation (PLCOpen: "MC_MoveSuperImposed") bekommen. Mit dieser Funktionalität kann ein weiteres Bewegungsprofil überlagert werden, mit dem es möglich ist, eine Positionsdifferenz auszugleichen.

(ab TwinCAT V2.9 Build 958)

Beschreibung

TwinCAT Camming:

04 / 2002: Online-Änderung von Tabellen-Skalierung und Tabellen-Offset mit Aktivierungsposition

Diese neue Achsfunktion (s. TwinCAT ADS Interface NC) bewirkt eine positionsgenaue Aktivierung von neuen Skalierungen und Offsets der Master- und Slaveachsen. Diese Funktion ist unabhängig von SPS- und ADS-Laufzeiten, sofern das Kommando rechtzeitig vor Überschreiten bzw. Unterschreiten der absoluten Masteraktivierungsposition abgesetzt worden ist.

Einsatzbeispiel:
Bei einer zyklischen Tabellenkopplung können z.B. genau beim Wechsel in die nächste Masterperiode neue Skalierungen und Offsets wirksam werden.

(ab TwinCAT V2.8 Build 725)

11 / 2002: Charakteristische Kennwerte von Tabellen (Kurvenscheiben)

Das Cam Design Tool (Kurvenscheibeneditor) bzw. der NC Kernel berechnen und verwalten nun auch die charakteristischen Kennwerte der Kurvenscheiben. Hierzu gehören physikalische Größen wie z. B. Positionsbereich und nominelle Geschwindigkeit des Masters, maximale und minimale Geschwindigkeit, Beschleunigung, Ruck und dynamisches Moment des Slaves, sowie der Effektivwert der Slavebeschleunigung.

Einsatzbeispiel:
Diese Kennwerte helfen, die mechanischer Beanspruchung, den Verschleiß und den Energieverbrauch der Maschine zu beurteilen und zu optimieren.

(ab TwinCAT V2.9 Build 906)

04 / 2004: Motion Function - Bewegungsgesetze in Echtzeit

Die Motion Functions realisieren die bekannten Bewegungsfunktionen (zum Beispiel der VDI 2143) direkt in dem Echtzeit Treiber der NC. Im Gegensatz zu den klassischen Tabellenkopplungen, die nur diskrete Schritte (Punktewolken) in die NC übertragen, liegen hier die vollständigen Informationen in der NC vor. Ein Bewegungsdiagram – die komplette Beschreibung der Bewegung einer Slaveachse – lässt sich durch entsprechende Funktionsbausteine einfach und übersichtlich von der PLC aus definieren und modifizieren. Für eine Visualisierung der aktuellen Daten besteht die Möglichkeit, entsprechende Werte der Position, Geschwindigkeit oder Beschleunigung intern rechnen zu lassen und in Tabellenform zur Verfügung zu stellen.

Im Cam Design Tool vom TwinCAT ist die Entscheidung, ob klassische Tabellenkopplungen oder Motion Function verwendet werden sollen, durch eine Auswahl umschaltbar. Danach werden für das Starten des Systems entweder die Tabellendaten oder die Punkte der Motion Functions generiert. Im Falle der Motion Functions können diese Punkte einzeln nachträglich von der PLC modifiziert werden. Zur Kontrolle der Daten in der NC gibt es die Möglichkeit die aktuelle Kurvenscheibe (Punktewolke oder Motion Function) der NC in dem Cam Design Tool im Hintergrund inklusive ihrer Ableitungen darzustellen. Die Daten der Motion Functions der NC können sogar per Upload in das Cam Design Tool geladen und dort modifiziert werden.

(ab TwinCAT V2.9 Build 958)

Beschreibung

11 / 2004: Online Änderung der Skalierung und des Offsets von Kurvenscheiben

Die Skalierung und der Offset von Slave und Master können online (in Kopplung) geändert werden. Diese Funktionalität ist für die Motion Function und die Positionstabellen implementiert. Die Aktivierung erfolgt entsprechend dem Aktivierungsmode instantan, ab einer Aktivierungsposition oder ab dem nächsten Zyklus. In dem Skalierungsmode AutoOffset wird automatisch der Offset des Slaves intern so gesetzt, dass die Position des Slaves stetig bleibt.

Beschreibung

11 / 2004: Online Modifikation der Motion Function

Die durch Motion Function definierten Kurvenscheiben können online modifiziert werden. Dazu können einzelne Punkte mit den entsprechenden Bewegungsgesetzen übertragen werden. Die Online Änderung wird nach entsprechenden Regeln aktiviert zum Beispiel zum Zyklusende, ab einer Aktivierungsposition, instantan oder nur auf dem nächsten Segment, das nicht von den Änderungen betroffen ist. In dem Skalierungsmode AutoOffset wird automatisch der Offset des Slaves intern so gesetzt, dass die Position des Slaves stetig bleibt. Zur Kontrolle enthält das zyklische Achs-Interface ein Bit (NcToPlc.nStateDWord.bCamDataQueued ). Mit dieser Funktionalität können zum Beispiel unterschiedliche Bewegungen für das Anfahren, die Arbeitsphase und das Herunterfahren einer Maschine (Start-, Arbeits- und Stopptabelle) realisiert werden.

Beschreibung

05 / 2005: Rückmeldung im zyklischen Achsinterface dass neue Tabellen Skalierungen zur Übernahme anstehen

Neue Skalierungsdaten stehen zur Übernahme bereit. Die Funktion AxisCamScalingPending in der PLC gibt den Status der Übernahme der Daten als aktuelle Skalierungen wieder. Nach Übernahme der Daten als aktuelle Skalierung wird die Variable wieder zurückgesetzt. Diese Information gilt sowohl für Motion Function als auch für Positionstabellen

(ab TwinCAT V2.9 Build 1030)

05 / 2005: Streckenkompensation (MC_MoveSuperImposed) nun auch für Kurvenscheiben

Die Streckenkompensation („MC_MoveSuperImposed“ bzw. "MC_MoveSuperImposedExt") kann nun auch in den zwei Varianten für den Slavetyp Tabellenkopplung genutzt werden. Dies gilt sowohl für die MotionFunction (MF) als auch für die Positionstabellen.

(ab TwinCAT V2.9 Build 1030)

11 / 2005: Lesen der aktuellen Tabellen-Kopplungs-Information

Während eine Slave-Achse über eine Kurvenscheibe gekoppelt ist, können mit dem Funktionsbaustein MC_CamInfo wesentliche Informationen zum derzeitigen Koppelzustand gelesen werden. Diese Möglichkeit besteht sowohl für die Positionstabelle als auch für die Motion Function (MF). Zu diesen Informationen zählen z.B. der Interpolationstyp, der Slave-Hub, die Master-Periode, die Offsets und Skalierungen und die letzten gültigen Positionen von Master und Slave.
Wenn beispielsweise nach einem Not-Stopp oder Achsfehler die gekoppelten Achsen wieder in die richtige Ausgangsposition gefahren werden sollen, so können vor dem Auflösen der Kopplung die relevanten Kopplungs-Informationen gelesen werden. Diese Informationen können dann nach dem individuellen Fehlerhandling zum Wiederankoppeln verwendet werden.

(ab TwinCAT V2.10 Build 1243 mit PLC Bibliothek: TcNcCamming.lib)

11 / 2005: Charakteristische Kennwerte von Tabellen

Die charakteristischen Kennwerte können jetzt sowohl für die Motion Function als auch für die Positionstabellen online berechnet werden. Die Positionstabellen werden als kubischer Spline interpretiert.

(ab TwinCAT V2.10 Build 1243)

03 / 2006: Online Wechsel der Kurvenscheibe

Bei einer bestehenden Tabellenkopplung kann eine Tabelle A direkt gegen eine andere Tabelle B online ausgetauscht werden. Dabei kann sowohl zwischen verschiedenen Interpolationsarten (Linear oder Spline) für Positionstabellen als auch zwischen Positionstabellen und Motion Function (MF) gewechselt werden. Die Regeln für den Wechsel werden durch den Aktivierungsmodus mit optionaler Aktivierungsposition festgelegt. Die neuen Werte für die Skalierung und den Offset von Master und Slave können entweder explizit parametriert werden oder werden intern in Abhängigkeit des Aktivierungsmodus vorbesetzt. Durch ein Flag in dem zyklischen Achs-Interface wird angezeigt, dass eine neue Tabelle zum Online Wechsel von Tabellen bereit steht. Nach Austausch und Aktivierung der neuen Tabelle wird dieses Flag automatisch zurückgesetzt.

(ab TwinCAT V2.10 Build ???)

TwinCAT Cam Design Tool:

04 / 2002: Cam Design Tool (Kurvenscheibeneditor) integriert in TwinCAT System Manager

Das Cam Design Tool (Kurvenscheibeneditor) ist ein grafisches Entwurfstool für elektronische Kurvenscheiben integriert in den System Manager des TwinCAT mit folgenden Eigenschaften:

  • Interaktiver Entwurf nach der VDI Richtlinie 2143 und zusätzliche Bewegungsgesetze
  • Gleichzeitige grafische und tabellarische Anzeige der Position und der Dynamikwerte der Slaves (Geschwindigkeit, Beschleunigung, Ruck, dynamisches Moment)
  • Einlesen vorhandener tabellarischen Kurvenscheiben mit anschließender Berechnung der Ableitungen
  • Speichern der Kurvenscheibendaten in der Konfigurationsdatei des System Managers, so dass beim Starten des Systems die automatisch generierten Tabellendaten in die Echtzeitumgebung geladen werden
  • Export und Import der internen Daten eines Slaves oder eines Masters mit all seinen Slaves in einer temporären Datei zum Austausch zwischen verschiedenen Projektdateien.

Anmerkung: Durch einen speziellen Key wird der Kurvenscheibeneditor im System Manager freigeschaltet.

(ab TwinCAT V2.8 Build 725)

Beschreibung

07 / 2002: Grafische Kontrolle der aktuellen Masterposition und Modifikation der Übertragungsfunktionen durch andere Applikationen

Der Kurvenscheibeneditor bietet jetzt neben der komfortablen grafischen Generierung von Kurvenscheiben auch die Möglichkeit der Kontrolle der aktuellen Masterposition in der Grafik.
Außerdem können dabei alle Slaves einer Masterachse in einem Diagramm dargestellt werden.
Die grafisch interaktive Modifikation von Symmetriewerten der Bewegungsgesetze oder der Beschleunigungswerte in Umkehrpunkten erleichtern das Feintuning der Übertragungsfunktionen.

Die Daten einer Kurvenscheibe (Positionswerte von Master und Slave inklusiv der Ableitungen an den Segmentgrenzen) können jetzt als XML-Datei exportiert werden.
Durch das TwinCAT System Manager Automation Interface ist es nun möglich, aus einer Visual Basic Applikation eine bestimmte Funktionalität des Kurvenscheibeneditors aufzurufen. Durch den direkten Zugriff auf die XML-Beschreibung der Kurvenscheibe lassen sich so von externen Applikationen die Werte einer Kurvenscheibe modifizieren und wieder online in die Echtzeit übertragen.

(ab TwinCAT V2.8 Build 735)

TwinCAT Hydraulik:

10 / 2002: Hydraulik-Ventil-Kennlinien zur Linearisierung des Übertragungsverhaltens nichtlinearer Systeme - TwinCAT Valve Diagram Editor

In TwinCAT werden jetzt auch hydraulische Achsen/Ventile direkt unterstützt. Durch grafische oder numerische Eingabe in den TwinCAT Valve Diagram Editor können Kennlinien interaktiv entworfen werden, die den physikalischen Zusammenhang von Ansteuersignal (z.B. Spannung) und resultierender Geschwindigkeit (in prozentualen oder absoluten Einheiten) beschreiben. Ebenfalls können aufgenommene Messwerttabellen importiert und grafisch angezeigt werden. Diese Messwerte dienen als Basis, um eine idealisierte Kennlinie zu entwerfen. Für die Glättung der Messwerte und Verrundung an den Übergangsstellen stehen effiziente mathematische Algorithmen zur Verfügung.
Im Online-Modus wird der aktuelle Arbeitspunkt auf der Kennlinie grafisch und numerisch dargestellt. Ferner stehen allgemeine Schnittstellen für den Import und Export der Daten zur Verfügung. Der TwinCAT Valve Diagram Editor ist integriert in den System Manager des TwinCAT.

Die erzeugten Kennlinien werden im TwinCAT System gespeichert und stehen nach einem Systemstart automatisch der NC zur Verfügung.

Einsatzbeispiel:
Schwerpunkt hydraulische Antriebe.

(ab TwinCAT V2.8 Build 735)

1. Quartal 2003: Hydraulik Regler (Ankündigung)

Ergänzend zu den Hydraulik Kennlinien wird im 3. Quartal 2002 ein sehr umfangreicher Hydraulikregler in TwinCAT realisiert werden. Diese beiden neuen Eigenschaften bilden eine 'starke Kombination' für zahlreiche Anwendungen im Hydraulikbereich, die bisher oftmals teure Hardwarelösungen erforderten.
Als weitere Zukunftsaussicht steht im kommenden Jahr der neue Beckhoff Feldbus zur Verfügung, der für einen Feldbus revolutionär kleine Abtastzeiten ermöglichen wird.

TwinCAT NCI:

06 / 2002: Hilfsachsen im Teileprogramm

Aus dem Teileprogramm können bis zu 5 Hilfsachsen angesprochen werden. Diese werden synchron mit der Bahn verfahren, d.h. sie starten gleichzeitig mit der Bahnbewegung und kommen auch gleichzeitig ins Ziel. Für den Fall, dass der Bahnweg 0 ist, wird eine virtuelle Bahn verwendet.

Einsatzbeispiele:

  • tangentiale Nachführung
    Ein Werkzeug muss z.B. immer orthogonal zur Bahn angestellt werden
  • Schwenken eines Werkzeugs

(ab TwinCAT V2.8 Build 725)

Beschreibung

07 / 2002: Satznummer des Teileprogramms kann ausgelesen werden

Die aktuelle Satznummer im Teileprogramm kann nun direkt ausgelesen werden. Der Rückgabewert beinhaltet die Satznummer, die sich z.Zt. der Anfrage in der Satzausführung (SAF) befindet.

Einsatzbeispiele:

  • Nach einem Abbruch des Teileprogramms, kann unter bestimmten Bedingungen einfach zum Segmentanfang wieder aufgesetzt werden
  • Für Debugzwecke kann die Satznummer, neben Achspositionen etc. mit dem TwinCAT Scope aufgezeichnet werden

(ab TwinCAT V2.8 Build 735)

Beschreibung

07 / 2002: Anzahl der Werkzeugdaten erhöht

Die Anzahl der möglichen Werkzeugdaten beträgt jetzt 255 (D1..D255).

(ab TwinCAT V2.8 Build 735)

Beschreibung

07 / 2002: G70/G71 Inch/Metrisch-Umschaltung

Das Maßsystem kann mit G70/G71 zwischen einer Bemaßung in Inch und Millimetern aus dem Teileprogramm umgeschaltet werden.

(ab TwinCAT V2.9 Build 803)

Beschreibung

10 / 2002: NCI-EStop

Mit dem NCI-EStop steht eine parametrierbare Stoppfunktion zur Verfügung. Dabei wird auf der Bahn angehalten und nach der Quittierung des Stopps kann das Teileprogramm an gleicher Stelle direkt fortgesetzt werden.

(ab TwinCAT V2.9 Build 905)

Beschreibung

10 / 2002: Funktionsbausteine zur Generierung eines Teileprogramms

Die TcNci.lib wurde um FB's zur einfacheren Generierung eines Teileprogramms erweitert. Damit wird z.B. das Teachen aus der SPS erleichtert werden. Es stehen dort FB's zur Verfügung, bei denen nur noch die Zielposition vorgegeben wird und daraus dann eine Zeile im NC-Teileprogramm generiert wird.

(voraussichtlich ab TwinCAT V2.9 Build 921, Beta bereits verfügbar)

Beschreibung

03 / 2003: Berechne Rotation eines Vektors im Teileprogramm

Mit dieser neuen Funktion ist es möglich direkt im Teileprogramm einen Vektor (3 Dimensional) um die momentan aktiven Rotationswinkel zu rotieren, bzw. zurück zudrehen.

(ab TwinCAT V2.9 Build 931)

Beschreibung

03 / 2003: Schreibe Werkzeugparameter aus dem Teileprogramm

Diese Funktion ermöglicht das Schreiben von Werkzeugparameter (z.B. Werkzeugradius) direkt aus dem Teileprogramm.

(ab TwinCAT V2.9 Build 932)

Beschreibung

03 / 2003: Verschleifen mit Hilfsachsen

Wenn sich der Koppelfaktor zwischen dem Bahnweg und dem Weg der Hilfsachse ändert, kann mit Hilfe eines Polynoms die Geschwindigkeit der Hilfsachse stetig in die neue Geschwindigkeit überführt werden. Dafür muss lediglich eine Toleranzkugel definiert werden, in der die Hilfsachse im Radius des Segmentübergangs von der optimalen Position abweichen darf.

(ab TwinCAT V2.9 Build 932)

Beschreibung (Glättung der Geschwindigkeit an Segmentübergängen)

07 / 2003: Lese verbleibende Bahnlänge

Diese Funktion ermöglicht es die noch zu verfahrende Bahnlänge bis zum nächsten Genauhalt (implizit oder explizit) auszulesen

(ab TwinCAT V2.9 Build 945)

Beschreibung (Verbleibende Bahnlänge)

07 / 2003 Zusätzliche Software-Endlagenüberwachung

Mit dieser Funktion werden die Verfahrsätze vor der eigentlichen Bewegung auf ihre Software-Endlagen überprüft.

(ab TwinCAT V2.9 Build 946)

Beschreibung (Globale Software-Endlagen der Bahn)

03 / 2005 Virtuelle Bewegungen überspringen

Der Befehl 'skip VirtualMovements' veranlasst das programmierte Bewegungen von nicht vorhandenen Achsen nicht ausgeführt werden

(ab TwinCAT V2.9 Build 1022)

Beschreibung (Überspringe virtuelle Bewegung)

03 / 2005 Zielpositionsüberwachung

Mit dieser Funktion wird aus dem NC-Programm die Überprüfung der Zielposiiton veranlasst.

(ab TwinCAT V2.9 Build 1026)

Beschreibung (Zielpositionsüberwachung)

06 / 2005 Schreibe einstellbare Nullpunktverschiebung aus dem Teileprogramm

Mit dem Befehl #set paramZeroShift kann die einstellbare Nullpunktverschiebung auch aus dem Teileprogramm parametriert werden

(ab TwinCAT V2.9 Build 1031)

Beschreibung

06 / 2005 Absetzen von Meldungen aus dem Teileprogramm

Mit dem Befehl MSG können Meldungen aus dem Teileprogramm abgesetzt werden.

(ab TwinCAT V2.9 Build 1031)

Beschreibung

06 / 2005 Erweiterung der Rotation

Nach einem ROT- bzw. AROT-Kommando kann optional auf die Programmierung des gesamten Bahnvektors verzichtet werden

(ab TwinCAT V2.9 Build 1031)

Beschreibung (Erweiterungen der Rotation)

06 / 2005 FBs zum Nullen der Werkzeugbeschreibungen und Nullpunktverschiebungen

Die TcNci.lib enthält neue Funktionsbausteine zum Nullen der Werkzeugbeschreibungen und Nullpunktverschiebungen

(ab TwinCAT V2.9 Build 1031)

Beschreibung

10 / 2005 Anzeige des Teileprogramms

Neben der bereits bekannten Methode zum Auslesen der aktuellen NC-Zeile, kann mit dieser neuen Funktion der aktuelle Dateiname und der File-Offset ausgelesen werden. Damit können dann beliebig viele NC-Zeilen zur Anzeige gebracht werden. Desweiteren gibt diese Methode im Fehlerfall eine Auskunft, in welcher Datei der Fehler aufgetreten ist.

(ab TwinCAT V2.10 Build 1243)

Beschreibung

10 / 2005 Mittelpunktskorrektur ein/aus

Mit der Mittelpunktsprogrammierung wird standardmäßig der Mittelpunkt des Kreises angepasst. Mit diesem Befehl, kann die Korrektur wahlweise ausgeschaltet werden.

(ab TwinCAT V2.10 Build 1243)

Beschreibung


Neuigkeiten im Bereich TwinCAT NC

TwinCAT Camming:

03 / 2006 Online Wechsel der Kurvenscheibe

TwinCAT NCI:

01 / 2006 | Neue Verschleifung für Geraden-Geraden-Übergänge
06 / 2006 | Zusätzliche Software-Endlagenüberwachung für Hilfsachsen
08 / 2006 | Anzeige und Auslesen von Technologiedaten
10 / 2006 | Zyklische Kanalinterface enthält die Kanal- und Gruppen-ID
01 / 2007 | Verhalten der Nullpunktverschiebungen und Werkzeugoffset unter G91 parametrierbar
01 / 2007 | Bezier-Verschleifung 3-ter und 5-ter Ordnung
02 / 2007 | Lineare Vorschubprogrammierung
10 / 2007 | TcPlcInterpolation-Library: Interpolationsbewegungen direkt aus der PLC absetzen
10 / 2007 | Konfigurierbares zyklisches Kanal-Interface
07 / 2008 | TcPlcInterpolation-Library: Neue Struktur für Nullpunktverschiebung und Rotation
08 / 2008 | Lesen von Werkzeugdaten aus dem Teileprogramm
09 / 2008 | Neuer Overridetyp
07 / 2009 | Neue Struktur für Bahndynamik

TwinCAT Camming:

03 / 2006: Online Wechsel der Kurvenscheibe

Bei einer bestehenden Tabellenkopplung kann eine Tabelle A direkt gegen eine andere Tabelle B online ausgetauscht werden. Dabei kann sowohl zwischen verschiedenen Interpolationsarten (Linear oder Spline) für Positionstabellen als auch zwischen Positionstabellen und Motion Function (MF) gewechselt werden. Die Regeln für den Wechsel werden durch den Aktivierungsmodus mit optionaler Aktivierungsposition festgelegt. Die neuen Werte für die Skalierung und den Offset von Master und Slave können entweder explizit parametriert werden oder werden intern in Abhängigkeit des Aktivierungsmodus vorbesetzt. Durch ein Flag in dem zyklischen Achs-Interface wird angezeigt, dass eine neue Tabelle zum Online Wechsel von Tabellen bereit steht. Nach Austausch und Aktivierung der neuen Tabelle wird dieses Flag automatisch zurückgesetzt.

(ab TwinCAT V2.10 Build ???)

TwinCAT NCI:

01 / 2006 Neue Verschleifung für Geraden-Geraden-Übergänge

Mit dem Befehl 'VertexSmoothing' stehen 2 neue Verschleifungsmethoden zur Verfügung. Es handelt sich dabei um eine Parabel- und Bi-quadratische-Verschleifung.

(ab TwinCAT V2.10 Build 1248)

Beschreibung

06 / 2006 Zusätzliche Software-Endlagenüberwachung für Hilfsachsen

Mit dieser Funktion werden die Verfahrsätze der Hilfsachsen vor der eigentlichen Bewegung auf ihre Software-Endlagen überprüft. Für die Bahnachsen ist diese Funktionalität schon in älteren Versionen verfügbar.

(ab TwinCAT V2.10 Build 1258)

Beschreibung

08 / 2006 Anzeige und Auslesen von Technologiedaten

Es handelt sich hierbei um eine Methode zum Auslesen von Technolgiedaten via ADS. Dazu zählen der aktuell wirkende G-Code, Nullpunktverschiebungen und Rotation. Diese Daten können z.B. zu Anzeigezwecken verwendet werden.

(ab TwinCAT V2.10 Build 1303)

Beschreibung

10 / 2006 Zyklische Kanalinterface enthält die Kanal- und Gruppen-ID

Das zyklische Kanal-Interface wurde um die Kanal- und Gruppen-ID erweitert. Dabei hat sich die Größe der Struktur nicht verändert. Auf diese Weise können die Funktionsbausteine für die Interpolation komfortabel genutzt werden, ohne dass zusätzliche Informationen über Kanal und Gruppen-Id benötigt werden.

(ab TwinCAT V2.10 Build 1305)

Beschreibung

01 / 2007 Verhalten der Nullpunktverschiebungen und Werkzeugoffset unter G91 parametrierbar

Standardmäßig wird mit der Nennung einer Achse die aktuelle Nullpunktverschiebung und der Werkzeugoffset herausgefahren. Mit den Funktionen 'ZeroShiftIncOff' und 'ToolOffsetIncOff' wird unter G91 nur die explizit programmierte Distanz ohne Verschiebungen herausgefahren.

(voraussichtlich ab TwinCAT V2.10 Build 1308)

Beschreibung

01 / 2007 Bezier-Verschleifung 3-ter und 5-ter Ordnung

Mit der Bezier-Verschleifung können sämtliche Geomtrieübergänge geschwindigkeits- und beschleunigunsstetig verschliffen werden. Damit kann ggf. auf eine Reduzierung der Bahngeschwindigkeit an Segmentübergängen verzichtet werden.

(voraussichtlich ab TwinCAT V2.10 Build 1308)

Beschreibung

02 / 2007 Lineare Vorschubprogrammierung

Standardmäßig wird mit der Programmierung einer Verfahrbewegung die Zielgeschwindigkeit so schnell wie möglich angefahren und diese dann solange wie möglich konstant gehalten. Mit dem Befehl 'FLIN' gibt es nun eine Möglichkeit, die Bahngeschwindigkeit linear über den Bahnweg zu ändern.

(voraussichtlich ab TwinCAT V2.10 Build 1308)

Beschreibung

10 / 2007 TcPlcInterpolation-Library: Interpolationsbewegungen direkt aus der PLC absetzen

Die TcPlcInterpolation-Library ermöglicht eine Interpolation direkt aus der SPS. Über eine Tabelle in der SPS werden verschiedene Verfahrbefehle (Gerade, Kreis, Bezier) und Hilfsfunktionen direkt an den NC-Kern übergeben. Damit ist die Verwendung von G-Code (DIN 66025) nicht mehr zwingend notwendig. Die Library ist für Pick & Place Aufgaben optimiert, bei denen oft erst zur Laufzeit die Zielposition bekannt wird.

(voraussichtlich ab TwinCAT V2.10 Build 1320)

Beschreibung

10 / 2007 Konfigurierbares zyklisches Kanal-Interface

Mit Hilfe der TcNci.lib können Variablen aus dem Gruppenstatus (z.B. Bahngeschwindigkeit, Bahnrestweg) in das zyklische Kanal-Interface eingeblendet werden.

(voraussichtlich ab TwinCAT V2.10 Build 1320)

Beschreibung

07 / 2008 TcPlcInterpolation-Library: Neue Struktur für Nullpunktverschiebung und Rotation

Die TcPlcInterpolation.lib wurde um eine Struktur erweitert, mit der eine Nullpunktverschiebung und Rotation beschrieben werden kann.

(voraussichtlich ab TwinCAT V2.10 Build 1329)

Beschreibung

08 / 2008 Lesen von Werkzeugdaten aus dem Teileprogramm

Das Kommando #get ToolParam(..)# ermöglicht eine Zuweisung von Werkzeugdaten im NC-Teileprogramm

(voraussichtlich ab TwinCAT V2.10 Build 1329)

Beschreibung

09 / 2008 Neuer Overridetyp

Der neue Overridetyp 'Reduced [0... >100%]' erlaubt einen Overridewert größer als 100%. Damit wird eine höhere Verfahrgeschwindigkeit ermöglicht, als die programmierte Bahngeschwindigkeit im G-Code.

(voraussichtlich ab TwinCAT V2.10 Build 1329)

Beschreibung

09 / 2008 Neue Struktur für Bahndynamik

Die TcPlcInterpolation.lib wurde um eine Struktur erweitert, mit der die Bahndynamik parametriert werden kann.

(voraussichtlich ab TwinCAT V2.10 Build 1341)

Beschreibung

TOP

Historie