TS5110 - TS5113 | TwinCAT Kinematic Transformation
Home


Vorwort

TS5110 - TS5113 | TwinCAT Kinematic Transformation
Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Installation

Installation
Installation
Das Kinematikpaket integriert sich transparent in die bestehende Motion Control Welt von TwinCAT: das einfache Einfügen eines zusätzlichen Kinematikkanals reicht aus. Die gesamte Parametrierung wird im TwinCAT System Manager vorgenommen. Das Paket unterstützt verschiedene parallele und serielle kinematische Systeme, wie sie z.B. in Pick-and-Place Aufgaben (Greifen und Absetzen) verwendet werden.
Das Supplement basiert auf TwinCAT NC I für die Interpolation von Bewegungen und G-Code (DIN 66025). Darüber hinaus können standardmäßige PTP- und Kurvenscheibenanwendungen realisiert werden. Die Programmierung basiert normalerweise auf dem kartesischen Koordinatensystem, wobei das Steuerungssystem die inverse Kinematik für die entsprechenden Motorpositionen berechnet. Das kinematische System kann im TwinCAT System Manager ausgewählt werden. Der Kinematikkanal wird für die Parametrierung des Typs (z.B. Delta) und die Stablängen und Versätze verwendet. Die Werte für Masse und Massenträgheit können für die dynamische Vorsteuerung angegeben werden. Die Funktionen „Fliegende Säge“ und „Kurvenscheibe“ ermöglichen z.B. die Synchronisation mit Förderbändern für das Greifen und Absetzen von Werkstücken.
Installationsanforderungen
Das Supplement TwinCAT Kinematic Transformation erfordert TwinCAT NCI-Level und mindestens die Version 2.11 R3. Sie läuft im Allgemeinen auf Windows XP/Vista/7 und CE Geräten.
Installation-Levels
TwinCAT Kinematic Transformation ist in 4 verschiedenen Levels unterteilt, in Abhängigkeit der Anzahl Transformationsachsen. Ein höheres Level beinhaltet alle Sub-Levels.
Level 1
Unterstützt die statische Transformation. Diese beinhaltet eine Translation und Rotation des Koordinatensystems.
Level 2
Unterstützt Level 1 und einfache (hauptsächlich 2D) kinematische Transformationen wie H-Bot und 2D-Parallelkinematik.
Level 3
Unterstützt Level 2 und komplexere (3D, 4D) kinematische Transformationen wie Delta-Roboter.
Level 4
Unterstützt Level 3 und komplexe kinematische Transformationen (bis zu 6D).


Konfiguration

Konfiguration
Konfiguration
Basierend auf PLCopen unterscheiden wir zwischen zwei Hauptkoordinatensystemen:
▪
Achskoordinatensystem (ACS, „Axis Coordinate System“)
Die Achsen des ACS sind mit dem realen Motor verbunden. Dieses Koordinatensystem stellt also die Positionierung des Motors dar, ohne dass der Tool Center Point (TCP) berücksichtigt wird.
▪
Maschinenkoordinatensystem (MCS, „Machine Coordinate System“)
Dieses ist standardmäßig ein kartesisches Koordinatensystem. Hier erfolgt im Allgemeinen die Programmierung von Bewegungen unter Verwendung der X-, Y- und Z-Achse. Die Rückwärtstransformation berechnet die Positionen für das Achskoordinatensystem. Die Achsen im Maschinenkoordinatensystem (MCS) sind reine Softwareachsen des Typs Simulationsencoder.
Alle ACS- und MCS-Achsen, die in einem kinematischen Transformationskanal verwendet werden, müssen im System Manager erzeugt werden. So hat z.B. ein Delta-Roboter 3 ACS-Achsen (M1...M3) und 3 MCS-Achsen (X, Y, Z).
Kinematischen Transformationskanal konfigurieren
1.
Alle Achsen (ACS und MCS) zur NC-Konfiguration im System Manager hinzufügen, genau wie PTP-Achsen.
AppendAxes
2.
Einen Kinematikkanal zur System Manager Konfiguration hinzufügen.
⇨
Durch das Hinzufügen eines Kanals wird eine Instanz einer Kinematikgruppe erzeugt.
3.
Den Kanaltyp auswählen: NC-Kanal (für Kinematic Transformation) um eine kinematische Transformation auszuführen.
4.
Die Objekte unter der Gruppe hinzufügen, die die kinematische Konfiguration des Benutzers darstellen.
5.
Nach TcNcKin.tmc im TwinCAT\IO-Ordner suchen.
6.
Zum Starten der Transformation für einen Delta-Roboter, wählen Sie z.B.
- Delta Typ 1
- Static-Trafo 6D (optionale MCS Verschiebung)
SelectKinObjects
7.
Die Transformationsgruppe muss wissen, welches Root-Modul aufzurufen ist. Deshalb muss die Objekt-ID der Kinematik (in diesem Fall Delta Type1) ausgewählt werden. Das Kinematik-Objekt definiert die Anzahl der in der SPS zu verwendenden ACS- und MCS-Achsen (siehe ST_KinAxes).
AssignTrafoToGroup
8.
Die Objektparameter entsprechend der verwendeten Kinematik parametrieren.
⇨
Wenn das erledigt ist, ist die System Manager Konfiguration abgeschlossen.
9.
Die Transformation kann jetzt von der SPS aus aktiviert werden (siehe SPS-Bibliothek). Zum Ansprechen der Transformation, ein zyklisches Kanalinterface in der SPS definieren und dieses mit den I/O des Kinematikkanals verknüpfen.
in_stKinToPlc AT %I* : NciChannelToPlc;
out_stPlcToKin AT %Q* : NciChannelFromPlc;


Unterstützte Transformationen

Unterstützte Transformationen
Unterstützte Transformationen
Übersicht
Transformationstyp | Schema | Erforderliches Level und Version
Statische Transformation (3D, 6D) |  | Level 1 Version 2.11.0 Build 3
H-Bot |  | Level 2 Version 2.11.0 Build 3
2D-Typ 1 |  | Level 2 Version 2.11.0 Build 3
2D-Typ 2 |  | Level 2 Version 2.11 Build 6
2D-Typ 3 |  | Level 2 Version 2.11 Build 6
2D-Kinematik Typ 6 (P XX) |  | Level 2
Delta Typ 1 |  | Level 3 Version 2.11.0 Build 3
Delta Typ 2 |  | Level 3
SCARA |  | Level 3
5D-Kinematik Typ 2 (XYZab) |  | Level 4
Zusätzliche Objekte
Objekttyp | Beschreibung | Erforderliches Level und Version
Statische Transformation (3D, 6D) | Beschreibt ein benutzerdefiniertes Koordinatensystem. | Level 1
Werkzeugversatz | Beschreibt ein Werkzeug auf Höhe des Kinematikflansches. | Level 1
Werkzeug Linear | Beschreibt ein am Kinematikflansch befestigtes 1D-Werkzeug, das die Möglichkeit bietet, den TCP in Richtung des Werkzeugs zu bewegen. | Level 1
Antriebsdrehmoment | Stellt die Trägheit und die Effizienz des Motors und des Getriebes dar, um das dynamische Modell genauer berechnen zu können. | Level 1
Weiterführende Informationen
•
Statische Transformation
•
H-Bot
•
2D-Kinematik Typ 1
•
2D-Kinematik Typ 2
•
2D-Kinematik Typ 3
•
Delta Typ 1
•
SCARA
•
5D-Kinematik Typ 2 (XYZab)
•
Antriebsdrehmoment
•
Werkzeugversatz
•
Werkzeug Linear


Statische Transformation

Unterstützte Transformationen [image] Statische Transformation
Statische Transformation
Die statische Transformation unterstützt eine Translation und eine Rotation. Durch Verwendung dieser Transformation besteht die Möglichkeit, ein Benutzerkoordinatensystem (UCS, „User Coordinate System“) zu definieren. Dieses Modul kümmert sich um die Transformation vom UCS zum Maschinenkoordinatensystem (MCS).
Die Parametrierung wird vom MCS zum UCS (Vorwärtstransformation) durchgeführt.
Zuerst muss die Translation beschrieben und anschließend die Rotation berechnet werden. Deswegen wird die in DIN 9300 beschriebene Roll-Nick-Gier-Regel verwendet. Die Berechnungssequenz für die Vorwärtstransformation ist Z, Y', X''.
Parameter | Beschreibung | Einheit
Translation X | Verschiebung in der X-Richtung vom MCS zum benutzerdefinierten Koordinatensystem. | mm
Translation Y | Verschiebung in der Y-Richtung vom MCS zum benutzerdefinierten Koordinatensystem. | mm
Translation Z | Verschiebung in der Z-Richtung vom MCS zum benutzerdefinierten Koordinatensystem. | mm
Rotation X | Rechtsdrehung um die X''-Achse in Grad | Grad
Rotation Y | Rechtsdrehung um die Y'-Achse in Grad | Grad
Rotation Z | Rechtsdrehung um die Z-Achse in Grad | Grad
Base Trafo OID | Im Falle einer kaskadierten statischen Transformation wird die Objekt-ID der Basistransformation an dieser Stelle parametriert. |


H-Bot

Unterstützte Transformationen [image] H-Bot
H-Bot
Der H-Bot ist wie oben im Schema gezeigt aufgebaut.
Die Motorachsen müssen in mm skaliert werden und entsprechen der Seillänge an jeder Seite des TCP. Für die Berechnung der Transformation reichen die relativen Seillängen. Die absoluten Seillängen sind nicht erforderlich.
Der Ursprungspunkt des Maschinenkoordinatensystem ist durch den Punkt definiert, für den die Positionen der beiden Motoren gleich null sind.
Parameter für die Kinematik
Parameter | Beschreibung | Einheit
MCS2WCS OID | Objekt-ID einer statischen Transformation, die die Position des MCS im Basiskoordinatensystem (normalerweise das Werkstückkoordinatensystem, WCS) definiert. |
Parameter für das dynamische Modell
Parameter | Beschreibung | Einheit
FirstDriveTorqueOID | Objekt-ID des ersten Antriebsdrehmoments Wenn die Motoren und Getriebe aller Motoren sich ähnlich verhalten, können alle Antriebsdrehmomente mithilfe einer OID dargestellt werden. Somit verweisen beide Parameter auf die gleiche Objekt-ID. |
SecondDriveTorqueOID | Objekt-ID des zweiten Antriebsdrehmoments |
GravityOrientationOID | Objekt-ID einer statischen Transformation, die die Montagerichtung beschreibt. Dieser Parameter wird dann verwendet, wenn der Greifer nicht zum Boden zeigt. Die Z-Achse der statischen Transformation definiert die Schwerkraftrichtung. Wenn der Roboter wie auf der Abbildung montiert ist, kann diese OID gleich null sein. |


2D-Kinematik Typ 1

Unterstützte Transformationen [image] 2D-Kinematik Typ 1
2D-Kinematik Typ 1
Die 2D-Kinematik Typ 1 ist wie oben im Schema gezeigt aufgebaut.
Alle Motorachsen sind in Grad skaliert und 0° ist wie im Schema gezeigt definiert, wobei der Pfeil die positive Richtung anzeigt.
Parameter für die Kinematik
Parameter | Beschreibung | Einheit
InnerArmLength | Länge von Drehpunkt zu Drehpunkt des inneren Arms. | mm
OuterArmLength | Länge von Drehpunkt zu Drehpunkt des äußeren Arms. | mm
Displacement | Länge vom Mittelpunkt der Grundplatte bis zu den virtuellen Drehachsen des inneren Arms. | mm
MCS2WCS OID | Objekt-ID einer statischen Transformation, die die Position des MCS im Basiskoordinatensystem (normalerweise das Werkstückkoordinatensystem, WCS) definiert. |
Parameter für das dynamische Modell
Parameter | Beschreibung | Einheit
InnerArmMass | Gesamtmasse des inneren Arms | kg
InnerArmMomentOfInertia | Trägheitsmoment des inneren Arms in Bezug zum Drehpunkt P1, der mit dem Motor verbunden ist. | kg mm^2
OuterArmMass | Masse des äußeren Arms. Die Gelenkmasse kann optional als eigener Parameter beschrieben werden. | kg
FirstLinkMass | Masse des Gelenks, das den inneren und äußeren Arm verbindet. Kann verwendet werden, wenn die Gelenkmasse nicht bereits in den äußeren und inneren Armen enthalten ist. Die Masse des Gelenks, das die Greiferplatte mit dem äußeren Arm verbindet, wird hier nicht spezifiziert. Diese kann der TcpMass hinzugefügt werden. Die Masse des ersten Gelenks bezieht sich auf den inneren Arm, der mit dem Motor 1 verbunden ist. | kg
SecondLinkMass | siehe FirstLinkMass Die Masse des zweiten Gelenks bezieht sich auf den inneren Arm, der mit dem Motor 2 verbunden ist. | kg
TcpMass | Masse des Tool Center Point, einschließlich Greiferplatte und Greifer. Die Nutzlast wird normalerweise mit Hilfe eines getrennten Parameters beschrieben. | kg
FirstDriveTorqueOID | Objekt-ID des ersten Antriebsdrehmoments Wenn die Motoren und Getriebe aller Motoren sich ähnlich verhalten, können alle Antriebsdrehmomente mithilfe einer OID dargestellt werden. Somit verweisen beide Parameter auf die gleiche Objekt-ID. |
SecondDriveTorqueOID | Objekt-ID des zweiten Antriebsdrehmoments |
GravityOrientationOID | Objekt-ID einer statischen Transformation, die die Montagerichtung beschreibt. Dieser Parameter wird dann verwendet, wenn der Greifer nicht zum Boden zeigt. Die Z-Achse der statischen Transformation definiert die Schwerkraftrichtung. Wenn der Roboter wie auf der Abbildung montiert ist, kann diese OID gleich null sein. |
Erforderliches Produkt-Level:
Level 2


2D-Kinematik Typ 2

Unterstützte Transformationen [image] 2D-Kinematik Typ 2
2D-Kinematik Typ 2
Die 2D-Kinematik Typ 2 ist wie oben im Schema gezeigt aufgebaut.
Alle Motorachsen sind in Grad skaliert und 0° ist wie im Schema gezeigt definiert, wobei der Pfeil die positive Richtung anzeigt.
Parameter für die Kinematik
Parameter | Beschreibung | Einheit
InnerArmLength | Länge von Drehpunkt zu Drehpunkt des inneren Arms. | mm
OuterArmLength | Länge von Drehpunkt zu Drehpunkt des äußeren Arms. | mm
Displacement | Länge vom Mittelpunkt der Grundplatte bis zu den virtuellen Drehachsen des inneren Arms. | mm
TcpLinkDistance | Distanz von Drehpunkt zu Drehpunkt des äußeren Arms. | mm
MCS2WCS OID | Objekt-ID einer statischen Transformation, die die Position des MCS im Basiskoordinatensystem (normalerweise das Werkstückkoordinatensystem, WCS) definiert. |
Parameter für das dynamische Modell
Parameter | Beschreibung | Einheit
InnerArmMass | Gesamtmasse des inneren Arms | kg
InnerArmMomentOfInertia | Trägheitsmoment des inneren Arms in Bezug zum Drehpunkt P1, der mit dem Motor verbunden ist. | kg mm^2
OuterArmMass | Masse des äußeren Arms. Die Gelenkmasse kann optional als eigener Parameter beschrieben werden. | kg
FirstLinkMass | Masse des Gelenks, das den inneren und äußeren Arm verbindet. Kann verwendet werden, wenn die Gelenkmasse nicht bereits in den äußeren und inneren Armen enthalten ist. Die Masse des Gelenks, das die Greiferplatte mit dem äußeren Arm verbindet, wird hier nicht spezifiziert. Diese kann der TcpMass hinzugefügt werden. Die Masse des ersten Gelenks bezieht sich auf den inneren Arm, der mit dem Motor 1 verbunden ist. | kg
SecondLinkMass | siehe FirstLinkMass Die Masse des zweiten Gelenks bezieht sich auf den inneren Arm, der mit dem Motor 2 verbunden ist. | kg
TcpMass | Masse des Tool Center Point, einschließlich Greiferplatte und Greifer. Die Nutzlast wird normalerweise mit Hilfe eines getrennten Parameters beschrieben. | kg
FirstDriveTorqueOID | Objekt-ID des ersten Antriebsdrehmoments Wenn die Motoren und Getriebe aller Motoren sich ähnlich verhalten, können alle Antriebsdrehmomente mithilfe einer OID dargestellt werden. Somit verweisen beide Parameter auf die gleiche Objekt-ID. |
SecondDriveTorqueOID | Objekt-ID des zweiten Antriebsdrehmoments |
GravityOrientationOID | Objekt-ID einer statischen Transformation, die die Montagerichtung beschreibt. Dieser Parameter wird dann verwendet, wenn der Greifer nicht zum Boden zeigt. Die Z-Achse der statischen Transformation definiert die Schwerkraftrichtung. Wenn der Roboter wie auf der Abbildung montiert ist, kann diese OID gleich null sein. |
Erforderliches Produkt-Level:
Level 2


2D-Kinematik Typ 3

Unterstützte Transformationen [image] 2D-Kinematik Typ 3
2D-Kinematik Typ 3
Die 2D-Kinematik Typ 3 ist wie oben im Schema gezeigt aufgebaut.
Alle Motorachsen sind in Grad skaliert und 0° ist wie im Schema gezeigt definiert, wobei der Pfeil die positive Richtung anzeigt.
Dieser Kinematiktyp ist als linkshändig implementiert. Die Wellen von Motor 1 und 2 befinden sich im Ursprung des Koordinatensystems.
Parameter für die Kinematik
Parameter | Beschreibung | Einheit
InnerArmLength | Länge von der Motorwelle zum Drehpunkt des äußeren Arms. | mm
OuterArmLength | Länge vom Drehpunkt zum Tool Center Point des äußeren Arms. | mm
MCS2WCS OID | Objekt-ID einer statischen Transformation, die die Position des MCS im Basiskoordinatensystem (normalerweise das Werkstückkoordinatensystem, WCS) definiert. |
Parameter für das dynamische Modell
Parameter | Beschreibung | Einheit
InnerArmMass | Gesamtmasse des inneren Arms | kg
OuterArmMass | Masse des äußeren Arms. | kg
ToolCenterpointMass | Masse des Tool Center Point, einschließlich Greiferplatte und Greifer. Die Nutzlast wird normalerweise mit Hilfe eines getrennten Parameters beschrieben. | kg
FirstDriveTorqueOID | Objekt-ID des ersten Antriebsdrehmoments Wenn die Motoren und Getriebe aller Motoren sich ähnlich verhalten, können alle Antriebsdrehmomente mithilfe einer OID dargestellt werden. Somit verweisen beide Parameter auf die gleiche Objekt-ID. |
SecondDriveTorqueOID | Objekt-ID des zweiten Antriebsdrehmoments |
GravityOrientationOID | Objekt-ID einer statischen Transformation, die die Montagerichtung beschreibt. Dieser Parameter wird dann verwendet, wenn der Greifer nicht zum Boden zeigt. Die Z-Achse der statischen Transformation definiert die Schwerkraftrichtung. Wenn der Roboter wie auf der Abbildung montiert ist, kann diese OID gleich null sein. |
Erforderliches Produkt-Level:
Level 2


Delta Typ 1

Unterstützte Transformationen [image] Delta Typ 1
Delta Typ 1
Grafik aus Delta Type 1 (Delta_Type1_2d_both_all.jpg)
Die Delta-Kinematik Typ 1 ist wie oben im Schema gezeigt aufgebaut. Die kinematische Transformation erwartet Kugelgelenke (oder Elemente mit gleichem Verhalten) in der Verbindung der Arme und mit der unteren Platte.
Der Zentrierstab für die Ausrichtung des Greifers kann optional parametriert werden.
Alle Motorachsen sind in Grad skaliert und 0° ist wie im Schema gezeigt definiert, wobei der Pfeil die positive Richtung anzeigt. Das gilt für alle 3 Motoren.
Parameter für die Kinematik
Parameter | Beschreibung | Einheit
InnerArmLength | Länge von Drehpunkt zu Drehpunkt des inneren Arms. Das ist der Arm, der direkt mit dem Motor verbunden ist. | mm
OuterArmLength | Länge von Drehpunkt zu Drehpunkt des äußeren Arms. | mm
Displacement | Länge vom Mittelpunkt der Grundplatte bis zu den virtuellen Drehachsen des inneren Arms. | mm
TcpDisplacement | Länge vom Mittelpunkt der Greiferplatte bis zu den virtuellen Drehachsen des äußeren Arms. | mm
MCS2WCS OID | Objekt-ID einer statischen Transformation, die die Position des MCS im Basiskoordinatensystem (normalerweise das Werkstückkoordinatensystem, WCS) definiert. |
Parameter für das dynamische Modell
Parameter | Beschreibung | Einheit
InnerArmMass | Gesamtmasse des inneren Arms | kg
InnerArmMomentOfInertia | Trägheitsmoment des inneren Arms in Bezug zum Drehpunkt P1, der mit dem Motor verbunden ist. | kg mm^2
OuterArmMass | Masse des äußeren Arms. Sind zwei Stäbe vorhanden, wird die Gesamtmasse benötigt. Die Gelenkmasse kann optional als eigener Parameter beschrieben werden. | kg
LinkMass | Masse des Gelenks, das den inneren und äußeren Arm verbindet. Kann verwendet werden, wenn die Gelenkmasse nicht bereits in den äußeren und inneren Armen enthalten ist. Die Masse des Gelenks, das die Greiferplatte mit dem äußeren Arm verbindet, wird hier nicht spezifiziert. Diese kann der TcpMass hinzugefügt werden. | kg
TcpMass | Masse des Tool Center Point, einschließlich Greiferplatte und Greifer. Die Nutzlast wird normalerweise mit Hilfe eines getrennten Parameters beschrieben. | kg
CenterStickMass | Gesamtmasse des Zentrierstabs | kg
CenterStickMomentOfInertia | Trägheitsmoment des Zentrierstabs in Bezug auf den Schwerpunkt (P2) | kg mm^2
CenterStickCenterOfMassDisplacement | Länge von Greiferplatte zum Schwerpunkt des Stabs. | mm
FirstDriveTorqueOID | Objekt-ID des ersten Antriebsdrehmoments Wenn die Motoren und Getriebe aller Motoren sich ähnlich verhalten, können alle Antriebsdrehmomente mithilfe einer OID dargestellt werden. Somit verweisen alle 3 Parameter auf die gleiche Objekt-ID. |
SecondDriveTorqueOID | Objekt-ID des zweiten Antriebsdrehmoments |
ThirdDriveTorqueOID | Objekt-ID des dritten Antriebsdrehmoments |
GravityOrientationOID | Objekt-ID einer statischen Transformation, die die Montagerichtung beschreibt. Dieser Parameter wird dann verwendet, wenn der Greifer nicht zum Boden zeigt. Die Z-Achse der statischen Transformation definiert die Schwerkraftrichtung. Wenn der Roboter wie auf der Abbildung montiert ist, kann diese OID gleich null sein. |
Erforderliches Produkt-Level:
Level 3


SCARA

Unterstützte Transformationen [image] SCARA
SCARA
Die SCARA-Kinematik („Selective Compliance Assembly Robot Arm“) ist wie im Schema oben aufgebaut.
Die Motorachsen 1, 2 und 4 sind in Grad skaliert, wobei die positive Drehrichtung in Pfeilrichtung ist. Die dritte Motorachse ist in mm skaliert.
Der Nullpunkt des MCS befindet sich im ersten Gelenk (M1). Die X-Achse wird vom SCARA Arm bestimmt, wenn alle Drehmotorachsen bei 0° stehen.
Parameter für die Kinematik
Parameter | Beschreibung | Einheit
Inner arm length | Länge von Drehpunkt zu Drehpunkt des inneren Arms. Dies ist der Arm auf der Nullpunktseite. | mm
Outer arm length | Länge von Drehpunkt zu Drehpunkt des äußeren Arms. Dies ist der Arm auf der TCP-Seite. | mm
Tool offset | Objekt-ID eines am Kinematikflansch befestigten Werkzeugs. |
MCS2WCS OID | Objekt-ID einer statischen Transformation, die die Position des MCS im Basiskoordinatensystem (normalerweise das Werkstückkoordinatensystem, WCS) definiert. |
Erforderliches Produkt-Level:
Level 3


5D-Kinematik Typ 2 (XYZab)

Unterstützte Transformationen [image] 5D-Kinematik Typ 2 (XYZab)
5D-Kinematik Typ 2 (XYZab)
Die 5D-Kinematik Typ 2 ist wie oben im Schema gezeigt aufgebaut.
Die Motoren 1 bis 3 (X, Y ,Z) sind in mm skaliert. Die Motoren 4 und 5 sind in Grad skaliert. 0° ist wie im Schema gezeigt definiert, wobei die positive Drehrichtung in Pfeilrichtung ist.
Parameter für die Kinematik
Parameter | Beschreibung | Einheit
D4 | Armlänge in X-Richtung von Motorachse 4 zur Motorachse 5 wie in Abbildung dargestellt. | mm
Offset 4 | Versatz in Y-Richtung zwischen Motorachse 4 und TCP | mm
Offset 5 | Versatz in X-Richtung zwischen Motorachse 5 und TCP | mm
Offset 6 | Versatz in Z-Richtung zwischen Motorachse 4 und Motorachse 5. | mm
Tool offset OID | Objekt-ID eines am Kinematikflansch befestigten Werkzeugs. |
MCS2WCS OID | Objekt-ID einer statischen Transformation, die die Position des MCS im Basiskoordinatensystem (normalerweise das Werkstückkoordinatensystem, WCS) definiert. |
Erforderliches Produkt-Level:
Level 4


Antriebsdrehmoment

Unterstützte Transformationen [image] Antriebsdrehmoment
Antriebsdrehmoment
Das Antriebsdrehmoment stellt die Trägheit und die Effizienz von Motor und Getriebe dar. Dieses wird für die genaue Berechnung des dynamischen Modells verwendet.
Parameter für den Antrieb
Parameter | Beschreibung | Einheit
Drive moment of inertia | Trägheitsmoment des Motorrotors | kg mm^2
Parameter für Getriebe
Parameter | Beschreibung | Einheit
Ratio | Getriebeübersetzung |
Gearbox moment of inertia | Trägheitsmoment vom Getriebe in Bezug auf den Antrieb | kg mm^2
Coulomb friction | Stellt den Bewegungsreibungskoeffizienten dar |
Stokes friction | Stellt den Anteil der proportional zur Geschwindigkeit ansteigenden Reibung dar |
Erforderliches Produkt-Level:
Level 1


Werkzeugversatz

Unterstützte Transformationen [image] Werkzeugversatz
Werkzeugversatz
Der Werkzeugversatz bietet dem Benutzer die Möglichkeit, ein Werkzeug mit der Kinematik zu verbinden.
Parameter | Beschreibung | Einheit
Extension X | X-Versatz des statischen Werkzeugs, das am Koordinatensystem des Flansches der übergeordneten Transformation befestigt ist. | mm
Extension Y | Y-Versatz des statischen Werkzeugs, das am Koordinatensystem des Flansches der übergeordneten Transformation befestigt ist. | mm
Extension Z | Z-Versatz des statischen Werkzeugs, das am Koordinatensystem des Flansches der übergeordneten Transformation befestigt ist. | mm


Werkzeug Linear

Unterstützte Transformationen [image] Werkzeug Linear
Werkzeug Linear
Beschreibt ein 1D-Werkzeug, das an der Kinematik befestigt ist. Mittels Verwendung einer zusätzlichen Simulationsachse besteht die Möglichkeit der Bewegung in Werkzeugrichtung. Das 1D-Werkzeug kann dazu verwendet werden, den TCP in einen bestimmten Abstand von einem Werkstück zu bewegen.
Wenn die Achsposition gleich 0 ist, dann befindet sich der TCP an der Position des Werkzeugversatzes.
Parameter | Beschreibung | Einheit
Tool offset | Länge des Werkzeugs | mm
Tool axis ID | Achs-ID der Simulationsachse. Beim Bewegen dieser Achse bewegt sich der TCP in Richtung des linearen Werkzeugs. |


SPS-Bibliothek

SPS-Bibliothek
SPS-Bibliothek
Funktionsbaustein | Beschreibung
Kinematic Tranformation
FB_ConfigKinGroup | Konfiguriert ACS- und MCS-Achsen entsprechend der kinematischen Transformationsgruppe und aktiviert den kartesischen Modus oder Gelenkmodus.
FB_ResetKinGroup | Setzt die kinematische Transformationsgruppe zurück
FB_CheckActualKinStatus | Liest azyklisch den Status der kinematischen Transformationsgruppe
F_GetKinChnOperationState | Liest zyklisch den Status der kinematischen Transformationsgruppe
F_GetAcsMcsAxisIds | Liest die aktiven ACS- und MCS-Achsen der Kinematikgruppe
Transformationsberechnung
FB_CalcTrafo | Berechnet die kinematische Transformation ohne Verbindung zu den Achsen
FB_CalcMultiTrafo | Berechnet die kinematische Transformation für mehrere Haltungen
Parameter und Koordinatensysteme online bearbeiten
FB_LockTrafoParam | Sperrt die Parameter der kinematischen Transformationsgruppe, verweigert Schreibzugriff
FB_UnlockTrafoParam | Entsperrt die Parameter der kinematischen Transformationsgruppe, erlaubt Schreibzugriff
Strukturen und Aufzählungen
Name | Beschreibung
ST_KinAxes | Struktur der ACS- und MCS-Achsen, die die Kinematik bilden
E_KINSTATUS | Status der Kinematikgruppe (Enum)
Entwicklungsumgebung | Zielsystem | Einzubindende SPS-Bibliotheken
TwinCAT v2.11.2000 | PC (i386) | TcNcKinematicTransformation.lib
Weiterführende Informationen
•
Funktionsbausteine
•
Funktionen
•
Datentypen


Funktionsbausteine

SPS-Bibliothek [image] Funktionsbausteine
Funktionsbausteine
Weiterführende Informationen
•
FB_ConfigKinGroup
•
FB_ResetKinGroup
•
FB_CheckActualKinStatus
•
FB_CalcTrafo
•
FB_UnlockTrafoParam
•
FB_LockTrafoParam


FB_ConfigKinGroup

SPS-Bibliothek [image] Funktionsbausteine [image] FB_ConfigKinGroup
FB_ConfigKinGroup
Der Funktionsbaustein FB_ConfigKinGroup konfiguriert Achsen entsprechend der kinematischen Transformation. Dies sind Achsen für das ACS (Achskoordinatensystem, Gelenk) und das MCS (Maschinenkoordinatensystem, kartesisch). Der Funktionsbaustein nimmt die in der stAxesList definierten ACS- und MCS-Achsen und konfiguriert diese in der Kinematikgruppe von stKinRefIn.
VAR_INPUT
VAR_INPUT
bExecute : BOOL;
bCartesianMode : BOOL;
END_VAR
bExecute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
bCartesianMode: Wenn FALSE, dann können die ACS-Achsen (Achskoordinatensystem, Gelenk) direkt bewegt werden. Wenn TRUE, dann wird die in den MCS-Achsen (kartesisch) beschriebene Bewegung in eine Bewegung der ACS-Achsen (Gelenk) transformiert. Die ACS-Achsen können nicht direkt bewegt werden.
VAR_IN_OUT
VAR_IN_OUT
stAxesList : ST_KinAxes;
stKinRefIn : NciChannelToPlc;
END_VAR
stAxesList: Bestimmt die ACS- und MCS-Achsen, die in der Konfiguration enthalten sind. Siehe ST_KinAxes.
stKinRefIn: Bestimmt die Kinematikgruppe der Konfiguration. Siehe NciChannelToPlc.
VAR_OUTPUT
VAR_OUTPUT
bBusy : BOOL;
bDone : BOOL;
bError : BOOL;
nErrorId : UDINT;
END_VAR
bBusy: Der Ausgang wird TRUE, wenn der Befehl mit bExecute gestartet ist und bleibt es dann so lange, wie der Funktionsbaustein den Befehl ausführt. Während bBusy gleich TRUE ist, wird an den Eingängen kein neuer Befehl angenommen. Wenn bBusy wieder FALSE wird, ist der Funktionsbaustein bereit für einen neuen Befehl. Gleichzeitig wird einer der Ausgänge bDone oder bError gesetzt.
bDone: Der Ausgang wird TRUE, wenn der Befehl erfolgreich ausgeführt wurde.
bError: Der Ausgang bError wird auf TRUE gesetzt, wenn bei der Ausführung des Befehls ein Fehler aufgetreten ist.
nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Der Fehlercode kann in der ADS Fehlerdokumentation oder in der NC Fehlerdokumentation (Fehlercodes ab 0x4000) nachgeschlagen werden.
Beispiel
VAR
io_X : AXIS_REF;
io_Y : AXIS_REF;
io_Z : AXIS_REF;
io_M1 : AXIS_REF;
io_M2 : AXIS_REF;
io_M3 : AXIS_REF;
out_stPlcToKin AT %Q* : NciChannelFromPlc;
out_stPlcToItp AT %Q* : NciChannelFromPlc;
fbConfigKinGroup : FB_ConfigKinGroup;
stAxesConfig : ST_KinAxes;
bAllAxesReady : BOOL;
bExecuteConfigKinGroup: BOOL;
bUserConfigKinGroup : BOOL;
bUserCartesianMode : BOOL; := TRUE;
(*true: cartesian mode - false: direct mode (without transformation) *)
END_VAR
(* read the IDs from the cyclic axis interface so the axes can mapped later to the kinematic group *)
stAxesConfig.nAxisIdsAcs[1] := io_M1.NcToPlc.AxisId;
stAxesConfig.nAxisIdsAcs[2] := io_M2.NcToPlc.AxisId;
stAxesConfig.nAxisIdsAcs[3] := io_M3.NcToPlc.AxisId;
stAxesConfig.nAxisIdsMcs[1] := io_X.NcToPlc.AxisId;
stAxesConfig.nAxisIdsMcs[2] := io_Y.NcToPlc.AxisId;
stAxesConfig.nAxisIdsMcs[3] := io_Z.NcToPlc.AxisId;

IF bAllAxesReady AND bUserConfigKinGroup THEN
bExecuteConfigKinGroup := TRUE;
ELSE
bExecuteConfigKinGroup := FALSE;
END_IF

fbConfigKinGroup(
bExecute := bExecuteConfigKinGroup ,
bCartesianMode := bUserCartesianMode ,
stAxesList := stAxesConfig,
stKinRefIn := in_stKinToPlc );
Zustand der Kinematikgruppe
Hinweis
Konfiguration freigeben
Die ACS-Achsen müssen freigegeben sein, damit der Zustand den Wert KinStatus_Ready erreichen kann. Wenn die ACS-Achsen nicht freigegeben sind, geben Sie die Achsen frei und rufen dann FB_ConfigKinGroup oder FB_ResetKinGroup auf.


FB_ResetKinGroup

SPS-Bibliothek [image] Funktionsbausteine [image] FB_ResetKinGroup
FB_ResetKinGroup
Der Funktionsbaustein FB_ResetKinGroup setzt die Kinematikgruppe zurück. Alle ACS- und MCS-Achsen werden zurückgesetzt. Des Weiteren kann der Eingang nItpChannelId für die Festlegung des zugehörigen Interpolationskanals verwendet werden. Der Kanal wird zurückgesetzt, wenn die nItpChannelId ungleich 0 ist.
Wenn alle Achsen freigegeben sind und die Gruppe sich im kartesischen Modus befand, dann kehrt die Gruppe zurück zum Zustand KinStatus_Ready. Befand sich die Gruppe nicht im kartesischen Modus, dann kehrt die Gruppe zum Zustand KinStatus_Empty zurück. Wenn die Achsen nicht freigegeben sind, dann verbleibt die Gruppe im Zustand KinStatus_Empty.
VAR_INPUT
VAR_INPUT
bExecute : BOOL;
nItpChannelId : UDINT;
END_VAR
bExecute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
nItpChannelId: ID des zugehörigen Interpolationskanals. Wenn Eingang ungleich 0 ist, dann wird der zugehörige Interpolationskanal zurückgesetzt.
VAR_IN_OUT
VAR_IN_OUT
stAxesList : ST_KinAxes;
stKinRefIn : NciChannelToPlc;
END_VAR
stAxesList: Bestimmt die ACS- und MCS-Achsen, die in der Konfiguration enthalten sind. Siehe ST_KinAxes.
stKinRefIn: Bestimmt die Kinematikgruppe der Konfiguration. Siehe NciChannelToPlc.
VAR_OUTPUT
VAR_OUTPUT
bBusy : BOOL;
bDone : BOOL;
bError : BOOL;
nErrorId : UDINT;
END_VAR
bBusy: Der Ausgang wird TRUE, wenn der Befehl mit bExecute gestartet ist und bleibt es dann so lange, wie der Funktionsbaustein den Befehl ausführt. Während bBusy gleich TRUE ist, wird an den Eingängen kein neuer Befehl angenommen. Wenn bBusy wieder FALSE wird, ist der Funktionsbaustein bereit für einen neuen Befehl. Gleichzeitig wird einer der Ausgänge bDone oder bError gesetzt.
bDone: Der Ausgang wird TRUE, wenn der Befehl erfolgreich ausgeführt wurde.
bError: Der Ausgang bError wird auf TRUE gesetzt, wenn bei der Ausführung des Befehls ein Fehler aufgetreten ist.
nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Der Fehlercode kann in der ADS Fehlerdokumentation oder in der NC Fehlerdokumentation (Fehlercodes ab 0x4000) nachgeschlagen werden.
Beispiel
VAR
fbFB_ResetKinGroup : FB_ResetKinGroup;
stAxesConfig : stAxesConfig;
in_stKinToPlc AT %I* : NciChannelToPlc;
END_VAR
fbFB_ResetKinGroup(
bExecute := TRUE,
nItpChannelId := 3,
stKinRefIn := in_stKinToPlc,
stAxesList := stAxesConfig,
bBusy=> ,
bDone=> ,
bError=> ,
nErrorId=> );
Zustand der Kinematikgruppe


FB_CheckActualKinStatus

SPS-Bibliothek [image] Funktionsbausteine [image] FB_CheckActualKinStatus
FB_CheckActualKinStatus
Der Funktionsbaustein FB_CheckActualKinStatus gibt den Status des Kinematikkanals zurück.
Hinweis
Zyklischer Erhalt des Status des Kinematikkanals
Dieser Funktionsbaustein benötigt mehr als einen SPS-Zyklus, um den Status des Kinematikkanals zu lesen. Um ihn für jeden Zyklus zu erhalten, benutzen Sie F_GetKinChnOperationState.
VAR_INPUT
VAR_INPUT
bExecute : BOOL;
END_VAR
bExecute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
VAR_IN_OUT
VAR_IN_OUT
stAxesList : ST_KinAxes;
stKinRefIn : NciChannelToPlc;
END_VAR
stAxesList: Bestimmt die ACS- und MCS-Achsen, die in der Konfiguration enthalten sind. Siehe ST_KinAxes.
stKinRefIn: Bestimmt die Kinematikgruppe der Konfiguration. Siehe NciChannelToPlc.
VAR_OUTPUT
VAR_OUTPUT
eKinStatus : E_KINSTATUS;
bBusy : BOOL;
bDone : BOOL;
bError : BOOL;
nErrorId : UDINT;
END_VAR
eKinStatus: Gibt den Status des Kinematikkanals zurück. Siehe E_KINSTATUS.
bBusy: Der Ausgang wird TRUE, wenn der Befehl mit bExecute gestartet ist und bleibt es dann so lange, wie der Funktionsbaustein den Befehl ausführt. Während bBusy gleich TRUE ist, wird an den Eingängen kein neuer Befehl angenommen. Wenn bBusy wieder FALSE wird, ist der Funktionsbaustein bereit für einen neuen Befehl. Gleichzeitig wird einer der Ausgänge bDone oder bError gesetzt.
bDone: Der Ausgang wird TRUE, wenn der Befehl erfolgreich ausgeführt wurde.
bError: Der Ausgang bError wird auf TRUE gesetzt, wenn bei der Ausführung des Befehls ein Fehler aufgetreten ist.
nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Der Fehlercode kann in der ADS Fehlerdokumentation oder in der NC Fehlerdokumentation (Fehlercodes ab 0x4000) nachgeschlagen werden.
Beispiel
VAR
fbFB_CheckActualKinStatus : FB_CheckActualKinStatus;
in_stKinToPlc AT %I* : NciChannelToPlc;
stAxesConfig : ST_KinAxes;
eKinStatus : E_KINSTATUS;
END_VAR
fbFB_CheckActualKinStatus(
bExecute := TRUE,
stAxesListReference := stAxesConfig,
stKinRefI := in_stKinToPlc,
eKinStatus => eKinStatus );
Zustand der Kinematikgruppe


FB_CalcTrafo

SPS-Bibliothek [image] Funktionsbausteine [image] FB_CalcTrafo
FB_CalcTrafo
Der Funktionsbaustein FB_CalcTrafo berechnet die Vorwärts- oder Rückwärtstransformation, selbst dann, wenn keine Kinematikgruppe mit FB_ConfigKinGroup erstellt wurde.
VAR_INPUT
VAR_INPUT
bExecute : BOOL;
bForward : BOOL;
oidTrafo : UDINT;
END_VAR
bExecute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
bForward: Bestimmt, ob die Vorwärts- oder Rückwärtstransformation berechnet wird.
oidTrafo: Objekt-ID des zu berechnenden kinematischen Transformationsobjekts. Siehe Beispiel unten.
VAR_IN_OUT
VAR_IN_OUT
stAxesPosIn : ARRAY[1..8] OF LREAL;
stAxesPosOut : ARRAY[1..8] OF LREAL;
END_VAR
stAxesPosIn: Array, das die Eingangspositionen der Transformation enthält. Bei der Berechnung einer Vorwärtstransformation stellen diese die Gelenkpositionen dar. Bei der Berechnung einer Rückwärtstransformation stellen diese die kartesischen Achspositionen dar.
stAxesPosOut: Array, das die Ergebnispositionen der Transformation enthält. Im Falle der Berechnung einer Vorwärtstransformation stellen diese die kartesischen Achspositionen dar. Im Falle der Berechnung einer Rückwärtstransformation stellen diese die Gelenkpositionen dar.
VAR_OUTPUT
VAR_OUTPUT
bBusy : BOOL;
bDone : BOOL;
bError : BOOL;
nErrorId : UDINT;
END_VAR
bBusy: Der Ausgang wird TRUE, wenn der Befehl mit bExecute gestartet ist und bleibt es dann so lange, wie der Funktionsbaustein den Befehl ausführt. Während bBusy gleich TRUE ist, wird an den Eingängen kein neuer Befehl angenommen. Wenn bBusy wieder FALSE wird, ist der Funktionsbaustein bereit für einen neuen Befehl. Gleichzeitig wird einer der Ausgänge bDone oder bError gesetzt.
bDone: Der Ausgang wird TRUE, wenn der Befehl erfolgreich ausgeführt wurde.
bError: Der Ausgang bError wird auf TRUE gesetzt, wenn bei der Ausführung des Befehls ein Fehler aufgetreten ist.
nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Der Fehlercode kann in der ADS Fehlerdokumentation oder in der NC Fehlerdokumentation (Fehlercodes ab 0x4000) nachgeschlagen werden.
Beispiel
Die SCARA-Transformation hat 4 ACS (Gelenk) Achsen und 4 MCS (kartesische) Achsen.
SCARA-Transformation - Beispielkonfiguration
SCARA-Transformation - Beispiel-Objekt-ID
VAR
fbFB_CalcTrafo : FB_CalcTrafo;
stAxesPosIn : ARRAY[1..8] OF LREAL;
stAxesPosOut : ARRAY[1..8] OF LREAL;
bUserExecute : BOOL;
bUserCalcFwdTrafo : BOOL;
END_VAR
fbFB_CalcTrafo(
bExecute := bUserExecute,
bForward := bUserCalcFwdTrafo,
oidTrafo := 16#01010072,
stAxesPosIn := stAxesPosIn,
stAxesPosOut := stAxesPosOut,
bBusy=> ,
bDone=> ,
bError=> ,
nErrorId=> );


FB_UnlockTrafoParam

SPS-Bibliothek [image] Funktionsbausteine [image] FB_UnlockTrafoParam
FB_UnlockTrafoParam
Der Funktionsbaustein FB_UnlockTrafoParam entsperrt die Transformationsparameter, so dass diese geschrieben werden können.
Nach der Freigabe können die Kinematikparameter von der SPS mit ADSWRITE geschrieben werden. Die erforderliche Indexgruppe ist die Objekt-ID und der Indexoffset ist die Parameter-ID. Die geschriebenen Parameter sind nicht persistent.
VORSICHT
Das Verändern der Parameter kann zu Diskontinuitäten führen.
Beachten Sie, dass dies mit größter Vorsicht zu benutzen ist. Die Neufestlegung von Kinematikparametern kann zu Diskontinuitäten in der Kinematikkette führen.
VAR_INPUT
VAR_INPUT
bExecute : BOOL;
oidTrafo : UDINT;
END_VAR
bExecute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
oidTrafo: Objekt-ID des kinematischen Transformationsobjekts. Siehe Beispiel unten.
VAR_OUTPUT
VAR_OUTPUT
bBusy : BOOL;
bDone : BOOL;
bError : BOOL;
nErrorId : UDINT;
END_VAR
bBusy: Der Ausgang wird TRUE, wenn der Befehl mit bExecute gestartet ist und bleibt es dann so lange, wie der Funktionsbaustein den Befehl ausführt. Während bBusy gleich TRUE ist, wird an den Eingängen kein neuer Befehl angenommen. Wenn bBusy wieder FALSE wird, ist der Funktionsbaustein bereit für einen neuen Befehl. Gleichzeitig wird einer der Ausgänge bDone oder bError gesetzt.
bDone: Der Ausgang wird TRUE, wenn der Befehl erfolgreich ausgeführt wurde.
bError: Der Ausgang bError wird auf TRUE gesetzt, wenn bei der Ausführung des Befehls ein Fehler aufgetreten ist.
nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Der Fehlercode kann in der ADS Fehlerdokumentation oder in der NC Fehlerdokumentation (Fehlercodes ab 0x4000) nachgeschlagen werden.
Beispiel
Die für die Freigabe eines Transformationsparameters und für das Schreiben eines entsprechenden neuen Wertes benötigten Objekt-ID und Parameter-ID können aus dem Transformationsobjekt im System Manager gelesen werden.
VAR
bUserExecuteUnlock : BOOL;
fbFB_UnlockTrafoParam : FB_UnlockTrafoParam;
bUserExecuteWriteParam : BOOL;
fbADSWRITE : ADSWRITE;
oidTrafo : UDINT := 16#010100B0; (*Trafo object id*)
pidTrafo : UDINT := 16#05010020; (*parameter id*)
fParamValue : LREAL;
END_VAR
fbFB_UnlockTrafoParam(
bExecute := bUserExecuteUnlock,
oidTrafo := oidTrafo,
bBusy=>,
bDone=>,
bError=>,
nErrorId=> );

(*After unlocking new parameter value can be written*)
fbADSWRITE(
NETID:='' ,
PORT:= AMSPORT_R0_NCSAF,
IDXGRP:=oidTrafo ,
IDXOFFS:= pidTrafo,
LEN:=SIZEOF(fParamValue) ,
SRCADDR:= ADR(fParamValue),
WRITE:=bUserExecuteWriteParam ,
TMOUT:= ,
BUSY=> ,
ERR=> ,
ERRID=> );


FB_LockTrafoParam

SPS-Bibliothek [image] Funktionsbausteine [image] FB_LockTrafoParam
FB_LockTrafoParam
Nachdem die Transformationsparameter mit Hilfe von FB_UnlockTrafoParam verändert wurden, sperrt der Funktionsbaustein FB_LockTrafoParam erneut die Transformationsparameter, so dass diese nicht mehr beschrieben werden können.
VAR_INPUT
VAR_INPUT
bExecute : BOOL;
oidTrafo : UDINT;
END_VAR
bExecute: Der Befehl wird durch eine steigende Flanke an diesem Eingang ausgelöst.
oidTrafo: Objekt-ID des kinematischen Transformationsobjekts. Siehe Beispiel unten.
VAR_OUTPUT
VAR_OUTPUT
bBusy : BOOL;
bDone : BOOL;
bError : BOOL;
nErrorId : UDINT;
END_VAR
bBusy: Der Ausgang wird TRUE, wenn der Befehl mit bExecute gestartet ist und bleibt es dann so lange, wie der Funktionsbaustein den Befehl ausführt. Während bBusy gleich TRUE ist, wird an den Eingängen kein neuer Befehl angenommen. Wenn bBusy wieder FALSE wird, ist der Funktionsbaustein bereit für einen neuen Befehl. Gleichzeitig wird einer der Ausgänge bDone oder bError gesetzt.
bDone: Der Ausgang wird TRUE, wenn der Befehl erfolgreich ausgeführt wurde.
bError: Der Ausgang bError wird auf TRUE gesetzt, wenn bei der Ausführung des Befehls ein Fehler aufgetreten ist.
nErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Der Fehlercode kann in der ADS Fehlerdokumentation oder in der NC Fehlerdokumentation (Fehlercodes ab 0x4000) nachgeschlagen werden.
Beispiel
SCARA-Transformation - Beispiel-Objekt-ID
VAR
bUserExecute : BOOL;
fbFB_LockTrafoParam : FB_LockTrafoParam;
oidTrafo : UDINT := 16#010100B0; (*Trafo object id*)
END_VAR
fbFB_LockTrafoParam(
bExecute := bUserExecute,
oidTrafo := oidTrafo,
bBusy=>,
bDone=>,
bError=>,
nErrorId=> );


Funktionen

SPS-Bibliothek [image] Funktionen
Funktionen
Weiterführende Informationen
•
F_GetKinChnOperationState
•
F_GetAcsMcsAxisIds


F_GetKinChnOperationState

SPS-Bibliothek [image] Funktionen [image] F_GetKinChnOperationState
F_GetKinChnOperationState
Diese Funktion gibt den Betriebszustand des Kinematikkanals zurück.
Function F_GetKinChnOperationState : E_KINSTATUS
VAR_IN_OUT
stKinRefIn : NciChannelToPlc
END_VAR
stKinRefIn: Bestimmt die Kinematikgruppe der Konfiguration. NciChannelToPlc bestätigen
Rückgabewert
E_KINSTATUS: Zustand des Kinematikkanals (siehe unten). Wenn eine ungültige Version des zyklischen Interface verwendet wird, wird KinStatus_InvalidItfVersion zurückgegeben.
Beispiel
VAR
stKinRefIn AT %I* : NciChannelToPlc;
nErrId : UDINT;
eKinOperationState : E_KINSTATUS;
END_VAR
IF F_GetKinChnOperationState(stKinRefIn)<> KinStatus_InvalidItfVersion THEN
eKinOperationState := F_GetKinChnOperationState(stKinRefIn);
ELSE
nErrId := F_GetKinChnOperationState(stKinRefIn);
END_IF
Anforderungen
Diese Funktion ist gültig ab Version 6 des zyklischen Interface. Wenn die Versionsnummer kleiner ist, wird KinStatus_InvalidItfVersion (bestätige E_KINSTATUS) zurückgegeben.


F_GetAcsMcsAxisIds

SPS-Bibliothek [image] Funktionen [image] F_GetAcsMcsAxisIds
F_GetAcsMcsAxisIds
Diese Funktion liest die konfigurierten ACS- und MCS-Achsen des zyklischen Interface. Die IDs werden in stAxesList geschrieben.
FUNCTION F_GetAcsMcsAxisIds : UDINT
VAR_IN_OUT
stAxesList : ST_KinAxes;
stKinRefIn : NciChannelToPlc;
END_VAR
stAxesList: Liste der Achs-IDs für das Achskoordinatensystem (ACS) und das Maschinenkoordinatensystem (MCS).
stKinRefIn: Die Struktur des zyklischen Kanalinterface vom Kinematikkanal zur SPS. Auf diese Struktur wird nur lesend zugegriffen.
Rückgabewert
UDINT: Fehlercode. Diese Funktion ist gültig ab Version 6 des zyklischen Interface. Wenn die Version korrekt ist, wird 0 zurückgegeben, ansonsten ein Fehlercode.
Beispiel
VAR
stAxesList : ST_KinAxes;
stKinRefIn AT %I* : NciChannelToPlc;
nErrId : UDINT;
END_VAR
nErrId := F_GetAcsMcsAxisIds(stAxesList, stKinRefIn);
IF nErrId=0 THEN
;(*Axes List is valid*)
END_IF
Anforderungen
Diese Funktion ist gültig ab Version 6 des zyklischen Interface. Wenn die Versionsnummer kleiner ist, wird KinStatus_InvalidItfVersion (bestätige E_KINSTATUS) zurückgegeben.


Datentypen

SPS-Bibliothek [image] Datentypen
Datentypen
Weiterführende Informationen
•
ST_KinAxes
•
E_KINSTATUS


ST_KinAxes

SPS-Bibliothek [image] Datentypen [image] ST_KinAxes
ST_KinAxes
Diese Struktur definiert die Achsen, die eine Kinematik bilden.
TYPE ST_KinAxes :
STRUCT
nAxisIdsMcs: ARRAY[1..8] OF DWORD;
nAxisIdsAcs: ARRAY[1..8] OF DWORD;
END_STRUCT
END_TYPE
nAxisIdsMcs: Liste der Achs-IDs der Achsen, die das Maschinenkoordinatensystem bilden. Normalerweise beinhalten die ersten drei Array-Elemente die kartesischen Achsen (X,Y,Z) und die folgenden Array-Elemente die Rotationsachsen.
nAxisIdsAcs: Liste der Achs-IDs der Achsen, die das Achskoordinatensystem bilden.
Beispiel
VAR
stAxesConfig : ST_KinAxes;
io_X : AXIS_REF;
io_Y : AXIS_REF;
io_Z : AXIS_REF;
io_M1 : AXIS_REF;
io_M2 : AXIS_REF;
io_M3 : AXIS_REF;
END_VAR
(* read the IDs from the cyclic axis interface so the axes can mapped later to the kinematic group *)
stAxesConfig.nAxisIdsAcs[1] := io_M1.NcToPlc.AxisId;
stAxesConfig.nAxisIdsAcs[2] := io_M2.NcToPlc.AxisId;
stAxesConfig.nAxisIdsAcs[3] := io_M3.NcToPlc.AxisId;
stAxesConfig.nAxisIdsMcs[1] := io_X.NcToPlc.AxisId;
stAxesConfig.nAxisIdsMcs[2] := io_Y.NcToPlc.AxisId;
stAxesConfig.nAxisIdsMcs[3] := io_Z.NcToPlc.AxisId;


E_KINSTATUS

SPS-Bibliothek [image] Datentypen [image] E_KINSTATUS
E_KINSTATUS
Diese Aufzählung definiert den Zustand der Kinematikgruppe.
TYPE E_KINSTATUS :
(
KinStatus_Error,
KinStatus_Empty,
KinStatus_Unknown,
KinStatus_StartPending,
KinStatus_Ready,
KinStatus_InvalidItfVersion := 16#4000
);
END_TYPE
KinStatus_Empty: ACS-Achsen können bewegt werden. Keine Transformation aktiviert.
KinStatus_Ready: MCS-Achsen können bewegt werden. Transformation aktiv.
KinStatus_InvalidItfVersion: Eine Funktion oder Funktionsbaustein wird nicht von dieser Version des zyklischen Kanalinterface unterstützt. Um die Funktion verwenden zu können, muss eine Aktualisierung vorgenommen werden.
Hinweis
Konfiguration freigeben
Die ACS-Achsen müssen freigegeben sein, damit der Zustand den Wert KinStatus_Ready erreichen kann.


Fehlercodes

Fehlercodes
Fehlercodes
Weiterführende Informationen
•
ADS Return Codes
•
Übersicht NC-Fehler


ADS Return Codes

Fehlercodes [image] ADS Return Codes
ADS Return Codes
Fehlercode: 0x000..., 0x500..., 0x700..., 0x1000......
Globale Fehlercodes
Hex | Dec | Beschreibung
0x0 | 0 | Kein Fehler
0x1 | 1 | Interner Fehler
0x2 | 2 | Keine Echtzeit
0x3 | 3 | Zuweisung gesperrt-Speicherfehler
0x4 | 4 | Postfach voll
0x5 | 5 | Falsches HMSG
0x6 | 6 | Ziel-Port nicht gefunden
0x7 | 7 | Zielrechner nicht gefunden
0x8 | 8 | Unbekannte Befehl-ID
0x9 | 9 | Ungültige Task-ID
0xA | 10 | Kein IO
0xB | 11 | Unbekannter ADS-Befehl
0xC | 12 | Win32 Fehler
0xD | 13 | Port nicht angeschlossen
0xE | 14 | Ungültige ADS-Länge
0xF | 15 | Ungültige AMS Net ID
0x10 | 16 | niedrige Installationsebene
0x11 | 17 | Kein Debugging verfügbar
0x12 | 18 | Port deaktiviert
0x13 | 19 | Port bereits verbunden
0x14 | 20 | ADS Sync Win32 Fehler
0x15 | 21 | ADS Sync Timeout
0x16 | 22 | ADS Sync AMS Fehler
0x17 | 23 | Keine Index-Map für ADS Sync vorhanden
0x18 | 24 | Ungültiger ADS-Port
0x19 | 25 | Kein Speicher
0x1A | 26 | TCP Sendefehler
0x1B | 27 | Host nicht erreichbar
0x1C | 28 | Ungültiges AMS Fragment
Router Fehlercodes
Hex | Dec | Name | Beschreibung
0x500 | 1280 | ROUTERERR_NOLOCKEDMEMORY | Lockierter Speicher kann nicht zugewiesen werden.
0x501 | 1281 | ROUTERERR_RESIZEMEMORY | Die Größe des Routerspeichers konnte nicht geändert werden.
0x502 | 1282 | ROUTERERR_MAILBOXFULL | Das Postfach hat die maximale Anzahl der möglichen Meldungen erreicht. Die aktuell gesendete Nachricht wurde abgewiesen.
0x503 | 1283 | ROUTERERR_DEBUGBOXFULL | Das Postfach hat die maximale Anzahl der möglichen Meldungen erreicht. Die gesendete Nachricht wird nicht im ADS Monitor angezeigt.
0x504 | 1284 | ROUTERERR_UNKNOWNPORTTYPE | Der Porttyp ist unbekannt.
0x505 | 1285 | ROUTERERR_NOTINITIALIZED | Router ist nicht initialisiert.
0x506 | 1286 | ROUTERERR_PORTALREADYINUSE | Die gewünschte Portnummer ist bereits vergeben.
0x507 | 1287 | ROUTERERR_NOTREGISTERED | Der Port ist nicht registriert.
0x508 | 1288 | ROUTERERR_NOMOREQUEUES | Die maximale Anzahl von Ports ist erreicht.
0x509 | 1289 | ROUTERERR_INVALIDPORT | Der Port ist ungültig.
0x50A | 1290 | ROUTERERR_NOTACTIVATED | Der Router ist nicht aktiv.
Allgemeine ADS Fehlercodes
Hex | Dec | Name | Beschreibung
0x700 | 1792 | ADSERR_DEVICE_ERROR | Gerätefehler
0x701 | 1793 | ADSERR_DEVICE_SRVNOTSUPP | Service wird vom Server nicht unterstützt
0x702 | 1794 | ADSERR_DEVICE_INVALIDGRP | Ungültige Index-Gruppe
0x703 | 1795 | ADSERR_DEVICE_INVALIDOFFSET | Ungültiger Index-Offset
0x704 | 1796 | ADSERR_DEVICE_INVALIDACCESS | Lesen und schreiben nicht gestattet.
0x705 | 1797 | ADSERR_DEVICE_INVALIDSIZE | Parametergröße nicht korrekt
0x706 | 1798 | ADSERR_DEVICE_INVALIDDATA | Ungültige Parameter-Werte
0x707 | 1799 | ADSERR_DEVICE_NOTREADY | Gerät ist nicht betriebsbereit
0x708 | 1800 | ADSERR_DEVICE_BUSY | Gerät ist beschäftigt
0x709 | 1801 | ADSERR_DEVICE_INVALIDCONTEXT | Ungültiger Kontext (muss in Windows sein)
0x70A | 1802 | ADSERR_DEVICE_NOMEMORY | Nicht genügend Speicher
0x70B | 1803 | ADSERR_DEVICE_INVALIDPARM | Ungültige Parameter-Werte
0x70C | 1804 | ADSERR_DEVICE_NOTFOUND | Nicht gefunden (Dateien,...)
0x70D | 1805 | ADSERR_DEVICE_SYNTAX | Syntax-Fehler in Datei oder Befehl
0x70E | 1806 | ADSERR_DEVICE_INCOMPATIBLE | Objekte stimmen nicht überein
0x70F | 1807 | ADSERR_DEVICE_EXISTS | Objekt ist bereits vorhanden
0x710 | 1808 | ADSERR_DEVICE_SYMBOLNOTFOUND | Symbol nicht gefunden
0x711 | 1809 | ADSERR_DEVICE_SYMBOLVERSIONINVALID | Symbol-Version ungültig
0x712 | 1810 | ADSERR_DEVICE_INVALIDSTATE | Gerät im ungültigen Zustand
0x713 | 1811 | ADSERR_DEVICE_TRANSMODENOTSUPP | AdsTransMode nicht unterstützt
0x714 | 1812 | ADSERR_DEVICE_NOTIFYHNDINVALID | Notification Handle ist ungültig
0x715 | 1813 | ADSERR_DEVICE_CLIENTUNKNOWN | Notification-Client nicht registriert
0x716 | 1814 | ADSERR_DEVICE_NOMOREHDLS | Keine weitere Notification Handle
0x717 | 1815 | ADSERR_DEVICE_INVALIDWATCHSIZE | Größe der Notification zu groß
0x718 | 1816 | ADSERR_DEVICE_NOTINIT | Gerät nicht initialisiert
0x719 | 1817 | ADSERR_DEVICE_TIMEOUT | Gerät hat einen Timeout
0x71A | 1818 | ADSERR_DEVICE_NOINTERFACE | Interface Abfrage fehlgeschlagen
0x71B | 1819 | ADSERR_DEVICE_INVALIDINTERFACE | Falsches Interface angefordert
0x71C | 1820 | ADSERR_DEVICE_INVALIDCLSID | Class-ID ist ungültig
0x71D | 1821 | ADSERR_DEVICE_INVALIDOBJID | Object-ID ist ungültig
0x71E | 1822 | ADSERR_DEVICE_PENDING | Anforderung steht aus
0x71F | 1823 | ADSERR_DEVICE_ABORTED | Anforderung wird abgebrochen
0x720 | 1824 | ADSERR_DEVICE_WARNING | Signal-Warnung
0x721 | 1825 | ADSERR_DEVICE_INVALIDARRAYIDX | Ungültiger Array-Index
0x722 | 1826 | ADSERR_DEVICE_SYMBOLNOTACTIVE | Symbol nicht aktiv
0x723 | 1827 | ADSERR_DEVICE_ACCESSDENIED | Zugriff verweigert
0x724 | 1828 | ADSERR_DEVICE_LICENSENOTFOUND | Fehlende Lizenz
0x725 | 1829 | ADSERR_DEVICE_LICENSEEXPIRED | Lizenz abgelaufen
0x726 | 1830 | ADSERR_DEVICE_LICENSEEXCEEDED | Lizenz überschritten
0x727 | 1831 | ADSERR_DEVICE_LICENSEINVALID | Lizenz ungültig
0x728 | 1832 | ADSERR_DEVICE_LICENSESYSTEMID | Lizenz der System-ID ungültig
0x729 | 1833 | ADSERR_DEVICE_LICENSENOTIMELIMIT | Lizenz nicht zeitlich begrenzt
0x72A | 1834 | ADSERR_DEVICE_LICENSEFUTUREISSUE | Lizenzproblem: Zeitpunkt in der Zukunft
0x72B | 1835 | ADSERR_DEVICE_LICENSETIMETOLONG | Lizenz-Zeitraum zu lang
0x72c | 1836 | ADSERR_DEVICE_EXCEPTION | Exception beim Systemstart
0x72D | 1837 | ADSERR_DEVICE_LICENSEDUPLICATED | Lizenz-Datei zweimal gelesen
0x72E | 1838 | ADSERR_DEVICE_SIGNATUREINVALID | Ungültige Signatur
0x72F | 1839 | ADSERR_DEVICE_CERTIFICATEINVALID | öffentliches Zertifikat
0x740 | 1856 | ADSERR_CLIENT_ERROR | Clientfehler
0x741 | 1857 | ADSERR_CLIENT_INVALIDPARM | Dienst enthält einen ungültigen Parameter
0x742 | 1858 | ADSERR_CLIENT_LISTEMPTY | Polling-Liste ist leer
0x743 | 1859 | ADSERR_CLIENT_VARUSED | Var-Verbindung bereits im Einsatz
0x744 | 1860 | ADSERR_CLIENT_DUPLINVOKEID | Die aufgerufene ID ist bereits in Benutzung
0x745 | 1861 | ADSERR_CLIENT_SYNCTIMEOUT | Timeout ist aufgetreten
0x746 | 1862 | ADSERR_CLIENT_W32ERROR | Fehler im Win32 Subsystem
0x747 | 1863 | ADSERR_CLIENT_TIMEOUTINVALID | Ungültiger Client Timeout-Wert
0x748 | 1864 | ADSERR_CLIENT_PORTNOTOPEN | ADS-Port nicht geöffnet
0x750 | 1872 | ADSERR_CLIENT_NOAMSADDR | Interner Fehler in Ads-Sync
0x751 | 1873 | ADSERR_CLIENT_SYNCINTERNAL | Hash-Tabelle-Überlauf
0x752 | 1874 | ADSERR_CLIENT_ADDHASH | Schlüssel nicht gefunden im Hash
0x753 | 1875 | ADSERR_CLIENT_REMOVEHASH | Keine weitere Symbole im Cache
0x754 | 1876 | ADSERR_CLIENT_NOMORESYM | Ungültige Antwort empfangen
0x755 | 1877 | ADSERR_CLIENT_SYNCRESINVALID | Sync Port ist gesperrt
RTime Fehlercodes
Hex | Dec | Name | Beschreibung
0x1000 | 4096 | RTERR_INTERNAL | Interner Fehler im TwinCAT Echtzeit-System.
0x1001 | 4097 | RTERR_BADTIMERPERIODS | Timer-Wert ist nicht gültig.
0x1002 | 4098 | RTERR_INVALIDTASKPTR | Task-Pointer hat den ungültigen Wert 0 (null).
0x1003 | 4099 | RTERR_INVALIDSTACKPTR | Task Stackpointer hat den ungültigen Wert 0.
0x1004 | 4100 | RTERR_PRIOEXISTS | Die Request Task Priority ist bereits vergeben.
0x1005 | 4101 | RTERR_NOMORETCB | Kein freies TCB (Task Control Block) zur Verfügung. Maximale Anzahl von TCBs beträgt 64.
0x1006 | 4102 | RTERR_NOMORESEMAS | Keine freien Semaphoren zur Verfügung. Maximale Anzahl der Semaphoren beträgt 64.
0x1007 | 4103 | RTERR_NOMOREQUEUES | Kein freier Platz in der Warteschlange zur Verfügung. Maximale Anzahl der Plätze in der Warteschlange beträgt 64.
0x100D | 4109 | RTERR_EXTIRQALREADYDEF | Ein externer Synchronisations-Interrupt wird bereits angewandt.
0x100E | 4110 | RTERR_EXTIRQNOTDEF | Kein externer Synchronisations-Interrupt angewandt.
0x100F | 4111 | RTERR_EXTIRQINSTALLFAILED | Anwendung des externen Synchronisierungs- Interrupts ist fehlgeschlagen
0x1010 | 4112 | RTERR_IRQLNOTLESSOREQUAL | Aufruf einer Service-Funktion im falschen Kontext
0x1017 | 4119 | RTERR_VMXNOTSUPPORTED | Intel VT-x Erweiterung wird nicht unterstützt.
0x1018 | 4120 | RTERR_VMXDISABLED | Intel VT-x Erweiterung ist nicht aktiviert im BIOS.
0x1019 | 4121 | RTERR_VMXCONTROLSMISSING | Fehlende Funktion in Intel VT-x Erweiterung.
0x101A | 4122 | RTERR_VMXENABLEFAILS | Aktivieren von Intel VT-x schlägt fehl.
TCP Winsock-Fehlercodes
Hex | Dec | Name | Beschreibung
0x274c | 10060 | WSAETIMEDOUT | Verbindungs Timeout aufgetreten. Fehler beim Herstellen der Verbindung, da die Gegenstelle nach einer bestimmten Zeitspanne nicht ordnungsgemäß reagiert hat, oder die hergestellte Verbindung konnte nicht aufrecht erhalten werden, da der verbundene Host nicht reagiert hat.
0x274d | 10061 | WSAECONNREFUSED | Verbindung abgelehnt. Es konnte keine Verbindung hergestellt werden, da der Zielcomputer dies explizit abgelehnt hat. Dieser Fehler resultiert normalerweise aus dem Versuch, eine Verbindung mit einem Dienst herzustellen, der auf dem fremden Host inaktiv ist—das heißt, einem Dienst, für den keine Serveranwendung ausgeführt wird.
0x2751 | 10065 | WSAEHOSTUNREACH | Keine Route zum Host Ein Socketvorgang bezog sich auf einen nicht verfügbaren Host.
 |  |  | Weitere Winsock-Fehlercodes: Win32-Fehlercodes


Übersicht NC-Fehler

Fehlercodes [image] Übersicht NC-Fehler
Übersicht NC-Fehler
Fehlercode ( Hex ) | Beschreibung
0x4000 – 0x4FFF: NC Fehlercodebereich
0x40nn | Allgemeine Fehler
0x41nn | Kanalfehler
0x42nn | Gruppenfehler
0x43nn | Achsfehler
0x44nn | Geberfehler
0x45nn | Reglerfehler
0x46nn | Antriebfehler
0x4Ann | Tabellenfehler
0x4Bnn | NC-SPS-Fehler
0x4Cnn | Kinematik Transformation
0x8000 – 0x8FFF: Erweiterter NC Fehlercodebereich
0x81nn – 0x811F | Bode Plot (Diagnose)
0x8120 – 0x8FFF | Weitere Fehler
Weiterführende Informationen
•
Allgemeine Fehler
•
Kanalfehler
•
Gruppenfehler
•
Achsfehler
•
Geberfehler
•
Reglerfehler
•
Antriebfehler
•
Tabellenfehler
•
NC-SPS-Fehler
•
Kinematische Transformation
•
Bode Return Codes
•
Weitere Fehler


Allgemeine Fehler

Fehlercodes [image] Übersicht NC-Fehler [image] Allgemeine Fehler
Allgemeine Fehler
Fehler(Hex) | Fehler(Dez) | Fehlertyp | Beschreibung
4000 | 16384 | Intern | „Interner Fehler“ Interner Systemfehler der NC auf Ring 0, nicht näher spezifizierbar.
4001 | 16385 | Speicher | „Speicher-Fehler“ Die Ring-0-Speicherverwaltung stellt benötigten Speicher nicht bereit. In der Regel ist dies die Folge anderer Fehler und die Steuerung wird (spätestens jetzt) den regulären Betrieb einstellen.
4002 | 16386 | Intern | „Nc-Retain-Daten-Fehler (Daten-Persistenz)“ Beim Laden der Nc Retain Daten ist ein Fehler aufgetreten, so dass die betroffenen Achsen nicht mehr referenziert sind (Status-Bit „Homed" ist FALSE). Dieser Fehler kann folgende Gründe haben: - es wurden keine Nc Retain Daten gefunden - es wurden nur alte Nc Retain Daten gefunden (alter Backup Datensatz) - die Nc Retain Daten sind korrupt oder inkonsistent
4010 | 16400 | Parameter | „Kanal-Identifier unzulässig“ Es ist entweder ein unzulässiger Wert (nicht 1...255) verwendet worden oder es ist ein Kanal genannt, der im System nicht existiert.
4011 | 16401 | Parameter | „Gruppen-Identifier unzulässig“ Es ist entweder ein unzulässiger Wert (nicht 1...255) verwendet worden oder es ist eine Gruppe genannt, der im System nicht existiert.
4012 | 16402 | Parameter | „Achsen-Identifier unzulässig“ Es ist entweder ein unzulässiger Wert (nicht 1...255) verwendet worden oder es ist eine Achse genannt, der im System nicht existiert.
4013 | 16403 | Parameter | „Geber-Identifier unzulässig“ Es ist entweder ein unzulässiger Wert (nicht 1...255) verwendet worden oder es ist ein Geber genannt, der im System nicht existiert.
4014 | 16404 | Parameter | „Regler-Identifier unzulässig“ Es ist entweder ein unzulässiger Wert (nicht 1...255) verwendet worden oder es ist ein Regler genannt, der im System nicht existiert.
4015 | 16405 | Parameter | „Antriebs-Identifier unzulässig“ Es ist entweder ein unzulässiger Wert (nicht 1...255) verwendet worden oder es ist ein Antrieb genannt, der im System nicht existiert.
4016 | 16406 | Parameter | „Tabellen-Identifier unzulässig“ Es ist entweder ein unzulässiger Wert (nicht 1...255) verwendet worden oder es ist eine Tabelle genannt, der im System nicht existiert.
4020 | 16416 | Intern | „Fehlendes Prozessabbild“ Kein SPS-Achsen-Interface beim Erzeugen einer Achse
4021 | 16417 | Intern | „Fehlendes Prozessabbild“ Kein Achsen- SPS-Interface beim Erzeugen einer Achse
4022 | 16418 | Intern | „Fehlendes Prozessabbild“ Kein Geber-IO-Interface beim Erzeugen einer Achse
4023 | 16419 | Intern | „Fehlendes Prozessabbild“ Kein IO-Geber-Interface beim Erzeugen einer Achse
4024 | 16420 | Intern | „Fehlendes Prozessabbild“ Kein Antrieb-IO-Interface beim Erzeugen einer Achse
4025 | 16421 | Intern | „Fehlendes Prozessabbild“ Kein IO-Antrieb-Interface beim Erzeugen einer Achse
4030 | 16432 | Intern | „Koppeltyp unzulässig“ Unzulässiger Master/Slave-Koppeltyp
4031 | 16433 | Intern | „Achstyp unzulässig“ Unzulässige Typangabe bei der Achserzeugung
4040 | 16448 | Intern | „Achse ist inkompatibel“ Achse ist für den vorgesehenen Zweck nicht geeignet. Zum Beispiel kann eine Eil/Schleich-Achse nicht die Rolle des Slaves in einer Achs-Kopplung übernehmen.
4050 | 16464 | Intern | „Kanal nicht betriebsbereit“ Der Kanal ist unvollständig und somit nicht betriebsbereit. In der Regel ist dies eine Folge von Problemen beim System-Start.
4051 | 16465 | Intern | „Gruppe nicht betriebsbereit“ Die Gruppe ist unvollständig und somit nicht betriebsbereit. In der Regel ist dies eine Folge von Problemen beim System-Start.
4052 | 16466 | Intern | „Achse nicht betriebsbereit“ Die Achse ist unvollständig und somit nicht betriebsbereit. In der Regel ist dies eine Folge von Problemen beim System-Start.
4060 | 16480 | Intern | „Kanal existiert“ Der zu erzeugende Kanal existiert bereits.
4061 | 16481 | Intern | „Gruppe existiert“ Die zu erzeugende Gruppe existiert bereits.
4062 | 16482 | Intern | „Achse existiert“ Die zu erzeugende Achse existiert bereits.
4063 | 16483 | Intern | „Tabelle existiert“ Die zu erzeugende Tabelle existiert bereits bzw. es wird intern versucht eine schon verwendete Tabelle-ID zu benutzen (z.B. für die Universelle Fliegende Säge).
4070 | 16496 | Intern | „Achsen-Index unzulässig“ Der für eine Achse angegebene Platz innerhalb des Kanals ist unzulässig.
4071 | 16497 | Intern | „Achsen-Index unzulässig“ Der für eine Achse angegebene Platz innerhalb der Gruppe ist unzulässig.


Kanalfehler

Fehlercodes [image] Übersicht NC-Fehler [image] Kanalfehler
Kanalfehler
Fehler(Hex) | Fehler(Dez) | Fehlertyp | Beschreibung
4101 | 16641 | Parameter | „Gruppen-Index unzulässig“ Der für eine Gruppe angegebene Platz innerhalb des Kanals ist unzulässig.
4102 | 16642 | Adresse | „Null-Zeiger“ Der Zeiger auf die Gruppe ist ungültig. In der Regel ist dies eine Folge eines Fehlers beim System-Start.
4103 | 16643 | Intern | „Fehlendes Prozess-Abbild“ Es ist kein Datenaustausch mit der SPS möglich. Mögliche Ursachen: n Der Kanal besitzt kein Interface (kein Interpreter vorhanden) n Die Verbindung zur SPS ist gestört
4104 | 16644 | Parameter | „M-Funktionsindex unzulässig“ Unzulässige M-Funktion (nicht 0...159) in der Ausführungsebene erkannt.
4105 | 16645 | Speicher | „Kein Speicher“ Es steht kein System-Speicher mehr zur Verfügung. In der Regel ist dies eine Folge anderer Fehler.
4106 | 16646 | Funktion | „Nicht bereit“ Die Funktion ist zur Zeit nicht verfügbar, weil bereits eine gleichartige Funktion in Bearbeitung ist. In der Regel ist dies eine Folge von Zugriffs-Konflikten: Mehr als eine Instanz will Befehle an den Kanal geben. Dies kann z.B. die Folge eines nicht korrekten SPS-Programms sein.
4107 | 16647 | Funktion | „Funktion/Kommando nicht unterstützt“ Eine angeforderte Funktion bzw. ein angefordertes Kommando wird vom Kanal nicht unterstützt.
4108 | 16648 | Parameter | „Unzulässiger Parameter beim Aufstarten“ Beim Aufstarten des Kanals (TwinCAT-Start), werden unzulässige Parameter verwendet. Typischerweise handelt es sich dabei um eine unzulässige Speichergröße des Kanals oder einen unzulässigen Kanaltyp.
4109 | 16649 | Funktion | „Kanal-Funktion (Kommando) nicht ausführbar“ Eine Kanalfunktion wie z.B. Interpreter Start, ist abgelehnt worden, da der Kanal entweder bereits aktiv ist, kein Programm geladen oder aber sich in einem Fehlerzustand befindet.
410A | 16650 | Funktion | "ItpGoAhead nicht ausführbar" Das Kommando ist nicht ausführbar, da der Interpreter nicht auf einem Dekodierstopp steht
4110 | 16656 | Parameter | „Fehler beim Öffnen einer Datei“ Die angegebene Datei ist nicht vorhanden. Beispiel: NC-Programm unbekannt.
4111 | 16657 | NC-Programmierung | „Syntax-Fehler beim Laden“ Die NC hat beim Laden eines NC-Programms einen Syntax-Fehler festgestellt.
4112 | 16658 | NC-Programmierung | „Syntax-Fehler beim Interpretieren“ Die NC hat beim Abarbeiten eines NC-Programms einen Syntax-Fehler festgestellt.
4113 | 16659 | NC-Programmierung | „Fehlendes Unterprogramm“ Die NC hat beim Laden ein fehlendes Unterprogramm festgestellt.
4114 | 16660 | Speicher | „Ladepuffer des Interpreters zu klein“ Die Ladepuffergröße des Interpreters ist überschritten worden.
4115 | 16661 | Intern | „Symbolik“ - reserviert
4116 | 16662 | Intern | „Symbolik“ - reserviert
4117 | 16663 | NC-Programmierung | „Unterprogramm nicht vollständig“ Kopf des Unterprogramms fehlt
4118 | 16664 | NC-Programmierung | „Fehler beim Laden des NC-Programms“ Die maximale Anzahl der ladbaren NC-Programme ist erreicht. Mögliche Ursache: Aus einem Hauptprogramm wurden zu viele Unterprogramme geladen.
4119 | 16665 | NC-Programmierung | „Fehler beim Laden des NC-Programms“ Der verwendete Programmname ist zu lang.
4120 | 16672 | NC-Programmierung | „Divide by Zero“ Die NC hat beim Abarbeiten einen Rechen-Fehler festgestellt: Teilen durch 0.
4121 | 16673 | NC-Programmierung | „Unzulässige Kreis-Parametrierung“ Die NC hat beim Abarbeiten einen Rechen-fehler festgestellt: Der angegebene Kreis ist nicht rechenbar.
4122 | 16674 | NC-Programmierung | „Unzulässige FPU-Operation“ Die NC hat beim Abarbeiten eine ungültige FPU-Operation festgestellt. Dieser Fehler tritt z.B. bei der Berechnung der Wurzel einer negativen Zahl auf
4130 | 16688 | NC-Programmierung | „Stack-Überlauf: Unterprogramme“ Die NC hat beim Abarbeiten einen Stack-Überlauf festgestellt: Zu viele Unterprogramm-Ebenen.
4131 | 16689 | NC-Programmierung | „Stack-Unterlauf: Unterprogramme“ Die NC hat beim Abarbeiten einen Stack-Unterlauf festgestellt: Zu viele Unterprogramm-Rückkehrbefehle. Hinweis: Ein Hauptprogramm darf nicht mit einem Rückkehrbefehle beendet werden.
4132 | 16690 | NC-Programmierung | „Stack-Überlauf: Rechenwerk“ Die NC hat beim Abarbeiten einen Stack-Überlauf festgestellt: Die Berechnung ist zu komplex oder ist nicht korrekt geschrieben.
4133 | 16691 | NC-Programmierung | „Stack-Unterlauf: Rechenwerk“ Die NC hat beim Abarbeiten einen Stack-Unterlauf festgestellt: Die Berechnung ist zu komplex oder ist nicht korrekt geschrieben.
4140 | 16704 | Parameter | „Register-Index unzulässig“ Die NC hat beim Abarbeiten einen unzulässigen Register-Index festgestellt: Das Programm enthält eine unzulässige Angabe (nicht R0...R999) oder ein Zeiger-Register enthält einen nicht zulässigen Wert.
4141 | 16705 | NC-Programmierung | „G-Funktions-Index unzulässig“ Die NC hat beim Abarbeiten eine unzulässige G-Funktion festgestellt (nicht 0...159).
4142 | 16706 | NC-Programmierung | „M-Funktions-Index unzulässig“ Die NC hat beim Abarbeiten eine unzulässige M-Funktion festgestellt (nicht 0...159).
4143 | 16707 | NC-Programmierung | „Erweiterte Adress-Angabe unzulässig“ Die NC hat beim Abarbeiten eine unzulässige erweiterte Adresse festgestellt (nicht 1...9).
4144 | 16708 | NC-Programmierung | „Index der internen H-Funktion unzulässig“ Die NC hat beim Abarbeiten eine unzulässige interne H-Funktion festgestellt. Dies ist in der Regel eine Folge eines Fehlers beim Laden.
4145 | 16709 | Parameter | „Wert für die Maschinendaten unzulässig“ Die NC hat beim Abarbeiten eine unzulässigen Wert für die Maschinendaten (MDB) festgestellt (nicht 0...7).
4150 | 16720 | Parameter | "Parameter für die Werkzeugkorrektur können hier nicht geändert werden" Die NC hat beim Abarbeiten einen unzulässigen Parameterwechsel für die Werkzeugkorrektur festgestellt. Dies kann z.B. ein veränderter Werkzeugradius sein, während ein Kreis programmiert wurde.
4151 | 16721 | Parameter | "Werkzeugkorrektur kann nicht berechnet werden" Die NC hat bei der Berechnung der Werkzeugkorrektur einen Fehler festgestellt.
4152 | 16722 | NC-Programmierung | Werkzeugkorrektur: Die Ebene für die Werkzeugkorrektur kann an dieser Stelle nicht geändert werden. Der Fehler tritt z.B. dann auf, wenn bei der Anwahl oder bei aktiver Werkzeugradiuskorrektur die Ebene geändert wird.
4153 | 16723 | NC-Programmierung | Werkzeugkorrektur: Bei der Anwahl der Werkzeugkorrektur wurde kein bzw. ein nicht gültiges D-Wort programmiert.
4154 | 16724 | NC-Programmierung | Werkzeugkorrektur: Der spezifizierte Werkzeugradius ist nicht zugelassen, da kleiner Null.
4155 | 16725 | NC-Programmierung | Werkzeugkorrektur: Der Werkzeugradius kann hier nicht geändert werden
4156 | 16726 | Intern | Werkzeugkorrektur: Collision Detection Table ist voll.
4157 | 16727 | Intern | Werkzeugkorrektur: Interner Fehler beim Einschalten der Flaschenhalserkennung
4158 | 16728 | Intern | Werkzeugkorrektur: Interner Fehler bei der Flaschenhalserkennung: Update Reversed Geo failed.
4159 | 16729 | NC-Programmierung | Werkzeugkorrektur: Unerwartete Kombination von Geometrietypen bei eingeschalteter Flaschenhalserkennung
415A | 16730 | NC-Programmierung | Werkzeugkorrektur: Programmierter Innenkreis ist kleiner als der Fräserradius
415B | 16731 | NC-Programmierung | Werkzeugkorrektur: Flaschenhalserkennung hat eine Konturverletzung erkannt
415C | 16732 | Speicher | Tabelle für korrigierte Einträge ist voll
415D | 16733 | Speicher | Eingangstabelle für die tangentiale Nachführung ist voll
415E | 16734 | Speicher | Ausführungstabelle für die tangentiale Nachführung ist voll
415F | 16735 | Intern | Geometrie für tangentiale Nachführung kann nicht berechnet werden
4160 | 16736 | Intern | reserviert
4161 | 16737 | Intern | reserviert
4162 | 16738 | Parameter | Die aktuell wirkenden Interpolationsregeln (G-Code), Nullpunktverschiebungen oder Rotation können nicht ermittelt werden
4170 | 16752 | NC-Programmierung | "Fehler beim Laden: Ungültiger Parameter" Die NC hat beim Laden eines NC-Programms einen ungültigen Parameter festgestellt.
4171 | 16753 | Intern | "Unzulässige Kontur-Startposition" Die NC hat beim Abarbeiten einen Rechenfehler festgestellt: Die angegebene Kontur ist nicht rechenbar, da die Startposition nicht auf der Kontur liegt.
4172 | 16754 | Intern | "Rückwärtsfahren: Invalid Tabellenindex" Die NC hat beim Abarbeiten des Rückwärtsfahrens einen ungültigen Tabellenindex festgestellt.


Gruppenfehler

Fehlercodes [image] Übersicht NC-Fehler [image] Gruppenfehler
Gruppenfehler
Fehler(Hex)
Fehler(Dez)
Fehlertyp
Beschreibung
4200
16896
Parameter
„Gruppen-ID unzulässig“
Der Wert für die Gruppen-ID ist unzulässig, da er z. B. bereits vergeben ist, kleiner gleich Null ist oder größer 255 ist.
Wertebereich: [1 ... 255]
Einheit: 1
4201
16897
Parameter
„Gruppen-Typ unzulässig“
Der Wert für den Gruppen-Typ ist unzulässig, da er nicht definiert ist.
Typ 1: PTP-Gruppe mit Slaves (Servo)
Typ 4: DxD-Gruppe mit Slaves (3D-Gruppe)
Typ 5: Eil/Schleich-Gruppe
Typ 6: Schrittmotor-Gruppe
Typ 9: Encoder-Gruppe mit Slaves (Servo)
…
Wertebereich: [1 ... 12]
Einheit: 1
4202
16898
Initialisierung
„Masterachsen-Index unzulässig“ Der Wert für den Masterachs-Index innerhalb einer interpolierenden 3D-Gruppe ist unzulässig, da er z. B. den Wertebereich verlassen hat. Index 0: X-Achse (erste Masterachse) Index 1: Y-Achse (zweite Masterachse) Index 2: Z-Achse (dritte Masterachse)
Wertebereich: [0, 1, 2]
Einheit: 1
4203
16899
Initialisierung
„Slaveachsen-Index unzulässig“ (INTERNER FEHLER) Der Wert für den Slaveachs-Index innerhalb einer Gruppe ist unzulässig, da er z. B. den Wertebereich verlassen hat, der Slaveplatz beim Einfügen einer neuen Slaveverbindung schon besetzt ist oder beim Aufheben einer solchen Slaveverbindung keine Slaveachse vorhanden ist. Index 0: Erste Slaveachse Index 1: Zweite Slaveachse Index 2: etc.
Wertebereich: [0 ... 7]
Einheit: 1
4204
16900
Initialisierung
„INTERNER FEHLER“ (GROUPERR_INTERNAL)
4205
16901
Parameter
„Zykluszeit für Satzausführungstask (SAF) unzulässig“ Der Wert für die Zykluszeit der NC Satzausführungstask (SAF 1/2) ist unzulässig, da er den Wertebereich verlassen hat.
Wertebereich: [0.001 ... 0.1]
Einheit: s
4206
16902
Initialisierung
„GROUPERR_RANGE_MAXELEMENTSINAXIS “
4207
16903
Parameter
„Zykluszeit für Satzvorbereitungstask (SVB) unzulässig“ Der Wert für die Zykluszeit der NC Satzvorbereitungstask (SVB 1/2) ist unzulässig, da er den Wertebereich verlassen hat.
Wertebereich: [0.001 ... 1.0]
Einheit: s
4208
16904
Parameter
„Einzelsatzbetrieb (Single Step Mode) unzulässig“ Das Flag für die Aktivierung bzw. Deaktivierung der Einzelsatzbetriebsart ist unzulässig. Wert 0: Passiv (Pufferbetrieb) Wert 1: Aktiv (Einzelsatzbetrieb)
Wertebereich: [0, 1]
Einheit: 1
4209
16905
Parameter
„Deaktivierung Gruppe unzulässig“ (INTERNER FEHLER) Das Flag für die Deaktivierung bzw. Aktivierung der kompletten Gruppe ist unzulässig. Wert 0: Gruppe aktiv Wert 1: Gruppe passiv
Wertebereich: [0, 1]
Einheit: 1
420A
16906
Initialisierung
„Satzausführungszustand (SAF-State) unzulässig“ (INTERNER FEHLER) Der Wert für den Zustand der Satzausführungsstatemaschine (SAF-State) ist unzulässig. Dieser Fehler tritt auf, wenn der Wertebereich verlassen wird oder sich die Statemaschine im Fehlerzustand befindet.
Wertebereich: [0 ... 5]
Einheit: 1
420B
16907
Adresse
„Adresse Kanal“ Gruppe besitzt keinen Kanal (Channel) bzw. die Kanaladresse ist nicht initialisiert worden.
420C
16908
Adresse
„Adresse Achse (Masterachse)“ Die Gruppe besitzt keine Masterachse (Masterachsen) bzw. die Achsadresse (Achsadressen) ist nicht initialisiert worden.
420D
16909
Adresse
„Adresse Masterachse“ Eine neue Master/Slave-Kopplung soll in die Gruppe eingefügt werden, wobei eine gültige Adresse auf die führende Masterachse fehlt.
420E
16910
Adresse
„Adresse Slaveachse“ Es soll eine Master/Slave-Kopplung in die Gruppe eingefügt werden, der eine gültige Adresse auf die Slaveachse fehlt.
420F
16911
Adresse
„Adresse Slave-Sollwertgenerator“ Es soll eine Master/Slave-Kopplung in die Gruppe eingefügt werden, der eine gültige Adresse auf den Slave-Sollwertgenerator fehlt.
4210
16912
Adresse
„Adresse Geber“ Eine Achse der Gruppe besitzt keinen Geber (Encoder) bzw. die Geberadresse ist nicht initialisiert worden.
4211
16913
Adresse
„Adresse Regler“ Eine Achse der Gruppe besitzt keinen Regler (Controller) bzw. die Regleradresse ist nicht initialisiert worden.
4212
16914
Adresse
„Adresse Drive“ Eine Achse der Gruppe besitzt keinen Antrieb (Drive) bzw. die Driveadresse ist nicht initialisiert worden.
4213
16915
Adresse
„GROUPERR_ADDR_MASTERGENERATOR“
4214
16916
Adresse
„Adresse Achsinterface NC zur SPS“ Gruppe/Achse besitzt kein Achsinterface von der NC zur SPS (NC to PLC) bzw. ist die Achsinterfaceadresse nicht initialisiert worden.
4215
16917
Adresse
„Adresse Slaveachse“ Eine bestehende Master/Slave-Kopplung soll innerhalb der Gruppe aufgelöst werden, wobei eine gültige Adresse auf die Slaveachse fehlt.
4216
16918
Adresse
„Tabelle unbekannt“ Die Tabelle bzw. die Tabellen-ID ist im System unbekannt. Hierbei kann es sich um eine Tabelle für eine Master/Slave Kopplung oder um eine Kennlinien-Tabelle handeln.
4217
16919
Adresse
„Adresse NcControl“ Die NcControladresse ist nicht initialisiert worden.
4218
16920
Initialisierung
"Kommandosperre da persistente NC-Daten zur Übernahme anstehen" Achse sperrt sich gegen Kommandos während sie auf gültige IO Daten wartet um die gepufferten persistenten NC Daten zu übernehmen.
4219
16921
Funktion
"Der Skalierungsmode MASTER-AUTOOFFSET ist unzulässig, da keine Referenz-Tabelle gefunden werden kann". Der verwendete Skalierungsmode MASTER-AUTOOFFSET ist in diesem Zusammenhang unzulässig, da kein Bezug auf eine bestehende Referenz-Tabelle hergestellt werden kann.
Dieser Fehler kann beispielsweise bei der Addition von Tabellen auftreten, wenn kein eindeutiger Bezug zu einer bestehenden Referenz-Tabelle hergestellt werden kann (z.B. weil der Bezug nicht eindeutig ist etc.).
421A
16922
Parameter
„Startposition der Masterachse lässt keine Synchronisation zu“ Die Position der Masterachse bei Ankopplung der Slaveachse lässt keine Synchronisation mit den angegebenen Synchronpositionen zu.
421B
16923
Parameter
„Slave-Koppelfaktor (Getriebefaktor) gleich 0.0 unzulässig“ Es ist eine Master/Slave-Kopplung mit dem Getriebefaktor 0.0 erzeugt worden. Dieser Wert ist unzulässig, da er keiner Kopplung entspricht und bei einer Division eine Exception der FPU generieren würde.
421C
16924
Funktion
„Einfügen von Masterachse in Gruppe unzulässig“ Es sollte eine Masterachse auf einen Platz innerhalb der Gruppe eingefügt werden, der bereits durch eine andere Masterachse belegt ist. Möglicherweise kann die Umgruppierung auch nicht durchgeführt werden, weil mit dieser Achse eine Slaveverbindung besteht. Diese muss zuvor aufgehoben werden.
421D
16925
Funktion
„Löschen von Masterachse aus Gruppe unzulässig“ (INTERNER FEHLER) Es sollte eine Masterachse von einem Platz innerhalb der Gruppe herausgenommen worden, der gar nicht durch eine Masterachse belegt gewesen ist.
421E
16926
Funktion
„Funktion/Eigenschaft wird vom Sollwertgenerator nicht unterstützt Es ist eine Funktion aktiviert worden, die die Sollwertgenerierung (z.B. PTP Sollwertgenerator) generell oder aber in dieser bestimmten Situation nicht unterstützt.
421F
16927
Initialisierung
„Initialisierung Gruppe“ Gruppe ist nicht initialisiert worden. Gruppe wurde zwar erzeugt, allerdings nicht weiter initialisiert (1. Initialisierung Gruppe-IO, 2. Initialisierung Gruppe, 3. Reset Gruppe).
4220
16928
Überwachung
„Gruppe nicht fertig / Gruppe nicht bereit für neuen Auftrag“ Gruppe bekommt einen neuen Auftrag, während sie sich noch in der Ausführung eines vorhandenen Auftrages befindet. Diese Anforderung ist unzulässig, da hierdurch die Ausführung des bisherigen Auftrages unterbrochen würde. Bei den neuen Aufträgen kann es sich z. B. um einen Positionierbefehl oder um die Funktion „Setze Istposition“ handeln. Für die Funktion „Neue Endposition setzen“ gilt genau der umgekehrte Sachverhalt. Hierbei muss nämlich die Gruppe/Achse noch aktiv verfahren werden, um eine Änderung der Endposition Veranlassen zu können.
4221
16929
Überwachung
„Geforderte Sollgeschwindigkeit ist unzulässig“ Der Wert für die geforderte Sollgeschwindigkeit eines Positionierauftrages ist entweder kleiner gleich Null, größer als die "maximal erlaubte Geschwindigkeit" (s. Achsparameter) oder bei Servo-Antrieben größer als die "Bezugsgeschwindigkeit" der Achse (s. Driveparameter).
4222
16930
Überwachung
„Geforderte Zielposition ist unzulässig (Masterachse)“ Der Wert für die geforderte Zielposition eines Positionierauftrages befindet sich nicht innerhalb der Softwareendlagen, d. h. die Software Endlage Minimum bzw. die Software Endlage Maximum würde unterschritten bzw. überschritten. Diese Überprüfung wird nur dann durchgeführt, wenn die jeweilige Endlagenüberwachung aktiviert ist.
4223
16931
Überwachung
„Regler- und/oder Vorschubfreigabe nicht vorhanden (Masterachse)“ Die für eine Positionierung benötigten Achsfreigaben der Masterachse sind nicht vorhanden. Hierbei kann es sich entweder um die Reglerfreigabe und/oder um die jeweilige richtungsabhängige Vorschubfreigabe handeln (s. Achsinterface PlcToNc).
4224
16932
Überwachung
„Verfahrweg kleiner einem Geberinkrement“ (INTERNER FEHLER) Der Verfahrweg einer Gruppe/Achse ist kleiner der physikalischen Gewichtung eines Geberinkrementes, d. h. der Verfahrweg ist kleiner als der Skalierungsfaktor der Achse. Hierauf wird in der Art reagiert, dass die Achse logisch fertig gemeldet wird, ohne aber das sie aktiv verfahren worden ist. Somit wird auch für den Anwender kein externer Fehler generiert. Für Eil-/Schleichachsen wird dieser Fehler ebenfalls ausgegeben, wenn ein ungleich Null parametrierter Schleifenweg kleiner der Summe aus Schleich- und Bremsweg ist. In diesem Fall kann die Zielposition nicht sinnvoll über- bzw. unterfahren werden.
4225
16933
Überwachung
„Antriebshardware nicht betriebsbereit bei Achsstart“ Bei einem Achsstart ist festgestellt worden, dass die Antriebshardware (Drive) nicht betriebsbereit ist. Hierfür kann es folgende Ursachen geben: - der Antrieb ist im Fehlerzustand (Hardwarefehler) - der Antrieb befindet sich in der Aufstartphase (z. B. nach einem Achsreset dem ein Hardwarefehler voraus ging) - dem Antrieb fehlt die Reglerfreigabe (ENABLE) Anmerkung: Der Zeitbedarf für das „Hochfahren“ eines Antriebes nach einem Hardwarefehler kann sich im Bereich von mehreren Sekunden bewegen.
4226
16934
Überwachung
"Die Parameter des Not-Stops sind unzulässig." Entweder sind die Verzögerung und der Ruck kleiner gleich Null oder aber einer der beiden Werte ist schwächer als die originalen Startdaten der Positionierung.
4227
16935
Funktion
"Der Sollwertgenerator ist nicht aktiv, so dass keine Instruktion angenommen wird."
4228
16936
Überwachung
„Geforderte Verfahrweg/Schleifenweg ist unzulässig“ Der Verfahrweg bzw. der Schleifenweg der Achse ist kleiner als der positive oder negative Bremsweg der Eil-/Schleich-Achse.
4229
16937
Überwachung
„Geforderte Zielposition ist unzulässig (Slaveachse)“ Der auf die Slaveachse verrechnete Wert für die Zielposition eines Positionierauftrages befindet sich nicht innerhalb der Softwareendlagen, d. h. die Software Endlage Minimum bzw. die Software Endlage Maximum würde unterschritten bzw. überschritten. Diese Überprüfung wird nur dann durchgeführt, wenn die jeweilige Endlagenüberwachung aktiviert ist.
422A
16938
Überwachung
„Regler- und/oder Vorschubfreigabe nicht vorhanden (Slaveachse)“ Die für eine Positionierung benötigten Achsfreigaben einer oder mehrerer beteiligten Slaveachsen sind nicht vorhanden. Hierbei kann es sich entweder um die Reglerfreigabe und/oder um die jeweilige richtungsabhängige Vorschubfreigabe handeln (s. Achsinterface PlcToNc).
422B
16939
Parameter
„Aktivierungsposition (Schwelle) liegt außerhalb des Bereichs der aktuellen Positionierung“Die Aktivierungsposition (Schwelle) eines Kommandos (z.B. "neue Geschwindigkeit ab einer Positionsschwelle") liegt außerhalb des Bereichs der aktuellen Positionierung (z.B. in Fahrtrichtung betrachtet vor der aktuellen Position oder hinter der Zielposition der Achse).
422C
16940
Parameter
„Start/Aktivierungsdaten der externen Sollwertübernahme sind unzulässig“ Es können folgende Fehlersituationen vorliegen: 1. Wenn die externe Sollwertgenerierung/Übernahme bereits aktiv ist und diese wiederholt mit einem Starttyp (1: Absolut, 2: Realtiv) aktiviert wird, der dem ursprünglichen Anfangsstarttyp widerspricht.
2. Wenn die interne Sollwertgenerierung (z.B. PTP) bereits aktiv ist und zusätzlich die externe Sollwertgenerierung mit dem Starttyp "Absolut" aktiviert wird (2 mal absolut widerspricht sich).
422D
16941
Parameter
„Geschwindigkeit ist nicht konstant“ Zur Veränderung der Dynamikparameter 'Acceleration' und 'Deceleration' muss die Achse in einem kräftefreien Zustand sein.
422E
16942
Parameter
„Ruck kleiner gleich 0.0 unzulässig“ Ein Wert kleiner gleich 0.0 für den Ruck (PTP und CNC) ist unzulässig, da der Ruck definitionsgemäß positiv ist und bei Ruck 0.0 durch Divisonen eine Exception der FPU generiert wird.
422F
16943
Parameter
„Beschleunigung kleiner gleich 0.0 unzulässig“ Ein Wert kleiner gleich 0.0 für die Beschleunigung (PTP und CNC) ist unzulässig, da die Beschleunigung definitionsgemäß positiv ist und bei Beschleunigung 0.0 sich keine Bewegung generieren lässt.
4230
16944
Parameter
„Absolutwert Verzögerung kleiner gleich 0.0 unzulässig“ Ein Wert kleiner gleich 0.0 für den Absolutwert der Verzögerung (PTP und CNC) ist unzulässig, da der Absolutwert der Verzögerung definitionsgemäß positiv ist und bei Absolutwert der Verzögerung 0.0 sich keine Bewegung generieren lässt
4231
16945
Parameter
„Sollgeschwindigkeit kleiner gleich 0.0 unzulässig“ Ein Wert kleiner gleich 0.0 bzw. außerhalb des Bereiches von 10-3 bis 10+10 ist für die Sollgeschwindigkeit (PTP und CNC) unzulässig, da die Sollgeschwindigkeit definitionsgemäß strikt positiv ist und bei Sollgeschwindigkeit 0.0 durch Divisionen eine Exception der FPU generiert wird.
4232
16946
Überwachung
„Verlust der Auflösungsgenauigkeit für eine angeforderte Positionierung“ Die Positionierung ist räumlich oder zeitlich so lang, dass Nachkommastellen irrelevant werden und es zu Ungenauigkeiten während der Positionierung kommen kann (LOSS_OF_PRECISION).
4233
16947
Parameter
„Zykuszeit kleiner gleich 0.0 unzulässig“ Ein Wert kleiner gleich 0.0 für die Zykluszeit (PTP und CNC) ist unzulässig, da die Zykluszeit definitionsgemäß strikt positiv ist und bei Zykluszeit 0.0 durch Divisionen eine Exception der FPU generiert wird.
4234
16948
Intern
„PTP Datentyp <intasdouble> Bereichsüberschreitung “ Der Startauftrag oder der Override oder die neue Zielposition sind so extrem parametriert, dass der interne Datentyp seine Genauigkeit verliert.
4235
16949
Funktion
„PTP LHL-Geschwindigkeitsprofil nicht generierbar“ (INTERNER FEHLER) Der Startauftrag oder der Override oder die neue Zielposition sind so extrem parametriert, dass kein Geschwindigkeitsprofil des Typs LHL (Low-High-Low) generierbar ist.
4236
16950
Funktion
„PTP HML-Geschwindigkeitsprofil nicht generierbar“ (INTERNER FEHLER) Der Override oder die neue Zielposition sind so extrem parametriert, dass kein Geschwindigkeitsprofil des Typs HML (High-Middle-Low) generierbar ist.
4237
16951
Adresse
„Startdaten-Adresse ungültig“ Die Adresse der Startdaten ist ungültig.
4238
16952
Parameter
„Geschwindigkeits-Override (StartOverride) unzulässig“ Der Wert für den Geschwindigkeits-Override ist unzulässig, da er unter 0.0% oder über 100.0% ist (s. Achsinterface PlcToNc). Hierbei entsprechen 100.0 % dem ganzzahligen Wert 1000000 im Achsinterface. Wertebereich: [0 ... 1000000]
4239
16953
Parameter
„StartTyp unzulässig“ Der angegebene Starttyp existiert nicht
423A
16954
Überwachung
„Geschwindigkeitsüberhöhung (Überschwingen in der Geschwindigkeit)“ Die neue Dynamik ist mit dem parametrierten Ruck ist so schwach, dass unter vorgegebenen Randbedingungen eine Geschwindigkeitsüberhöhung (Überschwingen in der Geschwindigkeit) droht. Das Kommando wird deshalb nicht ausgeführt.
423B
16955
Parameter
„Startparameter der Achsstruktur ungültig“ Externe oder interne Parameter der Startstruktur für eine Positionierauftrag sind ungültig. So können z. B. unzulässigerweise der Skalierungsfaktor, die SAF-Zykluszeit oder die geforderte Geschwindigkeit kleiner gleich Null sein.
423C
16956
Parameter
„Initialisierungsparameter des Overridegenerators ungültig“ Einer der (Re)Initialisierungparameter des Overridegenerators ist ungültig
423D
16957
Überwachung
„Slaveachse besitzt keinen Sollwertgenerator“ (INTERNER FEHLER) Innerhalb der Gruppe ist festgestellt worden, dass eine Slaveachse keinen gültigen Slavegenerator (Sollwertgenerator) besitzt. Slaveachse und Slavesollwertgenerator müssen zwingend paarweise vorhanden sein. Hierbei handelt es sich um einen internen Fehler.
423E
16958
Funktion
„Tabelle ist leer“ Die SVBTabelle oder die SAF-Tabelle enthält keinen Eintrag.
423F
16959
Funktion
„Tabelle ist voll“ Die SVBTabelle oder die SAF-Tabelle hat keine freie Zeile mehr.
4240
16960
Speicher
„Kein Speicher verfügbar“ SVB-Speicherallozierung für dynamischen Eintrag in SAF-Tabelle misslungen .
4241
16961
Funktion
„Tabelle enthält schon einen Eintrag“ (INTERNER FEHLER) SAF-Tabelleneintrag abgebrochen, da fälschlicherweise schon ein Eintrag existiert.
4242
16962
Funktion
„Stop ist schon aktiv“ Stopauftrag wird nicht weitergeleitet, da der Stop schon aktiviert worden war.
4243
16963
Funktion
„Kompensation wird nicht um die volle Kompensationsstrecke durchgeführt“ Die Komponsations-Start-Parameter lassen eine Kompensation um die volle zu kompensierende Strecke nicht zu. Daher wird eine Kompensation um eine kleinere Strecke durchgeführt.
4244
16964
Parameter
„Interne-Parameter der Kompensation ungültig“ (INTERNER FEHLER) Ungültige interne Parameter bzw. Startparameter des unterlagerten Generators.
4245
16965
Funktion
„Kompensation aktiv“ Start der Kompensation verweigert, da die Kompensation schon aktiv ist oder aber die Master-/Slaveachse gar nicht aktiv verfahren wird, wodurch eine Ausführung der Kompensation unmöglich ist.
4246
16966
Funktion
„Kompensation nicht aktiv“ Stop der Kompensation verweigert, da die Kompensation nicht aktiv ist.
4247
16967
Funktion
„Kompensationstyp ungültig“ Der Typ für die Streckenkompensation ist ungültig. Erlaubt ist zum jetzigen Zeitpunkt nur der Kompensationstyp 1 (trapezförmiger Geschwindigkeitsverlauf).
4248
16968
Funktion
„Achsadresse für Kompensation ungültig“ (INTERNER FEHLER) Die Adresse der Master- oder Slaveachse, auf die die Streckenkompensation wirken soll, ist ungültig. Hierbei handelt es sich um einen internen Fehler.
4249
16969
Adresse
„Ungültige Slave-Adresse“ (INTERNER FEHLER) Die angegebene Slave-Adresse zum online Ab/Abkoppeln ist ungültig.
424A
16970
Funktion
„Koppel-Geschwindigkeiten unzulässig“ Die Geschwindigkeit der zukünftigen Masterachse ist 0, so dass ein online Ankoppeln nicht möglich ist.
424B
16971
Funktion
„Koppel-Geschwindigkeiten nicht konstant“ Die Geschwindigkeit der zukünftigen Masterachse und die Geschwindigkeit der zukünftigen Slaveachse sind nicht konstant, so dass ein online Ankoppeln nicht möglich ist.
424C
16972
Parameter
„Zykluszeit kleiner gleich 0.0 unzulässig“ Ein Wert kleiner gleich 0.0 für die Zykluszeit (Slave) ist unzulässig, da die Zykluszeit definitionsgemäß strikt positiv ist und bei Zykluszeit 0.0 durch Divisionen eine Exception der FPU generiert wird.
424D
16973
Funktion
„Entkoppel-Auftrag unzulässig“ Die Slaveachse ist von einem Typ (z.B. Tabellenslave), oder in einem Zustand (Mastergeschwindigkeit 0), der keine Online Entkopplung zulässt.
424E
16974
Funktion
„Funktion unzulässig“ Die Funktion ist logisch nicht ausführbar, z.B. Kommandos die für Slaveachsen nicht möglich bzw. nicht erlaubt sind.
424F
16975
Parameter
„Kein gültiges Tabellengewicht gesetzt“ Der Gewichtungsfaktor ist für jede Tabelle 0, so dass keine Tabelle gelesen werden kann.
4250
16976
Funktion
„Achsstarttyp, Istpositionstyp oder Endpositionstyp unzulässig“ Der Starttyp für einen Positionierauftrag ist ungültig. Gültige Starttypen sind ABSOLUT (1), RELATIV (2), ENDLOS POSITIV (3), ENDLOS NEGATIV (4), MODULO (5), etc. . Ferner ist es möglich, dass die Typen für das Setzen einer neue Istposition oder das Anfahren einer neuen Endposition ungültig sind.
4251
16977
Funktion
„Funktion wird nicht unterstützt“ Es ist eine NC-Funktionalität ausgelöst worden, die nicht zur Benutzung freigegeben ist bzw. die nicht implementiert ist. Hierbei kann es sich z.B. um Kommandos handeln, die für Masterachsen nicht möglich bzw. nicht erlaubt sind.
4252
16978
Überwachung
„Zustand für Statemaschine ungültig“ (INTERNER FEHLER) Der Zustand für eine der internen Statemaschines ist ungültig. Hierbei handelt es sich um einen internen Fehler.
4253
16979
Überwachung
„SPS-Referenziernocke ist vorzeitig freigeworden“ Beim Referenziervorgang einer Achse wird diese in Richtung des SPS-Referenziernockens gestartet und erst beim Erreichen des Nockensignals wieder gestoppt. Nachdem die Achse dann auch physikalisch zum Stillstand gekommen ist muss der Referenziernocken weiterhin belegt bleiben, bis die Achse im Anschluss daran wieder regulär vom Nocken herunter gestartet wird.
4254
16980
Überwachung
„Abstandsüberwachung zwischen Aktivierung des Hardwarelatch und Eintritt des IO-Syncimpuls“ Bei aktivierter Abstandsüberwachung wird überwacht, ob der Abstand in Inkrementen zwischen der Aktivierung des Hardwarelatch und Eintritt des Syncimpuls (Nullimpuls) kleiner eines voreingestellten Wertes geworden ist. Wenn dieser Fall eingetreten ist wird dieser Fehler generiert. (s. Parameter Inkremental-Geber)
4255
16981
Speicher
„Kein Speicher verfügbar“ Die dynamische Speicherallozierung für den Sollwertgenerator oder die SVB-Tabelle oder die SAF-Tabelle ist fehlgeschlagen.
4256
16982
Überwachung
„Die Tabellen-Slave-Achse hat keine aktive Tabelle“ Obwohl die Tabellen-Slave-Achse Tabellen hat ist keine der Tabellen als aktiv gekennzeichnet. Falls das zur Laufzeit auftritt wird die ganze Master/Slave Gruppe per Laufzeitfehler angehalten.
4257
16983
Funktion
„Funktion nicht zugelassen“ Die angeforderte Funktion bzw. der angeforderte Auftrag ist logisch nicht erlaubt. Ein Beispiel für eine solche Fehlermeldung ist das „Setzen einer Istposition“ für einen Absolut-Geber (M3000, KL5001, etc.).
4258
16984
Funktion
„Kompensation-Stop unzulässig“ Stop der Kompensation ist nicht möglich, da die Kompensation schon in der Stopphase ist.
4259
16985
Funktion
„Slave-Tabelle wird benutzt“ Die Slave-Tabelle kann nicht aktiviert werden, da sie momentan benutzt wird.
425A
16986
Funktion
„Master- oder Slaveachse führt zum Koppelzeitpunkt einen Auftrag aus (z.B. eine Positionierung)“ Eine Master/Slave-Kopplung eines bestimmten Slavetyps (z.B. Linear-Kopplung) kann nicht durchgeführt werden, da sich entweder die Masterachse oder aber die zukünftige Slaveachse nicht im Stillstand befindet, sondern zum Koppelzeitpunkt einen Auftrag ausführt (z.B. eine Positionierung). Dies ist für diesen konkreten Koppeltyp nicht erlaubt.
425B
16987
Parameter
„Slave (Start)-Parameter ist falsch“ Einer der Slave Start-/Koppelparameter ist unzulässig (Koppelfaktor ist Null, Master Positionsskalierung einer Kurvenscheibe ist Null, etc.).
425C
16988
Parameter
„Slave-Typ is falsch“ Der Slave-Typ passt nicht zum (SVB) Start-Typ.
425D
16989
Funktion
„Achs-Stop ist schon aktiv“ Die Achs-Stop/EStop wird nicht eingeleitet, da der Stop schon aktiv ist.
425E
16990
Funktion
„Maximalanzahl von Tabellen pro Slavegenerator erreicht“ Die Maximalanzahl von Tabellen pro Slavegenerator ist erreicht (z.B. 4 Tabellen bei Verwendung von "MC_MultiCamIn").
425F
16991
Funktion
"Der Skalierungsmode ist unzulässig". Der verwendete Skalierungsmode in diesem Zusammenhang nicht gültig. Entweder ist der Mode nicht definiert bzw. noch nicht implementiert oder aber er kann in dieser Konstellation nicht umgesetzt werden.
So kann beispielsweise der Mode MASTER-AUTOOFFSET nicht verwendet werden, wenn relativ gekoppelt wird, da es hier einen Widerspruch gibt.
Ferner kann der Mode MASTER-AUTOOFFSET nicht beim erstmaligen Koppeln verwendet werden, da hier kein Bezug auf eine bestehende Referenz-Tabellenkopplung (Referenz-Tabelle) hergestellt werden kann.
4260
16992
Überwachung
„Reglerfreigabe“ Reglerfreigabe für Achse oder zugehörige Slaveachse nicht vorhanden (s. Achsinterface PlcToNc). Dieser Fehler tritt auf, wenn bei aktiver Positionierung einer Achse bzw. einer Gruppe von Achsen (auch Master/Slave-Gruppen) die Reglerfreigabe entzogen wird. Ferner tritt dieser Fehler auf, wenn eine PTP-Achse oder eine zugehörige Slaveachse ohne Reglerfreigabe gestartet wird.
4261
16993
Funktion
„Tabelle nicht gefunden“ Eine Tabelle mit der angegebenen ID existiert nicht oder wurde nicht eindeutig spezifiziert.
4262
16994
Funktion
„Falscher Tabellentyp“ Die in der Funktion angesprochene Tabelle hat den falschen Typ.
4263
16995
Funktion
„Einzelsatz Betrieb (Single Step Mode)“ Dieser Fehler tritt auf, wenn für eine Gruppe/Achse die Einzelsatz-Betriebsart angewählt ist, und noch während der Abarbeitung eines einzelnen Auftrages schon ein neuer Auftrag angefordert wird.
4264
16996
Funktion
„Gruppenauftrag unbekannt (asynchroner Tabelleneintrag)“ Die Gruppe hat einen Auftrag bekommen, dessen Typ oder Untertyp unbekannt ist. Gültige Aufträge können ein ein- oder mehrdimensionaler Positionierauftrag (Geo 1D, Geo 3D) , ein Referenzierauftrag, etc. sein.
4265
16997
Funktion
„Gruppenfunktion unbekannt (synchrone Funktion)“ Die Gruppe hat einen Funktion bekommen, dessen Typ unbekannt ist. Gültige Funktionen sind „Reset“, „Stop“, “Neue Endposition“, „Start/Stop Streckenkompensation“ „Istposition setzen“, „Referenzierstatus setzen/rücksetzen“ etc. .
4266
16998
Funktion
„Gruppenauftrag für Slave unzulässig“ Gruppenaufträge sind üblicherweise nur für Masterachsen und nicht für Slaveachsen möglich. Eine Slaveachse wird nur indirekt durch einen Positionierauftrag ihrer zugehörigen Masterachse verfahren. Ein Slave kann also nicht direkt einen Auftrag bekommen.
Ausnahme: s. Achsparameter "Erlaube Bewegungskommandos für Slaveachsen"
4267
16999
Funktion
„Gruppenfunktion für Slave unzulässig“ Gruppenfunktionen sind grundsätzlich nur für Masterachsen und nicht für Slaveachsen möglich. Die einzige Ausnahme bildet die Funktion „Start/Stop Streckenkompensation“, die sowohl für Master als auch Slaves möglich ist. Hierüber hinaus kann ein Slave keine weiteren direkten Funktionen verarbeiten.
4268
17000
Funktion
"GROUPERR_GROUPFUNC_NOMOTION"
4269
17001
Parameter
„Startposition = Zielposition“ Ungültige Positionsparameter.
426A
17002
Parameter
„Parameter-des Delay-Generators ungültig“ Ungültige externe/interne Parameter des Delaygenerators (Verzögerungszeit, Zykluszeit, Tics).
426B
17003
Parameter
„Externe-Parameter- der Kompensation ungültig“ Ungültige externe Startparameter der Kompensation (Beschleunigung, Verzögerung, Geschwindigkeit, Prozessgeschwindigkeit, Kompensationslänge) .
426C
17004
Parameter
"Der angewählte Overridetyp ist unzulässig."
426D
17005
Funktion
„Aktivierungsposition über/unterfahren“ Die angestrebte Aktivierungsposition liegt in der Vergangenheit des Masters (z.B. bei Kurvenscheibenumschaltung).
426E
17006
Funktion
„Aktivierung unmöglich: Master im Stillstand“ Die angestrebte Aktivierung der Korrektur ist nicht möglich, da die Masterachse nicht fährt. Ein Aufsynchronisieren ist nicht möglich, da sich die Masterachse im Stillstand befindet und die Slaveachse noch unsynchronisiert ist.
426F
17007
Funktion
„Aktivierungsmode nicht möglich“ Der angeforderte Aktivierungsmode ist nicht möglich wenn sich die Slave-Achse bewegt. Anderenfalls würde die Slave-Dynamik abrupt zu Null gesetzt werden.
4270
17008
Parameter
„Startparameter der Kompensation ungültig“ Einer der Dynamikparameter der Kompensation ist ungültig (notwendige Bedingung): Beschleunigung (>0) Verzögerung (>0) Prozessgeschwindigkeit (>0)
4271
17009
Parameter
„Startparameter der Kompensation ungültig“ Die Geschwindigkeitsüberhöhung ist negativ.
4272
17010
Parameter
„Startparameter der Kompensation ungültig“ Die Strecke auf der die Kompensation stattfindet ist nicht positiv.
4273
17011
Überwachung
„Zielposition über/unterfahren“ (INTERNER FEHLER) Die für das Ende des orientierten Stopps vorgesehene Position (aus der Modulo-Zielposition errechnet) ist schon überfahren worden.
4274
17012
Überwachung
„Zielposition wird über/unterfahren werden“ (INTERNER FEHLER) Die für das Ende des orientierten Stopps vorgesehene Position (aus der Modulo-Zielposition errechnet) ist zu nah und wird überfahren werden.
4276
17014
Überwachung
"GROUPERR_GUIDERSTARTDATA"
4277
17015
Überwachung
„Dynamikparameter nicht zulässig“ (INTERNER FEHLER) Die sich durch interne Berechnungen ergebenden Dynamikparameter wie Beschleunigung, Verzögerung und Ruck sind nicht zulässig.
4279
17017
Überwachung
"GROUPERR_GUIDEROVERRUN"
427A
17018
Überwachung
"GROUPERR_GUIDERLOOKAHEAD"
427B
17019
Überwachung
"GROUPERR_GUIDERLOOKAHEADEND"
427C
17020
Überwachung
"GROUPERR_GUIDERLOOKAHEADREQU"
427D
17021
Überwachung
"GROUPERR_GUIDERMODE"
427E
17022
Überwachung
„Fahrbefehl kann mathematisch nicht umgesetzt werden (BISECTION)“ Es wurde ein Fahrbefehl angefordert, für den mit der Parametrierung keine Lösung gefunden werden konnte. Der Fahrbefehl wurde jedoch bestmöglich ausgeführt und die Meldung ist daher eher als Warnung zu verstehen. Beispiele:
Ein Achsstart wird in der Bewegung in einer ungünstigen Dynamiksituation (Beschleunigungsphase) angefordert, in der die Fahrstrecke zu kurz oder die Geschwindigkeit deutlich zu hoch ist. Eine andere Möglichkeit ist eine Slaveachse, die in der Bewegung in einer ungünstigen Dynamiksituation abgekoppelt wird und anschließend mit einem Startkommando wie im vorherigen Fall beauftragt wird.
427F
17023
Überwachung
„Neue Zielposition ist bzw. wird überfahren werden“ Die neue Zielposition ist entweder schon überfahren worden oder wird in Zukunft überfahren werden, da die Achse bis zu dieser Position nicht gestoppt werden kann. Es wird deshalb instantan ein interner Stop eingeleitet.
4280
17024
Überwachung
„Gruppe nicht fertig / Gruppe nicht bereit für neuen Auftrag“ (INTERNER FEHLER/HINWEIS) Gruppe bekommt einen neuen Auftrag, während sie sich noch in der Ausführung eines vorhandenen Auftrages befindet. Diese Anforderung ist unzulässig, da hierdurch die Ausführung des bisherigen Auftrages unterbrochen würde. Bei den neuen Aufträgen kann es sich z. B. um einen Positionierbefehl oder um die Funktion „Setze Istposition“ handeln. Für die Funktion „Neue Endposition setzen“ gilt genau der umgekehrte Sachverhalt. Hierbei muss nämlich die Gruppe/Achse noch aktiv verfahren werden, um eine Änderung der Endposition Veranlassen zu können.
4281
17025
Parameter
"Die Parameter des orientierten Stops (O-Stop) sind unzulässig." Die Modulo-Zielposition darf nicht kleiner als Null und nicht größer gleich der Encoder-Modulo-Periode sein (z. B. im Intervall [0.0,360.0) ).
Anmerkung: Auch im Fehlerfall wird die Achse sicher gestoppt, steht dann aber anschließend nicht an der gewünschten orientierten Position.
4282
17026
Überwachung
"Die Modulo-Zielposition des Modulo-Starts ist unzulässig." Die Modulo-Zielposition ist außerhalb des gültigen Parameterbereichs. Der Wert darf nicht kleiner als Null und nicht größer gleich der Encoder-Modulo-Periode sein (z. B. im Intervall [0.0,360.0) für den Modulo-Starttyp "SHORTEST_WAY (261)" ).
4283
17027
Parameter
"Der Aktivierungsmode ist unzulässig". Der Aktivierungsmode kann sowohl bei der Online Änderung der Skalierung als auch bei Online Änderung der Motion Function verwendet worden sein. Allerdings ist der verwendete Aktivierungsmode in diesem Zusammenhang nicht gültig. Entweder ist der Mode nicht definiert bzw. noch nicht implementiert oder aber er kann in dieser Konstellation nicht umgesetzt werden (z.B. wenn lineare Tabellen mit einem unerlaubten zyklischen Aktivierungsmode NEXTCYCLE oder NEXTCYCLEONCE verwendet werden).
In anderen Fällen ist der Mode zwar prinzipiell gültig, das Kommando kann aber nicht umgesetzt werden, weil die Funktion schon einen Auftrag ausführt.
4284
17028
Parameter
"Der parametrierte Ruck ist unzulässig". Der Ruck ist kleiner als der Minimalruck. Der Wert für den Minimalruck beträgt 1.0 (z.B. mm/s^3).
4285
17029
Parameter
"Die parametrierte Beschleunigung bzw. Verzögerung ist unzulässig". Die parametrierte Beschleunigung oder Verzögerung ist kleiner als die erlaubte Minimalbeschleunigung. Der Wert für die Minimalbeschleunigung berechnet sich aus dem Minimalruck und der NC Zykluszeit (Minimalruck multipliziert mit der NC Zykluszeit). Die Einheit ist z.B. mm/s^2.
4286
17030
Parameter
"Die parametrierte Geschwindigkeit ist unzulässig". Die parametrierte Sollgeschwindigkeit ist kleiner als die Minimalgeschwindigkeit (der Wert Null ist erlaubt). Der Wert für die Minimalgeschwindigkeit berechnet sich aus dem Minimalruck und der NC Zykluszeit (Minimalruck multipliziert mit dem Quadrat der NC Zykluszeit). Die Einheit ist z.B. mm/s.
4287
17031
Überwachung
"Aktivierung kann nicht ausgeführt werden da bereits eine Aktivierung aktiv ist" Eine Aktivierung wie z.B. "CamIn", "CamScaling" oder "WriteMotionFunction" kann nicht ausgeführt werden da bereits eine andere Aktivierung ansteht (z.B. "CamIn", "CamScaling", "WriteMotionFunction"). Es kann jeweils nur eine Aktivierung aktiv sein.
4288
17032
Überwachung
„Unerlaubte Kombination von unterschiedlichen Zykluszeiten innerhalb einer Achsgruppe“ Innerhalb einer logischen Achsgruppe sind unterschiedliche Zykluszeiten für die gemeinsame Sollwertgenerierung bzw. für IO-Berabeitung einer Achse erkannt worden. Diese Situation kann sowohl beim Herrstellen einer Master/Slave-Kopplung als auch beim Konfigurieren einer 3D- oder FIFO-Gruppe (Einfügen von Haupt-, Zusatz- oder Slave-Achsen) aufgetreten sein.
4289
17033
Überwachung
„Unzulässige Bewegungsumkehr der Achse“ Aufgrund des aktuellen dynamischen Zustandes (aktuelle Geschwindigkeit, Beschleunigung und Ruck) würde eine Bewegungsumkehr verursacht werden. Zur Vermeidung dieser Bewegungsumkehr wird das Kommando nicht ausgeführt und der aktuelle Systemzustand wiederhergestellt.
428A
17034
Überwachung
„Unerlaubter Kommandozeitpunkt da eine andere Instruktion mit zuküftigen Aktivierungsposition aktiv ist“ Ein Kommando kann nicht akzeptiert werden, da zu diesem Zeitpunkt bereits ein anderes Kommando mit zuküftiger Aktivierungsposition aktiv ist (z.B. "Anfahren einer neuen Geschwindigkeit ab einer Aktivierungsposition" oder "Erreichen einer neuen Geschwindigkeit an einer Aktivierungsposition").
428B
17035
Überwachung
„Interner Fehler in der Stop-Berechnungsroutine“ (INTERNER FEHLER) Aufgrund eines internen Fehlers in der Stop-Berechnungsroutine kann das aktuelle Kommando nicht durchgeführt werden. Der vorherige Systemzustand ist wiederhergestellt worden.
428C
17036
Überwachung
„Kommando kann nur teilweise durchgeführt werden da der verbleibende Weg bis zur vollständigen Umsetzung zu kurz ist“Ein Kommando mit Aktivierungsposition (Schwelle) wie z.B. das "Anfahren einer neuen Geschwindigkeit ab einer Positionsschwelle" kann nur teilweise durchgeführt werden (also nicht vollständig), da der verbleibende Weg von der aktuellen Position bis zur Aktivierungsposition zu kurz ist.
428D
17037
Überwachung
„Ungültiger Abkoppeltyp“ Das Kommando zum Auflösen einer Slavekopplung mit anschließendem Nachstartkommando ist mit einem ungültigen Abkoppel- bzw. Nachstart-Typ aufgerufen worden.
428E
17038
Überwachung
„Unerlaubte Ziel-Geschwindigkeit beim Abkoppeln einer Slaveachse“ Das Kommando zum Auflösen einer Slavekopplung mit anschließendem Nachstartkommando ist mit einer unerlaubten Zielgeschwindigkeit aufgerufen worden [1 < V <Vmax].
428F
17039
Überwachung
„Aktivierung neue Dynamikparameter kann nicht durchgeführt werden“Das Kommando zum Aktivieren neuer Dynamikparameter wie Beschleunigung, Verzögerung und Ruck kann nicht durchgeführt werden, da dies eine neue beauftragte Fahrgeschwindigkeit erfordern würde.
Diese Fehlersituation kann z.B. auftreten, wenn sich die Achse im beschleunigten Zustand nahe der Zielposition befindet und die Dynamikparameter verringert werden.
4290
17040
Überwachung
„Kommando kann nicht durchgeführt werden da sich die Achse bereits in der Bemsphase befindet“Ein Kommando mit Aktivierungsposition (Schwelle) wie z.B. das "Anfahren einer neuen Geschwindigkeit ab einer Positionsschwelle" kann nicht durchgeführt werden, da sich die Achse bereits in der Bremsphase befindet und der verbleibende Weg von der aktuellen Position bis zur Aktivierungsposition zu kurz ist.
4291
17041
Überwachung
„Ruckskalierung der Abkoppelroutine beim Abkoppeln einer Slaveachse kann keine gültige Lösung finden“Die interne Ruckskalierung der Abkoppelroutine ( Abkopplung einer Slaveachse und Wandlung zum Master) kann keine gültige Lösung finden. Andernfalls könnte es zu einer unerwarteten Geschwindigkeitsüberhöhung, Bewegungsumkehr oder einem Überfahren der Zielposition kommen.
4292
17042
Überwachung
„Kommando kann nicht durchgeführt werden da der Auftragspuffer voll ist“Das Kommando wird abgelehnt, da der Auftragspuffer voll ist.
4293
17043
Intern
„Kommando kann aufgrund eines internen Fehlers im "Look Ahead" nicht ausgeführt werden“ (INTERNER FEHLER)Das Kommando kann aufgrund eines internen Fehlers im Zukunftsplaner ("look ahead") nicht ausgeführt werden.
4294
17044
Überwachung
„Kommando wird abgelehnt, da die neue Fahrgeschwindigkeit nicht umsetzbar ist“Das Kommando wird abgelehnt, da eine Umsetzung der neuen Fahrgeschwindigkeit (Zielgeschwindigkeit) Vrequ unmöglich und eine interne Optimierung undurchführbar ist.
4295
17045
Überwachung
„Aufeinander folgende Kommandos haben dieselbe Endposition“Aufeinander folgende Kommandos haben dieselbe Endposition, so dass sich eine Verfahrstrecke von Null ergibt.
4296
17046
Überwachung
„Logische Fahrtrichtung der Achse und parametrierte Fahrtrichtung des Puffer-Kommandos widerspechen sich“Im erweiterten Puffer-Betriebszustand (BufferMode), wo die aktuelle Endposition im aktuellen Segment durch die neue Puffer-Startposition überschrieben wird, liegen die aktuelle logische Fahrtrichtung antiparallel zur logischen Richtung des Puffer-Kommandos (=> Widerspruch).Ein gepuffertes Kommando (BufferMode BlendingLow, BlendingPrevious, BlendingNext, BlendingHigh) wird mit Fehler 0x4296 abgewiesen, wenn das Kommando mit der Beckhoff spezifischen Erweiterung einer optionalen Blending-Position verwendet wird, aber diese BlendingPosition jenseits der Zielposition des vorhergehenden Kommandos liegt.
4297
17047
Überwachung
„Kommando wird abgelehnt, da der verbleibende Restweg im aktuellen Segment zu kurz ist“Der für die Positionierung verbleibende Restweg ist nicht ausreichend, daher kann das Kommando nicht ausgeführt werden.
Dies kann z.B. im BufferMode (BlendingMode) der Fall sein, wenn der verbleibende Restweg im aktuellen Segment nicht ausreicht um beschleunigungsfrei zu fahren und am Segmentwechsel eine vorgegebene Geschwindigkeit erreicht zu haben (je nach BufferMode).
429B
17051
Überwachung
„Sammelfehler für ungültige Startparameter“ Dieser Fehler bezieht sich auf eine Falschparametrierung des Anwenders (Sammelfehler).Z.B. könnten Dynamikparameter wie Velo, Acc oder Dec kleiner gleich Null sein.
Oder folgende Fehlerfälle:
- BaseFrequence < 0.0
- StartFrequence < 1.0
- StepCount < 1, StepCount > 200
- BaseAmplitude <= 0.0
- StepDuration <= 0.0
- StopFrequence >= 1/(2*CycleTime)
429C
17052
Überwachung
„SPS-Referenziernocke ist nicht gefunden worden“ Beim Referenziervorgang einer Achse wird diese in Richtung des SPS-Referenziernockens gestartet. Diese Referenziernocke ist allerdings nicht wie erwartet gefunden worden (=> führt zum Abbruch des Referenziervorgangs).
429D
17053
Überwachung
„SPS-Referenziernocke ist nicht wieder freigeworden“ Beim Referenziervorgang einer Achse wird diese in Richtung des SPS-Referenziernockens gestartet und erst beim Erreichen des Nockensignals wieder gestoppt. Nachdem die Achse dann auch physikalisch zum Stillstand gekommen ist wird die Achse im Anschluss daran wieder regulär vom Nocken herunter gestartet. Hierbei ist der Referenziernocken beim Herunterfahren nicht wie erwartet wieder frei geworden (=> führt zum Abbruch des Referenziervorgangs).
429E
17054
Überwachung
„IO-Syncimpuls ist nicht gefunden worden (nur bei Verwendung von Hardwarelatch)“ Bei Aktivierung des Hardwarelatch wird erwartet, dass nach Ablauf einer bestimmten Zeit bzw. eines bestimmten Weges ein Syncimpuls (Nullimpuls) gefunden wird und ein Syncereignis ausgelöst wird. Ist dies nicht der Fall, dann wird darauf mit einem Fehler und dem Abbruch des Referenziervorgangs reagiert.
42A0
17056
Intern
„Gruppen-/Achsfolgefehler“ Folgefehler, der durch einen anderen verursachenden Fehler einer weiteren Achse innerhalb der Gruppe veranlasst worden ist. Gruppen-/Achsfolgefehler können im Zusammenhang mit Master/Slave-Kopplung oder mit einer mehrachsigen interpolierenden DXD-Gruppe auftreten. Wird z. B. an einer Masterachse eine Schleppabstandsüberschreitung erkannt, so werden alle übrigen Masterachsen dieser Gruppe, so wie auch sämtliche Slaveachsen, mit diesem Folgefehler versehen.
42A1
17057
Parameter
„Geschwindigkeitsreduktionsfaktor für C0/C1-Übergang unzulässig“ Ein C0-Übergang beschreibt zwei Geometrien, die zwar einen stetigen Verlauf besitzen, allerdings weder einmal noch zweimal stetig differenzierbar sind. Für solcher Übergänge wirkt der Geschwindigkeitsreduktionsfaktor C0. Anmerkung: Ein C1-Übergang ist dadurch gekennzeichnet, dass die zwei Geometrien einen stetigen Verlauf besitzen, allerdings nur einmal stetig differenzierbar sind. Für solcher Übergänge wirkt der Geschwindigkeitsreduktionsfaktor C1.
Wertebereich: [0.0 ... 1.0]
Einheit: 1
42A2
17058
Parameter
„Kritischer Winkel am Segmentübergang unzulässig“
Wertebereich: (0.0 ... 180.0]
Einheit: Grad
42A3
17059
Parameter
„Radius der Toleranzkugel“ nicht im erlaubten Wertebereich
Wertebereich: [0.0 ... 100.0]
Einheit: z. B. mm
42A4
17060
Parameter
Nicht implementiert.
42A5
17061
Parameter
„Starttypus“
Wertebereich: [0,1]
Einheit: 1
42A6
17062
Parameter
Nicht implementiert.
42A7
17063
Parameter
"Verschleifung" bei gegebenen Parametern nicht möglich
42A8
17064
Parameter
Nicht implementiert.
42A9
17065
Parameter
„Kurvengeschwindigkeitsreduktionsmethode unzulässig“ (INTERNER FEHLER) Die Kurvengeschwindigkeitsreduktionsmethode existiert nicht.
42AA
17066
Parameter
„Mindestgeschwindigkeit unzulässig“ Die eingegebene Mindestgeschwindigkeit ist kleiner 0.0.
42AB
17067
Parameter
„Powerfunction input unzulässig“ (INTERNER FEHLER) Die Eingabeparameter in die power_() Funktion führen zu einer FPU-Exception.
42AC
17068
Parameter
„Dynamikänderungsparameter unzulässig“ Ein Parameter der die Änderung der Dynamik reguliert ist ungültig. Parameter: 1.Absolute Bahndynamikänderung: alle Parameter müssen strikt positiv sein. 2.Relative Reduktion c_f: 0.0 < c_f <= 1.0
42AD
17069
Speicher
“Speicherallozierungfehler” (INTERNER FEHLER)
42AE
17070
Funktion
"Die berechnete Endposition passt nicht zur Endposition des Nc-Satzes (interner Fehler)."
42AF
17071
Parameter
"Berechne verbleibende Bahnlänge"
unzulässiger Wert
Wertebereich: [0,1]
42B0
17072
Funktion
„Sollwertgenerator SVB aktiv“ Start des Sollwertgenerators (SVB, SAF) verweigert, da die SVB-Task schon/noch aktiv ist.
42B1
17073
Parameter
„SVB-Parameter unzulässig“ (INTERNER FEHLER) Ein Parameter der inneren Struktur des Sollwertgenerators (SVB) führt zu logischen Fehlern und/oder zur einer FPU Exception. Betrifft die Parameter: Minimalgeschwindigkeit (>0,0), TimeMode, ModeDyn, ModeGeo, StartType, DistanceToEnd, TBallRadius.
42B2
17074
Parameter
„Geschwindigkeitsreduktionsfaktor unzulässig“ Ein Parameter der die Reduktion der Geschwindigkeit an Segmentübergängen reguliert ist ungültig. Parameter: 1.Einmal stetig differenzierbare Übergänge: VeloVertexFactorC1 2.Keinmal stetig differenzierbare Übergänge: VeloVertexFactorC0 CriticalVertexAngleLow, CriticalVertexAngleHigh.
42B3
17075
Parameter
„Helix ist Kreis“ Die Helix ist zu einem Kreis degeneriert und muss als solcher eingegeben werden.
42B4
17076
Parameter
„Helix ist Gerade“ Die Helix ist zu einer Geraden degeneriert und muss als solche eingegeben werden.
42B5
17077
Parameter
„Guider Parameter unzulässig“ Ein Parameter des Guiders führt zu logischen Fehlern und/oder zur einer FPU Exception.
42B6
17078
Adresse
„Ungültige Segmentadresse“ (INTERNER FEHLER) Das Geometriesegment hat keine gültige Geometriestruktur-Adresse oder keine gültige Dynamikstruktur-Adresse.
42B7
17079
Parameter
„Unparametrierter Generator“ (INTERNER FEHLER) Der SVB-Generator ist noch nicht parametriert worden und kann deswegen nicht arbeiten.
42B8
17080
Adresse
„Unparametrierte Tabelle“ (INTERNER FEHLER) Die Tabelle hat keine Information über die Adresse des zugehörigen Dynamikgenerators.
42BA
17082
Intern
"Die Berechnung der Bogenlänge der Verschleifung ist fehlgeschlagen (interner Fehler)."
42BB
17083
Parameter
"Der Radius der Toleranzkugel ist zu klein (kleiner als 0.1 mm)."
42BC
17084
Intern
Fehler bei der Berechnung der DXD-Software-Endlagen (interner Fehler)
42BD
17085
Funktion
"NC-Satz verletzt Software-Endlagen der Gruppe" Mindestens eine Bahnachse mit aktivierte Software-Endlagenüberwachung verletzt die Endlagen. Das Geometriesegment wird deshalb mit diesem Fehler abgelehnt.
42BE
17086
Parameter
"GROUPERR_DXD_SOFTENDCHECK"
42BF
17087
Parameter
"GROUPERR_DXD_RTTG_VELOREFERENCE"
42C0
17088
Intern
„Interpolierende Gruppe beinhaltet Achsen vom falschen Achstyp“ Eine interpolierende 3D-Gruppe darf nur mit kontinuierlich geführten Achsen vom Achstyp 1 (SERVO) bestückt sein.
42C1
17089
Intern
„Skalarprodukt nicht durchführbar“ Die Länge eines der beteiligten Vektoren ist 0.0.
42C2
17090
Intern
„Arcuscosinus nicht durchführbar“ Die Länge eines der beteiligten Vektoren ist 0.0.
42C3
17091
Parameter
„Ungültiger Tabellen-Eintragstyp“ Der angegebene Tabellen-Eintragstyp ist unbekannt.
42C4
17092
Parameter
„Ungültiger DIN66025-Infotyp“ (INTERNER FEHLER) Der angegebene DIN66025-Infotyp ist unbekannt. Bekannte Typen: G0, G1, G2, G3, G17, G18, G19.
42C5
17093
Parameter
„Ungültige Dimension“ (INTERNER FEHLER) Die CNC-Dimension ist unbekannt. Bekannte Dimensionen: 1, 2, 3. Oder: Die CNC-Dimension ist für das angegebene geometrische Objekt ungültig. Für Kreise muss die Dimension 2 oder 3 sein, für eine Helix 3.
42C6
17094
Parameter
„Geometrisches Objekt ist keine Gerade“ Die angegebene Objekt hat, als Gerade interpretiert, die Länge 0.0.
42C7
17095
Parameter
„Geometrisches Objekt ist kein Kreis“ Das angegebene Objekt hat, als Kreis interpretiert, die Länge 0.0 oder den Drehwinkel 0.0 oder den Radius 0.0.
42C8
17096
Parameter
„Geometrisches Objekt ist keine Helix“ Das angegebene Objekt hat, als Kreis interpretiert, die Länge 0.0 oder den Drehwinkel 0.0 oder den Radius 0.0. oder die Höhe 0.0.
42C9
17097
Parameter
„Sollgeschwindigkeit kleiner gleich 0.0 ungültig“ Ein Wert kleiner gleich 0.0 für die Sollgeschwindigkeit (CNC) ist unzulässig, da die Sollgeschwindigkeit definitionsgemäß positiv ist und bei Sollgeschwindigkeit 0.0 keine Bewegung generiert werden kann.
42CA
17098
Adresse
„Adresse für Look-Ahead ungültig“ (INTERNER FEHLER) Die angegebene Adresse für den Look-Ahead ist nicht gültig.
42CB
17099
Funktion
„Sollwertgeneraor SAF aktiv“ Start des Sollwertgenerators (SAF) verweigert, da die SAF-Task schon/noch aktiv ist.
42CC
17100
Funktion
„CNC Sollwertgenerierung nicht aktiv“ Stop oder Overrideänderung verweigert, da die Sollwertgenerierung nicht aktiv ist.
42CD
17101
Funktion
„CNC Sollwertgenerierung in Stopphase“ Stop oder Overrideänderung verweigert, da die Sollwertgenerierung in der Stopphase ist.
42CE
17102
Parameter
„Override unzulässig“ Ein Override unter 0.0% oder über 100.0% ist ungültig.
42CF
17103
Adresse
„Ungültige Tabellen-Adresse“ (INTERNER FEHLER) Die angegebene Tabellen-Adresse zur Initialisierung des Sollwertgenerators ist ungültig oder aber es ist kein gültiger Logger-Anschluss (Report-Datei) vorhanden.
42D0
17104
Parameter
„Ungültiger Tabellen-Eintragstyp“ Der angegebene Tabellen-Eintragstyp ist unbekannt.
42D1
17105
Speicher
„Speicherallozierung misslungen“ Speicherallozierung für Tabelle misslungen.
42D2
17106
Speicher
„Speicherallozierung misslungen“ Speicherallozierung für Filter misslungen
42D3
17107
Parameter
„Ungültiger Parameter“ Der Parameter des Filters ist unzulässig.
42D4
17108
Funktion
"Restweglöschen nicht möglich." Das Restweglöschen (nur Interpolation) schlug fehl, weil z.B. 'DelDTG' im aktuellen Verfahrsatz im NC-Programm nicht programmiert wurde
42D5
17109
Intern
"Der Sollwertgenerator der fliegenden Säge liefert inkompatible Werte (interner Fehler)."
42D6
17110
Funktion
"Achse wird intern gestoppt da sie sonst die angeforderte Zielposition überfahren würde (alter PTP-Sollwertgenerator)" Wenn z.B. bei der Online-Wandlung vom Slave zum Master eine neue Zielposition angefordert wird, die die Achse aufgrund der aktuellen Fahrsituation überfahren würde, dann wird die Achse intern gestoppt um sicherzustellen dass das Fahrziel nicht überfahren wird (alter).
42D7
17111
Funktion
"Interner Fehler bei der On-Line Wandlung des Slaves zum Master."
42D8
17112
Funktion
"Falsche Richtung bei der On-Line Wandlung des Slaves zum Master."
42DA
17114
Parameter
"Parameter der Motion Function (MF) Tabelle sind ungültig" Die Parameter der Motion Function (MF) sind unzulässig. Dies kann sich auf den erstmalig angelegten Datensatz oder auf online geänderte Daten beziehen.
42DB
17115
Parameter
"Die Parameter der Motion Function (MF) Tabelle sind ungültig" Die Parameter der Motion Function (MF) sind unzulässig. Dies kann sich auf den erstmalig angelegten Datensatz oder auf online geänderte Daten beziehen.
Fehlerursache kann sein, dass z.B. ein aktiver MF-Punkt (also kein IGNORE-Punkt) auf einen passiven MF-Punkt (also IGNORE-Punkt) zeigt.
42DC
17116
Überwachung
"Interner Fehler bei Verwendung der Motion Function (MF)" Hier ist ein interner Fehler bei Verwendung der Motion Function (MF) aufgetreten, der nicht weiter vom Anwender zu lösen ist. Bitte wenden sie sich an den TwinCAT Support.
42DD
17117
Funktion
"Achskopplung mittels Synchronisierungsgenerators wegen unzulässiger Achsdynamikwerte abgelehnt" Die Achskopplung mittels des Synchronisierungsgenerators ist abgelehnt worden, da einer der Slavedynamikparameter (Maschinendaten) unzulässig ist. Entweder ist die Maximalgeschwindigkeit, die Beschleunigung, die Verzögerung oder der Ruck kleiner gleich Null oder die erwartete Synchrongeschwindigkeit der Slaveachse ist größer als die maximal erlaubte Slavegeschwindigkeit.
42DE
17118
Funktion
"Koppelbedingungen des Synchronisierungsgenerators sind unzulässig" Bei positiver Fahrtrichtung der Masterachse muss gelten, dass die Mastersynchronposition größer als die Masterkoppelposition ist ("also in der Zukunft liegt"). Bei negativer Master-Fahrrichtung muss die Mastersynchronposition kleiner als die Masterkoppelposition sein.
42DF
17119
Überwachung
"Bewegungsprofil des Synchronisierungsgenerators verletzt eine Dynamikgrenze der Slaveachse oder eine geforderte Eigenschaft des Profils" Eine der parametrierten Überprüfungen (Checks) hat eine Überschreitung der Dynamikgrenzen (max. Geschwindigkeit, max. Beschleunigung, max. Verzögerung oder max. Ruck) der Slaveachse erkannt oder eine Profileigenschaft (z.B. Über- oder Unterschwingen in der Position oder der Geschwindigkeit) ist unzulässig.
Siehe auch zusätzliche/weitere Meldungen in der Windows Ereignisanzeige und im Meldefenster des Systemmanagers.
42E0
17120
Parameter
„Ungültiger Parameter“ Der Parameter des Encodergenerators ist unzulässig.
42E1
17121
Parameter
„Ungültiger Parameter“ Der Parameter des externen (Fifo) Generators ist unzulässig.
42E2
17122
Funktion
„Externer Generator ist aktiv“ Der externe Generator kann nicht gestartet werden, da er schon aktiv ist.
42E3
17123
Funktion
„Externer Generator ist nicht aktiv“ Der externe Generator kann nicht gestoppt werden, da er nicht aktiv ist.
42E4
17124
Funktion
"NC-Satz mit Hilfsachse verletzt Software-Endlagen der Gruppe" Mindestens eine Hilfsachse mit aktivierte Software-Endlagenüberwachung verletzt die Endlagen. Das Geometriesegment wird deshalb mit diesem Fehler abgelehnt.
42E5
17125
Funktion
"NC Satz vom Typ Bezier Kurve (Bezier Spline) enthält eine Singularität" Die Bezier Kurve (Bezier Spline) hat eine Spitze, d.h. an einem inneren Punkt streben sowohl die Krümmung als auch der Betrag der Geschwindigkeit so gegen Null, daß der Krümmungsradius unendlich ist.
Hinweis: Die Bezier Kurze sollte an genau dieser Stelle gemäß dem "Casteljau Algorithmus" geteilt werden. Diese Maßnahme erhält die Geometrie und eliminiert die innere Singularität.
42E7
17127
Parameter
„Wert für die Totzeitkompensation unzulässig“ Der Wert für die Totzeitkompensation in Sekunden für eine Slavekopplung an eine Encoder-Achse (virtuelle Achse) ist unzulässig.
Wertebereich: [0.0 ... 60.0]
Einheit: s
42E8
17128
Parameter
"GROUPERR_RANGE_NOMOTIONWINDOW"
Wertebereich: [0.0 ... 1000.0]
Einheit: z.B. mm/s
42E9
17129
Parameter
"GROUPERR_RANGE_NOMOTIONFILTERTIME"
Wertebereich: [0.0 ... 60.0]
Einheit: s
42EA
17130
Parameter
"GROUPERR_RANGE_TIMEUNITFIFO"
Wertebereich: (0.0 ... 1000.0]
Einheit: s
42EB
17131
Parameter
"GROUPERR_RANGE_OVERRIDETYPE"
Wertebereich: [1, 2]
Einheit: 1
42EC
17132
Parameter
"GROUPERR_RANGE_OVERRIDECHANGETIME"
Wertebereich: (0.0 ... 1000.0]
Einheit: s
42ED
17133
Parameter
"GROUPERR_FIFO_INVALIDDIMENSION"
Hinweis: Die FIFO-Dimension (Anzahl von Achsen) ist ab TC 2.11 Build 1547 von 8 auf 16 erhöht worden.
Wertebereich: [1 ... 8] bzw. [1 ... 16]
Einheit: 1 (Anzahl von Achsen)
42EE
17134
Adresse
"GROUPERR_ADDR_FIFOTABLE"
42EF
17135
Überwachung
"Achse wegen aktivem Stopp für Bewegungskommandos gesperrt" Die Achse/Gruppe ist für Bewegungskommandos gesperrt, da ein Stopp aktiv ist. Diese Sperre kann durch Aufrufen des Stopp-Kommandos mit Execute=FALSE oder durch einen Achs-Reset aufgehoben werden (s.a. MC_Stop und MC_Reset in TcMC2.Lib).
42F0
17136
Parameter
„Ungültige Anzahl von Hilfsachsen“ Die lokale Anzahl von Hilfsachsen stimmt nicht mit der globalen Anzahl der Hilfsachsen überein.
42F1
17137
Parameter
„Ungültiger Reduktionsparameter für Hilfsachsen“ Die Geschwindigkeitsreduktionsparameter der Hilfsachsen sind inkonsistent.
42F2
17138
Parameter
„Ungültiger Dynamikparameter für Hilfsachsen“ Die Dynamikparameter der Hilfsachsen sind inkonsistent.
42F3
17139
Parameter
„Ungültiger Koppelparameter für Hilfsachsen“ Die Koppelparameter der Hilfsachsen sind inkonsistent.
42F4
17140
Parameter
„Ungültiger Hilfsachseneintrag“ Der Hilfsachseneintrag ist leer (keine Achsbewegung).
42F6
17142
Parameter
"Ungültiger Parameter" Der Parameter für den Grenzwert der Geschwindigkeitsreduktion bei Hilfsachsen ist ungültig. Er muss im Intervall 0..1.0 liegen.
42F8
17144
Parameter
„BlockSearch - Segment nicht gefunden“ Das als Parameter angegebene Segment konnte bis zum Ende des NC-Programms nicht gefunden werden.
Mögliche Ursache:
▪
nBlockId ist nicht im durch eBlockSearchMode beschriebenen Modus angegeben
42F9
17145
Parameter
„Blocksearch – Ungültige verbleibende Segmentlänge“ Der Restweg im Parameter fLength ist falsch parametriert
42FB
17147
Überwachung
„INTERNER FEHLER“ (GROUPERR_SLAVE_INTERNAL)
42FF
17151
Überwachung
„GROUPERR_WATCHDOG“ (Kundenspezifischer Fehlercode)


Achsfehler

Fehlercodes [image] Übersicht NC-Fehler [image] Achsfehler
Achsfehler
Fehler(Hex) | Fehler(Dez) | Fehlertyp | Beschreibung
4300 | 17152 | Parameter | „Achs-ID unzulässig“ Der Wert für die Achs-ID ist unzulässig, da er z. B. bereits vergeben ist, kleiner gleich Null, größer 255 oder nicht in der Konfiguration vorhanden ist.
 |  |  | Wertebereich: [1 ... 255] | Einheit: 1
4301 | 17153 | Parameter | „Achs-Typ unzulässig“ Der Wert für den Achs-Typ ist unzulässig, da er nicht definiert ist. Typ 1: Servo Typ 2: Eil/Schleich Typ 3: Schrittmotor
 |  |  | Wertebereich: [1 ... 3] | Einheit: 1
4306 | 17158 | Parameter | „Handgeschwindigkeit langsam unzulässig“ Der Wert für die langsame Handgeschwindigkeit ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. m/min
4307 | 17159 | Parameter | „Handgeschwindigkeit schnell unzulässig“ Der Wert für die schnelle Handgeschwindigkeit ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. m/min
4308 | 17160 | Parameter | „Eilganggeschwindigkeit unzulässig“ Der Wert für die Eilganggeschwindigkeit ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. m/min
4309 | 17161 | Parameter | „Beschleunigung unzulässig“ Der Wert für die Achsbeschleunigung ist unzulässig.
 |  |  | Wertebereich: [0.0, 1000000.0] | Einheit: z. B. m/s/s
430A | 17162 | Parameter | „Verzögerung unzulässig“ Der Wert für die Achsverzögerung ist unzulässig.
 |  |  | Wertebereich: [0.0, 1000000.0] | Einheit: z. B. m/s/s
430B | 17163 | Parameter | „Ruck unzulässig“ Der Wert für die Achsruck ist unzulässig.
 |  |  | Wertebereich: [0.0, 1000000.0] | Einheit: z. B. m/s/s/s
430C | 17164 | Parameter | „Verzögerungszeit zwischen Position und Geschw. ist unzulässig (Totzeitkompensation)“ Der Wert für die Verzögerungszeit zwischen Position und Geschwindigkeit („Totzeitkompensation“) ist unzulässig.
 |  |  | Wertebereich: [0, 0.1] | Einheit: s
430D | 17165 | Parameter | „Override-Typ unzulässig“ Der Wert für den Geschwindigkeits Override-Typ ist unzulässig, da er nicht definiert ist. Typ 1: Bezogen auf interne reduzierte Geschwindigkeit (Defaultwert) Typ 2: Bezogen auf originale externe Startgeschwindigkeit
 |  |  | Wertebereich: [1 ... 4] | Einheit: 1
430E | 17166 | Parameter | "NCI: Geschwindigkeits-Sprung-Faktor ungültig" Es wurde versucht, einen ungültigen Wert für den Geschwindigkeits-Sprung-Faktor vorzugeben. Dieser Parameter wirkt nur für TwinCAT NCI.
 |  |  | Wertebereich: [0, 1000000] | Einheit: 1
430F | 17167 | Parameter | "NCI: Größe der Toleranzkugel für die Hilfsachse ungültig" Es wurde versucht, einen ungültigen Wert für die Größe der Toleranzkugel vorzugeben. Diese Kugel wirkt nur auf die Hilfsachsen!
 |  |  | Wertebereich: [0, 1000] | Einheit: z.B. mm
4310 | 17168 | Parameter | "NCI: Größe der erlaubten Abweichung für die Hilfsachse ungültig" Es wurde versucht, einen ungültigen Wert für die Größe der erlaubten Abweichung vorzugeben. Dieser Parameter wirkt nur auf die Hilfsachsen!
 |  |  | Wertebereich: [0, 10000] | Einheit: z.B. mm
4312 | 17170 | Parameter | „Referenziergeschwindigkeit in Richtung Nocken unzulässig“ Der Wert für die Referenziergeschwindigkeit in Richtung des Referenziernockens ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. m/min
4313 | 17171 | Parameter | „Referenziergeschwindigkeit in Richtung Sync unzulässig“ Der Wert für die Referenziergeschwindigkeit in Richtung des Syncimpulses (Nullspur) ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. m/min
4314 | 17172 | Parameter | „Pulsweite in positiver Richtung unzulässig“ Der Wert für die Pulsweite in positiver Richtung ist unzulässig (Pulsbetrieb). Die Nutzung der Pulsweite für eine Positionierung ist implizit über den Achsstarttyp auszuwählen. Der Pulsbetrieb entspricht einer Positionierung um einen relativen Verfahrweg, der genau der Pulsweite entspricht.
 |  |  | Wertebereich: [0.0, 1000000.0] | Einheit: z. B. mm
4315 | 17173 | Parameter | „Pulsweite in negativer Richtung unzulässig“ Der Wert für die Pulsweite in negativer Richtung ist unzulässig (Pulsbetrieb). Die Nutzung der Pulsweite für eine Positionierung ist implizit über den Achsstarttyp auszuwählen. Der Pulsbetrieb entspricht einer Positionierung um einen relativen Verfahrweg, der genau der Pulsweite entspricht.
 |  |  | Wertebereich: [0.0, 1000000.0 | Einheit: z. B. mm
4316 | 17174 | Parameter | „Pulszeit in positiver Richtung unzulässig“ Der Wert für die Pulsweite in positiver Richtung ist unzulässig (Pulsbetrieb).
 |  |  | Wertebereich: [0.0, 600.0] | Einheit: s
4317 | 17175 | Parameter | „Pulszeit in negativer Richtung unzulässig“ Der Wert für die Pulsweite in negativer Richtung ist unzulässig (Pulsbetrieb).
 |  |  | Wertebereich: [0.0, 600.0] | Einheit: s
4318 | 17176 | Parameter | „Schleichweg in positiver Richtung unzulässig“ Der Wert für den Schleichweg in positiver Richtung ist unzulässig.
 |  |  | Wertebereich: [0.0, 100000.0] | Einheit: z. B. mm
4319 | 17177 | Parameter | „Schleichweg in negativer Richtung unzulässig“ Der Wert für den Schleichweg in negativer Richtung ist unzulässig.
 |  |  | Wertebereich: [0.0, 100000.0] | Einheit: z. B. mm
431A | 17178 | Parameter | „Bremsweg in positiver Richtung unzulässig“ Der Wert für den Bremsweg in positiver Richtung ist unzulässig.
 |  |  | Wertebereich: [0.0, 100000.0] | Einheit: z. B. mm
431B | 17179 | Parameter | „Bremsweg in negativer Richtung unzulässig“ Der Wert für den Bremsweg in negativer Richtung ist unzulässig.
 |  |  | Wertebereich: [0.0, 100000.0] | Einheit: z. B. mm
431C | 17180 | Parameter | „Bremszeit in positiver Richtung unzulässig“ Der Wert für die Bremszeit in positiver Richtung ist unzulässig.
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
431D | 17181 | Parameter | „Bremszeit in negativer Richtung unzulässig“ Der Wert für die Bremszeit in negativer Richtung ist unzulässig.
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
431E | 17182 | Parameter | „Umschaltzeit von Eil- auf Schleichgang unzulässig“ Der Wert für die Umschaltzeit von Eil- auf Schleichgang ist unzulässig.
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
431F | 17183 | Parameter | „Schleichweg für Stopp unzulässig“ Der Wert für den Schleichweg für einem expliziten Stopp ist unzulässig.
 |  |  | Wertebereich: [0.0, 100000.0] | Einheit: z. B. mm
4320 | 17184 | Parameter | „Bewegungsüberwachung unzulässig“ Der Wert für die Aktivierung der Bewegungsüberwachung ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4321 | 17185 | Parameter | „Positionsfensterüberwachung unzulässig“ Der Wert für die Aktivierung der Positionsfensterüberwachung ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4322 | 17186 | Parameter | „Zielfensterüberwachung unzulässig“ Der Wert für die Aktivierung der Zielfensterüberwachung ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4323 | 17187 | Parameter | „Schleife unzulässig“ Der Wert für die Aktivierung des Schleifenweges ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4324 | 17188 | Parameter | „Bewegungsüberwachungszeit unzulässig“ Der Wert für die Bewegungsüberwachungszeit ist unzulässig.
 |  |  | Wertebereich: [0.0, 600.0] | Einheit: s
4325 | 17189 | Parameter | „Zielfensterbereich unzulässig“ Der Wert für das Zielfenster ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. mm
4326 | 17190 | Parameter | „Positionsfensterbereich unzulässig“ Der Wert für das Positionsfenster ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. mm
4327 | 17191 | Parameter | „Positionsfensterüberwachungszeit unzulässig“ Der Wert für die Positionsfensterüberwachungszeit ist unzulässig.
 |  |  | Wertebereich: [0.0, 600.0] | Einheit: s
4328 | 17192 | Parameter | „Schleifenweg unzulässig“ Der Wert für den Schleifenweg ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. mm
4329 | 17193 | Parameter | „Achszykluszeit unzulässig“ Der Wert für die Achszykluszeit ist unzulässig.
 |  |  | Wertebereich: [0.001, 0.1] | Einheit: s
432A | 17194 | Parameter | „Betriebsmodus Schrittmotor unzulässig“ Der Wert für den Schrittmotorbetriebsmodus ist unzulässig.
 |  |  | Wertebereich: [1, 2] | Einheit: 1
432B | 17195 | Parameter | „Weglänge pro Schrittmotorschritt unzulässig“ Der Wert für die Weglänge eines Schrittmotorschrittes ist unzulässig (Skalierung eines Schrittes).
 |  |  | Wertebereich: [0.000001, 1000.0] | Einheit: z. B. mm/STEP
432C | 17196 | Parameter | „Minimalgeschwindigkeit für Schrittmotorsollwertprofil unzulässig“ Der Wert für die Minimalgeschwindigkeit des Schrittmotorgeschwindigkeitsprofils ist unzulässig.
 |  |  | Wertebereich: [0.0, 1000.0] | Einheit: z. B. m/min
432D | 17197 | Parameter | „Schrittmotorstufen pro Geschwindigkeitsstufe unzulässig“ Der Wert für die Anzahl der Schritte pro Geschwindigkeitsstufe der Sollwertgenerierung ist unzulässig.
 |  |  | Wertebereich: [0, 100] | Einheit: 1
432E | 17198 | Parameter | „DWORD für die Interpretation der Achseinheiten unzulässig“ Der Wert, der Flags für die Interpretation der Positions- und Geschwindigkeitseinheiten enthält ist unzulässig.
 |  |  | Wertebereich: [0, 0xFFFFFFFF] | Einheit: 1
432F | 17199 | Parameter | „Maximalgeschwindigkeit unzulässig“ Der Wert für die maximale erlaubte Geschwindigkeit ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. m/min
4330 | 17200 | Parameter | „Bewegungsüberwachungsfenster unzulässig“ Der Wert für das Bewegungsüberwachungsfenster ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. mm
4331 | 17201 | Parameter | „PEH-Zeitüberwachung unzulässig“ Der Wert für die Aktivierung der PEH-Zeitüberwachung ist unzulässig (PEH: Positionierung Ende und Halt).
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4332 | 17202 | Parameter | „PEH-Überwachungszeit unzulässig“ Der Wert für die PEH-Überwachungszeit (Timeout) ist unzulässig (PEH: Positionierung Ende und Halt). Defaultwert: 5s
 |  |  | Wertebereich: [0.0, 600.0] | Einheit: s
4333 | 17203 | Parameter | „AXISERR_RANGE_DELAYBREAKRELEASE“
4334 | 17204 | Parameter | „AXISERR_RANGE_DATAPERSISTENCE“
433A | 17210 | Parameter | „AXISERR_RANGE_POSDIFF_FADING_ACCELERATION“
433B | 17211 | Parameter | "Signaltyp des 'Fast Axis Stop' unzulässig" Der Wert für den Signaltyp des 'Fast Axis Stop' ist unzulässig [0...5].
4340 | 17216 | Initialisierung | „Initialisierung Achse“ Achse ist nicht initialisiert worden. Achse wurde zwar erzeugt, allerdings nicht weiter initialisiert (1. Initialisierung Achs-IO, 2. Initialisierung Achse, 3. Reset Achse).
4341 | 17217 | Adresse | „Adresse Gruppe“ Achse besitzt keine Gruppe (Group) bzw. die Gruppenadresse ist nicht initialisiert worden (Gruppe beinhaltet die Sollwertgenerierung).
4342 | 17218 | Adresse | „Adresse Geber“ Achse besitzt keinen Geber (Encoder) bzw. die Geberadresse ist nicht initialisiert worden.
4343 | 17219 | Adresse | „Adresse Regler“ Achse besitzt keinen Regler (Controller) bzw. die Regleradresse ist nicht initialisiert worden.
4344 | 17220 | Adresse | „Adresse Antrieb“ Achse besitzt keinen Antrieb (Drive) bzw. die Antriebadresse ist nicht initialisiert worden.
4345 | 17221 | Adresse | „Adresse Achsinterface SPS zur NC“ Achse besitzt kein Achsinterface von der SPS zur NC (PLC to NC) bzw. ist die Achsinterfaceadresse nicht initialisiert worden.
4346 | 17222 | Adresse | „Adresse Achsinterface NC zur SPS“ Achse besitzt kein Achsinterface von der NC zur SPS (NC to PLC) bzw. ist die Achsinterfaceadresse nicht initialisiert worden.
4347 | 17223 | Adresse | „Größe Achsinterface NC zur SPS unzulässig“ (INTERNER FEHLER) Die Größe des Achsinterfaces von der NC zur SPS (NC to PLC) ist unzulässig.
4348 | 17224 | Adresse | „ Größe Achsinterface SPS zur NC unzulässig “(INTERNER FEHLER) Die Größe des Achsinterfaces von der SPS zur NC (PLC to NC) ist unzulässig.
4356 | 17238 | Überwachung | „Reglerfreigabe“ Reglerfreigabe für Achse nicht vorhanden (s. Achsinterface SPS®NC). Diese Freigabe wird z. B. für einen Positionierauftrag einer Achse überprüft.
4357 | 17239 | Überwachung | „Vorschubfreigabe Minus“ Vorschubfreigabe für negative Verfahrrichtung nicht vorhanden (s. Achsinterface SPS®NC) Diese Freigabe wird z. B. für einen Positionierauftrag einer Achse in negativer Richtung überprüft.
4358 | 17240 | Überwachung | „Vorschubfreigabe Plus“ Vorschubfreigabe für positive Verfahrrichtung nicht vorhanden (s. Achsinterface SPS®NC) Diese Freigabe wird z. B. für einen Positionierauftrag einer Achse in positiver Richtung überprüft.
4359 | 17241 | Überwachung | „Sollgeschwindigkeit unzulässig“ Die geforderte Sollgeschwindigkeit für einen Positionierauftrag ist nicht erlaubt. Dies kann der Fall sein, wenn die Geschwindigkeit kleiner gleich Null, größer als die maximal erlaubte Achsgeschwindigkeit oder bei Servo-Antrieben größer als die Bezugsgeschwindigkeit der Achse ist (s. Achs- und Driveparameter).
435A | 17242 | Überwachung | „Verfahrweg kleiner ein Geberinkrement“ (INTERNER FEHLER) Der Verfahrweg einer Achse ist bezogen auf einen Positionierauftrag kleiner einem Geberinkrement (s. Skalierungsfaktor). Diese Information wird allerdings intern so verwertet, dass ohne Rückgabe einer Fehlermeldung die Positionierung als beendet gilt.
435B | 17243 | Überwachung | „Überwachung Sollbeschleunigung“ (INTERNER FEHLER) Die Sollbeschleunigung hat die maximal zulässigen Beschleunigungs- bzw. Verzögerungsparameter der Achse überschritten
435C | 17244 | Überwachung | „PEH-Zeitüberwachung“ Die PEH-Zeitüberwachung hat nach einer Positionierung und nach Ablauf der daran anschließenden PEH-Überwachungszeit erkannt, dass das Zielpositionsfenster nicht erreicht worden ist. Folgende Überprüfungen müssen vorgenommen werden: Ist die PEH-Überwachungszeit im Sinne einer Timeout Überwachung genügend groß eingestellt (z.B. 1-5s) ? Die PEH-Überwachungszeit muss deutlich größer als die Zielpositionsüberwachungszeit gewählt werden. Sind die Kriterien für die Zielpositionsüberwachung (Bereichfenster und Zeit) zu streng eingestellt ? Anmerkung: Die PEH-Zeitüberwachung wirkt nur bei aktiver Zielpositionsüberwachung!
435D | 17245 | Überwachung | „Encoder-Existenz-Überwachung / Bewegungsüberwachung“ Der Encoderistwert hat sich bei aktiver Positionierung für eine vorgegebene Überwachungszeit von NC-Zyklus zu NC-Zyklus durchgehend um weniger als die vorgegebene Mindestbewegungungsschranke geändert. => Prüfen ob Achse mechanisch blockiert ist, oder das Encodersystem ausgefallen ist, etc..Anmerkung: Die Überwachung wird nicht im logischen Stillstand (Lageregelung) der Achse ausgewertet, sondern nur bei aktiver Positionierung (würde auch keinen Sinn machen, wenn es im Stillstand eine mechanische Haltebremse gibt)!
435E | 17246 | Überwachung | „Schleifenweg kleiner als Bremsweg“ Die angewählte Schleifenweg ist betragsmäßig kleiner gleich dem positiven bzw. negativen Bremsweg. Dies ist nicht erlaubt.
4361 | 17249 | Überwachung | „Zeitbereichsüberschreitung (Zukunft)“ Die berechnete Position liegt zu weit in der Zukunft (z.B. bei der Konvertierung von einer Position in eine zugehörige DC-Zeit ).
4362 | 17250 | Überwachung | „Zeitbereichsüberschreitung (Vergangenheit)“ Die berechnete Position liegt zu weit in der Vergangenheit (z.B. bei der Konvertierung von einer Position in eine zugehörige DC-Zeit).
4363 | 17251 | Überwachung | „Position nicht ermittelbar“ Die angefragte Position ist mathematisch nicht zu ermitteln, da sie a) in der Vergangenheit niemals erreicht wurde oder b) in Zukunft niemals erreicht werden wird (z.B. wenn die Achsgeschwindigkeit Null ist oder wenn aufgrund einer Beschleunigung eine Bewegungsumkehr stattfindet).
4364 | 17252 | Überwachung | „Position nicht ermittelbar (widersprüchliche Fahrtrichtung)“ Die vom Aufrufer der Funktion erwartete Fahrtrichtung weicht von der tatsächlichen Fahrtrichtung ab (Widerspruch zwischen SPS und NC Sicht bei z.B. der Konvertierung von einer Position in eine DC-Zeit).
43A0 | 17312 | Intern | „Achsfolgefehler“ Folgefehler, der durch einen anderen verursachenden Fehler einer weiteren Achse veranlasst worden ist. Achsfolgefehler können im Zusammenhang mit Master/Slave-Kopplung oder mit einer mehrachsigen interpolierenden DXD-Gruppe auftreten.


Geberfehler

Fehlercodes [image] Übersicht NC-Fehler [image] Geberfehler
Geberfehler
Fehler(Hex) | Fehler(Dez) | Fehlertyp | Beschreibung
4400 | 17408 | Parameter | „Geber-ID unzulässig“ Der Wert für die Geber-ID ist unzulässig, da er z. B. bereits vergeben ist, kleiner gleich Null ist oder größer 255 ist.
 |  |  | Wertebereich: [1 ... 255] | Einheit: 1
4401 | 17409 | Parameter | „Geber-Typ unzulässig“ Der Wert für den Geber-Typ ist unzulässig, da er nicht definiert ist. Typ 1: Simulation (Inkremental) Typ 2: M3000 (24 Bit Absolut) Typ 3: M31x0 (24 Bit Inkremental) Typ 4: KL5101 (16 Bit Inkremental) Typ 5: KL5001 (24 Bit Absolut SSI) Typ 6: KL5051 (16 Bit BISSI)
 |  |  | Wertebereich: [1 ... 6] | Einheit: 1
4402 | 17410 | Parameter | „Gebermodus“ Der Wert für den Gebermodus (Betriebsart) ist unzulässig. Modus 1: Ermittlung der Istposition Modus 2: Ermittlung der Istposition und der Istgeschwindigkeit (Filter)
 |  |  | Wertebereich: [1, 2] | Einheit: 1
4403 | 17411 | Parameter | „Geberzählrichtung invers ?“ Das Flag für die Geberzählrichtung ist unzulässig. Flag 0: Positive Geberzählrichtung Flag 1: Negative Geberzählrichtung
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4404 | 17412 | Initialisierung | „Referenzierstatus“ Das Flag für den Referenzierstatus ist unzulässig. Flag 0: Achse ist nicht referenziert Flag 1: Achse ist referenziert
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4405 | 17413 | Parameter | „Geberinkremente pro physikalische Geberumdrehung“ Der Wert für die Anzahl der Geberinkremente pro physikalische Geberumdrehung ist unzulässig. Dieser Wert dient zur softwaretechnischen Geberüberlauf- und Geberunterlaufverrechnung.
 |  |  | Wertebereich: [255, 0xFFFFFFFF] | Einheit: INC
4406 | 17414 | Parameter | „Skalierungsfaktor“ Der Wert für den Skalierungsfaktor ist unzulässig. Dieser Skalierungsfaktor gewichtet ein Geberinkrement (INC) zu einer physikalischen Einheit wie z.B. Millimeter oder Grad.
 |  |  | Wertebereich: [0.000001, 100.0] | Einheit: z. B. mm/INC
4407 | 17415 | Parameter | „Positionsoffset (Nullpunktoffset)“ Der Wert für den Positionsoffset des Gebers ist unzulässig. Dieser Wert wirkt sich additiv zu der verrechneten Geberposition aus und wird in den physikalischen Einheit des Gebers interpretiert.
 |  |  | Wertebereich: [-1000000.0, 1000000.0] | Einheit: z. B. mm
4408 | 17416 | Parameter | „Modulofaktor“ Der Wert für den Modulofaktor des Gebers ist unzulässig.
 |  |  | Wertebereich: [1.0, 1.0E+9] | Einheit: z. B. mm oder Grad
4409 | 17417 | Parameter | „Positionsfilterzeit“ Der Wert für die Istpositionsfilterzeit ist unzulässig (P-T1-Filter).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
440A | 17418 | Parameter | „Geschwindigkeitsfilterzeit“ Der Wert für die Istgeschwindigkeitsfilterzeit ist unzulässig (P-T1-Filter).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
440B | 17419 | Parameter | „Beschleunigungsfilterzeit“ Der Wert für die Istbeschleunigungsfilterzeit ist unzulässig (P-T1-Filter).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
440C | 17420 | Initialisierung | „Zykluszeit unzulässig“ (INTERNER FEHLER) Der Wert für die SAF-Zykluszeit der Istwertberechnung ist unzulässig (z. B. kleiner gleich Null).
440D | 17421 | Initialisierung | „ “ ENCERR_RANGE_UNITFLAGS
440E | 17422 | Parameter | „Istpositionskorrektur / Messsystemfehlerkorrektur“ Der Wert für die Aktivierung der Istpositionskorrektur („Meßsystemfehlerkorrektur“) ist unzulässig.
 |  |  | Wertebereich: [0, 1] |
440F | 17423 | Parameter | „Filterzeit Istpositionskorrektur “ Der Wert für die Istpositionskorrekturfilterzeit ist unzulässig (P-T1-Filter).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: 1
4410 | 17424 | Parameter | „Suchrichtung für Referenziernocken invers“ Der Wert für die Suchrichtung des Referenziernockens bei einem Referenziervorgang ist unzulässig. Wert 0: Positive Richtung Wert 1: Negative Richtung
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4411 | 17425 | Parameter | „Suchrichtung für Syncimpuls (Nullimpuls) invers“ Der Wert für die Suchrichtung des Syncimpuls (Nullimpuls) bei einem Referenziervorgang ist unzulässig. Wert 0: Positive Richtung Wert 1: Negative Richtung
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4412 | 17426 | Parameter | „Referenzposition“ Der Wert für die Referenzposition bei einem Referenziervorgang ist unzulässig.
 |  |  | Wertebereich: [-1000000.0, 1000000.0] | Einheit: z. B. mm
4413 | 17427 | Parameter | „Abstandsüberwachung zwischen Aktivierung des Hardwarelatch und Eintritt des Syncimpuls“ (NICHT IMPLEMENTIERT) Das Flag für die Abstandsüberwachung zwischen Aktivierung des Hardwarelatch und Eintritt des Sync/Nullimpuls („latch valid“) ist unzulässig. Wert 0: Passiv Wert 1: Aktiv
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4414 | 17428 | Parameter | „Mindestabstand zwischen Aktivierung des Hardwarelatch und Eintritt des Syncimpuls“ (NICHT IMPLEMENTIERT) Der Wert für den Mindestabstand in Inkrementen zwischen der Aktivierung des Hardwarelatch und Eintritt des Sync/Nullimpuls („latch valid“) bei einem Referenziervorgang ist unzulässig.
 |  |  | Wertebereich: [0, 65536] | Einheit: INC
4415 | 17429 | Parameter | „Externer Syncimpuls“ (NICHT IMPLEMENTIERT) Der Wert für die Aktivierung bzw. Deaktivierung des externen Syncimpuls bei einem Referenziervorgang ist unzulässig. Wert 0: Passiv Wert 1: Aktiv
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4416 | 17430 | Parameter | „Skalierung Rauschanteil unzulässig“ Der Wert für die Skalierung (Gewichtung) des synthetischen Rauschanteils ist unzulässig. Dieser Parameter existiert nur beim Simulationsencoder und dient einer realistischen Simulation.
 |  |  | Wertebereich: [0, 1000000] | Einheit: 1
4417 | 17431 | Parameter | „Toleranzfenster für Modulo-Achs-Start“ Der Wert für das Tolerenzfenster beim Modulo-Achsstart ist unzulässig. Dieser Wert muss größer gleich Null und kleiner als die Hälfte der Encoder-Modulo-Periode sein (z. B. im Intervall [0.0,180.0) ).
 |  |  | Wertebereich: [0.0, 180.0], Max: 0.5*Modulo-Periode | Einheit: z. B. mm oder Grad
4418 | 17432 | Parameter | „Encoder-Referenziermodus“ Der Wert für den Encoder Referenziermodus ist unzulässig bzw. wird für diesen Encodertyp nicht unterstützt.
 |  |  | Wertebereich: [0, 5] | Einheit: 1
4419 | 17433 | Parameter | „Encoder-Auswerterichtung“ Der Wert für die Encoder-Auswerterichtung (log. Zählrichtung) ist unzulässig.
 |  |  | Wertebereich: [0, 3] | Einheit: 1
441A | 17434 | Parameter | „Encoder-Bezugsmaßsystem“ Der Wert für das Encoder-Bezugsmaßsystem (0: INKREMENTAL, 1: ABSOLUT, 2: ABSOLUT+MODULO) ist unzulässig.
 |  |  | Wertebereich: [0, 2] | Einheit: 1
441B | 17435 | Parameter | „Encoder-Positionsinitialisierungsmodus“ Der Wert für den Encoder-Positionsinitialisierungsmodus bei Systemstart ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
441C | 17436 | Parameter | „Encoder-Vorzeicheninterpretation (UNSIGNED/SIGNED-Datentyp)“ Der Wert für die Encoder-Vorzeicheninterpretation (Datentyp) der Encoder-Istinkremente (0: default/nicht definiert, 1: UNSIGNED, 2: SIGNED) ist unzulässig.
 |  |  | Wertebereich: [0, 2] | Einheit: 1
4420 | 17440 | Parameter | „Software Endlagenüberwachung Minimum unzulässig“ Der Wert für die Aktivierung der Software Endlagenüberwachung Minimum ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4421 | 17441 | Parameter | „Software Endlagenüberwachung Maximum unzulässig“ Der Wert für die Aktivierung der Software Endlagenüberwachung Maximum ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4422 | 17442 | Funktion | „Istwertsetzen liegt außerhalb des Wertebereiches“ Die Funktion „Istwertsetzen“ kann nicht ausgeführt werden, da die neue Istposition außerhalb des vorgesehenen Wertebereiches liegt.
 |  |  | Wertebereich: [-1000000.0, 1000000.0] | Einheit: z. B. mm
4423 | 17443 | Parameter | „Software Endlage Minimum unzulässig“ Der Wert für die Software Endlage Minimum ist unzulässig.
 |  |  | Wertebereich: [-1000000000.0, 1000000000.0] | Einheit: z. B. mm
4424 | 17444 | Parameter | „Software Endlage Maximum unzulässig“ Der Wert für die Software Endlage Maximum ist unzulässig.
 |  |  | Wertebereich: [-1000000000.0, 1000000000.0] | Einheit: z. B. mm
4425 | 17445 | Parameter | „Filtermaske für Encoder Rohwert unzulässig“ Der Wert für die Filtermaske des Encoder-Rohwertes in Inkrementen ist unzulässig.
 |  |  | Wertebereich: [0x0, 0xFFFFFFFF] | Einheit: 1
4426 | 17446 | Parameter | „Referenzmaske für Encoder Rohwert unzulässig“ Der Wert für die Referenzmaske (Inkremente pro Geberumdrehung, Absolut-Auflösung) des Encoder-Rohwertes in Inkrementen ist unzulässig. Dieser Wert dient z.B. für das Referenzieren einer Achse mit dem Referenziermode "Software Sync".
 |  |  | Wertebereich: [0x0000000F, 0xFFFFFFFF] | Einheit: 1
4430 | 17456 | Funktion | „Aktivierung Hardwarelatch (Geber)“ Die Aktivierung des Geber-Hardwarelatch wird implizit durch den Referenziervorgang ausgelöst. Falls bereits diese Funktion zuvor ausgelöst worden ist und ein Latchwert bisher nicht gültig geworden ist („latch valid“), wird ein erneuter Aufruf dieser Funktion mit diesem Fehler abgelehnt.
4431 | 17457 | Funktion | „Aktivierung externer Hardwarelatch / Meßtasterfunktion (Geber)“ Die Aktivierung des externen Hardwarelatch (nur für KL5101, SERCOS, AX2xxx verfügbar) wird explizit durch ein ADS-Kommando ausgelöst (Aufruf aus SPS-Programm oder Visual Basic Oberfläche). Falls bereits diese Funktion zuvor ausgelöst worden ist und der Latchwert bisher nicht durch ein externes Signal gültig geworden ist („extern latch valid“ oder "Meßtaster gelatcht" bzw. "Echtzeitstatusbit"), wird ein erneuter Aufruf dieser Funktion mit diesem Fehler abgelehnt. Ebenfalls ist es möglich, dass diese Funktion wegen einer anderen zeitgleichen Funktion, wie das Referenzieren einer Inkrementalencoderachse, nicht ausgeführt werden kann.
4432 | 17458 | Funktion | „Aktivierung externer Hardwarelatch (Geber)“ Falls zuvor ein Referenziervorgang ausgelöst worden ist und die Hardware noch einen gültigen Latchwert signalisiert („latch valid“), darf diese Funktion nicht ausgelöst werden. Allerdings kann dieser Fehler in der Praxis quasi niemals auftreten.
4433 | 17459 | Funktion | „Aktivierung externer Hardwarelatch / Messtasterfunktion (Geber)“ Diese Funktion ist zuvor aktiviert worden und seit dem noch nicht fertig geworden (die interne Handshake-Kommunikation zwischen NC und IO-Gerät ist noch aktiv). In der Zwischenzeit ist eine erneute Aktivierung nicht erlaubt und wird deshalb mit einem Fehler abgewiesen. (Falls bereits diese Funktion zuvor ausgelöst worden ist und die Hardware noch signalisiert, dass der externe Latchwert schon gültig ist („extern latch valid“ oder "Messtaster gelatcht" bzw. "Echtzeitstatusbit"), darf eine erneute Aktivierung nicht ausgeführt werden. In diesem Fall würde irrtümlich sofort die Gültigkeit des externen Hardwarelatch signalisiert werden, allerdings noch mit einem alten Latchwert.)
4434 | 17460 | Überwachung | „Encoder-Funktion wird nicht unterstützt“ Es ist eine Encoder-Funktionalität ausgelöst worden, die nicht zur Benutzung freigegeben ist bzw. die nicht implementiert ist.
4435 | 17461 | Überwachung | „Encoder-Funktion bereits aktiv“ Es ist eine Encoder-Funktionalität ausgelöst worden, die nicht aktiviert werden kann, da sie bereits aktiv ist.
4440 | 17472 | Initialisierung | „Initialisierung Geber“ Geber ist nicht initialisiert worden. Achse wurde zwar erzeugt, allerdings nicht weiter initialisiert (1. Initialisierung Achs-IO, 2. Initialisierung Achse, 3. Reset Achse).
4441 | 17473 | Adresse | „Adresse Achse“ Geber besitzt keine Achse bzw. die Achsadresse ist nicht initialisiert worden.
4442 | 17474 | Adresse | „Adresse IO-Eingangsstruktur“ Antrieb besitzt keine gültige IO-Eingangsadresse im Prozessabbild.
4443 | 17475 | Adresse | „Adresse IO-Ausgangsstruktur“ Geber besitzt keine gültige IO-Ausgangsadresse im Prozessabbild.
4450 | 17488 | Überwachung | „Unterlaufüberwachung von Geberzähler“ Der Geberinkrementalzähler ist unterlaufen worden („underflow“).
4451 | 17489 | Überwachung | „Überlaufüberwachung von Geberzähler“ Der Geberinkrementalzähler ist überlaufen worden („overflow“).
4460 | 17504 | Überwachung | „Software Endlage Minimum (Achsstart)“ Bei aktiver Software-Endlagenüberwachung für Minimum ist auf eine Position gestartet worden, die unterhalb der Softwareendlage Minimum liegt.
4461 | 17505 | Überwachung | „Software Endlage Maximum (Achsstart)“ Bei aktiver Software-Endlagenüberwachung für Maximum ist auf eine Position gestartet worden, die oberhalb der Softwareendlage Maximum liegt.
4462 | 17506 | Überwachung | „Software Endlage Minimum (Positioniervorgang)“ Bei aktiver Software-Endlagenüberwachung für Minimum hat die Istposition die Softwareendlage Minimum unterschritten. Bei Servo-Achsen (kontinuierlich geführte Achsen) ist diese Schranke um den Betrag des parametrierten Schleppabstandfensters (Position) erweitert worden.
4463 | 17507 | Überwachung | „Software Endlage Maximum (Positioniervorgang)“ Bei aktiver Software-Endlagenüberwachung für Maximum hat die Istposition die Softwareendlage Maximum überschritten. Bei Servo-Achsen (kontinuierlich geführte Achsen) ist diese Schranke um den Betrag des parametrierten Schleppabstandfensters (Position) erweitert worden.
4464 | 17508 | Überwachung | „Encoder Hardwarefehler“ Der Antrieb bzw. das Encodersystem meldet einen Hardwarefehler des Encoders. Ein optionaler Fehlercode ist voraussichtlich der Meldung in der Ereignisanzeige zu entnehmen.
4465 | 17509 | Überwachung | „Positionsinitialisierungsfehler bei Systemstart“ Beim erstmaligen Initialisieren der Istposition lag diese für alle drei Initialisierungsversuche (ohne Über-/Unterlauf, mit Unterlauf und mit Überlauf ) außerhalb der Positionsendlagen Minimum und Maximum.
4470 | 17520 | Überwachung | „SSI-Wandlung fehlerhaft bzw. nicht fertig geworden“ Die SSI-Wandlung des FOX 50 Moduls ist für mehrere NC-Zyklen fehlerhaft gewesen bzw. nicht fertig geworden.
44A2 | 17570 | Überwachung | „ENCERR_ADDR_CONTROLLER“
44A3 | 17571 | Überwachung | „ENCERR_INVALID_CONTROLLERTYPE“


Reglerfehler

Fehlercodes [image] Übersicht NC-Fehler [image] Reglerfehler
Reglerfehler
Fehler(Hex) | Fehler(Dez) | Fehlertyp | Beschreibung
4500 | 17664 | Parameter | „Regler-ID unzulässig“ Der Wert für die Regler-ID ist unzulässig, da er z. B. bereits vergeben ist, kleiner gleich Null ist oder größer 255 ist.
 |  |  | Wertebereich: [1 ... 255] | Einheit: 1
4501 | 17665 | Parameter | „Regler-Typ unzulässig“ Der Wert für den Regler-Typ ist unzulässig, da er nicht definiert ist. Typ 1: P-Regler (Position) . . . Typ 7: Eil/Schleich-Regler Typ 8: Schrittmotor-Regler Typ 9: Sercos-Regler
 |  |  | Wertebereich: [1 ... 8] | Einheit: 1
4502 | 17666 | Parameter | „Betriebsmodus Regler unzulässig“ Der Wert für den Reglerbetriebsmodus ist unzulässig.
 |  |  | Wertebereich: [1] | Einheit: 1
4503 | 17667 | Parameter | „Gewichtung der Geschwindigkeitsvorsteuerung unzulässig“ Der Wert für die prozentuale Gewichtung der Geschwindigkeitsvorsteuerung ist unzulässig. Als Standard ist der Parameter mit 1.0 (100%) vorbesetzt.
 |  |  | Wertebereich: [0.0 ... 1.0] | Einheit: %
4504 | 17668 | Parameter | „Schleppabstandsüberwachung (Position) unzulässig“ Der Wert für die Aktivierung der Schleppabstandsüberwachung ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4505 | 17669 | Parameter | „Schleppüberwachung (Geschwindigkeit) unzulässig“ Der Wert für die Aktivierung der Schleppgeschwindigkeitsüberwachung (Geschwindigkeit) ist unzulässig.
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4506 | 17670 | Parameter | „Schleppabstandsfenster (Position) unzulässig“ Der Wert für das Schleppabstandsfenster (maximal zulässiger Schleppabstand) ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. mm
4507 | 17671 | Parameter | „Schleppfilterzeit (Position) unzulässig“ Der Wert für die Schleppfilterzeit (Position) ist unzulässig.
 |  |  | Wertebereich: [0.0, 600.0] | Einheit: s
4508 | 17672 | Parameter | „Schleppgeschwindigkeitsfenster (Geschwindigkeit) unzulässig“ Der Wert für das Schleppgeschwindigkeitsfenster (Geschwindigkeit) ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. m/min
4509 | 17673 | Parameter | „Schleppfilterzeit (Geschwindigkeit) unzulässig“ Der Wert für die Schleppfilterzeit (Geschwindigkeit) ist unzulässig.
 |  |  | Wertebereich: [0.0, 600.0] | Einheit: s
4510 | 17680 | Parameter | „Proportionalverstärkung Kv bzw. Kp (regler) unzulässig“ Positions Der Wert für die Proportionalverstärkung (Kv-Faktor bzw. Kp-Faktor) ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. mm/s/mm
4511 | 17681 | Parameter | „Nachstellzeit Tn (regler) unzulässig“ Positions Der Wert für die Nachstellzeit ist unzulässig (I-Anteil des PID-T1-Reglers).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
4512 | 17682 | Parameter | „Vorhaltzeit Tv (regler) unzulässig“ Positions Der Wert für die Vorhaltzeit ist unzulässig (D-Anteil des PID-T1-Reglers).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
4513 | 17683 | Parameter | „Dämpfungszeit Td (regler) unzulässig“ Positions Der Wert für die Dämpfungszeit ist unzulässig (D-Anteil des PID-T1-Reglers).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
4514 | 17684 | Funktion | „Aktivieren des automatischen Offsetabgleichs unzulässig“ Das Aktivieren des automatischen Offsetabgleichs ist nur für bestimmte Reglertypen (ohne I-Anteil) möglich.
4515 | 17685 | Parameter | „Zusätzliche Proportionalverstärkung Kv bzw. Kp (regler) unzulässig“ Positions Der Wert für den zweiten Satz der Proportionalverstärkung (Kv-Faktor bzw. Kp-Faktor) ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. mm/s/mm
4516 | 17686 | Parameter | „Bezugsgeschwindigkeit für zusätzliche Proportionalverstärkung Kv bzw. Kp (regler) unzulässig“ Positions Der Wert für die prozentuale Angabe der Bezugsgeschwindigkeit, ab der die zusätzliche Proportionalverstärkung gilt ist unzulässig. Als Standard Einstellung ist der Parameter mit 0.5 (50%) vorbesetzt.
 |  |  | Wertebereich: [0.0 ... 1.0] | Einheit: %
4517 | 17687 | Parameter | „Proportionalverstärkung Pa (anteil) unzulässig“ Beschleunigungs Der Wert für die Proportionalverstärkung (Pa-Faktor) ist unzulässig.
 |  |  | Wertebereich: [0.0, 1000000.0] | Einheit: s
4518 | 17688 | Parameter | „Proportionalverstärkung Kv (regler) unzulässig“ Geschwindigkeits Der Wert für die Proportionalverstärkung (Kv-Faktor) ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: 1
4519 | 17689 | Parameter | „Nachstellzeit Tn (regler) unzulässig“ Geschwindigkeits Der Wert für die Nachstellzeit ist unzulässig (I-Anteil des PID-T1-Reglers).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
451A | 17690 | Adresse | "CONTROLERR_RANGE_ACCJUMPLIMITINGMODE"
451B | 17691 | Adresse | "CONTROLERR_RANGE_ACCJUMPVALUE"
451C | 17692 | Adresse | "CONTROLERR_RANGE_FILTERTIME"
451D | 17693 | Parameter | „Totzone ist unzulässig“ Der Wert für die Totzone (neutrale Zone) des Positions- bzw. des Geschwindigkeitsfehlers (Regelabweichung) ist unzulässig (gilt für komplexere Regler mit Geschwindigkeits- oder Momenteninterface).
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: mm bzw. mm/s
4520 | 17696 | Parameter | „Vorhaltzeit Tv (regler) unzulässig“ Geschwindigkeits Der Wert für die Vorhaltzeit ist unzulässig (D-Anteil des PID-T1-Reglers).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
4521 | 17697 | Parameter | „Dämpfungszeit Td (regler) unzulässig“ Geschwindigkeits Der Wert für die Dämpfungszeit ist unzulässig (D-Anteil des PID-T1-Reglers). Wertevorschlag: 0.1 * Tv
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
4522 | 17698 | Parameter | "CONTROLERR_RANGE_IOUTPUTLIMIT"
4523 | 17699 | Parameter | "CONTROLERR_RANGE_DOUTPUTLIMIT"
4524 | 17700 | Parameter | "CONTROLERR_RANGE_POSIDISABLEWHENMOVING"
4540 | 17728 | Initialisierung | „Initialisierung Regler“ Regler ist nicht initialisiert worden. Regler wurde zwar erzeugt, allerdings nicht weiter initialisiert (1. Initialisierung Regler, 2. Reset Regler).
4541 | 17729 | Adresse | „Adresse Achse“ Regler kennt seine Achse (Axis) nicht bzw. die Achsadresse ist nicht initialisiert worden.
4542 | 17730 | Adresse | „Adresse Antrieb“ Regler kennt seinen Antrieb (Drive) nicht bzw. die Antriebadresse ist nicht initialisiert worden.
4550 | 17744 | Überwachung | „Schleppabstandsüberwachung (Position)“ Bei aktiver Schleppabstandsüberwachung (Position) ist eine Schleppabstandsüberschreitung aufgetreten, die vom Betrag größer dem Schleppabstandsfenster gewesen ist und zeitlich länger andauerte, als die parametrierte Schleppfilterzeit.
4551 | 17745 | Überwachung | „Schleppüberwachung (Geschwindigkeit)“ Bei aktiver Schleppgeschwindigkeitsüberwachung (Geschwindigkeit) ist eine Schleppgeschwindigkeitsüberschreitung aufgetreten, die vom Betrag größer dem Schleppfenster gewesen ist und zeitlich länger andauerte, als die parametrierte Schleppfilterzeit.
45A0 | 17824 | Überwachung | "CONTROLERR_RANGE_AREA_ASIDE"
45A1 | 17825 | Überwachung | "CONTROLERR_RANGE_AREA_BSIDE"
45A2 | 17826 | Überwachung | "CONTROLERR_RANGE_QNENN"
45A3 | 17827 | Überwachung | "CONTROLERR_RANGE_PNENN"
45A4 | 17828 | Überwachung | "CONTROLERR_RANGE_AXISIDPRESP0"


Antriebfehler

Fehlercodes [image] Übersicht NC-Fehler [image] Antriebfehler
Antriebfehler
Fehler(Hex) | Fehler(Dez) | Fehlertyp | Beschreibung
4600 | 17920 | Parameter | „Antrieb-ID unzulässig“ Der Wert für die Antrieb-ID ist unzulässig, da er z. B. bereits vergeben ist, kleiner gleich Null ist oder größer 255 ist.
 |  |  | Wertebereich: [1 ... 255] | Einheit: 1
4601 | 17921 | Parameter | „Antrieb-Typ unzulässig“ Der Wert für den Antriebs-Typ ist unzulässig, da er nicht definiert ist.
 |  |  | Wertebereich: [1, 20] | Einheit: 1
4602 | 17922 | Parameter | „Betriebsmodus Antrieb unzulässig“ Der Wert für den Antriebbetriebsmodus ist unzulässig (Modus 1: Standard).
 |  |  | Wertebereich: [1] | Einheit: 1
4603 | 17923 | Parameter | „Motorpolarität invers ?“ Das Flag für die Motorpolarität ist unzulässig. Flag 0: Positive Motorpolarität Flag 1: Negative Motorpolarität
 |  |  | Wertebereich: [0, 1] | Einheit: 1
4604 | 17924 | Parameter | „Driftkompensation/Geschwindigkeitsoffset (DAC-Offset)“ Der Wert für die Driftkompensation (DAC-Offset) ist unzulässig.
 |  |  | Wertebereich: [-100.0, 100.0] | Einheit: z. B. m/min
4605 | 17925 | Parameter | „Bezugsgeschwindigkeit (Geschwindigkeitsvorsteuerung)“ Der Wert für die Bezugsgeschwindigkeit (Geschwindigkeitsvorsteuerung oder auch Referenzgeschwindigkeit genannt) ist unzulässig.
 |  |  | Wertebereich: [0.0, 10000.0] | Einheit: z. B. m/min
4606 | 17926 | Parameter | „Referenzoutput in Prozent“ Der Wert für den Referenzoutput in Prozent ist unzulässig. Der Wert 1.0 (100 %) entspricht üblicherweise einer Spannung von 10.0 V.
 |  |  | Wertebereich: [0.0, 5.0] | Einheit: %
4607 | 17927 | Parameter | „Quadrantenausgleichsfaktor“ Der Wert für den Quadrantenausgleichsfaktor ist unzulässig.
 |  |  | Wertebereich: [0.0, 100.0] | Einheit: 1
4608 | 17928 | Parameter | „Geschwindigkeitsstützstelle in Prozent“ Der Wert für die Geschwindigkeitsstützstelle in Prozent ist unzulässig. Der Wert 1.0 entspricht 100 Prozent.
 |  |  | Wertebereich: [0.01, 1.0] | Einheit: %
4609 | 17929 | Parameter | „Ausgabestützstelle in Prozent“ Der Wert für die Ausgabestützstelle in Prozent ist unzulässig. Der Wert 1.0 entspricht 100 Prozent.
 |  |  | Wertebereich: [0.01, 1.0] | Einheit: %
460A | 17930 | Parameter | „Minimale bzw. maximale Ausgabeschranke (Ausgabelimitierung)“ Der Wert für die minimale und/oder maximale Ausgabeschranke ist unzulässig. Dies ist der Fall, wenn der Wertebereich überschritten wird, die maximale Schranke kleiner der minimalen Schranke ist oder der Bereich zwischen minimaler und maximaler Schranke gleich Null ist. Die Voreinstellung beträgt für die minimale Schranke –1.0 (-100 Prozent) und die maximale Schranke 1.0 (100 Prozent).
 |  |  | Wertebereich: [-1.0, 1.0] | Einheit: %
460B | 17931 | Parameter | „DRIVEERR_RANGE_MAXINCREMENT“
460C | 17932 | Parameter | „DRIVEERR_RANGE_ DRIVECONTROLDWORD“
460D | 17933 | Parameter | „DRIVEERR_RANGE_ RESETCYCLECOUNTER“
460F | 17935 | Parameter | „Drive Drehmoment-Ausgabeskalierung unzulässig“ Der Wert ist als Drive Drehmoment-Ausgabeskalierung (rot. Motor) bzw. als Kraft-Ausgabeskalierung (Linearmotor) unzulässig.
 |  |  | Wertebereich: [0, 1000000] | Einheit: 1
4610 | 17936 | Parameter | „Drive Geschwindigkeits-Ausgabeskalierung unzulässig“ Der Wert ist als Drive Geschwindigkeits-Ausgabeskalierung unzulässig.
 |  |  | Wertebereich: [0, 1000000] | Einheit: 1
4611 | 17937 | Parameter | „Profi Drive DSC Proportionalverstärkung Kpc (regler) unzulässig“ Positions Der Wert für die Profi Drive DSC Lageregelverstärkung (Kpc-Faktor) ist unzulässig.
 |  |  | Wertebereich: [0, 0xFFFFFF] | Einheit: 0.001 * 1/s
4612 | 17938 | Parameter | „Tabellen-ID ist unzulässig“ Der Wert für die Tabellen-ID ist unzulässig.
 |  |  | Wertebereich: [0, 255] | Einheit: 1
4613 | 17939 | Parameter | „Tabellen-Interpolationstyp ist unzulässig“ Der Wert als Tabellen-Interpolationstyp ist unzulässig.
 |  |  | Wertebereich: 0 (LINEAR), 2 (SPLINE) | Einheit: 1
4614 | 17940 | Parameter | „Ausgabeoffset in Prozent ist unzulässig“ Der Wert als Ausgabeoffset in Prozent (+/- 1.0) ist unzulässig.
 |  |  | Wertebereich: [-1.0, 1.0] | Einheit: %
4615 | 17941 | Parameter | „Profi Drive DSC Skalierung für Berechnung von 'Xerr' (regler) unzulässig“ Positions Der Wert ist als Profi Drive DSC Skalierung für die Berechnung von 'Xerr' unzulässig.
 |  |  | Wertebereich: [0, 1000000] | Einheit: 1
4616 | 17942 | Parameter | „Drive Beschleunigungs-Ausgabeskalierung unzulässig“ Der Wert ist als Drive Beschleunigungs-/Verzögerungs-Ausgabeskalierung unzulässig.
 |  |  | Wertebereich: [0, 1000000] | Einheit: 1
4617 | 17943 | Parameter | „Drive Positions-Ausgabeskalierung unzulässig“ Der Wert ist als Drive Positions-Ausgabeskalierung unzulässig.
 |  |  | Wertebereich: [0, 1000000] | Einheit: 1
461C | 17948 | Parameter | „Drive Filtertyp für Führungsgrößenfilter der Ausgabeposition unzulässig“ Der Wert ist als Drive Filtertyp zur Glättung der Ausgabeposition unzulässig (Führungsgrößenfilter der Soll-Position).
 |  |  | Wertebereich: [0, 2] | Einheit: 1
461D | 17949 | Parameter | „Drive Filterzeit für Führungsgrößenfilter der Ausgabeposition unzulässig“ Der Wert ist als Drive Filterzeit zur Glättung der Ausgabeposition unzulässig (Führungsgrößenfilter der Soll-Position).
 |  |  | Wertebereich: [0.0, 1.0] | Einheit: s
461E | 17950 | Parameter | „Drive Filterordnung für Führungsgrößenfilter der Ausgabeposition unzulässig“ Der Wert ist als Drive Filterordnung (P-Tn) zur Glättung der Ausgabeposition unzulässig (Führungsgrößenfilter der Soll-Position).
 |  |  | Wertebereich: [0, 10] | Einheit: 1
4620 | 17952 | Parameter | „Bit-Maske für Schrittmotorzyklus unzulässig“ Ein Wert der verschiedenen Schrittmotor Masken für den jeweiligen Zyklus ist unzulässig.
 |  |  | Wertebereich: [0, 255] | Einheit: 1
4621 | 17953 | Parameter | „Bit-Maske für Schrittmotorhaltestrom unzulässig“ Der Wert für die Schrittmotorhaltemaske ist unzulässig.
 |  |  | Wertebereich: [0, 255] | Einheit: 1
4622 | 17954 | Parameter | „Skalierungsfaktor für Ist-Moment (Ist-Strom) unzulässig“ Der Wert ist als Skalierungsfaktor für das Ist-Moment (bzw. Ist-Strom) unzulässig.
 |  |  | Wertebereich: [0, 1E+30] | Einheit:
4623 | 17955 | Parameter | „Filterzeit für Ist-Moment ist unzulässig“ Der Wert als Filterzeit für das Ist-Moment (bzw. den Ist-Strom) ist unzulässig (P-T1-Filter).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
4624 | 17956 | Parameter | „Filterzeit für die zeitliche Ableitung des Ist-Momentes ist unzulässig“ Der Wert als Filterzeit für die zeitliche Ableitung des Ist-Momentes (bzw. des Ist-Stromes) ist unzulässig (P-T1-Filter).
 |  |  | Wertebereich: [0.0, 60.0] | Einheit: s
4627 | 17959 | Funktion | DRIVEOPERATIONMODEBUSY. Die Aktivierung der Antriebsbetriebsart ist fehlgeschlagen, weil ein anderes Objekt mit OID… dieses Interface schon benutzt.
0x4630 ... 0x463F: Fehlercodes sind reserviert für externe Antriebsfehler (z.B. Schrittmotor Klemme bzw. Funktionsbaustein "MC_PowerStepper")
4630 | 17968 | Überwachung | „Übertemperatur“ Am Drive bzw. an der Klemme ist eine Übertemperatur erkannt bzw. gemeldet worden.
4631 | 17969 | Überwachung | „Unterspannung“ Am Drive bzw. an der Klemme ist eine Unterspannung erkannt bzw. gemeldet worden.
4632 | 17970 | Überwachung | „Drahtbruch in Phase A“ Am Drive bzw. an der Klemme ist ein Drahtbruch der Phase A erkannt bzw. gemeldet worden.
4633 | 17971 | Überwachung | „Drahtbruch in Phase B“ Am Drive bzw. an der Klemme ist ein Drahtbruch der Phase B erkannt bzw. gemeldet worden.
4634 | 17972 | Überwachung | „Überstrom in Phase A“ Am Drive bzw. an der Klemme ist ein Überstrom der Phase A erkannt bzw. gemeldet worden.
4635 | 17973 | Überwachung | „Überstrom in Phase B“ Am Drive bzw. an der Klemme ist ein Überstrom der Phase B erkannt bzw. gemeldet worden.
4636 | 17974 | Überwachung | „Drehmomentüberlast (Stall)“ Am Drive bzw. an der Klemme ist eine Drehmomentüberlast (Stall) erkannt bzw. gemeldet worden.
4640 | 17984 | Initialisierung | „Initialisierung Antrieb“ Antrieb ist nicht initialisiert worden. Antrieb wurde zwar erzeugt, allerdings nicht weiter initialisiert (1. Initialisierung Antrieb-IO, 2. Initialisierung Antrieb, 3. Reset Antrieb).
4641 | 17985 | Adresse | „Adresse Achse“ Antrieb kennt seine Achse (Axis) nicht bzw. die Achsadresse ist nicht initialisiert worden.
4642 | 17986 | Adresse | „Adresse IO-Eingangsstruktur“ Antrieb besitzt keine gültige IO-Eingangsadresse im Prozessabbild.
4643 | 17987 | Adresse | „Adresse IO-Ausgangsstruktur“ Antrieb besitzt keine gültige IO-Ausgangsadresse im Prozessabbild.
4650 | 18000 | Überwachung | „Antriebshardware nicht betriebsbereit“ Die Antriebshardware (Drive) nicht betriebsbereit ist. Hierfür kann es folgende Ursachen geben: - der Antrieb ist im Fehlerzustand (Hardwarefehler) - der Antrieb befindet sich in der Aufstartphase (z. B. nach einem Achsreset dem ein Hardwarefehler voraus ging) - dem Antrieb fehlt die Reglerfreigabe (ENABLE) Anmerkung: Der Zeitbedarf für das „Hochfahren“ eines Antriebes nach einem Hardwarefehler kann sich im Bereich von mehreren Sekunden bewegen.
4651 | 18001 | Überwachung | „Fehler in der zyklischen Kommunikation des Antriebs (Lebenszeichenzähler) “.Gründe könnten hier ein unterbrochener Feldbus oder ein im Fehlerzustand befindlicher Antrieb sein.
4652 | 18002 | Überwachung | „Ändern der Tabellen-ID bei aktiver Reglerfreige unzulässig“.Das Ändern (Abwählen, Anwählen) der Kennlinien-Tabellen-ID ist bei aktiver Reglerfreigabe der Achse nicht zulässig.
4655 | 18005 | Überwachung | "Ungültige IO-Daten für mehr als 'n' durchgehende NC Zyklen"Die Achse (Encoder oder Drive) hat für mehr als 'n' durchgehende NC Zyklen (NC SAF-Task) ungültige IO-Daten erkannt (z.B. n=3). Als Konsequenz ist es möglich, dass das Encoder Referenzierungs-Flag auf FALSE zurückgesetzt wird (d.h. der Encoder bekommt den Status "unreferenziert").EtherCAT Feldbus: "working counter error ('WCState')" Lightbus Feldbus: "CDL state error ('CdlState')"


Tabellenfehler

Fehlercodes [image] Übersicht NC-Fehler [image] Tabellenfehler
Tabellenfehler
Fehler(Hex) | Fehler(Dez) | Fehlertyp | Beschreibung
4A00 | 18944 | Parameter | „Tabellen-ID unzulässig“ Der Wert für die Tabellen-ID ist unzulässig, da er z. B. bereits vergeben ist, kleiner gleich Null ist oder größer 255 ist.
 |  |  | Wertebereich: [1 ... 255] | Einheit: 1
4A01 | 18945 | Parameter | „Tabellen-Typ unzulässig“ Der Wert für den Tabellen-Typ ist unzulässig, da er nicht definiert ist.
 |  |  | Wertebereich: [1] | Einheit: 1
4A02 | 18946 | Parameter | „Zeilenanzahl der Tabelle unzulässig“ Der Wert für die Zeilenanzahl der Tabelle ist unzulässig, da er z. B. bei Linearinterpolation kleiner Zwei und bei Splineinterpolation kleiner Vier ist.
 |  |  | Wertebereich: [2, 0xFFFF] | Einheit: 1
4A03 | 18947 | Parameter | „Spaltenanzahl der Tabelle unzulässig“ Der Wert für die Spaltenanzahl der Tabelle ist unzulässig, da er z. B. gleich Null bzw. kleiner gleich Eins ist (je nach Tabellen-/Slavetyp).
 |  |  | Wertebereich: [1, 0xFFFF] | Einheit: 1
4A04 | 18948 | Parameter | „Schrittweite (Positionsdelta) unzulässig“ Der Wert für die Schrittweite zwischen zwei Zeilen (Positionsdelta) ist unzulässig, da er z. B. kleiner gleich Null ist.
 |  |  | Wertebereich: [0.001, 1.0E+6] | Einheit: z. B mm
4A05 | 18949 | Parameter | „Periode unzulässig“ Der Wert für die Periode ist unzulässig, da er z. B. kleiner gleich Null ist.
 |  |  | Wertebereich: [0.001, 1.0E+9] | Einheit: z. B mm
4A06 | 18950 | Parameter | „Tabelle ist nicht monoton“ Der Wert für die Schrittweite ist unzulässig, da er z. B. kleiner gleich Null ist.
4A07 | 18951 | Initialisierung | „Tabellen-Untertyp unzulässig“ Der Wert für den Tabellen-Untertyp ist unzulässig, da er nicht definiert ist. Oder aber der Tabellen-Untertyp und die Tabellenklasse (Slave-Typ) passen nicht zusammen. Tabellen-Untertypen: (1) äquidistante lineare Positionstabelle, (2) äquidistante zyklische Positionstabelle, (3) nicht-äquidistante lineare Positionstabelle, (4) nicht-äquidistante zyklische Positionstabelle
 |  |  | Wertebereich: [1, 4] | Einheit: 1
4A08 | 18952 | Initialisierung | „Tabellen-Interpolationstyp unzulässig“ Der Wert für den Tabellen-Interpolationstyp ist unzulässig, da er nicht definiert ist. Tabellen-Interpolationstypen: (0) Linear-Interpolation, (1) 4-Punkt-Interpolation, (2) Spline-Interpolation
 |  |  | Wertebereich: [0, 2] | Einheit: 1
4A09 | 18953 | Initialisierung | „Falscher Tabellen-Haupttyp“ Der Tabellen-Haupttyp ist unzulässig, da er nicht definiert ist. Oder aber der Tabellen-Haupttyp und die Tabellenklasse (Slave-Typ) passen nicht zusammen. Tabellen-Haupttypen: (1) Kurvenscheiben-Tabelle (Camming), (10) Kennlinien-Tabelle, (16) "MotionFunction"-Tabelle (MF)
4A10 | 18960 | Initialisierung | „Initialisierung Tabelle“ Tabelle ist nicht initialisiert worden. Tabelle wurde zwar erzeugt, allerdings nicht weiter initialisiert. Z. B. ist die Anzahl der Zeilen oder Spalten kleiner gleich Null.
4A11 | 18961 | Initialisierung | „Nicht genügend Speicher vorhanden“ Tabelle konnte nicht erzeugt werden, da nicht genügend Speicher vorhanden ist.
4A12 | 18962 | Funktion | „Funktion wird nicht ausgeführt, Funktion nicht verfügbar“ Die Funktion ist für den aktuellen Tabellentyp nicht implementiert oder nicht ausführbar.
4A13 | 18963 | Funktion | „Zeilenindex unzulässig“ Der Startzeilenindex bzw. der Stoppzeilenindex, ab dem lesend oder schreibend auf die Tabelle zugegriffen werden soll, ist unzulässig. Z. B. ist der Zeilenindex größer als die Gesamtzeilenanzahl der Tabelle.
4A14 | 18964 | Funktion | „Spaltenindex unzulässig“ Der Startspaltenindex bzw. der Stoppspaltenindex, ab dem lesend oder schreibend auf die Tabelle zugegriffen werden soll, ist unzulässig. Z. B. ist der Spaltenindex größer als die Gesamtspaltenanzahl der Tabelle.
4A15 | 18965 | Funktion | „Zeilenanzahl unzulässig“ Die Anzahl der zu lesenden bzw. schreibenden Zeilen der Tabelle ist unzulässig. Die Zeilenanzahl muss genau einem ganzzahligen Vielfachen der Elemente einer Zeile entsprechen (n * Anzahl der Spalten).
4A16 | 18966 | Funktion | „Spaltenanzahl unzulässig“ Die Anzahl der zu lesenden bzw. schreibenden Spalten der Tabelle ist unzulässig. Die Spaltenanzahl muss genau einem ganzzahligen Vielfachen der Elemente einer Spalte entsprechen (n * Anzahl der Zeilen).
4A17 | 18967 | Funktion | „Fehler in der Skalierung oder in der Bereichsangabe“ Die Angaben im Tabellenheader sind inkonsistent, z.B. ist der Gültigkeitsbereich leer. Wenn der Fehler zur Laufzeit generiert wird ist er Laufzeitfehler und stoppt die Master/Slave Gruppe.
4A18 | 18968 | Funktion | „Multi-Tabellenslave außer Bereich“ Die Masterpositon des Slaves ist außerhalb der Tabellenwerte für den Master. Der Fehler ist Laufzeitfehler und stoppt die Master/Slave Gruppe.
4A19 | 18969 | Funktion | „Solo-Tabellen Underflow“ Die Masterpositon des Slaves ist außerhalb der Tabellenwerte für den Master. Der Masterwert der äquidistanten, linear abzuarbeitenden Tabelle liegt unter dem ersten Tabellenwert. Der Fehler ist Laufzeitfehler und stoppt die Master/Slave Gruppe.
4A1A | 18970 | Funktion | „Solo-Tabellen Overflow“ Die Masterpositon des Slaves ist außerhalb der Tabellenwerte für den Master. Der Masterwert der äquidistanten, linear abzuarbeitenden Tabelle liegt über dem ersten Tabellenwert. Der Fehler ist Laufzeitfehler und stoppt die Master/Slave Gruppe.
4A1B | 18971 | Parameter | „Falscher Abarbeitungmodus“ Der zyklische Abarbeitungsmodus kann nur „true“ oder „false“ sein.
4A1C | 18972 | Parameter | „Unzulässiger Parameter“ Der Parameter des Fifos ist unzulässig.
4A1D | 18973 | Parameter | „Fifo ist leer“ Das Fifo des Externen Generators ist leer. Das kann Bahnende oder Laufzeitfehler bedeuten.
4A1E | 18974 | Parameter | „Fifo ist voll“ Das Fifo des Externen Generators ist voll. Es ist Sache des Users immer wieder zu versuchen mit den abgelehnten Werten das Fifo zu füllen.
4A1F | 18975 | Parameter | „Punkt-Index der Motion Function ist ungültig“ Der Punkt-Index eines Motion Function Punktes einer Motion Function Tabelle ist unzulässig. Der Punkt-Index muss erstens größer Null sein und zweitens für eine Spalte einer Motion Function Tabelle numerisch fortlaufend sein (z.B. 1,2,3,... oder 10,11,12,...). Anmerkung: Der Punkt-Index darf nicht online geändert werden, sondern muss konstant gehalten werden.
4A20 | 18976 | Initialisierung | „Keine Diagonalisierung der Matrize“ Die Tabellenwerte des Masters lassen keine Berechnung des Splines zu.
4A21 | 18977 | Initialisierung | „Anzahl Splinepunkte zu klein“ Die Anzahl der Punkte eines kubischen Splines muss mindestens drei sein. Daher muss die Zeilenzahl mindestens drei sein.
4A22 | 18978 | Initialisierung | „Fifo darf nicht überschrieben werden“ Das Fifo des Externen Generators darf nicht überschrieben werden, da sonst über die aktive Abarbeitungszeile hinweg geschrieben würde. Es ist Sache des Users darauf zu achten, dass keine Änderungen oder Löschungen über die aktive Zeile hinweg angefordert werden.
4A23 | 18979 | Funktion | „Motion Function hat zuwenige Punkte “ Die Anzahl der gültigen Punkte, die eine Motion Function definieren, ist kleiner als zwei. Entweder ist die Gesamtzahl zu gering oder der Punkttyp vieler Punkte ist auf Ignore Point gesetzt.


NC-SPS-Fehler

Fehlercodes [image] Übersicht NC-Fehler [image] NC-SPS-Fehler
NC-SPS-Fehler
Fehler(Hex)
Fehler(Dec)
Fehlertyp
Beschreibung
4B00
19200
Parameter
"Achse ist gestoppt worden" Die Achse ist gestoppt worden, während die Achse zur Zielposition fährt. Die Achse könnte mit einem SPS Kommando über ADS, mit einem Aufruf durch AXFNC oder durch den System Manager gestoppt worden sein.
4B01
19201
Parameter
"Achse kann nicht gestartet werden" Die Achse kann nicht gestartet werden, weil:
▪
die Achse befindet sich im Error Status,
▪
die Achse führt einen anderen Auftrag aus,
▪
die Achse befindet sich im geschützten Modus,
▪
die Achse ist nicht betriebsbereit.
4B02
19202
Parameter
"Kontrollmodus nicht zulässig" Keine Zielpositionskontrolle und keine Positionsbereich Kontrolle.
4B03
19203
Parameter
"Achse bewegt sich nicht" Ein Restart von Position und Geschwindigkeit ist nur bei physikalischer Bewegung der Achse möglich.
4B04
19204
Parameter
"Falscher Modus für RestartPosAndVelo" Falscher Modus.
4B05
19205
Parameter
"Befehl nicht zulässig"
▪
endlose Bewegung in eine nicht spezifizierte Richtung
▪
Read/Write Parameter: unpassender Typ
4B06
19206
Parameter
"Parameter nicht korrekt"
▪
Falscher Override: > 100% oder < 0%
▪
Falscher Getriebefaktor: RatioDenominator = 0
4B07
19207
Parameter
"Timeout Achs-Funktionsbaustein"
Alle "MC_Move..."-Bausteine prüfen am Ende der Positionierung, ob diese erfolgreich abgeschlossen wurde. Im einfachsten Fall wird das "AxisHasJob"-Flag der NC-Achse geprüft, das zunächst besagt, dass die Positionierung logisch beendet wurde. Abhängig von der Parametrierung der NC-Achse kommen aber noch weitere Prüfungen (Gütekriterien) hinzu:
▪
"Positionsbereichsüberwachung"
Bei eingeschalteter Positionsbereichsüberwachung wird die Rückmeldung von der NC abgewartet. Die Achse muss sich nach der Positionierung innerhalb des definierten Positionsbereichsfensters befinden. Der Lageregler sorgt ggf. dafür, dass die Achse ins Ziel gezogen wird. Bei abgeschaltetem (Kv=0) oder schwachem Lageregler, wird das Ziel evtl. nicht erreicht.
▪
"Zielpositionsüberwachung"
Bei eingeschalteter Zielpositionsüberwachung wird die Rückmeldung von der NC abgewartet. Die Achse muss sich nach der Positionierung mindestens für die definierte Zeit im definierten Zielpositionsfenster befinden. Der Lageregler sorgt ggf. dafür, dass die Achse ins Ziel gezogen wird. Bei abgeschaltetem (Kv=0) oder schwachem Lageregler, wird das Ziel evtl. nicht erreicht. Ebenfalls kann eine schwingende Lagereglung dafür sorgen, dass die Achse um das Fenster herumpendelt und nicht dauerhaft in diesem Fenster verbleibt.
Wenn sich nun die Achse logisch in der Zielposition befindet (logischer Stillstand), aber das parametrierte Positionsfester nicht erreicht wird, dann wird die Überwachung der oben genannten NC-Rückmeldungen nach einem konstanten Timeout von 6 Sekunden mit Fehler 19207 (0x4B07) abgebrochen.
4B08
19208
Parameter
"Achse ist im geschützten Modus" Die Achse befindet sich im geschützten Modus (z.B. gekoppelt) und kann nicht bewegt werden.
4B09
19209
Parameter
"Achse ist nicht bereit" Die Achse ist nicht bereit und kann nicht bewegt werden.
4B0A
19210
Parameter
"Fehler beim Referenzieren" Das Referenzieren (Homing) der Achse konnte nicht gestartet werden oder war nicht erfolgreich.
4B0B
19211
Parameter
"Fehlerhafte Definition des Triggereingangs" Die Definition des Trigger-Signals für den Baustein MC_TouchProbe ist fehlerhaft. Die definierte Encoder-ID, das TriggerSignal oder die Trigger-Flanke sind ungültig.
4B0C
19212
Funktion
"Positionslatch wurde deaktiviert" Der Baustein MC_TouchProbe hat festgestellt, dass ein von ihm gestarteter Messtasterzyklus deaktiviert wurde. Ursache kann beispielsweise ein Achs-Reset sein.
4B0D
19213
Funktion
"Timeout NC-Status-Rückmeldung" Eine Funktion wurde erfolgreich von der SPS zur NC abgesetzt. Eine erwartete Rückmeldung im Status-Wort der Achse kommt aber nicht.
4B0E
19214
Funktion
"Zusatzprodukt nicht installiert" Die Funktion ist als Zusatzprodukt verfügbar, ist aber auf dem System nicht installiert.
4B0F
19215
Funktion
"No NC Cycle Counter Update" – Das NcToPlc Interface bzw. ein darin enthaltener NC Cycle Counter wurde nicht aktualisiert.
Fehlernummern 0x4B10 .. 0x4B2F werden im TwinCAT NCI Kontext verwendet:
4B10
19216
Funktion
"M-Funktion Anfrage fehlt" Dieser Fehler tritt auf, wenn eine Bestätigung der M-Funktion gemacht worden ist, aber das Anfragebit (request bit) nicht gesetzt worden ist.
4B11
19217
Parameter
"Nullpunktverschiebungsindex liegt außerhalb des Bereichs" Der Index der Nullpunktverschiebung ist ungültig.
4B12
19218
Parameter
"R-Parameterindex oder -größe ist ungültig" Dieser Fehler tritt auf, wenn die R-Parameter geschrieben oder gelesen werden, und der Index oder die Größe außerhalb des Bereichs liegen.
4B13
19219
Parameter
"Index für Werkzeugbeschreibung ist ungültig"
4B14
19220
Funktion
"Version des zyklischen Kanalinterfaces passt nicht zu der angeforderten Funktion bzw. dem Funktionsbaustein" Dieser Fehler tritt auf, wenn mit einer älteren TwinCAT Version, neue Funktionalitäten einer neueren TcNci.lib aufgerufen werden.
4B15
19221
Funktion
"Kanal ist nicht bereit für die angeforderte Funktion" Die anforderte Funktion kann nicht ausgeführt werden, da der Kanal sich im falschen Zustand befindet. Dieser Fehler tritt z.B. beim Rückwärtsfahren auf, wenn die Achsen zuvor nicht mit dem ItpEStop angehalten werden.
4B16
19222
Funktion
"Angeforderte Funktion ist nicht aktiv geschaltet" Die angeforderte Funktion benötigt zuvor eine explizite Aktivierung.
4B17
19223
Funktion
"Achse ist bereits in einer anderen Gruppe" Die Achse wurde bereits zu einer anderen Gruppe hinzugefügt.
4B18
19224
Funktion
"Blocksearch konnte nicht erfolgreich ausgeführt werden" Der Blocksearch ist fehlgeschlagen.
Mögliche Ursachen:
▪
Ungültige Blocknummer
4B19
19225
Parameter
"Ungültiger Blocksearch Parameter" Dieser Fehler tritt auf, wenn der FB ItpBlocksearch mit ungültigen Parametern aufgerufen wird (z.B. E_ItpDryRunMode, E_ItpBlockSearchMode)
4B20
19232
Funktion
"Kann nicht alle Achsen zufügen" Dieser Fehler tritt auf, wenn eine Hilfsachse zu einer Interpolationsgruppe hinzugefügt werden soll, und die Funktion ausfällt. Vermutlich wurde eine vorhergehende Anweisung einer Hilfsachse übersprungen.
Fehlernummern 0x4B30 .. 0x4B3F werden in der TcMcCam-Lib verwendet (MC_NC_TableErrorCodes):
4B30
19248
Parameter
"Pointer ist ungültig" Ein Zeiger auf eine Datenstruktur ist ungültig, z. B. Null
▪
Datenstruktur MC_CAM_REF wurde nicht initialisiert
4B31
19249
Parameter
"Speichergröße ungültig" Die Angabe der Speichergröße (SIZE) einer Datenstruktur ist ungültig.
▪
Speichergröße ist 0 oder kleiner als ein Element der adressierten Datenstruktur.
▪
Speichergröße ist kleiner als die angeforderte Datenmenge.
▪
Speichergröße passt nicht zu anderen Parametern, wie Punktanzahl, Zeilenanzahl oder Spaltenanzahl.
4B32
19250
Parameter
"Kurvenscheiben-ID ist ungültig" Die ID einer Kurvenscheibe liegt nicht zwischen 1 und 255.
4B33
19251
Parameter
"Punkt-ID ist ungültig" Die ID eines Punktes (Stützstelle) einer Motion Function ist kleiner als 1.
4B34
19252
Parameter
"Anzahl der Punkte ist ungültig" Die Anzahl der zu lesenden oder zu schreibenden Punkte (Stützstellen) einer Kurvenscheibe ist kleiner als 1.
4B35
19253
Parameter
"MC-Tabellentyp ist ungültig" Der Typ einer Kurvenscheibe entspricht nicht der Definition MC_TableType.
4B36
19254
Parameter
"Anzahl der Zeilen ungültig" Die Anzahl der Zeilen (Stützstellen) einer Kurvenscheibe ist kleiner als 1.
4B37
19255
Parameter
"Anzahl der Spalten ungültig" Die Anzahl der Spalten einer Kurvenscheibe ist ungültig.
▪
Die Spaltenzahl einer Motion Function ist ungleich 1
▪
Die Spaltenzahl einer Standard-Kurvenscheibe ist ungleich 2
▪
Die Spaltenzahl passt nicht zu einem anderen Parameter (ValueSelectMask)
4B38
19256
Parameter
"Schrittweite ungültig". Die Schrittweite für die Interpolation ist ungültig, z. B. kleiner gleich Null.
Fehlernummern 0x4B0F, 0x4B40 .. 0x4B4F werden in der TcNc-Lib verwendet:
4B40
19264
Überwachung
"Klemmentyp nicht unterstützt" Die verwendete Klemme wird nicht von diesem Funktionsblock unterstützt.
4B41
19265
Überwachung
"Register Read/Write Fehler" Dieser Fehler impliziert einen Gültigkeitsfehler.
4B42
19266
Überwachung
"Achse ist Enabled" Die Achse ist enabled und darf für den Vorgang nicht enabled sein.
4B43
19267
Parameter
"Größe der Kompensationstabelle falsch" Die angegebene Tabellengröße in Byte entspricht nicht der tatsächlichen Größe
4B44
19268
Parameter
Die minimale/maximale Position in der Kompensationstabelle entspricht nicht der Position in der Tabellenbeschreibung (ST_CompensationDesc)
4B45
19269
Parameter
"Nicht implementiert" Die angeforderte Funktion ist in dieser Kombination nicht implementiert
Fehlernummern 0x4B50 .. 0x4B5F werden in der TcRemoteSync-Lib verwendet:
Fehlernummern 0x4B60 .. 0x4B6F werden in der TcMc2-Lib im buffered commands Kontext verwendet:
4B60
19296
Überwachung
"Fahrauftrag wurde nicht aktiv" Ein Fahrauftrag wurde ausgelöst und zunächst von der NC erfolgreich mit neuer Kommandonummer quittiert und gepuffert. Dennoch wird der Fahrauftrag nicht aktiv (möglicherweise wegen einer Abbruchbedingung oder eines internen NC Fehlers).
4B61
19297
Überwachung
"Fahrauftrag konnte von der SPS nicht verfolgt werden" Ein Fahrauftrag wurde ausgelöst und zunächst von der NC erfolgreich mit neuer Kommandonummer quittiert und gepuffert. Dennoch konnte die Kommandoausführung von der SPS nicht verfolgt werden, da die NC bereits ein nachfolgendes Kommando ausführt. Der Ausführungszustand ist unklar. Dieser Fehler darf nur bei sehr kurzen Fahraufträgen auftreten, die innerhalb eines SPS-Zyklus abgearbeitet sind.
4B62
19298
Überwachung
"Gepuffertes Kommando wurde mit Fehler beendet" Ein gepuffertes Kommando wurde mit Fehler beendet. Die Fehlernummer ist nicht verfügbar, weil bereits ein neues Kommando ausgeführt wird.
4B63
19299
Überwachung
"Gepuffertes Kommando wurde ohne Rückmeldung beendet" Ein gepuffertes Kommando wurde beendet, aber es gibt keine Rückmeldung über Erfolg oder Fehler.
4B64
19300
Überwachung
" 'BufferMode' wird vom Kommando nicht unterstützt" Der 'BufferMode' wird von diesem Kommando nicht unterstützt.
4B65
19301
Überwachung
"Kommandonummer ist Null" Die vom System verwaltete Kommandonummer für gepufferte Kommandos hat unerwartet den Wert 0.
4B66
19302
Überwachung
"Funktionsbaustein wurde nicht zyklisch aufgerufen" Der Funktionsbaustein wurde nicht zyklisch aufgerufen. Daher konnte die Kommandoausführung von der SPS nicht verfolgt werden, während die NC bereits ein nachfolgendes Kommando ausführt. Der Ausführungszustand ist unklar.
Fehlernummern 0x4B70 .. 0x4B8F werden in der TcPlcInterpolation-Lib verwendet:
4B71
19313
Parameter
"Ungültiger NCI Entry Typ". Der FB FB_NciFeedTablePreparation wurde mit einem unbekannten nEntryType aufgerufen.
4B72
19314
Funktion
"NCI Feed Table voll" Die Tabelle ist voll und daher wird der Eintrag nicht angenommen.
Abhilfe:
Mit dem FB FB_NciFeedTable den Inhalt an den NC-Kern übergeben. Wenn bFeedingDone = TRUE, kann bei FB_NciFeedTablePreparation mit bResetTable die Tabelle zurückgesetzt werden und anschließend mit neuen Einträgen gefüllt werden.
4B73
19315
Funktion
interner Fehler
4B74
19316
Parameter
"ST_NciTangentialFollowingDesc: Tangentialachse ist keine Hilfsachse" In dem Eintrag für die tangentiale Nachführung wurde eine Tangentialachse genannt, die keine Hilfsachse ist.
4B75
19317
Parameter
ST_NciTangentialFollowingDesc: nPathAxis1 bzw. nPathAxis2 ist keine Bahnachse. Somit kann die Ebene nicht bestimmt werden.
4B76
19318
Parameter
ST_NciTangentialFollwoingDesc: nPathAxis1 und nPathAxis2 sind gleich. Somit kann die Ebene nicht bestimmt werden.
4B77
19319
Parameter
ST_NciGeoCirclePlane: Kreis falsch parametriert
4B78
19320
Funktion
Interner Fehler bei der Berechnung der tangentialen Nachführung
4B79
19321
Überwachung
Tangentiale Nachführung: Beim Einschalten der tangentialen Nachführung wurde die Überwachung der Ablenkungswinkel eingeschaltet (E_TfErrorOnCritical1) und mit dem aktuellen Segment ist ein zu großer Ablenkungswinkel festgestellt worden.
4B7A
19322
Funktion
nicht implementiert
4B7B
19323
Parameter
Tangentiale Nachführung: Der Radius des aktuellen Kreissegements ist zu klein
4B7C
19324
Parameter
FB_NciFeedTablePreparation: pEntry ist NULL
4B7D
19325
Parameter
FB_NciFeedTablePreparation: Der angegebene nEntryType stimmt nicht mit dem Strukturtyp überein
4B7E
19326
Parameter
ST_NciMFuncFast und ST_NciMFuncHsk: Die angeforderte M-Funktion liegt nicht zwischen 0 und 159
4B7F
19327
Parameter
ST_NciDynOvr: Der angeforderte Wert für den Dynamik-Override liegt nicht zwischen 0.01 und 1
4B80
19328
Parameter
ST_NciVertexSmoothing: ungültiger Parameter. Dieser Fehler wird bei einem negativen Verschleifungsradius bzw. bei einem unbekannten Verschleifungstyp erzeugt.
4B81
19329
Parameter
FB_NciFeedTablePrepartion: Die angeforderte Geschwindigkeit ist nicht im gültigen Bereich
4B82
19330
Parameter
ST_Nci*: ungültiger Parameter
Fehlernummern 0x4BA0 .. 0x4BAF werden in der TcNcKinematicTransformation-Lib verwendet:
4BA0
19360
Funktion
KinGroup Fehler: Die Kinematikgruppe befindet sich im Fehlerzustand.
Dieser Fehler kann auftreten, wenn sich die Kinematikgruppe beim Aufruf im Fehlerzustand oder in einem unerwarteten Zustand befindet (z.B. gleichzeitiger Aufruf über mehrere FB-Instanzen).
4BA1
19361
Funktion
KinGroup Timeout: Timeout beim Aufruf eines Kinematik-Bausteins
Fehlernummern 0x4B90 .. 0x4B9F werden in der Tc3_MC2_AdvancedHoming-Lib (PLCopen Part 5: Homing Procedures) verwendet:
4B90
19344
Parameter
Ermittelter Drive-Typ wird nicht unterstützt
4B91
19345
Parameter
Direction ist unzulässig
4B92
19346
SwitchMode ist unzulässig
4B93
19347
Mode für das Parameter-Handling ist unzulässig
4B94
19348
Parametrierung der Drehmomentgrenzen ist inkonsistent
4B95
19349
Parametrierung der Schleppabstandgrenze ist unzulässig (<=0).
4B96
19350
Parametrierung des Distanzlimits ist unzulässig (<0)
4B97
19351
Es wurde versucht erneut Parameter zu sichern, obwohl diese bereits gesichert wurden.
4B98
19352
Es wurde versucht Parameter zu restaurieren, obwohl keine gesichert wurden.
Fehlernummern 0x4BB0 .. 0x4BBF werden in der Tc2_MC2_Drive-Lib verwendet:
4BB0
19376
Funktion
Die aktuelle Achs-Position oder die sich durch den neuen Positions-Offset ergebende Achs-Position überschreitet den gültigen Wertebereich.
4BB1
19377
Funktion
Der neue Positions-Offset überschreitet den gültigen Wertebereich [AX5000: 2^31]
4BB2
19378
Funktion
Die aktuelle Achs-Position oder die sich durch den neuen Positions-Offset ergebende Achs-Position unterschreitet den gültigen Wertebereich.
4BB3
19379
Funktion
Der neue Positions-Offset unterschreitet den gültigen Wertebereich [AX5000: -2^31]
4BB4
19380
Funktion
Das aktivierte Feedback und/oder der Speicherort (AX5000: P-0-0275) unterscheiden sich von der Parametrierung am Baustein.
4BB5
19381
Funktion
Reinitialisierung der Nc-Istposition ist fehlgeschlagen.
z.B. Referenzsystem = „ABSOLUTE (with single overflow)“ & Softwareendlagenüberwachung ist deaktiviert.


Kinematische Transformation

Fehlercodes [image] Übersicht NC-Fehler [image] Kinematische Transformation
Kinematische Transformation
Fehler(Hex)
Fehler(Dez)
Fehlertyp
Beschreibung
4C00
19456
Transformation fehlgeschlagen.
4C01
19457
Mehrdeutige Lösung. Die Lösung für die Transformation ist nicht eindeutig.
4C02
19458
Ungültige Achsposition: Die Transformation kann mit den aktuellen Positionsdaten nicht gerechnet werden.
Mögliche Ursachen:
▪
Die Position befindet sich außerhalb des Arbeitsraums der Kinematik
4C03
19459
Konfiguration
Ungültige Dimension: Die Dimension der parametrierten Input-Parameter stimmt nicht mit der vom Kinematik-Objekt erwarteten Dimension überein.
Mögliche Ursachen:
▪
Es werden zu viele Positionswerte für diese Konfiguration mitgegeben. Überprüfen Sie die Anzahl der parametrierten Achsen.
4C04
19460
NCERR_KINTRAFO_REGISTRATION
4C05
19461
Intern
Newton Iteration fehlgeschlagen: Die Newton-Iteration konvergiert nicht.
4C06
19462
Intern
Jacobi-Matrix kann nicht invertiert werden
4C07
19463
Konfiguration
Ungültige Kaskade: Diese Konfiguration der Kinematik ist nicht zulässig.
4C08
19464
Programmierung
Singularität: Die Maschinenkonfiguration resultiert in singulären Achsgeschwindigkeiten.
4C0B
19467
Intern
Keine Metainfo: Metainfo-Pointer ist null.
4C20
19488
Intern
Transformation fehlgeschlagen: Aufruf des erweiterten Kinematik-Modells fehlgeschlagen.
4C30
19504
Programmierung
Ungültiger Inputframe: Programmierte kartesische Position kann in ACS-Konfiguration nicht angefahren werden.
4C50
19536
Intern
Ungültiger Offset: Zugriffsverletzung im Observer festgestellt.


Bode Return Codes

Fehlercodes [image] Übersicht NC-Fehler [image] Bode Return Codes
Bode Return Codes
Folgende Bode Plot spezifischen Fehlercodes werden im Bode Plot Server verwendet:
Code Hex | Code Dec | Symbol | Beschreibung
0x8100 | 33024 | INTERNAL | Internal error
0x8101 | 33025 | NOTINITIALIZED | Not initialized (e.g. no nc axis)
0x8102 | 33026 | INVALIDPARAM | Invalid parameter
0x8103 | 33027 | INVALIDOFFSET | Invalid index offset
0x8104 | 33028 | INVALIDSIZE | Invalid parameter size
0x8105 | 33029 | INVALIDSTARTPARAM | Invalid start parameter (set point generator)
0x8106 | 33030 | NOTSUPPORTED | Not supported
0x8107 | 33031 | AXISNOTENABLED | Nc axis not enabled
0x8108 | 33032 | AXISINERRORSTATE | Nc axis in error state
0x8109 | 33033 | DRIVEINERRORSTATE | IO drive in error state
0x810A | 33034 | AXISANDDRIVEINERROR-STATE | Nc axis AND IO drive in error state
0x810B | 33035 | INVALIDDRIVEOPMODE | Invalid drive operation mode active or requested (no bode plot mode)
0x810C | 33036 | INVALIDCONTEXT | Invalid context for this command (mandatory task or windows context needed)
0x810D | 33037 | NOAXISINTERFACE | Missing TCom axis interface (axis null pointer). Es fehlt eine Verbindung zur NC Achse. Entweder ist keine Achse (bzw. Achs-ID) parametriert worden oder die parametrierte Achse existiert nicht.
0x810E | 33038 | INPUTCYCLECOUNTER | Invalid input cycle counter from IO drive (e.g. frozen). Während der BodePlot Aufzeichnung werden die zyklischen Antriebsdaten durch einen „InputCycleCounter“ gesichert. Hierdurch kann zum einen ein unerwarteter Kommunikationsverlust erkannt (Stichwort LifeCounter) und zum anderen auf zeitliche Datenkonsistenz geprüft werden. Beispiel 1: Dieser Fehler kann auftreten wenn die Zykluszeit der aufrufenden Task grösser ist als die angenommene Antriebszykluszeit (dann kommt der Fehler allerdings gleich beim Start der Aufzeichnung). Beispiel 2: Dieser Fehler kann auftreten wenn die aufrufende Task Echtzeitstörungen hat (z.B. der "Exceed Counter" der Task hochzählt oder die Task niederprior ist wie z.B. oft bei der PLC). Hier könnte der Fehler jederzeit auch während der Aufnahme auftreten. Beispiel 3: Dieser Fehler kann vermehrt auftreten wenn die Echtzeitauslastung auf der Rechner recht groß ist (> 50%). Anmerkung: Siehe auch korrespondierenden AX5000 Drive Fehlercode F440.
0x810F | 33039 | POSITIONMONITORING (=> NC Runtime Error) | Position monitoring: Axis position is outside of the maximum allowed moving range. Die Achse hat das parametrierte Positions-bereichs-fenster verlassen woraufhin die Aufnahme abgebrochen und die NC Achse in den Fehlerzustand 0x810F versetzt wird (mit Standard NC Fehlerhandling). Das Positionsbereichsfenster wirkt symmetrisch um die Startposition der Achse (s.a. Parameterbeschreibung Position Monitoring Window). Typische Fehlermeldung im Logger: "BodePlot: 'Position Monitoring' error 0x%x because the actual position %f is above the maximum limit %f of the allowed position range (StartPos=%f, Window=%f)"
0x8110 | 33040 | DRIVELIMITATIONDETECTED | Driver limitations detected (current or velocity limitations) which causes a nonlinear behavior and invalid results of the bode plot. Eine BodePlot Aufzeichnung setzt eine näherungsweise lineare Übertragungsstrecke voraus. Wenn es im Antriebsgerät allerdings zu Limitierungen (Begrenzungen) der Geschwindigkeit oder des Stromes kommt, dann wird dieses nichtlineare Verhalten erkannt und eine Bodeplot Aufzeichnung wird abgebrochen. Gründe für diese Limitierungen kann eine für das Positions-, Geschwindigkeits- oder Torque-Interface zu groß gewählte Amplitude sein oder eine ungeeignete Wahl des Amplituden Skalierungsmode (s.a. Parameterbeschreibung Amplitude Scaling Mode, Base Amplitude, Signal Amplitude). Typische Fehlermeldung im Logger: "BodePlot: Sequence aborted with error 0x%x because the current limit of the drive has been exceeded (%d times) which causes a nonlinear behavior and invalid results of the bode plot"
0x8111 | 33041 | LIFECOUNTERMONITORING (=> NC Runtime Error) | Life counter monitoring (heartbeat): Lost of communication to GUI detected after watchdog timeout is elapsed. Das grafische Benutzerinface, aus dem die Bodeplot Aufzeichnung gestartet wurde, kommuniziert nicht mehr im erwarteten Rhythmus mit dem BodePlot Treiber (Stichwort „Life Counter“). Deshalb wird die Aufzeichnung sofort beendet und die NC Achse in den Fehlerzustand 0x8111 versetzt (mit Standard NC Fehlerhandling). Mögliche Gründe hierfür können ein Absturz der Bedienoberfläche oder eine erhebliche Störung des Windows Kontextes sein. Typische Fehlermeldung im Logger: "BodePlot: Sequence aborted with GUI Life Counter error 0x%x because the WatchDog timeout of %f s elapsed ('%s')"
0x8112 | 33042 | NCERR_BODEPLOT_WCSTATE | WC state error (IO data working counter) IO working counter Fehler (WC state) durch z.B. Echtzeitstörungen, EtherCAT CRC-Fehler oder Telegrammausfälle, EtherCAT Teilnehmer nicht in Kommunikation (OP-state), etc.
0x8113- 0x811F | 33043- 33055 | RESERVED | Reservierter Bereich


Weitere Fehler

Fehlercodes [image] Übersicht NC-Fehler [image] Weitere Fehler
Weitere Fehler
Error(Hex) | Error(Dec) | ErrorType | Description
0x8120 | 33056 | Environment | Invalid configuration for Object (e.g. in System Manager)
0x8121 | 33057 | Environment | Invalid environment for Object (e.g. TcCom-Object's Hierarchy or missing/faulty Objects)
0x8122 | 33058 | Environment | Incompatible Driver or Object
0x8135 | 33077 | Internal | Function Block Inputs are inconsitent.Some Inputs of the Function Block are inconsistent during. Probably Communicator and its IID, which both have to be set or unset.
0x813b | 33083 | Parameter | Transition Mode is invalid
0x813c | 33084 | Parameter | BufferMode is invalid
0x813d | 33085 | FunctionBlock | Only one active Instance of Function Block per Group is allowed.
0x813e | 33086 | State | Command is not allowed in current group state.
0x813f | 33087 | FunctionBlock | Slave cannot synchronize.The slave cannot reach the SlaveSyncPosition by the time the master has reached the MasterSyncPos.
0x8140 | 33088 | Parameter | Invalid value for one or more of the dynamic parameters (A, D, J).
0x8141 | 33089 | Parameter | IdentInGroup is invalid.
0x8142 | 33090 | Parameter | The number of axes in the group is incompatible with the axes convention.
0x8143 | 33091 | Communication | Function Block or respective Command is not supported by Target.
0x8145 | 33093 | FunctionBlock | Mapping of Cyclic Interface between Nc and Plc missing (e.g. AXIS_REF, AXES_GROUP_REF, ...).
0x8146 | 33094 | FunctionBlock | Invalid Velocity ValueThe velocity was not set or the entered value is invalid
0x8148 | 33096 | FunctionBlock | Invalid Input Value
0x8149 | 33097 | Parameter | Unsupported Dynamics for selected Group Kernel
0x814a | 33098 | Parameter | The programmed position dimension incompatible with the axes convention.
0x814b | 33099 | FunctionBlock | Path buffer is invalid. E.g. because provided buffer has invalid address or is not big enough
0x814c | 33100 | FunctionBlock | Path does not contain any element
0x814d | 33101 | FunctionBlock | Provided Path buffer is too small to store more Path Elements
0x814e | 33102 | Parameter | Dimension or at least one Value of Transition Parameters is invalid
0x814f | 33103 | FunctionBlock | Invalid or Incomplete Input Array
0x8150 | 33104 | FunctionBlock | Path length is zero
0x8151 | 33105 | State | Command is not allowed in current axis state.
0x8152 | 33106 | State | TwinCAT System is shutting down and cannot complete request.
0x8160 | 33120 | NC Programming | Circle Specification in Path is invalid.The specification of a circle segment in the programmed interpolated path (e.g. via MC_MovePath) has an invalid or ambiguous descripition. Probably its center cannot be determined reliably.
0x8161 | 33121 | NC Programming | Maximum stream lines reached.The maximum number of stream lines is limited. Please refer to function block documentation for details.
0x8163 | 33123 | FunctionBlock | Invalid First Segment.The corresponding element can only be analyzed with a well-defined start point.
0x8164 | 33124 | FunctionBlock | Invalid auxiliary point.The auxiliary point is not well-defined.
0x8166 | 33126 | FunctionBlock | Invalid parameter for GapControlModeInvalid parameter for GapControlMode, most likely in combination with the group parameter GapControlDirection
0x8167 | 33127 | External | Group got unsupported Axis Event (e.g. State Change)Group got unsupported Axis Event (e.g. State Change e.g. triggered by a Single Axis Reset)
0x8f76 - 0x8ff9 | 36726 - 36857 | Internal | Unexpected Internal Error
0x8ffb - 0x8ffe | 36859 - 36862 | Internal | Unexpected Internal Error