Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Einführung

Das Protokoll Fidelio FIAS - (Fidelio Interface and Application Specification) hat eine weltweit führende Position für Hotelmanagementsoftware bezogen und nimmt eine immer größere Rolle für Anwendungen in größeren Hotels ein. Da der Anspruch an vernetzte Systeme und an Raumautomatisierungen wächst, ermöglicht der TwinCAT FIAS Server mit einer direkten FIAS-Schnittstelle die problemlose Kommunikation zwischen Hotelmanagementsystem und SPS.
Der TwinCAT FIAS Server ist ein Softwarepaket für den Zugriff auf Systeme nach dem FIAS-Standard (Fidelio Interface Applikation Spezifikation).
Er ermöglicht die Kommunikation zwischen einer TwinCAT SPS und einem System, das über eine Kommunikationsschnittstelle nach dem FIAS-Standard verfügt.
Die Kommunikation erfolgt hierbei über TCP/IP.

Die Verbindung von Hotelmanagementsoftware und Automatisierungssystem hilft, die Effizienz der Anlage zu verbessern. So kann das Automatisierungssystem automatisch auf den Belegungsplan der Zimmer vom Hotelmanagementsystem reagieren. Bei einem nicht belegten Zimmer passt sich die Klimaregelung entsprechend an, oder die Beschattung wird bei starker Sonneneinstrahlung im Sommer automatisch aktiviert.
Neben der Möglichkeit, den Energieverbrauch zu optimieren, kann auch der Kundenservice verbessert werden. Benachrichtigungen zwischen Kunden und der Hotelmanagementsoftware können zusätzlich für kundenorientierte Dienstleistungen mit dem TwinCAT FIAS Server realisiert werden.


Hardwareanforderungen

Der TwinCAT FIAS Server ist auf allen PC-Steuerungen, die kompatibel zu TwinCAT sind, einsetzbar (ausgenommen ist der CX9000).

Zur Installation des TwinCAT FIAS Server auf einer CX x86- oder CX ARM-Prozessor basierenden Hardware-Plattform wird folgendes benötigt / vorausgesetzt.

  • TwinCAT PLC Runtime
  • Microsoft .NET Framework \ Compact .NET Framework.
  • Ethernetschnittstelle

Bitte informieren Sie sich im Beckhoff Information System, welche Hardware mit welchem Image diese Anforderungen erfüllen.


Benutzeranforderungen

Für den Nutzer dieses ADS Servers / dieser Bibliothek werden folgende Grundkenntnisse vorausgesetzt:

  • Umgang mit dem TwinCAT PLC Control
  • Umgang mit dem TwinCAT System Manager
  • PC und Netzwerkkenntnisse
  • Einschlägige Sicherheitsvorschriften der technischen Gebäudeausrüstung


Installation unter Windows CE (WEC)

Übertragen der Installation auf ein Windows CE Gerät

Wurde der TwinCAT FIAS Server erfolgreich auf einem Windows Standard Installiert, befinden sich im Ordner "..\TwinCAT\CE\FIAS Server" zwei Unterordner.

  • \ARMV4I
    • Dieser Ordner beinhaltet die CE-Installation:
      TcFIASServerCe.ARMV4I.CAB       für ARMV4 CPUs (z.B. CX900x)
  • \I586
    • Dieser Ordner beinhaltet die CE-Installation:
      TcFIASServerCe.I586.CAB       für X86 CPUs (z.B. CX10xx)

Übertragen Sie die Datei "TcFIASServerCe.ARMV4I.CAB" oder "TcFIASServerCe.I586.CAB" auf das Windows CE Gerät. Das kann über

  • einen frei gegebenem Ordner (Public folder)
  • FTP
  • ActiveSync
  • Compact Flash (CF) Adapter

erfolgen.

Installation auf dem Windows CE Gerät

Die Installation kann mit einem Doppelklick auf die CAB-Datei ausgeführt werden. Bestätigen Sie das vorgewählte (default) Verzeichnis "\hard disk\System\TC-FIAS-Server" mit "OK".

Nach der Installation wird die CAB-Datei automatisch gelöscht. Starten Sie das Gerät nach Beendigung der Installation neu.


Installation unter Windows Embedded Standrad (WES)

Starten der Installation

Starten Sie die Installation und folgen Sie den Anweisungen in den Dialogen.

Nach der Installation.

Ist die Installation beendet, befinden sich in Ihrem TwinCAT Ordner zwei neue Verzeichnisse "..\TwinCAT\CE\FIAS Server" und "..\TwinCAT\FIAS Server".
Im Verzeichnis "..\TwinCAT\CE\FIAS Server Server" finden Sie die Installationsdateien (.CAB) für die verschiedenen Windows CE Plattformen: ARM und X86.


Konfiguration

Der TwinCAT FIAS Server wird mittels einer Textdatei im XML-Format (TcFIASServer.cfg) konfiguriert. Die Datei wird mit der Installation mitgeliefert und befindet sich nach Beendigung der Installation im Installationsverzeichnis. Die Datei darf weder verschoben noch umbenannt werden. Die nachfolgende Tabelle beschreibt die einzelnen Parameter, die zur Konfiguration der Verbindungen zu einem Hotelmanagementserver benötigt werden. Des Weiteren wird beschrieben, in welchen Abhängigkeiten eine Backup-Datei erstellt wird und wie sie im laufenden Betrieb aktualisiert wird.

TcFIASServer.cfg (Beispiel)

<?xml version="1.0" encoding="utf-8" ?>
<TcFiasServerConfig>
   <Client Name="FIAS1" Port="5001" Ip="192.168.0.20" ResyncCycleTime="120" SaveCycleTime="120" SaveType="2" LinkAliveCycleTime="5" />
</TcFiasServerConfig>

Hinweis
Wenn Sie zu mehr als nur einem Hotelmanagementserver eine Verbindung aufbauen wollen, müssen Sie eine weitere FiasClient Konfiguration in der TcFIASServer.cfg Datei eintragen. Siehe folgendes Beispiel.

<?xml version="1.0" encoding="utf-8" ?>
<TcFiasServerConfig>
   <Client Name="FIAS1" Port="5001" Ip="192.168.0.21" ResyncCycleTime="120" SaveCycleTime="120" SaveType="2" LinkAliveCycleTime="5" />
   <Client Name="FIAS2" Port="5001" Ip="192.168.0.22" ResyncCycleTime="120" SaveCycleTime="120" SaveType="2" LinkAliveCycleTime="5" />
   <Client Name="FIAS3" Port="5001" Ip="192.168.0.23" ResyncCycleTime="120" SaveCycleTime="120" SaveType="2" LinkAliveCycleTime="5" />
</TcFiasServerConfig>

Beschreibung der Parameter

Hinweis
Kann ein Parameter nicht eingelesen werden oder liegt dieser außerhalb des erlaubten Bereichs, so liefert jeder Aufruf eines SPS-Bausteins aus der TcFIAS.Lib einen spezifischen Fehler zurück. Dies geschieht solange, bis der Fehler behoben wurde.
Parameter Beschreibung
Name

Name des Hotelmanagementservers.

Hinweis
Der hier angegebene Name darf nicht mehrmals in der Konfiguration verwendet werden.
Port

Der TCP Port des Hotelmanagementservers.

Hinweis
Der TCP Port ist variabel und wird vom Integrator des Fidelio Managementservers vorgegeben.
Ip

IP-Adresse des Hotelmanagementservers.

Hinweis
Die IP-Adresse ist variabel und wird vom Integrator des Fidelio Managementservers vorgegeben.
ResyncCycleTime

Gibt die Zeitspanne zwischen einem Resync der Datenbank an. Der TwinCAT FIAS Server vergleicht anhand eines Zeitstempels in der Backup-Datei ob die Zeitspanne zum vorherigen Resync überschritten wurde. Wurde die ResyncCycleTime überschritten, wird beim nächsten Verbindungsaufbau zum Managementserver ein Datenbank Resync durchlaufen.
Nach einem erfolgreichen Resync der Datenbank, werden die empfangenen Daten immer in die Backup-Datei geschrieben. Min-Wert ist 120 min und Max-Wert ist 65535 min.

Hinweis
Wird ResyncCycleTime auf einen ungültigen Wert oder einen Wert außerhalb des Wertebereichs gesetzt, so wird automatisch der Defaultwert von 120 min verwendet.
SaveType Der SaveType gibt an, in welchen Fällen die Backup-Datei beschrieben werden soll.
Parameter | Beschreibung
1 | Bei Veränderung.
2 | Im zeitlichen Intervall.

Hinweis
Wird SaveType auf einen ungültigen Wert, so wird automatisch der Defaultwert 2 verwendet.
SaveCycleTime

Gibt die Zeitspanne zwischen dem Intervall zum Beschreiben der Backup-Datei an. Die SaveCycleTime wird in Minuten erwartet. Min-Wert ist 30 min und Max-Wert ist 65535 min.

Hinweis
Ein kleiner Wert bedeutet, dass die Backup-Datei oft abgespeichert und somit häufiger auf den Massenspeicher des Controllers zugegriffen wird. Wählen Sie daher den Parameter so, dass die Anzahl der Zugriffe auf die Backup-Datei möglichst gering sind.

Wird SaveCycleTime auf einen ungültigen Wert oder einen Wert außerhalb des Wertebereichs gesetzt, so wird automatisch der Defaultwert von 30 min verwendet.
LinkAliveCycleTime

Gibt die Zeitspanne zwischen dem Intervall zum Senden eines Keep-Alive-Telegrams. Die LinkAliveCycleTime wird in Minuten erwartet. Min-Wert ist 5 min und Max-Wert ist 30 min.

Hinweis
Wird LinkAliveCycleTime auf einen ungültigen Wert oder einen Wert außerhalb des Wertebereichs gesetzt, so wird automatisch der Defaultwert von 5 min verwendet.


Funktionsbausteine - Übersicht

TS8035 | TwinCAT FIAS Server

Funktionsbausteine Übersicht

Name | Funktion
FB_FIASGuestDataRead | Dieser Funktionsbaustein dient zum Auslesen von Gastdaten.
FB_FIASRoomDataRead | Dieser Funktionsbaustein dient zum Auslesen von Raumdaten.
FB_FIASRoomDataWriteRoomStatus | Dieser Funktionsbaustein dient zum Schreiben vom Raumstatus.
FB_FIASGetClientConnectionState | Dieser Funktionsbaustein dient zum Auslesen des Verbindungsstatus vom TwinCAT FIAS Server zum Hotelmanagementserver.
FB_FIASGetDeviceInfo | Dieser Funktionsbaustein dient zum Auslesen des Namens und der Version vom TwinCAT FIAS Server.


FB_FIASGuestDataRead

Der Baustein liest die Gastdaten zu einer Reservierungsnummer aus.

Beispiele

Download Demo Projekt

VAR_INPUT

sNetId                  : T_AmsNetId;
sFIASServerName         : STRING;
dwReservationNumber     : DWORD;
bExecute                : BOOL;
tTimeout                : TIME := t#5s;

sNetId: Ist ein String, der die AMS Net Id des Zielgerätes enthält, an das der Befehl gerichtet wird.

sFIASServerName: Ist ein String, der den Namen des Hotelmanagementservers enthält, an den der TcFIASServer die FIAS- Befehle weiterleitet. Groß\Kleinschreibung wird nicht beachtet.

dwReservationNumber: Ist ein Dword, der die Reservierungsnummer enthält.

bExecute: Durch eine steigende Flanke an diesem Eingang wird der Befehl ausgelöst.

tTimeout: Gibt die Zeit bis zum Abbruch der Funktion an.

VAR_OUTPUT

bBusy                   : BOOL;
bError                  : BOOL;
udiErrorId              : UDINT;

bBusy: Dieser Ausgang bleibt solange auf TRUE, bis der Baustein eine Befehlsanforderung ausgeführt hat, längstens aber für die Dauer, bis zu der am tTimeout-Eingang angelegten Zeit. Während bBusy = TRUE ist, wird an den Eingängen kein neuer Befehl angenommen.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in udiErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

udiErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt.

VAR_IN_OUT

stGuestData             : ST_FIASGuestData;

stGuestData: Beinhaltet die angeforderten Gastdaten zu der Reservierungsnummer.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 | PC/CX | TcFIAS-Bibliothek ab V1.0.0


FB_FIASRoomDataRead

Der Baustein liest die Raumdaten zu einer Raumnummer aus.

Beispiele

Download Demo Projekt

VAR_INPUT

sNetId                  : T_AmsNetId;
sFIASServerName         : STRING;
sRoomNumber             : STRING(8);
bExecute                : BOOL;
tTimeout                : TIME := t#5s;

sNetId: Ist ein String, der die AMS Net Id des Zielgerätes enthält, an das der Befehl gerichtet wird.

sFIASServerName: Ist ein String, der den Namen des Hotelmanagementservers enthält, an den der TcFIASServer die FIAS- Befehle weiterleitet. Groß/Kleinschreibung wird nicht beachtet.

sRoomNumber: Ist ein String mit max. 8 alphanumerischen Zeichen, der die Raumnummer enthält.

bExecute: Durch eine steigende Flanke an diesem Eingang wird der Befehl ausgelöst.

tTimeout: Gibt die Zeit bis zum Abbruch der Funktion an.

VAR_OUTPUT

bBusy                   : BOOL;
bError                  : BOOL;
udiErrorId              : UDINT;
bRoomDataExist          : BOOL;

bBusy: Dieser Ausgang bleibt solange auf TRUE, bis der Baustein eine Befehlsanforderung ausgeführt hat, längstens aber für die Dauer, bis zu der am tTimeout-Eingang angelegten Zeit. Während bBusy = TRUE ist, wird an den Eingängen kein neuer Befehl angenommen.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in udiErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

udiErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt.

bRoomDataExist: Hat der TwinCAT FIAS Server Raumdaten zur angegebenen Raumnummer vom Hotel Managementserver empfangen und kann diese in die SPS weiterleiten, so wird der Ausgang auf TRUE geschaltet. Andernfalls auf FALSE.

VAR_IN_OUT

stRoomData              : ST_FIASRoomData;

stRoomData: Beinhaltet die angeforderten Raumdaten zu der Raumnummer.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 | PC/CX | TcFIAS-Bibliothek ab V1.0.0


FB_FIASRoomDataWriteRoomStatus

Der Baustein sendet den Raumstatus an den Hotelmanagementserver.

Beispiele

Download Demo Projekt

VAR_INPUT

sNetId                  : T_AmsNetId;
sFIASServerName         : STRING;
sRoomNumber             : STRING(8);
iRoomStatus             : INT;
bExecute                : BOOL;
tTimeout                : TIME := t#5s;

sNetId: Ist ein String, der die AMS Net Id des Zielgerätes enthält, an das der Befehl gerichtet wird.

sFIASServerName: Ist ein String, der den Namen des Hotelmanagementservers enthält, an den der TcFIASServer die FIAS- Befehle weiterleitet. Groß/Kleinschreibung wird nicht beachtet.

sRoomNumber: Ist ein String mit max. 8 alphanumerischen Zeichen, der die Raumnummer enthält.

iRoomStatus: Ist ein Int der den Raumstatus enthält.

bExecute: Durch eine steigende Flanke an diesem Eingang wird der Befehl ausgelöst.

tTimeout: Gibt die Zeit bis zum Abbruch der Funktion an.

VAR_OUTPUT

bBusy                   : BOOL;
bError                  : BOOL;
udiErrorId              : UDINT;

bBusy: Dieser Ausgang bleibt solange auf TRUE, bis der Baustein eine Befehlsanforderung ausgeführt hat, längstens aber für die Dauer, bis zu der am tTimeout-Eingang angelegten Zeit. Während bBusy = TRUE ist, wird an den Eingängen kein neuer Befehl angenommen.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in udiErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

udiErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 | PC/CX | TcFIAS-Bibliothek ab V1.0.0


FB_FIASGetClientConnectionState

Der Baustein liest den Status einer Verbindung zu einem Hotelmanagementserver aus.

Beispiele

Download Demo Projekt

VAR_INPUT

sNetId                   : T_AmsNetId;
sFIASServerName          : STRING(80);
bExecute                 : BOOL;
tTimeout                 : TIME := t#5s;

sNetId: Ist ein String, der die AMS Net Id des Zielgerätes enthält, an das der Befehl gerichtet wird.

sFIASServerName: Ist ein String, der den Namen des Hotelmanagementservers enthält, an den der TcFIAS Server die FIAS- Befehle weiterleitet. Groß-\Kleinschreibung wird nicht beachtet.

bExecute: Durch eine steigende Flanke an diesem Eingang wird der Befehl ausgelöst.

tTimeout: Gibt die Zeit bis zum Abbruch der Funktion an.

VAR_OUTPUT

bBusy                    : BOOL;
bError                   : BOOL;
udiErrorId               : UDINT;
eConnectionState         : E_FIASClientConnectionState;

bBusy: Dieser Ausgang bleibt solange auf TRUE, bis der Baustein eine Befehlsanforderung ausgeführt hat, längstens aber für die Dauer, bis zu der am tTimeout-Eingang angelegten Zeit. Während bBusy = TRUE ist, wird an den Eingängen kein neuer Befehl angenommen.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in udiErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

udiErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt.

eConnectionState: Dieser Ausgang wird auf eConnected gesetzt, sobald die Verbindung zum Hotelmanagementserver besteht. Besteht keine Verbindung wird der Ausgang auf eDisconnected gesetzt.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 | PC/CX | TcFIAS-Bibliothek ab V1.0.0


FB_FIASGetDeviceInfo

Der Baustein liest den Namen und die Versionsnummer des TwinCAT FIAS Servers aus.

Beispiele

Download Demo Projekt

VAR_INPUT

sNetId                  : T_AmsNetId;
bExecute                : BOOL;
tTimeout                : TIME := t#5s;

sNetId: Ist ein String, der die AMS Net Id des Zielgerätes enthält, an das der Befehl gerichtet wird.

bExecute: Durch eine steigende Flanke an diesem Eingang wird der Befehl ausgelöst.

tTimeout: Gibt die Zeit bis zum Abbruch der Funktion an.

VAR_OUTPUT

bBusy                   : BOOL;
bError                  : BOOL;
udiErrorId              : UDINT;
udiDeviceVersion        : UDINT;
sDeviceName             : STRING;

bBusy: Dieser Ausgang bleibt solange auf TRUE, bis der Baustein eine Befehlsanforderung ausgeführt hat, längstens aber für die Dauer, bis zu der am tTimeout-Eingang angelegten Zeit. Während bBusy = TRUE ist, wird an den Eingängen kein neuer Befehl angenommen.

bError: Dieser Ausgang wird auf TRUE geschaltet, wenn bei der Ausführung eines Befehls ein Fehler aufgetreten ist. Der befehlsspezifische Fehlercode ist in udiErrorId enthalten. Wird durch das Ausführen eines Befehls an den Eingängen auf FALSE zurückgesetzt.

udiErrorId: Enthält den befehlsspezifischen Fehlercode des zuletzt ausgeführten Befehls. Wird durch das Ausführen eines Befehls an den Eingängen auf 0 zurückgesetzt.

udiDeviceVersion: Version des TwinCAT FIAS Servers.

sDeviceName: Name des TwinCAT FIAS Servers.

Entwicklungsumgebung | Zielsystem | erforderliche Bibliotheken
TwinCAT 2.11 R3/x64 | PC/CX | TcFIAS-Bibliothek ab V1.0.0


Enum / Strukturen - Übersicht

Struktur
ST_FIASGuestData
ST_FIASRoomData
Enum
E_FIASGuestLanguage
E_FIASClientConnectionState


Enum / Strukturen

TS8035 | TwinCAT FIAS Server

ST_FIASGuestData

TYPE ST_FIASGuestData :
STRUCT
   dwReservationNumber    : DWORD;
   dtDateTime             : DATE_AND_TIME;
   dGuestArrivalDate      : DATE;
   dGuestDepartureDate    : DATE;
   sRoomNumber            : STRING(8);
   sGuestFirstName        : STRING(20);
   sGuestName             : STRING(40);
   sGuestTitle            : STRING(20);
   eGuestLanguage         : E_FIASGuestLanguage := -1;
   sUserDefinableField00  : STRING(40);
   sUserDefinableField01  : STRING(40);
   sUserDefinableField02  : STRING(40);
   sUserDefinableField03  : STRING(40);
   sUserDefinableField04  : STRING(40);
   sUserDefinableField05  : STRING(40);
   sUserDefinableField06  : STRING(40);
   sUserDefinableField07  : STRING(40);
   sUserDefinableField08  : STRING(40);
   sUserDefinableField09  : STRING(40);
   bShareFlag             : BOOL;
END_STRUCT
END_TYPE

ST_FIASRoomData

TYPE ST_FIASRoomData :
STRUCT
   arrReservationNumbers  : ARRAY[1..10] OF DWORD;
   sClassOfService        : STRING(10);
END_STRUCT
END_TYPE

E_FIASGuestLanguage

TYPE E_FIASGuestLanguage :
(
   eFIASGuestLanguagesUndefined := -1,
   eFIASEnglishAmerican := 1,
   eFIASFrench,
   eFIASGerman,
   eFIASItalian,
   eFIASJapanese,
   eFIASSpanish
);
END_TYPE

E_FIASClientConnectionState

TYPE E_FIASClientConnectionState :
(
   eFIASClientUnknown := 0,
   eFIASClientInitialized,
   eFIASClientInitializing,
   eFIASClientConnected,
   eFIASClientConnecting,
   eFIASClientDisconnected,
   eFIASClientDisconnecting
);
END_TYPE


Fehlercodes

Hex Code | Dec Code | Beschreibung
0x8501 | 34049 | Eingabeparameter Fehler an einem PLC Funktionsbaustein.
0x8502 | 34050 | Die Konfigurationsdatei TcFIASServer.cfg wurde nicht gefunden. Siehe Konfiguration
0x8503 | 34051 | Interner Server Fehler beim Verarbeiten der TcFIASServer Konfigurationsdatei TcFIASServer.cfg.
0x8504 | 34052 | Fehler in der Konfigurationsdatei TcFIASServer.cfg. Der XML-Knoten "Client" wurde nicht gefunden. Siehe Konfiguration
0x8505 | 34053 | Fehler in der Konfigurationsdatei TcFIASServer.cfg. Das XML-Attribute "Ip" wurde nicht im Client XML-Knoten gefunden oder beinhaltet einen fehlerhaften Wert. Siehe Konfiguration
0x8506 | 34054 | Fehler in der Konfigurationsdatei TcFIASServer.cfg. Das XML-Attribute "Port" wurde nicht im Client XML-Knoten gefunden oder beinhaltet einen fehlerhaften Wert. Siehe Konfiguration
0x8507 | 34055 | Fehler in der Konfigurationsdatei TcFIASServer.cfg. Das XML-Attribute "Name" wurde nicht im Client XML-Knoten gefunden oder beinhaltet einen fehlerhaften Wert. Siehe Konfiguration
0x8508 | 34056 | Fehler in der Konfigurationsdatei TcFIASServer.cfg. Das XML-Attribute "SaveType" wurde nicht im Client XML-Knoten gefunden oder beinhaltet einen fehlerhaften Wert. Siehe Konfiguration
0x8509 | 34057 | Fehler in der Konfigurationsdatei TcFIASServer.cfg. Das XML-Attribute "SaveCycleTime" wurde nicht im Client XML-Knoten gefunden oder beinhaltet einen fehlerhaften Wert. Siehe Konfiguration
0x850A | 34058 | Fehler in der Konfigurationsdatei TcFIASServer.cfg. Das XML-Attribute "ResyncCycleTime" wurde nicht im Client XML-Knoten gefunden oder beinhaltet einen fehlerhaften Wert. Siehe Konfiguration
0x850B | 34059 | Fehler beim Auslesen von einem Client Status. Der angegebene Client wurde nicht gefunden.
0x850C | 34060 | Interner Server Fehler beim Auslesen von einem Client Status.
0x850D | 34061 | Fehler beim Auslesen von Raumdaten. Der angegebene Raum wurde nicht gefunden oder es liegt keine Raum Information zum auslesen bereit.
0x850E | 34062 | Interner Server Fehler beim Auslesen von Raumdaten.
0x850F | 34063 | Fehler beim Auslesen von Gastdaten, Gastdaten wurden nicht gefunden.
0x8510 | 34064 | Interner Server Fehler beim Auslesen von Gastdaten.
0x8511 | 34065 | Fehler in der Konfigurationsdatei TcFIASServer.cfg. Das XML-Attribute "LinkAliveCycleTime" wurde nicht im Client XML-Knoten gefunden oder beinhaltet einen fehlerhaften Wert. Siehe Konfiguration
0x8512 | 34066 | Interner Server Fehler beim Schreiben von Raumdaten.
0x8513 | 34067 | Interner Server Fehler beim Schreiben von Raumdaten (Raumstatus).


Programmierbeispiele

Download Demo Projekt